Welcome to IceLib

[image]

IceLib Technical Reference
Welcome to IceLib
Send Feedback

The Interaction Center Extension Library (IceLib for short) is a programming API that allows developers to create custom applications that leverage the Interaction Center to solve business problems. IceLib is for developers who use modern .Net languages, such as C# or VB.Net.

IceLib provides a clean architecture that applications can use to manage sessions with the Interaction Center (IC) server. IceLib provides session creation and login functions that allow applications to connect with one or more IC servers using the login options that are available in Interaction Client .Net Edition (e.g. user, password, station, remote number, remote station, persistent, audio enabled, etc.).

Welcome

IceLib interfaces with SessionManager, the IC subsystem that brokers connections between client applications and a given IC Server. Custom IceLib applications fully leverage SessionManager, just like internally developed IC applications. For example, Interaction Desktop, Interaction Client Web Edition, Interaction Fax, Interaction VoiceMail, Interaction Client .Net Edition, and Interaction Client Outlook Edition all use IceLib and take advantage of its SessionManager capability. IceLib is feature-license based, not per-seat or per-session. Client sessions require client licenses.

Generally speaking, IceLib provides the means to work with Interactions, Directories, People, Interaction Tracker, and Unified Messaging. It manages connections with the IC server, specifies authentication and station settings, watches for connection state-change events, and performs actions relative to the connected Session user.

What's New in IceLib

What's New in IceLib outlines the differences with each IceLib release.

IceLib API

IceLib follows the direction that Microsoft has taken with public APIs. It conforms with Microsoft's design guidance and best practices for public APIs and framework development. It utilizes familiar style and naming conventions and it is based on Microsoft's .Net 2.0 technology framework.

For example, IceLib is object-based, rather than interface-based. This reflects the direction that Microsoft and the .NET technologies have taken to go beyond COM, in accordance with the .NET Framework Design Guidelines.

IceLib conforms with the Common Language Specification (CLS), a standard that defines naming restrictions, data types, and rules to which assemblies must conform if they are to be used across programming languages. This means that IceLib is compatible with C#, VB.Net, and all other .Net languages.

IceLib is a strongly typed API. Common attributes are accessible as properties, enumerations, or constants. IceLib supports generics, events, asynchronous patterns, and nullable types. Properties are used instead of public fields. This helps make the API future-proof, since changes can be made to a property get/set without affecting existing third-party application usage.

IceLib provides a consistent set of stable interfaces, that expose Interaction Client .Net Edition feature sets to third-party applications. It provides a stable foundation for application development. IceLib's internal consistency promotes intuitive use, and its adherence with .Net eases understanding, reduces ramp-up time, and speeds development.

Change notification is implemented using events that follow the common Object/EventArgs pattern. This allows multiple notification recipients to be registered. It also allows recipients granular control over which notifications they receive. Developers should name the custom delegate for an event "FooEventHandler". Foo does not have to match the name of the event if FooEventHandler is generally useful for multiple events in the system. FooEventHandler's first parameter should be "object sender" and the second parameter should either be "EventArgs e" (and set to EventArgs.Empty) if no arguments are needed, or if a custom FooEventArgs class that inherits from EventArgs (or CancelEventArgs).

Consistent API design promotes intuitive use by application developers. Further, it can reduce the number of bugs when correct usage patterns have previously been learned. The ease of use improvements gained through design consistency are sometimes termed "The Power of Sameness". This is beneficial to customers since it can reduce application development costs.

IceLib provides synchronous (blocking) and asynchronous (non-blocking) versions of most methods, especially those methods that make a server call. This convention allows the developer the convenience of choosing which programming model to use. It also allows him to switch back and forth between the two models where appropriate within the same application.

In IceLib, errors are reported via exceptions rather than by returning or querying error codes. Methods are designed to "fail fast", by evaluating parameters early and to throw meaningful argument exceptions. This helps developers to identify issues with code more quickly and easily.

Getting Started

The Getting Started section includes documentation on some key areas of the IceLib API, such as overview information and examples for common use cases. It can be challenging for a new developer to determine where to get started with the elements of a namespace. These topics are meant to "jump start" that effort, providing some important aspects to be aware of for a particular API area. Additionally, by providing focused example snippets around common tasks, these topics provide quicker understanding of what's possible and how to make those possibilities into reality. Then, the more full-featured example applications extend the core concepts and API usages into the context of developing real applications that allow users to perform larger tasks.

General Concepts

The Concepts section includes documentation on some fundamental concepts which are common to many different areas of the IceLib API. Some concepts are simple, while others contain nuances that can trip up developers. These topics strive to clarify these general points, providing conceptual context for utilizing elements throughout the IceLib API.

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


What's New in IceLib

[image]

IceLib Technical Reference
What's New in IceLib
Send Feedback

This section includes documentation on the features that have been added, improved, and changed in each release of IceLib.

What's New in 2021 R2
Details the changes in the 2021 R2 IceLib release compared to the 2021 R1 IceLib release.

What's New in 2021 R1
Details the changes in the 2021 R1 IceLib release compared to the 2020 R4 IceLib release.

What's New in 2020 R4
Details the changes in the 2020 R4 IceLib release compared to the 2020 R3 IceLib release.

What's New in 2020 R3
Details the changes in the 2020 R3 IceLib release compared to the 2020 R2 IceLib release.

What's New in 2020 R2
Details the changes in the 2020 R2 IceLib release compared to the 2020 R1 IceLib release.

What's New in 2020 R1
Details the changes in the 2020 R1 IceLib release compared to the 2019 R4 IceLib release.

What's New in 2019 R4
Details the changes in the 2019 R4 IceLib release compared to the 2019 R3 IceLib release.

What's New in 2019 R3
Details the changes in the 2019 R3 IceLib release compared to the 2019 R2 IceLib release.

What's New in 2019 R2
Details the changes in the 2019 R2 IceLib release compared to the 2019 R1 IceLib release.

What's New in 2019 R1
Details the changes in the 2019 R1 IceLib release compared to the 2018 R5 IceLib release.

What's New in 2018 R5
Details the changes in the 2018 R5 IceLib release compared to the 2018 R4 IceLib release.

What's New in 2018 R4
Details the changes in the 2018 R4 IceLib release compared to the 2018 R3 IceLib release.

What's New in 2018 R3
Details the changes in the 2018 R3 IceLib release compared to the 2018 R2 IceLib release.

What's New in 2018 R2
Details the changes in the 2018 R2 IceLib release compared to the 2018 R1 IceLib release.

What's New in 2018 R1
Details the changes in the 2018 R1 IceLib release compared to the 2017 R4 IceLib release.

What's New in 2017 R4
Details the changes in the 2017 R4 IceLib release compared to the 2017 R3 IceLib release.

What's New in 2017 R3
Details the changes in the 2017 R3 IceLib release compared to the 2017 R2 IceLib release.

What's New in 2017 R2
Details the changes in the 2017 R2 IceLib release compared to the 2017 R1 IceLib release.

What's New in 2017 R1
Details the changes in the 2017 R1 IceLib release compared to the 2016 R4 IceLib release.

What's New in 2016 R4
Details the changes in the 2016 R4 IceLib release compared to the 2016 R3 IceLib release.

What's New in 2016 R3
Details the changes in the 2016 R3 IceLib release compared to the 2016 R2 IceLib release.

What's New in 2016 R2
Details the changes in the 2016 R2 IceLib release compared to the 2016 R1 IceLib release.

What's New in 2016 R1
Details the changes in the 2016 R1 IceLib release compared to the 2015 R4 IceLib release.

What's New in 2015 R4
Details the changes in the 2015 R4 IceLib release compared to the 2015 R3 IceLib release.

What's New in 2015 R3
Details the changes in the 2015 R3 IceLib release compared to the 2015 R2 IceLib release.

What's New in 2015 R2
Details the changes in the 2015 R2 IceLib release compared to the 2015 R1 IceLib release.

What's New in 2015 R1
Details the changes in the 2015 R1 IceLib release compared to the 4.0 SU 6 IceLib release.

What's New in 4.0 SU 6
Details the changes in the 4.0 SU 6 IceLib release compared to the 4.0 SU 5 IceLib release.

What's New in 4.0 SU 5
Details the changes in the 4.0 SU 5 IceLib release compared to the 4.0 SU 4 IceLib release.

What's New in 4.0 SU 4
Details the changes in the 4.0 SU 4 IceLib release compared to the 4.0 SU 3 IceLib release.

What's New in 4.0 SU 3
Details the changes in the 4.0 SU 3 IceLib release compared to the 4.0 SU 2 IceLib release.

What's New in 4.0 SU 2
Details the changes in the 4.0 SU 2 IceLib release compared to the 4.0 SU 1 IceLib release.

What's New in 4.0 SU 1
Details the changes in the 4.0 SU 1 IceLib release compared to the 4.0 GA IceLib release.

What's New in 4.0 GA
Details the changes in the initial 4.0 GA IceLib release compared to what was in 3.0.


What's New in 2021 R2

[image]

IceLib Technical Reference
What's New in 2021 R2
Send Feedback

There are no API changes in the IceLib 2021R2 release.


What's New in 2021 R1

[image]

IceLib Technical Reference
What's New in 2021 R1
Send Feedback

There are no API changes in the IceLib 2021 R1 release.


What's New in 2020 R4

[image]

IceLib Technical Reference
What's New in 2020 R4
Send Feedback

IceLib 2020 R4 includes some documentation improvements.

Jump to a section:

  • Documentation

Documentation

The Statistics Catalog documentation now includes Interaction Dialer statistics. The catalog documentation is now sorted, making it easier to find statistics.


What's New in 2020 R3

[image]

IceLib Technical Reference
What's New in 2020 R3
Send Feedback

There are no API changes in the IceLib 2020 R3 release.


What's New in 2020 R2

[image]

IceLib Technical Reference
What's New in 2020 R2
Send Feedback

There are no API changes in the IceLib 2020 R2 release.


What's New in 2020 R1

[image]

IceLib Technical Reference
What's New in 2020 R1
Send Feedback

There are no API changes in the IceLib 2020 R1 release.


What's New in 2019 R4

[image]

IceLib Technical Reference
What's New in 2019 R4
Send Feedback

There are no API changes in the IceLib 2019 R4 release.


What's New in 2019 R3

[image]

IceLib Technical Reference
What's New in 2019 R3
Send Feedback

IceLib 2019 R5 includes a number of features fixes. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Configuration

Configuration

Caution
The DisplayName and Id properties of StreamingAudioMonitorProfileConfiguration had their Id values updated.


What's New in 2019 R2

[image]

IceLib Technical Reference
What's New in 2019 R2
Send Feedback

There are no API changes in the IceLib 2019 R2 release.


What's New in 2019 R1

[image]

IceLib Technical Reference
What's New in 2019 R1
Send Feedback

There are no API changes in the IceLib 2019 R1 release.


What's New in 2018 R5

[image]

IceLib Technical Reference
What's New in 2018 R5
Send Feedback

IceLib 2018 R5 includes a number of features fixes. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.People.UserStatus

ININ.IceLib.People.UserStatus

Starting in 2018R5 LoggedIn will return true for stationless session logins.


What's New in 2018 R4

[image]

IceLib Technical Reference
What's New in 2018 R4
Send Feedback

There are no API changes in the IceLib 2018 R4 release.


What's New in 2018 R3

[image]

IceLib Technical Reference
What's New in 2018 R3
Send Feedback

There are no API changes in the IceLib 2018 R3 release.


What's New in 2018 R2

[image]

IceLib Technical Reference
What's New in 2018 R2
Send Feedback

IceLib 2018 R2 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Connection
  • Interactions

Connection

A new SensitiveDataContext property was added to support PureConnect sensitive data tracing settings and change events. This is used by IceLib and application code to determine when the SuppressedValueIndicator should be traced in place of sensitive data. Also see the new SensitiveAttributeDataContext property.

Interactions

A new SensitiveAttributeDataContext property was added to support PureConnect sensitive interaction attribute tracing settings and change events. This is used by IceLib and applicatoin code to identify which interaction attributes should have tracing of their attribute values replaced by the SuppressedValueIndicator. Also see the new SensitiveDataContext property.


What's New in 2018 R1

[image]

IceLib Technical Reference
What's New in 2018 R1
Send Feedback

IceLib 2018 R1 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Configuration

Configuration

A new WebServicesConfiguration property was added to support configuring the WebServicesConfiguration administrative right.


What's New in 2017 R4

[image]

IceLib Technical Reference
What's New in 2017 R4
Send Feedback

IceLib 2017 R4 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Configuration
  • People

Configuration

A new DataExtractorJobAdmin property was added to support configuring the DataExtractorJobAdmin security right for RoleConfiguration, UserConfiguration, and WorkgroupConfiguration objects.

Support for configuring Salesforce with IceLib has been removed, as a result the CtiAttributeMapConfiguration, CtiConfiguration, and CtiQueryChildrenSettings objects were deprecated.

People

The InteractionFiles, InteractionMessages, and InteractionUrls properties were deprecated in favor of using the ServerDocuments property.


What's New in 2017 R3

[image]

IceLib Technical Reference
What's New in 2017 R3
Send Feedback

IceLib 2017 R3 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Configuration
  • Connection
  • Interactions
  • People
  • Reporting

Configuration

A new ForceUserLogout property was added to allow configuring RoleConfiguration, UserConfiguration, and WorkgroupConfiguration objects with the ability to force a user logout.

Connection

A new ForceUserLogout(String) method, as well as its associated ForceUserLogoutAsync(String, AsyncCompletedEventHandler, Object) method, was added. These methods provide the ability to force an IC User to be logged out of any IC-related application they are currently logged in to.

Interactions

A new HasEmailContent()()()() method was added to add a way for consumers to determine if the EmailInteraction has content.

People

A new AllowForceUserLogout, as well as the supporting AllowForceUserLogout field, was added to allowing configuring users with the ability to force a user logout.

Reporting

A new SiteIdFilter(ReportingManager, Int32) constructor was added to support filtering on all sites. A new SupportsAllSites property was added so that consumers can tell if the IC Server supports filters using all sites.


What's New in 2017 R2

[image]

IceLib Technical Reference
What's New in 2017 R2
Send Feedback

IceLib 2017 R2 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Interactions

Interactions

A new TransferToVoicemail enumeration value was added. When transferring an Interaction to voicemail with a specific target via TransferToVoicemail(String) or TransferToVoicemail(QueueId), this new capability should be checked instead of the Messaging capability. When transferring an Interaction to voicemail without specifying a target via Voicemail()()()(), the Messaging capability should continue to be used.


What's New in 2017 R1

[image]

IceLib Technical Reference
What's New in 2017 R1
Send Feedback

IceLib 2017 R1 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Configuration
  • Interactions
  • ProcessAutomation
  • QualityManagement

Configuration

The LicenseAllocationConfigurationList object was enhanced to allow querying for different types of licenses. A new SetLicenseAppliesToForQuery(LicenseAppliesToType) method was added to allow specifying the type of licenses that will come back from a query request.

The UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object was enchanced with two new security rights: AllowAgentComplianceOverride and ModifyBaseScriptAgentComplianceOverride.

The ReportingParameterDataType enumeration was enhanced to include new WhereClauseString and OrderClauseString items to provide better support for report querying.

Interactions

Breaking changes were made to the AssistanceList and AssistanceItem objects. Both objects had events that were incorrectly defined as fields. This caused applications written in Visual Basic to not be able to hook into those events. The following events were affects:

  • ItemAdded
  • ItemRemoved
  • ItemStateChanged
  • ItemChanged
  • MessageAdded
  • ParticipantAdded
  • ParticipantChanged
  • ParticipantRemoved
  • StateChanged

ProcessAutomation

Breaking changes were made to the ProcessDefinitionList and ProcessManager objects. Both objects had events that were incorrectly defined as fields. This caused applications written in Visual Basic to not be able to hook into those events. The following events were affects:

  • ProcessDefinitionChanged
  • ProcessDefinitionsListChanged
  • LaunchableProcessesChanged

QualityManagement

New methods were added to be able to retrieve HTTPS export Uri's: GetSecureExportUri(String, RecordingMediaType, String, Int32) and GetSecureExportUriAsync(String, RecordingMediaType, String, Int32, EventHandler<(Of <<'(GetExportUriCompletedEventArgs>)>>), Object).


What's New in 2016 R4

[image]

IceLib Technical Reference
What's New in 2016 R4
Send Feedback

IceLib 2016 R4 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Connection
  • Configuration
  • Interactions
  • People

Connection

To support the new password policy enhacements, the PasswordPolicy class has been updated to support the following new properties: MinimumLowercaseCharacters, MinimumNumericCharacters, MinimumSpecialCharacters, MinimumUppercaseCharacters, and SpecialCharacters.

Configuration

A new MutuallyExclusiveValueValidator class was added to support a new validation error type. This validation error type is currently used when both AllowAcdCalls and IsForward are set to true, or when both AllowFollowUp and IsPersistent are set to true.

Interactions

All Interaction-derived classes have been enhanced to allow retreiving of watched attributes in a way that will not throw an NotCachedException if the attribute is not being watched (other exceptions will contine to be thrown). The following methods were added:

  • TryGetWatchedBooleanAttribute(String, Boolean%)
  • TryGetWatchedDateTimeAttribute(String, DateTime%)
  • TryGetWatchedIntegerAttribute(String, Int32%)
  • TryGetWatchedStringAttribute(String, String%)
  • TryGetWatchedStringsAttribute(String, ReadOnlyCollection<(Of <<'(String>)>>)%)

People

A new GetActivationList(String) method was added to allow retrieving of the the cached workgroup activations.


What's New in 2016 R3

[image]

IceLib Technical Reference
What's New in 2016 R3
Send Feedback

IceLib 2016 R3 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Configuration
  • Interactions
  • People
  • Quality Management

Configuration

New CanInitiateRecordingSnippet and ShowRecordingSnippetButton security rights have been added to support the recording snippet feature.

New SnipLineQueue, SnipStationQueue, SnipUserQueue, and SnipWorkgroupQueue access rights have been added to support the recording snippet feature.

A new EnableSnippetRecordings property was added to support the recording snippet feature.

A new ContactListRecordOwnershipControl security right was added for compliance purposes. This is to allow a Dialer campaign to take exclusive control of a contact list record, instead of sharing it with other campaigns.

A new ServerReportConfigurationConfigurationContainer (and the associated ServerReportConfigurationConfiguration) object was added to support configuring server reports.

Interactions

All Interaction-derived objects have been enhanced with new methods, properties, and events to support the recording snippet feature. The recording snippet feature allows interaction recordings to be taken, stored on the IC Server, and then be processed by recorder policies that have been configured.

  • The InitiateRecordingSnip(Boolean, Boolean) and InitiateRecordingSnipAsync(Boolean, Boolean, AsyncCompletedEventHandler, Object) methods were added to provide a way to create recording snippets.
  • The RecordingSnippetCreated event (and the associated RecordingSnippetCreatedEventArgs) was added to provide a way to be notified of when a recording snippet was created.
  • The HasSnippetRecording property was added to provide a way to determine if the associated interaction has recording snippets.
  • The RelatedSnippetRecordings property and the RelatedSnippetRecordings field were added to provide access to the collection of snippet recordings for the associated interaction. A RelatedSnippetRecording object was also added.

A new RecordingSnip enumeration value was added.

People

New CanShowRecordingSnipButton and CanSnipRecording properties (as well as the associated CanShowRecordingSnipButton and CanSnipRecording fields) have been added to support the recording snippet feature.

New SnipLineQueue, SnipStationQueue, SnipUserQueue, and SnipWorkgroupQueue properties (as well as the associated SnipLineQueue, SnipStationQueue, SnipUserQueue, and SnipWorkgroupQueue fields) have been added to support the recording snippet feature.

A new IsInitialized enumeration value was added to provide additional information for the WatchedObjectsChanged event.

A new FeatureUnavailable enumeration value was added to provide additional information for the return value of PerformLicenseOperation(IList<(Of <<'(LicenseRequest>)>>)).

Quality Management

New methods and supporting objects have been added to support the recording snippet feature. The ININ.IceLib.QualityManagement additions provide support for adding, modifying, and removing recording attributes, as well as adding and removing recording tags. Recording attributes are key/value pairs that can be added to recordings, while recording tags are simple string values that can be added to recordings. Recording attributes and tags can be used for various purposes; however, a typical usage scenario is to setup a recorder policy to set the storage location of a recording based on the value/existance of an attribute or tag. Both recording attributes, and recording tags can be seen in the Recorder view's playback dialog of IC Business Manager.

  • AddRecordingAttributes(String, IDictionary<(Of <<'(String, String>)>>)) (and the associated AddRecordingAttributesAsync(String, IDictionary<(Of <<'(String, String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object)) was added to provide a way to add attributes to a recording.
  • ModifyRecordingAttributes(String, IDictionary<(Of <<'(String, String>)>>)) (and the associated ModifyRecordingAttributesAsync(String, IDictionary<(Of <<'(String, String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object)) was added to provide a way to modify attributes of a recording.
  • QueryRecordingAttributes(String) (and the associated QueryRecordingAttributesAsync(String, EventHandler<(Of <<'(QueryRecordingAttributesCompletedEventArgs>)>>), Object)) was added to provide a way to retrieve the attributes of a recording.
  • RemoveRecordingAttributes(String, IEnumerable<(Of <<'(String>)>>)) (and the associated RemoveRecordingAttributesAsync(String, IEnumerable<(Of <<'(String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object)) was added to provide a way to remove attributes from a recording.
  • AddRecordingTags(String, IEnumerable<(Of <<'(String>)>>)) (and the associated AddRecordingTagsAsync(String, IEnumerable<(Of <<'(String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object)) was added to provide a way to add tags to a recording.
  • QueryRecordingTags(String) (and the associated QueryRecordingTagsAsync(String, EventHandler<(Of <<'(QueryRecordingTagsCompletedEventArgs>)>>), Object)) was added to provide a way to retrieve the tags of a recording.
  • RemoveRecordingTags(String, IEnumerable<(Of <<'(String>)>>)) (and the associated RemoveRecordingTagsAsync(String, IEnumerable<(Of <<'(String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object)) was added to provide a way to remove tags from a recording.


What's New in 2016 R2

[image]

IceLib Technical Reference
What's New in 2016 R2
Send Feedback

IceLib 2016 R2 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Connection
  • Configuration
  • Documentation

Connection

New GetAuthenticationToken()()()() and GetAuthenticationTokenAsync(EventHandler<(Of <<'(GetAuthenticationTokenCompletedEventArgs>)>>), Object) methods were added to allow IceLib-based applications to retrieve the Authentication Token and Authentication Seed associated with the logged in user's session. These values can then be used to create an Interaction Center Web Service (ICWS) connection based off of the IceLib-based application's logged in user.

The GetAuthenticationTokenResult and GetAuthenticationTokenCompletedEventArgs objects were added to hold the Authentication Token and Authentication Seed return values from the GetAuthenticationToken and GetAuthenticationTokenAsync methods.

Configuration

Basic configuration support for MRCP Servers have been added and can be accessed via the MrcpServerConfigurationList and MrcpServerConfiguration objects.

A new MrcpServerList administrative rights property was added to support the MrcpServerConfiguration object.

New CreateModifyCampaignGroup, ManualTransitionSequence, and ModifyCampaignGroupSequence properties were added to provide additional support to security rights configuration.

Documentation

A new Certificate Validation concept page was updated to include details on how to enable client-side validation of server certificates for IceLib-based applications, as well as how to configure the certificates.


What's New in 2016 R1

[image]

IceLib Technical Reference
What's New in 2016 R1
Send Feedback

IceLib 2016 R1 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Connection

ININ.IceLib.Connection

The IceLib Single Sign-On implementation was extended to support 3rd party browser-based Identity Providers via a new pop-up browser window. As part of these changes, a new Browser enumeration value was added to distinguish Identity Providers that are configured to use a browser window. For compatibility purposes, IceLib-based applications are required to opt-in to seeing these Identity Providers. This can be done by specifying the application's supported AuthenticationFields to the GetAllowableAuthentications(AllowableAuthenticationsParameters) method with the SupportedAuthenticationFields property. Other supporting API elements were added for this new feature as well, including the CustomFormAuthScriptableClass and SingleSignOnRequestData classes, and a new HandleTryPromptForBrowserCredentials(SingleSignOnRequestData) method. Additionally, the Connecting to the Server concept page was updated to include sample IceLib code to show how to utilize this new functionality.

To help accommodate filtering Identity Providers with the new Browser enumeration value, and to allow for future growth, the GetAllowableAuthentications(AllowableAuthenticationsParameters) overload was added.

As a performance improvement, the ability to retrieve cached allowable authentications has been added via the GetCachedAllowableAuthentications(CachedAllowableAuthenticationsParameters) method. This was added to give IceLib-based applications the ability to retrieve the last known configured AllowableAuthentications for a specified host without having to first contact the IC Server.


What's New in 2015 R4

[image]

IceLib Technical Reference
What's New in 2015 R4
Send Feedback

IceLib 2015 R4 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Configuration
  • ININ.IceLib.Interactions
  • ININ.IceLib.People

ININ.IceLib.Configuration

New OptimizerModifyShiftTrading and OptimizerViewShiftTrading access rights, and a new CanAccessOptimizerShiftTrading security right have been added to help support the optimizer functionality.

ININ.IceLib.Interactions

IsSuspended and SuspendedAdditionalInformation properties were added to allow IceLib-based applications to keep track of the queue suspended state.

ININ.IceLib.People

New OptimizerModifyShiftTrading and OptimizerViewShiftTrading access list settings, and a new CanAccessOptimizerShiftTrading rights setting have been added to help support the optimizer functionality. Supporting OptimizerModifyShiftTrading and OptimizerViewShiftTrading access list attributes, and CanAccessOptimizerShiftTrading rights attributes have also been added.


What's New in 2015 R3

[image]

IceLib Technical Reference
What's New in 2015 R3
Send Feedback

IceLib 2015 R3 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Connection.Extensions
  • ININ.IceLib.Statistics

ININ.IceLib.Connection.Extensions

A new CustomProfileParameters class was added to help aid in creating CustomProfile objects via the newly added GetApplicationCustomProfile(CustomProfileParameters) method. A new RestrictCacheRefreshOption property was added to allow IceLib-based applications to opt-out of refreshing the previoulsy cached custom profile data when requesting profile information that does not exist (e.g. for custom profile information that may have been deprecated, and is no longer always present).

ININ.IceLib.Statistics

In 4.0 SU 5, the AlertFilterKey(AlertSet, String) constructor was incorrectly marked obsolete, and is no longer marked as such. Along with that change, the AlertFilterKey..::..TargetId property is now no longer marked obsolete. Clarifying comments have been added as to their proper usage.


What's New in 2015 R2

[image]

IceLib Technical Reference
What's New in 2015 R2
Send Feedback

IceLib 2015 R2 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Connection
  • ININ.IceLib.Configuration

ININ.IceLib.Connection

A new SocketConnectionTimedOut value was added to allow IceLib-based applications to distinguish an IceLibConnectionException as a socket timeout.

ININ.IceLib.Configuration

New ReportTableConfigurationList and ReportTableConfiguration classes have been added to help support additional configuration for reporting.

A new CrystalReport enumeration value and a new FileName property have been added to help support Crystal Reports.


What's New in 2015 R1

[image]

IceLib Technical Reference
What's New in 2015 R1
Send Feedback

IceLib 2015 R1 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Assembly References
  • ININ.IceLib.Configuration
  • ININ.IceLib.Interactions
  • ININ.IceLib.ProcessAutomation

Assembly References

As of 2015 R1, some of the file dependencies have changed. File dependencies prior to 2015 R1 had "1-2" embedded in the filenames - these dependencies have been changed to have version "1-4" in their filenames as of 2015 R1. For instance, i3trace-w32d-1-2.dll is now i3trace-w32d-1-4.dll. Caution should be taken when deploying a custom IceLib-based application to be sure that the deployment reflects these changes, specifically, if deploying using the "copy file" method as outlined in Deploying Custom IceLib-based Applications.

ININ.IceLib.Configuration

A new ConfigurationDeleteException class has been added to provide better feedback for cases when a Delete()()()() operation fails.

A new ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class has been added to support filtering configuration queries with a list of values. This class adds in the support for filtering configuration queries with an "Or" option. In order to determine if the IC Server supports this type of filtering, a new SupportsValueListFiltering(ConfigurationManager) method has been added.

Caution
Every new WrapUpCategoryConfiguration will now have its ID generated by the IC server. As a result, all queries for WrapUpCategoryConfiguration using an ID filter should switch to filter on the Display Name instead if it is intended to search by name.

ININ.IceLib.Interactions

EmailUpdated and EmailStartWatching()()()() have been deprecated in favor of EmailContentUpdated and EmailStartWatchingWithEvent()()()(). A supporting EmailContentUpdateEventArgs class has also been added.

ININ.IceLib.ProcessAutomation

Previous to 2015 R1, operations in the ININ.IceLib.ProcessAutomation namespace were not enforcing licensing requirements correctly. This has been corrected as of 2015 R1 and beyond. See the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses.

Caution
A custom application could previously have utilized ININ.IceLib.ProcessAutomation operations without first explicitly acquiring the required licenses for the user logged in through the custom application. As of 2015 R1, such an application will receive license failure results for its use of those ININ.IceLib.ProcessAutomation operations. The application must be modified to explicitly acquire the required licenses.

The asynchronous and synchronous versions of these methods are affected:

  • CreateInstance(ProcessLaunchParameters)
  • LaunchProcessByName(String, ProcessLaunchParameters)
  • Pickup()()()() (for Work Item Interactions)


What's New in 4.0 SU 6

[image]

IceLib Technical Reference
What's New in 4.0 SU 6
Send Feedback

IceLib 4.0 SU 6 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Configuration
  • ININ.IceLib.ProcessAutomation
  • ININ.IceLib.Statistics

ININ.IceLib.Configuration

The following constructors and properties were made obsolete: GroupedConfigurationId(String, String, ConfigurationIdGrouping), GroupedConfigurationId(String, String, ObjectType, String, ConfigurationIdGrouping), GroupedConfigurationId(String, String, String, ConfigurationIdGrouping), and ObjectName.

The following new methods have been added to help in creating GroupedConfigurationId objects: CreateAllGroupedConfigurationId()()()(), CreateGroupGroupedConfigurationId(String, ObjectType), and CreateSingleGroupedConfigurationId(String).

FeedbackSurveyGroup and LineGroup enumeration values have been added.

New objects and properties have been added to allow configuring of Single-Sign On (SSO): SingleSignOnIdentityProviderConfigurationList, SingleSignOnIdentityProviderConfiguration, SingleSignOnIdentityProviders, and SingleSignOnSecureTokenServer.

Caution
The data type of EFaqSearchOption has been changed to EFaqSearchOption.

ININ.IceLib.ProcessAutomation

ProcessLaunchParameters has a new PasOverloadedAtlaunchOption property. A supporting PasOverloadedAtLaunchOption object was added to support the new property. A new Queue enumeration value was also added to support this behavior.

ININ.IceLib.Statistics

AlertSet has a new CompareTo(Object) method.


What's New in 4.0 SU 5

[image]

IceLib Technical Reference
What's New in 4.0 SU 5
Send Feedback

IceLib 4.0 SU 5 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Configuration
  • ININ.IceLib.Connection
  • ININ.IceLib.Directories
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.QualityManagement
  • ININ.IceLib.Reporting
  • ININ.IceLib.Statistics

ININ.IceLib.Configuration

Transaction support for operations that affect the configured users has been added. Transactions are initiated via a call to ConfigurationManager..::..BeginTransaction()()()() or ConfigurationManager..::..BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). This causes user-related notifications to be suspended, until ConfigurationManager..::..EndTransaction(Int32) or ConfigurationManager..::..EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called. Transaction IDs can be set (or cleared using ConfigurationManager..::..NoTransactionId), by calling DefaultUserConfiguration..::..SetTransactionId(Int32), RoleConfiguration..::..SetTransactionId(Int32), UserConfiguration..::..SetTransactionId(Int32), and WorkgroupConfiguration..::..SetTransactionId(Int32). After being set (or cleared), prior to committing the objects to the IC Server's Configuration, Transaction IDs can be accessed via the DefaultUserConfiguration..::..TransactionId, RoleConfiguration..::..TransactionId, UserConfiguration..::..TransactionId, and WorkgroupConfiguration..::..TransactionId properties. Access Control Group assignments can also be included within transactions via a call to AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32).

The following new properties have been added to the various configuration objects: ClientTemplateConfiguration..::..IsPermanent, UserConfiguration..::..CallbackEnabledWorkgroups, WorkgroupConfiguration..::..CallbackMaxRetry, WorkgroupConfiguration..::..CallbackSnoozeDuration, WorkgroupConfiguration..::..IsCallbackEnabled, StructuredParameterConfiguration..::..Description, StructuredParameterConfiguration..::..Parameters, StationConfiguration..::..PhoneNumberClassifications, StationTemplateConfiguration..::..PhoneNumberClassifications, and ResponseManagementDocument..::..ImportedDescription.

The following properties have been marked as obsolete: UserConfiguration..::..MobileOfficeUser, WorkgroupConfiguration..::..HasActivation, WorkgroupConfiguration..::..HasMailbox, and WorkgroupConfiguration..::..RecordingBeepTones.

A new ResponseManagementDocumentConfiguration..::..SetDocument(ResponseManagementDocument) method has been added to facilitate importing documents.

The ServerParameterConfiguration and StructuredParameterConfiguration objects are now editable. StructuredParameter and StructuredParameterType objects have been added to support editing of structured parameters.

Getting validators on container configuration objects is now supported via calls to EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidators()()()() and GetValidatorsAsync(EventHandler<(Of <<'(GetValidatorsCompletedEventArgs<(Of <<'(TPropertyEnum>)>>)>)>>), Object).

The ability to query configuration objects by starting at a specific record number has been added. Setting the starting record number for a query can be done by setting the appropriate value on QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetStartAtRecordNumber(Int32). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartAtRecordNumber property has also been added.

New UserConfiguration..::..Rights..::..PreviewEmailUserQueue and WorkgroupConfiguration..::..Rights..::..PreviewEmailWorkgroupQueue filterable rights have been added.

Support for the following access rights has been added: CreateSchedulingUnitShiftRotations, CreateSchedulingUnitTimeoffRequests, DeleteSchedulingUnitShiftRotations, DeleteSchedulingUnitTimeoffRequests, ModifySchedulingUnitShiftRotations, ModifySchedulingUnitTimeoffRequests, PreviewEmailUserQueue, PreviewEmailWorkgroupQueue, ViewSchedulingUnitShiftRotations, and ViewSchedulingUnitTimeoffRequests.

Support for the following security rights has been added: CanCreateOptimizerActivityCodes, CanDeleteOptimizerActivityCodes, CanModifyOptimizerActivityCodes, CanModifyOptimizerStatusActivityTypeMapping, CanViewOptimizerActivityCodes, and CanViewOptimizerStatusActivityTypeMapping.

ININ.IceLib.Connection

A new concept page, Authentication, has been added that contains information about authenticating with IceLib, the various authentication types, and the related settings that affect authentication.

Support for single sign-on (SSO) authentication has been added to IceLib. See Authentication for more information. This support includes a new SecurityTokenServiceAuthSettings class used when connecting a Session and supporting classes AuthProviderContext, SecurityTokenServiceAuthParameters, SecurityTokenServicePresenter, and SecurityTokenServicePresenterContext.

The allowed authentication modes support was extended to return information about the configured SSO providers. Specifically, the AuthProviderDefinitions property was added to access the new AuthProviderDefinition class. Additionally, the GetAllowableAuthentications(HostSettings, String) method overload was added to allow specification of an isoLanguage in which the SSO provider's display name information should be returned.

The ICAuthSettings, AlternateWindowsAuthSettings, and ProxyAuthSettings classes were enhanced with SecureString support for their password handling.

Centralized tracing has been enabled for Citrix environments. This allows a default minimum trace level to be set via Interaction Administrator. Trace levels are able to be set on a per user basis, however, the highest effective value will be used. For example, if the trace levels for a user is set to a level below the minimum trace level then the minimum trace level set via Interaction Administrator will be used. On the contrary, if a user's trace level is set above the minimum trace level then the user's trace level will be used. Also, the trace level of one user will not affect the trace level of another user.

A new NewLocalCacheFileName(Session) method has been added that will create a temporary file in IceLib's local cache folder, suitable for use in file uploads.

A new station login persistence model has been made available, and can be used by setting the appropriate RemoteNumberSettings..::..PersistStationLogin, RemoteStationSettings..::..PersistStationLogin, or WorkstationSettings..::..PersistStationLogin values. Additionally, the Disconnect(Boolean) and DisconnectAsync(Boolean, AsyncCompletedEventHandler, Object) methods have been added to support persisting the station login while disconnecting a session connection.

Custom Notification watch support has been expanded with new ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][]) and ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) methods. Additionally new IsWatching()()()(), IsWatching(CustomMessageHeader), and IsWatching(List<(Of <<'(CustomMessageHeader>)>>)) methods were added so that it could be easily determined if an active watch is already in place.

ININ.IceLib.Directories

ModifyTrackerDirectory(String, String, TrackerFilterSettings) and ModifyTrackerDirectoryAsync(String, String, TrackerFilterSettings, AsyncCompletedEventHandler, Object) methods have been added.

ININ.IceLib.Interactions

SetCompletion(Boolean) and SetCompletionAsync(Boolean, AsyncCompletedEventHandler, Object) have been deprecated in favor of SetCompletion(CallbackSetCompletionParameters) and SetCompletionAsync(CallbackSetCompletionParameters, AsyncCompletedEventHandler, Object).

MakeCallbackCall(CallInteractionParameters) and MakeCallbackCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) has been added.

A new CallbackCompletion..::..Retry enumeration value has been added.

CallbackInteractionAttributeName has had the following values added: CallbackRetryCount, CallbackMaxRetry, CallbackSnoozed, CallbackSnoozeStartTime, CallbackSnoozeEndTime, and CallbackSnoozeActualWakeupTime.

A new CallInteractionParameters..::..CallbackInteractionId property has been added.

A new EmailContent..::..ReplyToRecipients property has been added.

The Interaction object has been enhanced with the following new properties: Language, LocalPartyType, and RemotePartyType, and their associated InteractionAttributeName values: Language, LocalPartyType, and RemotePartyType. An associated InteractionCallPartyType enumeration has also been added.

ININ.IceLib.People

The behavior of the Icon property on StatusMessageDetails has been changed. Prior to SU 5, when accessing the Icon property for the first time, the icon was attempted to be downloaded on the calling thread. In cases where the icon was not able to be downloaded, this could result in large response times (sometimes in the vicinity of 60 to 90 seconds per failed icon download). The Interaction Client currently accesses status icons on the UI thread, so in cases where icon downloads fail, there is potential for large delays in showing the Interaction Client's UI. Additionally, if a status icon was updated in Interaction Administrator, any active StatusMessageList watches would have been informed of the icon change via the WatchedObjectsChanged event; however, the new icon would not have been downloaded until the associated Icon property was accessed again.

To help alleviate this, a couple of changes have been made. Firstly, when accessing the Icon property, IceLib will now return the cached icon, if it had been loaded in memory already. If the icon had not yet been loaded in memory, IceLib attempts to load the icon into memory from the local file cache. Failing this, IceLib loads the default icon. At this point, a download request for an updated icon is queued on a background thread, and then the Icon property returns what it currently has loaded at this point. In the meantime, when there are icon downloads queued, the background downloader begins to download requested icons, and as they succeed, it will then fire the associated WatchedObjectsChanged event. The EventArgs of this event will contain the Id as the key in the Changed dictionary, and the values will contain an entry for Icon.

Additionally, when a status icon is changed in Interaction Administrator, IceLib will download the icon in the background, and will fire the same WatchedObjectsChanged event, and will include both the Icon and the IconFileName values in the EventArg's Changed dictionary.

A new WatchedStatusMessageObjectsChanged event has been added to allow notifications to be received when StatusMessageDetails objects that are part of a watched FilteredStatusMessageList change. The StatusMessageChangedEventArgs supporting object has been added for that event.

A new UserStatus..::..IsInitialized property was added.

A new WorkgroupActivation(String, Boolean) constructor was added.

Support for the following ACL attributes has been added: OptimizerCreateShiftRotations, OptimizerCreateTimeOffRequests, OptimizerDeleteShiftRotations, OptimizerDeleteTimeOffRequests, OptimizerModifyShiftRotations, OptimizerModifyTimeOffRequests, OptimizerViewShiftRotations, OptimizerViewTimeOffRequests, PreviewEmailUserQueue, PreviewEmailWorkgroupQueue.

Support for the following ACL settings has been added: OptimizerCreateShiftRotations, OptimizerCreateTimeOffRequests, OptimizerDeleteShiftRotations, OptimizerDeleteTimeOffRequests, OptimizerModifyShiftRotations, OptimizerModifyTimeOffRequests, OptimizerViewShiftRotations, OptimizerViewTimeOffRequests, PreviewEmailUserQueue, PreviewEmailWorkgroupQueue.

Support for the following rights attributes has been added: AllowIntercomChat, CanCreateOptimizerActivityCodes, CanDeleteOptimizerActivityCodes, CanModifyOptimizerActivityCodes, CanModifyOptimizerStatusToActivityTypeMapping, CanViewOptimizerActivityCodes, CanViewOptimizerStatusToActivityTypeMapping.

Support for the following rights settings has been added: AllowIntercomChat, CanCreateOptimizerActivityCodes, CanDeleteOptimizerActivityCodes, CanModifyOptimizerActivityCodes, CanModifyOptimizerStatusToActivityTypeMapping, CanViewOptimizerActivityCodes, CanViewOptimizerStatusToActivityTypeMapping.

ININ.IceLib.QualityManagement

StartRecording(String), StartRecordingAsync(String, EventHandler<(Of <<'(StartRecordingCompletedEventArgs>)>>), Object), StopRecording(String, IEnumerable<(Of <<'(Guid>)>>)), and StopRecordingAsync(String, IEnumerable<(Of <<'(Guid>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) methods have been added to support starting and stopping recordings, and a supporting StartRecordingCompletedEventArgs object has been added.

ININ.IceLib.Reporting

GetCurrentSiteId()()()() and GetCurrentSiteIdAsync(EventHandler<(Of <<'(GetCurrentSiteIdCompletedEventArgs>)>>), Object) methods have been added, as well as a supporting GetCurrentSiteIdCompletedEventArgs object.

New values have been added to InteractionSnapshotDirection: IntercomInbound and IntercomOutbound.

A new ININ.IceLib.Reporting.Interactions.Details namespace was added that allows more detailed InteractionSnapshot information via an Interaction object.

ININ.IceLib.Statistics

Statistic values can now come back from Stat Alert Server in an error state, and is supported by the following new items: ININ.IceLib.Statistics..::..StatisticErrorValueType, ININ.IceLib.Statistics..::..StatisticStatusMessageKeyValue, StatisticValue..::..ErrorReason and StatisticValue..::..StatisticErrorValueString.

The AlertFilterKey(AlertSet, String) constructor is now obsolete, and a new AlertFilterKey(AlertSet) constructor was added.

The AlertFilterKey..::..TargetId property is now obsolete.


What's New in 4.0 SU 4

[image]

IceLib Technical Reference
What's New in 4.0 SU 4
Send Feedback

IceLib 4.0 SU 4 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Documentation Improvements
  • IceLib SDK 64-bit
  • ININ.IceLib.Connection
  • ININ.IceLib.Connection.Extensions
  • ININ.IceLib.Configuration
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.Statistics
  • ININ.IceLib.Statistics.Alerts

Documentation Improvements

Added a Visual Studio page and a Deploying Custom IceLib-based Applications page.

IceLib SDK 64-bit

A 64-bit version of the IceLib SDK has been made available so that Interaction Center logic can be added to custom 64-bit applications.

A new concept page, IceLib SDK 32-bit vs. 64-bit, has been added that details the differences between the 32-bit and 64-bit versions of the IceLib SDK.

ININ.IceLib.Connection

The SessionSettings class was expanded to support application based settings with a new ApplicationProfileName property.

ININ.IceLib.Connection.Extensions

The CustomProfile class was expanded to support application based settings.

The ProfileItem class was expanded to support application based settings with a new ProfileItem(String, String, String) constructor that uses a String value instead of an Object value.

ININ.IceLib.Configuration

The LayoutConfigurationList and PositionConfigurationList classes were added. Rights were added for them in the UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class. Some miscellaneous supporting classes were also added. The ImageResourceConfiguration class has new HorizontalResolution and VerticalResolution properties.

New Optimizer-related rights were added to the UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class and the UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class, which also received new ReporterAdministrator and CanPublishProcess rights.

New Reporting configuration objects are now available: ReportCategoryConfigurationList, ReportMasterConfigurationList, ReportSectionConfigurationList, ReportParameterConfigurationList, ReportFlexibleColumnConfigurationList, ReportCustomDataConfigurationList, and ReportSystemSettingConfigurationList. The HistoricalReportConfigurationList class now supports editing of the configuration object.

Support was added to allow specifying of rights when querying ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>-derived objects. A new ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class was added, as well as new methods to support this: CreateQuerySettings()()()(), StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), ChangeWatchedQuerySettings(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)). Additionally, the ChangeWatchQuerySettingsAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method was obsoleted in favor of ChangeWatchedPropertiesAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).

ININ.IceLib.Interactions

The InteractionQueue class was expanded with a GetConferenceContents()()()() method to allow retrieval of the conference items in the queue. This complements the GetContents()()()() method.

The Interaction class has a new SecureRecordingPause(SecureRecordingPauseParameters) overload to better support custom applications that want to explicitly control the secure pause behavior.

ININ.IceLib.People

The StatusMessageDetails class was expanded with a IsFollowMeStatus property to identify if a status is the follow-me status.

New Optimizer-related rights were added to the UserAccessListsSettings class and the UserRightsSettings class.

ININ.IceLib.Statistics

A StatisticCatalogChanged event has been added.

ININ.IceLib.Statistics.Alerts

The behavior of StartWatching(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) and StartWatchingAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) when using All or the AdminAccess flag has been changed to properly start a watch using Alert Administrator rights. This will return all of the AlertSets on the server.

Care must be taken when using a StartWatching(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) in this manner to use with StartWatching(array<AlertFilterKey>[]()[][], AlertListenerFilter). This could hinder performance due to the number of alerts that will be watched.

The ININ.IceLib.Statistics.Alerts namespace has been expanded with support for the newly added AlertSetSubscriber class. This provides the ability for users to subscribe to AlertSets and receive notifications for them.

The AlertCatalog class was expanded with additional methods, including TransferOwnership(String, AlertSet) and UpdateSubscriptions(IEnumerable<(Of <<'(AlertSetSubscriber>)>>), String).

The StopWatchingAlertAdministrator()()()() method was added to support the stopping of an alert administrator watch.

The AlertSet class has been expanded with support for additional properties and methods, such as IsSubscribedBy(String, AlertSetSubscriberType), SubscribedByOwner, and AlertSetSubscribers.

The EditableAlertSet class has been expanded with support for additional properties and methods, such as AddAlertSetSubscriber and OwnerDisplayName.

The ClientMemoAlertAction class has been expanded with support for an additional property, SendToAlertSetSubscribers.

The EmailMessageAlertAction class has been expanded with support for an additional property, SendToAlertSetSubscribers.

The Memo class has been expanded with support for additional properties and methods, such as CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String, Boolean) and SendToAlertSetSubscribers.

The AlertSetSubscriberAction and AlertSetSubscriberType classes have been added to be used as parameters to the AlertSetSubscriber class's constructor.


What's New in 4.0 SU 3

[image]

IceLib Technical Reference
What's New in 4.0 SU 3
Send Feedback

IceLib 4.0 SU 3 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Connection
  • ININ.IceLib.Connection.Extensions
  • ININ.IceLib.Configuration
  • ININ.IceLib.Directories
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.QualityManagement
  • ININ.IceLib.Data.TransactionBuilder

ININ.IceLib.Connection

A new RequestTimeoutException was added that is raised when a particular operation times out while waiting on the server to respond. An example might be due to a long running database query or a particular system being overloaded. The IceLib connection isn't necessarily going to disconnect, so the SessionDisconnectedException that was previously being raised in this case was potentially misleading.

The Session class now has a DisplayName property that contains a display name for the Session User, once connected to the server.

The Session class now has a SupportedMedia property that contains the SupportedMedia for the Session User, once connected to the server. This property is updated when SetStationConnectionMode(StationConnectionMode, Int32) or ChangeStation(StationSettings) is called.

ININ.IceLib.Connection.Extensions

A new ProblemReporter class was added that allows an application to submit a problem report along with a subject, description, and related files.

The CustomProfile class was expanded to support application based settings.

The ProfileItem class was expanded to support application based settings with a new ProfileItem(String, String, String) constructor that uses a String value instead of an Object value.

ININ.IceLib.Configuration

All classes derived from ConfigurationObject now have a IsNewObject property. All classes derived from ListConfigurationObject now have a OriginalConfigurationId property.

All classes derived from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> now have IsCreateOnly and IsReadOnly properties.

Support was added for image resources via the ImageResourceConfigurationList and ImageResourceCategoryConfigurationList classes and supporting types. It was also added to UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> and AccessControlGroupConfiguration.

Support was added for recording beep tone configuration via the RecordingBeepToneConfigurationList class.

The WorkgroupConfiguration class was extended with CaptureInRecordings, PlayToExternalPartiesOnly, RecordingBeepTones, SelectedTone, and UseRecordingTones properties.

The ProblemReporterConfigurationContainer and ProblemReporterConfiguration classes were added to allow access to configuration settings for the ProblemReporter functionality. See the ProblemReporter class for more information about the ProblemReporter functionality.

The UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class was expanded with several Optimizer access rights. The UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class was expanded with ProblemReporter and Optimizer rights. The UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class was expanded with a ProblemReporter right.

Client template support was added via the ClientTemplateConfigurationList, ClientTemplateConfiguration, ClientTemplatePublishResult, ClientTemplateResource, and ClientTemplate classes. Additionally, support for publishing templates was added to the UserConfiguration, RoleConfiguration, and WorkgroupConfiguration classes via the PublishClientTemplate methods. A user's client templates were exposed via ClientTemplates. Finally, related rights were added as CanPublishClientTemplates and CanManageClientTemplates.

ININ.IceLib.Directories

The ContactEntry class was expanded with ContactSources, ExternalContactEntries, and Skills properties and related supporting types were added too. These additions apply to derived classes EditableContactEntry and TrackerContactEntry as well.

The DirectoryConfiguration, ContactDirectory and DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> classes were expanded with properties to identify pending load information. DirectoryConfiguration now has the Pending property to identify any PendingDirectoryGroupings that are pending. Pending meaning that the Interaction Center server has yet to determine any directories that match the grouping identified. ContactDirectory now has the PendingStatus property to identify if the contacts for the directory are pending to be loaded or not. DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> now has the Pending property to identify the pending status, if any, of either directory metadata or directory contact entries depending on if the event is sent from DirectoryConfigurationChanged or ContactDirectoryChanged respectively.

ININ.IceLib.Interactions

The CallbackInteraction class was expanded with a CallbackCompletionDisplay property. It was also added to CallbackInteractionAttributeName.

The ChatInteraction class was expanded with a SendFile(Stream, String) method overload that accepts a Stream. The EmailInteraction class was expanded with DownloadFileAttachment(EmailFileAttachment, Stream) and UploadFileAttachment(Stream, String) method overloads that accept a Stream.

ININ.IceLib.People

The UserAccessListsSettings and UserAccessListsAttributes classes were expanded with several Optimizer access rights. The UserRightsSettings and UserRightsAttributes classes were expanded with ProblemReporter and Optimizer rights.

The UserRightsSettings class was expanded with CanSecureRecordingPauseInteractions and CanShowSecureRecordingPauseButton.

ININ.IceLib.QualityManagement

The ScreenRecorder class was expanded with support to PauseRecordings(String) and ResumeRecordings(String).

ININ.IceLib.Data.TransactionBuilder

Support was added for "out of band" queries to support larger result sets. The out of band options are available via the TransactionData class properties ForceOutOfBand, CompletedAction, UserState, TransactionToken, and WasOutOfBandUsed. A TransactionManager class was also added for this namespace, with options for cancelling a transaction and for getting the status of a transaction. The TransactionClient class can now be constructed with a TransactionManager.


What's New in 4.0 SU 2

[image]

IceLib Technical Reference
What's New in 4.0 SU 2
Send Feedback

IceLib 4.0 SU 2 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • Example Applications
  • ININ.IceLib.Connection
  • ININ.IceLib.Configuration
  • ININ.IceLib.Directories
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.ProcessAutomation
  • ININ.IceLib.UnifiedMessaging

Example Applications

A new C# example application was added. This "Tutorial Example" began as the lab exercises at a few ININ User/Partner Conferences. It contains a document with exercises that lead the reader through several small examples of using IceLib functionality to accomplish a task in the Visual Studio project. This example demonstrates some functionality of the ININ.IceLib.Connection, ININ.IceLib.Configuration, and ININ.IceLib.Statistics namespaces. It also demonstrates an approach to integration of IceLib with a WPF application.

ININ.IceLib.Connection

Support was added for retrieving allowed authentication modes via the GetAllowableAuthentications(HostSettings) method. Support was added for retrieving a configured user agreement via the UserAgreement property.

The SessionSettings class was expanded to support application based settings with a new ApplicationProfileName property.

ININ.IceLib.Configuration

The ResponseManagementDocumentConfiguration class was expanded with support for editing response documents.

The ScheduleConfiguration class was expanded with support for additional properties, recurrences, and for editing.

The SecureInputFormConfiguration and SecureInputFormConfigurationList classes were added for configuring secure input forms.

Support was added for Salesforce integration settings via the ININ.IceLib.Configuration.Integrations.Salesforce namespace. An additional right was added for users, roles, and workgroups via UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Support was added for listing SIP bridge objects via the SipBridgeConfigurationList class.

Additional rights were added for users, roles, and workgroups via UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> for SelectionRuleConfiguration and SIP bridge.

Additional rights were added for users, roles, and workgroups via UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> for follow me, forward, and TUI phone number classifications.

Additional rights were added for users, roles, and workgroups via UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> for allowing agent schedule bidding, agent see own rank, agent see relative rank, email alerts, handler alerts, memo alerts, mini mode, and recording interactions.

The WorkgroupConfiguration class has a new MonitoredMailboxes property for configuring workgroup mailboxes.

DNIS mappings configuration was added via the DnisMappingsConfiguration and DnisMappingsConfigurationContainer classes.

The Language property was deprecated in favor of language options on the Keyword property.

The UserConfiguration.StationType property was removed due to being an invalid property.

ININ.IceLib.Directories

The ContactEntry class has a new LyncSipAddress property.

ININ.IceLib.Interactions

The PhoneNumber class has new properties AutoDialExtension, EditBase, and Extension available.

The Interaction class has a new InitiateSecureInput(SecureInputParameters) method.

ININ.IceLib.People

The LookupComparisonType enumeration now supports wildcard comparisons. See Wildcards for details.

The LookupEntry and LookupEntryProperty types have more lookup entry attributes available for business, home, and mobile email/phone values as well as IsActive.

The ResponseItem type has new Keywords, PlainTextValue, and Shortcut properties.

The WorkgroupDetails and WorkgroupAttributes types have a new MaximumChatResponseTime property.

The UserAccessListsSettings and UserAccessListsAttributes types have new PhoneNumberClassificationFollowMeList and PhoneNumberClassificationForwardList properties.

The UserRightsSettings and UserRightsAttributes types have new CanInitiateSecureInput and CanShowSecureInputButton properties.

ININ.IceLib.ProcessAutomation

The ProcessManager class has a new CheckForRunningProcess(String) method.

The WorkItemInteraction class has new ProcessDefinitionId and WorkItemIsTransferable properties.

ININ.IceLib.UnifiedMessaging

The FaxMessage class has a new SaveToStream(FaxAttachment, Stream, Boolean) method.


What's New in 4.0 SU 1

[image]

IceLib Technical Reference
What's New in 4.0 SU 1
Send Feedback

IceLib 4.0 SU 1 includes a number of features that have been added, improved, and changed. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features.

Jump to a section:

  • ININ.IceLib.Configuration
  • ININ.IceLib.Directories
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.ProcessAutomation
  • ININ.IceLib.Statistics
  • ININ.IceLib.Tracker

ININ.IceLib.Configuration

Support was added for several new configuration objects via the AccountCodesConfigurationContainer, DefaultLocationConfigurationContainer, and ICDataSourceConfigurationList classes, with some full and some basic support among them. The WrapUpCodeConfigurationList class was expanded to full editable support. The WorkgroupConfiguration, WrapUpCategoryConfiguration, WrapUpCodeConfiguration, and StatusMessageConfiguration classes were expanded.

New rights were added to UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, and UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. Utilization support was added to UserConfiguration. Many supporting types were added as well.

Support for Access Control Groups was added via the AccessControlGroupConfigurationList class which has full editable support. The AccessControlGroupAssignment property was added the following configuration types: AccountCodeConfiguration, AnalyzerKeywordSetConfiguration, ClientConfigurationTemplateConfiguration, InteractionProcessorTableConfiguration, LocationConfiguration, PasswordPolicyConfiguration, RoleConfiguration, ScheduleConfiguration, SkillConfiguration, StationConfiguration, StationGroupConfiguration, StationTemplateConfiguration, UserConfiguration, WorkgroupConfiguration, WrapUpCategoryConfiguration, and WrapUpCodeConfiguration.

Support for language-based queries was added to QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

ININ.IceLib.Directories

The DirectoryMetadata class has a new DirectoryAdmin property.

ININ.IceLib.Interactions

The Interaction class and its derived types have new properties AssociatedProcessDisplayName and TimeInWorkgroupQueue available. The InteractionAttributeName class has the new attribute names as well.

ININ.IceLib.People

The LicenseManagement class now supports watching for license changes. See StartWatching(array<String>[]()[][]) for details.

The UserRightsSettings and UserRightsAttributes classes had ShowAgentRank, ShowAgentRelativeRank, and ShowScheduleBidding added.

ININ.IceLib.ProcessAutomation

The ability to cancel a process instance was added to the ProcessManager class. The ProcessDefinition class now exposes PublishedVersion and Inputs properties.

The WorkItemInteraction class now includes a ProcessNumericId property. The WorkItemInteractionAttributeName class has the new attribute name as well.

ININ.IceLib.Statistics

The StatisticValue class and its derived types have new properties NullDisplayString, TimeSpanWithDayFormatString, and TimeSpanWithoutDayFormatString available. The StatisticFiniteDurationValue class has new members GetTimeStamp()()()() and IsTicking.

ININ.IceLib.Tracker

See the changes outlined in ININ.IceLib.Interactions for new interaction class properties, as they apply to a TrackerInteraction.


What's New in 4.0 GA

[image]

IceLib Technical Reference
What's New in 4.0 GA
Send Feedback

With the release of IceLib 4.0, there are a number of features that have been added, improved, and changed to match new IC Server changes. Each namespace in IceLib is broken out to list each of these changes, to make it easier to find places where existing IceLib integrations may need to be updated for major breaking changes, or places where integrations could be enhanced to use newly introduced features. It is worth noting that, due to underlying connection security changes, IceLib 3.0 integrations must be upgraded to use IceLib 4.0 in order to work with 4.0 IC Servers. Conversely, IceLib 4.0 integrations cannot be used with 3.0 IC Servers.

The IceLib example apps have been upgraded to use the Visual Studio 2010 development environment, along with other improvements. The IceLib assemblies have been upgraded to use the .NET Framework 3.5. The IceLib assemblies were upgraded to use .NET 3.5 instead of .NET 4.0 so that systems utilizing IceLib integrations would not be required to upgrade to .NET 4.0; however, this does not restrict the ability to do so if desired.

Jump to a section:

  • Documentation Improvements
  • Example Applications
  • ININ.IceLib.Configuration
  • ININ.IceLib.Directories
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.ProcessAutomation
  • ININ.IceLib.QualityManagement
  • ININ.IceLib.Reporting
  • ININ.IceLib.Statistics
  • ININ.IceLib.Tracker

Documentation Improvements

Added a Welcome to IceLib page and a What's New in IceLib page. Added new Getting Started topics which include documentation on some key areas of the IceLib API, such as overview information and examples for common use cases. Added new Concepts topics which describe some fundamental concepts which are common to many different areas of the IceLib API.

Added helpful tips throughout the IceLib API documentation, including links back to getting started and concept pages. Extended the documentation of API elements to include any example application usages, with details on file, line, and method reference.

Example Applications

A new C# example application was added to demonstrate usage of the ININ.IceLib.Statistics namespace. This "Statistics Sample" contains browsing of the statistics catalog, watching valid parameter values, listening to statistic value changes, and configuration and monitoring of alerts.

The example applications were upgraded to use Visual Studio 2010. Older style Windows Forms Designer code was broken out into separate Foo.Designer.cs files to reduce clutter and follow newer Visual Studio standards.

The example applications were freshened up throughout, with code improvements, some additional comments, and general clean up of warnings and style. Some "gee whiz" elements were removed that diluted the examples.

ININ.IceLib.Configuration

Full support for UserConfiguration, RoleConfiguration and WorkgroupConfiguration has been added. Additionally, basic support for over 70 new configuration objects has been added. Basic support includes the ability to query and monitor a configuration object for changes. Monitoring a configuration object is done by starting a watch with a supplied QuerySettings object. Two new events can then be monitored to check for changes: ConfigurationObjectsChanged and ConfigurationObjectsRemoved. The changed event is invoked when a watched configuration object's property changes. The removed event is invoked when a watched configuration object has been deleted.

At the time of IceLib 4.0 release, a new ConfigurationObjectsAdded event is visible in the API; however, it is currently not supported. This event will become functional in a future SU.

Support to return more than 50 results for a query has been added. This depends on the number of requested properties: If less than five properties are requested, a configuration query can return an unlimited number of results; however, if five or more properties are requested, then a maximum of 300 results will be returned. Extreme caution should be taken when executing a query that will return an unlimited number of results as this can cause adverse effects on the network if there are a large number of results.

The query model has been updated to help increase usability. All of the constructors for the QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object have been removed in favor of individualized methods for setting the requested properties, property filters, result limit, sort order and rights filters. Additionally, since the constructors for QuerySettings have been removed, creating this object is done through the configuration's list object with a new CreateQuerySettings method.

Support for standard properties, such as date created, date last modified, notes and custom attributes have been added to many of the configuration objects.

Support for filtering configuration objects through rights has been added. Supplying a RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> to the QuerySettings object will cause the applicable rights to be applied to the configuration object. For instance, by supplying a view right, only those configuration objects that the Session's UserId has view rights to will be returned.

More details can be found in the Configuration getting started section.

ININ.IceLib.Directories

When creating a speed dial directory, IceLib now provides the new Directory ID. This change also includes a new event arguments signature change for the asynchronous method - the event arguments will now be an instance of a CreateDirectoryCompletedEventArgs object that will supply the new Directory ID.

Support for a new ContactCountChanged event has been added that will notify a paged directory watch when the number of contacts contained in it has changed. This event will be invoked when a contact is added to the IC Server that matches the directory filter that was supplied to the paged directory watch. Additionally, the event will also be invoked when a contact no longer matches the supplied filter due to a change in the contact, or if the contact is removed from the IC Server.

ININ.IceLib.Interactions

To reflect IC Server changes, the email model has been changed. Support for reply, reply all, and forward have been added.

Support for a new assistance response system using the AgentAssistanceList and SupervisorAssistanceList objects has been added to replace the old help request mechanism. This new assistance response system includes a 2-way chat between agents and their supervisors, and it allows supervisors to monitor active assistance requests by their agents. This change has made the old AgentHelpRequest and AgentHelpResponse objects obsolete.

Wrapup codes can now be set per interaction segment. This change has made the old SetWrapUpCodeId method obsolete in favor of a newer AddWrapUpAssignment method.

Support for a new secure recording pause feature has been added with the SecureRecordingPause method. This allows recordings to be paused during periods where, for instance, confidential information is being relayed.

Support for a new consult transfer feature has been added with the MakeConsultTransfer method. This allows agents to bring a consultant in on an interaction. This feature can allow the agent to speak with a consultant without the external party hearing the conversation. It can allow the agent to bring the consultant in on the interaction, bringing all three parties in on the interaction.

Support for watching Line Queues has been added.

Support for inviting a party to an existing conference interaction was added with the InviteParty method.

Support for new Interaction properties that support secure calls have been added, including LocalSecurityLevelRequested, RemoteSecurityLevelRequested, SecurityLevelActual and SecurityLevelViolation.

Support for monitoring Screen Pops has been added through a new ScreenPop object. This allows incoming screen pops to be monitored for.

Support for monitored queue alerting has been added through a new MonitoredQueueAlerting object. This provides a way for enabling and disabling alerting on a monitored queue.

The AppendNote method now prepends the note with the User ID and timestamp on a new line.

ININ.IceLib.People

Due to IC Server changes, RecorderAccess has been removed from the list of available licenses. Additionally, because of IC Server changes, all of the "ModifyQueuList" ACLs for Lines, Stations, Users and Workgroups have been made obsolete in favor of individual coach, disconnect, join, listen, pickup, record, and transfer ACLs.

Support for new 4.0 ACLs has been made available. This includes - but is not limited to - ActivateOthersList, ChangeUserStatus and ViewIndividualStats. See UserAccessListsAttributes for a full list of available ACLs.

Support for new 4.0 user rights has been made available. This includes - but is not limited to - CanParkInteractions, CanSecureRecordingPauseInteractions and CanCreateConferenceCalls. Also, due to IC Server changes, many user rights have been made obsolete in favor of a new 4.0 right. See UserRightsAttributes for a full list of available user rights.

Support for activating a custom button action has been added using the ActivateButtonAction method.

Support for retrieving the workgroup activations for a specific user has been added using the GetActivationsForUser method.

Support for creating Voice Prompts has been added through a new VoicePrompts object.

Support for setting the values of boolean, string and string array attributes for user settings data has been added. This addition also applies to UserTrackerRightsSettings.

ININ.IceLib.ProcessAutomation

See the changes outlined in ININ.IceLib.Interactions with Wrapup Codes, Help Requests and Secure Recording, as they apply to a WorkItemInteraction.

ININ.IceLib.QualityManagement

The need to invoke the RegisterUser and DeregisterUser methods has been removed. These methods and all supporting classes have been marked as obsolete.

The ability to start a timed screen recording for a specified User ID and duration has been added with the StartTimedRecording method.

ININ.IceLib.Reporting

This namespace is new to IceLib in 4.0. This namespace contains classes for implementing reporting related features. This namespace can be used to retrieve historical information about interactions. A specific interaction can be retrieved; however, a filtered list of interactions can also be retrieved.

ININ.IceLib.Statistics

This namespace is new to IceLib 4.0. This namespace contains classes for receiving Interaction Center statistics. It can also be used to set and receive statistic alerts. All statistics shown in Interaction Supervisor TM can now be accessed via IceLib.

Support for querying details about statistics and parameters to those statistics has been added with the StatisticCatalog class. Watching statistic values is supported through the StatisticListener class. The value of a statistic, available as a StatisticValue, has type information, such as duration, string, or double.

Support for watching details about alerts has been added with the AlertCatalog class. The AlertCatalog also provides support for creating new alerts and editing existing alerts. The AlertListener class has been added to support watching alerts for changes in configuration or state. A state change occurs when an alert becomes triggered or is cleared. Alerts contain details about how they are configured, including the triggering statistic and the action type, such as email or memo.

A new "Statistics Sample" example application was added to demonstrate usage of this new namespace.

More details can be found in the Statistics getting started section.

ININ.IceLib.Tracker

See the changes outlined in ININ.IceLib.Interactions with Wrapup Codes, Help Requests and Secure Recording, as they apply to a TrackerInteraction.

Support for setting attribute values from a Boolean, a String and an array of Strings have been added.

Support for specifying an admin type filter has been added when searching for individuals using the SearchIndividuals method.


Getting Started

[image]

IceLib Technical Reference
Getting Started
Send Feedback

This section includes documentation on some key areas of the IceLib API, such as overview information and examples for common use cases. It can be challenging for a new developer to determine where to get started with the elements of a namespace. These topics are meant to "jump start" that effort, providing some important aspects to be aware of for a particular API area. Additionally, by providing focused example snippets around common tasks, these topics provide quicker understanding of what's possible and how to make those possibilities into reality.

Tip

The quick start topics are a great place to get started with the elements of a namespace. Then, the IceLib SDK's more full-featured example applications can serve as a great resource for example code in the context of developing real applications that allow users to perform larger tasks.

Example Applications
IceLib ships with full-featured sample applications in several languages (C#, VB.NET, ASP.NET).

Custom Profile Migration
The CustomProfile class contains methods for retrieving and saving custom application settings.

Visual Studio
Setting up a custom IceLib-based application in Visual Studio requires some specific settings.

Connecting to the Server
The ININ.IceLib.Connection namespace contains classes for connecting to an IC Server.

Configuration
The ININ.IceLib.Configuration namespace contains classes for configuring an IC Server.

Interactions
The ININ.IceLib.Interactions namespace contains classes for manipulating Interaction Center interaction queues.

Statistics
The ININ.IceLib.Statistics namespace contains classes for viewing, editing, and responding to alerts and statistics.

Statistics Catalog
The statistics catalog contains the display name, description, type, units, required statistic parameters (if any), etc. for each available statistic.

Custom Notifications
The CustomNotification class, along with some associated classes, contains functionality for sending and receiving notifications to and from custom handlers and IceLib applications.


Getting Started with Example Applications

[image]

IceLib Technical Reference
Getting Started with Example Applications
Send Feedback

IceLib ships with full-featured sample applications in several languages/technologies (C#, VB.NET, ASP.NET). These applications demonstrate usage of the IceLib API to implement user interface elements that perform a variety of tasks. Exploration of these example applications can not only provide insight into the nuances of API usage, but also provide impressions of good approaches to follow both in the code and in the API usage.

IceLib API element documentation has been augmented throughout with references to example application usage of those APIs. See this section for details.

When applying an ES or SU, any sample application files that have been modified will not be overwritten. If the ES or SU contains any updates to the sample application files, they will not be updated unless the modified files are replaced with the original files.

Jump to a section:

  • Example Applications
  • Examples Documentation

Example Applications

Each application is commented and designed to illustrate "best practices" of a real implementation. The examples cover key topic areas, such as:

Applications in ExampleApps Folder
Language | Project Folder | Description
C# | TutorialExample | This C# example contains a document with exercises that lead the reader through several small examples of using IceLib functionality to accomplish a task in the Visual Studio project. This example exercises some functionality of the ININ.IceLib.Connection, ININ.IceLib.Configuration, and ININ.IceLib.Statistics namespaces. It also demonstrates an approach to integration of IceLib with a WPF application.
C# | InteractionsTest | This C# example implements a simple but feature-rich telephony client, similar to Interaction Client .Net Edition. You can perform common telephony tasks (place calls, send calls to voicemail, disconnect, etc.), view voicemails and query server parameters. This example exercises the functionality of the ININ.IceLib.Interactions namespace.
C# | DirectoriesClient | Demonstrates the functionality of the ININ.IceLib.Directories namespace. This application shows how to connect to an IC server, display information about contact directories on the server, view metadata for a directory, display entries in a directory, and even create a new contact directory.
C# | DirExplorer | Exercises the functionality of the ININ.IceLib.Directories namespace by displaying workgroups, contact directories, Tracker, Station groups and entries in the Company Directory. A column in each view indicates whether or not a watch is in effect.
C# | PeopleClient | This example exercises the functionality of the ININ.IceLib.People namespace. Once you establish a session with the server, you can view Watched Queries (attributes of various settings, details of access rights, etc.), information about Status Messages, and license information.
C# | FaxSample | This application demonstrates how to send a Fax message.
C# | ConnectionExtensionsTest | This application tests server parameters, password policies, and custom notifications within the IceLib API.
C# | StatisticsSample | This example exercises the functionality of the ININ.IceLib.Statistics namespace. It contains browsing of the statistics catalog, watching valid parameter values, listening to statistic value changes, and configuration and monitoring of alerts.
C# | TrackerAdmin | This example helps you understand classes in the ININ.IceLib.Tracker namespace. The TreeView in the left pane allows you to select Address Types, Attribute Types, InteractionAddress Types, InteractionAddress Subtypes, Titles, Individual Types, and Organization Types. These elements correspond to classes in the Tracker namespace.
C# | TrackerClient | This example demonstrates the search functionality of the ININ.IceLib.Tracker namespace. It allows the user to search the Tracker for individuals, interactions, organizations, or a location.
C# | AutomationProcessLauncher | This example shows how to launch an Interaction Process Automation process with supplied data.
C# | RecorderSample | This application shows how to download an IC recording.
C# and PowerShell | ConfigurationCmdlet | This example demonstrates how to work with configured users through a PowerShell cmdlet.
VB.Net | VBTest | Visual Basic.Net source in the ExampleApps\VBTest folder demonstrates functionality of the ININ.IceLib.People namespace, especially the UserStatus and UserStatusList classes. Once you establish a session with the IC server, you can filter workgroups to select persons in a given status.
ASP.Net | AspIceLibClientDemo | This example implements a web page to set status information and place a call. It demonstrates how to use the Icelib public API to do tasks that are commonly carried out by the vaious IC Client applications.
Note
The 64-bit IceLib SDK does not contain the AspIceLibClientDemo example application. The example application (and other ASP.NET applications) can be built with the 64-bit IceLib assemblies, however the resultant web page would not be able to be debugged via Visual Studio, since that built-in debugging capability is 32-bit-only. For the purpose of an IceLib example application, requiring utilization of an actual IIS environment is not ideal, so we have left this example out of the 64-bit IceLib SDK. The 32-bit IceLib SDK still contains it.

Examples Documentation

Many API elements' documentation now have an Examples section to make it easier to find an example of a given API element. This documentation contains specific references to the selected API element from the IceLib SDK example applications, including the actual file name and line number for each example application.

Example Application Usages


Getting Started with Custom Profile Migration

[image]

IceLib Technical Reference
Getting Started with Custom Profile Migration
Send Feedback

Custom application settings that are stored using the CustomProfile class have had changes introduced that split the custom application settings into individual application based settings. The way in which custom application settings are stored was changed to increase performance with applications that utilized custom application settings. Specific steps need to be taken to migrate settings from the legacy settings to the new application based settings. The sections below outline how to use the legacy settings, the new application based settings, and how to migrate settings.

Jump to a section:

  • Working with Legacy Settings
  • Working with Application Based Settings
  • Migration of Legacy Settings to Application Based Settings
  • Migration of Application Based Settings from a Different Application Profile Name

Working with Legacy Settings

Working with legacy settings can be done in the same way it was done before; however, the CustomProfile(Session) constructor has been obsoleted in preference of the GetLegacyCustomProfile(Session) method.

Back to Introduction

Working with Application Based Settings

To retrieve and set application based settings, the ApplicationProfileName property needs to be set prior to calling Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) (or the associated async method). The GetApplicationCustomProfile(Session) method can then be used to get the CustomProfile object. If the application needs to access custom application settings from a different profile than is referenced on the ApplicationProfileName property, then a call to GetOtherApplicationCustomProfile(Session, String) can be made, and will return the appropriate custom application settings for the supplied profile name. Retrieving the custom application settings this way will not allow modifications, and as such, attempting to modify settings will result in an IceLibException.

Note

Although setting application based settings can be set via SetProfileItem(String, String, Object) (or the associated async method), it is recommended that they be set via SetProfileItem(String, String, String) (or the associated async method).

Back to Introduction

Migration of Legacy Settings to Application Based Settings

Specific steps need to be taken to migrate settings from the legacy application settings to the new application based settings. The following code example outlines a possible migration scenario:

CopyC#
private const string _RootNamespaceName = "My Root Namespace";

private void DoLegacyMigration()
{
    // This example assumes that a _Session object has been declared and already connected.
    // Additionally, it assumes that SessionSettings.ApplicationProfileName was set
    // prior to connecting.

    // Check to see if the IC Server supports Application Based Settings, and
    // return out if it doesn't.
    if (!CustomProfile.AreApplicationBasedSettingsSupported(_Session)) return;

    try
    {
        // Create the CustomProfile object to handle the new Application Based Settings.
        CustomProfile applicationProfile = CustomProfile.GetApplicationCustomProfile(_Session);

        // Check to see if the new settings already exist, and return out if they do.
        if (applicationProfile.CheckForApplicationBasedSettings()) return;

        // Get the legacy settings.
        CustomProfile legacyProfile = CustomProfile.GetLegacyCustomProfile(_Session);
        IDictionary<string, ProfileItem> legacySettings = legacyProfile.GetNamespaceContents(_RootNamespaceName);

        // Do the migration.
        foreach (KeyValuePair<string, ProfileItem> legacySetting in legacySettings)
        {
            // Should this setting be migrated?
            if (!IsLegacySettingEligibleForMigration(legacySetting.Value)) continue;

            try
            {
                // Convert the value.
                string newValue = ConvertLegacySettingValue(legacySetting.Value);

                // Set the new profile item on the Application Based Settings.
                applicationProfile.SetProfileItem(
                    legacySetting.Value.NamespacePath, legacySetting.Value.Key, newValue);
            }
            catch (Exception ex)
            {
                // TODO
            }
        }

        // Commit the changes
        applicationProfile.FlushChanges();
    }
    catch (IceLibException iceLibException)
    {
        // TODO
    }
    catch (Exception exception)
    {
        // TODO
    }
}

private bool IsLegacySettingEligibleForMigration(ProfileItem profileItem)
{
    if (profileItem == null) return false;

    // TODO:  Determine if this setting should be migrated or not.

    return true;
}

private string ConvertLegacySettingValue(ProfileItem profileItem)
{
    if (profileItem == null) throw new ArgumentNullException("profileItem");

    // TODO:  Convert the current setting object value to a string value
    //        since Application Based Setting value serialization/deserialization
    //        should now be handled by each individual application.

    return String.Empty;
}

Back to Introduction

Migration of Application Based Settings from a Different Application Profile Name

It may be necessary for an application to migrate application based settings from a different application profile. One possible scenario for this could be in the case of the release of a new version of a custom IceLib-based application in which settings from a previous version need to be updated/ignored in order to keep compatibility with previous versions that could still be in use. The following code example outlines a possible migration scenario:

CopyC#
private const string _OldRootNamespaceName = "My Root Namespace";
private const string _OriginalApplicationProfileName = "My Custom Application";

private void DoProfileMigration()
{
    // This example assumes that a _Session object has been declared and already connected.
    // Additionally, it assumes that SessionSettings.ApplicationProfileName was set
    // prior to connecting, and that a different value is used for the
    // ApplicationProfileName parameter of CustomProfile.GetOtherApplicationCustomProfile.

    // Check to see if the IC Server supports Application Based Settings, and
    // return out if it doesn't.
    if (!CustomProfile.AreApplicationBasedSettingsSupported(_Session)) return;

    try
    {
        // Create the CustomProfile object to handle the new Application Based Settings.
        CustomProfile applicationProfile = CustomProfile.GetApplicationCustomProfile(_Session);

        // Check to see if the new settings already exist, and return out if they do.
        if (applicationProfile.CheckForApplicationBasedSettings()) return;

        // Create the CustomProfile object to handle the original Application Based Settings.
        CustomProfile oldApplicationProfile = CustomProfile.GetOtherApplicationCustomProfile(
            _Session, _OriginalApplicationProfileName);

        // Check to see if the old settings exist, and return out if they don't.
        if (!oldApplicationProfile.CheckForApplicationBasedSettings()) return;

        // Get the old settings.
        IDictionary<string, ProfileItem> oldSettings =
            oldApplicationProfile.GetNamespaceContents(_OldRootNamespaceName);

        // Do the migration.
        foreach (KeyValuePair<string, ProfileItem> oldSetting in oldSettings)
        {
            // Should this setting be migrated?
            if (!IsOldSettingEligibleForMigration(oldSetting.Value)) continue;

            try
            {
                // Convert the value.
                string newValue = ConvertOldSettingValue(oldSetting.Value);

                // Set the new profile item on the Application Based Settings.
                applicationProfile.SetProfileItem(
                    oldSetting.Value.NamespacePath, oldSetting.Value.Key, newValue);
            }
            catch (Exception ex)
            {
                // TODO
            }
        }

        // Commit the changes
        applicationProfile.FlushChanges();
    }
    catch (IceLibException iceLibException)
    {
        // TODO
    }
    catch (Exception exception)
    {
        // TODO
    }
}

private bool IsOldSettingEligibleForMigration(ProfileItem profileItem)
{
    if (profileItem == null) return false;

    // TODO:  Determine if this setting should be migrated or not.

    return true;
}

private string ConvertOldSettingValue(ProfileItem profileItem)
{
    if (profileItem == null) throw new ArgumentNullException("profileItem");

    // TODO:  Convert the current setting value if needed.

    if (profileItem.IsPlainTextValue)
    {
        // TODO:  Convert the string value.
    }
    else
    {
        // TODO:  Convert the object value to a string.
    }

    return String.Empty;
}

Back to Introduction


Getting Started with Visual Studio

[image]

IceLib Technical Reference
Getting Started with Visual Studio
Send Feedback

There are a few requirements that must be met in order to setup a custom IceLib-based application from within Visual Studio, regardless of the version of Visual Studio used.

  • Use .NET Framework 3.5 or greater. Client Profile versions of .NET Frameworks cannot be used due to IceLib dependencies.
  • Select the appropriate processor architecture (either x86 or x64).
  • Include the necessary IceLib binary references. Note that the unmanaged assembly dependencies required by IceLib do not get copied to the project's output folder when adding the reference, so they will have to be copied manually.

Step-by-step instructions on setting up a custom IceLib-based application in Visual Studio.

Note
Visual Studio 2010 is used in this example, but any version of Visual Studio that supports the .NET Framework 3.5 or greater can be used.

After starting Visual Studio, go to the "New Project" screen. Select ".NET Framework 3.5", or a later version of the .NET Framework. After selecting the appropriate project type (Windows Forms Application, Console Application, etc.), give the project an appropriate name. The "New Project" screen should resemble something similar to the following:

Visual Studio New Project

After clicking the "OK" button, the next step is to setup the required project-specific properties. To do this, right click the project node in the Solution Explorer, and select "Properties". If using Visual Studio 2010 or earlier (Visual Studio 2012 defaults to not use the Client Profile), it will be necessary to change the "Target framework" from the "Client Profile". On the "Application" tab, be sure that the "Target framework" has an appropriate framework version selected - any .NET Framework version 3.5 or greater will work, as long as it is not a "Client Profile". Changing this will require the solution to be reloaded, in which case the properties window will need to be re-opened:

Visual Studio Application Properties

After changing (or verifying) the "Target framework", the project's "Platform target" will need to be changed on the "Build" tab. By default, Visual Studio will select "Any CPU" for this; however, because of the unmanaged assemblies that IceLib has dependencies on, a specific target must be selected. If the IceLib references that this project will be using are the x86 binaries (which is the typical case), select "x86" for the "Platform target"; otherwise, if the x64 binaries will be used, select "x64" for the "Platform target":

Visual Studio Build Properties

Due to the fact that all dependent IceLib binaries must reside in the output folder of the project, it will be necessary to copy those binaries over. An easy way to accomplish this is with pre-build commands. On the "Build Events" tab, there is a section where these commands can be added:

Visual Studio Pre-Build Properties
An example pre-build command could be "xcopy "$(ProjectDir)..\..\bin\*" "$(TargetDir)" /i /d /y" (without the lead and end quotes). This command, which will run prior to the project building, assumes that the IceLib SDK installation is located 2 folders back from the project location - this will have to be modified to fit individual needs. It will copy all files from the "bin" folder into the project's output folder. It assumes that the destination is a folder and will create it if it doesn't already exist (/i argument), will only copy files that have not been changed (/d argument), and will suppress overwrite prompts (/y argument). The IceLib SDK's Example Applications use this method to handle copying the dependent binaries over.

After making the necessary changes, the next step is to add in the IceLib references to the project. In the Solution Explorer, right click on the "References" node in the project and select "Add Reference". Browse to the "bin" folder under the installation folder of the IceLib SDK and select the ININ.IceLib* binaries that will be needed in the project. Be sure that the added references are set to "Copy Local" in the "Properties" window:

Visual Studio IceLib Properties
Visual Studio should set "Copy Local" to true by default, but it should be verified that this behavior stays the same with the version of Visual Studio being used. If "Copy Local" is not set to true, then the referenced binary will not be copied to the output folder, and as stated previously, these binaries need to be located in the same folder that the custom IceLib-based application is, in order for it to function properly.


Getting Started with Connecting to the Server

[image]

IceLib Technical Reference
Getting Started with Connecting to the Server
Send Feedback

The ININ.IceLib.Connection namespace contains classes for connecting to an Interaction Center server. The Session class is used to establish a connection using IceLib. Nearly every operation performed with IceLib is done relative to the Session class instance that was initially used to connect to the server.

When establishing the IceLib session, several "settings" classes must be provided, including one for authentication (a class derived from AuthSettings), one for which Interaction Center to connect to (HostSettings), one containing some general session behavior (SessionSettings), and one for station settings (a class derived from StationSettings).

Jump to a code example:

  • Establishing a Basic Connection
  • Establishing a Connection with Single Sign-On
  • Creating a Session on Behalf of Another User

Establishing a Basic Connection

The following example illustrates how to establish a basic connection.

Note

This example's use of the basic Interaction Center or Windows authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the appropriate Allow Windows authentication or Allow IC authentication setting enabled. See the Authentication concept page for more information.

CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Back to Introduction

Establishing a Connection with Single Sign-On

The following example illustrates how to establish a Single Sign-On connection.

Note

This example's use of the Security Token Service authentication type requires an Identity Provider to be configured in Interaction Administrator. See the Authentication concept page for more information.

CopyC#
public void EstablishSsoConnection()
{
    // For this example, the focus is on the authSettings part of the connection process, so we'll skip over the following parts.
    // See other examples for details on these settings classes.
    Session session = new Session();
    SessionSettings sessionSettings;
    HostSettings hostSettings;
    StationSettings stationSettings;
    CreateExampleSettings(out sessionSettings, out hostSettings, out stationSettings);

    // Optionally, the SSO user ID and password can be explicitly specified.
    // This GetSsoCredentials method is representative of custom application code that would obtain those values.
    string ssoUserName;
    SecureString ssoPassword;
    GetSsoCredentials(out ssoUserName, out ssoPassword);

    // SSO authentication provider(s) are configured in Interaction Administrator.
    // Then, one must be selected either programmatically or by prompting the user.
    string isoLanguage = "en-US";
    AllowableAuthentications allowableAuthentications = Session.GetAllowableAuthentications(hostSettings, isoLanguage);
    // This PromptForSelectedProvider method is representative of custom application code that would prompt for the selected provider.
    AuthProviderDefinition providerDefinition = PromptForSelectedProvider(allowableAuthentications.AuthProviderDefinitions);

    SecurityTokenServiceAuthParameters stsParams = new SecurityTokenServiceAuthParameters();
    // Optionally, the PresenterFactory allows for custom prompting of SSO credentials.
    stsParams.PresenterFactory = PresenterFactory;
    // Optionally, the SSO user ID and password can be explicitly specified.
    stsParams.UserName = ssoUserName;
    stsParams.Password = ssoPassword;
    // IceLib will automatically use persisted STS tokens, for single sign-on behavior, if these properties are set to true.
    // They default to false, requiring explicit opt-in.
    stsParams.UsePersistedToken = true;
    stsParams.PersistToken = true;

    // The SSO authSettings class is constructed from the selected AuthProviderDefinition and the STS parameters.
    SecurityTokenServiceAuthSettings authSettings = new SecurityTokenServiceAuthSettings(providerDefinition.ProviderContext, stsParams);

    // Note: Consider using the ConnectAsync method to avoid blocking the thread.
    session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);
}

internal class MySecurityTokenServicePresenter : SecurityTokenServicePresenter
{
    private readonly Control _ParentControlForInvoke;

    public MySecurityTokenServicePresenter(SecurityTokenServicePresenterContext securityTokenServicePresenterContext, Control parentControlForInvoke)
        : base(securityTokenServicePresenterContext)
    {
        _ParentControlForInvoke = parentControlForInvoke;
    }

    protected override void HandleTryPromptForBrowserCredentials(SingleSignOnRequestData singleSignOnRequestData)
    {
        // This method can be overridden in order to show a browser dialog to use an external Identity Provider.

        // In order to ensure the proper flow of events for Single Sign On, when using a 3rd
        // party Identity Provider within a browser window, the operation must be performed
        // synchronously.  If performed asynchronously, the Single Sign On flow will move forward
        // without receiving the proper credentials, and authentication will fail.
        _ParentControlForInvoke.Invoke(
            new MethodInvoker(() =>
            {
                // This dialog would need to be created by the custom application.
                // This dialog will need to have some form of WebBrowser control that can
                // utilize the SriptableObject from the singleSignOnRequestData.
                var browserDialog = new BrowserDialog();

                singleSignOnRequestData.ScriptableObject.RequestBrowserClose += (s, args) => browserDialog.Close();
                browserDialog.SetSingleSignOnRequestData(singleSignOnRequestData);
                browserDialog.ShowDialog(_ParentControlForInvoke);
            }));
    }

    protected override bool HandleTryPromptForCredentials(out string userName, out SecureString password)
    {
        // This method can be overridden in order to prompt the user for their SSO credentials.
        string promptedSsoUserName = "<prompted SSO user ID>";
        string promptedSsoPassword = "<prompted SSO password>";

        userName = promptedSsoUserName;
        password = new SecureString();
        foreach (char c in promptedSsoPassword)
        {
            password.AppendChar(c);
        }
        return true;
    }
}

internal SecurityTokenServicePresenter PresenterFactory(SecurityTokenServicePresenterContext securityTokenServicePresenterContext)
{
    // Simple factory to create the SecurityTokenServicePresenter class
    return new MySecurityTokenServicePresenter(securityTokenServicePresenterContext, _ParentControlForInvoke);
}

The following example illustrates the basic code necessary for the Web Browser Dialog.

CopyC#
public partial class BrowserDialog : Form
{
    public BrowserDialog()
    {
        InitializeComponent();
    }

    internal void SetSingleSignOnRequestData(SingleSignOnRequestData singleSignOnRequestData)
    {
        _WebBrowser.ObjectForScripting = singleSignOnRequestData.ScriptableObject;
        _WebBrowser.Navigate(singleSignOnRequestData.SingleSignOnUri);
    }
}

Back to Introduction

Creating a Session on Behalf of Another User

The following example shows how to monitor for sessions created by other users and then how to create a proxy connection to the IC server for another user, based on the authentication credentials of a special "elevated rights" user.

Note

This example's use of the Windows authentication type requires an Identity Provider to be configured in Interaction Administrator. See the Authentication concept page for more information.

CopyC#
private void StartSessionWatch()
{
    // For this example, the focus is on watching for sessions created by a particular target User, then creating a proxy connection as
    // if we were that target User, but authenticated using a special "elevated rights" user's credentials.  This is a model used by some
    // server-side integrations, where the server-side component connects as the single "elevated rights" user and can then perform
    // operations on behalf of other users in the system.

    // We'll skip over creation of this server-side application's Session.
    // See other examples for basic details on establishing a connection with the server.
    Session session = CreateSessionForElevatedRightsUser();

    // For this example, we create a "session watch" to monitor for other applications/users that are connecting to the server.
    // Alternatively, a "proxy login" could be create for a user that was obtained based on some other application logic.
    SessionWatch sessionWatch = new SessionWatch(session);

    // Register the event handlers for watched session changes.
    sessionWatch.SessionWatchedUserAdded += SessionWatchedUserAdded;
    sessionWatch.SessionWatchedUserRemoved += SessionWatchedUserRemoved;

    // A session watch can watch for sessions for a given IC User, for an IC Station, or for a Machine.
    // For this example, we'll assume that a particular IC User is to be watched, based on external application needs.
    string targetIcUserId = "<target user ID>";

    SessionWatchId[] sessionsToWatch = new SessionWatchId[]
    {
        new SessionWatchId(SessionWatchType.User, targetIcUserId)
    };

    // Start monitoring for watched session changes for the specified criteria.
    ReadOnlyCollection<SessionWatchSettings> watchSettings = sessionWatch.StartWatching(sessionsToWatch);

    // The result contains any existing connected sessions that match the session watch criteria.
    // The SessionWatchedUser* events will be invoked as matching sessions are connected/disconnected.
    foreach (SessionWatchSettings setting in watchSettings)
    {
        // For this example, we plan on creating a proxy connection on behalf of the target user.
        EstablishProxyConnectionToSession(setting.UserName,
                                          setting.SessionSettings,
                                          session.GetHostSettings(),
                                          setting.StationSettings);
    }
}

private void EstablishProxyConnectionToSession(string targetUserId,
                                               SessionSettings sessionSettings,
                                               HostSettings hostSettings,
                                               StationSettings stationSettings)
{
    // Here we assume that the current windows account under which this application is running is the one associated with
    // the elevated rights user.
    //
    // Note that the IC user that is used to "vouch for" targetUserId's login must have "elevated rights" that allow it to serve
    // as a proxy for the authentication of other Interaction Center users.  The "elevated rights" user should be created
    // specifically for the server-side application's use, with very few rights other than the ability to proxy authentication.
    //
    // The "elevated rights" user must have a specific "Proxy Logins" Access Control right configured on their Interaction Center
    // User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control
    // settings.
    ProxyWindowsAuthSettings proxyAuthSettings = new ProxyWindowsAuthSettings(targetUserId, ProxyTargetUserType.ICUser);

    // Alternatively, explicit IC user credentials (i.e. user ID and password) can be specified, but then often those credentials
    // are persisted somewhere to configure the custom application, so this is usually less secure than using Windows-based
    // authentication.
    // string elevatedRightsIcUserId = "<elevated rights user ID>";
    // string elevatedRightsIcPassword = "<elevated rights user password>";
    // ProxyAuthSettings proxyAuthSettings = new ProxyAuthSettings(elevatedRightsIcUserId, elevatedRightsIcPassword, userName);

    // Next, we create a new, separate, Session for the connection of the proxy login.
    // This Session will have the "context" (e.g. rights) of the target User's account, not of the elevated rights user's account.
    //
    // What makes this a "proxy login" is that either ProxyWindowsAuthSettings or ProxyAuthSettings is used as the authSettings parameter.
    Session proxySession = new Session();

    // For this example, we intend to make calls on behalf of the user, using their station.
    // So, we re-use the same station that was part of the session watch result for the user being proxied.
    proxySession.Connect(sessionSettings, hostSettings, proxyAuthSettings, stationSettings);
}

Back to Introduction


Getting Started with Configuration

[image]

IceLib Technical Reference
Getting Started with Configuration
Send Feedback

The ININ.IceLib.Configuration namespace contains classes for configuring an IC Server. ININ.IceLib.Configuration has rich support for the RoleConfiguration, UserConfiguration and WorkgroupConfiguration objects, as well as basic support for other objects such as SiteConfiguration and WrapUpCodeConfiguration.

There are a number of classes within the ININ.IceLib.Configuration namespace that provide support to the classes mentioned in the preceding summary. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

List-Based Configuration Objects

There are a number of object classes that are used to get properties for configuration objects that can have multiple instances on the server (distinguished by their ConfigurationId). These consist of ListConfigurationObject-derived classes. They are searched, with the results being cached, using a ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>-derived class. The search is comprised of a QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance which encapsulates a filter, a sort, the properties to be retrieved, the rights to be applied, and the result count limit. An example of this type of configuration object list is UserConfigurationList which is used to obtain UserConfiguration instances.

Some of these list-based configuration objects also support being edited, created, or deleted. These consist of EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>-derived classes and the EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>-derived classes used to search and cache them. The EditableConfigurationList-derived class has support for create and the EditableListConfigurationObject-derived class has support for edit and delete.

Container-Based Configuration Objects

There are a number of object classes that are used to get properties for configuration objects that can only have a single instance on the server. These consist of ContainerConfigurationObject-derived classes. They are queried, with the results being cached, using a ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>-derived class. The query is comprised of which properties are to be retrieved, and can also be specified with a ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance that encapsulates the properties to be retrieved and the rights to be applied.

Some of these container-based configuration objects also support being edited (but not created or deleted). These consist of EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>-derived classes. The EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>-derived class has support for edit. An example of this type of configuration object list is SystemConfigurationContainer which is used to obtain a SystemConfiguration instance.

List-Based Configuration Objects With a Parent/Child Relationship. There are a number of list-based configuration objects that have a parent-child relationship. A parent-child relationship is one in which the parent object has a property that contains a collection of child objects. Working with these types of objects are a little different from working with a standard list-based object. Currently, the objects that have such a relationship are: Parent object CtiConfiguration, with child object CtiAttributeMapConfiguration; parent object AnalyzerKeywordSetConfiguration, with child object AnalyzerKeywordConfiguration; parent object ScheduleConfiguration, with child object ScheduleRecurrenceConfiguration; and parent object WorkgroupConfiguration, with child object WorkgroupMonitoredMailboxConfiguration.

Querying List-Based Parent/Child Configuration Objects. A number of new steps needs to be completed to be able to query for a parent and child object. These steps involve using a HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object with an associated QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)>-derived object, in addition to the QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Adding new List-Based Parent/Child Configuration Objects. Adding a new parent/child configuration object differs only slightly from what is needed to add a typical list-based configuration object. The additional steps include creating the child object, and adding it to the associated collection property on the parent object.

Note

The following are some examples of using the configuration namespace classes. It is assumed that an active session is present, a ConfigurationManager instance has been created with the session, and saved in a variable named "_configurationManager".

Jump to a code example:

  • Adding a New Workgroup
  • Retrieving Id/DisplayName of Viewable Skills
  • Retrieving All Properties of Administerable Roles
  • Deleting a Skill
  • Retrieving the Users Assigned to a Specific Role
  • Updating the Current User's Home Phone Number
  • Handling Validation Exceptions During a Commit
  • Watching for Workgroup Changes and Deletions
  • Querying the System Languages
  • Querying Parent and Child Objects (with Analyzer Keywords)
  • Creating Parent and Child Objects (with Analyzer Keywords)
  • Setting the DisplayName of a Configuration Object
  • Setting the DisplayName of a UserConfiguration Object

Adding a New Workgroup

The following example illustrates how to use configuration to add a new workgroup to the IC Server.

CopyC#
var configurationList = new WorkgroupConfigurationList(_configurationManager);
var configurationObject = configurationList.CreateObject();

// Begin editing the object
configurationObject.PrepareForEdit();

// Set the ID
configurationObject.SetConfigurationId("New Workgroup");

// Set more properties
configurationObject.Extension.Value = "12345";

// Save the object
configurationObject.Commit();

Back to Introduction

Retrieving Id/DisplayName of Viewable Skills

The following example illustrates the bare minimum code needed to retrieve an Id/DisplayName listing of skills. By default, if no specific properties are requested, then only Id/DisplayName will be returned. If no rights are specified, then the results will have the associated view right applied. If no result limit is specified, because only Id and DisplayName will be requested, then an unlimited number of results will be returned.

CopyC#
var configurationList = new SkillConfigurationList(_configurationManager);
var querySettings = configurationList.CreateQuerySettings();

configurationList.StartCaching(querySettings);

foreach (var configurationObject in configurationList.GetConfigurationList())
{
    // Get the ID and DisplayName
    var id = configurationObject.ConfigurationId.Id;
    var displayName = configurationObject.ConfigurationId.DisplayName;

    // Do something else...
}

configurationList.StopCaching();

Back to Introduction

Retrieving All Properties of Administerable Roles

The following example illustrates how to retrieve all the properties of all roles that the session user has administrative rights to. This query will only return a maximum of 300 results because more than 5 properties are being requested.

CopyC#
var configurationList = new RoleConfigurationList(_configurationManager);
var querySettings = configurationList.CreateQuerySettings();

querySettings.SetPropertiesToRetrieveToAll();
querySettings.SetRightsFilterToAdmin();

configurationList.StartCaching(querySettings);

foreach (var configurationObject in configurationList.GetConfigurationList())
{
    // Get the ID and DisplayName
    var id = configurationObject.ConfigurationId.Id;
    var displayName = configurationObject.ConfigurationId.DisplayName;

    // Get some other properties
    foreach (var configurationId in configurationObject.Users.Value)
    {
        // Do something with the user...
        var userId = configurationId.Id;
        var userName = configurationId.DisplayName;
    }

    // Do something else...
}

configurationList.StopCaching();

Back to Introduction

Deleting a Skill

The following example illustrates the code needed to delete a skill from the IC Server. Note that the object where Delete is invoked is an instance of SkillConfiguration.

CopyC#
configurationObject.Delete();

Back to Introduction

Retrieving the Users Assigned to a Specific Role

The following example shows how to query the list of users that are assigned to a specific role. In this example, the only requested property is Users. Additionally, there is a filter placed on the the Id to match the supplied role name.

CopyC#
var configurationList = new RoleConfigurationList(_configurationManager);
var querySettings = configurationList.CreateQuerySettings();

querySettings.SetFilterDefinition(RoleConfiguration.Property.Id, roleName, FilterMatchType.Exact);
querySettings.SetPropertiesToRetrieve(new[] { RoleConfiguration.Property.Users });

configurationList.StartCaching(querySettings);

foreach (var configurationObject in configurationList.GetConfigurationList())
{
    // Do something
}

configurationList.StopCaching();

Back to Introduction

Updating the Current User's Home Phone Number

The following example illustrates the code needed update the home phone number of the current user. The code filters Id with the session's userid, applies the admin rights filter, and only retreives the property being updated. After retrieving the UserConfiguration object, the code updates and commits the phone number value.

CopyC#
var configurationList = new UserConfigurationList(_configurationManager);
var querySettings = configurationList.CreateQuerySettings();

// Get the currently logged on user
querySettings.SetFilterDefinition(UserConfiguration.Property.Id, _session.UserId, FilterMatchType.Exact);
// Since we are updating the object, request admin rights
querySettings.SetRightsFilterToAdmin();
// Request the phone number property
querySettings.SetPropertiesToRetrieve(new[] { UserConfiguration.Property.PersonalInformation_PhoneNumberOfHome1 });

configurationList.StartCaching(querySettings);

var configurationObject = configurationList.GetConfigurationList().FirstOrDefault();

if (configurationObject != null)
{
    // Begin editing the object
    configurationObject.PrepareForEdit();
    // Set the value
    configurationObject.PersonalInformation.PhoneNumberOfHome1.Value = new BasicPhoneNumber(phoneNumber, String.Empty, false);
    // Save the object
    configurationObject.Commit();
}

// Call StopCaching() to clean up resources
configurationList.StopCaching();

Back to Introduction

Handling Validation Exceptions During a Commit

The following example illustrates how to handle ConfigurationValidationExceptions when performing a Commit. For brevity, the needed code to perform a commit is not in this example. See the Updating the Current User's Home Phone Number example to see how to update a configuration object.

CopyC#
try
{
    // The rest of the code needed for Commit() is missing to shorten this example,
    //  see the "UpdateMyPhoneNumber" example to see a full usage of Commit().
    configurationObject.Commit();
}
catch (ConfigurationValidationException ex)
{
    foreach (var configurationValidationIssue in ex.GetValidationIssues<WorkgroupConfiguration.Property>())
    {
        var messsage = configurationValidationIssue.DisplayMessage;
        var property = configurationValidationIssue.PropertyEnum;
        var value = configurationValidationIssue.PropertyValue;
        var validator = configurationValidationIssue.Validator;

        // Do something...
    }
}

Back to Introduction

Watching for Workgroup Changes and Deletions

The following example illustrates how to query a WorkgroupConfigurationList, and monitor it for changes. Because this example is retrieving all properties, only the first 300 matches will be returned.

Note
Change and delete notifications on the watched list will only include those objects that existed at the time the watch was started. For instance, in this code example, once the watch is started, if a new workgroup gets added to the IC Server, it will not be included in this watch. The only way to include a new object after the initial watch, is to stop and restart the current watch.

Note
Notice that the events are subscribed to before the watch is started. In order to guarantee that no notifications are missed, the event handlers need to be subscribed to before the watch is started.

CopyC#
_configurationList = new WorkgroupConfigurationList(_configurationManager);
var querySettings = _configurationList.CreateQuerySettings();

querySettings.SetPropertiesToRetrieveToAll();

// Events will only be fired for objects that match the filtered objects as they existed at the start of the watch.
//  If a new object is added to the IC Server after the watch was started, they will not be included in this watch.
_configurationList.ConfigurationObjectsChanged += ConfigurationObjectsChanged;
_configurationList.ConfigurationObjectsRemoved += ConfigurationObjectsRemoved;
_configurationList.StartWatching(querySettings);

The following example illustrates the changed and removed event handler signatures, and the event arguments parameters.

CopyC#
private static void ConfigurationObjectsChanged(object sender, ConfigurationObjectChangesEventArgs<WorkgroupConfiguration, WorkgroupConfiguration.Property> e)
{
    foreach (var keyValuePair in e.ObjectsChanged)
    {
        // Do something
        var configurationObject = keyValuePair.Key;
        var propertiesChanged = keyValuePair.Value;
    }
}

private static void ConfigurationObjectsRemoved(object sender, ConfigurationWatchEventArgs<WorkgroupConfiguration> e)
{
    foreach (var configurationObject in e.ObjectsAffected)
    {
        // Do something
    }
}

The following example illustrates the code that needs to be run when an IceLib integrated application no longer needs the associated list watch. This could be in cases where, for instance, a form is closed, or when the application receives a ConnectionStateChanged notification where the connection is Down.

CopyC#
if (_configurationList == null || !_configurationList.IsWatching) return;

_configurationList.ConfigurationObjectsChanged -= ConfigurationObjectsChanged;
_configurationList.ConfigurationObjectsRemoved -= ConfigurationObjectsRemoved;
_configurationList.StopWatching();

Back to Introduction

Querying the System Languages

The following example illustrates how to retrieve all of the languages supported on the IC Server. This requires using the SystemConfigurationContainer.

CopyC#
var configurationContainer = new SystemConfigurationContainer(_configurationManager);

configurationContainer.StartCaching(new[]
                                        {
                                            SystemConfiguration.Property.DefaultLanguage,
                                            SystemConfiguration.Property.Languages
                                        });

var configurationObject = configurationContainer.GetConfigurationItem();

// Do something

configurationContainer.StopCaching();

Back to Introduction

Querying Parent and Child Objects (with Analyzer Keywords)

The following example illustrates how to retrieve all of the configured analyzer keywords on the IC Server. Because analyzer keywords represent objects with a parent and a child relationship, querying them requires a few more steps, and involves the following objects: AnalyzerKeywordSetConfigurationList, HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>, QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, AnalyzerQueryChildrenSettings, AnalyzerKeywordSetConfiguration and AnalyzerKeywordConfiguration.

CopyC#
// Create the parent list object.
var parentConfigurationList = new AnalyzerKeywordSetConfigurationList(_configurationManager);
// Create the parent query settings.
var parentQuerySettings = parentConfigurationList.CreateQuerySettings();
// Create the child query settings.
var childQuerySettings = parentConfigurationList.CreateKeywordQuerySettings();
// Create the query children settings.
var queryChildrenSettings = new AnalyzerQueryChildrenSettings();

// Setup the child query, and assign it to the query children settings property.
childQuerySettings.SetPropertiesToRetrieveToAll();
queryChildrenSettings.Keyword = childQuerySettings;

// Setup the parent query settings, and assign the child query.
// To get the child object, you must be sure to include the child property
// in the query.
parentQuerySettings.SetPropertiesToRetrieveToAll();
parentQuerySettings.SetRightsFilterToView();
// The query children settings must be included to get the child objects.
parentQuerySettings.SetChildQuerySettings(queryChildrenSettings);

// Start caching on the parent query settings.
try
{
    parentConfigurationList.StartCaching(parentQuerySettings);
}
catch
{
    // Do something meaningful here.
}

if (parentConfigurationList.IsCaching)
{
    // Get the configuration list.
    var analyzerKeywordSets = parentConfigurationList.GetConfigurationList();

    foreach (var analyzerKeywordSet in analyzerKeywordSets)
    {
        // Do something with the child objects.
        if (analyzerKeywordSet.Keywords.Value.Count > 0)
        {
        }
    }

    // Cleanup.
    parentConfigurationList.StopCaching();
}

Back to Introduction

Creating Parent and Child Objects (with Analyzer Keywords)

The following example illustrates how to create a new analyzer keyword set with a single analyzer keyword on the IC Server. Because analyzer keywords represent objects with a parent and a child relationship, creating them requires a few more steps, and involves the following objects: AnalyzerKeywordSetConfigurationList, AnalyzerKeywordSetConfiguration and AnalyzerKeywordConfiguration.

CopyC#
// Create the parent list object.
var parentConfigurationList = new AnalyzerKeywordSetConfigurationList(_configurationManager);
// Create the parent object.
var keywordSet = parentConfigurationList.CreateObject();

// Put it in edit mode.
keywordSet.PrepareForEdit();

// Set any needed parent properties.
keywordSet.SetConfigurationId(Guid.NewGuid().ToString());
keywordSet.SetDisplayName("My New Keyword Set");
keywordSet.Category.Value = "Category";

// Setup a single keyword.
// Create the keyword.
var analyzerKeyword = parentConfigurationList.CreateAnalyzerKeyword();

// Put it in edit mode.
analyzerKeyword.PrepareForEdit();

// Set any needed child properties.
analyzerKeyword.SetConfigurationId(Guid.NewGuid().ToString());
analyzerKeyword.SetDisplayName("Keyword");
analyzerKeyword.UserWords.Value.Add("Keyword");

// Add the child object to the parent property.
keywordSet.Keywords.Value.Add(analyzerKeyword);

try
{
    // Save the parent object, which will save the child objects as well.
    keywordSet.Commit();
}
catch (ConfigurationValidationException cvex)
{
    // Handle any validation exceptions
}

Back to Introduction

Setting the DisplayName of a Configuration Object

The following example illustrates how to set the DisplayName for a configuration object. Note that this does not work for the UserConfiguration object - a separate example is available to show how to set that.

CopyC#
var configurationList = new AccessControlGroupConfigurationList(_configurationManager);
var configurationObject = configurationList.CreateObject();

// Begin editing the object
configurationObject.PrepareForEdit();

// Set the ID
configurationObject.SetConfigurationId("ACG ID");

// Set the DisplayName - note that not all objects support setting a DisplayName.
// Documentation on SetDisplayName() shows which objects can have DisplayNames
// that are different from the ConfigurationId.
configurationObject.SetDisplayName("New ACG");

// TODO:  Set more properties

// Save the object
configurationObject.Commit();

Back to Introduction

Setting the DisplayName of a UserConfiguration Object

The following example illustrates how to set the DisplayName for a UserConfiguration object. DisplayNames for these objects are stored in the mailbox properties, and additional work has to be done to set them.

CopyC#
var configurationList = new UserConfigurationList(_configurationManager);
var querySettings = configurationList.CreateQuerySettings();

// Get the currently logged on user
querySettings.SetFilterDefinition(UserConfiguration.Property.Id, _session.UserId, FilterMatchType.Exact);
// Since we are updating the object, request admin rights
querySettings.SetRightsFilterToAdmin();
// Request the mailbox properties - note that we have to retrieve all of the mailbox properties
querySettings.SetPropertiesToRetrieve(
    UserConfiguration.Property.Mailbox_DirectoryMoniker,
    UserConfiguration.Property.Mailbox_DisplayName,
    UserConfiguration.Property.Mailbox_EmailAddress,
    UserConfiguration.Property.Mailbox_MailboxMoniker,
    UserConfiguration.Property.Mailbox_Type);

configurationList.StartCaching(querySettings);

var configurationObject = configurationList.GetConfigurationList().FirstOrDefault();

if (configurationObject != null)
{
    // Create appropriate MailboxSettings, with a new DisplayName.  Other MailboxSettings-derived
    // objects exist, but for simplicity, we'll just use the NoMailboxSettings.
    var mailboxSettings = new NoMailboxSettings("New Display Name");

    // Apply the MailboxSettings - note that this does not save the object to the IC Server.
    configurationObject.Mailbox.ApplyMailboxSettings(mailboxSettings);

    // Save the object
    configurationObject.Commit();
}

configurationList.StopCaching();

Back to Introduction


Getting Started with Interactions

[image]

IceLib Technical Reference
Getting Started with Interactions
Send Feedback

The ININ.IceLib.Interactions namespace contains classes for manipulating Interaction Center interaction queues, watching for specific interaction changes, creating interactions (calls, emails, chats, generic objects, etc.), resolving email recipients, getting a user's interaction history, and receiving interaction alerting events. It also allows for handling screen pops, working with agent assistance requests, assign wrap up codes, and retrieving phone number details.

In the Interaction Center system, an 'interaction' is an object such as a call, chat, email, queues, watching for specific interaction changes, creating interactions (calls, emails, chats, generic objects, etc.), resolving email recipients, getting a user's interaction history, and receiving interaction alerting events. It also allows for handling screen pops, working with agent assistance requests, assign wrap up codes, and retrieving phone number details.

Note

For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Note

The following are some examples of using the interactions namespace classes. It is assumed that an active session is present, an InteractionsManager instance has been created with the session, and saved in a variable named "_interactionsManager".

Jump to a code example:

  • Watching for Queue Contents Changes in Bulk
  • Watching for Queue Contents Changes Individually
  • Watching for Interaction Changes
  • Making a call
  • Creating a generic interaction
  • Watching for screen pop events

Watching for Queue Contents Changes in Bulk

The following example illustrates how to monitor an InteractionQueue for changes in bulk. It will watch for all Interactions on a given Queue as well as other related events. An example use of this type of watch would be as in the Interaction Client .Net Edition's "My Interactions" tab.

Note
If a QueueContentsChanged event handler has been added to the InteractionQueue instance, then no invididual events (e.g. InteractionAdded) will be received even if event handlers have been added.

Note
Notice that the events are subscribed to before the watch is started. In order to guarantee that no notifications are missed, the event handlers need to be subscribed to before the watch is started.

CopyC#
// For this example, we are interested in the "MyInteractions" queue of a user with ID "userid".
QueueId queueId = new QueueId(QueueType.MyInteractions, "userid");
_interactionQueue = new InteractionQueue(_interactionsManager, queueId);

// For this example, we are interested in watching the StateDescription and RemoteId attributes of the Interactions
// in the InteractionQueue. The watched attributes can also include custom attribute names.
//
// Any attribute that will later be retrieved from the interaction must be included in an Interaction or InteractionQueue
// watch that the Interaction instance is part of.
string[] watchedAttributes = new[] { InteractionAttributeName.StateDescription, InteractionAttributeName.RemoteId };

// The QueueContentsChanged event bundles up multiple interaction and conference interaction adds, removes, and changes.
// This event is preferred for workgroup and line queues for performance.  It can be used for all queues for convenience.
// (If there is a QueueContentsChanged event handler, then the individual added/removed/changed events will not be fired.)
_interactionQueue.QueueContentsChanged += QueueContentsChanged;
_interactionQueue.LostRights += QueueLostRights;

// Subscribe to events before starting the watch.
_interactionQueue.StartWatching(watchedAttributes);

The following example illustrates the event handler signatures, and the event arguments parameters.

CopyC#
private static void QueueContentsChanged(object sender, QueueContentsChangedEventArgs e)
{
    // The event args bundles queue contents changes together for improved performance.
    // It contains collections of all the interaction adds, removes, and changes
    // as well as collections of all the conference item adds, removes, and changes.

    // For removes, this includes the interactions and conference interactions that were removed.

    // For adds and changes, this includes the interactions and conference interactions that changed,
    // and the the names of the watched attributes that changed.

    // The attribute names correspond with InteractionAttributeName entries
    // (or the similar *AttributeName classes for specific interaction types),
    // or the names might correspond to custom attributes or attributes that aren't explicitly exposed through IceLib.

    // For adds and changes, the values of the attributes can be retrieved from the related Interaction instance's
    // properties and methods.
}

private static void QueueLostRights(object sender, EventArgs e)
{
    // This event will be sent if the session user loses rights to the queue.
}

The following example illustrates the code that needs to be run when an IceLib integrated application no longer needs the associated queue watch. This could be in cases where, for instance, a form is closed, or when the application receives a ConnectionStateChanged notification where the connection is Down.

CopyC#
if (_interactionQueue == null || !_interactionQueue.IsWatching()) return;

// Removing event handlers helps avoid dangling references.
_interactionQueue.QueueContentsChanged -= QueueContentsChanged;
_interactionQueue.LostRights -= QueueLostRights;

// Once a watch is no longer needed, it must be stopped so that IceLib/IC can clean up caches appropriately.
_interactionQueue.StopWatching();

Back to Introduction

Watching for Queue Contents Changes Individually

The following example illustrates how to monitor an InteractionQueue for changes individually. It will watch for all Interactions on a given Queue as well as other related events.

Note
The individual events (e.g. InteractionAdded) will only be received if no QueueContentsChanged event handler has been added to the InteractionQueue instance.

Note
Notice that the events are subscribed to before the watch is started. In order to guarantee that no notifications are missed, the event handlers need to be subscribed to before the watch is started.

CopyC#
// For this example, we are interested in the "MyInteractions" queue of a user with ID "userid".
QueueId queueId = new QueueId(QueueType.MyInteractions, "userid");
_interactionQueue = new InteractionQueue(_interactionsManager, queueId);

// For this example, we are interested in watching the StateDescription and RemoteId attributes of the Interactions
// in the Queue. The watched attributes can also include custom attribute names.
//
// Any attribute that will later be retrieved from the Interaction must be included in an Interaction or InteractionQueue
// watch that the Interaction instance is part of.
string[] watchedAttributes = new[] { InteractionAttributeName.StateDescription, InteractionAttributeName.RemoteId };

// Individual interaction and conference interaction adds/removes/changes can be received,
// as an alternative to the "batching" of QueueContentsChanged.
// (If there is a QueueContentsChanged event handler, then the individual added/removed/changed events will not be fired.)
_interactionQueue.InteractionAdded += QueueInteractionAdded;
_interactionQueue.InteractionChanged += QueueInteractionChanged;
_interactionQueue.InteractionRemoved += QueueInteractionRemoved;
_interactionQueue.ConferenceInteractionAdded += QueueConferenceInteractionAdded;
_interactionQueue.ConferenceInteractionChanged += QueueConferenceInteractionChanged;
_interactionQueue.ConferenceInteractionRemoved += QueueConferenceInteractionRemoved;
_interactionQueue.LostRights += QueueLostRightsEventHandler;

// Subscribe to events before starting the watch.
_interactionQueue.StartWatching(watchedAttributes);

The following example illustrates the event handler signatures, and the event arguments parameters.

CopyC#
private void QueueInteractionAdded(object sender, InteractionAttributesEventArgs e)
{
    // The event args contains the Interaction that was added and the names of the attributes that were watched.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueInteractionChanged(object sender, InteractionAttributesEventArgs e)
{
    // The event args contains the Interaction that changed and the names of the watched attributes that changed.

    // The attribute names correspond with InteractionAttributeName entries
    // (or the similar *AttributeName classes for specific interaction types),
    // or the names might correspond to custom attributes or attributes that aren't explicitly exposed through IceLib.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueInteractionRemoved(object sender, InteractionEventArgs e)
{
    // The event args contains the Interaction that was removed.
}

private static void QueueConferenceInteractionAdded(object sender, ConferenceInteractionAttributesEventArgs e)
{
    // The event args contains the conference Interaction that was added and the names of the attributes that were watched.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueConferenceInteractionChanged(object sender, ConferenceInteractionAttributesEventArgs e)
{
    // The event args contains the conference Interaction that changed and the names of the watched attributes that changed.

    // The attribute names correspond with InteractionAttributeName entries
    // (or the similar *AttributeName classes for specific interaction types),
    // or the names might correspond to custom attributes or attributes that aren't explicitly exposed through IceLib.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueConferenceInteractionRemoved(object sender, ConferenceInteractionEventArgs e)
{
    // The event args contains the conference Interaction that was removed.
}

private static void QueueLostRightsEventHandler(object sender, EventArgs e)
{
    // This event will be sent if the session user loses rights to the queue.
}

The following example illustrates the code that needs to be run when an IceLib integrated application no longer needs the associated queue watch. This could be in cases where, for instance, a form is closed, or when the application receives a ConnectionStateChanged notification where the connection is Down.

CopyC#
if (_interactionQueue == null || !_interactionQueue.IsWatching()) return;

// Removing event handlers helps avoid dangling references.
_interactionQueue.InteractionAdded -= QueueInteractionAdded;
_interactionQueue.InteractionChanged -= QueueInteractionChanged;
_interactionQueue.InteractionRemoved -= QueueInteractionRemoved;
_interactionQueue.ConferenceInteractionAdded -= QueueConferenceInteractionAdded;
_interactionQueue.ConferenceInteractionChanged -= QueueConferenceInteractionChanged;
_interactionQueue.ConferenceInteractionRemoved -= QueueConferenceInteractionRemoved;
_interactionQueue.LostRights -= QueueLostRightsEventHandler;

// Once a watch is no longer needed, it must be stopped so that IceLib/IC can clean up caches appropriately.
_interactionQueue.StopWatching();

Back to Introduction

Watching for Interaction Changes

The following example illustrates how to monitor an Interaction for changes.

Note
Notice that the events are subscribed to before the watch is started. In order to guarantee that no notifications are missed, the event handlers need to be subscribed to before the watch is started.

CopyC#
// For this example, we are interested in the "MyInteractions" queue of a user with ID "userid".
QueueId queueId = new QueueId(QueueType.MyInteractions, "userid");
_interactionQueue = new InteractionQueue(_interactionsManager, queueId);

// For this example, we are interested in watching the StateDescription and RemoteId attributes of the Interactions
// in the Queue. The watched attributes can also include custom attribute names.
//
// Any attribute that will later be retrieved from the Interaction must be included in an Interaction or InteractionQueue
// watch that the Interaction instance is part of.
string[] watchedAttributes = new[] { InteractionAttributeName.StateDescription, InteractionAttributeName.RemoteId };

// Individual interaction and conference interaction adds/removes/changes can be received,
// as an alternative to the "batching" of QueueContentsChanged.
// (If there is a QueueContentsChanged event handler, then the individual added/removed/changed events will not be fired.)
_interactionQueue.InteractionAdded += QueueInteractionAdded;
_interactionQueue.InteractionChanged += QueueInteractionChanged;
_interactionQueue.InteractionRemoved += QueueInteractionRemoved;
_interactionQueue.ConferenceInteractionAdded += QueueConferenceInteractionAdded;
_interactionQueue.ConferenceInteractionChanged += QueueConferenceInteractionChanged;
_interactionQueue.ConferenceInteractionRemoved += QueueConferenceInteractionRemoved;
_interactionQueue.LostRights += QueueLostRightsEventHandler;

// Subscribe to events before starting the watch.
_interactionQueue.StartWatching(watchedAttributes);

The following example illustrates the event handler signatures, and the event arguments parameters.

CopyC#
private void QueueInteractionAdded(object sender, InteractionAttributesEventArgs e)
{
    // The event args contains the Interaction that was added and the names of the attributes that were watched.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueInteractionChanged(object sender, InteractionAttributesEventArgs e)
{
    // The event args contains the Interaction that changed and the names of the watched attributes that changed.

    // The attribute names correspond with InteractionAttributeName entries
    // (or the similar *AttributeName classes for specific interaction types),
    // or the names might correspond to custom attributes or attributes that aren't explicitly exposed through IceLib.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueInteractionRemoved(object sender, InteractionEventArgs e)
{
    // The event args contains the Interaction that was removed.
}

private static void QueueConferenceInteractionAdded(object sender, ConferenceInteractionAttributesEventArgs e)
{
    // The event args contains the conference Interaction that was added and the names of the attributes that were watched.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueConferenceInteractionChanged(object sender, ConferenceInteractionAttributesEventArgs e)
{
    // The event args contains the conference Interaction that changed and the names of the watched attributes that changed.

    // The attribute names correspond with InteractionAttributeName entries
    // (or the similar *AttributeName classes for specific interaction types),
    // or the names might correspond to custom attributes or attributes that aren't explicitly exposed through IceLib.

    // The values of the attributes can be retrieved from the related Interaction instance's properties and methods.
}

private static void QueueConferenceInteractionRemoved(object sender, ConferenceInteractionEventArgs e)
{
    // The event args contains the conference Interaction that was removed.
}

private static void QueueLostRightsEventHandler(object sender, EventArgs e)
{
    // This event will be sent if the session user loses rights to the queue.
}

The following example illustrates the code that needs to be run when an IceLib integrated application no longer needs the associated interaction watch. This could be in cases where, for instance, a form is closed, or when the application receives a ConnectionStateChanged notification where the connection is Down.

CopyC#
if (_interactionQueue == null || !_interactionQueue.IsWatching()) return;

// Removing event handlers helps avoid dangling references.
_interactionQueue.InteractionAdded -= QueueInteractionAdded;
_interactionQueue.InteractionChanged -= QueueInteractionChanged;
_interactionQueue.InteractionRemoved -= QueueInteractionRemoved;
_interactionQueue.ConferenceInteractionAdded -= QueueConferenceInteractionAdded;
_interactionQueue.ConferenceInteractionChanged -= QueueConferenceInteractionChanged;
_interactionQueue.ConferenceInteractionRemoved -= QueueConferenceInteractionRemoved;
_interactionQueue.LostRights -= QueueLostRightsEventHandler;

// Once a watch is no longer needed, it must be stopped so that IceLib/IC can clean up caches appropriately.
_interactionQueue.StopWatching();

Back to Introduction

Making a call

The following example illustrates how to create a call interaction. There are various options such as placing the call on behalf of a workgroup or setting an account code.

CopyC#
CallInteractionParameters callInteractionParameters = new CallInteractionParameters("5555555");

// The call can be placed on behalf of a workgroup.
callInteractionParameters.OnBehalfOfWorkgroup = "marketing";

// An account code can easily be set on the call.
callInteractionParameters.AccountCodeId = "account code ID";

// Or some notes.
callInteractionParameters.Notes = "custom notes";

// Attributes can be initially set on the new call.
callInteractionParameters.AdditionalAttributes["custom attribute name"] = "custom attribute value";

// The asynchronous version is preferable if invoking the API from the UI thread.
Interaction interaction = _interactionsManager.MakeCall(callInteractionParameters);

Back to Introduction

Creating a generic interaction

The following example illustrates how to create a generic interaction. Custom attributes can be specified for the new interaction instance.

CopyC#
QueueId queueId = new QueueId(QueueType.Workgroup, "custom workgroup queue");

GenericInteractionParameters genericInteractionParameters = new GenericInteractionParameters(queueId, InteractionState.Alerting);

// Attributes can be initially set on the new call.
genericInteractionParameters.AdditionalAttributes["custom attribute name"] = "custom attribute value";

// The asynchronous version is preferable if invoking the API from the UI thread.
Interaction interaction = _interactionsManager.MakeGenericInteraction(genericInteractionParameters);

Back to Introduction

Watching for screen pop events

The following example illustrates how to monitor for screen pop events. The screen pop information is configured in Interaction Administrator, specifying an application, action, and commands that should be sent as a screen pop associated with the specified interactions in the system.

Note
Notice that the event is subscribed to before the watch is started. In order to guarantee that no notifications are missed, the event handlers need to be subscribed to before the watch is started.

CopyC#
_screenPop = new ScreenPop(_interactionsManager);

_screenPop.ScreenPopCreated += ScreenPopCreated;

// Subscribe to events before starting the watch.
_screenPop.StartWatching();

The following example illustrates the event handler signature, and the event arguments parameters.

CopyC#
private static void ScreenPopCreated(object sender, ScreenPopEventArgs e)
{
    // The event args contains the parameters for the screen pop: application, executable, action, commands, and Interaction ID.
    ScreenPopItem screenPopItem = e.ScreenPopItem;

    long interactionId = screenPopItem.InteractionId;

    string applicationName = screenPopItem.ApplicationName;
    string executableName = screenPopItem.ExecutableName;

    string actionName = screenPopItem.ActionName;
    string topicName = screenPopItem.TopicName;
    List<string> commands = screenPopItem.Commands;
}

The following example illustrates the code that needs to be run when an IceLib integrated application no longer needs the associated screen pop watch. This could be in cases where, for instance, a form is closed, or when the application receives a ConnectionStateChanged notification where the connection is Down.

CopyC#
if (_screenPop == null || !_screenPop.IsWatching()) return;

// Removing event handlers helps avoid dangling references.
_screenPop.ScreenPopCreated -= ScreenPopCreated;

// Once a watch is no longer needed, it must be stopped so that IceLib/IC can clean up caches appropriately.
_screenPop.StopWatching();

Back to Introduction


Getting Started with Statistics

[image]

IceLib Technical Reference
Getting Started with Statistics
Send Feedback

The ININ.IceLib.Statistics namespace contains classes that provide access to IC system statistics and alerts. The statistics API allows developers to view the statistics catalog, parameters for statistics, and watch specific statistic values. The alerts API allows developers to view the alert catalog, create alerts, and respond to triggered alerts.

Watching Statistics

The StatisticCatalog uses watches to track changes to the catalog of statistics. This watch will track if a statistic is added, removed, or a property on the statistic has changed. This watch is only tracking the definition of the statistic, not the value that the statistic has. Once a statistic watch is in place, using StartWatching()()()(), the definition of every statistic in the system can be retrieved with GetStatisticDefinitions()()()(). If a single known statistic is needed, GetStatisticDefinition will retrieve a statistic based on a supplied StatisticIdentifier. To obtain an instance of the StatisticIdentifier class, using a source URI string, the StatisticKeyTemplate can be used along with the StatisticIdentifier property.

The ININ.IceLib.Statistics namespace does not include an API element for each available statistic. Instead, it is "metadata based", where the catalog of available statistics can be retrieved from the IC server through IceLib's statistics API. For for the list of available statistics see Statistics Catalog.

Listening to Statistics

The StatisticListener will listen for changes to a statistic value. StartWatching will start listening for changes to the statistic value for the supplied StatisticKey list. The StatisticValueUpdated event is raised when the value of the statistic of interest has changed.

Forming a Valid Statistic Key

Note

For a statistic key to be valid, all of the parameter types for a statistic key must be used, and they must be presented in the same order they are given in the statistic catalog. The second example of Watching a Statistic Value shows code that creates a proper statistic key that is also resilient to changes in required parameters.

Watching Alerts

The AlertCatalog uses watches to track changes to the catalog of alerts. This watch will track if an alert is added, removed, or a property on the alert has changed. This watch is only tracking the definition of the alert, not if the alert has triggered or not. Once an alert watch is in place, using StartWatching, alert sets can be retrieved with GetAlertSet. All of the AlertDefinition objects for a given statistic can be retrieved with GetAlertDefinitions. The AlertCatalogChanged event will be triggered whenever there is a change to the portion of the alert catalog that is currently being watched.

Listening to Alerts

The AlertListener will watch for changes to an alert state. StartWatching will start listening for alert trigger events for the supplied AlertFilterKey list. The AlertReceived is raised when an alert has been triggered and when that state is cleared. Although AlertChanged is on the AlertListener, it triggered in response to an alert catalog change event, indicating that some property on the alert has changed, not the state of the alert. This is provided only as a convenience, providing the same information that the AlertCatalog provides.

Handling Memos

The MemoList will watch for changes to lists of memos. There are three types of memo lists, lists of alert memos created with CreateAlertMemoList, lists of memos sent to the current user created with CreateMyMemoList and CreateGeneralMemoList for general, non-alerting memos. To create a new memo, the Memo class provides several factory methods to create a new Memo. After a memo is created, it must be commited with CommitMemo.

Note

The following are some examples of using the statistics namespace classes. It is assumed that an active session is present, a StatisticsManager instance has been created with the session, and saved in a variable named "_statisticsManager".

Jump to a code example:

  • Retrieving All Statistics
  • Retrieving a Statistic Value
  • Watching a Statistic Value
  • Retrieving All Alerts
  • Watching for an Alert Trigger
  • Watching Memos
  • Creating a new Memo

Retrieving All Statistics

The following example illustrates how use the StatisticCatalog to retrieve a list of all statistics in the system.

CopyC#
StatisticCatalog catalog = new StatisticCatalog(_statisticsManager);
catalog.StartWatching();
ReadOnlyCollection<StatisticDefinition> statistics = catalog.GetStatisticDefinitions();

foreach (StatisticDefinition statistic in statistics)
{
    StatisticIdentifier id = statistic.Id;

    // Work with the statistic...
}

Back to Introduction

Retrieving a Statistic Value

The following example illustrates how to use the StatisticListener to retrieve the StatisticValue for a known statistic.

CopyC#
StatisticListener listener = new StatisticListener(_statisticsManager);
StatisticKey watchedKey = new StatisticKey(statistic.Id);
StatisticValue statValue;

listener.StartWatching(new[] { watchedKey });

statValue = listener[watchedKey];

if (!statValue.IsError && !statValue.IsNull)
{
    if (statistic.ValueType == StatisticValueType.Bool)
    {
        StatisticBoolValue boolStatValue = (StatisticBoolValue)statValue;
        bool value = boolStatValue.Value;

        // Work with the value...
    }
}

listener.StopWatching();

Back to Introduction

Watching a Statistic Value

The following example illustrates how to use the StatisticListener to watch the StatisticValue for a known statistic.

CopyC#
StatisticListener listener = new StatisticListener(_statisticsManager);
StatisticKey watchedKey = new StatisticKey(statistic.Id);

listener.StatisticValueUpdated += ListenerStatisticValueUpdated;

listener.StartWatching(new[] { watchedKey });

The following example illustrates how to use the StatisticListener to watch the StatisticValue for a known statistic with required parameters.

CopyC#
StatisticListener listener = new StatisticListener(_statisticsManager);
ParameterValuesDepot parameterValuesDepot = new ParameterValuesDepot(_statisticsManager);

listener.StatisticValueUpdated += ListenerStatisticValueUpdated;

ParameterValueKeyedCollection parameterValues = null;

// This way of watching a Statistic Value is resilient to changes in the number of required parameters
if (statistic.RequiredParameters.Count > 0)
{
    foreach (AssociatedParameterSetDefinition requiredParameter in statistic.RequiredParameters)
    {
        // Each AssociatedParameterSetDefinition will have its own set of RequiredParameters
        parameterValues = new ParameterValueKeyedCollection();
        foreach (ParameterTypeId type in requiredParameter)
        {
            ParameterQuery query = null;
            ParameterQueryResult parameterQueryResult = null;
            // The first parameter will be sent without any associated parameter values
            if (parameterValues.Count == 0)
            {
                // Create Parameter Query
                query = new ParameterQuery(type);
                // Get Possible Parameter values
                parameterQueryResult = parameterValuesDepot.ExecuteQuery(query);

                // Provide a way to select a specific parameter value
                foreach (var parameterValue in parameterQueryResult.Values)
                {
                    // Expose to the user or select a value programmatically
                    // For this example we will just select the first possible parameter value
                    parameterValues.Add(parameterValue);
                    break;
                }
                continue;
            }

            // The possible parameter values for the remaining associated parameters will change based upon the previously selected values
            // This is why the FilteredParameterQuery is used to retrieve the possible values for the rest of the parameters
            var associatedParameterValues = new List<ParameterValue>();
            foreach (var entry in parameterValues)
            {
                var pv = new ParameterValue(entry.Type, entry.Value);
                associatedParameterValues.Add(pv);
            }
            query = new FilteredParameterQuery(type, associatedParameterValues);
            parameterQueryResult = parameterValuesDepot.ExecuteQuery(query);

            // Provide a way to select a specific parameter value
            foreach (var parameterValue in parameterQueryResult.Values)
            {
                // Expose to the user or select a value programmatically
                // For this example we will just select the first possible parameter value
                parameterValues.Add(parameterValue);
                break;
            }
        }
    }

    // Start the watch for that AssociatedParameterSetDefinition
    StatisticKey key = new StatisticKey(statistic.Id, parameterValues);
    listener.StartWatching(new[] { key });
}
// No required parameters for the StatisticDefinition
else
{
    StatisticKey key = new StatisticKey(statistic.Id);
    listener.StartWatching(new[] { key });
}

The following code shows the event handler that will process the statistic change event.

CopyC#
void ListenerStatisticValueUpdated(object sender, StatisticValueUpdatedEventArgs e)
{
    StatisticValue statValue = e.StatisticValues[0];

    if (!statValue.IsError && !statValue.IsNull)
    {
        if (statValue.Definition.ValueType == StatisticValueType.Bool)
        {
            StatisticBoolValue boolStatValue = (StatisticBoolValue)statValue;
            bool value = boolStatValue.Value;

            // Work with the value...
        }
    }
}

Ensure that all watches are properly cleaned up when they are no longer needed.

CopyC#
listener.StatisticValueUpdated -= ListenerStatisticValueUpdated;
listener.StopWatching();

Back to Introduction

Retrieving All Alerts

The following example illustrates how use the AlertCatalog to retrieve a list of all alerts in the system.

CopyC#
AlertCatalog catalog = new AlertCatalog(_statisticsManager);
catalog.StartWatching();
ReadOnlyCollection<AlertSet> alerts = catalog.GetWatchedAlertSets();

foreach (AlertSet alert in alerts)
{
    foreach (AlertDefinition definition in alert.AlertDefinitions)
    {
        StatisticKey sourceStatistic = definition.StatisticKey;

        // Work with the alert...
    }
}

Back to Introduction

Watching for an Alert Trigger

The following example illustrates how to use the AlertListener to watch for an AlertRule to trigger or clear.

CopyC#
AlertListener listener = new AlertListener(_statisticsManager);
AlertFilterKey filterKey = new AlertFilterKey(alertSet, alertAction.TargetId);

listener.AlertReceived += ListenerAlertReceived;

listener.StartWatching(new[] { filterKey }, AlertListenerFilter.None);

The following code shows the event handler that will process the alert trigger event.

CopyC#
void ListenerAlertReceived(object sender, AlertNotificationEventArgs e)
{
    foreach (AlertNotification notification in e.AlertNotifications)
    {
        bool isTriggered = !notification.Cleared;
        AlertRule triggeredRule = notification.Rule;
        StatisticValue currentValue = notification.Value;

        // Work with the alert...
    }
}

Ensure that all watches are properly cleaned up when they are no longer needed.

CopyC#
listener.AlertReceived -= ListenerAlertReceived;
listener.StopWatching();

Back to Introduction

Watching Memos

The following example illustrates how to use the MemoList to watch for a non-alerting memo to be added.

CopyC#
MemoList list = MemoList.CreateGeneralMemoList(_statisticsManager);

list.MemoAdded += MemoAdded;

list.StartWatching();

The following code shows the event handler that will process the memo added event.

CopyC#
void MemoAdded(object sender, MemoEventArgs e)
{
    Memo newMemo = e.Memo;

    string text = newMemo.MessageText;

    // Work with the memo
}

Ensure that all watches are properly cleaned up when they are no longer needed.

CopyC#
list.MemoAdded -= MemoAdded;
list.StopWatching();

Back to Introduction

Creating a new Memo

The following example illustrates how to use the MemoList to create a new memo.

CopyC#
MemoList list = MemoList.CreateGeneralMemoList(_statisticsManager);

Memo newMemo = Memo.CreateMemo(_statisticsManager.Session, "A memo occurred",
    "Example Memo", null, false, null , false, DateTime.Now, null);

list.CommitMemo(listOfUserRecipients, listOfWorkgroupRecipients, newMemo);

Back to Introduction


Getting Started with Statistics Catalog

[image]

IceLib Technical Reference
Getting Started with Statistics Catalog
Send Feedback

The ININ.IceLib.Statistics namespace does not include an API element for each available statistic. Instead, it is "metadata based", where the catalog of available statistics can be retrieved from the IC server through IceLib's statistics API. The statistics catalog contains the display name, description, type, units, required statistic parameters (if any), etc. for each available statistic.

As a convenience, the statistics catalog is integrated into the IceLib API documentation, allowing for browsing of the available statistics. A statistic's ID can be used with the IceLib statistics API to watch for statistic value changes.

Note

The statistics catalog contained in the IceLib API documentation are for the particular GA release or SU update that the documentation was created for and might not include all statistics that are available when connecting to a newer or older IC Server.

The statistics catalog is organized into "categories" of statistics. The statistics within a given category tend to represent similar concepts or areas of the IC system. They also tend to have similar parameters. A given category is often restricted by licensing, which is indicated in a security note in each section.

The statistics catalog contains the following statistic categories:

  • Agent Statistics
  • Agents Real-time Adherence Details
  • Client Services Resources
  • Dialer Agent Statistics
  • Dialer Campaign Statistics
  • Dialer Custom Statistics
  • Dialer Phone Number Detail Statistics
  • Dialer Skill Statistics
  • Dialer Stage Statistics
  • Dialer Wrap Up Statistics
  • Dialer Zone Statistics
  • Email
  • Fax
  • Feedback Statistics
  • IC Memory Usage
  • IC Performance
  • IC System Status
  • Interaction Director Statistics
  • Interaction Statistics
  • Licenses
  • PMQ
  • Queue Statistics
  • Recorder Statistics
  • Recording
  • Session Manager Statistics
  • Speech Recognition
  • StatAlertServer Statistics
  • Tracker Server
  • Transaction Server
  • Workgroup Statistics

Agent Statistics

Agent statistics summarize the activity of call center agents. These statistics report average talk time, longest talk time, average wait time, non-ACD interactions, interactions entered, interactions answered, interactions offered, or interactions completed for the current shift, previous shift, current period, or previous period. Averages are calculated when the interaction completes (disconnects).

Note
Statistics in this category require at least one of the following licenses:
  • Client Access (I3_ACCESS_CLIENT)
  • Interaction Supervisor Plug-In: Workgroup (I3_ACCESS_WORKGROUP_SUPERVISOR_PLUGIN)
Title / Statistic ID Description Type (Units) Parameter Set(s)
Agent Keyword Spotted inin.agent:AgentKeywordSpotted Agent keyword spotted in an interaction statisticStringValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Agent Negative Score inin.agent:AverageAgentNegativeKwScore Sum up agent negative score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Agent Positive Score inin.agent:AverageAgentPositiveKwScore Sum up agent positive score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Customer Negative Score inin.agent:AverageCustomerNegativeKwScore Sum up customer negative score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Customer Positive Score inin.agent:AverageCustomerPositiveKwScore Sum up customer positive score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Hold Time inin.agent:AverageHoldTime The average hold time in queue of all ACD interactions. In technical terms, this is the average time all ACD interaction on the agents queue for the specified workgroup have been in Hold state. statisticDurationValue(s)
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Talk Time inin.agent:AverageTalkTime The average time the agent has spent on interactions for the specified workgroup. In technical terms, this is the average time all interactions on the agents queue for the specified workgroup have been in the ACD - Assigned state. statisticDurationValue(s)
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Average Wait Time inin.agent:AverageWaitTime Average wait time in queue of all interactions. In other words, the average time an interaction from the specified workgroup has alerted the agent in the current period. This is the average time all interactions have been in the ACD - Alerting state on the agents queue for the specified workgroup. statisticDurationValue(s)
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Customer Keyword Spotted inin.agent:CustomerKeywordSpotted Customer Keyword Spotted statisticStringValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Interactions Answered inin.agent:InteractionsAnswered Number of interactions answered, calculated as the number of ACD interactions from the specified workgroup that went to a Connected state in the agent's queue. statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Interactions Completed inin.agent:InteractionsCompleted Number of interactions completed (that went from a state of ACD - Assigned to ACD - Disconnected). statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Interactions Held inin.agent:InteractionsOnHold Number of interactions held. statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Interactions Received inin.agent:InteractionsEntered Total number of interactions that entered the queue. statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Longest Interaction Waiting inin.agent:LongestWaitTime Time of the longest currently waiting interaction. This interaction has been in the ACD - Wait Agent state the longest. Its duration is the amount of time that the interaction has waited to be picked up by an available agent, based on time in queue only. Supervisor workflow statistics always pertain to time in a workgroup or user interaction. Overall time in the system (such as time in IVR) is not counted. statisticFiniteDurationValue(s)
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Longest Talk Time inin.agent:LongestTalkTime Time of the longest currently connected interaction. This interaction has been in a Connected state the longest. statisticFiniteDurationValue(s)
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Non-ACD Interactions inin.agent:NonACDInteractions The number of interactions answered by an agent that were not routed to the agent by ACD. These are interoffice interactions, transfers, and other person-to-person interactions. statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Time In Status inin.agent:TimeInStatus This statistic is evaluated by time-in-status alerts. It appears in Workgroup Detail views to report the amount of time that an agent has been in a particular status condition. StatusMessage(s)
  • ININ.People.WorkgroupDirectory:Workgroup
  • ININ.People:Status
Total Agent Negative Score inin.agent:TotalAgentNegativeKwScore Sum up agent negative score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Total Agent Positive Score inin.agent:TotalAgentPositiveKwScore Sum up agent positive score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Total Customer Negative Score inin.agent:TotalCustomerNegativeKwScore Sum up customer negative score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval
Total Customer Positive Score inin.agent:TotalCustomerPositiveKwScore Sum up customer positive score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.AgentStats:Workgroup
  • ININ.People.AgentStats:User
  • ININ.Queue:Interval

Back to top

Agents Real-time Adherence Details

Interaction Optimizer Real-Time Adherence (RTA) statistics inform about agents who are currently scheduled. RTA statistics report scheduling unit, workgroup, status, scheduled activity, actual activity (based on status), adherence status, exception type, current adherence time, cumulative shift in adherence and shift out of adherence duration for an agent. If an agent is not in a currently published schedule, his or her information will not be available. Note that RTA statistics are designed to be used in a similar fashion to the Real-Time Adherence view available in IC Business Manager. For example, they are designed to have only one scheduling unit and one workgroup selected per request.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Optimizer Access Real-time Adherence (I3_ACCESS_OPTIMIZER_RTA)
Title / Statistic ID Description Type (Units) Parameter Set(s)
Actual Activity inin.optimizerrtadata:OptimizerCurrentActualActivity Current actual activity of agent based on logged in status. statisticStringValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Adherence Status inin.optimizerrtadata:OptimizerAdherenceStatus Agent adherence status indicating In Adherence or Out of Adherence with the schedule. statisticStringValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Agent inin.optimizerrtadata:OptimizerAgentName Display name of scheduled agent. statisticStringValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Current Adherence Duration inin.optimizerrtadata:OptimizerAdherenceDuration Duration for which agent is in the current adherence state after last adherence status change. statisticTimeDurationValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Exception Type inin.optimizerrtadata:OptimizerExceptionType Exception type indicates the specific reason for agent being Out of Adherence with the schedule. Possible display values are Early, Late, Unscheduled, Skipped, Logged Out or Unknown. statisticStringValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Number Of Agents In Adherence inin.optimizerrtadata:OptimizerNumberOfAgentsInAdherence The count of users in adherence with the current schedule. statisticIntValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
Number Of Agents Out Of Adherence inin.optimizerrtadata:OptimizerNumberOfAgentsOutOfAdherence The count of users not in adherence with the current schedule. statisticIntValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
Percent Of Agents In Adherence inin.optimizerrtadata:OptimizerPercentOfAgentsInAdherence The percentage of users in adherence with the current schedule. statisticPercentValue(%)
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
Percent Of Agents Out Of Adherence inin.optimizerrtadata:OptimizerPercentOfAgentsOutOfAdherence The percentage of users not in adherence with the current schedule. statisticPercentValue(%)
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
Scheduled Activity inin.optimizerrtadata:OptimizerCurrentScheduledActivity The activity scheduled by Interaction Optimizer for this agent at this point in time. statisticStringValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Shift Time In Adherence inin.optimizerrtadata:OptimizerShiftTimeInAdherence The cumulative amount of time that an agent has been in adherence, accumulated for the entire shift. statisticFiniteDurationValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Shift Time Out Of Adherence inin.optimizerrtadata:OptimizerShiftTimeOutOfAdherence The cumulative amount of time that an agent has been out of adherence, accumulated for the entire shift. statisticFiniteDurationValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent
Status inin.optimizerrtadata:OptimizerCurrentStatus Current logged in status of agent statisticStringValue
  • ININ.OptimizerRTAData:OptimizerSchedulingUnit
  • ININ.OptimizerRTAData:OptimizerWorkgroup
  • ININ.OptimizerRTAData:OptimizerAdherenceStatus
  • ININ.OptimizerRTAData:OptimizerExceptionType
  • ININ.OptimizerRTAData:OptimizerAgent

Back to top

Client Services Resources

Client Services statistics report the number of resources that IC's Client Services subsystem has available at a given point. These statistics are updated at the regular statistics interval. Client Services keeps track of logged-in users, their status, and their rights based on security configurations.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Status Of The Aggregator Connection inin.system.clientservices:PresenceManager | This Boolean indicator (Yes or No) indicates whether a connection with Interaction Aggregator server is active. | statisticBoolValue |

Back to top

Dialer Agent Statistics

Statistics summarizing the activity for a specific Dialer agent

Title / Statistic ID Description Type (Units) Parameter Set(s)
Abandon Rate (by Calls) inin.dialer.agent:AbandonRateByCalls The percentage of total Dialer calls handled by this agent which were classified as abandons. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Abandon Rate (by Contacts) inin.dialer.agent:AbandonRateByContacts The percentage of total Dialer calls handled by this agent which were contacts and were classified as abandons. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Abandon Rate (by Detections) inin.dialer.agent:AbandonRateByDetections The percentage of Dialer calls handled by this agent which reached a live party and were classified as abandons. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Average Break Time inin.dialer.agent:AverageBreakTime The average amount of time this agent spends on break. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Average Dialer Talk Time inin.dialer.agent:AverageDialerTalkTime The average amount of time this agent spends on each Dialer call. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Average Idle Time inin.dialer.agent:AverageIdleTime The average amount of time this agent spends idle. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Average Non-Dialer Talk Time inin.dialer.agent:AverageNonDialerTalkTime The average amount of time this agent has spends on each non-Dialer call. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Average Talk Time inin.dialer.agent:AverageTalkTime The average amount of time this agent has spent on each call. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Contact Rate inin.dialer.agent:ContactRate The percentage of total Dialer calls handled by this agent which were classified as contacts. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Contacts Per Hour inin.dialer.agent:ContactsPerHour The number of Dialer calls resulting in a contact which this agent handles per hour. StatisticDoubleValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Dialer Calls inin.dialer.agent:DialerCalls The number of Dialer calls this agent has completed. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Idle Periods inin.dialer.agent:IdlePeriods The number of times this agent has been idle. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Logged In Time inin.dialer.agent:LoggedInTime How long the agent has been logged into the campaign. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
Non-Dialer Calls inin.dialer.agent:NonDialerCalls The number of non-Dialer calls this agent has completed. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Percent Break Time inin.dialer.agent:PercentBreakTime The percentage of this agent's time which has been spent on break. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Percent Dialer Talk Time inin.dialer.agent:PercentDialerTalkTime The percentage of this agent's time which has been spent on Dialer calls. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Percent Idle Time inin.dialer.agent:PercentIdleTime The percentage of this agent's time which has been spent idle. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Percent Non-Dialer Talk Time inin.dialer.agent:PercentNonDialerTalkTime The percentage of this agent's time which has been spent on non-Dialer calls. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Stage inin.dialer.agent:Stage The stage the agent is currently in. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
Station inin.dialer.agent:Station The station this agent is logged into. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
Status inin.dialer.agent:Status The agent's current status. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
Successes Per Hour inin.dialer.agent:SuccessesPerHour The number of successful Dialer calls this agent handles per hour. StatisticDoubleValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Successes Rate (by Calls) inin.dialer.agent:SuccessRateByCalls The percentage of total Dialer calls handled by this agent which were classified as successes. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Successes Rate (by Contacts) inin.dialer.agent:SuccessRateByContacts The percentage of Dialer calls handled by this agent which were contacts and were classified as successes. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Time In Stage inin.dialer.agent:TimeInStage How long the agent has been in the current stage. statisticTimeDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
Time In Status inin.dialer.agent:TimeInStatus How long the agent has been in the current status. statisticTimeDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
Total Abandons inin.dialer.agent:TotalAbandons The number of calls this agent has completed that were classified as abandons. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Break Time inin.dialer.agent:TotalBreakTime The total amount of time this agent has spent on break. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Breaks inin.dialer.agent:TotalBreaks The number of times this agent has been on break. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Contacts inin.dialer.agent:TotalContacts The number of calls this agent has completed that were classified as contacts. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Contacts Or Abandons inin.dialer.agent:TotalContactOrAbandons The number of calls this agent has completed that were classified as contacts or abandons. This stat is used when calculating the abandon rate by contacts. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Detections inin.dialer.agent:TotalDetections The number of calls this agent has completed that were detected as a live speaker. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Dialer Talk Time inin.dialer.agent:TotalDialerTalkTime The total amount of time this agent has spent on connected Dialer calls. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Emails inin.dialer.agent:TotalEmails Total emails sent by Policy Behavior statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Emails inin.dialer.agent:TotalEmails Total emails sent by Policy Behavior statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Idle Time inin.dialer.agent:TotalIdleTime The total amount of time this agent has spent idle. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Non-Dialer Talk Time inin.dialer.agent:TotalNonDialerTalkTime The total amount of time this agent has spent on connected non-Dialer calls. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total SMS Messages inin.dialer.agent:TotalSMS Total number of SMS messages sent by Policy Behavior statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Successes inin.dialer.agent:TotalSuccesses The number of calls this agent has completed that were classified as successes. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval
Total Talk Time inin.dialer.agent:TotalTalkTime The total amount of time this agent has spent on Dialer and non-Dialer calls. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Interval

Back to top

Dialer Campaign Statistics

Statistics summarizing the activity for a specific Dialer campaign

Title / Statistic ID Description Type (Units) Parameter Set(s)
Abandon Rate inin.dialer.campaign:AbandonRate The current abandon rate for this campaign statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Active Agents inin.dialer.campaign:ActiveAgents The number of agents currently active in this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Active Calls inin.dialer.campaign:ActiveCalls The number of calls active within Dialer. This includes pending calls, outstanding calls, and connected calls statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Adjusted Calls Per Agent inin.dialer.campaign:AdjustedCallsPerAgent The number of calls Dialer needs to place on average, at this moment, to get a connect, adjusted by the pace. StatisticDoubleValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Agents On Break inin.dialer.campaign:DNDAgents The number of agents logged into this campaign that are currently on break statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Cached Contacts inin.dialer.campaign:CachedContacts The number of contacts currently in Dialer's cache statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Calls Per Agent inin.dialer.campaign:CallsPerAgent The number of calls Dialer needs to place on average, at this moment, to get a connect. StatisticDoubleValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Calls Per Hour inin.dialer.campaign:CallsPerHour The number of calls this campaign will place in an hour. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Connected Calls inin.dialer.campaign:ConnectedCalls The number of calls currently connected in this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Current Pace inin.dialer.campaign:CurrentPace The current pace for this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Effective Idle Agents inin.dialer.campaign:EffectiveIdleAgents The portion of the idle agents that are dedicated to this campaign StatisticDoubleValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Estimated Completion inin.dialer.campaign:EstimatedCompletion The estimated length of time left it will take this campaign to complete the current recycle. statisticFutureDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Filter inin.dialer.campaign:Filter The filter used by this campaign. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Filter Size inin.dialer.campaign:FilterSize The number of callable contacts in the contact list for this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Idle Agents inin.dialer.campaign:IdleAgents The number of agents logged into this campaign that are currently idle statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Last Error inin.dialer.campaign:LastError The most recent error associated with this campaign. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Last Warning inin.dialer.campaign:LastWarning The most recent warning associated with this campaign. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Non-Dialer Agents inin.dialer.campaign:NonDialerAgents The number of agents in this campaign that are currently on non-Dialer calls. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Priority inin.dialer.campaign:Priority The configured priority of this campaign statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Proceeding Calls inin.dialer.campaign:ProceedingCalls The number of calls currently proceeding in this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Recycle Blocked inin.dialer.campaign:RecycleBlocked The number of contacts that will not be dialed because they are currently zone blocked. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Recycle Size inin.dialer.campaign:RecycleSize The number of contacts left in the current recycle for this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Recycles Remaining inin.dialer.campaign:RecyclesRemaining The number of times this campaign will recycle before it is completed. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Sort inin.dialer.campaign:Sort The sort order used by this campaign. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Status inin.dialer.campaign:Status The status of this campaign. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Total Agents inin.dialer.campaign:TotalAgents The number of agents currently logged into this campaign. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
Workgroup inin.dialer.campaign:Workgroup The workgroup used by this campaign. statisticStringValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site

Back to top

Dialer Custom Statistics

Statistics summarizing the activity for custom statistics

Title / Statistic ID Description Type (Units) Parameter Set(s)
Average inin.dialer.custom:Average The average value of the custom column being tracked. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:CustomStatColumn
  • ININ.Dialer:Interval
Count inin.dialer.custom:Count The number of calls that have been completed where the value of the custom column being tracked is equal to the value specified. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:CustomStatColumn
  • ININ.Dialer:CustomStatValue
  • ININ.Dialer:Interval
Sum inin.dialer.custom:Sum The sum of the values of the custom column being tracked. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:CustomStatColumn
  • ININ.Dialer:Interval

Back to top

Dialer Phone Number Detail Statistics

Statistics summarizing the details of a specific phone number

Title / Statistic ID Description Type (Units) Parameter Set(s)
Attempts inin.dialer.pnd:Attempts The total number of times this phone number type has been attempted. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts Abandoned inin.dialer.pnd:AttemptsAbandoned The total number of attempts to this phone number type which have been classified as abandons. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts Answering Machine inin.dialer.pnd:AttemptsMachine The total number of attempts to this phone number type which have been classified as answering machines. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts Busy inin.dialer.pnd:AttemptsBusy The total number of attempts to this phone number type which have been classified as busy. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts Fax inin.dialer.pnd:AttemptsFax The total number of attempts to this phone number type which have been classified as fax. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts No Answer inin.dialer.pnd:AttemptsNoAnswer The total number of attempts to this phone number type which have been classified as no answer. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts Remote Hangup inin.dialer.pnd:AttemptsRemoteHangup The total number of attempts to this phone number type which have been classified as remote hangups. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts Rescheduled inin.dialer.pnd:AttemptsRescheduled The total number of attempts to this phone number type which have been rescheduled. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Attempts System Hangup inin.dialer.pnd:AttemptsSystemHangup The total number of attempts to this phone number type which have been classified as system hangups. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Contact Rate inin.dialer.pnd:ContactRate The contact rate for this phone number type. The rate is calculated using the number of contacts and the total number of attempts. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval
Contacts inin.dialer.pnd:Contacts The total number of contacts that have been made to this phone number type. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:PhoneNumberType
  • ININ.Dialer:Interval

Back to top

Dialer Skill Statistics

Statistics summarizing the details for a specific skill

Title / Statistic ID Description Type (Units) Parameter Set(s)
Cached Contacts inin.dialer.skill:CachedContacts The number of contacts requiring this skill combination which are currently in Dialer's cache. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Callable Contacts inin.dialer.skill:CallableContacts The number of contacts requiring this skill combination which are callable. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Finishing Agents inin.dialer.skill:FinishingAgents The number of finishing agents active in the campaign with this skill combination. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Idle Agents inin.dialer.skill:IdleAgents The number of idle agents active in the campaign with this skill combination. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Outstanding Contacts inin.dialer.skill:OutstandingContacts The number of contacts requiring this skill combination which are currently being called. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Scheduled Contacts inin.dialer.skill:ScheduledContacts The number of contacts requiring this skill combination which are scheduled. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Total Agents inin.dialer.skill:TotalAgents The number of agents active in the campaign with this skill combination. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill
Total Contacts inin.dialer.skill:TotalContacts The total number of contacts requiring this skill combination. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Skill

Back to top

Dialer Stage Statistics

Statistics summarizing the activity for a specific Dialer stage

Title / Statistic ID Description Type (Units) Parameter Set(s)
Average Time inin.dialer.stage:AverageTime The average time a call spends in this stage. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Stage
  • ININ.Dialer:Interval
Completed Calls inin.dialer.stage:CompletedCalls The number of calls that were completed while in this stage. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Stage
  • ININ.Dialer:Interval
Percent Completed inin.dialer.stage:PercentCompleted The percentage of the calls that enter this stage that are completed in this stage. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Stage
  • ININ.Dialer:Interval
Total Calls inin.dialer.stage:TotalCalls The number of calls that entered this stage. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Stage
  • ININ.Dialer:Interval
Total Time inin.dialer.stage:TotalTime The total time calls have spent in this stage. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:Stage
  • ININ.Dialer:Interval

Back to top

Dialer Wrap Up Statistics

Statistics summarizing the dispositions of Dialer calls

Title / Statistic ID Description Type (Units) Parameter Set(s)
Average Time inin.dialer.wrapup:AverageTime The average amount of time this agent spends on Dialer calls with this wrap-up category and code. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:WrapupCategory
  • ININ.Dialer:WrapupCode
  • ININ.Dialer:Interval
Percent Calls inin.dialer.wrapup:PercentCalls The percentage of the total calls this agent has completed which they completed with this wrap-up category and code. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:WrapupCategory
  • ININ.Dialer:WrapupCode
  • ININ.Dialer:Interval
Percent Time inin.dialer.wrapup:PercentTime The percentage of the time this agent has spent on calls for this wrap-up category and code to the total time the agent has spent on calls. statisticPercentValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:WrapupCategory
  • ININ.Dialer:WrapupCode
  • ININ.Dialer:Interval
Total Calls inin.dialer.wrapup:TotalCalls The number of calls this agent has completed with a specific wrap-up category and code. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:WrapupCategory
  • ININ.Dialer:WrapupCode
  • ININ.Dialer:Interval
Total Time inin.dialer.wrapup:TotalTime The total time this agent has spent on Dialer calls with a specific wrap-up category and code. statisticDurationValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Site
  • ININ.Dialer:Agent
  • ININ.Dialer:WrapupCategory
  • ININ.Dialer:WrapupCode
  • ININ.Dialer:Interval

Back to top

Dialer Zone Statistics

Statistics summarizing the details for a specific zone

Title / Statistic ID Description Type (Units) Parameter Set(s)
Cached Contacts inin.dialer.zone:CachedContacts The number of contacts with one or more callable phone numbers in this zone which are currently in cache. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Zone
Callable Contacts inin.dialer.zone:CallableContacts The number of callable contacts with one or more callable phone numbers in this zone. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Zone
Scheduled Contacts inin.dialer.zone:ScheduledContacts The number of contacts with a scheduled phone number in this zone. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Zone
Status inin.dialer.zone:Status The status of this zone - whether or not it is currently blocked. statisticBoolValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Zone
Total Contacts inin.dialer.zone:TotalContacts The total number of contacts with one or more callable phone numbers in this zone. statisticIntValue
  • ININ.Dialer:Campaign
  • ININ.Dialer:Zone

Back to top

Email

The statistics in this category summarize Email routing activity in IC. These statistics are updated at the regular statistics interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Emails In Pre-delivery Processing. inin.system.email:InPredeliveryProcessing | Number of Email messages that IC is in process of delivering. | statisticIntValue |
Emails Scheduled To Be Retried inin.system.email:ScheduledToBeRetried | Number of Email messages that have had at least one failed attempt at delivery, but because that failed attempt might have been due to a momentary problem (e.g. network outage, unavailable server, etc.), at least one more delivery attempt will be made. | statisticIntValue |
Emails That Cannot Be Delivered inin.system.email:Undeliverable | Number of Email messages that could not be delivered, either because the number of retry attempts on the message has been exceeded, or because something about the message makes it undeliverable (e.g. there are no recipients, a voicemail that is missing an audio file, etc.) | statisticIntValue |
Emails Waiting To Be Delivered inin.system.email:WaitingToBeDelivered | Number of Email messages that have been left, which IC has not started processing. | statisticIntValue |

Back to top

Fax

This category provides information about Faxing operations in the IC system. These statistics are updated at the regular statistics interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Fax Licenses Available inin.system.fax:AvailableResources | Number of active Fax stations that are currently available to send or receive Faxes. A low number indicates that additional active Fax resources should be added or configured. The display indicates the total number available out of total. | statisticIntValue |
Fax Receptions Failed (aborted) inin.system.fax:ReceiveAborted | Total number of Faxes received which failed due to line noise or faxing protocol error. | statisticIntValue |
Fax Receptions Failed (connection Failure) inin.system.fax:ReceiveConnectionFailure | Total number of Faxes received which failed due to no Fax resources available. This error indicates that additional hardware Fax resources are required. | statisticIntValue |
Fax Sends Aborted inin.system.fax:SendAborted | The number of Faxes sends that failed due to a faxing protocol error (too much line noise, too many errors, failure to negotiate baud rate, etc.) | statisticIntValue |
Faxes Received Successfully inin.system.fax:ReceiveSuccess | The total number of Faxes received today, this value is reset to zero every day at midnight. | statisticIntValue |
Faxes Send Connection Failures inin.system.fax:SendConnectionFailure | The total number of Faxes that failed due to invalid Fax numbers or connection problems (no available lines, or other telephony failure) since the server was restarted. | statisticIntValue |
Faxes Sent Successfully inin.system.fax:SendSuccess | The total number of Faxes sent successfully today, this value is reset to zero every day at midnight. | statisticIntValue |
Total Fax Licenses inin.system.fax:TotalResources | Total number of fax licenses. | statisticIntValue |

Back to top

Feedback Statistics

Interaction Feedback statistics inform about a named Interaction Feedback survey or survey group. Feedback views display real-time statistics for the last hour (relative to the present time) or statistics for the current day, since midnight. Daily statistics reset at midnight.

Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Active Surveys inin.feedback:ActiveSurveys Number of calls in a Connected state where the customer has agreed to take a survey at the end of the call. This number reflects customers that have not started the survey as well as customers currently taking the survey who are still Connected to the IC system. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Agent No Answer Today inin.feedback:AgentNoAnswerToday This column is used to indicate surveys that have been opted into for which no agent have answered, for today. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Available Licenses inin.feedback:AvailableLicenses | Available licenses | statisticIntValue
Below Minimum Score inin.feedback:BelowMinScore This column is used only if a survey definition specified a value (other than 0) in the Minimum Acceptable Score field. If a survey specifies a minimum value, indicating the lowest acceptable score on a survey, then each survey completed since midnight that scored below that minimum value is counted in this column. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Caller Disconnects Today inin.feedback:CallerDisconnectsToday This column is used to indicate surveys that have been opted into for which the caller has disconnected before the survey was presented, for today. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Survey Average Score Last Hour inin.feedback:AvgScoreLastHour This column displays the average score of selected surveys within the past hour. statisticPercentValue(%)
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Survey Average Score Today inin.feedback:AvgScoreToday This column displays the average score selected surveys since midnight. statisticPercentValue(%)
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Survey Opt-outs Today inin.feedback:OptedOutToday Number of calls since midnight where the customer did not agree to take the survey. This includes calls in the Connected state as well as previously disconnected calls. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Surveys Abandoned Today inin.feedback:AbandondedToday Number of calls who agreed to take a survey (at one point considered an Active Survey) but did not complete the survey. This reflects calls where the customer disconnected before taking the survey as well as those that disconnected while taking the survey before completing it. Abandoned survey data is not used in survey reports. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Surveys Bypassed (no License) Today inin.feedback:BypassedNoLicenseToday Number of calls since midnight where the customer took a survey but the agent who dealt with the caller did not have an Interaction Feedback Access license. In this case, the customer completed the survey and the data was captured, but it will not be included in the survey data in Interaction Feedback Reports. In the case where multiple agents handled a call, if at least one of the agents has an Interaction Feedback Access license, the survey data will be included in the reports. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Surveys Completed Today inin.feedback:CompletedSurveysToday Number of calls since midnight where a Survey was completed by obtaining answers to all of the questions. This count does not include Active Surveys or Abandoned Surveys. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Surveys In Error Today inin.feedback:ErrorTotalToday Number of system errors generated by the IC server since midnight. These errors could be any system error that could affect the performance of the IC server, and which are reflected in either the IC server's Windows event logs or IC subsystem logs. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Surveys Offered Last Hour inin.feedback:OfferedSurveysLastHour Number of surveys selected and offered to customers within the past hour. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Surveys Offered Today inin.feedback:OfferedSurveysToday Number of surveys selected and offered to customers since midnight. statisticIntValue
  • ININ.Feedback:SurveyGroupName
  • ININ.Feedback:SurveyName
Total Licenses inin.feedback:TotalLicenses | Total licenses | statisticIntValue

Back to top

IC Memory Usage

IC Memory Usage statistics report the amount of memory that IC subsystems are consuming (in kilobytes). These statistics are updated every 5 minutes.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Acc Server inin.system.memoryusage:AccServer | The amount of paged physical memory (working set) that Accumulator (Acc) server is using, expressed in kilobytes. Accumulators, similar to system registers, count events as they occur in the IC's Interaction Processor. Instances of these events are stored in variables and are accessible in report logs or other handlers using the Accumulator tools in Interaction Designer. | statisticIntValue(KB) |
Acd Server inin.system.memoryusage:AcdServer | The amount of paged physical memory (working set) that ACD Server is using, expressed in kilobytes. ACD Server determines which agent a call should be routed to, based upon skill and other factors. | statisticIntValue(KB) |
Admin Server inin.system.memoryusage:AdminServer | The amount of paged physical memory (working set) that Admin Server is using, expressed in kilobytes. Admin Server provides ACL management and licensing on top of the data managed by Directory Services. It maintains a very large cache of data with a size proportional to the amount of configuration information | statisticIntValue(KB) |
Client Services inin.system.memoryusage:ClientServices | The amount of paged physical memory (working set) that Client Services is using, expressed in kilobytes. Client Services keeps track of logged-in users, their status, and their rights based on security configurations. | statisticIntValue(KB) |
Cluster Connector inin.system.memoryusage:ClusterConnector | The amount of paged physical memory (working set) that the Cluster Connector is using, expressed in kilobytes. | statisticIntValue(KB) |
Compression Manager inin.system.memoryusage:CompressionManager | The amount of paged physical memory (working set) that Compression Manager is using, expressed in kilobytes. Compression Services compress audio recordings (such as voice mail messages) using the TrueSpeech compression algorithm. | statisticIntValue(KB) |
Data Manager inin.system.memoryusage:DataManager | The amount of paged physical memory (working set) that Data Manager is using, expressed in kilobytes. Data Manager is the IC subsystem that services Reverse White Page (RWP) lookup requests, as well as contact directory requests. Data Manager keeps track of data sources used to display Contact Directory and Speed Dial notebook pages in Interaction Client. | statisticIntValue(KB) |
DS Server inin.system.memoryusage:DSServer | The amount of paged physical memory (working set) that Directory Services is using, expressed in kilobytes. Directory Services provides the interface to the proprietary data store (configuration repository) that IC uses to store system configuration information. | statisticIntValue(KB) |
DS Sink inin.system.memoryusage:DSSink | The amount of paged physical memory (working set) that DSSink is using, expressed in kilobytes. | statisticIntValue(KB) |
EMS Server inin.system.memoryusage:EMSServer | The amount of paged physical memory (working set) that Multi-Site Client is using on a peer IC site, expressed in kilobytes. | statisticIntValue(KB) |
Fax Server inin.system.memoryusage:FaxServer | The amount of paged physical memory (working set) that Fax Services is using, expressed in kilobytes. The Fax subsystem allows the Interaction Center Platform to send and receive faxes. | statisticIntValue(KB) |
File Monitor inin.system.memoryusage:FileMonitor | The amount of paged physical memory (working set) that File Monitor is using, expressed in kilobytes. File Monitor keeps track of file usage. | statisticIntValue(KB) |
File Router inin.system.memoryusage:FileRouter | The amount of paged physical memory (working set) that the File Router is using, expressed in kilobytes. | statisticIntValue(KB) |
Host Server inin.system.memoryusage:HostServer | The amount of paged physical memory (working set) that Host Server is using, expressed in kilobytes. Host Services allows Interaction Center Platform to communicate with mainframes and IBM AS/400 systems using the 3270 and 5250 terminal emulation protocols. | statisticIntValue(KB) |
IC Interation Recovery Service inin.system.memoryusage:InteractionRecoveryService | The Amount of paged physical memory (working set) that IC Interation Recovery Service is using, expressed in kilobytes. | statisticIntValue(KB) |
IC STS inin.system.memoryusage:IcSts | The Amount of paged physical memory (working set) that IC STS is using, expressed in kilobytes. | statisticIntValue(KB) |
IP inin.system.memoryusage:IP | The amount of paged physical memory (working set) that Interaction Processor (IP) is using, expressed in kilobytes. Interaction Processor (IP) is the IC subsystem that processes low-level subsystem events in order to implement higher-level business logic. For example, Interaction Processor starts an instance of a handler in response to an event. | statisticIntValue(KB) |
IP Server inin.system.memoryusage:IPServer | The amount of paged physical memory (working set) that IP Server is using, expressed in kilobytes. IP Server manages several helper tasks for Interaction Processor and Report Logging. Specifically it logs line activity, and manages part of the Message waiting light processing. | statisticIntValue(KB) |
IPDB Server inin.system.memoryusage:IPDBServer | The amount of paged physical memory (working set) that IPDB Server is using, expressed in kilobytes. IPDB Server connects Interaction Processor to a specified database when Database tools are used. | statisticIntValue(KB) |
Mail Account Monitor inin.system.memoryusage:MailAccountMonitor | The amount of paged physical memory (working set) that Mail Account Monitor is using, expressed in kilobytes. Mail Account Monitor is responsible for syncing external user attributes from Mail accounts or LDAP to Directory Services. | statisticIntValue(KB) |
Notifier inin.system.memoryusage:Notifier | The amount of paged physical memory (working set) that Notifier is using, expressed in kilobytes. | statisticIntValue(KB) |
Optimizer Server inin.system.memoryusage:OptimizerServer | The amount of paged physical memory (working set) that Optimizer Server is using, expressed in kilobytes. | statisticIntValue(KB) |
Out Of Proc inin.system.memoryusage:OutOfProc | The amount of paged physical memory (working set) consumed by OutOfProc server, expressed in kilobytes. OutOfProc server is a service used to execute DLLs for Interaction Processor without risking the integrity of the IP process. Its size will be a function of any custom activities that might be added by the customer or VAR via these customization interfaces. | statisticIntValue(KB) |
Post Office Server inin.system.memoryusage:PostOfficeServer | The amount of paged physical memory (working set) that Post Office Server is using, expressed in kilobytes. Post Office Server (POS) is the IC subsystem that provides platform independent access to Email services such as message store access and message delivery. POS also provides support for Email routing, and will initiate an Reverse White Page (RWP) lookup request before queuing an incoming email interaction. | statisticIntValue(KB) |
Reco inin.system.memoryusage:SpeechRecognition | The amount of paged physical memory (working set) that Speech Recognition (ASR) is using, expressed in kilobytes. Speech recognition services recognize spoken commands and phrases for applications such as speech-enabled IVR (interactive voice response). | statisticIntValue(KB) |
Recorder Server inin.system.memoryusage:RecorderServer | The amount of paged physical memory (working set) that Interaction Recorder Server is using, expressed in kilobytes. Interaction Recorder is an application for managing phone calls, Emails, Faxes, screen recordings, and Web chats recorded within the CIC platform. Interaction Recorder identifies interactions to record and manages the compression, archiving, and storing of the attributes for each type of media recording. Using Interaction Recorder, you can quickly sort and manage large numbers of recordings. Interaction Recorder also includes features for scoring agent interactions and quality monitoring. | statisticIntValue(KB) |
Session Manager inin.system.memoryusage:SessionManager | The amount of paged physical memory (working set) that Session Manager is using, expressed in kilobytes. | statisticIntValue(KB) |
SMS Server inin.system.memoryusage:SMSServer | The amount of paged physical memory (working set) that Simple Message Services Server is using, expressed in kilobytes. IC provides tools that allow SMS messages to be sent or received. | statisticIntValue(KB) |
Stat Alert Server inin.system.memoryusage:StatAlertServer | The amount of paged physical memory (working set) that Alert Server is using, expressed in kilobytes. Alert Services allows users and supervisors to define specific circumstances (e.g., average hold time > 10 minutes) under which they are to be alerted and the means by which the alert is to occur (e.g., e-mail, pager, phone call, etc.). | statisticIntValue(KB) |
Statistics Server inin.system.memoryusage:StatServer | The amount of paged physical memory (working set) that Statistics Server (StatServer) is using, expressed in kilobytes. Statistics Server tracks important statistical information for real-time views and historical reporting. | statisticIntValue(KB) |
Switchover inin.system.memoryusage:Switchover | The amount of paged physical memory (working set) that the IC's automated switchover system is using, expressed in kilobytes. If an IC server ever fails, in less than 30 seconds the server can switch control to another mirror image IC server with minimal phone disruption. In addition, the switchover scheme allows administrators to manually switch the | statisticIntValue(KB) |
Telephony Services inin.system.memoryusage:TelephonyServices | The amount of paged physical memory (working set) that Telephony Services is using, expressed in kilobytes. | statisticIntValue(KB) |
Tracker Server inin.system.memoryusage:TrackerServer | The amount of paged physical memory (working set) that Tracker Server is using, expressed in kilobytes. Interaction Tracker is composed of two server-side subsystems: Tracker Server and Tracker Tran Server (also called Transaction Server). Tracker Server listens for specific events from Queue Manager and inserts and updates interaction records. Tracker Tran Server processes insert and update requests from Tracker Server and insert, update, and query requests from Interaction Tracker Clients. | statisticIntValue(KB) |
Transaction Server inin.system.memoryusage:TransactionServer | The amount of paged physical memory (working set) that Transaction Server is using, expressed in kilobytes. Transaction Server is a generic processor of database transactions related transactions for several different subsystems including Tracker and Recorder. | statisticIntValue(KB) |
VPIM Receiver inin.system.memoryusage:VPIMReceiver | The amount of paged physical memory (working set) that Voice Profile for Internet Mail (VPIM) Receiver is using, expressed in kilobytes. VPIM a mechanism for identifying body parts that a sender deems critical in a multi-part Internet mail message. | statisticIntValue(KB) |
Web Processor inin.system.memoryusage:WebProcessor | Amount of paged physical memory that Web Processor is using, expressed in kilobytes. Web Processor is the IC subsystem that handles all incoming web interactions and internal intercom chats. It operates in conjunction with servlet process on a web server and acts as web interface into the IC system. | statisticIntValue(KB) |

Back to top

IC Performance

This category provides information about performance of IC server. These statistics are updated at the regular statistics interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Available CPU inin.system.performance:CpuAvailableTotal | Available CPU in percent. | statisticPercentValue(%) |
Average Latency inin.system.performance:AverageLatency | The average Notifier/Queue Manager latency in milliseconds. This statistic is computed by sending no-op requests from Remoco to Queue Manager and then measuring the latency in the response from Queue Manager. | statisticIntValue(ms) |
Free Disk Space Logs inin.system.performance:FreeDiskSpaceLogs | The free disk space logs currently consume on this system in gigabytes. | StatisticDoubleValue(GB) |
Free Disk Space Recordings inin.system.performance:FreeDiskSpaceRecordings | The free disk space recordings currently consume on this system in gigabytes. | StatisticDoubleValue(GB) |
Free Disk Space System inin.system.performance:FreeDiskSpaceSystem | The free disk space of this system in gigabytes. | StatisticDoubleValue(GB) |
Free Disk Space Work inin.system.performance:FreeDiskSpaceWork | The free disk space work in gigabytes. | StatisticDoubleValue(GB) |
IP CPU Usage inin.system.performance:CpuIP | The value is the percentage of total CPU used by the Interaction Processor subsystem across all cores present in the machine. | statisticPercentValue(%) |
Notifier CPU Usage inin.system.performance:CpuNotifier | The value is the percentage of total CPU used by the Notifier subsystem across all cores present in the machine. | statisticPercentValue(%) |
Page Faults inin.system.performance:PageFaults | Page faults are the number of times that the operating system has to use the hard disk as a memory resource. A consistently large number of page faults may indicate that more main memory may be required. | statisticIntValue |
System Latency inin.system.performance:SystemLatency | Measures round trip time of a message through the Notifier subsystem. This indicates the general latency of the IC platform. A high latency value indicates that the server is busy and may require additional hardware resources. On a system that is not under load, this value is typically zero. On a moderately tasked system, a typical value might be 50-100 ms. A system under heavy load might be higher. Values over 300 milliseconds may cause noticeable delays and could indicate that a hardware upgrade or handler optimization is needed. | statisticIntValue(ms) |
Total CPU Usage inin.system.performance:CpuUsageTotal | The value is the sum of CPU utilization reported by Windows across all cores present in the machine. A value of 100% on a four core machine would indicate that all cores are completely used. | statisticPercentValue(%) |
Total Disk Space Logs inin.system.performance:TotalDiskSpaceLogs | The value indicates the amount of total disk space that is available on the drive where logs are saved. | StatisticDoubleValue(GB) |
Total Disk Space Recordings inin.system.performance:TotalDiskSpaceRecordings | The value indicates the amount of total disk space that is available on the drive where recordings are saved. | StatisticDoubleValue(GB) |
Total Disk Space System inin.system.performance:TotalDiskSpaceSystem | The value indicates the amount of total disk space that is available on the drive where the operating system resides. | StatisticDoubleValue(GB) |
Total Disk Space Work inin.system.performance:TotalDiskSpaceWork | The value indicates the amount of total disk space that is available on the drive that contains the IC work directory. | StatisticDoubleValue(GB) |
TS CPU Usage inin.system.performance:CpuTS | The value is the percentage of total CPU used by the Telephony Services subsystem across all cores present in the machine. | statisticPercentValue(%) |
TTS CPU Usage inin.system.performance:CpuTTS | The value is the percentage of total CPU used by the text to speech subsystem across all cores present in the machine. | statisticPercentValue(%) |

Back to top

IC System Status

The statistics in this category indicate general system status in terms of number of executing handlers, host and database tool errors, and available text-to-speech sessions. These statistics are updated at the regular statistics interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Available Remote Licenses inin.system.status:AvailableRemoteLicenses | The number of available remote licenses, updated every 10 minutes. | statisticIntValue |
Available TTS Sessions inin.system.status:AvailableTtsSessions | This value indicates the total number of text-to-speech sessions that are currently available. If the available number is approaching zero, you may need to purchase additional TTS sessions. | statisticIntValue |
Backup Server Name inin.system.status:BackupName | The Notifier name of the backup server, or N/A if no backup server is configured. | statisticStringValue |
Backup Server Ready inin.system.status:BackupReady | Indicates the health of the backup (Switchover) server. Displays Yes if the backup server is ready, or No if the backup server is known to be in a bad state or is no longer processing properly. | statisticBoolValue |
Current Handlers In The Thread Pool inin.system.status:CurrentHandlerThreadPool | Number of handlers in the thread pool. | statisticIntValue |
Currently Executing Handlers inin.system.status:RunningHandlerThreads | The value indicates the total number of handlers that are currently executing in the system. If this number continually trends up, this could indicate that handlers are not completing execution due to design flaws, or tool defects. | statisticIntValue |
Host Tool Connection Errors inin.system.status:HostToolConnectionErrors | Total errors for the 'Host Connect' Host Interface tool for the last ten minutes. These are failed attempts to connect to the host system. Errors of this type typically indicate host/communications problems or an incorrectly configured host profile. | statisticIntValue |
Host Tool Other Errors inin.system.status:HostToolOtherErrors | Total errors for the other Host Interface tool for the last ten minutes. Typically these are minor errors, caused by timeouts, unrecognized screens, and handler programming errors. | statisticIntValue |
Indicates If A Switchover Was Performed inin.system.status:SwitchoverPerformed | Indicates if a switchover was performed. | statisticBoolValue |
IP Is Running inin.system.status:IPRunning | Indicates whether Interaction Processor is running. | statisticBoolValue |
Maximum Executing Handlers inin.system.status:MaxHandlerThreads | Maximum number of handlers that can be executed in the system at any time. | statisticIntValue |
Queued Handler Threads inin.system.status:QueuedHandlerThreads | Number of handlers that are queued in the system right now. | statisticIntValue |
Switchover UDP Heartbeat Interval inin.system.status:UdpHeartbeatInterval | Heartbeats are a series of signals emitted at regular intervals, by IC servers on the network. This stat indicates the transmission rate for UDP heartbeats on the Switchover server, expressed in milliseconds. | statisticIntValue(ms) |
Time Since Last Switchover inin.system.status:TimeOfLastSwitchover | The amount of time that has passed since the last known switchover occurred, or | statisticTimeDurationValue |
Total TTS Sessions inin.system.status:TotalTtsSessions | Maximum number of concurrent TTS sessions allowed. | statisticIntValue |
Ts Ping Time inin.system.status:TsPingTime | The amount of time in milliseconds to ping the IC's Telephony Services subsystem. | statisticIntValue(ms) |

Back to top

Interaction Director Statistics

Interaction Director statistics.

Title / Statistic ID Description Type (Units) Parameter Set(s)
% Available inin.director:PercentInEG % Available. statisticPercentValue(%)
  • ININ.Director:EnterpriseGroup
Abandon Rate Distributions inin.director:AbandonedRateDistribution Abandoned rate distribution for an accumulative/partial sum bucket, workgroup, interaction type and time interval. The number of abandoned calls for each bucket is divided by the number of call that entered into the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
  • ININ.Queue:AccumulativeHistogramInterval
- or -
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
  • ININ.Queue:PartialSumHistogramInterval
Available To Take Director Interaction inin.director:AvailableForDirectorInteractionsInEG Available to take Director interaction. statisticIntValue
  • ININ.Director:EnterpriseGroup
Average Talk Time inin.director:AverageTalkTimeInEG Average talk time. statisticDurationValue(Seconds)
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
Average Wait Time inin.director:AverageWaitTimeInEG Average wait time. statisticDurationValue(Seconds)
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
Called Address inin.director:ISRCalledAddress Called address. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
Calling Address inin.director:ISRCallingAddress Calling address. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
DTMF Code inin.director:ISRDTMFCode DTMF code. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
DTMF Wait inin.director:ISRDTMFWait DTMF wait. statisticIntValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
Failures inin.director:ISRFailures Failures. statisticIntValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
From Server inin.director:ISRFromServer From server. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
ID Method inin.director:ISRIDMethod ID method. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
Interactions Abandoned inin.director:InteractionsAbandonedInEG Interactions abandoned. statisticIntValue
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
Interactions Answered inin.director:InteractionsAnsweredInEG Interactions answered. statisticIntValue
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
Interactions Completed inin.director:InteractionsCompletedInEG Interactions completed. statisticIntValue
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
Interactions Received inin.director:InteractionsReceivedInEG Interactions received. statisticIntValue
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
Line Group inin.director:ISRLinegroup Line group. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
Logged In inin.director:LoggedInAgentsInEG Logged in. statisticIntValue
  • ININ.Director:EnterpriseGroup
Longest Available inin.director:LongestAvailableInEG Longest available. statisticTimeDurationValue
  • ININ.Director:EnterpriseGroup
Longest Director Interaction inin.director:LongestDirectorInteractionInEG Longest Director interaction. statisticTimeDurationValue
  • ININ.Director:EnterpriseGroup
Longest-waiting Director Interaction inin.director:LongestWaitingDirectorInteractionInEG Longest-waiting Director interaction statisticTimeDurationValue
  • ININ.Director:EnterpriseGroup
Number Of Active Queues. inin.director:NumberOfActiveQueuesInEG Number of active queues statisticIntValue
  • ININ.Director:EnterpriseGroup
Number Of Calls Currently Answered inin.director:NumberOfCallsCurrentlyAnsweredInEG Number of calls currently answered. statisticIntValue
  • ININ.Director:EnterpriseGroup
Number Of Calls In Director Wait inin.director:NumberOfCallsInDirectorWaitInEG Number of calls in Director wait. statisticIntValue
  • ININ.Director:EnterpriseGroup
Number Of Configured Queues. inin.director:NumberOfConfiguredQueuesInEG Number of configured queues. statisticIntValue
  • ININ.Director:EnterpriseGroup
On ACW inin.director:OnACWInEG On ACW. statisticIntValue
  • ININ.Director:EnterpriseGroup
On Non-Director Interactions inin.director:OnNonDirectorInteractionsInEG On non-Director interactions. statisticIntValue
  • ININ.Director:EnterpriseGroup
Service Level Distributions inin.director:ServiceLevelDistribution The interactions that connected callers to agents within a specified time interval. The number of answered calls for each bucket is divided by the number of calls answered in the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
  • ININ.Queue:AccumulativeHistogramInterval
- or -
  • ININ.Director:EnterpriseGroup
  • ININ.Queue:Interval
  • ININ.Queue:PartialSumHistogramInterval
Status inin.director:ISRStatus Status. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
Successes inin.director:ISRSuccesses Successes. statisticIntValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
To Server inin.director:ISRToServer To server. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName
Unique ID inin.director:ISRUniqueID Unique ID. statisticStringValue
  • ININ.Director:ServerName
  • ININ.Director:InterServerRouteName

Back to top

Interaction Statistics

This category provides counts or durations for general object types in IC.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Active Calls inin.system.interaction:ActiveCalls | Total number of active call objects in the system, including SIP calls. See SIP Station Calls for a count of active SIP calls only. | statisticIntValue |
Active Chats inin.system.interaction:ActiveChats | Number of active chat objects in the system. | statisticIntValue |
Active Emails inin.system.interaction:ActiveEmails | Number of active Email objects in the system. | statisticIntValue |
Active Generic Objects inin.system.interaction:ActiveGenericObjects | Number of active generic objects in the system. A generic object is an integration object that can be placed on a queue, and routed throughout IC. Each generic object represents a third-party software construct of some sort, such as an external ticketing system, video conference, or other software that was defined by a third party. | statisticIntValue |
Active Social Conversations inin.system.interaction:ActiveSocialConversations | Number of active conversations in the system. | statisticIntValue |
Active Social Direct Messages inin.system.interaction:ActiveSocialDirectMessages | Number of active direct messages in the system. | statisticIntValue |
Active Workflows inin.system.interaction:ActiveWorkflows | Number of active workflows in the system. | statisticIntValue |
Longest Call inin.system.interaction:LongestCall | Duration of the longest call currently in the system. | statisticTimeDurationValue |
Longest Chat inin.system.interaction:LongestChat | Duration of the longest chat currently in the system. | statisticTimeDurationValue |
Longest Email inin.system.interaction:LongestEmail | Duration of the longest Email currently in the system. | statisticTimeDurationValue |
Longest Generic Object inin.system.interaction:LongestGenericObject | Duration of the longest generic object currently in the system. | statisticTimeDurationValue |
Longest Social Conversation inin.system.interaction:LongestSocialConversation | Duration of the longest Social Conversation currently in the system. | statisticTimeDurationValue |
Longest Social Direct Message inin.system.interaction:LongestSocialDirectMessage | Duration of the longest Direct Message currently in the system. | statisticTimeDurationValue |
Longest Workflow inin.system.interaction:LongestWorkflow | Duration of the longest workflow currently in the system. | statisticTimeDurationValue |
SIP Station Calls inin.system.interaction:ActiveConnectionCalls | The number of active calls that are SIP station calls. For example, if Active Calls equals 10, and there are 5 SIP station calls at the same time, then the total call count is 10, with 5 of those calls being SIP Station Calls. | statisticIntValue |

Back to top

Licenses

This category summarizes IC license availability and utilization.

Title / Statistic ID Description Type (Units) Parameter Set(s)
Allowed inin.licenses:TotalLicenses The total number of licenses on this system for the given license type. statisticIntValue
  • ININ.Licenses:Server
  • ININ.Licenses:LicenseType
  • ININ.Licenses:License
Available inin.licenses:AvailableLicenses The number of licenses on this system for the given license type that are not yet used. statisticIntValue
  • ININ.Licenses:Server
  • ININ.Licenses:LicenseType
  • ININ.Licenses:License
Available In Percent inin.licenses:AvailableLicensePercentage The percentage of licenses on this system for the given license type that are not yet used. statisticPercentValue
  • ININ.Licenses:Server
  • ININ.Licenses:LicenseType
  • ININ.Licenses:License
In Use inin.licenses:UsedLicenses The number of licenses on this system for the given license type that are in use. statisticIntValue
  • ININ.Licenses:Server
  • ININ.Licenses:LicenseType
  • ININ.Licenses:License
Used In Percent inin.licenses:UsedLicensePercentage The percentage of licenses on this system for the given license type that are in use. statisticPercentValue
  • ININ.Licenses:Server
  • ININ.Licenses:LicenseType
  • ININ.Licenses:License

Back to top

PMQ

The statistics in this category summarize activity in persistent message queues.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Admin Server Is Connected To DB inin.system.pmq:AdminServerConnectedToDb | Indicates whether or not Admin Server's PMQ object currently has a connection to the database. Not having a connection only indicates an error if items are also being persisted to disk. | statisticBoolValue |
Admin Server's Oldest Message On Disk inin.system.pmq:AdminServerOldestMessageOnDisk | Age of the oldest message that PMQ is currently storing to disk for Admin Server. This operation is common for Admin Server, and should be a concern only if the time lag is larger than the default reporting period (30 minutes). | statisticTimeDurationValue(s) |
Admin Server's PMQ Is Persisted To Disk inin.system.pmq:AdminServerPersistedToDisk | Indicates that PMQ is currently buffering Admin Server messages to disk. This is a common occurrence for Stat Server since it periodically sends large amounts of data to the database. If the subsystem is connected to the database, and it has messages persisting to disk then you should examine the 'oldest message on disk' statistic to find out whether messages are flowing smoothly or are backed up. | statisticIntValue(Messages) |
IP Is Connected To DB inin.system.pmq:IpConnectedToDb | Indicates whether or not Interaction Processor's PMQ object currently has a connection to the database. Not having a connection only indicates an error if items are also being persisted to disk. | statisticBoolValue |
IP Server Is Connected To DB inin.system.pmq:IpServerConnectedToDb | Indicates whether or not IP Server's PMQ object currently has a connection to the database. Not having a connection only indicates an error if items are also being persisted to disk. | statisticBoolValue |
IP Server's Oldest Message On Disk inin.system.pmq:IpServerOldestMessageOnDisk | Age of the oldest message that PMQ is currently storing to disk for Interaction Processor server. This operation is common for Interaction Processor server, and should be a concern only if the time lag is larger than the default reporting period (30 minutes). | statisticTimeDurationValue(s) |
IP Server's PMQ Is Persisted To Disk inin.system.pmq:IpServerPersistedToDisk | Indicates that PMQ is currently buffering IP Server messages to disk. This is a common occurrence for Stat Server since it periodically sends large amounts of data to the database. If the subsystem is connected to the database, and it has messages persisting to disk then you should examine the 'oldest message on disk' statistic to find out whether messages are flowing smoothly or are backed up. | statisticIntValue(Messages) |
IP's Oldest Message On Disk inin.system.pmq:IpOldestMessageOnDisk | This statistic indicates the age of the oldest message that PMQ is currently storing to disk for Interaction Processor server. This operation is common for Interaction Processor server, and should be a concern only if the time lag is larger than the default reporting period (30 minutes). | statisticTimeDurationValue(s) |
IP's PMQ Is Persisted To Disk inin.system.pmq:IpPersistedToDisk | Indicates that PMQ is currently buffering Interaction Processor messages to disk. This is a common occurrence for Stat Server since it periodically sends large amounts of data to the database. If the subsystem is connected to the database, and it has messages persisting to disk then you should examine the 'oldest message on disk' statistic to find out whether messages are flowing smoothly or are backed up. | statisticIntValue(Messages) |
Recorder Server Errors Persisted To Disk inin.system.pmq:RecorderServerErrorsPersistedToDisk | Number of Recorder Server error objects that are currently persisted to disk. | statisticIntValue(Messages) |
Recorder Server Is Connected To DB inin.system.pmq:RecorderServerConnectedToDb | Indicates whether or not Recorder Server's PMQ object currently has a connection to the database. Not having a connection only indicates an error if items are also being persisted to disk. | statisticBoolValue |
Recorder Server's Oldest Error On Disk inin.system.pmq:RecorderServerOldestErrorMessageOnDisk | Age of the oldest error that Recorder Server is currently storing to disk. | statisticTimeDurationValue(s) |
Recorder Server's Oldest Message On Disk inin.system.pmq:RecorderServerOldestMessageOnDisk | Age of the oldest message that PMQ is currently storing to disk for Recorder Server. This operation is common for Recorder Server, and should be a concern only if the time lag is larger than the default reporting period (30 minutes). | statisticTimeDurationValue(s) |
Recorder Server's PMQ Is Persisted To Disk inin.system.pmq:RecorderServerPersistedToDisk | Number of Recorder Server PMQ objects that are currently persisted to disk. | statisticIntValue(Messages) |
Stat Server Is Connected To DB inin.system.pmq:StatServerConnectedToDb | Indicates whether or not Stat Server's PMQ object currently has a connection to the database. Not having a connection only indicates an error if items are also being persisted to disk. | statisticBoolValue |
Stat Server's Oldest Message On Disk inin.system.pmq:StatServerOldestMessageOnDisk | Age of the oldest message that PMQ is currently storing to disk for Stat Server. This operation is common for Stat Server, and should be a concern only if the time lag is larger than the default reporting period (30 minutes). | statisticTimeDurationValue(s) |
Stat Server's PMQ Is Persisted To Disk inin.system.pmq:StatServerPersistedToDisk | Number of Stat Server PMQ objects that are currently persisted to disk. | statisticIntValue(Messages) |

Back to top

Queue Statistics

This category contains counts of active interactions in a queue

Title / Statistic ID Description Type (Units) Parameter Set(s)
Interaction Count inin.queue:InteractionCount Number of non-disconnected interactions of a specified type maintained by queue manager. statisticIntValue
  • ININ.Queue:Type
  • ININ.Queue:Name

Back to top

Recorder Statistics

Statistics for each server that can process recordings

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Recorder Client Access (I3_ACCESS_RECORDER_CLIENT)
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID Description Type (Units) Parameter Set(s)
Available HTTP Client Connections inin.recorder:AvailableHttpConnections HTTP client threads available for accepting recordings statisticIntValue
  • ININ.Recorder:ContentServer
Available Local Disk Space inin.recorder:AvailableLocalDiskSpace Free disk space for recordings on the local machine in gigabytes StatisticDoubleValue(GB)
  • ININ.Recorder:ContentServer
Available Log Disk Space inin.recorder:AvailableLoggingDiskSpace Free disk space for logs in gigabytes StatisticDoubleValue(GB)
  • ININ.Recorder:ContentServer
Available Share Disk Space inin.recorder:AvailableShareDiskSpace Free disk space for recordings on network shares in gigabytes StatisticDoubleValue(GB)
  • ININ.Recorder:ContentServer
Configured For Amazon S3 inin.recorder:ConnectedToS3 Indicates whether or not Recorder Server is configured to use Amazon's Simple Storage Service. statisticBoolValue
  • ININ.Recorder:ContentServer
Failed Transfers Last Hour inin.recorder:FailedTransfers Number of recordings failed to transfer last hour statisticIntValue
  • ININ.Recorder:ContentServer
Memory Usage inin.recorder:MemoryUsage The amount of paged physical memory (working set) that a content server is using, expressed in kilobytes. statisticIntValue(KB)
  • ININ.Recorder:ContentServer
Recordings Played Back Last Hour inin.recorder:RecordingsPlayedBack Recordings played back in the last hour statisticIntValue
  • ININ.Recorder:ContentServer
Recordings Successfully Processed Last Hour inin.recorder:RecordingsSuccessfullyProcessed Number of recordings successfully processed last hour statisticIntValue
  • ININ.Recorder:ContentServer
Total CPU Usage inin.recorder:CpuUsageTotal The value is the sum of CPU utilization reported by Windows across all cores present in the machine. A value of 100% on a four core machine would indicate that all cores are completely used. statisticPercentValue(%)
  • ININ.Recorder:ContentServer

Back to top

Recording

The statistics in this category describe activity in Interaction Recorder. These statistics are updated at the regular statistics interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Encumbered Recordings (last Hour) inin.system.recording:UnlicensedRecordingsLastHour | Number of recordings in the previous 60-minute interval where one or more of the internal participants does not have an Interaction Recorder Access license. | statisticIntValue |
Encumbered Recordings (today) inin.system.recording:UnlicensedRecordingsToday | Number of recordings since midnight where one or more of the internal participants does not have an Interaction Recorder Access license. | statisticIntValue |
Recorder Database Is Available inin.system.recording:DatabaseAvailable | Indicates whether the Interaction Recorder system can connect to its database. | statisticBoolValue |
Recorder Is Processing Recordings inin.system.recording:ProcessingRecordings | Indicates whether the Interaction Recorder system is currently processing recordings. | statisticBoolValue |
Recording Lag Time inin.system.recording:LagTime | If this stat is increasing to a high level, it could indicate that more Media Servers or Remote Content Servers should be added. | statisticTimeDurationValue |
Recording Storage Locations inin.system.recording:NumberConnectedCaptureServers | The number of recording storage locations. | statisticIntValue |
Recording Storage Locations Low On Space inin.system.recording:NumberLowDiskCaptureServers | The number of recording storage locations that are 90% or more full. | statisticIntValue |
Recordings In Progress inin.system.recording:NumberOfRecordingInteraction | Number of recordings that Interaction Recorder is conducting. | statisticIntValue |
Successful Recordings (last Hour) inin.system.recording:SuccessProcessedLastHour | Number of successful recordings that occurred in the last sixty minutes. | statisticIntValue |
Successful Recordings (today) inin.system.recording:SuccessProcessedToday | Number of successful recordings that occurred since midnight. | statisticIntValue |
Unsuccessful Recordings (last Hour) inin.system.recording:UnSuccessfullRecordingsLastHour | The number of failed recordings that occurred in the last sixty minutes. | statisticIntValue |
Unsuccessful Recordings (today) inin.system.recording:UnSuccessfullRecordingsToday | The number of unsuccessful recordings that occurred since midnight. | statisticIntValue |

Back to top

Session Manager Statistics

Statistics for each running Session Manager are given both as a total and broken down by device type.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID Description Type (Units) Parameter Set(s)
Session Count inin.sessionmanager:SessionCount The number of active sessions that are currently running on the given Session Manager. statisticIntValue
  • ININ.SessionManager:Server
  • ININ.SessionManager:SessionManager
  • ININ.SessionManager:ProductId

Back to top

Speech Recognition

The statistics in this category describe speech recognition activity in IC.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Current Speech Recognition Sessions inin.system.speechrecognition:CurrentRecognitionSessions | Number of speech recognition sessions currently occurring in the system. | statisticIntValue |
Peak Number Of Recognition Sessions inin.system.speechrecognition:PeakRecognitionSessions | The peak number of concurrent speech recognition sessions since the system was started. | statisticIntValue |

Back to top

StatAlertServer Statistics

Stats published by StatAlertServer which show information dealing with Stats, Alerts, and Memos

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Alert Rule Count inin.statalertserver:AlertRuleCount | Total number of Alert Rules known to StatAlertServer | statisticIntValue |
AlertSet Count inin.statalertserver:AlertSetCount | The total number of AlertSets known to StatAlertServer. | statisticIntValue |
Expander Alert Count inin.statalertserver:ExpanderAlertCount | The number of Expander Alerts (ie. Time In Status) known to StatAlertServer | statisticIntValue |
Total Alert Count inin.statalertserver:TotalAlertCount | The total number of alerts in the system, including the effective number alerts caused by the Expander Alerts. | statisticIntValue |
Total Memo Count inin.statalertserver:TotalMemoCount | The total number of Memos known to StatAlertServer. | statisticIntValue |

Back to top

Tracker Server

These performance statistics indicate the overall health of Interaction Tracker Server in the previous ten minute interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Failed Tracker Transactions inin.system.trackerserver:FailedTransactions | Number of transactions sent to Tracker Transaction Server in the last ten minute period that failed. A high value indicates that Tracker Transaction Server may be down. | statisticIntValue |
Interaction Segment Notifications inin.system.trackerserver:InteractionNotifications | Number of update notifications sent by Queue Manager to Interaction Tracker. This indicates how busy the server is, after having processed state changes of objects in the system (e.g. hold to voice mail, etc.). | statisticIntValue |
Posted Tracker Transactions inin.system.trackerserver:PostedTransactions | Number of transactions sent to Tracker Transaction Server for processing in the last ten minute period. | statisticIntValue |

Back to top

Transaction Server

Transaction Server statistics indicate the overall health of Transaction Server-a generic transaction server for recording, logging, etc. These performance statistics indicate the overall health of Transaction Server in the previous ten minute interval.

Note
Statistics in this category require at least one of the following licenses:
  • Interaction Supervisor Plug-In: System Status (I3_ACCESS_SYSTEM_STATUS_SUPERVISOR_PLUGIN)
Title / Statistic ID | Description | Type (Units) | Parameter Set(s)
Average Successful Transaction Time inin.system.transactionserver:AverageTimeForSuccessful | Average amount of time that Transaction Server needed to process a transaction in the previous ten minute interval. | StatisticDoubleValue |
Executed Transactions inin.system.transactionserver:ExecutedTransactions | Number of transactions that Transaction Server successfully executed in the previous ten minute interval. | statisticIntValue |
Failed Transactions inin.system.transactionserver:FailedTransactions | Number of transactions that Transaction Server failed to execute in the previous ten minute interval. A high value could indicate that database errors are occurring. | statisticIntValue |

Back to top

Workgroup Statistics

Workgroup statistics summarize ACD interactions, number of agents logged on, and other particulars that are common to the workgroup as a whole. The workgroup may or may not have associated queues.

Note
Statistics in this category require at least one of the following licenses:
  • Client Access (I3_ACCESS_CLIENT)
  • Interaction Supervisor Plug-In: Workgroup (I3_ACCESS_WORKGROUP_SUPERVISOR_PLUGIN)
Title / Statistic ID Description Type (Units) Parameter Set(s)
Abandon Rate Distributions inin.workgroup:AbandonedRateDistribution Abandoned rate distribution for an accumulative/partial sum bucket, workgroup, interaction type and time interval. The number of abandoned calls for each bucket is divided by the number of call that entered into the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
  • ININ.Queue:AccumulativeHistogramInterval
- or -
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
  • ININ.Queue:PartialSumHistogramInterval
Abandon Rate Missed Target inin.workgroup:AbandonedRateMissedTarget The number of calls that are abandoned outside of the service level target. It divides that number with the number of calls that entered into the workgroup queue to get this value in percentage. statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
Abandon Rate Target inin.workgroup:AbandonedRateTarget This statistics represent abandoned calls that happened within the service level target configuration. In addition, the number of those calls is divided by the number of calls that entered into the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
Agents Available inin.workgroup:AgentsAvailable The Available Agent Count of logged on agents that are available for ACD interactions. See definitions for Logged On and Available to take ACD interactions. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Agents In Status inin.workgroup:AgentsInStatus Number of agents in a particular status. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.People:Status
Available For ACD Interactions inin.workgroup:NumberAvailableForACDInteractions The number of agents available to take ACD interactions. An agent is considered to be available to take ACD interactions if all of the following apply: a) the agent is not on another interaction, b) the agent has an available status, c) the agent is logged on, d) the agent is activated on the specified workgroup. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Average Agent Negative Score inin.workgroup:AverageAgentNegativeKwScore Sum up agent negative score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Average Agent Positive Score inin.workgroup:AverageAgentPositiveKwScore Sum up agent positive score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Average Customer Negative Score inin.workgroup:AverageCustomerNegativeKwScore Sum up customer negative score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Average Customer Positive Score inin.workgroup:AverageCustomerPositiveKwScore Sum up customer positive score divided by the total number of calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Average Hold Time inin.workgroup:AverageHoldTime Total amount of hold time that on different ACD interactions, divided by number of ACD interactions handled by All Agents. statisticDurationValue(s)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Average Talk Time inin.workgroup:AverageTalkTime Total amount of time that All Agents spent on different ACD interactions, divided by number of ACD interactions handled by All Agents. statisticDurationValue(s)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Average Wait Time inin.workgroup:AverageWaitTime The total time that different ACD interactions waited in the Workgroup Queue before they were ACD assigned, divided by number of ACD interactions for the period reported. statisticDurationValue(s)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Highest Active Agent Positive Score inin.workgroup:BestActiveAgentKwScore Highest agent positive score for active calls statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Highest Active Customer Positive Score inin.workgroup:BestActiveCustomerKwScore Highest customer positive score for active calls statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Interactions Abandoned inin.workgroup:InteractionsAbandoned Number of interactions that were externally disconnected by the remote party before they could be client connected (picked up by an agent). Tip: the IC data dictionary provides supplemental information about abandoned calls. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Interactions Answered inin.workgroup:InteractionsAnswered Number of interactions answered, calculated as the number of ACD interactions from the specified workgroup that went to a Connected state in the agent's queue. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Interactions Answered inin.workgroup:InteractionsConnected Total number of interactions answered, which went from ACD - Wait Agent to ACD - Assigned. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Interactions Completed inin.workgroup:InteractionsCompleted Number of interactions completed (that went from a state of ACD - Assigned to ACD - Disconnected). statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Interactions Flowed-Out inin.workgroup:InteractionsFlowedOut Number of interactions flowed-out. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Interactions Held inin.workgroup:TotalInteractionsOnHold Number of interactions held. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Interactions On Hold inin.workgroup:InteractionsOnHold Number of interactions currently on hold. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Interactions Received inin.workgroup:InteractionsEntered Total number of interactions that entered the queue. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Interactions Waiting inin.workgroup:InteractionsWaiting Number of interactions waiting to be connected to an agent. These interactions are currently in the ACD - Wait Agent state. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Logged On inin.workgroup:LoggedIn The number of agents logged on for the specified workgroup. This is also the number of agents who are logged on the current server. This count does not include agents who are logged on to peer servers for the same workgroup. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Logged On + Activated inin.workgroup:AgentsLoggedInAndActivated The number of activated agents logged on for the specified workgroup. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Logged On Agents In This Workgroup inin.workgroup:AgentsLoggedIn Number of logged on agents in this workgroup. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Available inin.workgroup:LongestAvailable Longest period of time an agent is available. In other words, the duration of the longest available agent to take an ACD interaction for the specified workgroups. See Available to take ACD interactions. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Hold Time inin.workgroup:LongestOnHoldTime Time of the longest currently on hold interaction. This interaction has been in a Hold state the longest. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Inbound ACD Interaction inin.workgroup:LongestInboundACDInteraction Duration of the longest of the currently active inbound ACD interactions, or N/A if there is no inbound ACD interaction active. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Interaction Waiting inin.workgroup:LongestWaitTime Time of the longest currently waiting interaction. This interaction has been in the ACD - Wait Agent state the longest. Its duration is the amount of time that the interaction has waited to be picked up by an available agent, based on time in queue only. Supervisor workflow statistics always pertain to time in a workgroup or user interaction. Overall time in the system (such as time in IVR) is not counted. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Non-ACD Interaction inin.workgroup:LongestNonACDInteraction Duration of the longest of the currently active non-ACD interactions, or N/A if there is not an active non-ACD interaction. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Outbound ACD Interaction inin.workgroup:LongestOutboundACDInteraction Duration of the longest active outbound ACD interaction, or N/A if there is no active outbound ACD interaction. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Longest Talk Time inin.workgroup:LongestTalkTime Time of the longest currently connected interaction. This interaction has been in a Connected state the longest. statisticTimeDurationValue
  • ININ.People.WorkgroupStats:Workgroup
Lowest Active Agent Negative Score inin.workgroup:WorstActiveAgentKwScore Lowest agent negative score for active calls statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Lowest Active Customer Negative Score inin.workgroup:WorstActiveCustomerKwScore Lowest customer negative score for active calls statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Not Available For ACD Interactions inin.workgroup:NotAvailable Number of agents not available to take ACD interactions. The number of logged on and active agents minus the agents available for any interaction. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
On Inbound ACD Interactions inin.workgroup:OnInboundACDInteractions Number of agents on inbound ACD interactions. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
On Inbound ACW inin.workgroup:OnInboundACW Number of agents performing after call wrap-up work after receiving an ACD interaction. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
On Non-ACD Interactions inin.workgroup:NonACDInteractions Number of agents on non-ACD interactions. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
On Outbound ACD Interactions inin.workgroup:OnOutboundACDInteractions Number of agents on outbound ACD interactions. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
On Outbound ACW inin.workgroup:OnOutboundACW Number of agents performing after call wrap-up work to conclude an outbound ACD interaction. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Percent Available inin.workgroup:PercentAvailable Percent of logged on agents that are available for ACD interactions. ((available to take ACD interactions / logged on) * 100) statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
Service Level Distributions inin.workgroup:ServiceLevelDistribution The interactions that connected callers to agents within a specified time interval. The number of answered calls for each bucket is divided by the number of calls answered in the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
  • ININ.Queue:AccumulativeHistogramInterval
- or -
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
  • ININ.Queue:PartialSumHistogramInterval
Service Level Missed Target inin.workgroup:ServiceLevelMissedTarget The number of calls answered that did not make the service level target. The number of those calls is divided by the number of calls answered for the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
Service Level Target inin.workgroup:ServiceLevelTarget The number of calls answered that within the service level target configuration (inclusive) for the given workgroup queue, interaction type and interval (current period, shift, etc). The number of answered calls for each bucket is divided by the number of calls answered for the workgroup queue to represent this value in percentage. statisticPercentValue(%)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queues:InteractionType
  • ININ.Queue:Interval
Total Agent Negative Score inin.workgroup:TotalAgentNegativeKwScore Sum up agent negative score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Total Agent Positive Score inin.workgroup:TotalAgentPositiveKwScore Sum up agent positive score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Total Agents inin.workgroup:TotalAgents Total number of agents in the specified workgroups. This is typically the number of users that are members of the specified workgroup on the current server. This statistic does not take into account members of the same workgroup on peer servers. statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
Total Customer Negative Score inin.workgroup:TotalCustomerNegativeKwScore Sum up customer negative score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Total Customer Positive Score inin.workgroup:TotalCustomerPositiveKwScore Sum up customer positive score from calls in the current/previous period or shift statisticIntValue
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Total Hold Time inin.workgroup:TotalHoldTime Total amount of hold time that on different ACD interactions. statisticDurationValue(s)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Total Talk Time inin.workgroup:TotalTalkTime Total amount of time that All Agents spent on different ACD interactions. statisticDurationValue(s)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval
Total Wait Time inin.workgroup:TotalWaitTime The total time that different ACD interactions waited in the Workgroup Queue before they were ACD assigned. statisticDurationValue(s)
  • ININ.People.WorkgroupStats:Workgroup
  • ININ.Queue:Interval

Back to top


Getting Started with Custom Notifications

[image]

IceLib Technical Reference
Getting Started with Custom Notifications
Send Feedback

This page covers setting up IceLib custom handler and inter-application notifications via CustomNotification and some of its associated classes (CustomResponse, CustomRequest, CustomMessage, CustomMessageHeader, CustomMessageType, and CustomNotificationReceived). All of these classes are contained in the ININ.IceLib.Connection.Extensions namespace.

Jump to a section:

  • General Concepts
  • Custom Handler Notifications
  • Inter-Application Notifications

General Concepts

This section contains the following subsections.

  • Overview
  • About Custom Messages

Overview

The CustomNotification class allows initiation of custom handlers via SendServerRequestNoResponse (or SendServerRequestNoResponseAsync) and inter-application notifications via SendApplicationRequest (or SendApplicationRequestAsync) and SendApplicationResponse (or SendApplicationResponseAsync). The CustomNotification class also allows for reception of notifications from either custom handlers or other applications via the CustomNotificationReceived event. The request and response functions utilize the CustomRequest and CustomResponse classes respectively to send notifications. The CustomRequest and CustomResponse classes both rely on the CustomMessage class to send custom notifications. Likewise the CustomNotificationReceived event passes a parameter of the type CustomNotificationReceivedEventArgs which relies on the CustomMessage class to receive custom message notifications.

Back to Introduction

About Custom Messages

The CustomMessage class, the data transfer container for all CustomNotifications, is uniquely identified by its CustomMessageHeader. A CustomMessageHeader, and hence a CustomMessage, is uniquely identified by its four components the CustomMessageType, ObjectType, ObjectId, and EventId. Applications will have to know what type(s) of CustomMessages they will receive, and start watching accordingly. Applications start watches, via StartWatching or StartWatchingAsync for messages uniquely identified by a CustomMessageHeader. When the CustomMessageHeader(s) are matched the CustomNotificationReceived event, which should be hooked prior to any start watch calls, will be invoked.

CustomMessageType is the first part of identification of a CustomMessageHeader. It represents the message type and can have the values ServerNotification, ApplicationRequest or ApplicationResponse. ServerNotification is the notification type that an application will send to or receive from a custom handler. Notifications are sent to a custom handler via the SendServerRequestNoResponse or SendServerRequestNoResponseAsync methods. ApplicationRequest is the notification type that an application will receive when another application sends out notification via the SendApplicationRequest or SendApplicationRequestAsync methods. ApplicationResponse is the notification type that an application will receive when another application responds to an ApplicationRequest via the SendApplicationResponse or SendApplicationResponseAsync methods.

ObjectType is the second part of identification of a CustomMessageHeader. This represents the class of message and will always be a String with the value "Custom" for all CustomNotifications.

ObjectId is the third part of identification of a CustomMessageHeader and can be any user determined string.

EventId is the fourth part of identification of a CustomMessageHeader and can be any user determined string.

Back to Introduction

Custom Handler Notifications

This section contains the following subsections.

  • Custom Handlers - Background
  • Generating a Custom Handler Notification
  • Custom Handler Example

Custom Handlers - Background

When it is desirable IC Server's functionality may be extended via custom handlers, which are developed using Interaction Designer. Interaction Designer is IC's graphical programming and application generator tool.

All custom handlers always start with an initiator as their first step and an initiator is comprised of a set of events that start a custom handler. Custom handlers are registered with Interaction Processor, which watches for matching initiator events and launches the proper custom handler when an when a match is found. "Custom Notification", is one of the available Initiators when changing a custom handlers initiator and triggers on notifications sent via the SendServerRequestNoResponse or SendServerRequestNoResponseAsync methods. Additionally during a custom handlers execution it can send a custom notification as one of its steps. This custom notification can be picked up with the CustomNotificationReceived event assuming the event is hooked and the appropriate StartWatching or StartWatchingAsync call was made.

A CustomNotification initiator can be initiated via IceLib by sending a CustomRequest via SendServerRequestNoResponse or SendServerRequestNoResponseAsync. See the following section Generating a Custom Handler Notification for more information on building a notification for a custom handler.

Back to Introduction

Generating a Custom Handler Notification

Initiating a custom handler is possible through the SendServerRequestNoResponse or SendServerRequestNoResponseAsync methods. StartWatching or StartWatchingAsync can be used along with the CustomNotificationReceived event to receive notifications from a custom handler when it sends out a custom notification.

Note

Custom handlers only support an array of strings as message data. Ensure that any CustomRequests sent via SendServerRequestNoResponse or SendServerRequestNoResponseAsync only contain an array of strings by only utilizing the CustomRequest..::..Write(String []) method. Also any CustomMessages received via the CustomNotificationReceived event with the CustomMessageType of ServerNotification are only read from with the ReadStrings method.

Back to Introduction

Custom Handler Example

In this example the CreditCardSwipeCustomNotification class takes care of processing a credit card swipe and sending the proper information off to a custom handler installed on the IC Server. The custom handler would process the custom notification's ITEMCODE to determine a price and would then send a custom notification. The class CrediCardSwipedCompletePurchase would receive the custom handler's custom notification and process the information sent along to actually complete the purchase.

CopyC#
class CreditCardSwipeCustomNotification
{
    private CustomNotification _customNotification;
    public CreditCardSwipeCustomNotification(Session session)
    {
        _customNotification = new CustomNotification(session);
    }

    public void SendCreditCardSwipe()
    {
        //Load a string array with the message
        String[] purchaseInfo = new string[]
                        {
                            "Master Card",
                            "1234 5678 9876 5432",
                            "01/2014",
                            "965",
                            "ITEMCODE:12345" //An item code that will be used to look-up price
                        };

        //Create a custom request, the targeted custom handler should be watching for object ID "SwipeObjectID"
        // and notification event (event ID) "SwipeEventID". Both of these strings would be entered into the
        // custom notification initiator of the custom handler. NOTE: both strings would be entered without
        // quotes.
        CustomRequest creditCardSwipeNotification = new CustomRequest(
            new CustomMessageHeader(CustomMessageType.ServerNotification, "SwipeObjectID", "SwipeEventID"));
        //Load the request with data
        creditCardSwipeNotification.Write(purchaseInfo);
        //Send the notification to the custom handler
        _customNotification.SendServerRequestNoResponse(creditCardSwipeNotification);
    }
}

CopyC#
class CrediCardSwipedCompletePurchase : CustomNotification
{
    public CrediCardSwipedCompletePurchase(Session session)
        : base(session)
    {
        CustomNotificationReceived += HandleCompletePurchaseCustomNotification;

        //The custom handler would send a custom notification with
        // a Custom Object Identifier of "CompletePurchaseObjectID and
        // a Custom Event Identifier of "CompletePurchaseEventID".
        CustomMessageHeader customHandlerMessageHeader = new CustomMessageHeader(
            CustomMessageType.ServerNotification, "CompletePurchaseObjectID", "CompletePurchaseEventID");

        StartWatching(new[] { customHandlerMessageHeader });
    }

    private void HandleCompletePurchaseCustomNotification(object sender, CustomNotificationReceivedEventArgs e)
    {
        var infoForPurchase = e.Message.ReadStrings();

        if (infoForPurchase != null && infoForPurchase.Length > 4)
        {
            var creditCardType = infoForPurchase[0];
            var creditCardNumner = infoForPurchase[1];
            var creditCardExpirationDate = infoForPurchase[2];
            var creditCardCSV = infoForPurchase[3];
            var itemPrice = infoForPurchase[4];

            MakePurchase(creditCardType, creditCardNumner, creditCardExpirationDate, creditCardCSV, itemPrice);
        }

    }
}

Back to Introduction

Inter-Application Notifications

This section contains the following subsections.

  • Application Requests and Application Responses
  • Application to Application Custom Notification Example

Application Requests and Application Responses

The SendApplicationRequest and SendApplicationRequestAsync methods can be used to send out requests to other logged in IceLib applications. An IceLib application can listen for application requests by using StartWatching or StartWatchingAsync and respond by using SendApplicationResponse or SendApplicationResponseAsync.

Back to Introduction

Application to Application Custom Notification Example

Application Custom Notifications:

Application A wants to send out a custom notification with ObjectId "AppAObjectId" and EventId "AppAEventId" to to a custom handler that application B watches for. Application B sends back a custom notification with an array of strings containing "Foo" and "Bar".

In order for application B to receive this custom notification, first it would setup an event handler to listen for the CustomNotificationReceived event and then it would StartWatching or StartWatchingAsync on a CustomMessageHeader with CustomMessageType of ApplicationRequest, ObjectId "AppAObjectId" and EventId "AppAEventId". Notice that the handler HandleApplicationACustomNotification creates a CustomResponse object with the received message. SendApplicationResponse modifies the CustomMessageType to be ApplicationResponse and utilizes the ObjectId and EventId from the passed in message.

CopyC#
class ApplicationBCustomNotification : CustomNotification
{
    public ApplicationBCustomNotification(Session session)
        : base(session)
    {
        CustomNotificationReceived += HandleApplicationACustomNotification;

        CustomMessageHeader applicationAMessageHeader = new CustomMessageHeader(
            CustomMessageType.ApplicationRequest, "AppAObjectId", "AppAEventId");

        StartWatching(new[] { applicationAMessageHeader });
    }

    private void HandleApplicationACustomNotification(object sender, CustomNotificationReceivedEventArgs e)
    {
        //Create a custom response
        CustomResponse applicationBResponse = new CustomResponse(e.Message);
        //Load a string array with the message
        String[] message = new string[]
                        {
                            "Foo",
                            "Bar",
                        };
        //Load the message into the custom request
        applicationBResponse.Write(message);
        //Send the message to application A
        SendApplicationResponse(applicationBResponse);
    }
}

In order for the application A to receive the custom notification that application B is responding with, first it would setup an event handler to listen for the CustomNotificationReceived event and then it would StartWatching or StartWatchingAsync, on a CustomMessageHeader with CustomMessageType of ApplicationResponse, ObjectId "AppAObjectId" and EventId "AppAEventId". Notice that the ObjectId and the EventId are the same as those sent with the request; this is because by convention a SendApplicationResponse is created with the original message.

To start triggering the request notifications from application A to application B and the response back, application A would call SendApplicationRequest() from the snippet below.

CopyC#
class ApplicationACustomNotification : CustomNotification
{
    public ApplicationACustomNotification(Session session)
        : base(session)
    {
        CustomNotificationReceived += HandleApplicationBCustomNotification;

        CustomMessageHeader applicationBMessageHeader = new CustomMessageHeader(
            CustomMessageType.ApplicationResponse, "AppAObjectId", "AppAEventId");

        StartWatching(new[] { applicationBMessageHeader });
    }

    private void HandleApplicationBCustomNotification(object sender, CustomNotificationReceivedEventArgs e)
    {
        //Application B response received perform an action
        try
        {
            //Attempt to read the strings sent from application B
            string[] message = e.Message.ReadStrings();
            if (message.Contains("Foo") && message.Contains("Bar") && message.Length == 2)
            {
                Console.WriteLine("Application B responded with the expected strings: {0}",
                                  String.Join(",", message));
            }
            else
            {
                Console.WriteLine("Application B responded, but not with the expected strings: {0}",
                                  String.Join(",", message));
            }
        }
        catch (ININ.IceLib.IceLibException)
        {
            Console.WriteLine("Application B responded, but did not include any strings.");
        }
    }

    public void SendApplicationRequest()
    {
        //Create a custom request
        CustomRequest applicationARequest = new CustomRequest(
            new CustomMessageHeader(CustomMessageType.ApplicationRequest, "AppAObjectId", "AppAEventId"));
        //Send the notification to application B
        SendApplicationRequest(applicationARequest);
    }
}

Back to Introduction


Concepts

[image]

IceLib Technical Reference
Concepts
Send Feedback

This section includes documentation on some fundamental concepts which are common to many different areas of the IceLib API. Some concepts are simple, while others contain nuances that can trip up developers. These topics strive to clarify these general points, providing conceptual context for utilizing elements throughout the IceLib API.

Authentication
In order to connect to the Interaction Center server using IceLib, authentication must be provided. This page contains information about authenticating with IceLib, the various authentication types, and the related settings that affect authentication.

Version Information
IceLib API elements have documentation describing their release version information.

How Watches Work
Many classes in IceLib require a watch to be active for certain properties to be accessible or for certain events to be raised.

How Async Calls Work
IceLib provides synchronous (blocking) and asynchronous (non-blocking) versions of most methods, especially those methods that make a server call.

Handling Exceptions
IceLib methods throw a variety of exceptions that should be handled appropriately in order to avoid having unhandled exceptions (and subsequent application crashes) in an IceLib-based application.

HTTPS File Transfer
A new HTTPS File Transfer mechanism was introduced in 4.0 IceLib.

Integration Options
There are several different types of IceLib-based integrations. Some examples are described on this page.

Certificate Validation
On a default installation, IceLib-based applications do not perform client-side validation of server certificates; however, this option can be turned on.

IceLib SDK 32-bit vs. 64-bit
The IceLib SDK is available in 32-bit and 64-bit versions.

Deploying Custom IceLib-based Applications
There are several things that need to be considered when deploying a custom IceLib-based application.


Authentication

[image]

IceLib Technical Reference
Authentication
See Also Send Feedback

In order to connect to the Interaction Center server using IceLib, authentication must be provided. IceLib supports several types of authentication which are described below. Additionally, the sections below also describe some Interaction Center server settings that affect which authentication methods are available for use via IceLib connections.

See the Connecting to the Server "Getting Started" page for an examples of authentication.

This topic contains the following sections.

  • Allowed Authentications
  • Basic Authentication
    • Interaction Center Based Authentication
    • Windows Based Authentication
    • Manual Windows Based Authentication
  • Proxy Authentication
    • Interaction Center Based Proxy Authentication
    • Windows Based Proxy Authentication
    • Alternate Windows Based Proxy Authentication
  • Single Sign-On
    • Security Assertion Markup Language 2.0 (SAML 2.0)
  • See Also

Allowed Authentications

Interaction Center provides configuration options in Interaction Administrator to control what types of authentication can be used when connecting. The configuration options are provided to limit the options provided to end users to meet security requirements or to prevent users from accidentially using options that will not work with the configuration of the Interaction Center server.

The GetAllowableAuthentications(HostSettings, String) method allows retrieval of the supported authentication modes. The isoLanguage parameter specifies the language in which the Single Sign-On (SSO) provider's display name information should be returned, if any SSO provider is specified.

These supported authentication modes are configured in Interaction Administrator in the System Configuration dialog on the Connection Security tab, by selecting the Configure logon authentication. On the Logon Authentication Configuration dialog, the Authentication Method section has options for which types of authentication will be allowed. When establishing an IceLib connection, the server enforces these settings.

Applications must only use the options enabled or the connection will be denied by the server. The method describe above is useful for applications to query the server for what application methods are allowed. This can be done before prompting the user for credentials to ensure they are only presented with options that are enabled.

Basic Authentication

There are three main types of basic authentication with IceLib: Interaction Center (IC) based authentication, current Windows session based authentication, and explicit Windows credentials based authentication. These are described in detail below.

Interaction Center Based Authentication

Basic authentication can be based on Interaction Center credentials. Interaction Center supports the configuration of passwords directly on user objects in Interaction Administrator. The password configured on a user is subject to the password policy, if any, that is configured for that user. This password can be changed through Interaction Administrator (on the user object via the Password setting), or by the end-user via ININ applications such as the Interaction Client or Interaction Center Business Manager (ICBM).

The use of this authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the Allow IC authentication setting enabled.

In IceLib, this type of authentication is supported via the ICAuthSettings class. It requires the Interaction Center credentials of the user.

Windows Based Authentication

Basic authentication can be based on the credentials of the Windows session under which the IceLib connection is being established. For this to work, an association of the Windows account must be made with the Interaction Center user in Interaction Administrator on the user object via the NT Domain User setting.

The use of this authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the Allow Windows authentication setting enabled.

In IceLib, this type of authentication is supported via the WindowsAuthSettings class. It automatically uses the Windows credentials of the current Windows session.

Manual Windows Based Authentication

Basic authentication can be based on explicit credentials of a Windows session, either the same or different than the one under which the IceLib connection is being established. In this case, the actual Windows domain/user and password will be provided to the login process. For this to work, an association of the Windows account must be made with the Interaction Center user in Interaction Administrator on the user object via the NT Domain User setting.

The use of this authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the Allow manual entry of Windows authentication credentials setting enabled.

In IceLib, this type of authentication is supported via the AlternateWindowsAuthSettings class. It requires the explicit Windows credentials of the user (e.g. domain/user and password).

Proxy Authentication

For certain server-side application integrations, it can be necessary to establish IceLib sessions on behalf of end-users. For instance, a server-side IceLib-based service that must integrate with 3rd-party software by creating an IceLib session for each agent in order to perform its work.

In this case, the server-side application does not have access to the end-user's Interaction Center or Windows credentials with which to establish a connection for them. IceLib provides a solution to this problem by allowing configuration of an "elevated rights" user that has the right to serve as a proxy for the authentication of other Interaction Center users. The "elevated rights" user should be created specifically for the server-side application's use, with very few rights other than the ability to proxy authentication.

The "elevated rights" user must have a specific "Proxy Logins" Access Control right configured on their Interaction Center User via the Interaction Administrator application. This setting is in the Miscellaneous section of the Access Control settings.

There are three types of proxy authentication with IceLib: Interaction Center (IC) based proxy authentication, current Windows session based proxy authentication, and alternate Windows session based proxy authentication. These are described in detail below.

Interaction Center Based Proxy Authentication

Proxy authentication can be based on Interaction Center credentials. The Interaction Center supports the configuration of passwords directly on user objects in Interaction Administrator. The password configured on a user is subject to the password policy, if any, that is configured for that user. This password can be changed through Interaction Administrator (on the user object via the Password setting), or by the end-user via ININ applications such as the Interaction Client or Interaction Center Business Manager (ICBM).

The use of this authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the Allow IC authentication setting enabled.

In IceLib, this type of authentication is supported via the ProxyAuthSettings class. It requires both the Interaction Center credentials of the "elevated rights" user as well as either the Interaction Center user ID or Windows domain/password for the user which to proxy authentication. If the Windows domain/password is specified for the user for which to proxy authentication, then the Interaction Center user object for that user being proxied must also have the correct NT Domain User setting.

Windows Based Proxy Authentication

Proxy authentication can be based on the credentials of the Windows session under which the IceLib connection is being established. For this to work, an association of the Windows account must be made with the Interaction Center user in Interaction Administrator on the user object via the NT Domain User setting.

The use of this authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the Allow Windows authentication setting enabled.

In IceLib, this type of authentication is supported via the ProxyWindowsAuthSettings class. It automatically uses the Windows credentials of the current Windows session and also requires either the Interaction Center user ID or Windows domain/password for the user which to proxy authentication. If the Windows domain/password is specified for the user for which to proxy authentication, then the Interaction Center user object for that user being proxied must also have the correct NT Domain User setting.

Alternate Windows Based Proxy Authentication

Proxy authentication can be based on the credentials of a specified Windows session under which the IceLib connection is being established. For this to work, an association of the Windows account must be made with the Interaction Center user in Interaction Administrator on the user object via the NT Domain User setting.

The use of this authentication type requires the Logon Authentication Configuration dialog in Interaction Administrator to have the Allow Windows authentication setting enabled.

In IceLib, this type of authentication is supported via the ProxyAlternateWindowsAuthSettings class. Unlike the Windows based proxy authentication that uses the current Windows session, this authentication requires a Windows user and password to be supplied. It also requires either the Interaction Center user ID or Windows domain/password for the user which to proxy authentication. Because this authentication requires a Windows user and password to be specified, special care should be taken when using this method in cases where this information is required to be persisted. If the Windows domain/password is specified for the user for which to proxy authentication, then the Interaction Center user object for that user being proxied must also have the correct NT Domain User setting.

Single Sign-On

Single Sign-On (SSO) provides the ability for Interaction Center to delegate the responsibility of authenticating users to a centralized authentication server. This setup means that users do not need separate credentials for the Interaction Center system. They only need to remember the credentials for a company's central authentication server.

Note
Active Directory Federation Services (ADFS) is an example of an Identity Provider that allows Single Sign-On.

The use of this authentication type requires one or more configured SSO Identity Providers. The Identity Providers are configured in Interaction Administrator under Single Sign-On, Identity Providers.

In IceLib, this type of authentication is supported via the SecurityTokenServiceAuthSettings class. The list of configured Identity Providers is provided to IceLib through the GetAllowableAuthentications(HostSettings, String) method whose response contains the list of AuthProviderDefinitions. These definitions contain the display name for the Identity Provider and the AuthProviderContext instance which is required to create an instance of the setting class. The context class also provides information about what information the Identity Provider will need to authenticate.

The SecurityTokenServiceAuthParameters class has several options including properties for specifying the user name and password (the needs vary by the Identity Provider). This class also provides a place for IceLib applications to register a callback for when Identity Providers need additional information for authentication. For example, if the user name and password were not specified, but the Identity Provider expects a user name and password, the instance of SecurityTokenServicePresenter will be called to provide the credentials.

The SecurityTokenServiceAuthParameters class additionally provides PersistToken and UsePersistedToken properties. These properties control how the Single Sign-On token will be shared between IceLib applications. When PersistToken is true, the authentication token is stored on the local machine for use when the application is reopened or other IceLib applications are started. When UsePersistedToken is true, IceLib will attempt to find and use a stored token eliminating the need for the user to enter their credentials. The HasCachedToken(HostEndpoint, AuthProviderContext, String) method can be called to determine if a token exists before attempting the connection allowing IceLib applications to obtain credentials before attempting the connection. It is important to note that the tokens can expire so a token may be available but may not authenticate.

See the Connecting to the Server "Getting Started" page for an example using SSO.

Security Assertion Markup Language 2.0 (SAML 2.0)

IceLib supports the Security Assertion Markup Language 2.0 (SAML 2.0) protocol for Single Sign-On. In SAML 2.0, the central authentication server is known as the Identity Provider and trust is setup between Interaction Center and the Identity Provider by exchanging certificates. Once configured, when IceLib connects to the Interaction Center server, the server directs IceLib to first authenticate with the Identity Provider. The Identity Provider authenticates the user and provides a signed response containing claims about the user back to IceLib which forwards the response to the Interaction Center server. The server then validates the response and, using the claims defined in the response, associates the IceLib session with the correct user in the Interaction Center system.

The SAML 2.0 specification defines several methods for performing authentication. IceLib supports the HTTP Redirect and HTTP POST binding for the Web Browser SSO profile, as well as the Enhanced Client or Proxy (ECP) profile.

See Also

Reference

SecurityTokenServiceAuthSettings
ICAuthSettings
WindowsAuthSettings
AlternateWindowsAuthSettings
ProxyAuthSettings
ProxyAlternateWindowsAuthSettings
ProxyWindowsAuthSettings


Version Information

[image]

IceLib Technical Reference
Version Information
Send Feedback

IceLib API elements have documentation describing their release version information. This can help clarify what IC Server Version is required at an installation to support a given API element usage in an IceLib-based application.

IC Server Version

Some IceLib API elements (e.g. namespaces, classes, methods, events, properties) will be added in a service update (SU) rather than being part of the initial release. For example, new API elements might be added in "4.0 SU 3" to augment what was initially available at "4.0". When this happens, frequently the IC Server must also have that SU applied in order for the IceLib API to function properly.

When this is the case, the documentation for that IceLib API element will include a note explaining that a particular IC Server version is required. If the IceLib API element is used with an IC server of the incorrect version, it usually throws a ININ.IceLib..::..ServerOperationNotSupportedException exception. The following figure shows a similar example from a 3.0 SU.

IC Server Version Requirement, for Service Updates

Additionally, the version information is included in a Version Information section on most API elements. For the 4.0 IceLib API element, this section details the minimum IC server release of 4.0 that is required, for example 'GA' or 'SU 2' (where 'GA' refers to the initial release of 4.0). For informational purposes, the Version Information section also details which 2.4 or 3.0 releases also supported the matching API element from the 3.0 IceLib API, if it contained a matching API element. The following figure shows an example.

IC Server Version Requirement


How Watches Work
Send Feedback

Watches are used to query the values of properties and to receive notifications when those properties change. A StartWatch or StartWatchAsync method must be called before these properties are available and before these events are raised. Failure to start a watch will cause some property getters to throw a NotCachedException.

How Watches Work

Many classes in IceLib require a watch to be active for certain properties to be accessible or for certain events to be raised. Some of these watches are just "all or nothing", meaning either they're active or not. Other watches are "parameterized", meaning that they only watch certain items.

Several methods and properties work together to support watches for IceLib classes that can be watched. Examples are:

Name | Description
StartWatching() | Starts watching the given class instance. This is an example of an "all or nothing" watch.
StartWatchingAsync() | Asynchronously starts watching the given class instance. This is an example of an "all or nothing" watch. See How Async Calls Work for more information.
StartWatching(items) | Starts watching the specified items for the given class instance. This is an example of a "parameterized" watch.
StartWatchingAsync(items) | Asynchronously starts watching the specified items for the given class instance. This is an example of a "parameterized" watch. See How Async Calls Work for more information.
bool IsWatching() | Determines whether a watch is active for the given class instance. This can be used for an "all or nothing" or a "parameterized" watch.
bool IsWatching(item) | Determines whether a watch is active for the specified item for the given class instance. This is used for a "parameterized" watch.
ChangeWatchedItems(items) | Changes the items being watched for the given class instance. The exact method name varies for different item types.
ChangeWatchedItemsAsync(items) | Asynchronously changes the items being watched for the given class instance. The exact method name varies for different item types. See How Async Calls Work for more information.
StopWatching() | Stops watching the given class instance. This can be used for an "all or nothing" or a "parameterized" watch.
StopWatchingAsync() | Asynchronously stops watching the given class instance. This can be used for an "all or nothing" or a "parameterized" watch. See How Async Calls Work for more information.

For classes that have properties tied to a watch, starting a watch on a class instance not only allows the properties to be invoked for that instance, but also causes the properties that are part of the watch to be initialized with their current values for that class instance.

Important
Watch-based properties are available for use once the class instance's StartWatching has completed or its StartWatchingAsynccompletedCallback has been raised.

For classes that have events tied to a watch, starting a watch on a class instance allows its related events to be raised. An example of this is a "changed event" for watched items on a class instance. Another example is an add or remove event for items in an "all or nothing" class instance watch.

Important
All event handlers should be added before calling StartWatching or StartWatchingAsync to avoid missing an event that is raised as part of the initial watch.

For parameterized watches, different instances of a given class type can have different items being watched. For these instances, watch-based properties are tied to the instance on which they are being invoked.

Tip
The items being watched on one class instance will not be available on a different class instance that is not watching those items. The following pseudocode illustrates this:
CopyC#
IceLibClass classInstance1 = new IceLibClass(...);
IceLibClass classInstance2 = new IceLibClass(...);

classInstance1.StartWatching(/* a collection causing item1 and item2 to be watched */);
classInstance2.StartWatching(/* a collection causing item2 and item3 to be watched */);

// These property getter succeed because classInstance1 is watching the specified items.
IceLibClassItem valueOfInstance1Item1 = classInstance1.Item1;
IceLibClassItem valueOfInstance1Item2 = classInstance1.Item2;

// These property getter succeed because classInstance2 is watching the specified items.
IceLibClassItem valueOfInstance2Item2 = classInstance2.Item2;
IceLibClassItem valueOfInstance2Item3 = classInstance2.Item3;

// This property getter fails because classInstance2 is not watching item1.
// It will throw an ININ.IceLib.NotCachedException.
IceLibClassItem valueOfInstance2Item1 = classInstance2.Item1;

// Summary: The classInstance1 watch on Item1 does not affect classInstance2's Item1 property.

Disconnected Sessions

Watches do not carry over from disconnects. After a Session reconnects, the IC Server will not be aware of watches that were started before it disconnected; therefore, events that were being watched will no longer be invoked. Calling the IsWatching method of a watch will still return true and therefore is not an effective way of determining if a watch is no longer active due to a Session disconnect. Checking a Session’s ConnectionState should be used instead. In the event that a Session does get disconnected while there are active watches, StopWatching or StopWatchingAsync will need to be called to clean up IceLib’s cache. After a new Session is connected, new watches can then be started by calling StartWatching or StartWatchingAsync.

Calling StartWatching, StopWatching, or ChangeWatched or their async counterparts after a disconnect will have the following results:

Action | Behavior | Exception
StartWatching() | No action is taken. | InvalidOperationException
StopWatching() | The watch is cleaned up. | None
ChangeWatched() | No action is taken. | InvalidOperationException

Not Cached Exceptions

Many classes in IceLib contain properties that are only available when a watch is active (i.e. when StartWatching has been called). Generally, these properties are documented to require a call to StartWatching.

If one of these properties is used without an active watch, then usually a NotCachedException is thrown.

Interaction and Queue Watches

There are two types of watches related to Interactions, allowing different use-cases. The events that get raised are for the class on which the StartWatch was called.

  • The first type is a watch for all Interactions on a given Queue. An example use of this type of watch would be as in the Interaction Client .Net Edition's "My Interactions" tab.
    • This is performed using the InteractionQueue class. First by adding an event handler to InteractionQueue.InteractionChanged then using its StartWatching/StartWatchingAsync method to start watching for changes. The InteractionAdded/InteractionRemoved events will also be raised from this watch. An InteractionQueue watch only causes InteractionQueue events to be raised (not Interaction class events), but it does also allow watched attributes to be retrieved from an Interaction instance on that queue, whether an Interaction watch is active or not.
  • The second type is a watch on a specific Interaction, perhaps for more advanced editing that needs to watch a broader set of attributes on the Interaction. An example of this type of watch would be as in the Interaction Client .Net Edition's dialog for viewing an individual Interaction (the Properties dialog for Calls or the Chat dialog for Chats).
    • This is performed using the Interaction class. First by adding an event handler to Interaction.AttributesChanged then using its StartWatching/StartWatchingAsync method to start watching for changes. Other events such as Deallocated will also be raised from this watch. An Interaction watch only causes Interaction events to be raised (not InteractionQueue class events).
    • An Interaction watch cannot be started on the "shared" Interaction class instance that is contained in InteractionQueue.InteractionChanged events, but a new Interaction instance can easily be created for the same InteractionId as the one contained in the EventArgs for the event. (This is to protect different pieces of code both handling an InteractionQueue changed event and trying to start their own separate Interaction.StartWatching watches with conflicting sets of attributes.)

Both types of Interaction-related watches can be used at the same time, on the same interactions, with the result that an Interaction instance’s available attributes will reflect the union of the attributes being watched via an InteractionQueue.StartWatching (for a queue containing the Interaction) and via an Interaction.StartWatching. However, to reiterate, the events that get raised will be on the class instance on which a given StartWatching was initiated.


How Async Calls Work

[image]

IceLib Technical Reference
How Async Calls Work
Send Feedback

IceLib provides synchronous (blocking) and asynchronous (non-blocking) versions of most methods, especially those methods that make a server call. This convention allows the developer the convenience of choosing which programming model to use. It also allows him to switch back and forth between the two models where appropriate within the same application.

How Asynchronous Invocations Work

When an async method is invoked, the work is scheduled to be performed on a worker thread. Then, the async method returns back to the calling context so that the initial thread can continue without blocking. These async method flavors are frequently used when called from a UI thread so that the user experience is not degraded.

When an async method calls has completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the System.ComponentModel..::..AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of the method for more detailed error information.

Important
Watch-based properties are not available for use until the class instance's StartWatchingAsynccompletedCallback has been raised. See How Watches Work for more information.


Handling Exceptions
Send Feedback

IceLib methods throw a variety of exceptions that should be handled appropriately in order to avoid having unhandled exceptions (and subsequent application crashes) in an IceLib-based application. These exceptions are generally documented on each IceLib method that can throw them. There are some general practices that should be followed to ensure that an IceLib-based application is resilient to these exceptions.

Handling Exceptions

A common set of exceptions that IceLib can throw are related to input parameters being passed in to methods and class constructors such as ArgumentException, ArgumentNullException, and ArgumentOutOfRangeException. IceLib methods that require communication with the IC Server have a number of additional exceptions that can be thrown such as RequestTimeoutException, SessionDisconnectedException, and ObjectDisposedException.

Aside from handling specific exceptions that an IceLib-based application may want to handle, it is generally a good idea to also include an IceLibException and/or Exception catch block. This is to ensure that the IceLib-based application can handle other exceptions being thrown, such as the InsufficientRightsException that can be thrown when making calls that communicate with the IC Server. This will help to ensure that the IceLib-based application is resilient to exceptions that were unexpected at the time the application was written.

The following block of code shows an IceLib method call that is resilient to various exceptions that can be thrown:

CopyC#
try
{
    _Session.ChangeStation(new ININ.IceLib.Connection.WorkstationSettings(workstation, supportedMedia));
}
catch (ArgumentNullException)
{
    // Somehow the workstation parameter was null,
    // notify the user...maybe there was a bad
    // input check?
}
catch (ININ.IceLib.Connection.SessionDisconnectedException ex)
{
    // The connection was disconnected.  Do
    // something specific about this exception,
    // like kicking the user back to a login
    // screen after notifying them.
}
catch (ININ.IceLib.IceLibException ex)
{
    // Some other IceLib exception happened that
    // we weren't expecting.  Notify the user in
    // some way, and perhaps log it for future
    // investigation.
}
catch (Exception ex)
{
    // Some other exception happened.  Write it
    // to a log, or do something else so that it
    // can be further investigated.
}


HTTPS File Transfer

[image]

IceLib Technical Reference
HTTPS File Transfer
Send Feedback

In 4.0 IceLib, a number of file transfers between IceLib and the IC Server now utilize the HTTPS protocol. In order for this mechanism to work, port 8019 must be enabled by every server that is running Session Manager - including the IC Server and Off-Server Session Manager instances. Any machines running an IceLib-based application must also have access to port 8019. Session Manager controls the Uri used for downloading and uploading files, and it will use the network name of the IC Server as part of that Uri; however, in some situations, it is possible that the network name of the IC Server may not be discoverable (for instance, due to DNS restrictions), so the "SM HTTPS URL Base Map" server parameter should be setup to override this value. See the Configuring the "SM HTTPS URL Base Map" section for additional details on how to configure this server parameter. Following is a description of each IceLib namespace, and the specific APIs that are affected by the HTTPS file transfer mechanism.

Note

When files are downloaded via the HTTPS mechanism, they are stored in IceLib's local file cache. To help conserve network traffic, this local IceLib cache is checked prior to downloading a file. If it is determined that the file is currenlty up-to-date, then the file will be returned directly from the file cache, and it will not be re-downloaded.

Jump to a section:

  • Configuring the "SM HTTPS URL Base Map"
  • ININ.IceLib.Configuration
  • ININ.IceLib.Connection.Extensions
  • ININ.IceLib.Interactions
  • ININ.IceLib.People
  • ININ.IceLib.Data.TransactionBuilder

Configuring the "SM HTTPS URL Base Map"

The "SM HTTPS URL Base Map" server parameter can be set in cases where the network name of the IC Server is not able to be resolved via DNS. This server parameter is a &-delimited list of |-delimited mappings. The format to follow is "machine name1|resolvable value1&machine name2|resolvable value2". An example value could be "server1|server1.domainname.com&server2|server2.domainname.com".

Back to Introduction

ININ.IceLib.Configuration

Note

When configuration-based files are uploaded via the HTTPS mechanism, they are first copied to the logged in user's personal storage on the IC Server. After a successful upload, the IC Server then moves the uploaded file to the appropriate location, as dictated by each object's server parameter path, which are listed with each object type below.

The ClientTemplateConfiguration..::..Commit()()()() method uses the HTTPS upload file transfer mechanism, and the ClientTemplateConfiguration..::..DownloadResource()()()() method uses the HTTPS download file transfer mechanism. The "ClientTemplateXmlPath" server parameter determines the location of client templates on the IC Server. If this server parameter is not set, then the "Resource Path" server parameter is used, and the client template file is stored in the "Resources\ClientTemplates" subfolder of the "Resource Path" path. If the "Resource Path" server parameter is not set, then the "Server Path" server parameter is used, and the client template file is stored in the "Resources\ClientTemplates" subfolder.

The ImageResourceConfiguration..::..Commit()()()() method uses the HTTPS upload file transfer mechanism, and the ImageResourceConfiguration..::..DownloadResource()()()() method uses the HTTPS download file transfer mechanism. The "ImageResourcePath" server parameter determines the location of image resources on the IC Server. If this server parameter is not set, then the "Resource Path" server parameter is used. If the "Resource Path" server parameter is not set, then the "Server Path" server parameter is used, and the image resource file is then stored in a "Resources" subfolder.

The HTTPS upload file transfer mechanism is used when calling the Commit()()()() method on a ResponseManagementDocumentConfiguration object. The ResponseManagementDocumentConfiguration..::..DownloadDocument()()()() method uses the HTTPS download file transfer mechanism. The "Rx Document Path" server parameter determines the location of response management documents on the IC Server. If this server parameter is not set, then the response management document is saved to the "Server\I3RxDocs" folder.

Back to Introduction

ININ.IceLib.Connection.Extensions

The CustomProfile class, when constructed via a call to CustomProfile..::..GetApplicationCustomProfile(Session), uses the HTTPS file transfer mechanism. The CustomProfile..::..CheckForApplicationBasedSettings()()()(), CustomProfile..::..GetProfileItem(String, String), and CustomProfile..::..GetNamespaceContents(String) methods use the HTTPS download file transfer mechanism. The CustomProfile..::..FlushChanges()()()() method uses the HTTPS upload file transfer mechanism. The application-based custom profile files are uploaded and downloaded directly to and from the "ApplicationSettings" folder located in the logged in user's personal storage.

The ProblemReporter..::..Submit()()()() method uses the HTTPS upload file transfer mechanism. The "ProblemReporterPath" server parameter determines the location of problem reporter files on the IC Server. If this server parameter is not set, then the "Server Path" server parameter is used, and the problem report is saved in the "ProblemReporter" subfolder.

Back to Introduction

ININ.IceLib.Interactions

The EmailInteraction..::..UploadFileAttachment(Stream, String, String) and EmailInteraction..::..UploadFileAttachment(String, String) methods use the HTTPS upload file transfer mechanism. Email attachments are uploaded directly to the "Email" folder under the logged in user's personal storage.

Back to Introduction

ININ.IceLib.People

The StatusMessageDetails..::..Icon property uses the HTTPS download file transfer mechanism. Accessing the StatusMessageDetails..::..Icon property causes IceLib to attempt to read the current Icon from its local file cache. If it does not exist in the local file cache, IceLib will immediately return with a default icon, and will schedule a download of the updated icon. When the scheduled icon download completes, the StatusMessageList..::..WatchedObjectsChanged event is fired, with the StatusMessageProperty..::..Icon enumeration value indicated as part of the WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Changed property. The location of icon files are set via Interaction Administrator, in the "Status Messages" section.

Back to Introduction

ININ.IceLib.Data.TransactionBuilder

The TransactionClient..::..Execute(TransactionData%) method uses the HTTPS download file transfer mechanism. When TransactionData..::..ForceOutOfBand is set to true for the transaction being executed, and the IC Server has determined that Out of Band transfer requests are supported for the specified transaction, the TransactionData..::..WasOutOfBandUsed property will be set to true, indicating that the HTTPS transfer mechanism was used. There are no server parameters that affect the location of transaction data results; however, the "Out-of-band ThreadingPool Size" server parameter controls the number of simultaneous transactions that can run (default value is 4), and the "Out-of-band Resultset Expire Timeout" server parameter controls how long, in seconds, until an old result set is determined to be old and thus purged (default is 12 hours).

Back to Introduction


Integration Options

[image]

IceLib Technical Reference
Integration Options
Send Feedback

There are several different types of IceLib-based integrations.

Client-Side Integration

A client-side workstation running a custom .Net application that directly uses IceLib to integrate with the IC server. You could even have a custom .Net service on the workstation and integrate with the IC server by using IceLib.

Tip
This integration can be used along-side other IceLib-based applications, such as ININ’s Interaction .Net Client, without interfering with the existing application connection.
Note
This is the same mechanism used by ININ’s Interaction .Net Client, Interaction Fax, Interaction Voicemail, etc.

Web Server Integration

The ASP.NET code-behind uses IceLib on behalf of end user. The code-behind could also perform application-wide operations, independently of a particular IC user.

Tip
This integration can be used along-side other IceLib-based applications, such as ININ’s Interaction .Net Client, without interfering with the existing application connection.
Note
This is the same mechanism used by ININ’s 3.0 Web Client.

Web Server Integration

Limited Client-Side Integration

In some cases, a workstation application does not, or cannot, use IceLib directly. Perhaps a legacy client/server protocol cannot be modified or the client application is the product of another company.

In this model, a server-side application uses IceLib on behalf of a Client application or end user.

Tip
This integration can be used along-side other IceLib-based applications, such as ININ’s Interaction .Net Client, without interfering with the existing application connection. However, it might require other features of IceLib (e.g. Proxy logins and/or SessionWatch mechanism).
Note
This is the same mechanism used by various ININ Packaged Solutions (e.g. SAP integration).

Limited Client-Side Integration

Integration with Other Technologies

Applications written in languages that cannot use .Net directly can face additional challenges. Examples include using Java or other COM-enabled languages.

One approach is to create a custom .NET-based COM wrapper that encapsulates high level business-specific operations. The COM object then uses IceLib to implement the specific high level operations needed by the non-.NET application. This approach results in writing fewer COM methods because business specific needs will most likely utilize several IceLib operations in one step.

Integration with Other Technologies

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


Certificate Validation

[image]

IceLib Technical Reference
Certificate Validation
Send Feedback

On a default installation, IceLib-based applications do not perform client-side validation of server certificates; however, this option can be turned on.

Jump to a section:

  • Enabling Client-Side Validation of Server Certificates
  • Certificate Configuration

Enabling Client-Side Validation of Server Certificates

By default, IceLib-based applications do not perform client-side validation of the IC Server certificates. This can be enabled in 1 of 2 ways: By using a config file to turn it on for a specific application, or by using the registry to turn it on globally.

Note

Once this option is enabled, the configured IceLib-based client will not be able to login unless the IC Servers and client machine can agree on certificates. Attempting to connect to an IC Server without the certificates installed will result in an IceLibConnectionException.

Use an [ApplicationName.exe].config File

To enable this option on a per-application basis, create an [ApplicationName.exe].config file in the same folder that the application is installed. This file should have, at the very least, the following contents:

CopyXML
<configuration>
    <appSettings>
        <add key="enforceTLSCertificateChecks" value="true"/>
    </appSettings>
</configuration>

Use the Registry

To enable this option for all IceLib-based applications on a machine, create a new "enforceTLSCertificateChecks" DWORD value in the "SOFTWARE\Interactive Intelligence\CommonApplication" registry key, and set its value to 1. This can be set in either the "Current User" or "Local Machine" registry hives. If this value is set in the "Local Machine" registry hive, you will need to set this value in the "SOTWARE\Wow6432Node\Interactive Intelligence\CommonApplication" registry key.

Back to Introduction

Certificate Configuration

There are a few options to handle the configuration of certificates:

Replace all ININ Certificates

There are many things to consider when replacing all of the ININ Certificates with your own certificate authority signed certificates; as such, it is recommended that you contact ININ Support for further details.

Back to Introduction

Use an already trusted 3rd Party Certificate

Instructions on how to use an already trusted 3rd party certificate can be found in the following KB article: https://my.inin.com/products/pages/kb-details.aspx?entryid=q121666141100137. Note that these instructions require the root certificate to be configured as a subordinate certification authority.

Back to Introduction

Install IC Server Certificates on All Client Machines

Based on a default configuration of an IC Server, it will be necessary to install the IC Server's ServerGroup certificate to all client machines that will need to connect to it. Note that this process can be sped up using a Group Policy. The certificate that needs to be installed on the client machines are on the IC Server, in the following path: "[Install Path]\Certificates\ServerGroup\ServerGroupCertificate.cer".


IceLib SDK 32-bit vs. 64-bit
Send Feedback

The IceLib SDK is available in 32-bit and 64-bit versions.

Note
The IceLib .NET assemblies are not built as purely managed (AnyCPU) as they have dependencies on native DLLs. This requires both 32-bit and 64-bit versions so that each can have their respective 32-bit and 64-bit dependencies.

An example usage of the 64-bit IceLib SDK would be when a custom plugin to a 64-bit application requires the use of IceLib. For example, a SharePoint plugin that exposes queues and user statuses.

IceLib SDK 32-bit vs. 64-bit

There are two installs for the IceLib SDK (IceLibSDK.msi and IceLibSDK_64bit.msi) along with a merge module for each (IceLib_Redistributable.msm and IceLib_Redistributable_64bit.msm).

Each install includes ExampleApps and the IceLib .NET assemblies to implement IceLib as either 32-bit or 64-bit. The ExampleApps have their references pointing to the "\IceLib SDK\Bin" directory for the given install (32-bit or 64-bit).

When installing the 32-bit IceLib SDK on a 64-bit OS the default install path will be "Program Files (x86)\IceLib SDK" and the 64-bit install path will be "Program Files\IceLib SDK". This will allow both sets of assemblies to reside on the same machine.

Note
The 64-bit IceLib SDK does not contain the AspIceLibClientDemo example application. The example application (and other ASP.NET applications) can be built with the 64-bit IceLib assemblies, however the resultant web page would not be able to be debugged via Visual Studio, since that built-in debugging capability is 32-bit-only. For the purpose of an IceLib example application, requiring utilization of an actual IIS environment is not ideal, so we have left this example out of the 64-bit IceLib SDK. The 32-bit IceLib SDK still contains it.


Deploying Custom IceLib-based Applications

[image]

IceLib Technical Reference
Deploying Custom IceLib-based Applications
Send Feedback

There are some things that need to be taken into account when it comes time to deploy a custom IceLib-based custom application. In order for a custom IceLib-based application to function properly, IceLib's dependency binaries must be present in the folder where the custom IceLib-based application is installed to.

Jump to a section:

  • Deploying using IceLib's redistributable merge module (MSM).
  • Deploying using the "copy file" method.
  • A note on the trace initialization service.
  • A note on IC Center Service Updates (Patch).

Deploying using IceLib's redistributable merge module (MSM).

Caution
The Visual C++ Redistributable is required for IceLib's tracing support. For 2017 R2, this requires the Visual C++ Redistributable for Visual Studio 2015 (vc_redist.x86.exe or vc_redist.x64.exe). Interactive Intelligence installs automatically deploy this Visual C++ redistributable, however custom installations of IceLib might need to separately ensure that the Visual C++ redistributable has been installed if being installed without Interactive Intelligence installs. The IceLib SDK redistributable does not ensure that the Visual C++ redistributable is installed.

To help facilitate the deployment of a custom IceLib-based application, the IceLib SDK includes a redistributable merge module (MSM) that can be used with the installer for a custom IceLib-based application. The merge modules can be found in the IceLib SDK installation folder in the "Redistributable" folder, and can be included in the setup assembly used to install the application. There is a merge module for x86 (IceLib_Redistributable.msm) and x64 (IceLib_64_Redistributable.msm) architectures - be sure to include the one that is relevant to the application being installed. For more information on the IceLib SDK installations, see IceLib SDK 32-bit vs. 64-bit. Because merge modules are not able to run separate install processes, an additional step needs to be taken for cases where a custom IceLib-based application is being installed on a machine that does not have any IC Center software on it, and is explained in the A note on the trace initialization service section.

Back to Introduction

Deploying using the "copy file" method.

Caution
The Visual C++ Redistributable is required for IceLib's tracing support. For 2017 R2, this requires the Visual C++ Redistributable for Visual Studio 2015 (vc_redist.x86.exe or vc_redist.x64.exe). Interactive Intelligence installs automatically deploy this Visual C++ redistributable, however custom installations of IceLib might need to separately ensure that the Visual C++ redistributable has been installed if being installed without Interactive Intelligence installs. The IceLib SDK redistributable does not ensure that the Visual C++ redistributable is installed.
Caution
As of 2015 R1, some of the file dependencies have changed. File dependencies prior to 2015 R1 had "1-2" embedded in the filenames - now with each release these dependencies have a different version indicator in their filenames. For instance, the dependency i3trace-w32r-##-#.dll for the CIC 2017 R2 release would be i3trace-w32r-17-2.dll.

For cases where an installation package is not viable or necessary, a "copy file" deployment can be used. Simply speaking, a "copy file" deployment involves copying all of the necessary binaries to the appropriate location where the custom IceLib-based application will be run. The files that should be included in such a deployment include the binaries for the custom IceLib-based application, as well as the binaries from the IceLib SDK installation's "bin" folder (and pdb's if required as well). If the custom IceLib-based application is being installed on a machine that does not have any IC Center software on it, then the steps outlined in the A note on the trace initialization service section should be followed.

Back to Introduction

A note on the trace initialization service.

In order for a custom IceLib-based application to function properly, the "ININ Tracing Initialization ##-#" service must be installed and running, where "#" represents the year and release numbers (for CIC 2017 R2, this would be "ININ Tracing Initialization 17-2"). This service is installed as part of any IC Center software application (including the IceLib SDK); however, if a custom IceLib-based application is being installed on a machine that does not have any IC Center software on it, a separate installation needs to be run in order to install it. The trace service is installed by the merge module (IceLib_Redistributable.msm or IceLib_64_Redistributable.msm, depending on which one is needed).

Back to Introduction

A note on IC Center Service Updates (Patch).

IC Center Service Updates (Patch) do not install updated IceLib binaries for any installed custom IceLib-based application, regardless of whether the custom IceLib-based application's install was created with the IceLib merge module or from a "copy deployment". All custom IceLib-based applications will need to release their own updates to include the updated IceLib binaries. IC Center Service Updates do, however, update the IceLib SDK. If IUpdate is installed and running, this will be done automatically; however, if not, then it will be necessary to run the IceLib SDK update package (IceLibSDK_32bit_20##_R#_Patch##.msp or IceLibSDK_64bit_20##_R3_Patch##.msp as appropriate, where "#" represents the year, release, and patch numbers). Once the appropriate IC Center Service Update has been applied to the IceLib SDK, the updated binaries will be available in the "bin" folder where the IceLib SDK was installed, and can then be included in an update for the custom IceLib-based application.

Back to Introduction


ININ.IceLib Namespace

[image]

IceLib Technical Reference
ININ.IceLib Namespace
Send Feedback

The ININ.IceLib namespace contains fundamental classes and base classes for creating Interaction Center based applications. These include commonly-used value and reference data types, events and event handlers, interfaces, attributes, and processing exceptions.

Exceptions. There are a number of exceptions that can be thrown throughout IceLib. These are intended to allow custom applications to receive information about specific error conditions and be able to handle the condition accordingly. All such exceptions inherit from IceLibException. Examples of Interaction classes are: NotCachedException, ResourceInUseException, and ServerOperationNotSupportedException.

Tracing. The Tracing object offers support for simple tracing. These trace statements will be written into the PureConnect trace log for the running application instance. All such trace statements will be written to the "IceLib_Custom" trace topic.

Classes

 | Class | Description
Public class | AsyncCompletedEventArgs<(Of <(<'TResult>)>)> | Provides data for asynchronous operations.
Public class | DisplayableId | Represents a unique identifier for an object, along with its display name.
Public class | IceLibException | The general exception that is thrown for IceLib when a more specific exception cannot be determined.
Public class | IceLibExceptionTypes | This class is used by IceLibException and all of its derived types to provide more information about the type of error.
Public class | IceLibLicenseException | The exception that is thrown for IceLib when a required license is not available.
Public class | IceLibPasswordPolicyViolationException | The exception that is thrown for IceLib when a password is attempted to be saved that violates the password policy.
Public class | InsufficientRightsException | The exception that is thrown for IceLib when a required right is not available.
Public class | KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> | Provides data for the watched objects changed event for a watched object. The key for the object can be any type.
Public class | NotCachedException | The exception that is thrown for IceLib when a required value is not cached.
Public class | ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> | Provides data for the watched objects changed event for a watched object.
Public class | ResourceInUseException | The exception that is thrown for IceLib when a required resource is already in use.
Public class | ResultLimitExceededException | The exception that is thrown for IceLib when returned results exceed the maximum allowable amount.
Public class | ServerOperationNotSupportedException | The exception that is thrown for IceLib when the server does not support a requested operation.
Public class | Tracing | Contains support for tracing into the PureConnect log file.
Public class | TransferProgressChangedEventArgs | Members of this class provide data for TransferProgressChanged events.


AsyncCompletedEventArgs(TResult) Class

[image]

IceLib Technical Reference
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class
Members See Also Send Feedback
Provides data for asynchronous operations.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncCompletedEventArgs<TResult> : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncCompletedEventArgs(Of TResult) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TResult
The result type.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib..::..AsyncCompletedEventArgs<(Of <(<'TResult>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib Namespace


AsyncCompletedEventArgs(TResult) Members

[image] [image]

IceLib Technical Reference
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Members
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class Constructors Methods Properties See Also Send Feedback

The AsyncCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | AsyncCompletedEventArgs<(Of <(<'TResult>)>)> | Initializes a new instance of this class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result | Gets the result associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib Namespace


AsyncCompletedEventArgs(TResult) Constructor

[image]

IceLib Technical Reference
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Constructor
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback
Initializes a new instance of this class with the specified values.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AsyncCompletedEventArgs(
    TResult result,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    result As TResult, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

result
Type: TResult
The result.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib Namespace


AsyncCompletedEventArgs(TResult) Methods

[image] [image]

IceLib Technical Reference
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Methods
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback

The AsyncCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib Namespace


AsyncCompletedEventArgs(TResult) Properties

[image] [image]

IceLib Technical Reference
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Properties
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback

The AsyncCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result | Gets the result associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib Namespace


Result Property

[image]

IceLib Technical Reference
AsyncCompletedEventArgs<(Of <(<'TResult>)>)>..::..Result Property
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback
Gets the result associated with the event.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TResult Result { get; }
Visual Basic
Public ReadOnly Property Result As TResult
    Get

Field Value

The result.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Class
AsyncCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib Namespace


DisplayableId Class

[image]

IceLib Technical Reference
DisplayableId Class
Members See Also Send Feedback
Represents a unique identifier for an object, along with its display name.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DisplayableId : IComparable
Visual Basic
Public Class DisplayableId _
    Implements IComparable

Remarks

The DisplayableId class is used to represent a unique identifier for objects in the IC system, along with a DisplayName for that object, if one is defined. If no display name exists for the object, the class will return the Id for the object to be used as the display string.

Inheritance Hierarchy

System..::..Object
ININ.IceLib..::..DisplayableId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Members
ININ.IceLib Namespace


DisplayableId Members

[image] [image]

IceLib Technical Reference
DisplayableId Members
DisplayableId Class Constructors Methods Operators Properties See Also Send Feedback

The DisplayableId type exposes the following members.

Constructors

 | Name | Description
Public method | DisplayableId(String) | Initializes a new instance of the DisplayableId class.
Public method | DisplayableId(String, String) | Initializes a new instance of the DisplayableId class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(DisplayableId) | Determines whether the specified DisplayableId is equal to the current DisplayableId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | DisplayName | Gets the human-readable name that refers to this object.
Public property | Id | Gets the unique identifier used to reference this object.
 | None | Gets a DisplayableId representing no value (i.e. String.Empty).

See Also

DisplayableId Class
ININ.IceLib Namespace


DisplayableId Constructor

[image] [image]

IceLib Technical Reference
DisplayableId Constructor
DisplayableId Class See Also Send Feedback
Initializes a new instance of the DisplayableId class.

Overload List

 | Name | Description
Public method | DisplayableId(String) | Initializes a new instance of the DisplayableId class.
Public method | DisplayableId(String, String) | Initializes a new instance of the DisplayableId class.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


DisplayableId Constructor (String)

[image]

IceLib Technical Reference
DisplayableId Constructor (String)
DisplayableId Class See Also Send Feedback
Initializes a new instance of the DisplayableId class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DisplayableId(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
DisplayableId Overload
ININ.IceLib Namespace


DisplayableId Constructor (String, String)

[image]

IceLib Technical Reference
DisplayableId Constructor (String, String)
DisplayableId Class See Also Send Feedback
Initializes a new instance of the DisplayableId class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DisplayableId(
    string id,
    string displayName
)
Visual Basic
Public Sub New ( _
    id As String, _
    displayName As String _
)

Parameters

id
Type: System..::..String
The ID.
displayName
Type: System..::..String
The display name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
DisplayableId Overload
ININ.IceLib Namespace


DisplayableId Methods

[image] [image]

IceLib Technical Reference
DisplayableId Methods
DisplayableId Class See Also Send Feedback

The DisplayableId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(DisplayableId) | Determines whether the specified DisplayableId is equal to the current DisplayableId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

DisplayableId Class
ININ.IceLib Namespace


CompareTo Method

[image]

IceLib Technical Reference
DisplayableId..::..CompareTo Method
DisplayableId Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


Equals Method

[image] [image]

IceLib Technical Reference
DisplayableId..::..Equals Method
DisplayableId Class See Also Send Feedback
Determines whether two DisplayableId instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(DisplayableId) | Determines whether the specified DisplayableId is equal to the current DisplayableId.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
DisplayableId..::..Equals Method (Object)
DisplayableId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
Equals Overload
ININ.IceLib Namespace


Equals Method (DisplayableId)

[image]

IceLib Technical Reference
DisplayableId..::..Equals Method (DisplayableId)
DisplayableId Class See Also Send Feedback
Determines whether the specified DisplayableId is equal to the current DisplayableId.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    DisplayableId other
)
Visual Basic
Public Function Equals ( _
    other As DisplayableId _
) As Boolean

Parameters

other
Type: ININ.IceLib..::..DisplayableId
The DisplayableId to compare with the current DisplayableId.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified DisplayableId is equal to the current DisplayableId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
Equals Overload
ININ.IceLib Namespace


GetHashCode Method

[image]

IceLib Technical Reference
DisplayableId..::..GetHashCode Method
DisplayableId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


ToString Method

[image]

IceLib Technical Reference
DisplayableId..::..ToString Method
DisplayableId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


DisplayableId Operators

[image] [image]

IceLib Technical Reference
DisplayableId Operators
DisplayableId Class See Also Send Feedback

The DisplayableId type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

DisplayableId Class
ININ.IceLib Namespace


Equality Operator

[image]

IceLib Technical Reference
DisplayableId..::..Equality Operator
DisplayableId Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    DisplayableId displayableId1,
    DisplayableId displayableId2
)
Visual Basic
Public Shared Operator = ( _
    displayableId1 As DisplayableId, _
    displayableId2 As DisplayableId _
) As Boolean

Parameters

displayableId1
Type: ININ.IceLib..::..DisplayableId
A displayable ID to compare.
displayableId2
Type: ININ.IceLib..::..DisplayableId
A displayable ID to compare.

Return Value

Returns trueTruetruetrue (True in Visual Basic) if the values of its operands are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


Inequality Operator

[image]

IceLib Technical Reference
DisplayableId..::..Inequality Operator
DisplayableId Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    DisplayableId displayableId1,
    DisplayableId displayableId2
)
Visual Basic
Public Shared Operator <> ( _
    displayableId1 As DisplayableId, _
    displayableId2 As DisplayableId _
) As Boolean

Parameters

displayableId1
Type: ININ.IceLib..::..DisplayableId
A displayable ID to compare.
displayableId2
Type: ININ.IceLib..::..DisplayableId
A displayable ID to compare.

Return Value

Returns falseFalsefalsefalse (False in Visual Basic) if the values of its operands are equal, trueTruetruetrue (True in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


DisplayableId Properties

[image] [image]

IceLib Technical Reference
DisplayableId Properties
DisplayableId Class See Also Send Feedback

The DisplayableId type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the human-readable name that refers to this object.
Public property | Id | Gets the unique identifier used to reference this object.
 | None | Gets a DisplayableId representing no value (i.e. String.Empty).

See Also

DisplayableId Class
ININ.IceLib Namespace


DisplayName Property

[image]

IceLib Technical Reference
DisplayableId..::..DisplayName Property
DisplayableId Class See Also Send Feedback
Gets the human-readable name that refers to this object.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The human-readable display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


Id Property

[image]

IceLib Technical Reference
DisplayableId..::..Id Property
DisplayableId Class See Also Send Feedback
Gets the unique identifier used to reference this object.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


None Property

[image]

IceLib Technical Reference
DisplayableId..::..None Property
DisplayableId Class See Also Send Feedback
Gets a DisplayableId representing no value (i.e. String.Empty).

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static DisplayableId None { get; }
Visual Basic
Public Shared ReadOnly Property None As DisplayableId
    Get

Field Value

The DisplayableId.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DisplayableId Class
DisplayableId Members
ININ.IceLib Namespace


IceLibException Class

[image]

IceLib Technical Reference
IceLibException Class
Members See Also Send Feedback
The general exception that is thrown for IceLib when a more specific exception cannot be determined.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class IceLibException : Exception
Visual Basic
<SerializableAttribute> _
Public Class IceLibException _
    Inherits Exception

Remarks

This exception is thrown throughout IceLib when a more specific exception cannot be determined. It also serves as the base class for more specific IceLib exceptions, allowing consistent exception handling for all such exceptions.

Please refer to IceLibExceptionTypes for a list of error types.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Configuration..::..ConfigurationDeleteException
ININ.IceLib.Configuration..::..ConfigurationLicenseException
ININ.IceLib.Configuration..::..ConfigurationReferenceException
ININ.IceLib.Configuration..::..ConfigurationValidationException
ININ.IceLib.Connection..::..IceLibConnectionException
ININ.IceLib.Connection..::..InvalidServerVersionException
ININ.IceLib.Connection..::..RequestTimeoutException
ININ.IceLib.Connection..::..SessionDisconnectedException
ININ.IceLib.Data.TransactionBuilder..::..RecordNotFoundException
ININ.IceLib..::..IceLibLicenseException
ININ.IceLib..::..IceLibPasswordPolicyViolationException
ININ.IceLib..::..InsufficientRightsException
ININ.IceLib.Interactions..::..MakeCallException
ININ.IceLib..::..NotCachedException
ININ.IceLib..::..ResourceInUseException
ININ.IceLib..::..ResultLimitExceededException
ININ.IceLib..::..ServerOperationNotSupportedException
ININ.IceLib.UnifiedMessaging..::..RateLimitedException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibException Members
ININ.IceLib Namespace


IceLibException Members

[image] [image]

IceLib Technical Reference
IceLibException Members
IceLibException Class Constructors Methods Properties Events See Also Send Feedback

The IceLibException type exposes the following members.

Constructors

 | Name | Description
Public method | IceLibException()()()() | Initializes a new instance of the IceLibException class with default settings.
Public method | IceLibException(String) | Initializes a new instance of the IceLibException class with a specified error message.
Protected method | IceLibException(SerializationInfo, StreamingContext) | Initializes a new instance of the IceLibException class with a specified error message.
Public method | IceLibException(String, Exception) | Initializes a new instance of the IceLibException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code.
Public property | ErrorType | Gets the value for the type of error.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibException Class
ININ.IceLib Namespace


IceLibException Constructor

[image] [image]

IceLib Technical Reference
IceLibException Constructor
IceLibException Class See Also Send Feedback
Initializes a new instance of the IceLibException class.

Overload List

 | Name | Description
Public method | IceLibException()()()() | Initializes a new instance of the IceLibException class with default settings.
Public method | IceLibException(String) | Initializes a new instance of the IceLibException class with a specified error message.
Protected method | IceLibException(SerializationInfo, StreamingContext) | Initializes a new instance of the IceLibException class with a specified error message.
Public method | IceLibException(String, Exception) | Initializes a new instance of the IceLibException class with a specified error message.

See Also

IceLibException Class
IceLibException Members
ININ.IceLib Namespace


IceLibException Constructor

[image]

IceLib Technical Reference
IceLibException Constructor
IceLibException Class See Also Send Feedback
Initializes a new instance of the IceLibException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibException Class
IceLibException Members
IceLibException Overload
ININ.IceLib Namespace


IceLibException Constructor (String)

[image]

IceLib Technical Reference
IceLibException Constructor (String)
IceLibException Class See Also Send Feedback
Initializes a new instance of the IceLibException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibException Class
IceLibException Members
IceLibException Overload
ININ.IceLib Namespace


IceLibException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
IceLibException Constructor (SerializationInfo, StreamingContext)
IceLibException Class See Also Send Feedback
Initializes a new instance of the IceLibException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IceLibException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibException Class
IceLibException Members
IceLibException Overload
ININ.IceLib Namespace


IceLibException Constructor (String, Exception)

[image]

IceLib Technical Reference
IceLibException Constructor (String, Exception)
IceLibException Class See Also Send Feedback
Initializes a new instance of the IceLibException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibException Class
IceLibException Members
IceLibException Overload
ININ.IceLib Namespace


IceLibException Methods

[image] [image]

IceLib Technical Reference
IceLibException Methods
IceLibException Class See Also Send Feedback

The IceLibException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IceLibException Class
ININ.IceLib Namespace


IceLibException Properties

[image] [image]

IceLib Technical Reference
IceLibException Properties
IceLibException Class See Also Send Feedback

The IceLibException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code.
Public property | ErrorType | Gets the value for the type of error.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IceLibException Class
ININ.IceLib Namespace


ErrorCode Property

[image]

IceLib Technical Reference
IceLibException..::..ErrorCode Property
IceLibException Class See Also Send Feedback
Gets or sets the internal error code.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ErrorCode { get; internal set; }
Visual Basic
Public Property ErrorCode As Integer
    Get
    Friend Set

Field Value

The error code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibException Class
IceLibException Members
ININ.IceLib Namespace


ErrorType Property

[image]

IceLib Technical Reference
IceLibException..::..ErrorType Property
IceLibException Class See Also Send Feedback
Gets the value for the type of error.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ErrorType { get; internal set; }
Visual Basic
Public Property ErrorType As Integer
    Get
    Friend Set

Field Value

The error type.

Remarks

Please refer to the IceLibExceptionTypes class for more information on the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibException Class
IceLibException Members
ININ.IceLib Namespace


IceLibException Events

[image] [image]

IceLib Technical Reference
IceLibException Events
IceLibException Class See Also Send Feedback

The IceLibException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibException Class
ININ.IceLib Namespace


IceLibExceptionTypes Class

[image]

IceLib Technical Reference
IceLibExceptionTypes Class
Members See Also Send Feedback
This class is used by IceLibException and all of its derived types to provide more information about the type of error.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class IceLibExceptionTypes
Visual Basic
Public NotInheritable Class IceLibExceptionTypes

Inheritance Hierarchy

System..::..Object
ININ.IceLib..::..IceLibExceptionTypes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Members
ININ.IceLib Namespace


IceLibExceptionTypes Members

[image] [image]

IceLib Technical Reference
IceLibExceptionTypes Members
IceLibExceptionTypes Class Fields See Also Send Feedback

The IceLibExceptionTypes type exposes the following members.

Fields

Name | Description
Connection | See IceLibConnectionException and IceLibConnectionExceptionTypes for more information.
License | See IceLibLicenseException for more information.
PasswordPolicyViolation | See IceLibPasswordPolicyViolationException for more information.
RateLimited | Requests to refresh a voicemail or fax are being sent too frequently.
RemoteCommunicationFailure | The communication format was not properly negotiated. Your connection will be dropped.
RequestTimeout | See RequestTimeoutException for more information.
ResourceInUse | See ResourceInUseException for more information.
ServerOperationNotSupported | See ServerOperationNotSupportedException for more information.
Unspecified | An unknown error occurred.

See Also

IceLibExceptionTypes Class
ININ.IceLib Namespace


IceLibExceptionTypes Fields

[image] [image]

IceLib Technical Reference
IceLibExceptionTypes Fields
IceLibExceptionTypes Class See Also Send Feedback

The IceLibExceptionTypes type exposes the following members.

Fields

Name | Description
Connection | See IceLibConnectionException and IceLibConnectionExceptionTypes for more information.
License | See IceLibLicenseException for more information.
PasswordPolicyViolation | See IceLibPasswordPolicyViolationException for more information.
RateLimited | Requests to refresh a voicemail or fax are being sent too frequently.
RemoteCommunicationFailure | The communication format was not properly negotiated. Your connection will be dropped.
RequestTimeout | See RequestTimeoutException for more information.
ResourceInUse | See ResourceInUseException for more information.
ServerOperationNotSupported | See ServerOperationNotSupportedException for more information.
Unspecified | An unknown error occurred.

See Also

IceLibExceptionTypes Class
ININ.IceLib Namespace


Connection Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..Connection Field
IceLibExceptionTypes Class See Also Send Feedback
See IceLibConnectionException and IceLibConnectionExceptionTypes for more information.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int Connection
Visual Basic
Public Const Connection As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


License Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..License Field
IceLibExceptionTypes Class See Also Send Feedback
See IceLibLicenseException for more information.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int License
Visual Basic
Public Const License As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


PasswordPolicyViolation Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..PasswordPolicyViolation Field
IceLibExceptionTypes Class See Also Send Feedback
See IceLibPasswordPolicyViolationException for more information.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int PasswordPolicyViolation
Visual Basic
Public Const PasswordPolicyViolation As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


RateLimited Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..RateLimited Field
IceLibExceptionTypes Class See Also Send Feedback
Requests to refresh a voicemail or fax are being sent too frequently.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int RateLimited
Visual Basic
Public Const RateLimited As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


RemoteCommunicationFailure Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..RemoteCommunicationFailure Field
IceLibExceptionTypes Class See Also Send Feedback
The communication format was not properly negotiated. Your connection will be dropped.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int RemoteCommunicationFailure
Visual Basic
Public Const RemoteCommunicationFailure As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


RequestTimeout Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..RequestTimeout Field
IceLibExceptionTypes Class See Also Send Feedback
See RequestTimeoutException for more information.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int RequestTimeout
Visual Basic
Public Const RequestTimeout As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


ResourceInUse Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..ResourceInUse Field
IceLibExceptionTypes Class See Also Send Feedback
See ResourceInUseException for more information.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int ResourceInUse
Visual Basic
Public Const ResourceInUse As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


ServerOperationNotSupported Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..ServerOperationNotSupported Field
IceLibExceptionTypes Class See Also Send Feedback
See ServerOperationNotSupportedException for more information.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int ServerOperationNotSupported
Visual Basic
Public Const ServerOperationNotSupported As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


Unspecified Field

[image]

IceLib Technical Reference
IceLibExceptionTypes..::..Unspecified Field
IceLibExceptionTypes Class See Also Send Feedback
An unknown error occurred.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int Unspecified
Visual Basic
Public Const Unspecified As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibExceptionTypes Class
IceLibExceptionTypes Members
ININ.IceLib Namespace


IceLibLicenseException Class

[image]

IceLib Technical Reference
IceLibLicenseException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a required license is not available.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class IceLibLicenseException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class IceLibLicenseException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested operation requires a license that is not available.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..IceLibLicenseException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Members
ININ.IceLib Namespace


IceLibLicenseException Members

[image] [image]

IceLib Technical Reference
IceLibLicenseException Members
IceLibLicenseException Class Constructors Methods Properties Events See Also Send Feedback

The IceLibLicenseException type exposes the following members.

Constructors

 | Name | Description
Public method | IceLibLicenseException()()()() | Initializes a new instance of the IceLibLicenseException class with default settings.
Public method | IceLibLicenseException(CultureInfo) | Initializes a new instance of the IceLibLicenseException class with default settings.
Public method | IceLibLicenseException(String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Public method | IceLibLicenseException(CultureInfo, String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Protected method | IceLibLicenseException(SerializationInfo, StreamingContext) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | IceLibLicenseException(String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | IceLibLicenseException(CultureInfo, String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | ExceptionDetail | Gets a detailed description of the missing license.
Public property | FailedLicenses | Gets or sets the list of license names that failed.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibLicenseException Class
ININ.IceLib Namespace


IceLibLicenseException Constructor

[image] [image]

IceLib Technical Reference
IceLibLicenseException Constructor
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the IceLibLicenseException class.

Overload List

 | Name | Description
Public method | IceLibLicenseException()()()() | Initializes a new instance of the IceLibLicenseException class with default settings.
Public method | IceLibLicenseException(CultureInfo) | Initializes a new instance of the IceLibLicenseException class with default settings.
Public method | IceLibLicenseException(String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Public method | IceLibLicenseException(CultureInfo, String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Protected method | IceLibLicenseException(SerializationInfo, StreamingContext) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | IceLibLicenseException(String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | IceLibLicenseException(CultureInfo, String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
ININ.IceLib Namespace


IceLibLicenseException Constructor

[image]

IceLib Technical Reference
IceLibLicenseException Constructor
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the IceLibLicenseException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibLicenseException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Constructor (CultureInfo)

[image]

IceLib Technical Reference
IceLibLicenseException Constructor (CultureInfo)
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the IceLibLicenseException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibLicenseException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Constructor (String)

[image]

IceLib Technical Reference
IceLibLicenseException Constructor (String)
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibLicenseException(
    string exceptionDetail
)
Visual Basic
Public Sub New ( _
    exceptionDetail As String _
)

Parameters

exceptionDetail
Type: System..::..String
The exception detail message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Constructor (CultureInfo, String)

[image]

IceLib Technical Reference
IceLibLicenseException Constructor (CultureInfo, String)
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibLicenseException(
    CultureInfo cultureInfo,
    string exceptionDetail
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    exceptionDetail As String _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
exceptionDetail
Type: System..::..String
The exception detail message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
IceLibLicenseException Constructor (SerializationInfo, StreamingContext)
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IceLibLicenseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Constructor (String, Exception)

[image]

IceLib Technical Reference
IceLibLicenseException Constructor (String, Exception)
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibLicenseException(
    string exceptionDetail,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    exceptionDetail As String, _
    innerException As Exception _
)

Parameters

exceptionDetail
Type: System..::..String
The exception detail message.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Constructor (CultureInfo, String, Exception)

[image]

IceLib Technical Reference
IceLibLicenseException Constructor (CultureInfo, String, Exception)
IceLibLicenseException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibLicenseException(
    CultureInfo cultureInfo,
    string exceptionDetail,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    exceptionDetail As String, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
exceptionDetail
Type: System..::..String
The exception detail message.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
IceLibLicenseException Overload
ININ.IceLib Namespace


IceLibLicenseException Methods

[image] [image]

IceLib Technical Reference
IceLibLicenseException Methods
IceLibLicenseException Class See Also Send Feedback

The IceLibLicenseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IceLibLicenseException Class
ININ.IceLib Namespace


GetObjectData Method

[image]

IceLib Technical Reference
IceLibLicenseException..::..GetObjectData Method
IceLibLicenseException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
ININ.IceLib Namespace


IceLibLicenseException Properties

[image] [image]

IceLib Technical Reference
IceLibLicenseException Properties
IceLibLicenseException Class See Also Send Feedback

The IceLibLicenseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | ExceptionDetail | Gets a detailed description of the missing license.
Public property | FailedLicenses | Gets or sets the list of license names that failed.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IceLibLicenseException Class
ININ.IceLib Namespace


ExceptionDetail Property

[image]

IceLib Technical Reference
IceLibLicenseException..::..ExceptionDetail Property
IceLibLicenseException Class See Also Send Feedback
Gets a detailed description of the missing license.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExceptionDetail { get; }
Visual Basic
Public ReadOnly Property ExceptionDetail As String
    Get

Field Value

The exception detail message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
ININ.IceLib Namespace


FailedLicenses Property

[image]

IceLib Technical Reference
IceLibLicenseException..::..FailedLicenses Property
IceLibLicenseException Class See Also Send Feedback
Gets or sets the list of license names that failed.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string[] FailedLicenses { get; set; }
Visual Basic
Public Property FailedLicenses As String()
    Get
    Set

Field Value

The failed license names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IceLibLicenseException Class
IceLibLicenseException Members
ININ.IceLib Namespace


IceLibLicenseException Events

[image] [image]

IceLib Technical Reference
IceLibLicenseException Events
IceLibLicenseException Class See Also Send Feedback

The IceLibLicenseException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibLicenseException Class
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Class

[image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a password is attempted to be saved that violates the password policy.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class IceLibPasswordPolicyViolationException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class IceLibPasswordPolicyViolationException _
    Inherits IceLibException

Remarks

This exception is thrown when a password is attempted to be saved that violates the password policy.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..IceLibPasswordPolicyViolationException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

IceLibPasswordPolicyViolationException Members
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Members

[image] [image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Members
IceLibPasswordPolicyViolationException Class Constructors Methods Properties Events See Also Send Feedback

The IceLibPasswordPolicyViolationException type exposes the following members.

Constructors

 | Name | Description
Public method | IceLibPasswordPolicyViolationException(String) | Initializes a new instance of the IceLibPasswordPolicyViolationException class.
Public method | IceLibPasswordPolicyViolationException(CultureInfo, String) | Initializes a new instance of the IceLibPasswordPolicyViolationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibPasswordPolicyViolationException Class
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Constructor

[image] [image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Constructor
IceLibPasswordPolicyViolationException Class See Also Send Feedback
Initializes a new instance of the IceLibException class.

Overload List

 | Name | Description
Public method | IceLibPasswordPolicyViolationException(String) | Initializes a new instance of the IceLibPasswordPolicyViolationException class.
Public method | IceLibPasswordPolicyViolationException(CultureInfo, String) | Initializes a new instance of the IceLibPasswordPolicyViolationException class.

See Also

IceLibPasswordPolicyViolationException Class
IceLibPasswordPolicyViolationException Members
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Constructor (String)

[image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Constructor (String)
IceLibPasswordPolicyViolationException Class See Also Send Feedback
Initializes a new instance of the IceLibPasswordPolicyViolationException class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibPasswordPolicyViolationException(
    string policyError
)
Visual Basic
Public Sub New ( _
    policyError As String _
)

Parameters

policyError
Type: System..::..String
The policy error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

IceLibPasswordPolicyViolationException Class
IceLibPasswordPolicyViolationException Members
IceLibPasswordPolicyViolationException Overload
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Constructor (CultureInfo, String)

[image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Constructor (CultureInfo, String)
IceLibPasswordPolicyViolationException Class See Also Send Feedback
Initializes a new instance of the IceLibPasswordPolicyViolationException class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibPasswordPolicyViolationException(
    CultureInfo cultureInfo,
    string policyError
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    policyError As String _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
policyError
Type: System..::..String
The policy error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

IceLibPasswordPolicyViolationException Class
IceLibPasswordPolicyViolationException Members
IceLibPasswordPolicyViolationException Overload
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Methods

[image] [image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Methods
IceLibPasswordPolicyViolationException Class See Also Send Feedback

The IceLibPasswordPolicyViolationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IceLibPasswordPolicyViolationException Class
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Properties

[image] [image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Properties
IceLibPasswordPolicyViolationException Class See Also Send Feedback

The IceLibPasswordPolicyViolationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IceLibPasswordPolicyViolationException Class
ININ.IceLib Namespace


IceLibPasswordPolicyViolationException Events

[image] [image]

IceLib Technical Reference
IceLibPasswordPolicyViolationException Events
IceLibPasswordPolicyViolationException Class See Also Send Feedback

The IceLibPasswordPolicyViolationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibPasswordPolicyViolationException Class
ININ.IceLib Namespace


InsufficientRightsException Class

[image]

IceLib Technical Reference
InsufficientRightsException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a required right is not available.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class InsufficientRightsException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class InsufficientRightsException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested operation cannot be completed due to insufficient rights being available.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..InsufficientRightsException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Members
ININ.IceLib Namespace


InsufficientRightsException Members

[image] [image]

IceLib Technical Reference
InsufficientRightsException Members
InsufficientRightsException Class Constructors Methods Properties Events See Also Send Feedback

The InsufficientRightsException type exposes the following members.

Constructors

 | Name | Description
Public method | InsufficientRightsException()()()() | Initializes a new instance of the InsufficientRightsException class with default settings.
Public method | InsufficientRightsException(CultureInfo) | Initializes a new instance of the InsufficientRightsException class with default settings.
Public method | InsufficientRightsException(String) | Initializes a new instance of the InsufficientRightsException class with a specified cache value.
Protected method | InsufficientRightsException(SerializationInfo, StreamingContext) | Initializes a new instance of the InsufficientRightsException class with a specified error message.
Public method | InsufficientRightsException(String, Exception) | Initializes a new instance of the InsufficientRightsException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InsufficientRightsException Class
ININ.IceLib Namespace


InsufficientRightsException Constructor

[image] [image]

IceLib Technical Reference
InsufficientRightsException Constructor
InsufficientRightsException Class See Also Send Feedback
Initializes a new instance of the InsufficientRightsException class.

Overload List

 | Name | Description
Public method | InsufficientRightsException()()()() | Initializes a new instance of the InsufficientRightsException class with default settings.
Public method | InsufficientRightsException(CultureInfo) | Initializes a new instance of the InsufficientRightsException class with default settings.
Public method | InsufficientRightsException(String) | Initializes a new instance of the InsufficientRightsException class with a specified cache value.
Protected method | InsufficientRightsException(SerializationInfo, StreamingContext) | Initializes a new instance of the InsufficientRightsException class with a specified error message.
Public method | InsufficientRightsException(String, Exception) | Initializes a new instance of the InsufficientRightsException class with a specified error message.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
ININ.IceLib Namespace


InsufficientRightsException Constructor

[image]

IceLib Technical Reference
InsufficientRightsException Constructor
InsufficientRightsException Class See Also Send Feedback
Initializes a new instance of the InsufficientRightsException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InsufficientRightsException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
InsufficientRightsException Overload
ININ.IceLib Namespace


InsufficientRightsException Constructor (CultureInfo)

[image]

IceLib Technical Reference
InsufficientRightsException Constructor (CultureInfo)
InsufficientRightsException Class See Also Send Feedback
Initializes a new instance of the InsufficientRightsException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InsufficientRightsException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
InsufficientRightsException Overload
ININ.IceLib Namespace


InsufficientRightsException Constructor (String)

[image]

IceLib Technical Reference
InsufficientRightsException Constructor (String)
InsufficientRightsException Class See Also Send Feedback
Initializes a new instance of the InsufficientRightsException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InsufficientRightsException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
InsufficientRightsException Overload
ININ.IceLib Namespace


InsufficientRightsException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
InsufficientRightsException Constructor (SerializationInfo, StreamingContext)
InsufficientRightsException Class See Also Send Feedback
Initializes a new instance of the InsufficientRightsException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected InsufficientRightsException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
InsufficientRightsException Overload
ININ.IceLib Namespace


InsufficientRightsException Constructor (String, Exception)

[image]

IceLib Technical Reference
InsufficientRightsException Constructor (String, Exception)
InsufficientRightsException Class See Also Send Feedback
Initializes a new instance of the InsufficientRightsException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InsufficientRightsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The message that describes the error.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
InsufficientRightsException Overload
ININ.IceLib Namespace


InsufficientRightsException Methods

[image] [image]

IceLib Technical Reference
InsufficientRightsException Methods
InsufficientRightsException Class See Also Send Feedback

The InsufficientRightsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InsufficientRightsException Class
ININ.IceLib Namespace


GetObjectData Method

[image]

IceLib Technical Reference
InsufficientRightsException..::..GetObjectData Method
InsufficientRightsException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InsufficientRightsException Class
InsufficientRightsException Members
ININ.IceLib Namespace


InsufficientRightsException Properties

[image] [image]

IceLib Technical Reference
InsufficientRightsException Properties
InsufficientRightsException Class See Also Send Feedback

The InsufficientRightsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InsufficientRightsException Class
ININ.IceLib Namespace


InsufficientRightsException Events

[image] [image]

IceLib Technical Reference
InsufficientRightsException Events
InsufficientRightsException Class See Also Send Feedback

The InsufficientRightsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InsufficientRightsException Class
ININ.IceLib Namespace


KeyedObjectsChangedEventArgs(TKeyType, TPropertyEnum) Class

[image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Provides data for the watched objects changed event for a watched object. The key for the object can be any type.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class KeyedObjectsChangedEventArgs<TKeyType, TPropertyEnum> : EventArgs
Visual Basic
Public Class KeyedObjectsChangedEventArgs(Of TKeyType, TPropertyEnum) _
    Inherits EventArgs

Type Parameters

TKeyType
The type used for the keys of the objects that changed.
TPropertyEnum
Type parameter to indicate the type of property values that have changed.

Remarks

This class extends EventArgs, the base class for classes containing event data. It is similar to ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> but allows the use of keys with types other than string.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib..::..KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Members
ININ.IceLib Namespace


KeyedObjectsChangedEventArgs(TKeyType, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Members
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed. This is a map with the object identifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
ININ.IceLib Namespace


KeyedObjectsChangedEventArgs(TKeyType, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Methods
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class See Also Send Feedback

The KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
ININ.IceLib Namespace


KeyedObjectsChangedEventArgs(TKeyType, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Properties
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class See Also Send Feedback

The KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed. This is a map with the object identifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
ININ.IceLib Namespace


Added Property

[image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)>..::..Added Property
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were added.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TKeyType> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of TKeyType)
    Get

Field Value

The added objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Members
ININ.IceLib Namespace


Changed Property

[image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)>..::..Changed Property
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing objects that changed. This is a map with the object identifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<TKeyType, ReadOnlyCollection<TPropertyEnum>> Changed { get; }
Visual Basic
Public ReadOnly Property Changed As IDictionary(Of TKeyType, ReadOnlyCollection(Of TPropertyEnum))
    Get

Field Value

The changed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Members
ININ.IceLib Namespace


Removed Property

[image]

IceLib Technical Reference
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)>..::..Removed Property
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were removed.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TKeyType> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of TKeyType)
    Get

Field Value

The removed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Class
KeyedObjectsChangedEventArgs<(Of <(<'TKeyType, TPropertyEnum>)>)> Members
ININ.IceLib Namespace


NotCachedException Class

[image]

IceLib Technical Reference
NotCachedException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a required value is not cached.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class NotCachedException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class NotCachedException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested watched value has not yet been cached. This is usually due to not having a watch for that value, but can also happen if an asynchronous watch is requested and the value is queried before the asynchronous watch operation completes.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..NotCachedException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Members
ININ.IceLib Namespace


NotCachedException Members

[image] [image]

IceLib Technical Reference
NotCachedException Members
NotCachedException Class Constructors Methods Properties Events See Also Send Feedback

The NotCachedException type exposes the following members.

Constructors

 | Name | Description
Public method | NotCachedException()()()() | Initializes a new instance of the NotCachedException class with default settings.
Public method | NotCachedException(CultureInfo) | Initializes a new instance of the NotCachedException class with default settings.
Public method | NotCachedException(String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Public method | NotCachedException(CultureInfo, String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Protected method | NotCachedException(SerializationInfo, StreamingContext) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | NotCachedException(String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | NotCachedException(CultureInfo, String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CacheValueName | Gets the name of the cache value.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NotCachedException Class
ININ.IceLib Namespace


NotCachedException Constructor

[image] [image]

IceLib Technical Reference
NotCachedException Constructor
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class.

Overload List

 | Name | Description
Public method | NotCachedException()()()() | Initializes a new instance of the NotCachedException class with default settings.
Public method | NotCachedException(CultureInfo) | Initializes a new instance of the NotCachedException class with default settings.
Public method | NotCachedException(String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Public method | NotCachedException(CultureInfo, String) | Initializes a new instance of the NotCachedException class with a specified cache value.
Protected method | NotCachedException(SerializationInfo, StreamingContext) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | NotCachedException(String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.
Public method | NotCachedException(CultureInfo, String, Exception) | Initializes a new instance of the NotCachedException class with a specified error message.

See Also

NotCachedException Class
NotCachedException Members
ININ.IceLib Namespace


NotCachedException Constructor

[image]

IceLib Technical Reference
NotCachedException Constructor
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotCachedException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Constructor (CultureInfo)

[image]

IceLib Technical Reference
NotCachedException Constructor (CultureInfo)
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotCachedException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Constructor (String)

[image]

IceLib Technical Reference
NotCachedException Constructor (String)
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotCachedException(
    string cacheValueName
)
Visual Basic
Public Sub New ( _
    cacheValueName As String _
)

Parameters

cacheValueName
Type: System..::..String
The name of the cache value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Constructor (CultureInfo, String)

[image]

IceLib Technical Reference
NotCachedException Constructor (CultureInfo, String)
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotCachedException(
    CultureInfo cultureInfo,
    string cacheValueName
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    cacheValueName As String _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
cacheValueName
Type: System..::..String
The name of the cache value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
NotCachedException Constructor (SerializationInfo, StreamingContext)
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected NotCachedException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Constructor (String, Exception)

[image]

IceLib Technical Reference
NotCachedException Constructor (String, Exception)
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotCachedException(
    string cacheValueName,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cacheValueName As String, _
    innerException As Exception _
)

Parameters

cacheValueName
Type: System..::..String
The name of the cache value.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Constructor (CultureInfo, String, Exception)

[image]

IceLib Technical Reference
NotCachedException Constructor (CultureInfo, String, Exception)
NotCachedException Class See Also Send Feedback
Initializes a new instance of the NotCachedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotCachedException(
    CultureInfo cultureInfo,
    string cacheValueName,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    cacheValueName As String, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
cacheValueName
Type: System..::..String
The name of the cache value.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
NotCachedException Overload
ININ.IceLib Namespace


NotCachedException Methods

[image] [image]

IceLib Technical Reference
NotCachedException Methods
NotCachedException Class See Also Send Feedback

The NotCachedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NotCachedException Class
ININ.IceLib Namespace


GetObjectData Method

[image]

IceLib Technical Reference
NotCachedException..::..GetObjectData Method
NotCachedException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
ININ.IceLib Namespace


NotCachedException Properties

[image] [image]

IceLib Technical Reference
NotCachedException Properties
NotCachedException Class See Also Send Feedback

The NotCachedException type exposes the following members.

Properties

 | Name | Description
Public property | CacheValueName | Gets the name of the cache value.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NotCachedException Class
ININ.IceLib Namespace


CacheValueName Property

[image]

IceLib Technical Reference
NotCachedException..::..CacheValueName Property
NotCachedException Class See Also Send Feedback
Gets the name of the cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CacheValueName { get; }
Visual Basic
Public ReadOnly Property CacheValueName As String
    Get

Field Value

The name of the cache value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NotCachedException Class
NotCachedException Members
ININ.IceLib Namespace


NotCachedException Events

[image] [image]

IceLib Technical Reference
NotCachedException Events
NotCachedException Class See Also Send Feedback

The NotCachedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NotCachedException Class
ININ.IceLib Namespace


ObjectsChangedEventArgs(TPropertyEnum) Class

[image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Provides data for the watched objects changed event for a watched object.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ObjectsChangedEventArgs<TPropertyEnum> : EventArgs
Visual Basic
Public Class ObjectsChangedEventArgs(Of TPropertyEnum) _
    Inherits EventArgs

Type Parameters

TPropertyEnum
Type parameter to indicate the type of property values that have changed.

Remarks

This class extends EventArgs, the base class for classes containing event data.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib..::..ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib Namespace


ObjectsChangedEventArgs(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed. This is a map with the object identifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib Namespace


ObjectsChangedEventArgs(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Methods
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib Namespace


ObjectsChangedEventArgs(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Properties
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed. This is a map with the object identifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib Namespace


Added Property

[image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Added Property
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were added.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of String)
    Get

Field Value

The added objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib Namespace


Changed Property

[image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Changed Property
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing objects that changed. This is a map with the object identifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ReadOnlyCollection<TPropertyEnum>> Changed { get; }
Visual Basic
Public ReadOnly Property Changed As IDictionary(Of String, ReadOnlyCollection(Of TPropertyEnum))
    Get

Field Value

The changed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib Namespace


Removed Property

[image]

IceLib Technical Reference
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Removed Property
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were removed.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of String)
    Get

Field Value

The removed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ObjectsChangedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib Namespace


ResourceInUseException Class

[image]

IceLib Technical Reference
ResourceInUseException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a required resource is already in use.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ResourceInUseException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ResourceInUseException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested resource is already in use. This can happen if a call is attempted to be parked on an Orbit queue that already has a call on it.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..ResourceInUseException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Members
ININ.IceLib Namespace


ResourceInUseException Members

[image] [image]

IceLib Technical Reference
ResourceInUseException Members
ResourceInUseException Class Constructors Methods Properties Events See Also Send Feedback

The ResourceInUseException type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceInUseException()()()() | Initializes a new instance of the ResourceInUseException class with default settings.
Public method | ResourceInUseException(CultureInfo) | Initializes a new instance of the ResourceInUseException class with default settings.
Public method | ResourceInUseException(String) | Initializes a new instance of the ResourceInUseException class with a specified cache value.
Public method | ResourceInUseException(CultureInfo, String) | Initializes a new instance of the ResourceInUseException class with a specified cache value.
Protected method | ResourceInUseException(SerializationInfo, StreamingContext) | Initializes a new instance of the ResourceInUseException class with a specified error message.
Public method | ResourceInUseException(String, Exception) | Initializes a new instance of the ResourceInUseException class with a specified error message.
Public method | ResourceInUseException(CultureInfo, String, Exception) | Initializes a new instance of the ResourceInUseException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResourceName | Gets the name of the resource.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ResourceInUseException Class
ININ.IceLib Namespace


ResourceInUseException Constructor

[image] [image]

IceLib Technical Reference
ResourceInUseException Constructor
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class.

Overload List

 | Name | Description
Public method | ResourceInUseException()()()() | Initializes a new instance of the ResourceInUseException class with default settings.
Public method | ResourceInUseException(CultureInfo) | Initializes a new instance of the ResourceInUseException class with default settings.
Public method | ResourceInUseException(String) | Initializes a new instance of the ResourceInUseException class with a specified cache value.
Public method | ResourceInUseException(CultureInfo, String) | Initializes a new instance of the ResourceInUseException class with a specified cache value.
Protected method | ResourceInUseException(SerializationInfo, StreamingContext) | Initializes a new instance of the ResourceInUseException class with a specified error message.
Public method | ResourceInUseException(String, Exception) | Initializes a new instance of the ResourceInUseException class with a specified error message.
Public method | ResourceInUseException(CultureInfo, String, Exception) | Initializes a new instance of the ResourceInUseException class with a specified error message.

See Also

ResourceInUseException Class
ResourceInUseException Members
ININ.IceLib Namespace


ResourceInUseException Constructor

[image]

IceLib Technical Reference
ResourceInUseException Constructor
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResourceInUseException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ResourceInUseException Constructor (CultureInfo)
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResourceInUseException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Constructor (String)

[image]

IceLib Technical Reference
ResourceInUseException Constructor (String)
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResourceInUseException(
    string resourceName
)
Visual Basic
Public Sub New ( _
    resourceName As String _
)

Parameters

resourceName
Type: System..::..String
The name of the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Constructor (CultureInfo, String)

[image]

IceLib Technical Reference
ResourceInUseException Constructor (CultureInfo, String)
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with a specified cache value.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResourceInUseException(
    CultureInfo cultureInfo,
    string resourceName
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    resourceName As String _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
resourceName
Type: System..::..String
The name of the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
ResourceInUseException Constructor (SerializationInfo, StreamingContext)
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ResourceInUseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Constructor (String, Exception)

[image]

IceLib Technical Reference
ResourceInUseException Constructor (String, Exception)
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResourceInUseException(
    string resourceName,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    resourceName As String, _
    innerException As Exception _
)

Parameters

resourceName
Type: System..::..String
The name of the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Constructor (CultureInfo, String, Exception)

[image]

IceLib Technical Reference
ResourceInUseException Constructor (CultureInfo, String, Exception)
ResourceInUseException Class See Also Send Feedback
Initializes a new instance of the ResourceInUseException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResourceInUseException(
    CultureInfo cultureInfo,
    string resourceName,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    resourceName As String, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
resourceName
Type: System..::..String
The name of the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ResourceInUseException Overload
ININ.IceLib Namespace


ResourceInUseException Methods

[image] [image]

IceLib Technical Reference
ResourceInUseException Methods
ResourceInUseException Class See Also Send Feedback

The ResourceInUseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ResourceInUseException Class
ININ.IceLib Namespace


GetObjectData Method

[image]

IceLib Technical Reference
ResourceInUseException..::..GetObjectData Method
ResourceInUseException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ININ.IceLib Namespace


ResourceInUseException Properties

[image] [image]

IceLib Technical Reference
ResourceInUseException Properties
ResourceInUseException Class See Also Send Feedback

The ResourceInUseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResourceName | Gets the name of the resource.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ResourceInUseException Class
ININ.IceLib Namespace


ResourceName Property

[image]

IceLib Technical Reference
ResourceInUseException..::..ResourceName Property
ResourceInUseException Class See Also Send Feedback
Gets the name of the resource.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ResourceName { get; }
Visual Basic
Public ReadOnly Property ResourceName As String
    Get

Field Value

The name of the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResourceInUseException Class
ResourceInUseException Members
ININ.IceLib Namespace


ResourceInUseException Events

[image] [image]

IceLib Technical Reference
ResourceInUseException Events
ResourceInUseException Class See Also Send Feedback

The ResourceInUseException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ResourceInUseException Class
ININ.IceLib Namespace


ResultLimitExceededException Class

[image]

IceLib Technical Reference
ResultLimitExceededException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when returned results exceed the maximum allowable amount.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ResultLimitExceededException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ResultLimitExceededException _
    Inherits IceLibException

Remarks

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..ResultLimitExceededException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResultLimitExceededException Members
ININ.IceLib Namespace


ResultLimitExceededException Members

[image] [image]

IceLib Technical Reference
ResultLimitExceededException Members
ResultLimitExceededException Class Constructors Methods Properties Events See Also Send Feedback

The ResultLimitExceededException type exposes the following members.

Constructors

 | Name | Description
Public method | ResultLimitExceededException()()()() | Initializes a new instance of the ResultLimitExceededException class.
Public method | ResultLimitExceededException(CultureInfo) | Initializes a new instance of the ResultLimitExceededException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ResultLimitExceededException Class
ININ.IceLib Namespace


ResultLimitExceededException Constructor

[image] [image]

IceLib Technical Reference
ResultLimitExceededException Constructor
ResultLimitExceededException Class See Also Send Feedback
Initializes a new instance of the IceLibException class.

Overload List

 | Name | Description
Public method | ResultLimitExceededException()()()() | Initializes a new instance of the ResultLimitExceededException class.
Public method | ResultLimitExceededException(CultureInfo) | Initializes a new instance of the ResultLimitExceededException class.

See Also

ResultLimitExceededException Class
ResultLimitExceededException Members
ININ.IceLib Namespace


ResultLimitExceededException Constructor

[image]

IceLib Technical Reference
ResultLimitExceededException Constructor
ResultLimitExceededException Class See Also Send Feedback
Initializes a new instance of the ResultLimitExceededException class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResultLimitExceededException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResultLimitExceededException Class
ResultLimitExceededException Members
ResultLimitExceededException Overload
ININ.IceLib Namespace


ResultLimitExceededException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ResultLimitExceededException Constructor (CultureInfo)
ResultLimitExceededException Class See Also Send Feedback
Initializes a new instance of the ResultLimitExceededException class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResultLimitExceededException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResultLimitExceededException Class
ResultLimitExceededException Members
ResultLimitExceededException Overload
ININ.IceLib Namespace


ResultLimitExceededException Methods

[image] [image]

IceLib Technical Reference
ResultLimitExceededException Methods
ResultLimitExceededException Class See Also Send Feedback

The ResultLimitExceededException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ResultLimitExceededException Class
ININ.IceLib Namespace


ResultLimitExceededException Properties

[image] [image]

IceLib Technical Reference
ResultLimitExceededException Properties
ResultLimitExceededException Class See Also Send Feedback

The ResultLimitExceededException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ResultLimitExceededException Class
ININ.IceLib Namespace


ResultLimitExceededException Events

[image] [image]

IceLib Technical Reference
ResultLimitExceededException Events
ResultLimitExceededException Class See Also Send Feedback

The ResultLimitExceededException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ResultLimitExceededException Class
ININ.IceLib Namespace


ServerOperationNotSupportedException Class

[image]

IceLib Technical Reference
ServerOperationNotSupportedException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when the server does not support a requested operation.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ServerOperationNotSupportedException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ServerOperationNotSupportedException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested operation is not supported by the server. This can happen if the operation is implemented in a newer release of IceLib than the release of the server with which a Session was established.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib..::..ServerOperationNotSupportedException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Members
ININ.IceLib Namespace


ServerOperationNotSupportedException Members

[image] [image]

IceLib Technical Reference
ServerOperationNotSupportedException Members
ServerOperationNotSupportedException Class Constructors Methods Properties Events See Also Send Feedback

The ServerOperationNotSupportedException type exposes the following members.

Constructors

 | Name | Description
Public method | ServerOperationNotSupportedException()()()() | Initializes a new instance of the ServerOperationNotSupportedException class with default settings.
Public method | ServerOperationNotSupportedException(Exception) | Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.
Public method | ServerOperationNotSupportedException(CultureInfo) | Initializes a new instance of the ServerOperationNotSupportedException class with default settings.
Public method | ServerOperationNotSupportedException(CultureInfo, Exception) | Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.
Protected method | ServerOperationNotSupportedException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ServerOperationNotSupportedException Class
ININ.IceLib Namespace


ServerOperationNotSupportedException Constructor

[image] [image]

IceLib Technical Reference
ServerOperationNotSupportedException Constructor
ServerOperationNotSupportedException Class See Also Send Feedback
Initializes a new instance of the ServerOperationNotSupportedException class.

Overload List

 | Name | Description
Public method | ServerOperationNotSupportedException()()()() | Initializes a new instance of the ServerOperationNotSupportedException class with default settings.
Public method | ServerOperationNotSupportedException(Exception) | Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.
Public method | ServerOperationNotSupportedException(CultureInfo) | Initializes a new instance of the ServerOperationNotSupportedException class with default settings.
Public method | ServerOperationNotSupportedException(CultureInfo, Exception) | Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.
Protected method | ServerOperationNotSupportedException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ININ.IceLib Namespace


ServerOperationNotSupportedException Constructor

[image]

IceLib Technical Reference
ServerOperationNotSupportedException Constructor
ServerOperationNotSupportedException Class See Also Send Feedback
Initializes a new instance of the ServerOperationNotSupportedException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerOperationNotSupportedException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ServerOperationNotSupportedException Overload
ININ.IceLib Namespace


ServerOperationNotSupportedException Constructor (Exception)

[image]

IceLib Technical Reference
ServerOperationNotSupportedException Constructor (Exception)
ServerOperationNotSupportedException Class See Also Send Feedback
Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerOperationNotSupportedException(
    Exception innerException
)
Visual Basic
Public Sub New ( _
    innerException As Exception _
)

Parameters

innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ServerOperationNotSupportedException Overload
ININ.IceLib Namespace


ServerOperationNotSupportedException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ServerOperationNotSupportedException Constructor (CultureInfo)
ServerOperationNotSupportedException Class See Also Send Feedback
Initializes a new instance of the ServerOperationNotSupportedException class with default settings.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerOperationNotSupportedException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ServerOperationNotSupportedException Overload
ININ.IceLib Namespace


ServerOperationNotSupportedException Constructor (CultureInfo, Exception)

[image]

IceLib Technical Reference
ServerOperationNotSupportedException Constructor (CultureInfo, Exception)
ServerOperationNotSupportedException Class See Also Send Feedback
Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerOperationNotSupportedException(
    CultureInfo cultureInfo,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ServerOperationNotSupportedException Overload
ININ.IceLib Namespace


ServerOperationNotSupportedException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
ServerOperationNotSupportedException Constructor (SerializationInfo, StreamingContext)
ServerOperationNotSupportedException Class See Also Send Feedback
Initializes a new instance of the ServerOperationNotSupportedException class with a specified error message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ServerOperationNotSupportedException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ServerOperationNotSupportedException Overload
ININ.IceLib Namespace


ServerOperationNotSupportedException Methods

[image] [image]

IceLib Technical Reference
ServerOperationNotSupportedException Methods
ServerOperationNotSupportedException Class See Also Send Feedback

The ServerOperationNotSupportedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ServerOperationNotSupportedException Class
ININ.IceLib Namespace


GetObjectData Method

[image]

IceLib Technical Reference
ServerOperationNotSupportedException..::..GetObjectData Method
ServerOperationNotSupportedException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerOperationNotSupportedException Class
ServerOperationNotSupportedException Members
ININ.IceLib Namespace


ServerOperationNotSupportedException Properties

[image] [image]

IceLib Technical Reference
ServerOperationNotSupportedException Properties
ServerOperationNotSupportedException Class See Also Send Feedback

The ServerOperationNotSupportedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerOperationNotSupportedException Class
ININ.IceLib Namespace


ServerOperationNotSupportedException Events

[image] [image]

IceLib Technical Reference
ServerOperationNotSupportedException Events
ServerOperationNotSupportedException Class See Also Send Feedback

The ServerOperationNotSupportedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ServerOperationNotSupportedException Class
ININ.IceLib Namespace


Tracing Class

[image]

IceLib Technical Reference
Tracing Class
Members See Also Send Feedback
Contains support for tracing into the PureConnect log file.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Tracing
Visual Basic
Public NotInheritable Class Tracing

Remarks

All entries logged with this mechanism will be under the topic "Icelib_Custom" in the log file associated with the running application that is using IceLib.

Inheritance Hierarchy

System..::..Object
ININ.IceLib..::..Tracing

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Members
ININ.IceLib Namespace


Tracing Members

[image] [image]

IceLib Technical Reference
Tracing Members
Tracing Class Methods See Also Send Feedback

The Tracing type exposes the following members.

Methods

Name | Description
TraceAlways | Traces a message always, regardless of the trace level.
TraceError | Traces an error level message.
TraceException | Traces an exception and message.
TraceNote | Traces a note level message.
TraceStatus | Traces a status level message.
TraceVerbose | Traces a verbose level message.
TraceWarning | Traces a warning level message.

See Also

Tracing Class
ININ.IceLib Namespace


Tracing Methods

[image] [image]

IceLib Technical Reference
Tracing Methods
Tracing Class See Also Send Feedback

The Tracing type exposes the following members.

Methods

Name | Description
TraceAlways | Traces a message always, regardless of the trace level.
TraceError | Traces an error level message.
TraceException | Traces an exception and message.
TraceNote | Traces a note level message.
TraceStatus | Traces a status level message.
TraceVerbose | Traces a verbose level message.
TraceWarning | Traces a warning level message.

See Also

Tracing Class
ININ.IceLib Namespace


TraceAlways Method

[image]

IceLib Technical Reference
Tracing..::..TraceAlways Method
Tracing Class See Also Send Feedback
Traces a message always, regardless of the trace level.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceAlways(
    string message
)
Visual Basic
Public Shared Sub TraceAlways ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TraceError Method

[image]

IceLib Technical Reference
Tracing..::..TraceError Method
Tracing Class See Also Send Feedback
Traces an error level message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceError(
    string message
)
Visual Basic
Public Shared Sub TraceError ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TraceException Method

[image]

IceLib Technical Reference
Tracing..::..TraceException Method
Tracing Class See Also Send Feedback
Traces an exception and message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceException(
    Exception exception,
    string message
)
Visual Basic
Public Shared Sub TraceException ( _
    exception As Exception, _
    message As String _
)

Parameters

exception
Type: System..::..Exception
The exception.
message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TraceNote Method

[image]

IceLib Technical Reference
Tracing..::..TraceNote Method
Tracing Class See Also Send Feedback
Traces a note level message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceNote(
    string message
)
Visual Basic
Public Shared Sub TraceNote ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TraceStatus Method

[image]

IceLib Technical Reference
Tracing..::..TraceStatus Method
Tracing Class See Also Send Feedback
Traces a status level message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceStatus(
    string message
)
Visual Basic
Public Shared Sub TraceStatus ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TraceVerbose Method

[image]

IceLib Technical Reference
Tracing..::..TraceVerbose Method
Tracing Class See Also Send Feedback
Traces a verbose level message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceVerbose(
    string message
)
Visual Basic
Public Shared Sub TraceVerbose ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TraceWarning Method

[image]

IceLib Technical Reference
Tracing..::..TraceWarning Method
Tracing Class See Also Send Feedback
Traces a warning level message.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void TraceWarning(
    string message
)
Visual Basic
Public Shared Sub TraceWarning ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Tracing Class
Tracing Members
ININ.IceLib Namespace


TransferProgressChangedEventArgs Class

[image]

IceLib Technical Reference
TransferProgressChangedEventArgs Class
Members See Also Send Feedback
Members of this class provide data for TransferProgressChanged events.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TransferProgressChangedEventArgs : ProgressChangedEventArgs
Visual Basic
Public Class TransferProgressChangedEventArgs _
    Inherits ProgressChangedEventArgs

Remarks

This object provides extended information for upload/download transfer events. It not only provides a percent completion (from ProgressChangedEventArgs), but also includes the bytes transferred and the total used to calculate the percentage.

Examples

CopyC#
// This assumes a pre-existing session and local file.
RemoteFileHelper remoteFileHelper = new RemoteFileHelper(session);
string remoteFileName = remoteFileHelper.NewRemoteFileName(ServerFileType.Other);
remoteFileHelper.UploadProgressChanged += UploadChanged;
remoteFileHelper.UploadFile(localFileName, remoteFileName);
...
private void UploadChanged(object sender, TransferProgressChangedEventArgs e)
{
}

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..ProgressChangedEventArgs
ININ.IceLib..::..TransferProgressChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransferProgressChangedEventArgs Members
ININ.IceLib Namespace


TransferProgressChangedEventArgs Members

[image] [image]

IceLib Technical Reference
TransferProgressChangedEventArgs Members
TransferProgressChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The TransferProgressChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TransferProgressChangedEventArgs()()()() | Initializes a new instance of the TransferProgressChangedEventArgs class.
Public method | TransferProgressChangedEventArgs(Int64, Int64) | Initializes a new instance of the TransferProgressChangedEventArgs class.
Public method | TransferProgressChangedEventArgs(Int64, Int64, Object) | Initializes a new instance of the TransferProgressChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BytesTransferred | Gets the number of bytes transferred.
Public property | ProgressPercentage | Gets the asynchronous task progress percentage. (Inherited from ProgressChangedEventArgs.)
Public property | TotalBytesToTransfer | Gets the total number of bytes to transfer.
Public property | UserState | Gets a unique user state. (Inherited from ProgressChangedEventArgs.)

See Also

TransferProgressChangedEventArgs Class
ININ.IceLib Namespace


TransferProgressChangedEventArgs Constructor

[image] [image]

IceLib Technical Reference
TransferProgressChangedEventArgs Constructor
TransferProgressChangedEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransferProgressChangedEventArgs()()()() | Initializes a new instance of the TransferProgressChangedEventArgs class.
Public method | TransferProgressChangedEventArgs(Int64, Int64) | Initializes a new instance of the TransferProgressChangedEventArgs class.
Public method | TransferProgressChangedEventArgs(Int64, Int64, Object) | Initializes a new instance of the TransferProgressChangedEventArgs class.

See Also

TransferProgressChangedEventArgs Class
TransferProgressChangedEventArgs Members
ININ.IceLib Namespace


TransferProgressChangedEventArgs Constructor

[image]

IceLib Technical Reference
TransferProgressChangedEventArgs Constructor
TransferProgressChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the TransferProgressChangedEventArgs class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransferProgressChangedEventArgs()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransferProgressChangedEventArgs Class
TransferProgressChangedEventArgs Members
TransferProgressChangedEventArgs Overload
ININ.IceLib Namespace


TransferProgressChangedEventArgs Constructor (Int64, Int64)

[image]

IceLib Technical Reference
TransferProgressChangedEventArgs Constructor (Int64, Int64)
TransferProgressChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the TransferProgressChangedEventArgs class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransferProgressChangedEventArgs(
    long bytesTransferred,
    long totalBytesToTransfer
)
Visual Basic
Public Sub New ( _
    bytesTransferred As Long, _
    totalBytesToTransfer As Long _
)

Parameters

bytesTransferred
Type: System..::..Int64
The bytes transferred.
totalBytesToTransfer
Type: System..::..Int64
The total bytes to transfer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransferProgressChangedEventArgs Class
TransferProgressChangedEventArgs Members
TransferProgressChangedEventArgs Overload
ININ.IceLib Namespace


TransferProgressChangedEventArgs Constructor (Int64, Int64, Object)

[image]

IceLib Technical Reference
TransferProgressChangedEventArgs Constructor (Int64, Int64, Object)
TransferProgressChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the TransferProgressChangedEventArgs class.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransferProgressChangedEventArgs(
    long bytesTransferred,
    long totalBytesToTransfer,
    Object userState
)
Visual Basic
Public Sub New ( _
    bytesTransferred As Long, _
    totalBytesToTransfer As Long, _
    userState As Object _
)

Parameters

bytesTransferred
Type: System..::..Int64
The bytes transferred.
totalBytesToTransfer
Type: System..::..Int64
The total bytes to transfer.
userState
Type: System..::..Object
An object that contains state information for this request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransferProgressChangedEventArgs Class
TransferProgressChangedEventArgs Members
TransferProgressChangedEventArgs Overload
ININ.IceLib Namespace


TransferProgressChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
TransferProgressChangedEventArgs Methods
TransferProgressChangedEventArgs Class See Also Send Feedback

The TransferProgressChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransferProgressChangedEventArgs Class
ININ.IceLib Namespace


TransferProgressChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
TransferProgressChangedEventArgs Properties
TransferProgressChangedEventArgs Class See Also Send Feedback

The TransferProgressChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | BytesTransferred | Gets the number of bytes transferred.
Public property | ProgressPercentage | Gets the asynchronous task progress percentage. (Inherited from ProgressChangedEventArgs.)
Public property | TotalBytesToTransfer | Gets the total number of bytes to transfer.
Public property | UserState | Gets a unique user state. (Inherited from ProgressChangedEventArgs.)

See Also

TransferProgressChangedEventArgs Class
ININ.IceLib Namespace


BytesTransferred Property

[image]

IceLib Technical Reference
TransferProgressChangedEventArgs..::..BytesTransferred Property
TransferProgressChangedEventArgs Class See Also Send Feedback
Gets the number of bytes transferred.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long BytesTransferred { get; }
Visual Basic
Public ReadOnly Property BytesTransferred As Long
    Get

Field Value

The number of bytes transferred.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransferProgressChangedEventArgs Class
TransferProgressChangedEventArgs Members
ININ.IceLib Namespace


TotalBytesToTransfer Property

[image]

IceLib Technical Reference
TransferProgressChangedEventArgs..::..TotalBytesToTransfer Property
TransferProgressChangedEventArgs Class See Also Send Feedback
Gets the total number of bytes to transfer.

Namespace: ININ.IceLib
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long TotalBytesToTransfer { get; }
Visual Basic
Public ReadOnly Property TotalBytesToTransfer As Long
    Get

Field Value

The total bytes to transfer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransferProgressChangedEventArgs Class
TransferProgressChangedEventArgs Members
ININ.IceLib Namespace


ININ.IceLib.Configuration Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration Namespace
Send Feedback

The ININ.IceLib.Configuration namespace contains classes for configuring an Interaction Center server. ININ.IceLib.Configuration has rich support for the RoleConfiguration, UserConfiguration and WorkgroupConfiguration objects, as well as basic support for other objects such as SiteConfiguration and WrapUpCodeConfiguration.

There are a number of classes within the ININ.IceLib.Configuration namespace that provide support to the classes mentioned in the preceding summary. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

List-Based Configuration Objects. There are a number of object classes that are used to get properties for configuration objects that can have multiple instances on the server (distinguished by their ConfigurationId). These consist of ListConfigurationObject-derived classes. They are searched, with the results being cached, using a ConfigurationList-derived class. The search is comprised of a QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance which encapsulates a filter, a sort, the properties to be retrieved, the rights to be applied, and the result count limit. An example of this type of configuration object list is UserConfigurationList which is used to obtain UserConfiguration instances.

Some of these list-based configuration objects also support being edited, created, or deleted. These consist of EditableListConfigurationObject-derived classes and the EditableConfigurationList-derived classes used to search and cache them. The EditableConfigurationList-derived class has support for create and the EditableListConfigurationObject-derived class has support for edit and delete.

Container-Based Configuration Objects. There are a number of object classes that are used to get properties for configuration objects that can only have a single instance on the server. These consist of ContainerConfigurationObject-derived classes. They are queried, with the results being cached, using a ConfigurationContainer-derived class. The query is comprised of which properties are to be retrieved, and can also be specified with a ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance that encapsulates the properties to be retrieved and the rights to be applied.

Some of these container-based configuration objects also support being edited (but not created or deleted). These consist of EditableContainerConfigurationObject-derived classes. The EditableListConfigurationObject-derived class has support for edit. An example of this type of configuration object list is SystemConfigurationContainer which is used to obtain a SystemConfiguration instance.

List-Based Configuration Objects With a Parent/Child Relationship. There are a number of list-based configuration objects that have a parent-child relationship. A parent-child relationship is one in which the parent object has a property that contains a collection of child objects. Working with these types of objects are a little different from working with a standard list-based object. Currently, the objects that have such a relationship are: Parent object CtiConfiguration, with child object CtiAttributeMapConfiguration; parent object AnalyzerKeywordSetConfiguration, with child object AnalyzerKeywordConfiguration; parent object ScheduleConfiguration, with child object ScheduleRecurrenceConfiguration; and parent object WorkgroupConfiguration, with child object WorkgroupMonitoredMailboxConfiguration.

Querying List-Based Parent/Child Configuration Objects. A number of new steps needs to be completed to be able to query for a parent and child object. These steps involve using a HierarchicalQuerySettings object with an associated QueryChildrenSettings-derived object, in addition to the QuerySettings object. The Getting Started With Configuration topic has an example of how to query the Analyzer Keywords that are configured on the IC Server.

Adding new List-Based Parent/Child Configuration Objects. Adding a new parent/child configuration object differs only slightly from what is needed to add a typical list-based configuration object. The additional steps include creating the child object, and adding it to the associated collection property on the parent object. The Getting Started With Configuration topic has an example of how to add a new Analyzer Keyword Set with a new Keyword.

Note
For more information on getting started with configuration see Getting Started With Configuration.

Examples

The IceLib SDK includes example application references to the ININ.IceLib.Configuration namespace. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 60, in UserRoleConfigurationViewModel.set_SelectedConfigurationId
 | UserRoleConfigurationViewModel.cs, line 190, in UserRoleConfigurationViewModel.SessionConnectionStateChanged
 | UserRoleConfigurationViewModel.cs, line 203, in UserRoleConfigurationViewModel.<SessionConnectionStateChanged>b__7
 | UserRoleConfigurationViewModel.cs, line 48, in UserRoleConfigurationViewModel.#ctor
 | UserRoleConfigurationViewModel.CS$<>9__CachedAnonymousMethodDelegate8
 | UserRoleConfigurationViewModel.cs, line 32, in UserRoleConfigurationViewModel.set_ConfigurationIdList
 | UserRoleConfigurationViewModel.cs, line 45, in UserRoleConfigurationViewModel.set_ConfigurationObjects
 | UserRoleConfigurationViewModel._ConfigurationManager
 | UserRoleConfigurationViewModel._ConfigurationIdList
 | UserRoleConfigurationViewModel._ConfigurationObjects
 | UserRoleConfigurationViewModel._SelectedConfigurationId

Classes

 | Class | Description
Public class | AccessControlGroupConfiguration | Contains configuration and administration settings for an IC access control group.
Public class | AccessControlGroupConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AccessControlGroupConfigurationList | Allows for querying and managing access control group configuration objects.
Public class | AccountCodeConfiguration | Contains configuration and administration settings for an IC Account Code. An account code is a set of identifying numbers assigned to an account name. Account codes are used to track incoming and outgoing calls that can be tracked and reported in standard reports.
Public class | AccountCodeConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AccountCodeConfigurationList | Allows for querying and managing AccountCode configuration objects.
Public class | AccountCodesConfiguration | Contains configuration and administration settings for IC Account Codes.
Public class | AccountCodesConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AccountCodesConfigurationContainer | Allows for querying and managing the account codes configuration object.
Public class | AccumulatorConfiguration | Contains configuration and administration settings for an IC Accumulator. Accumulators are like global variables that hold a value outside of a handler. Accumulator tools within handlers can assign, increment, and retrieve the values stored in these accumulators. Before a tool in a handler can set the value of an accumulator, the accumulator must be defined in Interaction Administrator.
Public class | AccumulatorConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AccumulatorConfigurationList | Allows for querying and managing Accumulator configuration objects.
Public class | ActionConfiguration | Contains configuration and administration settings for an IC action.
Public class | ActionConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ActionConfigurationList | Allows for querying and managing action configuration objects.
Public class | AnalyzerKeywordConfiguration | Contains configuration and administration settings for an analyzer keyword.
Public class | AnalyzerKeywordConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AnalyzerKeywordSetConfiguration | Contains configuration and administration settings for an analyzer keyword set.
Public class | AnalyzerKeywordSetConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AnalyzerKeywordSetConfigurationList | Allows for querying and managing analyzer keyword set configuration objects.
Public class | AnalyzerQueryChildrenSettings | Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects.
Public class | AttendantConfigurationConfiguration | Obsolete. Contains configuration and administration settings for an IC AttendantConfiguration.
Public class | AttendantConfigurationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AttendantConfigurationConfigurationList | Obsolete. Allows for querying and managing AttendantConfiguration configuration objects.
Public class | AttendantEmailProfileConfiguration | Contains configuration and administration settings for an IC AttendantEmailProfile.
Public class | AttendantEmailProfileConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AttendantEmailProfileConfigurationList | Allows for querying and managing AttendantEmailProfile configuration objects.
Public class | AttendantInboundProfileConfiguration | Contains configuration and administration settings for an IC AttendantInboundProfile.
Public class | AttendantInboundProfileConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AttendantInboundProfileConfigurationList | Allows for querying and managing AttendantInboundProfile configuration objects.
Public class | AttendantOperatorProfileConfiguration | Contains configuration and administration settings for an IC AttendantOperatorProfile.
Public class | AttendantOperatorProfileConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AttendantOperatorProfileConfigurationList | Allows for querying and managing AttendantOperatorProfile configuration objects.
Public class | AttendantOutboundProfileConfiguration | Contains configuration and administration settings for an IC AttendantOutboundProfile.
Public class | AttendantOutboundProfileConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AttendantOutboundProfileConfigurationList | Allows for querying and managing AttendantOutboundProfile configuration objects.
Public class | AudioSourceConfiguration | Contains configuration and administration settings for an IC Audio Source. An audio source is a feature that provides a "named" audio source that continuously transmit audio and can be listened to simultaneously by multiple calls. A common use of Audio Sources is for hold music, either for system-wide calls on-hold or in-queue waiting for an agent.
Public class | AudioSourceConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | AudioSourceConfigurationList | Allows for querying and managing AudioSource configuration objects.
Public class | BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Represents a basic filter for searching configuration objects.
Public class | BeginTransactionCompletedEventArgs | Provides data for the asynchronous completed event of BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object).
Public class | ClientConfigurationTemplateConfiguration | Contains configuration and administration settings for an IC Client Configuration Template. A client configuration template can be used to specify the IC configuration to apply to a User.
Public class | ClientConfigurationTemplateConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ClientConfigurationTemplateConfigurationList | Allows for querying and managing ClientConfigurationTemplate configuration objects.
Public class | ClientTemplateConfiguration | Contains configuration and administration settings for IC Client Templates.
Public class | ClientTemplateConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ClientTemplateConfigurationList | Allows for querying and managing ClientTemplate configuration objects.
Public class | ClientTemplatePublishResult | Contains information on the results of publishing a client template.
Public class | ClientTemplateResource | Represents a client template for an ClientTemplateConfiguration object.
Public class | ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Allows for querying and managing a container-based configuration object.
Public class | ConfigurationDeleteException | The exception that is thrown for IceLib when a configuration delete operation fails.
Public class | ConfigurationId | Represents a unique identifier for an object, along with its display name.
Public class | ConfigurationLicenseException | The exception that is thrown for IceLib when an operation is prevented due to configuration license issues.
Public class | ConfigurationLicenseIssue | Represents a configuration license issue.
Public class | ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Allows for querying and managing list-based configuration objects.
Public class | ConfigurationManager | The ConfigurationManager class provides access to IC configuration and administration information for many IC objects, such as users, roles, prompts, and workgroups.
Public class | ConfigurationObject | Represents a configuration object.
Public class | ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Event arguments detailing the changes to a watched configuration object type.
Public class | ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> | Represents a configuration property value.
Public class | ConfigurationReferenceDetails | Represents details about a configuration reference.
Public class | ConfigurationReferenceException | The exception that is thrown for IceLib when an operation is prevented due to references by other objects.
Public class | ConfigurationValidationException | The exception that is thrown for IceLib when an operation is prevented due to configuration validation issues.
Public class | ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> | Represents a configuration validation issue.
Public class | ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> | Event arguments detailing the addition or removal of a watched configuration object type.
Public class | ContactListSourceConfiguration | Contains configuration and administration settings for an IC Contact List Source. A contact list source defines information about where an IC Contact list is located.
Public class | ContactListSourceConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ContactListSourceConfigurationList | Allows for querying and managing ContactListSource configuration objects.
Public class | ContainerConfigurationObject | Represents a container-based configuration object.
Public class | ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | This class represents settings for a Configuration query for container objects. CreateQuerySettings()()()() can be used to construct an appropriate ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. The Set functions can be used to override default values.
Public class | CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Provides data for asynchronous completed events of CreateObjectAsync(EventHandler<(Of <<'(CreateObjectCompletedEventArgs<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)>)>>), Object).
Public class | CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Represents a custom attribute filter for searching configuration objects.
Public class | CustomButtonConfiguration | Contains configuration and administration settings for an IC Custom Button. A custom button can be configured to be specific per interaction type, and optionally display it on the appropriate interaction dialog box(es). The custom button can be shown on the queue toolbar and/or on any one of the interaction dialog boxes (email, chat, call, etc...). Additionally, a button can be configured to apply to an "interaction type" which causes a queue-based custom button to be enabled only when one of the correct interaction types is selected in the queue view.
Public class | CustomButtonConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | CustomButtonConfigurationList | Allows for querying and managing CustomButton configuration objects.
Public class | DefaultLocationConfiguration | Contains configuration and administration settings for a Default Location for the IC System.
Public class | DefaultLocationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | DefaultLocationConfigurationContainer | Allows for querying and managing the default location object.
Public class | DefaultStationConfiguration | Contains configuration and administration settings for a Default Station for the IC System. A default station is used to set global options that impact all IC Stations.
Public class | DefaultStationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | DefaultStationConfigurationContainer | Allows for querying and managing the system configuration object.
Public class | DefaultUserConfiguration | Contains configuration and administration settings for a Default User for the IC System. A default user is used to set global options that impact all IC Users.
Public class | DefaultUserConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | DefaultUserConfigurationContainer | Allows for querying and managing the system configuration object.
Public class | DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> | Represents an inheritable configuration property with extended details.
Public class | DnisMappingsConfiguration | Contains configuration and administration settings for the Dnis Mappings.
Public class | DnisMappingsConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | DnisMappingsConfigurationContainer | Allows for querying and managing the system configuration object.
Public class | DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Allows for watching list-based configuration objects.
Public class | EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Allows for querying and managing editable list-based configuration objects.
Public class | EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> | Represents a container-based configuration object that can be edited.
Public class | EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> | Represents a list-based configuration object that can be edited.
Public class | FaxGroupConfiguration | Contains configuration and administration settings for an IC Fax Group. A fax group is a named group of fax resources.
Public class | FaxGroupConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | FaxGroupConfigurationList | Allows for querying and managing FaxGroup configuration objects.
Public class | FeatureLicenseConfiguration | Contains configuration and administration settings for an IC feature license.
Public class | FeatureLicenseConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | FeatureLicenseConfigurationList | Allows for querying feature license configuration objects.
Public class | FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Represents a filter for searching configuration objects.
Public class | GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> | Represents a general configuration property.
Public class | GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> | Provides data for asynchronous completed events of GetValidatorsAsync(EventHandler<(Of <<'(GetValidatorsCompletedEventArgs<(Of <<'(TPropertyEnum>)>>)>)>>), Object).
Public class | GroupedConfigurationId | Represents a unique identifier for an object, along with its display name.
Public class | GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Represents a group filter for searching configuration objects.
Public class | HandlerConfiguration | Contains configuration and administration settings for an IC Handler. Handlers are created in the Interaction Designer and "published" to the IC Server for use by the Interaction Processor. Handlers define all of the functionality of IC.
Public class | HandlerConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | HandlerConfigurationList | Allows for querying and managing Handler configuration objects.
Public class | HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> | This class represents settings for a Configuration query that results in data that is in a hierarchical format. If sub-object support is not needed, QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> should be used instead.
Public class | ICDataSourceConfiguration | Contains configuration and administration settings for sn IC data source.
Public class | ICDataSourceConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ICDataSourceConfigurationList | Allows for querying and managing IC data source configuration objects.
Public class | ImageResource | Represents an image resource for an ImageResourceConfiguration object.
Public class | ImageResourceCategoryConfiguration | Contains configuration and administration settings for ImageResourceCategory.
Public class | ImageResourceCategoryConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ImageResourceCategoryConfigurationList | Allows for querying and managing ImageResourceCategory configuration objects.
Public class | ImageResourceConfiguration | Contains configuration and administration settings for ImageResource.
Public class | ImageResourceConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ImageResourceConfigurationList | Allows for querying and managing ImageResource configuration objects.
Public class | InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> | Represents an inheritable configuration property.
Public class | InheritedValueDetails<(Of <(<'TValue>)>)> | Represents details about an inherited configuration reference.
Public class | InitializationFunctionConfiguration | Contains configuration and administration settings for an IC Initialization Function. Initialization functions are functions that perform some system initialization when the IC system starts. These functions are contained in DLLs that must be registered on the IC Server in the Interaction Administrator utility.
Public class | InitializationFunctionConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | InitializationFunctionConfigurationList | Allows for querying and managing InitializationFunction configuration objects.
Public class | InteractionClientPluginConfiguration | Contains configuration and administration settings for an IC Interaction Client Plugin.
Public class | InteractionClientPluginConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | InteractionClientPluginConfigurationList | Allows for querying and managing InteractionClientPlugin configuration objects.
Public class | InteractionConferenceRoomConfiguration | Contains configuration and administration settings for an IC Interaction Conference Room. An interaction conference room defines information needed to create an interaction conference.
Public class | InteractionConferenceRoomConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | InteractionConferenceRoomConfigurationList | Allows for querying and managing InteractionConferenceRoom configuration objects.
Public class | InteractionProcessorTableConfiguration | Contains configuration and administration settings for an IC InteractionProcessorTable.
Public class | InteractionProcessorTableConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | InteractionProcessorTableConfigurationList | Allows for querying and managing InteractionProcessorTable configuration objects.
Public class | LayoutConfiguration | Contains configuration and administration settings for an IC Layout. Layouts are used to define the physical position of agents and stations on a floor plan.
Public class | LayoutConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | LayoutConfigurationList | Allows for querying and managing Layout configuration objects.
Public class | LicenseAllocationConfiguration | Contains configuration and administration settings for an IC License Allocation. A license allocation defines a license known by IC's License Manager.
Public class | LicenseAllocationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | LicenseAllocationConfigurationList | Allows for querying and managing license allocation configuration objects.
Public class | LineConfiguration | Contains configuration and administration settings for an IC Line. A line is a generalized reference to individual analog lines from a CO, a single ISDN B channel, a T-1 or E-1 channel, or as a tie line between two switches.
Public class | LineConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | LineConfigurationList | Allows for querying and managing Line configuration objects.
Public class | LineGroupConfiguration | Contains configuration and administration settings for an IC Line Group. Line groups define a group of one or more lines that can be reserved for specific uses, such as long distance calls, local calls, etc. A line group can also reserve a group of lines for calls for an individual user or a workgroup.
Public class | LineGroupConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | LineGroupConfigurationList | Allows for querying and managing LineGroup configuration objects.
Public class | ListConfigurationObject | Represents a list-based configuration object.
Public class | LocationConfiguration | Contains configuration and administration settings for an IC Location. A location represents an area where things are considered to be in the same physical place. This location defines a set of endpoints (lines, stations, and servers) that share a common dial plan, and it defines Codec communications for the endpoints.
Public class | LocationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | LocationConfigurationList | Allows for querying and managing Location configuration objects.
Public class | MiscellaneousItemConfiguration | Contains configuration and administration settings for an IC MiscellaneousItem.
Public class | MiscellaneousItemConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | MiscellaneousItemConfigurationList | Allows for querying and managing MiscellaneousItem configuration objects.
Public class | MrcpServerConfiguration | Contains configuration and administration settings for Mrcp Servers.
Public class | MrcpServerConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | MrcpServerConfigurationList | Allows for querying and managing Mrcp Server configuration objects.
Public class | PagingCarrierConfiguration | Contains configuration and administration settings for an IC PagingCarrier.
Public class | PagingCarrierConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | PagingCarrierConfigurationList | Allows for querying and managing PagingCarrier configuration objects.
Public class | PasswordPolicyConfiguration | Contains configuration and administration settings for an IC Password Policy. A password policy is a set of rules that a password must meet.
Public class | PasswordPolicyConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | PasswordPolicyConfigurationList | Allows for querying and managing passwordPolicy configuration objects.
Public class | PersonalInformationProperties | Contains personal information settings for a UserConfiguration.
Public class | PhoneNumberClassificationConfiguration | Contains configuration and administration settings for an IC Phone Number Classification. A phone number classification defines a pattern in numbers, or an explicit group of phone numbers with a common purpose.
Public class | PhoneNumberClassificationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | PhoneNumberClassificationConfigurationList | Allows for querying and managing PhoneNumberClassification configuration objects.
Public class | PositionConfiguration | Contains configuration and administration settings for an IC Layout Position. A Position represents the physical location of a station.
Public class | PositionConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | PositionConfigurationList | Allows for querying and managing Position configuration objects.
Public class | ProblemReporterConfiguration | Contains configuration and administration settings for ProblemReporter.
Public class | ProblemReporterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ProblemReporterConfigurationContainer | Allows for querying and managing the ProblemReporter configuration object.
Public class | QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> | Abstract class that acts as a container for QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> that HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> uses to hold its children.
Public class | QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | This class represents settings for a Configuration query that provides a filtered and sorted set of results. CreateQuerySettings()()()() can be used to construct an appropriate QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. The Set functions can be used to override default values.
Public class | QueueColumnConfiguration | Contains configuration and administration settings for an IC QueueColumn.
Public class | QueueColumnConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | QueueColumnConfigurationList | Allows for querying and managing QueueColumn configuration objects.
Public class | RecordingBeepToneConfiguration | Contains configuration and administration settings for a Recording Beep Tone. A Beep Tone is a set of attributes that can be assigned to a workgroup.
Public class | RecordingBeepToneConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | RecordingBeepToneConfigurationList | Allows for querying and managing recording beep tone configuration objects.
Public class | ReportLogConfiguration | Contains configuration and administration settings for an IC Report Log. Report logs are predefined and do not require customization or configuration by default, and define a log's location.
Public class | ReportLogConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportLogConfigurationList | Allows for querying and managing ReportLog configuration objects.
Public class | ResponseManagementDocumentConfiguration | Contains configuration and administration settings for an IC Response Management Document. A response management document is a pre-defined response, such as a message, URL, or file.
Public class | ResponseManagementDocumentConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ResponseManagementDocumentConfigurationList | Allows for querying and managing ResponseManagementDocument configuration objects.
Public class | RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> | Represents an ACL that can be used to filter a query based on rights.
Public class | RoleConfiguration | Contains configuration and administration settings for an IC role. A role is a set of permissions that can be assigned to a workgroup or user.
Public class | RoleConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | RoleConfigurationList | Allows for querying and managing role configuration objects.
Public class | ScheduleConfiguration | Contains configuration and administration settings for an IC Schedule. A schedule defines dates and times to activate telephone-based menus.
Public class | ScheduleConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ScheduleConfigurationList | Allows for querying and managing Schedule configuration objects.
Public class | ScheduleQueryChildrenSettings | Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects for ScheduleRecurrences.
Public class | ScheduleRecurrenceConfiguration | Contains configuration and administration settings for the recurrence pattern of an IC Schedule.
Public class | ScheduleRecurrenceConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SecureInputFormConfiguration | Contains configuration and administration settings for a secure input form configuration object.
Public class | SecureInputFormConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SecureInputFormConfigurationList | Allows for querying and managing SecureInputForm configuration objects.
Public class | SelectionRuleConfiguration | Contains configuration and administration settings for Selection Rules.
Public class | SelectionRuleConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SelectionRuleConfigurationList | Allows for querying and managing Selection Rule configuration objects.
Public class | ServerParameterConfiguration | Contains configuration and administration settings for an IC ServerParameter.
Public class | ServerParameterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ServerParameterConfigurationList | Allows for querying and managing ServerParameter configuration objects and provides convenience functions for accessing some well-known parameters.
Public class | ServerReportConfigurationConfiguration | Contains configuration and administration settings for the IC Server Report Configuration.
Public class | ServerReportConfigurationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ServerReportConfigurationConfigurationContainer | Allows for querying and managing the Server Report Configuration object.
Public class | SingleSignOnIdentityProviderConfiguration | Contains configuration and administration settings for Single Sign On Identity Providers.
Public class | SingleSignOnIdentityProviderConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SingleSignOnIdentityProviderConfigurationList | Allows for querying and managing Single Sign On Identity Provider configuration objects.
Public class | SipBridgeConfiguration | Contains configuration and administration settings for Sip Bridges.
Public class | SipBridgeConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SipBridgeConfigurationList | Allows for querying and managing SipBridge configuration objects.
Public class | SiteConfiguration | Contains configuration and administration settings for sites configured in Interaction Administrator.
Public class | SiteConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SiteConfigurationList | Allows for querying and managing site configuration objects.
Public class | SkillConfiguration | Contains configuration and administration settings for an IC skill.
Public class | SkillConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SkillConfigurationList | Allows for querying and managing skill configuration objects.
Public class | SmdiPortConfiguration | Obsolete. Contains configuration and administration settings for an IC SMDI port.
Public class | SmdiPortConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SmdiPortConfigurationList | Obsolete. Allows for querying and managing SmdiPort configuration objects.
Public class | SmsBrokerConfiguration | Contains configuration and administration settings for an IC SMS Broker. An SMS broker is a company that takes care of routing SMS messages to cell phones and which collects SMS messages from cell phones.
Public class | SmsBrokerConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SmsBrokerConfigurationList | Allows for querying and managing SmsBroker configuration objects.
Public class | SortDefinition<(Of <(<'TPropertyEnum>)>)> | Represents a sort for searching configuration objects.
Public class | StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Contains standard properties for a ConfigurationObject.
Public class | StationConfiguration | Contains configuration and administration settings for an IC Station.
Public class | StationConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StationConfigurationList | Allows for querying and managing station configuration objects.
Public class | StationGroupConfiguration | Contains configuration and administration settings for an IC Station Group. A station group defines a logical group of stations that are related.
Public class | StationGroupConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StationGroupConfigurationList | Allows for querying and managing StationGroup configuration objects.
Public class | StationLicenseProperties | Contains license settings for a StationConfiguration.
Public class | StationTemplateConfiguration | Contains configuration and administration settings for an IC Station Template. A station template defines default behavior for a station and can be used when configuring the behavior of a new station.
Public class | StationTemplateConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StationTemplateConfigurationList | Allows for querying and managing stationTemplate configuration objects.
Public class | StatusColumnConfiguration | Contains configuration and administration settings for an IC StatusColumn.
Public class | StatusColumnConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StatusColumnConfigurationList | Allows for querying and managing StatusColumn configuration objects.
Public class | StatusMessageConfiguration | Contains configuration and administration settings for an IC Status Message. A status message is used for reporting status times.
Public class | StatusMessageConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StatusMessageConfigurationList | Allows for querying and managing StatusMessage configuration objects.
Public class | StreamingAudioMonitorProfileConfiguration | Contains configuration and administration settings for an StreamingAudioMonitorProfile.
Public class | StreamingAudioMonitorProfileConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StreamingAudioMonitorProfileConfigurationList | Allows for querying and managing StreamingAudioMonitorProfile configuration objects.
Public class | StructuredParameterConfiguration | Contains configuration and administration settings for an IC StructuredParameter. Structured parameters are typed parameters grouped together (like server parameters).
Public class | StructuredParameterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | StructuredParameterConfigurationList | Allows for querying and managing StructuredParameter configuration objects.
Public class | SystemConfiguration | Contains configuration and administration settings for the Interaction Center system.
Public class | SystemConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SystemConfigurationContainer | Allows for querying and managing the system configuration object.
Public class | SystemLanguage | Contains information about a language supported by the IC Server. A system language consists of a default language-neutral CultureInfo object, and a collection of it's associated language-specific CultureInfo objects.
Public class | SystemParameterConfiguration | Contains configuration and administration settings for an IC SystemParameter.
Public class | SystemParameterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | SystemParameterConfigurationList | Allows for querying and managing SystemParameter configuration objects.
Public class | TypedReference | Represents an object type and ID pair.
Public class | TypedReferenceValue<(Of <(<'TValue>)>)> | Represents an object type and ID pair.
Public class | UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Contains Access Control Right settings for configuration objects (e.g. RoleConfiguration).
Public class | UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Contains Administrative Access Control Right settings for configuration objects (e.g. RoleConfiguration).
Public class | UserConfiguration | Contains configuration and administration settings for an IC User. A user defines an individual within the IC System.
Public class | UserConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | UserConfigurationList | Allows for querying and managing user configuration objects.
Public class | UserLicenseProperties | Contains license settings for a UserConfiguration.
Public class | UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Contains Security Access Right settings for configuration objects (e.g. RoleConfiguration).
Public class | ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Represents a value list filter for searching configuration objects.
Public class | VoiceModuleConfiguration | Contains configuration and administration settings for an IC Voice Module. A voice module corresponds to the digital signal processor (DSP) on the Aculab board.
Public class | VoiceModuleConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | VoiceModuleConfigurationList | Allows for querying and managing VoiceModule configuration objects.
Public class | WebServicesParameterConfiguration | Contains configuration and administration settings for an IC Web Services Parameter. Web services parameters are used to configure IC Web Services.
Public class | WebServicesParameterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | WebServicesParameterConfigurationList | Allows for querying and managing WebServicesParameter configuration objects.
Public class | WorkgroupConfiguration | Contains configuration and administration settings for an IC workgroup. A workgroup is a defined logical group of Users related by function, department, project, or other organization.
Public class | WorkgroupConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | WorkgroupConfigurationList | Allows for querying and managing workgroup configuration objects.
Public class | WorkgroupMonitoredMailboxConfiguration | Contains configuration and administration settings for WorkgroupMonitoredMailbox.
Public class | WorkgroupMonitoredMailboxConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | WorkgroupQueryChildrenSettings | Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects for MonitoredMailboxes.
Public class | WrapUpCategoryConfiguration | Contains configuration and administration settings for an IC WrapUpCategory.
Public class | WrapUpCategoryConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | WrapUpCategoryConfigurationList | Allows for querying and managing WrapUpCategory configuration objects.
Public class | WrapUpCodeConfiguration | Contains configuration and administration settings for an IC Wrap-Up Code. Wrap-Up codes can be assigned by agents to incoming and outgoing interactions, and are used in reporting to help categorize call details.
Public class | WrapUpCodeConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | WrapUpCodeConfigurationList | Allows for querying and managing WrapUpCode configuration objects.

Interfaces

 | Interface | Description
Public interface | IEditable | Defines common aspects of a configuration object that can be in an editable state.

Enumerations

 | Enumeration | Description
Public enumeration | AccessControlGroupConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AccountCodeConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AccountCodesConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AccumulatorConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ActionConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AnalyzerKeywordConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AnalyzerKeywordSetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AttendantConfigurationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AttendantEmailProfileConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AttendantInboundProfileConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AttendantOperatorProfileConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AttendantOutboundProfileConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | AudioSourceConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ClientConfigurationTemplateConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ClientTemplateConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ConfigurationIdGrouping | The grouping of a GroupedConfigurationId.
Public enumeration | ConfigurationLicenseIssueType | Describes which type of configuration license issue was experienced.
Public enumeration | ContactListSourceConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | CustomButtonConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | DefaultLocationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | DefaultStationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | DefaultUserConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | DnisMappingsConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | FaxGroupConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | FeatureLicenseConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | FilterMatchType | Specifies the filter match type.
Public enumeration | HandlerConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ICDataSourceConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ImageResourceCategoryConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ImageResourceConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | InitializationFunctionConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | InteractionClientPluginConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | InteractionConferenceRoomConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | InteractionProcessorTableConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | LayoutConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | LicenseAllocationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | LineConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | LineGroupConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | LocationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | MiscellaneousItemConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | MrcpServerConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ObjectType | Represents the object type of a GroupedConfigurationId.
Public enumeration | PagingCarrierConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | PasswordPolicyConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | PhoneNumberClassificationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | PositionConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ProblemReporterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | QueryResultLimit | Limits a QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> result set to a non-numerical, special case value.
Public enumeration | QueueColumnConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | RecordingBeepToneConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportLogConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ResponseManagementDocumentConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | RoleConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ScheduleConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ScheduleRecurrenceConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SecureInputFormConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SelectionRuleConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ServerParameterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ServerReportConfigurationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SingleSignOnIdentityProviderConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SipBridgeConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SiteConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SkillConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SmdiPortConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SmsBrokerConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StationConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StationGroupConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StationTemplateConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StatusColumnConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StatusMessageConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StreamingAudioMonitorProfileConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | StructuredParameterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SystemConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | SystemParameterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | UserConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | VoiceModuleConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | WebServicesParameterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | WorkgroupConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | WorkgroupMonitoredMailboxConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | WrapUpCategoryConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | WrapUpCodeConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.


AccessControlGroupConfiguration Class

[image]

IceLib Technical Reference
AccessControlGroupConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC access control group.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccessControlGroupConfiguration : EditableListConfigurationObject<AccessControlGroupConfiguration..::..Property>
Visual Basic
Public Class AccessControlGroupConfiguration _
    Inherits EditableListConfigurationObject(Of AccessControlGroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' AccessControlGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccessControlGroupConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


AccessControlGroupConfiguration Members

[image] [image]

IceLib Technical Reference
AccessControlGroupConfiguration Members
AccessControlGroupConfiguration Class Methods Properties See Also Send Feedback

The AccessControlGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccountCodes | Provides access to the property representing the account codes for this access control group (use Property.AccountCodes).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | Children | Provides access to the property representing the children for this access control group (use Property.Children).
Public property | ClientConfigurationTemplates | Provides access to the property representing the client configuration templates for this access control group (use Property.ClientConfigurationTemplates).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ImageResources | Provides access to the property representing the image resources for this access control group (use Property.ImageResources).
Public property | InteractionProcessorTables | Provides access to the property representing the InteractionProcessorTables for this access control group (use Property.InteractionProcessorTables).
Public property | IpPhoneProxyGroups | Provides access to the property representing the IP Phone Proxy Groups for this access control group (use Property.IpPhoneProxyGroups).
Public property | IpPhoneRingSets | Provides access to the property representing the IP Phone Ring Sets for this access control group (use Property.IpPhones).
Public property | IpPhones | Provides access to the property representing the IP Phones for this access control group (use Property.IpPhones).
Public property | IpPhoneTemplates | Provides access to the property representing the IP Phone Templates for this access control group (use Property.IpPhoneTemplates).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | KeywordSets | Provides access to the property representing the KeywordSets for this access control group (use Property.KeywordSets).
Public property | Layouts | Provides access to the property representing the layouts for this access control group (use Property.Layouts).
Public property | Locations | Provides access to the property representing the locations for this access control group (use Property.Locations).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | Parent | Provides access to the property representing the Parent for this access control group (use Property.Parent).
Public property | PasswordPolicies | Provides access to the property representing the password policies for this access control group (use Property.PasswordPolicies).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | Roles | Provides access to the property representing the roles for this access control group (use Property.Roles).
Public property | Schedules | Provides access to the property representing the schedules for this access control group (use Property.Schedules).
Public property | Skills | Provides access to the property representing the skills for this access control group (use Property.Skills).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StationGroups | Provides access to the property representing the station groups for this access control group (use Property.StationGroups).
Public property | Stations | Provides access to the property representing the stations for this access control group (use Property.Stations).
Public property | StationTemplates | Provides access to the property representing the station templates for this access control group (use Property.StationTemplates).
Public property | Users | Provides access to the property representing the users for this access control group (use Property.Users).
Public property | Workgroups | Provides access to the property representing the workgroups for this access control group (use Property.Workgroups).
Public property | WrapUpCategories | Provides access to the property representing the wrap up categories for this access control group (use Property.WrapUpCategories).
Public property | WrapUpCodes | Provides access to the property representing the wrap up codes for this access control group (use Property.WrapUpCodes).

See Also

AccessControlGroupConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupConfiguration Methods

[image] [image]

IceLib Technical Reference
AccessControlGroupConfiguration Methods
AccessControlGroupConfiguration Class See Also Send Feedback

The AccessControlGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AccessControlGroupConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupConfiguration Properties

[image] [image]

IceLib Technical Reference
AccessControlGroupConfiguration Properties
AccessControlGroupConfiguration Class See Also Send Feedback

The AccessControlGroupConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodes | Provides access to the property representing the account codes for this access control group (use Property.AccountCodes).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | Children | Provides access to the property representing the children for this access control group (use Property.Children).
Public property | ClientConfigurationTemplates | Provides access to the property representing the client configuration templates for this access control group (use Property.ClientConfigurationTemplates).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ImageResources | Provides access to the property representing the image resources for this access control group (use Property.ImageResources).
Public property | InteractionProcessorTables | Provides access to the property representing the InteractionProcessorTables for this access control group (use Property.InteractionProcessorTables).
Public property | IpPhoneProxyGroups | Provides access to the property representing the IP Phone Proxy Groups for this access control group (use Property.IpPhoneProxyGroups).
Public property | IpPhoneRingSets | Provides access to the property representing the IP Phone Ring Sets for this access control group (use Property.IpPhones).
Public property | IpPhones | Provides access to the property representing the IP Phones for this access control group (use Property.IpPhones).
Public property | IpPhoneTemplates | Provides access to the property representing the IP Phone Templates for this access control group (use Property.IpPhoneTemplates).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | KeywordSets | Provides access to the property representing the KeywordSets for this access control group (use Property.KeywordSets).
Public property | Layouts | Provides access to the property representing the layouts for this access control group (use Property.Layouts).
Public property | Locations | Provides access to the property representing the locations for this access control group (use Property.Locations).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | Parent | Provides access to the property representing the Parent for this access control group (use Property.Parent).
Public property | PasswordPolicies | Provides access to the property representing the password policies for this access control group (use Property.PasswordPolicies).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | Roles | Provides access to the property representing the roles for this access control group (use Property.Roles).
Public property | Schedules | Provides access to the property representing the schedules for this access control group (use Property.Schedules).
Public property | Skills | Provides access to the property representing the skills for this access control group (use Property.Skills).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StationGroups | Provides access to the property representing the station groups for this access control group (use Property.StationGroups).
Public property | Stations | Provides access to the property representing the stations for this access control group (use Property.Stations).
Public property | StationTemplates | Provides access to the property representing the station templates for this access control group (use Property.StationTemplates).
Public property | Users | Provides access to the property representing the users for this access control group (use Property.Users).
Public property | Workgroups | Provides access to the property representing the workgroups for this access control group (use Property.Workgroups).
Public property | WrapUpCategories | Provides access to the property representing the wrap up categories for this access control group (use Property.WrapUpCategories).
Public property | WrapUpCodes | Provides access to the property representing the wrap up codes for this access control group (use Property.WrapUpCodes).

See Also

AccessControlGroupConfiguration Class
ININ.IceLib.Configuration Namespace


AccountCodes Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..AccountCodes Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the account codes for this access control group (use Property.AccountCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> AccountCodes { get; }
Visual Basic
Public ReadOnly Property AccountCodes As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the account codes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AccountCodeConfiguration
ININ.IceLib.Configuration..::..AccountCodeConfigurationList


Children Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Children Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the children for this access control group (use Property.Children).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Children { get; }
Visual Basic
Public ReadOnly Property Children As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the children.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AccessControlGroupConfiguration
ININ.IceLib.Configuration..::..AccessControlGroupConfigurationList


ClientConfigurationTemplates Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..ClientConfigurationTemplates Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the client configuration templates for this access control group (use Property.ClientConfigurationTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> ClientConfigurationTemplates { get; }
Visual Basic
Public ReadOnly Property ClientConfigurationTemplates As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the client configuration templates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfiguration
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfigurationList


ImageResources Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..ImageResources Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the image resources for this access control group (use Property.ImageResources).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> ImageResources { get; }
Visual Basic
Public ReadOnly Property ImageResources As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the image resources.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ImageResourceConfiguration
ININ.IceLib.Configuration..::..ImageResourceConfigurationList


InteractionProcessorTables Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..InteractionProcessorTables Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the InteractionProcessorTables for this access control group (use Property.InteractionProcessorTables).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> InteractionProcessorTables { get; }
Visual Basic
Public ReadOnly Property InteractionProcessorTables As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the tables.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..InteractionProcessorTableConfiguration
ININ.IceLib.Configuration..::..InteractionProcessorTableConfigurationList


IpPhoneProxyGroups Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..IpPhoneProxyGroups Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the IP Phone Proxy Groups for this access control group (use Property.IpPhoneProxyGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> IpPhoneProxyGroups { get; }
Visual Basic
Public ReadOnly Property IpPhoneProxyGroups As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the IP Phone Proxy Groups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


IpPhoneRingSets Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..IpPhoneRingSets Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the IP Phone Ring Sets for this access control group (use Property.IpPhones).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> IpPhoneRingSets { get; }
Visual Basic
Public ReadOnly Property IpPhoneRingSets As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the IP Phone Ring Sets.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


IpPhones Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..IpPhones Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the IP Phones for this access control group (use Property.IpPhones).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> IpPhones { get; }
Visual Basic
Public ReadOnly Property IpPhones As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the IP Phones.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


IpPhoneTemplates Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..IpPhoneTemplates Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the IP Phone Templates for this access control group (use Property.IpPhoneTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> IpPhoneTemplates { get; }
Visual Basic
Public ReadOnly Property IpPhoneTemplates As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the IP Phone Templates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..LocationConfiguration
ININ.IceLib.Configuration..::..LocationConfigurationList


KeywordSets Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..KeywordSets Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the KeywordSets for this access control group (use Property.KeywordSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> KeywordSets { get; }
Visual Basic
Public ReadOnly Property KeywordSets As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the KeywordSets.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfiguration
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfigurationList


Layouts Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Layouts Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the layouts for this access control group (use Property.Layouts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Layouts { get; }
Visual Basic
Public ReadOnly Property Layouts As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the layouts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..LayoutConfiguration
ININ.IceLib.Configuration..::..LayoutConfigurationList


Locations Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Locations Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the locations for this access control group (use Property.Locations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Locations { get; }
Visual Basic
Public ReadOnly Property Locations As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the locations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..LocationConfiguration
ININ.IceLib.Configuration..::..LocationConfigurationList


Parent Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Parent Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the Parent for this access control group (use Property.Parent).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, ConfigurationId> Parent { get; }
Visual Basic
Public ReadOnly Property Parent As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the Parent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


PasswordPolicies Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..PasswordPolicies Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the password policies for this access control group (use Property.PasswordPolicies).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> PasswordPolicies { get; }
Visual Basic
Public ReadOnly Property PasswordPolicies As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the password policies.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..PasswordPolicyConfiguration
ININ.IceLib.Configuration..::..PasswordPolicyConfigurationList


PropertiesChanged Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..PropertiesChanged Property
AccessControlGroupConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AccessControlGroupConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of AccessControlGroupConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


Roles Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Roles Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the roles for this access control group (use Property.Roles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Roles { get; }
Visual Basic
Public ReadOnly Property Roles As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the roles.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..RoleConfiguration
ININ.IceLib.Configuration..::..RoleConfigurationList


Schedules Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Schedules Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the schedules for this access control group (use Property.Schedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Schedules { get; }
Visual Basic
Public ReadOnly Property Schedules As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the schedules.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ScheduleConfiguration
ININ.IceLib.Configuration..::..ScheduleConfigurationList


Skills Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Skills Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the skills for this access control group (use Property.Skills).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Skills { get; }
Visual Basic
Public ReadOnly Property Skills As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the skills.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..SkillConfiguration
ININ.IceLib.Configuration..::..SkillConfigurationList


StandardProperties Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..StandardProperties Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace


StationGroups Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..StationGroups Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the station groups for this access control group (use Property.StationGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> StationGroups { get; }
Visual Basic
Public ReadOnly Property StationGroups As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the station groups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..StationGroupConfiguration
ININ.IceLib.Configuration..::..StationGroupConfigurationList


Stations Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Stations Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the stations for this access control group (use Property.Stations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Stations { get; }
Visual Basic
Public ReadOnly Property Stations As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the stations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..StationConfiguration
ININ.IceLib.Configuration..::..StationConfigurationList


StationTemplates Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..StationTemplates Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the station templates for this access control group (use Property.StationTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> StationTemplates { get; }
Visual Basic
Public ReadOnly Property StationTemplates As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the station templates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..StationTemplateConfiguration
ININ.IceLib.Configuration..::..StationTemplateConfigurationList


Users Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Users Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the users for this access control group (use Property.Users).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Users { get; }
Visual Basic
Public ReadOnly Property Users As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the users.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..UserConfiguration
ININ.IceLib.Configuration..::..UserConfigurationList


Workgroups Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Workgroups Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the workgroups for this access control group (use Property.Workgroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WorkgroupConfiguration
ININ.IceLib.Configuration..::..WorkgroupConfigurationList


WrapUpCategories Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..WrapUpCategories Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap up categories for this access control group (use Property.WrapUpCategories).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> WrapUpCategories { get; }
Visual Basic
Public ReadOnly Property WrapUpCategories As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the wrap up categories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WrapUpCategoryConfiguration
ININ.IceLib.Configuration..::..WrapUpCategoryConfigurationList


WrapUpCodes Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..WrapUpCodes Property
AccessControlGroupConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap up codes for this access control group (use Property.WrapUpCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccessControlGroupConfiguration..::..Property, Collection<ConfigurationId>> WrapUpCodes { get; }
Visual Basic
Public ReadOnly Property WrapUpCodes As GeneralConfigurationProperty(Of AccessControlGroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the wrap up codes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfiguration Class
AccessControlGroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WrapUpCodeConfiguration
ININ.IceLib.Configuration..::..WrapUpCodeConfigurationList


AccessControlGroupConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Property Enumeration
AccessControlGroupConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Children | 0 | Represents the Children property.
AccountCodes | 1 | Represents the AccountCodes property.
ClientConfigurationTemplates | 2 | Represents the ClientConfigurationTemplates property.
ImageResources | 3 | Represents the ImageResources property.
IpPhones | 4 | Represents the IpPhones property.
IpPhoneProxyGroups | 5 | Represents the IpPhoneProxyGroups property.
IpPhoneRingSets | 6 | Represents the IpPhoneRingSets property.
IpPhoneTemplates | 7 | Represents the IpPhoneTemplates property.
KeywordSets | 8 | Represents the KeywordSets property.
Layouts | 9 | Represents the Layouts property.
Locations | 10 | Represents the Locations property.
PasswordPolicies | 11 | Represents the PasswordPolicies property.
Roles | 12 | Represents the Roles property.
Schedules | 13 | Represents the Schedules property.
Skills | 14 | Represents the Skills property.
Stations | 15 | Represents the Stations property.
StationGroups | 16 | Represents the StationGroups property.
StationTemplates | 17 | Represents the StationTemplates property.
InteractionProcessorTables | 18 | Represents the InteractionProcessorTables property.
Users | 19 | Represents the Users property.
Workgroups | 20 | Represents the Workgroups property.
WrapUpCodes | 21 | Represents the WrapUpCodes property.
WrapUpCategories | 22 | Represents the WrapUpCategories property.
Parent | 23 | Represents the Parent property.
DisplayName | 24 | Represents the DisplayName part of the ConfigurationId property.
Id | 25 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration Namespace


AccessControlGroupConfiguration.Rights Class

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Rights Class
AccessControlGroupConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AccessControlGroupConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AccessControlGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccessControlGroupConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Rights Members
AccessControlGroupConfiguration..::..Rights Class Properties See Also Send Feedback

The AccessControlGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccessControlGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AccessControlGroupConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Rights Properties
AccessControlGroupConfiguration..::..Rights Class See Also Send Feedback

The AccessControlGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccessControlGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Rights..::..Admin Property
AccessControlGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccessControlGroupConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AccessControlGroupConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AccessControlGroupConfiguration..::..Rights Class
AccessControlGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
AccessControlGroupConfiguration..::..Rights..::..View Property
AccessControlGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccessControlGroupConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AccessControlGroupConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AccessControlGroupConfiguration..::..Rights Class
AccessControlGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccessControlGroupConfigurationList Class

[image]

IceLib Technical Reference
AccessControlGroupConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing access control group configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccessControlGroupConfigurationList : EditableConfigurationList<AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property>
Visual Basic
Public Class AccessControlGroupConfigurationList _
    Inherits EditableConfigurationList(Of AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' AccessControlGroupConfiguration, AccessControlGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccessControlGroupConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


AccessControlGroupConfigurationList Members

[image] [image]

IceLib Technical Reference
AccessControlGroupConfigurationList Members
AccessControlGroupConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AccessControlGroupConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AccessControlGroupConfigurationList | Initializes a new instance of the AccessControlGroupConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccessControlGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


AccessControlGroupConfigurationList Constructor

[image]

IceLib Technical Reference
AccessControlGroupConfigurationList Constructor
AccessControlGroupConfigurationList Class See Also Send Feedback
Initializes a new instance of the AccessControlGroupConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AccessControlGroupConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroupConfigurationList Class
AccessControlGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


AccessControlGroupConfigurationList Methods

[image] [image]

IceLib Technical Reference
AccessControlGroupConfigurationList Methods
AccessControlGroupConfigurationList Class See Also Send Feedback

The AccessControlGroupConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccessControlGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


AccessControlGroupConfigurationList Properties

[image] [image]

IceLib Technical Reference
AccessControlGroupConfigurationList Properties
AccessControlGroupConfigurationList Class See Also Send Feedback

The AccessControlGroupConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccessControlGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


AccessControlGroupConfigurationList Events

[image] [image]

IceLib Technical Reference
AccessControlGroupConfigurationList Events
AccessControlGroupConfigurationList Class See Also Send Feedback

The AccessControlGroupConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccessControlGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration Class

[image]

IceLib Technical Reference
AccountCodeConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Account Code. An account code is a set of identifying numbers assigned to an account name. Account codes are used to track incoming and outgoing calls that can be tracked and reported in standard reports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccountCodeConfiguration : EditableListConfigurationObject<AccountCodeConfiguration..::..Property>
Visual Basic
Public Class AccountCodeConfiguration _
    Inherits EditableListConfigurationObject(Of AccountCodeConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' AccountCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccountCodeConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfiguration Members
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration Members

[image] [image]

IceLib Technical Reference
AccountCodeConfiguration Members
AccountCodeConfiguration Class Methods Properties See Also Send Feedback

The AccountCodeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this account code (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing this Account Code's description (use Property.Description).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AccountCodeConfiguration Class
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration Methods

[image] [image]

IceLib Technical Reference
AccountCodeConfiguration Methods
AccountCodeConfiguration Class See Also Send Feedback

The AccountCodeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AccountCodeConfiguration Class
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration Properties

[image] [image]

IceLib Technical Reference
AccountCodeConfiguration Properties
AccountCodeConfiguration Class See Also Send Feedback

The AccountCodeConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this account code (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing this Account Code's description (use Property.Description).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AccountCodeConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..AccessControlGroupAssignment Property
AccountCodeConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this account code (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccountCodeConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of AccountCodeConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodeConfiguration Class
AccountCodeConfiguration Members
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..Description Property
AccountCodeConfiguration Class See Also Send Feedback
Provides access to the property representing this Account Code's description (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccountCodeConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of AccountCodeConfiguration..::..Property, String)
    Get

Field Value

The property representing this Account Code's description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodeConfiguration Class
AccountCodeConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..PropertiesChanged Property
AccountCodeConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AccountCodeConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of AccountCodeConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfiguration Class
AccountCodeConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..StandardProperties Property
AccountCodeConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<AccountCodeConfiguration, AccountCodeConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of AccountCodeConfiguration, AccountCodeConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfiguration Class
AccountCodeConfiguration Members
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..Property Enumeration
AccountCodeConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
Description | 1 | Represents the Description property.
DisplayName | 2 | Represents the DisplayName part of the ConfigurationId property.
Id | 3 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AccountCodeConfiguration.Rights Class

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..Rights Class
AccountCodeConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AccountCodeConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AccountCodeConfiguration..::..Rights Members
AccountCodeConfiguration..::..Rights Class Properties See Also Send Feedback

The AccountCodeConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccountCodeConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AccountCodeConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AccountCodeConfiguration..::..Rights Properties
AccountCodeConfiguration..::..Rights Class See Also Send Feedback

The AccountCodeConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccountCodeConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..Rights..::..Admin Property
AccountCodeConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccountCodeConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AccountCodeConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfiguration..::..Rights Class
AccountCodeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccountCodeList


View Property

[image]

IceLib Technical Reference
AccountCodeConfiguration..::..Rights..::..View Property
AccountCodeConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccountCodeConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AccountCodeConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfiguration..::..Rights Class
AccountCodeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListAccountCodes


AccountCodeConfigurationList Class

[image]

IceLib Technical Reference
AccountCodeConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AccountCode configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccountCodeConfigurationList : EditableConfigurationList<AccountCodeConfiguration, AccountCodeConfiguration..::..Property>
Visual Basic
Public Class AccountCodeConfigurationList _
    Inherits EditableConfigurationList(Of AccountCodeConfiguration, AccountCodeConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AccountCodeConfiguration, AccountCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AccountCodeConfiguration, AccountCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' AccountCodeConfiguration, AccountCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccountCodeConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfigurationList Members
ININ.IceLib.Configuration Namespace


AccountCodeConfigurationList Members

[image] [image]

IceLib Technical Reference
AccountCodeConfigurationList Members
AccountCodeConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AccountCodeConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AccountCodeConfigurationList | Initializes a new instance of the AccountCodeConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccountCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


AccountCodeConfigurationList Constructor

[image]

IceLib Technical Reference
AccountCodeConfigurationList Constructor
AccountCodeConfigurationList Class See Also Send Feedback
Initializes a new instance of the AccountCodeConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AccountCodeConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccountCodeConfigurationList Class
AccountCodeConfigurationList Members
ININ.IceLib.Configuration Namespace


AccountCodeConfigurationList Methods

[image] [image]

IceLib Technical Reference
AccountCodeConfigurationList Methods
AccountCodeConfigurationList Class See Also Send Feedback

The AccountCodeConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


AccountCodeConfigurationList Properties

[image] [image]

IceLib Technical Reference
AccountCodeConfigurationList Properties
AccountCodeConfigurationList Class See Also Send Feedback

The AccountCodeConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccountCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


AccountCodeConfigurationList Events

[image] [image]

IceLib Technical Reference
AccountCodeConfigurationList Events
AccountCodeConfigurationList Class See Also Send Feedback

The AccountCodeConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccountCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration Class

[image]

IceLib Technical Reference
AccountCodesConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for IC Account Codes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccountCodesConfiguration : EditableContainerConfigurationObject<AccountCodesConfiguration..::..Property>
Visual Basic
Public Class AccountCodesConfiguration _
    Inherits EditableContainerConfigurationObject(Of AccountCodesConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' AccountCodesConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccountCodesConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration Members
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration Members

[image] [image]

IceLib Technical Reference
AccountCodesConfiguration Members
AccountCodesConfiguration Class Methods Properties See Also Send Feedback

The AccountCodesConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccountCodesEnabled | Provides access to the property that enables or disables the Account Codes. (use Property.AccountCodesEnabled).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AccountCodesConfiguration Class
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration Methods

[image] [image]

IceLib Technical Reference
AccountCodesConfiguration Methods
AccountCodesConfiguration Class See Also Send Feedback

The AccountCodesConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AccountCodesConfiguration Class
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration Properties

[image] [image]

IceLib Technical Reference
AccountCodesConfiguration Properties
AccountCodesConfiguration Class See Also Send Feedback

The AccountCodesConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodesEnabled | Provides access to the property that enables or disables the Account Codes. (use Property.AccountCodesEnabled).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AccountCodesConfiguration Class
ININ.IceLib.Configuration Namespace


AccountCodesEnabled Property

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..AccountCodesEnabled Property
AccountCodesConfiguration Class See Also Send Feedback
Provides access to the property that enables or disables the Account Codes. (use Property.AccountCodesEnabled).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AccountCodesConfiguration..::..Property, bool> AccountCodesEnabled { get; }
Visual Basic
Public ReadOnly Property AccountCodesEnabled As GeneralConfigurationProperty(Of AccountCodesConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing if Account Code's are disabled or enabled.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration Class
AccountCodesConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..PropertiesChanged Property
AccountCodesConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AccountCodesConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of AccountCodesConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration Class
AccountCodesConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..StandardProperties Property
AccountCodesConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<AccountCodesConfiguration, AccountCodesConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of AccountCodesConfiguration, AccountCodesConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration Class
AccountCodesConfiguration Members
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..Property Enumeration
AccountCodesConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccountCodesEnabled | 0 | Represents the AccountCodesEnabled property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration Namespace


AccountCodesConfiguration.Rights Class

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..Rights Class
AccountCodesConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AccountCodesConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AccountCodesConfiguration..::..Rights Members
AccountCodesConfiguration..::..Rights Class Properties See Also Send Feedback

The AccountCodesConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccountCodesConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AccountCodesConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AccountCodesConfiguration..::..Rights Properties
AccountCodesConfiguration..::..Rights Class See Also Send Feedback

The AccountCodesConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccountCodesConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..Rights..::..Admin Property
AccountCodesConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccountCodesConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AccountCodesConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration..::..Rights Class
AccountCodesConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
AccountCodesConfiguration..::..Rights..::..View Property
AccountCodesConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccountCodesConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AccountCodesConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfiguration..::..Rights Class
AccountCodesConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccountCodesConfigurationContainer Class

[image]

IceLib Technical Reference
AccountCodesConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the account codes configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccountCodesConfigurationContainer : ConfigurationContainer<AccountCodesConfiguration, AccountCodesConfiguration..::..Property>
Visual Basic
Public Class AccountCodesConfigurationContainer _
    Inherits ConfigurationContainer(Of AccountCodesConfiguration, AccountCodesConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' AccountCodesConfiguration, AccountCodesConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccountCodesConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfigurationContainer Members
ININ.IceLib.Configuration Namespace


AccountCodesConfigurationContainer Members

[image] [image]

IceLib Technical Reference
AccountCodesConfigurationContainer Members
AccountCodesConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The AccountCodesConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | AccountCodesConfigurationContainer | Initializes a new instance of the AccountCodesConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccountCodesConfigurationContainer Class
ININ.IceLib.Configuration Namespace


AccountCodesConfigurationContainer Constructor

[image]

IceLib Technical Reference
AccountCodesConfigurationContainer Constructor
AccountCodesConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the AccountCodesConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AccountCodesConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccountCodesConfigurationContainer Class
AccountCodesConfigurationContainer Members
ININ.IceLib.Configuration Namespace


AccountCodesConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
AccountCodesConfigurationContainer Methods
AccountCodesConfigurationContainer Class See Also Send Feedback

The AccountCodesConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountCodesConfigurationContainer Class
ININ.IceLib.Configuration Namespace


AccountCodesConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
AccountCodesConfigurationContainer Properties
AccountCodesConfigurationContainer Class See Also Send Feedback

The AccountCodesConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccountCodesConfigurationContainer Class
ININ.IceLib.Configuration Namespace


AccountCodesConfigurationContainer Events

[image] [image]

IceLib Technical Reference
AccountCodesConfigurationContainer Events
AccountCodesConfigurationContainer Class See Also Send Feedback

The AccountCodesConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccountCodesConfigurationContainer Class
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration Class

[image]

IceLib Technical Reference
AccumulatorConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Accumulator. Accumulators are like global variables that hold a value outside of a handler. Accumulator tools within handlers can assign, increment, and retrieve the values stored in these accumulators. Before a tool in a handler can set the value of an accumulator, the accumulator must be defined in Interaction Administrator.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccumulatorConfiguration : ListConfigurationObject
Visual Basic
Public Class AccumulatorConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AccumulatorConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfiguration Members
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration Members

[image] [image]

IceLib Technical Reference
AccumulatorConfiguration Members
AccumulatorConfiguration Class Methods Properties See Also Send Feedback

The AccumulatorConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AccumulatorConfiguration Class
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration Methods

[image] [image]

IceLib Technical Reference
AccumulatorConfiguration Methods
AccumulatorConfiguration Class See Also Send Feedback

The AccumulatorConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AccumulatorConfiguration Class
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration Properties

[image] [image]

IceLib Technical Reference
AccumulatorConfiguration Properties
AccumulatorConfiguration Class See Also Send Feedback

The AccumulatorConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AccumulatorConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
AccumulatorConfiguration..::..StandardProperties Property
AccumulatorConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<AccumulatorConfiguration, AccumulatorConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of AccumulatorConfiguration, AccumulatorConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfiguration Class
AccumulatorConfiguration Members
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AccumulatorConfiguration..::..Property Enumeration
AccumulatorConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AccumulatorConfiguration.Rights Class

[image]

IceLib Technical Reference
AccumulatorConfiguration..::..Rights Class
AccumulatorConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AccumulatorConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AccumulatorConfiguration..::..Rights Members
AccumulatorConfiguration..::..Rights Class Properties See Also Send Feedback

The AccumulatorConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccumulatorConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AccumulatorConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AccumulatorConfiguration..::..Rights Properties
AccumulatorConfiguration..::..Rights Class See Also Send Feedback

The AccumulatorConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AccumulatorConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AccumulatorConfiguration..::..Rights..::..Admin Property
AccumulatorConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccumulatorConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AccumulatorConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfiguration..::..Rights Class
AccumulatorConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccumulatorList


View Property

[image]

IceLib Technical Reference
AccumulatorConfiguration..::..Rights..::..View Property
AccumulatorConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AccumulatorConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AccumulatorConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfiguration..::..Rights Class
AccumulatorConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AccumulatorConfigurationList Class

[image]

IceLib Technical Reference
AccumulatorConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Accumulator configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccumulatorConfigurationList : DynamicConfigurationList<AccumulatorConfiguration, AccumulatorConfiguration..::..Property>
Visual Basic
Public Class AccumulatorConfigurationList _
    Inherits DynamicConfigurationList(Of AccumulatorConfiguration, AccumulatorConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AccumulatorConfiguration, AccumulatorConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AccumulatorConfiguration, AccumulatorConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AccumulatorConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfigurationList Members
ININ.IceLib.Configuration Namespace


AccumulatorConfigurationList Members

[image] [image]

IceLib Technical Reference
AccumulatorConfigurationList Members
AccumulatorConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AccumulatorConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AccumulatorConfigurationList | Initializes a new instance of the AccumulatorConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccumulatorConfigurationList Class
ININ.IceLib.Configuration Namespace


AccumulatorConfigurationList Constructor

[image]

IceLib Technical Reference
AccumulatorConfigurationList Constructor
AccumulatorConfigurationList Class See Also Send Feedback
Initializes a new instance of the AccumulatorConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AccumulatorConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AccumulatorConfigurationList Class
AccumulatorConfigurationList Members
ININ.IceLib.Configuration Namespace


AccumulatorConfigurationList Methods

[image] [image]

IceLib Technical Reference
AccumulatorConfigurationList Methods
AccumulatorConfigurationList Class See Also Send Feedback

The AccumulatorConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccumulatorConfigurationList Class
ININ.IceLib.Configuration Namespace


AccumulatorConfigurationList Properties

[image] [image]

IceLib Technical Reference
AccumulatorConfigurationList Properties
AccumulatorConfigurationList Class See Also Send Feedback

The AccumulatorConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccumulatorConfigurationList Class
ININ.IceLib.Configuration Namespace


AccumulatorConfigurationList Events

[image] [image]

IceLib Technical Reference
AccumulatorConfigurationList Events
AccumulatorConfigurationList Class See Also Send Feedback

The AccumulatorConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AccumulatorConfigurationList Class
ININ.IceLib.Configuration Namespace


ActionConfiguration Class

[image]

IceLib Technical Reference
ActionConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC action.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ActionConfiguration : EditableListConfigurationObject<ActionConfiguration..::..Property>
Visual Basic
Public Class ActionConfiguration _
    Inherits EditableListConfigurationObject(Of ActionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ActionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ActionConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ActionConfiguration Members
ININ.IceLib.Configuration Namespace


ActionConfiguration Members

[image] [image]

IceLib Technical Reference
ActionConfiguration Members
ActionConfiguration Class Methods Properties See Also Send Feedback

The ActionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ActionType | Provides access to the property representing the type for this action (use Property.ActionType).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ActionConfiguration Class
ININ.IceLib.Configuration Namespace


ActionConfiguration Methods

[image] [image]

IceLib Technical Reference
ActionConfiguration Methods
ActionConfiguration Class See Also Send Feedback

The ActionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ActionConfiguration Class
ININ.IceLib.Configuration Namespace


ActionConfiguration Properties

[image] [image]

IceLib Technical Reference
ActionConfiguration Properties
ActionConfiguration Class See Also Send Feedback

The ActionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | Provides access to the property representing the type for this action (use Property.ActionType).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ActionConfiguration Class
ININ.IceLib.Configuration Namespace


ActionType Property

[image]

IceLib Technical Reference
ActionConfiguration..::..ActionType Property
ActionConfiguration Class See Also Send Feedback
Provides access to the property representing the type for this action (use Property.ActionType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ActionConfiguration..::..Property, string> ActionType { get; }
Visual Basic
Public ReadOnly Property ActionType As GeneralConfigurationProperty(Of ActionConfiguration..::..Property, String)
    Get

Field Value

The property representing the action type.

Remarks

Used to categorize the action. Valid values can be obtained from the members of the ActionTypeValues class.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ActionConfiguration Class
ActionConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ActionConfiguration..::..PropertiesChanged Property
ActionConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ActionConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ActionConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionConfiguration Class
ActionConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ActionConfiguration..::..StandardProperties Property
ActionConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ActionConfiguration, ActionConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ActionConfiguration, ActionConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionConfiguration Class
ActionConfiguration Members
ININ.IceLib.Configuration Namespace


ActionConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ActionConfiguration..::..Property Enumeration
ActionConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
ActionType | 0 | Represents the ActionType property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ActionConfiguration.Rights Class

[image]

IceLib Technical Reference
ActionConfiguration..::..Rights Class
ActionConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ActionConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ActionConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ActionConfiguration..::..Rights Members
ActionConfiguration..::..Rights Class Properties See Also Send Feedback

The ActionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ActionConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ActionConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ActionConfiguration..::..Rights Properties
ActionConfiguration..::..Rights Class See Also Send Feedback

The ActionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ActionConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ActionConfiguration..::..Rights..::..Admin Property
ActionConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ActionConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ActionConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionConfiguration..::..Rights Class
ActionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Actions


View Property

[image]

IceLib Technical Reference
ActionConfiguration..::..Rights..::..View Property
ActionConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ActionConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ActionConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionConfiguration..::..Rights Class
ActionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ActionConfigurationList Class

[image]

IceLib Technical Reference
ActionConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing action configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ActionConfigurationList : EditableConfigurationList<ActionConfiguration, ActionConfiguration..::..Property>
Visual Basic
Public Class ActionConfigurationList _
    Inherits EditableConfigurationList(Of ActionConfiguration, ActionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ActionConfiguration, ActionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ActionConfiguration, ActionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ActionConfiguration, ActionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ActionConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ActionConfigurationList Members
ININ.IceLib.Configuration Namespace


ActionConfigurationList Members

[image] [image]

IceLib Technical Reference
ActionConfigurationList Members
ActionConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ActionConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ActionConfigurationList | Initializes a new instance of the ActionConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ActionConfigurationList Class
ININ.IceLib.Configuration Namespace


ActionConfigurationList Constructor

[image]

IceLib Technical Reference
ActionConfigurationList Constructor
ActionConfigurationList Class See Also Send Feedback
Initializes a new instance of the ActionConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ActionConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ActionConfigurationList Class
ActionConfigurationList Members
ININ.IceLib.Configuration Namespace


ActionConfigurationList Methods

[image] [image]

IceLib Technical Reference
ActionConfigurationList Methods
ActionConfigurationList Class See Also Send Feedback

The ActionConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ActionConfigurationList Class
ININ.IceLib.Configuration Namespace


ActionConfigurationList Properties

[image] [image]

IceLib Technical Reference
ActionConfigurationList Properties
ActionConfigurationList Class See Also Send Feedback

The ActionConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ActionConfigurationList Class
ININ.IceLib.Configuration Namespace


ActionConfigurationList Events

[image] [image]

IceLib Technical Reference
ActionConfigurationList Events
ActionConfigurationList Class See Also Send Feedback

The ActionConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ActionConfigurationList Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration Class

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an analyzer keyword.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerKeywordConfiguration : EditableListConfigurationObject<AnalyzerKeywordConfiguration..::..Property>
Visual Basic
Public Class AnalyzerKeywordConfiguration _
    Inherits EditableListConfigurationObject(Of AnalyzerKeywordConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' AnalyzerKeywordConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AnalyzerKeywordConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfigurationList
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfiguration


AnalyzerKeywordConfiguration Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordConfiguration Members
AnalyzerKeywordConfiguration Class Methods Properties See Also Send Feedback

The AnalyzerKeywordConfiguration type exposes the following members.

Methods

Name Description
Public method CancelEdit
Cancels an edit started by PrepareForEdit()()()().
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Commit
AnalyzerKeywordConfiguration do not directly support commit, use the parent AnalyzerKeywordSetConfiguration's Commit()()()() instead.
(Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method CommitAsync
Asynchronously commits the contents of this object to the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Delete
Deletes this object from the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method DeleteAsync
Asynchronously deletes this object from the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSupportedAnalyzerLanguages
Queries the server for a list of supported analyzer languages.

When setting the language with SetLanguage(String) on a new AnalyzerKeywordConfiguration object, this list will contain all of the available languages that can be used. SetLanguage(String) expects the value from the Name property.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValidators
Gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method GetValidatorsAsync
Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method PrepareForEdit
Prepares a list-based configuration object for edit.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method SetConfigurationId
Sets the unique identifier used to reference this configuration object.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method SetDisplayName
Sets the display name for this configuration object.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method SetLanguage
Sets the language for this keyword.

Valid values for language can be retrieved from the Name property in the values returned from GetSupportedAnalyzerLanguages(ConfigurationManager).

Public method ToString
Returns a String that represents the current Object.
(Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AgentScore | Provides access to the property representing the agent score for this keyword (use Property.AgentScore).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CustomerScore | Provides access to the property representing the customer score for this keyword (use Property.CustomerScore).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Language | Gets the language.
Public property | MinimumConfidenceThreshold | Provides access to the property representing the minimum confidence level for this keyword (use Property.MinimumConfidenceThreshold).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | UserAntiPronunciations | Provides access to the property representing the anti-words (Words not to be used as a match for this keyword) for this keyword (use Property.UserAntiPronunciations).
Public property | UserAntiWords | Provides access to the property representing the non-matching keyword value(s) (use Property.AltPhoneticSpelling).
Public property | UserPronunciations | Provides access to the property representing the alternate phonetic spellings for this keyword (use Property.AltPhoneticSpelling).
Public property | UserWords | Provides access to the property representing the keyword value(s) (use Property.UserWords).

See Also

AnalyzerKeywordConfiguration Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration Methods

[image] [image]

IceLib Technical Reference
AnalyzerKeywordConfiguration Methods
AnalyzerKeywordConfiguration Class See Also Send Feedback

The AnalyzerKeywordConfiguration type exposes the following members.

Methods

Name Description
Public method CancelEdit
Cancels an edit started by PrepareForEdit()()()().
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Commit
AnalyzerKeywordConfiguration do not directly support commit, use the parent AnalyzerKeywordSetConfiguration's Commit()()()() instead.
(Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method CommitAsync
Asynchronously commits the contents of this object to the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Delete
Deletes this object from the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method DeleteAsync
Asynchronously deletes this object from the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSupportedAnalyzerLanguages
Queries the server for a list of supported analyzer languages.

When setting the language with SetLanguage(String) on a new AnalyzerKeywordConfiguration object, this list will contain all of the available languages that can be used. SetLanguage(String) expects the value from the Name property.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValidators
Gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method GetValidatorsAsync
Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method PrepareForEdit
Prepares a list-based configuration object for edit.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method SetConfigurationId
Sets the unique identifier used to reference this configuration object.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method SetDisplayName
Sets the display name for this configuration object.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method SetLanguage
Sets the language for this keyword.

Valid values for language can be retrieved from the Name property in the values returned from GetSupportedAnalyzerLanguages(ConfigurationManager).

Public method ToString
Returns a String that represents the current Object.
(Inherited from ConfigurationObject.)

See Also

AnalyzerKeywordConfiguration Class
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Commit Method
AnalyzerKeywordConfiguration Class See Also Send Feedback
AnalyzerKeywordConfiguration do not directly support commit, use the parent AnalyzerKeywordSetConfiguration's Commit()()()() instead.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Exceptions

Exception | Condition
System..::..NotSupportedException | AnalyzerKeywordConfiguration do not directly support commit, use commit on the parent AnalyzerKeywordSetConfiguration instead.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


GetSupportedAnalyzerLanguages Method

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..GetSupportedAnalyzerLanguages Method
AnalyzerKeywordConfiguration Class See Also Send Feedback
Queries the server for a list of supported analyzer languages.

When setting the language with SetLanguage(String) on a new AnalyzerKeywordConfiguration object, this list will contain all of the available languages that can be used. SetLanguage(String) expects the value from the Name property.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<CultureInfo> GetSupportedAnalyzerLanguages(
    ConfigurationManager configurationManager
)
Visual Basic
Public Shared Function GetSupportedAnalyzerLanguages ( _
    configurationManager As ConfigurationManager _
) As ReadOnlyCollection(Of CultureInfo)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Return Value

A collection of CultureInfo of the supported languages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


SetLanguage Method

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..SetLanguage Method
AnalyzerKeywordConfiguration Class See Also Send Feedback
Sets the language for this keyword.

Valid values for language can be retrieved from the Name property in the values returned from GetSupportedAnalyzerLanguages(ConfigurationManager).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetLanguage(
    string language
)
Visual Basic
Public Sub SetLanguage ( _
    language As String _
)

Parameters

language
Type: System..::..String
The language.

Exceptions

Exception | Condition
System..::..NotSupportedException | AnalyzerKeywordConfiguration language can only be set on create.
System..::..ArgumentNullException | language is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | language is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordConfiguration Properties
AnalyzerKeywordConfiguration Class See Also Send Feedback

The AnalyzerKeywordConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AgentScore | Provides access to the property representing the agent score for this keyword (use Property.AgentScore).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CustomerScore | Provides access to the property representing the customer score for this keyword (use Property.CustomerScore).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Language | Gets the language.
Public property | MinimumConfidenceThreshold | Provides access to the property representing the minimum confidence level for this keyword (use Property.MinimumConfidenceThreshold).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | UserAntiPronunciations | Provides access to the property representing the anti-words (Words not to be used as a match for this keyword) for this keyword (use Property.UserAntiPronunciations).
Public property | UserAntiWords | Provides access to the property representing the non-matching keyword value(s) (use Property.AltPhoneticSpelling).
Public property | UserPronunciations | Provides access to the property representing the alternate phonetic spellings for this keyword (use Property.AltPhoneticSpelling).
Public property | UserWords | Provides access to the property representing the keyword value(s) (use Property.UserWords).

See Also

AnalyzerKeywordConfiguration Class
ININ.IceLib.Configuration Namespace


AgentScore Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..AgentScore Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the agent score for this keyword (use Property.AgentScore).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, int> AgentScore { get; }
Visual Basic
Public ReadOnly Property AgentScore As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the agent score for this keyword.

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


CustomerScore Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..CustomerScore Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the customer score for this keyword (use Property.CustomerScore).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, int> CustomerScore { get; }
Visual Basic
Public ReadOnly Property CustomerScore As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the customer score for this keyword.

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


Language Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Language Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Gets the language.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Language { get; }
Visual Basic
Public ReadOnly Property Language As String
    Get

Field Value

The language.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


MinimumConfidenceThreshold Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..MinimumConfidenceThreshold Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the minimum confidence level for this keyword (use Property.MinimumConfidenceThreshold).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, float> MinimumConfidenceThreshold { get; }
Visual Basic
Public ReadOnly Property MinimumConfidenceThreshold As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Single)
    Get

Field Value

The property representing the minimum confidence level for this keyword.

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..PropertiesChanged Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AnalyzerKeywordConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of AnalyzerKeywordConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


UserAntiPronunciations Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..UserAntiPronunciations Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the anti-words (Words not to be used as a match for this keyword) for this keyword (use Property.UserAntiPronunciations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, Collection<string>> UserAntiPronunciations { get; }
Visual Basic
Public ReadOnly Property UserAntiPronunciations As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the anti-words for this keyword.

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


UserAntiWords Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..UserAntiWords Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the non-matching keyword value(s) (use Property.AltPhoneticSpelling).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, Collection<string>> UserAntiWords { get; }
Visual Basic
Public ReadOnly Property UserAntiWords As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the non-matching keyword value(s).

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


UserPronunciations Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..UserPronunciations Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the alternate phonetic spellings for this keyword (use Property.AltPhoneticSpelling).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, Collection<string>> UserPronunciations { get; }
Visual Basic
Public ReadOnly Property UserPronunciations As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the alternate phonetic spellings for this keyword.

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


UserWords Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..UserWords Property
AnalyzerKeywordConfiguration Class See Also Send Feedback
Provides access to the property representing the keyword value(s) (use Property.UserWords).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordConfiguration..::..Property, Collection<string>> UserWords { get; }
Visual Basic
Public ReadOnly Property UserWords As GeneralConfigurationProperty(Of AnalyzerKeywordConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the keyword value(s).

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordConfiguration Class
AnalyzerKeywordConfiguration Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Property Enumeration
AnalyzerKeywordConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
UserWords | 0 | Represents the UserWords property.
UserAntiWords | 1 | Represents the UserAntiWords property.
UserPronunciations | 2 | Represents the UserPronunciations property.
UserAntiPronunciations | 3 | Represents the UserAntiPronunciations property.
MinimumConfidenceThreshold | 4 | Represents the MinimumConfidenceThreshold property.
CustomerScore | 5 | Represents the CustomerScore property.
AgentScore | 6 | Represents the AgentScore property.
DisplayName | 7 | Represents the DisplayName part of the ConfigurationId property.
Id | 8 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration.Rights Class

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Rights Class
AnalyzerKeywordConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AnalyzerKeywordConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AnalyzerKeywordConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Rights Members
AnalyzerKeywordConfiguration..::..Rights Class Properties See Also Send Feedback

The AnalyzerKeywordConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AnalyzerKeywordConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Rights Properties
AnalyzerKeywordConfiguration..::..Rights Class See Also Send Feedback

The AnalyzerKeywordConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AnalyzerKeywordConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Rights..::..Admin Property
AnalyzerKeywordConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AnalyzerKeywordConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AnalyzerKeywordConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AnalyzerKeywordConfiguration..::..Rights Class
AnalyzerKeywordConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
AnalyzerKeywordConfiguration..::..Rights..::..View Property
AnalyzerKeywordConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AnalyzerKeywordConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AnalyzerKeywordConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AnalyzerKeywordConfiguration..::..Rights Class
AnalyzerKeywordConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration Class

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an analyzer keyword set.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerKeywordSetConfiguration : EditableListConfigurationObject<AnalyzerKeywordSetConfiguration..::..Property>
Visual Basic
Public Class AnalyzerKeywordSetConfiguration _
    Inherits EditableListConfigurationObject(Of AnalyzerKeywordSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' AnalyzerKeywordSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfigurationList
ININ.IceLib.Configuration..::..AnalyzerKeywordConfiguration


AnalyzerKeywordSetConfiguration Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration Members
AnalyzerKeywordSetConfiguration Class Methods Properties See Also Send Feedback

The AnalyzerKeywordSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this interaction analyzer keyword set (use Property.AccessControlGroupAssignment).
Public property | Category | Provides access to the property representing the category for this keyword list (use Property.Category).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Keywords | Provides access to the property representing the keywords for this keyword list (use Property.Keywords).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AnalyzerKeywordSetConfiguration Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration Methods

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration Methods
AnalyzerKeywordSetConfiguration Class See Also Send Feedback

The AnalyzerKeywordSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AnalyzerKeywordSetConfiguration Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration Properties
AnalyzerKeywordSetConfiguration Class See Also Send Feedback

The AnalyzerKeywordSetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this interaction analyzer keyword set (use Property.AccessControlGroupAssignment).
Public property | Category | Provides access to the property representing the category for this keyword list (use Property.Category).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Keywords | Provides access to the property representing the keywords for this keyword list (use Property.Keywords).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AnalyzerKeywordSetConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..AccessControlGroupAssignment Property
AnalyzerKeywordSetConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this interaction analyzer keyword set (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordSetConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of AnalyzerKeywordSetConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AnalyzerKeywordSetConfiguration Class
AnalyzerKeywordSetConfiguration Members
ININ.IceLib.Configuration Namespace


Category Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Category Property
AnalyzerKeywordSetConfiguration Class See Also Send Feedback
Provides access to the property representing the category for this keyword list (use Property.Category).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordSetConfiguration..::..Property, string> Category { get; }
Visual Basic
Public ReadOnly Property Category As GeneralConfigurationProperty(Of AnalyzerKeywordSetConfiguration..::..Property, String)
    Get

Field Value

The property representing the category for this keyword list

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration Class
AnalyzerKeywordSetConfiguration Members
ININ.IceLib.Configuration Namespace


Keywords Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Keywords Property
AnalyzerKeywordSetConfiguration Class See Also Send Feedback
Provides access to the property representing the keywords for this keyword list (use Property.Keywords).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<AnalyzerKeywordSetConfiguration..::..Property, Collection<AnalyzerKeywordConfiguration>> Keywords { get; }
Visual Basic
Public ReadOnly Property Keywords As GeneralConfigurationProperty(Of AnalyzerKeywordSetConfiguration..::..Property, Collection(Of AnalyzerKeywordConfiguration))
    Get

Field Value

The property representing the keywords for this keyword list

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration Class
AnalyzerKeywordSetConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..PropertiesChanged Property
AnalyzerKeywordSetConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AnalyzerKeywordSetConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of AnalyzerKeywordSetConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration Class
AnalyzerKeywordSetConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..StandardProperties Property
AnalyzerKeywordSetConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration Class
AnalyzerKeywordSetConfiguration Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Property Enumeration
AnalyzerKeywordSetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
Category | 1 | Represents the Category property.
Keywords | 2 | Represents the Keywords property.
DisplayName | 3 | Represents the DisplayName part of the ConfigurationId property.
Id | 4 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration.Rights Class

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Rights Class
AnalyzerKeywordSetConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Rights Members
AnalyzerKeywordSetConfiguration..::..Rights Class Properties See Also Send Feedback

The AnalyzerKeywordSetConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AnalyzerKeywordSetConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Rights Properties
AnalyzerKeywordSetConfiguration..::..Rights Class See Also Send Feedback

The AnalyzerKeywordSetConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AnalyzerKeywordSetConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Rights..::..Admin Property
AnalyzerKeywordSetConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AnalyzerKeywordSetConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AnalyzerKeywordSetConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration..::..Rights Class
AnalyzerKeywordSetConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionAnalyzerKeywordSets


View Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfiguration..::..Rights..::..View Property
AnalyzerKeywordSetConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AnalyzerKeywordSetConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AnalyzerKeywordSetConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfiguration..::..Rights Class
AnalyzerKeywordSetConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfigurationList Class

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing analyzer keyword set configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerKeywordSetConfigurationList : EditableConfigurationList<AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property>
Visual Basic
Public Class AnalyzerKeywordSetConfigurationList _
    Inherits EditableConfigurationList(Of AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfiguration
ININ.IceLib.Configuration..::..AnalyzerKeywordConfiguration
ININ.IceLib.Configuration..::..AnalyzerQueryChildrenSettings
ININ.IceLib.Configuration..::..HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>


AnalyzerKeywordSetConfigurationList Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList Members
AnalyzerKeywordSetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AnalyzerKeywordSetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyzerKeywordSetConfigurationList | Initializes a new instance of the AnalyzerKeywordConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateAnalyzerKeyword | Creates a new analyzer keyword.
Public method | CreateKeywordQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeywordAccuracy | Runs the execute function for obtaining the accuracy value of a keyword
 | GetKeywordCountInformation | Runs the execute function for getting the Keyword Count information for a given collection of Keyword Sets.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AnalyzerKeywordSetConfigurationList Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfigurationList Constructor

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList Constructor
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback
Initializes a new instance of the AnalyzerKeywordConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AnalyzerKeywordSetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfigurationList Class
AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfigurationList Methods

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList Methods
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback

The AnalyzerKeywordSetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateAnalyzerKeyword | Creates a new analyzer keyword.
Public method | CreateKeywordQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeywordAccuracy | Runs the execute function for obtaining the accuracy value of a keyword
 | GetKeywordCountInformation | Runs the execute function for getting the Keyword Count information for a given collection of Keyword Sets.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyzerKeywordSetConfigurationList Class
ININ.IceLib.Configuration Namespace


CreateAnalyzerKeyword Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList..::..CreateAnalyzerKeyword Method
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback
Creates a new analyzer keyword.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AnalyzerKeywordConfiguration CreateAnalyzerKeyword()
Visual Basic
Public Function CreateAnalyzerKeyword As AnalyzerKeywordConfiguration

Return Value

A new AnalyzerKeywordConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfigurationList Class
AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace


CreateKeywordQuerySettings Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList..::..CreateKeywordQuerySettings Method
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<AnalyzerKeywordConfiguration, AnalyzerKeywordConfiguration..::..Property> CreateKeywordQuerySettings()
Visual Basic
Public Function CreateKeywordQuerySettings As QuerySettings(Of AnalyzerKeywordConfiguration, AnalyzerKeywordConfiguration..::..Property)

Return Value

A new QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AnalyzerKeywordSetConfigurationList Class
AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace


CreateQuerySettings Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList..::..CreateQuerySettings Method
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings<AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property, AnalyzerQueryChildrenSettings> CreateQuerySettings()
Visual Basic
Public Function CreateQuerySettings As HierarchicalQuerySettings(Of AnalyzerKeywordSetConfiguration, AnalyzerKeywordSetConfiguration..::..Property, AnalyzerQueryChildrenSettings)

Return Value

A new HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfigurationList Class
AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace


GetKeywordAccuracy Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList..::..GetKeywordAccuracy Method
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback
Runs the execute function for obtaining the accuracy value of a keyword

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public float GetKeywordAccuracy(
    string keywordId,
    Collection<string> words,
    Collection<string> pronunciations,
    Collection<string> antiWords,
    Collection<string> antiWordPronunciations,
    string language
)
Visual Basic
Public Function GetKeywordAccuracy ( _
    keywordId As String, _
    words As Collection(Of String), _
    pronunciations As Collection(Of String), _
    antiWords As Collection(Of String), _
    antiWordPronunciations As Collection(Of String), _
    language As String _
) As Single

Parameters

keywordId
Type: System..::..String
Keyword Tag value
words
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
collection of spellings for the keyword
pronunciations
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
collection of user defined pronunciations
antiWords
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
collection of anti word spellings
antiWordPronunciations
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
collection of user defined anti word pronunciations
language
Type: System..::..String
language of the keyword

Return Value

the accuracy value as an int

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerKeywordSetConfigurationList Class
AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace


GetKeywordCountInformation Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList..::..GetKeywordCountInformation Method
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback
Runs the execute function for getting the Keyword Count information for a given collection of Keyword Sets.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static KeywordCountInformation GetKeywordCountInformation(
    ConfigurationManager configurationManager,
    IEnumerable<AnalyzerKeywordSetChannelRelationship> keywordSets
)
Visual Basic
Public Shared Function GetKeywordCountInformation ( _
    configurationManager As ConfigurationManager, _
    keywordSets As IEnumerable(Of AnalyzerKeywordSetChannelRelationship) _
) As KeywordCountInformation

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
A Configuration Manager instance.
keywordSets
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AnalyzerKeywordSetChannelRelationship >)>)>
The collection of Keyword Sets and their channel type to get the Keyword Count information for.

Return Value

A KeywordCountInformation object with the Keyword Counts for the provided Keyword Sets and the Keyword Count Limit.

Remarks

A Keyword Count is calculated by counting the user defined words, anti-words, pronunciations, and anti-pronunciations of a Keyword Set per language. The purpose of these counts is to verify that the total Keyword Counts of a Recorder Policy's Keyword Set assignments does not exceed the Keyword Count limit. This function returns the total Keyword Counts for a given collection of Keyword Sets and the Keyword Count limit. If the collection of Keyword Sets provided to this function is empty, the returned KeywordCountInformation will have an empty TotalKeywordCountsPerLanguage dictionary, but the Keyword Count Limit will still be provided.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The configurationManager parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AnalyzerKeywordSetConfigurationList Class
AnalyzerKeywordSetConfigurationList Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfigurationList Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList Properties
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback

The AnalyzerKeywordSetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AnalyzerKeywordSetConfigurationList Class
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSetConfigurationList Events

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetConfigurationList Events
AnalyzerKeywordSetConfigurationList Class See Also Send Feedback

The AnalyzerKeywordSetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AnalyzerKeywordSetConfigurationList Class
ININ.IceLib.Configuration Namespace


AnalyzerQueryChildrenSettings Class

[image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings Class
Members See Also Send Feedback
Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerQueryChildrenSettings : QueryChildrenSettings<AnalyzerKeywordSetConfiguration..::..Property>
Visual Basic
Public Class AnalyzerQueryChildrenSettings _
    Inherits QueryChildrenSettings(Of AnalyzerKeywordSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QueryChildrenSettings <(Of <(<' AnalyzerKeywordSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AnalyzerQueryChildrenSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfigurationList
ININ.IceLib.Configuration..::..AnalyzerKeywordConfiguration
ININ.IceLib.Configuration..::..QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>


AnalyzerQueryChildrenSettings Members

[image] [image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings Members
AnalyzerQueryChildrenSettings Class Constructors Methods Properties See Also Send Feedback

The AnalyzerQueryChildrenSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyzerQueryChildrenSettings | Initializes a new instance of the AnalyzerQueryChildrenSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Keyword | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.
Public property | Language | Obsolete. Gets or sets the language to filter keywords on. Use "*" to retrieve all languages.

See Also

AnalyzerQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


AnalyzerQueryChildrenSettings Constructor

[image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings Constructor
AnalyzerQueryChildrenSettings Class See Also Send Feedback
Initializes a new instance of the AnalyzerQueryChildrenSettings class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AnalyzerQueryChildrenSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerQueryChildrenSettings Class
AnalyzerQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


AnalyzerQueryChildrenSettings Methods

[image] [image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings Methods
AnalyzerQueryChildrenSettings Class See Also Send Feedback

The AnalyzerQueryChildrenSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyzerQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


AnalyzerQueryChildrenSettings Properties

[image] [image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings Properties
AnalyzerQueryChildrenSettings Class See Also Send Feedback

The AnalyzerQueryChildrenSettings type exposes the following members.

Properties

 | Name | Description
Public property | Keyword | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.
Public property | Language | Obsolete. Gets or sets the language to filter keywords on. Use "*" to retrieve all languages.

See Also

AnalyzerQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


Keyword Property

[image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings..::..Keyword Property
AnalyzerQueryChildrenSettings Class See Also Send Feedback
Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<AnalyzerKeywordConfiguration, AnalyzerKeywordConfiguration..::..Property> Keyword { get; set; }
Visual Basic
Public Property Keyword As QuerySettings(Of AnalyzerKeywordConfiguration, AnalyzerKeywordConfiguration..::..Property)
    Get
    Set

Field Value

The custom data sub query settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerQueryChildrenSettings Class
AnalyzerQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


Language Property

[image]

IceLib Technical Reference
AnalyzerQueryChildrenSettings..::..Language Property
AnalyzerQueryChildrenSettings Class See Also Send Feedback
Gets or sets the language to filter keywords on. Use "*" to retrieve all languages.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Language is no longer supported here, use Keyword.SetLanguageToRetrieve(), Keyword.SetLanguageToRetrieveToAll() or Keyword.SetLanguageToRetrieveToDefault() instead.")]
public string Language { get; set; }
Visual Basic
<ObsoleteAttribute("Language is no longer supported here, use Keyword.SetLanguageToRetrieve(), Keyword.SetLanguageToRetrieveToAll() or Keyword.SetLanguageToRetrieveToDefault() instead.")> _
Public Property Language As String
    Get
    Set

Field Value

The language.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerQueryChildrenSettings Class
AnalyzerQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration Class

[image]

IceLib Technical Reference
AttendantConfigurationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC AttendantConfiguration.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AttendantConfigurationConfiguration is no longer used.")]
public class AttendantConfigurationConfiguration : ListConfigurationObject
Visual Basic
<ObsoleteAttribute("AttendantConfigurationConfiguration is no longer used.")> _
Public Class AttendantConfigurationConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AttendantConfigurationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantConfigurationConfiguration Members
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration Members

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfiguration Members
AttendantConfigurationConfiguration Class Methods Properties See Also Send Feedback

The AttendantConfigurationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantConfigurationConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration Methods

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfiguration Methods
AttendantConfigurationConfiguration Class See Also Send Feedback

The AttendantConfigurationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AttendantConfigurationConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration Properties

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfiguration Properties
AttendantConfigurationConfiguration Class See Also Send Feedback

The AttendantConfigurationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantConfigurationConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AttendantConfigurationConfiguration..::..Property Enumeration
AttendantConfigurationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration.Rights Class

[image]

IceLib Technical Reference
AttendantConfigurationConfiguration..::..Rights Class
AttendantConfigurationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AttendantConfigurationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AttendantConfigurationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfiguration..::..Rights Members
AttendantConfigurationConfiguration..::..Rights Class Properties See Also Send Feedback

The AttendantConfigurationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AttendantConfigurationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfiguration..::..Rights Properties
AttendantConfigurationConfiguration..::..Rights Class See Also Send Feedback

The AttendantConfigurationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AttendantConfigurationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AttendantConfigurationConfiguration..::..Rights..::..Admin Property
AttendantConfigurationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantConfigurationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AttendantConfigurationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AttendantConfigurationConfiguration..::..Rights Class
AttendantConfigurationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
AttendantConfigurationConfiguration..::..Rights..::..View Property
AttendantConfigurationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantConfigurationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AttendantConfigurationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AttendantConfigurationConfiguration..::..Rights Class
AttendantConfigurationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfigurationList Class

[image]

IceLib Technical Reference
AttendantConfigurationConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AttendantConfiguration configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AttendantConfigurationConfigurationList is no longer used.")]
public class AttendantConfigurationConfigurationList : DynamicConfigurationList<AttendantConfigurationConfiguration, AttendantConfigurationConfiguration..::..Property>
Visual Basic
<ObsoleteAttribute("AttendantConfigurationConfigurationList is no longer used.")> _
Public Class AttendantConfigurationConfigurationList _
    Inherits DynamicConfigurationList(Of AttendantConfigurationConfiguration, AttendantConfigurationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AttendantConfigurationConfiguration, AttendantConfigurationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AttendantConfigurationConfiguration, AttendantConfigurationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AttendantConfigurationConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantConfigurationConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfigurationList Members

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfigurationList Members
AttendantConfigurationConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AttendantConfigurationConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AttendantConfigurationConfigurationList | Initializes a new instance of the AttendantConfigurationConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantConfigurationConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfigurationList Constructor

[image]

IceLib Technical Reference
AttendantConfigurationConfigurationList Constructor
AttendantConfigurationConfigurationList Class See Also Send Feedback
Initializes a new instance of the AttendantConfigurationConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttendantConfigurationConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantConfigurationConfigurationList Class
AttendantConfigurationConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfigurationList Methods

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfigurationList Methods
AttendantConfigurationConfigurationList Class See Also Send Feedback

The AttendantConfigurationConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttendantConfigurationConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfigurationList Properties

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfigurationList Properties
AttendantConfigurationConfigurationList Class See Also Send Feedback

The AttendantConfigurationConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantConfigurationConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantConfigurationConfigurationList Events

[image] [image]

IceLib Technical Reference
AttendantConfigurationConfigurationList Events
AttendantConfigurationConfigurationList Class See Also Send Feedback

The AttendantConfigurationConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantConfigurationConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration Class

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC AttendantEmailProfile.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantEmailProfileConfiguration : ListConfigurationObject
Visual Basic
Public Class AttendantEmailProfileConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AttendantEmailProfileConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfiguration Members
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration Members

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfiguration Members
AttendantEmailProfileConfiguration Class Methods Properties See Also Send Feedback

The AttendantEmailProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantEmailProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration Methods

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfiguration Methods
AttendantEmailProfileConfiguration Class See Also Send Feedback

The AttendantEmailProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AttendantEmailProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration Properties

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfiguration Properties
AttendantEmailProfileConfiguration Class See Also Send Feedback

The AttendantEmailProfileConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantEmailProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Property Enumeration
AttendantEmailProfileConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration.Rights Class

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights Class
AttendantEmailProfileConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AttendantEmailProfileConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights Members
AttendantEmailProfileConfiguration..::..Rights Class Properties See Also Send Feedback

The AttendantEmailProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantEmailProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights Properties
AttendantEmailProfileConfiguration..::..Rights Class See Also Send Feedback

The AttendantEmailProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantEmailProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights..::..Admin Property
AttendantEmailProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantEmailProfileConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AttendantEmailProfileConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfiguration..::..Rights Class
AttendantEmailProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


Modify Property

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights..::..Modify Property
AttendantEmailProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the modify rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantEmailProfileConfiguration> Modify { get; private set; }
Visual Basic
Public Shared Property Modify As RightsQueryFilter(Of AttendantEmailProfileConfiguration)
    Get
    Private Set

Field Value

The modify rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfiguration..::..Rights Class
AttendantEmailProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantEmailProfiles


View Property

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights..::..View Property
AttendantEmailProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantEmailProfileConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AttendantEmailProfileConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfiguration..::..Rights Class
AttendantEmailProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantEmailProfiles


ViewInSearch Property

[image]

IceLib Technical Reference
AttendantEmailProfileConfiguration..::..Rights..::..ViewInSearch Property
AttendantEmailProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantEmailProfileConfiguration> ViewInSearch { get; private set; }
Visual Basic
Public Shared Property ViewInSearch As RightsQueryFilter(Of AttendantEmailProfileConfiguration)
    Get
    Private Set

Field Value

The view in search right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfiguration..::..Rights Class
AttendantEmailProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantEmailProfileInSearch


AttendantEmailProfileConfigurationList Class

[image]

IceLib Technical Reference
AttendantEmailProfileConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AttendantEmailProfile configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantEmailProfileConfigurationList : DynamicConfigurationList<AttendantEmailProfileConfiguration, AttendantEmailProfileConfiguration..::..Property>
Visual Basic
Public Class AttendantEmailProfileConfigurationList _
    Inherits DynamicConfigurationList(Of AttendantEmailProfileConfiguration, AttendantEmailProfileConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AttendantEmailProfileConfiguration, AttendantEmailProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AttendantEmailProfileConfiguration, AttendantEmailProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AttendantEmailProfileConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfigurationList Members

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfigurationList Members
AttendantEmailProfileConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AttendantEmailProfileConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AttendantEmailProfileConfigurationList | Initializes a new instance of the AttendantEmailProfileConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantEmailProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfigurationList Constructor

[image]

IceLib Technical Reference
AttendantEmailProfileConfigurationList Constructor
AttendantEmailProfileConfigurationList Class See Also Send Feedback
Initializes a new instance of the AttendantEmailProfileConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttendantEmailProfileConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantEmailProfileConfigurationList Class
AttendantEmailProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfigurationList Methods

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfigurationList Methods
AttendantEmailProfileConfigurationList Class See Also Send Feedback

The AttendantEmailProfileConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttendantEmailProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfigurationList Properties

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfigurationList Properties
AttendantEmailProfileConfigurationList Class See Also Send Feedback

The AttendantEmailProfileConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantEmailProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantEmailProfileConfigurationList Events

[image] [image]

IceLib Technical Reference
AttendantEmailProfileConfigurationList Events
AttendantEmailProfileConfigurationList Class See Also Send Feedback

The AttendantEmailProfileConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantEmailProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration Class

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC AttendantInboundProfile.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantInboundProfileConfiguration : ListConfigurationObject
Visual Basic
Public Class AttendantInboundProfileConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AttendantInboundProfileConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfiguration Members
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration Members

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfiguration Members
AttendantInboundProfileConfiguration Class Methods Properties See Also Send Feedback

The AttendantInboundProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantInboundProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration Methods

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfiguration Methods
AttendantInboundProfileConfiguration Class See Also Send Feedback

The AttendantInboundProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AttendantInboundProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration Properties

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfiguration Properties
AttendantInboundProfileConfiguration Class See Also Send Feedback

The AttendantInboundProfileConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantInboundProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Property Enumeration
AttendantInboundProfileConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration.Rights Class

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights Class
AttendantInboundProfileConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AttendantInboundProfileConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights Members
AttendantInboundProfileConfiguration..::..Rights Class Properties See Also Send Feedback

The AttendantInboundProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantInboundProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights Properties
AttendantInboundProfileConfiguration..::..Rights Class See Also Send Feedback

The AttendantInboundProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantInboundProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights..::..Admin Property
AttendantInboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantInboundProfileConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AttendantInboundProfileConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfiguration..::..Rights Class
AttendantInboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


Modify Property

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights..::..Modify Property
AttendantInboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the modify rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantInboundProfileConfiguration> Modify { get; private set; }
Visual Basic
Public Shared Property Modify As RightsQueryFilter(Of AttendantInboundProfileConfiguration)
    Get
    Private Set

Field Value

The modify rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfiguration..::..Rights Class
AttendantInboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantInboundProfiles


View Property

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights..::..View Property
AttendantInboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantInboundProfileConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AttendantInboundProfileConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfiguration..::..Rights Class
AttendantInboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantInboundProfiles


ViewInSearch Property

[image]

IceLib Technical Reference
AttendantInboundProfileConfiguration..::..Rights..::..ViewInSearch Property
AttendantInboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantInboundProfileConfiguration> ViewInSearch { get; private set; }
Visual Basic
Public Shared Property ViewInSearch As RightsQueryFilter(Of AttendantInboundProfileConfiguration)
    Get
    Private Set

Field Value

The view in search right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfiguration..::..Rights Class
AttendantInboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantInboundProfileInSearch


AttendantInboundProfileConfigurationList Class

[image]

IceLib Technical Reference
AttendantInboundProfileConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AttendantInboundProfile configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantInboundProfileConfigurationList : DynamicConfigurationList<AttendantInboundProfileConfiguration, AttendantInboundProfileConfiguration..::..Property>
Visual Basic
Public Class AttendantInboundProfileConfigurationList _
    Inherits DynamicConfigurationList(Of AttendantInboundProfileConfiguration, AttendantInboundProfileConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AttendantInboundProfileConfiguration, AttendantInboundProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AttendantInboundProfileConfiguration, AttendantInboundProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AttendantInboundProfileConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfigurationList Members

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfigurationList Members
AttendantInboundProfileConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AttendantInboundProfileConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AttendantInboundProfileConfigurationList | Initializes a new instance of the AttendantInboundProfileConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantInboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfigurationList Constructor

[image]

IceLib Technical Reference
AttendantInboundProfileConfigurationList Constructor
AttendantInboundProfileConfigurationList Class See Also Send Feedback
Initializes a new instance of the AttendantInboundProfileConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttendantInboundProfileConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantInboundProfileConfigurationList Class
AttendantInboundProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfigurationList Methods

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfigurationList Methods
AttendantInboundProfileConfigurationList Class See Also Send Feedback

The AttendantInboundProfileConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttendantInboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfigurationList Properties

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfigurationList Properties
AttendantInboundProfileConfigurationList Class See Also Send Feedback

The AttendantInboundProfileConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantInboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantInboundProfileConfigurationList Events

[image] [image]

IceLib Technical Reference
AttendantInboundProfileConfigurationList Events
AttendantInboundProfileConfigurationList Class See Also Send Feedback

The AttendantInboundProfileConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantInboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration Class

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC AttendantOperatorProfile.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantOperatorProfileConfiguration : ListConfigurationObject
Visual Basic
Public Class AttendantOperatorProfileConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AttendantOperatorProfileConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration Members

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration Members
AttendantOperatorProfileConfiguration Class Methods Properties See Also Send Feedback

The AttendantOperatorProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantOperatorProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration Methods

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration Methods
AttendantOperatorProfileConfiguration Class See Also Send Feedback

The AttendantOperatorProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AttendantOperatorProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration Properties

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration Properties
AttendantOperatorProfileConfiguration Class See Also Send Feedback

The AttendantOperatorProfileConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantOperatorProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Property Enumeration
AttendantOperatorProfileConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration.Rights Class

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights Class
AttendantOperatorProfileConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AttendantOperatorProfileConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights Members
AttendantOperatorProfileConfiguration..::..Rights Class Properties See Also Send Feedback

The AttendantOperatorProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantOperatorProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights Properties
AttendantOperatorProfileConfiguration..::..Rights Class See Also Send Feedback

The AttendantOperatorProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantOperatorProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights..::..Admin Property
AttendantOperatorProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOperatorProfileConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AttendantOperatorProfileConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfiguration..::..Rights Class
AttendantOperatorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


Modify Property

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights..::..Modify Property
AttendantOperatorProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the modify rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOperatorProfileConfiguration> Modify { get; private set; }
Visual Basic
Public Shared Property Modify As RightsQueryFilter(Of AttendantOperatorProfileConfiguration)
    Get
    Private Set

Field Value

The modify rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfiguration..::..Rights Class
AttendantOperatorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantOperatorProfiles


View Property

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights..::..View Property
AttendantOperatorProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOperatorProfileConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AttendantOperatorProfileConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfiguration..::..Rights Class
AttendantOperatorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOperatorProfiles


ViewInSearch Property

[image]

IceLib Technical Reference
AttendantOperatorProfileConfiguration..::..Rights..::..ViewInSearch Property
AttendantOperatorProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOperatorProfileConfiguration> ViewInSearch { get; private set; }
Visual Basic
Public Shared Property ViewInSearch As RightsQueryFilter(Of AttendantOperatorProfileConfiguration)
    Get
    Private Set

Field Value

The view in search right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfiguration..::..Rights Class
AttendantOperatorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOperatorProfileInSearch


AttendantOperatorProfileConfigurationList Class

[image]

IceLib Technical Reference
AttendantOperatorProfileConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AttendantOperatorProfile configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantOperatorProfileConfigurationList : DynamicConfigurationList<AttendantOperatorProfileConfiguration, AttendantOperatorProfileConfiguration..::..Property>
Visual Basic
Public Class AttendantOperatorProfileConfigurationList _
    Inherits DynamicConfigurationList(Of AttendantOperatorProfileConfiguration, AttendantOperatorProfileConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AttendantOperatorProfileConfiguration, AttendantOperatorProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AttendantOperatorProfileConfiguration, AttendantOperatorProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AttendantOperatorProfileConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfigurationList Members

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfigurationList Members
AttendantOperatorProfileConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AttendantOperatorProfileConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AttendantOperatorProfileConfigurationList | Initializes a new instance of the AttendantOperatorProfileConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantOperatorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfigurationList Constructor

[image]

IceLib Technical Reference
AttendantOperatorProfileConfigurationList Constructor
AttendantOperatorProfileConfigurationList Class See Also Send Feedback
Initializes a new instance of the AttendantOperatorProfileConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttendantOperatorProfileConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOperatorProfileConfigurationList Class
AttendantOperatorProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfigurationList Methods

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfigurationList Methods
AttendantOperatorProfileConfigurationList Class See Also Send Feedback

The AttendantOperatorProfileConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttendantOperatorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfigurationList Properties

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfigurationList Properties
AttendantOperatorProfileConfigurationList Class See Also Send Feedback

The AttendantOperatorProfileConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantOperatorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOperatorProfileConfigurationList Events

[image] [image]

IceLib Technical Reference
AttendantOperatorProfileConfigurationList Events
AttendantOperatorProfileConfigurationList Class See Also Send Feedback

The AttendantOperatorProfileConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantOperatorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration Class

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC AttendantOutboundProfile.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantOutboundProfileConfiguration : ListConfigurationObject
Visual Basic
Public Class AttendantOutboundProfileConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AttendantOutboundProfileConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfiguration Members
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration Members

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration Members
AttendantOutboundProfileConfiguration Class Methods Properties See Also Send Feedback

The AttendantOutboundProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantOutboundProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration Methods

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration Methods
AttendantOutboundProfileConfiguration Class See Also Send Feedback

The AttendantOutboundProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AttendantOutboundProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration Properties

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration Properties
AttendantOutboundProfileConfiguration Class See Also Send Feedback

The AttendantOutboundProfileConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

AttendantOutboundProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Property Enumeration
AttendantOutboundProfileConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration.Rights Class

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights Class
AttendantOutboundProfileConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AttendantOutboundProfileConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights Members
AttendantOutboundProfileConfiguration..::..Rights Class Properties See Also Send Feedback

The AttendantOutboundProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantOutboundProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights Properties
AttendantOutboundProfileConfiguration..::..Rights Class See Also Send Feedback

The AttendantOutboundProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.
ViewInSearch | Gets the view in search rights filter.

See Also

AttendantOutboundProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights..::..Admin Property
AttendantOutboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOutboundProfileConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AttendantOutboundProfileConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfiguration..::..Rights Class
AttendantOutboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


Modify Property

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights..::..Modify Property
AttendantOutboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the modify rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOutboundProfileConfiguration> Modify { get; private set; }
Visual Basic
Public Shared Property Modify As RightsQueryFilter(Of AttendantOutboundProfileConfiguration)
    Get
    Private Set

Field Value

The modify rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfiguration..::..Rights Class
AttendantOutboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantOutboundProfiles


View Property

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights..::..View Property
AttendantOutboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOutboundProfileConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AttendantOutboundProfileConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfiguration..::..Rights Class
AttendantOutboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOutboundProfiles


ViewInSearch Property

[image]

IceLib Technical Reference
AttendantOutboundProfileConfiguration..::..Rights..::..ViewInSearch Property
AttendantOutboundProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AttendantOutboundProfileConfiguration> ViewInSearch { get; private set; }
Visual Basic
Public Shared Property ViewInSearch As RightsQueryFilter(Of AttendantOutboundProfileConfiguration)
    Get
    Private Set

Field Value

The view in search right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfiguration..::..Rights Class
AttendantOutboundProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOutboundProfileInSearch


AttendantOutboundProfileConfigurationList Class

[image]

IceLib Technical Reference
AttendantOutboundProfileConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AttendantOutboundProfile configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantOutboundProfileConfigurationList : DynamicConfigurationList<AttendantOutboundProfileConfiguration, AttendantOutboundProfileConfiguration..::..Property>
Visual Basic
Public Class AttendantOutboundProfileConfigurationList _
    Inherits DynamicConfigurationList(Of AttendantOutboundProfileConfiguration, AttendantOutboundProfileConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AttendantOutboundProfileConfiguration, AttendantOutboundProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AttendantOutboundProfileConfiguration, AttendantOutboundProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AttendantOutboundProfileConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfigurationList Members

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfigurationList Members
AttendantOutboundProfileConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AttendantOutboundProfileConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AttendantOutboundProfileConfigurationList | Initializes a new instance of the AttendantOutboundProfileConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantOutboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfigurationList Constructor

[image]

IceLib Technical Reference
AttendantOutboundProfileConfigurationList Constructor
AttendantOutboundProfileConfigurationList Class See Also Send Feedback
Initializes a new instance of the AttendantOutboundProfileConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttendantOutboundProfileConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantOutboundProfileConfigurationList Class
AttendantOutboundProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfigurationList Methods

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfigurationList Methods
AttendantOutboundProfileConfigurationList Class See Also Send Feedback

The AttendantOutboundProfileConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttendantOutboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfigurationList Properties

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfigurationList Properties
AttendantOutboundProfileConfigurationList Class See Also Send Feedback

The AttendantOutboundProfileConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantOutboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AttendantOutboundProfileConfigurationList Events

[image] [image]

IceLib Technical Reference
AttendantOutboundProfileConfigurationList Events
AttendantOutboundProfileConfigurationList Class See Also Send Feedback

The AttendantOutboundProfileConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AttendantOutboundProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration Class

[image]

IceLib Technical Reference
AudioSourceConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Audio Source. An audio source is a feature that provides a "named" audio source that continuously transmit audio and can be listened to simultaneously by multiple calls. A common use of Audio Sources is for hold music, either for system-wide calls on-hold or in-queue waiting for an agent.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AudioSourceConfiguration : ListConfigurationObject
Visual Basic
Public Class AudioSourceConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AudioSourceConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfiguration Members
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration Members

[image] [image]

IceLib Technical Reference
AudioSourceConfiguration Members
AudioSourceConfiguration Class Methods Properties See Also Send Feedback

The AudioSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AudioSourceConfiguration Class
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration Methods

[image] [image]

IceLib Technical Reference
AudioSourceConfiguration Methods
AudioSourceConfiguration Class See Also Send Feedback

The AudioSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

AudioSourceConfiguration Class
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration Properties

[image] [image]

IceLib Technical Reference
AudioSourceConfiguration Properties
AudioSourceConfiguration Class See Also Send Feedback

The AudioSourceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

AudioSourceConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
AudioSourceConfiguration..::..StandardProperties Property
AudioSourceConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<AudioSourceConfiguration, AudioSourceConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of AudioSourceConfiguration, AudioSourceConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfiguration Class
AudioSourceConfiguration Members
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration.Property Enumeration

[image]

IceLib Technical Reference
AudioSourceConfiguration..::..Property Enumeration
AudioSourceConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


AudioSourceConfiguration.Rights Class

[image]

IceLib Technical Reference
AudioSourceConfiguration..::..Rights Class
AudioSourceConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..AudioSourceConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
AudioSourceConfiguration..::..Rights Members
AudioSourceConfiguration..::..Rights Class Properties See Also Send Feedback

The AudioSourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AudioSourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


AudioSourceConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
AudioSourceConfiguration..::..Rights Properties
AudioSourceConfiguration..::..Rights Class See Also Send Feedback

The AudioSourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

AudioSourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
AudioSourceConfiguration..::..Rights..::..Admin Property
AudioSourceConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AudioSourceConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of AudioSourceConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfiguration..::..Rights Class
AudioSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AudioSources


View Property

[image]

IceLib Technical Reference
AudioSourceConfiguration..::..Rights..::..View Property
AudioSourceConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<AudioSourceConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of AudioSourceConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfiguration..::..Rights Class
AudioSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


AudioSourceConfigurationList Class

[image]

IceLib Technical Reference
AudioSourceConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing AudioSource configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AudioSourceConfigurationList : DynamicConfigurationList<AudioSourceConfiguration, AudioSourceConfiguration..::..Property>
Visual Basic
Public Class AudioSourceConfigurationList _
    Inherits DynamicConfigurationList(Of AudioSourceConfiguration, AudioSourceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' AudioSourceConfiguration, AudioSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' AudioSourceConfiguration, AudioSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..AudioSourceConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfigurationList Members
ININ.IceLib.Configuration Namespace


AudioSourceConfigurationList Members

[image] [image]

IceLib Technical Reference
AudioSourceConfigurationList Members
AudioSourceConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The AudioSourceConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | AudioSourceConfigurationList | Initializes a new instance of the AudioSourceConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AudioSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


AudioSourceConfigurationList Constructor

[image]

IceLib Technical Reference
AudioSourceConfigurationList Constructor
AudioSourceConfigurationList Class See Also Send Feedback
Initializes a new instance of the AudioSourceConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AudioSourceConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AudioSourceConfigurationList Class
AudioSourceConfigurationList Members
ININ.IceLib.Configuration Namespace


AudioSourceConfigurationList Methods

[image] [image]

IceLib Technical Reference
AudioSourceConfigurationList Methods
AudioSourceConfigurationList Class See Also Send Feedback

The AudioSourceConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AudioSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


AudioSourceConfigurationList Properties

[image] [image]

IceLib Technical Reference
AudioSourceConfigurationList Properties
AudioSourceConfigurationList Class See Also Send Feedback

The AudioSourceConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AudioSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


AudioSourceConfigurationList Events

[image] [image]

IceLib Technical Reference
AudioSourceConfigurationList Events
AudioSourceConfigurationList Class See Also Send Feedback

The AudioSourceConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

AudioSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a basic filter for searching configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class BasicFilterDefinition<TFilteredObject, TPropertyEnum> : FilterDefinition<TFilteredObject, TPropertyEnum>
where TFilteredObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class BasicFilterDefinition(Of TFilteredObject As ConfigurationObject, TPropertyEnum As {Structure, New}) _
    Inherits FilterDefinition(Of TFilteredObject, TPropertyEnum)

Type Parameters

TFilteredObject
The type of the filtered object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FilterDefinition <(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, Object) | Initializes a new instance of the BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.
Public method | BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, Object, FilterMatchType) | Initializes a new instance of the BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilteredProperty | Gets the filtered property.
Public property | FilterMatchType | Gets the filter match type.
Public property | TargetPropertyValue | Gets the target property value.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Constructor

[image] [image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, Object) | Initializes a new instance of the BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.
Public method | BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, Object, FilterMatchType) | Initializes a new instance of the BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Constructor (TPropertyEnum, Object)

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor (TPropertyEnum, Object)
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public BasicFilterDefinition(
    TPropertyEnum filteredProperty,
    Object targetValue
)
Visual Basic
Public Sub New ( _
    filteredProperty As TPropertyEnum, _
    targetValue As Object _
)

Parameters

filteredProperty
Type: TPropertyEnum
The filtered property.
targetValue
Type: System..::..Object
The target value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Overload
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Constructor (TPropertyEnum, Object, FilterMatchType)

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor (TPropertyEnum, Object, FilterMatchType)
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public BasicFilterDefinition(
    TPropertyEnum filteredProperty,
    Object targetValue,
    FilterMatchType filterMatchType
)
Visual Basic
Public Sub New ( _
    filteredProperty As TPropertyEnum, _
    targetValue As Object, _
    filterMatchType As FilterMatchType _
)

Parameters

filteredProperty
Type: TPropertyEnum
The filtered property.
targetValue
Type: System..::..Object
The target value.
filterMatchType
Type: ININ.IceLib.Configuration..::..FilterMatchType
The filter match type.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified filterMatchType is not from the FilterMatchType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Overload
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Methods
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..ToString Method
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


BasicFilterDefinition(TFilteredObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Properties
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilteredProperty | Gets the filtered property.
Public property | FilterMatchType | Gets the filter match type.
Public property | TargetPropertyValue | Gets the target property value.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


FilteredProperty Property

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..FilteredProperty Property
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filtered property.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TPropertyEnum FilteredProperty { get; }
Visual Basic
Public ReadOnly Property FilteredProperty As TPropertyEnum
    Get

Field Value

The filtered property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FilterMatchType Property

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..FilterMatchType Property
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilterMatchType FilterMatchType { get; }
Visual Basic
Public ReadOnly Property FilterMatchType As FilterMatchType
    Get

Field Value

The filter match type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


TargetPropertyValue Property

[image]

IceLib Technical Reference
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..TargetPropertyValue Property
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the target property value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object TargetPropertyValue { get; }
Visual Basic
Public ReadOnly Property TargetPropertyValue As Object
    Get

Field Value

The target property value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


BeginTransactionCompletedEventArgs Class

[image]

IceLib Technical Reference
BeginTransactionCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed event of BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class BeginTransactionCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class BeginTransactionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration..::..BeginTransactionCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

BeginTransactionCompletedEventArgs Members
ININ.IceLib.Configuration Namespace


BeginTransactionCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
BeginTransactionCompletedEventArgs Members
BeginTransactionCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The BeginTransactionCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BeginTransactionCompletedEventArgs | Initializes a new instance of the BeginTransactionCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TransactionId | Gets the transaction ID.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

BeginTransactionCompletedEventArgs Class
ININ.IceLib.Configuration Namespace


BeginTransactionCompletedEventArgs Constructor

[image]

IceLib Technical Reference
BeginTransactionCompletedEventArgs Constructor
BeginTransactionCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the BeginTransactionCompletedEventArgs class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public BeginTransactionCompletedEventArgs(
    int transactionId,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    transactionId As Integer, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

BeginTransactionCompletedEventArgs Class
BeginTransactionCompletedEventArgs Members
ININ.IceLib.Configuration Namespace


BeginTransactionCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
BeginTransactionCompletedEventArgs Methods
BeginTransactionCompletedEventArgs Class See Also Send Feedback

The BeginTransactionCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeginTransactionCompletedEventArgs Class
ININ.IceLib.Configuration Namespace


BeginTransactionCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
BeginTransactionCompletedEventArgs Properties
BeginTransactionCompletedEventArgs Class See Also Send Feedback

The BeginTransactionCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TransactionId | Gets the transaction ID.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

BeginTransactionCompletedEventArgs Class
ININ.IceLib.Configuration Namespace


TransactionId Property

[image]

IceLib Technical Reference
BeginTransactionCompletedEventArgs..::..TransactionId Property
BeginTransactionCompletedEventArgs Class See Also Send Feedback
Gets the transaction ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TransactionId { get; }
Visual Basic
Public ReadOnly Property TransactionId As Integer
    Get

Field Value

The transaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

BeginTransactionCompletedEventArgs Class
BeginTransactionCompletedEventArgs Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration Class

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Client Configuration Template. A client configuration template can be used to specify the IC configuration to apply to a User.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientConfigurationTemplateConfiguration : ListConfigurationObject
Visual Basic
Public Class ClientConfigurationTemplateConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration Members

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration Members
ClientConfigurationTemplateConfiguration Class Methods Properties See Also Send Feedback

The ClientConfigurationTemplateConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this client configuration template (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ClientConfigurationTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration Methods

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration Methods
ClientConfigurationTemplateConfiguration Class See Also Send Feedback

The ClientConfigurationTemplateConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ClientConfigurationTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration Properties

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration Properties
ClientConfigurationTemplateConfiguration Class See Also Send Feedback

The ClientConfigurationTemplateConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this client configuration template (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ClientConfigurationTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..AccessControlGroupAssignment Property
ClientConfigurationTemplateConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this client configuration template (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ClientConfigurationTemplateConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of ClientConfigurationTemplateConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ClientConfigurationTemplateConfiguration Class
ClientConfigurationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..StandardProperties Property
ClientConfigurationTemplateConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ClientConfigurationTemplateConfiguration, ClientConfigurationTemplateConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ClientConfigurationTemplateConfiguration, ClientConfigurationTemplateConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfiguration Class
ClientConfigurationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..Property Enumeration
ClientConfigurationTemplateConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration.Rights Class

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..Rights Class
ClientConfigurationTemplateConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..Rights Members
ClientConfigurationTemplateConfiguration..::..Rights Class Properties See Also Send Feedback

The ClientConfigurationTemplateConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ClientConfigurationTemplateConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..Rights Properties
ClientConfigurationTemplateConfiguration..::..Rights Class See Also Send Feedback

The ClientConfigurationTemplateConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ClientConfigurationTemplateConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..Rights..::..Admin Property
ClientConfigurationTemplateConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ClientConfigurationTemplateConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ClientConfigurationTemplateConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfiguration..::..Rights Class
ClientConfigurationTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientConfigurationTemplates


View Property

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfiguration..::..Rights..::..View Property
ClientConfigurationTemplateConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ClientConfigurationTemplateConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ClientConfigurationTemplateConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfiguration..::..Rights Class
ClientConfigurationTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfigurationList Class

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ClientConfigurationTemplate configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientConfigurationTemplateConfigurationList : DynamicConfigurationList<ClientConfigurationTemplateConfiguration, ClientConfigurationTemplateConfiguration..::..Property>
Visual Basic
Public Class ClientConfigurationTemplateConfigurationList _
    Inherits DynamicConfigurationList(Of ClientConfigurationTemplateConfiguration, ClientConfigurationTemplateConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ClientConfigurationTemplateConfiguration, ClientConfigurationTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ClientConfigurationTemplateConfiguration, ClientConfigurationTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfigurationList Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfigurationList Members

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfigurationList Members
ClientConfigurationTemplateConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ClientConfigurationTemplateConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ClientConfigurationTemplateConfigurationList | Initializes a new instance of the ClientConfigurationTemplateConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ClientConfigurationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfigurationList Constructor

[image]

IceLib Technical Reference
ClientConfigurationTemplateConfigurationList Constructor
ClientConfigurationTemplateConfigurationList Class See Also Send Feedback
Initializes a new instance of the ClientConfigurationTemplateConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ClientConfigurationTemplateConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientConfigurationTemplateConfigurationList Class
ClientConfigurationTemplateConfigurationList Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfigurationList Methods

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfigurationList Methods
ClientConfigurationTemplateConfigurationList Class See Also Send Feedback

The ClientConfigurationTemplateConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientConfigurationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfigurationList Properties

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfigurationList Properties
ClientConfigurationTemplateConfigurationList Class See Also Send Feedback

The ClientConfigurationTemplateConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ClientConfigurationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplateConfigurationList Events

[image] [image]

IceLib Technical Reference
ClientConfigurationTemplateConfigurationList Events
ClientConfigurationTemplateConfigurationList Class See Also Send Feedback

The ClientConfigurationTemplateConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ClientConfigurationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration Class

[image]

IceLib Technical Reference
ClientTemplateConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for IC Client Templates.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientTemplateConfiguration : EditableListConfigurationObject<ClientTemplateConfiguration..::..Property>
Visual Basic
Public Class ClientTemplateConfiguration _
    Inherits EditableListConfigurationObject(Of ClientTemplateConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ClientTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ClientTemplateConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration Members

[image] [image]

IceLib Technical Reference
ClientTemplateConfiguration Members
ClientTemplateConfiguration Class Methods Properties See Also Send Feedback

The ClientTemplateConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DownloadResource | Downloads an existing client template from the IC server.
Public method | DownloadResourceAsync | Asynchronously downloads an existing client template from the IC server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId(String).)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ApplicationId | Provides access to the property representing Application ID (use Property.ApplicationId).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClientTemplateResource | Gets the client template.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | FileDateLastModified | Provides access to the property representing the File Date Last Modified (use Property.FileDateLastModified).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the read-only property representing if the Client Template is permanent (use Property.IsPermanent).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ClientTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration Methods

[image] [image]

IceLib Technical Reference
ClientTemplateConfiguration Methods
ClientTemplateConfiguration Class See Also Send Feedback

The ClientTemplateConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DownloadResource | Downloads an existing client template from the IC server.
Public method | DownloadResourceAsync | Asynchronously downloads an existing client template from the IC server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId(String).)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ClientTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Commit Method
ClientTemplateConfiguration Class See Also Send Feedback
Commits the contents of this object to the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Remarks

PrepareForEdit()()()() should be called prior to modifying an object's settings or calling Commit(). When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Exceptions

Exception | Condition
System..::..InvalidOperationException | ClientTemplateResource has not been set.
ININ.IceLib..::..InsufficientRightsException | Unable to perform operation due to insufficient rights.
ININ.IceLib.Configuration..::..ConfigurationLicenseException | A license error was encountered while saving license changes.
ININ.IceLib.Configuration..::..ConfigurationValidationException | Validation failed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


DownloadResource Method

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..DownloadResource Method
ClientTemplateConfiguration Class See Also Send Feedback
Downloads an existing client template from the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadResource()
Visual Basic
Public Sub DownloadResource

Remarks

When complete, the ClientTemplateResource property will contain the client template details.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The client template is new and does not exist on the IC server yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


DownloadResourceAsync Method

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..DownloadResourceAsync Method
ClientTemplateConfiguration Class See Also Send Feedback
Asynchronously downloads an existing client template from the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadResourceAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub DownloadResourceAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When complete, the ClientTemplateResource property will contain the client template details.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The client template is new and does not exist on the IC server yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


SetConfigurationId Method

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..SetConfigurationId Method
ClientTemplateConfiguration Class See Also Send Feedback
Sets the unique identifier used to reference this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void SetConfigurationId(
    string id
)
Visual Basic
Public Overrides Sub SetConfigurationId ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Remarks

All configuration objects must have an ID set; however, not all configuration objects support setting both the ID and display name. For more information about the objects that support setting the display name separately, see SetDisplayName(String).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The configuration object is not newly created or already had Commit()()()() called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration Properties

[image] [image]

IceLib Technical Reference
ClientTemplateConfiguration Properties
ClientTemplateConfiguration Class See Also Send Feedback

The ClientTemplateConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationId | Provides access to the property representing Application ID (use Property.ApplicationId).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClientTemplateResource | Gets the client template.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | FileDateLastModified | Provides access to the property representing the File Date Last Modified (use Property.FileDateLastModified).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the read-only property representing if the Client Template is permanent (use Property.IsPermanent).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ClientTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


ApplicationId Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..ApplicationId Property
ClientTemplateConfiguration Class See Also Send Feedback
Provides access to the property representing Application ID (use Property.ApplicationId).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ClientTemplateConfiguration..::..Property, string> ApplicationId { get; }
Visual Basic
Public ReadOnly Property ApplicationId As GeneralConfigurationProperty(Of ClientTemplateConfiguration..::..Property, String)
    Get

Field Value

The property representing Application ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


ClientTemplateResource Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..ClientTemplateResource Property
ClientTemplateConfiguration Class See Also Send Feedback
Gets the client template.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ClientTemplateResource ClientTemplateResource { get; }
Visual Basic
Public ReadOnly Property ClientTemplateResource As ClientTemplateResource
    Get

Field Value

The client template resource.

Remarks

For an existing configuration object, a call to DownloadResource()()()() or DownloadResourceAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) is required prior to accessing it. When calling Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object), the client template will be uploaded to the server if the configuration object is new, or if the client template has been modified. Additionally, if editing an existing client template, the client template must be downloaded prior to calling PrepareForEdit()()()().

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


FileDateLastModified Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..FileDateLastModified Property
ClientTemplateConfiguration Class See Also Send Feedback
Provides access to the property representing the File Date Last Modified (use Property.FileDateLastModified).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ClientTemplateConfiguration..::..Property, DateTime> FileDateLastModified { get; }
Visual Basic
Public ReadOnly Property FileDateLastModified As GeneralConfigurationProperty(Of ClientTemplateConfiguration..::..Property, DateTime)
    Get

Field Value

The read-only property representing the File Date Last Modified.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


IsPermanent Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..IsPermanent Property
ClientTemplateConfiguration Class See Also Send Feedback
Provides access to the read-only property representing if the Client Template is permanent (use Property.IsPermanent).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ClientTemplateConfiguration..::..Property, bool> IsPermanent { get; }
Visual Basic
Public ReadOnly Property IsPermanent As GeneralConfigurationProperty(Of ClientTemplateConfiguration..::..Property, Boolean)
    Get

Field Value

The read-only property representing if the Client Template is permanent.

Remarks

If a Client Template is marked as permanent, it cannot be deleted.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..PropertiesChanged Property
ClientTemplateConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ClientTemplateConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ClientTemplateConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..StandardProperties Property
ClientTemplateConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration Class
ClientTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Property Enumeration
ClientTemplateConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
ApplicationId | 0 | Represents the ApplicationId property.
FileDateLastModified | 1 | Represents the FileDateLastModified property.
IsPermanent | 2 | Represents the IsPermanent property.
DisplayName | 3 | Represents the DisplayName part of the ConfigurationId property.
Id | 4 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration.Rights Class

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Rights Class
ClientTemplateConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ClientTemplateConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Rights Members
ClientTemplateConfiguration..::..Rights Class Properties See Also Send Feedback

The ClientTemplateConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ClientTemplateConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ClientTemplateConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Rights Properties
ClientTemplateConfiguration..::..Rights Class See Also Send Feedback

The ClientTemplateConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ClientTemplateConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Rights..::..Admin Property
ClientTemplateConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ClientTemplateConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ClientTemplateConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration..::..Rights Class
ClientTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanManageClientTemplates


View Property

[image]

IceLib Technical Reference
ClientTemplateConfiguration..::..Rights..::..View Property
ClientTemplateConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ClientTemplateConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ClientTemplateConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfiguration..::..Rights Class
ClientTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfigurationList Class

[image]

IceLib Technical Reference
ClientTemplateConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ClientTemplate configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientTemplateConfigurationList : EditableConfigurationList<ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property>
Visual Basic
Public Class ClientTemplateConfigurationList _
    Inherits EditableConfigurationList(Of ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ClientTemplateConfiguration, ClientTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ClientTemplateConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfigurationList Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfigurationList Members

[image] [image]

IceLib Technical Reference
ClientTemplateConfigurationList Members
ClientTemplateConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ClientTemplateConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ClientTemplateConfigurationList | Initializes a new instance of the ClientTemplateConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ClientTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientTemplateConfigurationList Constructor

[image]

IceLib Technical Reference
ClientTemplateConfigurationList Constructor
ClientTemplateConfigurationList Class See Also Send Feedback
Initializes a new instance of the ClientTemplateConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ClientTemplateConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateConfigurationList Class
ClientTemplateConfigurationList Members
ININ.IceLib.Configuration Namespace


ClientTemplateConfigurationList Methods

[image] [image]

IceLib Technical Reference
ClientTemplateConfigurationList Methods
ClientTemplateConfigurationList Class See Also Send Feedback

The ClientTemplateConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientTemplateConfigurationList Properties

[image] [image]

IceLib Technical Reference
ClientTemplateConfigurationList Properties
ClientTemplateConfigurationList Class See Also Send Feedback

The ClientTemplateConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ClientTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientTemplateConfigurationList Events

[image] [image]

IceLib Technical Reference
ClientTemplateConfigurationList Events
ClientTemplateConfigurationList Class See Also Send Feedback

The ClientTemplateConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ClientTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


ClientTemplatePublishResult Class

[image]

IceLib Technical Reference
ClientTemplatePublishResult Class
Members See Also Send Feedback
Contains information on the results of publishing a client template.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientTemplatePublishResult
Visual Basic
Public Class ClientTemplatePublishResult

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ClientTemplatePublishResult

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplatePublishResult Members
ININ.IceLib.Configuration Namespace
RoleConfiguration..::..PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String)
RoleConfiguration..::..PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String)
UserConfiguration..::..PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String)
UserConfiguration..::..PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String)
WorkgroupConfiguration..::..PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String)
WorkgroupConfiguration..::..PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String)


ClientTemplatePublishResult Members

[image] [image]

IceLib Technical Reference
ClientTemplatePublishResult Members
ClientTemplatePublishResult Class Methods Properties See Also Send Feedback

The ClientTemplatePublishResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ApplicationId | Gets the application ID.
Public property | ClientTemplateId | Gets the client template ID.
Public property | Successful | Gets a value indicating whether the client template was published for the specified user ID and application ID.
Public property | UserId | Gets the user ID.

See Also

ClientTemplatePublishResult Class
ININ.IceLib.Configuration Namespace


ClientTemplatePublishResult Methods

[image] [image]

IceLib Technical Reference
ClientTemplatePublishResult Methods
ClientTemplatePublishResult Class See Also Send Feedback

The ClientTemplatePublishResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ClientTemplatePublishResult Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ClientTemplatePublishResult..::..ToString Method
ClientTemplatePublishResult Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ClientTemplatePublishResult Class
ClientTemplatePublishResult Members
ININ.IceLib.Configuration Namespace


ClientTemplatePublishResult Properties

[image] [image]

IceLib Technical Reference
ClientTemplatePublishResult Properties
ClientTemplatePublishResult Class See Also Send Feedback

The ClientTemplatePublishResult type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationId | Gets the application ID.
Public property | ClientTemplateId | Gets the client template ID.
Public property | Successful | Gets a value indicating whether the client template was published for the specified user ID and application ID.
Public property | UserId | Gets the user ID.

See Also

ClientTemplatePublishResult Class
ININ.IceLib.Configuration Namespace


ApplicationId Property

[image]

IceLib Technical Reference
ClientTemplatePublishResult..::..ApplicationId Property
ClientTemplatePublishResult Class See Also Send Feedback
Gets the application ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; private set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Private Set

Field Value

The application ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplatePublishResult Class
ClientTemplatePublishResult Members
ININ.IceLib.Configuration Namespace


ClientTemplateId Property

[image]

IceLib Technical Reference
ClientTemplatePublishResult..::..ClientTemplateId Property
ClientTemplatePublishResult Class See Also Send Feedback
Gets the client template ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId ClientTemplateId { get; private set; }
Visual Basic
Public Property ClientTemplateId As ConfigurationId
    Get
    Private Set

Field Value

The client template ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplatePublishResult Class
ClientTemplatePublishResult Members
ININ.IceLib.Configuration Namespace


Successful Property

[image]

IceLib Technical Reference
ClientTemplatePublishResult..::..Successful Property
ClientTemplatePublishResult Class See Also Send Feedback
Gets a value indicating whether the client template was published for the specified user ID and application ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Successful { get; private set; }
Visual Basic
Public Property Successful As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if successful; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplatePublishResult Class
ClientTemplatePublishResult Members
ININ.IceLib.Configuration Namespace


UserId Property

[image]

IceLib Technical Reference
ClientTemplatePublishResult..::..UserId Property
ClientTemplatePublishResult Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; private set; }
Visual Basic
Public Property UserId As String
    Get
    Private Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplatePublishResult Class
ClientTemplatePublishResult Members
ININ.IceLib.Configuration Namespace


ClientTemplateResource Class

[image]

IceLib Technical Reference
ClientTemplateResource Class
Members See Also Send Feedback
Represents a client template for an ClientTemplateConfiguration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientTemplateResource : IDeepCloneable,
    IEditableProvider
Visual Basic
Public Class ClientTemplateResource _
    Implements IDeepCloneable, IEditableProvider

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ClientTemplateResource

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateResource Members
ININ.IceLib.Configuration Namespace


ClientTemplateResource Members

[image] [image]

IceLib Technical Reference
ClientTemplateResource Members
ClientTemplateResource Class Methods Properties See Also Send Feedback

The ClientTemplateResource type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTemplateXml | Sets the template Xml.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HasChanged | Gets a value indicating whether this client template has changed.
Public property | TemplateXml | Gets a readonly string that represents the template Xml.

See Also

ClientTemplateResource Class
ININ.IceLib.Configuration Namespace


ClientTemplateResource Methods

[image] [image]

IceLib Technical Reference
ClientTemplateResource Methods
ClientTemplateResource Class See Also Send Feedback

The ClientTemplateResource type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetTemplateXml | Sets the template Xml.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientTemplateResource Class
ININ.IceLib.Configuration Namespace


Clone Method

[image]

IceLib Technical Reference
ClientTemplateResource..::..Clone Method
ClientTemplateResource Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateResource Class
ClientTemplateResource Members
ININ.IceLib.Configuration Namespace


SetTemplateXml Method

[image]

IceLib Technical Reference
ClientTemplateResource..::..SetTemplateXml Method
ClientTemplateResource Class See Also Send Feedback
Sets the template Xml.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTemplateXml(
    string templateXml
)
Visual Basic
Public Sub SetTemplateXml ( _
    templateXml As String _
)

Parameters

templateXml
Type: System..::..String
The template Xml.

Exceptions

Exception | Condition
System..::..ArgumentException | templateXml is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.
System..::..InvalidOperationException | The client template is currently not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateResource Class
ClientTemplateResource Members
ININ.IceLib.Configuration Namespace


ClientTemplateResource Properties

[image] [image]

IceLib Technical Reference
ClientTemplateResource Properties
ClientTemplateResource Class See Also Send Feedback

The ClientTemplateResource type exposes the following members.

Properties

 | Name | Description
Public property | HasChanged | Gets a value indicating whether this client template has changed.
Public property | TemplateXml | Gets a readonly string that represents the template Xml.

See Also

ClientTemplateResource Class
ININ.IceLib.Configuration Namespace


HasChanged Property

[image]

IceLib Technical Reference
ClientTemplateResource..::..HasChanged Property
ClientTemplateResource Class See Also Send Feedback
Gets a value indicating whether this client template has changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasChanged { get; private set; }
Visual Basic
Public Property HasChanged As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if this client template has changed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateResource Class
ClientTemplateResource Members
ININ.IceLib.Configuration Namespace


TemplateXml Property

[image]

IceLib Technical Reference
ClientTemplateResource..::..TemplateXml Property
ClientTemplateResource Class See Also Send Feedback
Gets a readonly string that represents the template Xml.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TemplateXml { get; private set; }
Visual Basic
Public Property TemplateXml As String
    Get
    Private Set

Field Value

The readonly template Xml.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplateResource Class
ClientTemplateResource Members
ININ.IceLib.Configuration Namespace


ConfigurationContainer(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Allows for querying and managing a container-based configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ConfigurationContainer<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ContainerConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class ConfigurationContainer(Of TConfigurationObject As ContainerConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..AccountCodesConfigurationContainer
ININ.IceLib.Configuration..::..DefaultLocationConfigurationContainer
ININ.IceLib.Configuration..::..DefaultStationConfigurationContainer
ININ.IceLib.Configuration..::..DefaultUserConfigurationContainer
ININ.IceLib.Configuration..::..DnisMappingsConfigurationContainer
ININ.IceLib.Configuration..::..ProblemReporterConfigurationContainer
ININ.IceLib.Configuration.Recorder..::..RecorderConfigurationContainer
ININ.IceLib.Configuration..::..ServerReportConfigurationConfigurationContainer
ININ.IceLib.Configuration..::..SystemConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationContainer(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties Events See Also Send Feedback

The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in.
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in.
Public method | ChangeWatchedQuerySettings | Changes the watched query settings.
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings.
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async.
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object.
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object.
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StopCaching | Stops caching the configuration objects.
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager.
Public property | IsCaching | Gets a value indicating whether this instance is cached.
Public property | IsWatching | Gets a value indicating whether this instance is watched.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added.
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified.
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationContainer(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in.
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in.
Public method | ChangeWatchedQuerySettings | Changes the watched query settings.
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings.
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async.
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object.
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object.
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StopCaching | Stops caching the configuration objects.
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ChangeWatchedProperties Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchedProperties Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the watched properties, replacing the current ones with those passed in.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedProperties(
    IEnumerable<TPropertyEnum> propertiesInQuery
)
Visual Basic
Public Sub ChangeWatchedProperties ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum) _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ChangeWatchedPropertiesAsync Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchedPropertiesAsync Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the watched properties, replacing the current ones with those passed in.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedPropertiesAsync(
    IEnumerable<TPropertyEnum> propertiesInQuery,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedPropertiesAsync ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | propertiesInQuery is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ChangeWatchedQuerySettings Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchedQuerySettings Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the watched query settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedQuerySettings(
    ContainerQuerySettings<TConfigurationObject, TPropertyEnum> querySettings
)
Visual Basic
Public Sub ChangeWatchedQuerySettings ( _
    querySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum) _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..ContainerQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ChangeWatchedQuerySettingsAsync Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchedQuerySettingsAsync Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the watched query settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedQuerySettingsAsync(
    ContainerQuerySettings<TConfigurationObject, TPropertyEnum> querySettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedQuerySettingsAsync ( _
    querySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..ContainerQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | querySettings is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ChangeWatchQuerySettingsAsync Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchQuerySettingsAsync Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the query settings async.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ChangeWatchQuerySettingsAsync is obsolete, ChangeWatchedQuerySettingsAsync should be used instead.")]
public void ChangeWatchQuerySettingsAsync(
    IEnumerable<TPropertyEnum> propertiesInQuery,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("ChangeWatchQuerySettingsAsync is obsolete, ChangeWatchedQuerySettingsAsync should be used instead.")> _
Public Sub ChangeWatchQuerySettingsAsync ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | propertiesInQuery is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateQuerySettings Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateQuerySettings Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> CreateQuerySettings()
Visual Basic
Public Function CreateQuerySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

A new ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetConfigurationItem Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..GetConfigurationItem Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the configuration item.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TConfigurationObject GetConfigurationItem()
Visual Basic
Public Function GetConfigurationItem As TConfigurationObject

Return Value

A configuration object with the requested properties.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The specified object is not being cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>))
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>))
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)


StartCaching Method

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartCaching Method (IEnumerable(TPropertyEnum))

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching Method (IEnumerable<(Of <(<'TPropertyEnum>)>)>)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts caching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCaching(
    IEnumerable<TPropertyEnum> propertiesInQuery
)
Visual Basic
Public Sub StartCaching ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum) _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCaching Overload
ININ.IceLib.Configuration Namespace


StartCaching Method (ContainerQuerySettings(TConfigurationObject, TPropertyEnum))

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching Method (ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts caching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCaching(
    ContainerQuerySettings<TConfigurationObject, TPropertyEnum> querySettings
)
Visual Basic
Public Sub StartCaching ( _
    querySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum) _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..ContainerQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCaching Overload
ININ.IceLib.Configuration Namespace


StartCachingAsync Method

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartCachingAsync Method (IEnumerable(TPropertyEnum), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync Method (IEnumerable<(Of <(<'TPropertyEnum>)>)>, AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts caching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCachingAsync(
    IEnumerable<TPropertyEnum> propertiesInQuery,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartCachingAsync ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCachingAsync Overload
ININ.IceLib.Configuration Namespace


StartCachingAsync Method (ContainerQuerySettings(TConfigurationObject, TPropertyEnum), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync Method (ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts caching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCachingAsync(
    ContainerQuerySettings<TConfigurationObject, TPropertyEnum> querySettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartCachingAsync ( _
    querySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..ContainerQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCachingAsync Overload
ININ.IceLib.Configuration Namespace


StartWatching Method

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object.
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartWatching Method (IEnumerable(TPropertyEnum))

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching Method (IEnumerable<(Of <(<'TPropertyEnum>)>)>)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts watching the specified properties of the configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    IEnumerable<TPropertyEnum> propertiesInQuery
)
Visual Basic
Public Sub StartWatching ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum) _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.

Remarks

Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatching Overload
ININ.IceLib.Configuration Namespace


StartWatching Method (ContainerQuerySettings(TConfigurationObject, TPropertyEnum))

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching Method (ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts watching the configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    ContainerQuerySettings<TConfigurationObject, TPropertyEnum> querySettings
)
Visual Basic
Public Sub StartWatching ( _
    querySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum) _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..ContainerQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object.

Remarks

Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatching Overload
ININ.IceLib.Configuration Namespace


StartWatchingAsync Method

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartWatchingAsync Method (IEnumerable(TPropertyEnum), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync Method (IEnumerable<(Of <(<'TPropertyEnum>)>)>, AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts watching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    IEnumerable<TPropertyEnum> propertiesInQuery,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    propertiesInQuery As IEnumerable(Of TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

propertiesInQuery
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The properties to be selected in the query.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatchingAsync Overload
ININ.IceLib.Configuration Namespace


StartWatchingAsync Method (ContainerQuerySettings(TConfigurationObject, TPropertyEnum), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync Method (ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, AsyncCompletedEventHandler, Object)
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts watching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    ContainerQuerySettings<TConfigurationObject, TPropertyEnum> querySettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    querySettings As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..ContainerQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatchingAsync Overload
ININ.IceLib.Configuration Namespace


StopCaching Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StopCaching Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Stops caching the configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopCaching()
Visual Basic
Public Sub StopCaching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StopWatching Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StopWatching Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StopWatchingAsync Method
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously stops watching the configuration list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationContainer(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager.
Public property | IsCaching | Gets a value indicating whether this instance is cached.
Public property | IsWatching | Gets a value indicating whether this instance is watched.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationManager Property

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationManager Property
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the configuration manager.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationManager ConfigurationManager { get; }
Visual Basic
Public ReadOnly Property ConfigurationManager As ConfigurationManager
    Get

Field Value

The configuration manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsCaching Property

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IsCaching Property
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this instance is cached.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsCaching { get; }
Visual Basic
Public ReadOnly Property IsCaching As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is cached; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsWatching Property

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IsWatching Property
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this instance is watched.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching { get; }
Visual Basic
Public ReadOnly Property IsWatching As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationContainer(TConfigurationObject, TPropertyEnum) Events

[image] [image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Events
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added.
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified.
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationObjectsAdded Event

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationObjectsAdded Event
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Occurs when at least one item of type TConfigurationObject is added.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConfigurationWatchEventArgs<TConfigurationObject>> ConfigurationObjectsAdded
Visual Basic
Public Event ConfigurationObjectsAdded As EventHandler(Of ConfigurationWatchEventArgs(Of TConfigurationObject))

Remarks

This event will only occur when configuration objects being watched have been added. To start watching for configuration objects call either the StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) or StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method, or the StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedProperties(IEnumerable<(Of <<'(TPropertyEnum>)>>)) or ChangeWatchedPropertiesAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or ChangeWatchedQuerySettings(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) or ChangeWatchedQuerySettingsAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationObjectsChanged Event

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationObjectsChanged Event
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Occurs when at least one item of type TConfigurationObject is modified.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConfigurationObjectChangesEventArgs<TConfigurationObject, TPropertyEnum>> ConfigurationObjectsChanged
Visual Basic
Public Event ConfigurationObjectsChanged As EventHandler(Of ConfigurationObjectChangesEventArgs(Of TConfigurationObject, TPropertyEnum))

Remarks

This event will only occur when configuration objects being watched have been changed. To start watching for configuration objects call either the StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) or StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method, or the StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedProperties(IEnumerable<(Of <<'(TPropertyEnum>)>>)) or ChangeWatchedPropertiesAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or ChangeWatchedQuerySettings(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) or ChangeWatchedQuerySettingsAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationObjectsRemoved Event

[image]

IceLib Technical Reference
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationObjectsRemoved Event
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Occurs when at least one item of type TConfigurationObject is removed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConfigurationWatchEventArgs<TConfigurationObject>> ConfigurationObjectsRemoved
Visual Basic
Public Event ConfigurationObjectsRemoved As EventHandler(Of ConfigurationWatchEventArgs(Of TConfigurationObject))

Remarks

This event will only occur when configuration objects being watched have been removed. To start watching for configuration objects call either the StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) or StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method, or the StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedProperties(IEnumerable<(Of <<'(TPropertyEnum>)>>)) or ChangeWatchedPropertiesAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) or ChangeWatchedQuerySettings(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) or ChangeWatchedQuerySettingsAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)), StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object), StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)), or StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Class

[image]

IceLib Technical Reference
ConfigurationDeleteException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a configuration delete operation fails.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ConfigurationDeleteException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ConfigurationDeleteException _
    Inherits IceLibException

Remarks

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Configuration..::..ConfigurationDeleteException

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Members
ININ.IceLib.Configuration Namespace
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Delete()()()()


ConfigurationDeleteException Members

[image] [image]

IceLib Technical Reference
ConfigurationDeleteException Members
ConfigurationDeleteException Class Constructors Methods Properties Events See Also Send Feedback

The ConfigurationDeleteException type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationDeleteException()()()() | Initializes a new instance of the ConfigurationDeleteException class with default settings.
Public method | ConfigurationDeleteException(CultureInfo) | Initializes a new instance of the ConfigurationDeleteException class with default settings.
Public method | ConfigurationDeleteException(String) | Initializes a new instance of the ConfigurationDeleteException class with a specified cache value.
Protected method | ConfigurationDeleteException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationDeleteException class with a specified error message.
Public method | ConfigurationDeleteException(String, Exception) | Initializes a new instance of the ConfigurationDeleteException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationDeleteException Class
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Constructor

[image] [image]

IceLib Technical Reference
ConfigurationDeleteException Constructor
ConfigurationDeleteException Class See Also Send Feedback
Initializes a new instance of the ConfigurationDeleteException class.

Overload List

 | Name | Description
Public method | ConfigurationDeleteException()()()() | Initializes a new instance of the ConfigurationDeleteException class with default settings.
Public method | ConfigurationDeleteException(CultureInfo) | Initializes a new instance of the ConfigurationDeleteException class with default settings.
Public method | ConfigurationDeleteException(String) | Initializes a new instance of the ConfigurationDeleteException class with a specified cache value.
Protected method | ConfigurationDeleteException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationDeleteException class with a specified error message.
Public method | ConfigurationDeleteException(String, Exception) | Initializes a new instance of the ConfigurationDeleteException class with a specified error message.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Constructor

[image]

IceLib Technical Reference
ConfigurationDeleteException Constructor
ConfigurationDeleteException Class See Also Send Feedback
Initializes a new instance of the ConfigurationDeleteException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationDeleteException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ConfigurationDeleteException Overload
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ConfigurationDeleteException Constructor (CultureInfo)
ConfigurationDeleteException Class See Also Send Feedback
Initializes a new instance of the ConfigurationDeleteException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationDeleteException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ConfigurationDeleteException Overload
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Constructor (String)

[image]

IceLib Technical Reference
ConfigurationDeleteException Constructor (String)
ConfigurationDeleteException Class See Also Send Feedback
Initializes a new instance of the ConfigurationDeleteException class with a specified cache value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationDeleteException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ConfigurationDeleteException Overload
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
ConfigurationDeleteException Constructor (SerializationInfo, StreamingContext)
ConfigurationDeleteException Class See Also Send Feedback
Initializes a new instance of the ConfigurationDeleteException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ConfigurationDeleteException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ConfigurationDeleteException Overload
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Constructor (String, Exception)

[image]

IceLib Technical Reference
ConfigurationDeleteException Constructor (String, Exception)
ConfigurationDeleteException Class See Also Send Feedback
Initializes a new instance of the ConfigurationDeleteException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationDeleteException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The message that describes the error.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ConfigurationDeleteException Overload
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Methods

[image] [image]

IceLib Technical Reference
ConfigurationDeleteException Methods
ConfigurationDeleteException Class See Also Send Feedback

The ConfigurationDeleteException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationDeleteException Class
ININ.IceLib.Configuration Namespace


GetObjectData Method

[image]

IceLib Technical Reference
ConfigurationDeleteException..::..GetObjectData Method
ConfigurationDeleteException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ConfigurationDeleteException Class
ConfigurationDeleteException Members
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Properties

[image] [image]

IceLib Technical Reference
ConfigurationDeleteException Properties
ConfigurationDeleteException Class See Also Send Feedback

The ConfigurationDeleteException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationDeleteException Class
ININ.IceLib.Configuration Namespace


ConfigurationDeleteException Events

[image] [image]

IceLib Technical Reference
ConfigurationDeleteException Events
ConfigurationDeleteException Class See Also Send Feedback

The ConfigurationDeleteException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationDeleteException Class
ININ.IceLib.Configuration Namespace


ConfigurationId Class

[image]

IceLib Technical Reference
ConfigurationId Class
Members Example See Also Send Feedback
Represents a unique identifier for an object, along with its display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationId : IComparable
Visual Basic
Public Class ConfigurationId _
    Implements IComparable

Remarks

The ConfigurationId class is used to represent a unique identifier for configuration objects in the IC system, along with a DisplayName for that object, if one is defined. If no display name exists for the object, the class will return the Id for the object to be used as the display string.

Examples

The IceLib SDK includes example application references to the ConfigurationId class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 60, in UserRoleConfigurationViewModel.set_SelectedConfigurationId
 | UserRoleConfigurationViewModel.cs, line 48, in UserRoleConfigurationViewModel.#ctor
 | UserRoleConfigurationViewModel.cs, line 32, in UserRoleConfigurationViewModel.set_ConfigurationIdList
 | UserRoleConfigurationViewModel._ConfigurationIdList
 | UserRoleConfigurationViewModel._SelectedConfigurationId
 | UserRoleConfigurationViewModel.CS$<>9__CachedAnonymousMethodDelegate8

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationId
ININ.IceLib.Configuration..::..GroupedConfigurationId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Members
ININ.IceLib.Configuration Namespace


ConfigurationId Members

[image] [image]

IceLib Technical Reference
ConfigurationId Members
ConfigurationId Class Constructors Methods Operators Properties See Also Send Feedback

The ConfigurationId type exposes the following members.

Constructors

 | Name | Description
Protected method | ConfigurationId()()()() | Initializes a new instance of the ConfigurationId class, for None.
Public method | ConfigurationId(String) | Initializes a new instance of the ConfigurationId class.
Public method | ConfigurationId(String, String) | Initializes a new instance of the ConfigurationId class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ConfigurationId) | Determines whether the specified ConfigurationId is equal to the current ConfigurationId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | DisplayName | Gets the human-readable name that refers to this configuration object.
Public property | Id | Gets the unique identifier used to reference this configuration object.
 | None | Gets a ConfigurationId representing no value (i.e. String.Empty).

See Also

ConfigurationId Class
ININ.IceLib.Configuration Namespace


ConfigurationId Constructor

[image] [image]

IceLib Technical Reference
ConfigurationId Constructor
ConfigurationId Class See Also Send Feedback
Initializes a new instance of the ConfigurationId class.

Overload List

 | Name | Description
Protected method | ConfigurationId()()()() | Initializes a new instance of the ConfigurationId class, for None.
Public method | ConfigurationId(String) | Initializes a new instance of the ConfigurationId class.
Public method | ConfigurationId(String, String) | Initializes a new instance of the ConfigurationId class.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


ConfigurationId Constructor

[image]

IceLib Technical Reference
ConfigurationId Constructor
ConfigurationId Class See Also Send Feedback
Initializes a new instance of the ConfigurationId class, for None.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ConfigurationId()
Visual Basic
Protected Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ConfigurationId Overload
ININ.IceLib.Configuration Namespace


ConfigurationId Constructor (String)

[image]

IceLib Technical Reference
ConfigurationId Constructor (String)
ConfigurationId Class See Also Send Feedback
Initializes a new instance of the ConfigurationId class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ConfigurationId Overload
ININ.IceLib.Configuration Namespace


ConfigurationId Constructor (String, String)

[image]

IceLib Technical Reference
ConfigurationId Constructor (String, String)
ConfigurationId Class See Also Send Feedback
Initializes a new instance of the ConfigurationId class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId(
    string id,
    string displayName
)
Visual Basic
Public Sub New ( _
    id As String, _
    displayName As String _
)

Parameters

id
Type: System..::..String
The ID.
displayName
Type: System..::..String
The display name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ConfigurationId Overload
ININ.IceLib.Configuration Namespace


ConfigurationId Methods

[image] [image]

IceLib Technical Reference
ConfigurationId Methods
ConfigurationId Class See Also Send Feedback

The ConfigurationId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ConfigurationId) | Determines whether the specified ConfigurationId is equal to the current ConfigurationId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ConfigurationId Class
ININ.IceLib.Configuration Namespace


CompareTo Method

[image]

IceLib Technical Reference
ConfigurationId..::..CompareTo Method
ConfigurationId Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ConfigurationId..::..Equals Method
ConfigurationId Class See Also Send Feedback
Determines whether two ConfigurationId instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ConfigurationId) | Determines whether the specified ConfigurationId is equal to the current ConfigurationId.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ConfigurationId..::..Equals Method (Object)
ConfigurationId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
Equals Overload
ININ.IceLib.Configuration Namespace


Equals Method (ConfigurationId)

[image]

IceLib Technical Reference
ConfigurationId..::..Equals Method (ConfigurationId)
ConfigurationId Class See Also Send Feedback
Determines whether the specified ConfigurationId is equal to the current ConfigurationId.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ConfigurationId other
)
Visual Basic
Public Function Equals ( _
    other As ConfigurationId _
) As Boolean

Parameters

other
Type: ININ.IceLib.Configuration..::..ConfigurationId
The ConfigurationId to compare with the current ConfigurationId.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified ConfigurationId is equal to the current ConfigurationId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
Equals Overload
ININ.IceLib.Configuration Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ConfigurationId..::..GetHashCode Method
ConfigurationId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ConfigurationId..::..ToString Method
ConfigurationId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


ConfigurationId Operators

[image] [image]

IceLib Technical Reference
ConfigurationId Operators
ConfigurationId Class See Also Send Feedback

The ConfigurationId type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

ConfigurationId Class
ININ.IceLib.Configuration Namespace


Equality Operator

[image]

IceLib Technical Reference
ConfigurationId..::..Equality Operator
ConfigurationId Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ConfigurationId configurationId1,
    ConfigurationId configurationId2
)
Visual Basic
Public Shared Operator = ( _
    configurationId1 As ConfigurationId, _
    configurationId2 As ConfigurationId _
) As Boolean

Parameters

configurationId1
Type: ININ.IceLib.Configuration..::..ConfigurationId
A Configuration ID to compare.
configurationId2
Type: ININ.IceLib.Configuration..::..ConfigurationId
A Configuration ID to compare.

Return Value

Returns trueTruetruetrue (True in Visual Basic) if the values of its operands are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


Inequality Operator

[image]

IceLib Technical Reference
ConfigurationId..::..Inequality Operator
ConfigurationId Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ConfigurationId configurationId1,
    ConfigurationId configurationId2
)
Visual Basic
Public Shared Operator <> ( _
    configurationId1 As ConfigurationId, _
    configurationId2 As ConfigurationId _
) As Boolean

Parameters

configurationId1
Type: ININ.IceLib.Configuration..::..ConfigurationId
A Configuration ID to compare.
configurationId2
Type: ININ.IceLib.Configuration..::..ConfigurationId
A Configuration ID to compare.

Return Value

Returns falseFalsefalsefalse (False in Visual Basic) if the values of its operands are equal, trueTruetruetrue (True in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


ConfigurationId Properties

[image] [image]

IceLib Technical Reference
ConfigurationId Properties
ConfigurationId Class See Also Send Feedback

The ConfigurationId type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the human-readable name that refers to this configuration object.
Public property | Id | Gets the unique identifier used to reference this configuration object.
 | None | Gets a ConfigurationId representing no value (i.e. String.Empty).

See Also

ConfigurationId Class
ININ.IceLib.Configuration Namespace


DisplayName Property

[image]

IceLib Technical Reference
ConfigurationId..::..DisplayName Property
ConfigurationId Class See Also Send Feedback
Gets the human-readable name that refers to this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The human-readable display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


Id Property

[image]

IceLib Technical Reference
ConfigurationId..::..Id Property
ConfigurationId Class Example See Also Send Feedback
Gets the unique identifier used to reference this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Examples

The IceLib SDK includes example application references to the Id property. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 110, in UserRoleConfigurationViewModel.set_SelectedConfigurationId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


None Property

[image]

IceLib Technical Reference
ConfigurationId..::..None Property
ConfigurationId Class Example See Also Send Feedback
Gets a ConfigurationId representing no value (i.e. String.Empty).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ConfigurationId None { get; }
Visual Basic
Public Shared ReadOnly Property None As ConfigurationId
    Get

Field Value

The ConfigurationId.

Examples

The IceLib SDK includes example application references to the None property. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 48, in UserRoleConfigurationViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationId Class
ConfigurationId Members
ININ.IceLib.Configuration Namespace


ConfigurationIdGrouping Enumeration

[image]

IceLib Technical Reference
ConfigurationIdGrouping Enumeration
See Also Send Feedback
The grouping of a GroupedConfigurationId.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ConfigurationIdGrouping
Visual Basic
Public Enumeration ConfigurationIdGrouping

Members

Member name | Value | Description
All | 0 | Represents all possible ConfigurationIds.
Single | 1 | Represents a single ConfigurationId.
Group | 2 | Represents a grouping of ConfigurationIds where each ConfigurationId is a member of some other Aggregate (Workgroup, Role, ...).
AllGroups | 3 | Obsolete. Represents all possible group ConfigurationIds.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Class

[image]

IceLib Technical Reference
ConfigurationLicenseException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when an operation is prevented due to configuration license issues.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ConfigurationLicenseException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ConfigurationLicenseException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested operation cannot be performed due to configuration license issues.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Configuration..::..ConfigurationLicenseException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Members

[image] [image]

IceLib Technical Reference
ConfigurationLicenseException Members
ConfigurationLicenseException Class Constructors Methods Properties Events See Also Send Feedback

The ConfigurationLicenseException type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationLicenseException()()()() | Initializes a new instance of the ConfigurationLicenseException class with default settings.
Public method | ConfigurationLicenseException(CultureInfo) | Initializes a new instance of the ConfigurationLicenseException class with default settings.
Public method | ConfigurationLicenseException(CultureInfo, IEnumerable<(Of <<'(ConfigurationLicenseIssue>)>>)) | Initializes a new instance of the ConfigurationLicenseException class with a specified cache value.
Protected method | ConfigurationLicenseException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationLicenseException class with a specified error message.
Public method | ConfigurationLicenseException(CultureInfo, IEnumerable<(Of <<'(ConfigurationLicenseIssue>)>>), Exception) | Initializes a new instance of the ConfigurationLicenseException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LicenseIssues | Gets the license issues.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationLicenseException Class
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Constructor

[image] [image]

IceLib Technical Reference
ConfigurationLicenseException Constructor
ConfigurationLicenseException Class See Also Send Feedback
Initializes a new instance of the ConfigurationLicenseException class.

Overload List

 | Name | Description
Public method | ConfigurationLicenseException()()()() | Initializes a new instance of the ConfigurationLicenseException class with default settings.
Public method | ConfigurationLicenseException(CultureInfo) | Initializes a new instance of the ConfigurationLicenseException class with default settings.
Public method | ConfigurationLicenseException(CultureInfo, IEnumerable<(Of <<'(ConfigurationLicenseIssue>)>>)) | Initializes a new instance of the ConfigurationLicenseException class with a specified cache value.
Protected method | ConfigurationLicenseException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationLicenseException class with a specified error message.
Public method | ConfigurationLicenseException(CultureInfo, IEnumerable<(Of <<'(ConfigurationLicenseIssue>)>>), Exception) | Initializes a new instance of the ConfigurationLicenseException class with a specified error message.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Constructor

[image]

IceLib Technical Reference
ConfigurationLicenseException Constructor
ConfigurationLicenseException Class See Also Send Feedback
Initializes a new instance of the ConfigurationLicenseException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationLicenseException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ConfigurationLicenseException Overload
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ConfigurationLicenseException Constructor (CultureInfo)
ConfigurationLicenseException Class See Also Send Feedback
Initializes a new instance of the ConfigurationLicenseException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationLicenseException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ConfigurationLicenseException Overload
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Constructor (CultureInfo, IEnumerable(ConfigurationLicenseIssue))

[image]

IceLib Technical Reference
ConfigurationLicenseException Constructor (CultureInfo, IEnumerable<(Of <(<'ConfigurationLicenseIssue>)>)>)
ConfigurationLicenseException Class See Also Send Feedback
Initializes a new instance of the ConfigurationLicenseException class with a specified cache value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationLicenseException(
    CultureInfo cultureInfo,
    IEnumerable<ConfigurationLicenseIssue> licenseIssues
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    licenseIssues As IEnumerable(Of ConfigurationLicenseIssue) _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
licenseIssues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ConfigurationLicenseIssue >)>)>
The license issues.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ConfigurationLicenseException Overload
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
ConfigurationLicenseException Constructor (SerializationInfo, StreamingContext)
ConfigurationLicenseException Class See Also Send Feedback
Initializes a new instance of the ConfigurationLicenseException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ConfigurationLicenseException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ConfigurationLicenseException Overload
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Constructor (CultureInfo, IEnumerable(ConfigurationLicenseIssue), Exception)

[image]

IceLib Technical Reference
ConfigurationLicenseException Constructor (CultureInfo, IEnumerable<(Of <(<'ConfigurationLicenseIssue>)>)>, Exception)
ConfigurationLicenseException Class See Also Send Feedback
Initializes a new instance of the ConfigurationLicenseException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationLicenseException(
    CultureInfo cultureInfo,
    IEnumerable<ConfigurationLicenseIssue> licenseIssues,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    licenseIssues As IEnumerable(Of ConfigurationLicenseIssue), _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
licenseIssues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ConfigurationLicenseIssue >)>)>
The license issues.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ConfigurationLicenseException Overload
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Methods

[image] [image]

IceLib Technical Reference
ConfigurationLicenseException Methods
ConfigurationLicenseException Class See Also Send Feedback

The ConfigurationLicenseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationLicenseException Class
ININ.IceLib.Configuration Namespace


GetObjectData Method

[image]

IceLib Technical Reference
ConfigurationLicenseException..::..GetObjectData Method
ConfigurationLicenseException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Properties

[image] [image]

IceLib Technical Reference
ConfigurationLicenseException Properties
ConfigurationLicenseException Class See Also Send Feedback

The ConfigurationLicenseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LicenseIssues | Gets the license issues.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationLicenseException Class
ININ.IceLib.Configuration Namespace


LicenseIssues Property

[image]

IceLib Technical Reference
ConfigurationLicenseException..::..LicenseIssues Property
ConfigurationLicenseException Class See Also Send Feedback
Gets the license issues.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ConfigurationLicenseIssue> LicenseIssues { get; }
Visual Basic
Public ReadOnly Property LicenseIssues As ReadOnlyCollection(Of ConfigurationLicenseIssue)
    Get

Field Value

The license issues.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseException Class
ConfigurationLicenseException Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseException Events

[image] [image]

IceLib Technical Reference
ConfigurationLicenseException Events
ConfigurationLicenseException Class See Also Send Feedback

The ConfigurationLicenseException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationLicenseException Class
ININ.IceLib.Configuration Namespace


ConfigurationLicenseIssue Class

[image]

IceLib Technical Reference
ConfigurationLicenseIssue Class
Members See Also Send Feedback
Represents a configuration license issue.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationLicenseIssue
Visual Basic
Public Class ConfigurationLicenseIssue

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationLicenseIssue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseIssue Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseIssue Members

[image] [image]

IceLib Technical Reference
ConfigurationLicenseIssue Members
ConfigurationLicenseIssue Class Methods Properties See Also Send Feedback

The ConfigurationLicenseIssue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | License | Gets the license.

See Also

ConfigurationLicenseIssue Class
ININ.IceLib.Configuration Namespace


ConfigurationLicenseIssue Methods

[image] [image]

IceLib Technical Reference
ConfigurationLicenseIssue Methods
ConfigurationLicenseIssue Class See Also Send Feedback

The ConfigurationLicenseIssue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ConfigurationLicenseIssue Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ConfigurationLicenseIssue..::..ToString Method
ConfigurationLicenseIssue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationLicenseIssue Class
ConfigurationLicenseIssue Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseIssue Properties

[image] [image]

IceLib Technical Reference
ConfigurationLicenseIssue Properties
ConfigurationLicenseIssue Class See Also Send Feedback

The ConfigurationLicenseIssue type exposes the following members.

Properties

 | Name | Description
Public property | License | Gets the license.

See Also

ConfigurationLicenseIssue Class
ININ.IceLib.Configuration Namespace


License Property

[image]

IceLib Technical Reference
ConfigurationLicenseIssue..::..License Property
ConfigurationLicenseIssue Class See Also Send Feedback
Gets the license.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId License { get; }
Visual Basic
Public ReadOnly Property License As ConfigurationId
    Get

Field Value

The license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationLicenseIssue Class
ConfigurationLicenseIssue Members
ININ.IceLib.Configuration Namespace


ConfigurationLicenseIssueType Enumeration

[image]

IceLib Technical Reference
ConfigurationLicenseIssueType Enumeration
See Also Send Feedback
Describes which type of configuration license issue was experienced.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ConfigurationLicenseIssueType
Visual Basic
Public Enumeration ConfigurationLicenseIssueType

Members

Member name | Value | Description
None | 0 | No issues.
ErrorExceedsThreshold | 1 | License exceeds threshold.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ConfigurationList(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Allows for querying and managing list-based configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ConfigurationList<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ListConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class ConfigurationList(Of TConfigurationObject As ListConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..FeatureLicenseConfigurationList
ININ.IceLib.Configuration..::..ICDataSourceConfigurationList
ININ.IceLib.Configuration..::..ImageResourceCategoryConfigurationList
ININ.IceLib.Configuration..::..LicenseAllocationConfigurationList
ININ.IceLib.Configuration..::..MrcpServerConfigurationList
ININ.IceLib.Configuration..::..SelectionRuleConfigurationList
ININ.IceLib.Configuration..::..SingleSignOnIdentityProviderConfigurationList
ININ.IceLib.Configuration..::..SipBridgeConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationList(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StopCaching | Stops caching the configuration objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager.
Public property | IsCaching | Gets a value indicating whether this instance is cached.
Public property | IsWatching | Gets a value indicating whether this instance is watched.
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationList(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects.
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.
Public method | StopCaching | Stops caching the configuration objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CreateQuerySettings Method

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateQuerySettings Method
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> CreateQuerySettings()
Visual Basic
Public Function CreateQuerySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

A new QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetConfigurationList Method

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..GetConfigurationList Method
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the configuration list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TConfigurationObject> GetConfigurationList()
Visual Basic
Public Function GetConfigurationList As ReadOnlyCollection(Of TConfigurationObject)

Return Value

A list of configuration objects matching the filter and sort specified by the QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> passed to StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)).

Remarks

If an object in the returned configuration list is of the type EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> and the object's settings are going to be modified, PrepareForEdit()()()() must be called first. Once the object's settings have been modified, use Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) to commit the setting modifications to the server. Alternatively CancelEdit()()()() can be called to cancel any setting modifications.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The specified object is not being cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))


StartCaching Method

[image] [image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching Method
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts caching the specified configuration objects.

Overload List

 | Name | Description
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartCaching Method

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching Method
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCaching()
Visual Basic
Public Sub StartCaching

Remarks

The default values use a dynamic limit to return all ids and display names that the current user has view access to. This list is sorted ascending by display name.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCaching Overload
ININ.IceLib.Configuration Namespace


StartCaching Method (QuerySettings(TConfigurationObject, TPropertyEnum))

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching Method (QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>)
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts caching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCaching(
    QuerySettings<TConfigurationObject, TPropertyEnum> querySettings
)
Visual Basic
Public Sub StartCaching ( _
    querySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum) _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..QuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object."

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCaching Overload
ININ.IceLib.Configuration Namespace


StartCachingAsync Method

[image] [image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync Method
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts caching the specified configuration objects.

Overload List

 | Name | Description
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartCachingAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync Method (AsyncCompletedEventHandler, Object)
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCachingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartCachingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

The default values use a dynamic limit to return all ids and display names that the current user has view access to. This list is sorted ascending by display name.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCachingAsync Overload
ININ.IceLib.Configuration Namespace


StartCachingAsync Method (QuerySettings(TConfigurationObject, TPropertyEnum), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCachingAsync Method (QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, AsyncCompletedEventHandler, Object)
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts caching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartCachingAsync(
    QuerySettings<TConfigurationObject, TPropertyEnum> querySettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartCachingAsync ( _
    querySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..QuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object."
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartCachingAsync Overload
ININ.IceLib.Configuration Namespace


StopCaching Method

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StopCaching Method
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Stops caching the configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopCaching()
Visual Basic
Public Sub StopCaching

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationList(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager.
Public property | IsCaching | Gets a value indicating whether this instance is cached.
Public property | IsWatching | Gets a value indicating whether this instance is watched.
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationManager Property

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationManager Property
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the configuration manager.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationManager ConfigurationManager { get; }
Visual Basic
Public ReadOnly Property ConfigurationManager As ConfigurationManager
    Get

Field Value

The configuration manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsCaching Property

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IsCaching Property
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this instance is cached.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsCaching { get; }
Visual Basic
Public ReadOnly Property IsCaching As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this cached is caching; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsWatching Property

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IsWatching Property
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this instance is watched.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching { get; }
Visual Basic
Public ReadOnly Property IsWatching As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MoreResultsAvailable Property

[image]

IceLib Technical Reference
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MoreResultsAvailable Property
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether more results were available.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool MoreResultsAvailable { get; }
Visual Basic
Public ReadOnly Property MoreResultsAvailable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if more results were available; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationManager Class

[image]

IceLib Technical Reference
ConfigurationManager Class
Members Example See Also Send Feedback
The ConfigurationManager class provides access to IC configuration and administration information for many IC objects, such as users, roles, prompts, and workgroups.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationManager
Visual Basic
Public Class ConfigurationManager

Examples

The IceLib SDK includes example application references to the ConfigurationManager class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 146, in UserRoleConfigurationViewModel.#ctor
 | UserRoleConfigurationViewModel._ConfigurationManager

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationManager Members
ININ.IceLib.Configuration Namespace


ConfigurationManager Members

[image] [image]

IceLib Technical Reference
ConfigurationManager Members
ConfigurationManager Class Methods Fields Properties See Also Send Feedback

The ConfigurationManager type exposes the following members.

Methods

 | Name | Description
Public method | BeginTransaction | Begins a configuration transaction.
Public method | BeginTransactionAsync | Asynchronously begins a configuration transaction.
Public method | EndTransaction | Ends the configuration transaction.
Public method | EndTransactionAsync | Ends the configuration transaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a ConfigurationManager for the Session passed in.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoTransactionId | A transaction ID that represents no transaction.

Properties

 | Name | Description
Public property | Session | Gets the Session with which this ConfigurationManager is associated.

See Also

ConfigurationManager Class
ININ.IceLib.Configuration Namespace


ConfigurationManager Fields

[image] [image]

IceLib Technical Reference
ConfigurationManager Fields
ConfigurationManager Class See Also Send Feedback

The ConfigurationManager type exposes the following members.

Fields

Name | Description
NoTransactionId | A transaction ID that represents no transaction.

See Also

ConfigurationManager Class
ININ.IceLib.Configuration Namespace


NoTransactionId Field

[image]

IceLib Technical Reference
ConfigurationManager..::..NoTransactionId Field
ConfigurationManager Class See Also Send Feedback
A transaction ID that represents no transaction.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int NoTransactionId
Visual Basic
Public Const NoTransactionId As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace


ConfigurationManager Methods

[image] [image]

IceLib Technical Reference
ConfigurationManager Methods
ConfigurationManager Class See Also Send Feedback

The ConfigurationManager type exposes the following members.

Methods

 | Name | Description
Public method | BeginTransaction | Begins a configuration transaction.
Public method | BeginTransactionAsync | Asynchronously begins a configuration transaction.
Public method | EndTransaction | Ends the configuration transaction.
Public method | EndTransactionAsync | Ends the configuration transaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a ConfigurationManager for the Session passed in.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationManager Class
ININ.IceLib.Configuration Namespace


BeginTransaction Method

[image]

IceLib Technical Reference
ConfigurationManager..::..BeginTransaction Method
ConfigurationManager Class See Also Send Feedback
Begins a configuration transaction.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int BeginTransaction()
Visual Basic
Public Function BeginTransaction As Integer

Return Value

The transaction ID.

Remarks

The transaction ID can be set on supporting configuration objects by calling the appropriate SetTransactionId() method. If a transaction ID is set, notifications for watched UserConfiguration objects will be suspended until EndTransaction(Int32) is called. If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained.

Currently, the DefaultUserConfiguration, UserConfiguration, RoleConfiguration, and WorkgroupConfiguration objects are the only ones that support using transactions. Additionally, the AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32) method also supports transactions.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace
DefaultUserConfiguration..::..SetTransactionId(Int32)
UserConfiguration..::..SetTransactionId(Int32)
RoleConfiguration..::..SetTransactionId(Int32)
WorkgroupConfiguration..::..SetTransactionId(Int32)
AccessControlGroup..::..AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32)


BeginTransactionAsync Method

[image]

IceLib Technical Reference
ConfigurationManager..::..BeginTransactionAsync Method
ConfigurationManager Class See Also Send Feedback
Asynchronously begins a configuration transaction.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void BeginTransactionAsync(
    EventHandler<BeginTransactionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub BeginTransactionAsync ( _
    completedCallback As EventHandler(Of BeginTransactionCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' BeginTransactionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

The transaction ID can be set on supporting configuration objects by calling the appropriate SetTransactionId() method. If a transaction ID is set, notifications for watched UserConfiguration objects will be suspended until EndTransaction(Int32) is called. If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained.

Currently, the DefaultUserConfiguration, UserConfiguration, RoleConfiguration, and WorkgroupConfiguration objects are the only ones that support using transactions. Additionally, the AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32) method also supports transactions.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace
DefaultUserConfiguration..::..SetTransactionId(Int32)
UserConfiguration..::..SetTransactionId(Int32)
RoleConfiguration..::..SetTransactionId(Int32)
WorkgroupConfiguration..::..SetTransactionId(Int32)
AccessControlGroup..::..AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32)


EndTransaction Method

[image]

IceLib Technical Reference
ConfigurationManager..::..EndTransaction Method
ConfigurationManager Class See Also Send Feedback
Ends the configuration transaction.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EndTransaction(
    int transactionId
)
Visual Basic
Public Sub EndTransaction ( _
    transactionId As Integer _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ArgumentOutOfRangeException | transactionId is less than or equal to zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace
DefaultUserConfiguration..::..SetTransactionId(Int32)
UserConfiguration..::..SetTransactionId(Int32)
RoleConfiguration..::..SetTransactionId(Int32)
WorkgroupConfiguration..::..SetTransactionId(Int32)
AccessControlGroup..::..AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32)


EndTransactionAsync Method

[image]

IceLib Technical Reference
ConfigurationManager..::..EndTransactionAsync Method
ConfigurationManager Class See Also Send Feedback
Ends the configuration transaction.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EndTransactionAsync(
    int transactionId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EndTransactionAsync ( _
    transactionId As Integer, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Valid values can be obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained.

A call to this method will cause notifications for watched UserConfiguration objects to be fired for all changes that would have affected a watched UserConfiguration object made while inside the transaction.

Currently, the DefaultUserConfiguration, UserConfiguration, RoleConfiguration, and WorkgroupConfiguration objects are the only ones that support using transactions. Additionally, the AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32) method also supports transactions.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ArgumentOutOfRangeException | transactionId is less than or equal to zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace
DefaultUserConfiguration..::..SetTransactionId(Int32)
UserConfiguration..::..SetTransactionId(Int32)
RoleConfiguration..::..SetTransactionId(Int32)
WorkgroupConfiguration..::..SetTransactionId(Int32)
AccessControlGroup..::..AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32)


GetInstance Method

[image]

IceLib Technical Reference
ConfigurationManager..::..GetInstance Method
ConfigurationManager Class Example See Also Send Feedback
Gets a ConfigurationManager for the Session passed in.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ConfigurationManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As ConfigurationManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which the ConfigurationManager is associated.

Return Value

The ConfigurationManager.

Examples

The IceLib SDK includes example application references to the GetInstance method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 146, in UserRoleConfigurationViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace


ConfigurationManager Properties

[image] [image]

IceLib Technical Reference
ConfigurationManager Properties
ConfigurationManager Class See Also Send Feedback

The ConfigurationManager type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session with which this ConfigurationManager is associated.

See Also

ConfigurationManager Class
ININ.IceLib.Configuration Namespace


Session Property

[image]

IceLib Technical Reference
ConfigurationManager..::..Session Property
ConfigurationManager Class See Also Send Feedback
Gets the Session with which this ConfigurationManager is associated.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationManager Class
ConfigurationManager Members
ININ.IceLib.Configuration Namespace


ConfigurationObject Class

[image]

IceLib Technical Reference
ConfigurationObject Class
Members See Also Send Feedback
Represents a configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ConfigurationObject
Visual Basic
Public MustInherit Class ConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationObject Members
ININ.IceLib.Configuration Namespace


ConfigurationObject Members

[image] [image]

IceLib Technical Reference
ConfigurationObject Members
ConfigurationObject Class Methods Properties See Also Send Feedback

The ConfigurationObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object.

See Also

ConfigurationObject Class
ININ.IceLib.Configuration Namespace


ConfigurationObject Methods

[image] [image]

IceLib Technical Reference
ConfigurationObject Methods
ConfigurationObject Class See Also Send Feedback

The ConfigurationObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ConfigurationObject Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ConfigurationObject..::..ToString Method
ConfigurationObject Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationObject Class
ConfigurationObject Members
ININ.IceLib.Configuration Namespace


ConfigurationObject Properties

[image] [image]

IceLib Technical Reference
ConfigurationObject Properties
ConfigurationObject Class See Also Send Feedback

The ConfigurationObject type exposes the following members.

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object.

See Also

ConfigurationObject Class
ININ.IceLib.Configuration Namespace


IsNewObject Property

[image]

IceLib Technical Reference
ConfigurationObject..::..IsNewObject Property
ConfigurationObject Class See Also Send Feedback
Gets a value indicating whether this object is a new object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsNewObject { get; }
Visual Basic
Public ReadOnly Property IsNewObject As Boolean
    Get

Field Value

true if this object is a new object; otherwise, false.

Remarks

If this value is false, attempting to set a configuration property on this configuration object that has the IsCreateOnly property set to true, will result in a NotSupportedException to be thrown.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ConfigurationObject Class
ConfigurationObject Members
ININ.IceLib.Configuration Namespace


ConfigurationObjectChangesEventArgs(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Event arguments detailing the changes to a watched configuration object type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationObjectChangesEventArgs<TConfigurationObject, TPropertyEnum> : EventArgs
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class ConfigurationObjectChangesEventArgs(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New}) _
    Inherits EventArgs

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enum.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Configuration..::..ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationObjectChangesEventArgs(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ObjectsChanged | Gets the configuration objects that were changed.

See Also

ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationObjectChangesEventArgs(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationObjectChangesEventArgs(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ObjectsChanged | Gets the configuration objects that were changed.

See Also

ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ObjectsChanged Property

[image]

IceLib Technical Reference
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ObjectsChanged Property
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the configuration objects that were changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<TConfigurationObject, ReadOnlyCollection<TPropertyEnum>> ObjectsChanged { get; }
Visual Basic
Public ReadOnly Property ObjectsChanged As IDictionary(Of TConfigurationObject, ReadOnlyCollection(Of TPropertyEnum))
    Get

Field Value

The changed configuration objects.

Remarks

The dictionary is keyed by the configuration objects that changed, and the value of each key is the collection of properties that changed for that configuration object. Only the properties in this collection will be available in the keyed configuration object. In order to view other properties that were not part of this notification, a call to GetConfigurationList()()()() should be made to get the current state of all of the watched properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ConfigurationObjectChangesEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationProperty(TPropertyEnum) Class

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a configuration property value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ConfigurationProperty<TPropertyEnum> : IEditable,
    IEditableViaProxy, IDeepCloneable, IConfigurationObjectListener, IConfigurationPropertyProvider
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class ConfigurationProperty(Of TPropertyEnum As {Structure, New}) _
    Implements IEditable, IEditableViaProxy, IDeepCloneable, IConfigurationObjectListener,  _
    IConfigurationPropertyProvider

Type Parameters

TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationProperty(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> | Initializes a new instance of the ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | IsReadOnly | Gets a value indicating whether this property is read only.
Public property | PropertyEnum | Gets the property enumeration.
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.)

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationProperty(TPropertyEnum) Constructor

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Constructor
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ConfigurationProperty(
    ConfigurationProperty<TPropertyEnum> copy
)
Visual Basic
Protected Sub New ( _
    copy As ConfigurationProperty(Of TPropertyEnum) _
)

Parameters

copy
Type: ININ.IceLib.Configuration..::..ConfigurationProperty <(Of <(<' TPropertyEnum >)>)>
The copy.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationProperty(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Methods
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


Equals Method

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..Equals Method
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..GetHashCode Method
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsValid Method

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..IsValid Method
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsValid(
    out string displayMessage
)
Visual Basic
Public Function IsValid ( _
    <OutAttribute> ByRef displayMessage As String _
) As Boolean

Parameters

displayMessage
Type: System..::..String%
The display message, if not valid; otherwise, an empty string.

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Note that the validators are only available if GetValidators()()()() or GetValidatorsAsync(EventHandler<(Of <<'(GetValidatorsCompletedEventArgs<(Of <<'(TPropertyEnum>)>>)>)>>), Object) has been called.
The Validators will not be automatically evaluated until the data is committed, but IsValid(String%) can be used to test the current value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidators()()()()
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..Validators


ConfigurationProperty(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Properties
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | IsReadOnly | Gets a value indicating whether this property is read only.
Public property | PropertyEnum | Gets the property enumeration.
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.)

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


IsCreateOnly Property

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..IsCreateOnly Property
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this property is only valid for create.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsCreateOnly { get; internal set; }
Visual Basic
Public Property IsCreateOnly As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this property is only valid for create; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

If this property is create only, attempting to set it on a configuration object that has it's IsNewObject property set to false, will result in a NotSupportedException to be thrown.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsEditable Property

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..IsEditable Property
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEditable..::..IsEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IsReadOnly Property

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..IsReadOnly Property
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets a value indicating whether this property is read only.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsReadOnly { get; internal set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this property is read only; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

If this property is read only, attempting to set it will result in a NotSupportedException to be thrown.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PropertyEnum Property

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..PropertyEnum Property
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the property enumeration.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TPropertyEnum PropertyEnum { get; }
Visual Basic
Public ReadOnly Property PropertyEnum As TPropertyEnum
    Get

Field Value

The property enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Validators Property

[image]

IceLib Technical Reference
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..Validators Property
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Validator> Validators { get; }
Visual Basic
Public ReadOnly Property Validators As ReadOnlyCollection(Of Validator)
    Get

Field Value

The validators, if any, for this property.

Remarks

Note
Note that the validators are only available if GetValidators()()()() or GetValidatorsAsync(EventHandler<(Of <<'(GetValidatorsCompletedEventArgs<(Of <<'(TPropertyEnum>)>>)>)>>), Object) has been called.
The Validators will not be automatically evaluated until the data is committed, but IsValid(String%) can be used to test the current value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidators()()()()
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..IsValid(String%)


ConfigurationReferenceDetails Class

[image]

IceLib Technical Reference
ConfigurationReferenceDetails Class
Members See Also Send Feedback
Represents details about a configuration reference.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationReferenceDetails
Visual Basic
Public Class ConfigurationReferenceDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationReferenceDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceDetails Members
ININ.IceLib.Configuration Namespace


ConfigurationReferenceDetails Members

[image] [image]

IceLib Technical Reference
ConfigurationReferenceDetails Members
ConfigurationReferenceDetails Class Methods Properties See Also Send Feedback

The ConfigurationReferenceDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID.
Public property | ReferenceList | Gets the reference list.

See Also

ConfigurationReferenceDetails Class
ININ.IceLib.Configuration Namespace


ConfigurationReferenceDetails Methods

[image] [image]

IceLib Technical Reference
ConfigurationReferenceDetails Methods
ConfigurationReferenceDetails Class See Also Send Feedback

The ConfigurationReferenceDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationReferenceDetails Class
ININ.IceLib.Configuration Namespace


ConfigurationReferenceDetails Properties

[image] [image]

IceLib Technical Reference
ConfigurationReferenceDetails Properties
ConfigurationReferenceDetails Class See Also Send Feedback

The ConfigurationReferenceDetails type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID.
Public property | ReferenceList | Gets the reference list.

See Also

ConfigurationReferenceDetails Class
ININ.IceLib.Configuration Namespace


ConfigurationId Property

[image]

IceLib Technical Reference
ConfigurationReferenceDetails..::..ConfigurationId Property
ConfigurationReferenceDetails Class See Also Send Feedback
Gets the configuration ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId ConfigurationId { get; }
Visual Basic
Public ReadOnly Property ConfigurationId As ConfigurationId
    Get

Field Value

The configuration ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceDetails Class
ConfigurationReferenceDetails Members
ININ.IceLib.Configuration Namespace


ReferenceList Property

[image]

IceLib Technical Reference
ConfigurationReferenceDetails..::..ReferenceList Property
ConfigurationReferenceDetails Class See Also Send Feedback
Gets the reference list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TypedReference> ReferenceList { get; }
Visual Basic
Public ReadOnly Property ReferenceList As ReadOnlyCollection(Of TypedReference)
    Get

Field Value

The reference list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceDetails Class
ConfigurationReferenceDetails Members
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Class

[image]

IceLib Technical Reference
ConfigurationReferenceException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when an operation is prevented due to references by other objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ConfigurationReferenceException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ConfigurationReferenceException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested operation cannot be performed due to references by other configuration objects.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Configuration..::..ConfigurationReferenceException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Members
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Members

[image] [image]

IceLib Technical Reference
ConfigurationReferenceException Members
ConfigurationReferenceException Class Constructors Methods Properties Events See Also Send Feedback

The ConfigurationReferenceException type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationReferenceException()()()() | Initializes a new instance of the ConfigurationReferenceException class with default settings.
Public method | ConfigurationReferenceException(CultureInfo) | Initializes a new instance of the ConfigurationReferenceException class with default settings.
Public method | ConfigurationReferenceException(CultureInfo, ConfigurationReferenceDetails) | Initializes a new instance of the ConfigurationReferenceException class with a specified cache value.
Protected method | ConfigurationReferenceException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationReferenceException class with a specified error message.
Public method | ConfigurationReferenceException(CultureInfo, ConfigurationReferenceDetails, Exception) | Initializes a new instance of the ConfigurationReferenceException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | ConfigurationReferenceDetails | Gets the reference details.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationReferenceException Class
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Constructor

[image] [image]

IceLib Technical Reference
ConfigurationReferenceException Constructor
ConfigurationReferenceException Class See Also Send Feedback
Initializes a new instance of the ConfigurationReferenceException class.

Overload List

 | Name | Description
Public method | ConfigurationReferenceException()()()() | Initializes a new instance of the ConfigurationReferenceException class with default settings.
Public method | ConfigurationReferenceException(CultureInfo) | Initializes a new instance of the ConfigurationReferenceException class with default settings.
Public method | ConfigurationReferenceException(CultureInfo, ConfigurationReferenceDetails) | Initializes a new instance of the ConfigurationReferenceException class with a specified cache value.
Protected method | ConfigurationReferenceException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationReferenceException class with a specified error message.
Public method | ConfigurationReferenceException(CultureInfo, ConfigurationReferenceDetails, Exception) | Initializes a new instance of the ConfigurationReferenceException class with a specified error message.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Constructor

[image]

IceLib Technical Reference
ConfigurationReferenceException Constructor
ConfigurationReferenceException Class See Also Send Feedback
Initializes a new instance of the ConfigurationReferenceException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationReferenceException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ConfigurationReferenceException Overload
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ConfigurationReferenceException Constructor (CultureInfo)
ConfigurationReferenceException Class See Also Send Feedback
Initializes a new instance of the ConfigurationReferenceException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationReferenceException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ConfigurationReferenceException Overload
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Constructor (CultureInfo, ConfigurationReferenceDetails)

[image]

IceLib Technical Reference
ConfigurationReferenceException Constructor (CultureInfo, ConfigurationReferenceDetails)
ConfigurationReferenceException Class See Also Send Feedback
Initializes a new instance of the ConfigurationReferenceException class with a specified cache value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationReferenceException(
    CultureInfo cultureInfo,
    ConfigurationReferenceDetails configurationReferenceDetails
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    configurationReferenceDetails As ConfigurationReferenceDetails _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
configurationReferenceDetails
Type: ININ.IceLib.Configuration..::..ConfigurationReferenceDetails
The reference details.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ConfigurationReferenceException Overload
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
ConfigurationReferenceException Constructor (SerializationInfo, StreamingContext)
ConfigurationReferenceException Class See Also Send Feedback
Initializes a new instance of the ConfigurationReferenceException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ConfigurationReferenceException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ConfigurationReferenceException Overload
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Constructor (CultureInfo, ConfigurationReferenceDetails, Exception)

[image]

IceLib Technical Reference
ConfigurationReferenceException Constructor (CultureInfo, ConfigurationReferenceDetails, Exception)
ConfigurationReferenceException Class See Also Send Feedback
Initializes a new instance of the ConfigurationReferenceException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationReferenceException(
    CultureInfo cultureInfo,
    ConfigurationReferenceDetails configurationReferenceDetails,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    configurationReferenceDetails As ConfigurationReferenceDetails, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
configurationReferenceDetails
Type: ININ.IceLib.Configuration..::..ConfigurationReferenceDetails
The reference details.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ConfigurationReferenceException Overload
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Methods

[image] [image]

IceLib Technical Reference
ConfigurationReferenceException Methods
ConfigurationReferenceException Class See Also Send Feedback

The ConfigurationReferenceException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationReferenceException Class
ININ.IceLib.Configuration Namespace


GetObjectData Method

[image]

IceLib Technical Reference
ConfigurationReferenceException..::..GetObjectData Method
ConfigurationReferenceException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Properties

[image] [image]

IceLib Technical Reference
ConfigurationReferenceException Properties
ConfigurationReferenceException Class See Also Send Feedback

The ConfigurationReferenceException type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationReferenceDetails | Gets the reference details.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationReferenceException Class
ININ.IceLib.Configuration Namespace


ConfigurationReferenceDetails Property

[image]

IceLib Technical Reference
ConfigurationReferenceException..::..ConfigurationReferenceDetails Property
ConfigurationReferenceException Class See Also Send Feedback
Gets the reference details.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationReferenceDetails ConfigurationReferenceDetails { get; }
Visual Basic
Public ReadOnly Property ConfigurationReferenceDetails As ConfigurationReferenceDetails
    Get

Field Value

The reference details.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationReferenceException Class
ConfigurationReferenceException Members
ININ.IceLib.Configuration Namespace


ConfigurationReferenceException Events

[image] [image]

IceLib Technical Reference
ConfigurationReferenceException Events
ConfigurationReferenceException Class See Also Send Feedback

The ConfigurationReferenceException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationReferenceException Class
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Class

[image]

IceLib Technical Reference
ConfigurationValidationException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when an operation is prevented due to configuration validation issues.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ConfigurationValidationException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class ConfigurationValidationException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested operation cannot be performed due to configuration validation issues.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Configuration..::..ConfigurationValidationException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationException Members
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Members

[image] [image]

IceLib Technical Reference
ConfigurationValidationException Members
ConfigurationValidationException Class Constructors Methods Properties Events See Also Send Feedback

The ConfigurationValidationException type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationValidationException()()()() | Initializes a new instance of the ConfigurationValidationException class with default settings.
Public method | ConfigurationValidationException(CultureInfo) | Initializes a new instance of the ConfigurationValidationException class with default settings.
Protected method | ConfigurationValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationValidationException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | GetValidationIssues<(Of <<'(TPropertyEnum>)>>) | Gets the validation issues.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationValidationException Class
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Constructor

[image] [image]

IceLib Technical Reference
ConfigurationValidationException Constructor
ConfigurationValidationException Class See Also Send Feedback
Initializes a new instance of the ConfigurationValidationException class.

Overload List

 | Name | Description
Public method | ConfigurationValidationException()()()() | Initializes a new instance of the ConfigurationValidationException class with default settings.
Public method | ConfigurationValidationException(CultureInfo) | Initializes a new instance of the ConfigurationValidationException class with default settings.
Protected method | ConfigurationValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigurationValidationException class with a specified error message.

See Also

ConfigurationValidationException Class
ConfigurationValidationException Members
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Constructor

[image]

IceLib Technical Reference
ConfigurationValidationException Constructor
ConfigurationValidationException Class See Also Send Feedback
Initializes a new instance of the ConfigurationValidationException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationValidationException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationException Class
ConfigurationValidationException Members
ConfigurationValidationException Overload
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Constructor (CultureInfo)

[image]

IceLib Technical Reference
ConfigurationValidationException Constructor (CultureInfo)
ConfigurationValidationException Class See Also Send Feedback
Initializes a new instance of the ConfigurationValidationException class with default settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationValidationException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationException Class
ConfigurationValidationException Members
ConfigurationValidationException Overload
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
ConfigurationValidationException Constructor (SerializationInfo, StreamingContext)
ConfigurationValidationException Class See Also Send Feedback
Initializes a new instance of the ConfigurationValidationException class with a specified error message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ConfigurationValidationException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationException Class
ConfigurationValidationException Members
ConfigurationValidationException Overload
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Methods

[image] [image]

IceLib Technical Reference
ConfigurationValidationException Methods
ConfigurationValidationException Class See Also Send Feedback

The ConfigurationValidationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | GetValidationIssues<(Of <<'(TPropertyEnum>)>>) | Gets the validation issues.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ConfigurationValidationException Class
ININ.IceLib.Configuration Namespace


GetObjectData Method

[image]

IceLib Technical Reference
ConfigurationValidationException..::..GetObjectData Method
ConfigurationValidationException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationException Class
ConfigurationValidationException Members
ININ.IceLib.Configuration Namespace


GetValidationIssues(TPropertyEnum) Method

[image]

IceLib Technical Reference
ConfigurationValidationException..::..GetValidationIssues<(Of <(<'TPropertyEnum>)>)> Method
ConfigurationValidationException Class See Also Send Feedback
Gets the validation issues.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ConfigurationValidationIssue<TPropertyEnum>> GetValidationIssues<TPropertyEnum>()
where TPropertyEnum : struct, new()
Visual Basic
Public Function GetValidationIssues(Of TPropertyEnum As {Structure, New}) As ReadOnlyCollection(Of ConfigurationValidationIssue(Of TPropertyEnum))

Type Parameters

TPropertyEnum
The type of the property enumeration.

Return Value

The validation issues.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The specified TPropertyEnum does not match the object for which this exception was thrown.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationException Class
ConfigurationValidationException Members
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Properties

[image] [image]

IceLib Technical Reference
ConfigurationValidationException Properties
ConfigurationValidationException Class See Also Send Feedback

The ConfigurationValidationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ConfigurationValidationException Class
ININ.IceLib.Configuration Namespace


ConfigurationValidationException Events

[image] [image]

IceLib Technical Reference
ConfigurationValidationException Events
ConfigurationValidationException Class See Also Send Feedback

The ConfigurationValidationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ConfigurationValidationException Class
ININ.IceLib.Configuration Namespace


ConfigurationValidationIssue(TPropertyEnum) Class

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a configuration validation issue.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationValidationIssue<TPropertyEnum>
where TPropertyEnum : struct, new()
Visual Basic
Public Class ConfigurationValidationIssue(Of TPropertyEnum As {Structure, New})

Type Parameters

TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationValidationIssue(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DisplayMessage | Gets the display message.
Public property | IssueKey | Gets the issue key.
Public property | PropertyEnum | Gets the property enumeration.
Public property | PropertyValue | Gets the property value.
Public property | Validator | Gets the failed validator.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationValidationIssue(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Methods
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>..::..ToString Method
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationValidationIssue(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Properties
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DisplayMessage | Gets the display message.
Public property | IssueKey | Gets the issue key.
Public property | PropertyEnum | Gets the property enumeration.
Public property | PropertyValue | Gets the property value.
Public property | Validator | Gets the failed validator.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


DisplayMessage Property

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>..::..DisplayMessage Property
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the display message.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayMessage { get; }
Visual Basic
Public ReadOnly Property DisplayMessage As String
    Get

Field Value

The display message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IssueKey Property

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>..::..IssueKey Property
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the issue key.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IssueKey { get; }
Visual Basic
Public ReadOnly Property IssueKey As String
    Get

Field Value

The issue key.

Remarks

This is the dictionary key for properties with a type of Dictionary.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PropertyEnum Property

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>..::..PropertyEnum Property
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the property enumeration.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TPropertyEnum PropertyEnum { get; }
Visual Basic
Public ReadOnly Property PropertyEnum As TPropertyEnum
    Get

Field Value

The property enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PropertyValue Property

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>..::..PropertyValue Property
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the property value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PropertyValue { get; }
Visual Basic
Public ReadOnly Property PropertyValue As String
    Get

Field Value

The property value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Validator Property

[image]

IceLib Technical Reference
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)>..::..Validator Property
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the failed validator.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Validator Validator { get; }
Visual Basic
Public ReadOnly Property Validator As Validator
    Get

Field Value

The failed validator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Class
ConfigurationValidationIssue<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationWatchEventArgs(TConfigurationObject) Class

[image]

IceLib Technical Reference
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class
Members See Also Send Feedback
Event arguments detailing the addition or removal of a watched configuration object type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConfigurationWatchEventArgs<TConfigurationObject> : EventArgs
where TConfigurationObject : ConfigurationObject
Visual Basic
Public Class ConfigurationWatchEventArgs(Of TConfigurationObject As ConfigurationObject) _
    Inherits EventArgs

Type Parameters

TConfigurationObject
The type of the configuration object.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Configuration..::..ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationWatchEventArgs(TConfigurationObject) Members

[image] [image]

IceLib Technical Reference
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Members
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class Methods Properties See Also Send Feedback

The ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ObjectsAffected | Gets the configuration objects that were affected by the event.

See Also

ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationWatchEventArgs(TConfigurationObject) Methods

[image] [image]

IceLib Technical Reference
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Methods
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class See Also Send Feedback

The ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationWatchEventArgs(TConfigurationObject) Properties

[image] [image]

IceLib Technical Reference
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Properties
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class See Also Send Feedback

The ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ObjectsAffected | Gets the configuration objects that were affected by the event.

See Also

ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class
ININ.IceLib.Configuration Namespace


ObjectsAffected Property

[image]

IceLib Technical Reference
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)>..::..ObjectsAffected Property
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class See Also Send Feedback
Gets the configuration objects that were affected by the event.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TConfigurationObject> ObjectsAffected { get; }
Visual Basic
Public ReadOnly Property ObjectsAffected As ReadOnlyCollection(Of TConfigurationObject)
    Get

Field Value

The configuration objects affected by the event.

Remarks

The ConfigurationId property will be available, for configuration objects that support a ConfigurationId property (DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>-derived configuration objects). No other properties will be available for the objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Class
ConfigurationWatchEventArgs<(Of <(<'TConfigurationObject>)>)> Members
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration Class

[image]

IceLib Technical Reference
ContactListSourceConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Contact List Source. A contact list source defines information about where an IC Contact list is located.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactListSourceConfiguration : ListConfigurationObject
Visual Basic
Public Class ContactListSourceConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..ContactListSourceConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfiguration Members
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration Members

[image] [image]

IceLib Technical Reference
ContactListSourceConfiguration Members
ContactListSourceConfiguration Class Methods Properties See Also Send Feedback

The ContactListSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ContactListSourceConfiguration Class
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration Methods

[image] [image]

IceLib Technical Reference
ContactListSourceConfiguration Methods
ContactListSourceConfiguration Class See Also Send Feedback

The ContactListSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ContactListSourceConfiguration Class
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration Properties

[image] [image]

IceLib Technical Reference
ContactListSourceConfiguration Properties
ContactListSourceConfiguration Class See Also Send Feedback

The ContactListSourceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ContactListSourceConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ContactListSourceConfiguration..::..StandardProperties Property
ContactListSourceConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ContactListSourceConfiguration, ContactListSourceConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ContactListSourceConfiguration, ContactListSourceConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfiguration Class
ContactListSourceConfiguration Members
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ContactListSourceConfiguration..::..Property Enumeration
ContactListSourceConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration.Rights Class

[image]

IceLib Technical Reference
ContactListSourceConfiguration..::..Rights Class
ContactListSourceConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ContactListSourceConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ContactListSourceConfiguration..::..Rights Members
ContactListSourceConfiguration..::..Rights Class Properties See Also Send Feedback

The ContactListSourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ContactListSourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ContactListSourceConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ContactListSourceConfiguration..::..Rights Properties
ContactListSourceConfiguration..::..Rights Class See Also Send Feedback

The ContactListSourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ContactListSourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ContactListSourceConfiguration..::..Rights..::..Admin Property
ContactListSourceConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ContactListSourceConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ContactListSourceConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfiguration..::..Rights Class
ContactListSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ContactListSources


View Property

[image]

IceLib Technical Reference
ContactListSourceConfiguration..::..Rights..::..View Property
ContactListSourceConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ContactListSourceConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ContactListSourceConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfiguration..::..Rights Class
ContactListSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewGeneralDirectories


ContactListSourceConfigurationList Class

[image]

IceLib Technical Reference
ContactListSourceConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ContactListSource configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactListSourceConfigurationList : DynamicConfigurationList<ContactListSourceConfiguration, ContactListSourceConfiguration..::..Property>
Visual Basic
Public Class ContactListSourceConfigurationList _
    Inherits DynamicConfigurationList(Of ContactListSourceConfiguration, ContactListSourceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ContactListSourceConfiguration, ContactListSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ContactListSourceConfiguration, ContactListSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ContactListSourceConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfigurationList Members
ININ.IceLib.Configuration Namespace


ContactListSourceConfigurationList Members

[image] [image]

IceLib Technical Reference
ContactListSourceConfigurationList Members
ContactListSourceConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ContactListSourceConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ContactListSourceConfigurationList | Initializes a new instance of the ContactListSourceConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ContactListSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ContactListSourceConfigurationList Constructor

[image]

IceLib Technical Reference
ContactListSourceConfigurationList Constructor
ContactListSourceConfigurationList Class See Also Send Feedback
Initializes a new instance of the ContactListSourceConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactListSourceConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactListSourceConfigurationList Class
ContactListSourceConfigurationList Members
ININ.IceLib.Configuration Namespace


ContactListSourceConfigurationList Methods

[image] [image]

IceLib Technical Reference
ContactListSourceConfigurationList Methods
ContactListSourceConfigurationList Class See Also Send Feedback

The ContactListSourceConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactListSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ContactListSourceConfigurationList Properties

[image] [image]

IceLib Technical Reference
ContactListSourceConfigurationList Properties
ContactListSourceConfigurationList Class See Also Send Feedback

The ContactListSourceConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ContactListSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ContactListSourceConfigurationList Events

[image] [image]

IceLib Technical Reference
ContactListSourceConfigurationList Events
ContactListSourceConfigurationList Class See Also Send Feedback

The ContactListSourceConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ContactListSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ContainerConfigurationObject Class

[image]

IceLib Technical Reference
ContainerConfigurationObject Class
Members See Also Send Feedback
Represents a container-based configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ContainerConfigurationObject : ConfigurationObject
Visual Basic
Public MustInherit Class ContainerConfigurationObject _
    Inherits ConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..DefaultLocationConfiguration
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..ServerReportConfigurationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ContainerConfigurationObject Members
ININ.IceLib.Configuration Namespace


ContainerConfigurationObject Members

[image] [image]

IceLib Technical Reference
ContainerConfigurationObject Members
ContainerConfigurationObject Class Methods Properties See Also Send Feedback

The ContainerConfigurationObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)

See Also

ContainerConfigurationObject Class
ININ.IceLib.Configuration Namespace


ContainerConfigurationObject Methods

[image] [image]

IceLib Technical Reference
ContainerConfigurationObject Methods
ContainerConfigurationObject Class See Also Send Feedback

The ContainerConfigurationObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ContainerConfigurationObject Class
ININ.IceLib.Configuration Namespace


ContainerConfigurationObject Properties

[image] [image]

IceLib Technical Reference
ContainerConfigurationObject Properties
ContainerConfigurationObject Class See Also Send Feedback

The ContainerConfigurationObject type exposes the following members.

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)

See Also

ContainerConfigurationObject Class
ININ.IceLib.Configuration Namespace


ContainerQuerySettings(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
This class represents settings for a Configuration query for container objects. CreateQuerySettings()()()() can be used to construct an appropriate ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. The Set functions can be used to override default values.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContainerQuerySettings<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class ContainerQuerySettings(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Remarks

The ContainerQuerySettings class is constructed with default values to return the object that the current user has view access to. This query can be customized by calling the set functions. Calling a Set function will replace the existing settings for that item with the specified new values. For example, calling SetPropertiesToRetrieve will replace the existing property list. Calling a set function with nullNothingnullptra null reference (Nothing in Visual Basic) will cause that item to revert to the default values. All set functions return a this pointer to allow for optional fluent syntax. CreateQuerySettings()()()() is provided to allow a simple method to create a default ContainerQuerySettings object that can be further customized.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ContainerQuerySettings(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Initializes a new instance of the ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class, using default settings. CreateQuerySettings()()()() can also be used to construct an appropriate ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. Use the Set... functions to configure this ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Sets the properties that this settings will query.
Public method | SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]) | Sets the properties that this settings will query.
Public method | SetPropertiesToRetrieveToAll | Sets this query to retrieve all properties on the object.
Public method | SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][]) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method | SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>)) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method | SetRightsFilterToAdmin | Sets the rights filter to use the default admin right for this object.
Public method | SetRightsFilterToView | Sets the rights filter to use the default view right for this object.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | PropertiesInQuery | Gets the properties of the object that are to be included in the query results.
Public property | RightsFilters | Gets the list of rights that will filter the search results.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ContainerQuerySettings(TConfigurationObject, TPropertyEnum) Constructor

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Constructor
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class, using default settings. CreateQuerySettings()()()() can also be used to construct an appropriate ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. Use the Set... functions to configure this ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings()
Visual Basic
Public Sub New

Remarks

This constructor will create a default, empty ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ContainerQuerySettings(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Sets the properties that this settings will query.
Public method | SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]) | Sets the properties that this settings will query.
Public method | SetPropertiesToRetrieveToAll | Sets this query to retrieve all properties on the object.
Public method | SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][]) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method | SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>)) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method | SetRightsFilterToAdmin | Sets the rights filter to use the default admin right for this object.
Public method | SetRightsFilterToView | Sets the rights filter to use the default view right for this object.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieve Method

[image] [image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieve Method
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Sets the properties that this settings will query.
Public method | SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]) | Sets the properties that this settings will query.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieve Method (IEnumerable(TPropertyEnum))

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieve Method (IEnumerable<(Of <(<'TPropertyEnum>)>)>)
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the properties that this settings will query.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetPropertiesToRetrieve(
    IEnumerable<TPropertyEnum> properties
)
Visual Basic
Public Function SetPropertiesToRetrieve ( _
    properties As IEnumerable(Of TPropertyEnum) _
) As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The collection of properties to return in the query.

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetPropertiesToRetrieve Overload
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieve Method (TPropertyEnum[])

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieve Method (array<TPropertyEnum>[]()[][])
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the properties that this settings will query.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetPropertiesToRetrieve(
    params TPropertyEnum[] properties
)
Visual Basic
Public Function SetPropertiesToRetrieve ( _
    ParamArray properties As TPropertyEnum() _
) As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

properties
Type: array< TPropertyEnum >[]()[][]
The properties to return in the query.

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetPropertiesToRetrieve Overload
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieveToAll Method

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieveToAll Method
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets this query to retrieve all properties on the object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetPropertiesToRetrieveToAll()
Visual Basic
Public Function SetPropertiesToRetrieveToAll As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetRightsFilter Method

[image] [image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilter Method
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

Overload List

 | Name | Description
Public method | SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][]) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method | SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>)) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetRightsFilter Method (RightsQueryFilter(TConfigurationObject)[])

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilter Method (array<RightsQueryFilter<(Of <(<'TConfigurationObject>)>)>>[]()[][])
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilter(
    params RightsQueryFilter<TConfigurationObject>[] rights
)
Visual Basic
Public Function SetRightsFilter ( _
    ParamArray rights As RightsQueryFilter(Of TConfigurationObject)() _
) As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

rights
Type: array< ININ.IceLib.Configuration..::..RightsQueryFilter <(Of <(<' TConfigurationObject >)>)>>[]()[][]
The pre-constructed rights object. This can be found inside of the individual <TConfigurationObject> class, such as DefaultUserConfiguration..::..Rights or SystemConfiguration..::..Rights.

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the object against. For example, if DefaultUserConfiguration is being queried and Admin is specified, this query will only result in the DefaultUser object if the current user has Admins rights to it. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetRightsFilter Overload
ININ.IceLib.Configuration Namespace


SetRightsFilter Method (IEnumerable(RightsQueryFilter(TConfigurationObject)))

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilter Method (IEnumerable<(Of <(<'RightsQueryFilter<(Of <(<'TConfigurationObject>)>)>>)>)>)
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilter(
    IEnumerable<RightsQueryFilter<TConfigurationObject>> rights
)
Visual Basic
Public Function SetRightsFilter ( _
    rights As IEnumerable(Of RightsQueryFilter(Of TConfigurationObject)) _
) As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

rights
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' RightsQueryFilter <(Of <(<' TConfigurationObject >)>)>>)>)>
The pre-constructed rights object. This can be found inside of the individual <TConfigurationObject> class, such as DefaultUserConfiguration..::..Rights or SystemConfiguration..::..Rights.

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the object against. For example, if DefaultUserConfiguration is being queried and Admin is specified, this query will only result in the DefaultUser object if the current user has Admins rights to it. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetRightsFilter Overload
ININ.IceLib.Configuration Namespace


SetRightsFilterToAdmin Method

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilterToAdmin Method
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the rights filter to use the default admin right for this object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilterToAdmin()
Visual Basic
Public Function SetRightsFilterToAdmin As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the object against. For example, if DefaultUserConfiguration is being queried and Admin is specified, this query will only result in the DefaultUser object if the current user has Admins rights to it. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetRightsFilterToView Method

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilterToView Method
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the rights filter to use the default view right for this object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContainerQuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilterToView()
Visual Basic
Public Function SetRightsFilterToView As ContainerQuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the object against. For example, if DefaultUserConfiguration is being queried and Admin is specified, this query will only result in the DefaultUser object if the current user has Admins rights to it. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ToString Method
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ContainerQuerySettings(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | PropertiesInQuery | Gets the properties of the object that are to be included in the query results.
Public property | RightsFilters | Gets the list of rights that will filter the search results.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


PropertiesInQuery Property

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PropertiesInQuery Property
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the properties of the object that are to be included in the query results.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TPropertyEnum> PropertiesInQuery { get; }
Visual Basic
Public ReadOnly Property PropertiesInQuery As ReadOnlyCollection(Of TPropertyEnum)
    Get

Field Value

The properties in query.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RightsFilters Property

[image]

IceLib Technical Reference
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RightsFilters Property
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the list of rights that will filter the search results.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RightsQueryFilter<TConfigurationObject>> RightsFilters { get; }
Visual Basic
Public ReadOnly Property RightsFilters As ReadOnlyCollection(Of RightsQueryFilter(Of TConfigurationObject))
    Get

Field Value

The rights filter.

Remarks

The rights filters are predefined in the Rights class that belongs to the configuration classes. For example see UserConfiguration..::..Rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ContainerQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateObjectCompletedEventArgs(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Provides data for asynchronous completed events of CreateObjectAsync(EventHandler<(Of <<'(CreateObjectCompletedEventArgs<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)>)>>), Object).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CreateObjectCompletedEventArgs<TConfigurationObject, TPropertyEnum> : AsyncCompletedEventArgs
where TConfigurationObject : EditableListConfigurationObject<TPropertyEnum>
where TPropertyEnum : struct, new()
Visual Basic
Public Class CreateObjectCompletedEventArgs(Of TConfigurationObject As EditableListConfigurationObject(Of TPropertyEnum), TPropertyEnum As {Structure, New}) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration..::..CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateObjectCompletedEventArgs(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | Validators | Gets the configuration object.

See Also

CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CreateObjectCompletedEventArgs(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CreateObjectCompletedEventArgs(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | Validators | Gets the configuration object.

See Also

CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


Validators Property

[image]

IceLib Technical Reference
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Validators Property
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TConfigurationObject Validators { get; }
Visual Basic
Public ReadOnly Property Validators As TConfigurationObject
    Get

Field Value

The configuration object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
CreateObjectCompletedEventArgs<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a custom attribute filter for searching configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomAttributeFilterDefinition<TFilteredObject, TPropertyEnum> : FilterDefinition<TFilteredObject, TPropertyEnum>
where TFilteredObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class CustomAttributeFilterDefinition(Of TFilteredObject As ConfigurationObject, TPropertyEnum As {Structure, New}) _
    Inherits FilterDefinition(Of TFilteredObject, TPropertyEnum)

Type Parameters

TFilteredObject
The type of the filtered object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FilterDefinition <(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(String, String) | Initializes a new instance of the CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.
Public method | CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(String, String, FilterMatchType) | Initializes a new instance of the CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilteredProperty | Gets the filtered property.
Public property | FilterMatchType | Gets the filter match type.
Public property | TargetPropertyValue | Gets the target property value.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Constructor

[image] [image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(String, String) | Initializes a new instance of the CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.
Public method | CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(String, String, FilterMatchType) | Initializes a new instance of the CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Constructor (String, String)

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor (String, String)
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomAttributeFilterDefinition(
    string filteredProperty,
    string targetValue
)
Visual Basic
Public Sub New ( _
    filteredProperty As String, _
    targetValue As String _
)

Parameters

filteredProperty
Type: System..::..String
The filtered property.
targetValue
Type: System..::..String
The target value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Overload
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Constructor (String, String, FilterMatchType)

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor (String, String, FilterMatchType)
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomAttributeFilterDefinition(
    string filteredProperty,
    string targetValue,
    FilterMatchType filterMatchType
)
Visual Basic
Public Sub New ( _
    filteredProperty As String, _
    targetValue As String, _
    filterMatchType As FilterMatchType _
)

Parameters

filteredProperty
Type: System..::..String
The filtered property.
targetValue
Type: System..::..String
The target value.
filterMatchType
Type: ININ.IceLib.Configuration..::..FilterMatchType
The filter match type.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified filterMatchType is not from the FilterMatchType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Overload
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Methods
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..ToString Method
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CustomAttributeFilterDefinition(TFilteredObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Properties
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilteredProperty | Gets the filtered property.
Public property | FilterMatchType | Gets the filter match type.
Public property | TargetPropertyValue | Gets the target property value.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


FilteredProperty Property

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..FilteredProperty Property
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filtered property.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FilteredProperty { get; }
Visual Basic
Public ReadOnly Property FilteredProperty As String
    Get

Field Value

The filtered property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FilterMatchType Property

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..FilterMatchType Property
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilterMatchType FilterMatchType { get; }
Visual Basic
Public ReadOnly Property FilterMatchType As FilterMatchType
    Get

Field Value

The filter match type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


TargetPropertyValue Property

[image]

IceLib Technical Reference
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..TargetPropertyValue Property
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the target property value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object TargetPropertyValue { get; }
Visual Basic
Public ReadOnly Property TargetPropertyValue As Object
    Get

Field Value

The target property value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration Class

[image]

IceLib Technical Reference
CustomButtonConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Custom Button. A custom button can be configured to be specific per interaction type, and optionally display it on the appropriate interaction dialog box(es). The custom button can be shown on the queue toolbar and/or on any one of the interaction dialog boxes (email, chat, call, etc...). Additionally, a button can be configured to apply to an "interaction type" which causes a queue-based custom button to be enabled only when one of the correct interaction types is selected in the queue view.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomButtonConfiguration : EditableListConfigurationObject<CustomButtonConfiguration..::..Property>
Visual Basic
Public Class CustomButtonConfiguration _
    Inherits EditableListConfigurationObject(Of CustomButtonConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' CustomButtonConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..CustomButtonConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfiguration Members
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration Members

[image] [image]

IceLib Technical Reference
CustomButtonConfiguration Members
CustomButtonConfiguration Class Methods Properties See Also Send Feedback

The CustomButtonConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

CustomButtonConfiguration Class
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration Methods

[image] [image]

IceLib Technical Reference
CustomButtonConfiguration Methods
CustomButtonConfiguration Class See Also Send Feedback

The CustomButtonConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

CustomButtonConfiguration Class
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration Properties

[image] [image]

IceLib Technical Reference
CustomButtonConfiguration Properties
CustomButtonConfiguration Class See Also Send Feedback

The CustomButtonConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

CustomButtonConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
CustomButtonConfiguration..::..PropertiesChanged Property
CustomButtonConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<CustomButtonConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of CustomButtonConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfiguration Class
CustomButtonConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
CustomButtonConfiguration..::..StandardProperties Property
CustomButtonConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<CustomButtonConfiguration, CustomButtonConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of CustomButtonConfiguration, CustomButtonConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfiguration Class
CustomButtonConfiguration Members
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration.Property Enumeration

[image]

IceLib Technical Reference
CustomButtonConfiguration..::..Property Enumeration
CustomButtonConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


CustomButtonConfiguration.Rights Class

[image]

IceLib Technical Reference
CustomButtonConfiguration..::..Rights Class
CustomButtonConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..CustomButtonConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
CustomButtonConfiguration..::..Rights Members
CustomButtonConfiguration..::..Rights Class Properties See Also Send Feedback

The CustomButtonConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

CustomButtonConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


CustomButtonConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
CustomButtonConfiguration..::..Rights Properties
CustomButtonConfiguration..::..Rights Class See Also Send Feedback

The CustomButtonConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

CustomButtonConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
CustomButtonConfiguration..::..Rights..::..Admin Property
CustomButtonConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<CustomButtonConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of CustomButtonConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfiguration..::..Rights Class
CustomButtonConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientButtons


View Property

[image]

IceLib Technical Reference
CustomButtonConfiguration..::..Rights..::..View Property
CustomButtonConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<CustomButtonConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of CustomButtonConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfiguration..::..Rights Class
CustomButtonConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientButtons


CustomButtonConfigurationList Class

[image]

IceLib Technical Reference
CustomButtonConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing CustomButton configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomButtonConfigurationList : EditableConfigurationList<CustomButtonConfiguration, CustomButtonConfiguration..::..Property>
Visual Basic
Public Class CustomButtonConfigurationList _
    Inherits EditableConfigurationList(Of CustomButtonConfiguration, CustomButtonConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' CustomButtonConfiguration, CustomButtonConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' CustomButtonConfiguration, CustomButtonConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' CustomButtonConfiguration, CustomButtonConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..CustomButtonConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfigurationList Members
ININ.IceLib.Configuration Namespace


CustomButtonConfigurationList Members

[image] [image]

IceLib Technical Reference
CustomButtonConfigurationList Members
CustomButtonConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The CustomButtonConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | CustomButtonConfigurationList | Initializes a new instance of the CustomButtonConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

CustomButtonConfigurationList Class
ININ.IceLib.Configuration Namespace


CustomButtonConfigurationList Constructor

[image]

IceLib Technical Reference
CustomButtonConfigurationList Constructor
CustomButtonConfigurationList Class See Also Send Feedback
Initializes a new instance of the CustomButtonConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomButtonConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonConfigurationList Class
CustomButtonConfigurationList Members
ININ.IceLib.Configuration Namespace


CustomButtonConfigurationList Methods

[image] [image]

IceLib Technical Reference
CustomButtonConfigurationList Methods
CustomButtonConfigurationList Class See Also Send Feedback

The CustomButtonConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomButtonConfigurationList Class
ININ.IceLib.Configuration Namespace


CustomButtonConfigurationList Properties

[image] [image]

IceLib Technical Reference
CustomButtonConfigurationList Properties
CustomButtonConfigurationList Class See Also Send Feedback

The CustomButtonConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

CustomButtonConfigurationList Class
ININ.IceLib.Configuration Namespace


CustomButtonConfigurationList Events

[image] [image]

IceLib Technical Reference
CustomButtonConfigurationList Events
CustomButtonConfigurationList Class See Also Send Feedback

The CustomButtonConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

CustomButtonConfigurationList Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration Class

[image]

IceLib Technical Reference
DefaultLocationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Default Location for the IC System.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DefaultLocationConfiguration : ContainerConfigurationObject
Visual Basic
Public Class DefaultLocationConfiguration _
    Inherits ContainerConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..DefaultLocationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration Members

[image] [image]

IceLib Technical Reference
DefaultLocationConfiguration Members
DefaultLocationConfiguration Class Methods Properties See Also Send Feedback

The DefaultLocationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

DefaultLocationConfiguration Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration Methods

[image] [image]

IceLib Technical Reference
DefaultLocationConfiguration Methods
DefaultLocationConfiguration Class See Also Send Feedback

The DefaultLocationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

DefaultLocationConfiguration Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration Properties

[image] [image]

IceLib Technical Reference
DefaultLocationConfiguration Properties
DefaultLocationConfiguration Class See Also Send Feedback

The DefaultLocationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

DefaultLocationConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
DefaultLocationConfiguration..::..StandardProperties Property
DefaultLocationConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<DefaultLocationConfiguration, DefaultLocationConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of DefaultLocationConfiguration, DefaultLocationConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfiguration Class
DefaultLocationConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
DefaultLocationConfiguration..::..Property Enumeration
DefaultLocationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration.Rights Class

[image]

IceLib Technical Reference
DefaultLocationConfiguration..::..Rights Class
DefaultLocationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..DefaultLocationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
DefaultLocationConfiguration..::..Rights Members
DefaultLocationConfiguration..::..Rights Class Properties See Also Send Feedback

The DefaultLocationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DefaultLocationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
DefaultLocationConfiguration..::..Rights Properties
DefaultLocationConfiguration..::..Rights Class See Also Send Feedback

The DefaultLocationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DefaultLocationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
DefaultLocationConfiguration..::..Rights..::..Admin Property
DefaultLocationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DefaultLocationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of DefaultLocationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfiguration..::..Rights Class
DefaultLocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultLocationConfiguration


View Property

[image]

IceLib Technical Reference
DefaultLocationConfiguration..::..Rights..::..View Property
DefaultLocationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DefaultLocationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of DefaultLocationConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfiguration..::..Rights Class
DefaultLocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfigurationContainer Class

[image]

IceLib Technical Reference
DefaultLocationConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the default location object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DefaultLocationConfigurationContainer : ConfigurationContainer<DefaultLocationConfiguration, DefaultLocationConfiguration..::..Property>
Visual Basic
Public Class DefaultLocationConfigurationContainer _
    Inherits ConfigurationContainer(Of DefaultLocationConfiguration, DefaultLocationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' DefaultLocationConfiguration, DefaultLocationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DefaultLocationConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfigurationContainer Members

[image] [image]

IceLib Technical Reference
DefaultLocationConfigurationContainer Members
DefaultLocationConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The DefaultLocationConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultLocationConfigurationContainer | Initializes a new instance of the DefaultLocationConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultLocationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfigurationContainer Constructor

[image]

IceLib Technical Reference
DefaultLocationConfigurationContainer Constructor
DefaultLocationConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the DefaultLocationConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DefaultLocationConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultLocationConfigurationContainer Class
DefaultLocationConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
DefaultLocationConfigurationContainer Methods
DefaultLocationConfigurationContainer Class See Also Send Feedback

The DefaultLocationConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultLocationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
DefaultLocationConfigurationContainer Properties
DefaultLocationConfigurationContainer Class See Also Send Feedback

The DefaultLocationConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultLocationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultLocationConfigurationContainer Events

[image] [image]

IceLib Technical Reference
DefaultLocationConfigurationContainer Events
DefaultLocationConfigurationContainer Class See Also Send Feedback

The DefaultLocationConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultLocationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration Class

[image]

IceLib Technical Reference
DefaultStationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Default Station for the IC System. A default station is used to set global options that impact all IC Stations.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DefaultStationConfiguration : EditableContainerConfigurationObject<DefaultStationConfiguration..::..Property>
Visual Basic
Public Class DefaultStationConfiguration _
    Inherits EditableContainerConfigurationObject(Of DefaultStationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' DefaultStationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DefaultStationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration Members

[image] [image]

IceLib Technical Reference
DefaultStationConfiguration Members
DefaultStationConfiguration Class Methods Properties See Also Send Feedback

The DefaultStationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

DefaultStationConfiguration Class
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration Methods

[image] [image]

IceLib Technical Reference
DefaultStationConfiguration Methods
DefaultStationConfiguration Class See Also Send Feedback

The DefaultStationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

DefaultStationConfiguration Class
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration Properties

[image] [image]

IceLib Technical Reference
DefaultStationConfiguration Properties
DefaultStationConfiguration Class See Also Send Feedback

The DefaultStationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

DefaultStationConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
DefaultStationConfiguration..::..PropertiesChanged Property
DefaultStationConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<DefaultStationConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of DefaultStationConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultStationConfiguration Class
DefaultStationConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
DefaultStationConfiguration..::..StandardProperties Property
DefaultStationConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<DefaultStationConfiguration, DefaultStationConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of DefaultStationConfiguration, DefaultStationConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfiguration Class
DefaultStationConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
DefaultStationConfiguration..::..Property Enumeration
DefaultStationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


DefaultStationConfiguration.Rights Class

[image]

IceLib Technical Reference
DefaultStationConfiguration..::..Rights Class
DefaultStationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..DefaultStationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
DefaultStationConfiguration..::..Rights Members
DefaultStationConfiguration..::..Rights Class Properties See Also Send Feedback

The DefaultStationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DefaultStationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
DefaultStationConfiguration..::..Rights Properties
DefaultStationConfiguration..::..Rights Class See Also Send Feedback

The DefaultStationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DefaultStationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
DefaultStationConfiguration..::..Rights..::..Admin Property
DefaultStationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DefaultStationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of DefaultStationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfiguration..::..Rights Class
DefaultStationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultStationConfiguration


View Property

[image]

IceLib Technical Reference
DefaultStationConfiguration..::..Rights..::..View Property
DefaultStationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DefaultStationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of DefaultStationConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfiguration..::..Rights Class
DefaultStationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DefaultStationConfigurationContainer Class

[image]

IceLib Technical Reference
DefaultStationConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the system configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DefaultStationConfigurationContainer : ConfigurationContainer<DefaultStationConfiguration, DefaultStationConfiguration..::..Property>
Visual Basic
Public Class DefaultStationConfigurationContainer _
    Inherits ConfigurationContainer(Of DefaultStationConfiguration, DefaultStationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' DefaultStationConfiguration, DefaultStationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DefaultStationConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DefaultStationConfigurationContainer Members

[image] [image]

IceLib Technical Reference
DefaultStationConfigurationContainer Members
DefaultStationConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The DefaultStationConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultStationConfigurationContainer | Initializes a new instance of the DefaultStationConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultStationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultStationConfigurationContainer Constructor

[image]

IceLib Technical Reference
DefaultStationConfigurationContainer Constructor
DefaultStationConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the DefaultStationConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DefaultStationConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultStationConfigurationContainer Class
DefaultStationConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DefaultStationConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
DefaultStationConfigurationContainer Methods
DefaultStationConfigurationContainer Class See Also Send Feedback

The DefaultStationConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultStationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultStationConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
DefaultStationConfigurationContainer Properties
DefaultStationConfigurationContainer Class See Also Send Feedback

The DefaultStationConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultStationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultStationConfigurationContainer Events

[image] [image]

IceLib Technical Reference
DefaultStationConfigurationContainer Events
DefaultStationConfigurationContainer Class See Also Send Feedback

The DefaultStationConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultStationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration Class

[image]

IceLib Technical Reference
DefaultUserConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Default User for the IC System. A default user is used to set global options that impact all IC Users.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DefaultUserConfiguration : EditableContainerConfigurationObject<DefaultUserConfiguration..::..Property>
Visual Basic
Public Class DefaultUserConfiguration _
    Inherits EditableContainerConfigurationObject(Of DefaultUserConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' DefaultUserConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DefaultUserConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration Members

[image] [image]

IceLib Technical Reference
DefaultUserConfiguration Members
DefaultUserConfiguration Class Methods Properties See Also Send Feedback

The DefaultUserConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | TransactionId | Gets the transaction ID.

See Also

DefaultUserConfiguration Class
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration Methods

[image] [image]

IceLib Technical Reference
DefaultUserConfiguration Methods
DefaultUserConfiguration Class See Also Send Feedback

The DefaultUserConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

DefaultUserConfiguration Class
ININ.IceLib.Configuration Namespace


SetTransactionId Method

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..SetTransactionId Method
DefaultUserConfiguration Class See Also Send Feedback
Sets the transaction ID to use when calling Commit()()()().

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTransactionId(
    int transactionId
)
Visual Basic
Public Sub SetTransactionId ( _
    transactionId As Integer _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.

Remarks

Valid values can be obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained. Setting this value to NoTransactionId will clear the transaction ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | transactionId is less than zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

DefaultUserConfiguration Class
DefaultUserConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration Properties

[image] [image]

IceLib Technical Reference
DefaultUserConfiguration Properties
DefaultUserConfiguration Class See Also Send Feedback

The DefaultUserConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | TransactionId | Gets the transaction ID.

See Also

DefaultUserConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..PropertiesChanged Property
DefaultUserConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<DefaultUserConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of DefaultUserConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DefaultUserConfiguration Class
DefaultUserConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..StandardProperties Property
DefaultUserConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<DefaultUserConfiguration, DefaultUserConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of DefaultUserConfiguration, DefaultUserConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfiguration Class
DefaultUserConfiguration Members
ININ.IceLib.Configuration Namespace


TransactionId Property

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..TransactionId Property
DefaultUserConfiguration Class See Also Send Feedback
Gets the transaction ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TransactionId { get; }
Visual Basic
Public ReadOnly Property TransactionId As Integer
    Get

Remarks

Valid values are obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). Commit()()()() operations called on configuration objects that have a valid transaction ID set will cause notifications for watched UserConfiguration objects that would be affected to be suspended until a call to EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is made with the associated transaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

DefaultUserConfiguration Class
DefaultUserConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration.Property Enumeration

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..Property Enumeration
DefaultUserConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


DefaultUserConfiguration.Rights Class

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..Rights Class
DefaultUserConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..DefaultUserConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
DefaultUserConfiguration..::..Rights Members
DefaultUserConfiguration..::..Rights Class Properties See Also Send Feedback

The DefaultUserConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DefaultUserConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


DefaultUserConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
DefaultUserConfiguration..::..Rights Properties
DefaultUserConfiguration..::..Rights Class See Also Send Feedback

The DefaultUserConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DefaultUserConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..Rights..::..Admin Property
DefaultUserConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DefaultUserConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of DefaultUserConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfiguration..::..Rights Class
DefaultUserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultUserConfiguration


View Property

[image]

IceLib Technical Reference
DefaultUserConfiguration..::..Rights..::..View Property
DefaultUserConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DefaultUserConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of DefaultUserConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfiguration..::..Rights Class
DefaultUserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DefaultUserConfigurationContainer Class

[image]

IceLib Technical Reference
DefaultUserConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the system configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DefaultUserConfigurationContainer : ConfigurationContainer<DefaultUserConfiguration, DefaultUserConfiguration..::..Property>
Visual Basic
Public Class DefaultUserConfigurationContainer _
    Inherits ConfigurationContainer(Of DefaultUserConfiguration, DefaultUserConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' DefaultUserConfiguration, DefaultUserConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DefaultUserConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DefaultUserConfigurationContainer Members

[image] [image]

IceLib Technical Reference
DefaultUserConfigurationContainer Members
DefaultUserConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The DefaultUserConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultUserConfigurationContainer | Initializes a new instance of the DefaultUserConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultUserConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultUserConfigurationContainer Constructor

[image]

IceLib Technical Reference
DefaultUserConfigurationContainer Constructor
DefaultUserConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the DefaultUserConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DefaultUserConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DefaultUserConfigurationContainer Class
DefaultUserConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DefaultUserConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
DefaultUserConfigurationContainer Methods
DefaultUserConfigurationContainer Class See Also Send Feedback

The DefaultUserConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefaultUserConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultUserConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
DefaultUserConfigurationContainer Properties
DefaultUserConfigurationContainer Class See Also Send Feedback

The DefaultUserConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultUserConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DefaultUserConfigurationContainer Events

[image] [image]

IceLib Technical Reference
DefaultUserConfigurationContainer Events
DefaultUserConfigurationContainer Class See Also Send Feedback

The DefaultUserConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DefaultUserConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DetailedInheritableConfigurationProperty(TPropertyEnum, TValue) Class

[image]

IceLib Technical Reference
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
Members See Also Send Feedback
Represents an inheritable configuration property with extended details.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DetailedInheritableConfigurationProperty<TPropertyEnum, TValue> : InheritableConfigurationProperty<TPropertyEnum, TValue>
where TPropertyEnum : struct, new()
Visual Basic
Public Class DetailedInheritableConfigurationProperty(Of TPropertyEnum As {Structure, New}, TValue) _
    Inherits InheritableConfigurationProperty(Of TPropertyEnum, TValue)

Type Parameters

TPropertyEnum
The type of the property enumeration.
TValue
The type of the value.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationProperty <(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..GeneralConfigurationProperty <(Of <(<'TPropertyEnum, TValue>)>)>
ININ.IceLib.Configuration..::..InheritableConfigurationProperty <(Of <(<'TPropertyEnum, TValue>)>)>
ININ.IceLib.Configuration..::..DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


DetailedInheritableConfigurationProperty(TPropertyEnum, TValue) Members

[image] [image]

IceLib Technical Reference
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> | Initializes a new instance of the DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> class.

Methods

 | Name | Description
Public method | ClearPropertyValue | Clears the property value. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public method | GetInheritedDetails<(Of <<'(TConfigurationObject>)>>) | Gets the inherited details. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public method | IsValueDefined | Determines whether the value stored directly with this object is defined on the server or not. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

Properties

 | Name | Description
Public property | EffectiveValue | Gets the effective value of this property. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public property | InheritedValue | Gets the inherited value. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public property | InheritedValueDetails | Gets the inherited value.
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsReadOnly | Gets a value indicating whether this property is read only. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | PropertyEnum | Gets the property enumeration. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Value | Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.) (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

See Also

DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


DetailedInheritableConfigurationProperty(TPropertyEnum, TValue) Constructor

[image]

IceLib Technical Reference
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Constructor
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Initializes a new instance of the DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected DetailedInheritableConfigurationProperty(
    DetailedInheritableConfigurationProperty<TPropertyEnum, TValue> copy
)
Visual Basic
Protected Sub New ( _
    copy As DetailedInheritableConfigurationProperty(Of TPropertyEnum, TValue) _
)

Parameters

copy
Type: ININ.IceLib.Configuration..::..DetailedInheritableConfigurationProperty <(Of <(<' TPropertyEnum, TValue >)>)>
The copy.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


DetailedInheritableConfigurationProperty(TPropertyEnum, TValue) Methods

[image] [image]

IceLib Technical Reference
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Methods
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback

The DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ClearPropertyValue | Clears the property value. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public method | GetInheritedDetails<(Of <<'(TConfigurationObject>)>>) | Gets the inherited details. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public method | IsValueDefined | Determines whether the value stored directly with this object is defined on the server or not. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

See Also

DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


DetailedInheritableConfigurationProperty(TPropertyEnum, TValue) Properties

[image] [image]

IceLib Technical Reference
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Properties
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback

The DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | EffectiveValue | Gets the effective value of this property. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public property | InheritedValue | Gets the inherited value. (Inherited from InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)
Public property | InheritedValueDetails | Gets the inherited value.
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsReadOnly | Gets a value indicating whether this property is read only. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | PropertyEnum | Gets the property enumeration. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Value | Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.) (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

See Also

DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


InheritedValueDetails Property

[image]

IceLib Technical Reference
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..InheritedValueDetails Property
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Gets the inherited value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritedValueDetails<TValue> InheritedValueDetails { get; }
Visual Basic
Public ReadOnly Property InheritedValueDetails As InheritedValueDetails(Of TValue)
    Get

Field Value

The inherited value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration Class

[image]

IceLib Technical Reference
DnisMappingsConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for the Dnis Mappings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DnisMappingsConfiguration : EditableContainerConfigurationObject<DnisMappingsConfiguration..::..Property>
Visual Basic
Public Class DnisMappingsConfiguration _
    Inherits EditableContainerConfigurationObject(Of DnisMappingsConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' DnisMappingsConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DnisMappingsConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

DnisMappingsConfiguration Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration Members

[image] [image]

IceLib Technical Reference
DnisMappingsConfiguration Members
DnisMappingsConfiguration Class Methods Properties See Also Send Feedback

The DnisMappingsConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | RoutingTable | Provides access to the property representing the routing table (use Property.RoutingTable).

See Also

DnisMappingsConfiguration Class
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration Methods

[image] [image]

IceLib Technical Reference
DnisMappingsConfiguration Methods
DnisMappingsConfiguration Class See Also Send Feedback

The DnisMappingsConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

DnisMappingsConfiguration Class
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration Properties

[image] [image]

IceLib Technical Reference
DnisMappingsConfiguration Properties
DnisMappingsConfiguration Class See Also Send Feedback

The DnisMappingsConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | RoutingTable | Provides access to the property representing the routing table (use Property.RoutingTable).

See Also

DnisMappingsConfiguration Class
ININ.IceLib.Configuration Namespace


RoutingTable Property

[image]

IceLib Technical Reference
DnisMappingsConfiguration..::..RoutingTable Property
DnisMappingsConfiguration Class See Also Send Feedback
Provides access to the property representing the routing table (use Property.RoutingTable).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<DnisMappingsConfiguration..::..Property, Collection<RoutingTableEntrySettings>> RoutingTable { get; }
Visual Basic
Public ReadOnly Property RoutingTable As GeneralConfigurationProperty(Of DnisMappingsConfiguration..::..Property, Collection(Of RoutingTableEntrySettings))
    Get

Field Value

The property representing the routing table.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DnisMappingsConfiguration Class
DnisMappingsConfiguration Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration.Property Enumeration

[image]

IceLib Technical Reference
DnisMappingsConfiguration..::..Property Enumeration
DnisMappingsConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
RoutingTable | 0 | Represents the RoutingTable property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration.Rights Class

[image]

IceLib Technical Reference
DnisMappingsConfiguration..::..Rights Class
DnisMappingsConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..DnisMappingsConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DnisMappingsConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
DnisMappingsConfiguration..::..Rights Members
DnisMappingsConfiguration..::..Rights Class Properties See Also Send Feedback

The DnisMappingsConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DnisMappingsConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


DnisMappingsConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
DnisMappingsConfiguration..::..Rights Properties
DnisMappingsConfiguration..::..Rights Class See Also Send Feedback

The DnisMappingsConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

DnisMappingsConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
DnisMappingsConfiguration..::..Rights..::..Admin Property
DnisMappingsConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DnisMappingsConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of DnisMappingsConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DnisMappingsConfiguration..::..Rights Class
DnisMappingsConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DnisMappingsConfiguration


View Property

[image]

IceLib Technical Reference
DnisMappingsConfiguration..::..Rights..::..View Property
DnisMappingsConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<DnisMappingsConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of DnisMappingsConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DnisMappingsConfiguration..::..Rights Class
DnisMappingsConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfigurationContainer Class

[image]

IceLib Technical Reference
DnisMappingsConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the system configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DnisMappingsConfigurationContainer : ConfigurationContainer<DnisMappingsConfiguration, DnisMappingsConfiguration..::..Property>
Visual Basic
Public Class DnisMappingsConfigurationContainer _
    Inherits ConfigurationContainer(Of DnisMappingsConfiguration, DnisMappingsConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' DnisMappingsConfiguration, DnisMappingsConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DnisMappingsConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

DnisMappingsConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfigurationContainer Members

[image] [image]

IceLib Technical Reference
DnisMappingsConfigurationContainer Members
DnisMappingsConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The DnisMappingsConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | DnisMappingsConfigurationContainer | Initializes a new instance of the DnisMappingsConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DnisMappingsConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DnisMappingsConfigurationContainer Constructor

[image]

IceLib Technical Reference
DnisMappingsConfigurationContainer Constructor
DnisMappingsConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the DnisMappingsConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DnisMappingsConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

DnisMappingsConfigurationContainer Class
DnisMappingsConfigurationContainer Members
ININ.IceLib.Configuration Namespace


DnisMappingsConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
DnisMappingsConfigurationContainer Methods
DnisMappingsConfigurationContainer Class See Also Send Feedback

The DnisMappingsConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DnisMappingsConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DnisMappingsConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
DnisMappingsConfigurationContainer Properties
DnisMappingsConfigurationContainer Class See Also Send Feedback

The DnisMappingsConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DnisMappingsConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DnisMappingsConfigurationContainer Events

[image] [image]

IceLib Technical Reference
DnisMappingsConfigurationContainer Events
DnisMappingsConfigurationContainer Class See Also Send Feedback

The DnisMappingsConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DnisMappingsConfigurationContainer Class
ININ.IceLib.Configuration Namespace


DynamicConfigurationList(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Allows for watching list-based configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class DynamicConfigurationList<TConfigurationObject, TPropertyEnum> : ConfigurationList<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ListConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class DynamicConfigurationList(Of TConfigurationObject As ListConfigurationObject, TPropertyEnum As {Structure, New}) _
    Inherits ConfigurationList(Of TConfigurationObject, TPropertyEnum)

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..AccumulatorConfigurationList
ININ.IceLib.Configuration..::..AttendantConfigurationConfigurationList
ININ.IceLib.Configuration..::..AttendantEmailProfileConfigurationList
ININ.IceLib.Configuration..::..AttendantInboundProfileConfigurationList
ININ.IceLib.Configuration..::..AttendantOperatorProfileConfigurationList
ININ.IceLib.Configuration..::..AttendantOutboundProfileConfigurationList
ININ.IceLib.Configuration..::..AudioSourceConfigurationList
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfigurationList
ININ.IceLib.Configuration..::..ContactListSourceConfigurationList
ININ.IceLib.Configuration..::..EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration.EFaq..::..EFaqConfigurationList
ININ.IceLib.Configuration..::..FaxGroupConfigurationList
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyConfigurationList
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyGroupConfigurationList
ININ.IceLib.Configuration..::..HandlerConfigurationList
ININ.IceLib.Configuration..::..InitializationFunctionConfigurationList
ININ.IceLib.Configuration..::..InteractionClientPluginConfigurationList
ININ.IceLib.Configuration..::..InteractionConferenceRoomConfigurationList
ININ.IceLib.Configuration..::..InteractionProcessorTableConfigurationList
ININ.IceLib.Configuration..::..LineGroupConfigurationList
ININ.IceLib.Configuration..::..LocationConfigurationList
ININ.IceLib.Configuration..::..MiscellaneousItemConfigurationList
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerActiveDirectoryConfigurationList
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerStatusMessageConfigurationList
ININ.IceLib.Configuration.Optimizer..::..OptimizerSchedulingUnitConfigurationList
ININ.IceLib.Configuration..::..PagingCarrierConfigurationList
ININ.IceLib.Configuration.ProcessAutomation..::..ProcessConfigurationList
ININ.IceLib.Configuration.Recorder..::..RecorderQuestionnaireConfigurationList
ININ.IceLib.Configuration.Reporting..::..LegacyHistoricalReportConfigurationList
ININ.IceLib.Configuration..::..ReportLogConfigurationList
ININ.IceLib.Configuration..::..SiteConfigurationList
ININ.IceLib.Configuration..::..SmdiPortConfigurationList
ININ.IceLib.Configuration..::..SmsBrokerConfigurationList
ININ.IceLib.Configuration..::..StationGroupConfigurationList
ININ.IceLib.Configuration..::..StatusColumnConfigurationList
ININ.IceLib.Configuration..::..SystemParameterConfigurationList
ININ.IceLib.Configuration..::..VoiceModuleConfigurationList
ININ.IceLib.Configuration..::..WebServicesParameterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DynamicConfigurationList(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties Events See Also Send Feedback

The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects.
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects.
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added.
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified.
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


DynamicConfigurationList(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects.
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects.
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ChangeWatchQuerySettings Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchQuerySettings Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchQuerySettings(
    QuerySettings<TConfigurationObject, TPropertyEnum> querySettings
)
Visual Basic
Public Sub ChangeWatchQuerySettings ( _
    querySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum) _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..QuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The new query settings.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ChangeWatchQuerySettingsAsync Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeWatchQuerySettingsAsync Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchQuerySettingsAsync(
    QuerySettings<TConfigurationObject, TPropertyEnum> querySettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchQuerySettingsAsync ( _
    querySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..QuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | querySettings is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RefreshWatch Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RefreshWatch Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshWatch()
Visual Basic
Public Sub RefreshWatch

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RefreshWatchAsync Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RefreshWatchAsync Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshWatchAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RefreshWatchAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartWatching Method

[image] [image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts watching the specified configuration objects.

Overload List

 | Name | Description
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartWatching Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

The default values use a dynamic limit to return all ids and display names that the current user has view access to. This list is sorted ascending by display name.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatching Overload
ININ.IceLib.Configuration Namespace


StartWatching Method (QuerySettings(TConfigurationObject, TPropertyEnum))

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching Method (QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>)
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Starts watching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    QuerySettings<TConfigurationObject, TPropertyEnum> querySettings
)
Visual Basic
Public Sub StartWatching ( _
    querySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum) _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..QuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object."

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatching Overload
ININ.IceLib.Configuration Namespace


StartWatchingAsync Method

[image] [image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts watching the specified configuration objects.

Overload List

 | Name | Description
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartWatchingAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync Method (AsyncCompletedEventHandler, Object)
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

The default values use a dynamic limit to return all ids and display names that the current user has view access to. This list is sorted ascending by display name.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatchingAsync Overload
ININ.IceLib.Configuration Namespace


StartWatchingAsync Method (QuerySettings(TConfigurationObject, TPropertyEnum), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatchingAsync Method (QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>, AsyncCompletedEventHandler, Object)
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously starts watching the specified configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    QuerySettings<TConfigurationObject, TPropertyEnum> querySettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    querySettings As QuerySettings(Of TConfigurationObject, TPropertyEnum), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

querySettings
Type: ININ.IceLib.Configuration..::..QuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The query settings. Call CreateQuerySettings()()()() to construct a query settings object."
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StartWatchingAsync Overload
ININ.IceLib.Configuration Namespace


StopWatching Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StopWatching Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Stops watching the configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StopWatchingAsync Method
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously stops watching the configuration list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DynamicConfigurationList(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


DynamicConfigurationList(TConfigurationObject, TPropertyEnum) Events

[image] [image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Events
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added.
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified.
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ConfigurationObjectsAdded Event

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationObjectsAdded Event
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Occurs when at least one item of type TConfigurationObject is added.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConfigurationWatchEventArgs<TConfigurationObject>> ConfigurationObjectsAdded
Visual Basic
Public Event ConfigurationObjectsAdded As EventHandler(Of ConfigurationWatchEventArgs(Of TConfigurationObject))

Remarks

This event will only occur when configuration objects being watched have been added. To start watching for configuration objects call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchQuerySettings(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationObjectsChanged Event

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationObjectsChanged Event
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Occurs when at least one item of type TConfigurationObject is modified.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConfigurationObjectChangesEventArgs<TConfigurationObject, TPropertyEnum>> ConfigurationObjectsChanged
Visual Basic
Public Event ConfigurationObjectsChanged As EventHandler(Of ConfigurationObjectChangesEventArgs(Of TConfigurationObject, TPropertyEnum))

Remarks

This event will only occur when configuration objects being watched have been changed. To start watching for configuration objects call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchQuerySettings(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) method. Only the properties that were changed on this object will be available. In order to view other properties that were not part of this notification, a call to GetConfigurationList()()()() should be made to get the current state of all the watched properties.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ConfigurationObjectsRemoved Event

[image]

IceLib Technical Reference
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ConfigurationObjectsRemoved Event
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Occurs when at least one item of type TConfigurationObject is removed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConfigurationWatchEventArgs<TConfigurationObject>> ConfigurationObjectsRemoved
Visual Basic
Public Event ConfigurationObjectsRemoved As EventHandler(Of ConfigurationWatchEventArgs(Of TConfigurationObject))

Remarks

This event will only occur when configuration objects being watched have been removed. To start watching for configuration objects call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchQuerySettings(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) method. The ConfigurationId property is the only property that will be available on this object.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableConfigurationList(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Allows for querying and managing editable list-based configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class EditableConfigurationList<TConfigurationObject, TPropertyEnum> : DynamicConfigurationList<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : EditableListConfigurationObject<TPropertyEnum>
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class EditableConfigurationList(Of TConfigurationObject As EditableListConfigurationObject(Of TPropertyEnum), TPropertyEnum As {Structure, New}) _
    Inherits DynamicConfigurationList(Of TConfigurationObject, TPropertyEnum)

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..AccessControlGroupConfigurationList
ININ.IceLib.Configuration..::..AccountCodeConfigurationList
ININ.IceLib.Configuration..::..ActionConfigurationList
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfigurationList
ININ.IceLib.Configuration..::..ClientTemplateConfigurationList
ININ.IceLib.Configuration..::..CustomButtonConfigurationList
ININ.IceLib.Configuration..::..ImageResourceConfigurationList
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfigurationList
ININ.IceLib.Configuration..::..LayoutConfigurationList
ININ.IceLib.Configuration..::..LineConfigurationList
ININ.IceLib.Configuration..::..PasswordPolicyConfigurationList
ININ.IceLib.Configuration..::..PhoneNumberClassificationConfigurationList
ININ.IceLib.Configuration..::..PositionConfigurationList
ININ.IceLib.Configuration..::..QueueColumnConfigurationList
ININ.IceLib.Configuration..::..RecordingBeepToneConfigurationList
ININ.IceLib.Configuration.Reporting..::..HistoricalReportConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportCategoryConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportCustomDataConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportFlexibleColumnConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportMasterConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportParameterConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportSectionConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportSystemSettingConfigurationList
ININ.IceLib.Configuration.Reporting..::..ReportTableConfigurationList
ININ.IceLib.Configuration..::..ResponseManagementDocumentConfigurationList
ININ.IceLib.Configuration..::..RoleConfigurationList
ININ.IceLib.Configuration..::..ScheduleConfigurationList
ININ.IceLib.Configuration..::..SecureInputFormConfigurationList
ININ.IceLib.Configuration..::..ServerParameterConfigurationList
ININ.IceLib.Configuration..::..SkillConfigurationList
ININ.IceLib.Configuration..::..StationConfigurationList
ININ.IceLib.Configuration..::..StationTemplateConfigurationList
ININ.IceLib.Configuration..::..StatusMessageConfigurationList
ININ.IceLib.Configuration..::..StreamingAudioMonitorProfileConfigurationList
ININ.IceLib.Configuration..::..StructuredParameterConfigurationList
ININ.IceLib.Configuration..::..UserConfigurationList
ININ.IceLib.Configuration..::..WorkgroupConfigurationList
ININ.IceLib.Configuration..::..WrapUpCategoryConfigurationList
ININ.IceLib.Configuration..::..WrapUpCodeConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableConfigurationList(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties Events See Also Send Feedback

The EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list.
Public method | CreateObjectAsync | Asynchronously creates a new object in the list.
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


EditableConfigurationList(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list.
Public method | CreateObjectAsync | Asynchronously creates a new object in the list.
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CreateObject Method

[image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateObject Method
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Creates a new object in the list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TConfigurationObject CreateObject()
Visual Basic
Public Function CreateObject As TConfigurationObject

Return Value

The new configuration object instance.

Remarks

To modify the new object's settings PrepareForEdit()()()() must be called first. Once the object's settings are configured, use Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) to commit the setting modifications to the server. Alternatively CancelEdit()()()() can be called to cancel any setting modifications.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>


CreateObjectAsync Method

[image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateObjectAsync Method
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously creates a new object in the list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateObjectAsync(
    EventHandler<CreateObjectCompletedEventArgs<TConfigurationObject, TPropertyEnum>> completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateObjectAsync ( _
    completedCallback As EventHandler(Of CreateObjectCompletedEventArgs(Of TConfigurationObject, TPropertyEnum)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' CreateObjectCompletedEventArgs <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

To modify the new object's settings PrepareForEdit()()()() must be called first. Once the object's settings are configured, use Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) to commit the setting modifications to the server. Alternatively CancelEdit()()()() can be called to cancel any setting modifications.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableConfigurationList(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


EditableConfigurationList(TConfigurationObject, TPropertyEnum) Events

[image] [image]

IceLib Technical Reference
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Events
EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


EditableContainerConfigurationObject(TPropertyEnum) Class

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a container-based configuration object that can be edited.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class EditableContainerConfigurationObject<TPropertyEnum> : ContainerConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class EditableContainerConfigurationObject(Of TPropertyEnum As {Structure, New}) _
    Inherits ContainerConfigurationObject

Type Parameters

TPropertyEnum

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..AccountCodesConfiguration
ININ.IceLib.Configuration..::..DefaultStationConfiguration
ININ.IceLib.Configuration..::..DefaultUserConfiguration
ININ.IceLib.Configuration..::..DnisMappingsConfiguration
ININ.IceLib.Configuration..::..ProblemReporterConfiguration
ININ.IceLib.Configuration.Recorder..::..RecorderConfiguration
ININ.IceLib.Configuration..::..SystemConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableContainerConfigurationObject(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()().
Public method | Commit | Commits the contents of this object to the server.
Public method | CommitAsync | Asynchronously commits the contents of this object to the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties).
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


EditableContainerConfigurationObject(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Methods
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()().
Public method | Commit | Commits the contents of this object to the server.
Public method | CommitAsync | Asynchronously commits the contents of this object to the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties).
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CancelEdit Method

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..CancelEdit Method
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Cancels an edit started by PrepareForEdit()()()().

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelEdit()
Visual Basic
Public Sub CancelEdit

Remarks

When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit Method
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Commits the contents of this object to the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Commit()
Visual Basic
Public Sub Commit

Remarks

PrepareForEdit()()()() should be called prior to modifying an object's settings or calling Commit(). When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Exceptions

Exception | Condition
ININ.IceLib..::..InsufficientRightsException | Unable to perform operation due to insufficient rights.
ININ.IceLib.Configuration..::..ConfigurationValidationException | Validation failed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CommitAsync Method

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..CommitAsync Method
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously commits the contents of this object to the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CommitAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CommitAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

PrepareForEdit()()()() should be called prior to modifying an object's settings or calling CommitAsync(). When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetValidators Method

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidators Method
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the validators for a given configuration object type (and associates them with their Properties).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<TPropertyEnum, ReadOnlyCollection<Validator>> GetValidators()
Visual Basic
Public Function GetValidators As IDictionary(Of TPropertyEnum, ReadOnlyCollection(Of Validator))

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetValidatorsAsync Method

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidatorsAsync Method
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetValidatorsAsync(
    EventHandler<GetValidatorsCompletedEventArgs<TPropertyEnum>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetValidatorsAsync ( _
    completedCallback As EventHandler(Of GetValidatorsCompletedEventArgs(Of TPropertyEnum)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetValidatorsCompletedEventArgs <(Of <(<' TPropertyEnum >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PrepareForEdit Method

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..PrepareForEdit Method
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Prepares a container-based configuration object for edit.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PrepareForEdit()
Visual Basic
Public Sub PrepareForEdit

Remarks

Once the object's settings have been modified, use Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) to commit the setting modifications to the server. Alternatively CancelEdit()()()() can be called to cancel any setting modifications.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableContainerConfigurationObject(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Properties
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


Changed Property

[image]

IceLib Technical Reference
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Changed Property
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Indicates if this object has been modified since it was retrieved from the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual bool Changed { get; }
Visual Basic
Public Overridable ReadOnly Property Changed As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if changed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableListConfigurationObject(TPropertyEnum) Class

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a list-based configuration object that can be edited.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class EditableListConfigurationObject<TPropertyEnum> : ListConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class EditableListConfigurationObject(Of TPropertyEnum As {Structure, New}) _
    Inherits ListConfigurationObject

Type Parameters

TPropertyEnum

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..AccessControlGroupConfiguration
ININ.IceLib.Configuration..::..AccountCodeConfiguration
ININ.IceLib.Configuration..::..ActionConfiguration
ININ.IceLib.Configuration..::..AnalyzerKeywordConfiguration
ININ.IceLib.Configuration..::..AnalyzerKeywordSetConfiguration
ININ.IceLib.Configuration..::..ClientTemplateConfiguration
ININ.IceLib.Configuration..::..CustomButtonConfiguration
ININ.IceLib.Configuration..::..ImageResourceConfiguration
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiAttributeMapConfiguration
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfiguration
ININ.IceLib.Configuration..::..LayoutConfiguration
ININ.IceLib.Configuration..::..LineConfiguration
ININ.IceLib.Configuration..::..PasswordPolicyConfiguration
ININ.IceLib.Configuration..::..PhoneNumberClassificationConfiguration
ININ.IceLib.Configuration..::..PositionConfiguration
ININ.IceLib.Configuration..::..QueueColumnConfiguration
ININ.IceLib.Configuration..::..RecordingBeepToneConfiguration
ININ.IceLib.Configuration.Reporting..::..HistoricalReportConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportCategoryConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportCustomDataConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportFlexibleColumnConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportMasterConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportParameterConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportSectionConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportSystemSettingConfiguration
ININ.IceLib.Configuration.Reporting..::..ReportTableConfiguration
ININ.IceLib.Configuration..::..ResponseManagementDocumentConfiguration
ININ.IceLib.Configuration..::..RoleConfiguration
ININ.IceLib.Configuration..::..ScheduleConfiguration
ININ.IceLib.Configuration..::..ScheduleRecurrenceConfiguration
ININ.IceLib.Configuration..::..SecureInputFormConfiguration
ININ.IceLib.Configuration..::..ServerParameterConfiguration
ININ.IceLib.Configuration..::..SkillConfiguration
ININ.IceLib.Configuration..::..StationConfiguration
ININ.IceLib.Configuration..::..StationTemplateConfiguration
ININ.IceLib.Configuration..::..StatusMessageConfiguration
ININ.IceLib.Configuration..::..StreamingAudioMonitorProfileConfiguration
ININ.IceLib.Configuration..::..StructuredParameterConfiguration
ININ.IceLib.Configuration..::..UserConfiguration
ININ.IceLib.Configuration..::..WorkgroupConfiguration
ININ.IceLib.Configuration..::..WorkgroupMonitoredMailboxConfiguration
ININ.IceLib.Configuration..::..WrapUpCategoryConfiguration
ININ.IceLib.Configuration..::..WrapUpCodeConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableListConfigurationObject(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()().
Public method | Commit | Commits the contents of this object to the server.
Public method | CommitAsync | Asynchronously commits the contents of this object to the server.
Public method | Delete | Deletes this object from the server.
Public method | DeleteAsync | Asynchronously deletes this object from the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties).
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object.
Public method | SetDisplayName | Sets the display name for this configuration object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


EditableListConfigurationObject(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Methods
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()().
Public method | Commit | Commits the contents of this object to the server.
Public method | CommitAsync | Asynchronously commits the contents of this object to the server.
Public method | Delete | Deletes this object from the server.
Public method | DeleteAsync | Asynchronously deletes this object from the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties).
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object.
Public method | SetDisplayName | Sets the display name for this configuration object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CancelEdit Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..CancelEdit Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Cancels an edit started by PrepareForEdit()()()().

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelEdit()
Visual Basic
Public Sub CancelEdit

Remarks

When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Commits the contents of this object to the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual void Commit()
Visual Basic
Public Overridable Sub Commit

Remarks

PrepareForEdit()()()() should be called prior to modifying an object's settings or calling Commit(). When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Exceptions

Exception | Condition
ININ.IceLib..::..InsufficientRightsException | Unable to perform operation due to insufficient rights.
ININ.IceLib.Configuration..::..ConfigurationLicenseException | A license error was encountered while saving license changes.
ININ.IceLib.Configuration..::..ConfigurationValidationException | Validation failed.
System..::..InvalidOperationException | Unable to create new object without ID having been set via SetConfigurationId(String).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CommitAsync Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..CommitAsync Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously commits the contents of this object to the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual void CommitAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Overridable Sub CommitAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

PrepareForEdit()()()() should be called prior to modifying an object's settings or calling CommitAsync(). When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Delete Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Delete Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Deletes this object from the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete

Remarks

When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Exceptions

Exception | Condition
ININ.IceLib..::..InsufficientRightsException | Unable to perform operation due to insufficientRights.
ININ.IceLib.Configuration..::..ConfigurationReferenceException | Unable to perform operation due to references by other objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteAsync Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..DeleteAsync Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously deletes this object from the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetValidators Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidators Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the validators for a given configuration object type (and associates them with their Properties).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<TPropertyEnum, ReadOnlyCollection<Validator>> GetValidators()
Visual Basic
Public Function GetValidators As IDictionary(Of TPropertyEnum, ReadOnlyCollection(Of Validator))

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetValidatorsAsync Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..GetValidatorsAsync Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetValidatorsAsync(
    EventHandler<GetValidatorsCompletedEventArgs<TPropertyEnum>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetValidatorsAsync ( _
    completedCallback As EventHandler(Of GetValidatorsCompletedEventArgs(Of TPropertyEnum)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetValidatorsCompletedEventArgs <(Of <(<' TPropertyEnum >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PrepareForEdit Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..PrepareForEdit Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Prepares a list-based configuration object for edit.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PrepareForEdit()
Visual Basic
Public Sub PrepareForEdit

Remarks

Once the object's settings have been modified, use Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) to commit the setting modifications to the server. Alternatively CancelEdit()()()() can be called to cancel any setting modifications. This should be called before referencing any objects or sub-objects in the list. Referencing the objects before calling this function may cause the Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) to fail to write any changes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetConfigurationId Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Sets the unique identifier used to reference this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual void SetConfigurationId(
    string id
)
Visual Basic
Public Overridable Sub SetConfigurationId ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Remarks

All configuration objects must have an ID set; however, not all configuration objects support setting both the ID and display name. For more information about the objects that support setting the display name separately, see SetDisplayName(String).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The configuration object is not newly created or already had Commit()()()() called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetDisplayName Method

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetDisplayName Method
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Sets the display name for this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDisplayName(
    string displayName
)
Visual Basic
Public Sub SetDisplayName ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String
The display name.

Remarks

Not all configuration objects support setting the display name; however, all objects must have an ID set via SetConfigurationId(String). The following objects support having a display name that is different than the ID:
  • AccessControlGroupConfiguration
  • AnalyzerKeywordSetConfiguration
  • AttendantEmailProfileConfiguration
  • AttendantInboundProfileConfiguration
  • AttendantOperatorProfileConfiguration
  • AttendantOutboundProfileConfiguration
  • ContactListSourceConfiguration
  • ImageResourceConfiguration
  • PasswordPolicyConfiguration
  • PhoneNumberClassificationConfiguration
  • ProcessConfiguration
  • QueueColumnConfiguration
  • ReportLogConfiguration
  • StatusColumnConfiguration
  • StatusMessageConfiguration
  • UserConfiguration
  • WorkgroupMonitoredMailboxConfiguration

Note
Setting the display name on UserConfiguration is handled differently, the display name for a UserConfiguration object can be set/retrieved from the DisplayName value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


EditableListConfigurationObject(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Properties
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


Changed Property

[image]

IceLib Technical Reference
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Changed Property
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Indicates if this object has been modified since it was retrieved from the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual bool Changed { get; }
Visual Basic
Public Overridable ReadOnly Property Changed As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if changed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Class
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration Class

[image]

IceLib Technical Reference
FaxGroupConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Fax Group. A fax group is a named group of fax resources.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxGroupConfiguration : ListConfigurationObject
Visual Basic
Public Class FaxGroupConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..FaxGroupConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfiguration Members
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration Members

[image] [image]

IceLib Technical Reference
FaxGroupConfiguration Members
FaxGroupConfiguration Class Methods Properties See Also Send Feedback

The FaxGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

FaxGroupConfiguration Class
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration Methods

[image] [image]

IceLib Technical Reference
FaxGroupConfiguration Methods
FaxGroupConfiguration Class See Also Send Feedback

The FaxGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

FaxGroupConfiguration Class
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration Properties

[image] [image]

IceLib Technical Reference
FaxGroupConfiguration Properties
FaxGroupConfiguration Class See Also Send Feedback

The FaxGroupConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

FaxGroupConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
FaxGroupConfiguration..::..StandardProperties Property
FaxGroupConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<FaxGroupConfiguration, FaxGroupConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of FaxGroupConfiguration, FaxGroupConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfiguration Class
FaxGroupConfiguration Members
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration.Property Enumeration

[image]

IceLib Technical Reference
FaxGroupConfiguration..::..Property Enumeration
FaxGroupConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


FaxGroupConfiguration.Rights Class

[image]

IceLib Technical Reference
FaxGroupConfiguration..::..Rights Class
FaxGroupConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FaxGroupConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
FaxGroupConfiguration..::..Rights Members
FaxGroupConfiguration..::..Rights Class Properties See Also Send Feedback

The FaxGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

FaxGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


FaxGroupConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
FaxGroupConfiguration..::..Rights Properties
FaxGroupConfiguration..::..Rights Class See Also Send Feedback

The FaxGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

FaxGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
FaxGroupConfiguration..::..Rights..::..Admin Property
FaxGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FaxGroupConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of FaxGroupConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfiguration..::..Rights Class
FaxGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FaxGroups


View Property

[image]

IceLib Technical Reference
FaxGroupConfiguration..::..Rights..::..View Property
FaxGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FaxGroupConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of FaxGroupConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfiguration..::..Rights Class
FaxGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


FaxGroupConfigurationList Class

[image]

IceLib Technical Reference
FaxGroupConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing FaxGroup configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxGroupConfigurationList : DynamicConfigurationList<FaxGroupConfiguration, FaxGroupConfiguration..::..Property>
Visual Basic
Public Class FaxGroupConfigurationList _
    Inherits DynamicConfigurationList(Of FaxGroupConfiguration, FaxGroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' FaxGroupConfiguration, FaxGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' FaxGroupConfiguration, FaxGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..FaxGroupConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


FaxGroupConfigurationList Members

[image] [image]

IceLib Technical Reference
FaxGroupConfigurationList Members
FaxGroupConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The FaxGroupConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | FaxGroupConfigurationList | Initializes a new instance of the FaxGroupConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FaxGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


FaxGroupConfigurationList Constructor

[image]

IceLib Technical Reference
FaxGroupConfigurationList Constructor
FaxGroupConfigurationList Class See Also Send Feedback
Initializes a new instance of the FaxGroupConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxGroupConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FaxGroupConfigurationList Class
FaxGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


FaxGroupConfigurationList Methods

[image] [image]

IceLib Technical Reference
FaxGroupConfigurationList Methods
FaxGroupConfigurationList Class See Also Send Feedback

The FaxGroupConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


FaxGroupConfigurationList Properties

[image] [image]

IceLib Technical Reference
FaxGroupConfigurationList Properties
FaxGroupConfigurationList Class See Also Send Feedback

The FaxGroupConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FaxGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


FaxGroupConfigurationList Events

[image] [image]

IceLib Technical Reference
FaxGroupConfigurationList Events
FaxGroupConfigurationList Class See Also Send Feedback

The FaxGroupConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FaxGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration Class

[image]

IceLib Technical Reference
FeatureLicenseConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC feature license.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FeatureLicenseConfiguration : ListConfigurationObject
Visual Basic
Public Class FeatureLicenseConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..FeatureLicenseConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

FeatureLicenseConfiguration Members
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration Members

[image] [image]

IceLib Technical Reference
FeatureLicenseConfiguration Members
FeatureLicenseConfiguration Class Methods Properties See Also Send Feedback

The FeatureLicenseConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

FeatureLicenseConfiguration Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration Methods

[image] [image]

IceLib Technical Reference
FeatureLicenseConfiguration Methods
FeatureLicenseConfiguration Class See Also Send Feedback

The FeatureLicenseConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

FeatureLicenseConfiguration Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration Properties

[image] [image]

IceLib Technical Reference
FeatureLicenseConfiguration Properties
FeatureLicenseConfiguration Class See Also Send Feedback

The FeatureLicenseConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

FeatureLicenseConfiguration Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration.Property Enumeration

[image]

IceLib Technical Reference
FeatureLicenseConfiguration..::..Property Enumeration
FeatureLicenseConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration.Rights Class

[image]

IceLib Technical Reference
FeatureLicenseConfiguration..::..Rights Class
FeatureLicenseConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FeatureLicenseConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeatureLicenseConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
FeatureLicenseConfiguration..::..Rights Members
FeatureLicenseConfiguration..::..Rights Class Properties See Also Send Feedback

The FeatureLicenseConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

FeatureLicenseConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
FeatureLicenseConfiguration..::..Rights Properties
FeatureLicenseConfiguration..::..Rights Class See Also Send Feedback

The FeatureLicenseConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

FeatureLicenseConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
FeatureLicenseConfiguration..::..Rights..::..Admin Property
FeatureLicenseConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeatureLicenseConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of FeatureLicenseConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Remarks

Note
This right is here for reference purposes only. All querying against FeatureLicenseConfiguration ignores user rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeatureLicenseConfiguration..::..Rights Class
FeatureLicenseConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LicensesAllocationConfiguration


View Property

[image]

IceLib Technical Reference
FeatureLicenseConfiguration..::..Rights..::..View Property
FeatureLicenseConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeatureLicenseConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of FeatureLicenseConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeatureLicenseConfiguration..::..Rights Class
FeatureLicenseConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


FeatureLicenseConfigurationList Class

[image]

IceLib Technical Reference
FeatureLicenseConfigurationList Class
Members See Also Send Feedback
Allows for querying feature license configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FeatureLicenseConfigurationList : ConfigurationList<FeatureLicenseConfiguration, FeatureLicenseConfiguration..::..Property>
Visual Basic
Public Class FeatureLicenseConfigurationList _
    Inherits ConfigurationList(Of FeatureLicenseConfiguration, FeatureLicenseConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' FeatureLicenseConfiguration, FeatureLicenseConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..FeatureLicenseConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

FeatureLicenseConfigurationList Members
ININ.IceLib.Configuration Namespace


FeatureLicenseConfigurationList Members

[image] [image]

IceLib Technical Reference
FeatureLicenseConfigurationList Members
FeatureLicenseConfigurationList Class Constructors Methods Properties See Also Send Feedback

The FeatureLicenseConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | FeatureLicenseConfigurationList | Initializes a new instance of the FeatureLicenseConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeatureLicenseConfigurationList Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfigurationList Constructor

[image]

IceLib Technical Reference
FeatureLicenseConfigurationList Constructor
FeatureLicenseConfigurationList Class See Also Send Feedback
Initializes a new instance of the FeatureLicenseConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FeatureLicenseConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

FeatureLicenseConfigurationList Class
FeatureLicenseConfigurationList Members
ININ.IceLib.Configuration Namespace


FeatureLicenseConfigurationList Methods

[image] [image]

IceLib Technical Reference
FeatureLicenseConfigurationList Methods
FeatureLicenseConfigurationList Class See Also Send Feedback

The FeatureLicenseConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FeatureLicenseConfigurationList Class
ININ.IceLib.Configuration Namespace


FeatureLicenseConfigurationList Properties

[image] [image]

IceLib Technical Reference
FeatureLicenseConfigurationList Properties
FeatureLicenseConfigurationList Class See Also Send Feedback

The FeatureLicenseConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeatureLicenseConfigurationList Class
ININ.IceLib.Configuration Namespace


FilterDefinition(TFilteredObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a filter for searching configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class FilterDefinition<TFilteredObject, TPropertyEnum>
where TFilteredObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class FilterDefinition(Of TFilteredObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TFilteredObject
The type of the filtered object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FilterDefinition(TFilteredObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class Constructors Methods See Also Send Feedback

The FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Initializes a new instance of the FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


FilterDefinition(TFilteredObject, TPropertyEnum) Constructor

[image]

IceLib Technical Reference
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FilterDefinition()
Visual Basic
Protected Sub New

See Also

FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FilterDefinition(TFilteredObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Methods
FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


FilterMatchType Enumeration

[image]

IceLib Technical Reference
FilterMatchType Enumeration
See Also Send Feedback
Specifies the filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FilterMatchType
Visual Basic
Public Enumeration FilterMatchType

Members

Member name | Value | Description
Exact | 0 | Match if the specified target value is an exact match of the property value.
Prefix | 1 | Match if the specified target value is a prefix of the property value.
Contains | 2 | Match if the specified target value is contained in the property value. This is more intensive on server resources.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


GeneralConfigurationProperty(TPropertyEnum, TValue) Class

[image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
Members See Also Send Feedback
Represents a general configuration property.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GeneralConfigurationProperty<TPropertyEnum, TValue> : ConfigurationProperty<TPropertyEnum>,
    IValueDefinedListener
where TPropertyEnum : struct, new()
Visual Basic
Public Class GeneralConfigurationProperty(Of TPropertyEnum As {Structure, New}, TValue) _
    Inherits ConfigurationProperty(Of TPropertyEnum) _
    Implements IValueDefinedListener

Type Parameters

TPropertyEnum
The type of the property enumeration.
TValue
The type of the value.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationProperty <(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>
ININ.IceLib.Configuration..::..InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


GeneralConfigurationProperty(TPropertyEnum, TValue) Members

[image] [image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> | Initializes a new instance of the GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsReadOnly | Gets a value indicating whether this property is read only. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | PropertyEnum | Gets the property enumeration. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Value | Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.)

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


GeneralConfigurationProperty(TPropertyEnum, TValue) Constructor

[image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Constructor
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Initializes a new instance of the GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected GeneralConfigurationProperty(
    GeneralConfigurationProperty<TPropertyEnum, TValue> copy
)
Visual Basic
Protected Sub New ( _
    copy As GeneralConfigurationProperty(Of TPropertyEnum, TValue) _
)

Parameters

copy
Type: ININ.IceLib.Configuration..::..GeneralConfigurationProperty <(Of <(<' TPropertyEnum, TValue >)>)>
The copy.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


GeneralConfigurationProperty(TPropertyEnum, TValue) Methods

[image] [image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Methods
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback

The GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..ToString Method
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


GeneralConfigurationProperty(TPropertyEnum, TValue) Properties

[image] [image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Properties
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback

The GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsReadOnly | Gets a value indicating whether this property is read only. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | PropertyEnum | Gets the property enumeration. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Value | Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.)

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


Value Property

[image]

IceLib Technical Reference
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..Value Property
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValue Value { get; set; }
Visual Basic
Public Property Value As TValue
    Get
    Set

Field Value

The value.

Remarks

Note
Setting the value is only supported when editing an object (via or ) and for non-Collection based TValue.
Note
In order to clear a ConfigurationId property value, set the value to None instead of nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | Setting the value is only supported when editing an object and for non-Collection based TValue.
System..::..NotSupportedException | Setting the value is not supported for read-only properties. Check the documentation or the IsReadOnly property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..PrepareForEdit()()()()
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..PrepareForEdit()()()()
EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..PrepareForEdit()()()()
EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..PrepareForEdit()()()()
ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..IsReadOnly


GetValidatorsCompletedEventArgs(TPropertyEnum) Class

[image]

IceLib Technical Reference
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetValidatorsAsync(EventHandler<(Of <<'(GetValidatorsCompletedEventArgs<(Of <<'(TPropertyEnum>)>>)>)>>), Object).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetValidatorsCompletedEventArgs<TPropertyEnum> : AsyncCompletedEventArgs
where TPropertyEnum : struct, new()
Visual Basic
Public Class GetValidatorsCompletedEventArgs(Of TPropertyEnum As {Structure, New}) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TPropertyEnum

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration..::..GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GetValidatorsCompletedEventArgs(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | Validators | Gets the validators.

See Also

GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


GetValidatorsCompletedEventArgs(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Methods
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


GetValidatorsCompletedEventArgs(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Properties
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | Validators | Gets the validators.

See Also

GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


Validators Property

[image]

IceLib Technical Reference
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Validators Property
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the validators.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<TPropertyEnum, ReadOnlyCollection<Validator>> Validators { get; }
Visual Basic
Public ReadOnly Property Validators As IDictionary(Of TPropertyEnum, ReadOnlyCollection(Of Validator))
    Get

Field Value

The validators.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Class
GetValidatorsCompletedEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Class

[image]

IceLib Technical Reference
GroupedConfigurationId Class
Members See Also Send Feedback
Represents a unique identifier for an object, along with its display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GroupedConfigurationId : ConfigurationId
Visual Basic
Public Class GroupedConfigurationId _
    Inherits ConfigurationId

Remarks

The GroupedConfigurationId class is used to represent a unique identifier for configuration objects in the IC system, along with a DisplayName for that object, if one is defined. If no display name exists for the object, the class will return the Id for the object to be used as the display string.It also allows for certain groups to be represented as a GroupedConfigurationId.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationId
ININ.IceLib.Configuration..::..GroupedConfigurationId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Members

[image] [image]

IceLib Technical Reference
GroupedConfigurationId Members
GroupedConfigurationId Class Constructors Methods Properties See Also Send Feedback

The GroupedConfigurationId type exposes the following members.

Constructors

 | Name | Description
Public method | GroupedConfigurationId(String, String, ConfigurationIdGrouping) | Obsolete. Initializes a new instance of the GroupedConfigurationId class.
Public method | GroupedConfigurationId(String, String, String, ConfigurationIdGrouping) | Obsolete. Initializes a new instance of the GroupedConfigurationId class.
Public method | GroupedConfigurationId(String, String, ObjectType, String, ConfigurationIdGrouping) | Obsolete. Initializes a new instance of the GroupedConfigurationId class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from ConfigurationId.)
 | CreateAllGroupedConfigurationId | Creates the grouped configuration ID object that represents the "[All]" designator.
 | CreateGroupGroupedConfigurationId | Creates the grouped configuration ID object that represents a group configuration ID object.
 | CreateSingleGroupedConfigurationId | Creates the grouped configuration ID object that represents a single configuration ID object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from ConfigurationId.)
Public method | Equals(ConfigurationId) | Determines whether the specified ConfigurationId is equal to the current ConfigurationId. (Inherited from ConfigurationId.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ConfigurationId.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationId.)

Properties

 | Name | Description
Public property | DisplayName | Gets the human-readable name that refers to this configuration object. (Inherited from ConfigurationId.)
Public property | Grouping | Gets the grouping for this configuration ID.
Public property | Id | Gets the unique identifier used to reference this configuration object. (Inherited from ConfigurationId.)
 | None | Gets a ConfigurationId representing no value (i.e. String.Empty).
Public property | ObjectName | Obsolete. Gets the name of the object this configuration ID represents.
Public property | ObjectType | Gets the object type that this configuration ID represents.

See Also

GroupedConfigurationId Class
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Constructor

[image] [image]

IceLib Technical Reference
GroupedConfigurationId Constructor
GroupedConfigurationId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GroupedConfigurationId(String, String, ConfigurationIdGrouping) | Obsolete. Initializes a new instance of the GroupedConfigurationId class.
Public method | GroupedConfigurationId(String, String, String, ConfigurationIdGrouping) | Obsolete. Initializes a new instance of the GroupedConfigurationId class.
Public method | GroupedConfigurationId(String, String, ObjectType, String, ConfigurationIdGrouping) | Obsolete. Initializes a new instance of the GroupedConfigurationId class.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Constructor (String, String, ConfigurationIdGrouping)

[image]

IceLib Technical Reference
GroupedConfigurationId Constructor (String, String, ConfigurationIdGrouping)
GroupedConfigurationId Class See Also Send Feedback
Initializes a new instance of the GroupedConfigurationId class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("This constructor is no longer used, use one of the static Create methods.")]
public GroupedConfigurationId(
    string id,
    string groupType,
    ConfigurationIdGrouping grouping
)
Visual Basic
<ObsoleteAttribute("This constructor is no longer used, use one of the static Create methods.")> _
Public Sub New ( _
    id As String, _
    groupType As String, _
    grouping As ConfigurationIdGrouping _
)

Parameters

id
Type: System..::..String
The ID.
groupType
Type: System..::..String
The group type.
grouping
Type: ININ.IceLib.Configuration..::..ConfigurationIdGrouping
The grouping.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
GroupedConfigurationId Overload
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Constructor (String, String, String, ConfigurationIdGrouping)

[image]

IceLib Technical Reference
GroupedConfigurationId Constructor (String, String, String, ConfigurationIdGrouping)
GroupedConfigurationId Class See Also Send Feedback
Initializes a new instance of the GroupedConfigurationId class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("This constructor is no longer used, use one of the static Create methods.")]
public GroupedConfigurationId(
    string id,
    string displayName,
    string groupType,
    ConfigurationIdGrouping grouping
)
Visual Basic
<ObsoleteAttribute("This constructor is no longer used, use one of the static Create methods.")> _
Public Sub New ( _
    id As String, _
    displayName As String, _
    groupType As String, _
    grouping As ConfigurationIdGrouping _
)

Parameters

id
Type: System..::..String
The ID.
displayName
Type: System..::..String
The display name.
groupType
Type: System..::..String
The group type.
grouping
Type: ININ.IceLib.Configuration..::..ConfigurationIdGrouping
The grouping.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
GroupedConfigurationId Overload
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Constructor (String, String, ObjectType, String, ConfigurationIdGrouping)

[image]

IceLib Technical Reference
GroupedConfigurationId Constructor (String, String, ObjectType, String, ConfigurationIdGrouping)
GroupedConfigurationId Class See Also Send Feedback
Initializes a new instance of the GroupedConfigurationId class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("This constructor is no longer used, use one of the static Create methods.")]
public GroupedConfigurationId(
    string id,
    string displayName,
    ObjectType objectType,
    string objectName,
    ConfigurationIdGrouping grouping
)
Visual Basic
<ObsoleteAttribute("This constructor is no longer used, use one of the static Create methods.")> _
Public Sub New ( _
    id As String, _
    displayName As String, _
    objectType As ObjectType, _
    objectName As String, _
    grouping As ConfigurationIdGrouping _
)

Parameters

id
Type: System..::..String
The ID.
displayName
Type: System..::..String
The display name.
objectType
Type: ININ.IceLib.Configuration..::..ObjectType
The object type.
objectName
Type: System..::..String
The object name.
grouping
Type: ININ.IceLib.Configuration..::..ConfigurationIdGrouping
The grouping.

Remarks

The objectName parameter is not valid when the grouping parameter is ConfigurationIdGrouping.All or ConfigurationIdGrouping.AllGroups.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A parameter is used incorrectly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
GroupedConfigurationId Overload
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Methods

[image] [image]

IceLib Technical Reference
GroupedConfigurationId Methods
GroupedConfigurationId Class See Also Send Feedback

The GroupedConfigurationId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from ConfigurationId.)
 | CreateAllGroupedConfigurationId | Creates the grouped configuration ID object that represents the "[All]" designator.
 | CreateGroupGroupedConfigurationId | Creates the grouped configuration ID object that represents a group configuration ID object.
 | CreateSingleGroupedConfigurationId | Creates the grouped configuration ID object that represents a single configuration ID object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from ConfigurationId.)
Public method | Equals(ConfigurationId) | Determines whether the specified ConfigurationId is equal to the current ConfigurationId. (Inherited from ConfigurationId.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ConfigurationId.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationId.)

See Also

GroupedConfigurationId Class
ININ.IceLib.Configuration Namespace


CreateAllGroupedConfigurationId Method

[image]

IceLib Technical Reference
GroupedConfigurationId..::..CreateAllGroupedConfigurationId Method
GroupedConfigurationId Class See Also Send Feedback
Creates the grouped configuration ID object that represents the "[All]" designator.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static GroupedConfigurationId CreateAllGroupedConfigurationId()
Visual Basic
Public Shared Function CreateAllGroupedConfigurationId As GroupedConfigurationId

Return Value

A GroupedConfigurationId object that represents "[All]".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


CreateGroupGroupedConfigurationId Method

[image]

IceLib Technical Reference
GroupedConfigurationId..::..CreateGroupGroupedConfigurationId Method
GroupedConfigurationId Class See Also Send Feedback
Creates the grouped configuration ID object that represents a group configuration ID object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static GroupedConfigurationId CreateGroupGroupedConfigurationId(
    string objectId,
    ObjectType objectType
)
Visual Basic
Public Shared Function CreateGroupGroupedConfigurationId ( _
    objectId As String, _
    objectType As ObjectType _
) As GroupedConfigurationId

Parameters

objectId
Type: System..::..String
The object ID.
objectType
Type: ININ.IceLib.Configuration..::..ObjectType
The configuration object type.

Return Value

A GroupedConfigurationId object that represents the specified group configuration ID object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


CreateSingleGroupedConfigurationId Method

[image]

IceLib Technical Reference
GroupedConfigurationId..::..CreateSingleGroupedConfigurationId Method
GroupedConfigurationId Class See Also Send Feedback
Creates the grouped configuration ID object that represents a single configuration ID object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static GroupedConfigurationId CreateSingleGroupedConfigurationId(
    string objectId
)
Visual Basic
Public Shared Function CreateSingleGroupedConfigurationId ( _
    objectId As String _
) As GroupedConfigurationId

Parameters

objectId
Type: System..::..String
The object ID.

Return Value

A GroupedConfigurationId object that represents the specified single configuration ID object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


GroupedConfigurationId Properties

[image] [image]

IceLib Technical Reference
GroupedConfigurationId Properties
GroupedConfigurationId Class See Also Send Feedback

The GroupedConfigurationId type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the human-readable name that refers to this configuration object. (Inherited from ConfigurationId.)
Public property | Grouping | Gets the grouping for this configuration ID.
Public property | Id | Gets the unique identifier used to reference this configuration object. (Inherited from ConfigurationId.)
 | None | Gets a ConfigurationId representing no value (i.e. String.Empty).
Public property | ObjectName | Obsolete. Gets the name of the object this configuration ID represents.
Public property | ObjectType | Gets the object type that this configuration ID represents.

See Also

GroupedConfigurationId Class
ININ.IceLib.Configuration Namespace


Grouping Property

[image]

IceLib Technical Reference
GroupedConfigurationId..::..Grouping Property
GroupedConfigurationId Class See Also Send Feedback
Gets the grouping for this configuration ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationIdGrouping Grouping { get; internal set; }
Visual Basic
Public Property Grouping As ConfigurationIdGrouping
    Get
    Friend Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


None Property

[image]

IceLib Technical Reference
GroupedConfigurationId..::..None Property
GroupedConfigurationId Class See Also Send Feedback
Gets a ConfigurationId representing no value (i.e. String.Empty).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static GroupedConfigurationId None { get; }
Visual Basic
Public Shared ReadOnly Property None As GroupedConfigurationId
    Get

Field Value

The ConfigurationId.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


ObjectName Property

[image]

IceLib Technical Reference
GroupedConfigurationId..::..ObjectName Property
GroupedConfigurationId Class See Also Send Feedback
Gets the name of the object this configuration ID represents.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ObjectName is not used, use the Id property instead.")]
public string ObjectName { get; internal set; }
Visual Basic
<ObsoleteAttribute("ObjectName is not used, use the Id property instead.")> _
Public Property ObjectName As String
    Get
    Friend Set

Field Value

The name of the object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


ObjectType Property

[image]

IceLib Technical Reference
GroupedConfigurationId..::..ObjectType Property
GroupedConfigurationId Class See Also Send Feedback
Gets the object type that this configuration ID represents.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ObjectType ObjectType { get; internal set; }
Visual Basic
Public Property ObjectType As ObjectType
    Get
    Friend Set

Field Value

The object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GroupedConfigurationId Class
GroupedConfigurationId Members
ININ.IceLib.Configuration Namespace


GroupFilterDefinition(TFilteredObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a group filter for searching configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GroupFilterDefinition<TFilteredObject, TPropertyEnum> : FilterDefinition<TFilteredObject, TPropertyEnum>
where TFilteredObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class GroupFilterDefinition(Of TFilteredObject As ConfigurationObject, TPropertyEnum As {Structure, New}) _
    Inherits FilterDefinition(Of TFilteredObject, TPropertyEnum)

Type Parameters

TFilteredObject
The type of the filtered object.
TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FilterDefinition <(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GroupFilterDefinition(TFilteredObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> | Initializes a new instance of the GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Filters | Gets the filters in this group.

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


GroupFilterDefinition(TFilteredObject, TPropertyEnum) Constructor

[image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GroupFilterDefinition(
    IEnumerable<FilterDefinition<TFilteredObject, TPropertyEnum>> filterDefinitions
)
Visual Basic
Public Sub New ( _
    filterDefinitions As IEnumerable(Of FilterDefinition(Of TFilteredObject, TPropertyEnum)) _
)

Parameters

filterDefinitions
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' FilterDefinition <(Of <(<' TFilteredObject, TPropertyEnum >)>)>>)>)>
The filter definitions.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GroupFilterDefinition(TFilteredObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Methods
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..ToString Method
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


GroupFilterDefinition(TFilteredObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Properties
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Filters | Gets the filters in this group.

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


Filters Property

[image]

IceLib Technical Reference
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..Filters Property
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filters in this group.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<FilterDefinition<TFilteredObject, TPropertyEnum>> Filters { get; }
Visual Basic
Public ReadOnly Property Filters As IEnumerable(Of FilterDefinition(Of TFilteredObject, TPropertyEnum))
    Get

Field Value

The filters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


HandlerConfiguration Class

[image]

IceLib Technical Reference
HandlerConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Handler. Handlers are created in the Interaction Designer and "published" to the IC Server for use by the Interaction Processor. Handlers define all of the functionality of IC.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HandlerConfiguration : ListConfigurationObject
Visual Basic
Public Class HandlerConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..HandlerConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfiguration Members
ININ.IceLib.Configuration Namespace


HandlerConfiguration Members

[image] [image]

IceLib Technical Reference
HandlerConfiguration Members
HandlerConfiguration Class Methods Properties See Also Send Feedback

The HandlerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

HandlerConfiguration Class
ININ.IceLib.Configuration Namespace


HandlerConfiguration Methods

[image] [image]

IceLib Technical Reference
HandlerConfiguration Methods
HandlerConfiguration Class See Also Send Feedback

The HandlerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

HandlerConfiguration Class
ININ.IceLib.Configuration Namespace


HandlerConfiguration Properties

[image] [image]

IceLib Technical Reference
HandlerConfiguration Properties
HandlerConfiguration Class See Also Send Feedback

The HandlerConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

HandlerConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
HandlerConfiguration..::..StandardProperties Property
HandlerConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<HandlerConfiguration, HandlerConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of HandlerConfiguration, HandlerConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfiguration Class
HandlerConfiguration Members
ININ.IceLib.Configuration Namespace


HandlerConfiguration.Property Enumeration

[image]

IceLib Technical Reference
HandlerConfiguration..::..Property Enumeration
HandlerConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


HandlerConfiguration.Rights Class

[image]

IceLib Technical Reference
HandlerConfiguration..::..Rights Class
HandlerConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..HandlerConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


HandlerConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
HandlerConfiguration..::..Rights Members
HandlerConfiguration..::..Rights Class Properties See Also Send Feedback

The HandlerConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

HandlerConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


HandlerConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
HandlerConfiguration..::..Rights Properties
HandlerConfiguration..::..Rights Class See Also Send Feedback

The HandlerConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

HandlerConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
HandlerConfiguration..::..Rights..::..Admin Property
HandlerConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<HandlerConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of HandlerConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfiguration..::..Rights Class
HandlerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Handlers


View Property

[image]

IceLib Technical Reference
HandlerConfiguration..::..Rights..::..View Property
HandlerConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<HandlerConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of HandlerConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfiguration..::..Rights Class
HandlerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


HandlerConfigurationList Class

[image]

IceLib Technical Reference
HandlerConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Handler configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HandlerConfigurationList : DynamicConfigurationList<HandlerConfiguration, HandlerConfiguration..::..Property>
Visual Basic
Public Class HandlerConfigurationList _
    Inherits DynamicConfigurationList(Of HandlerConfiguration, HandlerConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' HandlerConfiguration, HandlerConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' HandlerConfiguration, HandlerConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..HandlerConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfigurationList Members
ININ.IceLib.Configuration Namespace


HandlerConfigurationList Members

[image] [image]

IceLib Technical Reference
HandlerConfigurationList Members
HandlerConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The HandlerConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | HandlerConfigurationList | Initializes a new instance of the HandlerConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HandlerConfigurationList Class
ININ.IceLib.Configuration Namespace


HandlerConfigurationList Constructor

[image]

IceLib Technical Reference
HandlerConfigurationList Constructor
HandlerConfigurationList Class See Also Send Feedback
Initializes a new instance of the HandlerConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HandlerConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HandlerConfigurationList Class
HandlerConfigurationList Members
ININ.IceLib.Configuration Namespace


HandlerConfigurationList Methods

[image] [image]

IceLib Technical Reference
HandlerConfigurationList Methods
HandlerConfigurationList Class See Also Send Feedback

The HandlerConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HandlerConfigurationList Class
ININ.IceLib.Configuration Namespace


HandlerConfigurationList Properties

[image] [image]

IceLib Technical Reference
HandlerConfigurationList Properties
HandlerConfigurationList Class See Also Send Feedback

The HandlerConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HandlerConfigurationList Class
ININ.IceLib.Configuration Namespace


HandlerConfigurationList Events

[image] [image]

IceLib Technical Reference
HandlerConfigurationList Events
HandlerConfigurationList Class See Also Send Feedback

The HandlerConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HandlerConfigurationList Class
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Class

[image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
Members See Also Send Feedback
This class represents settings for a Configuration query that results in data that is in a hierarchical format. If sub-object support is not needed, QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> should be used instead.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HierarchicalQuerySettings<TConfigurationObject, TPropertyEnum, TQueryChildrenSettings> : QuerySettings<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
where TQueryChildrenSettings : new(), QueryChildrenSettings<TPropertyEnum>
Visual Basic
Public Class HierarchicalQuerySettings(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New}, TQueryChildrenSettings As {New, QueryChildrenSettings(Of TPropertyEnum)}) _
    Inherits QuerySettings(Of TConfigurationObject, TPropertyEnum)

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.
TQueryChildrenSettings
The type of the child query settings that contains subentries.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QuerySettings <(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Members

[image] [image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class Constructors Methods Properties See Also Send Feedback

The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>()()()() | Initializes a new instance of the HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class, using default settings. Use the Set... functions toe configure the this HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object.
Public method | HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>(HierarchicalQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>>)) | Initializes a new instance of the HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class, using default settings. Use the Set... functions to configure this HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetChildQuerySettings
Sets the child query settings. When performing a hierarchical query, in addition to the filtering, sorting, etc... done one this query, all of those behaviors can be performed on the child objects as well.
Public method SetFilterDefinition(FilterDefinition<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetFilterDefinition(TPropertyEnum, Object)
Sets the filter definition to filter the results by the filteredProperty, using a Prefix filter match type.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetFilterDefinition(TPropertyEnum, Object, FilterMatchType)
Sets the filter definition to filter the results by the filteredProperty.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetLanguageToRetrieve
Sets the language to retrieve.

Remarks

If set to nullNothingnullptra null reference (Nothing in Visual Basic) or Empty, then only the default language will be returned.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetLanguageToRetrieveToAll
Sets the language to retrieve to all languages.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetLanguageToRetrieveToDefault
Sets the language to retrieve to the default language.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>))
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][])
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetPropertiesToRetrieveToAll
Sets this query to retrieve all properties on the objects.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetResultCountLimit(Int32)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetResultCountLimit(QueryResultLimit)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][])
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>))
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilterToAdmin
Sets the rights filter to use the default admin right for this object.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilterToView
Sets the rights filter to use the default view right for this object.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetSortOrder(SortDefinition<(Of <<'(TPropertyEnum>)>>))
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetSortOrder(TPropertyEnum, ListSortDirection)
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetStartAtRecordNumber
Sets the record number to start at for the query results. By default, the record number starts at zero (to start at the beginning).
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SupportsValueListFiltering
Determines if value list filtering via ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> is supported.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Properties

 | Name | Description
Public property | ChildQueries | Gets the child query settings.
Public property | FilterDefinition | Gets the filter definition. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | Language | Gets the language. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | PropertiesInQuery | Gets the properties of the object that are to be included in the query results. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | ResultCountLimit | Gets the result count limit or nullNothingnullptra null reference (Nothing in Visual Basic) if the results are unlimited. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | RightsFilters | Gets the list of rights that will filter the search results. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | SortDefinition | Gets the sort definition. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | StartAtRecordNumber | Gets the starting record number of the query results that will be returned. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Constructor

[image] [image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Constructor
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>()()()() | Initializes a new instance of the HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class, using default settings. Use the Set... functions toe configure the this HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object.
Public method | HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>(HierarchicalQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>>)) | Initializes a new instance of the HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class, using default settings. Use the Set... functions to configure this HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object.

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Constructor

[image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Constructor
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback
Initializes a new instance of the HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class, using default settings. Use the Set... functions toe configure the this HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Overload
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Constructor (HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings))

[image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Constructor (HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>)
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback
Initializes a new instance of the HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class, using default settings. Use the Set... functions to configure this HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings(
    HierarchicalQuerySettings<TConfigurationObject, TPropertyEnum, TQueryChildrenSettings> source
)
Visual Basic
Public Sub New ( _
    source As HierarchicalQuerySettings(Of TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) _
)

Parameters

source
Type: ININ.IceLib.Configuration..::..HierarchicalQuerySettings <(Of <(<' TConfigurationObject, TPropertyEnum, TQueryChildrenSettings >)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Overload
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Methods

[image] [image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Methods
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback

The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetChildQuerySettings
Sets the child query settings. When performing a hierarchical query, in addition to the filtering, sorting, etc... done one this query, all of those behaviors can be performed on the child objects as well.
Public method SetFilterDefinition(FilterDefinition<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetFilterDefinition(TPropertyEnum, Object)
Sets the filter definition to filter the results by the filteredProperty, using a Prefix filter match type.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetFilterDefinition(TPropertyEnum, Object, FilterMatchType)
Sets the filter definition to filter the results by the filteredProperty.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetLanguageToRetrieve
Sets the language to retrieve.

Remarks

If set to nullNothingnullptra null reference (Nothing in Visual Basic) or Empty, then only the default language will be returned.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetLanguageToRetrieveToAll
Sets the language to retrieve to all languages.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetLanguageToRetrieveToDefault
Sets the language to retrieve to the default language.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>))
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][])
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetPropertiesToRetrieveToAll
Sets this query to retrieve all properties on the objects.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetResultCountLimit(Int32)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetResultCountLimit(QueryResultLimit)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][])
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>))
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilterToAdmin
Sets the rights filter to use the default admin right for this object.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetRightsFilterToView
Sets the rights filter to use the default view right for this object.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetSortOrder(SortDefinition<(Of <<'(TPropertyEnum>)>>))
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetSortOrder(TPropertyEnum, ListSortDirection)
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SetStartAtRecordNumber
Sets the record number to start at for the query results. By default, the record number starts at zero (to start at the beginning).
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method SupportsValueListFiltering
Determines if value list filtering via ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> is supported.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
ININ.IceLib.Configuration Namespace


SetChildQuerySettings Method

[image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>..::..SetChildQuerySettings Method
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback
Sets the child query settings. When performing a hierarchical query, in addition to the filtering, sorting, etc... done one this query, all of those behaviors can be performed on the child objects as well.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings<TConfigurationObject, TPropertyEnum, TQueryChildrenSettings> SetChildQuerySettings(
    TQueryChildrenSettings childQueries
)
Visual Basic
Public Function SetChildQuerySettings ( _
    childQueries As TQueryChildrenSettings _
) As HierarchicalQuerySettings(Of TConfigurationObject, TPropertyEnum, TQueryChildrenSettings)

Parameters

childQueries
Type: TQueryChildrenSettings
The child QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)>.

Return Value

This HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
ININ.IceLib.Configuration Namespace


HierarchicalQuerySettings(TConfigurationObject, TPropertyEnum, TQueryChildrenSettings) Properties

[image] [image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Properties
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback

The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ChildQueries | Gets the child query settings.
Public property | FilterDefinition | Gets the filter definition. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | Language | Gets the language. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | PropertiesInQuery | Gets the properties of the object that are to be included in the query results. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | ResultCountLimit | Gets the result count limit or nullNothingnullptra null reference (Nothing in Visual Basic) if the results are unlimited. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | RightsFilters | Gets the list of rights that will filter the search results. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | SortDefinition | Gets the sort definition. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | StartAtRecordNumber | Gets the starting record number of the query results that will be returned. (Inherited from QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
ININ.IceLib.Configuration Namespace


ChildQueries Property

[image]

IceLib Technical Reference
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>..::..ChildQueries Property
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class See Also Send Feedback
Gets the child query settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TQueryChildrenSettings ChildQueries { get; }
Visual Basic
Public ReadOnly Property ChildQueries As TQueryChildrenSettings
    Get

Field Value

The child query settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Class
HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> Members
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration Class

[image]

IceLib Technical Reference
ICDataSourceConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for sn IC data source.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ICDataSourceConfiguration : ListConfigurationObject
Visual Basic
Public Class ICDataSourceConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..ICDataSourceConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration Members

[image] [image]

IceLib Technical Reference
ICDataSourceConfiguration Members
ICDataSourceConfiguration Class Methods Properties See Also Send Feedback

The ICDataSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AdditionalInformation | Provides access to the property representing the AdditionalInformation (use Property.AdditionalInformation).
Public property | BindDn | Provides access to the property representing the BindDN (use Property.BindDn).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConnectionString | Provides access to the property representing the ConnectionString (use Property.ConnectionString).
Public property | DataSourceSubType | Provides access to the property representing the DataSourceSubType (use Property.DataSourceSubType).
Public property | DataSourceType | Provides access to the property representing the DataSourceType (use Property.DataSourceType).
Public property | Driver | Provides access to the property representing the Driver (use Property.Driver).
Public property | Folder | Provides access to the property representing the Folder (use Property.Folder).
Public property | HasManualConnectionString | Provides access to the property that determines if this instance has a manual connection string (use Property.HasManualConnectionString).
Public property | HostName | Provides access to the property representing the HostName (use Property.HostName).
Public property | IsFileDsn | Provides access to the property determining if this instance is a file DSN (use Property.IsFileDsn).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsReadOnly | Provides access to the property that determines if this instance is read only (use Property.IsReadOnly).
Public property | OdbcDsn | Provides access to the property representing ODBC DSN (use Property.OdbcDsn).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | Password | Provides access to the property representing the Password (use Property.Password).
Public property | Port | Provides access to the property representing the Port (use Property.Port).
Public property | Qualifier | Provides access to the property representing the Qualifier (use Property.Qualifier).
Public property | ReportClientProxyPort | Provides access to the property representing ReportClientProxyPort (use Property.ReportClientProxyPort).
Public property | SearchDn | Provides access to the property representing the Search DN (use Property.SearchDn).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Url | Provides access to the property representing the Url (use Property.Url).
Public property | UseInternetEnabledReporting | Provides access to the property representing UseInternetEnabledReporting (use Property.UseInternetEnabledReporting).
Public property | UserId | Provides access to the property representing the User ID (use Property.UserId).

See Also

ICDataSourceConfiguration Class
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration Methods

[image] [image]

IceLib Technical Reference
ICDataSourceConfiguration Methods
ICDataSourceConfiguration Class See Also Send Feedback

The ICDataSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ICDataSourceConfiguration Class
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration Properties

[image] [image]

IceLib Technical Reference
ICDataSourceConfiguration Properties
ICDataSourceConfiguration Class See Also Send Feedback

The ICDataSourceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalInformation | Provides access to the property representing the AdditionalInformation (use Property.AdditionalInformation).
Public property | BindDn | Provides access to the property representing the BindDN (use Property.BindDn).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConnectionString | Provides access to the property representing the ConnectionString (use Property.ConnectionString).
Public property | DataSourceSubType | Provides access to the property representing the DataSourceSubType (use Property.DataSourceSubType).
Public property | DataSourceType | Provides access to the property representing the DataSourceType (use Property.DataSourceType).
Public property | Driver | Provides access to the property representing the Driver (use Property.Driver).
Public property | Folder | Provides access to the property representing the Folder (use Property.Folder).
Public property | HasManualConnectionString | Provides access to the property that determines if this instance has a manual connection string (use Property.HasManualConnectionString).
Public property | HostName | Provides access to the property representing the HostName (use Property.HostName).
Public property | IsFileDsn | Provides access to the property determining if this instance is a file DSN (use Property.IsFileDsn).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsReadOnly | Provides access to the property that determines if this instance is read only (use Property.IsReadOnly).
Public property | OdbcDsn | Provides access to the property representing ODBC DSN (use Property.OdbcDsn).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | Password | Provides access to the property representing the Password (use Property.Password).
Public property | Port | Provides access to the property representing the Port (use Property.Port).
Public property | Qualifier | Provides access to the property representing the Qualifier (use Property.Qualifier).
Public property | ReportClientProxyPort | Provides access to the property representing ReportClientProxyPort (use Property.ReportClientProxyPort).
Public property | SearchDn | Provides access to the property representing the Search DN (use Property.SearchDn).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Url | Provides access to the property representing the Url (use Property.Url).
Public property | UseInternetEnabledReporting | Provides access to the property representing UseInternetEnabledReporting (use Property.UseInternetEnabledReporting).
Public property | UserId | Provides access to the property representing the User ID (use Property.UserId).

See Also

ICDataSourceConfiguration Class
ININ.IceLib.Configuration Namespace


AdditionalInformation Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..AdditionalInformation Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the AdditionalInformation (use Property.AdditionalInformation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> AdditionalInformation { get; }
Visual Basic
Public ReadOnly Property AdditionalInformation As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the AdditionalInformation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


BindDn Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..BindDn Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the BindDN (use Property.BindDn).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> BindDn { get; }
Visual Basic
Public ReadOnly Property BindDn As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the BindDN.

Remarks

This is only available when DataSourceType is Ldap.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


ConnectionString Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..ConnectionString Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the ConnectionString (use Property.ConnectionString).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> ConnectionString { get; }
Visual Basic
Public ReadOnly Property ConnectionString As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the ConnectionString.

Remarks

This is only available when DataSourceType is Odbc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


DataSourceSubType Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..DataSourceSubType Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the DataSourceSubType (use Property.DataSourceSubType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, ICDataSourceSubType> DataSourceSubType { get; }
Visual Basic
Public ReadOnly Property DataSourceSubType As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, ICDataSourceSubType)
    Get

Field Value

The property representing the DataSourceSubType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


DataSourceType Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..DataSourceType Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the DataSourceType (use Property.DataSourceType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, ICDataSourceType> DataSourceType { get; }
Visual Basic
Public ReadOnly Property DataSourceType As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, ICDataSourceType)
    Get

Field Value

The property representing the DataSourceType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


Driver Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Driver Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Driver (use Property.Driver).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> Driver { get; }
Visual Basic
Public ReadOnly Property Driver As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Driver.

Remarks

This is only available when DataSourceType is Jdbc or WhitePages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


Folder Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Folder Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Folder (use Property.Folder).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> Folder { get; }
Visual Basic
Public ReadOnly Property Folder As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Folder.

Remarks

This is only available when DataSourceType is Mapi.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


HasManualConnectionString Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..HasManualConnectionString Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property that determines if this instance has a manual connection string (use Property.HasManualConnectionString).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, bool> HasManualConnectionString { get; }
Visual Basic
Public ReadOnly Property HasManualConnectionString As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the has manual connectin string flag .

Remarks

This is only available when DataSourceType is JdbcOdbc or Odbc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


HostName Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..HostName Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the HostName (use Property.HostName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> HostName { get; }
Visual Basic
Public ReadOnly Property HostName As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the HostName.

Remarks

This is only available when DataSourceType is Ldap.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


IsFileDsn Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..IsFileDsn Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property determining if this instance is a file DSN (use Property.IsFileDsn).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, bool> IsFileDsn { get; }
Visual Basic
Public ReadOnly Property IsFileDsn As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the is file DSN flag.

Remarks

This is only available when DataSourceType is Odbc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


IsReadOnly Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..IsReadOnly Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property that determines if this instance is read only (use Property.IsReadOnly).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, bool> IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the is read only flag.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


OdbcDsn Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..OdbcDsn Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing ODBC DSN (use Property.OdbcDsn).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> OdbcDsn { get; }
Visual Basic
Public ReadOnly Property OdbcDsn As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the ODBC DSN.

Remarks

This is only available when DataSourceType is JdbcOdbc or Odbc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


Password Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Password Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Password (use Property.Password).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> Password { get; }
Visual Basic
Public ReadOnly Property Password As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Password.

Remarks

This is only available when DataSourceType is Jdbc or JdbcOdbc or Ldap or Odbc or WhitePages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


Port Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Port Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Port (use Property.Port).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> Port { get; }
Visual Basic
Public ReadOnly Property Port As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Port.

Remarks

This is only available when DataSourceType is Ldap.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


Qualifier Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Qualifier Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Qualifier (use Property.Qualifier).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> Qualifier { get; }
Visual Basic
Public ReadOnly Property Qualifier As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Qualifier.

Remarks

This is only available when DataSourceType is Jdbc or JdbcOdbc or Odbc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


ReportClientProxyPort Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..ReportClientProxyPort Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing ReportClientProxyPort (use Property.ReportClientProxyPort).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, int> ReportClientProxyPort { get; }
Visual Basic
Public ReadOnly Property ReportClientProxyPort As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, Integer)
    Get

Field Value

The property representing ReportClientProxyPort setting for a data source.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


SearchDn Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..SearchDn Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Search DN (use Property.SearchDn).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> SearchDn { get; }
Visual Basic
Public ReadOnly Property SearchDn As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Search DN.

Remarks

This is only available when DataSourceType is Ldap.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..StandardProperties Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ICDataSourceConfiguration, ICDataSourceConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ICDataSourceConfiguration, ICDataSourceConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


Url Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Url Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Url (use Property.Url).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> Url { get; }
Visual Basic
Public ReadOnly Property Url As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Url.

Remarks

This is only available when DataSourceType is Jdbc or JdbcOdbc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


UseInternetEnabledReporting Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..UseInternetEnabledReporting Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing UseInternetEnabledReporting (use Property.UseInternetEnabledReporting).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, bool> UseInternetEnabledReporting { get; }
Visual Basic
Public ReadOnly Property UseInternetEnabledReporting As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing UseInternetEnabledReporting setting for a data source.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


UserId Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..UserId Property
ICDataSourceConfiguration Class See Also Send Feedback
Provides access to the property representing the User ID (use Property.UserId).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ICDataSourceConfiguration..::..Property, string> UserId { get; }
Visual Basic
Public ReadOnly Property UserId As GeneralConfigurationProperty(Of ICDataSourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the User ID.

Remarks

This is only available when DataSourceType is Jdbc or JdbcOdbc or Odbc or WhitePages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration Class
ICDataSourceConfiguration Members
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Property Enumeration
ICDataSourceConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AdditionalInformation | 0 | Represents the AdditionalInformation property.
BindDn | 1 | Represents the BindDn property.
ConnectionString | 2 | Represents the ConnectionString property.
DataSourceSubType | 3 | Represents the DataSourceSubType property.
DataSourceType | 4 | Represents the DataSourceType property.
Driver | 5 | Represents the Driver property.
Folder | 6 | Represents the Folder property.
HasManualConnectionString | 7 | Represents the HasManualConnectionString property.
HostName | 8 | Represents the HostName property.
IsFileDsn | 9 | Represents the IsFileDsn property.
IsReadOnly | 10 | Represents the IsReadOnly property.
OdbcDsn | 11 | Represents the OdbcDsn property.
Password | 12 | Represents the Password property.
Port | 13 | Represents the Port property.
Qualifier | 14 | Represents the Qualifier property.
SearchDn | 15 | Represents the SearchDn property.
Url | 16 | Represents the Url property.
UserId | 17 | Represents the UserId property.
UseInternetEnabledReporting | 20 | Represents the UseInternetEnabledReporting property.
ReportClientProxyPort | 21 | Represents the ReportClientProxyPort property.
DisplayName | 18 | Represents the DisplayName part of the ConfigurationId property.
Id | 19 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration.Rights Class

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Rights Class
ICDataSourceConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ICDataSourceConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Rights Members
ICDataSourceConfiguration..::..Rights Class Properties See Also Send Feedback

The ICDataSourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ICDataSourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ICDataSourceConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Rights Properties
ICDataSourceConfiguration..::..Rights Class See Also Send Feedback

The ICDataSourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ICDataSourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Rights..::..Admin Property
ICDataSourceConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ICDataSourceConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ICDataSourceConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration..::..Rights Class
ICDataSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ICDataSources


View Property

[image]

IceLib Technical Reference
ICDataSourceConfiguration..::..Rights..::..View Property
ICDataSourceConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ICDataSourceConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ICDataSourceConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfiguration..::..Rights Class
ICDataSourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewDataSource


ICDataSourceConfigurationList Class

[image]

IceLib Technical Reference
ICDataSourceConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing IC data source configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ICDataSourceConfigurationList : ConfigurationList<ICDataSourceConfiguration, ICDataSourceConfiguration..::..Property>
Visual Basic
Public Class ICDataSourceConfigurationList _
    Inherits ConfigurationList(Of ICDataSourceConfiguration, ICDataSourceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ICDataSourceConfiguration, ICDataSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ICDataSourceConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfigurationList Members
ININ.IceLib.Configuration Namespace


ICDataSourceConfigurationList Members

[image] [image]

IceLib Technical Reference
ICDataSourceConfigurationList Members
ICDataSourceConfigurationList Class Constructors Methods Properties See Also Send Feedback

The ICDataSourceConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ICDataSourceConfigurationList | Initializes a new instance of the ICDataSourceConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ICDataSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ICDataSourceConfigurationList Constructor

[image]

IceLib Technical Reference
ICDataSourceConfigurationList Constructor
ICDataSourceConfigurationList Class See Also Send Feedback
Initializes a new instance of the ICDataSourceConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICDataSourceConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ICDataSourceConfigurationList Class
ICDataSourceConfigurationList Members
ININ.IceLib.Configuration Namespace


ICDataSourceConfigurationList Methods

[image] [image]

IceLib Technical Reference
ICDataSourceConfigurationList Methods
ICDataSourceConfigurationList Class See Also Send Feedback

The ICDataSourceConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ICDataSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ICDataSourceConfigurationList Properties

[image] [image]

IceLib Technical Reference
ICDataSourceConfigurationList Properties
ICDataSourceConfigurationList Class See Also Send Feedback

The ICDataSourceConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ICDataSourceConfigurationList Class
ININ.IceLib.Configuration Namespace


IEditable Interface

[image]

IceLib Technical Reference
IEditable Interface
Members See Also Send Feedback
Defines common aspects of a configuration object that can be in an editable state.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IEditable
Visual Basic
Public Interface IEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

IEditable Members
ININ.IceLib.Configuration Namespace


IEditable Members

[image] [image]

IceLib Technical Reference
IEditable Members
IEditable Interface Properties See Also Send Feedback

The IEditable type exposes the following members.

Properties

 | Name | Description
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.

See Also

IEditable Interface
ININ.IceLib.Configuration Namespace


IEditable Properties

[image] [image]

IceLib Technical Reference
IEditable Properties
IEditable Interface See Also Send Feedback

The IEditable type exposes the following members.

Properties

 | Name | Description
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.

See Also

IEditable Interface
ININ.IceLib.Configuration Namespace


IsEditable Property

[image]

IceLib Technical Reference
IEditable..::..IsEditable Property
IEditable Interface See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
bool IsEditable { get; }
Visual Basic
ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

IEditable Interface
IEditable Members
ININ.IceLib.Configuration Namespace


ImageResource Class

[image]

IceLib Technical Reference
ImageResource Class
Members See Also Send Feedback
Represents an image resource for an ImageResourceConfiguration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImageResource : IDeepCloneable,
    IEditableProvider
Visual Basic
Public Class ImageResource _
    Implements IDeepCloneable, IEditableProvider

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ImageResource

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResource Members
ININ.IceLib.Configuration Namespace


ImageResource Members

[image] [image]

IceLib Technical Reference
ImageResource Members
ImageResource Class Methods Properties See Also Send Feedback

The ImageResource type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetImage(Stream) | Sets the image from an existing image file stream.
Public method | SetImage(String) | Sets the image from an existing image file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HasChanged | Gets a value indicating whether this image resource has changed.
Public property | ImageStream | Gets a readonly image stream that represents the image resource.

See Also

ImageResource Class
ININ.IceLib.Configuration Namespace


ImageResource Methods

[image] [image]

IceLib Technical Reference
ImageResource Methods
ImageResource Class See Also Send Feedback

The ImageResource type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetImage(Stream) | Sets the image from an existing image file stream.
Public method | SetImage(String) | Sets the image from an existing image file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageResource Class
ININ.IceLib.Configuration Namespace


Clone Method

[image]

IceLib Technical Reference
ImageResource..::..Clone Method
ImageResource Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResource Class
ImageResource Members
ININ.IceLib.Configuration Namespace


SetImage Method

[image] [image]

IceLib Technical Reference
ImageResource..::..SetImage Method
ImageResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetImage(Stream) | Sets the image from an existing image file stream.
Public method | SetImage(String) | Sets the image from an existing image file.

See Also

ImageResource Class
ImageResource Members
ININ.IceLib.Configuration Namespace


SetImage Method (Stream)

[image]

IceLib Technical Reference
ImageResource..::..SetImage Method (Stream)
ImageResource Class See Also Send Feedback
Sets the image from an existing image file stream.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetImage(
    Stream imageStream
)
Visual Basic
Public Sub SetImage ( _
    imageStream As Stream _
)

Parameters

imageStream
Type: System.IO..::..Stream
The image stream.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The image stream is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The image resource is currently not editable, or the image stream cannot be read.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResource Class
ImageResource Members
SetImage Overload
ININ.IceLib.Configuration Namespace


SetImage Method (String)

[image]

IceLib Technical Reference
ImageResource..::..SetImage Method (String)
ImageResource Class See Also Send Feedback
Sets the image from an existing image file.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetImage(
    string filePath
)
Visual Basic
Public Sub SetImage ( _
    filePath As String _
)

Parameters

filePath
Type: System..::..String
The file path.

Exceptions

Exception | Condition
System.IO..::..FileNotFoundException | filePath does not exist.
System..::..InvalidOperationException | The image resource is currently not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResource Class
ImageResource Members
SetImage Overload
ININ.IceLib.Configuration Namespace


ImageResource Properties

[image] [image]

IceLib Technical Reference
ImageResource Properties
ImageResource Class See Also Send Feedback

The ImageResource type exposes the following members.

Properties

 | Name | Description
Public property | HasChanged | Gets a value indicating whether this image resource has changed.
Public property | ImageStream | Gets a readonly image stream that represents the image resource.

See Also

ImageResource Class
ININ.IceLib.Configuration Namespace


HasChanged Property

[image]

IceLib Technical Reference
ImageResource..::..HasChanged Property
ImageResource Class See Also Send Feedback
Gets a value indicating whether this image resource has changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasChanged { get; private set; }
Visual Basic
Public Property HasChanged As Boolean
    Get
    Private Set

Field Value

true if this image resource has changed; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResource Class
ImageResource Members
ININ.IceLib.Configuration Namespace


ImageStream Property

[image]

IceLib Technical Reference
ImageResource..::..ImageStream Property
ImageResource Class See Also Send Feedback
Gets a readonly image stream that represents the image resource.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Stream ImageStream { get; }
Visual Basic
Public ReadOnly Property ImageStream As Stream
    Get

Field Value

The readonly image stream.

Remarks

To use the image stream to create a displayable image, the following can be used:

Examples

CopyC#
Bitmap bitmap = new Bitmap(configurationObject.ImageResource.ImageStream);

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResource Class
ImageResource Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration Class

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for ImageResourceCategory.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImageResourceCategoryConfiguration : ListConfigurationObject
Visual Basic
Public Class ImageResourceCategoryConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..ImageResourceCategoryConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration Members

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfiguration Members
ImageResourceCategoryConfiguration Class Methods Properties See Also Send Feedback

The ImageResourceCategoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | MaximumFileSize | Provides access to the property representing the Maximum File Size (use Property.MaximumFileSize).
Public property | MaximumHorizontalResolution | Provides access to the property representing the Maximum Horizontal Resolution (use Property.MaximumHorizontalResolution).
Public property | MaximumVerticalResolution | Provides access to the property representing the Maximum Vertical Resolution (use Property.MaximumVerticalResolution).
Public property | MinimumHorizontalResolution | Provides access to the property representing the Minimum Horizontal Resolution (use Property.MinimumHorizontalResolution).
Public property | MinimumVerticalResolution | Provides access to the property representing the Minimum Vertical Resolution (use Property.MinimumVerticalResolution).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | SupportedTypes | Provides access to the property representing the SupportedTypes (use Property.SupportedTypes).

See Also

ImageResourceCategoryConfiguration Class
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration Methods

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfiguration Methods
ImageResourceCategoryConfiguration Class See Also Send Feedback

The ImageResourceCategoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ImageResourceCategoryConfiguration Class
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration Properties

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfiguration Properties
ImageResourceCategoryConfiguration Class See Also Send Feedback

The ImageResourceCategoryConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | MaximumFileSize | Provides access to the property representing the Maximum File Size (use Property.MaximumFileSize).
Public property | MaximumHorizontalResolution | Provides access to the property representing the Maximum Horizontal Resolution (use Property.MaximumHorizontalResolution).
Public property | MaximumVerticalResolution | Provides access to the property representing the Maximum Vertical Resolution (use Property.MaximumVerticalResolution).
Public property | MinimumHorizontalResolution | Provides access to the property representing the Minimum Horizontal Resolution (use Property.MinimumHorizontalResolution).
Public property | MinimumVerticalResolution | Provides access to the property representing the Minimum Vertical Resolution (use Property.MinimumVerticalResolution).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | SupportedTypes | Provides access to the property representing the SupportedTypes (use Property.SupportedTypes).

See Also

ImageResourceCategoryConfiguration Class
ININ.IceLib.Configuration Namespace


MaximumFileSize Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..MaximumFileSize Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the Maximum File Size (use Property.MaximumFileSize).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceCategoryConfiguration..::..Property, int> MaximumFileSize { get; }
Visual Basic
Public ReadOnly Property MaximumFileSize As GeneralConfigurationProperty(Of ImageResourceCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Maximum File Size.

Remarks

The maximum file size is represented in KB.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


MaximumHorizontalResolution Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..MaximumHorizontalResolution Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the Maximum Horizontal Resolution (use Property.MaximumHorizontalResolution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceCategoryConfiguration..::..Property, int> MaximumHorizontalResolution { get; }
Visual Basic
Public ReadOnly Property MaximumHorizontalResolution As GeneralConfigurationProperty(Of ImageResourceCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Maximum Horizontal Resolution.

Remarks

The resolution is expressed in pixels.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


MaximumVerticalResolution Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..MaximumVerticalResolution Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the Maximum Vertical Resolution (use Property.MaximumVerticalResolution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceCategoryConfiguration..::..Property, int> MaximumVerticalResolution { get; }
Visual Basic
Public ReadOnly Property MaximumVerticalResolution As GeneralConfigurationProperty(Of ImageResourceCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Maximum Vertical Resolution.

Remarks

The resolution is expressed in pixels.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


MinimumHorizontalResolution Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..MinimumHorizontalResolution Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the Minimum Horizontal Resolution (use Property.MinimumHorizontalResolution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceCategoryConfiguration..::..Property, int> MinimumHorizontalResolution { get; }
Visual Basic
Public ReadOnly Property MinimumHorizontalResolution As GeneralConfigurationProperty(Of ImageResourceCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Minimum Horizontal Resolution.

Remarks

The resolution is expressed in pixels.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


MinimumVerticalResolution Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..MinimumVerticalResolution Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the Minimum Vertical Resolution (use Property.MinimumVerticalResolution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceCategoryConfiguration..::..Property, int> MinimumVerticalResolution { get; }
Visual Basic
Public ReadOnly Property MinimumVerticalResolution As GeneralConfigurationProperty(Of ImageResourceCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Minimum Vertical Resolution.

Remarks

The resolution is expressed in pixels.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..StandardProperties Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ImageResourceCategoryConfiguration, ImageResourceCategoryConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ImageResourceCategoryConfiguration, ImageResourceCategoryConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


SupportedTypes Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..SupportedTypes Property
ImageResourceCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the SupportedTypes (use Property.SupportedTypes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceCategoryConfiguration..::..Property, Collection<ImageMimeType>> SupportedTypes { get; }
Visual Basic
Public ReadOnly Property SupportedTypes As GeneralConfigurationProperty(Of ImageResourceCategoryConfiguration..::..Property, Collection(Of ImageMimeType))
    Get

Field Value

The property representing the SupportedTypes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration Class
ImageResourceCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..Property Enumeration
ImageResourceCategoryConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
MaximumFileSize | 0 | Represents the MaximumFileSize property.
MaximumHorizontalResolution | 1 | Represents the MaximumHorizontalResolution property.
MaximumVerticalResolution | 2 | Represents the MaximumVerticalResolution property.
MinimumHorizontalResolution | 3 | Represents the MinimumHorizontalResolution property.
MinimumVerticalResolution | 4 | Represents the MinimumVerticalResolution property.
SupportedTypes | 5 | Represents the SupportedTypes property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration.Rights Class

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..Rights Class
ImageResourceCategoryConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ImageResourceCategoryConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..Rights Members
ImageResourceCategoryConfiguration..::..Rights Class Properties See Also Send Feedback

The ImageResourceCategoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ImageResourceCategoryConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..Rights Properties
ImageResourceCategoryConfiguration..::..Rights Class See Also Send Feedback

The ImageResourceCategoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ImageResourceCategoryConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..Rights..::..Admin Property
ImageResourceCategoryConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ImageResourceCategoryConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ImageResourceCategoryConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration..::..Rights Class
ImageResourceCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
ImageResourceCategoryConfiguration..::..Rights..::..View Property
ImageResourceCategoryConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ImageResourceCategoryConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ImageResourceCategoryConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfiguration..::..Rights Class
ImageResourceCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfigurationList Class

[image]

IceLib Technical Reference
ImageResourceCategoryConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ImageResourceCategory configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImageResourceCategoryConfigurationList : ConfigurationList<ImageResourceCategoryConfiguration, ImageResourceCategoryConfiguration..::..Property>
Visual Basic
Public Class ImageResourceCategoryConfigurationList _
    Inherits ConfigurationList(Of ImageResourceCategoryConfiguration, ImageResourceCategoryConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ImageResourceCategoryConfiguration, ImageResourceCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ImageResourceCategoryConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfigurationList Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfigurationList Members

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfigurationList Members
ImageResourceCategoryConfigurationList Class Constructors Methods Properties See Also Send Feedback

The ImageResourceCategoryConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ImageResourceCategoryConfigurationList | Initializes a new instance of the ImageResourceCategoryConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ImageResourceCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfigurationList Constructor

[image]

IceLib Technical Reference
ImageResourceCategoryConfigurationList Constructor
ImageResourceCategoryConfigurationList Class See Also Send Feedback
Initializes a new instance of the ImageResourceCategoryConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImageResourceCategoryConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceCategoryConfigurationList Class
ImageResourceCategoryConfigurationList Members
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfigurationList Methods

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfigurationList Methods
ImageResourceCategoryConfigurationList Class See Also Send Feedback

The ImageResourceCategoryConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageResourceCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


ImageResourceCategoryConfigurationList Properties

[image] [image]

IceLib Technical Reference
ImageResourceCategoryConfigurationList Properties
ImageResourceCategoryConfigurationList Class See Also Send Feedback

The ImageResourceCategoryConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ImageResourceCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration Class

[image]

IceLib Technical Reference
ImageResourceConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for ImageResource.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImageResourceConfiguration : EditableListConfigurationObject<ImageResourceConfiguration..::..Property>
Visual Basic
Public Class ImageResourceConfiguration _
    Inherits EditableListConfigurationObject(Of ImageResourceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ImageResourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ImageResourceConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration Members

[image] [image]

IceLib Technical Reference
ImageResourceConfiguration Members
ImageResourceConfiguration Class Methods Properties See Also Send Feedback

The ImageResourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DownloadResource | Downloads an existing image resource from the IC server.
Public method | DownloadResourceAsync | Asynchronously downloads an existing image resource from the IC server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId(String).)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Category | Provides access to the property representing the Category (use Property.Category).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the Description (use Property.Description).
Public property | FileDateLastModified | Provides access to the property representing the File Date Last Modified (use Property.FileDateLastModified).
Public property | HorizontalResolution | Provides access to the property representing the Horizontal Resolution (use Property.HorizontalResolution).
Public property | ImageResource | Gets the image resource.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | MimeType | Provides access to the property representing the Mime Type (use Property.MimeType).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Tags | Provides access to the property representing the Tags (use Property.Tags).
Public property | VerticalResolution | Provides access to the property representing the Vertical Resolution (use Property.VerticalResolution).

See Also

ImageResourceConfiguration Class
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration Methods

[image] [image]

IceLib Technical Reference
ImageResourceConfiguration Methods
ImageResourceConfiguration Class See Also Send Feedback

The ImageResourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DownloadResource | Downloads an existing image resource from the IC server.
Public method | DownloadResourceAsync | Asynchronously downloads an existing image resource from the IC server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId(String).)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ImageResourceConfiguration Class
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Commit Method
ImageResourceConfiguration Class See Also Send Feedback
Commits the contents of this object to the server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Remarks

PrepareForEdit()()()() should be called prior to modifying an object's settings or calling Commit(). When this operation completes successfully, if the derived object supports transactions, the transaction ID property will be cleared.

Exceptions

Exception | Condition
System..::..InvalidOperationException | ImageResource has not been set.
ININ.IceLib..::..InsufficientRightsException | Unable to perform operation due to insufficient rights.
ININ.IceLib.Configuration..::..ConfigurationLicenseException | A license error was encountered while saving license changes.
ININ.IceLib.Configuration..::..ConfigurationValidationException | Validation failed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


DownloadResource Method

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..DownloadResource Method
ImageResourceConfiguration Class See Also Send Feedback
Downloads an existing image resource from the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadResource()
Visual Basic
Public Sub DownloadResource

Remarks

When complete, the ImageResource property will contain the image resource details.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The image resource is new and does not exist on the IC server yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


DownloadResourceAsync Method

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..DownloadResourceAsync Method
ImageResourceConfiguration Class See Also Send Feedback
Asynchronously downloads an existing image resource from the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadResourceAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub DownloadResourceAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When complete, the ImageResource property will contain the image resource details.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The image resource is new and does not exist on the IC server yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


SetConfigurationId Method

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..SetConfigurationId Method
ImageResourceConfiguration Class See Also Send Feedback
Sets the unique identifier used to reference this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void SetConfigurationId(
    string id
)
Visual Basic
Public Overrides Sub SetConfigurationId ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Remarks

All configuration objects must have an ID set; however, not all configuration objects support setting both the ID and display name. For more information about the objects that support setting the display name separately, see SetDisplayName(String).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The configuration object is not newly created or already had Commit()()()() called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration Properties

[image] [image]

IceLib Technical Reference
ImageResourceConfiguration Properties
ImageResourceConfiguration Class See Also Send Feedback

The ImageResourceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Category | Provides access to the property representing the Category (use Property.Category).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the Description (use Property.Description).
Public property | FileDateLastModified | Provides access to the property representing the File Date Last Modified (use Property.FileDateLastModified).
Public property | HorizontalResolution | Provides access to the property representing the Horizontal Resolution (use Property.HorizontalResolution).
Public property | ImageResource | Gets the image resource.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | MimeType | Provides access to the property representing the Mime Type (use Property.MimeType).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Tags | Provides access to the property representing the Tags (use Property.Tags).
Public property | VerticalResolution | Provides access to the property representing the Vertical Resolution (use Property.VerticalResolution).

See Also

ImageResourceConfiguration Class
ININ.IceLib.Configuration Namespace


Category Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Category Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Category (use Property.Category).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, ConfigurationId> Category { get; }
Visual Basic
Public ReadOnly Property Category As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the Category.

Remarks

This property can only be set when creating the object for the first time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Description Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Description (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, String)
    Get

Field Value

The property representing the Description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


FileDateLastModified Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..FileDateLastModified Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the File Date Last Modified (use Property.FileDateLastModified).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, DateTime> FileDateLastModified { get; }
Visual Basic
Public ReadOnly Property FileDateLastModified As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, DateTime)
    Get

Field Value

The read-only property representing the File Date Last Modified.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


HorizontalResolution Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..HorizontalResolution Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Horizontal Resolution (use Property.HorizontalResolution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, int> HorizontalResolution { get; }
Visual Basic
Public ReadOnly Property HorizontalResolution As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Horizontal Resolution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResource Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..ImageResource Property
ImageResourceConfiguration Class See Also Send Feedback
Gets the image resource.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImageResource ImageResource { get; }
Visual Basic
Public ReadOnly Property ImageResource As ImageResource
    Get

Field Value

The document.

Remarks

For an existing configuration object, a call to DownloadResource()()()() or DownloadResourceAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) is required prior to accessing the resource. When calling Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object), the image resource will be uploaded to the server if the configuration object is new, or if the image resource has been modified. Additionally, if editing an existing image resource, the image resource must be downloaded prior to calling PrepareForEdit()()()().

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


MimeType Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..MimeType Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Mime Type (use Property.MimeType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, ImageMimeType> MimeType { get; }
Visual Basic
Public ReadOnly Property MimeType As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, ImageMimeType)
    Get

Field Value

The property representing the Mime Type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..PropertiesChanged Property
ImageResourceConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ImageResourceConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ImageResourceConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..StandardProperties Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ImageResourceConfiguration, ImageResourceConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ImageResourceConfiguration, ImageResourceConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


Tags Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Tags Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Tags (use Property.Tags).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, Collection<string>> Tags { get; }
Visual Basic
Public ReadOnly Property Tags As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the Tags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


VerticalResolution Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..VerticalResolution Property
ImageResourceConfiguration Class See Also Send Feedback
Provides access to the property representing the Vertical Resolution (use Property.VerticalResolution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ImageResourceConfiguration..::..Property, int> VerticalResolution { get; }
Visual Basic
Public ReadOnly Property VerticalResolution As GeneralConfigurationProperty(Of ImageResourceConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Vertical Resolution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ImageResourceConfiguration Class
ImageResourceConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Property Enumeration
ImageResourceConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Category | 0 | Represents the Category property.
Description | 1 | Represents the Description property.
MimeType | 2 | Represents the MimeType property.
Tags | 3 | Represents the Tags property.
FileDateLastModified | 4 | Represents the FileDateLastModified property.
HorizontalResolution | 5 | Represents the HorizontalResolution property.
VerticalResolution | 6 | Represents the VerticalResolution property.
DisplayName | 7 | Represents the DisplayName part of the ConfigurationId property.
Id | 8 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ImageResourceConfiguration.Rights Class

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Rights Class
ImageResourceConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ImageResourceConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ImageResourceConfiguration..::..Rights Members
ImageResourceConfiguration..::..Rights Class Properties See Also Send Feedback

The ImageResourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ImageResourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ImageResourceConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ImageResourceConfiguration..::..Rights Properties
ImageResourceConfiguration..::..Rights Class See Also Send Feedback

The ImageResourceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ImageResourceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Rights..::..Admin Property
ImageResourceConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ImageResourceConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ImageResourceConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration..::..Rights Class
ImageResourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ImageResources


View Property

[image]

IceLib Technical Reference
ImageResourceConfiguration..::..Rights..::..View Property
ImageResourceConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ImageResourceConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ImageResourceConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfiguration..::..Rights Class
ImageResourceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ImageResourceConfigurationList Class

[image]

IceLib Technical Reference
ImageResourceConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ImageResource configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImageResourceConfigurationList : EditableConfigurationList<ImageResourceConfiguration, ImageResourceConfiguration..::..Property>
Visual Basic
Public Class ImageResourceConfigurationList _
    Inherits EditableConfigurationList(Of ImageResourceConfiguration, ImageResourceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ImageResourceConfiguration, ImageResourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ImageResourceConfiguration, ImageResourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ImageResourceConfiguration, ImageResourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ImageResourceConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfigurationList Members
ININ.IceLib.Configuration Namespace


ImageResourceConfigurationList Members

[image] [image]

IceLib Technical Reference
ImageResourceConfigurationList Members
ImageResourceConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ImageResourceConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ImageResourceConfigurationList | Initializes a new instance of the ImageResourceConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ImageResourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ImageResourceConfigurationList Constructor

[image]

IceLib Technical Reference
ImageResourceConfigurationList Constructor
ImageResourceConfigurationList Class See Also Send Feedback
Initializes a new instance of the ImageResourceConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImageResourceConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ImageResourceConfigurationList Class
ImageResourceConfigurationList Members
ININ.IceLib.Configuration Namespace


ImageResourceConfigurationList Methods

[image] [image]

IceLib Technical Reference
ImageResourceConfigurationList Methods
ImageResourceConfigurationList Class See Also Send Feedback

The ImageResourceConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageResourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ImageResourceConfigurationList Properties

[image] [image]

IceLib Technical Reference
ImageResourceConfigurationList Properties
ImageResourceConfigurationList Class See Also Send Feedback

The ImageResourceConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ImageResourceConfigurationList Class
ININ.IceLib.Configuration Namespace


ImageResourceConfigurationList Events

[image] [image]

IceLib Technical Reference
ImageResourceConfigurationList Events
ImageResourceConfigurationList Class See Also Send Feedback

The ImageResourceConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ImageResourceConfigurationList Class
ININ.IceLib.Configuration Namespace


InheritableConfigurationProperty(TPropertyEnum, TValue) Class

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
Members See Also Send Feedback
Represents an inheritable configuration property.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InheritableConfigurationProperty<TPropertyEnum, TValue> : GeneralConfigurationProperty<TPropertyEnum, TValue>
where TPropertyEnum : struct, new()
Visual Basic
Public Class InheritableConfigurationProperty(Of TPropertyEnum As {Structure, New}, TValue) _
    Inherits GeneralConfigurationProperty(Of TPropertyEnum, TValue)

Type Parameters

TPropertyEnum
The type of the property enumeration.
TValue
The type of the value.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationProperty <(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..GeneralConfigurationProperty <(Of <(<'TPropertyEnum, TValue>)>)>
ININ.IceLib.Configuration..::..InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>
ININ.IceLib.Configuration..::..DetailedInheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


InheritableConfigurationProperty(TPropertyEnum, TValue) Members

[image] [image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> | Initializes a new instance of the InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> class.

Methods

 | Name | Description
Public method | ClearPropertyValue | Clears the property value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..GetHashCode()()()().)
Public method | GetInheritedDetails<(Of <<'(TConfigurationObject>)>>) | Gets the inherited details.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public method | IsValueDefined | Determines whether the value stored directly with this object is defined on the server or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

Properties

 | Name | Description
Public property | EffectiveValue | Gets the effective value of this property.
Public property | InheritedValue | Gets the inherited value.
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsReadOnly | Gets a value indicating whether this property is read only. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | PropertyEnum | Gets the property enumeration. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Value | Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.) (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


InheritableConfigurationProperty(TPropertyEnum, TValue) Constructor

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Constructor
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Initializes a new instance of the InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected InheritableConfigurationProperty(
    InheritableConfigurationProperty<TPropertyEnum, TValue> copy
)
Visual Basic
Protected Sub New ( _
    copy As InheritableConfigurationProperty(Of TPropertyEnum, TValue) _
)

Parameters

copy
Type: ININ.IceLib.Configuration..::..InheritableConfigurationProperty <(Of <(<' TPropertyEnum, TValue >)>)>
The copy.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


InheritableConfigurationProperty(TPropertyEnum, TValue) Methods

[image] [image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Methods
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback

The InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | ClearPropertyValue | Clears the property value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>..::..GetHashCode()()()().)
Public method | GetInheritedDetails<(Of <<'(TConfigurationObject>)>>) | Gets the inherited details.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines whether this instance is valid, according to its Validators. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public method | IsValueDefined | Determines whether the value stored directly with this object is defined on the server or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


ClearPropertyValue Method

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..ClearPropertyValue Method
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Clears the property value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ClearPropertyValue()
Visual Basic
Public Sub ClearPropertyValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


Equals Method

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..Equals Method
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


GetHashCode Method

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..GetHashCode Method
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


GetInheritedDetails(TConfigurationObject) Method

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..GetInheritedDetails<(Of <(<'TConfigurationObject>)>)> Method
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Gets the inherited details.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritedValueDetails<TValue> GetInheritedDetails<TConfigurationObject>(
    ConfigurationManager configurationManager,
    ConfigurationId configurationId
)
where TConfigurationObject : ListConfigurationObject
Visual Basic
Public Function GetInheritedDetails(Of TConfigurationObject As ListConfigurationObject) ( _
    configurationManager As ConfigurationManager, _
    configurationId As ConfigurationId _
) As InheritedValueDetails(Of TValue)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
configurationId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The configuration ID.

Type Parameters

TConfigurationObject
The type of the configuration object that the property is tied to. For instance, UserConfiguration.

Return Value

An InheritedValueDetails<(Of <(<'TValue>)>)> object that contains the inherited details for this property.

Remarks

An active StartCaching()()()() or StartWatching()()()() call is not required to execute this method; however, a StartCaching()()()() or StartWatching()()()() call must have been previously made in order to supply the appropriate configurationId.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


IsValueDefined Method

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..IsValueDefined Method
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Determines whether the value stored directly with this object is defined on the server or not.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsValueDefined()
Visual Basic
Public Function IsValueDefined As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if the value is defined; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


InheritableConfigurationProperty(TPropertyEnum, TValue) Properties

[image] [image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Properties
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback

The InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | EffectiveValue | Gets the effective value of this property.
Public property | InheritedValue | Gets the inherited value.
Public property | IsCreateOnly | Gets a value indicating whether this property is only valid for create. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | IsReadOnly | Gets a value indicating whether this property is read only. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | PropertyEnum | Gets the property enumeration. (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Validators | Gets the validators, if any, for this property. (Only available if GetValidators()()()() has been called.) (Inherited from ConfigurationProperty<(Of <(<'TPropertyEnum>)>)>.)
Public property | Value | Gets or sets the value. (Setting the value is only supported when editing an object and for non-Collection based TValue.) (Inherited from GeneralConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>.)

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
ININ.IceLib.Configuration Namespace


EffectiveValue Property

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..EffectiveValue Property
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Gets the effective value of this property.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValue EffectiveValue { get; internal set; }
Visual Basic
Public Property EffectiveValue As TValue
    Get
    Friend Set

Field Value

The effective value.

Remarks

This is the effective value of the property as calculated by the server. If the value is not set locally on the configuration object, then the EffectiveValue will represent the system default or the inherited value of the property (if the property can be inherited).
Note
This value is not updated when setting the Value of this property. The EffectiveValue field is updated on the server. Changes made will show after the data has been committed and the cache refreshed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>


InheritedValue Property

[image]

IceLib Technical Reference
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)>..::..InheritedValue Property
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class See Also Send Feedback
Gets the inherited value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValue InheritedValue { get; internal set; }
Visual Basic
Public Property InheritedValue As TValue
    Get
    Friend Set

Field Value

The inherited value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Class
InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> Members
ININ.IceLib.Configuration Namespace


InheritedValueDetails(TValue) Class

[image]

IceLib Technical Reference
InheritedValueDetails<(Of <(<'TValue>)>)> Class
Members See Also Send Feedback
Represents details about an inherited configuration reference.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InheritedValueDetails<TValue>
Visual Basic
Public Class InheritedValueDetails(Of TValue)

Type Parameters

TValue
The type of the value.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..InheritedValueDetails<(Of <(<'TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritedValueDetails<(Of <(<'TValue>)>)> Members
ININ.IceLib.Configuration Namespace


InheritedValueDetails(TValue) Members

[image] [image]

IceLib Technical Reference
InheritedValueDetails<(Of <(<'TValue>)>)> Members
InheritedValueDetails<(Of <(<'TValue>)>)> Class Methods Properties See Also Send Feedback

The InheritedValueDetails<(Of <(<'TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReferenceList | Gets the reference list.

See Also

InheritedValueDetails<(Of <(<'TValue>)>)> Class
ININ.IceLib.Configuration Namespace


InheritedValueDetails(TValue) Methods

[image] [image]

IceLib Technical Reference
InheritedValueDetails<(Of <(<'TValue>)>)> Methods
InheritedValueDetails<(Of <(<'TValue>)>)> Class See Also Send Feedback

The InheritedValueDetails<(Of <(<'TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InheritedValueDetails<(Of <(<'TValue>)>)> Class
ININ.IceLib.Configuration Namespace


InheritedValueDetails(TValue) Properties

[image] [image]

IceLib Technical Reference
InheritedValueDetails<(Of <(<'TValue>)>)> Properties
InheritedValueDetails<(Of <(<'TValue>)>)> Class See Also Send Feedback

The InheritedValueDetails<(Of <(<'TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ReferenceList | Gets the reference list.

See Also

InheritedValueDetails<(Of <(<'TValue>)>)> Class
ININ.IceLib.Configuration Namespace


ReferenceList Property

[image]

IceLib Technical Reference
InheritedValueDetails<(Of <(<'TValue>)>)>..::..ReferenceList Property
InheritedValueDetails<(Of <(<'TValue>)>)> Class See Also Send Feedback
Gets the reference list.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TypedReferenceValue<TValue>> ReferenceList { get; }
Visual Basic
Public ReadOnly Property ReferenceList As ReadOnlyCollection(Of TypedReferenceValue(Of TValue))
    Get

Field Value

The reference list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

InheritedValueDetails<(Of <(<'TValue>)>)> Class
InheritedValueDetails<(Of <(<'TValue>)>)> Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration Class

[image]

IceLib Technical Reference
InitializationFunctionConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Initialization Function. Initialization functions are functions that perform some system initialization when the IC system starts. These functions are contained in DLLs that must be registered on the IC Server in the Interaction Administrator utility.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InitializationFunctionConfiguration : ListConfigurationObject
Visual Basic
Public Class InitializationFunctionConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..InitializationFunctionConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfiguration Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration Members

[image] [image]

IceLib Technical Reference
InitializationFunctionConfiguration Members
InitializationFunctionConfiguration Class Methods Properties See Also Send Feedback

The InitializationFunctionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

InitializationFunctionConfiguration Class
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration Methods

[image] [image]

IceLib Technical Reference
InitializationFunctionConfiguration Methods
InitializationFunctionConfiguration Class See Also Send Feedback

The InitializationFunctionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

InitializationFunctionConfiguration Class
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration Properties

[image] [image]

IceLib Technical Reference
InitializationFunctionConfiguration Properties
InitializationFunctionConfiguration Class See Also Send Feedback

The InitializationFunctionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

InitializationFunctionConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..StandardProperties Property
InitializationFunctionConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<InitializationFunctionConfiguration, InitializationFunctionConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of InitializationFunctionConfiguration, InitializationFunctionConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfiguration Class
InitializationFunctionConfiguration Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration.Property Enumeration

[image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..Property Enumeration
InitializationFunctionConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration.Rights Class

[image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..Rights Class
InitializationFunctionConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..InitializationFunctionConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..Rights Members
InitializationFunctionConfiguration..::..Rights Class Properties See Also Send Feedback

The InitializationFunctionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InitializationFunctionConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


InitializationFunctionConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..Rights Properties
InitializationFunctionConfiguration..::..Rights Class See Also Send Feedback

The InitializationFunctionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InitializationFunctionConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..Rights..::..Admin Property
InitializationFunctionConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InitializationFunctionConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of InitializationFunctionConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfiguration..::..Rights Class
InitializationFunctionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InitializationFunctions


View Property

[image]

IceLib Technical Reference
InitializationFunctionConfiguration..::..Rights..::..View Property
InitializationFunctionConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InitializationFunctionConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of InitializationFunctionConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfiguration..::..Rights Class
InitializationFunctionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfigurationList Class

[image]

IceLib Technical Reference
InitializationFunctionConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing InitializationFunction configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InitializationFunctionConfigurationList : DynamicConfigurationList<InitializationFunctionConfiguration, InitializationFunctionConfiguration..::..Property>
Visual Basic
Public Class InitializationFunctionConfigurationList _
    Inherits DynamicConfigurationList(Of InitializationFunctionConfiguration, InitializationFunctionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' InitializationFunctionConfiguration, InitializationFunctionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' InitializationFunctionConfiguration, InitializationFunctionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..InitializationFunctionConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfigurationList Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfigurationList Members

[image] [image]

IceLib Technical Reference
InitializationFunctionConfigurationList Members
InitializationFunctionConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The InitializationFunctionConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | InitializationFunctionConfigurationList | Initializes a new instance of the InitializationFunctionConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InitializationFunctionConfigurationList Class
ININ.IceLib.Configuration Namespace


InitializationFunctionConfigurationList Constructor

[image]

IceLib Technical Reference
InitializationFunctionConfigurationList Constructor
InitializationFunctionConfigurationList Class See Also Send Feedback
Initializes a new instance of the InitializationFunctionConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InitializationFunctionConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InitializationFunctionConfigurationList Class
InitializationFunctionConfigurationList Members
ININ.IceLib.Configuration Namespace


InitializationFunctionConfigurationList Methods

[image] [image]

IceLib Technical Reference
InitializationFunctionConfigurationList Methods
InitializationFunctionConfigurationList Class See Also Send Feedback

The InitializationFunctionConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitializationFunctionConfigurationList Class
ININ.IceLib.Configuration Namespace


InitializationFunctionConfigurationList Properties

[image] [image]

IceLib Technical Reference
InitializationFunctionConfigurationList Properties
InitializationFunctionConfigurationList Class See Also Send Feedback

The InitializationFunctionConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InitializationFunctionConfigurationList Class
ININ.IceLib.Configuration Namespace


InitializationFunctionConfigurationList Events

[image] [image]

IceLib Technical Reference
InitializationFunctionConfigurationList Events
InitializationFunctionConfigurationList Class See Also Send Feedback

The InitializationFunctionConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InitializationFunctionConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration Class

[image]

IceLib Technical Reference
InteractionClientPluginConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Interaction Client Plugin.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionClientPluginConfiguration : ListConfigurationObject
Visual Basic
Public Class InteractionClientPluginConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..InteractionClientPluginConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration Members

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfiguration Members
InteractionClientPluginConfiguration Class Methods Properties See Also Send Feedback

The InteractionClientPluginConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

InteractionClientPluginConfiguration Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration Methods

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfiguration Methods
InteractionClientPluginConfiguration Class See Also Send Feedback

The InteractionClientPluginConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

InteractionClientPluginConfiguration Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration Properties

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfiguration Properties
InteractionClientPluginConfiguration Class See Also Send Feedback

The InteractionClientPluginConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

InteractionClientPluginConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..StandardProperties Property
InteractionClientPluginConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<InteractionClientPluginConfiguration, InteractionClientPluginConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of InteractionClientPluginConfiguration, InteractionClientPluginConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfiguration Class
InteractionClientPluginConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration.Property Enumeration

[image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..Property Enumeration
InteractionClientPluginConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration.Rights Class

[image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..Rights Class
InteractionClientPluginConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..InteractionClientPluginConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..Rights Members
InteractionClientPluginConfiguration..::..Rights Class Properties See Also Send Feedback

The InteractionClientPluginConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InteractionClientPluginConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..Rights Properties
InteractionClientPluginConfiguration..::..Rights Class See Also Send Feedback

The InteractionClientPluginConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InteractionClientPluginConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..Rights..::..Admin Property
InteractionClientPluginConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InteractionClientPluginConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of InteractionClientPluginConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfiguration..::..Rights Class
InteractionClientPluginConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
InteractionClientPluginConfiguration..::..Rights..::..View Property
InteractionClientPluginConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InteractionClientPluginConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of InteractionClientPluginConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfiguration..::..Rights Class
InteractionClientPluginConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionClientPlugins


InteractionClientPluginConfigurationList Class

[image]

IceLib Technical Reference
InteractionClientPluginConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing InteractionClientPlugin configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionClientPluginConfigurationList : DynamicConfigurationList<InteractionClientPluginConfiguration, InteractionClientPluginConfiguration..::..Property>
Visual Basic
Public Class InteractionClientPluginConfigurationList _
    Inherits DynamicConfigurationList(Of InteractionClientPluginConfiguration, InteractionClientPluginConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' InteractionClientPluginConfiguration, InteractionClientPluginConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' InteractionClientPluginConfiguration, InteractionClientPluginConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..InteractionClientPluginConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfigurationList Members
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfigurationList Members

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfigurationList Members
InteractionClientPluginConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The InteractionClientPluginConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionClientPluginConfigurationList | Initializes a new instance of the InteractionClientPluginConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionClientPluginConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfigurationList Constructor

[image]

IceLib Technical Reference
InteractionClientPluginConfigurationList Constructor
InteractionClientPluginConfigurationList Class See Also Send Feedback
Initializes a new instance of the InteractionClientPluginConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionClientPluginConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionClientPluginConfigurationList Class
InteractionClientPluginConfigurationList Members
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfigurationList Methods

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfigurationList Methods
InteractionClientPluginConfigurationList Class See Also Send Feedback

The InteractionClientPluginConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionClientPluginConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfigurationList Properties

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfigurationList Properties
InteractionClientPluginConfigurationList Class See Also Send Feedback

The InteractionClientPluginConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionClientPluginConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionClientPluginConfigurationList Events

[image] [image]

IceLib Technical Reference
InteractionClientPluginConfigurationList Events
InteractionClientPluginConfigurationList Class See Also Send Feedback

The InteractionClientPluginConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionClientPluginConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration Class

[image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Interaction Conference Room. An interaction conference room defines information needed to create an interaction conference.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionConferenceRoomConfiguration : ListConfigurationObject
Visual Basic
Public Class InteractionConferenceRoomConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..InteractionConferenceRoomConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration Members

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration Members
InteractionConferenceRoomConfiguration Class Methods Properties See Also Send Feedback

The InteractionConferenceRoomConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

InteractionConferenceRoomConfiguration Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration Methods

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration Methods
InteractionConferenceRoomConfiguration Class See Also Send Feedback

The InteractionConferenceRoomConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

InteractionConferenceRoomConfiguration Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration Properties

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration Properties
InteractionConferenceRoomConfiguration Class See Also Send Feedback

The InteractionConferenceRoomConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

InteractionConferenceRoomConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..StandardProperties Property
InteractionConferenceRoomConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<InteractionConferenceRoomConfiguration, InteractionConferenceRoomConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of InteractionConferenceRoomConfiguration, InteractionConferenceRoomConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfiguration Class
InteractionConferenceRoomConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration.Property Enumeration

[image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..Property Enumeration
InteractionConferenceRoomConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration.Rights Class

[image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..Rights Class
InteractionConferenceRoomConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..InteractionConferenceRoomConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..Rights Members
InteractionConferenceRoomConfiguration..::..Rights Class Properties See Also Send Feedback

The InteractionConferenceRoomConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InteractionConferenceRoomConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..Rights Properties
InteractionConferenceRoomConfiguration..::..Rights Class See Also Send Feedback

The InteractionConferenceRoomConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InteractionConferenceRoomConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..Rights..::..Admin Property
InteractionConferenceRoomConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InteractionConferenceRoomConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of InteractionConferenceRoomConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfiguration..::..Rights Class
InteractionConferenceRoomConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionConferenceRooms


View Property

[image]

IceLib Technical Reference
InteractionConferenceRoomConfiguration..::..Rights..::..View Property
InteractionConferenceRoomConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InteractionConferenceRoomConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of InteractionConferenceRoomConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfiguration..::..Rights Class
InteractionConferenceRoomConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionConferenceRestrictRooms


InteractionConferenceRoomConfigurationList Class

[image]

IceLib Technical Reference
InteractionConferenceRoomConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing InteractionConferenceRoom configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionConferenceRoomConfigurationList : DynamicConfigurationList<InteractionConferenceRoomConfiguration, InteractionConferenceRoomConfiguration..::..Property>
Visual Basic
Public Class InteractionConferenceRoomConfigurationList _
    Inherits DynamicConfigurationList(Of InteractionConferenceRoomConfiguration, InteractionConferenceRoomConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' InteractionConferenceRoomConfiguration, InteractionConferenceRoomConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' InteractionConferenceRoomConfiguration, InteractionConferenceRoomConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..InteractionConferenceRoomConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfigurationList Members
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfigurationList Members

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfigurationList Members
InteractionConferenceRoomConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The InteractionConferenceRoomConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionConferenceRoomConfigurationList | Initializes a new instance of the InteractionConferenceRoomConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionConferenceRoomConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfigurationList Constructor

[image]

IceLib Technical Reference
InteractionConferenceRoomConfigurationList Constructor
InteractionConferenceRoomConfigurationList Class See Also Send Feedback
Initializes a new instance of the InteractionConferenceRoomConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionConferenceRoomConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConferenceRoomConfigurationList Class
InteractionConferenceRoomConfigurationList Members
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfigurationList Methods

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfigurationList Methods
InteractionConferenceRoomConfigurationList Class See Also Send Feedback

The InteractionConferenceRoomConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionConferenceRoomConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfigurationList Properties

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfigurationList Properties
InteractionConferenceRoomConfigurationList Class See Also Send Feedback

The InteractionConferenceRoomConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionConferenceRoomConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionConferenceRoomConfigurationList Events

[image] [image]

IceLib Technical Reference
InteractionConferenceRoomConfigurationList Events
InteractionConferenceRoomConfigurationList Class See Also Send Feedback

The InteractionConferenceRoomConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionConferenceRoomConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration Class

[image]

IceLib Technical Reference
InteractionProcessorTableConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC InteractionProcessorTable.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionProcessorTableConfiguration : ListConfigurationObject
Visual Basic
Public Class InteractionProcessorTableConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..InteractionProcessorTableConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionProcessorTableConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration Members

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfiguration Members
InteractionProcessorTableConfiguration Class Methods Properties See Also Send Feedback

The InteractionProcessorTableConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this interaction processor table (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

InteractionProcessorTableConfiguration Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration Methods

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfiguration Methods
InteractionProcessorTableConfiguration Class See Also Send Feedback

The InteractionProcessorTableConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

InteractionProcessorTableConfiguration Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration Properties

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfiguration Properties
InteractionProcessorTableConfiguration Class See Also Send Feedback

The InteractionProcessorTableConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this interaction processor table (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

InteractionProcessorTableConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..AccessControlGroupAssignment Property
InteractionProcessorTableConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this interaction processor table (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<InteractionProcessorTableConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of InteractionProcessorTableConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

InteractionProcessorTableConfiguration Class
InteractionProcessorTableConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration.Property Enumeration

[image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..Property Enumeration
InteractionProcessorTableConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration.Rights Class

[image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..Rights Class
InteractionProcessorTableConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..InteractionProcessorTableConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionProcessorTableConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..Rights Members
InteractionProcessorTableConfiguration..::..Rights Class Properties See Also Send Feedback

The InteractionProcessorTableConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InteractionProcessorTableConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..Rights Properties
InteractionProcessorTableConfiguration..::..Rights Class See Also Send Feedback

The InteractionProcessorTableConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

InteractionProcessorTableConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..Rights..::..Admin Property
InteractionProcessorTableConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InteractionProcessorTableConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of InteractionProcessorTableConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionProcessorTableConfiguration..::..Rights Class
InteractionProcessorTableConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionProcessorTables


View Property

[image]

IceLib Technical Reference
InteractionProcessorTableConfiguration..::..Rights..::..View Property
InteractionProcessorTableConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<InteractionProcessorTableConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of InteractionProcessorTableConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionProcessorTableConfiguration..::..Rights Class
InteractionProcessorTableConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfigurationList Class

[image]

IceLib Technical Reference
InteractionProcessorTableConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing InteractionProcessorTable configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionProcessorTableConfigurationList : DynamicConfigurationList<InteractionProcessorTableConfiguration, InteractionProcessorTableConfiguration..::..Property>
Visual Basic
Public Class InteractionProcessorTableConfigurationList _
    Inherits DynamicConfigurationList(Of InteractionProcessorTableConfiguration, InteractionProcessorTableConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' InteractionProcessorTableConfiguration, InteractionProcessorTableConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' InteractionProcessorTableConfiguration, InteractionProcessorTableConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..InteractionProcessorTableConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionProcessorTableConfigurationList Members
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfigurationList Members

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfigurationList Members
InteractionProcessorTableConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The InteractionProcessorTableConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionProcessorTableConfigurationList | Initializes a new instance of the InteractionProcessorTableConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionProcessorTableConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfigurationList Constructor

[image]

IceLib Technical Reference
InteractionProcessorTableConfigurationList Constructor
InteractionProcessorTableConfigurationList Class See Also Send Feedback
Initializes a new instance of the InteractionProcessorTableConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionProcessorTableConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionProcessorTableConfigurationList Class
InteractionProcessorTableConfigurationList Members
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfigurationList Methods

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfigurationList Methods
InteractionProcessorTableConfigurationList Class See Also Send Feedback

The InteractionProcessorTableConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionProcessorTableConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfigurationList Properties

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfigurationList Properties
InteractionProcessorTableConfigurationList Class See Also Send Feedback

The InteractionProcessorTableConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionProcessorTableConfigurationList Class
ININ.IceLib.Configuration Namespace


InteractionProcessorTableConfigurationList Events

[image] [image]

IceLib Technical Reference
InteractionProcessorTableConfigurationList Events
InteractionProcessorTableConfigurationList Class See Also Send Feedback

The InteractionProcessorTableConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

InteractionProcessorTableConfigurationList Class
ININ.IceLib.Configuration Namespace


LayoutConfiguration Class

[image]

IceLib Technical Reference
LayoutConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Layout. Layouts are used to define the physical position of agents and stations on a floor plan.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LayoutConfiguration : EditableListConfigurationObject<LayoutConfiguration..::..Property>
Visual Basic
Public Class LayoutConfiguration _
    Inherits EditableListConfigurationObject(Of LayoutConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' LayoutConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LayoutConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


LayoutConfiguration Members

[image] [image]

IceLib Technical Reference
LayoutConfiguration Members
LayoutConfiguration Class Methods Properties See Also Send Feedback

The LayoutConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this layout (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing this layout's description (use Property.Description).
Public property | ImageResource | Provides access to the property representing the image resource for this layout (use Property.ImageResource).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Location | Provides access to the property representing the location for this layout (use Property.Location).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PositionDefaultHeight | Provides access to the property representing the default position height for this layout (use Property.PositionDefaultHeight).
Public property | PositionDefaultWidth | Provides access to the property representing the default position width for this layout (use Property.PositionDefaultWidth).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LayoutConfiguration Class
ININ.IceLib.Configuration Namespace


LayoutConfiguration Methods

[image] [image]

IceLib Technical Reference
LayoutConfiguration Methods
LayoutConfiguration Class See Also Send Feedback

The LayoutConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

LayoutConfiguration Class
ININ.IceLib.Configuration Namespace


LayoutConfiguration Properties

[image] [image]

IceLib Technical Reference
LayoutConfiguration Properties
LayoutConfiguration Class See Also Send Feedback

The LayoutConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this layout (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing this layout's description (use Property.Description).
Public property | ImageResource | Provides access to the property representing the image resource for this layout (use Property.ImageResource).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Location | Provides access to the property representing the location for this layout (use Property.Location).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PositionDefaultHeight | Provides access to the property representing the default position height for this layout (use Property.PositionDefaultHeight).
Public property | PositionDefaultWidth | Provides access to the property representing the default position width for this layout (use Property.PositionDefaultWidth).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LayoutConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..AccessControlGroupAssignment Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this layout (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LayoutConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of LayoutConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..Description Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the property representing this layout's description (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LayoutConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of LayoutConfiguration..::..Property, String)
    Get

Field Value

The property representing this layout's description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


ImageResource Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..ImageResource Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the property representing the image resource for this layout (use Property.ImageResource).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LayoutConfiguration..::..Property, ConfigurationId> ImageResource { get; }
Visual Basic
Public ReadOnly Property ImageResource As GeneralConfigurationProperty(Of LayoutConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the image resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


Location Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..Location Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the property representing the location for this layout (use Property.Location).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LayoutConfiguration..::..Property, ConfigurationId> Location { get; }
Visual Basic
Public ReadOnly Property Location As GeneralConfigurationProperty(Of LayoutConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


PositionDefaultHeight Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..PositionDefaultHeight Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the property representing the default position height for this layout (use Property.PositionDefaultHeight).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LayoutConfiguration..::..Property, int> PositionDefaultHeight { get; }
Visual Basic
Public ReadOnly Property PositionDefaultHeight As GeneralConfigurationProperty(Of LayoutConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the default position width, in pixels.

Remarks

Must be between 1 and 2048.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


PositionDefaultWidth Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..PositionDefaultWidth Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the property representing the default position width for this layout (use Property.PositionDefaultWidth).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LayoutConfiguration..::..Property, int> PositionDefaultWidth { get; }
Visual Basic
Public ReadOnly Property PositionDefaultWidth As GeneralConfigurationProperty(Of LayoutConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the default position height, in pixels.

Remarks

Must be between 1 and 2048.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..PropertiesChanged Property
LayoutConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LayoutConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of LayoutConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..StandardProperties Property
LayoutConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<LayoutConfiguration, LayoutConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of LayoutConfiguration, LayoutConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration Class
LayoutConfiguration Members
ININ.IceLib.Configuration Namespace


LayoutConfiguration.Property Enumeration

[image]

IceLib Technical Reference
LayoutConfiguration..::..Property Enumeration
LayoutConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
Description | 1 | Represents the Description property.
ImageResource | 2 | Represents the ImageResource property.
Location | 3 | Represents the Location property.
PositionDefaultHeight | 4 | Represents the PositionDefaultHeight property.
PositionDefaultWidth | 5 | Represents the PositionDefaultWidth property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration Namespace


LayoutConfiguration.Rights Class

[image]

IceLib Technical Reference
LayoutConfiguration..::..Rights Class
LayoutConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..LayoutConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LayoutConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
LayoutConfiguration..::..Rights Members
LayoutConfiguration..::..Rights Class Properties See Also Send Feedback

The LayoutConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LayoutConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


LayoutConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
LayoutConfiguration..::..Rights Properties
LayoutConfiguration..::..Rights Class See Also Send Feedback

The LayoutConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LayoutConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..Rights..::..Admin Property
LayoutConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LayoutConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of LayoutConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration..::..Rights Class
LayoutConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WrapUpCodes


View Property

[image]

IceLib Technical Reference
LayoutConfiguration..::..Rights..::..View Property
LayoutConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LayoutConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of LayoutConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfiguration..::..Rights Class
LayoutConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewLayoutList


LayoutConfigurationList Class

[image]

IceLib Technical Reference
LayoutConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Layout configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LayoutConfigurationList : EditableConfigurationList<LayoutConfiguration, LayoutConfiguration..::..Property>
Visual Basic
Public Class LayoutConfigurationList _
    Inherits EditableConfigurationList(Of LayoutConfiguration, LayoutConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' LayoutConfiguration, LayoutConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' LayoutConfiguration, LayoutConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' LayoutConfiguration, LayoutConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LayoutConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfigurationList Members
ININ.IceLib.Configuration Namespace


LayoutConfigurationList Members

[image] [image]

IceLib Technical Reference
LayoutConfigurationList Members
LayoutConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The LayoutConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutConfigurationList | Initializes a new instance of the LayoutConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LayoutConfigurationList Class
ININ.IceLib.Configuration Namespace


LayoutConfigurationList Constructor

[image]

IceLib Technical Reference
LayoutConfigurationList Constructor
LayoutConfigurationList Class See Also Send Feedback
Initializes a new instance of the LayoutConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LayoutConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

LayoutConfigurationList Class
LayoutConfigurationList Members
ININ.IceLib.Configuration Namespace


LayoutConfigurationList Methods

[image] [image]

IceLib Technical Reference
LayoutConfigurationList Methods
LayoutConfigurationList Class See Also Send Feedback

The LayoutConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutConfigurationList Class
ININ.IceLib.Configuration Namespace


LayoutConfigurationList Properties

[image] [image]

IceLib Technical Reference
LayoutConfigurationList Properties
LayoutConfigurationList Class See Also Send Feedback

The LayoutConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LayoutConfigurationList Class
ININ.IceLib.Configuration Namespace


LayoutConfigurationList Events

[image] [image]

IceLib Technical Reference
LayoutConfigurationList Events
LayoutConfigurationList Class See Also Send Feedback

The LayoutConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LayoutConfigurationList Class
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration Class

[image]

IceLib Technical Reference
LicenseAllocationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC License Allocation. A license allocation defines a license known by IC's License Manager.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LicenseAllocationConfiguration : ListConfigurationObject
Visual Basic
Public Class LicenseAllocationConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..LicenseAllocationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration Members

[image] [image]

IceLib Technical Reference
LicenseAllocationConfiguration Members
LicenseAllocationConfiguration Class Methods Properties See Also Send Feedback

The LicenseAllocationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AppliedStationCount | Provides access to the property representing the applied station count for this license allocation (use Property.AppliedStationCount).
Public property | AppliedUserCount | Provides access to the property representing the applied user count for this license allocation (use Property.AppliedUserCount).
Public property | AssignableAllowedCount | Provides access to the property representing the assignable allowed count for this license allocation( use Property.AssignableAllowedCount).
Public property | AssignableConfiguredCount | Provides access to the property representing the assignable configured count for this license allocation( use Property.AssignableConfiguredCount).
Public property | ConcurrentAllowedCount | Provides access to the property representing the concurrent allowed count for this license allocation( use Property.ConcurrentAllowedCount).
Public property | ConcurrentConfiguredCount | Provides access to the property representing the concurrent configured count for this license allocation( use Property.ConcurrentConfiguredCount).
Public property | ConcurrentInUseCount | Provides access to the property representing the concurrent in use count for this license allocation( use Property.ConcurrentInUseCount).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | TotalAppliedCount | Provides access to the property representing the total applied count for this license allocation (use Property.TotalAppliedCount).
Public property | TotalCount | Provides access to the property representing the total count for this license allocation (use Property.TotalCount).

See Also

LicenseAllocationConfiguration Class
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration Methods

[image] [image]

IceLib Technical Reference
LicenseAllocationConfiguration Methods
LicenseAllocationConfiguration Class See Also Send Feedback

The LicenseAllocationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

LicenseAllocationConfiguration Class
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration Properties

[image] [image]

IceLib Technical Reference
LicenseAllocationConfiguration Properties
LicenseAllocationConfiguration Class See Also Send Feedback

The LicenseAllocationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AppliedStationCount | Provides access to the property representing the applied station count for this license allocation (use Property.AppliedStationCount).
Public property | AppliedUserCount | Provides access to the property representing the applied user count for this license allocation (use Property.AppliedUserCount).
Public property | AssignableAllowedCount | Provides access to the property representing the assignable allowed count for this license allocation( use Property.AssignableAllowedCount).
Public property | AssignableConfiguredCount | Provides access to the property representing the assignable configured count for this license allocation( use Property.AssignableConfiguredCount).
Public property | ConcurrentAllowedCount | Provides access to the property representing the concurrent allowed count for this license allocation( use Property.ConcurrentAllowedCount).
Public property | ConcurrentConfiguredCount | Provides access to the property representing the concurrent configured count for this license allocation( use Property.ConcurrentConfiguredCount).
Public property | ConcurrentInUseCount | Provides access to the property representing the concurrent in use count for this license allocation( use Property.ConcurrentInUseCount).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | TotalAppliedCount | Provides access to the property representing the total applied count for this license allocation (use Property.TotalAppliedCount).
Public property | TotalCount | Provides access to the property representing the total count for this license allocation (use Property.TotalCount).

See Also

LicenseAllocationConfiguration Class
ININ.IceLib.Configuration Namespace


AppliedStationCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..AppliedStationCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the applied station count for this license allocation (use Property.AppliedStationCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> AppliedStationCount { get; }
Visual Basic
Public ReadOnly Property AppliedStationCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the applied station count.

Remarks

This is the number of stations allocated to this license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


AppliedUserCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..AppliedUserCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the applied user count for this license allocation (use Property.AppliedUserCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> AppliedUserCount { get; }
Visual Basic
Public ReadOnly Property AppliedUserCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the applied user count.

Remarks

This is the number of users allocated to this license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


AssignableAllowedCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..AssignableAllowedCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the assignable allowed count for this license allocation( use Property.AssignableAllowedCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> AssignableAllowedCount { get; }
Visual Basic
Public ReadOnly Property AssignableAllowedCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the assignable allowed count.

Remarks

This is the number of licenses that are allowed to be assignable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


AssignableConfiguredCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..AssignableConfiguredCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the assignable configured count for this license allocation( use Property.AssignableConfiguredCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> AssignableConfiguredCount { get; }
Visual Basic
Public ReadOnly Property AssignableConfiguredCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the assignable configured count.

Remarks

This is the number of licenses that are configured as assignable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


ConcurrentAllowedCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..ConcurrentAllowedCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the concurrent allowed count for this license allocation( use Property.ConcurrentAllowedCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> ConcurrentAllowedCount { get; }
Visual Basic
Public ReadOnly Property ConcurrentAllowedCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the concurrent allowed count.

Remarks

This is the number of licenses that are allowed to be concurrent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


ConcurrentConfiguredCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..ConcurrentConfiguredCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the concurrent configured count for this license allocation( use Property.ConcurrentConfiguredCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> ConcurrentConfiguredCount { get; }
Visual Basic
Public ReadOnly Property ConcurrentConfiguredCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the concurrent configured count.

Remarks

This is the number of licenses that are configured as concurrent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


ConcurrentInUseCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..ConcurrentInUseCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the concurrent in use count for this license allocation( use Property.ConcurrentInUseCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> ConcurrentInUseCount { get; }
Visual Basic
Public ReadOnly Property ConcurrentInUseCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the concurrent in use count.

Remarks

This is the number of concurrent licenses that are in use.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


TotalAppliedCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..TotalAppliedCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the total applied count for this license allocation (use Property.TotalAppliedCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> TotalAppliedCount { get; }
Visual Basic
Public ReadOnly Property TotalAppliedCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the total applied count.

Remarks

This is the total number of users and stations allocated to this license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


TotalCount Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..TotalCount Property
LicenseAllocationConfiguration Class See Also Send Feedback
Provides access to the property representing the total count for this license allocation (use Property.TotalCount).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LicenseAllocationConfiguration..::..Property, int> TotalCount { get; }
Visual Basic
Public ReadOnly Property TotalCount As GeneralConfigurationProperty(Of LicenseAllocationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the total count.

Remarks

This is the number of licensed objects allowable for this license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfiguration Class
LicenseAllocationConfiguration Members
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..Property Enumeration
LicenseAllocationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
TotalCount | 0 | Represents the TotalCount property.
TotalAppliedCount | 1 | Represents the TotalAppliedCount property.
AppliedUserCount | 2 | Represents the AppliedUserCount property.
AppliedStationCount | 3 | Represents the AppliedStationCount property.
AssignableAllowedCount | 4 | Represents the AssignableAllowedCount property.
AssignableConfiguredCount | 5 | Represents the AssignableConfiguredCount property.
ConcurrentAllowedCount | 6 | Represents the ConcurrentAllowedCount property.
ConcurrentConfiguredCount | 7 | Represents the ConcurrentConfiguredCount property.
ConcurrentInUseCount | 8 | Represents the ConcurrentInUseCount property.
DisplayName | 9 | Represents the DisplayName part of the ConfigurationId property.
Id | 10 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration.Rights Class

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..Rights Class
LicenseAllocationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..LicenseAllocationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..Rights Members
LicenseAllocationConfiguration..::..Rights Class Properties See Also Send Feedback

The LicenseAllocationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LicenseAllocationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


LicenseAllocationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..Rights Properties
LicenseAllocationConfiguration..::..Rights Class See Also Send Feedback

The LicenseAllocationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LicenseAllocationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..Rights..::..Admin Property
LicenseAllocationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LicenseAllocationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of LicenseAllocationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Remarks

Note
This right is here for reference purposes only. All querying against LicenseAllocationConfiguration ignores user rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration..::..Rights Class
LicenseAllocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LicensesAllocationConfiguration


View Property

[image]

IceLib Technical Reference
LicenseAllocationConfiguration..::..Rights..::..View Property
LicenseAllocationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LicenseAllocationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of LicenseAllocationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseAllocationConfiguration..::..Rights Class
LicenseAllocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LicenseAllocationConfigurationList Class

[image]

IceLib Technical Reference
LicenseAllocationConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing license allocation configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LicenseAllocationConfigurationList : ConfigurationList<LicenseAllocationConfiguration, LicenseAllocationConfiguration..::..Property>
Visual Basic
Public Class LicenseAllocationConfigurationList _
    Inherits ConfigurationList(Of LicenseAllocationConfiguration, LicenseAllocationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' LicenseAllocationConfiguration, LicenseAllocationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LicenseAllocationConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfigurationList Members
ININ.IceLib.Configuration Namespace


LicenseAllocationConfigurationList Members

[image] [image]

IceLib Technical Reference
LicenseAllocationConfigurationList Members
LicenseAllocationConfigurationList Class Constructors Methods Properties See Also Send Feedback

The LicenseAllocationConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseAllocationConfigurationList | Initializes a new instance of the LicenseAllocationConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLicenseAppliesToForQuery | Sets a value that determines the types of licenses that are returned from search queries.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | LicenseAppliesTo | Get a value that determines the types of licenses that are returned from search queries.
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LicenseAllocationConfigurationList Class
ININ.IceLib.Configuration Namespace


LicenseAllocationConfigurationList Constructor

[image]

IceLib Technical Reference
LicenseAllocationConfigurationList Constructor
LicenseAllocationConfigurationList Class See Also Send Feedback
Initializes a new instance of the LicenseAllocationConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseAllocationConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

LicenseAllocationConfigurationList Class
LicenseAllocationConfigurationList Members
ININ.IceLib.Configuration Namespace


LicenseAllocationConfigurationList Methods

[image] [image]

IceLib Technical Reference
LicenseAllocationConfigurationList Methods
LicenseAllocationConfigurationList Class See Also Send Feedback

The LicenseAllocationConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetLicenseAppliesToForQuery | Sets a value that determines the types of licenses that are returned from search queries.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LicenseAllocationConfigurationList Class
ININ.IceLib.Configuration Namespace


SetLicenseAppliesToForQuery Method

[image]

IceLib Technical Reference
LicenseAllocationConfigurationList..::..SetLicenseAppliesToForQuery Method
LicenseAllocationConfigurationList Class See Also Send Feedback
Sets a value that determines the types of licenses that are returned from search queries.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetLicenseAppliesToForQuery(
    LicenseAppliesToType licenseAppliesTo
)
Visual Basic
Public Sub SetLicenseAppliesToForQuery ( _
    licenseAppliesTo As LicenseAppliesToType _
)

Parameters

licenseAppliesTo
Type: ININ.IceLib.Configuration.DataTypes..::..LicenseAppliesToType
The type of licenses to include in the search query.

Remarks

If None is supplied, then a default value of UsersAndStations will be used.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | licenseAppliesTo was not a valid LicenseAppliesToType value.

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

LicenseAllocationConfigurationList Class
LicenseAllocationConfigurationList Members
ININ.IceLib.Configuration Namespace
ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))


LicenseAllocationConfigurationList Properties

[image] [image]

IceLib Technical Reference
LicenseAllocationConfigurationList Properties
LicenseAllocationConfigurationList Class See Also Send Feedback

The LicenseAllocationConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | LicenseAppliesTo | Get a value that determines the types of licenses that are returned from search queries.
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LicenseAllocationConfigurationList Class
ININ.IceLib.Configuration Namespace


LicenseAppliesTo Property

[image]

IceLib Technical Reference
LicenseAllocationConfigurationList..::..LicenseAppliesTo Property
LicenseAllocationConfigurationList Class See Also Send Feedback
Get a value that determines the types of licenses that are returned from search queries.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseAppliesToType LicenseAppliesTo { get; private set; }
Visual Basic
Public Property LicenseAppliesTo As LicenseAppliesToType
    Get
    Private Set

Field Value

The type of licenses to include in the search query.

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

LicenseAllocationConfigurationList Class
LicenseAllocationConfigurationList Members
ININ.IceLib.Configuration Namespace
LicenseAllocationConfigurationList..::..SetLicenseAppliesToForQuery(LicenseAppliesToType)


LineConfiguration Class

[image]

IceLib Technical Reference
LineConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Line. A line is a generalized reference to individual analog lines from a CO, a single ISDN B channel, a T-1 or E-1 channel, or as a tie line between two switches.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LineConfiguration : EditableListConfigurationObject<LineConfiguration..::..Property>
Visual Basic
Public Class LineConfiguration _
    Inherits EditableListConfigurationObject(Of LineConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' LineConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LineConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration Members
ININ.IceLib.Configuration Namespace


LineConfiguration Members

[image] [image]

IceLib Technical Reference
LineConfiguration Members
LineConfiguration Class Methods Properties See Also Send Feedback

The LineConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LineConfiguration Class
ININ.IceLib.Configuration Namespace


LineConfiguration Methods

[image] [image]

IceLib Technical Reference
LineConfiguration Methods
LineConfiguration Class See Also Send Feedback

The LineConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

LineConfiguration Class
ININ.IceLib.Configuration Namespace


LineConfiguration Properties

[image] [image]

IceLib Technical Reference
LineConfiguration Properties
LineConfiguration Class See Also Send Feedback

The LineConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LineConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
LineConfiguration..::..PropertiesChanged Property
LineConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LineConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of LineConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration Class
LineConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
LineConfiguration..::..StandardProperties Property
LineConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<LineConfiguration, LineConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of LineConfiguration, LineConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration Class
LineConfiguration Members
ININ.IceLib.Configuration Namespace


LineConfiguration.Property Enumeration

[image]

IceLib Technical Reference
LineConfiguration..::..Property Enumeration
LineConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


LineConfiguration.Rights Class

[image]

IceLib Technical Reference
LineConfiguration..::..Rights Class
LineConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..LineConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LineConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
LineConfiguration..::..Rights Members
LineConfiguration..::..Rights Class Properties See Also Send Feedback

The LineConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
CoachLineQueue | Gets the coach line queue rights filter.
DisconnectLineQueue | Gets the disconnect line queue rights filter.
JoinLineQueue | Gets the join line queue rights filter.
ListenLineQueue | Gets the listen line queue rights filter.
PickupLineQueue | Gets the pickup line queue rights filter.
RecordLineQueue | Gets the record line queue rights filter.
SnipLineQueue | Gets the record line queue rights filter.
TransferLineQueue | Gets the transfer line queue rights filter.
View | Gets the view rights filter.

See Also

LineConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


LineConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
LineConfiguration..::..Rights Properties
LineConfiguration..::..Rights Class See Also Send Feedback

The LineConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
CoachLineQueue | Gets the coach line queue rights filter.
DisconnectLineQueue | Gets the disconnect line queue rights filter.
JoinLineQueue | Gets the join line queue rights filter.
ListenLineQueue | Gets the listen line queue rights filter.
PickupLineQueue | Gets the pickup line queue rights filter.
RecordLineQueue | Gets the record line queue rights filter.
SnipLineQueue | Gets the record line queue rights filter.
TransferLineQueue | Gets the transfer line queue rights filter.
View | Gets the view rights filter.

See Also

LineConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..Admin Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Lines


CoachLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..CoachLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the coach line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> CoachLineQueue { get; private set; }
Visual Basic
Public Shared Property CoachLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The coach line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachLineQueue


DisconnectLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..DisconnectLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the disconnect line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> DisconnectLineQueue { get; private set; }
Visual Basic
Public Shared Property DisconnectLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The disconnect line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectLineQueue


JoinLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..JoinLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the join line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> JoinLineQueue { get; private set; }
Visual Basic
Public Shared Property JoinLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The join line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinLineQueue


ListenLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..ListenLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the listen line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> ListenLineQueue { get; private set; }
Visual Basic
Public Shared Property ListenLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The listen line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenLineQueue


PickupLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..PickupLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the pickup line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> PickupLineQueue { get; private set; }
Visual Basic
Public Shared Property PickupLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The pickup line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupLineQueue


RecordLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..RecordLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the record line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> RecordLineQueue { get; private set; }
Visual Basic
Public Shared Property RecordLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The record line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordLineQueue


SnipLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..SnipLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the record line queue rights filter.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> SnipLineQueue { get; private set; }
Visual Basic
Public Shared Property SnipLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The snip line queue rights filter.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipLineQueue


TransferLineQueue Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..TransferLineQueue Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the transfer line queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> TransferLineQueue { get; private set; }
Visual Basic
Public Shared Property TransferLineQueue As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The transfer line queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferLineQueue


View Property

[image]

IceLib Technical Reference
LineConfiguration..::..Rights..::..View Property
LineConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of LineConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfiguration..::..Rights Class
LineConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewLineQueue


LineConfigurationList Class

[image]

IceLib Technical Reference
LineConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Line configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LineConfigurationList : EditableConfigurationList<LineConfiguration, LineConfiguration..::..Property>
Visual Basic
Public Class LineConfigurationList _
    Inherits EditableConfigurationList(Of LineConfiguration, LineConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' LineConfiguration, LineConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' LineConfiguration, LineConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' LineConfiguration, LineConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LineConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfigurationList Members
ININ.IceLib.Configuration Namespace


LineConfigurationList Members

[image] [image]

IceLib Technical Reference
LineConfigurationList Members
LineConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The LineConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | LineConfigurationList | Initializes a new instance of the LineConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LineConfigurationList Class
ININ.IceLib.Configuration Namespace


LineConfigurationList Constructor

[image]

IceLib Technical Reference
LineConfigurationList Constructor
LineConfigurationList Class See Also Send Feedback
Initializes a new instance of the LineConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LineConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineConfigurationList Class
LineConfigurationList Members
ININ.IceLib.Configuration Namespace


LineConfigurationList Methods

[image] [image]

IceLib Technical Reference
LineConfigurationList Methods
LineConfigurationList Class See Also Send Feedback

The LineConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineConfigurationList Class
ININ.IceLib.Configuration Namespace


LineConfigurationList Properties

[image] [image]

IceLib Technical Reference
LineConfigurationList Properties
LineConfigurationList Class See Also Send Feedback

The LineConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LineConfigurationList Class
ININ.IceLib.Configuration Namespace


LineConfigurationList Events

[image] [image]

IceLib Technical Reference
LineConfigurationList Events
LineConfigurationList Class See Also Send Feedback

The LineConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LineConfigurationList Class
ININ.IceLib.Configuration Namespace


LineGroupConfiguration Class

[image]

IceLib Technical Reference
LineGroupConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Line Group. Line groups define a group of one or more lines that can be reserved for specific uses, such as long distance calls, local calls, etc. A line group can also reserve a group of lines for calls for an individual user or a workgroup.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LineGroupConfiguration : ListConfigurationObject
Visual Basic
Public Class LineGroupConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..LineGroupConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfiguration Members
ININ.IceLib.Configuration Namespace


LineGroupConfiguration Members

[image] [image]

IceLib Technical Reference
LineGroupConfiguration Members
LineGroupConfiguration Class Methods Properties See Also Send Feedback

The LineGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LineGroupConfiguration Class
ININ.IceLib.Configuration Namespace


LineGroupConfiguration Methods

[image] [image]

IceLib Technical Reference
LineGroupConfiguration Methods
LineGroupConfiguration Class See Also Send Feedback

The LineGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

LineGroupConfiguration Class
ININ.IceLib.Configuration Namespace


LineGroupConfiguration Properties

[image] [image]

IceLib Technical Reference
LineGroupConfiguration Properties
LineGroupConfiguration Class See Also Send Feedback

The LineGroupConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LineGroupConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
LineGroupConfiguration..::..StandardProperties Property
LineGroupConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<LineGroupConfiguration, LineGroupConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of LineGroupConfiguration, LineGroupConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfiguration Class
LineGroupConfiguration Members
ININ.IceLib.Configuration Namespace


LineGroupConfiguration.Property Enumeration

[image]

IceLib Technical Reference
LineGroupConfiguration..::..Property Enumeration
LineGroupConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


LineGroupConfiguration.Rights Class

[image]

IceLib Technical Reference
LineGroupConfiguration..::..Rights Class
LineGroupConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..LineGroupConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LineGroupConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
LineGroupConfiguration..::..Rights Members
LineGroupConfiguration..::..Rights Class Properties See Also Send Feedback

The LineGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LineGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


LineGroupConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
LineGroupConfiguration..::..Rights Properties
LineGroupConfiguration..::..Rights Class See Also Send Feedback

The LineGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LineGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
LineGroupConfiguration..::..Rights..::..Admin Property
LineGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineGroupConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of LineGroupConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfiguration..::..Rights Class
LineGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LineGroups


View Property

[image]

IceLib Technical Reference
LineGroupConfiguration..::..Rights..::..View Property
LineGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LineGroupConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of LineGroupConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfiguration..::..Rights Class
LineGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LineGroupConfigurationList Class

[image]

IceLib Technical Reference
LineGroupConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing LineGroup configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LineGroupConfigurationList : DynamicConfigurationList<LineGroupConfiguration, LineGroupConfiguration..::..Property>
Visual Basic
Public Class LineGroupConfigurationList _
    Inherits DynamicConfigurationList(Of LineGroupConfiguration, LineGroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' LineGroupConfiguration, LineGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' LineGroupConfiguration, LineGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LineGroupConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


LineGroupConfigurationList Members

[image] [image]

IceLib Technical Reference
LineGroupConfigurationList Members
LineGroupConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The LineGroupConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | LineGroupConfigurationList | Initializes a new instance of the LineGroupConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LineGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


LineGroupConfigurationList Constructor

[image]

IceLib Technical Reference
LineGroupConfigurationList Constructor
LineGroupConfigurationList Class See Also Send Feedback
Initializes a new instance of the LineGroupConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LineGroupConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineGroupConfigurationList Class
LineGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


LineGroupConfigurationList Methods

[image] [image]

IceLib Technical Reference
LineGroupConfigurationList Methods
LineGroupConfigurationList Class See Also Send Feedback

The LineGroupConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


LineGroupConfigurationList Properties

[image] [image]

IceLib Technical Reference
LineGroupConfigurationList Properties
LineGroupConfigurationList Class See Also Send Feedback

The LineGroupConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LineGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


LineGroupConfigurationList Events

[image] [image]

IceLib Technical Reference
LineGroupConfigurationList Events
LineGroupConfigurationList Class See Also Send Feedback

The LineGroupConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LineGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


ListConfigurationObject Class

[image]

IceLib Technical Reference
ListConfigurationObject Class
Members Example See Also Send Feedback
Represents a list-based configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ListConfigurationObject : ConfigurationObject
Visual Basic
Public MustInherit Class ListConfigurationObject _
    Inherits ConfigurationObject

Examples

The IceLib SDK includes example application references to the ListConfigurationObject class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 203, in UserRoleConfigurationViewModel.<SessionConnectionStateChanged>b__7

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..AccumulatorConfiguration
ININ.IceLib.Configuration..::..AttendantConfigurationConfiguration
ININ.IceLib.Configuration..::..AttendantEmailProfileConfiguration
ININ.IceLib.Configuration..::..AttendantInboundProfileConfiguration
ININ.IceLib.Configuration..::..AttendantOperatorProfileConfiguration
ININ.IceLib.Configuration..::..AttendantOutboundProfileConfiguration
ININ.IceLib.Configuration..::..AudioSourceConfiguration
ININ.IceLib.Configuration..::..ClientConfigurationTemplateConfiguration
ININ.IceLib.Configuration..::..ContactListSourceConfiguration
ININ.IceLib.Configuration..::..EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration.EFaq..::..EFaqConfiguration
ININ.IceLib.Configuration..::..FaxGroupConfiguration
ININ.IceLib.Configuration..::..FeatureLicenseConfiguration
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyConfiguration
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyGroupConfiguration
ININ.IceLib.Configuration..::..HandlerConfiguration
ININ.IceLib.Configuration..::..ICDataSourceConfiguration
ININ.IceLib.Configuration..::..ImageResourceCategoryConfiguration
ININ.IceLib.Configuration..::..InitializationFunctionConfiguration
ININ.IceLib.Configuration..::..InteractionClientPluginConfiguration
ININ.IceLib.Configuration..::..InteractionConferenceRoomConfiguration
ININ.IceLib.Configuration..::..InteractionProcessorTableConfiguration
ININ.IceLib.Configuration..::..LicenseAllocationConfiguration
ININ.IceLib.Configuration..::..LineGroupConfiguration
ININ.IceLib.Configuration..::..LocationConfiguration
ININ.IceLib.Configuration..::..MiscellaneousItemConfiguration
ININ.IceLib.Configuration..::..MrcpServerConfiguration
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerActiveDirectoryConfiguration
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerStatusMessageConfiguration
ININ.IceLib.Configuration.Optimizer..::..OptimizerSchedulingUnitConfiguration
ININ.IceLib.Configuration..::..PagingCarrierConfiguration
ININ.IceLib.Configuration.ProcessAutomation..::..ProcessConfiguration
ININ.IceLib.Configuration.Recorder..::..RecorderQuestionnaireConfiguration
ININ.IceLib.Configuration.Reporting..::..LegacyHistoricalReportConfiguration
ININ.IceLib.Configuration..::..ReportLogConfiguration
ININ.IceLib.Configuration..::..SelectionRuleConfiguration
ININ.IceLib.Configuration..::..SingleSignOnIdentityProviderConfiguration
ININ.IceLib.Configuration..::..SipBridgeConfiguration
ININ.IceLib.Configuration..::..SiteConfiguration
ININ.IceLib.Configuration..::..SmdiPortConfiguration
ININ.IceLib.Configuration..::..SmsBrokerConfiguration
ININ.IceLib.Configuration..::..StationGroupConfiguration
ININ.IceLib.Configuration..::..StatusColumnConfiguration
ININ.IceLib.Configuration..::..SystemParameterConfiguration
ININ.IceLib.Configuration..::..VoiceModuleConfiguration
ININ.IceLib.Configuration..::..WebServicesParameterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ListConfigurationObject Members
ININ.IceLib.Configuration Namespace


ListConfigurationObject Members

[image] [image]

IceLib Technical Reference
ListConfigurationObject Members
ListConfigurationObject Class Methods Properties See Also Send Feedback

The ListConfigurationObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit.

See Also

ListConfigurationObject Class
ININ.IceLib.Configuration Namespace


ListConfigurationObject Methods

[image] [image]

IceLib Technical Reference
ListConfigurationObject Methods
ListConfigurationObject Class See Also Send Feedback

The ListConfigurationObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ListConfigurationObject Class
ININ.IceLib.Configuration Namespace


ListConfigurationObject Properties

[image] [image]

IceLib Technical Reference
ListConfigurationObject Properties
ListConfigurationObject Class See Also Send Feedback

The ListConfigurationObject type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit.

See Also

ListConfigurationObject Class
ININ.IceLib.Configuration Namespace


ConfigurationId Property

[image]

IceLib Technical Reference
ListConfigurationObject..::..ConfigurationId Property
ListConfigurationObject Class Example See Also Send Feedback
Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId ConfigurationId { get; }
Visual Basic
Public ReadOnly Property ConfigurationId As ConfigurationId
    Get

Field Value

The configuration ID.

Examples

The IceLib SDK includes example application references to the ConfigurationId property. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 203, in UserRoleConfigurationViewModel.<SessionConnectionStateChanged>b__7

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ListConfigurationObject Class
ListConfigurationObject Members
ININ.IceLib.Configuration Namespace


OriginalConfigurationId Property

[image]

IceLib Technical Reference
ListConfigurationObject..::..OriginalConfigurationId Property
ListConfigurationObject Class See Also Send Feedback
Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId OriginalConfigurationId { get; }
Visual Basic
Public ReadOnly Property OriginalConfigurationId As ConfigurationId
    Get

Remarks

A change in configuration ID following a Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object) can be detected by comparing this object's OriginalConfigurationId to its ConfigurationId.

If the IC Server assigns a new configuration ID to this object the ConfigurationId will be updated with that new value. OriginalConfigurationId will always be equivalent to the ConfigurationId assigned to the object prior to the commit.

Until a commit successfully completes, this property will be None.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ListConfigurationObject Class
ListConfigurationObject Members
ININ.IceLib.Configuration Namespace


LocationConfiguration Class

[image]

IceLib Technical Reference
LocationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Location. A location represents an area where things are considered to be in the same physical place. This location defines a set of endpoints (lines, stations, and servers) that share a common dial plan, and it defines Codec communications for the endpoints.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationConfiguration : ListConfigurationObject
Visual Basic
Public Class LocationConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..LocationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfiguration Members
ININ.IceLib.Configuration Namespace


LocationConfiguration Members

[image] [image]

IceLib Technical Reference
LocationConfiguration Members
LocationConfiguration Class Methods Properties See Also Send Feedback

The LocationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this location (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LocationConfiguration Class
ININ.IceLib.Configuration Namespace


LocationConfiguration Methods

[image] [image]

IceLib Technical Reference
LocationConfiguration Methods
LocationConfiguration Class See Also Send Feedback

The LocationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

LocationConfiguration Class
ININ.IceLib.Configuration Namespace


LocationConfiguration Properties

[image] [image]

IceLib Technical Reference
LocationConfiguration Properties
LocationConfiguration Class See Also Send Feedback

The LocationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this location (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LocationConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
LocationConfiguration..::..AccessControlGroupAssignment Property
LocationConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this location (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<LocationConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of LocationConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LocationConfiguration Class
LocationConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
LocationConfiguration..::..StandardProperties Property
LocationConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<LocationConfiguration, LocationConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of LocationConfiguration, LocationConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfiguration Class
LocationConfiguration Members
ININ.IceLib.Configuration Namespace


LocationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
LocationConfiguration..::..Property Enumeration
LocationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


LocationConfiguration.Rights Class

[image]

IceLib Technical Reference
LocationConfiguration..::..Rights Class
LocationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..LocationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LocationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
LocationConfiguration..::..Rights Members
LocationConfiguration..::..Rights Class Properties See Also Send Feedback

The LocationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LocationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


LocationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
LocationConfiguration..::..Rights Properties
LocationConfiguration..::..Rights Class See Also Send Feedback

The LocationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LocationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
LocationConfiguration..::..Rights..::..Admin Property
LocationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LocationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of LocationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfiguration..::..Rights Class
LocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Locations


View Property

[image]

IceLib Technical Reference
LocationConfiguration..::..Rights..::..View Property
LocationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LocationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of LocationConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfiguration..::..Rights Class
LocationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


LocationConfigurationList Class

[image]

IceLib Technical Reference
LocationConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Location configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationConfigurationList : DynamicConfigurationList<LocationConfiguration, LocationConfiguration..::..Property>
Visual Basic
Public Class LocationConfigurationList _
    Inherits DynamicConfigurationList(Of LocationConfiguration, LocationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' LocationConfiguration, LocationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' LocationConfiguration, LocationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..LocationConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfigurationList Members
ININ.IceLib.Configuration Namespace


LocationConfigurationList Members

[image] [image]

IceLib Technical Reference
LocationConfigurationList Members
LocationConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The LocationConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | LocationConfigurationList | Initializes a new instance of the LocationConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LocationConfigurationList Class
ININ.IceLib.Configuration Namespace


LocationConfigurationList Constructor

[image]

IceLib Technical Reference
LocationConfigurationList Constructor
LocationConfigurationList Class See Also Send Feedback
Initializes a new instance of the LocationConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LocationConfigurationList Class
LocationConfigurationList Members
ININ.IceLib.Configuration Namespace


LocationConfigurationList Methods

[image] [image]

IceLib Technical Reference
LocationConfigurationList Methods
LocationConfigurationList Class See Also Send Feedback

The LocationConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationConfigurationList Class
ININ.IceLib.Configuration Namespace


LocationConfigurationList Properties

[image] [image]

IceLib Technical Reference
LocationConfigurationList Properties
LocationConfigurationList Class See Also Send Feedback

The LocationConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LocationConfigurationList Class
ININ.IceLib.Configuration Namespace


LocationConfigurationList Events

[image] [image]

IceLib Technical Reference
LocationConfigurationList Events
LocationConfigurationList Class See Also Send Feedback

The LocationConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LocationConfigurationList Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration Class

[image]

IceLib Technical Reference
MiscellaneousItemConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC MiscellaneousItem.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MiscellaneousItemConfiguration : ListConfigurationObject
Visual Basic
Public Class MiscellaneousItemConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..MiscellaneousItemConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MiscellaneousItemConfiguration Members
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration Members

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfiguration Members
MiscellaneousItemConfiguration Class Methods Properties See Also Send Feedback

The MiscellaneousItemConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

MiscellaneousItemConfiguration Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration Methods

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfiguration Methods
MiscellaneousItemConfiguration Class See Also Send Feedback

The MiscellaneousItemConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

MiscellaneousItemConfiguration Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration Properties

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfiguration Properties
MiscellaneousItemConfiguration Class See Also Send Feedback

The MiscellaneousItemConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

MiscellaneousItemConfiguration Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration.Property Enumeration

[image]

IceLib Technical Reference
MiscellaneousItemConfiguration..::..Property Enumeration
MiscellaneousItemConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration.Rights Class

[image]

IceLib Technical Reference
MiscellaneousItemConfiguration..::..Rights Class
MiscellaneousItemConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..MiscellaneousItemConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MiscellaneousItemConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfiguration..::..Rights Members
MiscellaneousItemConfiguration..::..Rights Class Properties See Also Send Feedback

The MiscellaneousItemConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

MiscellaneousItemConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfiguration..::..Rights Properties
MiscellaneousItemConfiguration..::..Rights Class See Also Send Feedback

The MiscellaneousItemConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

MiscellaneousItemConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
MiscellaneousItemConfiguration..::..Rights..::..Admin Property
MiscellaneousItemConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<MiscellaneousItemConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of MiscellaneousItemConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MiscellaneousItemConfiguration..::..Rights Class
MiscellaneousItemConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
MiscellaneousItemConfiguration..::..Rights..::..View Property
MiscellaneousItemConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<MiscellaneousItemConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of MiscellaneousItemConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MiscellaneousItemConfiguration..::..Rights Class
MiscellaneousItemConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Miscellaneous


MiscellaneousItemConfigurationList Class

[image]

IceLib Technical Reference
MiscellaneousItemConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing MiscellaneousItem configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MiscellaneousItemConfigurationList : DynamicConfigurationList<MiscellaneousItemConfiguration, MiscellaneousItemConfiguration..::..Property>
Visual Basic
Public Class MiscellaneousItemConfigurationList _
    Inherits DynamicConfigurationList(Of MiscellaneousItemConfiguration, MiscellaneousItemConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' MiscellaneousItemConfiguration, MiscellaneousItemConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' MiscellaneousItemConfiguration, MiscellaneousItemConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..MiscellaneousItemConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MiscellaneousItemConfigurationList Members
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfigurationList Members

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfigurationList Members
MiscellaneousItemConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The MiscellaneousItemConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | MiscellaneousItemConfigurationList | Initializes a new instance of the MiscellaneousItemConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

MiscellaneousItemConfigurationList Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfigurationList Constructor

[image]

IceLib Technical Reference
MiscellaneousItemConfigurationList Constructor
MiscellaneousItemConfigurationList Class See Also Send Feedback
Initializes a new instance of the MiscellaneousItemConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MiscellaneousItemConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MiscellaneousItemConfigurationList Class
MiscellaneousItemConfigurationList Members
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfigurationList Methods

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfigurationList Methods
MiscellaneousItemConfigurationList Class See Also Send Feedback

The MiscellaneousItemConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MiscellaneousItemConfigurationList Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfigurationList Properties

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfigurationList Properties
MiscellaneousItemConfigurationList Class See Also Send Feedback

The MiscellaneousItemConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

MiscellaneousItemConfigurationList Class
ININ.IceLib.Configuration Namespace


MiscellaneousItemConfigurationList Events

[image] [image]

IceLib Technical Reference
MiscellaneousItemConfigurationList Events
MiscellaneousItemConfigurationList Class See Also Send Feedback

The MiscellaneousItemConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

MiscellaneousItemConfigurationList Class
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration Class

[image]

IceLib Technical Reference
MrcpServerConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Mrcp Servers.

Note: This class is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MrcpServerConfiguration : ListConfigurationObject
Visual Basic
Public Class MrcpServerConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..MrcpServerConfiguration

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfiguration Members
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration Members

[image] [image]

IceLib Technical Reference
MrcpServerConfiguration Members
MrcpServerConfiguration Class Methods Properties See Also Send Feedback

The MrcpServerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

MrcpServerConfiguration Class
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration Methods

[image] [image]

IceLib Technical Reference
MrcpServerConfiguration Methods
MrcpServerConfiguration Class See Also Send Feedback

The MrcpServerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

MrcpServerConfiguration Class
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration Properties

[image] [image]

IceLib Technical Reference
MrcpServerConfiguration Properties
MrcpServerConfiguration Class See Also Send Feedback

The MrcpServerConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

MrcpServerConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
MrcpServerConfiguration..::..StandardProperties Property
MrcpServerConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<MrcpServerConfiguration, MrcpServerConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of MrcpServerConfiguration, MrcpServerConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfiguration Class
MrcpServerConfiguration Members
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration.Property Enumeration

[image]

IceLib Technical Reference
MrcpServerConfiguration..::..Property Enumeration
MrcpServerConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Note: This enumeration is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 3498 | Represents the DisplayName part of the ConfigurationId property.
Id | 3499 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


MrcpServerConfiguration.Rights Class

[image]

IceLib Technical Reference
MrcpServerConfiguration..::..Rights Class
MrcpServerConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Note: This class is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..MrcpServerConfiguration..::..Rights

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
MrcpServerConfiguration..::..Rights Members
MrcpServerConfiguration..::..Rights Class Properties See Also Send Feedback

The MrcpServerConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

MrcpServerConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


MrcpServerConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
MrcpServerConfiguration..::..Rights Properties
MrcpServerConfiguration..::..Rights Class See Also Send Feedback

The MrcpServerConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

MrcpServerConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
MrcpServerConfiguration..::..Rights..::..Admin Property
MrcpServerConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<MrcpServerConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of MrcpServerConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfiguration..::..Rights Class
MrcpServerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MrcpServerList


View Property

[image]

IceLib Technical Reference
MrcpServerConfiguration..::..Rights..::..View Property
MrcpServerConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<MrcpServerConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of MrcpServerConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfiguration..::..Rights Class
MrcpServerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


MrcpServerConfigurationList Class

[image]

IceLib Technical Reference
MrcpServerConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Mrcp Server configuration objects.

Note: This class is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MrcpServerConfigurationList : ConfigurationList<MrcpServerConfiguration, MrcpServerConfiguration..::..Property>
Visual Basic
Public Class MrcpServerConfigurationList _
    Inherits ConfigurationList(Of MrcpServerConfiguration, MrcpServerConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' MrcpServerConfiguration, MrcpServerConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..MrcpServerConfigurationList

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfigurationList Members
ININ.IceLib.Configuration Namespace


MrcpServerConfigurationList Members

[image] [image]

IceLib Technical Reference
MrcpServerConfigurationList Members
MrcpServerConfigurationList Class Constructors Methods Properties See Also Send Feedback

The MrcpServerConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | MrcpServerConfigurationList | Initializes a new instance of the MrcpServerConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

MrcpServerConfigurationList Class
ININ.IceLib.Configuration Namespace


MrcpServerConfigurationList Constructor

[image]

IceLib Technical Reference
MrcpServerConfigurationList Constructor
MrcpServerConfigurationList Class See Also Send Feedback
Initializes a new instance of the MrcpServerConfigurationList class.

Note: This constructor is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MrcpServerConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

MrcpServerConfigurationList Class
MrcpServerConfigurationList Members
ININ.IceLib.Configuration Namespace


MrcpServerConfigurationList Methods

[image] [image]

IceLib Technical Reference
MrcpServerConfigurationList Methods
MrcpServerConfigurationList Class See Also Send Feedback

The MrcpServerConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MrcpServerConfigurationList Class
ININ.IceLib.Configuration Namespace


MrcpServerConfigurationList Properties

[image] [image]

IceLib Technical Reference
MrcpServerConfigurationList Properties
MrcpServerConfigurationList Class See Also Send Feedback

The MrcpServerConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

MrcpServerConfigurationList Class
ININ.IceLib.Configuration Namespace


ObjectType Enumeration

[image]

IceLib Technical Reference
ObjectType Enumeration
See Also Send Feedback
Represents the object type of a GroupedConfigurationId.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ObjectType
Visual Basic
Public Enumeration ObjectType

Members

Member name | Value | Description
None | 0 | Represents no object type.
Acg | 1 | Represents an ACG object type.
Workgroup | 2 | Represents the workgroup object type.
FeedbackSurveyGroup | 3 | Represents the feedback survey group object type.
LineGroup | 4 | Represents the line group object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration Class

[image]

IceLib Technical Reference
PagingCarrierConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC PagingCarrier.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PagingCarrierConfiguration : ListConfigurationObject
Visual Basic
Public Class PagingCarrierConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..PagingCarrierConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfiguration Members
ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration Members

[image] [image]

IceLib Technical Reference
PagingCarrierConfiguration Members
PagingCarrierConfiguration Class Methods Properties See Also Send Feedback

The PagingCarrierConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

PagingCarrierConfiguration Class
ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration Methods

[image] [image]

IceLib Technical Reference
PagingCarrierConfiguration Methods
PagingCarrierConfiguration Class See Also Send Feedback

The PagingCarrierConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

PagingCarrierConfiguration Class
ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration Properties

[image] [image]

IceLib Technical Reference
PagingCarrierConfiguration Properties
PagingCarrierConfiguration Class See Also Send Feedback

The PagingCarrierConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

PagingCarrierConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
PagingCarrierConfiguration..::..StandardProperties Property
PagingCarrierConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<PagingCarrierConfiguration, PagingCarrierConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of PagingCarrierConfiguration, PagingCarrierConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfiguration Class
PagingCarrierConfiguration Members
ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration.Property Enumeration

[image]

IceLib Technical Reference
PagingCarrierConfiguration..::..Property Enumeration
PagingCarrierConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration.Rights Class

[image]

IceLib Technical Reference
PagingCarrierConfiguration..::..Rights Class
PagingCarrierConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..PagingCarrierConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
PagingCarrierConfiguration..::..Rights Members
PagingCarrierConfiguration..::..Rights Class Properties See Also Send Feedback

The PagingCarrierConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

PagingCarrierConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


PagingCarrierConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
PagingCarrierConfiguration..::..Rights Properties
PagingCarrierConfiguration..::..Rights Class See Also Send Feedback

The PagingCarrierConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

PagingCarrierConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
PagingCarrierConfiguration..::..Rights..::..Admin Property
PagingCarrierConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PagingCarrierConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of PagingCarrierConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfiguration..::..Rights Class
PagingCarrierConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PagingCarriers


View Property

[image]

IceLib Technical Reference
PagingCarrierConfiguration..::..Rights..::..View Property
PagingCarrierConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PagingCarrierConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of PagingCarrierConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfiguration..::..Rights Class
PagingCarrierConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


PagingCarrierConfigurationList Class

[image]

IceLib Technical Reference
PagingCarrierConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing PagingCarrier configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PagingCarrierConfigurationList : DynamicConfigurationList<PagingCarrierConfiguration, PagingCarrierConfiguration..::..Property>
Visual Basic
Public Class PagingCarrierConfigurationList _
    Inherits DynamicConfigurationList(Of PagingCarrierConfiguration, PagingCarrierConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' PagingCarrierConfiguration, PagingCarrierConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' PagingCarrierConfiguration, PagingCarrierConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PagingCarrierConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfigurationList Members
ININ.IceLib.Configuration Namespace


PagingCarrierConfigurationList Members

[image] [image]

IceLib Technical Reference
PagingCarrierConfigurationList Members
PagingCarrierConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The PagingCarrierConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | PagingCarrierConfigurationList | Initializes a new instance of the PagingCarrierConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PagingCarrierConfigurationList Class
ININ.IceLib.Configuration Namespace


PagingCarrierConfigurationList Constructor

[image]

IceLib Technical Reference
PagingCarrierConfigurationList Constructor
PagingCarrierConfigurationList Class See Also Send Feedback
Initializes a new instance of the PagingCarrierConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PagingCarrierConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PagingCarrierConfigurationList Class
PagingCarrierConfigurationList Members
ININ.IceLib.Configuration Namespace


PagingCarrierConfigurationList Methods

[image] [image]

IceLib Technical Reference
PagingCarrierConfigurationList Methods
PagingCarrierConfigurationList Class See Also Send Feedback

The PagingCarrierConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PagingCarrierConfigurationList Class
ININ.IceLib.Configuration Namespace


PagingCarrierConfigurationList Properties

[image] [image]

IceLib Technical Reference
PagingCarrierConfigurationList Properties
PagingCarrierConfigurationList Class See Also Send Feedback

The PagingCarrierConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PagingCarrierConfigurationList Class
ININ.IceLib.Configuration Namespace


PagingCarrierConfigurationList Events

[image] [image]

IceLib Technical Reference
PagingCarrierConfigurationList Events
PagingCarrierConfigurationList Class See Also Send Feedback

The PagingCarrierConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PagingCarrierConfigurationList Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration Class

[image]

IceLib Technical Reference
PasswordPolicyConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Password Policy. A password policy is a set of rules that a password must meet.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PasswordPolicyConfiguration : EditableListConfigurationObject<PasswordPolicyConfiguration..::..Property>
Visual Basic
Public Class PasswordPolicyConfiguration _
    Inherits EditableListConfigurationObject(Of PasswordPolicyConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' PasswordPolicyConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PasswordPolicyConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PasswordPolicyConfiguration Members
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration Members

[image] [image]

IceLib Technical Reference
PasswordPolicyConfiguration Members
PasswordPolicyConfiguration Class Methods Properties See Also Send Feedback

The PasswordPolicyConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this password policy (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

PasswordPolicyConfiguration Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration Methods

[image] [image]

IceLib Technical Reference
PasswordPolicyConfiguration Methods
PasswordPolicyConfiguration Class See Also Send Feedback

The PasswordPolicyConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

PasswordPolicyConfiguration Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration Properties

[image] [image]

IceLib Technical Reference
PasswordPolicyConfiguration Properties
PasswordPolicyConfiguration Class See Also Send Feedback

The PasswordPolicyConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this password policy (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

PasswordPolicyConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..AccessControlGroupAssignment Property
PasswordPolicyConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this password policy (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PasswordPolicyConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of PasswordPolicyConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

PasswordPolicyConfiguration Class
PasswordPolicyConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..PropertiesChanged Property
PasswordPolicyConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PasswordPolicyConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of PasswordPolicyConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PasswordPolicyConfiguration Class
PasswordPolicyConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..StandardProperties Property
PasswordPolicyConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PasswordPolicyConfiguration Class
PasswordPolicyConfiguration Members
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration.Property Enumeration

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..Property Enumeration
PasswordPolicyConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration.Rights Class

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..Rights Class
PasswordPolicyConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..PasswordPolicyConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PasswordPolicyConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..Rights Members
PasswordPolicyConfiguration..::..Rights Class Properties See Also Send Feedback

The PasswordPolicyConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

PasswordPolicyConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..Rights Properties
PasswordPolicyConfiguration..::..Rights Class See Also Send Feedback

The PasswordPolicyConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

PasswordPolicyConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..Rights..::..Admin Property
PasswordPolicyConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PasswordPolicyConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of PasswordPolicyConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PasswordPolicyConfiguration..::..Rights Class
PasswordPolicyConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PasswordPolicies


View Property

[image]

IceLib Technical Reference
PasswordPolicyConfiguration..::..Rights..::..View Property
PasswordPolicyConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PasswordPolicyConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of PasswordPolicyConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PasswordPolicyConfiguration..::..Rights Class
PasswordPolicyConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


PasswordPolicyConfigurationList Class

[image]

IceLib Technical Reference
PasswordPolicyConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing passwordPolicy configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PasswordPolicyConfigurationList : EditableConfigurationList<PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property>
Visual Basic
Public Class PasswordPolicyConfigurationList _
    Inherits EditableConfigurationList(Of PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' PasswordPolicyConfiguration, PasswordPolicyConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PasswordPolicyConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PasswordPolicyConfigurationList Members
ININ.IceLib.Configuration Namespace


PasswordPolicyConfigurationList Members

[image] [image]

IceLib Technical Reference
PasswordPolicyConfigurationList Members
PasswordPolicyConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The PasswordPolicyConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordPolicyConfigurationList | Initializes a new instance of the PasswordPolicyConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PasswordPolicyConfigurationList Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfigurationList Constructor

[image]

IceLib Technical Reference
PasswordPolicyConfigurationList Constructor
PasswordPolicyConfigurationList Class See Also Send Feedback
Initializes a new instance of the PasswordPolicyConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PasswordPolicyConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PasswordPolicyConfigurationList Class
PasswordPolicyConfigurationList Members
ININ.IceLib.Configuration Namespace


PasswordPolicyConfigurationList Methods

[image] [image]

IceLib Technical Reference
PasswordPolicyConfigurationList Methods
PasswordPolicyConfigurationList Class See Also Send Feedback

The PasswordPolicyConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PasswordPolicyConfigurationList Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfigurationList Properties

[image] [image]

IceLib Technical Reference
PasswordPolicyConfigurationList Properties
PasswordPolicyConfigurationList Class See Also Send Feedback

The PasswordPolicyConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PasswordPolicyConfigurationList Class
ININ.IceLib.Configuration Namespace


PasswordPolicyConfigurationList Events

[image] [image]

IceLib Technical Reference
PasswordPolicyConfigurationList Events
PasswordPolicyConfigurationList Class See Also Send Feedback

The PasswordPolicyConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PasswordPolicyConfigurationList Class
ININ.IceLib.Configuration Namespace


PersonalInformationProperties Class

[image]

IceLib Technical Reference
PersonalInformationProperties Class
Members See Also Send Feedback
Contains personal information settings for a UserConfiguration.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PersonalInformationProperties
Visual Basic
Public Class PersonalInformationProperties

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..PersonalInformationProperties

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PersonalInformationProperties Members

[image] [image]

IceLib Technical Reference
PersonalInformationProperties Members
PersonalInformationProperties Class Methods Properties See Also Send Feedback

The PersonalInformationProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssistantName | Provides access to the property representing the assistant name for this user (use Property.PersonalInformation_AssistantName).
Public property | City | Provides access to the property representing the city for this user (use Property.PersonalInformation_City).
Public property | CompanyName | Provides access to the property representing the company name for this user (use Property.PersonalInformation_CompanyName).
Public property | Country | Provides access to the property representing the country for this user (use Property.PersonalInformation_Country).
Public property | DepartmentName | Provides access to the property representing the department name for this user (use Property.PersonalInformation_DepartmentName).
Public property | EmailAddress | Provides access to the property representing the business email address for this user (use Property.PersonalInformation_EmailAddress).
Public property | EmailAlias | Provides access to the property representing the email alias for this user (use Property.PersonalInformation_EmailAlias).
Public property | GivenName | Provides access to the property representing the given name for this user (use Property.PersonalInformation_GivenName).
Public property | Notes | Provides access to the property representing the personal info notes for this user (use Property.PersonalInformation_Notes).
Public property | OfficeLocation | Provides access to the property representing the business address for this user (use Property.PersonalInformation_OfficeLocation).
Public property | PhoneNumberOfAssistant | Provides access to the property representing the assistant's phone number for this user (use Property.PersonalInformation_PhoneNumberOfAssistant).
Public property | PhoneNumberOfBusiness1 | Provides access to the property representing the business number for this user (use Property.PersonalInformation_PhoneNumberOfBusiness1).
Public property | PhoneNumberOfBusiness2 | Provides access to the property representing the 2nd business number for this user (use Property.PersonalInformation_PhoneNumberOfBusiness2).
Public property | PhoneNumberOfFax | Provides access to the property representing the fax number for this user (use Property.PersonalInformation_PhoneNumberOfFax).
Public property | PhoneNumberOfHome1 | Provides access to the property representing the home number for this user (use Property.PersonalInformation_PhoneNumberOfHome1).
Public property | PhoneNumberOfHome2 | Provides access to the property representing the 2nd home number for this user (use Property.PersonalInformation_PhoneNumberOfHome2).
Public property | PhoneNumberOfMobile | Provides access to the property representing the mobile number for this user (use Property.PersonalInformation_PhoneNumberOfMobile).
Public property | PhoneNumberOfPager | Provides access to the property representing the pager number for this user (use Property.PersonalInformation_PhoneNumberOfPager).
Public property | PostalCode | Provides access to the property representing the postal code for this user (use Property.PersonalInformation_PostalCode).
Public property | StateOrProvince | Provides access to the property representing the state/province for this user (use Property.PersonalInformation_StateOrProvince).
Public property | StreetAddress | Provides access to the property representing the street address for this user (use Property.PersonalInformation_StreetAddress).
Public property | Surname | Provides access to the property representing the surname for this user (use Property.PersonalInformation_Surname).
Public property | Title | Provides access to the property representing the title for this user (use Property.PersonalInformation_Title).

See Also

PersonalInformationProperties Class
ININ.IceLib.Configuration Namespace


PersonalInformationProperties Methods

[image] [image]

IceLib Technical Reference
PersonalInformationProperties Methods
PersonalInformationProperties Class See Also Send Feedback

The PersonalInformationProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PersonalInformationProperties Class
ININ.IceLib.Configuration Namespace


PersonalInformationProperties Properties

[image] [image]

IceLib Technical Reference
PersonalInformationProperties Properties
PersonalInformationProperties Class See Also Send Feedback

The PersonalInformationProperties type exposes the following members.

Properties

 | Name | Description
Public property | AssistantName | Provides access to the property representing the assistant name for this user (use Property.PersonalInformation_AssistantName).
Public property | City | Provides access to the property representing the city for this user (use Property.PersonalInformation_City).
Public property | CompanyName | Provides access to the property representing the company name for this user (use Property.PersonalInformation_CompanyName).
Public property | Country | Provides access to the property representing the country for this user (use Property.PersonalInformation_Country).
Public property | DepartmentName | Provides access to the property representing the department name for this user (use Property.PersonalInformation_DepartmentName).
Public property | EmailAddress | Provides access to the property representing the business email address for this user (use Property.PersonalInformation_EmailAddress).
Public property | EmailAlias | Provides access to the property representing the email alias for this user (use Property.PersonalInformation_EmailAlias).
Public property | GivenName | Provides access to the property representing the given name for this user (use Property.PersonalInformation_GivenName).
Public property | Notes | Provides access to the property representing the personal info notes for this user (use Property.PersonalInformation_Notes).
Public property | OfficeLocation | Provides access to the property representing the business address for this user (use Property.PersonalInformation_OfficeLocation).
Public property | PhoneNumberOfAssistant | Provides access to the property representing the assistant's phone number for this user (use Property.PersonalInformation_PhoneNumberOfAssistant).
Public property | PhoneNumberOfBusiness1 | Provides access to the property representing the business number for this user (use Property.PersonalInformation_PhoneNumberOfBusiness1).
Public property | PhoneNumberOfBusiness2 | Provides access to the property representing the 2nd business number for this user (use Property.PersonalInformation_PhoneNumberOfBusiness2).
Public property | PhoneNumberOfFax | Provides access to the property representing the fax number for this user (use Property.PersonalInformation_PhoneNumberOfFax).
Public property | PhoneNumberOfHome1 | Provides access to the property representing the home number for this user (use Property.PersonalInformation_PhoneNumberOfHome1).
Public property | PhoneNumberOfHome2 | Provides access to the property representing the 2nd home number for this user (use Property.PersonalInformation_PhoneNumberOfHome2).
Public property | PhoneNumberOfMobile | Provides access to the property representing the mobile number for this user (use Property.PersonalInformation_PhoneNumberOfMobile).
Public property | PhoneNumberOfPager | Provides access to the property representing the pager number for this user (use Property.PersonalInformation_PhoneNumberOfPager).
Public property | PostalCode | Provides access to the property representing the postal code for this user (use Property.PersonalInformation_PostalCode).
Public property | StateOrProvince | Provides access to the property representing the state/province for this user (use Property.PersonalInformation_StateOrProvince).
Public property | StreetAddress | Provides access to the property representing the street address for this user (use Property.PersonalInformation_StreetAddress).
Public property | Surname | Provides access to the property representing the surname for this user (use Property.PersonalInformation_Surname).
Public property | Title | Provides access to the property representing the title for this user (use Property.PersonalInformation_Title).

See Also

PersonalInformationProperties Class
ININ.IceLib.Configuration Namespace


AssistantName Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..AssistantName Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the assistant name for this user (use Property.PersonalInformation_AssistantName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> AssistantName { get; }
Visual Basic
Public ReadOnly Property AssistantName As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the assistant name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


City Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..City Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the city for this user (use Property.PersonalInformation_City).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> City { get; }
Visual Basic
Public ReadOnly Property City As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


CompanyName Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..CompanyName Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the company name for this user (use Property.PersonalInformation_CompanyName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> CompanyName { get; }
Visual Basic
Public ReadOnly Property CompanyName As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the company name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


Country Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..Country Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the country for this user (use Property.PersonalInformation_Country).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Country { get; }
Visual Basic
Public ReadOnly Property Country As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


DepartmentName Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..DepartmentName Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the department name for this user (use Property.PersonalInformation_DepartmentName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> DepartmentName { get; }
Visual Basic
Public ReadOnly Property DepartmentName As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the department name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


EmailAddress Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..EmailAddress Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the business email address for this user (use Property.PersonalInformation_EmailAddress).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the business email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


EmailAlias Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..EmailAlias Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the email alias for this user (use Property.PersonalInformation_EmailAlias).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> EmailAlias { get; }
Visual Basic
Public ReadOnly Property EmailAlias As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the email alias.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


GivenName Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..GivenName Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the given name for this user (use Property.PersonalInformation_GivenName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> GivenName { get; }
Visual Basic
Public ReadOnly Property GivenName As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the given name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


Notes Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..Notes Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the personal info notes for this user (use Property.PersonalInformation_Notes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Notes { get; }
Visual Basic
Public ReadOnly Property Notes As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the personal info notes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


OfficeLocation Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..OfficeLocation Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the business address for this user (use Property.PersonalInformation_OfficeLocation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> OfficeLocation { get; }
Visual Basic
Public ReadOnly Property OfficeLocation As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the business address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfAssistant Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfAssistant Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the assistant's phone number for this user (use Property.PersonalInformation_PhoneNumberOfAssistant).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfAssistant { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfAssistant As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the assistant's phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfBusiness1 Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfBusiness1 Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the business number for this user (use Property.PersonalInformation_PhoneNumberOfBusiness1).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfBusiness1 { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfBusiness1 As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the business number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfBusiness2 Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfBusiness2 Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the 2nd business number for this user (use Property.PersonalInformation_PhoneNumberOfBusiness2).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfBusiness2 { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfBusiness2 As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the 2nd business number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfFax Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfFax Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the fax number for this user (use Property.PersonalInformation_PhoneNumberOfFax).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfFax { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfFax As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the fax number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfHome1 Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfHome1 Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the home number for this user (use Property.PersonalInformation_PhoneNumberOfHome1).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfHome1 { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfHome1 As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the home number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfHome2 Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfHome2 Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the 2nd home number for this user (use Property.PersonalInformation_PhoneNumberOfHome2).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfHome2 { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfHome2 As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the 2nd home number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfMobile Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfMobile Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the mobile number for this user (use Property.PersonalInformation_PhoneNumberOfMobile).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfMobile { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfMobile As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the mobile number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberOfPager Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PhoneNumberOfPager Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the pager number for this user (use Property.PersonalInformation_PhoneNumberOfPager).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, BasicPhoneNumber> PhoneNumberOfPager { get; }
Visual Basic
Public ReadOnly Property PhoneNumberOfPager As GeneralConfigurationProperty(Of UserConfiguration..::..Property, BasicPhoneNumber)
    Get

Field Value

The property representing the pager number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PostalCode Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..PostalCode Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the postal code for this user (use Property.PersonalInformation_PostalCode).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> PostalCode { get; }
Visual Basic
Public ReadOnly Property PostalCode As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the postal code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


StateOrProvince Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..StateOrProvince Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the state/province for this user (use Property.PersonalInformation_StateOrProvince).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> StateOrProvince { get; }
Visual Basic
Public ReadOnly Property StateOrProvince As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the state/province.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


StreetAddress Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..StreetAddress Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the street address for this user (use Property.PersonalInformation_StreetAddress).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> StreetAddress { get; }
Visual Basic
Public ReadOnly Property StreetAddress As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


Surname Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..Surname Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the surname for this user (use Property.PersonalInformation_Surname).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Surname { get; }
Visual Basic
Public ReadOnly Property Surname As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the surname.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


Title Property

[image]

IceLib Technical Reference
PersonalInformationProperties..::..Title Property
PersonalInformationProperties Class See Also Send Feedback
Provides access to the property representing the title for this user (use Property.PersonalInformation_Title).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Title { get; }
Visual Basic
Public ReadOnly Property Title As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

PersonalInformationProperties Class
PersonalInformationProperties Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration Class

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Phone Number Classification. A phone number classification defines a pattern in numbers, or an explicit group of phone numbers with a common purpose.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PhoneNumberClassificationConfiguration : EditableListConfigurationObject<PhoneNumberClassificationConfiguration..::..Property>
Visual Basic
Public Class PhoneNumberClassificationConfiguration _
    Inherits EditableListConfigurationObject(Of PhoneNumberClassificationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' PhoneNumberClassificationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PhoneNumberClassificationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration Members

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration Members
PhoneNumberClassificationConfiguration Class Methods Properties See Also Send Feedback

The PhoneNumberClassificationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

PhoneNumberClassificationConfiguration Class
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration Methods

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration Methods
PhoneNumberClassificationConfiguration Class See Also Send Feedback

The PhoneNumberClassificationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

PhoneNumberClassificationConfiguration Class
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration Properties

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration Properties
PhoneNumberClassificationConfiguration Class See Also Send Feedback

The PhoneNumberClassificationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

PhoneNumberClassificationConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..PropertiesChanged Property
PhoneNumberClassificationConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PhoneNumberClassificationConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of PhoneNumberClassificationConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration Class
PhoneNumberClassificationConfiguration Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Property Enumeration
PhoneNumberClassificationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration.Rights Class

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights Class
PhoneNumberClassificationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..PhoneNumberClassificationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights Members
PhoneNumberClassificationConfiguration..::..Rights Class Properties See Also Send Feedback

The PhoneNumberClassificationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
FollowMe | Gets the follow-me rights filter.
Forward | Gets the forward rights filter.
Tui | Gets the TUI rights filter.
View | Gets the view rights filter.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights Properties
PhoneNumberClassificationConfiguration..::..Rights Class See Also Send Feedback

The PhoneNumberClassificationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
FollowMe | Gets the follow-me rights filter.
Forward | Gets the forward rights filter.
Tui | Gets the TUI rights filter.
View | Gets the view rights filter.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights..::..Admin Property
PhoneNumberClassificationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PhoneNumberClassificationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of PhoneNumberClassificationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
PhoneNumberClassificationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


FollowMe Property

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights..::..FollowMe Property
PhoneNumberClassificationConfiguration..::..Rights Class See Also Send Feedback
Gets the follow-me rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PhoneNumberClassificationConfiguration> FollowMe { get; private set; }
Visual Basic
Public Shared Property FollowMe As RightsQueryFilter(Of PhoneNumberClassificationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
PhoneNumberClassificationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FollowMePhoneNumberClassifications


Forward Property

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights..::..Forward Property
PhoneNumberClassificationConfiguration..::..Rights Class See Also Send Feedback
Gets the forward rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PhoneNumberClassificationConfiguration> Forward { get; private set; }
Visual Basic
Public Shared Property Forward As RightsQueryFilter(Of PhoneNumberClassificationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
PhoneNumberClassificationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ForwardPhoneNumberClassifications


Tui Property

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights..::..Tui Property
PhoneNumberClassificationConfiguration..::..Rights Class See Also Send Feedback
Gets the TUI rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PhoneNumberClassificationConfiguration> Tui { get; private set; }
Visual Basic
Public Shared Property Tui As RightsQueryFilter(Of PhoneNumberClassificationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
PhoneNumberClassificationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TuiPhoneNumberClassifications


View Property

[image]

IceLib Technical Reference
PhoneNumberClassificationConfiguration..::..Rights..::..View Property
PhoneNumberClassificationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PhoneNumberClassificationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of PhoneNumberClassificationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfiguration..::..Rights Class
PhoneNumberClassificationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PhoneNumberClassifications


PhoneNumberClassificationConfigurationList Class

[image]

IceLib Technical Reference
PhoneNumberClassificationConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing PhoneNumberClassification configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PhoneNumberClassificationConfigurationList : EditableConfigurationList<PhoneNumberClassificationConfiguration, PhoneNumberClassificationConfiguration..::..Property>
Visual Basic
Public Class PhoneNumberClassificationConfigurationList _
    Inherits EditableConfigurationList(Of PhoneNumberClassificationConfiguration, PhoneNumberClassificationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' PhoneNumberClassificationConfiguration, PhoneNumberClassificationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' PhoneNumberClassificationConfiguration, PhoneNumberClassificationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' PhoneNumberClassificationConfiguration, PhoneNumberClassificationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PhoneNumberClassificationConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfigurationList Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfigurationList Members

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfigurationList Members
PhoneNumberClassificationConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The PhoneNumberClassificationConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | PhoneNumberClassificationConfigurationList | Initializes a new instance of the PhoneNumberClassificationConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PhoneNumberClassificationConfigurationList Class
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfigurationList Constructor

[image]

IceLib Technical Reference
PhoneNumberClassificationConfigurationList Constructor
PhoneNumberClassificationConfigurationList Class See Also Send Feedback
Initializes a new instance of the PhoneNumberClassificationConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PhoneNumberClassificationConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PhoneNumberClassificationConfigurationList Class
PhoneNumberClassificationConfigurationList Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfigurationList Methods

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfigurationList Methods
PhoneNumberClassificationConfigurationList Class See Also Send Feedback

The PhoneNumberClassificationConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhoneNumberClassificationConfigurationList Class
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfigurationList Properties

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfigurationList Properties
PhoneNumberClassificationConfigurationList Class See Also Send Feedback

The PhoneNumberClassificationConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PhoneNumberClassificationConfigurationList Class
ININ.IceLib.Configuration Namespace


PhoneNumberClassificationConfigurationList Events

[image] [image]

IceLib Technical Reference
PhoneNumberClassificationConfigurationList Events
PhoneNumberClassificationConfigurationList Class See Also Send Feedback

The PhoneNumberClassificationConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PhoneNumberClassificationConfigurationList Class
ININ.IceLib.Configuration Namespace


PositionConfiguration Class

[image]

IceLib Technical Reference
PositionConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Layout Position. A Position represents the physical location of a station.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PositionConfiguration : EditableListConfigurationObject<PositionConfiguration..::..Property>
Visual Basic
Public Class PositionConfiguration _
    Inherits EditableListConfigurationObject(Of PositionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' PositionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PositionConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Members
ININ.IceLib.Configuration Namespace


PositionConfiguration Members

[image] [image]

IceLib Technical Reference
PositionConfiguration Members
PositionConfiguration Class Methods Properties See Also Send Feedback

The PositionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Bottom | Provides access to the property representing the bottom coordinate for this position (use Property.Bottom).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Layout | Provides access to the property representing the layout for this position (use Property.Layout.)
Public property | Left | Provides access to the property representing the left coordinate for this position (use Property.Left).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | Right | Provides access to the property representing the right coordinate for this position (use Property.Right).
Public property | Station | Provides access to the property representing the station for this position (use Property.Station.)
Public property | Top | Provides access to the property representing the top coordinate for this position (use Property.Top).

See Also

PositionConfiguration Class
ININ.IceLib.Configuration Namespace


PositionConfiguration Methods

[image] [image]

IceLib Technical Reference
PositionConfiguration Methods
PositionConfiguration Class See Also Send Feedback

The PositionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

PositionConfiguration Class
ININ.IceLib.Configuration Namespace


PositionConfiguration Properties

[image] [image]

IceLib Technical Reference
PositionConfiguration Properties
PositionConfiguration Class See Also Send Feedback

The PositionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Provides access to the property representing the bottom coordinate for this position (use Property.Bottom).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Layout | Provides access to the property representing the layout for this position (use Property.Layout.)
Public property | Left | Provides access to the property representing the left coordinate for this position (use Property.Left).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | Right | Provides access to the property representing the right coordinate for this position (use Property.Right).
Public property | Station | Provides access to the property representing the station for this position (use Property.Station.)
Public property | Top | Provides access to the property representing the top coordinate for this position (use Property.Top).

See Also

PositionConfiguration Class
ININ.IceLib.Configuration Namespace


Bottom Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Bottom Property
PositionConfiguration Class See Also Send Feedback
Provides access to the property representing the bottom coordinate for this position (use Property.Bottom).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PositionConfiguration..::..Property, float> Bottom { get; }
Visual Basic
Public ReadOnly Property Bottom As GeneralConfigurationProperty(Of PositionConfiguration..::..Property, Single)
    Get

Field Value

The property representing the bottom coordinate, as a percentage of the Property.Layout height.

Remarks

Must be between 0 and 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


Layout Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Layout Property
PositionConfiguration Class See Also Send Feedback
Provides access to the property representing the layout for this position (use Property.Layout.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PositionConfiguration..::..Property, ConfigurationId> Layout { get; }
Visual Basic
Public ReadOnly Property Layout As GeneralConfigurationProperty(Of PositionConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the layout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


Left Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Left Property
PositionConfiguration Class See Also Send Feedback
Provides access to the property representing the left coordinate for this position (use Property.Left).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PositionConfiguration..::..Property, float> Left { get; }
Visual Basic
Public ReadOnly Property Left As GeneralConfigurationProperty(Of PositionConfiguration..::..Property, Single)
    Get

Field Value

The property representing the left coordinate, as a percentage of the Property.Layout width.

Remarks

Must be between 0 and 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
PositionConfiguration..::..PropertiesChanged Property
PositionConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PositionConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of PositionConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


Right Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Right Property
PositionConfiguration Class See Also Send Feedback
Provides access to the property representing the right coordinate for this position (use Property.Right).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PositionConfiguration..::..Property, float> Right { get; }
Visual Basic
Public ReadOnly Property Right As GeneralConfigurationProperty(Of PositionConfiguration..::..Property, Single)
    Get

Field Value

The property representing the right coordinate, as a percentage of the Property.Layout width.

Remarks

Must be between 0 and 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


Station Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Station Property
PositionConfiguration Class See Also Send Feedback
Provides access to the property representing the station for this position (use Property.Station.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PositionConfiguration..::..Property, ConfigurationId> Station { get; }
Visual Basic
Public ReadOnly Property Station As GeneralConfigurationProperty(Of PositionConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


Top Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Top Property
PositionConfiguration Class See Also Send Feedback
Provides access to the property representing the top coordinate for this position (use Property.Top).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<PositionConfiguration..::..Property, float> Top { get; }
Visual Basic
Public ReadOnly Property Top As GeneralConfigurationProperty(Of PositionConfiguration..::..Property, Single)
    Get

Field Value

The property representing the top coordinate, as a percentage of the Property.Layout height.

Remarks

Must be between 0 and 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration Class
PositionConfiguration Members
ININ.IceLib.Configuration Namespace


PositionConfiguration.Property Enumeration

[image]

IceLib Technical Reference
PositionConfiguration..::..Property Enumeration
PositionConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Bottom | 0 | Represents the Bottom property.
Layout | 1 | Represents the Layout property.
Left | 2 | Represents the Left property.
Right | 3 | Represents the Right property.
Station | 4 | Represents the Station property.
Top | 5 | Represents the Top property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration Namespace


PositionConfiguration.Rights Class

[image]

IceLib Technical Reference
PositionConfiguration..::..Rights Class
PositionConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..PositionConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


PositionConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
PositionConfiguration..::..Rights Members
PositionConfiguration..::..Rights Class Properties See Also Send Feedback

The PositionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

PositionConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


PositionConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
PositionConfiguration..::..Rights Properties
PositionConfiguration..::..Rights Class See Also Send Feedback

The PositionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

PositionConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Rights..::..Admin Property
PositionConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PositionConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of PositionConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration..::..Rights Class
PositionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Positions


View Property

[image]

IceLib Technical Reference
PositionConfiguration..::..Rights..::..View Property
PositionConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<PositionConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of PositionConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfiguration..::..Rights Class
PositionConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewPositionsList


PositionConfigurationList Class

[image]

IceLib Technical Reference
PositionConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Position configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PositionConfigurationList : EditableConfigurationList<PositionConfiguration, PositionConfiguration..::..Property>
Visual Basic
Public Class PositionConfigurationList _
    Inherits EditableConfigurationList(Of PositionConfiguration, PositionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' PositionConfiguration, PositionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' PositionConfiguration, PositionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' PositionConfiguration, PositionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..PositionConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfigurationList Members
ININ.IceLib.Configuration Namespace


PositionConfigurationList Members

[image] [image]

IceLib Technical Reference
PositionConfigurationList Members
PositionConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The PositionConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | PositionConfigurationList | Initializes a new instance of the PositionConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PositionConfigurationList Class
ININ.IceLib.Configuration Namespace


PositionConfigurationList Constructor

[image]

IceLib Technical Reference
PositionConfigurationList Constructor
PositionConfigurationList Class See Also Send Feedback
Initializes a new instance of the PositionConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PositionConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

PositionConfigurationList Class
PositionConfigurationList Members
ININ.IceLib.Configuration Namespace


PositionConfigurationList Methods

[image] [image]

IceLib Technical Reference
PositionConfigurationList Methods
PositionConfigurationList Class See Also Send Feedback

The PositionConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositionConfigurationList Class
ININ.IceLib.Configuration Namespace


PositionConfigurationList Properties

[image] [image]

IceLib Technical Reference
PositionConfigurationList Properties
PositionConfigurationList Class See Also Send Feedback

The PositionConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PositionConfigurationList Class
ININ.IceLib.Configuration Namespace


PositionConfigurationList Events

[image] [image]

IceLib Technical Reference
PositionConfigurationList Events
PositionConfigurationList Class See Also Send Feedback

The PositionConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

PositionConfigurationList Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration Class

[image]

IceLib Technical Reference
ProblemReporterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for ProblemReporter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProblemReporterConfiguration : EditableContainerConfigurationObject<ProblemReporterConfiguration..::..Property>
Visual Basic
Public Class ProblemReporterConfiguration _
    Inherits EditableContainerConfigurationObject(Of ProblemReporterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' ProblemReporterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ProblemReporterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Connection.Extensions..::..ProblemReporter


ProblemReporterConfiguration Members

[image] [image]

IceLib Technical Reference
ProblemReporterConfiguration Members
ProblemReporterConfiguration Class Methods Properties See Also Send Feedback

The ProblemReporterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | EmailAddresses | Provides access to the property representing the email addresses (use Property.EmailAddresses).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ProblemReporterConfiguration Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration Methods

[image] [image]

IceLib Technical Reference
ProblemReporterConfiguration Methods
ProblemReporterConfiguration Class See Also Send Feedback

The ProblemReporterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ProblemReporterConfiguration Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration Properties

[image] [image]

IceLib Technical Reference
ProblemReporterConfiguration Properties
ProblemReporterConfiguration Class See Also Send Feedback

The ProblemReporterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | EmailAddresses | Provides access to the property representing the email addresses (use Property.EmailAddresses).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ProblemReporterConfiguration Class
ININ.IceLib.Configuration Namespace


EmailAddresses Property

[image]

IceLib Technical Reference
ProblemReporterConfiguration..::..EmailAddresses Property
ProblemReporterConfiguration Class See Also Send Feedback
Provides access to the property representing the email addresses (use Property.EmailAddresses).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ProblemReporterConfiguration..::..Property, Collection<string>> EmailAddresses { get; }
Visual Basic
Public ReadOnly Property EmailAddresses As GeneralConfigurationProperty(Of ProblemReporterConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the email addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfiguration Class
ProblemReporterConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ProblemReporterConfiguration..::..StandardProperties Property
ProblemReporterConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ProblemReporterConfiguration, ProblemReporterConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ProblemReporterConfiguration, ProblemReporterConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfiguration Class
ProblemReporterConfiguration Members
ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ProblemReporterConfiguration..::..Property Enumeration
ProblemReporterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
EmailAddresses | 0 | Represents the EmailAddresses property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration.Rights Class

[image]

IceLib Technical Reference
ProblemReporterConfiguration..::..Rights Class
ProblemReporterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ProblemReporterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ProblemReporterConfiguration..::..Rights Members
ProblemReporterConfiguration..::..Rights Class Properties See Also Send Feedback

The ProblemReporterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ProblemReporterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ProblemReporterConfiguration..::..Rights Properties
ProblemReporterConfiguration..::..Rights Class See Also Send Feedback

The ProblemReporterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ProblemReporterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ProblemReporterConfiguration..::..Rights..::..Admin Property
ProblemReporterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ProblemReporterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ProblemReporterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfiguration..::..Rights Class
ProblemReporterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ProblemReporterConfiguration


View Property

[image]

IceLib Technical Reference
ProblemReporterConfiguration..::..Rights..::..View Property
ProblemReporterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ProblemReporterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ProblemReporterConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfiguration..::..Rights Class
ProblemReporterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ProblemReporterConfigurationContainer Class

[image]

IceLib Technical Reference
ProblemReporterConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the ProblemReporter configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProblemReporterConfigurationContainer : ConfigurationContainer<ProblemReporterConfiguration, ProblemReporterConfiguration..::..Property>
Visual Basic
Public Class ProblemReporterConfigurationContainer _
    Inherits ConfigurationContainer(Of ProblemReporterConfiguration, ProblemReporterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' ProblemReporterConfiguration, ProblemReporterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ProblemReporterConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfigurationContainer Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Connection.Extensions..::..ProblemReporter


ProblemReporterConfigurationContainer Members

[image] [image]

IceLib Technical Reference
ProblemReporterConfigurationContainer Members
ProblemReporterConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The ProblemReporterConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | ProblemReporterConfigurationContainer | Initializes a new instance of the ProblemReporterConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ProblemReporterConfigurationContainer Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfigurationContainer Constructor

[image]

IceLib Technical Reference
ProblemReporterConfigurationContainer Constructor
ProblemReporterConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the ProblemReporterConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProblemReporterConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporterConfigurationContainer Class
ProblemReporterConfigurationContainer Members
ININ.IceLib.Configuration Namespace


ProblemReporterConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
ProblemReporterConfigurationContainer Methods
ProblemReporterConfigurationContainer Class See Also Send Feedback

The ProblemReporterConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProblemReporterConfigurationContainer Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
ProblemReporterConfigurationContainer Properties
ProblemReporterConfigurationContainer Class See Also Send Feedback

The ProblemReporterConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ProblemReporterConfigurationContainer Class
ININ.IceLib.Configuration Namespace


ProblemReporterConfigurationContainer Events

[image] [image]

IceLib Technical Reference
ProblemReporterConfigurationContainer Events
ProblemReporterConfigurationContainer Class See Also Send Feedback

The ProblemReporterConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ProblemReporterConfigurationContainer Class
ININ.IceLib.Configuration Namespace


QueryChildrenSettings(TPropertyEnum) Class

[image]

IceLib Technical Reference
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Abstract class that acts as a container for QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> that HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> uses to hold its children.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class QueryChildrenSettings<TPropertyEnum>
where TPropertyEnum : struct, new()
Visual Basic
Public MustInherit Class QueryChildrenSettings(Of TPropertyEnum As {Structure, New})

Type Parameters

TPropertyEnum
The type of the property enum.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..AnalyzerQueryChildrenSettings
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiQueryChildrenSettings
ININ.IceLib.Configuration..::..ScheduleQueryChildrenSettings
ININ.IceLib.Configuration..::..WorkgroupQueryChildrenSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QueryChildrenSettings(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Members
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class Constructors Methods See Also Send Feedback

The QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> | Initializes a new instance of the QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


QueryChildrenSettings(TPropertyEnum) Constructor

[image]

IceLib Technical Reference
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Constructor
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> class

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected QueryChildrenSettings()
Visual Basic
Protected Sub New

See Also

QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QueryChildrenSettings(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Methods
QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryChildrenSettings<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


QueryResultLimit Enumeration

[image]

IceLib Technical Reference
QueryResultLimit Enumeration
See Also Send Feedback
Limits a QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> result set to a non-numerical, special case value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum QueryResultLimit
Visual Basic
Public Enumeration QueryResultLimit

Members

Member name | Value | Description
DynamicLimit | 0 | The result set will have a dynamic result length based on the number of properties that are queried. If more than five properties are queried, the results will be limited to 300 items. If five or less properties are queried, the results will be unlimited. This is the default limit that is applied to queries and should be used in most cases.
Unlimited | 1 | The result set will be unlimited. This should be used with extreme caution and only when requesting data that is of a reasonable number of properties and result entries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


QuerySettings(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
This class represents settings for a Configuration query that provides a filtered and sorted set of results. CreateQuerySettings()()()() can be used to construct an appropriate QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. The Set functions can be used to override default values.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QuerySettings<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class QuerySettings(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
The type of the configuration object.
TPropertyEnum
The type of the property enumeration.

Remarks

The QuerySettings class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. This query can be customized by calling the set functions. Calling a Set function will replace the existing settings for that item with the specified new values. For example, calling SetPropertiesToQuery will replace the existing property list. Calling a set function with nullNothingnullptra null reference (Nothing in Visual Basic) will cause that item to revert to the default values. All set functions return a this pointer to allow for optional fluent syntax. CreateQuerySettings()()()() is provided to allow a simple method to create a default QuerySettings object that can be further customized.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QuerySettings(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> | Initializes a new instance of the QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class, using default settings. CreateQuerySettings()()()() can also be used to construct an appropriate QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. Use the Set... functions to configure this QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetFilterDefinition(FilterDefinition<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.
Public method SetFilterDefinition(TPropertyEnum, Object)
Sets the filter definition to filter the results by the filteredProperty, using a Prefix filter match type.
Public method SetFilterDefinition(TPropertyEnum, Object, FilterMatchType)
Sets the filter definition to filter the results by the filteredProperty.
Public method SetLanguageToRetrieve
Sets the language to retrieve.

Remarks

If set to nullNothingnullptra null reference (Nothing in Visual Basic) or Empty, then only the default language will be returned.
Public method SetLanguageToRetrieveToAll
Sets the language to retrieve to all languages.
Public method SetLanguageToRetrieveToDefault
Sets the language to retrieve to the default language.
Public method SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>))
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
Public method SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][])
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
Public method SetPropertiesToRetrieveToAll
Sets this query to retrieve all properties on the objects.
Public method SetResultCountLimit(Int32)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
Public method SetResultCountLimit(QueryResultLimit)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
Public method SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][])
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>))
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method SetRightsFilterToAdmin
Sets the rights filter to use the default admin right for this object.
Public method SetRightsFilterToView
Sets the rights filter to use the default view right for this object.
Public method SetSortOrder(SortDefinition<(Of <<'(TPropertyEnum>)>>))
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
Public method SetSortOrder(TPropertyEnum, ListSortDirection)
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
Public method SetStartAtRecordNumber
Sets the record number to start at for the query results. By default, the record number starts at zero (to start at the beginning).
Public method SupportsValueListFiltering
Determines if value list filtering via ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> is supported.
Public method ToString
Returns a String that represents the current Object.
(Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilterDefinition | Gets the filter definition.
Public property | Language | Gets the language.
Public property | PropertiesInQuery | Gets the properties of the object that are to be included in the query results.
Public property | ResultCountLimit | Gets the result count limit or nullNothingnullptra null reference (Nothing in Visual Basic) if the results are unlimited.
Public property | RightsFilters | Gets the list of rights that will filter the search results.
Public property | SortDefinition | Gets the sort definition.
Public property | StartAtRecordNumber | Gets the starting record number of the query results that will be returned.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


QuerySettings(TConfigurationObject, TPropertyEnum) Constructor

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Constructor
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class, using default settings. CreateQuerySettings()()()() can also be used to construct an appropriate QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. Use the Set... functions to configure this QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings()
Visual Basic
Public Sub New

Remarks

This constructor will create a default, empty QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> instance. If unaltered through he set functions, this instance will return ID and display name for all objects the current user has View access to sorted by display name if applicable, ID otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QuerySettings(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

Name Description
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetFilterDefinition(FilterDefinition<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.
Public method SetFilterDefinition(TPropertyEnum, Object)
Sets the filter definition to filter the results by the filteredProperty, using a Prefix filter match type.
Public method SetFilterDefinition(TPropertyEnum, Object, FilterMatchType)
Sets the filter definition to filter the results by the filteredProperty.
Public method SetLanguageToRetrieve
Sets the language to retrieve.

Remarks

If set to nullNothingnullptra null reference (Nothing in Visual Basic) or Empty, then only the default language will be returned.
Public method SetLanguageToRetrieveToAll
Sets the language to retrieve to all languages.
Public method SetLanguageToRetrieveToDefault
Sets the language to retrieve to the default language.
Public method SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>))
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
Public method SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][])
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
Public method SetPropertiesToRetrieveToAll
Sets this query to retrieve all properties on the objects.
Public method SetResultCountLimit(Int32)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
Public method SetResultCountLimit(QueryResultLimit)
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
Public method SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][])
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>))
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method SetRightsFilterToAdmin
Sets the rights filter to use the default admin right for this object.
Public method SetRightsFilterToView
Sets the rights filter to use the default view right for this object.
Public method SetSortOrder(SortDefinition<(Of <<'(TPropertyEnum>)>>))
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
Public method SetSortOrder(TPropertyEnum, ListSortDirection)
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
Public method SetStartAtRecordNumber
Sets the record number to start at for the query results. By default, the record number starts at zero (to start at the beginning).
Public method SupportsValueListFiltering
Determines if value list filtering via ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> is supported.
Public method ToString
Returns a String that represents the current Object.
(Overrides Object..::..ToString()()()().)

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


SetFilterDefinition Method

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetFilterDefinition Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.

Overload List

 | Name | Description
Public method | SetFilterDefinition(FilterDefinition<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.
Public method | SetFilterDefinition(TPropertyEnum, Object) | Sets the filter definition to filter the results by the filteredProperty, using a Prefix filter match type.
Public method | SetFilterDefinition(TPropertyEnum, Object, FilterMatchType) | Sets the filter definition to filter the results by the filteredProperty.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetFilterDefinition Method (FilterDefinition(TConfigurationObject, TPropertyEnum))

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetFilterDefinition Method (FilterDefinition<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the filter definition that control how the result set is filtered. If no filter is specified the results will be unfiltered.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetFilterDefinition(
    FilterDefinition<TConfigurationObject, TPropertyEnum> filter
)
Visual Basic
Public Function SetFilterDefinition ( _
    filter As FilterDefinition(Of TConfigurationObject, TPropertyEnum) _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

filter
Type: ININ.IceLib.Configuration..::..FilterDefinition <(Of <(<' TConfigurationObject, TPropertyEnum >)>)>
The filter definition to apply. See BasicFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>, GroupFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>, and CustomAttributeFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetFilterDefinition Overload
ININ.IceLib.Configuration Namespace


SetFilterDefinition Method (TPropertyEnum, Object)

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetFilterDefinition Method (TPropertyEnum, Object)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the filter definition to filter the results by the filteredProperty, using a Prefix filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetFilterDefinition(
    TPropertyEnum filteredProperty,
    Object filterValue
)
Visual Basic
Public Function SetFilterDefinition ( _
    filteredProperty As TPropertyEnum, _
    filterValue As Object _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

filteredProperty
Type: TPropertyEnum
The property to filter by. Use the Property enumeration of your <TConfigurationObject>
filterValue
Type: System..::..Object
The value to match the property against.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetFilterDefinition Overload
ININ.IceLib.Configuration Namespace


SetFilterDefinition Method (TPropertyEnum, Object, FilterMatchType)

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetFilterDefinition Method (TPropertyEnum, Object, FilterMatchType)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the filter definition to filter the results by the filteredProperty.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetFilterDefinition(
    TPropertyEnum filteredProperty,
    Object filterValue,
    FilterMatchType filterMatchType
)
Visual Basic
Public Function SetFilterDefinition ( _
    filteredProperty As TPropertyEnum, _
    filterValue As Object, _
    filterMatchType As FilterMatchType _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

filteredProperty
Type: TPropertyEnum
The property to filter by. Use the Property enumeration of your <TConfigurationObject>
filterValue
Type: System..::..Object
The value to match the property against.
filterMatchType
Type: ININ.IceLib.Configuration..::..FilterMatchType
The type of comparison to perform on the filterValue.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetFilterDefinition Overload
ININ.IceLib.Configuration Namespace


SetLanguageToRetrieve Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetLanguageToRetrieve Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the language to retrieve.

Remarks

If set to nullNothingnullptra null reference (Nothing in Visual Basic) or Empty, then only the default language will be returned.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetLanguageToRetrieve(
    string language
)
Visual Basic
Public Function SetLanguageToRetrieve ( _
    language As String _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

language
Type: System..::..String

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetLanguageToRetrieveToAll Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetLanguageToRetrieveToAll Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the language to retrieve to all languages.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetLanguageToRetrieveToAll()
Visual Basic
Public Function SetLanguageToRetrieveToAll As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetLanguageToRetrieveToDefault Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetLanguageToRetrieveToDefault Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the language to retrieve to the default language.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetLanguageToRetrieveToDefault()
Visual Basic
Public Function SetLanguageToRetrieveToDefault As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieve Method

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieve Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.

Overload List

 | Name | Description
Public method | SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Sets the properties that this settings will query. If no properties are specified ID and display name are queried.
Public method | SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]) | Sets the properties that this settings will query. If no properties are specified ID and display name are queried.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieve Method (IEnumerable(TPropertyEnum))

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieve Method (IEnumerable<(Of <(<'TPropertyEnum>)>)>)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetPropertiesToRetrieve(
    IEnumerable<TPropertyEnum> properties
)
Visual Basic
Public Function SetPropertiesToRetrieve ( _
    properties As IEnumerable(Of TPropertyEnum) _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TPropertyEnum >)>)>
The collection of properties to return in the query.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetPropertiesToRetrieve Overload
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieve Method (TPropertyEnum[])

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieve Method (array<TPropertyEnum>[]()[][])
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the properties that this settings will query. If no properties are specified ID and display name are queried.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetPropertiesToRetrieve(
    params TPropertyEnum[] properties
)
Visual Basic
Public Function SetPropertiesToRetrieve ( _
    ParamArray properties As TPropertyEnum() _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

properties
Type: array< TPropertyEnum >[]()[][]
The properties to return in the query.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetPropertiesToRetrieve Overload
ININ.IceLib.Configuration Namespace


SetPropertiesToRetrieveToAll Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetPropertiesToRetrieveToAll Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets this query to retrieve all properties on the objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetPropertiesToRetrieveToAll()
Visual Basic
Public Function SetPropertiesToRetrieveToAll As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetResultCountLimit Method

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetResultCountLimit Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.

Overload List

 | Name | Description
Public method | SetResultCountLimit(Int32) | Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.
Public method | SetResultCountLimit(QueryResultLimit) | Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetResultCountLimit Method (Int32)

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetResultCountLimit Method (Int32)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetResultCountLimit(
    int count
)
Visual Basic
Public Function SetResultCountLimit ( _
    count As Integer _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

count
Type: System..::..Int32
The maximum number of results to retrieve.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified count is negative.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetResultCountLimit Overload
ININ.IceLib.Configuration Namespace


SetResultCountLimit Method (QueryResultLimit)

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetResultCountLimit Method (QueryResultLimit)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the maximum number of results to retrieve with this query. If no limit is specified the results will use a dynamic limit.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetResultCountLimit(
    QueryResultLimit limit
)
Visual Basic
Public Function SetResultCountLimit ( _
    limit As QueryResultLimit _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

limit
Type: ININ.IceLib.Configuration..::..QueryResultLimit
The non-numeric limit type, such as unlimited or dynamic.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified limit is not a valid QueryResultLimit.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetResultCountLimit Overload
ININ.IceLib.Configuration Namespace


SetRightsFilter Method

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilter Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

Overload List

 | Name | Description
Public method | SetRightsFilter(array<RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>[]()[][]) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.
Public method | SetRightsFilter(IEnumerable<(Of <<'(RightsQueryFilter<(Of <<'(TConfigurationObject>)>>)>)>>)) | Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetRightsFilter Method (RightsQueryFilter(TConfigurationObject)[])

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilter Method (array<RightsQueryFilter<(Of <(<'TConfigurationObject>)>)>>[]()[][])
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilter(
    params RightsQueryFilter<TConfigurationObject>[] rights
)
Visual Basic
Public Function SetRightsFilter ( _
    ParamArray rights As RightsQueryFilter(Of TConfigurationObject)() _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

rights
Type: array< ININ.IceLib.Configuration..::..RightsQueryFilter <(Of <(<' TConfigurationObject >)>)>>[]()[][]
The pre-constructed rights object. This can be found inside of the individual <TConfigurationObject> class, such as UserConfiguration..::..Rights or WorkgroupConfiguration..::..Rights.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the result list against. For example, if UserConfigurationList is being queried and ChangeUserStatus is specified, this query will only result in User objects that the current user has ChangeUserStatus rights to. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetRightsFilter Overload
ININ.IceLib.Configuration Namespace


SetRightsFilter Method (IEnumerable(RightsQueryFilter(TConfigurationObject)))

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilter Method (IEnumerable<(Of <(<'RightsQueryFilter<(Of <(<'TConfigurationObject>)>)>>)>)>)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the list of rights to filter the result set against. If no rights are specified the view right will be used.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilter(
    IEnumerable<RightsQueryFilter<TConfigurationObject>> rights
)
Visual Basic
Public Function SetRightsFilter ( _
    rights As IEnumerable(Of RightsQueryFilter(Of TConfigurationObject)) _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

rights
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' RightsQueryFilter <(Of <(<' TConfigurationObject >)>)>>)>)>
The pre-constructed rights object. This can be found inside of the individual <TConfigurationObject> class, such as UserConfiguration..::..Rights or WorkgroupConfiguration..::..Rights.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the result list against. For example, if UserConfigurationList is being queried and ChangeUserStatus is specified, this query will only result in User objects that the current user has ChangeUserStatus rights to. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetRightsFilter Overload
ININ.IceLib.Configuration Namespace


SetRightsFilterToAdmin Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilterToAdmin Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the rights filter to use the default admin right for this object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilterToAdmin()
Visual Basic
Public Function SetRightsFilterToAdmin As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the result list against. For example, if UserConfigurationList is being queried and ChangeUserStatus is specified, this query will only result in User objects that the current user has ChangeUserStatus rights to. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetRightsFilterToView Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetRightsFilterToView Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the rights filter to use the default view right for this object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetRightsFilterToView()
Visual Basic
Public Function SetRightsFilterToView As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

The rights filter sets a list of rights that will be used to filter the result list against. For example, if UserConfigurationList is being queried and ChangeUserStatus is specified, this query will only result in User objects that the current user has ChangeUserStatus rights to. This will overwrite the current rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetSortOrder Method

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetSortOrder Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.

Overload List

 | Name | Description
Public method | SetSortOrder(SortDefinition<(Of <<'(TPropertyEnum>)>>)) | Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.
Public method | SetSortOrder(TPropertyEnum, ListSortDirection) | Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SetSortOrder Method (SortDefinition(TPropertyEnum))

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetSortOrder Method (SortDefinition<(Of <(<'TPropertyEnum>)>)>)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetSortOrder(
    SortDefinition<TPropertyEnum> sort
)
Visual Basic
Public Function SetSortOrder ( _
    sort As SortDefinition(Of TPropertyEnum) _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

sort
Type: ININ.IceLib.Configuration..::..SortDefinition <(Of <(<' TPropertyEnum >)>)>
The SortDefinition<(Of <(<'TPropertyEnum>)>)>.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetSortOrder Overload
ININ.IceLib.Configuration Namespace


SetSortOrder Method (TPropertyEnum, ListSortDirection)

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetSortOrder Method (TPropertyEnum, ListSortDirection)
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the sort order to be applied to this query. If no sort order is specified, a default order of ascending display name will be applied.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetSortOrder(
    TPropertyEnum sortProperty,
    ListSortDirection sortDirection
)
Visual Basic
Public Function SetSortOrder ( _
    sortProperty As TPropertyEnum, _
    sortDirection As ListSortDirection _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

sortProperty
Type: TPropertyEnum
The property to sort on.
sortDirection
Type: System.ComponentModel..::..ListSortDirection
The direction sort.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
SetSortOrder Overload
ININ.IceLib.Configuration Namespace


SetStartAtRecordNumber Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SetStartAtRecordNumber Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Sets the record number to start at for the query results. By default, the record number starts at zero (to start at the beginning).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<TConfigurationObject, TPropertyEnum> SetStartAtRecordNumber(
    int startAtRecordNumber
)
Visual Basic
Public Function SetStartAtRecordNumber ( _
    startAtRecordNumber As Integer _
) As QuerySettings(Of TConfigurationObject, TPropertyEnum)

Parameters

startAtRecordNumber
Type: System..::..Int32
The record number to start the result at.

Return Value

This QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Remarks

This value is 0-based. If a value is specified that is greater than the number of records, then no results will be returned.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified startAtRecordNumber is less than zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SupportsValueListFiltering Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SupportsValueListFiltering Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Determines if value list filtering via ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> is supported.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SupportsValueListFiltering(
    ConfigurationManager configurationManager
)
Visual Basic
Public Function SupportsValueListFiltering ( _
    configurationManager As ConfigurationManager _
) As Boolean

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Return Value

trueTruetruetrue (True in Visual Basic) if value list filtering is supported; otherwise falseFalsefalsefalse (False in Visual Basic).

Remarks

Value list filtering is supported for 4.0 SU 6, for the following objects:
  • AccountCodeConfiguration
  • FeatureLicenseConfiguration
  • LicenseAllocationConfiguration
  • RoleConfiguration
  • SkillConfiguration
  • WorkgroupConfiguration
  • WorkgroupMonitoredMailboxConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ToString Method
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QuerySettings(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilterDefinition | Gets the filter definition.
Public property | Language | Gets the language.
Public property | PropertiesInQuery | Gets the properties of the object that are to be included in the query results.
Public property | ResultCountLimit | Gets the result count limit or nullNothingnullptra null reference (Nothing in Visual Basic) if the results are unlimited.
Public property | RightsFilters | Gets the list of rights that will filter the search results.
Public property | SortDefinition | Gets the sort definition.
Public property | StartAtRecordNumber | Gets the starting record number of the query results that will be returned.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


FilterDefinition Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FilterDefinition Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filter definition.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilterDefinition<TConfigurationObject, TPropertyEnum> FilterDefinition { get; }
Visual Basic
Public ReadOnly Property FilterDefinition As FilterDefinition(Of TConfigurationObject, TPropertyEnum)
    Get

Field Value

The filter definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Language Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Language Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the language.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Language { get; }
Visual Basic
Public ReadOnly Property Language As String
    Get

Field Value

The language.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PropertiesInQuery Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PropertiesInQuery Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the properties of the object that are to be included in the query results.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TPropertyEnum> PropertiesInQuery { get; }
Visual Basic
Public ReadOnly Property PropertiesInQuery As ReadOnlyCollection(Of TPropertyEnum)
    Get

Field Value

The properties in query.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ResultCountLimit Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ResultCountLimit Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the result count limit or nullNothingnullptra null reference (Nothing in Visual Basic) if the results are unlimited.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> ResultCountLimit { get; }
Visual Basic
Public ReadOnly Property ResultCountLimit As Nullable(Of Integer)
    Get

Field Value

The result count limit.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RightsFilters Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RightsFilters Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the list of rights that will filter the search results.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RightsQueryFilter<TConfigurationObject>> RightsFilters { get; }
Visual Basic
Public ReadOnly Property RightsFilters As ReadOnlyCollection(Of RightsQueryFilter(Of TConfigurationObject))
    Get

Field Value

The rights filter.

Remarks

The rights filters are predefined in the Rights class that belongs to the configuration classes. For example see UserConfiguration..::..Rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SortDefinition Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SortDefinition Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the sort definition.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SortDefinition<TPropertyEnum> SortDefinition { get; }
Visual Basic
Public ReadOnly Property SortDefinition As SortDefinition(Of TPropertyEnum)
    Get

Field Value

The sort definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StartAtRecordNumber Property

[image]

IceLib Technical Reference
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StartAtRecordNumber Property
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the starting record number of the query results that will be returned.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int StartAtRecordNumber { get; }
Visual Basic
Public ReadOnly Property StartAtRecordNumber As Integer
    Get

Field Value

The starting record number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration Class

[image]

IceLib Technical Reference
QueueColumnConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC QueueColumn.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueColumnConfiguration : EditableListConfigurationObject<QueueColumnConfiguration..::..Property>
Visual Basic
Public Class QueueColumnConfiguration _
    Inherits EditableListConfigurationObject(Of QueueColumnConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' QueueColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..QueueColumnConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration Members
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration Members

[image] [image]

IceLib Technical Reference
QueueColumnConfiguration Members
QueueColumnConfiguration Class Methods Properties See Also Send Feedback

The QueueColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Attribute | Provides access to the property representing the attribute for this column (use Property.Attribute).
Public property | AttributeType | Provides access to the property representing the attribute type for this column (use Property.AttributeType).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the property representing whether this column is permanent or custom (use Property.IsPermanent).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

QueueColumnConfiguration Class
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration Methods

[image] [image]

IceLib Technical Reference
QueueColumnConfiguration Methods
QueueColumnConfiguration Class See Also Send Feedback

The QueueColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

QueueColumnConfiguration Class
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration Properties

[image] [image]

IceLib Technical Reference
QueueColumnConfiguration Properties
QueueColumnConfiguration Class See Also Send Feedback

The QueueColumnConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Attribute | Provides access to the property representing the attribute for this column (use Property.Attribute).
Public property | AttributeType | Provides access to the property representing the attribute type for this column (use Property.AttributeType).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the property representing whether this column is permanent or custom (use Property.IsPermanent).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

QueueColumnConfiguration Class
ININ.IceLib.Configuration Namespace


Attribute Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..Attribute Property
QueueColumnConfiguration Class See Also Send Feedback
Provides access to the property representing the attribute for this column (use Property.Attribute).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<QueueColumnConfiguration..::..Property, string> Attribute { get; }
Visual Basic
Public ReadOnly Property Attribute As GeneralConfigurationProperty(Of QueueColumnConfiguration..::..Property, String)
    Get

Field Value

The property representing the column attribute.

Remarks

Note
This property only applies when IsPermanent is falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration Class
QueueColumnConfiguration Members
ININ.IceLib.Configuration Namespace
QueueColumnConfiguration..::..IsPermanent


AttributeType Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..AttributeType Property
QueueColumnConfiguration Class See Also Send Feedback
Provides access to the property representing the attribute type for this column (use Property.AttributeType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<QueueColumnConfiguration..::..Property, QueueColumnAttributeType> AttributeType { get; }
Visual Basic
Public ReadOnly Property AttributeType As GeneralConfigurationProperty(Of QueueColumnConfiguration..::..Property, QueueColumnAttributeType)
    Get

Field Value

The property representing the column attribute type.

Remarks

Note
This property only applies when IsPermanent is falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration Class
QueueColumnConfiguration Members
ININ.IceLib.Configuration Namespace
QueueColumnConfiguration..::..IsPermanent


IsPermanent Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..IsPermanent Property
QueueColumnConfiguration Class See Also Send Feedback
Provides access to the property representing whether this column is permanent or custom (use Property.IsPermanent).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<QueueColumnConfiguration..::..Property, bool> IsPermanent { get; }
Visual Basic
Public ReadOnly Property IsPermanent As GeneralConfigurationProperty(Of QueueColumnConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether this column is permanent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration Class
QueueColumnConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..PropertiesChanged Property
QueueColumnConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueColumnConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of QueueColumnConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration Class
QueueColumnConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..StandardProperties Property
QueueColumnConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<QueueColumnConfiguration, QueueColumnConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of QueueColumnConfiguration, QueueColumnConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration Class
QueueColumnConfiguration Members
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration.Property Enumeration

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..Property Enumeration
QueueColumnConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
IsPermanent | 0 | Represents the IsPermanent property.
AttributeType | 1 | Represents the AttributeType property.
Attribute | 2 | Represents the Attribute property.
DisplayName | 3 | Represents the DisplayName part of the ConfigurationId property.
Id | 4 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


QueueColumnConfiguration.Rights Class

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..Rights Class
QueueColumnConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QueueColumnConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
QueueColumnConfiguration..::..Rights Members
QueueColumnConfiguration..::..Rights Class Properties See Also Send Feedback

The QueueColumnConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Substitute | Gets the substitute rights filter.
View | Gets the view rights filter.

See Also

QueueColumnConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


QueueColumnConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
QueueColumnConfiguration..::..Rights Properties
QueueColumnConfiguration..::..Rights Class See Also Send Feedback

The QueueColumnConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Substitute | Gets the substitute rights filter.
View | Gets the view rights filter.

See Also

QueueColumnConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..Rights..::..Admin Property
QueueColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<QueueColumnConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of QueueColumnConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration..::..Rights Class
QueueColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..QueueControlColumns


Substitute Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..Rights..::..Substitute Property
QueueColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the substitute rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<QueueColumnConfiguration> Substitute { get; private set; }
Visual Basic
Public Shared Property Substitute As RightsQueryFilter(Of QueueColumnConfiguration)
    Get
    Private Set

Field Value

The substitute rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration..::..Rights Class
QueueColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SubstituteQueueControlColumns


View Property

[image]

IceLib Technical Reference
QueueColumnConfiguration..::..Rights..::..View Property
QueueColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<QueueColumnConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of QueueColumnConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfiguration..::..Rights Class
QueueColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewQueueControlColumns


QueueColumnConfigurationList Class

[image]

IceLib Technical Reference
QueueColumnConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing QueueColumn configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueColumnConfigurationList : EditableConfigurationList<QueueColumnConfiguration, QueueColumnConfiguration..::..Property>
Visual Basic
Public Class QueueColumnConfigurationList _
    Inherits EditableConfigurationList(Of QueueColumnConfiguration, QueueColumnConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' QueueColumnConfiguration, QueueColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' QueueColumnConfiguration, QueueColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' QueueColumnConfiguration, QueueColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..QueueColumnConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfigurationList Members
ININ.IceLib.Configuration Namespace


QueueColumnConfigurationList Members

[image] [image]

IceLib Technical Reference
QueueColumnConfigurationList Members
QueueColumnConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The QueueColumnConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | QueueColumnConfigurationList | Initializes a new instance of the QueueColumnConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

QueueColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


QueueColumnConfigurationList Constructor

[image]

IceLib Technical Reference
QueueColumnConfigurationList Constructor
QueueColumnConfigurationList Class See Also Send Feedback
Initializes a new instance of the QueueColumnConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueColumnConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueColumnConfigurationList Class
QueueColumnConfigurationList Members
ININ.IceLib.Configuration Namespace


QueueColumnConfigurationList Methods

[image] [image]

IceLib Technical Reference
QueueColumnConfigurationList Methods
QueueColumnConfigurationList Class See Also Send Feedback

The QueueColumnConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueueColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


QueueColumnConfigurationList Properties

[image] [image]

IceLib Technical Reference
QueueColumnConfigurationList Properties
QueueColumnConfigurationList Class See Also Send Feedback

The QueueColumnConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

QueueColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


QueueColumnConfigurationList Events

[image] [image]

IceLib Technical Reference
QueueColumnConfigurationList Events
QueueColumnConfigurationList Class See Also Send Feedback

The QueueColumnConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

QueueColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration Class

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Recording Beep Tone. A Beep Tone is a set of attributes that can be assigned to a workgroup.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecordingBeepToneConfiguration : EditableListConfigurationObject<RecordingBeepToneConfiguration..::..Property>
Visual Basic
Public Class RecordingBeepToneConfiguration _
    Inherits EditableListConfigurationObject(Of RecordingBeepToneConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' RecordingBeepToneConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..RecordingBeepToneConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration Members

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfiguration Members
RecordingBeepToneConfiguration Class Methods Properties See Also Send Feedback

The RecordingBeepToneConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | ToneAmplitudeOne | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneAmplitudeTwo | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneDuration | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneFrequencyOne | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneFrequencyTwo | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneInterval | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

See Also

RecordingBeepToneConfiguration Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration Methods

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfiguration Methods
RecordingBeepToneConfiguration Class See Also Send Feedback

The RecordingBeepToneConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

RecordingBeepToneConfiguration Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration Properties

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfiguration Properties
RecordingBeepToneConfiguration Class See Also Send Feedback

The RecordingBeepToneConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | ToneAmplitudeOne | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneAmplitudeTwo | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneDuration | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneFrequencyOne | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneFrequencyTwo | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | ToneInterval | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

See Also

RecordingBeepToneConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..PropertiesChanged Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RecordingBeepToneConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of RecordingBeepToneConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..StandardProperties Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


ToneAmplitudeOne Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..ToneAmplitudeOne Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecordingBeepToneConfiguration..::..Property, ConfigurationId> ToneAmplitudeOne { get; }
Visual Basic
Public ReadOnly Property ToneAmplitudeOne As GeneralConfigurationProperty(Of RecordingBeepToneConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


ToneAmplitudeTwo Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..ToneAmplitudeTwo Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecordingBeepToneConfiguration..::..Property, ConfigurationId> ToneAmplitudeTwo { get; }
Visual Basic
Public ReadOnly Property ToneAmplitudeTwo As GeneralConfigurationProperty(Of RecordingBeepToneConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


ToneDuration Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..ToneDuration Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecordingBeepToneConfiguration..::..Property, ConfigurationId> ToneDuration { get; }
Visual Basic
Public ReadOnly Property ToneDuration As GeneralConfigurationProperty(Of RecordingBeepToneConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


ToneFrequencyOne Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..ToneFrequencyOne Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecordingBeepToneConfiguration..::..Property, ConfigurationId> ToneFrequencyOne { get; }
Visual Basic
Public ReadOnly Property ToneFrequencyOne As GeneralConfigurationProperty(Of RecordingBeepToneConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


ToneFrequencyTwo Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..ToneFrequencyTwo Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecordingBeepToneConfiguration..::..Property, ConfigurationId> ToneFrequencyTwo { get; }
Visual Basic
Public ReadOnly Property ToneFrequencyTwo As GeneralConfigurationProperty(Of RecordingBeepToneConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


ToneInterval Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..ToneInterval Property
RecordingBeepToneConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecordingBeepToneConfiguration..::..Property, ConfigurationId> ToneInterval { get; }
Visual Basic
Public ReadOnly Property ToneInterval As GeneralConfigurationProperty(Of RecordingBeepToneConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration Class
RecordingBeepToneConfiguration Members
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration.Property Enumeration

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..Property Enumeration
RecordingBeepToneConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
ToneFrequencyOne | 0 | Represents the ToneFrequencyOne property.
ToneFrequencyTwo | 1 | Represents the ToneFrequencyTwo property.
ToneAmplitudeOne | 2 | Represents the ToneAmplitudeOne property.
ToneAmplitudeTwo | 3 | Represents the ToneAmplitudeTwo property.
ToneDuration | 4 | Represents the ToneDuration property.
ToneInterval | 5 | Represents the ToneInterval property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration.Rights Class

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..Rights Class
RecordingBeepToneConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..RecordingBeepToneConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..Rights Members
RecordingBeepToneConfiguration..::..Rights Class Properties See Also Send Feedback

The RecordingBeepToneConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

RecordingBeepToneConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..Rights Properties
RecordingBeepToneConfiguration..::..Rights Class See Also Send Feedback

The RecordingBeepToneConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

RecordingBeepToneConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..Rights..::..Admin Property
RecordingBeepToneConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecordingBeepToneConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of RecordingBeepToneConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration..::..Rights Class
RecordingBeepToneConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Roles


View Property

[image]

IceLib Technical Reference
RecordingBeepToneConfiguration..::..Rights..::..View Property
RecordingBeepToneConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecordingBeepToneConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of RecordingBeepToneConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfiguration..::..Rights Class
RecordingBeepToneConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfigurationList Class

[image]

IceLib Technical Reference
RecordingBeepToneConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing recording beep tone configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecordingBeepToneConfigurationList : EditableConfigurationList<RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property>
Visual Basic
Public Class RecordingBeepToneConfigurationList _
    Inherits EditableConfigurationList(Of RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' RecordingBeepToneConfiguration, RecordingBeepToneConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..RecordingBeepToneConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfigurationList Members
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfigurationList Members

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfigurationList Members
RecordingBeepToneConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The RecordingBeepToneConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | RecordingBeepToneConfigurationList | Initializes a new instance of the RecordingBeepToneConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecordingBeepToneConfigurationList Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfigurationList Constructor

[image]

IceLib Technical Reference
RecordingBeepToneConfigurationList Constructor
RecordingBeepToneConfigurationList Class See Also Send Feedback
Initializes a new instance of the RecordingBeepToneConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecordingBeepToneConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecordingBeepToneConfigurationList Class
RecordingBeepToneConfigurationList Members
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfigurationList Methods

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfigurationList Methods
RecordingBeepToneConfigurationList Class See Also Send Feedback

The RecordingBeepToneConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordingBeepToneConfigurationList Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfigurationList Properties

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfigurationList Properties
RecordingBeepToneConfigurationList Class See Also Send Feedback

The RecordingBeepToneConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecordingBeepToneConfigurationList Class
ININ.IceLib.Configuration Namespace


RecordingBeepToneConfigurationList Events

[image] [image]

IceLib Technical Reference
RecordingBeepToneConfigurationList Events
RecordingBeepToneConfigurationList Class See Also Send Feedback

The RecordingBeepToneConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecordingBeepToneConfigurationList Class
ININ.IceLib.Configuration Namespace


ReportLogConfiguration Class

[image]

IceLib Technical Reference
ReportLogConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Report Log. Report logs are predefined and do not require customization or configuration by default, and define a log's location.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportLogConfiguration : ListConfigurationObject
Visual Basic
Public Class ReportLogConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..ReportLogConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfiguration Members
ININ.IceLib.Configuration Namespace


ReportLogConfiguration Members

[image] [image]

IceLib Technical Reference
ReportLogConfiguration Members
ReportLogConfiguration Class Methods Properties See Also Send Feedback

The ReportLogConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ReportLogConfiguration Class
ININ.IceLib.Configuration Namespace


ReportLogConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportLogConfiguration Methods
ReportLogConfiguration Class See Also Send Feedback

The ReportLogConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportLogConfiguration Class
ININ.IceLib.Configuration Namespace


ReportLogConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportLogConfiguration Properties
ReportLogConfiguration Class See Also Send Feedback

The ReportLogConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ReportLogConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ReportLogConfiguration..::..StandardProperties Property
ReportLogConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ReportLogConfiguration, ReportLogConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ReportLogConfiguration, ReportLogConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfiguration Class
ReportLogConfiguration Members
ININ.IceLib.Configuration Namespace


ReportLogConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportLogConfiguration..::..Property Enumeration
ReportLogConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ReportLogConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportLogConfiguration..::..Rights Class
ReportLogConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ReportLogConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ReportLogConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportLogConfiguration..::..Rights Members
ReportLogConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportLogConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportLogConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ReportLogConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportLogConfiguration..::..Rights Properties
ReportLogConfiguration..::..Rights Class See Also Send Feedback

The ReportLogConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportLogConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ReportLogConfiguration..::..Rights..::..Admin Property
ReportLogConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportLogConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportLogConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfiguration..::..Rights Class
ReportLogConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ReportLogs


View Property

[image]

IceLib Technical Reference
ReportLogConfiguration..::..Rights..::..View Property
ReportLogConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportLogConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportLogConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfiguration..::..Rights Class
ReportLogConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ReportLogConfigurationList Class

[image]

IceLib Technical Reference
ReportLogConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ReportLog configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportLogConfigurationList : DynamicConfigurationList<ReportLogConfiguration, ReportLogConfiguration..::..Property>
Visual Basic
Public Class ReportLogConfigurationList _
    Inherits DynamicConfigurationList(Of ReportLogConfiguration, ReportLogConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportLogConfiguration, ReportLogConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportLogConfiguration, ReportLogConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ReportLogConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfigurationList Members
ININ.IceLib.Configuration Namespace


ReportLogConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportLogConfigurationList Members
ReportLogConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportLogConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportLogConfigurationList | Initializes a new instance of the ReportLogConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportLogConfigurationList Class
ININ.IceLib.Configuration Namespace


ReportLogConfigurationList Constructor

[image]

IceLib Technical Reference
ReportLogConfigurationList Constructor
ReportLogConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportLogConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportLogConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportLogConfigurationList Class
ReportLogConfigurationList Members
ININ.IceLib.Configuration Namespace


ReportLogConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportLogConfigurationList Methods
ReportLogConfigurationList Class See Also Send Feedback

The ReportLogConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportLogConfigurationList Class
ININ.IceLib.Configuration Namespace


ReportLogConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportLogConfigurationList Properties
ReportLogConfigurationList Class See Also Send Feedback

The ReportLogConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportLogConfigurationList Class
ININ.IceLib.Configuration Namespace


ReportLogConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportLogConfigurationList Events
ReportLogConfigurationList Class See Also Send Feedback

The ReportLogConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportLogConfigurationList Class
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration Class

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Response Management Document. A response management document is a pre-defined response, such as a message, URL, or file.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManagementDocumentConfiguration : EditableListConfigurationObject<ResponseManagementDocumentConfiguration..::..Property>
Visual Basic
Public Class ResponseManagementDocumentConfiguration _
    Inherits EditableListConfigurationObject(Of ResponseManagementDocumentConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ResponseManagementDocumentConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ResponseManagementDocumentConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration Members

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration Members
ResponseManagementDocumentConfiguration Class Methods Properties See Also Send Feedback

The ResponseManagementDocumentConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DownloadDocument | Downloads an existing response management document from the IC server.
Public method | DownloadDocumentAsync | Asynchronously downloads an existing response management document from the IC server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId(String).)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDocument | Sets the document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the description (use Property.Description).
Public property | Document | Gets the document.
Public property | DocumentDateLastModified | Provides read-only access to the property representing the date the document was last modified (use Property.DocumentDateLastModified).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ResponseManagementDocumentConfiguration Class
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration Methods

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration Methods
ResponseManagementDocumentConfiguration Class See Also Send Feedback

The ResponseManagementDocumentConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DownloadDocument | Downloads an existing response management document from the IC server.
Public method | DownloadDocumentAsync | Asynchronously downloads an existing response management document from the IC server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..SetConfigurationId(String).)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDocument | Sets the document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ResponseManagementDocumentConfiguration Class
ININ.IceLib.Configuration Namespace


DownloadDocument Method

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..DownloadDocument Method
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Downloads an existing response management document from the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadDocument()
Visual Basic
Public Sub DownloadDocument

Remarks

When complete, the Document property will contain the response managment document details.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The response management document is new and does not exist on the IC server yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


DownloadDocumentAsync Method

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..DownloadDocumentAsync Method
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Asynchronously downloads an existing response management document from the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadDocumentAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub DownloadDocumentAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When complete, the Document property will contain the response managment document details.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The response management document is new and does not exist on the IC server yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


SetConfigurationId Method

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..SetConfigurationId Method
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Sets the unique identifier used to reference this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void SetConfigurationId(
    string id
)
Visual Basic
Public Overrides Sub SetConfigurationId ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The configuration object is not newly created or already had Commit()()()() called.
System..::..ArgumentException | The id contains invalid file characters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


SetDocument Method

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..SetDocument Method
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Sets the document.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDocument(
    ResponseManagementDocument document
)
Visual Basic
Public Sub SetDocument ( _
    document As ResponseManagementDocument _
)

Parameters

document
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocument
The response management document.

Remarks

PrepareForEdit()()()() must be called prior to calling this. ResponseManagementDocument objects can be created from raw xml via calls to ReadFromXml(String) or CreateNewFromXml(String, String).

Exceptions

Exception | Condition
System..::..ArgumentNullException | document is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration Properties

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration Properties
ResponseManagementDocumentConfiguration Class See Also Send Feedback

The ResponseManagementDocumentConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the description (use Property.Description).
Public property | Document | Gets the document.
Public property | DocumentDateLastModified | Provides read-only access to the property representing the date the document was last modified (use Property.DocumentDateLastModified).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ResponseManagementDocumentConfiguration Class
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Description Property
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Provides access to the property representing the description (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ResponseManagementDocumentConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ResponseManagementDocumentConfiguration..::..Property, String)
    Get

Field Value

The property representing the description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


Document Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Document Property
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Gets the document.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementDocument Document { get; }
Visual Basic
Public ReadOnly Property Document As ResponseManagementDocument
    Get

Field Value

The document.

Remarks

For an existing configuration object, a call to DownloadDocument()()()() or DownloadDocumentAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) is required prior to accessing the document. If this is a new configuration object, a call to SetConfigurationId(String) must be made prior to accessing the document. When calling Commit()()()() or CommitAsync(AsyncCompletedEventHandler, Object), the response management document will be uploaded to the server if the configuration object is new, or if the document has been modified. Additionally, if editing an existing document, the document must be downloaded prior to calling PrepareForEdit()()()().

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


DocumentDateLastModified Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..DocumentDateLastModified Property
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Provides read-only access to the property representing the date the document was last modified (use Property.DocumentDateLastModified).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ResponseManagementDocumentConfiguration..::..Property, DateTime> DocumentDateLastModified { get; }
Visual Basic
Public ReadOnly Property DocumentDateLastModified As GeneralConfigurationProperty(Of ResponseManagementDocumentConfiguration..::..Property, DateTime)
    Get

Field Value

The property representing the date the document was last modified.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..PropertiesChanged Property
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseManagementDocumentConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ResponseManagementDocumentConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..StandardProperties Property
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentConfiguration Class
ResponseManagementDocumentConfiguration Members
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Property Enumeration
ResponseManagementDocumentConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Description | 0 | Represents the Description property.
DocumentDateLastModified | 1 | Represents the DocumentDateLastModified property.
DisplayName | 2 | Represents the DisplayName part of the ConfigurationId property.
Id | 3 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration.Rights Class

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Rights Class
ResponseManagementDocumentConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ResponseManagementDocumentConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Rights Members
ResponseManagementDocumentConfiguration..::..Rights Class Properties See Also Send Feedback

The ResponseManagementDocumentConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ResponseManagementDocumentConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Rights Properties
ResponseManagementDocumentConfiguration..::..Rights Class See Also Send Feedback

The ResponseManagementDocumentConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ResponseManagementDocumentConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Rights..::..Admin Property
ResponseManagementDocumentConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ResponseManagementDocumentConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ResponseManagementDocumentConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfiguration..::..Rights Class
ResponseManagementDocumentConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ResponseManagement


View Property

[image]

IceLib Technical Reference
ResponseManagementDocumentConfiguration..::..Rights..::..View Property
ResponseManagementDocumentConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ResponseManagementDocumentConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ResponseManagementDocumentConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfiguration..::..Rights Class
ResponseManagementDocumentConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ResponseManagementDocuments


ResponseManagementDocumentConfigurationList Class

[image]

IceLib Technical Reference
ResponseManagementDocumentConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ResponseManagementDocument configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManagementDocumentConfigurationList : EditableConfigurationList<ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property>
Visual Basic
Public Class ResponseManagementDocumentConfigurationList _
    Inherits EditableConfigurationList(Of ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ResponseManagementDocumentConfiguration, ResponseManagementDocumentConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ResponseManagementDocumentConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfigurationList Members
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfigurationList Members

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfigurationList Members
ResponseManagementDocumentConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ResponseManagementDocumentConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseManagementDocumentConfigurationList | Initializes a new instance of the ResponseManagementDocumentConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ResponseManagementDocumentConfigurationList Class
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfigurationList Constructor

[image]

IceLib Technical Reference
ResponseManagementDocumentConfigurationList Constructor
ResponseManagementDocumentConfigurationList Class See Also Send Feedback
Initializes a new instance of the ResponseManagementDocumentConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementDocumentConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ResponseManagementDocumentConfigurationList Class
ResponseManagementDocumentConfigurationList Members
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfigurationList Methods

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfigurationList Methods
ResponseManagementDocumentConfigurationList Class See Also Send Feedback

The ResponseManagementDocumentConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResponseManagementDocumentConfigurationList Class
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfigurationList Properties

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfigurationList Properties
ResponseManagementDocumentConfigurationList Class See Also Send Feedback

The ResponseManagementDocumentConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ResponseManagementDocumentConfigurationList Class
ININ.IceLib.Configuration Namespace


ResponseManagementDocumentConfigurationList Events

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentConfigurationList Events
ResponseManagementDocumentConfigurationList Class See Also Send Feedback

The ResponseManagementDocumentConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ResponseManagementDocumentConfigurationList Class
ININ.IceLib.Configuration Namespace


RightsQueryFilter(TConfigurationObject) Class

[image]

IceLib Technical Reference
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class
Members See Also Send Feedback
Represents an ACL that can be used to filter a query based on rights.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RightsQueryFilter<TConfigurationObject>
Visual Basic
Public Class RightsQueryFilter(Of TConfigurationObject)

Type Parameters

TConfigurationObject
The type of the configuration object this filter applies to.

Remarks

Each configuration object contains list of rights that it can use. For example see UserConfiguration..::..Rights.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..RightsQueryFilter<(Of <(<'TConfigurationObject>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Members
ININ.IceLib.Configuration Namespace


RightsQueryFilter(TConfigurationObject) Members

[image] [image]

IceLib Technical Reference
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Members
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class Methods See Also Send Feedback

The RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class
ININ.IceLib.Configuration Namespace


RightsQueryFilter(TConfigurationObject) Methods

[image] [image]

IceLib Technical Reference
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Methods
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class See Also Send Feedback

The RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)>..::..ToString Method
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Class
RightsQueryFilter<(Of <(<'TConfigurationObject>)>)> Members
ININ.IceLib.Configuration Namespace


RoleConfiguration Class

[image]

IceLib Technical Reference
RoleConfiguration Class
Members Example See Also Send Feedback
Contains configuration and administration settings for an IC role. A role is a set of permissions that can be assigned to a workgroup or user.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RoleConfiguration : EditableListConfigurationObject<RoleConfiguration..::..Property>
Visual Basic
Public Class RoleConfiguration _
    Inherits EditableListConfigurationObject(Of RoleConfiguration..::..Property)

Examples

The IceLib SDK includes example application references to the RoleConfiguration class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 203, in UserRoleConfigurationViewModel.<SessionConnectionStateChanged>b__7
 | UserRoleConfigurationViewModel.CS$<>9__CachedAnonymousMethodDelegate8

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' RoleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..RoleConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfiguration Members
ININ.IceLib.Configuration Namespace


RoleConfiguration Members

[image] [image]

IceLib Technical Reference
RoleConfiguration Members
RoleConfiguration Class Methods Properties See Also Send Feedback

The RoleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified roles.
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified role.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()() or Delete()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | AccessRights | Provides access to the various access control list properties.
Public property | AdministrativeRights | Provides access to the various administrative access control list properties.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClientConfigurationTemplate | Provides access to the property representing the client configuration template for this role (use Property.ClientConfigurationTemplate).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | InteractionMessageStoreMaxMessage | Obsolete. Provides access to the property representing the Interaction Message Store max messages for this role (use Property.InteractionMessageStoreMaxMessage).
Public property | InteractionMessageStoreMaxStorage | Obsolete. Provides access to the property representing the Interaction Message Store max storage for this role (use Property.InteractionMessageStoreMaxStorage).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PasswordPolicies | Provides access to the property representing the password policies for this role (use Property.PasswordPolicies).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | SecurityRights | Provides access to the various security properties.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | TransactionId | Gets the transaction ID.
Public property | Users | Provides access to the property representing the users this role is assigned to (use Property.Users).
Public property | Workgroups | Provides access to the property representing the workgroups this role is assigned to (use Property.Workgroups).

See Also

RoleConfiguration Class
ININ.IceLib.Configuration Namespace


RoleConfiguration Methods

[image] [image]

IceLib Technical Reference
RoleConfiguration Methods
RoleConfiguration Class See Also Send Feedback

The RoleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified roles.
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified role.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()() or Delete()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

RoleConfiguration Class
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method

[image] [image]

IceLib Technical Reference
RoleConfiguration..::..PublishClientTemplate Method
RoleConfiguration Class See Also Send Feedback

Overload List

Name | Description
PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified roles.
PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified role.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method (ConfigurationManager, ConfigurationId, IEnumerable(String), String)

[image]

IceLib Technical Reference
RoleConfiguration..::..PublishClientTemplate Method (ConfigurationManager, ConfigurationId, IEnumerable<(Of <(<'String>)>)>, String)
RoleConfiguration Class See Also Send Feedback
Publishes the client template to the specified roles.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ClientTemplatePublishResult> PublishClientTemplate(
    ConfigurationManager configurationManager,
    ConfigurationId clientTemplateId,
    IEnumerable<string> roleIds,
    string applicationId
)
Visual Basic
Public Shared Function PublishClientTemplate ( _
    configurationManager As ConfigurationManager, _
    clientTemplateId As ConfigurationId, _
    roleIds As IEnumerable(Of String), _
    applicationId As String _
) As ReadOnlyCollection(Of ClientTemplatePublishResult)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
clientTemplateId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The client template ID.
roleIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The role IDs.
applicationId
Type: System..::..String
The application ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ClientTemplatePublishResult objects with the results of the publish operation.

Remarks

Valid clientTemplateId values can be retrieved from the ConfigurationId property of ClientTemplateConfiguration. The roleIds values can be retrieved from the Id portion of RoleConfiguration The applicationId can be retrieved from the ApplicationName portion of the return value from GetSessionSettings()()()(). In order to publish client templates, the logged on user must have the CanPublishClientTemplates right.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | On of the roleIds, or applicationId is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
PublishClientTemplate Overload
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method (ConfigurationManager, ConfigurationId, String, String)

[image]

IceLib Technical Reference
RoleConfiguration..::..PublishClientTemplate Method (ConfigurationManager, ConfigurationId, String, String)
RoleConfiguration Class See Also Send Feedback
Publishes the client template to the specified role.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ClientTemplatePublishResult> PublishClientTemplate(
    ConfigurationManager configurationManager,
    ConfigurationId clientTemplateId,
    string roleId,
    string applicationId
)
Visual Basic
Public Shared Function PublishClientTemplate ( _
    configurationManager As ConfigurationManager, _
    clientTemplateId As ConfigurationId, _
    roleId As String, _
    applicationId As String _
) As ReadOnlyCollection(Of ClientTemplatePublishResult)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
clientTemplateId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The client template ID.
roleId
Type: System..::..String
The role ID.
applicationId
Type: System..::..String
The application ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ClientTemplatePublishResult objects with the results of the publish operation.

Remarks

Valid clientTemplateId values can be retrieved from the ConfigurationId property of ClientTemplateConfiguration. The role value can be retrieved from the Id portion of RoleConfiguration The applicationId can be retrieved from the ApplicationName portion of the return value from GetSessionSettings()()()(). In order to publish client templates, the logged on user must have the CanPublishClientTemplates right.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | roleId, or applicationId is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
PublishClientTemplate Overload
ININ.IceLib.Configuration Namespace


SetTransactionId Method

[image]

IceLib Technical Reference
RoleConfiguration..::..SetTransactionId Method
RoleConfiguration Class See Also Send Feedback
Sets the transaction ID to use when calling Commit()()()() or Delete()()()().

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTransactionId(
    int transactionId
)
Visual Basic
Public Sub SetTransactionId ( _
    transactionId As Integer _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.

Remarks

Valid values can be obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained. Setting this value to NoTransactionId will clear the transaction ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | transactionId is less than zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


RoleConfiguration Properties

[image] [image]

IceLib Technical Reference
RoleConfiguration Properties
RoleConfiguration Class See Also Send Feedback

The RoleConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).
Public property | AccessRights | Provides access to the various access control list properties.
Public property | AdministrativeRights | Provides access to the various administrative access control list properties.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClientConfigurationTemplate | Provides access to the property representing the client configuration template for this role (use Property.ClientConfigurationTemplate).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | InteractionMessageStoreMaxMessage | Obsolete. Provides access to the property representing the Interaction Message Store max messages for this role (use Property.InteractionMessageStoreMaxMessage).
Public property | InteractionMessageStoreMaxStorage | Obsolete. Provides access to the property representing the Interaction Message Store max storage for this role (use Property.InteractionMessageStoreMaxStorage).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PasswordPolicies | Provides access to the property representing the password policies for this role (use Property.PasswordPolicies).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | SecurityRights | Provides access to the various security properties.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | TransactionId | Gets the transaction ID.
Public property | Users | Provides access to the property representing the users this role is assigned to (use Property.Users).
Public property | Workgroups | Provides access to the property representing the workgroups this role is assigned to (use Property.Workgroups).

See Also

RoleConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
RoleConfiguration..::..AccessControlGroupAssignment Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this role (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RoleConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of RoleConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


AccessRights Property

[image]

IceLib Technical Reference
RoleConfiguration..::..AccessRights Property
RoleConfiguration Class See Also Send Feedback
Provides access to the various access control list properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAccessRightsProperties<RoleConfiguration, RoleConfiguration..::..Property> AccessRights { get; }
Visual Basic
Public ReadOnly Property AccessRights As UserAccessRightsProperties(Of RoleConfiguration, RoleConfiguration..::..Property)
    Get

Field Value

The role access control rights properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


AdministrativeRights Property

[image]

IceLib Technical Reference
RoleConfiguration..::..AdministrativeRights Property
RoleConfiguration Class See Also Send Feedback
Provides access to the various administrative access control list properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAdministrativeRightsProperties<RoleConfiguration, RoleConfiguration..::..Property> AdministrativeRights { get; }
Visual Basic
Public ReadOnly Property AdministrativeRights As UserAdministrativeRightsProperties(Of RoleConfiguration, RoleConfiguration..::..Property)
    Get

Field Value

The role access administrative access control properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplate Property

[image]

IceLib Technical Reference
RoleConfiguration..::..ClientConfigurationTemplate Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing the client configuration template for this role (use Property.ClientConfigurationTemplate).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RoleConfiguration..::..Property, ConfigurationId> ClientConfigurationTemplate { get; }
Visual Basic
Public ReadOnly Property ClientConfigurationTemplate As GeneralConfigurationProperty(Of RoleConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the client configuration template.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionMessageStoreMaxMessage Property

[image]

IceLib Technical Reference
RoleConfiguration..::..InteractionMessageStoreMaxMessage Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing the Interaction Message Store max messages for this role (use Property.InteractionMessageStoreMaxMessage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessageStoreMaxMessage is no longer available.")]
public InheritableConfigurationProperty<RoleConfiguration..::..Property, int> InteractionMessageStoreMaxMessage { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessageStoreMaxMessage is no longer available.")> _
Public ReadOnly Property InteractionMessageStoreMaxMessage As InheritableConfigurationProperty(Of RoleConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Interaction Message Store max message.

Remarks

Note
-1 = "No Limit"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionMessageStoreMaxStorage Property

[image]

IceLib Technical Reference
RoleConfiguration..::..InteractionMessageStoreMaxStorage Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing the Interaction Message Store max storage for this role (use Property.InteractionMessageStoreMaxStorage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessageStoreMaxStorage is no longer available.")]
public InheritableConfigurationProperty<RoleConfiguration..::..Property, int> InteractionMessageStoreMaxStorage { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessageStoreMaxStorage is no longer available.")> _
Public ReadOnly Property InteractionMessageStoreMaxStorage As InheritableConfigurationProperty(Of RoleConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Interaction Message Store max storage.

Remarks

Note
-1 = "No Limit"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


PasswordPolicies Property

[image]

IceLib Technical Reference
RoleConfiguration..::..PasswordPolicies Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing the password policies for this role (use Property.PasswordPolicies).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RoleConfiguration..::..Property, Collection<ConfigurationId>> PasswordPolicies { get; }
Visual Basic
Public ReadOnly Property PasswordPolicies As GeneralConfigurationProperty(Of RoleConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the password policies.

Remarks

A password policy is a rules describing how users must change their password. When a password policy is added to a Role, the Role takes on those permissions. If a User is a member of that Role, the User automatically inherits the password policies assigned to the Role.
  • Owned - To assign or remove a password policy on this Role, modify the Value of this property. One or more password policies must already be defined to add a password policy in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..PasswordPolicyConfiguration
ININ.IceLib.Configuration..::..PasswordPolicyConfigurationList


PropertiesChanged Property

[image]

IceLib Technical Reference
RoleConfiguration..::..PropertiesChanged Property
RoleConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RoleConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of RoleConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


SecurityRights Property

[image]

IceLib Technical Reference
RoleConfiguration..::..SecurityRights Property
RoleConfiguration Class See Also Send Feedback
Provides access to the various security properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserSecurityRightsProperties<RoleConfiguration, RoleConfiguration..::..Property> SecurityRights { get; }
Visual Basic
Public ReadOnly Property SecurityRights As UserSecurityRightsProperties(Of RoleConfiguration, RoleConfiguration..::..Property)
    Get

Field Value

The role security rights properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
RoleConfiguration..::..StandardProperties Property
RoleConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<RoleConfiguration, RoleConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of RoleConfiguration, RoleConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


TransactionId Property

[image]

IceLib Technical Reference
RoleConfiguration..::..TransactionId Property
RoleConfiguration Class See Also Send Feedback
Gets the transaction ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TransactionId { get; }
Visual Basic
Public ReadOnly Property TransactionId As Integer
    Get

Remarks

Valid values are obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). Commit()()()() and Delete()()()() operations called on configuration objects that have a valid transaction ID set will cause notifications for watched UserConfiguration objects that would be affected to be suspended until a call to EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is made with the associated transaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


Users Property

[image]

IceLib Technical Reference
RoleConfiguration..::..Users Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing the users this role is assigned to (use Property.Users).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RoleConfiguration..::..Property, Collection<ConfigurationId>> Users { get; }
Visual Basic
Public ReadOnly Property Users As GeneralConfigurationProperty(Of RoleConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the users.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


Workgroups Property

[image]

IceLib Technical Reference
RoleConfiguration..::..Workgroups Property
RoleConfiguration Class See Also Send Feedback
Provides access to the property representing the workgroups this role is assigned to (use Property.Workgroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RoleConfiguration..::..Property, Collection<ConfigurationId>> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As GeneralConfigurationProperty(Of RoleConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration Class
RoleConfiguration Members
ININ.IceLib.Configuration Namespace


RoleConfiguration.Property Enumeration

[image]

IceLib Technical Reference
RoleConfiguration..::..Property Enumeration
RoleConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
ClientConfigurationTemplate | 1 | Represents the ClientConfigurationTemplate property.
InteractionMessageStoreMaxMessage | 2 | Obsolete. Represents the InteractionMessageStoreMaxMessage property.
InteractionMessageStoreMaxStorage | 3 | Obsolete. Represents the InteractionMessageStoreMaxStorage property.
PasswordPolicies | 4 | Represents the PasswordPolicies property.
Users | 5 | Represents the Users property.
Workgroups | 6 | Represents the Workgroups property.
AccessRights_ActivateOthers | 1500 | Represents the ActivateOthers property.
AccessRights_ActivateSelf | 1501 | Represents the ActivateSelf property.
AccessRights_CanEditAccessRights | 1502 | Represents the CanEditAccessRights property.
AccessRights_ChangeUserStatus | 1503 | Represents the ChangeUserStatus property.
AccessRights_ClientButtons | 1504 | Represents the ClientButtons property.
AccessRights_CoachLineQueue | 1505 | Represents the CoachLineQueue property.
AccessRights_CoachStationQueue | 1506 | Represents the CoachStationQueue property.
AccessRights_CoachUserQueue | 1507 | Represents the CoachUserQueue property.
AccessRights_CoachWorkgroupQueue | 1508 | Represents the CoachWorkgroupQueue property.
AccessRights_CreateSchedulingUnitTimeoffRequests | 1509 | Represents the CreateSchedulingUnitTimeoffRequests property.
AccessRights_DeleteSchedulingUnitTimeoffRequests | 1510 | Represents the DeleteSchedulingUnitTimeoffRequests property.
AccessRights_DisconnectUserQueue | 1511 | Represents the DisconnectUserQueue property.
AccessRights_DisconnectLineQueue | 1512 | Represents the DisconnectLineQueue property.
AccessRights_DisconnectStationQueue | 1513 | Represents the DisconnectStationQueue property.
AccessRights_DisconnectWorkgroupQueue | 1514 | Represents the DisconnectWorkgroupQueue property.
AccessRights_EFaqs | 1515 | Represents the EFaqs property.
AccessRights_FollowMePhoneNumberClassifications | 1516 | Represents the FollowMePhoneNumberClassifications property.
AccessRights_ForwardPhoneNumberClassifications | 1517 | Represents the ForwardPhoneNumberClassifications property.
AccessRights_ViewHistoricalReports | 1518 | Represents the ViewHistoricalReports property.
AccessRights_HoldStationQueue | 1519 | Represents the HoldStationQueue property.
AccessRights_HoldUserQueue | 1520 | Represents the HoldUserQueue property.
AccessRights_InteractionConferenceRestrictRooms | 1521 | Represents the InteractionConferenceRestrictRooms property.
AccessRights_JoinLineQueue | 1522 | Represents the JoinLineQueue property.
AccessRights_JoinStationQueue | 1523 | Represents the JoinStationQueue property.
AccessRights_JoinUserQueue | 1524 | Represents the JoinUserQueue property.
AccessRights_JoinWorkgroupQueue | 1525 | Represents the JoinWorkgroupQueue property.
AccessRights_LaunchableProcessList | 1526 | Represents the LaunchableProcessList property.
AccessRights_ListAccountCodes | 1527 | Represents the ListAccountCodes property.
AccessRights_ListenLineQueue | 1528 | Represents the ListenLineQueue property.
AccessRights_ListenStationQueue | 1529 | Represents the ListenStationQueue property.
AccessRights_ListenUserQueue | 1530 | Represents the ListenUserQueue property.
AccessRights_ListenWorkgroupQueue | 1531 | Represents the ListenWorkgroupQueue property.
AccessRights_LoginStation | 1532 | Represents the LoginStation property.
AccessRights_ManageProcessList | 1533 | Represents the ManageProcessList property.
AccessRights_Miscellaneous | 1534 | Represents the Miscellaneous property.
AccessRights_ModifyAttendantEmailProfiles | 1535 | Represents the ModifyAttendantEmailProfiles property.
AccessRights_ModifyAttendantInboundProfiles | 1536 | Represents the ModifyAttendantInboundProfiles property.
AccessRights_ModifyAttendantOperatorProfiles | 1537 | Represents the ModifyAttendantOperatorProfiles property.
AccessRights_ModifyAttendantOutboundProfiles | 1538 | Represents the ModifyAttendantOutboundProfiles property.
AccessRights_ModifyFeedbackSurveys | 1539 | Represents the ModifyFeedbackSurveys property.
AccessRights_ModifyRecorderQuestionnaires | 1540 | Represents the ModifyRecorderQuestionnaires property.
AccessRights_MuteStationQueue | 1541 | Represents the MuteStationQueue property.
AccessRights_MuteUserQueue | 1542 | Represents the MuteUserQueue property.
AccessRights_ModifyCampaignsAgentlessCallingMode | 1543 | Obsolete. Represents the ModifyCampaignsAgentlessCallingMode property.
AccessRights_ModifyCampaignsAutomaticTimezoneMapping | 1544 | Obsolete. Represents the ModifyCampaignsAutomaticTimezoneMapping property.
AccessRights_ModifyCampaignsLineSettings | 1545 | Obsolete. Represents the ModifyCampaignsLineSettings property.
AccessRights_ModifyCampaignList | 1546 | Represents the ModifyCampaignList property.
AccessRights_ModifyCampaignsMaxLinesPerCampaign | 1547 | Obsolete. Represents the ModifyCampaignsMaxLinesPerCampaign property.
AccessRights_ModifyCampaignStatus | 1548 | Obsolete. Represents the ModifyCampaignStatus property.
AccessRights_ModifyPolicySetsBehaviorTypeCustomHandler | 1549 | Obsolete. Represents the ModifyPolicySetsBehaviorTypeCustomHandler property.
AccessRights_ModifyPolicySetsBehaviorTypeEventLog | 1550 | Obsolete. Represents the ModifyPolicySetsBehaviorTypeEventLog property.
AccessRights_ModifySchedulingUnitTimeoffRequests | 1551 | Represents the ModifySchedulingUnitTimeoffRequests property.
AccessRights_ModifyRuleSetsCustomHandler | 1552 | Obsolete. Represents the ModifyRuleSetsCustomHandler property.
AccessRights_ModifyRuleSetsEventLog | 1553 | Obsolete. Represents the ModifyRuleSetsEventLog property.
AccessRights_PhoneNumberClassifications | 1554 | Represents the PhoneNumberClassifications property.
AccessRights_PickupLineQueue | 1555 | Represents the PickupLineQueue property.
AccessRights_PickupStationQueue | 1556 | Represents the PickupStationQueue property.
AccessRights_PickupUserQueue | 1557 | Represents the PickupUserQueue property.
AccessRights_PickupWorkgroupQueue | 1558 | Represents the PickupWorkgroupQueue property.
AccessRights_PreviewEmailUserQueue | 1559 | Represents the PreviewEmailUserQueue property.
AccessRights_PreviewEmailWorkgroupQueue | 1560 | Represents the PreviewEmailWorkgroupQueue property.
AccessRights_InteractionClientPlugins | 1561 | Represents the InteractionClientPlugins property.
AccessRights_RecordLineQueue | 1562 | Represents the RecordLineQueue property.
AccessRights_RecordStationQueue | 1563 | Represents the RecordStationQueue property.
AccessRights_RecordUserQueue | 1564 | Represents the RecordUserQueue property.
AccessRights_RecordWorkgroupQueue | 1565 | Represents the RecordWorkgroupQueue property.
AccessRights_ResponseManagementDocuments | 1566 | Represents the ResponseManagementDocuments property.
AccessRights_StatusMessages | 1567 | Represents the StatusMessages property.
AccessRights_SubstituteQueueControlColumns | 1568 | Represents the SubstituteQueueControlColumns property.
AccessRights_TransferLineQueue | 1569 | Represents the TransferLineQueue property.
AccessRights_TransferStationQueue | 1570 | Represents the TransferStationQueue property.
AccessRights_TransferUserQueue | 1571 | Represents the TransferUserQueue property.
AccessRights_TransferWorkgroupQueue | 1572 | Represents the TransferWorkgroupQueue property.
AccessRights_TuiPhoneNumberClassifications | 1573 | Represents the TuiPhoneNumberClassifications property.
AccessRights_ViewAttendantEmailProfileInSearch | 1574 | Represents the ViewAttendantEmailProfileInSearch property.
AccessRights_ViewAttendantEmailProfiles | 1575 | Represents the ViewAttendantEmailProfiles property.
AccessRights_ViewAttendantInboundProfileInSearch | 1576 | Represents the ViewAttendantInboundProfileInSearch property.
AccessRights_ViewAttendantInboundProfiles | 1577 | Represents the ViewAttendantInboundProfiles property.
AccessRights_ViewAttendantOperatorProfileInSearch | 1578 | Represents the ViewAttendantOperatorProfileInSearch property.
AccessRights_ViewAttendantOperatorProfiles | 1579 | Represents the ViewAttendantOperatorProfiles property.
AccessRights_ViewAttendantOutboundProfileInSearch | 1580 | Represents the ViewAttendantOutboundProfileInSearch property.
AccessRights_ViewAttendantOutboundProfiles | 1581 | Represents the ViewAttendantOutboundProfiles property.
AccessRights_ViewFeedbackSurveys | 1582 | Represents the ViewFeedbackSurveys property.
AccessRights_ViewCampaignsAgentlessCallingMode | 1583 | Obsolete. Represents the ViewCampaignsAgentlessCallingMode property.
AccessRights_ViewCampaignsAutomaticTimezoneMapping | 1584 | Obsolete. Represents the ViewCampaignsAutomaticTimezoneMapping property.
AccessRights_ViewCampaignsLineSettings | 1585 | Obsolete. Represents the ViewCampaignsLineSettings property.
AccessRights_ViewCampaignList | 1586 | Represents the ViewCampaignList property.
AccessRights_ViewCampaignsMaxLinesPerCampaign | 1587 | Obsolete. Represents the ViewCampaignsMaxLinesPerCampaign property.
AccessRights_ViewCampaignStatus | 1588 | Obsolete. Represents the ViewCampaignStatus property.
AccessRights_ViewGeneralDirectories | 1589 | Represents the ViewGeneralDirectories property.
AccessRights_ViewIndividualStatistics | 1590 | Represents the ViewIndividualStatistics property.
AccessRights_ViewLayoutList | 1591 | Represents the ViewLayoutList property.
AccessRights_ViewLineQueue | 1592 | Represents the ViewLineQueue property.
AccessRights_ViewModifyOptimizerAll | 1593 | Represents the ViewModifyOptimizerAll property.
AccessRights_ViewOptimizerSchedulingUnits | 1594 | Obsolete. Represents the ViewOptimizerSchedulingUnits property.
AccessRights_ViewOptimizerForecasts | 1595 | Represents the ViewOptimizerForecasts property.
AccessRights_ModifyOptimizerForecasts | 1596 | Represents the ModifyOptimizerForecasts property.
AccessRights_CreateOptimizerForecasts | 1597 | Represents the CreateOptimizerForecasts property.
AccessRights_DeleteOptimizerForecasts | 1598 | Represents the DeleteOptimizerForecasts property.
AccessRights_ViewPolicySetsBehaviorTypeCustomHandler | 1599 | Obsolete. Represents the ViewPolicySetsBehaviorTypeCustomHandler property.
AccessRights_ViewPolicySetsBehaviorTypeEventLog | 1600 | Obsolete. Represents the ViewPolicySetsBehaviorTypeEventLog property.
AccessRights_ViewPositionsList | 1601 | Represents the ViewPositionsList property.
AccessRights_ViewSchedulingUnitIntradayMonitoring | 1602 | Represents the ViewSchedulingUnitIntradayMonitoring property.
AccessRights_ViewSchedulingUnitSchedulePreferences | 1603 | Represents the ViewSchedulingUnitSchedulePreferences property.
AccessRights_ViewSchedulingUnitListRealTimeAdherence | 1604 | Represents the ViewSchedulingUnitListRealTimeAdherence property.
AccessRights_ViewSchedulingUnitTimeoffRequests | 1605 | Represents the ViewSchedulingUnitTimeoffRequests property.
AccessRights_ModifySchedulingUnitListRealTimeAdherence | 1606 | Represents the ModifySchedulingUnitListRealTimeAdherence property.
AccessRights_ViewSchedulingUnitConfiguration | 1607 | Represents the ViewSchedulingUnitConfiguration property.
AccessRights_ModifySchedulingUnitConfiguration | 1608 | Represents the ModifySchedulingUnitConfiguration property.
AccessRights_ViewSchedulingUnitAgentConstraints | 1609 | Represents the ViewSchedulingUnitAgentConstraints property.
AccessRights_ModifySchedulingUnitAgentConstraints | 1610 | Represents the ModifySchedulingUnitAgentConstraints property.
AccessRights_CreateSchedulingUnitAgentConstraints | 1611 | Represents the CreateSchedulingUnitAgentConstraints property.
AccessRights_DeleteSchedulingUnitAgentConstraints | 1612 | Represents the DeleteSchedulingUnitAgentConstraints property.
AccessRights_ViewSchedulingUnitAgentGroups | 1613 | Represents the ViewSchedulingUnitAgentGroups property.
AccessRights_ModifySchedulingUnitAgentGroups | 1614 | Represents the ModifySchedulingUnitAgentGroups property.
AccessRights_CreateSchedulingUnitAgentGroups | 1615 | Represents the CreateSchedulingUnitAgentGroups property.
AccessRights_DeleteSchedulingUnitAgentGroups | 1616 | Represents the DeleteSchedulingUnitAgentGroups property.
AccessRights_ViewSchedulingUnitSchedules | 1617 | Represents the ViewSchedulingUnitSchedules property.
AccessRights_ModifySchedulingUnitSchedules | 1618 | Represents the ModifySchedulingUnitSchedules property.
AccessRights_CreateSchedulingUnitSchedules | 1619 | Represents the CreateSchedulingUnitSchedules property.
AccessRights_DeleteSchedulingUnitSchedules | 1620 | Represents the DeleteSchedulingUnitSchedules property.
AccessRights_ViewSchedulingUnitShiftRotations | 1621 | Represents the ViewSchedulingUnitShiftRotations property.
AccessRights_ModifySchedulingUnitShiftRotations | 1622 | Represents the ModifySchedulingUnitShiftRotations property.
AccessRights_CreateSchedulingUnitShiftRotations | 1623 | Represents the CreateSchedulingUnitShiftRotations property.
AccessRights_DeleteSchedulingUnitShiftRotations | 1624 | Represents the DeleteSchedulingUnitShiftRotations property.
AccessRights_ViewSchedulingUnitShifts | 1625 | Represents the ViewSchedulingUnitShifts property.
AccessRights_ModifySchedulingUnitShifts | 1626 | Represents the ModifySchedulingUnitShifts property.
AccessRights_CreateSchedulingUnitShifts | 1627 | Represents the CreateSchedulingUnitShifts property.
AccessRights_DeleteSchedulingUnitShifts | 1628 | Represents the DeleteSchedulingUnitShifts property.
AccessRights_ViewProcessList | 1629 | Represents the ViewProcessList property.
AccessRights_ViewQueueControlColumns | 1630 | Represents the ViewQueueControlColumns property.
AccessRights_ViewRecorderQuestionnaires | 1631 | Represents the ViewRecorderQuestionnaires property.
AccessRights_ViewReport | 1632 | Represents the ViewReport property.
AccessRights_ViewRuleSetsCustomHandler | 1633 | Obsolete. Represents the ViewRuleSetsCustomHandler property.
AccessRights_ViewRuleSetsEventLog | 1634 | Obsolete. Represents the ViewRuleSetsEventLog property.
AccessRights_ViewSkillList | 1635 | Represents the ViewSkillList property.
AccessRights_ViewStationGroups | 1636 | Represents the ViewStationGroups property.
AccessRights_ViewStationGroupsInSearch | 1637 | Represents the ViewStationGroupsInSearch property.
AccessRights_ViewStationQueue | 1638 | Represents the ViewStationQueue property.
AccessRights_ViewStationQueueInSearch | 1639 | Represents the ViewStationQueueInSearch property.
AccessRights_ViewStatusColumns | 1640 | Represents the ViewStatusColumns property.
AccessRights_ViewUserInteractionHistory | 1641 | Represents the ViewUserInteractionHistory property.
AccessRights_ViewUserQueue | 1642 | Represents the ViewUserQueue property.
AccessRights_ViewWorkgroup | 1643 | Represents the ViewWorkgroup property.
AccessRights_ViewWorkgroupQueue | 1644 | Represents the ViewWorkgroupQueue property.
AccessRights_ViewWorkgroupQueueInSearch | 1645 | Represents the ViewWorkgroupQueueInSearch property.
AccessRights_ViewWorkgroupStatistics | 1646 | Represents the ViewWorkgroupStatistics property.
AccessRights_ViewDataSource | 1647 | Represents the ViewDataSource property.
AccessRights_OptimizerViewShiftTrading | 1648 | Represents the OptimizerViewShiftTrading property.
AccessRights_OptimizerModifyShiftTrading | 1649 | Represents the OptimizerModifyShiftTrading property.
AccessRights_SnipLineQueue | 1650 | Represents the SnipLineQueue property.
AccessRights_SnipStationQueue | 1651 | Represents the SnipStationQueue property.
AccessRights_SnipUserQueue | 1652 | Represents the SnipUserQueue property.
AccessRights_SnipWorkgroupQueue | 1653 | Represents the SnipWorkgroupQueue property.
AdministrativeRights_AccountCodeList | 2000 | Represents the AccountCodeList property.
AdministrativeRights_AccumulatorList | 2001 | Represents the AccumulatorList property.
AdministrativeRights_Actions | 2002 | Represents the Actions property.
AdministrativeRights_AudioSources | 2003 | Represents the AudioSources property.
AdministrativeRights_CanEditAdministrativeRights | 2004 | Represents the CanEditAdministrativeRights property.
AdministrativeRights_ClientButtons | 2005 | Represents the ClientButtons property.
AdministrativeRights_ClientConfigurationConfiguration | 2006 | Represents the ClientConfigurationConfiguration property.
AdministrativeRights_ClientConfigurationTemplates | 2007 | Represents the ClientConfigurationTemplates property.
AdministrativeRights_Collective | 2008 | Represents the Collective property.
AdministrativeRights_ContactListSources | 2009 | Represents the ContactListSources property.
AdministrativeRights_DataManagerConfiguration | 2010 | Represents the DataManagerConfiguration property.
AdministrativeRights_DefaultIPPhoneConfiguration | 2011 | Represents the DefaultIPPhoneConfiguration property.
AdministrativeRights_DefaultLocationConfiguration | 2012 | Represents the DefaultLocationConfiguration property.
AdministrativeRights_DefaultStationConfiguration | 2013 | Represents the DefaultStationConfiguration property.
AdministrativeRights_DefaultUserConfiguration | 2014 | Represents the DefaultUserConfiguration property.
AdministrativeRights_DnisMappingsConfiguration | 2015 | Represents the DnisMappingsConfiguration property.
AdministrativeRights_EFaq | 2016 | Represents the EFaq property.
AdministrativeRights_FaxConfiguration | 2017 | Represents the FaxConfiguration property.
AdministrativeRights_FaxGroups | 2018 | Represents the FaxGroups property.
AdministrativeRights_Handlers | 2019 | Represents the Handlers property.
AdministrativeRights_ICDataSources | 2020 | Represents the ICDataSources property.
AdministrativeRights_ImageResources | 2021 | Represents the ImageResources property.
AdministrativeRights_InitializationFunctions | 2022 | Represents the InitializationFunctions property.
AdministrativeRights_InteractionAnalyzerKeywordSets | 2023 | Represents the InteractionAnalyzerKeywordSets property.
AdministrativeRights_InteractionConferenceConfiguration | 2024 | Represents the InteractionConferenceConfiguration property.
AdministrativeRights_InteractionConferenceRooms | 2025 | Represents the InteractionConferenceRooms property.
AdministrativeRights_InteractionDialerCallLists | 2026 | Represents the InteractionDialerCallLists property.
AdministrativeRights_InteractionDialerCampaigns | 2027 | Represents the InteractionDialerCampaigns property.
AdministrativeRights_InteractionDialerConfiguration | 2028 | Represents the InteractionDialerConfiguration property.
AdministrativeRights_InteractionDialerPolicySets | 2029 | Represents the InteractionDialerPolicySets property.
AdministrativeRights_InteractionDialerRuleSets | 2030 | Represents the InteractionDialerRuleSets property.
AdministrativeRights_InteractionDialerSchedules | 2031 | Represents the InteractionDialerSchedules property.
AdministrativeRights_InteractionDialerScripts | 2032 | Represents the InteractionDialerScripts property.
AdministrativeRights_InteractionDialerSkillSets | 2033 | Represents the InteractionDialerSkillSets property.
AdministrativeRights_InteractionDialerStageSets | 2034 | Represents the InteractionDialerStageSets property.
AdministrativeRights_InteractionDialerZoneSets | 2035 | Represents the InteractionDialerZoneSets property.
AdministrativeRights_InteractionFeedbackConfiguration | 2036 | Represents the InteractionFeedbackConfiguration property.
AdministrativeRights_InteractionOptimizerActivityTypesConfiguration | 2037 | Obsolete. Represents the InteractionOptimizerActivityTypesConfiguration property.
AdministrativeRights_InteractionOptimizerAdvancedConfiguration | 2038 | Represents the InteractionOptimizerAdvancedConfiguration property.
AdministrativeRights_InteractionOptimizerAgentsConfiguration | 2039 | Represents the InteractionOptimizerAgentsConfiguration property.
AdministrativeRights_InteractionOptimizerDayClassificationsConfiguration | 2040 | Obsolete. Represents the InteractionOptimizerDayClassificationsConfiguration property.
AdministrativeRights_InteractionOptimizerForecastsAndSchedulesConfiguration | 2041 | Obsolete. Represents the InteractionOptimizerForecastsAndSchedulesConfiguration property.
AdministrativeRights_InteractionOptimizerSchedulingUnits | 2042 | Obsolete. Represents the InteractionOptimizerSchedulingUnits property.
AdministrativeRights_InteractionProcessAutomation | 2043 | Represents the InteractionProcessAutomation property.
AdministrativeRights_InteractionProcessorTables | 2044 | Represents the InteractionProcessorTables property.
AdministrativeRights_InteractionRecorderConfiguration | 2045 | Represents the InteractionRecorderConfiguration property.
AdministrativeRights_InteractionTrackerConfiguration | 2046 | Represents the InteractionTrackerConfiguration property.
AdministrativeRights_IPPhoneRegistrationGroups | 2047 | Represents the IPPhoneRegistrationGroups property.
AdministrativeRights_IPPhoneRingSets | 2048 | Represents the IPPhoneRingSets property.
AdministrativeRights_IPPhones | 2049 | Represents the IPPhones property.
AdministrativeRights_IPPhoneTemplates | 2050 | Represents the IPPhoneTemplates property.
AdministrativeRights_Layouts | 2051 | Represents the Layouts property.
AdministrativeRights_LicensesAllocationConfiguration | 2052 | Represents the LicensesAllocationConfiguration property.
AdministrativeRights_LineGroups | 2053 | Represents the LineGroups property.
AdministrativeRights_Lines | 2054 | Represents the Lines property.
AdministrativeRights_Locations | 2055 | Represents the Locations property.
AdministrativeRights_LogRetrievalAssistantConfiguration | 2056 | Represents the LogRetrievalAssistantConfiguration property.
AdministrativeRights_MailConfiguration | 2057 | Represents the MailConfiguration property.
AdministrativeRights_MasterAdministrator | 2058 | Represents the MasterAdministrator property.
AdministrativeRights_MediaServersConfiguration | 2059 | Represents the MediaServersConfiguration property.
AdministrativeRights_MrcpConfiguration | 2060 | Represents the MrcpConfiguration property.
AdministrativeRights_OcsActiveDirectories | 2061 | Represents the OcsActiveDirectories property.
AdministrativeRights_OcsConfiguration | 2062 | Represents the OcsConfiguration property.
AdministrativeRights_OcsStatusMessages | 2063 | Represents the OcsStatusMessages property.
AdministrativeRights_PagingCarriers | 2064 | Represents the PagingCarriers property.
AdministrativeRights_PasswordPolicies | 2065 | Represents the PasswordPolicies property.
AdministrativeRights_PasswordPoliciesConfiguration | 2066 | Represents the PasswordPoliciesConfiguration property.
AdministrativeRights_PeerSitesConfiguration | 2067 | Represents the PeerSitesConfiguration property.
AdministrativeRights_PhoneNumbersConfiguration | 2068 | Represents the PhoneNumbersConfiguration property.
AdministrativeRights_Positions | 2069 | Represents the Positions property.
AdministrativeRights_ProblemReporterConfiguration | 2070 | Represents the ProblemReporterConfiguration property.
AdministrativeRights_QueueControlColumns | 2071 | Represents the QueueControlColumns property.
AdministrativeRights_ReportLogs | 2072 | Represents the ReportLogs property.
AdministrativeRights_Reports | 2073 | Represents the Reports property.
AdministrativeRights_ResponseManagement | 2074 | Represents the ResponseManagement property.
AdministrativeRights_Roles | 2075 | Represents the Roles property.
AdministrativeRights_SalesforceCtis | 2076 | Obsolete. Represents the SalesforceCtis property.
AdministrativeRights_SametimeConfiguration | 2077 | Represents the SametimeConfiguration property.
AdministrativeRights_Schedules | 2078 | Represents the Schedules property.
AdministrativeRights_SelectionRuleList | 2079 | Represents the SelectionRuleList property.
AdministrativeRights_SecureInputForms | 2080 | Represents the SecureInputForms property.
AdministrativeRights_ServerParameter | 2081 | Represents the ServerParameter property.
AdministrativeRights_ServersConfiguration | 2082 | Represents the ServersConfiguration property.
AdministrativeRights_SessionManagerServerConfiguration | 2083 | Represents the SessionManagerServerConfiguration property.
AdministrativeRights_SingleSignOnIdentityProviders | 2106 | Represents the SingleSignOnIdentityProviders property.
AdministrativeRights_SingleSignOnSecureTokenServer | 2107 | Represents the SingleSignOnSecureTokenServer property.
AdministrativeRights_SipBridge | 2084 | Represents the SipBridge property.
AdministrativeRights_SipProxyConfiguration | 2085 | Represents the SipProxyConfiguration property.
AdministrativeRights_Skills | 2086 | Represents the Skills property.
AdministrativeRights_SmsBroker | 2087 | Represents the SmsBroker property.
AdministrativeRights_SmsConfiguration | 2088 | Represents the SmsConfiguration property.
AdministrativeRights_SpeechRecognitionConfiguration | 2089 | Represents the SpeechRecognitionConfiguration property.
AdministrativeRights_StationGroups | 2090 | Represents the StationGroups property.
AdministrativeRights_Stations | 2091 | Represents the Stations property.
AdministrativeRights_StationTemplates | 2092 | Represents the StationTemplates property.
AdministrativeRights_StatusMessages | 2093 | Represents the StatusMessages property.
AdministrativeRights_StreamingAudioMonitorProfiles | 2108 | Represents the StreamingAudioMonitorProfiles property.
AdministrativeRights_StructuredParameters | 2094 | Represents the StructuredParameters property.
AdministrativeRights_SystemConfiguration | 2095 | Represents the SystemConfiguration property.
AdministrativeRights_SystemParameters | 2096 | Represents the SystemParameters property.
AdministrativeRights_Users | 2097 | Represents the Users property.
AdministrativeRights_VoiceModules | 2098 | Represents the VoiceModules property.
AdministrativeRights_WebServicesParameters | 2099 | Represents the WebServicesParameters property.
AdministrativeRights_Workgroups | 2100 | Represents the Workgroups property.
AdministrativeRights_WrapUpCodes | 2101 | Represents the WrapUpCodes property.
AdministrativeRights_WrapUpCategories | 2102 | Represents the WrapUpCategories property.
AdministrativeRights_CanPublishClientTemplates | 2103 | Represents the CanPublishClientTemplates property.
AdministrativeRights_MrcpServerList | 2104 | Represents the MrcpServerList property.
AdministrativeRights_WebServicesConfiguration | 2105 | Represents the WebServicesConfiguration property.
SecurityRights_AccessAllInteractionConferences | 1000 | Represents the AccessAllInteractionConferences property.
SecurityRights_AccessOwnedInteractionConferences | 1001 | Represents the AccessOwnedInteractionConferences property.
SecurityRights_AccountCodeVerification | 1002 | Represents the AccountCodeVerification property.
SecurityRights_AddIndividuals | 1003 | Represents the AddIndividuals property.
SecurityRights_AddOrganizations | 1004 | Represents the AddOrganizations property.
SecurityRights_AgentPreferences | 1005 | Represents the AgentPreferences property.
SecurityRights_AllowAccessToProblemReporter | 1006 | Represents the AllowAccessToProblemReporter property.
SecurityRights_AlertAdministrator | 1007 | Represents the AlertAdministrator property.
SecurityRights_AllowAgentRules | 1008 | Represents the AllowAgentRules property.
SecurityRights_AllowAgentScheduleBidding | 1009 | Represents the AllowAgentScheduleBidding property.
SecurityRights_AllowAgentSeeRelativeRank | 1010 | Represents the AllowAgentSeeRelativeRank property.
SecurityRights_AllowAgentSeeOwnRank | 1011 | Represents the AllowAgentSeeOwnRank property.
SecurityRights_AllowEmailAccessViaTui | 1012 | Represents the AllowEmailAccessViaTui property.
SecurityRights_AllowEmailAlerts | 1013 | Represents the AllowEmailAlerts property.
SecurityRights_AllowFaxAccessViaTui | 1014 | Represents the AllowFaxAccessViaTui property.
SecurityRights_AllowHandlerAlerts | 1015 | Represents the AllowHandlerAlerts property.
SecurityRights_AllowIntercomChat | 1016 | Represents the AllowIntercomChat property.
SecurityRights_AllowMiniMode | 1017 | Represents the AllowMiniMode property.
SecurityRights_AllowMemoAlerts | 1018 | Represents the AllowMemoAlerts property.
SecurityRights_AllowMonitorColumns | 1019 | Represents the AllowMonitorColumns property.
SecurityRights_AllowMultipleCalls | 1020 | Represents the AllowMultipleCalls property.
SecurityRights_AllowPersistentConnections | 1021 | Represents the AllowPersistentConnections property.
SecurityRights_AllowReceiveVoicemail | 1022 | Represents the AllowReceiveVoicemail property.
SecurityRights_AllowRelatedInteractionsPage | 1023 | Represents the AllowRelatedInteractionsPage property.
SecurityRights_AllowResponseManagement | 1024 | Represents the AllowResponseManagement property.
SecurityRights_AllowSpeedDials | 1025 | Represents the AllowSpeedDials property.
SecurityRights_AllowStatusNotes | 1026 | Represents the AllowStatusNotes property.
SecurityRights_AllowUserDefinedTelephoneNumberOnRemoteLogin | 1027 | Represents the AllowUserDefinedTelephoneNumberOnRemoteLogin property.
SecurityRights_AllowVideo | 1028 | Represents the AllowVideo property.
SecurityRights_AllowVoiceMaiAccessViaTui | 1029 | Represents the AllowVoiceMaiAccessViaTui property.
SecurityRights_AllowAlertProgramming | 1030 | Represents the AllowAlertProgramming property.
SecurityRights_AllowWorkgroupStats | 1031 | Represents the AllowWorkgroupStats property.
SecurityRights_CanCoachInteractions | 1032 | Represents the CanCoachInteractions property.
SecurityRights_CanConferenceCalls | 1033 | Represents the CanConferenceCalls property.
SecurityRights_CanCreateAlertSets | 1034 | Represents the CanCreateAlertSets property.
SecurityRights_CanShareAlertSets | 1035 | Represents the CanShareAlertSets property.
SecurityRights_CanCreateOptimizerActivityCodes | 1036 | Represents the CanCreateOptimizerActivityCodes property.
SecurityRights_CanCreateQuestionnaireDirectories | 1037 | Represents the CanCreateQuestionnaireDirectories property.
SecurityRights_CanDeleteOptimizerActivityCodes | 1038 | Represents the CanDeleteOptimizerActivityCodes property.
SecurityRights_CanDisconnectInteractions | 1039 | Represents the CanDisconnectInteractions property.
SecurityRights_CanInitiateSecureInput | 1040 | Represents the CanInitiateSecureInput property.
SecurityRights_CanForceSubscribeAlertSets | 1041 | Represents the CanForceSubscribeAlertSets property.
SecurityRights_CanJoinInteractions | 1042 | Represents the CanJoinInteractions property.
SecurityRights_CanListenInOnInteractions | 1043 | Represents the CanListenInOnInteractions property.
SecurityRights_CanManageClientTemplates | 1044 | Represents the CanManageClientTemplates property.
SecurityRights_CanModifyOptimizerActivityCodes | 1045 | Represents the CanModifyOptimizerActivityCodes property.
SecurityRights_CanModifyOptimizerStatusActivityTypeMapping | 1046 | Represents the CanModifyOptimizerStatusActivityTypeMapping property.
SecurityRights_CanMuteInteractions | 1047 | Represents the CanMuteInteractions property.
SecurityRights_CanOrbitQueue | 1048 | Represents the CanOrbitQueue property.
SecurityRights_CanOverrideFinishedScorecards | 1049 | Represents the CanOverrideFinishedScorecards property.
SecurityRights_CanParkInteractions | 1050 | Represents the CanParkInteractions property.
SecurityRights_CanPauseInteractions | 1051 | Represents the CanPauseInteractions property.
SecurityRights_CanPickupInteractions | 1052 | Represents the CanPickupInteractions property.
SecurityRights_CanPutInteractionsOnHold | 1053 | Represents the CanPutInteractionsOnHold property.
SecurityRights_CanRecordInteractions | 1054 | Represents the CanRecordInteractions property.
SecurityRights_CanRequestAssistanceFromSupervisor | 1055 | Represents the CanRequestAssistanceFromSupervisor property.
SecurityRights_CanSecureRecordingPauseInteractions | 1056 | Represents the CanSecureRecordingPauseInteractions property.
SecurityRights_CanTransferInteractions | 1057 | Represents the CanTransferInteractions property.
SecurityRights_CanTransferInteractionsToVoicemail | 1058 | Represents the CanTransferInteractionsToVoicemail property.
SecurityRights_CanUserInteractionRecorderSelector | 1059 | Represents the CanUserInteractionRecorderSelector property.
SecurityRights_CanViewOptimizerActivityCodes | 1060 | Represents the CanViewOptimizerActivityCodes property.
SecurityRights_CanViewOptimizerStatusActivityTypeMapping | 1061 | Represents the CanViewOptimizerStatusActivityTypeMapping property.
SecurityRights_CustomizeClient | 1062 | Represents the CustomizeClient property.
SecurityRights_DebugHandlers | 1063 | Represents the DebugHandlers property.
SecurityRights_DeleteIndividuals | 1064 | Represents the DeleteIndividuals property.
SecurityRights_DeleteOrganizations | 1065 | Represents the DeleteOrganizations property.
SecurityRights_DirectoryAdmin | 1066 | Represents the DirectoryAdmin property.
SecurityRights_ExecuteLongRunningQueries | 1067 | Obsolete. Represents the ExecuteLongRunningQueries property.
SecurityRights_FollowMe | 1068 | Represents the FollowMe property.
SecurityRights_HavePrivateContacts | 1069 | Represents the HavePrivateContacts property.
SecurityRights_IPPhoneProvisioningAdmin | 1070 | Represents the IPPhoneProvisioningAdmin property.
SecurityRights_LockPolicySets | 1071 | Represents the LockPolicySets property.
SecurityRights_LoginCampaign | 1072 | Represents the LoginCampaign property.
SecurityRights_ManageHandlers | 1073 | Represents the ManageHandlers property.
SecurityRights_MobileOfficeUser | 1074 | Represents the MobileOfficeUser property.
SecurityRights_ModifyConfigurationChangeAuditing | 1075 | Represents the ModifyConfigurationChangeAuditing property.
SecurityRights_ModifyConfigurationGeneral | 1076 | Represents the ModifyConfigurationGeneral property.
SecurityRights_ModifyConfigurationHTTPServer | 1077 | Represents the ModifyConfigurationHTTPServer property.
SecurityRights_ModifyConfigurationOutboundServers | 1078 | Represents the ModifyConfigurationOutboundServers property.
SecurityRights_ModifyConfigurationPhoneNumberTypes | 1079 | Represents the ModifyConfigurationPhoneNumberTypes property.
SecurityRights_ModifyConfigurationPreviewCallBehavior | 1080 | Represents the ModifyConfigurationPreviewCallBehavior property.
SecurityRights_ModifyIndividuals | 1081 | Represents the ModifyIndividuals property.
SecurityRights_ModifyInteractions | 1082 | Represents the ModifyInteractions property.
SecurityRights_ModifyOrganizations | 1083 | Represents the ModifyOrganizations property.
SecurityRights_OutlookTuiUser | 1084 | Represents the OutlookTuiUser property.
SecurityRights_PrivateCalls | 1085 | Represents the PrivateCalls property.
SecurityRights_PublishHandlers | 1086 | Represents the PublishHandlers property.
SecurityRights_RemoteControl | 1087 | Represents the RemoteControl property.
SecurityRights_ReporterAdministrator | 1088 | Represents the ReporterAdministrator property.
SecurityRights_RequireForcedAuthorizationCode | 1089 | Represents the RequireForcedAuthorizationCode property.
SecurityRights_ShowAssistanceButton | 1090 | Represents the ShowAssistanceButton property.
SecurityRights_ShowCoachButton | 1091 | Represents the ShowCoachButton property.
SecurityRights_ShowDisconnectButton | 1092 | Represents the ShowDisconnectButton property.
SecurityRights_ShowHoldButton | 1093 | Represents the ShowHoldButton property.
SecurityRights_ShowJoinButton | 1094 | Represents the ShowJoinButton property.
SecurityRights_ShowListenButton | 1095 | Represents the ShowListenButton property.
SecurityRights_ShowMuteButton | 1096 | Represents the ShowMuteButton property.
SecurityRights_ShowParkButton | 1097 | Represents the ShowParkButton property.
SecurityRights_ShowPauseButton | 1098 | Represents the ShowPauseButton property.
SecurityRights_ShowPickupButton | 1099 | Represents the ShowPickupButton property.
SecurityRights_ShowPrivateButton | 1100 | Represents the ShowPrivateButton property.
SecurityRights_ShowRecordButton | 1101 | Represents the ShowRecordButton property.
SecurityRights_ShowSecureInputButton | 1102 | Represents the ShowSecureInputButton property.
SecurityRights_ShowSecureRecordingPauseButton | 1103 | Represents the ShowSecureRecordingPauseButton property.
SecurityRights_ShowTransferButton | 1104 | Represents the ShowTransferButton property.
SecurityRights_ShowVoicemailButton | 1105 | Represents the ShowVoicemailButton property.
SecurityRights_ShowWorkgroupsProfilesTab | 1106 | Represents the ShowWorkgroupsProfilesTab property.
SecurityRights_TraceConfiguration | 1107 | Represents the TraceConfiguration property.
SecurityRights_TrackerAdministrator | 1108 | Represents the TrackerAdministrator property.
SecurityRights_UseTiffForFaxes | 1109 | Represents the UseTiffForFaxes property.
SecurityRights_ViewConfigurationChangeAuditing | 1110 | Represents the ViewConfigurationChangeAuditing property.
SecurityRights_ViewConfigurationGeneral | 1111 | Represents the ViewConfigurationGeneral property.
SecurityRights_ViewConfigurationHTTPServer | 1112 | Represents the ViewConfigurationHTTPServer property.
SecurityRights_ViewConfigurationOutboundServers | 1113 | Represents the ViewConfigurationOutboundServers property.
SecurityRights_ViewConfigurationPhoneNumberTypes | 1114 | Represents the ViewConfigurationPhoneNumberTypes property.
SecurityRights_ViewConfigurationPreviewCallBehavior | 1115 | Represents the ViewConfigurationPreviewCallBehavior property.
SecurityRights_ViewInteractionDetails | 1116 | Represents the ViewInteractionDetails property.
SecurityRights_ViewModifyCampaignAgentlessCallingType | 1117 | Represents the ViewModifyCampaignAgentlessCallingType property.
SecurityRights_ViewModifyCampaignAutomaticTimeZoneMapping | 1118 | Represents the ViewModifyCampaignAutomaticTimeZoneMapping property.
SecurityRights_ViewModifyCampaignLineSettings | 1119 | Represents the ViewModifyCampaignLineSettings property.
SecurityRights_ViewModifyCampaignMaxLines | 1120 | Represents the ViewModifyCampaignMaxLines property.
SecurityRights_ViewModifyCampaignStatus | 1121 | Represents the ViewModifyCampaignStatus property.
SecurityRights_ViewModifyContactListDataQuery | 1122 | Represents the ViewModifyContactListDataQuery property.
SecurityRights_ViewModifyCustomHandlerActions | 1123 | Represents the ViewModifyCustomHandlerActions property.
SecurityRights_ViewModifyDatabaseConnections | 1124 | Represents the ViewModifyDatabaseConnections property.
SecurityRights_ViewModifyDncSources | 1125 | Represents the ViewModifyDncSources property.
SecurityRights_ViewModifyEventLog | 1126 | Represents the ViewModifyEventLog property.
SecurityRights_ViewModifyTimeZoneMapData | 1127 | Represents the ViewModifyTimeZoneMapData property.
SecurityRights_ViewOtherPeoplesPrivateInteractions | 1128 | Represents the ViewOtherPeoplesPrivateInteractions property.
SecurityRights_CanDeleteSchedulingUnits | 1129 | Represents the CanDeleteSchedulingUnits property.
SecurityRights_CanCreateSchedulingUnits | 1130 | Represents the CanCreateSchedulingUnits property.
SecurityRights_CanViewOptimizerDayClassifications | 1131 | Represents the CanViewOptimizerDayClassifications property.
SecurityRights_CanModifyOptimizerDayClassifications | 1132 | Represents the CanModifyOptimizerDayClassifications property.
SecurityRights_CanCreateOptimizerDayClassifications | 1133 | Represents the CanCreateOptimizerDayClassifications property.
SecurityRights_CanDeleteOptimizerDayClassifications | 1134 | Represents the CanDeleteOptimizerDayClassifications property.
SecurityRights_CanPublishProcess | 1135 | Represents the CanPublishProcess property.
SecurityRights_CanSubmitTimeOff | 1138 | Represents the CanSubmitTimeOff property.
SecurityRights_CanAccessOptimizerShiftTrading | 1139 | Represents the CanAccessOptimizerShiftTrading property.
SecurityRights_RunContactListPredefinedActions | 1140 | Represents the RunContactListPredefinedActions property.
SecurityRights_CreateModifyCampaignGroup | 1141 | Represents the CreateModifyCampaignGroup property.
SecurityRights_ModifyCampaignGroupSequence | 1142 | Represents the ModifyCampaignGroupSequence property.
SecurityRights_ManualTransitionSequence | 1143 | Represents the ManualTransitionSequence property.
SecurityRights_CanInitiateRecordingSnippet | 1144 | Represents the CanInitiateRecordingSnippet property.
SecurityRights_ShowRecordingSnippetButton | 1145 | Represents the ShowRecordingSnippetButton property.
SecurityRights_ContactListRecordOwnershipControl | 1146 | Represents the ContactListRecordOwnershipControl property.
SecurityRights_ModifyBaseScriptAgentComplianceOverride | 1147 | Represents the ModifyBaseScriptAgentComplianceOverride property.
SecurityRights_AllowAgentComplianceOverride | 1148 | Represents the AllowAgentComplianceOverride property.
SecurityRights_ForceUserLogout | 1149 | Represents the ForceUserLogout property.
SecurityRights_DataExtractorJobAdmin | 1150 | Represents the DataExtractorJobAdmin property.
SecurityRights_CloudWorkforceEngagementAdministrator | 1151 | Represents the CloudWorkforceEngagementAdministrator property.
DisplayName | 1136 | Represents the DisplayName part of the ConfigurationId property.
Id | 1137 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


RoleConfiguration.Rights Class

[image]

IceLib Technical Reference
RoleConfiguration..::..Rights Class
RoleConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..RoleConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


RoleConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
RoleConfiguration..::..Rights Members
RoleConfiguration..::..Rights Class Properties See Also Send Feedback

The RoleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

RoleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


RoleConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
RoleConfiguration..::..Rights Properties
RoleConfiguration..::..Rights Class See Also Send Feedback

The RoleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

RoleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
RoleConfiguration..::..Rights..::..Admin Property
RoleConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RoleConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of RoleConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration..::..Rights Class
RoleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Roles


View Property

[image]

IceLib Technical Reference
RoleConfiguration..::..Rights..::..View Property
RoleConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RoleConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of RoleConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RoleConfiguration..::..Rights Class
RoleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


RoleConfigurationList Class

[image]

IceLib Technical Reference
RoleConfigurationList Class
Members Example See Also Send Feedback
Allows for querying and managing role configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RoleConfigurationList : EditableConfigurationList<RoleConfiguration, RoleConfiguration..::..Property>
Visual Basic
Public Class RoleConfigurationList _
    Inherits EditableConfigurationList(Of RoleConfiguration, RoleConfiguration..::..Property)

Examples

The IceLib SDK includes example application references to the RoleConfigurationList class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 190, in UserRoleConfigurationViewModel.SessionConnectionStateChanged

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' RoleConfiguration, RoleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' RoleConfiguration, RoleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' RoleConfiguration, RoleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..RoleConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfigurationList Members
ININ.IceLib.Configuration Namespace


RoleConfigurationList Members

[image] [image]

IceLib Technical Reference
RoleConfigurationList Members
RoleConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The RoleConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | RoleConfigurationList | Initializes a new instance of the RoleConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RoleConfigurationList Class
ININ.IceLib.Configuration Namespace


RoleConfigurationList Constructor

[image]

IceLib Technical Reference
RoleConfigurationList Constructor
RoleConfigurationList Class Example See Also Send Feedback
Initializes a new instance of the RoleConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RoleConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Examples

The IceLib SDK includes example application references to the RoleConfigurationList constructor. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 190, in UserRoleConfigurationViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

RoleConfigurationList Class
RoleConfigurationList Members
ININ.IceLib.Configuration Namespace


RoleConfigurationList Methods

[image] [image]

IceLib Technical Reference
RoleConfigurationList Methods
RoleConfigurationList Class See Also Send Feedback

The RoleConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleConfigurationList Class
ININ.IceLib.Configuration Namespace


RoleConfigurationList Properties

[image] [image]

IceLib Technical Reference
RoleConfigurationList Properties
RoleConfigurationList Class See Also Send Feedback

The RoleConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RoleConfigurationList Class
ININ.IceLib.Configuration Namespace


RoleConfigurationList Events

[image] [image]

IceLib Technical Reference
RoleConfigurationList Events
RoleConfigurationList Class See Also Send Feedback

The RoleConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RoleConfigurationList Class
ININ.IceLib.Configuration Namespace


ScheduleConfiguration Class

[image]

IceLib Technical Reference
ScheduleConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Schedule. A schedule defines dates and times to activate telephone-based menus.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScheduleConfiguration : EditableListConfigurationObject<ScheduleConfiguration..::..Property>
Visual Basic
Public Class ScheduleConfiguration _
    Inherits EditableListConfigurationObject(Of ScheduleConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ScheduleConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ScheduleConfigurationList
ININ.IceLib.Configuration..::..ScheduleRecurrenceConfiguration


ScheduleConfiguration Members

[image] [image]

IceLib Technical Reference
ScheduleConfiguration Members
ScheduleConfiguration Class Methods Properties See Also Send Feedback

The ScheduleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this schedule (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the description for this schedule (use Property.Description).
Public property | IsActive | Provides access to the property representing the is-active flag for this schedule (use Property.IsActive).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Keywords | Provides access to the property representing the keywords for this schedule (use Property.Keywords).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ScheduleRecurrences | Provides access to the property representing a collection containing the one recurrence pattern for this schedule (use Property.ScheduleRecurrences).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ScheduleConfiguration Class
ININ.IceLib.Configuration Namespace


ScheduleConfiguration Methods

[image] [image]

IceLib Technical Reference
ScheduleConfiguration Methods
ScheduleConfiguration Class See Also Send Feedback

The ScheduleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ScheduleConfiguration Class
ININ.IceLib.Configuration Namespace


ScheduleConfiguration Properties

[image] [image]

IceLib Technical Reference
ScheduleConfiguration Properties
ScheduleConfiguration Class See Also Send Feedback

The ScheduleConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this schedule (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the description for this schedule (use Property.Description).
Public property | IsActive | Provides access to the property representing the is-active flag for this schedule (use Property.IsActive).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Keywords | Provides access to the property representing the keywords for this schedule (use Property.Keywords).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ScheduleRecurrences | Provides access to the property representing a collection containing the one recurrence pattern for this schedule (use Property.ScheduleRecurrences).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ScheduleConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..AccessControlGroupAssignment Property
ScheduleConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this schedule (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..Description Property
ScheduleConfiguration Class See Also Send Feedback
Provides access to the property representing the description for this schedule (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, String)
    Get

Field Value

The property representing the description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


IsActive Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..IsActive Property
ScheduleConfiguration Class See Also Send Feedback
Provides access to the property representing the is-active flag for this schedule (use Property.IsActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, bool> IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether or not this schedule is active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


Keywords Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..Keywords Property
ScheduleConfiguration Class See Also Send Feedback
Provides access to the property representing the keywords for this schedule (use Property.Keywords).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, Collection<string>> Keywords { get; }
Visual Basic
Public ReadOnly Property Keywords As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the set of keywords.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..PropertiesChanged Property
ScheduleConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ScheduleConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ScheduleConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


ScheduleRecurrences Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..ScheduleRecurrences Property
ScheduleConfiguration Class See Also Send Feedback
Provides access to the property representing a collection containing the one recurrence pattern for this schedule (use Property.ScheduleRecurrences).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, Collection<ScheduleRecurrenceConfiguration>> ScheduleRecurrences { get; }
Visual Basic
Public ReadOnly Property ScheduleRecurrences As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, Collection(Of ScheduleRecurrenceConfiguration))
    Get

Field Value

The property representing the recurrence pattern collection.

Remarks

Only one schedule recurrence pattern is supported. Any objects after the first one will be ignored.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..StandardProperties Property
ScheduleConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ScheduleConfiguration, ScheduleConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ScheduleConfiguration, ScheduleConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members
ININ.IceLib.Configuration Namespace


ScheduleConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ScheduleConfiguration..::..Property Enumeration
ScheduleConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
Description | 1 | Represents the Description property.
IsActive | 2 | Represents the IsActive property.
Keywords | 3 | Represents the Keywords property.
ScheduleRecurrences | 4 | Represents the ScheduleRecurrences property.
DisplayName | 5 | Represents the DisplayName part of the ConfigurationId property.
Id | 6 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ScheduleConfiguration.Rights Class

[image]

IceLib Technical Reference
ScheduleConfiguration..::..Rights Class
ScheduleConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ScheduleConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ScheduleConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ScheduleConfiguration..::..Rights Members
ScheduleConfiguration..::..Rights Class Properties See Also Send Feedback

The ScheduleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ScheduleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ScheduleConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ScheduleConfiguration..::..Rights Properties
ScheduleConfiguration..::..Rights Class See Also Send Feedback

The ScheduleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ScheduleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..Rights..::..Admin Property
ScheduleConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ScheduleConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ScheduleConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfiguration..::..Rights Class
ScheduleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Schedules


View Property

[image]

IceLib Technical Reference
ScheduleConfiguration..::..Rights..::..View Property
ScheduleConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ScheduleConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ScheduleConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfiguration..::..Rights Class
ScheduleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ScheduleConfigurationList Class

[image]

IceLib Technical Reference
ScheduleConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Schedule configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScheduleConfigurationList : EditableConfigurationList<ScheduleConfiguration, ScheduleConfiguration..::..Property>
Visual Basic
Public Class ScheduleConfigurationList _
    Inherits EditableConfigurationList(Of ScheduleConfiguration, ScheduleConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ScheduleConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfigurationList Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ScheduleConfiguration
ININ.IceLib.Configuration..::..ScheduleRecurrenceConfiguration
ININ.IceLib.Configuration..::..ScheduleQueryChildrenSettings
ININ.IceLib.Configuration..::..HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>


ScheduleConfigurationList Members

[image] [image]

IceLib Technical Reference
ScheduleConfigurationList Members
ScheduleConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleConfigurationList | Initializes a new instance of the ScheduleConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | CreateRecurrenceQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateScheduleRecurrence | Creates a new schedule recurrence.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ScheduleConfigurationList Class
ININ.IceLib.Configuration Namespace


ScheduleConfigurationList Constructor

[image]

IceLib Technical Reference
ScheduleConfigurationList Constructor
ScheduleConfigurationList Class See Also Send Feedback
Initializes a new instance of the ScheduleConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ScheduleConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfigurationList Class
ScheduleConfigurationList Members
ININ.IceLib.Configuration Namespace


ScheduleConfigurationList Methods

[image] [image]

IceLib Technical Reference
ScheduleConfigurationList Methods
ScheduleConfigurationList Class See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | CreateRecurrenceQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateScheduleRecurrence | Creates a new schedule recurrence.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleConfigurationList Class
ININ.IceLib.Configuration Namespace


CreateQuerySettings Method

[image]

IceLib Technical Reference
ScheduleConfigurationList..::..CreateQuerySettings Method
ScheduleConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings<ScheduleConfiguration, ScheduleConfiguration..::..Property, ScheduleQueryChildrenSettings> CreateQuerySettings()
Visual Basic
Public Function CreateQuerySettings As HierarchicalQuerySettings(Of ScheduleConfiguration, ScheduleConfiguration..::..Property, ScheduleQueryChildrenSettings)

Return Value

A new HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScheduleConfigurationList Class
ScheduleConfigurationList Members
ININ.IceLib.Configuration Namespace


CreateRecurrenceQuerySettings Method

[image]

IceLib Technical Reference
ScheduleConfigurationList..::..CreateRecurrenceQuerySettings Method
ScheduleConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<ScheduleRecurrenceConfiguration, ScheduleRecurrenceConfiguration..::..Property> CreateRecurrenceQuerySettings()
Visual Basic
Public Function CreateRecurrenceQuerySettings As QuerySettings(Of ScheduleRecurrenceConfiguration, ScheduleRecurrenceConfiguration..::..Property)

Return Value

A new QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ScheduleConfigurationList Class
ScheduleConfigurationList Members
ININ.IceLib.Configuration Namespace


CreateScheduleRecurrence Method

[image]

IceLib Technical Reference
ScheduleConfigurationList..::..CreateScheduleRecurrence Method
ScheduleConfigurationList Class See Also Send Feedback
Creates a new schedule recurrence.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ScheduleRecurrenceConfiguration CreateScheduleRecurrence()
Visual Basic
Public Function CreateScheduleRecurrence As ScheduleRecurrenceConfiguration

Return Value

A new ScheduleRecurrenceConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleConfigurationList Class
ScheduleConfigurationList Members
ININ.IceLib.Configuration Namespace


ScheduleConfigurationList Properties

[image] [image]

IceLib Technical Reference
ScheduleConfigurationList Properties
ScheduleConfigurationList Class See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ScheduleConfigurationList Class
ININ.IceLib.Configuration Namespace


ScheduleConfigurationList Events

[image] [image]

IceLib Technical Reference
ScheduleConfigurationList Events
ScheduleConfigurationList Class See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ScheduleConfigurationList Class
ININ.IceLib.Configuration Namespace


ScheduleQueryChildrenSettings Class

[image]

IceLib Technical Reference
ScheduleQueryChildrenSettings Class
Members See Also Send Feedback
Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects for ScheduleRecurrences.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScheduleQueryChildrenSettings : QueryChildrenSettings<ScheduleConfiguration..::..Property>
Visual Basic
Public Class ScheduleQueryChildrenSettings _
    Inherits QueryChildrenSettings(Of ScheduleConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QueryChildrenSettings <(Of <(<' ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ScheduleQueryChildrenSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ScheduleConfigurationList
ININ.IceLib.Configuration..::..ScheduleRecurrenceConfiguration
ININ.IceLib.Configuration..::..QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>


ScheduleQueryChildrenSettings Members

[image] [image]

IceLib Technical Reference
ScheduleQueryChildrenSettings Members
ScheduleQueryChildrenSettings Class Constructors Methods Properties See Also Send Feedback

The ScheduleQueryChildrenSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleQueryChildrenSettings | Initializes a new instance of the ScheduleQueryChildrenSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ScheduleRecurrence | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

See Also

ScheduleQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


ScheduleQueryChildrenSettings Constructor

[image]

IceLib Technical Reference
ScheduleQueryChildrenSettings Constructor
ScheduleQueryChildrenSettings Class See Also Send Feedback
Initializes a new instance of the ScheduleQueryChildrenSettings class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ScheduleQueryChildrenSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleQueryChildrenSettings Class
ScheduleQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


ScheduleQueryChildrenSettings Methods

[image] [image]

IceLib Technical Reference
ScheduleQueryChildrenSettings Methods
ScheduleQueryChildrenSettings Class See Also Send Feedback

The ScheduleQueryChildrenSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


ScheduleQueryChildrenSettings Properties

[image] [image]

IceLib Technical Reference
ScheduleQueryChildrenSettings Properties
ScheduleQueryChildrenSettings Class See Also Send Feedback

The ScheduleQueryChildrenSettings type exposes the following members.

Properties

 | Name | Description
Public property | ScheduleRecurrence | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

See Also

ScheduleQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


ScheduleRecurrence Property

[image]

IceLib Technical Reference
ScheduleQueryChildrenSettings..::..ScheduleRecurrence Property
ScheduleQueryChildrenSettings Class See Also Send Feedback
Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<ScheduleRecurrenceConfiguration, ScheduleRecurrenceConfiguration..::..Property> ScheduleRecurrence { get; set; }
Visual Basic
Public Property ScheduleRecurrence As QuerySettings(Of ScheduleRecurrenceConfiguration, ScheduleRecurrenceConfiguration..::..Property)
    Get
    Set

Field Value

The custom data sub query settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleQueryChildrenSettings Class
ScheduleQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration Class

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for the recurrence pattern of an IC Schedule.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScheduleRecurrenceConfiguration : EditableListConfigurationObject<ScheduleRecurrenceConfiguration..::..Property>
Visual Basic
Public Class ScheduleRecurrenceConfiguration _
    Inherits EditableListConfigurationObject(Of ScheduleRecurrenceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ScheduleRecurrenceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ScheduleRecurrenceConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ScheduleConfigurationList
ININ.IceLib.Configuration..::..ScheduleConfiguration


ScheduleRecurrenceConfiguration Members

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration Members
ScheduleRecurrenceConfiguration Class Methods Properties See Also Send Feedback

The ScheduleRecurrenceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | ScheduleRecurrenceConfiguration objects do not directly support commit, use the parent ScheduleConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDailyScheduleRecurrence(Date) | Sets a daily schedule that runs all day and has no end date.
Public method | SetDailyScheduleRecurrence(Date, Date) | Sets a daily schedule that runs all day.
Public method | SetDailyScheduleRecurrence(Date, Time, Time) | Sets a daily schedule that has no end date.
Public method | SetDailyScheduleRecurrence(Date, Date, Time, Time) | Sets a daily schedule.
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetMonthlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>)) | Sets a monthly schedule that runs all day on specific dates and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>)) | Sets a monthly schedule that runs all day on specific dates.
Public method | SetMonthlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType) | Sets a monthly schedule that runs all day on a relative day and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType) | Sets a monthly schedule that runs all day on a relative day.
Public method | SetMonthlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Time, Time) | Sets a monthly schedule that runs on specific dates and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Time, Time) | Sets a monthly schedule that runs on specific dates.
Public method | SetMonthlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time) | Sets a monthly schedule that runs on a relative day and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time) | Sets a monthly schedule that runs on a relative day.
Public method | SetOneTimeScheduleRecurrence(Date, Date) | Sets a one-time schedule that runs all day.
Public method | SetOneTimeScheduleRecurrence(Date, Date, Time, Time) | Sets a one-time schedule.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date) | Sets a weekly day span schedule that is active all day and has no end date.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Date) | Sets a weekly day span schedule that is active all day.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Time, Time) | Sets a weekly day span schedule with no end date.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Date, Time, Time) | Sets a weekly day span schedule.
Public method | SetWeeklyScheduleRecurrence(Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets a weekly schedule that runs all day on certain days and has no end date.
Public method | SetWeeklyScheduleRecurrence(Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets a weekly schedule that runs all day on certain days.
Public method | SetWeeklyScheduleRecurrence(Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time) | Sets a weekly schedule that runs on certain days and has no end date.
Public method | SetWeeklyScheduleRecurrence(Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time) | Sets a weekly schedule that runs on certain days.
Public method | SetYearlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Int32) | Sets a yearly schedule that runs all day on specific dates of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Int32) | Sets a yearly schedule that runs all day on specific dates of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32) | Sets a yearly schedule that runs all day on a relative day of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32) | Sets a yearly schedule that runs all day on a relative day of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Int32, Time, Time) | Sets a yearly schedule that runs on specific dates of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Int32, Time, Time) | Sets a yearly schedule that runs on specific dates of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time) | Sets a yearly schedule that runs on a relative day of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time) | Sets a yearly schedule that runs on a relative day of a particular month.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Dates | Provides access to the property representing the specific dates in a month for this schedule recurrence (use Property.Dates).
Public property | Days | Provides access to the property representing the days of the week for this schedule recurrence (use Property.Days).
Public property | EndDate | Provides access to the property representing the end date for this schedule (use Property.EndDate).
Public property | EndTime | Provides access to the property representing the end time for this schedule (use Property.EndTime).
Public property | IsAllDay | Provides access to the property representing whether or not this schedule recurrence runs the entire day (use Property.IsDay).
Public property | IsDaySpan | Provides access to the property representing whether this schedule recurrence is a day span (use Property.IsDaySpan).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsRelative | Provides access to the property representing whether this schedule recurrence is a relative day in the month, as opposed to specific dates (use Property.IsRelative).
Public property | Month | Provides access to the property representing the month for a yearly schedule recurrence (use Property.Month).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PatternType | Provides access to the property representing the recurrence pattern type for this schedule (use Property.PatternType).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | RelativeDay | Provides access to the property representing the relative day of the month for this schedule recurrence (use Property.RelativeDay).
Public property | RelativeMonthlyInstance | Provides access to the property representing the relative month of the year for this schedule recurrence (use Property.RelativeMonthlyInstance).
Public property | StartDate | Provides access to the property representing the start date for this recurrence (use Property.StartDate).
Public property | StartTime | Provides access to the property representing the start time for this recurrence (use Property.StartTime).
Public property | WeeklyEndTime | Provides access to the property representing the end time for a weekly day span schedule recurrence (use Property.WeeklyEndTime).
Public property | WeeklyStartTime | Provides access to the property representing the start time for a weekly day span schedule recurrence (use Property.WeeklyStartTime).

See Also

ScheduleRecurrenceConfiguration Class
ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration Methods

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration Methods
ScheduleRecurrenceConfiguration Class See Also Send Feedback

The ScheduleRecurrenceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | ScheduleRecurrenceConfiguration objects do not directly support commit, use the parent ScheduleConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDailyScheduleRecurrence(Date) | Sets a daily schedule that runs all day and has no end date.
Public method | SetDailyScheduleRecurrence(Date, Date) | Sets a daily schedule that runs all day.
Public method | SetDailyScheduleRecurrence(Date, Time, Time) | Sets a daily schedule that has no end date.
Public method | SetDailyScheduleRecurrence(Date, Date, Time, Time) | Sets a daily schedule.
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetMonthlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>)) | Sets a monthly schedule that runs all day on specific dates and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>)) | Sets a monthly schedule that runs all day on specific dates.
Public method | SetMonthlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType) | Sets a monthly schedule that runs all day on a relative day and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType) | Sets a monthly schedule that runs all day on a relative day.
Public method | SetMonthlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Time, Time) | Sets a monthly schedule that runs on specific dates and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Time, Time) | Sets a monthly schedule that runs on specific dates.
Public method | SetMonthlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time) | Sets a monthly schedule that runs on a relative day and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time) | Sets a monthly schedule that runs on a relative day.
Public method | SetOneTimeScheduleRecurrence(Date, Date) | Sets a one-time schedule that runs all day.
Public method | SetOneTimeScheduleRecurrence(Date, Date, Time, Time) | Sets a one-time schedule.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date) | Sets a weekly day span schedule that is active all day and has no end date.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Date) | Sets a weekly day span schedule that is active all day.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Time, Time) | Sets a weekly day span schedule with no end date.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Date, Time, Time) | Sets a weekly day span schedule.
Public method | SetWeeklyScheduleRecurrence(Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets a weekly schedule that runs all day on certain days and has no end date.
Public method | SetWeeklyScheduleRecurrence(Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets a weekly schedule that runs all day on certain days.
Public method | SetWeeklyScheduleRecurrence(Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time) | Sets a weekly schedule that runs on certain days and has no end date.
Public method | SetWeeklyScheduleRecurrence(Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time) | Sets a weekly schedule that runs on certain days.
Public method | SetYearlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Int32) | Sets a yearly schedule that runs all day on specific dates of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Int32) | Sets a yearly schedule that runs all day on specific dates of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32) | Sets a yearly schedule that runs all day on a relative day of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32) | Sets a yearly schedule that runs all day on a relative day of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Int32, Time, Time) | Sets a yearly schedule that runs on specific dates of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Int32, Time, Time) | Sets a yearly schedule that runs on specific dates of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time) | Sets a yearly schedule that runs on a relative day of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time) | Sets a yearly schedule that runs on a relative day of a particular month.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ScheduleRecurrenceConfiguration Class
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Commit Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback
ScheduleRecurrenceConfiguration objects do not directly support commit, use the parent ScheduleConfiguration's Commit()()()() instead.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Exceptions

Exception | Condition
System..::..NotSupportedException | ScheduleRecurrenceConfiguration objects do not directly support commit, use commit on the parent ScheduleConfiguration instead.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetDailyScheduleRecurrence Method

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetDailyScheduleRecurrence Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDailyScheduleRecurrence(Date) | Sets a daily schedule that runs all day and has no end date.
Public method | SetDailyScheduleRecurrence(Date, Date) | Sets a daily schedule that runs all day.
Public method | SetDailyScheduleRecurrence(Date, Time, Time) | Sets a daily schedule that has no end date.
Public method | SetDailyScheduleRecurrence(Date, Date, Time, Time) | Sets a daily schedule.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetDailyScheduleRecurrence Method (Date)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetDailyScheduleRecurrence Method (Date)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a daily schedule that runs all day and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDailyScheduleRecurrence(
    Date startDate
)
Visual Basic
Public Sub SetDailyScheduleRecurrence ( _
    startDate As Date _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetDailyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetDailyScheduleRecurrence Method (Date, Date)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetDailyScheduleRecurrence Method (Date, Date)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a daily schedule that runs all day.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDailyScheduleRecurrence(
    Date startDate,
    Date endDate
)
Visual Basic
Public Sub SetDailyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetDailyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetDailyScheduleRecurrence Method (Date, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetDailyScheduleRecurrence Method (Date, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a daily schedule that has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDailyScheduleRecurrence(
    Date startDate,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetDailyScheduleRecurrence ( _
    startDate As Date, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetDailyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetDailyScheduleRecurrence Method (Date, Date, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetDailyScheduleRecurrence Method (Date, Date, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a daily schedule.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDailyScheduleRecurrence(
    Date startDate,
    Date endDate,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetDailyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetDailyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetMonthlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>)) | Sets a monthly schedule that runs all day on specific dates and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>)) | Sets a monthly schedule that runs all day on specific dates.
Public method | SetMonthlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType) | Sets a monthly schedule that runs all day on a relative day and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType) | Sets a monthly schedule that runs all day on a relative day.
Public method | SetMonthlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Time, Time) | Sets a monthly schedule that runs on specific dates and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Time, Time) | Sets a monthly schedule that runs on specific dates.
Public method | SetMonthlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time) | Sets a monthly schedule that runs on a relative day and has no end date.
Public method | SetMonthlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time) | Sets a monthly schedule that runs on a relative day.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, Collection(Int32))

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, Collection<(Of <(<'Int32>)>)>)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs all day on specific dates and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    Collection<int> dates
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    dates As Collection(Of Integer) _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of each month when the schedule runs. Duplicate values will be ignored.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, Date, Collection(Int32))

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, Date, Collection<(Of <(<'Int32>)>)>)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs all day on specific dates.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    Collection<int> dates
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    dates As Collection(Of Integer) _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of each month when the schedule runs. Duplicate values will be ignored.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs all day on a relative day and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs all day on a relative day.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, Collection(Int32), Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, Collection<(Of <(<'Int32>)>)>, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs on specific dates and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    Collection<int> dates,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    dates As Collection(Of Integer), _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of each month when the schedule runs. Duplicate values will be ignored.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, Date, Collection(Int32), Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, Date, Collection<(Of <(<'Int32>)>)>, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs on specific dates.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    Collection<int> dates,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    dates As Collection(Of Integer), _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of each month when the schedule runs. Duplicate values will be ignored.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs on a relative day and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetMonthlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetMonthlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a monthly schedule that runs on a relative day.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMonthlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetMonthlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetMonthlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetOneTimeScheduleRecurrence Method

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetOneTimeScheduleRecurrence Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetOneTimeScheduleRecurrence(Date, Date) | Sets a one-time schedule that runs all day.
Public method | SetOneTimeScheduleRecurrence(Date, Date, Time, Time) | Sets a one-time schedule.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetOneTimeScheduleRecurrence Method (Date, Date)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetOneTimeScheduleRecurrence Method (Date, Date)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a one-time schedule that runs all day.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetOneTimeScheduleRecurrence(
    Date startDate,
    Date endDate
)
Visual Basic
Public Sub SetOneTimeScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetOneTimeScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetOneTimeScheduleRecurrence Method (Date, Date, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetOneTimeScheduleRecurrence Method (Date, Date, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a one-time schedule.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetOneTimeScheduleRecurrence(
    Date startDate,
    Date endDate,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetOneTimeScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetOneTimeScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyDaySpanScheduleRecurrence Method

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyDaySpanScheduleRecurrence Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date) | Sets a weekly day span schedule that is active all day and has no end date.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Date) | Sets a weekly day span schedule that is active all day.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Time, Time) | Sets a weekly day span schedule with no end date.
Public method | SetWeeklyDaySpanScheduleRecurrence(Int32, Time, Int32, Time, Date, Date, Time, Time) | Sets a weekly day span schedule.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly day span schedule that is active all day and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyDaySpanScheduleRecurrence(
    int fromDay,
    Time fromTime,
    int toDay,
    Time toTime,
    Date startDate
)
Visual Basic
Public Sub SetWeeklyDaySpanScheduleRecurrence ( _
    fromDay As Integer, _
    fromTime As Time, _
    toDay As Integer, _
    toTime As Time, _
    startDate As Date _
)

Parameters

fromDay
Type: System..::..Int32
The day of the week when the schedule starts.
fromTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule starts.
toDay
Type: System..::..Int32
The day of the week when the schedule ends.
toTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule ends.
startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.

Remarks

fromDay and toDay must be between 1 and 7; 1=Sunday, 2=Monday, 3=Tuesday, etc. If toDay is less than fromDay, the schedule will run into the next week.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyDaySpanScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date, Date)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date, Date)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly day span schedule that is active all day.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyDaySpanScheduleRecurrence(
    int fromDay,
    Time fromTime,
    int toDay,
    Time toTime,
    Date startDate,
    Date endDate
)
Visual Basic
Public Sub SetWeeklyDaySpanScheduleRecurrence ( _
    fromDay As Integer, _
    fromTime As Time, _
    toDay As Integer, _
    toTime As Time, _
    startDate As Date, _
    endDate As Date _
)

Parameters

fromDay
Type: System..::..Int32
The day of the week when the schedule starts.
fromTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule starts.
toDay
Type: System..::..Int32
The day of the week when the schedule ends.
toTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule ends.
startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.

Remarks

fromDay and toDay must be between 1 and 7; 1=Sunday, 2=Monday, 3=Tuesday, etc. If toDay is less than fromDay, the schedule will run into the next week.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyDaySpanScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly day span schedule with no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyDaySpanScheduleRecurrence(
    int fromDay,
    Time fromTime,
    int toDay,
    Time toTime,
    Date startDate,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetWeeklyDaySpanScheduleRecurrence ( _
    fromDay As Integer, _
    fromTime As Time, _
    toDay As Integer, _
    toTime As Time, _
    startDate As Date, _
    startTime As Time, _
    endTime As Time _
)

Parameters

fromDay
Type: System..::..Int32
The day of the week when the schedule starts.
fromTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule starts.
toDay
Type: System..::..Int32
The day of the week when the schedule ends.
toTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule ends.
startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts being active.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the after which the schedule is no longer active.

Remarks

fromDay and toDay must be between 1 and 7; 1=Sunday, 2=Monday, 3=Tuesday, etc. If toDay is less than fromDay, the schedule will run into the next week.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyDaySpanScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date, Date, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyDaySpanScheduleRecurrence Method (Int32, Time, Int32, Time, Date, Date, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly day span schedule.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyDaySpanScheduleRecurrence(
    int fromDay,
    Time fromTime,
    int toDay,
    Time toTime,
    Date startDate,
    Date endDate,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetWeeklyDaySpanScheduleRecurrence ( _
    fromDay As Integer, _
    fromTime As Time, _
    toDay As Integer, _
    toTime As Time, _
    startDate As Date, _
    endDate As Date, _
    startTime As Time, _
    endTime As Time _
)

Parameters

fromDay
Type: System..::..Int32
The day of the week when the schedule starts.
fromTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule starts.
toDay
Type: System..::..Int32
The day of the week when the schedule ends.
toTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day when the schedule ends.
startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts being active.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the after which the schedule is no longer active.

Remarks

fromDay and toDay must be between 1 and 7; 1=Sunday, 2=Monday, 3=Tuesday, etc. If toDay is less than fromDay, the schedule will run into the next week.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyDaySpanScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyScheduleRecurrence Method

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyScheduleRecurrence Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetWeeklyScheduleRecurrence(Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets a weekly schedule that runs all day on certain days and has no end date.
Public method | SetWeeklyScheduleRecurrence(Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets a weekly schedule that runs all day on certain days.
Public method | SetWeeklyScheduleRecurrence(Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time) | Sets a weekly schedule that runs on certain days and has no end date.
Public method | SetWeeklyScheduleRecurrence(Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time) | Sets a weekly schedule that runs on certain days.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetWeeklyScheduleRecurrence Method (Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyScheduleRecurrence Method (Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly schedule that runs all day on certain days and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyScheduleRecurrence(
    Date startDate,
    bool runMonday,
    bool runTuesday,
    bool runWednesday,
    bool runThursday,
    bool runFriday,
    bool runSaturday,
    bool runSunday
)
Visual Basic
Public Sub SetWeeklyScheduleRecurrence ( _
    startDate As Date, _
    runMonday As Boolean, _
    runTuesday As Boolean, _
    runWednesday As Boolean, _
    runThursday As Boolean, _
    runFriday As Boolean, _
    runSaturday As Boolean, _
    runSunday As Boolean _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
runMonday
Type: System..::..Boolean
Whether or not the schedule runs on Monday.
runTuesday
Type: System..::..Boolean
Whether or not the schedule runs on Tuesday.
runWednesday
Type: System..::..Boolean
Whether or not the schedule runs on Wednesday.
runThursday
Type: System..::..Boolean
Whether or not the schedule runs on Thursday.
runFriday
Type: System..::..Boolean
Whether or not the schedule runs on Friday.
runSaturday
Type: System..::..Boolean
Whether or not the schedule runs on Saturday.
runSunday
Type: System..::..Boolean
Whether or not the schedule runs on Sunday.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyScheduleRecurrence Method (Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyScheduleRecurrence Method (Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly schedule that runs all day on certain days.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyScheduleRecurrence(
    Date startDate,
    Date endDate,
    bool runMonday,
    bool runTuesday,
    bool runWednesday,
    bool runThursday,
    bool runFriday,
    bool runSaturday,
    bool runSunday
)
Visual Basic
Public Sub SetWeeklyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    runMonday As Boolean, _
    runTuesday As Boolean, _
    runWednesday As Boolean, _
    runThursday As Boolean, _
    runFriday As Boolean, _
    runSaturday As Boolean, _
    runSunday As Boolean _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
runMonday
Type: System..::..Boolean
Whether or not the schedule runs on Monday.
runTuesday
Type: System..::..Boolean
Whether or not the schedule runs on Tuesday.
runWednesday
Type: System..::..Boolean
Whether or not the schedule runs on Wednesday.
runThursday
Type: System..::..Boolean
Whether or not the schedule runs on Thursday.
runFriday
Type: System..::..Boolean
Whether or not the schedule runs on Friday.
runSaturday
Type: System..::..Boolean
Whether or not the schedule runs on Saturday.
runSunday
Type: System..::..Boolean
Whether or not the schedule runs on Sunday.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyScheduleRecurrence Method (Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyScheduleRecurrence Method (Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly schedule that runs on certain days and has no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyScheduleRecurrence(
    Date startDate,
    bool runMonday,
    bool runTuesday,
    bool runWednesday,
    bool runThursday,
    bool runFriday,
    bool runSaturday,
    bool runSunday,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetWeeklyScheduleRecurrence ( _
    startDate As Date, _
    runMonday As Boolean, _
    runTuesday As Boolean, _
    runWednesday As Boolean, _
    runThursday As Boolean, _
    runFriday As Boolean, _
    runSaturday As Boolean, _
    runSunday As Boolean, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
runMonday
Type: System..::..Boolean
Whether or not the schedule runs on Monday.
runTuesday
Type: System..::..Boolean
Whether or not the schedule runs on Tuesday.
runWednesday
Type: System..::..Boolean
Whether or not the schedule runs on Wednesday.
runThursday
Type: System..::..Boolean
Whether or not the schedule runs on Thursday.
runFriday
Type: System..::..Boolean
Whether or not the schedule runs on Friday.
runSaturday
Type: System..::..Boolean
Whether or not the schedule runs on Saturday.
runSunday
Type: System..::..Boolean
Whether or not the schedule runs on Sunday.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetWeeklyScheduleRecurrence Method (Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetWeeklyScheduleRecurrence Method (Date, Date, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a weekly schedule that runs on certain days.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetWeeklyScheduleRecurrence(
    Date startDate,
    Date endDate,
    bool runMonday,
    bool runTuesday,
    bool runWednesday,
    bool runThursday,
    bool runFriday,
    bool runSaturday,
    bool runSunday,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetWeeklyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    runMonday As Boolean, _
    runTuesday As Boolean, _
    runWednesday As Boolean, _
    runThursday As Boolean, _
    runFriday As Boolean, _
    runSaturday As Boolean, _
    runSunday As Boolean, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
runMonday
Type: System..::..Boolean
Whether or not the schedule runs on Monday.
runTuesday
Type: System..::..Boolean
Whether or not the schedule runs on Tuesday.
runWednesday
Type: System..::..Boolean
Whether or not the schedule runs on Wednesday.
runThursday
Type: System..::..Boolean
Whether or not the schedule runs on Thursday.
runFriday
Type: System..::..Boolean
Whether or not the schedule runs on Friday.
runSaturday
Type: System..::..Boolean
Whether or not the schedule runs on Saturday.
runSunday
Type: System..::..Boolean
Whether or not the schedule runs on Sunday.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetWeeklyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method
ScheduleRecurrenceConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetYearlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Int32) | Sets a yearly schedule that runs all day on specific dates of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Int32) | Sets a yearly schedule that runs all day on specific dates of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32) | Sets a yearly schedule that runs all day on a relative day of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32) | Sets a yearly schedule that runs all day on a relative day of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, Collection<(Of <<'(Int32>)>>), Int32, Time, Time) | Sets a yearly schedule that runs on specific dates of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, Collection<(Of <<'(Int32>)>>), Int32, Time, Time) | Sets a yearly schedule that runs on specific dates of a particular month.
Public method | SetYearlyScheduleRecurrence(Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time) | Sets a yearly schedule that runs on a relative day of a particular month, with no end date.
Public method | SetYearlyScheduleRecurrence(Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time) | Sets a yearly schedule that runs on a relative day of a particular month.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, Collection(Int32), Int32)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, Collection<(Of <(<'Int32>)>)>, Int32)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs all day on specific dates of a particular month, with no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    Collection<int> dates,
    int month
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    dates As Collection(Of Integer), _
    month As Integer _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of the month when the schedule runs. Duplicate values will be ignored.
month
Type: System..::..Int32

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, Date, Collection(Int32), Int32)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, Date, Collection<(Of <(<'Int32>)>)>, Int32)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs all day on specific dates of a particular month.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    Collection<int> dates,
    int month
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    dates As Collection(Of Integer), _
    month As Integer _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of the month when the schedule runs. Duplicate values will be ignored.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs all day on a relative day of a particular month, with no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay,
    int month
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType, _
    month As Integer _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs all day on a relative day of a particular month.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay,
    int month
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType, _
    month As Integer _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, Collection(Int32), Int32, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, Collection<(Of <(<'Int32>)>)>, Int32, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs on specific dates of a particular month, with no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    Collection<int> dates,
    int month,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    dates As Collection(Of Integer), _
    month As Integer, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of the month when the schedule runs. Duplicate values will be ignored.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, Date, Collection(Int32), Int32, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, Date, Collection<(Of <(<'Int32>)>)>, Int32, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs on specific dates of a particular month.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    Collection<int> dates,
    int month,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    dates As Collection(Of Integer), _
    month As Integer, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
dates
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'Int32>)>)>
The dates of the month when the schedule runs. Duplicate values will be ignored.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs on a relative day of a particular month, with no end date.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay,
    int month,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType, _
    month As Integer, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


SetYearlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time)

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..SetYearlyScheduleRecurrence Method (Date, Date, RecurrenceRelativeMonthlyType, RecurrenceRelativeDayType, Int32, Time, Time)
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Sets a yearly schedule that runs on a relative day of a particular month.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetYearlyScheduleRecurrence(
    Date startDate,
    Date endDate,
    RecurrenceRelativeMonthlyType relativeMonthlyInstance,
    RecurrenceRelativeDayType relativeDay,
    int month,
    Time startTime,
    Time endTime
)
Visual Basic
Public Sub SetYearlyScheduleRecurrence ( _
    startDate As Date, _
    endDate As Date, _
    relativeMonthlyInstance As RecurrenceRelativeMonthlyType, _
    relativeDay As RecurrenceRelativeDayType, _
    month As Integer, _
    startTime As Time, _
    endTime As Time _
)

Parameters

startDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule first becomes active.
endDate
Type: ININ.IceLib.Configuration.DataTypes..::..Date
The date when the schedule stops being active.
relativeMonthlyInstance
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeMonthlyType
With relativeDay, defines when in the month the schedule runs.
relativeDay
Type: ININ.IceLib.Configuration.DataTypes..::..RecurrenceRelativeDayType
With relativeMonthlyInstance, defines when in the month the schedule runs.
month
Type: System..::..Int32
The month when the schedule runs; 1=January, 2=February, etc.
startTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule starts.
endTime
Type: ININ.IceLib.Configuration.DataTypes..::..Time
The time of day the schedule ends.

Remarks

month must be between 1 and 12.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
SetYearlyScheduleRecurrence Overload
ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration Properties

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration Properties
ScheduleRecurrenceConfiguration Class See Also Send Feedback

The ScheduleRecurrenceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Dates | Provides access to the property representing the specific dates in a month for this schedule recurrence (use Property.Dates).
Public property | Days | Provides access to the property representing the days of the week for this schedule recurrence (use Property.Days).
Public property | EndDate | Provides access to the property representing the end date for this schedule (use Property.EndDate).
Public property | EndTime | Provides access to the property representing the end time for this schedule (use Property.EndTime).
Public property | IsAllDay | Provides access to the property representing whether or not this schedule recurrence runs the entire day (use Property.IsDay).
Public property | IsDaySpan | Provides access to the property representing whether this schedule recurrence is a day span (use Property.IsDaySpan).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsRelative | Provides access to the property representing whether this schedule recurrence is a relative day in the month, as opposed to specific dates (use Property.IsRelative).
Public property | Month | Provides access to the property representing the month for a yearly schedule recurrence (use Property.Month).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PatternType | Provides access to the property representing the recurrence pattern type for this schedule (use Property.PatternType).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | RelativeDay | Provides access to the property representing the relative day of the month for this schedule recurrence (use Property.RelativeDay).
Public property | RelativeMonthlyInstance | Provides access to the property representing the relative month of the year for this schedule recurrence (use Property.RelativeMonthlyInstance).
Public property | StartDate | Provides access to the property representing the start date for this recurrence (use Property.StartDate).
Public property | StartTime | Provides access to the property representing the start time for this recurrence (use Property.StartTime).
Public property | WeeklyEndTime | Provides access to the property representing the end time for a weekly day span schedule recurrence (use Property.WeeklyEndTime).
Public property | WeeklyStartTime | Provides access to the property representing the start time for a weekly day span schedule recurrence (use Property.WeeklyStartTime).

See Also

ScheduleRecurrenceConfiguration Class
ININ.IceLib.Configuration Namespace


Dates Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Dates Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the specific dates in a month for this schedule recurrence (use Property.Dates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Collection<int>> Dates { get; }
Visual Basic
Public ReadOnly Property Dates As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Collection(Of Integer))
    Get

Field Value

The property representing the dates in a month.

Remarks

Valid values are in the range [1,31]. This property only applies when PatternType is Monthly or Yearly. If IsRelative is true, this property will be ignored.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


Days Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Days Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the days of the week for this schedule recurrence (use Property.Days).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Collection<int>> Days { get; }
Visual Basic
Public ReadOnly Property Days As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Collection(Of Integer))
    Get

Field Value

The property representing the days in a week.

Remarks

PatternType is Weekly and IsDaySpan is false: Valid values are in the range [1,7], with 1=Sunday, 2=Monday, etc. The entries are the days the schedule will run. PatternType is Weekly and IsDaySpan is true: There should be exactly two entries, for start day and end day. This property does not apply to other patterns.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


EndDate Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..EndDate Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the end date for this schedule (use Property.EndDate).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Date> EndDate { get; }
Visual Basic
Public ReadOnly Property EndDate As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Date)
    Get

Field Value

The property representing the end date.

Remarks

This property is required for all schedule recurrence patterns. Unless PatternType is OneTime, the schedule can be set to be active forever by setting to MinDate.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


EndTime Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..EndTime Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the end time for this schedule (use Property.EndTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Time> EndTime { get; }
Visual Basic
Public ReadOnly Property EndTime As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Time)
    Get

Field Value

The property representing the end time.

Remarks

It should be set to MinTime for an all-day schedule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


IsAllDay Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..IsAllDay Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing whether or not this schedule recurrence runs the entire day (use Property.IsDay).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, bool> IsAllDay { get; }
Visual Basic
Public ReadOnly Property IsAllDay As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the all-day indicator.

Remarks

This property is read-only. To define an all-day schedule, set both EndTime and StartTime to MinTime.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


IsDaySpan Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..IsDaySpan Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing whether this schedule recurrence is a day span (use Property.IsDaySpan).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, bool> IsDaySpan { get; }
Visual Basic
Public ReadOnly Property IsDaySpan As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the day span indicator.

Remarks

This property only applies when PatternType is Weekly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


IsRelative Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..IsRelative Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing whether this schedule recurrence is a relative day in the month, as opposed to specific dates (use Property.IsRelative).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, bool> IsRelative { get; }
Visual Basic
Public ReadOnly Property IsRelative As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the relative indicator.

Remarks

This property only applies when PatternType is Monthly or Yearly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


Month Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Month Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the month for a yearly schedule recurrence (use Property.Month).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, int> Month { get; }
Visual Basic
Public ReadOnly Property Month As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the month.

Remarks

Valid values are in the range [1,12]. This property only applies when PatternType is Monthly or Yearly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


PatternType Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..PatternType Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the recurrence pattern type for this schedule (use Property.PatternType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, RecurrencePatternType> PatternType { get; }
Visual Basic
Public ReadOnly Property PatternType As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, RecurrencePatternType)
    Get

Field Value

The property representing the recurrence pattern type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..PropertiesChanged Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ScheduleRecurrenceConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ScheduleRecurrenceConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


RelativeDay Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..RelativeDay Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the relative day of the month for this schedule recurrence (use Property.RelativeDay).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, RecurrenceRelativeDayType> RelativeDay { get; }
Visual Basic
Public ReadOnly Property RelativeDay As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, RecurrenceRelativeDayType)
    Get

Field Value

The property representing the relative day of the month.

Remarks

This property only applies if PatternType is Monthly or Yearly and IsRelative is true.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


RelativeMonthlyInstance Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..RelativeMonthlyInstance Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the relative month of the year for this schedule recurrence (use Property.RelativeMonthlyInstance).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, RecurrenceRelativeMonthlyType> RelativeMonthlyInstance { get; }
Visual Basic
Public ReadOnly Property RelativeMonthlyInstance As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, RecurrenceRelativeMonthlyType)
    Get

Field Value

The property representing the relative month in a year.

Remarks

This property only applies when PatternType is Monthly or Yearly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


StartDate Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..StartDate Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the start date for this recurrence (use Property.StartDate).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Date> StartDate { get; }
Visual Basic
Public ReadOnly Property StartDate As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Date)
    Get

Field Value

The property representing the start date.

Remarks

This property is required for all schedule recurrence patterns.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


StartTime Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..StartTime Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the start time for this recurrence (use Property.StartTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Time> StartTime { get; }
Visual Basic
Public ReadOnly Property StartTime As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Time)
    Get

Field Value

The property representing the start time.

Remarks

It should be set to MinTime for an all-day schedule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


WeeklyEndTime Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..WeeklyEndTime Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the end time for a weekly day span schedule recurrence (use Property.WeeklyEndTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Time> WeeklyEndTime { get; }
Visual Basic
Public ReadOnly Property WeeklyEndTime As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Time)
    Get

Field Value

The property representing the end time of the span.

Remarks

This property only applies when PatternType is Weekly and IsDaySpan is true. It will be ignored for all other patterns.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


WeeklyStartTime Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..WeeklyStartTime Property
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Provides access to the property representing the start time for a weekly day span schedule recurrence (use Property.WeeklyStartTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ScheduleRecurrenceConfiguration..::..Property, Time> WeeklyStartTime { get; }
Visual Basic
Public ReadOnly Property WeeklyStartTime As GeneralConfigurationProperty(Of ScheduleRecurrenceConfiguration..::..Property, Time)
    Get

Field Value

The property representing the start time of the span.

Remarks

This property only applies when PatternType is Weekly and IsDaySpan is true. It will be ignored for all other patterns.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration Class
ScheduleRecurrenceConfiguration Members
ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Property Enumeration
ScheduleRecurrenceConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Dates | 0 | Represents the Dates property.
Days | 1 | Represents the Days property.
EndDate | 2 | Represents the EndDate property.
EndTime | 3 | Represents the EndTime property.
IsAllDay | 4 | Represents the IsAllDay property.
IsDaySpan | 5 | Represents the IsDaySpan property.
IsRelative | 6 | Represents the IsRelative property.
Month | 7 | Represents the Month property.
PatternType | 8 | Represents the PatternType property.
RelativeDay | 9 | Represents the RelativeDay property.
RelativeMonthlyInstance | 10 | Represents the RelativeMonthlyInstance property.
StartDate | 11 | Represents the StartDate property.
StartTime | 12 | Represents the StartTime property.
WeeklyEndTime | 13 | Represents the WeeklyEndTime property.
WeeklyStartTime | 14 | Represents the WeeklyStartTime property.
DisplayName | 15 | Represents the DisplayName part of the ConfigurationId property.
Id | 16 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration.Rights Class

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Rights Class
ScheduleRecurrenceConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ScheduleRecurrenceConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Rights Members
ScheduleRecurrenceConfiguration..::..Rights Class Properties See Also Send Feedback

The ScheduleRecurrenceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ScheduleRecurrenceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ScheduleRecurrenceConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Rights Properties
ScheduleRecurrenceConfiguration..::..Rights Class See Also Send Feedback

The ScheduleRecurrenceConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ScheduleRecurrenceConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Rights..::..Admin Property
ScheduleRecurrenceConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ScheduleRecurrenceConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ScheduleRecurrenceConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration..::..Rights Class
ScheduleRecurrenceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
ScheduleRecurrenceConfiguration..::..Rights..::..View Property
ScheduleRecurrenceConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ScheduleRecurrenceConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ScheduleRecurrenceConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleRecurrenceConfiguration..::..Rights Class
ScheduleRecurrenceConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration Class

[image]

IceLib Technical Reference
SecureInputFormConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a secure input form configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecureInputFormConfiguration : EditableListConfigurationObject<SecureInputFormConfiguration..::..Property>
Visual Basic
Public Class SecureInputFormConfiguration _
    Inherits EditableListConfigurationObject(Of SecureInputFormConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' SecureInputFormConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SecureInputFormConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration Members

[image] [image]

IceLib Technical Reference
SecureInputFormConfiguration Members
SecureInputFormConfiguration Class Methods Properties See Also Send Feedback

The SecureInputFormConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIvrHandlers | Gets the IVR handlers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

Name Description
Public property Changed
Indicates if this object has been modified since it was retrieved from the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property ConfigurationId
Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.)
(Inherited from ListConfigurationObject.)
Public property CustomParameters
Provides access to the property representing the custom parameters (use Property.CustomParameters).

Remarks

This property is only valid when FormType is Custom.
Public property Description
Provides access to the property representing the description (use Property.Description).
Public property FormFields
Provides access to the property representing the form fields (use Property.FormFields).

Remarks

This property is only valid when FormType is Simple.
Public property FormName
Provides access to the property representing the form name (use Property.FormName).
Public property FormType
Provides access to the property representing the form type (use Property.FormType).
Public property IsNewObject
Gets a value indicating whether this object is a new object.
(Inherited from ConfigurationObject.)
Public property IvrHandlerName
Provides access to the property representing the ivr handler name (use Property.IvrHandlerName).

Remarks

Valid values can be retrieved from GetIvrHandlers(ConfigurationManager).
Public property OriginalConfigurationId
Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit.
(Inherited from ListConfigurationObject.)
Public property PropertiesChanged
Gets the properties that have been changed.
Public property StandardProperties
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SecureInputFormConfiguration Class
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration Methods

[image] [image]

IceLib Technical Reference
SecureInputFormConfiguration Methods
SecureInputFormConfiguration Class See Also Send Feedback

The SecureInputFormConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIvrHandlers | Gets the IVR handlers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SecureInputFormConfiguration Class
ININ.IceLib.Configuration Namespace


GetIvrHandlers Method

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..GetIvrHandlers Method
SecureInputFormConfiguration Class See Also Send Feedback
Gets the IVR handlers.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<string> GetIvrHandlers(
    ConfigurationManager configurationManager
)
Visual Basic
Public Shared Function GetIvrHandlers ( _
    configurationManager As ConfigurationManager _
) As ReadOnlyCollection(Of String)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Return Value

The IVR handlers.

Exceptions

Exception | Condition
System..::..ArgumentNullException | configurationManager is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration Properties

[image] [image]

IceLib Technical Reference
SecureInputFormConfiguration Properties
SecureInputFormConfiguration Class See Also Send Feedback

The SecureInputFormConfiguration type exposes the following members.

Properties

Name Description
Public property Changed
Indicates if this object has been modified since it was retrieved from the server.
(Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property ConfigurationId
Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.)
(Inherited from ListConfigurationObject.)
Public property CustomParameters
Provides access to the property representing the custom parameters (use Property.CustomParameters).

Remarks

This property is only valid when FormType is Custom.
Public property Description
Provides access to the property representing the description (use Property.Description).
Public property FormFields
Provides access to the property representing the form fields (use Property.FormFields).

Remarks

This property is only valid when FormType is Simple.
Public property FormName
Provides access to the property representing the form name (use Property.FormName).
Public property FormType
Provides access to the property representing the form type (use Property.FormType).
Public property IsNewObject
Gets a value indicating whether this object is a new object.
(Inherited from ConfigurationObject.)
Public property IvrHandlerName
Provides access to the property representing the ivr handler name (use Property.IvrHandlerName).

Remarks

Valid values can be retrieved from GetIvrHandlers(ConfigurationManager).
Public property OriginalConfigurationId
Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit.
(Inherited from ListConfigurationObject.)
Public property PropertiesChanged
Gets the properties that have been changed.
Public property StandardProperties
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SecureInputFormConfiguration Class
ININ.IceLib.Configuration Namespace


CustomParameters Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..CustomParameters Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the property representing the custom parameters (use Property.CustomParameters).

Remarks

This property is only valid when FormType is Custom.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SecureInputFormConfiguration..::..Property, IDictionary<string, string>> CustomParameters { get; }
Visual Basic
Public ReadOnly Property CustomParameters As GeneralConfigurationProperty(Of SecureInputFormConfiguration..::..Property, IDictionary(Of String, String))
    Get

Field Value

The property representing the custom parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Description Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the property representing the description (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SecureInputFormConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of SecureInputFormConfiguration..::..Property, String)
    Get

Field Value

The property representing the description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


FormFields Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..FormFields Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the property representing the form fields (use Property.FormFields).

Remarks

This property is only valid when FormType is Simple.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SecureInputFormConfiguration..::..Property, Collection<SecureInputFormFieldDefinition>> FormFields { get; }
Visual Basic
Public ReadOnly Property FormFields As GeneralConfigurationProperty(Of SecureInputFormConfiguration..::..Property, Collection(Of SecureInputFormFieldDefinition))
    Get

Field Value

The property representing the form fields.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


FormName Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..FormName Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the property representing the form name (use Property.FormName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SecureInputFormConfiguration..::..Property, string> FormName { get; }
Visual Basic
Public ReadOnly Property FormName As GeneralConfigurationProperty(Of SecureInputFormConfiguration..::..Property, String)
    Get

Field Value

The property representing the form name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


FormType Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..FormType Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the property representing the form type (use Property.FormType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SecureInputFormConfiguration..::..Property, SecureInputFormType> FormType { get; }
Visual Basic
Public ReadOnly Property FormType As GeneralConfigurationProperty(Of SecureInputFormConfiguration..::..Property, SecureInputFormType)
    Get

Field Value

The property representing the form type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


IvrHandlerName Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..IvrHandlerName Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the property representing the ivr handler name (use Property.IvrHandlerName).

Remarks

Valid values can be retrieved from GetIvrHandlers(ConfigurationManager).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SecureInputFormConfiguration..::..Property, string> IvrHandlerName { get; }
Visual Basic
Public ReadOnly Property IvrHandlerName As GeneralConfigurationProperty(Of SecureInputFormConfiguration..::..Property, String)
    Get

Field Value

The property representing the ivr handler name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..PropertiesChanged Property
SecureInputFormConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SecureInputFormConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of SecureInputFormConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..StandardProperties Property
SecureInputFormConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration Class
SecureInputFormConfiguration Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Property Enumeration
SecureInputFormConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
CustomParameters | 0 | Represents the CustomParameters property.
Description | 1 | Represents the Description property.
FormFields | 2 | Represents the FormFields property.
FormName | 3 | Represents the FormName property.
FormType | 4 | Represents the FormType property.
IvrHandlerName | 5 | Represents the IvrHandlerName property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration.Rights Class

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Rights Class
SecureInputFormConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SecureInputFormConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Rights Members
SecureInputFormConfiguration..::..Rights Class Properties See Also Send Feedback

The SecureInputFormConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SecureInputFormConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SecureInputFormConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Rights Properties
SecureInputFormConfiguration..::..Rights Class See Also Send Feedback

The SecureInputFormConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SecureInputFormConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Rights..::..Admin Property
SecureInputFormConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SecureInputFormConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SecureInputFormConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration..::..Rights Class
SecureInputFormConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SecureInputForms


View Property

[image]

IceLib Technical Reference
SecureInputFormConfiguration..::..Rights..::..View Property
SecureInputFormConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SecureInputFormConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SecureInputFormConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfiguration..::..Rights Class
SecureInputFormConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfigurationList Class

[image]

IceLib Technical Reference
SecureInputFormConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing SecureInputForm configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecureInputFormConfigurationList : EditableConfigurationList<SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property>
Visual Basic
Public Class SecureInputFormConfigurationList _
    Inherits EditableConfigurationList(Of SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' SecureInputFormConfiguration, SecureInputFormConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SecureInputFormConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfigurationList Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfigurationList Members

[image] [image]

IceLib Technical Reference
SecureInputFormConfigurationList Members
SecureInputFormConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SecureInputFormConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SecureInputFormConfigurationList | Initializes a new instance of the SecureInputFormConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SecureInputFormConfigurationList Class
ININ.IceLib.Configuration Namespace


SecureInputFormConfigurationList Constructor

[image]

IceLib Technical Reference
SecureInputFormConfigurationList Constructor
SecureInputFormConfigurationList Class See Also Send Feedback
Initializes a new instance of the SecureInputFormConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureInputFormConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormConfigurationList Class
SecureInputFormConfigurationList Members
ININ.IceLib.Configuration Namespace


SecureInputFormConfigurationList Methods

[image] [image]

IceLib Technical Reference
SecureInputFormConfigurationList Methods
SecureInputFormConfigurationList Class See Also Send Feedback

The SecureInputFormConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecureInputFormConfigurationList Class
ININ.IceLib.Configuration Namespace


SecureInputFormConfigurationList Properties

[image] [image]

IceLib Technical Reference
SecureInputFormConfigurationList Properties
SecureInputFormConfigurationList Class See Also Send Feedback

The SecureInputFormConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SecureInputFormConfigurationList Class
ININ.IceLib.Configuration Namespace


SecureInputFormConfigurationList Events

[image] [image]

IceLib Technical Reference
SecureInputFormConfigurationList Events
SecureInputFormConfigurationList Class See Also Send Feedback

The SecureInputFormConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SecureInputFormConfigurationList Class
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration Class

[image]

IceLib Technical Reference
SelectionRuleConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Selection Rules.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SelectionRuleConfiguration : ListConfigurationObject
Visual Basic
Public Class SelectionRuleConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SelectionRuleConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfiguration Members
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration Members

[image] [image]

IceLib Technical Reference
SelectionRuleConfiguration Members
SelectionRuleConfiguration Class Methods Properties See Also Send Feedback

The SelectionRuleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SelectionRuleConfiguration Class
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration Methods

[image] [image]

IceLib Technical Reference
SelectionRuleConfiguration Methods
SelectionRuleConfiguration Class See Also Send Feedback

The SelectionRuleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SelectionRuleConfiguration Class
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration Properties

[image] [image]

IceLib Technical Reference
SelectionRuleConfiguration Properties
SelectionRuleConfiguration Class See Also Send Feedback

The SelectionRuleConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SelectionRuleConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SelectionRuleConfiguration..::..StandardProperties Property
SelectionRuleConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SelectionRuleConfiguration, SelectionRuleConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SelectionRuleConfiguration, SelectionRuleConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfiguration Class
SelectionRuleConfiguration Members
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SelectionRuleConfiguration..::..Property Enumeration
SelectionRuleConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration.Rights Class

[image]

IceLib Technical Reference
SelectionRuleConfiguration..::..Rights Class
SelectionRuleConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SelectionRuleConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SelectionRuleConfiguration..::..Rights Members
SelectionRuleConfiguration..::..Rights Class Properties See Also Send Feedback

The SelectionRuleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SelectionRuleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SelectionRuleConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SelectionRuleConfiguration..::..Rights Properties
SelectionRuleConfiguration..::..Rights Class See Also Send Feedback

The SelectionRuleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SelectionRuleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SelectionRuleConfiguration..::..Rights..::..Admin Property
SelectionRuleConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SelectionRuleConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SelectionRuleConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfiguration..::..Rights Class
SelectionRuleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SelectionRuleList


View Property

[image]

IceLib Technical Reference
SelectionRuleConfiguration..::..Rights..::..View Property
SelectionRuleConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SelectionRuleConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SelectionRuleConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfiguration..::..Rights Class
SelectionRuleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SelectionRuleConfigurationList Class

[image]

IceLib Technical Reference
SelectionRuleConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Selection Rule configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SelectionRuleConfigurationList : ConfigurationList<SelectionRuleConfiguration, SelectionRuleConfiguration..::..Property>
Visual Basic
Public Class SelectionRuleConfigurationList _
    Inherits ConfigurationList(Of SelectionRuleConfiguration, SelectionRuleConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SelectionRuleConfiguration, SelectionRuleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SelectionRuleConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfigurationList Members
ININ.IceLib.Configuration Namespace


SelectionRuleConfigurationList Members

[image] [image]

IceLib Technical Reference
SelectionRuleConfigurationList Members
SelectionRuleConfigurationList Class Constructors Methods Properties See Also Send Feedback

The SelectionRuleConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SelectionRuleConfigurationList | Initializes a new instance of the SelectionRuleConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SelectionRuleConfigurationList Class
ININ.IceLib.Configuration Namespace


SelectionRuleConfigurationList Constructor

[image]

IceLib Technical Reference
SelectionRuleConfigurationList Constructor
SelectionRuleConfigurationList Class See Also Send Feedback
Initializes a new instance of the SelectionRuleConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SelectionRuleConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SelectionRuleConfigurationList Class
SelectionRuleConfigurationList Members
ININ.IceLib.Configuration Namespace


SelectionRuleConfigurationList Methods

[image] [image]

IceLib Technical Reference
SelectionRuleConfigurationList Methods
SelectionRuleConfigurationList Class See Also Send Feedback

The SelectionRuleConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionRuleConfigurationList Class
ININ.IceLib.Configuration Namespace


SelectionRuleConfigurationList Properties

[image] [image]

IceLib Technical Reference
SelectionRuleConfigurationList Properties
SelectionRuleConfigurationList Class See Also Send Feedback

The SelectionRuleConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SelectionRuleConfigurationList Class
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration Class

[image]

IceLib Technical Reference
ServerParameterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC ServerParameter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerParameterConfiguration : EditableListConfigurationObject<ServerParameterConfiguration..::..Property>
Visual Basic
Public Class ServerParameterConfiguration _
    Inherits EditableListConfigurationObject(Of ServerParameterConfiguration..::..Property)

Remarks

Currently, calling Delete()()()() is not supported, and will result in a ServerOperationNotSupportedException.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ServerParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ServerParameterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfiguration Members
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration Members

[image] [image]

IceLib Technical Reference
ServerParameterConfiguration Members
ServerParameterConfiguration Class Methods Properties See Also Send Feedback

The ServerParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Value | Provides access to the property representing the Value (use Property.Value).

See Also

ServerParameterConfiguration Class
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration Methods

[image] [image]

IceLib Technical Reference
ServerParameterConfiguration Methods
ServerParameterConfiguration Class See Also Send Feedback

The ServerParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ServerParameterConfiguration Class
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration Properties

[image] [image]

IceLib Technical Reference
ServerParameterConfiguration Properties
ServerParameterConfiguration Class See Also Send Feedback

The ServerParameterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Value | Provides access to the property representing the Value (use Property.Value).

See Also

ServerParameterConfiguration Class
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..PropertiesChanged Property
ServerParameterConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ServerParameterConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ServerParameterConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ServerParameterConfiguration Class
ServerParameterConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..StandardProperties Property
ServerParameterConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ServerParameterConfiguration, ServerParameterConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ServerParameterConfiguration, ServerParameterConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfiguration Class
ServerParameterConfiguration Members
ININ.IceLib.Configuration Namespace


Value Property

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..Value Property
ServerParameterConfiguration Class See Also Send Feedback
Provides access to the property representing the Value (use Property.Value).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ServerParameterConfiguration..::..Property, string> Value { get; }
Visual Basic
Public ReadOnly Property Value As GeneralConfigurationProperty(Of ServerParameterConfiguration..::..Property, String)
    Get

Field Value

The property representing the Value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ServerParameterConfiguration Class
ServerParameterConfiguration Members
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..Property Enumeration
ServerParameterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Value | 0 | Represents the Value property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


ServerParameterConfiguration.Rights Class

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..Rights Class
ServerParameterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ServerParameterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ServerParameterConfiguration..::..Rights Members
ServerParameterConfiguration..::..Rights Class Properties See Also Send Feedback

The ServerParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ServerParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ServerParameterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ServerParameterConfiguration..::..Rights Properties
ServerParameterConfiguration..::..Rights Class See Also Send Feedback

The ServerParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ServerParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..Rights..::..Admin Property
ServerParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ServerParameterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ServerParameterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfiguration..::..Rights Class
ServerParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ServerParameter


View Property

[image]

IceLib Technical Reference
ServerParameterConfiguration..::..Rights..::..View Property
ServerParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ServerParameterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ServerParameterConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfiguration..::..Rights Class
ServerParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ServerParameterConfigurationList Class

[image]

IceLib Technical Reference
ServerParameterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing ServerParameter configuration objects and provides convenience functions for accessing some well-known parameters.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerParameterConfigurationList : EditableConfigurationList<ServerParameterConfiguration, ServerParameterConfiguration..::..Property>
Visual Basic
Public Class ServerParameterConfigurationList _
    Inherits EditableConfigurationList(Of ServerParameterConfiguration, ServerParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ServerParameterConfiguration, ServerParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ServerParameterConfiguration, ServerParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ServerParameterConfiguration, ServerParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ServerParameterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


ServerParameterConfigurationList Members

[image] [image]

IceLib Technical Reference
ServerParameterConfigurationList Members
ServerParameterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ServerParameterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ServerParameterConfigurationList | Initializes a new instance of the ServerParameterConfigurationList class.

Methods

Name Description
Public method ChangeWatchQuerySettings
Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method ChangeWatchQuerySettingsAsync
Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method CreateObject
Creates a new object in the list.
(Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method CreateObjectAsync
Asynchronously creates a new object in the list.
(Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method CreateQuerySettings
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetConfigurationList
Gets the configuration list.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsDialerEnabled
Queries the server for whether Dialer is enabled on the server.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method RefreshWatch
Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method RefreshWatchAsync
Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCaching()()()()
Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Starts caching the specified configuration objects.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCachingAsync(AsyncCompletedEventHandler, Object)
Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
Asynchronously starts caching the specified configuration objects.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatching()()()()
Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Starts watching the specified configuration objects.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatchingAsync(AsyncCompletedEventHandler, Object)
Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
Asynchronously starts watching the specified configuration objects.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StopCaching
Stops caching the configuration objects.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StopWatching
Stops watching the configuration objects.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StopWatchingAsync
Asynchronously stops watching the configuration list.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ServerParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


ServerParameterConfigurationList Constructor

[image]

IceLib Technical Reference
ServerParameterConfigurationList Constructor
ServerParameterConfigurationList Class See Also Send Feedback
Initializes a new instance of the ServerParameterConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerParameterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ServerParameterConfigurationList Class
ServerParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


ServerParameterConfigurationList Methods

[image] [image]

IceLib Technical Reference
ServerParameterConfigurationList Methods
ServerParameterConfigurationList Class See Also Send Feedback

The ServerParameterConfigurationList type exposes the following members.

Methods

Name Description
Public method ChangeWatchQuerySettings
Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method ChangeWatchQuerySettingsAsync
Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method CreateObject
Creates a new object in the list.
(Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method CreateObjectAsync
Asynchronously creates a new object in the list.
(Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method CreateQuerySettings
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetConfigurationList
Gets the configuration list.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsDialerEnabled
Queries the server for whether Dialer is enabled on the server.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method RefreshWatch
Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method RefreshWatchAsync
Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCaching()()()()
Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Starts caching the specified configuration objects.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCachingAsync(AsyncCompletedEventHandler, Object)
Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
Asynchronously starts caching the specified configuration objects.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatching()()()()
Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>))
Starts watching the specified configuration objects.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatchingAsync(AsyncCompletedEventHandler, Object)
Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object)
Asynchronously starts watching the specified configuration objects.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StopCaching
Stops caching the configuration objects.
(Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StopWatching
Stops watching the configuration objects.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method StopWatchingAsync
Asynchronously stops watching the configuration list.
(Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ServerParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


IsDialerEnabled Method

[image]

IceLib Technical Reference
ServerParameterConfigurationList..::..IsDialerEnabled Method
ServerParameterConfigurationList Class See Also Send Feedback
Queries the server for whether Dialer is enabled on the server.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool IsDialerEnabled(
    ConfigurationManager configurationManager
)
Visual Basic
Public Shared Function IsDialerEnabled ( _
    configurationManager As ConfigurationManager _
) As Boolean

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Return Value

A boolean that indicates whether Dialer is enabled on the server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ServerParameterConfigurationList Class
ServerParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


ServerParameterConfigurationList Properties

[image] [image]

IceLib Technical Reference
ServerParameterConfigurationList Properties
ServerParameterConfigurationList Class See Also Send Feedback

The ServerParameterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ServerParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


ServerParameterConfigurationList Events

[image] [image]

IceLib Technical Reference
ServerParameterConfigurationList Events
ServerParameterConfigurationList Class See Also Send Feedback

The ServerParameterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ServerParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration Class

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for the IC Server Report Configuration.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerReportConfigurationConfiguration : ContainerConfigurationObject
Visual Basic
Public Class ServerReportConfigurationConfiguration _
    Inherits ContainerConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..ServerReportConfigurationConfiguration

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration Members
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration Members

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfiguration Members
ServerReportConfigurationConfiguration Class Methods Properties See Also Send Feedback

The ServerReportConfigurationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | QueueReportingInterval | Provides access to the property representing QueueReportingInterval for this ServerReportConfiguration (use Property.QueueReportingInterval).
Public property | ShouldPrintReportVersion | Provides access to the property representing ShouldPrintReportVersion for this ServerReportConfiguration (use Property.ShouldPrintReportVersion).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ServerReportConfigurationConfiguration Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration Methods

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfiguration Methods
ServerReportConfigurationConfiguration Class See Also Send Feedback

The ServerReportConfigurationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ServerReportConfigurationConfiguration Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration Properties

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfiguration Properties
ServerReportConfigurationConfiguration Class See Also Send Feedback

The ServerReportConfigurationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | QueueReportingInterval | Provides access to the property representing QueueReportingInterval for this ServerReportConfiguration (use Property.QueueReportingInterval).
Public property | ShouldPrintReportVersion | Provides access to the property representing ShouldPrintReportVersion for this ServerReportConfiguration (use Property.ShouldPrintReportVersion).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

ServerReportConfigurationConfiguration Class
ININ.IceLib.Configuration Namespace


QueueReportingInterval Property

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..QueueReportingInterval Property
ServerReportConfigurationConfiguration Class See Also Send Feedback
Provides access to the property representing QueueReportingInterval for this ServerReportConfiguration (use Property.QueueReportingInterval).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ServerReportConfigurationConfiguration..::..Property, int> QueueReportingInterval { get; }
Visual Basic
Public ReadOnly Property QueueReportingInterval As GeneralConfigurationProperty(Of ServerReportConfigurationConfiguration..::..Property, Integer)
    Get

Field Value

The property representing QueueReportingInterval.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration Class
ServerReportConfigurationConfiguration Members
ININ.IceLib.Configuration Namespace


ShouldPrintReportVersion Property

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..ShouldPrintReportVersion Property
ServerReportConfigurationConfiguration Class See Also Send Feedback
Provides access to the property representing ShouldPrintReportVersion for this ServerReportConfiguration (use Property.ShouldPrintReportVersion).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ServerReportConfigurationConfiguration..::..Property, bool> ShouldPrintReportVersion { get; }
Visual Basic
Public ReadOnly Property ShouldPrintReportVersion As GeneralConfigurationProperty(Of ServerReportConfigurationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ShouldPrintReportVersion.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration Class
ServerReportConfigurationConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..StandardProperties Property
ServerReportConfigurationConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<ServerReportConfigurationConfiguration, ServerReportConfigurationConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of ServerReportConfigurationConfiguration, ServerReportConfigurationConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration Class
ServerReportConfigurationConfiguration Members
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..Property Enumeration
ServerReportConfigurationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Note: This enumeration is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
QueueReportingInterval | 0 | Represents the QueueReportingInterval property.
ShouldPrintReportVersion | 1 | Represents the ShouldPrintReportVersion property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration.Rights Class

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..Rights Class
ServerReportConfigurationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ServerReportConfigurationConfiguration..::..Rights

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..Rights Members
ServerReportConfigurationConfiguration..::..Rights Class Properties See Also Send Feedback

The ServerReportConfigurationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ServerReportConfigurationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..Rights Properties
ServerReportConfigurationConfiguration..::..Rights Class See Also Send Feedback

The ServerReportConfigurationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ServerReportConfigurationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..Rights..::..Admin Property
ServerReportConfigurationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ServerReportConfigurationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ServerReportConfigurationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration..::..Rights Class
ServerReportConfigurationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ServersConfiguration


View Property

[image]

IceLib Technical Reference
ServerReportConfigurationConfiguration..::..Rights..::..View Property
ServerReportConfigurationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ServerReportConfigurationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ServerReportConfigurationConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfiguration..::..Rights Class
ServerReportConfigurationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfigurationContainer Class

[image]

IceLib Technical Reference
ServerReportConfigurationConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the Server Report Configuration object.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerReportConfigurationConfigurationContainer : ConfigurationContainer<ServerReportConfigurationConfiguration, ServerReportConfigurationConfiguration..::..Property>
Visual Basic
Public Class ServerReportConfigurationConfigurationContainer _
    Inherits ConfigurationContainer(Of ServerReportConfigurationConfiguration, ServerReportConfigurationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' ServerReportConfigurationConfiguration, ServerReportConfigurationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..ServerReportConfigurationConfigurationContainer

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfigurationContainer Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ServerReportConfigurationConfiguration


ServerReportConfigurationConfigurationContainer Members

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfigurationContainer Members
ServerReportConfigurationConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The ServerReportConfigurationConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | ServerReportConfigurationConfigurationContainer | Initializes a new instance of the ServerReportConfigurationConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ServerReportConfigurationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfigurationContainer Constructor

[image]

IceLib Technical Reference
ServerReportConfigurationConfigurationContainer Constructor
ServerReportConfigurationConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the ServerReportConfigurationConfigurationContainer class.

Note: This constructor is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerReportConfigurationConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

ServerReportConfigurationConfigurationContainer Class
ServerReportConfigurationConfigurationContainer Members
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfigurationContainer Methods
ServerReportConfigurationConfigurationContainer Class See Also Send Feedback

The ServerReportConfigurationConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerReportConfigurationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfigurationContainer Properties
ServerReportConfigurationConfigurationContainer Class See Also Send Feedback

The ServerReportConfigurationConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ServerReportConfigurationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


ServerReportConfigurationConfigurationContainer Events

[image] [image]

IceLib Technical Reference
ServerReportConfigurationConfigurationContainer Events
ServerReportConfigurationConfigurationContainer Class See Also Send Feedback

The ServerReportConfigurationConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ServerReportConfigurationConfigurationContainer Class
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration Class

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Single Sign On Identity Providers.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SingleSignOnIdentityProviderConfiguration : ListConfigurationObject
Visual Basic
Public Class SingleSignOnIdentityProviderConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SingleSignOnIdentityProviderConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfiguration Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration Members

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration Members
SingleSignOnIdentityProviderConfiguration Class Methods Properties See Also Send Feedback

The SingleSignOnIdentityProviderConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SingleSignOnIdentityProviderConfiguration Class
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration Methods

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration Methods
SingleSignOnIdentityProviderConfiguration Class See Also Send Feedback

The SingleSignOnIdentityProviderConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SingleSignOnIdentityProviderConfiguration Class
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration Properties

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration Properties
SingleSignOnIdentityProviderConfiguration Class See Also Send Feedback

The SingleSignOnIdentityProviderConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SingleSignOnIdentityProviderConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..StandardProperties Property
SingleSignOnIdentityProviderConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SingleSignOnIdentityProviderConfiguration, SingleSignOnIdentityProviderConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SingleSignOnIdentityProviderConfiguration, SingleSignOnIdentityProviderConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfiguration Class
SingleSignOnIdentityProviderConfiguration Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..Property Enumeration
SingleSignOnIdentityProviderConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 3498 | Represents the DisplayName part of the ConfigurationId property.
Id | 3499 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration.Rights Class

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..Rights Class
SingleSignOnIdentityProviderConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SingleSignOnIdentityProviderConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..Rights Members
SingleSignOnIdentityProviderConfiguration..::..Rights Class Properties See Also Send Feedback

The SingleSignOnIdentityProviderConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SingleSignOnIdentityProviderConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..Rights Properties
SingleSignOnIdentityProviderConfiguration..::..Rights Class See Also Send Feedback

The SingleSignOnIdentityProviderConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SingleSignOnIdentityProviderConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..Rights..::..Admin Property
SingleSignOnIdentityProviderConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SipBridgeConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SipBridgeConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfiguration..::..Rights Class
SingleSignOnIdentityProviderConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SingleSignOnIdentityProviders


View Property

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfiguration..::..Rights..::..View Property
SingleSignOnIdentityProviderConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SipBridgeConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SipBridgeConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfiguration..::..Rights Class
SingleSignOnIdentityProviderConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfigurationList Class

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Single Sign On Identity Provider configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SingleSignOnIdentityProviderConfigurationList : ConfigurationList<SingleSignOnIdentityProviderConfiguration, SingleSignOnIdentityProviderConfiguration..::..Property>
Visual Basic
Public Class SingleSignOnIdentityProviderConfigurationList _
    Inherits ConfigurationList(Of SingleSignOnIdentityProviderConfiguration, SingleSignOnIdentityProviderConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SingleSignOnIdentityProviderConfiguration, SingleSignOnIdentityProviderConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SingleSignOnIdentityProviderConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfigurationList Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfigurationList Members

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfigurationList Members
SingleSignOnIdentityProviderConfigurationList Class Constructors Methods Properties See Also Send Feedback

The SingleSignOnIdentityProviderConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SingleSignOnIdentityProviderConfigurationList | Initializes a new instance of the SingleSignOnIdentityProviderConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SingleSignOnIdentityProviderConfigurationList Class
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfigurationList Constructor

[image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfigurationList Constructor
SingleSignOnIdentityProviderConfigurationList Class See Also Send Feedback
Initializes a new instance of the SingleSignOnIdentityProviderConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SingleSignOnIdentityProviderConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SingleSignOnIdentityProviderConfigurationList Class
SingleSignOnIdentityProviderConfigurationList Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfigurationList Methods

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfigurationList Methods
SingleSignOnIdentityProviderConfigurationList Class See Also Send Feedback

The SingleSignOnIdentityProviderConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleSignOnIdentityProviderConfigurationList Class
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviderConfigurationList Properties

[image] [image]

IceLib Technical Reference
SingleSignOnIdentityProviderConfigurationList Properties
SingleSignOnIdentityProviderConfigurationList Class See Also Send Feedback

The SingleSignOnIdentityProviderConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SingleSignOnIdentityProviderConfigurationList Class
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration Class

[image]

IceLib Technical Reference
SipBridgeConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Sip Bridges.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SipBridgeConfiguration : ListConfigurationObject
Visual Basic
Public Class SipBridgeConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SipBridgeConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfiguration Members
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration Members

[image] [image]

IceLib Technical Reference
SipBridgeConfiguration Members
SipBridgeConfiguration Class Methods Properties See Also Send Feedback

The SipBridgeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SipBridgeConfiguration Class
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration Methods

[image] [image]

IceLib Technical Reference
SipBridgeConfiguration Methods
SipBridgeConfiguration Class See Also Send Feedback

The SipBridgeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SipBridgeConfiguration Class
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration Properties

[image] [image]

IceLib Technical Reference
SipBridgeConfiguration Properties
SipBridgeConfiguration Class See Also Send Feedback

The SipBridgeConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SipBridgeConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SipBridgeConfiguration..::..StandardProperties Property
SipBridgeConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SipBridgeConfiguration, SipBridgeConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SipBridgeConfiguration, SipBridgeConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfiguration Class
SipBridgeConfiguration Members
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SipBridgeConfiguration..::..Property Enumeration
SipBridgeConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SipBridgeConfiguration.Rights Class

[image]

IceLib Technical Reference
SipBridgeConfiguration..::..Rights Class
SipBridgeConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SipBridgeConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SipBridgeConfiguration..::..Rights Members
SipBridgeConfiguration..::..Rights Class Properties See Also Send Feedback

The SipBridgeConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SipBridgeConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SipBridgeConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SipBridgeConfiguration..::..Rights Properties
SipBridgeConfiguration..::..Rights Class See Also Send Feedback

The SipBridgeConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SipBridgeConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SipBridgeConfiguration..::..Rights..::..Admin Property
SipBridgeConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SipBridgeConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SipBridgeConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfiguration..::..Rights Class
SipBridgeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SipBridge


View Property

[image]

IceLib Technical Reference
SipBridgeConfiguration..::..Rights..::..View Property
SipBridgeConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SipBridgeConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SipBridgeConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfiguration..::..Rights Class
SipBridgeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SipBridgeConfigurationList Class

[image]

IceLib Technical Reference
SipBridgeConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing SipBridge configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SipBridgeConfigurationList : ConfigurationList<SipBridgeConfiguration, SipBridgeConfiguration..::..Property>
Visual Basic
Public Class SipBridgeConfigurationList _
    Inherits ConfigurationList(Of SipBridgeConfiguration, SipBridgeConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SipBridgeConfiguration, SipBridgeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SipBridgeConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfigurationList Members
ININ.IceLib.Configuration Namespace


SipBridgeConfigurationList Members

[image] [image]

IceLib Technical Reference
SipBridgeConfigurationList Members
SipBridgeConfigurationList Class Constructors Methods Properties See Also Send Feedback

The SipBridgeConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SipBridgeConfigurationList | Initializes a new instance of the SipBridgeConfigurationList class.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SipBridgeConfigurationList Class
ININ.IceLib.Configuration Namespace


SipBridgeConfigurationList Constructor

[image]

IceLib Technical Reference
SipBridgeConfigurationList Constructor
SipBridgeConfigurationList Class See Also Send Feedback
Initializes a new instance of the SipBridgeConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SipBridgeConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SipBridgeConfigurationList Class
SipBridgeConfigurationList Members
ININ.IceLib.Configuration Namespace


SipBridgeConfigurationList Methods

[image] [image]

IceLib Technical Reference
SipBridgeConfigurationList Methods
SipBridgeConfigurationList Class See Also Send Feedback

The SipBridgeConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SipBridgeConfigurationList Class
ININ.IceLib.Configuration Namespace


SipBridgeConfigurationList Properties

[image] [image]

IceLib Technical Reference
SipBridgeConfigurationList Properties
SipBridgeConfigurationList Class See Also Send Feedback

The SipBridgeConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SipBridgeConfigurationList Class
ININ.IceLib.Configuration Namespace


SiteConfiguration Class

[image]

IceLib Technical Reference
SiteConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for sites configured in Interaction Administrator.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SiteConfiguration : ListConfigurationObject
Visual Basic
Public Class SiteConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SiteConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfiguration Members
ININ.IceLib.Configuration Namespace


SiteConfiguration Members

[image] [image]

IceLib Technical Reference
SiteConfiguration Members
SiteConfiguration Class Methods Properties See Also Send Feedback

The SiteConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SiteConfiguration Class
ININ.IceLib.Configuration Namespace


SiteConfiguration Methods

[image] [image]

IceLib Technical Reference
SiteConfiguration Methods
SiteConfiguration Class See Also Send Feedback

The SiteConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SiteConfiguration Class
ININ.IceLib.Configuration Namespace


SiteConfiguration Properties

[image] [image]

IceLib Technical Reference
SiteConfiguration Properties
SiteConfiguration Class See Also Send Feedback

The SiteConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SiteConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SiteConfiguration..::..StandardProperties Property
SiteConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SiteConfiguration, SiteConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SiteConfiguration, SiteConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfiguration Class
SiteConfiguration Members
ININ.IceLib.Configuration Namespace


SiteConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SiteConfiguration..::..Property Enumeration
SiteConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


SiteConfiguration.Rights Class

[image]

IceLib Technical Reference
SiteConfiguration..::..Rights Class
SiteConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SiteConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SiteConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SiteConfiguration..::..Rights Members
SiteConfiguration..::..Rights Class Properties See Also Send Feedback

The SiteConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SiteConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SiteConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SiteConfiguration..::..Rights Properties
SiteConfiguration..::..Rights Class See Also Send Feedback

The SiteConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SiteConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SiteConfiguration..::..Rights..::..Admin Property
SiteConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SiteConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SiteConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfiguration..::..Rights Class
SiteConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PeerSitesConfiguration


View Property

[image]

IceLib Technical Reference
SiteConfiguration..::..Rights..::..View Property
SiteConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SiteConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SiteConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfiguration..::..Rights Class
SiteConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SiteConfigurationList Class

[image]

IceLib Technical Reference
SiteConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing site configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SiteConfigurationList : DynamicConfigurationList<SiteConfiguration, SiteConfiguration..::..Property>
Visual Basic
Public Class SiteConfigurationList _
    Inherits DynamicConfigurationList(Of SiteConfiguration, SiteConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SiteConfiguration, SiteConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' SiteConfiguration, SiteConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SiteConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfigurationList Members
ININ.IceLib.Configuration Namespace


SiteConfigurationList Members

[image] [image]

IceLib Technical Reference
SiteConfigurationList Members
SiteConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SiteConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SiteConfigurationList | Initializes a new instance of the SiteConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SiteConfigurationList Class
ININ.IceLib.Configuration Namespace


SiteConfigurationList Constructor

[image]

IceLib Technical Reference
SiteConfigurationList Constructor
SiteConfigurationList Class See Also Send Feedback
Initializes a new instance of the SiteConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SiteConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteConfigurationList Class
SiteConfigurationList Members
ININ.IceLib.Configuration Namespace


SiteConfigurationList Methods

[image] [image]

IceLib Technical Reference
SiteConfigurationList Methods
SiteConfigurationList Class See Also Send Feedback

The SiteConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SiteConfigurationList Class
ININ.IceLib.Configuration Namespace


SiteConfigurationList Properties

[image] [image]

IceLib Technical Reference
SiteConfigurationList Properties
SiteConfigurationList Class See Also Send Feedback

The SiteConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SiteConfigurationList Class
ININ.IceLib.Configuration Namespace


SiteConfigurationList Events

[image] [image]

IceLib Technical Reference
SiteConfigurationList Events
SiteConfigurationList Class See Also Send Feedback

The SiteConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SiteConfigurationList Class
ININ.IceLib.Configuration Namespace


SkillConfiguration Class

[image]

IceLib Technical Reference
SkillConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC skill.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SkillConfiguration : EditableListConfigurationObject<SkillConfiguration..::..Property>
Visual Basic
Public Class SkillConfiguration _
    Inherits EditableListConfigurationObject(Of SkillConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' SkillConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SkillConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SkillConfiguration Members
ININ.IceLib.Configuration Namespace


SkillConfiguration Members

[image] [image]

IceLib Technical Reference
SkillConfiguration Members
SkillConfiguration Class Methods Properties See Also Send Feedback

The SkillConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetErrorInformation | Provides access to the property representing whether there is a sync error, and returns the error received)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this skill (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | GenesysCloudSkillLanguage | Provides access to the property representing if this skill will be treated as a language in the cloud (use Property.GenesysCloudLastSync.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | PureCloudLastSync | Provides access to the property representing the time this was last synced to the cloud (use Property.GenesysCloudLastSync.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | UserAssignments | Provides access to the property representing the user assignments for this skill.(use Property.UserAssignments).
Public property | WorkgroupAssignments | Provides access to the property representing the workgroup assignments for this skill.(use Property.UserAssignments).

See Also

SkillConfiguration Class
ININ.IceLib.Configuration Namespace


SkillConfiguration Methods

[image] [image]

IceLib Technical Reference
SkillConfiguration Methods
SkillConfiguration Class See Also Send Feedback

The SkillConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetErrorInformation | Provides access to the property representing whether there is a sync error, and returns the error received)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SkillConfiguration Class
ININ.IceLib.Configuration Namespace


GetErrorInformation Method

[image]

IceLib Technical Reference
SkillConfiguration..::..GetErrorInformation Method
SkillConfiguration Class See Also Send Feedback
Provides access to the property representing whether there is a sync error, and returns the error received)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string GetErrorInformation(
    Session session,
    string skillName
)
Visual Basic
Public Shared Function GetErrorInformation ( _
    session As Session, _
    skillName As String _
) As String

Parameters

session
Type: ININ.IceLib.Connection..::..Session
skillName
Type: System..::..String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace


SkillConfiguration Properties

[image] [image]

IceLib Technical Reference
SkillConfiguration Properties
SkillConfiguration Class See Also Send Feedback

The SkillConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this skill (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | GenesysCloudSkillLanguage | Provides access to the property representing if this skill will be treated as a language in the cloud (use Property.GenesysCloudLastSync.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | PureCloudLastSync | Provides access to the property representing the time this was last synced to the cloud (use Property.GenesysCloudLastSync.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | UserAssignments | Provides access to the property representing the user assignments for this skill.(use Property.UserAssignments).
Public property | WorkgroupAssignments | Provides access to the property representing the workgroup assignments for this skill.(use Property.UserAssignments).

See Also

SkillConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
SkillConfiguration..::..AccessControlGroupAssignment Property
SkillConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this skill (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SkillConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of SkillConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace


GenesysCloudSkillLanguage Property

[image]

IceLib Technical Reference
SkillConfiguration..::..GenesysCloudSkillLanguage Property
SkillConfiguration Class See Also Send Feedback
Provides access to the property representing if this skill will be treated as a language in the cloud (use Property.GenesysCloudLastSync.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SkillConfiguration..::..Property, bool> GenesysCloudSkillLanguage { get; }
Visual Basic
Public ReadOnly Property GenesysCloudSkillLanguage As GeneralConfigurationProperty(Of SkillConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing if this skill will be treated as a language in the cloud.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
SkillConfiguration..::..PropertiesChanged Property
SkillConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SkillConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of SkillConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace


PureCloudLastSync Property

[image]

IceLib Technical Reference
SkillConfiguration..::..PureCloudLastSync Property
SkillConfiguration Class See Also Send Feedback
Provides access to the property representing the time this was last synced to the cloud (use Property.GenesysCloudLastSync.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SkillConfiguration..::..Property, string> PureCloudLastSync { get; }
Visual Basic
Public ReadOnly Property PureCloudLastSync As GeneralConfigurationProperty(Of SkillConfiguration..::..Property, String)
    Get

Field Value

The property representing the last time this was synced to the cloud.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SkillConfiguration..::..StandardProperties Property
SkillConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SkillConfiguration, SkillConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SkillConfiguration, SkillConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace


UserAssignments Property

[image]

IceLib Technical Reference
SkillConfiguration..::..UserAssignments Property
SkillConfiguration Class See Also Send Feedback
Provides access to the property representing the user assignments for this skill.(use Property.UserAssignments).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SkillConfiguration..::..Property, Collection<SkillSettings>> UserAssignments { get; }
Visual Basic
Public ReadOnly Property UserAssignments As GeneralConfigurationProperty(Of SkillConfiguration..::..Property, Collection(Of SkillSettings))
    Get

Field Value

The property representing the user assignments.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.
  • Owned - To assign or remove this skill to a User, modify the Value of this property. One or more Users must already be defined to assign this Skill to them.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration.DataTypes..::..SkillSettings
ININ.IceLib.Configuration..::..UserConfiguration
ININ.IceLib.Configuration..::..UserConfigurationList


WorkgroupAssignments Property

[image]

IceLib Technical Reference
SkillConfiguration..::..WorkgroupAssignments Property
SkillConfiguration Class See Also Send Feedback
Provides access to the property representing the workgroup assignments for this skill.(use Property.UserAssignments).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SkillConfiguration..::..Property, Collection<SkillSettings>> WorkgroupAssignments { get; }
Visual Basic
Public ReadOnly Property WorkgroupAssignments As GeneralConfigurationProperty(Of SkillConfiguration..::..Property, Collection(Of SkillSettings))
    Get

Field Value

The property representing the workgroup assignments.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.
  • Owned - To assign or remove this skill to a Workgroup, modify the Value of this property. One or more Workgroups must already be defined to assign this Skill to them.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SkillConfiguration Class
SkillConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration.DataTypes..::..SkillSettings
ININ.IceLib.Configuration..::..UserConfiguration
ININ.IceLib.Configuration..::..UserConfigurationList


SkillConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SkillConfiguration..::..Property Enumeration
SkillConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
UserAssignments | 1 | Represents the UserAssignments property.
WorkgroupAssignments | 2 | Represents the WorkgroupAssignments property.
PureCloudLastSync | 5 | Represents the PureCloudLastSync property.
GenesysCloudSkillLanguage | 6 | Represents the GenesysCloudSkillLanguage property.
DisplayName | 3 | Represents the DisplayName part of the ConfigurationId property.
Id | 4 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SkillConfiguration.Rights Class

[image]

IceLib Technical Reference
SkillConfiguration..::..Rights Class
SkillConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SkillConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SkillConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SkillConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SkillConfiguration..::..Rights Members
SkillConfiguration..::..Rights Class Properties See Also Send Feedback

The SkillConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SkillConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SkillConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SkillConfiguration..::..Rights Properties
SkillConfiguration..::..Rights Class See Also Send Feedback

The SkillConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SkillConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SkillConfiguration..::..Rights..::..Admin Property
SkillConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SkillConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SkillConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SkillConfiguration..::..Rights Class
SkillConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Skills


View Property

[image]

IceLib Technical Reference
SkillConfiguration..::..Rights..::..View Property
SkillConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SkillConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SkillConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SkillConfiguration..::..Rights Class
SkillConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSkillList


SkillConfigurationList Class

[image]

IceLib Technical Reference
SkillConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing skill configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SkillConfigurationList : EditableConfigurationList<SkillConfiguration, SkillConfiguration..::..Property>
Visual Basic
Public Class SkillConfigurationList _
    Inherits EditableConfigurationList(Of SkillConfiguration, SkillConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SkillConfiguration, SkillConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' SkillConfiguration, SkillConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' SkillConfiguration, SkillConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SkillConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SkillConfigurationList Members
ININ.IceLib.Configuration Namespace


SkillConfigurationList Members

[image] [image]

IceLib Technical Reference
SkillConfigurationList Members
SkillConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SkillConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SkillConfigurationList | Initializes a new instance of the SkillConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SkillConfigurationList Class
ININ.IceLib.Configuration Namespace


SkillConfigurationList Constructor

[image]

IceLib Technical Reference
SkillConfigurationList Constructor
SkillConfigurationList Class See Also Send Feedback
Initializes a new instance of the SkillConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SkillConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SkillConfigurationList Class
SkillConfigurationList Members
ININ.IceLib.Configuration Namespace


SkillConfigurationList Methods

[image] [image]

IceLib Technical Reference
SkillConfigurationList Methods
SkillConfigurationList Class See Also Send Feedback

The SkillConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkillConfigurationList Class
ININ.IceLib.Configuration Namespace


SkillConfigurationList Properties

[image] [image]

IceLib Technical Reference
SkillConfigurationList Properties
SkillConfigurationList Class See Also Send Feedback

The SkillConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SkillConfigurationList Class
ININ.IceLib.Configuration Namespace


SkillConfigurationList Events

[image] [image]

IceLib Technical Reference
SkillConfigurationList Events
SkillConfigurationList Class See Also Send Feedback

The SkillConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SkillConfigurationList Class
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration Class

[image]

IceLib Technical Reference
SmdiPortConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC SMDI port.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SmdiPortConfiguration is no longer used.")]
public class SmdiPortConfiguration : ListConfigurationObject
Visual Basic
<ObsoleteAttribute("SmdiPortConfiguration is no longer used.")> _
Public Class SmdiPortConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SmdiPortConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SmdiPortConfiguration Members
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration Members

[image] [image]

IceLib Technical Reference
SmdiPortConfiguration Members
SmdiPortConfiguration Class Methods Properties See Also Send Feedback

The SmdiPortConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

SmdiPortConfiguration Class
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration Methods

[image] [image]

IceLib Technical Reference
SmdiPortConfiguration Methods
SmdiPortConfiguration Class See Also Send Feedback

The SmdiPortConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SmdiPortConfiguration Class
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration Properties

[image] [image]

IceLib Technical Reference
SmdiPortConfiguration Properties
SmdiPortConfiguration Class See Also Send Feedback

The SmdiPortConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

SmdiPortConfiguration Class
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SmdiPortConfiguration..::..Property Enumeration
SmdiPortConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SmdiPortConfiguration.Rights Class

[image]

IceLib Technical Reference
SmdiPortConfiguration..::..Rights Class
SmdiPortConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SmdiPortConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmdiPortConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SmdiPortConfiguration..::..Rights Members
SmdiPortConfiguration..::..Rights Class Properties See Also Send Feedback

The SmdiPortConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SmdiPortConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SmdiPortConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SmdiPortConfiguration..::..Rights Properties
SmdiPortConfiguration..::..Rights Class See Also Send Feedback

The SmdiPortConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SmdiPortConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SmdiPortConfiguration..::..Rights..::..Admin Property
SmdiPortConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SmdiPortConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SmdiPortConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmdiPortConfiguration..::..Rights Class
SmdiPortConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
SmdiPortConfiguration..::..Rights..::..View Property
SmdiPortConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SmdiPortConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SmdiPortConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmdiPortConfiguration..::..Rights Class
SmdiPortConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SmdiPortConfigurationList Class

[image]

IceLib Technical Reference
SmdiPortConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing SmdiPort configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SmdiPortConfigurationList is no longer used.")]
public class SmdiPortConfigurationList : DynamicConfigurationList<SmdiPortConfiguration, SmdiPortConfiguration..::..Property>
Visual Basic
<ObsoleteAttribute("SmdiPortConfigurationList is no longer used.")> _
Public Class SmdiPortConfigurationList _
    Inherits DynamicConfigurationList(Of SmdiPortConfiguration, SmdiPortConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SmdiPortConfiguration, SmdiPortConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' SmdiPortConfiguration, SmdiPortConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SmdiPortConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SmdiPortConfigurationList Members
ININ.IceLib.Configuration Namespace


SmdiPortConfigurationList Members

[image] [image]

IceLib Technical Reference
SmdiPortConfigurationList Members
SmdiPortConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SmdiPortConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SmdiPortConfigurationList | Initializes a new instance of the SmdiPortConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SmdiPortConfigurationList Class
ININ.IceLib.Configuration Namespace


SmdiPortConfigurationList Constructor

[image]

IceLib Technical Reference
SmdiPortConfigurationList Constructor
SmdiPortConfigurationList Class See Also Send Feedback
Initializes a new instance of the SmdiPortConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SmdiPortConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SmdiPortConfigurationList Class
SmdiPortConfigurationList Members
ININ.IceLib.Configuration Namespace


SmdiPortConfigurationList Methods

[image] [image]

IceLib Technical Reference
SmdiPortConfigurationList Methods
SmdiPortConfigurationList Class See Also Send Feedback

The SmdiPortConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmdiPortConfigurationList Class
ININ.IceLib.Configuration Namespace


SmdiPortConfigurationList Properties

[image] [image]

IceLib Technical Reference
SmdiPortConfigurationList Properties
SmdiPortConfigurationList Class See Also Send Feedback

The SmdiPortConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SmdiPortConfigurationList Class
ININ.IceLib.Configuration Namespace


SmdiPortConfigurationList Events

[image] [image]

IceLib Technical Reference
SmdiPortConfigurationList Events
SmdiPortConfigurationList Class See Also Send Feedback

The SmdiPortConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SmdiPortConfigurationList Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration Class

[image]

IceLib Technical Reference
SmsBrokerConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC SMS Broker. An SMS broker is a company that takes care of routing SMS messages to cell phones and which collects SMS messages from cell phones.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SmsBrokerConfiguration : ListConfigurationObject
Visual Basic
Public Class SmsBrokerConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SmsBrokerConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfiguration Members
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration Members

[image] [image]

IceLib Technical Reference
SmsBrokerConfiguration Members
SmsBrokerConfiguration Class Methods Properties See Also Send Feedback

The SmsBrokerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SmsBrokerConfiguration Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration Methods

[image] [image]

IceLib Technical Reference
SmsBrokerConfiguration Methods
SmsBrokerConfiguration Class See Also Send Feedback

The SmsBrokerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SmsBrokerConfiguration Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration Properties

[image] [image]

IceLib Technical Reference
SmsBrokerConfiguration Properties
SmsBrokerConfiguration Class See Also Send Feedback

The SmsBrokerConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SmsBrokerConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SmsBrokerConfiguration..::..StandardProperties Property
SmsBrokerConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SmsBrokerConfiguration, SmsBrokerConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SmsBrokerConfiguration, SmsBrokerConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfiguration Class
SmsBrokerConfiguration Members
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SmsBrokerConfiguration..::..Property Enumeration
SmsBrokerConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration.Rights Class

[image]

IceLib Technical Reference
SmsBrokerConfiguration..::..Rights Class
SmsBrokerConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SmsBrokerConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SmsBrokerConfiguration..::..Rights Members
SmsBrokerConfiguration..::..Rights Class Properties See Also Send Feedback

The SmsBrokerConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SmsBrokerConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SmsBrokerConfiguration..::..Rights Properties
SmsBrokerConfiguration..::..Rights Class See Also Send Feedback

The SmsBrokerConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SmsBrokerConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SmsBrokerConfiguration..::..Rights..::..Admin Property
SmsBrokerConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SmsBrokerConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SmsBrokerConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfiguration..::..Rights Class
SmsBrokerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SmsBroker


View Property

[image]

IceLib Technical Reference
SmsBrokerConfiguration..::..Rights..::..View Property
SmsBrokerConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SmsBrokerConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SmsBrokerConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfiguration..::..Rights Class
SmsBrokerConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SmsBrokerConfigurationList Class

[image]

IceLib Technical Reference
SmsBrokerConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing SmsBroker configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SmsBrokerConfigurationList : DynamicConfigurationList<SmsBrokerConfiguration, SmsBrokerConfiguration..::..Property>
Visual Basic
Public Class SmsBrokerConfigurationList _
    Inherits DynamicConfigurationList(Of SmsBrokerConfiguration, SmsBrokerConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SmsBrokerConfiguration, SmsBrokerConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' SmsBrokerConfiguration, SmsBrokerConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SmsBrokerConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfigurationList Members
ININ.IceLib.Configuration Namespace


SmsBrokerConfigurationList Members

[image] [image]

IceLib Technical Reference
SmsBrokerConfigurationList Members
SmsBrokerConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SmsBrokerConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SmsBrokerConfigurationList | Initializes a new instance of the SmsBrokerConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SmsBrokerConfigurationList Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfigurationList Constructor

[image]

IceLib Technical Reference
SmsBrokerConfigurationList Constructor
SmsBrokerConfigurationList Class See Also Send Feedback
Initializes a new instance of the SmsBrokerConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SmsBrokerConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SmsBrokerConfigurationList Class
SmsBrokerConfigurationList Members
ININ.IceLib.Configuration Namespace


SmsBrokerConfigurationList Methods

[image] [image]

IceLib Technical Reference
SmsBrokerConfigurationList Methods
SmsBrokerConfigurationList Class See Also Send Feedback

The SmsBrokerConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmsBrokerConfigurationList Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfigurationList Properties

[image] [image]

IceLib Technical Reference
SmsBrokerConfigurationList Properties
SmsBrokerConfigurationList Class See Also Send Feedback

The SmsBrokerConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SmsBrokerConfigurationList Class
ININ.IceLib.Configuration Namespace


SmsBrokerConfigurationList Events

[image] [image]

IceLib Technical Reference
SmsBrokerConfigurationList Events
SmsBrokerConfigurationList Class See Also Send Feedback

The SmsBrokerConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SmsBrokerConfigurationList Class
ININ.IceLib.Configuration Namespace


SortDefinition(TPropertyEnum) Class

[image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a sort for searching configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SortDefinition<TPropertyEnum>
where TPropertyEnum : struct, new()
Visual Basic
Public Class SortDefinition(Of TPropertyEnum As {Structure, New})

Type Parameters

TPropertyEnum
The type of the property enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SortDefinition<(Of <(<'TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SortDefinition(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The SortDefinition<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SortDefinition<(Of <(<'TPropertyEnum>)>)> | Initializes a new instance of the SortDefinition<(Of <(<'TPropertyEnum>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | SortDirection | Gets the sort direction.
Public property | SortProperty | Gets the property to sort by.
 | SupportedSortProperties | Gets the supported sort properties for TPropertyEnum.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


SortDefinition(TPropertyEnum) Constructor

[image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)> Constructor
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the SortDefinition<(Of <(<'TPropertyEnum>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SortDefinition(
    TPropertyEnum sortProperty,
    ListSortDirection sortDirection
)
Visual Basic
Public Sub New ( _
    sortProperty As TPropertyEnum, _
    sortDirection As ListSortDirection _
)

Parameters

sortProperty
Type: TPropertyEnum
The sort property.
sortDirection
Type: System.ComponentModel..::..ListSortDirection
The sort direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SortDefinition(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)> Methods
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The SortDefinition<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)>..::..ToString Method
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SortDefinition(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)> Properties
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The SortDefinition<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | SortDirection | Gets the sort direction.
Public property | SortProperty | Gets the property to sort by.
 | SupportedSortProperties | Gets the supported sort properties for TPropertyEnum.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


SortDirection Property

[image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)>..::..SortDirection Property
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the sort direction.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ListSortDirection SortDirection { get; }
Visual Basic
Public ReadOnly Property SortDirection As ListSortDirection
    Get

Field Value

The sort direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SortProperty Property

[image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)>..::..SortProperty Property
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the property to sort by.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TPropertyEnum SortProperty { get; }
Visual Basic
Public ReadOnly Property SortProperty As TPropertyEnum
    Get

Field Value

The property to sort by.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SupportedSortProperties Property

[image]

IceLib Technical Reference
SortDefinition<(Of <(<'TPropertyEnum>)>)>..::..SupportedSortProperties Property
SortDefinition<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Gets the supported sort properties for TPropertyEnum.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<TPropertyEnum> SupportedSortProperties { get; }
Visual Basic
Public Shared ReadOnly Property SupportedSortProperties As ReadOnlyCollection(Of TPropertyEnum)
    Get

Field Value

The supported sort properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SortDefinition<(Of <(<'TPropertyEnum>)>)> Class
SortDefinition<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StandardProperties(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Contains standard properties for a ConfigurationObject.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StandardProperties<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class StandardProperties(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
TPropertyEnum

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StandardProperties(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomAttributes | Provides access to the custom attributes for the configuration object.
Public property | DateCreated | Provides access to the property representing the date this configuration object was created.
Public property | DateLastModified | Provides access to the property representing the date this configuration object was last modified.
Public property | Notes | Provides access to the property representing the notes for this configuration object.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


StandardProperties(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


StandardProperties(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | CustomAttributes | Provides access to the custom attributes for the configuration object.
Public property | DateCreated | Provides access to the property representing the date this configuration object was created.
Public property | DateLastModified | Provides access to the property representing the date this configuration object was last modified.
Public property | Notes | Provides access to the property representing the notes for this configuration object.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


CustomAttributes Property

[image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CustomAttributes Property
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the custom attributes for the configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<TPropertyEnum, IDictionary<string, string>> CustomAttributes { get; }
Visual Basic
Public ReadOnly Property CustomAttributes As GeneralConfigurationProperty(Of TPropertyEnum, IDictionary(Of String, String))
    Get

Field Value

The property representing the custom attributes for the configuration object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DateCreated Property

[image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DateCreated Property
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the date this configuration object was created.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<TPropertyEnum, DateTime> DateCreated { get; }
Visual Basic
Public ReadOnly Property DateCreated As GeneralConfigurationProperty(Of TPropertyEnum, DateTime)
    Get

Field Value

The property representing the date this configuration object was created.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DateLastModified Property

[image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DateLastModified Property
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the date this configuration object was last modified.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<TPropertyEnum, DateTime> DateLastModified { get; }
Visual Basic
Public ReadOnly Property DateLastModified As GeneralConfigurationProperty(Of TPropertyEnum, DateTime)
    Get

Field Value

The property representing the date this configuration object was last modified.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Notes Property

[image]

IceLib Technical Reference
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Notes Property
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the notes for this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<TPropertyEnum, string> Notes { get; }
Visual Basic
Public ReadOnly Property Notes As GeneralConfigurationProperty(Of TPropertyEnum, String)
    Get

Field Value

The property representing the notes for this configuration object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
StandardProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StationConfiguration Class

[image]

IceLib Technical Reference
StationConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Station.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationConfiguration : EditableListConfigurationObject<StationConfiguration..::..Property>
Visual Basic
Public Class StationConfiguration _
    Inherits EditableListConfigurationObject(Of StationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' StationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StationConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationConfiguration Members
ININ.IceLib.Configuration Namespace


StationConfiguration Members

[image] [image]

IceLib Technical Reference
StationConfiguration Members
StationConfiguration Class Methods Properties See Also Send Feedback

The StationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this station (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConnectionAddress | Provides access to the property representing the connection address for this station (use Property.ConnectionAddress).
Public property | ContactLine | Provides access to the property representing the contact line for this station (use Property.ContactLine).
Public property | Extension | Provides access to the property representing the extension for this station (use Property.Extension).
Public property | IdentificationAddress | Provides access to the property representing the identification address for this station (use Property.IdentificationAddress).
Public property | IsActive | Provides access to the property representing the IsActive property for this station (use Property.IsActive).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsShareable | Provides access to the property representing the IsShareable property for this station (use Property.IsShareable).
Public property | License | Provides access to the various license properties.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PhoneNumberClassifications | Provides access to the property representing the phone number classifications for this station (use Property.PhoneNumberClassifications).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ShouldAlwaysRing | Provides access to the property representing the ShouldAlwaysRing property for this station (use Property.ShouldAlwaysRing).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StationType | Provides access to the property representing the station type for this station (use Property.StationType).

See Also

StationConfiguration Class
ININ.IceLib.Configuration Namespace


StationConfiguration Methods

[image] [image]

IceLib Technical Reference
StationConfiguration Methods
StationConfiguration Class See Also Send Feedback

The StationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StationConfiguration Class
ININ.IceLib.Configuration Namespace


StationConfiguration Properties

[image] [image]

IceLib Technical Reference
StationConfiguration Properties
StationConfiguration Class See Also Send Feedback

The StationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this station (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConnectionAddress | Provides access to the property representing the connection address for this station (use Property.ConnectionAddress).
Public property | ContactLine | Provides access to the property representing the contact line for this station (use Property.ContactLine).
Public property | Extension | Provides access to the property representing the extension for this station (use Property.Extension).
Public property | IdentificationAddress | Provides access to the property representing the identification address for this station (use Property.IdentificationAddress).
Public property | IsActive | Provides access to the property representing the IsActive property for this station (use Property.IsActive).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsShareable | Provides access to the property representing the IsShareable property for this station (use Property.IsShareable).
Public property | License | Provides access to the various license properties.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PhoneNumberClassifications | Provides access to the property representing the phone number classifications for this station (use Property.PhoneNumberClassifications).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ShouldAlwaysRing | Provides access to the property representing the ShouldAlwaysRing property for this station (use Property.ShouldAlwaysRing).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StationType | Provides access to the property representing the station type for this station (use Property.StationType).

See Also

StationConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
StationConfiguration..::..AccessControlGroupAssignment Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this station (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of StationConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


ConnectionAddress Property

[image]

IceLib Technical Reference
StationConfiguration..::..ConnectionAddress Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the connection address for this station (use Property.ConnectionAddress).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, SipAddress> ConnectionAddress { get; }
Visual Basic
Public ReadOnly Property ConnectionAddress As GeneralConfigurationProperty(Of StationConfiguration..::..Property, SipAddress)
    Get

Field Value

The property representing the connection address.

Remarks

If the connection address is Empty, then ContactLine must be None.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


ContactLine Property

[image]

IceLib Technical Reference
StationConfiguration..::..ContactLine Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the contact line for this station (use Property.ContactLine).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<StationConfiguration..::..Property, ConfigurationId> ContactLine { get; }
Visual Basic
Public ReadOnly Property ContactLine As InheritableConfigurationProperty(Of StationConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the contact line.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


Extension Property

[image]

IceLib Technical Reference
StationConfiguration..::..Extension Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the extension for this station (use Property.Extension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, string> Extension { get; }
Visual Basic
Public ReadOnly Property Extension As GeneralConfigurationProperty(Of StationConfiguration..::..Property, String)
    Get

Field Value

The property representing the station extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


IdentificationAddress Property

[image]

IceLib Technical Reference
StationConfiguration..::..IdentificationAddress Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the identification address for this station (use Property.IdentificationAddress).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, SipAddress> IdentificationAddress { get; }
Visual Basic
Public ReadOnly Property IdentificationAddress As GeneralConfigurationProperty(Of StationConfiguration..::..Property, SipAddress)
    Get

Field Value

The property representing the identification address.

Remarks

The identification address should only be set when the StationType is not a RemoteStation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


IsActive Property

[image]

IceLib Technical Reference
StationConfiguration..::..IsActive Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the IsActive property for this station (use Property.IsActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the IsActive station property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


IsShareable Property

[image]

IceLib Technical Reference
StationConfiguration..::..IsShareable Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the IsShareable property for this station (use Property.IsShareable).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> IsShareable { get; }
Visual Basic
Public ReadOnly Property IsShareable As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the IsShareable station property.

Remarks

This property is only applicable when StationType is StandAlonePhone or Workstation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


License Property

[image]

IceLib Technical Reference
StationConfiguration..::..License Property
StationConfiguration Class See Also Send Feedback
Provides access to the various license properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationLicenseProperties License { get; }
Visual Basic
Public ReadOnly Property License As StationLicenseProperties
    Get

Field Value

The license properties group.

Remarks

When updating the license properties along with additional non-license properties on a StationConfiguration object via a call to Commit()()()(), it is possible for the license changes to fail, but the non-license changes to succeed. When a call to Commit()()()() results in a ConfigurationValidationException, and the list of validation issues obtained from checking the return value of GetValidationIssues<(Of <<'(TPropertyEnum>)>>)()()()() only contains validation issues relating to the license changes, then the rest of the update operation succeeded. Conversely, if a call to Commit()()()() results in a ConfigurationValidationException, and the list of validation issues obtained from checking the return value of GetValidationIssues<(Of <<'(TPropertyEnum>)>>)()()()() contains validation errors on the non-license properties, then the update to the object failed, and the license changes were not applied.

When watching the StationConfigurationList object for StationConfiguration changes, change notifications will not be sent for changes to the License property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassifications Property

[image]

IceLib Technical Reference
StationConfiguration..::..PhoneNumberClassifications Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the phone number classifications for this station (use Property.PhoneNumberClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, Collection<ConfigurationId>> PhoneNumberClassifications { get; }
Visual Basic
Public ReadOnly Property PhoneNumberClassifications As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the phone number classifications.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
StationConfiguration..::..PropertiesChanged Property
StationConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StationConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of StationConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


ShouldAlwaysRing Property

[image]

IceLib Technical Reference
StationConfiguration..::..ShouldAlwaysRing Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the ShouldAlwaysRing property for this station (use Property.ShouldAlwaysRing).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> ShouldAlwaysRing { get; }
Visual Basic
Public ReadOnly Property ShouldAlwaysRing As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the ShouldAlwaysRing station property.

Remarks

This property is only applicable when StationType is RemoteStation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StationConfiguration..::..StandardProperties Property
StationConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StationConfiguration, StationConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StationConfiguration, StationConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


StationType Property

[image]

IceLib Technical Reference
StationConfiguration..::..StationType Property
StationConfiguration Class See Also Send Feedback
Provides access to the property representing the station type for this station (use Property.StationType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, StationType> StationType { get; }
Visual Basic
Public ReadOnly Property StationType As GeneralConfigurationProperty(Of StationConfiguration..::..Property, StationType)
    Get

Field Value

The property representing the station type.

Remarks

Stations with different station types will have different configuration parameters. Some of the properties on a station will not be valid with certain station types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationConfiguration Class
StationConfiguration Members
ININ.IceLib.Configuration Namespace


StationConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StationConfiguration..::..Property Enumeration
StationConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
IsActive | 1 | Represents the IsActive property.
IsShareable | 2 | Represents the IsShareable property.
StationType | 3 | Represents the StationType property.
ContactLine | 4 | Represents the ContactLine property.
ConnectionAddress | 5 | Represents the ConnectionAddress property.
Extension | 6 | Represents the Extension property.
IdentificationAddress | 7 | Represents the IdentificationAddress property.
PhoneNumberClassifications | 8 | Represents the PhoneNumberClassifications property.
ShouldAlwaysRing | 9 | Represents the ShouldAlwaysRing property.
License_AdditionalLicenses | 4000 | Represents the AdditionalLicenses property.
License_HasBasicStationLicense | 4001 | Represents the HasBasicStationLicense property.
License_HasClientAccess | 4002 | Represents the HasClientAccess property.
License_HasRecorderAccess | 4003 | Represents the HasRecorderAccess property.
License_InteractionProcessAutomationType | 4004 | Represents the InteractionProcessAutomationLicenseType property.
License_LicenseActive | 4005 | Represents the LicenseActive property.
License_MachineName | 4006 | Represents the MachineName property.
License_MediaLevel | 4007 | Represents the MediaLevel property.
License_MediaTypes | 4008 | Represents the MediaTypes property.
DisplayName | 4009 | Represents the DisplayName part of the ConfigurationId property.
Id | 4010 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


StationConfiguration.Rights Class

[image]

IceLib Technical Reference
StationConfiguration..::..Rights Class
StationConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StationConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StationConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StationConfiguration..::..Rights Members
StationConfiguration..::..Rights Class Properties See Also Send Feedback

The StationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
CoachStationQueue | Gets the coach station queue rights filter.
DisconnectStationQueue | Gets the disconnect station queue rights filter.
HoldStationQueue | Gets the hold station queue rights filter.
JoinStationQueue | Gets the join station queue rights filter.
ListenStationQueue | Gets the listen station queue rights filter.
LoginStation | Gets the login station rights filter.
MuteStationQueue | Gets the mute station queue rights filter.
PickupStationQueue | Gets the pickup station queue rights filter.
RecordStationQueue | Gets the record station queue rights filter.
SnipStationQueue | Gets the snip station queue rights filter.
TransferStationQueue | Gets the transfer station queue rights filter.
View | Gets the view rights filter.
ViewStationQueueInSearch | Gets the view station queue in search rights filter.

See Also

StationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StationConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StationConfiguration..::..Rights Properties
StationConfiguration..::..Rights Class See Also Send Feedback

The StationConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
CoachStationQueue | Gets the coach station queue rights filter.
DisconnectStationQueue | Gets the disconnect station queue rights filter.
HoldStationQueue | Gets the hold station queue rights filter.
JoinStationQueue | Gets the join station queue rights filter.
ListenStationQueue | Gets the listen station queue rights filter.
LoginStation | Gets the login station rights filter.
MuteStationQueue | Gets the mute station queue rights filter.
PickupStationQueue | Gets the pickup station queue rights filter.
RecordStationQueue | Gets the record station queue rights filter.
SnipStationQueue | Gets the snip station queue rights filter.
TransferStationQueue | Gets the transfer station queue rights filter.
View | Gets the view rights filter.
ViewStationQueueInSearch | Gets the view station queue in search rights filter.

See Also

StationConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..Admin Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Stations


CoachStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..CoachStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the coach station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> CoachStationQueue { get; private set; }
Visual Basic
Public Shared Property CoachStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The coach station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachStationQueue


DisconnectStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..DisconnectStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the disconnect station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> DisconnectStationQueue { get; private set; }
Visual Basic
Public Shared Property DisconnectStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The disconnect station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectStationQueue


HoldStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..HoldStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the hold station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> HoldStationQueue { get; private set; }
Visual Basic
Public Shared Property HoldStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The hold station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..HoldStationQueue


JoinStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..JoinStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the join station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> JoinStationQueue { get; private set; }
Visual Basic
Public Shared Property JoinStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The join station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinStationQueue


ListenStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..ListenStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the listen station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> ListenStationQueue { get; private set; }
Visual Basic
Public Shared Property ListenStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The listen station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenStationQueue


LoginStation Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..LoginStation Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the login station rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> LoginStation { get; private set; }
Visual Basic
Public Shared Property LoginStation As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The login station rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LoginStation


MuteStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..MuteStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the mute station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> MuteStationQueue { get; private set; }
Visual Basic
Public Shared Property MuteStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The mute station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MuteStationQueue


PickupStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..PickupStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the pickup station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> PickupStationQueue { get; private set; }
Visual Basic
Public Shared Property PickupStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The pickup station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupStationQueue


RecordStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..RecordStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the record station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> RecordStationQueue { get; private set; }
Visual Basic
Public Shared Property RecordStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The record station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordStationQueue


SnipStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..SnipStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the snip station queue rights filter.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> SnipStationQueue { get; private set; }
Visual Basic
Public Shared Property SnipStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The snip station queue rights filter.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipStationQueue


TransferStationQueue Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..TransferStationQueue Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the transfer station queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> TransferStationQueue { get; private set; }
Visual Basic
Public Shared Property TransferStationQueue As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The transfer station queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferStationQueue


View Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..View Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationQueue


ViewStationQueueInSearch Property

[image]

IceLib Technical Reference
StationConfiguration..::..Rights..::..ViewStationQueueInSearch Property
StationConfiguration..::..Rights Class See Also Send Feedback
Gets the view station queue in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationConfiguration> ViewStationQueueInSearch { get; private set; }
Visual Basic
Public Shared Property ViewStationQueueInSearch As RightsQueryFilter(Of StationConfiguration)
    Get
    Private Set

Field Value

The view station queue in search rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationConfiguration..::..Rights Class
StationConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationQueueInSearch


StationConfigurationList Class

[image]

IceLib Technical Reference
StationConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing station configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationConfigurationList : EditableConfigurationList<StationConfiguration, StationConfiguration..::..Property>
Visual Basic
Public Class StationConfigurationList _
    Inherits EditableConfigurationList(Of StationConfiguration, StationConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StationConfiguration, StationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StationConfiguration, StationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' StationConfiguration, StationConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StationConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationConfigurationList Members
ININ.IceLib.Configuration Namespace


StationConfigurationList Members

[image] [image]

IceLib Technical Reference
StationConfigurationList Members
StationConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StationConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StationConfigurationList | Initializes a new instance of the StationConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationConfigurationList Class
ININ.IceLib.Configuration Namespace


StationConfigurationList Constructor

[image]

IceLib Technical Reference
StationConfigurationList Constructor
StationConfigurationList Class See Also Send Feedback
Initializes a new instance of the StationConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationConfigurationList Class
StationConfigurationList Members
ININ.IceLib.Configuration Namespace


StationConfigurationList Methods

[image] [image]

IceLib Technical Reference
StationConfigurationList Methods
StationConfigurationList Class See Also Send Feedback

The StationConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StationConfigurationList Class
ININ.IceLib.Configuration Namespace


StationConfigurationList Properties

[image] [image]

IceLib Technical Reference
StationConfigurationList Properties
StationConfigurationList Class See Also Send Feedback

The StationConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationConfigurationList Class
ININ.IceLib.Configuration Namespace


StationConfigurationList Events

[image] [image]

IceLib Technical Reference
StationConfigurationList Events
StationConfigurationList Class See Also Send Feedback

The StationConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationConfigurationList Class
ININ.IceLib.Configuration Namespace


StationGroupConfiguration Class

[image]

IceLib Technical Reference
StationGroupConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Station Group. A station group defines a logical group of stations that are related.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationGroupConfiguration : ListConfigurationObject
Visual Basic
Public Class StationGroupConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..StationGroupConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfiguration Members
ININ.IceLib.Configuration Namespace


StationGroupConfiguration Members

[image] [image]

IceLib Technical Reference
StationGroupConfiguration Members
StationGroupConfiguration Class Methods Properties See Also Send Feedback

The StationGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this station group (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StationGroupConfiguration Class
ININ.IceLib.Configuration Namespace


StationGroupConfiguration Methods

[image] [image]

IceLib Technical Reference
StationGroupConfiguration Methods
StationGroupConfiguration Class See Also Send Feedback

The StationGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StationGroupConfiguration Class
ININ.IceLib.Configuration Namespace


StationGroupConfiguration Properties

[image] [image]

IceLib Technical Reference
StationGroupConfiguration Properties
StationGroupConfiguration Class See Also Send Feedback

The StationGroupConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this station group (use Property.AccessControlGroupAssignment).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StationGroupConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
StationGroupConfiguration..::..AccessControlGroupAssignment Property
StationGroupConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this station group (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationGroupConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of StationGroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationGroupConfiguration Class
StationGroupConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StationGroupConfiguration..::..StandardProperties Property
StationGroupConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StationGroupConfiguration, StationGroupConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StationGroupConfiguration, StationGroupConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfiguration Class
StationGroupConfiguration Members
ININ.IceLib.Configuration Namespace


StationGroupConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StationGroupConfiguration..::..Property Enumeration
StationGroupConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Id | 2 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


StationGroupConfiguration.Rights Class

[image]

IceLib Technical Reference
StationGroupConfiguration..::..Rights Class
StationGroupConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StationGroupConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StationGroupConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StationGroupConfiguration..::..Rights Members
StationGroupConfiguration..::..Rights Class Properties See Also Send Feedback

The StationGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.
ViewStationGroupsInSearch | Gets the view station groups in search rights filter.

See Also

StationGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StationGroupConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StationGroupConfiguration..::..Rights Properties
StationGroupConfiguration..::..Rights Class See Also Send Feedback

The StationGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.
ViewStationGroupsInSearch | Gets the view station groups in search rights filter.

See Also

StationGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StationGroupConfiguration..::..Rights..::..Admin Property
StationGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationGroupConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StationGroupConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfiguration..::..Rights Class
StationGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StationGroups


View Property

[image]

IceLib Technical Reference
StationGroupConfiguration..::..Rights..::..View Property
StationGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationGroupConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StationGroupConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfiguration..::..Rights Class
StationGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationGroups


ViewStationGroupsInSearch Property

[image]

IceLib Technical Reference
StationGroupConfiguration..::..Rights..::..ViewStationGroupsInSearch Property
StationGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view station groups in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationGroupConfiguration> ViewStationGroupsInSearch { get; private set; }
Visual Basic
Public Shared Property ViewStationGroupsInSearch As RightsQueryFilter(Of StationGroupConfiguration)
    Get
    Private Set

Field Value

The view station groups in search rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfiguration..::..Rights Class
StationGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationGroupsInSearch


StationGroupConfigurationList Class

[image]

IceLib Technical Reference
StationGroupConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing StationGroup configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationGroupConfigurationList : DynamicConfigurationList<StationGroupConfiguration, StationGroupConfiguration..::..Property>
Visual Basic
Public Class StationGroupConfigurationList _
    Inherits DynamicConfigurationList(Of StationGroupConfiguration, StationGroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StationGroupConfiguration, StationGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StationGroupConfiguration, StationGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StationGroupConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


StationGroupConfigurationList Members

[image] [image]

IceLib Technical Reference
StationGroupConfigurationList Members
StationGroupConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StationGroupConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StationGroupConfigurationList | Initializes a new instance of the StationGroupConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


StationGroupConfigurationList Constructor

[image]

IceLib Technical Reference
StationGroupConfigurationList Constructor
StationGroupConfigurationList Class See Also Send Feedback
Initializes a new instance of the StationGroupConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationGroupConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationGroupConfigurationList Class
StationGroupConfigurationList Members
ININ.IceLib.Configuration Namespace


StationGroupConfigurationList Methods

[image] [image]

IceLib Technical Reference
StationGroupConfigurationList Methods
StationGroupConfigurationList Class See Also Send Feedback

The StationGroupConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StationGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


StationGroupConfigurationList Properties

[image] [image]

IceLib Technical Reference
StationGroupConfigurationList Properties
StationGroupConfigurationList Class See Also Send Feedback

The StationGroupConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


StationGroupConfigurationList Events

[image] [image]

IceLib Technical Reference
StationGroupConfigurationList Events
StationGroupConfigurationList Class See Also Send Feedback

The StationGroupConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationGroupConfigurationList Class
ININ.IceLib.Configuration Namespace


StationLicenseProperties Class

[image]

IceLib Technical Reference
StationLicenseProperties Class
Members See Also Send Feedback
Contains license settings for a StationConfiguration.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationLicenseProperties
Visual Basic
Public Class StationLicenseProperties

Remarks

When watching the StationConfigurationList object for StationConfiguration changes, change notifications will not be sent for changes to the License property.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StationLicenseProperties

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Members
ININ.IceLib.Configuration Namespace


StationLicenseProperties Members

[image] [image]

IceLib Technical Reference
StationLicenseProperties Members
StationLicenseProperties Class Methods Properties See Also Send Feedback

The StationLicenseProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalLicenses | Provides access to the property representing the additional licenses for this station (use Property.License_AdditionalLicenses).
Public property | HasBasicStationLicense | Provides access to the property representing basic station license for this station (use Property.License_HasBasicStationLicense).
Public property | HasClientAccess | Provides access to the property representing client access for this station (use Property.License_HasClientAccess).
Public property | HasRecorderAccess | Provides access to the property representing the recorder access for this station (use Property.License_HasRecorderAccess).
Public property | InteractionProcessAutomationLicenseType | Provides access to the property representing the Interaction Process Automation license type for this station (use Property.License_InteractionProcessAutomationType).
Public property | LicenseActive | Provides access to the property representing the license activation for this station (use Property.License_LicenseActive).
Public property | MachineName | Provides access to the property representing machine name for this station (use Property.License_MachineName).
Public property | MediaLevel | Provides access to the property representing the media level for this station (use Property.License_MediaLevel).
Public property | MediaTypes | Provides access to the property representing the media types for this station (use Property.License_MediaTypes).

See Also

StationLicenseProperties Class
ININ.IceLib.Configuration Namespace


StationLicenseProperties Methods

[image] [image]

IceLib Technical Reference
StationLicenseProperties Methods
StationLicenseProperties Class See Also Send Feedback

The StationLicenseProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StationLicenseProperties Class
ININ.IceLib.Configuration Namespace


StationLicenseProperties Properties

[image] [image]

IceLib Technical Reference
StationLicenseProperties Properties
StationLicenseProperties Class See Also Send Feedback

The StationLicenseProperties type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalLicenses | Provides access to the property representing the additional licenses for this station (use Property.License_AdditionalLicenses).
Public property | HasBasicStationLicense | Provides access to the property representing basic station license for this station (use Property.License_HasBasicStationLicense).
Public property | HasClientAccess | Provides access to the property representing client access for this station (use Property.License_HasClientAccess).
Public property | HasRecorderAccess | Provides access to the property representing the recorder access for this station (use Property.License_HasRecorderAccess).
Public property | InteractionProcessAutomationLicenseType | Provides access to the property representing the Interaction Process Automation license type for this station (use Property.License_InteractionProcessAutomationType).
Public property | LicenseActive | Provides access to the property representing the license activation for this station (use Property.License_LicenseActive).
Public property | MachineName | Provides access to the property representing machine name for this station (use Property.License_MachineName).
Public property | MediaLevel | Provides access to the property representing the media level for this station (use Property.License_MediaLevel).
Public property | MediaTypes | Provides access to the property representing the media types for this station (use Property.License_MediaTypes).

See Also

StationLicenseProperties Class
ININ.IceLib.Configuration Namespace


AdditionalLicenses Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..AdditionalLicenses Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing the additional licenses for this station (use Property.License_AdditionalLicenses).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, Collection<ConfigurationId>> AdditionalLicenses { get; }
Visual Basic
Public ReadOnly Property AdditionalLicenses As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the additional licenses.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic), and StationType is Workstation or RemoteStation.
The additional licenses that are assigned to this station. To assign or remove an additional license on this station, modify the Value of this property. One or more licenses must already exist to add a license in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace
StationLicenseProperties..::..LicenseActive
ININ.IceLib.Configuration..::..LicenseAllocationConfiguration
ININ.IceLib.Configuration..::..LicenseAllocationConfigurationList


HasBasicStationLicense Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..HasBasicStationLicense Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing basic station license for this station (use Property.License_HasBasicStationLicense).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> HasBasicStationLicense { get; }
Visual Basic
Public ReadOnly Property HasBasicStationLicense As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing basic station license.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic), and StationType is not UnifiedMessaging.
This is not supported for the UnifiedMessaging station type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace
StationLicenseProperties..::..LicenseActive


HasClientAccess Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..HasClientAccess Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing client access for this station (use Property.License_HasClientAccess).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> HasClientAccess { get; }
Visual Basic
Public ReadOnly Property HasClientAccess As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing client access.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic), and StationType is Workstation or RemoteStation.
Assigning this license to the station allows the client functionality of Interaction Client. Without this license assignment, the station cannot run Interaction Client.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace
StationLicenseProperties..::..LicenseActive


HasRecorderAccess Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..HasRecorderAccess Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing the recorder access for this station (use Property.License_HasRecorderAccess).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> HasRecorderAccess { get; }
Visual Basic
Public ReadOnly Property HasRecorderAccess As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the recorder access.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic), and StationType is StandAloneFaxMachine.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace
StationLicenseProperties..::..LicenseActive


InteractionProcessAutomationLicenseType Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..InteractionProcessAutomationLicenseType Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing the Interaction Process Automation license type for this station (use Property.License_InteractionProcessAutomationType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, InteractionProcessAutomationLicenseType> InteractionProcessAutomationLicenseType { get; }
Visual Basic
Public ReadOnly Property InteractionProcessAutomationLicenseType As GeneralConfigurationProperty(Of StationConfiguration..::..Property, InteractionProcessAutomationLicenseType)
    Get

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic), and StationType is Workstation or RemoteStation.
Specifies what Interaction Process Automation license this station should have. These are the available types of Interaction Process Automation licenses:
  • None - The station does not have an Interaction Process Automation license.
  • DirectRoutedWorkItems - This license enables you to launch any process to which you have rights. It also enables you to receive Work Items that are directly routed to you.
  • GroupRoutedWorkItems - This license enables you to receive Work Items that are either routed to you directly or as a member of a workgroup (similar to an ACD queue).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace


LicenseActive Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..LicenseActive Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing the license activation for this station (use Property.License_LicenseActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, bool> LicenseActive { get; }
Visual Basic
Public ReadOnly Property LicenseActive As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing license activation.

Remarks

Set this to trueTruetruetrue (True in Visual Basic) to set the license settings to Active. If falseFalsefalsefalse (False in Visual Basic), the other license settings are ignored by the system. This is a way to turn off licensing for a station, but keep the license settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace


MachineName Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..MachineName Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing machine name for this station (use Property.License_MachineName).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, string> MachineName { get; }
Visual Basic
Public ReadOnly Property MachineName As GeneralConfigurationProperty(Of StationConfiguration..::..Property, String)
    Get

Field Value

The property representing machine name.

Remarks

This is only valid for StandAloneFaxMachine, StandAlonePhone and Workstation station types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace


MediaLevel Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..MediaLevel Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing the media level for this station (use Property.License_MediaLevel).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, MediaLevel> MediaLevel { get; }
Visual Basic
Public ReadOnly Property MediaLevel As GeneralConfigurationProperty(Of StationConfiguration..::..Property, MediaLevel)
    Get

Field Value

The property representing the media level.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic), and StationType is Workstation or RemoteStation.
Specifies what type of ACD support this station should have. These are the available types of ACD licenses:
  • None - The station does not have ACD licenses.
  • Media1 - This license allows 1 interaction type at a given time.
  • Media2 - This license allows 2 interaction types at a given time.
  • Media3 Plus - This license allows 3 or more interaction types at a given time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace
StationLicenseProperties..::..LicenseActive
ININ.IceLib.Configuration.DataTypes..::..MediaLevel


MediaTypes Property

[image]

IceLib Technical Reference
StationLicenseProperties..::..MediaTypes Property
StationLicenseProperties Class See Also Send Feedback
Provides access to the property representing the media types for this station (use Property.License_MediaTypes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationConfiguration..::..Property, Collection<MediaType>> MediaTypes { get; }
Visual Basic
Public ReadOnly Property MediaTypes As GeneralConfigurationProperty(Of StationConfiguration..::..Property, Collection(Of MediaType))
    Get

Field Value

The property representing the media types.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic) and MediaLevel is Media1 or Media2, and StationType is Workstation or RemoteStation.
Specifies the type of interaction(s) to apply to the license.

Depending on the MediaLevel setting, a different number of MediaType items is expected.

  • Media1 - One MediaType instances is expected in the collection.
  • Media2 - Two MediaType instances are expected in the collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationLicenseProperties Class
StationLicenseProperties Members
ININ.IceLib.Configuration Namespace
StationLicenseProperties..::..LicenseActive
ININ.IceLib.Configuration.DataTypes..::..MediaType


StationTemplateConfiguration Class

[image]

IceLib Technical Reference
StationTemplateConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Station Template. A station template defines default behavior for a station and can be used when configuring the behavior of a new station.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationTemplateConfiguration : EditableListConfigurationObject<StationTemplateConfiguration..::..Property>
Visual Basic
Public Class StationTemplateConfiguration _
    Inherits EditableListConfigurationObject(Of StationTemplateConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' StationTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StationTemplateConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


StationTemplateConfiguration Members

[image] [image]

IceLib Technical Reference
StationTemplateConfiguration Members
StationTemplateConfiguration Class Methods Properties See Also Send Feedback

The StationTemplateConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this station template (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PhoneNumberClassifications | Provides access to the property representing the phone number classifications for this station template (use Property.PhoneNumberClassifications).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StationTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


StationTemplateConfiguration Methods

[image] [image]

IceLib Technical Reference
StationTemplateConfiguration Methods
StationTemplateConfiguration Class See Also Send Feedback

The StationTemplateConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StationTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


StationTemplateConfiguration Properties

[image] [image]

IceLib Technical Reference
StationTemplateConfiguration Properties
StationTemplateConfiguration Class See Also Send Feedback

The StationTemplateConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this station template (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PhoneNumberClassifications | Provides access to the property representing the phone number classifications for this station template (use Property.PhoneNumberClassifications).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StationTemplateConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..AccessControlGroupAssignment Property
StationTemplateConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this station template (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationTemplateConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of StationTemplateConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StationTemplateConfiguration Class
StationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassifications Property

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..PhoneNumberClassifications Property
StationTemplateConfiguration Class See Also Send Feedback
Provides access to the property representing the phone number classifications for this station template (use Property.PhoneNumberClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StationTemplateConfiguration..::..Property, Collection<ConfigurationId>> PhoneNumberClassifications { get; }
Visual Basic
Public ReadOnly Property PhoneNumberClassifications As GeneralConfigurationProperty(Of StationTemplateConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the phone number classifications.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StationTemplateConfiguration Class
StationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..PropertiesChanged Property
StationTemplateConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StationTemplateConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of StationTemplateConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationTemplateConfiguration Class
StationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..StandardProperties Property
StationTemplateConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StationTemplateConfiguration, StationTemplateConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StationTemplateConfiguration, StationTemplateConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationTemplateConfiguration Class
StationTemplateConfiguration Members
ININ.IceLib.Configuration Namespace


StationTemplateConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..Property Enumeration
StationTemplateConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
PhoneNumberClassifications | 1 | Represents the PhoneNumberClassifications property.
DisplayName | 2 | Represents the DisplayName part of the ConfigurationId property.
Id | 3 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


StationTemplateConfiguration.Rights Class

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..Rights Class
StationTemplateConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StationTemplateConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StationTemplateConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StationTemplateConfiguration..::..Rights Members
StationTemplateConfiguration..::..Rights Class Properties See Also Send Feedback

The StationTemplateConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StationTemplateConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StationTemplateConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StationTemplateConfiguration..::..Rights Properties
StationTemplateConfiguration..::..Rights Class See Also Send Feedback

The StationTemplateConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StationTemplateConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..Rights..::..Admin Property
StationTemplateConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationTemplateConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StationTemplateConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationTemplateConfiguration..::..Rights Class
StationTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StationTemplates


View Property

[image]

IceLib Technical Reference
StationTemplateConfiguration..::..Rights..::..View Property
StationTemplateConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StationTemplateConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StationTemplateConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StationTemplateConfiguration..::..Rights Class
StationTemplateConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StationTemplateConfigurationList Class

[image]

IceLib Technical Reference
StationTemplateConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing stationTemplate configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationTemplateConfigurationList : EditableConfigurationList<StationTemplateConfiguration, StationTemplateConfiguration..::..Property>
Visual Basic
Public Class StationTemplateConfigurationList _
    Inherits EditableConfigurationList(Of StationTemplateConfiguration, StationTemplateConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StationTemplateConfiguration, StationTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StationTemplateConfiguration, StationTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' StationTemplateConfiguration, StationTemplateConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StationTemplateConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationTemplateConfigurationList Members
ININ.IceLib.Configuration Namespace


StationTemplateConfigurationList Members

[image] [image]

IceLib Technical Reference
StationTemplateConfigurationList Members
StationTemplateConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StationTemplateConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StationTemplateConfigurationList | Initializes a new instance of the StationTemplateConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


StationTemplateConfigurationList Constructor

[image]

IceLib Technical Reference
StationTemplateConfigurationList Constructor
StationTemplateConfigurationList Class See Also Send Feedback
Initializes a new instance of the StationTemplateConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationTemplateConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationTemplateConfigurationList Class
StationTemplateConfigurationList Members
ININ.IceLib.Configuration Namespace


StationTemplateConfigurationList Methods

[image] [image]

IceLib Technical Reference
StationTemplateConfigurationList Methods
StationTemplateConfigurationList Class See Also Send Feedback

The StationTemplateConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


StationTemplateConfigurationList Properties

[image] [image]

IceLib Technical Reference
StationTemplateConfigurationList Properties
StationTemplateConfigurationList Class See Also Send Feedback

The StationTemplateConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


StationTemplateConfigurationList Events

[image] [image]

IceLib Technical Reference
StationTemplateConfigurationList Events
StationTemplateConfigurationList Class See Also Send Feedback

The StationTemplateConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StationTemplateConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration Class

[image]

IceLib Technical Reference
StatusColumnConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC StatusColumn.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusColumnConfiguration : ListConfigurationObject
Visual Basic
Public Class StatusColumnConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..StatusColumnConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfiguration Members
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration Members

[image] [image]

IceLib Technical Reference
StatusColumnConfiguration Members
StatusColumnConfiguration Class Methods Properties See Also Send Feedback

The StatusColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StatusColumnConfiguration Class
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration Methods

[image] [image]

IceLib Technical Reference
StatusColumnConfiguration Methods
StatusColumnConfiguration Class See Also Send Feedback

The StatusColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StatusColumnConfiguration Class
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration Properties

[image] [image]

IceLib Technical Reference
StatusColumnConfiguration Properties
StatusColumnConfiguration Class See Also Send Feedback

The StatusColumnConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StatusColumnConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StatusColumnConfiguration..::..StandardProperties Property
StatusColumnConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StatusColumnConfiguration, StatusColumnConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StatusColumnConfiguration, StatusColumnConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfiguration Class
StatusColumnConfiguration Members
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StatusColumnConfiguration..::..Property Enumeration
StatusColumnConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


StatusColumnConfiguration.Rights Class

[image]

IceLib Technical Reference
StatusColumnConfiguration..::..Rights Class
StatusColumnConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StatusColumnConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StatusColumnConfiguration..::..Rights Members
StatusColumnConfiguration..::..Rights Class Properties See Also Send Feedback

The StatusColumnConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StatusColumnConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StatusColumnConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StatusColumnConfiguration..::..Rights Properties
StatusColumnConfiguration..::..Rights Class See Also Send Feedback

The StatusColumnConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StatusColumnConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StatusColumnConfiguration..::..Rights..::..Admin Property
StatusColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StatusColumnConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StatusColumnConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfiguration..::..Rights Class
StatusColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
StatusColumnConfiguration..::..Rights..::..View Property
StatusColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StatusColumnConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StatusColumnConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfiguration..::..Rights Class
StatusColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStatusColumns


StatusColumnConfigurationList Class

[image]

IceLib Technical Reference
StatusColumnConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing StatusColumn configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusColumnConfigurationList : DynamicConfigurationList<StatusColumnConfiguration, StatusColumnConfiguration..::..Property>
Visual Basic
Public Class StatusColumnConfigurationList _
    Inherits DynamicConfigurationList(Of StatusColumnConfiguration, StatusColumnConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StatusColumnConfiguration, StatusColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StatusColumnConfiguration, StatusColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StatusColumnConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfigurationList Members
ININ.IceLib.Configuration Namespace


StatusColumnConfigurationList Members

[image] [image]

IceLib Technical Reference
StatusColumnConfigurationList Members
StatusColumnConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StatusColumnConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StatusColumnConfigurationList | Initializes a new instance of the StatusColumnConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StatusColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusColumnConfigurationList Constructor

[image]

IceLib Technical Reference
StatusColumnConfigurationList Constructor
StatusColumnConfigurationList Class See Also Send Feedback
Initializes a new instance of the StatusColumnConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusColumnConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusColumnConfigurationList Class
StatusColumnConfigurationList Members
ININ.IceLib.Configuration Namespace


StatusColumnConfigurationList Methods

[image] [image]

IceLib Technical Reference
StatusColumnConfigurationList Methods
StatusColumnConfigurationList Class See Also Send Feedback

The StatusColumnConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusColumnConfigurationList Properties

[image] [image]

IceLib Technical Reference
StatusColumnConfigurationList Properties
StatusColumnConfigurationList Class See Also Send Feedback

The StatusColumnConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StatusColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusColumnConfigurationList Events

[image] [image]

IceLib Technical Reference
StatusColumnConfigurationList Events
StatusColumnConfigurationList Class See Also Send Feedback

The StatusColumnConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StatusColumnConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration Class

[image]

IceLib Technical Reference
StatusMessageConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Status Message. A status message is used for reporting status times.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusMessageConfiguration : EditableListConfigurationObject<StatusMessageConfiguration..::..Property>
Visual Basic
Public Class StatusMessageConfiguration _
    Inherits EditableListConfigurationObject(Of StatusMessageConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' StatusMessageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StatusMessageConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration Members

[image] [image]

IceLib Technical Reference
StatusMessageConfiguration Members
StatusMessageConfiguration Class Methods Properties See Also Send Feedback

The StatusMessageConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AllowAcdCalls | Provides access to the property representing the ACD flag for this status message (use Property.AllowAcdCalls).
Public property | AllowFollowUp | Provides access to the property representing the AllowFollowUp flag for this status message (use Property.AllowFollowUp).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | GroupTagKey | Provides access to the property representing the GroupTagKey for this status message (use Property.GroupTagKey).
Public property | HasDate | Provides access to the property representing the HasDate flag for this status message (use Property.HasDate).
Public property | HasTime | Provides access to the property representing the HasTime flag for this status message (use Property.HasTime).
Public property | Icon | Provides access to the property representing the Icon for this status message (use Property.Icon).
Public property | IsAfterCallWork | Provides access to the property representing the AfterCallWork flag for this status message (use Property.IsAfterCallWork).
Public property | IsDoNotDisturb | Provides access to the property representing the DND flag for this status message (use Property.IsDoNotDisturb).
Public property | IsForward | Provides access to the property representing the IsForward flag for this status message (use Property.IsForward).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPersistent | Provides access to the property representing the Persistent flag for this status message (use Property.IsPersistent).
Public property | IsUserSelectable | Provides access to the property representing the UserSelectable flag for this status message (use Property.IsUserSelectable).
Public property | MessageText | Provides access to the property representing the text for this status message (use Property.MessageText).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StatusMessageConfiguration Class
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration Methods

[image] [image]

IceLib Technical Reference
StatusMessageConfiguration Methods
StatusMessageConfiguration Class See Also Send Feedback

The StatusMessageConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StatusMessageConfiguration Class
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration Properties

[image] [image]

IceLib Technical Reference
StatusMessageConfiguration Properties
StatusMessageConfiguration Class See Also Send Feedback

The StatusMessageConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AllowAcdCalls | Provides access to the property representing the ACD flag for this status message (use Property.AllowAcdCalls).
Public property | AllowFollowUp | Provides access to the property representing the AllowFollowUp flag for this status message (use Property.AllowFollowUp).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | GroupTagKey | Provides access to the property representing the GroupTagKey for this status message (use Property.GroupTagKey).
Public property | HasDate | Provides access to the property representing the HasDate flag for this status message (use Property.HasDate).
Public property | HasTime | Provides access to the property representing the HasTime flag for this status message (use Property.HasTime).
Public property | Icon | Provides access to the property representing the Icon for this status message (use Property.Icon).
Public property | IsAfterCallWork | Provides access to the property representing the AfterCallWork flag for this status message (use Property.IsAfterCallWork).
Public property | IsDoNotDisturb | Provides access to the property representing the DND flag for this status message (use Property.IsDoNotDisturb).
Public property | IsForward | Provides access to the property representing the IsForward flag for this status message (use Property.IsForward).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPersistent | Provides access to the property representing the Persistent flag for this status message (use Property.IsPersistent).
Public property | IsUserSelectable | Provides access to the property representing the UserSelectable flag for this status message (use Property.IsUserSelectable).
Public property | MessageText | Provides access to the property representing the text for this status message (use Property.MessageText).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StatusMessageConfiguration Class
ININ.IceLib.Configuration Namespace


AllowAcdCalls Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..AllowAcdCalls Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD flag for this status message (use Property.AllowAcdCalls).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> AllowAcdCalls { get; }
Visual Basic
Public ReadOnly Property AllowAcdCalls As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the ACD flag.

Remarks

Set this flag if the status message should indicate an agent is available to receive ACD calls. If the status message does not have this flag set, an agent using the status cannot receive ACD calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


AllowFollowUp Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..AllowFollowUp Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the AllowFollowUp flag for this status message (use Property.AllowFollowUp).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> AllowFollowUp { get; }
Visual Basic
Public ReadOnly Property AllowFollowUp As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the AllowFollowUp flag.

Remarks

Set this flag if the status message should indicate that an agent's status can change to "Follow Up" after an ACD call terminates. If this flag is clear, terminating ACD calls does not automatically change the agent's status to Follow Up.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


GroupTagKey Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..GroupTagKey Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the GroupTagKey for this status message (use Property.GroupTagKey).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, string> GroupTagKey { get; }
Visual Basic
Public ReadOnly Property GroupTagKey As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, String)
    Get

Field Value

The property representing the GroupTagKey.

Remarks

Used to describe or categorize the status message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


HasDate Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..HasDate Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the HasDate flag for this status message (use Property.HasDate).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> HasDate { get; }
Visual Basic
Public ReadOnly Property HasDate As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the HasDate flag.

Remarks

Set this flag if the status message should indicate an ending date, typically used when the Do Not Disturb attribute is set. Clear this flag if the status should indicate the user is available to take calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


HasTime Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..HasTime Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the HasTime flag for this status message (use Property.HasTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> HasTime { get; }
Visual Basic
Public ReadOnly Property HasTime As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the HasTime flag.

Remarks

Set this flag if the status message should indicate an ending time, typically used when the Do Not Disturb attribute is set. Clear this flag if the status should indicate the user is available to take calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


Icon Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..Icon Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the Icon for this status message (use Property.Icon).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, string> Icon { get; }
Visual Basic
Public ReadOnly Property Icon As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, String)
    Get

Field Value

The property representing the Icon.

Remarks

A path, parameter, or full path and file name with an .ICO extension that contains an icon representing the status message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


IsAfterCallWork Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..IsAfterCallWork Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the AfterCallWork flag for this status message (use Property.IsAfterCallWork).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> IsAfterCallWork { get; }
Visual Basic
Public ReadOnly Property IsAfterCallWork As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the AfterCallWork flag.

Remarks

Set this flag if the status message should indicate an agent is in a "Follow Up" mode after an ACD call. Clear this flag if the status is not a follow-up status for ACD calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


IsDoNotDisturb Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..IsDoNotDisturb Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the DND flag for this status message (use Property.IsDoNotDisturb).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> IsDoNotDisturb { get; }
Visual Basic
Public ReadOnly Property IsDoNotDisturb As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the DND flag.

Remarks

Set this flag if the status should indicate the user is unavailable or should not be interrupted. Clear this flag if the status should indicate the user is available to receive calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


IsForward Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..IsForward Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the IsForward flag for this status message (use Property.IsForward).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> IsForward { get; }
Visual Basic
Public ReadOnly Property IsForward As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the IsForward flag.

Remarks

Set this flag if the status message should indicate the user is available at a different phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


IsPersistent Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..IsPersistent Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the Persistent flag for this status message (use Property.IsPersistent).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> IsPersistent { get; }
Visual Basic
Public ReadOnly Property IsPersistent As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the Persistent flag.

Remarks

Set this flag if the status message can persist when the agent logs out of IC (for example, exits Interaction Client).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


IsUserSelectable Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..IsUserSelectable Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the UserSelectable flag for this status message (use Property.IsUserSelectable).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, bool> IsUserSelectable { get; }
Visual Basic
Public ReadOnly Property IsUserSelectable As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the UserSelectable flag.

Remarks

Set this flag if the user can select the status message from the Interaction Client interface or the system tray icon.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


MessageText Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..MessageText Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the property representing the text for this status message (use Property.MessageText).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StatusMessageConfiguration..::..Property, MultiLanguageString> MessageText { get; }
Visual Basic
Public ReadOnly Property MessageText As GeneralConfigurationProperty(Of StatusMessageConfiguration..::..Property, MultiLanguageString)
    Get

Field Value

The property representing the MessageText text.

Remarks

The text to appear on the Interaction Client's My Status list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..PropertiesChanged Property
StatusMessageConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatusMessageConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of StatusMessageConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..StandardProperties Property
StatusMessageConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StatusMessageConfiguration, StatusMessageConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StatusMessageConfiguration, StatusMessageConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfiguration Class
StatusMessageConfiguration Members
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..Property Enumeration
StatusMessageConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AllowAcdCalls | 0 | Represents the AllowAcdCalls property.
AllowFollowUp | 1 | Represents the AllowFollowUp property.
GroupTagKey | 2 | Represents the GroupTagKey property.
HasDate | 3 | Represents the HasDate property.
HasTime | 4 | Represents the HasTime property.
Icon | 5 | Represents the Icon property.
IsAfterCallWork | 6 | Represents the IsAfterCallWork property.
IsDoNotDisturb | 7 | Represents the IsDoNotDisturb property.
IsForward | 8 | Represents the IsForward property.
IsPersistent | 9 | Represents the IsPersistent property.
IsUserSelectable | 10 | Represents the IsUserSelectable property.
MessageText | 11 | Represents the MessageText property.
DisplayName | 12 | Represents the DisplayName part of the ConfigurationId property.
Id | 13 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


StatusMessageConfiguration.Rights Class

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..Rights Class
StatusMessageConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StatusMessageConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StatusMessageConfiguration..::..Rights Members
StatusMessageConfiguration..::..Rights Class Properties See Also Send Feedback

The StatusMessageConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StatusMessageConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StatusMessageConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StatusMessageConfiguration..::..Rights Properties
StatusMessageConfiguration..::..Rights Class See Also Send Feedback

The StatusMessageConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StatusMessageConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..Rights..::..Admin Property
StatusMessageConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StatusMessageConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StatusMessageConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfiguration..::..Rights Class
StatusMessageConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StatusMessages


View Property

[image]

IceLib Technical Reference
StatusMessageConfiguration..::..Rights..::..View Property
StatusMessageConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StatusMessageConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StatusMessageConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfiguration..::..Rights Class
StatusMessageConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StatusMessages


StatusMessageConfigurationList Class

[image]

IceLib Technical Reference
StatusMessageConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing StatusMessage configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusMessageConfigurationList : EditableConfigurationList<StatusMessageConfiguration, StatusMessageConfiguration..::..Property>
Visual Basic
Public Class StatusMessageConfigurationList _
    Inherits EditableConfigurationList(Of StatusMessageConfiguration, StatusMessageConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StatusMessageConfiguration, StatusMessageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StatusMessageConfiguration, StatusMessageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' StatusMessageConfiguration, StatusMessageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StatusMessageConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfigurationList Members
ININ.IceLib.Configuration Namespace


StatusMessageConfigurationList Members

[image] [image]

IceLib Technical Reference
StatusMessageConfigurationList Members
StatusMessageConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StatusMessageConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StatusMessageConfigurationList | Initializes a new instance of the StatusMessageConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StatusMessageConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusMessageConfigurationList Constructor

[image]

IceLib Technical Reference
StatusMessageConfigurationList Constructor
StatusMessageConfigurationList Class See Also Send Feedback
Initializes a new instance of the StatusMessageConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatusMessageConfigurationList Class
StatusMessageConfigurationList Members
ININ.IceLib.Configuration Namespace


StatusMessageConfigurationList Methods

[image] [image]

IceLib Technical Reference
StatusMessageConfigurationList Methods
StatusMessageConfigurationList Class See Also Send Feedback

The StatusMessageConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusMessageConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusMessageConfigurationList Properties

[image] [image]

IceLib Technical Reference
StatusMessageConfigurationList Properties
StatusMessageConfigurationList Class See Also Send Feedback

The StatusMessageConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StatusMessageConfigurationList Class
ININ.IceLib.Configuration Namespace


StatusMessageConfigurationList Events

[image] [image]

IceLib Technical Reference
StatusMessageConfigurationList Events
StatusMessageConfigurationList Class See Also Send Feedback

The StatusMessageConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StatusMessageConfigurationList Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration Class

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an StreamingAudioMonitorProfile.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StreamingAudioMonitorProfileConfiguration : EditableListConfigurationObject<StreamingAudioMonitorProfileConfiguration..::..Property>
Visual Basic
Public Class StreamingAudioMonitorProfileConfiguration _
    Inherits EditableListConfigurationObject(Of StreamingAudioMonitorProfileConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' StreamingAudioMonitorProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StreamingAudioMonitorProfileConfiguration

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration Members

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration Members
StreamingAudioMonitorProfileConfiguration Class Methods Properties See Also Send Feedback

The StreamingAudioMonitorProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AdditionalAttributes | Provides access to the property representing the streaming audio monitor profile additional attributes for this profile.(use Property.AdditionalAttributes).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Endpoints | Provides access to the property representing the Endpoints for this StreamingAudioMonitorProfile (use Property.Endpoints).
Public property | Header | Provides access to the property representing the Header for this StreamingAudioMonitorProfile (use Property.Header).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Uri | Provides access to the property representing the Uri for this StreamingAudioMonitorProfile (use Property.Uri).

See Also

StreamingAudioMonitorProfileConfiguration Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration Methods

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration Methods
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback

The StreamingAudioMonitorProfileConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StreamingAudioMonitorProfileConfiguration Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration Properties

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration Properties
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback

The StreamingAudioMonitorProfileConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Provides access to the property representing the streaming audio monitor profile additional attributes for this profile.(use Property.AdditionalAttributes).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Endpoints | Provides access to the property representing the Endpoints for this StreamingAudioMonitorProfile (use Property.Endpoints).
Public property | Header | Provides access to the property representing the Header for this StreamingAudioMonitorProfile (use Property.Header).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | Uri | Provides access to the property representing the Uri for this StreamingAudioMonitorProfile (use Property.Uri).

See Also

StreamingAudioMonitorProfileConfiguration Class
ININ.IceLib.Configuration Namespace


AdditionalAttributes Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..AdditionalAttributes Property
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Provides access to the property representing the streaming audio monitor profile additional attributes for this profile.(use Property.AdditionalAttributes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StreamingAudioMonitorProfileConfiguration..::..Property, string> AdditionalAttributes { get; }
Visual Basic
Public ReadOnly Property AdditionalAttributes As GeneralConfigurationProperty(Of StreamingAudioMonitorProfileConfiguration..::..Property, String)
    Get

Field Value

The property representing the additional data.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Class
StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


Endpoints Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Endpoints Property
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Provides access to the property representing the Endpoints for this StreamingAudioMonitorProfile (use Property.Endpoints).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StreamingAudioMonitorProfileConfiguration..::..Property, string> Endpoints { get; }
Visual Basic
Public ReadOnly Property Endpoints As GeneralConfigurationProperty(Of StreamingAudioMonitorProfileConfiguration..::..Property, String)
    Get

Field Value

The property representing Endpoints.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Class
StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


Header Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Header Property
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Provides access to the property representing the Header for this StreamingAudioMonitorProfile (use Property.Header).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StreamingAudioMonitorProfileConfiguration..::..Property, string> Header { get; }
Visual Basic
Public ReadOnly Property Header As GeneralConfigurationProperty(Of StreamingAudioMonitorProfileConfiguration..::..Property, String)
    Get

Field Value

The property representing Header.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Class
StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..PropertiesChanged Property
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StreamingAudioMonitorProfileConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of StreamingAudioMonitorProfileConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Class
StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..StandardProperties Property
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Class
StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


Uri Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Uri Property
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Provides access to the property representing the Uri for this StreamingAudioMonitorProfile (use Property.Uri).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StreamingAudioMonitorProfileConfiguration..::..Property, string> Uri { get; }
Visual Basic
Public ReadOnly Property Uri As GeneralConfigurationProperty(Of StreamingAudioMonitorProfileConfiguration..::..Property, String)
    Get

Field Value

The property representing Uri.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration Class
StreamingAudioMonitorProfileConfiguration Members
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Property Enumeration
StreamingAudioMonitorProfileConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Uri | 0 | Represents the Uri property.
Header | 1 | Represents the Header property.
Endpoints | 2 | Represents the Endpoints property.
AdditionalAttributes | 3 | Represents the AdditionalAttributes property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration.Rights Class

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Rights Class
StreamingAudioMonitorProfileConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StreamingAudioMonitorProfileConfiguration..::..Rights

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Rights Members
StreamingAudioMonitorProfileConfiguration..::..Rights Class Properties See Also Send Feedback

The StreamingAudioMonitorProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StreamingAudioMonitorProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Rights Properties
StreamingAudioMonitorProfileConfiguration..::..Rights Class See Also Send Feedback

The StreamingAudioMonitorProfileConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StreamingAudioMonitorProfileConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Rights..::..Admin Property
StreamingAudioMonitorProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StreamingAudioMonitorProfileConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StreamingAudioMonitorProfileConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration..::..Rights Class
StreamingAudioMonitorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StreamingAudioMonitorProfiles


View Property

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfiguration..::..Rights..::..View Property
StreamingAudioMonitorProfileConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StreamingAudioMonitorProfileConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StreamingAudioMonitorProfileConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2019 R1 and beyond.

See Also

StreamingAudioMonitorProfileConfiguration..::..Rights Class
StreamingAudioMonitorProfileConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfigurationList Class

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing StreamingAudioMonitorProfile configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StreamingAudioMonitorProfileConfigurationList : EditableConfigurationList<StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property>
Visual Basic
Public Class StreamingAudioMonitorProfileConfigurationList _
    Inherits EditableConfigurationList(Of StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' StreamingAudioMonitorProfileConfiguration, StreamingAudioMonitorProfileConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StreamingAudioMonitorProfileConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StreamingAudioMonitorProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfigurationList Members

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfigurationList Members
StreamingAudioMonitorProfileConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StreamingAudioMonitorProfileConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StreamingAudioMonitorProfileConfigurationList | Initializes a new instance of the StreamingAudioMonitorProfileConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StreamingAudioMonitorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfigurationList Constructor

[image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfigurationList Constructor
StreamingAudioMonitorProfileConfigurationList Class See Also Send Feedback
Initializes a new instance of the StreamingAudioMonitorProfileConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StreamingAudioMonitorProfileConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StreamingAudioMonitorProfileConfigurationList Class
StreamingAudioMonitorProfileConfigurationList Members
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfigurationList Methods

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfigurationList Methods
StreamingAudioMonitorProfileConfigurationList Class See Also Send Feedback

The StreamingAudioMonitorProfileConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StreamingAudioMonitorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfigurationList Properties

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfigurationList Properties
StreamingAudioMonitorProfileConfigurationList Class See Also Send Feedback

The StreamingAudioMonitorProfileConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StreamingAudioMonitorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


StreamingAudioMonitorProfileConfigurationList Events

[image] [image]

IceLib Technical Reference
StreamingAudioMonitorProfileConfigurationList Events
StreamingAudioMonitorProfileConfigurationList Class See Also Send Feedback

The StreamingAudioMonitorProfileConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StreamingAudioMonitorProfileConfigurationList Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration Class

[image]

IceLib Technical Reference
StructuredParameterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC StructuredParameter. Structured parameters are typed parameters grouped together (like server parameters).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StructuredParameterConfiguration : EditableListConfigurationObject<StructuredParameterConfiguration..::..Property>
Visual Basic
Public Class StructuredParameterConfiguration _
    Inherits EditableListConfigurationObject(Of StructuredParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' StructuredParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StructuredParameterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfiguration Members
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration Members

[image] [image]

IceLib Technical Reference
StructuredParameterConfiguration Members
StructuredParameterConfiguration Class Methods Properties See Also Send Feedback

The StructuredParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the description for this structured parameter (use Property.Description).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | Parameters | Provides access to the property representing the parameters for this structured parameter (use Property.Parameters).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StructuredParameterConfiguration Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration Methods

[image] [image]

IceLib Technical Reference
StructuredParameterConfiguration Methods
StructuredParameterConfiguration Class See Also Send Feedback

The StructuredParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

StructuredParameterConfiguration Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration Properties

[image] [image]

IceLib Technical Reference
StructuredParameterConfiguration Properties
StructuredParameterConfiguration Class See Also Send Feedback

The StructuredParameterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Provides access to the property representing the description for this structured parameter (use Property.Description).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | Parameters | Provides access to the property representing the parameters for this structured parameter (use Property.Parameters).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

StructuredParameterConfiguration Class
ININ.IceLib.Configuration Namespace


Description Property

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Description Property
StructuredParameterConfiguration Class See Also Send Feedback
Provides access to the property representing the description for this structured parameter (use Property.Description).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StructuredParameterConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of StructuredParameterConfiguration..::..Property, String)
    Get

Field Value

The property representing the description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameterConfiguration Class
StructuredParameterConfiguration Members
ININ.IceLib.Configuration Namespace


Parameters Property

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Parameters Property
StructuredParameterConfiguration Class See Also Send Feedback
Provides access to the property representing the parameters for this structured parameter (use Property.Parameters).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<StructuredParameterConfiguration..::..Property, Collection<StructuredParameter>> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As GeneralConfigurationProperty(Of StructuredParameterConfiguration..::..Property, Collection(Of StructuredParameter))
    Get

Field Value

The property representing the parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameterConfiguration Class
StructuredParameterConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..PropertiesChanged Property
StructuredParameterConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StructuredParameterConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of StructuredParameterConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameterConfiguration Class
StructuredParameterConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..StandardProperties Property
StructuredParameterConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfiguration Class
StructuredParameterConfiguration Members
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Property Enumeration
StructuredParameterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Description | 0 | Represents the Description property.
Parameters | 1 | Represents the Parameters property.
DisplayName | 2 | Represents the DisplayName part of the ConfigurationId property.
Id | 3 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration.Rights Class

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Rights Class
StructuredParameterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..StructuredParameterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Rights Members
StructuredParameterConfiguration..::..Rights Class Properties See Also Send Feedback

The StructuredParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StructuredParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Rights Properties
StructuredParameterConfiguration..::..Rights Class See Also Send Feedback

The StructuredParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

StructuredParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Rights..::..Admin Property
StructuredParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StructuredParameterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of StructuredParameterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfiguration..::..Rights Class
StructuredParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StructuredParameters


View Property

[image]

IceLib Technical Reference
StructuredParameterConfiguration..::..Rights..::..View Property
StructuredParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<StructuredParameterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of StructuredParameterConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfiguration..::..Rights Class
StructuredParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


StructuredParameterConfigurationList Class

[image]

IceLib Technical Reference
StructuredParameterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing StructuredParameter configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StructuredParameterConfigurationList : EditableConfigurationList<StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property>
Visual Basic
Public Class StructuredParameterConfigurationList _
    Inherits EditableConfigurationList(Of StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' StructuredParameterConfiguration, StructuredParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..StructuredParameterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


StructuredParameterConfigurationList Members

[image] [image]

IceLib Technical Reference
StructuredParameterConfigurationList Members
StructuredParameterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StructuredParameterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StructuredParameterConfigurationList | Initializes a new instance of the StructuredParameterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StructuredParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfigurationList Constructor

[image]

IceLib Technical Reference
StructuredParameterConfigurationList Constructor
StructuredParameterConfigurationList Class See Also Send Feedback
Initializes a new instance of the StructuredParameterConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StructuredParameterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StructuredParameterConfigurationList Class
StructuredParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


StructuredParameterConfigurationList Methods

[image] [image]

IceLib Technical Reference
StructuredParameterConfigurationList Methods
StructuredParameterConfigurationList Class See Also Send Feedback

The StructuredParameterConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuredParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfigurationList Properties

[image] [image]

IceLib Technical Reference
StructuredParameterConfigurationList Properties
StructuredParameterConfigurationList Class See Also Send Feedback

The StructuredParameterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StructuredParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


StructuredParameterConfigurationList Events

[image] [image]

IceLib Technical Reference
StructuredParameterConfigurationList Events
StructuredParameterConfigurationList Class See Also Send Feedback

The StructuredParameterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

StructuredParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


SystemConfiguration Class

[image]

IceLib Technical Reference
SystemConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for the Interaction Center system.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SystemConfiguration : EditableContainerConfigurationObject<SystemConfiguration..::..Property>
Visual Basic
Public Class SystemConfiguration _
    Inherits EditableContainerConfigurationObject(Of SystemConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' SystemConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SystemConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SystemConfiguration Members
ININ.IceLib.Configuration Namespace


SystemConfiguration Members

[image] [image]

IceLib Technical Reference
SystemConfiguration Members
SystemConfiguration Class Methods Properties See Also Send Feedback

The SystemConfiguration type exposes the following members.

Methods

Name Description
Public method CancelEdit
Cancels an edit started by PrepareForEdit()()()().
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Commit
Commits the contents of this object to the server.
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method CommitAsync
Asynchronously commits the contents of this object to the server.
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSupportedLanguages
Queries the server for a list of supported system languages.

When setting the language to retrieve with SetLanguageToRetrieve(String), this list will contain all of the available languages that can be used. SetLanguageToRetrieve(String) expects the value from the Name property. The DefaultLanguage can be used for the SetLanguageToRetrieve(String), as well as any of the languages contained in Languages.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.
GetTimeZones
Queries the server for a list of time zones.

Returns a list of time zones and their display name. Each time zone has 3 possible display names: normal display name, daylight saving time display name, and standard time display name. As a result, this function requires an enum value from TimeZoneDisplayNameType in the input so it can return the correct display name.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValidators
Gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method GetValidatorsAsync
Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method PrepareForEdit
Prepares a container-based configuration object for edit.
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | DefaultLanguage | Provides access to the property reprsenting the default language (use Property.DefaultLanguage).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Languages | Provides access to the property representing the languages (use Property.Languages).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SystemConfiguration Class
ININ.IceLib.Configuration Namespace


SystemConfiguration Methods

[image] [image]

IceLib Technical Reference
SystemConfiguration Methods
SystemConfiguration Class See Also Send Feedback

The SystemConfiguration type exposes the following members.

Methods

Name Description
Public method CancelEdit
Cancels an edit started by PrepareForEdit()()()().
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Commit
Commits the contents of this object to the server.
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method CommitAsync
Asynchronously commits the contents of this object to the server.
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSupportedLanguages
Queries the server for a list of supported system languages.

When setting the language to retrieve with SetLanguageToRetrieve(String), this list will contain all of the available languages that can be used. SetLanguageToRetrieve(String) expects the value from the Name property. The DefaultLanguage can be used for the SetLanguageToRetrieve(String), as well as any of the languages contained in Languages.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.
GetTimeZones
Queries the server for a list of time zones.

Returns a list of time zones and their display name. Each time zone has 3 possible display names: normal display name, daylight saving time display name, and standard time display name. As a result, this function requires an enum value from TimeZoneDisplayNameType in the input so it can return the correct display name.

Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetValidators
Gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method GetValidatorsAsync
Asynchronously gets the validators for a given configuration object type (and associates them with their Properties).
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method PrepareForEdit
Prepares a container-based configuration object for edit.
(Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from ConfigurationObject.)

See Also

SystemConfiguration Class
ININ.IceLib.Configuration Namespace


GetSupportedLanguages Method

[image]

IceLib Technical Reference
SystemConfiguration..::..GetSupportedLanguages Method
SystemConfiguration Class See Also Send Feedback
Queries the server for a list of supported system languages.

When setting the language to retrieve with SetLanguageToRetrieve(String), this list will contain all of the available languages that can be used. SetLanguageToRetrieve(String) expects the value from the Name property. The DefaultLanguage can be used for the SetLanguageToRetrieve(String), as well as any of the languages contained in Languages.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<SystemLanguage> GetSupportedLanguages(
    ConfigurationManager configurationManager
)
Visual Basic
Public Shared Function GetSupportedLanguages ( _
    configurationManager As ConfigurationManager _
) As ReadOnlyCollection(Of SystemLanguage)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Return Value

A collection of SystemLanguage of the supported languages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SystemConfiguration Class
SystemConfiguration Members
ININ.IceLib.Configuration Namespace


GetTimeZones Method

[image]

IceLib Technical Reference
SystemConfiguration..::..GetTimeZones Method
SystemConfiguration Class See Also Send Feedback
Queries the server for a list of time zones.

Returns a list of time zones and their display name. Each time zone has 3 possible display names: normal display name, daylight saving time display name, and standard time display name. As a result, this function requires an enum value from TimeZoneDisplayNameType in the input so it can return the correct display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ConfigurationId> GetTimeZones(
    ConfigurationManager configurationManager,
    TimeZoneDisplayNameType displayNameType
)
Visual Basic
Public Shared Function GetTimeZones ( _
    configurationManager As ConfigurationManager, _
    displayNameType As TimeZoneDisplayNameType _
) As ReadOnlyCollection(Of ConfigurationId)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
displayNameType
Type: ININ.IceLib.Configuration.DataTypes..::..TimeZoneDisplayNameType
Display type of the name.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ConfigurationId objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SystemConfiguration Class
SystemConfiguration Members
ININ.IceLib.Configuration Namespace


SystemConfiguration Properties

[image] [image]

IceLib Technical Reference
SystemConfiguration Properties
SystemConfiguration Class See Also Send Feedback

The SystemConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | DefaultLanguage | Provides access to the property reprsenting the default language (use Property.DefaultLanguage).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | Languages | Provides access to the property representing the languages (use Property.Languages).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SystemConfiguration Class
ININ.IceLib.Configuration Namespace


DefaultLanguage Property

[image]

IceLib Technical Reference
SystemConfiguration..::..DefaultLanguage Property
SystemConfiguration Class See Also Send Feedback
Provides access to the property reprsenting the default language (use Property.DefaultLanguage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SystemConfiguration..::..Property, CultureInfo> DefaultLanguage { get; }
Visual Basic
Public ReadOnly Property DefaultLanguage As GeneralConfigurationProperty(Of SystemConfiguration..::..Property, CultureInfo)
    Get

Field Value

The property representing the default language.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemConfiguration Class
SystemConfiguration Members
ININ.IceLib.Configuration Namespace


Languages Property

[image]

IceLib Technical Reference
SystemConfiguration..::..Languages Property
SystemConfiguration Class See Also Send Feedback
Provides access to the property representing the languages (use Property.Languages).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<SystemConfiguration..::..Property, Collection<CultureInfo>> Languages { get; }
Visual Basic
Public ReadOnly Property Languages As GeneralConfigurationProperty(Of SystemConfiguration..::..Property, Collection(Of CultureInfo))
    Get

Field Value

The property representing the languages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SystemConfiguration Class
SystemConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
SystemConfiguration..::..PropertiesChanged Property
SystemConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SystemConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of SystemConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SystemConfiguration Class
SystemConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SystemConfiguration..::..StandardProperties Property
SystemConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SystemConfiguration, SystemConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SystemConfiguration, SystemConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemConfiguration Class
SystemConfiguration Members
ININ.IceLib.Configuration Namespace


SystemConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SystemConfiguration..::..Property Enumeration
SystemConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DefaultLanguage | 0 | Represents the DefaultLanguage property.
Languages | 1 | Represents the Languages property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


SystemConfiguration.Rights Class

[image]

IceLib Technical Reference
SystemConfiguration..::..Rights Class
SystemConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SystemConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SystemConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SystemConfiguration..::..Rights Members
SystemConfiguration..::..Rights Class Properties See Also Send Feedback

The SystemConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SystemConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SystemConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SystemConfiguration..::..Rights Properties
SystemConfiguration..::..Rights Class See Also Send Feedback

The SystemConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SystemConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SystemConfiguration..::..Rights..::..Admin Property
SystemConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SystemConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SystemConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemConfiguration..::..Rights Class
SystemConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SystemConfiguration


View Property

[image]

IceLib Technical Reference
SystemConfiguration..::..Rights..::..View Property
SystemConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SystemConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SystemConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemConfiguration..::..Rights Class
SystemConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SystemConfigurationContainer Class

[image]

IceLib Technical Reference
SystemConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the system configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SystemConfigurationContainer : ConfigurationContainer<SystemConfiguration, SystemConfiguration..::..Property>
Visual Basic
Public Class SystemConfigurationContainer _
    Inherits ConfigurationContainer(Of SystemConfiguration, SystemConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' SystemConfiguration, SystemConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SystemConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SystemConfigurationContainer Members
ININ.IceLib.Configuration Namespace


SystemConfigurationContainer Members

[image] [image]

IceLib Technical Reference
SystemConfigurationContainer Members
SystemConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The SystemConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | SystemConfigurationContainer | Initializes a new instance of the SystemConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SystemConfigurationContainer Class
ININ.IceLib.Configuration Namespace


SystemConfigurationContainer Constructor

[image]

IceLib Technical Reference
SystemConfigurationContainer Constructor
SystemConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the SystemConfigurationContainer class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SystemConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

SystemConfigurationContainer Class
SystemConfigurationContainer Members
ININ.IceLib.Configuration Namespace


SystemConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
SystemConfigurationContainer Methods
SystemConfigurationContainer Class See Also Send Feedback

The SystemConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemConfigurationContainer Class
ININ.IceLib.Configuration Namespace


SystemConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
SystemConfigurationContainer Properties
SystemConfigurationContainer Class See Also Send Feedback

The SystemConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SystemConfigurationContainer Class
ININ.IceLib.Configuration Namespace


SystemConfigurationContainer Events

[image] [image]

IceLib Technical Reference
SystemConfigurationContainer Events
SystemConfigurationContainer Class See Also Send Feedback

The SystemConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SystemConfigurationContainer Class
ININ.IceLib.Configuration Namespace


SystemLanguage Class

[image]

IceLib Technical Reference
SystemLanguage Class
Members See Also Send Feedback
Contains information about a language supported by the IC Server. A system language consists of a default language-neutral CultureInfo object, and a collection of it's associated language-specific CultureInfo objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SystemLanguage
Visual Basic
Public Class SystemLanguage

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SystemLanguage

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SystemLanguage Members
ININ.IceLib.Configuration Namespace


SystemLanguage Members

[image] [image]

IceLib Technical Reference
SystemLanguage Members
SystemLanguage Class Methods Properties See Also Send Feedback

The SystemLanguage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultLanguage | Gets the default language associated with this instance.
Public property | Languages | Gets the list of culture-specific languages associated with the DefaultLanguage.

See Also

SystemLanguage Class
ININ.IceLib.Configuration Namespace


SystemLanguage Methods

[image] [image]

IceLib Technical Reference
SystemLanguage Methods
SystemLanguage Class See Also Send Feedback

The SystemLanguage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemLanguage Class
ININ.IceLib.Configuration Namespace


SystemLanguage Properties

[image] [image]

IceLib Technical Reference
SystemLanguage Properties
SystemLanguage Class See Also Send Feedback

The SystemLanguage type exposes the following members.

Properties

 | Name | Description
Public property | DefaultLanguage | Gets the default language associated with this instance.
Public property | Languages | Gets the list of culture-specific languages associated with the DefaultLanguage.

See Also

SystemLanguage Class
ININ.IceLib.Configuration Namespace


DefaultLanguage Property

[image]

IceLib Technical Reference
SystemLanguage..::..DefaultLanguage Property
SystemLanguage Class See Also Send Feedback
Gets the default language associated with this instance.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CultureInfo DefaultLanguage { get; private set; }
Visual Basic
Public Property DefaultLanguage As CultureInfo
    Get
    Private Set

Field Value

The default language.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SystemLanguage Class
SystemLanguage Members
ININ.IceLib.Configuration Namespace


Languages Property

[image]

IceLib Technical Reference
SystemLanguage..::..Languages Property
SystemLanguage Class See Also Send Feedback
Gets the list of culture-specific languages associated with the DefaultLanguage.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<CultureInfo> Languages { get; }
Visual Basic
Public ReadOnly Property Languages As ReadOnlyCollection(Of CultureInfo)
    Get

Field Value

A ReadOnlyCollection<(Of <(<'T>)>)> of CultureInfo objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SystemLanguage Class
SystemLanguage Members
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration Class

[image]

IceLib Technical Reference
SystemParameterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC SystemParameter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SystemParameterConfiguration : ListConfigurationObject
Visual Basic
Public Class SystemParameterConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..SystemParameterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfiguration Members
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration Members

[image] [image]

IceLib Technical Reference
SystemParameterConfiguration Members
SystemParameterConfiguration Class Methods Properties See Also Send Feedback

The SystemParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SystemParameterConfiguration Class
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration Methods

[image] [image]

IceLib Technical Reference
SystemParameterConfiguration Methods
SystemParameterConfiguration Class See Also Send Feedback

The SystemParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

SystemParameterConfiguration Class
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration Properties

[image] [image]

IceLib Technical Reference
SystemParameterConfiguration Properties
SystemParameterConfiguration Class See Also Send Feedback

The SystemParameterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

SystemParameterConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
SystemParameterConfiguration..::..StandardProperties Property
SystemParameterConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<SystemParameterConfiguration, SystemParameterConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of SystemParameterConfiguration, SystemParameterConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfiguration Class
SystemParameterConfiguration Members
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
SystemParameterConfiguration..::..Property Enumeration
SystemParameterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


SystemParameterConfiguration.Rights Class

[image]

IceLib Technical Reference
SystemParameterConfiguration..::..Rights Class
SystemParameterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..SystemParameterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
SystemParameterConfiguration..::..Rights Members
SystemParameterConfiguration..::..Rights Class Properties See Also Send Feedback

The SystemParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SystemParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


SystemParameterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
SystemParameterConfiguration..::..Rights Properties
SystemParameterConfiguration..::..Rights Class See Also Send Feedback

The SystemParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

SystemParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
SystemParameterConfiguration..::..Rights..::..Admin Property
SystemParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SystemParameterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of SystemParameterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfiguration..::..Rights Class
SystemParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SystemParameters


View Property

[image]

IceLib Technical Reference
SystemParameterConfiguration..::..Rights..::..View Property
SystemParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<SystemParameterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of SystemParameterConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfiguration..::..Rights Class
SystemParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


SystemParameterConfigurationList Class

[image]

IceLib Technical Reference
SystemParameterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing SystemParameter configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SystemParameterConfigurationList : DynamicConfigurationList<SystemParameterConfiguration, SystemParameterConfiguration..::..Property>
Visual Basic
Public Class SystemParameterConfigurationList _
    Inherits DynamicConfigurationList(Of SystemParameterConfiguration, SystemParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' SystemParameterConfiguration, SystemParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' SystemParameterConfiguration, SystemParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..SystemParameterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


SystemParameterConfigurationList Members

[image] [image]

IceLib Technical Reference
SystemParameterConfigurationList Members
SystemParameterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SystemParameterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SystemParameterConfigurationList | Initializes a new instance of the SystemParameterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SystemParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


SystemParameterConfigurationList Constructor

[image]

IceLib Technical Reference
SystemParameterConfigurationList Constructor
SystemParameterConfigurationList Class See Also Send Feedback
Initializes a new instance of the SystemParameterConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SystemParameterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SystemParameterConfigurationList Class
SystemParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


SystemParameterConfigurationList Methods

[image] [image]

IceLib Technical Reference
SystemParameterConfigurationList Methods
SystemParameterConfigurationList Class See Also Send Feedback

The SystemParameterConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


SystemParameterConfigurationList Properties

[image] [image]

IceLib Technical Reference
SystemParameterConfigurationList Properties
SystemParameterConfigurationList Class See Also Send Feedback

The SystemParameterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SystemParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


SystemParameterConfigurationList Events

[image] [image]

IceLib Technical Reference
SystemParameterConfigurationList Events
SystemParameterConfigurationList Class See Also Send Feedback

The SystemParameterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

SystemParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


TypedReference Class

[image]

IceLib Technical Reference
TypedReference Class
Members See Also Send Feedback
Represents an object type and ID pair.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TypedReference : IComparable
Visual Basic
Public Class TypedReference _
    Implements IComparable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..TypedReference
ININ.IceLib.Configuration..::..TypedReferenceValue<(Of <(<'TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Members
ININ.IceLib.Configuration Namespace


TypedReference Members

[image] [image]

IceLib Technical Reference
TypedReference Members
TypedReference Class Constructors Methods Operators Properties See Also Send Feedback

The TypedReference type exposes the following members.

Constructors

 | Name | Description
Public method | TypedReference | Initializes a new instance of the TypedReference class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(TypedReference) | Determines whether the specified TypedReference is equal to the current TypedReference.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier used to reference this configuration object.
Public property | ObjectType | Gets the object type.

See Also

TypedReference Class
ININ.IceLib.Configuration Namespace


TypedReference Constructor

[image]

IceLib Technical Reference
TypedReference Constructor
TypedReference Class See Also Send Feedback
Initializes a new instance of the TypedReference class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TypedReference(
    string objectType,
    string id
)
Visual Basic
Public Sub New ( _
    objectType As String, _
    id As String _
)

Parameters

objectType
Type: System..::..String
Type of the object.
id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


TypedReference Methods

[image] [image]

IceLib Technical Reference
TypedReference Methods
TypedReference Class See Also Send Feedback

The TypedReference type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(TypedReference) | Determines whether the specified TypedReference is equal to the current TypedReference.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

TypedReference Class
ININ.IceLib.Configuration Namespace


CompareTo Method

[image]

IceLib Technical Reference
TypedReference..::..CompareTo Method
TypedReference Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


Equals Method

[image] [image]

IceLib Technical Reference
TypedReference..::..Equals Method
TypedReference Class See Also Send Feedback
Determines whether two TypedReference instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(TypedReference) | Determines whether the specified TypedReference is equal to the current TypedReference.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
TypedReference..::..Equals Method (Object)
TypedReference Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TypedReference Class
TypedReference Members
Equals Overload
ININ.IceLib.Configuration Namespace


Equals Method (TypedReference)

[image]

IceLib Technical Reference
TypedReference..::..Equals Method (TypedReference)
TypedReference Class See Also Send Feedback
Determines whether the specified TypedReference is equal to the current TypedReference.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    TypedReference other
)
Visual Basic
Public Function Equals ( _
    other As TypedReference _
) As Boolean

Parameters

other
Type: ININ.IceLib.Configuration..::..TypedReference
The TypedReference to compare with the current TypedReference.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified TypedReference is equal to the current TypedReference; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Class
TypedReference Members
Equals Overload
ININ.IceLib.Configuration Namespace


GetHashCode Method

[image]

IceLib Technical Reference
TypedReference..::..GetHashCode Method
TypedReference Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
TypedReference..::..ToString Method
TypedReference Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


TypedReference Operators

[image] [image]

IceLib Technical Reference
TypedReference Operators
TypedReference Class See Also Send Feedback

The TypedReference type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

TypedReference Class
ININ.IceLib.Configuration Namespace


Equality Operator

[image]

IceLib Technical Reference
TypedReference..::..Equality Operator
TypedReference Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    TypedReference typedReference1,
    TypedReference typedReference2
)
Visual Basic
Public Shared Operator = ( _
    typedReference1 As TypedReference, _
    typedReference2 As TypedReference _
) As Boolean

Parameters

typedReference1
Type: ININ.IceLib.Configuration..::..TypedReference
The typed reference to compare.
typedReference2
Type: ININ.IceLib.Configuration..::..TypedReference
The typed reference to compare.

Return Value

Returns trueTruetruetrue (True in Visual Basic) if the values of its operands are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


Inequality Operator

[image]

IceLib Technical Reference
TypedReference..::..Inequality Operator
TypedReference Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    TypedReference typedReference1,
    TypedReference typedReference2
)
Visual Basic
Public Shared Operator <> ( _
    typedReference1 As TypedReference, _
    typedReference2 As TypedReference _
) As Boolean

Parameters

typedReference1
Type: ININ.IceLib.Configuration..::..TypedReference
The typed reference to compare.
typedReference2
Type: ININ.IceLib.Configuration..::..TypedReference
The typed reference to compare.

Return Value

Returns falseFalsefalsefalse (False in Visual Basic) if the values of its operands are equal, trueTruetruetrue (True in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


TypedReference Properties

[image] [image]

IceLib Technical Reference
TypedReference Properties
TypedReference Class See Also Send Feedback

The TypedReference type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier used to reference this configuration object.
Public property | ObjectType | Gets the object type.

See Also

TypedReference Class
ININ.IceLib.Configuration Namespace


Id Property

[image]

IceLib Technical Reference
TypedReference..::..Id Property
TypedReference Class See Also Send Feedback
Gets the unique identifier used to reference this configuration object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId Id { get; }
Visual Basic
Public ReadOnly Property Id As ConfigurationId
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


ObjectType Property

[image]

IceLib Technical Reference
TypedReference..::..ObjectType Property
TypedReference Class See Also Send Feedback
Gets the object type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectType { get; }
Visual Basic
Public ReadOnly Property ObjectType As String
    Get

Field Value

The object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReference Class
TypedReference Members
ININ.IceLib.Configuration Namespace


TypedReferenceValue(TValue) Class

[image]

IceLib Technical Reference
TypedReferenceValue<(Of <(<'TValue>)>)> Class
Members See Also Send Feedback
Represents an object type and ID pair.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TypedReferenceValue<TValue> : TypedReference
Visual Basic
Public Class TypedReferenceValue(Of TValue) _
    Inherits TypedReference

Type Parameters

TValue

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..TypedReference
ININ.IceLib.Configuration..::..TypedReferenceValue<(Of <(<'TValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReferenceValue<(Of <(<'TValue>)>)> Members
ININ.IceLib.Configuration Namespace


TypedReferenceValue(TValue) Members

[image] [image]

IceLib Technical Reference
TypedReferenceValue<(Of <(<'TValue>)>)> Members
TypedReferenceValue<(Of <(<'TValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The TypedReferenceValue<(Of <(<'TValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | TypedReferenceValue<(Of <(<'TValue>)>)> | Initializes a new instance of the TypedReference class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from TypedReference.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from TypedReference.)
Public method | Equals(TypedReference) | Determines whether the specified TypedReference is equal to the current TypedReference. (Inherited from TypedReference.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from TypedReference.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TypedReference.)

Properties

 | Name | Description
Public property | Id | Gets the unique identifier used to reference this configuration object. (Inherited from TypedReference.)
Public property | ObjectType | Gets the object type. (Inherited from TypedReference.)
Public property | Value | Gets the value.

See Also

TypedReferenceValue<(Of <(<'TValue>)>)> Class
ININ.IceLib.Configuration Namespace


TypedReferenceValue(TValue) Constructor

[image]

IceLib Technical Reference
TypedReferenceValue<(Of <(<'TValue>)>)> Constructor
TypedReferenceValue<(Of <(<'TValue>)>)> Class See Also Send Feedback
Initializes a new instance of the TypedReference class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TypedReferenceValue(
    string objectType,
    string id,
    TValue value
)
Visual Basic
Public Sub New ( _
    objectType As String, _
    id As String, _
    value As TValue _
)

Parameters

objectType
Type: System..::..String
Type of the object.
id
Type: System..::..String
The ID.
value
Type: TValue
The value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReferenceValue<(Of <(<'TValue>)>)> Class
TypedReferenceValue<(Of <(<'TValue>)>)> Members
ININ.IceLib.Configuration Namespace


TypedReferenceValue(TValue) Methods

[image] [image]

IceLib Technical Reference
TypedReferenceValue<(Of <(<'TValue>)>)> Methods
TypedReferenceValue<(Of <(<'TValue>)>)> Class See Also Send Feedback

The TypedReferenceValue<(Of <(<'TValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from TypedReference.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from TypedReference.)
Public method | Equals(TypedReference) | Determines whether the specified TypedReference is equal to the current TypedReference. (Inherited from TypedReference.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from TypedReference.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TypedReference.)

See Also

TypedReferenceValue<(Of <(<'TValue>)>)> Class
ININ.IceLib.Configuration Namespace


TypedReferenceValue(TValue) Properties

[image] [image]

IceLib Technical Reference
TypedReferenceValue<(Of <(<'TValue>)>)> Properties
TypedReferenceValue<(Of <(<'TValue>)>)> Class See Also Send Feedback

The TypedReferenceValue<(Of <(<'TValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier used to reference this configuration object. (Inherited from TypedReference.)
Public property | ObjectType | Gets the object type. (Inherited from TypedReference.)
Public property | Value | Gets the value.

See Also

TypedReferenceValue<(Of <(<'TValue>)>)> Class
ININ.IceLib.Configuration Namespace


Value Property

[image]

IceLib Technical Reference
TypedReferenceValue<(Of <(<'TValue>)>)>..::..Value Property
TypedReferenceValue<(Of <(<'TValue>)>)> Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValue Value { get; }
Visual Basic
Public ReadOnly Property Value As TValue
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

TypedReferenceValue<(Of <(<'TValue>)>)> Class
TypedReferenceValue<(Of <(<'TValue>)>)> Members
ININ.IceLib.Configuration Namespace


UserAccessRightsProperties(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Contains Access Control Right settings for configuration objects (e.g. RoleConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserAccessRightsProperties<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class UserAccessRightsProperties(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
TPropertyEnum

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..RoleConfiguration


UserAccessRightsProperties(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivateOthers | Provides access to the property representing the ActivateOthers access right for this user (use TPropertyEnum.AccessRights_ActivateOthers).
Public property | ActivateSelf | Provides access to the property representing the ActivateSelf access right for this user (use TPropertyEnum.AccessRights_ActivateOthers).
Public property | CanEditAccessRights | Provides access to the property representing the can edit access rights for this user (use TPropertyEnum.AccessRights_CanEditAccessRights).
Public property | ChangeUserStatus | Provides access to the property representing the ChangeUserStatus access right for this user (use TPropertyEnum.AccessRights_ChangeUserStatus).
Public property | ClientButtons | Provides access to the property representing the right to modify client buttons (use TPropertyEnum.AccessRights_ClientButtons).
Public property | CoachLineQueue | Provides access to the property representing the CoachLineQueue access right for this user (use TPropertyEnum.AccessRights_CoachLineQueue).
Public property | CoachStationQueue | Provides access to the property representing the CoachStationQueue access right for this user (use TPropertyEnum.AccessRights_CoachStationQueue).
Public property | CoachUserQueue | Provides access to the property representing the CoachUserQueue access right for this user (use TPropertyEnum.AccessRights_CoachUserQueue).
Public property | CoachWorkgroupQueue | Provides access to the property representing the CoachWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_CoachWorkgroupQueue).
Public property | CreateOptimizerForecasts | Provides access to the property representing the right to access CreateOptimizerForecasts (use TPropertyEnum.AccessRights_CreateOptimizerForecasts).
Public property | CreateSchedulingUnitAgentConstraints | Provides access to the property representing the right to create optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentConstraints).
Public property | CreateSchedulingUnitAgentGroups | Provides access to the property representing the right to create optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentGroups).
Public property | CreateSchedulingUnitSchedules | Provides access to the property representing the right to create optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_CreateSchedulingUnitSchedules).
Public property | CreateSchedulingUnitShiftRotations | Provides access to the property representing the right to create optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_CreateSchedulingUnitShiftRotations).
Public property | CreateSchedulingUnitShifts | Provides access to the property representing the right to create optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_CreateSchedulingUnitShifts).
Public property | CreateSchedulingUnitTimeoffRequests | Provides access to the property representing the right to create optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentGroups).
Public property | DeleteOptimizerForecasts | Provides access to the property representing the right to access DeleteOptimizerForecasts (use TPropertyEnum.AccessRights_DeleteOptimizerForecasts).
Public property | DeleteSchedulingUnitAgentConstraints | Provides access to the property representing the right to delete optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentConstraints).
Public property | DeleteSchedulingUnitAgentGroups | Provides access to the property representing the right to delete optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentGroups).
Public property | DeleteSchedulingUnitSchedules | Provides access to the property representing the right to delete optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_DeleteSchedulingUnitSchedules).
Public property | DeleteSchedulingUnitShiftRotations | Provides access to the property representing the right to delete optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_DeleteSchedulingUnitShiftRotations).
Public property | DeleteSchedulingUnitShifts | Provides access to the property representing the right to delete optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_DeleteSchedulingUnitShifts).
Public property | DeleteSchedulingUnitTimeoffRequests | Provides access to the property representing the right to delete optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentGroups).
Public property | DisconnectLineQueue | Provides access to the property representing the DisconnectLineQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectLineQueue).
Public property | DisconnectStationQueue | Provides access to the property representing the DisconnectStationQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectStationQueue).
Public property | DisconnectUserQueue | Provides access to the property representing the DisconnectUserQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectUserQueue).
Public property | DisconnectWorkgroupQueue | Provides access to the property representing the DisconnectWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectWorkgroupQueue).
Public property | EFaqs | Provides access to the property representing the right to access user queues (use TPropertyEnum.AccessRights_EFaqs).
Public property | FollowMePhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications for follow-me (use TPropertyEnum.AccessRights_FollowMePhoneNumberClassifications).
Public property | ForwardPhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications for call forwarding. (use TPropertyEnum.AccessRights_ForwardPhoneNumberClassifications).
Public property | HoldStationQueue | Provides access to the property representing the HoldStationQueue access right for this user (use TPropertyEnum.AccessRights_HoldStationQueue).
Public property | HoldUserQueue | Provides access to the property representing the HoldUserQueue access right for this user (use TPropertyEnum.AccessRights_HoldUserQueue).
Public property | InteractionClientPlugins | Provides access to the property representing the right to modify interaction client plugins (use TPropertyEnum.AccessRights_InteractionClientPlugins).
Public property | InteractionConferenceRestrictRooms | Provides access to the property representing the InteractionConferenceRestrictRooms access right for this user (use TPropertyEnum.AccessRights_InteractionConferenceRestrictRooms).
Public property | JoinLineQueue | Provides access to the property representing the JoinLineQueue access right for this user (use TPropertyEnum.AccessRights_JoinLineQueue).
Public property | JoinStationQueue | Provides access to the property representing the JoinStationQueue access right for this user (use TPropertyEnum.AccessRights_JoinStationQueue).
Public property | JoinUserQueue | Provides access to the property representing the JoinUserQueue access right for this user (use TPropertyEnum.AccessRights_JoinUserQueue).
Public property | JoinWorkgroupQueue | Provides access to the property representing the JoinWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_JoinWorkgroupQueue).
Public property | LaunchableProcessList | Provides access to the property representing the LaunchableProcessList access right for this user (use TPropertyEnum.AccessRights_LaunchableProcessList).
Public property | ListAccountCodes | Provides access to the property representing the list account codes access right for this user (use TPropertyEnum.AccessRights_ListAccountCodes).
Public property | ListenLineQueue | Provides access to the property representing the ListenLineQueue access right for this user (use TPropertyEnum.AccessRights_ListenLineQueue).
Public property | ListenStationQueue | Provides access to the property representing the ListenStationQueue access right for this user (use TPropertyEnum.AccessRights_ListenStationQueue).
Public property | ListenUserQueue | Provides access to the property representing the ListenUserQueue access right for this user (use TPropertyEnum.AccessRights_ListenUserQueue).
Public property | ListenWorkgroupQueue | Provides access to the property representing the ListenWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_ListenWorkgroupQueue).
Public property | LoginStation | Provides access to the property representing the LoginStation access right for this user (use TPropertyEnum.AccessRights_LoginStation).
Public property | ManageProcessList | Provides access to the property representing the ManageProcessList access right for this user (use TPropertyEnum.AccessRights_ManageProcessList).
Public property | Miscellaneous | Provides access to the property representing the right to access miscellaneous settings (use TPropertyEnum.AccessRights_Miscellaneous).
Public property | ModifyAttendantEmailProfiles | Provides access to the property representing the ModifyAttendantEmailProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantEmailProfiles).
Public property | ModifyAttendantInboundProfiles | Provides access to the property representing the ModifyAttendantInboundProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantInboundProfiles).
Public property | ModifyAttendantOperatorProfiles | Provides access to the property representing the ModifyAttendantOperatorProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantOperatorProfiles).
Public property | ModifyAttendantOutboundProfiles | Provides access to the property representing the ModifyAttendantOutboundProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantOutboundProfiles).
Public property | ModifyCampaignList | Provides access to the property representing the right to access ModifyCampaignList (use TPropertyEnum.AccessRights_ModifyCampaignList).
Public property | ModifyCampaignsAgentlessCallingMode | Obsolete. Provides access to the property representing the right to access ModifyCampaignsAgentlessCallingMode (use TPropertyEnum.AccessRights_ModifyCampaignsAgentlessCallingMode).
Public property | ModifyCampaignsAutomaticTimezoneMapping | Obsolete. Provides access to the property representing the right to access ModifyCampaignsAutomaticTimezoneMapping (use TPropertyEnum.AccessRights_ModifyCampaignsAutomaticTimezoneMapping).
Public property | ModifyCampaignsLineSettings | Obsolete. Provides access to the property representing the right to access ModifyCampaignsLineSettings (use TPropertyEnum.AccessRights_ModifyCampaignsLineSettings).
Public property | ModifyCampaignsMaxLinesPerCampaign | Obsolete. Provides access to the property representing the right to access ModifyCampaignsMaxLinesPerCampaign (use TPropertyEnum.AccessRights_ModifyCampaignsMaxLinesPerCampaign).
Public property | ModifyCampaignStatus | Obsolete. Provides access to the property representing the right to access ModifyCampaignStatus (use TPropertyEnum.AccessRights_ModifyCampaignStatus).
Public property | ModifyFeedbackSurveys | Provides access to the property representing the right to modify interaction feedback surveys (use TPropertyEnum.AccessRights_ModifyFeedbackSurveys).
Public property | ModifyOptimizerForecasts | Provides access to the property representing the right to access ModifyOptimizerForecasts (use TPropertyEnum.AccessRights_ModifyOptimizerForecasts).
Public property | ModifyPolicySetsBehaviorTypeCustomHandler | Obsolete. Provides access to the property representing the right to access ModifyPolicySetsBehaviorTypeCustomHandler (use TPropertyEnum.AccessRights_ModifyPolicySetsBehaviorTypeCustomHandler).
Public property | ModifyPolicySetsBehaviorTypeEventLog | Obsolete. Provides access to the property representing the right to access ModifyPolicySetsBehaviorTypeEventLog (use TPropertyEnum.AccessRights_ModifyPolicySetsBehaviorTypeEventLog).
Public property | ModifyRecorderQuestionnaires | Provides access to the property representing the right to modify recorder questionnaires (use TPropertyEnum.AccessRights_ModifyRecorderQuestionnaires).
Public property | ModifyRuleSetsCustomHandler | Obsolete. Provides access to the property representing the right to access ModifyRuleSetsCustomHandler (use TPropertyEnum.AccessRights_ModifyRuleSetsCustomHandler).
Public property | ModifyRuleSetsEventLog | Obsolete. Provides access to the property representing the right to access ModifyRuleSetsEventLog (use TPropertyEnum.AccessRights_ModifyRuleSetsEventLog).
Public property | ModifySchedulingUnitAgentConstraints | Provides access to the property representing the right to modify optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentConstraints).
Public property | ModifySchedulingUnitAgentGroups | Provides access to the property representing the right to modify optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentGroups).
Public property | ModifySchedulingUnitConfiguration | Provides access to the property representing the right to modify optimizer scheduling unit configuration (use TPropertyEnum.AccessRights_ModifySchedulingUnitConfiguration).
Public property | ModifySchedulingUnitListRealTimeAdherence | Provides access to the property representing the right to modify optimizer scheduling unit real-time adherence (use TPropertyEnum.AccessRights_ModifySchedulingUnitListRealTimeAdherence).
Public property | ModifySchedulingUnitSchedules | Provides access to the property representing the right to modify optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_ModifySchedulingUnitSchedules).
Public property | ModifySchedulingUnitShiftRotations | Provides access to the property representing the right to modify optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_ModifySchedulingUnitShiftRotations).
Public property | ModifySchedulingUnitShifts | Provides access to the property representing the right to modify optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_ModifySchedulingUnitShifts).
Public property | ModifySchedulingUnitTimeoffRequests | Provides access to the property representing the right to modify optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentGroups).
Public property | MuteStationQueue | Provides access to the property representing the MuteStationQueue access right for this user (use TPropertyEnum.AccessRights_MuteStationQueue).
Public property | MuteUserQueue | Provides access to the property representing the MuteUserQueue access right for this user (use TPropertyEnum.AccessRights_MuteUserQueue).
Public property | OptimizerModifyShiftTrading | Provides access to the property representing the right to modify optimizer scheduling unit shift trading (use TPropertyEnum.AccessRights_OptimizerModifyShiftTrading).
Public property | OptimizerViewShiftTrading | Provides access to the property representing the right to view optimizer scheduling unit shift trading(use TPropertyEnum.AccessRights_OptimizerViewShiftTrading).
Public property | PhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications (use TPropertyEnum.AccessRights_PhoneNumberClassifications).
Public property | PickupLineQueue | Provides access to the property representing the PickupLineQueue access right for this user (use TPropertyEnum.AccessRights_PickupLineQueue).
Public property | PickupStationQueue | Provides access to the property representing the PickupStationQueue access right for this user (use TPropertyEnum.AccessRights_PickupStationQueue).
Public property | PickupUserQueue | Provides access to the property representing the PickupUserQueue access right for this user (use TPropertyEnum.AccessRights_PickupUserQueue).
Public property | PickupWorkgroupQueue | Provides access to the property representing the PickupWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_PickupWorkgroupQueue).
Public property | PreviewEmailUserQueue | Provides access to the property representing the PreviewEmailUserQueue access right for this user (use TPropertyEnum.AccessRights_PreviewEmailUserQueue).
Public property | PreviewEmailWorkgroupQueue | Provides access to the property representing the PreviewEmailWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_PreviewEmailWorkgroupQueue).
Public property | RecordLineQueue | Provides access to the property representing the RecordLineQueue access right for this user (use TPropertyEnum.AccessRights_RecordLineQueue).
Public property | RecordStationQueue | Provides access to the property representing the RecordStationQueue access right for this user (use TPropertyEnum.AccessRights_RecordStationQueue).
Public property | RecordUserQueue | Provides access to the property representing the RecordUserQueue access right for this user (use TPropertyEnum.AccessRights_RecordUserQueue).
Public property | RecordWorkgroupQueue | Provides access to the property representing the RecordWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_RecordWorkgroupQueue).
Public property | ResponseManagementDocuments | Provides access to the property representing the right to modify response management documents (use TPropertyEnum.AccessRights_ResponseManagementDocuments).
Public property | SnipLineQueue | Provides access to the property representing the SnipLineQueue access right for this user (use TPropertyEnum.AccessRights_SnipLineQueue).
Public property | SnipStationQueue | Provides access to the property representing the SnipStationQueue access right for this user (use TPropertyEnum.AccessRights_SnipStationQueue).
Public property | SnipUserQueue | Provides access to the property representing the SnipUserQueue access right for this user (use TPropertyEnum.AccessRights_SnipUserQueue).
Public property | SnipWorkgroupQueue | Provides access to the property representing the SnipWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_SnipWorkgroupQueue).
Public property | StatusMessages | Provides access to the property representing the right to modify status messages (use TPropertyEnum.AccessRights_StatusMessages).
Public property | SubstituteQueueControlColumns | Provides access to the property representing the SubstituteQueueControlColumns access right for this user (use TPropertyEnum.AccessRights_SubstituteQueueControlColumns).
Public property | TransferLineQueue | Provides access to the property representing the TransferLineQueue access right for this user (use TPropertyEnum.AccessRights_TransferLineQueue).
Public property | TransferStationQueue | Provides access to the property representing the TransferStationQueue access right for this user (use TPropertyEnum.AccessRights_TransferStationQueue).
Public property | TransferUserQueue | Provides access to the property representing the TransferUserQueue access right for this user (use TPropertyEnum.AccessRights_TransferUserQueue).
Public property | TransferWorkgroupQueue | Provides access to the property representing the TransferWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_TransferWorkgroupQueue).
Public property | TuiPhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications via the TUI. (use TPropertyEnum.AccessRights_TuiPhoneNumberClassifications).
Public property | ViewAttendantEmailProfileInSearch | Provides access to the property representing the ViewAttendantEmailProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantEmailProfileInSearch).
Public property | ViewAttendantEmailProfiles | Provides access to the property representing the ViewAttendantEmailProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantEmailProfiles).
Public property | ViewAttendantInboundProfileInSearch | Provides access to the property representing the ViewAttendantInboundProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantInboundProfileInSearch).
Public property | ViewAttendantInboundProfiles | Provides access to the property representing the ViewAttendantInboundProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantInboundProfiles).
Public property | ViewAttendantOperatorProfileInSearch | Provides access to the property representing the ViewAttendantOperatorProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOperatorProfileInSearch).
Public property | ViewAttendantOperatorProfiles | Provides access to the property representing the ViewAttendantOperatorProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOperatorProfiles).
Public property | ViewAttendantOutboundProfileInSearch | Provides access to the property representing the ViewAttendantOutboundProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOutboundProfileInSearch).
Public property | ViewAttendantOutboundProfiles | Provides access to the property representing the ViewAttendantOutboundProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOutboundProfiles).
Public property | ViewCampaignList | Provides access to the property representing the right to access ViewCampaignList (use TPropertyEnum.AccessRights_ViewCampaignList).
Public property | ViewCampaignsAgentlessCallingMode | Obsolete. Provides access to the property representing the right to access ViewCampaignsAgentlessCallingMode (use TPropertyEnum.AccessRights_ViewCampaignsAgentlessCallingMode).
Public property | ViewCampaignsAutomaticTimezoneMapping | Obsolete. Provides access to the property representing the right to access ViewCampaignsAutomaticTimezoneMapping (use TPropertyEnum.AccessRights_ViewCampaignsAutomaticTimezoneMapping).
Public property | ViewCampaignsLineSettings | Obsolete. Provides access to the property representing the right to access ViewCampaignsLineSettings (use TPropertyEnum.AccessRights_ViewCampaignsLineSettings).
Public property | ViewCampaignsMaxLinesPerCampaign | Obsolete. Provides access to the property representing the right to access ViewCampaignsMaxLinesPerCampaign (use TPropertyEnum.AccessRights_ViewCampaignsMaxLinesPerCampaign).
Public property | ViewCampaignStatus | Obsolete. Provides access to the property representing the right to access ViewCampaignStatus (use TPropertyEnum.AccessRights_ViewCampaignStatus).
Public property | ViewDataSource | Provides access to the property representing the right to view the IC Data Source list (use TPropertyEnum.AccessRights_ViewDataSource).
Public property | ViewFeedbackSurveys | Provides access to the property representing the right to view feedback surveys (use TPropertyEnum.AccessRights_ViewFeedbackSurveys).
Public property | ViewGeneralDirectories | Provides access to the property representing the ViewGeneralDirectories access right for this user (use TPropertyEnum.AccessRights_ViewGeneralDirectories).
Public property | ViewHistoricalReports | Provides access to the property representing the ViewHistoricalReports access right for this user (use TPropertyEnum.AccessRights_ViewHistoricalReports).
Public property | ViewIndividualStatistics | Provides access to the property representing the ViewIndividualStatistics access right for this user (use TPropertyEnum.AccessRights_ViewIndividualStatistics).
Public property | ViewLayoutList | Provides access to the property representing the ViewLayoutList access right for this user (use TPropertyEnum.AccessRights_ViewLayoutList).
Public property | ViewLineQueue | Provides access to the property representing the right to view the line queue list (use TPropertyEnum.AccessRights_ViewLineQueue).
Public property | ViewModifyOptimizerAll | Provides access to the property representing the ViewModifyOptimizerAll access right for this user (use TPropertyEnum.AccessRights_ViewModifyOptimizerAll).
Public property | ViewOptimizerForecasts | Provides access to the property representing the right to access ViewOptimizerForecasts (use TPropertyEnum.AccessRights_ViewOptimizerForecasts).
Public property | ViewOptimizerSchedulingUnits | Obsolete. Provides access to the property representing the right to view optimizer scheduling units (use TPropertyEnum.AccessRights_ViewOptimizerSchedulingUnits).
Public property | ViewPolicySetsBehaviorTypeCustomHandler | Obsolete. Provides access to the property representing the right to access ViewPolicySetsBehaviorTypeCustomHandler (use TPropertyEnum.AccessRights_ViewPolicySetsBehaviorTypeCustomHandler).
Public property | ViewPolicySetsBehaviorTypeEventLog | Obsolete. Provides access to the property representing the right to access ViewPolicySetsBehaviorTypeEventLog (use TPropertyEnum.AccessRights_ViewPolicySetsBehaviorTypeEventLog).
Public property | ViewPositionsList | Provides access to the property representing the ViewPositionsList access right for this user (use TPropertyEnum.AccessRights_ViewPositionsList).
Public property | ViewProcessList | Provides access to the property representing the ViewProcessList access right for this user (use TPropertyEnum.AccessRights_ViewProcessList).
Public property | ViewQueueControlColumns | Provides access to the property representing the ViewQueueControlColumns access right for this user (use TPropertyEnum.AccessRights_ViewQueueControlColumns).
Public property | ViewRecorderQuestionnaires | Provides access to the property representing the right to view recorder questionnaires (use TPropertyEnum.AccessRights_ViewRecorderQuestionnaires).
Public property | ViewReport | Provides access to the property representing the right to view the report list (use TPropertyEnum.AccessRights_ViewReport).
Public property | ViewRuleSetsCustomHandler | Obsolete. Provides access to the property representing the right to access ViewRuleSetsCustomHandler (use TPropertyEnum.AccessRights_ViewRuleSetsCustomHandler).
Public property | ViewRuleSetsEventLog | Obsolete. Provides access to the property representing the right to access ViewRuleSetsEventLog (use TPropertyEnum.AccessRights_ViewRuleSetsEventLog).
Public property | ViewSchedulingUnitAgentConstraints | Provides access to the property representing the right to view optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentConstraints).
Public property | ViewSchedulingUnitAgentGroups | Provides access to the property representing the right to view optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentGroups).
Public property | ViewSchedulingUnitConfiguration | Provides access to the property representing the right to view optimizer scheduling unit configuration (use TPropertyEnum.AccessRights_ViewSchedulingUnitConfiguration).
Public property | ViewSchedulingUnitIntradayMonitoring | Provides access to the property representing the right to view optimizer scheduling unit intraday monitoring (use TPropertyEnum.AccessRights_ViewSchedulingUnitIntradayMonitoring).
Public property | ViewSchedulingUnitListRealTimeAdherence | Provides access to the property representing the right to view optimizer scheduling unit real-time adherence (use TPropertyEnum.AccessRights_ViewSchedulingUnitListRealTimeAdherence).
Public property | ViewSchedulingUnitSchedulePreferences | Provides access to the property representing the right to view optimizer scheduling unit preferences (use TPropertyEnum.AccessRights_ViewSchedulingUnitSchedulePreferences).
Public property | ViewSchedulingUnitSchedules | Provides access to the property representing the right to view optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_ViewSchedulingUnitSchedules).
Public property | ViewSchedulingUnitShiftRotations | Provides access to the property representing the right to view optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_ViewSchedulingUnitShiftRotations).
Public property | ViewSchedulingUnitShifts | Provides access to the property representing the right to view optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_ViewSchedulingUnitShifts).
Public property | ViewSchedulingUnitTimeoffRequests | Provides access to the property representing the right to view optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentGroups).
Public property | ViewSkillList | Provides access to the property representing the ViewSkillList access right for this user (use TPropertyEnum.AccessRights_ViewSkillList).
Public property | ViewStationGroups | Provides access to the property representing the ViewStationGroups access right for this user (use TPropertyEnum.AccessRights_ViewStationGroups).
Public property | ViewStationGroupsInSearch | Provides access to the property representing the ViewStationGroupsInSearch access right for this user (use TPropertyEnum.AccessRights_ViewStationGroupsInSearch).
Public property | ViewStationQueue | Provides access to the property representing the right to view the station queue list(use TPropertyEnum.AccessRights_ViewStationQueue).
Public property | ViewStationQueueInSearch | Provides access to the property representing the ViewStationQueueInSearch access right for this user (use TPropertyEnum.AccessRights_ViewStationQueueInSearch).
Public property | ViewStatusColumns | Provides access to the property representing the ViewStatusColumns access right for this user (use TPropertyEnum.AccessRights_ViewStatusColumns).
Public property | ViewUserInteractionHistory | Provides access to the property representing the right to view user interaction history (use TPropertyEnum.AccessRights_ViewUserInteractionHistory).
Public property | ViewUserQueue | Provides access to the property representing the right to view the user queue list (use TPropertyEnum.AccessRights_ViewUserQueue).
Public property | ViewWorkgroup | Provides access to the property representing the right to view the workgroup list (use TPropertyEnum.AccessRights_ViewWorkgroup).
Public property | ViewWorkgroupQueue | Provides access to the property representing the ViewWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupQueue).
Public property | ViewWorkgroupQueueInSearch | Provides access to the property representing the ViewWorkgroupQueueInSearch access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupQueueInSearch).
Public property | ViewWorkgroupStatistics | Provides access to the property representing the ViewWorkgroupStatistics access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupStatistics).

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


UserAccessRightsProperties(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


UserAccessRightsProperties(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ActivateOthers | Provides access to the property representing the ActivateOthers access right for this user (use TPropertyEnum.AccessRights_ActivateOthers).
Public property | ActivateSelf | Provides access to the property representing the ActivateSelf access right for this user (use TPropertyEnum.AccessRights_ActivateOthers).
Public property | CanEditAccessRights | Provides access to the property representing the can edit access rights for this user (use TPropertyEnum.AccessRights_CanEditAccessRights).
Public property | ChangeUserStatus | Provides access to the property representing the ChangeUserStatus access right for this user (use TPropertyEnum.AccessRights_ChangeUserStatus).
Public property | ClientButtons | Provides access to the property representing the right to modify client buttons (use TPropertyEnum.AccessRights_ClientButtons).
Public property | CoachLineQueue | Provides access to the property representing the CoachLineQueue access right for this user (use TPropertyEnum.AccessRights_CoachLineQueue).
Public property | CoachStationQueue | Provides access to the property representing the CoachStationQueue access right for this user (use TPropertyEnum.AccessRights_CoachStationQueue).
Public property | CoachUserQueue | Provides access to the property representing the CoachUserQueue access right for this user (use TPropertyEnum.AccessRights_CoachUserQueue).
Public property | CoachWorkgroupQueue | Provides access to the property representing the CoachWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_CoachWorkgroupQueue).
Public property | CreateOptimizerForecasts | Provides access to the property representing the right to access CreateOptimizerForecasts (use TPropertyEnum.AccessRights_CreateOptimizerForecasts).
Public property | CreateSchedulingUnitAgentConstraints | Provides access to the property representing the right to create optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentConstraints).
Public property | CreateSchedulingUnitAgentGroups | Provides access to the property representing the right to create optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentGroups).
Public property | CreateSchedulingUnitSchedules | Provides access to the property representing the right to create optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_CreateSchedulingUnitSchedules).
Public property | CreateSchedulingUnitShiftRotations | Provides access to the property representing the right to create optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_CreateSchedulingUnitShiftRotations).
Public property | CreateSchedulingUnitShifts | Provides access to the property representing the right to create optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_CreateSchedulingUnitShifts).
Public property | CreateSchedulingUnitTimeoffRequests | Provides access to the property representing the right to create optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentGroups).
Public property | DeleteOptimizerForecasts | Provides access to the property representing the right to access DeleteOptimizerForecasts (use TPropertyEnum.AccessRights_DeleteOptimizerForecasts).
Public property | DeleteSchedulingUnitAgentConstraints | Provides access to the property representing the right to delete optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentConstraints).
Public property | DeleteSchedulingUnitAgentGroups | Provides access to the property representing the right to delete optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentGroups).
Public property | DeleteSchedulingUnitSchedules | Provides access to the property representing the right to delete optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_DeleteSchedulingUnitSchedules).
Public property | DeleteSchedulingUnitShiftRotations | Provides access to the property representing the right to delete optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_DeleteSchedulingUnitShiftRotations).
Public property | DeleteSchedulingUnitShifts | Provides access to the property representing the right to delete optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_DeleteSchedulingUnitShifts).
Public property | DeleteSchedulingUnitTimeoffRequests | Provides access to the property representing the right to delete optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentGroups).
Public property | DisconnectLineQueue | Provides access to the property representing the DisconnectLineQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectLineQueue).
Public property | DisconnectStationQueue | Provides access to the property representing the DisconnectStationQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectStationQueue).
Public property | DisconnectUserQueue | Provides access to the property representing the DisconnectUserQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectUserQueue).
Public property | DisconnectWorkgroupQueue | Provides access to the property representing the DisconnectWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectWorkgroupQueue).
Public property | EFaqs | Provides access to the property representing the right to access user queues (use TPropertyEnum.AccessRights_EFaqs).
Public property | FollowMePhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications for follow-me (use TPropertyEnum.AccessRights_FollowMePhoneNumberClassifications).
Public property | ForwardPhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications for call forwarding. (use TPropertyEnum.AccessRights_ForwardPhoneNumberClassifications).
Public property | HoldStationQueue | Provides access to the property representing the HoldStationQueue access right for this user (use TPropertyEnum.AccessRights_HoldStationQueue).
Public property | HoldUserQueue | Provides access to the property representing the HoldUserQueue access right for this user (use TPropertyEnum.AccessRights_HoldUserQueue).
Public property | InteractionClientPlugins | Provides access to the property representing the right to modify interaction client plugins (use TPropertyEnum.AccessRights_InteractionClientPlugins).
Public property | InteractionConferenceRestrictRooms | Provides access to the property representing the InteractionConferenceRestrictRooms access right for this user (use TPropertyEnum.AccessRights_InteractionConferenceRestrictRooms).
Public property | JoinLineQueue | Provides access to the property representing the JoinLineQueue access right for this user (use TPropertyEnum.AccessRights_JoinLineQueue).
Public property | JoinStationQueue | Provides access to the property representing the JoinStationQueue access right for this user (use TPropertyEnum.AccessRights_JoinStationQueue).
Public property | JoinUserQueue | Provides access to the property representing the JoinUserQueue access right for this user (use TPropertyEnum.AccessRights_JoinUserQueue).
Public property | JoinWorkgroupQueue | Provides access to the property representing the JoinWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_JoinWorkgroupQueue).
Public property | LaunchableProcessList | Provides access to the property representing the LaunchableProcessList access right for this user (use TPropertyEnum.AccessRights_LaunchableProcessList).
Public property | ListAccountCodes | Provides access to the property representing the list account codes access right for this user (use TPropertyEnum.AccessRights_ListAccountCodes).
Public property | ListenLineQueue | Provides access to the property representing the ListenLineQueue access right for this user (use TPropertyEnum.AccessRights_ListenLineQueue).
Public property | ListenStationQueue | Provides access to the property representing the ListenStationQueue access right for this user (use TPropertyEnum.AccessRights_ListenStationQueue).
Public property | ListenUserQueue | Provides access to the property representing the ListenUserQueue access right for this user (use TPropertyEnum.AccessRights_ListenUserQueue).
Public property | ListenWorkgroupQueue | Provides access to the property representing the ListenWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_ListenWorkgroupQueue).
Public property | LoginStation | Provides access to the property representing the LoginStation access right for this user (use TPropertyEnum.AccessRights_LoginStation).
Public property | ManageProcessList | Provides access to the property representing the ManageProcessList access right for this user (use TPropertyEnum.AccessRights_ManageProcessList).
Public property | Miscellaneous | Provides access to the property representing the right to access miscellaneous settings (use TPropertyEnum.AccessRights_Miscellaneous).
Public property | ModifyAttendantEmailProfiles | Provides access to the property representing the ModifyAttendantEmailProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantEmailProfiles).
Public property | ModifyAttendantInboundProfiles | Provides access to the property representing the ModifyAttendantInboundProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantInboundProfiles).
Public property | ModifyAttendantOperatorProfiles | Provides access to the property representing the ModifyAttendantOperatorProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantOperatorProfiles).
Public property | ModifyAttendantOutboundProfiles | Provides access to the property representing the ModifyAttendantOutboundProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantOutboundProfiles).
Public property | ModifyCampaignList | Provides access to the property representing the right to access ModifyCampaignList (use TPropertyEnum.AccessRights_ModifyCampaignList).
Public property | ModifyCampaignsAgentlessCallingMode | Obsolete. Provides access to the property representing the right to access ModifyCampaignsAgentlessCallingMode (use TPropertyEnum.AccessRights_ModifyCampaignsAgentlessCallingMode).
Public property | ModifyCampaignsAutomaticTimezoneMapping | Obsolete. Provides access to the property representing the right to access ModifyCampaignsAutomaticTimezoneMapping (use TPropertyEnum.AccessRights_ModifyCampaignsAutomaticTimezoneMapping).
Public property | ModifyCampaignsLineSettings | Obsolete. Provides access to the property representing the right to access ModifyCampaignsLineSettings (use TPropertyEnum.AccessRights_ModifyCampaignsLineSettings).
Public property | ModifyCampaignsMaxLinesPerCampaign | Obsolete. Provides access to the property representing the right to access ModifyCampaignsMaxLinesPerCampaign (use TPropertyEnum.AccessRights_ModifyCampaignsMaxLinesPerCampaign).
Public property | ModifyCampaignStatus | Obsolete. Provides access to the property representing the right to access ModifyCampaignStatus (use TPropertyEnum.AccessRights_ModifyCampaignStatus).
Public property | ModifyFeedbackSurveys | Provides access to the property representing the right to modify interaction feedback surveys (use TPropertyEnum.AccessRights_ModifyFeedbackSurveys).
Public property | ModifyOptimizerForecasts | Provides access to the property representing the right to access ModifyOptimizerForecasts (use TPropertyEnum.AccessRights_ModifyOptimizerForecasts).
Public property | ModifyPolicySetsBehaviorTypeCustomHandler | Obsolete. Provides access to the property representing the right to access ModifyPolicySetsBehaviorTypeCustomHandler (use TPropertyEnum.AccessRights_ModifyPolicySetsBehaviorTypeCustomHandler).
Public property | ModifyPolicySetsBehaviorTypeEventLog | Obsolete. Provides access to the property representing the right to access ModifyPolicySetsBehaviorTypeEventLog (use TPropertyEnum.AccessRights_ModifyPolicySetsBehaviorTypeEventLog).
Public property | ModifyRecorderQuestionnaires | Provides access to the property representing the right to modify recorder questionnaires (use TPropertyEnum.AccessRights_ModifyRecorderQuestionnaires).
Public property | ModifyRuleSetsCustomHandler | Obsolete. Provides access to the property representing the right to access ModifyRuleSetsCustomHandler (use TPropertyEnum.AccessRights_ModifyRuleSetsCustomHandler).
Public property | ModifyRuleSetsEventLog | Obsolete. Provides access to the property representing the right to access ModifyRuleSetsEventLog (use TPropertyEnum.AccessRights_ModifyRuleSetsEventLog).
Public property | ModifySchedulingUnitAgentConstraints | Provides access to the property representing the right to modify optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentConstraints).
Public property | ModifySchedulingUnitAgentGroups | Provides access to the property representing the right to modify optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentGroups).
Public property | ModifySchedulingUnitConfiguration | Provides access to the property representing the right to modify optimizer scheduling unit configuration (use TPropertyEnum.AccessRights_ModifySchedulingUnitConfiguration).
Public property | ModifySchedulingUnitListRealTimeAdherence | Provides access to the property representing the right to modify optimizer scheduling unit real-time adherence (use TPropertyEnum.AccessRights_ModifySchedulingUnitListRealTimeAdherence).
Public property | ModifySchedulingUnitSchedules | Provides access to the property representing the right to modify optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_ModifySchedulingUnitSchedules).
Public property | ModifySchedulingUnitShiftRotations | Provides access to the property representing the right to modify optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_ModifySchedulingUnitShiftRotations).
Public property | ModifySchedulingUnitShifts | Provides access to the property representing the right to modify optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_ModifySchedulingUnitShifts).
Public property | ModifySchedulingUnitTimeoffRequests | Provides access to the property representing the right to modify optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentGroups).
Public property | MuteStationQueue | Provides access to the property representing the MuteStationQueue access right for this user (use TPropertyEnum.AccessRights_MuteStationQueue).
Public property | MuteUserQueue | Provides access to the property representing the MuteUserQueue access right for this user (use TPropertyEnum.AccessRights_MuteUserQueue).
Public property | OptimizerModifyShiftTrading | Provides access to the property representing the right to modify optimizer scheduling unit shift trading (use TPropertyEnum.AccessRights_OptimizerModifyShiftTrading).
Public property | OptimizerViewShiftTrading | Provides access to the property representing the right to view optimizer scheduling unit shift trading(use TPropertyEnum.AccessRights_OptimizerViewShiftTrading).
Public property | PhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications (use TPropertyEnum.AccessRights_PhoneNumberClassifications).
Public property | PickupLineQueue | Provides access to the property representing the PickupLineQueue access right for this user (use TPropertyEnum.AccessRights_PickupLineQueue).
Public property | PickupStationQueue | Provides access to the property representing the PickupStationQueue access right for this user (use TPropertyEnum.AccessRights_PickupStationQueue).
Public property | PickupUserQueue | Provides access to the property representing the PickupUserQueue access right for this user (use TPropertyEnum.AccessRights_PickupUserQueue).
Public property | PickupWorkgroupQueue | Provides access to the property representing the PickupWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_PickupWorkgroupQueue).
Public property | PreviewEmailUserQueue | Provides access to the property representing the PreviewEmailUserQueue access right for this user (use TPropertyEnum.AccessRights_PreviewEmailUserQueue).
Public property | PreviewEmailWorkgroupQueue | Provides access to the property representing the PreviewEmailWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_PreviewEmailWorkgroupQueue).
Public property | RecordLineQueue | Provides access to the property representing the RecordLineQueue access right for this user (use TPropertyEnum.AccessRights_RecordLineQueue).
Public property | RecordStationQueue | Provides access to the property representing the RecordStationQueue access right for this user (use TPropertyEnum.AccessRights_RecordStationQueue).
Public property | RecordUserQueue | Provides access to the property representing the RecordUserQueue access right for this user (use TPropertyEnum.AccessRights_RecordUserQueue).
Public property | RecordWorkgroupQueue | Provides access to the property representing the RecordWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_RecordWorkgroupQueue).
Public property | ResponseManagementDocuments | Provides access to the property representing the right to modify response management documents (use TPropertyEnum.AccessRights_ResponseManagementDocuments).
Public property | SnipLineQueue | Provides access to the property representing the SnipLineQueue access right for this user (use TPropertyEnum.AccessRights_SnipLineQueue).
Public property | SnipStationQueue | Provides access to the property representing the SnipStationQueue access right for this user (use TPropertyEnum.AccessRights_SnipStationQueue).
Public property | SnipUserQueue | Provides access to the property representing the SnipUserQueue access right for this user (use TPropertyEnum.AccessRights_SnipUserQueue).
Public property | SnipWorkgroupQueue | Provides access to the property representing the SnipWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_SnipWorkgroupQueue).
Public property | StatusMessages | Provides access to the property representing the right to modify status messages (use TPropertyEnum.AccessRights_StatusMessages).
Public property | SubstituteQueueControlColumns | Provides access to the property representing the SubstituteQueueControlColumns access right for this user (use TPropertyEnum.AccessRights_SubstituteQueueControlColumns).
Public property | TransferLineQueue | Provides access to the property representing the TransferLineQueue access right for this user (use TPropertyEnum.AccessRights_TransferLineQueue).
Public property | TransferStationQueue | Provides access to the property representing the TransferStationQueue access right for this user (use TPropertyEnum.AccessRights_TransferStationQueue).
Public property | TransferUserQueue | Provides access to the property representing the TransferUserQueue access right for this user (use TPropertyEnum.AccessRights_TransferUserQueue).
Public property | TransferWorkgroupQueue | Provides access to the property representing the TransferWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_TransferWorkgroupQueue).
Public property | TuiPhoneNumberClassifications | Provides access to the property representing the right to access Phone Number Classifications via the TUI. (use TPropertyEnum.AccessRights_TuiPhoneNumberClassifications).
Public property | ViewAttendantEmailProfileInSearch | Provides access to the property representing the ViewAttendantEmailProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantEmailProfileInSearch).
Public property | ViewAttendantEmailProfiles | Provides access to the property representing the ViewAttendantEmailProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantEmailProfiles).
Public property | ViewAttendantInboundProfileInSearch | Provides access to the property representing the ViewAttendantInboundProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantInboundProfileInSearch).
Public property | ViewAttendantInboundProfiles | Provides access to the property representing the ViewAttendantInboundProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantInboundProfiles).
Public property | ViewAttendantOperatorProfileInSearch | Provides access to the property representing the ViewAttendantOperatorProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOperatorProfileInSearch).
Public property | ViewAttendantOperatorProfiles | Provides access to the property representing the ViewAttendantOperatorProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOperatorProfiles).
Public property | ViewAttendantOutboundProfileInSearch | Provides access to the property representing the ViewAttendantOutboundProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOutboundProfileInSearch).
Public property | ViewAttendantOutboundProfiles | Provides access to the property representing the ViewAttendantOutboundProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOutboundProfiles).
Public property | ViewCampaignList | Provides access to the property representing the right to access ViewCampaignList (use TPropertyEnum.AccessRights_ViewCampaignList).
Public property | ViewCampaignsAgentlessCallingMode | Obsolete. Provides access to the property representing the right to access ViewCampaignsAgentlessCallingMode (use TPropertyEnum.AccessRights_ViewCampaignsAgentlessCallingMode).
Public property | ViewCampaignsAutomaticTimezoneMapping | Obsolete. Provides access to the property representing the right to access ViewCampaignsAutomaticTimezoneMapping (use TPropertyEnum.AccessRights_ViewCampaignsAutomaticTimezoneMapping).
Public property | ViewCampaignsLineSettings | Obsolete. Provides access to the property representing the right to access ViewCampaignsLineSettings (use TPropertyEnum.AccessRights_ViewCampaignsLineSettings).
Public property | ViewCampaignsMaxLinesPerCampaign | Obsolete. Provides access to the property representing the right to access ViewCampaignsMaxLinesPerCampaign (use TPropertyEnum.AccessRights_ViewCampaignsMaxLinesPerCampaign).
Public property | ViewCampaignStatus | Obsolete. Provides access to the property representing the right to access ViewCampaignStatus (use TPropertyEnum.AccessRights_ViewCampaignStatus).
Public property | ViewDataSource | Provides access to the property representing the right to view the IC Data Source list (use TPropertyEnum.AccessRights_ViewDataSource).
Public property | ViewFeedbackSurveys | Provides access to the property representing the right to view feedback surveys (use TPropertyEnum.AccessRights_ViewFeedbackSurveys).
Public property | ViewGeneralDirectories | Provides access to the property representing the ViewGeneralDirectories access right for this user (use TPropertyEnum.AccessRights_ViewGeneralDirectories).
Public property | ViewHistoricalReports | Provides access to the property representing the ViewHistoricalReports access right for this user (use TPropertyEnum.AccessRights_ViewHistoricalReports).
Public property | ViewIndividualStatistics | Provides access to the property representing the ViewIndividualStatistics access right for this user (use TPropertyEnum.AccessRights_ViewIndividualStatistics).
Public property | ViewLayoutList | Provides access to the property representing the ViewLayoutList access right for this user (use TPropertyEnum.AccessRights_ViewLayoutList).
Public property | ViewLineQueue | Provides access to the property representing the right to view the line queue list (use TPropertyEnum.AccessRights_ViewLineQueue).
Public property | ViewModifyOptimizerAll | Provides access to the property representing the ViewModifyOptimizerAll access right for this user (use TPropertyEnum.AccessRights_ViewModifyOptimizerAll).
Public property | ViewOptimizerForecasts | Provides access to the property representing the right to access ViewOptimizerForecasts (use TPropertyEnum.AccessRights_ViewOptimizerForecasts).
Public property | ViewOptimizerSchedulingUnits | Obsolete. Provides access to the property representing the right to view optimizer scheduling units (use TPropertyEnum.AccessRights_ViewOptimizerSchedulingUnits).
Public property | ViewPolicySetsBehaviorTypeCustomHandler | Obsolete. Provides access to the property representing the right to access ViewPolicySetsBehaviorTypeCustomHandler (use TPropertyEnum.AccessRights_ViewPolicySetsBehaviorTypeCustomHandler).
Public property | ViewPolicySetsBehaviorTypeEventLog | Obsolete. Provides access to the property representing the right to access ViewPolicySetsBehaviorTypeEventLog (use TPropertyEnum.AccessRights_ViewPolicySetsBehaviorTypeEventLog).
Public property | ViewPositionsList | Provides access to the property representing the ViewPositionsList access right for this user (use TPropertyEnum.AccessRights_ViewPositionsList).
Public property | ViewProcessList | Provides access to the property representing the ViewProcessList access right for this user (use TPropertyEnum.AccessRights_ViewProcessList).
Public property | ViewQueueControlColumns | Provides access to the property representing the ViewQueueControlColumns access right for this user (use TPropertyEnum.AccessRights_ViewQueueControlColumns).
Public property | ViewRecorderQuestionnaires | Provides access to the property representing the right to view recorder questionnaires (use TPropertyEnum.AccessRights_ViewRecorderQuestionnaires).
Public property | ViewReport | Provides access to the property representing the right to view the report list (use TPropertyEnum.AccessRights_ViewReport).
Public property | ViewRuleSetsCustomHandler | Obsolete. Provides access to the property representing the right to access ViewRuleSetsCustomHandler (use TPropertyEnum.AccessRights_ViewRuleSetsCustomHandler).
Public property | ViewRuleSetsEventLog | Obsolete. Provides access to the property representing the right to access ViewRuleSetsEventLog (use TPropertyEnum.AccessRights_ViewRuleSetsEventLog).
Public property | ViewSchedulingUnitAgentConstraints | Provides access to the property representing the right to view optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentConstraints).
Public property | ViewSchedulingUnitAgentGroups | Provides access to the property representing the right to view optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentGroups).
Public property | ViewSchedulingUnitConfiguration | Provides access to the property representing the right to view optimizer scheduling unit configuration (use TPropertyEnum.AccessRights_ViewSchedulingUnitConfiguration).
Public property | ViewSchedulingUnitIntradayMonitoring | Provides access to the property representing the right to view optimizer scheduling unit intraday monitoring (use TPropertyEnum.AccessRights_ViewSchedulingUnitIntradayMonitoring).
Public property | ViewSchedulingUnitListRealTimeAdherence | Provides access to the property representing the right to view optimizer scheduling unit real-time adherence (use TPropertyEnum.AccessRights_ViewSchedulingUnitListRealTimeAdherence).
Public property | ViewSchedulingUnitSchedulePreferences | Provides access to the property representing the right to view optimizer scheduling unit preferences (use TPropertyEnum.AccessRights_ViewSchedulingUnitSchedulePreferences).
Public property | ViewSchedulingUnitSchedules | Provides access to the property representing the right to view optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_ViewSchedulingUnitSchedules).
Public property | ViewSchedulingUnitShiftRotations | Provides access to the property representing the right to view optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_ViewSchedulingUnitShiftRotations).
Public property | ViewSchedulingUnitShifts | Provides access to the property representing the right to view optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_ViewSchedulingUnitShifts).
Public property | ViewSchedulingUnitTimeoffRequests | Provides access to the property representing the right to view optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentGroups).
Public property | ViewSkillList | Provides access to the property representing the ViewSkillList access right for this user (use TPropertyEnum.AccessRights_ViewSkillList).
Public property | ViewStationGroups | Provides access to the property representing the ViewStationGroups access right for this user (use TPropertyEnum.AccessRights_ViewStationGroups).
Public property | ViewStationGroupsInSearch | Provides access to the property representing the ViewStationGroupsInSearch access right for this user (use TPropertyEnum.AccessRights_ViewStationGroupsInSearch).
Public property | ViewStationQueue | Provides access to the property representing the right to view the station queue list(use TPropertyEnum.AccessRights_ViewStationQueue).
Public property | ViewStationQueueInSearch | Provides access to the property representing the ViewStationQueueInSearch access right for this user (use TPropertyEnum.AccessRights_ViewStationQueueInSearch).
Public property | ViewStatusColumns | Provides access to the property representing the ViewStatusColumns access right for this user (use TPropertyEnum.AccessRights_ViewStatusColumns).
Public property | ViewUserInteractionHistory | Provides access to the property representing the right to view user interaction history (use TPropertyEnum.AccessRights_ViewUserInteractionHistory).
Public property | ViewUserQueue | Provides access to the property representing the right to view the user queue list (use TPropertyEnum.AccessRights_ViewUserQueue).
Public property | ViewWorkgroup | Provides access to the property representing the right to view the workgroup list (use TPropertyEnum.AccessRights_ViewWorkgroup).
Public property | ViewWorkgroupQueue | Provides access to the property representing the ViewWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupQueue).
Public property | ViewWorkgroupQueueInSearch | Provides access to the property representing the ViewWorkgroupQueueInSearch access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupQueueInSearch).
Public property | ViewWorkgroupStatistics | Provides access to the property representing the ViewWorkgroupStatistics access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupStatistics).

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ActivateOthers Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ActivateOthers Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ActivateOthers access right for this user (use TPropertyEnum.AccessRights_ActivateOthers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ActivateOthers { get; }
Visual Basic
Public ReadOnly Property ActivateOthers As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ActivateOthers access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ActivateSelf Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ActivateSelf Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ActivateSelf access right for this user (use TPropertyEnum.AccessRights_ActivateOthers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ActivateSelf { get; }
Visual Basic
Public ReadOnly Property ActivateSelf As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ActivateSelf access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanEditAccessRights Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanEditAccessRights Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the can edit access rights for this user (use TPropertyEnum.AccessRights_CanEditAccessRights).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanEditAccessRights { get; }
Visual Basic
Public ReadOnly Property CanEditAccessRights As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the can edit access rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ChangeUserStatus Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeUserStatus Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ChangeUserStatus access right for this user (use TPropertyEnum.AccessRights_ChangeUserStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ChangeUserStatus { get; }
Visual Basic
Public ReadOnly Property ChangeUserStatus As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ChangeUserStatus access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..ChangeUserStatus


ClientButtons Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientButtons Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify client buttons (use TPropertyEnum.AccessRights_ClientButtons).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ClientButtons { get; }
Visual Basic
Public ReadOnly Property ClientButtons As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the client buttons access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
CustomButtonConfiguration..::..Rights..::..View


CoachLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CoachLineQueue access right for this user (use TPropertyEnum.AccessRights_CoachLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CoachLineQueue { get; }
Visual Basic
Public ReadOnly Property CoachLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the CoachLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..CoachLineQueue


CoachStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CoachStationQueue access right for this user (use TPropertyEnum.AccessRights_CoachStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CoachStationQueue { get; }
Visual Basic
Public ReadOnly Property CoachStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the CoachStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..CoachStationQueue


CoachUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CoachUserQueue access right for this user (use TPropertyEnum.AccessRights_CoachUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CoachUserQueue { get; }
Visual Basic
Public ReadOnly Property CoachUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the CoachUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..CoachUserQueue


CoachWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CoachWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_CoachWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CoachWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property CoachWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the CoachWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..CoachWorkgroupQueue


CreateOptimizerForecasts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateOptimizerForecasts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access CreateOptimizerForecasts (use TPropertyEnum.AccessRights_CreateOptimizerForecasts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateOptimizerForecasts { get; }
Visual Basic
Public ReadOnly Property CreateOptimizerForecasts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the CreateOptimizerForecasts access right.

Remarks

This access right is only available when Optimizer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateSchedulingUnitAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateSchedulingUnitAgentConstraints Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentConstraints).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateSchedulingUnitAgentConstraints { get; }
Visual Basic
Public ReadOnly Property CreateSchedulingUnitAgentConstraints As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the create optimizer scheduling unit agent constraints right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateSchedulingUnitAgentGroups Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateSchedulingUnitAgentGroups Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateSchedulingUnitAgentGroups { get; }
Visual Basic
Public ReadOnly Property CreateSchedulingUnitAgentGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the create optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateSchedulingUnitSchedules Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateSchedulingUnitSchedules Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_CreateSchedulingUnitSchedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateSchedulingUnitSchedules { get; }
Visual Basic
Public ReadOnly Property CreateSchedulingUnitSchedules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the create optimizer scheduling unit schedules right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateSchedulingUnitShiftRotations Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateSchedulingUnitShiftRotations Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_CreateSchedulingUnitShiftRotations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateSchedulingUnitShiftRotations { get; }
Visual Basic
Public ReadOnly Property CreateSchedulingUnitShiftRotations As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the create optimizer scheduling unit shift rotations right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateSchedulingUnitShifts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateSchedulingUnitShifts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_CreateSchedulingUnitShifts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateSchedulingUnitShifts { get; }
Visual Basic
Public ReadOnly Property CreateSchedulingUnitShifts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the create optimizer scheduling unit shifts right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateSchedulingUnitTimeoffRequests Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateSchedulingUnitTimeoffRequests Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_CreateSchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> CreateSchedulingUnitTimeoffRequests { get; }
Visual Basic
Public ReadOnly Property CreateSchedulingUnitTimeoffRequests As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the create optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteOptimizerForecasts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteOptimizerForecasts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access DeleteOptimizerForecasts (use TPropertyEnum.AccessRights_DeleteOptimizerForecasts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteOptimizerForecasts { get; }
Visual Basic
Public ReadOnly Property DeleteOptimizerForecasts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the DeleteOptimizerForecasts access right.

Remarks

This access right is only available when Optimizer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteSchedulingUnitAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteSchedulingUnitAgentConstraints Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentConstraints).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteSchedulingUnitAgentConstraints { get; }
Visual Basic
Public ReadOnly Property DeleteSchedulingUnitAgentConstraints As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the delete optimizer scheduling unit agent constraints right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteSchedulingUnitAgentGroups Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteSchedulingUnitAgentGroups Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteSchedulingUnitAgentGroups { get; }
Visual Basic
Public ReadOnly Property DeleteSchedulingUnitAgentGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the delete optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteSchedulingUnitSchedules Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteSchedulingUnitSchedules Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_DeleteSchedulingUnitSchedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteSchedulingUnitSchedules { get; }
Visual Basic
Public ReadOnly Property DeleteSchedulingUnitSchedules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the delete optimizer scheduling unit schedules right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteSchedulingUnitShiftRotations Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteSchedulingUnitShiftRotations Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_DeleteSchedulingUnitShiftRotations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteSchedulingUnitShiftRotations { get; }
Visual Basic
Public ReadOnly Property DeleteSchedulingUnitShiftRotations As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the delete optimizer scheduling unit shift rotations right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteSchedulingUnitShifts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteSchedulingUnitShifts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_DeleteSchedulingUnitShifts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteSchedulingUnitShifts { get; }
Visual Basic
Public ReadOnly Property DeleteSchedulingUnitShifts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the delete optimizer scheduling unit shifts right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteSchedulingUnitTimeoffRequests Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteSchedulingUnitTimeoffRequests Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_DeleteSchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DeleteSchedulingUnitTimeoffRequests { get; }
Visual Basic
Public ReadOnly Property DeleteSchedulingUnitTimeoffRequests As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the delete optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DisconnectLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DisconnectLineQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DisconnectLineQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the DisconnectLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..DisconnectLineQueue


DisconnectStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DisconnectStationQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DisconnectStationQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the DisconnectStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..DisconnectStationQueue


DisconnectUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DisconnectUserQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DisconnectUserQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the DisconnectUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..DisconnectUserQueue


DisconnectWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DisconnectWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_DisconnectWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> DisconnectWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the DisconnectWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..DisconnectWorkgroupQueue


EFaqs Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..EFaqs Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access user queues (use TPropertyEnum.AccessRights_EFaqs).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> EFaqs { get; }
Visual Basic
Public ReadOnly Property EFaqs As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the add organizations access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
EFaqConfiguration..::..Rights..::..View


FollowMePhoneNumberClassifications Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FollowMePhoneNumberClassifications Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access Phone Number Classifications for follow-me (use TPropertyEnum.AccessRights_FollowMePhoneNumberClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> FollowMePhoneNumberClassifications { get; }
Visual Basic
Public ReadOnly Property FollowMePhoneNumberClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the Follow-me Phone Numbers Classifications access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PhoneNumberClassificationConfiguration..::..Rights..::..FollowMe


ForwardPhoneNumberClassifications Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ForwardPhoneNumberClassifications Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access Phone Number Classifications for call forwarding. (use TPropertyEnum.AccessRights_ForwardPhoneNumberClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ForwardPhoneNumberClassifications { get; }
Visual Basic
Public ReadOnly Property ForwardPhoneNumberClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the Forward Phone Numbers Classifications access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PhoneNumberClassificationConfiguration..::..Rights..::..Forward


HoldStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..HoldStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the HoldStationQueue access right for this user (use TPropertyEnum.AccessRights_HoldStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> HoldStationQueue { get; }
Visual Basic
Public ReadOnly Property HoldStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the HoldStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..HoldStationQueue


HoldUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..HoldUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the HoldUserQueue access right for this user (use TPropertyEnum.AccessRights_HoldUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> HoldUserQueue { get; }
Visual Basic
Public ReadOnly Property HoldUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the HoldUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..HoldUserQueue


InteractionClientPlugins Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionClientPlugins Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify interaction client plugins (use TPropertyEnum.AccessRights_InteractionClientPlugins).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionClientPlugins { get; }
Visual Basic
Public ReadOnly Property InteractionClientPlugins As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify interaction client plugins right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
InteractionClientPluginConfiguration..::..Rights..::..View


InteractionConferenceRestrictRooms Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionConferenceRestrictRooms Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the InteractionConferenceRestrictRooms access right for this user (use TPropertyEnum.AccessRights_InteractionConferenceRestrictRooms).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionConferenceRestrictRooms { get; }
Visual Basic
Public ReadOnly Property InteractionConferenceRestrictRooms As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the InteractionConferenceRestrictRooms access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
InteractionConferenceRoomConfiguration..::..Rights..::..View


JoinLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the JoinLineQueue access right for this user (use TPropertyEnum.AccessRights_JoinLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> JoinLineQueue { get; }
Visual Basic
Public ReadOnly Property JoinLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the JoinLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..JoinLineQueue


JoinStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the JoinStationQueue access right for this user (use TPropertyEnum.AccessRights_JoinStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> JoinStationQueue { get; }
Visual Basic
Public ReadOnly Property JoinStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the JoinStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..JoinStationQueue


JoinUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the JoinUserQueue access right for this user (use TPropertyEnum.AccessRights_JoinUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> JoinUserQueue { get; }
Visual Basic
Public ReadOnly Property JoinUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the JoinUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..JoinUserQueue


JoinWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the JoinWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_JoinWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> JoinWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property JoinWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the JoinWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..JoinWorkgroupQueue


LaunchableProcessList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LaunchableProcessList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the LaunchableProcessList access right for this user (use TPropertyEnum.AccessRights_LaunchableProcessList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> LaunchableProcessList { get; }
Visual Basic
Public ReadOnly Property LaunchableProcessList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the LaunchableProcessList access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ProcessConfiguration..::..Rights..::..LaunchableProcessList


ListAccountCodes Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListAccountCodes Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list account codes access right for this user (use TPropertyEnum.AccessRights_ListAccountCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ListAccountCodes { get; }
Visual Basic
Public ReadOnly Property ListAccountCodes As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list account codes access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AccountCodeConfiguration..::..Rights..::..View


ListenLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ListenLineQueue access right for this user (use TPropertyEnum.AccessRights_ListenLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ListenLineQueue { get; }
Visual Basic
Public ReadOnly Property ListenLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ListenLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..ListenLineQueue


ListenStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ListenStationQueue access right for this user (use TPropertyEnum.AccessRights_ListenStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ListenStationQueue { get; }
Visual Basic
Public ReadOnly Property ListenStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ListenStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..ListenStationQueue


ListenUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ListenUserQueue access right for this user (use TPropertyEnum.AccessRights_ListenUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ListenUserQueue { get; }
Visual Basic
Public ReadOnly Property ListenUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ListenUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..ListenUserQueue


ListenWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ListenWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_ListenWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ListenWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property ListenWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ListenWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..ListenWorkgroupQueue


LoginStation Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LoginStation Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the LoginStation access right for this user (use TPropertyEnum.AccessRights_LoginStation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> LoginStation { get; }
Visual Basic
Public ReadOnly Property LoginStation As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the LoginStation access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..LoginStation


ManageProcessList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ManageProcessList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ManageProcessList access right for this user (use TPropertyEnum.AccessRights_ManageProcessList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ManageProcessList { get; }
Visual Basic
Public ReadOnly Property ManageProcessList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ManageProcessList access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Miscellaneous Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Miscellaneous Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access miscellaneous settings (use TPropertyEnum.AccessRights_Miscellaneous).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Miscellaneous { get; }
Visual Basic
Public ReadOnly Property Miscellaneous As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the miscellaneous access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
MiscellaneousItemConfiguration..::..Rights..::..View


ModifyAttendantEmailProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantEmailProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyAttendantEmailProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantEmailProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyAttendantEmailProfiles { get; }
Visual Basic
Public ReadOnly Property ModifyAttendantEmailProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyAttendantEmailProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantEmailProfileConfiguration..::..Rights..::..Modify


ModifyAttendantInboundProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantInboundProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyAttendantInboundProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantInboundProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyAttendantInboundProfiles { get; }
Visual Basic
Public ReadOnly Property ModifyAttendantInboundProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyAttendantInboundProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantInboundProfileConfiguration..::..Rights..::..Modify


ModifyAttendantOperatorProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantOperatorProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyAttendantOperatorProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantOperatorProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyAttendantOperatorProfiles { get; }
Visual Basic
Public ReadOnly Property ModifyAttendantOperatorProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyAttendantOperatorProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantOperatorProfileConfiguration..::..Rights..::..Modify


ModifyAttendantOutboundProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyAttendantOutboundProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyAttendantOutboundProfiles access right for this user (use TPropertyEnum.AccessRights_ModifyAttendantOutboundProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyAttendantOutboundProfiles { get; }
Visual Basic
Public ReadOnly Property ModifyAttendantOutboundProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyAttendantOutboundProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantOutboundProfileConfiguration..::..Rights..::..Modify


ModifyCampaignList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyCampaignList (use TPropertyEnum.AccessRights_ModifyCampaignList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyCampaignList { get; }
Visual Basic
Public ReadOnly Property ModifyCampaignList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyCampaignList access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyCampaignsAgentlessCallingMode Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignsAgentlessCallingMode Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyCampaignsAgentlessCallingMode (use TPropertyEnum.AccessRights_ModifyCampaignsAgentlessCallingMode).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyCampaignsAgentlessCallingMode is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyCampaignsAgentlessCallingMode { get; }
Visual Basic
<ObsoleteAttribute("ModifyCampaignsAgentlessCallingMode is no longer used.")> _
Public ReadOnly Property ModifyCampaignsAgentlessCallingMode As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyCampaignsAgentlessCallingMode access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyCampaignsAutomaticTimezoneMapping Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignsAutomaticTimezoneMapping Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyCampaignsAutomaticTimezoneMapping (use TPropertyEnum.AccessRights_ModifyCampaignsAutomaticTimezoneMapping).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyCampaignsAutomaticTimezoneMapping is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyCampaignsAutomaticTimezoneMapping { get; }
Visual Basic
<ObsoleteAttribute("ModifyCampaignsAutomaticTimezoneMapping is no longer used.")> _
Public ReadOnly Property ModifyCampaignsAutomaticTimezoneMapping As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyCampaignsAutomaticTimezoneMapping access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyCampaignsLineSettings Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignsLineSettings Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyCampaignsLineSettings (use TPropertyEnum.AccessRights_ModifyCampaignsLineSettings).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyCampaignsLineSettings is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyCampaignsLineSettings { get; }
Visual Basic
<ObsoleteAttribute("ModifyCampaignsLineSettings is no longer used.")> _
Public ReadOnly Property ModifyCampaignsLineSettings As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyCampaignsLineSettings access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyCampaignsMaxLinesPerCampaign Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignsMaxLinesPerCampaign Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyCampaignsMaxLinesPerCampaign (use TPropertyEnum.AccessRights_ModifyCampaignsMaxLinesPerCampaign).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyCampaignsMaxLinesPerCampaign is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyCampaignsMaxLinesPerCampaign { get; }
Visual Basic
<ObsoleteAttribute("ModifyCampaignsMaxLinesPerCampaign is no longer used.")> _
Public ReadOnly Property ModifyCampaignsMaxLinesPerCampaign As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyCampaignsMaxLinesPerCampaign access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyCampaignStatus Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignStatus Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyCampaignStatus (use TPropertyEnum.AccessRights_ModifyCampaignStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyCampaignStatus is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyCampaignStatus { get; }
Visual Basic
<ObsoleteAttribute("ModifyCampaignStatus is no longer used.")> _
Public ReadOnly Property ModifyCampaignStatus As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyCampaignStatus access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyFeedbackSurveys Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyFeedbackSurveys Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify interaction feedback surveys (use TPropertyEnum.AccessRights_ModifyFeedbackSurveys).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyFeedbackSurveys { get; }
Visual Basic
Public ReadOnly Property ModifyFeedbackSurveys As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify interaction feedback surveys right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
FeedbackSurveyConfiguration..::..Rights..::..Modify


ModifyOptimizerForecasts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyOptimizerForecasts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyOptimizerForecasts (use TPropertyEnum.AccessRights_ModifyOptimizerForecasts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyOptimizerForecasts { get; }
Visual Basic
Public ReadOnly Property ModifyOptimizerForecasts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyOptimizerForecasts access right.

Remarks

This access right is only available when Optimizer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyPolicySetsBehaviorTypeCustomHandler Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyPolicySetsBehaviorTypeCustomHandler Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyPolicySetsBehaviorTypeCustomHandler (use TPropertyEnum.AccessRights_ModifyPolicySetsBehaviorTypeCustomHandler).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyPolicySetsBehaviorTypeCustomHandler is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyPolicySetsBehaviorTypeCustomHandler { get; }
Visual Basic
<ObsoleteAttribute("ModifyPolicySetsBehaviorTypeCustomHandler is no longer used.")> _
Public ReadOnly Property ModifyPolicySetsBehaviorTypeCustomHandler As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyPolicySetsBehaviorTypeCustomHandler access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyPolicySetsBehaviorTypeEventLog Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyPolicySetsBehaviorTypeEventLog Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyPolicySetsBehaviorTypeEventLog (use TPropertyEnum.AccessRights_ModifyPolicySetsBehaviorTypeEventLog).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyPolicySetsBehaviorTypeEventLog is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyPolicySetsBehaviorTypeEventLog { get; }
Visual Basic
<ObsoleteAttribute("ModifyPolicySetsBehaviorTypeEventLog is no longer used.")> _
Public ReadOnly Property ModifyPolicySetsBehaviorTypeEventLog As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyPolicySetsBehaviorTypeEventLog access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyRecorderQuestionnaires Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyRecorderQuestionnaires Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify recorder questionnaires (use TPropertyEnum.AccessRights_ModifyRecorderQuestionnaires).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyRecorderQuestionnaires { get; }
Visual Basic
Public ReadOnly Property ModifyRecorderQuestionnaires As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify recorder questionnaires right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
RecorderQuestionnaireConfiguration..::..Rights..::..Modify


ModifyRuleSetsCustomHandler Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyRuleSetsCustomHandler Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyRuleSetsCustomHandler (use TPropertyEnum.AccessRights_ModifyRuleSetsCustomHandler).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyRuleSetsCustomHandler is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyRuleSetsCustomHandler { get; }
Visual Basic
<ObsoleteAttribute("ModifyRuleSetsCustomHandler is no longer used.")> _
Public ReadOnly Property ModifyRuleSetsCustomHandler As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyRuleSetsCustomHandler access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyRuleSetsEventLog Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyRuleSetsEventLog Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ModifyRuleSetsEventLog (use TPropertyEnum.AccessRights_ModifyRuleSetsEventLog).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyRuleSetsEventLog is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifyRuleSetsEventLog { get; }
Visual Basic
<ObsoleteAttribute("ModifyRuleSetsEventLog is no longer used.")> _
Public ReadOnly Property ModifyRuleSetsEventLog As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ModifyRuleSetsEventLog access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitAgentConstraints Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentConstraints).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitAgentConstraints { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitAgentConstraints As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit agent constraints right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitAgentGroups Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitAgentGroups Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitAgentGroups { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitAgentGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitConfiguration Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitConfiguration Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit configuration (use TPropertyEnum.AccessRights_ModifySchedulingUnitConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitConfiguration { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit configuration right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitListRealTimeAdherence Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitListRealTimeAdherence Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit real-time adherence (use TPropertyEnum.AccessRights_ModifySchedulingUnitListRealTimeAdherence).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitListRealTimeAdherence { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitListRealTimeAdherence As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit real-time adherence right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitSchedules Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitSchedules Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_ModifySchedulingUnitSchedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitSchedules { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitSchedules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit schedules right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitShiftRotations Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitShiftRotations Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_ModifySchedulingUnitShiftRotations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitShiftRotations { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitShiftRotations As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit shift rotations right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitShifts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitShifts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_ModifySchedulingUnitShifts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitShifts { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitShifts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit shifts right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifySchedulingUnitTimeoffRequests Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifySchedulingUnitTimeoffRequests Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ModifySchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ModifySchedulingUnitTimeoffRequests { get; }
Visual Basic
Public ReadOnly Property ModifySchedulingUnitTimeoffRequests As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MuteStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MuteStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the MuteStationQueue access right for this user (use TPropertyEnum.AccessRights_MuteStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> MuteStationQueue { get; }
Visual Basic
Public ReadOnly Property MuteStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the MuteStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..MuteStationQueue


MuteUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MuteUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the MuteUserQueue access right for this user (use TPropertyEnum.AccessRights_MuteUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> MuteUserQueue { get; }
Visual Basic
Public ReadOnly Property MuteUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the MuteUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..MuteUserQueue


OptimizerModifyShiftTrading Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OptimizerModifyShiftTrading Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer scheduling unit shift trading (use TPropertyEnum.AccessRights_OptimizerModifyShiftTrading).

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> OptimizerModifyShiftTrading { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyShiftTrading As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify optimizer scheduling unit shift trading right.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


OptimizerViewShiftTrading Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OptimizerViewShiftTrading Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit shift trading(use TPropertyEnum.AccessRights_OptimizerViewShiftTrading).

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> OptimizerViewShiftTrading { get; }
Visual Basic
Public ReadOnly Property OptimizerViewShiftTrading As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit shift trading right.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PhoneNumberClassifications Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PhoneNumberClassifications Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access Phone Number Classifications (use TPropertyEnum.AccessRights_PhoneNumberClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PhoneNumberClassifications { get; }
Visual Basic
Public ReadOnly Property PhoneNumberClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the Phone Numbers Classifications access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PhoneNumberClassificationConfiguration..::..Rights..::..View


PickupLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PickupLineQueue access right for this user (use TPropertyEnum.AccessRights_PickupLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PickupLineQueue { get; }
Visual Basic
Public ReadOnly Property PickupLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the PickupLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..PickupLineQueue


PickupStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PickupStationQueue access right for this user (use TPropertyEnum.AccessRights_PickupStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PickupStationQueue { get; }
Visual Basic
Public ReadOnly Property PickupStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the PickupStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..PickupStationQueue


PickupUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PickupUserQueue access right for this user (use TPropertyEnum.AccessRights_PickupUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PickupUserQueue { get; }
Visual Basic
Public ReadOnly Property PickupUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the PickupUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..PickupUserQueue


PickupWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PickupWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_PickupWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PickupWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property PickupWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the PickupWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..PickupWorkgroupQueue


PreviewEmailUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PreviewEmailUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PreviewEmailUserQueue access right for this user (use TPropertyEnum.AccessRights_PreviewEmailUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PreviewEmailUserQueue { get; }
Visual Basic
Public ReadOnly Property PreviewEmailUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the PreviewEmailUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..PreviewEmailUserQueue


PreviewEmailWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PreviewEmailWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PreviewEmailWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_PreviewEmailWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PreviewEmailWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property PreviewEmailWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the PreviewEmailWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..PreviewEmailWorkgroupQueue


RecordLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RecordLineQueue access right for this user (use TPropertyEnum.AccessRights_RecordLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> RecordLineQueue { get; }
Visual Basic
Public ReadOnly Property RecordLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the RecordLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..RecordLineQueue


RecordStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RecordStationQueue access right for this user (use TPropertyEnum.AccessRights_RecordStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> RecordStationQueue { get; }
Visual Basic
Public ReadOnly Property RecordStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the RecordStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..RecordStationQueue


RecordUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RecordUserQueue access right for this user (use TPropertyEnum.AccessRights_RecordUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> RecordUserQueue { get; }
Visual Basic
Public ReadOnly Property RecordUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the RecordUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..RecordUserQueue


RecordWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RecordWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_RecordWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> RecordWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property RecordWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the RecordWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..RecordWorkgroupQueue


ResponseManagementDocuments Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ResponseManagementDocuments Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify response management documents (use TPropertyEnum.AccessRights_ResponseManagementDocuments).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ResponseManagementDocuments { get; }
Visual Basic
Public ReadOnly Property ResponseManagementDocuments As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify response management documents right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ResponseManagementDocumentConfiguration..::..Rights..::..View


SnipLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SnipLineQueue access right for this user (use TPropertyEnum.AccessRights_SnipLineQueue).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SnipLineQueue { get; }
Visual Basic
Public ReadOnly Property SnipLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SnipLineQueue access right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..SnipLineQueue


SnipStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SnipStationQueue access right for this user (use TPropertyEnum.AccessRights_SnipStationQueue).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SnipStationQueue { get; }
Visual Basic
Public ReadOnly Property SnipStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SnipStationQueue access right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..SnipStationQueue


SnipUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SnipUserQueue access right for this user (use TPropertyEnum.AccessRights_SnipUserQueue).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SnipUserQueue { get; }
Visual Basic
Public ReadOnly Property SnipUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SnipUserQueue access right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..SnipUserQueue


SnipWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SnipWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_SnipWorkgroupQueue).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SnipWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property SnipWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SnipWorkgroupQueue access right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..SnipWorkgroupQueue


StatusMessages Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StatusMessages Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify status messages (use TPropertyEnum.AccessRights_StatusMessages).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> StatusMessages { get; }
Visual Basic
Public ReadOnly Property StatusMessages As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the modify status messages right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StatusMessageConfiguration..::..Rights..::..View


SubstituteQueueControlColumns Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SubstituteQueueControlColumns Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SubstituteQueueControlColumns access right for this user (use TPropertyEnum.AccessRights_SubstituteQueueControlColumns).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SubstituteQueueControlColumns { get; }
Visual Basic
Public ReadOnly Property SubstituteQueueControlColumns As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SubstituteQueueControlColumns access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
QueueColumnConfiguration..::..Rights..::..Substitute


TransferLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the TransferLineQueue access right for this user (use TPropertyEnum.AccessRights_TransferLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> TransferLineQueue { get; }
Visual Basic
Public ReadOnly Property TransferLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the TransferLineQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..TransferLineQueue


TransferStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the TransferStationQueue access right for this user (use TPropertyEnum.AccessRights_TransferStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> TransferStationQueue { get; }
Visual Basic
Public ReadOnly Property TransferStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the TransferStationQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..TransferStationQueue


TransferUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the TransferUserQueue access right for this user (use TPropertyEnum.AccessRights_TransferUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> TransferUserQueue { get; }
Visual Basic
Public ReadOnly Property TransferUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the TransferUserQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..TransferUserQueue


TransferWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the TransferWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_TransferWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> TransferWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property TransferWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the TransferWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..TransferWorkgroupQueue


TuiPhoneNumberClassifications Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TuiPhoneNumberClassifications Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access Phone Number Classifications via the TUI. (use TPropertyEnum.AccessRights_TuiPhoneNumberClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> TuiPhoneNumberClassifications { get; }
Visual Basic
Public ReadOnly Property TuiPhoneNumberClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the TUI Phone Numbers Classifications access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PhoneNumberClassificationConfiguration..::..Rights..::..Tui


ViewAttendantEmailProfileInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantEmailProfileInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantEmailProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantEmailProfileInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantEmailProfileInSearch { get; }
Visual Basic
Public ReadOnly Property ViewAttendantEmailProfileInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantEmailProfileInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantEmailProfileConfiguration..::..Rights..::..ViewInSearch


ViewAttendantEmailProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantEmailProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantEmailProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantEmailProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantEmailProfiles { get; }
Visual Basic
Public ReadOnly Property ViewAttendantEmailProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantEmailProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantEmailProfileConfiguration..::..Rights..::..View


ViewAttendantInboundProfileInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantInboundProfileInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantInboundProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantInboundProfileInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantInboundProfileInSearch { get; }
Visual Basic
Public ReadOnly Property ViewAttendantInboundProfileInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantInboundProfileInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantInboundProfileConfiguration..::..Rights..::..ViewInSearch


ViewAttendantInboundProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantInboundProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantInboundProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantInboundProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantInboundProfiles { get; }
Visual Basic
Public ReadOnly Property ViewAttendantInboundProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantInboundProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantInboundProfileConfiguration..::..Rights..::..View


ViewAttendantOperatorProfileInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOperatorProfileInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantOperatorProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOperatorProfileInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantOperatorProfileInSearch { get; }
Visual Basic
Public ReadOnly Property ViewAttendantOperatorProfileInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantOperatorProfileInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantOperatorProfileConfiguration..::..Rights..::..ViewInSearch


ViewAttendantOperatorProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOperatorProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantOperatorProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOperatorProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantOperatorProfiles { get; }
Visual Basic
Public ReadOnly Property ViewAttendantOperatorProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantOperatorProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantOperatorProfileConfiguration..::..Rights..::..View


ViewAttendantOutboundProfileInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOutboundProfileInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantOutboundProfileInSearch access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOutboundProfileInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantOutboundProfileInSearch { get; }
Visual Basic
Public ReadOnly Property ViewAttendantOutboundProfileInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantOutboundProfileInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantOutboundProfileConfiguration..::..Rights..::..ViewInSearch


ViewAttendantOutboundProfiles Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewAttendantOutboundProfiles Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewAttendantOutboundProfiles access right for this user (use TPropertyEnum.AccessRights_ViewAttendantOutboundProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewAttendantOutboundProfiles { get; }
Visual Basic
Public ReadOnly Property ViewAttendantOutboundProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewAttendantOutboundProfiles access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AttendantOutboundProfileConfiguration..::..Rights..::..View


ViewCampaignList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewCampaignList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewCampaignList (use TPropertyEnum.AccessRights_ViewCampaignList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewCampaignList { get; }
Visual Basic
Public ReadOnly Property ViewCampaignList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewCampaignList access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewCampaignsAgentlessCallingMode Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewCampaignsAgentlessCallingMode Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewCampaignsAgentlessCallingMode (use TPropertyEnum.AccessRights_ViewCampaignsAgentlessCallingMode).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewCampaignsAgentlessCallingMode is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewCampaignsAgentlessCallingMode { get; }
Visual Basic
<ObsoleteAttribute("ViewCampaignsAgentlessCallingMode is no longer used.")> _
Public ReadOnly Property ViewCampaignsAgentlessCallingMode As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewCampaignsAgentlessCallingMode access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewCampaignsAutomaticTimezoneMapping Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewCampaignsAutomaticTimezoneMapping Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewCampaignsAutomaticTimezoneMapping (use TPropertyEnum.AccessRights_ViewCampaignsAutomaticTimezoneMapping).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewCampaignsAutomaticTimezoneMapping is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewCampaignsAutomaticTimezoneMapping { get; }
Visual Basic
<ObsoleteAttribute("ViewCampaignsAutomaticTimezoneMapping is no longer used.")> _
Public ReadOnly Property ViewCampaignsAutomaticTimezoneMapping As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewCampaignsAutomaticTimezoneMapping access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewCampaignsLineSettings Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewCampaignsLineSettings Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewCampaignsLineSettings (use TPropertyEnum.AccessRights_ViewCampaignsLineSettings).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewCampaignsLineSettings is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewCampaignsLineSettings { get; }
Visual Basic
<ObsoleteAttribute("ViewCampaignsLineSettings is no longer used.")> _
Public ReadOnly Property ViewCampaignsLineSettings As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewCampaignsLineSettings access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewCampaignsMaxLinesPerCampaign Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewCampaignsMaxLinesPerCampaign Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewCampaignsMaxLinesPerCampaign (use TPropertyEnum.AccessRights_ViewCampaignsMaxLinesPerCampaign).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewCampaignsMaxLinesPerCampaign is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewCampaignsMaxLinesPerCampaign { get; }
Visual Basic
<ObsoleteAttribute("ViewCampaignsMaxLinesPerCampaign is no longer used.")> _
Public ReadOnly Property ViewCampaignsMaxLinesPerCampaign As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewCampaignsMaxLinesPerCampaign access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewCampaignStatus Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewCampaignStatus Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewCampaignStatus (use TPropertyEnum.AccessRights_ViewCampaignStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewCampaignStatus is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewCampaignStatus { get; }
Visual Basic
<ObsoleteAttribute("ViewCampaignStatus is no longer used.")> _
Public ReadOnly Property ViewCampaignStatus As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewCampaignStatus access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewDataSource Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewDataSource Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view the IC Data Source list (use TPropertyEnum.AccessRights_ViewDataSource).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewDataSource { get; }
Visual Basic
Public ReadOnly Property ViewDataSource As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view ic data source list right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ICDataSourceConfiguration..::..Rights..::..View


ViewFeedbackSurveys Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewFeedbackSurveys Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view feedback surveys (use TPropertyEnum.AccessRights_ViewFeedbackSurveys).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewFeedbackSurveys { get; }
Visual Basic
Public ReadOnly Property ViewFeedbackSurveys As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view feedback surveys right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
FeedbackSurveyConfiguration..::..Rights..::..View


ViewGeneralDirectories Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewGeneralDirectories Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewGeneralDirectories access right for this user (use TPropertyEnum.AccessRights_ViewGeneralDirectories).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewGeneralDirectories { get; }
Visual Basic
Public ReadOnly Property ViewGeneralDirectories As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewGeneralDirectories access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ContactListSourceConfiguration..::..Rights..::..View


ViewHistoricalReports Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewHistoricalReports Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewHistoricalReports access right for this user (use TPropertyEnum.AccessRights_ViewHistoricalReports).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewHistoricalReports { get; }
Visual Basic
Public ReadOnly Property ViewHistoricalReports As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewHistoricalReports access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
HistoricalReportConfiguration..::..Rights..::..ViewHistoricalReports


ViewIndividualStatistics Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewIndividualStatistics Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewIndividualStatistics access right for this user (use TPropertyEnum.AccessRights_ViewIndividualStatistics).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewIndividualStatistics { get; }
Visual Basic
Public ReadOnly Property ViewIndividualStatistics As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewIndividualStatistics access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..ViewIndividualStatistics


ViewLayoutList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewLayoutList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewLayoutList access right for this user (use TPropertyEnum.AccessRights_ViewLayoutList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewLayoutList { get; }
Visual Basic
Public ReadOnly Property ViewLayoutList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewLayoutList access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LayoutConfiguration..::..Rights..::..View


ViewLineQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewLineQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view the line queue list (use TPropertyEnum.AccessRights_ViewLineQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewLineQueue { get; }
Visual Basic
Public ReadOnly Property ViewLineQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view line queue list right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..View


ViewModifyOptimizerAll Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyOptimizerAll Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyOptimizerAll access right for this user (use TPropertyEnum.AccessRights_ViewModifyOptimizerAll).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewModifyOptimizerAll { get; }
Visual Basic
Public ReadOnly Property ViewModifyOptimizerAll As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewModifyOptimizerAll access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewOptimizerForecasts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewOptimizerForecasts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewOptimizerForecasts (use TPropertyEnum.AccessRights_ViewOptimizerForecasts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewOptimizerForecasts { get; }
Visual Basic
Public ReadOnly Property ViewOptimizerForecasts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewOptimizerForecasts access right.

Remarks

This access right is only available when Optimizer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewOptimizerSchedulingUnits Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewOptimizerSchedulingUnits Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling units (use TPropertyEnum.AccessRights_ViewOptimizerSchedulingUnits).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewOptimizerSchedulingUnits is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewOptimizerSchedulingUnits { get; }
Visual Basic
<ObsoleteAttribute("ViewOptimizerSchedulingUnits is no longer used.")> _
Public ReadOnly Property ViewOptimizerSchedulingUnits As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling units right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
OptimizerSchedulingUnitConfiguration..::..Rights..::..View


ViewPolicySetsBehaviorTypeCustomHandler Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewPolicySetsBehaviorTypeCustomHandler Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewPolicySetsBehaviorTypeCustomHandler (use TPropertyEnum.AccessRights_ViewPolicySetsBehaviorTypeCustomHandler).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewPolicySetsBehaviorTypeCustomHandler is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewPolicySetsBehaviorTypeCustomHandler { get; }
Visual Basic
<ObsoleteAttribute("ViewPolicySetsBehaviorTypeCustomHandler is no longer used.")> _
Public ReadOnly Property ViewPolicySetsBehaviorTypeCustomHandler As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewPolicySetsBehaviorTypeCustomHandler access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewPolicySetsBehaviorTypeEventLog Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewPolicySetsBehaviorTypeEventLog Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewPolicySetsBehaviorTypeEventLog (use TPropertyEnum.AccessRights_ViewPolicySetsBehaviorTypeEventLog).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewPolicySetsBehaviorTypeEventLog is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewPolicySetsBehaviorTypeEventLog { get; }
Visual Basic
<ObsoleteAttribute("ViewPolicySetsBehaviorTypeEventLog is no longer used.")> _
Public ReadOnly Property ViewPolicySetsBehaviorTypeEventLog As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewPolicySetsBehaviorTypeEventLog access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewPositionsList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewPositionsList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewPositionsList access right for this user (use TPropertyEnum.AccessRights_ViewPositionsList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewPositionsList { get; }
Visual Basic
Public ReadOnly Property ViewPositionsList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewPositionsList access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PositionConfiguration..::..Rights..::..View


ViewProcessList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewProcessList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewProcessList access right for this user (use TPropertyEnum.AccessRights_ViewProcessList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewProcessList { get; }
Visual Basic
Public ReadOnly Property ViewProcessList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewProcessList access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ProcessConfiguration..::..Rights..::..View


ViewQueueControlColumns Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewQueueControlColumns Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewQueueControlColumns access right for this user (use TPropertyEnum.AccessRights_ViewQueueControlColumns).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewQueueControlColumns { get; }
Visual Basic
Public ReadOnly Property ViewQueueControlColumns As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewQueueControlColumns access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
QueueColumnConfiguration..::..Rights..::..View


ViewRecorderQuestionnaires Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewRecorderQuestionnaires Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view recorder questionnaires (use TPropertyEnum.AccessRights_ViewRecorderQuestionnaires).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewRecorderQuestionnaires { get; }
Visual Basic
Public ReadOnly Property ViewRecorderQuestionnaires As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view recorder questionnaires right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
RecorderQuestionnaireConfiguration..::..Rights..::..View


ViewReport Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewReport Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view the report list (use TPropertyEnum.AccessRights_ViewReport).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewReport { get; }
Visual Basic
Public ReadOnly Property ViewReport As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view report list right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LegacyHistoricalReportConfiguration..::..Rights..::..View


ViewRuleSetsCustomHandler Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewRuleSetsCustomHandler Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewRuleSetsCustomHandler (use TPropertyEnum.AccessRights_ViewRuleSetsCustomHandler).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewRuleSetsCustomHandler is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewRuleSetsCustomHandler { get; }
Visual Basic
<ObsoleteAttribute("ViewRuleSetsCustomHandler is no longer used.")> _
Public ReadOnly Property ViewRuleSetsCustomHandler As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewRuleSetsCustomHandler access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewRuleSetsEventLog Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewRuleSetsEventLog Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to access ViewRuleSetsEventLog (use TPropertyEnum.AccessRights_ViewRuleSetsEventLog).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ViewRuleSetsEventLog is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewRuleSetsEventLog { get; }
Visual Basic
<ObsoleteAttribute("ViewRuleSetsEventLog is no longer used.")> _
Public ReadOnly Property ViewRuleSetsEventLog As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewRuleSetsEventLog access right.

Remarks

This access right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitAgentConstraints Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit agent constraints (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentConstraints).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitAgentConstraints { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitAgentConstraints As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit agent constraints right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitAgentGroups Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitAgentGroups Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitAgentGroups { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitAgentGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitConfiguration Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitConfiguration Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit configuration (use TPropertyEnum.AccessRights_ViewSchedulingUnitConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitConfiguration { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit configuration right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitIntradayMonitoring Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitIntradayMonitoring Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit intraday monitoring (use TPropertyEnum.AccessRights_ViewSchedulingUnitIntradayMonitoring).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitIntradayMonitoring { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitIntradayMonitoring As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit intraday monitoring right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitListRealTimeAdherence Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitListRealTimeAdherence Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit real-time adherence (use TPropertyEnum.AccessRights_ViewSchedulingUnitListRealTimeAdherence).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitListRealTimeAdherence { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitListRealTimeAdherence As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit real-time adherence right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitSchedulePreferences Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitSchedulePreferences Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit preferences (use TPropertyEnum.AccessRights_ViewSchedulingUnitSchedulePreferences).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitSchedulePreferences { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitSchedulePreferences As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit preferences right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitSchedules Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitSchedules Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit schedules (use TPropertyEnum.AccessRights_ViewSchedulingUnitSchedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitSchedules { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitSchedules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit schedules right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitShiftRotations Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitShiftRotations Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit shift rotations (use TPropertyEnum.AccessRights_ViewSchedulingUnitShiftRotations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitShiftRotations { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitShiftRotations As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit shift rotations right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitShifts Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitShifts Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit shifts (use TPropertyEnum.AccessRights_ViewSchedulingUnitShifts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitShifts { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitShifts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit shifts right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSchedulingUnitTimeoffRequests Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSchedulingUnitTimeoffRequests Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer scheduling unit agent groups (use TPropertyEnum.AccessRights_ViewSchedulingUnitAgentGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSchedulingUnitTimeoffRequests { get; }
Visual Basic
Public ReadOnly Property ViewSchedulingUnitTimeoffRequests As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view optimizer scheduling unit agent groups right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewSkillList Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewSkillList Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewSkillList access right for this user (use TPropertyEnum.AccessRights_ViewSkillList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewSkillList { get; }
Visual Basic
Public ReadOnly Property ViewSkillList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewSkillList access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SkillConfiguration..::..Rights..::..View


ViewStationGroups Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationGroups Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewStationGroups access right for this user (use TPropertyEnum.AccessRights_ViewStationGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewStationGroups { get; }
Visual Basic
Public ReadOnly Property ViewStationGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewStationGroups access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationGroupConfiguration..::..Rights..::..View


ViewStationGroupsInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationGroupsInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewStationGroupsInSearch access right for this user (use TPropertyEnum.AccessRights_ViewStationGroupsInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewStationGroupsInSearch { get; }
Visual Basic
Public ReadOnly Property ViewStationGroupsInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewStationGroupsInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationGroupConfiguration..::..Rights..::..ViewStationGroupsInSearch


ViewStationQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view the station queue list(use TPropertyEnum.AccessRights_ViewStationQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewStationQueue { get; }
Visual Basic
Public ReadOnly Property ViewStationQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view station queue right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..View


ViewStationQueueInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStationQueueInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewStationQueueInSearch access right for this user (use TPropertyEnum.AccessRights_ViewStationQueueInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewStationQueueInSearch { get; }
Visual Basic
Public ReadOnly Property ViewStationQueueInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewStationQueueInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..ViewStationQueueInSearch


ViewStatusColumns Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewStatusColumns Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewStatusColumns access right for this user (use TPropertyEnum.AccessRights_ViewStatusColumns).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewStatusColumns { get; }
Visual Basic
Public ReadOnly Property ViewStatusColumns As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewStatusColumns access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StatusColumnConfiguration..::..Rights..::..View


ViewUserInteractionHistory Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewUserInteractionHistory Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view user interaction history (use TPropertyEnum.AccessRights_ViewUserInteractionHistory).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewUserInteractionHistory { get; }
Visual Basic
Public ReadOnly Property ViewUserInteractionHistory As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view user interaction history right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..ViewUserInteractionHistory


ViewUserQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewUserQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view the user queue list (use TPropertyEnum.AccessRights_ViewUserQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewUserQueue { get; }
Visual Basic
Public ReadOnly Property ViewUserQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view user queue right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..View


ViewWorkgroup Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroup Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view the workgroup list (use TPropertyEnum.AccessRights_ViewWorkgroup).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewWorkgroup { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroup As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the view workgroup list right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..View


ViewWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroupQueue Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewWorkgroupQueue access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroupQueue As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewWorkgroupQueue access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..ViewWorkgroupQueueList


ViewWorkgroupQueueInSearch Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroupQueueInSearch Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewWorkgroupQueueInSearch access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupQueueInSearch).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewWorkgroupQueueInSearch { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroupQueueInSearch As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewWorkgroupQueueInSearch access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..ViewWorkgroupQueueInSearch


ViewWorkgroupStatistics Property

[image]

IceLib Technical Reference
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroupStatistics Property
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewWorkgroupStatistics access right for this user (use TPropertyEnum.AccessRights_ViewWorkgroupStatistics).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ViewWorkgroupStatistics { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroupStatistics As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the ViewWorkgroupStatistics access right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..ViewWorkgroupStatistics


UserAdministrativeRightsProperties(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Contains Administrative Access Control Right settings for configuration objects (e.g. RoleConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserAdministrativeRightsProperties<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class UserAdministrativeRightsProperties(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
TPropertyEnum

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


UserAdministrativeRightsProperties(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountCodeList | Provides access to the property representing the right to administer account codes (use TPropertyEnum.AdministrativeRights_AccountCodeList).
Public property | AccumulatorList | Provides access to the property representing the right to administer accumulators (use TPropertyEnum.AdministrativeRights_AccumulatorList).
Public property | Actions | Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_Actions).
Public property | AudioSources | Provides access to the property representing the list of audio source rights for this user (use TPropertyEnum.AdministrativeRights_AudioSources).
Public property | CanEditAdministrativeRights | Provides access to the property representing the can edit administrative rights for this user (use TPropertyEnum.AdministrativeRights_CanEditAdministrativeRights).
Public property | CanPublishClientTemplates | Provides access to the property representing the right to publish client templates (use TPropertyEnum.AdministrativeRights_CanPublishClientTemplates).
Public property | ClientButtons | Provides access to the property representing the list of client button rights for this user (use TPropertyEnum.AdministrativeRights_ClientButtons).
Public property | ClientConfigurationConfiguration | Provides access to the property representing the client configurations configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_ClientConfigurationConfiguration).
Public property | ClientConfigurationTemplates | Provides access to the property representing the list of client configuration templates the user has rights to (use TPropertyEnum.AdministrativeRights_ClientConfigurationTemplates).
Public property | Collective | Provides access to the property representing the right to administer collectives for this user (use TPropertyEnum.AdministrativeRights_Collective).
Public property | ContactListSources | Provides access to the property representing the right to administer contact list sources for this user.(use TPropertyEnum.AdministrativeRights_ContactListSources).
Public property | DataManagerConfiguration | Provides access to the property representing the right to administer data manager for this user (use TPropertyEnum.AdministrativeRights_DataManagerConfiguration).
Public property | DefaultIPPhoneConfiguration | Provides access to the property representing the right to administer the default ip phone configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultIPPhoneConfiguration).
Public property | DefaultLocationConfiguration | Provides access to the property representing the right to administer the default location configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultLocationConfiguration).
Public property | DefaultStationConfiguration | Provides access to the property representing the right to administer the default station configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultStationConfiguration).
Public property | DefaultUserConfiguration | Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_DefaultUserConfiguration).
Public property | DnisMappingsConfiguration | Provides access to the property representing the dnis mappings configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_DnisMappingsConfiguration).
Public property | EFaq | Provides access to the property representing the right to administer Efaq's for this user.(use TPropertyEnum.AdministrativeRights_EFaq).
Public property | FaxConfiguration | Provides access to the property representing the right to administer fax configuration (use TPropertyEnum.AdministrativeRights_FaxConfiguration).
Public property | FaxGroups | Provides access to the property representing the right to administer fax groups for this user. TPropertyEnum.AdministrativeRights_FaxGroups).
Public property | Handlers | Provides access to the property representing the right to administer handlers for this user.(use TPropertyEnum.AdministrativeRights_Handlers).
Public property | ICDataSources | Provides access to the property representing the right to administer IC Datasources for this users.(use TPropertyEnum.AdministrativeRights_ICDataSources).
Public property | ImageResources | Provides access to the property representing the image resources administrative right for this user (use TPropertyEnum.AdministrativeRights_ImageResources).
Public property | InitializationFunctions | Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_InitializationFunctions).
Public property | InteractionAnalyzerKeywordSets | Provides access to the property representing the right to administer interaction analyzer keyword sets for this user (use TPropertyEnum.AdministrativeRights_InteractionAnalyzerKeywordSets).
Public property | InteractionConferenceConfiguration | Provides access to the property representing the right to administer an interaction conference for this user (use TPropertyEnum.AdministrativeRights_InteractionConferenceConfiguration).
Public property | InteractionConferenceRooms | Provides access to the property representing the right to administer interaction conference rooms for this user (use TPropertyEnum.AdministrativeRights_InteractionConferenceRooms).
Public property | InteractionDialerCallLists | Provides access to the property representing the list of Dialer Call List rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerCallLists).
Public property | InteractionDialerCampaigns | Provides access to the property representing the list of campaign rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerCampaigns).
Public property | InteractionDialerConfiguration | Provides access to the property representing the list of dialer configuration rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerConfiguration).
Public property | InteractionDialerPolicySets | Provides access to the property representing the list of dialer policy sets for this user (use TPropertyEnum.AdministrativeRights_PolicySets).
Public property | InteractionDialerRuleSets | Provides access to the property representing the list of dialer rule sets for this user (use TPropertyEnum.AdministrativeRights_RuleSets).
Public property | InteractionDialerSchedules | Provides access to the property representing the list of dialer schedule rights for this user (use TPropertyEnum.AdministrativeRights_DialerSchedules).
Public property | InteractionDialerScripts | Provides access to the property representing the right to administer scripts (use TPropertyEnum.AdministrativeRights_Scripts).
Public property | InteractionDialerSkillSets | Provides access to the property representing the right to administer skill sets (use TPropertyEnum.AdministrativeRights_SkillSets).
Public property | InteractionDialerStageSets | Provides access to the property representing the right to administer stage sets (use TPropertyEnum.AdministrativeRights_StageSets).
Public property | InteractionDialerZoneSets | Provides access to the property representing the right to administer zone sets (use TPropertyEnum.AdministrativeRights_ZoneSets).
Public property | InteractionFeedbackConfiguration | Provides access to the property representing the right to administer interaction feedback configuration (use TPropertyEnum.AdministrativeRights_InteractionFeedbackConfiguration).
Public property | InteractionOptimizerActivityTypesConfiguration | Obsolete. Provides access to the property representing the right to configure interaction optimizer activity types (use TPropertyEnum.AdministrativeRights_InteractionOptimizerActivityTypesConfiguration).
Public property | InteractionOptimizerAdvancedConfiguration | Provides access to the property representing the right to administer interaction optimizer advanced configuration (use TPropertyEnum.AdministrativeRights_InteractionOptimizerAdvancedConfiguration).
Public property | InteractionOptimizerAgentsConfiguration | Provides access to the property representing the right to administer interaction optimizer agents configuration (use TPropertyEnum.AdministrativeRights_InteractionOptimizerAgentsConfiguration).
Public property | InteractionOptimizerDayClassificationsConfiguration | Obsolete. Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_InteractionOptimizerDayClassificationsConfiguration).
Public property | InteractionOptimizerForecastsAndSchedulesConfiguration | Obsolete. Provides access to the property representing the right to administer interaction optimizer forecasts and schedules (use TPropertyEnum.AdministrativeRights_InteractionOptimizerForecastsAndSchedulesConfiguration).
Public property | InteractionOptimizerSchedulingUnits | Obsolete. Provides access to the property representing the right to administer interaction optimizer scheduling units (use TPropertyEnum.AdministrativeRights_InteractionOptimizerSchedulingUnits).
Public property | InteractionProcessAutomation | Provides access to the property representing the InteractionProcessAutomation administrative right for this user (use TPropertyEnum.AdministrativeRights_InteractionProcessAutomation).
Public property | InteractionProcessorTables | Provides access to the property representing the right to administer interaction processor tables (use TPropertyEnum.AdministrativeRights_InteractionProcessorTables).
Public property | InteractionRecorderConfiguration | Provides access to the property representing the right to administer interaction recorder configuration (use TPropertyEnum.AdministrativeRights_InteractionRecorderConfiguration).
Public property | InteractionTrackerConfiguration | Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_InteractionTrackerConfiguration).
Public property | IPPhoneRegistrationGroups | Provides access to the property representing the right to administer IP phone registration groups (use TPropertyEnum.AdministrativeRights_IPPhoneRegistrationGroups).
Public property | IPPhoneRingSets | Provides access to the property representing the right to administer IP phone ring sets (use TPropertyEnum.AdministrativeRights_IPPhoneRingSets).
Public property | IPPhones | Provides access to the property representing the right to administer IP phones (use TPropertyEnum.AdministrativeRights_IPPhones).
Public property | IPPhoneTemplates | Provides access to the property representing the right to administer IP phone templates (use TPropertyEnum.AdministrativeRights_IPPhoneTemplates).
Public property | Layouts | Provides access to the property representing the right to administer layouts (use TPropertyEnum.AdministrativeRights_Layouts).
Public property | LicensesAllocationConfiguration | Provides access to the property representing the right to administer License allocation configuration (use TPropertyEnum.AdministrativeRights_LicensesAllocationConfiguration).
Public property | LineGroups | Provides access to the property representing the right to configure line groups. (use TPropertyEnum.AdministrativeRights_LineGroups).
Public property | Lines | Provides access to the property representing the right to administer Lines (use TPropertyEnum.AdministrativeRights_Lines).
Public property | Locations | Provides access to the property representing the right to administer locations (use TPropertyEnum.AdministrativeRights_Locations).
Public property | LogRetrievalAssistantConfiguration | Provides access to the property representing the right to administer the log retrieval assistant configuration (use TPropertyEnum.AdministrativeRights_LogRetrievalAssistantConfiguration).
Public property | MailConfiguration | Provides access to the property representing the right to administer mail configuration (use TPropertyEnum.AdministrativeRights_MailConfiguration).
Public property | MasterAdministrator | Provides read-only access to the property representing the master administrator configuration rights (use TPropertyEnum.AdministrativeRights_MasterAdministrator).
Public property | MediaServersConfiguration | Provides access to the property representing the right to administer media server configurations (use TPropertyEnum.AdministrativeRights_MediaServersConfiguration).
Public property | MrcpConfiguration | Provides access to the property representing the right to administer MRCP configuration (use TPropertyEnum.AdministrativeRights_MRCPConfiguration).
Public property | MrcpServerList | Provides access to the property representing the list of MRCP server administrative rights for this user (use TPropertyEnum.AdministrativeRights_MrcpServerList).
Public property | OcsActiveDirectories | Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_OCSActiveDirectories).
Public property | OcsConfiguration | Provides access to the property representing the right to administer OCS configuration (use TPropertyEnum.AdministrativeRights_OCSConfiguration).
Public property | OcsStatusMessages | Provides access to the property representing the right to administer OCS status messages (use TPropertyEnum.AdministrativeRights_OCSStatusMessages).
Public property | PagingCarriers | Provides access to the property representing the right to administer paging carriers (use TPropertyEnum.AdministrativeRights_PagingCarriers).
Public property | PasswordPolicies | Provides access to the property representing the right to administer password policies (use TPropertyEnum.AdministrativeRights_PasswordPolicies).
Public property | PasswordPoliciesConfiguration | Provides access to the property representing the right to administer password policy configuration (use TPropertyEnum.AdministrativeRights_PasswordPoliciesConfiguration).
Public property | PeerSitesConfiguration | Provides access to the property representing the right to administer peer site configuration (use TPropertyEnum.AdministrativeRights_PeerSitesConfiguration).
Public property | PhoneNumbersConfiguration | Provides access to the property representing the list account codes administrative right for this user (use TPropertyEnum.AdministrativeRights_PhoneNumbersConfiguration).
Public property | Positions | Provides access to the property representing the right to administer positions (use TPropertyEnum.AdministrativeRights_Positions).
Public property | ProblemReporterConfiguration | Provides access to the property representing the problem reporter configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_ProblemReporterConfiguration).
Public property | QueueControlColumns | Provides access to the property representing the QueueControlColumns administrative right for this user (use TPropertyEnum.AdministrativeRights_QueueControlColumns).
Public property | ReportLogs | Provides access to the property representing the right to administer report logs (use TPropertyEnum.AdministrativeRights_ReportLogs).
Public property | Reports | Provides access to the property representing the right to administer reports (use TPropertyEnum.AdministrativeRights_Reports).
Public property | ResponseManagement | Provides access to the property representing the right to administer response management (use TPropertyEnum.AdministrativeRights_ResponseManagement).
Public property | Roles | Provides access to the property representing the right to administer Roles(use TPropertyEnum.AdministrativeRights_Roles).
Public property | SalesforceCtis | Provides access to the property representing the SalesforceCtis administrative right for this user (use TPropertyEnum.AdministrativeRights_SalesforceCtis).
Public property | SametimeConfiguration | Provides access to the property representing the SametimeConfiguration administrative right for this user (use TPropertyEnum.AdministrativeRights_SametimeConfiguration).
Public property | Schedules | Provides access to the property representing the right to administer schedules (use TPropertyEnum.AdministrativeRights_Schedules).
Public property | SecureInputForms | Provides access to the property representing the right to administer secure input forms (use TPropertyEnum.AdministrativeRights_SecureInputForms).
Public property | SelectionRuleList | Provides access to the property representing the right to administer selection rules (use TPropertyEnum.AdministrativeRights_SelectionRuleList).
Public property | ServerParameter | Provides access to the property representing the right to administer server parameters (use TPropertyEnum.AdministrativeRights_ServerParameter).
Public property | ServersConfiguration | Provides access to the property representing the right to administer server configuration (use TPropertyEnum.AdministrativeRights_ServersConfiguration).
Public property | SessionManagerServerConfiguration | Provides access to the property representing the SessionManagerServerConfiguration administrative right for this user (use TPropertyEnum.AdministrativeRights_SessionManagerServerConfiguration).
Public property | SingleSignOnIdentityProviders | Provides access to the property representing the right to administer Single Sign On Identity Providers (use TPropertyEnum.AdministrativeRights_SingleSignOnIdentityProviders).
Public property | SingleSignOnSecureTokenServer | Provides access to the property representing the right to administer the Single Sign On Secure Token Server (use TPropertyEnum.AdministrativeRights_SingleSignOnSecureTokenServer).
Public property | SipBridge | Provides access to the property representing the right to administer Sip Bridges (use TPropertyEnum.AdministrativeRights_SipBridge).
Public property | SipProxyConfiguration | Provides access to the property representing the right to administer SIP proxy configuration (use TPropertyEnum.AdministrativeRights_SipProxyConfiguration).
Public property | Skills | Provides access to the property representing the right to administer skills (use TPropertyEnum.AdministrativeRights_Skills).
Public property | SmsBroker | Provides access to the property representing the right to administer SMS Broker (use TPropertyEnum.AdministrativeRights_SmsBroker).
Public property | SmsConfiguration | Provides access to the property representing the right to administer SMS configuration (use TPropertyEnum.AdministrativeRights_SmsConfiguration).
Public property | SpeechRecognitionConfiguration | Provides access to the property representing the right to administer speech recognition configuration (use TPropertyEnum.AdministrativeRights_SpeechRecognitionConfiguration).
Public property | StationGroups | Provides access to the property representing the right to administer station groups (use TPropertyEnum.AdministrativeRights_StationGroups).
Public property | Stations | Provides access to the property representing the right to administer stations (use TPropertyEnum.AdministrativeRights_Stations).
Public property | StationTemplates | Provides access to the property representing the right to administer station templates (use TPropertyEnum.AdministrativeRights_StationTemplates).
Public property | StatusMessages | Provides access to the property representing the right to administer status messages (use TPropertyEnum.AdministrativeRights_StatusMessages).
Public property | StreamingAudioMonitorProfiles | Provides access to the property representing the right to administer streaming audio monitor profile data (use TPropertyEnum.AdministrativeRights_StreamingAudioMonitorProfiles).
Public property | StructuredParameters | Provides access to the property representing the right to administer structured parameters (use TPropertyEnum.AdministrativeRights_StructuredParameters).
Public property | SystemConfiguration | Provides access to the property representing the right to administer the system configuration (use TPropertyEnum.AdministrativeRights_SystemConfiguration).
Public property | SystemParameters | Provides access to the property representing the right to administer system parameters (use TPropertyEnum.AdministrativeRights_SystemParameters).
Public property | Users | Provides access to the property representing the right to administer users (use TPropertyEnum.AdministrativeRights_Users).
Public property | VoiceModules | Provides access to the property representing the right to administer voice modules (use TPropertyEnum.AdministrativeRights_VoiceModules).
Public property | WebServicesConfiguration | Provides access to the property representing the right to administer Web Services configuration (use TPropertyEnum.AdministrativeRights_WebServicesConfiguration).
Public property | WebServicesParameters | Provides access to the property representing the right to administer web service parameters (use TPropertyEnum.AdministrativeRights_WebServicesParameters).
Public property | Workgroups | Provides access to the property representing the right to administer workgroups (use TPropertyEnum.AdministrativeRights_Workgroups).
Public property | WrapUpCategories | Provides access to the property representing the right to administer wrap up categories (use TPropertyEnum.AdministrativeRights_WrapUpCategories).
Public property | WrapUpCodes | Provides access to the property representing the right to administer wrap up codes (use TPropertyEnum.AdministrativeRights_WrapUpCodes).

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


UserAdministrativeRightsProperties(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


UserAdministrativeRightsProperties(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeList | Provides access to the property representing the right to administer account codes (use TPropertyEnum.AdministrativeRights_AccountCodeList).
Public property | AccumulatorList | Provides access to the property representing the right to administer accumulators (use TPropertyEnum.AdministrativeRights_AccumulatorList).
Public property | Actions | Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_Actions).
Public property | AudioSources | Provides access to the property representing the list of audio source rights for this user (use TPropertyEnum.AdministrativeRights_AudioSources).
Public property | CanEditAdministrativeRights | Provides access to the property representing the can edit administrative rights for this user (use TPropertyEnum.AdministrativeRights_CanEditAdministrativeRights).
Public property | CanPublishClientTemplates | Provides access to the property representing the right to publish client templates (use TPropertyEnum.AdministrativeRights_CanPublishClientTemplates).
Public property | ClientButtons | Provides access to the property representing the list of client button rights for this user (use TPropertyEnum.AdministrativeRights_ClientButtons).
Public property | ClientConfigurationConfiguration | Provides access to the property representing the client configurations configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_ClientConfigurationConfiguration).
Public property | ClientConfigurationTemplates | Provides access to the property representing the list of client configuration templates the user has rights to (use TPropertyEnum.AdministrativeRights_ClientConfigurationTemplates).
Public property | Collective | Provides access to the property representing the right to administer collectives for this user (use TPropertyEnum.AdministrativeRights_Collective).
Public property | ContactListSources | Provides access to the property representing the right to administer contact list sources for this user.(use TPropertyEnum.AdministrativeRights_ContactListSources).
Public property | DataManagerConfiguration | Provides access to the property representing the right to administer data manager for this user (use TPropertyEnum.AdministrativeRights_DataManagerConfiguration).
Public property | DefaultIPPhoneConfiguration | Provides access to the property representing the right to administer the default ip phone configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultIPPhoneConfiguration).
Public property | DefaultLocationConfiguration | Provides access to the property representing the right to administer the default location configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultLocationConfiguration).
Public property | DefaultStationConfiguration | Provides access to the property representing the right to administer the default station configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultStationConfiguration).
Public property | DefaultUserConfiguration | Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_DefaultUserConfiguration).
Public property | DnisMappingsConfiguration | Provides access to the property representing the dnis mappings configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_DnisMappingsConfiguration).
Public property | EFaq | Provides access to the property representing the right to administer Efaq's for this user.(use TPropertyEnum.AdministrativeRights_EFaq).
Public property | FaxConfiguration | Provides access to the property representing the right to administer fax configuration (use TPropertyEnum.AdministrativeRights_FaxConfiguration).
Public property | FaxGroups | Provides access to the property representing the right to administer fax groups for this user. TPropertyEnum.AdministrativeRights_FaxGroups).
Public property | Handlers | Provides access to the property representing the right to administer handlers for this user.(use TPropertyEnum.AdministrativeRights_Handlers).
Public property | ICDataSources | Provides access to the property representing the right to administer IC Datasources for this users.(use TPropertyEnum.AdministrativeRights_ICDataSources).
Public property | ImageResources | Provides access to the property representing the image resources administrative right for this user (use TPropertyEnum.AdministrativeRights_ImageResources).
Public property | InitializationFunctions | Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_InitializationFunctions).
Public property | InteractionAnalyzerKeywordSets | Provides access to the property representing the right to administer interaction analyzer keyword sets for this user (use TPropertyEnum.AdministrativeRights_InteractionAnalyzerKeywordSets).
Public property | InteractionConferenceConfiguration | Provides access to the property representing the right to administer an interaction conference for this user (use TPropertyEnum.AdministrativeRights_InteractionConferenceConfiguration).
Public property | InteractionConferenceRooms | Provides access to the property representing the right to administer interaction conference rooms for this user (use TPropertyEnum.AdministrativeRights_InteractionConferenceRooms).
Public property | InteractionDialerCallLists | Provides access to the property representing the list of Dialer Call List rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerCallLists).
Public property | InteractionDialerCampaigns | Provides access to the property representing the list of campaign rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerCampaigns).
Public property | InteractionDialerConfiguration | Provides access to the property representing the list of dialer configuration rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerConfiguration).
Public property | InteractionDialerPolicySets | Provides access to the property representing the list of dialer policy sets for this user (use TPropertyEnum.AdministrativeRights_PolicySets).
Public property | InteractionDialerRuleSets | Provides access to the property representing the list of dialer rule sets for this user (use TPropertyEnum.AdministrativeRights_RuleSets).
Public property | InteractionDialerSchedules | Provides access to the property representing the list of dialer schedule rights for this user (use TPropertyEnum.AdministrativeRights_DialerSchedules).
Public property | InteractionDialerScripts | Provides access to the property representing the right to administer scripts (use TPropertyEnum.AdministrativeRights_Scripts).
Public property | InteractionDialerSkillSets | Provides access to the property representing the right to administer skill sets (use TPropertyEnum.AdministrativeRights_SkillSets).
Public property | InteractionDialerStageSets | Provides access to the property representing the right to administer stage sets (use TPropertyEnum.AdministrativeRights_StageSets).
Public property | InteractionDialerZoneSets | Provides access to the property representing the right to administer zone sets (use TPropertyEnum.AdministrativeRights_ZoneSets).
Public property | InteractionFeedbackConfiguration | Provides access to the property representing the right to administer interaction feedback configuration (use TPropertyEnum.AdministrativeRights_InteractionFeedbackConfiguration).
Public property | InteractionOptimizerActivityTypesConfiguration | Obsolete. Provides access to the property representing the right to configure interaction optimizer activity types (use TPropertyEnum.AdministrativeRights_InteractionOptimizerActivityTypesConfiguration).
Public property | InteractionOptimizerAdvancedConfiguration | Provides access to the property representing the right to administer interaction optimizer advanced configuration (use TPropertyEnum.AdministrativeRights_InteractionOptimizerAdvancedConfiguration).
Public property | InteractionOptimizerAgentsConfiguration | Provides access to the property representing the right to administer interaction optimizer agents configuration (use TPropertyEnum.AdministrativeRights_InteractionOptimizerAgentsConfiguration).
Public property | InteractionOptimizerDayClassificationsConfiguration | Obsolete. Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_InteractionOptimizerDayClassificationsConfiguration).
Public property | InteractionOptimizerForecastsAndSchedulesConfiguration | Obsolete. Provides access to the property representing the right to administer interaction optimizer forecasts and schedules (use TPropertyEnum.AdministrativeRights_InteractionOptimizerForecastsAndSchedulesConfiguration).
Public property | InteractionOptimizerSchedulingUnits | Obsolete. Provides access to the property representing the right to administer interaction optimizer scheduling units (use TPropertyEnum.AdministrativeRights_InteractionOptimizerSchedulingUnits).
Public property | InteractionProcessAutomation | Provides access to the property representing the InteractionProcessAutomation administrative right for this user (use TPropertyEnum.AdministrativeRights_InteractionProcessAutomation).
Public property | InteractionProcessorTables | Provides access to the property representing the right to administer interaction processor tables (use TPropertyEnum.AdministrativeRights_InteractionProcessorTables).
Public property | InteractionRecorderConfiguration | Provides access to the property representing the right to administer interaction recorder configuration (use TPropertyEnum.AdministrativeRights_InteractionRecorderConfiguration).
Public property | InteractionTrackerConfiguration | Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_InteractionTrackerConfiguration).
Public property | IPPhoneRegistrationGroups | Provides access to the property representing the right to administer IP phone registration groups (use TPropertyEnum.AdministrativeRights_IPPhoneRegistrationGroups).
Public property | IPPhoneRingSets | Provides access to the property representing the right to administer IP phone ring sets (use TPropertyEnum.AdministrativeRights_IPPhoneRingSets).
Public property | IPPhones | Provides access to the property representing the right to administer IP phones (use TPropertyEnum.AdministrativeRights_IPPhones).
Public property | IPPhoneTemplates | Provides access to the property representing the right to administer IP phone templates (use TPropertyEnum.AdministrativeRights_IPPhoneTemplates).
Public property | Layouts | Provides access to the property representing the right to administer layouts (use TPropertyEnum.AdministrativeRights_Layouts).
Public property | LicensesAllocationConfiguration | Provides access to the property representing the right to administer License allocation configuration (use TPropertyEnum.AdministrativeRights_LicensesAllocationConfiguration).
Public property | LineGroups | Provides access to the property representing the right to configure line groups. (use TPropertyEnum.AdministrativeRights_LineGroups).
Public property | Lines | Provides access to the property representing the right to administer Lines (use TPropertyEnum.AdministrativeRights_Lines).
Public property | Locations | Provides access to the property representing the right to administer locations (use TPropertyEnum.AdministrativeRights_Locations).
Public property | LogRetrievalAssistantConfiguration | Provides access to the property representing the right to administer the log retrieval assistant configuration (use TPropertyEnum.AdministrativeRights_LogRetrievalAssistantConfiguration).
Public property | MailConfiguration | Provides access to the property representing the right to administer mail configuration (use TPropertyEnum.AdministrativeRights_MailConfiguration).
Public property | MasterAdministrator | Provides read-only access to the property representing the master administrator configuration rights (use TPropertyEnum.AdministrativeRights_MasterAdministrator).
Public property | MediaServersConfiguration | Provides access to the property representing the right to administer media server configurations (use TPropertyEnum.AdministrativeRights_MediaServersConfiguration).
Public property | MrcpConfiguration | Provides access to the property representing the right to administer MRCP configuration (use TPropertyEnum.AdministrativeRights_MRCPConfiguration).
Public property | MrcpServerList | Provides access to the property representing the list of MRCP server administrative rights for this user (use TPropertyEnum.AdministrativeRights_MrcpServerList).
Public property | OcsActiveDirectories | Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_OCSActiveDirectories).
Public property | OcsConfiguration | Provides access to the property representing the right to administer OCS configuration (use TPropertyEnum.AdministrativeRights_OCSConfiguration).
Public property | OcsStatusMessages | Provides access to the property representing the right to administer OCS status messages (use TPropertyEnum.AdministrativeRights_OCSStatusMessages).
Public property | PagingCarriers | Provides access to the property representing the right to administer paging carriers (use TPropertyEnum.AdministrativeRights_PagingCarriers).
Public property | PasswordPolicies | Provides access to the property representing the right to administer password policies (use TPropertyEnum.AdministrativeRights_PasswordPolicies).
Public property | PasswordPoliciesConfiguration | Provides access to the property representing the right to administer password policy configuration (use TPropertyEnum.AdministrativeRights_PasswordPoliciesConfiguration).
Public property | PeerSitesConfiguration | Provides access to the property representing the right to administer peer site configuration (use TPropertyEnum.AdministrativeRights_PeerSitesConfiguration).
Public property | PhoneNumbersConfiguration | Provides access to the property representing the list account codes administrative right for this user (use TPropertyEnum.AdministrativeRights_PhoneNumbersConfiguration).
Public property | Positions | Provides access to the property representing the right to administer positions (use TPropertyEnum.AdministrativeRights_Positions).
Public property | ProblemReporterConfiguration | Provides access to the property representing the problem reporter configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_ProblemReporterConfiguration).
Public property | QueueControlColumns | Provides access to the property representing the QueueControlColumns administrative right for this user (use TPropertyEnum.AdministrativeRights_QueueControlColumns).
Public property | ReportLogs | Provides access to the property representing the right to administer report logs (use TPropertyEnum.AdministrativeRights_ReportLogs).
Public property | Reports | Provides access to the property representing the right to administer reports (use TPropertyEnum.AdministrativeRights_Reports).
Public property | ResponseManagement | Provides access to the property representing the right to administer response management (use TPropertyEnum.AdministrativeRights_ResponseManagement).
Public property | Roles | Provides access to the property representing the right to administer Roles(use TPropertyEnum.AdministrativeRights_Roles).
Public property | SalesforceCtis | Provides access to the property representing the SalesforceCtis administrative right for this user (use TPropertyEnum.AdministrativeRights_SalesforceCtis).
Public property | SametimeConfiguration | Provides access to the property representing the SametimeConfiguration administrative right for this user (use TPropertyEnum.AdministrativeRights_SametimeConfiguration).
Public property | Schedules | Provides access to the property representing the right to administer schedules (use TPropertyEnum.AdministrativeRights_Schedules).
Public property | SecureInputForms | Provides access to the property representing the right to administer secure input forms (use TPropertyEnum.AdministrativeRights_SecureInputForms).
Public property | SelectionRuleList | Provides access to the property representing the right to administer selection rules (use TPropertyEnum.AdministrativeRights_SelectionRuleList).
Public property | ServerParameter | Provides access to the property representing the right to administer server parameters (use TPropertyEnum.AdministrativeRights_ServerParameter).
Public property | ServersConfiguration | Provides access to the property representing the right to administer server configuration (use TPropertyEnum.AdministrativeRights_ServersConfiguration).
Public property | SessionManagerServerConfiguration | Provides access to the property representing the SessionManagerServerConfiguration administrative right for this user (use TPropertyEnum.AdministrativeRights_SessionManagerServerConfiguration).
Public property | SingleSignOnIdentityProviders | Provides access to the property representing the right to administer Single Sign On Identity Providers (use TPropertyEnum.AdministrativeRights_SingleSignOnIdentityProviders).
Public property | SingleSignOnSecureTokenServer | Provides access to the property representing the right to administer the Single Sign On Secure Token Server (use TPropertyEnum.AdministrativeRights_SingleSignOnSecureTokenServer).
Public property | SipBridge | Provides access to the property representing the right to administer Sip Bridges (use TPropertyEnum.AdministrativeRights_SipBridge).
Public property | SipProxyConfiguration | Provides access to the property representing the right to administer SIP proxy configuration (use TPropertyEnum.AdministrativeRights_SipProxyConfiguration).
Public property | Skills | Provides access to the property representing the right to administer skills (use TPropertyEnum.AdministrativeRights_Skills).
Public property | SmsBroker | Provides access to the property representing the right to administer SMS Broker (use TPropertyEnum.AdministrativeRights_SmsBroker).
Public property | SmsConfiguration | Provides access to the property representing the right to administer SMS configuration (use TPropertyEnum.AdministrativeRights_SmsConfiguration).
Public property | SpeechRecognitionConfiguration | Provides access to the property representing the right to administer speech recognition configuration (use TPropertyEnum.AdministrativeRights_SpeechRecognitionConfiguration).
Public property | StationGroups | Provides access to the property representing the right to administer station groups (use TPropertyEnum.AdministrativeRights_StationGroups).
Public property | Stations | Provides access to the property representing the right to administer stations (use TPropertyEnum.AdministrativeRights_Stations).
Public property | StationTemplates | Provides access to the property representing the right to administer station templates (use TPropertyEnum.AdministrativeRights_StationTemplates).
Public property | StatusMessages | Provides access to the property representing the right to administer status messages (use TPropertyEnum.AdministrativeRights_StatusMessages).
Public property | StreamingAudioMonitorProfiles | Provides access to the property representing the right to administer streaming audio monitor profile data (use TPropertyEnum.AdministrativeRights_StreamingAudioMonitorProfiles).
Public property | StructuredParameters | Provides access to the property representing the right to administer structured parameters (use TPropertyEnum.AdministrativeRights_StructuredParameters).
Public property | SystemConfiguration | Provides access to the property representing the right to administer the system configuration (use TPropertyEnum.AdministrativeRights_SystemConfiguration).
Public property | SystemParameters | Provides access to the property representing the right to administer system parameters (use TPropertyEnum.AdministrativeRights_SystemParameters).
Public property | Users | Provides access to the property representing the right to administer users (use TPropertyEnum.AdministrativeRights_Users).
Public property | VoiceModules | Provides access to the property representing the right to administer voice modules (use TPropertyEnum.AdministrativeRights_VoiceModules).
Public property | WebServicesConfiguration | Provides access to the property representing the right to administer Web Services configuration (use TPropertyEnum.AdministrativeRights_WebServicesConfiguration).
Public property | WebServicesParameters | Provides access to the property representing the right to administer web service parameters (use TPropertyEnum.AdministrativeRights_WebServicesParameters).
Public property | Workgroups | Provides access to the property representing the right to administer workgroups (use TPropertyEnum.AdministrativeRights_Workgroups).
Public property | WrapUpCategories | Provides access to the property representing the right to administer wrap up categories (use TPropertyEnum.AdministrativeRights_WrapUpCategories).
Public property | WrapUpCodes | Provides access to the property representing the right to administer wrap up codes (use TPropertyEnum.AdministrativeRights_WrapUpCodes).

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


AccountCodeList Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccountCodeList Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer account codes (use TPropertyEnum.AdministrativeRights_AccountCodeList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> AccountCodeList { get; }
Visual Basic
Public ReadOnly Property AccountCodeList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of account codes that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AccountCodeConfiguration..::..Rights..::..Admin


AccumulatorList Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccumulatorList Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer accumulators (use TPropertyEnum.AdministrativeRights_AccumulatorList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> AccumulatorList { get; }
Visual Basic
Public ReadOnly Property AccumulatorList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of accumulators that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AccumulatorConfiguration..::..Rights..::..Admin


Actions Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Actions Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_Actions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Actions { get; }
Visual Basic
Public ReadOnly Property Actions As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of actions that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ActionConfiguration..::..Rights..::..Admin


AudioSources Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AudioSources Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of audio source rights for this user (use TPropertyEnum.AdministrativeRights_AudioSources).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> AudioSources { get; }
Visual Basic
Public ReadOnly Property AudioSources As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of audio sources that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AudioSourceConfiguration..::..Rights..::..Admin


CanEditAdministrativeRights Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanEditAdministrativeRights Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the can edit administrative rights for this user (use TPropertyEnum.AdministrativeRights_CanEditAdministrativeRights).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanEditAdministrativeRights { get; }
Visual Basic
Public ReadOnly Property CanEditAdministrativeRights As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the can edit administrative rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanPublishClientTemplates Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanPublishClientTemplates Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to publish client templates (use TPropertyEnum.AdministrativeRights_CanPublishClientTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanPublishClientTemplates { get; }
Visual Basic
Public ReadOnly Property CanPublishClientTemplates As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the right to publish client templates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ClientButtons Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientButtons Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of client button rights for this user (use TPropertyEnum.AdministrativeRights_ClientButtons).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ClientButtons { get; }
Visual Basic
Public ReadOnly Property ClientButtons As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of client buttons that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
CustomButtonConfiguration..::..Rights..::..Admin


ClientConfigurationConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientConfigurationConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the client configurations configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_ClientConfigurationConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ClientConfigurationConfiguration { get; }
Visual Basic
Public ReadOnly Property ClientConfigurationConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer client configuration configurations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplates Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ClientConfigurationTemplates Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of client configuration templates the user has rights to (use TPropertyEnum.AdministrativeRights_ClientConfigurationTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ClientConfigurationTemplates { get; }
Visual Basic
Public ReadOnly Property ClientConfigurationTemplates As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of client configuration templates that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ClientConfigurationTemplateConfiguration..::..Rights..::..Admin


Collective Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Collective Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer collectives for this user (use TPropertyEnum.AdministrativeRights_Collective).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> Collective { get; }
Visual Basic
Public ReadOnly Property Collective As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer a collective.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ContactListSources Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ContactListSources Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer contact list sources for this user.(use TPropertyEnum.AdministrativeRights_ContactListSources).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ContactListSources { get; }
Visual Basic
Public ReadOnly Property ContactListSources As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of contact list sources that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ContactListSourceConfiguration..::..Rights..::..Admin


DataManagerConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DataManagerConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer data manager for this user (use TPropertyEnum.AdministrativeRights_DataManagerConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DataManagerConfiguration { get; }
Visual Basic
Public ReadOnly Property DataManagerConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer data manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DefaultIPPhoneConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultIPPhoneConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer the default ip phone configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultIPPhoneConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DefaultIPPhoneConfiguration { get; }
Visual Basic
Public ReadOnly Property DefaultIPPhoneConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer the default ip phone configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DefaultLocationConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultLocationConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer the default location configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultLocationConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DefaultLocationConfiguration { get; }
Visual Basic
Public ReadOnly Property DefaultLocationConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer the default location configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DefaultStationConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultStationConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer the default station configuration for this user.(use TPropertyEnum.AdministrativeRights_DefaultStationConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DefaultStationConfiguration { get; }
Visual Basic
Public ReadOnly Property DefaultStationConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer the default station configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
DefaultStationConfiguration..::..Rights..::..Admin


DefaultUserConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DefaultUserConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_DefaultUserConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DefaultUserConfiguration { get; }
Visual Basic
Public ReadOnly Property DefaultUserConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer the default user configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
DefaultUserConfiguration..::..Rights..::..Admin


DnisMappingsConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DnisMappingsConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the dnis mappings configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_DnisMappingsConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DnisMappingsConfiguration { get; }
Visual Basic
Public ReadOnly Property DnisMappingsConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer the dnis mappings configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
DefaultUserConfiguration..::..Rights..::..Admin


EFaq Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..EFaq Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer Efaq's for this user.(use TPropertyEnum.AdministrativeRights_EFaq).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> EFaq { get; }
Visual Basic
Public ReadOnly Property EFaq As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of EFaq's that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
EFaqConfiguration..::..Rights..::..Admin


FaxConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FaxConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer fax configuration (use TPropertyEnum.AdministrativeRights_FaxConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> FaxConfiguration { get; }
Visual Basic
Public ReadOnly Property FaxConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer fax configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FaxGroups Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FaxGroups Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer fax groups for this user. TPropertyEnum.AdministrativeRights_FaxGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> FaxGroups { get; }
Visual Basic
Public ReadOnly Property FaxGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of fax groups that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
FaxGroupConfiguration..::..Rights..::..Admin


Handlers Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Handlers Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer handlers for this user.(use TPropertyEnum.AdministrativeRights_Handlers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Handlers { get; }
Visual Basic
Public ReadOnly Property Handlers As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of handlers that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
HandlerConfiguration..::..Rights..::..Admin


ICDataSources Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ICDataSources Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer IC Datasources for this users.(use TPropertyEnum.AdministrativeRights_ICDataSources).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ICDataSources { get; }
Visual Basic
Public ReadOnly Property ICDataSources As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of IC data sources that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ImageResources Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ImageResources Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the image resources administrative right for this user (use TPropertyEnum.AdministrativeRights_ImageResources).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ImageResources { get; }
Visual Basic
Public ReadOnly Property ImageResources As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of image resources that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
InitializationFunctionConfiguration..::..Rights..::..Admin


InitializationFunctions Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InitializationFunctions Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_InitializationFunctions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InitializationFunctions { get; }
Visual Basic
Public ReadOnly Property InitializationFunctions As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of initialization functions that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
InitializationFunctionConfiguration..::..Rights..::..Admin


InteractionAnalyzerKeywordSets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionAnalyzerKeywordSets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction analyzer keyword sets for this user (use TPropertyEnum.AdministrativeRights_InteractionAnalyzerKeywordSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionAnalyzerKeywordSets { get; }
Visual Basic
Public ReadOnly Property InteractionAnalyzerKeywordSets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of interaction analyzer keyword sets that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
AnalyzerKeywordSetConfiguration..::..Rights..::..Admin


InteractionConferenceConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionConferenceConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer an interaction conference for this user (use TPropertyEnum.AdministrativeRights_InteractionConferenceConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionConferenceConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionConferenceConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction conference configurations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionConferenceRooms Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionConferenceRooms Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction conference rooms for this user (use TPropertyEnum.AdministrativeRights_InteractionConferenceRooms).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionConferenceRooms { get; }
Visual Basic
Public ReadOnly Property InteractionConferenceRooms As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of interaction conference rooms that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
InteractionConferenceRoomConfiguration..::..Rights..::..Admin


InteractionDialerCallLists Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerCallLists Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of Dialer Call List rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerCallLists).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerCallLists { get; }
Visual Basic
Public ReadOnly Property InteractionDialerCallLists As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of Call Lists that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerCampaigns Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerCampaigns Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of campaign rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerCampaigns).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerCampaigns { get; }
Visual Basic
Public ReadOnly Property InteractionDialerCampaigns As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of campaigns that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of dialer configuration rights for this user (use TPropertyEnum.AdministrativeRights_InteractionDialerConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionDialerConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionDialerConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the list of dialer configuration rights that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding the object associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerPolicySets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerPolicySets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of dialer policy sets for this user (use TPropertyEnum.AdministrativeRights_PolicySets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerPolicySets { get; }
Visual Basic
Public ReadOnly Property InteractionDialerPolicySets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of dialer policy sets that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerRuleSets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerRuleSets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of dialer rule sets for this user (use TPropertyEnum.AdministrativeRights_RuleSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerRuleSets { get; }
Visual Basic
Public ReadOnly Property InteractionDialerRuleSets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of dialer rule sets that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerSchedules Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerSchedules Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of dialer schedule rights for this user (use TPropertyEnum.AdministrativeRights_DialerSchedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerSchedules { get; }
Visual Basic
Public ReadOnly Property InteractionDialerSchedules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of dialer schedules that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerScripts Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerScripts Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer scripts (use TPropertyEnum.AdministrativeRights_Scripts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerScripts { get; }
Visual Basic
Public ReadOnly Property InteractionDialerScripts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of scripts that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerSkillSets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerSkillSets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer skill sets (use TPropertyEnum.AdministrativeRights_SkillSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerSkillSets { get; }
Visual Basic
Public ReadOnly Property InteractionDialerSkillSets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of skill sets that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerStageSets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerStageSets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer stage sets (use TPropertyEnum.AdministrativeRights_StageSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerStageSets { get; }
Visual Basic
Public ReadOnly Property InteractionDialerStageSets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of stage sets that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionDialerZoneSets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionDialerZoneSets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer zone sets (use TPropertyEnum.AdministrativeRights_ZoneSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionDialerZoneSets { get; }
Visual Basic
Public ReadOnly Property InteractionDialerZoneSets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of zone sets that may be administered.

Remarks

The ININ.IceLib.Dialer.dll assembly contains a matching configuration class in the ININ.IceLib.Configuration.Dialer namespace for finding objects associated with this right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionFeedbackConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionFeedbackConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction feedback configuration (use TPropertyEnum.AdministrativeRights_InteractionFeedbackConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionFeedbackConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionFeedbackConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction feedback configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
FeedbackSurveyConfiguration..::..Rights..::..Admin


InteractionOptimizerActivityTypesConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionOptimizerActivityTypesConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to configure interaction optimizer activity types (use TPropertyEnum.AdministrativeRights_InteractionOptimizerActivityTypesConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionOptimizerActivityTypesConfiguration is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")]
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionOptimizerActivityTypesConfiguration { get; }
Visual Basic
<ObsoleteAttribute("InteractionOptimizerActivityTypesConfiguration is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")> _
Public ReadOnly Property InteractionOptimizerActivityTypesConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction optimizer activity types configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionOptimizerAdvancedConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionOptimizerAdvancedConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction optimizer advanced configuration (use TPropertyEnum.AdministrativeRights_InteractionOptimizerAdvancedConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionOptimizerAdvancedConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionOptimizerAdvancedConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction optimizer advanced configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionOptimizerAgentsConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionOptimizerAgentsConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction optimizer agents configuration (use TPropertyEnum.AdministrativeRights_InteractionOptimizerAgentsConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionOptimizerAgentsConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionOptimizerAgentsConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction optimizer agent configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionOptimizerDayClassificationsConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionOptimizerDayClassificationsConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list actions administrative right for this user (use TPropertyEnum.AdministrativeRights_InteractionOptimizerDayClassificationsConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionOptimizerDayClassificationsConfiguration is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")]
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionOptimizerDayClassificationsConfiguration { get; }
Visual Basic
<ObsoleteAttribute("InteractionOptimizerDayClassificationsConfiguration is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")> _
Public ReadOnly Property InteractionOptimizerDayClassificationsConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction optimizer day classifications configurations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionOptimizerForecastsAndSchedulesConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionOptimizerForecastsAndSchedulesConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction optimizer forecasts and schedules (use TPropertyEnum.AdministrativeRights_InteractionOptimizerForecastsAndSchedulesConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionOptimizerForecastsAndSchedulesConfiguration is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")]
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionOptimizerForecastsAndSchedulesConfiguration { get; }
Visual Basic
<ObsoleteAttribute("InteractionOptimizerForecastsAndSchedulesConfiguration is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")> _
Public ReadOnly Property InteractionOptimizerForecastsAndSchedulesConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction optimizer forecasts and schedules configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionOptimizerSchedulingUnits Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionOptimizerSchedulingUnits Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction optimizer scheduling units (use TPropertyEnum.AdministrativeRights_InteractionOptimizerSchedulingUnits).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionOptimizerSchedulingUnits is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")]
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionOptimizerSchedulingUnits { get; }
Visual Basic
<ObsoleteAttribute("InteractionOptimizerSchedulingUnits is obsolete. Please use IC Business Manager to configure Interaction Optimizer.")> _
Public ReadOnly Property InteractionOptimizerSchedulingUnits As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of interaction optimizer scheduling units that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


InteractionProcessAutomation Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionProcessAutomation Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the InteractionProcessAutomation administrative right for this user (use TPropertyEnum.AdministrativeRights_InteractionProcessAutomation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionProcessAutomation { get; }
Visual Basic
Public ReadOnly Property InteractionProcessAutomation As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the InteractionProcessAutomation administrative right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ProcessConfiguration..::..Rights..::..Admin


InteractionProcessorTables Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionProcessorTables Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction processor tables (use TPropertyEnum.AdministrativeRights_InteractionProcessorTables).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> InteractionProcessorTables { get; }
Visual Basic
Public ReadOnly Property InteractionProcessorTables As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of interaction processor tables that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
InteractionProcessorTableConfiguration..::..Rights..::..Admin


InteractionRecorderConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionRecorderConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer interaction recorder configuration (use TPropertyEnum.AdministrativeRights_InteractionRecorderConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionRecorderConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionRecorderConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction recorder configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
RecorderConfiguration..::..Rights..::..Admin


InteractionTrackerConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionTrackerConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_InteractionTrackerConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> InteractionTrackerConfiguration { get; }
Visual Basic
Public ReadOnly Property InteractionTrackerConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer interaction tracker configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IPPhoneRegistrationGroups Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IPPhoneRegistrationGroups Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer IP phone registration groups (use TPropertyEnum.AdministrativeRights_IPPhoneRegistrationGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> IPPhoneRegistrationGroups { get; }
Visual Basic
Public ReadOnly Property IPPhoneRegistrationGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of IP phone registration groups that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IPPhoneRingSets Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IPPhoneRingSets Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer IP phone ring sets (use TPropertyEnum.AdministrativeRights_IPPhoneRingSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> IPPhoneRingSets { get; }
Visual Basic
Public ReadOnly Property IPPhoneRingSets As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of IP phone ring sets that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IPPhones Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IPPhones Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer IP phones (use TPropertyEnum.AdministrativeRights_IPPhones).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> IPPhones { get; }
Visual Basic
Public ReadOnly Property IPPhones As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of IP phones that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IPPhoneTemplates Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IPPhoneTemplates Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer IP phone templates (use TPropertyEnum.AdministrativeRights_IPPhoneTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> IPPhoneTemplates { get; }
Visual Basic
Public ReadOnly Property IPPhoneTemplates As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of IP phone templates that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Layouts Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Layouts Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer layouts (use TPropertyEnum.AdministrativeRights_Layouts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Layouts { get; }
Visual Basic
Public ReadOnly Property Layouts As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of layouts that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LayoutConfiguration..::..Rights..::..Admin


LicensesAllocationConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LicensesAllocationConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer License allocation configuration (use TPropertyEnum.AdministrativeRights_LicensesAllocationConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> LicensesAllocationConfiguration { get; }
Visual Basic
Public ReadOnly Property LicensesAllocationConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer the license allocation configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
FeatureLicenseConfiguration..::..Rights..::..Admin
LicenseAllocationConfiguration..::..Rights..::..Admin


LineGroups Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LineGroups Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to configure line groups. (use TPropertyEnum.AdministrativeRights_LineGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> LineGroups { get; }
Visual Basic
Public ReadOnly Property LineGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of line groups that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WebServicesParameterConfiguration..::..Rights..::..Admin


Lines Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Lines Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer Lines (use TPropertyEnum.AdministrativeRights_Lines).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Lines { get; }
Visual Basic
Public ReadOnly Property Lines As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of lines that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LineConfiguration..::..Rights..::..Admin


Locations Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Locations Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer locations (use TPropertyEnum.AdministrativeRights_Locations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Locations { get; }
Visual Basic
Public ReadOnly Property Locations As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of locations that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LocationConfiguration..::..Rights..::..Admin


LogRetrievalAssistantConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LogRetrievalAssistantConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer the log retrieval assistant configuration (use TPropertyEnum.AdministrativeRights_LogRetrievalAssistantConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> LogRetrievalAssistantConfiguration { get; }
Visual Basic
Public ReadOnly Property LogRetrievalAssistantConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer log retrieval assistant configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MailConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MailConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer mail configuration (use TPropertyEnum.AdministrativeRights_MailConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> MailConfiguration { get; }
Visual Basic
Public ReadOnly Property MailConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer mail configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MasterAdministrator Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MasterAdministrator Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides read-only access to the property representing the master administrator configuration rights (use TPropertyEnum.AdministrativeRights_MasterAdministrator).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> MasterAdministrator { get; }
Visual Basic
Public ReadOnly Property MasterAdministrator As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the master administer configuration right.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MediaServersConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MediaServersConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer media server configurations (use TPropertyEnum.AdministrativeRights_MediaServersConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> MediaServersConfiguration { get; }
Visual Basic
Public ReadOnly Property MediaServersConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer media server configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MrcpConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MrcpConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer MRCP configuration (use TPropertyEnum.AdministrativeRights_MRCPConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> MrcpConfiguration { get; }
Visual Basic
Public ReadOnly Property MrcpConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer MRCP configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MrcpServerList Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MrcpServerList Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of MRCP server administrative rights for this user (use TPropertyEnum.AdministrativeRights_MrcpServerList).

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> MrcpServerList { get; }
Visual Basic
Public ReadOnly Property MrcpServerList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of MRCP servers that may be administered.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


OcsActiveDirectories Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OcsActiveDirectories Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list of action administrative rights for this user (use TPropertyEnum.AdministrativeRights_OCSActiveDirectories).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> OcsActiveDirectories { get; }
Visual Basic
Public ReadOnly Property OcsActiveDirectories As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of OCS active directories that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights..::..Admin


OcsConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OcsConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer OCS configuration (use TPropertyEnum.AdministrativeRights_OCSConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> OcsConfiguration { get; }
Visual Basic
Public ReadOnly Property OcsConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer OCS configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


OcsStatusMessages Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OcsStatusMessages Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer OCS status messages (use TPropertyEnum.AdministrativeRights_OCSStatusMessages).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> OcsStatusMessages { get; }
Visual Basic
Public ReadOnly Property OcsStatusMessages As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of OCS status messages that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
OfficeCommunicationServerStatusMessageConfiguration..::..Rights..::..Admin


PagingCarriers Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PagingCarriers Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer paging carriers (use TPropertyEnum.AdministrativeRights_PagingCarriers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PagingCarriers { get; }
Visual Basic
Public ReadOnly Property PagingCarriers As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of paging carriers that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PagingCarrierConfiguration..::..Rights..::..Admin


PasswordPolicies Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PasswordPolicies Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer password policies (use TPropertyEnum.AdministrativeRights_PasswordPolicies).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> PasswordPolicies { get; }
Visual Basic
Public ReadOnly Property PasswordPolicies As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of password policies that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PasswordPolicyConfiguration..::..Rights..::..Admin


PasswordPoliciesConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PasswordPoliciesConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer password policy configuration (use TPropertyEnum.AdministrativeRights_PasswordPoliciesConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> PasswordPoliciesConfiguration { get; }
Visual Basic
Public ReadOnly Property PasswordPoliciesConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer password policy configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PeerSitesConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PeerSitesConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer peer site configuration (use TPropertyEnum.AdministrativeRights_PeerSitesConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> PeerSitesConfiguration { get; }
Visual Basic
Public ReadOnly Property PeerSitesConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer peer site configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SiteConfiguration..::..Rights..::..Admin


PhoneNumbersConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PhoneNumbersConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the list account codes administrative right for this user (use TPropertyEnum.AdministrativeRights_PhoneNumbersConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> PhoneNumbersConfiguration { get; }
Visual Basic
Public ReadOnly Property PhoneNumbersConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer phone number configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Positions Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Positions Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer positions (use TPropertyEnum.AdministrativeRights_Positions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Positions { get; }
Visual Basic
Public ReadOnly Property Positions As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of positions that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
PositionConfiguration..::..Rights..::..Admin


ProblemReporterConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ProblemReporterConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the problem reporter configuration administrative right for this user (use TPropertyEnum.AdministrativeRights_ProblemReporterConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ProblemReporterConfiguration { get; }
Visual Basic
Public ReadOnly Property ProblemReporterConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer problem reporter configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


QueueControlColumns Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..QueueControlColumns Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the QueueControlColumns administrative right for this user (use TPropertyEnum.AdministrativeRights_QueueControlColumns).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> QueueControlColumns { get; }
Visual Basic
Public ReadOnly Property QueueControlColumns As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the QueueControlColumns administrative right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
QueueColumnConfiguration..::..Rights..::..Admin


ReportLogs Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ReportLogs Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer report logs (use TPropertyEnum.AdministrativeRights_ReportLogs).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ReportLogs { get; }
Visual Basic
Public ReadOnly Property ReportLogs As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of report logs that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ReportLogConfiguration..::..Rights..::..Admin


Reports Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Reports Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer reports (use TPropertyEnum.AdministrativeRights_Reports).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Reports { get; }
Visual Basic
Public ReadOnly Property Reports As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of reports that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
LegacyHistoricalReportConfiguration..::..Rights..::..Admin


ResponseManagement Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ResponseManagement Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer response management (use TPropertyEnum.AdministrativeRights_ResponseManagement).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ResponseManagement { get; }
Visual Basic
Public ReadOnly Property ResponseManagement As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of response management messages that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ResponseManagementDocumentConfiguration..::..Rights..::..Admin


Roles Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Roles Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer Roles(use TPropertyEnum.AdministrativeRights_Roles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Roles { get; }
Visual Basic
Public ReadOnly Property Roles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of roles that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
RoleConfiguration..::..Rights..::..Admin


SalesforceCtis Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SalesforceCtis Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SalesforceCtis administrative right for this user (use TPropertyEnum.AdministrativeRights_SalesforceCtis).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SalesforceCtis { get; }
Visual Basic
Public ReadOnly Property SalesforceCtis As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SalesforceCtis administrative right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SametimeConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SametimeConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SametimeConfiguration administrative right for this user (use TPropertyEnum.AdministrativeRights_SametimeConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SametimeConfiguration { get; }
Visual Basic
Public ReadOnly Property SametimeConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the SametimeConfiguration administrative right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Schedules Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Schedules Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer schedules (use TPropertyEnum.AdministrativeRights_Schedules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Schedules { get; }
Visual Basic
Public ReadOnly Property Schedules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of schedules that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ScheduleConfiguration..::..Rights..::..Admin


SecureInputForms Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SecureInputForms Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer secure input forms (use TPropertyEnum.AdministrativeRights_SecureInputForms).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SecureInputForms { get; }
Visual Basic
Public ReadOnly Property SecureInputForms As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the secure input forms that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SecureInputFormConfiguration..::..Rights..::..Admin


SelectionRuleList Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SelectionRuleList Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer selection rules (use TPropertyEnum.AdministrativeRights_SelectionRuleList).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SelectionRuleList { get; }
Visual Basic
Public ReadOnly Property SelectionRuleList As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SelectionRuleList that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SelectionRuleConfiguration..::..Rights..::..Admin


ServerParameter Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ServerParameter Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer server parameters (use TPropertyEnum.AdministrativeRights_ServerParameter).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> ServerParameter { get; }
Visual Basic
Public ReadOnly Property ServerParameter As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of server parameters that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ServerParameterConfiguration..::..Rights..::..Admin


ServersConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ServersConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer server configuration (use TPropertyEnum.AdministrativeRights_ServersConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ServersConfiguration { get; }
Visual Basic
Public ReadOnly Property ServersConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer server configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SessionManagerServerConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SessionManagerServerConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the SessionManagerServerConfiguration administrative right for this user (use TPropertyEnum.AdministrativeRights_SessionManagerServerConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SessionManagerServerConfiguration { get; }
Visual Basic
Public ReadOnly Property SessionManagerServerConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the SessionManagerServerConfiguration administrative right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SingleSignOnIdentityProviders Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SingleSignOnIdentityProviders Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer Single Sign On Identity Providers (use TPropertyEnum.AdministrativeRights_SingleSignOnIdentityProviders).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SingleSignOnIdentityProviders { get; }
Visual Basic
Public ReadOnly Property SingleSignOnIdentityProviders As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the Single Sign On Identity Providers that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SingleSignOnIdentityProviderConfiguration..::..Rights..::..Admin


SingleSignOnSecureTokenServer Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SingleSignOnSecureTokenServer Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer the Single Sign On Secure Token Server (use TPropertyEnum.AdministrativeRights_SingleSignOnSecureTokenServer).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SingleSignOnSecureTokenServer { get; }
Visual Basic
Public ReadOnly Property SingleSignOnSecureTokenServer As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing if the Single Sign On Secure Token Server may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SipBridge Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SipBridge Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer Sip Bridges (use TPropertyEnum.AdministrativeRights_SipBridge).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SipBridge { get; }
Visual Basic
Public ReadOnly Property SipBridge As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the SipBridge that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SipBridgeConfiguration..::..Rights..::..Admin


SipProxyConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SipProxyConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer SIP proxy configuration (use TPropertyEnum.AdministrativeRights_SipProxyConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SipProxyConfiguration { get; }
Visual Basic
Public ReadOnly Property SipProxyConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer SIP proxy configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


Skills Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Skills Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer skills (use TPropertyEnum.AdministrativeRights_Skills).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Skills { get; }
Visual Basic
Public ReadOnly Property Skills As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of skills that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SkillConfiguration..::..Rights..::..Admin


SmsBroker Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SmsBroker Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer SMS Broker (use TPropertyEnum.AdministrativeRights_SmsBroker).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SmsBroker { get; }
Visual Basic
Public ReadOnly Property SmsBroker As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of SMS Broker that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SmsBrokerConfiguration..::..Rights..::..Admin


SmsConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SmsConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer SMS configuration (use TPropertyEnum.AdministrativeRights_SmsConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SmsConfiguration { get; }
Visual Basic
Public ReadOnly Property SmsConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer SMS configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


SpeechRecognitionConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SpeechRecognitionConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer speech recognition configuration (use TPropertyEnum.AdministrativeRights_SpeechRecognitionConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SpeechRecognitionConfiguration { get; }
Visual Basic
Public ReadOnly Property SpeechRecognitionConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer speech recognition configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


StationGroups Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StationGroups Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer station groups (use TPropertyEnum.AdministrativeRights_StationGroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> StationGroups { get; }
Visual Basic
Public ReadOnly Property StationGroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of station groups that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationGroupConfiguration..::..Rights..::..Admin


Stations Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Stations Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer stations (use TPropertyEnum.AdministrativeRights_Stations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Stations { get; }
Visual Basic
Public ReadOnly Property Stations As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of stations that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationConfiguration..::..Rights..::..Admin


StationTemplates Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StationTemplates Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer station templates (use TPropertyEnum.AdministrativeRights_StationTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> StationTemplates { get; }
Visual Basic
Public ReadOnly Property StationTemplates As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of station templates that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StationTemplateConfiguration..::..Rights..::..Admin


StatusMessages Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StatusMessages Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer status messages (use TPropertyEnum.AdministrativeRights_StatusMessages).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> StatusMessages { get; }
Visual Basic
Public ReadOnly Property StatusMessages As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of status messages that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StatusMessageConfiguration..::..Rights..::..Admin


StreamingAudioMonitorProfiles Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StreamingAudioMonitorProfiles Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer streaming audio monitor profile data (use TPropertyEnum.AdministrativeRights_StreamingAudioMonitorProfiles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> StreamingAudioMonitorProfiles { get; }
Visual Basic
Public ReadOnly Property StreamingAudioMonitorProfiles As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of status messages that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StreamingAudioMonitorProfileConfiguration..::..Rights..::..Admin


StructuredParameters Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..StructuredParameters Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer structured parameters (use TPropertyEnum.AdministrativeRights_StructuredParameters).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> StructuredParameters { get; }
Visual Basic
Public ReadOnly Property StructuredParameters As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of structured parameters that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
StructuredParameterConfiguration..::..Rights..::..Admin


SystemConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SystemConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer the system configuration (use TPropertyEnum.AdministrativeRights_SystemConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> SystemConfiguration { get; }
Visual Basic
Public ReadOnly Property SystemConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer system configuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SystemConfiguration..::..Rights..::..Admin


SystemParameters Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SystemParameters Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer system parameters (use TPropertyEnum.AdministrativeRights_SystemParameters).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> SystemParameters { get; }
Visual Basic
Public ReadOnly Property SystemParameters As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of system parameters that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
SystemConfiguration..::..Rights..::..Admin
SystemParameterConfiguration..::..Rights..::..Admin


Users Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Users Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer users (use TPropertyEnum.AdministrativeRights_Users).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Users { get; }
Visual Basic
Public ReadOnly Property Users As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of users that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..Rights..::..Admin


VoiceModules Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..VoiceModules Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer voice modules (use TPropertyEnum.AdministrativeRights_VoiceModules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> VoiceModules { get; }
Visual Basic
Public ReadOnly Property VoiceModules As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of voice modules that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
VoiceModuleConfiguration..::..Rights..::..Admin


WebServicesConfiguration Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WebServicesConfiguration Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer Web Services configuration (use TPropertyEnum.AdministrativeRights_WebServicesConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> WebServicesConfiguration { get; }
Visual Basic
Public ReadOnly Property WebServicesConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ability to administer Web Services configuration.

Version Information

Supported for IC Server version 2018 R1 and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


WebServicesParameters Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WebServicesParameters Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer web service parameters (use TPropertyEnum.AdministrativeRights_WebServicesParameters).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> WebServicesParameters { get; }
Visual Basic
Public ReadOnly Property WebServicesParameters As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of web service parameters that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WebServicesParameterConfiguration..::..Rights..::..Admin


Workgroups Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Workgroups Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer workgroups (use TPropertyEnum.AdministrativeRights_Workgroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of workgroups that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..Rights..::..Admin


WrapUpCategories Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WrapUpCategories Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer wrap up categories (use TPropertyEnum.AdministrativeRights_WrapUpCategories).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> WrapUpCategories { get; }
Visual Basic
Public ReadOnly Property WrapUpCategories As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of wrap up codes that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WrapUpCategoryConfiguration..::..Rights..::..Admin


WrapUpCodes Property

[image]

IceLib Technical Reference
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WrapUpCodes Property
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to administer wrap up codes (use TPropertyEnum.AdministrativeRights_WrapUpCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, Collection<GroupedConfigurationId>> WrapUpCodes { get; }
Visual Basic
Public ReadOnly Property WrapUpCodes As InheritableConfigurationProperty(Of TPropertyEnum, Collection(Of GroupedConfigurationId))
    Get

Field Value

The property representing the list of wrap up codes that may be administered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
WrapUpCodeConfiguration..::..Rights..::..Admin


UserConfiguration Class

[image]

IceLib Technical Reference
UserConfiguration Class
Members Example See Also Send Feedback
Contains configuration and administration settings for an IC User. A user defines an individual within the IC System.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserConfiguration : EditableListConfigurationObject<UserConfiguration..::..Property>
Visual Basic
Public Class UserConfiguration _
    Inherits EditableListConfigurationObject(Of UserConfiguration..::..Property)

Remarks

Setting the display name for a UserConfiguration object cannot be done using SetDisplayName(String). The display name for a UserConfiguration object can be set/retrieved from the DisplayName value.

Examples

The IceLib SDK includes example application references to the UserConfiguration class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 45, in UserRoleConfigurationViewModel.set_ConfigurationObjects
 | UserRoleConfigurationViewModel._ConfigurationObjects

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' UserConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..UserConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Members
ININ.IceLib.Configuration Namespace


UserConfiguration Members

[image] [image]

IceLib Technical Reference
UserConfiguration Members
UserConfiguration Class Methods Properties See Also Send Feedback

The UserConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified user IDs.
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified user.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetPassword | Sets the password for this session user.
Public method | SetPasswordAsync | Asynchronously sets the password for this session user.
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()() or Delete()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this user (use Property.AccessControlGroupAssignment).
Public property | AccessRights | Provides access to the various access control list properties.
Public property | AcdAgentGreeting | Provides access to the property representing whether the ACD agent greeting is active for this user (use Property.AcdAgentGreeting).
Public property | AcdAgentGreetingFile | Provides access to the property representing the ACD agent greeting file for this user (use Property.AcdAgentGreetingFile).
Public property | AdministrativeRights | Provides access to the various administrative access control list properties.
Public property | AlertOnSecurityBelowRequestedLevel | Provides access to the property representing AlertOnSecurityBelowRequestedLevel for this user (use Property.AlertOnSecurityBelowRequestedLevel).
Public property | AlertPaneAllowChange | Provides access to the property representing AlertPaneAllowChange for this user (use Property.AlertPaneAllowChange).
Public property | Alias | Provides access to the property representing the alias (or privacy name) for this user (use Property.Alias).
Public property | Analyze | Provides access to the property that determines whether or not outgoing external calls for this user are are analyzed (use Property.Analyze).
Public property | AutoAnswerAcdInteractions | Provides access to the property representing whether to auto-answer ACD interactions for this user (use Property.AutoAnswerAcdInteractions).
Public property | AutoAnswerNonAcdInteractions | Provides access to the property representing whether to auto-answer non-ACD interactions for this user (use Property.AutoAnswerNonAcdInteractions).
Public property | CallbackEnabledWorkgroups | Provides access to the read-only property representing the collection of workgroups this user is assigned to that are callback enabled (use Property.CallbackEnabledWorkgroups).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClientConfigDateLastModified | Provides access to the property representing ClientConfigDateLastModified for this user (use Property.ClientConfigDateLastModified).
Public property | ClientConfigurationTemplate | Provides access to the property representing the client configuration template for this user (use Property.ClientConfigurationTemplate).
Public property | ClientTemplates | Provides access to the read-only property representing the published client templates for this user (use Property.ClientTemplates).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConfirmDial | Provides access to the property representing ConfirmDial for this user (use Property.ConfirmDial).
Public property | ConfirmDragDrop | Provides access to the property representing ConfirmDragDrop for this user (use Property.ConfirmDragDrop).
Public property | Cost | Provides access to the property representing the ACD cost for this user (use Property.Cost).
Public property | DefaultWorkstation | Provides access to the property representing the default workstation for this user (use Property.DefaultWorkstation).
Public property | EFaqSearchOption | Provides access to the property representing EFaqSearchOption for this user (use Property.EFaqSearchOption).
Public property | EFaqSearchOptionAllowChange | Provides access to the property representing EFaqSearchOptionAllowChange for this user (use Property.EFaqSearchOptionAllowChange).
Public property | ExcludeFromDirectory | Provides access to the property representing whether to exclude the entry from the company directory for this user (use Property.ExcludeFromDirectory).
Public property | ExtCallTimeout | Provides access to the property representing ExtCallTimeout for this user (use Property.ExtCallTimeout).
Public property | ExtendedAbsencePrompt | Provides access to the property representing ExtendedAbsencePrompt for this user (use Property.ExtendedAbsencePrompt).
Public property | Extension | Provides access to the property representing the extension for this user (use Property.Extension).
Public property | FaxCapability | Provides access to the property representing the FAX capability for this user (use Property.FaxCapability).
Public property | FollowMeAllowChange | Provides access to the property representing FollowMeAllowChange for this user (use Property.FollowMeAllowChange).
Public property | HomeSite | Provides access to the property representing the home site for this user (use Property.HomeSite).
 | ICServerUMDestination | Gets the a UM destination that represents the IC server.
Public property | InteractionDisconnectedAction | Provides access to the property representing the interaction disconnected action for this user (use Property.InteractionDisconnectedAction).
Public property | InteractionMessageStoreMaxMessage | Obsolete. Provides access to the property representing the Interaction Message Store max messages for this user (use Property.InteractionMessageStoreMaxMessage).
Public property | InteractionMessageStoreMaxStorage | Obsolete. Provides access to the property representing the Interaction Message Store max storage for this user (use Property.InteractionMessageStoreMaxStorage).
Public property | InteractionOfferingAction | Provides access to the property representing the interaction offering action for this user (use Property.InteractionOfferingAction).
Public property | InteractionOfferingTimeout | Provides access to the property representing the interaction offering timeout for this user (use Property.InteractionOfferingTimeout).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | License | Provides access to the various license properties.
Public property | ListenForSipRequests | Provides access to the property representing ListenForSipRequests for this user (use Property.ListenForSipRequests).
Public property | LyncIntegrationEnabled | Provides access to the property that determines whether or not Lync Integration is enabled for this user (use Property.).
Public property | LyncLineUri | Provides access to the property representing the Lync Line URI for this user (use Property.).
Public property | LyncOption | Provides access to the property representing Lync Options for this user (use Property.).
Public property | LyncSipAddress | Provides access to the property representing the Lync SIP Address for this user (use Property.).
Public property | Mailbox | Provides access to the various mailbox properties.
Public property | MobileOfficeUser | Obsolete. Provides access to the property representing whether the user is Mobile Office enabled (use Property.MobileOfficeUser).
Public property | MuteonTransfer | Provides access to the property representing MuteonTransfer for this user (use Property.MuteonTransfer).
Public property | MwiAddress | Provides access to the property representing the MWI address for this user (use Property.MwiAddress).
Public property | MwiEnabled | Provides access to the property representing whether MWI is enabled for this user (use Property.MwiEnabled).
Public property | MwiMode | Provides access to the property representing the MWI mode for this user (use Property.MwiMode).
Public property | MwiSmdiPhoneNumber | Obsolete. Provides access to the property representing the MWI SMDI phone number for this user (use Property.MwiSmdiPhoneNumber).
Public property | MwiSmdiPort | Obsolete. Provides access to the property representing the MWI SMDI port ID for this user (use Property.MwiSmdiPort).
Public property | NameSpellingsAsr | Provides access to the property representing the ASR name spellings for this user (use Property.NameSpellingsAsr).
Public property | NameSpellingTts | Provides access to the property representing the TTS name spelling for this user (use Property.NameSpellingTts).
Public property | NtDomainUser | Provides access to the property representing the NT domain user for this user (use Property.NtDomainUser).
Public property | OpenNewCallWindow | Provides access to the property representing OpenNewCallWindow for this user (use Property.OpenNewCallWindow).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | OutboundAni | Provides access to the property representing the outbound ANI for this user (use Property.OutboundAni).
Public property | ParkedCallExtension | Provides access to the property representing the parked call extension for this user (use Property.ParkedCallExtension).
Public property | ParkedCallTimeout | Provides access to the property representing the parked call timeout for this user (use Property.ParkedCallTimeout).
Public property | ParkedChatExtension | Provides access to the property representing the parked chat extension for this user (use Property.ParkedChatExtension).
Public property | ParkedChatTimeout | Provides access to the property representing the parked chat timeout for this user (use Property.ParkedChatTimeout).
Public property | ParkedEmailExtension | Provides access to the property representing the parked email extension for this user (use Property.ParkedEmailExtension).
Public property | ParkedEmailTimeout | Provides access to the property representing the parked email timeout for this user (use Property.ParkedEmailTimeout).
Public property | ParkedGenericObjectExtension | Provides access to the property representing the parked generic object extension for this user (use Property.ParkedGenericObjectExtension).
Public property | ParkedGenericObjectTimeout | Provides access to the property representing the parked generic object timeout for this user (use Property.ParkedGenericObjectTimeout).
Public property | PasswordPolicies | Provides access to the property representing the password policies for this user (use Property.PasswordPolicies).
Public property | PersonalInformation | Provides access to the various personal information properties.
Public property | PopTrackertoResolveContact | Provides access to the property representing PopTrackertoResolveContact for this user (use Property.PopTrackertoResolveContact).
Public property | PreferredLanguage | Provides access to the property representing the preferred language for this user (use Property.PreferredLanguage).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | QueuePagePaneAllowChange | Provides access to the property representing QueuePagePaneAllowChange for this user (use Property.QueuePagePaneAllowChange).
Public property | QueuePageSelected | Provides access to the property representing QueuePageSelected for this user (use Property.QueuePageSelected).
Public property | RedialInterval | Provides access to the property representing RedialInterval for this user (use Property.RedialInterval).
Public property | RingWhenOnPhone | Provides access to the property representing RingWhenOnPhone for this user (use Property.RingWhenOnPhone).
Public property | Roles | Provides access to the property representing the roles for this user (use Property.Roles).
Public property | ScreenCalls | Provides access to the property representing ScreenCalls for this user (use Property.ScreenCalls).
Public property | SecurityRights | Provides access to the various security properties.
Public property | SelectInteractiononDisconnect | Provides access to the property representing SelectInteractiononDisconnect for this user (use Property.SelectInteractiononDisconnect).
Public property | ShowStatusInSysTray | Provides access to the property representing ShowStatusInSysTray for this user (use Property.ShowStatusInSysTray).
Public property | Skills | Provides access to the property representing the skills for this user (use Property.Skills).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StatisticsShiftStarts | Provides access to the property representing the statistics shift starts for this user (use Property.StatisticsShiftStarts).
Public property | StatusText | Provides access to the property representing StatusText for this user (use Property.StatusText).
Public property | TransactionId | Gets the transaction ID.
Public property | UmDestination | Provides access to the property representing the UM destination for this user (use Property.UmDestination).
Public property | UmRemoteOverride | Provides access to the property representing the UM remote override for this user (use Property.UmRemoteOverride).
Public property | UseWkgRing | Provides access to the property representing UseWkgRing for this user (use Property.UseWkgRing).
Public property | Utilizations | Provides access to the property representing the media utilizations for this user (use Property.Utilizations).
Public property | VniStation | Provides access to the property representing VniStation for this user (use Property.VniStation).
Public property | WhisperToneLevel | Provides access to the property representing the whisper tone level for this user (use Property.WhisperToneLevel).
Public property | Workgroups | Provides access to the property representing the workgroups for this user (use Property.Workgroups).

See Also

UserConfiguration Class
ININ.IceLib.Configuration Namespace


UserConfiguration Methods

[image] [image]

IceLib Technical Reference
UserConfiguration Methods
UserConfiguration Class See Also Send Feedback

The UserConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified user IDs.
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified user.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetPassword | Sets the password for this session user.
Public method | SetPasswordAsync | Asynchronously sets the password for this session user.
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()() or Delete()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

UserConfiguration Class
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method

[image] [image]

IceLib Technical Reference
UserConfiguration..::..PublishClientTemplate Method
UserConfiguration Class See Also Send Feedback

Overload List

Name | Description
PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified user IDs.
PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified user.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method (ConfigurationManager, ConfigurationId, IEnumerable(String), String)

[image]

IceLib Technical Reference
UserConfiguration..::..PublishClientTemplate Method (ConfigurationManager, ConfigurationId, IEnumerable<(Of <(<'String>)>)>, String)
UserConfiguration Class See Also Send Feedback
Publishes the client template to the specified user IDs.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ClientTemplatePublishResult> PublishClientTemplate(
    ConfigurationManager configurationManager,
    ConfigurationId clientTemplateId,
    IEnumerable<string> userIds,
    string applicationId
)
Visual Basic
Public Shared Function PublishClientTemplate ( _
    configurationManager As ConfigurationManager, _
    clientTemplateId As ConfigurationId, _
    userIds As IEnumerable(Of String), _
    applicationId As String _
) As ReadOnlyCollection(Of ClientTemplatePublishResult)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
clientTemplateId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The client template ID.
userIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The user IDs.
applicationId
Type: System..::..String
The application ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ClientTemplatePublishResult objects with the results of the publish operation.

Remarks

Valid clientTemplateId values can be retrieved from the ConfigurationId property of ClientTemplateConfiguration. The userIds value can be retrieved from the Id portion of UserConfiguration, or UserId. The applicationId can be retrieved from the ApplicationName portion of the return value from GetSessionSettings()()()(). In order to publish client templates, the logged on user must have the CanPublishClientTemplates right.

Exceptions

Exception | Condition
System..::..ArgumentNullException | configurationManager, clientTemplateId, or applicationId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | One of the values in userIds is Empty, or applicationId is Empty.
System..::..InvalidOperationException | userIds is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
PublishClientTemplate Overload
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method (ConfigurationManager, ConfigurationId, String, String)

[image]

IceLib Technical Reference
UserConfiguration..::..PublishClientTemplate Method (ConfigurationManager, ConfigurationId, String, String)
UserConfiguration Class See Also Send Feedback
Publishes the client template to the specified user.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ClientTemplatePublishResult PublishClientTemplate(
    ConfigurationManager configurationManager,
    ConfigurationId clientTemplateId,
    string userId,
    string applicationId
)
Visual Basic
Public Shared Function PublishClientTemplate ( _
    configurationManager As ConfigurationManager, _
    clientTemplateId As ConfigurationId, _
    userId As String, _
    applicationId As String _
) As ClientTemplatePublishResult

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
clientTemplateId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The client template ID.
userId
Type: System..::..String
The user ID.
applicationId
Type: System..::..String
The application ID.

Return Value

A ClientTemplatePublishResult object that contain the results of the publish.

Remarks

Valid clientTemplateId values can be retrieved from the ConfigurationId property of ClientTemplateConfiguration. The userIdvalue can be retrieved from the Id portion of UserConfiguration, or UserId. The applicationId can be retrieved from the ApplicationName portion of the return value from GetSessionSettings()()()(). In order to publish client templates, the logged on user must have the CanPublishClientTemplates right.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | userId or applicationId is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
PublishClientTemplate Overload
ININ.IceLib.Configuration Namespace


SetPassword Method

[image]

IceLib Technical Reference
UserConfiguration..::..SetPassword Method
UserConfiguration Class See Also Send Feedback
Sets the password for this session user.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetPassword(
    string newPassword,
    bool force
)
Visual Basic
Public Sub SetPassword ( _
    newPassword As String, _
    force As Boolean _
)

Parameters

newPassword
Type: System..::..String
The new password.
force
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) attempt to force the password change by bypassing the password policy, otherwise return password policy violation errors that may occur.

Remarks

The password policy can be overridden by setting force to trueTruetruetrue (True in Visual Basic) only if the user has Master Administrator rights. If the password cannot be set and the server is not able to override the password policy an IceLibException containing the error message will be thrown.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | The password was unable to be set.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


SetPasswordAsync Method

[image]

IceLib Technical Reference
UserConfiguration..::..SetPasswordAsync Method
UserConfiguration Class See Also Send Feedback
Asynchronously sets the password for this session user.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetPasswordAsync(
    string newPassword,
    bool force,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetPasswordAsync ( _
    newPassword As String, _
    force As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

newPassword
Type: System..::..String
The new password.
force
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) attempt to force the password change by bypassing the password policy, otherwise return password policy violation errors that may occur.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

The password policy can be overridden by setting force to trueTruetruetrue (True in Visual Basic) only if the user has Master Administrator rights. If the password cannot be set and the server is not able to override the password policy an IceLibException containing the error message will be returned in the AsyncCompletedEventArgs.Error property.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


SetTransactionId Method

[image]

IceLib Technical Reference
UserConfiguration..::..SetTransactionId Method
UserConfiguration Class See Also Send Feedback
Sets the transaction ID to use when calling Commit()()()() or Delete()()()().

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTransactionId(
    int transactionId
)
Visual Basic
Public Sub SetTransactionId ( _
    transactionId As Integer _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.

Remarks

Valid values can be obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained. Setting this value to NoTransactionId will clear the transaction ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | transactionId is less than zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


UserConfiguration Properties

[image] [image]

IceLib Technical Reference
UserConfiguration Properties
UserConfiguration Class See Also Send Feedback

The UserConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this user (use Property.AccessControlGroupAssignment).
Public property | AccessRights | Provides access to the various access control list properties.
Public property | AcdAgentGreeting | Provides access to the property representing whether the ACD agent greeting is active for this user (use Property.AcdAgentGreeting).
Public property | AcdAgentGreetingFile | Provides access to the property representing the ACD agent greeting file for this user (use Property.AcdAgentGreetingFile).
Public property | AdministrativeRights | Provides access to the various administrative access control list properties.
Public property | AlertOnSecurityBelowRequestedLevel | Provides access to the property representing AlertOnSecurityBelowRequestedLevel for this user (use Property.AlertOnSecurityBelowRequestedLevel).
Public property | AlertPaneAllowChange | Provides access to the property representing AlertPaneAllowChange for this user (use Property.AlertPaneAllowChange).
Public property | Alias | Provides access to the property representing the alias (or privacy name) for this user (use Property.Alias).
Public property | Analyze | Provides access to the property that determines whether or not outgoing external calls for this user are are analyzed (use Property.Analyze).
Public property | AutoAnswerAcdInteractions | Provides access to the property representing whether to auto-answer ACD interactions for this user (use Property.AutoAnswerAcdInteractions).
Public property | AutoAnswerNonAcdInteractions | Provides access to the property representing whether to auto-answer non-ACD interactions for this user (use Property.AutoAnswerNonAcdInteractions).
Public property | CallbackEnabledWorkgroups | Provides access to the read-only property representing the collection of workgroups this user is assigned to that are callback enabled (use Property.CallbackEnabledWorkgroups).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClientConfigDateLastModified | Provides access to the property representing ClientConfigDateLastModified for this user (use Property.ClientConfigDateLastModified).
Public property | ClientConfigurationTemplate | Provides access to the property representing the client configuration template for this user (use Property.ClientConfigurationTemplate).
Public property | ClientTemplates | Provides access to the read-only property representing the published client templates for this user (use Property.ClientTemplates).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConfirmDial | Provides access to the property representing ConfirmDial for this user (use Property.ConfirmDial).
Public property | ConfirmDragDrop | Provides access to the property representing ConfirmDragDrop for this user (use Property.ConfirmDragDrop).
Public property | Cost | Provides access to the property representing the ACD cost for this user (use Property.Cost).
Public property | DefaultWorkstation | Provides access to the property representing the default workstation for this user (use Property.DefaultWorkstation).
Public property | EFaqSearchOption | Provides access to the property representing EFaqSearchOption for this user (use Property.EFaqSearchOption).
Public property | EFaqSearchOptionAllowChange | Provides access to the property representing EFaqSearchOptionAllowChange for this user (use Property.EFaqSearchOptionAllowChange).
Public property | ExcludeFromDirectory | Provides access to the property representing whether to exclude the entry from the company directory for this user (use Property.ExcludeFromDirectory).
Public property | ExtCallTimeout | Provides access to the property representing ExtCallTimeout for this user (use Property.ExtCallTimeout).
Public property | ExtendedAbsencePrompt | Provides access to the property representing ExtendedAbsencePrompt for this user (use Property.ExtendedAbsencePrompt).
Public property | Extension | Provides access to the property representing the extension for this user (use Property.Extension).
Public property | FaxCapability | Provides access to the property representing the FAX capability for this user (use Property.FaxCapability).
Public property | FollowMeAllowChange | Provides access to the property representing FollowMeAllowChange for this user (use Property.FollowMeAllowChange).
Public property | HomeSite | Provides access to the property representing the home site for this user (use Property.HomeSite).
 | ICServerUMDestination | Gets the a UM destination that represents the IC server.
Public property | InteractionDisconnectedAction | Provides access to the property representing the interaction disconnected action for this user (use Property.InteractionDisconnectedAction).
Public property | InteractionMessageStoreMaxMessage | Obsolete. Provides access to the property representing the Interaction Message Store max messages for this user (use Property.InteractionMessageStoreMaxMessage).
Public property | InteractionMessageStoreMaxStorage | Obsolete. Provides access to the property representing the Interaction Message Store max storage for this user (use Property.InteractionMessageStoreMaxStorage).
Public property | InteractionOfferingAction | Provides access to the property representing the interaction offering action for this user (use Property.InteractionOfferingAction).
Public property | InteractionOfferingTimeout | Provides access to the property representing the interaction offering timeout for this user (use Property.InteractionOfferingTimeout).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | License | Provides access to the various license properties.
Public property | ListenForSipRequests | Provides access to the property representing ListenForSipRequests for this user (use Property.ListenForSipRequests).
Public property | LyncIntegrationEnabled | Provides access to the property that determines whether or not Lync Integration is enabled for this user (use Property.).
Public property | LyncLineUri | Provides access to the property representing the Lync Line URI for this user (use Property.).
Public property | LyncOption | Provides access to the property representing Lync Options for this user (use Property.).
Public property | LyncSipAddress | Provides access to the property representing the Lync SIP Address for this user (use Property.).
Public property | Mailbox | Provides access to the various mailbox properties.
Public property | MobileOfficeUser | Obsolete. Provides access to the property representing whether the user is Mobile Office enabled (use Property.MobileOfficeUser).
Public property | MuteonTransfer | Provides access to the property representing MuteonTransfer for this user (use Property.MuteonTransfer).
Public property | MwiAddress | Provides access to the property representing the MWI address for this user (use Property.MwiAddress).
Public property | MwiEnabled | Provides access to the property representing whether MWI is enabled for this user (use Property.MwiEnabled).
Public property | MwiMode | Provides access to the property representing the MWI mode for this user (use Property.MwiMode).
Public property | MwiSmdiPhoneNumber | Obsolete. Provides access to the property representing the MWI SMDI phone number for this user (use Property.MwiSmdiPhoneNumber).
Public property | MwiSmdiPort | Obsolete. Provides access to the property representing the MWI SMDI port ID for this user (use Property.MwiSmdiPort).
Public property | NameSpellingsAsr | Provides access to the property representing the ASR name spellings for this user (use Property.NameSpellingsAsr).
Public property | NameSpellingTts | Provides access to the property representing the TTS name spelling for this user (use Property.NameSpellingTts).
Public property | NtDomainUser | Provides access to the property representing the NT domain user for this user (use Property.NtDomainUser).
Public property | OpenNewCallWindow | Provides access to the property representing OpenNewCallWindow for this user (use Property.OpenNewCallWindow).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | OutboundAni | Provides access to the property representing the outbound ANI for this user (use Property.OutboundAni).
Public property | ParkedCallExtension | Provides access to the property representing the parked call extension for this user (use Property.ParkedCallExtension).
Public property | ParkedCallTimeout | Provides access to the property representing the parked call timeout for this user (use Property.ParkedCallTimeout).
Public property | ParkedChatExtension | Provides access to the property representing the parked chat extension for this user (use Property.ParkedChatExtension).
Public property | ParkedChatTimeout | Provides access to the property representing the parked chat timeout for this user (use Property.ParkedChatTimeout).
Public property | ParkedEmailExtension | Provides access to the property representing the parked email extension for this user (use Property.ParkedEmailExtension).
Public property | ParkedEmailTimeout | Provides access to the property representing the parked email timeout for this user (use Property.ParkedEmailTimeout).
Public property | ParkedGenericObjectExtension | Provides access to the property representing the parked generic object extension for this user (use Property.ParkedGenericObjectExtension).
Public property | ParkedGenericObjectTimeout | Provides access to the property representing the parked generic object timeout for this user (use Property.ParkedGenericObjectTimeout).
Public property | PasswordPolicies | Provides access to the property representing the password policies for this user (use Property.PasswordPolicies).
Public property | PersonalInformation | Provides access to the various personal information properties.
Public property | PopTrackertoResolveContact | Provides access to the property representing PopTrackertoResolveContact for this user (use Property.PopTrackertoResolveContact).
Public property | PreferredLanguage | Provides access to the property representing the preferred language for this user (use Property.PreferredLanguage).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | QueuePagePaneAllowChange | Provides access to the property representing QueuePagePaneAllowChange for this user (use Property.QueuePagePaneAllowChange).
Public property | QueuePageSelected | Provides access to the property representing QueuePageSelected for this user (use Property.QueuePageSelected).
Public property | RedialInterval | Provides access to the property representing RedialInterval for this user (use Property.RedialInterval).
Public property | RingWhenOnPhone | Provides access to the property representing RingWhenOnPhone for this user (use Property.RingWhenOnPhone).
Public property | Roles | Provides access to the property representing the roles for this user (use Property.Roles).
Public property | ScreenCalls | Provides access to the property representing ScreenCalls for this user (use Property.ScreenCalls).
Public property | SecurityRights | Provides access to the various security properties.
Public property | SelectInteractiononDisconnect | Provides access to the property representing SelectInteractiononDisconnect for this user (use Property.SelectInteractiononDisconnect).
Public property | ShowStatusInSysTray | Provides access to the property representing ShowStatusInSysTray for this user (use Property.ShowStatusInSysTray).
Public property | Skills | Provides access to the property representing the skills for this user (use Property.Skills).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StatisticsShiftStarts | Provides access to the property representing the statistics shift starts for this user (use Property.StatisticsShiftStarts).
Public property | StatusText | Provides access to the property representing StatusText for this user (use Property.StatusText).
Public property | TransactionId | Gets the transaction ID.
Public property | UmDestination | Provides access to the property representing the UM destination for this user (use Property.UmDestination).
Public property | UmRemoteOverride | Provides access to the property representing the UM remote override for this user (use Property.UmRemoteOverride).
Public property | UseWkgRing | Provides access to the property representing UseWkgRing for this user (use Property.UseWkgRing).
Public property | Utilizations | Provides access to the property representing the media utilizations for this user (use Property.Utilizations).
Public property | VniStation | Provides access to the property representing VniStation for this user (use Property.VniStation).
Public property | WhisperToneLevel | Provides access to the property representing the whisper tone level for this user (use Property.WhisperToneLevel).
Public property | Workgroups | Provides access to the property representing the workgroups for this user (use Property.Workgroups).

See Also

UserConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
UserConfiguration..::..AccessControlGroupAssignment Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this user (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of UserConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


AccessRights Property

[image]

IceLib Technical Reference
UserConfiguration..::..AccessRights Property
UserConfiguration Class See Also Send Feedback
Provides access to the various access control list properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAccessRightsProperties<UserConfiguration, UserConfiguration..::..Property> AccessRights { get; }
Visual Basic
Public ReadOnly Property AccessRights As UserAccessRightsProperties(Of UserConfiguration, UserConfiguration..::..Property)
    Get

Field Value

The user access control rights properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


AcdAgentGreeting Property

[image]

IceLib Technical Reference
UserConfiguration..::..AcdAgentGreeting Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing whether the ACD agent greeting is active for this user (use Property.AcdAgentGreeting).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> AcdAgentGreeting { get; }
Visual Basic
Public ReadOnly Property AcdAgentGreeting As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether the ACD agent greeting is active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..AcdAgentGreetingFile


AcdAgentGreetingFile Property

[image]

IceLib Technical Reference
UserConfiguration..::..AcdAgentGreetingFile Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD agent greeting file for this user (use Property.AcdAgentGreetingFile).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> AcdAgentGreetingFile { get; }
Visual Basic
Public ReadOnly Property AcdAgentGreetingFile As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the ACD agent greeting file.

Remarks

This greeting, also known as a "smile", is intended for use by call center agents who are members of a workgroup and are receiving ACD calls. This feature is best used with the Auto-Answer Calls (user/agent attribute set in Interaction Administrator). When used with Auto-Answer Calls enabled, your Agent Greeting plays to the caller as the agent is being alerted. The length of the Agent Greeting is limited to 10 seconds, and therefore, is considered an introduction or "smile". For example, \\ICServer\IC\Resources\AgentGreeting_JohnDoe.wav.
Note
Once recorded, the Agent Greeting will be played to all ACD callers alerting on the agent's queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..AcdAgentGreeting


AdministrativeRights Property

[image]

IceLib Technical Reference
UserConfiguration..::..AdministrativeRights Property
UserConfiguration Class See Also Send Feedback
Provides access to the various administrative access control list properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAdministrativeRightsProperties<UserConfiguration, UserConfiguration..::..Property> AdministrativeRights { get; }
Visual Basic
Public ReadOnly Property AdministrativeRights As UserAdministrativeRightsProperties(Of UserConfiguration, UserConfiguration..::..Property)
    Get

Field Value

The user access administrative access control properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


AlertOnSecurityBelowRequestedLevel Property

[image]

IceLib Technical Reference
UserConfiguration..::..AlertOnSecurityBelowRequestedLevel Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing AlertOnSecurityBelowRequestedLevel for this user (use Property.AlertOnSecurityBelowRequestedLevel).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> AlertOnSecurityBelowRequestedLevel { get; }
Visual Basic
Public ReadOnly Property AlertOnSecurityBelowRequestedLevel As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing AlertOnSecurityBelowRequestedLevel.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


AlertPaneAllowChange Property

[image]

IceLib Technical Reference
UserConfiguration..::..AlertPaneAllowChange Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing AlertPaneAllowChange for this user (use Property.AlertPaneAllowChange).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> AlertPaneAllowChange { get; }
Visual Basic
Public ReadOnly Property AlertPaneAllowChange As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing AlertPaneAllowChange.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Alias Property

[image]

IceLib Technical Reference
UserConfiguration..::..Alias Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the alias (or privacy name) for this user (use Property.Alias).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Alias { get; }
Visual Basic
Public ReadOnly Property Alias As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the alias.

Remarks

This field is used for creating an alias for agent names in chat and other displays.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Analyze Property

[image]

IceLib Technical Reference
UserConfiguration..::..Analyze Property
UserConfiguration Class See Also Send Feedback
Provides access to the property that determines whether or not outgoing external calls for this user are are analyzed (use Property.Analyze).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> Analyze { get; }
Visual Basic
Public ReadOnly Property Analyze As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing Analyze.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


AutoAnswerAcdInteractions Property

[image]

IceLib Technical Reference
UserConfiguration..::..AutoAnswerAcdInteractions Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing whether to auto-answer ACD interactions for this user (use Property.AutoAnswerAcdInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> AutoAnswerAcdInteractions { get; }
Visual Basic
Public ReadOnly Property AutoAnswerAcdInteractions As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether to auto-answer ACD interactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


AutoAnswerNonAcdInteractions Property

[image]

IceLib Technical Reference
UserConfiguration..::..AutoAnswerNonAcdInteractions Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing whether to auto-answer non-ACD interactions for this user (use Property.AutoAnswerNonAcdInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> AutoAnswerNonAcdInteractions { get; }
Visual Basic
Public ReadOnly Property AutoAnswerNonAcdInteractions As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether to auto-answer non-ACD interactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


CallbackEnabledWorkgroups Property

[image]

IceLib Technical Reference
UserConfiguration..::..CallbackEnabledWorkgroups Property
UserConfiguration Class See Also Send Feedback
Provides access to the read-only property representing the collection of workgroups this user is assigned to that are callback enabled (use Property.CallbackEnabledWorkgroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<ConfigurationId>> CallbackEnabledWorkgroups { get; }
Visual Basic
Public ReadOnly Property CallbackEnabledWorkgroups As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The read-only property represnting the collection of callback enabled workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..IsCallbackEnabled


ClientConfigDateLastModified Property

[image]

IceLib Technical Reference
UserConfiguration..::..ClientConfigDateLastModified Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ClientConfigDateLastModified for this user (use Property.ClientConfigDateLastModified).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, DateTime> ClientConfigDateLastModified { get; }
Visual Basic
Public ReadOnly Property ClientConfigDateLastModified As GeneralConfigurationProperty(Of UserConfiguration..::..Property, DateTime)
    Get

Field Value

The property representing ClientConfigDateLastModified.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ClientConfigurationTemplate Property

[image]

IceLib Technical Reference
UserConfiguration..::..ClientConfigurationTemplate Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the client configuration template for this user (use Property.ClientConfigurationTemplate).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, ConfigurationId> ClientConfigurationTemplate { get; }
Visual Basic
Public ReadOnly Property ClientConfigurationTemplate As InheritableConfigurationProperty(Of UserConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the client configuration template.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ClientTemplates Property

[image]

IceLib Technical Reference
UserConfiguration..::..ClientTemplates Property
UserConfiguration Class See Also Send Feedback
Provides access to the read-only property representing the published client templates for this user (use Property.ClientTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<ClientTemplate>> ClientTemplates { get; }
Visual Basic
Public ReadOnly Property ClientTemplates As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of ClientTemplate))
    Get

Field Value

The read-only property representing the published client configuration templates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ConfirmDial Property

[image]

IceLib Technical Reference
UserConfiguration..::..ConfirmDial Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ConfirmDial for this user (use Property.ConfirmDial).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ConfirmDial { get; }
Visual Basic
Public ReadOnly Property ConfirmDial As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ConfirmDial.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ConfirmDragDrop Property

[image]

IceLib Technical Reference
UserConfiguration..::..ConfirmDragDrop Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ConfirmDragDrop for this user (use Property.ConfirmDragDrop).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ConfirmDragDrop { get; }
Visual Basic
Public ReadOnly Property ConfirmDragDrop As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ConfirmDragDrop.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Cost Property

[image]

IceLib Technical Reference
UserConfiguration..::..Cost Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD cost for this user (use Property.Cost).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Cost { get; }
Visual Basic
Public ReadOnly Property Cost As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the ACD cost.

Remarks

A positive number from 1 to 100 to define the cost attribute for this agent. The higher the cost number, the more expensive this agent appears to the ACD processing. If you want to consider employee cost when distributing ACD calls, assign a cost to each ACD agent according to their relative expense in the company or group. Then make analogous changes in the ACDProcessCall tool to increase the weight for Cost. This option is not available in EIC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


DefaultWorkstation Property

[image]

IceLib Technical Reference
UserConfiguration..::..DefaultWorkstation Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the default workstation for this user (use Property.DefaultWorkstation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, ConfigurationId> DefaultWorkstation { get; }
Visual Basic
Public ReadOnly Property DefaultWorkstation As GeneralConfigurationProperty(Of UserConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the default workstation.

Remarks

The name of the workstation primarily associated with the user’s account.

For example, if USER1 is the workstation name associated with User 1's account, then USER1, or its analog phone, rings on incoming calls even if User One is not logged on to the network unless:

  • User 1 has selected a status other than Available (for example, Do Not Disturb. See Status Messages).
  • Someone other than User 1 is logged on to the workstation. Example, if User 1's default station is Station 1, do not route calls addressed to User 1 to Station 1, as long as another user is logged on to that station (whether Station 1 is the name of the PC or the name specified in the IC command line, it doesn't matter). Otherwise, it causes a security breach.

In either case, incoming calls for User 1 go directly to User 1's voice mail.

Note

Do not configure as a user's default workstation any workstation intended for regular use by more than one person.

You cannot select a Remote Station name as the default workstation. Remote users must log on to the IC to receive calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


EFaqSearchOption Property

[image]

IceLib Technical Reference
UserConfiguration..::..EFaqSearchOption Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing EFaqSearchOption for this user (use Property.EFaqSearchOption).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, EFaqSearchOption> EFaqSearchOption { get; }
Visual Basic
Public ReadOnly Property EFaqSearchOption As GeneralConfigurationProperty(Of UserConfiguration..::..Property, EFaqSearchOption)
    Get

Field Value

The property representing EFaqSearchOption.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


EFaqSearchOptionAllowChange Property

[image]

IceLib Technical Reference
UserConfiguration..::..EFaqSearchOptionAllowChange Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing EFaqSearchOptionAllowChange for this user (use Property.EFaqSearchOptionAllowChange).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> EFaqSearchOptionAllowChange { get; }
Visual Basic
Public ReadOnly Property EFaqSearchOptionAllowChange As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing EFaqSearchOptionAllowChange.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ExcludeFromDirectory Property

[image]

IceLib Technical Reference
UserConfiguration..::..ExcludeFromDirectory Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing whether to exclude the entry from the company directory for this user (use Property.ExcludeFromDirectory).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ExcludeFromDirectory { get; }
Visual Basic
Public ReadOnly Property ExcludeFromDirectory As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether to exclude the entry from the company .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ExtCallTimeout Property

[image]

IceLib Technical Reference
UserConfiguration..::..ExtCallTimeout Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ExtCallTimeout for this user (use Property.ExtCallTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, int> ExtCallTimeout { get; }
Visual Basic
Public ReadOnly Property ExtCallTimeout As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Integer)
    Get

Field Value

The property representing ExtCallTimeout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ExtendedAbsencePrompt Property

[image]

IceLib Technical Reference
UserConfiguration..::..ExtendedAbsencePrompt Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ExtendedAbsencePrompt for this user (use Property.ExtendedAbsencePrompt).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ExtendedAbsencePrompt { get; }
Visual Basic
Public ReadOnly Property ExtendedAbsencePrompt As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ExtendedAbsencePrompt.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Extension Property

[image]

IceLib Technical Reference
UserConfiguration..::..Extension Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the extension for this user (use Property.Extension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> Extension { get; }
Visual Basic
Public ReadOnly Property Extension As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the extension.

Remarks

When this user logs on to the network at any Interaction Client workstation, the IC system detects that user’s presence (by his or her extension) and routes calls to the workstation where the user logged on. If the user is logged on to more than one workstation at the same time, all connected workstations ring when a call is received for that user, regardless of the workstation’s extension number.
Note
Be sure the user extension numbers do not begin with a number that conflicts with a workgroup extension or other valid queue extension. Extension numbers can be from two to six digits but should avoid the following numbers (in North America): 1800, 1900, 1411, 1911.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


FaxCapability Property

[image]

IceLib Technical Reference
UserConfiguration..::..FaxCapability Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the FAX capability for this user (use Property.FaxCapability).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> FaxCapability { get; }
Visual Basic
Public ReadOnly Property FaxCapability As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the FAX capability.

Remarks

If you configure a user as fax-capable, then callers to that DID hear ring-back while the handler listens for a fax. The handler then places the call on the queue.
Note
If you do not configure a user as fax-capable, the call goes directly to that user queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


FollowMeAllowChange Property

[image]

IceLib Technical Reference
UserConfiguration..::..FollowMeAllowChange Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing FollowMeAllowChange for this user (use Property.FollowMeAllowChange).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> FollowMeAllowChange { get; }
Visual Basic
Public ReadOnly Property FollowMeAllowChange As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing FollowMeAllowChange.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


HomeSite Property

[image]

IceLib Technical Reference
UserConfiguration..::..HomeSite Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the home site for this user (use Property.HomeSite).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> HomeSite { get; }
Visual Basic
Public ReadOnly Property HomeSite As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the home site.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ICServerUMDestination Property

[image]

IceLib Technical Reference
UserConfiguration..::..ICServerUMDestination Property
UserConfiguration Class See Also Send Feedback
Gets the a UM destination that represents the IC server.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ICServerUMDestination { get; }
Visual Basic
Public Shared ReadOnly Property ICServerUMDestination As String
    Get

Field Value

The IC server UM destination.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..UmDestination


InteractionDisconnectedAction Property

[image]

IceLib Technical Reference
UserConfiguration..::..InteractionDisconnectedAction Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the interaction disconnected action for this user (use Property.InteractionDisconnectedAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, ConfigurationId> InteractionDisconnectedAction { get; }
Visual Basic
Public ReadOnly Property InteractionDisconnectedAction As GeneralConfigurationProperty(Of UserConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the interaction disconnected action.

Remarks

An action to start each time an interaction moves from the connected state to a disconnected state in a User queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ActionConfiguration
ININ.IceLib.Configuration..::..ActionConfigurationList


InteractionMessageStoreMaxMessage Property

[image]

IceLib Technical Reference
UserConfiguration..::..InteractionMessageStoreMaxMessage Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the Interaction Message Store max messages for this user (use Property.InteractionMessageStoreMaxMessage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessageStoreMaxMessage is no longer available.")]
public InheritableConfigurationProperty<UserConfiguration..::..Property, int> InteractionMessageStoreMaxMessage { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessageStoreMaxMessage is no longer available.")> _
Public ReadOnly Property InteractionMessageStoreMaxMessage As InheritableConfigurationProperty(Of UserConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Interaction Message Store max message.

Remarks

Note
-1 = "No Limit"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionMessageStoreMaxStorage Property

[image]

IceLib Technical Reference
UserConfiguration..::..InteractionMessageStoreMaxStorage Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the Interaction Message Store max storage for this user (use Property.InteractionMessageStoreMaxStorage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessageStoreMaxStorage is no longer available.")]
public InheritableConfigurationProperty<UserConfiguration..::..Property, int> InteractionMessageStoreMaxStorage { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessageStoreMaxStorage is no longer available.")> _
Public ReadOnly Property InteractionMessageStoreMaxStorage As InheritableConfigurationProperty(Of UserConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Interaction Message Store max storage.

Remarks

Note
-1 = "No Limit"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionOfferingAction Property

[image]

IceLib Technical Reference
UserConfiguration..::..InteractionOfferingAction Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the interaction offering action for this user (use Property.InteractionOfferingAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, ConfigurationId> InteractionOfferingAction { get; }
Visual Basic
Public ReadOnly Property InteractionOfferingAction As GeneralConfigurationProperty(Of UserConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the interaction offering action.

Remarks

An action to start each time a non-ACD interaction enters an alerting state (for example, the station rings) in a User queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ActionConfiguration
ININ.IceLib.Configuration..::..ActionConfigurationList


InteractionOfferingTimeout Property

[image]

IceLib Technical Reference
UserConfiguration..::..InteractionOfferingTimeout Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the interaction offering timeout for this user (use Property.InteractionOfferingTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, TimeSpan> InteractionOfferingTimeout { get; }
Visual Basic
Public ReadOnly Property InteractionOfferingTimeout As InheritableConfigurationProperty(Of UserConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the interaction offering timeout.

Remarks

The number of seconds an incoming interaction rings at the Interaction Client station before the interaction quits alerting and proceeds to the next step in the handler (for example, goes to voice mail or changes an ACD agent’s status to ACD-Agent not answering and offers the interaction to another agent). The default value is 15 seconds; entering 0 (zero) also means 15 seconds. The minimum value is 7 seconds, which allows at least one full ring cycle. For North America, the standard ring duration for one ring is six seconds, which includes two seconds of ring and four seconds of pause time.

Note

This setting affects ACD and non-ACD interactions differently, depending on where you set it.

This setting also affects the timeout for the workgroup's Group Ring and Sequential Ring.

The timeout value on the Workgroup determines the number of seconds ACD interactions alert on agent workstations.

The timeout value on the User determines the number of seconds non-ACD interactions alert on agent workstations.

The timeout value on the Default User determines the number of seconds non-ACD interactions alert on agent workstations only when the value is 0 (zero) on the User. If it is set to 0 (zero) on the User, the default value is 15 seconds of alerting.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


License Property

[image]

IceLib Technical Reference
UserConfiguration..::..License Property
UserConfiguration Class See Also Send Feedback
Provides access to the various license properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserLicenseProperties License { get; }
Visual Basic
Public ReadOnly Property License As UserLicenseProperties
    Get

Field Value

The license properties group.

Remarks

When updating the license properties along with additional non-license properties on a UserConfiguration object via a call to Commit()()()(), it is possible for the license changes to fail, but the non-license changes to succeed. When a call to Commit()()()() results in a ConfigurationValidationException, and the list of validation issues obtained from checking the return value of GetValidationIssues<(Of <<'(TPropertyEnum>)>>)()()()() only contains validation issues relating to the license changes, then the rest of the update operation succeeded. Conversely, if a call to Commit()()()() results in a ConfigurationValidationException, and the list of validation issues obtained from checking the return value of GetValidationIssues<(Of <<'(TPropertyEnum>)>>)()()()() contains validation errors on the non-license properties, then the update to the object failed, and the license changes were not applied.

When watching the UserConfigurationList object for UserConfiguration changes, change notifications will not be sent for changes to the License property. The ININ.IceLib.People.LicenseManagement object can be used as an alternative to watching the logged in user's licenses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ListenForSipRequests Property

[image]

IceLib Technical Reference
UserConfiguration..::..ListenForSipRequests Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ListenForSipRequests for this user (use Property.ListenForSipRequests).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ListenForSipRequests { get; }
Visual Basic
Public ReadOnly Property ListenForSipRequests As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ListenForSipRequests.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


LyncIntegrationEnabled Property

[image]

IceLib Technical Reference
UserConfiguration..::..LyncIntegrationEnabled Property
UserConfiguration Class See Also Send Feedback
Provides access to the property that determines whether or not Lync Integration is enabled for this user (use Property.).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> LyncIntegrationEnabled { get; }
Visual Basic
Public ReadOnly Property LyncIntegrationEnabled As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing if Lync Integration is enabled .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


LyncLineUri Property

[image]

IceLib Technical Reference
UserConfiguration..::..LyncLineUri Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the Lync Line URI for this user (use Property.).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> LyncLineUri { get; }
Visual Basic
Public ReadOnly Property LyncLineUri As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the Lync Line URI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


LyncOption Property

[image]

IceLib Technical Reference
UserConfiguration..::..LyncOption Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing Lync Options for this user (use Property.).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, LyncOption> LyncOption { get; }
Visual Basic
Public ReadOnly Property LyncOption As GeneralConfigurationProperty(Of UserConfiguration..::..Property, LyncOption)
    Get

Field Value

The read-only property representing the Lync Options.

Remarks

The value of this property is not a flags enumeration. See the comments on LyncOption for valid values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


LyncSipAddress Property

[image]

IceLib Technical Reference
UserConfiguration..::..LyncSipAddress Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the Lync SIP Address for this user (use Property.).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> LyncSipAddress { get; }
Visual Basic
Public ReadOnly Property LyncSipAddress As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the Lync SIP Address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Mailbox Property

[image]

IceLib Technical Reference
UserConfiguration..::..Mailbox Property
UserConfiguration Class See Also Send Feedback
Provides access to the various mailbox properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxProperties Mailbox { get; }
Visual Basic
Public ReadOnly Property Mailbox As MailboxProperties
    Get

Field Value

The mailbox properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


MobileOfficeUser Property

[image]

IceLib Technical Reference
UserConfiguration..::..MobileOfficeUser Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing whether the user is Mobile Office enabled (use Property.MobileOfficeUser).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("MobileOfficeUser is not used.")]
public InheritableConfigurationProperty<UserConfiguration..::..Property, bool> MobileOfficeUser { get; }
Visual Basic
<ObsoleteAttribute("MobileOfficeUser is not used.")> _
Public ReadOnly Property MobileOfficeUser As InheritableConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the user is Mobile Office enabled.

Remarks

Specifies user access to the Mobile Office feature.
Note
If Outlook TUI User is selected, the Mobile Office User option is automatically selected and grayed-out. This allows correct inheritance with the Mobile Office role. For example, User A can inherit from Role B and Role C. If Role B has Outlook TUI User checked and Role C has Mobile Office User checked, then User A will have both options selected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


MuteonTransfer Property

[image]

IceLib Technical Reference
UserConfiguration..::..MuteonTransfer Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing MuteonTransfer for this user (use Property.MuteonTransfer).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> MuteonTransfer { get; }
Visual Basic
Public ReadOnly Property MuteonTransfer As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing MuteonTransfer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


MwiAddress Property

[image]

IceLib Technical Reference
UserConfiguration..::..MwiAddress Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the MWI address for this user (use Property.MwiAddress).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> MwiAddress { get; }
Visual Basic
Public ReadOnly Property MwiAddress As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the MWI address.

Remarks

Note
This setting only applies when MwiEnabled is trueTruetruetrue (True in Visual Basic) and MwiMode is Address.
The phone number to alert when a message is waiting for this user. This could be the user's primary extension or any other extension the user designates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..MwiEnabled
UserConfiguration..::..MwiMode
UserConfiguration..::..MwiSmdiPhoneNumber
UserConfiguration..::..MwiSmdiPort


MwiEnabled Property

[image]

IceLib Technical Reference
UserConfiguration..::..MwiEnabled Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing whether MWI is enabled for this user (use Property.MwiEnabled).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> MwiEnabled { get; }
Visual Basic
Public ReadOnly Property MwiEnabled As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing whether MWI is enabled.

Remarks

Set this property to indicate this user has an MWI-enabled phone and wishes to use this SMDI feature. Clear the property to disable the MWI feature for this user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..MwiMode
UserConfiguration..::..MwiAddress
UserConfiguration..::..MwiSmdiPhoneNumber
UserConfiguration..::..MwiSmdiPort


MwiMode Property

[image]

IceLib Technical Reference
UserConfiguration..::..MwiMode Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the MWI mode for this user (use Property.MwiMode).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, MwiMode> MwiMode { get; }
Visual Basic
Public ReadOnly Property MwiMode As GeneralConfigurationProperty(Of UserConfiguration..::..Property, MwiMode)
    Get

Field Value

The property representing the MWI mode.

Remarks

Note
This setting only applies when MwiEnabled is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..MwiEnabled
UserConfiguration..::..MwiAddress
UserConfiguration..::..MwiSmdiPhoneNumber
UserConfiguration..::..MwiSmdiPort


MwiSmdiPhoneNumber Property

[image]

IceLib Technical Reference
UserConfiguration..::..MwiSmdiPhoneNumber Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the MWI SMDI phone number for this user (use Property.MwiSmdiPhoneNumber).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("MwiSmdiPhoneNumber is no longer used.")]
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> MwiSmdiPhoneNumber { get; }
Visual Basic
<ObsoleteAttribute("MwiSmdiPhoneNumber is no longer used.")> _
Public ReadOnly Property MwiSmdiPhoneNumber As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the MWI SMDI phone number.

Remarks

Note
This setting only applies when MwiEnabled is trueTruetruetrue (True in Visual Basic) and MwiMode is Smdi.
The phone number to alert when a message is waiting for this user. This could be the user's primary extension or any other extension the user designates.
Note
For more information on SMDI integration, see SMDI Interface Fact Sheet located in the Technical Reference Documents section in the IC Documentation Library on the IC Server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..MwiEnabled
UserConfiguration..::..MwiMode
UserConfiguration..::..MwiAddress
UserConfiguration..::..MwiSmdiPort


MwiSmdiPort Property

[image]

IceLib Technical Reference
UserConfiguration..::..MwiSmdiPort Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the MWI SMDI port ID for this user (use Property.MwiSmdiPort).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("MwiSmdiPort is no longer used.")]
public GeneralConfigurationProperty<UserConfiguration..::..Property, ConfigurationId> MwiSmdiPort { get; }
Visual Basic
<ObsoleteAttribute("MwiSmdiPort is no longer used.")> _
Public ReadOnly Property MwiSmdiPort As GeneralConfigurationProperty(Of UserConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the MWI SMDI port.

Remarks

Note
This setting only applies when MwiEnabled is trueTruetruetrue (True in Visual Basic) and MwiMode is Smdi.
The ID of the MWI SMDI port configuration. This configured IC SMDI port represents a specific COM port used by the SMDI cable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..MwiEnabled
UserConfiguration..::..MwiMode
UserConfiguration..::..MwiAddress
UserConfiguration..::..MwiSmdiPhoneNumber


NameSpellingsAsr Property

[image]

IceLib Technical Reference
UserConfiguration..::..NameSpellingsAsr Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the ASR name spellings for this user (use Property.NameSpellingsAsr).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<string>> NameSpellingsAsr { get; }
Visual Basic
Public ReadOnly Property NameSpellingsAsr As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the ASR name spellings.

Remarks

Note
The user's or workgroup's phonetic spelling of the name. You can specify multiple spellings for ASR. The ASR spelling attribute should be a multi-valued attribute.
Note
The ASR phonetic spelling values are used by the “Reco Create Company Directory Grammar”. This can be very useful to add nick names or different spellings of a user’s name. Any valid grammar token may be specified in this list. For example, assume a user called “John Smith”. That’s the first and last name as he is known to the IC system and used by default for the company directory grammar. However, you want to add additional spellings to increase the coverage of the grammar by adding the following alternate spellings:
  • Johnny Smith
  • John Robert Smith
  • John R Smith
Note
You should be careful not to add too many alternate spellings without actually knowing whether the spellings will be used by callers. If the grammar coverage becomes too broad, in particular if the company directory already contains a lot of similarly sounding names, the recognitions quality will be degraded because of the ambiguity.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


NameSpellingTts Property

[image]

IceLib Technical Reference
UserConfiguration..::..NameSpellingTts Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the TTS name spelling for this user (use Property.NameSpellingTts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> NameSpellingTts { get; }
Visual Basic
Public ReadOnly Property NameSpellingTts As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the TTS name spelling.

Remarks

The user's or workgroup's phonetic spelling of the name.

The TTS spelling should be a single-valued attribute. You spell the name like it sounds. For example if you have a user name spelled "Rose", but it is pronounced "Rosy", you would enter "Rosy".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


NtDomainUser Property

[image]

IceLib Technical Reference
UserConfiguration..::..NtDomainUser Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the NT domain user for this user (use Property.NtDomainUser).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> NtDomainUser { get; }
Visual Basic
Public ReadOnly Property NtDomainUser As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the NT domain user.

Remarks

The domain qualified user log on name for this IC user (for example, CorpDomain\SonyaM). IC uses this field to automatically authenticate that the IC user has a valid account in the network domain. With the appropriate value in this field, the IC user logged in to the domain with this name can start any IC application and IC automatically authenticates this user as a form of security. This prevents non-IC users from starting an IC application (such as Interaction Client) and running it on the network.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


OpenNewCallWindow Property

[image]

IceLib Technical Reference
UserConfiguration..::..OpenNewCallWindow Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing OpenNewCallWindow for this user (use Property.OpenNewCallWindow).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> OpenNewCallWindow { get; }
Visual Basic
Public ReadOnly Property OpenNewCallWindow As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing OpenNewCallWindow.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


OutboundAni Property

[image]

IceLib Technical Reference
UserConfiguration..::..OutboundAni Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the outbound ANI for this user (use Property.OutboundAni).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> OutboundAni { get; }
Visual Basic
Public ReadOnly Property OutboundAni As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the outbound ANI.

Remarks

The ANI/Caller ID for the system to send when this user makes an outbound call.
Note

This option overrides the OutboundAni.

This Outbound ANI option does not override a call placed with a specific Calling Party Number and Calling Party Name. Call Forwarding and Follow-me numbers placed as outbound calls use the Forwarded Parties ANI and Name where allowed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ParkedCallExtension Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedCallExtension Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked call extension for this user (use Property.ParkedCallExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, string> ParkedCallExtension { get; }
Visual Basic
Public ReadOnly Property ParkedCallExtension As InheritableConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked call extension.

Remarks

The destination extension for a parked call that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedCallTimeout
UserConfiguration..::..ParkedCallTimeout


ParkedCallTimeout Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedCallTimeout Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked call timeout for this user (use Property.ParkedCallTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, TimeSpan> ParkedCallTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedCallTimeout As InheritableConfigurationProperty(Of UserConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked call timeout.

Remarks

The maximum time in minutes that a parked call should wait before transfer to the specified ParkedCallExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedCallExtension


ParkedChatExtension Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedChatExtension Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked chat extension for this user (use Property.ParkedChatExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, string> ParkedChatExtension { get; }
Visual Basic
Public ReadOnly Property ParkedChatExtension As InheritableConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked chat extension.

Remarks

The destination extension for a parked chat that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedChatTimeout
UserConfiguration..::..ParkedChatTimeout


ParkedChatTimeout Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedChatTimeout Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked chat timeout for this user (use Property.ParkedChatTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, TimeSpan> ParkedChatTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedChatTimeout As InheritableConfigurationProperty(Of UserConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked chat timeout.

Remarks

The maximum time in minutes that a parked chat should wait before transfer to the specified ParkedChatExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedChatExtension


ParkedEmailExtension Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedEmailExtension Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked email extension for this user (use Property.ParkedEmailExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, string> ParkedEmailExtension { get; }
Visual Basic
Public ReadOnly Property ParkedEmailExtension As InheritableConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked email extension.

Remarks

The destination extension for a parked email that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedEmailTimeout
UserConfiguration..::..ParkedEmailTimeout


ParkedEmailTimeout Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedEmailTimeout Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked email timeout for this user (use Property.ParkedEmailTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, TimeSpan> ParkedEmailTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedEmailTimeout As InheritableConfigurationProperty(Of UserConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked email timeout.

Remarks

The maximum time in minutes that a parked email should wait before transfer to the specified ParkedEmailExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedEmailExtension


ParkedGenericObjectExtension Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedGenericObjectExtension Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked generic object extension for this user (use Property.ParkedGenericObjectExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, string> ParkedGenericObjectExtension { get; }
Visual Basic
Public ReadOnly Property ParkedGenericObjectExtension As InheritableConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked generic object extension.

Remarks

The destination extension for a parked generic object that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedGenericObjectTimeout
UserConfiguration..::..ParkedEmailTimeout


ParkedGenericObjectTimeout Property

[image]

IceLib Technical Reference
UserConfiguration..::..ParkedGenericObjectTimeout Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the parked generic object timeout for this user (use Property.ParkedGenericObjectTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, TimeSpan> ParkedGenericObjectTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedGenericObjectTimeout As InheritableConfigurationProperty(Of UserConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked generic object timeout.

Remarks

The maximum time in minutes that a parked generic object should wait before transfer to the specified ParkedGenericObjectExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ParkedGenericObjectExtension


PasswordPolicies Property

[image]

IceLib Technical Reference
UserConfiguration..::..PasswordPolicies Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the password policies for this user (use Property.PasswordPolicies).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, Collection<ConfigurationId>> PasswordPolicies { get; }
Visual Basic
Public ReadOnly Property PasswordPolicies As InheritableConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the password policies.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.
A password policy is a rules describing how users must change their password. When a password policy is added to a Role, the Role takes on those permissions. If a User is a member of that Role, the User automatically inherits the password policies assigned to the Role.
  • Inherited - The inherited password policies are accessible via the InheritedValue of this property.
  • Owned - To assign or remove a password policy on this User, modify the Value of this property. One or more password policies must already be defined to add a password policy in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..PasswordPolicyConfiguration
ININ.IceLib.Configuration..::..PasswordPolicyConfigurationList


PersonalInformation Property

[image]

IceLib Technical Reference
UserConfiguration..::..PersonalInformation Property
UserConfiguration Class See Also Send Feedback
Provides access to the various personal information properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PersonalInformationProperties PersonalInformation { get; }
Visual Basic
Public ReadOnly Property PersonalInformation As PersonalInformationProperties
    Get

Field Value

The personal information properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


PopTrackertoResolveContact Property

[image]

IceLib Technical Reference
UserConfiguration..::..PopTrackertoResolveContact Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing PopTrackertoResolveContact for this user (use Property.PopTrackertoResolveContact).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> PopTrackertoResolveContact { get; }
Visual Basic
Public ReadOnly Property PopTrackertoResolveContact As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing PopTrackertoResolveContact.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


PreferredLanguage Property

[image]

IceLib Technical Reference
UserConfiguration..::..PreferredLanguage Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the preferred language for this user (use Property.PreferredLanguage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> PreferredLanguage { get; }
Visual Basic
Public ReadOnly Property PreferredLanguage As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the preferred language.

Remarks

The preferred language is used for the prompts for this user. The valid values can be obtained from Languages by using the Name of the CultureInfo desired.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
SystemConfiguration..::..Languages


PropertiesChanged Property

[image]

IceLib Technical Reference
UserConfiguration..::..PropertiesChanged Property
UserConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<UserConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of UserConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


QueuePagePaneAllowChange Property

[image]

IceLib Technical Reference
UserConfiguration..::..QueuePagePaneAllowChange Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing QueuePagePaneAllowChange for this user (use Property.QueuePagePaneAllowChange).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> QueuePagePaneAllowChange { get; }
Visual Basic
Public ReadOnly Property QueuePagePaneAllowChange As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing QueuePagePaneAllowChange.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


QueuePageSelected Property

[image]

IceLib Technical Reference
UserConfiguration..::..QueuePageSelected Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing QueuePageSelected for this user (use Property.QueuePageSelected).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> QueuePageSelected { get; }
Visual Basic
Public ReadOnly Property QueuePageSelected As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing QueuePageSelected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


RedialInterval Property

[image]

IceLib Technical Reference
UserConfiguration..::..RedialInterval Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing RedialInterval for this user (use Property.RedialInterval).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, int> RedialInterval { get; }
Visual Basic
Public ReadOnly Property RedialInterval As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Integer)
    Get

Field Value

The property representing RedialInterval.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


RingWhenOnPhone Property

[image]

IceLib Technical Reference
UserConfiguration..::..RingWhenOnPhone Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing RingWhenOnPhone for this user (use Property.RingWhenOnPhone).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> RingWhenOnPhone { get; }
Visual Basic
Public ReadOnly Property RingWhenOnPhone As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing RingWhenOnPhone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Roles Property

[image]

IceLib Technical Reference
UserConfiguration..::..Roles Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the roles for this user (use Property.Roles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<UserConfiguration..::..Property, Collection<ConfigurationId>> Roles { get; }
Visual Basic
Public ReadOnly Property Roles As InheritableConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the roles.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.
A role is a set of permissions. When a Role is added to a Workgroup, the Workgroup takes on those permissions. If a User is a member of that Workgroup, the User automatically inherits the Roles assigned to the Workgroup.
  • Inherited - The inherited Roles are accessible via the InheritedValue of this property.
  • Owned - To assign or remove a role on this User, modify the Value of this property. One or more Roles must already be defined to add a Role in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..RoleConfiguration
ININ.IceLib.Configuration..::..RoleConfigurationList


ScreenCalls Property

[image]

IceLib Technical Reference
UserConfiguration..::..ScreenCalls Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ScreenCalls for this user (use Property.ScreenCalls).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ScreenCalls { get; }
Visual Basic
Public ReadOnly Property ScreenCalls As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ScreenCalls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


SecurityRights Property

[image]

IceLib Technical Reference
UserConfiguration..::..SecurityRights Property
UserConfiguration Class See Also Send Feedback
Provides access to the various security properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserSecurityRightsProperties<UserConfiguration, UserConfiguration..::..Property> SecurityRights { get; }
Visual Basic
Public ReadOnly Property SecurityRights As UserSecurityRightsProperties(Of UserConfiguration, UserConfiguration..::..Property)
    Get

Field Value

The user security rights properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


SelectInteractiononDisconnect Property

[image]

IceLib Technical Reference
UserConfiguration..::..SelectInteractiononDisconnect Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing SelectInteractiononDisconnect for this user (use Property.SelectInteractiononDisconnect).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> SelectInteractiononDisconnect { get; }
Visual Basic
Public ReadOnly Property SelectInteractiononDisconnect As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing SelectInteractiononDisconnect.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


ShowStatusInSysTray Property

[image]

IceLib Technical Reference
UserConfiguration..::..ShowStatusInSysTray Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing ShowStatusInSysTray for this user (use Property.ShowStatusInSysTray).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> ShowStatusInSysTray { get; }
Visual Basic
Public ReadOnly Property ShowStatusInSysTray As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing ShowStatusInSysTray.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Skills Property

[image]

IceLib Technical Reference
UserConfiguration..::..Skills Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the skills for this user (use Property.Skills).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DetailedInheritableConfigurationProperty<UserConfiguration..::..Property, Collection<SkillSettings>> Skills { get; }
Visual Basic
Public ReadOnly Property Skills As DetailedInheritableConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of SkillSettings))
    Get

Field Value

The property representing the skills.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.
  • Inherited - The inherited Skills are accessible via the InheritedValue of this property.
  • Owned - To assign or remove a skill on this User, modify the Value of this property. One or more Skills must already be defined to add a Skill in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration.DataTypes..::..SkillSettings
ININ.IceLib.Configuration..::..SkillConfiguration
ININ.IceLib.Configuration..::..SkillConfigurationList


StandardProperties Property

[image]

IceLib Technical Reference
UserConfiguration..::..StandardProperties Property
UserConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<UserConfiguration, UserConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of UserConfiguration, UserConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


StatisticsShiftStarts Property

[image]

IceLib Technical Reference
UserConfiguration..::..StatisticsShiftStarts Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the statistics shift starts for this user (use Property.StatisticsShiftStarts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<TimeSpan>> StatisticsShiftStarts { get; }
Visual Basic
Public ReadOnly Property StatisticsShiftStarts As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the statistics shift starts.

Remarks

This list of times determines the beginning time and duration of each shift for the members of the current Workgroup. These times are used to define (relative to the current time) the "current shift" and the "previous shift" in Interaction Supervisor. By default, three eight-hour shifts are defined from 12:00 midnight to 8:00 AM (0:00), 8:00 AM to 4:00 PM (8:00), and 4:00 PM to midnight (16:00). You can define as many shifts as you like, but the statistics are relative to the span of time defined in each shift. If your company has only one eight-hour shift, you should still define three eight-hour shifts around the times of your shift.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


StatusText Property

[image]

IceLib Technical Reference
UserConfiguration..::..StatusText Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing StatusText for this user (use Property.StatusText).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> StatusText { get; }
Visual Basic
Public ReadOnly Property StatusText As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing StatusText.

Remarks

This property is read-only and cannot be set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


TransactionId Property

[image]

IceLib Technical Reference
UserConfiguration..::..TransactionId Property
UserConfiguration Class See Also Send Feedback
Gets the transaction ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TransactionId { get; }
Visual Basic
Public ReadOnly Property TransactionId As Integer
    Get

Remarks

Valid values are obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). Commit()()()() and Delete()()()() operations called on configuration objects that have a valid transaction ID set will cause notifications for watched UserConfiguration objects that would be affected to be suspended until a call to EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is made with the associated transaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


UmDestination Property

[image]

IceLib Technical Reference
UserConfiguration..::..UmDestination Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the UM destination for this user (use Property.UmDestination).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> UmDestination { get; }
Visual Basic
Public ReadOnly Property UmDestination As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the UM destination.

Remarks

This is a UM station ID. To specify a UM destination of the IC server, use ICServerUMDestination.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
UserConfiguration..::..ICServerUMDestination


UmRemoteOverride Property

[image]

IceLib Technical Reference
UserConfiguration..::..UmRemoteOverride Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the UM remote override for this user (use Property.UmRemoteOverride).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> UmRemoteOverride { get; }
Visual Basic
Public ReadOnly Property UmRemoteOverride As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the UM remote override.

Remarks

The UM extension to use (instead of the standard IC extension).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


UseWkgRing Property

[image]

IceLib Technical Reference
UserConfiguration..::..UseWkgRing Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing UseWkgRing for this user (use Property.UseWkgRing).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> UseWkgRing { get; }
Visual Basic
Public ReadOnly Property UseWkgRing As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing UseWkgRing.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Utilizations Property

[image]

IceLib Technical Reference
UserConfiguration..::..Utilizations Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the media utilizations for this user (use Property.Utilizations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DetailedInheritableConfigurationProperty<UserConfiguration..::..Property, Collection<UtilizationSettings>> Utilizations { get; }
Visual Basic
Public ReadOnly Property Utilizations As DetailedInheritableConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of UtilizationSettings))
    Get

Field Value

The property representing the utilizations.

Remarks

Note
This is an InheritableConfigurationProperty<(Of <(<'TPropertyEnum, TValue>)>)> which means that values can be defined directly on this object or they can be inherited based on membership in other groups.
  • Inherited - The inherited Utilizations are accessible via the InheritedValue of this property.
  • Owned - To assign or remove a utilization on this User, modify the Value of this property. One or more Utilizations must already be defined to add a UtilizationSettings in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration.DataTypes..::..UtilizationSettings


VniStation Property

[image]

IceLib Technical Reference
UserConfiguration..::..VniStation Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing VniStation for this user (use Property.VniStation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> VniStation { get; }
Visual Basic
Public ReadOnly Property VniStation As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing VniStation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


WhisperToneLevel Property

[image]

IceLib Technical Reference
UserConfiguration..::..WhisperToneLevel Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the whisper tone level for this user (use Property.WhisperToneLevel).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, int> WhisperToneLevel { get; }
Visual Basic
Public ReadOnly Property WhisperToneLevel As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the whisper tone level.

Remarks

The volume level of the 'whisper' tone the agent hears when there is an ACD call to the workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace


Workgroups Property

[image]

IceLib Technical Reference
UserConfiguration..::..Workgroups Property
UserConfiguration Class See Also Send Feedback
Provides access to the property representing the workgroups for this user (use Property.Workgroups).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<ConfigurationId>> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfiguration Class
UserConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WorkgroupConfiguration
ININ.IceLib.Configuration..::..WorkgroupConfigurationList


UserConfiguration.Property Enumeration

[image]

IceLib Technical Reference
UserConfiguration..::..Property Enumeration
UserConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
AcdAgentGreeting | 1 | Represents the AcdAgentGreeting property.
AcdAgentGreetingFile | 2 | Represents the AcdAgentGreetingFile property.
AlertOnSecurityBelowRequestedLevel | 3 | Represents the AlertOnSecurityBelowRequestedLevel property.
AlertPaneAllowChange | 4 | Represents the AlertPaneAllowChange property.
Alias | 5 | Represents the Alias property.
Analyze | 6 | Represents the Analyze property.
AutoAnswerAcdInteractions | 7 | Represents the AutoAnswerAcdInteractions property.
AutoAnswerNonAcdInteractions | 8 | Represents the AutoAnswerNonAcdInteractions property.
CallbackEnabledWorkgroups | 9 | Represents the CallbackEnabledWorkgroups property.
ClientConfigDateLastModified | 10 | Represents the ClientConfigDateLastModified property.
ClientConfigurationTemplate | 11 | Represents the ClientConfigurationTemplate property.
ClientTemplates | 12 | Represents the ClientTemplates property.
ConfirmDial | 13 | Represents the ConfirmDial property.
ConfirmDragDrop | 14 | Represents the ConfirmDragDrop property.
Cost | 15 | Represents the Cost property.
DefaultWorkstation | 16 | Represents the DefaultWorkstation property.
EFaqSearchOption | 17 | Represents the EFaqSearchOption property.
EFaqSearchOptionAllowChange | 18 | Represents the EFaqSearchOptionAllowChange property.
ExcludeFromDirectory | 19 | Represents the ExcludeFromDirectory property.
ExtCallTimeout | 20 | Represents the ExtCallTimeout property.
ExtendedAbsencePrompt | 21 | Represents the ExtendedAbsencePrompt property.
Extension | 22 | Represents the Extension property.
FaxCapability | 23 | Represents the FaxCapability property.
FollowMeAllowChange | 24 | Represents the FollowMeAllowChange property.
HomeSite | 25 | Represents the HomeSite property.
InteractionDisconnectedAction | 26 | Represents the InteractionDisconnectedAction property.
InteractionMessageStoreMaxMessage | 27 | Obsolete. Represents the InteractionMessageStoreMaxMessage property.
InteractionMessageStoreMaxStorage | 28 | Obsolete. Represents the InteractionMessageStoreMaxStorage property.
InteractionOfferingAction | 29 | Represents the InteractionOfferingAction property.
InteractionOfferingTimeout | 30 | Represents the InteractionOfferingTimeout property.
LyncSipAddress | 31 | Represents the LyncSipAddress property.
LyncLineUri | 32 | Represents the LyncLineUri property.
LyncOption | 33 | Represents the LyncOption property.
LyncIntegrationEnabled | 34 | Represents the LyncIntegrationEnabled property.
ListenForSipRequests | 35 | Represents the ListenForSipRequests property.
MobileOfficeUser | 36 | Represents the MobileOfficeUser property.
MuteonTransfer | 37 | Represents the MuteonTransfer property.
MwiAddress | 38 | Represents the MwiAddress property.
MwiEnabled | 39 | Represents the MwiEnabled property.
MwiMode | 40 | Represents the MwiMode property.
MwiSmdiPhoneNumber | 41 | Obsolete. Represents the MwiSmdiPhoneNumber property.
MwiSmdiPort | 42 | Obsolete. Represents the MwiSmdiPort property.
NameSpellingsAsr | 44 | Represents the NameSpellingsAsr property.
NameSpellingTts | 45 | Represents the NameSpellingTts property.
NtDomainUser | 46 | Represents the NtDomainUser property.
OpenNewCallWindow | 47 | Represents the OpenNewCallWindow property.
OutboundAni | 48 | Represents the OutboundAni property.
ParkedCallExtension | 49 | Represents the ParkedCallExtension property.
ParkedCallTimeout | 50 | Represents the ParkedCallTimeout property.
ParkedChatExtension | 51 | Represents the ParkedChatExtension property.
ParkedChatTimeout | 52 | Represents the ParkedChatTimeout property.
ParkedEmailExtension | 53 | Represents the ParkedEmailExtension property.
ParkedEmailTimeout | 54 | Represents the ParkedEmailTimeout property.
ParkedGenericObjectExtension | 55 | Represents the ParkedGenericObjectExtension property.
ParkedGenericObjectTimeout | 56 | Represents the ParkedGenericObjectTimeout property.
PasswordPolicies | 57 | Represents the PasswordPolicies property.
PopTrackertoResolveContact | 58 | Represents the PopTrackertoResolveContact property.
PreferredLanguage | 59 | Represents the PreferredLanguage property.
QueuePagePaneAllowChange | 60 | Represents the QueuePagePaneAllowChange property.
QueuePageSelected | 61 | Represents the QueuePageSelected property.
RedialInterval | 62 | Represents the RedialInterval property.
RingWhenOnPhone | 63 | Represents the RingWhenOnPhone property.
Roles | 64 | Represents the Roles property.
ScreenCalls | 65 | Represents the ScreenCalls property.
SelectInteractiononDisconnect | 66 | Represents the SelectInteractiononDisconnect property.
ShowStatusInSysTray | 67 | Represents the ShowStatusInSysTray property.
Skills | 68 | Represents the Skills property.
StatisticsShiftStarts | 69 | Represents the StatisticsShiftStarts property.
StatusText | 70 | Represents the StatusText property.
UmDestination | 71 | Represents the UmDestination property.
UmRemoteOverride | 72 | Represents the UmRemoteOverride property.
UseWkgRing | 73 | Represents the UseWkgRing property.
Utilizations | 74 | Represents the Utilizations property.
VniStation | 75 | Represents the VniStation property.
WhisperToneLevel | 76 | Represents the WhisperToneLevel property.
Workgroups | 77 | Represents the Workgroups property.
License_AdditionalLicenses | 3500 | Represents the AdditionalLicenses property.
License_AllocationType | 3501 | Represents the LicenseAllocationType property.
License_HasClientAccess | 3502 | Represents the HasClientAccess property.
License_InteractionProcessAutomationType | 3503 | Represents the InteractionProcessAutomationLicenseType property.
License_LicenseActive | 3504 | Represents the LicenseActive property.
License_MediaLevel | 3505 | Represents the MediaLevel property.
License_MediaTypes | 3506 | Represents the MediaTypes property.
Mailbox_DirectoryMoniker | 6500 | Represents the DirectoryMoniker property.
Mailbox_DisplayName | 6501 | Represents the DisplayName property.
Mailbox_EmailAddress | 6502 | Represents the EmailAddress property.
Mailbox_MailboxMoniker | 6503 | Represents the MailboxMoniker property.
Mailbox_Type | 6504 | Represents the Type property.
PersonalInformation_AssistantName | 2500 | Represents the AssistantName property.
PersonalInformation_City | 2501 | Represents the City property.
PersonalInformation_CompanyName | 2502 | Represents the CompanyName property.
PersonalInformation_Country | 2503 | Represents the Country property.
PersonalInformation_DepartmentName | 2504 | Represents the DepartmentName property.
PersonalInformation_EmailAddress | 2505 | Represents the EmailAddress property.
PersonalInformation_EmailAlias | 2506 | Represents the EmailAlias property.
PersonalInformation_GivenName | 2507 | Represents the GivenName property.
PersonalInformation_Notes | 2508 | Represents the Notes property.
PersonalInformation_OfficeLocation | 2509 | Represents the OfficeLocation property.
PersonalInformation_PhoneNumberOfAssistant | 2510 | Represents the PhoneNumberOfAssistant property.
PersonalInformation_PhoneNumberOfBusiness1 | 2511 | Represents the PhoneNumberOfBusiness1 property.
PersonalInformation_PhoneNumberOfBusiness2 | 2512 | Represents the PhoneNumberOfBusiness2 property.
PersonalInformation_PhoneNumberOfFax | 2513 | Represents the PhoneNumberOfFax property.
PersonalInformation_PhoneNumberOfHome1 | 2514 | Represents the PhoneNumberOfHome1 property.
PersonalInformation_PhoneNumberOfHome2 | 2515 | Represents the PhoneNumberOfHome2 property.
PersonalInformation_PhoneNumberOfMobile | 2516 | Represents the PhoneNumberOfMobile property.
PersonalInformation_PhoneNumberOfPager | 2517 | Represents the PhoneNumberOfPager property.
PersonalInformation_PostalCode | 2518 | Represents the PostalCode property.
PersonalInformation_StateOrProvince | 2519 | Represents the StateOrProvince property.
PersonalInformation_StreetAddress | 2520 | Represents the StreetAddress property.
PersonalInformation_Surname | 2521 | Represents the Surname property.
PersonalInformation_Title | 2522 | Represents the Title property.
AccessRights_ActivateOthers | 1500 | Represents the ActivateOthers property.
AccessRights_ActivateSelf | 1501 | Represents the ActivateSelf property.
AccessRights_CanEditAccessRights | 1502 | Represents the CanEditAccessRights property.
AccessRights_ChangeUserStatus | 1503 | Represents the ChangeUserStatus property.
AccessRights_ClientButtons | 1504 | Represents the ClientButtons property.
AccessRights_CoachLineQueue | 1505 | Represents the CoachLineQueue property.
AccessRights_CoachStationQueue | 1506 | Represents the CoachStationQueue property.
AccessRights_CoachUserQueue | 1507 | Represents the CoachUserQueue property.
AccessRights_CoachWorkgroupQueue | 1508 | Represents the CoachWorkgroupQueue property.
AccessRights_CreateSchedulingUnitTimeoffRequests | 1509 | Represents the CreateSchedulingUnitTimeoffRequests property.
AccessRights_DeleteSchedulingUnitTimeoffRequests | 1510 | Represents the DeleteSchedulingUnitTimeoffRequests property.
AccessRights_DisconnectUserQueue | 1511 | Represents the DisconnectUserQueue property.
AccessRights_DisconnectLineQueue | 1512 | Represents the DisconnectLineQueue property.
AccessRights_DisconnectStationQueue | 1513 | Represents the DisconnectStationQueue property.
AccessRights_DisconnectWorkgroupQueue | 1514 | Represents the DisconnectWorkgroupQueue property.
AccessRights_EFaqs | 1515 | Represents the EFaqs property.
AccessRights_FollowMePhoneNumberClassifications | 1516 | Represents the FollowMePhoneNumberClassifications property.
AccessRights_ForwardPhoneNumberClassifications | 1517 | Represents the ForwardPhoneNumberClassifications property.
AccessRights_ViewHistoricalReports | 1518 | Represents the ViewHistoricalReports property.
AccessRights_HoldStationQueue | 1519 | Represents the HoldStationQueue property.
AccessRights_HoldUserQueue | 1520 | Represents the HoldUserQueue property.
AccessRights_InteractionConferenceRestrictRooms | 1521 | Represents the InteractionConferenceRestrictRooms property.
AccessRights_JoinLineQueue | 1522 | Represents the JoinLineQueue property.
AccessRights_JoinStationQueue | 1523 | Represents the JoinStationQueue property.
AccessRights_JoinUserQueue | 1524 | Represents the JoinUserQueue property.
AccessRights_JoinWorkgroupQueue | 1525 | Represents the JoinWorkgroupQueue property.
AccessRights_LaunchableProcessList | 1526 | Represents the LaunchableProcessList property.
AccessRights_ListAccountCodes | 1527 | Represents the ListAccountCodes property.
AccessRights_ListenLineQueue | 1528 | Represents the ListenLineQueue property.
AccessRights_ListenStationQueue | 1529 | Represents the ListenStationQueue property.
AccessRights_ListenUserQueue | 1530 | Represents the ListenUserQueue property.
AccessRights_ListenWorkgroupQueue | 1531 | Represents the ListenWorkgroupQueue property.
AccessRights_LoginStation | 1532 | Represents the LoginStation property.
AccessRights_ManageProcessList | 1533 | Represents the ManageProcessList property.
AccessRights_Miscellaneous | 1534 | Represents the Miscellaneous property.
AccessRights_ModifyAttendantEmailProfiles | 1535 | Represents the ModifyAttendantEmailProfiles property.
AccessRights_ModifyAttendantInboundProfiles | 1536 | Represents the ModifyAttendantInboundProfiles property.
AccessRights_ModifyAttendantOperatorProfiles | 1537 | Represents the ModifyAttendantOperatorProfiles property.
AccessRights_ModifyAttendantOutboundProfiles | 1538 | Represents the ModifyAttendantOutboundProfiles property.
AccessRights_ModifyFeedbackSurveys | 1539 | Represents the ModifyFeedbackSurveys property.
AccessRights_ModifyRecorderQuestionnaires | 1540 | Represents the ModifyRecorderQuestionnaires property.
AccessRights_MuteStationQueue | 1541 | Represents the MuteStationQueue property.
AccessRights_MuteUserQueue | 1542 | Represents the MuteUserQueue property.
AccessRights_ModifyCampaignsAgentlessCallingMode | 1543 | Obsolete. Represents the ModifyCampaignsAgentlessCallingMode property.
AccessRights_ModifyCampaignsAutomaticTimezoneMapping | 1544 | Obsolete. Represents the ModifyCampaignsAutomaticTimezoneMapping property.
AccessRights_ModifyCampaignsLineSettings | 1545 | Obsolete. Represents the ModifyCampaignsLineSettings property.
AccessRights_ModifyCampaignList | 1546 | Represents the ModifyCampaignList property.
AccessRights_ModifyCampaignsMaxLinesPerCampaign | 1547 | Obsolete. Represents the ModifyCampaignsMaxLinesPerCampaign property.
AccessRights_ModifyCampaignStatus | 1548 | Obsolete. Represents the ModifyCampaignStatus property.
AccessRights_ModifyPolicySetsBehaviorTypeCustomHandler | 1549 | Obsolete. Represents the ModifyPolicySetsBehaviorTypeCustomHandler property.
AccessRights_ModifyPolicySetsBehaviorTypeEventLog | 1550 | Obsolete. Represents the ModifyPolicySetsBehaviorTypeEventLog property.
AccessRights_ModifySchedulingUnitTimeoffRequests | 1551 | Represents the ModifySchedulingUnitTimeoffRequests property.
AccessRights_ModifyRuleSetsCustomHandler | 1552 | Obsolete. Represents the ModifyRuleSetsCustomHandler property.
AccessRights_ModifyRuleSetsEventLog | 1553 | Obsolete. Represents the ModifyRuleSetsEventLog property.
AccessRights_PhoneNumberClassifications | 1554 | Represents the PhoneNumberClassifications property.
AccessRights_PickupLineQueue | 1555 | Represents the PickupLineQueue property.
AccessRights_PickupStationQueue | 1556 | Represents the PickupStationQueue property.
AccessRights_PickupUserQueue | 1557 | Represents the PickupUserQueue property.
AccessRights_PickupWorkgroupQueue | 1558 | Represents the PickupWorkgroupQueue property.
AccessRights_PreviewEmailUserQueue | 1559 | Represents the PreviewEmailUserQueue property.
AccessRights_PreviewEmailWorkgroupQueue | 1560 | Represents the PreviewEmailWorkgroupQueue property.
AccessRights_InteractionClientPlugins | 1561 | Represents the InteractionClientPlugins property.
AccessRights_RecordLineQueue | 1562 | Represents the RecordLineQueue property.
AccessRights_RecordStationQueue | 1563 | Represents the RecordStationQueue property.
AccessRights_RecordUserQueue | 1564 | Represents the RecordUserQueue property.
AccessRights_RecordWorkgroupQueue | 1565 | Represents the RecordWorkgroupQueue property.
AccessRights_ResponseManagementDocuments | 1566 | Represents the ResponseManagementDocuments property.
AccessRights_StatusMessages | 1567 | Represents the StatusMessages property.
AccessRights_SubstituteQueueControlColumns | 1568 | Represents the SubstituteQueueControlColumns property.
AccessRights_TransferLineQueue | 1569 | Represents the TransferLineQueue property.
AccessRights_TransferStationQueue | 1570 | Represents the TransferStationQueue property.
AccessRights_TransferUserQueue | 1571 | Represents the TransferUserQueue property.
AccessRights_TransferWorkgroupQueue | 1572 | Represents the TransferWorkgroupQueue property.
AccessRights_TuiPhoneNumberClassifications | 1573 | Represents the TuiPhoneNumberClassifications property.
AccessRights_ViewAttendantEmailProfileInSearch | 1574 | Represents the ViewAttendantEmailProfileInSearch property.
AccessRights_ViewAttendantEmailProfiles | 1575 | Represents the ViewAttendantEmailProfiles property.
AccessRights_ViewAttendantInboundProfileInSearch | 1576 | Represents the ViewAttendantInboundProfileInSearch property.
AccessRights_ViewAttendantInboundProfiles | 1577 | Represents the ViewAttendantInboundProfiles property.
AccessRights_ViewAttendantOperatorProfileInSearch | 1578 | Represents the ViewAttendantOperatorProfileInSearch property.
AccessRights_ViewAttendantOperatorProfiles | 1579 | Represents the ViewAttendantOperatorProfiles property.
AccessRights_ViewAttendantOutboundProfileInSearch | 1580 | Represents the ViewAttendantOutboundProfileInSearch property.
AccessRights_ViewAttendantOutboundProfiles | 1581 | Represents the ViewAttendantOutboundProfiles property.
AccessRights_ViewFeedbackSurveys | 1582 | Represents the ViewFeedbackSurveys property.
AccessRights_ViewCampaignsAgentlessCallingMode | 1583 | Obsolete. Represents the ViewCampaignsAgentlessCallingMode property.
AccessRights_ViewCampaignsAutomaticTimezoneMapping | 1584 | Obsolete. Represents the ViewCampaignsAutomaticTimezoneMapping property.
AccessRights_ViewCampaignsLineSettings | 1585 | Obsolete. Represents the ViewCampaignsLineSettings property.
AccessRights_ViewCampaignList | 1586 | Represents the ViewCampaignList property.
AccessRights_ViewCampaignsMaxLinesPerCampaign | 1587 | Obsolete. Represents the ViewCampaignsMaxLinesPerCampaign property.
AccessRights_ViewCampaignStatus | 1588 | Obsolete. Represents the ViewCampaignStatus property.
AccessRights_ViewGeneralDirectories | 1589 | Represents the ViewGeneralDirectories property.
AccessRights_ViewIndividualStatistics | 1590 | Represents the ViewIndividualStatistics property.
AccessRights_ViewLayoutList | 1591 | Represents the ViewLayoutList property.
AccessRights_ViewLineQueue | 1592 | Represents the ViewLineQueue property.
AccessRights_ViewModifyOptimizerAll | 1593 | Represents the ViewModifyOptimizerAll property.
AccessRights_ViewOptimizerSchedulingUnits | 1594 | Obsolete. Represents the ViewOptimizerSchedulingUnits property.
AccessRights_ViewOptimizerForecasts | 1595 | Represents the ViewOptimizerForecasts property.
AccessRights_ModifyOptimizerForecasts | 1596 | Represents the ModifyOptimizerForecasts property.
AccessRights_CreateOptimizerForecasts | 1597 | Represents the CreateOptimizerForecasts property.
AccessRights_DeleteOptimizerForecasts | 1598 | Represents the DeleteOptimizerForecasts property.
AccessRights_ViewPolicySetsBehaviorTypeCustomHandler | 1599 | Obsolete. Represents the ViewPolicySetsBehaviorTypeCustomHandler property.
AccessRights_ViewPolicySetsBehaviorTypeEventLog | 1600 | Obsolete. Represents the ViewPolicySetsBehaviorTypeEventLog property.
AccessRights_ViewPositionsList | 1601 | Represents the ViewPositionsList property.
AccessRights_ViewSchedulingUnitIntradayMonitoring | 1602 | Represents the ViewSchedulingUnitIntradayMonitoring property.
AccessRights_ViewSchedulingUnitSchedulePreferences | 1603 | Represents the ViewSchedulingUnitSchedulePreferences property.
AccessRights_ViewSchedulingUnitListRealTimeAdherence | 1604 | Represents the ViewSchedulingUnitListRealTimeAdherence property.
AccessRights_ViewSchedulingUnitTimeoffRequests | 1605 | Represents the ViewSchedulingUnitTimeoffRequests property.
AccessRights_ModifySchedulingUnitListRealTimeAdherence | 1606 | Represents the ModifySchedulingUnitListRealTimeAdherence property.
AccessRights_ViewSchedulingUnitConfiguration | 1607 | Represents the ViewSchedulingUnitConfiguration property.
AccessRights_ModifySchedulingUnitConfiguration | 1608 | Represents the ModifySchedulingUnitConfiguration property.
AccessRights_ViewSchedulingUnitAgentConstraints | 1609 | Represents the ViewSchedulingUnitAgentConstraints property.
AccessRights_ModifySchedulingUnitAgentConstraints | 1610 | Represents the ModifySchedulingUnitAgentConstraints property.
AccessRights_CreateSchedulingUnitAgentConstraints | 1611 | Represents the CreateSchedulingUnitAgentConstraints property.
AccessRights_DeleteSchedulingUnitAgentConstraints | 1612 | Represents the DeleteSchedulingUnitAgentConstraints property.
AccessRights_ViewSchedulingUnitAgentGroups | 1613 | Represents the ViewSchedulingUnitAgentGroups property.
AccessRights_ModifySchedulingUnitAgentGroups | 1614 | Represents the ModifySchedulingUnitAgentGroups property.
AccessRights_CreateSchedulingUnitAgentGroups | 1615 | Represents the CreateSchedulingUnitAgentGroups property.
AccessRights_DeleteSchedulingUnitAgentGroups | 1616 | Represents the DeleteSchedulingUnitAgentGroups property.
AccessRights_ViewSchedulingUnitSchedules | 1617 | Represents the ViewSchedulingUnitSchedules property.
AccessRights_ModifySchedulingUnitSchedules | 1618 | Represents the ModifySchedulingUnitSchedules property.
AccessRights_CreateSchedulingUnitSchedules | 1619 | Represents the CreateSchedulingUnitSchedules property.
AccessRights_DeleteSchedulingUnitSchedules | 1620 | Represents the DeleteSchedulingUnitSchedules property.
AccessRights_ViewSchedulingUnitShiftRotations | 1621 | Represents the ViewSchedulingUnitShiftRotations property.
AccessRights_ModifySchedulingUnitShiftRotations | 1622 | Represents the ModifySchedulingUnitShiftRotations property.
AccessRights_CreateSchedulingUnitShiftRotations | 1623 | Represents the CreateSchedulingUnitShiftRotations property.
AccessRights_DeleteSchedulingUnitShiftRotations | 1624 | Represents the DeleteSchedulingUnitShiftRotations property.
AccessRights_ViewSchedulingUnitShifts | 1625 | Represents the ViewSchedulingUnitShifts property.
AccessRights_ModifySchedulingUnitShifts | 1626 | Represents the ModifySchedulingUnitShifts property.
AccessRights_CreateSchedulingUnitShifts | 1627 | Represents the CreateSchedulingUnitShifts property.
AccessRights_DeleteSchedulingUnitShifts | 1628 | Represents the DeleteSchedulingUnitShifts property.
AccessRights_ViewProcessList | 1629 | Represents the ViewProcessList property.
AccessRights_ViewQueueControlColumns | 1630 | Represents the ViewQueueControlColumns property.
AccessRights_ViewRecorderQuestionnaires | 1631 | Represents the ViewRecorderQuestionnaires property.
AccessRights_ViewReport | 1632 | Represents the ViewReport property.
AccessRights_ViewRuleSetsCustomHandler | 1633 | Obsolete. Represents the ViewRuleSetsCustomHandler property.
AccessRights_ViewRuleSetsEventLog | 1634 | Obsolete. Represents the ViewRuleSetsEventLog property.
AccessRights_ViewSkillList | 1635 | Represents the ViewSkillList property.
AccessRights_ViewStationGroups | 1636 | Represents the ViewStationGroups property.
AccessRights_ViewStationGroupsInSearch | 1637 | Represents the ViewStationGroupsInSearch property.
AccessRights_ViewStationQueue | 1638 | Represents the ViewStationQueue property.
AccessRights_ViewStationQueueInSearch | 1639 | Represents the ViewStationQueueInSearch property.
AccessRights_ViewStatusColumns | 1640 | Represents the ViewStatusColumns property.
AccessRights_ViewUserInteractionHistory | 1641 | Represents the ViewUserInteractionHistory property.
AccessRights_ViewUserQueue | 1642 | Represents the ViewUserQueue property.
AccessRights_ViewWorkgroup | 1643 | Represents the ViewWorkgroup property.
AccessRights_ViewWorkgroupQueue | 1644 | Represents the ViewWorkgroupQueue property.
AccessRights_ViewWorkgroupQueueInSearch | 1645 | Represents the ViewWorkgroupQueueInSearch property.
AccessRights_ViewWorkgroupStatistics | 1646 | Represents the ViewWorkgroupStatistics property.
AccessRights_ViewDataSource | 1647 | Represents the ViewDataSource property.
AccessRights_OptimizerViewShiftTrading | 1648 | Represents the OptimizerViewShiftTrading property.
AccessRights_OptimizerModifyShiftTrading | 1649 | Represents the OptimizerModifyShiftTrading property.
AccessRights_SnipLineQueue | 1650 | Represents the SnipLineQueue property.
AccessRights_SnipStationQueue | 1651 | Represents the SnipStationQueue property.
AccessRights_SnipUserQueue | 1652 | Represents the SnipUserQueue property.
AccessRights_SnipWorkgroupQueue | 1653 | Represents the SnipWorkgroupQueue property.
AdministrativeRights_AccountCodeList | 2000 | Represents the AccountCodeList property.
AdministrativeRights_AccumulatorList | 2001 | Represents the AccumulatorList property.
AdministrativeRights_Actions | 2002 | Represents the Actions property.
AdministrativeRights_AudioSources | 2003 | Represents the AudioSources property.
AdministrativeRights_CanEditAdministrativeRights | 2004 | Represents the CanEditAdministrativeRights property.
AdministrativeRights_ClientButtons | 2005 | Represents the ClientButtons property.
AdministrativeRights_ClientConfigurationConfiguration | 2006 | Represents the ClientConfigurationConfiguration property.
AdministrativeRights_ClientConfigurationTemplates | 2007 | Represents the ClientConfigurationTemplates property.
AdministrativeRights_Collective | 2008 | Represents the Collective property.
AdministrativeRights_ContactListSources | 2009 | Represents the ContactListSources property.
AdministrativeRights_DataManagerConfiguration | 2010 | Represents the DataManagerConfiguration property.
AdministrativeRights_DefaultIPPhoneConfiguration | 2011 | Represents the DefaultIPPhoneConfiguration property.
AdministrativeRights_DefaultLocationConfiguration | 2012 | Represents the DefaultLocationConfiguration property.
AdministrativeRights_DefaultStationConfiguration | 2013 | Represents the DefaultStationConfiguration property.
AdministrativeRights_DefaultUserConfiguration | 2014 | Represents the DefaultUserConfiguration property.
AdministrativeRights_DnisMappingsConfiguration | 2015 | Represents the DnisMappingsConfiguration property.
AdministrativeRights_EFaq | 2016 | Represents the EFaq property.
AdministrativeRights_FaxConfiguration | 2017 | Represents the FaxConfiguration property.
AdministrativeRights_FaxGroups | 2018 | Represents the FaxGroups property.
AdministrativeRights_Handlers | 2019 | Represents the Handlers property.
AdministrativeRights_ICDataSources | 2020 | Represents the ICDataSources property.
AdministrativeRights_ImageResources | 2021 | Represents the ImageResources property.
AdministrativeRights_InitializationFunctions | 2022 | Represents the InitializationFunctions property.
AdministrativeRights_InteractionAnalyzerKeywordSets | 2023 | Represents the InteractionAnalyzerKeywordSets property.
AdministrativeRights_InteractionConferenceConfiguration | 2024 | Represents the InteractionConferenceConfiguration property.
AdministrativeRights_InteractionConferenceRooms | 2025 | Represents the InteractionConferenceRooms property.
AdministrativeRights_InteractionDialerCallLists | 2026 | Represents the InteractionDialerCallLists property.
AdministrativeRights_InteractionDialerCampaigns | 2027 | Represents the InteractionDialerCampaigns property.
AdministrativeRights_InteractionDialerConfiguration | 2028 | Represents the InteractionDialerConfiguration property.
AdministrativeRights_InteractionDialerPolicySets | 2029 | Represents the InteractionDialerPolicySets property.
AdministrativeRights_InteractionDialerRuleSets | 2030 | Represents the InteractionDialerRuleSets property.
AdministrativeRights_InteractionDialerSchedules | 2031 | Represents the InteractionDialerSchedules property.
AdministrativeRights_InteractionDialerScripts | 2032 | Represents the InteractionDialerScripts property.
AdministrativeRights_InteractionDialerSkillSets | 2033 | Represents the InteractionDialerSkillSets property.
AdministrativeRights_InteractionDialerStageSets | 2034 | Represents the InteractionDialerStageSets property.
AdministrativeRights_InteractionDialerZoneSets | 2035 | Represents the InteractionDialerZoneSets property.
AdministrativeRights_InteractionFeedbackConfiguration | 2036 | Represents the InteractionFeedbackConfiguration property.
AdministrativeRights_InteractionOptimizerActivityTypesConfiguration | 2037 | Obsolete. Represents the InteractionOptimizerActivityTypesConfiguration property.
AdministrativeRights_InteractionOptimizerAdvancedConfiguration | 2038 | Represents the InteractionOptimizerAdvancedConfiguration property.
AdministrativeRights_InteractionOptimizerAgentsConfiguration | 2039 | Represents the InteractionOptimizerAgentsConfiguration property.
AdministrativeRights_InteractionOptimizerDayClassificationsConfiguration | 2040 | Obsolete. Represents the InteractionOptimizerDayClassificationsConfiguration property.
AdministrativeRights_InteractionOptimizerForecastsAndSchedulesConfiguration | 2041 | Obsolete. Represents the InteractionOptimizerForecastsAndSchedulesConfiguration property.
AdministrativeRights_InteractionOptimizerSchedulingUnits | 2042 | Obsolete. Represents the InteractionOptimizerSchedulingUnits property.
AdministrativeRights_InteractionProcessAutomation | 2043 | Represents the InteractionProcessAutomation property.
AdministrativeRights_InteractionProcessorTables | 2044 | Represents the InteractionProcessorTables property.
AdministrativeRights_InteractionRecorderConfiguration | 2045 | Represents the InteractionRecorderConfiguration property.
AdministrativeRights_InteractionTrackerConfiguration | 2046 | Represents the InteractionTrackerConfiguration property.
AdministrativeRights_IPPhoneRegistrationGroups | 2047 | Represents the IPPhoneRegistrationGroups property.
AdministrativeRights_IPPhoneRingSets | 2048 | Represents the IPPhoneRingSets property.
AdministrativeRights_IPPhones | 2049 | Represents the IPPhones property.
AdministrativeRights_IPPhoneTemplates | 2050 | Represents the IPPhoneTemplates property.
AdministrativeRights_Layouts | 2051 | Represents the Layouts property.
AdministrativeRights_LicensesAllocationConfiguration | 2052 | Represents the LicensesAllocationConfiguration property.
AdministrativeRights_LineGroups | 2053 | Represents the LineGroups property.
AdministrativeRights_Lines | 2054 | Represents the Lines property.
AdministrativeRights_Locations | 2055 | Represents the Locations property.
AdministrativeRights_LogRetrievalAssistantConfiguration | 2056 | Represents the LogRetrievalAssistantConfiguration property.
AdministrativeRights_MailConfiguration | 2057 | Represents the MailConfiguration property.
AdministrativeRights_MasterAdministrator | 2058 | Represents the MasterAdministrator property.
AdministrativeRights_MediaServersConfiguration | 2059 | Represents the MediaServersConfiguration property.
AdministrativeRights_MrcpConfiguration | 2060 | Represents the MrcpConfiguration property.
AdministrativeRights_OcsActiveDirectories | 2061 | Represents the OcsActiveDirectories property.
AdministrativeRights_OcsConfiguration | 2062 | Represents the OcsConfiguration property.
AdministrativeRights_OcsStatusMessages | 2063 | Represents the OcsStatusMessages property.
AdministrativeRights_PagingCarriers | 2064 | Represents the PagingCarriers property.
AdministrativeRights_PasswordPolicies | 2065 | Represents the PasswordPolicies property.
AdministrativeRights_PasswordPoliciesConfiguration | 2066 | Represents the PasswordPoliciesConfiguration property.
AdministrativeRights_PeerSitesConfiguration | 2067 | Represents the PeerSitesConfiguration property.
AdministrativeRights_PhoneNumbersConfiguration | 2068 | Represents the PhoneNumbersConfiguration property.
AdministrativeRights_Positions | 2069 | Represents the Positions property.
AdministrativeRights_ProblemReporterConfiguration | 2070 | Represents the ProblemReporterConfiguration property.
AdministrativeRights_QueueControlColumns | 2071 | Represents the QueueControlColumns property.
AdministrativeRights_ReportLogs | 2072 | Represents the ReportLogs property.
AdministrativeRights_Reports | 2073 | Represents the Reports property.
AdministrativeRights_ResponseManagement | 2074 | Represents the ResponseManagement property.
AdministrativeRights_Roles | 2075 | Represents the Roles property.
AdministrativeRights_SalesforceCtis | 2076 | Obsolete. Represents the SalesforceCtis property.
AdministrativeRights_SametimeConfiguration | 2077 | Represents the SametimeConfiguration property.
AdministrativeRights_Schedules | 2078 | Represents the Schedules property.
AdministrativeRights_SelectionRuleList | 2079 | Represents the SelectionRuleList property.
AdministrativeRights_SecureInputForms | 2080 | Represents the SecureInputForms property.
AdministrativeRights_ServerParameter | 2081 | Represents the ServerParameter property.
AdministrativeRights_ServersConfiguration | 2082 | Represents the ServersConfiguration property.
AdministrativeRights_SessionManagerServerConfiguration | 2083 | Represents the SessionManagerServerConfiguration property.
AdministrativeRights_SingleSignOnIdentityProviders | 2106 | Represents the SingleSignOnIdentityProviders property.
AdministrativeRights_SingleSignOnSecureTokenServer | 2107 | Represents the SingleSignOnSecureTokenServer property.
AdministrativeRights_SipBridge | 2084 | Represents the SipBridge property.
AdministrativeRights_SipProxyConfiguration | 2085 | Represents the SipProxyConfiguration property.
AdministrativeRights_Skills | 2086 | Represents the Skills property.
AdministrativeRights_SmsBroker | 2087 | Represents the SmsBroker property.
AdministrativeRights_SmsConfiguration | 2088 | Represents the SmsConfiguration property.
AdministrativeRights_SpeechRecognitionConfiguration | 2089 | Represents the SpeechRecognitionConfiguration property.
AdministrativeRights_StationGroups | 2090 | Represents the StationGroups property.
AdministrativeRights_Stations | 2091 | Represents the Stations property.
AdministrativeRights_StationTemplates | 2092 | Represents the StationTemplates property.
AdministrativeRights_StatusMessages | 2093 | Represents the StatusMessages property.
AdministrativeRights_StreamingAudioMonitorProfiles | 2108 | Represents the StreamingAudioMonitorProfiles property.
AdministrativeRights_StructuredParameters | 2094 | Represents the StructuredParameters property.
AdministrativeRights_SystemConfiguration | 2095 | Represents the SystemConfiguration property.
AdministrativeRights_SystemParameters | 2096 | Represents the SystemParameters property.
AdministrativeRights_Users | 2097 | Represents the Users property.
AdministrativeRights_VoiceModules | 2098 | Represents the VoiceModules property.
AdministrativeRights_WebServicesParameters | 2099 | Represents the WebServicesParameters property.
AdministrativeRights_Workgroups | 2100 | Represents the Workgroups property.
AdministrativeRights_WrapUpCodes | 2101 | Represents the WrapUpCodes property.
AdministrativeRights_WrapUpCategories | 2102 | Represents the WrapUpCategories property.
AdministrativeRights_CanPublishClientTemplates | 2103 | Represents the CanPublishClientTemplates property.
AdministrativeRights_MrcpServerList | 2104 | Represents the MrcpServerList property.
AdministrativeRights_WebServicesConfiguration | 2105 | Represents the WebServicesConfiguration property.
SecurityRights_AccessAllInteractionConferences | 1000 | Represents the AccessAllInteractionConferences property.
SecurityRights_AccessOwnedInteractionConferences | 1001 | Represents the AccessOwnedInteractionConferences property.
SecurityRights_AccountCodeVerification | 1002 | Represents the AccountCodeVerification property.
SecurityRights_AddIndividuals | 1003 | Represents the AddIndividuals property.
SecurityRights_AddOrganizations | 1004 | Represents the AddOrganizations property.
SecurityRights_AgentPreferences | 1005 | Represents the AgentPreferences property.
SecurityRights_AllowAccessToProblemReporter | 1006 | Represents the AllowAccessToProblemReporter property.
SecurityRights_AlertAdministrator | 1007 | Represents the AlertAdministrator property.
SecurityRights_AllowAgentRules | 1008 | Represents the AllowAgentRules property.
SecurityRights_AllowAgentScheduleBidding | 1009 | Represents the AllowAgentScheduleBidding property.
SecurityRights_AllowAgentSeeRelativeRank | 1010 | Represents the AllowAgentSeeRelativeRank property.
SecurityRights_AllowAgentSeeOwnRank | 1011 | Represents the AllowAgentSeeOwnRank property.
SecurityRights_AllowEmailAccessViaTui | 1012 | Represents the AllowEmailAccessViaTui property.
SecurityRights_AllowEmailAlerts | 1013 | Represents the AllowEmailAlerts property.
SecurityRights_AllowFaxAccessViaTui | 1014 | Represents the AllowFaxAccessViaTui property.
SecurityRights_AllowHandlerAlerts | 1015 | Represents the AllowHandlerAlerts property.
SecurityRights_AllowIntercomChat | 1016 | Represents the AllowIntercomChat property.
SecurityRights_AllowMiniMode | 1017 | Represents the AllowMiniMode property.
SecurityRights_AllowMemoAlerts | 1018 | Represents the AllowMemoAlerts property.
SecurityRights_AllowMonitorColumns | 1019 | Represents the AllowMonitorColumns property.
SecurityRights_AllowMultipleCalls | 1020 | Represents the AllowMultipleCalls property.
SecurityRights_AllowPersistentConnections | 1021 | Represents the AllowPersistentConnections property.
SecurityRights_AllowReceiveVoicemail | 1022 | Represents the AllowReceiveVoicemail property.
SecurityRights_AllowRelatedInteractionsPage | 1023 | Represents the AllowRelatedInteractionsPage property.
SecurityRights_AllowResponseManagement | 1024 | Represents the AllowResponseManagement property.
SecurityRights_AllowSpeedDials | 1025 | Represents the AllowSpeedDials property.
SecurityRights_AllowStatusNotes | 1026 | Represents the AllowStatusNotes property.
SecurityRights_AllowUserDefinedTelephoneNumberOnRemoteLogin | 1027 | Represents the AllowUserDefinedTelephoneNumberOnRemoteLogin property.
SecurityRights_AllowVideo | 1028 | Represents the AllowVideo property.
SecurityRights_AllowVoiceMaiAccessViaTui | 1029 | Represents the AllowVoiceMaiAccessViaTui property.
SecurityRights_AllowAlertProgramming | 1030 | Represents the AllowAlertProgramming property.
SecurityRights_AllowWorkgroupStats | 1031 | Represents the AllowWorkgroupStats property.
SecurityRights_CanCoachInteractions | 1032 | Represents the CanCoachInteractions property.
SecurityRights_CanConferenceCalls | 1033 | Represents the CanConferenceCalls property.
SecurityRights_CanCreateAlertSets | 1034 | Represents the CanCreateAlertSets property.
SecurityRights_CanShareAlertSets | 1035 | Represents the CanShareAlertSets property.
SecurityRights_CanCreateOptimizerActivityCodes | 1036 | Represents the CanCreateOptimizerActivityCodes property.
SecurityRights_CanCreateQuestionnaireDirectories | 1037 | Represents the CanCreateQuestionnaireDirectories property.
SecurityRights_CanDeleteOptimizerActivityCodes | 1038 | Represents the CanDeleteOptimizerActivityCodes property.
SecurityRights_CanDisconnectInteractions | 1039 | Represents the CanDisconnectInteractions property.
SecurityRights_CanInitiateSecureInput | 1040 | Represents the CanInitiateSecureInput property.
SecurityRights_CanForceSubscribeAlertSets | 1041 | Represents the CanForceSubscribeAlertSets property.
SecurityRights_CanJoinInteractions | 1042 | Represents the CanJoinInteractions property.
SecurityRights_CanListenInOnInteractions | 1043 | Represents the CanListenInOnInteractions property.
SecurityRights_CanManageClientTemplates | 1044 | Represents the CanManageClientTemplates property.
SecurityRights_CanModifyOptimizerActivityCodes | 1045 | Represents the CanModifyOptimizerActivityCodes property.
SecurityRights_CanModifyOptimizerStatusActivityTypeMapping | 1046 | Represents the CanModifyOptimizerStatusActivityTypeMapping property.
SecurityRights_CanMuteInteractions | 1047 | Represents the CanMuteInteractions property.
SecurityRights_CanOrbitQueue | 1048 | Represents the CanOrbitQueue property.
SecurityRights_CanOverrideFinishedScorecards | 1049 | Represents the CanOverrideFinishedScorecards property.
SecurityRights_CanParkInteractions | 1050 | Represents the CanParkInteractions property.
SecurityRights_CanPauseInteractions | 1051 | Represents the CanPauseInteractions property.
SecurityRights_CanPickupInteractions | 1052 | Represents the CanPickupInteractions property.
SecurityRights_CanPutInteractionsOnHold | 1053 | Represents the CanPutInteractionsOnHold property.
SecurityRights_CanRecordInteractions | 1054 | Represents the CanRecordInteractions property.
SecurityRights_CanRequestAssistanceFromSupervisor | 1055 | Represents the CanRequestAssistanceFromSupervisor property.
SecurityRights_CanSecureRecordingPauseInteractions | 1056 | Represents the CanSecureRecordingPauseInteractions property.
SecurityRights_CanTransferInteractions | 1057 | Represents the CanTransferInteractions property.
SecurityRights_CanTransferInteractionsToVoicemail | 1058 | Represents the CanTransferInteractionsToVoicemail property.
SecurityRights_CanUserInteractionRecorderSelector | 1059 | Represents the CanUserInteractionRecorderSelector property.
SecurityRights_CanViewOptimizerActivityCodes | 1060 | Represents the CanViewOptimizerActivityCodes property.
SecurityRights_CanViewOptimizerStatusActivityTypeMapping | 1061 | Represents the CanViewOptimizerStatusActivityTypeMapping property.
SecurityRights_CustomizeClient | 1062 | Represents the CustomizeClient property.
SecurityRights_DebugHandlers | 1063 | Represents the DebugHandlers property.
SecurityRights_DeleteIndividuals | 1064 | Represents the DeleteIndividuals property.
SecurityRights_DeleteOrganizations | 1065 | Represents the DeleteOrganizations property.
SecurityRights_DirectoryAdmin | 1066 | Represents the DirectoryAdmin property.
SecurityRights_ExecuteLongRunningQueries | 1067 | Obsolete. Represents the ExecuteLongRunningQueries property.
SecurityRights_FollowMe | 1068 | Represents the FollowMe property.
SecurityRights_HavePrivateContacts | 1069 | Represents the HavePrivateContacts property.
SecurityRights_IPPhoneProvisioningAdmin | 1070 | Represents the IPPhoneProvisioningAdmin property.
SecurityRights_LockPolicySets | 1071 | Represents the LockPolicySets property.
SecurityRights_LoginCampaign | 1072 | Represents the LoginCampaign property.
SecurityRights_ManageHandlers | 1073 | Represents the ManageHandlers property.
SecurityRights_MobileOfficeUser | 1074 | Represents the MobileOfficeUser property.
SecurityRights_ModifyConfigurationChangeAuditing | 1075 | Represents the ModifyConfigurationChangeAuditing property.
SecurityRights_ModifyConfigurationGeneral | 1076 | Represents the ModifyConfigurationGeneral property.
SecurityRights_ModifyConfigurationHTTPServer | 1077 | Represents the ModifyConfigurationHTTPServer property.
SecurityRights_ModifyConfigurationOutboundServers | 1078 | Represents the ModifyConfigurationOutboundServers property.
SecurityRights_ModifyConfigurationPhoneNumberTypes | 1079 | Represents the ModifyConfigurationPhoneNumberTypes property.
SecurityRights_ModifyConfigurationPreviewCallBehavior | 1080 | Represents the ModifyConfigurationPreviewCallBehavior property.
SecurityRights_ModifyIndividuals | 1081 | Represents the ModifyIndividuals property.
SecurityRights_ModifyInteractions | 1082 | Represents the ModifyInteractions property.
SecurityRights_ModifyOrganizations | 1083 | Represents the ModifyOrganizations property.
SecurityRights_OutlookTuiUser | 1084 | Represents the OutlookTuiUser property.
SecurityRights_PrivateCalls | 1085 | Represents the PrivateCalls property.
SecurityRights_PublishHandlers | 1086 | Represents the PublishHandlers property.
SecurityRights_RemoteControl | 1087 | Represents the RemoteControl property.
SecurityRights_ReporterAdministrator | 1088 | Represents the ReporterAdministrator property.
SecurityRights_RequireForcedAuthorizationCode | 1089 | Represents the RequireForcedAuthorizationCode property.
SecurityRights_ShowAssistanceButton | 1090 | Represents the ShowAssistanceButton property.
SecurityRights_ShowCoachButton | 1091 | Represents the ShowCoachButton property.
SecurityRights_ShowDisconnectButton | 1092 | Represents the ShowDisconnectButton property.
SecurityRights_ShowHoldButton | 1093 | Represents the ShowHoldButton property.
SecurityRights_ShowJoinButton | 1094 | Represents the ShowJoinButton property.
SecurityRights_ShowListenButton | 1095 | Represents the ShowListenButton property.
SecurityRights_ShowMuteButton | 1096 | Represents the ShowMuteButton property.
SecurityRights_ShowParkButton | 1097 | Represents the ShowParkButton property.
SecurityRights_ShowPauseButton | 1098 | Represents the ShowPauseButton property.
SecurityRights_ShowPickupButton | 1099 | Represents the ShowPickupButton property.
SecurityRights_ShowPrivateButton | 1100 | Represents the ShowPrivateButton property.
SecurityRights_ShowRecordButton | 1101 | Represents the ShowRecordButton property.
SecurityRights_ShowSecureInputButton | 1102 | Represents the ShowSecureInputButton property.
SecurityRights_ShowSecureRecordingPauseButton | 1103 | Represents the ShowSecureRecordingPauseButton property.
SecurityRights_ShowTransferButton | 1104 | Represents the ShowTransferButton property.
SecurityRights_ShowVoicemailButton | 1105 | Represents the ShowVoicemailButton property.
SecurityRights_ShowWorkgroupsProfilesTab | 1106 | Represents the ShowWorkgroupsProfilesTab property.
SecurityRights_TraceConfiguration | 1107 | Represents the TraceConfiguration property.
SecurityRights_TrackerAdministrator | 1108 | Represents the TrackerAdministrator property.
SecurityRights_UseTiffForFaxes | 1109 | Represents the UseTiffForFaxes property.
SecurityRights_ViewConfigurationChangeAuditing | 1110 | Represents the ViewConfigurationChangeAuditing property.
SecurityRights_ViewConfigurationGeneral | 1111 | Represents the ViewConfigurationGeneral property.
SecurityRights_ViewConfigurationHTTPServer | 1112 | Represents the ViewConfigurationHTTPServer property.
SecurityRights_ViewConfigurationOutboundServers | 1113 | Represents the ViewConfigurationOutboundServers property.
SecurityRights_ViewConfigurationPhoneNumberTypes | 1114 | Represents the ViewConfigurationPhoneNumberTypes property.
SecurityRights_ViewConfigurationPreviewCallBehavior | 1115 | Represents the ViewConfigurationPreviewCallBehavior property.
SecurityRights_ViewInteractionDetails | 1116 | Represents the ViewInteractionDetails property.
SecurityRights_ViewModifyCampaignAgentlessCallingType | 1117 | Represents the ViewModifyCampaignAgentlessCallingType property.
SecurityRights_ViewModifyCampaignAutomaticTimeZoneMapping | 1118 | Represents the ViewModifyCampaignAutomaticTimeZoneMapping property.
SecurityRights_ViewModifyCampaignLineSettings | 1119 | Represents the ViewModifyCampaignLineSettings property.
SecurityRights_ViewModifyCampaignMaxLines | 1120 | Represents the ViewModifyCampaignMaxLines property.
SecurityRights_ViewModifyCampaignStatus | 1121 | Represents the ViewModifyCampaignStatus property.
SecurityRights_ViewModifyContactListDataQuery | 1122 | Represents the ViewModifyContactListDataQuery property.
SecurityRights_ViewModifyCustomHandlerActions | 1123 | Represents the ViewModifyCustomHandlerActions property.
SecurityRights_ViewModifyDatabaseConnections | 1124 | Represents the ViewModifyDatabaseConnections property.
SecurityRights_ViewModifyDncSources | 1125 | Represents the ViewModifyDncSources property.
SecurityRights_ViewModifyEventLog | 1126 | Represents the ViewModifyEventLog property.
SecurityRights_ViewModifyTimeZoneMapData | 1127 | Represents the ViewModifyTimeZoneMapData property.
SecurityRights_ViewOtherPeoplesPrivateInteractions | 1128 | Represents the ViewOtherPeoplesPrivateInteractions property.
SecurityRights_CanDeleteSchedulingUnits | 1129 | Represents the CanDeleteSchedulingUnits property.
SecurityRights_CanCreateSchedulingUnits | 1130 | Represents the CanCreateSchedulingUnits property.
SecurityRights_CanViewOptimizerDayClassifications | 1131 | Represents the CanViewOptimizerDayClassifications property.
SecurityRights_CanModifyOptimizerDayClassifications | 1132 | Represents the CanModifyOptimizerDayClassifications property.
SecurityRights_CanCreateOptimizerDayClassifications | 1133 | Represents the CanCreateOptimizerDayClassifications property.
SecurityRights_CanDeleteOptimizerDayClassifications | 1134 | Represents the CanDeleteOptimizerDayClassifications property.
SecurityRights_CanPublishProcess | 1135 | Represents the CanPublishProcess property.
SecurityRights_CanSubmitTimeOff | 1138 | Represents the CanSubmitTimeOff property.
SecurityRights_CanAccessOptimizerShiftTrading | 1139 | Represents the CanAccessOptimizerShiftTrading property.
SecurityRights_RunContactListPredefinedActions | 1140 | Represents the RunContactListPredefinedActions property.
SecurityRights_CreateModifyCampaignGroup | 1141 | Represents the CreateModifyCampaignGroup property.
SecurityRights_ModifyCampaignGroupSequence | 1142 | Represents the ModifyCampaignGroupSequence property.
SecurityRights_ManualTransitionSequence | 1143 | Represents the ManualTransitionSequence property.
SecurityRights_CanInitiateRecordingSnippet | 1144 | Represents the CanInitiateRecordingSnippet property.
SecurityRights_ShowRecordingSnippetButton | 1145 | Represents the ShowRecordingSnippetButton property.
SecurityRights_ContactListRecordOwnershipControl | 1146 | Represents the ContactListRecordOwnershipControl property.
SecurityRights_ModifyBaseScriptAgentComplianceOverride | 1147 | Represents the ModifyBaseScriptAgentComplianceOverride property.
SecurityRights_AllowAgentComplianceOverride | 1148 | Represents the AllowAgentComplianceOverride property.
SecurityRights_ForceUserLogout | 1149 | Represents the ForceUserLogout property.
SecurityRights_DataExtractorJobAdmin | 1150 | Represents the DataExtractorJobAdmin property.
SecurityRights_CloudWorkforceEngagementAdministrator | 1151 | Represents the CloudWorkforceEngagementAdministrator property.
DisplayName | 1136 | Represents the DisplayName part of the ConfigurationId property.
Id | 1137 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


UserConfiguration.Rights Class

[image]

IceLib Technical Reference
UserConfiguration..::..Rights Class
UserConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..UserConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


UserConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
UserConfiguration..::..Rights Members
UserConfiguration..::..Rights Class Properties See Also Send Feedback

The UserConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
ChangeUserStatus | Gets the change user status rights filter.
CoachUserQueue | Gets the coach user queue rights filter.
DisconnectUserQueue | Gets or sets the view individual statistics rights filter.
HoldUserQueue | Gets the hold user queue rights filter.
JoinUserQueue | Gets the join user queue rights filter.
ListenUserQueue | Gets the listen user queue rights filter.
LoggedInUser | Gets the logged in user rights filter.
MuteUserQueue | Gets the mute user queue rights filter.
PickupUserQueue | Gets the pickup user queue rights filter.
PreviewEmailUserQueue | Gets the preview email user queue rights filter.
RecordUserQueue | Gets the record user queue rights filter.
SnipUserQueue | Gets the snip user queue rights filter.
TransferUserQueue | Gets the transfer user queue rights filter.
View | Gets the view rights filter.
ViewIndividualStatistics | Gets or sets the view individual statistics rights filter.
ViewUserInteractionHistory | Gets or sets the view user interaction history rights filter.

See Also

UserConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


UserConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
UserConfiguration..::..Rights Properties
UserConfiguration..::..Rights Class See Also Send Feedback

The UserConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
ChangeUserStatus | Gets the change user status rights filter.
CoachUserQueue | Gets the coach user queue rights filter.
DisconnectUserQueue | Gets or sets the view individual statistics rights filter.
HoldUserQueue | Gets the hold user queue rights filter.
JoinUserQueue | Gets the join user queue rights filter.
ListenUserQueue | Gets the listen user queue rights filter.
LoggedInUser | Gets the logged in user rights filter.
MuteUserQueue | Gets the mute user queue rights filter.
PickupUserQueue | Gets the pickup user queue rights filter.
PreviewEmailUserQueue | Gets the preview email user queue rights filter.
RecordUserQueue | Gets the record user queue rights filter.
SnipUserQueue | Gets the snip user queue rights filter.
TransferUserQueue | Gets the transfer user queue rights filter.
View | Gets the view rights filter.
ViewIndividualStatistics | Gets or sets the view individual statistics rights filter.
ViewUserInteractionHistory | Gets or sets the view user interaction history rights filter.

See Also

UserConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..Admin Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Users


ChangeUserStatus Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..ChangeUserStatus Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the change user status rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> ChangeUserStatus { get; private set; }
Visual Basic
Public Shared Property ChangeUserStatus As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The change user status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ChangeUserStatus


CoachUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..CoachUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the coach user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> CoachUserQueue { get; private set; }
Visual Basic
Public Shared Property CoachUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The coach user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachUserQueue


DisconnectUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..DisconnectUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets or sets the view individual statistics rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> DisconnectUserQueue { get; private set; }
Visual Basic
Public Shared Property DisconnectUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The view individual statistics.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectUserQueue


HoldUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..HoldUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the hold user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> HoldUserQueue { get; private set; }
Visual Basic
Public Shared Property HoldUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The hold user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..HoldUserQueue


JoinUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..JoinUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the join user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> JoinUserQueue { get; private set; }
Visual Basic
Public Shared Property JoinUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The join user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinUserQueue


ListenUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..ListenUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the listen user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> ListenUserQueue { get; private set; }
Visual Basic
Public Shared Property ListenUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The listen user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenUserQueue


LoggedInUser Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..LoggedInUser Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the logged in user rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> LoggedInUser { get; private set; }
Visual Basic
Public Shared Property LoggedInUser As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The logged in rights filter.

Remarks

The LoggedInUser rights filter allows the inclusion of the currently logged in user's data in the result set regardless of the user's admin or access rights assignments.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


MuteUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..MuteUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the mute user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> MuteUserQueue { get; private set; }
Visual Basic
Public Shared Property MuteUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The mute user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MuteUserQueue


PickupUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..PickupUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the pickup user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> PickupUserQueue { get; private set; }
Visual Basic
Public Shared Property PickupUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The pickup user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupUserQueue


PreviewEmailUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..PreviewEmailUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the preview email user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> PreviewEmailUserQueue { get; private set; }
Visual Basic
Public Shared Property PreviewEmailUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The preview email user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PreviewEmailUserQueue


RecordUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..RecordUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the record user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> RecordUserQueue { get; private set; }
Visual Basic
Public Shared Property RecordUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The record user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordUserQueue


SnipUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..SnipUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the snip user queue rights filter.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> SnipUserQueue { get; private set; }
Visual Basic
Public Shared Property SnipUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The snip user queue rights filter.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipUserQueue


TransferUserQueue Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..TransferUserQueue Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the transfer user queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> TransferUserQueue { get; private set; }
Visual Basic
Public Shared Property TransferUserQueue As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The transfer user queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferUserQueue


View Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..View Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewUserQueue


ViewIndividualStatistics Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..ViewIndividualStatistics Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets or sets the view individual statistics rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> ViewIndividualStatistics { get; private set; }
Visual Basic
Public Shared Property ViewIndividualStatistics As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The view individual statistics.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewIndividualStatistics


ViewUserInteractionHistory Property

[image]

IceLib Technical Reference
UserConfiguration..::..Rights..::..ViewUserInteractionHistory Property
UserConfiguration..::..Rights Class See Also Send Feedback
Gets or sets the view user interaction history rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<UserConfiguration> ViewUserInteractionHistory { get; private set; }
Visual Basic
Public Shared Property ViewUserInteractionHistory As RightsQueryFilter(Of UserConfiguration)
    Get
    Private Set

Field Value

The view individual statistics.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserConfiguration..::..Rights Class
UserConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewUserInteractionHistory


UserConfigurationList Class

[image]

IceLib Technical Reference
UserConfigurationList Class
Members Example See Also Send Feedback
Allows for querying and managing user configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserConfigurationList : EditableConfigurationList<UserConfiguration, UserConfiguration..::..Property>
Visual Basic
Public Class UserConfigurationList _
    Inherits EditableConfigurationList(Of UserConfiguration, UserConfiguration..::..Property)

Examples

The IceLib SDK includes example application references to the UserConfigurationList class. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 107, in UserRoleConfigurationViewModel.set_SelectedConfigurationId

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' UserConfiguration, UserConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' UserConfiguration, UserConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' UserConfiguration, UserConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..UserConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfigurationList Members
ININ.IceLib.Configuration Namespace


UserConfigurationList Members

[image] [image]

IceLib Technical Reference
UserConfigurationList Members
UserConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The UserConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | UserConfigurationList | Initializes a new instance of the UserConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
 | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingLoggedInUser | Starts watching the currently logged in user.
Public method | StartWatchingLoggedInUserAsync | Starts watching the currently logged in user.
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

UserConfigurationList Class
ININ.IceLib.Configuration Namespace


UserConfigurationList Constructor

[image]

IceLib Technical Reference
UserConfigurationList Constructor
UserConfigurationList Class Example See Also Send Feedback
Initializes a new instance of the UserConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Examples

The IceLib SDK includes example application references to the UserConfigurationList constructor. Some examples are listed below.
Project | Location
TutorialExample | UserRoleConfigurationViewModel.cs, line 107, in UserRoleConfigurationViewModel.set_SelectedConfigurationId

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfigurationList Class
UserConfigurationList Members
ININ.IceLib.Configuration Namespace


UserConfigurationList Methods

[image] [image]

IceLib Technical Reference
UserConfigurationList Methods
UserConfigurationList Class See Also Send Feedback

The UserConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
 | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingLoggedInUser | Starts watching the currently logged in user.
Public method | StartWatchingLoggedInUserAsync | Starts watching the currently logged in user.
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserConfigurationList Class
ININ.IceLib.Configuration Namespace


RetrievePropertiesForMailboxSettings Method

[image]

IceLib Technical Reference
UserConfigurationList..::..RetrievePropertiesForMailboxSettings Method
UserConfigurationList Class See Also Send Feedback
Retrieves the property values that would result from applying the specified mailbox settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static MailboxRetrievedValues RetrievePropertiesForMailboxSettings(
    ConfigurationManager configurationManager,
    MailboxSettings mailboxSettings
)
Visual Basic
Public Shared Function RetrievePropertiesForMailboxSettings ( _
    configurationManager As ConfigurationManager, _
    mailboxSettings As MailboxSettings _
) As MailboxRetrievedValues

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.

Return Value

The retrieved mailbox values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserConfigurationList Class
UserConfigurationList Members
ININ.IceLib.Configuration Namespace
MailboxProperties..::..ApplyMailboxSettings(MailboxSettings)


StartWatchingLoggedInUser Method

[image]

IceLib Technical Reference
UserConfigurationList..::..StartWatchingLoggedInUser Method
UserConfigurationList Class See Also Send Feedback
Starts watching the currently logged in user.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingLoggedInUser(
    IEnumerable<UserConfiguration..::..Property> selectedProperties
)
Visual Basic
Public Sub StartWatchingLoggedInUser ( _
    selectedProperties As IEnumerable(Of UserConfiguration..::..Property) _
)

Parameters

selectedProperties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' UserConfiguration..::..Property >)>)>
The properties to watch.

Remarks

StartWatchingLoggedInUser starts a watch on the currently logged in user. After the watch is started GetConfigurationList()()()() can be used to retreive the currently logged in user object. Use StopWatching()()()() to stop this watch.
Note
All event handlers should be added before calling StartWatchingLoggedInUser(IEnumerable<(Of <<'(UserConfiguration..::..Property>)>>)) or StartWatchingLoggedInUserAsync(IEnumerable<(Of <<'(UserConfiguration..::..Property>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfigurationList Class
UserConfigurationList Members
ININ.IceLib.Configuration Namespace


StartWatchingLoggedInUserAsync Method

[image]

IceLib Technical Reference
UserConfigurationList..::..StartWatchingLoggedInUserAsync Method
UserConfigurationList Class See Also Send Feedback
Starts watching the currently logged in user.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingLoggedInUserAsync(
    IEnumerable<UserConfiguration..::..Property> selectedProperties,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingLoggedInUserAsync ( _
    selectedProperties As IEnumerable(Of UserConfiguration..::..Property), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

selectedProperties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' UserConfiguration..::..Property >)>)>
The properties to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

StartWatchingLoggedInUserAsync asynchronously starts a watch on the currently logged in user. After the watch is started GetConfigurationList()()()() can be used to retrieve the currently logged in user object. Use StopWatching()()()() to stop this watch.
Note
All event handlers should be added before calling StartWatchingLoggedInUser(IEnumerable<(Of <<'(UserConfiguration..::..Property>)>>)) or StartWatchingLoggedInUserAsync(IEnumerable<(Of <<'(UserConfiguration..::..Property>)>>), AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> is already watched or cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserConfigurationList Class
UserConfigurationList Members
ININ.IceLib.Configuration Namespace


UserConfigurationList Properties

[image] [image]

IceLib Technical Reference
UserConfigurationList Properties
UserConfigurationList Class See Also Send Feedback

The UserConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

UserConfigurationList Class
ININ.IceLib.Configuration Namespace


UserConfigurationList Events

[image] [image]

IceLib Technical Reference
UserConfigurationList Events
UserConfigurationList Class See Also Send Feedback

The UserConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

UserConfigurationList Class
ININ.IceLib.Configuration Namespace


UserLicenseProperties Class

[image]

IceLib Technical Reference
UserLicenseProperties Class
Members See Also Send Feedback
Contains license settings for a UserConfiguration.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserLicenseProperties
Visual Basic
Public Class UserLicenseProperties

Remarks

When watching the UserConfigurationList object for UserConfiguration changes, change notifications will not be sent for changes to the License property. The ININ.IceLib.People.LicenseManagement object can be used as an alternative to watching the logged in user's licenses.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..UserLicenseProperties

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserLicenseProperties Members
ININ.IceLib.Configuration Namespace


UserLicenseProperties Members

[image] [image]

IceLib Technical Reference
UserLicenseProperties Members
UserLicenseProperties Class Methods Properties See Also Send Feedback

The UserLicenseProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalLicenses | Provides access to the property representing the additional licenses for this user (use Property.License_AdditionalLicenses).
Public property | HasClientAccess | Provides access to the property representing client access for this user (use Property.License_HasClientAccess).
Public property | InteractionProcessAutomationLicenseType | Provides access to the property representing the Interaction Process Automation license type for this user (use Property.License_InteractionProcessAutomationType).
Public property | LicenseActive | Provides access to the property representing the license activation for this user (use Property.License_LicenseActive).
Public property | LicenseAllocationType | Provides access to the property representing the license allocation type for this user (use Property.License_AllocationType).
Public property | MediaLevel | Provides access to the property representing the media level for this user (use Property.License_MediaLevel).
Public property | MediaTypes | Provides access to the property representing the media types for this user (use Property.License_MediaTypes).

See Also

UserLicenseProperties Class
ININ.IceLib.Configuration Namespace


UserLicenseProperties Methods

[image] [image]

IceLib Technical Reference
UserLicenseProperties Methods
UserLicenseProperties Class See Also Send Feedback

The UserLicenseProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserLicenseProperties Class
ININ.IceLib.Configuration Namespace


UserLicenseProperties Properties

[image] [image]

IceLib Technical Reference
UserLicenseProperties Properties
UserLicenseProperties Class See Also Send Feedback

The UserLicenseProperties type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalLicenses | Provides access to the property representing the additional licenses for this user (use Property.License_AdditionalLicenses).
Public property | HasClientAccess | Provides access to the property representing client access for this user (use Property.License_HasClientAccess).
Public property | InteractionProcessAutomationLicenseType | Provides access to the property representing the Interaction Process Automation license type for this user (use Property.License_InteractionProcessAutomationType).
Public property | LicenseActive | Provides access to the property representing the license activation for this user (use Property.License_LicenseActive).
Public property | LicenseAllocationType | Provides access to the property representing the license allocation type for this user (use Property.License_AllocationType).
Public property | MediaLevel | Provides access to the property representing the media level for this user (use Property.License_MediaLevel).
Public property | MediaTypes | Provides access to the property representing the media types for this user (use Property.License_MediaTypes).

See Also

UserLicenseProperties Class
ININ.IceLib.Configuration Namespace


AdditionalLicenses Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..AdditionalLicenses Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing the additional licenses for this user (use Property.License_AdditionalLicenses).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<ConfigurationId>> AdditionalLicenses { get; }
Visual Basic
Public ReadOnly Property AdditionalLicenses As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the additional licenses.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic).
The additional licenses that are assigned to this user. To assign or remove an additional license on this User, modify the Value of this property. One or more licenses must already exist to add a license in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace
UserLicenseProperties..::..LicenseActive
ININ.IceLib.Configuration..::..LicenseAllocationConfiguration
ININ.IceLib.Configuration..::..LicenseAllocationConfigurationList


HasClientAccess Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..HasClientAccess Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing client access for this user (use Property.License_HasClientAccess).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> HasClientAccess { get; }
Visual Basic
Public ReadOnly Property HasClientAccess As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing client access.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic).
Assigning this license to the user allows the client functionality of Interaction Client. Without this license assignment, the user cannot run Interaction Client.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace
UserLicenseProperties..::..LicenseActive


InteractionProcessAutomationLicenseType Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..InteractionProcessAutomationLicenseType Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing the Interaction Process Automation license type for this user (use Property.License_InteractionProcessAutomationType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, InteractionProcessAutomationLicenseType> InteractionProcessAutomationLicenseType { get; }
Visual Basic
Public ReadOnly Property InteractionProcessAutomationLicenseType As GeneralConfigurationProperty(Of UserConfiguration..::..Property, InteractionProcessAutomationLicenseType)
    Get

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic).
Specifies what Interaction Process Automation license this user should have. These are the available types of Interaction Process Automation licenses:
  • None - The user does not have an Interaction Process Automation license.
  • DirectRoutedWorkItems - This license enables you to launch any process to which you have rights. It also enables you to receive Work Items that are directly routed to you.
  • GroupRoutedWorkItems - This license enables you to receive Work Items that are either routed to you directly or as a member of a workgroup (similar to an ACD queue).
  • ProcessMonitor Plus - This license enables you to view process status and details in the Process Monitor or to use Process Reporting in IC Business Manager Applications.
  • ProcessDesigner Plus - This license enables you to use the Process Designer to create and modify Interaction Process Automation processes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace


LicenseActive Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..LicenseActive Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing the license activation for this user (use Property.License_LicenseActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, bool> LicenseActive { get; }
Visual Basic
Public ReadOnly Property LicenseActive As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing license activation.

Remarks

Set this to trueTruetruetrue (True in Visual Basic) to set the license settings to Active. If falseFalsefalsefalse (False in Visual Basic), the other license settings are ignored by the system. This is a way to turn off licensing for a user, but keep the license settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace


LicenseAllocationType Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..LicenseAllocationType Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing the license allocation type for this user (use Property.License_AllocationType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, LicenseAllocationType> LicenseAllocationType { get; }
Visual Basic
Public ReadOnly Property LicenseAllocationType As GeneralConfigurationProperty(Of UserConfiguration..::..Property, LicenseAllocationType)
    Get

Field Value

The property representing the license allocation type.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace


MediaLevel Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..MediaLevel Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing the media level for this user (use Property.License_MediaLevel).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, MediaLevel> MediaLevel { get; }
Visual Basic
Public ReadOnly Property MediaLevel As GeneralConfigurationProperty(Of UserConfiguration..::..Property, MediaLevel)
    Get

Field Value

The property representing the media level.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic).
Specifies what type of ACD support this user should have. These are the available types of ACD licenses:
  • None - The user does not have ACD licenses.
  • Media1 - This license allows 1 interaction type at a given time.
  • Media2 - This license allows 2 interaction types at a given time.
  • Media3 Plus - This license allows 3 or more interaction types at a given time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace
UserLicenseProperties..::..LicenseActive
ININ.IceLib.Configuration.DataTypes..::..MediaLevel


MediaTypes Property

[image]

IceLib Technical Reference
UserLicenseProperties..::..MediaTypes Property
UserLicenseProperties Class See Also Send Feedback
Provides access to the property representing the media types for this user (use Property.License_MediaTypes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, Collection<MediaType>> MediaTypes { get; }
Visual Basic
Public ReadOnly Property MediaTypes As GeneralConfigurationProperty(Of UserConfiguration..::..Property, Collection(Of MediaType))
    Get

Field Value

The property representing the media types.

Remarks

Note
This setting only applies when LicenseActive is trueTruetruetrue (True in Visual Basic) and MediaLevel is Media1 or Media2.
Specifies the type of interaction(s) to apply to the license.

Depending on the MediaLevel setting, a different number of MediaType items is expected.

  • Media1 - One MediaType instances is expected in the collection.
  • Media2 - Two MediaType instances are expected in the collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

UserLicenseProperties Class
UserLicenseProperties Members
ININ.IceLib.Configuration Namespace
UserLicenseProperties..::..LicenseActive
ININ.IceLib.Configuration.DataTypes..::..MediaType


UserSecurityRightsProperties(TConfigurationObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Contains Security Access Right settings for configuration objects (e.g. RoleConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserSecurityRightsProperties<TConfigurationObject, TPropertyEnum>
where TConfigurationObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class UserSecurityRightsProperties(Of TConfigurationObject As ConfigurationObject, TPropertyEnum As {Structure, New})

Type Parameters

TConfigurationObject
TPropertyEnum

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


UserSecurityRightsProperties(TConfigurationObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessAllInteractionConferences | Provides access to the property representing the AccessAllInteractionConferences security right for this user (use TPropertyEnum.SecurityRights_AccessAllInteractionConferences).
Public property | AccessOwnedInteractionConferences | Provides access to the property representing the AccessOwnedInteractionConferences security right for this user (use TPropertyEnum.SecurityRights_AccessOwnedInteractionConferences).
Public property | AccountCodeVerification | Provides access to the property representing the account code verification security right for this user (use TPropertyEnum.SecurityRights_AccountCodeVerification).
Public property | AddIndividuals | Provides access to the property representing the add individuals security right for this user (use TPropertyEnum.SecurityRights_AddIndividuals).
Public property | AddOrganizations | Provides access to the property representing the add organizations security right for this user (use TPropertyEnum.SecurityRights_AddOrganizations).
Public property | AgentPreferences | Provides access to the property representing the AgentPreferences security right for this user (use TPropertyEnum.SecurityRights_AgentPreferences).
Public property | AlertAdministrator | Provides access to the property representing the AlertAdministrator security right for this user (use TPropertyEnum.SecurityRights_AlertAdministrator).
Public property | AllowAccessToProblemReporter | Provides access to the property representing the AllowAccessToProblemReporter security right for this user (use TPropertyEnum.SecurityRights_AllowAccessToProblemReporter).
Public property | AllowAgentComplianceOverride | Provides access to the property representing the AllowAgentComplianceOverride security right for this user (use TPropertyEnum.SecurityRights_AllowAgentComplianceOverride).
Public property | AllowAgentRules | Provides access to the property representing the AllowAgentRules security right for this user (use TPropertyEnum.SecurityRights_AllowAgentRules).
Public property | AllowAgentScheduleBidding | Provides access to the property representing the AllowAgentScheduleBidding security right for this user (use TPropertyEnum.SecurityRights_AllowAgentScheduleBidding).
Public property | AllowAgentSeeOwnRank | Provides access to the property representing the AllowAgentSeeOwnRank security right for this user (use TPropertyEnum.SecurityRights_AllowAgentSeeOwnRank).
Public property | AllowAgentSeeRelativeRank | Provides access to the property representing the AllowAgentSeeRelativeRank security right for this user (use TPropertyEnum.SecurityRights_AllowAgentSeeRelativeRank ).
Public property | AllowAlertProgramming | Provides access to the property representing the AllowAlertProgramming security right for this user (use TPropertyEnum.SecurityRights_AllowAlertProgramming).
Public property | AllowEmailAccessViaTui | Provides access to the property representing the AllowEmailAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowEmailAccessViaTui).
Public property | AllowEmailAlerts | Provides access to the property representing the AllowEmailAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowEmailAlerts).
Public property | AllowFaxAccessViaTui | Provides access to the property representing the AllowFaxAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowFaxAccessViaTui).
Public property | AllowHandlerAlerts | Provides access to the property representing the AllowHandlerAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowHandlerAlerts).
Public property | AllowIntercomChat | Provides access to the property representing the AllowIntercomChat security right for this user (use TPropertyEnum.SecurityRights_AllowIntercomChat).
Public property | AllowMemoAlerts | Provides access to the property representing the AllowMemoAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowMemoAlerts).
Public property | AllowMiniMode | Provides access to the property representing the AllowMiniMode security right for this user (use TPropertyEnum.SecurityRights_AllowMiniMode).
Public property | AllowMonitorColumns | Provides access to the property representing the AllowMonitorColumns security right for this user (use TPropertyEnum.SecurityRights_AllowMonitorColumns).
Public property | AllowMultipleCalls | Provides access to the property representing the AllowMultipleCalls security right for this user (use TPropertyEnum.SecurityRights_AllowMultipleCalls).
Public property | AllowPersistentConnections | Provides access to the property representing the AllowPersistentConnections security right for this user (use TPropertyEnum.SecurityRights_AllowPersistentConnections).
Public property | AllowReceiveVoicemail | Provides access to the property representing the AllowReceiveVoicemail security right for this user (use TPropertyEnum.SecurityRights_AllowReceiveVoicemail).
Public property | AllowRelatedInteractionsPage | Provides access to the property representing the AllowRelatedInteractionsPage security right for this user (use TPropertyEnum.SecurityRights_AllowRelatedInteractionsPage).
Public property | AllowResponseManagement | Provides access to the property representing the AllowResponseManagement security right for this user (use TPropertyEnum.SecurityRights_AllowResponseManagement).
Public property | AllowSpeedDials | Provides access to the property representing the AllowSpeedDials security right for this user (use TPropertyEnum.SecurityRights_AllowSpeedDials).
Public property | AllowStatusNotes | Provides access to the property representing the AllowStatusNotes security right for this user (use TPropertyEnum.SecurityRights_AllowStatusNotes).
Public property | AllowUserDefinedTelephoneNumberOnRemoteLogin | Provides access to the property representing the AllowUserDefinedTelephoneNumberOnRemoteLogin security right for this user (use TPropertyEnum.SecurityRights_AllowUserDefinedTelephoneNumberOnRemoteLogin).
Public property | AllowVideo | Provides access to the property representing the AllowVideo security right for this user (use TPropertyEnum.SecurityRights_AllowVideo).
Public property | AllowVoiceMaiAccessViaTui | Provides access to the property representing the AllowVoiceMaiAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowVoiceMaiAccessViaTui).
Public property | AllowWorkgroupStats | Provides access to the property representing the AllowWorkgroupStats security right for this user (use TPropertyEnum.SecurityRights_AllowWorkgroupStats).
Public property | CanAccessOptimizerShiftTrading | Provides access to the property representing the CanAccessOptimizerShiftTrading security right for this user (use TPropertyEnum.SecurityRights_CanAccessOptimizerShiftTrading).
Public property | CanCoachInteractions | Provides access to the property representing the CanCoachInteractions security right for this user (use TPropertyEnum.SecurityRights_CanCoachInteractions).
Public property | CanConferenceCalls | Provides access to the property representing the CanConferenceCalls security right for this user (use TPropertyEnum.SecurityRights_CanConferenceCalls).
Public property | CanCreateAlertSets | Provides access to the property representing the CanCreateAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanCreateAlertSets).
Public property | CanCreateOptimizerActivityCodes | Provides access to the property representing the right to create optimizer activity codes (use TPropertyEnum.SecurityRights_CanCreateOptimizerActivityCodes).
Public property | CanCreateOptimizerDayClassifications | Provides access to the property representing the CanCreateOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanCreateOptimizerDayClassifications).
Public property | CanCreateQuestionnaireDirectories | Provides access to the property representing the CanCreateQuestionnaireDirectories security right for this user (use TPropertyEnum.SecurityRights_CanCreateQuestionnaireDirectories).
Public property | CanCreateSchedulingUnits | Provides access to the property representing the CanCreateSchedulingUnits security right for this user (use TPropertyEnum.SecurityRights_CanCreateSchedulingUnits).
Public property | CanDeleteOptimizerActivityCodes | Provides access to the property representing the right to delete optimizer activity codes (use TPropertyEnum.SecurityRights_CanDeleteOptimizerActivityCodes).
Public property | CanDeleteOptimizerDayClassifications | Provides access to the property representing the CanDeleteOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanDeleteOptimizerDayClassifications).
Public property | CanDeleteSchedulingUnits | Provides access to the property representing the CanDeleteSchedulingUnits security right for this user (use TPropertyEnum.SecurityRights_CanDeleteSchedulingUnits).
Public property | CanDisconnectInteractions | Provides access to the property representing the CanDisconnectInteractions security right for this user (use TPropertyEnum.SecurityRights_CanDisconnectInteractions).
Public property | CanForceSubscribeAlertSets | Provides access to the property representing the CanForceSubscribeAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanForceSubscribeAlertSets).
Public property | CanInitiateRecordingSnippet | Provides access to the property representing the CanInitiateRecordingSnippet security right for this user (use TPropertyEnum.SecurityRights_CanInitiateRecordingSnippet).
Public property | CanInitiateSecureInput | Provides access to the property representing the CanInitiateSecureInput security right for this user (use TPropertyEnum.SecurityRights_CanInitiateSecureInput).
Public property | CanJoinInteractions | Provides access to the property representing the CanJoinInteractions security right for this user (use TPropertyEnum.SecurityRights_CanJoinInteractions).
Public property | CanListenInOnInteractions | Provides access to the property representing the CanListenInOnInteractions security right for this user (use TPropertyEnum.SecurityRights_CanListenInOnInteractions).
Public property | CanManageClientTemplates | Provides access to the property representing the CanManageClientTemplates security right for this user (use TPropertyEnum.SecurityRights_CanManageClientTemplates).
Public property | CanModifyOptimizerActivityCodes | Provides access to the property representing the right to modify optimizer activity codes (use TPropertyEnum.SecurityRights_CanModifyOptimizerActivityCodes).
Public property | CanModifyOptimizerDayClassifications | Provides access to the property representing the CanModifyOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanModifyOptimizerDayClassifications).
Public property | CanModifyOptimizerStatusActivityTypeMapping | Provides access to the property representing the right to modify optimizer activity type mapping (use TPropertyEnum.SecurityRights_CanModifyOptimizerStatusActivityTypeMapping).
Public property | CanMuteInteractions | Provides access to the property representing the CanMuteInteractions security right for this user (use TPropertyEnum.SecurityRights_CanMuteInteractions).
Public property | CanOrbitQueue | Provides access to the property representing the CanOrbitQueue security right for this user (use TPropertyEnum.SecurityRights_CanOrbitQueue).
Public property | CanOverrideFinishedScorecards | Provides access to the property representing the CanOverrideFinishedScorecards security right for this user (use TPropertyEnum.SecurityRights_CanOverrideFinishedScorecards).
Public property | CanParkInteractions | Provides access to the property representing the CanParkInteractions security right for this user (use TPropertyEnum.SecurityRights_CanParkInteractions).
Public property | CanPauseInteractions | Provides access to the property representing the CanPauseInteractions security right for this user (use TPropertyEnum.SecurityRights_CanPauseInteractions).
Public property | CanPickupInteractions | Provides access to the property representing the CanPickupInteractions security right for this user (use TPropertyEnum.SecurityRights_CanPickupInteractions).
Public property | CanPublishProcess | Provides access to the property representing the CanPublishProcess security right for this user (use TPropertyEnum.SecurityRights_CanPublishProcess).
Public property | CanPutInteractionsOnHold | Provides access to the property representing the CanPutInteractionsOnHold security right for this user (use TPropertyEnum.SecurityRights_CanPutInteractionsOnHold).
Public property | CanRecordInteractions | Provides access to the property representing the CanRecordInteractions security right for this user (use TPropertyEnum.SecurityRights_CanRecordInteractions).
Public property | CanRequestAssistanceFromSupervisor | Provides access to the property representing the CanRequestAssistanceFromSupervisor security right for this user (use TPropertyEnum.SecurityRights_CanRequestAssistanceFromSupervisor).
Public property | CanSecureRecordingPauseInteractions | Provides access to the property representing the CanSecureRecordingPauseInteractions security right for this user (use TPropertyEnum.SecurityRights_CanSecureRecordingPauseInteractions).
Public property | CanShareAlertSets | Provides access to the property representing the CanShareAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanShareAlertSets).
Public property | CanSubmitTimeOff | Provides access to the property representing the CanSubmitTimeOff security right for this user (use TPropertyEnum.SecurityRights_CanSubmitTimeOff).
Public property | CanTransferInteractions | Provides access to the property representing the CanTransferInteractions security right for this user (use TPropertyEnum.SecurityRights_CanTransferInteractions).
Public property | CanTransferInteractionsToVoicemail | Provides access to the property representing the CanTransferInteractionsToVoicemail security right for this user (use TPropertyEnum.SecurityRights_CanTransferInteractionsToVoicemail).
Public property | CanUserInteractionRecorderSelector | Provides access to the property representing the CanUserInteractionRecorderSelector security right for this user (use TPropertyEnum.SecurityRights_CanUserInteractionRecorderSelector).
Public property | CanViewOptimizerActivityCodes | Provides access to the property representing the right to view optimizer activity codes (use TPropertyEnum.SecurityRights_CanViewOptimizerActivityCodes).
Public property | CanViewOptimizerDayClassifications | Provides access to the property representing the CanViewOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanViewOptimizerDayClassifications).
Public property | CanViewOptimizerStatusActivityTypeMapping | Provides access to the property representing the right to view optimizer activity type mapping (use TPropertyEnum.SecurityRights_CanViewOptimizerStatusActivityTypeMapping).
Public property | CloudWorkforceEngagementAdministrator | Provides access to the property representing the CloudWorkforceEngagementAdministrator security right for this user (use TPropertyEnum.SecurityRights_CloudWorkforceEngagementAdministrator).
Public property | ContactListRecordOwnershipControl | Provides access to the property representing the ContactListRecordOwnershipControl security right for this user (use TPropertyEnum.SecurityRights_ContactListRecordOwnershipControl).
Public property | CreateModifyCampaignGroup | Provides access to the property representing the CreateModifyCampaignGroup security right for this user (use TPropertyEnum.SecurityRights_CreateModifyCampaignGroup).
Public property | CustomizeClient | Provides access to the property representing the CustomizeClient security right for this user (use TPropertyEnum.SecurityRights_CustomizeClient).
Public property | DataExtractorJobAdmin | Provides access to the property representing the DataExtractorJobAdmin security right for this user (use TPropertyEnum.SecurityRights_DataExtractorJobAdmin).
Public property | DebugHandlers | Provides access to the property representing the DebugHandlers security right for this user (use TPropertyEnum.SecurityRights_DebugHandlers).
Public property | DeleteIndividuals | Provides access to the property representing the DeleteIndividuals security right for this user (use TPropertyEnum.SecurityRights_DeleteIndividuals).
Public property | DeleteOrganizations | Provides access to the property representing the DeleteOrganizations security right for this user (use TPropertyEnum.SecurityRights_DeleteOrganizations).
Public property | DirectoryAdmin | Provides access to the property representing the DirectoryAdmin security right for this user (use TPropertyEnum.SecurityRights_DirectoryAdmin).
Public property | ExecuteLongRunningQueries | Obsolete. Provides access to the property representing the ExecuteLongRunningQueries security right for this user (use TPropertyEnum.SecurityRights_ExecuteLongRunningQueries).
Public property | FollowMe | Provides access to the property representing the FollowMe security right for this user (use TPropertyEnum.SecurityRights_FollowMe).
Public property | ForceUserLogout | Provides access to the property representing the ForceUserLogout security right for this user (use TPropertyEnum.SecurityRights_ForceUserLogout).
Public property | HavePrivateContacts | Provides access to the property representing the HavePrivateContacts security right for this user (use TPropertyEnum.SecurityRights_HavePrivateContacts).
Public property | IPPhoneProvisioningAdmin | Provides access to the property representing the IPPhoneProvisioningAdmin security right for this user (use TPropertyEnum.SecurityRights_IPPhoneProvisioningAdmin).
Public property | LockPolicySets | Provides access to the property representing the LockPolicySets security right for this user (use TPropertyEnum.SecurityRights_LockPolicySets).
Public property | LoginCampaign | Provides access to the property representing the LoginCampaign security right for this user (use TPropertyEnum.SecurityRights_LoginCampaign).
Public property | ManageHandlers | Provides access to the property representing the ManageHandlers security right for this user (use TPropertyEnum.SecurityRights_ManageHandlers).
Public property | ManualTransitionSequence | Provides access to the property representing the ManualTransitionSequence security right for this user (use TPropertyEnum.SecurityRights_ManualTransitionSequence).
Public property | MobileOfficeUser | Provides access to the property representing the MobileOfficeUser security right for this user (use TPropertyEnum.SecurityRights_MobileOfficeUser).
Public property | ModifyBaseScriptAgentComplianceOverride | Provides access to the property representing the ModifyBaseScriptAgentComplianceOverride security right for this user (use TPropertyEnum.SecurityRights_ModifyBaseScriptAgentComplianceOverride).
Public property | ModifyCampaignGroupSequence | Provides access to the property representing the ModifyCampaignGroupSequence security right for this user (use TPropertyEnum.SecurityRights_ModifyCampaignGroupSequence).
Public property | ModifyConfigurationChangeAuditing | Provides access to the property representing the ModifyConfigurationChangeAuditing security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationChangeAuditing).
Public property | ModifyConfigurationGeneral | Provides access to the property representing the ModifyConfigurationGeneral security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationGeneral).
Public property | ModifyConfigurationHTTPServer | Provides access to the property representing the ModifyConfigurationHTTPServer security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationHTTPServer).
Public property | ModifyConfigurationOutboundServers | Provides access to the property representing the ModifyConfigurationOutboundServers security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationOutboundServers).
Public property | ModifyConfigurationPhoneNumberTypes | Provides access to the property representing the ModifyConfigurationPhoneNumberTypes security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationPhoneNumberTypes).
Public property | ModifyConfigurationPreviewCallBehavior | Provides access to the property representing the ModifyConfigurationPreviewCallBehavior security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationPreviewCallBehavior).
Public property | ModifyIndividuals | Provides access to the property representing the ModifyIndividuals security right for this user (use TPropertyEnum.SecurityRights_ModifyIndividuals).
Public property | ModifyInteractions | Provides access to the property representing the ModifyInteractions security right for this user (use TPropertyEnum.SecurityRights_ModifyInteractions).
Public property | ModifyOrganizations | Provides access to the property representing the ModifyOrganizations security right for this user (use TPropertyEnum.SecurityRights_ModifyOrganizations).
Public property | OutlookTuiUser | Provides access to the property representing the OutlookTuiUser security right for this user (use TPropertyEnum.SecurityRights_OutlookTuiUser).
Public property | PrivateCalls | Provides access to the property representing the PrivateCalls security right for this user (use TPropertyEnum.SecurityRights_PrivateCalls).
Public property | PublishHandlers | Provides access to the property representing the PublishHandlers security right for this user (use TPropertyEnum.SecurityRights_PublishHandlers).
Public property | RemoteControl | Provides access to the property representing the RemoteControl security right for this user (use TPropertyEnum.SecurityRights_RemoteControl).
Public property | ReporterAdministrator | Provides access to the property representing the Interaction Reporter Administrator security right for this user (use TPropertyEnum.SecurityRights_ReporterAdministrator).
Public property | RequireForcedAuthorizationCode | Provides access to the property representing the RequireForcedAuthorizationCode security right for this user (use TPropertyEnum.SecurityRights_RequireForcedAuthorizationCode).
Public property | RunContactListPredefinedActions | Provides access to the property representing the RunContactListPredefinedActions security right for this user (use TPropertyEnum.SecurityRights_RunContactListPredefinedActions).
Public property | ShowAssistanceButton | Provides access to the property representing the ShowAssistanceButton security right for this user (use TPropertyEnum.SecurityRights_ShowAssistanceButton).
Public property | ShowCoachButton | Provides access to the property representing the ShowCoachButton security right for this user (use TPropertyEnum.SecurityRights_ShowCoachButton).
Public property | ShowDisconnectButton | Provides access to the property representing the ShowDisconnectButton security right for this user (use TPropertyEnum.SecurityRights_ShowDisconnectButton).
Public property | ShowHoldButton | Provides access to the property representing the ShowHoldButton security right for this user (use TPropertyEnum.SecurityRights_ShowHoldButton).
Public property | ShowJoinButton | Provides access to the property representing the ShowJoinButton security right for this user (use TPropertyEnum.SecurityRights_ShowJoinButton).
Public property | ShowListenButton | Provides access to the property representing the ShowListenButton security right for this user (use TPropertyEnum.SecurityRights_ShowListenButton).
Public property | ShowMuteButton | Provides access to the property representing the ShowMuteButton security right for this user (use TPropertyEnum.SecurityRights_ShowMuteButton).
Public property | ShowParkButton | Provides access to the property representing the ShowParkButton security right for this user (use TPropertyEnum.SecurityRights_ShowParkButton).
Public property | ShowPauseButton | Provides access to the property representing the ShowPauseButton security right for this user (use TPropertyEnum.SecurityRights_ShowPauseButton).
Public property | ShowPickupButton | Provides access to the property representing the ShowPickupButton security right for this user (use TPropertyEnum.SecurityRights_ShowPickupButton).
Public property | ShowPrivateButton | Provides access to the property representing the ShowPrivateButton security right for this user (use TPropertyEnum.SecurityRights_ShowPrivateButton).
Public property | ShowRecordButton | Provides access to the property representing the ShowRecordButton security right for this user (use TPropertyEnum.SecurityRights_ShowRecordButton).
Public property | ShowRecordingSnippetButton | Provides access to the property representing the ShowRecordingSnippetButton security right for this user (use TPropertyEnum.SecurityRights_ShowRecordingSnippetButton).
Public property | ShowSecureInputButton | Provides access to the property representing the ShowSecureInputButton security right for this user (use TPropertyEnum.SecurityRights_ShowSecureInputButton).
Public property | ShowSecureRecordingPauseButton | Provides access to the property representing the ShowSecureRecordingPauseButton security right for this user (use TPropertyEnum.SecurityRights_ShowSecureRecordingPauseButton).
Public property | ShowTransferButton | Provides access to the property representing the ShowTransferButton security right for this user (use TPropertyEnum.SecurityRights_ShowTransferButton).
Public property | ShowVoicemailButton | Provides access to the property representing the ShowVoicemailButton security right for this user (use TPropertyEnum.SecurityRights_ShowVoicemailButton).
Public property | ShowWorkgroupsProfilesTab | Provides access to the property representing the ShowWorkgroupsProfilesTab security right for this user (use TPropertyEnum.SecurityRights_ShowWorkgroupsProfilesTab).
Public property | TraceConfiguration | Provides access to the property representing the TraceConfiguration security right for this user (use TPropertyEnum.SecurityRights_TraceConfiguration).
Public property | TrackerAdministrator | Provides access to the property representing the TrackerAdministrator security right for this user (use TPropertyEnum.SecurityRights_TrackerAdministrator).
Public property | UseTiffForFaxes | Provides access to the property representing the UseTiffForFaxes security right for this user (use TPropertyEnum.SecurityRights_UseTiffForFaxes).
Public property | ViewConfigurationChangeAuditing | Provides access to the property representing the ViewConfigurationChangeAuditing security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationChangeAuditing).
Public property | ViewConfigurationGeneral | Provides access to the property representing the ViewConfigurationGeneral security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationGeneral).
Public property | ViewConfigurationHTTPServer | Provides access to the property representing the ViewConfigurationHTTPServer security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationHTTPServer).
Public property | ViewConfigurationOutboundServers | Provides access to the property representing the ViewConfigurationOutboundServers security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationOutboundServers).
Public property | ViewConfigurationPhoneNumberTypes | Provides access to the property representing the ViewConfigurationPhoneNumberTypes security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationPhoneNumberTypes).
Public property | ViewConfigurationPreviewCallBehavior | Provides access to the property representing the DialerConfigurationViewPreviewCallBehavior security right for this user (use TPropertyEnum.SecurityRights_DialerConfigurationViewPreviewCallBehavior).
Public property | ViewInteractionDetails | Provides access to the property representing the ViewInteractionDetails security right for this user (use TPropertyEnum.SecurityRights_ViewInteractionDetails).
Public property | ViewModifyCampaignAgentlessCallingType | Provides access to the property representing the ViewModifyCampaignAgentlessCallingType security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignAgentlessCallingType).
Public property | ViewModifyCampaignAutomaticTimeZoneMapping | Provides access to the property representing the ViewModifyCampaignAutomaticTimeZoneMapping security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignAutomaticTimeZoneMapping).
Public property | ViewModifyCampaignLineSettings | Provides access to the property representing the ViewModifyCampaignLineSettings security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignLineSettings).
Public property | ViewModifyCampaignMaxLines | Provides access to the property representing the ViewModifyCampaignMaxLines security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignMaxLines).
Public property | ViewModifyCampaignStatus | Provides access to the property representing the ViewModifyCampaignStatus security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignStatus).
Public property | ViewModifyContactListDataQuery | Provides access to the property representing the ViewModifyContactListDataQuery security right for this user (use TPropertyEnum.SecurityRights_ViewModifyContactListDataQuery).
Public property | ViewModifyCustomHandlerActions | Provides access to the property representing the ViewModifyCustomHandlerActions security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCustomHandlerActions).
Public property | ViewModifyDatabaseConnections | Provides access to the property representing the ViewModifyDatabaseConnections security right for this user (use TPropertyEnum.SecurityRights_ViewModifyDatabaseConnections).
Public property | ViewModifyDncSources | Provides access to the property representing the ViewModifyDncSources security right for this user (use TPropertyEnum.SecurityRights_ViewModifyDncSources).
Public property | ViewModifyEventLog | Provides access to the property representing the ViewModifyEventLog security right for this user (use TPropertyEnum.SecurityRights_ViewModifyEventLog).
Public property | ViewModifyTimeZoneMapData | Provides access to the property representing the ViewModifyTimeZoneMapData security right for this user (use TPropertyEnum.SecurityRights_ViewModifyTimeZoneMapData).
Public property | ViewOtherPeoplesPrivateInteractions | Provides access to the property representing the ViewOtherPeoplesPrivateInteractions security right for this user (use TPropertyEnum.SecurityRights_ViewOtherPeoplesPrivateInteractions).

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


UserSecurityRightsProperties(TConfigurationObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Methods
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


UserSecurityRightsProperties(TConfigurationObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Properties
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback

The UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AccessAllInteractionConferences | Provides access to the property representing the AccessAllInteractionConferences security right for this user (use TPropertyEnum.SecurityRights_AccessAllInteractionConferences).
Public property | AccessOwnedInteractionConferences | Provides access to the property representing the AccessOwnedInteractionConferences security right for this user (use TPropertyEnum.SecurityRights_AccessOwnedInteractionConferences).
Public property | AccountCodeVerification | Provides access to the property representing the account code verification security right for this user (use TPropertyEnum.SecurityRights_AccountCodeVerification).
Public property | AddIndividuals | Provides access to the property representing the add individuals security right for this user (use TPropertyEnum.SecurityRights_AddIndividuals).
Public property | AddOrganizations | Provides access to the property representing the add organizations security right for this user (use TPropertyEnum.SecurityRights_AddOrganizations).
Public property | AgentPreferences | Provides access to the property representing the AgentPreferences security right for this user (use TPropertyEnum.SecurityRights_AgentPreferences).
Public property | AlertAdministrator | Provides access to the property representing the AlertAdministrator security right for this user (use TPropertyEnum.SecurityRights_AlertAdministrator).
Public property | AllowAccessToProblemReporter | Provides access to the property representing the AllowAccessToProblemReporter security right for this user (use TPropertyEnum.SecurityRights_AllowAccessToProblemReporter).
Public property | AllowAgentComplianceOverride | Provides access to the property representing the AllowAgentComplianceOverride security right for this user (use TPropertyEnum.SecurityRights_AllowAgentComplianceOverride).
Public property | AllowAgentRules | Provides access to the property representing the AllowAgentRules security right for this user (use TPropertyEnum.SecurityRights_AllowAgentRules).
Public property | AllowAgentScheduleBidding | Provides access to the property representing the AllowAgentScheduleBidding security right for this user (use TPropertyEnum.SecurityRights_AllowAgentScheduleBidding).
Public property | AllowAgentSeeOwnRank | Provides access to the property representing the AllowAgentSeeOwnRank security right for this user (use TPropertyEnum.SecurityRights_AllowAgentSeeOwnRank).
Public property | AllowAgentSeeRelativeRank | Provides access to the property representing the AllowAgentSeeRelativeRank security right for this user (use TPropertyEnum.SecurityRights_AllowAgentSeeRelativeRank ).
Public property | AllowAlertProgramming | Provides access to the property representing the AllowAlertProgramming security right for this user (use TPropertyEnum.SecurityRights_AllowAlertProgramming).
Public property | AllowEmailAccessViaTui | Provides access to the property representing the AllowEmailAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowEmailAccessViaTui).
Public property | AllowEmailAlerts | Provides access to the property representing the AllowEmailAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowEmailAlerts).
Public property | AllowFaxAccessViaTui | Provides access to the property representing the AllowFaxAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowFaxAccessViaTui).
Public property | AllowHandlerAlerts | Provides access to the property representing the AllowHandlerAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowHandlerAlerts).
Public property | AllowIntercomChat | Provides access to the property representing the AllowIntercomChat security right for this user (use TPropertyEnum.SecurityRights_AllowIntercomChat).
Public property | AllowMemoAlerts | Provides access to the property representing the AllowMemoAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowMemoAlerts).
Public property | AllowMiniMode | Provides access to the property representing the AllowMiniMode security right for this user (use TPropertyEnum.SecurityRights_AllowMiniMode).
Public property | AllowMonitorColumns | Provides access to the property representing the AllowMonitorColumns security right for this user (use TPropertyEnum.SecurityRights_AllowMonitorColumns).
Public property | AllowMultipleCalls | Provides access to the property representing the AllowMultipleCalls security right for this user (use TPropertyEnum.SecurityRights_AllowMultipleCalls).
Public property | AllowPersistentConnections | Provides access to the property representing the AllowPersistentConnections security right for this user (use TPropertyEnum.SecurityRights_AllowPersistentConnections).
Public property | AllowReceiveVoicemail | Provides access to the property representing the AllowReceiveVoicemail security right for this user (use TPropertyEnum.SecurityRights_AllowReceiveVoicemail).
Public property | AllowRelatedInteractionsPage | Provides access to the property representing the AllowRelatedInteractionsPage security right for this user (use TPropertyEnum.SecurityRights_AllowRelatedInteractionsPage).
Public property | AllowResponseManagement | Provides access to the property representing the AllowResponseManagement security right for this user (use TPropertyEnum.SecurityRights_AllowResponseManagement).
Public property | AllowSpeedDials | Provides access to the property representing the AllowSpeedDials security right for this user (use TPropertyEnum.SecurityRights_AllowSpeedDials).
Public property | AllowStatusNotes | Provides access to the property representing the AllowStatusNotes security right for this user (use TPropertyEnum.SecurityRights_AllowStatusNotes).
Public property | AllowUserDefinedTelephoneNumberOnRemoteLogin | Provides access to the property representing the AllowUserDefinedTelephoneNumberOnRemoteLogin security right for this user (use TPropertyEnum.SecurityRights_AllowUserDefinedTelephoneNumberOnRemoteLogin).
Public property | AllowVideo | Provides access to the property representing the AllowVideo security right for this user (use TPropertyEnum.SecurityRights_AllowVideo).
Public property | AllowVoiceMaiAccessViaTui | Provides access to the property representing the AllowVoiceMaiAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowVoiceMaiAccessViaTui).
Public property | AllowWorkgroupStats | Provides access to the property representing the AllowWorkgroupStats security right for this user (use TPropertyEnum.SecurityRights_AllowWorkgroupStats).
Public property | CanAccessOptimizerShiftTrading | Provides access to the property representing the CanAccessOptimizerShiftTrading security right for this user (use TPropertyEnum.SecurityRights_CanAccessOptimizerShiftTrading).
Public property | CanCoachInteractions | Provides access to the property representing the CanCoachInteractions security right for this user (use TPropertyEnum.SecurityRights_CanCoachInteractions).
Public property | CanConferenceCalls | Provides access to the property representing the CanConferenceCalls security right for this user (use TPropertyEnum.SecurityRights_CanConferenceCalls).
Public property | CanCreateAlertSets | Provides access to the property representing the CanCreateAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanCreateAlertSets).
Public property | CanCreateOptimizerActivityCodes | Provides access to the property representing the right to create optimizer activity codes (use TPropertyEnum.SecurityRights_CanCreateOptimizerActivityCodes).
Public property | CanCreateOptimizerDayClassifications | Provides access to the property representing the CanCreateOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanCreateOptimizerDayClassifications).
Public property | CanCreateQuestionnaireDirectories | Provides access to the property representing the CanCreateQuestionnaireDirectories security right for this user (use TPropertyEnum.SecurityRights_CanCreateQuestionnaireDirectories).
Public property | CanCreateSchedulingUnits | Provides access to the property representing the CanCreateSchedulingUnits security right for this user (use TPropertyEnum.SecurityRights_CanCreateSchedulingUnits).
Public property | CanDeleteOptimizerActivityCodes | Provides access to the property representing the right to delete optimizer activity codes (use TPropertyEnum.SecurityRights_CanDeleteOptimizerActivityCodes).
Public property | CanDeleteOptimizerDayClassifications | Provides access to the property representing the CanDeleteOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanDeleteOptimizerDayClassifications).
Public property | CanDeleteSchedulingUnits | Provides access to the property representing the CanDeleteSchedulingUnits security right for this user (use TPropertyEnum.SecurityRights_CanDeleteSchedulingUnits).
Public property | CanDisconnectInteractions | Provides access to the property representing the CanDisconnectInteractions security right for this user (use TPropertyEnum.SecurityRights_CanDisconnectInteractions).
Public property | CanForceSubscribeAlertSets | Provides access to the property representing the CanForceSubscribeAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanForceSubscribeAlertSets).
Public property | CanInitiateRecordingSnippet | Provides access to the property representing the CanInitiateRecordingSnippet security right for this user (use TPropertyEnum.SecurityRights_CanInitiateRecordingSnippet).
Public property | CanInitiateSecureInput | Provides access to the property representing the CanInitiateSecureInput security right for this user (use TPropertyEnum.SecurityRights_CanInitiateSecureInput).
Public property | CanJoinInteractions | Provides access to the property representing the CanJoinInteractions security right for this user (use TPropertyEnum.SecurityRights_CanJoinInteractions).
Public property | CanListenInOnInteractions | Provides access to the property representing the CanListenInOnInteractions security right for this user (use TPropertyEnum.SecurityRights_CanListenInOnInteractions).
Public property | CanManageClientTemplates | Provides access to the property representing the CanManageClientTemplates security right for this user (use TPropertyEnum.SecurityRights_CanManageClientTemplates).
Public property | CanModifyOptimizerActivityCodes | Provides access to the property representing the right to modify optimizer activity codes (use TPropertyEnum.SecurityRights_CanModifyOptimizerActivityCodes).
Public property | CanModifyOptimizerDayClassifications | Provides access to the property representing the CanModifyOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanModifyOptimizerDayClassifications).
Public property | CanModifyOptimizerStatusActivityTypeMapping | Provides access to the property representing the right to modify optimizer activity type mapping (use TPropertyEnum.SecurityRights_CanModifyOptimizerStatusActivityTypeMapping).
Public property | CanMuteInteractions | Provides access to the property representing the CanMuteInteractions security right for this user (use TPropertyEnum.SecurityRights_CanMuteInteractions).
Public property | CanOrbitQueue | Provides access to the property representing the CanOrbitQueue security right for this user (use TPropertyEnum.SecurityRights_CanOrbitQueue).
Public property | CanOverrideFinishedScorecards | Provides access to the property representing the CanOverrideFinishedScorecards security right for this user (use TPropertyEnum.SecurityRights_CanOverrideFinishedScorecards).
Public property | CanParkInteractions | Provides access to the property representing the CanParkInteractions security right for this user (use TPropertyEnum.SecurityRights_CanParkInteractions).
Public property | CanPauseInteractions | Provides access to the property representing the CanPauseInteractions security right for this user (use TPropertyEnum.SecurityRights_CanPauseInteractions).
Public property | CanPickupInteractions | Provides access to the property representing the CanPickupInteractions security right for this user (use TPropertyEnum.SecurityRights_CanPickupInteractions).
Public property | CanPublishProcess | Provides access to the property representing the CanPublishProcess security right for this user (use TPropertyEnum.SecurityRights_CanPublishProcess).
Public property | CanPutInteractionsOnHold | Provides access to the property representing the CanPutInteractionsOnHold security right for this user (use TPropertyEnum.SecurityRights_CanPutInteractionsOnHold).
Public property | CanRecordInteractions | Provides access to the property representing the CanRecordInteractions security right for this user (use TPropertyEnum.SecurityRights_CanRecordInteractions).
Public property | CanRequestAssistanceFromSupervisor | Provides access to the property representing the CanRequestAssistanceFromSupervisor security right for this user (use TPropertyEnum.SecurityRights_CanRequestAssistanceFromSupervisor).
Public property | CanSecureRecordingPauseInteractions | Provides access to the property representing the CanSecureRecordingPauseInteractions security right for this user (use TPropertyEnum.SecurityRights_CanSecureRecordingPauseInteractions).
Public property | CanShareAlertSets | Provides access to the property representing the CanShareAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanShareAlertSets).
Public property | CanSubmitTimeOff | Provides access to the property representing the CanSubmitTimeOff security right for this user (use TPropertyEnum.SecurityRights_CanSubmitTimeOff).
Public property | CanTransferInteractions | Provides access to the property representing the CanTransferInteractions security right for this user (use TPropertyEnum.SecurityRights_CanTransferInteractions).
Public property | CanTransferInteractionsToVoicemail | Provides access to the property representing the CanTransferInteractionsToVoicemail security right for this user (use TPropertyEnum.SecurityRights_CanTransferInteractionsToVoicemail).
Public property | CanUserInteractionRecorderSelector | Provides access to the property representing the CanUserInteractionRecorderSelector security right for this user (use TPropertyEnum.SecurityRights_CanUserInteractionRecorderSelector).
Public property | CanViewOptimizerActivityCodes | Provides access to the property representing the right to view optimizer activity codes (use TPropertyEnum.SecurityRights_CanViewOptimizerActivityCodes).
Public property | CanViewOptimizerDayClassifications | Provides access to the property representing the CanViewOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanViewOptimizerDayClassifications).
Public property | CanViewOptimizerStatusActivityTypeMapping | Provides access to the property representing the right to view optimizer activity type mapping (use TPropertyEnum.SecurityRights_CanViewOptimizerStatusActivityTypeMapping).
Public property | CloudWorkforceEngagementAdministrator | Provides access to the property representing the CloudWorkforceEngagementAdministrator security right for this user (use TPropertyEnum.SecurityRights_CloudWorkforceEngagementAdministrator).
Public property | ContactListRecordOwnershipControl | Provides access to the property representing the ContactListRecordOwnershipControl security right for this user (use TPropertyEnum.SecurityRights_ContactListRecordOwnershipControl).
Public property | CreateModifyCampaignGroup | Provides access to the property representing the CreateModifyCampaignGroup security right for this user (use TPropertyEnum.SecurityRights_CreateModifyCampaignGroup).
Public property | CustomizeClient | Provides access to the property representing the CustomizeClient security right for this user (use TPropertyEnum.SecurityRights_CustomizeClient).
Public property | DataExtractorJobAdmin | Provides access to the property representing the DataExtractorJobAdmin security right for this user (use TPropertyEnum.SecurityRights_DataExtractorJobAdmin).
Public property | DebugHandlers | Provides access to the property representing the DebugHandlers security right for this user (use TPropertyEnum.SecurityRights_DebugHandlers).
Public property | DeleteIndividuals | Provides access to the property representing the DeleteIndividuals security right for this user (use TPropertyEnum.SecurityRights_DeleteIndividuals).
Public property | DeleteOrganizations | Provides access to the property representing the DeleteOrganizations security right for this user (use TPropertyEnum.SecurityRights_DeleteOrganizations).
Public property | DirectoryAdmin | Provides access to the property representing the DirectoryAdmin security right for this user (use TPropertyEnum.SecurityRights_DirectoryAdmin).
Public property | ExecuteLongRunningQueries | Obsolete. Provides access to the property representing the ExecuteLongRunningQueries security right for this user (use TPropertyEnum.SecurityRights_ExecuteLongRunningQueries).
Public property | FollowMe | Provides access to the property representing the FollowMe security right for this user (use TPropertyEnum.SecurityRights_FollowMe).
Public property | ForceUserLogout | Provides access to the property representing the ForceUserLogout security right for this user (use TPropertyEnum.SecurityRights_ForceUserLogout).
Public property | HavePrivateContacts | Provides access to the property representing the HavePrivateContacts security right for this user (use TPropertyEnum.SecurityRights_HavePrivateContacts).
Public property | IPPhoneProvisioningAdmin | Provides access to the property representing the IPPhoneProvisioningAdmin security right for this user (use TPropertyEnum.SecurityRights_IPPhoneProvisioningAdmin).
Public property | LockPolicySets | Provides access to the property representing the LockPolicySets security right for this user (use TPropertyEnum.SecurityRights_LockPolicySets).
Public property | LoginCampaign | Provides access to the property representing the LoginCampaign security right for this user (use TPropertyEnum.SecurityRights_LoginCampaign).
Public property | ManageHandlers | Provides access to the property representing the ManageHandlers security right for this user (use TPropertyEnum.SecurityRights_ManageHandlers).
Public property | ManualTransitionSequence | Provides access to the property representing the ManualTransitionSequence security right for this user (use TPropertyEnum.SecurityRights_ManualTransitionSequence).
Public property | MobileOfficeUser | Provides access to the property representing the MobileOfficeUser security right for this user (use TPropertyEnum.SecurityRights_MobileOfficeUser).
Public property | ModifyBaseScriptAgentComplianceOverride | Provides access to the property representing the ModifyBaseScriptAgentComplianceOverride security right for this user (use TPropertyEnum.SecurityRights_ModifyBaseScriptAgentComplianceOverride).
Public property | ModifyCampaignGroupSequence | Provides access to the property representing the ModifyCampaignGroupSequence security right for this user (use TPropertyEnum.SecurityRights_ModifyCampaignGroupSequence).
Public property | ModifyConfigurationChangeAuditing | Provides access to the property representing the ModifyConfigurationChangeAuditing security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationChangeAuditing).
Public property | ModifyConfigurationGeneral | Provides access to the property representing the ModifyConfigurationGeneral security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationGeneral).
Public property | ModifyConfigurationHTTPServer | Provides access to the property representing the ModifyConfigurationHTTPServer security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationHTTPServer).
Public property | ModifyConfigurationOutboundServers | Provides access to the property representing the ModifyConfigurationOutboundServers security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationOutboundServers).
Public property | ModifyConfigurationPhoneNumberTypes | Provides access to the property representing the ModifyConfigurationPhoneNumberTypes security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationPhoneNumberTypes).
Public property | ModifyConfigurationPreviewCallBehavior | Provides access to the property representing the ModifyConfigurationPreviewCallBehavior security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationPreviewCallBehavior).
Public property | ModifyIndividuals | Provides access to the property representing the ModifyIndividuals security right for this user (use TPropertyEnum.SecurityRights_ModifyIndividuals).
Public property | ModifyInteractions | Provides access to the property representing the ModifyInteractions security right for this user (use TPropertyEnum.SecurityRights_ModifyInteractions).
Public property | ModifyOrganizations | Provides access to the property representing the ModifyOrganizations security right for this user (use TPropertyEnum.SecurityRights_ModifyOrganizations).
Public property | OutlookTuiUser | Provides access to the property representing the OutlookTuiUser security right for this user (use TPropertyEnum.SecurityRights_OutlookTuiUser).
Public property | PrivateCalls | Provides access to the property representing the PrivateCalls security right for this user (use TPropertyEnum.SecurityRights_PrivateCalls).
Public property | PublishHandlers | Provides access to the property representing the PublishHandlers security right for this user (use TPropertyEnum.SecurityRights_PublishHandlers).
Public property | RemoteControl | Provides access to the property representing the RemoteControl security right for this user (use TPropertyEnum.SecurityRights_RemoteControl).
Public property | ReporterAdministrator | Provides access to the property representing the Interaction Reporter Administrator security right for this user (use TPropertyEnum.SecurityRights_ReporterAdministrator).
Public property | RequireForcedAuthorizationCode | Provides access to the property representing the RequireForcedAuthorizationCode security right for this user (use TPropertyEnum.SecurityRights_RequireForcedAuthorizationCode).
Public property | RunContactListPredefinedActions | Provides access to the property representing the RunContactListPredefinedActions security right for this user (use TPropertyEnum.SecurityRights_RunContactListPredefinedActions).
Public property | ShowAssistanceButton | Provides access to the property representing the ShowAssistanceButton security right for this user (use TPropertyEnum.SecurityRights_ShowAssistanceButton).
Public property | ShowCoachButton | Provides access to the property representing the ShowCoachButton security right for this user (use TPropertyEnum.SecurityRights_ShowCoachButton).
Public property | ShowDisconnectButton | Provides access to the property representing the ShowDisconnectButton security right for this user (use TPropertyEnum.SecurityRights_ShowDisconnectButton).
Public property | ShowHoldButton | Provides access to the property representing the ShowHoldButton security right for this user (use TPropertyEnum.SecurityRights_ShowHoldButton).
Public property | ShowJoinButton | Provides access to the property representing the ShowJoinButton security right for this user (use TPropertyEnum.SecurityRights_ShowJoinButton).
Public property | ShowListenButton | Provides access to the property representing the ShowListenButton security right for this user (use TPropertyEnum.SecurityRights_ShowListenButton).
Public property | ShowMuteButton | Provides access to the property representing the ShowMuteButton security right for this user (use TPropertyEnum.SecurityRights_ShowMuteButton).
Public property | ShowParkButton | Provides access to the property representing the ShowParkButton security right for this user (use TPropertyEnum.SecurityRights_ShowParkButton).
Public property | ShowPauseButton | Provides access to the property representing the ShowPauseButton security right for this user (use TPropertyEnum.SecurityRights_ShowPauseButton).
Public property | ShowPickupButton | Provides access to the property representing the ShowPickupButton security right for this user (use TPropertyEnum.SecurityRights_ShowPickupButton).
Public property | ShowPrivateButton | Provides access to the property representing the ShowPrivateButton security right for this user (use TPropertyEnum.SecurityRights_ShowPrivateButton).
Public property | ShowRecordButton | Provides access to the property representing the ShowRecordButton security right for this user (use TPropertyEnum.SecurityRights_ShowRecordButton).
Public property | ShowRecordingSnippetButton | Provides access to the property representing the ShowRecordingSnippetButton security right for this user (use TPropertyEnum.SecurityRights_ShowRecordingSnippetButton).
Public property | ShowSecureInputButton | Provides access to the property representing the ShowSecureInputButton security right for this user (use TPropertyEnum.SecurityRights_ShowSecureInputButton).
Public property | ShowSecureRecordingPauseButton | Provides access to the property representing the ShowSecureRecordingPauseButton security right for this user (use TPropertyEnum.SecurityRights_ShowSecureRecordingPauseButton).
Public property | ShowTransferButton | Provides access to the property representing the ShowTransferButton security right for this user (use TPropertyEnum.SecurityRights_ShowTransferButton).
Public property | ShowVoicemailButton | Provides access to the property representing the ShowVoicemailButton security right for this user (use TPropertyEnum.SecurityRights_ShowVoicemailButton).
Public property | ShowWorkgroupsProfilesTab | Provides access to the property representing the ShowWorkgroupsProfilesTab security right for this user (use TPropertyEnum.SecurityRights_ShowWorkgroupsProfilesTab).
Public property | TraceConfiguration | Provides access to the property representing the TraceConfiguration security right for this user (use TPropertyEnum.SecurityRights_TraceConfiguration).
Public property | TrackerAdministrator | Provides access to the property representing the TrackerAdministrator security right for this user (use TPropertyEnum.SecurityRights_TrackerAdministrator).
Public property | UseTiffForFaxes | Provides access to the property representing the UseTiffForFaxes security right for this user (use TPropertyEnum.SecurityRights_UseTiffForFaxes).
Public property | ViewConfigurationChangeAuditing | Provides access to the property representing the ViewConfigurationChangeAuditing security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationChangeAuditing).
Public property | ViewConfigurationGeneral | Provides access to the property representing the ViewConfigurationGeneral security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationGeneral).
Public property | ViewConfigurationHTTPServer | Provides access to the property representing the ViewConfigurationHTTPServer security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationHTTPServer).
Public property | ViewConfigurationOutboundServers | Provides access to the property representing the ViewConfigurationOutboundServers security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationOutboundServers).
Public property | ViewConfigurationPhoneNumberTypes | Provides access to the property representing the ViewConfigurationPhoneNumberTypes security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationPhoneNumberTypes).
Public property | ViewConfigurationPreviewCallBehavior | Provides access to the property representing the DialerConfigurationViewPreviewCallBehavior security right for this user (use TPropertyEnum.SecurityRights_DialerConfigurationViewPreviewCallBehavior).
Public property | ViewInteractionDetails | Provides access to the property representing the ViewInteractionDetails security right for this user (use TPropertyEnum.SecurityRights_ViewInteractionDetails).
Public property | ViewModifyCampaignAgentlessCallingType | Provides access to the property representing the ViewModifyCampaignAgentlessCallingType security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignAgentlessCallingType).
Public property | ViewModifyCampaignAutomaticTimeZoneMapping | Provides access to the property representing the ViewModifyCampaignAutomaticTimeZoneMapping security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignAutomaticTimeZoneMapping).
Public property | ViewModifyCampaignLineSettings | Provides access to the property representing the ViewModifyCampaignLineSettings security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignLineSettings).
Public property | ViewModifyCampaignMaxLines | Provides access to the property representing the ViewModifyCampaignMaxLines security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignMaxLines).
Public property | ViewModifyCampaignStatus | Provides access to the property representing the ViewModifyCampaignStatus security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignStatus).
Public property | ViewModifyContactListDataQuery | Provides access to the property representing the ViewModifyContactListDataQuery security right for this user (use TPropertyEnum.SecurityRights_ViewModifyContactListDataQuery).
Public property | ViewModifyCustomHandlerActions | Provides access to the property representing the ViewModifyCustomHandlerActions security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCustomHandlerActions).
Public property | ViewModifyDatabaseConnections | Provides access to the property representing the ViewModifyDatabaseConnections security right for this user (use TPropertyEnum.SecurityRights_ViewModifyDatabaseConnections).
Public property | ViewModifyDncSources | Provides access to the property representing the ViewModifyDncSources security right for this user (use TPropertyEnum.SecurityRights_ViewModifyDncSources).
Public property | ViewModifyEventLog | Provides access to the property representing the ViewModifyEventLog security right for this user (use TPropertyEnum.SecurityRights_ViewModifyEventLog).
Public property | ViewModifyTimeZoneMapData | Provides access to the property representing the ViewModifyTimeZoneMapData security right for this user (use TPropertyEnum.SecurityRights_ViewModifyTimeZoneMapData).
Public property | ViewOtherPeoplesPrivateInteractions | Provides access to the property representing the ViewOtherPeoplesPrivateInteractions security right for this user (use TPropertyEnum.SecurityRights_ViewOtherPeoplesPrivateInteractions).

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


AccessAllInteractionConferences Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccessAllInteractionConferences Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AccessAllInteractionConferences security right for this user (use TPropertyEnum.SecurityRights_AccessAllInteractionConferences).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AccessAllInteractionConferences { get; }
Visual Basic
Public ReadOnly Property AccessAllInteractionConferences As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AccessAllInteractionConferences security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AccessOwnedInteractionConferences Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccessOwnedInteractionConferences Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AccessOwnedInteractionConferences security right for this user (use TPropertyEnum.SecurityRights_AccessOwnedInteractionConferences).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AccessOwnedInteractionConferences { get; }
Visual Basic
Public ReadOnly Property AccessOwnedInteractionConferences As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AccessOwnedInteractionConferences security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AccountCodeVerification Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AccountCodeVerification Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the account code verification security right for this user (use TPropertyEnum.SecurityRights_AccountCodeVerification).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AccountCodeVerification { get; }
Visual Basic
Public ReadOnly Property AccountCodeVerification As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the account code verification security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AddIndividuals Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AddIndividuals Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the add individuals security right for this user (use TPropertyEnum.SecurityRights_AddIndividuals).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AddIndividuals { get; }
Visual Basic
Public ReadOnly Property AddIndividuals As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the add individuals security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AddOrganizations Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AddOrganizations Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the add organizations security right for this user (use TPropertyEnum.SecurityRights_AddOrganizations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AddOrganizations { get; }
Visual Basic
Public ReadOnly Property AddOrganizations As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the add organizations security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AgentPreferences Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AgentPreferences Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AgentPreferences security right for this user (use TPropertyEnum.SecurityRights_AgentPreferences).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AgentPreferences { get; }
Visual Basic
Public ReadOnly Property AgentPreferences As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AgentPreferences security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AlertAdministrator Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AlertAdministrator Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AlertAdministrator security right for this user (use TPropertyEnum.SecurityRights_AlertAdministrator).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AlertAdministrator { get; }
Visual Basic
Public ReadOnly Property AlertAdministrator As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AlertAdministrator security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAccessToProblemReporter Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAccessToProblemReporter Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAccessToProblemReporter security right for this user (use TPropertyEnum.SecurityRights_AllowAccessToProblemReporter).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAccessToProblemReporter { get; }
Visual Basic
Public ReadOnly Property AllowAccessToProblemReporter As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAccessToProblemReporter security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAgentComplianceOverride Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAgentComplianceOverride Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAgentComplianceOverride security right for this user (use TPropertyEnum.SecurityRights_AllowAgentComplianceOverride).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAgentComplianceOverride { get; }
Visual Basic
Public ReadOnly Property AllowAgentComplianceOverride As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAgentComplianceOverride security right.

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAgentRules Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAgentRules Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAgentRules security right for this user (use TPropertyEnum.SecurityRights_AllowAgentRules).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAgentRules { get; }
Visual Basic
Public ReadOnly Property AllowAgentRules As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAgentRules security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAgentScheduleBidding Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAgentScheduleBidding Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAgentScheduleBidding security right for this user (use TPropertyEnum.SecurityRights_AllowAgentScheduleBidding).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAgentScheduleBidding { get; }
Visual Basic
Public ReadOnly Property AllowAgentScheduleBidding As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAgentScheduleBidding security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAgentSeeOwnRank Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAgentSeeOwnRank Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAgentSeeOwnRank security right for this user (use TPropertyEnum.SecurityRights_AllowAgentSeeOwnRank).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAgentSeeOwnRank { get; }
Visual Basic
Public ReadOnly Property AllowAgentSeeOwnRank As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAgentSeeOwnRank security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAgentSeeRelativeRank Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAgentSeeRelativeRank Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAgentSeeRelativeRank security right for this user (use TPropertyEnum.SecurityRights_AllowAgentSeeRelativeRank ).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAgentSeeRelativeRank { get; }
Visual Basic
Public ReadOnly Property AllowAgentSeeRelativeRank As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAgentSeeRelativeRank security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowAlertProgramming Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowAlertProgramming Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowAlertProgramming security right for this user (use TPropertyEnum.SecurityRights_AllowAlertProgramming).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowAlertProgramming { get; }
Visual Basic
Public ReadOnly Property AllowAlertProgramming As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowAlertProgramming security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowEmailAccessViaTui Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowEmailAccessViaTui Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowEmailAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowEmailAccessViaTui).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowEmailAccessViaTui { get; }
Visual Basic
Public ReadOnly Property AllowEmailAccessViaTui As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowEmailAccessViaTui security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowEmailAlerts Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowEmailAlerts Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowEmailAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowEmailAlerts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowEmailAlerts { get; }
Visual Basic
Public ReadOnly Property AllowEmailAlerts As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowEmailAlerts security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowFaxAccessViaTui Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowFaxAccessViaTui Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowFaxAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowFaxAccessViaTui).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowFaxAccessViaTui { get; }
Visual Basic
Public ReadOnly Property AllowFaxAccessViaTui As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowFaxAccessViaTui security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowHandlerAlerts Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowHandlerAlerts Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowHandlerAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowHandlerAlerts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowHandlerAlerts { get; }
Visual Basic
Public ReadOnly Property AllowHandlerAlerts As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowHandlerAlerts security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowIntercomChat Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowIntercomChat Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowIntercomChat security right for this user (use TPropertyEnum.SecurityRights_AllowIntercomChat).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowIntercomChat { get; }
Visual Basic
Public ReadOnly Property AllowIntercomChat As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowIntercomChat security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowMemoAlerts Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowMemoAlerts Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowMemoAlerts security right for this user (use TPropertyEnum.SecurityRights_AllowMemoAlerts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowMemoAlerts { get; }
Visual Basic
Public ReadOnly Property AllowMemoAlerts As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowMemoAlerts security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowMiniMode Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowMiniMode Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowMiniMode security right for this user (use TPropertyEnum.SecurityRights_AllowMiniMode).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowMiniMode { get; }
Visual Basic
Public ReadOnly Property AllowMiniMode As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowMiniMode security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowMonitorColumns Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowMonitorColumns Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowMonitorColumns security right for this user (use TPropertyEnum.SecurityRights_AllowMonitorColumns).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowMonitorColumns { get; }
Visual Basic
Public ReadOnly Property AllowMonitorColumns As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowMonitorColumns security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowMultipleCalls Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowMultipleCalls Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowMultipleCalls security right for this user (use TPropertyEnum.SecurityRights_AllowMultipleCalls).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowMultipleCalls { get; }
Visual Basic
Public ReadOnly Property AllowMultipleCalls As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowMultipleCalls security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowPersistentConnections Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowPersistentConnections Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowPersistentConnections security right for this user (use TPropertyEnum.SecurityRights_AllowPersistentConnections).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowPersistentConnections { get; }
Visual Basic
Public ReadOnly Property AllowPersistentConnections As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowPersistentConnections security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowReceiveVoicemail Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowReceiveVoicemail Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowReceiveVoicemail security right for this user (use TPropertyEnum.SecurityRights_AllowReceiveVoicemail).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowReceiveVoicemail { get; }
Visual Basic
Public ReadOnly Property AllowReceiveVoicemail As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowReceiveVoicemail security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowRelatedInteractionsPage Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowRelatedInteractionsPage Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowRelatedInteractionsPage security right for this user (use TPropertyEnum.SecurityRights_AllowRelatedInteractionsPage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowRelatedInteractionsPage { get; }
Visual Basic
Public ReadOnly Property AllowRelatedInteractionsPage As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowRelatedInteractionsPage security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowResponseManagement Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowResponseManagement Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowResponseManagement security right for this user (use TPropertyEnum.SecurityRights_AllowResponseManagement).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowResponseManagement { get; }
Visual Basic
Public ReadOnly Property AllowResponseManagement As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowResponseManagement security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowSpeedDials Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowSpeedDials Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowSpeedDials security right for this user (use TPropertyEnum.SecurityRights_AllowSpeedDials).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowSpeedDials { get; }
Visual Basic
Public ReadOnly Property AllowSpeedDials As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowSpeedDials security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowStatusNotes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowStatusNotes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowStatusNotes security right for this user (use TPropertyEnum.SecurityRights_AllowStatusNotes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowStatusNotes { get; }
Visual Basic
Public ReadOnly Property AllowStatusNotes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowStatusNotes security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowUserDefinedTelephoneNumberOnRemoteLogin Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowUserDefinedTelephoneNumberOnRemoteLogin Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowUserDefinedTelephoneNumberOnRemoteLogin security right for this user (use TPropertyEnum.SecurityRights_AllowUserDefinedTelephoneNumberOnRemoteLogin).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowUserDefinedTelephoneNumberOnRemoteLogin { get; }
Visual Basic
Public ReadOnly Property AllowUserDefinedTelephoneNumberOnRemoteLogin As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowUserDefinedTelephoneNumberOnRemoteLogin security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowVideo Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowVideo Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowVideo security right for this user (use TPropertyEnum.SecurityRights_AllowVideo).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowVideo { get; }
Visual Basic
Public ReadOnly Property AllowVideo As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowVideo security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowVoiceMaiAccessViaTui Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowVoiceMaiAccessViaTui Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowVoiceMaiAccessViaTui security right for this user (use TPropertyEnum.SecurityRights_AllowVoiceMaiAccessViaTui).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowVoiceMaiAccessViaTui { get; }
Visual Basic
Public ReadOnly Property AllowVoiceMaiAccessViaTui As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowVoiceMaiAccessViaTui security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


AllowWorkgroupStats Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..AllowWorkgroupStats Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the AllowWorkgroupStats security right for this user (use TPropertyEnum.SecurityRights_AllowWorkgroupStats).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> AllowWorkgroupStats { get; }
Visual Basic
Public ReadOnly Property AllowWorkgroupStats As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the AllowWorkgroupStats security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanAccessOptimizerShiftTrading Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanAccessOptimizerShiftTrading Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanAccessOptimizerShiftTrading security right for this user (use TPropertyEnum.SecurityRights_CanAccessOptimizerShiftTrading).

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanAccessOptimizerShiftTrading { get; }
Visual Basic
Public ReadOnly Property CanAccessOptimizerShiftTrading As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanAccessOptimizerShiftTrading security right.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanCoachInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanCoachInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanCoachInteractions security right for this user (use TPropertyEnum.SecurityRights_CanCoachInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanCoachInteractions { get; }
Visual Basic
Public ReadOnly Property CanCoachInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanCoachInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanConferenceCalls Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanConferenceCalls Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanConferenceCalls security right for this user (use TPropertyEnum.SecurityRights_CanConferenceCalls).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanConferenceCalls { get; }
Visual Basic
Public ReadOnly Property CanConferenceCalls As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanConferenceCalls security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanCreateAlertSets Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanCreateAlertSets Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanCreateAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanCreateAlertSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanCreateAlertSets { get; }
Visual Basic
Public ReadOnly Property CanCreateAlertSets As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanCreateAlertSets security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanCreateOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanCreateOptimizerActivityCodes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to create optimizer activity codes (use TPropertyEnum.SecurityRights_CanCreateOptimizerActivityCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanCreateOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanCreateOptimizerActivityCodes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the create optimizer activity codes right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanCreateOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanCreateOptimizerDayClassifications Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanCreateOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanCreateOptimizerDayClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanCreateOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanCreateOptimizerDayClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanCreateOptimizerDayClassifications security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanCreateQuestionnaireDirectories Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanCreateQuestionnaireDirectories Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanCreateQuestionnaireDirectories security right for this user (use TPropertyEnum.SecurityRights_CanCreateQuestionnaireDirectories).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanCreateQuestionnaireDirectories { get; }
Visual Basic
Public ReadOnly Property CanCreateQuestionnaireDirectories As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanCreateQuestionnaireDirectories security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanCreateSchedulingUnits Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanCreateSchedulingUnits Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanCreateSchedulingUnits security right for this user (use TPropertyEnum.SecurityRights_CanCreateSchedulingUnits).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanCreateSchedulingUnits { get; }
Visual Basic
Public ReadOnly Property CanCreateSchedulingUnits As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanCreateSchedulingUnits security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanDeleteOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanDeleteOptimizerActivityCodes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to delete optimizer activity codes (use TPropertyEnum.SecurityRights_CanDeleteOptimizerActivityCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanDeleteOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanDeleteOptimizerActivityCodes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the delete optimizer activity codes right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanDeleteOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanDeleteOptimizerDayClassifications Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanDeleteOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanDeleteOptimizerDayClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanDeleteOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanDeleteOptimizerDayClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanDeleteOptimizerDayClassifications security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanDeleteSchedulingUnits Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanDeleteSchedulingUnits Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanDeleteSchedulingUnits security right for this user (use TPropertyEnum.SecurityRights_CanDeleteSchedulingUnits).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanDeleteSchedulingUnits { get; }
Visual Basic
Public ReadOnly Property CanDeleteSchedulingUnits As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanDeleteSchedulingUnits security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanDisconnectInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanDisconnectInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanDisconnectInteractions security right for this user (use TPropertyEnum.SecurityRights_CanDisconnectInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanDisconnectInteractions { get; }
Visual Basic
Public ReadOnly Property CanDisconnectInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanDisconnectInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanForceSubscribeAlertSets Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanForceSubscribeAlertSets Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanForceSubscribeAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanForceSubscribeAlertSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanForceSubscribeAlertSets { get; }
Visual Basic
Public ReadOnly Property CanForceSubscribeAlertSets As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanForceSubscribeAlertSets security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanInitiateRecordingSnippet Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanInitiateRecordingSnippet Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanInitiateRecordingSnippet security right for this user (use TPropertyEnum.SecurityRights_CanInitiateRecordingSnippet).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanInitiateRecordingSnippet { get; }
Visual Basic
Public ReadOnly Property CanInitiateRecordingSnippet As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanInitiateRecordingSnippet security right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanInitiateSecureInput Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanInitiateSecureInput Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanInitiateSecureInput security right for this user (use TPropertyEnum.SecurityRights_CanInitiateSecureInput).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanInitiateSecureInput { get; }
Visual Basic
Public ReadOnly Property CanInitiateSecureInput As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanInitiateSecureInput security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanJoinInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanJoinInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanJoinInteractions security right for this user (use TPropertyEnum.SecurityRights_CanJoinInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanJoinInteractions { get; }
Visual Basic
Public ReadOnly Property CanJoinInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanJoinInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanListenInOnInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanListenInOnInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanListenInOnInteractions security right for this user (use TPropertyEnum.SecurityRights_CanListenInOnInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanListenInOnInteractions { get; }
Visual Basic
Public ReadOnly Property CanListenInOnInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanListenInOnInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanManageClientTemplates Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanManageClientTemplates Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanManageClientTemplates security right for this user (use TPropertyEnum.SecurityRights_CanManageClientTemplates).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanManageClientTemplates { get; }
Visual Basic
Public ReadOnly Property CanManageClientTemplates As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanManageClientTemplates security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace
ClientTemplateConfiguration..::..Rights..::..Admin


CanModifyOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanModifyOptimizerActivityCodes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer activity codes (use TPropertyEnum.SecurityRights_CanModifyOptimizerActivityCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanModifyOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanModifyOptimizerActivityCodes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the modify optimizer activity codes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanModifyOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanModifyOptimizerDayClassifications Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanModifyOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanModifyOptimizerDayClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanModifyOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanModifyOptimizerDayClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanModifyOptimizerDayClassifications security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanModifyOptimizerStatusActivityTypeMapping Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanModifyOptimizerStatusActivityTypeMapping Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to modify optimizer activity type mapping (use TPropertyEnum.SecurityRights_CanModifyOptimizerStatusActivityTypeMapping).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanModifyOptimizerStatusActivityTypeMapping { get; }
Visual Basic
Public ReadOnly Property CanModifyOptimizerStatusActivityTypeMapping As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the modify optimizer activity type mapping right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanMuteInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanMuteInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanMuteInteractions security right for this user (use TPropertyEnum.SecurityRights_CanMuteInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanMuteInteractions { get; }
Visual Basic
Public ReadOnly Property CanMuteInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanMuteInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanOrbitQueue Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanOrbitQueue Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanOrbitQueue security right for this user (use TPropertyEnum.SecurityRights_CanOrbitQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanOrbitQueue { get; }
Visual Basic
Public ReadOnly Property CanOrbitQueue As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanOrbitQueue security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanOverrideFinishedScorecards Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanOverrideFinishedScorecards Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanOverrideFinishedScorecards security right for this user (use TPropertyEnum.SecurityRights_CanOverrideFinishedScorecards).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanOverrideFinishedScorecards { get; }
Visual Basic
Public ReadOnly Property CanOverrideFinishedScorecards As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanOverrideFinishedScorecards security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanParkInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanParkInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanParkInteractions security right for this user (use TPropertyEnum.SecurityRights_CanParkInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanParkInteractions { get; }
Visual Basic
Public ReadOnly Property CanParkInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanParkInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanPauseInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanPauseInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanPauseInteractions security right for this user (use TPropertyEnum.SecurityRights_CanPauseInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanPauseInteractions { get; }
Visual Basic
Public ReadOnly Property CanPauseInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanPauseInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanPickupInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanPickupInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanPickupInteractions security right for this user (use TPropertyEnum.SecurityRights_CanPickupInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanPickupInteractions { get; }
Visual Basic
Public ReadOnly Property CanPickupInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanPickupInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanPublishProcess Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanPublishProcess Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanPublishProcess security right for this user (use TPropertyEnum.SecurityRights_CanPublishProcess).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanPublishProcess { get; }
Visual Basic
Public ReadOnly Property CanPublishProcess As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanPublishProcess security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanPutInteractionsOnHold Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanPutInteractionsOnHold Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanPutInteractionsOnHold security right for this user (use TPropertyEnum.SecurityRights_CanPutInteractionsOnHold).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanPutInteractionsOnHold { get; }
Visual Basic
Public ReadOnly Property CanPutInteractionsOnHold As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanPutInteractionsOnHold security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanRecordInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanRecordInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanRecordInteractions security right for this user (use TPropertyEnum.SecurityRights_CanRecordInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanRecordInteractions { get; }
Visual Basic
Public ReadOnly Property CanRecordInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanRecordInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanRequestAssistanceFromSupervisor Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanRequestAssistanceFromSupervisor Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanRequestAssistanceFromSupervisor security right for this user (use TPropertyEnum.SecurityRights_CanRequestAssistanceFromSupervisor).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanRequestAssistanceFromSupervisor { get; }
Visual Basic
Public ReadOnly Property CanRequestAssistanceFromSupervisor As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanRequestAssistanceFromSupervisor security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanSecureRecordingPauseInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanSecureRecordingPauseInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanSecureRecordingPauseInteractions security right for this user (use TPropertyEnum.SecurityRights_CanSecureRecordingPauseInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanSecureRecordingPauseInteractions { get; }
Visual Basic
Public ReadOnly Property CanSecureRecordingPauseInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanSecureRecordingPauseInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanShareAlertSets Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanShareAlertSets Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanShareAlertSets security right for this user (use TPropertyEnum.SecurityRights_CanShareAlertSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanShareAlertSets { get; }
Visual Basic
Public ReadOnly Property CanShareAlertSets As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanShareAlertSets security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanSubmitTimeOff Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanSubmitTimeOff Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanSubmitTimeOff security right for this user (use TPropertyEnum.SecurityRights_CanSubmitTimeOff).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanSubmitTimeOff { get; }
Visual Basic
Public ReadOnly Property CanSubmitTimeOff As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanSubmitTimeOff security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanTransferInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanTransferInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanTransferInteractions security right for this user (use TPropertyEnum.SecurityRights_CanTransferInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanTransferInteractions { get; }
Visual Basic
Public ReadOnly Property CanTransferInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanTransferInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanTransferInteractionsToVoicemail Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanTransferInteractionsToVoicemail Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanTransferInteractionsToVoicemail security right for this user (use TPropertyEnum.SecurityRights_CanTransferInteractionsToVoicemail).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanTransferInteractionsToVoicemail { get; }
Visual Basic
Public ReadOnly Property CanTransferInteractionsToVoicemail As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanTransferInteractionsToVoicemail security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanUserInteractionRecorderSelector Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanUserInteractionRecorderSelector Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanUserInteractionRecorderSelector security right for this user (use TPropertyEnum.SecurityRights_CanUserInteractionRecorderSelector).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanUserInteractionRecorderSelector { get; }
Visual Basic
Public ReadOnly Property CanUserInteractionRecorderSelector As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanUserInteractionRecorderSelector security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanViewOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanViewOptimizerActivityCodes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer activity codes (use TPropertyEnum.SecurityRights_CanViewOptimizerActivityCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanViewOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanViewOptimizerActivityCodes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the view optimizer activity codes right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanViewOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanViewOptimizerDayClassifications Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CanViewOptimizerDayClassifications security right for this user (use TPropertyEnum.SecurityRights_CanViewOptimizerDayClassifications).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanViewOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanViewOptimizerDayClassifications As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CanViewOptimizerDayClassifications security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CanViewOptimizerStatusActivityTypeMapping Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CanViewOptimizerStatusActivityTypeMapping Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the right to view optimizer activity type mapping (use TPropertyEnum.SecurityRights_CanViewOptimizerStatusActivityTypeMapping).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CanViewOptimizerStatusActivityTypeMapping { get; }
Visual Basic
Public ReadOnly Property CanViewOptimizerStatusActivityTypeMapping As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the view optimizer activity type mapping right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CloudWorkforceEngagementAdministrator Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CloudWorkforceEngagementAdministrator Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CloudWorkforceEngagementAdministrator security right for this user (use TPropertyEnum.SecurityRights_CloudWorkforceEngagementAdministrator).

Note: This property is supported for IC Server version 2020 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CloudWorkforceEngagementAdministrator { get; }
Visual Basic
Public ReadOnly Property CloudWorkforceEngagementAdministrator As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CloudWorkforceEngagementAdministrator security right.

Version Information

Supported for IC Server version 2020 R2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ContactListRecordOwnershipControl Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ContactListRecordOwnershipControl Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ContactListRecordOwnershipControl security right for this user (use TPropertyEnum.SecurityRights_ContactListRecordOwnershipControl).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ContactListRecordOwnershipControl { get; }
Visual Basic
Public ReadOnly Property ContactListRecordOwnershipControl As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ContactListRecordOwnershipControl security right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CreateModifyCampaignGroup Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CreateModifyCampaignGroup Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CreateModifyCampaignGroup security right for this user (use TPropertyEnum.SecurityRights_CreateModifyCampaignGroup).

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CreateModifyCampaignGroup { get; }
Visual Basic
Public ReadOnly Property CreateModifyCampaignGroup As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CreateModifyCampaignGroup security right.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


CustomizeClient Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CustomizeClient Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the CustomizeClient security right for this user (use TPropertyEnum.SecurityRights_CustomizeClient).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> CustomizeClient { get; }
Visual Basic
Public ReadOnly Property CustomizeClient As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the CustomizeClient security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DataExtractorJobAdmin Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DataExtractorJobAdmin Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DataExtractorJobAdmin security right for this user (use TPropertyEnum.SecurityRights_DataExtractorJobAdmin).

Note: This property is supported for IC Server version 2017 R4 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DataExtractorJobAdmin { get; }
Visual Basic
Public ReadOnly Property DataExtractorJobAdmin As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the DataExtractorJobAdmin security right.

Version Information

Supported for IC Server version 2017 R4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DebugHandlers Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DebugHandlers Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DebugHandlers security right for this user (use TPropertyEnum.SecurityRights_DebugHandlers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DebugHandlers { get; }
Visual Basic
Public ReadOnly Property DebugHandlers As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the DebugHandlers security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteIndividuals Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteIndividuals Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DeleteIndividuals security right for this user (use TPropertyEnum.SecurityRights_DeleteIndividuals).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DeleteIndividuals { get; }
Visual Basic
Public ReadOnly Property DeleteIndividuals As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the DeleteIndividuals security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DeleteOrganizations Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DeleteOrganizations Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DeleteOrganizations security right for this user (use TPropertyEnum.SecurityRights_DeleteOrganizations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DeleteOrganizations { get; }
Visual Basic
Public ReadOnly Property DeleteOrganizations As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the DeleteOrganizations security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


DirectoryAdmin Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DirectoryAdmin Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DirectoryAdmin security right for this user (use TPropertyEnum.SecurityRights_DirectoryAdmin).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> DirectoryAdmin { get; }
Visual Basic
Public ReadOnly Property DirectoryAdmin As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the DirectoryAdmin security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ExecuteLongRunningQueries Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ExecuteLongRunningQueries Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ExecuteLongRunningQueries security right for this user (use TPropertyEnum.SecurityRights_ExecuteLongRunningQueries).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ExecuteLongRunningQueries is no longer used.")]
public InheritableConfigurationProperty<TPropertyEnum, bool> ExecuteLongRunningQueries { get; }
Visual Basic
<ObsoleteAttribute("ExecuteLongRunningQueries is no longer used.")> _
Public ReadOnly Property ExecuteLongRunningQueries As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ExecuteLongRunningQueries security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FollowMe Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..FollowMe Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the FollowMe security right for this user (use TPropertyEnum.SecurityRights_FollowMe).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> FollowMe { get; }
Visual Basic
Public ReadOnly Property FollowMe As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the FollowMe security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ForceUserLogout Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ForceUserLogout Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ForceUserLogout security right for this user (use TPropertyEnum.SecurityRights_ForceUserLogout).

Note: This property is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ForceUserLogout { get; }
Visual Basic
Public ReadOnly Property ForceUserLogout As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ForceUserLogout security right.

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


HavePrivateContacts Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..HavePrivateContacts Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the HavePrivateContacts security right for this user (use TPropertyEnum.SecurityRights_HavePrivateContacts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> HavePrivateContacts { get; }
Visual Basic
Public ReadOnly Property HavePrivateContacts As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the HavePrivateContacts security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


IPPhoneProvisioningAdmin Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..IPPhoneProvisioningAdmin Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the IPPhoneProvisioningAdmin security right for this user (use TPropertyEnum.SecurityRights_IPPhoneProvisioningAdmin).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> IPPhoneProvisioningAdmin { get; }
Visual Basic
Public ReadOnly Property IPPhoneProvisioningAdmin As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the IPPhoneProvisioningAdmin security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


LockPolicySets Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LockPolicySets Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the LockPolicySets security right for this user (use TPropertyEnum.SecurityRights_LockPolicySets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> LockPolicySets { get; }
Visual Basic
Public ReadOnly Property LockPolicySets As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the LockPolicySets security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


LoginCampaign Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LoginCampaign Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the LoginCampaign security right for this user (use TPropertyEnum.SecurityRights_LoginCampaign).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> LoginCampaign { get; }
Visual Basic
Public ReadOnly Property LoginCampaign As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the LoginCampaign security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ManageHandlers Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ManageHandlers Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ManageHandlers security right for this user (use TPropertyEnum.SecurityRights_ManageHandlers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ManageHandlers { get; }
Visual Basic
Public ReadOnly Property ManageHandlers As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ManageHandlers security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ManualTransitionSequence Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ManualTransitionSequence Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ManualTransitionSequence security right for this user (use TPropertyEnum.SecurityRights_ManualTransitionSequence).

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ManualTransitionSequence { get; }
Visual Basic
Public ReadOnly Property ManualTransitionSequence As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ManualTransitionSequence security right.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


MobileOfficeUser Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..MobileOfficeUser Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the MobileOfficeUser security right for this user (use TPropertyEnum.SecurityRights_MobileOfficeUser).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> MobileOfficeUser { get; }
Visual Basic
Public ReadOnly Property MobileOfficeUser As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the MobileOfficeUser security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyBaseScriptAgentComplianceOverride Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyBaseScriptAgentComplianceOverride Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyBaseScriptAgentComplianceOverride security right for this user (use TPropertyEnum.SecurityRights_ModifyBaseScriptAgentComplianceOverride).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyBaseScriptAgentComplianceOverride { get; }
Visual Basic
Public ReadOnly Property ModifyBaseScriptAgentComplianceOverride As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyBaseScriptAgentComplianceOverride security right.

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyCampaignGroupSequence Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyCampaignGroupSequence Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyCampaignGroupSequence security right for this user (use TPropertyEnum.SecurityRights_ModifyCampaignGroupSequence).

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyCampaignGroupSequence { get; }
Visual Basic
Public ReadOnly Property ModifyCampaignGroupSequence As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyCampaignGroupSequence security right.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyConfigurationChangeAuditing Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyConfigurationChangeAuditing Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyConfigurationChangeAuditing security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationChangeAuditing).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyConfigurationChangeAuditing { get; }
Visual Basic
Public ReadOnly Property ModifyConfigurationChangeAuditing As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyConfigurationChangeAuditing security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyConfigurationGeneral Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyConfigurationGeneral Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyConfigurationGeneral security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationGeneral).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyConfigurationGeneral { get; }
Visual Basic
Public ReadOnly Property ModifyConfigurationGeneral As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyConfigurationGeneral security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyConfigurationHTTPServer Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyConfigurationHTTPServer Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyConfigurationHTTPServer security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationHTTPServer).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyConfigurationHTTPServer { get; }
Visual Basic
Public ReadOnly Property ModifyConfigurationHTTPServer As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyConfigurationHTTPServer security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyConfigurationOutboundServers Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyConfigurationOutboundServers Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyConfigurationOutboundServers security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationOutboundServers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyConfigurationOutboundServers { get; }
Visual Basic
Public ReadOnly Property ModifyConfigurationOutboundServers As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyConfigurationOutboundServers security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyConfigurationPhoneNumberTypes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyConfigurationPhoneNumberTypes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyConfigurationPhoneNumberTypes security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationPhoneNumberTypes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyConfigurationPhoneNumberTypes { get; }
Visual Basic
Public ReadOnly Property ModifyConfigurationPhoneNumberTypes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyConfigurationPhoneNumberTypes security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyConfigurationPreviewCallBehavior Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyConfigurationPreviewCallBehavior Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyConfigurationPreviewCallBehavior security right for this user (use TPropertyEnum.SecurityRights_ModifyConfigurationPreviewCallBehavior).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyConfigurationPreviewCallBehavior { get; }
Visual Basic
Public ReadOnly Property ModifyConfigurationPreviewCallBehavior As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyConfigurationPreviewCallBehavior security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyIndividuals Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyIndividuals Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyIndividuals security right for this user (use TPropertyEnum.SecurityRights_ModifyIndividuals).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyIndividuals { get; }
Visual Basic
Public ReadOnly Property ModifyIndividuals As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyIndividuals security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyInteractions security right for this user (use TPropertyEnum.SecurityRights_ModifyInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyInteractions { get; }
Visual Basic
Public ReadOnly Property ModifyInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ModifyOrganizations Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyOrganizations Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ModifyOrganizations security right for this user (use TPropertyEnum.SecurityRights_ModifyOrganizations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ModifyOrganizations { get; }
Visual Basic
Public ReadOnly Property ModifyOrganizations As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ModifyOrganizations security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


OutlookTuiUser Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OutlookTuiUser Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the OutlookTuiUser security right for this user (use TPropertyEnum.SecurityRights_OutlookTuiUser).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> OutlookTuiUser { get; }
Visual Basic
Public ReadOnly Property OutlookTuiUser As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the OutlookTuiUser security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PrivateCalls Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PrivateCalls Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PrivateCalls security right for this user (use TPropertyEnum.SecurityRights_PrivateCalls).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> PrivateCalls { get; }
Visual Basic
Public ReadOnly Property PrivateCalls As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the PrivateCalls security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


PublishHandlers Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PublishHandlers Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the PublishHandlers security right for this user (use TPropertyEnum.SecurityRights_PublishHandlers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> PublishHandlers { get; }
Visual Basic
Public ReadOnly Property PublishHandlers As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the PublishHandlers security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RemoteControl Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RemoteControl Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RemoteControl security right for this user (use TPropertyEnum.SecurityRights_RemoteControl).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> RemoteControl { get; }
Visual Basic
Public ReadOnly Property RemoteControl As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the RemoteControl security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ReporterAdministrator Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ReporterAdministrator Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the Interaction Reporter Administrator security right for this user (use TPropertyEnum.SecurityRights_ReporterAdministrator).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ReporterAdministrator { get; }
Visual Basic
Public ReadOnly Property ReporterAdministrator As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the Interaction Reporter Administrator security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RequireForcedAuthorizationCode Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RequireForcedAuthorizationCode Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RequireForcedAuthorizationCode security right for this user (use TPropertyEnum.SecurityRights_RequireForcedAuthorizationCode).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> RequireForcedAuthorizationCode { get; }
Visual Basic
Public ReadOnly Property RequireForcedAuthorizationCode As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the RequireForcedAuthorizationCode security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


RunContactListPredefinedActions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RunContactListPredefinedActions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the RunContactListPredefinedActions security right for this user (use TPropertyEnum.SecurityRights_RunContactListPredefinedActions).

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> RunContactListPredefinedActions { get; }
Visual Basic
Public ReadOnly Property RunContactListPredefinedActions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the RunContactListPredefinedActions security right.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowAssistanceButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowAssistanceButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowAssistanceButton security right for this user (use TPropertyEnum.SecurityRights_ShowAssistanceButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowAssistanceButton { get; }
Visual Basic
Public ReadOnly Property ShowAssistanceButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowAssistanceButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowCoachButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowCoachButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowCoachButton security right for this user (use TPropertyEnum.SecurityRights_ShowCoachButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowCoachButton { get; }
Visual Basic
Public ReadOnly Property ShowCoachButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowCoachButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowDisconnectButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowDisconnectButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowDisconnectButton security right for this user (use TPropertyEnum.SecurityRights_ShowDisconnectButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowDisconnectButton { get; }
Visual Basic
Public ReadOnly Property ShowDisconnectButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowDisconnectButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowHoldButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowHoldButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowHoldButton security right for this user (use TPropertyEnum.SecurityRights_ShowHoldButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowHoldButton { get; }
Visual Basic
Public ReadOnly Property ShowHoldButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowHoldButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowJoinButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowJoinButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowJoinButton security right for this user (use TPropertyEnum.SecurityRights_ShowJoinButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowJoinButton { get; }
Visual Basic
Public ReadOnly Property ShowJoinButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowJoinButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowListenButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowListenButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowListenButton security right for this user (use TPropertyEnum.SecurityRights_ShowListenButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowListenButton { get; }
Visual Basic
Public ReadOnly Property ShowListenButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowListenButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowMuteButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowMuteButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowMuteButton security right for this user (use TPropertyEnum.SecurityRights_ShowMuteButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowMuteButton { get; }
Visual Basic
Public ReadOnly Property ShowMuteButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowMuteButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowParkButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowParkButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowParkButton security right for this user (use TPropertyEnum.SecurityRights_ShowParkButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowParkButton { get; }
Visual Basic
Public ReadOnly Property ShowParkButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowParkButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowPauseButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowPauseButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowPauseButton security right for this user (use TPropertyEnum.SecurityRights_ShowPauseButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowPauseButton { get; }
Visual Basic
Public ReadOnly Property ShowPauseButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowPauseButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowPickupButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowPickupButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowPickupButton security right for this user (use TPropertyEnum.SecurityRights_ShowPickupButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowPickupButton { get; }
Visual Basic
Public ReadOnly Property ShowPickupButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowPickupButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowPrivateButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowPrivateButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowPrivateButton security right for this user (use TPropertyEnum.SecurityRights_ShowPrivateButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowPrivateButton { get; }
Visual Basic
Public ReadOnly Property ShowPrivateButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowPrivateButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowRecordButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowRecordButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowRecordButton security right for this user (use TPropertyEnum.SecurityRights_ShowRecordButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowRecordButton { get; }
Visual Basic
Public ReadOnly Property ShowRecordButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowRecordButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowRecordingSnippetButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowRecordingSnippetButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowRecordingSnippetButton security right for this user (use TPropertyEnum.SecurityRights_ShowRecordingSnippetButton).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowRecordingSnippetButton { get; }
Visual Basic
Public ReadOnly Property ShowRecordingSnippetButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowRecordingSnippetButton security right.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowSecureInputButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowSecureInputButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowSecureInputButton security right for this user (use TPropertyEnum.SecurityRights_ShowSecureInputButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowSecureInputButton { get; }
Visual Basic
Public ReadOnly Property ShowSecureInputButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowSecureInputButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowSecureRecordingPauseButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowSecureRecordingPauseButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowSecureRecordingPauseButton security right for this user (use TPropertyEnum.SecurityRights_ShowSecureRecordingPauseButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowSecureRecordingPauseButton { get; }
Visual Basic
Public ReadOnly Property ShowSecureRecordingPauseButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowSecureRecordingPauseButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowTransferButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowTransferButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowTransferButton security right for this user (use TPropertyEnum.SecurityRights_ShowTransferButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowTransferButton { get; }
Visual Basic
Public ReadOnly Property ShowTransferButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowTransferButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowVoicemailButton Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowVoicemailButton Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowVoicemailButton security right for this user (use TPropertyEnum.SecurityRights_ShowVoicemailButton).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowVoicemailButton { get; }
Visual Basic
Public ReadOnly Property ShowVoicemailButton As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowVoicemailButton security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ShowWorkgroupsProfilesTab Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ShowWorkgroupsProfilesTab Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ShowWorkgroupsProfilesTab security right for this user (use TPropertyEnum.SecurityRights_ShowWorkgroupsProfilesTab).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ShowWorkgroupsProfilesTab { get; }
Visual Basic
Public ReadOnly Property ShowWorkgroupsProfilesTab As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ShowWorkgroupsProfilesTab security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


TraceConfiguration Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TraceConfiguration Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the TraceConfiguration security right for this user (use TPropertyEnum.SecurityRights_TraceConfiguration).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> TraceConfiguration { get; }
Visual Basic
Public ReadOnly Property TraceConfiguration As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the TraceConfiguration security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


TrackerAdministrator Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TrackerAdministrator Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the TrackerAdministrator security right for this user (use TPropertyEnum.SecurityRights_TrackerAdministrator).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> TrackerAdministrator { get; }
Visual Basic
Public ReadOnly Property TrackerAdministrator As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the TrackerAdministrator security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


UseTiffForFaxes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..UseTiffForFaxes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the UseTiffForFaxes security right for this user (use TPropertyEnum.SecurityRights_UseTiffForFaxes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> UseTiffForFaxes { get; }
Visual Basic
Public ReadOnly Property UseTiffForFaxes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the UseTiffForFaxes security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewConfigurationChangeAuditing Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewConfigurationChangeAuditing Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewConfigurationChangeAuditing security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationChangeAuditing).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewConfigurationChangeAuditing { get; }
Visual Basic
Public ReadOnly Property ViewConfigurationChangeAuditing As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewConfigurationChangeAuditing security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewConfigurationGeneral Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewConfigurationGeneral Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewConfigurationGeneral security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationGeneral).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewConfigurationGeneral { get; }
Visual Basic
Public ReadOnly Property ViewConfigurationGeneral As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewConfigurationGeneral security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewConfigurationHTTPServer Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewConfigurationHTTPServer Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewConfigurationHTTPServer security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationHTTPServer).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewConfigurationHTTPServer { get; }
Visual Basic
Public ReadOnly Property ViewConfigurationHTTPServer As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewConfigurationHTTPServer security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewConfigurationOutboundServers Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewConfigurationOutboundServers Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewConfigurationOutboundServers security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationOutboundServers).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewConfigurationOutboundServers { get; }
Visual Basic
Public ReadOnly Property ViewConfigurationOutboundServers As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewConfigurationOutboundServers security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewConfigurationPhoneNumberTypes Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewConfigurationPhoneNumberTypes Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewConfigurationPhoneNumberTypes security right for this user (use TPropertyEnum.SecurityRights_ViewConfigurationPhoneNumberTypes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewConfigurationPhoneNumberTypes { get; }
Visual Basic
Public ReadOnly Property ViewConfigurationPhoneNumberTypes As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewConfigurationPhoneNumberTypes security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewConfigurationPreviewCallBehavior Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewConfigurationPreviewCallBehavior Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the DialerConfigurationViewPreviewCallBehavior security right for this user (use TPropertyEnum.SecurityRights_DialerConfigurationViewPreviewCallBehavior).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewConfigurationPreviewCallBehavior { get; }
Visual Basic
Public ReadOnly Property ViewConfigurationPreviewCallBehavior As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the DialerConfigurationViewPreviewCallBehavior security right.

Remarks

This security right is only available when Dialer has been installed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewInteractionDetails Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewInteractionDetails Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewInteractionDetails security right for this user (use TPropertyEnum.SecurityRights_ViewInteractionDetails).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewInteractionDetails { get; }
Visual Basic
Public ReadOnly Property ViewInteractionDetails As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewInteractionDetails security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyCampaignAgentlessCallingType Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyCampaignAgentlessCallingType Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyCampaignAgentlessCallingType security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignAgentlessCallingType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyCampaignAgentlessCallingType { get; }
Visual Basic
Public ReadOnly Property ViewModifyCampaignAgentlessCallingType As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyCampaignAgentlessCallingType security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyCampaignAutomaticTimeZoneMapping Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyCampaignAutomaticTimeZoneMapping Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyCampaignAutomaticTimeZoneMapping security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignAutomaticTimeZoneMapping).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyCampaignAutomaticTimeZoneMapping { get; }
Visual Basic
Public ReadOnly Property ViewModifyCampaignAutomaticTimeZoneMapping As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyCampaignAgentlessCallingType security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyCampaignLineSettings Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyCampaignLineSettings Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyCampaignLineSettings security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignLineSettings).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyCampaignLineSettings { get; }
Visual Basic
Public ReadOnly Property ViewModifyCampaignLineSettings As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyCampaignLineSettings security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyCampaignMaxLines Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyCampaignMaxLines Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyCampaignMaxLines security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignMaxLines).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyCampaignMaxLines { get; }
Visual Basic
Public ReadOnly Property ViewModifyCampaignMaxLines As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyCampaignMaxLines security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyCampaignStatus Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyCampaignStatus Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyCampaignStatus security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCampaignStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyCampaignStatus { get; }
Visual Basic
Public ReadOnly Property ViewModifyCampaignStatus As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyCampaignStatus security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyContactListDataQuery Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyContactListDataQuery Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyContactListDataQuery security right for this user (use TPropertyEnum.SecurityRights_ViewModifyContactListDataQuery).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyContactListDataQuery { get; }
Visual Basic
Public ReadOnly Property ViewModifyContactListDataQuery As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyContactListDataQuery security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyCustomHandlerActions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyCustomHandlerActions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyCustomHandlerActions security right for this user (use TPropertyEnum.SecurityRights_ViewModifyCustomHandlerActions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyCustomHandlerActions { get; }
Visual Basic
Public ReadOnly Property ViewModifyCustomHandlerActions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyCustomHandlerActions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyDatabaseConnections Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyDatabaseConnections Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyDatabaseConnections security right for this user (use TPropertyEnum.SecurityRights_ViewModifyDatabaseConnections).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyDatabaseConnections { get; }
Visual Basic
Public ReadOnly Property ViewModifyDatabaseConnections As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyDatabaseConnections security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyDncSources Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyDncSources Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyDncSources security right for this user (use TPropertyEnum.SecurityRights_ViewModifyDncSources).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyDncSources { get; }
Visual Basic
Public ReadOnly Property ViewModifyDncSources As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyDncSources security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyEventLog Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyEventLog Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyEventLog security right for this user (use TPropertyEnum.SecurityRights_ViewModifyEventLog).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyEventLog { get; }
Visual Basic
Public ReadOnly Property ViewModifyEventLog As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyEventLog security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewModifyTimeZoneMapData Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyTimeZoneMapData Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewModifyTimeZoneMapData security right for this user (use TPropertyEnum.SecurityRights_ViewModifyTimeZoneMapData).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewModifyTimeZoneMapData { get; }
Visual Basic
Public ReadOnly Property ViewModifyTimeZoneMapData As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewModifyTimeZoneMapData security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ViewOtherPeoplesPrivateInteractions Property

[image]

IceLib Technical Reference
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewOtherPeoplesPrivateInteractions Property
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class See Also Send Feedback
Provides access to the property representing the ViewOtherPeoplesPrivateInteractions security right for this user (use TPropertyEnum.SecurityRights_ViewOtherPeoplesPrivateInteractions).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<TPropertyEnum, bool> ViewOtherPeoplesPrivateInteractions { get; }
Visual Basic
Public ReadOnly Property ViewOtherPeoplesPrivateInteractions As InheritableConfigurationProperty(Of TPropertyEnum, Boolean)
    Get

Field Value

The property representing the ViewOtherPeoplesPrivateInteractions security right.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Class
UserSecurityRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Class

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
Members See Also Send Feedback
Represents a value list filter for searching configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValueListFilterDefinition<TFilteredObject, TPropertyEnum> : FilterDefinition<TFilteredObject, TPropertyEnum>
where TFilteredObject : ConfigurationObject
where TPropertyEnum : struct, new()
Visual Basic
Public Class ValueListFilterDefinition(Of TFilteredObject As ConfigurationObject, TPropertyEnum As {Structure, New}) _
    Inherits FilterDefinition(Of TFilteredObject, TPropertyEnum)

Type Parameters

TFilteredObject
The type of the filtered object.
TPropertyEnum
The type of the property enumeration.

Remarks

When this filter is applied, each value in the property values is matched with an "Or" operation.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..FilterDefinition <(Of <(<'TFilteredObject, TPropertyEnum>)>)>
ININ.IceLib.Configuration..::..ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class Constructors Methods Properties See Also Send Feedback

The ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, IEnumerable<(Of <<'(Object>)>>)) | Initializes a new instance of the ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.
Public method | ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, IEnumerable<(Of <<'(Object>)>>), FilterMatchType) | Initializes a new instance of the ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilteredProperty | Gets the filtered property.
Public property | FilterMatchType | Gets the filter match type.
Public property | TargetPropertyValues | Gets the target property values.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Constructor

[image] [image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, IEnumerable<(Of <<'(Object>)>>)) | Initializes a new instance of the ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.
Public method | ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>(TPropertyEnum, IEnumerable<(Of <<'(Object>)>>), FilterMatchType) | Initializes a new instance of the ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Constructor (TPropertyEnum, IEnumerable(Object))

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor (TPropertyEnum, IEnumerable<(Of <(<'Object>)>)>)
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class, using a Prefix filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ValueListFilterDefinition(
    TPropertyEnum filteredProperty,
    IEnumerable<Object> targetValues
)
Visual Basic
Public Sub New ( _
    filteredProperty As TPropertyEnum, _
    targetValues As IEnumerable(Of Object) _
)

Parameters

filteredProperty
Type: TPropertyEnum
The filtered property.
targetValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'Object>)>)>
The target values.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Overload
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Constructor (TPropertyEnum, IEnumerable(Object), FilterMatchType)

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Constructor (TPropertyEnum, IEnumerable<(Of <(<'Object>)>)>, FilterMatchType)
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Initializes a new instance of the ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ValueListFilterDefinition(
    TPropertyEnum filteredProperty,
    IEnumerable<Object> targetValues,
    FilterMatchType filterMatchType
)
Visual Basic
Public Sub New ( _
    filteredProperty As TPropertyEnum, _
    targetValues As IEnumerable(Of Object), _
    filterMatchType As FilterMatchType _
)

Parameters

filteredProperty
Type: TPropertyEnum
The filtered property.
targetValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'Object>)>)>
The target values.
filterMatchType
Type: ININ.IceLib.Configuration..::..FilterMatchType
The filter match type.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified filterMatchType is not from the FilterMatchType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Overload
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Methods
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


ToString Method

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..ToString Method
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


ValueListFilterDefinition(TFilteredObject, TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Properties
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback

The ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilteredProperty | Gets the filtered property.
Public property | FilterMatchType | Gets the filter match type.
Public property | TargetPropertyValues | Gets the target property values.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ININ.IceLib.Configuration Namespace


FilteredProperty Property

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..FilteredProperty Property
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filtered property.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TPropertyEnum FilteredProperty { get; }
Visual Basic
Public ReadOnly Property FilteredProperty As TPropertyEnum
    Get

Field Value

The filtered property.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


FilterMatchType Property

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..FilterMatchType Property
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the filter match type.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilterMatchType FilterMatchType { get; }
Visual Basic
Public ReadOnly Property FilterMatchType As FilterMatchType
    Get

Field Value

The filter match type.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


TargetPropertyValues Property

[image]

IceLib Technical Reference
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)>..::..TargetPropertyValues Property
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class See Also Send Feedback
Gets the target property values.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Object> TargetPropertyValues { get; }
Visual Basic
Public ReadOnly Property TargetPropertyValues As ReadOnlyCollection(Of Object)
    Get

Field Value

The target property values.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Class
ValueListFilterDefinition<(Of <(<'TFilteredObject, TPropertyEnum>)>)> Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration Class

[image]

IceLib Technical Reference
VoiceModuleConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Voice Module. A voice module corresponds to the digital signal processor (DSP) on the Aculab board.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoiceModuleConfiguration : ListConfigurationObject
Visual Basic
Public Class VoiceModuleConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..VoiceModuleConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfiguration Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration Members

[image] [image]

IceLib Technical Reference
VoiceModuleConfiguration Members
VoiceModuleConfiguration Class Methods Properties See Also Send Feedback

The VoiceModuleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

VoiceModuleConfiguration Class
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration Methods

[image] [image]

IceLib Technical Reference
VoiceModuleConfiguration Methods
VoiceModuleConfiguration Class See Also Send Feedback

The VoiceModuleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

VoiceModuleConfiguration Class
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration Properties

[image] [image]

IceLib Technical Reference
VoiceModuleConfiguration Properties
VoiceModuleConfiguration Class See Also Send Feedback

The VoiceModuleConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

VoiceModuleConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
VoiceModuleConfiguration..::..StandardProperties Property
VoiceModuleConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<VoiceModuleConfiguration, VoiceModuleConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of VoiceModuleConfiguration, VoiceModuleConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfiguration Class
VoiceModuleConfiguration Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration.Property Enumeration

[image]

IceLib Technical Reference
VoiceModuleConfiguration..::..Property Enumeration
VoiceModuleConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration.Rights Class

[image]

IceLib Technical Reference
VoiceModuleConfiguration..::..Rights Class
VoiceModuleConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..VoiceModuleConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
VoiceModuleConfiguration..::..Rights Members
VoiceModuleConfiguration..::..Rights Class Properties See Also Send Feedback

The VoiceModuleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

VoiceModuleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


VoiceModuleConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
VoiceModuleConfiguration..::..Rights Properties
VoiceModuleConfiguration..::..Rights Class See Also Send Feedback

The VoiceModuleConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

VoiceModuleConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
VoiceModuleConfiguration..::..Rights..::..Admin Property
VoiceModuleConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<VoiceModuleConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of VoiceModuleConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfiguration..::..Rights Class
VoiceModuleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..VoiceModules


View Property

[image]

IceLib Technical Reference
VoiceModuleConfiguration..::..Rights..::..View Property
VoiceModuleConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<VoiceModuleConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of VoiceModuleConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfiguration..::..Rights Class
VoiceModuleConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfigurationList Class

[image]

IceLib Technical Reference
VoiceModuleConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing VoiceModule configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoiceModuleConfigurationList : DynamicConfigurationList<VoiceModuleConfiguration, VoiceModuleConfiguration..::..Property>
Visual Basic
Public Class VoiceModuleConfigurationList _
    Inherits DynamicConfigurationList(Of VoiceModuleConfiguration, VoiceModuleConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' VoiceModuleConfiguration, VoiceModuleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' VoiceModuleConfiguration, VoiceModuleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..VoiceModuleConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfigurationList Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfigurationList Members

[image] [image]

IceLib Technical Reference
VoiceModuleConfigurationList Members
VoiceModuleConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The VoiceModuleConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | VoiceModuleConfigurationList | Initializes a new instance of the VoiceModuleConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

VoiceModuleConfigurationList Class
ININ.IceLib.Configuration Namespace


VoiceModuleConfigurationList Constructor

[image]

IceLib Technical Reference
VoiceModuleConfigurationList Constructor
VoiceModuleConfigurationList Class See Also Send Feedback
Initializes a new instance of the VoiceModuleConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoiceModuleConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoiceModuleConfigurationList Class
VoiceModuleConfigurationList Members
ININ.IceLib.Configuration Namespace


VoiceModuleConfigurationList Methods

[image] [image]

IceLib Technical Reference
VoiceModuleConfigurationList Methods
VoiceModuleConfigurationList Class See Also Send Feedback

The VoiceModuleConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoiceModuleConfigurationList Class
ININ.IceLib.Configuration Namespace


VoiceModuleConfigurationList Properties

[image] [image]

IceLib Technical Reference
VoiceModuleConfigurationList Properties
VoiceModuleConfigurationList Class See Also Send Feedback

The VoiceModuleConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

VoiceModuleConfigurationList Class
ININ.IceLib.Configuration Namespace


VoiceModuleConfigurationList Events

[image] [image]

IceLib Technical Reference
VoiceModuleConfigurationList Events
VoiceModuleConfigurationList Class See Also Send Feedback

The VoiceModuleConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

VoiceModuleConfigurationList Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration Class

[image]

IceLib Technical Reference
WebServicesParameterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Web Services Parameter. Web services parameters are used to configure IC Web Services.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WebServicesParameterConfiguration : ListConfigurationObject
Visual Basic
Public Class WebServicesParameterConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..WebServicesParameterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfiguration Members
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration Members

[image] [image]

IceLib Technical Reference
WebServicesParameterConfiguration Members
WebServicesParameterConfiguration Class Methods Properties See Also Send Feedback

The WebServicesParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

WebServicesParameterConfiguration Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration Methods

[image] [image]

IceLib Technical Reference
WebServicesParameterConfiguration Methods
WebServicesParameterConfiguration Class See Also Send Feedback

The WebServicesParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

WebServicesParameterConfiguration Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration Properties

[image] [image]

IceLib Technical Reference
WebServicesParameterConfiguration Properties
WebServicesParameterConfiguration Class See Also Send Feedback

The WebServicesParameterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

WebServicesParameterConfiguration Class
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..StandardProperties Property
WebServicesParameterConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<WebServicesParameterConfiguration, WebServicesParameterConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of WebServicesParameterConfiguration, WebServicesParameterConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfiguration Class
WebServicesParameterConfiguration Members
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..Property Enumeration
WebServicesParameterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration.Rights Class

[image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..Rights Class
WebServicesParameterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..WebServicesParameterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..Rights Members
WebServicesParameterConfiguration..::..Rights Class Properties See Also Send Feedback

The WebServicesParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WebServicesParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..Rights Properties
WebServicesParameterConfiguration..::..Rights Class See Also Send Feedback

The WebServicesParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WebServicesParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..Rights..::..Admin Property
WebServicesParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WebServicesParameterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of WebServicesParameterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfiguration..::..Rights Class
WebServicesParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WebServicesParameters


View Property

[image]

IceLib Technical Reference
WebServicesParameterConfiguration..::..Rights..::..View Property
WebServicesParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WebServicesParameterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of WebServicesParameterConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfiguration..::..Rights Class
WebServicesParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WebServicesParameterConfigurationList Class

[image]

IceLib Technical Reference
WebServicesParameterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing WebServicesParameter configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WebServicesParameterConfigurationList : DynamicConfigurationList<WebServicesParameterConfiguration, WebServicesParameterConfiguration..::..Property>
Visual Basic
Public Class WebServicesParameterConfigurationList _
    Inherits DynamicConfigurationList(Of WebServicesParameterConfiguration, WebServicesParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' WebServicesParameterConfiguration, WebServicesParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' WebServicesParameterConfiguration, WebServicesParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WebServicesParameterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


WebServicesParameterConfigurationList Members

[image] [image]

IceLib Technical Reference
WebServicesParameterConfigurationList Members
WebServicesParameterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The WebServicesParameterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | WebServicesParameterConfigurationList | Initializes a new instance of the WebServicesParameterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WebServicesParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfigurationList Constructor

[image]

IceLib Technical Reference
WebServicesParameterConfigurationList Constructor
WebServicesParameterConfigurationList Class See Also Send Feedback
Initializes a new instance of the WebServicesParameterConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WebServicesParameterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WebServicesParameterConfigurationList Class
WebServicesParameterConfigurationList Members
ININ.IceLib.Configuration Namespace


WebServicesParameterConfigurationList Methods

[image] [image]

IceLib Technical Reference
WebServicesParameterConfigurationList Methods
WebServicesParameterConfigurationList Class See Also Send Feedback

The WebServicesParameterConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebServicesParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfigurationList Properties

[image] [image]

IceLib Technical Reference
WebServicesParameterConfigurationList Properties
WebServicesParameterConfigurationList Class See Also Send Feedback

The WebServicesParameterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WebServicesParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


WebServicesParameterConfigurationList Events

[image] [image]

IceLib Technical Reference
WebServicesParameterConfigurationList Events
WebServicesParameterConfigurationList Class See Also Send Feedback

The WebServicesParameterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WebServicesParameterConfigurationList Class
ININ.IceLib.Configuration Namespace


WorkgroupConfiguration Class

[image]

IceLib Technical Reference
WorkgroupConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC workgroup. A workgroup is a defined logical group of Users related by function, department, project, or other organization.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupConfiguration : EditableListConfigurationObject<WorkgroupConfiguration..::..Property>
Visual Basic
Public Class WorkgroupConfiguration _
    Inherits EditableListConfigurationObject(Of WorkgroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' WorkgroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WorkgroupConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WorkgroupConfigurationList
ININ.IceLib.Configuration..::..WorkgroupMonitoredMailboxConfiguration


WorkgroupConfiguration Members

[image] [image]

IceLib Technical Reference
WorkgroupConfiguration Members
WorkgroupConfiguration Class Methods Properties See Also Send Feedback

The WorkgroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified workgroups.
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified workgroup.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()() or Delete()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this workgroup (use Property.AccessControlGroupAssignment).
Public property | AccessRights | Provides access to the various access control list properties.
Public property | AcdDisconnectedAction | Provides access to the property representing the ACD disconnected action for this workgroup (use Property.AcdDisconnectedAction).
Public property | AcdIncomingAction | Provides access to the property representing the ACD incoming action for this workgroup (use Property.AcdIncomingAction).
Public property | AcdOfferingAction | Provides access to the property representing the ACD offering action for this workgroup (use Property.AcdOfferingAction).
Public property | AcdSaveRepliesToSentItemsFolder | Provides access to the property representing ACD save replies to sent items folder for this workgroup (use Property.AcdSaveRepliesToSentItemsFolder).
Public property | AcdTransferAction | Provides access to the property representing the ACD transfer action for this workgroup (use Property.AcdTransferAction).
Public property | AcdUseAvailablityTime | Provides access to the property representing ACD use availability time for this workgroup (use Property.AcdUseAvailablityTime).
Public property | AdministrativeRights | Provides access to the various administrative access control list properties.
Public property | AgentScoreChange | Provides access to the property representing the agent score change for this workgroup (use Property.AgentScoreChange).
Public property | AnalyzerKeywordSets | Obsolete. Provides access to the property representing the analyzer keyword sets for this workgroup (use Property.AnalyzerKeywordSets).
Public property | CallbackMaxRetry | Provides access to the property representing how many times a callback may be retried. (use Property.CallbackMaxRetry)
Public property | CallbackServiceLevelDistribution | Provides access to the property representing the CallbackServiceLevelDistribution for this workgroup (use Property.CallbackServiceLevelDistribution).
Public property | CallbackServiceLevelTarget | Provides access to the property representing the CallbackServiceLevelTarget for this workgroup (use Property.CallbackServiceLevelTarget).
Public property | CallbackSnoozeDuration | Provides access to the property representing how many seconds a snooze on a callback should last. (use Property.CallbackSnoozeDuration)
Public property | CallServiceLevelDistribution | Provides access to the property representing the CallServiceLevelDistribution for this workgroup (use Property.CallServiceLevelDistribution).
Public property | CallServiceLevelTarget | Provides access to the property representing the CallServiceLevelTarget for this workgroup (use Property.CallServiceLevelTarget).
Public property | CallStatisticsPeriod | Provides access to the property representing the call statistics period for this workgroup (use Property.CallStatisticsPeriod).
Public property | CaptureInRecordings | Provides access to the property representing the CaptureInRecordings for this workgroup (use Property.CaptureInRecordings).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ChatServiceLevelDistribution | Provides access to the property representing the ChatServiceLevelDistribution for this workgroup (use Property.ChatServiceLevelDistribution).
Public property | ChatServiceLevelTarget | Provides access to the property representing the ChatServiceLevelTarget for this workgroup (use Property.ChatServiceLevelTarget).
Public property | ClientWaitTimeout | Provides access to the property representing the client wait timeout for this workgroup (use Property.ClientWaitTimeout).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | EmailServiceLevelDistribution | Provides access to the property representing the EmailServiceLevelDistribution for this workgroup (use Property.EmailServiceLevelDistribution).
Public property | EmailServiceLevelTarget | Provides access to the property representing the EmailServiceLevelTarget for this workgroup (use Property.EmailServiceLevelTarget).
Public property | EstimatedCallTimeInterval | Provides access to the property representing the estimated call time interval for this workgroup (use Property.EstimatedCallTimeInterval).
Public property | ExecuteTransferActionOnUserTransfer | Provides access to the property representing the execute transfer action on user transfer for this workgroup (use Property.ExecuteTransferActionOnUserTransfer).
Public property | Extension | Provides access to the property representing the extension for this workgroup (use Property.Extension).
Public property | FaxCapability | Provides access to the property representing the FAX capability for this workgroup (use Property.FaxCapability).
Public property | GenericServiceLevelDistribution | Provides access to the property representing the GenericServiceLevelDistribution for this workgroup (use Property.GenericServiceLevelDistribution).
Public property | GenericServiceLevelTarget | Provides access to the property representing the GenericServiceLevelTarget for this workgroup (use Property.GenericServiceLevelTarget).
Public property | GracePeriodBeforeNew | Provides access to the property representing the grace period before new for this workgroup (use Property.GracePeriodBeforeNew).
Public property | HasActivation | Obsolete. Provides access to the property representing the has activation for this workgroup (use Property.HasActivation).
Public property | HasMailbox | Obsolete. Provides access to the property representing the has mailbox for this workgroup (use Property.HasMailbox).
Public property | HasQueue | Provides access to the property representing the has queue for this workgroup (use Property.HasQueue).
Public property | InteractionDisconnectedAction | Provides access to the property representing the interaction disconnected action for this workgroup (use Property.InteractionDisconnectedAction).
Public property | InteractionMessageStoreMaxMessage | Obsolete. Provides access to the property representing the Interaction Message Store max messages for this workgroup (use Property.InteractionMessageStoreMaxMessage).
Public property | InteractionMessageStoreMaxStorage | Obsolete. Provides access to the property representing the Interaction Message Store max storage for this workgroup (use Property.InteractionMessageStoreMaxStorage).
Public property | InteractionOfferingAction | Provides access to the property representing the interaction offering action for this workgroup (use Property.InteractionOfferingAction).
Public property | InteractionOfferingTimeout | Provides access to the property representing the interaction offering timeout for this workgroup (use Property.InteractionOfferingTimeout).
Public property | IsAcdEmailRoutingActive | Provides access to the property representing the is acd email routing active for this workgroup (use Property.IsAcdEmailRoutingActive).
Public property | IsActive | Provides access to the property representing the is active for this workgroup (use Property.IsActive).
Public property | IsCallbackEnabled | Provides access to the property representing if callback is enabled for this workgroup (use Property.IsCallbackEnabled).
Public property | IsExemptHeldInteractionsEnabled | Provides access to the property representing the is exempt held interactions enabled for this workgroup (use Property.IsExemptHeldInteractionsEnabled).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsWrapUpActive | Provides access to the property representing the is wrap up active for this workgroup (use Property.IsWrapUpActive).
Public property | KeypadWaitTimeout | Provides access to the property representing the keypad wait timeout for this workgroup (use Property.KeypadWaitTimeout).
Public property | Mailbox | Provides access to the various mailbox properties.
Public property | MaximumChatReponseTime | Provides access to the property representing how many seconds a chat interaction can go without being updated before the User Interface should warn the user (use Property.MaximumChatReponseTime).
Public property | MaxNumberOfExempt | Provides access to the property representing the max number of exempt for this workgroup (use Property.MaxNumberOfExempt).
Public property | Members | Provides access to the property representing the members for this workgroup (use Property.Members).
Public property | MembersSpanSites | Provides access to the property representing the members span sites for this workgroup (use Property.MembersSpanSites).
Public property | MonitoredMailboxes | Provides access to the property representing the monitored mailboxes for this workgroup (use Property.MonitoredMailboxes).
Public property | NameSpellingsAsr | Provides access to the property representing the ASR name spellings for this workgroup (use Property.NameSpellingsAsr).
Public property | NameSpellingTts | Provides access to the property representing the TTS name spelling for this workgroup (use Property.NameSpellingTts).
Public property | NoAnswerStatus | Provides access to the property representing the no answer status for this workgroup (use Property.NoAnswerStatus).
Public property | OnCallStatus | Provides access to the property representing the on call status for this workgroup (use Property.OnCallStatus).
Public property | OnHoldMessage | Provides access to the property representing the on hold message for this workgroup (use Property.OnHoldMessage).
Public property | OnHoldMusic | Provides access to the property representing the on hold music for this workgroup (use Property.OnHoldMusic).
Public property | OperatorTarget | Provides access to the property representing the operator target for this workgroup (use Property.OperatorTarget).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | ParkedCallExtension | Provides access to the property representing the parked call extension for this workgroup (use Property.ParkedCallExtension).
Public property | ParkedCallTimeout | Provides access to the property representing the parked call timeout for this workgroup (use Property.ParkedCallTimeout).
Public property | ParkedChatExtension | Provides access to the property representing the parked chat extension for this workgroup (use Property.ParkedChatExtension).
Public property | ParkedChatTimeout | Provides access to the property representing the parked chat timeout for this workgroup (use Property.ParkedChatTimeout).
Public property | ParkedEmailExtension | Provides access to the property representing the parked email extension for this workgroup (use Property.ParkedEmailExtension).
Public property | ParkedEmailTimeout | Provides access to the property representing the parked email timeout for this workgroup (use Property.ParkedEmailTimeout).
Public property | ParkedGenericObjectExtension | Provides access to the property representing the parked generic object extension for this workgroup (use Property.ParkedGenericObjectExtension).
Public property | ParkedGenericObjectTimeout | Provides access to the property representing the parked generic object timeout for this workgroup (use Property.ParkedGenericObjectTimeout).
Public property | PlayToExternalPartiesOnly | Provides access to the property representing the ExternalPartiesOnly for this workgroup (use Property.PlayToExternalPartiesOnly).
Public property | PreferredLanguage | Provides access to the property representing the preferred language for this workgroup (use Property.PreferredLanguage).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | QueueType | Provides access to the property representing the queue type for this workgroup (use Property.QueueType).
Public property | RecordAll | Provides access to the property representing the record all for this workgroup (use Property.RecordAll).
Public property | RecordingBeepTones | Obsolete. Provides access to the property representing the RecordingBeepTone for this workgroup (use Property.RecordingBeepTones).
Public property | RevertToAvailableTimeout | Provides access to the property representing the revert to available timeout for this workgroup (use Property.RevertToAvailableTimeout).
Public property | Roles | Provides access to the property representing the roles for this workgroup (use Property.Roles).
Public property | SecureInputForms | Provides access to the property representing the secure input forms for this workgroup (use Property.SecureInputForms).
Public property | SecurityRights | Provides access to the various security properties.
Public property | SelectedTone | Provides access to the property representing the SelectedTone for this workgroup (use Property.SelectedTone).
Public property | Skills | Provides access to the property representing the skills for this workgroup (use Property.Skills).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StatisticsShiftStarts | Provides access to the property representing the statistics shift starts for this workgroup (use Property.StatisticsShiftStarts).
Public property | Supervisors | Provides access to the property representing the supervisors for this workgroup (use Property.Supervisors).
Public property | TransactionId | Gets the transaction ID.
Public property | UseRecordingTones | Provides access to the property representing the UseRecordingTones for this workgroup (use Property.UseRecordingTones).
Public property | UseTiffForFaxes | Provides access to the property representing the use tiff for faxes for this workgroup (use Property.UseTiffForFaxes).
Public property | Utilizations | Provides access to the property representing the media utilizations for this workgroup (use Property.Utilizations).
Public property | VoicemailMessage | Provides access to the property representing the voicemail message for this workgroup (use Property.VoicemailMessage).
Public property | WorkItemServiceLevelDistribution | Provides access to the property representing the WorkItemServiceLevelDistribution for this workgroup (use Property.WorkItemServiceLevelDistribution).
Public property | WorkItemServiceLevelTarget | Provides access to the property representing the WorkItemServiceLevelTarget for this workgroup (use Property.WorkItemServiceLevelTarget).
Public property | WrapUpCodes | Provides access to the property representing the wrap up codes for this workgroup (use Property.WrapUpCodes).
Public property | WrapUpPrompt | Provides access to the property representing the wrap up prompt for this workgroup (use Property.WrapUpPrompt).
Public property | WrapUpStatus | Provides access to the property representing the wrap up status for this workgroup (use Property.WrapUpStatus).
Public property | WrapUpTimeout | Provides access to the property representing the wrap up timeout for this workgroup (use Property.WrapUpTimeout).

See Also

WorkgroupConfiguration Class
ININ.IceLib.Configuration Namespace


WorkgroupConfiguration Methods

[image] [image]

IceLib Technical Reference
WorkgroupConfiguration Methods
WorkgroupConfiguration Class See Also Send Feedback

The WorkgroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified workgroups.
 | PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified workgroup.
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetTransactionId | Sets the transaction ID to use when calling Commit()()()() or Delete()()()().
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

WorkgroupConfiguration Class
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method

[image] [image]

IceLib Technical Reference
WorkgroupConfiguration..::..PublishClientTemplate Method
WorkgroupConfiguration Class See Also Send Feedback

Overload List

Name | Description
PublishClientTemplate(ConfigurationManager, ConfigurationId, IEnumerable<(Of <<'(String>)>>), String) | Publishes the client template to the specified workgroups.
PublishClientTemplate(ConfigurationManager, ConfigurationId, String, String) | Publishes the client template to the specified workgroup.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method (ConfigurationManager, ConfigurationId, IEnumerable(String), String)

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..PublishClientTemplate Method (ConfigurationManager, ConfigurationId, IEnumerable<(Of <(<'String>)>)>, String)
WorkgroupConfiguration Class See Also Send Feedback
Publishes the client template to the specified workgroups.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ClientTemplatePublishResult> PublishClientTemplate(
    ConfigurationManager configurationManager,
    ConfigurationId clientTemplateId,
    IEnumerable<string> workgroupIds,
    string applicationId
)
Visual Basic
Public Shared Function PublishClientTemplate ( _
    configurationManager As ConfigurationManager, _
    clientTemplateId As ConfigurationId, _
    workgroupIds As IEnumerable(Of String), _
    applicationId As String _
) As ReadOnlyCollection(Of ClientTemplatePublishResult)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
clientTemplateId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The client template ID.
workgroupIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The workgroup IDs.
applicationId
Type: System..::..String
The application ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ClientTemplatePublishResult objects with the results of the publish operation.

Remarks

Valid clientTemplateId values can be retrieved from the ConfigurationId property of ClientTemplateConfiguration. The workgroupIds values can be retrieved from the Id portion of WorkgroupConfiguration The applicationId can be retrieved from the ApplicationName portion of the return value from GetSessionSettings()()()(). In order to publish client templates, the logged on user must have the CanPublishClientTemplates right.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | One of the workgroupIds, or applicationId is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
PublishClientTemplate Overload
ININ.IceLib.Configuration Namespace


PublishClientTemplate Method (ConfigurationManager, ConfigurationId, String, String)

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..PublishClientTemplate Method (ConfigurationManager, ConfigurationId, String, String)
WorkgroupConfiguration Class See Also Send Feedback
Publishes the client template to the specified workgroup.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ClientTemplatePublishResult> PublishClientTemplate(
    ConfigurationManager configurationManager,
    ConfigurationId clientTemplateId,
    string workgroupId,
    string applicationId
)
Visual Basic
Public Shared Function PublishClientTemplate ( _
    configurationManager As ConfigurationManager, _
    clientTemplateId As ConfigurationId, _
    workgroupId As String, _
    applicationId As String _
) As ReadOnlyCollection(Of ClientTemplatePublishResult)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
clientTemplateId
Type: ININ.IceLib.Configuration..::..ConfigurationId
The client template ID.
workgroupId
Type: System..::..String
The workgroup ID.
applicationId
Type: System..::..String
The application ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ClientTemplatePublishResult objects with the results of the publish operation.

Remarks

Valid clientTemplateId values can be retrieved from the ConfigurationId property of ClientTemplateConfiguration. The workgroupId value can be retrieved from the Id portion of WorkgroupConfiguration The applicationId can be retrieved from the ApplicationName portion of the return value from GetSessionSettings()()()(). In order to publish client templates, the logged on user must have the CanPublishClientTemplates right.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | workgroupId, or applicationId is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
PublishClientTemplate Overload
ININ.IceLib.Configuration Namespace


SetTransactionId Method

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..SetTransactionId Method
WorkgroupConfiguration Class See Also Send Feedback
Sets the transaction ID to use when calling Commit()()()() or Delete()()()().

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTransactionId(
    int transactionId
)
Visual Basic
Public Sub SetTransactionId ( _
    transactionId As Integer _
)

Parameters

transactionId
Type: System..::..Int32
The transaction ID.

Remarks

Valid values can be obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). If the connected Session is disconnected before EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is called, all transaction IDs will become invalid, and new ones will need to be obtained. Setting this value to NoTransactionId will clear the transaction ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | transactionId is less than zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WorkgroupConfiguration Properties

[image] [image]

IceLib Technical Reference
WorkgroupConfiguration Properties
WorkgroupConfiguration Class See Also Send Feedback

The WorkgroupConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this workgroup (use Property.AccessControlGroupAssignment).
Public property | AccessRights | Provides access to the various access control list properties.
Public property | AcdDisconnectedAction | Provides access to the property representing the ACD disconnected action for this workgroup (use Property.AcdDisconnectedAction).
Public property | AcdIncomingAction | Provides access to the property representing the ACD incoming action for this workgroup (use Property.AcdIncomingAction).
Public property | AcdOfferingAction | Provides access to the property representing the ACD offering action for this workgroup (use Property.AcdOfferingAction).
Public property | AcdSaveRepliesToSentItemsFolder | Provides access to the property representing ACD save replies to sent items folder for this workgroup (use Property.AcdSaveRepliesToSentItemsFolder).
Public property | AcdTransferAction | Provides access to the property representing the ACD transfer action for this workgroup (use Property.AcdTransferAction).
Public property | AcdUseAvailablityTime | Provides access to the property representing ACD use availability time for this workgroup (use Property.AcdUseAvailablityTime).
Public property | AdministrativeRights | Provides access to the various administrative access control list properties.
Public property | AgentScoreChange | Provides access to the property representing the agent score change for this workgroup (use Property.AgentScoreChange).
Public property | AnalyzerKeywordSets | Obsolete. Provides access to the property representing the analyzer keyword sets for this workgroup (use Property.AnalyzerKeywordSets).
Public property | CallbackMaxRetry | Provides access to the property representing how many times a callback may be retried. (use Property.CallbackMaxRetry)
Public property | CallbackServiceLevelDistribution | Provides access to the property representing the CallbackServiceLevelDistribution for this workgroup (use Property.CallbackServiceLevelDistribution).
Public property | CallbackServiceLevelTarget | Provides access to the property representing the CallbackServiceLevelTarget for this workgroup (use Property.CallbackServiceLevelTarget).
Public property | CallbackSnoozeDuration | Provides access to the property representing how many seconds a snooze on a callback should last. (use Property.CallbackSnoozeDuration)
Public property | CallServiceLevelDistribution | Provides access to the property representing the CallServiceLevelDistribution for this workgroup (use Property.CallServiceLevelDistribution).
Public property | CallServiceLevelTarget | Provides access to the property representing the CallServiceLevelTarget for this workgroup (use Property.CallServiceLevelTarget).
Public property | CallStatisticsPeriod | Provides access to the property representing the call statistics period for this workgroup (use Property.CallStatisticsPeriod).
Public property | CaptureInRecordings | Provides access to the property representing the CaptureInRecordings for this workgroup (use Property.CaptureInRecordings).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ChatServiceLevelDistribution | Provides access to the property representing the ChatServiceLevelDistribution for this workgroup (use Property.ChatServiceLevelDistribution).
Public property | ChatServiceLevelTarget | Provides access to the property representing the ChatServiceLevelTarget for this workgroup (use Property.ChatServiceLevelTarget).
Public property | ClientWaitTimeout | Provides access to the property representing the client wait timeout for this workgroup (use Property.ClientWaitTimeout).
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | EmailServiceLevelDistribution | Provides access to the property representing the EmailServiceLevelDistribution for this workgroup (use Property.EmailServiceLevelDistribution).
Public property | EmailServiceLevelTarget | Provides access to the property representing the EmailServiceLevelTarget for this workgroup (use Property.EmailServiceLevelTarget).
Public property | EstimatedCallTimeInterval | Provides access to the property representing the estimated call time interval for this workgroup (use Property.EstimatedCallTimeInterval).
Public property | ExecuteTransferActionOnUserTransfer | Provides access to the property representing the execute transfer action on user transfer for this workgroup (use Property.ExecuteTransferActionOnUserTransfer).
Public property | Extension | Provides access to the property representing the extension for this workgroup (use Property.Extension).
Public property | FaxCapability | Provides access to the property representing the FAX capability for this workgroup (use Property.FaxCapability).
Public property | GenericServiceLevelDistribution | Provides access to the property representing the GenericServiceLevelDistribution for this workgroup (use Property.GenericServiceLevelDistribution).
Public property | GenericServiceLevelTarget | Provides access to the property representing the GenericServiceLevelTarget for this workgroup (use Property.GenericServiceLevelTarget).
Public property | GracePeriodBeforeNew | Provides access to the property representing the grace period before new for this workgroup (use Property.GracePeriodBeforeNew).
Public property | HasActivation | Obsolete. Provides access to the property representing the has activation for this workgroup (use Property.HasActivation).
Public property | HasMailbox | Obsolete. Provides access to the property representing the has mailbox for this workgroup (use Property.HasMailbox).
Public property | HasQueue | Provides access to the property representing the has queue for this workgroup (use Property.HasQueue).
Public property | InteractionDisconnectedAction | Provides access to the property representing the interaction disconnected action for this workgroup (use Property.InteractionDisconnectedAction).
Public property | InteractionMessageStoreMaxMessage | Obsolete. Provides access to the property representing the Interaction Message Store max messages for this workgroup (use Property.InteractionMessageStoreMaxMessage).
Public property | InteractionMessageStoreMaxStorage | Obsolete. Provides access to the property representing the Interaction Message Store max storage for this workgroup (use Property.InteractionMessageStoreMaxStorage).
Public property | InteractionOfferingAction | Provides access to the property representing the interaction offering action for this workgroup (use Property.InteractionOfferingAction).
Public property | InteractionOfferingTimeout | Provides access to the property representing the interaction offering timeout for this workgroup (use Property.InteractionOfferingTimeout).
Public property | IsAcdEmailRoutingActive | Provides access to the property representing the is acd email routing active for this workgroup (use Property.IsAcdEmailRoutingActive).
Public property | IsActive | Provides access to the property representing the is active for this workgroup (use Property.IsActive).
Public property | IsCallbackEnabled | Provides access to the property representing if callback is enabled for this workgroup (use Property.IsCallbackEnabled).
Public property | IsExemptHeldInteractionsEnabled | Provides access to the property representing the is exempt held interactions enabled for this workgroup (use Property.IsExemptHeldInteractionsEnabled).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsWrapUpActive | Provides access to the property representing the is wrap up active for this workgroup (use Property.IsWrapUpActive).
Public property | KeypadWaitTimeout | Provides access to the property representing the keypad wait timeout for this workgroup (use Property.KeypadWaitTimeout).
Public property | Mailbox | Provides access to the various mailbox properties.
Public property | MaximumChatReponseTime | Provides access to the property representing how many seconds a chat interaction can go without being updated before the User Interface should warn the user (use Property.MaximumChatReponseTime).
Public property | MaxNumberOfExempt | Provides access to the property representing the max number of exempt for this workgroup (use Property.MaxNumberOfExempt).
Public property | Members | Provides access to the property representing the members for this workgroup (use Property.Members).
Public property | MembersSpanSites | Provides access to the property representing the members span sites for this workgroup (use Property.MembersSpanSites).
Public property | MonitoredMailboxes | Provides access to the property representing the monitored mailboxes for this workgroup (use Property.MonitoredMailboxes).
Public property | NameSpellingsAsr | Provides access to the property representing the ASR name spellings for this workgroup (use Property.NameSpellingsAsr).
Public property | NameSpellingTts | Provides access to the property representing the TTS name spelling for this workgroup (use Property.NameSpellingTts).
Public property | NoAnswerStatus | Provides access to the property representing the no answer status for this workgroup (use Property.NoAnswerStatus).
Public property | OnCallStatus | Provides access to the property representing the on call status for this workgroup (use Property.OnCallStatus).
Public property | OnHoldMessage | Provides access to the property representing the on hold message for this workgroup (use Property.OnHoldMessage).
Public property | OnHoldMusic | Provides access to the property representing the on hold music for this workgroup (use Property.OnHoldMusic).
Public property | OperatorTarget | Provides access to the property representing the operator target for this workgroup (use Property.OperatorTarget).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | ParkedCallExtension | Provides access to the property representing the parked call extension for this workgroup (use Property.ParkedCallExtension).
Public property | ParkedCallTimeout | Provides access to the property representing the parked call timeout for this workgroup (use Property.ParkedCallTimeout).
Public property | ParkedChatExtension | Provides access to the property representing the parked chat extension for this workgroup (use Property.ParkedChatExtension).
Public property | ParkedChatTimeout | Provides access to the property representing the parked chat timeout for this workgroup (use Property.ParkedChatTimeout).
Public property | ParkedEmailExtension | Provides access to the property representing the parked email extension for this workgroup (use Property.ParkedEmailExtension).
Public property | ParkedEmailTimeout | Provides access to the property representing the parked email timeout for this workgroup (use Property.ParkedEmailTimeout).
Public property | ParkedGenericObjectExtension | Provides access to the property representing the parked generic object extension for this workgroup (use Property.ParkedGenericObjectExtension).
Public property | ParkedGenericObjectTimeout | Provides access to the property representing the parked generic object timeout for this workgroup (use Property.ParkedGenericObjectTimeout).
Public property | PlayToExternalPartiesOnly | Provides access to the property representing the ExternalPartiesOnly for this workgroup (use Property.PlayToExternalPartiesOnly).
Public property | PreferredLanguage | Provides access to the property representing the preferred language for this workgroup (use Property.PreferredLanguage).
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | QueueType | Provides access to the property representing the queue type for this workgroup (use Property.QueueType).
Public property | RecordAll | Provides access to the property representing the record all for this workgroup (use Property.RecordAll).
Public property | RecordingBeepTones | Obsolete. Provides access to the property representing the RecordingBeepTone for this workgroup (use Property.RecordingBeepTones).
Public property | RevertToAvailableTimeout | Provides access to the property representing the revert to available timeout for this workgroup (use Property.RevertToAvailableTimeout).
Public property | Roles | Provides access to the property representing the roles for this workgroup (use Property.Roles).
Public property | SecureInputForms | Provides access to the property representing the secure input forms for this workgroup (use Property.SecureInputForms).
Public property | SecurityRights | Provides access to the various security properties.
Public property | SelectedTone | Provides access to the property representing the SelectedTone for this workgroup (use Property.SelectedTone).
Public property | Skills | Provides access to the property representing the skills for this workgroup (use Property.Skills).
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | StatisticsShiftStarts | Provides access to the property representing the statistics shift starts for this workgroup (use Property.StatisticsShiftStarts).
Public property | Supervisors | Provides access to the property representing the supervisors for this workgroup (use Property.Supervisors).
Public property | TransactionId | Gets the transaction ID.
Public property | UseRecordingTones | Provides access to the property representing the UseRecordingTones for this workgroup (use Property.UseRecordingTones).
Public property | UseTiffForFaxes | Provides access to the property representing the use tiff for faxes for this workgroup (use Property.UseTiffForFaxes).
Public property | Utilizations | Provides access to the property representing the media utilizations for this workgroup (use Property.Utilizations).
Public property | VoicemailMessage | Provides access to the property representing the voicemail message for this workgroup (use Property.VoicemailMessage).
Public property | WorkItemServiceLevelDistribution | Provides access to the property representing the WorkItemServiceLevelDistribution for this workgroup (use Property.WorkItemServiceLevelDistribution).
Public property | WorkItemServiceLevelTarget | Provides access to the property representing the WorkItemServiceLevelTarget for this workgroup (use Property.WorkItemServiceLevelTarget).
Public property | WrapUpCodes | Provides access to the property representing the wrap up codes for this workgroup (use Property.WrapUpCodes).
Public property | WrapUpPrompt | Provides access to the property representing the wrap up prompt for this workgroup (use Property.WrapUpPrompt).
Public property | WrapUpStatus | Provides access to the property representing the wrap up status for this workgroup (use Property.WrapUpStatus).
Public property | WrapUpTimeout | Provides access to the property representing the wrap up timeout for this workgroup (use Property.WrapUpTimeout).

See Also

WorkgroupConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AccessControlGroupAssignment Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this workgroup (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AccessRights Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AccessRights Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the various access control list properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAccessRightsProperties<WorkgroupConfiguration, WorkgroupConfiguration..::..Property> AccessRights { get; }
Visual Basic
Public ReadOnly Property AccessRights As UserAccessRightsProperties(Of WorkgroupConfiguration, WorkgroupConfiguration..::..Property)
    Get

Field Value

The workgroup access control rights properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AcdDisconnectedAction Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AcdDisconnectedAction Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD disconnected action for this workgroup (use Property.AcdDisconnectedAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> AcdDisconnectedAction { get; }
Visual Basic
Public ReadOnly Property AcdDisconnectedAction As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the ACD disconnected action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AcdIncomingAction Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AcdIncomingAction Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD incoming action for this workgroup (use Property.AcdIncomingAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> AcdIncomingAction { get; }
Visual Basic
Public ReadOnly Property AcdIncomingAction As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the ACD incoming action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AcdOfferingAction Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AcdOfferingAction Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD offering action for this workgroup (use Property.AcdOfferingAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> AcdOfferingAction { get; }
Visual Basic
Public ReadOnly Property AcdOfferingAction As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the ACD offering action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AcdSaveRepliesToSentItemsFolder Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AcdSaveRepliesToSentItemsFolder Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing ACD save replies to sent items folder for this workgroup (use Property.AcdSaveRepliesToSentItemsFolder).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> AcdSaveRepliesToSentItemsFolder { get; }
Visual Basic
Public ReadOnly Property AcdSaveRepliesToSentItemsFolder As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the ACD save replies to sent items folder.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AcdTransferAction Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AcdTransferAction Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ACD transfer action for this workgroup (use Property.AcdTransferAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> AcdTransferAction { get; }
Visual Basic
Public ReadOnly Property AcdTransferAction As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the ACD transfer action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AcdUseAvailablityTime Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AcdUseAvailablityTime Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing ACD use availability time for this workgroup (use Property.AcdUseAvailablityTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> AcdUseAvailablityTime { get; }
Visual Basic
Public ReadOnly Property AcdUseAvailablityTime As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the ACD use availability time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AdministrativeRights Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AdministrativeRights Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the various administrative access control list properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAdministrativeRightsProperties<WorkgroupConfiguration, WorkgroupConfiguration..::..Property> AdministrativeRights { get; }
Visual Basic
Public ReadOnly Property AdministrativeRights As UserAdministrativeRightsProperties(Of WorkgroupConfiguration, WorkgroupConfiguration..::..Property)
    Get

Field Value

The workgroup access administrative access control properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AgentScoreChange Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AgentScoreChange Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the agent score change for this workgroup (use Property.AgentScoreChange).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> AgentScoreChange { get; }
Visual Basic
Public ReadOnly Property AgentScoreChange As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the agent score change.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


AnalyzerKeywordSets Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..AnalyzerKeywordSets Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the analyzer keyword sets for this workgroup (use Property.AnalyzerKeywordSets).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AnalyzerKeywordSets are configured with recorder policies instead of with workgroups now.")]
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<AnalyzerKeywordSetChannelRelationship>> AnalyzerKeywordSets { get; }
Visual Basic
<ObsoleteAttribute("AnalyzerKeywordSets are configured with recorder policies instead of with workgroups now.")> _
Public ReadOnly Property AnalyzerKeywordSets As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of AnalyzerKeywordSetChannelRelationship))
    Get

Field Value

The property representing the analyzer keyword sets.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallbackMaxRetry Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallbackMaxRetry Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing how many times a callback may be retried. (use Property.CallbackMaxRetry)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> CallbackMaxRetry { get; }
Visual Basic
Public ReadOnly Property CallbackMaxRetry As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the number of times a callback may be retried.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallbackServiceLevelDistribution Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallbackServiceLevelDistribution Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the CallbackServiceLevelDistribution for this workgroup (use Property.CallbackServiceLevelDistribution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> CallbackServiceLevelDistribution { get; }
Visual Basic
Public ReadOnly Property CallbackServiceLevelDistribution As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the CallbackServiceLevelDistribution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallbackServiceLevelTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallbackServiceLevelTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the CallbackServiceLevelTarget for this workgroup (use Property.CallbackServiceLevelTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> CallbackServiceLevelTarget { get; }
Visual Basic
Public ReadOnly Property CallbackServiceLevelTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the CallbackServiceLevelTarget.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallbackSnoozeDuration Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallbackSnoozeDuration Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing how many seconds a snooze on a callback should last. (use Property.CallbackSnoozeDuration)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> CallbackSnoozeDuration { get; }
Visual Basic
Public ReadOnly Property CallbackSnoozeDuration As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the number of seconds a callback snooze should last.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallServiceLevelDistribution Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallServiceLevelDistribution Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the CallServiceLevelDistribution for this workgroup (use Property.CallServiceLevelDistribution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> CallServiceLevelDistribution { get; }
Visual Basic
Public ReadOnly Property CallServiceLevelDistribution As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the CallServiceLevelDistribution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallServiceLevelTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallServiceLevelTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the CallServiceLevelTarget for this workgroup (use Property.CallServiceLevelTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> CallServiceLevelTarget { get; }
Visual Basic
Public ReadOnly Property CallServiceLevelTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the CallServiceLevelTarget.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CallStatisticsPeriod Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CallStatisticsPeriod Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the call statistics period for this workgroup (use Property.CallStatisticsPeriod).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> CallStatisticsPeriod { get; }
Visual Basic
Public ReadOnly Property CallStatisticsPeriod As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the call statistics period.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


CaptureInRecordings Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..CaptureInRecordings Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the CaptureInRecordings for this workgroup (use Property.CaptureInRecordings).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> CaptureInRecordings { get; }
Visual Basic
Public ReadOnly Property CaptureInRecordings As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the CaptureInRecordings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


ChatServiceLevelDistribution Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ChatServiceLevelDistribution Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ChatServiceLevelDistribution for this workgroup (use Property.ChatServiceLevelDistribution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> ChatServiceLevelDistribution { get; }
Visual Basic
Public ReadOnly Property ChatServiceLevelDistribution As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the ChatServiceLevelDistribution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


ChatServiceLevelTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ChatServiceLevelTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ChatServiceLevelTarget for this workgroup (use Property.ChatServiceLevelTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> ChatServiceLevelTarget { get; }
Visual Basic
Public ReadOnly Property ChatServiceLevelTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the ChatServiceLevelTarget.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


ClientWaitTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ClientWaitTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the client wait timeout for this workgroup (use Property.ClientWaitTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> ClientWaitTimeout { get; }
Visual Basic
Public ReadOnly Property ClientWaitTimeout As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the client wait timeout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


EmailServiceLevelDistribution Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..EmailServiceLevelDistribution Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the EmailServiceLevelDistribution for this workgroup (use Property.EmailServiceLevelDistribution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> EmailServiceLevelDistribution { get; }
Visual Basic
Public ReadOnly Property EmailServiceLevelDistribution As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the EmailServiceLevelDistribution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


EmailServiceLevelTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..EmailServiceLevelTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the EmailServiceLevelTarget for this workgroup (use Property.EmailServiceLevelTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> EmailServiceLevelTarget { get; }
Visual Basic
Public ReadOnly Property EmailServiceLevelTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the EmailServiceLevelTarget.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


EstimatedCallTimeInterval Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..EstimatedCallTimeInterval Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the estimated call time interval for this workgroup (use Property.EstimatedCallTimeInterval).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> EstimatedCallTimeInterval { get; }
Visual Basic
Public ReadOnly Property EstimatedCallTimeInterval As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the estimated call time interval.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


ExecuteTransferActionOnUserTransfer Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ExecuteTransferActionOnUserTransfer Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the execute transfer action on user transfer for this workgroup (use Property.ExecuteTransferActionOnUserTransfer).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> ExecuteTransferActionOnUserTransfer { get; }
Visual Basic
Public ReadOnly Property ExecuteTransferActionOnUserTransfer As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the execute transfer action on user transfer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Extension Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Extension Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the extension for this workgroup (use Property.Extension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> Extension { get; }
Visual Basic
Public ReadOnly Property Extension As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the extension.

Remarks

Note
Be sure the workgroup extension numbers do not begin with a number that conflicts with a user extension or other valid queue extension. Extension numbers can be from two to six digits but should avoid the following numbers (in North America): 1800, 1900, 1411, 1911.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


FaxCapability Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..FaxCapability Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the FAX capability for this workgroup (use Property.FaxCapability).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> FaxCapability { get; }
Visual Basic
Public ReadOnly Property FaxCapability As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the FAX capability.

Remarks

If you configure a workgroup as fax-capable, then callers to that DID hear ring-back while the handler listens for a fax. The handler then places the call on the queue.
Note
If you do not configure a workgroup as fax-capable, the call goes directly to that workgroup queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


GenericServiceLevelDistribution Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..GenericServiceLevelDistribution Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the GenericServiceLevelDistribution for this workgroup (use Property.GenericServiceLevelDistribution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> GenericServiceLevelDistribution { get; }
Visual Basic
Public ReadOnly Property GenericServiceLevelDistribution As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the GenericServiceLevelDistribution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


GenericServiceLevelTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..GenericServiceLevelTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the GenericServiceLevelTarget for this workgroup (use Property.GenericServiceLevelTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> GenericServiceLevelTarget { get; }
Visual Basic
Public ReadOnly Property GenericServiceLevelTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the GenericServiceLevelTarget.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


GracePeriodBeforeNew Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..GracePeriodBeforeNew Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the grace period before new for this workgroup (use Property.GracePeriodBeforeNew).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> GracePeriodBeforeNew { get; }
Visual Basic
Public ReadOnly Property GracePeriodBeforeNew As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the grace period before new.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


HasActivation Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..HasActivation Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the has activation for this workgroup (use Property.HasActivation).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("HasActivation is not a valid property for WorkgroupConfiguration.")]
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> HasActivation { get; }
Visual Basic
<ObsoleteAttribute("HasActivation is not a valid property for WorkgroupConfiguration.")> _
Public ReadOnly Property HasActivation As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing has activation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


HasMailbox Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..HasMailbox Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the has mailbox for this workgroup (use Property.HasMailbox).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("HasMailbox is not a valid property for WorkgroupConfiguration.")]
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> HasMailbox { get; }
Visual Basic
<ObsoleteAttribute("HasMailbox is not a valid property for WorkgroupConfiguration.")> _
Public ReadOnly Property HasMailbox As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing has mailbox.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


HasQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..HasQueue Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the has queue for this workgroup (use Property.HasQueue).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> HasQueue { get; }
Visual Basic
Public ReadOnly Property HasQueue As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing has queue.

Remarks

This read-only property is not directly editable. See QueueType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionDisconnectedAction Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..InteractionDisconnectedAction Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the interaction disconnected action for this workgroup (use Property.InteractionDisconnectedAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> InteractionDisconnectedAction { get; }
Visual Basic
Public ReadOnly Property InteractionDisconnectedAction As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the interaction disconnected action.

Remarks

An action to start each time an interaction moves from the connected state to a disconnected state in a workgroup queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ActionConfiguration
ININ.IceLib.Configuration..::..ActionConfigurationList


InteractionMessageStoreMaxMessage Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..InteractionMessageStoreMaxMessage Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the Interaction Message Store max messages for this workgroup (use Property.InteractionMessageStoreMaxMessage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessageStoreMaxMessage is no longer available.")]
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, int> InteractionMessageStoreMaxMessage { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessageStoreMaxMessage is no longer available.")> _
Public ReadOnly Property InteractionMessageStoreMaxMessage As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Interaction Message Store max message.

Remarks

Note
-1 = "No Limit"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionMessageStoreMaxStorage Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..InteractionMessageStoreMaxStorage Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the Interaction Message Store max storage for this workgroup (use Property.InteractionMessageStoreMaxStorage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessageStoreMaxStorage is no longer available.")]
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, int> InteractionMessageStoreMaxStorage { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessageStoreMaxStorage is no longer available.")> _
Public ReadOnly Property InteractionMessageStoreMaxStorage As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the Interaction Message Store max storage.

Remarks

Note
-1 = "No Limit"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


InteractionOfferingAction Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..InteractionOfferingAction Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the interaction offering action for this workgroup (use Property.InteractionOfferingAction).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> InteractionOfferingAction { get; }
Visual Basic
Public ReadOnly Property InteractionOfferingAction As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the interaction offering action.

Remarks

An action to start each time a non-ACD interaction enters an alerting state (for example, the station rings) in a workgroup queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..ActionConfiguration
ININ.IceLib.Configuration..::..ActionConfigurationList


InteractionOfferingTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..InteractionOfferingTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the interaction offering timeout for this workgroup (use Property.InteractionOfferingTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> InteractionOfferingTimeout { get; }
Visual Basic
Public ReadOnly Property InteractionOfferingTimeout As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the interaction offering timeout.

Remarks

The number of seconds an incoming interaction rings at the Interaction Client station before the interaction quits alerting and proceeds to the next step in the handler (for example, goes to voice mail or changes an ACD agent’s status to ACD-Agent not answering and offers the interaction to another agent). The default value is 15 seconds; entering 0 (zero) also means 15 seconds. The minimum value is 7 seconds, which allows at least one full ring cycle. For North America, the standard ring duration for one ring is six seconds, which includes two seconds of ring and four seconds of pause time.

Note

This setting affects ACD and non-ACD interactions differently, depending on where you set it.

This setting also affects the timeout for the workgroup's Group Ring and Sequential Ring.

The timeout value on the Workgroup determines the number of seconds ACD interactions alert on agent workstations.

The timeout value on the User determines the number of seconds non-ACD interactions alert on agent workstations.

The timeout value on the Default User determines the number of seconds non-ACD interactions alert on agent workstations only when the value is 0 (zero) on the User. If it is set to 0 (zero) on the User, the default value is 15 seconds of alerting.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


IsAcdEmailRoutingActive Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..IsAcdEmailRoutingActive Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the is acd email routing active for this workgroup (use Property.IsAcdEmailRoutingActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> IsAcdEmailRoutingActive { get; }
Visual Basic
Public ReadOnly Property IsAcdEmailRoutingActive As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing acd email routing active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


IsActive Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..IsActive Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the is active for this workgroup (use Property.IsActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing is active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


IsCallbackEnabled Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..IsCallbackEnabled Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing if callback is enabled for this workgroup (use Property.IsCallbackEnabled).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> IsCallbackEnabled { get; }
Visual Basic
Public ReadOnly Property IsCallbackEnabled As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing if callback is enabled for this workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


IsExemptHeldInteractionsEnabled Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..IsExemptHeldInteractionsEnabled Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the is exempt held interactions enabled for this workgroup (use Property.IsExemptHeldInteractionsEnabled).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> IsExemptHeldInteractionsEnabled { get; }
Visual Basic
Public ReadOnly Property IsExemptHeldInteractionsEnabled As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing is exempt held interactions enabled.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


IsWrapUpActive Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..IsWrapUpActive Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the is wrap up active for this workgroup (use Property.IsWrapUpActive).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> IsWrapUpActive { get; }
Visual Basic
Public ReadOnly Property IsWrapUpActive As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing is wrap up active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


KeypadWaitTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..KeypadWaitTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the keypad wait timeout for this workgroup (use Property.KeypadWaitTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> KeypadWaitTimeout { get; }
Visual Basic
Public ReadOnly Property KeypadWaitTimeout As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the keypad wait timeout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Mailbox Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Mailbox Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the various mailbox properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupMailboxProperties Mailbox { get; }
Visual Basic
Public ReadOnly Property Mailbox As WorkgroupMailboxProperties
    Get

Field Value

The mailbox properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


MaximumChatReponseTime Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..MaximumChatReponseTime Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing how many seconds a chat interaction can go without being updated before the User Interface should warn the user (use Property.MaximumChatReponseTime).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> MaximumChatReponseTime { get; }
Visual Basic
Public ReadOnly Property MaximumChatReponseTime As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the number of seconds before an inactive chat should warn the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


MaxNumberOfExempt Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..MaxNumberOfExempt Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the max number of exempt for this workgroup (use Property.MaxNumberOfExempt).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> MaxNumberOfExempt { get; }
Visual Basic
Public ReadOnly Property MaxNumberOfExempt As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the max number of exempt.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Members Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Members Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the members for this workgroup (use Property.Members).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<ConfigurationId>> Members { get; }
Visual Basic
Public ReadOnly Property Members As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the members.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


MembersSpanSites Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..MembersSpanSites Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the members span sites for this workgroup (use Property.MembersSpanSites).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> MembersSpanSites { get; }
Visual Basic
Public ReadOnly Property MembersSpanSites As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing members spans sites.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


MonitoredMailboxes Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..MonitoredMailboxes Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the monitored mailboxes for this workgroup (use Property.MonitoredMailboxes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<WorkgroupMonitoredMailboxConfiguration>> MonitoredMailboxes { get; }
Visual Basic
Public ReadOnly Property MonitoredMailboxes As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of WorkgroupMonitoredMailboxConfiguration))
    Get

Field Value

The property representing the monitored mailboxes for this workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


NameSpellingsAsr Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..NameSpellingsAsr Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ASR name spellings for this workgroup (use Property.NameSpellingsAsr).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<string>> NameSpellingsAsr { get; }
Visual Basic
Public ReadOnly Property NameSpellingsAsr As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of String))
    Get

Field Value

The property representing the ASR name spellings.

Remarks

Note
The user's or workgroup's phonetic spelling of the name. You can specify multiple spellings for ASR. The ASR spelling attribute should be a multi-valued attribute.
Note
The ASR phonetic spelling values are used by the “Reco Create Company Directory Grammar”. This can be very useful to add nick names or different spellings of a user’s name. Any valid grammar token may be specified in this list. For example, assume a user called “John Smith”. That’s the first and last name as he is known to the IC system and used by default for the company directory grammar. However, you want to add additional spellings to increase the coverage of the grammar by adding the following alternate spellings:
  • Johnny Smith
  • John Robert Smith
  • John R Smith
Note
You should be careful not to add too many alternate spellings without actually knowing whether the spellings will be used by callers. If the grammar coverage becomes too broad, in particular if the company directory already contains a lot of similarly sounding names, the recognitions quality will be degraded because of the ambiguity.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


NameSpellingTts Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..NameSpellingTts Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the TTS name spelling for this workgroup (use Property.NameSpellingTts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> NameSpellingTts { get; }
Visual Basic
Public ReadOnly Property NameSpellingTts As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the TTS name spelling.

Remarks

The user's or workgroup's phonetic spelling of the name.

The TTS spelling should be a single-valued attribute. You spell the name like it sounds. For example if you have a user name spelled "Rose", but it is pronounced "Rosy", you would enter "Rosy".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


NoAnswerStatus Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..NoAnswerStatus Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the no answer status for this workgroup (use Property.NoAnswerStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> NoAnswerStatus { get; }
Visual Basic
Public ReadOnly Property NoAnswerStatus As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the no answer status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


OnCallStatus Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..OnCallStatus Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the on call status for this workgroup (use Property.OnCallStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> OnCallStatus { get; }
Visual Basic
Public ReadOnly Property OnCallStatus As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the on call status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


OnHoldMessage Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..OnHoldMessage Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the on hold message for this workgroup (use Property.OnHoldMessage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> OnHoldMessage { get; }
Visual Basic
Public ReadOnly Property OnHoldMessage As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the on hold message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


OnHoldMusic Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..OnHoldMusic Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the on hold music for this workgroup (use Property.OnHoldMusic).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> OnHoldMusic { get; }
Visual Basic
Public ReadOnly Property OnHoldMusic As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the on hold music.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


OperatorTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..OperatorTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the operator target for this workgroup (use Property.OperatorTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> OperatorTarget { get; }
Visual Basic
Public ReadOnly Property OperatorTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the operator target.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


ParkedCallExtension Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedCallExtension Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked call extension for this workgroup (use Property.ParkedCallExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, string> ParkedCallExtension { get; }
Visual Basic
Public ReadOnly Property ParkedCallExtension As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked call extension.

Remarks

The destination extension for a parked call that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedCallTimeout
WorkgroupConfiguration..::..ParkedCallTimeout


ParkedCallTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedCallTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked call timeout for this workgroup (use Property.ParkedCallTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> ParkedCallTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedCallTimeout As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked call timeout.

Remarks

The maximum time in minutes that a parked call should wait before transfer to the specified ParkedCallExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedCallExtension


ParkedChatExtension Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedChatExtension Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked chat extension for this workgroup (use Property.ParkedChatExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, string> ParkedChatExtension { get; }
Visual Basic
Public ReadOnly Property ParkedChatExtension As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked chat extension.

Remarks

The destination extension for a parked chat that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedChatTimeout
WorkgroupConfiguration..::..ParkedChatTimeout


ParkedChatTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedChatTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked chat timeout for this workgroup (use Property.ParkedChatTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> ParkedChatTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedChatTimeout As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked chat timeout.

Remarks

The maximum time in minutes that a parked chat should wait before transfer to the specified ParkedChatExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedChatExtension


ParkedEmailExtension Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedEmailExtension Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked email extension for this workgroup (use Property.ParkedEmailExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, string> ParkedEmailExtension { get; }
Visual Basic
Public ReadOnly Property ParkedEmailExtension As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked email extension.

Remarks

The destination extension for a parked email that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedEmailTimeout
WorkgroupConfiguration..::..ParkedEmailTimeout


ParkedEmailTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedEmailTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked email timeout for this workgroup (use Property.ParkedEmailTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> ParkedEmailTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedEmailTimeout As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked email timeout.

Remarks

The maximum time in minutes that a parked email should wait before transfer to the specified ParkedEmailExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedEmailExtension


ParkedGenericObjectExtension Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedGenericObjectExtension Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked generic object extension for this workgroup (use Property.ParkedGenericObjectExtension).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, string> ParkedGenericObjectExtension { get; }
Visual Basic
Public ReadOnly Property ParkedGenericObjectExtension As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the parked generic object extension.

Remarks

The destination extension for a parked generic object that has reached its .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedGenericObjectTimeout
WorkgroupConfiguration..::..ParkedGenericObjectTimeout


ParkedGenericObjectTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..ParkedGenericObjectTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the parked generic object timeout for this workgroup (use Property.ParkedGenericObjectTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InheritableConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> ParkedGenericObjectTimeout { get; }
Visual Basic
Public ReadOnly Property ParkedGenericObjectTimeout As InheritableConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the parked generic object timeout.

Remarks

The maximum time in minutes that a parked generic object should wait before transfer to the specified ParkedGenericObjectExtension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
WorkgroupConfiguration..::..ParkedGenericObjectExtension


PlayToExternalPartiesOnly Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..PlayToExternalPartiesOnly Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the ExternalPartiesOnly for this workgroup (use Property.PlayToExternalPartiesOnly).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> PlayToExternalPartiesOnly { get; }
Visual Basic
Public ReadOnly Property PlayToExternalPartiesOnly As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the ExternalPartiesOnly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


PreferredLanguage Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..PreferredLanguage Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the preferred language for this workgroup (use Property.PreferredLanguage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> PreferredLanguage { get; }
Visual Basic
Public ReadOnly Property PreferredLanguage As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the preferred language.

Remarks

The preferred language is used for the prompts for this workgroup. The valid values can be obtained from Languages by using the Name of the CultureInfo desired.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
SystemConfiguration..::..Languages


PropertiesChanged Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..PropertiesChanged Property
WorkgroupConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WorkgroupConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of WorkgroupConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


QueueType Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..QueueType Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the queue type for this workgroup (use Property.QueueType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, WorkgroupQueueType> QueueType { get; }
Visual Basic
Public ReadOnly Property QueueType As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, WorkgroupQueueType)
    Get

Field Value

The property representing the queue type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


RecordAll Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..RecordAll Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the record all for this workgroup (use Property.RecordAll).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> RecordAll { get; }
Visual Basic
Public ReadOnly Property RecordAll As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing record all.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


RecordingBeepTones Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..RecordingBeepTones Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the RecordingBeepTone for this workgroup (use Property.RecordingBeepTones).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("RecordingBeepTones is not a valid property for WorkgroupConfiguration.")]
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<ConfigurationId>> RecordingBeepTones { get; }
Visual Basic
<ObsoleteAttribute("RecordingBeepTones is not a valid property for WorkgroupConfiguration.")> _
Public ReadOnly Property RecordingBeepTones As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the RecordingBeepTones.

Remarks

A RecordingBeepTone is a set of attributes. When a RecordingBeepTone is added to a Workgroup, the Workgroup takes on those attributes.
  • Owned - To assign or remove a RecordingBeepTone on this Workgroup, modify the Value of this property. One or more RecordingBeepTones must already be defined to add a RecordingBeepTone in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..RecordingBeepToneConfiguration
ININ.IceLib.Configuration..::..RecordingBeepToneConfigurationList


RevertToAvailableTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..RevertToAvailableTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the revert to available timeout for this workgroup (use Property.RevertToAvailableTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> RevertToAvailableTimeout { get; }
Visual Basic
Public ReadOnly Property RevertToAvailableTimeout As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the revert to available timeout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Roles Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Roles Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the roles for this workgroup (use Property.Roles).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<ConfigurationId>> Roles { get; }
Visual Basic
Public ReadOnly Property Roles As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the roles.

Remarks

A role is a set of permissions. When a Role is added to a Workgroup, the Workgroup takes on those permissions. If a User is a member of that Workgroup, the User automatically inherits the Roles assigned to the Workgroup.
  • Owned - To assign or remove a role on this User, modify the Value of this property. One or more Roles must already be defined to add a Role in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..RoleConfiguration
ININ.IceLib.Configuration..::..RoleConfigurationList


SecureInputForms Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..SecureInputForms Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the secure input forms for this workgroup (use Property.SecureInputForms).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<ConfigurationId>> SecureInputForms { get; }
Visual Basic
Public ReadOnly Property SecureInputForms As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the secure input forms.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..SecureInputFormConfiguration
ININ.IceLib.Configuration..::..SecureInputFormConfigurationList


SecurityRights Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..SecurityRights Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the various security properties.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserSecurityRightsProperties<WorkgroupConfiguration, WorkgroupConfiguration..::..Property> SecurityRights { get; }
Visual Basic
Public ReadOnly Property SecurityRights As UserSecurityRightsProperties(Of WorkgroupConfiguration, WorkgroupConfiguration..::..Property)
    Get

Field Value

The workgroup security rights properties group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


SelectedTone Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..SelectedTone Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the SelectedTone for this workgroup (use Property.SelectedTone).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> SelectedTone { get; }
Visual Basic
Public ReadOnly Property SelectedTone As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the SelectedTone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Skills Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Skills Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the skills for this workgroup (use Property.Skills).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<SkillSettings>> Skills { get; }
Visual Basic
Public ReadOnly Property Skills As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of SkillSettings))
    Get

Field Value

The property representing the skills.

Remarks

  • Owned - To assign or remove a skill on this User, modify the Value of this property. One or more Skills must already be defined to add a Skill in this list.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration.DataTypes..::..SkillSettings
ININ.IceLib.Configuration..::..SkillConfiguration
ININ.IceLib.Configuration..::..SkillConfigurationList


StandardProperties Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..StandardProperties Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<WorkgroupConfiguration, WorkgroupConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of WorkgroupConfiguration, WorkgroupConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


StatisticsShiftStarts Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..StatisticsShiftStarts Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the statistics shift starts for this workgroup (use Property.StatisticsShiftStarts).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> StatisticsShiftStarts { get; }
Visual Basic
Public ReadOnly Property StatisticsShiftStarts As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the statistics shift starts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Supervisors Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Supervisors Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the supervisors for this workgroup (use Property.Supervisors).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<ConfigurationId>> Supervisors { get; }
Visual Basic
Public ReadOnly Property Supervisors As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the supervisors.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


TransactionId Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..TransactionId Property
WorkgroupConfiguration Class See Also Send Feedback
Gets the transaction ID.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TransactionId { get; }
Visual Basic
Public ReadOnly Property TransactionId As Integer
    Get

Remarks

Valid values are obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). Commit()()()() and Delete()()()() operations called on configuration objects that have a valid transaction ID set will cause notifications for watched UserConfiguration objects that would be affected to be suspended until a call to EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is made with the associated transaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


UseRecordingTones Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..UseRecordingTones Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the UseRecordingTones for this workgroup (use Property.UseRecordingTones).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> UseRecordingTones { get; }
Visual Basic
Public ReadOnly Property UseRecordingTones As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the UseRecordingTones.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


UseTiffForFaxes Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..UseTiffForFaxes Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the use tiff for faxes for this workgroup (use Property.UseTiffForFaxes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, bool> UseTiffForFaxes { get; }
Visual Basic
Public ReadOnly Property UseTiffForFaxes As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing use tiff for faxes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


Utilizations Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Utilizations Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the media utilizations for this workgroup (use Property.Utilizations).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<UtilizationSettings>> Utilizations { get; }
Visual Basic
Public ReadOnly Property Utilizations As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of UtilizationSettings))
    Get

Field Value

The property representing the utilizations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration.DataTypes..::..UtilizationSettings


VoicemailMessage Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..VoicemailMessage Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the voicemail message for this workgroup (use Property.VoicemailMessage).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> VoicemailMessage { get; }
Visual Basic
Public ReadOnly Property VoicemailMessage As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the voicemail message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WorkItemServiceLevelDistribution Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..WorkItemServiceLevelDistribution Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the WorkItemServiceLevelDistribution for this workgroup (use Property.WorkItemServiceLevelDistribution).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<TimeSpan>> WorkItemServiceLevelDistribution { get; }
Visual Basic
Public ReadOnly Property WorkItemServiceLevelDistribution As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of TimeSpan))
    Get

Field Value

The property representing the WorkItemServiceLevelDistribution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WorkItemServiceLevelTarget Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..WorkItemServiceLevelTarget Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the WorkItemServiceLevelTarget for this workgroup (use Property.WorkItemServiceLevelTarget).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, TimeSpan> WorkItemServiceLevelTarget { get; }
Visual Basic
Public ReadOnly Property WorkItemServiceLevelTarget As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, TimeSpan)
    Get

Field Value

The property representing the WorkItemServiceLevelTarget.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpCodes Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..WrapUpCodes Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap up codes for this workgroup (use Property.WrapUpCodes).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, Collection<ConfigurationId>> WrapUpCodes { get; }
Visual Basic
Public ReadOnly Property WrapUpCodes As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Field Value

The property representing the wrap up codes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpPrompt Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..WrapUpPrompt Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap up prompt for this workgroup (use Property.WrapUpPrompt).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> WrapUpPrompt { get; }
Visual Basic
Public ReadOnly Property WrapUpPrompt As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the wrap up prompt.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpStatus Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..WrapUpStatus Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap up status for this workgroup (use Property.WrapUpStatus).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, ConfigurationId> WrapUpStatus { get; }
Visual Basic
Public ReadOnly Property WrapUpStatus As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the wrap up status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpTimeout Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..WrapUpTimeout Property
WorkgroupConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap up timeout for this workgroup (use Property.WrapUpTimeout).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, int> WrapUpTimeout { get; }
Visual Basic
Public ReadOnly Property WrapUpTimeout As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, Integer)
    Get

Field Value

The property representing the wrap up timeout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration Class
WorkgroupConfiguration Members
ININ.IceLib.Configuration Namespace


WorkgroupConfiguration.Property Enumeration

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Property Enumeration
WorkgroupConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
CallbackMaxRetry | 1 | Represents the CallbackMaxRetry property.
CallbackSnoozeDuration | 2 | Represents the CallbackSnoozeDuration property.
Extension | 3 | Represents the Extension property.
FaxCapability | 4 | Represents the FaxCapability property.
InteractionDisconnectedAction | 5 | Represents the InteractionDisconnectedAction property.
InteractionMessageStoreMaxMessage | 6 | Obsolete. Represents the InteractionMessageStoreMaxMessage property.
InteractionMessageStoreMaxStorage | 7 | Obsolete. Represents the InteractionMessageStoreMaxStorage property.
InteractionOfferingAction | 8 | Represents the InteractionOfferingAction property.
InteractionOfferingTimeout | 9 | Represents the InteractionOfferingTimeout property.
IsCallbackEnabled | 10 | Represents the IsCallbackEnabled property.
ParkedCallExtension | 11 | Represents the ParkedCallExtension property.
ParkedCallTimeout | 12 | Represents the ParkedCallTimeout property.
ParkedChatExtension | 13 | Represents the ParkedChatExtension property.
ParkedChatTimeout | 14 | Represents the ParkedChatTimeout property.
ParkedEmailExtension | 15 | Represents the ParkedEmailExtension property.
ParkedEmailTimeout | 16 | Represents the ParkedEmailTimeout property.
ParkedGenericObjectExtension | 17 | Represents the ParkedGenericObjectExtension property.
ParkedGenericObjectTimeout | 18 | Represents the ParkedGenericObjectTimeout property.
PreferredLanguage | 19 | Represents the PreferredLanguage property.
Roles | 20 | Represents the Roles property.
RecordingBeepTones | 21 | Obsolete. Represents the RecordingBeepTones property.
UseRecordingTones | 22 | Represents the UseRecordingTones property.
PlayToExternalPartiesOnly | 23 | Represents the PlayToExternalPartiesOnly property.
CaptureInRecordings | 24 | Represents the CaptureInRecordings property.
SelectedTone | 25 | Represents the SelectedTone property.
Skills | 26 | Represents the Skills property.
HasMailbox | 27 | Obsolete. Represents the HasMailbox property.
HasQueue | 28 | Represents the HasQueue property.
QueueType | 29 | Represents the QueueType property.
HasActivation | 30 | Obsolete. Represents the HasActivation property.
IsActive | 31 | Represents the IsActive property.
IsWrapUpActive | 32 | Represents the IsWrapUpActive property.
Supervisors | 33 | Represents the Supervisors property.
MaximumChatReponseTime | 34 | Represents the MaximumChatReponseTime property.
Members | 35 | Represents the Members property.
RecordAll | 36 | Represents the RecordAll property.
MembersSpanSites | 37 | Represents the MembersSpanSites property.
UseTiffForFaxes | 38 | Represents the UseTiffForFaxes property.
CallStatisticsPeriod | 39 | Represents the CallStatisticsPeriod property.
EstimatedCallTimeInterval | 40 | Represents the EstimatedCallTimeInterval property.
StatisticsShiftStarts | 41 | Represents the StatisticsShiftStarts property.
IsAcdEmailRoutingActive | 42 | Represents the IsAcdEmailRoutingActive property.
AcdOfferingAction | 43 | Represents the AcdOfferingAction property.
AcdDisconnectedAction | 44 | Represents the AcdDisconnectedAction property.
AcdTransferAction | 45 | Represents the AcdTransferAction property.
AcdIncomingAction | 46 | Represents the AcdIncomingAction property.
ExecuteTransferActionOnUserTransfer | 47 | Represents the ExecuteTransferActionOnUserTransfer property.
RevertToAvailableTimeout | 48 | Represents the RevertToAvailableTimeout property.
NoAnswerStatus | 49 | Represents the NoAnswerStatus property.
OnCallStatus | 50 | Represents the OnCallStatus property.
IsExemptHeldInteractionsEnabled | 51 | Represents the IsExemptHeldInteractionsEnabled property.
WrapUpStatus | 52 | Represents the WrapUpStatus property.
WrapUpTimeout | 53 | Represents the WrapUpTimeout property.
MaxNumberOfExempt | 54 | Represents the MaxNumberOfExempt property.
GracePeriodBeforeNew | 55 | Represents the GracePeriodBeforeNew property.
AgentScoreChange | 56 | Represents the AgentScoreChange property.
KeypadWaitTimeout | 57 | Represents the KeypadWaitTimeout property.
ClientWaitTimeout | 58 | Represents the ClientWaitTimeout property.
WrapUpPrompt | 59 | Represents the WrapUpPrompt property.
WrapUpCodes | 60 | Represents the WrapUpCodes property.
VoicemailMessage | 61 | Represents the VoicemailMessage property.
AcdSaveRepliesToSentItemsFolder | 62 | Represents the AcdSaveRepliesToSentItemsFolder property.
AcdUseAvailablityTime | 63 | Represents the AcdUseAvailablityTime property.
OperatorTarget | 64 | Represents the OperatorTarget property.
NameSpellingsAsr | 65 | Represents the NameSpellingsAsr property.
NameSpellingTts | 66 | Represents the NameSpellingTts property.
AnalyzerKeywordSets | 67 | Obsolete. Represents the AnalyzerKeywordSets property.
Utilizations | 68 | Represents the Utilizations property.
OnHoldMessage | 69 | Represents the OnHoldMessage property.
OnHoldMusic | 70 | Represents the OnHoldMusic property.
CallServiceLevelTarget | 71 | Represents the CallServiceLevelTarget property.
CallbackServiceLevelTarget | 72 | Represents the CallbackServiceLevelTarget property.
ChatServiceLevelTarget | 73 | Represents the ChatServiceLevelTarget property.
EmailServiceLevelTarget | 74 | Represents the EmailServiceLevelTarget property.
GenericServiceLevelTarget | 75 | Represents the GenericServiceLevelTarget property.
WorkItemServiceLevelTarget | 76 | Represents the WorkItemServiceLevelTarget property.
CallServiceLevelDistribution | 77 | Represents the CallServiceLevelDistribution property.
CallbackServiceLevelDistribution | 78 | Represents the CallbackServiceLevelDistribution property.
ChatServiceLevelDistribution | 79 | Represents the ChatServiceLevelDistribution property.
EmailServiceLevelDistribution | 80 | Represents the EmailServiceLevelDistribution property.
GenericServiceLevelDistribution | 81 | Represents the GenericServiceLevelDistribution property.
WorkItemServiceLevelDistribution | 82 | Represents the WorkItemServiceLevelDistribution property.
SecureInputForms | 83 | Represents the SecureInputForms property.
MonitoredMailboxes | 84 | Represents the MonitoredMailboxes property.
AccessRights_ActivateOthers | 1500 | Represents the ActivateOthers property.
AccessRights_ActivateSelf | 1501 | Represents the ActivateSelf property.
AccessRights_CanEditAccessRights | 1502 | Represents the CanEditAccessRights property.
AccessRights_ChangeUserStatus | 1503 | Represents the ChangeUserStatus property.
AccessRights_ClientButtons | 1504 | Represents the ClientButtons property.
AccessRights_CoachLineQueue | 1505 | Represents the CoachLineQueue property.
AccessRights_CoachStationQueue | 1506 | Represents the CoachStationQueue property.
AccessRights_CoachUserQueue | 1507 | Represents the CoachUserQueue property.
AccessRights_CoachWorkgroupQueue | 1508 | Represents the CoachWorkgroupQueue property.
AccessRights_CreateSchedulingUnitTimeoffRequests | 1509 | Represents the CreateSchedulingUnitTimeoffRequests property.
AccessRights_DeleteSchedulingUnitTimeoffRequests | 1510 | Represents the DeleteSchedulingUnitTimeoffRequests property.
AccessRights_DisconnectUserQueue | 1511 | Represents the DisconnectUserQueue property.
AccessRights_DisconnectLineQueue | 1512 | Represents the DisconnectLineQueue property.
AccessRights_DisconnectStationQueue | 1513 | Represents the DisconnectStationQueue property.
AccessRights_DisconnectWorkgroupQueue | 1514 | Represents the DisconnectWorkgroupQueue property.
AccessRights_EFaqs | 1515 | Represents the EFaqs property.
AccessRights_FollowMePhoneNumberClassifications | 1516 | Represents the FollowMePhoneNumberClassifications property.
AccessRights_ForwardPhoneNumberClassifications | 1517 | Represents the ForwardPhoneNumberClassifications property.
AccessRights_ViewHistoricalReports | 1518 | Represents the ViewHistoricalReports property.
AccessRights_HoldStationQueue | 1519 | Represents the HoldStationQueue property.
AccessRights_HoldUserQueue | 1520 | Represents the HoldUserQueue property.
AccessRights_InteractionConferenceRestrictRooms | 1521 | Represents the InteractionConferenceRestrictRooms property.
AccessRights_JoinLineQueue | 1522 | Represents the JoinLineQueue property.
AccessRights_JoinStationQueue | 1523 | Represents the JoinStationQueue property.
AccessRights_JoinUserQueue | 1524 | Represents the JoinUserQueue property.
AccessRights_JoinWorkgroupQueue | 1525 | Represents the JoinWorkgroupQueue property.
AccessRights_LaunchableProcessList | 1526 | Represents the LaunchableProcessList property.
AccessRights_ListAccountCodes | 1527 | Represents the ListAccountCodes property.
AccessRights_ListenLineQueue | 1528 | Represents the ListenLineQueue property.
AccessRights_ListenStationQueue | 1529 | Represents the ListenStationQueue property.
AccessRights_ListenUserQueue | 1530 | Represents the ListenUserQueue property.
AccessRights_ListenWorkgroupQueue | 1531 | Represents the ListenWorkgroupQueue property.
AccessRights_LoginStation | 1532 | Represents the LoginStation property.
AccessRights_ManageProcessList | 1533 | Represents the ManageProcessList property.
AccessRights_Miscellaneous | 1534 | Represents the Miscellaneous property.
AccessRights_ModifyAttendantEmailProfiles | 1535 | Represents the ModifyAttendantEmailProfiles property.
AccessRights_ModifyAttendantInboundProfiles | 1536 | Represents the ModifyAttendantInboundProfiles property.
AccessRights_ModifyAttendantOperatorProfiles | 1537 | Represents the ModifyAttendantOperatorProfiles property.
AccessRights_ModifyAttendantOutboundProfiles | 1538 | Represents the ModifyAttendantOutboundProfiles property.
AccessRights_ModifyFeedbackSurveys | 1539 | Represents the ModifyFeedbackSurveys property.
AccessRights_ModifyRecorderQuestionnaires | 1540 | Represents the ModifyRecorderQuestionnaires property.
AccessRights_MuteStationQueue | 1541 | Represents the MuteStationQueue property.
AccessRights_MuteUserQueue | 1542 | Represents the MuteUserQueue property.
AccessRights_ModifyCampaignsAgentlessCallingMode | 1543 | Obsolete. Represents the ModifyCampaignsAgentlessCallingMode property.
AccessRights_ModifyCampaignsAutomaticTimezoneMapping | 1544 | Obsolete. Represents the ModifyCampaignsAutomaticTimezoneMapping property.
AccessRights_ModifyCampaignsLineSettings | 1545 | Obsolete. Represents the ModifyCampaignsLineSettings property.
AccessRights_ModifyCampaignList | 1546 | Represents the ModifyCampaignList property.
AccessRights_ModifyCampaignsMaxLinesPerCampaign | 1547 | Obsolete. Represents the ModifyCampaignsMaxLinesPerCampaign property.
AccessRights_ModifyCampaignStatus | 1548 | Obsolete. Represents the ModifyCampaignStatus property.
AccessRights_ModifyPolicySetsBehaviorTypeCustomHandler | 1549 | Obsolete. Represents the ModifyPolicySetsBehaviorTypeCustomHandler property.
AccessRights_ModifyPolicySetsBehaviorTypeEventLog | 1550 | Obsolete. Represents the ModifyPolicySetsBehaviorTypeEventLog property.
AccessRights_ModifySchedulingUnitTimeoffRequests | 1551 | Represents the ModifySchedulingUnitTimeoffRequests property.
AccessRights_ModifyRuleSetsCustomHandler | 1552 | Obsolete. Represents the ModifyRuleSetsCustomHandler property.
AccessRights_ModifyRuleSetsEventLog | 1553 | Obsolete. Represents the ModifyRuleSetsEventLog property.
AccessRights_PhoneNumberClassifications | 1554 | Represents the PhoneNumberClassifications property.
AccessRights_PickupLineQueue | 1555 | Represents the PickupLineQueue property.
AccessRights_PickupStationQueue | 1556 | Represents the PickupStationQueue property.
AccessRights_PickupUserQueue | 1557 | Represents the PickupUserQueue property.
AccessRights_PickupWorkgroupQueue | 1558 | Represents the PickupWorkgroupQueue property.
AccessRights_PreviewEmailUserQueue | 1559 | Represents the PreviewEmailUserQueue property.
AccessRights_PreviewEmailWorkgroupQueue | 1560 | Represents the PreviewEmailWorkgroupQueue property.
AccessRights_InteractionClientPlugins | 1561 | Represents the InteractionClientPlugins property.
AccessRights_RecordLineQueue | 1562 | Represents the RecordLineQueue property.
AccessRights_RecordStationQueue | 1563 | Represents the RecordStationQueue property.
AccessRights_RecordUserQueue | 1564 | Represents the RecordUserQueue property.
AccessRights_RecordWorkgroupQueue | 1565 | Represents the RecordWorkgroupQueue property.
AccessRights_ResponseManagementDocuments | 1566 | Represents the ResponseManagementDocuments property.
AccessRights_StatusMessages | 1567 | Represents the StatusMessages property.
AccessRights_SubstituteQueueControlColumns | 1568 | Represents the SubstituteQueueControlColumns property.
AccessRights_TransferLineQueue | 1569 | Represents the TransferLineQueue property.
AccessRights_TransferStationQueue | 1570 | Represents the TransferStationQueue property.
AccessRights_TransferUserQueue | 1571 | Represents the TransferUserQueue property.
AccessRights_TransferWorkgroupQueue | 1572 | Represents the TransferWorkgroupQueue property.
AccessRights_TuiPhoneNumberClassifications | 1573 | Represents the TuiPhoneNumberClassifications property.
AccessRights_ViewAttendantEmailProfileInSearch | 1574 | Represents the ViewAttendantEmailProfileInSearch property.
AccessRights_ViewAttendantEmailProfiles | 1575 | Represents the ViewAttendantEmailProfiles property.
AccessRights_ViewAttendantInboundProfileInSearch | 1576 | Represents the ViewAttendantInboundProfileInSearch property.
AccessRights_ViewAttendantInboundProfiles | 1577 | Represents the ViewAttendantInboundProfiles property.
AccessRights_ViewAttendantOperatorProfileInSearch | 1578 | Represents the ViewAttendantOperatorProfileInSearch property.
AccessRights_ViewAttendantOperatorProfiles | 1579 | Represents the ViewAttendantOperatorProfiles property.
AccessRights_ViewAttendantOutboundProfileInSearch | 1580 | Represents the ViewAttendantOutboundProfileInSearch property.
AccessRights_ViewAttendantOutboundProfiles | 1581 | Represents the ViewAttendantOutboundProfiles property.
AccessRights_ViewFeedbackSurveys | 1582 | Represents the ViewFeedbackSurveys property.
AccessRights_ViewCampaignsAgentlessCallingMode | 1583 | Obsolete. Represents the ViewCampaignsAgentlessCallingMode property.
AccessRights_ViewCampaignsAutomaticTimezoneMapping | 1584 | Obsolete. Represents the ViewCampaignsAutomaticTimezoneMapping property.
AccessRights_ViewCampaignsLineSettings | 1585 | Obsolete. Represents the ViewCampaignsLineSettings property.
AccessRights_ViewCampaignList | 1586 | Represents the ViewCampaignList property.
AccessRights_ViewCampaignsMaxLinesPerCampaign | 1587 | Obsolete. Represents the ViewCampaignsMaxLinesPerCampaign property.
AccessRights_ViewCampaignStatus | 1588 | Obsolete. Represents the ViewCampaignStatus property.
AccessRights_ViewGeneralDirectories | 1589 | Represents the ViewGeneralDirectories property.
AccessRights_ViewIndividualStatistics | 1590 | Represents the ViewIndividualStatistics property.
AccessRights_ViewLayoutList | 1591 | Represents the ViewLayoutList property.
AccessRights_ViewLineQueue | 1592 | Represents the ViewLineQueue property.
AccessRights_ViewModifyOptimizerAll | 1593 | Represents the ViewModifyOptimizerAll property.
AccessRights_ViewOptimizerSchedulingUnits | 1594 | Obsolete. Represents the ViewOptimizerSchedulingUnits property.
AccessRights_ViewOptimizerForecasts | 1595 | Represents the ViewOptimizerForecasts property.
AccessRights_ModifyOptimizerForecasts | 1596 | Represents the ModifyOptimizerForecasts property.
AccessRights_CreateOptimizerForecasts | 1597 | Represents the CreateOptimizerForecasts property.
AccessRights_DeleteOptimizerForecasts | 1598 | Represents the DeleteOptimizerForecasts property.
AccessRights_ViewPolicySetsBehaviorTypeCustomHandler | 1599 | Obsolete. Represents the ViewPolicySetsBehaviorTypeCustomHandler property.
AccessRights_ViewPolicySetsBehaviorTypeEventLog | 1600 | Obsolete. Represents the ViewPolicySetsBehaviorTypeEventLog property.
AccessRights_ViewPositionsList | 1601 | Represents the ViewPositionsList property.
AccessRights_ViewSchedulingUnitIntradayMonitoring | 1602 | Represents the ViewSchedulingUnitIntradayMonitoring property.
AccessRights_ViewSchedulingUnitSchedulePreferences | 1603 | Represents the ViewSchedulingUnitSchedulePreferences property.
AccessRights_ViewSchedulingUnitListRealTimeAdherence | 1604 | Represents the ViewSchedulingUnitListRealTimeAdherence property.
AccessRights_ViewSchedulingUnitTimeoffRequests | 1605 | Represents the ViewSchedulingUnitTimeoffRequests property.
AccessRights_ModifySchedulingUnitListRealTimeAdherence | 1606 | Represents the ModifySchedulingUnitListRealTimeAdherence property.
AccessRights_ViewSchedulingUnitConfiguration | 1607 | Represents the ViewSchedulingUnitConfiguration property.
AccessRights_ModifySchedulingUnitConfiguration | 1608 | Represents the ModifySchedulingUnitConfiguration property.
AccessRights_ViewSchedulingUnitAgentConstraints | 1609 | Represents the ViewSchedulingUnitAgentConstraints property.
AccessRights_ModifySchedulingUnitAgentConstraints | 1610 | Represents the ModifySchedulingUnitAgentConstraints property.
AccessRights_CreateSchedulingUnitAgentConstraints | 1611 | Represents the CreateSchedulingUnitAgentConstraints property.
AccessRights_DeleteSchedulingUnitAgentConstraints | 1612 | Represents the DeleteSchedulingUnitAgentConstraints property.
AccessRights_ViewSchedulingUnitAgentGroups | 1613 | Represents the ViewSchedulingUnitAgentGroups property.
AccessRights_ModifySchedulingUnitAgentGroups | 1614 | Represents the ModifySchedulingUnitAgentGroups property.
AccessRights_CreateSchedulingUnitAgentGroups | 1615 | Represents the CreateSchedulingUnitAgentGroups property.
AccessRights_DeleteSchedulingUnitAgentGroups | 1616 | Represents the DeleteSchedulingUnitAgentGroups property.
AccessRights_ViewSchedulingUnitSchedules | 1617 | Represents the ViewSchedulingUnitSchedules property.
AccessRights_ModifySchedulingUnitSchedules | 1618 | Represents the ModifySchedulingUnitSchedules property.
AccessRights_CreateSchedulingUnitSchedules | 1619 | Represents the CreateSchedulingUnitSchedules property.
AccessRights_DeleteSchedulingUnitSchedules | 1620 | Represents the DeleteSchedulingUnitSchedules property.
AccessRights_ViewSchedulingUnitShiftRotations | 1621 | Represents the ViewSchedulingUnitShiftRotations property.
AccessRights_ModifySchedulingUnitShiftRotations | 1622 | Represents the ModifySchedulingUnitShiftRotations property.
AccessRights_CreateSchedulingUnitShiftRotations | 1623 | Represents the CreateSchedulingUnitShiftRotations property.
AccessRights_DeleteSchedulingUnitShiftRotations | 1624 | Represents the DeleteSchedulingUnitShiftRotations property.
AccessRights_ViewSchedulingUnitShifts | 1625 | Represents the ViewSchedulingUnitShifts property.
AccessRights_ModifySchedulingUnitShifts | 1626 | Represents the ModifySchedulingUnitShifts property.
AccessRights_CreateSchedulingUnitShifts | 1627 | Represents the CreateSchedulingUnitShifts property.
AccessRights_DeleteSchedulingUnitShifts | 1628 | Represents the DeleteSchedulingUnitShifts property.
AccessRights_ViewProcessList | 1629 | Represents the ViewProcessList property.
AccessRights_ViewQueueControlColumns | 1630 | Represents the ViewQueueControlColumns property.
AccessRights_ViewRecorderQuestionnaires | 1631 | Represents the ViewRecorderQuestionnaires property.
AccessRights_ViewReport | 1632 | Represents the ViewReport property.
AccessRights_ViewRuleSetsCustomHandler | 1633 | Obsolete. Represents the ViewRuleSetsCustomHandler property.
AccessRights_ViewRuleSetsEventLog | 1634 | Obsolete. Represents the ViewRuleSetsEventLog property.
AccessRights_ViewSkillList | 1635 | Represents the ViewSkillList property.
AccessRights_ViewStationGroups | 1636 | Represents the ViewStationGroups property.
AccessRights_ViewStationGroupsInSearch | 1637 | Represents the ViewStationGroupsInSearch property.
AccessRights_ViewStationQueue | 1638 | Represents the ViewStationQueue property.
AccessRights_ViewStationQueueInSearch | 1639 | Represents the ViewStationQueueInSearch property.
AccessRights_ViewStatusColumns | 1640 | Represents the ViewStatusColumns property.
AccessRights_ViewUserInteractionHistory | 1641 | Represents the ViewUserInteractionHistory property.
AccessRights_ViewUserQueue | 1642 | Represents the ViewUserQueue property.
AccessRights_ViewWorkgroup | 1643 | Represents the ViewWorkgroup property.
AccessRights_ViewWorkgroupQueue | 1644 | Represents the ViewWorkgroupQueue property.
AccessRights_ViewWorkgroupQueueInSearch | 1645 | Represents the ViewWorkgroupQueueInSearch property.
AccessRights_ViewWorkgroupStatistics | 1646 | Represents the ViewWorkgroupStatistics property.
AccessRights_ViewDataSource | 1647 | Represents the ViewDataSource property.
AccessRights_OptimizerViewShiftTrading | 1648 | Represents the OptimizerViewShiftTrading property.
AccessRights_OptimizerModifyShiftTrading | 1649 | Represents the OptimizerModifyShiftTrading property.
AccessRights_SnipLineQueue | 1650 | Represents the SnipLineQueue property.
AccessRights_SnipStationQueue | 1651 | Represents the SnipStationQueue property.
AccessRights_SnipUserQueue | 1652 | Represents the SnipUserQueue property.
AccessRights_SnipWorkgroupQueue | 1653 | Represents the SnipWorkgroupQueue property.
AdministrativeRights_AccountCodeList | 2000 | Represents the AccountCodeList property.
AdministrativeRights_AccumulatorList | 2001 | Represents the AccumulatorList property.
AdministrativeRights_Actions | 2002 | Represents the Actions property.
AdministrativeRights_AudioSources | 2003 | Represents the AudioSources property.
AdministrativeRights_CanEditAdministrativeRights | 2004 | Represents the CanEditAdministrativeRights property.
AdministrativeRights_ClientButtons | 2005 | Represents the ClientButtons property.
AdministrativeRights_ClientConfigurationConfiguration | 2006 | Represents the ClientConfigurationConfiguration property.
AdministrativeRights_ClientConfigurationTemplates | 2007 | Represents the ClientConfigurationTemplates property.
AdministrativeRights_Collective | 2008 | Represents the Collective property.
AdministrativeRights_ContactListSources | 2009 | Represents the ContactListSources property.
AdministrativeRights_DataManagerConfiguration | 2010 | Represents the DataManagerConfiguration property.
AdministrativeRights_DefaultIPPhoneConfiguration | 2011 | Represents the DefaultIPPhoneConfiguration property.
AdministrativeRights_DefaultLocationConfiguration | 2012 | Represents the DefaultLocationConfiguration property.
AdministrativeRights_DefaultStationConfiguration | 2013 | Represents the DefaultStationConfiguration property.
AdministrativeRights_DefaultUserConfiguration | 2014 | Represents the DefaultUserConfiguration property.
AdministrativeRights_DnisMappingsConfiguration | 2015 | Represents the DnisMappingsConfiguration property.
AdministrativeRights_EFaq | 2016 | Represents the EFaq property.
AdministrativeRights_FaxConfiguration | 2017 | Represents the FaxConfiguration property.
AdministrativeRights_FaxGroups | 2018 | Represents the FaxGroups property.
AdministrativeRights_Handlers | 2019 | Represents the Handlers property.
AdministrativeRights_ICDataSources | 2020 | Represents the ICDataSources property.
AdministrativeRights_ImageResources | 2021 | Represents the ImageResources property.
AdministrativeRights_InitializationFunctions | 2022 | Represents the InitializationFunctions property.
AdministrativeRights_InteractionAnalyzerKeywordSets | 2023 | Represents the InteractionAnalyzerKeywordSets property.
AdministrativeRights_InteractionConferenceConfiguration | 2024 | Represents the InteractionConferenceConfiguration property.
AdministrativeRights_InteractionConferenceRooms | 2025 | Represents the InteractionConferenceRooms property.
AdministrativeRights_InteractionDialerCallLists | 2026 | Represents the InteractionDialerCallLists property.
AdministrativeRights_InteractionDialerCampaigns | 2027 | Represents the InteractionDialerCampaigns property.
AdministrativeRights_InteractionDialerConfiguration | 2028 | Represents the InteractionDialerConfiguration property.
AdministrativeRights_InteractionDialerPolicySets | 2029 | Represents the InteractionDialerPolicySets property.
AdministrativeRights_InteractionDialerRuleSets | 2030 | Represents the InteractionDialerRuleSets property.
AdministrativeRights_InteractionDialerSchedules | 2031 | Represents the InteractionDialerSchedules property.
AdministrativeRights_InteractionDialerScripts | 2032 | Represents the InteractionDialerScripts property.
AdministrativeRights_InteractionDialerSkillSets | 2033 | Represents the InteractionDialerSkillSets property.
AdministrativeRights_InteractionDialerStageSets | 2034 | Represents the InteractionDialerStageSets property.
AdministrativeRights_InteractionDialerZoneSets | 2035 | Represents the InteractionDialerZoneSets property.
AdministrativeRights_InteractionFeedbackConfiguration | 2036 | Represents the InteractionFeedbackConfiguration property.
AdministrativeRights_InteractionOptimizerActivityTypesConfiguration | 2037 | Obsolete. Represents the InteractionOptimizerActivityTypesConfiguration property.
AdministrativeRights_InteractionOptimizerAdvancedConfiguration | 2038 | Represents the InteractionOptimizerAdvancedConfiguration property.
AdministrativeRights_InteractionOptimizerAgentsConfiguration | 2039 | Represents the InteractionOptimizerAgentsConfiguration property.
AdministrativeRights_InteractionOptimizerDayClassificationsConfiguration | 2040 | Obsolete. Represents the InteractionOptimizerDayClassificationsConfiguration property.
AdministrativeRights_InteractionOptimizerForecastsAndSchedulesConfiguration | 2041 | Obsolete. Represents the InteractionOptimizerForecastsAndSchedulesConfiguration property.
AdministrativeRights_InteractionOptimizerSchedulingUnits | 2042 | Obsolete. Represents the InteractionOptimizerSchedulingUnits property.
AdministrativeRights_InteractionProcessAutomation | 2043 | Represents the InteractionProcessAutomation property.
AdministrativeRights_InteractionProcessorTables | 2044 | Represents the InteractionProcessorTables property.
AdministrativeRights_InteractionRecorderConfiguration | 2045 | Represents the InteractionRecorderConfiguration property.
AdministrativeRights_InteractionTrackerConfiguration | 2046 | Represents the InteractionTrackerConfiguration property.
AdministrativeRights_IPPhoneRegistrationGroups | 2047 | Represents the IPPhoneRegistrationGroups property.
AdministrativeRights_IPPhoneRingSets | 2048 | Represents the IPPhoneRingSets property.
AdministrativeRights_IPPhones | 2049 | Represents the IPPhones property.
AdministrativeRights_IPPhoneTemplates | 2050 | Represents the IPPhoneTemplates property.
AdministrativeRights_Layouts | 2051 | Represents the Layouts property.
AdministrativeRights_LicensesAllocationConfiguration | 2052 | Represents the LicensesAllocationConfiguration property.
AdministrativeRights_LineGroups | 2053 | Represents the LineGroups property.
AdministrativeRights_Lines | 2054 | Represents the Lines property.
AdministrativeRights_Locations | 2055 | Represents the Locations property.
AdministrativeRights_LogRetrievalAssistantConfiguration | 2056 | Represents the LogRetrievalAssistantConfiguration property.
AdministrativeRights_MailConfiguration | 2057 | Represents the MailConfiguration property.
AdministrativeRights_MasterAdministrator | 2058 | Represents the MasterAdministrator property.
AdministrativeRights_MediaServersConfiguration | 2059 | Represents the MediaServersConfiguration property.
AdministrativeRights_MrcpConfiguration | 2060 | Represents the MrcpConfiguration property.
AdministrativeRights_OcsActiveDirectories | 2061 | Represents the OcsActiveDirectories property.
AdministrativeRights_OcsConfiguration | 2062 | Represents the OcsConfiguration property.
AdministrativeRights_OcsStatusMessages | 2063 | Represents the OcsStatusMessages property.
AdministrativeRights_PagingCarriers | 2064 | Represents the PagingCarriers property.
AdministrativeRights_PasswordPolicies | 2065 | Represents the PasswordPolicies property.
AdministrativeRights_PasswordPoliciesConfiguration | 2066 | Represents the PasswordPoliciesConfiguration property.
AdministrativeRights_PeerSitesConfiguration | 2067 | Represents the PeerSitesConfiguration property.
AdministrativeRights_PhoneNumbersConfiguration | 2068 | Represents the PhoneNumbersConfiguration property.
AdministrativeRights_Positions | 2069 | Represents the Positions property.
AdministrativeRights_ProblemReporterConfiguration | 2070 | Represents the ProblemReporterConfiguration property.
AdministrativeRights_QueueControlColumns | 2071 | Represents the QueueControlColumns property.
AdministrativeRights_ReportLogs | 2072 | Represents the ReportLogs property.
AdministrativeRights_Reports | 2073 | Represents the Reports property.
AdministrativeRights_ResponseManagement | 2074 | Represents the ResponseManagement property.
AdministrativeRights_Roles | 2075 | Represents the Roles property.
AdministrativeRights_SalesforceCtis | 2076 | Obsolete. Represents the SalesforceCtis property.
AdministrativeRights_SametimeConfiguration | 2077 | Represents the SametimeConfiguration property.
AdministrativeRights_Schedules | 2078 | Represents the Schedules property.
AdministrativeRights_SelectionRuleList | 2079 | Represents the SelectionRuleList property.
AdministrativeRights_SecureInputForms | 2080 | Represents the SecureInputForms property.
AdministrativeRights_ServerParameter | 2081 | Represents the ServerParameter property.
AdministrativeRights_ServersConfiguration | 2082 | Represents the ServersConfiguration property.
AdministrativeRights_SessionManagerServerConfiguration | 2083 | Represents the SessionManagerServerConfiguration property.
AdministrativeRights_SingleSignOnIdentityProviders | 2106 | Represents the SingleSignOnIdentityProviders property.
AdministrativeRights_SingleSignOnSecureTokenServer | 2107 | Represents the SingleSignOnSecureTokenServer property.
AdministrativeRights_SipBridge | 2084 | Represents the SipBridge property.
AdministrativeRights_SipProxyConfiguration | 2085 | Represents the SipProxyConfiguration property.
AdministrativeRights_Skills | 2086 | Represents the Skills property.
AdministrativeRights_SmsBroker | 2087 | Represents the SmsBroker property.
AdministrativeRights_SmsConfiguration | 2088 | Represents the SmsConfiguration property.
AdministrativeRights_SpeechRecognitionConfiguration | 2089 | Represents the SpeechRecognitionConfiguration property.
AdministrativeRights_StationGroups | 2090 | Represents the StationGroups property.
AdministrativeRights_Stations | 2091 | Represents the Stations property.
AdministrativeRights_StationTemplates | 2092 | Represents the StationTemplates property.
AdministrativeRights_StatusMessages | 2093 | Represents the StatusMessages property.
AdministrativeRights_StreamingAudioMonitorProfiles | 2108 | Represents the StreamingAudioMonitorProfiles property.
AdministrativeRights_StructuredParameters | 2094 | Represents the StructuredParameters property.
AdministrativeRights_SystemConfiguration | 2095 | Represents the SystemConfiguration property.
AdministrativeRights_SystemParameters | 2096 | Represents the SystemParameters property.
AdministrativeRights_Users | 2097 | Represents the Users property.
AdministrativeRights_VoiceModules | 2098 | Represents the VoiceModules property.
AdministrativeRights_WebServicesParameters | 2099 | Represents the WebServicesParameters property.
AdministrativeRights_Workgroups | 2100 | Represents the Workgroups property.
AdministrativeRights_WrapUpCodes | 2101 | Represents the WrapUpCodes property.
AdministrativeRights_WrapUpCategories | 2102 | Represents the WrapUpCategories property.
AdministrativeRights_CanPublishClientTemplates | 2103 | Represents the CanPublishClientTemplates property.
AdministrativeRights_MrcpServerList | 2104 | Represents the MrcpServerList property.
AdministrativeRights_WebServicesConfiguration | 2105 | Represents the WebServicesConfiguration property.
SecurityRights_AccessAllInteractionConferences | 1000 | Represents the AccessAllInteractionConferences property.
SecurityRights_AccessOwnedInteractionConferences | 1001 | Represents the AccessOwnedInteractionConferences property.
SecurityRights_AccountCodeVerification | 1002 | Represents the AccountCodeVerification property.
SecurityRights_AddIndividuals | 1003 | Represents the AddIndividuals property.
SecurityRights_AddOrganizations | 1004 | Represents the AddOrganizations property.
SecurityRights_AgentPreferences | 1005 | Represents the AgentPreferences property.
SecurityRights_AllowAccessToProblemReporter | 1006 | Represents the AllowAccessToProblemReporter property.
SecurityRights_AlertAdministrator | 1007 | Represents the AlertAdministrator property.
SecurityRights_AllowAgentRules | 1008 | Represents the AllowAgentRules property.
SecurityRights_AllowAgentScheduleBidding | 1009 | Represents the AllowAgentScheduleBidding property.
SecurityRights_AllowAgentSeeRelativeRank | 1010 | Represents the AllowAgentSeeRelativeRank property.
SecurityRights_AllowAgentSeeOwnRank | 1011 | Represents the AllowAgentSeeOwnRank property.
SecurityRights_AllowEmailAccessViaTui | 1012 | Represents the AllowEmailAccessViaTui property.
SecurityRights_AllowEmailAlerts | 1013 | Represents the AllowEmailAlerts property.
SecurityRights_AllowFaxAccessViaTui | 1014 | Represents the AllowFaxAccessViaTui property.
SecurityRights_AllowHandlerAlerts | 1015 | Represents the AllowHandlerAlerts property.
SecurityRights_AllowIntercomChat | 1016 | Represents the AllowIntercomChat property.
SecurityRights_AllowMiniMode | 1017 | Represents the AllowMiniMode property.
SecurityRights_AllowMemoAlerts | 1018 | Represents the AllowMemoAlerts property.
SecurityRights_AllowMonitorColumns | 1019 | Represents the AllowMonitorColumns property.
SecurityRights_AllowMultipleCalls | 1020 | Represents the AllowMultipleCalls property.
SecurityRights_AllowPersistentConnections | 1021 | Represents the AllowPersistentConnections property.
SecurityRights_AllowReceiveVoicemail | 1022 | Represents the AllowReceiveVoicemail property.
SecurityRights_AllowRelatedInteractionsPage | 1023 | Represents the AllowRelatedInteractionsPage property.
SecurityRights_AllowResponseManagement | 1024 | Represents the AllowResponseManagement property.
SecurityRights_AllowSpeedDials | 1025 | Represents the AllowSpeedDials property.
SecurityRights_AllowStatusNotes | 1026 | Represents the AllowStatusNotes property.
SecurityRights_AllowUserDefinedTelephoneNumberOnRemoteLogin | 1027 | Represents the AllowUserDefinedTelephoneNumberOnRemoteLogin property.
SecurityRights_AllowVideo | 1028 | Represents the AllowVideo property.
SecurityRights_AllowVoiceMaiAccessViaTui | 1029 | Represents the AllowVoiceMaiAccessViaTui property.
SecurityRights_AllowAlertProgramming | 1030 | Represents the AllowAlertProgramming property.
SecurityRights_AllowWorkgroupStats | 1031 | Represents the AllowWorkgroupStats property.
SecurityRights_CanCoachInteractions | 1032 | Represents the CanCoachInteractions property.
SecurityRights_CanConferenceCalls | 1033 | Represents the CanConferenceCalls property.
SecurityRights_CanCreateAlertSets | 1034 | Represents the CanCreateAlertSets property.
SecurityRights_CanShareAlertSets | 1035 | Represents the CanShareAlertSets property.
SecurityRights_CanCreateOptimizerActivityCodes | 1036 | Represents the CanCreateOptimizerActivityCodes property.
SecurityRights_CanCreateQuestionnaireDirectories | 1037 | Represents the CanCreateQuestionnaireDirectories property.
SecurityRights_CanDeleteOptimizerActivityCodes | 1038 | Represents the CanDeleteOptimizerActivityCodes property.
SecurityRights_CanDisconnectInteractions | 1039 | Represents the CanDisconnectInteractions property.
SecurityRights_CanInitiateSecureInput | 1040 | Represents the CanInitiateSecureInput property.
SecurityRights_CanForceSubscribeAlertSets | 1041 | Represents the CanForceSubscribeAlertSets property.
SecurityRights_CanJoinInteractions | 1042 | Represents the CanJoinInteractions property.
SecurityRights_CanListenInOnInteractions | 1043 | Represents the CanListenInOnInteractions property.
SecurityRights_CanManageClientTemplates | 1044 | Represents the CanManageClientTemplates property.
SecurityRights_CanModifyOptimizerActivityCodes | 1045 | Represents the CanModifyOptimizerActivityCodes property.
SecurityRights_CanModifyOptimizerStatusActivityTypeMapping | 1046 | Represents the CanModifyOptimizerStatusActivityTypeMapping property.
SecurityRights_CanMuteInteractions | 1047 | Represents the CanMuteInteractions property.
SecurityRights_CanOrbitQueue | 1048 | Represents the CanOrbitQueue property.
SecurityRights_CanOverrideFinishedScorecards | 1049 | Represents the CanOverrideFinishedScorecards property.
SecurityRights_CanParkInteractions | 1050 | Represents the CanParkInteractions property.
SecurityRights_CanPauseInteractions | 1051 | Represents the CanPauseInteractions property.
SecurityRights_CanPickupInteractions | 1052 | Represents the CanPickupInteractions property.
SecurityRights_CanPutInteractionsOnHold | 1053 | Represents the CanPutInteractionsOnHold property.
SecurityRights_CanRecordInteractions | 1054 | Represents the CanRecordInteractions property.
SecurityRights_CanRequestAssistanceFromSupervisor | 1055 | Represents the CanRequestAssistanceFromSupervisor property.
SecurityRights_CanSecureRecordingPauseInteractions | 1056 | Represents the CanSecureRecordingPauseInteractions property.
SecurityRights_CanTransferInteractions | 1057 | Represents the CanTransferInteractions property.
SecurityRights_CanTransferInteractionsToVoicemail | 1058 | Represents the CanTransferInteractionsToVoicemail property.
SecurityRights_CanUserInteractionRecorderSelector | 1059 | Represents the CanUserInteractionRecorderSelector property.
SecurityRights_CanViewOptimizerActivityCodes | 1060 | Represents the CanViewOptimizerActivityCodes property.
SecurityRights_CanViewOptimizerStatusActivityTypeMapping | 1061 | Represents the CanViewOptimizerStatusActivityTypeMapping property.
SecurityRights_CustomizeClient | 1062 | Represents the CustomizeClient property.
SecurityRights_DebugHandlers | 1063 | Represents the DebugHandlers property.
SecurityRights_DeleteIndividuals | 1064 | Represents the DeleteIndividuals property.
SecurityRights_DeleteOrganizations | 1065 | Represents the DeleteOrganizations property.
SecurityRights_DirectoryAdmin | 1066 | Represents the DirectoryAdmin property.
SecurityRights_ExecuteLongRunningQueries | 1067 | Obsolete. Represents the ExecuteLongRunningQueries property.
SecurityRights_FollowMe | 1068 | Represents the FollowMe property.
SecurityRights_HavePrivateContacts | 1069 | Represents the HavePrivateContacts property.
SecurityRights_IPPhoneProvisioningAdmin | 1070 | Represents the IPPhoneProvisioningAdmin property.
SecurityRights_LockPolicySets | 1071 | Represents the LockPolicySets property.
SecurityRights_LoginCampaign | 1072 | Represents the LoginCampaign property.
SecurityRights_ManageHandlers | 1073 | Represents the ManageHandlers property.
SecurityRights_MobileOfficeUser | 1074 | Represents the MobileOfficeUser property.
SecurityRights_ModifyConfigurationChangeAuditing | 1075 | Represents the ModifyConfigurationChangeAuditing property.
SecurityRights_ModifyConfigurationGeneral | 1076 | Represents the ModifyConfigurationGeneral property.
SecurityRights_ModifyConfigurationHTTPServer | 1077 | Represents the ModifyConfigurationHTTPServer property.
SecurityRights_ModifyConfigurationOutboundServers | 1078 | Represents the ModifyConfigurationOutboundServers property.
SecurityRights_ModifyConfigurationPhoneNumberTypes | 1079 | Represents the ModifyConfigurationPhoneNumberTypes property.
SecurityRights_ModifyConfigurationPreviewCallBehavior | 1080 | Represents the ModifyConfigurationPreviewCallBehavior property.
SecurityRights_ModifyIndividuals | 1081 | Represents the ModifyIndividuals property.
SecurityRights_ModifyInteractions | 1082 | Represents the ModifyInteractions property.
SecurityRights_ModifyOrganizations | 1083 | Represents the ModifyOrganizations property.
SecurityRights_OutlookTuiUser | 1084 | Represents the OutlookTuiUser property.
SecurityRights_PrivateCalls | 1085 | Represents the PrivateCalls property.
SecurityRights_PublishHandlers | 1086 | Represents the PublishHandlers property.
SecurityRights_RemoteControl | 1087 | Represents the RemoteControl property.
SecurityRights_ReporterAdministrator | 1088 | Represents the ReporterAdministrator property.
SecurityRights_RequireForcedAuthorizationCode | 1089 | Represents the RequireForcedAuthorizationCode property.
SecurityRights_ShowAssistanceButton | 1090 | Represents the ShowAssistanceButton property.
SecurityRights_ShowCoachButton | 1091 | Represents the ShowCoachButton property.
SecurityRights_ShowDisconnectButton | 1092 | Represents the ShowDisconnectButton property.
SecurityRights_ShowHoldButton | 1093 | Represents the ShowHoldButton property.
SecurityRights_ShowJoinButton | 1094 | Represents the ShowJoinButton property.
SecurityRights_ShowListenButton | 1095 | Represents the ShowListenButton property.
SecurityRights_ShowMuteButton | 1096 | Represents the ShowMuteButton property.
SecurityRights_ShowParkButton | 1097 | Represents the ShowParkButton property.
SecurityRights_ShowPauseButton | 1098 | Represents the ShowPauseButton property.
SecurityRights_ShowPickupButton | 1099 | Represents the ShowPickupButton property.
SecurityRights_ShowPrivateButton | 1100 | Represents the ShowPrivateButton property.
SecurityRights_ShowRecordButton | 1101 | Represents the ShowRecordButton property.
SecurityRights_ShowSecureInputButton | 1102 | Represents the ShowSecureInputButton property.
SecurityRights_ShowSecureRecordingPauseButton | 1103 | Represents the ShowSecureRecordingPauseButton property.
SecurityRights_ShowTransferButton | 1104 | Represents the ShowTransferButton property.
SecurityRights_ShowVoicemailButton | 1105 | Represents the ShowVoicemailButton property.
SecurityRights_ShowWorkgroupsProfilesTab | 1106 | Represents the ShowWorkgroupsProfilesTab property.
SecurityRights_TraceConfiguration | 1107 | Represents the TraceConfiguration property.
SecurityRights_TrackerAdministrator | 1108 | Represents the TrackerAdministrator property.
SecurityRights_UseTiffForFaxes | 1109 | Represents the UseTiffForFaxes property.
SecurityRights_ViewConfigurationChangeAuditing | 1110 | Represents the ViewConfigurationChangeAuditing property.
SecurityRights_ViewConfigurationGeneral | 1111 | Represents the ViewConfigurationGeneral property.
SecurityRights_ViewConfigurationHTTPServer | 1112 | Represents the ViewConfigurationHTTPServer property.
SecurityRights_ViewConfigurationOutboundServers | 1113 | Represents the ViewConfigurationOutboundServers property.
SecurityRights_ViewConfigurationPhoneNumberTypes | 1114 | Represents the ViewConfigurationPhoneNumberTypes property.
SecurityRights_ViewConfigurationPreviewCallBehavior | 1115 | Represents the ViewConfigurationPreviewCallBehavior property.
SecurityRights_ViewInteractionDetails | 1116 | Represents the ViewInteractionDetails property.
SecurityRights_ViewModifyCampaignAgentlessCallingType | 1117 | Represents the ViewModifyCampaignAgentlessCallingType property.
SecurityRights_ViewModifyCampaignAutomaticTimeZoneMapping | 1118 | Represents the ViewModifyCampaignAutomaticTimeZoneMapping property.
SecurityRights_ViewModifyCampaignLineSettings | 1119 | Represents the ViewModifyCampaignLineSettings property.
SecurityRights_ViewModifyCampaignMaxLines | 1120 | Represents the ViewModifyCampaignMaxLines property.
SecurityRights_ViewModifyCampaignStatus | 1121 | Represents the ViewModifyCampaignStatus property.
SecurityRights_ViewModifyContactListDataQuery | 1122 | Represents the ViewModifyContactListDataQuery property.
SecurityRights_ViewModifyCustomHandlerActions | 1123 | Represents the ViewModifyCustomHandlerActions property.
SecurityRights_ViewModifyDatabaseConnections | 1124 | Represents the ViewModifyDatabaseConnections property.
SecurityRights_ViewModifyDncSources | 1125 | Represents the ViewModifyDncSources property.
SecurityRights_ViewModifyEventLog | 1126 | Represents the ViewModifyEventLog property.
SecurityRights_ViewModifyTimeZoneMapData | 1127 | Represents the ViewModifyTimeZoneMapData property.
SecurityRights_ViewOtherPeoplesPrivateInteractions | 1128 | Represents the ViewOtherPeoplesPrivateInteractions property.
SecurityRights_CanDeleteSchedulingUnits | 1129 | Represents the CanDeleteSchedulingUnits property.
SecurityRights_CanCreateSchedulingUnits | 1130 | Represents the CanCreateSchedulingUnits property.
SecurityRights_CanViewOptimizerDayClassifications | 1131 | Represents the CanViewOptimizerDayClassifications property.
SecurityRights_CanModifyOptimizerDayClassifications | 1132 | Represents the CanModifyOptimizerDayClassifications property.
SecurityRights_CanCreateOptimizerDayClassifications | 1133 | Represents the CanCreateOptimizerDayClassifications property.
SecurityRights_CanDeleteOptimizerDayClassifications | 1134 | Represents the CanDeleteOptimizerDayClassifications property.
SecurityRights_CanPublishProcess | 1135 | Represents the CanPublishProcess property.
SecurityRights_CanSubmitTimeOff | 1138 | Represents the CanSubmitTimeOff property.
SecurityRights_CanAccessOptimizerShiftTrading | 1139 | Represents the CanAccessOptimizerShiftTrading property.
SecurityRights_RunContactListPredefinedActions | 1140 | Represents the RunContactListPredefinedActions property.
SecurityRights_CreateModifyCampaignGroup | 1141 | Represents the CreateModifyCampaignGroup property.
SecurityRights_ModifyCampaignGroupSequence | 1142 | Represents the ModifyCampaignGroupSequence property.
SecurityRights_ManualTransitionSequence | 1143 | Represents the ManualTransitionSequence property.
SecurityRights_CanInitiateRecordingSnippet | 1144 | Represents the CanInitiateRecordingSnippet property.
SecurityRights_ShowRecordingSnippetButton | 1145 | Represents the ShowRecordingSnippetButton property.
SecurityRights_ContactListRecordOwnershipControl | 1146 | Represents the ContactListRecordOwnershipControl property.
SecurityRights_ModifyBaseScriptAgentComplianceOverride | 1147 | Represents the ModifyBaseScriptAgentComplianceOverride property.
SecurityRights_AllowAgentComplianceOverride | 1148 | Represents the AllowAgentComplianceOverride property.
SecurityRights_ForceUserLogout | 1149 | Represents the ForceUserLogout property.
SecurityRights_DataExtractorJobAdmin | 1150 | Represents the DataExtractorJobAdmin property.
SecurityRights_CloudWorkforceEngagementAdministrator | 1151 | Represents the CloudWorkforceEngagementAdministrator property.
Mailbox_DisplayName | 7000 | Represents the DisplayName property.
Mailbox_EmailAddress | 7001 | Represents the EmailAddress property.
Mailbox_Type | 7002 | Represents the Type property.
DisplayName | 7003 | Represents the DisplayName part of the ConfigurationId property.
Id | 7004 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

ININ.IceLib.Configuration Namespace


WorkgroupConfiguration.Rights Class

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..WorkgroupConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WorkgroupConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights Members
WorkgroupConfiguration..::..Rights Class Properties See Also Send Feedback

The WorkgroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
ActivateOthers | Gets the activate others rights filter.
ActivateSelf | Gets the activate self rights filter.
Admin | Gets the admin rights filter rights filter.
CoachWorkgroupQueue | Gets the coach workgroup queue rights filter.
DisconnectWorkgroupQueue | Gets the disconnect workgroup queue rights filter.
JoinWorkgroupQueue | Gets the join workgroup queue rights filter.
ListenWorkgroupQueue | Gets the listen workgroup queue rights filter.
PickupWorkgroupQueue | Gets the pickup workgroup queue rights filter.
PreviewEmailWorkgroupQueue | Gets the preview email workgroup queue rights filter.
RecordWorkgroupQueue | Gets the record workgroup queue rights filter.
SnipWorkgroupQueue | Gets the snip workgroup queue rights filter.
TransferWorkgroupQueue | Gets the transfer workgroup queue rights filter.
View | Gets the view rights filter.
ViewWorkgroupQueueInSearch | Gets the view workgroup queue in search rights filter.
ViewWorkgroupQueueList | Gets the view workgroup queue list rights filter.
ViewWorkgroupStatistics | Gets the view workgroup statistics rights filter.

See Also

WorkgroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


WorkgroupConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights Properties
WorkgroupConfiguration..::..Rights Class See Also Send Feedback

The WorkgroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
ActivateOthers | Gets the activate others rights filter.
ActivateSelf | Gets the activate self rights filter.
Admin | Gets the admin rights filter rights filter.
CoachWorkgroupQueue | Gets the coach workgroup queue rights filter.
DisconnectWorkgroupQueue | Gets the disconnect workgroup queue rights filter.
JoinWorkgroupQueue | Gets the join workgroup queue rights filter.
ListenWorkgroupQueue | Gets the listen workgroup queue rights filter.
PickupWorkgroupQueue | Gets the pickup workgroup queue rights filter.
PreviewEmailWorkgroupQueue | Gets the preview email workgroup queue rights filter.
RecordWorkgroupQueue | Gets the record workgroup queue rights filter.
SnipWorkgroupQueue | Gets the snip workgroup queue rights filter.
TransferWorkgroupQueue | Gets the transfer workgroup queue rights filter.
View | Gets the view rights filter.
ViewWorkgroupQueueInSearch | Gets the view workgroup queue in search rights filter.
ViewWorkgroupQueueList | Gets the view workgroup queue list rights filter.
ViewWorkgroupStatistics | Gets the view workgroup statistics rights filter.

See Also

WorkgroupConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


ActivateOthers Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..ActivateOthers Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the activate others rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> ActivateOthers { get; private set; }
Visual Basic
Public Shared Property ActivateOthers As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The activate others rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ActivateOthers


ActivateSelf Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..ActivateSelf Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the activate self rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> ActivateSelf { get; private set; }
Visual Basic
Public Shared Property ActivateSelf As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The activate self rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ActivateSelf


Admin Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..Admin Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The admin rights filter rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Workgroups


CoachWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..CoachWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the coach workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> CoachWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property CoachWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The coach workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..CoachWorkgroupQueue


DisconnectWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..DisconnectWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the disconnect workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> DisconnectWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property DisconnectWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The disconnect workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..DisconnectWorkgroupQueue


JoinWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..JoinWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the join workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> JoinWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property JoinWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The join workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..JoinWorkgroupQueue


ListenWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..ListenWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the listen workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> ListenWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property ListenWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The listen workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ListenWorkgroupQueue


PickupWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..PickupWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the pickup workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> PickupWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property PickupWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The pickup workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PickupWorkgroupQueue


PreviewEmailWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..PreviewEmailWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the preview email workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> PreviewEmailWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property PreviewEmailWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The preview email workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..PreviewEmailWorkgroupQueue


RecordWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..RecordWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the record workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> RecordWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property RecordWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The record workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..RecordWorkgroupQueue


SnipWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..SnipWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the snip workgroup queue rights filter.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> SnipWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property SnipWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The snip workgroup queue rights filter.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SnipWorkgroupQueue


TransferWorkgroupQueue Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..TransferWorkgroupQueue Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the transfer workgroup queue rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> TransferWorkgroupQueue { get; private set; }
Visual Basic
Public Shared Property TransferWorkgroupQueue As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The transfer workgroup queue rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..TransferWorkgroupQueue


View Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..View Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroup


ViewWorkgroupQueueInSearch Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..ViewWorkgroupQueueInSearch Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view workgroup queue in search rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> ViewWorkgroupQueueInSearch { get; private set; }
Visual Basic
Public Shared Property ViewWorkgroupQueueInSearch As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The view workgroup queue in search rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroupQueueInSearch


ViewWorkgroupQueueList Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..ViewWorkgroupQueueList Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view workgroup queue list rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> ViewWorkgroupQueueList { get; private set; }
Visual Basic
Public Shared Property ViewWorkgroupQueueList As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The view workgroup queue list rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroupQueue


ViewWorkgroupStatistics Property

[image]

IceLib Technical Reference
WorkgroupConfiguration..::..Rights..::..ViewWorkgroupStatistics Property
WorkgroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view workgroup statistics rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupConfiguration> ViewWorkgroupStatistics { get; private set; }
Visual Basic
Public Shared Property ViewWorkgroupStatistics As RightsQueryFilter(Of WorkgroupConfiguration)
    Get
    Private Set

Field Value

The view workgroup statistics rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupConfiguration..::..Rights Class
WorkgroupConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewWorkgroupStatistics


WorkgroupConfigurationList Class

[image]

IceLib Technical Reference
WorkgroupConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing workgroup configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupConfigurationList : EditableConfigurationList<WorkgroupConfiguration, WorkgroupConfiguration..::..Property>
Visual Basic
Public Class WorkgroupConfigurationList _
    Inherits EditableConfigurationList(Of WorkgroupConfiguration, WorkgroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' WorkgroupConfiguration, WorkgroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' WorkgroupConfiguration, WorkgroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' WorkgroupConfiguration, WorkgroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WorkgroupConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

WorkgroupConfigurationList Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WorkgroupConfiguration
ININ.IceLib.Configuration..::..WorkgroupMonitoredMailboxConfiguration
ININ.IceLib.Configuration..::..WorkgroupQueryChildrenSettings
ININ.IceLib.Configuration..::..HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>


WorkgroupConfigurationList Members

[image] [image]

IceLib Technical Reference
WorkgroupConfigurationList Members
WorkgroupConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The WorkgroupConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | WorkgroupConfigurationList | Initializes a new instance of the WorkgroupConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateMonitoredMailbox | Creates a new monitored mailbox.
Public method | CreateMonitoredMailboxQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
 | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WorkgroupConfigurationList Class
ININ.IceLib.Configuration Namespace


WorkgroupConfigurationList Constructor

[image]

IceLib Technical Reference
WorkgroupConfigurationList Constructor
WorkgroupConfigurationList Class See Also Send Feedback
Initializes a new instance of the WorkgroupConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

WorkgroupConfigurationList Class
WorkgroupConfigurationList Members
ININ.IceLib.Configuration Namespace


WorkgroupConfigurationList Methods

[image] [image]

IceLib Technical Reference
WorkgroupConfigurationList Methods
WorkgroupConfigurationList Class See Also Send Feedback

The WorkgroupConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateMonitoredMailbox | Creates a new monitored mailbox.
Public method | CreateMonitoredMailboxQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
 | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings.
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupConfigurationList Class
ININ.IceLib.Configuration Namespace


CreateMonitoredMailbox Method

[image]

IceLib Technical Reference
WorkgroupConfigurationList..::..CreateMonitoredMailbox Method
WorkgroupConfigurationList Class See Also Send Feedback
Creates a new monitored mailbox.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupMonitoredMailboxConfiguration CreateMonitoredMailbox()
Visual Basic
Public Function CreateMonitoredMailbox As WorkgroupMonitoredMailboxConfiguration

Return Value

A new WorkgroupMonitoredMailboxConfiguration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

WorkgroupConfigurationList Class
WorkgroupConfigurationList Members
ININ.IceLib.Configuration Namespace


CreateMonitoredMailboxQuerySettings Method

[image]

IceLib Technical Reference
WorkgroupConfigurationList..::..CreateMonitoredMailboxQuerySettings Method
WorkgroupConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<WorkgroupMonitoredMailboxConfiguration, WorkgroupMonitoredMailboxConfiguration..::..Property> CreateMonitoredMailboxQuerySettings()
Visual Basic
Public Function CreateMonitoredMailboxQuerySettings As QuerySettings(Of WorkgroupMonitoredMailboxConfiguration, WorkgroupMonitoredMailboxConfiguration..::..Property)

Return Value

A new QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

WorkgroupConfigurationList Class
WorkgroupConfigurationList Members
ININ.IceLib.Configuration Namespace


CreateQuerySettings Method

[image]

IceLib Technical Reference
WorkgroupConfigurationList..::..CreateQuerySettings Method
WorkgroupConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings<WorkgroupConfiguration, WorkgroupConfiguration..::..Property, WorkgroupQueryChildrenSettings> CreateQuerySettings()
Visual Basic
Public Function CreateQuerySettings As HierarchicalQuerySettings(Of WorkgroupConfiguration, WorkgroupConfiguration..::..Property, WorkgroupQueryChildrenSettings)

Return Value

A new HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

WorkgroupConfigurationList Class
WorkgroupConfigurationList Members
ININ.IceLib.Configuration Namespace


RetrievePropertiesForMailboxSettings Method

[image]

IceLib Technical Reference
WorkgroupConfigurationList..::..RetrievePropertiesForMailboxSettings Method
WorkgroupConfigurationList Class See Also Send Feedback
Retrieves the property values that would result from applying the specified mailbox settings.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static MailboxRetrievedValues RetrievePropertiesForMailboxSettings(
    ConfigurationManager configurationManager,
    MailboxSettings mailboxSettings
)
Visual Basic
Public Shared Function RetrievePropertiesForMailboxSettings ( _
    configurationManager As ConfigurationManager, _
    mailboxSettings As MailboxSettings _
) As MailboxRetrievedValues

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.

Return Value

The retrieved mailbox values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

WorkgroupConfigurationList Class
WorkgroupConfigurationList Members
ININ.IceLib.Configuration Namespace
MailboxProperties..::..ApplyMailboxSettings(MailboxSettings)


WorkgroupConfigurationList Properties

[image] [image]

IceLib Technical Reference
WorkgroupConfigurationList Properties
WorkgroupConfigurationList Class See Also Send Feedback

The WorkgroupConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WorkgroupConfigurationList Class
ININ.IceLib.Configuration Namespace


WorkgroupConfigurationList Events

[image] [image]

IceLib Technical Reference
WorkgroupConfigurationList Events
WorkgroupConfigurationList Class See Also Send Feedback

The WorkgroupConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WorkgroupConfigurationList Class
ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration Class

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for WorkgroupMonitoredMailbox.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupMonitoredMailboxConfiguration : EditableListConfigurationObject<WorkgroupMonitoredMailboxConfiguration..::..Property>
Visual Basic
Public Class WorkgroupMonitoredMailboxConfiguration _
    Inherits EditableListConfigurationObject(Of WorkgroupMonitoredMailboxConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' WorkgroupMonitoredMailboxConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WorkgroupMonitoredMailboxConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WorkgroupConfigurationList
ININ.IceLib.Configuration..::..WorkgroupConfiguration


WorkgroupMonitoredMailboxConfiguration Members

[image] [image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration Members
WorkgroupMonitoredMailboxConfiguration Class Methods Properties See Also Send Feedback

The WorkgroupMonitoredMailboxConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | WorkgroupMonitoredMailboxConfiguration do not directly support commit, use the parent WorkgroupConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | CanReceiveEncryptedEmail | Provides access to the property representing CanReceiveEncryptedEmail (use Property.CanReceiveEncryptedEmail).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | EmailAddress | Provides access to the property representing the EmailAddress (use Property.EmailAddress).
Public property | InboundFolder | Provides access to the property representing the InboundFolder (use Property.InboundFolder).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | MailboxMoniker | Provides access to the property representing the MailboxMoniker (use Property.MailboxMoniker).
Public property | MailboxType | Provides access to the property representing the MailboxType (use Property.MailboxType).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

WorkgroupMonitoredMailboxConfiguration Class
ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration Methods

[image] [image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration Methods
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback

The WorkgroupMonitoredMailboxConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | WorkgroupMonitoredMailboxConfiguration do not directly support commit, use the parent WorkgroupConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

WorkgroupMonitoredMailboxConfiguration Class
ININ.IceLib.Configuration Namespace


Commit Method

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Commit Method
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
WorkgroupMonitoredMailboxConfiguration do not directly support commit, use the parent WorkgroupConfiguration's Commit()()()() instead.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Exceptions

Exception | Condition
System..::..NotSupportedException | WorkgroupMonitoredMailboxConfiguration do not directly support commit, use commit on the parent WorkgroupConfiguration instead.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration Properties

[image] [image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration Properties
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback

The WorkgroupMonitoredMailboxConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | CanReceiveEncryptedEmail | Provides access to the property representing CanReceiveEncryptedEmail (use Property.CanReceiveEncryptedEmail).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | EmailAddress | Provides access to the property representing the EmailAddress (use Property.EmailAddress).
Public property | InboundFolder | Provides access to the property representing the InboundFolder (use Property.InboundFolder).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | MailboxMoniker | Provides access to the property representing the MailboxMoniker (use Property.MailboxMoniker).
Public property | MailboxType | Provides access to the property representing the MailboxType (use Property.MailboxType).
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

WorkgroupMonitoredMailboxConfiguration Class
ININ.IceLib.Configuration Namespace


CanReceiveEncryptedEmail Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..CanReceiveEncryptedEmail Property
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Provides access to the property representing CanReceiveEncryptedEmail (use Property.CanReceiveEncryptedEmail).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupMonitoredMailboxConfiguration..::..Property, bool> CanReceiveEncryptedEmail { get; }
Visual Basic
Public ReadOnly Property CanReceiveEncryptedEmail As GeneralConfigurationProperty(Of WorkgroupMonitoredMailboxConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing CanReceiveEncryptedEmail.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


EmailAddress Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..EmailAddress Property
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Provides access to the property representing the EmailAddress (use Property.EmailAddress).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupMonitoredMailboxConfiguration..::..Property, string> EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As GeneralConfigurationProperty(Of WorkgroupMonitoredMailboxConfiguration..::..Property, String)
    Get

Field Value

The property representing the EmailAddress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


InboundFolder Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..InboundFolder Property
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Provides access to the property representing the InboundFolder (use Property.InboundFolder).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupMonitoredMailboxConfiguration..::..Property, string> InboundFolder { get; }
Visual Basic
Public ReadOnly Property InboundFolder As GeneralConfigurationProperty(Of WorkgroupMonitoredMailboxConfiguration..::..Property, String)
    Get

Field Value

The property representing the InboundFolder.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


MailboxMoniker Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..MailboxMoniker Property
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Provides access to the property representing the MailboxMoniker (use Property.MailboxMoniker).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupMonitoredMailboxConfiguration..::..Property, string> MailboxMoniker { get; }
Visual Basic
Public ReadOnly Property MailboxMoniker As GeneralConfigurationProperty(Of WorkgroupMonitoredMailboxConfiguration..::..Property, String)
    Get

Field Value

The property representing the MailboxMoniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


MailboxType Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..MailboxType Property
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Provides access to the property representing the MailboxType (use Property.MailboxType).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupMonitoredMailboxConfiguration..::..Property, MonitoredMailboxType> MailboxType { get; }
Visual Basic
Public ReadOnly Property MailboxType As GeneralConfigurationProperty(Of WorkgroupMonitoredMailboxConfiguration..::..Property, MonitoredMailboxType)
    Get

Field Value

The property representing the MailboxType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..PropertiesChanged Property
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WorkgroupMonitoredMailboxConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of WorkgroupMonitoredMailboxConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration Class
WorkgroupMonitoredMailboxConfiguration Members
ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration.Property Enumeration

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Property Enumeration
WorkgroupMonitoredMailboxConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
CanReceiveEncryptedEmail | 0 | Represents the CanReceiveEncryptedEmail property.
EmailAddress | 1 | Represents the EmailAddress property.
InboundFolder | 2 | Represents the InboundFolder property.
MailboxMoniker | 3 | Represents the MailboxMoniker property.
MailboxType | 4 | Represents the MailboxType property.
DisplayName | 5 | Represents the DisplayName part of the ConfigurationId property.
Id | 6 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration.Rights Class

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Rights Class
WorkgroupMonitoredMailboxConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..WorkgroupMonitoredMailboxConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Rights Members
WorkgroupMonitoredMailboxConfiguration..::..Rights Class Properties See Also Send Feedback

The WorkgroupMonitoredMailboxConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WorkgroupMonitoredMailboxConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


WorkgroupMonitoredMailboxConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Rights Properties
WorkgroupMonitoredMailboxConfiguration..::..Rights Class See Also Send Feedback

The WorkgroupMonitoredMailboxConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WorkgroupMonitoredMailboxConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Rights..::..Admin Property
WorkgroupMonitoredMailboxConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupMonitoredMailboxConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of WorkgroupMonitoredMailboxConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration..::..Rights Class
WorkgroupMonitoredMailboxConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


View Property

[image]

IceLib Technical Reference
WorkgroupMonitoredMailboxConfiguration..::..Rights..::..View Property
WorkgroupMonitoredMailboxConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WorkgroupMonitoredMailboxConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of WorkgroupMonitoredMailboxConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMonitoredMailboxConfiguration..::..Rights Class
WorkgroupMonitoredMailboxConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WorkgroupQueryChildrenSettings Class

[image]

IceLib Technical Reference
WorkgroupQueryChildrenSettings Class
Members See Also Send Feedback
Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects for MonitoredMailboxes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupQueryChildrenSettings : QueryChildrenSettings<WorkgroupConfiguration..::..Property>
Visual Basic
Public Class WorkgroupQueryChildrenSettings _
    Inherits QueryChildrenSettings(Of WorkgroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QueryChildrenSettings <(Of <(<' WorkgroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WorkgroupQueryChildrenSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace
ININ.IceLib.Configuration..::..WorkgroupConfigurationList
ININ.IceLib.Configuration..::..WorkgroupMonitoredMailboxConfiguration
ININ.IceLib.Configuration..::..QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>


WorkgroupQueryChildrenSettings Members

[image] [image]

IceLib Technical Reference
WorkgroupQueryChildrenSettings Members
WorkgroupQueryChildrenSettings Class Constructors Methods Properties See Also Send Feedback

The WorkgroupQueryChildrenSettings type exposes the following members.

Constructors

 | Name | Description
Public method | WorkgroupQueryChildrenSettings | Initializes a new instance of the WorkgroupQueryChildrenSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MonitoredMailbox | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

See Also

WorkgroupQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


WorkgroupQueryChildrenSettings Constructor

[image]

IceLib Technical Reference
WorkgroupQueryChildrenSettings Constructor
WorkgroupQueryChildrenSettings Class See Also Send Feedback
Initializes a new instance of the WorkgroupQueryChildrenSettings class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupQueryChildrenSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupQueryChildrenSettings Class
WorkgroupQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


WorkgroupQueryChildrenSettings Methods

[image] [image]

IceLib Technical Reference
WorkgroupQueryChildrenSettings Methods
WorkgroupQueryChildrenSettings Class See Also Send Feedback

The WorkgroupQueryChildrenSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


WorkgroupQueryChildrenSettings Properties

[image] [image]

IceLib Technical Reference
WorkgroupQueryChildrenSettings Properties
WorkgroupQueryChildrenSettings Class See Also Send Feedback

The WorkgroupQueryChildrenSettings type exposes the following members.

Properties

 | Name | Description
Public property | MonitoredMailbox | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

See Also

WorkgroupQueryChildrenSettings Class
ININ.IceLib.Configuration Namespace


MonitoredMailbox Property

[image]

IceLib Technical Reference
WorkgroupQueryChildrenSettings..::..MonitoredMailbox Property
WorkgroupQueryChildrenSettings Class See Also Send Feedback
Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<WorkgroupMonitoredMailboxConfiguration, WorkgroupMonitoredMailboxConfiguration..::..Property> MonitoredMailbox { get; set; }
Visual Basic
Public Property MonitoredMailbox As QuerySettings(Of WorkgroupMonitoredMailboxConfiguration, WorkgroupMonitoredMailboxConfiguration..::..Property)
    Get
    Set

Field Value

The custom data sub query settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupQueryChildrenSettings Class
WorkgroupQueryChildrenSettings Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration Class

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC WrapUpCategory.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WrapUpCategoryConfiguration : EditableListConfigurationObject<WrapUpCategoryConfiguration..::..Property>
Visual Basic
Public Class WrapUpCategoryConfiguration _
    Inherits EditableListConfigurationObject(Of WrapUpCategoryConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' WrapUpCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WrapUpCategoryConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration Members

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfiguration Members
WrapUpCategoryConfiguration Class Methods Properties See Also Send Feedback

The WrapUpCategoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this wrapup category (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsActualContact | Provides access to the property representing whether or not the interaction connects to an actual person (use Property.IsActualContact.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the property representing whether or this category was created by the system or by an administrator (use Property.IsPermanent.)
Public property | IsSuccessfulInteraction | Provides access to the property representing whether or not the interaction succeeds (use Property.IsSuccessfulInteraction.)
Public property | Label | Provides access to the property representing the wrap-up category label for this category (use Property.Label.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PhoneNumberStatus | Provides access to the property representing the phone number status for this category (use Property.PhoneNumberStatus.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | RecordStatus | Provides access to the property representing the record status for this category (use Property.RecordStatus.)
Public property | ShouldIncrementAttempts | Provides access to the property representing whether or not the attempts counter should be incremented (use Property.ShouldIncrementAttempts.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

WrapUpCategoryConfiguration Class
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration Methods

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfiguration Methods
WrapUpCategoryConfiguration Class See Also Send Feedback

The WrapUpCategoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

WrapUpCategoryConfiguration Class
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration Properties

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfiguration Properties
WrapUpCategoryConfiguration Class See Also Send Feedback

The WrapUpCategoryConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this wrapup category (use Property.AccessControlGroupAssignment).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsActualContact | Provides access to the property representing whether or not the interaction connects to an actual person (use Property.IsActualContact.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the property representing whether or this category was created by the system or by an administrator (use Property.IsPermanent.)
Public property | IsSuccessfulInteraction | Provides access to the property representing whether or not the interaction succeeds (use Property.IsSuccessfulInteraction.)
Public property | Label | Provides access to the property representing the wrap-up category label for this category (use Property.Label.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PhoneNumberStatus | Provides access to the property representing the phone number status for this category (use Property.PhoneNumberStatus.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | RecordStatus | Provides access to the property representing the record status for this category (use Property.RecordStatus.)
Public property | ShouldIncrementAttempts | Provides access to the property representing whether or not the attempts counter should be incremented (use Property.ShouldIncrementAttempts.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

WrapUpCategoryConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..AccessControlGroupAssignment Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this wrapup category (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


IsActualContact Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..IsActualContact Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing whether or not the interaction connects to an actual person (use Property.IsActualContact.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, bool> IsActualContact { get; }
Visual Basic
Public ReadOnly Property IsActualContact As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the actual contact flag.

Remarks

This property is only visible when dialer is activated.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


IsPermanent Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..IsPermanent Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing whether or this category was created by the system or by an administrator (use Property.IsPermanent.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, bool> IsPermanent { get; }
Visual Basic
Public ReadOnly Property IsPermanent As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, Boolean)
    Get

Field Value

The read-only property representing the permanent flag.

Remarks

Permanent categories are created during the install and cannot be deleted.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


IsSuccessfulInteraction Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..IsSuccessfulInteraction Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing whether or not the interaction succeeds (use Property.IsSuccessfulInteraction.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, bool> IsSuccessfulInteraction { get; }
Visual Basic
Public ReadOnly Property IsSuccessfulInteraction As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the interaction success flag.

Remarks

This property is only visible when dialer is activated.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


Label Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Label Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap-up category label for this category (use Property.Label.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, MultiLanguageString> Label { get; }
Visual Basic
Public ReadOnly Property Label As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, MultiLanguageString)
    Get

Field Value

The property representing the wrap-up category label.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


PhoneNumberStatus Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..PhoneNumberStatus Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the phone number status for this category (use Property.PhoneNumberStatus.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, string> PhoneNumberStatus { get; }
Visual Basic
Public ReadOnly Property PhoneNumberStatus As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, String)
    Get

Field Value

The property representing the phone number status. Any single alphanumeric character is valid.

Remarks

This property is only visible when dialer is activated.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..PropertiesChanged Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WrapUpCategoryConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of WrapUpCategoryConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


RecordStatus Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..RecordStatus Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing the record status for this category (use Property.RecordStatus.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, string> RecordStatus { get; }
Visual Basic
Public ReadOnly Property RecordStatus As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, String)
    Get

Field Value

The property representing the record status. Any single alphanumeric character is valid.

Remarks

This property is only visible when dialer is activated.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


ShouldIncrementAttempts Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..ShouldIncrementAttempts Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the property representing whether or not the attempts counter should be incremented (use Property.ShouldIncrementAttempts.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCategoryConfiguration..::..Property, bool> ShouldIncrementAttempts { get; }
Visual Basic
Public ReadOnly Property ShouldIncrementAttempts As GeneralConfigurationProperty(Of WrapUpCategoryConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the increment attempts flag.

Remarks

This property is only visible when dialer is activated.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..StandardProperties Property
WrapUpCategoryConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfiguration Class
WrapUpCategoryConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration.Property Enumeration

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Property Enumeration
WrapUpCategoryConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
ShouldIncrementAttempts | 1 | Represents the ShouldIncrementAttempts property.
IsActualContact | 2 | Represents the IsActualContact property.
IsSuccessfulInteraction | 3 | Represents the IsSuccessfulInteraction property.
Label | 4 | Represents the Label property.
PhoneNumberStatus | 5 | Represents the PhoneNumberStatus property.
RecordStatus | 6 | Represents the RecordStatus property.
IsPermanent | 7 | Represents the IsPermanent property.
DisplayName | 8 | Represents the DisplayName part of the ConfigurationId property.
Id | 9 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration.Rights Class

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Rights Class
WrapUpCategoryConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..WrapUpCategoryConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Rights Members
WrapUpCategoryConfiguration..::..Rights Class Properties See Also Send Feedback

The WrapUpCategoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WrapUpCategoryConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Rights Properties
WrapUpCategoryConfiguration..::..Rights Class See Also Send Feedback

The WrapUpCategoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WrapUpCategoryConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Rights..::..Admin Property
WrapUpCategoryConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WrapUpCategoryConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of WrapUpCategoryConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfiguration..::..Rights Class
WrapUpCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WrapUpCategories


View Property

[image]

IceLib Technical Reference
WrapUpCategoryConfiguration..::..Rights..::..View Property
WrapUpCategoryConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WrapUpCategoryConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of WrapUpCategoryConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfiguration..::..Rights Class
WrapUpCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfigurationList Class

[image]

IceLib Technical Reference
WrapUpCategoryConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing WrapUpCategory configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WrapUpCategoryConfigurationList : EditableConfigurationList<WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property>
Visual Basic
Public Class WrapUpCategoryConfigurationList _
    Inherits EditableConfigurationList(Of WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' WrapUpCategoryConfiguration, WrapUpCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WrapUpCategoryConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfigurationList Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfigurationList Members

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfigurationList Members
WrapUpCategoryConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The WrapUpCategoryConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | WrapUpCategoryConfigurationList | Initializes a new instance of the WrapUpCategoryConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WrapUpCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfigurationList Constructor

[image]

IceLib Technical Reference
WrapUpCategoryConfigurationList Constructor
WrapUpCategoryConfigurationList Class See Also Send Feedback
Initializes a new instance of the WrapUpCategoryConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WrapUpCategoryConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCategoryConfigurationList Class
WrapUpCategoryConfigurationList Members
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfigurationList Methods

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfigurationList Methods
WrapUpCategoryConfigurationList Class See Also Send Feedback

The WrapUpCategoryConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WrapUpCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfigurationList Properties

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfigurationList Properties
WrapUpCategoryConfigurationList Class See Also Send Feedback

The WrapUpCategoryConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WrapUpCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCategoryConfigurationList Events

[image] [image]

IceLib Technical Reference
WrapUpCategoryConfigurationList Events
WrapUpCategoryConfigurationList Class See Also Send Feedback

The WrapUpCategoryConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WrapUpCategoryConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration Class

[image]

IceLib Technical Reference
WrapUpCodeConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Wrap-Up Code. Wrap-Up codes can be assigned by agents to incoming and outgoing interactions, and are used in reporting to help categorize call details.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WrapUpCodeConfiguration : EditableListConfigurationObject<WrapUpCodeConfiguration..::..Property>
Visual Basic
Public Class WrapUpCodeConfiguration _
    Inherits EditableListConfigurationObject(Of WrapUpCodeConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' WrapUpCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WrapUpCodeConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration Members

[image] [image]

IceLib Technical Reference
WrapUpCodeConfiguration Members
WrapUpCodeConfiguration Class Methods Properties See Also Send Feedback

The WrapUpCodeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetErrorInformation | Provides access to the property representing whether there is a sync error, and returns the error received)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this wrapup code (use Property.AccessControlGroupAssignment).
Public property | Category | Provides access to the property representing the wrap-up category for this code (use Property.Category.)
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Digits | Provides access to the property representing the digits used to assign this code (use Property.Digits.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the property representing whether or not this code was created by the system or by an administrator (use Property.IsPermanent.)
Public property | IsRightPartyContact | Provides access to the property representing whether or not this code contacts the right party (use Property.IsRightPartyContact.)
Public property | Label | Provides access to the property representing the wrap-up code label for this code (use Property.Label.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | PureCloudLastSync | Provides access to the property representing the time this was last synced to the cloud (use Property.GenesysCloudLastSync.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

WrapUpCodeConfiguration Class
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration Methods

[image] [image]

IceLib Technical Reference
WrapUpCodeConfiguration Methods
WrapUpCodeConfiguration Class See Also Send Feedback

The WrapUpCodeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetErrorInformation | Provides access to the property representing whether there is a sync error, and returns the error received)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

WrapUpCodeConfiguration Class
ININ.IceLib.Configuration Namespace


GetErrorInformation Method

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..GetErrorInformation Method
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing whether there is a sync error, and returns the error received)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string GetErrorInformation(
    Session session,
    string wrapupCode
)
Visual Basic
Public Shared Function GetErrorInformation ( _
    session As Session, _
    wrapupCode As String _
) As String

Parameters

session
Type: ININ.IceLib.Connection..::..Session
wrapupCode
Type: System..::..String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration Properties

[image] [image]

IceLib Technical Reference
WrapUpCodeConfiguration Properties
WrapUpCodeConfiguration Class See Also Send Feedback

The WrapUpCodeConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlGroupAssignment | Provides access to the property representing access control group assignment for this wrapup code (use Property.AccessControlGroupAssignment).
Public property | Category | Provides access to the property representing the wrap-up category for this code (use Property.Category.)
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Digits | Provides access to the property representing the digits used to assign this code (use Property.Digits.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsPermanent | Provides access to the property representing whether or not this code was created by the system or by an administrator (use Property.IsPermanent.)
Public property | IsRightPartyContact | Provides access to the property representing whether or not this code contacts the right party (use Property.IsRightPartyContact.)
Public property | Label | Provides access to the property representing the wrap-up code label for this code (use Property.Label.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | PureCloudLastSync | Provides access to the property representing the time this was last synced to the cloud (use Property.GenesysCloudLastSync.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

WrapUpCodeConfiguration Class
ININ.IceLib.Configuration Namespace


AccessControlGroupAssignment Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..AccessControlGroupAssignment Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing access control group assignment for this wrapup code (use Property.AccessControlGroupAssignment).

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, ConfigurationId> AccessControlGroupAssignment { get; }
Visual Basic
Public ReadOnly Property AccessControlGroupAssignment As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the access control group assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


Category Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Category Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap-up category for this code (use Property.Category.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, ConfigurationId> Category { get; }
Visual Basic
Public ReadOnly Property Category As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, ConfigurationId)
    Get

Field Value

The property representing the wrap-up category.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


Digits Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Digits Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing the digits used to assign this code (use Property.Digits.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, string> Digits { get; }
Visual Basic
Public ReadOnly Property Digits As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, String)
    Get

Field Value

The property representing the digits used to assign the code.

Remarks

The digits are a numeric code that is entered to reference the wrap-up code. The Digits value must be unique across the wrap-up codes, including leading zeroes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


IsPermanent Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..IsPermanent Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing whether or not this code was created by the system or by an administrator (use Property.IsPermanent.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, bool> IsPermanent { get; }
Visual Basic
Public ReadOnly Property IsPermanent As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, Boolean)
    Get

Field Value

The read-only property representing the permanent flag.

Remarks

Permanent codes are created during the install and cannot be deleted.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


IsRightPartyContact Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..IsRightPartyContact Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing whether or not this code contacts the right party (use Property.IsRightPartyContact.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, bool> IsRightPartyContact { get; }
Visual Basic
Public ReadOnly Property IsRightPartyContact As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the right party contact flag.

Remarks

This property is only visible when dialer is activated.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


Label Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Label Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing the wrap-up code label for this code (use Property.Label.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, MultiLanguageString> Label { get; }
Visual Basic
Public ReadOnly Property Label As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, MultiLanguageString)
    Get

Field Value

The property representing the wrap-up code label.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..PropertiesChanged Property
WrapUpCodeConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WrapUpCodeConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of WrapUpCodeConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


PureCloudLastSync Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..PureCloudLastSync Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the property representing the time this was last synced to the cloud (use Property.GenesysCloudLastSync.)

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WrapUpCodeConfiguration..::..Property, string> PureCloudLastSync { get; }
Visual Basic
Public ReadOnly Property PureCloudLastSync As GeneralConfigurationProperty(Of WrapUpCodeConfiguration..::..Property, String)
    Get

Field Value

The property representing the last time this was synced to the cloud.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


StandardProperties Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..StandardProperties Property
WrapUpCodeConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration Class
WrapUpCodeConfiguration Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration.Property Enumeration

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Property Enumeration
WrapUpCodeConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessControlGroupAssignment | 0 | Represents the AccessControlGroupAssignment property.
Category | 1 | Represents the Category property.
Digits | 2 | Represents the Digits property.
IsRightPartyContact | 3 | Represents the IsRightPartyContact property.
Label | 4 | Represents the Label property.
IsPermanent | 5 | Represents the IsPermanent property.
PureCloudLastSync | 8 | Represents the PureCloudLastSync property.
DisplayName | 6 | Represents the DisplayName part of the ConfigurationId property.
Id | 7 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration.Rights Class

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Rights Class
WrapUpCodeConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..WrapUpCodeConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Rights Members
WrapUpCodeConfiguration..::..Rights Class Properties See Also Send Feedback

The WrapUpCodeConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WrapUpCodeConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


WrapUpCodeConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Rights Properties
WrapUpCodeConfiguration..::..Rights Class See Also Send Feedback

The WrapUpCodeConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

WrapUpCodeConfiguration..::..Rights Class
ININ.IceLib.Configuration Namespace


Admin Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Rights..::..Admin Property
WrapUpCodeConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WrapUpCodeConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of WrapUpCodeConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration..::..Rights Class
WrapUpCodeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..WrapUpCodes


View Property

[image]

IceLib Technical Reference
WrapUpCodeConfiguration..::..Rights..::..View Property
WrapUpCodeConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<WrapUpCodeConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of WrapUpCodeConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfiguration..::..Rights Class
WrapUpCodeConfiguration..::..Rights Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfigurationList Class

[image]

IceLib Technical Reference
WrapUpCodeConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing WrapUpCode configuration objects.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WrapUpCodeConfigurationList : EditableConfigurationList<WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property>
Visual Basic
Public Class WrapUpCodeConfigurationList _
    Inherits EditableConfigurationList(Of WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' WrapUpCodeConfiguration, WrapUpCodeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..WrapUpCodeConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfigurationList Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfigurationList Members

[image] [image]

IceLib Technical Reference
WrapUpCodeConfigurationList Members
WrapUpCodeConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The WrapUpCodeConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | WrapUpCodeConfigurationList | Initializes a new instance of the WrapUpCodeConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WrapUpCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCodeConfigurationList Constructor

[image]

IceLib Technical Reference
WrapUpCodeConfigurationList Constructor
WrapUpCodeConfigurationList Class See Also Send Feedback
Initializes a new instance of the WrapUpCodeConfigurationList class.

Namespace: ININ.IceLib.Configuration
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WrapUpCodeConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpCodeConfigurationList Class
WrapUpCodeConfigurationList Members
ININ.IceLib.Configuration Namespace


WrapUpCodeConfigurationList Methods

[image] [image]

IceLib Technical Reference
WrapUpCodeConfigurationList Methods
WrapUpCodeConfigurationList Class See Also Send Feedback

The WrapUpCodeConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WrapUpCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCodeConfigurationList Properties

[image] [image]

IceLib Technical Reference
WrapUpCodeConfigurationList Properties
WrapUpCodeConfigurationList Class See Also Send Feedback

The WrapUpCodeConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WrapUpCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


WrapUpCodeConfigurationList Events

[image] [image]

IceLib Technical Reference
WrapUpCodeConfigurationList Events
WrapUpCodeConfigurationList Class See Also Send Feedback

The WrapUpCodeConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

WrapUpCodeConfigurationList Class
ININ.IceLib.Configuration Namespace


ININ.IceLib.Configuration.DataTypes Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.DataTypes Namespace
Send Feedback

The ININ.IceLib.Configuration.DataTypes namespace contains classes that provide support to the classes in the ININ.IceLib.Configuration namespace. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

Classes

 | Class | Description
Public class | AccessControlGroup | Represents an Access Control Group.
Public class | ActionTypeValues | Represents the valid values for the ActionType property.
Public class | AnalyzerKeywordSetChannelRelationship | Represents a channel relationship configuration value.
Public class | BasicPhoneNumber | Represents a phone number configuration value.
Public class | ClientTemplate | Contains information about a published client template.
Public class | Date | Represents a date configuration value.
Public class | KeywordCount | The Keyword Count information for a given langauge.
Public class | KeywordCountInformation | The Keyword Count information.
Public class | MultiLanguageString | Represents a multi-language string configuration value.
Public class | RoutingTableEntrySettings | Represents an entry in the routing table.
Public class | SecureInputFormFieldDefinition | Represents a SecureInputFormConfiguration's field definition.
Public class | SipAddress | Represents a SIP address.
Public class | SkillSettings | Represents a user's configuration skill settings.
Public class | StructuredParameter | Represents a structured parameter value for a StructuredParameterConfiguration object.
Public class | Time | Represents a time configuration value.
Public class | UtilizationSettings | Represents a user's configuration utilization settings.

Enumerations

 | Enumeration | Description
Public enumeration | AccessControlGroupObjectType | Represents the possible object types that can be assigned to an Access Control Group.
Public enumeration | AnalyzerKeywordSetChannelType | Represents the channel type for analyzer keyword set channel relationships.
Public enumeration | EFaqSearchOption | Represents the e-FAQ Search Option used by a UserConfiguration.
Public enumeration | ICDataSourceSubType | Represents the data source sub type for a object.
Public enumeration | ICDataSourceType | Represents the data source type for a object.
Public enumeration | ImageMimeType | Represents the image mime type for an ImageResourceCategoryConfiguration and an ImageResourceConfiguration.
Public enumeration | InteractionProcessAutomationLicenseType | Represents the Interaction Process Administration license type for user configuration licensing purposes.
Public enumeration | LicenseAllocationType | Represents the License Allocation type used for Concurrent Licensing Purposes.
Public enumeration | LicenseAppliesToType | Represents the types of licenses that can be queried for.
Public enumeration | LyncOption | Represents the Lync Option for the LyncOption property.
Public enumeration | MailboxDirectoryType | Represents the mailbox type for a MailboxDirectoryDefinition.
Public enumeration | MediaLevel | Represents the media level for user configuration licensing purposes.
Public enumeration | MediaType | Represents the media type for user configuration licensing purposes.
Public enumeration | MonitoredMailboxType | Represents a monitored mailbox type.
Public enumeration | MwiMode | Represents the message waiting indicator mode.
Public enumeration | Orientation | The paper orientation of the report.
Public enumeration | ParameterSource | Source of this parameter.
Public enumeration | QueueColumnAttributeType | Represents the attribute type for a QueueColumn.
Public enumeration | RecurrencePatternType | Represents the recurrence pattern type for a schedule.
Public enumeration | RecurrenceRelativeDayType | Represents the relative day recurrence type for a schedule. Used with RecurrenceRelativeMonthlyType to specify, e.g., the second Wednesday of the month.
Public enumeration | RecurrenceRelativeMonthlyType | Represents the monthly recurrence instance type for a schedule. Used with RecurrenceRelativeDayType to specify, e.g., the second Wednesday of the month.
Public enumeration | ReportingParameterDataType | Parameter data type.
Public enumeration | ReportingParameterTypes | The type of Report Parameter; tells the Report engine how to handle it.
Public enumeration | ReportType | The type of output for this meta data.
Public enumeration | RoutingTableDestinationType | Represents the Destination Type for a Routing Table entry.
Public enumeration | RoutingTableSubstitutionType | Represents the Substitution Type for a Routing Table entry.
Public enumeration | SecureInputFormType | Represents a SecureInputFormConfiguration's form type.
Public enumeration | StationType | Represents the type of a station.
Public enumeration | StructuredParameterType | Represents the structured parameter type for a StructuredParameter object.
Public enumeration | TimeZoneDisplayNameType | Represents the possible display names used to represent a time zone.
Public enumeration | WorkgroupQueueType | Represents the Queue Type for Workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.


AccessControlGroup Class

[image]

IceLib Technical Reference
AccessControlGroup Class
Members See Also Send Feedback
Represents an Access Control Group.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccessControlGroup
Visual Basic
Public Class AccessControlGroup

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..AccessControlGroup

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroup Members
ININ.IceLib.Configuration.DataTypes Namespace


AccessControlGroup Members

[image] [image]

IceLib Technical Reference
AccessControlGroup Members
AccessControlGroup Class Methods Properties See Also Send Feedback

The AccessControlGroup type exposes the following members.

Methods

 | Name | Description
 | AreAccessControlGroupsInUse | Runs the execute function to see if Access Control Groups are being used.
 | AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType) | Runs the execute function to assign new members to an Access Control Group.
 | AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32) | Runs the execute function to assign new members to an Access Control Group.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessControlGroupsForObjectType | Runs the execute function to get the list of AccessControlGroup that a given user has access to.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Children | Gets or sets the children.
Public property | ConfigurationId | Gets or sets the ID.

See Also

AccessControlGroup Class
ININ.IceLib.Configuration.DataTypes Namespace


AccessControlGroup Methods

[image] [image]

IceLib Technical Reference
AccessControlGroup Methods
AccessControlGroup Class See Also Send Feedback

The AccessControlGroup type exposes the following members.

Methods

 | Name | Description
 | AreAccessControlGroupsInUse | Runs the execute function to see if Access Control Groups are being used.
 | AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType) | Runs the execute function to assign new members to an Access Control Group.
 | AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32) | Runs the execute function to assign new members to an Access Control Group.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAccessControlGroupsForObjectType | Runs the execute function to get the list of AccessControlGroup that a given user has access to.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccessControlGroup Class
ININ.IceLib.Configuration.DataTypes Namespace


AreAccessControlGroupsInUse Method

[image]

IceLib Technical Reference
AccessControlGroup..::..AreAccessControlGroupsInUse Method
AccessControlGroup Class See Also Send Feedback
Runs the execute function to see if Access Control Groups are being used.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool AreAccessControlGroupsInUse(
    ConfigurationManager configurationManager
)
Visual Basic
Public Shared Function AreAccessControlGroupsInUse ( _
    configurationManager As ConfigurationManager _
) As Boolean

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
A Configuration Manager instance.

Return Value

true if they are being used, otherwise false.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroup Class
AccessControlGroup Members
ININ.IceLib.Configuration.DataTypes Namespace


AssignToAccessControlGroup Method

[image] [image]

IceLib Technical Reference
AccessControlGroup..::..AssignToAccessControlGroup Method
AccessControlGroup Class See Also Send Feedback

Overload List

Name | Description
AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType) | Runs the execute function to assign new members to an Access Control Group.
AssignToAccessControlGroup(ConfigurationManager, AccessControlGroup, IEnumerable<(Of <<'(ConfigurationId>)>>), AccessControlGroupObjectType, Int32) | Runs the execute function to assign new members to an Access Control Group.

See Also

AccessControlGroup Class
AccessControlGroup Members
ININ.IceLib.Configuration.DataTypes Namespace


AssignToAccessControlGroup Method (ConfigurationManager, AccessControlGroup, IEnumerable(ConfigurationId), AccessControlGroupObjectType)

[image]

IceLib Technical Reference
AccessControlGroup..::..AssignToAccessControlGroup Method (ConfigurationManager, AccessControlGroup, IEnumerable<(Of <(<'ConfigurationId>)>)>, AccessControlGroupObjectType)
AccessControlGroup Class See Also Send Feedback
Runs the execute function to assign new members to an Access Control Group.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool AssignToAccessControlGroup(
    ConfigurationManager configurationManager,
    AccessControlGroup accessControlGroup,
    IEnumerable<ConfigurationId> newMembers,
    AccessControlGroupObjectType objectType
)
Visual Basic
Public Shared Function AssignToAccessControlGroup ( _
    configurationManager As ConfigurationManager, _
    accessControlGroup As AccessControlGroup, _
    newMembers As IEnumerable(Of ConfigurationId), _
    objectType As AccessControlGroupObjectType _
) As Boolean

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
A Configuration Manager instance.
accessControlGroup
Type: ININ.IceLib.Configuration.DataTypes..::..AccessControlGroup
The access control group to assign the new members to.
newMembers
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ConfigurationId >)>)>
A list of new members.
objectType
Type: ININ.IceLib.Configuration.DataTypes..::..AccessControlGroupObjectType
The type of the object being assigned.

Return Value

trueTruetruetrue (True in Visual Basic) if they are being used, otherwise falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An empty new members list was provided.
System..::..ArgumentOutOfRangeException | Invalid AccessControlGroupObjectType was provided.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroup Class
AccessControlGroup Members
AssignToAccessControlGroup Overload
ININ.IceLib.Configuration.DataTypes Namespace


AssignToAccessControlGroup Method (ConfigurationManager, AccessControlGroup, IEnumerable(ConfigurationId), AccessControlGroupObjectType, Int32)

[image]

IceLib Technical Reference
AccessControlGroup..::..AssignToAccessControlGroup Method (ConfigurationManager, AccessControlGroup, IEnumerable<(Of <(<'ConfigurationId>)>)>, AccessControlGroupObjectType, Int32)
AccessControlGroup Class See Also Send Feedback
Runs the execute function to assign new members to an Access Control Group.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool AssignToAccessControlGroup(
    ConfigurationManager configurationManager,
    AccessControlGroup accessControlGroup,
    IEnumerable<ConfigurationId> newMembers,
    AccessControlGroupObjectType objectType,
    int transactionId
)
Visual Basic
Public Shared Function AssignToAccessControlGroup ( _
    configurationManager As ConfigurationManager, _
    accessControlGroup As AccessControlGroup, _
    newMembers As IEnumerable(Of ConfigurationId), _
    objectType As AccessControlGroupObjectType, _
    transactionId As Integer _
) As Boolean

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
A Configuration Manager instance.
accessControlGroup
Type: ININ.IceLib.Configuration.DataTypes..::..AccessControlGroup
The access control group to assign the new members to.
newMembers
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ConfigurationId >)>)>
A list of new members.
objectType
Type: ININ.IceLib.Configuration.DataTypes..::..AccessControlGroupObjectType
The type of the object being assigned.
transactionId
Type: System..::..Int32
The transaction ID.

Return Value

trueTruetruetrue (True in Visual Basic) if they are being used, otherwise falseFalsefalsefalse (False in Visual Basic).

Remarks

Valid values for transactionId are obtained from a call to BeginTransaction()()()() or BeginTransactionAsync(EventHandler<(Of <<'(BeginTransactionCompletedEventArgs>)>>), Object). If a valid transaction ID is set, notifications for watched configuration objects will be suspended until a call to EndTransaction(Int32) or EndTransactionAsync(Int32, AsyncCompletedEventHandler, Object) is made with the associated transaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An empty new members list was provided.
System..::..ArgumentOutOfRangeException | Invalid AccessControlGroupObjectType was provided, or transactionId is less than or equal to zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AccessControlGroup Class
AccessControlGroup Members
AssignToAccessControlGroup Overload
ININ.IceLib.Configuration.DataTypes Namespace


GetAccessControlGroupsForObjectType Method

[image]

IceLib Technical Reference
AccessControlGroup..::..GetAccessControlGroupsForObjectType Method
AccessControlGroup Class See Also Send Feedback
Runs the execute function to get the list of AccessControlGroup that a given user has access to.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static IEnumerable<AccessControlGroup> GetAccessControlGroupsForObjectType(
    ConfigurationManager configurationManager,
    string userId,
    AccessControlGroupObjectType objectType
)
Visual Basic
Public Shared Function GetAccessControlGroupsForObjectType ( _
    configurationManager As ConfigurationManager, _
    userId As String, _
    objectType As AccessControlGroupObjectType _
) As IEnumerable(Of AccessControlGroup)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
A Configuration Manager instance.
userId
Type: System..::..String
A user ID to to check access against.
objectType
Type: ININ.IceLib.Configuration.DataTypes..::..AccessControlGroupObjectType
The type of object to get a list of Access Control Groups for.

Return Value

List of AccessControlGroup for a given object type that this user has access to.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An empty user ID was provided.
System..::..ArgumentOutOfRangeException | Invalid AccessControlGroupObjectType was provided.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroup Class
AccessControlGroup Members
ININ.IceLib.Configuration.DataTypes Namespace


AccessControlGroup Properties

[image] [image]

IceLib Technical Reference
AccessControlGroup Properties
AccessControlGroup Class See Also Send Feedback

The AccessControlGroup type exposes the following members.

Properties

 | Name | Description
Public property | Children | Gets or sets the children.
Public property | ConfigurationId | Gets or sets the ID.

See Also

AccessControlGroup Class
ININ.IceLib.Configuration.DataTypes Namespace


Children Property

[image]

IceLib Technical Reference
AccessControlGroup..::..Children Property
AccessControlGroup Class See Also Send Feedback
Gets or sets the children.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<AccessControlGroup> Children { get; private set; }
Visual Basic
Public Property Children As IEnumerable(Of AccessControlGroup)
    Get
    Private Set

Field Value

The list of any child Access Control Groups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroup Class
AccessControlGroup Members
ININ.IceLib.Configuration.DataTypes Namespace


ConfigurationId Property

[image]

IceLib Technical Reference
AccessControlGroup..::..ConfigurationId Property
AccessControlGroup Class See Also Send Feedback
Gets or sets the ID.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId ConfigurationId { get; private set; }
Visual Basic
Public Property ConfigurationId As ConfigurationId
    Get
    Private Set

Field Value

The Configuration ID for this Access Control Group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AccessControlGroup Class
AccessControlGroup Members
ININ.IceLib.Configuration.DataTypes Namespace


AccessControlGroupObjectType Enumeration

[image]

IceLib Technical Reference
AccessControlGroupObjectType Enumeration
See Also Send Feedback
Represents the possible object types that can be assigned to an Access Control Group.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AccessControlGroupObjectType
Visual Basic
Public Enumeration AccessControlGroupObjectType

Members

Member name | Value | Description
AccountCode | 0 | Account Code
ClientConfigurationTemplate | 1 | Client Configuration Template
IpPhone | 2 | Ip Phone
IpPhoneProxyGroup | 3 | Ip Phone Proxy Group
IpPhoneRingSet | 4 | Ip Phone Ring Set
IpPhoneTemplate | 5 | Ip Phone Template
KeywordSet | 6 | Keyword Set
Layout | 7 | Layout
Location | 8 | Location
PasswordPolicy | 9 | Password Policy
Role | 10 | Role
Schedule | 11 | Schedule
Skill | 12 | Skill
Station | 13 | Station
StationGroup | 14 | Station Group
StationTemplate | 15 | Station Template
InteractionProcessorTable | 16 | Table
User | 17 | User
Workgroup | 18 | Workgroup
WrapUpCode | 19 | Wrap-up Code
WrapUpCategory | 20 | Wrap-up Category
ImageResource | 21 | Image Resource

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ActionTypeValues Class

[image]

IceLib Technical Reference
ActionTypeValues Class
Members See Also Send Feedback
Represents the valid values for the ActionType property.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ActionTypeValues
Visual Basic
Public Class ActionTypeValues

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..ActionTypeValues

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ActionTypeValues Members
ININ.IceLib.Configuration.DataTypes Namespace


ActionTypeValues Members

[image] [image]

IceLib Technical Reference
ActionTypeValues Members
ActionTypeValues Class Constructors Methods Fields See Also Send Feedback

The ActionTypeValues type exposes the following members.

Constructors

 | Name | Description
Public method | ActionTypeValues | Initializes a new instance of the ActionTypeValues class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Dde | Represents the "DDE" action type.
ScreenPop | Represents the "Screen Pop" action type.
UrlScreenPop | Represents the "URL Screen Pop" action type.

See Also

ActionTypeValues Class
ININ.IceLib.Configuration.DataTypes Namespace


ActionTypeValues Constructor

[image]

IceLib Technical Reference
ActionTypeValues Constructor
ActionTypeValues Class See Also Send Feedback
Initializes a new instance of the ActionTypeValues class

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ActionTypeValues()
Visual Basic
Public Sub New

See Also

ActionTypeValues Class
ActionTypeValues Members
ININ.IceLib.Configuration.DataTypes Namespace


ActionTypeValues Fields

[image] [image]

IceLib Technical Reference
ActionTypeValues Fields
ActionTypeValues Class See Also Send Feedback

The ActionTypeValues type exposes the following members.

Fields

Name | Description
Dde | Represents the "DDE" action type.
ScreenPop | Represents the "Screen Pop" action type.
UrlScreenPop | Represents the "URL Screen Pop" action type.

See Also

ActionTypeValues Class
ININ.IceLib.Configuration.DataTypes Namespace


Dde Field

[image]

IceLib Technical Reference
ActionTypeValues..::..Dde Field
ActionTypeValues Class See Also Send Feedback
Represents the "DDE" action type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const string Dde
Visual Basic
Public Const Dde As String

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ActionTypeValues Class
ActionTypeValues Members
ININ.IceLib.Configuration.DataTypes Namespace


ScreenPop Field

[image]

IceLib Technical Reference
ActionTypeValues..::..ScreenPop Field
ActionTypeValues Class See Also Send Feedback
Represents the "Screen Pop" action type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const string ScreenPop
Visual Basic
Public Const ScreenPop As String

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ActionTypeValues Class
ActionTypeValues Members
ININ.IceLib.Configuration.DataTypes Namespace


UrlScreenPop Field

[image]

IceLib Technical Reference
ActionTypeValues..::..UrlScreenPop Field
ActionTypeValues Class See Also Send Feedback
Represents the "URL Screen Pop" action type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const string UrlScreenPop
Visual Basic
Public Const UrlScreenPop As String

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

ActionTypeValues Class
ActionTypeValues Members
ININ.IceLib.Configuration.DataTypes Namespace


ActionTypeValues Methods

[image] [image]

IceLib Technical Reference
ActionTypeValues Methods
ActionTypeValues Class See Also Send Feedback

The ActionTypeValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ActionTypeValues Class
ININ.IceLib.Configuration.DataTypes Namespace


AnalyzerKeywordSetChannelRelationship Class

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship Class
Members See Also Send Feedback
Represents a channel relationship configuration value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerKeywordSetChannelRelationship : IEditable,
    IEditableViaProxy, IDeepCloneable
Visual Basic
Public Class AnalyzerKeywordSetChannelRelationship _
    Implements IEditable, IEditableViaProxy, IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..AnalyzerKeywordSetChannelRelationship

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


AnalyzerKeywordSetChannelRelationship Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship Members
AnalyzerKeywordSetChannelRelationship Class Constructors Methods Properties See Also Send Feedback

The AnalyzerKeywordSetChannelRelationship type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyzerKeywordSetChannelRelationship | Initializes a new instance of the AnalyzerKeywordSetChannelRelationship class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Channel | Gets or sets the channel.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | KeywordSetId | Gets or sets the keyword set id.

See Also

AnalyzerKeywordSetChannelRelationship Class
ININ.IceLib.Configuration.DataTypes Namespace


AnalyzerKeywordSetChannelRelationship Constructor

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship Constructor
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Initializes a new instance of the AnalyzerKeywordSetChannelRelationship class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AnalyzerKeywordSetChannelRelationship(
    AnalyzerKeywordSetChannelType channel,
    ConfigurationId cid
)
Visual Basic
Public Sub New ( _
    channel As AnalyzerKeywordSetChannelType, _
    cid As ConfigurationId _
)

Parameters

channel
Type: ININ.IceLib.Configuration.DataTypes..::..AnalyzerKeywordSetChannelType
The channel.
cid
Type: ININ.IceLib.Configuration..::..ConfigurationId
The cid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


AnalyzerKeywordSetChannelRelationship Methods

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship Methods
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback

The AnalyzerKeywordSetChannelRelationship type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AnalyzerKeywordSetChannelRelationship Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship..::..Equals Method
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship..::..GetHashCode Method
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship..::..ToString Method
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


AnalyzerKeywordSetChannelRelationship Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship Properties
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback

The AnalyzerKeywordSetChannelRelationship type exposes the following members.

Properties

 | Name | Description
Public property | Channel | Gets or sets the channel.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | KeywordSetId | Gets or sets the keyword set id.

See Also

AnalyzerKeywordSetChannelRelationship Class
ININ.IceLib.Configuration.DataTypes Namespace


Channel Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship..::..Channel Property
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Gets or sets the channel.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AnalyzerKeywordSetChannelType Channel { get; set; }
Visual Basic
Public Property Channel As AnalyzerKeywordSetChannelType
    Get
    Set

Field Value

The channel.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


IsEditable Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship..::..IsEditable Property
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEditable..::..IsEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


KeywordSetId Property

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelRelationship..::..KeywordSetId Property
AnalyzerKeywordSetChannelRelationship Class See Also Send Feedback
Gets or sets the keyword set id.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId KeywordSetId { get; set; }
Visual Basic
Public Property KeywordSetId As ConfigurationId
    Get
    Set

Field Value

The keyword set id.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AnalyzerKeywordSetChannelRelationship Class
AnalyzerKeywordSetChannelRelationship Members
ININ.IceLib.Configuration.DataTypes Namespace


AnalyzerKeywordSetChannelType Enumeration

[image]

IceLib Technical Reference
AnalyzerKeywordSetChannelType Enumeration
See Also Send Feedback
Represents the channel type for analyzer keyword set channel relationships.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AnalyzerKeywordSetChannelType
Visual Basic
Public Enumeration AnalyzerKeywordSetChannelType

Members

Member name | Value | Description
None | 0 | No channel type.
Customer | 1 | Customer channel type.
Agent | 2 | Agent channel type.
Both | 3 | Both channel types (customer and agent).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


BasicPhoneNumber Class

[image]

IceLib Technical Reference
BasicPhoneNumber Class
Members See Also Send Feedback
Represents a phone number configuration value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class BasicPhoneNumber : ComplexConfigurationDataType,
    IDeepCloneable
Visual Basic
Public Class BasicPhoneNumber _
    Inherits ComplexConfigurationDataType _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ComplexConfigurationDataType
ININ.IceLib.Configuration.DataTypes..::..BasicPhoneNumber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


BasicPhoneNumber Members

[image] [image]

IceLib Technical Reference
BasicPhoneNumber Members
BasicPhoneNumber Class Constructors Methods Properties See Also Send Feedback

The BasicPhoneNumber type exposes the following members.

Constructors

 | Name | Description
Public method | BasicPhoneNumber | Initializes a new instance of the BasicPhoneNumber class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DialExtensionAutomatically | Gets a value indicating whether the extension should be auto-dialed.
Public property | Extension | Gets the extension.
Public property | Number | Gets the number.

See Also

BasicPhoneNumber Class
ININ.IceLib.Configuration.DataTypes Namespace


BasicPhoneNumber Constructor

[image]

IceLib Technical Reference
BasicPhoneNumber Constructor
BasicPhoneNumber Class See Also Send Feedback
Initializes a new instance of the BasicPhoneNumber class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public BasicPhoneNumber(
    string number,
    string extension,
    bool dialExtensionAutomatically
)
Visual Basic
Public Sub New ( _
    number As String, _
    extension As String, _
    dialExtensionAutomatically As Boolean _
)

Parameters

number
Type: System..::..String
The number.
extension
Type: System..::..String
The extension.
dialExtensionAutomatically
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) the extension is to be auto-dialed.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


BasicPhoneNumber Methods

[image] [image]

IceLib Technical Reference
BasicPhoneNumber Methods
BasicPhoneNumber Class See Also Send Feedback

The BasicPhoneNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

BasicPhoneNumber Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
BasicPhoneNumber..::..Equals Method
BasicPhoneNumber Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
BasicPhoneNumber..::..GetHashCode Method
BasicPhoneNumber Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
BasicPhoneNumber..::..ToString Method
BasicPhoneNumber Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


BasicPhoneNumber Properties

[image] [image]

IceLib Technical Reference
BasicPhoneNumber Properties
BasicPhoneNumber Class See Also Send Feedback

The BasicPhoneNumber type exposes the following members.

Properties

 | Name | Description
Public property | DialExtensionAutomatically | Gets a value indicating whether the extension should be auto-dialed.
Public property | Extension | Gets the extension.
Public property | Number | Gets the number.

See Also

BasicPhoneNumber Class
ININ.IceLib.Configuration.DataTypes Namespace


DialExtensionAutomatically Property

[image]

IceLib Technical Reference
BasicPhoneNumber..::..DialExtensionAutomatically Property
BasicPhoneNumber Class See Also Send Feedback
Gets a value indicating whether the extension should be auto-dialed.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DialExtensionAutomatically { get; }
Visual Basic
Public ReadOnly Property DialExtensionAutomatically As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the extension should be auto-dialed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


Extension Property

[image]

IceLib Technical Reference
BasicPhoneNumber..::..Extension Property
BasicPhoneNumber Class See Also Send Feedback
Gets the extension.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


Number Property

[image]

IceLib Technical Reference
BasicPhoneNumber..::..Number Property
BasicPhoneNumber Class See Also Send Feedback
Gets the number.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Number { get; }
Visual Basic
Public ReadOnly Property Number As String
    Get

Field Value

The number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

BasicPhoneNumber Class
BasicPhoneNumber Members
ININ.IceLib.Configuration.DataTypes Namespace


ClientTemplate Class

[image]

IceLib Technical Reference
ClientTemplate Class
Members See Also Send Feedback
Contains information about a published client template.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientTemplate : IDeepCloneable
Visual Basic
Public Class ClientTemplate _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..ClientTemplate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


ClientTemplate Members

[image] [image]

IceLib Technical Reference
ClientTemplate Members
ClientTemplate Class Methods Properties See Also Send Feedback

The ClientTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ApplicationId | Gets the application ID.
Public property | ConfigurationId | Gets the configuration ID.
Public property | DatePublished | Gets the date and time the client template was last published.

See Also

ClientTemplate Class
ININ.IceLib.Configuration.DataTypes Namespace


ClientTemplate Methods

[image] [image]

IceLib Technical Reference
ClientTemplate Methods
ClientTemplate Class See Also Send Feedback

The ClientTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ClientTemplate Class
ININ.IceLib.Configuration.DataTypes Namespace


Clone Method

[image]

IceLib Technical Reference
ClientTemplate..::..Clone Method
ClientTemplate Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
ClientTemplate..::..Equals Method
ClientTemplate Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ClientTemplate..::..GetHashCode Method
ClientTemplate Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
ClientTemplate..::..ToString Method
ClientTemplate Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


ClientTemplate Properties

[image] [image]

IceLib Technical Reference
ClientTemplate Properties
ClientTemplate Class See Also Send Feedback

The ClientTemplate type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationId | Gets the application ID.
Public property | ConfigurationId | Gets the configuration ID.
Public property | DatePublished | Gets the date and time the client template was last published.

See Also

ClientTemplate Class
ININ.IceLib.Configuration.DataTypes Namespace


ApplicationId Property

[image]

IceLib Technical Reference
ClientTemplate..::..ApplicationId Property
ClientTemplate Class See Also Send Feedback
Gets the application ID.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; private set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Private Set

Field Value

The application ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


ConfigurationId Property

[image]

IceLib Technical Reference
ClientTemplate..::..ConfigurationId Property
ClientTemplate Class See Also Send Feedback
Gets the configuration ID.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId ConfigurationId { get; private set; }
Visual Basic
Public Property ConfigurationId As ConfigurationId
    Get
    Private Set

Field Value

The configuration ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


DatePublished Property

[image]

IceLib Technical Reference
ClientTemplate..::..DatePublished Property
ClientTemplate Class See Also Send Feedback
Gets the date and time the client template was last published.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime DatePublished { get; private set; }
Visual Basic
Public Property DatePublished As DateTime
    Get
    Private Set

Field Value

The date and time the client template was published.

Remarks

This value is expressed in UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ClientTemplate Class
ClientTemplate Members
ININ.IceLib.Configuration.DataTypes Namespace


Date Class

[image]

IceLib Technical Reference
Date Class
Members See Also Send Feedback
Represents a date configuration value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Date : IDeepCloneable
Visual Basic
Public Class Date _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..Date

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Date Members
ININ.IceLib.Configuration.DataTypes Namespace


Date Members

[image] [image]

IceLib Technical Reference
Date Members
Date Class Constructors Methods Fields Properties See Also Send Feedback

The Date type exposes the following members.

Constructors

 | Name | Description
Public method | Date | Initializes a new instance of the Date class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
MinDate | Used as the end date for a "forever" schedule.

Properties

 | Name | Description
Public property | DateValue | Gets the date value for this instance.

See Also

Date Class
ININ.IceLib.Configuration.DataTypes Namespace


Date Constructor

[image]

IceLib Technical Reference
Date Constructor
Date Class See Also Send Feedback
Initializes a new instance of the Date class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Date(
    int year,
    int month,
    int day
)
Visual Basic
Public Sub New ( _
    year As Integer, _
    month As Integer, _
    day As Integer _
)

Parameters

year
Type: System..::..Int32
The year.
month
Type: System..::..Int32
The month.
day
Type: System..::..Int32
The day.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Date Class
Date Members
ININ.IceLib.Configuration.DataTypes Namespace


Date Fields

[image] [image]

IceLib Technical Reference
Date Fields
Date Class See Also Send Feedback

The Date type exposes the following members.

Fields

Name | Description
MinDate | Used as the end date for a "forever" schedule.

See Also

Date Class
ININ.IceLib.Configuration.DataTypes Namespace


MinDate Field

[image]

IceLib Technical Reference
Date..::..MinDate Field
Date Class See Also Send Feedback
Used as the end date for a "forever" schedule.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly Date MinDate
Visual Basic
Public Shared ReadOnly MinDate As Date

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Date Class
Date Members
ININ.IceLib.Configuration.DataTypes Namespace


Date Methods

[image] [image]

IceLib Technical Reference
Date Methods
Date Class See Also Send Feedback

The Date type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Date Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
Date..::..Equals Method
Date Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Date Class
Date Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
Date..::..GetHashCode Method
Date Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Date Class
Date Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
Date..::..ToString Method
Date Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Date Class
Date Members
ININ.IceLib.Configuration.DataTypes Namespace


Date Properties

[image] [image]

IceLib Technical Reference
Date Properties
Date Class See Also Send Feedback

The Date type exposes the following members.

Properties

 | Name | Description
Public property | DateValue | Gets the date value for this instance.

See Also

Date Class
ININ.IceLib.Configuration.DataTypes Namespace


DateValue Property

[image]

IceLib Technical Reference
Date..::..DateValue Property
Date Class See Also Send Feedback
Gets the date value for this instance.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime DateValue { get; private set; }
Visual Basic
Public Property DateValue As DateTime
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Date Class
Date Members
ININ.IceLib.Configuration.DataTypes Namespace


EFaqSearchOption Enumeration

[image]

IceLib Technical Reference
EFaqSearchOption Enumeration
See Also Send Feedback
Represents the e-FAQ Search Option used by a UserConfiguration.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EFaqSearchOption
Visual Basic
Public Enumeration EFaqSearchOption

Members

Member name | Value | Description
All | 0 | All
Generous | 1 | Generous
Best | 2 | Best
Strict | 3 | Strict

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ICDataSourceSubType Enumeration

[image]

IceLib Technical Reference
ICDataSourceSubType Enumeration
See Also Send Feedback
Represents the data source sub type for a object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ICDataSourceSubType
Visual Basic
Public Enumeration ICDataSourceSubType

Members

Member name | Value | Description
None | 0 | Represents no data sub type.
Db2 | 1 | Represents a DB2 data sub type.
Informix | 2 | Represents an Informix data sub type.
Ingres | 3 | Represents an Ingres data sub type.
Oracle | 4 | Represents an Oracle data sub type.
MsAccess | 5 | Represents an MS Access data sub type.
MsSql | 6 | Represents an MS SQL data sub type.
Sybase | 7 | Represents a Sybase data sub type.
Other | 8 | Represents an Other data sub type.
IPlanet | 9 | Represents an iPlanet data sub type.
OpenLdap | 10 | Represents an Open LDAP data sub type.
ActiveDirectory | 11 | Represents an Active Directory data sub type.
MsOutlook | 12 | Represents a MS Outlook data sub type.
MsExchange | 13 | Represents a MS Exchange data sub type.
ININTextFile | 14 | Represents an ININ Text File data sub type.
ThinkDirectMarketing | 15 | Represents a Think Direct Marketing data sub type.
RediConnect | 16 | Represents a Redi-Connect data sub type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ICDataSourceType Enumeration

[image]

IceLib Technical Reference
ICDataSourceType Enumeration
See Also Send Feedback
Represents the data source type for a object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ICDataSourceType
Visual Basic
Public Enumeration ICDataSourceType

Members

Member name | Value | Description
None | 0 | Represents no data type.
Jdbc | 1 | Represents a JDBC data type.
JdbcOdbc | 2 | Represents a JDBC-ODBC data type.
Ldap | 3 | Represents an LDAP data type.
Mapi | 4 | Represents a MAPI data type.
Odbc | 5 | Represents an ODBC data type.
WhitePages | 6 | Represents a white pages data type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ImageMimeType Enumeration

[image]

IceLib Technical Reference
ImageMimeType Enumeration
See Also Send Feedback
Represents the image mime type for an ImageResourceCategoryConfiguration and an ImageResourceConfiguration.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ImageMimeType
Visual Basic
Public Enumeration ImageMimeType

Members

Member name | Value | Description
None | 0 | Represnts no mime type.
Tiff | 1 | Represents a TIFF mime type.
Jpeg | 2 | Represents a JPEG mime type.
Png | 3 | Represents a PNG mime type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


InteractionProcessAutomationLicenseType Enumeration

[image]

IceLib Technical Reference
InteractionProcessAutomationLicenseType Enumeration
See Also Send Feedback
Represents the Interaction Process Administration license type for user configuration licensing purposes.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionProcessAutomationLicenseType
Visual Basic
Public Enumeration InteractionProcessAutomationLicenseType

Members

Member name | Value | Description
None | 0 | No Interaction Process Administration license type was found.
DirectRoutedWorkItems | 1 | Direct Routed Work Items.
GroupRoutedWorkItems | 2 | Group Routed Work Items.
ProcessMonitor 3 Process Monitor.

Remarks

This is not valid for InteractionProcessAutomationLicenseType.
ProcessDesigner 4 Process Designer.

Remarks

This is not valid for InteractionProcessAutomationLicenseType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


KeywordCount Class

[image]

IceLib Technical Reference
KeywordCount Class
Members See Also Send Feedback
The Keyword Count information for a given langauge.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class KeywordCount
Visual Basic
Public Class KeywordCount

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..KeywordCount

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

KeywordCount Members
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCount Members

[image] [image]

IceLib Technical Reference
KeywordCount Members
KeywordCount Class Methods Properties See Also Send Feedback

The KeywordCount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExceedsKeywordCountLimit | True if this particular language exceeds the Keyword Count limit, false otherwise.
Public property | TotalKeywordCount | The total Keyword Count for this language.

See Also

KeywordCount Class
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCount Methods

[image] [image]

IceLib Technical Reference
KeywordCount Methods
KeywordCount Class See Also Send Feedback

The KeywordCount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeywordCount Class
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCount Properties

[image] [image]

IceLib Technical Reference
KeywordCount Properties
KeywordCount Class See Also Send Feedback

The KeywordCount type exposes the following members.

Properties

 | Name | Description
Public property | ExceedsKeywordCountLimit | True if this particular language exceeds the Keyword Count limit, false otherwise.
Public property | TotalKeywordCount | The total Keyword Count for this language.

See Also

KeywordCount Class
ININ.IceLib.Configuration.DataTypes Namespace


ExceedsKeywordCountLimit Property

[image]

IceLib Technical Reference
KeywordCount..::..ExceedsKeywordCountLimit Property
KeywordCount Class See Also Send Feedback
True if this particular language exceeds the Keyword Count limit, false otherwise.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ExceedsKeywordCountLimit { get; private set; }
Visual Basic
Public Property ExceedsKeywordCountLimit As Boolean
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

KeywordCount Class
KeywordCount Members
ININ.IceLib.Configuration.DataTypes Namespace


TotalKeywordCount Property

[image]

IceLib Technical Reference
KeywordCount..::..TotalKeywordCount Property
KeywordCount Class See Also Send Feedback
The total Keyword Count for this language.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TotalKeywordCount { get; private set; }
Visual Basic
Public Property TotalKeywordCount As Integer
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

KeywordCount Class
KeywordCount Members
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCountInformation Class

[image]

IceLib Technical Reference
KeywordCountInformation Class
Members See Also Send Feedback
The Keyword Count information.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class KeywordCountInformation
Visual Basic
Public Class KeywordCountInformation

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..KeywordCountInformation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

KeywordCountInformation Members
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCountInformation Members

[image] [image]

IceLib Technical Reference
KeywordCountInformation Members
KeywordCountInformation Class Methods Properties See Also Send Feedback

The KeywordCountInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | KeywordCountLimit | The maximum number of Keyword Counts per language that can be assigned to a Workgroup.
Public property | TotalKeywordCountsPerLanguage | The collection of total Keyword Counts per language.

See Also

KeywordCountInformation Class
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCountInformation Methods

[image] [image]

IceLib Technical Reference
KeywordCountInformation Methods
KeywordCountInformation Class See Also Send Feedback

The KeywordCountInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeywordCountInformation Class
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCountInformation Properties

[image] [image]

IceLib Technical Reference
KeywordCountInformation Properties
KeywordCountInformation Class See Also Send Feedback

The KeywordCountInformation type exposes the following members.

Properties

 | Name | Description
Public property | KeywordCountLimit | The maximum number of Keyword Counts per language that can be assigned to a Workgroup.
Public property | TotalKeywordCountsPerLanguage | The collection of total Keyword Counts per language.

See Also

KeywordCountInformation Class
ININ.IceLib.Configuration.DataTypes Namespace


KeywordCountLimit Property

[image]

IceLib Technical Reference
KeywordCountInformation..::..KeywordCountLimit Property
KeywordCountInformation Class See Also Send Feedback
The maximum number of Keyword Counts per language that can be assigned to a Workgroup.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int KeywordCountLimit { get; private set; }
Visual Basic
Public Property KeywordCountLimit As Integer
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

KeywordCountInformation Class
KeywordCountInformation Members
ININ.IceLib.Configuration.DataTypes Namespace


TotalKeywordCountsPerLanguage Property

[image]

IceLib Technical Reference
KeywordCountInformation..::..TotalKeywordCountsPerLanguage Property
KeywordCountInformation Class See Also Send Feedback
The collection of total Keyword Counts per language.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<CultureInfo, KeywordCount> TotalKeywordCountsPerLanguage { get; private set; }
Visual Basic
Public Property TotalKeywordCountsPerLanguage As IDictionary(Of CultureInfo, KeywordCount)
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

KeywordCountInformation Class
KeywordCountInformation Members
ININ.IceLib.Configuration.DataTypes Namespace


LicenseAllocationType Enumeration

[image]

IceLib Technical Reference
LicenseAllocationType Enumeration
See Also Send Feedback
Represents the License Allocation type used for Concurrent Licensing Purposes.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LicenseAllocationType
Visual Basic
Public Enumeration LicenseAllocationType

Members

Member name | Value | Description
Assignable | 0 | Assignable License Type.
Concurrent | 1 | Concurrent License Type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


LicenseAppliesToType Enumeration

[image]

IceLib Technical Reference
LicenseAppliesToType Enumeration
See Also Send Feedback
Represents the types of licenses that can be queried for.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LicenseAppliesToType
Visual Basic
Public Enumeration LicenseAppliesToType

Members

Member name | Value | Description
None | 0 | Represents the default, uninitialized value.
UsersAndStations | 1 | Represents licenses that can be applied to both Users and Stations.
Stations | 2 | Represents licenses that can be applied to Stations.
Users | 3 | Represents licenses that can be applied to Users.
All | 4 | Represents any license type.

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace
LicenseAllocationConfigurationList..::..SetLicenseAppliesToForQuery(LicenseAppliesToType)


LyncOption Enumeration

[image]

IceLib Technical Reference
LyncOption Enumeration
See Also Send Feedback
Represents the Lync Option for the LyncOption property.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum LyncOption
Visual Basic
<FlagsAttribute> _
Public Enumeration LyncOption

Members

Member name | Value | Description
None | 0 | Represents no Lync Options.
PublicConnectivity | 1 | Represents that public connectivity is enabled.
RemoteCallControl | 2 | Obsolete. Represents that remote call control is enabled.
OrganizeMeetingWithAnonymousParticipants | 4 | Obsolete. Represents the ability to allow meetings to be organized with anonymous participants.
UnifiedCommunications | 8 | Represents that unified communications is enabled.
EnhancedPresence | 16 | Obsolete. Represents that enhanced presence is enabled.
RemoteCallControlDualMode | 32 | Represents that remote call control is enabled.
AutoAttendantEnabled | 64 | Obsolete. Represents that auto attendant is enabled.

Remarks

RemoteCallControl, OrganizeMeetingWithAnonymousParticipants, EnhancedPresence, and AutoAttendantEnabled are not valid options for LyncOption. Additionally, LyncOption should not be treated as a flags enumeration. When setting the LyncOption property, only one of the valid values should be used: PublicConnectivity, UnifiedCommunications, or RemoteCallControlDualMode. In Interaction Administrator, these values correspond to "IM Only", "Enterprise Voice", and "Remote Call Control" respectively.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


MailboxDirectoryType Enumeration

[image]

IceLib Technical Reference
MailboxDirectoryType Enumeration
See Also Send Feedback
Represents the mailbox type for a MailboxDirectoryDefinition.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MailboxDirectoryType
Visual Basic
Public Enumeration MailboxDirectoryType

Members

Member name | Value | Description
Unknown | 0 | Represents an unknown mailbox type.
Mailbox | 1 | Represents a mailbox type.
DistributionList | 2 | Represents a distribution list type.
ForumEntry | 3 | Represents a forum entry type.
External | 4 | Represents an external type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


MediaLevel Enumeration

[image]

IceLib Technical Reference
MediaLevel Enumeration
See Also Send Feedback
Represents the media level for user configuration licensing purposes.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MediaLevel
Visual Basic
Public Enumeration MediaLevel

Members

Member name | Value | Description
None | 0 | No media level was found.
Media1 | 1 | Media level 1.
Media2 | 2 | Media level 2.
Media3 | 3 | Media level 3.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


MediaType Enumeration

[image]

IceLib Technical Reference
MediaType Enumeration
See Also Send Feedback
Represents the media type for user configuration licensing purposes.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MediaType
Visual Basic
Public Enumeration MediaType

Members

Member name | Value | Description
Invalid | 0 | An invalid media type was found.
Call | 1 | A call interaction.
Chat | 2 | A chat interaction.
Email | 3 | An email interaction.
Generic | 4 | A generic interaction.
Callback | 5 | A callback interaction.
WorkItem | 6 | A workitem interaction.
SocialConversation | 7 | A socialconversation interaction.
SocialDirectMessage | 8 | A directmessage interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


MonitoredMailboxType Enumeration

[image]

IceLib Technical Reference
MonitoredMailboxType Enumeration
See Also Send Feedback
Represents a monitored mailbox type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MonitoredMailboxType
Visual Basic
Public Enumeration MonitoredMailboxType

Members

Member name | Value | Description
None | 0 | Represents no mailbox type.
Inbound | 1 | Represents an inbound mailbox type.
Outbound | 2 | Represents an outbound mailbox type.
OutboundAndInbound | 3 | Represents an outbound and inbound mailbox type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


MultiLanguageString Class

[image]

IceLib Technical Reference
MultiLanguageString Class
Members See Also Send Feedback
Represents a multi-language string configuration value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MultiLanguageString : ComplexConfigurationDataType,
    IDeepCloneable, IEditable, IEditableViaProxy, IValueDefinedProvider
Visual Basic
Public Class MultiLanguageString _
    Inherits ComplexConfigurationDataType _
    Implements IDeepCloneable, IEditable, IEditableViaProxy, IValueDefinedProvider

Inheritance Hierarchy

System..::..Object
ComplexConfigurationDataType
ININ.IceLib.Configuration.DataTypes..::..MultiLanguageString

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


MultiLanguageString Members

[image] [image]

IceLib Technical Reference
MultiLanguageString Members
MultiLanguageString Class Methods Properties See Also Send Feedback

The MultiLanguageString type exposes the following members.

Methods

 | Name | Description
Public method | AddMultiLanguageValue | Adds the multi-language value. If a language value already exists, it is overwritten with the new value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveMultiLanguageValue | Removes the multi-language value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DefaultValue | Gets or sets the default value. The default value is non-locale specific.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | Items | Gets the multi-language items associated with this object.

See Also

MultiLanguageString Class
ININ.IceLib.Configuration.DataTypes Namespace


MultiLanguageString Methods

[image] [image]

IceLib Technical Reference
MultiLanguageString Methods
MultiLanguageString Class See Also Send Feedback

The MultiLanguageString type exposes the following members.

Methods

 | Name | Description
Public method | AddMultiLanguageValue | Adds the multi-language value. If a language value already exists, it is overwritten with the new value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveMultiLanguageValue | Removes the multi-language value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MultiLanguageString Class
ININ.IceLib.Configuration.DataTypes Namespace


AddMultiLanguageValue Method

[image]

IceLib Technical Reference
MultiLanguageString..::..AddMultiLanguageValue Method
MultiLanguageString Class See Also Send Feedback
Adds the multi-language value. If a language value already exists, it is overwritten with the new value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddMultiLanguageValue(
    string language,
    string value
)
Visual Basic
Public Sub AddMultiLanguageValue ( _
    language As String, _
    value As String _
)

Parameters

language
Type: System..::..String
The language.
value
Type: System..::..String
The value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
MultiLanguageString..::..Equals Method
MultiLanguageString Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
MultiLanguageString..::..GetHashCode Method
MultiLanguageString Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


RemoveMultiLanguageValue Method

[image]

IceLib Technical Reference
MultiLanguageString..::..RemoveMultiLanguageValue Method
MultiLanguageString Class See Also Send Feedback
Removes the multi-language value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveMultiLanguageValue(
    string language
)
Visual Basic
Public Sub RemoveMultiLanguageValue ( _
    language As String _
)

Parameters

language
Type: System..::..String
The language to remove.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
MultiLanguageString..::..ToString Method
MultiLanguageString Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


MultiLanguageString Properties

[image] [image]

IceLib Technical Reference
MultiLanguageString Properties
MultiLanguageString Class See Also Send Feedback

The MultiLanguageString type exposes the following members.

Properties

 | Name | Description
Public property | DefaultValue | Gets or sets the default value. The default value is non-locale specific.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | Items | Gets the multi-language items associated with this object.

See Also

MultiLanguageString Class
ININ.IceLib.Configuration.DataTypes Namespace


DefaultValue Property

[image]

IceLib Technical Reference
MultiLanguageString..::..DefaultValue Property
MultiLanguageString Class See Also Send Feedback
Gets or sets the default value. The default value is non-locale specific.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultValue { get; set; }
Visual Basic
Public Property DefaultValue As String
    Get
    Set

Field Value

The default value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


IsEditable Property

[image]

IceLib Technical Reference
MultiLanguageString..::..IsEditable Property
MultiLanguageString Class See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEditable..::..IsEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


Items Property

[image]

IceLib Technical Reference
MultiLanguageString..::..Items Property
MultiLanguageString Class See Also Send Feedback
Gets the multi-language items associated with this object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> Items { get; }
Visual Basic
Public ReadOnly Property Items As IDictionary(Of String, String)
    Get

Field Value

The multi-language items.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

MultiLanguageString Class
MultiLanguageString Members
ININ.IceLib.Configuration.DataTypes Namespace


MwiMode Enumeration

[image]

IceLib Technical Reference
MwiMode Enumeration
See Also Send Feedback
Represents the message waiting indicator mode.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MwiMode
Visual Basic
Public Enumeration MwiMode

Members

Member name | Value | Description
Default | 0 | Use the default.
Smdi | 1 | Obsolete. Use SMDI (Simplified Message Desk Interface).
Address | 2 | Use the address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


Orientation Enumeration

[image]

IceLib Technical Reference
Orientation Enumeration
See Also Send Feedback
The paper orientation of the report.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Orientation
Visual Basic
Public Enumeration Orientation

Members

Member name | Value | Description
None | 0 | Not assigned.
Portrait | 1 | Portrait.
Landscape | 2 | Landscape.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ParameterSource Enumeration

[image]

IceLib Technical Reference
ParameterSource Enumeration
See Also Send Feedback
Source of this parameter.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ParameterSource
Visual Basic
Public Enumeration ParameterSource

Members

Member name | Value | Description
None | 0 | Not assigned.
FixedToDefault | 1 | Parameter can only be a default value, entered by the report administrator.
UserSupplied | 2 | User must supply parameter.
Null | 3 | User must supply parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


QueueColumnAttributeType Enumeration

[image]

IceLib Technical Reference
QueueColumnAttributeType Enumeration
See Also Send Feedback
Represents the attribute type for a QueueColumn.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum QueueColumnAttributeType
Visual Basic
Public Enumeration QueueColumnAttributeType

Members

Member name | Value | Description
Invalid | 0 | An invalid attribute type was found.
Boolean | 1 | A boolean value.
String | 2 | A string value.
Number | 3 | A numeric value.
Timestamp | 4 | A timestamp value.
Duration | 5 | A duration value.
InteractionId | 6 | An InteractionId value.
MultiValueString | 7 | A collection of string values.
MultiValueNumber | 8 | A collection of numeric values.
MultiValueInteractionIds | 9 | A collection of InteractionId values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


RecurrencePatternType Enumeration

[image]

IceLib Technical Reference
RecurrencePatternType Enumeration
See Also Send Feedback
Represents the recurrence pattern type for a schedule.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RecurrencePatternType
Visual Basic
Public Enumeration RecurrencePatternType

Members

Member name | Value | Description
None | 0 | Recurrence pattern not specified.
OneTime | 1 | Schedule occurs only once.
Daily | 2 | Schedule repeates daily.
Weekly | 3 | Schedule repeats weekly.
Monthly | 4 | Schedule repeats monthly.
Yearly | 5 | Schedule repeats yearly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


RecurrenceRelativeDayType Enumeration

[image]

IceLib Technical Reference
RecurrenceRelativeDayType Enumeration
See Also Send Feedback
Represents the relative day recurrence type for a schedule. Used with RecurrenceRelativeMonthlyType to specify, e.g., the second Wednesday of the month.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RecurrenceRelativeDayType
Visual Basic
Public Enumeration RecurrenceRelativeDayType

Members

Member name | Value | Description
None | 0 | Recurrence day not specified.
Day | 1 | Schedule repeats on the matching day.
Monday | 2 | Schedule repeats on the matching Monday.
Tuesday | 3 | Schedule repeats on the matching Tuesday.
Wednesday | 4 | Schedule repeats on the matching Wednesday.
Thursday | 5 | Schedule repeats on the matching Thursday.
Friday | 6 | Schedule repeats on the matching Friday.
Saturday | 7 | Schedule repeats on the matching Saturday.
Sunday | 8 | Schedule repeats on the matching Sunday.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


RecurrenceRelativeMonthlyType Enumeration

[image]

IceLib Technical Reference
RecurrenceRelativeMonthlyType Enumeration
See Also Send Feedback
Represents the monthly recurrence instance type for a schedule. Used with RecurrenceRelativeDayType to specify, e.g., the second Wednesday of the month.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RecurrenceRelativeMonthlyType
Visual Basic
Public Enumeration RecurrenceRelativeMonthlyType

Members

Member name | Value | Description
None | 0 | Recurrence instance not specified.
First | 1 | Schedule repeats on the first matching day.
Second | 2 | Schedule repeats on the second matching day.
Third | 3 | Schedule repeats on the third matching day.
Fourth | 4 | Schedule repeats on the fourth matching day.
Last | 5 | Schedule repeats last matching day.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ReportingParameterDataType Enumeration

[image]

IceLib Technical Reference
ReportingParameterDataType Enumeration
See Also Send Feedback
Parameter data type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ReportingParameterDataType
Visual Basic
Public Enumeration ReportingParameterDataType

Members

Member name | Value | Description
None | 0 | Not assigned.
Boolean | 1 | Boolean.
Date | 2 | Date.
ICWorkflowName | 3 | ICWorkflowName.
Number | 4 | Number.
String | 5 | String.
Time | 6 | Time.
User | 7 | User.
DistributionQueue | 8 | DistributionQueue.
Role | 9 | Role.
Guid | 10 | GUID.
Duration | 11 | Duration.
CrystalString | 12 | CrystalString.
WhereClauseString | 13 | WhereClauseString.
OrderClauseString | 14 | OrderClauseString.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ReportingParameterTypes Enumeration

[image]

IceLib Technical Reference
ReportingParameterTypes Enumeration
See Also Send Feedback
The type of Report Parameter; tells the Report engine how to handle it.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum ReportingParameterTypes
Visual Basic
<FlagsAttribute> _
Public Enumeration ReportingParameterTypes

Members

Member name | Value | Description
SqlFilter | 1 | SqlFilter.
Threshold | 2 | Threshold.
Informational | 4 | Informational.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ReportType Enumeration

[image]

IceLib Technical Reference
ReportType Enumeration
See Also Send Feedback
The type of output for this meta data.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ReportType
Visual Basic
Public Enumeration ReportType

Members

Member name | Value | Description
None | 0 | Not assigned.
ActiveReport | 1 | ActiveReport.
LiveGraph | 2 | InfragisticsGraph.
CrystalReport | 3 | CrystalReport.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableDestinationType Enumeration

[image]

IceLib Technical Reference
RoutingTableDestinationType Enumeration
See Also Send Feedback
Represents the Destination Type for a Routing Table entry.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RoutingTableDestinationType
Visual Basic
Public Enumeration RoutingTableDestinationType

Members

Member name | Value | Description
None | 0 | Represents None.
User | 1 | Represents User.
Workgroup | 2 | Represents Workgroup.
Station | 3 | Represents Station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableEntrySettings Class

[image]

IceLib Technical Reference
RoutingTableEntrySettings Class
Members See Also Send Feedback
Represents an entry in the routing table.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RoutingTableEntrySettings : ComplexConfigurationDataType,
    IEditable, IEditableViaProxy, IDeepCloneable
Visual Basic
Public Class RoutingTableEntrySettings _
    Inherits ComplexConfigurationDataType _
    Implements IEditable, IEditableViaProxy, IDeepCloneable

Inheritance Hierarchy

System..::..Object
ComplexConfigurationDataType
ININ.IceLib.Configuration.DataTypes..::..RoutingTableEntrySettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableEntrySettings Members

[image] [image]

IceLib Technical Reference
RoutingTableEntrySettings Members
RoutingTableEntrySettings Class Constructors Methods Properties See Also Send Feedback

The RoutingTableEntrySettings type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingTableEntrySettings | Initializes a new instance of the RoutingTableEntrySettings class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Destination | Gets or sets the destination.
Public property | DestinationType | Gets or sets the type of the destination.
Public property | Dnis | Gets or sets the dnis.
Public property | Extension | Gets the destinations's extension.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | SubstitutionType | Gets or sets the type of the substitution.

See Also

RoutingTableEntrySettings Class
ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableEntrySettings Constructor

[image]

IceLib Technical Reference
RoutingTableEntrySettings Constructor
RoutingTableEntrySettings Class See Also Send Feedback
Initializes a new instance of the RoutingTableEntrySettings class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RoutingTableEntrySettings(
    string dnis,
    ConfigurationId destination,
    RoutingTableDestinationType destinationType,
    string extension,
    string description,
    RoutingTableSubstitutionType substitutionType
)
Visual Basic
Public Sub New ( _
    dnis As String, _
    destination As ConfigurationId, _
    destinationType As RoutingTableDestinationType, _
    extension As String, _
    description As String, _
    substitutionType As RoutingTableSubstitutionType _
)

Parameters

dnis
Type: System..::..String
The Dnis number
destination
Type: ININ.IceLib.Configuration..::..ConfigurationId
The destination.
destinationType
Type: ININ.IceLib.Configuration.DataTypes..::..RoutingTableDestinationType
Type of the destination.
extension
Type: System..::..String
The extension of the destination.
description
Type: System..::..String
The description.
substitutionType
Type: ININ.IceLib.Configuration.DataTypes..::..RoutingTableSubstitutionType
The substitution type.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | A parameter is not a valid enum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableEntrySettings Methods

[image] [image]

IceLib Technical Reference
RoutingTableEntrySettings Methods
RoutingTableEntrySettings Class See Also Send Feedback

The RoutingTableEntrySettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RoutingTableEntrySettings Class
ININ.IceLib.Configuration.DataTypes Namespace


Clone Method

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..Clone Method
RoutingTableEntrySettings Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..Equals Method
RoutingTableEntrySettings Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..GetHashCode Method
RoutingTableEntrySettings Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..ToString Method
RoutingTableEntrySettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableEntrySettings Properties

[image] [image]

IceLib Technical Reference
RoutingTableEntrySettings Properties
RoutingTableEntrySettings Class See Also Send Feedback

The RoutingTableEntrySettings type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Destination | Gets or sets the destination.
Public property | DestinationType | Gets or sets the type of the destination.
Public property | Dnis | Gets or sets the dnis.
Public property | Extension | Gets the destinations's extension.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | SubstitutionType | Gets or sets the type of the substitution.

See Also

RoutingTableEntrySettings Class
ININ.IceLib.Configuration.DataTypes Namespace


Description Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..Description Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets or sets the description.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Field Value

The description.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Destination Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..Destination Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets or sets the destination.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId Destination { get; set; }
Visual Basic
Public Property Destination As ConfigurationId
    Get
    Set

Field Value

The destination.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


DestinationType Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..DestinationType Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets or sets the type of the destination.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RoutingTableDestinationType DestinationType { get; set; }
Visual Basic
Public Property DestinationType As RoutingTableDestinationType
    Get
    Set

Field Value

The type of the destination.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Dnis Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..Dnis Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets or sets the dnis.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Dnis { get; set; }
Visual Basic
Public Property Dnis As String
    Get
    Set

Field Value

The dnis.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Extension Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..Extension Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets the destinations's extension.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; private set; }
Visual Basic
Public Property Extension As String
    Get
    Private Set

Field Value

The destinations's extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


IsEditable Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..IsEditable Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEditable..::..IsEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


SubstitutionType Property

[image]

IceLib Technical Reference
RoutingTableEntrySettings..::..SubstitutionType Property
RoutingTableEntrySettings Class See Also Send Feedback
Gets or sets the type of the substitution.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RoutingTableSubstitutionType SubstitutionType { get; set; }
Visual Basic
Public Property SubstitutionType As RoutingTableSubstitutionType
    Get
    Set

Field Value

The type of the substitution.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

RoutingTableEntrySettings Class
RoutingTableEntrySettings Members
ININ.IceLib.Configuration.DataTypes Namespace


RoutingTableSubstitutionType Enumeration

[image]

IceLib Technical Reference
RoutingTableSubstitutionType Enumeration
See Also Send Feedback
Represents the Substitution Type for a Routing Table entry.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RoutingTableSubstitutionType
Visual Basic
Public Enumeration RoutingTableSubstitutionType

Members

Member name | Value | Description
None | 0 | Represents none.
Replace | 1 | Represents replace.
Prefix | 2 | Represents prefix.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


SecureInputFormFieldDefinition Class

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition Class
Members See Also Send Feedback
Represents a SecureInputFormConfiguration's field definition.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecureInputFormFieldDefinition : ComplexConfigurationDataType,
    IDeepCloneable
Visual Basic
Public Class SecureInputFormFieldDefinition _
    Inherits ComplexConfigurationDataType _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ComplexConfigurationDataType
ININ.IceLib.Configuration.DataTypes..::..SecureInputFormFieldDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


SecureInputFormFieldDefinition Members

[image] [image]

IceLib Technical Reference
SecureInputFormFieldDefinition Members
SecureInputFormFieldDefinition Class Constructors Methods Properties See Also Send Feedback

The SecureInputFormFieldDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | SecureInputFormFieldDefinition | Initializes a new instance of the SecureInputFormFieldDefinition class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | Id | Gets the ID.

See Also

SecureInputFormFieldDefinition Class
ININ.IceLib.Configuration.DataTypes Namespace


SecureInputFormFieldDefinition Constructor

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition Constructor
SecureInputFormFieldDefinition Class See Also Send Feedback
Initializes a new instance of the SecureInputFormFieldDefinition class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureInputFormFieldDefinition(
    string id,
    string displayName
)
Visual Basic
Public Sub New ( _
    id As String, _
    displayName As String _
)

Parameters

id
Type: System..::..String
The ID.
displayName
Type: System..::..String
The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


SecureInputFormFieldDefinition Methods

[image] [image]

IceLib Technical Reference
SecureInputFormFieldDefinition Methods
SecureInputFormFieldDefinition Class See Also Send Feedback

The SecureInputFormFieldDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SecureInputFormFieldDefinition Class
ININ.IceLib.Configuration.DataTypes Namespace


Clone Method

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition..::..Clone Method
SecureInputFormFieldDefinition Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition..::..Equals Method
SecureInputFormFieldDefinition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition..::..GetHashCode Method
SecureInputFormFieldDefinition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition..::..ToString Method
SecureInputFormFieldDefinition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


SecureInputFormFieldDefinition Properties

[image] [image]

IceLib Technical Reference
SecureInputFormFieldDefinition Properties
SecureInputFormFieldDefinition Class See Also Send Feedback

The SecureInputFormFieldDefinition type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | Id | Gets the ID.

See Also

SecureInputFormFieldDefinition Class
ININ.IceLib.Configuration.DataTypes Namespace


DisplayName Property

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition..::..DisplayName Property
SecureInputFormFieldDefinition Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; private set; }
Visual Basic
Public Property DisplayName As String
    Get
    Private Set

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


Id Property

[image]

IceLib Technical Reference
SecureInputFormFieldDefinition..::..Id Property
SecureInputFormFieldDefinition Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputFormFieldDefinition Class
SecureInputFormFieldDefinition Members
ININ.IceLib.Configuration.DataTypes Namespace


SecureInputFormType Enumeration

[image]

IceLib Technical Reference
SecureInputFormType Enumeration
See Also Send Feedback
Represents a SecureInputFormConfiguration's form type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum SecureInputFormType
Visual Basic
Public Enumeration SecureInputFormType

Members

Member name | Value | Description
None | 0 | Represents no form type.
Custom | 1 | Represents a custom form type.
Simple | 2 | Represents a simple form type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Class

[image]

IceLib Technical Reference
SipAddress Class
Members See Also Send Feedback
Represents a SIP address.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SipAddress : IDeepCloneable
Visual Basic
Public Class SipAddress _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..SipAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Members

[image] [image]

IceLib Technical Reference
SipAddress Members
SipAddress Class Constructors Methods Fields Properties See Also Send Feedback

The SipAddress type exposes the following members.

Constructors

 | Name | Description
Public method | SipAddress(String) | Initializes a new instance of the SipAddress class.
Public method | SipAddress(String, String, Int32) | Initializes a new instance of the SipAddress class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
Empty | Represents an empty SIP address.

Properties

 | Name | Description
Public property | Address | Gets the address.

See Also

SipAddress Class
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Constructor

[image] [image]

IceLib Technical Reference
SipAddress Constructor
SipAddress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SipAddress(String) | Initializes a new instance of the SipAddress class.
Public method | SipAddress(String, String, Int32) | Initializes a new instance of the SipAddress class.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Constructor (String)

[image]

IceLib Technical Reference
SipAddress Constructor (String)
SipAddress Class See Also Send Feedback
Initializes a new instance of the SipAddress class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SipAddress(
    string alternateFormat
)
Visual Basic
Public Sub New ( _
    alternateFormat As String _
)

Parameters

alternateFormat
Type: System..::..String
The alternate format to use.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SipAddress Class
SipAddress Members
SipAddress Overload
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Constructor (String, String, Int32)

[image]

IceLib Technical Reference
SipAddress Constructor (String, String, Int32)
SipAddress Class See Also Send Feedback
Initializes a new instance of the SipAddress class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SipAddress(
    string user,
    string host,
    int port
)
Visual Basic
Public Sub New ( _
    user As String, _
    host As String, _
    port As Integer _
)

Parameters

user
Type: System..::..String
The user portion.
host
Type: System..::..String
The host portion.
port
Type: System..::..Int32
The port portion.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SipAddress Class
SipAddress Members
SipAddress Overload
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Fields

[image] [image]

IceLib Technical Reference
SipAddress Fields
SipAddress Class See Also Send Feedback

The SipAddress type exposes the following members.

Fields

Name | Description
Empty | Represents an empty SIP address.

See Also

SipAddress Class
ININ.IceLib.Configuration.DataTypes Namespace


Empty Field

[image]

IceLib Technical Reference
SipAddress..::..Empty Field
SipAddress Class See Also Send Feedback
Represents an empty SIP address.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly SipAddress Empty
Visual Basic
Public Shared ReadOnly Empty As SipAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Methods

[image] [image]

IceLib Technical Reference
SipAddress Methods
SipAddress Class See Also Send Feedback

The SipAddress type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a deep copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SipAddress Class
ININ.IceLib.Configuration.DataTypes Namespace


Clone Method

[image]

IceLib Technical Reference
SipAddress..::..Clone Method
SipAddress Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
SipAddress..::..Equals Method
SipAddress Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
SipAddress..::..GetHashCode Method
SipAddress Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
SipAddress..::..ToString Method
SipAddress Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


SipAddress Properties

[image] [image]

IceLib Technical Reference
SipAddress Properties
SipAddress Class See Also Send Feedback

The SipAddress type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the address.

See Also

SipAddress Class
ININ.IceLib.Configuration.DataTypes Namespace


Address Property

[image]

IceLib Technical Reference
SipAddress..::..Address Property
SipAddress Class See Also Send Feedback
Gets the address.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; }
Visual Basic
Public ReadOnly Property Address As String
    Get

Field Value

The address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SipAddress Class
SipAddress Members
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Class

[image]

IceLib Technical Reference
SkillSettings Class
Members See Also Send Feedback
Represents a user's configuration skill settings.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SkillSettings : ComplexConfigurationDataType,
    IEditable, IEditableViaProxy, IDeepCloneable
Visual Basic
Public Class SkillSettings _
    Inherits ComplexConfigurationDataType _
    Implements IEditable, IEditableViaProxy, IDeepCloneable

Inheritance Hierarchy

System..::..Object
ComplexConfigurationDataType
ININ.IceLib.Configuration.DataTypes..::..SkillSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Members

[image] [image]

IceLib Technical Reference
SkillSettings Members
SkillSettings Class Constructors Methods Properties See Also Send Feedback

The SkillSettings type exposes the following members.

Constructors

 | Name | Description
Public method | SkillSettings(String, Int32, Int32) | Initializes a new instance of the SkillSettings class.
Public method | SkillSettings(ConfigurationId, Int32, Int32) | Initializes a new instance of the SkillSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DesireToUse | Gets or sets the desire to use.
Public property | Id | Gets the ID.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | Proficiency | Gets or sets the proficiency.

See Also

SkillSettings Class
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Constructor

[image] [image]

IceLib Technical Reference
SkillSettings Constructor
SkillSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SkillSettings(String, Int32, Int32) | Initializes a new instance of the SkillSettings class.
Public method | SkillSettings(ConfigurationId, Int32, Int32) | Initializes a new instance of the SkillSettings class.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Constructor (String, Int32, Int32)

[image]

IceLib Technical Reference
SkillSettings Constructor (String, Int32, Int32)
SkillSettings Class See Also Send Feedback
Initializes a new instance of the SkillSettings class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SkillSettings(
    string id,
    int proficiency,
    int desireToUse
)
Visual Basic
Public Sub New ( _
    id As String, _
    proficiency As Integer, _
    desireToUse As Integer _
)

Parameters

id
Type: System..::..String
The ID.
proficiency
Type: System..::..Int32
The proficiency.
desireToUse
Type: System..::..Int32
The desire to use.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

SkillSettings Class
SkillSettings Members
SkillSettings Overload
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Constructor (ConfigurationId, Int32, Int32)

[image]

IceLib Technical Reference
SkillSettings Constructor (ConfigurationId, Int32, Int32)
SkillSettings Class See Also Send Feedback
Initializes a new instance of the SkillSettings class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SkillSettings(
    ConfigurationId id,
    int proficiency,
    int desireToUse
)
Visual Basic
Public Sub New ( _
    id As ConfigurationId, _
    proficiency As Integer, _
    desireToUse As Integer _
)

Parameters

id
Type: ININ.IceLib.Configuration..::..ConfigurationId
The ID.
proficiency
Type: System..::..Int32
The proficiency.
desireToUse
Type: System..::..Int32
The desire to use.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

SkillSettings Class
SkillSettings Members
SkillSettings Overload
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Methods

[image] [image]

IceLib Technical Reference
SkillSettings Methods
SkillSettings Class See Also Send Feedback

The SkillSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SkillSettings Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
SkillSettings..::..Equals Method
SkillSettings Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
SkillSettings..::..GetHashCode Method
SkillSettings Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
SkillSettings..::..ToString Method
SkillSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


SkillSettings Properties

[image] [image]

IceLib Technical Reference
SkillSettings Properties
SkillSettings Class See Also Send Feedback

The SkillSettings type exposes the following members.

Properties

 | Name | Description
Public property | DesireToUse | Gets or sets the desire to use.
Public property | Id | Gets the ID.
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | Proficiency | Gets or sets the proficiency.

See Also

SkillSettings Class
ININ.IceLib.Configuration.DataTypes Namespace


DesireToUse Property

[image]

IceLib Technical Reference
SkillSettings..::..DesireToUse Property
SkillSettings Class See Also Send Feedback
Gets or sets the desire to use.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int DesireToUse { get; set; }
Visual Basic
Public Property DesireToUse As Integer
    Get
    Set

Field Value

The desire to use.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Id Property

[image]

IceLib Technical Reference
SkillSettings..::..Id Property
SkillSettings Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConfigurationId Id { get; }
Visual Basic
Public ReadOnly Property Id As ConfigurationId
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


IsEditable Property

[image]

IceLib Technical Reference
SkillSettings..::..IsEditable Property
SkillSettings Class See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEditable..::..IsEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Proficiency Property

[image]

IceLib Technical Reference
SkillSettings..::..Proficiency Property
SkillSettings Class See Also Send Feedback
Gets or sets the proficiency.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Proficiency { get; set; }
Visual Basic
Public Property Proficiency As Integer
    Get
    Set

Field Value

The proficiency.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Modifying the value is only supported when editing an object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

SkillSettings Class
SkillSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


StationType Enumeration

[image]

IceLib Technical Reference
StationType Enumeration
See Also Send Feedback
Represents the type of a station.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StationType
Visual Basic
Public Enumeration StationType

Members

Member name | Value | Description
StandAlonePhone | 0 | A stand-alone phone station.
Workstation | 1 | A workstation.
StandAloneFaxMachine | 2 | A stand-alone FAX machine.
RemoteStation | 3 | A remote station.
UnifiedMessaging 4 A unified messaging station.

Remarks

This is not valid for a StationTemplateConfiguration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


StructuredParameter Class

[image]

IceLib Technical Reference
StructuredParameter Class
Members See Also Send Feedback
Represents a structured parameter value for a StructuredParameterConfiguration object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StructuredParameter : IDeepCloneable
Visual Basic
Public Class StructuredParameter _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..StructuredParameter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


StructuredParameter Members

[image] [image]

IceLib Technical Reference
StructuredParameter Members
StructuredParameter Class Constructors Methods Properties See Also Send Feedback

The StructuredParameter type exposes the following members.

Constructors

 | Name | Description
Public method | StructuredParameter | Initializes a new instance of the StructuredParameter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Name | Gets the name of the structured parameter.
Public property | ParameterType | Gets the structured parameter type.
Public property | Values | Gets the values for the structured parameter.

See Also

StructuredParameter Class
ININ.IceLib.Configuration.DataTypes Namespace


StructuredParameter Constructor

[image]

IceLib Technical Reference
StructuredParameter Constructor
StructuredParameter Class See Also Send Feedback
Initializes a new instance of the StructuredParameter class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StructuredParameter(
    string name,
    StructuredParameterType parameterType,
    IEnumerable<string> values
)
Visual Basic
Public Sub New ( _
    name As String, _
    parameterType As StructuredParameterType, _
    values As IEnumerable(Of String) _
)

Parameters

name
Type: System..::..String
The name of the structured parameter.
parameterType
Type: ININ.IceLib.Configuration.DataTypes..::..StructuredParameterType
The type of structured parameter.
values
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The values for the structured parameter.

Exceptions

Exception | Condition
System..::..ArgumentNullException | name or values is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | name is Empty.
System..::..ArgumentOutOfRangeException | parameterType is not a valid StructuredParameterType, or is None.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


StructuredParameter Methods

[image] [image]

IceLib Technical Reference
StructuredParameter Methods
StructuredParameter Class See Also Send Feedback

The StructuredParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StructuredParameter Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
StructuredParameter..::..Equals Method
StructuredParameter Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
StructuredParameter..::..GetHashCode Method
StructuredParameter Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
StructuredParameter..::..ToString Method
StructuredParameter Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


StructuredParameter Properties

[image] [image]

IceLib Technical Reference
StructuredParameter Properties
StructuredParameter Class See Also Send Feedback

The StructuredParameter type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of the structured parameter.
Public property | ParameterType | Gets the structured parameter type.
Public property | Values | Gets the values for the structured parameter.

See Also

StructuredParameter Class
ININ.IceLib.Configuration.DataTypes Namespace


Name Property

[image]

IceLib Technical Reference
StructuredParameter..::..Name Property
StructuredParameter Class See Also Send Feedback
Gets the name of the structured parameter.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

Field Value

The name of the structured parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


ParameterType Property

[image]

IceLib Technical Reference
StructuredParameter..::..ParameterType Property
StructuredParameter Class See Also Send Feedback
Gets the structured parameter type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StructuredParameterType ParameterType { get; private set; }
Visual Basic
Public Property ParameterType As StructuredParameterType
    Get
    Private Set

Field Value

The structured parameter type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


Values Property

[image]

IceLib Technical Reference
StructuredParameter..::..Values Property
StructuredParameter Class See Also Send Feedback
Gets the values for the structured parameter.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Values { get; }
Visual Basic
Public ReadOnly Property Values As ReadOnlyCollection(Of String)
    Get

Field Value

The values for the structured parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StructuredParameter Class
StructuredParameter Members
ININ.IceLib.Configuration.DataTypes Namespace


StructuredParameterType Enumeration

[image]

IceLib Technical Reference
StructuredParameterType Enumeration
See Also Send Feedback
Represents the structured parameter type for a StructuredParameter object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StructuredParameterType
Visual Basic
Public Enumeration StructuredParameterType

Members

Member name | Value | Description
None | 0 | Represents the default uninitialized value.
Encrypted | 1 | Represents an encrypted structured parameter.
MultiString | 2 | Represents a multi-string value structured parameter.
String | 3 | Represents a string value structured parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


Time Class

[image]

IceLib Technical Reference
Time Class
Members See Also Send Feedback
Represents a time configuration value.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Time : IDeepCloneable
Visual Basic
Public Class Time _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..Time

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Time Members
ININ.IceLib.Configuration.DataTypes Namespace


Time Members

[image] [image]

IceLib Technical Reference
Time Members
Time Class Constructors Methods Fields Properties See Also Send Feedback

The Time type exposes the following members.

Constructors

 | Name | Description
Public method | Time | Initializes a new instance of the Time class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
MinTime | Used as the start or end time for an all-day schedule.

Properties

 | Name | Description
Public property | TimeValue | Gets the time value for this instance.

See Also

Time Class
ININ.IceLib.Configuration.DataTypes Namespace


Time Constructor

[image]

IceLib Technical Reference
Time Constructor
Time Class See Also Send Feedback
Initializes a new instance of the Time class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Time(
    int hour,
    int minute,
    int second
)
Visual Basic
Public Sub New ( _
    hour As Integer, _
    minute As Integer, _
    second As Integer _
)

Parameters

hour
Type: System..::..Int32
The hour.
minute
Type: System..::..Int32
The minute.
second
Type: System..::..Int32
The seconds.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Time Class
Time Members
ININ.IceLib.Configuration.DataTypes Namespace


Time Fields

[image] [image]

IceLib Technical Reference
Time Fields
Time Class See Also Send Feedback

The Time type exposes the following members.

Fields

Name | Description
MinTime | Used as the start or end time for an all-day schedule.

See Also

Time Class
ININ.IceLib.Configuration.DataTypes Namespace


MinTime Field

[image]

IceLib Technical Reference
Time..::..MinTime Field
Time Class See Also Send Feedback
Used as the start or end time for an all-day schedule.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly Time MinTime
Visual Basic
Public Shared ReadOnly MinTime As Time

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Time Class
Time Members
ININ.IceLib.Configuration.DataTypes Namespace


Time Methods

[image] [image]

IceLib Technical Reference
Time Methods
Time Class See Also Send Feedback

The Time type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Time Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
Time..::..Equals Method
Time Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Time Class
Time Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
Time..::..GetHashCode Method
Time Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Time Class
Time Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
Time..::..ToString Method
Time Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Time Class
Time Members
ININ.IceLib.Configuration.DataTypes Namespace


Time Properties

[image] [image]

IceLib Technical Reference
Time Properties
Time Class See Also Send Feedback

The Time type exposes the following members.

Properties

 | Name | Description
Public property | TimeValue | Gets the time value for this instance.

See Also

Time Class
ININ.IceLib.Configuration.DataTypes Namespace


TimeValue Property

[image]

IceLib Technical Reference
Time..::..TimeValue Property
Time Class See Also Send Feedback
Gets the time value for this instance.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime TimeValue { get; private set; }
Visual Basic
Public Property TimeValue As DateTime
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Time Class
Time Members
ININ.IceLib.Configuration.DataTypes Namespace


TimeZoneDisplayNameType Enumeration

[image]

IceLib Technical Reference
TimeZoneDisplayNameType Enumeration
See Also Send Feedback
Represents the possible display names used to represent a time zone.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum TimeZoneDisplayNameType
Visual Basic
Public Enumeration TimeZoneDisplayNameType

Members

Member name | Value | Description
Normal | 0 | Represents a normal display name.
DaylightSavingTime | 1 | Represents a daylight saving time display name.
Standard | 2 | Represents a standard time display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


UtilizationSettings Class

[image]

IceLib Technical Reference
UtilizationSettings Class
Members See Also Send Feedback
Represents a user's configuration utilization settings.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UtilizationSettings : IEditable,
    IEditableViaProxy, IDeepCloneable
Visual Basic
Public Class UtilizationSettings _
    Implements IEditable, IEditableViaProxy, IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.DataTypes..::..UtilizationSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


UtilizationSettings Members

[image] [image]

IceLib Technical Reference
UtilizationSettings Members
UtilizationSettings Class Constructors Methods Properties See Also Send Feedback

The UtilizationSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UtilizationSettings | Initializes a new instance of the UtilizationSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | MaxAssignable | Gets or sets the max assignable.
Public property | MediaType | Gets or sets the type of the media.
Public property | Utilization | Gets or sets the utilization.

See Also

UtilizationSettings Class
ININ.IceLib.Configuration.DataTypes Namespace


UtilizationSettings Constructor

[image]

IceLib Technical Reference
UtilizationSettings Constructor
UtilizationSettings Class See Also Send Feedback
Initializes a new instance of the UtilizationSettings class.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UtilizationSettings(
    MediaType mediaType,
    int utilization,
    int maxAssignable
)
Visual Basic
Public Sub New ( _
    mediaType As MediaType, _
    utilization As Integer, _
    maxAssignable As Integer _
)

Parameters

mediaType
Type: ININ.IceLib.Configuration.DataTypes..::..MediaType
Type of the media.
utilization
Type: System..::..Int32
The utilization.
maxAssignable
Type: System..::..Int32
The max assignable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


UtilizationSettings Methods

[image] [image]

IceLib Technical Reference
UtilizationSettings Methods
UtilizationSettings Class See Also Send Feedback

The UtilizationSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

UtilizationSettings Class
ININ.IceLib.Configuration.DataTypes Namespace


Equals Method

[image]

IceLib Technical Reference
UtilizationSettings..::..Equals Method
UtilizationSettings Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


GetHashCode Method

[image]

IceLib Technical Reference
UtilizationSettings..::..GetHashCode Method
UtilizationSettings Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


ToString Method

[image]

IceLib Technical Reference
UtilizationSettings..::..ToString Method
UtilizationSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


UtilizationSettings Properties

[image] [image]

IceLib Technical Reference
UtilizationSettings Properties
UtilizationSettings Class See Also Send Feedback

The UtilizationSettings type exposes the following members.

Properties

 | Name | Description
Public property | IsEditable | Gets a value indicating whether this instance is in an editable state.
Public property | MaxAssignable | Gets or sets the max assignable.
Public property | MediaType | Gets or sets the type of the media.
Public property | Utilization | Gets or sets the utilization.

See Also

UtilizationSettings Class
ININ.IceLib.Configuration.DataTypes Namespace


IsEditable Property

[image]

IceLib Technical Reference
UtilizationSettings..::..IsEditable Property
UtilizationSettings Class See Also Send Feedback
Gets a value indicating whether this instance is in an editable state.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in an editable state; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEditable..::..IsEditable

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


MaxAssignable Property

[image]

IceLib Technical Reference
UtilizationSettings..::..MaxAssignable Property
UtilizationSettings Class See Also Send Feedback
Gets or sets the max assignable.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaxAssignable { get; set; }
Visual Basic
Public Property MaxAssignable As Integer
    Get
    Set

Field Value

The max assignable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


MediaType Property

[image]

IceLib Technical Reference
UtilizationSettings..::..MediaType Property
UtilizationSettings Class See Also Send Feedback
Gets or sets the type of the media.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MediaType MediaType { get; set; }
Visual Basic
Public Property MediaType As MediaType
    Get
    Set

Field Value

The type of the media.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


Utilization Property

[image]

IceLib Technical Reference
UtilizationSettings..::..Utilization Property
UtilizationSettings Class See Also Send Feedback
Gets or sets the utilization.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Utilization { get; set; }
Visual Basic
Public Property Utilization As Integer
    Get
    Set

Field Value

The utilization.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UtilizationSettings Class
UtilizationSettings Members
ININ.IceLib.Configuration.DataTypes Namespace


WorkgroupQueueType Enumeration

[image]

IceLib Technical Reference
WorkgroupQueueType Enumeration
See Also Send Feedback
Represents the Queue Type for Workgroups.

Namespace: ININ.IceLib.Configuration.DataTypes
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum WorkgroupQueueType
Visual Basic
Public Enumeration WorkgroupQueueType

Members

Member name | Value | Description
None | 0 | Represents no queue type.
Custom | 1 | Represents a custom queue.
GroupRing | 2 | Represents a group ring queue.
Sequential | 3 | Represents a sequential queue.
RoundRobin | 4 | Represents a round robin queue.
Acd | 5 | Represents an ACD queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.DataTypes Namespace


ININ.IceLib.Configuration.EFaq Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.EFaq Namespace
Send Feedback

The ININ.IceLib.Configuration.EFaq namespace contains classes that provide support for EFaq configuration.

Classes

 | Class | Description
Public class | EFaqConfiguration | Contains configuration and administration settings for an IC EFaq.
Public class | EFaqConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | EFaqConfigurationList | Allows for querying and managing EFaq configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | EFaqConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


EFaqConfiguration Class

[image]

IceLib Technical Reference
EFaqConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC EFaq.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqConfiguration : ListConfigurationObject
Visual Basic
Public Class EFaqConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.EFaq..::..EFaqConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EFaqConfiguration Members
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration Members

[image] [image]

IceLib Technical Reference
EFaqConfiguration Members
EFaqConfiguration Class Methods Properties See Also Send Feedback

The EFaqConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

EFaqConfiguration Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration Methods

[image] [image]

IceLib Technical Reference
EFaqConfiguration Methods
EFaqConfiguration Class See Also Send Feedback

The EFaqConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

EFaqConfiguration Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration Properties

[image] [image]

IceLib Technical Reference
EFaqConfiguration Properties
EFaqConfiguration Class See Also Send Feedback

The EFaqConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

EFaqConfiguration Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration.Property Enumeration

[image]

IceLib Technical Reference
EFaqConfiguration..::..Property Enumeration
EFaqConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration.Rights Class

[image]

IceLib Technical Reference
EFaqConfiguration..::..Rights Class
EFaqConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.EFaq..::..EFaqConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EFaqConfiguration..::..Rights Members
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
EFaqConfiguration..::..Rights Members
EFaqConfiguration..::..Rights Class Properties See Also Send Feedback

The EFaqConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

EFaqConfiguration..::..Rights Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
EFaqConfiguration..::..Rights Properties
EFaqConfiguration..::..Rights Class See Also Send Feedback

The EFaqConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

EFaqConfiguration..::..Rights Class
ININ.IceLib.Configuration.EFaq Namespace


Admin Property

[image]

IceLib Technical Reference
EFaqConfiguration..::..Rights..::..Admin Property
EFaqConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<EFaqConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of EFaqConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EFaqConfiguration..::..Rights Class
EFaqConfiguration..::..Rights Members
ININ.IceLib.Configuration.EFaq Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..EFaq


View Property

[image]

IceLib Technical Reference
EFaqConfiguration..::..Rights..::..View Property
EFaqConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<EFaqConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of EFaqConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EFaqConfiguration..::..Rights Class
EFaqConfiguration..::..Rights Members
ININ.IceLib.Configuration.EFaq Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..EFaqs


EFaqConfigurationList Class

[image]

IceLib Technical Reference
EFaqConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing EFaq configuration objects.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqConfigurationList : DynamicConfigurationList<EFaqConfiguration, EFaqConfiguration..::..Property>
Visual Basic
Public Class EFaqConfigurationList _
    Inherits DynamicConfigurationList(Of EFaqConfiguration, EFaqConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' EFaqConfiguration, EFaqConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' EFaqConfiguration, EFaqConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.EFaq..::..EFaqConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EFaqConfigurationList Members
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfigurationList Members

[image] [image]

IceLib Technical Reference
EFaqConfigurationList Members
EFaqConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The EFaqConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | EFaqConfigurationList | Initializes a new instance of the EFaqConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

EFaqConfigurationList Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfigurationList Constructor

[image]

IceLib Technical Reference
EFaqConfigurationList Constructor
EFaqConfigurationList Class See Also Send Feedback
Initializes a new instance of the EFaqConfigurationList class.

Namespace: ININ.IceLib.Configuration.EFaq
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EFaqConfigurationList Class
EFaqConfigurationList Members
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfigurationList Methods

[image] [image]

IceLib Technical Reference
EFaqConfigurationList Methods
EFaqConfigurationList Class See Also Send Feedback

The EFaqConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqConfigurationList Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfigurationList Properties

[image] [image]

IceLib Technical Reference
EFaqConfigurationList Properties
EFaqConfigurationList Class See Also Send Feedback

The EFaqConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

EFaqConfigurationList Class
ININ.IceLib.Configuration.EFaq Namespace


EFaqConfigurationList Events

[image] [image]

IceLib Technical Reference
EFaqConfigurationList Events
EFaqConfigurationList Class See Also Send Feedback

The EFaqConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

EFaqConfigurationList Class
ININ.IceLib.Configuration.EFaq Namespace


ININ.IceLib.Configuration.Feedback Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Feedback Namespace
Send Feedback

The ININ.IceLib.Configuration.Feedback namespace contains classes that provide support for feedback configuration.

Classes

 | Class | Description
Public class | FeedbackSurveyConfiguration | Contains configuration and administration settings for an IC Feedback survey.
Public class | FeedbackSurveyConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | FeedbackSurveyConfigurationList | Allows for querying and managing Feedback configuration objects.
Public class | FeedbackSurveyGroupConfiguration | Contains configuration and administration settings for an IC FeedbackSurveyGroup.
Public class | FeedbackSurveyGroupConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | FeedbackSurveyGroupConfigurationList | Allows for querying and managing FeedbackSurveyGroup configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | FeedbackSurveyConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | FeedbackSurveyGroupConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


FeedbackSurveyConfiguration Class

[image]

IceLib Technical Reference
FeedbackSurveyConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Feedback survey.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FeedbackSurveyConfiguration : ListConfigurationObject
Visual Basic
Public Class FeedbackSurveyConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfiguration Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration Members

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfiguration Members
FeedbackSurveyConfiguration Class Methods Properties See Also Send Feedback

The FeedbackSurveyConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

FeedbackSurveyConfiguration Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration Methods

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfiguration Methods
FeedbackSurveyConfiguration Class See Also Send Feedback

The FeedbackSurveyConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

FeedbackSurveyConfiguration Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration Properties

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfiguration Properties
FeedbackSurveyConfiguration Class See Also Send Feedback

The FeedbackSurveyConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

FeedbackSurveyConfiguration Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration.Property Enumeration

[image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Property Enumeration
FeedbackSurveyConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration.Rights Class

[image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Rights Class
FeedbackSurveyConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Rights Members
FeedbackSurveyConfiguration..::..Rights Class Properties See Also Send Feedback

The FeedbackSurveyConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the access rights filter.
View | Gets the view rights filter.

See Also

FeedbackSurveyConfiguration..::..Rights Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Rights Properties
FeedbackSurveyConfiguration..::..Rights Class See Also Send Feedback

The FeedbackSurveyConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the access rights filter.
View | Gets the view rights filter.

See Also

FeedbackSurveyConfiguration..::..Rights Class
ININ.IceLib.Configuration.Feedback Namespace


Admin Property

[image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Rights..::..Admin Property
FeedbackSurveyConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeedbackSurveyConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of FeedbackSurveyConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfiguration..::..Rights Class
FeedbackSurveyConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionFeedbackConfiguration


Modify Property

[image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Rights..::..Modify Property
FeedbackSurveyConfiguration..::..Rights Class See Also Send Feedback
Gets the access rights filter.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeedbackSurveyConfiguration> Modify { get; private set; }
Visual Basic
Public Shared Property Modify As RightsQueryFilter(Of FeedbackSurveyConfiguration)
    Get
    Private Set

Field Value

The access right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfiguration..::..Rights Class
FeedbackSurveyConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyFeedbackSurveys


View Property

[image]

IceLib Technical Reference
FeedbackSurveyConfiguration..::..Rights..::..View Property
FeedbackSurveyConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeedbackSurveyConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of FeedbackSurveyConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfiguration..::..Rights Class
FeedbackSurveyConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewFeedbackSurveys


FeedbackSurveyConfigurationList Class

[image]

IceLib Technical Reference
FeedbackSurveyConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Feedback configuration objects.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FeedbackSurveyConfigurationList : DynamicConfigurationList<FeedbackSurveyConfiguration, FeedbackSurveyConfiguration..::..Property>
Visual Basic
Public Class FeedbackSurveyConfigurationList _
    Inherits DynamicConfigurationList(Of FeedbackSurveyConfiguration, FeedbackSurveyConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' FeedbackSurveyConfiguration, FeedbackSurveyConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' FeedbackSurveyConfiguration, FeedbackSurveyConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfigurationList Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfigurationList Members

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfigurationList Members
FeedbackSurveyConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The FeedbackSurveyConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | FeedbackSurveyConfigurationList | Initializes a new instance of the FeedbackSurveyConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeedbackSurveyConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfigurationList Constructor

[image]

IceLib Technical Reference
FeedbackSurveyConfigurationList Constructor
FeedbackSurveyConfigurationList Class See Also Send Feedback
Initializes a new instance of the FeedbackSurveyConfigurationList class.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FeedbackSurveyConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyConfigurationList Class
FeedbackSurveyConfigurationList Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfigurationList Methods

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfigurationList Methods
FeedbackSurveyConfigurationList Class See Also Send Feedback

The FeedbackSurveyConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FeedbackSurveyConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfigurationList Properties

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfigurationList Properties
FeedbackSurveyConfigurationList Class See Also Send Feedback

The FeedbackSurveyConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeedbackSurveyConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyConfigurationList Events

[image] [image]

IceLib Technical Reference
FeedbackSurveyConfigurationList Events
FeedbackSurveyConfigurationList Class See Also Send Feedback

The FeedbackSurveyConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeedbackSurveyConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration Class

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC FeedbackSurveyGroup.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FeedbackSurveyGroupConfiguration : ListConfigurationObject
Visual Basic
Public Class FeedbackSurveyGroupConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyGroupConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyGroupConfiguration Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration Members

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration Members
FeedbackSurveyGroupConfiguration Class Methods Properties See Also Send Feedback

The FeedbackSurveyGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

FeedbackSurveyGroupConfiguration Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration Methods

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration Methods
FeedbackSurveyGroupConfiguration Class See Also Send Feedback

The FeedbackSurveyGroupConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

FeedbackSurveyGroupConfiguration Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration Properties

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration Properties
FeedbackSurveyGroupConfiguration Class See Also Send Feedback

The FeedbackSurveyGroupConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

FeedbackSurveyGroupConfiguration Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration.Property Enumeration

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration..::..Property Enumeration
FeedbackSurveyGroupConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration.Rights Class

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration..::..Rights Class
FeedbackSurveyGroupConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyGroupConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration..::..Rights Members
FeedbackSurveyGroupConfiguration..::..Rights Class Properties See Also Send Feedback

The FeedbackSurveyGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

FeedbackSurveyGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration..::..Rights Properties
FeedbackSurveyGroupConfiguration..::..Rights Class See Also Send Feedback

The FeedbackSurveyGroupConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

FeedbackSurveyGroupConfiguration..::..Rights Class
ININ.IceLib.Configuration.Feedback Namespace


Admin Property

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration..::..Rights..::..Admin Property
FeedbackSurveyGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeedbackSurveyGroupConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of FeedbackSurveyGroupConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyGroupConfiguration..::..Rights Class
FeedbackSurveyGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace


View Property

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfiguration..::..Rights..::..View Property
FeedbackSurveyGroupConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<FeedbackSurveyGroupConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of FeedbackSurveyGroupConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyGroupConfiguration..::..Rights Class
FeedbackSurveyGroupConfiguration..::..Rights Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfigurationList Class

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing FeedbackSurveyGroup configuration objects.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FeedbackSurveyGroupConfigurationList : DynamicConfigurationList<FeedbackSurveyGroupConfiguration, FeedbackSurveyGroupConfiguration..::..Property>
Visual Basic
Public Class FeedbackSurveyGroupConfigurationList _
    Inherits DynamicConfigurationList(Of FeedbackSurveyGroupConfiguration, FeedbackSurveyGroupConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' FeedbackSurveyGroupConfiguration, FeedbackSurveyGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' FeedbackSurveyGroupConfiguration, FeedbackSurveyGroupConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Feedback..::..FeedbackSurveyGroupConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyGroupConfigurationList Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfigurationList Members

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfigurationList Members
FeedbackSurveyGroupConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The FeedbackSurveyGroupConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | FeedbackSurveyGroupConfigurationList | Initializes a new instance of the FeedbackSurveyGroupConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeedbackSurveyGroupConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfigurationList Constructor

[image]

IceLib Technical Reference
FeedbackSurveyGroupConfigurationList Constructor
FeedbackSurveyGroupConfigurationList Class See Also Send Feedback
Initializes a new instance of the FeedbackSurveyGroupConfigurationList class.

Namespace: ININ.IceLib.Configuration.Feedback
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FeedbackSurveyGroupConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FeedbackSurveyGroupConfigurationList Class
FeedbackSurveyGroupConfigurationList Members
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfigurationList Methods

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfigurationList Methods
FeedbackSurveyGroupConfigurationList Class See Also Send Feedback

The FeedbackSurveyGroupConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FeedbackSurveyGroupConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfigurationList Properties

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfigurationList Properties
FeedbackSurveyGroupConfigurationList Class See Also Send Feedback

The FeedbackSurveyGroupConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeedbackSurveyGroupConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


FeedbackSurveyGroupConfigurationList Events

[image] [image]

IceLib Technical Reference
FeedbackSurveyGroupConfigurationList Events
FeedbackSurveyGroupConfigurationList Class See Also Send Feedback

The FeedbackSurveyGroupConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

FeedbackSurveyGroupConfigurationList Class
ININ.IceLib.Configuration.Feedback Namespace


ININ.IceLib.Configuration.Integrations.Salesforce Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Integrations.Salesforce Namespace
Send Feedback

The ININ.IceLib.Configuration.Integrations.Salesforce namespace contains classes that provide support for configuration relating to the Salesforce.com integration.

Classes

 | Class | Description
Public class | CtiAttributeMapConfiguration | Obsolete. Contains configuration of call attributes to be synchronized to the Salesforce activity.
Public class | CtiAttributeMapConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | CtiConfiguration | Obsolete. Contains configuration and administration settings for the Salesforce integration.
Public class | CtiConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | CtiConfigurationList | Obsolete. Allows for querying and managing cti configuration objects.
Public class | CtiQueryChildrenSettings | Obsolete. Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects.

Enumerations

 | Enumeration | Description
Public enumeration | CtiAttributeMapConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | CtiConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.


CtiAttributeMapConfiguration Class

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration Class
Members See Also Send Feedback
Contains configuration of call attributes to be synchronized to the Salesforce activity.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")]
public class CtiAttributeMapConfiguration : EditableListConfigurationObject<CtiAttributeMapConfiguration..::..Property>
Visual Basic
<ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")> _
Public Class CtiAttributeMapConfiguration _
    Inherits EditableListConfigurationObject(Of CtiAttributeMapConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' CtiAttributeMapConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiAttributeMapConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfigurationList
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfiguration


CtiAttributeMapConfiguration Members

[image] [image]

IceLib Technical Reference
CtiAttributeMapConfiguration Members
CtiAttributeMapConfiguration Class Methods Properties See Also Send Feedback

The CtiAttributeMapConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | CtiAttributeMapConfiguration does not directly support commit, use the parent CtiConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | CallAttribute | The name of the call attribute to sync to Salesforce.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsDateTimeAttribute | Specifies if the call attribute is a Date/Time value.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | SalesforceField | The field in a Salesforce Activity to set the call attribute to.
Public property | SyncOnInbound | Specifies if the attribute should be mapped for inbound calls.
Public property | SyncOnOutbound | Specifies if the attribute should be mapped for outbound calls.

See Also

CtiAttributeMapConfiguration Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiAttributeMapConfiguration Methods

[image] [image]

IceLib Technical Reference
CtiAttributeMapConfiguration Methods
CtiAttributeMapConfiguration Class See Also Send Feedback

The CtiAttributeMapConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | CtiAttributeMapConfiguration does not directly support commit, use the parent CtiConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>..::..Commit()()()().)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

CtiAttributeMapConfiguration Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


Commit Method

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Commit Method
CtiAttributeMapConfiguration Class See Also Send Feedback
CtiAttributeMapConfiguration does not directly support commit, use the parent CtiConfiguration's Commit()()()() instead.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Exceptions

Exception | Condition
System..::..NotSupportedException | CtiAttributeMapConfiguration do not directly support commit, use commit on the parent CtiConfiguration instead.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Class
CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiAttributeMapConfiguration Properties

[image] [image]

IceLib Technical Reference
CtiAttributeMapConfiguration Properties
CtiAttributeMapConfiguration Class See Also Send Feedback

The CtiAttributeMapConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | CallAttribute | The name of the call attribute to sync to Salesforce.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsDateTimeAttribute | Specifies if the call attribute is a Date/Time value.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | SalesforceField | The field in a Salesforce Activity to set the call attribute to.
Public property | SyncOnInbound | Specifies if the attribute should be mapped for inbound calls.
Public property | SyncOnOutbound | Specifies if the attribute should be mapped for outbound calls.

See Also

CtiAttributeMapConfiguration Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CallAttribute Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..CallAttribute Property
CtiAttributeMapConfiguration Class See Also Send Feedback
The name of the call attribute to sync to Salesforce.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiAttributeMapConfiguration..::..Property, string> CallAttribute { get; }
Visual Basic
Public ReadOnly Property CallAttribute As GeneralConfigurationProperty(Of CtiAttributeMapConfiguration..::..Property, String)
    Get

Field Value

The call attribute name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Class
CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


IsDateTimeAttribute Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..IsDateTimeAttribute Property
CtiAttributeMapConfiguration Class See Also Send Feedback
Specifies if the call attribute is a Date/Time value.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiAttributeMapConfiguration..::..Property, bool> IsDateTimeAttribute { get; }
Visual Basic
Public ReadOnly Property IsDateTimeAttribute As GeneralConfigurationProperty(Of CtiAttributeMapConfiguration..::..Property, Boolean)
    Get

Field Value

True if the call attribute is a Date/Time value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Class
CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SalesforceField Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..SalesforceField Property
CtiAttributeMapConfiguration Class See Also Send Feedback
The field in a Salesforce Activity to set the call attribute to.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiAttributeMapConfiguration..::..Property, string> SalesforceField { get; }
Visual Basic
Public ReadOnly Property SalesforceField As GeneralConfigurationProperty(Of CtiAttributeMapConfiguration..::..Property, String)
    Get

Field Value

The Salesforce field name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Class
CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SyncOnInbound Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..SyncOnInbound Property
CtiAttributeMapConfiguration Class See Also Send Feedback
Specifies if the attribute should be mapped for inbound calls.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiAttributeMapConfiguration..::..Property, bool> SyncOnInbound { get; }
Visual Basic
Public ReadOnly Property SyncOnInbound As GeneralConfigurationProperty(Of CtiAttributeMapConfiguration..::..Property, Boolean)
    Get

Field Value

True to mapp this attribute for inbound calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Class
CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SyncOnOutbound Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..SyncOnOutbound Property
CtiAttributeMapConfiguration Class See Also Send Feedback
Specifies if the attribute should be mapped for outbound calls.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiAttributeMapConfiguration..::..Property, bool> SyncOnOutbound { get; }
Visual Basic
Public ReadOnly Property SyncOnOutbound As GeneralConfigurationProperty(Of CtiAttributeMapConfiguration..::..Property, Boolean)
    Get

Field Value

True to mapp this attribute for outbound calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiAttributeMapConfiguration Class
CtiAttributeMapConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiAttributeMapConfiguration.Property Enumeration

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Property Enumeration
CtiAttributeMapConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
CallAttribute | 0 | Represents the CallAttribute property.
SalesforceField | 1 | Represents the SalesforceField property.
SyncOnInbound | 2 | Represents the SyncOnInbound property.
SyncOnOutbound | 3 | Represents the SyncOnOutbound property.
IsDateTimeAttribute | 4 | Represents the IsDateTimeAttribute property.
DisplayName | 5 | Represents the DisplayName part of the ConfigurationId property.
Id | 6 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiAttributeMapConfiguration.Rights Class

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Rights Class
CtiAttributeMapConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiAttributeMapConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CtiAttributeMapConfiguration..::..Rights Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiAttributeMapConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Rights Members
CtiAttributeMapConfiguration..::..Rights Class Properties See Also Send Feedback

The CtiAttributeMapConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

CtiAttributeMapConfiguration..::..Rights Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiAttributeMapConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Rights Properties
CtiAttributeMapConfiguration..::..Rights Class See Also Send Feedback

The CtiAttributeMapConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

CtiAttributeMapConfiguration..::..Rights Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


Admin Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Rights..::..Admin Property
CtiAttributeMapConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<CtiAttributeMapConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of CtiAttributeMapConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CtiAttributeMapConfiguration..::..Rights Class
CtiAttributeMapConfiguration..::..Rights Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


View Property

[image]

IceLib Technical Reference
CtiAttributeMapConfiguration..::..Rights..::..View Property
CtiAttributeMapConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<CtiAttributeMapConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of CtiAttributeMapConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CtiAttributeMapConfiguration..::..Rights Class
CtiAttributeMapConfiguration..::..Rights Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration Class

[image]

IceLib Technical Reference
CtiConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for the Salesforce integration.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")]
public class CtiConfiguration : EditableListConfigurationObject<CtiConfiguration..::..Property>
Visual Basic
<ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")> _
Public Class CtiConfiguration _
    Inherits EditableListConfigurationObject(Of CtiConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' CtiConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfigurationList
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiAttributeMapConfiguration


CtiConfiguration Members

[image] [image]

IceLib Technical Reference
CtiConfiguration Members
CtiConfiguration Class Methods Properties See Also Send Feedback

The CtiConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AttributeMappings | Provides access to the property representing the configurations for this configuration list (use Property.CtiAttributeMaps).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CreateCallLogForInternalCalls | Create a call log for internal calls.
Public property | CreateCallLogOnInteractionsNotConnected | Create Salesforce Call Log Activity on Interactions that have not been connected.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OpenAndEditCallLogOnDisconnect | When an Interaction disconnects, the Salesforce Call Log will automatically open in edit mode in the Last Calls section of the Softphone.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PopAccountCodeDialogOnDisconnect | When an Interaction disconnects, pop the account code dialog.
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | SaveWrapTimeField | Save wrap up time.
Public property | SendScreenPopOnAlerting | Add inbound interaction to Salesforce Softphone on Alerting event.
Public property | ShowAdvancedTransferButton | Determines if the advanced transfer dialog should be shown in the CTI.
Public property | ShowSpeedDial | Determines if the speed dial should be shown in the CTI.
Public property | SpeedDialDirectory | Directory name to use for the speed dial.
Public property | SpeedDialNumber | Contact number to use in the speed dial.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | UseAdvancedDial | Use the advanced dial functionality.

See Also

CtiConfiguration Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration Methods

[image] [image]

IceLib Technical Reference
CtiConfiguration Methods
CtiConfiguration Class See Also Send Feedback

The CtiConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

CtiConfiguration Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration Properties

[image] [image]

IceLib Technical Reference
CtiConfiguration Properties
CtiConfiguration Class See Also Send Feedback

The CtiConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMappings | Provides access to the property representing the configurations for this configuration list (use Property.CtiAttributeMaps).
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CreateCallLogForInternalCalls | Create a call log for internal calls.
Public property | CreateCallLogOnInteractionsNotConnected | Create Salesforce Call Log Activity on Interactions that have not been connected.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OpenAndEditCallLogOnDisconnect | When an Interaction disconnects, the Salesforce Call Log will automatically open in edit mode in the Last Calls section of the Softphone.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PopAccountCodeDialogOnDisconnect | When an Interaction disconnects, pop the account code dialog.
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | SaveWrapTimeField | Save wrap up time.
Public property | SendScreenPopOnAlerting | Add inbound interaction to Salesforce Softphone on Alerting event.
Public property | ShowAdvancedTransferButton | Determines if the advanced transfer dialog should be shown in the CTI.
Public property | ShowSpeedDial | Determines if the speed dial should be shown in the CTI.
Public property | SpeedDialDirectory | Directory name to use for the speed dial.
Public property | SpeedDialNumber | Contact number to use in the speed dial.
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.
Public property | UseAdvancedDial | Use the advanced dial functionality.

See Also

CtiConfiguration Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


AttributeMappings Property

[image]

IceLib Technical Reference
CtiConfiguration..::..AttributeMappings Property
CtiConfiguration Class See Also Send Feedback
Provides access to the property representing the configurations for this configuration list (use Property.CtiAttributeMaps).

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, Collection<CtiAttributeMapConfiguration>> AttributeMappings { get; }
Visual Basic
Public ReadOnly Property AttributeMappings As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Collection(Of CtiAttributeMapConfiguration))
    Get

Field Value

The property representing the configurations for this configuation list

Remarks

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CreateCallLogForInternalCalls Property

[image]

IceLib Technical Reference
CtiConfiguration..::..CreateCallLogForInternalCalls Property
CtiConfiguration Class See Also Send Feedback
Create a call log for internal calls.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> CreateCallLogForInternalCalls { get; }
Visual Basic
Public ReadOnly Property CreateCallLogForInternalCalls As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

True to create a call log for internal calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CreateCallLogOnInteractionsNotConnected Property

[image]

IceLib Technical Reference
CtiConfiguration..::..CreateCallLogOnInteractionsNotConnected Property
CtiConfiguration Class See Also Send Feedback
Create Salesforce Call Log Activity on Interactions that have not been connected.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> CreateCallLogOnInteractionsNotConnected { get; }
Visual Basic
Public ReadOnly Property CreateCallLogOnInteractionsNotConnected As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

The property to create call logs on interactions that have not been connected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


OpenAndEditCallLogOnDisconnect Property

[image]

IceLib Technical Reference
CtiConfiguration..::..OpenAndEditCallLogOnDisconnect Property
CtiConfiguration Class See Also Send Feedback
When an Interaction disconnects, the Salesforce Call Log will automatically open in edit mode in the Last Calls section of the Softphone.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> OpenAndEditCallLogOnDisconnect { get; }
Visual Basic
Public ReadOnly Property OpenAndEditCallLogOnDisconnect As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

The property to open and edit call log on disconnect.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


PopAccountCodeDialogOnDisconnect Property

[image]

IceLib Technical Reference
CtiConfiguration..::..PopAccountCodeDialogOnDisconnect Property
CtiConfiguration Class See Also Send Feedback
When an Interaction disconnects, pop the account code dialog.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> PopAccountCodeDialogOnDisconnect { get; }
Visual Basic
Public ReadOnly Property PopAccountCodeDialogOnDisconnect As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

The property to pop the account dialog on disconnect.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
CtiConfiguration..::..PropertiesChanged Property
CtiConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<CtiConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of CtiConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SaveWrapTimeField Property

[image]

IceLib Technical Reference
CtiConfiguration..::..SaveWrapTimeField Property
CtiConfiguration Class See Also Send Feedback
Save wrap up time.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, string> SaveWrapTimeField { get; }
Visual Basic
Public ReadOnly Property SaveWrapTimeField As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, String)
    Get

Field Value

Save the Wrap Up time per interaction and store in the Salesforce Activity. If desired, this value defines the custom Activity field to store this data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SendScreenPopOnAlerting Property

[image]

IceLib Technical Reference
CtiConfiguration..::..SendScreenPopOnAlerting Property
CtiConfiguration Class See Also Send Feedback
Add inbound interaction to Salesforce Softphone on Alerting event.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> SendScreenPopOnAlerting { get; }
Visual Basic
Public ReadOnly Property SendScreenPopOnAlerting As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

The property to send screen pops on alerting calls.

Remarks

Set to true to add interaction when interaction is in alerting state, false to add interaction when interaction is added to user's queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


ShowAdvancedTransferButton Property

[image]

IceLib Technical Reference
CtiConfiguration..::..ShowAdvancedTransferButton Property
CtiConfiguration Class See Also Send Feedback
Determines if the advanced transfer dialog should be shown in the CTI.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> ShowAdvancedTransferButton { get; }
Visual Basic
Public ReadOnly Property ShowAdvancedTransferButton As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

True to show the speed dial in the CTI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


ShowSpeedDial Property

[image]

IceLib Technical Reference
CtiConfiguration..::..ShowSpeedDial Property
CtiConfiguration Class See Also Send Feedback
Determines if the speed dial should be shown in the CTI.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> ShowSpeedDial { get; }
Visual Basic
Public ReadOnly Property ShowSpeedDial As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

True to show the speed dial in the CTI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SpeedDialDirectory Property

[image]

IceLib Technical Reference
CtiConfiguration..::..SpeedDialDirectory Property
CtiConfiguration Class See Also Send Feedback
Directory name to use for the speed dial.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, string> SpeedDialDirectory { get; }
Visual Basic
Public ReadOnly Property SpeedDialDirectory As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, String)
    Get

Field Value

The property of the id for the speed dial directory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


SpeedDialNumber Property

[image]

IceLib Technical Reference
CtiConfiguration..::..SpeedDialNumber Property
CtiConfiguration Class See Also Send Feedback
Contact number to use in the speed dial.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, string> SpeedDialNumber { get; }
Visual Basic
Public ReadOnly Property SpeedDialNumber As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, String)
    Get

Field Value

The number of the contact to use for the speed dial.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


StandardProperties Property

[image]

IceLib Technical Reference
CtiConfiguration..::..StandardProperties Property
CtiConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<CtiConfiguration, CtiConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of CtiConfiguration, CtiConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


UseAdvancedDial Property

[image]

IceLib Technical Reference
CtiConfiguration..::..UseAdvancedDial Property
CtiConfiguration Class See Also Send Feedback
Use the advanced dial functionality.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<CtiConfiguration..::..Property, bool> UseAdvancedDial { get; }
Visual Basic
Public ReadOnly Property UseAdvancedDial As GeneralConfigurationProperty(Of CtiConfiguration..::..Property, Boolean)
    Get

Field Value

True to prompt the advanced dial features before placing a call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration Class
CtiConfiguration Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration.Property Enumeration

[image]

IceLib Technical Reference
CtiConfiguration..::..Property Enumeration
CtiConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
CreateCallLogOnInteractionsNotConnected | 0 | Represents the CreateCallLogOnInteractionsNotConnected property.
OpenAndEditCallLogOnDisconnect | 1 | Represents the OpenAndEditCallLogOnDisconnect property.
UseAdvancedDial | 2 | Represents the UseAdvancedDial property.
SendScreenPopOnAlerting | 3 | Represents the SendScreenPopOnAlerting property.
PopAccountCodeDialogOnDisconnect | 4 | Represents the PopAccountCodeDialogOnDisconnect property.
ShowAdvancedTransferButton | 5 | Represents the ShowAdvancedTransferButton property.
ShowSpeedDial | 6 | Represents the ShowSpeedDial property.
SpeedDialDirectory | 7 | Represents the SpeedDialDirectory property.
SpeedDialNumber | 8 | Represents the SpeedDialNumber property.
CreateCallLogForInternalCalls | 9 | Represents the CreateCallLogForInternalCalls property.
SaveWrapTimeField | 10 | Represents the SaveWrapTimeField property.
CtiAttributeMaps | 11 | Represents the AttributeMappings property.
DisplayName | 12 | Represents the DisplayName part of the ConfigurationId property.
Id | 13 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration.Rights Class

[image]

IceLib Technical Reference
CtiConfiguration..::..Rights Class
CtiConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration..::..Rights Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
CtiConfiguration..::..Rights Members
CtiConfiguration..::..Rights Class Properties See Also Send Feedback

The CtiConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

CtiConfiguration..::..Rights Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
CtiConfiguration..::..Rights Properties
CtiConfiguration..::..Rights Class See Also Send Feedback

The CtiConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

CtiConfiguration..::..Rights Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


Admin Property

[image]

IceLib Technical Reference
CtiConfiguration..::..Rights..::..Admin Property
CtiConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<CtiConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of CtiConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration..::..Rights Class
CtiConfiguration..::..Rights Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..SalesforceCtis


View Property

[image]

IceLib Technical Reference
CtiConfiguration..::..Rights..::..View Property
CtiConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<CtiConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of CtiConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfiguration..::..Rights Class
CtiConfiguration..::..Rights Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfigurationList Class

[image]

IceLib Technical Reference
CtiConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing cti configuration objects.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")]
public class CtiConfigurationList : EditableConfigurationList<CtiConfiguration, CtiConfiguration..::..Property>
Visual Basic
<ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")> _
Public Class CtiConfigurationList _
    Inherits EditableConfigurationList(Of CtiConfiguration, CtiConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' CtiConfiguration, CtiConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' CtiConfiguration, CtiConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' CtiConfiguration, CtiConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfigurationList Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfiguration
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiAttributeMapConfiguration
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiQueryChildrenSettings
ININ.IceLib.Configuration..::..HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>


CtiConfigurationList Members

[image] [image]

IceLib Technical Reference
CtiConfigurationList Members
CtiConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The CtiConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | CtiConfigurationList | Initializes a new instance of the CtiConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateAttributeMapQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateCtiAttributeMap | Creates a new cti attribute map.
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

CtiConfigurationList Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfigurationList Constructor

[image]

IceLib Technical Reference
CtiConfigurationList Constructor
CtiConfigurationList Class See Also Send Feedback
Initializes a new instance of the CtiConfigurationList class.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CtiConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfigurationList Class
CtiConfigurationList Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfigurationList Methods

[image] [image]

IceLib Technical Reference
CtiConfigurationList Methods
CtiConfigurationList Class See Also Send Feedback

The CtiConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateAttributeMapQuerySettings | Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).
Public method | CreateCtiAttributeMap | Creates a new cti attribute map.
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CtiConfigurationList Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CreateAttributeMapQuerySettings Method

[image]

IceLib Technical Reference
CtiConfigurationList..::..CreateAttributeMapQuerySettings Method
CtiConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this parent list's child object query functions. The only actions that are supported on child query settings are SetPropertiesToRetrieveToAll()()()(), SetPropertiesToRetrieve(IEnumerable<(Of <<'(TPropertyEnum>)>>)), and SetPropertiesToRetrieve(array<TPropertyEnum>[]()[][]).

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<CtiAttributeMapConfiguration, CtiAttributeMapConfiguration..::..Property> CreateAttributeMapQuerySettings()
Visual Basic
Public Function CreateAttributeMapQuerySettings As QuerySettings(Of CtiAttributeMapConfiguration, CtiAttributeMapConfiguration..::..Property)

Return Value

A new QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

CtiConfigurationList Class
CtiConfigurationList Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CreateCtiAttributeMap Method

[image]

IceLib Technical Reference
CtiConfigurationList..::..CreateCtiAttributeMap Method
CtiConfigurationList Class See Also Send Feedback
Creates a new cti attribute map.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CtiAttributeMapConfiguration CreateCtiAttributeMap()
Visual Basic
Public Function CreateCtiAttributeMap As CtiAttributeMapConfiguration

Return Value

A new CtiAttributeMapConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfigurationList Class
CtiConfigurationList Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CreateQuerySettings Method

[image]

IceLib Technical Reference
CtiConfigurationList..::..CreateQuerySettings Method
CtiConfigurationList Class See Also Send Feedback
Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HierarchicalQuerySettings<CtiConfiguration, CtiConfiguration..::..Property, CtiQueryChildrenSettings> CreateQuerySettings()
Visual Basic
Public Function CreateQuerySettings As HierarchicalQuerySettings(Of CtiConfiguration, CtiConfiguration..::..Property, CtiQueryChildrenSettings)

Return Value

A new HierarchicalQuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum, TQueryChildrenSettings>)>)>.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiConfigurationList Class
CtiConfigurationList Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfigurationList Properties

[image] [image]

IceLib Technical Reference
CtiConfigurationList Properties
CtiConfigurationList Class See Also Send Feedback

The CtiConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

CtiConfigurationList Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiConfigurationList Events

[image] [image]

IceLib Technical Reference
CtiConfigurationList Events
CtiConfigurationList Class See Also Send Feedback

The CtiConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

CtiConfigurationList Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiQueryChildrenSettings Class

[image]

IceLib Technical Reference
CtiQueryChildrenSettings Class
Members See Also Send Feedback
Provides query settings for a hierarchical query to allow querying, filtering and sorting of child objects.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")]
public class CtiQueryChildrenSettings : QueryChildrenSettings<CtiConfiguration..::..Property>
Visual Basic
<ObsoleteAttribute("The ININ.IceLib.Configuration.Integrations.Salesforce namespace is no longer available.")> _
Public Class CtiQueryChildrenSettings _
    Inherits QueryChildrenSettings(Of CtiConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..QueryChildrenSettings <(Of <(<' CtiConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiQueryChildrenSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiQueryChildrenSettings Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiConfigurationList
ININ.IceLib.Configuration.Integrations.Salesforce..::..CtiAttributeMapConfiguration
ININ.IceLib.Configuration..::..QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>


CtiQueryChildrenSettings Members

[image] [image]

IceLib Technical Reference
CtiQueryChildrenSettings Members
CtiQueryChildrenSettings Class Constructors Methods Properties See Also Send Feedback

The CtiQueryChildrenSettings type exposes the following members.

Constructors

 | Name | Description
Public method | CtiQueryChildrenSettings | Initializes a new instance of the CtiQueryChildrenSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeMappings | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

See Also

CtiQueryChildrenSettings Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiQueryChildrenSettings Constructor

[image]

IceLib Technical Reference
CtiQueryChildrenSettings Constructor
CtiQueryChildrenSettings Class See Also Send Feedback
Initializes a new instance of the CtiQueryChildrenSettings class.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CtiQueryChildrenSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiQueryChildrenSettings Class
CtiQueryChildrenSettings Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiQueryChildrenSettings Methods

[image] [image]

IceLib Technical Reference
CtiQueryChildrenSettings Methods
CtiQueryChildrenSettings Class See Also Send Feedback

The CtiQueryChildrenSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CtiQueryChildrenSettings Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


CtiQueryChildrenSettings Properties

[image] [image]

IceLib Technical Reference
CtiQueryChildrenSettings Properties
CtiQueryChildrenSettings Class See Also Send Feedback

The CtiQueryChildrenSettings type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMappings | Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

See Also

CtiQueryChildrenSettings Class
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


AttributeMappings Property

[image]

IceLib Technical Reference
CtiQueryChildrenSettings..::..AttributeMappings Property
CtiQueryChildrenSettings Class See Also Send Feedback
Gets or sets the custom data sub query settings. If custom data is required for this query, this property must be filled out.

Namespace: ININ.IceLib.Configuration.Integrations.Salesforce
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QuerySettings<CtiAttributeMapConfiguration, CtiAttributeMapConfiguration..::..Property> AttributeMappings { get; set; }
Visual Basic
Public Property AttributeMappings As QuerySettings(Of CtiAttributeMapConfiguration, CtiAttributeMapConfiguration..::..Property)
    Get
    Set

Field Value

The custom data sub query settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CtiQueryChildrenSettings Class
CtiQueryChildrenSettings Members
ININ.IceLib.Configuration.Integrations.Salesforce Namespace


ININ.IceLib.Configuration.Mailbox Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Mailbox Namespace
Send Feedback

The ININ.IceLib.Configuration.Mailbox namespace contains classes that provide support to the classes in the ININ.IceLib.Configuration namespace. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

Classes

 | Class | Description
Public class | GenericProviderMailboxSettings | Provides settings describing a mailbox based on a generic provider, such as Exchange, GroupWise, and Notes. (Corresponds to GenericProvider.)
Public class | ImapSmtpMailboxSettings | Provides settings describing a mailbox based on IMAP and/or SMTP. (Corresponds to ImapSmtp.)
Public class | InteractionMessageStoreMailboxSettings | Provides settings describing a mailbox based on Interaction Message Store. (Corresponds to InteractionMessageStore.)
Public class | MailboxProperties | Contains mailbox settings for a UserConfiguration.
Public class | MailboxRetrievedValues | Contains retrieved mailbox settings for a UserConfiguration from a call to RetrievePropertiesForMailboxSettings(MailboxSettings), or for a WorkgroupConfiguration from a call to RetrievePropertiesForMailboxSettings(MailboxSettings).
Public class | MailboxSettings | Provides common implementation for mailbox settings classes.
Public class | NoMailboxSettings | Provides settings describing having no mailbox configured. (Corresponds to None.)
Public class | RetrievePropertiesForMailboxSettingsCompletedEventArgs | Provides data for asynchronous completed events of RetrievePropertiesForMailboxSettingsAsync(MailboxSettings, EventHandler<(Of <<'(RetrievePropertiesForMailboxSettingsCompletedEventArgs>)>>), Object).
Public class | WorkgroupMailboxProperties | Contains mailbox settings for a WorkgroupConfiguration.

Enumerations

 | Enumeration | Description
Public enumeration | MailboxType | Represents the mailbox type for a UserConfiguration or a WorkgroupConfiguration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.


GenericProviderMailboxSettings Class

[image]

IceLib Technical Reference
GenericProviderMailboxSettings Class
Members See Also Send Feedback
Provides settings describing a mailbox based on a generic provider, such as Exchange, GroupWise, and Notes. (Corresponds to GenericProvider.)

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GenericProviderMailboxSettings : MailboxSettings
Visual Basic
Public Class GenericProviderMailboxSettings _
    Inherits MailboxSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
ININ.IceLib.Configuration.Mailbox..::..GenericProviderMailboxSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


GenericProviderMailboxSettings Members

[image] [image]

IceLib Technical Reference
GenericProviderMailboxSettings Members
GenericProviderMailboxSettings Class Constructors Methods Properties See Also Send Feedback

The GenericProviderMailboxSettings type exposes the following members.

Constructors

 | Name | Description
Public method | GenericProviderMailboxSettings | Initializes a new instance of the GenericProviderMailboxSettings. Values are retrieved from a call to SearchDirectories(SearchDirectoriesParameters) or SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

Properties

 | Name | Description
Public property | DirectoryMoniker | Gets the directory moniker.
Public property | DisplayName | Gets the display name.
Public property | EmailAddress | Gets the email address.
Public property | MailboxMoniker | Gets the mailbox moniker.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)

See Also

GenericProviderMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


GenericProviderMailboxSettings Constructor

[image]

IceLib Technical Reference
GenericProviderMailboxSettings Constructor
GenericProviderMailboxSettings Class See Also Send Feedback
Initializes a new instance of the GenericProviderMailboxSettings. Values are retrieved from a call to SearchDirectories(SearchDirectoriesParameters) or SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GenericProviderMailboxSettings(
    string displayName,
    string directoryMoniker,
    string emailAddress,
    string mailboxMoniker
)
Visual Basic
Public Sub New ( _
    displayName As String, _
    directoryMoniker As String, _
    emailAddress As String, _
    mailboxMoniker As String _
)

Parameters

displayName
Type: System..::..String
The display name.
directoryMoniker
Type: System..::..String
The directory moniker.
emailAddress
Type: System..::..String
The email address.
mailboxMoniker
Type: System..::..String
The mailbox moniker.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GenericProviderMailboxSettings Class
GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


GenericProviderMailboxSettings Methods

[image] [image]

IceLib Technical Reference
GenericProviderMailboxSettings Methods
GenericProviderMailboxSettings Class See Also Send Feedback

The GenericProviderMailboxSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

See Also

GenericProviderMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


ToString Method

[image]

IceLib Technical Reference
GenericProviderMailboxSettings..::..ToString Method
GenericProviderMailboxSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericProviderMailboxSettings Class
GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


GenericProviderMailboxSettings Properties

[image] [image]

IceLib Technical Reference
GenericProviderMailboxSettings Properties
GenericProviderMailboxSettings Class See Also Send Feedback

The GenericProviderMailboxSettings type exposes the following members.

Properties

 | Name | Description
Public property | DirectoryMoniker | Gets the directory moniker.
Public property | DisplayName | Gets the display name.
Public property | EmailAddress | Gets the email address.
Public property | MailboxMoniker | Gets the mailbox moniker.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)

See Also

GenericProviderMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


DirectoryMoniker Property

[image]

IceLib Technical Reference
GenericProviderMailboxSettings..::..DirectoryMoniker Property
GenericProviderMailboxSettings Class See Also Send Feedback
Gets the directory moniker.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DirectoryMoniker { get; }
Visual Basic
Public ReadOnly Property DirectoryMoniker As String
    Get

Field Value

The directory moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GenericProviderMailboxSettings Class
GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
GenericProviderMailboxSettings..::..DisplayName Property
GenericProviderMailboxSettings Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GenericProviderMailboxSettings Class
GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


EmailAddress Property

[image]

IceLib Technical Reference
GenericProviderMailboxSettings..::..EmailAddress Property
GenericProviderMailboxSettings Class See Also Send Feedback
Gets the email address.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As String
    Get

Field Value

The email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GenericProviderMailboxSettings Class
GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxMoniker Property

[image]

IceLib Technical Reference
GenericProviderMailboxSettings..::..MailboxMoniker Property
GenericProviderMailboxSettings Class See Also Send Feedback
Gets the mailbox moniker.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MailboxMoniker { get; }
Visual Basic
Public ReadOnly Property MailboxMoniker As String
    Get

Field Value

The mailbox moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GenericProviderMailboxSettings Class
GenericProviderMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Class

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings Class
Members See Also Send Feedback
Provides settings describing a mailbox based on IMAP and/or SMTP. (Corresponds to ImapSmtp.)

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImapSmtpMailboxSettings : MailboxSettings
Visual Basic
Public Class ImapSmtpMailboxSettings _
    Inherits MailboxSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
ININ.IceLib.Configuration.Mailbox..::..ImapSmtpMailboxSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Members

[image] [image]

IceLib Technical Reference
ImapSmtpMailboxSettings Members
ImapSmtpMailboxSettings Class Constructors Methods Properties See Also Send Feedback

The ImapSmtpMailboxSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ImapSmtpMailboxSettings(String) | Initializes a new instance of the ImapSmtpMailboxSettings.
Public method | ImapSmtpMailboxSettings(String, String) | Initializes a new instance of the ImapSmtpMailboxSettings class.
Public method | ImapSmtpMailboxSettings(String, String, String) | Initializes a new instance of the ImapSmtpMailboxSettings class.
Public method | ImapSmtpMailboxSettings(String, String, String, Boolean) | Initializes a new instance of the ImapSmtpMailboxSettings class.
Public method | ImapSmtpMailboxSettings(String, String, String, String, String) | Initializes a new instance of the ImapSmtpMailboxSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | EmailAddress | Gets the email address.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)
Public property | Password | Gets the password.
Public property | Server | Gets the server.
Public property | UseProxyAuthentication | Gets the value indicating if using proxy authentication.
Public property | UserName | Gets the user name.

See Also

ImapSmtpMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Constructor

[image] [image]

IceLib Technical Reference
ImapSmtpMailboxSettings Constructor
ImapSmtpMailboxSettings Class See Also Send Feedback
Initializes a new instance of the ImapSmtpMailboxSettings class.

Overload List

 | Name | Description
Public method | ImapSmtpMailboxSettings(String) | Initializes a new instance of the ImapSmtpMailboxSettings.
Public method | ImapSmtpMailboxSettings(String, String) | Initializes a new instance of the ImapSmtpMailboxSettings class.
Public method | ImapSmtpMailboxSettings(String, String, String) | Initializes a new instance of the ImapSmtpMailboxSettings class.
Public method | ImapSmtpMailboxSettings(String, String, String, Boolean) | Initializes a new instance of the ImapSmtpMailboxSettings class.
Public method | ImapSmtpMailboxSettings(String, String, String, String, String) | Initializes a new instance of the ImapSmtpMailboxSettings class.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Constructor (String)

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings Constructor (String)
ImapSmtpMailboxSettings Class See Also Send Feedback
Initializes a new instance of the ImapSmtpMailboxSettings.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImapSmtpMailboxSettings(
    string displayName
)
Visual Basic
Public Sub New ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String
The display name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ImapSmtpMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Constructor (String, String)

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings Constructor (String, String)
ImapSmtpMailboxSettings Class See Also Send Feedback
Initializes a new instance of the ImapSmtpMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImapSmtpMailboxSettings(
    string displayName,
    string emailAddress
)
Visual Basic
Public Sub New ( _
    displayName As String, _
    emailAddress As String _
)

Parameters

displayName
Type: System..::..String
The display name.
emailAddress
Type: System..::..String
The email address.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ImapSmtpMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Constructor (String, String, String)

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings Constructor (String, String, String)
ImapSmtpMailboxSettings Class See Also Send Feedback
Initializes a new instance of the ImapSmtpMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImapSmtpMailboxSettings(
    string displayName,
    string emailAddress,
    string server
)
Visual Basic
Public Sub New ( _
    displayName As String, _
    emailAddress As String, _
    server As String _
)

Parameters

displayName
Type: System..::..String
The display name.
emailAddress
Type: System..::..String
The email address.
server
Type: System..::..String
The server.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ImapSmtpMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Constructor (String, String, String, Boolean)

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings Constructor (String, String, String, Boolean)
ImapSmtpMailboxSettings Class See Also Send Feedback
Initializes a new instance of the ImapSmtpMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImapSmtpMailboxSettings(
    string displayName,
    string emailAddress,
    string server,
    bool useProxyAuthentication
)
Visual Basic
Public Sub New ( _
    displayName As String, _
    emailAddress As String, _
    server As String, _
    useProxyAuthentication As Boolean _
)

Parameters

displayName
Type: System..::..String
The display name.
emailAddress
Type: System..::..String
The email address.
server
Type: System..::..String
The server.
useProxyAuthentication
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), then use proxy authentication.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ImapSmtpMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Constructor (String, String, String, String, String)

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings Constructor (String, String, String, String, String)
ImapSmtpMailboxSettings Class See Also Send Feedback
Initializes a new instance of the ImapSmtpMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ImapSmtpMailboxSettings(
    string displayName,
    string emailAddress,
    string server,
    string userName,
    string password
)
Visual Basic
Public Sub New ( _
    displayName As String, _
    emailAddress As String, _
    server As String, _
    userName As String, _
    password As String _
)

Parameters

displayName
Type: System..::..String
The display name.
emailAddress
Type: System..::..String
The email address.
server
Type: System..::..String
The server.
userName
Type: System..::..String
Name of the user.
password
Type: System..::..String
The password.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ImapSmtpMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Methods

[image] [image]

IceLib Technical Reference
ImapSmtpMailboxSettings Methods
ImapSmtpMailboxSettings Class See Also Send Feedback

The ImapSmtpMailboxSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

See Also

ImapSmtpMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


ToString Method

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..ToString Method
ImapSmtpMailboxSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


ImapSmtpMailboxSettings Properties

[image] [image]

IceLib Technical Reference
ImapSmtpMailboxSettings Properties
ImapSmtpMailboxSettings Class See Also Send Feedback

The ImapSmtpMailboxSettings type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | EmailAddress | Gets the email address.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)
Public property | Password | Gets the password.
Public property | Server | Gets the server.
Public property | UseProxyAuthentication | Gets the value indicating if using proxy authentication.
Public property | UserName | Gets the user name.

See Also

ImapSmtpMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..DisplayName Property
ImapSmtpMailboxSettings Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


EmailAddress Property

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..EmailAddress Property
ImapSmtpMailboxSettings Class See Also Send Feedback
Gets the email address.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As String
    Get

Field Value

The email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


Password Property

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..Password Property
ImapSmtpMailboxSettings Class See Also Send Feedback
Gets the password.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Password { get; }
Visual Basic
Public ReadOnly Property Password As String
    Get

Field Value

The password.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


Server Property

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..Server Property
ImapSmtpMailboxSettings Class See Also Send Feedback
Gets the server.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Server { get; }
Visual Basic
Public ReadOnly Property Server As String
    Get

Field Value

The server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


UseProxyAuthentication Property

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..UseProxyAuthentication Property
ImapSmtpMailboxSettings Class See Also Send Feedback
Gets the value indicating if using proxy authentication.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool UseProxyAuthentication { get; }
Visual Basic
Public ReadOnly Property UseProxyAuthentication As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if using proxy authentication; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


UserName Property

[image]

IceLib Technical Reference
ImapSmtpMailboxSettings..::..UserName Property
ImapSmtpMailboxSettings Class See Also Send Feedback
Gets the user name.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; }
Visual Basic
Public ReadOnly Property UserName As String
    Get

Field Value

The user name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ImapSmtpMailboxSettings Class
ImapSmtpMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Class

[image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Class
Members See Also Send Feedback
Provides settings describing a mailbox based on Interaction Message Store. (Corresponds to InteractionMessageStore.)

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionMessageStoreMailboxSettings : MailboxSettings
Visual Basic
Public Class InteractionMessageStoreMailboxSettings _
    Inherits MailboxSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
ININ.IceLib.Configuration.Mailbox..::..InteractionMessageStoreMailboxSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionMessageStoreMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Members

[image] [image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Members
InteractionMessageStoreMailboxSettings Class Constructors Methods Properties See Also Send Feedback

The InteractionMessageStoreMailboxSettings type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionMessageStoreMailboxSettings(String) | Initializes a new instance of the InteractionMessageStoreMailboxSettings class.
Public method | InteractionMessageStoreMailboxSettings(String, String) | Initializes a new instance of the InteractionMessageStoreMailboxSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)
Public property | UserId | Gets the user ID.

See Also

InteractionMessageStoreMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Constructor

[image] [image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Constructor
InteractionMessageStoreMailboxSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InteractionMessageStoreMailboxSettings(String) | Initializes a new instance of the InteractionMessageStoreMailboxSettings class.
Public method | InteractionMessageStoreMailboxSettings(String, String) | Initializes a new instance of the InteractionMessageStoreMailboxSettings class.

See Also

InteractionMessageStoreMailboxSettings Class
InteractionMessageStoreMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Constructor (String)

[image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Constructor (String)
InteractionMessageStoreMailboxSettings Class See Also Send Feedback
Initializes a new instance of the InteractionMessageStoreMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionMessageStoreMailboxSettings(
    string userId
)
Visual Basic
Public Sub New ( _
    userId As String _
)

Parameters

userId
Type: System..::..String
The user ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionMessageStoreMailboxSettings Class
InteractionMessageStoreMailboxSettings Members
InteractionMessageStoreMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Constructor (String, String)

[image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Constructor (String, String)
InteractionMessageStoreMailboxSettings Class See Also Send Feedback
Initializes a new instance of the InteractionMessageStoreMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionMessageStoreMailboxSettings(
    string userId,
    string displayName
)
Visual Basic
Public Sub New ( _
    userId As String, _
    displayName As String _
)

Parameters

userId
Type: System..::..String
The user ID.
displayName
Type: System..::..String
The display name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionMessageStoreMailboxSettings Class
InteractionMessageStoreMailboxSettings Members
InteractionMessageStoreMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Methods

[image] [image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Methods
InteractionMessageStoreMailboxSettings Class See Also Send Feedback

The InteractionMessageStoreMailboxSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

See Also

InteractionMessageStoreMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings..::..ToString Method
InteractionMessageStoreMailboxSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionMessageStoreMailboxSettings Class
InteractionMessageStoreMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


InteractionMessageStoreMailboxSettings Properties

[image] [image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings Properties
InteractionMessageStoreMailboxSettings Class See Also Send Feedback

The InteractionMessageStoreMailboxSettings type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)
Public property | UserId | Gets the user ID.

See Also

InteractionMessageStoreMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings..::..DisplayName Property
InteractionMessageStoreMailboxSettings Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionMessageStoreMailboxSettings Class
InteractionMessageStoreMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


UserId Property

[image]

IceLib Technical Reference
InteractionMessageStoreMailboxSettings..::..UserId Property
InteractionMessageStoreMailboxSettings Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionMessageStoreMailboxSettings Class
InteractionMessageStoreMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxProperties Class

[image]

IceLib Technical Reference
MailboxProperties Class
Members See Also Send Feedback
Contains mailbox settings for a UserConfiguration.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MailboxProperties
Visual Basic
Public Class MailboxProperties

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxProperties

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxProperties Members

[image] [image]

IceLib Technical Reference
MailboxProperties Members
MailboxProperties Class Methods Properties See Also Send Feedback

The MailboxProperties type exposes the following members.

Methods

 | Name | Description
Public method | ApplyMailboxSettings | Applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | ApplyMailboxSettingsAsync | Asynchronously applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | RetrievePropertiesForMailboxSettingsAsync | Asynchronously retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectoryMoniker | Provides read-only access to the property representing the mailbox directory moniker for this user (use Property.Mailbox_DirectoryMoniker).
Public property | DisplayName | Provides read-only access to the property representing the mailbox display name for this user (use Property.Mailbox_DisplayName).
Public property | EmailAddress | Provides read-only access to the property representing the mailbox email address for this user (use Property.Mailbox_EmailAddress).
Public property | MailboxMoniker | Provides read-only access to the property representing the mailbox moniker for this user (use Property.Mailbox_MailboxMoniker).
Public property | Type | Provides read-only access to the property representing the mailbox option for this user (use Property.Mailbox_Type).

See Also

MailboxProperties Class
ININ.IceLib.Configuration.Mailbox Namespace


MailboxProperties Methods

[image] [image]

IceLib Technical Reference
MailboxProperties Methods
MailboxProperties Class See Also Send Feedback

The MailboxProperties type exposes the following members.

Methods

 | Name | Description
Public method | ApplyMailboxSettings | Applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | ApplyMailboxSettingsAsync | Asynchronously applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | RetrievePropertiesForMailboxSettingsAsync | Asynchronously retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailboxProperties Class
ININ.IceLib.Configuration.Mailbox Namespace


ApplyMailboxSettings Method

[image]

IceLib Technical Reference
MailboxProperties..::..ApplyMailboxSettings Method
MailboxProperties Class See Also Send Feedback
Applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ApplyMailboxSettings(
    MailboxSettings mailboxSettings
)
Visual Basic
Public Sub ApplyMailboxSettings ( _
    mailboxSettings As MailboxSettings _
)

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace
MailboxProperties..::..RetrievePropertiesForMailboxSettings(MailboxSettings)


ApplyMailboxSettingsAsync Method

[image]

IceLib Technical Reference
MailboxProperties..::..ApplyMailboxSettingsAsync Method
MailboxProperties Class See Also Send Feedback
Asynchronously applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ApplyMailboxSettingsAsync(
    MailboxSettings mailboxSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ApplyMailboxSettingsAsync ( _
    mailboxSettings As MailboxSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


RetrievePropertiesForMailboxSettings Method

[image]

IceLib Technical Reference
MailboxProperties..::..RetrievePropertiesForMailboxSettings Method
MailboxProperties Class See Also Send Feedback
Retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxRetrievedValues RetrievePropertiesForMailboxSettings(
    MailboxSettings mailboxSettings
)
Visual Basic
Public Function RetrievePropertiesForMailboxSettings ( _
    mailboxSettings As MailboxSettings _
) As MailboxRetrievedValues

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.

Return Value

The retrieved mailbox values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace
MailboxProperties..::..ApplyMailboxSettings(MailboxSettings)


RetrievePropertiesForMailboxSettingsAsync Method

[image]

IceLib Technical Reference
MailboxProperties..::..RetrievePropertiesForMailboxSettingsAsync Method
MailboxProperties Class See Also Send Feedback
Asynchronously retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RetrievePropertiesForMailboxSettingsAsync(
    MailboxSettings mailboxSettings,
    EventHandler<RetrievePropertiesForMailboxSettingsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub RetrievePropertiesForMailboxSettingsAsync ( _
    mailboxSettings As MailboxSettings, _
    completedCallback As EventHandler(Of RetrievePropertiesForMailboxSettingsCompletedEventArgs), _
    userState As Object _
)

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.
completedCallback
Type: System..::..EventHandler<(Of <(<' RetrievePropertiesForMailboxSettingsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxProperties Properties

[image] [image]

IceLib Technical Reference
MailboxProperties Properties
MailboxProperties Class See Also Send Feedback

The MailboxProperties type exposes the following members.

Properties

 | Name | Description
Public property | DirectoryMoniker | Provides read-only access to the property representing the mailbox directory moniker for this user (use Property.Mailbox_DirectoryMoniker).
Public property | DisplayName | Provides read-only access to the property representing the mailbox display name for this user (use Property.Mailbox_DisplayName).
Public property | EmailAddress | Provides read-only access to the property representing the mailbox email address for this user (use Property.Mailbox_EmailAddress).
Public property | MailboxMoniker | Provides read-only access to the property representing the mailbox moniker for this user (use Property.Mailbox_MailboxMoniker).
Public property | Type | Provides read-only access to the property representing the mailbox option for this user (use Property.Mailbox_Type).

See Also

MailboxProperties Class
ININ.IceLib.Configuration.Mailbox Namespace


DirectoryMoniker Property

[image]

IceLib Technical Reference
MailboxProperties..::..DirectoryMoniker Property
MailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox directory moniker for this user (use Property.Mailbox_DirectoryMoniker).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> DirectoryMoniker { get; }
Visual Basic
Public ReadOnly Property DirectoryMoniker As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the mailbox directory.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
MailboxProperties..::..DisplayName Property
MailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox display name for this user (use Property.Mailbox_DisplayName).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the mailbox display name.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


EmailAddress Property

[image]

IceLib Technical Reference
MailboxProperties..::..EmailAddress Property
MailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox email address for this user (use Property.Mailbox_EmailAddress).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the mailbox email address.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxMoniker Property

[image]

IceLib Technical Reference
MailboxProperties..::..MailboxMoniker Property
MailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox moniker for this user (use Property.Mailbox_MailboxMoniker).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, string> MailboxMoniker { get; }
Visual Basic
Public ReadOnly Property MailboxMoniker As GeneralConfigurationProperty(Of UserConfiguration..::..Property, String)
    Get

Field Value

The property representing the mailbox.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


Type Property

[image]

IceLib Technical Reference
MailboxProperties..::..Type Property
MailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox option for this user (use Property.Mailbox_Type).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<UserConfiguration..::..Property, MailboxType> Type { get; }
Visual Basic
Public ReadOnly Property Type As GeneralConfigurationProperty(Of UserConfiguration..::..Property, MailboxType)
    Get

Field Value

The property representing the mailbox type.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxProperties Class
MailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxRetrievedValues Class

[image]

IceLib Technical Reference
MailboxRetrievedValues Class
Members See Also Send Feedback
Contains retrieved mailbox settings for a UserConfiguration from a call to RetrievePropertiesForMailboxSettings(MailboxSettings), or for a WorkgroupConfiguration from a call to RetrievePropertiesForMailboxSettings(MailboxSettings).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MailboxRetrievedValues
Visual Basic
Public Class MailboxRetrievedValues

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxRetrievedValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxRetrievedValues Members

[image] [image]

IceLib Technical Reference
MailboxRetrievedValues Members
MailboxRetrievedValues Class Methods Properties See Also Send Feedback

The MailboxRetrievedValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DirectoryMoniker | Provides access to the property representing the mailbox directory moniker for this user (use Property.Mailbox_DirectoryMoniker).
Public property | DisplayName | Provides access to the property representing the mailbox display name for this user or workgroup (use Property.Mailbox_DisplayName).
Public property | EmailAddress | Provides access to the property representing the mailbox email address for this user or workgroup (use Property.Mailbox_EmailAddress).
Public property | MailboxMoniker | Provides access to the property representing the mailbox moniker for this user (use Property.Mailbox_MailboxMoniker).
Public property | Type | Provides access to the property representing the mailbox option for this user or workgroup (use Property.Mailbox_Type).

See Also

MailboxRetrievedValues Class
ININ.IceLib.Configuration.Mailbox Namespace


MailboxRetrievedValues Methods

[image] [image]

IceLib Technical Reference
MailboxRetrievedValues Methods
MailboxRetrievedValues Class See Also Send Feedback

The MailboxRetrievedValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MailboxRetrievedValues Class
ININ.IceLib.Configuration.Mailbox Namespace


ToString Method

[image]

IceLib Technical Reference
MailboxRetrievedValues..::..ToString Method
MailboxRetrievedValues Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MailboxRetrievedValues Class
MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxRetrievedValues Properties

[image] [image]

IceLib Technical Reference
MailboxRetrievedValues Properties
MailboxRetrievedValues Class See Also Send Feedback

The MailboxRetrievedValues type exposes the following members.

Properties

 | Name | Description
Public property | DirectoryMoniker | Provides access to the property representing the mailbox directory moniker for this user (use Property.Mailbox_DirectoryMoniker).
Public property | DisplayName | Provides access to the property representing the mailbox display name for this user or workgroup (use Property.Mailbox_DisplayName).
Public property | EmailAddress | Provides access to the property representing the mailbox email address for this user or workgroup (use Property.Mailbox_EmailAddress).
Public property | MailboxMoniker | Provides access to the property representing the mailbox moniker for this user (use Property.Mailbox_MailboxMoniker).
Public property | Type | Provides access to the property representing the mailbox option for this user or workgroup (use Property.Mailbox_Type).

See Also

MailboxRetrievedValues Class
ININ.IceLib.Configuration.Mailbox Namespace


DirectoryMoniker Property

[image]

IceLib Technical Reference
MailboxRetrievedValues..::..DirectoryMoniker Property
MailboxRetrievedValues Class See Also Send Feedback
Provides access to the property representing the mailbox directory moniker for this user (use Property.Mailbox_DirectoryMoniker).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DirectoryMoniker { get; }
Visual Basic
Public ReadOnly Property DirectoryMoniker As String
    Get

Field Value

The property representing the mailbox display name.

Remarks

Note
This property is not directly editable. This property is not valid for workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxRetrievedValues Class
MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
MailboxRetrievedValues..::..DisplayName Property
MailboxRetrievedValues Class See Also Send Feedback
Provides access to the property representing the mailbox display name for this user or workgroup (use Property.Mailbox_DisplayName).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The property representing the mailbox display name.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxRetrievedValues Class
MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


EmailAddress Property

[image]

IceLib Technical Reference
MailboxRetrievedValues..::..EmailAddress Property
MailboxRetrievedValues Class See Also Send Feedback
Provides access to the property representing the mailbox email address for this user or workgroup (use Property.Mailbox_EmailAddress).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As String
    Get

Field Value

The property representing the mailbox display name.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxRetrievedValues Class
MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxMoniker Property

[image]

IceLib Technical Reference
MailboxRetrievedValues..::..MailboxMoniker Property
MailboxRetrievedValues Class See Also Send Feedback
Provides access to the property representing the mailbox moniker for this user (use Property.Mailbox_MailboxMoniker).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MailboxMoniker { get; }
Visual Basic
Public ReadOnly Property MailboxMoniker As String
    Get

Field Value

The property representing the mailbox.

Remarks

Note
This property is not directly editable. This property is not valid for workgroups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxRetrievedValues Class
MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


Type Property

[image]

IceLib Technical Reference
MailboxRetrievedValues..::..Type Property
MailboxRetrievedValues Class See Also Send Feedback
Provides access to the property representing the mailbox option for this user or workgroup (use Property.Mailbox_Type).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxType Type { get; }
Visual Basic
Public ReadOnly Property Type As MailboxType
    Get

Field Value

The property representing the mailbox option.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxRetrievedValues Class
MailboxRetrievedValues Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxSettings Class

[image]

IceLib Technical Reference
MailboxSettings Class
Members See Also Send Feedback
Provides common implementation for mailbox settings classes.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class MailboxSettings
Visual Basic
Public MustInherit Class MailboxSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
ININ.IceLib.Configuration.Mailbox..::..GenericProviderMailboxSettings
ININ.IceLib.Configuration.Mailbox..::..ImapSmtpMailboxSettings
ININ.IceLib.Configuration.Mailbox..::..InteractionMessageStoreMailboxSettings
ININ.IceLib.Configuration.Mailbox..::..NoMailboxSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxSettings Members

[image] [image]

IceLib Technical Reference
MailboxSettings Members
MailboxSettings Class Methods Properties See Also Send Feedback

The MailboxSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | MailboxType | Gets the type of the mailbox.

See Also

MailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


MailboxSettings Methods

[image] [image]

IceLib Technical Reference
MailboxSettings Methods
MailboxSettings Class See Also Send Feedback

The MailboxSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


ToString Method

[image]

IceLib Technical Reference
MailboxSettings..::..ToString Method
MailboxSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MailboxSettings Class
MailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxSettings Properties

[image] [image]

IceLib Technical Reference
MailboxSettings Properties
MailboxSettings Class See Also Send Feedback

The MailboxSettings type exposes the following members.

Properties

 | Name | Description
Public property | MailboxType | Gets the type of the mailbox.

See Also

MailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


MailboxType Property

[image]

IceLib Technical Reference
MailboxSettings..::..MailboxType Property
MailboxSettings Class See Also Send Feedback
Gets the type of the mailbox.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxType MailboxType { get; }
Visual Basic
Public ReadOnly Property MailboxType As MailboxType
    Get

Field Value

The type of the mailbox.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MailboxSettings Class
MailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


MailboxType Enumeration

[image]

IceLib Technical Reference
MailboxType Enumeration
See Also Send Feedback
Represents the mailbox type for a UserConfiguration or a WorkgroupConfiguration.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MailboxType
Visual Basic
Public Enumeration MailboxType

Members

Member name | Value | Description
None | 0 | User or Workgroup has no mailbox configured.
InteractionMessageStore | 1 | User or Workgroup has an Interaction Message Store mailbox configured.
ImapSmtp | 2 | User or Workgroup has an IMAP or SMTP mailbox configured.
GenericProvider | 3 | User or Workgroup has provider-based mailbox configured (such as Microsoft Exchange or Lotus Notes).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Class

[image]

IceLib Technical Reference
NoMailboxSettings Class
Members See Also Send Feedback
Provides settings describing having no mailbox configured. (Corresponds to None.)

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NoMailboxSettings : MailboxSettings
Visual Basic
Public Class NoMailboxSettings _
    Inherits MailboxSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
ININ.IceLib.Configuration.Mailbox..::..NoMailboxSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

NoMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Members

[image] [image]

IceLib Technical Reference
NoMailboxSettings Members
NoMailboxSettings Class Constructors Methods Properties See Also Send Feedback

The NoMailboxSettings type exposes the following members.

Constructors

 | Name | Description
Public method | NoMailboxSettings()()()() | Initializes a new instance of the NoMailboxSettings class.
Public method | NoMailboxSettings(String) | Initializes a new instance of the NoMailboxSettings class with an explicit display name to use.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)

See Also

NoMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Constructor

[image] [image]

IceLib Technical Reference
NoMailboxSettings Constructor
NoMailboxSettings Class See Also Send Feedback
Initializes a new instance of the NoMailboxSettings class.

Overload List

 | Name | Description
Public method | NoMailboxSettings()()()() | Initializes a new instance of the NoMailboxSettings class.
Public method | NoMailboxSettings(String) | Initializes a new instance of the NoMailboxSettings class with an explicit display name to use.

See Also

NoMailboxSettings Class
NoMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Constructor

[image]

IceLib Technical Reference
NoMailboxSettings Constructor
NoMailboxSettings Class See Also Send Feedback
Initializes a new instance of the NoMailboxSettings class.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NoMailboxSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

NoMailboxSettings Class
NoMailboxSettings Members
NoMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Constructor (String)

[image]

IceLib Technical Reference
NoMailboxSettings Constructor (String)
NoMailboxSettings Class See Also Send Feedback
Initializes a new instance of the NoMailboxSettings class with an explicit display name to use.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NoMailboxSettings(
    string displayName
)
Visual Basic
Public Sub New ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String
The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

NoMailboxSettings Class
NoMailboxSettings Members
NoMailboxSettings Overload
ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Methods

[image] [image]

IceLib Technical Reference
NoMailboxSettings Methods
NoMailboxSettings Class See Also Send Feedback

The NoMailboxSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides MailboxSettings..::..ToString()()()().)

See Also

NoMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


ToString Method

[image]

IceLib Technical Reference
NoMailboxSettings..::..ToString Method
NoMailboxSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NoMailboxSettings Class
NoMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


NoMailboxSettings Properties

[image] [image]

IceLib Technical Reference
NoMailboxSettings Properties
NoMailboxSettings Class See Also Send Feedback

The NoMailboxSettings type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the display name.
Public property | MailboxType | Gets the type of the mailbox. (Inherited from MailboxSettings.)

See Also

NoMailboxSettings Class
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
NoMailboxSettings..::..DisplayName Property
NoMailboxSettings Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

NoMailboxSettings Class
NoMailboxSettings Members
ININ.IceLib.Configuration.Mailbox Namespace


RetrievePropertiesForMailboxSettingsCompletedEventArgs Class

[image]

IceLib Technical Reference
RetrievePropertiesForMailboxSettingsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of RetrievePropertiesForMailboxSettingsAsync(MailboxSettings, EventHandler<(Of <<'(RetrievePropertiesForMailboxSettingsCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RetrievePropertiesForMailboxSettingsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class RetrievePropertiesForMailboxSettingsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox..::..RetrievePropertiesForMailboxSettingsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RetrievePropertiesForMailboxSettingsCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox Namespace


RetrievePropertiesForMailboxSettingsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
RetrievePropertiesForMailboxSettingsCompletedEventArgs Members
RetrievePropertiesForMailboxSettingsCompletedEventArgs Class Methods Properties See Also Send Feedback

The RetrievePropertiesForMailboxSettingsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | MailboxRetrievedValues | Gets the retrieved mailbox values.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

RetrievePropertiesForMailboxSettingsCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox Namespace


RetrievePropertiesForMailboxSettingsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
RetrievePropertiesForMailboxSettingsCompletedEventArgs Methods
RetrievePropertiesForMailboxSettingsCompletedEventArgs Class See Also Send Feedback

The RetrievePropertiesForMailboxSettingsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RetrievePropertiesForMailboxSettingsCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox Namespace


RetrievePropertiesForMailboxSettingsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
RetrievePropertiesForMailboxSettingsCompletedEventArgs Properties
RetrievePropertiesForMailboxSettingsCompletedEventArgs Class See Also Send Feedback

The RetrievePropertiesForMailboxSettingsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | MailboxRetrievedValues | Gets the retrieved mailbox values.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

RetrievePropertiesForMailboxSettingsCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox Namespace


MailboxRetrievedValues Property

[image]

IceLib Technical Reference
RetrievePropertiesForMailboxSettingsCompletedEventArgs..::..MailboxRetrievedValues Property
RetrievePropertiesForMailboxSettingsCompletedEventArgs Class See Also Send Feedback
Gets the retrieved mailbox values.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxRetrievedValues MailboxRetrievedValues { get; }
Visual Basic
Public ReadOnly Property MailboxRetrievedValues As MailboxRetrievedValues
    Get

Field Value

The retrieved mailbox values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RetrievePropertiesForMailboxSettingsCompletedEventArgs Class
RetrievePropertiesForMailboxSettingsCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox Namespace


WorkgroupMailboxProperties Class

[image]

IceLib Technical Reference
WorkgroupMailboxProperties Class
Members See Also Send Feedback
Contains mailbox settings for a WorkgroupConfiguration.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupMailboxProperties
Visual Basic
Public Class WorkgroupMailboxProperties

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox..::..WorkgroupMailboxProperties

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


WorkgroupMailboxProperties Members

[image] [image]

IceLib Technical Reference
WorkgroupMailboxProperties Members
WorkgroupMailboxProperties Class Methods Properties See Also Send Feedback

The WorkgroupMailboxProperties type exposes the following members.

Methods

 | Name | Description
Public method | ApplyMailboxSettings | Applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | ApplyMailboxSettingsAsync | Asynchronously applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | RetrievePropertiesForMailboxSettingsAsync | Asynchronously retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Provides read-only access to the property representing the mailbox display name for this workgroup (use Property.Mailbox_DisplayName).
Public property | EmailAddress | Provides read-only access to the property representing the mailbox email address for this workgroup (use Property.Mailbox_EmailAddress).
Public property | Type | Provides read-only access to the property representing the mailbox option for this workgroup (use Property.Mailbox_Type).

See Also

WorkgroupMailboxProperties Class
ININ.IceLib.Configuration.Mailbox Namespace


WorkgroupMailboxProperties Methods

[image] [image]

IceLib Technical Reference
WorkgroupMailboxProperties Methods
WorkgroupMailboxProperties Class See Also Send Feedback

The WorkgroupMailboxProperties type exposes the following members.

Methods

 | Name | Description
Public method | ApplyMailboxSettings | Applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | ApplyMailboxSettingsAsync | Asynchronously applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RetrievePropertiesForMailboxSettings | Retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | RetrievePropertiesForMailboxSettingsAsync | Asynchronously retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupMailboxProperties Class
ININ.IceLib.Configuration.Mailbox Namespace


ApplyMailboxSettings Method

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..ApplyMailboxSettings Method
WorkgroupMailboxProperties Class See Also Send Feedback
Applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ApplyMailboxSettings(
    MailboxSettings mailboxSettings
)
Visual Basic
Public Sub ApplyMailboxSettings ( _
    mailboxSettings As MailboxSettings _
)

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace
WorkgroupMailboxProperties..::..RetrievePropertiesForMailboxSettings(MailboxSettings)


ApplyMailboxSettingsAsync Method

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..ApplyMailboxSettingsAsync Method
WorkgroupMailboxProperties Class See Also Send Feedback
Asynchronously applies the specified mailbox settings to this MailboxProperties. The values are not saved until Commit()()()() is called.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ApplyMailboxSettingsAsync(
    MailboxSettings mailboxSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ApplyMailboxSettingsAsync ( _
    mailboxSettings As MailboxSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


RetrievePropertiesForMailboxSettings Method

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..RetrievePropertiesForMailboxSettings Method
WorkgroupMailboxProperties Class See Also Send Feedback
Retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxRetrievedValues RetrievePropertiesForMailboxSettings(
    MailboxSettings mailboxSettings
)
Visual Basic
Public Function RetrievePropertiesForMailboxSettings ( _
    mailboxSettings As MailboxSettings _
) As MailboxRetrievedValues

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.

Return Value

The retrieved mailbox values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace
WorkgroupMailboxProperties..::..ApplyMailboxSettings(MailboxSettings)


RetrievePropertiesForMailboxSettingsAsync Method

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..RetrievePropertiesForMailboxSettingsAsync Method
WorkgroupMailboxProperties Class See Also Send Feedback
Asynchronously retrieves the property values that would result from applying the specified mailbox settings. The values are not applied to this MailboxProperties.

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RetrievePropertiesForMailboxSettingsAsync(
    MailboxSettings mailboxSettings,
    EventHandler<RetrievePropertiesForMailboxSettingsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub RetrievePropertiesForMailboxSettingsAsync ( _
    mailboxSettings As MailboxSettings, _
    completedCallback As EventHandler(Of RetrievePropertiesForMailboxSettingsCompletedEventArgs), _
    userState As Object _
)

Parameters

mailboxSettings
Type: ININ.IceLib.Configuration.Mailbox..::..MailboxSettings
The mailbox settings.
completedCallback
Type: System..::..EventHandler<(Of <(<' RetrievePropertiesForMailboxSettingsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


WorkgroupMailboxProperties Properties

[image] [image]

IceLib Technical Reference
WorkgroupMailboxProperties Properties
WorkgroupMailboxProperties Class See Also Send Feedback

The WorkgroupMailboxProperties type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Provides read-only access to the property representing the mailbox display name for this workgroup (use Property.Mailbox_DisplayName).
Public property | EmailAddress | Provides read-only access to the property representing the mailbox email address for this workgroup (use Property.Mailbox_EmailAddress).
Public property | Type | Provides read-only access to the property representing the mailbox option for this workgroup (use Property.Mailbox_Type).

See Also

WorkgroupMailboxProperties Class
ININ.IceLib.Configuration.Mailbox Namespace


DisplayName Property

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..DisplayName Property
WorkgroupMailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox display name for this workgroup (use Property.Mailbox_DisplayName).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the mailbox display name.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


EmailAddress Property

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..EmailAddress Property
WorkgroupMailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox email address for this workgroup (use Property.Mailbox_EmailAddress).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, string> EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, String)
    Get

Field Value

The property representing the mailbox email address.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


Type Property

[image]

IceLib Technical Reference
WorkgroupMailboxProperties..::..Type Property
WorkgroupMailboxProperties Class See Also Send Feedback
Provides read-only access to the property representing the mailbox option for this workgroup (use Property.Mailbox_Type).

Namespace: ININ.IceLib.Configuration.Mailbox
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<WorkgroupConfiguration..::..Property, MailboxType> Type { get; }
Visual Basic
Public ReadOnly Property Type As GeneralConfigurationProperty(Of WorkgroupConfiguration..::..Property, MailboxType)
    Get

Field Value

The property representing the mailbox type.

Remarks

Note
This property is not directly editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupMailboxProperties Class
WorkgroupMailboxProperties Members
ININ.IceLib.Configuration.Mailbox Namespace


ININ.IceLib.Configuration.Mailbox.Utility Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Mailbox.Utility Namespace
Send Feedback

The ININ.IceLib.Configuration.Mailbox.Utility namespace contains classes to define, retrieve, set, and test IMAP servers, as well as to define and test various aspects of e-mail sending and delivery.

Classes

 | Class | Description
Public class | GetEnabledMailboxTypesCompletedEventArgs | Provides data for asynchronous completed events of GetEnabledMailboxTypesAsync(EventHandler<(Of <<'(GetEnabledMailboxTypesCompletedEventArgs>)>>), Object).
Public class | GetImapServersCompletedEventArgs | Provides data for asynchronous completed events of GetImapServersAsync(EventHandler<(Of <<'(GetImapServersCompletedEventArgs>)>>), Object).
Public class | GetInteractionMessageStoreMailboxesCompletedEventArgs | Provides data for asynchronous completed events of GetInteractionMessageStoreMailboxesAsync(EventHandler<(Of <<'(GetInteractionMessageStoreMailboxesCompletedEventArgs>)>>), Object).
Public class | GetMailboxFoldersCompletedEventArgs | Provides data for asynchronous completed events of GetMailboxFoldersAsync(GetMailboxFoldersParameters, EventHandler<(Of <<'(GetMailboxFoldersCompletedEventArgs>)>>), Object).
Public class | GetMailboxFoldersParameters | Provides details when testing monikers via GetMailboxFolders(GetMailboxFoldersParameters) and GetMailboxFoldersAsync(GetMailboxFoldersParameters, EventHandler<(Of <<'(GetMailboxFoldersCompletedEventArgs>)>>), Object).
Public class | GetSearchableDirectoriesCompletedEventArgs | Provides data for asynchronous completed events of GetSearchableDirectoriesAsync(EventHandler<(Of <<'(GetSearchableDirectoriesCompletedEventArgs>)>>), Object).
Public class | ImapServerDefinition | Class that hold information about an imap server.
Public class | MailboxDirectoryDefinition | Class that holds information about a mailbox directory. SearchDirectories(SearchDirectoriesParameters) SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object)
Public class | MailboxUtilities | Class that provides access to various mailbox functions.
Public class | OpenMailboxCompletedEventArgs | Provides data for asynchronous completed events of OpenMailboxAsync(OpenMailboxParameters, EventHandler<(Of <<'(OpenMailboxCompletedEventArgs>)>>), Object).
Public class | OpenMailboxParameters | Provides details when opening a mailbox via OpenMailbox(OpenMailboxParameters) or OpenMailboxAsync(OpenMailboxParameters, EventHandler<(Of <<'(OpenMailboxCompletedEventArgs>)>>), Object).
Public class | SearchDirectoriesCompletedEventArgs | Provides data for asynchronous completed events of SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).
Public class | SearchDirectoriesParameters | Provides details when searching directories via SearchDirectories(SearchDirectoriesParameters) and SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).
Public class | SendEmailCompletedEventArgs | Provides data for asynchronous completed events of SendEmailAsync(SendEmailParameters, EventHandler<(Of <<'(SendEmailCompletedEventArgs>)>>), Object).
Public class | SendEmailParameters | Provides details when creating emails via SendEmail(SendEmailParameters) and SendEmailAsync(SendEmailParameters, EventHandler<(Of <<'(SendEmailCompletedEventArgs>)>>), Object).
Public class | TestMonikerCompletedEventArgs | Provides data for asynchronous completed events of TestMonikerAsync(TestMonikerParameters, EventHandler<(Of <<'(TestMonikerCompletedEventArgs>)>>), Object).
Public class | TestMonikerParameters | Provides details when testing monikers via TestMoniker(TestMonikerParameters) and TestMonikerAsync(TestMonikerParameters, EventHandler<(Of <<'(TestMonikerCompletedEventArgs>)>>), Object).

Enumerations

 | Enumeration | Description
Public enumeration | EnabledMailboxType | Represents an enabled mailbox type for GetEnabledMailboxTypes()()()() and GetEnabledMailboxTypesAsync(EventHandler<(Of <<'(GetEnabledMailboxTypesCompletedEventArgs>)>>), Object).
Public enumeration | SearchDirectoryType | Describes the types of directory searches when using SearchDirectories(SearchDirectoriesParameters) or SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


EnabledMailboxType Enumeration

[image]

IceLib Technical Reference
EnabledMailboxType Enumeration
See Also Send Feedback
Represents an enabled mailbox type for GetEnabledMailboxTypes()()()() and GetEnabledMailboxTypesAsync(EventHandler<(Of <<'(GetEnabledMailboxTypesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EnabledMailboxType
Visual Basic
Public Enumeration EnabledMailboxType

Members

Member name | Value | Description
None | 0 | Represents no mailbox type.
Exchange | 1 | Represents the Exchange mailbox type.
Notes | 2 | Represents the Notes mailbox type.
InteractionMessageStore | 3 | Represents the Interaction Message Store mailbox type.
GroupWise | 4 | Represents the GroupWise mailbox type.
Ldap | 5 | Represents the LDAP mailbox type.
Smtp | 6 | Represents the SMTP mailbox type.
Imap | 7 | Represents the IMAP mailbox type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetEnabledMailboxTypesCompletedEventArgs Class

[image]

IceLib Technical Reference
GetEnabledMailboxTypesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetEnabledMailboxTypesAsync(EventHandler<(Of <<'(GetEnabledMailboxTypesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetEnabledMailboxTypesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetEnabledMailboxTypesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..GetEnabledMailboxTypesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetEnabledMailboxTypesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetEnabledMailboxTypesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetEnabledMailboxTypesCompletedEventArgs Members
GetEnabledMailboxTypesCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetEnabledMailboxTypesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | MailboxTypes | Gets the mailbox types.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetEnabledMailboxTypesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetEnabledMailboxTypesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetEnabledMailboxTypesCompletedEventArgs Methods
GetEnabledMailboxTypesCompletedEventArgs Class See Also Send Feedback

The GetEnabledMailboxTypesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetEnabledMailboxTypesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetEnabledMailboxTypesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetEnabledMailboxTypesCompletedEventArgs Properties
GetEnabledMailboxTypesCompletedEventArgs Class See Also Send Feedback

The GetEnabledMailboxTypesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | MailboxTypes | Gets the mailbox types.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetEnabledMailboxTypesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxTypes Property

[image]

IceLib Technical Reference
GetEnabledMailboxTypesCompletedEventArgs..::..MailboxTypes Property
GetEnabledMailboxTypesCompletedEventArgs Class See Also Send Feedback
Gets the mailbox types.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<EnabledMailboxType> MailboxTypes { get; }
Visual Basic
Public ReadOnly Property MailboxTypes As ICollection(Of EnabledMailboxType)
    Get

Field Value

The mailbox types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetEnabledMailboxTypesCompletedEventArgs Class
GetEnabledMailboxTypesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetImapServersCompletedEventArgs Class

[image]

IceLib Technical Reference
GetImapServersCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetImapServersAsync(EventHandler<(Of <<'(GetImapServersCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetImapServersCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetImapServersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..GetImapServersCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetImapServersCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetImapServersCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetImapServersCompletedEventArgs Members
GetImapServersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetImapServersCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ImapServers | Gets the imap servers.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetImapServersCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetImapServersCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetImapServersCompletedEventArgs Methods
GetImapServersCompletedEventArgs Class See Also Send Feedback

The GetImapServersCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetImapServersCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetImapServersCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetImapServersCompletedEventArgs Properties
GetImapServersCompletedEventArgs Class See Also Send Feedback

The GetImapServersCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ImapServers | Gets the imap servers.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetImapServersCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ImapServers Property

[image]

IceLib Technical Reference
GetImapServersCompletedEventArgs..::..ImapServers Property
GetImapServersCompletedEventArgs Class See Also Send Feedback
Gets the imap servers.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<ImapServerDefinition> ImapServers { get; }
Visual Basic
Public ReadOnly Property ImapServers As ICollection(Of ImapServerDefinition)
    Get

Field Value

The imap servers.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetImapServersCompletedEventArgs Class
GetImapServersCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetInteractionMessageStoreMailboxesCompletedEventArgs Class

[image]

IceLib Technical Reference
GetInteractionMessageStoreMailboxesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetInteractionMessageStoreMailboxesAsync(EventHandler<(Of <<'(GetInteractionMessageStoreMailboxesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetInteractionMessageStoreMailboxesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetInteractionMessageStoreMailboxesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..GetInteractionMessageStoreMailboxesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetInteractionMessageStoreMailboxesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetInteractionMessageStoreMailboxesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetInteractionMessageStoreMailboxesCompletedEventArgs Members
GetInteractionMessageStoreMailboxesCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInteractionMessageStoreMailboxesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Mailboxes | Gets the mailboxes.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionMessageStoreMailboxesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetInteractionMessageStoreMailboxesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetInteractionMessageStoreMailboxesCompletedEventArgs Methods
GetInteractionMessageStoreMailboxesCompletedEventArgs Class See Also Send Feedback

The GetInteractionMessageStoreMailboxesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInteractionMessageStoreMailboxesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetInteractionMessageStoreMailboxesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetInteractionMessageStoreMailboxesCompletedEventArgs Properties
GetInteractionMessageStoreMailboxesCompletedEventArgs Class See Also Send Feedback

The GetInteractionMessageStoreMailboxesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Mailboxes | Gets the mailboxes.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionMessageStoreMailboxesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Mailboxes Property

[image]

IceLib Technical Reference
GetInteractionMessageStoreMailboxesCompletedEventArgs..::..Mailboxes Property
GetInteractionMessageStoreMailboxesCompletedEventArgs Class See Also Send Feedback
Gets the mailboxes.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<MailboxDirectoryDefinition> Mailboxes { get; }
Visual Basic
Public ReadOnly Property Mailboxes As ICollection(Of MailboxDirectoryDefinition)
    Get

Field Value

The mailboxes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetInteractionMessageStoreMailboxesCompletedEventArgs Class
GetInteractionMessageStoreMailboxesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersCompletedEventArgs Class

[image]

IceLib Technical Reference
GetMailboxFoldersCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetMailboxFoldersAsync(GetMailboxFoldersParameters, EventHandler<(Of <<'(GetMailboxFoldersCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetMailboxFoldersCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetMailboxFoldersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..GetMailboxFoldersCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetMailboxFoldersCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetMailboxFoldersCompletedEventArgs Members
GetMailboxFoldersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetMailboxFoldersCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Folders | Gets the folders.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetMailboxFoldersCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetMailboxFoldersCompletedEventArgs Methods
GetMailboxFoldersCompletedEventArgs Class See Also Send Feedback

The GetMailboxFoldersCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetMailboxFoldersCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetMailboxFoldersCompletedEventArgs Properties
GetMailboxFoldersCompletedEventArgs Class See Also Send Feedback

The GetMailboxFoldersCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Folders | Gets the folders.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetMailboxFoldersCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Folders Property

[image]

IceLib Technical Reference
GetMailboxFoldersCompletedEventArgs..::..Folders Property
GetMailboxFoldersCompletedEventArgs Class See Also Send Feedback
Gets the folders.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<string> Folders { get; }
Visual Basic
Public ReadOnly Property Folders As ICollection(Of String)
    Get

Field Value

The folders.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetMailboxFoldersCompletedEventArgs Class
GetMailboxFoldersCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersParameters Class

[image]

IceLib Technical Reference
GetMailboxFoldersParameters Class
Members See Also Send Feedback
Provides details when testing monikers via GetMailboxFolders(GetMailboxFoldersParameters) and GetMailboxFoldersAsync(GetMailboxFoldersParameters, EventHandler<(Of <<'(GetMailboxFoldersCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetMailboxFoldersParameters
Visual Basic
Public Class GetMailboxFoldersParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..GetMailboxFoldersParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetMailboxFoldersParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersParameters Members

[image] [image]

IceLib Technical Reference
GetMailboxFoldersParameters Members
GetMailboxFoldersParameters Class Constructors Methods Properties See Also Send Feedback

The GetMailboxFoldersParameters type exposes the following members.

Constructors

 | Name | Description
Public method | GetMailboxFoldersParameters | Initializes a new instance of the GetMailboxFoldersParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Moniker | Gets the moniker.

See Also

GetMailboxFoldersParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersParameters Constructor

[image]

IceLib Technical Reference
GetMailboxFoldersParameters Constructor
GetMailboxFoldersParameters Class See Also Send Feedback
Initializes a new instance of the GetMailboxFoldersParameters class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetMailboxFoldersParameters(
    string moniker
)
Visual Basic
Public Sub New ( _
    moniker As String _
)

Parameters

moniker
Type: System..::..String
The moniker.

Exceptions

Exception | Condition
System..::..ArgumentNullException | moniker is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | moniker is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetMailboxFoldersParameters Class
GetMailboxFoldersParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersParameters Methods

[image] [image]

IceLib Technical Reference
GetMailboxFoldersParameters Methods
GetMailboxFoldersParameters Class See Also Send Feedback

The GetMailboxFoldersParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

GetMailboxFoldersParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ToString Method

[image]

IceLib Technical Reference
GetMailboxFoldersParameters..::..ToString Method
GetMailboxFoldersParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetMailboxFoldersParameters Class
GetMailboxFoldersParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersParameters Properties

[image] [image]

IceLib Technical Reference
GetMailboxFoldersParameters Properties
GetMailboxFoldersParameters Class See Also Send Feedback

The GetMailboxFoldersParameters type exposes the following members.

Properties

 | Name | Description
Public property | Moniker | Gets the moniker.

See Also

GetMailboxFoldersParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Moniker Property

[image]

IceLib Technical Reference
GetMailboxFoldersParameters..::..Moniker Property
GetMailboxFoldersParameters Class See Also Send Feedback
Gets the moniker.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Moniker { get; }
Visual Basic
Public ReadOnly Property Moniker As String
    Get

Field Value

The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetMailboxFoldersParameters Class
GetMailboxFoldersParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetSearchableDirectoriesCompletedEventArgs Class

[image]

IceLib Technical Reference
GetSearchableDirectoriesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetSearchableDirectoriesAsync(EventHandler<(Of <<'(GetSearchableDirectoriesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetSearchableDirectoriesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetSearchableDirectoriesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..GetSearchableDirectoriesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetSearchableDirectoriesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetSearchableDirectoriesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetSearchableDirectoriesCompletedEventArgs Members
GetSearchableDirectoriesCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetSearchableDirectoriesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Directories | Gets the directories.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetSearchableDirectoriesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetSearchableDirectoriesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetSearchableDirectoriesCompletedEventArgs Methods
GetSearchableDirectoriesCompletedEventArgs Class See Also Send Feedback

The GetSearchableDirectoriesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetSearchableDirectoriesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetSearchableDirectoriesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetSearchableDirectoriesCompletedEventArgs Properties
GetSearchableDirectoriesCompletedEventArgs Class See Also Send Feedback

The GetSearchableDirectoriesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Directories | Gets the directories.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetSearchableDirectoriesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Directories Property

[image]

IceLib Technical Reference
GetSearchableDirectoriesCompletedEventArgs..::..Directories Property
GetSearchableDirectoriesCompletedEventArgs Class See Also Send Feedback
Gets the directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<string> Directories { get; }
Visual Basic
Public ReadOnly Property Directories As ICollection(Of String)
    Get

Field Value

The directories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetSearchableDirectoriesCompletedEventArgs Class
GetSearchableDirectoriesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ImapServerDefinition Class

[image]

IceLib Technical Reference
ImapServerDefinition Class
Members See Also Send Feedback
Class that hold information about an imap server.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ImapServerDefinition
Visual Basic
Public Class ImapServerDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..ImapServerDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ImapServerDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace
MailboxUtilities..::..GetImapServers()()()()
MailboxUtilities..::..GetImapServersAsync(EventHandler<(Of <<'(GetImapServersCompletedEventArgs>)>>), Object)


ImapServerDefinition Members

[image] [image]

IceLib Technical Reference
ImapServerDefinition Members
ImapServerDefinition Class Methods Properties See Also Send Feedback

The ImapServerDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ServerName | Gets the name of the server.
Public property | SupportsProxyAuthentication | Gets a value indicating whether the server supports proxy authentication.

See Also

ImapServerDefinition Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ImapServerDefinition Methods

[image] [image]

IceLib Technical Reference
ImapServerDefinition Methods
ImapServerDefinition Class See Also Send Feedback

The ImapServerDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImapServerDefinition Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ImapServerDefinition Properties

[image] [image]

IceLib Technical Reference
ImapServerDefinition Properties
ImapServerDefinition Class See Also Send Feedback

The ImapServerDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ServerName | Gets the name of the server.
Public property | SupportsProxyAuthentication | Gets a value indicating whether the server supports proxy authentication.

See Also

ImapServerDefinition Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ServerName Property

[image]

IceLib Technical Reference
ImapServerDefinition..::..ServerName Property
ImapServerDefinition Class See Also Send Feedback
Gets the name of the server.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ServerName { get; }
Visual Basic
Public ReadOnly Property ServerName As String
    Get

Field Value

The name of the server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ImapServerDefinition Class
ImapServerDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SupportsProxyAuthentication Property

[image]

IceLib Technical Reference
ImapServerDefinition..::..SupportsProxyAuthentication Property
ImapServerDefinition Class See Also Send Feedback
Gets a value indicating whether the server supports proxy authentication.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SupportsProxyAuthentication { get; }
Visual Basic
Public ReadOnly Property SupportsProxyAuthentication As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the server supports proxy authentication; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ImapServerDefinition Class
ImapServerDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxDirectoryDefinition Class

[image]

IceLib Technical Reference
MailboxDirectoryDefinition Class
Members See Also Send Feedback
Class that holds information about a mailbox directory. SearchDirectories(SearchDirectoriesParameters) SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object)

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MailboxDirectoryDefinition
Visual Basic
Public Class MailboxDirectoryDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..MailboxDirectoryDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxDirectoryDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxDirectoryDefinition Members

[image] [image]

IceLib Technical Reference
MailboxDirectoryDefinition Members
MailboxDirectoryDefinition Class Methods Properties See Also Send Feedback

The MailboxDirectoryDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectoryEntry | Gets the directory entry.
Public property | DisplayName | Gets the display name.
Public property | EmailAddress | Gets the email address.
Public property | Mailbox | Gets the mailbox.
Public property | MailboxType | Gets the type of the mailbox.

See Also

MailboxDirectoryDefinition Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxDirectoryDefinition Methods

[image] [image]

IceLib Technical Reference
MailboxDirectoryDefinition Methods
MailboxDirectoryDefinition Class See Also Send Feedback

The MailboxDirectoryDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailboxDirectoryDefinition Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxDirectoryDefinition Properties

[image] [image]

IceLib Technical Reference
MailboxDirectoryDefinition Properties
MailboxDirectoryDefinition Class See Also Send Feedback

The MailboxDirectoryDefinition type exposes the following members.

Properties

 | Name | Description
Public property | DirectoryEntry | Gets the directory entry.
Public property | DisplayName | Gets the display name.
Public property | EmailAddress | Gets the email address.
Public property | Mailbox | Gets the mailbox.
Public property | MailboxType | Gets the type of the mailbox.

See Also

MailboxDirectoryDefinition Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


DirectoryEntry Property

[image]

IceLib Technical Reference
MailboxDirectoryDefinition..::..DirectoryEntry Property
MailboxDirectoryDefinition Class See Also Send Feedback
Gets the directory entry.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DirectoryEntry { get; }
Visual Basic
Public ReadOnly Property DirectoryEntry As String
    Get

Field Value

The directory entry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxDirectoryDefinition Class
MailboxDirectoryDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


DisplayName Property

[image]

IceLib Technical Reference
MailboxDirectoryDefinition..::..DisplayName Property
MailboxDirectoryDefinition Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxDirectoryDefinition Class
MailboxDirectoryDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


EmailAddress Property

[image]

IceLib Technical Reference
MailboxDirectoryDefinition..::..EmailAddress Property
MailboxDirectoryDefinition Class See Also Send Feedback
Gets the email address.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailAddress { get; }
Visual Basic
Public ReadOnly Property EmailAddress As String
    Get

Field Value

The email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxDirectoryDefinition Class
MailboxDirectoryDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Mailbox Property

[image]

IceLib Technical Reference
MailboxDirectoryDefinition..::..Mailbox Property
MailboxDirectoryDefinition Class See Also Send Feedback
Gets the mailbox.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Mailbox { get; }
Visual Basic
Public ReadOnly Property Mailbox As String
    Get

Field Value

The mailbox.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxDirectoryDefinition Class
MailboxDirectoryDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxType Property

[image]

IceLib Technical Reference
MailboxDirectoryDefinition..::..MailboxType Property
MailboxDirectoryDefinition Class See Also Send Feedback
Gets the type of the mailbox.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxDirectoryType MailboxType { get; }
Visual Basic
Public ReadOnly Property MailboxType As MailboxDirectoryType
    Get

Field Value

The type of the mailbox.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxDirectoryDefinition Class
MailboxDirectoryDefinition Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxUtilities Class

[image]

IceLib Technical Reference
MailboxUtilities Class
Members See Also Send Feedback
Class that provides access to various mailbox functions.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MailboxUtilities
Visual Basic
Public Class MailboxUtilities

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..MailboxUtilities

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxUtilities Members

[image] [image]

IceLib Technical Reference
MailboxUtilities Members
MailboxUtilities Class Constructors Methods See Also Send Feedback

The MailboxUtilities type exposes the following members.

Constructors

 | Name | Description
Public method | MailboxUtilities | Initializes a new instance of the MailboxUtilities class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnabledMailboxTypes | Gets the enabled mailbox types.
Public method | GetEnabledMailboxTypesAsync | Asynchronously gets the enabled mailbox types.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImapServers | Gets the available imap servers.
Public method | GetImapServersAsync | Asynchronously gets the available imap servers.
Public method | GetInteractionMessageStoreMailboxes | Gets the interaction maessage store mailboxes.
Public method | GetInteractionMessageStoreMailboxesAsync | Asynchronously gets the interaction maessage store mailboxes.
Public method | GetMailboxFolders | Gets the mailbox folders.
Public method | GetMailboxFoldersAsync | Asynchronously gets the mailbox folders.
Public method | GetSearchableDirectories | Gets the searchable directories.
Public method | GetSearchableDirectoriesAsync | Asynchronously gets the searchable directories.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenMailbox | Opens the mailbox.
Public method | OpenMailboxAsync | Asynchronously opens the mailbox.
Public method | SearchDirectories | Searches the directories.
Public method | SearchDirectoriesAsync | Asynchronously searches the directories.
Public method | SendEmail | Sends the email.
Public method | SendEmailAsync | Asynchronously sends the email.
Public method | TestMoniker | Tests the moniker.
Public method | TestMonikerAsync | Asynchronously tests the moniker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailboxUtilities Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxUtilities Constructor

[image]

IceLib Technical Reference
MailboxUtilities Constructor
MailboxUtilities Class See Also Send Feedback
Initializes a new instance of the MailboxUtilities class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MailboxUtilities(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxUtilities Methods

[image] [image]

IceLib Technical Reference
MailboxUtilities Methods
MailboxUtilities Class See Also Send Feedback

The MailboxUtilities type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnabledMailboxTypes | Gets the enabled mailbox types.
Public method | GetEnabledMailboxTypesAsync | Asynchronously gets the enabled mailbox types.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImapServers | Gets the available imap servers.
Public method | GetImapServersAsync | Asynchronously gets the available imap servers.
Public method | GetInteractionMessageStoreMailboxes | Gets the interaction maessage store mailboxes.
Public method | GetInteractionMessageStoreMailboxesAsync | Asynchronously gets the interaction maessage store mailboxes.
Public method | GetMailboxFolders | Gets the mailbox folders.
Public method | GetMailboxFoldersAsync | Asynchronously gets the mailbox folders.
Public method | GetSearchableDirectories | Gets the searchable directories.
Public method | GetSearchableDirectoriesAsync | Asynchronously gets the searchable directories.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenMailbox | Opens the mailbox.
Public method | OpenMailboxAsync | Asynchronously opens the mailbox.
Public method | SearchDirectories | Searches the directories.
Public method | SearchDirectoriesAsync | Asynchronously searches the directories.
Public method | SendEmail | Sends the email.
Public method | SendEmailAsync | Asynchronously sends the email.
Public method | TestMoniker | Tests the moniker.
Public method | TestMonikerAsync | Asynchronously tests the moniker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailboxUtilities Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetEnabledMailboxTypes Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetEnabledMailboxTypes Method
MailboxUtilities Class See Also Send Feedback
Gets the enabled mailbox types.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<EnabledMailboxType> GetEnabledMailboxTypes()
Visual Basic
Public Function GetEnabledMailboxTypes As ICollection(Of EnabledMailboxType)

Return Value

The enabled mailbox types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetEnabledMailboxTypesAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetEnabledMailboxTypesAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously gets the enabled mailbox types.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetEnabledMailboxTypesAsync(
    EventHandler<GetEnabledMailboxTypesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetEnabledMailboxTypesAsync ( _
    completedCallback As EventHandler(Of GetEnabledMailboxTypesCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetEnabledMailboxTypesCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetImapServers Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetImapServers Method
MailboxUtilities Class See Also Send Feedback
Gets the available imap servers.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<ImapServerDefinition> GetImapServers()
Visual Basic
Public Function GetImapServers As ICollection(Of ImapServerDefinition)

Return Value

The available imap servers.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetImapServersAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetImapServersAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously gets the available imap servers.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetImapServersAsync(
    EventHandler<GetImapServersCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetImapServersAsync ( _
    completedCallback As EventHandler(Of GetImapServersCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetImapServersCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetInteractionMessageStoreMailboxes Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetInteractionMessageStoreMailboxes Method
MailboxUtilities Class See Also Send Feedback
Gets the interaction maessage store mailboxes.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<MailboxDirectoryDefinition> GetInteractionMessageStoreMailboxes()
Visual Basic
Public Function GetInteractionMessageStoreMailboxes As ICollection(Of MailboxDirectoryDefinition)

Return Value

The interaction maessage store mailboxes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetInteractionMessageStoreMailboxesAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetInteractionMessageStoreMailboxesAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously gets the interaction maessage store mailboxes.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionMessageStoreMailboxesAsync(
    EventHandler<GetInteractionMessageStoreMailboxesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionMessageStoreMailboxesAsync ( _
    completedCallback As EventHandler(Of GetInteractionMessageStoreMailboxesCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetInteractionMessageStoreMailboxesCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFolders Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetMailboxFolders Method
MailboxUtilities Class See Also Send Feedback
Gets the mailbox folders.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<string> GetMailboxFolders(
    GetMailboxFoldersParameters getMailboxFoldersParameters
)
Visual Basic
Public Function GetMailboxFolders ( _
    getMailboxFoldersParameters As GetMailboxFoldersParameters _
) As ICollection(Of String)

Parameters

getMailboxFoldersParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..GetMailboxFoldersParameters
The mailbox folders parameters.

Return Value

The mailbox folders.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetMailboxFoldersAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetMailboxFoldersAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously gets the mailbox folders.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetMailboxFoldersAsync(
    GetMailboxFoldersParameters getMailboxFoldersParameters,
    EventHandler<GetMailboxFoldersCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetMailboxFoldersAsync ( _
    getMailboxFoldersParameters As GetMailboxFoldersParameters, _
    completedCallback As EventHandler(Of GetMailboxFoldersCompletedEventArgs), _
    userState As Object _
)

Parameters

getMailboxFoldersParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..GetMailboxFoldersParameters
The mailbox folders parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetMailboxFoldersCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetSearchableDirectories Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetSearchableDirectories Method
MailboxUtilities Class See Also Send Feedback
Gets the searchable directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<string> GetSearchableDirectories()
Visual Basic
Public Function GetSearchableDirectories As ICollection(Of String)

Return Value

The searchable directories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


GetSearchableDirectoriesAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..GetSearchableDirectoriesAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously gets the searchable directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetSearchableDirectoriesAsync(
    EventHandler<GetSearchableDirectoriesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetSearchableDirectoriesAsync ( _
    completedCallback As EventHandler(Of GetSearchableDirectoriesCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetSearchableDirectoriesCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailbox Method

[image]

IceLib Technical Reference
MailboxUtilities..::..OpenMailbox Method
MailboxUtilities Class See Also Send Feedback
Opens the mailbox.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool OpenMailbox(
    OpenMailboxParameters openMailboxParameters
)
Visual Basic
Public Function OpenMailbox ( _
    openMailboxParameters As OpenMailboxParameters _
) As Boolean

Parameters

openMailboxParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..OpenMailboxParameters
The open mailbox parameters.

Return Value

trueTruetruetrue (True in Visual Basic) if the mailbox was successfully opened; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..OpenMailboxAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously opens the mailbox.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void OpenMailboxAsync(
    OpenMailboxParameters openMailboxParameters,
    EventHandler<OpenMailboxCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub OpenMailboxAsync ( _
    openMailboxParameters As OpenMailboxParameters, _
    completedCallback As EventHandler(Of OpenMailboxCompletedEventArgs), _
    userState As Object _
)

Parameters

openMailboxParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..OpenMailboxParameters
The open mailbox parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' OpenMailboxCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectories Method

[image]

IceLib Technical Reference
MailboxUtilities..::..SearchDirectories Method
MailboxUtilities Class See Also Send Feedback
Searches the directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<MailboxDirectoryDefinition> SearchDirectories(
    SearchDirectoriesParameters searchDirectoriesParameters
)
Visual Basic
Public Function SearchDirectories ( _
    searchDirectoriesParameters As SearchDirectoriesParameters _
) As ICollection(Of MailboxDirectoryDefinition)

Parameters

searchDirectoriesParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..SearchDirectoriesParameters
The search directories parameters.

Return Value

The mailbox directories that match the search parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..ResultLimitExceededException | The number of search results exceeded the allowable limit.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..SearchDirectoriesAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously searches the directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SearchDirectoriesAsync(
    SearchDirectoriesParameters searchDirectoriesParameters,
    EventHandler<SearchDirectoriesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SearchDirectoriesAsync ( _
    searchDirectoriesParameters As SearchDirectoriesParameters, _
    completedCallback As EventHandler(Of SearchDirectoriesCompletedEventArgs), _
    userState As Object _
)

Parameters

searchDirectoriesParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..SearchDirectoriesParameters
The search directories parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' SearchDirectoriesCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmail Method

[image]

IceLib Technical Reference
MailboxUtilities..::..SendEmail Method
MailboxUtilities Class See Also Send Feedback
Sends the email.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendEmail(
    SendEmailParameters sendEmailParameters
)
Visual Basic
Public Function SendEmail ( _
    sendEmailParameters As SendEmailParameters _
) As Boolean

Parameters

sendEmailParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..SendEmailParameters
The send email parameters.

Return Value

trueTruetruetrue (True in Visual Basic) if the email was successfully sent; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..SendEmailAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously sends the email.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendEmailAsync(
    SendEmailParameters sendEmailParameters,
    EventHandler<SendEmailCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendEmailAsync ( _
    sendEmailParameters As SendEmailParameters, _
    completedCallback As EventHandler(Of SendEmailCompletedEventArgs), _
    userState As Object _
)

Parameters

sendEmailParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..SendEmailParameters
The send email parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' SendEmailCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMoniker Method

[image]

IceLib Technical Reference
MailboxUtilities..::..TestMoniker Method
MailboxUtilities Class See Also Send Feedback
Tests the moniker.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TestMoniker(
    TestMonikerParameters testMonikerParameters
)
Visual Basic
Public Function TestMoniker ( _
    testMonikerParameters As TestMonikerParameters _
) As Boolean

Parameters

testMonikerParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..TestMonikerParameters
The test moniker parameters.

Return Value

trueTruetruetrue (True in Visual Basic) if the moniker is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerAsync Method

[image]

IceLib Technical Reference
MailboxUtilities..::..TestMonikerAsync Method
MailboxUtilities Class See Also Send Feedback
Asynchronously tests the moniker.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TestMonikerAsync(
    TestMonikerParameters testMonikerParameters,
    EventHandler<TestMonikerCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub TestMonikerAsync ( _
    testMonikerParameters As TestMonikerParameters, _
    completedCallback As EventHandler(Of TestMonikerCompletedEventArgs), _
    userState As Object _
)

Parameters

testMonikerParameters
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..TestMonikerParameters
The test moniker parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' TestMonikerCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MailboxUtilities Class
MailboxUtilities Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxCompletedEventArgs Class

[image]

IceLib Technical Reference
OpenMailboxCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of OpenMailboxAsync(OpenMailboxParameters, EventHandler<(Of <<'(OpenMailboxCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OpenMailboxCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class OpenMailboxCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..OpenMailboxCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OpenMailboxCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
OpenMailboxCompletedEventArgs Members
OpenMailboxCompletedEventArgs Class Methods Properties See Also Send Feedback

The OpenMailboxCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

OpenMailboxCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
OpenMailboxCompletedEventArgs Methods
OpenMailboxCompletedEventArgs Class See Also Send Feedback

The OpenMailboxCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenMailboxCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
OpenMailboxCompletedEventArgs Properties
OpenMailboxCompletedEventArgs Class See Also Send Feedback

The OpenMailboxCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

OpenMailboxCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Success Property

[image]

IceLib Technical Reference
OpenMailboxCompletedEventArgs..::..Success Property
OpenMailboxCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Success { get; }
Visual Basic
Public ReadOnly Property Success As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if successful; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OpenMailboxCompletedEventArgs Class
OpenMailboxCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxParameters Class

[image]

IceLib Technical Reference
OpenMailboxParameters Class
Members See Also Send Feedback
Provides details when opening a mailbox via OpenMailbox(OpenMailboxParameters) or OpenMailboxAsync(OpenMailboxParameters, EventHandler<(Of <<'(OpenMailboxCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OpenMailboxParameters
Visual Basic
Public Class OpenMailboxParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..OpenMailboxParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OpenMailboxParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxParameters Members

[image] [image]

IceLib Technical Reference
OpenMailboxParameters Members
OpenMailboxParameters Class Constructors Methods Properties See Also Send Feedback

The OpenMailboxParameters type exposes the following members.

Constructors

 | Name | Description
Public method | OpenMailboxParameters | Initializes a new instance of the OpenMailboxParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Moniker | Gets the moniker.

See Also

OpenMailboxParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxParameters Constructor

[image]

IceLib Technical Reference
OpenMailboxParameters Constructor
OpenMailboxParameters Class See Also Send Feedback
Initializes a new instance of the OpenMailboxParameters class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OpenMailboxParameters(
    string moniker
)
Visual Basic
Public Sub New ( _
    moniker As String _
)

Parameters

moniker
Type: System..::..String
The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OpenMailboxParameters Class
OpenMailboxParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxParameters Methods

[image] [image]

IceLib Technical Reference
OpenMailboxParameters Methods
OpenMailboxParameters Class See Also Send Feedback

The OpenMailboxParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

OpenMailboxParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ToString Method

[image]

IceLib Technical Reference
OpenMailboxParameters..::..ToString Method
OpenMailboxParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OpenMailboxParameters Class
OpenMailboxParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


OpenMailboxParameters Properties

[image] [image]

IceLib Technical Reference
OpenMailboxParameters Properties
OpenMailboxParameters Class See Also Send Feedback

The OpenMailboxParameters type exposes the following members.

Properties

 | Name | Description
Public property | Moniker | Gets the moniker.

See Also

OpenMailboxParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Moniker Property

[image]

IceLib Technical Reference
OpenMailboxParameters..::..Moniker Property
OpenMailboxParameters Class See Also Send Feedback
Gets the moniker.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Moniker { get; }
Visual Basic
Public ReadOnly Property Moniker As String
    Get

Field Value

The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OpenMailboxParameters Class
OpenMailboxParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesCompletedEventArgs Class

[image]

IceLib Technical Reference
SearchDirectoriesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchDirectoriesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class SearchDirectoriesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..SearchDirectoriesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
SearchDirectoriesCompletedEventArgs Members
SearchDirectoriesCompletedEventArgs Class Methods Properties See Also Send Feedback

The SearchDirectoriesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | MailboxDirectories | Gets the mailbox directories.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SearchDirectoriesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
SearchDirectoriesCompletedEventArgs Methods
SearchDirectoriesCompletedEventArgs Class See Also Send Feedback

The SearchDirectoriesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchDirectoriesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
SearchDirectoriesCompletedEventArgs Properties
SearchDirectoriesCompletedEventArgs Class See Also Send Feedback

The SearchDirectoriesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | MailboxDirectories | Gets the mailbox directories.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SearchDirectoriesCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


MailboxDirectories Property

[image]

IceLib Technical Reference
SearchDirectoriesCompletedEventArgs..::..MailboxDirectories Property
SearchDirectoriesCompletedEventArgs Class See Also Send Feedback
Gets the mailbox directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICollection<MailboxDirectoryDefinition> MailboxDirectories { get; }
Visual Basic
Public ReadOnly Property MailboxDirectories As ICollection(Of MailboxDirectoryDefinition)
    Get

Field Value

The mailbox directories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesCompletedEventArgs Class
SearchDirectoriesCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Class

[image]

IceLib Technical Reference
SearchDirectoriesParameters Class
Members See Also Send Feedback
Provides details when searching directories via SearchDirectories(SearchDirectoriesParameters) and SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchDirectoriesParameters
Visual Basic
Public Class SearchDirectoriesParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..SearchDirectoriesParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Members

[image] [image]

IceLib Technical Reference
SearchDirectoriesParameters Members
SearchDirectoriesParameters Class Constructors Methods Properties See Also Send Feedback

The SearchDirectoriesParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SearchDirectoriesParameters(String, SearchDirectoryType, String) | Initializes a new instance of the SearchDirectoriesParameters class.
Public method | SearchDirectoriesParameters(String, SearchDirectoryType, String, Boolean) | Initializes a new instance of the SearchDirectoriesParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IncludeDistributionLists | Gets a value indicating if the directory search should return distribution lists in the results.
Public property | SearchDirectories | Gets the search directories.
Public property | SearchTerm | Gets the search term.
Public property | SearchType | Gets the type of the search.

See Also

SearchDirectoriesParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Constructor

[image] [image]

IceLib Technical Reference
SearchDirectoriesParameters Constructor
SearchDirectoriesParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SearchDirectoriesParameters(String, SearchDirectoryType, String) | Initializes a new instance of the SearchDirectoriesParameters class.
Public method | SearchDirectoriesParameters(String, SearchDirectoryType, String, Boolean) | Initializes a new instance of the SearchDirectoriesParameters class.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Constructor (String, SearchDirectoryType, String)

[image]

IceLib Technical Reference
SearchDirectoriesParameters Constructor (String, SearchDirectoryType, String)
SearchDirectoriesParameters Class See Also Send Feedback
Initializes a new instance of the SearchDirectoriesParameters class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchDirectoriesParameters(
    string searchTerm,
    SearchDirectoryType searchType,
    string searchDirectories
)
Visual Basic
Public Sub New ( _
    searchTerm As String, _
    searchType As SearchDirectoryType, _
    searchDirectories As String _
)

Parameters

searchTerm
Type: System..::..String
The search term.
searchType
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..SearchDirectoryType
Type of the search.
searchDirectories
Type: System..::..String
The search directories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
SearchDirectoriesParameters Overload
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Constructor (String, SearchDirectoryType, String, Boolean)

[image]

IceLib Technical Reference
SearchDirectoriesParameters Constructor (String, SearchDirectoryType, String, Boolean)
SearchDirectoriesParameters Class See Also Send Feedback
Initializes a new instance of the SearchDirectoriesParameters class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchDirectoriesParameters(
    string searchTerm,
    SearchDirectoryType searchType,
    string searchDirectories,
    bool includeDistributionLists
)
Visual Basic
Public Sub New ( _
    searchTerm As String, _
    searchType As SearchDirectoryType, _
    searchDirectories As String, _
    includeDistributionLists As Boolean _
)

Parameters

searchTerm
Type: System..::..String
The search term.
searchType
Type: ININ.IceLib.Configuration.Mailbox.Utility..::..SearchDirectoryType
Type of the search.
searchDirectories
Type: System..::..String
The search directories.
includeDistributionLists
Type: System..::..Boolean
Determines if the directory search should return distribution lists in the results.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
SearchDirectoriesParameters Overload
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Methods

[image] [image]

IceLib Technical Reference
SearchDirectoriesParameters Methods
SearchDirectoriesParameters Class See Also Send Feedback

The SearchDirectoriesParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SearchDirectoriesParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ToString Method

[image]

IceLib Technical Reference
SearchDirectoriesParameters..::..ToString Method
SearchDirectoriesParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoriesParameters Properties

[image] [image]

IceLib Technical Reference
SearchDirectoriesParameters Properties
SearchDirectoriesParameters Class See Also Send Feedback

The SearchDirectoriesParameters type exposes the following members.

Properties

 | Name | Description
Public property | IncludeDistributionLists | Gets a value indicating if the directory search should return distribution lists in the results.
Public property | SearchDirectories | Gets the search directories.
Public property | SearchTerm | Gets the search term.
Public property | SearchType | Gets the type of the search.

See Also

SearchDirectoriesParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


IncludeDistributionLists Property

[image]

IceLib Technical Reference
SearchDirectoriesParameters..::..IncludeDistributionLists Property
SearchDirectoriesParameters Class See Also Send Feedback
Gets a value indicating if the directory search should return distribution lists in the results.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IncludeDistributionLists { get; }
Visual Basic
Public ReadOnly Property IncludeDistributionLists As Boolean
    Get

Field Value

true if distribution lists should be returned in the search results; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectories Property

[image]

IceLib Technical Reference
SearchDirectoriesParameters..::..SearchDirectories Property
SearchDirectoriesParameters Class See Also Send Feedback
Gets the search directories.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SearchDirectories { get; }
Visual Basic
Public ReadOnly Property SearchDirectories As String
    Get

Field Value

The search directories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchTerm Property

[image]

IceLib Technical Reference
SearchDirectoriesParameters..::..SearchTerm Property
SearchDirectoriesParameters Class See Also Send Feedback
Gets the search term.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SearchTerm { get; }
Visual Basic
Public ReadOnly Property SearchTerm As String
    Get

Field Value

The search term.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchType Property

[image]

IceLib Technical Reference
SearchDirectoriesParameters..::..SearchType Property
SearchDirectoriesParameters Class See Also Send Feedback
Gets the type of the search.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchDirectoryType SearchType { get; }
Visual Basic
Public ReadOnly Property SearchType As SearchDirectoryType
    Get

Field Value

The type of the search.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SearchDirectoriesParameters Class
SearchDirectoriesParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SearchDirectoryType Enumeration

[image]

IceLib Technical Reference
SearchDirectoryType Enumeration
See Also Send Feedback
Describes the types of directory searches when using SearchDirectories(SearchDirectoriesParameters) or SearchDirectoriesAsync(SearchDirectoriesParameters, EventHandler<(Of <<'(SearchDirectoriesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum SearchDirectoryType
Visual Basic
Public Enumeration SearchDirectoryType

Members

Member name | Value | Description
Name | 0 | Search the directory by name.
Address | 1 | Search the directory by email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailCompletedEventArgs Class

[image]

IceLib Technical Reference
SendEmailCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of SendEmailAsync(SendEmailParameters, EventHandler<(Of <<'(SendEmailCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SendEmailCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class SendEmailCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..SendEmailCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
SendEmailCompletedEventArgs Members
SendEmailCompletedEventArgs Class Methods Properties See Also Send Feedback

The SendEmailCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SendEmailCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
SendEmailCompletedEventArgs Methods
SendEmailCompletedEventArgs Class See Also Send Feedback

The SendEmailCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendEmailCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
SendEmailCompletedEventArgs Properties
SendEmailCompletedEventArgs Class See Also Send Feedback

The SendEmailCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SendEmailCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Success Property

[image]

IceLib Technical Reference
SendEmailCompletedEventArgs..::..Success Property
SendEmailCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Success { get; }
Visual Basic
Public ReadOnly Property Success As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if successful; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailCompletedEventArgs Class
SendEmailCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailParameters Class

[image]

IceLib Technical Reference
SendEmailParameters Class
Members See Also Send Feedback
Provides details when creating emails via SendEmail(SendEmailParameters) and SendEmailAsync(SendEmailParameters, EventHandler<(Of <<'(SendEmailCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SendEmailParameters
Visual Basic
Public Class SendEmailParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..SendEmailParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailParameters Members

[image] [image]

IceLib Technical Reference
SendEmailParameters Members
SendEmailParameters Class Constructors Methods Properties See Also Send Feedback

The SendEmailParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SendEmailParameters | Initializes a new instance of the SendEmailParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Body | Gets the body.
Public property | Recipients | Gets the recipients.
Public property | Subject | Gets the subject.

See Also

SendEmailParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailParameters Constructor

[image]

IceLib Technical Reference
SendEmailParameters Constructor
SendEmailParameters Class See Also Send Feedback
Initializes a new instance of the SendEmailParameters class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SendEmailParameters(
    IEnumerable<string> recipients,
    string subject,
    string body
)
Visual Basic
Public Sub New ( _
    recipients As IEnumerable(Of String), _
    subject As String, _
    body As String _
)

Parameters

recipients
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The recipients.
subject
Type: System..::..String
The subject.
body
Type: System..::..String
The body.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailParameters Class
SendEmailParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailParameters Methods

[image] [image]

IceLib Technical Reference
SendEmailParameters Methods
SendEmailParameters Class See Also Send Feedback

The SendEmailParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SendEmailParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ToString Method

[image]

IceLib Technical Reference
SendEmailParameters..::..ToString Method
SendEmailParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SendEmailParameters Class
SendEmailParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


SendEmailParameters Properties

[image] [image]

IceLib Technical Reference
SendEmailParameters Properties
SendEmailParameters Class See Also Send Feedback

The SendEmailParameters type exposes the following members.

Properties

 | Name | Description
Public property | Body | Gets the body.
Public property | Recipients | Gets the recipients.
Public property | Subject | Gets the subject.

See Also

SendEmailParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Body Property

[image]

IceLib Technical Reference
SendEmailParameters..::..Body Property
SendEmailParameters Class See Also Send Feedback
Gets the body.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Body { get; }
Visual Basic
Public ReadOnly Property Body As String
    Get

Field Value

The body.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailParameters Class
SendEmailParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Recipients Property

[image]

IceLib Technical Reference
SendEmailParameters..::..Recipients Property
SendEmailParameters Class See Also Send Feedback
Gets the recipients.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Recipients { get; }
Visual Basic
Public ReadOnly Property Recipients As ReadOnlyCollection(Of String)
    Get

Field Value

The recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailParameters Class
SendEmailParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Subject Property

[image]

IceLib Technical Reference
SendEmailParameters..::..Subject Property
SendEmailParameters Class See Also Send Feedback
Gets the subject.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Subject { get; }
Visual Basic
Public ReadOnly Property Subject As String
    Get

Field Value

The subject.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendEmailParameters Class
SendEmailParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerCompletedEventArgs Class

[image]

IceLib Technical Reference
TestMonikerCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of TestMonikerAsync(TestMonikerParameters, EventHandler<(Of <<'(TestMonikerCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TestMonikerCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class TestMonikerCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Configuration.Mailbox.Utility..::..TestMonikerCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

TestMonikerCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
TestMonikerCompletedEventArgs Members
TestMonikerCompletedEventArgs Class Methods Properties See Also Send Feedback

The TestMonikerCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

TestMonikerCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
TestMonikerCompletedEventArgs Methods
TestMonikerCompletedEventArgs Class See Also Send Feedback

The TestMonikerCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestMonikerCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
TestMonikerCompletedEventArgs Properties
TestMonikerCompletedEventArgs Class See Also Send Feedback

The TestMonikerCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

TestMonikerCompletedEventArgs Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Success Property

[image]

IceLib Technical Reference
TestMonikerCompletedEventArgs..::..Success Property
TestMonikerCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether this OpenMailboxCompletedEventArgs was successful.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Success { get; }
Visual Basic
Public ReadOnly Property Success As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if successful; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

TestMonikerCompletedEventArgs Class
TestMonikerCompletedEventArgs Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerParameters Class

[image]

IceLib Technical Reference
TestMonikerParameters Class
Members See Also Send Feedback
Provides details when testing monikers via TestMoniker(TestMonikerParameters) and TestMonikerAsync(TestMonikerParameters, EventHandler<(Of <<'(TestMonikerCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TestMonikerParameters
Visual Basic
Public Class TestMonikerParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Mailbox.Utility..::..TestMonikerParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

TestMonikerParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerParameters Members

[image] [image]

IceLib Technical Reference
TestMonikerParameters Members
TestMonikerParameters Class Constructors Methods Properties See Also Send Feedback

The TestMonikerParameters type exposes the following members.

Constructors

 | Name | Description
Public method | TestMonikerParameters | Initializes a new instance of the TestMonikerParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Moniker | Gets the moniker.

See Also

TestMonikerParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerParameters Constructor

[image]

IceLib Technical Reference
TestMonikerParameters Constructor
TestMonikerParameters Class See Also Send Feedback
Initializes a new instance of the TestMonikerParameters class.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TestMonikerParameters(
    string moniker
)
Visual Basic
Public Sub New ( _
    moniker As String _
)

Parameters

moniker
Type: System..::..String
The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

TestMonikerParameters Class
TestMonikerParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerParameters Methods

[image] [image]

IceLib Technical Reference
TestMonikerParameters Methods
TestMonikerParameters Class See Also Send Feedback

The TestMonikerParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

TestMonikerParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ToString Method

[image]

IceLib Technical Reference
TestMonikerParameters..::..ToString Method
TestMonikerParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TestMonikerParameters Class
TestMonikerParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


TestMonikerParameters Properties

[image] [image]

IceLib Technical Reference
TestMonikerParameters Properties
TestMonikerParameters Class See Also Send Feedback

The TestMonikerParameters type exposes the following members.

Properties

 | Name | Description
Public property | Moniker | Gets the moniker.

See Also

TestMonikerParameters Class
ININ.IceLib.Configuration.Mailbox.Utility Namespace


Moniker Property

[image]

IceLib Technical Reference
TestMonikerParameters..::..Moniker Property
TestMonikerParameters Class See Also Send Feedback
Gets the moniker.

Namespace: ININ.IceLib.Configuration.Mailbox.Utility
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Moniker { get; }
Visual Basic
Public ReadOnly Property Moniker As String
    Get

Field Value

The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

TestMonikerParameters Class
TestMonikerParameters Members
ININ.IceLib.Configuration.Mailbox.Utility Namespace


ININ.IceLib.Configuration.OCS Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.OCS Namespace
Send Feedback

The ININ.IceLib.Configuration.OCS namespace contains classes that provide support for office communication server configuration.

Classes

 | Class | Description
Public class | OfficeCommunicationServerActiveDirectoryConfiguration | Contains configuration and administration settings for an IC OfficeCommunicationServerActiveDirectory.
Public class | OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | OfficeCommunicationServerActiveDirectoryConfigurationList | Allows for querying and managing OfficeCommunicationServerActiveDirectory configuration objects.
Public class | OfficeCommunicationServerStatusMessageConfiguration | Contains configuration and administration settings for an IC OfficeCommunicationServerStatusMessage.
Public class | OfficeCommunicationServerStatusMessageConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | OfficeCommunicationServerStatusMessageConfigurationList | Allows for querying and managing OfficeCommunicationServerStatusMessage configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | OfficeCommunicationServerActiveDirectoryConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | OfficeCommunicationServerStatusMessageConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


OfficeCommunicationServerActiveDirectoryConfiguration Class

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC OfficeCommunicationServerActiveDirectory.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OfficeCommunicationServerActiveDirectoryConfiguration : ListConfigurationObject
Visual Basic
Public Class OfficeCommunicationServerActiveDirectoryConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerActiveDirectoryConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration Members

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration Members
OfficeCommunicationServerActiveDirectoryConfiguration Class Methods Properties See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration Methods

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration Methods
OfficeCommunicationServerActiveDirectoryConfiguration Class See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

OfficeCommunicationServerActiveDirectoryConfiguration Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration Properties

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration Properties
OfficeCommunicationServerActiveDirectoryConfiguration Class See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration Class
ININ.IceLib.Configuration.OCS Namespace


StandardProperties Property

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..StandardProperties Property
OfficeCommunicationServerActiveDirectoryConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<OfficeCommunicationServerActiveDirectoryConfiguration, OfficeCommunicationServerActiveDirectoryConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of OfficeCommunicationServerActiveDirectoryConfiguration, OfficeCommunicationServerActiveDirectoryConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration Class
OfficeCommunicationServerActiveDirectoryConfiguration Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration.Property Enumeration

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..Property Enumeration
OfficeCommunicationServerActiveDirectoryConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration.Rights Class

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class
OfficeCommunicationServerActiveDirectoryConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Members
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class Properties See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Properties
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class
ININ.IceLib.Configuration.OCS Namespace


Admin Property

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights..::..Admin Property
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OfficeCommunicationServerActiveDirectoryConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of OfficeCommunicationServerActiveDirectoryConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Members
ININ.IceLib.Configuration.OCS Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OcsActiveDirectories


View Property

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights..::..View Property
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OfficeCommunicationServerActiveDirectoryConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of OfficeCommunicationServerActiveDirectoryConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Class
OfficeCommunicationServerActiveDirectoryConfiguration..::..Rights Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfigurationList Class

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing OfficeCommunicationServerActiveDirectory configuration objects.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OfficeCommunicationServerActiveDirectoryConfigurationList : DynamicConfigurationList<OfficeCommunicationServerActiveDirectoryConfiguration, OfficeCommunicationServerActiveDirectoryConfiguration..::..Property>
Visual Basic
Public Class OfficeCommunicationServerActiveDirectoryConfigurationList _
    Inherits DynamicConfigurationList(Of OfficeCommunicationServerActiveDirectoryConfiguration, OfficeCommunicationServerActiveDirectoryConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' OfficeCommunicationServerActiveDirectoryConfiguration, OfficeCommunicationServerActiveDirectoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' OfficeCommunicationServerActiveDirectoryConfiguration, OfficeCommunicationServerActiveDirectoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerActiveDirectoryConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfigurationList Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfigurationList Members

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfigurationList Members
OfficeCommunicationServerActiveDirectoryConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | OfficeCommunicationServerActiveDirectoryConfigurationList | Initializes a new instance of the OfficeCommunicationServerActiveDirectoryConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OfficeCommunicationServerActiveDirectoryConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfigurationList Constructor

[image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfigurationList Constructor
OfficeCommunicationServerActiveDirectoryConfigurationList Class See Also Send Feedback
Initializes a new instance of the OfficeCommunicationServerActiveDirectoryConfigurationList class.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OfficeCommunicationServerActiveDirectoryConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerActiveDirectoryConfigurationList Class
OfficeCommunicationServerActiveDirectoryConfigurationList Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfigurationList Methods

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfigurationList Methods
OfficeCommunicationServerActiveDirectoryConfigurationList Class See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OfficeCommunicationServerActiveDirectoryConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfigurationList Properties

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfigurationList Properties
OfficeCommunicationServerActiveDirectoryConfigurationList Class See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OfficeCommunicationServerActiveDirectoryConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerActiveDirectoryConfigurationList Events

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerActiveDirectoryConfigurationList Events
OfficeCommunicationServerActiveDirectoryConfigurationList Class See Also Send Feedback

The OfficeCommunicationServerActiveDirectoryConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OfficeCommunicationServerActiveDirectoryConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration Class

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC OfficeCommunicationServerStatusMessage.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OfficeCommunicationServerStatusMessageConfiguration : ListConfigurationObject
Visual Basic
Public Class OfficeCommunicationServerStatusMessageConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerStatusMessageConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfiguration Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration Members

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration Members
OfficeCommunicationServerStatusMessageConfiguration Class Methods Properties See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

OfficeCommunicationServerStatusMessageConfiguration Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration Methods

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration Methods
OfficeCommunicationServerStatusMessageConfiguration Class See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

OfficeCommunicationServerStatusMessageConfiguration Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration Properties

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration Properties
OfficeCommunicationServerStatusMessageConfiguration Class See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

OfficeCommunicationServerStatusMessageConfiguration Class
ININ.IceLib.Configuration.OCS Namespace


StandardProperties Property

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..StandardProperties Property
OfficeCommunicationServerStatusMessageConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<OfficeCommunicationServerStatusMessageConfiguration, OfficeCommunicationServerStatusMessageConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of OfficeCommunicationServerStatusMessageConfiguration, OfficeCommunicationServerStatusMessageConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfiguration Class
OfficeCommunicationServerStatusMessageConfiguration Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration.Property Enumeration

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..Property Enumeration
OfficeCommunicationServerStatusMessageConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration.Rights Class

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class
OfficeCommunicationServerStatusMessageConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerStatusMessageConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfiguration..::..Rights Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Members
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class Properties See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Properties
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class
ININ.IceLib.Configuration.OCS Namespace


Admin Property

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..Rights..::..Admin Property
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OfficeCommunicationServerStatusMessageConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of OfficeCommunicationServerStatusMessageConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Members
ININ.IceLib.Configuration.OCS Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..OcsStatusMessages


View Property

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfiguration..::..Rights..::..View Property
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OfficeCommunicationServerStatusMessageConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of OfficeCommunicationServerStatusMessageConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfiguration..::..Rights Class
OfficeCommunicationServerStatusMessageConfiguration..::..Rights Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfigurationList Class

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing OfficeCommunicationServerStatusMessage configuration objects.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OfficeCommunicationServerStatusMessageConfigurationList : DynamicConfigurationList<OfficeCommunicationServerStatusMessageConfiguration, OfficeCommunicationServerStatusMessageConfiguration..::..Property>
Visual Basic
Public Class OfficeCommunicationServerStatusMessageConfigurationList _
    Inherits DynamicConfigurationList(Of OfficeCommunicationServerStatusMessageConfiguration, OfficeCommunicationServerStatusMessageConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' OfficeCommunicationServerStatusMessageConfiguration, OfficeCommunicationServerStatusMessageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' OfficeCommunicationServerStatusMessageConfiguration, OfficeCommunicationServerStatusMessageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.OCS..::..OfficeCommunicationServerStatusMessageConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfigurationList Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfigurationList Members

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfigurationList Members
OfficeCommunicationServerStatusMessageConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | OfficeCommunicationServerStatusMessageConfigurationList | Initializes a new instance of the OfficeCommunicationServerStatusMessageConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OfficeCommunicationServerStatusMessageConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfigurationList Constructor

[image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfigurationList Constructor
OfficeCommunicationServerStatusMessageConfigurationList Class See Also Send Feedback
Initializes a new instance of the OfficeCommunicationServerStatusMessageConfigurationList class.

Namespace: ININ.IceLib.Configuration.OCS
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OfficeCommunicationServerStatusMessageConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OfficeCommunicationServerStatusMessageConfigurationList Class
OfficeCommunicationServerStatusMessageConfigurationList Members
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfigurationList Methods

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfigurationList Methods
OfficeCommunicationServerStatusMessageConfigurationList Class See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OfficeCommunicationServerStatusMessageConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfigurationList Properties

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfigurationList Properties
OfficeCommunicationServerStatusMessageConfigurationList Class See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OfficeCommunicationServerStatusMessageConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


OfficeCommunicationServerStatusMessageConfigurationList Events

[image] [image]

IceLib Technical Reference
OfficeCommunicationServerStatusMessageConfigurationList Events
OfficeCommunicationServerStatusMessageConfigurationList Class See Also Send Feedback

The OfficeCommunicationServerStatusMessageConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OfficeCommunicationServerStatusMessageConfigurationList Class
ININ.IceLib.Configuration.OCS Namespace


ININ.IceLib.Configuration.Optimizer Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Optimizer Namespace
Send Feedback

The ININ.IceLib.Configuration.Optimizer namespace contains classes that provide support for optimizer configuration.

Classes

 | Class | Description
Public class | OptimizerSchedulingUnitConfiguration | Contains configuration and administration settings for an IC OptimizerSchedulingUnit.
Public class | OptimizerSchedulingUnitConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | OptimizerSchedulingUnitConfigurationList | Allows for querying and managing OptimizerSchedulingUnit configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | OptimizerSchedulingUnitConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


OptimizerSchedulingUnitConfiguration Class

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC OptimizerSchedulingUnit.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OptimizerSchedulingUnitConfiguration : ListConfigurationObject
Visual Basic
Public Class OptimizerSchedulingUnitConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.Optimizer..::..OptimizerSchedulingUnitConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfiguration Members
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration Members

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration Members
OptimizerSchedulingUnitConfiguration Class Methods Properties See Also Send Feedback

The OptimizerSchedulingUnitConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

OptimizerSchedulingUnitConfiguration Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration Methods

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration Methods
OptimizerSchedulingUnitConfiguration Class See Also Send Feedback

The OptimizerSchedulingUnitConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

OptimizerSchedulingUnitConfiguration Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration Properties

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration Properties
OptimizerSchedulingUnitConfiguration Class See Also Send Feedback

The OptimizerSchedulingUnitConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

OptimizerSchedulingUnitConfiguration Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration.Property Enumeration

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Property Enumeration
OptimizerSchedulingUnitConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration.Rights Class

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Rights Class
OptimizerSchedulingUnitConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Optimizer..::..OptimizerSchedulingUnitConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfiguration..::..Rights Members
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Rights Members
OptimizerSchedulingUnitConfiguration..::..Rights Class Properties See Also Send Feedback

The OptimizerSchedulingUnitConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.
ViewModifyOptimizerAll | Gets the view modify optimizer all rights filter.

See Also

OptimizerSchedulingUnitConfiguration..::..Rights Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Rights Properties
OptimizerSchedulingUnitConfiguration..::..Rights Class See Also Send Feedback

The OptimizerSchedulingUnitConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.
ViewModifyOptimizerAll | Gets the view modify optimizer all rights filter.

See Also

OptimizerSchedulingUnitConfiguration..::..Rights Class
ININ.IceLib.Configuration.Optimizer Namespace


Admin Property

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Rights..::..Admin Property
OptimizerSchedulingUnitConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OptimizerSchedulingUnitConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of OptimizerSchedulingUnitConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfiguration..::..Rights Class
OptimizerSchedulingUnitConfiguration..::..Rights Members
ININ.IceLib.Configuration.Optimizer Namespace


View Property

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Rights..::..View Property
OptimizerSchedulingUnitConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OptimizerSchedulingUnitConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of OptimizerSchedulingUnitConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfiguration..::..Rights Class
OptimizerSchedulingUnitConfiguration..::..Rights Members
ININ.IceLib.Configuration.Optimizer Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewOptimizerSchedulingUnits


ViewModifyOptimizerAll Property

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfiguration..::..Rights..::..ViewModifyOptimizerAll Property
OptimizerSchedulingUnitConfiguration..::..Rights Class See Also Send Feedback
Gets the view modify optimizer all rights filter.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<OptimizerSchedulingUnitConfiguration> ViewModifyOptimizerAll { get; private set; }
Visual Basic
Public Shared Property ViewModifyOptimizerAll As RightsQueryFilter(Of OptimizerSchedulingUnitConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfiguration..::..Rights Class
OptimizerSchedulingUnitConfiguration..::..Rights Members
ININ.IceLib.Configuration.Optimizer Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewModifyOptimizerAll


OptimizerSchedulingUnitConfigurationList Class

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing OptimizerSchedulingUnit configuration objects.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OptimizerSchedulingUnitConfigurationList : DynamicConfigurationList<OptimizerSchedulingUnitConfiguration, OptimizerSchedulingUnitConfiguration..::..Property>
Visual Basic
Public Class OptimizerSchedulingUnitConfigurationList _
    Inherits DynamicConfigurationList(Of OptimizerSchedulingUnitConfiguration, OptimizerSchedulingUnitConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' OptimizerSchedulingUnitConfiguration, OptimizerSchedulingUnitConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' OptimizerSchedulingUnitConfiguration, OptimizerSchedulingUnitConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Optimizer..::..OptimizerSchedulingUnitConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfigurationList Members
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfigurationList Members

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfigurationList Members
OptimizerSchedulingUnitConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The OptimizerSchedulingUnitConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | OptimizerSchedulingUnitConfigurationList | Initializes a new instance of the OptimizerSchedulingUnitConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OptimizerSchedulingUnitConfigurationList Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfigurationList Constructor

[image]

IceLib Technical Reference
OptimizerSchedulingUnitConfigurationList Constructor
OptimizerSchedulingUnitConfigurationList Class See Also Send Feedback
Initializes a new instance of the OptimizerSchedulingUnitConfigurationList class.

Namespace: ININ.IceLib.Configuration.Optimizer
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OptimizerSchedulingUnitConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

OptimizerSchedulingUnitConfigurationList Class
OptimizerSchedulingUnitConfigurationList Members
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfigurationList Methods

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfigurationList Methods
OptimizerSchedulingUnitConfigurationList Class See Also Send Feedback

The OptimizerSchedulingUnitConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptimizerSchedulingUnitConfigurationList Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfigurationList Properties

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfigurationList Properties
OptimizerSchedulingUnitConfigurationList Class See Also Send Feedback

The OptimizerSchedulingUnitConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OptimizerSchedulingUnitConfigurationList Class
ININ.IceLib.Configuration.Optimizer Namespace


OptimizerSchedulingUnitConfigurationList Events

[image] [image]

IceLib Technical Reference
OptimizerSchedulingUnitConfigurationList Events
OptimizerSchedulingUnitConfigurationList Class See Also Send Feedback

The OptimizerSchedulingUnitConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

OptimizerSchedulingUnitConfigurationList Class
ININ.IceLib.Configuration.Optimizer Namespace


ININ.IceLib.Configuration.ProcessAutomation Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.ProcessAutomation Namespace
Send Feedback

The ININ.IceLib.Configuration.ProcessAutomation namespace contains classes that provide support for process automation configuration.

Classes

 | Class | Description
Public class | ProcessConfiguration | Contains configuration and administration settings for an IPA process.
Public class | ProcessConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ProcessConfigurationList | Allows for querying and managing IPA process configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | ProcessConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


ProcessConfiguration Class

[image]

IceLib Technical Reference
ProcessConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IPA process.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessConfiguration : ListConfigurationObject
Visual Basic
Public Class ProcessConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.ProcessAutomation..::..ProcessConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfiguration Members
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration Members

[image] [image]

IceLib Technical Reference
ProcessConfiguration Members
ProcessConfiguration Class Methods Properties See Also Send Feedback

The ProcessConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

ProcessConfiguration Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration Methods

[image] [image]

IceLib Technical Reference
ProcessConfiguration Methods
ProcessConfiguration Class See Also Send Feedback

The ProcessConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ProcessConfiguration Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration Properties

[image] [image]

IceLib Technical Reference
ProcessConfiguration Properties
ProcessConfiguration Class See Also Send Feedback

The ProcessConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

ProcessConfiguration Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ProcessConfiguration..::..Property Enumeration
ProcessConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration.Rights Class

[image]

IceLib Technical Reference
ProcessConfiguration..::..Rights Class
ProcessConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.ProcessAutomation..::..ProcessConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfiguration..::..Rights Members
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ProcessConfiguration..::..Rights Members
ProcessConfiguration..::..Rights Class Properties See Also Send Feedback

The ProcessConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
LaunchableProcessList | Gets the launchable process list filter.
ManageProcessList | Gets the manage process list filter.
View | Gets the view rights filter.

See Also

ProcessConfiguration..::..Rights Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ProcessConfiguration..::..Rights Properties
ProcessConfiguration..::..Rights Class See Also Send Feedback

The ProcessConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
LaunchableProcessList | Gets the launchable process list filter.
ManageProcessList | Gets the manage process list filter.
View | Gets the view rights filter.

See Also

ProcessConfiguration..::..Rights Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


Admin Property

[image]

IceLib Technical Reference
ProcessConfiguration..::..Rights..::..Admin Property
ProcessConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ProcessConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ProcessConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfiguration..::..Rights Class
ProcessConfiguration..::..Rights Members
ININ.IceLib.Configuration.ProcessAutomation Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionProcessAutomation


LaunchableProcessList Property

[image]

IceLib Technical Reference
ProcessConfiguration..::..Rights..::..LaunchableProcessList Property
ProcessConfiguration..::..Rights Class See Also Send Feedback
Gets the launchable process list filter.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ProcessConfiguration> LaunchableProcessList { get; private set; }
Visual Basic
Public Shared Property LaunchableProcessList As RightsQueryFilter(Of ProcessConfiguration)
    Get
    Private Set

Field Value

The launchable process list filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfiguration..::..Rights Class
ProcessConfiguration..::..Rights Members
ININ.IceLib.Configuration.ProcessAutomation Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..LaunchableProcessList


ManageProcessList Property

[image]

IceLib Technical Reference
ProcessConfiguration..::..Rights..::..ManageProcessList Property
ProcessConfiguration..::..Rights Class See Also Send Feedback
Gets the manage process list filter.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ProcessConfiguration> ManageProcessList { get; private set; }
Visual Basic
Public Shared Property ManageProcessList As RightsQueryFilter(Of ProcessConfiguration)
    Get
    Private Set

Field Value

The manage process list filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfiguration..::..Rights Class
ProcessConfiguration..::..Rights Members
ININ.IceLib.Configuration.ProcessAutomation Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ManageProcessList


View Property

[image]

IceLib Technical Reference
ProcessConfiguration..::..Rights..::..View Property
ProcessConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ProcessConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ProcessConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfiguration..::..Rights Class
ProcessConfiguration..::..Rights Members
ININ.IceLib.Configuration.ProcessAutomation Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewProcessList


ProcessConfigurationList Class

[image]

IceLib Technical Reference
ProcessConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing IPA process configuration objects.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessConfigurationList : DynamicConfigurationList<ProcessConfiguration, ProcessConfiguration..::..Property>
Visual Basic
Public Class ProcessConfigurationList _
    Inherits DynamicConfigurationList(Of ProcessConfiguration, ProcessConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ProcessConfiguration, ProcessConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ProcessConfiguration, ProcessConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.ProcessAutomation..::..ProcessConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfigurationList Members
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfigurationList Members

[image] [image]

IceLib Technical Reference
ProcessConfigurationList Members
ProcessConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ProcessConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessConfigurationList | Initializes a new instance of the ProcessConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ProcessConfigurationList Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfigurationList Constructor

[image]

IceLib Technical Reference
ProcessConfigurationList Constructor
ProcessConfigurationList Class See Also Send Feedback
Initializes a new instance of the ProcessConfigurationList class.

Namespace: ININ.IceLib.Configuration.ProcessAutomation
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ProcessConfigurationList Class
ProcessConfigurationList Members
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfigurationList Methods

[image] [image]

IceLib Technical Reference
ProcessConfigurationList Methods
ProcessConfigurationList Class See Also Send Feedback

The ProcessConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessConfigurationList Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfigurationList Properties

[image] [image]

IceLib Technical Reference
ProcessConfigurationList Properties
ProcessConfigurationList Class See Also Send Feedback

The ProcessConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ProcessConfigurationList Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ProcessConfigurationList Events

[image] [image]

IceLib Technical Reference
ProcessConfigurationList Events
ProcessConfigurationList Class See Also Send Feedback

The ProcessConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ProcessConfigurationList Class
ININ.IceLib.Configuration.ProcessAutomation Namespace


ININ.IceLib.Configuration.Recorder Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Recorder Namespace
Send Feedback

The ININ.IceLib.Configuration.Recorder namespace contains classes that provide support for recorder configuration.

Classes

 | Class | Description
Public class | RecorderConfiguration | Contains configuration and administration settings for Interaction Recorder.
Public class | RecorderConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | RecorderConfigurationContainer | Allows for querying and managing the Recorder object.
Public class | RecorderQuestionnaireConfiguration | Contains configuration and administration settings for an IC RecorderQuestionnaire.
Public class | RecorderQuestionnaireConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | RecorderQuestionnaireConfigurationList | Allows for querying and managing RecorderQuestionnaire configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | RecorderConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | RecorderQuestionnaireConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


RecorderConfiguration Class

[image]

IceLib Technical Reference
RecorderConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Interaction Recorder.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecorderConfiguration : EditableContainerConfigurationObject<RecorderConfiguration..::..Property>
Visual Basic
Public Class RecorderConfiguration _
    Inherits EditableContainerConfigurationObject(Of RecorderConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ContainerConfigurationObject
ININ.IceLib.Configuration..::..EditableContainerConfigurationObject <(Of <(<' RecorderConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Recorder..::..RecorderConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfiguration Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration Members

[image] [image]

IceLib Technical Reference
RecorderConfiguration Members
RecorderConfiguration Class Methods Properties See Also Send Feedback

The RecorderConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | EnableSnippetRecordings | Provides access to the property for allowing the creation of snippet recordings (use Property.EnableSnippetRecordings).
Public property | ForceHandsetPlayback | Provides access to the property for forcing handset playback of recordings (use Property.ForceHandsetPlayback).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

RecorderConfiguration Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration Methods

[image] [image]

IceLib Technical Reference
RecorderConfiguration Methods
RecorderConfiguration Class See Also Send Feedback

The RecorderConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a container-based configuration object for edit. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

RecorderConfiguration Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration Properties

[image] [image]

IceLib Technical Reference
RecorderConfiguration Properties
RecorderConfiguration Class See Also Send Feedback

The RecorderConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableContainerConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | EnableSnippetRecordings | Provides access to the property for allowing the creation of snippet recordings (use Property.EnableSnippetRecordings).
Public property | ForceHandsetPlayback | Provides access to the property for forcing handset playback of recordings (use Property.ForceHandsetPlayback).
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

RecorderConfiguration Class
ININ.IceLib.Configuration.Recorder Namespace


EnableSnippetRecordings Property

[image]

IceLib Technical Reference
RecorderConfiguration..::..EnableSnippetRecordings Property
RecorderConfiguration Class See Also Send Feedback
Provides access to the property for allowing the creation of snippet recordings (use Property.EnableSnippetRecordings).

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecorderConfiguration..::..Property, bool> EnableSnippetRecordings { get; }
Visual Basic
Public ReadOnly Property EnableSnippetRecordings As GeneralConfigurationProperty(Of RecorderConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the Enable Snippet Recordings attribute.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecorderConfiguration Class
RecorderConfiguration Members
ININ.IceLib.Configuration.Recorder Namespace


ForceHandsetPlayback Property

[image]

IceLib Technical Reference
RecorderConfiguration..::..ForceHandsetPlayback Property
RecorderConfiguration Class See Also Send Feedback
Provides access to the property for forcing handset playback of recordings (use Property.ForceHandsetPlayback).

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<RecorderConfiguration..::..Property, bool> ForceHandsetPlayback { get; }
Visual Basic
Public ReadOnly Property ForceHandsetPlayback As GeneralConfigurationProperty(Of RecorderConfiguration..::..Property, Boolean)
    Get

Field Value

The property representing the Force Handset Playback attribute.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfiguration Class
RecorderConfiguration Members
ININ.IceLib.Configuration.Recorder Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
RecorderConfiguration..::..PropertiesChanged Property
RecorderConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RecorderConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of RecorderConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

RecorderConfiguration Class
RecorderConfiguration Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration.Property Enumeration

[image]

IceLib Technical Reference
RecorderConfiguration..::..Property Enumeration
RecorderConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
ForceHandsetPlayback | 0 | Represents the ForceHandsetPlayback property.
EnableSnippetRecordings | 1 | Represents the EnableSnippetRecordings property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration.Rights Class

[image]

IceLib Technical Reference
RecorderConfiguration..::..Rights Class
RecorderConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Recorder..::..RecorderConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
RecorderConfiguration..::..Rights Members
RecorderConfiguration..::..Rights Class Properties See Also Send Feedback

The RecorderConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

RecorderConfiguration..::..Rights Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
RecorderConfiguration..::..Rights Properties
RecorderConfiguration..::..Rights Class See Also Send Feedback

The RecorderConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

RecorderConfiguration..::..Rights Class
ININ.IceLib.Configuration.Recorder Namespace


Admin Property

[image]

IceLib Technical Reference
RecorderConfiguration..::..Rights..::..Admin Property
RecorderConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecorderConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of RecorderConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfiguration..::..Rights Class
RecorderConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..InteractionRecorderConfiguration


View Property

[image]

IceLib Technical Reference
RecorderConfiguration..::..Rights..::..View Property
RecorderConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecorderConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of RecorderConfiguration)
    Get
    Private Set

Field Value

The view rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfiguration..::..Rights Class
RecorderConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfigurationContainer Class

[image]

IceLib Technical Reference
RecorderConfigurationContainer Class
Members See Also Send Feedback
Allows for querying and managing the Recorder object.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecorderConfigurationContainer : ConfigurationContainer<RecorderConfiguration, RecorderConfiguration..::..Property>
Visual Basic
Public Class RecorderConfigurationContainer _
    Inherits ConfigurationContainer(Of RecorderConfiguration, RecorderConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationContainer <(Of <(<' RecorderConfiguration, RecorderConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Recorder..::..RecorderConfigurationContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfigurationContainer Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfigurationContainer Members

[image] [image]

IceLib Technical Reference
RecorderConfigurationContainer Members
RecorderConfigurationContainer Class Constructors Methods Properties Events See Also Send Feedback

The RecorderConfigurationContainer type exposes the following members.

Constructors

 | Name | Description
Public method | RecorderConfigurationContainer | Initializes a new instance of the RecorderConfigurationContainer class.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecorderConfigurationContainer Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfigurationContainer Constructor

[image]

IceLib Technical Reference
RecorderConfigurationContainer Constructor
RecorderConfigurationContainer Class See Also Send Feedback
Initializes a new instance of the RecorderConfigurationContainer class.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecorderConfigurationContainer(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderConfigurationContainer Class
RecorderConfigurationContainer Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfigurationContainer Methods

[image] [image]

IceLib Technical Reference
RecorderConfigurationContainer Methods
RecorderConfigurationContainer Class See Also Send Feedback

The RecorderConfigurationContainer type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedProperties | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedPropertiesAsync | Changes the watched properties, replacing the current ones with those passed in. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettings | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchedQuerySettingsAsync | Changes the watched query settings. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Obsolete. Changes the query settings async. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this container object's query functions, such as StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)). (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationItem | Gets the configuration item. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartCaching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(IEnumerable<(Of <<'(TPropertyEnum>)>>)) | Starts watching the specified properties of the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the configuration object. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(IEnumerable<(Of <<'(TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(ContainerQuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecorderConfigurationContainer Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfigurationContainer Properties

[image] [image]

IceLib Technical Reference
RecorderConfigurationContainer Properties
RecorderConfigurationContainer Class See Also Send Feedback

The RecorderConfigurationContainer type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecorderConfigurationContainer Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderConfigurationContainer Events

[image] [image]

IceLib Technical Reference
RecorderConfigurationContainer Events
RecorderConfigurationContainer Class See Also Send Feedback

The RecorderConfigurationContainer type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from ConfigurationContainer<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecorderConfigurationContainer Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration Class

[image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC RecorderQuestionnaire.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecorderQuestionnaireConfiguration : ListConfigurationObject
Visual Basic
Public Class RecorderQuestionnaireConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.Recorder..::..RecorderQuestionnaireConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfiguration Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration Members

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration Members
RecorderQuestionnaireConfiguration Class Methods Properties See Also Send Feedback

The RecorderQuestionnaireConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

RecorderQuestionnaireConfiguration Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration Methods

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration Methods
RecorderQuestionnaireConfiguration Class See Also Send Feedback

The RecorderQuestionnaireConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

RecorderQuestionnaireConfiguration Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration Properties

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration Properties
RecorderQuestionnaireConfiguration Class See Also Send Feedback

The RecorderQuestionnaireConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)

See Also

RecorderQuestionnaireConfiguration Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration.Property Enumeration

[image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Property Enumeration
RecorderQuestionnaireConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration.Rights Class

[image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Rights Class
RecorderQuestionnaireConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Recorder..::..RecorderQuestionnaireConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Rights Members
RecorderQuestionnaireConfiguration..::..Rights Class Properties See Also Send Feedback

The RecorderQuestionnaireConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.

See Also

RecorderQuestionnaireConfiguration..::..Rights Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Rights Properties
RecorderQuestionnaireConfiguration..::..Rights Class See Also Send Feedback

The RecorderQuestionnaireConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
Modify | Gets the modify rights filter.
View | Gets the view rights filter.

See Also

RecorderQuestionnaireConfiguration..::..Rights Class
ININ.IceLib.Configuration.Recorder Namespace


Admin Property

[image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Rights..::..Admin Property
RecorderQuestionnaireConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecorderQuestionnaireConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of RecorderQuestionnaireConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfiguration..::..Rights Class
RecorderQuestionnaireConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace


Modify Property

[image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Rights..::..Modify Property
RecorderQuestionnaireConfiguration..::..Rights Class See Also Send Feedback
Gets the modify rights filter.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecorderQuestionnaireConfiguration> Modify { get; private set; }
Visual Basic
Public Shared Property Modify As RightsQueryFilter(Of RecorderQuestionnaireConfiguration)
    Get
    Private Set

Field Value

The modify right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfiguration..::..Rights Class
RecorderQuestionnaireConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ModifyRecorderQuestionnaires


View Property

[image]

IceLib Technical Reference
RecorderQuestionnaireConfiguration..::..Rights..::..View Property
RecorderQuestionnaireConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<RecorderQuestionnaireConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of RecorderQuestionnaireConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfiguration..::..Rights Class
RecorderQuestionnaireConfiguration..::..Rights Members
ININ.IceLib.Configuration.Recorder Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewRecorderQuestionnaires


RecorderQuestionnaireConfigurationList Class

[image]

IceLib Technical Reference
RecorderQuestionnaireConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing RecorderQuestionnaire configuration objects.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecorderQuestionnaireConfigurationList : DynamicConfigurationList<RecorderQuestionnaireConfiguration, RecorderQuestionnaireConfiguration..::..Property>
Visual Basic
Public Class RecorderQuestionnaireConfigurationList _
    Inherits DynamicConfigurationList(Of RecorderQuestionnaireConfiguration, RecorderQuestionnaireConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' RecorderQuestionnaireConfiguration, RecorderQuestionnaireConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' RecorderQuestionnaireConfiguration, RecorderQuestionnaireConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Recorder..::..RecorderQuestionnaireConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfigurationList Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfigurationList Members

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfigurationList Members
RecorderQuestionnaireConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The RecorderQuestionnaireConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | RecorderQuestionnaireConfigurationList | Initializes a new instance of the RecorderQuestionnaireConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecorderQuestionnaireConfigurationList Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfigurationList Constructor

[image]

IceLib Technical Reference
RecorderQuestionnaireConfigurationList Constructor
RecorderQuestionnaireConfigurationList Class See Also Send Feedback
Initializes a new instance of the RecorderQuestionnaireConfigurationList class.

Namespace: ININ.IceLib.Configuration.Recorder
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecorderQuestionnaireConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RecorderQuestionnaireConfigurationList Class
RecorderQuestionnaireConfigurationList Members
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfigurationList Methods

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfigurationList Methods
RecorderQuestionnaireConfigurationList Class See Also Send Feedback

The RecorderQuestionnaireConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecorderQuestionnaireConfigurationList Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfigurationList Properties

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfigurationList Properties
RecorderQuestionnaireConfigurationList Class See Also Send Feedback

The RecorderQuestionnaireConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecorderQuestionnaireConfigurationList Class
ININ.IceLib.Configuration.Recorder Namespace


RecorderQuestionnaireConfigurationList Events

[image] [image]

IceLib Technical Reference
RecorderQuestionnaireConfigurationList Events
RecorderQuestionnaireConfigurationList Class See Also Send Feedback

The RecorderQuestionnaireConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

RecorderQuestionnaireConfigurationList Class
ININ.IceLib.Configuration.Recorder Namespace


ININ.IceLib.Configuration.Reporting Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Reporting Namespace
Send Feedback

The ININ.IceLib.Configuration.Reporting namespace contains classes that provide support for report configuration.

Classes

 | Class | Description
Public class | HistoricalReportConfiguration | Contains configuration and administration settings for a Historical Report.
Public class | HistoricalReportConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | HistoricalReportConfigurationList | Allows for querying and managing Historical Report configuration objects.
Public class | LegacyHistoricalReportConfiguration | Contains configuration and administration settings for an IC Report.
Public class | LegacyHistoricalReportConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | LegacyHistoricalReportConfigurationList | Allows for querying and managing Legacy Historical Report configuration objects.
Public class | ReportCategoryConfiguration | Contains configuration and administration settings for Reporting's Categories.
Public class | ReportCategoryConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportCategoryConfigurationList | Allows for querying and managing reporting category configuration objects.
Public class | ReportCustomDataConfiguration | Contains configuration and administration settings for Reporting's Custom Data.
Public class | ReportCustomDataConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportCustomDataConfigurationList | Allows for querying and managing reporting custom data configuration objects.
Public class | ReportFlexibleColumnConfiguration | Contains configuration and administration settings for Reporting's Flexible Columns.
Public class | ReportFlexibleColumnConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportFlexibleColumnConfigurationList | Allows for querying and managing reporting flexible column configuration objects.
Public class | ReportMasterConfiguration | Contains configuration and administration settings for Reporting's Master Report.
Public class | ReportMasterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportMasterConfigurationList | Allows for querying and managing reporting master report configuration objects.
Public class | ReportParameterConfiguration | Contains configuration and administration settings for Reporting's Parameters.
Public class | ReportParameterConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportParameterConfigurationList | Allows for querying and managing reporting parameter configuration objects.
Public class | ReportSectionConfiguration | Contains configuration and administration settings for Reporting's Sections.
Public class | ReportSectionConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportSectionConfigurationList | Allows for querying and managing reporting section configuration objects.
Public class | ReportSystemSettingConfiguration | Contains configuration and administration settings for Reporting's System Settings.
Public class | ReportSystemSettingConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportSystemSettingConfigurationList | Allows for querying and managing reporting system settings configuration objects.
Public class | ReportTableConfiguration | Contains configuration and administration settings for Reporting's Table Data.
Public class | ReportTableConfiguration..::..Rights | Provides filters that can be used to filter based on access control lists.
Public class | ReportTableConfigurationList | Allows for querying and managing reporting table configuration objects.

Enumerations

 | Enumeration | Description
Public enumeration | HistoricalReportConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | LegacyHistoricalReportConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportCategoryConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportCustomDataConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportFlexibleColumnConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportMasterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportParameterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportSectionConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportSystemSettingConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.
Public enumeration | ReportTableConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


HistoricalReportConfiguration Class

[image]

IceLib Technical Reference
HistoricalReportConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Historical Report.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HistoricalReportConfiguration : EditableListConfigurationObject<HistoricalReportConfiguration..::..Property>
Visual Basic
Public Class HistoricalReportConfiguration _
    Inherits EditableListConfigurationObject(Of HistoricalReportConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' HistoricalReportConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..HistoricalReportConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoricalReportConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration Members

[image] [image]

IceLib Technical Reference
HistoricalReportConfiguration Members
HistoricalReportConfiguration Class Methods Properties See Also Send Feedback

The HistoricalReportConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

HistoricalReportConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration Methods

[image] [image]

IceLib Technical Reference
HistoricalReportConfiguration Methods
HistoricalReportConfiguration Class See Also Send Feedback

The HistoricalReportConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

HistoricalReportConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration Properties

[image] [image]

IceLib Technical Reference
HistoricalReportConfiguration Properties
HistoricalReportConfiguration Class See Also Send Feedback

The HistoricalReportConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.

See Also

HistoricalReportConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
HistoricalReportConfiguration..::..PropertiesChanged Property
HistoricalReportConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<HistoricalReportConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of HistoricalReportConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

HistoricalReportConfiguration Class
HistoricalReportConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration.Property Enumeration

[image]

IceLib Technical Reference
HistoricalReportConfiguration..::..Property Enumeration
HistoricalReportConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration.Rights Class

[image]

IceLib Technical Reference
HistoricalReportConfiguration..::..Rights Class
HistoricalReportConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..HistoricalReportConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoricalReportConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
HistoricalReportConfiguration..::..Rights Members
HistoricalReportConfiguration..::..Rights Class Properties See Also Send Feedback

The HistoricalReportConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
ViewHistoricalReports | Gets the view historical reports filter.

See Also

HistoricalReportConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
HistoricalReportConfiguration..::..Rights Properties
HistoricalReportConfiguration..::..Rights Class See Also Send Feedback

The HistoricalReportConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
ViewHistoricalReports | Gets the view historical reports filter.

See Also

HistoricalReportConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
HistoricalReportConfiguration..::..Rights..::..Admin Property
HistoricalReportConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<HistoricalReportConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of HistoricalReportConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoricalReportConfiguration..::..Rights Class
HistoricalReportConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ViewHistoricalReports Property

[image]

IceLib Technical Reference
HistoricalReportConfiguration..::..Rights..::..ViewHistoricalReports Property
HistoricalReportConfiguration..::..Rights Class See Also Send Feedback
Gets the view historical reports filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<HistoricalReportConfiguration> ViewHistoricalReports { get; private set; }
Visual Basic
Public Shared Property ViewHistoricalReports As RightsQueryFilter(Of HistoricalReportConfiguration)
    Get
    Private Set

Field Value

The view historical reports filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoricalReportConfiguration..::..Rights Class
HistoricalReportConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewHistoricalReports


HistoricalReportConfigurationList Class

[image]

IceLib Technical Reference
HistoricalReportConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Historical Report configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HistoricalReportConfigurationList : EditableConfigurationList<HistoricalReportConfiguration, HistoricalReportConfiguration..::..Property>
Visual Basic
Public Class HistoricalReportConfigurationList _
    Inherits EditableConfigurationList(Of HistoricalReportConfiguration, HistoricalReportConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' HistoricalReportConfiguration, HistoricalReportConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' HistoricalReportConfiguration, HistoricalReportConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' HistoricalReportConfiguration, HistoricalReportConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..HistoricalReportConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoricalReportConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfigurationList Members

[image] [image]

IceLib Technical Reference
HistoricalReportConfigurationList Members
HistoricalReportConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The HistoricalReportConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | HistoricalReportConfigurationList | Initializes a new instance of the HistoricalReportConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfigurationList Constructor

[image]

IceLib Technical Reference
HistoricalReportConfigurationList Constructor
HistoricalReportConfigurationList Class See Also Send Feedback
Initializes a new instance of the HistoricalReportConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HistoricalReportConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoricalReportConfigurationList Class
HistoricalReportConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfigurationList Methods

[image] [image]

IceLib Technical Reference
HistoricalReportConfigurationList Methods
HistoricalReportConfigurationList Class See Also Send Feedback

The HistoricalReportConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfigurationList Properties

[image] [image]

IceLib Technical Reference
HistoricalReportConfigurationList Properties
HistoricalReportConfigurationList Class See Also Send Feedback

The HistoricalReportConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


HistoricalReportConfigurationList Events

[image] [image]

IceLib Technical Reference
HistoricalReportConfigurationList Events
HistoricalReportConfigurationList Class See Also Send Feedback

The HistoricalReportConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

HistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration Class

[image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an IC Report.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LegacyHistoricalReportConfiguration : ListConfigurationObject
Visual Basic
Public Class LegacyHistoricalReportConfiguration _
    Inherits ListConfigurationObject

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration.Reporting..::..LegacyHistoricalReportConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration Members

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration Members
LegacyHistoricalReportConfiguration Class Methods Properties See Also Send Feedback

The LegacyHistoricalReportConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LegacyHistoricalReportConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration Methods

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration Methods
LegacyHistoricalReportConfiguration Class See Also Send Feedback

The LegacyHistoricalReportConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

LegacyHistoricalReportConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration Properties

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration Properties
LegacyHistoricalReportConfiguration Class See Also Send Feedback

The LegacyHistoricalReportConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | StandardProperties | Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

See Also

LegacyHistoricalReportConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


StandardProperties Property

[image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..StandardProperties Property
LegacyHistoricalReportConfiguration Class See Also Send Feedback
Provides access to the various standard properties, such as DateLastModified, DateCreated and Notes.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StandardProperties<LegacyHistoricalReportConfiguration, LegacyHistoricalReportConfiguration..::..Property> StandardProperties { get; }
Visual Basic
Public ReadOnly Property StandardProperties As StandardProperties(Of LegacyHistoricalReportConfiguration, LegacyHistoricalReportConfiguration..::..Property)
    Get

Field Value

The standard properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfiguration Class
LegacyHistoricalReportConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration.Property Enumeration

[image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..Property Enumeration
LegacyHistoricalReportConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
DisplayName | 0 | Represents the DisplayName part of the ConfigurationId property.
Id | 1 | Represents the Id part of the ConfigurationId property.
StandardProperties_DateCreated | 3000 | Represents the DateCreated property.
StandardProperties_DateLastModified | 3001 | Represents the DateLastModified property.
StandardProperties_Notes | 3002 | Represents the Notes property.
StandardProperties_CustomAttributes | 3003 | Represents the CustomAttributes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration.Rights Class

[image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..Rights Class
LegacyHistoricalReportConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..LegacyHistoricalReportConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..Rights Members
LegacyHistoricalReportConfiguration..::..Rights Class Properties See Also Send Feedback

The LegacyHistoricalReportConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LegacyHistoricalReportConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..Rights Properties
LegacyHistoricalReportConfiguration..::..Rights Class See Also Send Feedback

The LegacyHistoricalReportConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

LegacyHistoricalReportConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..Rights..::..Admin Property
LegacyHistoricalReportConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LegacyHistoricalReportConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of LegacyHistoricalReportConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfiguration..::..Rights Class
LegacyHistoricalReportConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace
UserAdministrativeRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..Reports


View Property

[image]

IceLib Technical Reference
LegacyHistoricalReportConfiguration..::..Rights..::..View Property
LegacyHistoricalReportConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<LegacyHistoricalReportConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of LegacyHistoricalReportConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfiguration..::..Rights Class
LegacyHistoricalReportConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace
UserAccessRightsProperties<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>..::..ViewReport


LegacyHistoricalReportConfigurationList Class

[image]

IceLib Technical Reference
LegacyHistoricalReportConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Legacy Historical Report configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LegacyHistoricalReportConfigurationList : DynamicConfigurationList<LegacyHistoricalReportConfiguration, LegacyHistoricalReportConfiguration..::..Property>
Visual Basic
Public Class LegacyHistoricalReportConfigurationList _
    Inherits DynamicConfigurationList(Of LegacyHistoricalReportConfiguration, LegacyHistoricalReportConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' LegacyHistoricalReportConfiguration, LegacyHistoricalReportConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' LegacyHistoricalReportConfiguration, LegacyHistoricalReportConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..LegacyHistoricalReportConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfigurationList Members

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfigurationList Members
LegacyHistoricalReportConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The LegacyHistoricalReportConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | LegacyHistoricalReportConfigurationList | Initializes a new instance of the LegacyHistoricalReportConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LegacyHistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfigurationList Constructor

[image]

IceLib Technical Reference
LegacyHistoricalReportConfigurationList Constructor
LegacyHistoricalReportConfigurationList Class See Also Send Feedback
Initializes a new instance of the LegacyHistoricalReportConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LegacyHistoricalReportConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LegacyHistoricalReportConfigurationList Class
LegacyHistoricalReportConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfigurationList Methods

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfigurationList Methods
LegacyHistoricalReportConfigurationList Class See Also Send Feedback

The LegacyHistoricalReportConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegacyHistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfigurationList Properties

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfigurationList Properties
LegacyHistoricalReportConfigurationList Class See Also Send Feedback

The LegacyHistoricalReportConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LegacyHistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


LegacyHistoricalReportConfigurationList Events

[image] [image]

IceLib Technical Reference
LegacyHistoricalReportConfigurationList Events
LegacyHistoricalReportConfigurationList Class See Also Send Feedback

The LegacyHistoricalReportConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

LegacyHistoricalReportConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration Class

[image]

IceLib Technical Reference
ReportCategoryConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Categories.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportCategoryConfiguration : EditableListConfigurationObject<ReportCategoryConfiguration..::..Property>
Visual Basic
Public Class ReportCategoryConfiguration _
    Inherits EditableListConfigurationObject(Of ReportCategoryConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportCategoryConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration Members

[image] [image]

IceLib Technical Reference
ReportCategoryConfiguration Members
ReportCategoryConfiguration Class Methods Properties See Also Send Feedback

The ReportCategoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CopyGuid | Gets the copy GUID.
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | FriendlyKey | Gets the report friendly key.
Public property | Id | Gets the report category ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | License | Gets the license.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | Sequence | Gets the sequence.
Public property | Version | Gets the version.

See Also

ReportCategoryConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportCategoryConfiguration Methods
ReportCategoryConfiguration Class See Also Send Feedback

The ReportCategoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportCategoryConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportCategoryConfiguration Properties
ReportCategoryConfiguration Class See Also Send Feedback

The ReportCategoryConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CopyGuid | Gets the copy GUID.
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | FriendlyKey | Gets the report friendly key.
Public property | Id | Gets the report category ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | License | Gets the license.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | Sequence | Gets the sequence.
Public property | Version | Gets the version.

See Also

ReportCategoryConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


CopyGuid Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..CopyGuid Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the copy GUID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> CopyGuid { get; }
Visual Basic
Public ReadOnly Property CopyGuid As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The copy GUID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Description Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Description Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DescriptionResource Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..DescriptionResource Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the description resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> DescriptionResource { get; }
Visual Basic
Public ReadOnly Property DescriptionResource As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The description resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


FriendlyKey Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..FriendlyKey Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the report friendly key.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> FriendlyKey { get; }
Visual Basic
Public ReadOnly Property FriendlyKey As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The report friendly key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Id Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the report category ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The report category ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsVisible Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..IsVisible Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the visible.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, bool> IsVisible { get; }
Visual Basic
Public ReadOnly Property IsVisible As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, Boolean)
    Get

Field Value

The visible.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..LastModifiedDateTimeUtc Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..LastModifiedUser Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


License Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..License Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the license.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> License { get; }
Visual Basic
Public ReadOnly Property License As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Name Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Name Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> Name { get; }
Visual Basic
Public ReadOnly Property Name As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


NameResource Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..NameResource Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the name resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, string> NameResource { get; }
Visual Basic
Public ReadOnly Property NameResource As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, String)
    Get

Field Value

The name resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..PropertiesChanged Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportCategoryConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportCategoryConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..ReadOnly Property
ReportCategoryConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Sequence Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Sequence Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the sequence.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, int> Sequence { get; }
Visual Basic
Public ReadOnly Property Sequence As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The sequence.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Version Property
ReportCategoryConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCategoryConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportCategoryConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration Class
ReportCategoryConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Property Enumeration
ReportCategoryConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
Name | 1 | Represents the Name property.
Description | 2 | Represents the Description property.
License | 3 | Represents the License property.
FriendlyKey | 4 | Represents the FriendlyKey property.
NameResource | 5 | Represents the NameResource property.
DescriptionResource | 6 | Represents the DescriptionResource property.
IsVisible | 7 | Represents the IsVisible property.
CopyGuid | 8 | Represents the CopyGuid property.
Sequence | 9 | Represents the Sequence property.
LastModifiedUser | 10 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 11 | Represents the LastModifiedDateTimeUtc property.
Version | 12 | Represents the Version property.
ReadOnly | 13 | Represents the ReadOnly property.
DisplayName | 14 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Rights Class
ReportCategoryConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportCategoryConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Rights Members
ReportCategoryConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportCategoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportCategoryConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Rights Properties
ReportCategoryConfiguration..::..Rights Class See Also Send Feedback

The ReportCategoryConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportCategoryConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Rights..::..Admin Property
ReportCategoryConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportCategoryConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportCategoryConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration..::..Rights Class
ReportCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportCategoryConfiguration..::..Rights..::..View Property
ReportCategoryConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportCategoryConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportCategoryConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfiguration..::..Rights Class
ReportCategoryConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfigurationList Class

[image]

IceLib Technical Reference
ReportCategoryConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting category configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportCategoryConfigurationList : EditableConfigurationList<ReportCategoryConfiguration, ReportCategoryConfiguration..::..Property>
Visual Basic
Public Class ReportCategoryConfigurationList _
    Inherits EditableConfigurationList(Of ReportCategoryConfiguration, ReportCategoryConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportCategoryConfiguration, ReportCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportCategoryConfiguration, ReportCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportCategoryConfiguration, ReportCategoryConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportCategoryConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportCategoryConfigurationList Members
ReportCategoryConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportCategoryConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportCategoryConfigurationList | Initializes a new instance of the ReportCategoryConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportCategoryConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfigurationList Constructor

[image]

IceLib Technical Reference
ReportCategoryConfigurationList Constructor
ReportCategoryConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportCategoryConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportCategoryConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCategoryConfigurationList Class
ReportCategoryConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportCategoryConfigurationList Methods
ReportCategoryConfigurationList Class See Also Send Feedback

The ReportCategoryConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportCategoryConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportCategoryConfigurationList Properties
ReportCategoryConfigurationList Class See Also Send Feedback

The ReportCategoryConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportCategoryConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCategoryConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportCategoryConfigurationList Events
ReportCategoryConfigurationList Class See Also Send Feedback

The ReportCategoryConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportCategoryConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration Class

[image]

IceLib Technical Reference
ReportCustomDataConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Custom Data.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportCustomDataConfiguration : EditableListConfigurationObject<ReportCustomDataConfiguration..::..Property>
Visual Basic
Public Class ReportCustomDataConfiguration _
    Inherits EditableListConfigurationObject(Of ReportCustomDataConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportCustomDataConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportCustomDataConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration Members

[image] [image]

IceLib Technical Reference
ReportCustomDataConfiguration Members
ReportCustomDataConfiguration Class Methods Properties See Also Send Feedback

The ReportCustomDataConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Data | Gets the custom data.
Public property | Description | Gets the description.
Public property | Id | Gets the report custom data ID.
Public property | IsEncrypted | Gets a value indicating whether the data is encrypted.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | Name | Gets the name.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Version | Gets the version.

See Also

ReportCustomDataConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportCustomDataConfiguration Methods
ReportCustomDataConfiguration Class See Also Send Feedback

The ReportCustomDataConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportCustomDataConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportCustomDataConfiguration Properties
ReportCustomDataConfiguration Class See Also Send Feedback

The ReportCustomDataConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Data | Gets the custom data.
Public property | Description | Gets the description.
Public property | Id | Gets the report custom data ID.
Public property | IsEncrypted | Gets a value indicating whether the data is encrypted.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | Name | Gets the name.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Version | Gets the version.

See Also

ReportCustomDataConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


Data Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Data Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the custom data.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, string> Data { get; }
Visual Basic
Public ReadOnly Property Data As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, String)
    Get

Field Value

The custom data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Description Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Description Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, String)
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Id Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the report custom data ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, String)
    Get

Field Value

The report custom data ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsEncrypted Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..IsEncrypted Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets a value indicating whether the data is encrypted.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, bool> IsEncrypted { get; }
Visual Basic
Public ReadOnly Property IsEncrypted As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, Boolean)
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if encrypted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..LastModifiedDateTimeUtc Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..LastModifiedUser Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Name Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Name Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, string> Name { get; }
Visual Basic
Public ReadOnly Property Name As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..PropertiesChanged Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportCustomDataConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportCustomDataConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..ReadOnly Property
ReportCustomDataConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportId Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..ReportId Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the report ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, string> ReportId { get; }
Visual Basic
Public ReadOnly Property ReportId As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, String)
    Get

Field Value

The report ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Version Property
ReportCustomDataConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportCustomDataConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportCustomDataConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration Class
ReportCustomDataConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Property Enumeration
ReportCustomDataConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
ReportId | 1 | Represents the ReportId property.
Name | 2 | Represents the Name property.
Description | 3 | Represents the Description property.
IsEncrypted | 4 | Represents the IsEncrypted property.
Data | 5 | Represents the Data property.
LastModifiedUser | 6 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 7 | Represents the LastModifiedDateTimeUtc property.
Version | 8 | Represents the Version property.
ReadOnly | 9 | Represents the ReadOnly property.
DisplayName | 10 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Rights Class
ReportCustomDataConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportCustomDataConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Rights Members
ReportCustomDataConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportCustomDataConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportCustomDataConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Rights Properties
ReportCustomDataConfiguration..::..Rights Class See Also Send Feedback

The ReportCustomDataConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportCustomDataConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Rights..::..Admin Property
ReportCustomDataConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportCustomDataConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportCustomDataConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration..::..Rights Class
ReportCustomDataConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportCustomDataConfiguration..::..Rights..::..View Property
ReportCustomDataConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportCustomDataConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportCustomDataConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfiguration..::..Rights Class
ReportCustomDataConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfigurationList Class

[image]

IceLib Technical Reference
ReportCustomDataConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting custom data configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportCustomDataConfigurationList : EditableConfigurationList<ReportCustomDataConfiguration, ReportCustomDataConfiguration..::..Property>
Visual Basic
Public Class ReportCustomDataConfigurationList _
    Inherits EditableConfigurationList(Of ReportCustomDataConfiguration, ReportCustomDataConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportCustomDataConfiguration, ReportCustomDataConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportCustomDataConfiguration, ReportCustomDataConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportCustomDataConfiguration, ReportCustomDataConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportCustomDataConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportCustomDataConfigurationList Members
ReportCustomDataConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportCustomDataConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportCustomDataConfigurationList | Initializes a new instance of the ReportCustomDataConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportCustomDataConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfigurationList Constructor

[image]

IceLib Technical Reference
ReportCustomDataConfigurationList Constructor
ReportCustomDataConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportCustomDataConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportCustomDataConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportCustomDataConfigurationList Class
ReportCustomDataConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportCustomDataConfigurationList Methods
ReportCustomDataConfigurationList Class See Also Send Feedback

The ReportCustomDataConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportCustomDataConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportCustomDataConfigurationList Properties
ReportCustomDataConfigurationList Class See Also Send Feedback

The ReportCustomDataConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportCustomDataConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportCustomDataConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportCustomDataConfigurationList Events
ReportCustomDataConfigurationList Class See Also Send Feedback

The ReportCustomDataConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportCustomDataConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration Class

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Flexible Columns.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportFlexibleColumnConfiguration : EditableListConfigurationObject<ReportFlexibleColumnConfiguration..::..Property>
Visual Basic
Public Class ReportFlexibleColumnConfiguration _
    Inherits EditableListConfigurationObject(Of ReportFlexibleColumnConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportFlexibleColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportFlexibleColumnConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration Members

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration Members
ReportFlexibleColumnConfiguration Class Methods Properties See Also Send Feedback

The ReportFlexibleColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ColumnName | Gets the name of the column.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | Id | Gets the report flexible column ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Version | Gets the version.

See Also

ReportFlexibleColumnConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration Methods
ReportFlexibleColumnConfiguration Class See Also Send Feedback

The ReportFlexibleColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportFlexibleColumnConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration Properties
ReportFlexibleColumnConfiguration Class See Also Send Feedback

The ReportFlexibleColumnConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ColumnName | Gets the name of the column.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | Id | Gets the report flexible column ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Version | Gets the version.

See Also

ReportFlexibleColumnConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ColumnName Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..ColumnName Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the name of the column.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> ColumnName { get; }
Visual Basic
Public ReadOnly Property ColumnName As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The name of the column.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Description Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Description Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DescriptionResource Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..DescriptionResource Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the description resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> DescriptionResource { get; }
Visual Basic
Public ReadOnly Property DescriptionResource As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The description resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Id Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the report flexible column ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The report flexible column ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..LastModifiedDateTimeUtc Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..LastModifiedUser Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Name Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Name Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> Name { get; }
Visual Basic
Public ReadOnly Property Name As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


NameResource Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..NameResource Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the name resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> NameResource { get; }
Visual Basic
Public ReadOnly Property NameResource As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The name resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..PropertiesChanged Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportFlexibleColumnConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportFlexibleColumnConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..ReadOnly Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportId Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..ReportId Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the report ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, string> ReportId { get; }
Visual Basic
Public ReadOnly Property ReportId As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, String)
    Get

Field Value

The report ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Version Property
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportFlexibleColumnConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportFlexibleColumnConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration Class
ReportFlexibleColumnConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Property Enumeration
ReportFlexibleColumnConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
ReportId | 1 | Represents the ReportId property.
Name | 2 | Represents the Name property.
NameResource | 3 | Represents the NameResource property.
Description | 4 | Represents the Description property.
DescriptionResource | 5 | Represents the DescriptionResource property.
ColumnName | 6 | Represents the ColumnName property.
LastModifiedUser | 7 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 8 | Represents the LastModifiedDateTimeUtc property.
Version | 9 | Represents the Version property.
ReadOnly | 10 | Represents the ReadOnly property.
DisplayName | 11 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Rights Class
ReportFlexibleColumnConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportFlexibleColumnConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Rights Members
ReportFlexibleColumnConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportFlexibleColumnConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportFlexibleColumnConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Rights Properties
ReportFlexibleColumnConfiguration..::..Rights Class See Also Send Feedback

The ReportFlexibleColumnConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportFlexibleColumnConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Rights..::..Admin Property
ReportFlexibleColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportFlexibleColumnConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportFlexibleColumnConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration..::..Rights Class
ReportFlexibleColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportFlexibleColumnConfiguration..::..Rights..::..View Property
ReportFlexibleColumnConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportFlexibleColumnConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportFlexibleColumnConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfiguration..::..Rights Class
ReportFlexibleColumnConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfigurationList Class

[image]

IceLib Technical Reference
ReportFlexibleColumnConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting flexible column configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportFlexibleColumnConfigurationList : EditableConfigurationList<ReportFlexibleColumnConfiguration, ReportFlexibleColumnConfiguration..::..Property>
Visual Basic
Public Class ReportFlexibleColumnConfigurationList _
    Inherits EditableConfigurationList(Of ReportFlexibleColumnConfiguration, ReportFlexibleColumnConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportFlexibleColumnConfiguration, ReportFlexibleColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportFlexibleColumnConfiguration, ReportFlexibleColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportFlexibleColumnConfiguration, ReportFlexibleColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportFlexibleColumnConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfigurationList Members
ReportFlexibleColumnConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportFlexibleColumnConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportFlexibleColumnConfigurationList | Initializes a new instance of the ReportFlexibleColumnConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportFlexibleColumnConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfigurationList Constructor

[image]

IceLib Technical Reference
ReportFlexibleColumnConfigurationList Constructor
ReportFlexibleColumnConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportFlexibleColumnConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportFlexibleColumnConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportFlexibleColumnConfigurationList Class
ReportFlexibleColumnConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfigurationList Methods
ReportFlexibleColumnConfigurationList Class See Also Send Feedback

The ReportFlexibleColumnConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportFlexibleColumnConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfigurationList Properties
ReportFlexibleColumnConfigurationList Class See Also Send Feedback

The ReportFlexibleColumnConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportFlexibleColumnConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportFlexibleColumnConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportFlexibleColumnConfigurationList Events
ReportFlexibleColumnConfigurationList Class See Also Send Feedback

The ReportFlexibleColumnConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportFlexibleColumnConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration Class

[image]

IceLib Technical Reference
ReportMasterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Master Report.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportMasterConfiguration : EditableListConfigurationObject<ReportMasterConfiguration..::..Property>
Visual Basic
Public Class ReportMasterConfiguration _
    Inherits EditableListConfigurationObject(Of ReportMasterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportMasterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportMasterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration Members

[image] [image]

IceLib Technical Reference
ReportMasterConfiguration Members
ReportMasterConfiguration Class Methods Properties See Also Send Feedback

The ReportMasterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AllowCount | Gets the allow count.
Public property | AllowParameterEdit | Gets the allow parameter edit.
Public property | AssemblyName | Gets the name of the assembly.
Public property | CategoryId | Gets the category ID.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClassName | Gets the name of the class.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CopyGuid | Gets the copy GUID.
Public property | CopyReportGuid | Gets the copy report GUID.
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | DSKey | Gets the DS Key.
Public property | FileName | Gets the file name of the report.
Public property | FriendlyKey | Gets the friendly key.
Public property | ICDataSource | Gets the ic data source.
Public property | Id | Gets the report ID.
Public property | IsLocked | Gets the locked.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsReleased | Gets the released status.
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | LastRunDateTimeUtc | Gets the last run date time UTC.
Public property | LastRunUserId | Gets the last run user id.
Public property | License | Gets the license.
Public property | LinkedReportFriendlyKey | Gets the linked report friendly key.
Public property | LogoFile | Gets the logo file.
Public property | MaxRows | Gets the max rows.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | Notes | Gets the report notes.
Public property | Orientation | Gets the orientation.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | ParameterPageHelpId | Gets the parameter page help id.
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportPageHelpId | Gets the report page help id.
Public property | ReportType | Gets the type of the report.
Public property | ReportXml | Gets the report XML.
Public property | RequireAcl | Gets the require acl.
Public property | RunCount | Gets the run count.
Public property | Sequence | Gets the sequence.
Public property | StoredProcedure | Gets the stored procedure.
Public property | StoredProcedureCount | Gets the stored procedure count.
Public property | StoredProcedureSample | Gets the stored procedure sample.
Public property | SubTitle | Gets the sub title.
Public property | SubTitleResource | Gets the sub title resource.
Public property | TimeoutPeriod | Gets the last modified date time UTC.
Public property | Version | Gets the version.

See Also

ReportMasterConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportMasterConfiguration Methods
ReportMasterConfiguration Class See Also Send Feedback

The ReportMasterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportMasterConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportMasterConfiguration Properties
ReportMasterConfiguration Class See Also Send Feedback

The ReportMasterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AllowCount | Gets the allow count.
Public property | AllowParameterEdit | Gets the allow parameter edit.
Public property | AssemblyName | Gets the name of the assembly.
Public property | CategoryId | Gets the category ID.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClassName | Gets the name of the class.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | CopyGuid | Gets the copy GUID.
Public property | CopyReportGuid | Gets the copy report GUID.
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | DSKey | Gets the DS Key.
Public property | FileName | Gets the file name of the report.
Public property | FriendlyKey | Gets the friendly key.
Public property | ICDataSource | Gets the ic data source.
Public property | Id | Gets the report ID.
Public property | IsLocked | Gets the locked.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsReleased | Gets the released status.
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | LastRunDateTimeUtc | Gets the last run date time UTC.
Public property | LastRunUserId | Gets the last run user id.
Public property | License | Gets the license.
Public property | LinkedReportFriendlyKey | Gets the linked report friendly key.
Public property | LogoFile | Gets the logo file.
Public property | MaxRows | Gets the max rows.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | Notes | Gets the report notes.
Public property | Orientation | Gets the orientation.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | ParameterPageHelpId | Gets the parameter page help id.
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportPageHelpId | Gets the report page help id.
Public property | ReportType | Gets the type of the report.
Public property | ReportXml | Gets the report XML.
Public property | RequireAcl | Gets the require acl.
Public property | RunCount | Gets the run count.
Public property | Sequence | Gets the sequence.
Public property | StoredProcedure | Gets the stored procedure.
Public property | StoredProcedureCount | Gets the stored procedure count.
Public property | StoredProcedureSample | Gets the stored procedure sample.
Public property | SubTitle | Gets the sub title.
Public property | SubTitleResource | Gets the sub title resource.
Public property | TimeoutPeriod | Gets the last modified date time UTC.
Public property | Version | Gets the version.

See Also

ReportMasterConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


AllowCount Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..AllowCount Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the allow count.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> AllowCount { get; }
Visual Basic
Public ReadOnly Property AllowCount As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The allow count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


AllowParameterEdit Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..AllowParameterEdit Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the allow parameter edit.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> AllowParameterEdit { get; }
Visual Basic
Public ReadOnly Property AllowParameterEdit As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The allow parameter edit.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


AssemblyName Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..AssemblyName Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the name of the assembly.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> AssemblyName { get; }
Visual Basic
Public ReadOnly Property AssemblyName As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The name of the assembly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


CategoryId Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..CategoryId Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the category ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The category ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ClassName Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ClassName Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the name of the class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> ClassName { get; }
Visual Basic
Public ReadOnly Property ClassName As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The name of the class.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


CopyGuid Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..CopyGuid Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the copy GUID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> CopyGuid { get; }
Visual Basic
Public ReadOnly Property CopyGuid As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The copy GUID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


CopyReportGuid Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..CopyReportGuid Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the copy report GUID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> CopyReportGuid { get; }
Visual Basic
Public ReadOnly Property CopyReportGuid As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The copy report GUID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Description Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Description Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DescriptionResource Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..DescriptionResource Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the description resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> DescriptionResource { get; }
Visual Basic
Public ReadOnly Property DescriptionResource As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The description resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DSKey Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..DSKey Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the DS Key.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, int> DSKey { get; }
Visual Basic
Public ReadOnly Property DSKey As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Integer)
    Get

Field Value

The DS Key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


FileName Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..FileName Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the file name of the report.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> FileName { get; }
Visual Basic
Public ReadOnly Property FileName As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The file name of the report.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


FriendlyKey Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..FriendlyKey Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the friendly key.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> FriendlyKey { get; }
Visual Basic
Public ReadOnly Property FriendlyKey As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The friendly key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ICDataSource Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ICDataSource Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the ic data source.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> ICDataSource { get; }
Visual Basic
Public ReadOnly Property ICDataSource As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The ic data source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Id Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the report ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The report ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsLocked Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..IsLocked Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the locked.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> IsLocked { get; }
Visual Basic
Public ReadOnly Property IsLocked As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The locked.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsReleased Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..IsReleased Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the released status.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> IsReleased { get; }
Visual Basic
Public ReadOnly Property IsReleased As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The reports released status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsVisible Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..IsVisible Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the visible.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> IsVisible { get; }
Visual Basic
Public ReadOnly Property IsVisible As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The visible.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..LastModifiedDateTimeUtc Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..LastModifiedUser Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastRunDateTimeUtc Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..LastRunDateTimeUtc Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the last run date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, DateTime> LastRunDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastRunDateTimeUtc As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, DateTime)
    Get

Field Value

The last run date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastRunUserId Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..LastRunUserId Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the last run user id.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> LastRunUserId { get; }
Visual Basic
Public ReadOnly Property LastRunUserId As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The last run user id.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


License Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..License Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the license.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> License { get; }
Visual Basic
Public ReadOnly Property License As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LinkedReportFriendlyKey Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..LinkedReportFriendlyKey Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the linked report friendly key.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> LinkedReportFriendlyKey { get; }
Visual Basic
Public ReadOnly Property LinkedReportFriendlyKey As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The linked report friendly key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LogoFile Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..LogoFile Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the logo file.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> LogoFile { get; }
Visual Basic
Public ReadOnly Property LogoFile As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The logo file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


MaxRows Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..MaxRows Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the max rows.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, int> MaxRows { get; }
Visual Basic
Public ReadOnly Property MaxRows As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Integer)
    Get

Field Value

The max rows.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Name Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Name Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> Name { get; }
Visual Basic
Public ReadOnly Property Name As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


NameResource Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..NameResource Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the name resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> NameResource { get; }
Visual Basic
Public ReadOnly Property NameResource As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The name resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Notes Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Notes Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the report notes.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> Notes { get; }
Visual Basic
Public ReadOnly Property Notes As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The report notes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Orientation Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Orientation Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the orientation.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, Orientation> Orientation { get; }
Visual Basic
Public ReadOnly Property Orientation As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Orientation)
    Get

Field Value

The orientation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ParameterPageHelpId Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ParameterPageHelpId Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the parameter page help id.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> ParameterPageHelpId { get; }
Visual Basic
Public ReadOnly Property ParameterPageHelpId As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The parameter page help id.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..PropertiesChanged Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportMasterConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportMasterConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ReadOnly Property
ReportMasterConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportPageHelpId Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ReportPageHelpId Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the report page help id.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> ReportPageHelpId { get; }
Visual Basic
Public ReadOnly Property ReportPageHelpId As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The report page help id.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportType Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ReportType Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the type of the report.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, ReportType> ReportType { get; }
Visual Basic
Public ReadOnly Property ReportType As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, ReportType)
    Get

Field Value

The type of the report.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportXml Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..ReportXml Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the report XML.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> ReportXml { get; }
Visual Basic
Public ReadOnly Property ReportXml As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The report XML.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


RequireAcl Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..RequireAcl Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the require acl.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, bool> RequireAcl { get; }
Visual Basic
Public ReadOnly Property RequireAcl As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Boolean)
    Get

Field Value

The require acl.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


RunCount Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..RunCount Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the run count.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, int> RunCount { get; }
Visual Basic
Public ReadOnly Property RunCount As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Integer)
    Get

Field Value

The run count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Sequence Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Sequence Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the sequence.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, int> Sequence { get; }
Visual Basic
Public ReadOnly Property Sequence As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Integer)
    Get

Field Value

The sequence.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


StoredProcedure Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..StoredProcedure Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the stored procedure.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> StoredProcedure { get; }
Visual Basic
Public ReadOnly Property StoredProcedure As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The stored procedure.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


StoredProcedureCount Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..StoredProcedureCount Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the stored procedure count.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> StoredProcedureCount { get; }
Visual Basic
Public ReadOnly Property StoredProcedureCount As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The stored procedure count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


StoredProcedureSample Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..StoredProcedureSample Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the stored procedure sample.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> StoredProcedureSample { get; }
Visual Basic
Public ReadOnly Property StoredProcedureSample As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The stored procedure sample.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


SubTitle Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..SubTitle Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the sub title.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> SubTitle { get; }
Visual Basic
Public ReadOnly Property SubTitle As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The sub title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


SubTitleResource Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..SubTitleResource Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the sub title resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, string> SubTitleResource { get; }
Visual Basic
Public ReadOnly Property SubTitleResource As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, String)
    Get

Field Value

The sub title resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


TimeoutPeriod Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..TimeoutPeriod Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, int> TimeoutPeriod { get; }
Visual Basic
Public ReadOnly Property TimeoutPeriod As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Integer)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Version Property
ReportMasterConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportMasterConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportMasterConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration Class
ReportMasterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Property Enumeration
ReportMasterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
CategoryId | 1 | Represents the CategoryId property.
DSKey | 2 | Represents the DSKey property.
FriendlyKey | 3 | Represents the FriendlyKey property.
LinkedReportFriendlyKey | 4 | Represents the LinkedReportFriendlyKey property.
Name | 5 | Represents the Name property.
NameResource | 6 | Represents the NameResource property.
Description | 7 | Represents the Description property.
DescriptionResource | 8 | Represents the DescriptionResource property.
IsVisible | 9 | Represents the IsVisible property.
SubTitle | 10 | Represents the SubTitle property.
SubTitleResource | 11 | Represents the SubTitleResource property.
AssemblyName | 12 | Represents the AssemblyName property.
ClassName | 13 | Represents the ClassName property.
Orientation | 14 | Represents the Orientation property.
ReportXml | 15 | Represents the ReportXml property.
LogoFile | 16 | Represents the LogoFile property.
MaxRows | 17 | Represents the MaxRows property.
LastRunDateTimeUtc | 18 | Represents the LastRunDateTimeUtc property.
LastRunUserId | 19 | Represents the LastRunUserId property.
RunCount | 20 | Represents the RunCount property.
IsLocked | 21 | Represents the IsLocked property.
ICDataSource | 22 | Represents the ICDataSource property.
StoredProcedure | 23 | Represents the StoredProcedure property.
StoredProcedureCount | 24 | Represents the StoredProcedureCount property.
StoredProcedureSample | 25 | Represents the StoredProcedureSample property.
ParameterPageHelpId | 26 | Represents the ParameterPageHelpId property.
ReportPageHelpId | 27 | Represents the ReportPageHelpId property.
AllowParameterEdit | 28 | Represents the AllowParameterEdit property.
AllowCount | 29 | Represents the AllowCount property.
RequireAcl | 30 | Represents the RequireAcl property.
Notes | 31 | Represents the Notes property.
ReportType | 32 | Represents the ReportType property.
Sequence | 33 | Represents the Sequence property.
License | 34 | Represents the License property.
CopyGuid | 35 | Represents the CopyGuid property.
CopyReportGuid | 36 | Represents the CopyReportGuid property.
LastModifiedUser | 37 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 38 | Represents the LastModifiedDateTimeUtc property.
IsReleased | 39 | Represents the IsReleased property.
Version | 40 | Represents the Version property.
TimeoutPeriod | 41 | Represents the TimeoutPeriod property.
ReadOnly | 42 | Represents the ReadOnly property.
FileName | 44 | Represents the FileName property.
DisplayName | 43 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Rights Class
ReportMasterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportMasterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportMasterConfiguration..::..Rights Members
ReportMasterConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportMasterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportMasterConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportMasterConfiguration..::..Rights Properties
ReportMasterConfiguration..::..Rights Class See Also Send Feedback

The ReportMasterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportMasterConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Rights..::..Admin Property
ReportMasterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportMasterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportMasterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration..::..Rights Class
ReportMasterConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportMasterConfiguration..::..Rights..::..View Property
ReportMasterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportMasterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportMasterConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfiguration..::..Rights Class
ReportMasterConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfigurationList Class

[image]

IceLib Technical Reference
ReportMasterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting master report configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportMasterConfigurationList : EditableConfigurationList<ReportMasterConfiguration, ReportMasterConfiguration..::..Property>
Visual Basic
Public Class ReportMasterConfigurationList _
    Inherits EditableConfigurationList(Of ReportMasterConfiguration, ReportMasterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportMasterConfiguration, ReportMasterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportMasterConfiguration, ReportMasterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportMasterConfiguration, ReportMasterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportMasterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportMasterConfigurationList Members
ReportMasterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportMasterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportMasterConfigurationList | Initializes a new instance of the ReportMasterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportMasterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfigurationList Constructor

[image]

IceLib Technical Reference
ReportMasterConfigurationList Constructor
ReportMasterConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportMasterConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportMasterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportMasterConfigurationList Class
ReportMasterConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportMasterConfigurationList Methods
ReportMasterConfigurationList Class See Also Send Feedback

The ReportMasterConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportMasterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportMasterConfigurationList Properties
ReportMasterConfigurationList Class See Also Send Feedback

The ReportMasterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportMasterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportMasterConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportMasterConfigurationList Events
ReportMasterConfigurationList Class See Also Send Feedback

The ReportMasterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportMasterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration Class

[image]

IceLib Technical Reference
ReportParameterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Parameters.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportParameterConfiguration : EditableListConfigurationObject<ReportParameterConfiguration..::..Property>
Visual Basic
Public Class ReportParameterConfiguration _
    Inherits EditableListConfigurationObject(Of ReportParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportParameterConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration Members

[image] [image]

IceLib Technical Reference
ReportParameterConfiguration Members
ReportParameterConfiguration Class Methods Properties See Also Send Feedback

The ReportParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AllowAnd | Gets the allow or.
Public property | AllowOr | Gets the allow or.
Public property | AllowSample | Gets the allow sample.
Public property | AssemblyName | Gets the name of the assembly.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClassName | Gets the name of the class.
Public property | ColumnName | Gets the name of the column.
Public property | ColumnName2 | Gets the column name2.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConvertDateToGmt | Gets the convert date to GMT.
Public property | CustomData1 | Gets the custom data1.
Public property | CustomData2 | Gets the custom data2.
Public property | CustomData3 | Gets the custom data3.
Public property | DataType | Gets the type of the data.
Public property | DefaultValue | Gets the default value.
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | DisplayByDefault | Gets the display by default.
Public property | FriendlyKey | Gets the friendly key.
Public property | Id | Gets the report parameter ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsRequired | Gets the required.
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | License | Gets the license.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | ParameterType | Gets the type of the parameter.
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Sequence | Gets the sequence.
Public property | Source | Gets the source.
Public property | UserControlAssemblyName | Gets the name of the user control assembly.
Public property | UserControlClassName | Gets the name of the user control class.
Public property | Version | Gets the version.

See Also

ReportParameterConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportParameterConfiguration Methods
ReportParameterConfiguration Class See Also Send Feedback

The ReportParameterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportParameterConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportParameterConfiguration Properties
ReportParameterConfiguration Class See Also Send Feedback

The ReportParameterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AllowAnd | Gets the allow or.
Public property | AllowOr | Gets the allow or.
Public property | AllowSample | Gets the allow sample.
Public property | AssemblyName | Gets the name of the assembly.
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ClassName | Gets the name of the class.
Public property | ColumnName | Gets the name of the column.
Public property | ColumnName2 | Gets the column name2.
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | ConvertDateToGmt | Gets the convert date to GMT.
Public property | CustomData1 | Gets the custom data1.
Public property | CustomData2 | Gets the custom data2.
Public property | CustomData3 | Gets the custom data3.
Public property | DataType | Gets the type of the data.
Public property | DefaultValue | Gets the default value.
Public property | Description | Gets the description.
Public property | DescriptionResource | Gets the description resource.
Public property | DisplayByDefault | Gets the display by default.
Public property | FriendlyKey | Gets the friendly key.
Public property | Id | Gets the report parameter ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsRequired | Gets the required.
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | License | Gets the license.
Public property | Name | Gets the name.
Public property | NameResource | Gets the name resource.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | ParameterType | Gets the type of the parameter.
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Sequence | Gets the sequence.
Public property | Source | Gets the source.
Public property | UserControlAssemblyName | Gets the name of the user control assembly.
Public property | UserControlClassName | Gets the name of the user control class.
Public property | Version | Gets the version.

See Also

ReportParameterConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


AllowAnd Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..AllowAnd Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the allow or.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> AllowAnd { get; }
Visual Basic
Public ReadOnly Property AllowAnd As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The allow or.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


AllowOr Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..AllowOr Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the allow or.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> AllowOr { get; }
Visual Basic
Public ReadOnly Property AllowOr As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The allow or.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


AllowSample Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..AllowSample Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the allow sample.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> AllowSample { get; }
Visual Basic
Public ReadOnly Property AllowSample As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The allow sample.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


AssemblyName Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..AssemblyName Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name of the assembly.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> AssemblyName { get; }
Visual Basic
Public ReadOnly Property AssemblyName As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name of the assembly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ClassName Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ClassName Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name of the class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> ClassName { get; }
Visual Basic
Public ReadOnly Property ClassName As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name of the class.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ColumnName Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ColumnName Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name of the column.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> ColumnName { get; }
Visual Basic
Public ReadOnly Property ColumnName As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name of the column.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ColumnName2 Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ColumnName2 Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the column name2.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> ColumnName2 { get; }
Visual Basic
Public ReadOnly Property ColumnName2 As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The column name2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ConvertDateToGmt Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ConvertDateToGmt Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the convert date to GMT.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> ConvertDateToGmt { get; }
Visual Basic
Public ReadOnly Property ConvertDateToGmt As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The convert date to GMT.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


CustomData1 Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..CustomData1 Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the custom data1.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> CustomData1 { get; }
Visual Basic
Public ReadOnly Property CustomData1 As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The custom data1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


CustomData2 Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..CustomData2 Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the custom data2.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> CustomData2 { get; }
Visual Basic
Public ReadOnly Property CustomData2 As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The custom data2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


CustomData3 Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..CustomData3 Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the custom data3.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> CustomData3 { get; }
Visual Basic
Public ReadOnly Property CustomData3 As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The custom data3.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DataType Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..DataType Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the type of the data.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, ReportingParameterDataType> DataType { get; }
Visual Basic
Public ReadOnly Property DataType As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, ReportingParameterDataType)
    Get

Field Value

The type of the data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DefaultValue Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..DefaultValue Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the default value.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> DefaultValue { get; }
Visual Basic
Public ReadOnly Property DefaultValue As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The default value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Description Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Description Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> Description { get; }
Visual Basic
Public ReadOnly Property Description As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DescriptionResource Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..DescriptionResource Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the description resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> DescriptionResource { get; }
Visual Basic
Public ReadOnly Property DescriptionResource As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The description resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


DisplayByDefault Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..DisplayByDefault Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the display by default.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> DisplayByDefault { get; }
Visual Basic
Public ReadOnly Property DisplayByDefault As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The display by default.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


FriendlyKey Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..FriendlyKey Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the friendly key.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> FriendlyKey { get; }
Visual Basic
Public ReadOnly Property FriendlyKey As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The friendly key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Id Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the report parameter ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The report parameter ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsRequired Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..IsRequired Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the required.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> IsRequired { get; }
Visual Basic
Public ReadOnly Property IsRequired As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The required.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsVisible Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..IsVisible Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the visible.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> IsVisible { get; }
Visual Basic
Public ReadOnly Property IsVisible As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The visible.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..LastModifiedDateTimeUtc Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..LastModifiedUser Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


License Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..License Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the license.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> License { get; }
Visual Basic
Public ReadOnly Property License As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Name Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Name Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> Name { get; }
Visual Basic
Public ReadOnly Property Name As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


NameResource Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..NameResource Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name resource.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> NameResource { get; }
Visual Basic
Public ReadOnly Property NameResource As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ParameterType Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ParameterType Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the type of the parameter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, ReportingParameterTypes> ParameterType { get; }
Visual Basic
Public ReadOnly Property ParameterType As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, ReportingParameterTypes)
    Get

Field Value

The type of the parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..PropertiesChanged Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportParameterConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportParameterConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ReadOnly Property
ReportParameterConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportId Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..ReportId Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the report ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> ReportId { get; }
Visual Basic
Public ReadOnly Property ReportId As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The report ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Sequence Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Sequence Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the sequence.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, int> Sequence { get; }
Visual Basic
Public ReadOnly Property Sequence As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Integer)
    Get

Field Value

The sequence.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Source Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Source Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the source.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, ParameterSource> Source { get; }
Visual Basic
Public ReadOnly Property Source As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, ParameterSource)
    Get

Field Value

The source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


UserControlAssemblyName Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..UserControlAssemblyName Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name of the user control assembly.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> UserControlAssemblyName { get; }
Visual Basic
Public ReadOnly Property UserControlAssemblyName As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name of the user control assembly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


UserControlClassName Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..UserControlClassName Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the name of the user control class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, string> UserControlClassName { get; }
Visual Basic
Public ReadOnly Property UserControlClassName As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, String)
    Get

Field Value

The name of the user control class.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Version Property
ReportParameterConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportParameterConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportParameterConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration Class
ReportParameterConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Property Enumeration
ReportParameterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
ReportId | 1 | Represents the ReportId property.
Name | 2 | Represents the Name property.
NameResource | 3 | Represents the NameResource property.
Description | 4 | Represents the Description property.
DescriptionResource | 5 | Represents the DescriptionResource property.
IsVisible | 6 | Represents the IsVisible property.
LastModifiedUser | 7 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 8 | Represents the LastModifiedDateTimeUtc property.
Sequence | 9 | Represents the Sequence property.
FriendlyKey | 10 | Represents the FriendlyKey property.
AssemblyName | 11 | Represents the AssemblyName property.
ClassName | 12 | Represents the ClassName property.
UserControlAssemblyName | 13 | Represents the UserControlAssemblyName property.
UserControlClassName | 14 | Represents the UserControlClassName property.
Source | 15 | Represents the Source property.
DataType | 16 | Represents the DataType property.
DefaultValue | 17 | Represents the DefaultValue property.
IsRequired | 18 | Represents the IsRequired property.
DisplayByDefault | 19 | Represents the DisplayByDefault property.
ColumnName | 20 | Represents the ColumnName property.
ColumnName2 | 21 | Represents the ColumnName2 property.
ConvertDateToGmt | 22 | Represents the ConvertDateToGmt property.
ParameterType | 23 | Represents the ParameterType property.
CustomData1 | 24 | Represents the CustomData1 property.
CustomData2 | 25 | Represents the CustomData2 property.
CustomData3 | 26 | Represents the CustomData3 property.
AllowSample | 27 | Represents the AllowSample property.
AllowOr | 28 | Represents the AllowOr property.
AllowAnd | 29 | Represents the AllowAnd property.
License | 30 | Represents the License property.
Version | 31 | Represents the Version property.
ReadOnly | 32 | Represents the ReadOnly property.
DisplayName | 33 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Rights Class
ReportParameterConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportParameterConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportParameterConfiguration..::..Rights Members
ReportParameterConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportParameterConfiguration..::..Rights Properties
ReportParameterConfiguration..::..Rights Class See Also Send Feedback

The ReportParameterConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportParameterConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Rights..::..Admin Property
ReportParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportParameterConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportParameterConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration..::..Rights Class
ReportParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportParameterConfiguration..::..Rights..::..View Property
ReportParameterConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportParameterConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportParameterConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfiguration..::..Rights Class
ReportParameterConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfigurationList Class

[image]

IceLib Technical Reference
ReportParameterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting parameter configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportParameterConfigurationList : EditableConfigurationList<ReportParameterConfiguration, ReportParameterConfiguration..::..Property>
Visual Basic
Public Class ReportParameterConfigurationList _
    Inherits EditableConfigurationList(Of ReportParameterConfiguration, ReportParameterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportParameterConfiguration, ReportParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportParameterConfiguration, ReportParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportParameterConfiguration, ReportParameterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportParameterConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportParameterConfigurationList Members
ReportParameterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportParameterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportParameterConfigurationList | Initializes a new instance of the ReportParameterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportParameterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfigurationList Constructor

[image]

IceLib Technical Reference
ReportParameterConfigurationList Constructor
ReportParameterConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportParameterConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportParameterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportParameterConfigurationList Class
ReportParameterConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportParameterConfigurationList Methods
ReportParameterConfigurationList Class See Also Send Feedback

The ReportParameterConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportParameterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportParameterConfigurationList Properties
ReportParameterConfigurationList Class See Also Send Feedback

The ReportParameterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportParameterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportParameterConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportParameterConfigurationList Events
ReportParameterConfigurationList Class See Also Send Feedback

The ReportParameterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportParameterConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration Class

[image]

IceLib Technical Reference
ReportSectionConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Sections.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportSectionConfiguration : EditableListConfigurationObject<ReportSectionConfiguration..::..Property>
Visual Basic
Public Class ReportSectionConfiguration _
    Inherits EditableListConfigurationObject(Of ReportSectionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportSectionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportSectionConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration Members

[image] [image]

IceLib Technical Reference
ReportSectionConfiguration Members
ReportSectionConfiguration Class Methods Properties See Also Send Feedback

The ReportSectionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Id | Gets the report section ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | Name | Gets the name.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Version | Gets the version.

See Also

ReportSectionConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportSectionConfiguration Methods
ReportSectionConfiguration Class See Also Send Feedback

The ReportSectionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportSectionConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportSectionConfiguration Properties
ReportSectionConfiguration Class See Also Send Feedback

The ReportSectionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | Id | Gets the report section ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | IsVisible | Gets the visible.
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | Name | Gets the name.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Version | Gets the version.

See Also

ReportSectionConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Id Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the report section ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, String)
    Get

Field Value

The report section ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


IsVisible Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..IsVisible Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the visible.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, bool> IsVisible { get; }
Visual Basic
Public ReadOnly Property IsVisible As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, Boolean)
    Get

Field Value

The visible.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..LastModifiedDateTimeUtc Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..LastModifiedUser Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Name Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Name Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, string> Name { get; }
Visual Basic
Public ReadOnly Property Name As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..PropertiesChanged Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportSectionConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportSectionConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..ReadOnly Property
ReportSectionConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportId Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..ReportId Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the report ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, string> ReportId { get; }
Visual Basic
Public ReadOnly Property ReportId As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, String)
    Get

Field Value

The report ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Version Property
ReportSectionConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSectionConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportSectionConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration Class
ReportSectionConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Property Enumeration
ReportSectionConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
LastModifiedUser | 1 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 2 | Represents the LastModifiedDateTimeUtc property.
ReportId | 3 | Represents the ReportId property.
Name | 4 | Represents the Name property.
IsVisible | 5 | Represents the IsVisible property.
Version | 6 | Represents the Version property.
ReadOnly | 7 | Represents the ReadOnly property.
DisplayName | 8 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Rights Class
ReportSectionConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportSectionConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportSectionConfiguration..::..Rights Members
ReportSectionConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportSectionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportSectionConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportSectionConfiguration..::..Rights Properties
ReportSectionConfiguration..::..Rights Class See Also Send Feedback

The ReportSectionConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportSectionConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Rights..::..Admin Property
ReportSectionConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportSectionConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportSectionConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration..::..Rights Class
ReportSectionConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportSectionConfiguration..::..Rights..::..View Property
ReportSectionConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportSectionConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportSectionConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfiguration..::..Rights Class
ReportSectionConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfigurationList Class

[image]

IceLib Technical Reference
ReportSectionConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting section configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportSectionConfigurationList : EditableConfigurationList<ReportSectionConfiguration, ReportSectionConfiguration..::..Property>
Visual Basic
Public Class ReportSectionConfigurationList _
    Inherits EditableConfigurationList(Of ReportSectionConfiguration, ReportSectionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportSectionConfiguration, ReportSectionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportSectionConfiguration, ReportSectionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportSectionConfiguration, ReportSectionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportSectionConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportSectionConfigurationList Members
ReportSectionConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportSectionConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportSectionConfigurationList | Initializes a new instance of the ReportSectionConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportSectionConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfigurationList Constructor

[image]

IceLib Technical Reference
ReportSectionConfigurationList Constructor
ReportSectionConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportSectionConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportSectionConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSectionConfigurationList Class
ReportSectionConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportSectionConfigurationList Methods
ReportSectionConfigurationList Class See Also Send Feedback

The ReportSectionConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportSectionConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportSectionConfigurationList Properties
ReportSectionConfigurationList Class See Also Send Feedback

The ReportSectionConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportSectionConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSectionConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportSectionConfigurationList Events
ReportSectionConfigurationList Class See Also Send Feedback

The ReportSectionConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportSectionConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration Class

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's System Settings.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportSystemSettingConfiguration : EditableListConfigurationObject<ReportSystemSettingConfiguration..::..Property>
Visual Basic
Public Class ReportSystemSettingConfiguration _
    Inherits EditableListConfigurationObject(Of ReportSystemSettingConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportSystemSettingConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportSystemSettingConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration Members

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfiguration Members
ReportSystemSettingConfiguration Class Methods Properties See Also Send Feedback

The ReportSystemSettingConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | FirstDayOfWeek | Gets the first day of week.
Public property | Id | Gets the report system setting ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTime | Gets the last modified date time.
Public property | LastModifiedUser | Gets the last modified user.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | SystemLogoFile | Gets the system logo file.
Public property | TimeoutPeriod | Gets the first day of week.
Public property | Version | Gets the version.

See Also

ReportSystemSettingConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfiguration Methods
ReportSystemSettingConfiguration Class See Also Send Feedback

The ReportSystemSettingConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportSystemSettingConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfiguration Properties
ReportSystemSettingConfiguration Class See Also Send Feedback

The ReportSystemSettingConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | FirstDayOfWeek | Gets the first day of week.
Public property | Id | Gets the report system setting ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTime | Gets the last modified date time.
Public property | LastModifiedUser | Gets the last modified user.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | SystemLogoFile | Gets the system logo file.
Public property | TimeoutPeriod | Gets the first day of week.
Public property | Version | Gets the version.

See Also

ReportSystemSettingConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


FirstDayOfWeek Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..FirstDayOfWeek Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the first day of week.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, DayOfWeek> FirstDayOfWeek { get; }
Visual Basic
Public ReadOnly Property FirstDayOfWeek As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, DayOfWeek)
    Get

Field Value

The first day of week.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Id Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the report system setting ID.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, String)
    Get

Field Value

The report system setting ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTime Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..LastModifiedDateTime Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the last modified date time.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, DateTime> LastModifiedDateTime { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTime As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..LastModifiedUser Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the last modified user.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..PropertiesChanged Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportSystemSettingConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportSystemSettingConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..ReadOnly Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


SystemLogoFile Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..SystemLogoFile Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the system logo file.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, string> SystemLogoFile { get; }
Visual Basic
Public ReadOnly Property SystemLogoFile As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, String)
    Get

Field Value

The system logo file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


TimeoutPeriod Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..TimeoutPeriod Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the first day of week.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, int> TimeoutPeriod { get; }
Visual Basic
Public ReadOnly Property TimeoutPeriod As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, Integer)
    Get

Field Value

The first day of week.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Version Property
ReportSystemSettingConfiguration Class See Also Send Feedback
Gets the version.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportSystemSettingConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportSystemSettingConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration Class
ReportSystemSettingConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Property Enumeration
ReportSystemSettingConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
SystemLogoFile | 1 | Represents the SystemLogoFile property.
FirstDayOfWeek | 2 | Represents the FirstDayOfWeek property.
TimeoutPeriod | 3 | Represents the TimeoutPeriod property.
LastModifiedUser | 4 | Represents the LastModifiedUser property.
LastModifiedDateTime | 5 | Represents the LastModifiedDateTime property.
Version | 6 | Represents the Version property.
ReadOnly | 7 | Represents the ReadOnly property.
DisplayName | 8 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Rights Class
ReportSystemSettingConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportSystemSettingConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Rights Members
ReportSystemSettingConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportSystemSettingConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportSystemSettingConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Rights Properties
ReportSystemSettingConfiguration..::..Rights Class See Also Send Feedback

The ReportSystemSettingConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportSystemSettingConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Rights..::..Admin Property
ReportSystemSettingConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportSystemSettingConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportSystemSettingConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration..::..Rights Class
ReportSystemSettingConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportSystemSettingConfiguration..::..Rights..::..View Property
ReportSystemSettingConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportSystemSettingConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportSystemSettingConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfiguration..::..Rights Class
ReportSystemSettingConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfigurationList Class

[image]

IceLib Technical Reference
ReportSystemSettingConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting system settings configuration objects.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportSystemSettingConfigurationList : EditableConfigurationList<ReportSystemSettingConfiguration, ReportSystemSettingConfiguration..::..Property>
Visual Basic
Public Class ReportSystemSettingConfigurationList _
    Inherits EditableConfigurationList(Of ReportSystemSettingConfiguration, ReportSystemSettingConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportSystemSettingConfiguration, ReportSystemSettingConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportSystemSettingConfiguration, ReportSystemSettingConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportSystemSettingConfiguration, ReportSystemSettingConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportSystemSettingConfigurationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfigurationList Members
ReportSystemSettingConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportSystemSettingConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportSystemSettingConfigurationList | Initializes a new instance of the ReportSystemSettingConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportSystemSettingConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfigurationList Constructor

[image]

IceLib Technical Reference
ReportSystemSettingConfigurationList Constructor
ReportSystemSettingConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportSystemSettingConfigurationList class.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportSystemSettingConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReportSystemSettingConfigurationList Class
ReportSystemSettingConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfigurationList Methods
ReportSystemSettingConfigurationList Class See Also Send Feedback

The ReportSystemSettingConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportSystemSettingConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfigurationList Properties
ReportSystemSettingConfigurationList Class See Also Send Feedback

The ReportSystemSettingConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportSystemSettingConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportSystemSettingConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportSystemSettingConfigurationList Events
ReportSystemSettingConfigurationList Class See Also Send Feedback

The ReportSystemSettingConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportSystemSettingConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration Class

[image]

IceLib Technical Reference
ReportTableConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for Reporting's Table Data.

Note: This class is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportTableConfiguration : EditableListConfigurationObject<ReportTableConfiguration..::..Property>
Visual Basic
Public Class ReportTableConfiguration _
    Inherits EditableListConfigurationObject(Of ReportTableConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationObject
ININ.IceLib.Configuration..::..ListConfigurationObject
ININ.IceLib.Configuration..::..EditableListConfigurationObject <(Of <(<' ReportTableConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportTableConfiguration

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration Members

[image] [image]

IceLib Technical Reference
ReportTableConfiguration Members
ReportTableConfiguration Class Methods Properties See Also Send Feedback

The ReportTableConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IcDataSource | Gets the IC Data Source
Public property | Id | Gets the report custom data ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Sequence | Gets the Sequence Number
Public property | TableName | Gets the name.
Public property | Version | Gets the version.

See Also

ReportTableConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration Methods

[image] [image]

IceLib Technical Reference
ReportTableConfiguration Methods
ReportTableConfiguration Class See Also Send Feedback

The ReportTableConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | Cancels an edit started by PrepareForEdit()()()(). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Commit | Commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | CommitAsync | Asynchronously commits the contents of this object to the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Delete | Deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | DeleteAsync | Asynchronously deletes this object from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | Gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | GetValidatorsAsync | Asynchronously gets the validators for a given configuration object type (and associates them with their Properties). (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | Prepares a list-based configuration object for edit. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetConfigurationId | Sets the unique identifier used to reference this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | SetDisplayName | Sets the display name for this configuration object. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ConfigurationObject.)

See Also

ReportTableConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration Properties

[image] [image]

IceLib Technical Reference
ReportTableConfiguration Properties
ReportTableConfiguration Class See Also Send Feedback

The ReportTableConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Indicates if this object has been modified since it was retrieved from the server. (Inherited from EditableListConfigurationObject<(Of <(<'TPropertyEnum>)>)>.)
Public property | ConfigurationId | Gets the configuration ID. (Use Property.Id and Property.DisplayName to filter or sort on this property.) (Inherited from ListConfigurationObject.)
Public property | IcDataSource | Gets the IC Data Source
Public property | Id | Gets the report custom data ID.
Public property | IsNewObject | Gets a value indicating whether this object is a new object. (Inherited from ConfigurationObject.)
Public property | LastModifiedDateTimeUtc | Gets the last modified date time UTC.
Public property | LastModifiedUser | Gets the last modified user.
Public property | OriginalConfigurationId | Following a commit, this will be equivalent to the configuration ID that was assigned to this object prior to the commit. (Inherited from ListConfigurationObject.)
Public property | PropertiesChanged | Gets the properties that have been changed.
Public property | ReadOnly | Indicates if the class is read only.
Public property | ReportId | Gets the report ID.
Public property | Sequence | Gets the Sequence Number
Public property | TableName | Gets the name.
Public property | Version | Gets the version.

See Also

ReportTableConfiguration Class
ININ.IceLib.Configuration.Reporting Namespace


IcDataSource Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..IcDataSource Property
ReportTableConfiguration Class See Also Send Feedback
Gets the IC Data Source

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, string> IcDataSource { get; }
Visual Basic
Public ReadOnly Property IcDataSource As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, String)
    Get

Field Value

The IC Data Source

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Id Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Id Property
ReportTableConfiguration Class See Also Send Feedback
Gets the report custom data ID.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, string> Id { get; }
Visual Basic
Public ReadOnly Property Id As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, String)
    Get

Field Value

The report custom data ID.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedDateTimeUtc Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..LastModifiedDateTimeUtc Property
ReportTableConfiguration Class See Also Send Feedback
Gets the last modified date time UTC.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, DateTime> LastModifiedDateTimeUtc { get; }
Visual Basic
Public ReadOnly Property LastModifiedDateTimeUtc As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, DateTime)
    Get

Field Value

The last modified date time UTC.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


LastModifiedUser Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..LastModifiedUser Property
ReportTableConfiguration Class See Also Send Feedback
Gets the last modified user.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, string> LastModifiedUser { get; }
Visual Basic
Public ReadOnly Property LastModifiedUser As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, String)
    Get

Field Value

The last modified user.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


PropertiesChanged Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..PropertiesChanged Property
ReportTableConfiguration Class See Also Send Feedback
Gets the properties that have been changed.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReportTableConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of ReportTableConfiguration..::..Property)
    Get

Field Value

The changed properties.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReadOnly Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..ReadOnly Property
ReportTableConfiguration Class See Also Send Feedback
Indicates if the class is read only.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, bool> ReadOnly { get; }
Visual Basic
Public ReadOnly Property ReadOnly As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, Boolean)
    Get

Field Value

The read only indicator.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportId Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..ReportId Property
ReportTableConfiguration Class See Also Send Feedback
Gets the report ID.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, string> ReportId { get; }
Visual Basic
Public ReadOnly Property ReportId As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, String)
    Get

Field Value

The report ID.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Sequence Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Sequence Property
ReportTableConfiguration Class See Also Send Feedback
Gets the Sequence Number

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, int> Sequence { get; }
Visual Basic
Public ReadOnly Property Sequence As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, Integer)
    Get

Field Value

The Sequence Number

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


TableName Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..TableName Property
ReportTableConfiguration Class See Also Send Feedback
Gets the name.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, string> TableName { get; }
Visual Basic
Public ReadOnly Property TableName As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, String)
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


Version Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Version Property
ReportTableConfiguration Class See Also Send Feedback
Gets the version.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GeneralConfigurationProperty<ReportTableConfiguration..::..Property, int> Version { get; }
Visual Basic
Public ReadOnly Property Version As GeneralConfigurationProperty(Of ReportTableConfiguration..::..Property, Integer)
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration Class
ReportTableConfiguration Members
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration.Property Enumeration

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Property Enumeration
ReportTableConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Note: This enumeration is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id property.
ReportId | 1 | Represents the ReportId property.
TableName | 2 | Represents the TableName property.
IcDataSource | 3 | Represents the IcDataSource property.
Sequence | 4 | Represents the Sequence property.
LastModifiedUser | 5 | Represents the LastModifiedUser property.
LastModifiedDateTimeUtc | 6 | Represents the LastModifiedDateTimeUtc property.
Version | 7 | Represents the Version property.
ReadOnly | 8 | Represents the ReadOnly property.
DisplayName | 9 | Represents the DisplayName part of the ConfigurationId property.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration.Rights Class

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Rights Class
ReportTableConfiguration Class Members See Also Send Feedback
Provides filters that can be used to filter based on access control lists.

Note: This class is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Rights
Visual Basic
Public NotInheritable Class Rights

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Reporting..::..ReportTableConfiguration..::..Rights

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration.Rights Members

[image] [image]

IceLib Technical Reference
ReportTableConfiguration..::..Rights Members
ReportTableConfiguration..::..Rights Class Properties See Also Send Feedback

The ReportTableConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportTableConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfiguration.Rights Properties

[image] [image]

IceLib Technical Reference
ReportTableConfiguration..::..Rights Properties
ReportTableConfiguration..::..Rights Class See Also Send Feedback

The ReportTableConfiguration..::..Rights type exposes the following members.

Properties

Name | Description
Admin | Gets the admin rights filter.
View | Gets the view rights filter.

See Also

ReportTableConfiguration..::..Rights Class
ININ.IceLib.Configuration.Reporting Namespace


Admin Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Rights..::..Admin Property
ReportTableConfiguration..::..Rights Class See Also Send Feedback
Gets the admin rights filter.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportTableConfiguration> Admin { get; private set; }
Visual Basic
Public Shared Property Admin As RightsQueryFilter(Of ReportTableConfiguration)
    Get
    Private Set

Field Value

The admin rights filter.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration..::..Rights Class
ReportTableConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


View Property

[image]

IceLib Technical Reference
ReportTableConfiguration..::..Rights..::..View Property
ReportTableConfiguration..::..Rights Class See Also Send Feedback
Gets the view rights filter.

Note: This property is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static RightsQueryFilter<ReportTableConfiguration> View { get; private set; }
Visual Basic
Public Shared Property View As RightsQueryFilter(Of ReportTableConfiguration)
    Get
    Private Set

Field Value

The view right filter.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfiguration..::..Rights Class
ReportTableConfiguration..::..Rights Members
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfigurationList Class

[image]

IceLib Technical Reference
ReportTableConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing reporting table configuration objects.

Note: This class is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportTableConfigurationList : EditableConfigurationList<ReportTableConfiguration, ReportTableConfiguration..::..Property>
Visual Basic
Public Class ReportTableConfigurationList _
    Inherits EditableConfigurationList(Of ReportTableConfiguration, ReportTableConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration..::..ConfigurationList <(Of <(<' ReportTableConfiguration, ReportTableConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..DynamicConfigurationList <(Of <(<' ReportTableConfiguration, ReportTableConfiguration..::..Property >)>)>
ININ.IceLib.Configuration..::..EditableConfigurationList <(Of <(<' ReportTableConfiguration, ReportTableConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Reporting..::..ReportTableConfigurationList

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfigurationList Members

[image] [image]

IceLib Technical Reference
ReportTableConfigurationList Members
ReportTableConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ReportTableConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ReportTableConfigurationList | Initializes a new instance of the ReportTableConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportTableConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfigurationList Constructor

[image]

IceLib Technical Reference
ReportTableConfigurationList Constructor
ReportTableConfigurationList Class See Also Send Feedback
Initializes a new instance of the ReportTableConfigurationList class.

Note: This constructor is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Configuration.Reporting
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReportTableConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

ReportTableConfigurationList Class
ReportTableConfigurationList Members
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfigurationList Methods

[image] [image]

IceLib Technical Reference
ReportTableConfigurationList Methods
ReportTableConfigurationList Class See Also Send Feedback

The ReportTableConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | Changes the query settings, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ChangeWatchQuerySettingsAsync | Changes the query settings asynchronously, replacing the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> with those passed in. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObject | Creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateObjectAsync | Asynchronously creates a new object in the list. (Inherited from EditableConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | CreateQuerySettings | Creates a query settings object that is appropriate to this list's query functions, such as StartCaching()()()(). The QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> class is constructed with default values to use a dynamic limit to return all IDs and display names that the current user has view access to. This list is sorted ascending by display name. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | Gets the configuration list. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | Refreshes the current watch, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | RefreshWatchAsync | Refreshes the current watch asynchronously, which will update the list with any new items that match the current QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching()()()() | Starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts caching the specified configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching()()()() | Starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>)) | Starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects using a default QuerySettings<(Of <(<'TConfigurationObject, TPropertyEnum>)>)> object. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(TConfigurationObject, TPropertyEnum>)>>), AsyncCompletedEventHandler, Object) | Asynchronously starts watching the specified configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopCaching | Stops caching the configuration objects. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatching | Stops watching the configuration objects. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | StopWatchingAsync | Asynchronously stops watching the configuration list. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportTableConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfigurationList Properties

[image] [image]

IceLib Technical Reference
ReportTableConfigurationList Properties
ReportTableConfigurationList Class See Also Send Feedback

The ReportTableConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | Gets the configuration manager. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsCaching | Gets a value indicating whether this instance is cached. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | IsWatching | Gets a value indicating whether this instance is watched. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available. (Inherited from ConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportTableConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ReportTableConfigurationList Events

[image] [image]

IceLib Technical Reference
ReportTableConfigurationList Events
ReportTableConfigurationList Class See Also Send Feedback

The ReportTableConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | Occurs when at least one item of type TConfigurationObject is added. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsChanged | Occurs when at least one item of type TConfigurationObject is modified. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)
Public event | ConfigurationObjectsRemoved | Occurs when at least one item of type TConfigurationObject is removed. (Inherited from DynamicConfigurationList<(Of <(<'TConfigurationObject, TPropertyEnum>)>)>.)

See Also

ReportTableConfigurationList Class
ININ.IceLib.Configuration.Reporting Namespace


ININ.IceLib.Configuration.ResponseManagement Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.ResponseManagement Namespace
Send Feedback

The ININ.IceLib.Configuration.ResponseManagement namespace contains classes that provide support for retreiving and updating response management documents.

Classes

 | Class | Description
Public class | ResponseManagementCategoryDocumentItem | Contains information about a response management category document item that is contained within a ResponseManagementDocument.
Public class | ResponseManagementDocument | Contains information about a response management document.
Public class | ResponseManagementDocumentItem | Contains base information about a response management document item that is contained within a ResponseManagementDocument.
Public class | ResponseManagementDocumentReference | Contains information about a response management document reference item that is contained within a ResponseManagementDocument.
Public class | ResponseManagementEntryDocumentItem | Contains information about a response management entry document item that is contained within a ResponseManagementDocument.

Interfaces

 | Interface | Description
Public interface | IResponseManagementDocumentItemContainer | Provides an interface for working with objects that can be a container for ResponseManagementDocumentItem objects.

Enumerations

 | Enumeration | Description
Public enumeration | ResponseManagementEntryDocumentItemType | Represents the possible response management entry document item types from a ResponseManagementEntryDocumentItem.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.


IResponseManagementDocumentItemContainer Interface

[image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer Interface
Members See Also Send Feedback
Provides an interface for working with objects that can be a container for ResponseManagementDocumentItem objects.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IResponseManagementDocumentItemContainer
Visual Basic
Public Interface IResponseManagementDocumentItemContainer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

IResponseManagementDocumentItemContainer Members
ININ.IceLib.Configuration.ResponseManagement Namespace


IResponseManagementDocumentItemContainer Members

[image] [image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer Members
IResponseManagementDocumentItemContainer Interface Methods Properties See Also Send Feedback

The IResponseManagementDocumentItemContainer type exposes the following members.

Methods

 | Name | Description
Public method | AddDocumentItem | Adds the document item.
Public method | ClearDocumentItems | Clears the document items.
Public method | RemoveDocumentItem | Removes the document item.

Properties

 | Name | Description
Public property | DocumentItems | Gets the document items.

See Also

IResponseManagementDocumentItemContainer Interface
ININ.IceLib.Configuration.ResponseManagement Namespace


IResponseManagementDocumentItemContainer Methods

[image] [image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer Methods
IResponseManagementDocumentItemContainer Interface See Also Send Feedback

The IResponseManagementDocumentItemContainer type exposes the following members.

Methods

 | Name | Description
Public method | AddDocumentItem | Adds the document item.
Public method | ClearDocumentItems | Clears the document items.
Public method | RemoveDocumentItem | Removes the document item.

See Also

IResponseManagementDocumentItemContainer Interface
ININ.IceLib.Configuration.ResponseManagement Namespace


AddDocumentItem Method

[image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer..::..AddDocumentItem Method
IResponseManagementDocumentItemContainer Interface See Also Send Feedback
Adds the document item.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void AddDocumentItem(
    ResponseManagementDocumentItem documentItem
)
Visual Basic
Sub AddDocumentItem ( _
    documentItem As ResponseManagementDocumentItem _
)

Parameters

documentItem
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentItem
The document item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

IResponseManagementDocumentItemContainer Interface
IResponseManagementDocumentItemContainer Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ClearDocumentItems Method

[image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer..::..ClearDocumentItems Method
IResponseManagementDocumentItemContainer Interface See Also Send Feedback
Clears the document items.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void ClearDocumentItems()
Visual Basic
Sub ClearDocumentItems

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

IResponseManagementDocumentItemContainer Interface
IResponseManagementDocumentItemContainer Members
ININ.IceLib.Configuration.ResponseManagement Namespace


RemoveDocumentItem Method

[image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer..::..RemoveDocumentItem Method
IResponseManagementDocumentItemContainer Interface See Also Send Feedback
Removes the document item.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void RemoveDocumentItem(
    string id
)
Visual Basic
Sub RemoveDocumentItem ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

IResponseManagementDocumentItemContainer Interface
IResponseManagementDocumentItemContainer Members
ININ.IceLib.Configuration.ResponseManagement Namespace


IResponseManagementDocumentItemContainer Properties

[image] [image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer Properties
IResponseManagementDocumentItemContainer Interface See Also Send Feedback

The IResponseManagementDocumentItemContainer type exposes the following members.

Properties

 | Name | Description
Public property | DocumentItems | Gets the document items.

See Also

IResponseManagementDocumentItemContainer Interface
ININ.IceLib.Configuration.ResponseManagement Namespace


DocumentItems Property

[image]

IceLib Technical Reference
IResponseManagementDocumentItemContainer..::..DocumentItems Property
IResponseManagementDocumentItemContainer Interface See Also Send Feedback
Gets the document items.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
ReadOnlyCollection<ResponseManagementDocumentItem> DocumentItems { get; }
Visual Basic
ReadOnly Property DocumentItems As ReadOnlyCollection(Of ResponseManagementDocumentItem)
    Get

Field Value

The document items.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

IResponseManagementDocumentItemContainer Interface
IResponseManagementDocumentItemContainer Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementCategoryDocumentItem Class

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem Class
Members See Also Send Feedback
Contains information about a response management category document item that is contained within a ResponseManagementDocument.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManagementCategoryDocumentItem : ResponseManagementDocumentItem,
    IResponseManagementDocumentItemContainer
Visual Basic
Public Class ResponseManagementCategoryDocumentItem _
    Inherits ResponseManagementDocumentItem _
    Implements IResponseManagementDocumentItemContainer

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentItem
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementCategoryDocumentItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementCategoryDocumentItem Members

[image] [image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem Members
ResponseManagementCategoryDocumentItem Class Constructors Methods Properties See Also Send Feedback

The ResponseManagementCategoryDocumentItem type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseManagementCategoryDocumentItem | Initializes a new instance of the ResponseManagementCategoryDocumentItem class.

Methods

 | Name | Description
Public method | AddDocumentItem | Adds the document item.
Public method | ClearDocumentItems | Clears the document items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveDocumentItem | Removes the document item.
Public method | ToString | Returns a String that represents the current Object. (Overrides ResponseManagementDocumentItem..::..ToString()()()().)

Properties

 | Name | Description
Public property | DocumentItems | Gets the document items.
Public property | Id | Gets or sets the ID. (Inherited from ResponseManagementDocumentItem.)
Public property | Title | Gets or sets the title. (Inherited from ResponseManagementDocumentItem.)

See Also

ResponseManagementCategoryDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementCategoryDocumentItem Constructor

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem Constructor
ResponseManagementCategoryDocumentItem Class See Also Send Feedback
Initializes a new instance of the ResponseManagementCategoryDocumentItem class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementCategoryDocumentItem(
    string title
)
Visual Basic
Public Sub New ( _
    title As String _
)

Parameters

title
Type: System..::..String
The title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementCategoryDocumentItem Class
ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementCategoryDocumentItem Methods

[image] [image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem Methods
ResponseManagementCategoryDocumentItem Class See Also Send Feedback

The ResponseManagementCategoryDocumentItem type exposes the following members.

Methods

 | Name | Description
Public method | AddDocumentItem | Adds the document item.
Public method | ClearDocumentItems | Clears the document items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveDocumentItem | Removes the document item.
Public method | ToString | Returns a String that represents the current Object. (Overrides ResponseManagementDocumentItem..::..ToString()()()().)

See Also

ResponseManagementCategoryDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


AddDocumentItem Method

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem..::..AddDocumentItem Method
ResponseManagementCategoryDocumentItem Class See Also Send Feedback
Adds the document item.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddDocumentItem(
    ResponseManagementDocumentItem documentItem
)
Visual Basic
Public Sub AddDocumentItem ( _
    documentItem As ResponseManagementDocumentItem _
)

Parameters

documentItem
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentItem
The document item.

Implements

IResponseManagementDocumentItemContainer..::..AddDocumentItem(ResponseManagementDocumentItem)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementCategoryDocumentItem Class
ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ClearDocumentItems Method

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem..::..ClearDocumentItems Method
ResponseManagementCategoryDocumentItem Class See Also Send Feedback
Clears the document items.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ClearDocumentItems()
Visual Basic
Public Sub ClearDocumentItems

Implements

IResponseManagementDocumentItemContainer..::..ClearDocumentItems()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementCategoryDocumentItem Class
ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


RemoveDocumentItem Method

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem..::..RemoveDocumentItem Method
ResponseManagementCategoryDocumentItem Class See Also Send Feedback
Removes the document item.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveDocumentItem(
    string id
)
Visual Basic
Public Sub RemoveDocumentItem ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Implements

IResponseManagementDocumentItemContainer..::..RemoveDocumentItem(String)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementCategoryDocumentItem Class
ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ToString Method

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem..::..ToString Method
ResponseManagementCategoryDocumentItem Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementCategoryDocumentItem Class
ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementCategoryDocumentItem Properties

[image] [image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem Properties
ResponseManagementCategoryDocumentItem Class See Also Send Feedback

The ResponseManagementCategoryDocumentItem type exposes the following members.

Properties

 | Name | Description
Public property | DocumentItems | Gets the document items.
Public property | Id | Gets or sets the ID. (Inherited from ResponseManagementDocumentItem.)
Public property | Title | Gets or sets the title. (Inherited from ResponseManagementDocumentItem.)

See Also

ResponseManagementCategoryDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


DocumentItems Property

[image]

IceLib Technical Reference
ResponseManagementCategoryDocumentItem..::..DocumentItems Property
ResponseManagementCategoryDocumentItem Class See Also Send Feedback
Gets the document items.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseManagementDocumentItem> DocumentItems { get; }
Visual Basic
Public ReadOnly Property DocumentItems As ReadOnlyCollection(Of ResponseManagementDocumentItem)
    Get

Field Value

The document items.

Implements

IResponseManagementDocumentItemContainer..::..DocumentItems

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementCategoryDocumentItem Class
ResponseManagementCategoryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocument Class

[image]

IceLib Technical Reference
ResponseManagementDocument Class
Members See Also Send Feedback
Contains information about a response management document.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManagementDocument : IResponseManagementDocumentItemContainer,
    IDeepCloneable, IEditableProvider
Visual Basic
Public Class ResponseManagementDocument _
    Implements IResponseManagementDocumentItemContainer, IDeepCloneable, IEditableProvider

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocument

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocument Members

[image] [image]

IceLib Technical Reference
ResponseManagementDocument Members
ResponseManagementDocument Class Constructors Methods Properties See Also Send Feedback

The ResponseManagementDocument type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseManagementDocument | Initializes a new instance of the ResponseManagementDocument class.

Methods

Name Description
Public method AddDocumentItem
Adds the document item.
Public method AddDocumentReference
Adds the document reference.
Public method ClearDocumentItems
Clears the document items.
Public method ClearDocumentReferences
Clears the document references.
Public method Clone
Creates a new object that is a deep copy of the current instance.
CreateNewFromXml
Creates a new ResponseManagementDocument from XML.

Remarks

New IDs will be generated for the new document, and current reference documents will be ignored.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetXmlRepresentation()()()()
Gets the XML representation.
GetXmlRepresentation(ConfigurationManager, String)
Gets the XML representation.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
ReadFromXml
Reads the ResponseManagementDocument from XML.
Public method RemoveDocumentItem
Removes the document item.
Public method RemoveDocumentReference
Removes the document reference.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | DocumentItems | Gets the document items.
Public property | DocumentReferences | Gets the document references.
Public property | HasChanged | Gets a value indicating whether this document has changed.
Public property | Id | Gets the ID.
Public property | ImportedDescription | Gets the imported description.
Public property | Title | Gets the title.

See Also

ResponseManagementDocument Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocument Constructor

[image]

IceLib Technical Reference
ResponseManagementDocument Constructor
ResponseManagementDocument Class See Also Send Feedback
Initializes a new instance of the ResponseManagementDocument class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementDocument(
    string title
)
Visual Basic
Public Sub New ( _
    title As String _
)

Parameters

title
Type: System..::..String
The title.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocument Methods

[image] [image]

IceLib Technical Reference
ResponseManagementDocument Methods
ResponseManagementDocument Class See Also Send Feedback

The ResponseManagementDocument type exposes the following members.

Methods

Name Description
Public method AddDocumentItem
Adds the document item.
Public method AddDocumentReference
Adds the document reference.
Public method ClearDocumentItems
Clears the document items.
Public method ClearDocumentReferences
Clears the document references.
Public method Clone
Creates a new object that is a deep copy of the current instance.
CreateNewFromXml
Creates a new ResponseManagementDocument from XML.

Remarks

New IDs will be generated for the new document, and current reference documents will be ignored.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetXmlRepresentation()()()()
Gets the XML representation.
GetXmlRepresentation(ConfigurationManager, String)
Gets the XML representation.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
ReadFromXml
Reads the ResponseManagementDocument from XML.
Public method RemoveDocumentItem
Removes the document item.
Public method RemoveDocumentReference
Removes the document reference.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ResponseManagementDocument Class
ININ.IceLib.Configuration.ResponseManagement Namespace


AddDocumentItem Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..AddDocumentItem Method
ResponseManagementDocument Class See Also Send Feedback
Adds the document item.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddDocumentItem(
    ResponseManagementDocumentItem documentItem
)
Visual Basic
Public Sub AddDocumentItem ( _
    documentItem As ResponseManagementDocumentItem _
)

Parameters

documentItem
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentItem
The document item.

Implements

IResponseManagementDocumentItemContainer..::..AddDocumentItem(ResponseManagementDocumentItem)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


AddDocumentReference Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..AddDocumentReference Method
ResponseManagementDocument Class See Also Send Feedback
Adds the document reference.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddDocumentReference(
    ResponseManagementDocumentReference documentReference
)
Visual Basic
Public Sub AddDocumentReference ( _
    documentReference As ResponseManagementDocumentReference _
)

Parameters

documentReference
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentReference
The document reference.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ClearDocumentItems Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..ClearDocumentItems Method
ResponseManagementDocument Class See Also Send Feedback
Clears the document items.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ClearDocumentItems()
Visual Basic
Public Sub ClearDocumentItems

Implements

IResponseManagementDocumentItemContainer..::..ClearDocumentItems()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ClearDocumentReferences Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..ClearDocumentReferences Method
ResponseManagementDocument Class See Also Send Feedback
Clears the document references.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ClearDocumentReferences()
Visual Basic
Public Sub ClearDocumentReferences

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Clone Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..Clone Method
ResponseManagementDocument Class See Also Send Feedback
Creates a new object that is a deep copy of the current instance.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


CreateNewFromXml Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..CreateNewFromXml Method
ResponseManagementDocument Class See Also Send Feedback
Creates a new ResponseManagementDocument from XML.

Remarks

New IDs will be generated for the new document, and current reference documents will be ignored.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ResponseManagementDocument CreateNewFromXml(
    string documentXml,
    string newTitle
)
Visual Basic
Public Shared Function CreateNewFromXml ( _
    documentXml As String, _
    newTitle As String _
) As ResponseManagementDocument

Parameters

documentXml
Type: System..::..String
The document XML.
newTitle
Type: System..::..String
The new title.

Return Value

A new ResponseManagementDocument object imported from the specified documentXml.

Exceptions

Exception | Condition
System..::..ArgumentNullException | documentXml is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | documentXml is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


GetXmlRepresentation Method

[image] [image]

IceLib Technical Reference
ResponseManagementDocument..::..GetXmlRepresentation Method
ResponseManagementDocument Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetXmlRepresentation()()()() | Gets the XML representation.
 | GetXmlRepresentation(ConfigurationManager, String) | Gets the XML representation.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


GetXmlRepresentation Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..GetXmlRepresentation Method
ResponseManagementDocument Class See Also Send Feedback
Gets the XML representation.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetXmlRepresentation()
Visual Basic
Public Function GetXmlRepresentation As String

Return Value

The XML representation of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
GetXmlRepresentation Overload
ININ.IceLib.Configuration.ResponseManagement Namespace


GetXmlRepresentation Method (ConfigurationManager, String)

[image]

IceLib Technical Reference
ResponseManagementDocument..::..GetXmlRepresentation Method (ConfigurationManager, String)
ResponseManagementDocument Class See Also Send Feedback
Gets the XML representation.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string GetXmlRepresentation(
    ConfigurationManager configurationManager,
    string documentId
)
Visual Basic
Public Shared Function GetXmlRepresentation ( _
    configurationManager As ConfigurationManager, _
    documentId As String _
) As String

Parameters

configurationManager
Type: ININ.IceLib.Configuration..::..ConfigurationManager
The configuration manager.
documentId
Type: System..::..String
The document ID.

Return Value

The XML representation of the specified response management document.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
GetXmlRepresentation Overload
ININ.IceLib.Configuration.ResponseManagement Namespace


ReadFromXml Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..ReadFromXml Method
ResponseManagementDocument Class See Also Send Feedback
Reads the ResponseManagementDocument from XML.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ResponseManagementDocument ReadFromXml(
    string documentXml
)
Visual Basic
Public Shared Function ReadFromXml ( _
    documentXml As String _
) As ResponseManagementDocument

Parameters

documentXml
Type: System..::..String
The document XML.

Return Value

A ResponseManagementDocument object that represents the specified documentXml, preserving its original data.

Exceptions

Exception | Condition
System..::..ArgumentNullException | documentXml is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | documentXml is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


RemoveDocumentItem Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..RemoveDocumentItem Method
ResponseManagementDocument Class See Also Send Feedback
Removes the document item.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveDocumentItem(
    string id
)
Visual Basic
Public Sub RemoveDocumentItem ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Implements

IResponseManagementDocumentItemContainer..::..RemoveDocumentItem(String)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


RemoveDocumentReference Method

[image]

IceLib Technical Reference
ResponseManagementDocument..::..RemoveDocumentReference Method
ResponseManagementDocument Class See Also Send Feedback
Removes the document reference.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveDocumentReference(
    string id
)
Visual Basic
Public Sub RemoveDocumentReference ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocument Properties

[image] [image]

IceLib Technical Reference
ResponseManagementDocument Properties
ResponseManagementDocument Class See Also Send Feedback

The ResponseManagementDocument type exposes the following members.

Properties

 | Name | Description
Public property | DocumentItems | Gets the document items.
Public property | DocumentReferences | Gets the document references.
Public property | HasChanged | Gets a value indicating whether this document has changed.
Public property | Id | Gets the ID.
Public property | ImportedDescription | Gets the imported description.
Public property | Title | Gets the title.

See Also

ResponseManagementDocument Class
ININ.IceLib.Configuration.ResponseManagement Namespace


DocumentItems Property

[image]

IceLib Technical Reference
ResponseManagementDocument..::..DocumentItems Property
ResponseManagementDocument Class See Also Send Feedback
Gets the document items.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseManagementDocumentItem> DocumentItems { get; }
Visual Basic
Public ReadOnly Property DocumentItems As ReadOnlyCollection(Of ResponseManagementDocumentItem)
    Get

Field Value

The document items.

Implements

IResponseManagementDocumentItemContainer..::..DocumentItems

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


DocumentReferences Property

[image]

IceLib Technical Reference
ResponseManagementDocument..::..DocumentReferences Property
ResponseManagementDocument Class See Also Send Feedback
Gets the document references.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseManagementDocumentReference> DocumentReferences { get; }
Visual Basic
Public ReadOnly Property DocumentReferences As ReadOnlyCollection(Of ResponseManagementDocumentReference)
    Get

Field Value

The document references.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


HasChanged Property

[image]

IceLib Technical Reference
ResponseManagementDocument..::..HasChanged Property
ResponseManagementDocument Class See Also Send Feedback
Gets a value indicating whether this document has changed.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasChanged { get; }
Visual Basic
Public ReadOnly Property HasChanged As Boolean
    Get

Field Value

true if this document has changed; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Id Property

[image]

IceLib Technical Reference
ResponseManagementDocument..::..Id Property
ResponseManagementDocument Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ImportedDescription Property

[image]

IceLib Technical Reference
ResponseManagementDocument..::..ImportedDescription Property
ResponseManagementDocument Class See Also Send Feedback
Gets the imported description.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ImportedDescription { get; private set; }
Visual Basic
Public Property ImportedDescription As String
    Get
    Private Set

Field Value

The imported description.

Remarks

This value is only available for Response Management Documents that have been exported. When importing documents, this value should be used to populate the Description property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Title Property

[image]

IceLib Technical Reference
ResponseManagementDocument..::..Title Property
ResponseManagementDocument Class See Also Send Feedback
Gets the title.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Title { get; private set; }
Visual Basic
Public Property Title As String
    Get
    Private Set

Field Value

The title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocument Class
ResponseManagementDocument Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentItem Class

[image]

IceLib Technical Reference
ResponseManagementDocumentItem Class
Members See Also Send Feedback
Contains base information about a response management document item that is contained within a ResponseManagementDocument.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ResponseManagementDocumentItem
Visual Basic
Public MustInherit Class ResponseManagementDocumentItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentItem
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementCategoryDocumentItem
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementEntryDocumentItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentItem Members

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentItem Members
ResponseManagementDocumentItem Class Constructors Methods Properties See Also Send Feedback

The ResponseManagementDocumentItem type exposes the following members.

Constructors

 | Name | Description
Protected method | ResponseManagementDocumentItem | Initializes a new instance of the ResponseManagementDocumentItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets or sets the ID.
Public property | Title | Gets or sets the title.

See Also

ResponseManagementDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentItem Constructor

[image]

IceLib Technical Reference
ResponseManagementDocumentItem Constructor
ResponseManagementDocumentItem Class See Also Send Feedback
Initializes a new instance of the ResponseManagementDocumentItem class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ResponseManagementDocumentItem(
    string title
)
Visual Basic
Protected Sub New ( _
    title As String _
)

Parameters

title
Type: System..::..String
The title.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentItem Class
ResponseManagementDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentItem Methods

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentItem Methods
ResponseManagementDocumentItem Class See Also Send Feedback

The ResponseManagementDocumentItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ResponseManagementDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ToString Method

[image]

IceLib Technical Reference
ResponseManagementDocumentItem..::..ToString Method
ResponseManagementDocumentItem Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementDocumentItem Class
ResponseManagementDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentItem Properties

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentItem Properties
ResponseManagementDocumentItem Class See Also Send Feedback

The ResponseManagementDocumentItem type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the ID.
Public property | Title | Gets or sets the title.

See Also

ResponseManagementDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


Id Property

[image]

IceLib Technical Reference
ResponseManagementDocumentItem..::..Id Property
ResponseManagementDocumentItem Class See Also Send Feedback
Gets or sets the ID.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentItem Class
ResponseManagementDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Title Property

[image]

IceLib Technical Reference
ResponseManagementDocumentItem..::..Title Property
ResponseManagementDocumentItem Class See Also Send Feedback
Gets or sets the title.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Title { get; private set; }
Visual Basic
Public Property Title As String
    Get
    Private Set

Field Value

The title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentItem Class
ResponseManagementDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentReference Class

[image]

IceLib Technical Reference
ResponseManagementDocumentReference Class
Members See Also Send Feedback
Contains information about a response management document reference item that is contained within a ResponseManagementDocument.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManagementDocumentReference
Visual Basic
Public Class ResponseManagementDocumentReference

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentReference

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentReference Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentReference Members

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentReference Members
ResponseManagementDocumentReference Class Constructors Methods Properties See Also Send Feedback

The ResponseManagementDocumentReference type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseManagementDocumentReference | Initializes a new instance of the ResponseManagementDocumentReference class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets or sets the ID.
Public property | Title | Gets or sets the title.

See Also

ResponseManagementDocumentReference Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentReference Constructor

[image]

IceLib Technical Reference
ResponseManagementDocumentReference Constructor
ResponseManagementDocumentReference Class See Also Send Feedback
Initializes a new instance of the ResponseManagementDocumentReference class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementDocumentReference(
    string title
)
Visual Basic
Public Sub New ( _
    title As String _
)

Parameters

title
Type: System..::..String
The title.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentReference Class
ResponseManagementDocumentReference Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentReference Methods

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentReference Methods
ResponseManagementDocumentReference Class See Also Send Feedback

The ResponseManagementDocumentReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ResponseManagementDocumentReference Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ToString Method

[image]

IceLib Technical Reference
ResponseManagementDocumentReference..::..ToString Method
ResponseManagementDocumentReference Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementDocumentReference Class
ResponseManagementDocumentReference Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementDocumentReference Properties

[image] [image]

IceLib Technical Reference
ResponseManagementDocumentReference Properties
ResponseManagementDocumentReference Class See Also Send Feedback

The ResponseManagementDocumentReference type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the ID.
Public property | Title | Gets or sets the title.

See Also

ResponseManagementDocumentReference Class
ININ.IceLib.Configuration.ResponseManagement Namespace


Id Property

[image]

IceLib Technical Reference
ResponseManagementDocumentReference..::..Id Property
ResponseManagementDocumentReference Class See Also Send Feedback
Gets or sets the ID.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentReference Class
ResponseManagementDocumentReference Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Title Property

[image]

IceLib Technical Reference
ResponseManagementDocumentReference..::..Title Property
ResponseManagementDocumentReference Class See Also Send Feedback
Gets or sets the title.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Title { get; private set; }
Visual Basic
Public Property Title As String
    Get
    Private Set

Field Value

The title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementDocumentReference Class
ResponseManagementDocumentReference Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Class

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Class
Members See Also Send Feedback
Contains information about a response management entry document item that is contained within a ResponseManagementDocument.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManagementEntryDocumentItem : ResponseManagementDocumentItem
Visual Basic
Public Class ResponseManagementEntryDocumentItem _
    Inherits ResponseManagementDocumentItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementDocumentItem
ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementEntryDocumentItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Members

[image] [image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Members
ResponseManagementEntryDocumentItem Class Constructors Methods Properties See Also Send Feedback

The ResponseManagementEntryDocumentItem type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseManagementEntryDocumentItem(ResponseManagementEntryDocumentItemType, String) | Initializes a new instance of the ResponseManagementEntryDocumentItem class.
Public method | ResponseManagementEntryDocumentItem(ResponseManagementEntryDocumentItemType, String, String) | Initializes a new instance of the ResponseManagementEntryDocumentItem class.
Public method | ResponseManagementEntryDocumentItem(ResponseManagementEntryDocumentItemType, String, String, String) | Initializes a new instance of the ResponseManagementEntryDocumentItem class.

Methods

 | Name | Description
Public method | AddKeyword | Adds the keyword.
Public method | ClearKeywords | Clears the keywords.
 | ConvertEntryTypeFromXmlValue | Converts the entry type from its XML value.
 | ConvertEntryTypeToXmlValue | Converts the entry type to its XML value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveKeyword | Removes the keyword.
Public method | ToString | Returns a String that represents the current Object. (Overrides ResponseManagementDocumentItem..::..ToString()()()().)

Properties

 | Name | Description
Public property | EntryType | Gets or sets the type of the entry.
Public property | Id | Gets or sets the ID. (Inherited from ResponseManagementDocumentItem.)
Public property | Keywords | Gets the keywords.
Public property | PlainTextValue | Gets the plain text value.
Public property | Shortcut | Gets or sets the shortcut.
Public property | Title | Gets or sets the title. (Inherited from ResponseManagementDocumentItem.)
Public property | Value | Gets or sets the value.

See Also

ResponseManagementEntryDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Constructor

[image] [image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Constructor
ResponseManagementEntryDocumentItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResponseManagementEntryDocumentItem(ResponseManagementEntryDocumentItemType, String) | Initializes a new instance of the ResponseManagementEntryDocumentItem class.
Public method | ResponseManagementEntryDocumentItem(ResponseManagementEntryDocumentItemType, String, String) | Initializes a new instance of the ResponseManagementEntryDocumentItem class.
Public method | ResponseManagementEntryDocumentItem(ResponseManagementEntryDocumentItemType, String, String, String) | Initializes a new instance of the ResponseManagementEntryDocumentItem class.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Constructor (ResponseManagementEntryDocumentItemType, String)

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Constructor (ResponseManagementEntryDocumentItemType, String)
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Initializes a new instance of the ResponseManagementEntryDocumentItem class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementEntryDocumentItem(
    ResponseManagementEntryDocumentItemType entryType,
    string title
)
Visual Basic
Public Sub New ( _
    entryType As ResponseManagementEntryDocumentItemType, _
    title As String _
)

Parameters

entryType
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementEntryDocumentItemType
Type of the entry.
title
Type: System..::..String
The title.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | entryType is not one of the ResponseManagementEntryDocumentItemType values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ResponseManagementEntryDocumentItem Overload
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Constructor (ResponseManagementEntryDocumentItemType, String, String)

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Constructor (ResponseManagementEntryDocumentItemType, String, String)
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Initializes a new instance of the ResponseManagementEntryDocumentItem class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementEntryDocumentItem(
    ResponseManagementEntryDocumentItemType entryType,
    string title,
    string value
)
Visual Basic
Public Sub New ( _
    entryType As ResponseManagementEntryDocumentItemType, _
    title As String, _
    value As String _
)

Parameters

entryType
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementEntryDocumentItemType
Type of the entry.
title
Type: System..::..String
The title.
value
Type: System..::..String
The value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | value is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | entryType is not one of the ResponseManagementEntryDocumentItemType values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ResponseManagementEntryDocumentItem Overload
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Constructor (ResponseManagementEntryDocumentItemType, String, String, String)

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Constructor (ResponseManagementEntryDocumentItemType, String, String, String)
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Initializes a new instance of the ResponseManagementEntryDocumentItem class.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementEntryDocumentItem(
    ResponseManagementEntryDocumentItemType entryType,
    string title,
    string value,
    string shortcut
)
Visual Basic
Public Sub New ( _
    entryType As ResponseManagementEntryDocumentItemType, _
    title As String, _
    value As String, _
    shortcut As String _
)

Parameters

entryType
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementEntryDocumentItemType
Type of the entry.
title
Type: System..::..String
The title.
value
Type: System..::..String
The value.
shortcut
Type: System..::..String
The shortcut.

Exceptions

Exception | Condition
System..::..ArgumentNullException | value or shortcut is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | entryType is not one of the ResponseManagementEntryDocumentItemType values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ResponseManagementEntryDocumentItem Overload
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Methods

[image] [image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Methods
ResponseManagementEntryDocumentItem Class See Also Send Feedback

The ResponseManagementEntryDocumentItem type exposes the following members.

Methods

 | Name | Description
Public method | AddKeyword | Adds the keyword.
Public method | ClearKeywords | Clears the keywords.
 | ConvertEntryTypeFromXmlValue | Converts the entry type from its XML value.
 | ConvertEntryTypeToXmlValue | Converts the entry type to its XML value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveKeyword | Removes the keyword.
Public method | ToString | Returns a String that represents the current Object. (Overrides ResponseManagementDocumentItem..::..ToString()()()().)

See Also

ResponseManagementEntryDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


AddKeyword Method

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..AddKeyword Method
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Adds the keyword.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddKeyword(
    string keyword
)
Visual Basic
Public Sub AddKeyword ( _
    keyword As String _
)

Parameters

keyword
Type: System..::..String
The keyword.

Exceptions

Exception | Condition
System..::..ArgumentNullException | keyword is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ClearKeywords Method

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..ClearKeywords Method
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Clears the keywords.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ClearKeywords()
Visual Basic
Public Sub ClearKeywords

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ConvertEntryTypeFromXmlValue Method

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..ConvertEntryTypeFromXmlValue Method
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Converts the entry type from its XML value.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ResponseManagementEntryDocumentItemType ConvertEntryTypeFromXmlValue(
    string value
)
Visual Basic
Public Shared Function ConvertEntryTypeFromXmlValue ( _
    value As String _
) As ResponseManagementEntryDocumentItemType

Parameters

value
Type: System..::..String
The value.

Return Value

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ConvertEntryTypeToXmlValue Method

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..ConvertEntryTypeToXmlValue Method
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Converts the entry type to its XML value.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ConvertEntryTypeToXmlValue(
    ResponseManagementEntryDocumentItemType documentItemType
)
Visual Basic
Public Shared Function ConvertEntryTypeToXmlValue ( _
    documentItemType As ResponseManagementEntryDocumentItemType _
) As String

Parameters

documentItemType
Type: ININ.IceLib.Configuration.ResponseManagement..::..ResponseManagementEntryDocumentItemType
Type of the document item.

Return Value

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


RemoveKeyword Method

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..RemoveKeyword Method
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Removes the keyword.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveKeyword(
    string keyword
)
Visual Basic
Public Sub RemoveKeyword ( _
    keyword As String _
)

Parameters

keyword
Type: System..::..String
The keyword.

Exceptions

Exception | Condition
System..::..ArgumentNullException | keyword is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ToString Method

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..ToString Method
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItem Properties

[image] [image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem Properties
ResponseManagementEntryDocumentItem Class See Also Send Feedback

The ResponseManagementEntryDocumentItem type exposes the following members.

Properties

 | Name | Description
Public property | EntryType | Gets or sets the type of the entry.
Public property | Id | Gets or sets the ID. (Inherited from ResponseManagementDocumentItem.)
Public property | Keywords | Gets the keywords.
Public property | PlainTextValue | Gets the plain text value.
Public property | Shortcut | Gets or sets the shortcut.
Public property | Title | Gets or sets the title. (Inherited from ResponseManagementDocumentItem.)
Public property | Value | Gets or sets the value.

See Also

ResponseManagementEntryDocumentItem Class
ININ.IceLib.Configuration.ResponseManagement Namespace


EntryType Property

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..EntryType Property
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Gets or sets the type of the entry.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManagementEntryDocumentItemType EntryType { get; private set; }
Visual Basic
Public Property EntryType As ResponseManagementEntryDocumentItemType
    Get
    Private Set

Field Value

The type of the entry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Keywords Property

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..Keywords Property
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Gets the keywords.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Keywords { get; }
Visual Basic
Public ReadOnly Property Keywords As ReadOnlyCollection(Of String)
    Get

Field Value

The keywords.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


PlainTextValue Property

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..PlainTextValue Property
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Gets the plain text value.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PlainTextValue { get; }
Visual Basic
Public ReadOnly Property PlainTextValue As String
    Get

Field Value

The plain text value.

Remarks

PlainTextValue returns the text representation of Value when EntryType is Text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Shortcut Property

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..Shortcut Property
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Gets or sets the shortcut.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Shortcut { get; set; }
Visual Basic
Public Property Shortcut As String
    Get
    Set

Field Value

The shortcut.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


Value Property

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItem..::..Value Property
ResponseManagementEntryDocumentItem Class See Also Send Feedback
Gets or sets the value.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value.

Remarks

The value can contain Html fragments or full Html when EntryType is Text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseManagementEntryDocumentItem Class
ResponseManagementEntryDocumentItem Members
ININ.IceLib.Configuration.ResponseManagement Namespace


ResponseManagementEntryDocumentItemType Enumeration

[image]

IceLib Technical Reference
ResponseManagementEntryDocumentItemType Enumeration
See Also Send Feedback
Represents the possible response management entry document item types from a ResponseManagementEntryDocumentItem.

Namespace: ININ.IceLib.Configuration.ResponseManagement
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ResponseManagementEntryDocumentItemType
Visual Basic
Public Enumeration ResponseManagementEntryDocumentItemType

Members

Member name | Value | Description
None | 0 | Represents no document item type.
File | 1 | Represents a file document item type.
Text | 2 | Represents a text document item type.
Url | 3 | Represents a URL document item type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ININ.IceLib.Configuration.ResponseManagement Namespace


ININ.IceLib.Configuration.Validators Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Configuration.Validators Namespace
Send Feedback

The ININ.IceLib.Configuration.Validators namespace contains classes that provide support to the classes in the ININ.IceLib.Configuration namespace. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

Classes

 | Class | Description
Public class | AcgTreeValidator | Represents ACG Tree validator.
Public class | AnalyzerKeywordCountValueValidator | Represents Analyzer keyword count values validator. This validator verifies that the number of keywords does not exceed the maximum number of keywords.
Public class | AnalyzerPronunciationValueValidator | Represents Analyzer pronunciation values validator. This validator validates that a given pronunciation is valid.
Public class | AnalyzerWordValueValidator | Represents Analyzer keyword values validator. This validator validates that a given analyzer word is a valid word.
Public class | AttendantProfileValidator | Represents Attendant Profile validator. This validator validates that a given attendant profile must exist.
Public class | CharacterDelimitedValueValidator | Represents character delimited value validator. This validator validates that a given character delimited value matches the number of expected elements and each of the values in it is valid.
Public class | CollectionCountValidator | Represents a configuration value collection count validator. This validator validates that a given collection contains the appropriate number of items.
Public class | CollectionItemValidator | Represents a configuration value collection item validator. This validator validates each collection item with its appropriate validator.
Public class | ExistingAttributeValueValidator | Represents a configuration value existing attribute value validator. This validator validates that a given attribute must exist.
Public class | ExistingExtensionValidator | Represents and existing extension validator. This validator validates that a given extension must exist within either a User, Workgroup, Station or StationGroup.
Public class | ExistingInstanceIdValidator | Represents a configuration value existing instance ID validator. This validator validates that a given instance ID must exist.
Public class | ExistingInstanceIdWithAttributeValueValidator | Represents an existing instance ID with attribute value validator. This validator validates that a given instance ID exists and has an attribute with specific values.
Public class | ExistingLanguageValuesValidator | Represents an existing language code validation object. This object validates that a given language code must exist.
Public class | ExtensionValidator | Represents an Extension validator. This validator validates that a given extension does not already exist.
Public class | InvalidCharacterValidator | Represents Invalid Character validator. This validator validates that a given value does not contain invalid characters.
Public class | InvalidMailboxFolderValidator | Represents the invalid mailbox folder validator. This validator indicates that a the specified mailbox folder is not valid.
Public class | MultipleOfValidator | Represents Multiple Of validator. This validator validates that a given value can be equally divided by the provided MultipleOf value.
Public class | MutuallyExclusiveValueValidator | Represents a configuration mutually exclusive value validator. This validator validates that a given attribute cannot be set if other conflicting attributes are also set.
Public class | PropertyNotApplicableValidator | Represents property not applicable validator. This validator indicates that a property is applicable with the current configuration.
Public class | RangeFloatValidator | Represents a configuration value range float validator. This validator validates that a given float value falls within a specific range.
Public class | RangeValidator | Represents a configuration value range validator. This validator validates that a given value falls within a specified range.
Public class | RecorderPolicyAnalyzerKeywordCountValueValidator | Represents Analyzer keyword count values validator for Recorder Policies. This validator verifies that the number of keywords assigned to a Recorder Policy does not exceed the maximum number of keywords.
Public class | ReferenceCountValidator | Represents a reference count validator. This validator validates that a given attribute value is only referenced the appropriate number of times.
Public class | RegularExpressionValidator | Represents a configuration value regular expression validator. This validator validates that a given value matches a specified regular expression.
Public class | RequiredAttributeValidator | Represents a configuration attribute required value validator. This validator validates that an attribute must be specified.
Public class | RequiredValueValidator | Represents a configuration value required value validator. This validator validates that a value must be specified.
Public class | ScheduleEndDateTimeValidator | Represents the schedule end date/time validator. This validator validates that a given end date or end time is less than the start date if it is specified.
Public class | StringLengthValidator | Represents a configuration value string length validator. This validator validates that a given string must be within a specific length.
Public class | UniqueAttributeValueValidator | Represents a configuration value unique instance ID validator. This validator validates that a given attribute value is unique across all attributes of the same type.
Public class | UniqueInstanceIdValidator | Represents a configuration value unique instance ID validator. This validator validates that a given value must be unique across all objects of the same type.
Public class | ValidationGroupValidator | Represents a group of validators.
Public class | Validator | Represents a configuration value validator.
Public class | ValidFormatValidator | Represents a configuration value format validator. This validator validates that a given value is in a valid format.
Public class | ValidValuesValidator | Represents a configuration value valid values validator. This validator validates that a given value falls within its valid values.
Public class | WorkgroupAnalyzerKeywordCountValueValidator | Represents workgroup Analyzer keyword count values validator. This validator verifies that the number of keywords assigned to a workgroup does not exceed the maximum number of keywords.

Enumerations

 | Enumeration | Description
Public enumeration | ValidationGroupValidator..::..ValidationLogicalOperator | Specifies what type of logical operator this ValidationGroup will use to combine its child validators.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.


AcgTreeValidator Class

[image]

IceLib Technical Reference
AcgTreeValidator Class
Members See Also Send Feedback
Represents ACG Tree validator.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AcgTreeValidator : Validator
Visual Basic
Public Class AcgTreeValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..AcgTreeValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AcgTreeValidator Members
ININ.IceLib.Configuration.Validators Namespace


AcgTreeValidator Members

[image] [image]

IceLib Technical Reference
AcgTreeValidator Members
AcgTreeValidator Class Constructors Methods Properties See Also Send Feedback

The AcgTreeValidator type exposes the following members.

Constructors

 | Name | Description
Public method | AcgTreeValidator | Initializes a new instance of the AcgTreeValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AcgTreeValidator Class
ININ.IceLib.Configuration.Validators Namespace


AcgTreeValidator Constructor

[image]

IceLib Technical Reference
AcgTreeValidator Constructor
AcgTreeValidator Class See Also Send Feedback
Initializes a new instance of the AcgTreeValidator class.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AcgTreeValidator(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

AcgTreeValidator Class
AcgTreeValidator Members
ININ.IceLib.Configuration.Validators Namespace


AcgTreeValidator Methods

[image] [image]

IceLib Technical Reference
AcgTreeValidator Methods
AcgTreeValidator Class See Also Send Feedback

The AcgTreeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AcgTreeValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
AcgTreeValidator..::..ToString Method
AcgTreeValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AcgTreeValidator Class
AcgTreeValidator Members
ININ.IceLib.Configuration.Validators Namespace


AcgTreeValidator Properties

[image] [image]

IceLib Technical Reference
AcgTreeValidator Properties
AcgTreeValidator Class See Also Send Feedback

The AcgTreeValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AcgTreeValidator Class
ININ.IceLib.Configuration.Validators Namespace


AnalyzerKeywordCountValueValidator Class

[image]

IceLib Technical Reference
AnalyzerKeywordCountValueValidator Class
Members See Also Send Feedback
Represents Analyzer keyword count values validator. This validator verifies that the number of keywords does not exceed the maximum number of keywords.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerKeywordCountValueValidator : Validator
Visual Basic
Public Class AnalyzerKeywordCountValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..AnalyzerKeywordCountValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AnalyzerKeywordCountValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


AnalyzerKeywordCountValueValidator Members

[image] [image]

IceLib Technical Reference
AnalyzerKeywordCountValueValidator Members
AnalyzerKeywordCountValueValidator Class Methods Properties See Also Send Feedback

The AnalyzerKeywordCountValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


AnalyzerKeywordCountValueValidator Methods

[image] [image]

IceLib Technical Reference
AnalyzerKeywordCountValueValidator Methods
AnalyzerKeywordCountValueValidator Class See Also Send Feedback

The AnalyzerKeywordCountValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
AnalyzerKeywordCountValueValidator..::..ToString Method
AnalyzerKeywordCountValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerKeywordCountValueValidator Class
AnalyzerKeywordCountValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


AnalyzerKeywordCountValueValidator Properties

[image] [image]

IceLib Technical Reference
AnalyzerKeywordCountValueValidator Properties
AnalyzerKeywordCountValueValidator Class See Also Send Feedback

The AnalyzerKeywordCountValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


AnalyzerPronunciationValueValidator Class

[image]

IceLib Technical Reference
AnalyzerPronunciationValueValidator Class
Members See Also Send Feedback
Represents Analyzer pronunciation values validator. This validator validates that a given pronunciation is valid.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerPronunciationValueValidator : Validator
Visual Basic
Public Class AnalyzerPronunciationValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..AnalyzerPronunciationValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerPronunciationValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


AnalyzerPronunciationValueValidator Members

[image] [image]

IceLib Technical Reference
AnalyzerPronunciationValueValidator Members
AnalyzerPronunciationValueValidator Class Methods Properties See Also Send Feedback

The AnalyzerPronunciationValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AnalyzerPronunciationValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


AnalyzerPronunciationValueValidator Methods

[image] [image]

IceLib Technical Reference
AnalyzerPronunciationValueValidator Methods
AnalyzerPronunciationValueValidator Class See Also Send Feedback

The AnalyzerPronunciationValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AnalyzerPronunciationValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
AnalyzerPronunciationValueValidator..::..ToString Method
AnalyzerPronunciationValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerPronunciationValueValidator Class
AnalyzerPronunciationValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


AnalyzerPronunciationValueValidator Properties

[image] [image]

IceLib Technical Reference
AnalyzerPronunciationValueValidator Properties
AnalyzerPronunciationValueValidator Class See Also Send Feedback

The AnalyzerPronunciationValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AnalyzerPronunciationValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


AnalyzerWordValueValidator Class

[image]

IceLib Technical Reference
AnalyzerWordValueValidator Class
Members See Also Send Feedback
Represents Analyzer keyword values validator. This validator validates that a given analyzer word is a valid word.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnalyzerWordValueValidator : Validator
Visual Basic
Public Class AnalyzerWordValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..AnalyzerWordValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AnalyzerWordValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


AnalyzerWordValueValidator Members

[image] [image]

IceLib Technical Reference
AnalyzerWordValueValidator Members
AnalyzerWordValueValidator Class Methods Properties See Also Send Feedback

The AnalyzerWordValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AnalyzerWordValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


AnalyzerWordValueValidator Methods

[image] [image]

IceLib Technical Reference
AnalyzerWordValueValidator Methods
AnalyzerWordValueValidator Class See Also Send Feedback

The AnalyzerWordValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AnalyzerWordValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
AnalyzerWordValueValidator..::..ToString Method
AnalyzerWordValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnalyzerWordValueValidator Class
AnalyzerWordValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


AnalyzerWordValueValidator Properties

[image] [image]

IceLib Technical Reference
AnalyzerWordValueValidator Properties
AnalyzerWordValueValidator Class See Also Send Feedback

The AnalyzerWordValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AnalyzerWordValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


AttendantProfileValidator Class

[image]

IceLib Technical Reference
AttendantProfileValidator Class
Members See Also Send Feedback
Represents Attendant Profile validator. This validator validates that a given attendant profile must exist.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttendantProfileValidator : Validator
Visual Basic
Public Class AttendantProfileValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..AttendantProfileValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantProfileValidator Members
ININ.IceLib.Configuration.Validators Namespace


AttendantProfileValidator Members

[image] [image]

IceLib Technical Reference
AttendantProfileValidator Members
AttendantProfileValidator Class Constructors Methods Properties See Also Send Feedback

The AttendantProfileValidator type exposes the following members.

Constructors

 | Name | Description
Public method | AttendantProfileValidator | Initializes a new instance of the AttendantProfileValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AttendantProfileValidator Class
ININ.IceLib.Configuration.Validators Namespace


AttendantProfileValidator Constructor

[image]

IceLib Technical Reference
AttendantProfileValidator Constructor
AttendantProfileValidator Class See Also Send Feedback
Initializes a new instance of the AttendantProfileValidator class.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttendantProfileValidator(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AttendantProfileValidator Class
AttendantProfileValidator Members
ININ.IceLib.Configuration.Validators Namespace


AttendantProfileValidator Methods

[image] [image]

IceLib Technical Reference
AttendantProfileValidator Methods
AttendantProfileValidator Class See Also Send Feedback

The AttendantProfileValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AttendantProfileValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
AttendantProfileValidator..::..ToString Method
AttendantProfileValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttendantProfileValidator Class
AttendantProfileValidator Members
ININ.IceLib.Configuration.Validators Namespace


AttendantProfileValidator Properties

[image] [image]

IceLib Technical Reference
AttendantProfileValidator Properties
AttendantProfileValidator Class See Also Send Feedback

The AttendantProfileValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

AttendantProfileValidator Class
ININ.IceLib.Configuration.Validators Namespace


CharacterDelimitedValueValidator Class

[image]

IceLib Technical Reference
CharacterDelimitedValueValidator Class
Members See Also Send Feedback
Represents character delimited value validator. This validator validates that a given character delimited value matches the number of expected elements and each of the values in it is valid.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CharacterDelimitedValueValidator : Validator
Visual Basic
Public Class CharacterDelimitedValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..CharacterDelimitedValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CharacterDelimitedValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


CharacterDelimitedValueValidator Members

[image] [image]

IceLib Technical Reference
CharacterDelimitedValueValidator Members
CharacterDelimitedValueValidator Class Methods Properties See Also Send Feedback

The CharacterDelimitedValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

CharacterDelimitedValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


CharacterDelimitedValueValidator Methods

[image] [image]

IceLib Technical Reference
CharacterDelimitedValueValidator Methods
CharacterDelimitedValueValidator Class See Also Send Feedback

The CharacterDelimitedValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

CharacterDelimitedValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
CharacterDelimitedValueValidator..::..ToString Method
CharacterDelimitedValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CharacterDelimitedValueValidator Class
CharacterDelimitedValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


CharacterDelimitedValueValidator Properties

[image] [image]

IceLib Technical Reference
CharacterDelimitedValueValidator Properties
CharacterDelimitedValueValidator Class See Also Send Feedback

The CharacterDelimitedValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

CharacterDelimitedValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


CollectionCountValidator Class

[image]

IceLib Technical Reference
CollectionCountValidator Class
Members See Also Send Feedback
Represents a configuration value collection count validator. This validator validates that a given collection contains the appropriate number of items.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CollectionCountValidator : Validator
Visual Basic
Public Class CollectionCountValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..CollectionCountValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

CollectionCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


CollectionCountValidator Members

[image] [image]

IceLib Technical Reference
CollectionCountValidator Members
CollectionCountValidator Class Methods Properties See Also Send Feedback

The CollectionCountValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

CollectionCountValidator Class
ININ.IceLib.Configuration.Validators Namespace


CollectionCountValidator Methods

[image] [image]

IceLib Technical Reference
CollectionCountValidator Methods
CollectionCountValidator Class See Also Send Feedback

The CollectionCountValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

CollectionCountValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
CollectionCountValidator..::..ToString Method
CollectionCountValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CollectionCountValidator Class
CollectionCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


CollectionCountValidator Properties

[image] [image]

IceLib Technical Reference
CollectionCountValidator Properties
CollectionCountValidator Class See Also Send Feedback

The CollectionCountValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

CollectionCountValidator Class
ININ.IceLib.Configuration.Validators Namespace


MaximumValue Property

[image]

IceLib Technical Reference
CollectionCountValidator..::..MaximumValue Property
CollectionCountValidator Class See Also Send Feedback
Gets the maximum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MaximumValue { get; }
Visual Basic
Public ReadOnly Property MaximumValue As Nullable(Of Integer)
    Get

Field Value

The maximum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

CollectionCountValidator Class
CollectionCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


MinimumValue Property

[image]

IceLib Technical Reference
CollectionCountValidator..::..MinimumValue Property
CollectionCountValidator Class See Also Send Feedback
Gets the minimum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MinimumValue { get; }
Visual Basic
Public ReadOnly Property MinimumValue As Nullable(Of Integer)
    Get

Field Value

The minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

CollectionCountValidator Class
CollectionCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


CollectionItemValidator Class

[image]

IceLib Technical Reference
CollectionItemValidator Class
Members See Also Send Feedback
Represents a configuration value collection item validator. This validator validates each collection item with its appropriate validator.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CollectionItemValidator : Validator
Visual Basic
Public Class CollectionItemValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..CollectionItemValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

CollectionItemValidator Members
ININ.IceLib.Configuration.Validators Namespace


CollectionItemValidator Members

[image] [image]

IceLib Technical Reference
CollectionItemValidator Members
CollectionItemValidator Class Methods Properties See Also Send Feedback

The CollectionItemValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | ItemValidators | Gets the item validators.

See Also

CollectionItemValidator Class
ININ.IceLib.Configuration.Validators Namespace


CollectionItemValidator Methods

[image] [image]

IceLib Technical Reference
CollectionItemValidator Methods
CollectionItemValidator Class See Also Send Feedback

The CollectionItemValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

CollectionItemValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
CollectionItemValidator..::..ToString Method
CollectionItemValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CollectionItemValidator Class
CollectionItemValidator Members
ININ.IceLib.Configuration.Validators Namespace


CollectionItemValidator Properties

[image] [image]

IceLib Technical Reference
CollectionItemValidator Properties
CollectionItemValidator Class See Also Send Feedback

The CollectionItemValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | ItemValidators | Gets the item validators.

See Also

CollectionItemValidator Class
ININ.IceLib.Configuration.Validators Namespace


ItemValidators Property

[image]

IceLib Technical Reference
CollectionItemValidator..::..ItemValidators Property
CollectionItemValidator Class See Also Send Feedback
Gets the item validators.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Validator> ItemValidators { get; }
Visual Basic
Public ReadOnly Property ItemValidators As ReadOnlyCollection(Of Validator)
    Get

Field Value

The item validators.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

CollectionItemValidator Class
CollectionItemValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingAttributeValueValidator Class

[image]

IceLib Technical Reference
ExistingAttributeValueValidator Class
Members See Also Send Feedback
Represents a configuration value existing attribute value validator. This validator validates that a given attribute must exist.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExistingAttributeValueValidator : Validator
Visual Basic
Public Class ExistingAttributeValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ExistingAttributeValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ExistingAttributeValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingAttributeValueValidator Members

[image] [image]

IceLib Technical Reference
ExistingAttributeValueValidator Members
ExistingAttributeValueValidator Class Methods Properties See Also Send Feedback

The ExistingAttributeValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingAttributeValueValidator Methods

[image] [image]

IceLib Technical Reference
ExistingAttributeValueValidator Methods
ExistingAttributeValueValidator Class See Also Send Feedback

The ExistingAttributeValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ExistingAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ExistingAttributeValueValidator..::..ToString Method
ExistingAttributeValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExistingAttributeValueValidator Class
ExistingAttributeValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingAttributeValueValidator Properties

[image] [image]

IceLib Technical Reference
ExistingAttributeValueValidator Properties
ExistingAttributeValueValidator Class See Also Send Feedback

The ExistingAttributeValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingExtensionValidator Class

[image]

IceLib Technical Reference
ExistingExtensionValidator Class
Members See Also Send Feedback
Represents and existing extension validator. This validator validates that a given extension must exist within either a User, Workgroup, Station or StationGroup.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExistingExtensionValidator : Validator
Visual Basic
Public Class ExistingExtensionValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ExistingExtensionValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ExistingExtensionValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingExtensionValidator Members

[image] [image]

IceLib Technical Reference
ExistingExtensionValidator Members
ExistingExtensionValidator Class Constructors Methods Properties See Also Send Feedback

The ExistingExtensionValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ExistingExtensionValidator | Initializes a new instance of the ExistingExtensionValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingExtensionValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingExtensionValidator Constructor

[image]

IceLib Technical Reference
ExistingExtensionValidator Constructor
ExistingExtensionValidator Class See Also Send Feedback
Initializes a new instance of the ExistingExtensionValidator class.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExistingExtensionValidator(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ExistingExtensionValidator Class
ExistingExtensionValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingExtensionValidator Methods

[image] [image]

IceLib Technical Reference
ExistingExtensionValidator Methods
ExistingExtensionValidator Class See Also Send Feedback

The ExistingExtensionValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ExistingExtensionValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ExistingExtensionValidator..::..ToString Method
ExistingExtensionValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExistingExtensionValidator Class
ExistingExtensionValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingExtensionValidator Properties

[image] [image]

IceLib Technical Reference
ExistingExtensionValidator Properties
ExistingExtensionValidator Class See Also Send Feedback

The ExistingExtensionValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingExtensionValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdValidator Class

[image]

IceLib Technical Reference
ExistingInstanceIdValidator Class
Members See Also Send Feedback
Represents a configuration value existing instance ID validator. This validator validates that a given instance ID must exist.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExistingInstanceIdValidator : Validator
Visual Basic
Public Class ExistingInstanceIdValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ExistingInstanceIdValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ExistingInstanceIdValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdValidator Members

[image] [image]

IceLib Technical Reference
ExistingInstanceIdValidator Members
ExistingInstanceIdValidator Class Methods Properties See Also Send Feedback

The ExistingInstanceIdValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingInstanceIdValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdValidator Methods

[image] [image]

IceLib Technical Reference
ExistingInstanceIdValidator Methods
ExistingInstanceIdValidator Class See Also Send Feedback

The ExistingInstanceIdValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ExistingInstanceIdValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ExistingInstanceIdValidator..::..ToString Method
ExistingInstanceIdValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExistingInstanceIdValidator Class
ExistingInstanceIdValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdValidator Properties

[image] [image]

IceLib Technical Reference
ExistingInstanceIdValidator Properties
ExistingInstanceIdValidator Class See Also Send Feedback

The ExistingInstanceIdValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingInstanceIdValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdWithAttributeValueValidator Class

[image]

IceLib Technical Reference
ExistingInstanceIdWithAttributeValueValidator Class
Members See Also Send Feedback
Represents an existing instance ID with attribute value validator. This validator validates that a given instance ID exists and has an attribute with specific values.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExistingInstanceIdWithAttributeValueValidator : Validator
Visual Basic
Public Class ExistingInstanceIdWithAttributeValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ExistingInstanceIdWithAttributeValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ExistingInstanceIdWithAttributeValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdWithAttributeValueValidator Members

[image] [image]

IceLib Technical Reference
ExistingInstanceIdWithAttributeValueValidator Members
ExistingInstanceIdWithAttributeValueValidator Class Methods Properties See Also Send Feedback

The ExistingInstanceIdWithAttributeValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingInstanceIdWithAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdWithAttributeValueValidator Methods

[image] [image]

IceLib Technical Reference
ExistingInstanceIdWithAttributeValueValidator Methods
ExistingInstanceIdWithAttributeValueValidator Class See Also Send Feedback

The ExistingInstanceIdWithAttributeValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ExistingInstanceIdWithAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ExistingInstanceIdWithAttributeValueValidator..::..ToString Method
ExistingInstanceIdWithAttributeValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExistingInstanceIdWithAttributeValueValidator Class
ExistingInstanceIdWithAttributeValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingInstanceIdWithAttributeValueValidator Properties

[image] [image]

IceLib Technical Reference
ExistingInstanceIdWithAttributeValueValidator Properties
ExistingInstanceIdWithAttributeValueValidator Class See Also Send Feedback

The ExistingInstanceIdWithAttributeValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingInstanceIdWithAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingLanguageValuesValidator Class

[image]

IceLib Technical Reference
ExistingLanguageValuesValidator Class
Members See Also Send Feedback
Represents an existing language code validation object. This object validates that a given language code must exist.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExistingLanguageValuesValidator : Validator
Visual Basic
Public Class ExistingLanguageValuesValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ExistingLanguageValuesValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ExistingLanguageValuesValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingLanguageValuesValidator Members

[image] [image]

IceLib Technical Reference
ExistingLanguageValuesValidator Members
ExistingLanguageValuesValidator Class Methods Properties See Also Send Feedback

The ExistingLanguageValuesValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingLanguageValuesValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExistingLanguageValuesValidator Methods

[image] [image]

IceLib Technical Reference
ExistingLanguageValuesValidator Methods
ExistingLanguageValuesValidator Class See Also Send Feedback

The ExistingLanguageValuesValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ExistingLanguageValuesValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ExistingLanguageValuesValidator..::..ToString Method
ExistingLanguageValuesValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExistingLanguageValuesValidator Class
ExistingLanguageValuesValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExistingLanguageValuesValidator Properties

[image] [image]

IceLib Technical Reference
ExistingLanguageValuesValidator Properties
ExistingLanguageValuesValidator Class See Also Send Feedback

The ExistingLanguageValuesValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExistingLanguageValuesValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExtensionValidator Class

[image]

IceLib Technical Reference
ExtensionValidator Class
Members See Also Send Feedback
Represents an Extension validator. This validator validates that a given extension does not already exist.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExtensionValidator : Validator
Visual Basic
Public Class ExtensionValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ExtensionValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ExtensionValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExtensionValidator Members

[image] [image]

IceLib Technical Reference
ExtensionValidator Members
ExtensionValidator Class Constructors Methods Properties See Also Send Feedback

The ExtensionValidator type exposes the following members.

Constructors

 | Name | Description
Public method | ExtensionValidator | Initializes a new instance of the ExtensionValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExtensionValidator Class
ININ.IceLib.Configuration.Validators Namespace


ExtensionValidator Constructor

[image]

IceLib Technical Reference
ExtensionValidator Constructor
ExtensionValidator Class See Also Send Feedback
Initializes a new instance of the ExtensionValidator class.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExtensionValidator(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ExtensionValidator Class
ExtensionValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExtensionValidator Methods

[image] [image]

IceLib Technical Reference
ExtensionValidator Methods
ExtensionValidator Class See Also Send Feedback

The ExtensionValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ExtensionValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ExtensionValidator..::..ToString Method
ExtensionValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExtensionValidator Class
ExtensionValidator Members
ININ.IceLib.Configuration.Validators Namespace


ExtensionValidator Properties

[image] [image]

IceLib Technical Reference
ExtensionValidator Properties
ExtensionValidator Class See Also Send Feedback

The ExtensionValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ExtensionValidator Class
ININ.IceLib.Configuration.Validators Namespace


InvalidCharacterValidator Class

[image]

IceLib Technical Reference
InvalidCharacterValidator Class
Members See Also Send Feedback
Represents Invalid Character validator. This validator validates that a given value does not contain invalid characters.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InvalidCharacterValidator : Validator
Visual Basic
Public Class InvalidCharacterValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..InvalidCharacterValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvalidCharacterValidator Members
ININ.IceLib.Configuration.Validators Namespace


InvalidCharacterValidator Members

[image] [image]

IceLib Technical Reference
InvalidCharacterValidator Members
InvalidCharacterValidator Class Constructors Methods Properties See Also Send Feedback

The InvalidCharacterValidator type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidCharacterValidator | Initializes a new instance of the InvalidCharacterValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | InvalidCharacters | Gets the invalid characters.

See Also

InvalidCharacterValidator Class
ININ.IceLib.Configuration.Validators Namespace


InvalidCharacterValidator Constructor

[image]

IceLib Technical Reference
InvalidCharacterValidator Constructor
InvalidCharacterValidator Class See Also Send Feedback
Initializes a new instance of the InvalidCharacterValidator class.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidCharacterValidator(
    string id,
    string invalidCharacters
)
Visual Basic
Public Sub New ( _
    id As String, _
    invalidCharacters As String _
)

Parameters

id
Type: System..::..String
The ID.
invalidCharacters
Type: System..::..String
The invalid characters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvalidCharacterValidator Class
InvalidCharacterValidator Members
ININ.IceLib.Configuration.Validators Namespace


InvalidCharacterValidator Methods

[image] [image]

IceLib Technical Reference
InvalidCharacterValidator Methods
InvalidCharacterValidator Class See Also Send Feedback

The InvalidCharacterValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InvalidCharacterValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
InvalidCharacterValidator..::..ToString Method
InvalidCharacterValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InvalidCharacterValidator Class
InvalidCharacterValidator Members
ININ.IceLib.Configuration.Validators Namespace


InvalidCharacterValidator Properties

[image] [image]

IceLib Technical Reference
InvalidCharacterValidator Properties
InvalidCharacterValidator Class See Also Send Feedback

The InvalidCharacterValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | InvalidCharacters | Gets the invalid characters.

See Also

InvalidCharacterValidator Class
ININ.IceLib.Configuration.Validators Namespace


InvalidCharacters Property

[image]

IceLib Technical Reference
InvalidCharacterValidator..::..InvalidCharacters Property
InvalidCharacterValidator Class See Also Send Feedback
Gets the invalid characters.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InvalidCharacters { get; }
Visual Basic
Public ReadOnly Property InvalidCharacters As String
    Get

Field Value

The invalid characters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvalidCharacterValidator Class
InvalidCharacterValidator Members
ININ.IceLib.Configuration.Validators Namespace


InvalidMailboxFolderValidator Class

[image]

IceLib Technical Reference
InvalidMailboxFolderValidator Class
Members See Also Send Feedback
Represents the invalid mailbox folder validator. This validator indicates that a the specified mailbox folder is not valid.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InvalidMailboxFolderValidator : Validator
Visual Basic
Public Class InvalidMailboxFolderValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..InvalidMailboxFolderValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidMailboxFolderValidator Members
ININ.IceLib.Configuration.Validators Namespace


InvalidMailboxFolderValidator Members

[image] [image]

IceLib Technical Reference
InvalidMailboxFolderValidator Members
InvalidMailboxFolderValidator Class Methods Properties See Also Send Feedback

The InvalidMailboxFolderValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

InvalidMailboxFolderValidator Class
ININ.IceLib.Configuration.Validators Namespace


InvalidMailboxFolderValidator Methods

[image] [image]

IceLib Technical Reference
InvalidMailboxFolderValidator Methods
InvalidMailboxFolderValidator Class See Also Send Feedback

The InvalidMailboxFolderValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InvalidMailboxFolderValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
InvalidMailboxFolderValidator..::..ToString Method
InvalidMailboxFolderValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InvalidMailboxFolderValidator Class
InvalidMailboxFolderValidator Members
ININ.IceLib.Configuration.Validators Namespace


InvalidMailboxFolderValidator Properties

[image] [image]

IceLib Technical Reference
InvalidMailboxFolderValidator Properties
InvalidMailboxFolderValidator Class See Also Send Feedback

The InvalidMailboxFolderValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

InvalidMailboxFolderValidator Class
ININ.IceLib.Configuration.Validators Namespace


MultipleOfValidator Class

[image]

IceLib Technical Reference
MultipleOfValidator Class
Members See Also Send Feedback
Represents Multiple Of validator. This validator validates that a given value can be equally divided by the provided MultipleOf value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MultipleOfValidator : Validator
Visual Basic
Public Class MultipleOfValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..MultipleOfValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MultipleOfValidator Members
ININ.IceLib.Configuration.Validators Namespace


MultipleOfValidator Members

[image] [image]

IceLib Technical Reference
MultipleOfValidator Members
MultipleOfValidator Class Constructors Methods Properties See Also Send Feedback

The MultipleOfValidator type exposes the following members.

Constructors

 | Name | Description
Public method | MultipleOfValidator | Initializes a new instance of the MultipleOfValidator class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MultipleOf | Gets the multiple Of value.

See Also

MultipleOfValidator Class
ININ.IceLib.Configuration.Validators Namespace


MultipleOfValidator Constructor

[image]

IceLib Technical Reference
MultipleOfValidator Constructor
MultipleOfValidator Class See Also Send Feedback
Initializes a new instance of the MultipleOfValidator class.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MultipleOfValidator(
    string id,
    Nullable<int> multipleOf
)
Visual Basic
Public Sub New ( _
    id As String, _
    multipleOf As Nullable(Of Integer) _
)

Parameters

id
Type: System..::..String
The ID.
multipleOf
Type: System..::..Nullable<(Of <(<'Int32>)>)>
The multiple of.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MultipleOfValidator Class
MultipleOfValidator Members
ININ.IceLib.Configuration.Validators Namespace


MultipleOfValidator Methods

[image] [image]

IceLib Technical Reference
MultipleOfValidator Methods
MultipleOfValidator Class See Also Send Feedback

The MultipleOfValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MultipleOfValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
MultipleOfValidator..::..ToString Method
MultipleOfValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipleOfValidator Class
MultipleOfValidator Members
ININ.IceLib.Configuration.Validators Namespace


MultipleOfValidator Properties

[image] [image]

IceLib Technical Reference
MultipleOfValidator Properties
MultipleOfValidator Class See Also Send Feedback

The MultipleOfValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MultipleOf | Gets the multiple Of value.

See Also

MultipleOfValidator Class
ININ.IceLib.Configuration.Validators Namespace


MultipleOf Property

[image]

IceLib Technical Reference
MultipleOfValidator..::..MultipleOf Property
MultipleOfValidator Class See Also Send Feedback
Gets the multiple Of value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MultipleOf { get; }
Visual Basic
Public ReadOnly Property MultipleOf As Nullable(Of Integer)
    Get

Field Value

The multiple of value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MultipleOfValidator Class
MultipleOfValidator Members
ININ.IceLib.Configuration.Validators Namespace


MutuallyExclusiveValueValidator Class

[image]

IceLib Technical Reference
MutuallyExclusiveValueValidator Class
Members See Also Send Feedback
Represents a configuration mutually exclusive value validator. This validator validates that a given attribute cannot be set if other conflicting attributes are also set.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MutuallyExclusiveValueValidator : Validator
Visual Basic
Public Class MutuallyExclusiveValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..MutuallyExclusiveValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

MutuallyExclusiveValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


MutuallyExclusiveValueValidator Members

[image] [image]

IceLib Technical Reference
MutuallyExclusiveValueValidator Members
MutuallyExclusiveValueValidator Class Methods Properties See Also Send Feedback

The MutuallyExclusiveValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

MutuallyExclusiveValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


MutuallyExclusiveValueValidator Methods

[image] [image]

IceLib Technical Reference
MutuallyExclusiveValueValidator Methods
MutuallyExclusiveValueValidator Class See Also Send Feedback

The MutuallyExclusiveValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MutuallyExclusiveValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
MutuallyExclusiveValueValidator..::..ToString Method
MutuallyExclusiveValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MutuallyExclusiveValueValidator Class
MutuallyExclusiveValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


MutuallyExclusiveValueValidator Properties

[image] [image]

IceLib Technical Reference
MutuallyExclusiveValueValidator Properties
MutuallyExclusiveValueValidator Class See Also Send Feedback

The MutuallyExclusiveValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

MutuallyExclusiveValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


PropertyNotApplicableValidator Class

[image]

IceLib Technical Reference
PropertyNotApplicableValidator Class
Members See Also Send Feedback
Represents property not applicable validator. This validator indicates that a property is applicable with the current configuration.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PropertyNotApplicableValidator : Validator
Visual Basic
Public Class PropertyNotApplicableValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..PropertyNotApplicableValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

PropertyNotApplicableValidator Members
ININ.IceLib.Configuration.Validators Namespace


PropertyNotApplicableValidator Members

[image] [image]

IceLib Technical Reference
PropertyNotApplicableValidator Members
PropertyNotApplicableValidator Class Methods Properties See Also Send Feedback

The PropertyNotApplicableValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

PropertyNotApplicableValidator Class
ININ.IceLib.Configuration.Validators Namespace


PropertyNotApplicableValidator Methods

[image] [image]

IceLib Technical Reference
PropertyNotApplicableValidator Methods
PropertyNotApplicableValidator Class See Also Send Feedback

The PropertyNotApplicableValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

PropertyNotApplicableValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
PropertyNotApplicableValidator..::..ToString Method
PropertyNotApplicableValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PropertyNotApplicableValidator Class
PropertyNotApplicableValidator Members
ININ.IceLib.Configuration.Validators Namespace


PropertyNotApplicableValidator Properties

[image] [image]

IceLib Technical Reference
PropertyNotApplicableValidator Properties
PropertyNotApplicableValidator Class See Also Send Feedback

The PropertyNotApplicableValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

PropertyNotApplicableValidator Class
ININ.IceLib.Configuration.Validators Namespace


RangeFloatValidator Class

[image]

IceLib Technical Reference
RangeFloatValidator Class
Members See Also Send Feedback
Represents a configuration value range float validator. This validator validates that a given float value falls within a specific range.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RangeFloatValidator : Validator
Visual Basic
Public Class RangeFloatValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..RangeFloatValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeFloatValidator Members
ININ.IceLib.Configuration.Validators Namespace


RangeFloatValidator Members

[image] [image]

IceLib Technical Reference
RangeFloatValidator Members
RangeFloatValidator Class Methods Properties See Also Send Feedback

The RangeFloatValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

RangeFloatValidator Class
ININ.IceLib.Configuration.Validators Namespace


RangeFloatValidator Methods

[image] [image]

IceLib Technical Reference
RangeFloatValidator Methods
RangeFloatValidator Class See Also Send Feedback

The RangeFloatValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RangeFloatValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
RangeFloatValidator..::..ToString Method
RangeFloatValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RangeFloatValidator Class
RangeFloatValidator Members
ININ.IceLib.Configuration.Validators Namespace


RangeFloatValidator Properties

[image] [image]

IceLib Technical Reference
RangeFloatValidator Properties
RangeFloatValidator Class See Also Send Feedback

The RangeFloatValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

RangeFloatValidator Class
ININ.IceLib.Configuration.Validators Namespace


MaximumValue Property

[image]

IceLib Technical Reference
RangeFloatValidator..::..MaximumValue Property
RangeFloatValidator Class See Also Send Feedback
Gets the maximum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<float> MaximumValue { get; }
Visual Basic
Public ReadOnly Property MaximumValue As Nullable(Of Single)
    Get

Field Value

The maximum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeFloatValidator Class
RangeFloatValidator Members
ININ.IceLib.Configuration.Validators Namespace


MinimumValue Property

[image]

IceLib Technical Reference
RangeFloatValidator..::..MinimumValue Property
RangeFloatValidator Class See Also Send Feedback
Gets the minimum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<float> MinimumValue { get; }
Visual Basic
Public ReadOnly Property MinimumValue As Nullable(Of Single)
    Get

Field Value

The minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeFloatValidator Class
RangeFloatValidator Members
ININ.IceLib.Configuration.Validators Namespace


RangeValidator Class

[image]

IceLib Technical Reference
RangeValidator Class
Members See Also Send Feedback
Represents a configuration value range validator. This validator validates that a given value falls within a specified range.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RangeValidator : Validator
Visual Basic
Public Class RangeValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..RangeValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RangeValidator Members
ININ.IceLib.Configuration.Validators Namespace


RangeValidator Members

[image] [image]

IceLib Technical Reference
RangeValidator Members
RangeValidator Class Methods Properties See Also Send Feedback

The RangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

RangeValidator Class
ININ.IceLib.Configuration.Validators Namespace


RangeValidator Methods

[image] [image]

IceLib Technical Reference
RangeValidator Methods
RangeValidator Class See Also Send Feedback

The RangeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RangeValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
RangeValidator..::..ToString Method
RangeValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RangeValidator Class
RangeValidator Members
ININ.IceLib.Configuration.Validators Namespace


RangeValidator Properties

[image] [image]

IceLib Technical Reference
RangeValidator Properties
RangeValidator Class See Also Send Feedback

The RangeValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

RangeValidator Class
ININ.IceLib.Configuration.Validators Namespace


MaximumValue Property

[image]

IceLib Technical Reference
RangeValidator..::..MaximumValue Property
RangeValidator Class See Also Send Feedback
Gets the maximum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MaximumValue { get; }
Visual Basic
Public ReadOnly Property MaximumValue As Nullable(Of Integer)
    Get

Field Value

The maximum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RangeValidator Class
RangeValidator Members
ININ.IceLib.Configuration.Validators Namespace


MinimumValue Property

[image]

IceLib Technical Reference
RangeValidator..::..MinimumValue Property
RangeValidator Class See Also Send Feedback
Gets the minimum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MinimumValue { get; }
Visual Basic
Public ReadOnly Property MinimumValue As Nullable(Of Integer)
    Get

Field Value

The minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RangeValidator Class
RangeValidator Members
ININ.IceLib.Configuration.Validators Namespace


RecorderPolicyAnalyzerKeywordCountValueValidator Class

[image]

IceLib Technical Reference
RecorderPolicyAnalyzerKeywordCountValueValidator Class
Members See Also Send Feedback
Represents Analyzer keyword count values validator for Recorder Policies. This validator verifies that the number of keywords assigned to a Recorder Policy does not exceed the maximum number of keywords.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecorderPolicyAnalyzerKeywordCountValueValidator : Validator
Visual Basic
Public Class RecorderPolicyAnalyzerKeywordCountValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..RecorderPolicyAnalyzerKeywordCountValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RecorderPolicyAnalyzerKeywordCountValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


RecorderPolicyAnalyzerKeywordCountValueValidator Members

[image] [image]

IceLib Technical Reference
RecorderPolicyAnalyzerKeywordCountValueValidator Members
RecorderPolicyAnalyzerKeywordCountValueValidator Class Methods Properties See Also Send Feedback

The RecorderPolicyAnalyzerKeywordCountValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

RecorderPolicyAnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


RecorderPolicyAnalyzerKeywordCountValueValidator Methods

[image] [image]

IceLib Technical Reference
RecorderPolicyAnalyzerKeywordCountValueValidator Methods
RecorderPolicyAnalyzerKeywordCountValueValidator Class See Also Send Feedback

The RecorderPolicyAnalyzerKeywordCountValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RecorderPolicyAnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
RecorderPolicyAnalyzerKeywordCountValueValidator..::..ToString Method
RecorderPolicyAnalyzerKeywordCountValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderPolicyAnalyzerKeywordCountValueValidator Class
RecorderPolicyAnalyzerKeywordCountValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


RecorderPolicyAnalyzerKeywordCountValueValidator Properties

[image] [image]

IceLib Technical Reference
RecorderPolicyAnalyzerKeywordCountValueValidator Properties
RecorderPolicyAnalyzerKeywordCountValueValidator Class See Also Send Feedback

The RecorderPolicyAnalyzerKeywordCountValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

RecorderPolicyAnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ReferenceCountValidator Class

[image]

IceLib Technical Reference
ReferenceCountValidator Class
Members See Also Send Feedback
Represents a reference count validator. This validator validates that a given attribute value is only referenced the appropriate number of times.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReferenceCountValidator : Validator
Visual Basic
Public Class ReferenceCountValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ReferenceCountValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReferenceCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


ReferenceCountValidator Members

[image] [image]

IceLib Technical Reference
ReferenceCountValidator Members
ReferenceCountValidator Class Methods Properties See Also Send Feedback

The ReferenceCountValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumReferenceCount | Gets the maximum reference count.

See Also

ReferenceCountValidator Class
ININ.IceLib.Configuration.Validators Namespace


ReferenceCountValidator Methods

[image] [image]

IceLib Technical Reference
ReferenceCountValidator Methods
ReferenceCountValidator Class See Also Send Feedback

The ReferenceCountValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ReferenceCountValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ReferenceCountValidator..::..ToString Method
ReferenceCountValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReferenceCountValidator Class
ReferenceCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


ReferenceCountValidator Properties

[image] [image]

IceLib Technical Reference
ReferenceCountValidator Properties
ReferenceCountValidator Class See Also Send Feedback

The ReferenceCountValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumReferenceCount | Gets the maximum reference count.

See Also

ReferenceCountValidator Class
ININ.IceLib.Configuration.Validators Namespace


MaximumReferenceCount Property

[image]

IceLib Technical Reference
ReferenceCountValidator..::..MaximumReferenceCount Property
ReferenceCountValidator Class See Also Send Feedback
Gets the maximum reference count.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MaximumReferenceCount { get; }
Visual Basic
Public ReadOnly Property MaximumReferenceCount As Nullable(Of Integer)
    Get

Field Value

The maximum reference count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ReferenceCountValidator Class
ReferenceCountValidator Members
ININ.IceLib.Configuration.Validators Namespace


RegularExpressionValidator Class

[image]

IceLib Technical Reference
RegularExpressionValidator Class
Members See Also Send Feedback
Represents a configuration value regular expression validator. This validator validates that a given value matches a specified regular expression.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RegularExpressionValidator : Validator
Visual Basic
Public Class RegularExpressionValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..RegularExpressionValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RegularExpressionValidator Members
ININ.IceLib.Configuration.Validators Namespace


RegularExpressionValidator Members

[image] [image]

IceLib Technical Reference
RegularExpressionValidator Members
RegularExpressionValidator Class Methods Properties See Also Send Feedback

The RegularExpressionValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | RegularExpression | Gets the regular expression.

See Also

RegularExpressionValidator Class
ININ.IceLib.Configuration.Validators Namespace


RegularExpressionValidator Methods

[image] [image]

IceLib Technical Reference
RegularExpressionValidator Methods
RegularExpressionValidator Class See Also Send Feedback

The RegularExpressionValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RegularExpressionValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
RegularExpressionValidator..::..ToString Method
RegularExpressionValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RegularExpressionValidator Class
RegularExpressionValidator Members
ININ.IceLib.Configuration.Validators Namespace


RegularExpressionValidator Properties

[image] [image]

IceLib Technical Reference
RegularExpressionValidator Properties
RegularExpressionValidator Class See Also Send Feedback

The RegularExpressionValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | RegularExpression | Gets the regular expression.

See Also

RegularExpressionValidator Class
ININ.IceLib.Configuration.Validators Namespace


RegularExpression Property

[image]

IceLib Technical Reference
RegularExpressionValidator..::..RegularExpression Property
RegularExpressionValidator Class See Also Send Feedback
Gets the regular expression.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RegularExpression { get; }
Visual Basic
Public ReadOnly Property RegularExpression As String
    Get

Field Value

The regular expression.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RegularExpressionValidator Class
RegularExpressionValidator Members
ININ.IceLib.Configuration.Validators Namespace


RequiredAttributeValidator Class

[image]

IceLib Technical Reference
RequiredAttributeValidator Class
Members See Also Send Feedback
Represents a configuration attribute required value validator. This validator validates that an attribute must be specified.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RequiredAttributeValidator : Validator
Visual Basic
Public Class RequiredAttributeValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..RequiredAttributeValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

RequiredAttributeValidator Members
ININ.IceLib.Configuration.Validators Namespace


RequiredAttributeValidator Members

[image] [image]

IceLib Technical Reference
RequiredAttributeValidator Members
RequiredAttributeValidator Class Methods Properties See Also Send Feedback

The RequiredAttributeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

RequiredAttributeValidator Class
ININ.IceLib.Configuration.Validators Namespace


RequiredAttributeValidator Methods

[image] [image]

IceLib Technical Reference
RequiredAttributeValidator Methods
RequiredAttributeValidator Class See Also Send Feedback

The RequiredAttributeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RequiredAttributeValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
RequiredAttributeValidator..::..ToString Method
RequiredAttributeValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RequiredAttributeValidator Class
RequiredAttributeValidator Members
ININ.IceLib.Configuration.Validators Namespace


RequiredAttributeValidator Properties

[image] [image]

IceLib Technical Reference
RequiredAttributeValidator Properties
RequiredAttributeValidator Class See Also Send Feedback

The RequiredAttributeValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

RequiredAttributeValidator Class
ININ.IceLib.Configuration.Validators Namespace


RequiredValueValidator Class

[image]

IceLib Technical Reference
RequiredValueValidator Class
Members See Also Send Feedback
Represents a configuration value required value validator. This validator validates that a value must be specified.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RequiredValueValidator : Validator
Visual Basic
Public Class RequiredValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..RequiredValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

RequiredValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


RequiredValueValidator Members

[image] [image]

IceLib Technical Reference
RequiredValueValidator Members
RequiredValueValidator Class Methods Properties See Also Send Feedback

The RequiredValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

RequiredValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


RequiredValueValidator Methods

[image] [image]

IceLib Technical Reference
RequiredValueValidator Methods
RequiredValueValidator Class See Also Send Feedback

The RequiredValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RequiredValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
RequiredValueValidator..::..ToString Method
RequiredValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RequiredValueValidator Class
RequiredValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


RequiredValueValidator Properties

[image] [image]

IceLib Technical Reference
RequiredValueValidator Properties
RequiredValueValidator Class See Also Send Feedback

The RequiredValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

RequiredValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ScheduleEndDateTimeValidator Class

[image]

IceLib Technical Reference
ScheduleEndDateTimeValidator Class
Members See Also Send Feedback
Represents the schedule end date/time validator. This validator validates that a given end date or end time is less than the start date if it is specified.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScheduleEndDateTimeValidator : Validator
Visual Basic
Public Class ScheduleEndDateTimeValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ScheduleEndDateTimeValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ScheduleEndDateTimeValidator Members
ININ.IceLib.Configuration.Validators Namespace


ScheduleEndDateTimeValidator Members

[image] [image]

IceLib Technical Reference
ScheduleEndDateTimeValidator Members
ScheduleEndDateTimeValidator Class Methods Properties See Also Send Feedback

The ScheduleEndDateTimeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ScheduleEndDateTimeValidator Class
ININ.IceLib.Configuration.Validators Namespace


ScheduleEndDateTimeValidator Methods

[image] [image]

IceLib Technical Reference
ScheduleEndDateTimeValidator Methods
ScheduleEndDateTimeValidator Class See Also Send Feedback

The ScheduleEndDateTimeValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ScheduleEndDateTimeValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ScheduleEndDateTimeValidator..::..ToString Method
ScheduleEndDateTimeValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ScheduleEndDateTimeValidator Class
ScheduleEndDateTimeValidator Members
ININ.IceLib.Configuration.Validators Namespace


ScheduleEndDateTimeValidator Properties

[image] [image]

IceLib Technical Reference
ScheduleEndDateTimeValidator Properties
ScheduleEndDateTimeValidator Class See Also Send Feedback

The ScheduleEndDateTimeValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ScheduleEndDateTimeValidator Class
ININ.IceLib.Configuration.Validators Namespace


StringLengthValidator Class

[image]

IceLib Technical Reference
StringLengthValidator Class
Members See Also Send Feedback
Represents a configuration value string length validator. This validator validates that a given string must be within a specific length.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StringLengthValidator : Validator
Visual Basic
Public Class StringLengthValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..StringLengthValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

StringLengthValidator Members
ININ.IceLib.Configuration.Validators Namespace


StringLengthValidator Members

[image] [image]

IceLib Technical Reference
StringLengthValidator Members
StringLengthValidator Class Methods Properties See Also Send Feedback

The StringLengthValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

StringLengthValidator Class
ININ.IceLib.Configuration.Validators Namespace


StringLengthValidator Methods

[image] [image]

IceLib Technical Reference
StringLengthValidator Methods
StringLengthValidator Class See Also Send Feedback

The StringLengthValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StringLengthValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
StringLengthValidator..::..ToString Method
StringLengthValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StringLengthValidator Class
StringLengthValidator Members
ININ.IceLib.Configuration.Validators Namespace


StringLengthValidator Properties

[image] [image]

IceLib Technical Reference
StringLengthValidator Properties
StringLengthValidator Class See Also Send Feedback

The StringLengthValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | MaximumValue | Gets the maximum value.
Public property | MinimumValue | Gets the minimum value.

See Also

StringLengthValidator Class
ININ.IceLib.Configuration.Validators Namespace


MaximumValue Property

[image]

IceLib Technical Reference
StringLengthValidator..::..MaximumValue Property
StringLengthValidator Class See Also Send Feedback
Gets the maximum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MaximumValue { get; }
Visual Basic
Public ReadOnly Property MaximumValue As Nullable(Of Integer)
    Get

Field Value

The maximum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

StringLengthValidator Class
StringLengthValidator Members
ININ.IceLib.Configuration.Validators Namespace


MinimumValue Property

[image]

IceLib Technical Reference
StringLengthValidator..::..MinimumValue Property
StringLengthValidator Class See Also Send Feedback
Gets the minimum value.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<int> MinimumValue { get; }
Visual Basic
Public ReadOnly Property MinimumValue As Nullable(Of Integer)
    Get

Field Value

The minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

StringLengthValidator Class
StringLengthValidator Members
ININ.IceLib.Configuration.Validators Namespace


UniqueAttributeValueValidator Class

[image]

IceLib Technical Reference
UniqueAttributeValueValidator Class
Members See Also Send Feedback
Represents a configuration value unique instance ID validator. This validator validates that a given attribute value is unique across all attributes of the same type.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UniqueAttributeValueValidator : Validator
Visual Basic
Public Class UniqueAttributeValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..UniqueAttributeValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UniqueAttributeValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


UniqueAttributeValueValidator Members

[image] [image]

IceLib Technical Reference
UniqueAttributeValueValidator Members
UniqueAttributeValueValidator Class Methods Properties See Also Send Feedback

The UniqueAttributeValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

UniqueAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


UniqueAttributeValueValidator Methods

[image] [image]

IceLib Technical Reference
UniqueAttributeValueValidator Methods
UniqueAttributeValueValidator Class See Also Send Feedback

The UniqueAttributeValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

UniqueAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
UniqueAttributeValueValidator..::..ToString Method
UniqueAttributeValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UniqueAttributeValueValidator Class
UniqueAttributeValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


UniqueAttributeValueValidator Properties

[image] [image]

IceLib Technical Reference
UniqueAttributeValueValidator Properties
UniqueAttributeValueValidator Class See Also Send Feedback

The UniqueAttributeValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

UniqueAttributeValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


UniqueInstanceIdValidator Class

[image]

IceLib Technical Reference
UniqueInstanceIdValidator Class
Members See Also Send Feedback
Represents a configuration value unique instance ID validator. This validator validates that a given value must be unique across all objects of the same type.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UniqueInstanceIdValidator : Validator
Visual Basic
Public Class UniqueInstanceIdValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..UniqueInstanceIdValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UniqueInstanceIdValidator Members
ININ.IceLib.Configuration.Validators Namespace


UniqueInstanceIdValidator Members

[image] [image]

IceLib Technical Reference
UniqueInstanceIdValidator Members
UniqueInstanceIdValidator Class Methods Properties See Also Send Feedback

The UniqueInstanceIdValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

UniqueInstanceIdValidator Class
ININ.IceLib.Configuration.Validators Namespace


UniqueInstanceIdValidator Methods

[image] [image]

IceLib Technical Reference
UniqueInstanceIdValidator Methods
UniqueInstanceIdValidator Class See Also Send Feedback

The UniqueInstanceIdValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

UniqueInstanceIdValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
UniqueInstanceIdValidator..::..ToString Method
UniqueInstanceIdValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UniqueInstanceIdValidator Class
UniqueInstanceIdValidator Members
ININ.IceLib.Configuration.Validators Namespace


UniqueInstanceIdValidator Properties

[image] [image]

IceLib Technical Reference
UniqueInstanceIdValidator Properties
UniqueInstanceIdValidator Class See Also Send Feedback

The UniqueInstanceIdValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

UniqueInstanceIdValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidationGroupValidator Class

[image]

IceLib Technical Reference
ValidationGroupValidator Class
Members See Also Send Feedback
Represents a group of validators.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValidationGroupValidator : Validator
Visual Basic
Public Class ValidationGroupValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ValidationGroupValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidationGroupValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidationGroupValidator Members

[image] [image]

IceLib Technical Reference
ValidationGroupValidator Members
ValidationGroupValidator Class Methods Properties See Also Send Feedback

The ValidationGroupValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildValidatorList | Gets the list of the child validators.
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | ValidationOperator | Gets the validation logical operator.

See Also

ValidationGroupValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidationGroupValidator Methods

[image] [image]

IceLib Technical Reference
ValidationGroupValidator Methods
ValidationGroupValidator Class See Also Send Feedback

The ValidationGroupValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidationGroupValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidationGroupValidator Properties

[image] [image]

IceLib Technical Reference
ValidationGroupValidator Properties
ValidationGroupValidator Class See Also Send Feedback

The ValidationGroupValidator type exposes the following members.

Properties

 | Name | Description
Public property | ChildValidatorList | Gets the list of the child validators.
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | ValidationOperator | Gets the validation logical operator.

See Also

ValidationGroupValidator Class
ININ.IceLib.Configuration.Validators Namespace


ChildValidatorList Property

[image]

IceLib Technical Reference
ValidationGroupValidator..::..ChildValidatorList Property
ValidationGroupValidator Class See Also Send Feedback
Gets the list of the child validators.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Validator> ChildValidatorList { get; }
Visual Basic
Public ReadOnly Property ChildValidatorList As ReadOnlyCollection(Of Validator)
    Get

Field Value

The list of the child validators.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidationGroupValidator Class
ValidationGroupValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidationOperator Property

[image]

IceLib Technical Reference
ValidationGroupValidator..::..ValidationOperator Property
ValidationGroupValidator Class See Also Send Feedback
Gets the validation logical operator.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ValidationGroupValidator..::..ValidationLogicalOperator ValidationOperator { get; }
Visual Basic
Public ReadOnly Property ValidationOperator As ValidationGroupValidator..::..ValidationLogicalOperator
    Get

Field Value

The validation logical operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidationGroupValidator Class
ValidationGroupValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidationGroupValidator.ValidationLogicalOperator Enumeration

[image]

IceLib Technical Reference
ValidationGroupValidator..::..ValidationLogicalOperator Enumeration
ValidationGroupValidator Class See Also Send Feedback
Specifies what type of logical operator this ValidationGroup will use to combine its child validators.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ValidationLogicalOperator
Visual Basic
Public Enumeration ValidationLogicalOperator

Members

Member name | Value | Description
And | 0 | Represents a logical "AND" operation.
Or | 1 | Represents a logical "OR" operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Configuration.Validators Namespace


Validator Class

[image]

IceLib Technical Reference
Validator Class
Members See Also Send Feedback
Represents a configuration value validator.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class Validator
Visual Basic
Public MustInherit Class Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..AcgTreeValidator
ININ.IceLib.Configuration.Validators..::..AnalyzerKeywordCountValueValidator
ININ.IceLib.Configuration.Validators..::..AnalyzerPronunciationValueValidator
ININ.IceLib.Configuration.Validators..::..AnalyzerWordValueValidator
ININ.IceLib.Configuration.Validators..::..AttendantProfileValidator
ININ.IceLib.Configuration.Validators..::..CharacterDelimitedValueValidator
ININ.IceLib.Configuration.Validators..::..CollectionCountValidator
ININ.IceLib.Configuration.Validators..::..CollectionItemValidator
ININ.IceLib.Configuration.Validators..::..ExistingAttributeValueValidator
ININ.IceLib.Configuration.Validators..::..ExistingExtensionValidator
ININ.IceLib.Configuration.Validators..::..ExistingInstanceIdValidator
ININ.IceLib.Configuration.Validators..::..ExistingInstanceIdWithAttributeValueValidator
ININ.IceLib.Configuration.Validators..::..ExistingLanguageValuesValidator
ININ.IceLib.Configuration.Validators..::..ExtensionValidator
ININ.IceLib.Configuration.Validators..::..InvalidCharacterValidator
ININ.IceLib.Configuration.Validators..::..InvalidMailboxFolderValidator
ININ.IceLib.Configuration.Validators..::..MultipleOfValidator
ININ.IceLib.Configuration.Validators..::..MutuallyExclusiveValueValidator
ININ.IceLib.Configuration.Validators..::..PropertyNotApplicableValidator
ININ.IceLib.Configuration.Validators..::..RangeFloatValidator
ININ.IceLib.Configuration.Validators..::..RangeValidator
ININ.IceLib.Configuration.Validators..::..RecorderPolicyAnalyzerKeywordCountValueValidator
ININ.IceLib.Configuration.Validators..::..ReferenceCountValidator
ININ.IceLib.Configuration.Validators..::..RegularExpressionValidator
ININ.IceLib.Configuration.Validators..::..RequiredAttributeValidator
ININ.IceLib.Configuration.Validators..::..RequiredValueValidator
ININ.IceLib.Configuration.Validators..::..ScheduleEndDateTimeValidator
ININ.IceLib.Configuration.Validators..::..StringLengthValidator
ININ.IceLib.Configuration.Validators..::..UniqueAttributeValueValidator
ININ.IceLib.Configuration.Validators..::..UniqueInstanceIdValidator
ININ.IceLib.Configuration.Validators..::..ValidationGroupValidator
ININ.IceLib.Configuration.Validators..::..ValidFormatValidator
ININ.IceLib.Configuration.Validators..::..ValidValuesValidator
ININ.IceLib.Configuration.Validators..::..WorkgroupAnalyzerKeywordCountValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

Validator Members
ININ.IceLib.Configuration.Validators Namespace


Validator Members

[image] [image]

IceLib Technical Reference
Validator Members
Validator Class Methods Properties See Also Send Feedback

The Validator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the ID.

See Also

Validator Class
ININ.IceLib.Configuration.Validators Namespace


Validator Methods

[image] [image]

IceLib Technical Reference
Validator Methods
Validator Class See Also Send Feedback

The Validator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Validator Class
ININ.IceLib.Configuration.Validators Namespace


Validator Properties

[image] [image]

IceLib Technical Reference
Validator Properties
Validator Class See Also Send Feedback

The Validator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID.

See Also

Validator Class
ININ.IceLib.Configuration.Validators Namespace


Id Property

[image]

IceLib Technical Reference
Validator..::..Id Property
Validator Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

Validator Class
Validator Members
ININ.IceLib.Configuration.Validators Namespace


ValidFormatValidator Class

[image]

IceLib Technical Reference
ValidFormatValidator Class
Members See Also Send Feedback
Represents a configuration value format validator. This validator validates that a given value is in a valid format.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValidFormatValidator : Validator
Visual Basic
Public Class ValidFormatValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ValidFormatValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidFormatValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidFormatValidator Members

[image] [image]

IceLib Technical Reference
ValidFormatValidator Members
ValidFormatValidator Class Methods Properties See Also Send Feedback

The ValidFormatValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ValidFormatValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidFormatValidator Methods

[image] [image]

IceLib Technical Reference
ValidFormatValidator Methods
ValidFormatValidator Class See Also Send Feedback

The ValidFormatValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ValidFormatValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ValidFormatValidator..::..ToString Method
ValidFormatValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ValidFormatValidator Class
ValidFormatValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidFormatValidator Properties

[image] [image]

IceLib Technical Reference
ValidFormatValidator Properties
ValidFormatValidator Class See Also Send Feedback

The ValidFormatValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

ValidFormatValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidValuesValidator Class

[image]

IceLib Technical Reference
ValidValuesValidator Class
Members See Also Send Feedback
Represents a configuration value valid values validator. This validator validates that a given value falls within its valid values.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValidValuesValidator : Validator
Visual Basic
Public Class ValidValuesValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..ValidValuesValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

ValidValuesValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidValuesValidator Members

[image] [image]

IceLib Technical Reference
ValidValuesValidator Members
ValidValuesValidator Class Methods Properties See Also Send Feedback

The ValidValuesValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | ValidValues | Gets the read only collection of valid values.

See Also

ValidValuesValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidValuesValidator Methods

[image] [image]

IceLib Technical Reference
ValidValuesValidator Methods
ValidValuesValidator Class See Also Send Feedback

The ValidValuesValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ValidValuesValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
ValidValuesValidator..::..ToString Method
ValidValuesValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ValidValuesValidator Class
ValidValuesValidator Members
ININ.IceLib.Configuration.Validators Namespace


ValidValuesValidator Properties

[image] [image]

IceLib Technical Reference
ValidValuesValidator Properties
ValidValuesValidator Class See Also Send Feedback

The ValidValuesValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)
Public property | ValidValues | Gets the read only collection of valid values.

See Also

ValidValuesValidator Class
ININ.IceLib.Configuration.Validators Namespace


ValidValues Property

[image]

IceLib Technical Reference
ValidValuesValidator..::..ValidValues Property
ValidValuesValidator Class See Also Send Feedback
Gets the read only collection of valid values.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ValidValues { get; }
Visual Basic
Public ReadOnly Property ValidValues As ReadOnlyCollection(Of String)
    Get

Field Value

The valid values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidValuesValidator Class
ValidValuesValidator Members
ININ.IceLib.Configuration.Validators Namespace


WorkgroupAnalyzerKeywordCountValueValidator Class

[image]

IceLib Technical Reference
WorkgroupAnalyzerKeywordCountValueValidator Class
Members See Also Send Feedback
Represents workgroup Analyzer keyword count values validator. This validator verifies that the number of keywords assigned to a workgroup does not exceed the maximum number of keywords.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupAnalyzerKeywordCountValueValidator : Validator
Visual Basic
Public Class WorkgroupAnalyzerKeywordCountValueValidator _
    Inherits Validator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Validators..::..Validator
ININ.IceLib.Configuration.Validators..::..WorkgroupAnalyzerKeywordCountValueValidator

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupAnalyzerKeywordCountValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


WorkgroupAnalyzerKeywordCountValueValidator Members

[image] [image]

IceLib Technical Reference
WorkgroupAnalyzerKeywordCountValueValidator Members
WorkgroupAnalyzerKeywordCountValueValidator Class Methods Properties See Also Send Feedback

The WorkgroupAnalyzerKeywordCountValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

WorkgroupAnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


WorkgroupAnalyzerKeywordCountValueValidator Methods

[image] [image]

IceLib Technical Reference
WorkgroupAnalyzerKeywordCountValueValidator Methods
WorkgroupAnalyzerKeywordCountValueValidator Class See Also Send Feedback

The WorkgroupAnalyzerKeywordCountValueValidator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

WorkgroupAnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ToString Method

[image]

IceLib Technical Reference
WorkgroupAnalyzerKeywordCountValueValidator..::..ToString Method
WorkgroupAnalyzerKeywordCountValueValidator Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Validators
Assembly: ININ.IceLib.Configuration (in ININ.IceLib.Configuration.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAnalyzerKeywordCountValueValidator Class
WorkgroupAnalyzerKeywordCountValueValidator Members
ININ.IceLib.Configuration.Validators Namespace


WorkgroupAnalyzerKeywordCountValueValidator Properties

[image] [image]

IceLib Technical Reference
WorkgroupAnalyzerKeywordCountValueValidator Properties
WorkgroupAnalyzerKeywordCountValueValidator Class See Also Send Feedback

The WorkgroupAnalyzerKeywordCountValueValidator type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID. (Inherited from Validator.)

See Also

WorkgroupAnalyzerKeywordCountValueValidator Class
ININ.IceLib.Configuration.Validators Namespace


ININ.IceLib.Connection Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Connection Namespace
See Also Send Feedback

The ININ.IceLib.Connection namespace contains classes for connecting with Interaction Center.

There are a number of classes within the ININ.IceLib.Connection namespace that provide support to the classes mentioned in the preceding summary. Example of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

Session. The Session object is the root of any IceLib connection with the IC server. It accepts various settings to describe the session and provides events when the connection state changes.

Host Settings. The HostSettings is used to specify the BridgeHost to which a Session should be established.

Authentication Settings. There are a number of object classes that are used to specify authentication settings for the Session such as what IC User ID and Password to login with. All such objects inherit from AuthSettings. Examples of authentication classes are: ICAuthSettings and WindowsAuthSettings,

Station Settings. There are a number of object classes that are used to specify station settings for the Session such as what remote number is serving as the User's station. All such objects inherit from StationSettings. Examples of station classes are: WorkstationSettings and RemoteStationSettings,

Note
All "manager" classes found in the IceLib library are designed as singletons-classes instantiated only once. For example, to begin working with any of the functionality provided in the ININ.IceLib.Interactions.InteractionsManager, you must obtain the instance through a call to its GetInstance method.

Examples

CopyC#
Session session = new Session();
session.Connect(...);
InteractionsManager interactionsManager = InteractionsManager.GetInstance(session);

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the ININ.IceLib.Connection namespace. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 50, in LoginStationViewModel.#ctor
 | LoginStationViewModel.cs, line 113, in LoginStationViewModel.CreateStationSettings
 | LoginViewModel.cs, line 11, in LoginViewModel.#ctor
 | LoginViewModel.cs, line 186, in LoginViewModel.PerformLogin
 | LoginHostViewModel.cs, line 9, in LoginHostViewModel.#ctor
 | LoginAuthViewModel.cs, line 9, in LoginAuthViewModel.#ctor
 | ChangeStationViewModel.cs, line 11, in ChangeStationViewModel.#ctor
 | ConnectionViewModel.cs, line 197, in ConnectionViewModel.SetSessionValues
 | ConnectionViewModel.cs, line 214, in ConnectionViewModel.SetStationValues
 | ConnectionViewModel.cs, line 12, in ConnectionViewModel.#ctor
 | ConnectionViewModel.cs, line 186, in ConnectionViewModel.SessionConnectionStateChanged
 | SystemStatisticsViewModel.cs, line 51, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 138, in StatisticCatalogViewModel.SessionConnectionStateChanged
 | UserRoleConfigurationViewModel.cs, line 150, in UserRoleConfigurationViewModel.SessionConnectionStateChanged
 | MainWindowViewModel.cs, line 22, in MainWindowViewModel.#ctor

Classes

 | Class | Description
Public class | AllowableAuthentications | Represents the allowable authentication methods for logon.
Public class | AllowableAuthenticationsParameters | Class used to provide input parameters for GetAllowableAuthentications(AllowableAuthenticationsParameters).
Public class | AlternateWindowsAuthSettings | Passed to a Session in order to authenticate a Windows user.
Public class | AuthProviderContext | Provides context of an authentication provider for the security token service.
Public class | AuthProviderDefinition | Defines an authentication provider for the security token service.
Public class | AuthSettings | Passed to a Session in order to authenticate a user.
Public class | CachedAllowableAuthenticationsParameters | Class used to provide input parameters for GetCachedAllowableAuthentications(CachedAllowableAuthenticationsParameters).
Public class | CommonCredentials | Offers a set of static methods that get or set credentials to or from the credential cache.
Public class | ConnectionStateChangedEventArgs | Provides data for the ConnectionStateChanged event.
Public class | CustomFormAuthScriptableClass | The class to be used as the ObjectForScripting for a web browser control when using Single Sign On with an that uses .
Public class | EffectiveStationChangedEventArgs | Provides data for the EffectiveStationChanged event.
Public class | GetAuthenticationTokenCompletedEventArgs | Provides data for the asynchronous completed event of GetAuthenticationTokenAsync(EventHandler<(Of <<'(GetAuthenticationTokenCompletedEventArgs>)>>), Object).
Public class | GetAuthenticationTokenResult | Provides return data for the GetAuthenticationToken()()()() method.
Public class | HostEndpoint | Represents an endpoint for BridgeHost connections.
Public class | HostSettings | Passed to a Session in order to specify a host (i.e. IC server).
Public class | ICAuthSettings | Passed to a Session in order to authenticate an Interaction Center user.
Public class | IceLibConnectionException | The exception that is thrown when an attempt to connect to an IC server has failed.
Public class | IceLibConnectionExceptionTypes | This class is used by IceLibConnectionException to provide more information about the type of error.
Public class | InvalidServerVersionException | The exception that is thrown when an attempt was made to connect to an IC server with an incompatible IceLib version.
Public class | RemoteFileHelper | Utility class for transferring personal storage files.
Public class | RemoteNumberSettings | Passed to a Session in order to specify a remote number connection.
Public class | RemoteStationSettings | Passed to a Session in order to specify a remote station.
Public class | RequestTimeoutException | The exception that is thrown for IceLib when a server operation times out.
Public class | SecurityTokenServiceAuthParameters | Provides configuration for SecurityTokenServiceAuthSettings. All properties are optional.
Public class | SecurityTokenServiceAuthSettings | Passed to a Session in order to authenticate an Interaction Center user.
Public class | SecurityTokenServicePresenter | Allows a custom application to present STS authentication requests to the user.
Public class | SecurityTokenServicePresenterContext | Provides context for STS authentication via a SecurityTokenServicePresenter.
Public class | SensitiveDataContext | Provides access to the Session's sensitive data context.
Public class | Session | Represents the connection Session with the Interaction Center server.
Public class | SessionDisconnectedException | The exception that is thrown for IceLib when a server operation is requested while the Session is disconnected.
Public class | SessionSettings | Passed to a Session in order to configure a session.
Public class | SingleSignOnRequestData | Class used to supply information to a web browser control when using Single Sign On with an that uses .
Public class | StationInfo | Describes a station.
Public class | StationlessSettings | Passed to a Session in order to specify a stationless connection.
Public class | StationSettings | Passed to a Session in order to specify a station.
Public class | StoredCredentials | A set of credentials that can be persisted, retrieved, and used to authenticate with the server.
Public class | WindowsAuthSettings | Passed to a Session in order to authenticate a Windows user using data from the current environment.
Public class | WorkstationSettings | Passed to a Session in order to specify a workstation.

Enumerations

 | Enumeration | Description
Public enumeration | AuthenticationFields | Represents the possible fields for various authentication methods.
Public enumeration | ClassOfService | Specifies constants indicating what class of service a session supports.
Public enumeration | ConnectionState | Specifies constants indicating the state of a Session's connection.
Public enumeration | ConnectionStateReason | Specifies constants indicating the reason for the state of a Session's connection.
Public enumeration | DeviceType | Specifies constants indicating what type of device is establishing a session.
Public enumeration | LoadFlags | This bitmask is used specify which credentials to load from the set of credentials that have been stored.
Public enumeration | LoadPreference | Used to specify the order in which to try and retrieve stored credentials.
Public enumeration | ReadyForInteractionsType | Specifies constants indicating at what time the application is ready to make or receive Interactions.
Public enumeration | ServerFileType | Specifies constants indicating where to store files in PersonalStorage on the server.
Public enumeration | StationConnectionMode | Used to change the station login and logout behavior with respect to the IceLib Session.
Public enumeration | StationType | Specifies constants indicating a station's type.
Public enumeration | SupportedMedia | Specifies constants indicating what media types a station supports.
Public enumeration | WindowsAuthProtocols | Specifies constants indicating authentication protocols.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


AllowableAuthentications Class

[image]

IceLib Technical Reference
AllowableAuthentications Class
Members See Also Send Feedback
Represents the allowable authentication methods for logon.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AllowableAuthentications
Visual Basic
Public Class AllowableAuthentications

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AllowableAuthentications

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AllowableAuthentications Members

[image] [image]

IceLib Technical Reference
AllowableAuthentications Members
AllowableAuthentications Class Methods Properties See Also Send Feedback

The AllowableAuthentications type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AllowAlternateWindowsAuth | Gets the value indicating whether or not AlternateWindowsAuthentication is allowed.
Public property | AllowCachedCredentials | Gets the value indicating whether or not the usage of cached credentials is allowed.
Public property | AllowICAuth | Gets the value indicating whether or not ICAuthentication is allowed.
Public property | AllowWindowsAuth | Gets the value indicating whether or not WindowsAuthentication is allowed.
Public property | AuthProviderDefinitions | Gets the available authentication providers for the secure token service (STS).

See Also

AllowableAuthentications Class
ININ.IceLib.Connection Namespace


AllowableAuthentications Methods

[image] [image]

IceLib Technical Reference
AllowableAuthentications Methods
AllowableAuthentications Class See Also Send Feedback

The AllowableAuthentications type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AllowableAuthentications Class
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
AllowableAuthentications..::..ToString Method
AllowableAuthentications Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AllowableAuthentications Class
AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AllowableAuthentications Properties

[image] [image]

IceLib Technical Reference
AllowableAuthentications Properties
AllowableAuthentications Class See Also Send Feedback

The AllowableAuthentications type exposes the following members.

Properties

 | Name | Description
Public property | AllowAlternateWindowsAuth | Gets the value indicating whether or not AlternateWindowsAuthentication is allowed.
Public property | AllowCachedCredentials | Gets the value indicating whether or not the usage of cached credentials is allowed.
Public property | AllowICAuth | Gets the value indicating whether or not ICAuthentication is allowed.
Public property | AllowWindowsAuth | Gets the value indicating whether or not WindowsAuthentication is allowed.
Public property | AuthProviderDefinitions | Gets the available authentication providers for the secure token service (STS).

See Also

AllowableAuthentications Class
ININ.IceLib.Connection Namespace


AllowAlternateWindowsAuth Property

[image]

IceLib Technical Reference
AllowableAuthentications..::..AllowAlternateWindowsAuth Property
AllowableAuthentications Class See Also Send Feedback
Gets the value indicating whether or not AlternateWindowsAuthentication is allowed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowAlternateWindowsAuth { get; }
Visual Basic
Public ReadOnly Property AllowAlternateWindowsAuth As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if AlternateWindowsAuthentication is allowed, otherwise falseFalsefalsefalse (False in Visual Basic)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AllowableAuthentications Class
AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AllowCachedCredentials Property

[image]

IceLib Technical Reference
AllowableAuthentications..::..AllowCachedCredentials Property
AllowableAuthentications Class See Also Send Feedback
Gets the value indicating whether or not the usage of cached credentials is allowed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowCachedCredentials { get; }
Visual Basic
Public ReadOnly Property AllowCachedCredentials As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if caching credentials is allowed, otherwise falseFalsefalsefalse (False in Visual Basic)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AllowableAuthentications Class
AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AllowICAuth Property

[image]

IceLib Technical Reference
AllowableAuthentications..::..AllowICAuth Property
AllowableAuthentications Class See Also Send Feedback
Gets the value indicating whether or not ICAuthentication is allowed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowICAuth { get; }
Visual Basic
Public ReadOnly Property AllowICAuth As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if ICAuthentication is allowed, otherwise falseFalsefalsefalse (False in Visual Basic)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AllowableAuthentications Class
AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AllowWindowsAuth Property

[image]

IceLib Technical Reference
AllowableAuthentications..::..AllowWindowsAuth Property
AllowableAuthentications Class See Also Send Feedback
Gets the value indicating whether or not WindowsAuthentication is allowed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowWindowsAuth { get; }
Visual Basic
Public ReadOnly Property AllowWindowsAuth As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if WindowsAuthentication is allowed, otherwise falseFalsefalsefalse (False in Visual Basic)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

AllowableAuthentications Class
AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AuthProviderDefinitions Property

[image]

IceLib Technical Reference
AllowableAuthentications..::..AuthProviderDefinitions Property
AllowableAuthentications Class See Also Send Feedback
Gets the available authentication providers for the secure token service (STS).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AuthProviderDefinition> AuthProviderDefinitions { get; }
Visual Basic
Public ReadOnly Property AuthProviderDefinitions As ReadOnlyCollection(Of AuthProviderDefinition)
    Get

Field Value

The secure token authentication providers.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AllowableAuthentications Class
AllowableAuthentications Members
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Class

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters Class
Members See Also Send Feedback
Class used to provide input parameters for GetAllowableAuthentications(AllowableAuthenticationsParameters).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AllowableAuthenticationsParameters
Visual Basic
Public Class AllowableAuthenticationsParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AllowableAuthenticationsParameters

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Members

[image] [image]

IceLib Technical Reference
AllowableAuthenticationsParameters Members
AllowableAuthenticationsParameters Class Constructors Methods Properties See Also Send Feedback

The AllowableAuthenticationsParameters type exposes the following members.

Constructors

 | Name | Description
Public method | AllowableAuthenticationsParameters(HostSettings) | Initializes a new instance of the AllowableAuthenticationsParameters class.
Public method | AllowableAuthenticationsParameters(HostSettings, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the AllowableAuthenticationsParameters class.
Public method | AllowableAuthenticationsParameters(HostSettings, String) | Initializes a new instance of the AllowableAuthenticationsParameters class.
Public method | AllowableAuthenticationsParameters(HostSettings, String, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the AllowableAuthenticationsParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | HostSettings | Gets the HostSettings for the connection.
Public property | IsoLanguage | Gets the ISO culture name that will be used to localize display strings.
Public property | SupportedAuthenticationFields | Gets the supported authentication fields.

See Also

AllowableAuthenticationsParameters Class
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Constructor

[image] [image]

IceLib Technical Reference
AllowableAuthenticationsParameters Constructor
AllowableAuthenticationsParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllowableAuthenticationsParameters(HostSettings) | Initializes a new instance of the AllowableAuthenticationsParameters class.
Public method | AllowableAuthenticationsParameters(HostSettings, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the AllowableAuthenticationsParameters class.
Public method | AllowableAuthenticationsParameters(HostSettings, String) | Initializes a new instance of the AllowableAuthenticationsParameters class.
Public method | AllowableAuthenticationsParameters(HostSettings, String, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the AllowableAuthenticationsParameters class.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Constructor (HostSettings)

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters Constructor (HostSettings)
AllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the AllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AllowableAuthenticationsParameters(
    HostSettings hostSettings
)
Visual Basic
Public Sub New ( _
    hostSettings As HostSettings _
)

Parameters

hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.

Exceptions

Exception | Condition
System..::..ArgumentNullException | hostSettings is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
AllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Constructor (HostSettings, ICollection(AuthenticationFields))

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters Constructor (HostSettings, ICollection<(Of <(<'AuthenticationFields>)>)>)
AllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the AllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AllowableAuthenticationsParameters(
    HostSettings hostSettings,
    ICollection<AuthenticationFields> supportedAuthenticationFields
)
Visual Basic
Public Sub New ( _
    hostSettings As HostSettings, _
    supportedAuthenticationFields As ICollection(Of AuthenticationFields) _
)

Parameters

hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.
supportedAuthenticationFields
Type: System.Collections.Generic..::..ICollection<(Of <(<' AuthenticationFields >)>)>
The supported authentication fields.

Exceptions

Exception | Condition
System..::..ArgumentNullException | hostSettings is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | supportedAuthenticationFields contains a value not part of the AuthenticationFields enum, or is None.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
AllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Constructor (HostSettings, String)

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters Constructor (HostSettings, String)
AllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the AllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AllowableAuthenticationsParameters(
    HostSettings hostSettings,
    string isoLanguage
)
Visual Basic
Public Sub New ( _
    hostSettings As HostSettings, _
    isoLanguage As String _
)

Parameters

hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.
isoLanguage
Type: System..::..String
The ISO culture name that will be used to localize display strings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | isoLanguage is Empty.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
AllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Constructor (HostSettings, String, ICollection(AuthenticationFields))

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters Constructor (HostSettings, String, ICollection<(Of <(<'AuthenticationFields>)>)>)
AllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the AllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AllowableAuthenticationsParameters(
    HostSettings hostSettings,
    string isoLanguage,
    ICollection<AuthenticationFields> supportedAuthenticationFields
)
Visual Basic
Public Sub New ( _
    hostSettings As HostSettings, _
    isoLanguage As String, _
    supportedAuthenticationFields As ICollection(Of AuthenticationFields) _
)

Parameters

hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.
isoLanguage
Type: System..::..String
The ISO culture name that will be used to localize display strings.
supportedAuthenticationFields
Type: System.Collections.Generic..::..ICollection<(Of <(<' AuthenticationFields >)>)>
The supported authentication fields.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | isoLanguage is Empty.
System..::..ArgumentOutOfRangeException | supportedAuthenticationFields contains a value not part of the AuthenticationFields enum, or is None.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
AllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Methods

[image] [image]

IceLib Technical Reference
AllowableAuthenticationsParameters Methods
AllowableAuthenticationsParameters Class See Also Send Feedback

The AllowableAuthenticationsParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

AllowableAuthenticationsParameters Class
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters..::..ToString Method
AllowableAuthenticationsParameters Class See Also Send Feedback

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


AllowableAuthenticationsParameters Properties

[image] [image]

IceLib Technical Reference
AllowableAuthenticationsParameters Properties
AllowableAuthenticationsParameters Class See Also Send Feedback

The AllowableAuthenticationsParameters type exposes the following members.

Properties

 | Name | Description
Public property | HostSettings | Gets the HostSettings for the connection.
Public property | IsoLanguage | Gets the ISO culture name that will be used to localize display strings.
Public property | SupportedAuthenticationFields | Gets the supported authentication fields.

See Also

AllowableAuthenticationsParameters Class
ININ.IceLib.Connection Namespace


HostSettings Property

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters..::..HostSettings Property
AllowableAuthenticationsParameters Class See Also Send Feedback
Gets the HostSettings for the connection.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostSettings HostSettings { get; private set; }
Visual Basic
Public Property HostSettings As HostSettings
    Get
    Private Set

Field Value

The HostSettings for the connection.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


IsoLanguage Property

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters..::..IsoLanguage Property
AllowableAuthenticationsParameters Class See Also Send Feedback
Gets the ISO culture name that will be used to localize display strings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IsoLanguage { get; private set; }
Visual Basic
Public Property IsoLanguage As String
    Get
    Private Set

Field Value

The ISO culture name that will be used to localize display strings.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


SupportedAuthenticationFields Property

[image]

IceLib Technical Reference
AllowableAuthenticationsParameters..::..SupportedAuthenticationFields Property
AllowableAuthenticationsParameters Class See Also Send Feedback
Gets the supported authentication fields.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AuthenticationFields> SupportedAuthenticationFields { get; }
Visual Basic
Public ReadOnly Property SupportedAuthenticationFields As ReadOnlyCollection(Of AuthenticationFields)
    Get

Field Value

The supported authentication fields.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

AllowableAuthenticationsParameters Class
AllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Class

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings Class
Members See Also Send Feedback
Passed to a Session in order to authenticate a Windows user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlternateWindowsAuthSettings : AuthSettings
Visual Basic
Public Class AlternateWindowsAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.

The AlternateWindowsAuthSettings object is used to specify Windows user authentication settings when the credentials for the application's current environment don't necessarily match the user's credentials. This is used when Windows user credentials should be used to authenticate the user requesting a Session.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..AlternateWindowsAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings
ININ.IceLib.Connection..::..WindowsAuthSettings


AlternateWindowsAuthSettings Members

[image] [image]

IceLib Technical Reference
AlternateWindowsAuthSettings Members
AlternateWindowsAuthSettings Class Constructors Methods Properties See Also Send Feedback

The AlternateWindowsAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AlternateWindowsAuthSettings()()()() | Initializes a new instance of the AlternateWindowsAuthSettings class.
Public method | AlternateWindowsAuthSettings(String, SecureString) | Initializes a new instance of the AlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | AlternateWindowsAuthSettings(String, String) | Initializes a new instance of the AlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | AlternateWindowsAuthSettings(String, String, SecureString, WindowsAuthProtocols) | Initializes a new instance of the AlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | AlternateWindowsAuthSettings(String, String, String, WindowsAuthProtocols) | Initializes a new instance of the AlternateWindowsAuthSettings class and populates the properties from the given parameters.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this AuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from AuthSettings.)

Properties

 | Name | Description
Public property | Domain | Gets or sets the domain associated with the UserName.
Public property | FullyQualifiedUserName | Gets the fully qualified user name.
Public property | Password | Sets the password.
Public property | Protocols | Gets or sets the Windows authentication protocols to use.
Public property | SecurePassword | Sets the password.
Public property | UserName | Gets or sets the name of the user.

See Also

AlternateWindowsAuthSettings Class
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Constructor

[image] [image]

IceLib Technical Reference
AlternateWindowsAuthSettings Constructor
AlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the AlternateWindowsAuthSettings class.

Overload List

 | Name | Description
Public method | AlternateWindowsAuthSettings()()()() | Initializes a new instance of the AlternateWindowsAuthSettings class.
Public method | AlternateWindowsAuthSettings(String, SecureString) | Initializes a new instance of the AlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | AlternateWindowsAuthSettings(String, String) | Initializes a new instance of the AlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | AlternateWindowsAuthSettings(String, String, SecureString, WindowsAuthProtocols) | Initializes a new instance of the AlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | AlternateWindowsAuthSettings(String, String, String, WindowsAuthProtocols) | Initializes a new instance of the AlternateWindowsAuthSettings class and populates the properties from the given parameters.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Constructor

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings Constructor
AlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the AlternateWindowsAuthSettings class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlternateWindowsAuthSettings()
Visual Basic
Public Sub New

Remarks

The properties of the object must be set before the object can be used to connect.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
AlternateWindowsAuthSettings Overload
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Constructor (String, SecureString)

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings Constructor (String, SecureString)
AlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the AlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlternateWindowsAuthSettings(
    string userNameWithDomain,
    SecureString password
)
Visual Basic
Public Sub New ( _
    userNameWithDomain As String, _
    password As SecureString _
)

Parameters

userNameWithDomain
Type: System..::..String
The user name with the domain prefix in the form: "domain\user", or in the User Principle Name (UPN) format: "user@example.com". If no domain is specified, and the user name is not in the UPN format, the domain of the environment in which the IceLib application is running will be used.
password
Type: System.Security..::..SecureString
The user's password.

Remarks

The Protocols property will be set to WindowsAuthProtocols.All.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.
System..::..ArgumentException | userNameWithDomain is not formatted properly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
AlternateWindowsAuthSettings Overload
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


AlternateWindowsAuthSettings Constructor (String, String)

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings Constructor (String, String)
AlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the AlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlternateWindowsAuthSettings(
    string userNameWithDomain,
    string password
)
Visual Basic
Public Sub New ( _
    userNameWithDomain As String, _
    password As String _
)

Parameters

userNameWithDomain
Type: System..::..String
The user name with the domain prefix in the form: "domain\user", or in the User Principle Name (UPN) format: "user@example.com". If no domain is specified, and the user name is not in the UPN format, the domain of the environment in which the IceLib application is running will be used.
password
Type: System..::..String
The user's password.

Remarks

The Protocols property will be set to WindowsAuthProtocols.All.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.
System..::..ArgumentException | userNameWithDomain is not formatted properly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
AlternateWindowsAuthSettings Overload
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


AlternateWindowsAuthSettings Constructor (String, String, SecureString, WindowsAuthProtocols)

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings Constructor (String, String, SecureString, WindowsAuthProtocols)
AlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the AlternateWindowsAuthSettings class and populates the properties from the given parameters.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlternateWindowsAuthSettings(
    string domainName,
    string userName,
    SecureString password,
    WindowsAuthProtocols protocols
)
Visual Basic
Public Sub New ( _
    domainName As String, _
    userName As String, _
    password As SecureString, _
    protocols As WindowsAuthProtocols _
)

Parameters

domainName
Type: System..::..String
Name of the domain to which the user belongs.
userName
Type: System..::..String
Name of the Windows user.
password
Type: System.Security..::..SecureString
The password.
protocols
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
The Windows authentication protocols to use.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
AlternateWindowsAuthSettings Overload
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Constructor (String, String, String, WindowsAuthProtocols)

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings Constructor (String, String, String, WindowsAuthProtocols)
AlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the AlternateWindowsAuthSettings class and populates the properties from the given parameters.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlternateWindowsAuthSettings(
    string domainName,
    string userName,
    string password,
    WindowsAuthProtocols protocols
)
Visual Basic
Public Sub New ( _
    domainName As String, _
    userName As String, _
    password As String, _
    protocols As WindowsAuthProtocols _
)

Parameters

domainName
Type: System..::..String
Name of the domain to which the user belongs.
userName
Type: System..::..String
Name of the Windows user.
password
Type: System..::..String
The password.
protocols
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
The Windows authentication protocols to use.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
AlternateWindowsAuthSettings Overload
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Methods

[image] [image]

IceLib Technical Reference
AlternateWindowsAuthSettings Methods
AlternateWindowsAuthSettings Class See Also Send Feedback

The AlternateWindowsAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this AuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from AuthSettings.)

See Also

AlternateWindowsAuthSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..Clone Method
AlternateWindowsAuthSettings Class See Also Send Feedback
Returns an exact copy of this AuthSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new AuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..Dispose Method
AlternateWindowsAuthSettings Class See Also Send Feedback
Releases all resources used by the AuthSettings.

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..Dispose Method (Boolean)
AlternateWindowsAuthSettings Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
Dispose Overload
ININ.IceLib.Connection Namespace


AlternateWindowsAuthSettings Properties

[image] [image]

IceLib Technical Reference
AlternateWindowsAuthSettings Properties
AlternateWindowsAuthSettings Class See Also Send Feedback

The AlternateWindowsAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | Domain | Gets or sets the domain associated with the UserName.
Public property | FullyQualifiedUserName | Gets the fully qualified user name.
Public property | Password | Sets the password.
Public property | Protocols | Gets or sets the Windows authentication protocols to use.
Public property | SecurePassword | Sets the password.
Public property | UserName | Gets or sets the name of the user.

See Also

AlternateWindowsAuthSettings Class
ININ.IceLib.Connection Namespace


Domain Property

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..Domain Property
AlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the domain associated with the UserName.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Domain { get; set; }
Visual Basic
Public Property Domain As String
    Get
    Set

Field Value

The domain.

Remarks

If UserName is in the User Principle Name (UPN) format, this value may be an empty string.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


FullyQualifiedUserName Property

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..FullyQualifiedUserName Property
AlternateWindowsAuthSettings Class See Also Send Feedback
Gets the fully qualified user name.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FullyQualifiedUserName { get; }
Visual Basic
Public ReadOnly Property FullyQualifiedUserName As String
    Get

Remarks

If a domain was specified, the result will be in the format "Domain\UserName". If a User Principal Name (UPN) was specified, the result will be the UPN only (for example, "user@example.com").

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


Password Property

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..Password Property
AlternateWindowsAuthSettings Class See Also Send Feedback
Sets the password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Password { internal get; set; }
Visual Basic
Public Property Password As String
    Friend Get
    Set

Field Value

The password.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


Protocols Property

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..Protocols Property
AlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the Windows authentication protocols to use.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowsAuthProtocols Protocols { get; set; }
Visual Basic
Public Property Protocols As WindowsAuthProtocols
    Get
    Set

Field Value

Flags specifying protocols to use.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


SecurePassword Property

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..SecurePassword Property
AlternateWindowsAuthSettings Class See Also Send Feedback
Sets the password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureString SecurePassword { internal get; set; }
Visual Basic
Public Property SecurePassword As SecureString
    Friend Get
    Set

Field Value

The password.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


UserName Property

[image]

IceLib Technical Reference
AlternateWindowsAuthSettings..::..UserName Property
AlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

Field Value

The name of the user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlternateWindowsAuthSettings Class
AlternateWindowsAuthSettings Members
ININ.IceLib.Connection Namespace


AuthenticationFields Enumeration

[image]

IceLib Technical Reference
AuthenticationFields Enumeration
See Also Send Feedback
Represents the possible fields for various authentication methods.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AuthenticationFields
Visual Basic
Public Enumeration AuthenticationFields

Members

Member name | Value | Description
None | 0 | The authentication does not require any fields or the fields are unknown.
CurrentUser | 1 | The authentication requires the username be the current logged in user.
UserName | 2 | The authentication requires the user enter a user name.
UserNameAndPassword | 3 | The authentication requires the user enter a user name and password.
Browser | 4 | The authentication requires the user to login via a browser page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Connection Namespace


AuthProviderContext Class

[image]

IceLib Technical Reference
AuthProviderContext Class
Members See Also Send Feedback
Provides context of an authentication provider for the security token service.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AuthProviderContext
Visual Basic
Public Class AuthProviderContext

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthProviderContext

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AuthProviderContext Members
ININ.IceLib.Connection Namespace


AuthProviderContext Members

[image] [image]

IceLib Technical Reference
AuthProviderContext Members
AuthProviderContext Class Methods Properties See Also Send Feedback

The AuthProviderContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AuthenticationFields | Gets the fields needed by the authentication provider.
Public property | Id | Gets the authentication provider's ID.

See Also

AuthProviderContext Class
ININ.IceLib.Connection Namespace


AuthProviderContext Methods

[image] [image]

IceLib Technical Reference
AuthProviderContext Methods
AuthProviderContext Class See Also Send Feedback

The AuthProviderContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AuthProviderContext Class
ININ.IceLib.Connection Namespace


Equals Method

[image]

IceLib Technical Reference
AuthProviderContext..::..Equals Method
AuthProviderContext Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthProviderContext Class
AuthProviderContext Members
ININ.IceLib.Connection Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AuthProviderContext..::..GetHashCode Method
AuthProviderContext Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthProviderContext Class
AuthProviderContext Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
AuthProviderContext..::..ToString Method
AuthProviderContext Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthProviderContext Class
AuthProviderContext Members
ININ.IceLib.Connection Namespace


AuthProviderContext Properties

[image] [image]

IceLib Technical Reference
AuthProviderContext Properties
AuthProviderContext Class See Also Send Feedback

The AuthProviderContext type exposes the following members.

Properties

 | Name | Description
Public property | AuthenticationFields | Gets the fields needed by the authentication provider.
Public property | Id | Gets the authentication provider's ID.

See Also

AuthProviderContext Class
ININ.IceLib.Connection Namespace


AuthenticationFields Property

[image]

IceLib Technical Reference
AuthProviderContext..::..AuthenticationFields Property
AuthProviderContext Class See Also Send Feedback
Gets the fields needed by the authentication provider.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AuthenticationFields AuthenticationFields { get; }
Visual Basic
Public ReadOnly Property AuthenticationFields As AuthenticationFields
    Get

Field Value

The authentication provider's fields.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AuthProviderContext Class
AuthProviderContext Members
ININ.IceLib.Connection Namespace


Id Property

[image]

IceLib Technical Reference
AuthProviderContext..::..Id Property
AuthProviderContext Class See Also Send Feedback
Gets the authentication provider's ID.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The authentication provider's ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AuthProviderContext Class
AuthProviderContext Members
ININ.IceLib.Connection Namespace


AuthProviderDefinition Class

[image]

IceLib Technical Reference
AuthProviderDefinition Class
Members See Also Send Feedback
Defines an authentication provider for the security token service.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AuthProviderDefinition
Visual Basic
Public Class AuthProviderDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthProviderDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AuthProviderDefinition Members
ININ.IceLib.Connection Namespace


AuthProviderDefinition Members

[image] [image]

IceLib Technical Reference
AuthProviderDefinition Members
AuthProviderDefinition Class Methods Properties See Also Send Feedback

The AuthProviderDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DisplayName | Gets the authentication provider's display name.
Public property | ProviderContext | Gets the authentication provider context.

See Also

AuthProviderDefinition Class
ININ.IceLib.Connection Namespace


AuthProviderDefinition Methods

[image] [image]

IceLib Technical Reference
AuthProviderDefinition Methods
AuthProviderDefinition Class See Also Send Feedback

The AuthProviderDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AuthProviderDefinition Class
ININ.IceLib.Connection Namespace


Equals Method

[image]

IceLib Technical Reference
AuthProviderDefinition..::..Equals Method
AuthProviderDefinition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthProviderDefinition Class
AuthProviderDefinition Members
ININ.IceLib.Connection Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AuthProviderDefinition..::..GetHashCode Method
AuthProviderDefinition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthProviderDefinition Class
AuthProviderDefinition Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
AuthProviderDefinition..::..ToString Method
AuthProviderDefinition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthProviderDefinition Class
AuthProviderDefinition Members
ININ.IceLib.Connection Namespace


AuthProviderDefinition Properties

[image] [image]

IceLib Technical Reference
AuthProviderDefinition Properties
AuthProviderDefinition Class See Also Send Feedback

The AuthProviderDefinition type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the authentication provider's display name.
Public property | ProviderContext | Gets the authentication provider context.

See Also

AuthProviderDefinition Class
ININ.IceLib.Connection Namespace


DisplayName Property

[image]

IceLib Technical Reference
AuthProviderDefinition..::..DisplayName Property
AuthProviderDefinition Class See Also Send Feedback
Gets the authentication provider's display name.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The authentication provider's display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AuthProviderDefinition Class
AuthProviderDefinition Members
ININ.IceLib.Connection Namespace


ProviderContext Property

[image]

IceLib Technical Reference
AuthProviderDefinition..::..ProviderContext Property
AuthProviderDefinition Class See Also Send Feedback
Gets the authentication provider context.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AuthProviderContext ProviderContext { get; }
Visual Basic
Public ReadOnly Property ProviderContext As AuthProviderContext
    Get

Field Value

The authentication provider context.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AuthProviderDefinition Class
AuthProviderDefinition Members
ININ.IceLib.Connection Namespace


AuthSettings Class

[image]

IceLib Technical Reference
AuthSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to authenticate a user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class AuthSettings : IDisposable
Visual Basic
Public MustInherit Class AuthSettings _
    Implements IDisposable

Remarks

Note
For more information on authenticating with IceLib see Authentication.
The AuthSettings object serves as a base class for objects that specify user authentication settings.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the AuthSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginAuthViewModel.cs, line 9, in LoginAuthViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..AlternateWindowsAuthSettings
ININ.IceLib.Connection.Extensions..::..ProxyAlternateWindowsAuthSettings
ININ.IceLib.Connection.Extensions..::..ProxyAuthSettings
ININ.IceLib.Connection.Extensions..::..ProxyWindowsAuthSettings
ININ.IceLib.Connection..::..ICAuthSettings
ININ.IceLib.Connection..::..SecurityTokenServiceAuthSettings
ININ.IceLib.Connection..::..WindowsAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


AuthSettings Members

[image] [image]

IceLib Technical Reference
AuthSettings Members
AuthSettings Class Constructors Methods See Also Send Feedback

The AuthSettings type exposes the following members.

Constructors

 | Name | Description
Protected method | AuthSettings | Initializes a new instance of the AuthSettings class with default settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this AuthSettings object.
Public method | Dispose()()()() | Releases all resources used by the AuthSettings.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

See Also

AuthSettings Class
ININ.IceLib.Connection Namespace


AuthSettings Constructor

[image]

IceLib Technical Reference
AuthSettings Constructor
AuthSettings Class See Also Send Feedback
Initializes a new instance of the AuthSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected AuthSettings()
Visual Basic
Protected Sub New

Remarks

This constructor is called by derived class constructors to initialize state in this type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthSettings Class
AuthSettings Members
ININ.IceLib.Connection Namespace


AuthSettings Methods

[image] [image]

IceLib Technical Reference
AuthSettings Methods
AuthSettings Class See Also Send Feedback

The AuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this AuthSettings object.
Public method | Dispose()()()() | Releases all resources used by the AuthSettings.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

See Also

AuthSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
AuthSettings..::..Clone Method
AuthSettings Class See Also Send Feedback
Returns an exact copy of this AuthSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract AuthSettings Clone()
Visual Basic
Public MustOverride Function Clone As AuthSettings

Return Value

A new AuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthSettings Class
AuthSettings Members
ININ.IceLib.Connection Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
AuthSettings..::..Dispose Method
AuthSettings Class See Also Send Feedback
Releases all resources used by the AuthSettings.

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the AuthSettings.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

See Also

AuthSettings Class
AuthSettings Members
ININ.IceLib.Connection Namespace


Dispose Method

[image]

IceLib Technical Reference
AuthSettings..::..Dispose Method
AuthSettings Class See Also Send Feedback
Releases all resources used by the AuthSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthSettings Class
AuthSettings Members
Dispose Overload
ININ.IceLib.Connection Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
AuthSettings..::..Dispose Method (Boolean)
AuthSettings Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthSettings Class
AuthSettings Members
Dispose Overload
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
AuthSettings..::..ToTrace Method
AuthSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual string ToTrace()
Visual Basic
Public Overridable Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AuthSettings Class
AuthSettings Members
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Class

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Class
Members See Also Send Feedback
Class used to provide input parameters for GetCachedAllowableAuthentications(CachedAllowableAuthenticationsParameters).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CachedAllowableAuthenticationsParameters
Visual Basic
Public Class CachedAllowableAuthenticationsParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..CachedAllowableAuthenticationsParameters

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Members

[image] [image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Members
CachedAllowableAuthenticationsParameters Class Constructors Methods Properties See Also Send Feedback

The CachedAllowableAuthenticationsParameters type exposes the following members.

Constructors

 | Name | Description
Public method | CachedAllowableAuthenticationsParameters(String) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.
Public method | CachedAllowableAuthenticationsParameters(String, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.
Public method | CachedAllowableAuthenticationsParameters(String, String) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.
Public method | CachedAllowableAuthenticationsParameters(String, String, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | HostName | Gets the name of the host used to look up the allowable authentications.
Public property | IsoLanguage | Gets the ISO culture name that will be used to localize display strings.
Public property | SupportedAuthenticationFields | Gets the supported authentication fields.

See Also

CachedAllowableAuthenticationsParameters Class
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Constructor

[image] [image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Constructor
CachedAllowableAuthenticationsParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CachedAllowableAuthenticationsParameters(String) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.
Public method | CachedAllowableAuthenticationsParameters(String, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.
Public method | CachedAllowableAuthenticationsParameters(String, String) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.
Public method | CachedAllowableAuthenticationsParameters(String, String, ICollection<(Of <<'(AuthenticationFields>)>>)) | Initializes a new instance of the CachedAllowableAuthenticationsParameters class.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Constructor (String)

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Constructor (String)
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the CachedAllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CachedAllowableAuthenticationsParameters(
    string hostName
)
Visual Basic
Public Sub New ( _
    hostName As String _
)

Parameters

hostName
Type: System..::..String
The name of the host used to look up the allowable authentications.

Exceptions

Exception | Condition
System..::..ArgumentNullException | hostName is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | hostName is Empty.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
CachedAllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Constructor (String, ICollection(AuthenticationFields))

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Constructor (String, ICollection<(Of <(<'AuthenticationFields>)>)>)
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the CachedAllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CachedAllowableAuthenticationsParameters(
    string hostName,
    ICollection<AuthenticationFields> supportedAuthenticationFields
)
Visual Basic
Public Sub New ( _
    hostName As String, _
    supportedAuthenticationFields As ICollection(Of AuthenticationFields) _
)

Parameters

hostName
Type: System..::..String
The name of the host used to look up the allowable authentications.
supportedAuthenticationFields
Type: System.Collections.Generic..::..ICollection<(Of <(<' AuthenticationFields >)>)>
The supported authentication fields.

Exceptions

Exception | Condition
System..::..ArgumentNullException | hostName is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | hostName is Empty.
System..::..ArgumentOutOfRangeException | supportedAuthenticationFields contains a value not part of the AuthenticationFields enum, or is None.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
CachedAllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Constructor (String, String)

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Constructor (String, String)
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the CachedAllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CachedAllowableAuthenticationsParameters(
    string hostName,
    string isoLanguage
)
Visual Basic
Public Sub New ( _
    hostName As String, _
    isoLanguage As String _
)

Parameters

hostName
Type: System..::..String
The name of the host used to look up the allowable authentications.
isoLanguage
Type: System..::..String
The ISO culture name that will be used to localize display strings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
CachedAllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Constructor (String, String, ICollection(AuthenticationFields))

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Constructor (String, String, ICollection<(Of <(<'AuthenticationFields>)>)>)
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Initializes a new instance of the CachedAllowableAuthenticationsParameters class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CachedAllowableAuthenticationsParameters(
    string hostName,
    string isoLanguage,
    ICollection<AuthenticationFields> supportedAuthenticationFields
)
Visual Basic
Public Sub New ( _
    hostName As String, _
    isoLanguage As String, _
    supportedAuthenticationFields As ICollection(Of AuthenticationFields) _
)

Parameters

hostName
Type: System..::..String
The name of the host used to look up the allowable authentications.
isoLanguage
Type: System..::..String
The ISO culture name that will be used to localize display strings.
supportedAuthenticationFields
Type: System.Collections.Generic..::..ICollection<(Of <(<' AuthenticationFields >)>)>
The supported authentication fields.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.
System..::..ArgumentOutOfRangeException | supportedAuthenticationFields contains a value not part of the AuthenticationFields enum, or is None.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
CachedAllowableAuthenticationsParameters Overload
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Methods

[image] [image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Methods
CachedAllowableAuthenticationsParameters Class See Also Send Feedback

The CachedAllowableAuthenticationsParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CachedAllowableAuthenticationsParameters Class
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters..::..ToString Method
CachedAllowableAuthenticationsParameters Class See Also Send Feedback

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


CachedAllowableAuthenticationsParameters Properties

[image] [image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters Properties
CachedAllowableAuthenticationsParameters Class See Also Send Feedback

The CachedAllowableAuthenticationsParameters type exposes the following members.

Properties

 | Name | Description
Public property | HostName | Gets the name of the host used to look up the allowable authentications.
Public property | IsoLanguage | Gets the ISO culture name that will be used to localize display strings.
Public property | SupportedAuthenticationFields | Gets the supported authentication fields.

See Also

CachedAllowableAuthenticationsParameters Class
ININ.IceLib.Connection Namespace


HostName Property

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters..::..HostName Property
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Gets the name of the host used to look up the allowable authentications.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HostName { get; private set; }
Visual Basic
Public Property HostName As String
    Get
    Private Set

Field Value

The name of the host used to look up the allowable authentications.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


IsoLanguage Property

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters..::..IsoLanguage Property
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Gets the ISO culture name that will be used to localize display strings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IsoLanguage { get; private set; }
Visual Basic
Public Property IsoLanguage As String
    Get
    Private Set

Field Value

The ISO culture name that will be used to localize display strings.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


SupportedAuthenticationFields Property

[image]

IceLib Technical Reference
CachedAllowableAuthenticationsParameters..::..SupportedAuthenticationFields Property
CachedAllowableAuthenticationsParameters Class See Also Send Feedback
Gets the supported authentication fields.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AuthenticationFields> SupportedAuthenticationFields { get; }
Visual Basic
Public ReadOnly Property SupportedAuthenticationFields As ReadOnlyCollection(Of AuthenticationFields)
    Get

Field Value

The supported authentication fields.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CachedAllowableAuthenticationsParameters Class
CachedAllowableAuthenticationsParameters Members
ININ.IceLib.Connection Namespace


ClassOfService Enumeration

[image]

IceLib Technical Reference
ClassOfService Enumeration
See Also Send Feedback
Specifies constants indicating what class of service a session supports.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ClassOfService
Visual Basic
Public Enumeration ClassOfService

Members

Member name | Value | Description
HighlyAvailable | 0 | The session connection is highly available.
General | 1 | The session connection has general availability.
SparselyAvailable | 2 | The session connection is sparsely available.

Remarks

This enumeration is used by SessionSettings to specify what class of service a session supports.

Terminated sessions purge shared server-side cache after roughly 3 minutes for HighlyAvailable and after roughly 30 minutes for other levels.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


CommonCredentials Class

[image]

IceLib Technical Reference
CommonCredentials Class
Members Example See Also Send Feedback
Offers a set of static methods that get or set credentials to or from the credential cache.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class CommonCredentials
Visual Basic
Public NotInheritable Class CommonCredentials

Remarks

This allows an application to create a session without prompting for credentials each time by using credentials that were previously saved.

Examples

The following example illustrates one way to store credentials using the CommonCredentials class.

CopyC#
... //Create a session and connect.

     //Connected successfully. Store the credentials so they can be used to login later.
     string applicationName = System.Diagnostics.Process.GetCurrentProcess().ProcessName;

     StoredCredentials credentials = new StoredCredentials(applicationName, _Session, true);
     CommonCredentials.SetCredentials(credentials, true);  //save these credentials and set them as the default set.
...

This example demonstrates how to load the most recently stored credentials between the defaults and those stored for this application.

CopyC#
...
    string applicationName = System.Diagnostics.Process.GetCurrentProcess().ProcessName;

    StoredCredentials credentials = CommonCredentials.GetCredentials(applicationName,
                                                                     LoadFlags.Default | LoadFlags.Application,
                                                                     LoadPreference.Newest);

    if ((null != credentials) && credentials.HasPersistedPassword)
    {
        _session.Connect(credentials.SessionSettings,
                     credentials.HostSettings,
                     credentials.AuthSettings,
                     credentials.StationSettings);
    }
    else
    {
        PromptUserForLogin();
    }
...

Examples

The IceLib SDK includes example application references to the CommonCredentials class. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 27, in LoginViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..CommonCredentials

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CommonCredentials Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..StoredCredentials


CommonCredentials Members

[image] [image]

IceLib Technical Reference
CommonCredentials Members
CommonCredentials Class Methods See Also Send Feedback

The CommonCredentials type exposes the following members.

Methods

Name | Description
GetCredentials()()()() | Gets the default stored credentials.
GetCredentials(String) | Gets the stored credentials for the specified application.
GetCredentials(String, LoadFlags, LoadPreference) | Gets the stored credentials for the specified application, given a set of acceptable credentials (Application, Default, etc.) and a preference as to which to try first.
SetCredentials | Persists the stored credentials for later retrieval.

See Also

CommonCredentials Class
ININ.IceLib.Connection Namespace


CommonCredentials Methods

[image] [image]

IceLib Technical Reference
CommonCredentials Methods
CommonCredentials Class See Also Send Feedback

The CommonCredentials type exposes the following members.

Methods

Name | Description
GetCredentials()()()() | Gets the default stored credentials.
GetCredentials(String) | Gets the stored credentials for the specified application.
GetCredentials(String, LoadFlags, LoadPreference) | Gets the stored credentials for the specified application, given a set of acceptable credentials (Application, Default, etc.) and a preference as to which to try first.
SetCredentials | Persists the stored credentials for later retrieval.

See Also

CommonCredentials Class
ININ.IceLib.Connection Namespace


GetCredentials Method

[image] [image]

IceLib Technical Reference
CommonCredentials..::..GetCredentials Method
CommonCredentials Class See Also Send Feedback
Retrieves credentials that were previously stored on the system.

Overload List

Name | Description
GetCredentials()()()() | Gets the default stored credentials.
GetCredentials(String) | Gets the stored credentials for the specified application.
GetCredentials(String, LoadFlags, LoadPreference) | Gets the stored credentials for the specified application, given a set of acceptable credentials (Application, Default, etc.) and a preference as to which to try first.

See Also

CommonCredentials Class
CommonCredentials Members
ININ.IceLib.Connection Namespace


GetCredentials Method

[image]

IceLib Technical Reference
CommonCredentials..::..GetCredentials Method
CommonCredentials Class Example See Also Send Feedback
Gets the default stored credentials.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StoredCredentials GetCredentials()
Visual Basic
Public Shared Function GetCredentials As StoredCredentials

Return Value

A StoredCredentials object representing all the credential information that was saved, or nullNothingnullptra null reference (Nothing in Visual Basic) if no credentials were found.

Examples

The IceLib SDK includes example application references to the GetCredentials method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 27, in LoginViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CommonCredentials Class
CommonCredentials Members
GetCredentials Overload
ININ.IceLib.Connection Namespace


GetCredentials Method (String)

[image]

IceLib Technical Reference
CommonCredentials..::..GetCredentials Method (String)
CommonCredentials Class See Also Send Feedback
Gets the stored credentials for the specified application.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StoredCredentials GetCredentials(
    string applicationName
)
Visual Basic
Public Shared Function GetCredentials ( _
    applicationName As String _
) As StoredCredentials

Parameters

applicationName
Type: System..::..String
The unique name of the application storing the credentials.

Return Value

The StoredCredentials object that was last saved under applicationName, or nullNothingnullptra null reference (Nothing in Visual Basic) if there are no credentials stored for that application.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CommonCredentials Class
CommonCredentials Members
GetCredentials Overload
ININ.IceLib.Connection Namespace


GetCredentials Method (String, LoadFlags, LoadPreference)

[image]

IceLib Technical Reference
CommonCredentials..::..GetCredentials Method (String, LoadFlags, LoadPreference)
CommonCredentials Class See Also Send Feedback
Gets the stored credentials for the specified application, given a set of acceptable credentials (Application, Default, etc.) and a preference as to which to try first.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StoredCredentials GetCredentials(
    string applicationName,
    LoadFlags acceptedCreds,
    LoadPreference preference
)
Visual Basic
Public Shared Function GetCredentials ( _
    applicationName As String, _
    acceptedCreds As LoadFlags, _
    preference As LoadPreference _
) As StoredCredentials

Parameters

applicationName
Type: System..::..String
The unique name of the application storing the credentials.
acceptedCreds
Type: ININ.IceLib.Connection..::..LoadFlags
One or more LoadFlags indicating which set of stored credentials are acceptable.
preference
Type: ININ.IceLib.Connection..::..LoadPreference
Used to specify the order in which to try and load the credentials.

Return Value

A StoredCredentials object from the specified set of accepted credentials, or nullNothingnullptra null reference (Nothing in Visual Basic) if there were no matches.

Remarks

If Newest is specified, the system will retrieve the most recently saved StoredCredentials object amongst those specified in acceptedCreds. If Application is specified, the system will search for a set of stored credentials using the following search order (records that are not indicated by acceptedCreds are ignored): 1. Credentials previously saved by the specified application. 2. The default set of stored credentials. 3. Any other stored credentials.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CommonCredentials Class
CommonCredentials Members
GetCredentials Overload
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..LoadFlags
ININ.IceLib.Connection..::..LoadPreference
ININ.IceLib.Connection..::..StoredCredentials


SetCredentials Method

[image]

IceLib Technical Reference
CommonCredentials..::..SetCredentials Method
CommonCredentials Class See Also Send Feedback
Persists the stored credentials for later retrieval.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void SetCredentials(
    StoredCredentials credentials,
    bool setAsDefault
)
Visual Basic
Public Shared Sub SetCredentials ( _
    credentials As StoredCredentials, _
    setAsDefault As Boolean _
)

Parameters

credentials
Type: ININ.IceLib.Connection..::..StoredCredentials
The credentials to save.
setAsDefault
Type: System..::..Boolean
Overwrite the existing default saved credentials. If setAsDefault is set to trueTruetruetrue (True in Visual Basic) the default credentials will be set to credentials, as will the credentials for the specified application. Otherwise, the saved credentials for applicationName will be set to credentials and the default will remain unchanged.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An argument was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CommonCredentials Class
CommonCredentials Members
ININ.IceLib.Connection Namespace


ConnectionState Enumeration

[image]

IceLib Technical Reference
ConnectionState Enumeration
Example See Also Send Feedback
Specifies constants indicating the state of a Session's connection.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ConnectionState
Visual Basic
Public Enumeration ConnectionState

Members

Member name | Value | Description
None | 0 | The session's connection does not exist.
Up | 1 | The session's connection is up.
Down | 2 | The session's connection is down.
Attempting | 3 | The session is attempting to re-establish a connection.

Remarks

This enumeration is used in conjunction with ConnectionStateReason by Session to specify the state of its connection.

The ConnectionState state machine looks like the following:

CopyC#
        /------\ <------------ /----\
        | Down |               | Up |
        \------/               \----/
          |  ^                  ^
          |  |                  |
          |  |   /--------------/
          V  |   |
o-----> /---------\
        | Attempt |
        \---------/

The following are connection states (followed by their transition symbols):

  • Up - (U)
  • Down - (D)
  • Attempting - (A)
  • None - (N)
The following are connection state reasons (followed by their applicable transitions):
  • Switchover - (U->D)
  • SessionTimeout - (U->D)
  • UserLogOff - (U->D)
  • LogOn - (N->A, A->U)
  • LogOnFailed - (A->D)
  • AnotherLogOn - (U->D)
  • StationDeactivated - (U->D)
  • StationDeleted - (U->D)
  • AdminLogoff - (U->D)
  • ServerNotResponding - (U->L, A->D, L->A, A->L)
  • None - (Initial state)

Examples

The following example demonstrates usage of a Session object.
CopyC#
using ININ.IceLib.Connection;

Session session = new Session();

... // Further processing

if (session.ConnectionState != ConnectionState.Up)
{
  // There is no active connection.
}

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Class

[image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Class
Members Example See Also Send Feedback
Provides data for the ConnectionStateChanged event.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConnectionStateChangedEventArgs : EventArgs
Visual Basic
Public Class ConnectionStateChangedEventArgs _
    Inherits EventArgs

Remarks

The ConnectionStateChangedEventArgs class contains properties that describe the ConnectionState change and the reason for the change.

Examples

The IceLib SDK includes example application references to the ConnectionStateChangedEventArgs class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 51, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 138, in StatisticCatalogViewModel.SessionConnectionStateChanged
 | UserRoleConfigurationViewModel.cs, line 150, in UserRoleConfigurationViewModel.SessionConnectionStateChanged
 | ConnectionViewModel.cs, line 186, in ConnectionViewModel.SessionConnectionStateChanged

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection..::..ConnectionStateChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConnectionStateChangedEventArgs Members
ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Members

[image] [image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Members
ConnectionStateChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ConnectionStateChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionStateChangedEventArgs(ConnectionState, ConnectionStateReason) | Initializes a new instance of the ConnectionStateChangedEventArgs class with the specified state and reason.
Public method | ConnectionStateChangedEventArgs(ConnectionState, ConnectionStateReason, String) | Initializes a new instance of the ConnectionStateChangedEventArgs class with the specified message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets the message associated with the connection state change.
Public property | Reason | Gets the new ConnectionStateReason.
Public property | State | Gets the new ConnectionState.

See Also

ConnectionStateChangedEventArgs Class
ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Constructor

[image] [image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Constructor
ConnectionStateChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the ConnectionStateChangedEventArgs class.

Overload List

 | Name | Description
Public method | ConnectionStateChangedEventArgs(ConnectionState, ConnectionStateReason) | Initializes a new instance of the ConnectionStateChangedEventArgs class with the specified state and reason.
Public method | ConnectionStateChangedEventArgs(ConnectionState, ConnectionStateReason, String) | Initializes a new instance of the ConnectionStateChangedEventArgs class with the specified message.

See Also

ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Members
ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Constructor (ConnectionState, ConnectionStateReason)

[image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Constructor (ConnectionState, ConnectionStateReason)
ConnectionStateChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the ConnectionStateChangedEventArgs class with the specified state and reason.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConnectionStateChangedEventArgs(
    ConnectionState state,
    ConnectionStateReason reason
)
Visual Basic
Public Sub New ( _
    state As ConnectionState, _
    reason As ConnectionStateReason _
)

Parameters

state
Type: ININ.IceLib.Connection..::..ConnectionState
The new connection state.
reason
Type: ININ.IceLib.Connection..::..ConnectionStateReason
The new connection state reason.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Members
ConnectionStateChangedEventArgs Overload
ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Constructor (ConnectionState, ConnectionStateReason, String)

[image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Constructor (ConnectionState, ConnectionStateReason, String)
ConnectionStateChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the ConnectionStateChangedEventArgs class with the specified message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConnectionStateChangedEventArgs(
    ConnectionState state,
    ConnectionStateReason reason,
    string message
)
Visual Basic
Public Sub New ( _
    state As ConnectionState, _
    reason As ConnectionStateReason, _
    message As String _
)

Parameters

state
Type: ININ.IceLib.Connection..::..ConnectionState
The new connection state.
reason
Type: ININ.IceLib.Connection..::..ConnectionStateReason
The new connection state reason.
message
Type: System..::..String
The message associated with the connection state change.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified value is not from the enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Members
ConnectionStateChangedEventArgs Overload
ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Methods
ConnectionStateChangedEventArgs Class See Also Send Feedback

The ConnectionStateChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectionStateChangedEventArgs Class
ININ.IceLib.Connection Namespace


ConnectionStateChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
ConnectionStateChangedEventArgs Properties
ConnectionStateChangedEventArgs Class See Also Send Feedback

The ConnectionStateChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the message associated with the connection state change.
Public property | Reason | Gets the new ConnectionStateReason.
Public property | State | Gets the new ConnectionState.

See Also

ConnectionStateChangedEventArgs Class
ININ.IceLib.Connection Namespace


Message Property

[image]

IceLib Technical Reference
ConnectionStateChangedEventArgs..::..Message Property
ConnectionStateChangedEventArgs Class See Also Send Feedback
Gets the message associated with the connection state change.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Field Value

The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Members
ININ.IceLib.Connection Namespace


Reason Property

[image]

IceLib Technical Reference
ConnectionStateChangedEventArgs..::..Reason Property
ConnectionStateChangedEventArgs Class See Also Send Feedback
Gets the new ConnectionStateReason.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConnectionStateReason Reason { get; }
Visual Basic
Public ReadOnly Property Reason As ConnectionStateReason
    Get

Field Value

The reason.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Members
ININ.IceLib.Connection Namespace


State Property

[image]

IceLib Technical Reference
ConnectionStateChangedEventArgs..::..State Property
ConnectionStateChangedEventArgs Class Example See Also Send Feedback
Gets the new ConnectionState.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConnectionState State { get; }
Visual Basic
Public ReadOnly Property State As ConnectionState
    Get

Field Value

The state.

Examples

The IceLib SDK includes example application references to the State property. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 52, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 139, in StatisticCatalogViewModel.SessionConnectionStateChanged
 | UserRoleConfigurationViewModel.cs, line 151, in UserRoleConfigurationViewModel.SessionConnectionStateChanged
 | ConnectionViewModel.cs, line 187, in ConnectionViewModel.SessionConnectionStateChanged

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConnectionStateChangedEventArgs Class
ConnectionStateChangedEventArgs Members
ININ.IceLib.Connection Namespace


ConnectionStateReason Enumeration

[image]

IceLib Technical Reference
ConnectionStateReason Enumeration
Example See Also Send Feedback
Specifies constants indicating the reason for the state of a Session's connection.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ConnectionStateReason
Visual Basic
Public Enumeration ConnectionStateReason

Members

Member name | Value | Description
None | 0 | There is no reason for the current connection state.
ServerNotResponding | 1 | The connection state is not up because the server is not responding.
LogOn | 2 | The connection state is attempting or up because a logon has been initiated.
LogOnFailed | 3 | The connection state is down because the logon attempt failed.
AdminLogOff | 4 | The connection state is down due to administrative action.
UserDeleted | 5 | The connection state is down due to administrative action.
StationDeleted | 6 | The connection state is down due to administrative action.
StationDeactivated | 7 | The connection state is down due to administrative action.
AnotherLogOn | 8 | The connection state is down due to a subsequent logon.
UserLogOff | 9 | The connection state is down because the user has logged off.
SessionTimeout | 10 | The connection state is down because the session has timed out.
Switchover | 11 | The connection state is down because a switchover has been initiated.

Remarks

This enumeration is used to indicate the reason for the Session's ConnectionState.

Examples

The following example demonstrates usage of a Session object.
CopyC#
using ININ.IceLib.Connection;

Session session = new Session();

... // Further processing

if ((session.ConnectionState == ConnectionState.Down) && (session.ConnectionStateReason == ConnectionStateReason.LogOnFailed))
{
  // The login attempt failed.
}

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


CustomFormAuthScriptableClass Class

[image]

IceLib Technical Reference
CustomFormAuthScriptableClass Class
Members See Also Send Feedback
The class to be used as the ObjectForScripting for a web browser control when using Single Sign On with an that uses .

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ComVisibleAttribute(true)]
public class CustomFormAuthScriptableClass
Visual Basic
<ComVisibleAttribute(True)> _
Public Class CustomFormAuthScriptableClass

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..CustomFormAuthScriptableClass

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CustomFormAuthScriptableClass Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..AuthProviderDefinition
AuthenticationFields..::..Browser


CustomFormAuthScriptableClass Members

[image] [image]

IceLib Technical Reference
CustomFormAuthScriptableClass Members
CustomFormAuthScriptableClass Class Methods Events See Also Send Feedback

The CustomFormAuthScriptableClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | RequestBrowserClose | Occurs to request the browser window to be closed once the Single Sign On authentication has completed.

See Also

CustomFormAuthScriptableClass Class
ININ.IceLib.Connection Namespace


CustomFormAuthScriptableClass Methods

[image] [image]

IceLib Technical Reference
CustomFormAuthScriptableClass Methods
CustomFormAuthScriptableClass Class See Also Send Feedback

The CustomFormAuthScriptableClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomFormAuthScriptableClass Class
ININ.IceLib.Connection Namespace


CustomFormAuthScriptableClass Events

[image] [image]

IceLib Technical Reference
CustomFormAuthScriptableClass Events
CustomFormAuthScriptableClass Class See Also Send Feedback

The CustomFormAuthScriptableClass type exposes the following members.

Events

 | Name | Description
Public event | RequestBrowserClose | Occurs to request the browser window to be closed once the Single Sign On authentication has completed.

See Also

CustomFormAuthScriptableClass Class
ININ.IceLib.Connection Namespace


RequestBrowserClose Event

[image]

IceLib Technical Reference
CustomFormAuthScriptableClass..::..RequestBrowserClose Event
CustomFormAuthScriptableClass Class See Also Send Feedback
Occurs to request the browser window to be closed once the Single Sign On authentication has completed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler RequestBrowserClose
Visual Basic
Public Event RequestBrowserClose As EventHandler

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

CustomFormAuthScriptableClass Class
CustomFormAuthScriptableClass Members
ININ.IceLib.Connection Namespace


DeviceType Enumeration

[image]

IceLib Technical Reference
DeviceType Enumeration
See Also Send Feedback
Specifies constants indicating what type of device is establishing a session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum DeviceType
Visual Basic
Public Enumeration DeviceType

Members

Member name | Value | Description
General | 0 | The device details cannot be identified.
Win32 | 1 | The device is using Win32.
PocketPC | 2 | The device is using PocketPC.
Web | 3 | The device is a web page.
Phone | 4 | The device is a phone interface.
Sip | 5 | The device is a Sip phone interface.
Linux | 6 | The device is using Linux.
Mac | 7 | The device is a Mac.

Remarks

This enumeration is used by SessionSettings to specify what type of device is establishing a session.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


EffectiveStationChangedEventArgs Class

[image]

IceLib Technical Reference
EffectiveStationChangedEventArgs Class
Members See Also Send Feedback
Provides data for the EffectiveStationChanged event.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EffectiveStationChangedEventArgs : EventArgs
Visual Basic
Public Class EffectiveStationChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection..::..EffectiveStationChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EffectiveStationChangedEventArgs Members
ININ.IceLib.Connection Namespace


EffectiveStationChangedEventArgs Members

[image] [image]

IceLib Technical Reference
EffectiveStationChangedEventArgs Members
EffectiveStationChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The EffectiveStationChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EffectiveStationChangedEventArgs | Initializes a new instance of the EffectiveStationChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EffectiveStation | Gets the effective station.
Public property | UserId | Gets the user ID.

See Also

EffectiveStationChangedEventArgs Class
ININ.IceLib.Connection Namespace


EffectiveStationChangedEventArgs Constructor

[image]

IceLib Technical Reference
EffectiveStationChangedEventArgs Constructor
EffectiveStationChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the EffectiveStationChangedEventArgs class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EffectiveStationChangedEventArgs(
    string userId,
    string effectiveStation
)
Visual Basic
Public Sub New ( _
    userId As String, _
    effectiveStation As String _
)

Parameters

userId
Type: System..::..String
The user ID.
effectiveStation
Type: System..::..String
The effective station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EffectiveStationChangedEventArgs Class
EffectiveStationChangedEventArgs Members
ININ.IceLib.Connection Namespace


EffectiveStationChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
EffectiveStationChangedEventArgs Methods
EffectiveStationChangedEventArgs Class See Also Send Feedback

The EffectiveStationChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EffectiveStationChangedEventArgs Class
ININ.IceLib.Connection Namespace


EffectiveStationChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
EffectiveStationChangedEventArgs Properties
EffectiveStationChangedEventArgs Class See Also Send Feedback

The EffectiveStationChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | EffectiveStation | Gets the effective station.
Public property | UserId | Gets the user ID.

See Also

EffectiveStationChangedEventArgs Class
ININ.IceLib.Connection Namespace


EffectiveStation Property

[image]

IceLib Technical Reference
EffectiveStationChangedEventArgs..::..EffectiveStation Property
EffectiveStationChangedEventArgs Class See Also Send Feedback
Gets the effective station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EffectiveStation { get; private set; }
Visual Basic
Public Property EffectiveStation As String
    Get
    Private Set

Field Value

The effective station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EffectiveStationChangedEventArgs Class
EffectiveStationChangedEventArgs Members
ININ.IceLib.Connection Namespace


UserId Property

[image]

IceLib Technical Reference
EffectiveStationChangedEventArgs..::..UserId Property
EffectiveStationChangedEventArgs Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; private set; }
Visual Basic
Public Property UserId As String
    Get
    Private Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EffectiveStationChangedEventArgs Class
EffectiveStationChangedEventArgs Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenCompletedEventArgs Class

[image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed event of GetAuthenticationTokenAsync(EventHandler<(Of <<'(GetAuthenticationTokenCompletedEventArgs>)>>), Object).

Note: This class is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetAuthenticationTokenCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetAuthenticationTokenCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection..::..GetAuthenticationTokenCompletedEventArgs

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenCompletedEventArgs Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs Members
GetAuthenticationTokenCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetAuthenticationTokenCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetAuthenticationTokenCompletedEventArgs | Initializes a new instance of the GetAuthenticationTokenCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuthenticationToken | Gets the authentication token.
Public property | AuthenticationTokenSeed | Gets the authentication token seed.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAuthenticationTokenCompletedEventArgs Class
ININ.IceLib.Connection Namespace


GetAuthenticationTokenCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs Constructor
GetAuthenticationTokenCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetAuthenticationTokenCompletedEventArgs class.

Note: This constructor is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetAuthenticationTokenCompletedEventArgs(
    string authenticationToken,
    Guid authenticationTokenSeed,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    authenticationToken As String, _
    authenticationTokenSeed As Guid, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

authenticationToken
Type: System..::..String
The authentication token.
authenticationTokenSeed
Type: System..::..Guid
The authentication token seed.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenCompletedEventArgs Class
GetAuthenticationTokenCompletedEventArgs Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs Methods
GetAuthenticationTokenCompletedEventArgs Class See Also Send Feedback

The GetAuthenticationTokenCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAuthenticationTokenCompletedEventArgs Class
ININ.IceLib.Connection Namespace


GetAuthenticationTokenCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs Properties
GetAuthenticationTokenCompletedEventArgs Class See Also Send Feedback

The GetAuthenticationTokenCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AuthenticationToken | Gets the authentication token.
Public property | AuthenticationTokenSeed | Gets the authentication token seed.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAuthenticationTokenCompletedEventArgs Class
ININ.IceLib.Connection Namespace


AuthenticationToken Property

[image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs..::..AuthenticationToken Property
GetAuthenticationTokenCompletedEventArgs Class See Also Send Feedback
Gets the authentication token.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AuthenticationToken { get; }
Visual Basic
Public ReadOnly Property AuthenticationToken As String
    Get

Field Value

The authentication token.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenCompletedEventArgs Class
GetAuthenticationTokenCompletedEventArgs Members
ININ.IceLib.Connection Namespace


AuthenticationTokenSeed Property

[image]

IceLib Technical Reference
GetAuthenticationTokenCompletedEventArgs..::..AuthenticationTokenSeed Property
GetAuthenticationTokenCompletedEventArgs Class See Also Send Feedback
Gets the authentication token seed.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Guid AuthenticationTokenSeed { get; }
Visual Basic
Public ReadOnly Property AuthenticationTokenSeed As Guid
    Get

Field Value

The authentication token seed.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenCompletedEventArgs Class
GetAuthenticationTokenCompletedEventArgs Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenResult Class

[image]

IceLib Technical Reference
GetAuthenticationTokenResult Class
Members See Also Send Feedback
Provides return data for the GetAuthenticationToken()()()() method.

Note: This class is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetAuthenticationTokenResult
Visual Basic
Public Class GetAuthenticationTokenResult

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..GetAuthenticationTokenResult

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenResult Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenResult Members

[image] [image]

IceLib Technical Reference
GetAuthenticationTokenResult Members
GetAuthenticationTokenResult Class Constructors Methods Properties See Also Send Feedback

The GetAuthenticationTokenResult type exposes the following members.

Constructors

 | Name | Description
Public method | GetAuthenticationTokenResult | Initializes a new instance of the GetAuthenticationTokenResult class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuthenticationToken | Gets the authentication token.
Public property | AuthenticationTokenSeed | Gets the authentication token seed.

See Also

GetAuthenticationTokenResult Class
ININ.IceLib.Connection Namespace


GetAuthenticationTokenResult Constructor

[image]

IceLib Technical Reference
GetAuthenticationTokenResult Constructor
GetAuthenticationTokenResult Class See Also Send Feedback
Initializes a new instance of the GetAuthenticationTokenResult class.

Note: This constructor is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetAuthenticationTokenResult(
    string authenticationToken,
    Guid authenticationTokenSeed
)
Visual Basic
Public Sub New ( _
    authenticationToken As String, _
    authenticationTokenSeed As Guid _
)

Parameters

authenticationToken
Type: System..::..String
The authentication token.
authenticationTokenSeed
Type: System..::..Guid
The authentication token seed.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenResult Class
GetAuthenticationTokenResult Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenResult Methods

[image] [image]

IceLib Technical Reference
GetAuthenticationTokenResult Methods
GetAuthenticationTokenResult Class See Also Send Feedback

The GetAuthenticationTokenResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAuthenticationTokenResult Class
ININ.IceLib.Connection Namespace


GetAuthenticationTokenResult Properties

[image] [image]

IceLib Technical Reference
GetAuthenticationTokenResult Properties
GetAuthenticationTokenResult Class See Also Send Feedback

The GetAuthenticationTokenResult type exposes the following members.

Properties

 | Name | Description
Public property | AuthenticationToken | Gets the authentication token.
Public property | AuthenticationTokenSeed | Gets the authentication token seed.

See Also

GetAuthenticationTokenResult Class
ININ.IceLib.Connection Namespace


AuthenticationToken Property

[image]

IceLib Technical Reference
GetAuthenticationTokenResult..::..AuthenticationToken Property
GetAuthenticationTokenResult Class See Also Send Feedback
Gets the authentication token.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AuthenticationToken { get; private set; }
Visual Basic
Public Property AuthenticationToken As String
    Get
    Private Set

Field Value

The authentication token.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenResult Class
GetAuthenticationTokenResult Members
ININ.IceLib.Connection Namespace


AuthenticationTokenSeed Property

[image]

IceLib Technical Reference
GetAuthenticationTokenResult..::..AuthenticationTokenSeed Property
GetAuthenticationTokenResult Class See Also Send Feedback
Gets the authentication token seed.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Guid AuthenticationTokenSeed { get; private set; }
Visual Basic
Public Property AuthenticationTokenSeed As Guid
    Get
    Private Set

Field Value

The authentication token seed.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

GetAuthenticationTokenResult Class
GetAuthenticationTokenResult Members
ININ.IceLib.Connection Namespace


HostEndpoint Class

[image]

IceLib Technical Reference
HostEndpoint Class
Members Example See Also Send Feedback
Represents an endpoint for BridgeHost connections.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HostEndpoint
Visual Basic
Public Class HostEndpoint

Remarks

This is used by the HostSettings class to specify an endpoint (i.e. BridgeHost) for the Session to use when attempting a connection.

Note
BridgeHost is the connector between thin clients and the Session Manager. It translates network protocols, socket-level security checking, and other tasks during a thin client-to-Session Manager exchange.

Examples

CopyC#
HostEndpoint hostEndpoint = new HostEndpoint("MyBridgeHostServer");
HostSettings hostSettings = new HostSettings(hostEndpoint);
Session session = new Session();
session.Connect(..., hostSettings, ...);

Examples

The IceLib SDK includes example application references to the HostEndpoint class. Some examples are listed below.
Project | Location
TutorialExample | LoginHostViewModel.cs, line 30, in LoginHostViewModel.CreateHostSettings
 | LoginHostViewModel.cs, line 20, in LoginHostViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..HostEndpoint

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Members
ININ.IceLib.Connection Namespace


HostEndpoint Members

[image] [image]

IceLib Technical Reference
HostEndpoint Members
HostEndpoint Class Constructors Methods Fields Properties See Also Send Feedback

The HostEndpoint type exposes the following members.

Constructors

 | Name | Description
Public method | HostEndpoint()()()() | Initializes a new instance of the HostEndpoint class with default settings.
Public method | HostEndpoint(String) | Initializes a new instance of the HostEndpoint class with the specified host.
Public method | HostEndpoint(String, Int32) | Initializes a new instance of the HostEndpoint class with the specified host and port.
Public method | HostEndpoint(String, Int32, Boolean) | Initializes a new instance of the HostEndpoint class with the specified host and port and adds a reference to itself as the only resolved endpoint.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this HostEndpoint object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
DefaultHost | Represents the default Host. This field is read-only.
DefaultPort | Represents the default Port. This field is read-only.

Properties

 | Name | Description
Public property | Host | Gets or sets the Host.
Public property | HostDisplayString | Gets the host display string.
Public property | Port | Gets or sets the Port.

See Also

HostEndpoint Class
ININ.IceLib.Connection Namespace


HostEndpoint Constructor

[image] [image]

IceLib Technical Reference
HostEndpoint Constructor
HostEndpoint Class See Also Send Feedback
Initializes a new instance of the HostEndpoint class.

Overload List

 | Name | Description
Public method | HostEndpoint()()()() | Initializes a new instance of the HostEndpoint class with default settings.
Public method | HostEndpoint(String) | Initializes a new instance of the HostEndpoint class with the specified host.
Public method | HostEndpoint(String, Int32) | Initializes a new instance of the HostEndpoint class with the specified host and port.
Public method | HostEndpoint(String, Int32, Boolean) | Initializes a new instance of the HostEndpoint class with the specified host and port and adds a reference to itself as the only resolved endpoint.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


HostEndpoint Constructor

[image]

IceLib Technical Reference
HostEndpoint Constructor
HostEndpoint Class See Also Send Feedback
Initializes a new instance of the HostEndpoint class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostEndpoint()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
HostEndpoint Overload
ININ.IceLib.Connection Namespace


HostEndpoint Constructor (String)

[image]

IceLib Technical Reference
HostEndpoint Constructor (String)
HostEndpoint Class Example See Also Send Feedback
Initializes a new instance of the HostEndpoint class with the specified host.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostEndpoint(
    string host
)
Visual Basic
Public Sub New ( _
    host As String _
)

Parameters

host
Type: System..::..String
The host to connect to.

Remarks

The host will attempt to be parsed for the [host]:[port] format. The port will default to DefaultPort if not set.

Examples

The IceLib SDK includes example application references to the HostEndpoint constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginHostViewModel.cs, line 30, in LoginHostViewModel.CreateHostSettings

Exceptions

Exception | Condition
System..::..ArgumentException | The host parameter string is empty.
System..::..ArgumentNullException | The host parameter string is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
HostEndpoint Overload
ININ.IceLib.Connection Namespace


HostEndpoint Constructor (String, Int32)

[image]

IceLib Technical Reference
HostEndpoint Constructor (String, Int32)
HostEndpoint Class See Also Send Feedback
Initializes a new instance of the HostEndpoint class with the specified host and port.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostEndpoint(
    string host,
    int port
)
Visual Basic
Public Sub New ( _
    host As String, _
    port As Integer _
)

Parameters

host
Type: System..::..String
The host to connect to.
port
Type: System..::..Int32
The port to connect with.

Remarks

The host will attempt to be parsed for the [host]:[port] format. If the port is not found in this format, it will be set by the port parameter.

Exceptions

Exception | Condition
System..::..ArgumentException | The host parameter string is empty.
System..::..ArgumentNullException | The host parameter string is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The port parameter is less than 1 or greater than 65535.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
HostEndpoint Overload
ININ.IceLib.Connection Namespace


HostEndpoint Constructor (String, Int32, Boolean)

[image]

IceLib Technical Reference
HostEndpoint Constructor (String, Int32, Boolean)
HostEndpoint Class See Also Send Feedback
Initializes a new instance of the HostEndpoint class with the specified host and port and adds a reference to itself as the only resolved endpoint.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostEndpoint(
    string host,
    int port,
    bool resolveToSelf
)
Visual Basic
Public Sub New ( _
    host As String, _
    port As Integer, _
    resolveToSelf As Boolean _
)

Parameters

host
Type: System..::..String
The host.
port
Type: System..::..Int32
The port.
resolveToSelf
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), resolve to self.

Remarks

This constructor may be used to initialize an instance of HostEndpoint that is known to resolve only to itself. Since ResolveEndpoint()()()() uses network-bound DNS operations, it is advantageous to create self-resolving endpoints when possible to reduce unnecessary network overhead.

This also serves to limit the number of unique instances of HostEndpoint.

Exceptions

Exception | Condition
System..::..ArgumentException | The host parameter string is empty.
System..::..ArgumentNullException | The host parameter string is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The port parameter is less than 1 or greater than 65535.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
HostEndpoint Overload
ININ.IceLib.Connection Namespace


HostEndpoint Fields

[image] [image]

IceLib Technical Reference
HostEndpoint Fields
HostEndpoint Class See Also Send Feedback

The HostEndpoint type exposes the following members.

Fields

Name | Description
DefaultHost | Represents the default Host. This field is read-only.
DefaultPort | Represents the default Port. This field is read-only.

See Also

HostEndpoint Class
ININ.IceLib.Connection Namespace


DefaultHost Field

[image]

IceLib Technical Reference
HostEndpoint..::..DefaultHost Field
HostEndpoint Class See Also Send Feedback
Represents the default Host. This field is read-only.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DefaultHost
Visual Basic
Public Shared ReadOnly DefaultHost As String

Remarks

If the Host property is set to this value, then the default BridgeHost host will be used.

Retrieves the default host server stored in the registry. It will first look in HKEY_CURRENT_USER\Software\Interactive Intelligence\EIC\BridgeHost in the default key. Then if that is blank it will look in the same place under HKEY_LOCAL_MACHINE. Finally, if that is also blank, it defaults to i3ClientSrv. It is recommended that sites create a DNS alias to their BridgeHost server with that name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


DefaultPort Field

[image]

IceLib Technical Reference
HostEndpoint..::..DefaultPort Field
HostEndpoint Class See Also Send Feedback
Represents the default Port. This field is read-only.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int DefaultPort
Visual Basic
Public Const DefaultPort As Integer

Remarks

If the Port property is set to this value, then the default BridgeHost port will be used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


HostEndpoint Methods

[image] [image]

IceLib Technical Reference
HostEndpoint Methods
HostEndpoint Class See Also Send Feedback

The HostEndpoint type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this HostEndpoint object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

HostEndpoint Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
HostEndpoint..::..Clone Method
HostEndpoint Class See Also Send Feedback
Returns an exact copy of this HostEndpoint object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual HostEndpoint Clone()
Visual Basic
Public Overridable Function Clone As HostEndpoint

Return Value

A new HostEndpoint object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


Equals Method

[image]

IceLib Technical Reference
HostEndpoint..::..Equals Method
HostEndpoint Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


GetHashCode Method

[image]

IceLib Technical Reference
HostEndpoint..::..GetHashCode Method
HostEndpoint Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
HostEndpoint..::..ToString Method
HostEndpoint Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


HostEndpoint Properties

[image] [image]

IceLib Technical Reference
HostEndpoint Properties
HostEndpoint Class See Also Send Feedback

The HostEndpoint type exposes the following members.

Properties

 | Name | Description
Public property | Host | Gets or sets the Host.
Public property | HostDisplayString | Gets the host display string.
Public property | Port | Gets or sets the Port.

See Also

HostEndpoint Class
ININ.IceLib.Connection Namespace


Host Property

[image]

IceLib Technical Reference
HostEndpoint..::..Host Property
HostEndpoint Class Example See Also Send Feedback
Gets or sets the Host.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Host { get; set; }
Visual Basic
Public Property Host As String
    Get
    Set

Field Value

The host.

Remarks

This property specifies the host to connect to. The default is DefaultHost. Setting this property will attempt to parsed for the [host]:[port] format. If the port is not specified in this format, it remains unchanged from what it was previously.

Examples

The IceLib SDK includes example application references to the Host property. Some examples are listed below.
Project | Location
TutorialExample | LoginHostViewModel.cs, line 20, in LoginHostViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentException | The host string is empty.
System..::..ArgumentNullException | The host string is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


HostDisplayString Property

[image]

IceLib Technical Reference
HostEndpoint..::..HostDisplayString Property
HostEndpoint Class See Also Send Feedback
Gets the host display string.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HostDisplayString { get; }
Visual Basic
Public ReadOnly Property HostDisplayString As String
    Get

Field Value

The host display string.

Remarks

This value can be used as a display value for the Host, and will include the Port value, if set.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


Port Property

[image]

IceLib Technical Reference
HostEndpoint..::..Port Property
HostEndpoint Class See Also Send Feedback
Gets or sets the Port.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Port { get; set; }
Visual Basic
Public Property Port As Integer
    Get
    Set

Field Value

The port.

Remarks

The default is DefaultPort.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The port value is less than 1 or greater than 65535.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostEndpoint Class
HostEndpoint Members
ININ.IceLib.Connection Namespace


HostSettings Class

[image]

IceLib Technical Reference
HostSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to specify a host (i.e. IC server).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HostSettings
Visual Basic
Public Class HostSettings

Remarks

The HostSettings object is used to specify a HostEndpoint (i.e. IC server) for the Session to use when attempting a connection.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the HostSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginHostViewModel.cs, line 9, in LoginHostViewModel.#ctor
 | LoginHostViewModel.cs, line 31, in LoginHostViewModel.CreateHostSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..HostSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


HostSettings Members

[image] [image]

IceLib Technical Reference
HostSettings Members
HostSettings Class Constructors Methods Properties See Also Send Feedback

The HostSettings type exposes the following members.

Constructors

 | Name | Description
Public method | HostSettings()()()() | Initializes a new instance of the HostSettings class with default settings.
Public method | HostSettings(HostEndpoint) | Initializes a new instance of the HostSettings class with the specified host.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this HostSettings object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | HostEndpoint | Gets or sets the HostEndpoint.
Public property | IgnoreAlternateServerList | If set to trueTruetruetrue (True in Visual Basic), Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) will not try any alternate servers when connecting to the IC server specified by these HostSettings. Defaults to falseFalsefalsefalse (False in Visual Basic).

See Also

HostSettings Class
ININ.IceLib.Connection Namespace


HostSettings Constructor

[image] [image]

IceLib Technical Reference
HostSettings Constructor
HostSettings Class See Also Send Feedback
Initializes a new instance of the HostSettings class.

Overload List

 | Name | Description
Public method | HostSettings()()()() | Initializes a new instance of the HostSettings class with default settings.
Public method | HostSettings(HostEndpoint) | Initializes a new instance of the HostSettings class with the specified host.

See Also

HostSettings Class
HostSettings Members
ININ.IceLib.Connection Namespace


HostSettings Constructor

[image]

IceLib Technical Reference
HostSettings Constructor
HostSettings Class See Also Send Feedback
Initializes a new instance of the HostSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Class
HostSettings Members
HostSettings Overload
ININ.IceLib.Connection Namespace


HostSettings Constructor (HostEndpoint)

[image]

IceLib Technical Reference
HostSettings Constructor (HostEndpoint)
HostSettings Class Example See Also Send Feedback
Initializes a new instance of the HostSettings class with the specified host.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostSettings(
    HostEndpoint hostEndpoint
)
Visual Basic
Public Sub New ( _
    hostEndpoint As HostEndpoint _
)

Parameters

hostEndpoint
Type: ININ.IceLib.Connection..::..HostEndpoint
The host to connect to.

Examples

The IceLib SDK includes example application references to the HostSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginHostViewModel.cs, line 31, in LoginHostViewModel.CreateHostSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Class
HostSettings Members
HostSettings Overload
ININ.IceLib.Connection Namespace


HostSettings Methods

[image] [image]

IceLib Technical Reference
HostSettings Methods
HostSettings Class See Also Send Feedback

The HostSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this HostSettings object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

HostSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
HostSettings..::..Clone Method
HostSettings Class See Also Send Feedback
Returns an exact copy of this HostSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostSettings Clone()
Visual Basic
Public Function Clone As HostSettings

Return Value

A new HostSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Class
HostSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
HostSettings..::..ToString Method
HostSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Class
HostSettings Members
ININ.IceLib.Connection Namespace


HostSettings Properties

[image] [image]

IceLib Technical Reference
HostSettings Properties
HostSettings Class See Also Send Feedback

The HostSettings type exposes the following members.

Properties

 | Name | Description
Public property | HostEndpoint | Gets or sets the HostEndpoint.
Public property | IgnoreAlternateServerList | If set to trueTruetruetrue (True in Visual Basic), Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) will not try any alternate servers when connecting to the IC server specified by these HostSettings. Defaults to falseFalsefalsefalse (False in Visual Basic).

See Also

HostSettings Class
ININ.IceLib.Connection Namespace


HostEndpoint Property

[image]

IceLib Technical Reference
HostSettings..::..HostEndpoint Property
HostSettings Class Example See Also Send Feedback
Gets or sets the HostEndpoint.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostEndpoint HostEndpoint { get; set; }
Visual Basic
Public Property HostEndpoint As HostEndpoint
    Get
    Set

Field Value

The host endpoint.

Remarks

This property specifies the HostEndpoint to connect to.

Examples

The IceLib SDK includes example application references to the HostEndpoint property. Some examples are listed below.
Project | Location
TutorialExample | LoginHostViewModel.cs, line 20, in LoginHostViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | The value being set is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Class
HostSettings Members
ININ.IceLib.Connection Namespace


IgnoreAlternateServerList Property

[image]

IceLib Technical Reference
HostSettings..::..IgnoreAlternateServerList Property
HostSettings Class See Also Send Feedback
If set to trueTruetruetrue (True in Visual Basic), Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) will not try any alternate servers when connecting to the IC server specified by these HostSettings. Defaults to falseFalsefalsefalse (False in Visual Basic).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IgnoreAlternateServerList { get; set; }
Visual Basic
Public Property IgnoreAlternateServerList As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic), if the list of alternate servers should be ignored.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HostSettings Class
HostSettings Members
ININ.IceLib.Connection Namespace


ICAuthSettings Class

[image]

IceLib Technical Reference
ICAuthSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to authenticate an Interaction Center user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ICAuthSettings : AuthSettings
Visual Basic
Public Class ICAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.
The ICAuthSettings object is used to specify Interaction Center user authentication settings. This is used when an IC username and password should be used to authenticate the user requesting a Session.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the ICAuthSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginAuthViewModel.cs, line 25, in LoginAuthViewModel.#ctor
 | LoginAuthViewModel.cs, line 42, in LoginAuthViewModel.CreateAuthSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..ICAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


ICAuthSettings Members

[image] [image]

IceLib Technical Reference
ICAuthSettings Members
ICAuthSettings Class Constructors Methods Properties See Also Send Feedback

The ICAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ICAuthSettings()()()() | Initializes a new instance of the ICAuthSettings class with default settings.
Public method | ICAuthSettings(String, SecureString) | Initializes a new instance of the ICAuthSettings class with user settings.
Public method | ICAuthSettings(String, String) | Initializes a new instance of the ICAuthSettings class with user settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this ICAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Inherited from AuthSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

Properties

 | Name | Description
Public property | Password | Sets the Interaction Center password.
Public property | SecurePassword | Sets the Interaction Center password.
Public property | UserName | Gets or sets the Interaction Center userName.

See Also

ICAuthSettings Class
ININ.IceLib.Connection Namespace


ICAuthSettings Constructor

[image] [image]

IceLib Technical Reference
ICAuthSettings Constructor
ICAuthSettings Class See Also Send Feedback
Initializes a new instance of the ICAuthSettings class.

Overload List

 | Name | Description
Public method | ICAuthSettings()()()() | Initializes a new instance of the ICAuthSettings class with default settings.
Public method | ICAuthSettings(String, SecureString) | Initializes a new instance of the ICAuthSettings class with user settings.
Public method | ICAuthSettings(String, String) | Initializes a new instance of the ICAuthSettings class with user settings.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


ICAuthSettings Constructor

[image]

IceLib Technical Reference
ICAuthSettings Constructor
ICAuthSettings Class See Also Send Feedback
Initializes a new instance of the ICAuthSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICAuthSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ICAuthSettings Overload
ININ.IceLib.Connection Namespace


ICAuthSettings Constructor (String, SecureString)

[image]

IceLib Technical Reference
ICAuthSettings Constructor (String, SecureString)
ICAuthSettings Class See Also Send Feedback
Initializes a new instance of the ICAuthSettings class with user settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICAuthSettings(
    string userName,
    SecureString password
)
Visual Basic
Public Sub New ( _
    userName As String, _
    password As SecureString _
)

Parameters

userName
Type: System..::..String
The Interaction Center user name.
password
Type: System.Security..::..SecureString
The Interaction Center password.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ICAuthSettings Overload
ININ.IceLib.Connection Namespace


ICAuthSettings Constructor (String, String)

[image]

IceLib Technical Reference
ICAuthSettings Constructor (String, String)
ICAuthSettings Class Example See Also Send Feedback
Initializes a new instance of the ICAuthSettings class with user settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICAuthSettings(
    string userName,
    string password
)
Visual Basic
Public Sub New ( _
    userName As String, _
    password As String _
)

Parameters

userName
Type: System..::..String
The Interaction Center user name.
password
Type: System..::..String
The Interaction Center password.

Examples

The IceLib SDK includes example application references to the ICAuthSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginAuthViewModel.cs, line 42, in LoginAuthViewModel.CreateAuthSettings

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ICAuthSettings Overload
ININ.IceLib.Connection Namespace


ICAuthSettings Methods

[image] [image]

IceLib Technical Reference
ICAuthSettings Methods
ICAuthSettings Class See Also Send Feedback

The ICAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this ICAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Inherited from AuthSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

See Also

ICAuthSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
ICAuthSettings..::..Clone Method
ICAuthSettings Class See Also Send Feedback
Returns an exact copy of this ICAuthSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new ICAuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
ICAuthSettings..::..ToString Method
ICAuthSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
ICAuthSettings..::..ToTrace Method
ICAuthSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToTrace()
Visual Basic
Public Overrides Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


ICAuthSettings Properties

[image] [image]

IceLib Technical Reference
ICAuthSettings Properties
ICAuthSettings Class See Also Send Feedback

The ICAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | Password | Sets the Interaction Center password.
Public property | SecurePassword | Sets the Interaction Center password.
Public property | UserName | Gets or sets the Interaction Center userName.

See Also

ICAuthSettings Class
ININ.IceLib.Connection Namespace


Password Property

[image]

IceLib Technical Reference
ICAuthSettings..::..Password Property
ICAuthSettings Class See Also Send Feedback
Sets the Interaction Center password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Password { internal get; set; }
Visual Basic
Public Property Password As String
    Friend Get
    Set

Field Value

The password.

Remarks

Note: There is intentionally no public getter for this property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


SecurePassword Property

[image]

IceLib Technical Reference
ICAuthSettings..::..SecurePassword Property
ICAuthSettings Class See Also Send Feedback
Sets the Interaction Center password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureString SecurePassword { internal get; set; }
Visual Basic
Public Property SecurePassword As SecureString
    Friend Get
    Set

Field Value

The password.

Remarks

Note: There is intentionally no public getter for this property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


UserName Property

[image]

IceLib Technical Reference
ICAuthSettings..::..UserName Property
ICAuthSettings Class Example See Also Send Feedback
Gets or sets the Interaction Center userName.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

Field Value

The name of the user.

Examples

The IceLib SDK includes example application references to the UserName property. Some examples are listed below.
Project | Location
TutorialExample | LoginAuthViewModel.cs, line 29, in LoginAuthViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICAuthSettings Class
ICAuthSettings Members
ININ.IceLib.Connection Namespace


IceLibConnectionException Class

[image]

IceLib Technical Reference
IceLibConnectionException Class
Members See Also Send Feedback
The exception that is thrown when an attempt to connect to an IC server has failed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class IceLibConnectionException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class IceLibConnectionException _
    Inherits IceLibException

Remarks

This exception is thrown when attempting to establish a connection to an IC server has failed.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Please refer to IceLibConnectionExceptionTypes for a list of possible error types.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Connection..::..IceLibConnectionException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Members
ININ.IceLib.Connection Namespace


IceLibConnectionException Members

[image] [image]

IceLib Technical Reference
IceLibConnectionException Members
IceLibConnectionException Class Constructors Methods Properties Events See Also Send Feedback

The IceLibConnectionException type exposes the following members.

Constructors

 | Name | Description
Public method | IceLibConnectionException(Int32) | Initializes a new instance of the IceLibConnectionException class with default settings.
Public method | IceLibConnectionException(Int32, Exception) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Public method | IceLibConnectionException(Int32, CultureInfo) | Initializes a new instance of the IceLibConnectionException class with default settings.
Public method | IceLibConnectionException(Int32, String) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Public method | IceLibConnectionException(Int32, CultureInfo, Exception) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Protected method | IceLibConnectionException(Int32, SerializationInfo, StreamingContext) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Public method | IceLibConnectionException(Int32, String, Exception) | Initializes a new instance of the IceLibConnectionException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | ConnectionErrorType | Gets the value for the type of error.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibConnectionException Class
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor

[image] [image]

IceLib Technical Reference
IceLibConnectionException Constructor
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class.

Overload List

 | Name | Description
Public method | IceLibConnectionException(Int32) | Initializes a new instance of the IceLibConnectionException class with default settings.
Public method | IceLibConnectionException(Int32, Exception) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Public method | IceLibConnectionException(Int32, CultureInfo) | Initializes a new instance of the IceLibConnectionException class with default settings.
Public method | IceLibConnectionException(Int32, String) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Public method | IceLibConnectionException(Int32, CultureInfo, Exception) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Protected method | IceLibConnectionException(Int32, SerializationInfo, StreamingContext) | Initializes a new instance of the IceLibConnectionException class with a specified error message.
Public method | IceLibConnectionException(Int32, String, Exception) | Initializes a new instance of the IceLibConnectionException class with a specified error message.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibConnectionException(
    int icelibConnectionExceptionType
)
Visual Basic
Public Sub New ( _
    icelibConnectionExceptionType As Integer _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32, Exception)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32, Exception)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibConnectionException(
    int icelibConnectionExceptionType,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    icelibConnectionExceptionType As Integer, _
    innerException As Exception _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32, CultureInfo)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32, CultureInfo)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibConnectionException(
    int icelibConnectionExceptionType,
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    icelibConnectionExceptionType As Integer, _
    cultureInfo As CultureInfo _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.
cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32, String)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32, String)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibConnectionException(
    int icelibConnectionExceptionType,
    string message
)
Visual Basic
Public Sub New ( _
    icelibConnectionExceptionType As Integer, _
    message As String _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.
message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32, CultureInfo, Exception)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32, CultureInfo, Exception)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibConnectionException(
    int icelibConnectionExceptionType,
    CultureInfo cultureInfo,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    icelibConnectionExceptionType As Integer, _
    cultureInfo As CultureInfo, _
    innerException As Exception _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.
cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32, SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32, SerializationInfo, StreamingContext)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IceLibConnectionException(
    int icelibConnectionExceptionType,
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    icelibConnectionExceptionType As Integer, _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.
info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Constructor (Int32, String, Exception)

[image]

IceLib Technical Reference
IceLibConnectionException Constructor (Int32, String, Exception)
IceLibConnectionException Class See Also Send Feedback
Initializes a new instance of the IceLibConnectionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IceLibConnectionException(
    int icelibConnectionExceptionType,
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    icelibConnectionExceptionType As Integer, _
    message As String, _
    innerException As Exception _
)

Parameters

icelibConnectionExceptionType
Type: System..::..Int32
The type of the connection exception.
message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
IceLibConnectionException Overload
ININ.IceLib.Connection Namespace


IceLibConnectionException Methods

[image] [image]

IceLib Technical Reference
IceLibConnectionException Methods
IceLibConnectionException Class See Also Send Feedback

The IceLibConnectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IceLibConnectionException Class
ININ.IceLib.Connection Namespace


GetObjectData Method

[image]

IceLib Technical Reference
IceLibConnectionException..::..GetObjectData Method
IceLibConnectionException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
ININ.IceLib.Connection Namespace


IceLibConnectionException Properties

[image] [image]

IceLib Technical Reference
IceLibConnectionException Properties
IceLibConnectionException Class See Also Send Feedback

The IceLibConnectionException type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionErrorType | Gets the value for the type of error.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IceLibConnectionException Class
ININ.IceLib.Connection Namespace


ConnectionErrorType Property

[image]

IceLib Technical Reference
IceLibConnectionException..::..ConnectionErrorType Property
IceLibConnectionException Class See Also Send Feedback
Gets the value for the type of error.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ConnectionErrorType { get; internal set; }
Visual Basic
Public Property ConnectionErrorType As Integer
    Get
    Friend Set

Field Value

The error type.

Remarks

Please refer to the IceLibConnectionExceptionTypes class for more information on the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionException Class
IceLibConnectionException Members
ININ.IceLib.Connection Namespace


IceLibConnectionException Events

[image] [image]

IceLib Technical Reference
IceLibConnectionException Events
IceLibConnectionException Class See Also Send Feedback

The IceLibConnectionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IceLibConnectionException Class
ININ.IceLib.Connection Namespace


IceLibConnectionExceptionTypes Class

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes Class
Members See Also Send Feedback
This class is used by IceLibConnectionException to provide more information about the type of error.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class IceLibConnectionExceptionTypes
Visual Basic
Public NotInheritable Class IceLibConnectionExceptionTypes

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..IceLibConnectionExceptionTypes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


IceLibConnectionExceptionTypes Members

[image] [image]

IceLib Technical Reference
IceLibConnectionExceptionTypes Members
IceLibConnectionExceptionTypes Class Fields See Also Send Feedback

The IceLibConnectionExceptionTypes type exposes the following members.

Fields

Name | Description
AccessDenied | The specified user or station does not have sufficient rights to perform the requested action.
AlernateWindowsAuthDisabled | Alternate windows authentication is disabled.
Authentication | There was an error authenticating the username and/or password.
ConnectionRefused | The connection was actively refused by the socket.
Fail | There was a catastrophic failure during the connection process.
HostNameResolutionError | The specified host name could not be resolved.
ICAuthDisabled | IC authentication is disabled.
IntegratedWindowsAuthDisabled | Windows authentication is disabled.
InvalidParameterValues | There were invalid parameters for the connect request.
InvalidSessionId | The Session ID is invalid.
LoginTimeout | The login request exceeded the timeout period.
NoRights | The required rights are unavailable.
NoServerFound | There was no server found.
RemoteAtLocal | Local logins to remote stations are not permitted.
RequiredLicenseNotAssigned | The license required to perform the requested operation is unavailable.
ServerTooBusy | The server is currently too busy to accept a new session.
SessionRefusedBy | The session has been refused by the server.
Socket | A non-specific socket error occurred.
SocketConnectionTimedOut | The connection attempt timed out, or the connected host has failed to respond.
StationInactive | The specified station is marked inactive.
UnknownStation | The specified station is not known.
UnknownUser | The specified user name is not known.
Unspecified | An unknown error occurred.

See Also

IceLibConnectionExceptionTypes Class
ININ.IceLib.Connection Namespace


IceLibConnectionExceptionTypes Fields

[image] [image]

IceLib Technical Reference
IceLibConnectionExceptionTypes Fields
IceLibConnectionExceptionTypes Class See Also Send Feedback

The IceLibConnectionExceptionTypes type exposes the following members.

Fields

Name | Description
AccessDenied | The specified user or station does not have sufficient rights to perform the requested action.
AlernateWindowsAuthDisabled | Alternate windows authentication is disabled.
Authentication | There was an error authenticating the username and/or password.
ConnectionRefused | The connection was actively refused by the socket.
Fail | There was a catastrophic failure during the connection process.
HostNameResolutionError | The specified host name could not be resolved.
ICAuthDisabled | IC authentication is disabled.
IntegratedWindowsAuthDisabled | Windows authentication is disabled.
InvalidParameterValues | There were invalid parameters for the connect request.
InvalidSessionId | The Session ID is invalid.
LoginTimeout | The login request exceeded the timeout period.
NoRights | The required rights are unavailable.
NoServerFound | There was no server found.
RemoteAtLocal | Local logins to remote stations are not permitted.
RequiredLicenseNotAssigned | The license required to perform the requested operation is unavailable.
ServerTooBusy | The server is currently too busy to accept a new session.
SessionRefusedBy | The session has been refused by the server.
Socket | A non-specific socket error occurred.
SocketConnectionTimedOut | The connection attempt timed out, or the connected host has failed to respond.
StationInactive | The specified station is marked inactive.
UnknownStation | The specified station is not known.
UnknownUser | The specified user name is not known.
Unspecified | An unknown error occurred.

See Also

IceLibConnectionExceptionTypes Class
ININ.IceLib.Connection Namespace


AccessDenied Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..AccessDenied Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The specified user or station does not have sufficient rights to perform the requested action.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int AccessDenied
Visual Basic
Public Const AccessDenied As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


AlernateWindowsAuthDisabled Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..AlernateWindowsAuthDisabled Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
Alternate windows authentication is disabled.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int AlernateWindowsAuthDisabled
Visual Basic
Public Const AlernateWindowsAuthDisabled As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


Authentication Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..Authentication Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
There was an error authenticating the username and/or password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int Authentication
Visual Basic
Public Const Authentication As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


ConnectionRefused Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..ConnectionRefused Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The connection was actively refused by the socket.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int ConnectionRefused
Visual Basic
Public Const ConnectionRefused As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


Fail Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..Fail Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
There was a catastrophic failure during the connection process.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int Fail
Visual Basic
Public Const Fail As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


HostNameResolutionError Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..HostNameResolutionError Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The specified host name could not be resolved.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int HostNameResolutionError
Visual Basic
Public Const HostNameResolutionError As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


ICAuthDisabled Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..ICAuthDisabled Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
IC authentication is disabled.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int ICAuthDisabled
Visual Basic
Public Const ICAuthDisabled As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


IntegratedWindowsAuthDisabled Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..IntegratedWindowsAuthDisabled Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
Windows authentication is disabled.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int IntegratedWindowsAuthDisabled
Visual Basic
Public Const IntegratedWindowsAuthDisabled As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


InvalidParameterValues Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..InvalidParameterValues Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
There were invalid parameters for the connect request.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int InvalidParameterValues
Visual Basic
Public Const InvalidParameterValues As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


InvalidSessionId Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..InvalidSessionId Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The Session ID is invalid.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int InvalidSessionId
Visual Basic
Public Const InvalidSessionId As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


LoginTimeout Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..LoginTimeout Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The login request exceeded the timeout period.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int LoginTimeout
Visual Basic
Public Const LoginTimeout As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


NoRights Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..NoRights Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The required rights are unavailable.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int NoRights
Visual Basic
Public Const NoRights As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


NoServerFound Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..NoServerFound Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
There was no server found.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int NoServerFound
Visual Basic
Public Const NoServerFound As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


RemoteAtLocal Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..RemoteAtLocal Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
Local logins to remote stations are not permitted.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int RemoteAtLocal
Visual Basic
Public Const RemoteAtLocal As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


RequiredLicenseNotAssigned Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..RequiredLicenseNotAssigned Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The license required to perform the requested operation is unavailable.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int RequiredLicenseNotAssigned
Visual Basic
Public Const RequiredLicenseNotAssigned As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


ServerTooBusy Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..ServerTooBusy Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The server is currently too busy to accept a new session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int ServerTooBusy
Visual Basic
Public Const ServerTooBusy As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


SessionRefusedBy Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..SessionRefusedBy Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The session has been refused by the server.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int SessionRefusedBy
Visual Basic
Public Const SessionRefusedBy As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


Socket Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..Socket Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
A non-specific socket error occurred.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int Socket
Visual Basic
Public Const Socket As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


SocketConnectionTimedOut Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..SocketConnectionTimedOut Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The connection attempt timed out, or the connected host has failed to respond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int SocketConnectionTimedOut
Visual Basic
Public Const SocketConnectionTimedOut As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


StationInactive Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..StationInactive Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The specified station is marked inactive.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int StationInactive
Visual Basic
Public Const StationInactive As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


UnknownStation Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..UnknownStation Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The specified station is not known.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int UnknownStation
Visual Basic
Public Const UnknownStation As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


UnknownUser Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..UnknownUser Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
The specified user name is not known.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int UnknownUser
Visual Basic
Public Const UnknownUser As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


Unspecified Field

[image]

IceLib Technical Reference
IceLibConnectionExceptionTypes..::..Unspecified Field
IceLibConnectionExceptionTypes Class See Also Send Feedback
An unknown error occurred.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int Unspecified
Visual Basic
Public Const Unspecified As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

IceLibConnectionExceptionTypes Class
IceLibConnectionExceptionTypes Members
ININ.IceLib.Connection Namespace


InvalidServerVersionException Class

[image]

IceLib Technical Reference
InvalidServerVersionException Class
Members See Also Send Feedback
The exception that is thrown when an attempt was made to connect to an IC server with an incompatible IceLib version.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class InvalidServerVersionException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class InvalidServerVersionException _
    Inherits IceLibException

Remarks

This exception is thrown when attempting to establish a connection to an IC server from an incompatible IceLib version.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Connection..::..InvalidServerVersionException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Members
ININ.IceLib.Connection Namespace


InvalidServerVersionException Members

[image] [image]

IceLib Technical Reference
InvalidServerVersionException Members
InvalidServerVersionException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidServerVersionException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidServerVersionException()()()() | Initializes a new instance of the InvalidServerVersionException class with default settings.
Public method | InvalidServerVersionException(Exception) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Public method | InvalidServerVersionException(CultureInfo) | Initializes a new instance of the InvalidServerVersionException class with default settings.
Public method | InvalidServerVersionException(String) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Public method | InvalidServerVersionException(CultureInfo, Exception) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Protected method | InvalidServerVersionException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Public method | InvalidServerVersionException(String, Exception) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidServerVersionException Class
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor

[image] [image]

IceLib Technical Reference
InvalidServerVersionException Constructor
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class.

Overload List

 | Name | Description
Public method | InvalidServerVersionException()()()() | Initializes a new instance of the InvalidServerVersionException class with default settings.
Public method | InvalidServerVersionException(Exception) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Public method | InvalidServerVersionException(CultureInfo) | Initializes a new instance of the InvalidServerVersionException class with default settings.
Public method | InvalidServerVersionException(String) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Public method | InvalidServerVersionException(CultureInfo, Exception) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Protected method | InvalidServerVersionException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.
Public method | InvalidServerVersionException(String, Exception) | Initializes a new instance of the InvalidServerVersionException class with a specified error message.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidServerVersionException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor (Exception)

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor (Exception)
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidServerVersionException(
    Exception innerException
)
Visual Basic
Public Sub New ( _
    innerException As Exception _
)

Parameters

innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor (CultureInfo)

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor (CultureInfo)
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidServerVersionException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor (String)

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor (String)
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidServerVersionException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor (CultureInfo, Exception)

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor (CultureInfo, Exception)
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidServerVersionException(
    CultureInfo cultureInfo,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor (SerializationInfo, StreamingContext)
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected InvalidServerVersionException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Constructor (String, Exception)

[image]

IceLib Technical Reference
InvalidServerVersionException Constructor (String, Exception)
InvalidServerVersionException Class See Also Send Feedback
Initializes a new instance of the InvalidServerVersionException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvalidServerVersionException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
InvalidServerVersionException Overload
ININ.IceLib.Connection Namespace


InvalidServerVersionException Methods

[image] [image]

IceLib Technical Reference
InvalidServerVersionException Methods
InvalidServerVersionException Class See Also Send Feedback

The InvalidServerVersionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidServerVersionException Class
ININ.IceLib.Connection Namespace


GetObjectData Method

[image]

IceLib Technical Reference
InvalidServerVersionException..::..GetObjectData Method
InvalidServerVersionException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InvalidServerVersionException Class
InvalidServerVersionException Members
ININ.IceLib.Connection Namespace


InvalidServerVersionException Properties

[image] [image]

IceLib Technical Reference
InvalidServerVersionException Properties
InvalidServerVersionException Class See Also Send Feedback

The InvalidServerVersionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidServerVersionException Class
ININ.IceLib.Connection Namespace


InvalidServerVersionException Events

[image] [image]

IceLib Technical Reference
InvalidServerVersionException Events
InvalidServerVersionException Class See Also Send Feedback

The InvalidServerVersionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidServerVersionException Class
ININ.IceLib.Connection Namespace


LoadFlags Enumeration

[image]

IceLib Technical Reference
LoadFlags Enumeration
See Also Send Feedback
This bitmask is used specify which credentials to load from the set of credentials that have been stored.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum LoadFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration LoadFlags

Members

Member name | Value | Description
None | 0 | No load flags were specified.
Default | 1 | Indicates the default stored credentials.
Application | 2 | Indicates the stored credentials for the specified application.
OtherApplications | 4 | Indicates the stored credentials for applications other than the specified application.
Any | 7 | Represents all the stored credentials.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


LoadPreference Enumeration

[image]

IceLib Technical Reference
LoadPreference Enumeration
See Also Send Feedback
Used to specify the order in which to try and retrieve stored credentials.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LoadPreference
Visual Basic
Public Enumeration LoadPreference

Members

Member name | Value | Description
None | 0 | No load preference was identified.
Newest | 1 | Attempt to load the newest record first.
Application | 2 | Attempt to load the record associated with the specified application first.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


ReadyForInteractionsType Enumeration

[image]

IceLib Technical Reference
ReadyForInteractionsType Enumeration
See Also Send Feedback
Specifies constants indicating at what time the application is ready to make or receive Interactions.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum ReadyForInteractionsType
Visual Basic
<FlagsAttribute> _
Public Enumeration ReadyForInteractionsType

Members

Member name | Value | Description
None | 0 | The application will be free to decide when it is ready to make or take Interactions.
AfterLogin | 1 | The application will be ready 8 seconds after login completes successfully.
AfterChangeStation | 2 | The application will be ready immediately after ChangeStation(StationSettings) completes successfully.

Remarks

If None is specified, the application will have to explicitly call SetReadyForInteractions()()()() when it is ready to receive Interactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

ININ.IceLib.Connection Namespace


RemoteFileHelper Class

[image]

IceLib Technical Reference
RemoteFileHelper Class
Members See Also Send Feedback
Utility class for transferring personal storage files.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RemoteFileHelper
Visual Basic
Public Class RemoteFileHelper

Remarks

This helper class transfers personal storage files between local and remote locations. This is also used by IceLib for UnifiedMessaging operations involving Voicemail and Fax.

Examples

CopyC#
// This assumes a pre-existing session and local file.
RemoteFileHelper remoteFileHelper = new RemoteFileHelper(session);
string remoteFileName = remoteFileHelper.NewRemoteFileName(ServerFileType.Other);
remoteFileHelper.UploadFile(localFileName, remoteFileName);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..RemoteFileHelper

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Members
ININ.IceLib.Connection Namespace


RemoteFileHelper Members

[image] [image]

IceLib Technical Reference
RemoteFileHelper Members
RemoteFileHelper Class Constructors Methods Events See Also Send Feedback

The RemoteFileHelper type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteFileHelper | Initializes a new instance of the RemoteFileHelper class.

Methods

 | Name | Description
Public method | CancelDownload | Cancels a current file download (based on the unique remote file name).
Public method | CancelUpload | Cancels a current file upload (based on the unique remote file name).
Public method | DownloadFile(String, BinaryWriter, Object) | Downloads a remote file and saves it to the specified stream.
Public method | DownloadFile(String, String, Object) | Downloads a remote file and saves it to the specified local location.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLocalCacheFileName | Creates an empty temporary file in the local cache's temp directory.
 | NewLocalFileName | Creates an empty temporary file in the local temp directory.
 | NewRemoteFileName | Generates a valid and unique path and file name suitable for uploading to PersonalStorage on the server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UploadFile(String, String) | Uploads a local file into the specified remote location, without performing audio codec conversion.
Public method | UploadFile(String, BinaryReader, Object) | Uploads a stream into the specified remote location, without performing audio codec conversion.
Public method | UploadFile(String, String, Boolean) | Uploads a local file into the specified remote location.
Public method | UploadFile(String, BinaryReader, Boolean, Object) | Uploads a stream into the specified remote location.

Events

 | Name | Description
Public event | DownloadProgressChanged | Occurs when the progress level changes for a downloading file.
Public event | UploadProgressChanged | Occurs when the progress level changes for an uploading file.

See Also

RemoteFileHelper Class
ININ.IceLib.Connection Namespace


RemoteFileHelper Constructor

[image]

IceLib Technical Reference
RemoteFileHelper Constructor
RemoteFileHelper Class See Also Send Feedback
Initializes a new instance of the RemoteFileHelper class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RemoteFileHelper(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


RemoteFileHelper Methods

[image] [image]

IceLib Technical Reference
RemoteFileHelper Methods
RemoteFileHelper Class See Also Send Feedback

The RemoteFileHelper type exposes the following members.

Methods

 | Name | Description
Public method | CancelDownload | Cancels a current file download (based on the unique remote file name).
Public method | CancelUpload | Cancels a current file upload (based on the unique remote file name).
Public method | DownloadFile(String, BinaryWriter, Object) | Downloads a remote file and saves it to the specified stream.
Public method | DownloadFile(String, String, Object) | Downloads a remote file and saves it to the specified local location.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLocalCacheFileName | Creates an empty temporary file in the local cache's temp directory.
 | NewLocalFileName | Creates an empty temporary file in the local temp directory.
 | NewRemoteFileName | Generates a valid and unique path and file name suitable for uploading to PersonalStorage on the server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UploadFile(String, String) | Uploads a local file into the specified remote location, without performing audio codec conversion.
Public method | UploadFile(String, BinaryReader, Object) | Uploads a stream into the specified remote location, without performing audio codec conversion.
Public method | UploadFile(String, String, Boolean) | Uploads a local file into the specified remote location.
Public method | UploadFile(String, BinaryReader, Boolean, Object) | Uploads a stream into the specified remote location.

See Also

RemoteFileHelper Class
ININ.IceLib.Connection Namespace


CancelDownload Method

[image]

IceLib Technical Reference
RemoteFileHelper..::..CancelDownload Method
RemoteFileHelper Class See Also Send Feedback
Cancels a current file download (based on the unique remote file name).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelDownload(
    string remoteFileName
)
Visual Basic
Public Sub CancelDownload ( _
    remoteFileName As String _
)

Parameters

remoteFileName
Type: System..::..String
The unique server file name to cancel from downloading.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A file name parameter had 0-length.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


CancelUpload Method

[image]

IceLib Technical Reference
RemoteFileHelper..::..CancelUpload Method
RemoteFileHelper Class See Also Send Feedback
Cancels a current file upload (based on the unique remote file name).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelUpload(
    string remoteFileName
)
Visual Basic
Public Sub CancelUpload ( _
    remoteFileName As String _
)

Parameters

remoteFileName
Type: System..::..String
The unique server file name to cancel from uploading.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A file name parameter had 0-length.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


DownloadFile Method

[image] [image]

IceLib Technical Reference
RemoteFileHelper..::..DownloadFile Method
RemoteFileHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DownloadFile(String, BinaryWriter, Object) | Downloads a remote file and saves it to the specified stream.
Public method | DownloadFile(String, String, Object) | Downloads a remote file and saves it to the specified local location.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


DownloadFile Method (String, BinaryWriter, Object)

[image]

IceLib Technical Reference
RemoteFileHelper..::..DownloadFile Method (String, BinaryWriter, Object)
RemoteFileHelper Class See Also Send Feedback
Downloads a remote file and saves it to the specified stream.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DownloadFile(
    string remoteFileName,
    BinaryWriter writer,
    Object userState
)
Visual Basic
Public Function DownloadFile ( _
    remoteFileName As String, _
    writer As BinaryWriter, _
    userState As Object _
) As Boolean

Parameters

remoteFileName
Type: System..::..String
The remote file name.
writer
Type: System.IO..::..BinaryWriter
The writer.
userState
Type: System..::..Object
An object representing state for all events fired during this operation.

Return Value

trueTruetruetrue (True in Visual Basic) if the file was fully downloaded, falseFalsefalsefalse (False in Visual Basic) if the download was cancelled.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A file name parameter had 0-length.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
DownloadFile Overload
ININ.IceLib.Connection Namespace


DownloadFile Method (String, String, Object)

[image]

IceLib Technical Reference
RemoteFileHelper..::..DownloadFile Method (String, String, Object)
RemoteFileHelper Class See Also Send Feedback
Downloads a remote file and saves it to the specified local location.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DownloadFile(
    string remoteFileName,
    string localFileName,
    Object userState
)
Visual Basic
Public Function DownloadFile ( _
    remoteFileName As String, _
    localFileName As String, _
    userState As Object _
) As Boolean

Parameters

remoteFileName
Type: System..::..String
The remote file name.
localFileName
Type: System..::..String
The local file name.
userState
Type: System..::..Object
An object representing state for all events fired during this operation.

Return Value

trueTruetruetrue (True in Visual Basic) if the file was fully downloaded, falseFalsefalsefalse (False in Visual Basic) if the download was cancelled.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A file name parameter had 0-length.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
DownloadFile Overload
ININ.IceLib.Connection Namespace


NewLocalCacheFileName Method

[image]

IceLib Technical Reference
RemoteFileHelper..::..NewLocalCacheFileName Method
RemoteFileHelper Class See Also Send Feedback
Creates an empty temporary file in the local cache's temp directory.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string NewLocalCacheFileName(
    Session session
)
Visual Basic
Public Shared Function NewLocalCacheFileName ( _
    session As Session _
) As String

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Return Value

The full path to the created temporary file.

Remarks

NOTE: The returned file name has been created with zero size. Do not attempt to create a new file with the same name, as it will fail.

This requires that the Windows user executing the application have a loaded profile.

Exceptions

Exception | Condition
System.IO..::..IOException | The file could not be created. Check the temporary directory permissions, and verify that there is enough free disk space.
System..::..ArgumentNullException | session is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


NewLocalFileName Method

[image]

IceLib Technical Reference
RemoteFileHelper..::..NewLocalFileName Method
RemoteFileHelper Class See Also Send Feedback
Creates an empty temporary file in the local temp directory.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string NewLocalFileName()
Visual Basic
Public Shared Function NewLocalFileName As String

Return Value

The full path to the created temporary file.

Remarks

NOTE: The returned file name has been created with zero size. Do not attempt to create a new file with the same name, as it will fail.

If access to the Windows temporary folder is not allowed, use NewLocalCacheFileName(Session) instead, to use the local IceLib cache folder. Note that this would require that the Windows user executing the application has a loaded profile.

Exceptions

Exception | Condition
System.IO..::..IOException | The file could not be created. Check the TMP, TEMP, and USERPROFILE environment variables, the temporary directory permissions, and verify that there is enough free disk space.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


NewRemoteFileName Method

[image]

IceLib Technical Reference
RemoteFileHelper..::..NewRemoteFileName Method
RemoteFileHelper Class See Also Send Feedback
Generates a valid and unique path and file name suitable for uploading to PersonalStorage on the server.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string NewRemoteFileName(
    ServerFileType serverFileType
)
Visual Basic
Public Shared Function NewRemoteFileName ( _
    serverFileType As ServerFileType _
) As String

Parameters

serverFileType
Type: ININ.IceLib.Connection..::..ServerFileType
ServerFileType that is used to determine destination directory.

Return Value

Path name to use for uploading a file of type "ServerFileType". This file is not created by default (unlike NewLocalFileName()()()()).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


UploadFile Method

[image] [image]

IceLib Technical Reference
RemoteFileHelper..::..UploadFile Method
RemoteFileHelper Class See Also Send Feedback
Uploads a local file into the specified remote location.

Overload List

 | Name | Description
Public method | UploadFile(String, String) | Uploads a local file into the specified remote location, without performing audio codec conversion.
Public method | UploadFile(String, BinaryReader, Object) | Uploads a stream into the specified remote location, without performing audio codec conversion.
Public method | UploadFile(String, String, Boolean) | Uploads a local file into the specified remote location.
Public method | UploadFile(String, BinaryReader, Boolean, Object) | Uploads a stream into the specified remote location.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


UploadFile Method (String, String)

[image]

IceLib Technical Reference
RemoteFileHelper..::..UploadFile Method (String, String)
RemoteFileHelper Class See Also Send Feedback
Uploads a local file into the specified remote location, without performing audio codec conversion.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool UploadFile(
    string localFileName,
    string remoteFileName
)
Visual Basic
Public Function UploadFile ( _
    localFileName As String, _
    remoteFileName As String _
) As Boolean

Parameters

localFileName
Type: System..::..String
The local file name.
remoteFileName
Type: System..::..String
The remote file name.

Return Value

trueTruetruetrue (True in Visual Basic) if the upload succeeded, falseFalsefalsefalse (False in Visual Basic) if it was cancelled.

Remarks

Note that some types of server files are periodically purged for space reasons, so an uploaded file may not exist for all time in the future.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A file name parameter had 0-length.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
UploadFile Overload
ININ.IceLib.Connection Namespace


UploadFile Method (String, BinaryReader, Object)

[image]

IceLib Technical Reference
RemoteFileHelper..::..UploadFile Method (String, BinaryReader, Object)
RemoteFileHelper Class See Also Send Feedback
Uploads a stream into the specified remote location, without performing audio codec conversion.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool UploadFile(
    string remoteFileName,
    BinaryReader reader,
    Object userState
)
Visual Basic
Public Function UploadFile ( _
    remoteFileName As String, _
    reader As BinaryReader, _
    userState As Object _
) As Boolean

Parameters

remoteFileName
Type: System..::..String
The remote file name.
reader
Type: System.IO..::..BinaryReader
The reader.
userState
Type: System..::..Object
An object representing state for all events fired during this operation.

Return Value

trueTruetruetrue (True in Visual Basic) if the upload succeeded, falseFalsefalsefalse (False in Visual Basic) if it was cancelled.

Remarks

Note that some types of server files are periodically purged for space reasons, so an uploaded file may not exist for all time in the future.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The remoteFileNameThe request timed out while waiting for a response.The Session does not have a valid connection.The Session has been disposed. length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
UploadFile Overload
ININ.IceLib.Connection Namespace


UploadFile Method (String, String, Boolean)

[image]

IceLib Technical Reference
RemoteFileHelper..::..UploadFile Method (String, String, Boolean)
RemoteFileHelper Class See Also Send Feedback
Uploads a local file into the specified remote location.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool UploadFile(
    string localFileName,
    string remoteFileName,
    bool convertAudio
)
Visual Basic
Public Function UploadFile ( _
    localFileName As String, _
    remoteFileName As String, _
    convertAudio As Boolean _
) As Boolean

Parameters

localFileName
Type: System..::..String
The local file name.
remoteFileName
Type: System..::..String
The remote file name.
convertAudio
Type: System..::..Boolean
Convert to acceptable audio format. If falseFalsefalsefalse (False in Visual Basic), audio playback of this file may fail.

Return Value

trueTruetruetrue (True in Visual Basic) if the upload succeeded, falseFalsefalsefalse (False in Visual Basic) if it was cancelled.

Remarks

Note that some types of server files are periodically purged for space reasons, so an uploaded file may not exist for all time in the future.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A file name parameter had 0-length.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
UploadFile Overload
ININ.IceLib.Connection Namespace


UploadFile Method (String, BinaryReader, Boolean, Object)

[image]

IceLib Technical Reference
RemoteFileHelper..::..UploadFile Method (String, BinaryReader, Boolean, Object)
RemoteFileHelper Class See Also Send Feedback
Uploads a stream into the specified remote location.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool UploadFile(
    string remoteFileName,
    BinaryReader reader,
    bool convertAudio,
    Object userState
)
Visual Basic
Public Function UploadFile ( _
    remoteFileName As String, _
    reader As BinaryReader, _
    convertAudio As Boolean, _
    userState As Object _
) As Boolean

Parameters

remoteFileName
Type: System..::..String
The remote file name.
reader
Type: System.IO..::..BinaryReader
The reader.
convertAudio
Type: System..::..Boolean
Convert to acceptable audio format. If falseFalsefalsefalse (False in Visual Basic), audio playback of this file may fail.
userState
Type: System..::..Object
An object representing state for all events fired during this operation.

Return Value

trueTruetruetrue (True in Visual Basic) if the upload succeeded, falseFalsefalsefalse (False in Visual Basic) if it was cancelled.

Remarks

Note that some types of server files are periodically purged for space reasons, so an uploaded file may not exist for all time in the future.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The remoteFileNameThe request timed out while waiting for a response.The Session does not have a valid connection.The Session has been disposed. length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
UploadFile Overload
ININ.IceLib.Connection Namespace


RemoteFileHelper Events

[image] [image]

IceLib Technical Reference
RemoteFileHelper Events
RemoteFileHelper Class See Also Send Feedback

The RemoteFileHelper type exposes the following members.

Events

 | Name | Description
Public event | DownloadProgressChanged | Occurs when the progress level changes for a downloading file.
Public event | UploadProgressChanged | Occurs when the progress level changes for an uploading file.

See Also

RemoteFileHelper Class
ININ.IceLib.Connection Namespace


DownloadProgressChanged Event

[image]

IceLib Technical Reference
RemoteFileHelper..::..DownloadProgressChanged Event
RemoteFileHelper Class See Also Send Feedback
Occurs when the progress level changes for a downloading file.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<TransferProgressChangedEventArgs> DownloadProgressChanged
Visual Basic
Public Event DownloadProgressChanged As EventHandler(Of TransferProgressChangedEventArgs)

Remarks

This event will only occur if a download has been started. (See DownloadFile(String, String, Object) or DownloadFile(String, BinaryWriter, Object).)

The UserData property of the TransferProgressChangedEventArgs will contain the remote file name specified in order to track multiple concurrent downloads.

Note
All event handlers should be added before the download is started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


UploadProgressChanged Event

[image]

IceLib Technical Reference
RemoteFileHelper..::..UploadProgressChanged Event
RemoteFileHelper Class See Also Send Feedback
Occurs when the progress level changes for an uploading file.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<TransferProgressChangedEventArgs> UploadProgressChanged
Visual Basic
Public Event UploadProgressChanged As EventHandler(Of TransferProgressChangedEventArgs)

Remarks

This event will only occur if a upload has been started. (See UploadFile(String, String) or UploadFile(String, String, Boolean).)

The UserData property of the TransferProgressChangedEventArgs will contain the local file name specified in order to track multiple concurrent uploads.

Note
All event handlers should be added before the upload is started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteFileHelper Class
RemoteFileHelper Members
ININ.IceLib.Connection Namespace


RemoteNumberSettings Class

[image]

IceLib Technical Reference
RemoteNumberSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to specify a remote number connection.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RemoteNumberSettings : StationSettings
Visual Basic
Public Class RemoteNumberSettings _
    Inherits StationSettings

Remarks

The RemoteNumberSettings object is used to specify dynamic remote workstation settings. This establishes a Session via a remote phone number, but not associated with a particular IC station.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the RemoteNumberSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 83, in LoginStationViewModel.#ctor
 | LoginStationViewModel.cs, line 117, in LoginStationViewModel.CreateStationSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..RemoteNumberSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


RemoteNumberSettings Members

[image] [image]

IceLib Technical Reference
RemoteNumberSettings Members
RemoteNumberSettings Class Constructors Methods Properties See Also Send Feedback

The RemoteNumberSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteNumberSettings()()()() | Initializes a new instance of the RemoteNumberSettings class with default settings.
Public method | RemoteNumberSettings(SupportedMedia, String, Boolean) | Initializes a new instance of the RemoteNumberSettings class with station settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this RemoteNumberSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides StationSettings..::..ToTrace()()()().)

Properties

 | Name | Description
Public property | PersistentConnection | Gets or sets the PersistentConnection.
Public property | PersistStationLogin | Gets or sets a value indicating whether the station login is persisted.
Public property | RemoteNumber | Gets or sets the RemoteNumber.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)

See Also

RemoteNumberSettings Class
ININ.IceLib.Connection Namespace


RemoteNumberSettings Constructor

[image] [image]

IceLib Technical Reference
RemoteNumberSettings Constructor
RemoteNumberSettings Class See Also Send Feedback
Initializes a new instance of the RemoteNumberSettings class.

Overload List

 | Name | Description
Public method | RemoteNumberSettings()()()() | Initializes a new instance of the RemoteNumberSettings class with default settings.
Public method | RemoteNumberSettings(SupportedMedia, String, Boolean) | Initializes a new instance of the RemoteNumberSettings class with station settings.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


RemoteNumberSettings Constructor

[image]

IceLib Technical Reference
RemoteNumberSettings Constructor
RemoteNumberSettings Class See Also Send Feedback
Initializes a new instance of the RemoteNumberSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RemoteNumberSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
RemoteNumberSettings Overload
ININ.IceLib.Connection Namespace


RemoteNumberSettings Constructor (SupportedMedia, String, Boolean)

[image]

IceLib Technical Reference
RemoteNumberSettings Constructor (SupportedMedia, String, Boolean)
RemoteNumberSettings Class Example See Also Send Feedback
Initializes a new instance of the RemoteNumberSettings class with station settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RemoteNumberSettings(
    SupportedMedia supportedMedia,
    string remoteNumber,
    bool persistentConnection
)
Visual Basic
Public Sub New ( _
    supportedMedia As SupportedMedia, _
    remoteNumber As String, _
    persistentConnection As Boolean _
)

Parameters

supportedMedia
Type: ININ.IceLib.Connection..::..SupportedMedia
The media types supported by this station.
remoteNumber
Type: System..::..String
The remote number.
persistentConnection
Type: System..::..Boolean
Specifies whether the remote connection is persistent.

Examples

The IceLib SDK includes example application references to the RemoteNumberSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 117, in LoginStationViewModel.CreateStationSettings

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified supported media is not from the SupportedMedia enumeration.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
RemoteNumberSettings Overload
ININ.IceLib.Connection Namespace


RemoteNumberSettings Methods

[image] [image]

IceLib Technical Reference
RemoteNumberSettings Methods
RemoteNumberSettings Class See Also Send Feedback

The RemoteNumberSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this RemoteNumberSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides StationSettings..::..ToTrace()()()().)

See Also

RemoteNumberSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
RemoteNumberSettings..::..Clone Method
RemoteNumberSettings Class See Also Send Feedback
Returns an exact copy of this RemoteNumberSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StationSettings Clone()
Visual Basic
Public Overrides Function Clone As StationSettings

Return Value

A new RemoteNumberSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
RemoteNumberSettings..::..ToString Method
RemoteNumberSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
RemoteNumberSettings..::..ToTrace Method
RemoteNumberSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToTrace()
Visual Basic
Public Overrides Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


RemoteNumberSettings Properties

[image] [image]

IceLib Technical Reference
RemoteNumberSettings Properties
RemoteNumberSettings Class See Also Send Feedback

The RemoteNumberSettings type exposes the following members.

Properties

 | Name | Description
Public property | PersistentConnection | Gets or sets the PersistentConnection.
Public property | PersistStationLogin | Gets or sets a value indicating whether the station login is persisted.
Public property | RemoteNumber | Gets or sets the RemoteNumber.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)

See Also

RemoteNumberSettings Class
ININ.IceLib.Connection Namespace


PersistentConnection Property

[image]

IceLib Technical Reference
RemoteNumberSettings..::..PersistentConnection Property
RemoteNumberSettings Class Example See Also Send Feedback
Gets or sets the PersistentConnection.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PersistentConnection { get; set; }
Visual Basic
Public Property PersistentConnection As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if a persistent connection; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

The default is falseFalsefalsefalse (False in Visual Basic). Setting this value to trueTruetruetrue (True in Visual Basic) will allow the IC Server to keep the line connected between the remote station device and the IC Server, even after disconnecting a call interaction. This allows subsequent call interactions to be patched in immediately upon pickup, rather than requiring the server to call the remote station device again.

Examples

The IceLib SDK includes example application references to the PersistentConnection property. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 89, in LoginStationViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


PersistStationLogin Property

[image]

IceLib Technical Reference
RemoteNumberSettings..::..PersistStationLogin Property
RemoteNumberSettings Class See Also Send Feedback
Gets or sets a value indicating whether the station login is persisted.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PersistStationLogin { get; set; }
Visual Basic
Public Property PersistStationLogin As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if the station login is persisted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Setting this to trueTruetruetrue (True in Visual Basic) tells the IC Server that the station login should be persisted. Calling Disconnect()()()() will persist the station connection based on the value of the currently connected StationSettings's StationConnectionMode property. If StationConnectionMode is set to Default, then the station login will be disconnected; otherwise, it will be persisted. Alternatively, Disconnect(Boolean) can be called to notify the IC Server of the desired disconnect behavior. If the station login is persisted, the session user will still appear to be logged into the station after or Disconnect(Boolean) is called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace
Session..::..Disconnect()()()()


RemoteNumber Property

[image]

IceLib Technical Reference
RemoteNumberSettings..::..RemoteNumber Property
RemoteNumberSettings Class Example See Also Send Feedback
Gets or sets the RemoteNumber.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteNumber { get; set; }
Visual Basic
Public Property RemoteNumber As String
    Get
    Set

Field Value

The remote number.

Examples

The IceLib SDK includes example application references to the RemoteNumber property. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 88, in LoginStationViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


StationId Property

[image]

IceLib Technical Reference
RemoteNumberSettings..::..StationId Property
RemoteNumberSettings Class See Also Send Feedback
Gets a StationId to best represent the StationSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string StationId { get; }
Visual Basic
Public Overrides ReadOnly Property StationId As String
    Get

Field Value

The station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteNumberSettings Class
RemoteNumberSettings Members
ININ.IceLib.Connection Namespace


RemoteStationSettings Class

[image]

IceLib Technical Reference
RemoteStationSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to specify a remote station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RemoteStationSettings : StationSettings
Visual Basic
Public Class RemoteStationSettings _
    Inherits StationSettings

Remarks

Use the RemoteStationSettings object to specify remote workstation settings. It establishes a Session against the specified station, but via a remote phone number.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the RemoteStationSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 74, in LoginStationViewModel.#ctor
 | LoginStationViewModel.cs, line 115, in LoginStationViewModel.CreateStationSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..RemoteStationSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


RemoteStationSettings Members

[image] [image]

IceLib Technical Reference
RemoteStationSettings Members
RemoteStationSettings Class Constructors Methods Properties See Also Send Feedback

The RemoteStationSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteStationSettings()()()() | Initializes a new instance of the RemoteStationSettings class with default settings.
Public method | RemoteStationSettings(String, SupportedMedia, String) | Initializes a new instance of the RemoteStationSettings class with station settings.
Public method | RemoteStationSettings(String, SupportedMedia, String, Boolean) | Obsolete. Initializes a new instance of the RemoteStationSettings class with station settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this RemoteStationSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from StationSettings.)

Properties

 | Name | Description
Public property | PersistStationLogin | Gets or sets a value indicating whether the station login is persisted.
Public property | RemoteNumber | Gets or sets the optional RemoteNumber.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)
Public property | Workstation | Gets or sets the Workstation.

See Also

RemoteStationSettings Class
ININ.IceLib.Connection Namespace


RemoteStationSettings Constructor

[image] [image]

IceLib Technical Reference
RemoteStationSettings Constructor
RemoteStationSettings Class See Also Send Feedback
Initializes a new instance of the RemoteStationSettings class.

Overload List

 | Name | Description
Public method | RemoteStationSettings()()()() | Initializes a new instance of the RemoteStationSettings class with default settings.
Public method | RemoteStationSettings(String, SupportedMedia, String) | Initializes a new instance of the RemoteStationSettings class with station settings.
Public method | RemoteStationSettings(String, SupportedMedia, String, Boolean) | Obsolete. Initializes a new instance of the RemoteStationSettings class with station settings.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace


RemoteStationSettings Constructor

[image]

IceLib Technical Reference
RemoteStationSettings Constructor
RemoteStationSettings Class See Also Send Feedback
Initializes a new instance of the RemoteStationSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RemoteStationSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
RemoteStationSettings Overload
ININ.IceLib.Connection Namespace


RemoteStationSettings Constructor (String, SupportedMedia, String)

[image]

IceLib Technical Reference
RemoteStationSettings Constructor (String, SupportedMedia, String)
RemoteStationSettings Class Example See Also Send Feedback
Initializes a new instance of the RemoteStationSettings class with station settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RemoteStationSettings(
    string workstation,
    SupportedMedia supportedMedia,
    string remoteNumber
)
Visual Basic
Public Sub New ( _
    workstation As String, _
    supportedMedia As SupportedMedia, _
    remoteNumber As String _
)

Parameters

workstation
Type: System..::..String
The workstation.
supportedMedia
Type: ININ.IceLib.Connection..::..SupportedMedia
The media types supported by this station.
remoteNumber
Type: System..::..String
An optional remote number. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Examples

The IceLib SDK includes example application references to the RemoteStationSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 115, in LoginStationViewModel.CreateStationSettings

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified supported media is not from the SupportedMedia enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
RemoteStationSettings Overload
ININ.IceLib.Connection Namespace


RemoteStationSettings Constructor (String, SupportedMedia, String, Boolean)

[image]

IceLib Technical Reference
RemoteStationSettings Constructor (String, SupportedMedia, String, Boolean)
RemoteStationSettings Class See Also Send Feedback
Initializes a new instance of the RemoteStationSettings class with station settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Please use an overload that does not use a persistentConnection parameter.")]
public RemoteStationSettings(
    string workstation,
    SupportedMedia supportedMedia,
    string remoteNumber,
    bool persistentConnection
)
Visual Basic
<ObsoleteAttribute("Please use an overload that does not use a persistentConnection parameter.")> _
Public Sub New ( _
    workstation As String, _
    supportedMedia As SupportedMedia, _
    remoteNumber As String, _
    persistentConnection As Boolean _
)

Parameters

workstation
Type: System..::..String
The workstation.
supportedMedia
Type: ININ.IceLib.Connection..::..SupportedMedia
The media types supported by this station.
remoteNumber
Type: System..::..String
An optional remote number. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
persistentConnection
Type: System..::..Boolean
Specifies whether the remote connection is persistent.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified supported media is not from the SupportedMedia enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
RemoteStationSettings Overload
ININ.IceLib.Connection Namespace


RemoteStationSettings Methods

[image] [image]

IceLib Technical Reference
RemoteStationSettings Methods
RemoteStationSettings Class See Also Send Feedback

The RemoteStationSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this RemoteStationSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from StationSettings.)

See Also

RemoteStationSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
RemoteStationSettings..::..Clone Method
RemoteStationSettings Class See Also Send Feedback
Returns an exact copy of this RemoteStationSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StationSettings Clone()
Visual Basic
Public Overrides Function Clone As StationSettings

Return Value

A new RemoteStationSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
RemoteStationSettings..::..ToString Method
RemoteStationSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace


RemoteStationSettings Properties

[image] [image]

IceLib Technical Reference
RemoteStationSettings Properties
RemoteStationSettings Class See Also Send Feedback

The RemoteStationSettings type exposes the following members.

Properties

 | Name | Description
Public property | PersistStationLogin | Gets or sets a value indicating whether the station login is persisted.
Public property | RemoteNumber | Gets or sets the optional RemoteNumber.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)
Public property | Workstation | Gets or sets the Workstation.

See Also

RemoteStationSettings Class
ININ.IceLib.Connection Namespace


PersistStationLogin Property

[image]

IceLib Technical Reference
RemoteStationSettings..::..PersistStationLogin Property
RemoteStationSettings Class See Also Send Feedback
Gets or sets a value indicating whether the station login is persisted.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PersistStationLogin { get; set; }
Visual Basic
Public Property PersistStationLogin As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if the station login is persisted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Setting this to trueTruetruetrue (True in Visual Basic) tells the IC Server that the station login should be persisted. Calling Disconnect()()()() will persist the station connection based on the value of the currently connected StationSettings's StationConnectionMode property. If StationConnectionMode is set to Default, then the station login will be disconnected; otherwise, it will be persisted. Alternatively, Disconnect(Boolean) can be called to notify the IC Server of the desired disconnect behavior. If the station login is persisted, the session user will still appear to be logged into the station after or Disconnect(Boolean) is called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace
Session..::..Disconnect()()()()


RemoteNumber Property

[image]

IceLib Technical Reference
RemoteStationSettings..::..RemoteNumber Property
RemoteStationSettings Class Example See Also Send Feedback
Gets or sets the optional RemoteNumber.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteNumber { get; set; }
Visual Basic
Public Property RemoteNumber As String
    Get
    Set

Field Value

The remote number.

Remarks

If the value is set to nullNothingnullptra null reference (Nothing in Visual Basic) it will automatically default to an empty string.

Examples

The IceLib SDK includes example application references to the RemoteNumber property. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 79, in LoginStationViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace


StationId Property

[image]

IceLib Technical Reference
RemoteStationSettings..::..StationId Property
RemoteStationSettings Class See Also Send Feedback
Gets a StationId to best represent the StationSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string StationId { get; }
Visual Basic
Public Overrides ReadOnly Property StationId As String
    Get

Field Value

The station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace


Workstation Property

[image]

IceLib Technical Reference
RemoteStationSettings..::..Workstation Property
RemoteStationSettings Class See Also Send Feedback
Gets or sets the Workstation.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workstation { get; set; }
Visual Basic
Public Property Workstation As String
    Get
    Set

Field Value

The workstation.

Remarks

The default is the MachineName.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RemoteStationSettings Class
RemoteStationSettings Members
ININ.IceLib.Connection Namespace


RequestTimeoutException Class

[image]

IceLib Technical Reference
RequestTimeoutException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a server operation times out.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class RequestTimeoutException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class RequestTimeoutException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a requested server operation times out.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Connection..::..RequestTimeoutException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Members
ININ.IceLib.Connection Namespace


RequestTimeoutException Members

[image] [image]

IceLib Technical Reference
RequestTimeoutException Members
RequestTimeoutException Class Constructors Methods Properties Events See Also Send Feedback

The RequestTimeoutException type exposes the following members.

Constructors

 | Name | Description
Public method | RequestTimeoutException()()()() | Initializes a new instance of the RequestTimeoutException class with default settings.
Public method | RequestTimeoutException(Exception) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Public method | RequestTimeoutException(CultureInfo) | Initializes a new instance of the RequestTimeoutException class with default settings.
Public method | RequestTimeoutException(String) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Public method | RequestTimeoutException(CultureInfo, Exception) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Protected method | RequestTimeoutException(SerializationInfo, StreamingContext) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Public method | RequestTimeoutException(String, Exception) | Initializes a new instance of the RequestTimeoutException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RequestTimeoutException Class
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor

[image] [image]

IceLib Technical Reference
RequestTimeoutException Constructor
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class.

Overload List

 | Name | Description
Public method | RequestTimeoutException()()()() | Initializes a new instance of the RequestTimeoutException class with default settings.
Public method | RequestTimeoutException(Exception) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Public method | RequestTimeoutException(CultureInfo) | Initializes a new instance of the RequestTimeoutException class with default settings.
Public method | RequestTimeoutException(String) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Public method | RequestTimeoutException(CultureInfo, Exception) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Protected method | RequestTimeoutException(SerializationInfo, StreamingContext) | Initializes a new instance of the RequestTimeoutException class with a specified error message.
Public method | RequestTimeoutException(String, Exception) | Initializes a new instance of the RequestTimeoutException class with a specified error message.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor

[image]

IceLib Technical Reference
RequestTimeoutException Constructor
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RequestTimeoutException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor (Exception)

[image]

IceLib Technical Reference
RequestTimeoutException Constructor (Exception)
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RequestTimeoutException(
    Exception innerException
)
Visual Basic
Public Sub New ( _
    innerException As Exception _
)

Parameters

innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor (CultureInfo)

[image]

IceLib Technical Reference
RequestTimeoutException Constructor (CultureInfo)
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RequestTimeoutException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor (String)

[image]

IceLib Technical Reference
RequestTimeoutException Constructor (String)
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RequestTimeoutException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor (CultureInfo, Exception)

[image]

IceLib Technical Reference
RequestTimeoutException Constructor (CultureInfo, Exception)
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RequestTimeoutException(
    CultureInfo cultureInfo,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
RequestTimeoutException Constructor (SerializationInfo, StreamingContext)
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected RequestTimeoutException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Constructor (String, Exception)

[image]

IceLib Technical Reference
RequestTimeoutException Constructor (String, Exception)
RequestTimeoutException Class See Also Send Feedback
Initializes a new instance of the RequestTimeoutException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RequestTimeoutException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
RequestTimeoutException Overload
ININ.IceLib.Connection Namespace


RequestTimeoutException Methods

[image] [image]

IceLib Technical Reference
RequestTimeoutException Methods
RequestTimeoutException Class See Also Send Feedback

The RequestTimeoutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RequestTimeoutException Class
ININ.IceLib.Connection Namespace


GetObjectData Method

[image]

IceLib Technical Reference
RequestTimeoutException..::..GetObjectData Method
RequestTimeoutException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

RequestTimeoutException Class
RequestTimeoutException Members
ININ.IceLib.Connection Namespace


RequestTimeoutException Properties

[image] [image]

IceLib Technical Reference
RequestTimeoutException Properties
RequestTimeoutException Class See Also Send Feedback

The RequestTimeoutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RequestTimeoutException Class
ININ.IceLib.Connection Namespace


RequestTimeoutException Events

[image] [image]

IceLib Technical Reference
RequestTimeoutException Events
RequestTimeoutException Class See Also Send Feedback

The RequestTimeoutException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RequestTimeoutException Class
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthParameters Class

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters Class
Members See Also Send Feedback
Provides configuration for SecurityTokenServiceAuthSettings. All properties are optional.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecurityTokenServiceAuthParameters
Visual Basic
Public Class SecurityTokenServiceAuthParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..SecurityTokenServiceAuthParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthParameters Members

[image] [image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters Members
SecurityTokenServiceAuthParameters Class Constructors Methods Properties See Also Send Feedback

The SecurityTokenServiceAuthParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityTokenServiceAuthParameters | Initializes a new instance of the SecurityTokenServiceAuthParameters class

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this SecurityTokenServiceAuthParameters object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace |

Properties

 | Name | Description
Public property | Password | Gets or sets the password.
Public property | PersistToken | Gets or sets a value indicating whether to store the security token from this login attempt for use with future login attempts from this machine for this server/user.
Public property | PresenterFactory | Gets or sets the presenter factory, which supports prompting the user for other authentication details.
Public property | UsePersistedToken | Gets or sets a value indicating whether to attempt to use the previously stored security token for this login attempt from this machine for this server/user.
Public property | UserName | Gets or sets the user name.

See Also

SecurityTokenServiceAuthParameters Class
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthParameters Constructor

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters Constructor
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Initializes a new instance of the SecurityTokenServiceAuthParameters class

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecurityTokenServiceAuthParameters()
Visual Basic
Public Sub New

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthParameters Methods

[image] [image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters Methods
SecurityTokenServiceAuthParameters Class See Also Send Feedback

The SecurityTokenServiceAuthParameters type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this SecurityTokenServiceAuthParameters object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace |

See Also

SecurityTokenServiceAuthParameters Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..Clone Method
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Returns an exact copy of this SecurityTokenServiceAuthParameters object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecurityTokenServiceAuthParameters Clone()
Visual Basic
Public Function Clone As SecurityTokenServiceAuthParameters

Return Value

A new SecurityTokenServiceAuthParameters object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..ToString Method
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..ToTrace Method
SecurityTokenServiceAuthParameters Class See Also Send Feedback

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ToTrace()
Visual Basic
Public Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthParameters Properties

[image] [image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters Properties
SecurityTokenServiceAuthParameters Class See Also Send Feedback

The SecurityTokenServiceAuthParameters type exposes the following members.

Properties

 | Name | Description
Public property | Password | Gets or sets the password.
Public property | PersistToken | Gets or sets a value indicating whether to store the security token from this login attempt for use with future login attempts from this machine for this server/user.
Public property | PresenterFactory | Gets or sets the presenter factory, which supports prompting the user for other authentication details.
Public property | UsePersistedToken | Gets or sets a value indicating whether to attempt to use the previously stored security token for this login attempt from this machine for this server/user.
Public property | UserName | Gets or sets the user name.

See Also

SecurityTokenServiceAuthParameters Class
ININ.IceLib.Connection Namespace


Password Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..Password Property
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Gets or sets the password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureString Password { get; set; }
Visual Basic
Public Property Password As SecureString
    Get
    Set

Field Value

The password.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


PersistToken Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..PersistToken Property
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Gets or sets a value indicating whether to store the security token from this login attempt for use with future login attempts from this machine for this server/user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PersistToken { get; set; }
Visual Basic
Public Property PersistToken As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if persist token; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


PresenterFactory Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..PresenterFactory Property
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Gets or sets the presenter factory, which supports prompting the user for other authentication details.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Func<SecurityTokenServicePresenterContext, SecurityTokenServicePresenter> PresenterFactory { get; set; }
Visual Basic
Public Property PresenterFactory As Func(Of SecurityTokenServicePresenterContext, SecurityTokenServicePresenter)
    Get
    Set

Field Value

The presenter factory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


UsePersistedToken Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..UsePersistedToken Property
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Gets or sets a value indicating whether to attempt to use the previously stored security token for this login attempt from this machine for this server/user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool UsePersistedToken { get; set; }
Visual Basic
Public Property UsePersistedToken As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should use the persisted token; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


UserName Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthParameters..::..UserName Property
SecurityTokenServiceAuthParameters Class See Also Send Feedback
Gets or sets the user name.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

Field Value

The name of the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthParameters Class
SecurityTokenServiceAuthParameters Members
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthSettings Class

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings Class
Members See Also Send Feedback
Passed to a Session in order to authenticate an Interaction Center user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecurityTokenServiceAuthSettings : AuthSettings
Visual Basic
Public Class SecurityTokenServiceAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.
The SecurityTokenServiceAuthSettings object is used to hold user authentication settings. This is used when the user credentials should be validated against an external Identity Provider when requesting a Session.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..SecurityTokenServiceAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


SecurityTokenServiceAuthSettings Members

[image] [image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings Members
SecurityTokenServiceAuthSettings Class Constructors Methods Properties See Also Send Feedback

The SecurityTokenServiceAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityTokenServiceAuthSettings | Initializes a new instance of the SecurityTokenServiceAuthSettings class with user settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this SecurityTokenServiceAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Inherited from AuthSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasCachedToken | Determines whether there is a cached security token for the specified context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

Properties

 | Name | Description
Public property | ProviderContext | Gets the authentication provider context.
Public property | UserName | Gets the user name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SecurityTokenServiceAuthSettings Class
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthSettings Constructor

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings Constructor
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Initializes a new instance of the SecurityTokenServiceAuthSettings class with user settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecurityTokenServiceAuthSettings(
    AuthProviderContext providerContext,
    SecurityTokenServiceAuthParameters parameters
)
Visual Basic
Public Sub New ( _
    providerContext As AuthProviderContext, _
    parameters As SecurityTokenServiceAuthParameters _
)

Parameters

providerContext
Type: ININ.IceLib.Connection..::..AuthProviderContext
The authentication provider context.
parameters
Type: ININ.IceLib.Connection..::..SecurityTokenServiceAuthParameters
The authentication parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A required parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthSettings Methods

[image] [image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings Methods
SecurityTokenServiceAuthSettings Class See Also Send Feedback

The SecurityTokenServiceAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this SecurityTokenServiceAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Inherited from AuthSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasCachedToken | Determines whether there is a cached security token for the specified context.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

See Also

SecurityTokenServiceAuthSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings..::..Clone Method
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Returns an exact copy of this SecurityTokenServiceAuthSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new SecurityTokenServiceAuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


HasCachedToken Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings..::..HasCachedToken Method
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Determines whether there is a cached security token for the specified context.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool HasCachedToken(
    HostEndpoint endpoint,
    AuthProviderContext providerContext,
    string userName
)
Visual Basic
Public Shared Function HasCachedToken ( _
    endpoint As HostEndpoint, _
    providerContext As AuthProviderContext, _
    userName As String _
) As Boolean

Parameters

endpoint
Type: ININ.IceLib.Connection..::..HostEndpoint
The endpoint.
providerContext
Type: ININ.IceLib.Connection..::..AuthProviderContext
The authentication provider context.
userName
Type: System..::..String
The user name.

Return Value

trueTruetruetrue (True in Visual Basic) if has a cached token for the specified context; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings..::..ToString Method
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings..::..ToTrace Method
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToTrace()
Visual Basic
Public Overrides Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


SecurityTokenServiceAuthSettings Properties

[image] [image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings Properties
SecurityTokenServiceAuthSettings Class See Also Send Feedback

The SecurityTokenServiceAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | ProviderContext | Gets the authentication provider context.
Public property | UserName | Gets the user name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SecurityTokenServiceAuthSettings Class
ININ.IceLib.Connection Namespace


ProviderContext Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings..::..ProviderContext Property
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Gets the authentication provider context.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AuthProviderContext ProviderContext { get; }
Visual Basic
Public ReadOnly Property ProviderContext As AuthProviderContext
    Get

Field Value

The authentication provider context.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


UserName Property

[image]

IceLib Technical Reference
SecurityTokenServiceAuthSettings..::..UserName Property
SecurityTokenServiceAuthSettings Class See Also Send Feedback
Gets the user name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; }
Visual Basic
Public ReadOnly Property UserName As String
    Get

Field Value

The name of the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServiceAuthSettings Class
SecurityTokenServiceAuthSettings Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenter Class

[image]

IceLib Technical Reference
SecurityTokenServicePresenter Class
Members See Also Send Feedback
Allows a custom application to present STS authentication requests to the user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class SecurityTokenServicePresenter
Visual Basic
Public MustInherit Class SecurityTokenServicePresenter

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..SecurityTokenServicePresenter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenter Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenter Members

[image] [image]

IceLib Technical Reference
SecurityTokenServicePresenter Members
SecurityTokenServicePresenter Class Constructors Methods Properties See Also Send Feedback

The SecurityTokenServicePresenter type exposes the following members.

Constructors

 | Name | Description
Protected method | SecurityTokenServicePresenter | Initializes a new instance of the SecurityTokenServicePresenter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleTryPromptForBrowserCredentials | Handle an attempt to prompt for credentials via a web browser.
Protected method | HandleTryPromptForCredentials | Handle an attempt to prompt for credentials.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | Context | Gets the STS context, which provides information and operations for interacting with the STS sequence.

See Also

SecurityTokenServicePresenter Class
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenter Constructor

[image]

IceLib Technical Reference
SecurityTokenServicePresenter Constructor
SecurityTokenServicePresenter Class See Also Send Feedback
Initializes a new instance of the SecurityTokenServicePresenter class.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected SecurityTokenServicePresenter(
    SecurityTokenServicePresenterContext context
)
Visual Basic
Protected Sub New ( _
    context As SecurityTokenServicePresenterContext _
)

Parameters

context
Type: ININ.IceLib.Connection..::..SecurityTokenServicePresenterContext
The STS context.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenter Class
SecurityTokenServicePresenter Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenter Methods

[image] [image]

IceLib Technical Reference
SecurityTokenServicePresenter Methods
SecurityTokenServicePresenter Class See Also Send Feedback

The SecurityTokenServicePresenter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleTryPromptForBrowserCredentials | Handle an attempt to prompt for credentials via a web browser.
Protected method | HandleTryPromptForCredentials | Handle an attempt to prompt for credentials.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityTokenServicePresenter Class
ININ.IceLib.Connection Namespace


HandleTryPromptForBrowserCredentials Method

[image]

IceLib Technical Reference
SecurityTokenServicePresenter..::..HandleTryPromptForBrowserCredentials Method
SecurityTokenServicePresenter Class See Also Send Feedback
Handle an attempt to prompt for credentials via a web browser.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected internal virtual void HandleTryPromptForBrowserCredentials(
    SingleSignOnRequestData singleSignOnRequestData
)
Visual Basic
Protected Friend Overridable Sub HandleTryPromptForBrowserCredentials ( _
    singleSignOnRequestData As SingleSignOnRequestData _
)

Parameters

singleSignOnRequestData
Type: ININ.IceLib.Connection..::..SingleSignOnRequestData
The single sign on request data.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

SecurityTokenServicePresenter Class
SecurityTokenServicePresenter Members
ININ.IceLib.Connection Namespace


HandleTryPromptForCredentials Method

[image]

IceLib Technical Reference
SecurityTokenServicePresenter..::..HandleTryPromptForCredentials Method
SecurityTokenServicePresenter Class See Also Send Feedback
Handle an attempt to prompt for credentials.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected internal virtual bool HandleTryPromptForCredentials(
    out string userName,
    out SecureString password
)
Visual Basic
Protected Friend Overridable Function HandleTryPromptForCredentials ( _
    <OutAttribute> ByRef userName As String, _
    <OutAttribute> ByRef password As SecureString _
) As Boolean

Parameters

userName
Type: System..::..String%
The user name.
password
Type: System.Security..::..SecureString%
The password.

Return Value

trueTruetruetrue (True in Visual Basic) if the credentials were successfully retrieved; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenter Class
SecurityTokenServicePresenter Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenter Properties

[image] [image]

IceLib Technical Reference
SecurityTokenServicePresenter Properties
SecurityTokenServicePresenter Class See Also Send Feedback

The SecurityTokenServicePresenter type exposes the following members.

Properties

 | Name | Description
Protected property | Context | Gets the STS context, which provides information and operations for interacting with the STS sequence.

See Also

SecurityTokenServicePresenter Class
ININ.IceLib.Connection Namespace


Context Property

[image]

IceLib Technical Reference
SecurityTokenServicePresenter..::..Context Property
SecurityTokenServicePresenter Class See Also Send Feedback
Gets the STS context, which provides information and operations for interacting with the STS sequence.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected SecurityTokenServicePresenterContext Context { get; }
Visual Basic
Protected ReadOnly Property Context As SecurityTokenServicePresenterContext
    Get

Field Value

The STS context.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenter Class
SecurityTokenServicePresenter Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenterContext Class

[image]

IceLib Technical Reference
SecurityTokenServicePresenterContext Class
Members See Also Send Feedback
Provides context for STS authentication via a SecurityTokenServicePresenter.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public sealed class SecurityTokenServicePresenterContext
Visual Basic
Public NotInheritable Class SecurityTokenServicePresenterContext

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..SecurityTokenServicePresenterContext

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenterContext Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenterContext Members

[image] [image]

IceLib Technical Reference
SecurityTokenServicePresenterContext Members
SecurityTokenServicePresenterContext Class Methods Properties See Also Send Feedback

The SecurityTokenServicePresenterContext type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Aborts the STS authentication sequence. For example, if the user closed the HTML page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ProviderContext | Gets the authentication provider context.

See Also

SecurityTokenServicePresenterContext Class
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenterContext Methods

[image] [image]

IceLib Technical Reference
SecurityTokenServicePresenterContext Methods
SecurityTokenServicePresenterContext Class See Also Send Feedback

The SecurityTokenServicePresenterContext type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Aborts the STS authentication sequence. For example, if the user closed the HTML page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityTokenServicePresenterContext Class
ININ.IceLib.Connection Namespace


Abort Method

[image]

IceLib Technical Reference
SecurityTokenServicePresenterContext..::..Abort Method
SecurityTokenServicePresenterContext Class See Also Send Feedback
Aborts the STS authentication sequence. For example, if the user closed the HTML page.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Abort(
    string reason
)
Visual Basic
Public Sub Abort ( _
    reason As String _
)

Parameters

reason
Type: System..::..String
A brief reason for the abort, which will be traced in the log file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenterContext Class
SecurityTokenServicePresenterContext Members
ININ.IceLib.Connection Namespace


SecurityTokenServicePresenterContext Properties

[image] [image]

IceLib Technical Reference
SecurityTokenServicePresenterContext Properties
SecurityTokenServicePresenterContext Class See Also Send Feedback

The SecurityTokenServicePresenterContext type exposes the following members.

Properties

 | Name | Description
Public property | ProviderContext | Gets the authentication provider context.

See Also

SecurityTokenServicePresenterContext Class
ININ.IceLib.Connection Namespace


ProviderContext Property

[image]

IceLib Technical Reference
SecurityTokenServicePresenterContext..::..ProviderContext Property
SecurityTokenServicePresenterContext Class See Also Send Feedback
Gets the authentication provider context.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AuthProviderContext ProviderContext { get; }
Visual Basic
Public ReadOnly Property ProviderContext As AuthProviderContext
    Get

Field Value

The authentication provider context.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

SecurityTokenServicePresenterContext Class
SecurityTokenServicePresenterContext Members
ININ.IceLib.Connection Namespace


SensitiveDataContext Class

[image]

IceLib Technical Reference
SensitiveDataContext Class
Members See Also Send Feedback
Provides access to the Session's sensitive data context.

Note: This class is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SensitiveDataContext
Visual Basic
Public Class SensitiveDataContext

Remarks

Use this class to get access to the Session's sensitive data information.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..SensitiveDataContext

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveDataContext Members
ININ.IceLib.Connection Namespace


SensitiveDataContext Members

[image] [image]

IceLib Technical Reference
SensitiveDataContext Members
SensitiveDataContext Class Methods Fields Properties Events See Also Send Feedback

The SensitiveDataContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SuppressedValueIndicator | Gets a substitute value to trace instead of suppressed sensitive values.

Properties

 | Name | Description
Public property | ShouldSuppressSensitiveDataTracing | Gets a valud indicating whether to suppress sensitive data tracing.

Events

 | Name | Description
Public event | SensitiveDataContextChanged | Occurs when the sensitive data context has changed.

See Also

SensitiveDataContext Class
ININ.IceLib.Connection Namespace


SensitiveDataContext Fields

[image] [image]

IceLib Technical Reference
SensitiveDataContext Fields
SensitiveDataContext Class See Also Send Feedback

The SensitiveDataContext type exposes the following members.

Fields

Name | Description
SuppressedValueIndicator | Gets a substitute value to trace instead of suppressed sensitive values.

See Also

SensitiveDataContext Class
ININ.IceLib.Connection Namespace


SuppressedValueIndicator Field

[image]

IceLib Technical Reference
SensitiveDataContext..::..SuppressedValueIndicator Field
SensitiveDataContext Class See Also Send Feedback
Gets a substitute value to trace instead of suppressed sensitive values.

Note: This field is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SuppressedValueIndicator
Visual Basic
Public Shared ReadOnly SuppressedValueIndicator As String

Field Value

The suppressed value indicator.

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveDataContext Class
SensitiveDataContext Members
ININ.IceLib.Connection Namespace


SensitiveDataContext Methods

[image] [image]

IceLib Technical Reference
SensitiveDataContext Methods
SensitiveDataContext Class See Also Send Feedback

The SensitiveDataContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SensitiveDataContext Class
ININ.IceLib.Connection Namespace


SensitiveDataContext Properties

[image] [image]

IceLib Technical Reference
SensitiveDataContext Properties
SensitiveDataContext Class See Also Send Feedback

The SensitiveDataContext type exposes the following members.

Properties

 | Name | Description
Public property | ShouldSuppressSensitiveDataTracing | Gets a valud indicating whether to suppress sensitive data tracing.

See Also

SensitiveDataContext Class
ININ.IceLib.Connection Namespace


ShouldSuppressSensitiveDataTracing Property

[image]

IceLib Technical Reference
SensitiveDataContext..::..ShouldSuppressSensitiveDataTracing Property
SensitiveDataContext Class See Also Send Feedback
Gets a valud indicating whether to suppress sensitive data tracing.

Note: This property is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShouldSuppressSensitiveDataTracing { get; }
Visual Basic
Public ReadOnly Property ShouldSuppressSensitiveDataTracing As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if sensitive data tracing should be suppressed, otherwise falseFalsefalsefalse (False in Visual Basic)

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveDataContext Class
SensitiveDataContext Members
ININ.IceLib.Connection Namespace


SensitiveDataContext Events

[image] [image]

IceLib Technical Reference
SensitiveDataContext Events
SensitiveDataContext Class See Also Send Feedback

The SensitiveDataContext type exposes the following members.

Events

 | Name | Description
Public event | SensitiveDataContextChanged | Occurs when the sensitive data context has changed.

See Also

SensitiveDataContext Class
ININ.IceLib.Connection Namespace


SensitiveDataContextChanged Event

[image]

IceLib Technical Reference
SensitiveDataContext..::..SensitiveDataContextChanged Event
SensitiveDataContext Class See Also Send Feedback
Occurs when the sensitive data context has changed.

Note: This event is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EventArgs> SensitiveDataContextChanged
Visual Basic
Public Event SensitiveDataContextChanged As EventHandler(Of EventArgs)

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveDataContext Class
SensitiveDataContext Members
ININ.IceLib.Connection Namespace


ServerFileType Enumeration

[image]

IceLib Technical Reference
ServerFileType Enumeration
Example See Also Send Feedback
Specifies constants indicating where to store files in PersonalStorage on the server.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ServerFileType
Visual Basic
Public Enumeration ServerFileType

Members

Member name | Value | Description
Other | 0 | The destination for this file is unable to be determined based on file type, use the default destination.
Fax | 1 | The destination for this file is the location for Fax files.
Voicemail | 2 | The destination for this file is the location for Voicemail files.
Email | 3 | The destination for this file is the location for Email files.
Chat | 4 | The destination for this file is the location for Chat files.
ResponseManagementDocument | 5 | The destination for this file is the location for Response Management documents.
ApplicationSettings | 6 | The destination for this file is the location for Application Settings.
ImageResource | 7 | The destination for this file is the location for Image resources.
ProblemReport | 8 | The destination for this file is the location for Problem Report files.
ClientTemplate | 9 | The destination for this file is the location for Client templates.
CrystalReportTemplate | 10 | The destination for this file is the location for Crystal Report Templates

Remarks

This enumeration is used by RemoteFileHelper to specify a remote file type.

Examples

The following example demonstrates creation of a remote file name.
CopyC#
string remoteFileName = RemoteFileHelper.NewRemoteFileName(ServerFileType.Other);

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


Session Class

[image]

IceLib Technical Reference
Session Class
Members Example See Also Send Feedback
Represents the connection Session with the Interaction Center server.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Session : IDisposable
Visual Basic
Public Class Session _
    Implements IDisposable

Remarks

The Session is the root of any IceLib connection with the IC server. It accepts various settings to describe the session and provides events when there is a change in connection settings or connection state.

Host Settings. The HostSettings is used to specify the host information used to establish a Session connection.

Authentication Settings. There are a number of object classes that are used to specify authentication settings for the Session such as what IC User ID and Password to login with. All such objects inherit from AuthSettings. Examples of authentication classes are: ICAuthSettings and WindowsAuthSettings.

Station Settings. There are a number of object classes that are used to specify station settings for the Session such as what remote number is serving as the User's station. All such objects inherit from StationSettings. Examples of station classes are: WorkstationSettings and RemoteStationSettings. There are additional considerations that need to be taken into account when using StationlessSettings. See the StationlessSettings object for further details.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

Note
All "manager" classes found in the IceLib library are designed as singletons-classes instantiated only once. For example, to begin working with any of the functionality provided in the ININ.IceLib.Interactions.InteractionsManager, you must obtain the instance through a call to its GetInstance method.
CopyC#
Session session = new Session();
session.Connect(...);
InteractionsManager interactionsManager = InteractionsManager.GetInstance(session);

Examples

The IceLib SDK includes example application references to the Session class. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 197, in ConnectionViewModel.SetSessionValues
 | ConnectionViewModel.cs, line 12, in ConnectionViewModel.#ctor
 | ConnectionViewModel.cs, line 214, in ConnectionViewModel.SetStationValues
 | ConnectionViewModel._Session
 | ChangeStationViewModel.cs, line 11, in ChangeStationViewModel.#ctor
 | ChangeStationViewModel.cs, line 107, in ChangeStationViewModel.PerformLogin
 | LoginViewModel.cs, line 191, in LoginViewModel.PerformLogin
 | LoginViewModel.cs, line 11, in LoginViewModel.#ctor
 | SystemStatisticsViewModel.cs, line 38, in SystemStatisticsViewModel.#ctor
 | SystemStatisticsViewModel._Session
 | StatisticCatalogViewModel.cs, line 12, in StatisticCatalogViewModel.#ctor
 | StatisticCatalogViewModel._Session
 | UserRoleConfigurationViewModel.cs, line 22, in UserRoleConfigurationViewModel.#ctor
 | UserRoleConfigurationViewModel._Session
 | MainWindowViewModel.cs, line 22, in MainWindowViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..Session

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


Session Members

[image] [image]

IceLib Technical Reference
Session Members
Session Class Constructors Methods Properties Events See Also Send Feedback

The Session type exposes the following members.

Constructors

 | Name | Description
Public method | Session | Initializes a new instance of the Session class with default settings.

Methods

 | Name | Description
Public method | ChangeStation | Changes the station for the session.
Public method | ChangeStationAsync | Asynchronously changes the station for the session.
Public method | CheckSession | Verify that there is a connected session.
Public method | Connect | Connects the session using the specified settings.
Public method | ConnectAsync | Asynchronously connects the session using the specified settings.
Public method | Disconnect()()()() | Disconnects the Session.
Public method | Disconnect(Boolean) | Disconnects the Session.
Public method | DisconnectAsync(AsyncCompletedEventHandler, Object) | Asynchronously disconnects the Session.
Public method | DisconnectAsync(Boolean, AsyncCompletedEventHandler, Object) | Asynchronously disconnects the Session.
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases the resources used by the Session.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForceUserLogout | Force logout a user from all the applications.
Public method | ForceUserLogoutAsync | Asynchronously logs out user from all the applications.
 | GetAllowableAuthentications(AllowableAuthenticationsParameters) | Gets the allowable authentication types.
 | GetAllowableAuthentications(HostSettings) | Gets the allowable authentication types.
 | GetAllowableAuthentications(HostSettings, String) | Gets the allowable authentication types.
Public method | GetAuthenticationToken | Gets the authentication token for the Session.
Public method | GetAuthenticationTokenAsync | Asynchronously gets the authentication token for the Session.
Public method | GetAuthSettings | Gets a copy of the AuthSettings.
 | GetCachedAllowableAuthentications(String) | Gets the cached allowable authentication types.
 | GetCachedAllowableAuthentications(CachedAllowableAuthenticationsParameters) | Gets the cached allowable authentication types.
 | GetCachedAllowableAuthentications(String, String) | Gets the cached allowable authentication types.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostSettings | Gets a copy of the HostSettings.
Public method | GetSessionSettings | Gets a copy of the SessionSettings.
Public method | GetStationInfo | Gets a copy of the StationInfo.
Public method | GetStationSettings | Gets a copy of the StationSettings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAutoReconnectInterval(Int32) | Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost.
Public method | SetAutoReconnectInterval(Int32, Int32) | Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost, allowing a difference between the amount of time before an initial reconnect and all subsequent reconnect attempts.
Public method | SetReadyForInteractions | Signals the application's readiness to make or receive Interactions.
Public method | SetReadyForInteractionsAsync | Asynchronously signals the application's readiness to make or receive Interactions.
Public method | SetStationConnectionMode | Sets the station connection mode for the session, which controls when the user is logged out of the station.
Public method | SetStationConnectionModeAsync | Asynchronously sets the station connection mode for the session, which controls when the user is logged out of the station.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Public property AdditionalUtcOffset
Gets or sets an additional clock skew for the session.
Public property AttemptToSetThreadCulture
Gets or sets a value indicating whether to attempt to set IceLib's background threads' CurrentUICulture.
Public property AutoReconnectEnabled
Enables or disables automatic reconnection attempts when the connection is lost.
Public property AutoReconnecting
Identifies whether an AutoReconnect is in the process of occurring.
Public property ClockSkew
Gets the clock skew.
Public property ConnectionState
Gets the current ConnectionState of the Session.
Public property ConnectionStateMessage
Gets the most recent text description of the state of the Session.
Public property ConnectionStateReason
Gets the current ConnectionStateReason of the Session.
Public property CultureInfo
Gets the culture info, as specified by SessionSettings.IsoLanguage.
Public property CustomerName
Gets the name of the customer to whom IC is licensed.
Public property DisplayName
Gets the display name for the logged in user.
Public property EffectiveStation
Gets the effective station that the user is logged in to.

Remarks

This value is initially set to Empty, and will be updated after the session user logs into a station.
Public property Endpoint
Returns a new HostEndpoint containing the details of the currently connected HostEndpoint.
Public property ICServer
Gets the name of the IC server to which the session is connected.
Public property InteractionCenterReleaseVersion
Gets the release version information of the Interaction Center to which the session is connected (if available).
Public property IsEncrypted Obsolete.
Returns whether the current connection is encrypted.
Public property RawSessionId
The internal Session ID as a UInt32.
Public property SensitiveDataContext
Gets the sensitive data context for this session.
Public property SessionId
The internal Session ID.
Public property SessionManagerName
Gets the relative distinguished name (RDN) of the SessionManager to which the session is connected.
Public property SessionManagerNameFQDN
Gets the fully qualified domain name (FQDN) of the SessionManager to which the session is connected.
Public property SessionManagerReleaseVersion
Gets the release version information of the Session Manager to which the session is connected (if available).
Public property SessionManagerVersion
Gets the version number of the SessionManager to which the session is connected (if available).
Public property SupportedMedia
Gets the supported media flags (SupportedMedia).
Public property UserAgreement
Gets the user agreement text.
Public property UserId
Gets the ID of the logged in IC user.
Public property UserLogOnId
Gets the log on ID of the logged in IC user.

Events

 | Name | Description
Public event | ConnectionStateChanged | Occurs when the Session's ConnectionState changes.
Public event | EffectiveStationChanged | Occurs when the Session user's EffectiveStation changes.
Public event | StationSettingsChanged | Occurs when the Session's StationSettings changes.

See Also

Session Class
ININ.IceLib.Connection Namespace


Session Constructor

[image]

IceLib Technical Reference
Session Constructor
Session Class Example See Also Send Feedback
Initializes a new instance of the Session class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session()
Visual Basic
Public Sub New

Examples

The IceLib SDK includes example application references to the Session constructor. Some examples are listed below.
Project | Location
TutorialExample | MainWindowViewModel.cs, line 22, in MainWindowViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Session Methods

[image] [image]

IceLib Technical Reference
Session Methods
Session Class See Also Send Feedback

The Session type exposes the following members.

Methods

 | Name | Description
Public method | ChangeStation | Changes the station for the session.
Public method | ChangeStationAsync | Asynchronously changes the station for the session.
Public method | CheckSession | Verify that there is a connected session.
Public method | Connect | Connects the session using the specified settings.
Public method | ConnectAsync | Asynchronously connects the session using the specified settings.
Public method | Disconnect()()()() | Disconnects the Session.
Public method | Disconnect(Boolean) | Disconnects the Session.
Public method | DisconnectAsync(AsyncCompletedEventHandler, Object) | Asynchronously disconnects the Session.
Public method | DisconnectAsync(Boolean, AsyncCompletedEventHandler, Object) | Asynchronously disconnects the Session.
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases the resources used by the Session.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForceUserLogout | Force logout a user from all the applications.
Public method | ForceUserLogoutAsync | Asynchronously logs out user from all the applications.
 | GetAllowableAuthentications(AllowableAuthenticationsParameters) | Gets the allowable authentication types.
 | GetAllowableAuthentications(HostSettings) | Gets the allowable authentication types.
 | GetAllowableAuthentications(HostSettings, String) | Gets the allowable authentication types.
Public method | GetAuthenticationToken | Gets the authentication token for the Session.
Public method | GetAuthenticationTokenAsync | Asynchronously gets the authentication token for the Session.
Public method | GetAuthSettings | Gets a copy of the AuthSettings.
 | GetCachedAllowableAuthentications(String) | Gets the cached allowable authentication types.
 | GetCachedAllowableAuthentications(CachedAllowableAuthenticationsParameters) | Gets the cached allowable authentication types.
 | GetCachedAllowableAuthentications(String, String) | Gets the cached allowable authentication types.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostSettings | Gets a copy of the HostSettings.
Public method | GetSessionSettings | Gets a copy of the SessionSettings.
Public method | GetStationInfo | Gets a copy of the StationInfo.
Public method | GetStationSettings | Gets a copy of the StationSettings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAutoReconnectInterval(Int32) | Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost.
Public method | SetAutoReconnectInterval(Int32, Int32) | Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost, allowing a difference between the amount of time before an initial reconnect and all subsequent reconnect attempts.
Public method | SetReadyForInteractions | Signals the application's readiness to make or receive Interactions.
Public method | SetReadyForInteractionsAsync | Asynchronously signals the application's readiness to make or receive Interactions.
Public method | SetStationConnectionMode | Sets the station connection mode for the session, which controls when the user is logged out of the station.
Public method | SetStationConnectionModeAsync | Asynchronously sets the station connection mode for the session, which controls when the user is logged out of the station.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Session Class
ININ.IceLib.Connection Namespace


ChangeStation Method

[image]

IceLib Technical Reference
Session..::..ChangeStation Method
Session Class See Also Send Feedback
Changes the station for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeStation(
    StationSettings stationSettings
)
Visual Basic
Public Sub ChangeStation ( _
    stationSettings As StationSettings _
)

Parameters

stationSettings
Type: ININ.IceLib.Connection..::..StationSettings
The StationSettings for the connection.

Remarks

For security reasons a user can only be logged in to one station at a time. If the user logs in to a different station, the system drops the original station connection. Multiple instances of client applications may be run on the same machine using different user logins and the same station.

If a user who is logged in via Interaction Client .NET Edition tries, for example, to connect using Interaction Connect, they will receive a message at the original station such as: "Your connection has been dropped due to a subsequent login on a different station".

Changing a station from StationlessSettings to any other StationSettings-derived type that uses a station is not supported. Attempting to do so will result in an IceLibException. Additionally, changing station from a StationSettings-derived type that uses a station to StationlessSettings is also not supported. Starting with 2016 R1, this will now throw an appropriate IceLibException if attempted.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ChangeStationAsync Method

[image]

IceLib Technical Reference
Session..::..ChangeStationAsync Method
Session Class Example See Also Send Feedback
Asynchronously changes the station for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeStationAsync(
    StationSettings stationSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeStationAsync ( _
    stationSettings As StationSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

stationSettings
Type: ININ.IceLib.Connection..::..StationSettings
The StationSettings for the connection.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

For security reasons a user can only be logged in to one station at a time. If the user logs in to a different station, the system drops the original station connection. Multiple instances of client applications may be run on the same machine using different user logins and the same station.

If a user who is logged in via Interaction Client .NET Edition tries, for example, to connect using Interaction Connect, they will receive a message at the original station such as: "Your connection has been dropped due to a subsequent login on a different station".

Changing a station from StationlessSettings to any other StationSettings-derived type that uses a station is not supported. Attempting to do so will result in an IceLibException. Additionally, changing station from a StationSettings-derived type that uses a station to StationlessSettings is also not supported. Starting with 2016 R1, this will now throw an appropriate IceLibException if attempted.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Examples

The IceLib SDK includes example application references to the ChangeStationAsync method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | ChangeStationViewModel.cs, line 107, in ChangeStationViewModel.PerformLogin

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


CheckSession Method

[image]

IceLib Technical Reference
Session..::..CheckSession Method
Session Class See Also Send Feedback
Verify that there is a connected session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CheckSession()
Visual Basic
Public Sub CheckSession

Remarks

This helper can be used to provide early detection of an invalid connection. If the Session does not have a connection an exception will be thrown.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Connect Method

[image]

IceLib Technical Reference
Session..::..Connect Method
Session Class See Also Send Feedback
Connects the session using the specified settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Connect(
    SessionSettings sessionSettings,
    HostSettings hostSettings,
    AuthSettings authSettings,
    StationSettings stationSettings
)
Visual Basic
Public Sub Connect ( _
    sessionSettings As SessionSettings, _
    hostSettings As HostSettings, _
    authSettings As AuthSettings, _
    stationSettings As StationSettings _
)

Parameters

sessionSettings
Type: ININ.IceLib.Connection..::..SessionSettings
The SessionSettings for the connection.
hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.
authSettings
Type: ININ.IceLib.Connection..::..AuthSettings
The AuthSettings for the connection.
stationSettings
Type: ININ.IceLib.Connection..::..StationSettings
The StationSettings for the connection.

Remarks

For security reasons a user can only be logged in to one station at a time. If the user logs in to a different station, the system drops the original station connection. Multiple instances of client applications may be run on the same machine using different user logins and the same station.

If a user who is logged in via Interaction Client .NET Edition tries, for example, to connect using Interaction Connect, they will receive a message at the original station such as: "Your connection has been dropped due to a subsequent login on a different station".

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | The connection was not established.
ININ.IceLib..::..IceLibLicenseException | A required license is not available.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ConnectAsync Method

[image]

IceLib Technical Reference
Session..::..ConnectAsync Method
Session Class Example See Also Send Feedback
Asynchronously connects the session using the specified settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConnectAsync(
    SessionSettings sessionSettings,
    HostSettings hostSettings,
    AuthSettings authSettings,
    StationSettings stationSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ConnectAsync ( _
    sessionSettings As SessionSettings, _
    hostSettings As HostSettings, _
    authSettings As AuthSettings, _
    stationSettings As StationSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

sessionSettings
Type: ININ.IceLib.Connection..::..SessionSettings
The SessionSettings for the connection.
hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.
authSettings
Type: ININ.IceLib.Connection..::..AuthSettings
The AuthSettings for the connection.
stationSettings
Type: ININ.IceLib.Connection..::..StationSettings
The StationSettings for the connection.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

For security reasons a user can only be logged in to one station at a time. If the user logs in to a different station, the system drops the original station connection. Multiple instances of client applications may be run on the same machine using different user logins and the same station.

If a user who is logged in via Interaction Client .NET Edition tries, for example, to connect using Interaction Connect, they will receive a message at the original station such as: "Your connection has been dropped due to a subsequent login on a different station".

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Examples

The IceLib SDK includes example application references to the ConnectAsync method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 191, in LoginViewModel.PerformLogin

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Disconnect Method

[image] [image]

IceLib Technical Reference
Session..::..Disconnect Method
Session Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Disconnect()()()() | Disconnects the Session.
Public method | Disconnect(Boolean) | Disconnects the Session.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Disconnect Method

[image]

IceLib Technical Reference
Session..::..Disconnect Method
Session Class See Also Send Feedback
Disconnects the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibException | The connection could not be disconnected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
Disconnect Overload
ININ.IceLib.Connection Namespace


Disconnect Method (Boolean)

[image]

IceLib Technical Reference
Session..::..Disconnect Method (Boolean)
Session Class See Also Send Feedback
Disconnects the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Disconnect(
    bool persistStationLogin
)
Visual Basic
Public Sub Disconnect ( _
    persistStationLogin As Boolean _
)

Parameters

persistStationLogin
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) if the station login is persisted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibException | The connection could not be disconnected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

Session Class
Session Members
Disconnect Overload
ININ.IceLib.Connection Namespace
RemoteNumberSettings..::..PersistStationLogin
RemoteStationSettings..::..PersistStationLogin
WorkstationSettings..::..PersistStationLogin


DisconnectAsync Method

[image] [image]

IceLib Technical Reference
Session..::..DisconnectAsync Method
Session Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DisconnectAsync(AsyncCompletedEventHandler, Object) | Asynchronously disconnects the Session.
Public method | DisconnectAsync(Boolean, AsyncCompletedEventHandler, Object) | Asynchronously disconnects the Session.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


DisconnectAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Session..::..DisconnectAsync Method (AsyncCompletedEventHandler, Object)
Session Class See Also Send Feedback
Asynchronously disconnects the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DisconnectAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DisconnectAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
DisconnectAsync Overload
ININ.IceLib.Connection Namespace


DisconnectAsync Method (Boolean, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Session..::..DisconnectAsync Method (Boolean, AsyncCompletedEventHandler, Object)
Session Class See Also Send Feedback
Asynchronously disconnects the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DisconnectAsync(
    bool persistStationLogin,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DisconnectAsync ( _
    persistStationLogin As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

persistStationLogin
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) if the station login is persisted; otherwise, falseFalsefalsefalse (False in Visual Basic).
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

Session Class
Session Members
DisconnectAsync Overload
ININ.IceLib.Connection Namespace
RemoteNumberSettings..::..PersistStationLogin
RemoteStationSettings..::..PersistStationLogin
WorkstationSettings..::..PersistStationLogin


Dispose Method

[image] [image]

IceLib Technical Reference
Session..::..Dispose Method
Session Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases the resources used by the Session.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Dispose Method

[image]

IceLib Technical Reference
Session..::..Dispose Method
Session Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
Dispose Overload
ININ.IceLib.Connection Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
Session..::..Dispose Method (Boolean)
Session Class See Also Send Feedback
Releases the resources used by the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the object is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
Dispose Overload
ININ.IceLib.Connection Namespace


ForceUserLogout Method

[image]

IceLib Technical Reference
Session..::..ForceUserLogout Method
Session Class See Also Send Feedback
Force logout a user from all the applications.

Note: This method is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ForceUserLogout(
    string userId
)
Visual Basic
Public Sub ForceUserLogout ( _
    userId As String _
)

Parameters

userId
Type: System..::..String
User ID to be forced logout.

Remarks

An appropriate IceLibException will be thrown if the is user not logged out.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ForceUserLogoutAsync Method

[image]

IceLib Technical Reference
Session..::..ForceUserLogoutAsync Method
Session Class See Also Send Feedback
Asynchronously logs out user from all the applications.

Note: This method is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ForceUserLogoutAsync(
    string userId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ForceUserLogoutAsync ( _
    userId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userId
Type: System..::..String
User ID to be forced logout.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

An appropriate IceLibException will be thrown if the is user not logged out.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetAllowableAuthentications Method

[image] [image]

IceLib Technical Reference
Session..::..GetAllowableAuthentications Method
Session Class See Also Send Feedback

Overload List

Name | Description
GetAllowableAuthentications(AllowableAuthenticationsParameters) | Gets the allowable authentication types.
GetAllowableAuthentications(HostSettings) | Gets the allowable authentication types.
GetAllowableAuthentications(HostSettings, String) | Gets the allowable authentication types.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetAllowableAuthentications Method (AllowableAuthenticationsParameters)

[image]

IceLib Technical Reference
Session..::..GetAllowableAuthentications Method (AllowableAuthenticationsParameters)
Session Class See Also Send Feedback
Gets the allowable authentication types.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static AllowableAuthentications GetAllowableAuthentications(
    AllowableAuthenticationsParameters parameters
)
Visual Basic
Public Shared Function GetAllowableAuthentications ( _
    parameters As AllowableAuthenticationsParameters _
) As AllowableAuthentications

Parameters

parameters
Type: ININ.IceLib.Connection..::..AllowableAuthenticationsParameters
The AllowableAuthentications object used to look up the allowable authentications.

Return Value

An AllowableAuthentications object defining the allowable authentication types.

Remarks

Interaction Administrator can be used to configure which authentication types are allowed to be used to connect. Those types will be presented in the application login options.

Exceptions

Exception | Condition
System..::..ArgumentNullException | HostSettings is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

Session Class
Session Members
GetAllowableAuthentications Overload
ININ.IceLib.Connection Namespace


GetAllowableAuthentications Method (HostSettings)

[image]

IceLib Technical Reference
Session..::..GetAllowableAuthentications Method (HostSettings)
Session Class See Also Send Feedback
Gets the allowable authentication types.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static AllowableAuthentications GetAllowableAuthentications(
    HostSettings hostSettings
)
Visual Basic
Public Shared Function GetAllowableAuthentications ( _
    hostSettings As HostSettings _
) As AllowableAuthentications

Parameters

hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.

Return Value

An AllowableAuthentications object defining the allowable authentication types.

Remarks

Interaction Administrator can be used to configure which authentication types are allowed to be used to connect. Those types will be presented in the application login options.

Exceptions

Exception | Condition
System..::..ArgumentNullException | HostSettings is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Session Class
Session Members
GetAllowableAuthentications Overload
ININ.IceLib.Connection Namespace


GetAllowableAuthentications Method (HostSettings, String)

[image]

IceLib Technical Reference
Session..::..GetAllowableAuthentications Method (HostSettings, String)
Session Class See Also Send Feedback
Gets the allowable authentication types.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static AllowableAuthentications GetAllowableAuthentications(
    HostSettings hostSettings,
    string isoLanguage
)
Visual Basic
Public Shared Function GetAllowableAuthentications ( _
    hostSettings As HostSettings, _
    isoLanguage As String _
) As AllowableAuthentications

Parameters

hostSettings
Type: ININ.IceLib.Connection..::..HostSettings
The HostSettings for the connection.
isoLanguage
Type: System..::..String
The ISO culture name that will be used to localize display strings.

Return Value

An AllowableAuthentications object defining the allowable authentication types.

Remarks

Interaction Administrator can be used to configure which authentication types are allowed to be used to connect. Those types will be presented in the application login options.

Exceptions

Exception | Condition
System..::..ArgumentNullException | HostSettings is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Session Class
Session Members
GetAllowableAuthentications Overload
ININ.IceLib.Connection Namespace


GetAuthenticationToken Method

[image]

IceLib Technical Reference
Session..::..GetAuthenticationToken Method
Session Class See Also Send Feedback
Gets the authentication token for the Session.

Note: This method is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetAuthenticationTokenResult GetAuthenticationToken()
Visual Basic
Public Function GetAuthenticationToken As GetAuthenticationTokenResult

Return Value

An GetAuthenticationTokenResult object that contains the authentication token and seed.

Remarks

The authentication token can be used to create a new separate session without requiring user credentials, for example using web services.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetAuthenticationTokenAsync Method

[image]

IceLib Technical Reference
Session..::..GetAuthenticationTokenAsync Method
Session Class See Also Send Feedback
Asynchronously gets the authentication token for the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetAuthenticationTokenAsync(
    EventHandler<GetAuthenticationTokenCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetAuthenticationTokenAsync ( _
    completedCallback As EventHandler(Of GetAuthenticationTokenCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetAuthenticationTokenCompletedEventArgs >)>)>
userState
Type: System..::..Object

Remarks

The authentication token can be used to create a new separate session without requiring user credentials, for example using web services.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

The request timed out while waiting for a response.The Session does not have a valid connection.The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetAuthSettings Method

[image]

IceLib Technical Reference
Session..::..GetAuthSettings Method
Session Class See Also Send Feedback
Gets a copy of the AuthSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AuthSettings GetAuthSettings()
Visual Basic
Public Function GetAuthSettings As AuthSettings

Return Value

The Session's AuthSettings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetCachedAllowableAuthentications Method

[image] [image]

IceLib Technical Reference
Session..::..GetCachedAllowableAuthentications Method
Session Class See Also Send Feedback

Overload List

Name | Description
GetCachedAllowableAuthentications(String) | Gets the cached allowable authentication types.
GetCachedAllowableAuthentications(CachedAllowableAuthenticationsParameters) | Gets the cached allowable authentication types.
GetCachedAllowableAuthentications(String, String) | Gets the cached allowable authentication types.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetCachedAllowableAuthentications Method (String)

[image]

IceLib Technical Reference
Session..::..GetCachedAllowableAuthentications Method (String)
Session Class See Also Send Feedback
Gets the cached allowable authentication types.

Note: This method is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static AllowableAuthentications GetCachedAllowableAuthentications(
    string hostName
)
Visual Basic
Public Shared Function GetCachedAllowableAuthentications ( _
    hostName As String _
) As AllowableAuthentications

Parameters

hostName
Type: System..::..String
The name of the host used to look up the allowable authentications.

Return Value

An AllowableAuthentications object defining the allowable authentication types.

Remarks

Interaction Administrator can be used to configure which authentication types are allowed to be used to connect. Those types will be presented in the application login options.

Exceptions

Exception | Condition
System..::..ArgumentNullException | hostName is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | hostName is Empty.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

Session Class
Session Members
GetCachedAllowableAuthentications Overload
ININ.IceLib.Connection Namespace


GetCachedAllowableAuthentications Method (CachedAllowableAuthenticationsParameters)

[image]

IceLib Technical Reference
Session..::..GetCachedAllowableAuthentications Method (CachedAllowableAuthenticationsParameters)
Session Class See Also Send Feedback
Gets the cached allowable authentication types.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static AllowableAuthentications GetCachedAllowableAuthentications(
    CachedAllowableAuthenticationsParameters parameters
)
Visual Basic
Public Shared Function GetCachedAllowableAuthentications ( _
    parameters As CachedAllowableAuthenticationsParameters _
) As AllowableAuthentications

Parameters

parameters
Type: ININ.IceLib.Connection..::..CachedAllowableAuthenticationsParameters
The CachedAllowableAuthenticationsParameters object used to look up the allowable authentications.

Return Value

An AllowableAuthentications object defining the allowable authentication types.

Remarks

Interaction Administrator can be used to configure which authentication types are allowed to be used to connect. Those types will be presented in the application login options.

Exceptions

Exception | Condition
System..::..ArgumentNullException | parameters is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

Session Class
Session Members
GetCachedAllowableAuthentications Overload
ININ.IceLib.Connection Namespace


GetCachedAllowableAuthentications Method (String, String)

[image]

IceLib Technical Reference
Session..::..GetCachedAllowableAuthentications Method (String, String)
Session Class See Also Send Feedback
Gets the cached allowable authentication types.

Note: This method is supported for IC Server version 2015 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static AllowableAuthentications GetCachedAllowableAuthentications(
    string hostName,
    string isoLanguage
)
Visual Basic
Public Shared Function GetCachedAllowableAuthentications ( _
    hostName As String, _
    isoLanguage As String _
) As AllowableAuthentications

Parameters

hostName
Type: System..::..String
The name of the host used to look up the allowable authentications.
isoLanguage
Type: System..::..String
The ISO culture name that will be used to localize display strings.

Return Value

An AllowableAuthentications object defining the allowable authentication types.

Remarks

Interaction Administrator can be used to configure which authentication types are allowed to be used to connect. Those types will be presented in the application login options.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R2 and beyond.

See Also

Session Class
Session Members
GetCachedAllowableAuthentications Overload
ININ.IceLib.Connection Namespace


GetHostSettings Method

[image]

IceLib Technical Reference
Session..::..GetHostSettings Method
Session Class See Also Send Feedback
Gets a copy of the HostSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostSettings GetHostSettings()
Visual Basic
Public Function GetHostSettings As HostSettings

Return Value

The Session's HostSettings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetSessionSettings Method

[image]

IceLib Technical Reference
Session..::..GetSessionSettings Method
Session Class See Also Send Feedback
Gets a copy of the SessionSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionSettings GetSessionSettings()
Visual Basic
Public Function GetSessionSettings As SessionSettings

Return Value

The Session's SessionSettings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetStationInfo Method

[image]

IceLib Technical Reference
Session..::..GetStationInfo Method
Session Class Example See Also Send Feedback
Gets a copy of the StationInfo.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationInfo GetStationInfo()
Visual Basic
Public Function GetStationInfo As StationInfo

Return Value

The Session's StationInfo.

Examples

The IceLib SDK includes example application references to the GetStationInfo method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 214, in ConnectionViewModel.SetStationValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


GetStationSettings Method

[image]

IceLib Technical Reference
Session..::..GetStationSettings Method
Session Class Example See Also Send Feedback
Gets a copy of the StationSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationSettings GetStationSettings()
Visual Basic
Public Function GetStationSettings As StationSettings

Return Value

The Session's StationSettings.

Examples

The IceLib SDK includes example application references to the GetStationSettings method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | ChangeStationViewModel.cs, line 26, in ChangeStationViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SetAutoReconnectInterval Method

[image] [image]

IceLib Technical Reference
Session..::..SetAutoReconnectInterval Method
Session Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAutoReconnectInterval(Int32) | Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost.
Public method | SetAutoReconnectInterval(Int32, Int32) | Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost, allowing a difference between the amount of time before an initial reconnect and all subsequent reconnect attempts.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SetAutoReconnectInterval Method (Int32)

[image]

IceLib Technical Reference
Session..::..SetAutoReconnectInterval Method (Int32)
Session Class See Also Send Feedback
Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAutoReconnectInterval(
    int interval
)
Visual Basic
Public Sub SetAutoReconnectInterval ( _
    interval As Integer _
)

Parameters

interval
Type: System..::..Int32
The time, in seconds, to wait between reconnection attempts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
SetAutoReconnectInterval Overload
ININ.IceLib.Connection Namespace


SetAutoReconnectInterval Method (Int32, Int32)

[image]

IceLib Technical Reference
Session..::..SetAutoReconnectInterval Method (Int32, Int32)
Session Class See Also Send Feedback
Sets the amount of time (in seconds) to wait between reconnection attempts when the connection has been lost, allowing a difference between the amount of time before an initial reconnect and all subsequent reconnect attempts.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAutoReconnectInterval(
    int initialInterval,
    int subsequentIntervals
)
Visual Basic
Public Sub SetAutoReconnectInterval ( _
    initialInterval As Integer, _
    subsequentIntervals As Integer _
)

Parameters

initialInterval
Type: System..::..Int32
The time, in seconds, to wait before performing an initial reconnection attempt.
subsequentIntervals
Type: System..::..Int32
The time, in seconds, to wait between all reconnection attempts after the first reconnection attempt has occurred.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | An invalid interval parameter value was used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
SetAutoReconnectInterval Overload
ININ.IceLib.Connection Namespace


SetReadyForInteractions Method

[image]

IceLib Technical Reference
Session..::..SetReadyForInteractions Method
Session Class See Also Send Feedback
Signals the application's readiness to make or receive Interactions.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetReadyForInteractions()
Visual Basic
Public Sub SetReadyForInteractions

Remarks

This need only be called if the value of ReadyForInteractions requires it.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
SessionSettings..::..ReadyForInteractions


SetReadyForInteractionsAsync Method

[image]

IceLib Technical Reference
Session..::..SetReadyForInteractionsAsync Method
Session Class See Also Send Feedback
Asynchronously signals the application's readiness to make or receive Interactions.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetReadyForInteractionsAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetReadyForInteractionsAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This need only be called if the value of ReadyForInteractions requires it.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
SessionSettings..::..ReadyForInteractions


SetStationConnectionMode Method

[image]

IceLib Technical Reference
Session..::..SetStationConnectionMode Method
Session Class See Also Send Feedback
Sets the station connection mode for the session, which controls when the user is logged out of the station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStationConnectionMode(
    StationConnectionMode stationConnectionMode,
    int applicationGroupId
)
Visual Basic
Public Sub SetStationConnectionMode ( _
    stationConnectionMode As StationConnectionMode, _
    applicationGroupId As Integer _
)

Parameters

stationConnectionMode
Type: ININ.IceLib.Connection..::..StationConnectionMode
The station connection mode.
applicationGroupId
Type: System..::..Int32
The application group ID.

Remarks

The StationConnectionMode controls whether the user remains connected to the station, or is logged out of the station when the IceLib session is disconnected. See the documentation for StationConnectionMode for a description of each mode.

For cases where the station connection remains after the IceLib Session disconnects, the applicationGroupId is used to group the station connections made by the specific client application so that the application can manage them from subsequent IceLib sessions.

SetStationConnectionMode behavior has changed as of 3.0 SU 19 and 4.0 SU 5. This method should still be invoked to preserve backwards compatibility with older 3.0/4.0 SUs; however, to utilize the new station login persistence model, a new property should be set on the appropriate StationSettings-derived class: PersistStationLogin, PersistStationLogin, and PersistStationLogin. Additionally, a new Disconnect(Boolean) method has been added to allow specifying the expected behavior of the persisted station login when disconnecting a session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SetStationConnectionModeAsync Method

[image]

IceLib Technical Reference
Session..::..SetStationConnectionModeAsync Method
Session Class See Also Send Feedback
Asynchronously sets the station connection mode for the session, which controls when the user is logged out of the station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStationConnectionModeAsync(
    StationConnectionMode stationConnectionMode,
    int applicationGroupId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetStationConnectionModeAsync ( _
    stationConnectionMode As StationConnectionMode, _
    applicationGroupId As Integer, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

stationConnectionMode
Type: ININ.IceLib.Connection..::..StationConnectionMode
The station connection mode.
applicationGroupId
Type: System..::..Int32
The application group ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

SetStationConnectionModeAsync behavior has changed as of 3.0 SU 19 and 4.0 SU 5. This method should still be invoked to preserve backwards compatibility with older 3.0/4.0 SUs; however, to utilize the new station login persistence model, a new property should be set on the appropriate StationSettings-derived class: PersistStationLogin, PersistStationLogin, and PersistStationLogin. Additionally, a new Disconnect(Boolean) method has been added to allow specifying the expected behavior of the persisted station login when disconnecting a session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Session Properties

[image] [image]

IceLib Technical Reference
Session Properties
Session Class See Also Send Feedback

The Session type exposes the following members.

Properties

Name Description
Public property AdditionalUtcOffset
Gets or sets an additional clock skew for the session.
Public property AttemptToSetThreadCulture
Gets or sets a value indicating whether to attempt to set IceLib's background threads' CurrentUICulture.
Public property AutoReconnectEnabled
Enables or disables automatic reconnection attempts when the connection is lost.
Public property AutoReconnecting
Identifies whether an AutoReconnect is in the process of occurring.
Public property ClockSkew
Gets the clock skew.
Public property ConnectionState
Gets the current ConnectionState of the Session.
Public property ConnectionStateMessage
Gets the most recent text description of the state of the Session.
Public property ConnectionStateReason
Gets the current ConnectionStateReason of the Session.
Public property CultureInfo
Gets the culture info, as specified by SessionSettings.IsoLanguage.
Public property CustomerName
Gets the name of the customer to whom IC is licensed.
Public property DisplayName
Gets the display name for the logged in user.
Public property EffectiveStation
Gets the effective station that the user is logged in to.

Remarks

This value is initially set to Empty, and will be updated after the session user logs into a station.
Public property Endpoint
Returns a new HostEndpoint containing the details of the currently connected HostEndpoint.
Public property ICServer
Gets the name of the IC server to which the session is connected.
Public property InteractionCenterReleaseVersion
Gets the release version information of the Interaction Center to which the session is connected (if available).
Public property IsEncrypted Obsolete.
Returns whether the current connection is encrypted.
Public property RawSessionId
The internal Session ID as a UInt32.
Public property SensitiveDataContext
Gets the sensitive data context for this session.
Public property SessionId
The internal Session ID.
Public property SessionManagerName
Gets the relative distinguished name (RDN) of the SessionManager to which the session is connected.
Public property SessionManagerNameFQDN
Gets the fully qualified domain name (FQDN) of the SessionManager to which the session is connected.
Public property SessionManagerReleaseVersion
Gets the release version information of the Session Manager to which the session is connected (if available).
Public property SessionManagerVersion
Gets the version number of the SessionManager to which the session is connected (if available).
Public property SupportedMedia
Gets the supported media flags (SupportedMedia).
Public property UserAgreement
Gets the user agreement text.
Public property UserId
Gets the ID of the logged in IC user.
Public property UserLogOnId
Gets the log on ID of the logged in IC user.

See Also

Session Class
ININ.IceLib.Connection Namespace


AdditionalUtcOffset Property

[image]

IceLib Technical Reference
Session..::..AdditionalUtcOffset Property
Session Class See Also Send Feedback
Gets or sets an additional clock skew for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan AdditionalUtcOffset { get; set; }
Visual Basic
Public Property AdditionalUtcOffset As TimeSpan
    Get
    Set

Field Value

The additional clock skew.

Remarks

The default is a time span of 0. This can be changed to perform a "proxy" time adjustment as if the user were logging in from another machine. For instance, a web server might want to artificially adjust time to match where the web browser is running.

This time span will be added into all IceLib DateTime values:

  • [Clock Skew] = [Server Time Now in Local Time] - [Client Time Now]
  • [IceLib Client Time] = [Server Time in Local Time] - [Clock Skew] - [AdditionalUtcOffset]
  • [Server Time in Local Time] = [IceLib Client Time] + [Clock Skew] + [AdditionalUtcOffset]

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
SessionSettings..::..MachineName


AttemptToSetThreadCulture Property

[image]

IceLib Technical Reference
Session..::..AttemptToSetThreadCulture Property
Session Class See Also Send Feedback
Gets or sets a value indicating whether to attempt to set IceLib's background threads' CurrentUICulture.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AttemptToSetThreadCulture { get; set; }
Visual Basic
Public Property AttemptToSetThreadCulture As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should attempt to set thread culture; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This is an optional convenience that simplifies the work of any custom applications that require their threads' CurrentUICulture to be set. IceLib does not rely on AttemptToSetThreadCulture for whether it should load its string resources, but does use CultureInfo.

If set to trueTruetruetrue (True in Visual Basic), IceLib will attempt to set the CurrentUICulture of its background threads to the value in CultureInfo (as specified by SessionSettings.IsoLanguage).

Note
The background threads' CurrentCulture will never be set by IceLib.

This setting defaults to trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
Session..::..CultureInfo


AutoReconnectEnabled Property

[image]

IceLib Technical Reference
Session..::..AutoReconnectEnabled Property
Session Class See Also Send Feedback
Enables or disables automatic reconnection attempts when the connection is lost.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AutoReconnectEnabled { get; set; }
Visual Basic
Public Property AutoReconnectEnabled As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if auto reconnect is enabled; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


AutoReconnecting Property

[image]

IceLib Technical Reference
Session..::..AutoReconnecting Property
Session Class See Also Send Feedback
Identifies whether an AutoReconnect is in the process of occurring.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AutoReconnecting { get; }
Visual Basic
Public ReadOnly Property AutoReconnecting As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if auto reconnecting; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ClockSkew Property

[image]

IceLib Technical Reference
Session..::..ClockSkew Property
Session Class See Also Send Feedback
Gets the clock skew.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan ClockSkew { get; }
Visual Basic
Public ReadOnly Property ClockSkew As TimeSpan
    Get

Field Value

The clock skew.

Remarks

The clock skew accounts for slight differences in the clock adjustment of the local client versus the IC server. It does not account for timezone differences.

This value is exposed to allow conversion of times between client and server for custom attributes or other values outside of the control of IceLib itself.

The relationship of clock skew to client and server times can be described as follows:

  • [Clock Skew] = [Server Time Now in Local Time] - [Client Time Now]
  • [IceLib Client Time] = [Server Time in Local Time] - [Clock Skew] - [AdditionalUtcOffset]
  • [Server Time in Local Time] = [IceLib Client Time] + [Clock Skew] + [AdditionalUtcOffset]

As shown, IceLib DateTime values are also affected by the AdditionalUtcOffset, if one is specified.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
Session..::..AdditionalUtcOffset


ConnectionState Property

[image]

IceLib Technical Reference
Session..::..ConnectionState Property
Session Class See Also Send Feedback
Gets the current ConnectionState of the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConnectionState ConnectionState { get; }
Visual Basic
Public ReadOnly Property ConnectionState As ConnectionState
    Get

Field Value

The connection state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ConnectionStateMessage Property

[image]

IceLib Technical Reference
Session..::..ConnectionStateMessage Property
Session Class Example See Also Send Feedback
Gets the most recent text description of the state of the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ConnectionStateMessage { get; }
Visual Basic
Public ReadOnly Property ConnectionStateMessage As String
    Get

Field Value

The connection state message.

Examples

The IceLib SDK includes example application references to the ConnectionStateMessage property. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 206, in ConnectionViewModel.SetSessionValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ConnectionStateReason Property

[image]

IceLib Technical Reference
Session..::..ConnectionStateReason Property
Session Class See Also Send Feedback
Gets the current ConnectionStateReason of the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConnectionStateReason ConnectionStateReason { get; }
Visual Basic
Public ReadOnly Property ConnectionStateReason As ConnectionStateReason
    Get

Field Value

The connection state reason.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


CultureInfo Property

[image]

IceLib Technical Reference
Session..::..CultureInfo Property
Session Class See Also Send Feedback
Gets the culture info, as specified by SessionSettings.IsoLanguage.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CultureInfo CultureInfo { get; }
Visual Basic
Public ReadOnly Property CultureInfo As CultureInfo
    Get

Field Value

The culture info.

Remarks

This value is used to load IceLib's string resources. If AttemptToSetThreadCulture is set to trueTruetruetrue (True in Visual Basic), this value will also be applied to IceLib's background threads' CurrentUICulture.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
Session..::..AttemptToSetThreadCulture
SessionSettings.IsoLanguage


CustomerName Property

[image]

IceLib Technical Reference
Session..::..CustomerName Property
Session Class See Also Send Feedback
Gets the name of the customer to whom IC is licensed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CustomerName { get; }
Visual Basic
Public ReadOnly Property CustomerName As String
    Get

Field Value

The name of the customer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


DisplayName Property

[image]

IceLib Technical Reference
Session..::..DisplayName Property
Session Class See Also Send Feedback
Gets the display name for the logged in user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Return Value

The logged in user's display name or Empty if the display name is not available.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


EffectiveStation Property

[image]

IceLib Technical Reference
Session..::..EffectiveStation Property
Session Class See Also Send Feedback
Gets the effective station that the user is logged in to.

Remarks

This value is initially set to Empty, and will be updated after the session user logs into a station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EffectiveStation { get; }
Visual Basic
Public ReadOnly Property EffectiveStation As String
    Get

Field Value

The effective station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Endpoint Property

[image]

IceLib Technical Reference
Session..::..Endpoint Property
Session Class See Also Send Feedback
Returns a new HostEndpoint containing the details of the currently connected HostEndpoint.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostEndpoint Endpoint { get; }
Visual Basic
Public ReadOnly Property Endpoint As HostEndpoint
    Get

Field Value

The endpoint.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


ICServer Property

[image]

IceLib Technical Reference
Session..::..ICServer Property
Session Class Example See Also Send Feedback
Gets the name of the IC server to which the session is connected.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICServer { get; }
Visual Basic
Public ReadOnly Property ICServer As String
    Get

Field Value

The IC server.

Examples

The IceLib SDK includes example application references to the ICServer property. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 198, in ConnectionViewModel.SetSessionValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


InteractionCenterReleaseVersion Property

[image]

IceLib Technical Reference
Session..::..InteractionCenterReleaseVersion Property
Session Class See Also Send Feedback
Gets the release version information of the Interaction Center to which the session is connected (if available).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Version InteractionCenterReleaseVersion { get; }
Visual Basic
Public ReadOnly Property InteractionCenterReleaseVersion As Version
    Get

Field Value

The Interaction Center version.

Remarks

This property contains major version, minor version and SU version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


IsEncrypted Property

[image]

IceLib Technical Reference
Session..::..IsEncrypted Property
Session Class See Also Send Feedback
Returns whether the current connection is encrypted.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("As of 4.0 IceLib, this property is no longer used, connections to any 4.0+ IC Server is always encrypted.")]
public bool IsEncrypted { get; }
Visual Basic
<ObsoleteAttribute("As of 4.0 IceLib, this property is no longer used, connections to any 4.0+ IC Server is always encrypted.")> _
Public ReadOnly Property IsEncrypted As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is encrypted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


RawSessionId Property

[image]

IceLib Technical Reference
Session..::..RawSessionId Property
Session Class See Also Send Feedback
The internal Session ID as a UInt32.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[CLSCompliantAttribute(false)]
public uint RawSessionId { get; }
Visual Basic
<CLSCompliantAttribute(False)> _
Public ReadOnly Property RawSessionId As UInteger
    Get

Field Value

The session ID.

Remarks

This value can be used for diagnostic purposes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SensitiveDataContext Property

[image]

IceLib Technical Reference
Session..::..SensitiveDataContext Property
Session Class See Also Send Feedback
Gets the sensitive data context for this session.

Note: This property is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SensitiveDataContext SensitiveDataContext { get; }
Visual Basic
Public ReadOnly Property SensitiveDataContext As SensitiveDataContext
    Get

Field Value

The sensitive data context.

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace
Session..::..SensitiveDataContext


SessionId Property

[image]

IceLib Technical Reference
Session..::..SessionId Property
Session Class See Also Send Feedback
The internal Session ID.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long SessionId { get; }
Visual Basic
Public ReadOnly Property SessionId As Long
    Get

Field Value

The session ID.

Remarks

This value can be used for diagnostic purposes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SessionManagerName Property

[image]

IceLib Technical Reference
Session..::..SessionManagerName Property
Session Class Example See Also Send Feedback
Gets the relative distinguished name (RDN) of the SessionManager to which the session is connected.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SessionManagerName { get; }
Visual Basic
Public ReadOnly Property SessionManagerName As String
    Get

Field Value

The RDN of the session manager.

Examples

The IceLib SDK includes example application references to the SessionManagerName property. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 197, in ConnectionViewModel.SetSessionValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SessionManagerNameFQDN Property

[image]

IceLib Technical Reference
Session..::..SessionManagerNameFQDN Property
Session Class See Also Send Feedback
Gets the fully qualified domain name (FQDN) of the SessionManager to which the session is connected.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SessionManagerNameFQDN { get; }
Visual Basic
Public ReadOnly Property SessionManagerNameFQDN As String
    Get

Field Value

The FQDN of the session manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SessionManagerReleaseVersion Property

[image]

IceLib Technical Reference
Session..::..SessionManagerReleaseVersion Property
Session Class See Also Send Feedback
Gets the release version information of the Session Manager to which the session is connected (if available).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Version SessionManagerReleaseVersion { get; }
Visual Basic
Public ReadOnly Property SessionManagerReleaseVersion As Version
    Get

Field Value

The Session Manager version.

Remarks

This property contains major version, minor version and SU version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SessionManagerVersion Property

[image]

IceLib Technical Reference
Session..::..SessionManagerVersion Property
Session Class See Also Send Feedback
Gets the version number of the SessionManager to which the session is connected (if available).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Version SessionManagerVersion { get; }
Visual Basic
Public ReadOnly Property SessionManagerVersion As Version
    Get

Field Value

The session manager version.

Remarks

Note that this version info wasn't available until version 2.4 Feature Pack 1. When connecting to SessionManagers of an earlier version the string will be empty. This version is the file version of the session manager. Please refer to InteractionCenterReleaseVersion and SessionManagerReleaseVersion to know the major, minor and SU versions of the IC server and Session Manager respectively.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SupportedMedia Property

[image]

IceLib Technical Reference
Session..::..SupportedMedia Property
Session Class See Also Send Feedback
Gets the supported media flags (SupportedMedia).

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SupportedMedia SupportedMedia { get; }
Visual Basic
Public ReadOnly Property SupportedMedia As SupportedMedia
    Get

Field Value

The supported media.

Remarks

This value is updated when ChangeStation(StationSettings) or SetStationConnectionMode(StationConnectionMode, Int32) is called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.
For 3.0, supported for IC Server version 3.0 SU 16 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


UserAgreement Property

[image]

IceLib Technical Reference
Session..::..UserAgreement Property
Session Class See Also Send Feedback
Gets the user agreement text.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserAgreement { get; }
Visual Basic
Public ReadOnly Property UserAgreement As String
    Get

Field Value

The user agreement.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


UserId Property

[image]

IceLib Technical Reference
Session..::..UserId Property
Session Class Example See Also Send Feedback
Gets the ID of the logged in IC user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Examples

The IceLib SDK includes example application references to the UserId property. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 198, in ConnectionViewModel.SetSessionValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


UserLogOnId Property

[image]

IceLib Technical Reference
Session..::..UserLogOnId Property
Session Class See Also Send Feedback
Gets the log on ID of the logged in IC user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserLogOnId { get; }
Visual Basic
Public ReadOnly Property UserLogOnId As String
    Get

Field Value

The log on ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


Session Events

[image] [image]

IceLib Technical Reference
Session Events
Session Class See Also Send Feedback

The Session type exposes the following members.

Events

 | Name | Description
Public event | ConnectionStateChanged | Occurs when the Session's ConnectionState changes.
Public event | EffectiveStationChanged | Occurs when the Session user's EffectiveStation changes.
Public event | StationSettingsChanged | Occurs when the Session's StationSettings changes.

See Also

Session Class
ININ.IceLib.Connection Namespace


ConnectionStateChanged Event

[image]

IceLib Technical Reference
Session..::..ConnectionStateChanged Event
Session Class Example See Also Send Feedback
Occurs when the Session's ConnectionState changes.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConnectionStateChangedEventArgs> ConnectionStateChanged
Visual Basic
Public Event ConnectionStateChanged As EventHandler(Of ConnectionStateChangedEventArgs)

Remarks

This event will only occur while the session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) and ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)
Note
All event handlers should be added before calling Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).

Examples

The IceLib SDK includes example application references to the ConnectionStateChanged event. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 28, in SystemStatisticsViewModel.#ctor
 | StatisticCatalogViewModel.cs, line 28, in StatisticCatalogViewModel.#ctor
 | UserRoleConfigurationViewModel.cs, line 144, in UserRoleConfigurationViewModel.#ctor
 | ConnectionViewModel.cs, line 40, in ConnectionViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


EffectiveStationChanged Event

[image]

IceLib Technical Reference
Session..::..EffectiveStationChanged Event
Session Class See Also Send Feedback
Occurs when the Session user's EffectiveStation changes.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EffectiveStationChangedEventArgs> EffectiveStationChanged
Visual Basic
Public Event EffectiveStationChanged As EventHandler(Of EffectiveStationChangedEventArgs)

Remarks

This event will only occur while the session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) and ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)
Note
All event handlers should be added before calling Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


StationSettingsChanged Event

[image]

IceLib Technical Reference
Session..::..StationSettingsChanged Event
Session Class Example See Also Send Feedback
Occurs when the Session's StationSettings changes.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler StationSettingsChanged
Visual Basic
Public Event StationSettingsChanged As EventHandler

Remarks

This event will only occur while the session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) and ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)
Note
All event handlers should be added before calling Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).

Examples

The IceLib SDK includes example application references to the StationSettingsChanged event. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 41, in ConnectionViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Session Class
Session Members
ININ.IceLib.Connection Namespace


SessionDisconnectedException Class

[image]

IceLib Technical Reference
SessionDisconnectedException Class
Members See Also Send Feedback
The exception that is thrown for IceLib when a server operation is requested while the Session is disconnected.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class SessionDisconnectedException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class SessionDisconnectedException _
    Inherits IceLibException

Remarks

This exception is thrown by various IceLib objects when a server operation is requested while the Session is disconnected. If the Session is connected, this SessionDisconnectedException will not be thrown, even if the request times out.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Connection..::..SessionDisconnectedException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Members
ININ.IceLib.Connection Namespace


SessionDisconnectedException Members

[image] [image]

IceLib Technical Reference
SessionDisconnectedException Members
SessionDisconnectedException Class Constructors Methods Properties Events See Also Send Feedback

The SessionDisconnectedException type exposes the following members.

Constructors

 | Name | Description
Public method | SessionDisconnectedException()()()() | Initializes a new instance of the SessionDisconnectedException class with default settings.
Public method | SessionDisconnectedException(Exception) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Public method | SessionDisconnectedException(CultureInfo) | Initializes a new instance of the SessionDisconnectedException class with default settings.
Public method | SessionDisconnectedException(String) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Public method | SessionDisconnectedException(CultureInfo, Exception) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Protected method | SessionDisconnectedException(SerializationInfo, StreamingContext) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Public method | SessionDisconnectedException(String, Exception) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SessionDisconnectedException Class
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor

[image] [image]

IceLib Technical Reference
SessionDisconnectedException Constructor
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class.

Overload List

 | Name | Description
Public method | SessionDisconnectedException()()()() | Initializes a new instance of the SessionDisconnectedException class with default settings.
Public method | SessionDisconnectedException(Exception) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Public method | SessionDisconnectedException(CultureInfo) | Initializes a new instance of the SessionDisconnectedException class with default settings.
Public method | SessionDisconnectedException(String) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Public method | SessionDisconnectedException(CultureInfo, Exception) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Protected method | SessionDisconnectedException(SerializationInfo, StreamingContext) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.
Public method | SessionDisconnectedException(String, Exception) | Initializes a new instance of the SessionDisconnectedException class with a specified error message.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionDisconnectedException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor (Exception)

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor (Exception)
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionDisconnectedException(
    Exception innerException
)
Visual Basic
Public Sub New ( _
    innerException As Exception _
)

Parameters

innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor (CultureInfo)

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor (CultureInfo)
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionDisconnectedException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor (String)

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor (String)
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionDisconnectedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor (CultureInfo, Exception)

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor (CultureInfo, Exception)
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionDisconnectedException(
    CultureInfo cultureInfo,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor (SerializationInfo, StreamingContext)
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected SessionDisconnectedException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Constructor (String, Exception)

[image]

IceLib Technical Reference
SessionDisconnectedException Constructor (String, Exception)
SessionDisconnectedException Class See Also Send Feedback
Initializes a new instance of the SessionDisconnectedException class with a specified error message.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionDisconnectedException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
SessionDisconnectedException Overload
ININ.IceLib.Connection Namespace


SessionDisconnectedException Methods

[image] [image]

IceLib Technical Reference
SessionDisconnectedException Methods
SessionDisconnectedException Class See Also Send Feedback

The SessionDisconnectedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SessionDisconnectedException Class
ININ.IceLib.Connection Namespace


GetObjectData Method

[image]

IceLib Technical Reference
SessionDisconnectedException..::..GetObjectData Method
SessionDisconnectedException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionDisconnectedException Class
SessionDisconnectedException Members
ININ.IceLib.Connection Namespace


SessionDisconnectedException Properties

[image] [image]

IceLib Technical Reference
SessionDisconnectedException Properties
SessionDisconnectedException Class See Also Send Feedback

The SessionDisconnectedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SessionDisconnectedException Class
ININ.IceLib.Connection Namespace


SessionDisconnectedException Events

[image] [image]

IceLib Technical Reference
SessionDisconnectedException Events
SessionDisconnectedException Class See Also Send Feedback

The SessionDisconnectedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SessionDisconnectedException Class
ININ.IceLib.Connection Namespace


SessionSettings Class

[image]

IceLib Technical Reference
SessionSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to configure a session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SessionSettings
Visual Basic
Public Class SessionSettings

Remarks

The SessionSettings object is used to specify overall settings such as the connecting application's name or a specific ISO language to use.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the SessionSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 186, in LoginViewModel.PerformLogin

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..SessionSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


SessionSettings Members

[image] [image]

IceLib Technical Reference
SessionSettings Members
SessionSettings Class Constructors Methods Properties See Also Send Feedback

The SessionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | SessionSettings()()()() | Initializes a new instance of the SessionSettings class with default settings.
Public method | SessionSettings(IDictionary<(Of <<'(String, String>)>>)) | Initializes a new instance of the SessionSettings class with additional settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this SessionSettings object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace |

Properties

 | Name | Description
Public property | ApplicationHostComputerName | Gets the name of the computer that is hosting the Icelib application.
Public property | ApplicationHostDisplayVersion | Gets the application host display version for the session.
Public property | ApplicationHostFileVersion | Gets the application host file version for the session.
Public property | ApplicationName | Gets or sets the Application Name for the session.
Public property | ApplicationProfileName | Gets or sets the Application Profile Name for the session.
Public property | ApplicationTraceId | Gets or sets the Application Trace ID for this session.
Public property | ClassOfService | Gets or sets the ClassOfService for the session.
Public property | CustomSettings | Gets a collection which can be used to set custom parameters for the Session.
Public property | DeviceType | Gets or sets the DeviceType for the session.
Public property | IcelibDisplayVersion | Gets the IceLib display version for the session.
Public property | IcelibFileVersion | Gets the IceLib file version for the session.
Public property | IsoLanguage | Gets or sets the ISO culture name for the session.
Public property | License | Gets or sets the license for this session.
Public property | MachineName | Gets or sets the MachineName for the session.
Public property | MarketPlaceApplicationCode | Gets or sets the MarketPlace application code.
Public property | MarketPlaceApplicationLicenseName | Gets or sets the MarketPlace application's license name.
Public property | ReadyForInteractions | Gets or sets application's readiness to make or receive Interactions.

See Also

SessionSettings Class
ININ.IceLib.Connection Namespace


SessionSettings Constructor

[image] [image]

IceLib Technical Reference
SessionSettings Constructor
SessionSettings Class See Also Send Feedback
Initializes a new instance of the SessionSettings class.

Overload List

 | Name | Description
Public method | SessionSettings()()()() | Initializes a new instance of the SessionSettings class with default settings.
Public method | SessionSettings(IDictionary<(Of <<'(String, String>)>>)) | Initializes a new instance of the SessionSettings class with additional settings.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


SessionSettings Constructor

[image]

IceLib Technical Reference
SessionSettings Constructor
SessionSettings Class Example See Also Send Feedback
Initializes a new instance of the SessionSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionSettings()
Visual Basic
Public Sub New

Examples

The IceLib SDK includes example application references to the SessionSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 186, in LoginViewModel.PerformLogin

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
SessionSettings Overload
ININ.IceLib.Connection Namespace


SessionSettings Constructor (IDictionary(String, String))

[image]

IceLib Technical Reference
SessionSettings Constructor (IDictionary<(Of <(<'String, String>)>)>)
SessionSettings Class See Also Send Feedback
Initializes a new instance of the SessionSettings class with additional settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionSettings(
    IDictionary<string, string> customSettings
)
Visual Basic
Public Sub New ( _
    customSettings As IDictionary(Of String, String) _
)

Parameters

customSettings
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
Additional settings to be passed through during login.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter value is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
SessionSettings Overload
ININ.IceLib.Connection Namespace


SessionSettings Methods

[image] [image]

IceLib Technical Reference
SessionSettings Methods
SessionSettings Class See Also Send Feedback

The SessionSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this SessionSettings object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace |

See Also

SessionSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
SessionSettings..::..Clone Method
SessionSettings Class See Also Send Feedback
Returns an exact copy of this SessionSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual SessionSettings Clone()
Visual Basic
Public Overridable Function Clone As SessionSettings

Return Value

A new SessionSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
SessionSettings..::..ToString Method
SessionSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
SessionSettings..::..ToTrace Method
SessionSettings Class See Also Send Feedback

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ToTrace()
Visual Basic
Public Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


SessionSettings Properties

[image] [image]

IceLib Technical Reference
SessionSettings Properties
SessionSettings Class See Also Send Feedback

The SessionSettings type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationHostComputerName | Gets the name of the computer that is hosting the Icelib application.
Public property | ApplicationHostDisplayVersion | Gets the application host display version for the session.
Public property | ApplicationHostFileVersion | Gets the application host file version for the session.
Public property | ApplicationName | Gets or sets the Application Name for the session.
Public property | ApplicationProfileName | Gets or sets the Application Profile Name for the session.
Public property | ApplicationTraceId | Gets or sets the Application Trace ID for this session.
Public property | ClassOfService | Gets or sets the ClassOfService for the session.
Public property | CustomSettings | Gets a collection which can be used to set custom parameters for the Session.
Public property | DeviceType | Gets or sets the DeviceType for the session.
Public property | IcelibDisplayVersion | Gets the IceLib display version for the session.
Public property | IcelibFileVersion | Gets the IceLib file version for the session.
Public property | IsoLanguage | Gets or sets the ISO culture name for the session.
Public property | License | Gets or sets the license for this session.
Public property | MachineName | Gets or sets the MachineName for the session.
Public property | MarketPlaceApplicationCode | Gets or sets the MarketPlace application code.
Public property | MarketPlaceApplicationLicenseName | Gets or sets the MarketPlace application's license name.
Public property | ReadyForInteractions | Gets or sets application's readiness to make or receive Interactions.

See Also

SessionSettings Class
ININ.IceLib.Connection Namespace


ApplicationHostComputerName Property

[image]

IceLib Technical Reference
SessionSettings..::..ApplicationHostComputerName Property
SessionSettings Class See Also Send Feedback
Gets the name of the computer that is hosting the Icelib application.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationHostComputerName { get; }
Visual Basic
Public ReadOnly Property ApplicationHostComputerName As String
    Get

Field Value

The Application host name.

Remarks

The application host computer name is the name of the computer that is hosting the Icelib application. This property applies specifically to the applications that host several client sessions.

ApplicationHostComputerName is not available for SessionSettings from a SessionWatch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ApplicationHostDisplayVersion Property

[image]

IceLib Technical Reference
SessionSettings..::..ApplicationHostDisplayVersion Property
SessionSettings Class See Also Send Feedback
Gets the application host display version for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationHostDisplayVersion { get; }
Visual Basic
Public ReadOnly Property ApplicationHostDisplayVersion As String
    Get

Field Value

The Application host file version.

Remarks

The application host display version is the user-friendly version of the executable that is hosting the Icelib application.

ApplicationHostDisplayVersion is not available for SessionSettings from a SessionWatch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ApplicationHostFileVersion Property

[image]

IceLib Technical Reference
SessionSettings..::..ApplicationHostFileVersion Property
SessionSettings Class See Also Send Feedback
Gets the application host file version for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationHostFileVersion { get; }
Visual Basic
Public ReadOnly Property ApplicationHostFileVersion As String
    Get

Field Value

The Application host file version.

Remarks

The application host file version is the version of the executable that is hosting the Icelib application.

ApplicationHostFileVersion is not available for SessionSettings from a SessionWatch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ApplicationName Property

[image]

IceLib Technical Reference
SessionSettings..::..ApplicationName Property
SessionSettings Class See Also Send Feedback
Gets or sets the Application Name for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationName { get; set; }
Visual Basic
Public Property ApplicationName As String
    Get
    Set

Field Value

The name of the application.

Remarks

This setting identifies the application that created the Session. (Defaults to the name of the current process.)

The value will show up in the Supervisor view for SessionManager. It will also be used for future associations of plug-ins to applications. So, please set it to a constant value representing the application.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ApplicationProfileName Property

[image]

IceLib Technical Reference
SessionSettings..::..ApplicationProfileName Property
SessionSettings Class See Also Send Feedback
Gets or sets the Application Profile Name for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationProfileName { get; set; }
Visual Basic
Public Property ApplicationProfileName As String
    Get
    Set

Field Value

The profile name for the application.

Remarks

See the CustomProfile object to see how this value affects how Custom Profiles work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ApplicationTraceId Property

[image]

IceLib Technical Reference
SessionSettings..::..ApplicationTraceId Property
SessionSettings Class See Also Send Feedback
Gets or sets the Application Trace ID for this session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationTraceId { get; set; }
Visual Basic
Public Property ApplicationTraceId As String
    Get
    Set

Field Value

The Application Trace ID.

Remarks

This setting identifies the application that created this Session for unified tracing purposes.

The value will show up in the Tracing section of Interaction Administrator.

Note
This setting is primarily used for internal PureConnect applications to associate themselves with the elevated trace levels configured in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ClassOfService Property

[image]

IceLib Technical Reference
SessionSettings..::..ClassOfService Property
SessionSettings Class See Also Send Feedback
Gets or sets the ClassOfService for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ClassOfService ClassOfService { get; set; }
Visual Basic
Public Property ClassOfService As ClassOfService
    Get
    Set

Field Value

The class of service.

Remarks

The default is HighlyAvailable.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | This exception occurs when the specified class of service is not from the ClassOfService enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


CustomSettings Property

[image]

IceLib Technical Reference
SessionSettings..::..CustomSettings Property
SessionSettings Class See Also Send Feedback
Gets a collection which can be used to set custom parameters for the Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> CustomSettings { get; }
Visual Basic
Public ReadOnly Property CustomSettings As IDictionary(Of String, String)
    Get

Field Value

The custom settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


DeviceType Property

[image]

IceLib Technical Reference
SessionSettings..::..DeviceType Property
SessionSettings Class See Also Send Feedback
Gets or sets the DeviceType for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DeviceType DeviceType { get; set; }
Visual Basic
Public Property DeviceType As DeviceType
    Get
    Set

Field Value

The device type.

Remarks

The default is Win32.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified device type is not from the DeviceType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


IcelibDisplayVersion Property

[image]

IceLib Technical Reference
SessionSettings..::..IcelibDisplayVersion Property
SessionSettings Class See Also Send Feedback
Gets the IceLib display version for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IcelibDisplayVersion { get; }
Visual Basic
Public ReadOnly Property IcelibDisplayVersion As String
    Get

Field Value

The IceLib display version.

Remarks

The IceLib display version is the user-friendly file version of ININ.Icelib.dll.

IcelibDisplayVersion is not available for SessionSettings from a SessionWatch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


IcelibFileVersion Property

[image]

IceLib Technical Reference
SessionSettings..::..IcelibFileVersion Property
SessionSettings Class See Also Send Feedback
Gets the IceLib file version for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IcelibFileVersion { get; }
Visual Basic
Public ReadOnly Property IcelibFileVersion As String
    Get

Field Value

The IceLib file version.

Remarks

The IceLib file version is the version of the ININ.Icelib.dll

IcelibFileVersion is not available for SessionSettings from a SessionWatch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


IsoLanguage Property

[image]

IceLib Technical Reference
SessionSettings..::..IsoLanguage Property
SessionSettings Class See Also Send Feedback
Gets or sets the ISO culture name for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IsoLanguage { get; set; }
Visual Basic
Public Property IsoLanguage As String
    Get
    Set

Field Value

The ISO language.

Remarks

The ISO culture name is in the format "<languagecode2>-<country/regioncode2>" and defaults to System.Globalization.CultureInfo.CurrentUICulture.Name. Set this value to control the language of strings returned from Session Manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace
Session..::..CultureInfo


License Property

[image]

IceLib Technical Reference
SessionSettings..::..License Property
SessionSettings Class See Also Send Feedback
Gets or sets the license for this session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string License { get; set; }
Visual Basic
Public Property License As String
    Get
    Set

Field Value

The license or nullNothingnullptra null reference (Nothing in Visual Basic) to indicate license is not set.

Remarks

If the license specified is not available, the session will not connect.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


MachineName Property

[image]

IceLib Technical Reference
SessionSettings..::..MachineName Property
SessionSettings Class See Also Send Feedback
Gets or sets the MachineName for the session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MachineName { get; set; }
Visual Basic
Public Property MachineName As String
    Get
    Set

Field Value

The machine name.

Remarks

The default is the MachineName. This can be changed to perform a "proxy" login as if the user were logging in from another machine. For instance, a web server might use a proxy login by specifying the machine name where the web browser is running.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace
Session..::..AdditionalUtcOffset


MarketPlaceApplicationCode Property

[image]

IceLib Technical Reference
SessionSettings..::..MarketPlaceApplicationCode Property
SessionSettings Class See Also Send Feedback
Gets or sets the MarketPlace application code.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MarketPlaceApplicationCode { get; set; }
Visual Basic
Public Property MarketPlaceApplicationCode As String
    Get
    Set

Field Value

The MarketPlace application code.

Remarks

When setting this, the MarketPlaceApplicationLicenseName property should also be set. This value can be obtained from the MarketPlace Application's registration information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


MarketPlaceApplicationLicenseName Property

[image]

IceLib Technical Reference
SessionSettings..::..MarketPlaceApplicationLicenseName Property
SessionSettings Class See Also Send Feedback
Gets or sets the MarketPlace application's license name.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MarketPlaceApplicationLicenseName { get; set; }
Visual Basic
Public Property MarketPlaceApplicationLicenseName As String
    Get
    Set

Field Value

The MarketPlace application's license name.

Remarks

When setting this, the MarketPlaceApplicationCode property should also be set. This value can be obtained from the MarketPlace Application's registration information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


ReadyForInteractions Property

[image]

IceLib Technical Reference
SessionSettings..::..ReadyForInteractions Property
SessionSettings Class See Also Send Feedback
Gets or sets application's readiness to make or receive Interactions.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadyForInteractionsType ReadyForInteractions { get; set; }
Visual Basic
Public Property ReadyForInteractions As ReadyForInteractionsType
    Get
    Set

Field Value

The application's readiness to make or receive Interactions.

Remarks

The default is AfterLogin | AfterChangeStation.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not from the ReadyForInteractionsType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

SessionSettings Class
SessionSettings Members
ININ.IceLib.Connection Namespace


SingleSignOnRequestData Class

[image]

IceLib Technical Reference
SingleSignOnRequestData Class
Members See Also Send Feedback
Class used to supply information to a web browser control when using Single Sign On with an that uses .

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SingleSignOnRequestData
Visual Basic
Public Class SingleSignOnRequestData

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..SingleSignOnRequestData

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

SingleSignOnRequestData Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..AuthProviderDefinition
AuthenticationFields..::..Browser


SingleSignOnRequestData Members

[image] [image]

IceLib Technical Reference
SingleSignOnRequestData Members
SingleSignOnRequestData Class Methods Properties See Also Send Feedback

The SingleSignOnRequestData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuthProviderId | Gets the authentication provider ID.
Public property | ScriptableObject | Gets the scriptable object that the web browser control uses to make the completed callback.
Public property | SingleSignOnUri | Gets the Single Sign On URI that the browser control should navigate to.

See Also

SingleSignOnRequestData Class
ININ.IceLib.Connection Namespace


SingleSignOnRequestData Methods

[image] [image]

IceLib Technical Reference
SingleSignOnRequestData Methods
SingleSignOnRequestData Class See Also Send Feedback

The SingleSignOnRequestData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleSignOnRequestData Class
ININ.IceLib.Connection Namespace


SingleSignOnRequestData Properties

[image] [image]

IceLib Technical Reference
SingleSignOnRequestData Properties
SingleSignOnRequestData Class See Also Send Feedback

The SingleSignOnRequestData type exposes the following members.

Properties

 | Name | Description
Public property | AuthProviderId | Gets the authentication provider ID.
Public property | ScriptableObject | Gets the scriptable object that the web browser control uses to make the completed callback.
Public property | SingleSignOnUri | Gets the Single Sign On URI that the browser control should navigate to.

See Also

SingleSignOnRequestData Class
ININ.IceLib.Connection Namespace


AuthProviderId Property

[image]

IceLib Technical Reference
SingleSignOnRequestData..::..AuthProviderId Property
SingleSignOnRequestData Class See Also Send Feedback
Gets the authentication provider ID.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AuthProviderId { get; private set; }
Visual Basic
Public Property AuthProviderId As String
    Get
    Private Set

Field Value

The authentication provider ID.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

SingleSignOnRequestData Class
SingleSignOnRequestData Members
ININ.IceLib.Connection Namespace


ScriptableObject Property

[image]

IceLib Technical Reference
SingleSignOnRequestData..::..ScriptableObject Property
SingleSignOnRequestData Class See Also Send Feedback
Gets the scriptable object that the web browser control uses to make the completed callback.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomFormAuthScriptableClass ScriptableObject { get; private set; }
Visual Basic
Public Property ScriptableObject As CustomFormAuthScriptableClass
    Get
    Private Set

Field Value

The scriptable object.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

SingleSignOnRequestData Class
SingleSignOnRequestData Members
ININ.IceLib.Connection Namespace


SingleSignOnUri Property

[image]

IceLib Technical Reference
SingleSignOnRequestData..::..SingleSignOnUri Property
SingleSignOnRequestData Class See Also Send Feedback
Gets the Single Sign On URI that the browser control should navigate to.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Uri SingleSignOnUri { get; private set; }
Visual Basic
Public Property SingleSignOnUri As Uri
    Get
    Private Set

Field Value

The Single Sign On URI.

Version Information

Supported for IC Server version 2016 R1 and beyond.

See Also

SingleSignOnRequestData Class
SingleSignOnRequestData Members
ININ.IceLib.Connection Namespace


StationConnectionMode Enumeration

[image]

IceLib Technical Reference
StationConnectionMode Enumeration
See Also Send Feedback
Used to change the station login and logout behavior with respect to the IceLib Session.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StationConnectionMode
Visual Basic
Public Enumeration StationConnectionMode

Members

Member name | Value | Description
Default | 0 | The user should be logged out of the station when the IceLib Session is disconnected.
IndependentOfSession | 1 | The user should remain logged into the station when the IceLib Session is disconnected.
IndependentConnectionsLogoutWithSession | 2 | Indicates that this station login, as well as those created for with IndependentOfSession using the same application group ID should be logged out when this IceLib Session is disconnected.

Remarks

The StationConnectionMode can be used to indicate how the system should manage the user's station session. If StationConnectionMode.Default is specified, the user will be logged into the specified station when the IceLib Session connects, and will be logged out of that station when the IceLib Session is disconnected. If IndependentOfSession is specified, the user will be logged into the station while the IceLib Session connects and also after Session disconnects. When IndependentConnectionsLogoutWithSession is used, all station connections for the user that have the same application group ID as the current session will be disconnected when the IceLib Session is disconnected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace
Session..::..SetStationConnectionMode(StationConnectionMode, Int32)


StationInfo Class

[image]

IceLib Technical Reference
StationInfo Class
Members Example See Also Send Feedback
Describes a station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationInfo
Visual Basic
Public Class StationInfo

Remarks

The StationInfo object contains information about the connected Station associated with a Session. You can get or set the station's extension, ID, SIP address, user, and station type, and other properties.

Examples

CopyC#
Session session = new Session();
session.Connect(...);
StationInfo stationInfo = session.GetStationInfo();
if (stationInfo.StationType == StationType.Local)
{
    string extension = stationInfo.Extension;
}

Examples

The IceLib SDK includes example application references to the StationInfo class. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 214, in ConnectionViewModel.SetStationValues

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StationInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Members
ININ.IceLib.Connection Namespace


StationInfo Members

[image] [image]

IceLib Technical Reference
StationInfo Members
StationInfo Class Constructors Methods Properties See Also Send Feedback

The StationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | StationInfo()()()() | Initializes a new instance of the StationInfo class with default settings.
Protected method | StationInfo(StationInfo) | Initializes a new instance of the StationInfo class with another instance.

Methods

 | Name | Description
Public method | Clone | Clones the station info object by making a deep copy of all member values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CanBeDialed | Gets or sets whether the station can be dialed.
Public property | DNDStatusSyncAvailable | Obsolete. Gets a value indicating whether DND status synchronization is available on this station.
Public property | Extension | Gets or sets the station Extension.
Public property | Id | Gets or sets the station ID.
Public property | RingAlways | Gets or sets whether the station will always ring.
Public property | SipAddress | Gets or sets the station Sip address.
Public property | SipPassword | Gets or sets the station Sip password.
Public property | SipUser | Gets or sets the station Sip user.
Public property | Type | Gets or sets the station type.

See Also

StationInfo Class
ININ.IceLib.Connection Namespace


StationInfo Constructor

[image] [image]

IceLib Technical Reference
StationInfo Constructor
StationInfo Class See Also Send Feedback
Initializes a new instance of the StationInfo class.

Overload List

 | Name | Description
Public method | StationInfo()()()() | Initializes a new instance of the StationInfo class with default settings.
Protected method | StationInfo(StationInfo) | Initializes a new instance of the StationInfo class with another instance.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


StationInfo Constructor

[image]

IceLib Technical Reference
StationInfo Constructor
StationInfo Class See Also Send Feedback
Initializes a new instance of the StationInfo class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationInfo()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
StationInfo Overload
ININ.IceLib.Connection Namespace


StationInfo Constructor (StationInfo)

[image]

IceLib Technical Reference
StationInfo Constructor (StationInfo)
StationInfo Class See Also Send Feedback
Initializes a new instance of the StationInfo class with another instance.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected StationInfo(
    StationInfo stationInfo
)
Visual Basic
Protected Sub New ( _
    stationInfo As StationInfo _
)

Parameters

stationInfo
Type: ININ.IceLib.Connection..::..StationInfo
The station info.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
StationInfo Overload
ININ.IceLib.Connection Namespace


StationInfo Methods

[image] [image]

IceLib Technical Reference
StationInfo Methods
StationInfo Class See Also Send Feedback

The StationInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the station info object by making a deep copy of all member values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StationInfo Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
StationInfo..::..Clone Method
StationInfo Class See Also Send Feedback
Clones the station info object by making a deep copy of all member values.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationInfo Clone()
Visual Basic
Public Function Clone As StationInfo

Return Value

A new cloned object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
StationInfo..::..ToString Method
StationInfo Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


StationInfo Properties

[image] [image]

IceLib Technical Reference
StationInfo Properties
StationInfo Class See Also Send Feedback

The StationInfo type exposes the following members.

Properties

 | Name | Description
Public property | CanBeDialed | Gets or sets whether the station can be dialed.
Public property | DNDStatusSyncAvailable | Obsolete. Gets a value indicating whether DND status synchronization is available on this station.
Public property | Extension | Gets or sets the station Extension.
Public property | Id | Gets or sets the station ID.
Public property | RingAlways | Gets or sets whether the station will always ring.
Public property | SipAddress | Gets or sets the station Sip address.
Public property | SipPassword | Gets or sets the station Sip password.
Public property | SipUser | Gets or sets the station Sip user.
Public property | Type | Gets or sets the station type.

See Also

StationInfo Class
ININ.IceLib.Connection Namespace


CanBeDialed Property

[image]

IceLib Technical Reference
StationInfo..::..CanBeDialed Property
StationInfo Class See Also Send Feedback
Gets or sets whether the station can be dialed.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanBeDialed { get; set; }
Visual Basic
Public Property CanBeDialed As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can be dialed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


DNDStatusSyncAvailable Property

[image]

IceLib Technical Reference
StationInfo..::..DNDStatusSyncAvailable Property
StationInfo Class See Also Send Feedback
Gets a value indicating whether DND status synchronization is available on this station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("DNDStatusSyncAvailable has been deprecated.")]
public bool DNDStatusSyncAvailable { get; set; }
Visual Basic
<ObsoleteAttribute("DNDStatusSyncAvailable has been deprecated.")> _
Public Property DNDStatusSyncAvailable As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if DND status synchronization is available on this station; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
This property was deprecated in 3.0 SU-3 and should no longer be used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


Extension Property

[image]

IceLib Technical Reference
StationInfo..::..Extension Property
StationInfo Class See Also Send Feedback
Gets or sets the station Extension.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set

Field Value

The extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


Id Property

[image]

IceLib Technical Reference
StationInfo..::..Id Property
StationInfo Class Example See Also Send Feedback
Gets or sets the station ID.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID.

Examples

The IceLib SDK includes example application references to the Id property. Some examples are listed below.
Project | Location
TutorialExample | ConnectionViewModel.cs, line 214, in ConnectionViewModel.SetStationValues

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


RingAlways Property

[image]

IceLib Technical Reference
StationInfo..::..RingAlways Property
StationInfo Class See Also Send Feedback
Gets or sets whether the station will always ring.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool RingAlways { get; set; }
Visual Basic
Public Property RingAlways As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should ring always; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


SipAddress Property

[image]

IceLib Technical Reference
StationInfo..::..SipAddress Property
StationInfo Class See Also Send Feedback
Gets or sets the station Sip address.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SipAddress { get; set; }
Visual Basic
Public Property SipAddress As String
    Get
    Set

Field Value

The SIP address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


SipPassword Property

[image]

IceLib Technical Reference
StationInfo..::..SipPassword Property
StationInfo Class See Also Send Feedback
Gets or sets the station Sip password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SipPassword { get; set; }
Visual Basic
Public Property SipPassword As String
    Get
    Set

Field Value

The SIP password.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


SipUser Property

[image]

IceLib Technical Reference
StationInfo..::..SipUser Property
StationInfo Class See Also Send Feedback
Gets or sets the station Sip user.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SipUser { get; set; }
Visual Basic
Public Property SipUser As String
    Get
    Set

Field Value

The SIP user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


Type Property

[image]

IceLib Technical Reference
StationInfo..::..Type Property
StationInfo Class See Also Send Feedback
Gets or sets the station type.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationType Type { get; set; }
Visual Basic
Public Property Type As StationType
    Get
    Set

Field Value

The station type.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified station type is not from the StationType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationInfo Class
StationInfo Members
ININ.IceLib.Connection Namespace


StationlessSettings Class

[image]

IceLib Technical Reference
StationlessSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to specify a stationless connection.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StationlessSettings : StationSettings
Visual Basic
Public Class StationlessSettings _
    Inherits StationSettings

Remarks

The StationlessSettings object is used to specify that no station should be associated with the Session.

When using a stationless Session, telephony operations made from the ININ.IceLib.Interactions namespace will generally be rejected as most of these operations require the logged in user to be logged in with a station. The following is a list of operations that do require a logged in station:

  • ININ.IceLib.Interactions.InteractionsManager.MakeCall
  • ININ.IceLib.Interactions.Interaction.Coach
  • ININ.IceLib.Interactions.Interaction.ConsultTransfer
  • ININ.IceLib.Interactions.Interaction.InitiateSecureInput
  • ININ.IceLib.Interactions.Interaction.Join
  • ININ.IceLib.Interactions.Interaction.Listen
  • ININ.IceLib.Interactions.Interaction.Pickup
There are operations that can be performed without a station, for example:
  • ININ.IceLib.Interactions.Interaction.BlindTransfer
  • ININ.IceLib.Interactions.Interaction.Disconnect
  • ININ.IceLib.Interactions.Interaction.Hold
  • ININ.IceLib.Interactions.Interaction.Mute
  • ININ.IceLib.Interactions.Interaction.Park
  • ININ.IceLib.Interactions.Interaction.Pause
  • ININ.IceLib.Interactions.Interaction.Private
  • ININ.IceLib.Interactions.Interaction.Record
  • ININ.IceLib.Interactions.Interaction.SecureRecordingPause
  • ININ.IceLib.Interactions.Interaction.TransferToVoicemail
  • ININ.IceLib.Interactions.Interaction.Voicemail
Additionally, Sessions created via the various available proxy authentications (ProxyAuthSettings for example) that will require making telephony-related operations, should ensure that a station is in use by the proxied user. This can be done by logging in with the station settings that are already in use by the proxied user. The SessionWatch object can be used to obtain this information.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the StationlessSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 119, in LoginStationViewModel.CreateStationSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..StationlessSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationlessSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


StationlessSettings Members

[image] [image]

IceLib Technical Reference
StationlessSettings Members
StationlessSettings Class Constructors Methods Properties See Also Send Feedback

The StationlessSettings type exposes the following members.

Constructors

 | Name | Description
Public method | StationlessSettings()()()() | Initializes a new instance of the StationlessSettings class with default settings.
Public method | StationlessSettings(String) | Initializes a new instance of the StationlessSettings class with proxy station for acquiring licenses.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this StationlessSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from StationSettings.)

Properties

 | Name | Description
Public property | ProxyStationForLicense | Gets or sets Proxy StationId that is used to acquire licenses.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)

See Also

StationlessSettings Class
ININ.IceLib.Connection Namespace


StationlessSettings Constructor

[image] [image]

IceLib Technical Reference
StationlessSettings Constructor
StationlessSettings Class See Also Send Feedback
Initializes a new instance of the StationlessSettings class.

Overload List

 | Name | Description
Public method | StationlessSettings()()()() | Initializes a new instance of the StationlessSettings class with default settings.
Public method | StationlessSettings(String) | Initializes a new instance of the StationlessSettings class with proxy station for acquiring licenses.

See Also

StationlessSettings Class
StationlessSettings Members
ININ.IceLib.Connection Namespace


StationlessSettings Constructor

[image]

IceLib Technical Reference
StationlessSettings Constructor
StationlessSettings Class Example See Also Send Feedback
Initializes a new instance of the StationlessSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationlessSettings()
Visual Basic
Public Sub New

Examples

The IceLib SDK includes example application references to the StationlessSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 119, in LoginStationViewModel.CreateStationSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationlessSettings Class
StationlessSettings Members
StationlessSettings Overload
ININ.IceLib.Connection Namespace


StationlessSettings Constructor (String)

[image]

IceLib Technical Reference
StationlessSettings Constructor (String)
StationlessSettings Class See Also Send Feedback
Initializes a new instance of the StationlessSettings class with proxy station for acquiring licenses.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationlessSettings(
    string proxyStationForLicense
)
Visual Basic
Public Sub New ( _
    proxyStationForLicense As String _
)

Parameters

proxyStationForLicense
Type: System..::..String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationlessSettings Class
StationlessSettings Members
StationlessSettings Overload
ININ.IceLib.Connection Namespace


StationlessSettings Methods

[image] [image]

IceLib Technical Reference
StationlessSettings Methods
StationlessSettings Class See Also Send Feedback

The StationlessSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this StationlessSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from StationSettings.)

See Also

StationlessSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
StationlessSettings..::..Clone Method
StationlessSettings Class See Also Send Feedback
Returns an exact copy of this StationlessSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StationSettings Clone()
Visual Basic
Public Overrides Function Clone As StationSettings

Return Value

A new StationlessSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationlessSettings Class
StationlessSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
StationlessSettings..::..ToString Method
StationlessSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationlessSettings Class
StationlessSettings Members
ININ.IceLib.Connection Namespace


StationlessSettings Properties

[image] [image]

IceLib Technical Reference
StationlessSettings Properties
StationlessSettings Class See Also Send Feedback

The StationlessSettings type exposes the following members.

Properties

 | Name | Description
Public property | ProxyStationForLicense | Gets or sets Proxy StationId that is used to acquire licenses.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)

See Also

StationlessSettings Class
ININ.IceLib.Connection Namespace


ProxyStationForLicense Property

[image]

IceLib Technical Reference
StationlessSettings..::..ProxyStationForLicense Property
StationlessSettings Class See Also Send Feedback
Gets or sets Proxy StationId that is used to acquire licenses.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProxyStationForLicense { get; set; }
Visual Basic
Public Property ProxyStationForLicense As String
    Get
    Set

Field Value

The proxy station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

StationlessSettings Class
StationlessSettings Members
ININ.IceLib.Connection Namespace


StationId Property

[image]

IceLib Technical Reference
StationlessSettings..::..StationId Property
StationlessSettings Class See Also Send Feedback
Gets a StationId to best represent the StationSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string StationId { get; }
Visual Basic
Public Overrides ReadOnly Property StationId As String
    Get

Field Value

The station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationlessSettings Class
StationlessSettings Members
ININ.IceLib.Connection Namespace


StationSettings Class

[image]

IceLib Technical Reference
StationSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to specify a station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class StationSettings
Visual Basic
Public MustInherit Class StationSettings

Remarks

The StationSettings object serves as a base class for objects that specify station settings.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the StationSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 50, in LoginStationViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..RemoteNumberSettings
ININ.IceLib.Connection..::..RemoteStationSettings
ININ.IceLib.Connection..::..StationlessSettings
ININ.IceLib.Connection..::..WorkstationSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


StationSettings Members

[image] [image]

IceLib Technical Reference
StationSettings Members
StationSettings Class Methods Properties See Also Send Feedback

The StationSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this StationSettings object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Properties

 | Name | Description
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station.
Public property | StationId | Gets a StationId to best represent the StationSettings.
Public property | SupportedMedia | Gets or sets the SupportedMedia.

See Also

StationSettings Class
ININ.IceLib.Connection Namespace


StationSettings Methods

[image] [image]

IceLib Technical Reference
StationSettings Methods
StationSettings Class See Also Send Feedback

The StationSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this StationSettings object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

See Also

StationSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
StationSettings..::..Clone Method
StationSettings Class See Also Send Feedback
Returns an exact copy of this StationSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract StationSettings Clone()
Visual Basic
Public MustOverride Function Clone As StationSettings

Return Value

A new StationSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationSettings Class
StationSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
StationSettings..::..ToTrace Method
StationSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual string ToTrace()
Visual Basic
Public Overridable Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationSettings Class
StationSettings Members
ININ.IceLib.Connection Namespace


StationSettings Properties

[image] [image]

IceLib Technical Reference
StationSettings Properties
StationSettings Class See Also Send Feedback

The StationSettings type exposes the following members.

Properties

 | Name | Description
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station.
Public property | StationId | Gets a StationId to best represent the StationSettings.
Public property | SupportedMedia | Gets or sets the SupportedMedia.

See Also

StationSettings Class
ININ.IceLib.Connection Namespace


StationConnectionMode Property

[image]

IceLib Technical Reference
StationSettings..::..StationConnectionMode Property
StationSettings Class See Also Send Feedback
Gets the station connection mode, which controls when the user is logged out of the station.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationConnectionMode StationConnectionMode { get; internal set; }
Visual Basic
Public Property StationConnectionMode As StationConnectionMode
    Get
    Friend Set

Field Value

The station connection mode.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationSettings Class
StationSettings Members
ININ.IceLib.Connection Namespace
Session..::..SetStationConnectionMode(StationConnectionMode, Int32)


StationId Property

[image]

IceLib Technical Reference
StationSettings..::..StationId Property
StationSettings Class Example See Also Send Feedback
Gets a StationId to best represent the StationSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract string StationId { get; }
Visual Basic
Public MustOverride ReadOnly Property StationId As String
    Get

Field Value

The station ID.

Examples

The IceLib SDK includes example application references to the StationId property. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 70, in LoginStationViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationSettings Class
StationSettings Members
ININ.IceLib.Connection Namespace


SupportedMedia Property

[image]

IceLib Technical Reference
StationSettings..::..SupportedMedia Property
StationSettings Class See Also Send Feedback
Gets or sets the SupportedMedia.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SupportedMedia SupportedMedia { get; set; }
Visual Basic
Public Property SupportedMedia As SupportedMedia
    Get
    Set

Field Value

The supported media.

Remarks

The default is None.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified supported media is not from the SupportedMedia enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StationSettings Class
StationSettings Members
ININ.IceLib.Connection Namespace


StationType Enumeration

[image]

IceLib Technical Reference
StationType Enumeration
See Also Send Feedback
Specifies constants indicating a station's type.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StationType
Visual Basic
Public Enumeration StationType

Members

Member name | Value | Description
Unknown | 0 | The station is of an unknown type.
Local | 1 | The station is a local workstation.
Remote | 2 | The station is a remote workstation.
Sip | 3 | The station is connected via Sip.
Tapi | 4 | The station is connected via Tapi.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


StoredCredentials Class

[image]

IceLib Technical Reference
StoredCredentials Class
Members Example See Also Send Feedback
A set of credentials that can be persisted, retrieved, and used to authenticate with the server.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public sealed class StoredCredentials
Visual Basic
Public NotInheritable Class StoredCredentials

Examples

The IceLib SDK includes example application references to the StoredCredentials class. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 35, in LoginViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StoredCredentials

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..CommonCredentials


StoredCredentials Members

[image] [image]

IceLib Technical Reference
StoredCredentials Members
StoredCredentials Class Methods Properties See Also Send Feedback

The StoredCredentials type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString to write out the (unprotected) contents of this StoredCredential. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application storing the credentials.
Public property | AuthSettings | Gets or sets the authentication settings.
Public property | HasPersistedPassword | Gets or sets a value indicating whether this instance has a persisted password.
Public property | HostSettings | Gets or sets the host settings.
Public property | LocalCustomSettings | Gets a collection which can be used to get/set local custom credentials settings.
Public property | SessionSettings | Gets or sets the session settings.
Public property | StationSettings | Gets or sets the station settings.
Public property | Updated | Gets the date and time these credentials were saved.

See Also

StoredCredentials Class
ININ.IceLib.Connection Namespace


StoredCredentials Methods

[image] [image]

IceLib Technical Reference
StoredCredentials Methods
StoredCredentials Class See Also Send Feedback

The StoredCredentials type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString to write out the (unprotected) contents of this StoredCredential. (Overrides Object..::..ToString()()()().)

See Also

StoredCredentials Class
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
StoredCredentials..::..ToString Method
StoredCredentials Class See Also Send Feedback
Override of ToString to write out the (unprotected) contents of this StoredCredential.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


StoredCredentials Properties

[image] [image]

IceLib Technical Reference
StoredCredentials Properties
StoredCredentials Class See Also Send Feedback

The StoredCredentials type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application storing the credentials.
Public property | AuthSettings | Gets or sets the authentication settings.
Public property | HasPersistedPassword | Gets or sets a value indicating whether this instance has a persisted password.
Public property | HostSettings | Gets or sets the host settings.
Public property | LocalCustomSettings | Gets a collection which can be used to get/set local custom credentials settings.
Public property | SessionSettings | Gets or sets the session settings.
Public property | StationSettings | Gets or sets the station settings.
Public property | Updated | Gets the date and time these credentials were saved.

See Also

StoredCredentials Class
ININ.IceLib.Connection Namespace


ApplicationName Property

[image]

IceLib Technical Reference
StoredCredentials..::..ApplicationName Property
StoredCredentials Class See Also Send Feedback
Gets or sets the name of the application storing the credentials.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationName { get; set; }
Visual Basic
Public Property ApplicationName As String
    Get
    Set

Field Value

The name of the application.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Attempted to set the value to nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


AuthSettings Property

[image]

IceLib Technical Reference
StoredCredentials..::..AuthSettings Property
StoredCredentials Class Example See Also Send Feedback
Gets or sets the authentication settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AuthSettings AuthSettings { get; set; }
Visual Basic
Public Property AuthSettings As AuthSettings
    Get
    Set

Field Value

The authentication settings.

Examples

The IceLib SDK includes example application references to the AuthSettings property. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 35, in LoginViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | Attempted to set the value to nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


HasPersistedPassword Property

[image]

IceLib Technical Reference
StoredCredentials..::..HasPersistedPassword Property
StoredCredentials Class See Also Send Feedback
Gets or sets a value indicating whether this instance has a persisted password.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasPersistedPassword { get; set; }
Visual Basic
Public Property HasPersistedPassword As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has a persisted password; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


HostSettings Property

[image]

IceLib Technical Reference
StoredCredentials..::..HostSettings Property
StoredCredentials Class Example See Also Send Feedback
Gets or sets the host settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HostSettings HostSettings { get; set; }
Visual Basic
Public Property HostSettings As HostSettings
    Get
    Set

Field Value

The host settings.

Examples

The IceLib SDK includes example application references to the HostSettings property. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 36, in LoginViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | Attempted to set the value to nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


LocalCustomSettings Property

[image]

IceLib Technical Reference
StoredCredentials..::..LocalCustomSettings Property
StoredCredentials Class See Also Send Feedback
Gets a collection which can be used to get/set local custom credentials settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> LocalCustomSettings { get; }
Visual Basic
Public ReadOnly Property LocalCustomSettings As IDictionary(Of String, String)
    Get

Field Value

The custom settings.

Remarks

This provides a facility for grouping custom settings with the CommonCredentials. For example, this can allow a custom application to store specialized Login dialog settings.

Unlike CustomSettings, LocalCustomSettings do not get sent to the server and are only intended to be a simple way to save connection-related settings, such as from an application's login dialog.

Note
LocalCustomSettings should be limited to connection-related settings and not used as a general application setting persistence scheme.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


SessionSettings Property

[image]

IceLib Technical Reference
StoredCredentials..::..SessionSettings Property
StoredCredentials Class See Also Send Feedback
Gets or sets the session settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionSettings SessionSettings { get; set; }
Visual Basic
Public Property SessionSettings As SessionSettings
    Get
    Set

Field Value

The session settings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Attempted to set the value to nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


StationSettings Property

[image]

IceLib Technical Reference
StoredCredentials..::..StationSettings Property
StoredCredentials Class Example See Also Send Feedback
Gets or sets the station settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationSettings StationSettings { get; set; }
Visual Basic
Public Property StationSettings As StationSettings
    Get
    Set

Field Value

The station settings.

Examples

The IceLib SDK includes example application references to the StationSettings property. Some examples are listed below.
Project | Location
TutorialExample | LoginViewModel.cs, line 37, in LoginViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | Attempted to set the value to nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


Updated Property

[image]

IceLib Technical Reference
StoredCredentials..::..Updated Property
StoredCredentials Class See Also Send Feedback
Gets the date and time these credentials were saved.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Updated { get; internal set; }
Visual Basic
Public Property Updated As DateTime
    Get
    Friend Set

Field Value

The date and time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StoredCredentials Class
StoredCredentials Members
ININ.IceLib.Connection Namespace


SupportedMedia Enumeration

[image]

IceLib Technical Reference
SupportedMedia Enumeration
Example See Also Send Feedback
Specifies constants indicating what media types a station supports.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum SupportedMedia
Visual Basic
<FlagsAttribute> _
Public Enumeration SupportedMedia

Members

Member name | Value | Description
None | 0 | The station supports no media types. Cannot be used with other flags.
Call | 1 | The station supports calls.
Chat | 2 | The station supports chats.
Email | 4 | The station supports emails.
Generic | 8 | The station supports generic objects.
BrowserSync | 16 | The station supports browser sync objects.
Callback | 32 | The station supports callbacks.
DualForm | 64 | The station supports dual form objects.
SmsMessage | 256 | The station supports SMS messages.
WorkItem | 1024 | The station supports work item interactions.

Remarks

This enumeration is used by StationSettings to specify what media a station supports.

Examples

The following example demonstrates creation of a StationSettings object.
CopyC#
using ININ.IceLib.Connection;

SupportedMedia supportedMedia = SupportedMedia.Call | SupportedMedia.Chat | SupportedMedia.Email;
WorkstationSettings stationSettings = new WorkstationSettings("station1", supportedMedia);

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


WindowsAuthProtocols Enumeration

[image]

IceLib Technical Reference
WindowsAuthProtocols Enumeration
See Also Send Feedback
Specifies constants indicating authentication protocols.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum WindowsAuthProtocols
Visual Basic
<FlagsAttribute> _
Public Enumeration WindowsAuthProtocols

Members

Member name | Value | Description
None | 0 | No protocols.
Ntlm | 1 | The NTLM protocol (also known as Lanmanager Protocol).
Kerberos | 2 | The Kerberos protocol.
All | 3 | All known protocols.

Remarks

This enumeration is used by WindowsAuthSettings to specify what protocols to attempt when connecting.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Connection Namespace


WindowsAuthSettings Class

[image]

IceLib Technical Reference
WindowsAuthSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to authenticate a Windows user using data from the current environment.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WindowsAuthSettings : AuthSettings
Visual Basic
Public Class WindowsAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.
The WindowsAuthSettings object is used to specify Windows user authentication settings. This is used when Windows user credentials should be used to authenticate the user requesting a Session.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the WindowsAuthSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginAuthViewModel.cs, line 39, in LoginAuthViewModel.CreateAuthSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..WindowsAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


WindowsAuthSettings Members

[image] [image]

IceLib Technical Reference
WindowsAuthSettings Members
WindowsAuthSettings Class Constructors Methods Properties See Also Send Feedback

The WindowsAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | WindowsAuthSettings()()()() | Initializes a new instance of the WindowsAuthSettings class with default settings.
Public method | WindowsAuthSettings(WindowsAuthProtocols) | Initializes a new instance of the WindowsAuthSettings class, designating which protocols should be used.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this WindowsAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

Properties

 | Name | Description
Public property | ProtocolFlags | Gets or sets the protocol flags.
Public property | UserName | Gets the Windows userName associated with this instance.

See Also

WindowsAuthSettings Class
ININ.IceLib.Connection Namespace


WindowsAuthSettings Constructor

[image] [image]

IceLib Technical Reference
WindowsAuthSettings Constructor
WindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the WindowsAuthSettings class.

Overload List

 | Name | Description
Public method | WindowsAuthSettings()()()() | Initializes a new instance of the WindowsAuthSettings class with default settings.
Public method | WindowsAuthSettings(WindowsAuthProtocols) | Initializes a new instance of the WindowsAuthSettings class, designating which protocols should be used.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


WindowsAuthSettings Constructor

[image]

IceLib Technical Reference
WindowsAuthSettings Constructor
WindowsAuthSettings Class Example See Also Send Feedback
Initializes a new instance of the WindowsAuthSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowsAuthSettings()
Visual Basic
Public Sub New

Examples

The IceLib SDK includes example application references to the WindowsAuthSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginAuthViewModel.cs, line 39, in LoginAuthViewModel.CreateAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
WindowsAuthSettings Overload
ININ.IceLib.Connection Namespace


WindowsAuthSettings Constructor (WindowsAuthProtocols)

[image]

IceLib Technical Reference
WindowsAuthSettings Constructor (WindowsAuthProtocols)
WindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the WindowsAuthSettings class, designating which protocols should be used.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowsAuthSettings(
    WindowsAuthProtocols protocolFlags
)
Visual Basic
Public Sub New ( _
    protocolFlags As WindowsAuthProtocols _
)

Parameters

protocolFlags
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
Flags to indicate which protocols should be used.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified protocols is not from the WindowsAuthProtocols enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
WindowsAuthSettings Overload
ININ.IceLib.Connection Namespace


WindowsAuthSettings Methods

[image] [image]

IceLib Technical Reference
WindowsAuthSettings Methods
WindowsAuthSettings Class See Also Send Feedback

The WindowsAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this WindowsAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

See Also

WindowsAuthSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
WindowsAuthSettings..::..Clone Method
WindowsAuthSettings Class See Also Send Feedback
Returns an exact copy of this WindowsAuthSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new WindowsAuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
WindowsAuthSettings..::..Dispose Method
WindowsAuthSettings Class See Also Send Feedback
Releases all resources used by the AuthSettings.

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
WindowsAuthSettings..::..Dispose Method (Boolean)
WindowsAuthSettings Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
Dispose Overload
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
WindowsAuthSettings..::..ToString Method
WindowsAuthSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
WindowsAuthSettings..::..ToTrace Method
WindowsAuthSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToTrace()
Visual Basic
Public Overrides Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


WindowsAuthSettings Properties

[image] [image]

IceLib Technical Reference
WindowsAuthSettings Properties
WindowsAuthSettings Class See Also Send Feedback

The WindowsAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | ProtocolFlags | Gets or sets the protocol flags.
Public property | UserName | Gets the Windows userName associated with this instance.

See Also

WindowsAuthSettings Class
ININ.IceLib.Connection Namespace


ProtocolFlags Property

[image]

IceLib Technical Reference
WindowsAuthSettings..::..ProtocolFlags Property
WindowsAuthSettings Class See Also Send Feedback
Gets or sets the protocol flags.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowsAuthProtocols ProtocolFlags { get; set; }
Visual Basic
Public Property ProtocolFlags As WindowsAuthProtocols
    Get
    Set

Field Value

The protocol flags.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified protocols is not from the WindowsAuthProtocols enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


UserName Property

[image]

IceLib Technical Reference
WindowsAuthSettings..::..UserName Property
WindowsAuthSettings Class See Also Send Feedback
Gets the Windows userName associated with this instance.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; }
Visual Basic
Public ReadOnly Property UserName As String
    Get

Field Value

The windows username.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WindowsAuthSettings Class
WindowsAuthSettings Members
ININ.IceLib.Connection Namespace


WorkstationSettings Class

[image]

IceLib Technical Reference
WorkstationSettings Class
Members Example See Also Send Feedback
Passed to a Session in order to specify a workstation.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkstationSettings : StationSettings
Visual Basic
Public Class WorkstationSettings _
    Inherits StationSettings

Remarks

The WorkstationSettings object is used to specify local workstation settings. This establishes a Session directly on the specified station. The station name is set to the current machine name by default.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Examples

The IceLib SDK includes example application references to the WorkstationSettings class. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 113, in LoginStationViewModel.CreateStationSettings
 | LoginStationViewModel.cs, line 66, in LoginStationViewModel.#ctor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..WorkstationSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Members
ININ.IceLib.Connection Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


WorkstationSettings Members

[image] [image]

IceLib Technical Reference
WorkstationSettings Members
WorkstationSettings Class Constructors Methods Properties See Also Send Feedback

The WorkstationSettings type exposes the following members.

Constructors

 | Name | Description
Public method | WorkstationSettings()()()() | Initializes a new instance of the WorkstationSettings class with default settings.
Public method | WorkstationSettings(String, SupportedMedia) | Initializes a new instance of the WorkstationSettings class with station settings.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this WorkstationSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides StationSettings..::..ToTrace()()()().)

Properties

 | Name | Description
Public property | PersistStationLogin | Gets or sets a value indicating whether the station login is persisted.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)
Public property | Workstation | Gets or sets the Workstation.

See Also

WorkstationSettings Class
ININ.IceLib.Connection Namespace


WorkstationSettings Constructor

[image] [image]

IceLib Technical Reference
WorkstationSettings Constructor
WorkstationSettings Class See Also Send Feedback
Initializes a new instance of the WorkstationSettings class.

Overload List

 | Name | Description
Public method | WorkstationSettings()()()() | Initializes a new instance of the WorkstationSettings class with default settings.
Public method | WorkstationSettings(String, SupportedMedia) | Initializes a new instance of the WorkstationSettings class with station settings.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace


WorkstationSettings Constructor

[image]

IceLib Technical Reference
WorkstationSettings Constructor
WorkstationSettings Class See Also Send Feedback
Initializes a new instance of the WorkstationSettings class with default settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkstationSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
WorkstationSettings Overload
ININ.IceLib.Connection Namespace


WorkstationSettings Constructor (String, SupportedMedia)

[image]

IceLib Technical Reference
WorkstationSettings Constructor (String, SupportedMedia)
WorkstationSettings Class Example See Also Send Feedback
Initializes a new instance of the WorkstationSettings class with station settings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkstationSettings(
    string workstation,
    SupportedMedia supportedMedia
)
Visual Basic
Public Sub New ( _
    workstation As String, _
    supportedMedia As SupportedMedia _
)

Parameters

workstation
Type: System..::..String
The workstation.
supportedMedia
Type: ININ.IceLib.Connection..::..SupportedMedia
The media types supported by this station.

Examples

The IceLib SDK includes example application references to the WorkstationSettings constructor. Some examples are listed below.
Project | Location
TutorialExample | LoginStationViewModel.cs, line 113, in LoginStationViewModel.CreateStationSettings

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified supported media is not from the SupportedMedia enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
WorkstationSettings Overload
ININ.IceLib.Connection Namespace


WorkstationSettings Methods

[image] [image]

IceLib Technical Reference
WorkstationSettings Methods
WorkstationSettings Class See Also Send Feedback

The WorkstationSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this WorkstationSettings object. (Overrides StationSettings..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides StationSettings..::..ToTrace()()()().)

See Also

WorkstationSettings Class
ININ.IceLib.Connection Namespace


Clone Method

[image]

IceLib Technical Reference
WorkstationSettings..::..Clone Method
WorkstationSettings Class See Also Send Feedback
Returns an exact copy of this WorkstationSettings object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StationSettings Clone()
Visual Basic
Public Overrides Function Clone As StationSettings

Return Value

A new WorkstationSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace


ToString Method

[image]

IceLib Technical Reference
WorkstationSettings..::..ToString Method
WorkstationSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace


ToTrace Method

[image]

IceLib Technical Reference
WorkstationSettings..::..ToTrace Method
WorkstationSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToTrace()
Visual Basic
Public Overrides Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace


WorkstationSettings Properties

[image] [image]

IceLib Technical Reference
WorkstationSettings Properties
WorkstationSettings Class See Also Send Feedback

The WorkstationSettings type exposes the following members.

Properties

 | Name | Description
Public property | PersistStationLogin | Gets or sets a value indicating whether the station login is persisted.
Public property | StationConnectionMode | Gets the station connection mode, which controls when the user is logged out of the station. (Inherited from StationSettings.)
Public property | StationId | Gets a StationId to best represent the StationSettings. (Overrides StationSettings..::..StationId.)
Public property | SupportedMedia | Gets or sets the SupportedMedia. (Inherited from StationSettings.)
Public property | Workstation | Gets or sets the Workstation.

See Also

WorkstationSettings Class
ININ.IceLib.Connection Namespace


PersistStationLogin Property

[image]

IceLib Technical Reference
WorkstationSettings..::..PersistStationLogin Property
WorkstationSettings Class See Also Send Feedback
Gets or sets a value indicating whether the station login is persisted.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PersistStationLogin { get; set; }
Visual Basic
Public Property PersistStationLogin As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if the station login is persisted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Setting this to trueTruetruetrue (True in Visual Basic) tells the IC Server that the station login should be persisted. Calling Disconnect()()()() will persist the station connection based on the value of the currently connected StationSettings's StationConnectionMode property. If StationConnectionMode is set to Default, then the station login will be disconnected; otherwise, it will be persisted. Alternatively, Disconnect(Boolean) can be called to notify the IC Server of the desired disconnect behavior. If the station login is persisted, the session user will still appear to be logged into the station after or Disconnect(Boolean) is called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace
Session..::..Disconnect()()()()


StationId Property

[image]

IceLib Technical Reference
WorkstationSettings..::..StationId Property
WorkstationSettings Class See Also Send Feedback
Gets a StationId to best represent the StationSettings.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string StationId { get; }
Visual Basic
Public Overrides ReadOnly Property StationId As String
    Get

Field Value

The station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace


Workstation Property

[image]

IceLib Technical Reference
WorkstationSettings..::..Workstation Property
WorkstationSettings Class See Also Send Feedback
Gets or sets the Workstation.

Namespace: ININ.IceLib.Connection
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workstation { get; set; }
Visual Basic
Public Property Workstation As String
    Get
    Set

Field Value

The workstation.

Remarks

The default is the MachineName.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkstationSettings Class
WorkstationSettings Members
ININ.IceLib.Connection Namespace


ININ.IceLib.Connection.Extensions Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Connection.Extensions Namespace
Send Feedback

The ININ.IceLib.Connection.Extensions namespace contains classes to support advanced connection-related features.

This includes retrieving ServerParameters, setting the user's password, persisting custom settings to the IC server, sending or receiving a CustomNotification, and watching for creation of other Sessions.

Classes

 | Class | Description
Public class | CheckForApplicationBasedSettingsCompletedEventArgs | Provides data for the asynchronous completed event of CheckForApplicationBasedSettingsAsync(EventHandler<(Of <<'(CheckForApplicationBasedSettingsCompletedEventArgs>)>>), Object).
Public class | CustomMessage | Represents a custom notification message received from the IC server.
Public class | CustomMessageHeader | Indentifies the type of a CustomMessage.
Public class | CustomNotification | Provides functionality for sending and receiving notifications to and from custom handlers and IceLib applications.
Public class | CustomNotificationReceivedEventArgs | Provides definition for the CustomNotificationReceived event of CustomNotification.
Public class | CustomProfile | Allows storage of custom application settings to the Interaction Center server.
Public class | CustomProfileParameters | Class used to specify the parameters for creating am application-based CustomProfile object via GetApplicationCustomProfile(CustomProfileParameters).
Public class | CustomRequest | Represents a custom notification request sent to the IC server.
Public class | CustomResponse | Represents a custom notification response to reply to the IC server.
Public class | GetNamespaceContentsCompletedEventArgs | Provides data for the asynchronous completed events of CustomProfile.
Public class | GetProfileItemCompletedEventArgs | Provides data for the asynchronous completed events of CustomProfile.
Public class | GetServerParametersCompletedEventArgs | Provides data for asynchronous completed events of ServerParameters.
Public class | PasswordEventArgs | This class implements event arguments for the PasswordExpired and PasswordEnteredNagPeriod events.
Public class | PasswordPolicy | Defines password policy for a given user, for use with the Security class.
Public class | PasswordPolicyAsyncCompletedEventArgs | Arguments returned by the GetPasswordPolicyAsync(EventHandler<(Of <<'(PasswordPolicyAsyncCompletedEventArgs>)>>), Object) request.
Public class | ProblemReporter | Used to submit a problem report along with a subject, description, and related files.
Public class | ProfileItem | Represents a custom application setting that will be persisted to the Interaction Center server.
Public class | ProxyAlternateWindowsAuthSettings | Passed to a Session in order to authenticate an Interaction Center user that is creating a session on behalf of another Interaction Center user (through windows authentication).
Public class | ProxyAuthSettings | Passed to a Session in order to authenticate an Interaction Center user that is creating a session on behalf of another Interaction Center user.
Public class | ProxyWindowsAuthSettings | Passed to a Session in order to authenticate an Interaction Center user (through windows authentication) that is creating a session on behalf of another Interaction Center user.
Public class | Security | Provides access to the Session user's password policy and allows for setting of the password.
Public class | SendCompletedEventArgs | Provides data for the SendServerRequest method of CustomNotification completedCallback delegate of CustomNotification.
Public class | ServerParameter | Provides information about a server parameter within the Interaction Center system.
Public class | ServerParameters | Allows querying and watching of server parameters within the Interaction Center system.
Public class | ServerParametersChangedEventArgs | Provides data for the ServerParametersChanged event.
Public class | SessionWatch | Allows watching for login/logout events for users, all users on a station, or all users on a computer.
Public class | SessionWatchAsyncEventArgs | Provides data for the asynchronous completed events of SessionWatch.
Public class | SessionWatchedUserAddedRemovedEventArgs | Provides data for the watched user added and watched user removed events.
Public class | SessionWatchedUserChangedEventArgs | Obsolete. Provides data for the watched user changed event.
Public class | SessionWatchId | Identifies a watched session for the SessionWatch class.
Public class | SessionWatchSettings | Describes session, station, and machine data for a watched session.

Enumerations

 | Enumeration | Description
Public enumeration | CustomMessageType | Represents the type of Custom Messages.
Public enumeration | ProxyTargetUserType | Used to specify if the target user is an IC user or a Windows user.
Public enumeration | RestrictCacheRefreshOptions | Represents the options for restricting custom profile cache refreshing for a CustomProfile.
Public enumeration | SessionWatchType | Describes the type of Session Watch to perform.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


CheckForApplicationBasedSettingsCompletedEventArgs Class

[image]

IceLib Technical Reference
CheckForApplicationBasedSettingsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed event of CheckForApplicationBasedSettingsAsync(EventHandler<(Of <<'(CheckForApplicationBasedSettingsCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CheckForApplicationBasedSettingsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class CheckForApplicationBasedSettingsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..CheckForApplicationBasedSettingsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CheckForApplicationBasedSettingsCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


CheckForApplicationBasedSettingsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
CheckForApplicationBasedSettingsCompletedEventArgs Members
CheckForApplicationBasedSettingsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The CheckForApplicationBasedSettingsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CheckForApplicationBasedSettingsCompletedEventArgs | Initializes a new instance of the CheckForApplicationBasedSettingsCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | HasApplicationBasedSettings | Gets a value indicating whether the application based settings exists.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CheckForApplicationBasedSettingsCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


CheckForApplicationBasedSettingsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
CheckForApplicationBasedSettingsCompletedEventArgs Constructor
CheckForApplicationBasedSettingsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the CheckForApplicationBasedSettingsCompletedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CheckForApplicationBasedSettingsCompletedEventArgs(
    bool hasApplicationBasedSettings,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    hasApplicationBasedSettings As Boolean, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

hasApplicationBasedSettings
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) then the application based settings exist.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
State of the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CheckForApplicationBasedSettingsCompletedEventArgs Class
CheckForApplicationBasedSettingsCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


CheckForApplicationBasedSettingsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
CheckForApplicationBasedSettingsCompletedEventArgs Methods
CheckForApplicationBasedSettingsCompletedEventArgs Class See Also Send Feedback

The CheckForApplicationBasedSettingsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckForApplicationBasedSettingsCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


CheckForApplicationBasedSettingsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
CheckForApplicationBasedSettingsCompletedEventArgs Properties
CheckForApplicationBasedSettingsCompletedEventArgs Class See Also Send Feedback

The CheckForApplicationBasedSettingsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | HasApplicationBasedSettings | Gets a value indicating whether the application based settings exists.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CheckForApplicationBasedSettingsCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


HasApplicationBasedSettings Property

[image]

IceLib Technical Reference
CheckForApplicationBasedSettingsCompletedEventArgs..::..HasApplicationBasedSettings Property
CheckForApplicationBasedSettingsCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether the application based settings exists.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasApplicationBasedSettings { get; }
Visual Basic
Public ReadOnly Property HasApplicationBasedSettings As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the application based settings exist; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CheckForApplicationBasedSettingsCompletedEventArgs Class
CheckForApplicationBasedSettingsCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessage Class

[image]

IceLib Technical Reference
CustomMessage Class
Members See Also Send Feedback
Represents a custom notification message received from the IC server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomMessage
Visual Basic
Public Class CustomMessage

Remarks

See CustomNotification for further details.

Note
For more information on getting started with custom notifications see Getting Started With Custom Notifications.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomMessage

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessage Members

[image] [image]

IceLib Technical Reference
CustomMessage Members
CustomMessage Class Constructors Methods Properties See Also Send Feedback

The CustomMessage type exposes the following members.

Constructors

 | Name | Description
Public method | CustomMessage | Initializes a new instance of the CustomMessage class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadBoolean | Reads a bool from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadByte | Reads a byte from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadChar | Reads a char from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadDouble | Reads the double. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadInt16 | Reads an Int16 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadInt32 | Reads an Int32 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadInt64 | Reads an Int64 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadString | Reads a string from the response stream. Do not use with custom handlers ( Header.CustomMessageType == ServerNotification).
Public method | ReadStrings | Reads the strings from the response stream.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | EventId | Gets the event ID.
Public property | Header | Gets the header.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.

See Also

CustomMessage Class
ININ.IceLib.Connection.Extensions Namespace


CustomMessage Constructor

[image]

IceLib Technical Reference
CustomMessage Constructor
CustomMessage Class See Also Send Feedback
Initializes a new instance of the CustomMessage class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessage(
    CustomMessageHeader header
)
Visual Basic
Public Sub New ( _
    header As CustomMessageHeader _
)

Parameters

header
Type: ININ.IceLib.Connection.Extensions..::..CustomMessageHeader
The header for this custom message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessage Methods

[image] [image]

IceLib Technical Reference
CustomMessage Methods
CustomMessage Class See Also Send Feedback

The CustomMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadBoolean | Reads a bool from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadByte | Reads a byte from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadChar | Reads a char from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadDouble | Reads the double. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadInt16 | Reads an Int16 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadInt32 | Reads an Int32 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadInt64 | Reads an Int64 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).
Public method | ReadString | Reads a string from the response stream. Do not use with custom handlers ( Header.CustomMessageType == ServerNotification).
Public method | ReadStrings | Reads the strings from the response stream.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

CustomMessage Class
ININ.IceLib.Connection.Extensions Namespace


ReadBoolean Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadBoolean Method
CustomMessage Class See Also Send Feedback
Reads a bool from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ReadBoolean()
Visual Basic
Public Function ReadBoolean As Boolean

Return Value

The bool value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadByte Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadByte Method
CustomMessage Class See Also Send Feedback
Reads a byte from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public byte ReadByte()
Visual Basic
Public Function ReadByte As Byte

Return Value

The byte value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadChar Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadChar Method
CustomMessage Class See Also Send Feedback
Reads a char from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public char ReadChar()
Visual Basic
Public Function ReadChar As Char

Return Value

The char value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadDouble Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadDouble Method
CustomMessage Class See Also Send Feedback
Reads the double. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public double ReadDouble()
Visual Basic
Public Function ReadDouble As Double

Return Value

The double value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadInt16 Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadInt16 Method
CustomMessage Class See Also Send Feedback
Reads an Int16 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public short ReadInt16()
Visual Basic
Public Function ReadInt16 As Short

Return Value

The Int16 value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadInt32 Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadInt32 Method
CustomMessage Class See Also Send Feedback
Reads an Int32 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ReadInt32()
Visual Basic
Public Function ReadInt32 As Integer

Return Value

The Int32 value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadInt64 Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadInt64 Method
CustomMessage Class See Also Send Feedback
Reads an Int64 from the response stream. Do not use with custom handlers (Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long ReadInt64()
Visual Basic
Public Function ReadInt64 As Long

Return Value

The Int64 value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadString Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadString Method
CustomMessage Class See Also Send Feedback
Reads a string from the response stream. Do not use with custom handlers ( Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ReadString()
Visual Basic
Public Function ReadString As String

Return Value

The string value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format requested.
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ReadStrings Method

[image]

IceLib Technical Reference
CustomMessage..::..ReadStrings Method
CustomMessage Class See Also Send Feedback
Reads the strings from the response stream.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string[] ReadStrings()
Visual Basic
Public Function ReadStrings As String()

Return Value

The string[] value.

Remarks

ServerNotification is allowed in the use of this method.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibException | Attempted to read beyond end of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
CustomMessage..::..ToString Method
CustomMessage Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessage Properties

[image] [image]

IceLib Technical Reference
CustomMessage Properties
CustomMessage Class See Also Send Feedback

The CustomMessage type exposes the following members.

Properties

 | Name | Description
Public property | EventId | Gets the event ID.
Public property | Header | Gets the header.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.

See Also

CustomMessage Class
ININ.IceLib.Connection.Extensions Namespace


EventId Property

[image]

IceLib Technical Reference
CustomMessage..::..EventId Property
CustomMessage Class See Also Send Feedback
Gets the event ID.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EventId { get; }
Visual Basic
Public ReadOnly Property EventId As String
    Get

Field Value

The event ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


Header Property

[image]

IceLib Technical Reference
CustomMessage..::..Header Property
CustomMessage Class See Also Send Feedback
Gets the header.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessageHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As CustomMessageHeader
    Get

Field Value

The header.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ObjectId Property

[image]

IceLib Technical Reference
CustomMessage..::..ObjectId Property
CustomMessage Class See Also Send Feedback
Gets the object ID for this request.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectId { get; }
Visual Basic
Public ReadOnly Property ObjectId As String
    Get

Field Value

The object ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


ObjectType Property

[image]

IceLib Technical Reference
CustomMessage..::..ObjectType Property
CustomMessage Class See Also Send Feedback
Gets the object type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectType { get; }
Visual Basic
Public ReadOnly Property ObjectType As String
    Get

Field Value

The object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessage Class
CustomMessage Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessageHeader Class

[image]

IceLib Technical Reference
CustomMessageHeader Class
Members See Also Send Feedback
Indentifies the type of a CustomMessage.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomMessageHeader
Visual Basic
Public Class CustomMessageHeader

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomMessageHeader

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessageHeader Members

[image] [image]

IceLib Technical Reference
CustomMessageHeader Members
CustomMessageHeader Class Constructors Methods Properties See Also Send Feedback

The CustomMessageHeader type exposes the following members.

Constructors

 | Name | Description
Public method | CustomMessageHeader | Initializes a new instance of the CustomMessageHeader class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CustomMessageType | Gets the type of the custom notification.
Public property | EventId | Gets the event ID.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.

See Also

CustomMessageHeader Class
ININ.IceLib.Connection.Extensions Namespace


CustomMessageHeader Constructor

[image]

IceLib Technical Reference
CustomMessageHeader Constructor
CustomMessageHeader Class See Also Send Feedback
Initializes a new instance of the CustomMessageHeader class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessageHeader(
    CustomMessageType type,
    string objectId,
    string eventId
)
Visual Basic
Public Sub New ( _
    type As CustomMessageType, _
    objectId As String, _
    eventId As String _
)

Parameters

type
Type: ININ.IceLib.Connection.Extensions..::..CustomMessageType
The custom notification type.
objectId
Type: System..::..String
The object ID.
eventId
Type: System..::..String
The event ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | One of the arguments is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | type is not a valid value for CustomMessageType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessageHeader Methods

[image] [image]

IceLib Technical Reference
CustomMessageHeader Methods
CustomMessageHeader Class See Also Send Feedback

The CustomMessageHeader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

CustomMessageHeader Class
ININ.IceLib.Connection.Extensions Namespace


Equals Method

[image]

IceLib Technical Reference
CustomMessageHeader..::..Equals Method
CustomMessageHeader Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
CustomMessageHeader..::..GetHashCode Method
CustomMessageHeader Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
CustomMessageHeader..::..ToString Method
CustomMessageHeader Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessageHeader Properties

[image] [image]

IceLib Technical Reference
CustomMessageHeader Properties
CustomMessageHeader Class See Also Send Feedback

The CustomMessageHeader type exposes the following members.

Properties

 | Name | Description
Public property | CustomMessageType | Gets the type of the custom notification.
Public property | EventId | Gets the event ID.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.

See Also

CustomMessageHeader Class
ININ.IceLib.Connection.Extensions Namespace


CustomMessageType Property

[image]

IceLib Technical Reference
CustomMessageHeader..::..CustomMessageType Property
CustomMessageHeader Class See Also Send Feedback
Gets the type of the custom notification.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessageType CustomMessageType { get; }
Visual Basic
Public ReadOnly Property CustomMessageType As CustomMessageType
    Get

Field Value

The type of the custom notification.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


EventId Property

[image]

IceLib Technical Reference
CustomMessageHeader..::..EventId Property
CustomMessageHeader Class See Also Send Feedback
Gets the event ID.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EventId { get; }
Visual Basic
Public ReadOnly Property EventId As String
    Get

Field Value

The event ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


ObjectId Property

[image]

IceLib Technical Reference
CustomMessageHeader..::..ObjectId Property
CustomMessageHeader Class See Also Send Feedback
Gets the object ID for this request.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectId { get; }
Visual Basic
Public ReadOnly Property ObjectId As String
    Get

Field Value

The object ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


ObjectType Property

[image]

IceLib Technical Reference
CustomMessageHeader..::..ObjectType Property
CustomMessageHeader Class See Also Send Feedback
Gets the object type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectType { get; }
Visual Basic
Public ReadOnly Property ObjectType As String
    Get

Field Value

The object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomMessageHeader Class
CustomMessageHeader Members
ININ.IceLib.Connection.Extensions Namespace


CustomMessageType Enumeration

[image]

IceLib Technical Reference
CustomMessageType Enumeration
See Also Send Feedback
Represents the type of Custom Messages.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CustomMessageType
Visual Basic
Public Enumeration CustomMessageType

Members

Member name | Value | Description
None | 0 | No type.
ServerNotification | 1 | Reply from a custom handler.
ApplicationRequest | 2 | A Request sent to another IceLib application.
ApplicationResponse | 4 | A Response from another IceLib application.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

ININ.IceLib.Connection.Extensions Namespace


CustomNotification Class

[image]

IceLib Technical Reference
CustomNotification Class
Members See Also Send Feedback
Provides functionality for sending and receiving notifications to and from custom handlers and IceLib applications.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomNotification
Visual Basic
Public Class CustomNotification

Remarks

Initiating custom handlers is possible through the SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) methods. StartWatching(array<CustomMessageHeader>[]()[][]) or StartWatchingAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) can be used to receive notifications from a custom handler when it sends a custom notification.

The SendApplicationRequest(CustomRequest) or SendApplicationRequestAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) methods can be used to send out request notifications to other IceLib applications. Other IceLib applications can listen for application requests by using StartWatching(array<CustomMessageHeader>[]()[][]) or StartWatchingAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and can respond by using the SendApplicationResponse(CustomResponse) or SendApplicationResponseAsync(CustomResponse, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) methods.

Note
For more information on getting started with custom notifications see Getting Started With Custom Notifications.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomNotification

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


CustomNotification Members

[image] [image]

IceLib Technical Reference
CustomNotification Members
CustomNotification Class Constructors Methods Events See Also Send Feedback

The CustomNotification type exposes the following members.

Constructors

 | Name | Description
Public method | CustomNotification | Initializes a new instance of the CustomNotification class.

Methods

 | Name | Description
Public method | ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][]) | Sends a request to the server to change the watched notifications, replacing the existing watch.
Public method | ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][]) | Sends a request to the server to change the watched notifications.
Public method | ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously sends a request to the server to change the watched notifications, replacing the existing watch.
Public method | ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously sends a request to the server to change the watched notifications.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentlyWatchedHeaders | Returns the currently watched headers.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(CustomMessageHeader) | Determines whether a watch is active and if the specified value is being watched.
Public method | IsWatching(List<(Of <<'(CustomMessageHeader>)>>)) | Determines whether a watch is active and if the specified values are being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendApplicationRequest | Sends the specified custom request.
Public method | SendApplicationRequestAsync | Sends the no response asynchronously.
Public method | SendApplicationResponse | Sends the response.
Public method | SendApplicationResponseAsync | Sends the response asynchronously.
Public method | SendServerRequestNoResponse | Sends a message, with no response expected.
Public method | SendServerRequestNoResponseAsync | Asynchronously sends a message, with no response expected.
Public method | StartWatching | Sends a request to the server to start watching for messages with the given header information.
Public method | StartWatchingAsync | Asynchronously sends a request to the server to start watching for messages with the given header information.
Public method | StopWatching()()()() | Stops watching for custom messages.
Public method | StopWatching(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously stops watching for custom messages.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | CustomNotificationReceived | Occurs when a CustomNotification is received from the server.

See Also

CustomNotification Class
ININ.IceLib.Connection.Extensions Namespace


CustomNotification Constructor

[image]

IceLib Technical Reference
CustomNotification Constructor
CustomNotification Class See Also Send Feedback
Initializes a new instance of the CustomNotification class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomNotification(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


CustomNotification Methods

[image] [image]

IceLib Technical Reference
CustomNotification Methods
CustomNotification Class See Also Send Feedback

The CustomNotification type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][]) | Sends a request to the server to change the watched notifications, replacing the existing watch.
Public method | ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][]) | Sends a request to the server to change the watched notifications.
Public method | ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously sends a request to the server to change the watched notifications, replacing the existing watch.
Public method | ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously sends a request to the server to change the watched notifications.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentlyWatchedHeaders | Returns the currently watched headers.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(CustomMessageHeader) | Determines whether a watch is active and if the specified value is being watched.
Public method | IsWatching(List<(Of <<'(CustomMessageHeader>)>>)) | Determines whether a watch is active and if the specified values are being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendApplicationRequest | Sends the specified custom request.
Public method | SendApplicationRequestAsync | Sends the no response asynchronously.
Public method | SendApplicationResponse | Sends the response.
Public method | SendApplicationResponseAsync | Sends the response asynchronously.
Public method | SendServerRequestNoResponse | Sends a message, with no response expected.
Public method | SendServerRequestNoResponseAsync | Asynchronously sends a message, with no response expected.
Public method | StartWatching | Sends a request to the server to start watching for messages with the given header information.
Public method | StartWatchingAsync | Asynchronously sends a request to the server to start watching for messages with the given header information.
Public method | StopWatching()()()() | Stops watching for custom messages.
Public method | StopWatching(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously stops watching for custom messages.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomNotification Class
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedNotifications Method

[image] [image]

IceLib Technical Reference
CustomNotification..::..ChangeWatchedNotifications Method
CustomNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][]) | Sends a request to the server to change the watched notifications, replacing the existing watch.
Public method | ChangeWatchedNotifications(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][]) | Sends a request to the server to change the watched notifications.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedNotifications Method (CustomMessageHeader[])

[image]

IceLib Technical Reference
CustomNotification..::..ChangeWatchedNotifications Method (array<CustomMessageHeader>[]()[][])
CustomNotification Class See Also Send Feedback
Sends a request to the server to change the watched notifications, replacing the existing watch.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedNotifications(
    CustomMessageHeader[] messageTypes
)
Visual Basic
Public Sub ChangeWatchedNotifications ( _
    messageTypes As CustomMessageHeader() _
)

Parameters

messageTypes
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The new message types.

Remarks

For further details see CustomNotification.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ChangeWatchedNotifications Overload
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedNotifications Method (CustomMessageHeader[], CustomMessageHeader[])

[image]

IceLib Technical Reference
CustomNotification..::..ChangeWatchedNotifications Method (array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][])
CustomNotification Class See Also Send Feedback
Sends a request to the server to change the watched notifications.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedNotifications(
    CustomMessageHeader[] typesAdded,
    CustomMessageHeader[] typesRemoved
)
Visual Basic
Public Sub ChangeWatchedNotifications ( _
    typesAdded As CustomMessageHeader(), _
    typesRemoved As CustomMessageHeader() _
)

Parameters

typesAdded
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The message types to add to the watch.
typesRemoved
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The message types to remove from the watch.

Remarks

For further details see CustomNotification.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ChangeWatchedNotifications Overload
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedNotificationsAsync Method

[image] [image]

IceLib Technical Reference
CustomNotification..::..ChangeWatchedNotificationsAsync Method
CustomNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously sends a request to the server to change the watched notifications, replacing the existing watch.
Public method | ChangeWatchedNotificationsAsync(array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously sends a request to the server to change the watched notifications.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedNotificationsAsync Method (CustomMessageHeader[], EventHandler(AsyncCompletedEventArgs), Object)

[image]

IceLib Technical Reference
CustomNotification..::..ChangeWatchedNotificationsAsync Method (array<CustomMessageHeader>[]()[][], EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>, Object)
CustomNotification Class See Also Send Feedback
Asynchronously sends a request to the server to change the watched notifications, replacing the existing watch.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedNotificationsAsync(
    CustomMessageHeader[] messageTypes,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedNotificationsAsync ( _
    messageTypes As CustomMessageHeader(), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

messageTypes
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The notification types.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

For further details see CustomNotification.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ChangeWatchedNotificationsAsync Overload
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedNotificationsAsync Method (CustomMessageHeader[], CustomMessageHeader[], EventHandler(AsyncCompletedEventArgs), Object)

[image]

IceLib Technical Reference
CustomNotification..::..ChangeWatchedNotificationsAsync Method (array<CustomMessageHeader>[]()[][], array<CustomMessageHeader>[]()[][], EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>, Object)
CustomNotification Class See Also Send Feedback
Asynchronously sends a request to the server to change the watched notifications.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedNotificationsAsync(
    CustomMessageHeader[] typesAdded,
    CustomMessageHeader[] typesRemoved,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedNotificationsAsync ( _
    typesAdded As CustomMessageHeader(), _
    typesRemoved As CustomMessageHeader(), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

typesAdded
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The notification types to add.
typesRemoved
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The notification types to remove.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

For further details see CustomNotification.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ChangeWatchedNotificationsAsync Overload
ININ.IceLib.Connection.Extensions Namespace


GetCurrentlyWatchedHeaders Method

[image]

IceLib Technical Reference
CustomNotification..::..GetCurrentlyWatchedHeaders Method
CustomNotification Class See Also Send Feedback
Returns the currently watched headers.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<CustomMessageHeader> GetCurrentlyWatchedHeaders()
Visual Basic
Public Function GetCurrentlyWatchedHeaders As ReadOnlyCollection(Of CustomMessageHeader)

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of CustomMessageHeader objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
CustomNotification..::..IsWatching Method
CustomNotification Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(CustomMessageHeader) | Determines whether a watch is active and if the specified value is being watched.
Public method | IsWatching(List<(Of <<'(CustomMessageHeader>)>>)) | Determines whether a watch is active and if the specified values are being watched.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method

[image]

IceLib Technical Reference
CustomNotification..::..IsWatching Method
CustomNotification Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CustomNotification Class
CustomNotification Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method (CustomMessageHeader)

[image]

IceLib Technical Reference
CustomNotification..::..IsWatching Method (CustomMessageHeader)
CustomNotification Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    CustomMessageHeader messageType
)
Visual Basic
Public Function IsWatching ( _
    messageType As CustomMessageHeader _
) As Boolean

Parameters

messageType
Type: ININ.IceLib.Connection.Extensions..::..CustomMessageHeader
The message type to check.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CustomNotification Class
CustomNotification Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method (List(CustomMessageHeader))

[image]

IceLib Technical Reference
CustomNotification..::..IsWatching Method (List<(Of <(<'CustomMessageHeader>)>)>)
CustomNotification Class See Also Send Feedback
Determines whether a watch is active and if the specified values are being watched.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    List<CustomMessageHeader> messageTypes
)
Visual Basic
Public Function IsWatching ( _
    messageTypes As List(Of CustomMessageHeader) _
) As Boolean

Parameters

messageTypes
Type: System.Collections.Generic..::..List<(Of <(<' CustomMessageHeader >)>)>
The message types to check.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CustomNotification Class
CustomNotification Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


SendApplicationRequest Method

[image]

IceLib Technical Reference
CustomNotification..::..SendApplicationRequest Method
CustomNotification Class See Also Send Feedback
Sends the specified custom request.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendApplicationRequest(
    CustomRequest customRequest
)
Visual Basic
Public Sub SendApplicationRequest ( _
    customRequest As CustomRequest _
)

Parameters

customRequest
Type: ININ.IceLib.Connection.Extensions..::..CustomRequest
The custom request.

Remarks

For further details see CustomNotification.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


SendApplicationRequestAsync Method

[image]

IceLib Technical Reference
CustomNotification..::..SendApplicationRequestAsync Method
CustomNotification Class See Also Send Feedback
Sends the no response asynchronously.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendApplicationRequestAsync(
    CustomRequest customRequest,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendApplicationRequestAsync ( _
    customRequest As CustomRequest, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

customRequest
Type: ININ.IceLib.Connection.Extensions..::..CustomRequest
The custom request.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

For further details see CustomNotification.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


SendApplicationResponse Method

[image]

IceLib Technical Reference
CustomNotification..::..SendApplicationResponse Method
CustomNotification Class See Also Send Feedback
Sends the response.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendApplicationResponse(
    CustomResponse customResponse
)
Visual Basic
Public Sub SendApplicationResponse ( _
    customResponse As CustomResponse _
)

Parameters

customResponse
Type: ININ.IceLib.Connection.Extensions..::..CustomResponse
The custom response.

Remarks

For further details see CustomNotification.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


SendApplicationResponseAsync Method

[image]

IceLib Technical Reference
CustomNotification..::..SendApplicationResponseAsync Method
CustomNotification Class See Also Send Feedback
Sends the response asynchronously.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendApplicationResponseAsync(
    CustomResponse customResponse,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendApplicationResponseAsync ( _
    customResponse As CustomResponse, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

customResponse
Type: ININ.IceLib.Connection.Extensions..::..CustomResponse
The custom response.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

For further details see CustomNotification.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


SendServerRequestNoResponse Method

[image]

IceLib Technical Reference
CustomNotification..::..SendServerRequestNoResponse Method
CustomNotification Class See Also Send Feedback
Sends a message, with no response expected.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendServerRequestNoResponse(
    CustomRequest customRequest
)
Visual Basic
Public Sub SendServerRequestNoResponse ( _
    customRequest As CustomRequest _
)

Parameters

customRequest
Type: ININ.IceLib.Connection.Extensions..::..CustomRequest
The custom request.

Remarks

Custom Handlers expect an array of strings (only) as input. Make sure that your custom request contains an array of strings only.

Be sure to StartWatching(array<CustomMessageHeader>[]()[][]) if the custom handler sends out custom notification. Again, Custom Handlers send an array of strings (only) as notifications.

For further details see CustomNotification.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Invalid data format found.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


SendServerRequestNoResponseAsync Method

[image]

IceLib Technical Reference
CustomNotification..::..SendServerRequestNoResponseAsync Method
CustomNotification Class See Also Send Feedback
Asynchronously sends a message, with no response expected.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendServerRequestNoResponseAsync(
    CustomRequest customRequest,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendServerRequestNoResponseAsync ( _
    customRequest As CustomRequest, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

customRequest
Type: ININ.IceLib.Connection.Extensions..::..CustomRequest
The custom request.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Custom Handlers expect an array of strings (only) as input. Make sure that your custom request contains an array of strings only.

Be sure to StartWatching(array<CustomMessageHeader>[]()[][]) if the custom handler sends out custom notification. Again, Custom Handlers send an array of strings (only) as notifications.

For further details see CustomNotification.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


StartWatching Method

[image]

IceLib Technical Reference
CustomNotification..::..StartWatching Method
CustomNotification Class See Also Send Feedback
Sends a request to the server to start watching for messages with the given header information.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    CustomMessageHeader[] messageTypes
)
Visual Basic
Public Sub StartWatching ( _
    messageTypes As CustomMessageHeader() _
)

Parameters

messageTypes
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The notification types.

Remarks

Note
All event handlers should be added before calling StartWatching(array<CustomMessageHeader>[]()[][]) or StartWatchingAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).

For further details see CustomNotification.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
CustomNotification..::..StartWatchingAsync Method
CustomNotification Class See Also Send Feedback
Asynchronously sends a request to the server to start watching for messages with the given header information.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    CustomMessageHeader[] messageTypes,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    messageTypes As CustomMessageHeader(), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

messageTypes
Type: array< ININ.IceLib.Connection.Extensions..::..CustomMessageHeader >[]()[][]
The notification types.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<CustomMessageHeader>[]()[][]) or StartWatchingAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).

For further details see CustomNotification.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


StopWatching Method

[image] [image]

IceLib Technical Reference
CustomNotification..::..StopWatching Method
CustomNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StopWatching()()()() | Stops watching for custom messages.
Public method | StopWatching(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) | Asynchronously stops watching for custom messages.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


StopWatching Method

[image]

IceLib Technical Reference
CustomNotification..::..StopWatching Method
CustomNotification Class See Also Send Feedback
Stops watching for custom messages.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
StopWatching Overload
ININ.IceLib.Connection.Extensions Namespace


StopWatching Method (EventHandler(AsyncCompletedEventArgs), Object)

[image]

IceLib Technical Reference
CustomNotification..::..StopWatching Method (EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>, Object)
CustomNotification Class See Also Send Feedback
Asynchronously stops watching for custom messages.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatching ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
StopWatching Overload
ININ.IceLib.Connection.Extensions Namespace


CustomNotification Events

[image] [image]

IceLib Technical Reference
CustomNotification Events
CustomNotification Class See Also Send Feedback

The CustomNotification type exposes the following members.

Events

 | Name | Description
Public event | CustomNotificationReceived | Occurs when a CustomNotification is received from the server.

See Also

CustomNotification Class
ININ.IceLib.Connection.Extensions Namespace


CustomNotificationReceived Event

[image]

IceLib Technical Reference
CustomNotification..::..CustomNotificationReceived Event
CustomNotification Class See Also Send Feedback
Occurs when a CustomNotification is received from the server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<CustomNotificationReceivedEventArgs> CustomNotificationReceived
Visual Basic
Public Event CustomNotificationReceived As EventHandler(Of CustomNotificationReceivedEventArgs)

Remarks

This event will only occur if custom notification are being watched. To start watching custom notifications call either the StartWatching(array<CustomMessageHeader>[]()[][]) method or the StartWatchingAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) method.

For further details see CustomNotification.

Note
All event handlers should be added before calling StartWatching(array<CustomMessageHeader>[]()[][]) or StartWatchingAsync(array<CustomMessageHeader>[]()[][], EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotification Class
CustomNotification Members
ININ.IceLib.Connection.Extensions Namespace


CustomNotificationReceivedEventArgs Class

[image]

IceLib Technical Reference
CustomNotificationReceivedEventArgs Class
Members See Also Send Feedback
Provides definition for the CustomNotificationReceived event of CustomNotification.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomNotificationReceivedEventArgs : EventArgs
Visual Basic
Public Class CustomNotificationReceivedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection.Extensions..::..CustomNotificationReceivedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotificationReceivedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


CustomNotificationReceivedEventArgs Members

[image] [image]

IceLib Technical Reference
CustomNotificationReceivedEventArgs Members
CustomNotificationReceivedEventArgs Class Methods Properties See Also Send Feedback

The CustomNotificationReceivedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets the message.

See Also

CustomNotificationReceivedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


CustomNotificationReceivedEventArgs Methods

[image] [image]

IceLib Technical Reference
CustomNotificationReceivedEventArgs Methods
CustomNotificationReceivedEventArgs Class See Also Send Feedback

The CustomNotificationReceivedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomNotificationReceivedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


CustomNotificationReceivedEventArgs Properties

[image] [image]

IceLib Technical Reference
CustomNotificationReceivedEventArgs Properties
CustomNotificationReceivedEventArgs Class See Also Send Feedback

The CustomNotificationReceivedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the message.

See Also

CustomNotificationReceivedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


Message Property

[image]

IceLib Technical Reference
CustomNotificationReceivedEventArgs..::..Message Property
CustomNotificationReceivedEventArgs Class See Also Send Feedback
Gets the message.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessage Message { get; }
Visual Basic
Public ReadOnly Property Message As CustomMessage
    Get

Field Value

The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomNotificationReceivedEventArgs Class
CustomNotificationReceivedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


CustomProfile Class

[image]

IceLib Technical Reference
CustomProfile Class
Members See Also Send Feedback
Allows storage of custom application settings to the Interaction Center server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomProfile
Visual Basic
Public Class CustomProfile

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomProfile

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace
ININ.IceLib.Connection.Extensions..::..CustomProfile


CustomProfile Members

[image] [image]

IceLib Technical Reference
CustomProfile Members
CustomProfile Class Constructors Methods Properties See Also Send Feedback

The CustomProfile type exposes the following members.

Constructors

 | Name | Description
Public method | CustomProfile | Obsolete. Initializes a new instance of the CustomProfile class.

Methods

 | Name | Description
 | AreApplicationBasedSettingsSupported | Indicates whether or not application based settings are supported on the IC Server.
Public method | CheckForApplicationBasedSettings | Checks to see if the application based settings exist for the specified application profile name from .
Public method | CheckForApplicationBasedSettingsAsync | Asynchronously checks to see if the application based settings exist for the specified application profile name from .
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FlushChanges | Forces any pending changes to be saved to the server immediately.
Public method | FlushChangesAsync | Asynchronously forces any pending changes to be saved to the server.
 | GetApplicationCustomProfile(CustomProfileParameters) | Gets the custom profile using the specified CustomProfileParameters.
 | GetApplicationCustomProfile(Session) | Gets the custom profile for this application's profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLegacyCustomProfile | Gets the legacy custom profile.
Public method | GetNamespaceContents | Gets the profile items contained in the requested namespace path.
Public method | GetNamespaceContentsAsync | Asynchronously gets the profile items contained in the requested namespace path.
 | GetOtherApplicationCustomProfile | Gets the custom profile for a specific application's profile.
Public method | GetProfileItem | Gets the specified profile item.
Public method | GetProfileItemAsync | Asynchronously gets the specified profile item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveNamespaceContents | Removes the profile items in the specified namespace.
Public method | RemoveNamespaceContentsAsync | Asynchronously removes the profile items in the specified namespace.
Public method | RemoveProfileItem | Removes the specified profile item.
Public method | RemoveProfileItemAsync | Asynchronously removes the specified profile item.
Public method | SetProfileItem(String, String, Object) | Sets the specified profile item.
Public method | SetProfileItem(String, String, String) | Sets the specified profile item.
Public method | SetProfileItemAsync(String, String, Object, AsyncCompletedEventHandler, Object) | Asynchronously sets the specified profile item.
Public method | SetProfileItemAsync(String, String, String, AsyncCompletedEventHandler, Object) | Asynchronously sets the specified profile item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanEditProfileItems | Gets a value indicating whether this custom profile allows editing profile items.
Public property | IsInLegacyMode | Gets a value indicating whether this custom profile is in legacy mode.

See Also

CustomProfile Class
ININ.IceLib.Connection.Extensions Namespace


CustomProfile Constructor

[image]

IceLib Technical Reference
CustomProfile Constructor
CustomProfile Class See Also Send Feedback
Initializes a new instance of the CustomProfile class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("This constructor is obsolete, use one of the static methods to create a new Custom Profile object.")]
public CustomProfile(
    Session session
)
Visual Basic
<ObsoleteAttribute("This constructor is obsolete, use one of the static methods to create a new Custom Profile object.")> _
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


CustomProfile Methods

[image] [image]

IceLib Technical Reference
CustomProfile Methods
CustomProfile Class See Also Send Feedback

The CustomProfile type exposes the following members.

Methods

 | Name | Description
 | AreApplicationBasedSettingsSupported | Indicates whether or not application based settings are supported on the IC Server.
Public method | CheckForApplicationBasedSettings | Checks to see if the application based settings exist for the specified application profile name from .
Public method | CheckForApplicationBasedSettingsAsync | Asynchronously checks to see if the application based settings exist for the specified application profile name from .
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FlushChanges | Forces any pending changes to be saved to the server immediately.
Public method | FlushChangesAsync | Asynchronously forces any pending changes to be saved to the server.
 | GetApplicationCustomProfile(CustomProfileParameters) | Gets the custom profile using the specified CustomProfileParameters.
 | GetApplicationCustomProfile(Session) | Gets the custom profile for this application's profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLegacyCustomProfile | Gets the legacy custom profile.
Public method | GetNamespaceContents | Gets the profile items contained in the requested namespace path.
Public method | GetNamespaceContentsAsync | Asynchronously gets the profile items contained in the requested namespace path.
 | GetOtherApplicationCustomProfile | Gets the custom profile for a specific application's profile.
Public method | GetProfileItem | Gets the specified profile item.
Public method | GetProfileItemAsync | Asynchronously gets the specified profile item.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveNamespaceContents | Removes the profile items in the specified namespace.
Public method | RemoveNamespaceContentsAsync | Asynchronously removes the profile items in the specified namespace.
Public method | RemoveProfileItem | Removes the specified profile item.
Public method | RemoveProfileItemAsync | Asynchronously removes the specified profile item.
Public method | SetProfileItem(String, String, Object) | Sets the specified profile item.
Public method | SetProfileItem(String, String, String) | Sets the specified profile item.
Public method | SetProfileItemAsync(String, String, Object, AsyncCompletedEventHandler, Object) | Asynchronously sets the specified profile item.
Public method | SetProfileItemAsync(String, String, String, AsyncCompletedEventHandler, Object) | Asynchronously sets the specified profile item.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomProfile Class
ININ.IceLib.Connection.Extensions Namespace


AreApplicationBasedSettingsSupported Method

[image]

IceLib Technical Reference
CustomProfile..::..AreApplicationBasedSettingsSupported Method
CustomProfile Class See Also Send Feedback
Indicates whether or not application based settings are supported on the IC Server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool AreApplicationBasedSettingsSupported(
    Session session
)
Visual Basic
Public Shared Function AreApplicationBasedSettingsSupported ( _
    session As Session _
) As Boolean

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Return Value

trueTruetruetrue (True in Visual Basic) if application based settings are supported on the IC Server; otherwise falseFalsefalsefalse (False in Visual Basic).

Remarks

The Session need to be connected to an IC Server in order to provide an accurate value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


CheckForApplicationBasedSettings Method

[image]

IceLib Technical Reference
CustomProfile..::..CheckForApplicationBasedSettings Method
CustomProfile Class See Also Send Feedback
Checks to see if the application based settings exist for the specified application profile name from .

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CheckForApplicationBasedSettings()
Visual Basic
Public Function CheckForApplicationBasedSettings As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if the application based settings exist; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Returns falseFalsefalsefalse (False in Visual Basic) if IsInLegacyMode is trueTruetruetrue (True in Visual Basic), otherwise, tries to download the application based settings from the IC Server and returns whether or not it was successful.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace
SessionSettings..::..ApplicationProfileName


CheckForApplicationBasedSettingsAsync Method

[image]

IceLib Technical Reference
CustomProfile..::..CheckForApplicationBasedSettingsAsync Method
CustomProfile Class See Also Send Feedback
Asynchronously checks to see if the application based settings exist for the specified application profile name from .

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CheckForApplicationBasedSettingsAsync(
    EventHandler<CheckForApplicationBasedSettingsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CheckForApplicationBasedSettingsAsync ( _
    completedCallback As EventHandler(Of CheckForApplicationBasedSettingsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' CheckForApplicationBasedSettingsCompletedEventArgs >)>)>
userState
Type: System..::..Object

Return Value

trueTruetruetrue (True in Visual Basic) if the application based settings exist; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Returns falseFalsefalsefalse (False in Visual Basic) if IsInLegacyMode is trueTruetruetrue (True in Visual Basic), otherwise, tries to download the application based settings from the IC Server and returns whether or not it was successful.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace
SessionSettings..::..ApplicationProfileName


FlushChanges Method

[image]

IceLib Technical Reference
CustomProfile..::..FlushChanges Method
CustomProfile Class See Also Send Feedback
Forces any pending changes to be saved to the server immediately.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void FlushChanges()
Visual Basic
Public Sub FlushChanges

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


FlushChangesAsync Method

[image]

IceLib Technical Reference
CustomProfile..::..FlushChangesAsync Method
CustomProfile Class See Also Send Feedback
Asynchronously forces any pending changes to be saved to the server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void FlushChangesAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub FlushChangesAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The AsyncCompletedEventArgs instance containing the event data.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetApplicationCustomProfile Method

[image] [image]

IceLib Technical Reference
CustomProfile..::..GetApplicationCustomProfile Method
CustomProfile Class See Also Send Feedback

Overload List

Name | Description
GetApplicationCustomProfile(CustomProfileParameters) | Gets the custom profile using the specified CustomProfileParameters.
GetApplicationCustomProfile(Session) | Gets the custom profile for this application's profile.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetApplicationCustomProfile Method (CustomProfileParameters)

[image]

IceLib Technical Reference
CustomProfile..::..GetApplicationCustomProfile Method (CustomProfileParameters)
CustomProfile Class See Also Send Feedback
Gets the custom profile using the specified CustomProfileParameters.

Note: This method is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static CustomProfile GetApplicationCustomProfile(
    CustomProfileParameters parameters
)
Visual Basic
Public Shared Function GetApplicationCustomProfile ( _
    parameters As CustomProfileParameters _
) As CustomProfile

Parameters

parameters
Type: ININ.IceLib.Connection.Extensions..::..CustomProfileParameters
The parameters.

Return Value

A CustomProfile object using the specified CustomProfileParameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..NotSupportedException | The server does not support setting the profile name for custom profiles.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfile Class
CustomProfile Members
GetApplicationCustomProfile Overload
ININ.IceLib.Connection.Extensions Namespace


GetApplicationCustomProfile Method (Session)

[image]

IceLib Technical Reference
CustomProfile..::..GetApplicationCustomProfile Method (Session)
CustomProfile Class See Also Send Feedback
Gets the custom profile for this application's profile.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static CustomProfile GetApplicationCustomProfile(
    Session session
)
Visual Basic
Public Shared Function GetApplicationCustomProfile ( _
    session As Session _
) As CustomProfile

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Return Value

A CustomProfile that uses the session's ApplicationProfileName for getting and setting profile information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..NotSupportedException | The server does not support setting the profile name for custom profiles.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
GetApplicationCustomProfile Overload
ININ.IceLib.Connection.Extensions Namespace


GetLegacyCustomProfile Method

[image]

IceLib Technical Reference
CustomProfile..::..GetLegacyCustomProfile Method
CustomProfile Class See Also Send Feedback
Gets the legacy custom profile.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static CustomProfile GetLegacyCustomProfile(
    Session session
)
Visual Basic
Public Shared Function GetLegacyCustomProfile ( _
    session As Session _
) As CustomProfile

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Return Value

A CustomProfile that uses the legacy mechanism for getting and setting profile information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContents Method

[image]

IceLib Technical Reference
CustomProfile..::..GetNamespaceContents Method
CustomProfile Class See Also Send Feedback
Gets the profile items contained in the requested namespace path.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ProfileItem> GetNamespaceContents(
    string namespacePath
)
Visual Basic
Public Function GetNamespaceContents ( _
    namespacePath As String _
) As IDictionary(Of String, ProfileItem)

Parameters

namespacePath
Type: System..::..String
The namespace path.

Return Value

The profile items.

Remarks

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.
Note
Requesting a namespace will cause that namespace, and all sub-namespaces, to be returned and cached. This can be used to pre-cache all profile items for a root namespace and make subsequent requests for profile items return from the local cache instead of issuing a server request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath length is zero.
ININ.IceLib..::..IceLibException | The custom profile information could not be retrieved.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContentsAsync Method

[image]

IceLib Technical Reference
CustomProfile..::..GetNamespaceContentsAsync Method
CustomProfile Class See Also Send Feedback
Asynchronously gets the profile items contained in the requested namespace path.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetNamespaceContentsAsync(
    string namespacePath,
    EventHandler<GetNamespaceContentsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetNamespaceContentsAsync ( _
    namespacePath As String, _
    completedCallback As EventHandler(Of GetNamespaceContentsCompletedEventArgs), _
    userState As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetNamespaceContentsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath length is zero.
ININ.IceLib..::..IceLibException | The custom profile information could not be retrieved.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetOtherApplicationCustomProfile Method

[image]

IceLib Technical Reference
CustomProfile..::..GetOtherApplicationCustomProfile Method
CustomProfile Class See Also Send Feedback
Gets the custom profile for a specific application's profile.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static CustomProfile GetOtherApplicationCustomProfile(
    Session session,
    string applicationProfileName
)
Visual Basic
Public Shared Function GetOtherApplicationCustomProfile ( _
    session As Session, _
    applicationProfileName As String _
) As CustomProfile

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.
applicationProfileName
Type: System..::..String
The application's profile name to use.

Return Value

A CustomProfile that uses the applicationProfileName for getting profile information.

Remarks

Custom profile information retrieved this way is read-only if the applicationProfileName does not match the value provided on the session's ApplicationProfileName.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.
ININ.IceLib..::..ServerOperationNotSupportedException | The server does not support setting the profile name for custom profiles.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetProfileItem Method

[image]

IceLib Technical Reference
CustomProfile..::..GetProfileItem Method
CustomProfile Class See Also Send Feedback
Gets the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProfileItem GetProfileItem(
    string namespacePath,
    string key
)
Visual Basic
Public Function GetProfileItem ( _
    namespacePath As String, _
    key As String _
) As ProfileItem

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.

Return Value

The requested profile item.

Remarks

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.
ININ.IceLib..::..IceLibException | The custom profile information could not be retrieved.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


GetProfileItemAsync Method

[image]

IceLib Technical Reference
CustomProfile..::..GetProfileItemAsync Method
CustomProfile Class See Also Send Feedback
Asynchronously gets the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetProfileItemAsync(
    string namespacePath,
    string key,
    EventHandler<GetProfileItemCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetProfileItemAsync ( _
    namespacePath As String, _
    key As String, _
    completedCallback As EventHandler(Of GetProfileItemCompletedEventArgs), _
    userState As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetProfileItemCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.
ININ.IceLib..::..IceLibException | The custom profile information could not be retrieved.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


RemoveNamespaceContents Method

[image]

IceLib Technical Reference
CustomProfile..::..RemoveNamespaceContents Method
CustomProfile Class See Also Send Feedback
Removes the profile items in the specified namespace.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveNamespaceContents(
    string namespacePath
)
Visual Basic
Public Sub RemoveNamespaceContents ( _
    namespacePath As String _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If the namespacePath length is zero.
ININ.IceLib..::..NotCachedException | The requested parameter is not cached.
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


RemoveNamespaceContentsAsync Method

[image]

IceLib Technical Reference
CustomProfile..::..RemoveNamespaceContentsAsync Method
CustomProfile Class See Also Send Feedback
Asynchronously removes the profile items in the specified namespace.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveNamespaceContentsAsync(
    string namespacePath,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RemoveNamespaceContentsAsync ( _
    namespacePath As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The AsyncCompletedEventArgs instance containing the event data.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If the namespacePath length is zero.
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


RemoveProfileItem Method

[image]

IceLib Technical Reference
CustomProfile..::..RemoveProfileItem Method
CustomProfile Class See Also Send Feedback
Removes the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveProfileItem(
    string namespacePath,
    string key
)
Visual Basic
Public Sub RemoveProfileItem ( _
    namespacePath As String, _
    key As String _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.
ININ.IceLib..::..NotCachedException | The requested parameter is not cached.
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


RemoveProfileItemAsync Method

[image]

IceLib Technical Reference
CustomProfile..::..RemoveProfileItemAsync Method
CustomProfile Class See Also Send Feedback
Asynchronously removes the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveProfileItemAsync(
    string namespacePath,
    string key,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RemoveProfileItemAsync ( _
    namespacePath As String, _
    key As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The AsyncCompletedEventArgs instance containing the event data.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


SetProfileItem Method

[image] [image]

IceLib Technical Reference
CustomProfile..::..SetProfileItem Method
CustomProfile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProfileItem(String, String, Object) | Sets the specified profile item.
Public method | SetProfileItem(String, String, String) | Sets the specified profile item.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


SetProfileItem Method (String, String, Object)

[image]

IceLib Technical Reference
CustomProfile..::..SetProfileItem Method (String, String, Object)
CustomProfile Class See Also Send Feedback
Sets the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetProfileItem(
    string namespacePath,
    string key,
    Object value
)
Visual Basic
Public Sub SetProfileItem ( _
    namespacePath As String, _
    key As String, _
    value As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
value
Type: System..::..Object
The value.

Remarks

namespacePath represents a path to organize the settings. The application may require that some settings be grouped together, so the namespacePath would be used to organize them that way, hierarchically. It also helps avoid collisions with the settings from other applications/code. Namespaces use the '/' character as a separator to build complex hierarchies. For example, "MyApplication/Configuration" and "MyApplication/Layout" would both be sub-namespaces situated in the "MyApplication" namespace.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
SetProfileItem Overload
ININ.IceLib.Connection.Extensions Namespace


SetProfileItem Method (String, String, String)

[image]

IceLib Technical Reference
CustomProfile..::..SetProfileItem Method (String, String, String)
CustomProfile Class See Also Send Feedback
Sets the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetProfileItem(
    string namespacePath,
    string key,
    string value
)
Visual Basic
Public Sub SetProfileItem ( _
    namespacePath As String, _
    key As String, _
    value As String _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
value
Type: System..::..String
The value.

Remarks

namespacePath represents a path to organize the settings. The application may require that some settings be grouped together, so the namespacePath would be used to organize them that way, hierarchically. It also helps avoid collisions with the settings from other applications/code. Namespaces use the '/' character as a separator to build complex hierarchies. For example, "MyApplication/Configuration" and "MyApplication/Layout" would both be sub-namespaces situated in the "MyApplication" namespace.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.
ININ.IceLib..::..IceLibException | The custom profile item cannot be modified because CanEditProfileItems is trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
SetProfileItem Overload
ININ.IceLib.Connection.Extensions Namespace


SetProfileItemAsync Method

[image] [image]

IceLib Technical Reference
CustomProfile..::..SetProfileItemAsync Method
CustomProfile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProfileItemAsync(String, String, Object, AsyncCompletedEventHandler, Object) | Asynchronously sets the specified profile item.
Public method | SetProfileItemAsync(String, String, String, AsyncCompletedEventHandler, Object) | Asynchronously sets the specified profile item.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


SetProfileItemAsync Method (String, String, Object, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
CustomProfile..::..SetProfileItemAsync Method (String, String, Object, AsyncCompletedEventHandler, Object)
CustomProfile Class See Also Send Feedback
Asynchronously sets the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetProfileItemAsync(
    string namespacePath,
    string key,
    Object value,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetProfileItemAsync ( _
    namespacePath As String, _
    key As String, _
    value As Object, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
value
Type: System..::..Object
The value.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The AsyncCompletedEventArgs instance containing the event data.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

namespacePath represents a path to organize the settings. The application may require that some settings be grouped together, so the namespacePath would be used to organize them that way, hierarchically. It also helps avoid collisions with the settings from other applications/code. Namespaces use the '/' character as a separator to build complex hierarchies. For example, "MyApplication/Configuration" and "MyApplication/Layout" would both be sub-namespaces situated in the "MyApplication" namespace.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
SetProfileItemAsync Overload
ININ.IceLib.Connection.Extensions Namespace


SetProfileItemAsync Method (String, String, String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
CustomProfile..::..SetProfileItemAsync Method (String, String, String, AsyncCompletedEventHandler, Object)
CustomProfile Class See Also Send Feedback
Asynchronously sets the specified profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetProfileItemAsync(
    string namespacePath,
    string key,
    string value,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetProfileItemAsync ( _
    namespacePath As String, _
    key As String, _
    value As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
value
Type: System..::..String
The value.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The AsyncCompletedEventArgs instance containing the event data.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

namespacePath represents a path to organize the settings. The application may require that some settings be grouped together, so the namespacePath would be used to organize them that way, hierarchically. It also helps avoid collisions with the settings from other applications/code. Namespaces use the '/' character as a separator to build complex hierarchies. For example, "MyApplication/Configuration" and "MyApplication/Layout" would both be sub-namespaces situated in the "MyApplication" namespace.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The namespacePath or key length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomProfile Class
CustomProfile Members
SetProfileItemAsync Overload
ININ.IceLib.Connection.Extensions Namespace


CustomProfile Properties

[image] [image]

IceLib Technical Reference
CustomProfile Properties
CustomProfile Class See Also Send Feedback

The CustomProfile type exposes the following members.

Properties

 | Name | Description
Public property | CanEditProfileItems | Gets a value indicating whether this custom profile allows editing profile items.
Public property | IsInLegacyMode | Gets a value indicating whether this custom profile is in legacy mode.

See Also

CustomProfile Class
ININ.IceLib.Connection.Extensions Namespace


CanEditProfileItems Property

[image]

IceLib Technical Reference
CustomProfile..::..CanEditProfileItems Property
CustomProfile Class See Also Send Feedback
Gets a value indicating whether this custom profile allows editing profile items.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanEditProfileItems { get; }
Visual Basic
Public ReadOnly Property CanEditProfileItems As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this custom profile allows editing profile items; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

When using creating a custom profile with GetOtherApplicationCustomProfile(Session, String), if the application profile name does not match the Session's ApplicationProfileName, then editing of the profile items via calls to SetProfileItem(String, String, Object), SetProfileItem(String, String, String), RemoveProfileItem(String, String), RemoveNamespaceContents(String), FlushChanges()()()(), and the associated asynchronous versions, are not allowed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


IsInLegacyMode Property

[image]

IceLib Technical Reference
CustomProfile..::..IsInLegacyMode Property
CustomProfile Class See Also Send Feedback
Gets a value indicating whether this custom profile is in legacy mode.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsInLegacyMode { get; private set; }
Visual Basic
Public Property IsInLegacyMode As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if this custom profile is legacy mode; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Custom profile instances that are in legacy mode save profile information in a single file. To use per-application custom profile settings to save profile information, use GetApplicationCustomProfile(CustomProfileParameters) or GetOtherApplicationCustomProfile(Session, String). When using these methods to create a custom profile, the connected Session's ApplicationProfileName needs to be set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

CustomProfile Class
CustomProfile Members
ININ.IceLib.Connection.Extensions Namespace


CustomProfileParameters Class

[image]

IceLib Technical Reference
CustomProfileParameters Class
Members See Also Send Feedback
Class used to specify the parameters for creating am application-based CustomProfile object via GetApplicationCustomProfile(CustomProfileParameters).

Note: This class is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomProfileParameters
Visual Basic
Public Class CustomProfileParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomProfileParameters

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Members
ININ.IceLib.Connection.Extensions Namespace


CustomProfileParameters Members

[image] [image]

IceLib Technical Reference
CustomProfileParameters Members
CustomProfileParameters Class Constructors Methods Properties See Also Send Feedback

The CustomProfileParameters type exposes the following members.

Constructors

 | Name | Description
Public method | CustomProfileParameters(Session) | Initializes a new instance of the CustomProfileParameters class.
Public method | CustomProfileParameters(Session, RestrictCacheRefreshOptions) | Initializes a new instance of the CustomProfileParameters class.
Public method | CustomProfileParameters(Session, String) | Initializes a new instance of the CustomProfileParameters class.
Public method | CustomProfileParameters(Session, String, RestrictCacheRefreshOptions) | Initializes a new instance of the CustomProfileParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationProfileName | Gets the application's profile name to use.
Public property | RestrictCacheRefreshOption | Gets a value indicating if cache refreshing should be restricted.
Public property | Session | Gets the session to associate with the CustomProfile object.

See Also

CustomProfileParameters Class
ININ.IceLib.Connection.Extensions Namespace


CustomProfileParameters Constructor

[image] [image]

IceLib Technical Reference
CustomProfileParameters Constructor
CustomProfileParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomProfileParameters(Session) | Initializes a new instance of the CustomProfileParameters class.
Public method | CustomProfileParameters(Session, RestrictCacheRefreshOptions) | Initializes a new instance of the CustomProfileParameters class.
Public method | CustomProfileParameters(Session, String) | Initializes a new instance of the CustomProfileParameters class.
Public method | CustomProfileParameters(Session, String, RestrictCacheRefreshOptions) | Initializes a new instance of the CustomProfileParameters class.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
ININ.IceLib.Connection.Extensions Namespace


CustomProfileParameters Constructor (Session)

[image]

IceLib Technical Reference
CustomProfileParameters Constructor (Session)
CustomProfileParameters Class See Also Send Feedback
Initializes a new instance of the CustomProfileParameters class.

Note: This constructor is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomProfileParameters(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Remarks

The ApplicationProfileName is set via the session's ApplicationProfileName property.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
CustomProfileParameters Overload
ININ.IceLib.Connection.Extensions Namespace
CustomProfile..::..GetApplicationCustomProfile(Session)


CustomProfileParameters Constructor (Session, RestrictCacheRefreshOptions)

[image]

IceLib Technical Reference
CustomProfileParameters Constructor (Session, RestrictCacheRefreshOptions)
CustomProfileParameters Class See Also Send Feedback
Initializes a new instance of the CustomProfileParameters class.

Note: This constructor is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomProfileParameters(
    Session session,
    RestrictCacheRefreshOptions restrictCacheRefreshOption
)
Visual Basic
Public Sub New ( _
    session As Session, _
    restrictCacheRefreshOption As RestrictCacheRefreshOptions _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.
restrictCacheRefreshOption
Type: ININ.IceLib.Connection.Extensions..::..RestrictCacheRefreshOptions
see RestrictCacheRefreshOptions for valid values and behaviors.

Remarks

The ApplicationProfileName is set via the session's ApplicationProfileName property.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
CustomProfileParameters Overload
ININ.IceLib.Connection.Extensions Namespace
CustomProfile..::..GetApplicationCustomProfile(Session)


CustomProfileParameters Constructor (Session, String)

[image]

IceLib Technical Reference
CustomProfileParameters Constructor (Session, String)
CustomProfileParameters Class See Also Send Feedback
Initializes a new instance of the CustomProfileParameters class.

Note: This constructor is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomProfileParameters(
    Session session,
    string applicationProfileName
)
Visual Basic
Public Sub New ( _
    session As Session, _
    applicationProfileName As String _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.
applicationProfileName
Type: System..::..String
The application's profile name to use.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
CustomProfileParameters Overload
ININ.IceLib.Connection.Extensions Namespace
CustomProfile..::..GetOtherApplicationCustomProfile(Session, String)


CustomProfileParameters Constructor (Session, String, RestrictCacheRefreshOptions)

[image]

IceLib Technical Reference
CustomProfileParameters Constructor (Session, String, RestrictCacheRefreshOptions)
CustomProfileParameters Class See Also Send Feedback
Initializes a new instance of the CustomProfileParameters class.

Note: This constructor is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomProfileParameters(
    Session session,
    string applicationProfileName,
    RestrictCacheRefreshOptions restrictCacheRefreshOption
)
Visual Basic
Public Sub New ( _
    session As Session, _
    applicationProfileName As String, _
    restrictCacheRefreshOption As RestrictCacheRefreshOptions _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.
applicationProfileName
Type: System..::..String
The application's profile name to use.
restrictCacheRefreshOption
Type: ININ.IceLib.Connection.Extensions..::..RestrictCacheRefreshOptions
see RestrictCacheRefreshOptions for valid values and behaviors.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.
System..::..ArgumentOutOfRangeException | restrictCacheRefreshOption is not a valid RestrictCacheRefreshOptions value, or restrictCacheRefreshOption is None.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
CustomProfileParameters Overload
ININ.IceLib.Connection.Extensions Namespace
CustomProfile..::..GetOtherApplicationCustomProfile(Session, String)


CustomProfileParameters Methods

[image] [image]

IceLib Technical Reference
CustomProfileParameters Methods
CustomProfileParameters Class See Also Send Feedback

The CustomProfileParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomProfileParameters Class
ININ.IceLib.Connection.Extensions Namespace


CustomProfileParameters Properties

[image] [image]

IceLib Technical Reference
CustomProfileParameters Properties
CustomProfileParameters Class See Also Send Feedback

The CustomProfileParameters type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationProfileName | Gets the application's profile name to use.
Public property | RestrictCacheRefreshOption | Gets a value indicating if cache refreshing should be restricted.
Public property | Session | Gets the session to associate with the CustomProfile object.

See Also

CustomProfileParameters Class
ININ.IceLib.Connection.Extensions Namespace


ApplicationProfileName Property

[image]

IceLib Technical Reference
CustomProfileParameters..::..ApplicationProfileName Property
CustomProfileParameters Class See Also Send Feedback
Gets the application's profile name to use.

Note: This property is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationProfileName { get; private set; }
Visual Basic
Public Property ApplicationProfileName As String
    Get
    Private Set

Field Value

The application's profile name to use.

Remarks

If the ApplicationProfileName value does not match the ApplicationProfileName property for the specified Session, then the associated CustomProfile object will be read-only.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
ININ.IceLib.Connection.Extensions Namespace


RestrictCacheRefreshOption Property

[image]

IceLib Technical Reference
CustomProfileParameters..::..RestrictCacheRefreshOption Property
CustomProfileParameters Class See Also Send Feedback
Gets a value indicating if cache refreshing should be restricted.

Note: This property is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RestrictCacheRefreshOptions RestrictCacheRefreshOption { get; private set; }
Visual Basic
Public Property RestrictCacheRefreshOption As RestrictCacheRefreshOptions
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) to restrict cache refreshing; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

If this is RestrictCacheRefreshOptions.NoRestrictions, once the custom profile data has been cached, the custom profile cache will only be refreshed on successful calls to FlushChanges()()()() or FlushChangesAsync(AsyncCompletedEventHandler, Object). If this is RestrictCacheRefreshOptions.RestrictOnGetOperations, then the custom profile cache will also be refreshed when calling GetProfileItem(String, String), GetProfileItemAsync(String, String, EventHandler<(Of <<'(GetProfileItemCompletedEventArgs>)>>), Object), GetNamespaceContents(String), and GetNamespaceContentsAsync(String, EventHandler<(Of <<'(GetNamespaceContentsCompletedEventArgs>)>>), Object), if the requested key was not found in the current custom profile cache data.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
ININ.IceLib.Connection.Extensions Namespace


Session Property

[image]

IceLib Technical Reference
CustomProfileParameters..::..Session Property
CustomProfileParameters Class See Also Send Feedback
Gets the session to associate with the CustomProfile object.

Note: This property is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; private set; }
Visual Basic
Public Property Session As Session
    Get
    Private Set

Field Value

The session.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

CustomProfileParameters Class
CustomProfileParameters Members
ININ.IceLib.Connection.Extensions Namespace


CustomRequest Class

[image]

IceLib Technical Reference
CustomRequest Class
Members See Also Send Feedback
Represents a custom notification request sent to the IC server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomRequest
Visual Basic
Public Class CustomRequest

Remarks

See CustomNotification for further details.

Note
For more information on getting started with custom notifications see Getting Started With Custom Notifications.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomRequest

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


CustomRequest Members

[image] [image]

IceLib Technical Reference
CustomRequest Members
CustomRequest Class Constructors Methods Properties See Also Send Feedback

The CustomRequest type exposes the following members.

Constructors

 | Name | Description
Public method | CustomRequest | Initializes a new instance of the CustomRequest class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | Write(Boolean) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Byte) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Char) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Double) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int16) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int32) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int64) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(String) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(array<String>[]()[][]) | Writes the specified data.

Properties

 | Name | Description
Public property | EventId | Gets the event ID.
Public property | Header | Gets the header.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.

See Also

CustomRequest Class
ININ.IceLib.Connection.Extensions Namespace


CustomRequest Constructor

[image]

IceLib Technical Reference
CustomRequest Constructor
CustomRequest Class See Also Send Feedback
Initializes a new instance of the CustomRequest class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomRequest(
    CustomMessageHeader header
)
Visual Basic
Public Sub New ( _
    header As CustomMessageHeader _
)

Parameters

header
Type: ININ.IceLib.Connection.Extensions..::..CustomMessageHeader
The header for this custom message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


CustomRequest Methods

[image] [image]

IceLib Technical Reference
CustomRequest Methods
CustomRequest Class See Also Send Feedback

The CustomRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | Write(Boolean) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Byte) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Char) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Double) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int16) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int32) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int64) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(String) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(array<String>[]()[][]) | Writes the specified data.

See Also

CustomRequest Class
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
CustomRequest..::..ToString Method
CustomRequest Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


Write Method

[image] [image]

IceLib Technical Reference
CustomRequest..::..Write Method
CustomRequest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(Boolean) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Byte) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Char) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Double) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int16) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int32) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(Int64) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(String) | Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).
Public method | Write(array<String>[]()[][]) | Writes the specified data.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


Write Method (Boolean)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Boolean)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    bool data
)
Visual Basic
Public Sub Write ( _
    data As Boolean _
)

Parameters

data
Type: System..::..Boolean
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Byte)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Byte)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    byte data
)
Visual Basic
Public Sub Write ( _
    data As Byte _
)

Parameters

data
Type: System..::..Byte
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Char)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Char)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    char data
)
Visual Basic
Public Sub Write ( _
    data As Char _
)

Parameters

data
Type: System..::..Char
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Double)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Double)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    double data
)
Visual Basic
Public Sub Write ( _
    data As Double _
)

Parameters

data
Type: System..::..Double
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Int16)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Int16)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    short data
)
Visual Basic
Public Sub Write ( _
    data As Short _
)

Parameters

data
Type: System..::..Int16
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Int32)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Int32)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    int data
)
Visual Basic
Public Sub Write ( _
    data As Integer _
)

Parameters

data
Type: System..::..Int32
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Int64)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (Int64)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    long data
)
Visual Basic
Public Sub Write ( _
    data As Long _
)

Parameters

data
Type: System..::..Int64
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (String)

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (String)
CustomRequest Class See Also Send Feedback
Writes the specified data. Do not use with custom handlers (sending requests via SendServerRequestNoResponse(CustomRequest) or SendServerRequestNoResponseAsync(CustomRequest, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) and if Header.CustomMessageType == ServerNotification).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    string data
)
Visual Basic
Public Sub Write ( _
    data As String _
)

Parameters

data
Type: System..::..String
The data.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Invalid data format.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (String[])

[image]

IceLib Technical Reference
CustomRequest..::..Write Method (array<String>[]()[][])
CustomRequest Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    string[] data
)
Visual Basic
Public Sub Write ( _
    data As String() _
)

Parameters

data
Type: array<System..::..String>[]()[][]
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


CustomRequest Properties

[image] [image]

IceLib Technical Reference
CustomRequest Properties
CustomRequest Class See Also Send Feedback

The CustomRequest type exposes the following members.

Properties

 | Name | Description
Public property | EventId | Gets the event ID.
Public property | Header | Gets the header.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.

See Also

CustomRequest Class
ININ.IceLib.Connection.Extensions Namespace


EventId Property

[image]

IceLib Technical Reference
CustomRequest..::..EventId Property
CustomRequest Class See Also Send Feedback
Gets the event ID.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EventId { get; }
Visual Basic
Public ReadOnly Property EventId As String
    Get

Field Value

The event ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


Header Property

[image]

IceLib Technical Reference
CustomRequest..::..Header Property
CustomRequest Class See Also Send Feedback
Gets the header.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessageHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As CustomMessageHeader
    Get

Field Value

The header.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


ObjectId Property

[image]

IceLib Technical Reference
CustomRequest..::..ObjectId Property
CustomRequest Class See Also Send Feedback
Gets the object ID for this request.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectId { get; }
Visual Basic
Public ReadOnly Property ObjectId As String
    Get

Field Value

The object ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


ObjectType Property

[image]

IceLib Technical Reference
CustomRequest..::..ObjectType Property
CustomRequest Class See Also Send Feedback
Gets the object type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectType { get; }
Visual Basic
Public ReadOnly Property ObjectType As String
    Get

Field Value

The object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomRequest Class
CustomRequest Members
ININ.IceLib.Connection.Extensions Namespace


CustomResponse Class

[image]

IceLib Technical Reference
CustomResponse Class
Members See Also Send Feedback
Represents a custom notification response to reply to the IC server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomResponse
Visual Basic
Public Class CustomResponse

Remarks

See CustomNotification for further details.

Note
For more information on getting started with custom notifications see Getting Started With Custom Notifications.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..CustomResponse

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


CustomResponse Members

[image] [image]

IceLib Technical Reference
CustomResponse Members
CustomResponse Class Constructors Methods Properties See Also Send Feedback

The CustomResponse type exposes the following members.

Constructors

 | Name | Description
Public method | CustomResponse | Initializes a new instance of the CustomResponse class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | Write(Boolean) | Writes the specified data.
Public method | Write(Byte) | Writes the specified data.
Public method | Write(Char) | Writes the specified data.
Public method | Write(Double) | Writes the specified data.
Public method | Write(Int16) | Writes the specified data.
Public method | Write(Int32) | Writes the specified data.
Public method | Write(Int64) | Writes the specified data.
Public method | Write(String) | Writes the specified data.
Public method | Write(array<String>[]()[][]) | Writes the specified data.

Properties

 | Name | Description
Public property | EventId | Gets the event ID.
Public property | Header | Gets the header.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.
Public property | OriginalMessage | Gets the original message.

See Also

CustomResponse Class
ININ.IceLib.Connection.Extensions Namespace


CustomResponse Constructor

[image]

IceLib Technical Reference
CustomResponse Constructor
CustomResponse Class See Also Send Feedback
Initializes a new instance of the CustomResponse class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomResponse(
    CustomMessage originalMessage
)
Visual Basic
Public Sub New ( _
    originalMessage As CustomMessage _
)

Parameters

originalMessage
Type: ININ.IceLib.Connection.Extensions..::..CustomMessage
The original message that is being responded to.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


CustomResponse Methods

[image] [image]

IceLib Technical Reference
CustomResponse Methods
CustomResponse Class See Also Send Feedback

The CustomResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | Write(Boolean) | Writes the specified data.
Public method | Write(Byte) | Writes the specified data.
Public method | Write(Char) | Writes the specified data.
Public method | Write(Double) | Writes the specified data.
Public method | Write(Int16) | Writes the specified data.
Public method | Write(Int32) | Writes the specified data.
Public method | Write(Int64) | Writes the specified data.
Public method | Write(String) | Writes the specified data.
Public method | Write(array<String>[]()[][]) | Writes the specified data.

See Also

CustomResponse Class
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
CustomResponse..::..ToString Method
CustomResponse Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


Write Method

[image] [image]

IceLib Technical Reference
CustomResponse..::..Write Method
CustomResponse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(Boolean) | Writes the specified data.
Public method | Write(Byte) | Writes the specified data.
Public method | Write(Char) | Writes the specified data.
Public method | Write(Double) | Writes the specified data.
Public method | Write(Int16) | Writes the specified data.
Public method | Write(Int32) | Writes the specified data.
Public method | Write(Int64) | Writes the specified data.
Public method | Write(String) | Writes the specified data.
Public method | Write(array<String>[]()[][]) | Writes the specified data.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


Write Method (Boolean)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Boolean)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    bool data
)
Visual Basic
Public Sub Write ( _
    data As Boolean _
)

Parameters

data
Type: System..::..Boolean
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Byte)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Byte)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    byte data
)
Visual Basic
Public Sub Write ( _
    data As Byte _
)

Parameters

data
Type: System..::..Byte
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Char)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Char)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    char data
)
Visual Basic
Public Sub Write ( _
    data As Char _
)

Parameters

data
Type: System..::..Char
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Double)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Double)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    double data
)
Visual Basic
Public Sub Write ( _
    data As Double _
)

Parameters

data
Type: System..::..Double
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Int16)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Int16)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    short data
)
Visual Basic
Public Sub Write ( _
    data As Short _
)

Parameters

data
Type: System..::..Int16
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Int32)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Int32)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    int data
)
Visual Basic
Public Sub Write ( _
    data As Integer _
)

Parameters

data
Type: System..::..Int32
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (Int64)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (Int64)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    long data
)
Visual Basic
Public Sub Write ( _
    data As Long _
)

Parameters

data
Type: System..::..Int64
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (String)

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (String)
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    string data
)
Visual Basic
Public Sub Write ( _
    data As String _
)

Parameters

data
Type: System..::..String
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


Write Method (String[])

[image]

IceLib Technical Reference
CustomResponse..::..Write Method (array<String>[]()[][])
CustomResponse Class See Also Send Feedback
Writes the specified data.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Write(
    string[] data
)
Visual Basic
Public Sub Write ( _
    data As String() _
)

Parameters

data
Type: array<System..::..String>[]()[][]
The data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
Write Overload
ININ.IceLib.Connection.Extensions Namespace


CustomResponse Properties

[image] [image]

IceLib Technical Reference
CustomResponse Properties
CustomResponse Class See Also Send Feedback

The CustomResponse type exposes the following members.

Properties

 | Name | Description
Public property | EventId | Gets the event ID.
Public property | Header | Gets the header.
Public property | ObjectId | Gets the object ID for this request.
Public property | ObjectType | Gets the object type.
Public property | OriginalMessage | Gets the original message.

See Also

CustomResponse Class
ININ.IceLib.Connection.Extensions Namespace


EventId Property

[image]

IceLib Technical Reference
CustomResponse..::..EventId Property
CustomResponse Class See Also Send Feedback
Gets the event ID.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EventId { get; }
Visual Basic
Public ReadOnly Property EventId As String
    Get

Field Value

The event ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


Header Property

[image]

IceLib Technical Reference
CustomResponse..::..Header Property
CustomResponse Class See Also Send Feedback
Gets the header.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessageHeader Header { get; }
Visual Basic
Public ReadOnly Property Header As CustomMessageHeader
    Get

Field Value

The header.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


ObjectId Property

[image]

IceLib Technical Reference
CustomResponse..::..ObjectId Property
CustomResponse Class See Also Send Feedback
Gets the object ID for this request.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectId { get; }
Visual Basic
Public ReadOnly Property ObjectId As String
    Get

Field Value

The object ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


ObjectType Property

[image]

IceLib Technical Reference
CustomResponse..::..ObjectType Property
CustomResponse Class See Also Send Feedback
Gets the object type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObjectType { get; }
Visual Basic
Public ReadOnly Property ObjectType As String
    Get

Field Value

The object type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


OriginalMessage Property

[image]

IceLib Technical Reference
CustomResponse..::..OriginalMessage Property
CustomResponse Class See Also Send Feedback
Gets the original message.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessage OriginalMessage { get; }
Visual Basic
Public ReadOnly Property OriginalMessage As CustomMessage
    Get

Field Value

The original message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

CustomResponse Class
CustomResponse Members
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContentsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetNamespaceContentsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of CustomProfile.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetNamespaceContentsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetNamespaceContentsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..GetNamespaceContentsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetNamespaceContentsCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContentsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetNamespaceContentsCompletedEventArgs Members
GetNamespaceContentsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetNamespaceContentsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetNamespaceContentsCompletedEventArgs | Initializes a new instance of the GetNamespaceContentsCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProfileItems | Gets the profile items.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetNamespaceContentsCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContentsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetNamespaceContentsCompletedEventArgs Constructor
GetNamespaceContentsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetNamespaceContentsCompletedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetNamespaceContentsCompletedEventArgs(
    IDictionary<string, ProfileItem> profileItems,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    profileItems As IDictionary(Of String, ProfileItem), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

profileItems
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, ProfileItem >)>)>
The profile items.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
State of the user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetNamespaceContentsCompletedEventArgs Class
GetNamespaceContentsCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContentsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetNamespaceContentsCompletedEventArgs Methods
GetNamespaceContentsCompletedEventArgs Class See Also Send Feedback

The GetNamespaceContentsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetNamespaceContentsCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


GetNamespaceContentsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetNamespaceContentsCompletedEventArgs Properties
GetNamespaceContentsCompletedEventArgs Class See Also Send Feedback

The GetNamespaceContentsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProfileItems | Gets the profile items.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetNamespaceContentsCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


ProfileItems Property

[image]

IceLib Technical Reference
GetNamespaceContentsCompletedEventArgs..::..ProfileItems Property
GetNamespaceContentsCompletedEventArgs Class See Also Send Feedback
Gets the profile items.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ProfileItem> ProfileItems { get; }
Visual Basic
Public ReadOnly Property ProfileItems As IDictionary(Of String, ProfileItem)
    Get

Field Value

The profile items.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetNamespaceContentsCompletedEventArgs Class
GetNamespaceContentsCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetProfileItemCompletedEventArgs Class

[image]

IceLib Technical Reference
GetProfileItemCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of CustomProfile.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetProfileItemCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetProfileItemCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..GetProfileItemCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetProfileItemCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetProfileItemCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetProfileItemCompletedEventArgs Members
GetProfileItemCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetProfileItemCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetProfileItemCompletedEventArgs | Initializes a new instance of the GetProfileItemCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProfileItem | Gets the profile item.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetProfileItemCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


GetProfileItemCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetProfileItemCompletedEventArgs Constructor
GetProfileItemCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetProfileItemCompletedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetProfileItemCompletedEventArgs(
    ProfileItem profileItem,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    profileItem As ProfileItem, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

profileItem
Type: ININ.IceLib.Connection.Extensions..::..ProfileItem
The profile item.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
State of the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetProfileItemCompletedEventArgs Class
GetProfileItemCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetProfileItemCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetProfileItemCompletedEventArgs Methods
GetProfileItemCompletedEventArgs Class See Also Send Feedback

The GetProfileItemCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetProfileItemCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


GetProfileItemCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetProfileItemCompletedEventArgs Properties
GetProfileItemCompletedEventArgs Class See Also Send Feedback

The GetProfileItemCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProfileItem | Gets the profile item.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetProfileItemCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Property

[image]

IceLib Technical Reference
GetProfileItemCompletedEventArgs..::..ProfileItem Property
GetProfileItemCompletedEventArgs Class See Also Send Feedback
Gets the profile item.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProfileItem ProfileItem { get; }
Visual Basic
Public ReadOnly Property ProfileItem As ProfileItem
    Get

Field Value

The profile item.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetProfileItemCompletedEventArgs Class
GetProfileItemCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetServerParametersCompletedEventArgs Class

[image]

IceLib Technical Reference
GetServerParametersCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of ServerParameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetServerParametersCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetServerParametersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..GetServerParametersCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetServerParametersCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetServerParametersCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetServerParametersCompletedEventArgs Members
GetServerParametersCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetServerParametersCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetServerParametersCompletedEventArgs | Initializes a new instance of the GetServerParametersCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ServerParameters | Gets the server parameters.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetServerParametersCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


GetServerParametersCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetServerParametersCompletedEventArgs Constructor
GetServerParametersCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetServerParametersCompletedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetServerParametersCompletedEventArgs(
    ServerParameter[] serverParams,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    serverParams As ServerParameter(), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

serverParams
Type: array< ININ.IceLib.Connection.Extensions..::..ServerParameter >[]()[][]
The server parameters.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetServerParametersCompletedEventArgs Class
GetServerParametersCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


GetServerParametersCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetServerParametersCompletedEventArgs Methods
GetServerParametersCompletedEventArgs Class See Also Send Feedback

The GetServerParametersCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetServerParametersCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


GetServerParametersCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetServerParametersCompletedEventArgs Properties
GetServerParametersCompletedEventArgs Class See Also Send Feedback

The GetServerParametersCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ServerParameters | Gets the server parameters.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetServerParametersCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Property

[image]

IceLib Technical Reference
GetServerParametersCompletedEventArgs..::..ServerParameters Property
GetServerParametersCompletedEventArgs Class See Also Send Feedback
Gets the server parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ServerParameter> ServerParameters { get; }
Visual Basic
Public ReadOnly Property ServerParameters As ReadOnlyCollection(Of ServerParameter)
    Get

Field Value

The server parameters.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetServerParametersCompletedEventArgs Class
GetServerParametersCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordEventArgs Class

[image]

IceLib Technical Reference
PasswordEventArgs Class
Members See Also Send Feedback
This class implements event arguments for the PasswordExpired and PasswordEnteredNagPeriod events.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlRootAttribute("PasswordNotify")]
public class PasswordEventArgs : EventArgs
Visual Basic
<XmlRootAttribute("PasswordNotify")> _
Public Class PasswordEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection.Extensions..::..PasswordEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordEventArgs Members

[image] [image]

IceLib Technical Reference
PasswordEventArgs Members
PasswordEventArgs Class Constructors Methods Properties See Also Send Feedback

The PasswordEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordEventArgs | Initializes a new instance of the PasswordEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Event | Gets or sets the type of event (Password entered nag period or Password expired).
Public property | PasswordAge | Gets or sets the password age.
Public property | PasswordMaxAge | Gets or sets the password max age.
Public property | PasswordNagAge | Gets or sets the password nag age.
Public property | Text | Gets or sets the localized text corresponding to the password event.
Public property | UserId | Gets or sets the user ID for which this password event has occurred.

See Also

PasswordEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


PasswordEventArgs Constructor

[image]

IceLib Technical Reference
PasswordEventArgs Constructor
PasswordEventArgs Class See Also Send Feedback
Initializes a new instance of the PasswordEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PasswordEventArgs()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordEventArgs Methods

[image] [image]

IceLib Technical Reference
PasswordEventArgs Methods
PasswordEventArgs Class See Also Send Feedback

The PasswordEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PasswordEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


PasswordEventArgs Properties

[image] [image]

IceLib Technical Reference
PasswordEventArgs Properties
PasswordEventArgs Class See Also Send Feedback

The PasswordEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Event | Gets or sets the type of event (Password entered nag period or Password expired).
Public property | PasswordAge | Gets or sets the password age.
Public property | PasswordMaxAge | Gets or sets the password max age.
Public property | PasswordNagAge | Gets or sets the password nag age.
Public property | Text | Gets or sets the localized text corresponding to the password event.
Public property | UserId | Gets or sets the user ID for which this password event has occurred.

See Also

PasswordEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


Event Property

[image]

IceLib Technical Reference
PasswordEventArgs..::..Event Property
PasswordEventArgs Class See Also Send Feedback
Gets or sets the type of event (Password entered nag period or Password expired).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlAttributeAttribute("Event")]
public string Event { get; set; }
Visual Basic
<XmlAttributeAttribute("Event")> _
Public Property Event As String
    Get
    Set

Field Value

The event attribute.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordAge Property

[image]

IceLib Technical Reference
PasswordEventArgs..::..PasswordAge Property
PasswordEventArgs Class See Also Send Feedback
Gets or sets the password age.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlElementAttribute("PasswordAge")]
public int PasswordAge { get; set; }
Visual Basic
<XmlElementAttribute("PasswordAge")> _
Public Property PasswordAge As Integer
    Get
    Set

Field Value

The password age.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordMaxAge Property

[image]

IceLib Technical Reference
PasswordEventArgs..::..PasswordMaxAge Property
PasswordEventArgs Class See Also Send Feedback
Gets or sets the password max age.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlElementAttribute("PasswordMaxAge")]
public int PasswordMaxAge { get; set; }
Visual Basic
<XmlElementAttribute("PasswordMaxAge")> _
Public Property PasswordMaxAge As Integer
    Get
    Set

Field Value

The password max age.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordNagAge Property

[image]

IceLib Technical Reference
PasswordEventArgs..::..PasswordNagAge Property
PasswordEventArgs Class See Also Send Feedback
Gets or sets the password nag age.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlElementAttribute("PasswordNagAge")]
public int PasswordNagAge { get; set; }
Visual Basic
<XmlElementAttribute("PasswordNagAge")> _
Public Property PasswordNagAge As Integer
    Get
    Set

Field Value

The password nag age.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


Text Property

[image]

IceLib Technical Reference
PasswordEventArgs..::..Text Property
PasswordEventArgs Class See Also Send Feedback
Gets or sets the localized text corresponding to the password event.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlElementAttribute("Text")]
public string Text { get; set; }
Visual Basic
<XmlElementAttribute("Text")> _
Public Property Text As String
    Get
    Set

Field Value

The localized text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


UserId Property

[image]

IceLib Technical Reference
PasswordEventArgs..::..UserId Property
PasswordEventArgs Class See Also Send Feedback
Gets or sets the user ID for which this password event has occurred.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[XmlAttributeAttribute("User")]
public string UserId { get; set; }
Visual Basic
<XmlAttributeAttribute("User")> _
Public Property UserId As String
    Get
    Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordEventArgs Class
PasswordEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicy Class

[image]

IceLib Technical Reference
PasswordPolicy Class
Members See Also Send Feedback
Defines password policy for a given user, for use with the Security class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PasswordPolicy
Visual Basic
Public Class PasswordPolicy

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..PasswordPolicy

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicy Members

[image] [image]

IceLib Technical Reference
PasswordPolicy Members
PasswordPolicy Class Methods Properties See Also Send Feedback

The PasswordPolicy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountLockoutDuration | Gets the account lockout duration.
Public property | AccountLockoutResetTime | Gets the account lockout reset time.
Public property | AllSequentialDigitsAllowed | Gets a value indicating whether all sequential digits is allowed.
Public property | CurrentAge | Gets the current age.
Public property | LastLockoutTime | Gets the last lockout time in UTC.
Public property | LastPasswordSetTime | Gets the last password set time in UTC.
Public property | MaximumAge | Gets the maximum age.
Public property | MaximumAllowedLoginAttempts | Gets the maximum allowed login attempts.
Public property | MaximumNagPeriod | Gets the maximum nag period.
Public property | MinimumAge | Gets the minimum age.
Public property | MinimumLength | Gets the minimum length.
Public property | MinimumLowercaseCharacters | Gets the minimum number of lowercase characters.
Public property | MinimumNumericCharacters | Gets the minimum number of numeric characters.
Public property | MinimumSpecialCharacters | Gets the minimum number of special characters.
Public property | MinimumUppercaseCharacters | Gets the minimum number of uppercase characters.
Public property | MustChangePassword | Gets a value indicating whether the user must change their password.
Public property | MustChangePasswordTime | Gets the must change password time in UTC.
Public property | SpecialCharacters | Gets the special characters.
Public property | UniquenessConstraint | Gets the uniqueness constraint.

See Also

PasswordPolicy Class
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicy Methods

[image] [image]

IceLib Technical Reference
PasswordPolicy Methods
PasswordPolicy Class See Also Send Feedback

The PasswordPolicy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PasswordPolicy Class
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicy Properties

[image] [image]

IceLib Technical Reference
PasswordPolicy Properties
PasswordPolicy Class See Also Send Feedback

The PasswordPolicy type exposes the following members.

Properties

 | Name | Description
Public property | AccountLockoutDuration | Gets the account lockout duration.
Public property | AccountLockoutResetTime | Gets the account lockout reset time.
Public property | AllSequentialDigitsAllowed | Gets a value indicating whether all sequential digits is allowed.
Public property | CurrentAge | Gets the current age.
Public property | LastLockoutTime | Gets the last lockout time in UTC.
Public property | LastPasswordSetTime | Gets the last password set time in UTC.
Public property | MaximumAge | Gets the maximum age.
Public property | MaximumAllowedLoginAttempts | Gets the maximum allowed login attempts.
Public property | MaximumNagPeriod | Gets the maximum nag period.
Public property | MinimumAge | Gets the minimum age.
Public property | MinimumLength | Gets the minimum length.
Public property | MinimumLowercaseCharacters | Gets the minimum number of lowercase characters.
Public property | MinimumNumericCharacters | Gets the minimum number of numeric characters.
Public property | MinimumSpecialCharacters | Gets the minimum number of special characters.
Public property | MinimumUppercaseCharacters | Gets the minimum number of uppercase characters.
Public property | MustChangePassword | Gets a value indicating whether the user must change their password.
Public property | MustChangePasswordTime | Gets the must change password time in UTC.
Public property | SpecialCharacters | Gets the special characters.
Public property | UniquenessConstraint | Gets the uniqueness constraint.

See Also

PasswordPolicy Class
ININ.IceLib.Connection.Extensions Namespace


AccountLockoutDuration Property

[image]

IceLib Technical Reference
PasswordPolicy..::..AccountLockoutDuration Property
PasswordPolicy Class See Also Send Feedback
Gets the account lockout duration.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int AccountLockoutDuration { get; }
Visual Basic
Public ReadOnly Property AccountLockoutDuration As Integer
    Get

Field Value

The account lockout duration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


AccountLockoutResetTime Property

[image]

IceLib Technical Reference
PasswordPolicy..::..AccountLockoutResetTime Property
PasswordPolicy Class See Also Send Feedback
Gets the account lockout reset time.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int AccountLockoutResetTime { get; }
Visual Basic
Public ReadOnly Property AccountLockoutResetTime As Integer
    Get

Field Value

The account lockout reset time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


AllSequentialDigitsAllowed Property

[image]

IceLib Technical Reference
PasswordPolicy..::..AllSequentialDigitsAllowed Property
PasswordPolicy Class See Also Send Feedback
Gets a value indicating whether all sequential digits is allowed.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllSequentialDigitsAllowed { get; }
Visual Basic
Public ReadOnly Property AllSequentialDigitsAllowed As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if all sequential digits is allowed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


CurrentAge Property

[image]

IceLib Technical Reference
PasswordPolicy..::..CurrentAge Property
PasswordPolicy Class See Also Send Feedback
Gets the current age.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CurrentAge { get; }
Visual Basic
Public ReadOnly Property CurrentAge As Integer
    Get

Field Value

The current age.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


LastLockoutTime Property

[image]

IceLib Technical Reference
PasswordPolicy..::..LastLockoutTime Property
PasswordPolicy Class See Also Send Feedback
Gets the last lockout time in UTC.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime LastLockoutTime { get; }
Visual Basic
Public ReadOnly Property LastLockoutTime As DateTime
    Get

Field Value

The last lockout time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


LastPasswordSetTime Property

[image]

IceLib Technical Reference
PasswordPolicy..::..LastPasswordSetTime Property
PasswordPolicy Class See Also Send Feedback
Gets the last password set time in UTC.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime LastPasswordSetTime { get; }
Visual Basic
Public ReadOnly Property LastPasswordSetTime As DateTime
    Get

Field Value

The last password set time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MaximumAge Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MaximumAge Property
PasswordPolicy Class See Also Send Feedback
Gets the maximum age.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaximumAge { get; }
Visual Basic
Public ReadOnly Property MaximumAge As Integer
    Get

Field Value

The maximum age.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MaximumAllowedLoginAttempts Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MaximumAllowedLoginAttempts Property
PasswordPolicy Class See Also Send Feedback
Gets the maximum allowed login attempts.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaximumAllowedLoginAttempts { get; }
Visual Basic
Public ReadOnly Property MaximumAllowedLoginAttempts As Integer
    Get

Field Value

The maximum allowed login attempts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MaximumNagPeriod Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MaximumNagPeriod Property
PasswordPolicy Class See Also Send Feedback
Gets the maximum nag period.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaximumNagPeriod { get; }
Visual Basic
Public ReadOnly Property MaximumNagPeriod As Integer
    Get

Field Value

The maximum nag period.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MinimumAge Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MinimumAge Property
PasswordPolicy Class See Also Send Feedback
Gets the minimum age.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MinimumAge { get; }
Visual Basic
Public ReadOnly Property MinimumAge As Integer
    Get

Field Value

The minimum age.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MinimumLength Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MinimumLength Property
PasswordPolicy Class See Also Send Feedback
Gets the minimum length.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MinimumLength { get; }
Visual Basic
Public ReadOnly Property MinimumLength As Integer
    Get

Field Value

The minimum length.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MinimumLowercaseCharacters Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MinimumLowercaseCharacters Property
PasswordPolicy Class See Also Send Feedback
Gets the minimum number of lowercase characters.

Note: This property is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MinimumLowercaseCharacters { get; }
Visual Basic
Public ReadOnly Property MinimumLowercaseCharacters As Integer
    Get

Field Value

The minimum number of lowercase characters.

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MinimumNumericCharacters Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MinimumNumericCharacters Property
PasswordPolicy Class See Also Send Feedback
Gets the minimum number of numeric characters.

Note: This property is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MinimumNumericCharacters { get; }
Visual Basic
Public ReadOnly Property MinimumNumericCharacters As Integer
    Get

Field Value

The minimum number of numeric characters.

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MinimumSpecialCharacters Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MinimumSpecialCharacters Property
PasswordPolicy Class See Also Send Feedback
Gets the minimum number of special characters.

Note: This property is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MinimumSpecialCharacters { get; }
Visual Basic
Public ReadOnly Property MinimumSpecialCharacters As Integer
    Get

Field Value

The minimum number of special characters.

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace
PasswordPolicy..::..SpecialCharacters


MinimumUppercaseCharacters Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MinimumUppercaseCharacters Property
PasswordPolicy Class See Also Send Feedback
Gets the minimum number of uppercase characters.

Note: This property is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MinimumUppercaseCharacters { get; }
Visual Basic
Public ReadOnly Property MinimumUppercaseCharacters As Integer
    Get

Field Value

The minimum number of uppercase characters.

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MustChangePassword Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MustChangePassword Property
PasswordPolicy Class See Also Send Feedback
Gets a value indicating whether the user must change their password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool MustChangePassword { get; }
Visual Basic
Public ReadOnly Property MustChangePassword As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user must change their password; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


MustChangePasswordTime Property

[image]

IceLib Technical Reference
PasswordPolicy..::..MustChangePasswordTime Property
PasswordPolicy Class See Also Send Feedback
Gets the must change password time in UTC.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime MustChangePasswordTime { get; }
Visual Basic
Public ReadOnly Property MustChangePasswordTime As DateTime
    Get

Field Value

The must change password time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


SpecialCharacters Property

[image]

IceLib Technical Reference
PasswordPolicy..::..SpecialCharacters Property
PasswordPolicy Class See Also Send Feedback
Gets the special characters.

Note: This property is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SpecialCharacters { get; }
Visual Basic
Public ReadOnly Property SpecialCharacters As String
    Get

Field Value

The special characters.

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace
PasswordPolicy..::..MinimumSpecialCharacters


UniquenessConstraint Property

[image]

IceLib Technical Reference
PasswordPolicy..::..UniquenessConstraint Property
PasswordPolicy Class See Also Send Feedback
Gets the uniqueness constraint.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int UniquenessConstraint { get; }
Visual Basic
Public ReadOnly Property UniquenessConstraint As Integer
    Get

Field Value

The uniqueness constraint.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicy Class
PasswordPolicy Members
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicyAsyncCompletedEventArgs Class

[image]

IceLib Technical Reference
PasswordPolicyAsyncCompletedEventArgs Class
Members See Also Send Feedback
Arguments returned by the GetPasswordPolicyAsync(EventHandler<(Of <<'(PasswordPolicyAsyncCompletedEventArgs>)>>), Object) request.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PasswordPolicyAsyncCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class PasswordPolicyAsyncCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..PasswordPolicyAsyncCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicyAsyncCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicyAsyncCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
PasswordPolicyAsyncCompletedEventArgs Members
PasswordPolicyAsyncCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The PasswordPolicyAsyncCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordPolicyAsyncCompletedEventArgs | Initializes a new instance of the PasswordPolicyAsyncCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PasswordPolicy | Gets or sets the password policy.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

PasswordPolicyAsyncCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicyAsyncCompletedEventArgs Constructor

[image]

IceLib Technical Reference
PasswordPolicyAsyncCompletedEventArgs Constructor
PasswordPolicyAsyncCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the PasswordPolicyAsyncCompletedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PasswordPolicyAsyncCompletedEventArgs(
    PasswordPolicy passwordPolicy,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    passwordPolicy As PasswordPolicy, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

passwordPolicy
Type: ININ.IceLib.Connection.Extensions..::..PasswordPolicy
The password policy.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
Not currently supported.
userState
Type: System..::..Object
The user-supplied object to be passed to the asynchronous password policy operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicyAsyncCompletedEventArgs Class
PasswordPolicyAsyncCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicyAsyncCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
PasswordPolicyAsyncCompletedEventArgs Methods
PasswordPolicyAsyncCompletedEventArgs Class See Also Send Feedback

The PasswordPolicyAsyncCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PasswordPolicyAsyncCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicyAsyncCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
PasswordPolicyAsyncCompletedEventArgs Properties
PasswordPolicyAsyncCompletedEventArgs Class See Also Send Feedback

The PasswordPolicyAsyncCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PasswordPolicy | Gets or sets the password policy.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

PasswordPolicyAsyncCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


PasswordPolicy Property

[image]

IceLib Technical Reference
PasswordPolicyAsyncCompletedEventArgs..::..PasswordPolicy Property
PasswordPolicyAsyncCompletedEventArgs Class See Also Send Feedback
Gets or sets the password policy.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PasswordPolicy PasswordPolicy { get; set; }
Visual Basic
Public Property PasswordPolicy As PasswordPolicy
    Get
    Set

Field Value

The password policy.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PasswordPolicyAsyncCompletedEventArgs Class
PasswordPolicyAsyncCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


ProblemReporter Class

[image]

IceLib Technical Reference
ProblemReporter Class
Members See Also Send Feedback
Used to submit a problem report along with a subject, description, and related files.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProblemReporter
Visual Basic
Public Class ProblemReporter

Remarks

Calling Submit()()()() or SubmitAsync(AsyncCompletedEventHandler, Object) will upload the files to the destination and send an email to the appropriate recipients, both of which are defined in Interaction Administrator.

The file size limit to upload is 200MB.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..ProblemReporter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


ProblemReporter Members

[image] [image]

IceLib Technical Reference
ProblemReporter Members
ProblemReporter Class Constructors Methods Properties See Also Send Feedback

The ProblemReporter type exposes the following members.

Constructors

 | Name | Description
Public method | ProblemReporter | Initializes a new instance of the ProblemReporter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits the problem report and emails the recipients defined in Interaction Administrator.
Public method | SubmitAsync | Asynchronously submits the problem report and emails the recipients defined in Interaction Administrator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the description for the report.
Public property | FilePath | Gets the filepath for the file to upload.
Public property | Subject | Gets the subject for the email of the report.

See Also

ProblemReporter Class
ININ.IceLib.Connection.Extensions Namespace


ProblemReporter Constructor

[image]

IceLib Technical Reference
ProblemReporter Constructor
ProblemReporter Class See Also Send Feedback
Initializes a new instance of the ProblemReporter class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProblemReporter(
    Session session,
    string subject,
    string description,
    string filePath
)
Visual Basic
Public Sub New ( _
    session As Session, _
    subject As String, _
    description As String, _
    filePath As String _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.
subject
Type: System..::..String
The subject for the email of the problem report.
description
Type: System..::..String
The description of the problem.
filePath
Type: System..::..String
The path and name of a local file to upload. The file size must not exceed 200MB.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | The filePath parameter points to a file that exceeds 200MB.
System.IO..::..IOException | There was an error accessing the file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Class
ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


ProblemReporter Methods

[image] [image]

IceLib Technical Reference
ProblemReporter Methods
ProblemReporter Class See Also Send Feedback

The ProblemReporter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits the problem report and emails the recipients defined in Interaction Administrator.
Public method | SubmitAsync | Asynchronously submits the problem report and emails the recipients defined in Interaction Administrator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProblemReporter Class
ININ.IceLib.Connection.Extensions Namespace


Submit Method

[image]

IceLib Technical Reference
ProblemReporter..::..Submit Method
ProblemReporter Class See Also Send Feedback
Submits the problem report and emails the recipients defined in Interaction Administrator.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Submit()
Visual Basic
Public Sub Submit

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibException | The file exceeded the upload limit of 200MB or there were insufficient rights to submit a report.
System.IO..::..IOException | There was an error accessing the file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Class
ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


SubmitAsync Method

[image]

IceLib Technical Reference
ProblemReporter..::..SubmitAsync Method
ProblemReporter Class See Also Send Feedback
Asynchronously submits the problem report and emails the recipients defined in Interaction Administrator.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SubmitAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SubmitAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception occurred while submitting.
ININ.IceLib..::..IceLibException | The file exceeded the upload limit of 200MB.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Class
ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


ProblemReporter Properties

[image] [image]

IceLib Technical Reference
ProblemReporter Properties
ProblemReporter Class See Also Send Feedback

The ProblemReporter type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description for the report.
Public property | FilePath | Gets the filepath for the file to upload.
Public property | Subject | Gets the subject for the email of the report.

See Also

ProblemReporter Class
ININ.IceLib.Connection.Extensions Namespace


Description Property

[image]

IceLib Technical Reference
ProblemReporter..::..Description Property
ProblemReporter Class See Also Send Feedback
Gets the description for the report.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Class
ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


FilePath Property

[image]

IceLib Technical Reference
ProblemReporter..::..FilePath Property
ProblemReporter Class See Also Send Feedback
Gets the filepath for the file to upload.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FilePath { get; }
Visual Basic
Public ReadOnly Property FilePath As String
    Get

Field Value

The filepath.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Class
ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


Subject Property

[image]

IceLib Technical Reference
ProblemReporter..::..Subject Property
ProblemReporter Class See Also Send Feedback
Gets the subject for the email of the report.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Subject { get; }
Visual Basic
Public ReadOnly Property Subject As String
    Get

Field Value

The subject.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProblemReporter Class
ProblemReporter Members
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Class

[image]

IceLib Technical Reference
ProfileItem Class
Members See Also Send Feedback
Represents a custom application setting that will be persisted to the Interaction Center server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProfileItem
Visual Basic
Public Class ProfileItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..ProfileItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace
ININ.IceLib.Connection.Extensions..::..CustomProfile


ProfileItem Members

[image] [image]

IceLib Technical Reference
ProfileItem Members
ProfileItem Class Constructors Methods Operators Properties See Also Send Feedback

The ProfileItem type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileItem(String, String, Object) | Initializes a new instance of the ProfileItem class.
Public method | ProfileItem(String, String, String) | Initializes a new instance of the ProfileItem class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ProfileItem) | Determines whether the specified ProfileItem is equal to the current ProfileItem.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of ProfileItem are equal.
Inequality | Determines whether two instances of ProfileItem are not equal.

Properties

 | Name | Description
Public property | IsPlainTextValue | Gets a value indicating whether this profile item is stored with a plain text value.
Public property | Key | Gets the key.
Public property | NamespacePath | Gets the namespace path.
Public property | Value | Gets the value.

See Also

ProfileItem Class
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Constructor

[image] [image]

IceLib Technical Reference
ProfileItem Constructor
ProfileItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProfileItem(String, String, Object) | Initializes a new instance of the ProfileItem class.
Public method | ProfileItem(String, String, String) | Initializes a new instance of the ProfileItem class.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Constructor (String, String, Object)

[image]

IceLib Technical Reference
ProfileItem Constructor (String, String, Object)
ProfileItem Class See Also Send Feedback
Initializes a new instance of the ProfileItem class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProfileItem(
    string namespacePath,
    string key,
    Object value
)
Visual Basic
Public Sub New ( _
    namespacePath As String, _
    key As String, _
    value As Object _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
value
Type: System..::..Object
The value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ProfileItem Overload
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Constructor (String, String, String)

[image]

IceLib Technical Reference
ProfileItem Constructor (String, String, String)
ProfileItem Class See Also Send Feedback
Initializes a new instance of the ProfileItem class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProfileItem(
    string namespacePath,
    string key,
    string value
)
Visual Basic
Public Sub New ( _
    namespacePath As String, _
    key As String, _
    value As String _
)

Parameters

namespacePath
Type: System..::..String
The namespace path.
key
Type: System..::..String
The key.
value
Type: System..::..String
The value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ProfileItem Overload
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Methods

[image] [image]

IceLib Technical Reference
ProfileItem Methods
ProfileItem Class See Also Send Feedback

The ProfileItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ProfileItem) | Determines whether the specified ProfileItem is equal to the current ProfileItem.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ProfileItem Class
ININ.IceLib.Connection.Extensions Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ProfileItem..::..Equals Method
ProfileItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ProfileItem) | Determines whether the specified ProfileItem is equal to the current ProfileItem.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ProfileItem..::..Equals Method (Object)
ProfileItem Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProfileItem Class
ProfileItem Members
Equals Overload
ININ.IceLib.Connection.Extensions Namespace


Equals Method (ProfileItem)

[image]

IceLib Technical Reference
ProfileItem..::..Equals Method (ProfileItem)
ProfileItem Class See Also Send Feedback
Determines whether the specified ProfileItem is equal to the current ProfileItem.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ProfileItem other
)
Visual Basic
Public Function Equals ( _
    other As ProfileItem _
) As Boolean

Parameters

other
Type: ININ.IceLib.Connection.Extensions..::..ProfileItem
The ProfileItem to compare with the current ProfileItem.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified ProfileItem is equal to the current ProfileItem; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
Equals Overload
ININ.IceLib.Connection.Extensions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ProfileItem..::..GetHashCode Method
ProfileItem Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
ProfileItem..::..ToString Method
ProfileItem Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Operators

[image] [image]

IceLib Technical Reference
ProfileItem Operators
ProfileItem Class See Also Send Feedback

The ProfileItem type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of ProfileItem are equal.
Inequality | Determines whether two instances of ProfileItem are not equal.

See Also

ProfileItem Class
ININ.IceLib.Connection.Extensions Namespace


Equality Operator

[image]

IceLib Technical Reference
ProfileItem..::..Equality Operator
ProfileItem Class See Also Send Feedback
Determines whether two instances of ProfileItem are equal.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ProfileItem a,
    ProfileItem b
)
Visual Basic
Public Shared Operator = ( _
    a As ProfileItem, _
    b As ProfileItem _
) As Boolean

Parameters

a
Type: ININ.IceLib.Connection.Extensions..::..ProfileItem
The first ProfileItem to compare.
b
Type: ININ.IceLib.Connection.Extensions..::..ProfileItem
The second ProfileItem to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


Inequality Operator

[image]

IceLib Technical Reference
ProfileItem..::..Inequality Operator
ProfileItem Class See Also Send Feedback
Determines whether two instances of ProfileItem are not equal.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ProfileItem a,
    ProfileItem b
)
Visual Basic
Public Shared Operator <> ( _
    a As ProfileItem, _
    b As ProfileItem _
) As Boolean

Parameters

a
Type: ININ.IceLib.Connection.Extensions..::..ProfileItem
The first ProfileItem to compare.
b
Type: ININ.IceLib.Connection.Extensions..::..ProfileItem
The second ProfileItem to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


ProfileItem Properties

[image] [image]

IceLib Technical Reference
ProfileItem Properties
ProfileItem Class See Also Send Feedback

The ProfileItem type exposes the following members.

Properties

 | Name | Description
Public property | IsPlainTextValue | Gets a value indicating whether this profile item is stored with a plain text value.
Public property | Key | Gets the key.
Public property | NamespacePath | Gets the namespace path.
Public property | Value | Gets the value.

See Also

ProfileItem Class
ININ.IceLib.Connection.Extensions Namespace


IsPlainTextValue Property

[image]

IceLib Technical Reference
ProfileItem..::..IsPlainTextValue Property
ProfileItem Class See Also Send Feedback
Gets a value indicating whether this profile item is stored with a plain text value.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPlainTextValue { get; }
Visual Basic
Public ReadOnly Property IsPlainTextValue As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this profile item is stored with a plain text value; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Profile items that are saved with a plain text value means that the Value object property can be safely casted to a String. This is controlled by using the SetProfileItem(String, String, Object) method (in which case, this value would be falseFalsefalsefalse (False in Visual Basic)) or with the SetProfileItem(String, String, String) method (in which case this value would be trueTruetruetrue (True in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


Key Property

[image]

IceLib Technical Reference
ProfileItem..::..Key Property
ProfileItem Class See Also Send Feedback
Gets the key.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Key { get; private set; }
Visual Basic
Public Property Key As String
    Get
    Private Set

Field Value

The key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


NamespacePath Property

[image]

IceLib Technical Reference
ProfileItem..::..NamespacePath Property
ProfileItem Class See Also Send Feedback
Gets the namespace path.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string NamespacePath { get; private set; }
Visual Basic
Public Property NamespacePath As String
    Get
    Private Set

Field Value

The namespace path.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


Value Property

[image]

IceLib Technical Reference
ProfileItem..::..Value Property
ProfileItem Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Value { get; private set; }
Visual Basic
Public Property Value As Object
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ProfileItem Class
ProfileItem Members
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Class

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Class
Members See Also Send Feedback
Passed to a Session in order to authenticate an Interaction Center user that is creating a session on behalf of another Interaction Center user (through windows authentication).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProxyAlternateWindowsAuthSettings : AuthSettings
Visual Basic
Public Class ProxyAlternateWindowsAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.

The ProxyAlternateWindowsAuthSettings object is used to specify Interaction Center proxy user authentication settings. This is used when alternate windows credentials should be used to authenticate the proxy user requesting a Session on behalf of another Interaction Center user. In order to do proxy logins the proxy user must have the "Proxy Logins" right set in Interaction Administrator.

The ProxyAlternateWindowsAuthSettings object can be used with the SessionWatch object to supply the StationSettings and SessionSettings arguments to the Connect method of the Session object.

Note
In 2.4 SU 27 and beyond the server parameter UsersWithProxyLoginRight is used to set the list of users that have rights to perform proxy logins via this class. The value for this parameter should contain a '|' delimited list of user IDs. However, in 3.0 and beyond the logged in user must have a specific "Proxy Logins" Access Control right configured on their IC User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control settings.

Examples

The following example shows how to monitor for sessions created by other users and then how to create a proxy connection to the IC server for another user, based on the authentication credentials of a special "elevated rights" user.
CopyC#
private void StartSessionWatch()
{
    // For this example, the focus is on watching for sessions created by a particular target User, then creating a proxy connection as
    // if we were that target User, but authenticated using a special "elevated rights" user's credentials.  This is a model used by some
    // server-side integrations, where the server-side component connects as the single "elevated rights" user and can then perform
    // operations on behalf of other users in the system.

    // We'll skip over creation of this server-side application's Session.
    // See other examples for basic details on establishing a connection with the server.
    Session session = CreateSessionForElevatedRightsUser();

    // For this example, we create a "session watch" to monitor for other applications/users that are connecting to the server.
    // Alternatively, a "proxy login" could be create for a user that was obtained based on some other application logic.
    SessionWatch sessionWatch = new SessionWatch(session);

    // Register the event handlers for watched session changes.
    sessionWatch.SessionWatchedUserAdded += SessionWatchedUserAdded;
    sessionWatch.SessionWatchedUserRemoved += SessionWatchedUserRemoved;

    // A session watch can watch for sessions for a given IC User, for an IC Station, or for a Machine.
    // For this example, we'll assume that a particular IC User is to be watched, based on external application needs.
    string targetIcUserId = "<target user ID>";

    SessionWatchId[] sessionsToWatch = new SessionWatchId[]
    {
        new SessionWatchId(SessionWatchType.User, targetIcUserId)
    };

    // Start monitoring for watched session changes for the specified criteria.
    ReadOnlyCollection<SessionWatchSettings> watchSettings = sessionWatch.StartWatching(sessionsToWatch);

    // The result contains any existing connected sessions that match the session watch criteria.
    // The SessionWatchedUser* events will be invoked as matching sessions are connected/disconnected.
    foreach (SessionWatchSettings setting in watchSettings)
    {
        // For this example, we plan on creating a proxy connection on behalf of the target user.
        EstablishProxyConnectionToSession(setting.UserName,
                                          setting.SessionSettings,
                                          session.GetHostSettings(),
                                          setting.StationSettings);
    }
}

private void EstablishProxyConnectionToSession(string targetUserId,
                                               SessionSettings sessionSettings,
                                               HostSettings hostSettings,
                                               StationSettings stationSettings)
{
    // Here we assume that the current windows account under which this application is running is the one associated with
    // the elevated rights user.
    //
    // Note that the IC user that is used to "vouch for" targetUserId's login must have "elevated rights" that allow it to serve
    // as a proxy for the authentication of other Interaction Center users.  The "elevated rights" user should be created
    // specifically for the server-side application's use, with very few rights other than the ability to proxy authentication.
    //
    // The "elevated rights" user must have a specific "Proxy Logins" Access Control right configured on their Interaction Center
    // User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control
    // settings.
    ProxyWindowsAuthSettings proxyAuthSettings = new ProxyWindowsAuthSettings(targetUserId, ProxyTargetUserType.ICUser);

    // Alternatively, explicit IC user credentials (i.e. user ID and password) can be specified, but then often those credentials
    // are persisted somewhere to configure the custom application, so this is usually less secure than using Windows-based
    // authentication.
    // string elevatedRightsIcUserId = "<elevated rights user ID>";
    // string elevatedRightsIcPassword = "<elevated rights user password>";
    // ProxyAuthSettings proxyAuthSettings = new ProxyAuthSettings(elevatedRightsIcUserId, elevatedRightsIcPassword, userName);

    // Next, we create a new, separate, Session for the connection of the proxy login.
    // This Session will have the "context" (e.g. rights) of the target User's account, not of the elevated rights user's account.
    //
    // What makes this a "proxy login" is that either ProxyWindowsAuthSettings or ProxyAuthSettings is used as the authSettings parameter.
    Session proxySession = new Session();

    // For this example, we intend to make calls on behalf of the user, using their station.
    // So, we re-use the same station that was part of the session watch result for the user being proxied.
    proxySession.Connect(sessionSettings, hostSettings, proxyAuthSettings, stationSettings);
}

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection.Extensions..::..ProxyAlternateWindowsAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace
SessionWatch
ProxyWindowsAuthSettings
ProxyAuthSettings


ProxyAlternateWindowsAuthSettings Members

[image] [image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Class Constructors Methods Properties See Also Send Feedback

The ProxyAlternateWindowsAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyAlternateWindowsAuthSettings()()()() | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, SecureString, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, SecureString) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, String) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, SecureString, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, String, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this AuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from AuthSettings.)

Properties

 | Name | Description
Public property | Domain | Gets or sets the domain associated with the UserName.
Public property | FullyQualifiedUserName | Gets the fully qualified user name.
Public property | Password | Sets the password.
Public property | Protocols | Gets or sets the Windows authentication protocols to use.
Public property | SecurePassword | Sets the password.
Public property | TargetUserName | Gets or sets the target user name associated with this instance.
Public property | TargetUserType | Gets or sets the target user type.
Public property | UserName | Gets or sets the name of the user.

See Also

ProxyAlternateWindowsAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Constructor

[image] [image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class.

Overload List

 | Name | Description
Public method | ProxyAlternateWindowsAuthSettings()()()() | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, SecureString, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, SecureString) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, String) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, SecureString, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.
Public method | ProxyAlternateWindowsAuthSettings(String, ProxyTargetUserType, String, String, String, WindowsAuthProtocols) | Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Constructor

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings()
Visual Basic
Public Sub New

Remarks

The properties of the object must be set before the object can be used to connect.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string userNameWithDomain,
    string password
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    userNameWithDomain As String, _
    password As String _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
userNameWithDomain
Type: System..::..String
The user name with the domain prefix in the form: "domain\user", or in the User Principle Name (UPN) format: "user@example.com". If no domain is specified, and the user name is not in the UPN format, the domain of the environment in which the IceLib application is running will be used.
password
Type: System..::..String
The user's password.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

The Protocols property will be set to WindowsAuthProtocols.All.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.
System..::..ArgumentException | userNameWithDomain is not formatted properly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, SecureString, WindowsAuthProtocols)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, SecureString, WindowsAuthProtocols)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string userNameWithDomain,
    SecureString password,
    WindowsAuthProtocols protocols
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    userNameWithDomain As String, _
    password As SecureString, _
    protocols As WindowsAuthProtocols _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
userNameWithDomain
Type: System..::..String
The user name with the domain prefix in the form: "domain\user", or in the User Principle Name (UPN) format: "user@example.com". If no domain is specified, and the user name is not in the UPN format, the domain of the environment in which the IceLib application is running will be used.
password
Type: System.Security..::..SecureString
The user's password.
protocols
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
The Windows authentication protocols to use.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

The Protocols property will be set to WindowsAuthProtocols.All.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.
System..::..ArgumentException | userNameWithDomain is not formatted properly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, WindowsAuthProtocols)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, WindowsAuthProtocols)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class given a combined domain and user name, as well as a password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string userNameWithDomain,
    string password,
    WindowsAuthProtocols protocols
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    userNameWithDomain As String, _
    password As String, _
    protocols As WindowsAuthProtocols _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
userNameWithDomain
Type: System..::..String
The user name with the domain prefix in the form: "domain\user", or in the User Principle Name (UPN) format: "user@example.com". If no domain is specified, and the user name is not in the UPN format, the domain of the environment in which the IceLib application is running will be used.
password
Type: System..::..String
The user's password.
protocols
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
The Windows authentication protocols to use.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

The Protocols property will be set to WindowsAuthProtocols.All.

Examples

The following example shows how to create a connection to the IC server:
CopyC#
// The IceLib Session can be created once and used for the life of the process.
Session session = new Session();
// An event handler is usually added to monitor connection state changes.
session.ConnectionStateChanged += delegate { /* React to connection state changes. */ };

// The application name can be displayed in Interaction Supervisor and is used for diagnostic operations.
SessionSettings sessionSettings = new SessionSettings();
sessionSettings.ApplicationName = "<Custom Application Name>";

// Specify the server being connected to (which is usually the IC server name).
// (It can also be a DNS "A" record that refers to both IC servers in a switchover pair.)
HostEndpoint hostEndpoint = new HostEndpoint("<IC Server Name>");
HostSettings hostSettings = new HostSettings(hostEndpoint);

// There are many options for specifying user authentication information.
// (See the derived classes of ININ.IceLib.Connection.AuthSettings for more information.)
//
// The current windows user's windows authentication can be used (if the IC user is configured with NT credentials).
WindowsAuthSettings authSettings = new WindowsAuthSettings();
// Alternatively, IC authentication can be used.
ICAuthSettings icAuthSettings = new ICAuthSettings("<IC_User_LoginID>", "<IC_User_Password>");

// There are many options for specifying IC station information.
// (See the derived classes of ININ.IceLib.Connection.StationSettings for more information.)
//
// If the application does not require a Station login, a simple "stationless" connection can be used.
StationlessSettings stationSettings = new StationlessSettings();
// Alternatively, an IC station could be specified.
WorkstationSettings workstationSettings = new WorkstationSettings("<IC_StationID>", SupportedMedia.Call);
// Or, a dynamic remote number station could be specified.
RemoteNumberSettings remoteNumberSettings = new RemoteNumberSettings(SupportedMedia.Call, "555-555-5555", true);

// Note: Consider using the ConnectAsync method to avoid blocking the thread.
session.Connect(sessionSettings, hostSettings, authSettings, stationSettings);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.
System..::..ArgumentException | userNameWithDomain is not formatted properly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace
ININ.IceLib.Connection..::..Session
ININ.IceLib.Connection..::..SessionSettings
ININ.IceLib.Connection..::..StationSettings
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection..::..HostSettings


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, SecureString)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, SecureString)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string domainName,
    string userName,
    SecureString password
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    domainName As String, _
    userName As String, _
    password As SecureString _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
domainName
Type: System..::..String
Name of the domain to which the user belongs.
userName
Type: System..::..String
Name of the Windows user.
password
Type: System.Security..::..SecureString
The password.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, String)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, String)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string domainName,
    string userName,
    string password
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    domainName As String, _
    userName As String, _
    password As String _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
domainName
Type: System..::..String
Name of the domain to which the user belongs.
userName
Type: System..::..String
Name of the Windows user.
password
Type: System..::..String
The password.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, SecureString, WindowsAuthProtocols)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, SecureString, WindowsAuthProtocols)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string domainName,
    string userName,
    SecureString password,
    WindowsAuthProtocols protocols
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    domainName As String, _
    userName As String, _
    password As SecureString, _
    protocols As WindowsAuthProtocols _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
domainName
Type: System..::..String
Name of the domain to which the user belongs.
userName
Type: System..::..String
Name of the Windows user.
password
Type: System.Security..::..SecureString
The password.
protocols
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
The Windows authentication protocols to use.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, String, WindowsAuthProtocols)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Constructor (String, ProxyTargetUserType, String, String, String, WindowsAuthProtocols)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAlternateWindowsAuthSettings class and populates the properties from the given parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAlternateWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType,
    string domainName,
    string userName,
    string password,
    WindowsAuthProtocols protocols
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType, _
    domainName As String, _
    userName As String, _
    password As String, _
    protocols As WindowsAuthProtocols _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.
domainName
Type: System..::..String
Name of the domain to which the user belongs.
userName
Type: System..::..String
Name of the Windows user.
password
Type: System..::..String
The password.
protocols
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
The Windows authentication protocols to use.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ProxyAlternateWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Methods

[image] [image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Methods
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback

The ProxyAlternateWindowsAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this AuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from AuthSettings.)

See Also

ProxyAlternateWindowsAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


Clone Method

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..Clone Method
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Returns an exact copy of this AuthSettings object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new AuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..Dispose Method
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Releases all resources used by the AuthSettings.

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..Dispose Method (Boolean)
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
Dispose Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAlternateWindowsAuthSettings Properties

[image] [image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings Properties
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback

The ProxyAlternateWindowsAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | Domain | Gets or sets the domain associated with the UserName.
Public property | FullyQualifiedUserName | Gets the fully qualified user name.
Public property | Password | Sets the password.
Public property | Protocols | Gets or sets the Windows authentication protocols to use.
Public property | SecurePassword | Sets the password.
Public property | TargetUserName | Gets or sets the target user name associated with this instance.
Public property | TargetUserType | Gets or sets the target user type.
Public property | UserName | Gets or sets the name of the user.

See Also

ProxyAlternateWindowsAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


Domain Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..Domain Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the domain associated with the UserName.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Domain { get; set; }
Visual Basic
Public Property Domain As String
    Get
    Set

Field Value

The domain.

Remarks

If UserName is in the User Principle Name (UPN) format, this value may be an empty string.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


FullyQualifiedUserName Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..FullyQualifiedUserName Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Gets the fully qualified user name.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FullyQualifiedUserName { get; }
Visual Basic
Public ReadOnly Property FullyQualifiedUserName As String
    Get

Remarks

If a domain was specified, the result will be in the format "Domain\UserName". If a User Principal Name (UPN) was specified, the result will be the UPN only (for example, "user@example.com").

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


Password Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..Password Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Sets the password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Password { internal get; set; }
Visual Basic
Public Property Password As String
    Friend Get
    Set

Field Value

The password.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


Protocols Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..Protocols Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the Windows authentication protocols to use.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowsAuthProtocols Protocols { get; set; }
Visual Basic
Public Property Protocols As WindowsAuthProtocols
    Get
    Set

Field Value

Flags specifying protocols to use.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | An invalid value was specified as part of the protocol flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


SecurePassword Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..SecurePassword Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Sets the password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureString SecurePassword { internal get; set; }
Visual Basic
Public Property SecurePassword As SecureString
    Friend Get
    Set

Field Value

The password.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


TargetUserName Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..TargetUserName Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the target user name associated with this instance.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TargetUserName { get; set; }
Visual Basic
Public Property TargetUserName As String
    Get
    Set

Field Value

The target user name.

Remarks

When TargetUserType is WindowsUser, the value should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Value must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


TargetUserType Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..TargetUserType Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the target user type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyTargetUserType TargetUserType { get; set; }
Visual Basic
Public Property TargetUserType As ProxyTargetUserType
    Get
    Set

Field Value

The target user type.

Remarks

When setting this to WindowsUser, the value of TargetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified protocols is not from the ProxyTargetUserType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


UserName Property

[image]

IceLib Technical Reference
ProxyAlternateWindowsAuthSettings..::..UserName Property
ProxyAlternateWindowsAuthSettings Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

Field Value

The name of the user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ProxyAlternateWindowsAuthSettings Class
ProxyAlternateWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Class

[image]

IceLib Technical Reference
ProxyAuthSettings Class
Members See Also Send Feedback
Passed to a Session in order to authenticate an Interaction Center user that is creating a session on behalf of another Interaction Center user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProxyAuthSettings : AuthSettings
Visual Basic
Public Class ProxyAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.

The ProxyAuthSettings object is used to specify Interaction Center proxy user authentication settings. This is used when an IC user name and password should be used to authenticate the proxy user requesting a Session on behalf of another Interaction Center user. In order to do proxy logins the proxy user must have the "Proxy Logins" right set in Interaction Administrator.

The ProxyAuthSettings object can be used with the SessionWatch object to supply the StationSettings and SessionSettings arguments to the Connect method of the Session object.

Note
In 2.4 SU 27 and beyond the server parameter UsersWithProxyLoginRight is used to set the list of users that have rights to perform proxy logins via this class. The value for this parameter should contain a '|' delimited list of user IDs. However, in 3.0 and beyond the logged in user must have a specific "Proxy Logins" Access Control right configured on their IC User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control settings.

Examples

The following example shows how to monitor for sessions created by other users and then how to create a proxy connection to the IC server for another user, based on the authentication credentials of a special "elevated rights" user.
CopyC#
private void StartSessionWatch()
{
    // For this example, the focus is on watching for sessions created by a particular target User, then creating a proxy connection as
    // if we were that target User, but authenticated using a special "elevated rights" user's credentials.  This is a model used by some
    // server-side integrations, where the server-side component connects as the single "elevated rights" user and can then perform
    // operations on behalf of other users in the system.

    // We'll skip over creation of this server-side application's Session.
    // See other examples for basic details on establishing a connection with the server.
    Session session = CreateSessionForElevatedRightsUser();

    // For this example, we create a "session watch" to monitor for other applications/users that are connecting to the server.
    // Alternatively, a "proxy login" could be create for a user that was obtained based on some other application logic.
    SessionWatch sessionWatch = new SessionWatch(session);

    // Register the event handlers for watched session changes.
    sessionWatch.SessionWatchedUserAdded += SessionWatchedUserAdded;
    sessionWatch.SessionWatchedUserRemoved += SessionWatchedUserRemoved;

    // A session watch can watch for sessions for a given IC User, for an IC Station, or for a Machine.
    // For this example, we'll assume that a particular IC User is to be watched, based on external application needs.
    string targetIcUserId = "<target user ID>";

    SessionWatchId[] sessionsToWatch = new SessionWatchId[]
    {
        new SessionWatchId(SessionWatchType.User, targetIcUserId)
    };

    // Start monitoring for watched session changes for the specified criteria.
    ReadOnlyCollection<SessionWatchSettings> watchSettings = sessionWatch.StartWatching(sessionsToWatch);

    // The result contains any existing connected sessions that match the session watch criteria.
    // The SessionWatchedUser* events will be invoked as matching sessions are connected/disconnected.
    foreach (SessionWatchSettings setting in watchSettings)
    {
        // For this example, we plan on creating a proxy connection on behalf of the target user.
        EstablishProxyConnectionToSession(setting.UserName,
                                          setting.SessionSettings,
                                          session.GetHostSettings(),
                                          setting.StationSettings);
    }
}

private void EstablishProxyConnectionToSession(string targetUserId,
                                               SessionSettings sessionSettings,
                                               HostSettings hostSettings,
                                               StationSettings stationSettings)
{
    // Here we assume that the current windows account under which this application is running is the one associated with
    // the elevated rights user.
    //
    // Note that the IC user that is used to "vouch for" targetUserId's login must have "elevated rights" that allow it to serve
    // as a proxy for the authentication of other Interaction Center users.  The "elevated rights" user should be created
    // specifically for the server-side application's use, with very few rights other than the ability to proxy authentication.
    //
    // The "elevated rights" user must have a specific "Proxy Logins" Access Control right configured on their Interaction Center
    // User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control
    // settings.
    ProxyWindowsAuthSettings proxyAuthSettings = new ProxyWindowsAuthSettings(targetUserId, ProxyTargetUserType.ICUser);

    // Alternatively, explicit IC user credentials (i.e. user ID and password) can be specified, but then often those credentials
    // are persisted somewhere to configure the custom application, so this is usually less secure than using Windows-based
    // authentication.
    // string elevatedRightsIcUserId = "<elevated rights user ID>";
    // string elevatedRightsIcPassword = "<elevated rights user password>";
    // ProxyAuthSettings proxyAuthSettings = new ProxyAuthSettings(elevatedRightsIcUserId, elevatedRightsIcPassword, userName);

    // Next, we create a new, separate, Session for the connection of the proxy login.
    // This Session will have the "context" (e.g. rights) of the target User's account, not of the elevated rights user's account.
    //
    // What makes this a "proxy login" is that either ProxyWindowsAuthSettings or ProxyAuthSettings is used as the authSettings parameter.
    Session proxySession = new Session();

    // For this example, we intend to make calls on behalf of the user, using their station.
    // So, we re-use the same station that was part of the session watch result for the user being proxied.
    proxySession.Connect(sessionSettings, hostSettings, proxyAuthSettings, stationSettings);
}

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection.Extensions..::..ProxyAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace
SessionWatch
ProxyWindowsAuthSettings
ProxyAuthSettings


ProxyAuthSettings Members

[image] [image]

IceLib Technical Reference
ProxyAuthSettings Members
ProxyAuthSettings Class Constructors Methods Properties See Also Send Feedback

The ProxyAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyAuthSettings()()()() | Initializes a new instance of the ProxyAuthSettings class.
Public method | ProxyAuthSettings(String, SecureString, String) | Initializes a new instance of the ProxyAuthSettings class with default settings.
Public method | ProxyAuthSettings(String, String, String) | Initializes a new instance of the ProxyAuthSettings class with default settings.
Public method | ProxyAuthSettings(String, SecureString, String, ProxyTargetUserType) | Initializes a new instance of the ProxyAuthSettings class.
Public method | ProxyAuthSettings(String, String, String, ProxyTargetUserType) | Initializes a new instance of the ProxyAuthSettings class.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this ProxyAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Inherited from AuthSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from AuthSettings.)

Properties

 | Name | Description
Public property | ProxyPassword | Sets the proxy password.
Public property | ProxyUserName | Gets or sets the name of the proxy user.
Public property | SecureProxyPassword | Sets the proxy password.
Public property | TargetUserName | Gets or sets the target user name.
Public property | TargetUserType | Gets or sets the target user type.

See Also

ProxyAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Constructor

[image] [image]

IceLib Technical Reference
ProxyAuthSettings Constructor
ProxyAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAuthSettings class.

Overload List

 | Name | Description
Public method | ProxyAuthSettings()()()() | Initializes a new instance of the ProxyAuthSettings class.
Public method | ProxyAuthSettings(String, SecureString, String) | Initializes a new instance of the ProxyAuthSettings class with default settings.
Public method | ProxyAuthSettings(String, String, String) | Initializes a new instance of the ProxyAuthSettings class with default settings.
Public method | ProxyAuthSettings(String, SecureString, String, ProxyTargetUserType) | Initializes a new instance of the ProxyAuthSettings class.
Public method | ProxyAuthSettings(String, String, String, ProxyTargetUserType) | Initializes a new instance of the ProxyAuthSettings class.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Constructor

[image]

IceLib Technical Reference
ProxyAuthSettings Constructor
ProxyAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAuthSettings class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAuthSettings()
Visual Basic
Public Sub New

Remarks

This constructor is called by derived class constructors to initialize state in this type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ProxyAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Constructor (String, SecureString, String)

[image]

IceLib Technical Reference
ProxyAuthSettings Constructor (String, SecureString, String)
ProxyAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAuthSettings class with default settings.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAuthSettings(
    string proxyUserName,
    SecureString proxyPassword,
    string targetUserName
)
Visual Basic
Public Sub New ( _
    proxyUserName As String, _
    proxyPassword As SecureString, _
    targetUserName As String _
)

Parameters

proxyUserName
Type: System..::..String
Name of the proxy user.
proxyPassword
Type: System.Security..::..SecureString
The proxy password.
targetUserName
Type: System..::..String
Name of the target user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ProxyAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Constructor (String, String, String)

[image]

IceLib Technical Reference
ProxyAuthSettings Constructor (String, String, String)
ProxyAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAuthSettings class with default settings.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAuthSettings(
    string proxyUserName,
    string proxyPassword,
    string targetUserName
)
Visual Basic
Public Sub New ( _
    proxyUserName As String, _
    proxyPassword As String, _
    targetUserName As String _
)

Parameters

proxyUserName
Type: System..::..String
Name of the proxy user.
proxyPassword
Type: System..::..String
The proxy password.
targetUserName
Type: System..::..String
Name of the target user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ProxyAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Constructor (String, SecureString, String, ProxyTargetUserType)

[image]

IceLib Technical Reference
ProxyAuthSettings Constructor (String, SecureString, String, ProxyTargetUserType)
ProxyAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAuthSettings class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAuthSettings(
    string proxyUserName,
    SecureString proxyPassword,
    string targetUserName,
    ProxyTargetUserType targetUserType
)
Visual Basic
Public Sub New ( _
    proxyUserName As String, _
    proxyPassword As SecureString, _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType _
)

Parameters

proxyUserName
Type: System..::..String
Name of the proxy user.
proxyPassword
Type: System.Security..::..SecureString
The proxy password.
targetUserName
Type: System..::..String
Name of the target user.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The target user type.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified targetUserType is not from the ProxyTargetUserType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ProxyAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Constructor (String, String, String, ProxyTargetUserType)

[image]

IceLib Technical Reference
ProxyAuthSettings Constructor (String, String, String, ProxyTargetUserType)
ProxyAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyAuthSettings class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyAuthSettings(
    string proxyUserName,
    string proxyPassword,
    string targetUserName,
    ProxyTargetUserType targetUserType
)
Visual Basic
Public Sub New ( _
    proxyUserName As String, _
    proxyPassword As String, _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType _
)

Parameters

proxyUserName
Type: System..::..String
Name of the proxy user.
proxyPassword
Type: System..::..String
The proxy password.
targetUserName
Type: System..::..String
Name of the target user.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The target user type.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified targetUserType is not from the ProxyTargetUserType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ProxyAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Methods

[image] [image]

IceLib Technical Reference
ProxyAuthSettings Methods
ProxyAuthSettings Class See Also Send Feedback

The ProxyAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this ProxyAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Inherited from AuthSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Inherited from AuthSettings.)

See Also

ProxyAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


Clone Method

[image]

IceLib Technical Reference
ProxyAuthSettings..::..Clone Method
ProxyAuthSettings Class See Also Send Feedback
Returns an exact copy of this ProxyAuthSettings object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new ProxyAuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
ProxyAuthSettings..::..ToString Method
ProxyAuthSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyAuthSettings Properties

[image] [image]

IceLib Technical Reference
ProxyAuthSettings Properties
ProxyAuthSettings Class See Also Send Feedback

The ProxyAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | ProxyPassword | Sets the proxy password.
Public property | ProxyUserName | Gets or sets the name of the proxy user.
Public property | SecureProxyPassword | Sets the proxy password.
Public property | TargetUserName | Gets or sets the target user name.
Public property | TargetUserType | Gets or sets the target user type.

See Also

ProxyAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


ProxyPassword Property

[image]

IceLib Technical Reference
ProxyAuthSettings..::..ProxyPassword Property
ProxyAuthSettings Class See Also Send Feedback
Sets the proxy password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProxyPassword { internal get; set; }
Visual Basic
Public Property ProxyPassword As String
    Friend Get
    Set

Field Value

The proxy password.

Remarks

Note: There is intentionally no public getter for this property.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Value must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyUserName Property

[image]

IceLib Technical Reference
ProxyAuthSettings..::..ProxyUserName Property
ProxyAuthSettings Class See Also Send Feedback
Gets or sets the name of the proxy user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProxyUserName { get; set; }
Visual Basic
Public Property ProxyUserName As String
    Get
    Set

Field Value

The name of the proxy user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Value must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


SecureProxyPassword Property

[image]

IceLib Technical Reference
ProxyAuthSettings..::..SecureProxyPassword Property
ProxyAuthSettings Class See Also Send Feedback
Sets the proxy password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureString SecureProxyPassword { internal get; set; }
Visual Basic
Public Property SecureProxyPassword As SecureString
    Friend Get
    Set

Field Value

The proxy password.

Remarks

Note: There is intentionally no public getter for this property.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Value must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


TargetUserName Property

[image]

IceLib Technical Reference
ProxyAuthSettings..::..TargetUserName Property
ProxyAuthSettings Class See Also Send Feedback
Gets or sets the target user name.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TargetUserName { get; set; }
Visual Basic
Public Property TargetUserName As String
    Get
    Set

Exceptions

Exception | Condition
System..::..ArgumentNullException | Value must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


TargetUserType Property

[image]

IceLib Technical Reference
ProxyAuthSettings..::..TargetUserType Property
ProxyAuthSettings Class See Also Send Feedback
Gets or sets the target user type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyTargetUserType TargetUserType { get; set; }
Visual Basic
Public Property TargetUserType As ProxyTargetUserType
    Get
    Set

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | value must be of type ProxyTargetUserType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyAuthSettings Class
ProxyAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyTargetUserType Enumeration

[image]

IceLib Technical Reference
ProxyTargetUserType Enumeration
See Also Send Feedback
Used to specify if the target user is an IC user or a Windows user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ProxyTargetUserType
Visual Basic
Public Enumeration ProxyTargetUserType

Members

Member name | Value | Description
ICUser | 0 | IC user target type.
WindowsUser | 1 | Windows user target type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Class

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings Class
Members See Also Send Feedback
Passed to a Session in order to authenticate an Interaction Center user (through windows authentication) that is creating a session on behalf of another Interaction Center user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProxyWindowsAuthSettings : AuthSettings
Visual Basic
Public Class ProxyWindowsAuthSettings _
    Inherits AuthSettings

Remarks

Note
For more information on authenticating with IceLib see Authentication.

The ProxyWindowsAuthSettings object is used to specify Interaction Center proxy user authentication settings. This is used when windows credentials should be used to authenticate the proxy user requesting a Session on behalf of another Interaction Center user. In order to do proxy logins the proxy user must have the "Proxy Logins" right set in Interaction Administrator.

The ProxyWindowsAuthSettings object can be used with the SessionWatch object to supply the StationSettings and SessionSettings arguments to the Connect method of the Session object.

Note
In 2.4 SU 27 and beyond the server parameter UsersWithProxyLoginRight is used to set the list of users that have rights to perform proxy logins via this class. The value for this parameter should contain a '|' delimited list of user IDs. However, in 3.0 and beyond the logged in user must have a specific "Proxy Logins" Access Control right configured on their IC User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control settings.

Examples

The following example shows how to monitor for sessions created by other users and then how to create a proxy connection to the IC server for another user, based on the authentication credentials of a special "elevated rights" user.
CopyC#
private void StartSessionWatch()
{
    // For this example, the focus is on watching for sessions created by a particular target User, then creating a proxy connection as
    // if we were that target User, but authenticated using a special "elevated rights" user's credentials.  This is a model used by some
    // server-side integrations, where the server-side component connects as the single "elevated rights" user and can then perform
    // operations on behalf of other users in the system.

    // We'll skip over creation of this server-side application's Session.
    // See other examples for basic details on establishing a connection with the server.
    Session session = CreateSessionForElevatedRightsUser();

    // For this example, we create a "session watch" to monitor for other applications/users that are connecting to the server.
    // Alternatively, a "proxy login" could be create for a user that was obtained based on some other application logic.
    SessionWatch sessionWatch = new SessionWatch(session);

    // Register the event handlers for watched session changes.
    sessionWatch.SessionWatchedUserAdded += SessionWatchedUserAdded;
    sessionWatch.SessionWatchedUserRemoved += SessionWatchedUserRemoved;

    // A session watch can watch for sessions for a given IC User, for an IC Station, or for a Machine.
    // For this example, we'll assume that a particular IC User is to be watched, based on external application needs.
    string targetIcUserId = "<target user ID>";

    SessionWatchId[] sessionsToWatch = new SessionWatchId[]
    {
        new SessionWatchId(SessionWatchType.User, targetIcUserId)
    };

    // Start monitoring for watched session changes for the specified criteria.
    ReadOnlyCollection<SessionWatchSettings> watchSettings = sessionWatch.StartWatching(sessionsToWatch);

    // The result contains any existing connected sessions that match the session watch criteria.
    // The SessionWatchedUser* events will be invoked as matching sessions are connected/disconnected.
    foreach (SessionWatchSettings setting in watchSettings)
    {
        // For this example, we plan on creating a proxy connection on behalf of the target user.
        EstablishProxyConnectionToSession(setting.UserName,
                                          setting.SessionSettings,
                                          session.GetHostSettings(),
                                          setting.StationSettings);
    }
}

private void EstablishProxyConnectionToSession(string targetUserId,
                                               SessionSettings sessionSettings,
                                               HostSettings hostSettings,
                                               StationSettings stationSettings)
{
    // Here we assume that the current windows account under which this application is running is the one associated with
    // the elevated rights user.
    //
    // Note that the IC user that is used to "vouch for" targetUserId's login must have "elevated rights" that allow it to serve
    // as a proxy for the authentication of other Interaction Center users.  The "elevated rights" user should be created
    // specifically for the server-side application's use, with very few rights other than the ability to proxy authentication.
    //
    // The "elevated rights" user must have a specific "Proxy Logins" Access Control right configured on their Interaction Center
    // User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control
    // settings.
    ProxyWindowsAuthSettings proxyAuthSettings = new ProxyWindowsAuthSettings(targetUserId, ProxyTargetUserType.ICUser);

    // Alternatively, explicit IC user credentials (i.e. user ID and password) can be specified, but then often those credentials
    // are persisted somewhere to configure the custom application, so this is usually less secure than using Windows-based
    // authentication.
    // string elevatedRightsIcUserId = "<elevated rights user ID>";
    // string elevatedRightsIcPassword = "<elevated rights user password>";
    // ProxyAuthSettings proxyAuthSettings = new ProxyAuthSettings(elevatedRightsIcUserId, elevatedRightsIcPassword, userName);

    // Next, we create a new, separate, Session for the connection of the proxy login.
    // This Session will have the "context" (e.g. rights) of the target User's account, not of the elevated rights user's account.
    //
    // What makes this a "proxy login" is that either ProxyWindowsAuthSettings or ProxyAuthSettings is used as the authSettings parameter.
    Session proxySession = new Session();

    // For this example, we intend to make calls on behalf of the user, using their station.
    // So, we re-use the same station that was part of the session watch result for the user being proxied.
    proxySession.Connect(sessionSettings, hostSettings, proxyAuthSettings, stationSettings);
}

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection..::..AuthSettings
ININ.IceLib.Connection.Extensions..::..ProxyWindowsAuthSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace
SessionWatch
ProxyWindowsAuthSettings
ProxyAuthSettings


ProxyWindowsAuthSettings Members

[image] [image]

IceLib Technical Reference
ProxyWindowsAuthSettings Members
ProxyWindowsAuthSettings Class Constructors Methods Properties See Also Send Feedback

The ProxyWindowsAuthSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ProxyWindowsAuthSettings()()()() | Initializes a new instance of the ProxyWindowsAuthSettings class with default settings.
Public method | ProxyWindowsAuthSettings(String) | Initializes a new instance of the ProxyWindowsAuthSettings class with default settings specifying the target user name.
Public method | ProxyWindowsAuthSettings(String, ProxyTargetUserType) | Initializes a new instance of the ProxyWindowsAuthSettings class specifying the target user name and target user type.
Public method | ProxyWindowsAuthSettings(WindowsAuthProtocols, String) | Initializes a new instance of the ProxyWindowsAuthSettings class, designating which protocols should be used as well as the target user name.
Public method | ProxyWindowsAuthSettings(WindowsAuthProtocols, String, ProxyTargetUserType) | Initializes a new instance of the ProxyWindowsAuthSettings class, designating which protocols should be used as well as the target user name and type of target user.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this ProxyWindowsAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

Properties

 | Name | Description
Public property | ProtocolFlags | Gets or sets the protocol flags.
Public property | ProxyUserName | Gets the Windows user name associated with this instance.
Public property | TargetUserName | Gets or sets the target user name associated with this instance.
Public property | TargetUserType | Gets or sets the target user type.

See Also

ProxyWindowsAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Constructor

[image] [image]

IceLib Technical Reference
ProxyWindowsAuthSettings Constructor
ProxyWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyWindowsAuthSettings class with default settings.

Overload List

 | Name | Description
Public method | ProxyWindowsAuthSettings()()()() | Initializes a new instance of the ProxyWindowsAuthSettings class with default settings.
Public method | ProxyWindowsAuthSettings(String) | Initializes a new instance of the ProxyWindowsAuthSettings class with default settings specifying the target user name.
Public method | ProxyWindowsAuthSettings(String, ProxyTargetUserType) | Initializes a new instance of the ProxyWindowsAuthSettings class specifying the target user name and target user type.
Public method | ProxyWindowsAuthSettings(WindowsAuthProtocols, String) | Initializes a new instance of the ProxyWindowsAuthSettings class, designating which protocols should be used as well as the target user name.
Public method | ProxyWindowsAuthSettings(WindowsAuthProtocols, String, ProxyTargetUserType) | Initializes a new instance of the ProxyWindowsAuthSettings class, designating which protocols should be used as well as the target user name and type of target user.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Constructor

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings Constructor
ProxyWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyWindowsAuthSettings class with default settings.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyWindowsAuthSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ProxyWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Constructor (String)

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings Constructor (String)
ProxyWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyWindowsAuthSettings class with default settings specifying the target user name.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyWindowsAuthSettings(
    string targetUserName
)
Visual Basic
Public Sub New ( _
    targetUserName As String _
)

Parameters

targetUserName
Type: System..::..String
The target user name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ProxyWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Constructor (String, ProxyTargetUserType)

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings Constructor (String, ProxyTargetUserType)
ProxyWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyWindowsAuthSettings class specifying the target user name and target user type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyWindowsAuthSettings(
    string targetUserName,
    ProxyTargetUserType targetUserType
)
Visual Basic
Public Sub New ( _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType _
)

Parameters

targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified targetUserType is not from the ProxyTargetUserType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ProxyWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Constructor (WindowsAuthProtocols, String)

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings Constructor (WindowsAuthProtocols, String)
ProxyWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyWindowsAuthSettings class, designating which protocols should be used as well as the target user name.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyWindowsAuthSettings(
    WindowsAuthProtocols protocolFlags,
    string targetUserName
)
Visual Basic
Public Sub New ( _
    protocolFlags As WindowsAuthProtocols, _
    targetUserName As String _
)

Parameters

protocolFlags
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
Flags to indicate which protocols should be used.
targetUserName
Type: System..::..String
The target user name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified protocols is not from the WindowsAuthProtocols enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ProxyWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Constructor (WindowsAuthProtocols, String, ProxyTargetUserType)

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings Constructor (WindowsAuthProtocols, String, ProxyTargetUserType)
ProxyWindowsAuthSettings Class See Also Send Feedback
Initializes a new instance of the ProxyWindowsAuthSettings class, designating which protocols should be used as well as the target user name and type of target user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyWindowsAuthSettings(
    WindowsAuthProtocols protocolFlags,
    string targetUserName,
    ProxyTargetUserType targetUserType
)
Visual Basic
Public Sub New ( _
    protocolFlags As WindowsAuthProtocols, _
    targetUserName As String, _
    targetUserType As ProxyTargetUserType _
)

Parameters

protocolFlags
Type: ININ.IceLib.Connection..::..WindowsAuthProtocols
Flags to indicate which protocols should be used.
targetUserName
Type: System..::..String
The target user name.
targetUserType
Type: ININ.IceLib.Connection.Extensions..::..ProxyTargetUserType
The type of user the target user is.

Remarks

When targetUserType is WindowsUser, targetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The specified protocols is not from the WindowsAuthProtocols enumeration.
System..::..ArgumentOutOfRangeException | The target user type is not from the ProxyTargetUserType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ProxyWindowsAuthSettings Overload
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Methods

[image] [image]

IceLib Technical Reference
ProxyWindowsAuthSettings Methods
ProxyWindowsAuthSettings Class See Also Send Feedback

The ProxyWindowsAuthSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns an exact copy of this ProxyWindowsAuthSettings object. (Overrides AuthSettings..::..Clone()()()().)
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | ToTrace | Returns obfuscated valued of PII fields when obfuscation is enabled in the logs (Overrides AuthSettings..::..ToTrace()()()().)

See Also

ProxyWindowsAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


Clone Method

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..Clone Method
ProxyWindowsAuthSettings Class See Also Send Feedback
Returns an exact copy of this ProxyWindowsAuthSettings object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override AuthSettings Clone()
Visual Basic
Public Overrides Function Clone As AuthSettings

Return Value

A new ProxyWindowsAuthSettings object that is a copy of this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..Dispose Method
ProxyWindowsAuthSettings Class See Also Send Feedback
Releases all resources used by the AuthSettings.

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the AuthSettings. (Inherited from AuthSettings.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources. (Overrides AuthSettings..::..Dispose(Boolean).)

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..Dispose Method (Boolean)
ProxyWindowsAuthSettings Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
Dispose Overload
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..ToString Method
ProxyWindowsAuthSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ToTrace Method

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..ToTrace Method
ProxyWindowsAuthSettings Class See Also Send Feedback
Returns obfuscated valued of PII fields when obfuscation is enabled in the logs

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToTrace()
Visual Basic
Public Overrides Function ToTrace As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyWindowsAuthSettings Properties

[image] [image]

IceLib Technical Reference
ProxyWindowsAuthSettings Properties
ProxyWindowsAuthSettings Class See Also Send Feedback

The ProxyWindowsAuthSettings type exposes the following members.

Properties

 | Name | Description
Public property | ProtocolFlags | Gets or sets the protocol flags.
Public property | ProxyUserName | Gets the Windows user name associated with this instance.
Public property | TargetUserName | Gets or sets the target user name associated with this instance.
Public property | TargetUserType | Gets or sets the target user type.

See Also

ProxyWindowsAuthSettings Class
ININ.IceLib.Connection.Extensions Namespace


ProtocolFlags Property

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..ProtocolFlags Property
ProxyWindowsAuthSettings Class See Also Send Feedback
Gets or sets the protocol flags.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowsAuthProtocols ProtocolFlags { get; set; }
Visual Basic
Public Property ProtocolFlags As WindowsAuthProtocols
    Get
    Set

Field Value

The protocol flags.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified protocols is not from the WindowsAuthProtocols enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


ProxyUserName Property

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..ProxyUserName Property
ProxyWindowsAuthSettings Class See Also Send Feedback
Gets the Windows user name associated with this instance.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProxyUserName { get; }
Visual Basic
Public ReadOnly Property ProxyUserName As String
    Get

Field Value

The windows user name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


TargetUserName Property

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..TargetUserName Property
ProxyWindowsAuthSettings Class See Also Send Feedback
Gets or sets the target user name associated with this instance.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TargetUserName { get; set; }
Visual Basic
Public Property TargetUserName As String
    Get
    Set

Field Value

The target user name.

Remarks

When TargetUserType is WindowsUser, the value should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Value must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


TargetUserType Property

[image]

IceLib Technical Reference
ProxyWindowsAuthSettings..::..TargetUserType Property
ProxyWindowsAuthSettings Class See Also Send Feedback
Gets or sets the target user type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProxyTargetUserType TargetUserType { get; set; }
Visual Basic
Public Property TargetUserType As ProxyTargetUserType
    Get
    Set

Field Value

The target user type.

Remarks

When setting this to WindowsUser, the value of TargetUserName should follow the format of domain\user.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified protocols is not from the ProxyTargetUserType enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ProxyWindowsAuthSettings Class
ProxyWindowsAuthSettings Members
ININ.IceLib.Connection.Extensions Namespace


RestrictCacheRefreshOptions Enumeration

[image]

IceLib Technical Reference
RestrictCacheRefreshOptions Enumeration
See Also Send Feedback
Represents the options for restricting custom profile cache refreshing for a CustomProfile.

Note: This enumeration is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum RestrictCacheRefreshOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration RestrictCacheRefreshOptions

Members

Member name | Value | Description
None | 0 | Represents an unset value.
NoRestrictions | 1 | When used to create a CustomProfile, this indicates that the custom profile cache will be refreshed when calling FlushChanges()()()() or FlushChangesAsync(AsyncCompletedEventHandler, Object). The custom profile cache will also be refreshed when calling GetProfileItem(String, String), GetProfileItemAsync(String, String, EventHandler<(Of <<'(GetProfileItemCompletedEventArgs>)>>), Object), GetNamespaceContents(String), and GetNamespaceContentsAsync(String, EventHandler<(Of <<'(GetNamespaceContentsCompletedEventArgs>)>>), Object), if the requested key was not found in the current custom profile cache data.
RestrictOnGetOperations | 2 | When used to create a CustomProfile, this indicates that once the custom profile data has been cached, the custom profile cache will only be refreshed on successful calls to FlushChanges()()()() or FlushChangesAsync(AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ININ.IceLib.Connection.Extensions Namespace


Security Class

[image]

IceLib Technical Reference
Security Class
Members See Also Send Feedback
Provides access to the Session user's password policy and allows for setting of the password.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Security
Visual Basic
Public Class Security

Remarks

Use this class to get the password policy for a user, or to set the user's password.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..Security

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Members
ININ.IceLib.Connection.Extensions Namespace


Security Members

[image] [image]

IceLib Technical Reference
Security Members
Security Class Constructors Methods Events See Also Send Feedback

The Security type exposes the following members.

Constructors

 | Name | Description
Public method | Security | Initializes a new instance of the Security class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPasswordPolicy | Gets the password policy for this session user.
Public method | GetPasswordPolicyAsync | Asynchronously gets the password policy for this session user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPassword | Sets the password for this session user.
Public method | SetPasswordAsync | Asynchronously sets the password for this session user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | PasswordEnteredNagPeriod | Raised when the session user's password enters the password nag period.
Public event | PasswordExpired | Raised when the session user's password expires.

See Also

Security Class
ININ.IceLib.Connection.Extensions Namespace


Security Constructor

[image]

IceLib Technical Reference
Security Constructor
Security Class See Also Send Feedback
Initializes a new instance of the Security class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Security(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


Security Methods

[image] [image]

IceLib Technical Reference
Security Methods
Security Class See Also Send Feedback

The Security type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPasswordPolicy | Gets the password policy for this session user.
Public method | GetPasswordPolicyAsync | Asynchronously gets the password policy for this session user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPassword | Sets the password for this session user.
Public method | SetPasswordAsync | Asynchronously sets the password for this session user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Security Class
ININ.IceLib.Connection.Extensions Namespace


GetPasswordPolicy Method

[image]

IceLib Technical Reference
Security..::..GetPasswordPolicy Method
Security Class See Also Send Feedback
Gets the password policy for this session user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PasswordPolicy GetPasswordPolicy()
Visual Basic
Public Function GetPasswordPolicy As PasswordPolicy

Return Value

The PasswordPolicy for this session user.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


GetPasswordPolicyAsync Method

[image]

IceLib Technical Reference
Security..::..GetPasswordPolicyAsync Method
Security Class See Also Send Feedback
Asynchronously gets the password policy for this session user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetPasswordPolicyAsync(
    EventHandler<PasswordPolicyAsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetPasswordPolicyAsync ( _
    completedCallback As EventHandler(Of PasswordPolicyAsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' PasswordPolicyAsyncCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


SetPassword Method

[image]

IceLib Technical Reference
Security..::..SetPassword Method
Security Class See Also Send Feedback
Sets the password for this session user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetPassword(
    string oldPassword,
    string newPassword
)
Visual Basic
Public Sub SetPassword ( _
    oldPassword As String, _
    newPassword As String _
)

Parameters

oldPassword
Type: System..::..String
The old password.
newPassword
Type: System..::..String
The new password.

Remarks

If the password cannot be set, an IceLibException containing the error message will be thrown.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | The password was unable to be set.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


SetPasswordAsync Method

[image]

IceLib Technical Reference
Security..::..SetPasswordAsync Method
Security Class See Also Send Feedback
Asynchronously sets the password for this session user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetPasswordAsync(
    string oldPassword,
    string newPassword,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetPasswordAsync ( _
    oldPassword As String, _
    newPassword As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

oldPassword
Type: System..::..String
The old password.
newPassword
Type: System..::..String
The new password.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

If the password cannot be set, an IceLibException containing the error message will be returned in the AsyncCompletedEventArgs.Error property.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


Security Events

[image] [image]

IceLib Technical Reference
Security Events
Security Class See Also Send Feedback

The Security type exposes the following members.

Events

 | Name | Description
Public event | PasswordEnteredNagPeriod | Raised when the session user's password enters the password nag period.
Public event | PasswordExpired | Raised when the session user's password expires.

See Also

Security Class
ININ.IceLib.Connection.Extensions Namespace


PasswordEnteredNagPeriod Event

[image]

IceLib Technical Reference
Security..::..PasswordEnteredNagPeriod Event
Security Class See Also Send Feedback
Raised when the session user's password enters the password nag period.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<PasswordEventArgs> PasswordEnteredNagPeriod
Visual Basic
Public Event PasswordEnteredNagPeriod As EventHandler(Of PasswordEventArgs)

Remarks

This event will only occur while the session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) and ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)
Note
All event handlers should be added before calling Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


PasswordExpired Event

[image]

IceLib Technical Reference
Security..::..PasswordExpired Event
Security Class See Also Send Feedback
Raised when the session user's password expires.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<PasswordEventArgs> PasswordExpired
Visual Basic
Public Event PasswordExpired As EventHandler(Of PasswordEventArgs)

Remarks

This event will only occur while the session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) and ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)
Note
All event handlers should be added before calling Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Security Class
Security Members
ININ.IceLib.Connection.Extensions Namespace


SendCompletedEventArgs Class

[image]

IceLib Technical Reference
SendCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SendServerRequest method of CustomNotification completedCallback delegate of CustomNotification.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SendCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class SendCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..SendCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SendCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SendCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
SendCompletedEventArgs Members
SendCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SendCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SendCompletedEventArgs | Initializes a new instance of the SendCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Response | Gets the response.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SendCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SendCompletedEventArgs Constructor

[image]

IceLib Technical Reference
SendCompletedEventArgs Constructor
SendCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the SendCompletedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SendCompletedEventArgs(
    CustomMessage message,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    message As CustomMessage, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

message
Type: ININ.IceLib.Connection.Extensions..::..CustomMessage
The message.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SendCompletedEventArgs Class
SendCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SendCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
SendCompletedEventArgs Methods
SendCompletedEventArgs Class See Also Send Feedback

The SendCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SendCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
SendCompletedEventArgs Properties
SendCompletedEventArgs Class See Also Send Feedback

The SendCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Response | Gets the response.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SendCompletedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


Response Property

[image]

IceLib Technical Reference
SendCompletedEventArgs..::..Response Property
SendCompletedEventArgs Class See Also Send Feedback
Gets the response.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomMessage Response { get; }
Visual Basic
Public ReadOnly Property Response As CustomMessage
    Get

Field Value

The response.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SendCompletedEventArgs Class
SendCompletedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameter Class

[image]

IceLib Technical Reference
ServerParameter Class
Members See Also Send Feedback
Provides information about a server parameter within the Interaction Center system.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerParameter
Visual Basic
Public Class ServerParameter

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..ServerParameter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameter Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameter Members

[image] [image]

IceLib Technical Reference
ServerParameter Members
ServerParameter Class Methods Properties See Also Send Feedback

The ServerParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Exists | Gets whether this server parameter exists on the server.
Public property | Name | Gets the Name of the server parameter.
Public property | Value | Gets the value of this server parameter.

See Also

ServerParameter Class
ININ.IceLib.Connection.Extensions Namespace


ServerParameter Methods

[image] [image]

IceLib Technical Reference
ServerParameter Methods
ServerParameter Class See Also Send Feedback

The ServerParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ServerParameter Class
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
ServerParameter..::..ToString Method
ServerParameter Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameter Class
ServerParameter Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameter Properties

[image] [image]

IceLib Technical Reference
ServerParameter Properties
ServerParameter Class See Also Send Feedback

The ServerParameter type exposes the following members.

Properties

 | Name | Description
Public property | Exists | Gets whether this server parameter exists on the server.
Public property | Name | Gets the Name of the server parameter.
Public property | Value | Gets the value of this server parameter.

See Also

ServerParameter Class
ININ.IceLib.Connection.Extensions Namespace


Exists Property

[image]

IceLib Technical Reference
ServerParameter..::..Exists Property
ServerParameter Class See Also Send Feedback
Gets whether this server parameter exists on the server.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Exists { get; }
Visual Basic
Public ReadOnly Property Exists As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the server parameter exists; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameter Class
ServerParameter Members
ININ.IceLib.Connection.Extensions Namespace


Name Property

[image]

IceLib Technical Reference
ServerParameter..::..Name Property
ServerParameter Class See Also Send Feedback
Gets the Name of the server parameter.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name of the parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameter Class
ServerParameter Members
ININ.IceLib.Connection.Extensions Namespace


Value Property

[image]

IceLib Technical Reference
ServerParameter..::..Value Property
ServerParameter Class See Also Send Feedback
Gets the value of this server parameter.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get

Field Value

The value of this parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameter Class
ServerParameter Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Class

[image]

IceLib Technical Reference
ServerParameters Class
Members See Also Send Feedback
Allows querying and watching of server parameters within the Interaction Center system.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerParameters
Visual Basic
Public Class ServerParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..ServerParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Members

[image] [image]

IceLib Technical Reference
ServerParameters Members
ServerParameters Class Constructors Methods Events See Also Send Feedback

The ServerParameters type exposes the following members.

Constructors

 | Name | Description
Public method | ServerParameters | Initializes a new instance of the ServerParameters class.

Methods

 | Name | Description
Public method | ChangeWatchedParameters | Changes which server parameters are being watched.
Public method | ChangeWatchedParametersAsync | Asynchronously changes which server parameters are being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedServerParameter | Gets the Server Parameter that is cached.
Public method | GetCachedServerParameters | Gets all the server parameters that are cached.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerParameters | Gets a list of server parameters.
Public method | GetServerParametersAsync | Asynchronously gets a list of server parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified serverParameterNames.
Public method | StartWatchingAsync | Asynchronously starts watching the specified serverParameterNames.
Public method | StopWatching | Stops watching the server parameters.
Public method | StopWatchingAsync | Asynchronously stops watching the server parameters.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | ServerParametersChanged | Occurs when a Server Parameter changes.

See Also

ServerParameters Class
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Constructor

[image]

IceLib Technical Reference
ServerParameters Constructor
ServerParameters Class See Also Send Feedback
Initializes a new instance of the ServerParameters class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerParameters(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Methods

[image] [image]

IceLib Technical Reference
ServerParameters Methods
ServerParameters Class See Also Send Feedback

The ServerParameters type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedParameters | Changes which server parameters are being watched.
Public method | ChangeWatchedParametersAsync | Asynchronously changes which server parameters are being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedServerParameter | Gets the Server Parameter that is cached.
Public method | GetCachedServerParameters | Gets all the server parameters that are cached.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServerParameters | Gets a list of server parameters.
Public method | GetServerParametersAsync | Asynchronously gets a list of server parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified serverParameterNames.
Public method | StartWatchingAsync | Asynchronously starts watching the specified serverParameterNames.
Public method | StopWatching | Stops watching the server parameters.
Public method | StopWatchingAsync | Asynchronously stops watching the server parameters.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerParameters Class
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedParameters Method

[image]

IceLib Technical Reference
ServerParameters..::..ChangeWatchedParameters Method
ServerParameters Class See Also Send Feedback
Changes which server parameters are being watched.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedParameters(
    string[] serverParameterNamesToAdd,
    string[] serverParameterNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedParameters ( _
    serverParameterNamesToAdd As String(), _
    serverParameterNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

serverParameterNamesToAdd
Type: array<System..::..String>[]()[][]
The server parameter names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
serverParameterNamesToRemove
Type: array<System..::..String>[]()[][]
The server parameter names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The requested parameter is not in the cache.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedParametersAsync Method

[image]

IceLib Technical Reference
ServerParameters..::..ChangeWatchedParametersAsync Method
ServerParameters Class See Also Send Feedback
Asynchronously changes which server parameters are being watched.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedParametersAsync(
    string[] serverParameterNamesToAdd,
    string[] serverParameterNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedParametersAsync ( _
    serverParameterNamesToAdd As String(), _
    serverParameterNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

serverParameterNamesToAdd
Type: array<System..::..String>[]()[][]
The server parameter names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
serverParameterNamesToRemove
Type: array<System..::..String>[]()[][]
The server parameter names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


GetCachedServerParameter Method

[image]

IceLib Technical Reference
ServerParameters..::..GetCachedServerParameter Method
ServerParameters Class See Also Send Feedback
Gets the Server Parameter that is cached.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerParameter GetCachedServerParameter(
    string parameterName
)
Visual Basic
Public Function GetCachedServerParameter ( _
    parameterName As String _
) As ServerParameter

Parameters

parameterName
Type: System..::..String
The name of the parameter.

Return Value

The requested server parameter.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The requested parameter is not cached.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


GetCachedServerParameters Method

[image]

IceLib Technical Reference
ServerParameters..::..GetCachedServerParameters Method
ServerParameters Class See Also Send Feedback
Gets all the server parameters that are cached.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ServerParameter> GetCachedServerParameters()
Visual Basic
Public Function GetCachedServerParameters As ReadOnlyCollection(Of ServerParameter)

Return Value

The ServerParameter array.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


GetServerParameters Method

[image]

IceLib Technical Reference
ServerParameters..::..GetServerParameters Method
ServerParameters Class See Also Send Feedback
Gets a list of server parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ServerParameter> GetServerParameters(
    string[] serverParameterNames
)
Visual Basic
Public Function GetServerParameters ( _
    serverParameterNames As String() _
) As ReadOnlyCollection(Of ServerParameter)

Parameters

serverParameterNames
Type: array<System..::..String>[]()[][]
The server parameters being requested.

Return Value

A collection of ServerParameter objects.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


GetServerParametersAsync Method

[image]

IceLib Technical Reference
ServerParameters..::..GetServerParametersAsync Method
ServerParameters Class See Also Send Feedback
Asynchronously gets a list of server parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetServerParametersAsync(
    string[] serverParameterNames,
    EventHandler<GetServerParametersCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetServerParametersAsync ( _
    serverParameterNames As String(), _
    completedCallback As EventHandler(Of GetServerParametersCompletedEventArgs), _
    userState As Object _
)

Parameters

serverParameterNames
Type: array<System..::..String>[]()[][]
The server parameters being requested.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetServerParametersCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
ServerParameters..::..IsWatching Method
ServerParameters Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method

[image]

IceLib Technical Reference
ServerParameters..::..IsWatching Method
ServerParameters Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
ServerParameters..::..IsWatching Method (String)
ServerParameters Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string serverParamName
)
Visual Basic
Public Function IsWatching ( _
    serverParamName As String _
) As Boolean

Parameters

serverParamName
Type: System..::..String
Name of the server parameter.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


StartWatching Method

[image]

IceLib Technical Reference
ServerParameters..::..StartWatching Method
ServerParameters Class See Also Send Feedback
Starts watching the specified serverParameterNames.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] serverParameterNames
)
Visual Basic
Public Sub StartWatching ( _
    serverParameterNames As String() _
)

Parameters

serverParameterNames
Type: array<System..::..String>[]()[][]
The server parameter names.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
ServerParameters..::..StartWatchingAsync Method
ServerParameters Class See Also Send Feedback
Asynchronously starts watching the specified serverParameterNames.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] serverParameterNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    serverParameterNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

serverParameterNames
Type: array<System..::..String>[]()[][]
The server parameter names.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


StopWatching Method

[image]

IceLib Technical Reference
ServerParameters..::..StopWatching Method
ServerParameters Class See Also Send Feedback
Stops watching the server parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
ServerParameters..::..StopWatchingAsync Method
ServerParameters Class See Also Send Feedback
Asynchronously stops watching the server parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Events

[image] [image]

IceLib Technical Reference
ServerParameters Events
ServerParameters Class See Also Send Feedback

The ServerParameters type exposes the following members.

Events

 | Name | Description
Public event | ServerParametersChanged | Occurs when a Server Parameter changes.

See Also

ServerParameters Class
ININ.IceLib.Connection.Extensions Namespace


ServerParametersChanged Event

[image]

IceLib Technical Reference
ServerParameters..::..ServerParametersChanged Event
ServerParameters Class See Also Send Feedback
Occurs when a Server Parameter changes.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ServerParametersChangedEventArgs> ServerParametersChanged
Visual Basic
Public Event ServerParametersChanged As EventHandler(Of ServerParametersChangedEventArgs)

Remarks

This event will only occur when server parameters being watched have changed. To start watching for server parameters call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which server parameters are being watched once the watch has been started, use the ChangeWatchedParameters(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParameters Class
ServerParameters Members
ININ.IceLib.Connection.Extensions Namespace


ServerParametersChangedEventArgs Class

[image]

IceLib Technical Reference
ServerParametersChangedEventArgs Class
Members See Also Send Feedback
Provides data for the ServerParametersChanged event.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServerParametersChangedEventArgs : EventArgs
Visual Basic
Public Class ServerParametersChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection.Extensions..::..ServerParametersChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParametersChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


ServerParametersChangedEventArgs Members

[image] [image]

IceLib Technical Reference
ServerParametersChangedEventArgs Members
ServerParametersChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ServerParametersChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ServerParametersChangedEventArgs | Initializes a new instance of the ServerParametersChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ServerParameters | Gets the server parameters.

See Also

ServerParametersChangedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


ServerParametersChangedEventArgs Constructor

[image]

IceLib Technical Reference
ServerParametersChangedEventArgs Constructor
ServerParametersChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the ServerParametersChangedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServerParametersChangedEventArgs(
    ServerParameter[] serverParameters
)
Visual Basic
Public Sub New ( _
    serverParameters As ServerParameter() _
)

Parameters

serverParameters
Type: array< ININ.IceLib.Connection.Extensions..::..ServerParameter >[]()[][]
The server parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParametersChangedEventArgs Class
ServerParametersChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


ServerParametersChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
ServerParametersChangedEventArgs Methods
ServerParametersChangedEventArgs Class See Also Send Feedback

The ServerParametersChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerParametersChangedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


ServerParametersChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
ServerParametersChangedEventArgs Properties
ServerParametersChangedEventArgs Class See Also Send Feedback

The ServerParametersChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ServerParameters | Gets the server parameters.

See Also

ServerParametersChangedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


ServerParameters Property

[image]

IceLib Technical Reference
ServerParametersChangedEventArgs..::..ServerParameters Property
ServerParametersChangedEventArgs Class See Also Send Feedback
Gets the server parameters.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ServerParameter> ServerParameters { get; }
Visual Basic
Public ReadOnly Property ServerParameters As ReadOnlyCollection(Of ServerParameter)
    Get

Field Value

The server parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ServerParametersChangedEventArgs Class
ServerParametersChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatch Class

[image]

IceLib Technical Reference
SessionWatch Class
Members See Also Send Feedback
Allows watching for login/logout events for users, all users on a station, or all users on a computer.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SessionWatch
Visual Basic
Public Class SessionWatch

Remarks

Examples

The following example shows how to monitor for sessions created by other users and then how to create a proxy connection to the IC server for another user, based on the authentication credentials of a special "elevated rights" user.
CopyC#
private void StartSessionWatch()
{
    // For this example, the focus is on watching for sessions created by a particular target User, then creating a proxy connection as
    // if we were that target User, but authenticated using a special "elevated rights" user's credentials.  This is a model used by some
    // server-side integrations, where the server-side component connects as the single "elevated rights" user and can then perform
    // operations on behalf of other users in the system.

    // We'll skip over creation of this server-side application's Session.
    // See other examples for basic details on establishing a connection with the server.
    Session session = CreateSessionForElevatedRightsUser();

    // For this example, we create a "session watch" to monitor for other applications/users that are connecting to the server.
    // Alternatively, a "proxy login" could be create for a user that was obtained based on some other application logic.
    SessionWatch sessionWatch = new SessionWatch(session);

    // Register the event handlers for watched session changes.
    sessionWatch.SessionWatchedUserAdded += SessionWatchedUserAdded;
    sessionWatch.SessionWatchedUserRemoved += SessionWatchedUserRemoved;

    // A session watch can watch for sessions for a given IC User, for an IC Station, or for a Machine.
    // For this example, we'll assume that a particular IC User is to be watched, based on external application needs.
    string targetIcUserId = "<target user ID>";

    SessionWatchId[] sessionsToWatch = new SessionWatchId[]
    {
        new SessionWatchId(SessionWatchType.User, targetIcUserId)
    };

    // Start monitoring for watched session changes for the specified criteria.
    ReadOnlyCollection<SessionWatchSettings> watchSettings = sessionWatch.StartWatching(sessionsToWatch);

    // The result contains any existing connected sessions that match the session watch criteria.
    // The SessionWatchedUser* events will be invoked as matching sessions are connected/disconnected.
    foreach (SessionWatchSettings setting in watchSettings)
    {
        // For this example, we plan on creating a proxy connection on behalf of the target user.
        EstablishProxyConnectionToSession(setting.UserName,
                                          setting.SessionSettings,
                                          session.GetHostSettings(),
                                          setting.StationSettings);
    }
}

private void EstablishProxyConnectionToSession(string targetUserId,
                                               SessionSettings sessionSettings,
                                               HostSettings hostSettings,
                                               StationSettings stationSettings)
{
    // Here we assume that the current windows account under which this application is running is the one associated with
    // the elevated rights user.
    //
    // Note that the IC user that is used to "vouch for" targetUserId's login must have "elevated rights" that allow it to serve
    // as a proxy for the authentication of other Interaction Center users.  The "elevated rights" user should be created
    // specifically for the server-side application's use, with very few rights other than the ability to proxy authentication.
    //
    // The "elevated rights" user must have a specific "Proxy Logins" Access Control right configured on their Interaction Center
    // User via the Interaction Administrator application. This setting is in the "Miscellaneous" section of the Access Control
    // settings.
    ProxyWindowsAuthSettings proxyAuthSettings = new ProxyWindowsAuthSettings(targetUserId, ProxyTargetUserType.ICUser);

    // Alternatively, explicit IC user credentials (i.e. user ID and password) can be specified, but then often those credentials
    // are persisted somewhere to configure the custom application, so this is usually less secure than using Windows-based
    // authentication.
    // string elevatedRightsIcUserId = "<elevated rights user ID>";
    // string elevatedRightsIcPassword = "<elevated rights user password>";
    // ProxyAuthSettings proxyAuthSettings = new ProxyAuthSettings(elevatedRightsIcUserId, elevatedRightsIcPassword, userName);

    // Next, we create a new, separate, Session for the connection of the proxy login.
    // This Session will have the "context" (e.g. rights) of the target User's account, not of the elevated rights user's account.
    //
    // What makes this a "proxy login" is that either ProxyWindowsAuthSettings or ProxyAuthSettings is used as the authSettings parameter.
    Session proxySession = new Session();

    // For this example, we intend to make calls on behalf of the user, using their station.
    // So, we re-use the same station that was part of the session watch result for the user being proxied.
    proxySession.Connect(sessionSettings, hostSettings, proxyAuthSettings, stationSettings);
}

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..SessionWatch

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace
SessionWatch
ProxyWindowsAuthSettings
ProxyAuthSettings


SessionWatch Members

[image] [image]

IceLib Technical Reference
SessionWatch Members
SessionWatch Class Constructors Methods Events See Also Send Feedback

The SessionWatch type exposes the following members.

Constructors

 | Name | Description
Public method | SessionWatch | Initializes a new instance of the SessionWatch class.

Methods

 | Name | Description
Public method | ChangeWatchedSessions | Changes the list of users, stations, and computers to watch for user login/logout events.
Public method | ChangeWatchedSessionsAsync | Asynchronously changes the list of users, stations, and computers to watch for user login/logout events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedSessions | Gets all watched Sessions for any watched user, station or machine.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(SessionWatchId) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Sets a watch for login/logout events for users, all users on a station, or all users on a computer.
Public method | StartWatchingAsync | Asynchronously sets a watch for login/logout events for users, all users on a station, or all users on a computer.
Public method | StopWatching | Stops all watches.
Public method | StopWatchingAsync | Asynchronously stops all watches.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | SessionWatchedUserAdded | Occurs when a user session is created in IC.
Public event | SessionWatchedUserChanged | Obsolete. Occurs when a Session starts or stops for a watched user, station, or machine.
Public event | SessionWatchedUserRemoved | Occurs when a user session is removed in IC.

See Also

SessionWatch Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatch Constructor

[image]

IceLib Technical Reference
SessionWatch Constructor
SessionWatch Class See Also Send Feedback
Initializes a new instance of the SessionWatch class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatch(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatch Methods

[image] [image]

IceLib Technical Reference
SessionWatch Methods
SessionWatch Class See Also Send Feedback

The SessionWatch type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedSessions | Changes the list of users, stations, and computers to watch for user login/logout events.
Public method | ChangeWatchedSessionsAsync | Asynchronously changes the list of users, stations, and computers to watch for user login/logout events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedSessions | Gets all watched Sessions for any watched user, station or machine.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(SessionWatchId) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Sets a watch for login/logout events for users, all users on a station, or all users on a computer.
Public method | StartWatchingAsync | Asynchronously sets a watch for login/logout events for users, all users on a station, or all users on a computer.
Public method | StopWatching | Stops all watches.
Public method | StopWatchingAsync | Asynchronously stops all watches.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionWatch Class
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedSessions Method

[image]

IceLib Technical Reference
SessionWatch..::..ChangeWatchedSessions Method
SessionWatch Class See Also Send Feedback
Changes the list of users, stations, and computers to watch for user login/logout events.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SessionWatchSettings> ChangeWatchedSessions(
    SessionWatchId[] sessionWatchIdsToAdd,
    SessionWatchId[] sessionWatchIdsToRemove,
    bool replaceExisting
)
Visual Basic
Public Function ChangeWatchedSessions ( _
    sessionWatchIdsToAdd As SessionWatchId(), _
    sessionWatchIdsToRemove As SessionWatchId(), _
    replaceExisting As Boolean _
) As ReadOnlyCollection(Of SessionWatchSettings)

Parameters

sessionWatchIdsToAdd
Type: array< ININ.IceLib.Connection.Extensions..::..SessionWatchId >[]()[][]
The session watch IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
sessionWatchIdsToRemove
Type: array< ININ.IceLib.Connection.Extensions..::..SessionWatchId >[]()[][]
The session watch IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Return Value

The session watch settings.

Remarks

This method silently ignores attempts to add items already being watched or to remove items not being watched.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An element in a parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


ChangeWatchedSessionsAsync Method

[image]

IceLib Technical Reference
SessionWatch..::..ChangeWatchedSessionsAsync Method
SessionWatch Class See Also Send Feedback
Asynchronously changes the list of users, stations, and computers to watch for user login/logout events.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedSessionsAsync(
    SessionWatchId[] sessionWatchIdsToAdd,
    SessionWatchId[] sessionWatchIdsToRemove,
    bool replaceExisting,
    EventHandler<SessionWatchAsyncEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedSessionsAsync ( _
    sessionWatchIdsToAdd As SessionWatchId(), _
    sessionWatchIdsToRemove As SessionWatchId(), _
    replaceExisting As Boolean, _
    completedCallback As EventHandler(Of SessionWatchAsyncEventArgs), _
    userState As Object _
)

Parameters

sessionWatchIdsToAdd
Type: array< ININ.IceLib.Connection.Extensions..::..SessionWatchId >[]()[][]
The session watch IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
sessionWatchIdsToRemove
Type: array< ININ.IceLib.Connection.Extensions..::..SessionWatchId >[]()[][]
The session watch IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System..::..EventHandler<(Of <(<' SessionWatchAsyncEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method silently ignores attempts to add items already being watched or to remove items not being watched.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An element in a parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


GetWatchedSessions Method

[image]

IceLib Technical Reference
SessionWatch..::..GetWatchedSessions Method
SessionWatch Class See Also Send Feedback
Gets all watched Sessions for any watched user, station or machine.

Note: This method is supported for IC Server version 2017 R2 and beyond.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SessionWatchSettings> GetWatchedSessions()
Visual Basic
Public Function GetWatchedSessions As ReadOnlyCollection(Of SessionWatchSettings)

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of SessionWatchSettings objects.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The watcher is not currently watched.

Version Information

Supported for IC Server version 2017 R2 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
SessionWatch..::..IsWatching Method
SessionWatch Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(SessionWatchId) | Determines whether a watch is active and if the specified value is being watched.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method

[image]

IceLib Technical Reference
SessionWatch..::..IsWatching Method
SessionWatch Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


IsWatching Method (SessionWatchId)

[image]

IceLib Technical Reference
SessionWatch..::..IsWatching Method (SessionWatchId)
SessionWatch Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    SessionWatchId watchId
)
Visual Basic
Public Function IsWatching ( _
    watchId As SessionWatchId _
) As Boolean

Parameters

watchId
Type: ININ.IceLib.Connection.Extensions..::..SessionWatchId
The scoped identifier.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
IsWatching Overload
ININ.IceLib.Connection.Extensions Namespace


StartWatching Method

[image]

IceLib Technical Reference
SessionWatch..::..StartWatching Method
SessionWatch Class See Also Send Feedback
Sets a watch for login/logout events for users, all users on a station, or all users on a computer.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SessionWatchSettings> StartWatching(
    SessionWatchId[] watchIds
)
Visual Basic
Public Function StartWatching ( _
    watchIds As SessionWatchId() _
) As ReadOnlyCollection(Of SessionWatchSettings)

Parameters

watchIds
Type: array< ININ.IceLib.Connection.Extensions..::..SessionWatchId >[]()[][]
The scoped identifiers for all watches.

Return Value

The session watch settings.

Remarks

Note
All event handlers should be added before calling StartWatching(array<SessionWatchId>[]()[][]) or StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
SessionWatch..::..StartWatchingAsync Method
SessionWatch Class See Also Send Feedback
Asynchronously sets a watch for login/logout events for users, all users on a station, or all users on a computer.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    SessionWatchId[] watchIds,
    EventHandler<SessionWatchAsyncEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    watchIds As SessionWatchId(), _
    completedCallback As EventHandler(Of SessionWatchAsyncEventArgs), _
    userState As Object _
)

Parameters

watchIds
Type: array< ININ.IceLib.Connection.Extensions..::..SessionWatchId >[]()[][]
The scoped identifiers for all watches.
completedCallback
Type: System..::..EventHandler<(Of <(<' SessionWatchAsyncEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<SessionWatchId>[]()[][]) or StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


StopWatching Method

[image]

IceLib Technical Reference
SessionWatch..::..StopWatching Method
SessionWatch Class See Also Send Feedback
Stops all watches.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
SessionWatch..::..StopWatchingAsync Method
SessionWatch Class See Also Send Feedback
Asynchronously stops all watches.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatch Events

[image] [image]

IceLib Technical Reference
SessionWatch Events
SessionWatch Class See Also Send Feedback

The SessionWatch type exposes the following members.

Events

 | Name | Description
Public event | SessionWatchedUserAdded | Occurs when a user session is created in IC.
Public event | SessionWatchedUserChanged | Obsolete. Occurs when a Session starts or stops for a watched user, station, or machine.
Public event | SessionWatchedUserRemoved | Occurs when a user session is removed in IC.

See Also

SessionWatch Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserAdded Event

[image]

IceLib Technical Reference
SessionWatch..::..SessionWatchedUserAdded Event
SessionWatch Class See Also Send Feedback
Occurs when a user session is created in IC.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<SessionWatchedUserAddedRemovedEventArgs> SessionWatchedUserAdded
Visual Basic
Public Event SessionWatchedUserAdded As EventHandler(Of SessionWatchedUserAddedRemovedEventArgs)

Remarks

This event will only occur when sessions being watched have changed. To start watching for sessions call either the StartWatching(array<SessionWatchId>[]()[][]) method or the StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object) method. To modify which sessions are being watched once the watch has been started, use the ChangeWatchedSessions(array<SessionWatchId>[]()[][], array<SessionWatchId>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<SessionWatchId>[]()[][]) or StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.
For 2.4, supported for IC Server version 2.4 SU 31 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserChanged Event

[image]

IceLib Technical Reference
SessionWatch..::..SessionWatchedUserChanged Event
SessionWatch Class See Also Send Feedback
Occurs when a Session starts or stops for a watched user, station, or machine.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SessionWatchUserChanged event has been deprecated. Please use SessionWatchedUserAdded and SessionWatchedUserRemoved instead.",
    false)]
public event EventHandler<SessionWatchedUserChangedEventArgs> SessionWatchedUserChanged
Visual Basic
<ObsoleteAttribute("SessionWatchUserChanged event has been deprecated. Please use SessionWatchedUserAdded and SessionWatchedUserRemoved instead.",  _
    False)> _
Public Event SessionWatchedUserChanged As EventHandler(Of SessionWatchedUserChangedEventArgs)

Remarks

This event will only occur when sessions being watched have changed. To start watching for sessions call either the StartWatching(array<SessionWatchId>[]()[][]) method or the StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object) method. To modify which sessions are being watched once the watch has been started, use the ChangeWatchedSessions(array<SessionWatchId>[]()[][], array<SessionWatchId>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<SessionWatchId>[]()[][]) or StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 27 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserRemoved Event

[image]

IceLib Technical Reference
SessionWatch..::..SessionWatchedUserRemoved Event
SessionWatch Class See Also Send Feedback
Occurs when a user session is removed in IC.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<SessionWatchedUserAddedRemovedEventArgs> SessionWatchedUserRemoved
Visual Basic
Public Event SessionWatchedUserRemoved As EventHandler(Of SessionWatchedUserAddedRemovedEventArgs)

Remarks

This event will only occur when sessions being watched have changed. To start watching for sessions call either the StartWatching(array<SessionWatchId>[]()[][]) method or the StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object) method. To modify which sessions are being watched once the watch has been started, use the ChangeWatchedSessions(array<SessionWatchId>[]()[][], array<SessionWatchId>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<SessionWatchId>[]()[][]) or StartWatchingAsync(array<SessionWatchId>[]()[][], EventHandler<(Of <<'(SessionWatchAsyncEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.
For 2.4, supported for IC Server version 2.4 SU 31 and beyond.

See Also

SessionWatch Class
SessionWatch Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchAsyncEventArgs Class

[image]

IceLib Technical Reference
SessionWatchAsyncEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of SessionWatch.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SessionWatchAsyncEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class SessionWatchAsyncEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Connection.Extensions..::..SessionWatchAsyncEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchAsyncEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchAsyncEventArgs Members

[image] [image]

IceLib Technical Reference
SessionWatchAsyncEventArgs Members
SessionWatchAsyncEventArgs Class Constructors Methods Properties See Also Send Feedback

The SessionWatchAsyncEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SessionWatchAsyncEventArgs | Initializes a new instance of the SessionWatchAsyncEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SessionWatchSettings | Gets the session watch settings.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SessionWatchAsyncEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchAsyncEventArgs Constructor

[image]

IceLib Technical Reference
SessionWatchAsyncEventArgs Constructor
SessionWatchAsyncEventArgs Class See Also Send Feedback
Initializes a new instance of the SessionWatchAsyncEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchAsyncEventArgs(
    ReadOnlyCollection<SessionWatchSettings> sessionWatchSettings,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    sessionWatchSettings As ReadOnlyCollection(Of SessionWatchSettings), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

sessionWatchSettings
Type: System.Collections.ObjectModel..::..ReadOnlyCollection<(Of <(<' SessionWatchSettings >)>)>
The session watch settings.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchAsyncEventArgs Class
SessionWatchAsyncEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchAsyncEventArgs Methods

[image] [image]

IceLib Technical Reference
SessionWatchAsyncEventArgs Methods
SessionWatchAsyncEventArgs Class See Also Send Feedback

The SessionWatchAsyncEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionWatchAsyncEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchAsyncEventArgs Properties

[image] [image]

IceLib Technical Reference
SessionWatchAsyncEventArgs Properties
SessionWatchAsyncEventArgs Class See Also Send Feedback

The SessionWatchAsyncEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SessionWatchSettings | Gets the session watch settings.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SessionWatchAsyncEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchSettings Property

[image]

IceLib Technical Reference
SessionWatchAsyncEventArgs..::..SessionWatchSettings Property
SessionWatchAsyncEventArgs Class See Also Send Feedback
Gets the session watch settings.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<SessionWatchSettings> SessionWatchSettings { get; }
Visual Basic
Public ReadOnly Property SessionWatchSettings As ReadOnlyCollection(Of SessionWatchSettings)
    Get

Field Value

The session watch settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchAsyncEventArgs Class
SessionWatchAsyncEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserAddedRemovedEventArgs Class

[image]

IceLib Technical Reference
SessionWatchedUserAddedRemovedEventArgs Class
Members See Also Send Feedback
Provides data for the watched user added and watched user removed events.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SessionWatchedUserAddedRemovedEventArgs : EventArgs
Visual Basic
Public Class SessionWatchedUserAddedRemovedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection.Extensions..::..SessionWatchedUserAddedRemovedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.
For 2.4, supported for IC Server version 2.4 SU 31 and beyond.

See Also

SessionWatchedUserAddedRemovedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserAddedRemovedEventArgs Members

[image] [image]

IceLib Technical Reference
SessionWatchedUserAddedRemovedEventArgs Members
SessionWatchedUserAddedRemovedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SessionWatchedUserAddedRemovedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SessionWatchedUserAddedRemovedEventArgs | Initializes a new instance of the SessionWatchedUserAddedRemovedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Settings | Gets the SessionWatchSettings instance.

See Also

SessionWatchedUserAddedRemovedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserAddedRemovedEventArgs Constructor

[image]

IceLib Technical Reference
SessionWatchedUserAddedRemovedEventArgs Constructor
SessionWatchedUserAddedRemovedEventArgs Class See Also Send Feedback
Initializes a new instance of the SessionWatchedUserAddedRemovedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchedUserAddedRemovedEventArgs()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.
For 2.4, supported for IC Server version 2.4 SU 31 and beyond.

See Also

SessionWatchedUserAddedRemovedEventArgs Class
SessionWatchedUserAddedRemovedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserAddedRemovedEventArgs Methods

[image] [image]

IceLib Technical Reference
SessionWatchedUserAddedRemovedEventArgs Methods
SessionWatchedUserAddedRemovedEventArgs Class See Also Send Feedback

The SessionWatchedUserAddedRemovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionWatchedUserAddedRemovedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserAddedRemovedEventArgs Properties

[image] [image]

IceLib Technical Reference
SessionWatchedUserAddedRemovedEventArgs Properties
SessionWatchedUserAddedRemovedEventArgs Class See Also Send Feedback

The SessionWatchedUserAddedRemovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Settings | Gets the SessionWatchSettings instance.

See Also

SessionWatchedUserAddedRemovedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


Settings Property

[image]

IceLib Technical Reference
SessionWatchedUserAddedRemovedEventArgs..::..Settings Property
SessionWatchedUserAddedRemovedEventArgs Class See Also Send Feedback
Gets the SessionWatchSettings instance.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchSettings Settings { get; private set; }
Visual Basic
Public Property Settings As SessionWatchSettings
    Get
    Private Set

Field Value

The SessionWatchSettings instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.
For 2.4, supported for IC Server version 2.4 SU 31 and beyond.

See Also

SessionWatchedUserAddedRemovedEventArgs Class
SessionWatchedUserAddedRemovedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserChangedEventArgs Class

[image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs Class
Members See Also Send Feedback
Provides data for the watched user changed event.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SessionWatchedUserChangedEventArgs has been deprecated. Please use SessionWatchedUserAddedRemovedEventArgs instead.",
    false)]
public class SessionWatchedUserChangedEventArgs : EventArgs
Visual Basic
<ObsoleteAttribute("SessionWatchedUserChangedEventArgs has been deprecated. Please use SessionWatchedUserAddedRemovedEventArgs instead.",  _
    False)> _
Public Class SessionWatchedUserChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Connection.Extensions..::..SessionWatchedUserChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchedUserChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserChangedEventArgs Members

[image] [image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs Members
SessionWatchedUserChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SessionWatchedUserChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SessionWatchedUserChangedEventArgs | Initializes a new instance of the SessionWatchedUserChangedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Login | Gets a value indicating whether the change was a login.
Public property | MachineName | Gets the name of the machine.
Public property | StationName | Gets the name of the station.
Public property | UserId | Gets the user ID.

See Also

SessionWatchedUserChangedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserChangedEventArgs Constructor

[image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs Constructor
SessionWatchedUserChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the SessionWatchedUserChangedEventArgs class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchedUserChangedEventArgs(
    bool login,
    string userId,
    string stationName,
    string machineName
)
Visual Basic
Public Sub New ( _
    login As Boolean, _
    userId As String, _
    stationName As String, _
    machineName As String _
)

Parameters

login
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), logged in.
userId
Type: System..::..String
The user ID.
stationName
Type: System..::..String
Name of the station.
machineName
Type: System..::..String
Name of the machine.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchedUserChangedEventArgs Class
SessionWatchedUserChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs Methods
SessionWatchedUserChangedEventArgs Class See Also Send Feedback

The SessionWatchedUserChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionWatchedUserChangedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchedUserChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs Properties
SessionWatchedUserChangedEventArgs Class See Also Send Feedback

The SessionWatchedUserChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Login | Gets a value indicating whether the change was a login.
Public property | MachineName | Gets the name of the machine.
Public property | StationName | Gets the name of the station.
Public property | UserId | Gets the user ID.

See Also

SessionWatchedUserChangedEventArgs Class
ININ.IceLib.Connection.Extensions Namespace


Login Property

[image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs..::..Login Property
SessionWatchedUserChangedEventArgs Class See Also Send Feedback
Gets a value indicating whether the change was a login.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Login { get; private set; }
Visual Basic
Public Property Login As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if logged in; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchedUserChangedEventArgs Class
SessionWatchedUserChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


MachineName Property

[image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs..::..MachineName Property
SessionWatchedUserChangedEventArgs Class See Also Send Feedback
Gets the name of the machine.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MachineName { get; private set; }
Visual Basic
Public Property MachineName As String
    Get
    Private Set

Field Value

The name of the machine.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchedUserChangedEventArgs Class
SessionWatchedUserChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


StationName Property

[image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs..::..StationName Property
SessionWatchedUserChangedEventArgs Class See Also Send Feedback
Gets the name of the station.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationName { get; private set; }
Visual Basic
Public Property StationName As String
    Get
    Private Set

Field Value

The name of the station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchedUserChangedEventArgs Class
SessionWatchedUserChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


UserId Property

[image]

IceLib Technical Reference
SessionWatchedUserChangedEventArgs..::..UserId Property
SessionWatchedUserChangedEventArgs Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; private set; }
Visual Basic
Public Property UserId As String
    Get
    Private Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchedUserChangedEventArgs Class
SessionWatchedUserChangedEventArgs Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchId Class

[image]

IceLib Technical Reference
SessionWatchId Class
Members See Also Send Feedback
Identifies a watched session for the SessionWatch class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SessionWatchId
Visual Basic
Public Class SessionWatchId

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..SessionWatchId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchId Members

[image] [image]

IceLib Technical Reference
SessionWatchId Members
SessionWatchId Class Constructors Methods Properties See Also Send Feedback

The SessionWatchId type exposes the following members.

Constructors

 | Name | Description
Public method | SessionWatchId | Initializes a new instance of the SessionWatchId class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | WatchType | Gets the type of the watch.

See Also

SessionWatchId Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchId Constructor

[image]

IceLib Technical Reference
SessionWatchId Constructor
SessionWatchId Class See Also Send Feedback
Initializes a new instance of the SessionWatchId class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchId(
    SessionWatchType watchType,
    string name
)
Visual Basic
Public Sub New ( _
    watchType As SessionWatchType, _
    name As String _
)

Parameters

watchType
Type: ININ.IceLib.Connection.Extensions..::..SessionWatchType
Type of the watch.
name
Type: System..::..String
The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchId Class
SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchId Methods

[image] [image]

IceLib Technical Reference
SessionWatchId Methods
SessionWatchId Class See Also Send Feedback

The SessionWatchId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SessionWatchId Class
ININ.IceLib.Connection.Extensions Namespace


Equals Method

[image]

IceLib Technical Reference
SessionWatchId..::..Equals Method
SessionWatchId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionWatchId Class
SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
SessionWatchId..::..GetHashCode Method
SessionWatchId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionWatchId Class
SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


ToString Method

[image]

IceLib Technical Reference
SessionWatchId..::..ToString Method
SessionWatchId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SessionWatchId Class
SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchId Properties

[image] [image]

IceLib Technical Reference
SessionWatchId Properties
SessionWatchId Class See Also Send Feedback

The SessionWatchId type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name.
Public property | WatchType | Gets the type of the watch.

See Also

SessionWatchId Class
ININ.IceLib.Connection.Extensions Namespace


Name Property

[image]

IceLib Technical Reference
SessionWatchId..::..Name Property
SessionWatchId Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchId Class
SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


WatchType Property

[image]

IceLib Technical Reference
SessionWatchId..::..WatchType Property
SessionWatchId Class See Also Send Feedback
Gets the type of the watch.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchType WatchType { get; }
Visual Basic
Public ReadOnly Property WatchType As SessionWatchType
    Get

Field Value

The type of the watch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchId Class
SessionWatchId Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchSettings Class

[image]

IceLib Technical Reference
SessionWatchSettings Class
Members See Also Send Feedback
Describes session, station, and machine data for a watched session.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SessionWatchSettings
Visual Basic
Public Class SessionWatchSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Connection.Extensions..::..SessionWatchSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchSettings Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchSettings Members

[image] [image]

IceLib Technical Reference
SessionWatchSettings Members
SessionWatchSettings Class Constructors Methods Properties See Also Send Feedback

The SessionWatchSettings type exposes the following members.

Constructors

 | Name | Description
Public method | SessionWatchSettings | Initializes a new instance of the SessionWatchSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SessionSettings | Gets the session settings.
Public property | SessionWatchId | Gets the session watch ID. This is used to correlate user session information with a session watch.
Public property | StationSettings | Gets the station settings (as a StationSettings-derived instance).
Public property | UserName | Gets the name of the user.

See Also

SessionWatchSettings Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchSettings Constructor

[image]

IceLib Technical Reference
SessionWatchSettings Constructor
SessionWatchSettings Class See Also Send Feedback
Initializes a new instance of the SessionWatchSettings class.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchSettings Class
SessionWatchSettings Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchSettings Methods

[image] [image]

IceLib Technical Reference
SessionWatchSettings Methods
SessionWatchSettings Class See Also Send Feedback

The SessionWatchSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionWatchSettings Class
ININ.IceLib.Connection.Extensions Namespace


SessionWatchSettings Properties

[image] [image]

IceLib Technical Reference
SessionWatchSettings Properties
SessionWatchSettings Class See Also Send Feedback

The SessionWatchSettings type exposes the following members.

Properties

 | Name | Description
Public property | SessionSettings | Gets the session settings.
Public property | SessionWatchId | Gets the session watch ID. This is used to correlate user session information with a session watch.
Public property | StationSettings | Gets the station settings (as a StationSettings-derived instance).
Public property | UserName | Gets the name of the user.

See Also

SessionWatchSettings Class
ININ.IceLib.Connection.Extensions Namespace


SessionSettings Property

[image]

IceLib Technical Reference
SessionWatchSettings..::..SessionSettings Property
SessionWatchSettings Class See Also Send Feedback
Gets the session settings.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionSettings SessionSettings { get; internal set; }
Visual Basic
Public Property SessionSettings As SessionSettings
    Get
    Friend Set

Field Value

The session settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchSettings Class
SessionWatchSettings Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchId Property

[image]

IceLib Technical Reference
SessionWatchSettings..::..SessionWatchId Property
SessionWatchSettings Class See Also Send Feedback
Gets the session watch ID. This is used to correlate user session information with a session watch.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SessionWatchId SessionWatchId { get; internal set; }
Visual Basic
Public Property SessionWatchId As SessionWatchId
    Get
    Friend Set

Field Value

The session watch ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchSettings Class
SessionWatchSettings Members
ININ.IceLib.Connection.Extensions Namespace


StationSettings Property

[image]

IceLib Technical Reference
SessionWatchSettings..::..StationSettings Property
SessionWatchSettings Class See Also Send Feedback
Gets the station settings (as a StationSettings-derived instance).

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StationSettings StationSettings { get; internal set; }
Visual Basic
Public Property StationSettings As StationSettings
    Get
    Friend Set

Field Value

The StationSettings-derived instance (e.g. WorkstationSettings, StationlessSettings, etc.).

Remarks

Examples

CopyC#
SessionWatchSettings sessionWatchSettings = ...;
RemoteStationSettings remoteStationSettings = sessionWatchSettings.StationSettings as RemoteStationSettings;
if (remoteStationSettings != null)
{
    // do work for remote station.
}
else if (sessionWatchSettings.StationSettings is StationlessSettings)
{
    // do work for stationless settings.
}

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchSettings Class
SessionWatchSettings Members
ININ.IceLib.Connection.Extensions Namespace


UserName Property

[image]

IceLib Technical Reference
SessionWatchSettings..::..UserName Property
SessionWatchSettings Class See Also Send Feedback
Gets the name of the user.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserName { get; internal set; }
Visual Basic
Public Property UserName As String
    Get
    Friend Set

Field Value

The name of the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

SessionWatchSettings Class
SessionWatchSettings Members
ININ.IceLib.Connection.Extensions Namespace


SessionWatchType Enumeration

[image]

IceLib Technical Reference
SessionWatchType Enumeration
See Also Send Feedback
Describes the type of Session Watch to perform.

Namespace: ININ.IceLib.Connection.Extensions
Assembly: ININ.IceLib (in ININ.IceLib.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum SessionWatchType
Visual Basic
Public Enumeration SessionWatchType

Members

Member name | Value | Description
User | 0 | Watch for a given user.
Station | 1 | Watch for all users on a station.
Machine | 2 | Watch for all users on a machine.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.
For 2.4, supported for IC Server version 2.4 SU 28 and beyond.

See Also

ININ.IceLib.Connection.Extensions Namespace


ININ.IceLib.Data.TransactionBuilder Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Data.TransactionBuilder Namespace
Send Feedback

The ININ.IceLib.Data.TransactionBuilder namespace contains classes necessary for client applications to execute transactions remotely through Transaction Server.

The primary class used in the ININ.IceLib.Data.TransactionBuilder namespace is the TransactionClient class.

The classes in the TransactionBuilder can be used in a .Net application to execute custom transactions. The ININ.IceLib.Tracker namespace contains an API for accessing and manipulating Interaction Tracker data. The classes and methods in the ININ.IceLib.Tracker namespace use the classes in the ININ.IceLib.Data.TransactionBuilder namespace as a middle tier. It provides the communication layer that is used to execute the remote stored procedures via TransactionServer.

Classes

 | Class | Description
Public class | CancelTransactionCompletedEventArgs | Provides data for the CancelTransactionAsync(String, EventHandler<(Of <<'(CancelTransactionCompletedEventArgs>)>>), Object) completedCallback delegate.
Public class | DatabaseUuidHelper | Provides utility methods for UUIDs returned from databases via I3DBTran.
Public class | ExecuteCompletedEventArgs | Provides data for the ExecuteCompleted event of a TransactionClient.
Public class | MultiObjectWireProtocol | Class that provides static methods to marshall basic I3DBTran types into a StringBuilder This allows multiple objects and/or a variable number of objects or data parameters to be passed to a tran via a single CLOB parameter.
Public class | QueryTransactionStatusCompletedEventArgs | Provides data for the QueryTransactionStatusAsync(String, EventHandler<(Of <<'(QueryTransactionStatusCompletedEventArgs>)>>), Object) completedCallback delegate.
Public class | RecordNotFoundException | Represents a RecordNotFound error.
Public class | TransactionClient | Provides the communication layer between .NET Client applications and Transaction Server.
Public class | TransactionData | Contains the configurable settings that a TransactionClient uses when communicating with Transaction Server.
Public class | TransactionManager | The TransactionManager class provides methods to interact with transactions executed from a TransactionClient instance.
Public class | TransactionParameter | Represents a parameter that is used for executing transactions. Each transaction can have multiple transaction parameters.
Public class | TransactionSettingDefaults | Class containing defaults used by TransactionSettings.
Public class | TransactionSettings | Contains the settings used for communication with the Transaction Server.

Enumerations

 | Enumeration | Description
Public enumeration | ExtendedErrorCode | Specifies constants indicating the extented error codes for transaction execution failures.
Public enumeration | ParameterDataType | Specifies constants indicating the data type of a transaction parameter.
Public enumeration | ParameterType | Specifies constants indicating the type of a transaction parameter.
Public enumeration | TransactionIsolationType | Specifies constants indicating the isolation type of a transaction.
Public enumeration | TransactionRequestType | Specifies constants indicating the request type of a transaction.
Public enumeration | TransactionStatus | Represents the status of a transaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


CancelTransactionCompletedEventArgs Class

[image]

IceLib Technical Reference
CancelTransactionCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the CancelTransactionAsync(String, EventHandler<(Of <<'(CancelTransactionCompletedEventArgs>)>>), Object) completedCallback delegate.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CancelTransactionCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class CancelTransactionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Data.TransactionBuilder..::..CancelTransactionCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CancelTransactionCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


CancelTransactionCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
CancelTransactionCompletedEventArgs Members
CancelTransactionCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The CancelTransactionCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CancelTransactionCompletedEventArgs | Initializes a new instance of the CancelTransactionCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CancelTransactionCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


CancelTransactionCompletedEventArgs Constructor

[image]

IceLib Technical Reference
CancelTransactionCompletedEventArgs Constructor
CancelTransactionCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the CancelTransactionCompletedEventArgs class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CancelTransactionCompletedEventArgs(
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CancelTransactionCompletedEventArgs Class
CancelTransactionCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


CancelTransactionCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
CancelTransactionCompletedEventArgs Methods
CancelTransactionCompletedEventArgs Class See Also Send Feedback

The CancelTransactionCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CancelTransactionCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


CancelTransactionCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
CancelTransactionCompletedEventArgs Properties
CancelTransactionCompletedEventArgs Class See Also Send Feedback

The CancelTransactionCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CancelTransactionCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


DatabaseUuidHelper Class

[image]

IceLib Technical Reference
DatabaseUuidHelper Class
Members See Also Send Feedback
Provides utility methods for UUIDs returned from databases via I3DBTran.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DatabaseUuidHelper
Visual Basic
Public Class DatabaseUuidHelper

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..DatabaseUuidHelper

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DatabaseUuidHelper Members
ININ.IceLib.Data.TransactionBuilder Namespace


DatabaseUuidHelper Members

[image] [image]

IceLib Technical Reference
DatabaseUuidHelper Members
DatabaseUuidHelper Class Constructors Methods See Also Send Feedback

The DatabaseUuidHelper type exposes the following members.

Constructors

 | Name | Description
Public method | DatabaseUuidHelper | Initializes a new instance of the DatabaseUuidHelper class

Methods

 | Name | Description
 | AdjustDatabaseUuidString | UUIDs as returned by databases will be rendered as strings, in different formats depending on the database implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseUuidHelper Class
ININ.IceLib.Data.TransactionBuilder Namespace


DatabaseUuidHelper Constructor

[image]

IceLib Technical Reference
DatabaseUuidHelper Constructor
DatabaseUuidHelper Class See Also Send Feedback
Initializes a new instance of the DatabaseUuidHelper class

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DatabaseUuidHelper()
Visual Basic
Public Sub New

See Also

DatabaseUuidHelper Class
DatabaseUuidHelper Members
ININ.IceLib.Data.TransactionBuilder Namespace


DatabaseUuidHelper Methods

[image] [image]

IceLib Technical Reference
DatabaseUuidHelper Methods
DatabaseUuidHelper Class See Also Send Feedback

The DatabaseUuidHelper type exposes the following members.

Methods

 | Name | Description
 | AdjustDatabaseUuidString | UUIDs as returned by databases will be rendered as strings, in different formats depending on the database implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseUuidHelper Class
ININ.IceLib.Data.TransactionBuilder Namespace


AdjustDatabaseUuidString Method

[image]

IceLib Technical Reference
DatabaseUuidHelper..::..AdjustDatabaseUuidString Method
DatabaseUuidHelper Class See Also Send Feedback
UUIDs as returned by databases will be rendered as strings, in different formats depending on the database implementation.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string AdjustDatabaseUuidString(
    string databaseUuidAsString
)
Visual Basic
Public Shared Function AdjustDatabaseUuidString ( _
    databaseUuidAsString As String _
) As String

Parameters

databaseUuidAsString
Type: System..::..String
A UUID expressed as a string returned by a database.

Return Value

A string of the adjusted UUID.

Remarks

SQL Server will be rendering from the UNIQUEIDENTIFIER type, which is a natural UUID container, while all other databases will be rendering from the relevant binary data type. The main difference (and the reason for this method) is that SQL Server's rendering will be in xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx format (instead of non-dashed formats with possible extra characters), AND the first 3 components of the SQL Server are in little-endian format while the last 2 components are in big-endian format. The problem comes in in that while the native from_string method can read all of the string formats, it assumes that the first 3 components (the 1 4 byte component and the next 2 byte components) are in little-endian format. That works great for SQL Server, but all other formats are essentially big-endian integers. The upshot is that all UUID strings returned by databases that are NOT SQL Server, the uuids generated by the native from_string method will be wrong.

This method assumes that the string passed in is a UUID string as returned by the database. It examines the string and if the string is not in dashed format, then it assumed to be returned by a database other than SQL Server and the first 4 2 hex character byte strings are endian swapped, the next 2 2 hex character byte strings are endian swapped, and the next 2 2 hex character byte strings are endian swapped. In addition, surrounding curly braces, quotes, 'X' and '0x' characters are removed.

This mirrors the function of the I3DBTran StringToGUID() function in eic/src/I3DBTran/I3DBTranUtility/I3DBTranConversions.cpp, which is used to perform the same task for C++-based I3DBTran clients.

Note
WARNING: ONLY APPLY THIS METHOD TO UUID STRINGS BEING RETURNED BY A DATABASE. If you run it against a valid UUID that was formatted without dashes, you will get an unexpected endian swap and your UUID will not be what you expect. If you're not sure you should use this method, you probably shouldn't use it at all. It is intended to be used almost exclusively by codegen created code, or code created by those brave souls that call I3DBTran directly.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DatabaseUuidHelper Class
DatabaseUuidHelper Members
ININ.IceLib.Data.TransactionBuilder Namespace


ExecuteCompletedEventArgs Class

[image]

IceLib Technical Reference
ExecuteCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the ExecuteCompleted event of a TransactionClient.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExecuteCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class ExecuteCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Data.TransactionBuilder..::..ExecuteCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExecuteCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


ExecuteCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
ExecuteCompletedEventArgs Members
ExecuteCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ExecuteCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ExecuteCompletedEventArgs | Initializes a new instance of the ExecuteCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets the success result associated with the event.
Public property | TransactionData | Gets the transaction data associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ExecuteCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


ExecuteCompletedEventArgs Constructor

[image]

IceLib Technical Reference
ExecuteCompletedEventArgs Constructor
ExecuteCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ExecuteCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExecuteCompletedEventArgs(
    bool success,
    TransactionData transactionData,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    success As Boolean, _
    transactionData As TransactionData, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

success
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the transaction success.
transactionData
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionData
The transaction data.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExecuteCompletedEventArgs Class
ExecuteCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


ExecuteCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
ExecuteCompletedEventArgs Methods
ExecuteCompletedEventArgs Class See Also Send Feedback

The ExecuteCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


ExecuteCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
ExecuteCompletedEventArgs Properties
ExecuteCompletedEventArgs Class See Also Send Feedback

The ExecuteCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Success | Gets the success result associated with the event.
Public property | TransactionData | Gets the transaction data associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ExecuteCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


Success Property

[image]

IceLib Technical Reference
ExecuteCompletedEventArgs..::..Success Property
ExecuteCompletedEventArgs Class See Also Send Feedback
Gets the success result associated with the event.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Success { get; }
Visual Basic
Public ReadOnly Property Success As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the transaction completed successfully; falseFalsefalsefalse (False in Visual Basic) otherwise.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExecuteCompletedEventArgs Class
ExecuteCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionData Property

[image]

IceLib Technical Reference
ExecuteCompletedEventArgs..::..TransactionData Property
ExecuteCompletedEventArgs Class See Also Send Feedback
Gets the transaction data associated with the event.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionData TransactionData { get; }
Visual Basic
Public ReadOnly Property TransactionData As TransactionData
    Get

Field Value

The transaction data includes parameters, the name of the procedure, query results, return code, transaction name, and other details.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExecuteCompletedEventArgs Class
ExecuteCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


ExtendedErrorCode Enumeration

[image]

IceLib Technical Reference
ExtendedErrorCode Enumeration
See Also Send Feedback
Specifies constants indicating the extented error codes for transaction execution failures.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ExtendedErrorCode
Visual Basic
Public Enumeration ExtendedErrorCode

Members

Member name | Value | Description
Other | -1 | Other.
Success | 0 | Success.
RecordNotFound | 1 | Record not found.
RecordChanged | 2 | Record changed.
RecordDeactivated | 3 | Record deactivated.

Remarks

This enumeration is used by TransactionClient during transaction execution to specify the extented error codes for transaction execution failures.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Data.TransactionBuilder Namespace


MultiObjectWireProtocol Class

[image]

IceLib Technical Reference
MultiObjectWireProtocol Class
Members See Also Send Feedback
Class that provides static methods to marshall basic I3DBTran types into a StringBuilder This allows multiple objects and/or a variable number of objects or data parameters to be passed to a tran via a single CLOB parameter.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MultiObjectWireProtocol
Visual Basic
Public Class MultiObjectWireProtocol

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..MultiObjectWireProtocol

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Members
ININ.IceLib.Data.TransactionBuilder Namespace


MultiObjectWireProtocol Members

[image] [image]

IceLib Technical Reference
MultiObjectWireProtocol Members
MultiObjectWireProtocol Class Constructors Methods See Also Send Feedback

The MultiObjectWireProtocol type exposes the following members.

Constructors

 | Name | Description
Public method | MultiObjectWireProtocol | Initializes a new instance of the MultiObjectWireProtocol class

Methods

 | Name | Description
 | Encode(StringBuilder) | Static method to marshall a NULL into a StringBuilder buffer.
 | Encode(StringBuilder, Boolean) | Static method to marshall a boolean into a StringBuilder buffer.
 | Encode(StringBuilder, DateTime) | Static method to marshall a date/time into a StringBuilder buffer.
 | Encode(StringBuilder, Double) | Static method to marshall a double into a StringBuilder buffer.
 | Encode(StringBuilder, Guid) | Static method to marshall a guid into a StringBuilder buffer.
 | Encode(StringBuilder, Int32) | Static method to marshall an integer into a StringBuilder buffer.
 | Encode(StringBuilder, Int64) | Static method to marshall a long into a StringBuilder buffer.
 | Encode(StringBuilder, String) | Static method to marshall a string into a StringBuilder buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiObjectWireProtocol Class
ININ.IceLib.Data.TransactionBuilder Namespace


MultiObjectWireProtocol Constructor

[image]

IceLib Technical Reference
MultiObjectWireProtocol Constructor
MultiObjectWireProtocol Class See Also Send Feedback
Initializes a new instance of the MultiObjectWireProtocol class

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MultiObjectWireProtocol()
Visual Basic
Public Sub New

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
ININ.IceLib.Data.TransactionBuilder Namespace


MultiObjectWireProtocol Methods

[image] [image]

IceLib Technical Reference
MultiObjectWireProtocol Methods
MultiObjectWireProtocol Class See Also Send Feedback

The MultiObjectWireProtocol type exposes the following members.

Methods

 | Name | Description
 | Encode(StringBuilder) | Static method to marshall a NULL into a StringBuilder buffer.
 | Encode(StringBuilder, Boolean) | Static method to marshall a boolean into a StringBuilder buffer.
 | Encode(StringBuilder, DateTime) | Static method to marshall a date/time into a StringBuilder buffer.
 | Encode(StringBuilder, Double) | Static method to marshall a double into a StringBuilder buffer.
 | Encode(StringBuilder, Guid) | Static method to marshall a guid into a StringBuilder buffer.
 | Encode(StringBuilder, Int32) | Static method to marshall an integer into a StringBuilder buffer.
 | Encode(StringBuilder, Int64) | Static method to marshall a long into a StringBuilder buffer.
 | Encode(StringBuilder, String) | Static method to marshall a string into a StringBuilder buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiObjectWireProtocol Class
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method

[image] [image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method
MultiObjectWireProtocol Class See Also Send Feedback

Overload List

Name | Description
Encode(StringBuilder) | Static method to marshall a NULL into a StringBuilder buffer.
Encode(StringBuilder, Boolean) | Static method to marshall a boolean into a StringBuilder buffer.
Encode(StringBuilder, DateTime) | Static method to marshall a date/time into a StringBuilder buffer.
Encode(StringBuilder, Double) | Static method to marshall a double into a StringBuilder buffer.
Encode(StringBuilder, Guid) | Static method to marshall a guid into a StringBuilder buffer.
Encode(StringBuilder, Int32) | Static method to marshall an integer into a StringBuilder buffer.
Encode(StringBuilder, Int64) | Static method to marshall a long into a StringBuilder buffer.
Encode(StringBuilder, String) | Static method to marshall a string into a StringBuilder buffer.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a NULL into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the NULL into.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, Boolean)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, Boolean)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a boolean into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    bool d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As Boolean _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..Boolean
The boolean data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, DateTime)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, DateTime)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a date/time into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    DateTime d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As DateTime _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..DateTime
The DateTime data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, Double)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, Double)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a double into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    double d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As Double _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..Double
The double data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, Guid)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, Guid)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a guid into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    Guid d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As Guid _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..Guid
The guid data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, Int32)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, Int32)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall an integer into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    int d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As Integer _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..Int32
The integer data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, Int64)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, Int64)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a long into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    long d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As Long _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..Int64
The integer data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Encode Method (StringBuilder, String)

[image]

IceLib Technical Reference
MultiObjectWireProtocol..::..Encode Method (StringBuilder, String)
MultiObjectWireProtocol Class See Also Send Feedback
Static method to marshall a string into a StringBuilder buffer.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static void Encode(
    StringBuilder buf,
    string d
)
Visual Basic
Public Shared Sub Encode ( _
    buf As StringBuilder, _
    d As String _
)

Parameters

buf
Type: System.Text..::..StringBuilder
The StringBuilder buffer to marshall the data into.
d
Type: System..::..String
The string data to be marshalled into the buffer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultiObjectWireProtocol Class
MultiObjectWireProtocol Members
Encode Overload
ININ.IceLib.Data.TransactionBuilder Namespace


ParameterDataType Enumeration

[image]

IceLib Technical Reference
ParameterDataType Enumeration
See Also Send Feedback
Specifies constants indicating the data type of a transaction parameter.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ParameterDataType
Visual Basic
Public Enumeration ParameterDataType

Members

Member name | Value | Description
Integer | 0 | An integer.
IntegerNull | 1 | A nullNothingnullptra null reference (Nothing in Visual Basic) integer.
RowCountInteger | 2 | A row count integer.
RowCountIntegerNull | 3 | A nullNothingnullptra null reference (Nothing in Visual Basic) row count integer.
Boolean | 4 | A bool.
BooleanNull | 5 | A nullNothingnullptra null reference (Nothing in Visual Basic) bool.
String | 6 | A string.
StringNull | 7 | A nullNothingnullptra null reference (Nothing in Visual Basic) string.
Real | 8 | A double.
RealNull | 9 | A nullNothingnullptra null reference (Nothing in Visual Basic) double.
DateTime | 10 | A datetime.
DateTimeNull | 11 | A nullNothingnullptra null reference (Nothing in Visual Basic) datetime.
Guid | 12 | A Guid.
GuidNull | 13 | A nullNothingnullptra null reference (Nothing in Visual Basic) Guid.

Remarks

This enumeration is used by TransactionClient during a transaction execution to specify the data type of its transaction parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Data.TransactionBuilder Namespace


ParameterType Enumeration

[image]

IceLib Technical Reference
ParameterType Enumeration
See Also Send Feedback
Specifies constants indicating the type of a transaction parameter.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ParameterType
Visual Basic
Public Enumeration ParameterType

Members

Member name | Value | Description
In | 0 | An input.
Out | 1 | An output.
InOut | 2 | An input/output.
Return | 3 | A return code.

Remarks

This enumeration is used by TransactionClient during a transaction execution to specify the type of its transaction parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatusCompletedEventArgs Class

[image]

IceLib Technical Reference
QueryTransactionStatusCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the QueryTransactionStatusAsync(String, EventHandler<(Of <<'(QueryTransactionStatusCompletedEventArgs>)>>), Object) completedCallback delegate.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueryTransactionStatusCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class QueryTransactionStatusCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Data.TransactionBuilder..::..QueryTransactionStatusCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

QueryTransactionStatusCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatusCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
QueryTransactionStatusCompletedEventArgs Members
QueryTransactionStatusCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The QueryTransactionStatusCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueryTransactionStatusCompletedEventArgs | Initializes a new instance of the QueryTransactionStatusCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TransactionStatus | Gets a value indicating the status of the transaction.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryTransactionStatusCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatusCompletedEventArgs Constructor

[image]

IceLib Technical Reference
QueryTransactionStatusCompletedEventArgs Constructor
QueryTransactionStatusCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the QueryTransactionStatusCompletedEventArgs class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueryTransactionStatusCompletedEventArgs(
    TransactionStatus transactionStatus,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    transactionStatus As TransactionStatus, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

transactionStatus
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionStatus
The status of the transaction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | transactionStatus is not a valid TransactionStatus enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

QueryTransactionStatusCompletedEventArgs Class
QueryTransactionStatusCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatusCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
QueryTransactionStatusCompletedEventArgs Methods
QueryTransactionStatusCompletedEventArgs Class See Also Send Feedback

The QueryTransactionStatusCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryTransactionStatusCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatusCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
QueryTransactionStatusCompletedEventArgs Properties
QueryTransactionStatusCompletedEventArgs Class See Also Send Feedback

The QueryTransactionStatusCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TransactionStatus | Gets a value indicating the status of the transaction.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryTransactionStatusCompletedEventArgs Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionStatus Property

[image]

IceLib Technical Reference
QueryTransactionStatusCompletedEventArgs..::..TransactionStatus Property
QueryTransactionStatusCompletedEventArgs Class See Also Send Feedback
Gets a value indicating the status of the transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionStatus TransactionStatus { get; private set; }
Visual Basic
Public Property TransactionStatus As TransactionStatus
    Get
    Private Set

Field Value

The transaction status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

QueryTransactionStatusCompletedEventArgs Class
QueryTransactionStatusCompletedEventArgs Members
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Class

[image]

IceLib Technical Reference
RecordNotFoundException Class
Members See Also Send Feedback
Represents a RecordNotFound error.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecordNotFoundException : IceLibException
Visual Basic
Public Class RecordNotFoundException _
    Inherits IceLibException

Remarks

Throw this exception when a requested data record cannot be found.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Data.TransactionBuilder..::..RecordNotFoundException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecordNotFoundException Members
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Members

[image] [image]

IceLib Technical Reference
RecordNotFoundException Members
RecordNotFoundException Class Constructors Methods Properties Events See Also Send Feedback

The RecordNotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | RecordNotFoundException()()()() | Initializes a new instance of the RecordNotFoundException class.
Public method | RecordNotFoundException(CultureInfo) | Initializes a new instance of the RecordNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RecordNotFoundException Class
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Constructor

[image] [image]

IceLib Technical Reference
RecordNotFoundException Constructor
RecordNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordNotFoundException()()()() | Initializes a new instance of the RecordNotFoundException class.
Public method | RecordNotFoundException(CultureInfo) | Initializes a new instance of the RecordNotFoundException class.

See Also

RecordNotFoundException Class
RecordNotFoundException Members
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Constructor

[image]

IceLib Technical Reference
RecordNotFoundException Constructor
RecordNotFoundException Class See Also Send Feedback
Initializes a new instance of the RecordNotFoundException class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecordNotFoundException()
Visual Basic
Public Sub New

Remarks

Loads the localized error string and passes it to the base constructor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecordNotFoundException Class
RecordNotFoundException Members
RecordNotFoundException Overload
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Constructor (CultureInfo)

[image]

IceLib Technical Reference
RecordNotFoundException Constructor (CultureInfo)
RecordNotFoundException Class See Also Send Feedback
Initializes a new instance of the RecordNotFoundException class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecordNotFoundException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Remarks

Loads the localized error string and passes it to the base constructor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecordNotFoundException Class
RecordNotFoundException Members
RecordNotFoundException Overload
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Methods

[image] [image]

IceLib Technical Reference
RecordNotFoundException Methods
RecordNotFoundException Class See Also Send Feedback

The RecordNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RecordNotFoundException Class
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Properties

[image] [image]

IceLib Technical Reference
RecordNotFoundException Properties
RecordNotFoundException Class See Also Send Feedback

The RecordNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RecordNotFoundException Class
ININ.IceLib.Data.TransactionBuilder Namespace


RecordNotFoundException Events

[image] [image]

IceLib Technical Reference
RecordNotFoundException Events
RecordNotFoundException Class See Also Send Feedback

The RecordNotFoundException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RecordNotFoundException Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Class

[image]

IceLib Technical Reference
TransactionClient Class
Members See Also Send Feedback
Provides the communication layer between .NET Client applications and Transaction Server.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TransactionClient
Visual Basic
Public Class TransactionClient

Remarks

TransactionClient uses IceLib's Session to pass data back and forth to Session Manager, which in turn uses Notifier to pass data back and forth to Transaction Server. TransactionClient supports both synchronous and asynchronous operations. To execute a transaction synchronously, use Execute(TransactionData%). To execute a transaction asynchronously, use ExecuteAsync(TransactionData, EventHandler<(Of <<'(ExecuteCompletedEventArgs>)>>), Object).

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..TransactionClient

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Members

[image] [image]

IceLib Technical Reference
TransactionClient Members
TransactionClient Class Constructors Methods Properties See Also Send Feedback

The TransactionClient type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionClient(Session) | Creates a new instance of the TransactionClient class.
Public method | TransactionClient(TransactionManager) | Initializes a new instance of the TransactionClient class.

Methods

 | Name | Description
Public method | BeginExecute | Begins an asynchronous request to execute a transaction.
Public method | EndExecute | Ends a pending asynchronous request to execute a transaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes a transaction synchronously. Caller is blocked until results are returned from the transaction execution.
Public method | ExecuteAsync | Asynchronously executes a transaction.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultConnectionInformation | Retrieves the default Tracker ConnectionInformation for the Session.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataFormatErrorString | Accessor-only property that will return the localized data format error string.
Public property | LastError | Property for accessing or modifying the last error that occurred while executing a transaction or processing the results.
Public property | ReportParameterInvalidDataTypeString | Accessor-only property that will return the localized report parameter invalid data type error string.
Public property | TransactionExecutionErrorString | Accessor-only property that will return the localized transaction execution error string.
Public property | TransactionSettingsGlobalScope | Accessor-only property that will return the global scope TransactionSettings object.
Public property | TransactionSettingsTransactionScope | Accessor-only property that will return the transaction scope TransactionSettings object.

See Also

TransactionClient Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Constructor

[image] [image]

IceLib Technical Reference
TransactionClient Constructor
TransactionClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransactionClient(Session) | Creates a new instance of the TransactionClient class.
Public method | TransactionClient(TransactionManager) | Initializes a new instance of the TransactionClient class.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Constructor (Session)

[image]

IceLib Technical Reference
TransactionClient Constructor (Session)
TransactionClient Class See Also Send Feedback
Creates a new instance of the TransactionClient class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionClient(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
IceLib Session used for communication with Session Manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
TransactionClient Overload
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Constructor (TransactionManager)

[image]

IceLib Technical Reference
TransactionClient Constructor (TransactionManager)
TransactionClient Class See Also Send Feedback
Initializes a new instance of the TransactionClient class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionClient(
    TransactionManager transactionManager
)
Visual Basic
Public Sub New ( _
    transactionManager As TransactionManager _
)

Parameters

transactionManager
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionManager
The transaction manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionClient Class
TransactionClient Members
TransactionClient Overload
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Methods

[image] [image]

IceLib Technical Reference
TransactionClient Methods
TransactionClient Class See Also Send Feedback

The TransactionClient type exposes the following members.

Methods

 | Name | Description
Public method | BeginExecute | Begins an asynchronous request to execute a transaction.
Public method | EndExecute | Ends a pending asynchronous request to execute a transaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes a transaction synchronously. Caller is blocked until results are returned from the transaction execution.
Public method | ExecuteAsync | Asynchronously executes a transaction.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultConnectionInformation | Retrieves the default Tracker ConnectionInformation for the Session.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionClient Class
ININ.IceLib.Data.TransactionBuilder Namespace


BeginExecute Method

[image]

IceLib Technical Reference
TransactionClient..::..BeginExecute Method
TransactionClient Class See Also Send Feedback
Begins an asynchronous request to execute a transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IAsyncResult BeginExecute(
    TransactionData data,
    AsyncCallback callback,
    Object state
)
Visual Basic
Public Function BeginExecute ( _
    data As TransactionData, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

data
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionData
A TransactionData object that holds information about the transaction being executed.
callback
Type: System..::..AsyncCallback
The AsyncCallback delegate.
state
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Return Value

An IAsyncResult that references the asynchronous operation.

Remarks

Public method to initiate the execution of a transaction in a non-blocking fashion.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


EndExecute Method

[image]

IceLib Technical Reference
TransactionClient..::..EndExecute Method
TransactionClient Class See Also Send Feedback
Ends a pending asynchronous request to execute a transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool EndExecute(
    IAsyncResult result,
    out TransactionData data
)
Visual Basic
Public Function EndExecute ( _
    result As IAsyncResult, _
    <OutAttribute> ByRef data As TransactionData _
) As Boolean

Parameters

result
Type: System..::..IAsyncResult
An IAsyncResult that stores state information and any user defined data for this asynchronous operation.
data
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionData %
A TransactionData object that holds information about the transaction being executed.

Return Value

trueTruetruetrue (True in Visual Basic) if the transaction was executed successfully; falseFalsefalsefalse (False in Visual Basic) otherwise.

Remarks

Call this to end an asynchronous operation.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The actual type of the result parameter is not the appropriate type for this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


Execute Method

[image]

IceLib Technical Reference
TransactionClient..::..Execute Method
TransactionClient Class See Also Send Feedback
Executes a transaction synchronously. Caller is blocked until results are returned from the transaction execution.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Execute(
    ref TransactionData transactionData
)
Visual Basic
Public Function Execute ( _
    ByRef transactionData As TransactionData _
) As Boolean

Parameters

transactionData
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionData %
A TransactionData object that holds information about the transaction being executed.

Return Value

trueTruetruetrue (True in Visual Basic) if the transaction completed successfully; falseFalsefalsefalse (False in Visual Basic) otherwise.

Remarks

See ResultSet for an explanation of how transaction information is populated in the transactionData parameter. If the CompletedAction is set, then the transaction data will not be available until the CompletedAction is invoked. When ForceOutOfBand is set to true, and the CompletedAction is set, the TransactionToken will be set when this method returns, and can be used in conjunction with CancelTransaction(String), CancelTransactionAsync(String, EventHandler<(Of <<'(CancelTransactionCompletedEventArgs>)>>), Object), QueryTransactionStatus(String) or QueryTransactionStatus(String) to cancel or track the status of the transaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


ExecuteAsync Method

[image]

IceLib Technical Reference
TransactionClient..::..ExecuteAsync Method
TransactionClient Class See Also Send Feedback
Asynchronously executes a transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ExecuteAsync(
    TransactionData transactionData,
    EventHandler<ExecuteCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ExecuteAsync ( _
    transactionData As TransactionData, _
    completedCallback As EventHandler(Of ExecuteCompletedEventArgs), _
    userState As Object _
)

Parameters

transactionData
Type: ININ.IceLib.Data.TransactionBuilder..::..TransactionData
A TransactionData object that holds information about the transaction being executed.
completedCallback
Type: System..::..EventHandler<(Of <(<' ExecuteCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

See ResultSet for an explanation of how transaction information is populated in the transactionData parameter.

If the CompletedAction is set, then the transaction data will not be available until the CompletedAction is invoked. When ForceOutOfBand is set to true, and the CompletedAction is set, the TransactionToken will be set when the completedCallback is invoked, and can be used in conjunction with CancelTransaction(String), CancelTransactionAsync(String, EventHandler<(Of <<'(CancelTransactionCompletedEventArgs>)>>), Object), QueryTransactionStatus(String) or QueryTransactionStatus(String) to cancel or track the status of the transaction.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


GetDefaultConnectionInformation Method

[image]

IceLib Technical Reference
TransactionClient..::..GetDefaultConnectionInformation Method
TransactionClient Class See Also Send Feedback
Retrieves the default Tracker ConnectionInformation for the Session.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetDefaultConnectionInformation()
Visual Basic
Public Function GetDefaultConnectionInformation As String

Return Value

The default connection information.

Remarks

GetDefaultConnectionInformation() retrieves the value from the IC server based on the Session that the TransactionClient was instantiated against, or uses the cached value if it has already been retrieved.

This method will be invoked automatically for any transaction that has only a ConnectionInformation value of TransactionSettingDefaults.ConnectionInformation for both the transaction and global settings of the TransactionClient.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionClient Properties

[image] [image]

IceLib Technical Reference
TransactionClient Properties
TransactionClient Class See Also Send Feedback

The TransactionClient type exposes the following members.

Properties

 | Name | Description
Public property | DataFormatErrorString | Accessor-only property that will return the localized data format error string.
Public property | LastError | Property for accessing or modifying the last error that occurred while executing a transaction or processing the results.
Public property | ReportParameterInvalidDataTypeString | Accessor-only property that will return the localized report parameter invalid data type error string.
Public property | TransactionExecutionErrorString | Accessor-only property that will return the localized transaction execution error string.
Public property | TransactionSettingsGlobalScope | Accessor-only property that will return the global scope TransactionSettings object.
Public property | TransactionSettingsTransactionScope | Accessor-only property that will return the transaction scope TransactionSettings object.

See Also

TransactionClient Class
ININ.IceLib.Data.TransactionBuilder Namespace


DataFormatErrorString Property

[image]

IceLib Technical Reference
TransactionClient..::..DataFormatErrorString Property
TransactionClient Class See Also Send Feedback
Accessor-only property that will return the localized data format error string.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DataFormatErrorString { get; }
Visual Basic
Public ReadOnly Property DataFormatErrorString As String
    Get

Field Value

The data format error string.

Remarks

This string is used by generated code to display an error string indicating that the result string from the Transaction Server contained a format error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


LastError Property

[image]

IceLib Technical Reference
TransactionClient..::..LastError Property
TransactionClient Class See Also Send Feedback
Property for accessing or modifying the last error that occurred while executing a transaction or processing the results.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastError { get; set; }
Visual Basic
Public Property LastError As String
    Get
    Set

Field Value

The last error.

Remarks

This string is used by generated code to display an error string indicating the last error that occurred. This is a non-localized string that comes directly from the TransactionServer.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


ReportParameterInvalidDataTypeString Property

[image]

IceLib Technical Reference
TransactionClient..::..ReportParameterInvalidDataTypeString Property
TransactionClient Class See Also Send Feedback
Accessor-only property that will return the localized report parameter invalid data type error string.

Note: This property is supported for IC Server version 2016 R2 and beyond.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ReportParameterInvalidDataTypeString { get; }
Visual Basic
Public ReadOnly Property ReportParameterInvalidDataTypeString As String
    Get

Field Value

The report parameter error string.

Remarks

This string is used by generated code to display an error string indicating that an error occurred during transaction execution.

Version Information

Supported for IC Server version 2016 R2 and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionExecutionErrorString Property

[image]

IceLib Technical Reference
TransactionClient..::..TransactionExecutionErrorString Property
TransactionClient Class See Also Send Feedback
Accessor-only property that will return the localized transaction execution error string.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TransactionExecutionErrorString { get; }
Visual Basic
Public ReadOnly Property TransactionExecutionErrorString As String
    Get

Field Value

The transaction execution error string.

Remarks

This string is used by generated code to display an error string indicating that an error occurred during transaction execution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettingsGlobalScope Property

[image]

IceLib Technical Reference
TransactionClient..::..TransactionSettingsGlobalScope Property
TransactionClient Class See Also Send Feedback
Accessor-only property that will return the global scope TransactionSettings object.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionSettings TransactionSettingsGlobalScope { get; }
Visual Basic
Public ReadOnly Property TransactionSettingsGlobalScope As TransactionSettings
    Get

Field Value

The transaction settings global scope.

Remarks

This is where the global transaction settings are stored. These settings will be included in the request string that is sent to the Transaction Server only if they have not be overridden by settings in the TransactionSettingsTransactionScope property. They will persist for all transactions being executed by a particular TransactionClient object. If you want to change transaction settings for a particular transaction, use the TransactionSettingsTransactionScope property

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettingsTransactionScope Property

[image]

IceLib Technical Reference
TransactionClient..::..TransactionSettingsTransactionScope Property
TransactionClient Class See Also Send Feedback
Accessor-only property that will return the transaction scope TransactionSettings object.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionSettings TransactionSettingsTransactionScope { get; }
Visual Basic
Public ReadOnly Property TransactionSettingsTransactionScope As TransactionSettings
    Get

Field Value

The transaction settings transaction scope.

Remarks

This is where any temporary transaction settings are stored. These settings will be included in the request string that is sent to the Transaction Server only if they have overridden the settings in the TransactionSettingsGlobalScope property. The transaction settings contained in the TransactionSettingsTransactionScope property are cleared by the generated code after each transaction execution. If you want to set transaction settings that will persist for all transactions being executed by a particular TransactionClient object, use the TransactionSettingsGlobalScope property

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionClient Class
TransactionClient Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionData Class

[image]

IceLib Technical Reference
TransactionData Class
Members See Also Send Feedback
Contains the configurable settings that a TransactionClient uses when communicating with Transaction Server.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TransactionData : IDisposable
Visual Basic
Public Class TransactionData _
    Implements IDisposable

Remarks

This class is used during the construction of the request string that is sent to the Transaction Server. It contains information that is necessary for the execution of transactions. The defaults are recommended in most cases.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..TransactionData

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionData Members

[image] [image]

IceLib Technical Reference
TransactionData Members
TransactionData Class Constructors Methods Properties See Also Send Feedback

The TransactionData type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionData | Initializes a new instance of the TransactionData class.

Methods

 | Name | Description
Public method | Clone | Makes a copy of this transaction data.
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases the resources used by the Session.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CompletedAction | Gets or sets the completed action to be called when the transaction results are available.
Public property | ForceOutOfBand | Gets or sets a value indicating whether to force receiving the transaction results "out of band".
Public property | Parameters | Gets the Parameters.
Public property | ProcedureName | Gets or sets ProcedureName.
Public property | ResultSet | Gets the ResultSet.
Public property | ReturnCode | Gets or sets ReturnCode.
Public property | TransactionName | Gets or sets TransactionName.
Public property | TransactionToken | Gets the transaction token associated with this TransactionData.
Public property | UserState | Gets or sets extended data to be stored on the transaction data.
Public property | WarningMessage | Gets or sets WarningMessage.
Public property | WasOutOfBandUsed | Gets a value indicating whether the transaction results were sent "out of band".

See Also

TransactionData Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionData Constructor

[image]

IceLib Technical Reference
TransactionData Constructor
TransactionData Class See Also Send Feedback
Initializes a new instance of the TransactionData class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionData()
Visual Basic
Public Sub New

Remarks

Constructs a TransactionData object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionData Methods

[image] [image]

IceLib Technical Reference
TransactionData Methods
TransactionData Class See Also Send Feedback

The TransactionData type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Makes a copy of this transaction data.
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases the resources used by the Session.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

TransactionData Class
ININ.IceLib.Data.TransactionBuilder Namespace


Clone Method

[image]

IceLib Technical Reference
TransactionData..::..Clone Method
TransactionData Class See Also Send Feedback
Makes a copy of this transaction data.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionData Clone()
Visual Basic
Public Function Clone As TransactionData

Return Value

A copy of this transaction data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
TransactionData..::..Dispose Method
TransactionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Releases the resources used by the Session.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


Dispose Method

[image]

IceLib Technical Reference
TransactionData..::..Dispose Method
TransactionData Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
Dispose Overload
ININ.IceLib.Data.TransactionBuilder Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
TransactionData..::..Dispose Method (Boolean)
TransactionData Class See Also Send Feedback
Releases the resources used by the Session.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the object is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
Dispose Overload
ININ.IceLib.Data.TransactionBuilder Namespace


ToString Method

[image]

IceLib Technical Reference
TransactionData..::..ToString Method
TransactionData Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionData Properties

[image] [image]

IceLib Technical Reference
TransactionData Properties
TransactionData Class See Also Send Feedback

The TransactionData type exposes the following members.

Properties

 | Name | Description
Public property | CompletedAction | Gets or sets the completed action to be called when the transaction results are available.
Public property | ForceOutOfBand | Gets or sets a value indicating whether to force receiving the transaction results "out of band".
Public property | Parameters | Gets the Parameters.
Public property | ProcedureName | Gets or sets ProcedureName.
Public property | ResultSet | Gets the ResultSet.
Public property | ReturnCode | Gets or sets ReturnCode.
Public property | TransactionName | Gets or sets TransactionName.
Public property | TransactionToken | Gets the transaction token associated with this TransactionData.
Public property | UserState | Gets or sets extended data to be stored on the transaction data.
Public property | WarningMessage | Gets or sets WarningMessage.
Public property | WasOutOfBandUsed | Gets a value indicating whether the transaction results were sent "out of band".

See Also

TransactionData Class
ININ.IceLib.Data.TransactionBuilder Namespace


CompletedAction Property

[image]

IceLib Technical Reference
TransactionData..::..CompletedAction Property
TransactionData Class See Also Send Feedback
Gets or sets the completed action to be called when the transaction results are available.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Action<ExecuteCompletedEventArgs> CompletedAction { get; set; }
Visual Basic
Public Property CompletedAction As Action(Of ExecuteCompletedEventArgs)
    Get
    Set

Field Value

The completed action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


ForceOutOfBand Property

[image]

IceLib Technical Reference
TransactionData..::..ForceOutOfBand Property
TransactionData Class See Also Send Feedback
Gets or sets a value indicating whether to force receiving the transaction results "out of band".

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ForceOutOfBand { get; set; }
Visual Basic
Public Property ForceOutOfBand As Boolean
    Get
    Set

Field Value

true if to force to receive transaction results "out of band"; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


Parameters Property

[image]

IceLib Technical Reference
TransactionData..::..Parameters Property
TransactionData Class See Also Send Feedback
Gets the Parameters.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<TransactionParameter> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Collection(Of TransactionParameter)
    Get

Field Value

The parameters.

Remarks

The Parameters property allows access to the list of parameters that are used for a transaction. Before a transaction is executed, a list of Parameters is constructed according to the requirements of that particular transaction. The list is contained in the TransactionData object that is passed to either the Execute(TransactionData%) method or the ExecuteAsync(TransactionData, EventHandler<(Of <<'(ExecuteCompletedEventArgs>)>>), Object) method. This list of parameters is also included in the request string that is sent to Transaction Server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


ProcedureName Property

[image]

IceLib Technical Reference
TransactionData..::..ProcedureName Property
TransactionData Class See Also Send Feedback
Gets or sets ProcedureName.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProcedureName { get; set; }
Visual Basic
Public Property ProcedureName As String
    Get
    Set

Field Value

The name of the procedure.

Remarks

The ProcedureName is the name of the stored procedure that will be executed by Transaction Server.

The TransactionName and ProcedureName properties are currently sent in the wrong order to the IC Server. In order to get the desired results when calling Execute(TransactionData%), ExecuteAsync(TransactionData, EventHandler<(Of <<'(ExecuteCompletedEventArgs>)>>), Object), or BeginExecute(TransactionData, AsyncCallback, Object), these 2 parameter values should be swapped so that the TransactionName property has the stored procedure name, and the ProcedureName property has the transaction name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


ResultSet Property

[image]

IceLib Technical Reference
TransactionData..::..ResultSet Property
TransactionData Class See Also Send Feedback
Gets the ResultSet.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DataSet ResultSet { get; }
Visual Basic
Public ReadOnly Property ResultSet As DataSet
    Get

Field Value

The result set.

Remarks

ResultSet contains the data that is returned after the execution of a transaction.
Note

All Out, InOut, and Return parameter data is returned in Tables[0] with the following columns:

Ordinal Position, Include Metadata, DataType, Value, Name, Parameter Type, Db Type, Db Type Name, Size, Radix, Nullable, and Remarks

Columns Name through Remarks are all metadata columns. If Include Metadata is not equal to "1" these columns will have the value Empty.

Ordinal Position is the ordinal position in the Parameters list including In parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


ReturnCode Property

[image]

IceLib Technical Reference
TransactionData..::..ReturnCode Property
TransactionData Class See Also Send Feedback
Gets or sets ReturnCode.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ReturnCode { get; set; }
Visual Basic
Public Property ReturnCode As Integer
    Get
    Set

Field Value

The return code.

Remarks

This is the return code of the transaction upon being executed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionName Property

[image]

IceLib Technical Reference
TransactionData..::..TransactionName Property
TransactionData Class See Also Send Feedback
Gets or sets TransactionName.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TransactionName { get; set; }
Visual Basic
Public Property TransactionName As String
    Get
    Set

Field Value

The name of the transaction.

Remarks

The TransactionName can be any string.

The TransactionName and ProcedureName properties are currently sent in the wrong order to the IC Server. In order to get the desired results when calling Execute(TransactionData%), ExecuteAsync(TransactionData, EventHandler<(Of <<'(ExecuteCompletedEventArgs>)>>), Object), or BeginExecute(TransactionData, AsyncCallback, Object), these 2 parameter values should be swapped so that the TransactionName property has the stored procedure name, and the ProcedureName property has the transaction name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionToken Property

[image]

IceLib Technical Reference
TransactionData..::..TransactionToken Property
TransactionData Class See Also Send Feedback
Gets the transaction token associated with this TransactionData.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TransactionToken { get; internal set; }
Visual Basic
Public Property TransactionToken As String
    Get
    Friend Set

Field Value

The transaction token.

Remarks

The transaction token can be used to with the CancelTransaction(String), CancelTransactionAsync(String, EventHandler<(Of <<'(CancelTransactionCompletedEventArgs>)>>), Object), QueryTransactionStatus(String) and QueryTransactionStatusAsync(String, EventHandler<(Of <<'(QueryTransactionStatusCompletedEventArgs>)>>), Object) methods.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


UserState Property

[image]

IceLib Technical Reference
TransactionData..::..UserState Property
TransactionData Class See Also Send Feedback
Gets or sets extended data to be stored on the transaction data.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object UserState { get; set; }
Visual Basic
Public Property UserState As Object
    Get
    Set

Field Value

The extended data to be stored.

Remarks

This object will be copied to the TransactionData clone for the CompletedAction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


WarningMessage Property

[image]

IceLib Technical Reference
TransactionData..::..WarningMessage Property
TransactionData Class See Also Send Feedback
Gets or sets WarningMessage.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WarningMessage { get; set; }
Visual Basic
Public Property WarningMessage As String
    Get
    Set

Field Value

The warning message.

Remarks

The WarningMessage is a string containing the warning message returned from Transaction Server in the event of a transaction execution failure. It will give details (in a non-localized string) as to why the transaction execution failed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


WasOutOfBandUsed Property

[image]

IceLib Technical Reference
TransactionData..::..WasOutOfBandUsed Property
TransactionData Class See Also Send Feedback
Gets a value indicating whether the transaction results were sent "out of band".

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool WasOutOfBandUsed { get; internal set; }
Visual Basic
Public Property WasOutOfBandUsed As Boolean
    Get
    Friend Set

Field Value

true if the transaction results were sent "out of band"; otherwise, false.

Remarks

If true, then the TransactionToken value can be used in conjunction with the CancelTransaction(String), CancelTransactionAsync(String, EventHandler<(Of <<'(CancelTransactionCompletedEventArgs>)>>), Object), QueryTransactionStatus(String) and QueryTransactionStatusAsync(String, EventHandler<(Of <<'(QueryTransactionStatusCompletedEventArgs>)>>), Object) methods.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionData Class
TransactionData Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionIsolationType Enumeration

[image]

IceLib Technical Reference
TransactionIsolationType Enumeration
See Also Send Feedback
Specifies constants indicating the isolation type of a transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum TransactionIsolationType
Visual Basic
Public Enumeration TransactionIsolationType

Members

Member name | Value | Description
Default | 0 | Default.
ReadUncommitted | 1 | Read uncommitted.
ReadCommitted | 2 | Read committed.
RepeatableRead | 3 | Repeatable read.
Serializable | 4 | Serializable.

Remarks

This enumeration is used by TransactionClient during transaction execution to specify the transaction isolation type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Data.TransactionBuilder Namespace


TransactionManager Class

[image]

IceLib Technical Reference
TransactionManager Class
Members See Also Send Feedback
The TransactionManager class provides methods to interact with transactions executed from a TransactionClient instance.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TransactionManager
Visual Basic
Public Class TransactionManager

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..TransactionManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionManager Members

[image] [image]

IceLib Technical Reference
TransactionManager Members
TransactionManager Class Methods Properties See Also Send Feedback

The TransactionManager type exposes the following members.

Methods

 | Name | Description
Public method | CancelTransaction | Cancels the transaction associated with the supplied transaction token.
Public method | CancelTransactionAsync | Asynchronously cancels the transaction associated with the supplied transaction token.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a TransactionManager for the Session passed in.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryTransactionStatus | Queries the transaction status associated with the supplied transaction token.
Public method | QueryTransactionStatusAsync | Asynchronously queries the transaction status associated with the supplied transaction token.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Session | Gets the Session with which this TransactionManager is associated.

See Also

TransactionManager Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionManager Methods

[image] [image]

IceLib Technical Reference
TransactionManager Methods
TransactionManager Class See Also Send Feedback

The TransactionManager type exposes the following members.

Methods

 | Name | Description
Public method | CancelTransaction | Cancels the transaction associated with the supplied transaction token.
Public method | CancelTransactionAsync | Asynchronously cancels the transaction associated with the supplied transaction token.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a TransactionManager for the Session passed in.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryTransactionStatus | Queries the transaction status associated with the supplied transaction token.
Public method | QueryTransactionStatusAsync | Asynchronously queries the transaction status associated with the supplied transaction token.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionManager Class
ININ.IceLib.Data.TransactionBuilder Namespace


CancelTransaction Method

[image]

IceLib Technical Reference
TransactionManager..::..CancelTransaction Method
TransactionManager Class See Also Send Feedback
Cancels the transaction associated with the supplied transaction token.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelTransaction(
    string transactionToken
)
Visual Basic
Public Sub CancelTransaction ( _
    transactionToken As String _
)

Parameters

transactionToken
Type: System..::..String
The transaction token associated with the transaction to cancel.

Remarks

The CompletedAction should be set and will be raised when the transaction is cancelled. When raised, the Cancelled property of the ExecuteCompletedEventArgs instance will be set to trueTruetruetrue (True in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Class
TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


CancelTransactionAsync Method

[image]

IceLib Technical Reference
TransactionManager..::..CancelTransactionAsync Method
TransactionManager Class See Also Send Feedback
Asynchronously cancels the transaction associated with the supplied transaction token.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelTransactionAsync(
    string transactionToken,
    EventHandler<CancelTransactionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CancelTransactionAsync ( _
    transactionToken As String, _
    completedCallback As EventHandler(Of CancelTransactionCompletedEventArgs), _
    userState As Object _
)

Parameters

transactionToken
Type: System..::..String
The transaction token associated with the transaction to cancel.
completedCallback
Type: System..::..EventHandler<(Of <(<' CancelTransactionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

The CompletedAction should be set and will be raised when the transaction is cancelled. When raised, the Cancelled property of the ExecuteCompletedEventArgs instance will be set to trueTruetruetrue (True in Visual Basic).

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Class
TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


GetInstance Method

[image]

IceLib Technical Reference
TransactionManager..::..GetInstance Method
TransactionManager Class See Also Send Feedback
Gets a TransactionManager for the Session passed in.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static TransactionManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As TransactionManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which the TransactionManager is associated.

Return Value

The TransactionManager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Class
TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatus Method

[image]

IceLib Technical Reference
TransactionManager..::..QueryTransactionStatus Method
TransactionManager Class See Also Send Feedback
Queries the transaction status associated with the supplied transaction token.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionStatus QueryTransactionStatus(
    string transactionToken
)
Visual Basic
Public Function QueryTransactionStatus ( _
    transactionToken As String _
) As TransactionStatus

Parameters

transactionToken
Type: System..::..String
The transaction token associated with the transaction to query.

Return Value

A TransactionStatus value representing the state of the transaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Class
TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


QueryTransactionStatusAsync Method

[image]

IceLib Technical Reference
TransactionManager..::..QueryTransactionStatusAsync Method
TransactionManager Class See Also Send Feedback
Asynchronously queries the transaction status associated with the supplied transaction token.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void QueryTransactionStatusAsync(
    string transactionToken,
    EventHandler<QueryTransactionStatusCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub QueryTransactionStatusAsync ( _
    transactionToken As String, _
    completedCallback As EventHandler(Of QueryTransactionStatusCompletedEventArgs), _
    userState As Object _
)

Parameters

transactionToken
Type: System..::..String
The transaction token associated with the transaction to query.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryTransactionStatusCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Class
TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionManager Properties

[image] [image]

IceLib Technical Reference
TransactionManager Properties
TransactionManager Class See Also Send Feedback

The TransactionManager type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session with which this TransactionManager is associated.

See Also

TransactionManager Class
ININ.IceLib.Data.TransactionBuilder Namespace


Session Property

[image]

IceLib Technical Reference
TransactionManager..::..Session Property
TransactionManager Class See Also Send Feedback
Gets the Session with which this TransactionManager is associated.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionManager Class
TransactionManager Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionParameter Class

[image]

IceLib Technical Reference
TransactionParameter Class
Members See Also Send Feedback
Represents a parameter that is used for executing transactions. Each transaction can have multiple transaction parameters.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TransactionParameter
Visual Basic
Public Class TransactionParameter

Remarks

Contains a ParameterType (input, output, result set, etc.), a ParameterDataType (integer, string, etc.) and a (string) Value.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..TransactionParameter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionParameter Members

[image] [image]

IceLib Technical Reference
TransactionParameter Members
TransactionParameter Class Constructors Methods Properties See Also Send Feedback

The TransactionParameter type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionParameter | Initializes a new instance of the TransactionParameter class.

Methods

 | Name | Description
Public method | Clone | Makes a copy of this transaction parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNull | Sets DataType to the null type that corresponds to the current DataType.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DataType | Gets or sets the ParameterDataType.
Public property | Type | Gets or sets the ParameterType.
Public property | Value | Gets or sets the value.

See Also

TransactionParameter Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionParameter Constructor

[image]

IceLib Technical Reference
TransactionParameter Constructor
TransactionParameter Class See Also Send Feedback
Initializes a new instance of the TransactionParameter class.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionParameter()
Visual Basic
Public Sub New

Remarks

Only constructor provided.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionParameter Methods

[image] [image]

IceLib Technical Reference
TransactionParameter Methods
TransactionParameter Class See Also Send Feedback

The TransactionParameter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Makes a copy of this transaction parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNull | Sets DataType to the null type that corresponds to the current DataType.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

TransactionParameter Class
ININ.IceLib.Data.TransactionBuilder Namespace


Clone Method

[image]

IceLib Technical Reference
TransactionParameter..::..Clone Method
TransactionParameter Class See Also Send Feedback
Makes a copy of this transaction parameter.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionParameter Clone()
Visual Basic
Public Function Clone As TransactionParameter

Return Value

A copy of this transaction parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


SetNull Method

[image]

IceLib Technical Reference
TransactionParameter..::..SetNull Method
TransactionParameter Class See Also Send Feedback
Sets DataType to the null type that corresponds to the current DataType.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetNull()
Visual Basic
Public Sub SetNull

Remarks

Call this method to change the DataType from Integer to IntegerNull or from String to StringNull, etc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


ToString Method

[image]

IceLib Technical Reference
TransactionParameter..::..ToString Method
TransactionParameter Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionParameter Properties

[image] [image]

IceLib Technical Reference
TransactionParameter Properties
TransactionParameter Class See Also Send Feedback

The TransactionParameter type exposes the following members.

Properties

 | Name | Description
Public property | DataType | Gets or sets the ParameterDataType.
Public property | Type | Gets or sets the ParameterType.
Public property | Value | Gets or sets the value.

See Also

TransactionParameter Class
ININ.IceLib.Data.TransactionBuilder Namespace


DataType Property

[image]

IceLib Technical Reference
TransactionParameter..::..DataType Property
TransactionParameter Class See Also Send Feedback
Gets or sets the ParameterDataType.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterDataType DataType { get; set; }
Visual Basic
Public Property DataType As ParameterDataType
    Get
    Set

Field Value

The data type.

Remarks

Can be any ParameterDataType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


Type Property

[image]

IceLib Technical Reference
TransactionParameter..::..Type Property
TransactionParameter Class See Also Send Feedback
Gets or sets the ParameterType.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterType Type { get; set; }
Visual Basic
Public Property Type As ParameterType
    Get
    Set

Field Value

The type.

Remarks

Can be any ParameterType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


Value Property

[image]

IceLib Technical Reference
TransactionParameter..::..Value Property
TransactionParameter Class See Also Send Feedback
Gets or sets the value.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value.

Remarks

Can be any string value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionParameter Class
TransactionParameter Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionRequestType Enumeration

[image]

IceLib Technical Reference
TransactionRequestType Enumeration
See Also Send Feedback
Specifies constants indicating the request type of a transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum TransactionRequestType
Visual Basic
Public Enumeration TransactionRequestType

Members

Member name | Value | Description
None | 0 | Transaction request type none.
Supported | 1 | Transaction request type supported.
Requires | 2 | Transaction request type requires.
Distributed | 3 | Transaction request type distributed.
RequiresNewDistributed | 4 | Transaction request type requires new distributed.

Remarks

This enumeration is used by TransactionClient during transaction execution to specify the transaction request type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettingDefaults Class

[image]

IceLib Technical Reference
TransactionSettingDefaults Class
Members See Also Send Feedback
Class containing defaults used by TransactionSettings.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class TransactionSettingDefaults
Visual Basic
Public NotInheritable Class TransactionSettingDefaults

Remarks

When a TransactionSettings object is constructed, its members will be initialized using values from this class.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..TransactionSettingDefaults

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettingDefaults Members

[image] [image]

IceLib Technical Reference
TransactionSettingDefaults Members
TransactionSettingDefaults Class Properties See Also Send Feedback

The TransactionSettingDefaults type exposes the following members.

Properties

Name | Description
AdditionalInformation | Gets the default value for additional info.
Asynchronous | Gets the default value for asynchronous.
Catalog | Gets the default value for catalog.
ClientNet | Gets the default value for client net.
ConnectionInformation | Gets the default value for connection information.
FormatVersion | Gets the default value for format version.
IncludeParameterMetadata | Gets the default value for include parameter metadata.
IncludeRowSetMetadata | Gets the default value for include row set metadata.
IsolationType | Gets the default value for isolation type.
Provider | Gets the default value for provider.
ReadOnly | Gets the default value for read only.
RequestType | Gets the default value for request type.
RowLimit | Gets the default value for row limit.
Schema | Gets the default value for schema.
ServerInfo | Gets the default value for server info.
Timeout | Gets the default value for timeout.
TransactionId | Gets the default value for transaction ID.
TransactionServer | Gets the default value for Transaction Server.
UserId | Gets the default value for user ID.

See Also

TransactionSettingDefaults Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettingDefaults Properties

[image] [image]

IceLib Technical Reference
TransactionSettingDefaults Properties
TransactionSettingDefaults Class See Also Send Feedback

The TransactionSettingDefaults type exposes the following members.

Properties

Name | Description
AdditionalInformation | Gets the default value for additional info.
Asynchronous | Gets the default value for asynchronous.
Catalog | Gets the default value for catalog.
ClientNet | Gets the default value for client net.
ConnectionInformation | Gets the default value for connection information.
FormatVersion | Gets the default value for format version.
IncludeParameterMetadata | Gets the default value for include parameter metadata.
IncludeRowSetMetadata | Gets the default value for include row set metadata.
IsolationType | Gets the default value for isolation type.
Provider | Gets the default value for provider.
ReadOnly | Gets the default value for read only.
RequestType | Gets the default value for request type.
RowLimit | Gets the default value for row limit.
Schema | Gets the default value for schema.
ServerInfo | Gets the default value for server info.
Timeout | Gets the default value for timeout.
TransactionId | Gets the default value for transaction ID.
TransactionServer | Gets the default value for Transaction Server.
UserId | Gets the default value for user ID.

See Also

TransactionSettingDefaults Class
ININ.IceLib.Data.TransactionBuilder Namespace


AdditionalInformation Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..AdditionalInformation Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for additional info.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string AdditionalInformation { get; }
Visual Basic
Public Shared ReadOnly Property AdditionalInformation As String
    Get

Field Value

The additional information.

Remarks

Use this property when you want to reset the value of additional info back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


Asynchronous Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..Asynchronous Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for asynchronous.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool Asynchronous { get; }
Visual Basic
Public Shared ReadOnly Property Asynchronous As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if asynchronous; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Use this property when you want to reset the value of asynchronous back to its default.
Note
The asynchronous property of the TransactionSettings class can only be set to the default of falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


Catalog Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..Catalog Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for catalog.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Catalog { get; }
Visual Basic
Public Shared ReadOnly Property Catalog As String
    Get

Field Value

The catalog.

Remarks

Use this property when you want to reset the value of catalog back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


ClientNet Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..ClientNet Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for client net.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ClientNet { get; }
Visual Basic
Public Shared ReadOnly Property ClientNet As String
    Get

Field Value

The client net.

Remarks

Use this property when you want to reset the value of client net back to its default of "{6EC724FF-B9B5-445e-8927-EB329EE35F8E}".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


ConnectionInformation Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..ConnectionInformation Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for connection information.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ConnectionInformation { get; }
Visual Basic
Public Shared ReadOnly Property ConnectionInformation As String
    Get

Field Value

The connection information.

Remarks

Use this property when you want to reset the value of connection information back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


FormatVersion Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..FormatVersion Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for format version.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static int FormatVersion { get; }
Visual Basic
Public Shared ReadOnly Property FormatVersion As Integer
    Get

Field Value

The format version.

Remarks

Use this property when you want to reset the value of FormatVersion back to its default of 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


IncludeParameterMetadata Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..IncludeParameterMetadata Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for include parameter metadata.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool IncludeParameterMetadata { get; }
Visual Basic
Public Shared ReadOnly Property IncludeParameterMetadata As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if should include parameter metadata; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Use this property when you want to reset the value of include parameter metadata back to its default of falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


IncludeRowSetMetadata Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..IncludeRowSetMetadata Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for include row set metadata.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool IncludeRowSetMetadata { get; }
Visual Basic
Public Shared ReadOnly Property IncludeRowSetMetadata As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if should include row set metadata; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Use this property when you want to reset the value of include row set metadata back to its default of falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


IsolationType Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..IsolationType Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for isolation type.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static TransactionIsolationType IsolationType { get; }
Visual Basic
Public Shared ReadOnly Property IsolationType As TransactionIsolationType
    Get

Field Value

The isolation type.

Remarks

Use this property when you want to reset the value of isolation type back to its default of ReadCommitted.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


Provider Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..Provider Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for provider.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Provider { get; }
Visual Basic
Public Shared ReadOnly Property Provider As String
    Get

Field Value

The provider.

Remarks

Use this property when you want to reset the value of provider back to its default of "ININ.I3DBTranSPProvider.1".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


ReadOnly Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..ReadOnly Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for read only.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool ReadOnly { get; }
Visual Basic
Public Shared ReadOnly Property ReadOnly As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if read only; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Use this property when you want to reset the value of read only back to its default of falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


RequestType Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..RequestType Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for request type.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static TransactionRequestType RequestType { get; }
Visual Basic
Public Shared ReadOnly Property RequestType As TransactionRequestType
    Get

Field Value

The type of the request.

Remarks

Use this property when you want to reset the value of request type back to its default of Supported.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


RowLimit Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..RowLimit Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for row limit.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static int RowLimit { get; }
Visual Basic
Public Shared ReadOnly Property RowLimit As Integer
    Get

Field Value

The row limit.

Remarks

Use this property when you want to reset the value of row limit back to its default of 1000.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


Schema Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..Schema Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for schema.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Schema { get; }
Visual Basic
Public Shared ReadOnly Property Schema As String
    Get

Field Value

The schema.

Remarks

Use this property when you want to reset the value of schema back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


ServerInfo Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..ServerInfo Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for server info.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ServerInfo { get; }
Visual Basic
Public Shared ReadOnly Property ServerInfo As String
    Get

Field Value

The server info.

Remarks

Use this property when you want to reset the value of server info back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


Timeout Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..Timeout Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for timeout.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static long Timeout { get; }
Visual Basic
Public Shared ReadOnly Property Timeout As Long
    Get

Field Value

The timeout.

Remarks

Use this property when you want to reset the value of timeout back to its default of 60.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionId Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..TransactionId Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for transaction ID.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string TransactionId { get; }
Visual Basic
Public Shared ReadOnly Property TransactionId As String
    Get

Field Value

The transaction ID.

Remarks

Use this property when you want to reset the value of Transaction ID back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionServer Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..TransactionServer Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for Transaction Server.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string TransactionServer { get; }
Visual Basic
Public Shared ReadOnly Property TransactionServer As String
    Get

Field Value

The transaction server.

Remarks

Use this property when you want to reset the value of Transaction Server back to its default of "TransactionServer".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


UserId Property

[image]

IceLib Technical Reference
TransactionSettingDefaults..::..UserId Property
TransactionSettingDefaults Class See Also Send Feedback
Gets the default value for user ID.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string UserId { get; }
Visual Basic
Public Shared ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Remarks

Use this property when you want to reset the value of user ID back to its default of Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettingDefaults Class
TransactionSettingDefaults Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettings Class

[image]

IceLib Technical Reference
TransactionSettings Class
Members See Also Send Feedback
Contains the settings used for communication with the Transaction Server.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TransactionSettings
Visual Basic
Public Class TransactionSettings

Remarks

A TransactionClient contains a TransactionSettings data member. The values contained within this TransactionSettings are included in the request string that is sent to Transaction Server.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Data.TransactionBuilder..::..TransactionSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettings Members

[image] [image]

IceLib Technical Reference
TransactionSettings Members
TransactionSettings Class Constructors Methods Properties See Also Send Feedback

The TransactionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionSettings | Constructs a TransactionSettings object.

Methods

 | Name | Description
Public method | Clone | Makes a copy of this transaction settings.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | This method sets all transaction settings back to the default settings.
Public method | ToString | Returns a string representation of TransactionSettings. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AdditionalInformation | Gets or sets the additional info for this transaction.
Public property | Asynchronous | Gets asynchronous flag.
Public property | Catalog | Gets or sets the catalog.
Public property | ClientNet | Gets or sets ClientNet.
Public property | ConnectionInformation | Gets or sets the connection information.
Public property | FormatVersion | Gets or sets the format version.
Public property | IncludeParameterMetadata | Gets or sets the include parameter metadata flag.
Public property | IncludeRowSetMetadata | Gets or sets the row set metadata flag.
Public property | IsolationType | Gets or sets the isolation type of this transaction.
Public property | Provider | Gets or sets the provider.
Public property | ReadOnly | Gets or sets the read-only flag.
Public property | RequestType | Gets or sets the request type of this transaction.
Public property | RowLimit | Gets or sets the row limit for this transaction.
Public property | Schema | Gets or sets the schema.
Public property | ServerInfo | Gets or sets the server info for this transaction.
Public property | Timeout | Gets or sets the timeout (in seconds).
Public property | TransactionId | Gets or sets the transaction ID.
Public property | UserId | Gets or sets the user ID.

See Also

TransactionSettings Class
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettings Constructor

[image]

IceLib Technical Reference
TransactionSettings Constructor
TransactionSettings Class See Also Send Feedback
Constructs a TransactionSettings object.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionSettings()
Visual Basic
Public Sub New

Remarks

The only constructor. The TransactionSettings object will be initialized with the values stored in the TransactionSettingDefaults struct.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettings Methods

[image] [image]

IceLib Technical Reference
TransactionSettings Methods
TransactionSettings Class See Also Send Feedback

The TransactionSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Makes a copy of this transaction settings.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | This method sets all transaction settings back to the default settings.
Public method | ToString | Returns a string representation of TransactionSettings. (Overrides Object..::..ToString()()()().)

See Also

TransactionSettings Class
ININ.IceLib.Data.TransactionBuilder Namespace


Clone Method

[image]

IceLib Technical Reference
TransactionSettings..::..Clone Method
TransactionSettings Class See Also Send Feedback
Makes a copy of this transaction settings.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionSettings Clone()
Visual Basic
Public Function Clone As TransactionSettings

Return Value

A copy of this transaction settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


Reset Method

[image]

IceLib Technical Reference
TransactionSettings..::..Reset Method
TransactionSettings Class See Also Send Feedback
This method sets all transaction settings back to the default settings.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Remarks

Call this method to restore the transaction settings to the default settings. The default settings are contained in the TransactionSettingDefaults struct.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


ToString Method

[image]

IceLib Technical Reference
TransactionSettings..::..ToString Method
TransactionSettings Class See Also Send Feedback
Returns a string representation of TransactionSettings.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

The transaction settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionSettings Properties

[image] [image]

IceLib Technical Reference
TransactionSettings Properties
TransactionSettings Class See Also Send Feedback

The TransactionSettings type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalInformation | Gets or sets the additional info for this transaction.
Public property | Asynchronous | Gets asynchronous flag.
Public property | Catalog | Gets or sets the catalog.
Public property | ClientNet | Gets or sets ClientNet.
Public property | ConnectionInformation | Gets or sets the connection information.
Public property | FormatVersion | Gets or sets the format version.
Public property | IncludeParameterMetadata | Gets or sets the include parameter metadata flag.
Public property | IncludeRowSetMetadata | Gets or sets the row set metadata flag.
Public property | IsolationType | Gets or sets the isolation type of this transaction.
Public property | Provider | Gets or sets the provider.
Public property | ReadOnly | Gets or sets the read-only flag.
Public property | RequestType | Gets or sets the request type of this transaction.
Public property | RowLimit | Gets or sets the row limit for this transaction.
Public property | Schema | Gets or sets the schema.
Public property | ServerInfo | Gets or sets the server info for this transaction.
Public property | Timeout | Gets or sets the timeout (in seconds).
Public property | TransactionId | Gets or sets the transaction ID.
Public property | UserId | Gets or sets the user ID.

See Also

TransactionSettings Class
ININ.IceLib.Data.TransactionBuilder Namespace


AdditionalInformation Property

[image]

IceLib Technical Reference
TransactionSettings..::..AdditionalInformation Property
TransactionSettings Class See Also Send Feedback
Gets or sets the additional info for this transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AdditionalInformation { get; set; }
Visual Basic
Public Property AdditionalInformation As String
    Get
    Set

Field Value

The additional information.

Remarks

The default is the empty string. It's ok to leave it empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


Asynchronous Property

[image]

IceLib Technical Reference
TransactionSettings..::..Asynchronous Property
TransactionSettings Class See Also Send Feedback
Gets asynchronous flag.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Asynchronous { get; }
Visual Basic
Public ReadOnly Property Asynchronous As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if asynchronous; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This flag is there for legacy reasons. It will always be falseFalsefalsefalse (False in Visual Basic). However, that does not mean that asynchronous operations are not supported. They are. For details, please see the documentation on TransactionClient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


Catalog Property

[image]

IceLib Technical Reference
TransactionSettings..::..Catalog Property
TransactionSettings Class See Also Send Feedback
Gets or sets the catalog.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Catalog { get; set; }
Visual Basic
Public Property Catalog As String
    Get
    Set

Field Value

The catalog.

Remarks

Contains the catelog to be used for executing transactions that contain data base operations. The default is the empty string. It's ok to leave it empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


ClientNet Property

[image]

IceLib Technical Reference
TransactionSettings..::..ClientNet Property
TransactionSettings Class See Also Send Feedback
Gets or sets ClientNet.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ClientNet { get; set; }
Visual Basic
Public Property ClientNet As String
    Get
    Set

Field Value

The client net.

Remarks

GUID representing the client net to use. The default should be used in most cases.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


ConnectionInformation Property

[image]

IceLib Technical Reference
TransactionSettings..::..ConnectionInformation Property
TransactionSettings Class See Also Send Feedback
Gets or sets the connection information.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ConnectionInformation { get; set; }
Visual Basic
Public Property ConnectionInformation As String
    Get
    Set

Field Value

The connection information.

Remarks

Contains the data source string used for executing transactions that contain data base operations. Example: ICDS:IC Tracker

If the value is TransactionSettingDefaults.ConnectionInformation, for both the Transaction and Global settings of the TransactionClient, then GetDefaultConnectionInformation()()()() will be called at Transaction exceution time to determine the connection information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


FormatVersion Property

[image]

IceLib Technical Reference
TransactionSettings..::..FormatVersion Property
TransactionSettings Class See Also Send Feedback
Gets or sets the format version.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int FormatVersion { get; set; }
Visual Basic
Public Property FormatVersion As Integer
    Get
    Set

Field Value

The format version.

Remarks

Specifies version number of the request/response strings. Unlikely to change very often.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


IncludeParameterMetadata Property

[image]

IceLib Technical Reference
TransactionSettings..::..IncludeParameterMetadata Property
TransactionSettings Class See Also Send Feedback
Gets or sets the include parameter metadata flag.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IncludeParameterMetadata { get; set; }
Visual Basic
Public Property IncludeParameterMetadata As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should include parameter metadata; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Should parameter metadata be included in this transaction? Leave this at the default (falseFalsefalsefalse (False in Visual Basic)) for all transactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


IncludeRowSetMetadata Property

[image]

IceLib Technical Reference
TransactionSettings..::..IncludeRowSetMetadata Property
TransactionSettings Class See Also Send Feedback
Gets or sets the row set metadata flag.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IncludeRowSetMetadata { get; set; }
Visual Basic
Public Property IncludeRowSetMetadata As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should include row set metadata; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Should row set metadata be included in this transaction? Leave this at the default (falseFalsefalsefalse (False in Visual Basic)) for all transactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


IsolationType Property

[image]

IceLib Technical Reference
TransactionSettings..::..IsolationType Property
TransactionSettings Class See Also Send Feedback
Gets or sets the isolation type of this transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionIsolationType IsolationType { get; set; }
Visual Basic
Public Property IsolationType As TransactionIsolationType
    Get
    Set

Field Value

The isolation type.

Remarks

Contains a TransactionIsolationType object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


Provider Property

[image]

IceLib Technical Reference
TransactionSettings..::..Provider Property
TransactionSettings Class See Also Send Feedback
Gets or sets the provider.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Provider { get; set; }
Visual Basic
Public Property Provider As String
    Get
    Set

Field Value

The provider.

Remarks

Specifies which provider should be used by the Transaction Server to process the request contained in the transaction. Example: ININ.I3DBTranSPProvider.1

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


ReadOnly Property

[image]

IceLib Technical Reference
TransactionSettings..::..ReadOnly Property
TransactionSettings Class See Also Send Feedback
Gets or sets the read-only flag.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic
Public Property ReadOnly As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if read only; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Is this transaction a read-only operation?

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


RequestType Property

[image]

IceLib Technical Reference
TransactionSettings..::..RequestType Property
TransactionSettings Class See Also Send Feedback
Gets or sets the request type of this transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionRequestType RequestType { get; set; }
Visual Basic
Public Property RequestType As TransactionRequestType
    Get
    Set

Field Value

The type of the request.

Remarks

Contains a TransactionRequestType object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


RowLimit Property

[image]

IceLib Technical Reference
TransactionSettings..::..RowLimit Property
TransactionSettings Class See Also Send Feedback
Gets or sets the row limit for this transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RowLimit { get; set; }
Visual Basic
Public Property RowLimit As Integer
    Get
    Set

Field Value

The row limit.

Remarks

The default is 1000.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


Schema Property

[image]

IceLib Technical Reference
TransactionSettings..::..Schema Property
TransactionSettings Class See Also Send Feedback
Gets or sets the schema.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Schema { get; set; }
Visual Basic
Public Property Schema As String
    Get
    Set

Field Value

The schema.

Remarks

Contains the schema to be used for executing transactions that contain data base operations. The default is the empty string. It's ok to leave it empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


ServerInfo Property

[image]

IceLib Technical Reference
TransactionSettings..::..ServerInfo Property
TransactionSettings Class See Also Send Feedback
Gets or sets the server info for this transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ServerInfo { get; set; }
Visual Basic
Public Property ServerInfo As String
    Get
    Set

Field Value

The server info.

Remarks

The default is the empty string. It's ok to leave it empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


Timeout Property

[image]

IceLib Technical Reference
TransactionSettings..::..Timeout Property
TransactionSettings Class See Also Send Feedback
Gets or sets the timeout (in seconds).

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long Timeout { get; set; }
Visual Basic
Public Property Timeout As Long
    Get
    Set

Field Value

The timeout.

Remarks

Specifies how long (in seconds)the Transaction Server should wait for a transaction to complete before considering it hung and returning to the caller. The default is 60.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionId Property

[image]

IceLib Technical Reference
TransactionSettings..::..TransactionId Property
TransactionSettings Class See Also Send Feedback
Gets or sets the transaction ID.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TransactionId { get; set; }
Visual Basic
Public Property TransactionId As String
    Get
    Set

Field Value

The transaction ID.

Remarks

The transaction ID of this transaction. The default is the empty string. It's ok to leave it empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


UserId Property

[image]

IceLib Technical Reference
TransactionSettings..::..UserId Property
TransactionSettings Class See Also Send Feedback
Gets or sets the user ID.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set

Field Value

The user ID.

Remarks

Specifies user ID to associate with the transaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TransactionSettings Class
TransactionSettings Members
ININ.IceLib.Data.TransactionBuilder Namespace


TransactionStatus Enumeration

[image]

IceLib Technical Reference
TransactionStatus Enumeration
See Also Send Feedback
Represents the status of a transaction.

Namespace: ININ.IceLib.Data.TransactionBuilder
Assembly: ININ.IceLib.Data.TransactionBuilder (in ININ.IceLib.Data.TransactionBuilder.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum TransactionStatus
Visual Basic
Public Enumeration TransactionStatus

Members

Member name | Value | Description
None | 0 | Represents no status.
Uninitialized | 1 | Represents an uninitialized transaction.
Waiting | 2 | Represents a waiting transaction.
Executing | 3 | Represents an executing transaction.
Successful | 4 | Represents a successful transaction.
Failed | 5 | Represents a failed transaction.
Aborted | 6 | Represents an aborted transaction.
Unknown | 7 | Represents a transaction in an unknown state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Data.TransactionBuilder Namespace


ININ.IceLib.Directories Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Directories Namespace
Send Feedback

The ININ.IceLib.Directories namespace contains classes for accessing Interaction Center directories.

The namespace is organized around tasks one would typically want to perform, such as:

  1. Retrieving and managing the list of directories
  2. Retrieving and managing the entries within a specific directory

Retrieving and managing the list of directories

Use the DirectoryConfiguration class to retrieve and manage a list of available directories, and to watch for changes to that list. Calling GetList()()()() or GetEntry(String) on a DirectoryConfiguration instance will retrieve one or more DirectoryMetadata elements, each one representing a specific directory, workgroup, speed dial list, etc. A DirectoryMetadata instance describes everything there is to know about a particular directory. It is also used to create a ContactDirectory which in turn is used to retrieve the entries within the specific directory.

Retrieving and managing the entries within a specific directory

To retrieve a list of entries within a directory, start by determining the DirectoryMetadata that describes the directory you are interested in. Construct a ContactDirectory instance using this metadata, call StartWatching()()()() to start the watch and then call GetList()()()() or GetEntry(String) to return one or more ContactEntry elements. Each returned ContactEntry instance represents a particular entry in the directory.

If you are dealing with large directories, it is advised that you using the paged view interface. The paged view interface requires setting up a ContactDirectoryWatchSettings instance that allows you to set a filter, sort order, start position and number of items to retrieve. The initial paged watched view is established by supplying an instance of ContactDirectoryWatchSettings to StartWatching(ContactDirectoryWatchSettings). Once the watch is established you can page back or forth by making a call to ChangeWatched(ContactDirectoryWatchSettings).

Synchronous Example

The following is an example of synchronously retrieving a list of all available directories and displaying the first and last name of each user in each directory.

Note
Using these classes in a synchronous manner is not recommended for client applications since the main thread will be blocked. It is shown here for a brief example. It is recommended to only use the synchronous methods if it is applicable to your application scenario (e.g. ASP.NET) or your application is making synchronous calls within a background thread.

CopyC#
static void PrintAllDirectories (ININ.IceLib.Connection.Session session)
{
    DirectoriesManager dirManager = DirectoriesManager.GetInstance(session);
    DirectoryConfiguration dirConfig = new DirectoryConfiguration(dirManager);

    dirConfig.StartWatching();
    System.Collections.ObjectModel.ReadOnlyCollection<DirectoryMetadata> metaData = dirConfig.GetList();

    foreach (DirectoryMetadata dirMetadata in metaData)
    {
        System.Console.Out.WriteLine("====== {0} Entries ======", dirMetadata.DisplayName);

        ContactDirectory contactDir = new ContactDirectory(dirManager, dirMetadata);
        contactDir.StartWatching();

        System.Collections.ObjectModel.ReadOnlyCollection<ContactEntry> contactEntries = contactDir.GetList();
        foreach (ContactEntry entry in contactEntries)
        {
            System.Console.Out.WriteLine("{0}, {1}", entry.LastName, entry.FirstName);
        }
    }
}

Classes

 | Class | Description
Public class | ContactCountEventArgs | Provides data for the count change event ContactCountChanged.
Public class | ContactDirectory | Represents a contact directory. An instance of this object is used to obtain a watched list of contact entries and perform operations on them.
Public class | ContactDirectoryProgressChangedEventArgs | Represents the current progress for a task invoked by StartWatchingAsync(AsyncCompletedEventHandler, Object), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Public class | ContactDirectoryWatchSettings | This class represents settings for a directory watch that provides a filtered and sorted view of contact entries. This view can be returned in increments or pages at a time.
Public class | ContactEntry | Represents a directory contact watched object.
Public class | ContactFilterGroup | Represents a grouping of filter items.
Public class | ContactFilterItem | Serves as a base class for items that filter contact entries that should be returned.
Public class | ContactFilterMatch | Represents an item to filter contact entries that should be returned.
Public class | ContactSortItem | Represents an item to sort on a particular contact entry property.
Public class | CreateDirectoryCompletedEventArgs | Provides data for the CreateTrackerDirectoryAsync(String, TrackerFilterSettings, EventHandler<(Of <<'(CreateDirectoryCompletedEventArgs>)>>), Object) and CreateSpeedDialDirectory(String, DirectoryMetadataAccessRights) completedCallback delegate of DirectoryConfiguration.
Public class | DirectoriesManager | Provides access to all the various IC directories.
Public class | DirectoryConfiguration | Represents IC directory configuration. An instance of this object is used to obtain a list of available directories and perform operations on them.
Public class | DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> | Provides data for watched object change events.
Public class | DirectoryMetadata | Represents a directory metadata watched object. This object maintains information of a particular directory that exists on the IC server. The directory metadata is used to identify a directory of contact entries.
Public class | DirectoryPhoneNumber | Represents a phone number stored in the contact directory.
Public class | EditableContactEntry | Represents an editable contact entry object. This object is used to make updates to directory contacts.
Public class | EditableDirectoryPhoneNumber | Represents a editable telephone number stored in the contact directory.
Public class | ExternalContactEntries | Provides a list of ExternalContactEntry objects for a ContactEntry.
Public class | ExternalContactEntry | Contains additional information to ContactEntry for contacts that relate to a system external to IC. A contact is considered to have an external IC relation, when contacts are added or merged in from an external source, or IC contains information specific to an external system.
Public class | ExternalPresenceProvider | Provides External Presence provider details of a ContactEntry.
Public class | ExternalPresenceProviders | Provides a list of ExternalPresenceProviders of a ContactEntry.
Public class | PendingDirectoryEntries | Used to identify overall pending status and individual PendingDirectoryGroup statuses for directories (DirectoryConfigurationChanged or Pending).
Public class | PendingDirectoryGroup | Represents a grouping of directories that are or were pending to be loaded.
Public class | PendingEntries | Base class for identification of pending directory data.
Public class | TrackerFilterAttribute | Tracker filter attribute.
Public class | TrackerFilterSettings | Tracker filter settings.
Public class | UserSkill | Represents a user's skill.

Enumerations

 | Enumeration | Description
Public enumeration | ContactAccessRights | Specifies constants for the access rights of a directory contact.
Public enumeration | ContactFilterType | Represents the type of pattern matching that should be performed.
Public enumeration | ContactPrimaryNumberDesignation | Specifies constants indicating which directory contact property is the primary number.
Public enumeration | ContactProperty | Each value in this enumeration represents a property in ContactEntry.
Public enumeration | ContactSource | Used to identify the source(s) for a contact entry.
Public enumeration | DirectoryMetadataAccessRights | Specifies constants for the access rights of a directory.
Public enumeration | DirectoryMetadataCategory | Specifies constants for the category of a directory.
Public enumeration | DirectoryMetadataDisplayType | Specifies constants for the display type of a directory.
Public enumeration | DirectoryMetadataProperty | Specifies constants for the DirectoryMetadata properties.
Public enumeration | PendingStatus | Identifies the pending status of a directory object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


ContactAccessRights Enumeration

[image]

IceLib Technical Reference
ContactAccessRights Enumeration
See Also Send Feedback
Specifies constants for the access rights of a directory contact.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum ContactAccessRights
Visual Basic
<FlagsAttribute> _
Public Enumeration ContactAccessRights

Members

Member name | Value | Description
None | 0 | No access rights are specified.
Read | 1 | Permission to read a contact entry.
Create | 2 | Permission to create a new contact entry.
Update | 4 | Permission to update a contact entry.
Delete | 8 | Permission to delete a contact entry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


ContactCountEventArgs Class

[image]

IceLib Technical Reference
ContactCountEventArgs Class
Members See Also Send Feedback
Provides data for the count change event ContactCountChanged.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactCountEventArgs : EventArgs
Visual Basic
Public Class ContactCountEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Directories..::..ContactCountEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactCountEventArgs Members
ININ.IceLib.Directories Namespace


ContactCountEventArgs Members

[image] [image]

IceLib Technical Reference
ContactCountEventArgs Members
ContactCountEventArgs Class Methods Properties See Also Send Feedback

The ContactCountEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilteredCount | Gets the number of contacts that exist in the filter.
Public property | UnfilteredCount | Gets the number of contacts that exist in the parent directory of the filter.

See Also

ContactCountEventArgs Class
ININ.IceLib.Directories Namespace


ContactCountEventArgs Methods

[image] [image]

IceLib Technical Reference
ContactCountEventArgs Methods
ContactCountEventArgs Class See Also Send Feedback

The ContactCountEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactCountEventArgs Class
ININ.IceLib.Directories Namespace


ContactCountEventArgs Properties

[image] [image]

IceLib Technical Reference
ContactCountEventArgs Properties
ContactCountEventArgs Class See Also Send Feedback

The ContactCountEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | FilteredCount | Gets the number of contacts that exist in the filter.
Public property | UnfilteredCount | Gets the number of contacts that exist in the parent directory of the filter.

See Also

ContactCountEventArgs Class
ININ.IceLib.Directories Namespace


FilteredCount Property

[image]

IceLib Technical Reference
ContactCountEventArgs..::..FilteredCount Property
ContactCountEventArgs Class See Also Send Feedback
Gets the number of contacts that exist in the filter.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int FilteredCount { get; }
Visual Basic
Public ReadOnly Property FilteredCount As Integer
    Get

Field Value

The number of contacts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactCountEventArgs Class
ContactCountEventArgs Members
ININ.IceLib.Directories Namespace


UnfilteredCount Property

[image]

IceLib Technical Reference
ContactCountEventArgs..::..UnfilteredCount Property
ContactCountEventArgs Class See Also Send Feedback
Gets the number of contacts that exist in the parent directory of the filter.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int UnfilteredCount { get; }
Visual Basic
Public ReadOnly Property UnfilteredCount As Integer
    Get

Field Value

The number of contacts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactCountEventArgs Class
ContactCountEventArgs Members
ININ.IceLib.Directories Namespace


ContactDirectory Class

[image]

IceLib Technical Reference
ContactDirectory Class
Members See Also Send Feedback
Represents a contact directory. An instance of this object is used to obtain a watched list of contact entries and perform operations on them.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactDirectory
Visual Basic
Public Class ContactDirectory

Remarks

Note
Contact directories contain lists of people and contact information about those people. In Interaction Client, the default directory for private contacts is named IC Private Contacts, the default directory for public contacts is IC Public Contacts, and the directory which holds all company employees is the Company Directory.

A ContactDirectory object manages a watched list of ContactEntry objects. In addition, there are methods to create, update or delete contact entries. The directory watched is identified by a specific directory as identified by a DirectoryMetadata object instance.

Getting a list of watched objects

Each watched object is maintained internally within a cache. The cache is constructed so that only one instance of a ContactEntry object is shared between other instances of a ContactDirectory object.

This object contains synchronous as well as asynchronous counterpart methods for any method that could potentially block a thread by running a lengthy operation. Synchronous methods block the thread that they are performed on. Asynchronous methods will not block. When an asynchronous method completes an event is raised on a thread appropriate to the application-model, such as the GUI thread in a UI application. By convention, synchronous calls are invoked by a method; for example: DoSomething(). Their asynchronous counterparts are invoked via DoSomethingAsync() with the result returned in a DoSomethingCompleted event.

A start watch, via a call to StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object), is required to retrieve the available contact entries from the IC Server. Once the start watch has successfully completed, call GetList()()()() to obtain the available contact entries.

Change notifications to the list of contact entries can be subscribed to via the ContactDirectoryChanged event handler. Change events are not raised on a thread appropriate to the application mode, such as the GUI thread in a UI application.

A watch can be stopped via a call to StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object).

Viewed watches

A viewed watch allows only a subset of the contact entries to be retrieved from the IC server. A viewed watch is established by creating a watch settings instance, ContactDirectoryWatchSettings, which specifies the start index, count of entries to return, a filter and a sort order. The viewed watch is established via a call to watch aware start watch methods - StartWatching(ContactDirectoryWatchSettings) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).

Once a viewed start watch has been established, the view can be changed by a call to ChangeWatched(ContactDirectoryWatchSettings) or ChangeWatchedAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object). Typically, the watch settings can be adjusted to advance to the Next()()()() page or go back to the Previous()()()() page.

Change notifications to the viewed list of contact entries can be subscribed to via the ContactDirectoryChanged event handler. Note that only change events for objects in the watch settings view will be reported. In particular, objects might appear or disappear in scope based on the filter or sort criteria. No more than Count contact entries will be maintained. So, for example, if an item is added to the view, an item will also be removed from the view to keep the Count unchanged.

Contact entry updates

Contact entries can be created, updated and deleted with the following synchronous and asynchronous methods.

  • CreateContactEntry(EditableContactEntry) or CreateContactEntryAsync(EditableContactEntry, AsyncCompletedEventHandler, Object)
  • UpdateContactEntry(EditableContactEntry) or UpdateContactEntryAsync(EditableContactEntry, AsyncCompletedEventHandler, Object)
  • DeleteContactEntry(String) or DeleteContactEntryAsync(String, AsyncCompletedEventHandler, Object)

A EditableContactEntry instance is required for creating and updating contact entries.

Speed dial contact entries

A speed dial directory represents a link to another contact entry in another directory. When viewing the properties of a speed dial contact entry you are actually viewing the properties of the linked contact entry. Within the speed dial directory an alternate primary number designation may be specified. The PrimaryNumberDesignation is the default number to call.

Speed dial links can be created, updated, and deleted with the following synchronous or asynchronous methods.

  • CreateSpeedDialLink(DirectoryMetadata, ContactEntry, ContactPrimaryNumberDesignation) or CreateSpeedDialLinkAsync(DirectoryMetadata, ContactEntry, ContactPrimaryNumberDesignation, AsyncCompletedEventHandler, Object)
  • UpdateSpeedDialLink(ContactEntry, ContactPrimaryNumberDesignation) or UpdateSpeedDialLinkAsync(ContactEntry, ContactPrimaryNumberDesignation, AsyncCompletedEventHandler, Object)
  • DeleteContactEntry(String) or DeleteContactEntryAsync(String, AsyncCompletedEventHandler, Object)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactDirectory

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Members
ININ.IceLib.Directories Namespace


ContactDirectory Members

[image] [image]

IceLib Technical Reference
ContactDirectory Members
ContactDirectory Class Constructors Methods Properties Events See Also Send Feedback

The ContactDirectory type exposes the following members.

Constructors

 | Name | Description
Public method | ContactDirectory(DirectoriesManager, DirectoryMetadata) | Initializes a new instance of the ContactDirectory class.
Public method | ContactDirectory(DirectoriesManager, DirectoryMetadata, Boolean) | Initializes a new instance of the ContactDirectory class with optional client side caching.

Methods

 | Name | Description
Public method | CanCreateEntry | Determines whether the user associated with this session can create a new contact entry.
Public method | CanDeleteEntry | Determines whether the user associated with this session can delete the contact entry.
Public method | CanRefreshContacts | Determines wether the user associated with this session can send refresh the contacts in this directory.
Public method | CanUpdateEntry | Determines whether the user associated with this session can update the contact entry.
Public method | CanUpdatePrimaryNumberDesignation | Determines whether the user associated with this session can update the primary number designation for the contact entry.
Public method | ChangeWatched | A synchronous request to change the watch.
Public method | ChangeWatchedAsync | An asynchronous request to change the watch.
Public method | CreateContactEntry | Creates the contact entry.
Public method | CreateContactEntryAsync | An asynchronous request to create a contact entry.
Public method | CreateSpeedDialLink | Creates a link from a speed dial directory to a contact entry in the current directory. The speed dial directory is a directory containing links to other directories' contact entries.
Public method | CreateSpeedDialLinkAsync | Creates the speed dial link asynchronously.
Public method | DeleteContactEntry | Deletes the contact entry.
Public method | DeleteContactEntryAsync | An asynchronous request to delete the contact entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCachedDirectory | Gets a contact directory from local cache when working offline.
Public method | GetEntry | Gets an entry based on its EntryId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the list of ContactEntry instances watched for a given directory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshContacts | A synchronous method to refesh the contacts in this directory.
Public method | RefreshContactsAsync | A synchronous method to refresh the contacts in this directory.
Public method | StartWatching()()()() | A synchronous request to query and watch contact entries.
Public method | StartWatching(ContactDirectoryWatchSettings) | A synchronous request to query and watch contact entries.
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | An asynchronous request to query and watch contact entrys.
Public method | StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) | An asynchronous request to query and watch contact entrys.
Public method | StartWatchingAsyncCancel | Cancel a StartWatchingAsync(AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) request.
Public method | StopWatching | A synchronous method to stop watching a directory .
Public method | StopWatchingAsync | A synchronous method to stop watching a directory.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | UpdateContactEntry | Updates the contact entry.
Public method | UpdateContactEntryAsync | Starts an asynchronous update of a contact entry.
Public method | UpdateSpeedDialLink | Updates the contact entry link.
Public method | UpdateSpeedDialLinkAsync | Updates the contact entry link asynchronously.

Properties

 | Name | Description
Public property | DirectoriesManager | Gets the directories manager.
Public property | FilteredCount | Gets the total number of entries that match a filter for a view.
Public property | Metadata | Gets the metadata.
Public property | PendingStatus | Identifies if this contact directory has pending contact entries that still need to be loaded from the Interaction Center server.
Public property | TotalCount | Gets the total count of entries in the contact directory that is being watched.

Events

 | Name | Description
Public event | ContactCountChanged | Occurs when the number of contacts in this ContactEntry has changed.
Public event | ContactDirectoryChanged | Occurs when one of the ContactEntry watched objects has changed.
Public event | StartWatchingProgressChanged | Occurs when a call to StartWatchingAsync(AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) sends a progress message.

See Also

ContactDirectory Class
ININ.IceLib.Directories Namespace


ContactDirectory Constructor

[image] [image]

IceLib Technical Reference
ContactDirectory Constructor
ContactDirectory Class See Also Send Feedback
Initializes a new instance of the ContactDirectory class.

Overload List

 | Name | Description
Public method | ContactDirectory(DirectoriesManager, DirectoryMetadata) | Initializes a new instance of the ContactDirectory class.
Public method | ContactDirectory(DirectoriesManager, DirectoryMetadata, Boolean) | Initializes a new instance of the ContactDirectory class with optional client side caching.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ContactDirectory Constructor (DirectoriesManager, DirectoryMetadata)

[image]

IceLib Technical Reference
ContactDirectory Constructor (DirectoriesManager, DirectoryMetadata)
ContactDirectory Class See Also Send Feedback
Initializes a new instance of the ContactDirectory class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectory(
    DirectoriesManager manager,
    DirectoryMetadata metadata
)
Visual Basic
Public Sub New ( _
    manager As DirectoriesManager, _
    metadata As DirectoryMetadata _
)

Parameters

manager
Type: ININ.IceLib.Directories..::..DirectoriesManager
The manager.
metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata.

Remarks

Contact directory information will be cached on the client side.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ContactDirectory Overload
ININ.IceLib.Directories Namespace


ContactDirectory Constructor (DirectoriesManager, DirectoryMetadata, Boolean)

[image]

IceLib Technical Reference
ContactDirectory Constructor (DirectoriesManager, DirectoryMetadata, Boolean)
ContactDirectory Class See Also Send Feedback
Initializes a new instance of the ContactDirectory class with optional client side caching.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectory(
    DirectoriesManager manager,
    DirectoryMetadata metadata,
    bool enableCaching
)
Visual Basic
Public Sub New ( _
    manager As DirectoriesManager, _
    metadata As DirectoryMetadata, _
    enableCaching As Boolean _
)

Parameters

manager
Type: ININ.IceLib.Directories..::..DirectoriesManager
The manager.
metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata.
enableCaching
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) enable caching.

Remarks

Optionally enable client side caching of the contact directory.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ContactDirectory Overload
ININ.IceLib.Directories Namespace


ContactDirectory Methods

[image] [image]

IceLib Technical Reference
ContactDirectory Methods
ContactDirectory Class See Also Send Feedback

The ContactDirectory type exposes the following members.

Methods

 | Name | Description
Public method | CanCreateEntry | Determines whether the user associated with this session can create a new contact entry.
Public method | CanDeleteEntry | Determines whether the user associated with this session can delete the contact entry.
Public method | CanRefreshContacts | Determines wether the user associated with this session can send refresh the contacts in this directory.
Public method | CanUpdateEntry | Determines whether the user associated with this session can update the contact entry.
Public method | CanUpdatePrimaryNumberDesignation | Determines whether the user associated with this session can update the primary number designation for the contact entry.
Public method | ChangeWatched | A synchronous request to change the watch.
Public method | ChangeWatchedAsync | An asynchronous request to change the watch.
Public method | CreateContactEntry | Creates the contact entry.
Public method | CreateContactEntryAsync | An asynchronous request to create a contact entry.
Public method | CreateSpeedDialLink | Creates a link from a speed dial directory to a contact entry in the current directory. The speed dial directory is a directory containing links to other directories' contact entries.
Public method | CreateSpeedDialLinkAsync | Creates the speed dial link asynchronously.
Public method | DeleteContactEntry | Deletes the contact entry.
Public method | DeleteContactEntryAsync | An asynchronous request to delete the contact entry.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCachedDirectory | Gets a contact directory from local cache when working offline.
Public method | GetEntry | Gets an entry based on its EntryId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the list of ContactEntry instances watched for a given directory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshContacts | A synchronous method to refesh the contacts in this directory.
Public method | RefreshContactsAsync | A synchronous method to refresh the contacts in this directory.
Public method | StartWatching()()()() | A synchronous request to query and watch contact entries.
Public method | StartWatching(ContactDirectoryWatchSettings) | A synchronous request to query and watch contact entries.
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | An asynchronous request to query and watch contact entrys.
Public method | StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) | An asynchronous request to query and watch contact entrys.
Public method | StartWatchingAsyncCancel | Cancel a StartWatchingAsync(AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) request.
Public method | StopWatching | A synchronous method to stop watching a directory .
Public method | StopWatchingAsync | A synchronous method to stop watching a directory.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | UpdateContactEntry | Updates the contact entry.
Public method | UpdateContactEntryAsync | Starts an asynchronous update of a contact entry.
Public method | UpdateSpeedDialLink | Updates the contact entry link.
Public method | UpdateSpeedDialLinkAsync | Updates the contact entry link asynchronously.

See Also

ContactDirectory Class
ININ.IceLib.Directories Namespace


CanCreateEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..CanCreateEntry Method
ContactDirectory Class See Also Send Feedback
Determines whether the user associated with this session can create a new contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateEntry()
Visual Basic
Public Function CanCreateEntry As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if the user can create a new contact entry; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CanDeleteEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..CanDeleteEntry Method
ContactDirectory Class See Also Send Feedback
Determines whether the user associated with this session can delete the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteEntry(
    ContactEntry entry
)
Visual Basic
Public Function CanDeleteEntry ( _
    entry As ContactEntry _
) As Boolean

Parameters

entry
Type: ININ.IceLib.Directories..::..ContactEntry
The entry.

Return Value

trueTruetruetrue (True in Visual Basic) if the user can delete the specified entry; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CanRefreshContacts Method

[image]

IceLib Technical Reference
ContactDirectory..::..CanRefreshContacts Method
ContactDirectory Class See Also Send Feedback
Determines wether the user associated with this session can send refresh the contacts in this directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanRefreshContacts()
Visual Basic
Public Function CanRefreshContacts As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if the user can refresh; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CanUpdateEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..CanUpdateEntry Method
ContactDirectory Class See Also Send Feedback
Determines whether the user associated with this session can update the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUpdateEntry(
    ContactEntry entry
)
Visual Basic
Public Function CanUpdateEntry ( _
    entry As ContactEntry _
) As Boolean

Parameters

entry
Type: ININ.IceLib.Directories..::..ContactEntry
The entry.

Return Value

trueTruetruetrue (True in Visual Basic) if the user can update the specified entry; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CanUpdatePrimaryNumberDesignation Method

[image]

IceLib Technical Reference
ContactDirectory..::..CanUpdatePrimaryNumberDesignation Method
ContactDirectory Class See Also Send Feedback
Determines whether the user associated with this session can update the primary number designation for the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUpdatePrimaryNumberDesignation(
    ContactEntry entry
)
Visual Basic
Public Function CanUpdatePrimaryNumberDesignation ( _
    entry As ContactEntry _
) As Boolean

Parameters

entry
Type: ININ.IceLib.Directories..::..ContactEntry
The entry.

Return Value

trueTruetruetrue (True in Visual Basic) if the user can update the specified entry; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ChangeWatched Method

[image]

IceLib Technical Reference
ContactDirectory..::..ChangeWatched Method
ContactDirectory Class See Also Send Feedback
A synchronous request to change the watch.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatched(
    ContactDirectoryWatchSettings watchSettings
)
Visual Basic
Public Sub ChangeWatched ( _
    watchSettings As ContactDirectoryWatchSettings _
)

Parameters

watchSettings
Type: ININ.IceLib.Directories..::..ContactDirectoryWatchSettings
The watch settings.

Remarks

This method is only valid for paged directories, that is, directories on which a viewed watch is active.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A watch was not started or this method was called on a directory that is not a paged directory. The request timed out while waiting for a response.The Session does not have a valid connection.The Session has been disposed. See StartWatching(ContactDirectoryWatchSettings).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ChangeWatchedAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..ChangeWatchedAsync Method
ContactDirectory Class See Also Send Feedback
An asynchronous request to change the watch.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAsync(
    ContactDirectoryWatchSettings watchSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAsync ( _
    watchSettings As ContactDirectoryWatchSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

watchSettings
Type: ININ.IceLib.Directories..::..ContactDirectoryWatchSettings
The watch settings.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method is only valid for paged directories, that is, directories on which a viewed watch is active.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A watch was not started or this method was called on a directory that is not a paged directory. See StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CreateContactEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..CreateContactEntry Method
ContactDirectory Class See Also Send Feedback
Creates the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateContactEntry(
    EditableContactEntry editableEntry
)
Visual Basic
Public Sub CreateContactEntry ( _
    editableEntry As EditableContactEntry _
)

Parameters

editableEntry
Type: ININ.IceLib.Directories..::..EditableContactEntry
The editable entry.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CreateContactEntryAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..CreateContactEntryAsync Method
ContactDirectory Class See Also Send Feedback
An asynchronous request to create a contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateContactEntryAsync(
    EditableContactEntry editableEntry,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateContactEntryAsync ( _
    editableEntry As EditableContactEntry, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

editableEntry
Type: ININ.IceLib.Directories..::..EditableContactEntry
The editable entry.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CreateSpeedDialLink Method

[image]

IceLib Technical Reference
ContactDirectory..::..CreateSpeedDialLink Method
ContactDirectory Class See Also Send Feedback
Creates a link from a speed dial directory to a contact entry in the current directory. The speed dial directory is a directory containing links to other directories' contact entries.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateSpeedDialLink(
    DirectoryMetadata speedDialDirectoryMetadata,
    ContactEntry linkedContactEntry,
    ContactPrimaryNumberDesignation newLinkPrimaryNumberDesignation
)
Visual Basic
Public Sub CreateSpeedDialLink ( _
    speedDialDirectoryMetadata As DirectoryMetadata, _
    linkedContactEntry As ContactEntry, _
    newLinkPrimaryNumberDesignation As ContactPrimaryNumberDesignation _
)

Parameters

speedDialDirectoryMetadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The speed dial directory metadata.
linkedContactEntry
Type: ININ.IceLib.Directories..::..ContactEntry
The linked contact entry.
newLinkPrimaryNumberDesignation
Type: ININ.IceLib.Directories..::..ContactPrimaryNumberDesignation
The new link primary number designation.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


CreateSpeedDialLinkAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..CreateSpeedDialLinkAsync Method
ContactDirectory Class See Also Send Feedback
Creates the speed dial link asynchronously.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateSpeedDialLinkAsync(
    DirectoryMetadata speedDialDirectoryMetadata,
    ContactEntry linkedContactEntry,
    ContactPrimaryNumberDesignation newLinkPrimaryNumberDesignation,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateSpeedDialLinkAsync ( _
    speedDialDirectoryMetadata As DirectoryMetadata, _
    linkedContactEntry As ContactEntry, _
    newLinkPrimaryNumberDesignation As ContactPrimaryNumberDesignation, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

speedDialDirectoryMetadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The speed dial directory metadata.
linkedContactEntry
Type: ININ.IceLib.Directories..::..ContactEntry
The linked contact entry.
newLinkPrimaryNumberDesignation
Type: ININ.IceLib.Directories..::..ContactPrimaryNumberDesignation
The new link primary number designation.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


DeleteContactEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..DeleteContactEntry Method
ContactDirectory Class See Also Send Feedback
Deletes the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteContactEntry(
    string entryId
)
Visual Basic
Public Sub DeleteContactEntry ( _
    entryId As String _
)

Parameters

entryId
Type: System..::..String
The entry ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


DeleteContactEntryAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..DeleteContactEntryAsync Method
ContactDirectory Class See Also Send Feedback
An asynchronous request to delete the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteContactEntryAsync(
    string entryId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteContactEntryAsync ( _
    entryId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

entryId
Type: System..::..String
The entry ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


GetCachedDirectory Method

[image]

IceLib Technical Reference
ContactDirectory..::..GetCachedDirectory Method
ContactDirectory Class See Also Send Feedback
Gets a contact directory from local cache when working offline.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<ContactEntry> GetCachedDirectory(
    string userId,
    string icServer,
    string directoryMetadataId
)
Visual Basic
Public Shared Function GetCachedDirectory ( _
    userId As String, _
    icServer As String, _
    directoryMetadataId As String _
) As ReadOnlyCollection(Of ContactEntry)

Parameters

userId
Type: System..::..String
The ID of the user for which the directory was cached.
icServer
Type: System..::..String
The name of the IC server to which the directory belongs.
directoryMetadataId
Type: System..::..String
The directory metadata ID. (DirectoryMetaData.Id)

Return Value

A list of contact entries.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


GetEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..GetEntry Method
ContactDirectory Class See Also Send Feedback
Gets an entry based on its EntryId.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactEntry GetEntry(
    string entryId
)
Visual Basic
Public Function GetEntry ( _
    entryId As String _
) As ContactEntry

Parameters

entryId
Type: System..::..String
The EntryId.

Return Value

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the entry could not be found.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | A StartWatch has not been called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


GetList Method

[image]

IceLib Technical Reference
ContactDirectory..::..GetList Method
ContactDirectory Class See Also Send Feedback
Gets the list of ContactEntry instances watched for a given directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ContactEntry> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of ContactEntry)

Return Value

A list of ContactEntry.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | A StartWatch has not been called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


IsWatching Method

[image]

IceLib Technical Reference
ContactDirectory..::..IsWatching Method
ContactDirectory Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


RefreshContacts Method

[image]

IceLib Technical Reference
ContactDirectory..::..RefreshContacts Method
ContactDirectory Class See Also Send Feedback
A synchronous method to refesh the contacts in this directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshContacts()
Visual Basic
Public Sub RefreshContacts

Remarks

Results from the refresh are sent as change notifications for non-paged watches. For paged watches call GetList()()()() to get items that match the current watch.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


RefreshContactsAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..RefreshContactsAsync Method
ContactDirectory Class See Also Send Feedback
A synchronous method to refresh the contacts in this directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshContactsAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RefreshContactsAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Results from the refresh are sent as change notifications for non-paged watches. For paged watches call GetList()()()() to get items that match the current watch.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


StartWatching Method

[image] [image]

IceLib Technical Reference
ContactDirectory..::..StartWatching Method
ContactDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartWatching()()()() | A synchronous request to query and watch contact entries.
Public method | StartWatching(ContactDirectoryWatchSettings) | A synchronous request to query and watch contact entries.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


StartWatching Method

[image]

IceLib Technical Reference
ContactDirectory..::..StartWatching Method
ContactDirectory Class See Also Send Feedback
A synchronous request to query and watch contact entries.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()(), StartWatchingAsync(AsyncCompletedEventHandler, Object), StartWatching(ContactDirectoryWatchSettings), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch has already been started for this instance of ContactDirectory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
StartWatching Overload
ININ.IceLib.Directories Namespace


StartWatching Method (ContactDirectoryWatchSettings)

[image]

IceLib Technical Reference
ContactDirectory..::..StartWatching Method (ContactDirectoryWatchSettings)
ContactDirectory Class See Also Send Feedback
A synchronous request to query and watch contact entries.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    ContactDirectoryWatchSettings watchSettings
)
Visual Basic
Public Sub StartWatching ( _
    watchSettings As ContactDirectoryWatchSettings _
)

Parameters

watchSettings
Type: ININ.IceLib.Directories..::..ContactDirectoryWatchSettings
The watch settings.

Remarks

Note
All event handlers should be added before calling StartWatching()()()(), StartWatchingAsync(AsyncCompletedEventHandler, Object), StartWatching(ContactDirectoryWatchSettings), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A watch has already been started for this instance of ContactDirectory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
StartWatching Overload
ININ.IceLib.Directories Namespace


StartWatchingAsync Method

[image] [image]

IceLib Technical Reference
ContactDirectory..::..StartWatchingAsync Method
ContactDirectory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | An asynchronous request to query and watch contact entrys.
Public method | StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) | An asynchronous request to query and watch contact entrys.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


StartWatchingAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ContactDirectory..::..StartWatchingAsync Method (AsyncCompletedEventHandler, Object)
ContactDirectory Class See Also Send Feedback
An asynchronous request to query and watch contact entrys.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Function StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
) As Long

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Return Value

A task ID. This can be used to cancel this request. See StartWatchingAsyncCancel(Int64).

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()(), StartWatchingAsync(AsyncCompletedEventHandler, Object), StartWatching(ContactDirectoryWatchSettings), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch has already been started for this instance of ContactDirectory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
StartWatchingAsync Overload
ININ.IceLib.Directories Namespace


StartWatchingAsync Method (ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ContactDirectory..::..StartWatchingAsync Method (ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object)
ContactDirectory Class See Also Send Feedback
An asynchronous request to query and watch contact entrys.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long StartWatchingAsync(
    ContactDirectoryWatchSettings watchSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Function StartWatchingAsync ( _
    watchSettings As ContactDirectoryWatchSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
) As Long

Parameters

watchSettings
Type: ININ.IceLib.Directories..::..ContactDirectoryWatchSettings
The watch settings.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Return Value

A task ID. This can be used to cancel this request. See StartWatchingAsyncCancel(Int64).

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()(), StartWatchingAsync(AsyncCompletedEventHandler, Object), StartWatching(ContactDirectoryWatchSettings), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A watch has already been started for this instance of ContactDirectory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
StartWatchingAsync Overload
ININ.IceLib.Directories Namespace


StartWatchingAsyncCancel Method

[image]

IceLib Technical Reference
ContactDirectory..::..StartWatchingAsyncCancel Method
ContactDirectory Class See Also Send Feedback
Cancel a StartWatchingAsync(AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) request.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsyncCancel(
    long taskId
)
Visual Basic
Public Sub StartWatchingAsyncCancel ( _
    taskId As Long _
)

Parameters

taskId
Type: System..::..Int64
The task ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


StopWatching Method

[image]

IceLib Technical Reference
ContactDirectory..::..StopWatching Method
ContactDirectory Class See Also Send Feedback
A synchronous method to stop watching a directory .

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started. See StartWatching()()()(), or StartWatching(ContactDirectoryWatchSettings).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..StopWatchingAsync Method
ContactDirectory Class See Also Send Feedback
A synchronous method to stop watching a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started. See StartWatchingAsync(AsyncCompletedEventHandler, Object), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ToString Method

[image]

IceLib Technical Reference
ContactDirectory..::..ToString Method
ContactDirectory Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


UpdateContactEntry Method

[image]

IceLib Technical Reference
ContactDirectory..::..UpdateContactEntry Method
ContactDirectory Class See Also Send Feedback
Updates the contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateContactEntry(
    EditableContactEntry editableEntry
)
Visual Basic
Public Sub UpdateContactEntry ( _
    editableEntry As EditableContactEntry _
)

Parameters

editableEntry
Type: ININ.IceLib.Directories..::..EditableContactEntry
The editable contact entry.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


UpdateContactEntryAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..UpdateContactEntryAsync Method
ContactDirectory Class See Also Send Feedback
Starts an asynchronous update of a contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateContactEntryAsync(
    EditableContactEntry editableEntry,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateContactEntryAsync ( _
    editableEntry As EditableContactEntry, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

editableEntry
Type: ININ.IceLib.Directories..::..EditableContactEntry
The editable entry.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


UpdateSpeedDialLink Method

[image]

IceLib Technical Reference
ContactDirectory..::..UpdateSpeedDialLink Method
ContactDirectory Class See Also Send Feedback
Updates the contact entry link.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateSpeedDialLink(
    ContactEntry speedDialEntry,
    ContactPrimaryNumberDesignation primaryNumberDesignation
)
Visual Basic
Public Sub UpdateSpeedDialLink ( _
    speedDialEntry As ContactEntry, _
    primaryNumberDesignation As ContactPrimaryNumberDesignation _
)

Parameters

speedDialEntry
Type: ININ.IceLib.Directories..::..ContactEntry
The speed dial entry.
primaryNumberDesignation
Type: ININ.IceLib.Directories..::..ContactPrimaryNumberDesignation
The primary number designation.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace
EditableContactEntry..::..PrimaryNumberDesignation


UpdateSpeedDialLinkAsync Method

[image]

IceLib Technical Reference
ContactDirectory..::..UpdateSpeedDialLinkAsync Method
ContactDirectory Class See Also Send Feedback
Updates the contact entry link asynchronously.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateSpeedDialLinkAsync(
    ContactEntry speedDialEntry,
    ContactPrimaryNumberDesignation primaryNumberDesignation,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateSpeedDialLinkAsync ( _
    speedDialEntry As ContactEntry, _
    primaryNumberDesignation As ContactPrimaryNumberDesignation, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

speedDialEntry
Type: ININ.IceLib.Directories..::..ContactEntry
The speed dial entry.
primaryNumberDesignation
Type: ININ.IceLib.Directories..::..ContactPrimaryNumberDesignation
The primary number designation.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace
EditableContactEntry..::..PrimaryNumberDesignation


ContactDirectory Properties

[image] [image]

IceLib Technical Reference
ContactDirectory Properties
ContactDirectory Class See Also Send Feedback

The ContactDirectory type exposes the following members.

Properties

 | Name | Description
Public property | DirectoriesManager | Gets the directories manager.
Public property | FilteredCount | Gets the total number of entries that match a filter for a view.
Public property | Metadata | Gets the metadata.
Public property | PendingStatus | Identifies if this contact directory has pending contact entries that still need to be loaded from the Interaction Center server.
Public property | TotalCount | Gets the total count of entries in the contact directory that is being watched.

See Also

ContactDirectory Class
ININ.IceLib.Directories Namespace


DirectoriesManager Property

[image]

IceLib Technical Reference
ContactDirectory..::..DirectoriesManager Property
ContactDirectory Class See Also Send Feedback
Gets the directories manager.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoriesManager DirectoriesManager { get; }
Visual Basic
Public ReadOnly Property DirectoriesManager As DirectoriesManager
    Get

Field Value

The directories manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


FilteredCount Property

[image]

IceLib Technical Reference
ContactDirectory..::..FilteredCount Property
ContactDirectory Class See Also Send Feedback
Gets the total number of entries that match a filter for a view.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int FilteredCount { get; }
Visual Basic
Public ReadOnly Property FilteredCount As Integer
    Get

Field Value

The filtered count.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | A StartWatch has not been called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


Metadata Property

[image]

IceLib Technical Reference
ContactDirectory..::..Metadata Property
ContactDirectory Class See Also Send Feedback
Gets the metadata.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryMetadata Metadata { get; }
Visual Basic
Public ReadOnly Property Metadata As DirectoryMetadata
    Get

Field Value

The metadata associated with this directory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


PendingStatus Property

[image]

IceLib Technical Reference
ContactDirectory..::..PendingStatus Property
ContactDirectory Class See Also Send Feedback
Identifies if this contact directory has pending contact entries that still need to be loaded from the Interaction Center server.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PendingStatus PendingStatus { get; }
Visual Basic
Public ReadOnly Property PendingStatus As PendingStatus
    Get

Remarks

In general, if a directory is pending then it will not have any contact entries and if it is not pending it will have all of the currently available contact entries. If a directory is marked as Pending once contacts are loaded the ContactDirectoryChanged event will be used to notify that contacts are available.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


TotalCount Property

[image]

IceLib Technical Reference
ContactDirectory..::..TotalCount Property
ContactDirectory Class See Also Send Feedback
Gets the total count of entries in the contact directory that is being watched.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TotalCount { get; }
Visual Basic
Public ReadOnly Property TotalCount As Integer
    Get

Field Value

The total count.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | A StartWatch has not been called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ContactDirectory Events

[image] [image]

IceLib Technical Reference
ContactDirectory Events
ContactDirectory Class See Also Send Feedback

The ContactDirectory type exposes the following members.

Events

 | Name | Description
Public event | ContactCountChanged | Occurs when the number of contacts in this ContactEntry has changed.
Public event | ContactDirectoryChanged | Occurs when one of the ContactEntry watched objects has changed.
Public event | StartWatchingProgressChanged | Occurs when a call to StartWatchingAsync(AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) sends a progress message.

See Also

ContactDirectory Class
ININ.IceLib.Directories Namespace


ContactCountChanged Event

[image]

IceLib Technical Reference
ContactDirectory..::..ContactCountChanged Event
ContactDirectory Class See Also Send Feedback
Occurs when the number of contacts in this ContactEntry has changed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ContactCountEventArgs> ContactCountChanged
Visual Basic
Public Event ContactCountChanged As EventHandler(Of ContactCountEventArgs)

Remarks

This event will only occur if the contact directory is being watched. To start watching the contact directory call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()(), StartWatchingAsync(AsyncCompletedEventHandler, Object), StartWatching(ContactDirectoryWatchSettings), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ContactDirectoryChanged Event

[image]

IceLib Technical Reference
ContactDirectory..::..ContactDirectoryChanged Event
ContactDirectory Class See Also Send Feedback
Occurs when one of the ContactEntry watched objects has changed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<DirectoryEventArgs<ContactEntry>> ContactDirectoryChanged
Visual Basic
Public Event ContactDirectoryChanged As EventHandler(Of DirectoryEventArgs(Of ContactEntry))

Remarks

This event will only occur if the contact directory is being watched. To start watching the contact directory call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()(), StartWatchingAsync(AsyncCompletedEventHandler, Object), StartWatching(ContactDirectoryWatchSettings), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


StartWatchingProgressChanged Event

[image]

IceLib Technical Reference
ContactDirectory..::..StartWatchingProgressChanged Event
ContactDirectory Class See Also Send Feedback
Occurs when a call to StartWatchingAsync(AsyncCompletedEventHandler, Object) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object) sends a progress message.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ContactDirectoryProgressChangedEventArgs> StartWatchingProgressChanged
Visual Basic
Public Event StartWatchingProgressChanged As EventHandler(Of ContactDirectoryProgressChangedEventArgs)

Remarks

This event is raised on a thread appropriate to the application-model, such as the GUI thread in a UI application.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectory Class
ContactDirectory Members
ININ.IceLib.Directories Namespace


ContactDirectoryProgressChangedEventArgs Class

[image]

IceLib Technical Reference
ContactDirectoryProgressChangedEventArgs Class
Members See Also Send Feedback
Represents the current progress for a task invoked by StartWatchingAsync(AsyncCompletedEventHandler, Object), or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactDirectoryProgressChangedEventArgs : ProgressChangedEventArgs
Visual Basic
Public Class ContactDirectoryProgressChangedEventArgs _
    Inherits ProgressChangedEventArgs

Remarks

It is sometimes impossible to return a progress percentage since the number of entries may be unknown for most directories. A count of items received so far is returned in the property RunningTotalCount.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..ProgressChangedEventArgs
ININ.IceLib.Directories..::..ContactDirectoryProgressChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryProgressChangedEventArgs Members
ININ.IceLib.Directories Namespace


ContactDirectoryProgressChangedEventArgs Members

[image] [image]

IceLib Technical Reference
ContactDirectoryProgressChangedEventArgs Members
ContactDirectoryProgressChangedEventArgs Class Methods Properties See Also Send Feedback

The ContactDirectoryProgressChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ProgressPercentage | Gets the asynchronous task progress percentage. (Inherited from ProgressChangedEventArgs.)
Public property | RunningTotalCount | Gets the running total count of entries received so far.
Public property | UserState | Gets a unique user state. (Inherited from ProgressChangedEventArgs.)

See Also

ContactDirectoryProgressChangedEventArgs Class
ININ.IceLib.Directories Namespace


ContactDirectoryProgressChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
ContactDirectoryProgressChangedEventArgs Methods
ContactDirectoryProgressChangedEventArgs Class See Also Send Feedback

The ContactDirectoryProgressChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactDirectoryProgressChangedEventArgs Class
ININ.IceLib.Directories Namespace


ContactDirectoryProgressChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
ContactDirectoryProgressChangedEventArgs Properties
ContactDirectoryProgressChangedEventArgs Class See Also Send Feedback

The ContactDirectoryProgressChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ProgressPercentage | Gets the asynchronous task progress percentage. (Inherited from ProgressChangedEventArgs.)
Public property | RunningTotalCount | Gets the running total count of entries received so far.
Public property | UserState | Gets a unique user state. (Inherited from ProgressChangedEventArgs.)

See Also

ContactDirectoryProgressChangedEventArgs Class
ININ.IceLib.Directories Namespace


RunningTotalCount Property

[image]

IceLib Technical Reference
ContactDirectoryProgressChangedEventArgs..::..RunningTotalCount Property
ContactDirectoryProgressChangedEventArgs Class See Also Send Feedback
Gets the running total count of entries received so far.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RunningTotalCount { get; internal set; }
Visual Basic
Public Property RunningTotalCount As Integer
    Get
    Friend Set

Field Value

The running total count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryProgressChangedEventArgs Class
ContactDirectoryProgressChangedEventArgs Members
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Class

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings Class
Members Example See Also Send Feedback
This class represents settings for a directory watch that provides a filtered and sorted view of contact entries. This view can be returned in increments or pages at a time.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactDirectoryWatchSettings
Visual Basic
Public Class ContactDirectoryWatchSettings

Remarks

The initial watch is established supplying an instance of this object to StartWatching(ContactDirectoryWatchSettings) or StartWatchingAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object). This class represents an immutable object. Once it is created it can not be modified. Convenience methods (Next and Previous for example,) are available to create slightly altered versions of this object that can be used to change the watch via ChangeWatched(ContactDirectoryWatchSettings) or ChangeWatchedAsync(ContactDirectoryWatchSettings, AsyncCompletedEventHandler, Object).

Once the start or change watch is completed, the watched values are available via a call to GetList()()()().

Examples

CopyC#
Collection<ContactFilterItem> filterItems = new Collection<ContactFilterItem>();
Collection<ContactSortItem> sortItems = new Collection<ContactSortItem>();

// Match all entries that are part of Acme Inc, with a last name starting with the letter 'S'.
filterItems.Add( new ContactFilterMatch(ContactProperty.Company, ContactFilterType.Exact, "Acme Inc.") );
filterItems.Add( new ContactFilterMatch(ContactProperty.LastName, ContactFilterType.Prefix, "S") );

sortItems.Add( new ContactSortItem(ContactProperty.LastName, ListSortDirection.Ascending) );
sortItems.Add( new ContactSortItem(ContactProperty.FirstName, ListSortDirection.Descending) );

ContactDirectoryWatchSettings watchSettings = new ContactDirectoryWatchSettings(0, 50, filterItems, sortItems);

_ContactDirectory.StartWatchingAsync( watchSettings );

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactDirectoryWatchSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Members

[image] [image]

IceLib Technical Reference
ContactDirectoryWatchSettings Members
ContactDirectoryWatchSettings Class Constructors Methods Fields Properties See Also Send Feedback

The ContactDirectoryWatchSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ContactDirectoryWatchSettings(Int32, Int32, IList<(Of <<'(ContactSortItem>)>>)) | Initializes a new instance of the ContactDirectoryWatchSettings class.
Public method | ContactDirectoryWatchSettings(Int32, Int32, ContactFilterItem, ContactSortItem) | Initializes a new instance of the ContactDirectoryWatchSettings class.
Public method | ContactDirectoryWatchSettings(Int32, Int32, IList<(Of <<'(ContactFilterItem>)>>), IList<(Of <<'(ContactSortItem>)>>)) | Initializes a new instance of the ContactDirectoryWatchSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | First | Sets the index to the first page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Jump | Sets a new index value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewCount | Sets a new count for the watch.
Public method | NewFilter | Sets a new filter.
Public method | NewSort | Sets a new sort.
Public method | Next | Sets the index to the next logical value.
Public method | Previous | Sets the index to the previous logical value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
All | Return a ContactDirectoryWatchSettings instance that gets all contact entries with no sorting applied.

Properties

 | Name | Description
Public property | Count | Gets the count of contact entries to retrieve.
Public property | FilterItems | Gets the filter items.
Public property | Index | Gets the contact entry index to start retrieving.
 | MaxCount | Gets the max count.
Public property | SortItems | Gets the sort items.

See Also

ContactDirectoryWatchSettings Class
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Constructor

[image] [image]

IceLib Technical Reference
ContactDirectoryWatchSettings Constructor
ContactDirectoryWatchSettings Class See Also Send Feedback
Initializes a new instance of the ContactDirectoryWatchSettings class.

Overload List

 | Name | Description
Public method | ContactDirectoryWatchSettings(Int32, Int32, IList<(Of <<'(ContactSortItem>)>>)) | Initializes a new instance of the ContactDirectoryWatchSettings class.
Public method | ContactDirectoryWatchSettings(Int32, Int32, ContactFilterItem, ContactSortItem) | Initializes a new instance of the ContactDirectoryWatchSettings class.
Public method | ContactDirectoryWatchSettings(Int32, Int32, IList<(Of <<'(ContactFilterItem>)>>), IList<(Of <<'(ContactSortItem>)>>)) | Initializes a new instance of the ContactDirectoryWatchSettings class.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Constructor (Int32, Int32, IList(ContactSortItem))

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings Constructor (Int32, Int32, IList<(Of <(<'ContactSortItem>)>)>)
ContactDirectoryWatchSettings Class See Also Send Feedback
Initializes a new instance of the ContactDirectoryWatchSettings class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings(
    int index,
    int count,
    IList<ContactSortItem> sortItems
)
Visual Basic
Public Sub New ( _
    index As Integer, _
    count As Integer, _
    sortItems As IList(Of ContactSortItem) _
)

Parameters

index
Type: System..::..Int32
The starting index.
count
Type: System..::..Int32
The count of the number of contact entries to retrieve.
sortItems
Type: System.Collections.Generic..::..IList<(Of <(<' ContactSortItem >)>)>
The sorting.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ContactDirectoryWatchSettings Overload
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Constructor (Int32, Int32, ContactFilterItem, ContactSortItem)

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings Constructor (Int32, Int32, ContactFilterItem, ContactSortItem)
ContactDirectoryWatchSettings Class See Also Send Feedback
Initializes a new instance of the ContactDirectoryWatchSettings class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings(
    int index,
    int count,
    ContactFilterItem filterItem,
    ContactSortItem sortItem
)
Visual Basic
Public Sub New ( _
    index As Integer, _
    count As Integer, _
    filterItem As ContactFilterItem, _
    sortItem As ContactSortItem _
)

Parameters

index
Type: System..::..Int32
The starting index.
count
Type: System..::..Int32
The count of the number of contact entries to retrieve.
filterItem
Type: ININ.IceLib.Directories..::..ContactFilterItem
The filter.
sortItem
Type: ININ.IceLib.Directories..::..ContactSortItem
The sorting.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ContactDirectoryWatchSettings Overload
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Constructor (Int32, Int32, IList(ContactFilterItem), IList(ContactSortItem))

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings Constructor (Int32, Int32, IList<(Of <(<'ContactFilterItem>)>)>, IList<(Of <(<'ContactSortItem>)>)>)
ContactDirectoryWatchSettings Class See Also Send Feedback
Initializes a new instance of the ContactDirectoryWatchSettings class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings(
    int index,
    int count,
    IList<ContactFilterItem> filterItems,
    IList<ContactSortItem> sortItems
)
Visual Basic
Public Sub New ( _
    index As Integer, _
    count As Integer, _
    filterItems As IList(Of ContactFilterItem), _
    sortItems As IList(Of ContactSortItem) _
)

Parameters

index
Type: System..::..Int32
The starting index.
count
Type: System..::..Int32
The count of the number of contact entries to retrieve.
filterItems
Type: System.Collections.Generic..::..IList<(Of <(<' ContactFilterItem >)>)>
The filters.
sortItems
Type: System.Collections.Generic..::..IList<(Of <(<' ContactSortItem >)>)>
The sorting.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ContactDirectoryWatchSettings Overload
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Fields

[image] [image]

IceLib Technical Reference
ContactDirectoryWatchSettings Fields
ContactDirectoryWatchSettings Class See Also Send Feedback

The ContactDirectoryWatchSettings type exposes the following members.

Fields

Name | Description
All | Return a ContactDirectoryWatchSettings instance that gets all contact entries with no sorting applied.

See Also

ContactDirectoryWatchSettings Class
ININ.IceLib.Directories Namespace


All Field

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..All Field
ContactDirectoryWatchSettings Class See Also Send Feedback
Return a ContactDirectoryWatchSettings instance that gets all contact entries with no sorting applied.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly ContactDirectoryWatchSettings All
Visual Basic
Public Shared ReadOnly All As ContactDirectoryWatchSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Methods

[image] [image]

IceLib Technical Reference
ContactDirectoryWatchSettings Methods
ContactDirectoryWatchSettings Class See Also Send Feedback

The ContactDirectoryWatchSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | First | Sets the index to the first page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Jump | Sets a new index value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewCount | Sets a new count for the watch.
Public method | NewFilter | Sets a new filter.
Public method | NewSort | Sets a new sort.
Public method | Next | Sets the index to the next logical value.
Public method | Previous | Sets the index to the previous logical value.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ContactDirectoryWatchSettings Class
ININ.IceLib.Directories Namespace


First Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..First Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets the index to the first page.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings First()
Visual Basic
Public Function First As ContactDirectoryWatchSettings

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Index value increased set to zero, the start of the first page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


Jump Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..Jump Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets a new index value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings Jump(
    int index
)
Visual Basic
Public Function Jump ( _
    index As Integer _
) As ContactDirectoryWatchSettings

Parameters

index
Type: System..::..Int32
The new starting index. Must be greater than or equal to zero.

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Count value set to the new value.

Exceptions

Exception | Condition
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


NewCount Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..NewCount Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets a new count for the watch.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings NewCount(
    int newCountValue
)
Visual Basic
Public Function NewCount ( _
    newCountValue As Integer _
) As ContactDirectoryWatchSettings

Parameters

newCountValue
Type: System..::..Int32
The new count. Must be greater than zero.

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Count value set to the new value.

Exceptions

Exception | Condition
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


NewFilter Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..NewFilter Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets a new filter.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings NewFilter(
    IList<ContactFilterItem> filterItems
)
Visual Basic
Public Function NewFilter ( _
    filterItems As IList(Of ContactFilterItem) _
) As ContactDirectoryWatchSettings

Parameters

filterItems
Type: System.Collections.Generic..::..IList<(Of <(<' ContactFilterItem >)>)>
The new filters.

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Count value set to the new value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


NewSort Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..NewSort Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets a new sort.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings NewSort(
    IList<ContactSortItem> sortItems
)
Visual Basic
Public Function NewSort ( _
    sortItems As IList(Of ContactSortItem) _
) As ContactDirectoryWatchSettings

Parameters

sortItems
Type: System.Collections.Generic..::..IList<(Of <(<' ContactSortItem >)>)>
The new sorting.

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Count value set to the new value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


Next Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..Next Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets the index to the next logical value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings Next()
Visual Basic
Public Function Next As ContactDirectoryWatchSettings

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Index value increased by the Count value. If the new Index were to exceed the MaxCount the returned instance will set the Index to MaxCount.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


Previous Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..Previous Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Sets the index to the previous logical value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactDirectoryWatchSettings Previous()
Visual Basic
Public Function Previous As ContactDirectoryWatchSettings

Return Value

A new ContactDirectoryWatchSettings that is equivalent to this instance, but has the Index value decreased by the value of Count. If the new Index is less than zero, then the Index will be set to zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


ToString Method

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..ToString Method
ContactDirectoryWatchSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


ContactDirectoryWatchSettings Properties

[image] [image]

IceLib Technical Reference
ContactDirectoryWatchSettings Properties
ContactDirectoryWatchSettings Class See Also Send Feedback

The ContactDirectoryWatchSettings type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the count of contact entries to retrieve.
Public property | FilterItems | Gets the filter items.
Public property | Index | Gets the contact entry index to start retrieving.
 | MaxCount | Gets the max count.
Public property | SortItems | Gets the sort items.

See Also

ContactDirectoryWatchSettings Class
ININ.IceLib.Directories Namespace


Count Property

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..Count Property
ContactDirectoryWatchSettings Class See Also Send Feedback
Gets the count of contact entries to retrieve.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Field Value

The count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


FilterItems Property

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..FilterItems Property
ContactDirectoryWatchSettings Class See Also Send Feedback
Gets the filter items.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ContactFilterItem> FilterItems { get; }
Visual Basic
Public ReadOnly Property FilterItems As ReadOnlyCollection(Of ContactFilterItem)
    Get

Field Value

The filter items.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


Index Property

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..Index Property
ContactDirectoryWatchSettings Class See Also Send Feedback
Gets the contact entry index to start retrieving.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get

Field Value

The index.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


MaxCount Property

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..MaxCount Property
ContactDirectoryWatchSettings Class See Also Send Feedback
Gets the max count.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static int MaxCount { get; }
Visual Basic
Public Shared ReadOnly Property MaxCount As Integer
    Get

Field Value

The max count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


SortItems Property

[image]

IceLib Technical Reference
ContactDirectoryWatchSettings..::..SortItems Property
ContactDirectoryWatchSettings Class See Also Send Feedback
Gets the sort items.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ContactSortItem> SortItems { get; }
Visual Basic
Public ReadOnly Property SortItems As ReadOnlyCollection(Of ContactSortItem)
    Get

Field Value

The sort items.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactDirectoryWatchSettings Class
ContactDirectoryWatchSettings Members
ININ.IceLib.Directories Namespace


ContactEntry Class

[image]

IceLib Technical Reference
ContactEntry Class
Members See Also Send Feedback
Represents a directory contact watched object.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactEntry : IComparable<ContactEntry>
Visual Basic
Public Class ContactEntry _
    Implements IComparable(Of ContactEntry)

Remarks

Object instances of this class are obtained by a ContactDirectory instance.

These are read-only entries. A contact may be modified via the EditableContactEntry object.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactEntry
ININ.IceLib.Directories..::..EditableContactEntry
ININ.IceLib.Tracker..::..TrackerContactEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Members
ININ.IceLib.Directories Namespace


ContactEntry Members

[image] [image]

IceLib Technical Reference
ContactEntry Members
ContactEntry Class Methods Properties See Also Send Feedback

The ContactEntry type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultPhoneNumber | This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance.
Public method | GetDisplayableIdentifier | This is a convenience method that will retrieve an displayable identifier for this ContactEntry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAccess | Determines whether the specified access rights have been granted.
Public method | IsOwner | Determines whether the specified possible owner is the actual owner of this contact entry.
Public method | IsPropertySet | Determines whether the specified ContactProperty contains data for this ContactEntry.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AccessRights | Gets the access rights.
Public property | Alias | Gets the alias.
Public property | Assistant | Gets the assistant.
Public property | AssistantPhone | Gets the assistant phone.
Public property | BusinessAddress | Gets the business address.
Public property | BusinessCity | Gets the business city.
Public property | BusinessCountry | Gets the business country.
Public property | BusinessEmail | Gets the business Email.
Public property | BusinessPhone | Gets the business telephone number.
Public property | BusinessPhone2 | Gets the second business phone.
Public property | BusinessState | Gets the state of the business.
Public property | BusinessZipCode | Gets the business zip code.
Public property | Company | Gets the company.
Public property | ContactSources | Gets the contact's source(s). See ContactSource for further details.
Public property | Department | Gets the department.
Public property | DisplayName | Gets the directory contact display name.
Public property | EntryId | Gets the entry ID. A unique identifier for a directory contact instance.
Public property | Extension | Gets the extension.
Public property | ExtensionAsPhoneNumber | Gets the extension in Phone Number format. DirectoryPhoneNumber.
Public property | ExternalContactEntries | Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC.
Public property | ExternalPresenceProviders | Gets the available external presence providers for this contact.
Public property | Fax | Gets the Fax.
Public property | FirstName | Gets the first name of the contact.
Public property | HomeAddress | Gets the home address.
Public property | HomeCity | Gets the home city.
Public property | HomeCountry | Gets the home country.
Public property | HomeEmail | Gets the home Email.
Public property | HomePhone | Gets the home telephone number.
Public property | HomePhone2 | Gets the second home phone.
Public property | HomeState | Gets the state of the home.
Public property | HomeZipCode | Gets the home zip code.
Public property | Index | Gets the location of this contact on a paged directory.
Public property | LastName | Gets the last name of the contact.
Public property | LyncSipAddress | Obsolete. Gets the Lync SIP Address for this contact.
Public property | MobilePhone | Gets the mobile phone.
Public property | Notes | Gets the notes.
Public property | OwnerId | Gets the owner.
Public property | Pager | Gets the pager.
Public property | PrimaryNumberDesignation | Gets the primary number designation.
Public property | Skills | Gets the Skills set for this contact.
Public property | StatusUri | Gets the Status Uri.
Public property | Title | Gets the title.
Public property | TrackerData | Gets the tracker data.
Public property | UserId | Gets the user ID.
Public property | VoicemailLocation | Gets the Voicemail location.
Public property | Webpage | Gets the web page.
Public property | Workgroups | Gets the workgroups.

See Also

ContactEntry Class
ININ.IceLib.Directories Namespace


ContactEntry Methods

[image] [image]

IceLib Technical Reference
ContactEntry Methods
ContactEntry Class See Also Send Feedback

The ContactEntry type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultPhoneNumber | This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance.
Public method | GetDisplayableIdentifier | This is a convenience method that will retrieve an displayable identifier for this ContactEntry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAccess | Determines whether the specified access rights have been granted.
Public method | IsOwner | Determines whether the specified possible owner is the actual owner of this contact entry.
Public method | IsPropertySet | Determines whether the specified ContactProperty contains data for this ContactEntry.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ContactEntry Class
ININ.IceLib.Directories Namespace


CompareTo Method

[image]

IceLib Technical Reference
ContactEntry..::..CompareTo Method
ContactEntry Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    ContactEntry rhs
)
Visual Basic
Public Function CompareTo ( _
    rhs As ContactEntry _
) As Integer

Parameters

rhs
Type: ININ.IceLib.Directories..::..ContactEntry

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


GetDefaultPhoneNumber Method

[image]

IceLib Technical Reference
ContactEntry..::..GetDefaultPhoneNumber Method
ContactEntry Class See Also Send Feedback
This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber GetDefaultPhoneNumber()
Visual Basic
Public Function GetDefaultPhoneNumber As DirectoryPhoneNumber

Return Value

A directory phone number. If none could be found an empty phone number is returned.

Remarks

This method will first check the phone number associated with the PrimaryNumberDesignation and return that phone's DirectoryPhoneNumber property, if it is not empty.

If the phone number property is not set for the primary number designation, this method will look for the first phone number set in the following order: Extension, BusinessPhone, HomePhone, BusinessPhone2, HomePhone2, MobilePhone, AssistantPhone, Pager, and then Fax.

If there is no phone number available an empty DirectoryPhoneNumber is returned.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


GetDisplayableIdentifier Method

[image]

IceLib Technical Reference
ContactEntry..::..GetDisplayableIdentifier Method
ContactEntry Class See Also Send Feedback
This is a convenience method that will retrieve an displayable identifier for this ContactEntry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetDisplayableIdentifier()
Visual Basic
Public Function GetDisplayableIdentifier As String

Return Value

A displayable identifier for this ContactEntry.

Remarks

This method iterates over this ContactEntry and tries to get the best displayable identifier, every time it finds a blank string it moves on. The order it uses is: DisplayName FirstName LastName UserId Company DefaultNumber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ContactEntry..::..GetHashCode Method
ContactEntry Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HasAccess Method

[image]

IceLib Technical Reference
ContactEntry..::..HasAccess Method
ContactEntry Class See Also Send Feedback
Determines whether the specified access rights have been granted.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasAccess(
    ContactAccessRights rights
)
Visual Basic
Public Function HasAccess ( _
    rights As ContactAccessRights _
) As Boolean

Parameters

rights
Type: ININ.IceLib.Directories..::..ContactAccessRights
The rights.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified rights to check has access; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


IsOwner Method

[image]

IceLib Technical Reference
ContactEntry..::..IsOwner Method
ContactEntry Class See Also Send Feedback
Determines whether the specified possible owner is the actual owner of this contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsOwner(
    string possibleOwner
)
Visual Basic
Public Function IsOwner ( _
    possibleOwner As String _
) As Boolean

Parameters

possibleOwner
Type: System..::..String
The possible owner.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified possible owner is owner; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


IsPropertySet Method

[image]

IceLib Technical Reference
ContactEntry..::..IsPropertySet Method
ContactEntry Class See Also Send Feedback
Determines whether the specified ContactProperty contains data for this ContactEntry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPropertySet(
    ContactProperty contactProperty
)
Visual Basic
Public Function IsPropertySet ( _
    contactProperty As ContactProperty _
) As Boolean

Parameters

contactProperty
Type: ININ.IceLib.Directories..::..ContactProperty
The ContactProperty to check.

Return Value

trueTruetruetrue (True in Visual Basic) if the ContactProperty contains data; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ToString Method

[image]

IceLib Technical Reference
ContactEntry..::..ToString Method
ContactEntry Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ContactEntry Properties

[image] [image]

IceLib Technical Reference
ContactEntry Properties
ContactEntry Class See Also Send Feedback

The ContactEntry type exposes the following members.

Properties

 | Name | Description
Public property | AccessRights | Gets the access rights.
Public property | Alias | Gets the alias.
Public property | Assistant | Gets the assistant.
Public property | AssistantPhone | Gets the assistant phone.
Public property | BusinessAddress | Gets the business address.
Public property | BusinessCity | Gets the business city.
Public property | BusinessCountry | Gets the business country.
Public property | BusinessEmail | Gets the business Email.
Public property | BusinessPhone | Gets the business telephone number.
Public property | BusinessPhone2 | Gets the second business phone.
Public property | BusinessState | Gets the state of the business.
Public property | BusinessZipCode | Gets the business zip code.
Public property | Company | Gets the company.
Public property | ContactSources | Gets the contact's source(s). See ContactSource for further details.
Public property | Department | Gets the department.
Public property | DisplayName | Gets the directory contact display name.
Public property | EntryId | Gets the entry ID. A unique identifier for a directory contact instance.
Public property | Extension | Gets the extension.
Public property | ExtensionAsPhoneNumber | Gets the extension in Phone Number format. DirectoryPhoneNumber.
Public property | ExternalContactEntries | Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC.
Public property | ExternalPresenceProviders | Gets the available external presence providers for this contact.
Public property | Fax | Gets the Fax.
Public property | FirstName | Gets the first name of the contact.
Public property | HomeAddress | Gets the home address.
Public property | HomeCity | Gets the home city.
Public property | HomeCountry | Gets the home country.
Public property | HomeEmail | Gets the home Email.
Public property | HomePhone | Gets the home telephone number.
Public property | HomePhone2 | Gets the second home phone.
Public property | HomeState | Gets the state of the home.
Public property | HomeZipCode | Gets the home zip code.
Public property | Index | Gets the location of this contact on a paged directory.
Public property | LastName | Gets the last name of the contact.
Public property | LyncSipAddress | Obsolete. Gets the Lync SIP Address for this contact.
Public property | MobilePhone | Gets the mobile phone.
Public property | Notes | Gets the notes.
Public property | OwnerId | Gets the owner.
Public property | Pager | Gets the pager.
Public property | PrimaryNumberDesignation | Gets the primary number designation.
Public property | Skills | Gets the Skills set for this contact.
Public property | StatusUri | Gets the Status Uri.
Public property | Title | Gets the title.
Public property | TrackerData | Gets the tracker data.
Public property | UserId | Gets the user ID.
Public property | VoicemailLocation | Gets the Voicemail location.
Public property | Webpage | Gets the web page.
Public property | Workgroups | Gets the workgroups.

See Also

ContactEntry Class
ININ.IceLib.Directories Namespace


AccessRights Property

[image]

IceLib Technical Reference
ContactEntry..::..AccessRights Property
ContactEntry Class See Also Send Feedback
Gets the access rights.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactAccessRights AccessRights { get; }
Visual Basic
Public ReadOnly Property AccessRights As ContactAccessRights
    Get

Field Value

The contact's access rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Alias Property

[image]

IceLib Technical Reference
ContactEntry..::..Alias Property
ContactEntry Class See Also Send Feedback
Gets the alias.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Alias { get; }
Visual Basic
Public ReadOnly Property Alias As String
    Get

Field Value

The contact's alias.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Assistant Property

[image]

IceLib Technical Reference
ContactEntry..::..Assistant Property
ContactEntry Class See Also Send Feedback
Gets the assistant.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Assistant { get; }
Visual Basic
Public ReadOnly Property Assistant As String
    Get

Field Value

The name of the contact's assistant or subordinate.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


AssistantPhone Property

[image]

IceLib Technical Reference
ContactEntry..::..AssistantPhone Property
ContactEntry Class See Also Send Feedback
Gets the assistant phone.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber AssistantPhone { get; }
Visual Basic
Public ReadOnly Property AssistantPhone As DirectoryPhoneNumber
    Get

Field Value

The assistant's telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessAddress Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessAddress Property
ContactEntry Class See Also Send Feedback
Gets the business address.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessAddress { get; }
Visual Basic
Public ReadOnly Property BusinessAddress As String
    Get

Field Value

The contact's business address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessCity Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessCity Property
ContactEntry Class See Also Send Feedback
Gets the business city.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCity { get; }
Visual Basic
Public ReadOnly Property BusinessCity As String
    Get

Field Value

The city where the business is located.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessCountry Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessCountry Property
ContactEntry Class See Also Send Feedback
Gets the business country.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCountry { get; }
Visual Basic
Public ReadOnly Property BusinessCountry As String
    Get

Field Value

The country where the business is located.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessEmail Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessEmail Property
ContactEntry Class See Also Send Feedback
Gets the business Email.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessEmail { get; }
Visual Basic
Public ReadOnly Property BusinessEmail As String
    Get

Field Value

The business Email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessPhone Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessPhone Property
ContactEntry Class See Also Send Feedback
Gets the business telephone number.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber BusinessPhone { get; }
Visual Basic
Public ReadOnly Property BusinessPhone As DirectoryPhoneNumber
    Get

Field Value

The contact's business telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessPhone2 Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessPhone2 Property
ContactEntry Class See Also Send Feedback
Gets the second business phone.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber BusinessPhone2 { get; }
Visual Basic
Public ReadOnly Property BusinessPhone2 As DirectoryPhoneNumber
    Get

Field Value

The contact's alternate business telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessState Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessState Property
ContactEntry Class See Also Send Feedback
Gets the state of the business.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessState { get; }
Visual Basic
Public ReadOnly Property BusinessState As String
    Get

Field Value

The state where the business is located.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


BusinessZipCode Property

[image]

IceLib Technical Reference
ContactEntry..::..BusinessZipCode Property
ContactEntry Class See Also Send Feedback
Gets the business zip code.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessZipCode { get; }
Visual Basic
Public ReadOnly Property BusinessZipCode As String
    Get

Field Value

The business address zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Company Property

[image]

IceLib Technical Reference
ContactEntry..::..Company Property
ContactEntry Class See Also Send Feedback
Gets the company.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; }
Visual Basic
Public ReadOnly Property Company As String
    Get

Field Value

The company that this contact works for.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ContactSources Property

[image]

IceLib Technical Reference
ContactEntry..::..ContactSources Property
ContactEntry Class See Also Send Feedback
Gets the contact's source(s). See ContactSource for further details.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactSource ContactSources { get; }
Visual Basic
Public ReadOnly Property ContactSources As ContactSource
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Department Property

[image]

IceLib Technical Reference
ContactEntry..::..Department Property
ContactEntry Class See Also Send Feedback
Gets the department.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; }
Visual Basic
Public ReadOnly Property Department As String
    Get

Field Value

The department that this contact works in.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


DisplayName Property

[image]

IceLib Technical Reference
ContactEntry..::..DisplayName Property
ContactEntry Class See Also Send Feedback
Gets the directory contact display name.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The contact's display name. Usually this is Lastname, Firstname.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


EntryId Property

[image]

IceLib Technical Reference
ContactEntry..::..EntryId Property
ContactEntry Class See Also Send Feedback
Gets the entry ID. A unique identifier for a directory contact instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EntryId { get; }
Visual Basic
Public ReadOnly Property EntryId As String
    Get

Field Value

The entry ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Extension Property

[image]

IceLib Technical Reference
ContactEntry..::..Extension Property
ContactEntry Class See Also Send Feedback
Gets the extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The contact's extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ExtensionAsPhoneNumber Property

[image]

IceLib Technical Reference
ContactEntry..::..ExtensionAsPhoneNumber Property
ContactEntry Class See Also Send Feedback
Gets the extension in Phone Number format. DirectoryPhoneNumber.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber ExtensionAsPhoneNumber { get; }
Visual Basic
Public ReadOnly Property ExtensionAsPhoneNumber As DirectoryPhoneNumber
    Get

Field Value

The contact's telephone extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ExternalContactEntries Property

[image]

IceLib Technical Reference
ContactEntry..::..ExternalContactEntries Property
ContactEntry Class See Also Send Feedback
Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExternalContactEntries ExternalContactEntries { get; }
Visual Basic
Public ReadOnly Property ExternalContactEntries As ExternalContactEntries
    Get

Remarks

Note
This information has been provided to support internal ININ integrations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ExternalPresenceProviders Property

[image]

IceLib Technical Reference
ContactEntry..::..ExternalPresenceProviders Property
ContactEntry Class See Also Send Feedback
Gets the available external presence providers for this contact.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExternalPresenceProviders ExternalPresenceProviders { get; }
Visual Basic
Public ReadOnly Property ExternalPresenceProviders As ExternalPresenceProviders
    Get

Field Value

The external presence providers.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Fax Property

[image]

IceLib Technical Reference
ContactEntry..::..Fax Property
ContactEntry Class See Also Send Feedback
Gets the Fax.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber Fax { get; }
Visual Basic
Public ReadOnly Property Fax As DirectoryPhoneNumber
    Get

Field Value

The telephone number of the contact's Fax machine.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


FirstName Property

[image]

IceLib Technical Reference
ContactEntry..::..FirstName Property
ContactEntry Class See Also Send Feedback
Gets the first name of the contact.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; }
Visual Basic
Public ReadOnly Property FirstName As String
    Get

Field Value

The contact's first name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomeAddress Property

[image]

IceLib Technical Reference
ContactEntry..::..HomeAddress Property
ContactEntry Class See Also Send Feedback
Gets the home address.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeAddress { get; }
Visual Basic
Public ReadOnly Property HomeAddress As String
    Get

Field Value

The contact's number and street, apartment, etc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomeCity Property

[image]

IceLib Technical Reference
ContactEntry..::..HomeCity Property
ContactEntry Class See Also Send Feedback
Gets the home city.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeCity { get; }
Visual Basic
Public ReadOnly Property HomeCity As String
    Get

Field Value

The home address city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomeCountry Property

[image]

IceLib Technical Reference
ContactEntry..::..HomeCountry Property
ContactEntry Class See Also Send Feedback
Gets the home country.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeCountry { get; }
Visual Basic
Public ReadOnly Property HomeCountry As String
    Get

Field Value

The country associated with the contact's home address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomeEmail Property

[image]

IceLib Technical Reference
ContactEntry..::..HomeEmail Property
ContactEntry Class See Also Send Feedback
Gets the home Email.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeEmail { get; }
Visual Basic
Public ReadOnly Property HomeEmail As String
    Get

Field Value

The contact's personal Email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomePhone Property

[image]

IceLib Technical Reference
ContactEntry..::..HomePhone Property
ContactEntry Class See Also Send Feedback
Gets the home telephone number.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber HomePhone { get; }
Visual Basic
Public ReadOnly Property HomePhone As DirectoryPhoneNumber
    Get

Field Value

The contact's home telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomePhone2 Property

[image]

IceLib Technical Reference
ContactEntry..::..HomePhone2 Property
ContactEntry Class See Also Send Feedback
Gets the second home phone.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber HomePhone2 { get; }
Visual Basic
Public ReadOnly Property HomePhone2 As DirectoryPhoneNumber
    Get

Field Value

The contact's secondary home phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomeState Property

[image]

IceLib Technical Reference
ContactEntry..::..HomeState Property
ContactEntry Class See Also Send Feedback
Gets the state of the home.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeState { get; }
Visual Basic
Public ReadOnly Property HomeState As String
    Get

Field Value

The state where the home is located.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


HomeZipCode Property

[image]

IceLib Technical Reference
ContactEntry..::..HomeZipCode Property
ContactEntry Class See Also Send Feedback
Gets the home zip code.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeZipCode { get; }
Visual Basic
Public ReadOnly Property HomeZipCode As String
    Get

Field Value

The home address zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Index Property

[image]

IceLib Technical Reference
ContactEntry..::..Index Property
ContactEntry Class See Also Send Feedback
Gets the location of this contact on a paged directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Index { get; }
Visual Basic
Public ReadOnly Property Index As String
    Get

Field Value

The location.

Remarks

Note that this property makes sense only when the application is receiving notifications on a paged directory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


LastName Property

[image]

IceLib Technical Reference
ContactEntry..::..LastName Property
ContactEntry Class See Also Send Feedback
Gets the last name of the contact.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; }
Visual Basic
Public ReadOnly Property LastName As String
    Get

Field Value

The contact's last name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


LyncSipAddress Property

[image]

IceLib Technical Reference
ContactEntry..::..LyncSipAddress Property
ContactEntry Class See Also Send Feedback
Gets the Lync SIP Address for this contact.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("LyncSipAddress is obsolete as of 4.0 SU 03.")]
public string LyncSipAddress { get; }
Visual Basic
<ObsoleteAttribute("LyncSipAddress is obsolete as of 4.0 SU 03.")> _
Public ReadOnly Property LyncSipAddress As String
    Get

Field Value

The Lync SIP Address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


MobilePhone Property

[image]

IceLib Technical Reference
ContactEntry..::..MobilePhone Property
ContactEntry Class See Also Send Feedback
Gets the mobile phone.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber MobilePhone { get; }
Visual Basic
Public ReadOnly Property MobilePhone As DirectoryPhoneNumber
    Get

Field Value

The contact's mobile phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Notes Property

[image]

IceLib Technical Reference
ContactEntry..::..Notes Property
ContactEntry Class See Also Send Feedback
Gets the notes.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; }
Visual Basic
Public ReadOnly Property Notes As String
    Get

Field Value

The note text, if any, that is stored in this contact entry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


OwnerId Property

[image]

IceLib Technical Reference
ContactEntry..::..OwnerId Property
ContactEntry Class See Also Send Feedback
Gets the owner.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As String
    Get

Field Value

The owner of this contact entry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Pager Property

[image]

IceLib Technical Reference
ContactEntry..::..Pager Property
ContactEntry Class See Also Send Feedback
Gets the pager.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber Pager { get; }
Visual Basic
Public ReadOnly Property Pager As DirectoryPhoneNumber
    Get

Field Value

The contact's pager number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


PrimaryNumberDesignation Property

[image]

IceLib Technical Reference
ContactEntry..::..PrimaryNumberDesignation Property
ContactEntry Class See Also Send Feedback
Gets the primary number designation.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactPrimaryNumberDesignation PrimaryNumberDesignation { get; }
Visual Basic
Public ReadOnly Property PrimaryNumberDesignation As ContactPrimaryNumberDesignation
    Get

Field Value

The primary number designation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Skills Property

[image]

IceLib Technical Reference
ContactEntry..::..Skills Property
ContactEntry Class See Also Send Feedback
Gets the Skills set for this contact.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<UserSkill> Skills { get; }
Visual Basic
Public ReadOnly Property Skills As ReadOnlyCollection(Of UserSkill)
    Get

Field Value

The Skills that this contact has.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


StatusUri Property

[image]

IceLib Technical Reference
ContactEntry..::..StatusUri Property
ContactEntry Class See Also Send Feedback
Gets the Status Uri.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StatusUri { get; }
Visual Basic
Public ReadOnly Property StatusUri As String
    Get

Field Value

The contact's Status Uri.

Remarks

This can be used for watching / retrieving user's status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Title Property

[image]

IceLib Technical Reference
ContactEntry..::..Title Property
ContactEntry Class See Also Send Feedback
Gets the title.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get

Field Value

The contact's job title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


TrackerData Property

[image]

IceLib Technical Reference
ContactEntry..::..TrackerData Property
ContactEntry Class See Also Send Feedback
Gets the tracker data.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerData { get; }
Visual Basic
Public ReadOnly Property TrackerData As String
    Get

Field Value

The tracker data.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


UserId Property

[image]

IceLib Technical Reference
ContactEntry..::..UserId Property
ContactEntry Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


VoicemailLocation Property

[image]

IceLib Technical Reference
ContactEntry..::..VoicemailLocation Property
ContactEntry Class See Also Send Feedback
Gets the Voicemail location.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string VoicemailLocation { get; }
Visual Basic
Public ReadOnly Property VoicemailLocation As String
    Get

Field Value

The Voicemail location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Webpage Property

[image]

IceLib Technical Reference
ContactEntry..::..Webpage Property
ContactEntry Class See Also Send Feedback
Gets the web page.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Webpage { get; }
Visual Basic
Public ReadOnly Property Webpage As String
    Get

Field Value

The URL of a corporate web page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


Workgroups Property

[image]

IceLib Technical Reference
ContactEntry..::..Workgroups Property
ContactEntry Class See Also Send Feedback
Gets the workgroups.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As ReadOnlyCollection(Of String)
    Get

Field Value

The workgroups that this contact is a member of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactEntry Class
ContactEntry Members
ININ.IceLib.Directories Namespace


ContactFilterGroup Class

[image]

IceLib Technical Reference
ContactFilterGroup Class
Members See Also Send Feedback
Represents a grouping of filter items.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactFilterGroup : ContactFilterItem
Visual Basic
Public Class ContactFilterGroup _
    Inherits ContactFilterItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactFilterItem
ININ.IceLib.Directories..::..ContactFilterGroup

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterGroup Members
ININ.IceLib.Directories Namespace


ContactFilterGroup Members

[image] [image]

IceLib Technical Reference
ContactFilterGroup Members
ContactFilterGroup Class Constructors Methods Properties See Also Send Feedback

The ContactFilterGroup type exposes the following members.

Constructors

 | Name | Description
Public method | ContactFilterGroup | Initializes a new instance of the ContactFilterGroup class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterItems | Gets the filter items.
Public property | MatchAny | Gets a value indicating whether the group matches for any contained match.

See Also

ContactFilterGroup Class
ININ.IceLib.Directories Namespace


ContactFilterGroup Constructor

[image]

IceLib Technical Reference
ContactFilterGroup Constructor
ContactFilterGroup Class See Also Send Feedback
Initializes a new instance of the ContactFilterGroup class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactFilterGroup(
    IList<ContactFilterItem> filterItems,
    bool matchAny
)
Visual Basic
Public Sub New ( _
    filterItems As IList(Of ContactFilterItem), _
    matchAny As Boolean _
)

Parameters

filterItems
Type: System.Collections.Generic..::..IList<(Of <(<' ContactFilterItem >)>)>
The filter items.
matchAny
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) matches if any contained ContactFilterItem matches.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterGroup Class
ContactFilterGroup Members
ININ.IceLib.Directories Namespace


ContactFilterGroup Methods

[image] [image]

IceLib Technical Reference
ContactFilterGroup Methods
ContactFilterGroup Class See Also Send Feedback

The ContactFilterGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactFilterGroup Class
ININ.IceLib.Directories Namespace


ContactFilterGroup Properties

[image] [image]

IceLib Technical Reference
ContactFilterGroup Properties
ContactFilterGroup Class See Also Send Feedback

The ContactFilterGroup type exposes the following members.

Properties

 | Name | Description
Public property | FilterItems | Gets the filter items.
Public property | MatchAny | Gets a value indicating whether the group matches for any contained match.

See Also

ContactFilterGroup Class
ININ.IceLib.Directories Namespace


FilterItems Property

[image]

IceLib Technical Reference
ContactFilterGroup..::..FilterItems Property
ContactFilterGroup Class See Also Send Feedback
Gets the filter items.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ContactFilterItem> FilterItems { get; }
Visual Basic
Public ReadOnly Property FilterItems As ReadOnlyCollection(Of ContactFilterItem)
    Get

Field Value

The filter items.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterGroup Class
ContactFilterGroup Members
ININ.IceLib.Directories Namespace


MatchAny Property

[image]

IceLib Technical Reference
ContactFilterGroup..::..MatchAny Property
ContactFilterGroup Class See Also Send Feedback
Gets a value indicating whether the group matches for any contained match.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool MatchAny { get; }
Visual Basic
Public ReadOnly Property MatchAny As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if any contained ContactFilterItem matches; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterGroup Class
ContactFilterGroup Members
ININ.IceLib.Directories Namespace


ContactFilterItem Class

[image]

IceLib Technical Reference
ContactFilterItem Class
Members See Also Send Feedback
Serves as a base class for items that filter contact entries that should be returned.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ContactFilterItem
Visual Basic
Public MustInherit Class ContactFilterItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactFilterItem
ININ.IceLib.Directories..::..ContactFilterGroup
ININ.IceLib.Directories..::..ContactFilterMatch

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterItem Members
ININ.IceLib.Directories Namespace


ContactFilterItem Members

[image] [image]

IceLib Technical Reference
ContactFilterItem Members
ContactFilterItem Class Constructors Methods See Also Send Feedback

The ContactFilterItem type exposes the following members.

Constructors

 | Name | Description
Protected method | ContactFilterItem | Initializes a new instance of the ContactFilterItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactFilterItem Class
ININ.IceLib.Directories Namespace


ContactFilterItem Constructor

[image]

IceLib Technical Reference
ContactFilterItem Constructor
ContactFilterItem Class See Also Send Feedback
Initializes a new instance of the ContactFilterItem class

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ContactFilterItem()
Visual Basic
Protected Sub New

See Also

ContactFilterItem Class
ContactFilterItem Members
ININ.IceLib.Directories Namespace


ContactFilterItem Methods

[image] [image]

IceLib Technical Reference
ContactFilterItem Methods
ContactFilterItem Class See Also Send Feedback

The ContactFilterItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactFilterItem Class
ININ.IceLib.Directories Namespace


ContactFilterMatch Class

[image]

IceLib Technical Reference
ContactFilterMatch Class
Members See Also Send Feedback
Represents an item to filter contact entries that should be returned.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactFilterMatch : ContactFilterItem
Visual Basic
Public Class ContactFilterMatch _
    Inherits ContactFilterItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactFilterItem
ININ.IceLib.Directories..::..ContactFilterMatch

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterMatch Members
ININ.IceLib.Directories Namespace


ContactFilterMatch Members

[image] [image]

IceLib Technical Reference
ContactFilterMatch Members
ContactFilterMatch Class Constructors Methods Properties See Also Send Feedback

The ContactFilterMatch type exposes the following members.

Constructors

 | Name | Description
Public method | ContactFilterMatch(ContactProperty, ContactFilterType, IList<(Of <<'(String>)>>)) | Initializes a new instance of the ContactFilterMatch class for multiple expressions.
Public method | ContactFilterMatch(ContactProperty, ContactFilterType, String) | Initializes a new instance of the ContactFilterMatch class for a single expression.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterExpressions | Gets the filter expressions.
Public property | FilterType | Gets the type of the filter.
Public property | Property | Gets the property.

See Also

ContactFilterMatch Class
ININ.IceLib.Directories Namespace


ContactFilterMatch Constructor

[image] [image]

IceLib Technical Reference
ContactFilterMatch Constructor
ContactFilterMatch Class See Also Send Feedback
Initializes a new instance of the ContactFilterMatch class.

Overload List

 | Name | Description
Public method | ContactFilterMatch(ContactProperty, ContactFilterType, IList<(Of <<'(String>)>>)) | Initializes a new instance of the ContactFilterMatch class for multiple expressions.
Public method | ContactFilterMatch(ContactProperty, ContactFilterType, String) | Initializes a new instance of the ContactFilterMatch class for a single expression.

See Also

ContactFilterMatch Class
ContactFilterMatch Members
ININ.IceLib.Directories Namespace


ContactFilterMatch Constructor (ContactProperty, ContactFilterType, IList(String))

[image]

IceLib Technical Reference
ContactFilterMatch Constructor (ContactProperty, ContactFilterType, IList<(Of <(<'String>)>)>)
ContactFilterMatch Class See Also Send Feedback
Initializes a new instance of the ContactFilterMatch class for multiple expressions.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactFilterMatch(
    ContactProperty property,
    ContactFilterType filterType,
    IList<string> filterExpressions
)
Visual Basic
Public Sub New ( _
    property As ContactProperty, _
    filterType As ContactFilterType, _
    filterExpressions As IList(Of String) _
)

Parameters

property
Type: ININ.IceLib.Directories..::..ContactProperty
The contact property.
filterType
Type: ININ.IceLib.Directories..::..ContactFilterType
Type of the filter.
filterExpressions
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The filter expressions.

Remarks

The filter will match if any of the specified expressions matches according to the property and filterType.

Exceptions

Exception | Condition
System..::..ArgumentException | An invalid ContactFilterType and ContactProperty was used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterMatch Class
ContactFilterMatch Members
ContactFilterMatch Overload
ININ.IceLib.Directories Namespace


ContactFilterMatch Constructor (ContactProperty, ContactFilterType, String)

[image]

IceLib Technical Reference
ContactFilterMatch Constructor (ContactProperty, ContactFilterType, String)
ContactFilterMatch Class See Also Send Feedback
Initializes a new instance of the ContactFilterMatch class for a single expression.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactFilterMatch(
    ContactProperty property,
    ContactFilterType filterType,
    string filterExpression
)
Visual Basic
Public Sub New ( _
    property As ContactProperty, _
    filterType As ContactFilterType, _
    filterExpression As String _
)

Parameters

property
Type: ININ.IceLib.Directories..::..ContactProperty
The contact property.
filterType
Type: ININ.IceLib.Directories..::..ContactFilterType
Type of the filter.
filterExpression
Type: System..::..String
The filter expression.

Remarks

The filter will match if any of the specified expressions matches according to the property and filterType.

Exceptions

Exception | Condition
System..::..ArgumentException | An invalid ContactFilterType and ContactProperty combination was used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterMatch Class
ContactFilterMatch Members
ContactFilterMatch Overload
ININ.IceLib.Directories Namespace


ContactFilterMatch Methods

[image] [image]

IceLib Technical Reference
ContactFilterMatch Methods
ContactFilterMatch Class See Also Send Feedback

The ContactFilterMatch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactFilterMatch Class
ININ.IceLib.Directories Namespace


ContactFilterMatch Properties

[image] [image]

IceLib Technical Reference
ContactFilterMatch Properties
ContactFilterMatch Class See Also Send Feedback

The ContactFilterMatch type exposes the following members.

Properties

 | Name | Description
Public property | FilterExpressions | Gets the filter expressions.
Public property | FilterType | Gets the type of the filter.
Public property | Property | Gets the property.

See Also

ContactFilterMatch Class
ININ.IceLib.Directories Namespace


FilterExpressions Property

[image]

IceLib Technical Reference
ContactFilterMatch..::..FilterExpressions Property
ContactFilterMatch Class See Also Send Feedback
Gets the filter expressions.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> FilterExpressions { get; }
Visual Basic
Public ReadOnly Property FilterExpressions As ReadOnlyCollection(Of String)
    Get

Field Value

The filter expressions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterMatch Class
ContactFilterMatch Members
ININ.IceLib.Directories Namespace


FilterType Property

[image]

IceLib Technical Reference
ContactFilterMatch..::..FilterType Property
ContactFilterMatch Class See Also Send Feedback
Gets the type of the filter.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactFilterType FilterType { get; }
Visual Basic
Public ReadOnly Property FilterType As ContactFilterType
    Get

Field Value

The type of the filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterMatch Class
ContactFilterMatch Members
ININ.IceLib.Directories Namespace


Property Property

[image]

IceLib Technical Reference
ContactFilterMatch..::..Property Property
ContactFilterMatch Class See Also Send Feedback
Gets the property.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactProperty Property { get; }
Visual Basic
Public ReadOnly Property Property As ContactProperty
    Get

Field Value

The property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactFilterMatch Class
ContactFilterMatch Members
ININ.IceLib.Directories Namespace


ContactFilterType Enumeration

[image]

IceLib Technical Reference
ContactFilterType Enumeration
See Also Send Feedback
Represents the type of pattern matching that should be performed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ContactFilterType
Visual Basic
Public Enumeration ContactFilterType

Members

Member name | Value | Description
Exact | 0 | The filter matches a property exactly.
Prefix | 1 | The filter matches the prefix of a property's value.
Exists | 2 | The filter matches if the property exists. That is it has a non-empty value.
Empty | 3 | The filter matches if the property value is empty. That is it does not have a value.
Wildcards | 4 | The filter matches using a expression that contains wildcards. The filter expression may contain wildcard symbols. A "*" will match zero or more characters. A "?" will match any single character. For example "Dev*" would match "Developers", "Development-Asia", and "Devices". "T?m" would match "Tim" and "Tom" but not "Team". This filter type is not allowed for the AccessRights property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


ContactPrimaryNumberDesignation Enumeration

[image]

IceLib Technical Reference
ContactPrimaryNumberDesignation Enumeration
See Also Send Feedback
Specifies constants indicating which directory contact property is the primary number.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ContactPrimaryNumberDesignation
Visual Basic
Public Enumeration ContactPrimaryNumberDesignation

Members

Member name | Value | Description
None | 0 | No primary number designation specified.
BusinessPhone | 1 | The contact entry property BusinessPhone is the primary number.
BusinessPhone2 | 2 | The contact entry property BusinessPhone2 is the primary number.
HomePhone | 3 | The contact entry property HomePhone is the primary number.
HomePhone2 | 4 | The contact entry property HomePhone2 is the primary number.
MobilePhone | 5 | The contact entry property MobilePhone is the primary number.
Fax | 6 | The contact entry property Fax is the primary number.
Pager | 7 | The contact entry property Pager is the primary number.
AssistantPhone | 8 | The contact entry property AssistantPhone is the primary number.
Extension | 9 | The contact entry property Extension is the primary number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


ContactProperty Enumeration

[image]

IceLib Technical Reference
ContactProperty Enumeration
See Also Send Feedback
Each value in this enumeration represents a property in ContactEntry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ContactProperty
Visual Basic
Public Enumeration ContactProperty

Members

Member name | Value | Description
None | 0 | No property is defined.
EntryId | 1 | Represents the EntryId property.
FirstName | 2 | Represents the FirstName property.
LastName | 3 | Represents the LastName property.
Extension | 4 | Represents the Extension property.
UserId | 5 | Represents the UserId property.
Department | 6 | Represents the Department property.
Company | 7 | Represents the Company property.
Title | 8 | Represents the Title property.
BusinessAddress | 9 | Represents the BusinessAddress property.
BusinessCity | 10 | Represents the BusinessCity property.
BusinessState | 11 | Represents the BusinessState property.
BusinessZipCode | 12 | Represents the BusinessZipCode property.
BusinessCountry | 13 | Represents the BusinessCountry property.
BusinessEmail | 14 | Represents the BusinessEmail property.
Assistant | 15 | Represents the Assistant property.
HomeCountry | 16 | Represents the HomeCountry property.
HomeEmail | 17 | Represents the HomeEmail property.
BusinessPhone | 18 | Represents the BusinessPhone property.
BusinessPhone2 | 19 | Represents the BusinessPhone2 property.
HomePhone2 | 20 | Represents the HomePhone2 property.
MobilePhone | 21 | Represents the MobilePhone property.
Fax | 22 | Represents the Fax property.
Pager | 23 | Represents the Pager property.
AssistantPhone | 24 | Represents the AssistantPhone property.
Webpage | 25 | Represents the Webpage property.
PrimaryNumberDesignation | 26 | Represents the PrimaryNumberDesignation property.
Notes | 27 | Represents the Notes property.
DisplayName | 28 | Represents the DisplayName property.
HomeAddress | 29 | Represents the HomeAddress property.
HomeCity | 30 | Represents the HomeCity property.
HomeState | 31 | Represents the HomeState property.
HomeZipCode | 32 | Represents the HomeZipCode property.
HomePhone | 33 | Represents the HomePhone property.
VoicemailLocation | 34 | Represents the VoicemailLocation property.
Workgroups | 35 | Represents the Workgroups property.
OwnerId | 36 | Represents the OwnerId property.
Alias | 37 | Represents the Alias property.
AccessRights | 38 | Represents the AccessRights property.
TrackerData | 39 | Represents the TrackerData property.
StatusUri | 40 | Represents the StatusUri property.
Index | 41 | Represents the Index property.
ExternalPresenceProviders | 42 | ExternalPresenceProviders for more information.
LyncSipAddress | 43 | Obsolete. Represents the LyncSipAddress property.
ContactSources | 44 | Represents the ContactSources property.
ExternalContactEntries | 45 | Represents the ExternalContactEntries property.
Skills | 46 | Represents the Skills property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


ContactSortItem Class

[image]

IceLib Technical Reference
ContactSortItem Class
Members See Also Send Feedback
Represents an item to sort on a particular contact entry property.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ContactSortItem
Visual Basic
Public Class ContactSortItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactSortItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactSortItem Members
ININ.IceLib.Directories Namespace


ContactSortItem Members

[image] [image]

IceLib Technical Reference
ContactSortItem Members
ContactSortItem Class Constructors Methods Properties See Also Send Feedback

The ContactSortItem type exposes the following members.

Constructors

 | Name | Description
Public method | ContactSortItem | Initializes a new instance of the ContactSortItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Property | Gets the property.
Public property | SortDirection | Gets the sort direction (ascending or descending).

See Also

ContactSortItem Class
ININ.IceLib.Directories Namespace


ContactSortItem Constructor

[image]

IceLib Technical Reference
ContactSortItem Constructor
ContactSortItem Class See Also Send Feedback
Initializes a new instance of the ContactSortItem class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactSortItem(
    ContactProperty property,
    ListSortDirection sortDirection
)
Visual Basic
Public Sub New ( _
    property As ContactProperty, _
    sortDirection As ListSortDirection _
)

Parameters

property
Type: ININ.IceLib.Directories..::..ContactProperty
The contact entry property.
sortDirection
Type: System.ComponentModel..::..ListSortDirection
The sort direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactSortItem Class
ContactSortItem Members
ININ.IceLib.Directories Namespace


ContactSortItem Methods

[image] [image]

IceLib Technical Reference
ContactSortItem Methods
ContactSortItem Class See Also Send Feedback

The ContactSortItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactSortItem Class
ININ.IceLib.Directories Namespace


ContactSortItem Properties

[image] [image]

IceLib Technical Reference
ContactSortItem Properties
ContactSortItem Class See Also Send Feedback

The ContactSortItem type exposes the following members.

Properties

 | Name | Description
Public property | Property | Gets the property.
Public property | SortDirection | Gets the sort direction (ascending or descending).

See Also

ContactSortItem Class
ININ.IceLib.Directories Namespace


Property Property

[image]

IceLib Technical Reference
ContactSortItem..::..Property Property
ContactSortItem Class See Also Send Feedback
Gets the property.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactProperty Property { get; }
Visual Basic
Public ReadOnly Property Property As ContactProperty
    Get

Field Value

The property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactSortItem Class
ContactSortItem Members
ININ.IceLib.Directories Namespace


SortDirection Property

[image]

IceLib Technical Reference
ContactSortItem..::..SortDirection Property
ContactSortItem Class See Also Send Feedback
Gets the sort direction (ascending or descending).

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ListSortDirection SortDirection { get; }
Visual Basic
Public ReadOnly Property SortDirection As ListSortDirection
    Get

Field Value

The sort direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ContactSortItem Class
ContactSortItem Members
ININ.IceLib.Directories Namespace


ContactSource Enumeration

[image]

IceLib Technical Reference
ContactSource Enumeration
See Also Send Feedback
Used to identify the source(s) for a contact entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum ContactSource
Visual Basic
<FlagsAttribute> _
Public Enumeration ContactSource

Members

Member name | Value | Description
Unknown | 0 | Identifies a contact that was pulled from an unknown source.
IC | 1 | Identifies contacts that are pulled from the IC Server.
Lync | 2 | Identifies contacts that are pulled from Lync. This is considered an external source and identifies that additional contact information maybe be available from ExternalContactEntries for the related ContactEntry.
SameTime | 4 | Identifies contacts that are pulled from SameTime. This is considered an external source and identifies that additional contact information maybe be available from ExternalContactEntries for the related ContactEntry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Directories Namespace


CreateDirectoryCompletedEventArgs Class

[image]

IceLib Technical Reference
CreateDirectoryCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the CreateTrackerDirectoryAsync(String, TrackerFilterSettings, EventHandler<(Of <<'(CreateDirectoryCompletedEventArgs>)>>), Object) and CreateSpeedDialDirectory(String, DirectoryMetadataAccessRights) completedCallback delegate of DirectoryConfiguration.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CreateDirectoryCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class CreateDirectoryCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Directories..::..CreateDirectoryCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CreateDirectoryCompletedEventArgs Members
ININ.IceLib.Directories Namespace


CreateDirectoryCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
CreateDirectoryCompletedEventArgs Members
CreateDirectoryCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The CreateDirectoryCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CreateDirectoryCompletedEventArgs | Initializes a new instance of the CreateDirectoryCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | DirectoryId | Gets the directory ID associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateDirectoryCompletedEventArgs Class
ININ.IceLib.Directories Namespace


CreateDirectoryCompletedEventArgs Constructor

[image]

IceLib Technical Reference
CreateDirectoryCompletedEventArgs Constructor
CreateDirectoryCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the CreateDirectoryCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CreateDirectoryCompletedEventArgs(
    string directoryId,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    directoryId As String, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

directoryId
Type: System..::..String
The Directory ID.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The directoryId length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CreateDirectoryCompletedEventArgs Class
CreateDirectoryCompletedEventArgs Members
ININ.IceLib.Directories Namespace


CreateDirectoryCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
CreateDirectoryCompletedEventArgs Methods
CreateDirectoryCompletedEventArgs Class See Also Send Feedback

The CreateDirectoryCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateDirectoryCompletedEventArgs Class
ININ.IceLib.Directories Namespace


CreateDirectoryCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
CreateDirectoryCompletedEventArgs Properties
CreateDirectoryCompletedEventArgs Class See Also Send Feedback

The CreateDirectoryCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | DirectoryId | Gets the directory ID associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateDirectoryCompletedEventArgs Class
ININ.IceLib.Directories Namespace


DirectoryId Property

[image]

IceLib Technical Reference
CreateDirectoryCompletedEventArgs..::..DirectoryId Property
CreateDirectoryCompletedEventArgs Class See Also Send Feedback
Gets the directory ID associated with the event.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DirectoryId { get; }
Visual Basic
Public ReadOnly Property DirectoryId As String
    Get

Field Value

The directory ID.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CreateDirectoryCompletedEventArgs Class
CreateDirectoryCompletedEventArgs Members
ININ.IceLib.Directories Namespace


DirectoriesManager Class

[image]

IceLib Technical Reference
DirectoriesManager Class
Members Example See Also Send Feedback
Provides access to all the various IC directories.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DirectoriesManager
Visual Basic
Public Class DirectoriesManager

Remarks

This class serves as the initial entry point into the Directories namespace. There is only one instance of this object per session. This object is required to manage the resources of other objects within this namespace. All classes in the Directories namespace send and receive messages to and from the IC system via the Session object of the DirectoriesManager.

Note that the DirectoriesManager class is a singleton object and is accessed using the GetInstance(Session) method.

Examples

CopyC#
Session session = new Session();
session.Connect(...);
DirectoriesManager directoryManager = DirectoriesManager.GetInstance(session);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..DirectoriesManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoriesManager Members
ININ.IceLib.Directories Namespace


DirectoriesManager Members

[image] [image]

IceLib Technical Reference
DirectoriesManager Members
DirectoriesManager Class Methods Properties See Also Send Feedback

The DirectoriesManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a DirectoriesManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectoriesId | Gets the unique ID for this object instance.
Public property | Session | Gets the Session with which this DirectoriesManager is associated.

See Also

DirectoriesManager Class
ININ.IceLib.Directories Namespace


DirectoriesManager Methods

[image] [image]

IceLib Technical Reference
DirectoriesManager Methods
DirectoriesManager Class See Also Send Feedback

The DirectoriesManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a DirectoriesManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectoriesManager Class
ININ.IceLib.Directories Namespace


GetInstance Method

[image]

IceLib Technical Reference
DirectoriesManager..::..GetInstance Method
DirectoriesManager Class See Also Send Feedback
Gets a DirectoriesManager.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static DirectoriesManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As DirectoriesManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The DirectoriesManager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoriesManager Class
DirectoriesManager Members
ININ.IceLib.Directories Namespace


DirectoriesManager Properties

[image] [image]

IceLib Technical Reference
DirectoriesManager Properties
DirectoriesManager Class See Also Send Feedback

The DirectoriesManager type exposes the following members.

Properties

 | Name | Description
Public property | DirectoriesId | Gets the unique ID for this object instance.
Public property | Session | Gets the Session with which this DirectoriesManager is associated.

See Also

DirectoriesManager Class
ININ.IceLib.Directories Namespace


DirectoriesId Property

[image]

IceLib Technical Reference
DirectoriesManager..::..DirectoriesId Property
DirectoriesManager Class See Also Send Feedback
Gets the unique ID for this object instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long DirectoriesId { get; }
Visual Basic
Public ReadOnly Property DirectoriesId As Long
    Get

Field Value

The directories ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoriesManager Class
DirectoriesManager Members
ININ.IceLib.Directories Namespace


Session Property

[image]

IceLib Technical Reference
DirectoriesManager..::..Session Property
DirectoriesManager Class See Also Send Feedback
Gets the Session with which this DirectoriesManager is associated.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoriesManager Class
DirectoriesManager Members
ININ.IceLib.Directories Namespace


DirectoryConfiguration Class

[image]

IceLib Technical Reference
DirectoryConfiguration Class
Members See Also Send Feedback
Represents IC directory configuration. An instance of this object is used to obtain a list of available directories and perform operations on them.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DirectoryConfiguration
Visual Basic
Public Class DirectoryConfiguration

Remarks

This object manages a watched list of DirectoryMetadata objects. The DirectoryMetadata is required by a ContactDirectory instance in order to get a list of contact entries (ContactEntry). In addition, an instance of this object provides support for updating directory configuration for tasks like creating, modifying and deleting directory entries.

Getting a list of watched objects

A watched object is maintained internally within a cache. The cache is constructed so that only one instance of a DirectoryMetadata object is shared between other instances of a DirectoryConfiguration object.

This object contains synchronous as well as asynchronous counterpart methods for any method that could potentially block a thread by running a lengthy operation. Synchronous methods block the thread that they are performed on. Asynchronous methods will not block. When an asynchronous method completes, an event is raised on a thread appropriate to the application-model, such as the GUI thread in a UI application. By convention, synchronous calls are invoked by a method, such as DoSomething(). Their asynchronous counterparts are invoked via DoSomethingAsync() with the result returned in a DoSomethingCompleted event.

A start watch, via a call to StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object) is required to obtain the available directories. Once the start watch has successfully completed, call GetList()()()() to obtain the available directories.

Change notifications to metadata can be subscribed to via the DirectoryConfigurationChanged event handler. Change events are not raised on a thread appropriate to the application mode, such as the GUI thread in a UI application.

A watch can be stopped via a call to StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object).

Directory updates

Speed dial directories can be created, renamed and deleted with the following synchronous and asynchronous methods.

  • CreateSpeedDialDirectory(String, DirectoryMetadataAccessRights) or CreateSpeedDialDirectoryAsync(String, DirectoryMetadataAccessRights, EventHandler<(Of <<'(CreateDirectoryCompletedEventArgs>)>>), Object)
  • RenameDirectory(DirectoryMetadata, String) or RenameDirectoryAsync(DirectoryMetadata, String, AsyncCompletedEventHandler, Object)
  • DeleteDirectory(DirectoryMetadata) or DeleteDirectoryAsync(DirectoryMetadata, AsyncCompletedEventHandler, Object)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..DirectoryConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DirectoryConfiguration Members

[image] [image]

IceLib Technical Reference
DirectoryConfiguration Members
DirectoryConfiguration Class Constructors Methods Properties Events See Also Send Feedback

The DirectoryConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | DirectoryConfiguration | Initializes a new instance of the DirectoryConfiguration class.

Methods

 | Name | Description
Public method | CanDeleteDirectory | Determines whether the user associated with this session is allowed to delete a directory.
Public method | CanRenameDirectory | Determines whether the user associated with this session is allowed to rename a directory.
Public method | CanUpdateDirectory | Determines whether the user associated with this session is allowed to update a directory.
Public method | CreateSpeedDialDirectory | Create a speed dial directory.
Public method | CreateSpeedDialDirectoryAsync | An asynchronous request to create a speed dial directory.
Public method | CreateTrackerDirectory | Create a filtered tracker directory.
Public method | CreateTrackerDirectoryAsync | An asynchronous request to create a tracker directory.
Public method | DeleteDirectory | Deletes a directory entry. Note that currently only speed dial and tracker directories can be deleted.
Public method | DeleteDirectoryAsync | Asynchronously deletes the directory. Note that currently only speed dial directories can be deleted.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntry | Gets the entry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets a list of directory metadata being watched.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ModifyTrackerDirectory | Modify a filtered tracker directory.
Public method | ModifyTrackerDirectoryAsync | An asynchronous request to modify a tracker directory.
Public method | RenameDirectory | Rename the directory. Note that currently only speed dial directories can be renamed.
Public method | RenameDirectoryAsync | Asynchronously rename the speed dial directory. Note that currently only speed dial directories can be renamed.
Public method | StartWatching | A synchronous request to query and watch directory configuration metadata.
Public method | StartWatchingAsync | Starts an asynchronous request to query and watch directory configuration metadata.
Public method | StopWatching | A synchronous request to stop watching directory configuration metadata.
Public method | StopWatchingAsync | Start an asynchronous request to stop watching directory configuration metadata.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Pending | Identifies any pending directory groups, those that have yet to be loaded by the Interaction Center server.

Events

 | Name | Description
Public event | DirectoryConfigurationChanged | Occurs when one of the DirectoryMetadata watched objects has changed.

See Also

DirectoryConfiguration Class
ININ.IceLib.Directories Namespace


DirectoryConfiguration Constructor

[image]

IceLib Technical Reference
DirectoryConfiguration Constructor
DirectoryConfiguration Class See Also Send Feedback
Initializes a new instance of the DirectoryConfiguration class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryConfiguration(
    DirectoriesManager manager
)
Visual Basic
Public Sub New ( _
    manager As DirectoriesManager _
)

Parameters

manager
Type: ININ.IceLib.Directories..::..DirectoriesManager
The manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DirectoryConfiguration Methods

[image] [image]

IceLib Technical Reference
DirectoryConfiguration Methods
DirectoryConfiguration Class See Also Send Feedback

The DirectoryConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CanDeleteDirectory | Determines whether the user associated with this session is allowed to delete a directory.
Public method | CanRenameDirectory | Determines whether the user associated with this session is allowed to rename a directory.
Public method | CanUpdateDirectory | Determines whether the user associated with this session is allowed to update a directory.
Public method | CreateSpeedDialDirectory | Create a speed dial directory.
Public method | CreateSpeedDialDirectoryAsync | An asynchronous request to create a speed dial directory.
Public method | CreateTrackerDirectory | Create a filtered tracker directory.
Public method | CreateTrackerDirectoryAsync | An asynchronous request to create a tracker directory.
Public method | DeleteDirectory | Deletes a directory entry. Note that currently only speed dial and tracker directories can be deleted.
Public method | DeleteDirectoryAsync | Asynchronously deletes the directory. Note that currently only speed dial directories can be deleted.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEntry | Gets the entry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets a list of directory metadata being watched.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ModifyTrackerDirectory | Modify a filtered tracker directory.
Public method | ModifyTrackerDirectoryAsync | An asynchronous request to modify a tracker directory.
Public method | RenameDirectory | Rename the directory. Note that currently only speed dial directories can be renamed.
Public method | RenameDirectoryAsync | Asynchronously rename the speed dial directory. Note that currently only speed dial directories can be renamed.
Public method | StartWatching | A synchronous request to query and watch directory configuration metadata.
Public method | StartWatchingAsync | Starts an asynchronous request to query and watch directory configuration metadata.
Public method | StopWatching | A synchronous request to stop watching directory configuration metadata.
Public method | StopWatchingAsync | Start an asynchronous request to stop watching directory configuration metadata.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectoryConfiguration Class
ININ.IceLib.Directories Namespace


CanDeleteDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CanDeleteDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Determines whether the user associated with this session is allowed to delete a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteDirectory(
    DirectoryMetadata metadata
)
Visual Basic
Public Function CanDeleteDirectory ( _
    metadata As DirectoryMetadata _
) As Boolean

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata for the directory to delete.

Return Value

trueTruetruetrue (True in Visual Basic) if this instance can delete the directory; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


CanRenameDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CanRenameDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Determines whether the user associated with this session is allowed to rename a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanRenameDirectory(
    DirectoryMetadata metadata
)
Visual Basic
Public Function CanRenameDirectory ( _
    metadata As DirectoryMetadata _
) As Boolean

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata for the directory to rename.

Return Value

trueTruetruetrue (True in Visual Basic) if this instance can update the directory; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


CanUpdateDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CanUpdateDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Determines whether the user associated with this session is allowed to update a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUpdateDirectory(
    DirectoryMetadata metadata
)
Visual Basic
Public Function CanUpdateDirectory ( _
    metadata As DirectoryMetadata _
) As Boolean

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata for the directory to update.

Return Value

trueTruetruetrue (True in Visual Basic) if this instance can update the directory; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


CreateSpeedDialDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CreateSpeedDialDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Create a speed dial directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CreateSpeedDialDirectory(
    string speedDialName,
    DirectoryMetadataAccessRights accessMask
)
Visual Basic
Public Function CreateSpeedDialDirectory ( _
    speedDialName As String, _
    accessMask As DirectoryMetadataAccessRights _
) As String

Parameters

speedDialName
Type: System..::..String
Name of the speed dial directory.
accessMask
Type: ININ.IceLib.Directories..::..DirectoryMetadataAccessRights
The access mask.

Return Value

The newly created directory object's ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


CreateSpeedDialDirectoryAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CreateSpeedDialDirectoryAsync Method
DirectoryConfiguration Class See Also Send Feedback
An asynchronous request to create a speed dial directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateSpeedDialDirectoryAsync(
    string speedDialName,
    DirectoryMetadataAccessRights accessMask,
    EventHandler<CreateDirectoryCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateSpeedDialDirectoryAsync ( _
    speedDialName As String, _
    accessMask As DirectoryMetadataAccessRights, _
    completedCallback As EventHandler(Of CreateDirectoryCompletedEventArgs), _
    userState As Object _
)

Parameters

speedDialName
Type: System..::..String
Name of the speed dial.
accessMask
Type: ININ.IceLib.Directories..::..DirectoryMetadataAccessRights
The access mask.
completedCallback
Type: System..::..EventHandler<(Of <(<' CreateDirectoryCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


CreateTrackerDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CreateTrackerDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Create a filtered tracker directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CreateTrackerDirectory(
    string trackerDirectoryName,
    TrackerFilterSettings filterSettings
)
Visual Basic
Public Function CreateTrackerDirectory ( _
    trackerDirectoryName As String, _
    filterSettings As TrackerFilterSettings _
) As String

Parameters

trackerDirectoryName
Type: System..::..String
Name of the tracker directory.
filterSettings
Type: ININ.IceLib.Directories..::..TrackerFilterSettings
The filter settings.

Return Value

The newly created directory object's ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


CreateTrackerDirectoryAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..CreateTrackerDirectoryAsync Method
DirectoryConfiguration Class See Also Send Feedback
An asynchronous request to create a tracker directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateTrackerDirectoryAsync(
    string trackerDirectoryName,
    TrackerFilterSettings filterSettings,
    EventHandler<CreateDirectoryCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateTrackerDirectoryAsync ( _
    trackerDirectoryName As String, _
    filterSettings As TrackerFilterSettings, _
    completedCallback As EventHandler(Of CreateDirectoryCompletedEventArgs), _
    userState As Object _
)

Parameters

trackerDirectoryName
Type: System..::..String
Name of the tracker directory.
filterSettings
Type: ININ.IceLib.Directories..::..TrackerFilterSettings
The filter settings.
completedCallback
Type: System..::..EventHandler<(Of <(<' CreateDirectoryCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DeleteDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..DeleteDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Deletes a directory entry. Note that currently only speed dial and tracker directories can be deleted.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteDirectory(
    DirectoryMetadata metadata
)
Visual Basic
Public Sub DeleteDirectory ( _
    metadata As DirectoryMetadata _
)

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The directory metadata.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..NotSupportedException | The directory does not support the delete operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DeleteDirectoryAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..DeleteDirectoryAsync Method
DirectoryConfiguration Class See Also Send Feedback
Asynchronously deletes the directory. Note that currently only speed dial directories can be deleted.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteDirectoryAsync(
    DirectoryMetadata metadata,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteDirectoryAsync ( _
    metadata As DirectoryMetadata, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..NotSupportedException | The directory does not support the delete operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


GetEntry Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..GetEntry Method
DirectoryConfiguration Class See Also Send Feedback
Gets the entry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryMetadata GetEntry(
    string directoryId
)
Visual Basic
Public Function GetEntry ( _
    directoryId As String _
) As DirectoryMetadata

Parameters

directoryId
Type: System..::..String
The directory ID.

Return Value

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the entry could not be found.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | A StartWatch has not been called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


GetList Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..GetList Method
DirectoryConfiguration Class See Also Send Feedback
Gets a list of directory metadata being watched.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<DirectoryMetadata> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of DirectoryMetadata)

Return Value

A list of directory metadata.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | A StartWatch has not been called.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


IsWatching Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..IsWatching Method
DirectoryConfiguration Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


ModifyTrackerDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..ModifyTrackerDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Modify a filtered tracker directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ModifyTrackerDirectory(
    string trackerDirectoryId,
    string trackerDirectoryName,
    TrackerFilterSettings filterSettings
)
Visual Basic
Public Sub ModifyTrackerDirectory ( _
    trackerDirectoryId As String, _
    trackerDirectoryName As String, _
    filterSettings As TrackerFilterSettings _
)

Parameters

trackerDirectoryId
Type: System..::..String
ID of the tracker directory.
trackerDirectoryName
Type: System..::..String
Name of the tracker directory.
filterSettings
Type: ININ.IceLib.Directories..::..TrackerFilterSettings
The filter settings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


ModifyTrackerDirectoryAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..ModifyTrackerDirectoryAsync Method
DirectoryConfiguration Class See Also Send Feedback
An asynchronous request to modify a tracker directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ModifyTrackerDirectoryAsync(
    string trackerDirectoryId,
    string trackerDirectoryName,
    TrackerFilterSettings filterSettings,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ModifyTrackerDirectoryAsync ( _
    trackerDirectoryId As String, _
    trackerDirectoryName As String, _
    filterSettings As TrackerFilterSettings, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

trackerDirectoryId
Type: System..::..String
ID of the tracker directory.
trackerDirectoryName
Type: System..::..String
Name of the tracker directory.
filterSettings
Type: ININ.IceLib.Directories..::..TrackerFilterSettings
The filter settings.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


RenameDirectory Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..RenameDirectory Method
DirectoryConfiguration Class See Also Send Feedback
Rename the directory. Note that currently only speed dial directories can be renamed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RenameDirectory(
    DirectoryMetadata metadata,
    string newSpeedDialDisplayName
)
Visual Basic
Public Sub RenameDirectory ( _
    metadata As DirectoryMetadata, _
    newSpeedDialDisplayName As String _
)

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The directory metadata.
newSpeedDialDisplayName
Type: System..::..String
New name of the speed dial display.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


RenameDirectoryAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..RenameDirectoryAsync Method
DirectoryConfiguration Class See Also Send Feedback
Asynchronously rename the speed dial directory. Note that currently only speed dial directories can be renamed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RenameDirectoryAsync(
    DirectoryMetadata metadata,
    string newSpeedDialDisplayName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RenameDirectoryAsync ( _
    metadata As DirectoryMetadata, _
    newSpeedDialDisplayName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

metadata
Type: ININ.IceLib.Directories..::..DirectoryMetadata
The metadata.
newSpeedDialDisplayName
Type: System..::..String
New name of the speed dial display.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


StartWatching Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..StartWatching Method
DirectoryConfiguration Class See Also Send Feedback
A synchronous request to query and watch directory configuration metadata.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch has already been started for this instance of DirectoryConfiguration.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..StartWatchingAsync Method
DirectoryConfiguration Class See Also Send Feedback
Starts an asynchronous request to query and watch directory configuration metadata.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch has already been started for this instance of DirectoryConfiguration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


StopWatching Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..StopWatching Method
DirectoryConfiguration Class See Also Send Feedback
A synchronous request to stop watching directory configuration metadata.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started. See StartWatching()()()().

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
DirectoryConfiguration..::..StopWatchingAsync Method
DirectoryConfiguration Class See Also Send Feedback
Start an asynchronous request to stop watching directory configuration metadata.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started. See StartWatching()()()().

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DirectoryConfiguration Properties

[image] [image]

IceLib Technical Reference
DirectoryConfiguration Properties
DirectoryConfiguration Class See Also Send Feedback

The DirectoryConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Pending | Identifies any pending directory groups, those that have yet to be loaded by the Interaction Center server.

See Also

DirectoryConfiguration Class
ININ.IceLib.Directories Namespace


Pending Property

[image]

IceLib Technical Reference
DirectoryConfiguration..::..Pending Property
DirectoryConfiguration Class See Also Send Feedback
Identifies any pending directory groups, those that have yet to be loaded by the Interaction Center server.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PendingDirectoryEntries Pending { get; }
Visual Basic
Public ReadOnly Property Pending As PendingDirectoryEntries
    Get

Remarks

DirectoryConfigurationChanged should be hooked to receive events concerning any pending directory groups.

When a directory group is identified as pending, IceLib cannot provide any specific information on which specific directory metadata may or may not be present. It is possible that once the Interaction Center server loads the pending directory group, it finds that there are no matching directories, so IceLib may report that the directory group is complete (no longer pending) but also not report the addition of any new directories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DirectoryConfiguration Events

[image] [image]

IceLib Technical Reference
DirectoryConfiguration Events
DirectoryConfiguration Class See Also Send Feedback

The DirectoryConfiguration type exposes the following members.

Events

 | Name | Description
Public event | DirectoryConfigurationChanged | Occurs when one of the DirectoryMetadata watched objects has changed.

See Also

DirectoryConfiguration Class
ININ.IceLib.Directories Namespace


DirectoryConfigurationChanged Event

[image]

IceLib Technical Reference
DirectoryConfiguration..::..DirectoryConfigurationChanged Event
DirectoryConfiguration Class See Also Send Feedback
Occurs when one of the DirectoryMetadata watched objects has changed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<DirectoryEventArgs<DirectoryMetadata>> DirectoryConfigurationChanged
Visual Basic
Public Event DirectoryConfigurationChanged As EventHandler(Of DirectoryEventArgs(Of DirectoryMetadata))

Remarks

Note
Change events are not raised on a thread appropriate to the application mode, such as the GUI thread in a UI application.
This event will only occur if the directory configuration is being watched. To start watching the directory configuration call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.

If any PendingDirectoryGroups are identified, a directory change event will be raised for each of the pending directory groups the Interaction Center server resolves. A PendingDirectoryGroup is considered pending when the Interaction Center server does not yet have information concerning the directory grouping identified. The status of any directories pending load is available via the Pending property.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryConfiguration Class
DirectoryConfiguration Members
ININ.IceLib.Directories Namespace


DirectoryEventArgs(TWatchedObject) Class

[image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
Members See Also Send Feedback
Provides data for watched object change events.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DirectoryEventArgs<TWatchedObject> : EventArgs
where TWatchedObject : class
Visual Basic
Public Class DirectoryEventArgs(Of TWatchedObject As Class) _
    Inherits EventArgs

Type Parameters

TWatchedObject
The watched object.

Remarks

TWatchedObjects refers to the watched objects. These can either be DirectoryMetadata or ContactEntry object.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Directories..::..DirectoryEventArgs<(Of <(<'TWatchedObject>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
ININ.IceLib.Directories Namespace


DirectoryEventArgs(TWatchedObject) Members

[image] [image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class Methods Properties See Also Send Feedback

The DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChangedProperties | Gets the changed properties.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed.
Public property | Pending | Gets the pending status for this update.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
ININ.IceLib.Directories Namespace


DirectoryEventArgs(TWatchedObject) Methods

[image] [image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Methods
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback

The DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChangedProperties | Gets the changed properties.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
ININ.IceLib.Directories Namespace


GetChangedProperties Method

[image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)>..::..GetChangedProperties Method
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback
Gets the changed properties.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Enum> GetChangedProperties(
    TWatchedObject watchedObject
)
Visual Basic
Public Function GetChangedProperties ( _
    watchedObject As TWatchedObject _
) As ReadOnlyCollection(Of Enum)

Parameters

watchedObject
Type: TWatchedObject
The watched object.

Return Value

Returns a list of properties that have changed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
ININ.IceLib.Directories Namespace


DirectoryEventArgs(TWatchedObject) Properties

[image] [image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Properties
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback

The DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed.
Public property | Pending | Gets the pending status for this update.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
ININ.IceLib.Directories Namespace


Added Property

[image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)>..::..Added Property
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback
Get the existing object identifiers that were added.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObject> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of TWatchedObject)
    Get

Field Value

The added objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
ININ.IceLib.Directories Namespace


Changed Property

[image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)>..::..Changed Property
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback
Get the existing objects that changed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObject> Changed { get; }
Visual Basic
Public ReadOnly Property Changed As ReadOnlyCollection(Of TWatchedObject)
    Get

Field Value

The collection of changed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
ININ.IceLib.Directories Namespace


Pending Property

[image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)>..::..Pending Property
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback
Gets the pending status for this update.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PendingEntries Pending { get; }
Visual Basic
Public ReadOnly Property Pending As PendingEntries
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
ININ.IceLib.Directories Namespace


Removed Property

[image]

IceLib Technical Reference
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)>..::..Removed Property
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class See Also Send Feedback
Get the existing object identifiers that were removed.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObject> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of TWatchedObject)
    Get

Field Value

The removed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Class
DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> Members
ININ.IceLib.Directories Namespace


DirectoryMetadata Class

[image]

IceLib Technical Reference
DirectoryMetadata Class
Members See Also Send Feedback
Represents a directory metadata watched object. This object maintains information of a particular directory that exists on the IC server. The directory metadata is used to identify a directory of contact entries.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DirectoryMetadata
Visual Basic
Public Class DirectoryMetadata

Remarks

An instance of DirectoryMetadata represents an IC directory and is required to obtain a list of contact entries within that directory. Instances of DirectoryMetadata are obtained by the DirectoryConfiguration watched object.

A DirectoryMetadata instance is required to construct a ContactDirectory watched object instance in order to obtain the associated ContactEntry object instances.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..DirectoryMetadata

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DirectoryMetadata Members

[image] [image]

IceLib Technical Reference
DirectoryMetadata Members
DirectoryMetadata Class Methods Fields Properties See Also Send Feedback

The DirectoryMetadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOwner | Determines whether the specified possible owner is owner.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UnknownApproximateCount | Defines a constant for when the ApproximateCount value is unknown.

Properties

 | Name | Description
Public property | AccessRights | Gets the access rights.
Public property | ApproximateCount | Gets the approximate count of the directory, if known.
Public property | CanRefresh | Gets a value indicating whether the directory for this instance can refresh.
Public property | Category | Gets the category.
Public property | DirectoryAdmin | Gets a value indicating where or not DirectoryAdmin rights have been acquired for this directory.
Public property | DisplayName | Gets the directory name to display.
Public property | DisplayType | Gets the type of the display.
Public property | HasDynamicFields | Gets a value indicating whether this instance has dynamic fields.
Public property | HasStatus | Gets a value indicating whether the directory has status information.
Public property | Id | Gets the unique identifier.
Public property | IsPrivate | Gets a value indicating whether the directory for this instance is private.
Public property | OwnerId | Gets the owner ID.

See Also

DirectoryMetadata Class
ININ.IceLib.Directories Namespace


DirectoryMetadata Fields

[image] [image]

IceLib Technical Reference
DirectoryMetadata Fields
DirectoryMetadata Class See Also Send Feedback

The DirectoryMetadata type exposes the following members.

Fields

Name | Description
UnknownApproximateCount | Defines a constant for when the ApproximateCount value is unknown.

See Also

DirectoryMetadata Class
ININ.IceLib.Directories Namespace


UnknownApproximateCount Field

[image]

IceLib Technical Reference
DirectoryMetadata..::..UnknownApproximateCount Field
DirectoryMetadata Class See Also Send Feedback
Defines a constant for when the ApproximateCount value is unknown.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int UnknownApproximateCount
Visual Basic
Public Const UnknownApproximateCount As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DirectoryMetadata Methods

[image] [image]

IceLib Technical Reference
DirectoryMetadata Methods
DirectoryMetadata Class See Also Send Feedback

The DirectoryMetadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOwner | Determines whether the specified possible owner is owner.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectoryMetadata Class
ININ.IceLib.Directories Namespace


IsOwner Method

[image]

IceLib Technical Reference
DirectoryMetadata..::..IsOwner Method
DirectoryMetadata Class See Also Send Feedback
Determines whether the specified possible owner is owner.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsOwner(
    string possibleOwner
)
Visual Basic
Public Function IsOwner ( _
    possibleOwner As String _
) As Boolean

Parameters

possibleOwner
Type: System..::..String
The possible owner.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified possible owner is owner; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DirectoryMetadata Properties

[image] [image]

IceLib Technical Reference
DirectoryMetadata Properties
DirectoryMetadata Class See Also Send Feedback

The DirectoryMetadata type exposes the following members.

Properties

 | Name | Description
Public property | AccessRights | Gets the access rights.
Public property | ApproximateCount | Gets the approximate count of the directory, if known.
Public property | CanRefresh | Gets a value indicating whether the directory for this instance can refresh.
Public property | Category | Gets the category.
Public property | DirectoryAdmin | Gets a value indicating where or not DirectoryAdmin rights have been acquired for this directory.
Public property | DisplayName | Gets the directory name to display.
Public property | DisplayType | Gets the type of the display.
Public property | HasDynamicFields | Gets a value indicating whether this instance has dynamic fields.
Public property | HasStatus | Gets a value indicating whether the directory has status information.
Public property | Id | Gets the unique identifier.
Public property | IsPrivate | Gets a value indicating whether the directory for this instance is private.
Public property | OwnerId | Gets the owner ID.

See Also

DirectoryMetadata Class
ININ.IceLib.Directories Namespace


AccessRights Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..AccessRights Property
DirectoryMetadata Class See Also Send Feedback
Gets the access rights.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryMetadataAccessRights AccessRights { get; }
Visual Basic
Public ReadOnly Property AccessRights As DirectoryMetadataAccessRights
    Get

Field Value

The access rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


ApproximateCount Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..ApproximateCount Property
DirectoryMetadata Class See Also Send Feedback
Gets the approximate count of the directory, if known.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ApproximateCount { get; }
Visual Basic
Public ReadOnly Property ApproximateCount As Integer
    Get

Field Value

The approximate count.

Remarks

The value UnknownApproximateCount will be returned if the count is not known.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


CanRefresh Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..CanRefresh Property
DirectoryMetadata Class See Also Send Feedback
Gets a value indicating whether the directory for this instance can refresh.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanRefresh { get; }
Visual Basic
Public ReadOnly Property CanRefresh As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the directory can refresh; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


Category Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..Category Property
DirectoryMetadata Class See Also Send Feedback
Gets the category.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryMetadataCategory Category { get; }
Visual Basic
Public ReadOnly Property Category As DirectoryMetadataCategory
    Get

Field Value

The category.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DirectoryAdmin Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..DirectoryAdmin Property
DirectoryMetadata Class See Also Send Feedback
Gets a value indicating where or not DirectoryAdmin rights have been acquired for this directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DirectoryAdmin { get; }
Visual Basic
Public ReadOnly Property DirectoryAdmin As Boolean
    Get

Field Value

true if this instance has acquired DirectoryAdmin rights; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DisplayName Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..DisplayName Property
DirectoryMetadata Class See Also Send Feedback
Gets the directory name to display.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The name of the directory for display.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DisplayType Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..DisplayType Property
DirectoryMetadata Class See Also Send Feedback
Gets the type of the display.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryMetadataDisplayType DisplayType { get; }
Visual Basic
Public ReadOnly Property DisplayType As DirectoryMetadataDisplayType
    Get

Field Value

The type of the display.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


HasDynamicFields Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..HasDynamicFields Property
DirectoryMetadata Class See Also Send Feedback
Gets a value indicating whether this instance has dynamic fields.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasDynamicFields { get; }
Visual Basic
Public ReadOnly Property HasDynamicFields As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has dynamic fields; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


HasStatus Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..HasStatus Property
DirectoryMetadata Class See Also Send Feedback
Gets a value indicating whether the directory has status information.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasStatus { get; }
Visual Basic
Public ReadOnly Property HasStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this directory has status information; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This is an indicator whether an application can query / watch statuses of the contacts in this directory. For more information on how to query / watch statuses please refer to UserStatusList from ININ.IceLib.People namespace.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


Id Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..Id Property
DirectoryMetadata Class See Also Send Feedback
Gets the unique identifier.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


IsPrivate Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..IsPrivate Property
DirectoryMetadata Class See Also Send Feedback
Gets a value indicating whether the directory for this instance is private.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPrivate { get; }
Visual Basic
Public ReadOnly Property IsPrivate As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this directory is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


OwnerId Property

[image]

IceLib Technical Reference
DirectoryMetadata..::..OwnerId Property
DirectoryMetadata Class See Also Send Feedback
Gets the owner ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As String
    Get

Field Value

The owner ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryMetadata Class
DirectoryMetadata Members
ININ.IceLib.Directories Namespace


DirectoryMetadataAccessRights Enumeration

[image]

IceLib Technical Reference
DirectoryMetadataAccessRights Enumeration
See Also Send Feedback
Specifies constants for the access rights of a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum DirectoryMetadataAccessRights
Visual Basic
<FlagsAttribute> _
Public Enumeration DirectoryMetadataAccessRights

Members

Member name | Value | Description
None | 0 | No access rights are specified.
Read | 1 | Permission to read a directory.
Create | 2 | Permission to create a new directory.
Update | 4 | Permission to update a directory.
Delete | 8 | Permission to delete a directory.
Rename | 16 | Permission to rename a directory.
PrimaryNumber | 64 | Permission to access a primary number designation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


DirectoryMetadataCategory Enumeration

[image]

IceLib Technical Reference
DirectoryMetadataCategory Enumeration
See Also Send Feedback
Specifies constants for the category of a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum DirectoryMetadataCategory
Visual Basic
Public Enumeration DirectoryMetadataCategory

Members

Member name | Value | Description
None | 0 | No category is defined.
Company | 1 | Represents a company directory.
Workgroup | 2 | Represents an IC workgroup as a directory.
General | 3 | Represents an external directory. For example IC Private Contacts.
StationGroup | 4 | Represents an IC station group as a directory.
SpeedDial | 5 | Represents a directory for speed dial entries.
GroupAndProfile | 6 | Represents a directory for Attendant workgroups and profiles.
Tracker | 7 | Represents a tracker directory.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


DirectoryMetadataDisplayType Enumeration

[image]

IceLib Technical Reference
DirectoryMetadataDisplayType Enumeration
See Also Send Feedback
Specifies constants for the display type of a directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum DirectoryMetadataDisplayType
Visual Basic
Public Enumeration DirectoryMetadataDisplayType

Members

Member name | Value | Description
None | 0 | No display type is defined.
List | 1 | Represents a list.
Filter | 2 | Represents a filter.
Speed | 3 | Represents a speed dial.
Tracker | 4 | Represents tracker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


DirectoryMetadataProperty Enumeration

[image]

IceLib Technical Reference
DirectoryMetadataProperty Enumeration
See Also Send Feedback
Specifies constants for the DirectoryMetadata properties.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum DirectoryMetadataProperty
Visual Basic
Public Enumeration DirectoryMetadataProperty

Members

Member name | Value | Description
None | 0 | No property is defined.
Id | 1 | Represents the Id property.
DisplayName | 2 | Represents the DisplayName property.
DisplayType | 3 | Represents the DisplayType property.
ApproximateSize | 4 | Represents the ApproximateCount property.
HasDynamicFields | 5 | Represents the HasDynamicFields property.
CanRefresh | 6 | Represents the CanRefresh property.
IsPrivate | 7 | Represents the IsPrivate property.
Category | 8 | Represents the Category property.
OwnerId | 9 | Represents the OwnerId property.
AccessRights | 10 | Represents the AccessRights property.
DirectoryAdmin | 13 | Represents the DirectoryAdmin property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Directories Namespace


DirectoryPhoneNumber Class

[image]

IceLib Technical Reference
DirectoryPhoneNumber Class
Members See Also Send Feedback
Represents a phone number stored in the contact directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DirectoryPhoneNumber
Visual Basic
Public Class DirectoryPhoneNumber

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..DirectoryPhoneNumber
ININ.IceLib.Directories..::..EditableDirectoryPhoneNumber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


DirectoryPhoneNumber Members

[image] [image]

IceLib Technical Reference
DirectoryPhoneNumber Members
DirectoryPhoneNumber Class Methods Properties See Also Send Feedback

The DirectoryPhoneNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current DirectoryPhoneNumber. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AutodialExtension | Gets a value indicating whether to automatically dial the extension.
Public property | ContactProperty | Gets the ContactProperty that this phone number represents.
Public property | DialString | Gets the dial string.
Public property | DisplayString | Gets a displayable string combining the PhoneNumber and Extension.
Public property | Extension | Gets the extension.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | PhoneNumber | Gets the phone number.

See Also

DirectoryPhoneNumber Class
ININ.IceLib.Directories Namespace


DirectoryPhoneNumber Methods

[image] [image]

IceLib Technical Reference
DirectoryPhoneNumber Methods
DirectoryPhoneNumber Class See Also Send Feedback

The DirectoryPhoneNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current DirectoryPhoneNumber. (Overrides Object..::..ToString()()()().)

See Also

DirectoryPhoneNumber Class
ININ.IceLib.Directories Namespace


ToString Method

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..ToString Method
DirectoryPhoneNumber Class See Also Send Feedback
Returns a String that represents the current DirectoryPhoneNumber.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current DisplayString.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


DirectoryPhoneNumber Properties

[image] [image]

IceLib Technical Reference
DirectoryPhoneNumber Properties
DirectoryPhoneNumber Class See Also Send Feedback

The DirectoryPhoneNumber type exposes the following members.

Properties

 | Name | Description
Public property | AutodialExtension | Gets a value indicating whether to automatically dial the extension.
Public property | ContactProperty | Gets the ContactProperty that this phone number represents.
Public property | DialString | Gets the dial string.
Public property | DisplayString | Gets a displayable string combining the PhoneNumber and Extension.
Public property | Extension | Gets the extension.
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | PhoneNumber | Gets the phone number.

See Also

DirectoryPhoneNumber Class
ININ.IceLib.Directories Namespace


AutodialExtension Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..AutodialExtension Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets a value indicating whether to automatically dial the extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AutodialExtension { get; }
Visual Basic
Public ReadOnly Property AutodialExtension As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) to automatically dial the extension; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


ContactProperty Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..ContactProperty Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets the ContactProperty that this phone number represents.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactProperty ContactProperty { get; }
Visual Basic
Public ReadOnly Property ContactProperty As ContactProperty
    Get

Field Value

The contact property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


DialString Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..DialString Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets the dial string.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DialString { get; }
Visual Basic
Public ReadOnly Property DialString As String
    Get

Field Value

The dial string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


DisplayString Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..DisplayString Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets a displayable string combining the PhoneNumber and Extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; }
Visual Basic
Public ReadOnly Property DisplayString As String
    Get

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


Extension Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..Extension Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets the extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


IsEmpty Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..IsEmpty Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets a value indicating whether this instance is empty.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is empty; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


PhoneNumber Property

[image]

IceLib Technical Reference
DirectoryPhoneNumber..::..PhoneNumber Property
DirectoryPhoneNumber Class See Also Send Feedback
Gets the phone number.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PhoneNumber { get; }
Visual Basic
Public ReadOnly Property PhoneNumber As String
    Get

Field Value

The phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DirectoryPhoneNumber Class
DirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


EditableContactEntry Class

[image]

IceLib Technical Reference
EditableContactEntry Class
Members See Also Send Feedback
Represents an editable contact entry object. This object is used to make updates to directory contacts.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EditableContactEntry : ContactEntry
Visual Basic
Public Class EditableContactEntry _
    Inherits ContactEntry

Remarks

An object instance can be initialized from a read-only ContactEntry.

This object is required by the ContactDirectory update methods.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactEntry
ININ.IceLib.Directories..::..EditableContactEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Members
ININ.IceLib.Directories Namespace


EditableContactEntry Members

[image] [image]

IceLib Technical Reference
EditableContactEntry Members
EditableContactEntry Class Constructors Methods Properties See Also Send Feedback

The EditableContactEntry type exposes the following members.

Constructors

 | Name | Description
Public method | EditableContactEntry()()()() | Initializes a new instance of the EditableContactEntry class.
Public method | EditableContactEntry(ContactEntry) | Initializes a new instance of the EditableContactEntry class.

Methods

 | Name | Description
Public method | AddAccessRights | Adds the access rights.
Public method | CompareTo | Compares the current object with another object of the same type. (Inherited from ContactEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultPhoneNumber | This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance. (Inherited from ContactEntry.)
Public method | GetDisplayableIdentifier | This is a convenience method that will retrieve an displayable identifier for this ContactEntry. (Inherited from ContactEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ContactEntry.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAccess | Determines whether the specified access rights have been granted. (Inherited from ContactEntry.)
Public method | IsOwner | Determines whether the specified possible owner is the actual owner of this contact entry. (Inherited from ContactEntry.)
Public method | IsPropertySet | Determines whether the specified ContactProperty contains data for this ContactEntry. (Inherited from ContactEntry.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SubtractAccessRights | Subtracts the access rights.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ContactEntry.)

Properties

 | Name | Description
Public property | AccessRights | Gets or sets the access rights.
Public property | Alias | Gets the alias.
Public property | Assistant | Gets or sets the assistant name.
Public property | AssistantPhone | Gets the assistant phone, which can be used to edit the value.
Public property | BusinessAddress | Gets or sets the business address.
Public property | BusinessCity | Gets or sets the business city.
Public property | BusinessCountry | Gets or sets the business country.
Public property | BusinessEmail | Gets or sets the business Email.
Public property | BusinessPhone | Gets the business phone, which can be used to edit the value.
Public property | BusinessPhone2 | Gets the business phone2, which can be used to edit the value.
Public property | BusinessState | Gets or sets the state of the business.
Public property | BusinessZipCode | Gets or sets the business zip code.
Public property | Company | Gets or sets the company.
Public property | ContactSources | Gets the contact's source(s). See ContactSource for further details. (Inherited from ContactEntry.)
Public property | Department | Gets or sets the department.
Public property | DisplayName | Gets or sets the name of the display.
Public property | EntryId | Gets or sets the entry ID.
Public property | Extension | Gets the extension.
Public property | ExtensionAsPhoneNumber | Gets the extension in Phone Number format. DirectoryPhoneNumber.
Public property | ExternalContactEntries | Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC. (Inherited from ContactEntry.)
Public property | ExternalPresenceProviders | Gets the available external presence providers for this contact. (Inherited from ContactEntry.)
Public property | Fax | Gets the contact's business Fax number, which can be used to edit the value.
Public property | FirstName | Gets or sets first name.
Public property | HomeAddress | Gets or sets the home address.
Public property | HomeCity | Gets or sets the home city.
Public property | HomeCountry | Gets or sets the home country.
Public property | HomeEmail | Gets or sets the home Email.
Public property | HomePhone | Gets the home phone, which can be used to edit the value.
Public property | HomePhone2 | Gets the home phone2, which can be used to edit the value.
Public property | HomeState | Gets or sets the home state.
Public property | HomeZipCode | Gets or sets the home zip code.
Public property | Index | Gets the location of this contact on a paged directory. (Inherited from ContactEntry.)
Public property | LastName | Gets or sets last name.
Public property | LyncSipAddress | Obsolete. Gets the Lync SIP Address for this contact. (Inherited from ContactEntry.)
Public property | MobilePhone | Gets the mobile phone, which can be used to edit the value.
Public property | Notes | Gets or sets the notes.
Public property | OwnerId | Gets the owner.
Public property | Pager | Gets the pager, which can be used to edit the value.
Public property | PrimaryNumberDesignation | Gets or sets the primary number designation. (Not for use with SpeedDial directories.)
Public property | Skills | Gets the Skills set for this contact. (Inherited from ContactEntry.)
Public property | StatusUri | Gets or sets the status uri.
Public property | Title | Gets or sets the title.
Public property | TrackerData | Gets the tracker data. (Inherited from ContactEntry.)
Public property | UserId | Gets the user ID.
Public property | VoicemailLocation | Gets the Voicemail location.
Public property | Webpage | Gets or sets the web page.
Public property | Workgroups | Gets the workgroups.

See Also

EditableContactEntry Class
ININ.IceLib.Directories Namespace


EditableContactEntry Constructor

[image] [image]

IceLib Technical Reference
EditableContactEntry Constructor
EditableContactEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditableContactEntry()()()() | Initializes a new instance of the EditableContactEntry class.
Public method | EditableContactEntry(ContactEntry) | Initializes a new instance of the EditableContactEntry class.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


EditableContactEntry Constructor

[image]

IceLib Technical Reference
EditableContactEntry Constructor
EditableContactEntry Class See Also Send Feedback
Initializes a new instance of the EditableContactEntry class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableContactEntry()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
EditableContactEntry Overload
ININ.IceLib.Directories Namespace


EditableContactEntry Constructor (ContactEntry)

[image]

IceLib Technical Reference
EditableContactEntry Constructor (ContactEntry)
EditableContactEntry Class See Also Send Feedback
Initializes a new instance of the EditableContactEntry class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableContactEntry(
    ContactEntry entry
)
Visual Basic
Public Sub New ( _
    entry As ContactEntry _
)

Parameters

entry
Type: ININ.IceLib.Directories..::..ContactEntry
The entry.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
EditableContactEntry Overload
ININ.IceLib.Directories Namespace


EditableContactEntry Methods

[image] [image]

IceLib Technical Reference
EditableContactEntry Methods
EditableContactEntry Class See Also Send Feedback

The EditableContactEntry type exposes the following members.

Methods

 | Name | Description
Public method | AddAccessRights | Adds the access rights.
Public method | CompareTo | Compares the current object with another object of the same type. (Inherited from ContactEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultPhoneNumber | This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance. (Inherited from ContactEntry.)
Public method | GetDisplayableIdentifier | This is a convenience method that will retrieve an displayable identifier for this ContactEntry. (Inherited from ContactEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ContactEntry.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAccess | Determines whether the specified access rights have been granted. (Inherited from ContactEntry.)
Public method | IsOwner | Determines whether the specified possible owner is the actual owner of this contact entry. (Inherited from ContactEntry.)
Public method | IsPropertySet | Determines whether the specified ContactProperty contains data for this ContactEntry. (Inherited from ContactEntry.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SubtractAccessRights | Subtracts the access rights.
Public method | ToString | Returns a String that represents the current Object. (Inherited from ContactEntry.)

See Also

EditableContactEntry Class
ININ.IceLib.Directories Namespace


AddAccessRights Method

[image]

IceLib Technical Reference
EditableContactEntry..::..AddAccessRights Method
EditableContactEntry Class See Also Send Feedback
Adds the access rights.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAccessRights(
    ContactAccessRights rights
)
Visual Basic
Public Sub AddAccessRights ( _
    rights As ContactAccessRights _
)

Parameters

rights
Type: ININ.IceLib.Directories..::..ContactAccessRights
The access rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


SubtractAccessRights Method

[image]

IceLib Technical Reference
EditableContactEntry..::..SubtractAccessRights Method
EditableContactEntry Class See Also Send Feedback
Subtracts the access rights.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SubtractAccessRights(
    ContactAccessRights rights
)
Visual Basic
Public Sub SubtractAccessRights ( _
    rights As ContactAccessRights _
)

Parameters

rights
Type: ININ.IceLib.Directories..::..ContactAccessRights
The rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


EditableContactEntry Properties

[image] [image]

IceLib Technical Reference
EditableContactEntry Properties
EditableContactEntry Class See Also Send Feedback

The EditableContactEntry type exposes the following members.

Properties

 | Name | Description
Public property | AccessRights | Gets or sets the access rights.
Public property | Alias | Gets the alias.
Public property | Assistant | Gets or sets the assistant name.
Public property | AssistantPhone | Gets the assistant phone, which can be used to edit the value.
Public property | BusinessAddress | Gets or sets the business address.
Public property | BusinessCity | Gets or sets the business city.
Public property | BusinessCountry | Gets or sets the business country.
Public property | BusinessEmail | Gets or sets the business Email.
Public property | BusinessPhone | Gets the business phone, which can be used to edit the value.
Public property | BusinessPhone2 | Gets the business phone2, which can be used to edit the value.
Public property | BusinessState | Gets or sets the state of the business.
Public property | BusinessZipCode | Gets or sets the business zip code.
Public property | Company | Gets or sets the company.
Public property | ContactSources | Gets the contact's source(s). See ContactSource for further details. (Inherited from ContactEntry.)
Public property | Department | Gets or sets the department.
Public property | DisplayName | Gets or sets the name of the display.
Public property | EntryId | Gets or sets the entry ID.
Public property | Extension | Gets the extension.
Public property | ExtensionAsPhoneNumber | Gets the extension in Phone Number format. DirectoryPhoneNumber.
Public property | ExternalContactEntries | Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC. (Inherited from ContactEntry.)
Public property | ExternalPresenceProviders | Gets the available external presence providers for this contact. (Inherited from ContactEntry.)
Public property | Fax | Gets the contact's business Fax number, which can be used to edit the value.
Public property | FirstName | Gets or sets first name.
Public property | HomeAddress | Gets or sets the home address.
Public property | HomeCity | Gets or sets the home city.
Public property | HomeCountry | Gets or sets the home country.
Public property | HomeEmail | Gets or sets the home Email.
Public property | HomePhone | Gets the home phone, which can be used to edit the value.
Public property | HomePhone2 | Gets the home phone2, which can be used to edit the value.
Public property | HomeState | Gets or sets the home state.
Public property | HomeZipCode | Gets or sets the home zip code.
Public property | Index | Gets the location of this contact on a paged directory. (Inherited from ContactEntry.)
Public property | LastName | Gets or sets last name.
Public property | LyncSipAddress | Obsolete. Gets the Lync SIP Address for this contact. (Inherited from ContactEntry.)
Public property | MobilePhone | Gets the mobile phone, which can be used to edit the value.
Public property | Notes | Gets or sets the notes.
Public property | OwnerId | Gets the owner.
Public property | Pager | Gets the pager, which can be used to edit the value.
Public property | PrimaryNumberDesignation | Gets or sets the primary number designation. (Not for use with SpeedDial directories.)
Public property | Skills | Gets the Skills set for this contact. (Inherited from ContactEntry.)
Public property | StatusUri | Gets or sets the status uri.
Public property | Title | Gets or sets the title.
Public property | TrackerData | Gets the tracker data. (Inherited from ContactEntry.)
Public property | UserId | Gets the user ID.
Public property | VoicemailLocation | Gets the Voicemail location.
Public property | Webpage | Gets or sets the web page.
Public property | Workgroups | Gets the workgroups.

See Also

EditableContactEntry Class
ININ.IceLib.Directories Namespace


AccessRights Property

[image]

IceLib Technical Reference
EditableContactEntry..::..AccessRights Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the access rights.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactAccessRights AccessRights { get; set; }
Visual Basic
Public Property AccessRights As ContactAccessRights
    Get
    Set

Field Value

This contact's access rights.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Alias Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Alias Property
EditableContactEntry Class See Also Send Feedback
Gets the alias.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Alias { get; }
Visual Basic
Public ReadOnly Property Alias As String
    Get

Field Value

The alias.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Assistant Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Assistant Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the assistant name.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Assistant { get; set; }
Visual Basic
Public Property Assistant As String
    Get
    Set

Field Value

The name of this contact's assistant.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


AssistantPhone Property

[image]

IceLib Technical Reference
EditableContactEntry..::..AssistantPhone Property
EditableContactEntry Class See Also Send Feedback
Gets the assistant phone, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber AssistantPhone { get; }
Visual Basic
Public ReadOnly Property AssistantPhone As EditableDirectoryPhoneNumber
    Get

Field Value

The assistant's telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessAddress Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessAddress Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the business address.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessAddress { get; set; }
Visual Basic
Public Property BusinessAddress As String
    Get
    Set

Field Value

The business address (number and street).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessCity Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessCity Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the business city.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCity { get; set; }
Visual Basic
Public Property BusinessCity As String
    Get
    Set

Field Value

The business city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessCountry Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessCountry Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the business country.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCountry { get; set; }
Visual Basic
Public Property BusinessCountry As String
    Get
    Set

Field Value

The business country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessEmail Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessEmail Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the business Email.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessEmail { get; set; }
Visual Basic
Public Property BusinessEmail As String
    Get
    Set

Field Value

The business Email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessPhone Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessPhone Property
EditableContactEntry Class See Also Send Feedback
Gets the business phone, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber BusinessPhone { get; }
Visual Basic
Public ReadOnly Property BusinessPhone As EditableDirectoryPhoneNumber
    Get

Field Value

The business phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessPhone2 Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessPhone2 Property
EditableContactEntry Class See Also Send Feedback
Gets the business phone2, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber BusinessPhone2 { get; }
Visual Basic
Public ReadOnly Property BusinessPhone2 As EditableDirectoryPhoneNumber
    Get

Field Value

The business phone2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessState Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessState Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the state of the business.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessState { get; set; }
Visual Basic
Public Property BusinessState As String
    Get
    Set

Field Value

The state of the business.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


BusinessZipCode Property

[image]

IceLib Technical Reference
EditableContactEntry..::..BusinessZipCode Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the business zip code.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessZipCode { get; set; }
Visual Basic
Public Property BusinessZipCode As String
    Get
    Set

Field Value

The business zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Company Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Company Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the company.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set

Field Value

The name of the company that this contact works for.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Department Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Department Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the department.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; set; }
Visual Basic
Public Property Department As String
    Get
    Set

Field Value

The department that this contact works in.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


DisplayName Property

[image]

IceLib Technical Reference
EditableContactEntry..::..DisplayName Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the name of the display.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The name of the display.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


EntryId Property

[image]

IceLib Technical Reference
EditableContactEntry..::..EntryId Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the entry ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EntryId { get; set; }
Visual Basic
Public Property EntryId As String
    Get
    Set

Field Value

The entry ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Extension Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Extension Property
EditableContactEntry Class See Also Send Feedback
Gets the extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The contact's telephone extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


ExtensionAsPhoneNumber Property

[image]

IceLib Technical Reference
EditableContactEntry..::..ExtensionAsPhoneNumber Property
EditableContactEntry Class See Also Send Feedback
Gets the extension in Phone Number format. DirectoryPhoneNumber.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryPhoneNumber ExtensionAsPhoneNumber { get; }
Visual Basic
Public ReadOnly Property ExtensionAsPhoneNumber As DirectoryPhoneNumber
    Get

Field Value

The contact's telephone extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Fax Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Fax Property
EditableContactEntry Class See Also Send Feedback
Gets the contact's business Fax number, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber Fax { get; }
Visual Basic
Public ReadOnly Property Fax As EditableDirectoryPhoneNumber
    Get

Field Value

The Fax phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


FirstName Property

[image]

IceLib Technical Reference
EditableContactEntry..::..FirstName Property
EditableContactEntry Class See Also Send Feedback
Gets or sets first name.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The contact's first name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomeAddress Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomeAddress Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the home address.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeAddress { get; set; }
Visual Basic
Public Property HomeAddress As String
    Get
    Set

Field Value

The home address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomeCity Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomeCity Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the home city.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeCity { get; set; }
Visual Basic
Public Property HomeCity As String
    Get
    Set

Field Value

The home city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomeCountry Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomeCountry Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the home country.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeCountry { get; set; }
Visual Basic
Public Property HomeCountry As String
    Get
    Set

Field Value

The home country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomeEmail Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomeEmail Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the home Email.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeEmail { get; set; }
Visual Basic
Public Property HomeEmail As String
    Get
    Set

Field Value

The contact's personal Email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomePhone Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomePhone Property
EditableContactEntry Class See Also Send Feedback
Gets the home phone, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber HomePhone { get; }
Visual Basic
Public ReadOnly Property HomePhone As EditableDirectoryPhoneNumber
    Get

Field Value

The home phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomePhone2 Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomePhone2 Property
EditableContactEntry Class See Also Send Feedback
Gets the home phone2, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber HomePhone2 { get; }
Visual Basic
Public ReadOnly Property HomePhone2 As EditableDirectoryPhoneNumber
    Get

Field Value

The home phone2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomeState Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomeState Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the home state.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeState { get; set; }
Visual Basic
Public Property HomeState As String
    Get
    Set

Field Value

The home state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


HomeZipCode Property

[image]

IceLib Technical Reference
EditableContactEntry..::..HomeZipCode Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the home zip code.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeZipCode { get; set; }
Visual Basic
Public Property HomeZipCode As String
    Get
    Set

Field Value

The home zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


LastName Property

[image]

IceLib Technical Reference
EditableContactEntry..::..LastName Property
EditableContactEntry Class See Also Send Feedback
Gets or sets last name.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The contact's last name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


MobilePhone Property

[image]

IceLib Technical Reference
EditableContactEntry..::..MobilePhone Property
EditableContactEntry Class See Also Send Feedback
Gets the mobile phone, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber MobilePhone { get; }
Visual Basic
Public ReadOnly Property MobilePhone As EditableDirectoryPhoneNumber
    Get

Field Value

The mobile phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Notes Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Notes Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the notes.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; set; }
Visual Basic
Public Property Notes As String
    Get
    Set

Field Value

Text in the notes field.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


OwnerId Property

[image]

IceLib Technical Reference
EditableContactEntry..::..OwnerId Property
EditableContactEntry Class See Also Send Feedback
Gets the owner.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As String
    Get

Field Value

The owner.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Pager Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Pager Property
EditableContactEntry Class See Also Send Feedback
Gets the pager, which can be used to edit the value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber Pager { get; }
Visual Basic
Public ReadOnly Property Pager As EditableDirectoryPhoneNumber
    Get

Field Value

The contact's pager number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


PrimaryNumberDesignation Property

[image]

IceLib Technical Reference
EditableContactEntry..::..PrimaryNumberDesignation Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the primary number designation. (Not for use with SpeedDial directories.)

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactPrimaryNumberDesignation PrimaryNumberDesignation { get; set; }
Visual Basic
Public Property PrimaryNumberDesignation As ContactPrimaryNumberDesignation
    Get
    Set

Field Value

The primary number designation.

Remarks

Note
This is not for use with Speed Dial directories. For those, use UpdateSpeedDialLink(ContactEntry, ContactPrimaryNumberDesignation).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not from the enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace
ContactDirectory..::..UpdateSpeedDialLink(ContactEntry, ContactPrimaryNumberDesignation)


StatusUri Property

[image]

IceLib Technical Reference
EditableContactEntry..::..StatusUri Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the status uri.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StatusUri { get; set; }
Visual Basic
Public Property StatusUri As String
    Get
    Set

Field Value

This contact's status uri.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Title Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Title Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the title.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Field Value

The contact's job title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


UserId Property

[image]

IceLib Technical Reference
EditableContactEntry..::..UserId Property
EditableContactEntry Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


VoicemailLocation Property

[image]

IceLib Technical Reference
EditableContactEntry..::..VoicemailLocation Property
EditableContactEntry Class See Also Send Feedback
Gets the Voicemail location.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string VoicemailLocation { get; }
Visual Basic
Public ReadOnly Property VoicemailLocation As String
    Get

Field Value

The Voicemail location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Webpage Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Webpage Property
EditableContactEntry Class See Also Send Feedback
Gets or sets the web page.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Webpage { get; set; }
Visual Basic
Public Property Webpage As String
    Get
    Set

Field Value

The URL of a company web page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


Workgroups Property

[image]

IceLib Technical Reference
EditableContactEntry..::..Workgroups Property
EditableContactEntry Class See Also Send Feedback
Gets the workgroups.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As ReadOnlyCollection(Of String)
    Get

Field Value

The workgroups that this contact is a member of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableContactEntry Class
EditableContactEntry Members
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Class

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Class
Members See Also Send Feedback
Represents a editable telephone number stored in the contact directory.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EditableDirectoryPhoneNumber : DirectoryPhoneNumber
Visual Basic
Public Class EditableDirectoryPhoneNumber _
    Inherits DirectoryPhoneNumber

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..DirectoryPhoneNumber
ININ.IceLib.Directories..::..EditableDirectoryPhoneNumber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Members

[image] [image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Members
EditableDirectoryPhoneNumber Class Constructors Methods Properties See Also Send Feedback

The EditableDirectoryPhoneNumber type exposes the following members.

Constructors

 | Name | Description
Public method | EditableDirectoryPhoneNumber()()()() | Initializes a new instance of the EditableDirectoryPhoneNumber class.
Public method | EditableDirectoryPhoneNumber(DirectoryPhoneNumber) | Initializes a new instance of the DirectoryPhoneNumber class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current DirectoryPhoneNumber. (Inherited from DirectoryPhoneNumber.)

Properties

 | Name | Description
Public property | AutodialExtension | Gets or sets a value indicating whether to automatically dial the extension.
Public property | ContactProperty | Gets the ContactProperty that this phone number represents. (Inherited from DirectoryPhoneNumber.)
Public property | DialString | Gets the dial string.
Public property | DisplayString | Gets the display string.
Public property | Extension | Gets or sets the extension.
Public property | IsEmpty | Gets a value indicating whether this instance is empty. (Inherited from DirectoryPhoneNumber.)
Public property | PhoneNumber | Gets or sets the telephone number.

See Also

EditableDirectoryPhoneNumber Class
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Constructor

[image] [image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Constructor
EditableDirectoryPhoneNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditableDirectoryPhoneNumber()()()() | Initializes a new instance of the EditableDirectoryPhoneNumber class.
Public method | EditableDirectoryPhoneNumber(DirectoryPhoneNumber) | Initializes a new instance of the DirectoryPhoneNumber class.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Constructor

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Constructor
EditableDirectoryPhoneNumber Class See Also Send Feedback
Initializes a new instance of the EditableDirectoryPhoneNumber class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
EditableDirectoryPhoneNumber Overload
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Constructor (DirectoryPhoneNumber)

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Constructor (DirectoryPhoneNumber)
EditableDirectoryPhoneNumber Class See Also Send Feedback
Initializes a new instance of the DirectoryPhoneNumber class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableDirectoryPhoneNumber(
    DirectoryPhoneNumber directoryPhoneNumber
)
Visual Basic
Public Sub New ( _
    directoryPhoneNumber As DirectoryPhoneNumber _
)

Parameters

directoryPhoneNumber
Type: ININ.IceLib.Directories..::..DirectoryPhoneNumber
An existing directory phone number.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
EditableDirectoryPhoneNumber Overload
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Methods

[image] [image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Methods
EditableDirectoryPhoneNumber Class See Also Send Feedback

The EditableDirectoryPhoneNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current DirectoryPhoneNumber. (Inherited from DirectoryPhoneNumber.)

See Also

EditableDirectoryPhoneNumber Class
ININ.IceLib.Directories Namespace


EditableDirectoryPhoneNumber Properties

[image] [image]

IceLib Technical Reference
EditableDirectoryPhoneNumber Properties
EditableDirectoryPhoneNumber Class See Also Send Feedback

The EditableDirectoryPhoneNumber type exposes the following members.

Properties

 | Name | Description
Public property | AutodialExtension | Gets or sets a value indicating whether to automatically dial the extension.
Public property | ContactProperty | Gets the ContactProperty that this phone number represents. (Inherited from DirectoryPhoneNumber.)
Public property | DialString | Gets the dial string.
Public property | DisplayString | Gets the display string.
Public property | Extension | Gets or sets the extension.
Public property | IsEmpty | Gets a value indicating whether this instance is empty. (Inherited from DirectoryPhoneNumber.)
Public property | PhoneNumber | Gets or sets the telephone number.

See Also

EditableDirectoryPhoneNumber Class
ININ.IceLib.Directories Namespace


AutodialExtension Property

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber..::..AutodialExtension Property
EditableDirectoryPhoneNumber Class See Also Send Feedback
Gets or sets a value indicating whether to automatically dial the extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AutodialExtension { get; set; }
Visual Basic
Public Property AutodialExtension As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) to automatically dial the extension; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


DialString Property

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber..::..DialString Property
EditableDirectoryPhoneNumber Class See Also Send Feedback
Gets the dial string.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DialString { get; }
Visual Basic
Public ReadOnly Property DialString As String
    Get

Field Value

The dial string is the actual string of characters sent to the Central Office to place a call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


DisplayString Property

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber..::..DisplayString Property
EditableDirectoryPhoneNumber Class See Also Send Feedback
Gets the display string.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; }
Visual Basic
Public ReadOnly Property DisplayString As String
    Get

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


Extension Property

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber..::..Extension Property
EditableDirectoryPhoneNumber Class See Also Send Feedback
Gets or sets the extension.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set

Field Value

The extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


PhoneNumber Property

[image]

IceLib Technical Reference
EditableDirectoryPhoneNumber..::..PhoneNumber Property
EditableDirectoryPhoneNumber Class See Also Send Feedback
Gets or sets the telephone number.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PhoneNumber { get; set; }
Visual Basic
Public Property PhoneNumber As String
    Get
    Set

Field Value

The telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableDirectoryPhoneNumber Class
EditableDirectoryPhoneNumber Members
ININ.IceLib.Directories Namespace


ExternalContactEntries Class

[image]

IceLib Technical Reference
ExternalContactEntries Class
Members See Also Send Feedback
Provides a list of ExternalContactEntry objects for a ContactEntry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExternalContactEntries : IEnumerable<KeyValuePair<ContactSource, ExternalContactEntry>>,
    IEnumerable
Visual Basic
Public Class ExternalContactEntries _
    Implements IEnumerable(Of KeyValuePair(Of ContactSource, ExternalContactEntry)),  _
    IEnumerable

Remarks

Utilize ContactSources and ContactSource to help determine when a ContactEntry may contain additional information in the ExternalContactEntries field.

See ExternalContactEntry for further information.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ExternalContactEntries

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ExternalContactEntries Members
ININ.IceLib.Directories Namespace


ExternalContactEntries Members

[image] [image]

IceLib Technical Reference
ExternalContactEntries Members
ExternalContactEntries Class Methods Properties See Also Send Feedback

The ExternalContactEntries type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The number of ExternalContactEntry objects contained in this ExternalContactEntries instance.
Public property | Item | Gets the ExternalContactEntry with the specified contact source designation.

See Also

ExternalContactEntries Class
ININ.IceLib.Directories Namespace


ExternalContactEntries Methods

[image] [image]

IceLib Technical Reference
ExternalContactEntries Methods
ExternalContactEntries Class See Also Send Feedback

The ExternalContactEntries type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalContactEntries Class
ININ.IceLib.Directories Namespace


GetEnumerator Method

[image]

IceLib Technical Reference
ExternalContactEntries..::..GetEnumerator Method
ExternalContactEntries Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerator<KeyValuePair<ContactSource, ExternalContactEntry>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ContactSource, ExternalContactEntry))

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalContactEntries Class
ExternalContactEntries Members
ININ.IceLib.Directories Namespace


ExternalContactEntries Properties

[image] [image]

IceLib Technical Reference
ExternalContactEntries Properties
ExternalContactEntries Class See Also Send Feedback

The ExternalContactEntries type exposes the following members.

Properties

 | Name | Description
Public property | Count | The number of ExternalContactEntry objects contained in this ExternalContactEntries instance.
Public property | Item | Gets the ExternalContactEntry with the specified contact source designation.

See Also

ExternalContactEntries Class
ININ.IceLib.Directories Namespace


Count Property

[image]

IceLib Technical Reference
ExternalContactEntries..::..Count Property
ExternalContactEntries Class See Also Send Feedback
The number of ExternalContactEntry objects contained in this ExternalContactEntries instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ExternalContactEntries Class
ExternalContactEntries Members
ININ.IceLib.Directories Namespace


Item Property

[image]

IceLib Technical Reference
ExternalContactEntries..::..Item Property
ExternalContactEntries Class See Also Send Feedback
Gets the ExternalContactEntry with the specified contact source designation.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExternalContactEntry this[
    ContactSource source
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    source As ContactSource _
) As ExternalContactEntry
    Get

Parameters

source
Type: ININ.IceLib.Directories..::..ContactSource

Field Value

The ExternalContactEntry matching the contact source designation.

Return Value

The ExternalContactEntry corresponding to the ContactSource. If the source is not found then .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ExternalContactEntries Class
ExternalContactEntries Members
ININ.IceLib.Directories Namespace


ExternalContactEntry Class

[image]

IceLib Technical Reference
ExternalContactEntry Class
Members See Also Send Feedback
Contains additional information to ContactEntry for contacts that relate to a system external to IC. A contact is considered to have an external IC relation, when contacts are added or merged in from an external source, or IC contains information specific to an external system.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExternalContactEntry
Visual Basic
Public Class ExternalContactEntry

Remarks

Utilize ContactSources and ContactSource to help determine when a ContactEntry may contain additional information in the ExternalContactEntries field.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ExternalContactEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ExternalContactEntry Members
ININ.IceLib.Directories Namespace


ExternalContactEntry Members

[image] [image]

IceLib Technical Reference
ExternalContactEntry Members
ExternalContactEntry Class Methods Properties See Also Send Feedback

The ExternalContactEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFields | Gets a map of field names to values.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Source | Gets the ContactSource of where the fields were pulled from.

See Also

ExternalContactEntry Class
ININ.IceLib.Directories Namespace


ExternalContactEntry Methods

[image] [image]

IceLib Technical Reference
ExternalContactEntry Methods
ExternalContactEntry Class See Also Send Feedback

The ExternalContactEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFields | Gets a map of field names to values.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalContactEntry Class
ININ.IceLib.Directories Namespace


GetFields Method

[image]

IceLib Technical Reference
ExternalContactEntry..::..GetFields Method
ExternalContactEntry Class See Also Send Feedback
Gets a map of field names to values.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> GetFields()
Visual Basic
Public Function GetFields As IDictionary(Of String, String)

Return Value

An IDictionary<(Of <(<'TKey, TValue>)>)> containing field name to value mappings.

Remarks

Information provided by GetFields()()()() will not be documented and is not guaranteed to stay the same. Field names and values are subject to change.
Note
GetFields()()()() has been provided to support internal ININ integrations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ExternalContactEntry Class
ExternalContactEntry Members
ININ.IceLib.Directories Namespace


ExternalContactEntry Properties

[image] [image]

IceLib Technical Reference
ExternalContactEntry Properties
ExternalContactEntry Class See Also Send Feedback

The ExternalContactEntry type exposes the following members.

Properties

 | Name | Description
Public property | Source | Gets the ContactSource of where the fields were pulled from.

See Also

ExternalContactEntry Class
ININ.IceLib.Directories Namespace


Source Property

[image]

IceLib Technical Reference
ExternalContactEntry..::..Source Property
ExternalContactEntry Class See Also Send Feedback
Gets the ContactSource of where the fields were pulled from.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ContactSource Source { get; }
Visual Basic
Public ReadOnly Property Source As ContactSource
    Get

Return Value

The external source for this ExternalContactEntry. Returns Unknown if the source could not be determined.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ExternalContactEntry Class
ExternalContactEntry Members
ININ.IceLib.Directories Namespace


ExternalPresenceProvider Class

[image]

IceLib Technical Reference
ExternalPresenceProvider Class
Members See Also Send Feedback
Provides External Presence provider details of a ContactEntry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExternalPresenceProvider
Visual Basic
Public Class ExternalPresenceProvider

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ExternalPresenceProvider

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProvider Members
ININ.IceLib.Directories Namespace


ExternalPresenceProvider Members

[image] [image]

IceLib Technical Reference
ExternalPresenceProvider Members
ExternalPresenceProvider Class Methods Properties See Also Send Feedback

The ExternalPresenceProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PresenceId | Gets the presence ID of the ExternalPresence.
Public property | ProviderName | Gets the name of the external presence system.
Public property | StatusUri | Gets the Status URI for this external presence system.

See Also

ExternalPresenceProvider Class
ININ.IceLib.Directories Namespace


ExternalPresenceProvider Methods

[image] [image]

IceLib Technical Reference
ExternalPresenceProvider Methods
ExternalPresenceProvider Class See Also Send Feedback

The ExternalPresenceProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalPresenceProvider Class
ININ.IceLib.Directories Namespace


ExternalPresenceProvider Properties

[image] [image]

IceLib Technical Reference
ExternalPresenceProvider Properties
ExternalPresenceProvider Class See Also Send Feedback

The ExternalPresenceProvider type exposes the following members.

Properties

 | Name | Description
Public property | PresenceId | Gets the presence ID of the ExternalPresence.
Public property | ProviderName | Gets the name of the external presence system.
Public property | StatusUri | Gets the Status URI for this external presence system.

See Also

ExternalPresenceProvider Class
ININ.IceLib.Directories Namespace


PresenceId Property

[image]

IceLib Technical Reference
ExternalPresenceProvider..::..PresenceId Property
ExternalPresenceProvider Class See Also Send Feedback
Gets the presence ID of the ExternalPresence.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PresenceId { get; }
Visual Basic
Public ReadOnly Property PresenceId As String
    Get

Field Value

The presence ID of the ExternalPresence.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProvider Class
ExternalPresenceProvider Members
ININ.IceLib.Directories Namespace


ProviderName Property

[image]

IceLib Technical Reference
ExternalPresenceProvider..::..ProviderName Property
ExternalPresenceProvider Class See Also Send Feedback
Gets the name of the external presence system.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProviderName { get; }
Visual Basic
Public ReadOnly Property ProviderName As String
    Get

Field Value

The name of the external presence system.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProvider Class
ExternalPresenceProvider Members
ININ.IceLib.Directories Namespace


StatusUri Property

[image]

IceLib Technical Reference
ExternalPresenceProvider..::..StatusUri Property
ExternalPresenceProvider Class See Also Send Feedback
Gets the Status URI for this external presence system.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StatusUri { get; }
Visual Basic
Public ReadOnly Property StatusUri As String
    Get

Field Value

The Status URI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProvider Class
ExternalPresenceProvider Members
ININ.IceLib.Directories Namespace


ExternalPresenceProviders Class

[image]

IceLib Technical Reference
ExternalPresenceProviders Class
Members See Also Send Feedback
Provides a list of ExternalPresenceProviders of a ContactEntry.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExternalPresenceProviders : IEnumerable<KeyValuePair<string, ExternalPresenceProvider>>,
    IEnumerable
Visual Basic
Public Class ExternalPresenceProviders _
    Implements IEnumerable(Of KeyValuePair(Of String, ExternalPresenceProvider)),  _
    IEnumerable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ExternalPresenceProviders

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProviders Members
ININ.IceLib.Directories Namespace


ExternalPresenceProviders Members

[image] [image]

IceLib Technical Reference
ExternalPresenceProviders Members
ExternalPresenceProviders Class Methods Properties See Also Send Feedback

The ExternalPresenceProviders type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the ExternalPresenceProvider with the specified provider name.

See Also

ExternalPresenceProviders Class
ININ.IceLib.Directories Namespace


ExternalPresenceProviders Methods

[image] [image]

IceLib Technical Reference
ExternalPresenceProviders Methods
ExternalPresenceProviders Class See Also Send Feedback

The ExternalPresenceProviders type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalPresenceProviders Class
ININ.IceLib.Directories Namespace


GetEnumerator Method

[image]

IceLib Technical Reference
ExternalPresenceProviders..::..GetEnumerator Method
ExternalPresenceProviders Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerator<KeyValuePair<string, ExternalPresenceProvider>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, ExternalPresenceProvider))

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProviders Class
ExternalPresenceProviders Members
ININ.IceLib.Directories Namespace


ExternalPresenceProviders Properties

[image] [image]

IceLib Technical Reference
ExternalPresenceProviders Properties
ExternalPresenceProviders Class See Also Send Feedback

The ExternalPresenceProviders type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the ExternalPresenceProvider with the specified provider name.

See Also

ExternalPresenceProviders Class
ININ.IceLib.Directories Namespace


Item Property

[image]

IceLib Technical Reference
ExternalPresenceProviders..::..Item Property
ExternalPresenceProviders Class See Also Send Feedback
Gets the ExternalPresenceProvider with the specified provider name.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExternalPresenceProvider this[
    string providerName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    providerName As String _
) As ExternalPresenceProvider
    Get

Parameters

providerName
Type: System..::..String

Field Value

The ExternalPresenceProvider matching the provider name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalPresenceProviders Class
ExternalPresenceProviders Members
ININ.IceLib.Directories Namespace


PendingDirectoryEntries Class

[image]

IceLib Technical Reference
PendingDirectoryEntries Class
Members See Also Send Feedback
Used to identify overall pending status and individual PendingDirectoryGroup statuses for directories (DirectoryConfigurationChanged or Pending).

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PendingDirectoryEntries : PendingEntries
Visual Basic
Public Class PendingDirectoryEntries _
    Inherits PendingEntries

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..PendingEntries
ININ.IceLib.Directories..::..PendingDirectoryEntries

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryEntries Members
ININ.IceLib.Directories Namespace


PendingDirectoryEntries Members

[image] [image]

IceLib Technical Reference
PendingDirectoryEntries Members
PendingDirectoryEntries Class Methods Properties See Also Send Feedback

The PendingDirectoryEntries type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides PendingEntries..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Entries | Gets the entries.
Public property | Status | Gets the overall PendingStatus. (Inherited from PendingEntries.)

See Also

PendingDirectoryEntries Class
ININ.IceLib.Directories Namespace


PendingDirectoryEntries Methods

[image] [image]

IceLib Technical Reference
PendingDirectoryEntries Methods
PendingDirectoryEntries Class See Also Send Feedback

The PendingDirectoryEntries type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides PendingEntries..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PendingDirectoryEntries Class
ININ.IceLib.Directories Namespace


Clone Method

[image]

IceLib Technical Reference
PendingDirectoryEntries..::..Clone Method
PendingDirectoryEntries Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PendingDirectoryEntries Class
PendingDirectoryEntries Members
ININ.IceLib.Directories Namespace


PendingDirectoryEntries Properties

[image] [image]

IceLib Technical Reference
PendingDirectoryEntries Properties
PendingDirectoryEntries Class See Also Send Feedback

The PendingDirectoryEntries type exposes the following members.

Properties

 | Name | Description
Public property | Entries | Gets the entries.
Public property | Status | Gets the overall PendingStatus. (Inherited from PendingEntries.)

See Also

PendingDirectoryEntries Class
ININ.IceLib.Directories Namespace


Entries Property

[image]

IceLib Technical Reference
PendingDirectoryEntries..::..Entries Property
PendingDirectoryEntries Class See Also Send Feedback
Gets the entries.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PendingDirectoryGroup> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As ReadOnlyCollection(Of PendingDirectoryGroup)
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryEntries Class
PendingDirectoryEntries Members
ININ.IceLib.Directories Namespace


PendingDirectoryGroup Class

[image]

IceLib Technical Reference
PendingDirectoryGroup Class
Members See Also Send Feedback
Represents a grouping of directories that are or were pending to be loaded.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PendingDirectoryGroup : ICloneable,
    IEquatable<PendingDirectoryGroup>
Visual Basic
Public Class PendingDirectoryGroup _
    Implements ICloneable, IEquatable(Of PendingDirectoryGroup)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..PendingDirectoryGroup

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


PendingDirectoryGroup Members

[image] [image]

IceLib Technical Reference
PendingDirectoryGroup Members
PendingDirectoryGroup Class Constructors Methods Properties See Also Send Feedback

The PendingDirectoryGroup type exposes the following members.

Constructors

 | Name | Description
Public method | PendingDirectoryGroup | Initializes a new instance of the PendingDirectoryGroup class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(PendingDirectoryGroup) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DirectoryMetadataCategory | Gets the directory metadata category.
Public property | IsPending | Gets a value indicating whether this directory category is still pending.
Public property | IsPrivate | Gets a value indicating whether the directory group is private or not.

See Also

PendingDirectoryGroup Class
ININ.IceLib.Directories Namespace


PendingDirectoryGroup Constructor

[image]

IceLib Technical Reference
PendingDirectoryGroup Constructor
PendingDirectoryGroup Class See Also Send Feedback
Initializes a new instance of the PendingDirectoryGroup class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PendingDirectoryGroup(
    DirectoryMetadataCategory category,
    bool isPrivate
)
Visual Basic
Public Sub New ( _
    category As DirectoryMetadataCategory, _
    isPrivate As Boolean _
)

Parameters

category
Type: ININ.IceLib.Directories..::..DirectoryMetadataCategory
The category.
isPrivate
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) this grouping is considered non-public.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


PendingDirectoryGroup Methods

[image] [image]

IceLib Technical Reference
PendingDirectoryGroup Methods
PendingDirectoryGroup Class See Also Send Feedback

The PendingDirectoryGroup type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(PendingDirectoryGroup) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PendingDirectoryGroup Class
ININ.IceLib.Directories Namespace


Clone Method

[image]

IceLib Technical Reference
PendingDirectoryGroup..::..Clone Method
PendingDirectoryGroup Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


Equals Method

[image] [image]

IceLib Technical Reference
PendingDirectoryGroup..::..Equals Method
PendingDirectoryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(PendingDirectoryGroup) | Indicates whether the current object is equal to another object of the same type.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


Equals Method (PendingDirectoryGroup)

[image]

IceLib Technical Reference
PendingDirectoryGroup..::..Equals Method (PendingDirectoryGroup)
PendingDirectoryGroup Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    PendingDirectoryGroup other
)
Visual Basic
Public Function Equals ( _
    other As PendingDirectoryGroup _
) As Boolean

Parameters

other
Type: ININ.IceLib.Directories..::..PendingDirectoryGroup
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
Equals Overload
ININ.IceLib.Directories Namespace


PendingDirectoryGroup Properties

[image] [image]

IceLib Technical Reference
PendingDirectoryGroup Properties
PendingDirectoryGroup Class See Also Send Feedback

The PendingDirectoryGroup type exposes the following members.

Properties

 | Name | Description
Public property | DirectoryMetadataCategory | Gets the directory metadata category.
Public property | IsPending | Gets a value indicating whether this directory category is still pending.
Public property | IsPrivate | Gets a value indicating whether the directory group is private or not.

See Also

PendingDirectoryGroup Class
ININ.IceLib.Directories Namespace


DirectoryMetadataCategory Property

[image]

IceLib Technical Reference
PendingDirectoryGroup..::..DirectoryMetadataCategory Property
PendingDirectoryGroup Class See Also Send Feedback
Gets the directory metadata category.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectoryMetadataCategory DirectoryMetadataCategory { get; private set; }
Visual Basic
Public Property DirectoryMetadataCategory As DirectoryMetadataCategory
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


IsPending Property

[image]

IceLib Technical Reference
PendingDirectoryGroup..::..IsPending Property
PendingDirectoryGroup Class See Also Send Feedback
Gets a value indicating whether this directory category is still pending.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPending { get; internal set; }
Visual Basic
Public Property IsPending As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is pending; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


IsPrivate Property

[image]

IceLib Technical Reference
PendingDirectoryGroup..::..IsPrivate Property
PendingDirectoryGroup Class See Also Send Feedback
Gets a value indicating whether the directory group is private or not.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPrivate { get; private set; }
Visual Basic
Public Property IsPrivate As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingDirectoryGroup Class
PendingDirectoryGroup Members
ININ.IceLib.Directories Namespace


PendingEntries Class

[image]

IceLib Technical Reference
PendingEntries Class
Members See Also Send Feedback
Base class for identification of pending directory data.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PendingEntries : ICloneable
Visual Basic
Public Class PendingEntries _
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..PendingEntries
ININ.IceLib.Directories..::..PendingDirectoryEntries

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingEntries Members
ININ.IceLib.Directories Namespace


PendingEntries Members

[image] [image]

IceLib Technical Reference
PendingEntries Members
PendingEntries Class Methods Properties See Also Send Feedback

The PendingEntries type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Status | Gets the overall PendingStatus.

See Also

PendingEntries Class
ININ.IceLib.Directories Namespace


PendingEntries Methods

[image] [image]

IceLib Technical Reference
PendingEntries Methods
PendingEntries Class See Also Send Feedback

The PendingEntries type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PendingEntries Class
ININ.IceLib.Directories Namespace


Clone Method

[image]

IceLib Technical Reference
PendingEntries..::..Clone Method
PendingEntries Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PendingEntries Class
PendingEntries Members
ININ.IceLib.Directories Namespace


PendingEntries Properties

[image] [image]

IceLib Technical Reference
PendingEntries Properties
PendingEntries Class See Also Send Feedback

The PendingEntries type exposes the following members.

Properties

 | Name | Description
Public property | Status | Gets the overall PendingStatus.

See Also

PendingEntries Class
ININ.IceLib.Directories Namespace


Status Property

[image]

IceLib Technical Reference
PendingEntries..::..Status Property
PendingEntries Class See Also Send Feedback
Gets the overall PendingStatus.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PendingStatus Status { get; internal set; }
Visual Basic
Public Property Status As PendingStatus
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PendingEntries Class
PendingEntries Members
ININ.IceLib.Directories Namespace


PendingStatus Enumeration

[image]

IceLib Technical Reference
PendingStatus Enumeration
See Also Send Feedback
Identifies the pending status of a directory object.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum PendingStatus
Visual Basic
Public Enumeration PendingStatus

Members

Member name | Value | Description
None | 0 | All information was loaded when requested, no loads are or were pending.
Pending | 1 | There is information that still needs to be loaded.
Completed | 2 | All pending information was loaded.

Remarks

See DirectoryConfiguration, ContactDirectory and DirectoryEventArgs<(Of <(<'TWatchedObject>)>)> for usages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Directories Namespace


TrackerFilterAttribute Class

[image]

IceLib Technical Reference
TrackerFilterAttribute Class
Members See Also Send Feedback
Tracker filter attribute.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerFilterAttribute
Visual Basic
Public Class TrackerFilterAttribute

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..TrackerFilterAttribute

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterAttribute Members
ININ.IceLib.Directories Namespace


TrackerFilterAttribute Members

[image] [image]

IceLib Technical Reference
TrackerFilterAttribute Members
TrackerFilterAttribute Class Constructors Methods Properties See Also Send Feedback

The TrackerFilterAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerFilterAttribute()()()() | Initializes a new instance of the TrackerFilterAttribute class.
Public method | TrackerFilterAttribute(String, String) | Initializes a new instance of the TrackerFilterAttribute class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeId | Gets or sets the attribute ID.
Public property | Value | Gets or sets the attribute value.

See Also

TrackerFilterAttribute Class
ININ.IceLib.Directories Namespace


TrackerFilterAttribute Constructor

[image] [image]

IceLib Technical Reference
TrackerFilterAttribute Constructor
TrackerFilterAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrackerFilterAttribute()()()() | Initializes a new instance of the TrackerFilterAttribute class.
Public method | TrackerFilterAttribute(String, String) | Initializes a new instance of the TrackerFilterAttribute class.

See Also

TrackerFilterAttribute Class
TrackerFilterAttribute Members
ININ.IceLib.Directories Namespace


TrackerFilterAttribute Constructor

[image]

IceLib Technical Reference
TrackerFilterAttribute Constructor
TrackerFilterAttribute Class See Also Send Feedback
Initializes a new instance of the TrackerFilterAttribute class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerFilterAttribute()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterAttribute Class
TrackerFilterAttribute Members
TrackerFilterAttribute Overload
ININ.IceLib.Directories Namespace


TrackerFilterAttribute Constructor (String, String)

[image]

IceLib Technical Reference
TrackerFilterAttribute Constructor (String, String)
TrackerFilterAttribute Class See Also Send Feedback
Initializes a new instance of the TrackerFilterAttribute class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerFilterAttribute(
    string attributeId,
    string attributeValue
)
Visual Basic
Public Sub New ( _
    attributeId As String, _
    attributeValue As String _
)

Parameters

attributeId
Type: System..::..String
The attribute ID.
attributeValue
Type: System..::..String
The attribute value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterAttribute Class
TrackerFilterAttribute Members
TrackerFilterAttribute Overload
ININ.IceLib.Directories Namespace


TrackerFilterAttribute Methods

[image] [image]

IceLib Technical Reference
TrackerFilterAttribute Methods
TrackerFilterAttribute Class See Also Send Feedback

The TrackerFilterAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerFilterAttribute Class
ININ.IceLib.Directories Namespace


TrackerFilterAttribute Properties

[image] [image]

IceLib Technical Reference
TrackerFilterAttribute Properties
TrackerFilterAttribute Class See Also Send Feedback

The TrackerFilterAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeId | Gets or sets the attribute ID.
Public property | Value | Gets or sets the attribute value.

See Also

TrackerFilterAttribute Class
ININ.IceLib.Directories Namespace


AttributeId Property

[image]

IceLib Technical Reference
TrackerFilterAttribute..::..AttributeId Property
TrackerFilterAttribute Class See Also Send Feedback
Gets or sets the attribute ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AttributeId { get; set; }
Visual Basic
Public Property AttributeId As String
    Get
    Set

Field Value

The attribute ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterAttribute Class
TrackerFilterAttribute Members
ININ.IceLib.Directories Namespace


Value Property

[image]

IceLib Technical Reference
TrackerFilterAttribute..::..Value Property
TrackerFilterAttribute Class See Also Send Feedback
Gets or sets the attribute value.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The attribute value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterAttribute Class
TrackerFilterAttribute Members
ININ.IceLib.Directories Namespace


TrackerFilterSettings Class

[image]

IceLib Technical Reference
TrackerFilterSettings Class
Members See Also Send Feedback
Tracker filter settings.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerFilterSettings
Visual Basic
Public Class TrackerFilterSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..TrackerFilterSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


TrackerFilterSettings Members

[image] [image]

IceLib Technical Reference
TrackerFilterSettings Members
TrackerFilterSettings Class Constructors Methods Properties See Also Send Feedback

The TrackerFilterSettings type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerFilterSettings | Initializes a new instance of the TrackerFilterSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressCity | Gets or sets the address city.
Public property | AddressCountry | Gets or sets the address country.
Public property | AddressState | Gets or sets the address state.
Public property | AddressTypeId | Gets or sets the address type ID.
Public property | AddressZip | Gets or sets the address zip code.
Public property | AttributeValues | Gets the attribute values collection. This is a collection of TrackerFilterAttribute.
Public property | Department | Gets or sets the department.
Public property | IndividualTypeId | Gets or sets the individual type ID.
Public property | LocationId | Gets or sets the location ID.
Public property | OrganizationId | Gets or sets the organization ID.

See Also

TrackerFilterSettings Class
ININ.IceLib.Directories Namespace


TrackerFilterSettings Constructor

[image]

IceLib Technical Reference
TrackerFilterSettings Constructor
TrackerFilterSettings Class See Also Send Feedback
Initializes a new instance of the TrackerFilterSettings class.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerFilterSettings()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


TrackerFilterSettings Methods

[image] [image]

IceLib Technical Reference
TrackerFilterSettings Methods
TrackerFilterSettings Class See Also Send Feedback

The TrackerFilterSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerFilterSettings Class
ININ.IceLib.Directories Namespace


TrackerFilterSettings Properties

[image] [image]

IceLib Technical Reference
TrackerFilterSettings Properties
TrackerFilterSettings Class See Also Send Feedback

The TrackerFilterSettings type exposes the following members.

Properties

 | Name | Description
Public property | AddressCity | Gets or sets the address city.
Public property | AddressCountry | Gets or sets the address country.
Public property | AddressState | Gets or sets the address state.
Public property | AddressTypeId | Gets or sets the address type ID.
Public property | AddressZip | Gets or sets the address zip code.
Public property | AttributeValues | Gets the attribute values collection. This is a collection of TrackerFilterAttribute.
Public property | Department | Gets or sets the department.
Public property | IndividualTypeId | Gets or sets the individual type ID.
Public property | LocationId | Gets or sets the location ID.
Public property | OrganizationId | Gets or sets the organization ID.

See Also

TrackerFilterSettings Class
ININ.IceLib.Directories Namespace


AddressCity Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..AddressCity Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the address city.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddressCity { get; set; }
Visual Basic
Public Property AddressCity As String
    Get
    Set

Field Value

The address city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


AddressCountry Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..AddressCountry Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the address country.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddressCountry { get; set; }
Visual Basic
Public Property AddressCountry As String
    Get
    Set

Field Value

The address country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


AddressState Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..AddressState Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the address state.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddressState { get; set; }
Visual Basic
Public Property AddressState As String
    Get
    Set

Field Value

The state of the address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


AddressTypeId Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..AddressTypeId Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the address type ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddressTypeId { get; set; }
Visual Basic
Public Property AddressTypeId As String
    Get
    Set

Field Value

The address type ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


AddressZip Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..AddressZip Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the address zip code.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddressZip { get; set; }
Visual Basic
Public Property AddressZip As String
    Get
    Set

Field Value

The address zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


AttributeValues Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..AttributeValues Property
TrackerFilterSettings Class See Also Send Feedback
Gets the attribute values collection. This is a collection of TrackerFilterAttribute.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<TrackerFilterAttribute> AttributeValues { get; }
Visual Basic
Public ReadOnly Property AttributeValues As Collection(Of TrackerFilterAttribute)
    Get

Field Value

The attribute values collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


Department Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..Department Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the department.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; set; }
Visual Basic
Public Property Department As String
    Get
    Set

Field Value

The department.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


IndividualTypeId Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..IndividualTypeId Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the individual type ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualTypeId { get; set; }
Visual Basic
Public Property IndividualTypeId As String
    Get
    Set

Field Value

The individual type ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


LocationId Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..LocationId Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the location ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


OrganizationId Property

[image]

IceLib Technical Reference
TrackerFilterSettings..::..OrganizationId Property
TrackerFilterSettings Class See Also Send Feedback
Gets or sets the organization ID.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerFilterSettings Class
TrackerFilterSettings Members
ININ.IceLib.Directories Namespace


UserSkill Class

[image]

IceLib Technical Reference
UserSkill Class
Members See Also Send Feedback
Represents a user's skill.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserSkill
Visual Basic
Public Class UserSkill

Remarks

User's skill is a combination of name, proficiency and desire to use.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..UserSkill

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSkill Members
ININ.IceLib.Directories Namespace


UserSkill Members

[image] [image]

IceLib Technical Reference
UserSkill Members
UserSkill Class Constructors Methods Properties See Also Send Feedback

The UserSkill type exposes the following members.

Constructors

 | Name | Description
Public method | UserSkill | Initializes a new instance of the UserSkill class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DesireToUse | A percentage value representing the user's desire to use the skill.
Public property | Name | Gets the name of the skill.
Public property | Proficiency | A percentage value representing the user's proficiency in the skill.

See Also

UserSkill Class
ININ.IceLib.Directories Namespace


UserSkill Constructor

[image]

IceLib Technical Reference
UserSkill Constructor
UserSkill Class See Also Send Feedback
Initializes a new instance of the UserSkill class

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserSkill()
Visual Basic
Public Sub New

See Also

UserSkill Class
UserSkill Members
ININ.IceLib.Directories Namespace


UserSkill Methods

[image] [image]

IceLib Technical Reference
UserSkill Methods
UserSkill Class See Also Send Feedback

The UserSkill type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserSkill Class
ININ.IceLib.Directories Namespace


UserSkill Properties

[image] [image]

IceLib Technical Reference
UserSkill Properties
UserSkill Class See Also Send Feedback

The UserSkill type exposes the following members.

Properties

 | Name | Description
Public property | DesireToUse | A percentage value representing the user's desire to use the skill.
Public property | Name | Gets the name of the skill.
Public property | Proficiency | A percentage value representing the user's proficiency in the skill.

See Also

UserSkill Class
ININ.IceLib.Directories Namespace


DesireToUse Property

[image]

IceLib Technical Reference
UserSkill..::..DesireToUse Property
UserSkill Class See Also Send Feedback
A percentage value representing the user's desire to use the skill.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int DesireToUse { get; internal set; }
Visual Basic
Public Property DesireToUse As Integer
    Get
    Friend Set

Field Value

The Desire to Use.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSkill Class
UserSkill Members
ININ.IceLib.Directories Namespace


Name Property

[image]

IceLib Technical Reference
UserSkill..::..Name Property
UserSkill Class See Also Send Feedback
Gets the name of the skill.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set

Field Value

The name of the skill.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSkill Class
UserSkill Members
ININ.IceLib.Directories Namespace


Proficiency Property

[image]

IceLib Technical Reference
UserSkill..::..Proficiency Property
UserSkill Class See Also Send Feedback
A percentage value representing the user's proficiency in the skill.

Namespace: ININ.IceLib.Directories
Assembly: ININ.IceLib.Directories (in ININ.IceLib.Directories.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Proficiency { get; internal set; }
Visual Basic
Public Property Proficiency As Integer
    Get
    Friend Set

Field Value

The Proficiency.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserSkill Class
UserSkill Members
ININ.IceLib.Directories Namespace


ININ.IceLib.EFaq Namespace

[image]

IceLib Technical Reference
ININ.IceLib.EFaq Namespace
Send Feedback

The ININ.IceLib.EFaq namespace provides classes for accessing the e-FAQ Frequently Asked Question database.

To obtain a list of e-FAQ servers and their respective FAQ Topics, use the EFaqServerList class. This class provides access to the EFaqServer objects that correspond to the e-FAQ servers to which the user has been granted access persmission. Queries can then be issued to each server via the Query(String, IEnumerable<(Of <<'(EFaqTopic>)>>), EFaqQueryOptions) method, or the corresponding asynchronous method, on the EFaqServer object.

Classes

 | Class | Description
Public class | EFaqEntry | Represents a Question / Answer entry in the e-FAQ database.
Public class | EFaqQueryCompletedEventArgs | Provides data for the completedCallback delegate of the QueryAsync(String, IEnumerable<(Of <<'(EFaqTopic>)>>), EFaqQueryOptions, EventHandler<(Of <<'(EFaqQueryCompletedEventArgs>)>>), Object) event of an EFaqServer.
Public class | EFaqQueryOptions | Specifies the settings used when submitting an e-FAQ query.
Public class | EFaqQueryResults | The result set returned by an e-FAQ query.
Public class | EFaqServer | Represents an e-FAQ server that is in contact with the IC server.
Public class | EFaqServerList | Provides information and change notifications about the e-FAQ system.
Public class | EFaqTopic | Represents a single FAQ on an e-FAQ server.

Enumerations

 | Enumeration | Description
Public enumeration | EFaqServerProperty | Each enumerated value represents a property of the EFaqServer class.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.


EFaqEntry Class

[image]

IceLib Technical Reference
EFaqEntry Class
Members See Also Send Feedback
Represents a Question / Answer entry in the e-FAQ database.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqEntry
Visual Basic
Public Class EFaqEntry

Remarks

An EFaqEntry object represents a single Question and Answer entry in the e-FAQ database, as well as relevant metadata for that entry.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.EFaq..::..EFaqEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Members
ININ.IceLib.EFaq Namespace


EFaqEntry Members

[image] [image]

IceLib Technical Reference
EFaqEntry Members
EFaqEntry Class Methods Properties See Also Send Feedback

The EFaqEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkAsUsed | Marks this entry as used.
Public method | MarkAsUsedAsync | Asynchronously marks this entry as used.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Answer | Gets the answer portion of this entry.
Public property | AnswerAsPlainText | Gets the answer portion of this entry, rendered as plain text.
Public property | Grade | Gets the grade for this entry, describing how well it matched the query.
Public property | Id | Gets the unique identifier for this entry.
Public property | Question | Gets the question portion of this entry.
Public property | QuestionAsPlainText | Gets the question portion of this entry, rendered as plain text.

See Also

EFaqEntry Class
ININ.IceLib.EFaq Namespace


EFaqEntry Methods

[image] [image]

IceLib Technical Reference
EFaqEntry Methods
EFaqEntry Class See Also Send Feedback

The EFaqEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkAsUsed | Marks this entry as used.
Public method | MarkAsUsedAsync | Asynchronously marks this entry as used.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqEntry Class
ININ.IceLib.EFaq Namespace


MarkAsUsed Method

[image]

IceLib Technical Reference
EFaqEntry..::..MarkAsUsed Method
EFaqEntry Class See Also Send Feedback
Marks this entry as used.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MarkAsUsed()
Visual Basic
Public Sub MarkAsUsed

Remarks

This can be used by the FAQ author to guage the quality of an entry.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


MarkAsUsedAsync Method

[image]

IceLib Technical Reference
EFaqEntry..::..MarkAsUsedAsync Method
EFaqEntry Class See Also Send Feedback
Asynchronously marks this entry as used.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MarkAsUsedAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub MarkAsUsedAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

This can be used by the FAQ author to gauge the quality of an entry.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


EFaqEntry Properties

[image] [image]

IceLib Technical Reference
EFaqEntry Properties
EFaqEntry Class See Also Send Feedback

The EFaqEntry type exposes the following members.

Properties

 | Name | Description
Public property | Answer | Gets the answer portion of this entry.
Public property | AnswerAsPlainText | Gets the answer portion of this entry, rendered as plain text.
Public property | Grade | Gets the grade for this entry, describing how well it matched the query.
Public property | Id | Gets the unique identifier for this entry.
Public property | Question | Gets the question portion of this entry.
Public property | QuestionAsPlainText | Gets the question portion of this entry, rendered as plain text.

See Also

EFaqEntry Class
ININ.IceLib.EFaq Namespace


Answer Property

[image]

IceLib Technical Reference
EFaqEntry..::..Answer Property
EFaqEntry Class See Also Send Feedback
Gets the answer portion of this entry.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Answer { get; internal set; }
Visual Basic
Public Property Answer As String
    Get
    Friend Set

Field Value

The answer.

Remarks

E-FAQ entries can contain embedded HTML tags. Answer will retain the HTML tags and whitespace, whereas AnswerAsPlainText will attempt to render the entry's HTML and whitespace to a text-only version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


AnswerAsPlainText Property

[image]

IceLib Technical Reference
EFaqEntry..::..AnswerAsPlainText Property
EFaqEntry Class See Also Send Feedback
Gets the answer portion of this entry, rendered as plain text.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AnswerAsPlainText { get; }
Visual Basic
Public ReadOnly Property AnswerAsPlainText As String
    Get

Field Value

The answer in plain text.

Remarks

E-FAQ entries can contain embedded HTML tags. Answer will retain the HTML tags and whitespace, whereas AnswerAsPlainText will attempt to render the entry's HTML and whitespace to a text-only version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


Grade Property

[image]

IceLib Technical Reference
EFaqEntry..::..Grade Property
EFaqEntry Class See Also Send Feedback
Gets the grade for this entry, describing how well it matched the query.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public double Grade { get; internal set; }
Visual Basic
Public Property Grade As Double
    Get
    Friend Set

Field Value

The grade.

Remarks

The grade of a result is used to determine how well a Question / Answer pair matches the query. Setting the minimum grade higher will generally yield fewer results. The valid range is 1.0 to 10.0. Only entries with grades above the MinimumGrade specified in the query will be returned.

When more than one entry is returned, e-FAQ uses the matching grade to rank the results so that they can be presented in the order of the highest score first.

In the case of a tie, the order the entries actually get returned is undefined. Thus, it is theoretically possible that two entries might get exactly the same score and one would get returned and not the other. (For example, if a query had specified that only up to 3 entries be returned and there was a tie for third place, one entry would get left out of the result set, even though its score was the same as the other 3rd place entry.)

The only exception to all of this is entries that are returned because they contained a "guaranteed hit" keyword. All of these are returned, no matter what. (So, even if the query specified only to return up to 5 entries, if 7 entries were guaranteed-hits, then 7 entries will be returned.)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace
EFaqQueryOptions..::..MinimumGrade


Id Property

[image]

IceLib Technical Reference
EFaqEntry..::..Id Property
EFaqEntry Class See Also Send Feedback
Gets the unique identifier for this entry.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; internal set; }
Visual Basic
Public Property Id As String
    Get
    Friend Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


Question Property

[image]

IceLib Technical Reference
EFaqEntry..::..Question Property
EFaqEntry Class See Also Send Feedback
Gets the question portion of this entry.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Question { get; internal set; }
Visual Basic
Public Property Question As String
    Get
    Friend Set

Field Value

The question.

Remarks

E-FAQ entries can contain embedded HTML tags. Question will retain the HTML tags and whitespace, whereas QuestionAsPlainText will attempt to render the entry's HTML and whitespace to a text-only version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


QuestionAsPlainText Property

[image]

IceLib Technical Reference
EFaqEntry..::..QuestionAsPlainText Property
EFaqEntry Class See Also Send Feedback
Gets the question portion of this entry, rendered as plain text.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string QuestionAsPlainText { get; }
Visual Basic
Public ReadOnly Property QuestionAsPlainText As String
    Get

Field Value

The question in plain text.

Remarks

E-FAQ entries can contain embedded HTML tags. Question will retain the HTML tags and whitespace, whereas QuestionAsPlainText will attempt to render the entry's HTML and whitespace to a text-only version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqEntry Class
EFaqEntry Members
ININ.IceLib.EFaq Namespace


EFaqQueryCompletedEventArgs Class

[image]

IceLib Technical Reference
EFaqQueryCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of the QueryAsync(String, IEnumerable<(Of <<'(EFaqTopic>)>>), EFaqQueryOptions, EventHandler<(Of <<'(EFaqQueryCompletedEventArgs>)>>), Object) event of an EFaqServer.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqQueryCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class EFaqQueryCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.EFaq..::..EFaqQueryCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryCompletedEventArgs Members
ININ.IceLib.EFaq Namespace


EFaqQueryCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
EFaqQueryCompletedEventArgs Members
EFaqQueryCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The EFaqQueryCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EFaqQueryCompletedEventArgs | Initializes a new instance of this class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | EFaqQueryResults | Gets the e-FAQ query results associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

EFaqQueryCompletedEventArgs Class
ININ.IceLib.EFaq Namespace


EFaqQueryCompletedEventArgs Constructor

[image]

IceLib Technical Reference
EFaqQueryCompletedEventArgs Constructor
EFaqQueryCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of this class with the specified values.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqQueryCompletedEventArgs(
    EFaqQueryResults eFaqQueryResults,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    eFaqQueryResults As EFaqQueryResults, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

eFaqQueryResults
Type: ININ.IceLib.EFaq..::..EFaqQueryResults
The e-FAQ query results.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryCompletedEventArgs Class
EFaqQueryCompletedEventArgs Members
ININ.IceLib.EFaq Namespace


EFaqQueryCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
EFaqQueryCompletedEventArgs Methods
EFaqQueryCompletedEventArgs Class See Also Send Feedback

The EFaqQueryCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqQueryCompletedEventArgs Class
ININ.IceLib.EFaq Namespace


EFaqQueryCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
EFaqQueryCompletedEventArgs Properties
EFaqQueryCompletedEventArgs Class See Also Send Feedback

The EFaqQueryCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | EFaqQueryResults | Gets the e-FAQ query results associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

EFaqQueryCompletedEventArgs Class
ININ.IceLib.EFaq Namespace


EFaqQueryResults Property

[image]

IceLib Technical Reference
EFaqQueryCompletedEventArgs..::..EFaqQueryResults Property
EFaqQueryCompletedEventArgs Class See Also Send Feedback
Gets the e-FAQ query results associated with the event.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqQueryResults EFaqQueryResults { get; }
Visual Basic
Public ReadOnly Property EFaqQueryResults As EFaqQueryResults
    Get

Field Value

The query results.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryCompletedEventArgs Class
EFaqQueryCompletedEventArgs Members
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Class

[image]

IceLib Technical Reference
EFaqQueryOptions Class
Members See Also Send Feedback
Specifies the settings used when submitting an e-FAQ query.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqQueryOptions
Visual Basic
Public Class EFaqQueryOptions

Inheritance Hierarchy

System..::..Object
ININ.IceLib.EFaq..::..EFaqQueryOptions

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryOptions Members
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Members

[image] [image]

IceLib Technical Reference
EFaqQueryOptions Members
EFaqQueryOptions Class Constructors Methods Properties See Also Send Feedback

The EFaqQueryOptions type exposes the following members.

Constructors

 | Name | Description
Public method | EFaqQueryOptions()()()() | Initializes a new instance of the EFaqQueryOptions class.
Public method | EFaqQueryOptions(Int32, Double, Double) | Initializes a new instance of the EFaqQueryOptions class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | MaximumResults | Gets the maximum results returned per query.
Public property | MinimumGrade | Gets the minimum grade allowed for an entry.
Public property | ScoreThreshold | Gets score threshold.

See Also

EFaqQueryOptions Class
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Constructor

[image] [image]

IceLib Technical Reference
EFaqQueryOptions Constructor
EFaqQueryOptions Class See Also Send Feedback
Initializes a new instance of the EFaqQueryOptions class.

Overload List

 | Name | Description
Public method | EFaqQueryOptions()()()() | Initializes a new instance of the EFaqQueryOptions class.
Public method | EFaqQueryOptions(Int32, Double, Double) | Initializes a new instance of the EFaqQueryOptions class with the specified values.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Constructor

[image]

IceLib Technical Reference
EFaqQueryOptions Constructor
EFaqQueryOptions Class See Also Send Feedback
Initializes a new instance of the EFaqQueryOptions class.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqQueryOptions()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
EFaqQueryOptions Overload
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Constructor (Int32, Double, Double)

[image]

IceLib Technical Reference
EFaqQueryOptions Constructor (Int32, Double, Double)
EFaqQueryOptions Class See Also Send Feedback
Initializes a new instance of the EFaqQueryOptions class with the specified values.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqQueryOptions(
    int maximumResults,
    double minimumGrade,
    double scoreThreshold
)
Visual Basic
Public Sub New ( _
    maximumResults As Integer, _
    minimumGrade As Double, _
    scoreThreshold As Double _
)

Parameters

maximumResults
Type: System..::..Int32
The maximum results to return.
minimumGrade
Type: System..::..Double
The minimum grade.
scoreThreshold
Type: System..::..Double
The score threshold.

Remarks

Note
If entries are returned because they contain a "guaranteed hit" keyword, all of them are returned, no matter what. (So, even if the query specified only to return up to 5 entries, if 7 entries were guaranteed-hits, then 7 entries will be returned.)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
EFaqQueryOptions Overload
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Methods

[image] [image]

IceLib Technical Reference
EFaqQueryOptions Methods
EFaqQueryOptions Class See Also Send Feedback

The EFaqQueryOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

EFaqQueryOptions Class
ININ.IceLib.EFaq Namespace


ToString Method

[image]

IceLib Technical Reference
EFaqQueryOptions..::..ToString Method
EFaqQueryOptions Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
ININ.IceLib.EFaq Namespace


EFaqQueryOptions Properties

[image] [image]

IceLib Technical Reference
EFaqQueryOptions Properties
EFaqQueryOptions Class See Also Send Feedback

The EFaqQueryOptions type exposes the following members.

Properties

 | Name | Description
Public property | MaximumResults | Gets the maximum results returned per query.
Public property | MinimumGrade | Gets the minimum grade allowed for an entry.
Public property | ScoreThreshold | Gets score threshold.

See Also

EFaqQueryOptions Class
ININ.IceLib.EFaq Namespace


MaximumResults Property

[image]

IceLib Technical Reference
EFaqQueryOptions..::..MaximumResults Property
EFaqQueryOptions Class See Also Send Feedback
Gets the maximum results returned per query.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaximumResults { get; set; }
Visual Basic
Public Property MaximumResults As Integer
    Get
    Set

Field Value

The maximum results to return.

Remarks

The value must be greater than or equal to 0. Defaults to 50.

Remarks

Note
If entries are returned because they contain a "guaranteed hit" keyword, all of them are returned, no matter what. (So, even if the query specified only to return up to 5 entries, if 7 entries were guaranteed-hits, then 7 entries will be returned.)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
ININ.IceLib.EFaq Namespace


MinimumGrade Property

[image]

IceLib Technical Reference
EFaqQueryOptions..::..MinimumGrade Property
EFaqQueryOptions Class See Also Send Feedback
Gets the minimum grade allowed for an entry.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public double MinimumGrade { get; set; }
Visual Basic
Public Property MinimumGrade As Double
    Get
    Set

Field Value

The minimum grade.

Remarks

The grade of a result is used to determine how well a Question / Answer pair matches the query. Setting the minimum grade higher will generally yield fewer results. The valid range is 1.0 to 10.0. The default is 2.5.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
ININ.IceLib.EFaq Namespace
EFaqEntry..::..Grade


ScoreThreshold Property

[image]

IceLib Technical Reference
EFaqQueryOptions..::..ScoreThreshold Property
EFaqQueryOptions Class See Also Send Feedback
Gets score threshold.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public double ScoreThreshold { get; set; }
Visual Basic
Public Property ScoreThreshold As Double
    Get
    Set

Field Value

The score threshold.

Remarks

The e-FAQ engine uses the score threshold to determine how many words in a Question / Answer pair must match words from the query text. If the score threshold is 0, no matches will be cut based on this criteria. The value must be greater than or equal to 0.0. The default is 1.0. A score threshold of 2.0 is considered strict, and few results will be returned.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryOptions Class
EFaqQueryOptions Members
ININ.IceLib.EFaq Namespace


EFaqQueryResults Class

[image]

IceLib Technical Reference
EFaqQueryResults Class
Members See Also Send Feedback
The result set returned by an e-FAQ query.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqQueryResults
Visual Basic
Public Class EFaqQueryResults

Remarks

The
CopyC#
EFaqQueryResults
 class provides access to the results returned by an e-FAQ query operation. It also provides information about the results, such as the QueryOptions used, and an XML representation of the results.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.EFaq..::..EFaqQueryResults

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryResults Members
ININ.IceLib.EFaq Namespace


EFaqQueryResults Members

[image] [image]

IceLib Technical Reference
EFaqQueryResults Members
EFaqQueryResults Class Methods Properties See Also Send Feedback

The EFaqQueryResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EFaqServer | Gets the e-FAQ server that was queried.
Public property | Entries | Gets the e-FAQ entries that make up the result set.
Public property | QueryId | Gets the ID of the query that yielded these results, as assigned by the e-FAQ server.
Public property | QueryOptions | Gets the query options used to obtain these results.
Public property | QueryString | Gets the query string used to generate these results.

See Also

EFaqQueryResults Class
ININ.IceLib.EFaq Namespace


EFaqQueryResults Methods

[image] [image]

IceLib Technical Reference
EFaqQueryResults Methods
EFaqQueryResults Class See Also Send Feedback

The EFaqQueryResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqQueryResults Class
ININ.IceLib.EFaq Namespace


EFaqQueryResults Properties

[image] [image]

IceLib Technical Reference
EFaqQueryResults Properties
EFaqQueryResults Class See Also Send Feedback

The EFaqQueryResults type exposes the following members.

Properties

 | Name | Description
Public property | EFaqServer | Gets the e-FAQ server that was queried.
Public property | Entries | Gets the e-FAQ entries that make up the result set.
Public property | QueryId | Gets the ID of the query that yielded these results, as assigned by the e-FAQ server.
Public property | QueryOptions | Gets the query options used to obtain these results.
Public property | QueryString | Gets the query string used to generate these results.

See Also

EFaqQueryResults Class
ININ.IceLib.EFaq Namespace


EFaqServer Property

[image]

IceLib Technical Reference
EFaqQueryResults..::..EFaqServer Property
EFaqQueryResults Class See Also Send Feedback
Gets the e-FAQ server that was queried.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqServer EFaqServer { get; }
Visual Basic
Public ReadOnly Property EFaqServer As EFaqServer
    Get

Field Value

The e-FAQ server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryResults Class
EFaqQueryResults Members
ININ.IceLib.EFaq Namespace


Entries Property

[image]

IceLib Technical Reference
EFaqQueryResults..::..Entries Property
EFaqQueryResults Class See Also Send Feedback
Gets the e-FAQ entries that make up the result set.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<EFaqEntry> Entries { get; }
Visual Basic
Public ReadOnly Property Entries As ReadOnlyCollection(Of EFaqEntry)
    Get

Field Value

A read-only collection of the entries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryResults Class
EFaqQueryResults Members
ININ.IceLib.EFaq Namespace


QueryId Property

[image]

IceLib Technical Reference
EFaqQueryResults..::..QueryId Property
EFaqQueryResults Class See Also Send Feedback
Gets the ID of the query that yielded these results, as assigned by the e-FAQ server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long QueryId { get; }
Visual Basic
Public ReadOnly Property QueryId As Long
    Get

Field Value

The query ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryResults Class
EFaqQueryResults Members
ININ.IceLib.EFaq Namespace


QueryOptions Property

[image]

IceLib Technical Reference
EFaqQueryResults..::..QueryOptions Property
EFaqQueryResults Class See Also Send Feedback
Gets the query options used to obtain these results.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqQueryOptions QueryOptions { get; }
Visual Basic
Public ReadOnly Property QueryOptions As EFaqQueryOptions
    Get

Field Value

The query options.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryResults Class
EFaqQueryResults Members
ININ.IceLib.EFaq Namespace


QueryString Property

[image]

IceLib Technical Reference
EFaqQueryResults..::..QueryString Property
EFaqQueryResults Class See Also Send Feedback
Gets the query string used to generate these results.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string QueryString { get; }
Visual Basic
Public ReadOnly Property QueryString As String
    Get

Field Value

The query string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqQueryResults Class
EFaqQueryResults Members
ININ.IceLib.EFaq Namespace


EFaqServer Class

[image]

IceLib Technical Reference
EFaqServer Class
Members See Also Send Feedback
Represents an e-FAQ server that is in contact with the IC server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqServer
Visual Basic
Public Class EFaqServer

Remarks

The EFaqServer class provides a means to submit queries to an e-FAQ server and obtain other information about the server. The user must have the appropriate permission in order to query the server.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.EFaq..::..EFaqServer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServer Members
ININ.IceLib.EFaq Namespace


EFaqServer Members

[image] [image]

IceLib Technical Reference
EFaqServer Members
EFaqServer Class Methods Properties See Also Send Feedback

The EFaqServer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Query | Submits the specified query string to the e-FAQ server.
Public method | QueryAsync | Asynchronously submits the specified query string to the e-FAQ server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FaqTopics | Gets FAQ topics available to the user on this server.
Public property | Name | Gets name of the server.

See Also

EFaqServer Class
ININ.IceLib.EFaq Namespace


EFaqServer Methods

[image] [image]

IceLib Technical Reference
EFaqServer Methods
EFaqServer Class See Also Send Feedback

The EFaqServer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Query | Submits the specified query string to the e-FAQ server.
Public method | QueryAsync | Asynchronously submits the specified query string to the e-FAQ server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqServer Class
ININ.IceLib.EFaq Namespace


Query Method

[image]

IceLib Technical Reference
EFaqServer..::..Query Method
EFaqServer Class See Also Send Feedback
Submits the specified query string to the e-FAQ server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqQueryResults Query(
    string queryString,
    IEnumerable<EFaqTopic> faqs,
    EFaqQueryOptions options
)
Visual Basic
Public Function Query ( _
    queryString As String, _
    faqs As IEnumerable(Of EFaqTopic), _
    options As EFaqQueryOptions _
) As EFaqQueryResults

Parameters

queryString
Type: System..::..String
The query string.
faqs
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' EFaqTopic >)>)>
The faqs on the server that are to be included in the search.
options
Type: ININ.IceLib.EFaq..::..EFaqQueryOptions
The query options.

Return Value

An EFaqQueryResults object representing the result set returned by the e-FAQ server.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServer Class
EFaqServer Members
ININ.IceLib.EFaq Namespace


QueryAsync Method

[image]

IceLib Technical Reference
EFaqServer..::..QueryAsync Method
EFaqServer Class See Also Send Feedback
Asynchronously submits the specified query string to the e-FAQ server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void QueryAsync(
    string queryString,
    IEnumerable<EFaqTopic> faqs,
    EFaqQueryOptions options,
    EventHandler<EFaqQueryCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub QueryAsync ( _
    queryString As String, _
    faqs As IEnumerable(Of EFaqTopic), _
    options As EFaqQueryOptions, _
    completedCallback As EventHandler(Of EFaqQueryCompletedEventArgs), _
    userState As Object _
)

Parameters

queryString
Type: System..::..String
The query string.
faqs
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' EFaqTopic >)>)>
The faqs on the server that are to be included in the search.
options
Type: ININ.IceLib.EFaq..::..EFaqQueryOptions
The query options.
completedCallback
Type: System..::..EventHandler<(Of <(<' EFaqQueryCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServer Class
EFaqServer Members
ININ.IceLib.EFaq Namespace


EFaqServer Properties

[image] [image]

IceLib Technical Reference
EFaqServer Properties
EFaqServer Class See Also Send Feedback

The EFaqServer type exposes the following members.

Properties

 | Name | Description
Public property | FaqTopics | Gets FAQ topics available to the user on this server.
Public property | Name | Gets name of the server.

See Also

EFaqServer Class
ININ.IceLib.EFaq Namespace


FaqTopics Property

[image]

IceLib Technical Reference
EFaqServer..::..FaqTopics Property
EFaqServer Class See Also Send Feedback
Gets FAQ topics available to the user on this server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<EFaqTopic> FaqTopics { get; }
Visual Basic
Public ReadOnly Property FaqTopics As ReadOnlyCollection(Of EFaqTopic)
    Get

Field Value

The FAQ topics.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServer Class
EFaqServer Members
ININ.IceLib.EFaq Namespace


Name Property

[image]

IceLib Technical Reference
EFaqServer..::..Name Property
EFaqServer Class See Also Send Feedback
Gets name of the server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name of the server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServer Class
EFaqServer Members
ININ.IceLib.EFaq Namespace


EFaqServerList Class

[image]

IceLib Technical Reference
EFaqServerList Class
Members See Also Send Feedback
Provides information and change notifications about the e-FAQ system.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqServerList
Visual Basic
Public Class EFaqServerList

Inheritance Hierarchy

System..::..Object
ININ.IceLib.EFaq..::..EFaqServerList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Members
ININ.IceLib.EFaq Namespace


EFaqServerList Members

[image] [image]

IceLib Technical Reference
EFaqServerList Members
EFaqServerList Class Constructors Methods Properties Events See Also Send Feedback

The EFaqServerList type exposes the following members.

Constructors

 | Name | Description
Public method | EFaqServerList | Initializes a new instance of the EFaqServerList class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServers | Gets the e-Faq servers that the current user has permission to query.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for changes to the list of e-FAQ servers.
Public method | StartWatchingAsync | Asynchronously starts watching for changes to the list of e-FAQ servers.
Public method | StopWatching | Stops watching for changes to the list of e-FAQ servers.
Public method | StopWatchingAsync | Asynchonously stops watching for changes to the list of e-FAQ servers.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the EFaqServer with the specified name.

Events

 | Name | Description
Public event | ServersChanged | Occurs when a property of one or more user-accessible e-FAQ servers changes, and when an e-FAQ server is added or removed.

See Also

EFaqServerList Class
ININ.IceLib.EFaq Namespace


EFaqServerList Constructor

[image]

IceLib Technical Reference
EFaqServerList Constructor
EFaqServerList Class See Also Send Feedback
Initializes a new instance of the EFaqServerList class.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqServerList(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


EFaqServerList Methods

[image] [image]

IceLib Technical Reference
EFaqServerList Methods
EFaqServerList Class See Also Send Feedback

The EFaqServerList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetServers | Gets the e-Faq servers that the current user has permission to query.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for changes to the list of e-FAQ servers.
Public method | StartWatchingAsync | Asynchronously starts watching for changes to the list of e-FAQ servers.
Public method | StopWatching | Stops watching for changes to the list of e-FAQ servers.
Public method | StopWatchingAsync | Asynchonously stops watching for changes to the list of e-FAQ servers.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqServerList Class
ININ.IceLib.EFaq Namespace


GetServers Method

[image]

IceLib Technical Reference
EFaqServerList..::..GetServers Method
EFaqServerList Class See Also Send Feedback
Gets the e-Faq servers that the current user has permission to query.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<EFaqServer> GetServers()
Visual Basic
Public Function GetServers As ReadOnlyCollection(Of EFaqServer)

Return Value

A read-only collection of EFaqServer objects that the user has been granted access to.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch is not in progress.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


IsWatching Method

[image]

IceLib Technical Reference
EFaqServerList..::..IsWatching Method
EFaqServerList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


StartWatching Method

[image]

IceLib Technical Reference
EFaqServerList..::..StartWatching Method
EFaqServerList Class See Also Send Feedback
Starts watching for changes to the list of e-FAQ servers.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
EFaqServerList..::..StartWatchingAsync Method
EFaqServerList Class See Also Send Feedback
Asynchronously starts watching for changes to the list of e-FAQ servers.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


StopWatching Method

[image]

IceLib Technical Reference
EFaqServerList..::..StopWatching Method
EFaqServerList Class See Also Send Feedback
Stops watching for changes to the list of e-FAQ servers.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
EFaqServerList..::..StopWatchingAsync Method
EFaqServerList Class See Also Send Feedback
Asynchonously stops watching for changes to the list of e-FAQ servers.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


EFaqServerList Properties

[image] [image]

IceLib Technical Reference
EFaqServerList Properties
EFaqServerList Class See Also Send Feedback

The EFaqServerList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the EFaqServer with the specified name.

See Also

EFaqServerList Class
ININ.IceLib.EFaq Namespace


Item Property

[image]

IceLib Technical Reference
EFaqServerList..::..Item Property
EFaqServerList Class See Also Send Feedback
Gets the EFaqServer with the specified name.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqServer this[
    string serverName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    serverName As String _
) As EFaqServer
    Get

Parameters

serverName
Type: System..::..String
The name of the server.

Field Value

The e-FAQ server object for the specified server.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An argument was invalid.
ININ.IceLib..::..NotCachedException | The server is not in the cache.
System..::..InvalidOperationException | A watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


EFaqServerList Events

[image] [image]

IceLib Technical Reference
EFaqServerList Events
EFaqServerList Class See Also Send Feedback

The EFaqServerList type exposes the following members.

Events

 | Name | Description
Public event | ServersChanged | Occurs when a property of one or more user-accessible e-FAQ servers changes, and when an e-FAQ server is added or removed.

See Also

EFaqServerList Class
ININ.IceLib.EFaq Namespace


ServersChanged Event

[image]

IceLib Technical Reference
EFaqServerList..::..ServersChanged Event
EFaqServerList Class See Also Send Feedback
Occurs when a property of one or more user-accessible e-FAQ servers changes, and when an e-FAQ server is added or removed.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ObjectsChangedEventArgs<EFaqServerProperty>> ServersChanged
Visual Basic
Public Event ServersChanged As EventHandler(Of ObjectsChangedEventArgs(Of EFaqServerProperty))

Remarks

This event will only occur if the server list is being watched. To start watching the server list call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqServerList Class
EFaqServerList Members
ININ.IceLib.EFaq Namespace


EFaqServerProperty Enumeration

[image]

IceLib Technical Reference
EFaqServerProperty Enumeration
See Also Send Feedback
Each enumerated value represents a property of the EFaqServer class.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EFaqServerProperty
Visual Basic
Public Enumeration EFaqServerProperty

Members

Member name | Value | Description
None | 0 | No property.
ServerName | 1 | The server name.
FaqTopics | 2 | The list of Faq Topics (FAQs).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

ININ.IceLib.EFaq Namespace


EFaqTopic Class

[image]

IceLib Technical Reference
EFaqTopic Class
Members See Also Send Feedback
Represents a single FAQ on an e-FAQ server.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EFaqTopic
Visual Basic
Public Class EFaqTopic

Remarks

A FAQ on an e-FAQ server contains several questions and the corresponding answers. A server may have several such FAQs that may be queried.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.EFaq..::..EFaqTopic

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqTopic Members
ININ.IceLib.EFaq Namespace


EFaqTopic Members

[image] [image]

IceLib Technical Reference
EFaqTopic Members
EFaqTopic Class Methods Properties See Also Send Feedback

The EFaqTopic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the description of the FAQ.
Public property | EFaqServer | Gets the e-FAQ server with which this EFaqTopic is associated.
Public property | InsertResultsStyleSheet | Gets the insert results stylesheet location.
Public property | Name | Gets the name of the FAQ.
Public property | ResultsStyleSheet | Gets the results stylesheet location.

See Also

EFaqTopic Class
ININ.IceLib.EFaq Namespace


EFaqTopic Methods

[image] [image]

IceLib Technical Reference
EFaqTopic Methods
EFaqTopic Class See Also Send Feedback

The EFaqTopic type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EFaqTopic Class
ININ.IceLib.EFaq Namespace


Equals Method

[image]

IceLib Technical Reference
EFaqTopic..::..Equals Method
EFaqTopic Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EFaqTopic..::..GetHashCode Method
EFaqTopic Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


EFaqTopic Properties

[image] [image]

IceLib Technical Reference
EFaqTopic Properties
EFaqTopic Class See Also Send Feedback

The EFaqTopic type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the FAQ.
Public property | EFaqServer | Gets the e-FAQ server with which this EFaqTopic is associated.
Public property | InsertResultsStyleSheet | Gets the insert results stylesheet location.
Public property | Name | Gets the name of the FAQ.
Public property | ResultsStyleSheet | Gets the results stylesheet location.

See Also

EFaqTopic Class
ININ.IceLib.EFaq Namespace


Description Property

[image]

IceLib Technical Reference
EFaqTopic..::..Description Property
EFaqTopic Class See Also Send Feedback
Gets the description of the FAQ.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; internal set; }
Visual Basic
Public Property Description As String
    Get
    Friend Set

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


EFaqServer Property

[image]

IceLib Technical Reference
EFaqTopic..::..EFaqServer Property
EFaqTopic Class See Also Send Feedback
Gets the e-FAQ server with which this EFaqTopic is associated.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EFaqServer EFaqServer { get; }
Visual Basic
Public ReadOnly Property EFaqServer As EFaqServer
    Get

Field Value

The e-FAQ server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


InsertResultsStyleSheet Property

[image]

IceLib Technical Reference
EFaqTopic..::..InsertResultsStyleSheet Property
EFaqTopic Class See Also Send Feedback
Gets the insert results stylesheet location.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InsertResultsStyleSheet { get; internal set; }
Visual Basic
Public Property InsertResultsStyleSheet As String
    Get
    Friend Set

Field Value

The path to the insert results stylesheet.

Remarks

The insert results stylesheet can be used to format query results as they are inserted into another application, for example, by a copy and paste operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


Name Property

[image]

IceLib Technical Reference
EFaqTopic..::..Name Property
EFaqTopic Class See Also Send Feedback
Gets the name of the FAQ.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


ResultsStyleSheet Property

[image]

IceLib Technical Reference
EFaqTopic..::..ResultsStyleSheet Property
EFaqTopic Class See Also Send Feedback
Gets the results stylesheet location.

Namespace: ININ.IceLib.EFaq
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ResultsStyleSheet { get; internal set; }
Visual Basic
Public Property ResultsStyleSheet As String
    Get
    Friend Set

Field Value

The path to the results stylesheet.

Remarks

The results stylesheet can be used to format the results of query as they are displayed to the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 2 and beyond.

See Also

EFaqTopic Class
EFaqTopic Members
ININ.IceLib.EFaq Namespace


ININ.IceLib.Interactions Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Interactions Namespace
Send Feedback

The ININ.IceLib.Interactions namespace contains classes for manipulating Interaction Center interaction queues.

There are a number of classes within the ININ.IceLib.Interactions namespace that provide support to the classes mentioned in the preceding summary. Example of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

Queue Watches. There are a number of object classes that are used to get specific attributes for the Interactions contained in a given Interaction Queue. They are watched, meaning, that any time an attribute is changed, the internal cache of that object is kept up to date so anytime that attribute's property is referenced the current value will be returned. An event notification is available when any of the attributes changes in value.

Note
If the entire contents of an InteractionQueue is to be watched, Queue watches are more efficient than having individual Interaction watches on each Interaction in the Queue.

Interaction Watches. There are a number of object classes that are used to get specific attributes for a given Interaction. They are watched, meaning, that any time an attribute is changed, the internal cache of that object is kept up to date so anytime that attribute's property is referenced the current value will be returned. An event notification is available when any of the attributes changes in value. All such objects inherit from Interaction. Examples of Interaction classes are: CallInteraction, ChatInteraction, and EmailInteraction.

Interaction Conferences. The InteractionConference object provides information about a conference of interactions. Additionally, the InteractionQueue object provides support for watching attribute changes for Interactions within conferences contained on an interaction queue.

Note
For more information on getting started with queues and interactions see Getting Started With Interactions.

Classes

 | Class | Description
Public class | ActionParameterNames | Parameter name strings used with the PerformingActionEventArgs and PerformedActionEventArgs event argument classes.
Public class | AgentAssistanceList | This class represents a collection of assistance request items belonging to an agent.
Public class | AgentHelpRequest | Obsolete. This class represents an agent's request for help from a supervisor.
Public class | AgentHelpRequestEventArgs | Obsolete. Provides data for the AgentHelpRequested event. The AgentHelpRequest object is contained in objects of this class.
Public class | AgentHelpResponse | Obsolete. This class represents a supervisor's response to an agent's help request.
Public class | AgentHelpResponseEventArgs | Obsolete. Provides data for the AgentHelpResponseReceived event.
Public class | AssistanceItem | This class represents an Agent Assistance Request Item.
Public class | AssistanceItemChangedEventArgs | Provides data for the ItemChanged event of an AssistanceItem.
Public class | AssistanceItemMessageAddedEventArgs | Provides data for the MessageAdded event of an AssistanceItem.
Public class | AssistanceItemParticipantEventArgs | Provides data for the ParticipantAdded and ParticipantChanged event of an AssistanceItem.
Public class | AssistanceItemParticipantRemovedEventArgs | Provides data for the ParticipantRemoved event of an AssistanceItem.
Public class | AssistanceItemStateChangedEventArgs | Provides data for the StateChanged event of an AssistanceItem.
Public class | AssistanceList | This class represents the list of assistance request items that belong to an agent and/or supervisor.
Public class | AssistanceListEventArgs | Provides data for the ItemAdded/ItemRemoved events of an AssistanceList.
Public class | AssistanceListItemAddedEventArgs | Provides data for the ItemAdded event of an AssistanceList.
Public class | AssistanceMessage | Describes data associated with a message for an AssistanceItem.
Public class | AssistanceParticipant | Describes a participant associated with an AssistanceItem.
Public class | AssistanceRequestCompletedEventArgs | Provides data for the SendAssistanceRequestAsync(SendAssistanceRequestParameters, EventHandler<(Of <<'(AssistanceRequestCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | AsyncStartWatchCompletedEventArgs | Provides data for the completedCallback delegate of StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object), GetStringAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(String>)>>)>)>>), Object), GetIntegerAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object), and GetDateTimeAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(DateTime>)>>)>)>>), Object) events of a InteractionAlerting.
Public class | AttributeMonitorId | Identifies an InteractionAttributeMonitor within the Interaction Center system. InteractionAttributeMonitor has more details.
Public class | AttributesEventArgs | Provides data for the AttributesChanged event of a Interaction.
Public class | CallbackInteraction | Represents a callback interaction within the Interaction Center system. Callback interactions occur when agents call a customer in accordance with a callback request.
Public class | CallbackInteractionAttributeName | Specifies attribute names that can be used with CallbackInteractions.
Public class | CallbackInteractionParameters | Provides details when creating Callback Interactions via MakeCallbackInteraction(CallbackInteractionParameters).
Public class | CallbackSetCompletionParameters | Provides details when completing a callback via CallbackInteraction's SetCompletion method.
Public class | CallInteraction | Represents a call within the Interaction Center system.
Public class | CallInteractionParameters | Provides details when making a call via InteractionsManager's MakeCall method.
Public class | CallMadeEventArgs | Provides data for the CallMade event.
Public class | ChatInteraction | Represents a chat within the Interaction Center system.
Public class | ChatMember | Represents a member (person participating) in a ChatInteraction.
Public class | ChatMemberEventArgs | Provides data for the ChatMemberAdded/Changed/Removed events of a ChatInteraction.
Public class | ChatText | Represents a single chat entry in a ChatInteraction.
Public class | ChatUpdateEventArgs | Provides data for the ChatMemberAdded/Removed events of a ChatInteraction.
Public class | ConferenceId | Identifies a Conference within the Interaction Center system.
Public class | ConferenceInteractionAttributesEventArgs | Provides data for the ConferenceInteractionChanged event of an InteractionQueue object.
Public class | ConferenceInteractionEventArgs | Provides data for the events involving a single Interaction conference member.
Public class | ConferenceItemData | Contains information about a conference item.
Public class | ConsultTransfer | Represents a consult transfer between a caller, agent, and consult.
Public class | ConsultTransferParameters | Provides details when creating Consult Transfers via MakeConsultTransfer(ConsultTransferParameters).
Public class | EmailAddress | Represents a resolved Email address from an EmailResolver.
Public class | EmailAddressesEventArgs | Provides data for the EmailResolved event.
Public class | EmailBody | Represents an email body within an EmailContent.
Public class | EmailContent | Represents the content for an EmailInteraction.
Public class | EmailContentUpdateEventArgs | Used to notify listeners of updated email contents.
Public class | EmailCreateResponseCompletedEventArgs | Represents the completion of a CreateResponseAsync(EmailContent, EmailResponseType, EventHandler<(Of <<'(EmailCreateResponseCompletedEventArgs>)>>), Object) call.
Public class | EmailDownloadMessageAttachmentCompletedEventArgs | Represents the completion of a DownloadMessageAttachmentAsync(EmailMessageAttachment, EventHandler<(Of <<'(EmailDownloadMessageAttachmentCompletedEventArgs>)>>), Object) call.
Public class | EmailEncryptionCertificate | Definition for EmailEncryptionCertificate class.
Public class | EmailFileAttachment | Represents an attachment to an EmailInteraction.
Public class | EmailInteraction | Represents an email within the Interaction Center system.
Public class | EmailInteractionAttributeName | Specifies attribute names that can be used with EmailInteraction.
Public class | EmailInteractionParameters | Provides details when making an email via InteractionsManager's MakeEmail method.
Public class | EmailMessageAttachment | Represents a message attachment to a EmailInteraction.
Public class | EmailResolver | Allows resolving Email addresses within the Interaction Center system.
Public class | EmailSignatureCertificate | Definition for EmailSignatureCertificate class.
Public class | GenericInteraction | Represents a generic interaction object within the Interaction Center system.
Public class | GenericInteractionParameters | Provides details when creating Generic Interactions via MakeGenericInteraction(GenericInteractionParameters).
Public class | GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> | Provides data for the completedCallback delegate of GetBooleanAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Boolean>)>>)>)>>), Object), GetStringAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(String>)>>)>)>>), Object), GetIntegerAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object), and GetDateTimeAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(DateTime>)>>)>)>>), Object) events of a Interaction.
Public class | GetContentsCompletedEventArgs | Provides data for asynchronous completed events of InteractionConference and InteractionQueue.
Public class | GetStringAttributesCompletedEventArgs | Provides data for the completedCallback delegate of GetStringAttributesAsync(array<String>[]()[][], EventHandler<(Of <<'(GetStringAttributesCompletedEventArgs>)>>), Object) events of a Interaction.
Public class | HistoryItem | Contains history information for an Interaction.
Public class | InitiateSecureInputCompletedEventArgs | Provides data for the InitiateSecureInputAsync(SecureInputParameters, EventHandler<(Of <<'(InitiateSecureInputCompletedEventArgs>)>>), Object)'s completedCallback delegate of Interaction.
Public class | Interaction | Represents an Interaction within the Interaction Center system.
Public class | InteractionAlerting | This class provides information about Interactions that are alerting for the Session User.
Public class | InteractionAlertingDetails | Provides details for alerting via the InteractionAlerting class.
Public class | InteractionAlertingEventArgs | Provides data for the AlertReceived event.
Public class | InteractionAttributeMonitor | Allows attribute level monitors on the Interaction Center system.
Public class | InteractionAttributeName | Specifies attribute names that can be used with Interaction watches.
Public class | InteractionAttributesEventArgs | Provides data for the InteractionAttributesChanged event of a InteractionQueue.
Public class | InteractionCompletedEventArgs | Provides data for the asynchronous completed events of InteractionsManager.
Public class | InteractionConference | Represents a conference within the Interaction Center system.
Public class | InteractionEventArgs | Provides data for events involving a single Interaction.
Public class | InteractionId | Identifies an Interaction within the Interaction Center system.
Public class | InteractionMonitor | Represents a monitoring on an Interaction.
Public class | InteractionQueue | Represents a queue of Interactions within the Interaction Center system.
Public class | InteractionRecord | Represents a recording of an Interaction.
Public class | InteractionSegment | A segment of an Interaction.
Public class | InteractionsHistory | Provides access to interaction history information for a user.
Public class | InteractionsManager | Provides access to Interactions and InteractionQueues.
Public class | InvitePartyCompletedEventArgs | Provides data for the InvitePartyAsync(InteractionId, InvitePartyParameters, EventHandler<(Of <<'(InvitePartyCompletedEventArgs>)>>), Object) completedCallback delegate of InvitePartyAsync(InteractionId, InvitePartyParameters, EventHandler<(Of <<'(InvitePartyCompletedEventArgs>)>>), Object).
Public class | InvitePartyParameters | Provides details when inviting a party via InviteParty(InteractionId, InvitePartyParameters).
Public class | MakeCallbackInteractionCompletedEventArgs | Provides data for the MakeCallbackInteractionAsync(CallbackInteractionParameters, EventHandler<(Of <<'(MakeCallbackInteractionCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | MakeCallException | This exception is thrown by various MakeCall methods of InteractionsManager when the server is unable to make a call.
Public class | MakeChatCompletedEventArgs | Provides data for the MakeChatAsync(String, EventHandler<(Of <<'(MakeChatCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | MakeConsultTransferCompletedEventArgs | Provides data for the MakeConsultTransferAsync(ConsultTransferParameters, EventHandler<(Of <<'(MakeConsultTransferCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | MakeEmailCompletedEventArgs | Provides data for the MakeEmailAsync(EmailInteractionParameters, EventHandler<(Of <<'(MakeEmailCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | MakeGenericInteractionCompletedEventArgs | Provides data for the MakeGenericInteractionAsync(GenericInteractionParameters, EventHandler<(Of <<'(MakeGenericInteractionCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | MakeNewConferenceCompletedEventArgs | Provides data for the MakeNewConferenceAsync(array<Interaction>[]()[][], EventHandler<(Of <<'(MakeNewConferenceCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | MonitoredQueueAlerting | This class provides the main interface to enable alerting on a monitored queue.
Public class | MonitorInteraction | Represents a monitor interaction within the Interaction Center system.
Public class | MonitorInteractionAttributeName | Specifies attribute names that can be used with the MonitorInteractions class.
Public class | NotificationsSuspendedEventArgs | Provides data for the NotificationsSuspendedChanged notification.
Public class | PerformedActionEventArgs | Provides data for the PerformingAction event.
Public class | PerformingActionEventArgs | Provides data for the PerformingAction event.
Public class | PhoneNumber | Detailed information about a phone number within the Interaction Center system.
Public class | QueryPhoneNumberDetailsCompletedEventArgs | Provides data for the QueryPhoneNumberDetailsAsync(array<String>[]()[][], EventHandler<(Of <<'(QueryPhoneNumberDetailsCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.
Public class | QueueConferenceItem | Provides queue conference item details for QueueContentsChangedEventArgs.
Public class | QueueConferenceItemAttributes | Provides queue conference item details for QueueContentsChangedEventArgs.
Public class | QueueContentsChangedEventArgs | Provides data for the QueueContentsChanged event of a InteractionQueue.
Public class | QueueId | Identifies an InteractionQueue within the Interaction Center system.
Public class | QueueItem | Provides queue item details for QueueContentsChangedEventArgs.
Public class | QueueItemAttributes | Provides queue item details for QueueContentsChangedEventArgs.
Public class | RecorderInteraction | Represents a recorder interaction within the Interaction Center system.
Public class | RecorderInteractionAttributeName | Specifies attribute names that can be used with RecorderInteractions.
Public class | RecordingSnippetCreatedEventArgs | Provides data for the RecordingSnippetCreated event of a Interaction.
Public class | RelatedSnippetRecording | Represents a related snippet recording of an Interaction.
Public class | ScreenPop | This class serves as the main interface for tracking when DDE screen pops occur.
Public class | ScreenPopEventArgs | Provides data for the screen pop events of ScreenPop.
Public class | ScreenPopItem | This class contains the ScreenPop event data.
Public class | SecureInputParameters | Provides details when initiating secure input via the InitiateSecureInput(SecureInputParameters) method.
Public class | SecureRecordingPauseParameters | Provides a mechanism to pass secure recording pause parameters. Used in SecureRecordingPause(SecureRecordingPauseParameters) and SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object).
Public class | SendAssistanceRequestParameters | Provides details when sending an assistance request via SendAssistanceRequest(SendAssistanceRequestParameters).
Public class | SensitiveAttributeDataContext | Provides access to the Session's sensitive data context for Interaction attributes.
Public class | SocialConversationInteraction | SocialConversationInteraction - Social Conversation Interactions are handled here
Public class | SocialDirectMessageInteraction | Represents Social Direct Message within the Interaction Center system.
Public class | SupervisorAssistanceList | This class represents a collection of assistance request items belonging to a supervisor.
Public class | WrapUpAssignment | Representation of an assignment of a wrap-up code to a segment of an interaction.

Enumerations

 | Enumeration | Description
Public enumeration | AssistanceItemState | Defines the states for an AssistanceItem.
Public enumeration | AssistanceParticipantAction | Describes the action of an AssistanceParticipant in regards to an AssistanceItem.
Public enumeration | CallAnalysisType | Used to specify if analysis needs to be performed on a call.
Public enumeration | CallbackCompletion | Specifies constants indicating the completion of a CallbackInteraction.
Public enumeration | CallMadeStage | Specifies constants indicating when the CallMade event should be raised.
Public enumeration | ChatMemberType | Specifies constants indicating the whether a ChatMember is internal or external.
Public enumeration | ConsultTransferParticipants | The participants in a ConsultTransfer.
Public enumeration | EmailCloneAttachmentType | Determines what attachments from the source email to include when an EmailContent object is cloned.
Public enumeration | EmailEncryptionStatus | Possible encryption status of an EmailInteraction.
Public enumeration | EmailInteractionCapabilities | Specifies constants indicating the capabilities of an EmailInteraction.
Public enumeration | EmailPriority | The priority of an e-mail.
Public enumeration | EmailResponseType | Specifies constants indicating the response type of an EmailInteraction.
Public enumeration | EmailSignatureStatus | Possible status of an DigitalSignatures.
Public enumeration | HistoryItemFlags | An set of flags to indicate the status of the interaction.
Public enumeration | HistoryItemProperty | Each value in the enumeration represents a property of HistoryItem.
Public enumeration | InteractionAlertAction | Indicates the action that needs to be taken when an alert event is received.
Public enumeration | InteractionAlertType | Represents the reason why an interaction is alerting.
Public enumeration | InteractionCallPartyType | Specifies constants indicating the party type of a call.
Public enumeration | InteractionCallType | Specifies constants indicating the call type.
Public enumeration | InteractionCapabilities | Specifies constants indicating the capabilities of an Interaction.
Public enumeration | InteractionDirection | Specifies constants indicating the direction of an Interaction.
Public enumeration | InteractionMonitorType | Specifies constants indicating the type of an Interaction monitor.
Public enumeration | InteractionPartyType | Represents local party type and remote party type of an interaction.
Public enumeration | InteractionSecurityLevel | Specifies constants indicating the security level of an Interaction.
Public enumeration | InteractionState | Specifies constants indicating the state of an Interaction.
Public enumeration | InteractionType | Specifies constants indicating the type of an Interaction.
Public enumeration | IsdnCauseCode | ISDN Cause Codes that may have been returned when placing a call.
Public enumeration | MakeCallFailureCode | Call failure codes describing the results of an attempt to place a call.
Public enumeration | MonitoredQueueAlertMode | Specifies if an alert should be a silent alert or not.
Public enumeration | QueueType | Specifies constants indicating the type of an InteractionQueue.
Public enumeration | SecureRecordingPauseAction | Specifies the secure recording pause action that should be taken.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


ActionParameterNames Class

[image]

IceLib Technical Reference
ActionParameterNames Class
Members See Also Send Feedback
Parameter name strings used with the PerformingActionEventArgs and PerformedActionEventArgs event argument classes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class ActionParameterNames
Visual Basic
Public NotInheritable Class ActionParameterNames

Remarks

The parameter names specified in this class are used in conjunction with the ActionParameters and ActionParameters dictionary properties. These keys can be used to access the data originally passed into the method that caused each event to be raised.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ActionParameterNames

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionParameterNames Members
ININ.IceLib.Interactions Namespace


ActionParameterNames Members

[image] [image]

IceLib Technical Reference
ActionParameterNames Members
ActionParameterNames Class Fields See Also Send Feedback

The ActionParameterNames type exposes the following members.

Fields

Name | Description
ConsultId | The InteractionId of the Interaction representing the consult transfer target.
Message | The user message entered when requesting assistance.
On | Specifies whether an action is being turned on or off.
Supervisor | Specifies whether an action is being performed in a supervisory manner or not.
Target | The target of an action.

See Also

ActionParameterNames Class
ININ.IceLib.Interactions Namespace


ActionParameterNames Fields

[image] [image]

IceLib Technical Reference
ActionParameterNames Fields
ActionParameterNames Class See Also Send Feedback

The ActionParameterNames type exposes the following members.

Fields

Name | Description
ConsultId | The InteractionId of the Interaction representing the consult transfer target.
Message | The user message entered when requesting assistance.
On | Specifies whether an action is being turned on or off.
Supervisor | Specifies whether an action is being performed in a supervisory manner or not.
Target | The target of an action.

See Also

ActionParameterNames Class
ININ.IceLib.Interactions Namespace


ConsultId Field

[image]

IceLib Technical Reference
ActionParameterNames..::..ConsultId Field
ActionParameterNames Class See Also Send Feedback
The InteractionId of the Interaction representing the consult transfer target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ConsultId
Visual Basic
Public Shared ReadOnly ConsultId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionParameterNames Class
ActionParameterNames Members
ININ.IceLib.Interactions Namespace


Message Field

[image]

IceLib Technical Reference
ActionParameterNames..::..Message Field
ActionParameterNames Class See Also Send Feedback
The user message entered when requesting assistance.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Message
Visual Basic
Public Shared ReadOnly Message As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionParameterNames Class
ActionParameterNames Members
ININ.IceLib.Interactions Namespace


On Field

[image]

IceLib Technical Reference
ActionParameterNames..::..On Field
ActionParameterNames Class See Also Send Feedback
Specifies whether an action is being turned on or off.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string On
Visual Basic
Public Shared ReadOnly On As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionParameterNames Class
ActionParameterNames Members
ININ.IceLib.Interactions Namespace


Supervisor Field

[image]

IceLib Technical Reference
ActionParameterNames..::..Supervisor Field
ActionParameterNames Class See Also Send Feedback
Specifies whether an action is being performed in a supervisory manner or not.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Supervisor
Visual Basic
Public Shared ReadOnly Supervisor As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionParameterNames Class
ActionParameterNames Members
ININ.IceLib.Interactions Namespace


Target Field

[image]

IceLib Technical Reference
ActionParameterNames..::..Target Field
ActionParameterNames Class See Also Send Feedback
The target of an action.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Target
Visual Basic
Public Shared ReadOnly Target As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ActionParameterNames Class
ActionParameterNames Members
ININ.IceLib.Interactions Namespace


AgentAssistanceList Class

[image]

IceLib Technical Reference
AgentAssistanceList Class
Members See Also Send Feedback
This class represents a collection of assistance request items belonging to an agent.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AgentAssistanceList : AssistanceList
Visual Basic
Public Class AgentAssistanceList _
    Inherits AssistanceList

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AssistanceList
ININ.IceLib.Interactions..::..AgentAssistanceList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AgentAssistanceList Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..AssistanceList


AgentAssistanceList Members

[image] [image]

IceLib Technical Reference
AgentAssistanceList Members
AgentAssistanceList Class Constructors Methods Properties Events See Also Send Feedback

The AgentAssistanceList type exposes the following members.

Constructors

 | Name | Description
Public method | AgentAssistanceList | Initializes a new instance of the AgentAssistanceList class.

Methods

 | Name | Description
Public method | Accept | Accepts an assistance request. (Inherited from AssistanceList.)
Public method | AcceptAsync | Asynchronously accepts an assistance request. (Inherited from AssistanceList.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssistanceRequests | Gets the list of assistance request items associated with this list. (Inherited from AssistanceList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Ignore | Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IgnoreAsync | Asynchronously Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IsWatching | Determines whether a watch is active. (Inherited from AssistanceList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatching | Stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets an assistance request item with the associated ID. (Inherited from AssistanceList.)

Events

 | Name | Description
Public event | ItemAdded | Event that occurs when a new assistance item is added to the assistance list. (Inherited from AssistanceList.)
Public event | ItemRemoved | Event that occurs when an assistance item is removed from the assistance list. (Inherited from AssistanceList.)
Public event | ItemStateChanged | Event that occurs when an assistance item's state changes in the assistance list. (Inherited from AssistanceList.)

See Also

AgentAssistanceList Class
ININ.IceLib.Interactions Namespace


AgentAssistanceList Constructor

[image]

IceLib Technical Reference
AgentAssistanceList Constructor
AgentAssistanceList Class See Also Send Feedback
Initializes a new instance of the AgentAssistanceList class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AgentAssistanceList(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AgentAssistanceList Class
AgentAssistanceList Members
ININ.IceLib.Interactions Namespace


AgentAssistanceList Methods

[image] [image]

IceLib Technical Reference
AgentAssistanceList Methods
AgentAssistanceList Class See Also Send Feedback

The AgentAssistanceList type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts an assistance request. (Inherited from AssistanceList.)
Public method | AcceptAsync | Asynchronously accepts an assistance request. (Inherited from AssistanceList.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssistanceRequests | Gets the list of assistance request items associated with this list. (Inherited from AssistanceList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Ignore | Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IgnoreAsync | Asynchronously Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IsWatching | Determines whether a watch is active. (Inherited from AssistanceList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatching | Stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentAssistanceList Class
ININ.IceLib.Interactions Namespace


AgentAssistanceList Properties

[image] [image]

IceLib Technical Reference
AgentAssistanceList Properties
AgentAssistanceList Class See Also Send Feedback

The AgentAssistanceList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets an assistance request item with the associated ID. (Inherited from AssistanceList.)

See Also

AgentAssistanceList Class
ININ.IceLib.Interactions Namespace


AgentAssistanceList Events

[image] [image]

IceLib Technical Reference
AgentAssistanceList Events
AgentAssistanceList Class See Also Send Feedback

The AgentAssistanceList type exposes the following members.

Events

 | Name | Description
Public event | ItemAdded | Event that occurs when a new assistance item is added to the assistance list. (Inherited from AssistanceList.)
Public event | ItemRemoved | Event that occurs when an assistance item is removed from the assistance list. (Inherited from AssistanceList.)
Public event | ItemStateChanged | Event that occurs when an assistance item's state changes in the assistance list. (Inherited from AssistanceList.)

See Also

AgentAssistanceList Class
ININ.IceLib.Interactions Namespace


AgentHelpRequest Class

[image]

IceLib Technical Reference
AgentHelpRequest Class
Members See Also Send Feedback
This class represents an agent's request for help from a supervisor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AgentHelpRequest is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequest instead.")]
public class AgentHelpRequest
Visual Basic
<ObsoleteAttribute("AgentHelpRequest is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequest instead.")> _
Public Class AgentHelpRequest

Remarks

Agents sometimes need to obtain help with an interaction. For example, an agent might request help when a caller asks a question that the agent cannot answer.

When the request is sent, all supervisors of the workgroup from which the call originated receive an assistance request stating that the agent needs help. When one supervisor accepts the assistance request, the request is automatically dismissed from all other supervisors' IC systems.

Objects of this class contain data about an a agent's help request. These data items (agent, problem description, station, extension, etc.) are sent to the supervisor and are returned in the AgentHelpResponse object when the supervisor responds.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AgentHelpRequest

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


AgentHelpRequest Members

[image] [image]

IceLib Technical Reference
AgentHelpRequest Members
AgentHelpRequest Class Constructors Methods Properties See Also Send Feedback

The AgentHelpRequest type exposes the following members.

Constructors

 | Name | Description
Public method | AgentHelpRequest | Initializes a new instance of the AgentHelpRequest class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Agent | Gets the agent.
Public property | Extension | Gets the extension.
Public property | InteractionId | Gets the interaction ID.
Public property | ProblemDescription | Gets the problem description.
Public property | Station | Gets the station.
Public property | Workgroup | Gets the workgroup.

See Also

AgentHelpRequest Class
ININ.IceLib.Interactions Namespace


AgentHelpRequest Constructor

[image]

IceLib Technical Reference
AgentHelpRequest Constructor
AgentHelpRequest Class See Also Send Feedback
Initializes a new instance of the AgentHelpRequest class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AgentHelpRequest(
    string workgroup,
    string agent,
    string station,
    string extension,
    string problemDescription,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    workgroup As String, _
    agent As String, _
    station As String, _
    extension As String, _
    problemDescription As String, _
    interactionId As InteractionId _
)

Parameters

workgroup
Type: System..::..String
The workgroup.
agent
Type: System..::..String
The agent.
station
Type: System..::..String
The station.
extension
Type: System..::..String
The extension.
problemDescription
Type: System..::..String
The problem description.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


AgentHelpRequest Methods

[image] [image]

IceLib Technical Reference
AgentHelpRequest Methods
AgentHelpRequest Class See Also Send Feedback

The AgentHelpRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentHelpRequest Class
ININ.IceLib.Interactions Namespace


AgentHelpRequest Properties

[image] [image]

IceLib Technical Reference
AgentHelpRequest Properties
AgentHelpRequest Class See Also Send Feedback

The AgentHelpRequest type exposes the following members.

Properties

 | Name | Description
Public property | Agent | Gets the agent.
Public property | Extension | Gets the extension.
Public property | InteractionId | Gets the interaction ID.
Public property | ProblemDescription | Gets the problem description.
Public property | Station | Gets the station.
Public property | Workgroup | Gets the workgroup.

See Also

AgentHelpRequest Class
ININ.IceLib.Interactions Namespace


Agent Property

[image]

IceLib Technical Reference
AgentHelpRequest..::..Agent Property
AgentHelpRequest Class See Also Send Feedback
Gets the agent.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Agent { get; }
Visual Basic
Public ReadOnly Property Agent As String
    Get

Field Value

The agent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


Extension Property

[image]

IceLib Technical Reference
AgentHelpRequest..::..Extension Property
AgentHelpRequest Class See Also Send Feedback
Gets the extension.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
AgentHelpRequest..::..InteractionId Property
AgentHelpRequest Class See Also Send Feedback
Gets the interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


ProblemDescription Property

[image]

IceLib Technical Reference
AgentHelpRequest..::..ProblemDescription Property
AgentHelpRequest Class See Also Send Feedback
Gets the problem description.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProblemDescription { get; }
Visual Basic
Public ReadOnly Property ProblemDescription As String
    Get

Field Value

The problem description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


Station Property

[image]

IceLib Technical Reference
AgentHelpRequest..::..Station Property
AgentHelpRequest Class See Also Send Feedback
Gets the station.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Station { get; }
Visual Basic
Public ReadOnly Property Station As String
    Get

Field Value

The station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


Workgroup Property

[image]

IceLib Technical Reference
AgentHelpRequest..::..Workgroup Property
AgentHelpRequest Class See Also Send Feedback
Gets the workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; }
Visual Basic
Public ReadOnly Property Workgroup As String
    Get

Field Value

The workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequest Class
AgentHelpRequest Members
ININ.IceLib.Interactions Namespace


AgentHelpRequestEventArgs Class

[image]

IceLib Technical Reference
AgentHelpRequestEventArgs Class
Members See Also Send Feedback
Provides data for the AgentHelpRequested event. The AgentHelpRequest object is contained in objects of this class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AgentHelpRequest is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequest instead.")]
public class AgentHelpRequestEventArgs : EventArgs
Visual Basic
<ObsoleteAttribute("AgentHelpRequest is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequest instead.")> _
Public Class AgentHelpRequestEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AgentHelpRequestEventArgs
ININ.IceLib.Interactions..::..AgentHelpResponseEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequestEventArgs Members
ININ.IceLib.Interactions Namespace


AgentHelpRequestEventArgs Members

[image] [image]

IceLib Technical Reference
AgentHelpRequestEventArgs Members
AgentHelpRequestEventArgs Class Constructors Methods Properties See Also Send Feedback

The AgentHelpRequestEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AgentHelpRequestEventArgs | Initializes a new instance of the AgentHelpRequestEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AgentHelpRequest | Gets the agent help request.

See Also

AgentHelpRequestEventArgs Class
ININ.IceLib.Interactions Namespace


AgentHelpRequestEventArgs Constructor

[image]

IceLib Technical Reference
AgentHelpRequestEventArgs Constructor
AgentHelpRequestEventArgs Class See Also Send Feedback
Initializes a new instance of the AgentHelpRequestEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AgentHelpRequestEventArgs(
    AgentHelpRequest agentHelpRequest
)
Visual Basic
Public Sub New ( _
    agentHelpRequest As AgentHelpRequest _
)

Parameters

agentHelpRequest
Type: ININ.IceLib.Interactions..::..AgentHelpRequest
The agent help request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequestEventArgs Class
AgentHelpRequestEventArgs Members
ININ.IceLib.Interactions Namespace


AgentHelpRequestEventArgs Methods

[image] [image]

IceLib Technical Reference
AgentHelpRequestEventArgs Methods
AgentHelpRequestEventArgs Class See Also Send Feedback

The AgentHelpRequestEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentHelpRequestEventArgs Class
ININ.IceLib.Interactions Namespace


AgentHelpRequestEventArgs Properties

[image] [image]

IceLib Technical Reference
AgentHelpRequestEventArgs Properties
AgentHelpRequestEventArgs Class See Also Send Feedback

The AgentHelpRequestEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AgentHelpRequest | Gets the agent help request.

See Also

AgentHelpRequestEventArgs Class
ININ.IceLib.Interactions Namespace


AgentHelpRequest Property

[image]

IceLib Technical Reference
AgentHelpRequestEventArgs..::..AgentHelpRequest Property
AgentHelpRequestEventArgs Class See Also Send Feedback
Gets the agent help request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AgentHelpRequest AgentHelpRequest { get; }
Visual Basic
Public ReadOnly Property AgentHelpRequest As AgentHelpRequest
    Get

Field Value

The agent help request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpRequestEventArgs Class
AgentHelpRequestEventArgs Members
ININ.IceLib.Interactions Namespace


AgentHelpResponse Class

[image]

IceLib Technical Reference
AgentHelpResponse Class
Members See Also Send Feedback
This class represents a supervisor's response to an agent's help request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AgentHelpResponse is no longer used.  Use AgentAssistanceList and SupervisorAssistanceList instead.")]
public class AgentHelpResponse
Visual Basic
<ObsoleteAttribute("AgentHelpResponse is no longer used.  Use AgentAssistanceList and SupervisorAssistanceList instead.")> _
Public Class AgentHelpResponse

Remarks

This class provides support for sending a response to an agent's supervisor help request.

To send a response to a help request call SendResponse(AgentHelpRequest, Boolean, String) or SendResponseAsync(AgentHelpRequest, Boolean, String, AsyncCompletedEventHandler, Object) providing the AgentHelpRequest object and a flag indicating whether the supervisor will help. When the asynchronous send-response operation completes, it invokes the completedCallback delegate.

Note
The asynchronous version of the method is preferred since sending a response can be a lengthy operation.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AgentHelpResponse

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


AgentHelpResponse Members

[image] [image]

IceLib Technical Reference
AgentHelpResponse Members
AgentHelpResponse Class Constructors Methods Properties Events See Also Send Feedback

The AgentHelpResponse type exposes the following members.

Constructors

 | Name | Description
Public method | AgentHelpResponse | Initializes a new instance of the AgentHelpResponse class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendResponse | Sends a response to an AgentHelpRequest.
Public method | SendResponseAsync | Asynchronously sends a response to an AgentHelpRequest.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated.

Events

 | Name | Description
Public event | AgentHelpRequested | Occurs when an Agent requests help.
Public event | AgentHelpResponseReceived | Occurs when an Agent help request is answered.

See Also

AgentHelpResponse Class
ININ.IceLib.Interactions Namespace


AgentHelpResponse Constructor

[image]

IceLib Technical Reference
AgentHelpResponse Constructor
AgentHelpResponse Class See Also Send Feedback
Initializes a new instance of the AgentHelpResponse class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AgentHelpResponse(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Class
AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


AgentHelpResponse Methods

[image] [image]

IceLib Technical Reference
AgentHelpResponse Methods
AgentHelpResponse Class See Also Send Feedback

The AgentHelpResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendResponse | Sends a response to an AgentHelpRequest.
Public method | SendResponseAsync | Asynchronously sends a response to an AgentHelpRequest.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentHelpResponse Class
ININ.IceLib.Interactions Namespace


SendResponse Method

[image]

IceLib Technical Reference
AgentHelpResponse..::..SendResponse Method
AgentHelpResponse Class See Also Send Feedback
Sends a response to an AgentHelpRequest.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendResponse(
    AgentHelpRequest agentHelpRequest,
    bool willHelp,
    string response
)
Visual Basic
Public Sub SendResponse ( _
    agentHelpRequest As AgentHelpRequest, _
    willHelp As Boolean, _
    response As String _
)

Parameters

agentHelpRequest
Type: ININ.IceLib.Interactions..::..AgentHelpRequest
The agent help request.
willHelp
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) will help.
response
Type: System..::..String
The response, if one is provided.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Class
AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


SendResponseAsync Method

[image]

IceLib Technical Reference
AgentHelpResponse..::..SendResponseAsync Method
AgentHelpResponse Class See Also Send Feedback
Asynchronously sends a response to an AgentHelpRequest.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendResponseAsync(
    AgentHelpRequest agentHelpRequest,
    bool willHelp,
    string response,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SendResponseAsync ( _
    agentHelpRequest As AgentHelpRequest, _
    willHelp As Boolean, _
    response As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

agentHelpRequest
Type: ININ.IceLib.Interactions..::..AgentHelpRequest
The agent help request.
willHelp
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) will help.
response
Type: System..::..String
The response, if one is provided.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Class
AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


AgentHelpResponse Properties

[image] [image]

IceLib Technical Reference
AgentHelpResponse Properties
AgentHelpResponse Class See Also Send Feedback

The AgentHelpResponse type exposes the following members.

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated.

See Also

AgentHelpResponse Class
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
AgentHelpResponse..::..InteractionsManager Property
AgentHelpResponse Class See Also Send Feedback
Gets the InteractionManager with which this Interaction is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Class
AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


AgentHelpResponse Events

[image] [image]

IceLib Technical Reference
AgentHelpResponse Events
AgentHelpResponse Class See Also Send Feedback

The AgentHelpResponse type exposes the following members.

Events

 | Name | Description
Public event | AgentHelpRequested | Occurs when an Agent requests help.
Public event | AgentHelpResponseReceived | Occurs when an Agent help request is answered.

See Also

AgentHelpResponse Class
ININ.IceLib.Interactions Namespace


AgentHelpRequested Event

[image]

IceLib Technical Reference
AgentHelpResponse..::..AgentHelpRequested Event
AgentHelpResponse Class See Also Send Feedback
Occurs when an Agent requests help.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AgentHelpRequestEventArgs> AgentHelpRequested
Visual Basic
Public Event AgentHelpRequested As EventHandler(Of AgentHelpRequestEventArgs)

Remarks

This event will only occur while the Session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Class
AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


AgentHelpResponseReceived Event

[image]

IceLib Technical Reference
AgentHelpResponse..::..AgentHelpResponseReceived Event
AgentHelpResponse Class See Also Send Feedback
Occurs when an Agent help request is answered.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AgentHelpResponseEventArgs> AgentHelpResponseReceived
Visual Basic
Public Event AgentHelpResponseReceived As EventHandler(Of AgentHelpResponseEventArgs)

Remarks

This event will only occur while the Session is connected. (See Connect(SessionSettings, HostSettings, AuthSettings, StationSettings) or ConnectAsync(SessionSettings, HostSettings, AuthSettings, StationSettings, AsyncCompletedEventHandler, Object).)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponse Class
AgentHelpResponse Members
ININ.IceLib.Interactions Namespace


AgentHelpResponseEventArgs Class

[image]

IceLib Technical Reference
AgentHelpResponseEventArgs Class
Members See Also Send Feedback
Provides data for the AgentHelpResponseReceived event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("AgentHelpResponse is no longer used.  Use AgentAssistanceList and SupervisorAssistanceList instead.")]
public class AgentHelpResponseEventArgs : AgentHelpRequestEventArgs
Visual Basic
<ObsoleteAttribute("AgentHelpResponse is no longer used.  Use AgentAssistanceList and SupervisorAssistanceList instead.")> _
Public Class AgentHelpResponseEventArgs _
    Inherits AgentHelpRequestEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AgentHelpRequestEventArgs
ININ.IceLib.Interactions..::..AgentHelpResponseEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponseEventArgs Members
ININ.IceLib.Interactions Namespace


AgentHelpResponseEventArgs Members

[image] [image]

IceLib Technical Reference
AgentHelpResponseEventArgs Members
AgentHelpResponseEventArgs Class Constructors Methods Properties See Also Send Feedback

The AgentHelpResponseEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AgentHelpResponseEventArgs | Initializes a new instance of the AgentHelpRequestEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AgentHelpRequest | Gets the agent help request. (Inherited from AgentHelpRequestEventArgs.)
Public property | Responder | Gets the responder.
Public property | Response | Gets the response.
Public property | WillHelp | Gets a value indicating whether the supervisor will provide help.

See Also

AgentHelpResponseEventArgs Class
ININ.IceLib.Interactions Namespace


AgentHelpResponseEventArgs Constructor

[image]

IceLib Technical Reference
AgentHelpResponseEventArgs Constructor
AgentHelpResponseEventArgs Class See Also Send Feedback
Initializes a new instance of the AgentHelpRequestEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AgentHelpResponseEventArgs(
    AgentHelpRequest agentHelpRequest,
    string responder,
    bool willHelp,
    string response
)
Visual Basic
Public Sub New ( _
    agentHelpRequest As AgentHelpRequest, _
    responder As String, _
    willHelp As Boolean, _
    response As String _
)

Parameters

agentHelpRequest
Type: ININ.IceLib.Interactions..::..AgentHelpRequest
The agent help request.
responder
Type: System..::..String
The responder.
willHelp
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) will help.
response
Type: System..::..String
The response.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponseEventArgs Class
AgentHelpResponseEventArgs Members
ININ.IceLib.Interactions Namespace


AgentHelpResponseEventArgs Methods

[image] [image]

IceLib Technical Reference
AgentHelpResponseEventArgs Methods
AgentHelpResponseEventArgs Class See Also Send Feedback

The AgentHelpResponseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentHelpResponseEventArgs Class
ININ.IceLib.Interactions Namespace


AgentHelpResponseEventArgs Properties

[image] [image]

IceLib Technical Reference
AgentHelpResponseEventArgs Properties
AgentHelpResponseEventArgs Class See Also Send Feedback

The AgentHelpResponseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AgentHelpRequest | Gets the agent help request. (Inherited from AgentHelpRequestEventArgs.)
Public property | Responder | Gets the responder.
Public property | Response | Gets the response.
Public property | WillHelp | Gets a value indicating whether the supervisor will provide help.

See Also

AgentHelpResponseEventArgs Class
ININ.IceLib.Interactions Namespace


Responder Property

[image]

IceLib Technical Reference
AgentHelpResponseEventArgs..::..Responder Property
AgentHelpResponseEventArgs Class See Also Send Feedback
Gets the responder.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Responder { get; }
Visual Basic
Public ReadOnly Property Responder As String
    Get

Field Value

The responder.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponseEventArgs Class
AgentHelpResponseEventArgs Members
ININ.IceLib.Interactions Namespace


Response Property

[image]

IceLib Technical Reference
AgentHelpResponseEventArgs..::..Response Property
AgentHelpResponseEventArgs Class See Also Send Feedback
Gets the response.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Response { get; }
Visual Basic
Public ReadOnly Property Response As String
    Get

Field Value

The response.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponseEventArgs Class
AgentHelpResponseEventArgs Members
ININ.IceLib.Interactions Namespace


WillHelp Property

[image]

IceLib Technical Reference
AgentHelpResponseEventArgs..::..WillHelp Property
AgentHelpResponseEventArgs Class See Also Send Feedback
Gets a value indicating whether the supervisor will provide help.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool WillHelp { get; }
Visual Basic
Public ReadOnly Property WillHelp As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if will provide help; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AgentHelpResponseEventArgs Class
AgentHelpResponseEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItem Class

[image]

IceLib Technical Reference
AssistanceItem Class
Members See Also Send Feedback
This class represents an Agent Assistance Request Item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceItem
Visual Basic
Public Class AssistanceItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AssistanceItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Members
ININ.IceLib.Interactions Namespace


AssistanceItem Members

[image] [image]

IceLib Technical Reference
AssistanceItem Members
AssistanceItem Class Methods Properties Events See Also Send Feedback

The AssistanceItem type exposes the following members.

Methods

 | Name | Description
Public method | Complete | Completes the assistance request.
Public method | CompleteAsync | Asynchronously completes the assistance request.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendMessage | Sends a message to the assistance request.
Public method | SendMessageAsync | Asynchronously sends a message to the assistance request.
Public method | StartWatching | Starts watching the AssistanceItem.
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceItem.
Public method | StopWatching | Stops watching the AssistanceItem.
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceItem.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the ID of the assistance request.
Public property | Extension | Gets the agent's extension.
Public property | InitiatingUser | Gets the participant that initiated the assistance request.
Public property | InitiationTime | Gets the date and time the assistance request was initiated.
Public property | InteractionId | Gets the interaction ID associated with the assistance request.
Public property | Messages | Gets the messages associated with the assistance request.
Public property | Participants | Gets the participants involved in the assistance request.
Public property | ProblemDescription | Gets the problem description for the assistance request.
Public property | State | Gets the state of the assistance request.
Public property | Station | Gets the agent's station.
Public property | Workgroup | Gets the workgroup that the assistance request belongs to.

Events

Name Description
Public event ItemChanged
Event that occurs when the assistance request changes.
Note
This event will be invoked on the resulting AssistanceItem for the first time after a call to SendAssistanceRequest(SendAssistanceRequestParameters).
Public event MessageAdded
Event that occurs when a new message is added to the assistance request.
Public event ParticipantAdded
Event that occurs when a new participant becomes involved in the assistance request.
Public event ParticipantChanged
Event that occurs when a participant's action changes.
Public event ParticipantRemoved
Event that occurs when a participant is no longer involved in the assistance request.
Public event StateChanged
Event that occurs when the state of the assistance request changes.

See Also

AssistanceItem Class
ININ.IceLib.Interactions Namespace


AssistanceItem Methods

[image] [image]

IceLib Technical Reference
AssistanceItem Methods
AssistanceItem Class See Also Send Feedback

The AssistanceItem type exposes the following members.

Methods

 | Name | Description
Public method | Complete | Completes the assistance request.
Public method | CompleteAsync | Asynchronously completes the assistance request.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendMessage | Sends a message to the assistance request.
Public method | SendMessageAsync | Asynchronously sends a message to the assistance request.
Public method | StartWatching | Starts watching the AssistanceItem.
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceItem.
Public method | StopWatching | Stops watching the AssistanceItem.
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceItem.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceItem Class
ININ.IceLib.Interactions Namespace


Complete Method

[image]

IceLib Technical Reference
AssistanceItem..::..Complete Method
AssistanceItem Class See Also Send Feedback
Completes the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Complete()
Visual Basic
Public Sub Complete

Exceptions

Exception | Condition
System..::..InvalidOperationException | The state of the assistance request is already Completed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


CompleteAsync Method

[image]

IceLib Technical Reference
AssistanceItem..::..CompleteAsync Method
AssistanceItem Class See Also Send Feedback
Asynchronously completes the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CompleteAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CompleteAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The state of the assistance request is already Completed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
AssistanceItem..::..IsWatching Method
AssistanceItem Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


SendMessage Method

[image]

IceLib Technical Reference
AssistanceItem..::..SendMessage Method
AssistanceItem Class See Also Send Feedback
Sends a message to the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendMessage(
    string message
)
Visual Basic
Public Sub SendMessage ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message to send.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


SendMessageAsync Method

[image]

IceLib Technical Reference
AssistanceItem..::..SendMessageAsync Method
AssistanceItem Class See Also Send Feedback
Asynchronously sends a message to the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendMessageAsync(
    string message,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendMessageAsync ( _
    message As String, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

message
Type: System..::..String
The message to send.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
AssistanceItem..::..StartWatching Method
AssistanceItem Class See Also Send Feedback
Starts watching the AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is already being watched or cannot perform this operation on the AssistanceItem.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
AssistanceItem..::..StartWatchingAsync Method
AssistanceItem Class See Also Send Feedback
Asynchronously starts watching the AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched or cannot perform this operation on the AssistanceItem.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
AssistanceItem..::..StopWatching Method
AssistanceItem Class See Also Send Feedback
Stops watching the AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

StopWatching()()()() or StopWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched or cannot perform this operation on the AssistanceItem.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
AssistanceItem..::..StopWatchingAsync Method
AssistanceItem Class See Also Send Feedback
Asynchronously stops watching the AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

StopWatching()()()() or StopWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched or cannot perform this operation on the AssistanceItem.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceItem..::..ToString Method
AssistanceItem Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


AssistanceItem Properties

[image] [image]

IceLib Technical Reference
AssistanceItem Properties
AssistanceItem Class See Also Send Feedback

The AssistanceItem type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the ID of the assistance request.
Public property | Extension | Gets the agent's extension.
Public property | InitiatingUser | Gets the participant that initiated the assistance request.
Public property | InitiationTime | Gets the date and time the assistance request was initiated.
Public property | InteractionId | Gets the interaction ID associated with the assistance request.
Public property | Messages | Gets the messages associated with the assistance request.
Public property | Participants | Gets the participants involved in the assistance request.
Public property | ProblemDescription | Gets the problem description for the assistance request.
Public property | State | Gets the state of the assistance request.
Public property | Station | Gets the agent's station.
Public property | Workgroup | Gets the workgroup that the assistance request belongs to.

See Also

AssistanceItem Class
ININ.IceLib.Interactions Namespace


AssistanceItemId Property

[image]

IceLib Technical Reference
AssistanceItem..::..AssistanceItemId Property
AssistanceItem Class See Also Send Feedback
Gets the ID of the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistanceItemId { get; internal set; }
Visual Basic
Public Property AssistanceItemId As String
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


Extension Property

[image]

IceLib Technical Reference
AssistanceItem..::..Extension Property
AssistanceItem Class See Also Send Feedback
Gets the agent's extension.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; internal set; }
Visual Basic
Public Property Extension As String
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


InitiatingUser Property

[image]

IceLib Technical Reference
AssistanceItem..::..InitiatingUser Property
AssistanceItem Class See Also Send Feedback
Gets the participant that initiated the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceParticipant InitiatingUser { get; }
Visual Basic
Public ReadOnly Property InitiatingUser As AssistanceParticipant
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


InitiationTime Property

[image]

IceLib Technical Reference
AssistanceItem..::..InitiationTime Property
AssistanceItem Class See Also Send Feedback
Gets the date and time the assistance request was initiated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime InitiationTime { get; internal set; }
Visual Basic
Public Property InitiationTime As DateTime
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
AssistanceItem..::..InteractionId Property
AssistanceItem Class See Also Send Feedback
Gets the interaction ID associated with the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; internal set; }
Visual Basic
Public Property InteractionId As InteractionId
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


Messages Property

[image]

IceLib Technical Reference
AssistanceItem..::..Messages Property
AssistanceItem Class See Also Send Feedback
Gets the messages associated with the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssistanceMessage> Messages { get; }
Visual Basic
Public ReadOnly Property Messages As ReadOnlyCollection(Of AssistanceMessage)
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


Participants Property

[image]

IceLib Technical Reference
AssistanceItem..::..Participants Property
AssistanceItem Class See Also Send Feedback
Gets the participants involved in the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssistanceParticipant> Participants { get; }
Visual Basic
Public ReadOnly Property Participants As ReadOnlyCollection(Of AssistanceParticipant)
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


ProblemDescription Property

[image]

IceLib Technical Reference
AssistanceItem..::..ProblemDescription Property
AssistanceItem Class See Also Send Feedback
Gets the problem description for the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProblemDescription { get; }
Visual Basic
Public ReadOnly Property ProblemDescription As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


State Property

[image]

IceLib Technical Reference
AssistanceItem..::..State Property
AssistanceItem Class See Also Send Feedback
Gets the state of the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItemState State { get; internal set; }
Visual Basic
Public Property State As AssistanceItemState
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


Station Property

[image]

IceLib Technical Reference
AssistanceItem..::..Station Property
AssistanceItem Class See Also Send Feedback
Gets the agent's station.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Station { get; internal set; }
Visual Basic
Public Property Station As String
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


Workgroup Property

[image]

IceLib Technical Reference
AssistanceItem..::..Workgroup Property
AssistanceItem Class See Also Send Feedback
Gets the workgroup that the assistance request belongs to.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; internal set; }
Visual Basic
Public Property Workgroup As String
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


AssistanceItem Events

[image] [image]

IceLib Technical Reference
AssistanceItem Events
AssistanceItem Class See Also Send Feedback

The AssistanceItem type exposes the following members.

Events

Name Description
Public event ItemChanged
Event that occurs when the assistance request changes.
Note
This event will be invoked on the resulting AssistanceItem for the first time after a call to SendAssistanceRequest(SendAssistanceRequestParameters).
Public event MessageAdded
Event that occurs when a new message is added to the assistance request.
Public event ParticipantAdded
Event that occurs when a new participant becomes involved in the assistance request.
Public event ParticipantChanged
Event that occurs when a participant's action changes.
Public event ParticipantRemoved
Event that occurs when a participant is no longer involved in the assistance request.
Public event StateChanged
Event that occurs when the state of the assistance request changes.

See Also

AssistanceItem Class
ININ.IceLib.Interactions Namespace


ItemChanged Event

[image]

IceLib Technical Reference
AssistanceItem..::..ItemChanged Event
AssistanceItem Class See Also Send Feedback
Event that occurs when the assistance request changes.
Note
This event will be invoked on the resulting AssistanceItem for the first time after a call to SendAssistanceRequest(SendAssistanceRequestParameters).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemChangedEventArgs> ItemChanged
Visual Basic
Public Event ItemChanged As EventHandler(Of AssistanceItemChangedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


MessageAdded Event

[image]

IceLib Technical Reference
AssistanceItem..::..MessageAdded Event
AssistanceItem Class See Also Send Feedback
Event that occurs when a new message is added to the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemMessageAddedEventArgs> MessageAdded
Visual Basic
Public Event MessageAdded As EventHandler(Of AssistanceItemMessageAddedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


ParticipantAdded Event

[image]

IceLib Technical Reference
AssistanceItem..::..ParticipantAdded Event
AssistanceItem Class See Also Send Feedback
Event that occurs when a new participant becomes involved in the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemParticipantEventArgs> ParticipantAdded
Visual Basic
Public Event ParticipantAdded As EventHandler(Of AssistanceItemParticipantEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


ParticipantChanged Event

[image]

IceLib Technical Reference
AssistanceItem..::..ParticipantChanged Event
AssistanceItem Class See Also Send Feedback
Event that occurs when a participant's action changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemParticipantEventArgs> ParticipantChanged
Visual Basic
Public Event ParticipantChanged As EventHandler(Of AssistanceItemParticipantEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


ParticipantRemoved Event

[image]

IceLib Technical Reference
AssistanceItem..::..ParticipantRemoved Event
AssistanceItem Class See Also Send Feedback
Event that occurs when a participant is no longer involved in the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemParticipantRemovedEventArgs> ParticipantRemoved
Visual Basic
Public Event ParticipantRemoved As EventHandler(Of AssistanceItemParticipantRemovedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


StateChanged Event

[image]

IceLib Technical Reference
AssistanceItem..::..StateChanged Event
AssistanceItem Class See Also Send Feedback
Event that occurs when the state of the assistance request changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemStateChangedEventArgs> StateChanged
Visual Basic
Public Event StateChanged As EventHandler(Of AssistanceItemStateChangedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItem Class
AssistanceItem Members
ININ.IceLib.Interactions Namespace


AssistanceItemChangedEventArgs Class

[image]

IceLib Technical Reference
AssistanceItemChangedEventArgs Class
Members See Also Send Feedback
Provides data for the ItemChanged event of an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceItemChangedEventArgs : EventArgs
Visual Basic
Public Class AssistanceItemChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceItemChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemChangedEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceItemChangedEventArgs Members
AssistanceItemChangedEventArgs Class Methods Properties See Also Send Feedback

The AssistanceItemChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItem | Gets the assistance item.

See Also

AssistanceItemChangedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceItemChangedEventArgs Methods
AssistanceItemChangedEventArgs Class See Also Send Feedback

The AssistanceItemChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceItemChangedEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceItemChangedEventArgs..::..ToString Method
AssistanceItemChangedEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceItemChangedEventArgs Class
AssistanceItemChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceItemChangedEventArgs Properties
AssistanceItemChangedEventArgs Class See Also Send Feedback

The AssistanceItemChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItem | Gets the assistance item.

See Also

AssistanceItemChangedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItem Property

[image]

IceLib Technical Reference
AssistanceItemChangedEventArgs..::..AssistanceItem Property
AssistanceItemChangedEventArgs Class See Also Send Feedback
Gets the assistance item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItem AssistanceItem { get; }
Visual Basic
Public ReadOnly Property AssistanceItem As AssistanceItem
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemChangedEventArgs Class
AssistanceItemChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemMessageAddedEventArgs Class

[image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs Class
Members See Also Send Feedback
Provides data for the MessageAdded event of an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceItemMessageAddedEventArgs : EventArgs
Visual Basic
Public Class AssistanceItemMessageAddedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceItemMessageAddedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemMessageAddedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemMessageAddedEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs Members
AssistanceItemMessageAddedEventArgs Class Methods Properties See Also Send Feedback

The AssistanceItemMessageAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID associated with the message.
Public property | Message | Gets the message that was added.

See Also

AssistanceItemMessageAddedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemMessageAddedEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs Methods
AssistanceItemMessageAddedEventArgs Class See Also Send Feedback

The AssistanceItemMessageAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceItemMessageAddedEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs..::..ToString Method
AssistanceItemMessageAddedEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceItemMessageAddedEventArgs Class
AssistanceItemMessageAddedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemMessageAddedEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs Properties
AssistanceItemMessageAddedEventArgs Class See Also Send Feedback

The AssistanceItemMessageAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID associated with the message.
Public property | Message | Gets the message that was added.

See Also

AssistanceItemMessageAddedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemId Property

[image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs..::..AssistanceItemId Property
AssistanceItemMessageAddedEventArgs Class See Also Send Feedback
Gets the assistance request ID associated with the message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistanceItemId { get; }
Visual Basic
Public ReadOnly Property AssistanceItemId As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemMessageAddedEventArgs Class
AssistanceItemMessageAddedEventArgs Members
ININ.IceLib.Interactions Namespace


Message Property

[image]

IceLib Technical Reference
AssistanceItemMessageAddedEventArgs..::..Message Property
AssistanceItemMessageAddedEventArgs Class See Also Send Feedback
Gets the message that was added.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceMessage Message { get; }
Visual Basic
Public ReadOnly Property Message As AssistanceMessage
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemMessageAddedEventArgs Class
AssistanceItemMessageAddedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantEventArgs Class

[image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs Class
Members See Also Send Feedback
Provides data for the ParticipantAdded and ParticipantChanged event of an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceItemParticipantEventArgs : EventArgs
Visual Basic
Public Class AssistanceItemParticipantEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceItemParticipantEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemParticipantEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs Members
AssistanceItemParticipantEventArgs Class Methods Properties See Also Send Feedback

The AssistanceItemParticipantEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID.
Public property | Participant | Gets the participant that was added.

See Also

AssistanceItemParticipantEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs Methods
AssistanceItemParticipantEventArgs Class See Also Send Feedback

The AssistanceItemParticipantEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceItemParticipantEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs..::..ToString Method
AssistanceItemParticipantEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceItemParticipantEventArgs Class
AssistanceItemParticipantEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs Properties
AssistanceItemParticipantEventArgs Class See Also Send Feedback

The AssistanceItemParticipantEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID.
Public property | Participant | Gets the participant that was added.

See Also

AssistanceItemParticipantEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemId Property

[image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs..::..AssistanceItemId Property
AssistanceItemParticipantEventArgs Class See Also Send Feedback
Gets the assistance request ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistanceItemId { get; }
Visual Basic
Public ReadOnly Property AssistanceItemId As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemParticipantEventArgs Class
AssistanceItemParticipantEventArgs Members
ININ.IceLib.Interactions Namespace


Participant Property

[image]

IceLib Technical Reference
AssistanceItemParticipantEventArgs..::..Participant Property
AssistanceItemParticipantEventArgs Class See Also Send Feedback
Gets the participant that was added.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceParticipant Participant { get; }
Visual Basic
Public ReadOnly Property Participant As AssistanceParticipant
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemParticipantEventArgs Class
AssistanceItemParticipantEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantRemovedEventArgs Class

[image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs Class
Members See Also Send Feedback
Provides data for the ParticipantRemoved event of an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceItemParticipantRemovedEventArgs : EventArgs
Visual Basic
Public Class AssistanceItemParticipantRemovedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceItemParticipantRemovedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemParticipantRemovedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantRemovedEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs Members
AssistanceItemParticipantRemovedEventArgs Class Methods Properties See Also Send Feedback

The AssistanceItemParticipantRemovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID.
Public property | Participant | Gets the participant that was removed.

See Also

AssistanceItemParticipantRemovedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantRemovedEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs Methods
AssistanceItemParticipantRemovedEventArgs Class See Also Send Feedback

The AssistanceItemParticipantRemovedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceItemParticipantRemovedEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs..::..ToString Method
AssistanceItemParticipantRemovedEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceItemParticipantRemovedEventArgs Class
AssistanceItemParticipantRemovedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemParticipantRemovedEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs Properties
AssistanceItemParticipantRemovedEventArgs Class See Also Send Feedback

The AssistanceItemParticipantRemovedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID.
Public property | Participant | Gets the participant that was removed.

See Also

AssistanceItemParticipantRemovedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemId Property

[image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs..::..AssistanceItemId Property
AssistanceItemParticipantRemovedEventArgs Class See Also Send Feedback
Gets the assistance request ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistanceItemId { get; }
Visual Basic
Public ReadOnly Property AssistanceItemId As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemParticipantRemovedEventArgs Class
AssistanceItemParticipantRemovedEventArgs Members
ININ.IceLib.Interactions Namespace


Participant Property

[image]

IceLib Technical Reference
AssistanceItemParticipantRemovedEventArgs..::..Participant Property
AssistanceItemParticipantRemovedEventArgs Class See Also Send Feedback
Gets the participant that was removed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceParticipant Participant { get; }
Visual Basic
Public ReadOnly Property Participant As AssistanceParticipant
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemParticipantRemovedEventArgs Class
AssistanceItemParticipantRemovedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemState Enumeration

[image]

IceLib Technical Reference
AssistanceItemState Enumeration
See Also Send Feedback
Defines the states for an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AssistanceItemState
Visual Basic
Public Enumeration AssistanceItemState

Members

Member name | Value | Description
None | 0 | The assistance item has no state.
Accepted | 1 | The assistance item has been accepted by a supervisor.
Completed | 2 | The assistance item has been completed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


AssistanceItemStateChangedEventArgs Class

[image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs Class
Members See Also Send Feedback
Provides data for the StateChanged event of an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceItemStateChangedEventArgs : EventArgs
Visual Basic
Public Class AssistanceItemStateChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceItemStateChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemStateChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemStateChangedEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs Members
AssistanceItemStateChangedEventArgs Class Methods Properties See Also Send Feedback

The AssistanceItemStateChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID associated with the message.
Public property | AssistanceItemState | Gets the state of the assistance item.

See Also

AssistanceItemStateChangedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemStateChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs Methods
AssistanceItemStateChangedEventArgs Class See Also Send Feedback

The AssistanceItemStateChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceItemStateChangedEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs..::..ToString Method
AssistanceItemStateChangedEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceItemStateChangedEventArgs Class
AssistanceItemStateChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemStateChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs Properties
AssistanceItemStateChangedEventArgs Class See Also Send Feedback

The AssistanceItemStateChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID associated with the message.
Public property | AssistanceItemState | Gets the state of the assistance item.

See Also

AssistanceItemStateChangedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemId Property

[image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs..::..AssistanceItemId Property
AssistanceItemStateChangedEventArgs Class See Also Send Feedback
Gets the assistance request ID associated with the message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistanceItemId { get; }
Visual Basic
Public ReadOnly Property AssistanceItemId As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemStateChangedEventArgs Class
AssistanceItemStateChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceItemState Property

[image]

IceLib Technical Reference
AssistanceItemStateChangedEventArgs..::..AssistanceItemState Property
AssistanceItemStateChangedEventArgs Class See Also Send Feedback
Gets the state of the assistance item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItemState AssistanceItemState { get; }
Visual Basic
Public ReadOnly Property AssistanceItemState As AssistanceItemState
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceItemStateChangedEventArgs Class
AssistanceItemStateChangedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceList Class

[image]

IceLib Technical Reference
AssistanceList Class
Members See Also Send Feedback
This class represents the list of assistance request items that belong to an agent and/or supervisor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class AssistanceList
Visual Basic
Public MustInherit Class AssistanceList

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AssistanceList
ININ.IceLib.Interactions..::..AgentAssistanceList
ININ.IceLib.Interactions..::..SupervisorAssistanceList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Members
ININ.IceLib.Interactions Namespace


AssistanceList Members

[image] [image]

IceLib Technical Reference
AssistanceList Members
AssistanceList Class Constructors Methods Properties Events See Also Send Feedback

The AssistanceList type exposes the following members.

Constructors

 | Name | Description
Protected method | AssistanceList | Initializes a new instance of the AssistanceList class.

Methods

 | Name | Description
Public method | Accept | Accepts an assistance request.
Public method | AcceptAsync | Asynchronously accepts an assistance request.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssistanceRequests | Gets the list of assistance request items associated with this list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Ignore | Ignores an assistance request.
Public method | IgnoreAsync | Asynchronously Ignores an assistance request.
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the AssistanceList.
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceList.
Public method | StopWatching | Stops watching the AssistanceList.
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceList.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets an assistance request item with the associated ID.

Events

 | Name | Description
Public event | ItemAdded | Event that occurs when a new assistance item is added to the assistance list.
Public event | ItemRemoved | Event that occurs when an assistance item is removed from the assistance list.
Public event | ItemStateChanged | Event that occurs when an assistance item's state changes in the assistance list.

See Also

AssistanceList Class
ININ.IceLib.Interactions Namespace


AssistanceList Constructor

[image]

IceLib Technical Reference
AssistanceList Constructor
AssistanceList Class See Also Send Feedback
Initializes a new instance of the AssistanceList class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected AssistanceList(
    InteractionsManager interactionsManager
)
Visual Basic
Protected Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


AssistanceList Methods

[image] [image]

IceLib Technical Reference
AssistanceList Methods
AssistanceList Class See Also Send Feedback

The AssistanceList type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts an assistance request.
Public method | AcceptAsync | Asynchronously accepts an assistance request.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssistanceRequests | Gets the list of assistance request items associated with this list.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Ignore | Ignores an assistance request.
Public method | IgnoreAsync | Asynchronously Ignores an assistance request.
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the AssistanceList.
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceList.
Public method | StopWatching | Stops watching the AssistanceList.
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceList.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssistanceList Class
ININ.IceLib.Interactions Namespace


Accept Method

[image]

IceLib Technical Reference
AssistanceList..::..Accept Method
AssistanceList Class See Also Send Feedback
Accepts an assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Accept(
    string assistanceItemId,
    string message
)
Visual Basic
Public Sub Accept ( _
    assistanceItemId As String, _
    message As String _
)

Parameters

assistanceItemId
Type: System..::..String
The assistance request ID to accept.
message
Type: System..::..String
The message to send while accepting the assistance request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


AcceptAsync Method

[image]

IceLib Technical Reference
AssistanceList..::..AcceptAsync Method
AssistanceList Class See Also Send Feedback
Asynchronously accepts an assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AcceptAsync(
    string assistanceItemId,
    string message,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AcceptAsync ( _
    assistanceItemId As String, _
    message As String, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

assistanceItemId
Type: System..::..String
The assistance request ID to accept.
message
Type: System..::..String
The message to send while accepting the assistance request.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


GetAssistanceRequests Method

[image]

IceLib Technical Reference
AssistanceList..::..GetAssistanceRequests Method
AssistanceList Class See Also Send Feedback
Gets the list of assistance request items associated with this list.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssistanceItem> GetAssistanceRequests()
Visual Basic
Public Function GetAssistanceRequests As ReadOnlyCollection(Of AssistanceItem)

Return Value

A collection of assistance request items.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


Ignore Method

[image]

IceLib Technical Reference
AssistanceList..::..Ignore Method
AssistanceList Class See Also Send Feedback
Ignores an assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Ignore(
    string assistanceItemId,
    string message
)
Visual Basic
Public Sub Ignore ( _
    assistanceItemId As String, _
    message As String _
)

Parameters

assistanceItemId
Type: System..::..String
The assistance request ID to Ignore.
message
Type: System..::..String
The message to send while Ignoreing the assistance request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


IgnoreAsync Method

[image]

IceLib Technical Reference
AssistanceList..::..IgnoreAsync Method
AssistanceList Class See Also Send Feedback
Asynchronously Ignores an assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void IgnoreAsync(
    string assistanceItemId,
    string message,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub IgnoreAsync ( _
    assistanceItemId As String, _
    message As String, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

assistanceItemId
Type: System..::..String
The assistance request ID to Ignore.
message
Type: System..::..String
The message to send while Ignoreing the assistance request.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
AssistanceList..::..IsWatching Method
AssistanceList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
AssistanceList..::..StartWatching Method
AssistanceList Class See Also Send Feedback
Starts watching the AssistanceList.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is already being watched or cannot perform this operation on the AssistanceList.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
AssistanceList..::..StartWatchingAsync Method
AssistanceList Class See Also Send Feedback
Asynchronously starts watching the AssistanceList.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched or cannot perform this operation on the AssistanceList.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
AssistanceList..::..StopWatching Method
AssistanceList Class See Also Send Feedback
Stops watching the AssistanceList.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

StopWatching()()()() or StopWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched or cannot perform this operation on the AssistanceList.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
AssistanceList..::..StopWatchingAsync Method
AssistanceList Class See Also Send Feedback
Asynchronously stops watching the AssistanceList.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

StopWatching()()()() or StopWatchingAsync(EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched or cannot perform this operation on the AssistanceList.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


AssistanceList Properties

[image] [image]

IceLib Technical Reference
AssistanceList Properties
AssistanceList Class See Also Send Feedback

The AssistanceList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets an assistance request item with the associated ID.

See Also

AssistanceList Class
ININ.IceLib.Interactions Namespace


Item Property

[image]

IceLib Technical Reference
AssistanceList..::..Item Property
AssistanceList Class See Also Send Feedback
Gets an assistance request item with the associated ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItem this[
    string assistanceItemId
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    assistanceItemId As String _
) As AssistanceItem
    Get

Parameters

assistanceItemId
Type: System..::..String
The assistance request ID.

Return Value

The assistance item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


AssistanceList Events

[image] [image]

IceLib Technical Reference
AssistanceList Events
AssistanceList Class See Also Send Feedback

The AssistanceList type exposes the following members.

Events

 | Name | Description
Public event | ItemAdded | Event that occurs when a new assistance item is added to the assistance list.
Public event | ItemRemoved | Event that occurs when an assistance item is removed from the assistance list.
Public event | ItemStateChanged | Event that occurs when an assistance item's state changes in the assistance list.

See Also

AssistanceList Class
ININ.IceLib.Interactions Namespace


ItemAdded Event

[image]

IceLib Technical Reference
AssistanceList..::..ItemAdded Event
AssistanceList Class See Also Send Feedback
Event that occurs when a new assistance item is added to the assistance list.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceListItemAddedEventArgs> ItemAdded
Visual Basic
Public Event ItemAdded As EventHandler(Of AssistanceListItemAddedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


ItemRemoved Event

[image]

IceLib Technical Reference
AssistanceList..::..ItemRemoved Event
AssistanceList Class See Also Send Feedback
Event that occurs when an assistance item is removed from the assistance list.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceListEventArgs> ItemRemoved
Visual Basic
Public Event ItemRemoved As EventHandler(Of AssistanceListEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


ItemStateChanged Event

[image]

IceLib Technical Reference
AssistanceList..::..ItemStateChanged Event
AssistanceList Class See Also Send Feedback
Event that occurs when an assistance item's state changes in the assistance list.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssistanceItemStateChangedEventArgs> ItemStateChanged
Visual Basic
Public Event ItemStateChanged As EventHandler(Of AssistanceItemStateChangedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceList Class
AssistanceList Members
ININ.IceLib.Interactions Namespace


AssistanceListEventArgs Class

[image]

IceLib Technical Reference
AssistanceListEventArgs Class
Members See Also Send Feedback
Provides data for the ItemAdded/ItemRemoved events of an AssistanceList.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceListEventArgs : EventArgs
Visual Basic
Public Class AssistanceListEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceListEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceListEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceListEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceListEventArgs Members
AssistanceListEventArgs Class Methods Properties See Also Send Feedback

The AssistanceListEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID.

See Also

AssistanceListEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceListEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceListEventArgs Methods
AssistanceListEventArgs Class See Also Send Feedback

The AssistanceListEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceListEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceListEventArgs..::..ToString Method
AssistanceListEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceListEventArgs Class
AssistanceListEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceListEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceListEventArgs Properties
AssistanceListEventArgs Class See Also Send Feedback

The AssistanceListEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItemId | Gets the assistance request ID.

See Also

AssistanceListEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItemId Property

[image]

IceLib Technical Reference
AssistanceListEventArgs..::..AssistanceItemId Property
AssistanceListEventArgs Class See Also Send Feedback
Gets the assistance request ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistanceItemId { get; }
Visual Basic
Public ReadOnly Property AssistanceItemId As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceListEventArgs Class
AssistanceListEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceListItemAddedEventArgs Class

[image]

IceLib Technical Reference
AssistanceListItemAddedEventArgs Class
Members See Also Send Feedback
Provides data for the ItemAdded event of an AssistanceList.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceListItemAddedEventArgs : EventArgs
Visual Basic
Public Class AssistanceListItemAddedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AssistanceListItemAddedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceListItemAddedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceListItemAddedEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceListItemAddedEventArgs Members
AssistanceListItemAddedEventArgs Class Methods Properties See Also Send Feedback

The AssistanceListItemAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AssistanceItem | Gets the assistance item.

See Also

AssistanceListItemAddedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceListItemAddedEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceListItemAddedEventArgs Methods
AssistanceListItemAddedEventArgs Class See Also Send Feedback

The AssistanceListItemAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceListItemAddedEventArgs Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceListItemAddedEventArgs..::..ToString Method
AssistanceListItemAddedEventArgs Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceListItemAddedEventArgs Class
AssistanceListItemAddedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceListItemAddedEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceListItemAddedEventArgs Properties
AssistanceListItemAddedEventArgs Class See Also Send Feedback

The AssistanceListItemAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItem | Gets the assistance item.

See Also

AssistanceListItemAddedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItem Property

[image]

IceLib Technical Reference
AssistanceListItemAddedEventArgs..::..AssistanceItem Property
AssistanceListItemAddedEventArgs Class See Also Send Feedback
Gets the assistance item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItem AssistanceItem { get; }
Visual Basic
Public ReadOnly Property AssistanceItem As AssistanceItem
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceListItemAddedEventArgs Class
AssistanceListItemAddedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceMessage Class

[image]

IceLib Technical Reference
AssistanceMessage Class
Members See Also Send Feedback
Describes data associated with a message for an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceMessage
Visual Basic
Public Class AssistanceMessage

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AssistanceMessage

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceMessage Members
ININ.IceLib.Interactions Namespace


AssistanceMessage Members

[image] [image]

IceLib Technical Reference
AssistanceMessage Members
AssistanceMessage Class Methods Properties See Also Send Feedback

The AssistanceMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Message | Gets the message text.
Public property | Participant | Gets the participant that initiated the message.
Public property | TimeAdded | Gets the date and time the message was added.

See Also

AssistanceMessage Class
ININ.IceLib.Interactions Namespace


AssistanceMessage Methods

[image] [image]

IceLib Technical Reference
AssistanceMessage Methods
AssistanceMessage Class See Also Send Feedback

The AssistanceMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceMessage Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceMessage..::..ToString Method
AssistanceMessage Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceMessage Class
AssistanceMessage Members
ININ.IceLib.Interactions Namespace


AssistanceMessage Properties

[image] [image]

IceLib Technical Reference
AssistanceMessage Properties
AssistanceMessage Class See Also Send Feedback

The AssistanceMessage type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the message text.
Public property | Participant | Gets the participant that initiated the message.
Public property | TimeAdded | Gets the date and time the message was added.

See Also

AssistanceMessage Class
ININ.IceLib.Interactions Namespace


Message Property

[image]

IceLib Technical Reference
AssistanceMessage..::..Message Property
AssistanceMessage Class See Also Send Feedback
Gets the message text.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceMessage Class
AssistanceMessage Members
ININ.IceLib.Interactions Namespace


Participant Property

[image]

IceLib Technical Reference
AssistanceMessage..::..Participant Property
AssistanceMessage Class See Also Send Feedback
Gets the participant that initiated the message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceParticipant Participant { get; }
Visual Basic
Public ReadOnly Property Participant As AssistanceParticipant
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceMessage Class
AssistanceMessage Members
ININ.IceLib.Interactions Namespace


TimeAdded Property

[image]

IceLib Technical Reference
AssistanceMessage..::..TimeAdded Property
AssistanceMessage Class See Also Send Feedback
Gets the date and time the message was added.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime TimeAdded { get; }
Visual Basic
Public ReadOnly Property TimeAdded As DateTime
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceMessage Class
AssistanceMessage Members
ININ.IceLib.Interactions Namespace


AssistanceParticipant Class

[image]

IceLib Technical Reference
AssistanceParticipant Class
Members See Also Send Feedback
Describes a participant associated with an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceParticipant
Visual Basic
Public Class AssistanceParticipant

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AssistanceParticipant

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceParticipant Members
ININ.IceLib.Interactions Namespace


AssistanceParticipant Members

[image] [image]

IceLib Technical Reference
AssistanceParticipant Members
AssistanceParticipant Class Constructors Methods Properties See Also Send Feedback

The AssistanceParticipant type exposes the following members.

Constructors

 | Name | Description
Public method | AssistanceParticipant | Initializes a new instance of AssistanceParticipant with the specified parameters.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Action | Gets the action in regards to the assistance request of the participant.
Public property | DisplayName | Gets the display name of the participant.
Public property | UserId | Gets the user ID of the participant.

See Also

AssistanceParticipant Class
ININ.IceLib.Interactions Namespace


AssistanceParticipant Constructor

[image]

IceLib Technical Reference
AssistanceParticipant Constructor
AssistanceParticipant Class See Also Send Feedback
Initializes a new instance of AssistanceParticipant with the specified parameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceParticipant(
    string userId,
    string displayName,
    AssistanceParticipantAction action
)
Visual Basic
Public Sub New ( _
    userId As String, _
    displayName As String, _
    action As AssistanceParticipantAction _
)

Parameters

userId
Type: System..::..String
The user ID of the participant.
displayName
Type: System..::..String
The display name of the participant.
action
Type: ININ.IceLib.Interactions..::..AssistanceParticipantAction
The action in regards to the assistance request of the participant.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The is not in the valid values of AssistanceParticipantAction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceParticipant Class
AssistanceParticipant Members
ININ.IceLib.Interactions Namespace


AssistanceParticipant Methods

[image] [image]

IceLib Technical Reference
AssistanceParticipant Methods
AssistanceParticipant Class See Also Send Feedback

The AssistanceParticipant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AssistanceParticipant Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AssistanceParticipant..::..ToString Method
AssistanceParticipant Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssistanceParticipant Class
AssistanceParticipant Members
ININ.IceLib.Interactions Namespace


AssistanceParticipant Properties

[image] [image]

IceLib Technical Reference
AssistanceParticipant Properties
AssistanceParticipant Class See Also Send Feedback

The AssistanceParticipant type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the action in regards to the assistance request of the participant.
Public property | DisplayName | Gets the display name of the participant.
Public property | UserId | Gets the user ID of the participant.

See Also

AssistanceParticipant Class
ININ.IceLib.Interactions Namespace


Action Property

[image]

IceLib Technical Reference
AssistanceParticipant..::..Action Property
AssistanceParticipant Class See Also Send Feedback
Gets the action in regards to the assistance request of the participant.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceParticipantAction Action { get; internal set; }
Visual Basic
Public Property Action As AssistanceParticipantAction
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceParticipant Class
AssistanceParticipant Members
ININ.IceLib.Interactions Namespace


DisplayName Property

[image]

IceLib Technical Reference
AssistanceParticipant..::..DisplayName Property
AssistanceParticipant Class See Also Send Feedback
Gets the display name of the participant.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; internal set; }
Visual Basic
Public Property DisplayName As String
    Get
    Friend Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceParticipant Class
AssistanceParticipant Members
ININ.IceLib.Interactions Namespace


UserId Property

[image]

IceLib Technical Reference
AssistanceParticipant..::..UserId Property
AssistanceParticipant Class See Also Send Feedback
Gets the user ID of the participant.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceParticipant Class
AssistanceParticipant Members
ININ.IceLib.Interactions Namespace


AssistanceParticipantAction Enumeration

[image]

IceLib Technical Reference
AssistanceParticipantAction Enumeration
See Also Send Feedback
Describes the action of an AssistanceParticipant in regards to an AssistanceItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AssistanceParticipantAction
Visual Basic
Public Enumeration AssistanceParticipantAction

Members

Member name | Value | Description
None | 0 | No action.
Initiated | 1 | The participant initiated the assistance request.
Ignored | 2 | The participant is ignoring the assistance request.
Accepted | 3 | The participant has accepted the assistance request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


AssistanceRequestCompletedEventArgs Class

[image]

IceLib Technical Reference
AssistanceRequestCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SendAssistanceRequestAsync(SendAssistanceRequestParameters, EventHandler<(Of <<'(AssistanceRequestCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssistanceRequestCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AssistanceRequestCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..AssistanceRequestCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceRequestCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceRequestCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AssistanceRequestCompletedEventArgs Members
AssistanceRequestCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The AssistanceRequestCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AssistanceRequestCompletedEventArgs | Initializes a new instance of with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssistanceItem | Gets the assistance request item.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AssistanceRequestCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceRequestCompletedEventArgs Constructor

[image]

IceLib Technical Reference
AssistanceRequestCompletedEventArgs Constructor
AssistanceRequestCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceRequestCompletedEventArgs(
    AssistanceItem assistanceItem,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    assistanceItem As AssistanceItem, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

assistanceItem
Type: ININ.IceLib.Interactions..::..AssistanceItem
The assistance request item.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceRequestCompletedEventArgs Class
AssistanceRequestCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


AssistanceRequestCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AssistanceRequestCompletedEventArgs Methods
AssistanceRequestCompletedEventArgs Class See Also Send Feedback

The AssistanceRequestCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssistanceRequestCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceRequestCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AssistanceRequestCompletedEventArgs Properties
AssistanceRequestCompletedEventArgs Class See Also Send Feedback

The AssistanceRequestCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AssistanceItem | Gets the assistance request item.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AssistanceRequestCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


AssistanceItem Property

[image]

IceLib Technical Reference
AssistanceRequestCompletedEventArgs..::..AssistanceItem Property
AssistanceRequestCompletedEventArgs Class See Also Send Feedback
Gets the assistance request item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItem AssistanceItem { get; }
Visual Basic
Public ReadOnly Property AssistanceItem As AssistanceItem
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssistanceRequestCompletedEventArgs Class
AssistanceRequestCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


AsyncStartWatchCompletedEventArgs Class

[image]

IceLib Technical Reference
AsyncStartWatchCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object), GetStringAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(String>)>>)>)>>), Object), GetIntegerAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object), and GetDateTimeAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(DateTime>)>>)>)>>), Object) events of a InteractionAlerting.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncStartWatchCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncStartWatchCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..AsyncStartWatchCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncStartWatchCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


AsyncStartWatchCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncStartWatchCompletedEventArgs Members
AsyncStartWatchCompletedEventArgs Class Methods Properties See Also Send Feedback

The AsyncStartWatchCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlertingDetails | Gets the initial alerting details.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncStartWatchCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


AsyncStartWatchCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncStartWatchCompletedEventArgs Methods
AsyncStartWatchCompletedEventArgs Class See Also Send Feedback

The AsyncStartWatchCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncStartWatchCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


AsyncStartWatchCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncStartWatchCompletedEventArgs Properties
AsyncStartWatchCompletedEventArgs Class See Also Send Feedback

The AsyncStartWatchCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AlertingDetails | Gets the initial alerting details.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncStartWatchCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


AlertingDetails Property

[image]

IceLib Technical Reference
AsyncStartWatchCompletedEventArgs..::..AlertingDetails Property
AsyncStartWatchCompletedEventArgs Class See Also Send Feedback
Gets the initial alerting details.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionAlertingDetails> AlertingDetails { get; }
Visual Basic
Public ReadOnly Property AlertingDetails As ReadOnlyCollection(Of InteractionAlertingDetails)
    Get

Field Value

The alerting details.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncStartWatchCompletedEventArgs Class
AsyncStartWatchCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


AttributeMonitorId Class

[image]

IceLib Technical Reference
AttributeMonitorId Class
Members See Also Send Feedback
Identifies an InteractionAttributeMonitor within the Interaction Center system. InteractionAttributeMonitor has more details.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class AttributeMonitorId : IComparable,
    IComparable<AttributeMonitorId>
Visual Basic
<SerializableAttribute> _
Public Class AttributeMonitorId _
    Implements IComparable, IComparable(Of AttributeMonitorId)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AttributeMonitorId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


AttributeMonitorId Members

[image] [image]

IceLib Technical Reference
AttributeMonitorId Members
AttributeMonitorId Class Constructors Methods Operators Properties See Also Send Feedback

The AttributeMonitorId type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeMonitorId | Initializes a new instance of the AttributeMonitorId class

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(AttributeMonitorId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AttributeMonitorId) | Determines whether the specified AttributeMonitorId is equal to the current QueueId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of AttributeMonitorId are equal.
Inequality | Determines whether two instances of AttributeMonitorId are not equal.

Properties

 | Name | Description
Public property | AttributeName | Gets the attribute name of the Monitor being identified.
Public property | AttributeValue | Gets the attribute value of the Monitor being identified.

See Also

AttributeMonitorId Class
ININ.IceLib.Interactions Namespace


AttributeMonitorId Constructor

[image]

IceLib Technical Reference
AttributeMonitorId Constructor
AttributeMonitorId Class See Also Send Feedback
Initializes a new instance of the AttributeMonitorId class

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttributeMonitorId(
    string attributeName,
    string attributeValue
)
Visual Basic
Public Sub New ( _
    attributeName As String, _
    attributeValue As String _
)

Parameters

attributeName
Type: System..::..String
The name of the attribute.
attributeValue
Type: System..::..String
The value of the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


AttributeMonitorId Methods

[image] [image]

IceLib Technical Reference
AttributeMonitorId Methods
AttributeMonitorId Class See Also Send Feedback

The AttributeMonitorId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(AttributeMonitorId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AttributeMonitorId) | Determines whether the specified AttributeMonitorId is equal to the current QueueId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AttributeMonitorId Class
ININ.IceLib.Interactions Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
AttributeMonitorId..::..CompareTo Method
AttributeMonitorId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(AttributeMonitorId) | Compares the current object with another object of the same type.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


CompareTo Method (Object)

[image]

IceLib Technical Reference
AttributeMonitorId..::..CompareTo Method (Object)
AttributeMonitorId Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


CompareTo Method (AttributeMonitorId)

[image]

IceLib Technical Reference
AttributeMonitorId..::..CompareTo Method (AttributeMonitorId)
AttributeMonitorId Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    AttributeMonitorId other
)
Visual Basic
Public Function CompareTo ( _
    other As AttributeMonitorId _
) As Integer

Parameters

other
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AttributeMonitorId..::..Equals Method
AttributeMonitorId Class See Also Send Feedback
Determines whether two AttributeMonitorId instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AttributeMonitorId) | Determines whether the specified AttributeMonitorId is equal to the current QueueId.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AttributeMonitorId..::..Equals Method (Object)
AttributeMonitorId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
Equals Overload
ININ.IceLib.Interactions Namespace


Equals Method (AttributeMonitorId)

[image]

IceLib Technical Reference
AttributeMonitorId..::..Equals Method (AttributeMonitorId)
AttributeMonitorId Class See Also Send Feedback
Determines whether the specified AttributeMonitorId is equal to the current QueueId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AttributeMonitorId other
)
Visual Basic
Public Function Equals ( _
    other As AttributeMonitorId _
) As Boolean

Parameters

other
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
The AttributeMonitorId to compare with the current AttributeMonitorId.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified AttributeMonitorId is equal to the current AttributeMonitorId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
Equals Overload
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AttributeMonitorId..::..GetHashCode Method
AttributeMonitorId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
AttributeMonitorId..::..ToString Method
AttributeMonitorId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


AttributeMonitorId Operators

[image] [image]

IceLib Technical Reference
AttributeMonitorId Operators
AttributeMonitorId Class See Also Send Feedback

The AttributeMonitorId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of AttributeMonitorId are equal.
Inequality | Determines whether two instances of AttributeMonitorId are not equal.

See Also

AttributeMonitorId Class
ININ.IceLib.Interactions Namespace


Equality Operator

[image]

IceLib Technical Reference
AttributeMonitorId..::..Equality Operator
AttributeMonitorId Class See Also Send Feedback
Determines whether two instances of AttributeMonitorId are equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AttributeMonitorId a,
    AttributeMonitorId b
)
Visual Basic
Public Shared Operator = ( _
    a As AttributeMonitorId, _
    b As AttributeMonitorId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
The first AttributeMonitorId to compare.
b
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
The second AttributeMonitorId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


Inequality Operator

[image]

IceLib Technical Reference
AttributeMonitorId..::..Inequality Operator
AttributeMonitorId Class See Also Send Feedback
Determines whether two instances of AttributeMonitorId are not equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AttributeMonitorId a,
    AttributeMonitorId b
)
Visual Basic
Public Shared Operator <> ( _
    a As AttributeMonitorId, _
    b As AttributeMonitorId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
The first AttributeMonitorId to compare.
b
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
The second AttributeMonitorId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


AttributeMonitorId Properties

[image] [image]

IceLib Technical Reference
AttributeMonitorId Properties
AttributeMonitorId Class See Also Send Feedback

The AttributeMonitorId type exposes the following members.

Properties

 | Name | Description
Public property | AttributeName | Gets the attribute name of the Monitor being identified.
Public property | AttributeValue | Gets the attribute value of the Monitor being identified.

See Also

AttributeMonitorId Class
ININ.IceLib.Interactions Namespace


AttributeName Property

[image]

IceLib Technical Reference
AttributeMonitorId..::..AttributeName Property
AttributeMonitorId Class See Also Send Feedback
Gets the attribute name of the Monitor being identified.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AttributeName { get; }
Visual Basic
Public ReadOnly Property AttributeName As String
    Get

Field Value

The Name of the attribute.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


AttributeValue Property

[image]

IceLib Technical Reference
AttributeMonitorId..::..AttributeValue Property
AttributeMonitorId Class See Also Send Feedback
Gets the attribute value of the Monitor being identified.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AttributeValue { get; }
Visual Basic
Public ReadOnly Property AttributeValue As String
    Get

Field Value

The value of the attribute.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

AttributeMonitorId Class
AttributeMonitorId Members
ININ.IceLib.Interactions Namespace


AttributesEventArgs Class

[image]

IceLib Technical Reference
AttributesEventArgs Class
Members See Also Send Feedback
Provides data for the AttributesChanged event of a Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttributesEventArgs : EventArgs
Visual Basic
Public Class AttributesEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..AttributesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributesEventArgs Members
ININ.IceLib.Interactions Namespace


AttributesEventArgs Members

[image] [image]

IceLib Technical Reference
AttributesEventArgs Members
AttributesEventArgs Class Constructors Methods Properties See Also Send Feedback

The AttributesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AttributesEventArgs | Initializes a new instance of the AttributesEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

AttributesEventArgs Class
ININ.IceLib.Interactions Namespace


AttributesEventArgs Constructor

[image]

IceLib Technical Reference
AttributesEventArgs Constructor
AttributesEventArgs Class See Also Send Feedback
Initializes a new instance of the AttributesEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttributesEventArgs(
    string[] interactionAttributeNames
)
Visual Basic
Public Sub New ( _
    interactionAttributeNames As String() _
)

Parameters

interactionAttributeNames
Type: array<System..::..String>[]()[][]
The interaction attribute names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributesEventArgs Class
AttributesEventArgs Members
ININ.IceLib.Interactions Namespace


AttributesEventArgs Methods

[image] [image]

IceLib Technical Reference
AttributesEventArgs Methods
AttributesEventArgs Class See Also Send Feedback

The AttributesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributesEventArgs Class
ININ.IceLib.Interactions Namespace


AttributesEventArgs Properties

[image] [image]

IceLib Technical Reference
AttributesEventArgs Properties
AttributesEventArgs Class See Also Send Feedback

The AttributesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

AttributesEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionAttributeNames Property

[image]

IceLib Technical Reference
AttributesEventArgs..::..InteractionAttributeNames Property
AttributesEventArgs Class See Also Send Feedback
Gets the attribute names associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> InteractionAttributeNames { get; }
Visual Basic
Public ReadOnly Property InteractionAttributeNames As ReadOnlyCollection(Of String)
    Get

Field Value

The interaction attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributesEventArgs Class
AttributesEventArgs Members
ININ.IceLib.Interactions Namespace


CallAnalysisType Enumeration

[image]

IceLib Technical Reference
CallAnalysisType Enumeration
See Also Send Feedback
Used to specify if analysis needs to be performed on a call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CallAnalysisType
Visual Basic
Public Enumeration CallAnalysisType

Members

Member name | Value | Description
Default | 0 | Uses Default setting specified for the user.
Yes | 1 | Analysis will be performed on the call.
No | 2 | Analysis will not be performed on the call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

ININ.IceLib.Interactions Namespace


CallbackCompletion Enumeration

[image]

IceLib Technical Reference
CallbackCompletion Enumeration
See Also Send Feedback
Specifies constants indicating the completion of a CallbackInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CallbackCompletion
Visual Basic
Public Enumeration CallbackCompletion

Members

Member name | Value | Description
None | 0 | The completion has not been assigned.
Success | 1 | The callback succeeded.
Failure | 2 | The callback failed.
Retry | 3 | The callback was retried.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


CallbackInteraction Class

[image]

IceLib Technical Reference
CallbackInteraction Class
Members See Also Send Feedback
Represents a callback interaction within the Interaction Center system. Callback interactions occur when agents call a customer in accordance with a callback request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CallbackInteraction : Interaction
Visual Basic
Public Class CallbackInteraction _
    Inherits Interaction

Remarks

To set a callback request to completed, call the SetCompletion(CallbackSetCompletionParameters) method and provide a boolean to indicate success or failure. When the asynchronous method returns it invokes the completedCallback delegate.

Calling properties on this object without a watch in place raises the NotCachedException.

Note
The asynchronous methods are preferred since the stop completion task can be lengthy.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..CallbackInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackInteraction Members

[image] [image]

IceLib Technical Reference
CallbackInteraction Members
CallbackInteraction Class Constructors Methods Properties Events See Also Send Feedback

The CallbackInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | CallbackInteraction | Initializes a new instance of the CallbackInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Public method | MakeCallbackCall | Makes the call for this CallbackInteraction.
Public method | MakeCallbackCallAsync | Asynchronously makes a callback call.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetCompletion(Boolean) | Obsolete. Sets the callback completion.
Public method | SetCompletion(CallbackSetCompletionParameters) | Sets the callback's completion.
Public method | SetCompletionAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously sets the callback completion.
Public method | SetCompletionAsync(CallbackSetCompletionParameters, AsyncCompletedEventHandler, Object) | Asynchronously sets the callback's completion.
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallbackAssociatedCallId | Gets the callback associated call ID.
Public property | CallbackCompletion | Gets the callback completion.
Public property | CallbackCompletionDisplay | Gets the callback message.
Public property | CallbackMessage | Gets the callback message.
Public property | CallbackPhone | Gets the callback phone number.
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

CallbackInteraction Class
ININ.IceLib.Interactions Namespace


CallbackInteraction Constructor

[image]

IceLib Technical Reference
CallbackInteraction Constructor
CallbackInteraction Class See Also Send Feedback
Initializes a new instance of the CallbackInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackInteraction Methods

[image] [image]

IceLib Technical Reference
CallbackInteraction Methods
CallbackInteraction Class See Also Send Feedback

The CallbackInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Public method | MakeCallbackCall | Makes the call for this CallbackInteraction.
Public method | MakeCallbackCallAsync | Asynchronously makes a callback call.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetCompletion(Boolean) | Obsolete. Sets the callback completion.
Public method | SetCompletion(CallbackSetCompletionParameters) | Sets the callback's completion.
Public method | SetCompletionAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously sets the callback completion.
Public method | SetCompletionAsync(CallbackSetCompletionParameters, AsyncCompletedEventHandler, Object) | Asynchronously sets the callback's completion.
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

CallbackInteraction Class
ININ.IceLib.Interactions Namespace


MakeCallbackCall Method

[image]

IceLib Technical Reference
CallbackInteraction..::..MakeCallbackCall Method
CallbackInteraction Class See Also Send Feedback
Makes the call for this CallbackInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction MakeCallbackCall(
    CallInteractionParameters callParameters
)
Visual Basic
Public Function MakeCallbackCall ( _
    callParameters As CallInteractionParameters _
) As Interaction

Parameters

callParameters
Type: ININ.IceLib.Interactions..::..CallInteractionParameters
The call parameters.

Return Value

The Interaction that was returned.

Remarks

This method will set the CallbackInteractionId property of callParameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | The Session does not have a valid connection.
ININ.IceLib.Interactions..::..MakeCallException | Call could not be made because of a server side error.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


MakeCallbackCallAsync Method

[image]

IceLib Technical Reference
CallbackInteraction..::..MakeCallbackCallAsync Method
CallbackInteraction Class See Also Send Feedback
Asynchronously makes a callback call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeCallbackCallAsync(
    CallInteractionParameters callParameters,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeCallbackCallAsync ( _
    callParameters As CallInteractionParameters, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

callParameters
Type: ININ.IceLib.Interactions..::..CallInteractionParameters
The call parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

This method will set the CallbackInteractionId property of callParameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


SetCompletion Method

[image] [image]

IceLib Technical Reference
CallbackInteraction..::..SetCompletion Method
CallbackInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCompletion(Boolean) | Obsolete. Sets the callback completion.
Public method | SetCompletion(CallbackSetCompletionParameters) | Sets the callback's completion.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


SetCompletion Method (Boolean)

[image]

IceLib Technical Reference
CallbackInteraction..::..SetCompletion Method (Boolean)
CallbackInteraction Class See Also Send Feedback
Sets the callback completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SetCompletion(bool) has been deprecated. Please use SetCompletion(CallbackSetCompletionParameters) instead.",
    false)]
public void SetCompletion(
    bool completion
)
Visual Basic
<ObsoleteAttribute("SetCompletion(bool) has been deprecated. Please use SetCompletion(CallbackSetCompletionParameters) instead.",  _
    False)> _
Public Sub SetCompletion ( _
    completion As Boolean _
)

Parameters

completion
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) completed successfully.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
SetCompletion Overload
ININ.IceLib.Interactions Namespace


SetCompletion Method (CallbackSetCompletionParameters)

[image]

IceLib Technical Reference
CallbackInteraction..::..SetCompletion Method (CallbackSetCompletionParameters)
CallbackInteraction Class See Also Send Feedback
Sets the callback's completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetCompletion(
    CallbackSetCompletionParameters callbackSetCompletionParameters
)
Visual Basic
Public Sub SetCompletion ( _
    callbackSetCompletionParameters As CallbackSetCompletionParameters _
)

Parameters

callbackSetCompletionParameters
Type: ININ.IceLib.Interactions..::..CallbackSetCompletionParameters
The CallbackSetCompletionParameters for this callback attempt.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
SetCompletion Overload
ININ.IceLib.Interactions Namespace


SetCompletionAsync Method

[image] [image]

IceLib Technical Reference
CallbackInteraction..::..SetCompletionAsync Method
CallbackInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCompletionAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously sets the callback completion.
Public method | SetCompletionAsync(CallbackSetCompletionParameters, AsyncCompletedEventHandler, Object) | Asynchronously sets the callback's completion.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


SetCompletionAsync Method (Boolean, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
CallbackInteraction..::..SetCompletionAsync Method (Boolean, AsyncCompletedEventHandler, Object)
CallbackInteraction Class See Also Send Feedback
Asynchronously sets the callback completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SetCompletionAsync(bool, AsyncCompletedEventHandler, object) has been deprecated. Please use SetCompletionAsync(CallbackSetCompletionParameters, AsyncCompletedEventHandler, object) instead.",
    false)]
public void SetCompletionAsync(
    bool completion,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("SetCompletionAsync(bool, AsyncCompletedEventHandler, object) has been deprecated. Please use SetCompletionAsync(CallbackSetCompletionParameters, AsyncCompletedEventHandler, object) instead.",  _
    False)> _
Public Sub SetCompletionAsync ( _
    completion As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completion
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) completed successfully.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
SetCompletionAsync Overload
ININ.IceLib.Interactions Namespace


SetCompletionAsync Method (CallbackSetCompletionParameters, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
CallbackInteraction..::..SetCompletionAsync Method (CallbackSetCompletionParameters, AsyncCompletedEventHandler, Object)
CallbackInteraction Class See Also Send Feedback
Asynchronously sets the callback's completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetCompletionAsync(
    CallbackSetCompletionParameters callbackSetCompletionParameters,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetCompletionAsync ( _
    callbackSetCompletionParameters As CallbackSetCompletionParameters, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

callbackSetCompletionParameters
Type: ININ.IceLib.Interactions..::..CallbackSetCompletionParameters
The CallbackSetCompletionParameters for this callback attempt.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
SetCompletionAsync Overload
ININ.IceLib.Interactions Namespace


CallbackInteraction Properties

[image] [image]

IceLib Technical Reference
CallbackInteraction Properties
CallbackInteraction Class See Also Send Feedback

The CallbackInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallbackAssociatedCallId | Gets the callback associated call ID.
Public property | CallbackCompletion | Gets the callback completion.
Public property | CallbackCompletionDisplay | Gets the callback message.
Public property | CallbackMessage | Gets the callback message.
Public property | CallbackPhone | Gets the callback phone number.
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

CallbackInteraction Class
ININ.IceLib.Interactions Namespace


CallbackAssociatedCallId Property

[image]

IceLib Technical Reference
CallbackInteraction..::..CallbackAssociatedCallId Property
CallbackInteraction Class See Also Send Feedback
Gets the callback associated call ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId CallbackAssociatedCallId { get; }
Visual Basic
Public ReadOnly Property CallbackAssociatedCallId As InteractionId
    Get

Field Value

The callback associated call ID.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackCompletion Property

[image]

IceLib Technical Reference
CallbackInteraction..::..CallbackCompletion Property
CallbackInteraction Class See Also Send Feedback
Gets the callback completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackCompletion CallbackCompletion { get; }
Visual Basic
Public ReadOnly Property CallbackCompletion As CallbackCompletion
    Get

Field Value

The callback completion.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackCompletionDisplay Property

[image]

IceLib Technical Reference
CallbackInteraction..::..CallbackCompletionDisplay Property
CallbackInteraction Class See Also Send Feedback
Gets the callback message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallbackCompletionDisplay { get; }
Visual Basic
Public ReadOnly Property CallbackCompletionDisplay As String
    Get

Field Value

The callback message.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackMessage Property

[image]

IceLib Technical Reference
CallbackInteraction..::..CallbackMessage Property
CallbackInteraction Class See Also Send Feedback
Gets the callback message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallbackMessage { get; }
Visual Basic
Public ReadOnly Property CallbackMessage As String
    Get

Field Value

The callback message.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackPhone Property

[image]

IceLib Technical Reference
CallbackInteraction..::..CallbackPhone Property
CallbackInteraction Class See Also Send Feedback
Gets the callback phone number.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallbackPhone { get; }
Visual Basic
Public ReadOnly Property CallbackPhone As String
    Get

Field Value

The callback phone number.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteraction Class
CallbackInteraction Members
ININ.IceLib.Interactions Namespace


CallbackInteraction Events

[image] [image]

IceLib Technical Reference
CallbackInteraction Events
CallbackInteraction Class See Also Send Feedback

The CallbackInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

CallbackInteraction Class
ININ.IceLib.Interactions Namespace


CallbackInteractionAttributeName Class

[image]

IceLib Technical Reference
CallbackInteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with CallbackInteractions.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class CallbackInteractionAttributeName : InteractionAttributeName
Visual Basic
Public MustInherit Class CallbackInteractionAttributeName _
    Inherits InteractionAttributeName

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.Interactions..::..CallbackInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackInteractionAttributeName Members

[image] [image]

IceLib Technical Reference
CallbackInteractionAttributeName Members
CallbackInteractionAttributeName Class Methods Fields See Also Send Feedback

The CallbackInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CallbackAssociatedCallId | The call ID of the associated call to the callback.
CallbackCompletion | The callback completion.
CallbackCompletionDisplay | The display string of the callback completion.
CallbackMaxRetry | The maximum number of retries that should be attempted for this callback.
CallbackMessage | The callback message.
CallbackPhone | The phone number to callback.
CallbackRetryCount | The retry attempt for this callback.
CallbackSnoozeActualWakeupTime | The actual time at which this callback left snooze and re-entered the ACD queue.
CallbackSnoozed | Whether this callback is snoozed or not.
CallbackSnoozeEndTime | The desired time at which this callback should leave snooze and re-enter the ACD queue.
CallbackSnoozeStartTime | The time at which this callback entered a snoozed state.

See Also

CallbackInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


CallbackInteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
CallbackInteractionAttributeName Fields
CallbackInteractionAttributeName Class See Also Send Feedback

The CallbackInteractionAttributeName type exposes the following members.

Fields

Name | Description
CallbackAssociatedCallId | The call ID of the associated call to the callback.
CallbackCompletion | The callback completion.
CallbackCompletionDisplay | The display string of the callback completion.
CallbackMaxRetry | The maximum number of retries that should be attempted for this callback.
CallbackMessage | The callback message.
CallbackPhone | The phone number to callback.
CallbackRetryCount | The retry attempt for this callback.
CallbackSnoozeActualWakeupTime | The actual time at which this callback left snooze and re-entered the ACD queue.
CallbackSnoozed | Whether this callback is snoozed or not.
CallbackSnoozeEndTime | The desired time at which this callback should leave snooze and re-enter the ACD queue.
CallbackSnoozeStartTime | The time at which this callback entered a snoozed state.

See Also

CallbackInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


CallbackAssociatedCallId Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackAssociatedCallId Field
CallbackInteractionAttributeName Class See Also Send Feedback
The call ID of the associated call to the callback.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackAssociatedCallId
Visual Basic
Public Shared ReadOnly CallbackAssociatedCallId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackCompletion Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackCompletion Field
CallbackInteractionAttributeName Class See Also Send Feedback
The callback completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackCompletion
Visual Basic
Public Shared ReadOnly CallbackCompletion As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackCompletionDisplay Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackCompletionDisplay Field
CallbackInteractionAttributeName Class See Also Send Feedback
The display string of the callback completion.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackCompletionDisplay
Visual Basic
Public Shared ReadOnly CallbackCompletionDisplay As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackMaxRetry Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackMaxRetry Field
CallbackInteractionAttributeName Class See Also Send Feedback
The maximum number of retries that should be attempted for this callback.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackMaxRetry
Visual Basic
Public Shared ReadOnly CallbackMaxRetry As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackMessage Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackMessage Field
CallbackInteractionAttributeName Class See Also Send Feedback
The callback message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackMessage
Visual Basic
Public Shared ReadOnly CallbackMessage As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackPhone Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackPhone Field
CallbackInteractionAttributeName Class See Also Send Feedback
The phone number to callback.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackPhone
Visual Basic
Public Shared ReadOnly CallbackPhone As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackRetryCount Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackRetryCount Field
CallbackInteractionAttributeName Class See Also Send Feedback
The retry attempt for this callback.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackRetryCount
Visual Basic
Public Shared ReadOnly CallbackRetryCount As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackSnoozeActualWakeupTime Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackSnoozeActualWakeupTime Field
CallbackInteractionAttributeName Class See Also Send Feedback
The actual time at which this callback left snooze and re-entered the ACD queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackSnoozeActualWakeupTime
Visual Basic
Public Shared ReadOnly CallbackSnoozeActualWakeupTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackSnoozed Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackSnoozed Field
CallbackInteractionAttributeName Class See Also Send Feedback
Whether this callback is snoozed or not.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackSnoozed
Visual Basic
Public Shared ReadOnly CallbackSnoozed As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackSnoozeEndTime Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackSnoozeEndTime Field
CallbackInteractionAttributeName Class See Also Send Feedback
The desired time at which this callback should leave snooze and re-enter the ACD queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackSnoozeEndTime
Visual Basic
Public Shared ReadOnly CallbackSnoozeEndTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackSnoozeStartTime Field

[image]

IceLib Technical Reference
CallbackInteractionAttributeName..::..CallbackSnoozeStartTime Field
CallbackInteractionAttributeName Class See Also Send Feedback
The time at which this callback entered a snoozed state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallbackSnoozeStartTime
Visual Basic
Public Shared ReadOnly CallbackSnoozeStartTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackInteractionAttributeName Class
CallbackInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallbackInteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
CallbackInteractionAttributeName Methods
CallbackInteractionAttributeName Class See Also Send Feedback

The CallbackInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallbackInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


CallbackInteractionParameters Class

[image]

IceLib Technical Reference
CallbackInteractionParameters Class
Members See Also Send Feedback
Provides details when creating Callback Interactions via MakeCallbackInteraction(CallbackInteractionParameters).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CallbackInteractionParameters
Visual Basic
Public Class CallbackInteractionParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..CallbackInteractionParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackInteractionParameters Members

[image] [image]

IceLib Technical Reference
CallbackInteractionParameters Members
CallbackInteractionParameters Class Constructors Methods Properties See Also Send Feedback

The CallbackInteractionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | CallbackInteractionParameters | Initializes a new instance of the CallbackInteractionParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of CallbackInteractionParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets the additional interaction attributes.
Public property | CallbackMessage | The callback message.
Public property | CallbackPhone | The callback phone number.
Public property | ScopedQueueName | Gets the scoped queue name.

See Also

CallbackInteractionParameters Class
ININ.IceLib.Interactions Namespace


CallbackInteractionParameters Constructor

[image]

IceLib Technical Reference
CallbackInteractionParameters Constructor
CallbackInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallbackInteractionParameters class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackInteractionParameters(
    string scopedQueueName,
    string callbackPhone,
    string callbackMessage,
    Dictionary<string, string> additionalAttributes
)
Visual Basic
Public Sub New ( _
    scopedQueueName As String, _
    callbackPhone As String, _
    callbackMessage As String, _
    additionalAttributes As Dictionary(Of String, String) _
)

Parameters

scopedQueueName
Type: System..::..String
The scoped name of the queue to which to add the callback interaction.
callbackPhone
Type: System..::..String
The callback phone number.
callbackMessage
Type: System..::..String
The callback message.
additionalAttributes
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
Additional attributes to use to construct the callback.

Remarks

Valid additional attributes include RemoteName, RemoteAddress, RemoteId, LocalName, LocalAddress and LocalId.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Class
CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackInteractionParameters Methods

[image] [image]

IceLib Technical Reference
CallbackInteractionParameters Methods
CallbackInteractionParameters Class See Also Send Feedback

The CallbackInteractionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of CallbackInteractionParameters. (Overrides Object..::..ToString()()()().)

See Also

CallbackInteractionParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
CallbackInteractionParameters..::..ToString Method
CallbackInteractionParameters Class See Also Send Feedback
Gets the string representation of CallbackInteractionParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Class
CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackInteractionParameters Properties

[image] [image]

IceLib Technical Reference
CallbackInteractionParameters Properties
CallbackInteractionParameters Class See Also Send Feedback

The CallbackInteractionParameters type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets the additional interaction attributes.
Public property | CallbackMessage | The callback message.
Public property | CallbackPhone | The callback phone number.
Public property | ScopedQueueName | Gets the scoped queue name.

See Also

CallbackInteractionParameters Class
ININ.IceLib.Interactions Namespace


AdditionalAttributes Property

[image]

IceLib Technical Reference
CallbackInteractionParameters..::..AdditionalAttributes Property
CallbackInteractionParameters Class See Also Send Feedback
Gets the additional interaction attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Dictionary<string, string> AdditionalAttributes { get; }
Visual Basic
Public ReadOnly Property AdditionalAttributes As Dictionary(Of String, String)
    Get

Field Value

The additional interaction attributes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Class
CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackMessage Property

[image]

IceLib Technical Reference
CallbackInteractionParameters..::..CallbackMessage Property
CallbackInteractionParameters Class See Also Send Feedback
The callback message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallbackMessage { get; set; }
Visual Basic
Public Property CallbackMessage As String
    Get
    Set

Field Value

The callback message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Class
CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackPhone Property

[image]

IceLib Technical Reference
CallbackInteractionParameters..::..CallbackPhone Property
CallbackInteractionParameters Class See Also Send Feedback
The callback phone number.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallbackPhone { get; set; }
Visual Basic
Public Property CallbackPhone As String
    Get
    Set

Field Value

The callback phone name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Class
CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


ScopedQueueName Property

[image]

IceLib Technical Reference
CallbackInteractionParameters..::..ScopedQueueName Property
CallbackInteractionParameters Class See Also Send Feedback
Gets the scoped queue name.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ScopedQueueName { get; }
Visual Basic
Public ReadOnly Property ScopedQueueName As String
    Get

Field Value

The scoped queue name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CallbackInteractionParameters Class
CallbackInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackSetCompletionParameters Class

[image]

IceLib Technical Reference
CallbackSetCompletionParameters Class
Members See Also Send Feedback
Provides details when completing a callback via CallbackInteraction's SetCompletion method.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CallbackSetCompletionParameters
Visual Basic
Public Class CallbackSetCompletionParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..CallbackSetCompletionParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackSetCompletionParameters Members
ININ.IceLib.Interactions Namespace


CallbackSetCompletionParameters Members

[image] [image]

IceLib Technical Reference
CallbackSetCompletionParameters Members
CallbackSetCompletionParameters Class Constructors Methods Properties See Also Send Feedback

The CallbackSetCompletionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | CallbackSetCompletionParameters | Initializes a new instance of the CallbackSetCompletionParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Completion | Gets the CallbackCompletion for this callback attempt.

See Also

CallbackSetCompletionParameters Class
ININ.IceLib.Interactions Namespace


CallbackSetCompletionParameters Constructor

[image]

IceLib Technical Reference
CallbackSetCompletionParameters Constructor
CallbackSetCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallbackSetCompletionParameters class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackSetCompletionParameters(
    CallbackCompletion completion
)
Visual Basic
Public Sub New ( _
    completion As CallbackCompletion _
)

Parameters

completion
Type: ININ.IceLib.Interactions..::..CallbackCompletion
The CallbackCompletion for this callback attempt.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackSetCompletionParameters Class
CallbackSetCompletionParameters Members
ININ.IceLib.Interactions Namespace


CallbackSetCompletionParameters Methods

[image] [image]

IceLib Technical Reference
CallbackSetCompletionParameters Methods
CallbackSetCompletionParameters Class See Also Send Feedback

The CallbackSetCompletionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

CallbackSetCompletionParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
CallbackSetCompletionParameters..::..ToString Method
CallbackSetCompletionParameters Class See Also Send Feedback

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackSetCompletionParameters Class
CallbackSetCompletionParameters Members
ININ.IceLib.Interactions Namespace


CallbackSetCompletionParameters Properties

[image] [image]

IceLib Technical Reference
CallbackSetCompletionParameters Properties
CallbackSetCompletionParameters Class See Also Send Feedback

The CallbackSetCompletionParameters type exposes the following members.

Properties

 | Name | Description
Public property | Completion | Gets the CallbackCompletion for this callback attempt.

See Also

CallbackSetCompletionParameters Class
ININ.IceLib.Interactions Namespace


Completion Property

[image]

IceLib Technical Reference
CallbackSetCompletionParameters..::..Completion Property
CallbackSetCompletionParameters Class See Also Send Feedback
Gets the CallbackCompletion for this callback attempt.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackCompletion Completion { get; private set; }
Visual Basic
Public Property Completion As CallbackCompletion
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallbackSetCompletionParameters Class
CallbackSetCompletionParameters Members
ININ.IceLib.Interactions Namespace


CallInteraction Class

[image]

IceLib Technical Reference
CallInteraction Class
Members See Also Send Feedback
Represents a call within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CallInteraction : Interaction
Visual Basic
Public Class CallInteraction _
    Inherits Interaction

Remarks

This class provides the ability to play digits, play audio, and stop all audio for the call interaction.

  • To play digits, call the PlayDigits(String) or PlayDigitsAsync(String, AsyncCompletedEventHandler, Object) methods. When the asynchronous play digits operation completes, it invokes the completedCallback delegate.

  • To play audio, call the PlayWaveAudio(String, Boolean, Boolean) or PlayWaveAudioAsync(String, Boolean, Boolean, AsyncCompletedEventHandler, Object) methods. When the asynchronous play audio operation completes, it invokes the completedCallback delegate.

Note
The asynchronous methods are preferred since the above operations can be lengthy.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..CallInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Members
ININ.IceLib.Interactions Namespace


CallInteraction Members

[image] [image]

IceLib Technical Reference
CallInteraction Members
CallInteraction Class Constructors Methods Properties Events See Also Send Feedback

The CallInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | CallInteraction | Initializes a new instance of the CallInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | PlayDigits | Plays the digits to the CallInteraction.
Public method | PlayDigitsAsync | Asynchronously plays the digits to the CallInteraction.
Public method | PlayWaveAudio | Plays a server-located WAV file into the call.
Public method | PlayWaveAudioAsync | Asynchronously plays a server-located WAV file into the call.
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopAllWaveAudio | Stops all wave audio playback on this call.
Public method | StopAllWaveAudioAsync | Asynchronously stops all wave audio playback on this call.
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | PlayWaveAudioComplete | Occurs when audio played by PlayWaveAudio(String, Boolean, Boolean) is completed.
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

CallInteraction Class
ININ.IceLib.Interactions Namespace


CallInteraction Constructor

[image]

IceLib Technical Reference
CallInteraction Constructor
CallInteraction Class See Also Send Feedback
Initializes a new instance of the CallInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


CallInteraction Methods

[image] [image]

IceLib Technical Reference
CallInteraction Methods
CallInteraction Class See Also Send Feedback

The CallInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | PlayDigits | Plays the digits to the CallInteraction.
Public method | PlayDigitsAsync | Asynchronously plays the digits to the CallInteraction.
Public method | PlayWaveAudio | Plays a server-located WAV file into the call.
Public method | PlayWaveAudioAsync | Asynchronously plays a server-located WAV file into the call.
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopAllWaveAudio | Stops all wave audio playback on this call.
Public method | StopAllWaveAudioAsync | Asynchronously stops all wave audio playback on this call.
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

CallInteraction Class
ININ.IceLib.Interactions Namespace


PlayDigits Method

[image]

IceLib Technical Reference
CallInteraction..::..PlayDigits Method
CallInteraction Class See Also Send Feedback
Plays the digits to the CallInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayDigits(
    string digits
)
Visual Basic
Public Sub PlayDigits ( _
    digits As String _
)

Parameters

digits
Type: System..::..String
The digits.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


PlayDigitsAsync Method

[image]

IceLib Technical Reference
CallInteraction..::..PlayDigitsAsync Method
CallInteraction Class See Also Send Feedback
Asynchronously plays the digits to the CallInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayDigitsAsync(
    string digits,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PlayDigitsAsync ( _
    digits As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

digits
Type: System..::..String
The digits.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


PlayWaveAudio Method

[image]

IceLib Technical Reference
CallInteraction..::..PlayWaveAudio Method
CallInteraction Class See Also Send Feedback
Plays a server-located WAV file into the call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayWaveAudio(
    string fileName,
    bool isRemoteFile,
    bool enableDigits
)
Visual Basic
Public Sub PlayWaveAudio ( _
    fileName As String, _
    isRemoteFile As Boolean, _
    enableDigits As Boolean _
)

Parameters

fileName
Type: System..::..String
The name of a WAV file to play. If this file is located locally, this must be the full path to the file. If it is located remotely, this must be the result of calling NewRemoteFileName(ServerFileType) or NewRemoteFileName(ServerFileType, String).
isRemoteFile
Type: System..::..Boolean
Whether the specified file is located locally (and needs to be uploaded) or is located on the server.
enableDigits
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) to enable playing of digits into the call to skip forward and backwards, falseFalsefalsefalse (False in Visual Basic) to ignore digits.

Remarks

When playback is complete, the PlayWaveAudioComplete event will be fired.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


PlayWaveAudioAsync Method

[image]

IceLib Technical Reference
CallInteraction..::..PlayWaveAudioAsync Method
CallInteraction Class See Also Send Feedback
Asynchronously plays a server-located WAV file into the call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayWaveAudioAsync(
    string fileName,
    bool isRemoteFile,
    bool enableDigits,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PlayWaveAudioAsync ( _
    fileName As String, _
    isRemoteFile As Boolean, _
    enableDigits As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

fileName
Type: System..::..String
The name of a WAV file to play. If this file is located locally, this must be the full path to the file. If it is located remotely, this must be the result of calling NewRemoteFileName(ServerFileType) or NewRemoteFileName(ServerFileType, String).
isRemoteFile
Type: System..::..Boolean
Whether the specified file is located locally (and needs to be uploaded) or is located on the server.
enableDigits
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) to enable playing of digits into the call to skip forward and backwards, falseFalsefalsefalse (False in Visual Basic) to ignore digits.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When playback is complete, the PlayWaveAudioComplete event will be fired.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


StopAllWaveAudio Method

[image]

IceLib Technical Reference
CallInteraction..::..StopAllWaveAudio Method
CallInteraction Class See Also Send Feedback
Stops all wave audio playback on this call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopAllWaveAudio()
Visual Basic
Public Sub StopAllWaveAudio

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


StopAllWaveAudioAsync Method

[image]

IceLib Technical Reference
CallInteraction..::..StopAllWaveAudioAsync Method
CallInteraction Class See Also Send Feedback
Asynchronously stops all wave audio playback on this call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopAllWaveAudioAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopAllWaveAudioAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


CallInteraction Properties

[image] [image]

IceLib Technical Reference
CallInteraction Properties
CallInteraction Class See Also Send Feedback

The CallInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

CallInteraction Class
ININ.IceLib.Interactions Namespace


CallInteraction Events

[image] [image]

IceLib Technical Reference
CallInteraction Events
CallInteraction Class See Also Send Feedback

The CallInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | PlayWaveAudioComplete | Occurs when audio played by PlayWaveAudio(String, Boolean, Boolean) is completed.
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

CallInteraction Class
ININ.IceLib.Interactions Namespace


PlayWaveAudioComplete Event

[image]

IceLib Technical Reference
CallInteraction..::..PlayWaveAudioComplete Event
CallInteraction Class See Also Send Feedback
Occurs when audio played by PlayWaveAudio(String, Boolean, Boolean) is completed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler PlayWaveAudioComplete
Visual Basic
Public Event PlayWaveAudioComplete As EventHandler

Remarks

This event will only occur after a play wave audio request has been made. (See PlayWaveAudio(String, Boolean, Boolean) or PlayWaveAudioAsync(String, Boolean, Boolean, AsyncCompletedEventHandler, Object).)
Note
All event handlers should be added before calling PlayWaveAudio(String, Boolean, Boolean) or PlayWaveAudioAsync(String, Boolean, Boolean, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteraction Class
CallInteraction Members
ININ.IceLib.Interactions Namespace


CallInteractionParameters Class

[image]

IceLib Technical Reference
CallInteractionParameters Class
Members See Also Send Feedback
Provides details when making a call via InteractionsManager's MakeCall method.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CallInteractionParameters
Visual Basic
Public Class CallInteractionParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..CallInteractionParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallInteractionParameters Members

[image] [image]

IceLib Technical Reference
CallInteractionParameters Members
CallInteractionParameters Class Constructors Methods Properties See Also Send Feedback

The CallInteractionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | CallInteractionParameters(String) | Initializes a new instance of the CallInteractionParameters class. The on behalf of workgroup and call made stage are initialized with default values.
Public method | CallInteractionParameters(QueueId) | Initializes a new instance of the CallInteractionParameters class using a QueueId to specify the target. The on behalf of workgroup and call made stage are initialized with default values.
Public method | CallInteractionParameters(String, CallMadeStage) | Initializes a new instance of the CallInteractionParameters class using the default value for the on behalf of workgroup.
Public method | CallInteractionParameters(QueueId, CallMadeStage) | Initializes a new instance of the CallInteractionParameters using a QueueId to specify the target and the default value for the on behalf of workgroup.
Public method | CallInteractionParameters(String, String, CallMadeStage) | Initializes a new instance of the CallInteractionParameters class.
Public method | CallInteractionParameters(QueueId, String, CallMadeStage) | Initializes a new instance of the CallInteractionParameters class, using a QueueId to specify the target.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of CallInteractionParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AccountCodeId | Gets or sets the account code ID.
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | CallAnalysisType | Gets or sets the Call analysis type.
Public property | CallbackInteractionId | Gets or sets the ID of the callback initiating this call.
Public property | CallMadeStage | Gets or sets the call made stage.
Public property | Notes | Gets or sets the notes.
Public property | OnBehalfOfWorkgroup | Gets or sets the on behalf of workgroup.
Public property | Target | Gets or sets the target.

See Also

CallInteractionParameters Class
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor

[image] [image]

IceLib Technical Reference
CallInteractionParameters Constructor
CallInteractionParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallInteractionParameters(String) | Initializes a new instance of the CallInteractionParameters class. The on behalf of workgroup and call made stage are initialized with default values.
Public method | CallInteractionParameters(QueueId) | Initializes a new instance of the CallInteractionParameters class using a QueueId to specify the target. The on behalf of workgroup and call made stage are initialized with default values.
Public method | CallInteractionParameters(String, CallMadeStage) | Initializes a new instance of the CallInteractionParameters class using the default value for the on behalf of workgroup.
Public method | CallInteractionParameters(QueueId, CallMadeStage) | Initializes a new instance of the CallInteractionParameters using a QueueId to specify the target and the default value for the on behalf of workgroup.
Public method | CallInteractionParameters(String, String, CallMadeStage) | Initializes a new instance of the CallInteractionParameters class.
Public method | CallInteractionParameters(QueueId, String, CallMadeStage) | Initializes a new instance of the CallInteractionParameters class, using a QueueId to specify the target.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor (String)

[image]

IceLib Technical Reference
CallInteractionParameters Constructor (String)
CallInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallInteractionParameters class. The on behalf of workgroup and call made stage are initialized with default values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteractionParameters(
    string target
)
Visual Basic
Public Sub New ( _
    target As String _
)

Parameters

target
Type: System..::..String
The target.

Remarks

The target can be set to Attendant DS values. Refer to Target for more information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
CallInteractionParameters Overload
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor (QueueId)

[image]

IceLib Technical Reference
CallInteractionParameters Constructor (QueueId)
CallInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallInteractionParameters class using a QueueId to specify the target. The on behalf of workgroup and call made stage are initialized with default values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteractionParameters(
    QueueId target
)
Visual Basic
Public Sub New ( _
    target As QueueId _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
CallInteractionParameters Overload
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor (String, CallMadeStage)

[image]

IceLib Technical Reference
CallInteractionParameters Constructor (String, CallMadeStage)
CallInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallInteractionParameters class using the default value for the on behalf of workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteractionParameters(
    string target,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As String, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: System..::..String
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Remarks

The target can be set to Attendant DS values. Refer to Target for more information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
CallInteractionParameters Overload
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor (QueueId, CallMadeStage)

[image]

IceLib Technical Reference
CallInteractionParameters Constructor (QueueId, CallMadeStage)
CallInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallInteractionParameters using a QueueId to specify the target and the default value for the on behalf of workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteractionParameters(
    QueueId target,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As QueueId, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
CallInteractionParameters Overload
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor (String, String, CallMadeStage)

[image]

IceLib Technical Reference
CallInteractionParameters Constructor (String, String, CallMadeStage)
CallInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallInteractionParameters class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteractionParameters(
    string target,
    string onBehalfOfWorkgroup,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As String, _
    onBehalfOfWorkgroup As String, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: System..::..String
The target.
onBehalfOfWorkgroup
Type: System..::..String
The on behalf of workgroup (or nullNothingnullptra null reference (Nothing in Visual Basic)).
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Remarks

The target can be set to Attendant DS values. Refer to Target for more information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
CallInteractionParameters Overload
ININ.IceLib.Interactions Namespace


CallInteractionParameters Constructor (QueueId, String, CallMadeStage)

[image]

IceLib Technical Reference
CallInteractionParameters Constructor (QueueId, String, CallMadeStage)
CallInteractionParameters Class See Also Send Feedback
Initializes a new instance of the CallInteractionParameters class, using a QueueId to specify the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallInteractionParameters(
    QueueId target,
    string onBehalfOfWorkgroup,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As QueueId, _
    onBehalfOfWorkgroup As String, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.
onBehalfOfWorkgroup
Type: System..::..String
The on behalf of workgroup (or nullNothingnullptra null reference (Nothing in Visual Basic)).
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
CallInteractionParameters Overload
ININ.IceLib.Interactions Namespace


CallInteractionParameters Methods

[image] [image]

IceLib Technical Reference
CallInteractionParameters Methods
CallInteractionParameters Class See Also Send Feedback

The CallInteractionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of CallInteractionParameters. (Overrides Object..::..ToString()()()().)

See Also

CallInteractionParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
CallInteractionParameters..::..ToString Method
CallInteractionParameters Class See Also Send Feedback
Gets the string representation of CallInteractionParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallInteractionParameters Properties

[image] [image]

IceLib Technical Reference
CallInteractionParameters Properties
CallInteractionParameters Class See Also Send Feedback

The CallInteractionParameters type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets or sets the account code ID.
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | CallAnalysisType | Gets or sets the Call analysis type.
Public property | CallbackInteractionId | Gets or sets the ID of the callback initiating this call.
Public property | CallMadeStage | Gets or sets the call made stage.
Public property | Notes | Gets or sets the notes.
Public property | OnBehalfOfWorkgroup | Gets or sets the on behalf of workgroup.
Public property | Target | Gets or sets the target.

See Also

CallInteractionParameters Class
ININ.IceLib.Interactions Namespace


AccountCodeId Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..AccountCodeId Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the account code ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCodeId { get; set; }
Visual Basic
Public Property AccountCodeId As String
    Get
    Set

Field Value

The account code ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


AdditionalAttributes Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..AdditionalAttributes Property
CallInteractionParameters Class See Also Send Feedback
Gets a collection which can be used to set additional attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> AdditionalAttributes { get; internal set; }
Visual Basic
Public Property AdditionalAttributes As IDictionary(Of String, String)
    Get
    Friend Set

Field Value

The additional attributes collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallAnalysisType Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..CallAnalysisType Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the Call analysis type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallAnalysisType CallAnalysisType { get; set; }
Visual Basic
Public Property CallAnalysisType As CallAnalysisType
    Get
    Set

Field Value

Specifies whether call analysis needs to be performed on this call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallbackInteractionId Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..CallbackInteractionId Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the ID of the callback initiating this call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId CallbackInteractionId { get; set; }
Visual Basic
Public Property CallbackInteractionId As InteractionId
    Get
    Set

Field Value

The ID of the initiating callback, or Empty if this call was not made through a callback.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallMadeStage Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..CallMadeStage Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the call made stage.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallMadeStage CallMadeStage { get; set; }
Visual Basic
Public Property CallMadeStage As CallMadeStage
    Get
    Set

Field Value

Specifies when to raise the CallMade event.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


Notes Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..Notes Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the notes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; set; }
Visual Basic
Public Property Notes As String
    Get
    Set

Field Value

The notes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


OnBehalfOfWorkgroup Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..OnBehalfOfWorkgroup Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the on behalf of workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OnBehalfOfWorkgroup { get; set; }
Visual Basic
Public Property OnBehalfOfWorkgroup As String
    Get
    Set

Field Value

The on behalf of workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


Target Property

[image]

IceLib Technical Reference
CallInteractionParameters..::..Target Property
CallInteractionParameters Class See Also Send Feedback
Gets or sets the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set

Field Value

The target.

Remarks

This property can be set to Attendant DS values such as "${ATTENDANT}\000061l". Those values can be retrieved from the ININ.IceLib.People.LookupEntry.Extension property of the return value for ININ.IceLib.People.PeopleManager.GetLookupEntries.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallInteractionParameters Class
CallInteractionParameters Members
ININ.IceLib.Interactions Namespace


CallMadeEventArgs Class

[image]

IceLib Technical Reference
CallMadeEventArgs Class
Members See Also Send Feedback
Provides data for the CallMade event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CallMadeEventArgs : CancelEventArgs
Visual Basic
Public Class CallMadeEventArgs _
    Inherits CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
ININ.IceLib.Interactions..::..CallMadeEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallMadeEventArgs Members
ININ.IceLib.Interactions Namespace


CallMadeEventArgs Members

[image] [image]

IceLib Technical Reference
CallMadeEventArgs Members
CallMadeEventArgs Class Constructors Methods Properties See Also Send Feedback

The CallMadeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CallMadeEventArgs | Initializes a new instance of the CallMadeEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Interaction | Gets the Interaction associated with the change.

See Also

CallMadeEventArgs Class
ININ.IceLib.Interactions Namespace


CallMadeEventArgs Constructor

[image]

IceLib Technical Reference
CallMadeEventArgs Constructor
CallMadeEventArgs Class See Also Send Feedback
Initializes a new instance of the CallMadeEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallMadeEventArgs(
    Interaction interaction
)
Visual Basic
Public Sub New ( _
    interaction As Interaction _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallMadeEventArgs Class
CallMadeEventArgs Members
ININ.IceLib.Interactions Namespace


CallMadeEventArgs Methods

[image] [image]

IceLib Technical Reference
CallMadeEventArgs Methods
CallMadeEventArgs Class See Also Send Feedback

The CallMadeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallMadeEventArgs Class
ININ.IceLib.Interactions Namespace


CallMadeEventArgs Properties

[image] [image]

IceLib Technical Reference
CallMadeEventArgs Properties
CallMadeEventArgs Class See Also Send Feedback

The CallMadeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Interaction | Gets the Interaction associated with the change.

See Also

CallMadeEventArgs Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
CallMadeEventArgs..::..Interaction Property
CallMadeEventArgs Class See Also Send Feedback
Gets the Interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CallMadeEventArgs Class
CallMadeEventArgs Members
ININ.IceLib.Interactions Namespace


CallMadeStage Enumeration

[image]

IceLib Technical Reference
CallMadeStage Enumeration
See Also Send Feedback
Specifies constants indicating when the CallMade event should be raised.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CallMadeStage
Visual Basic
Public Enumeration CallMadeStage

Members

Member name | Value | Description
None | 0 | No make call operation should be performed.
Allocated | 1 | The call has been allocated.
Started | 2 | The call has started.
Completed | 3 | The call has completed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


ChatInteraction Class

[image]

IceLib Technical Reference
ChatInteraction Class
Members See Also Send Feedback
Represents a chat within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ChatInteraction : Interaction
Visual Basic
Public Class ChatInteraction _
    Inherits Interaction

Remarks

Chat interactions allow users to interact by sending and receiving text, files, or URLs.

  • To start watching a chat interaction call ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object). When the asynchronous chat start watch completes it invokes the completedCallback delegate.

  • To stop watching a chat interaction call ChatStopWatching()()()() or ChatStopWatchingAsync(AsyncCompletedEventHandler, Object). When the asynchronous chat stop watch completes, it invokes the completedCallback delegate.

  • To add members to the chat call AddMembers(array<InteractionId>[]()[][]) or AddMembersAsync(array<InteractionId>[]()[][], AsyncCompletedEventHandler, Object) providing an array of InteractionId for all members to add to this chat. When the asynchronous add members operation completes it invokes the completedCallback delegate.

  • To set an indicator to the members that a member is typing call the SetTypingIndicator(Boolean) or SetTypingIndicatorAsync(Boolean, AsyncCompletedEventHandler, Object) providing a flag to indicate if the typing indicator is visible or not. When the asynchronous set typing indicator operation completes it invokes the completedCallback delegate.

  • To send text to members of this chat, call the SendText(String) or SendTextAsync(String, AsyncCompletedEventHandler, Object) methods with the text to send. When the asynchronous send text operation completes it invokes the completedCallback delegate.

  • To send a URL to the chat members, call the SendUrl(Uri) or SendUrlAsync(Uri, AsyncCompletedEventHandler, Object) methods. When the asynchronous send URL operation completes it invokes the completedCallback delegate.

  • To send a file to chat members call SendFile(String) or SendFileAsync(String, AsyncCompletedEventHandler, Object). When the asynchronous send file operation completes it invokes the completedCallback delegate.

  • Calling ChatStartWatching or ChatStartWatchingAsync when a watch is already in place, or calling ChatStopWatching or ChatStartWatchingAsync when a watch is not in place raises an InvalidOperationException.

Note
The asynchronous versions of the above methods are preferred since they can be lengthy operations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..ChatInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatInteraction Members

[image] [image]

IceLib Technical Reference
ChatInteraction Members
ChatInteraction Class Constructors Methods Properties Events See Also Send Feedback

The ChatInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | ChatInteraction | Initializes a new instance of the ChatInteraction class.

Methods

 | Name | Description
Public method | AddMembers | Adds interactions to the chat.
Public method | AddMembersAsync | Asynchronously adds interactions to the chat.
Public method | AddUser | Adds user to the chat.
Public method | AddUserAsync | Asynchronously adds user to the chat.
Public method | AddUsers | Adds users to the chat.
Public method | AddUsersAsync | Asynchronously adds users to the chat.
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChatIsWatching | Determines whether an chat watch is active.
Public method | ChatStartWatching | Starts watching the chat interaction.
Public method | ChatStartWatchingAsync | Asynchronously starts watching the chat interaction.
Public method | ChatStopWatching | Stops watching the chats interaction.
Public method | ChatStopWatchingAsync | Asynchronously stops watching the chats interaction.
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the chat history-returned in an array of ChatText objects.
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetMembers | Gets the members.
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SendFile(String) | Sends a file to the chat members.
Public method | SendFile(Stream, String) | Sends a file to the chat members.
Public method | SendFileAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously sends a file to the chat members.
Public method | SendFileAsync(Stream, String, AsyncCompletedEventHandler, Object) | Asynchronously sends a file to the chat members.
Public method | SendText | Sends text to the chat members.
Public method | SendTextAsync | Asynchronously sends text to the chat members.
Public method | SendUrl | Sends a Url to the chat members.
Public method | SendUrlAsync | Asynchronously sends a Url to the chat members.
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetTypingIndicator | Sets the typing indicator for the Session user.
Public method | SetTypingIndicatorAsync | Asynchronously sets the typing indicator for the Session user.
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | ChatMemberAdded | Occurs when a ChatMember is added to the ChatInteraction.
Public event | ChatMemberChanged | Occurs when a ChatMember's DisplayName property changes.
Public event | ChatMemberRemoved | Occurs when a ChatMember is removed from the ChatInteraction.
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)
Public event | TextAdded | Occurs when text is added to the chat.
Public event | TypingChanged | Occurs when a ChatMember's IsTyping property changes.
Public event | UrlAdded | Occurs when a URL is added to the chat.

See Also

ChatInteraction Class
ININ.IceLib.Interactions Namespace


ChatInteraction Constructor

[image]

IceLib Technical Reference
ChatInteraction Constructor
ChatInteraction Class See Also Send Feedback
Initializes a new instance of the ChatInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatInteraction Methods

[image] [image]

IceLib Technical Reference
ChatInteraction Methods
ChatInteraction Class See Also Send Feedback

The ChatInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AddMembers | Adds interactions to the chat.
Public method | AddMembersAsync | Asynchronously adds interactions to the chat.
Public method | AddUser | Adds user to the chat.
Public method | AddUserAsync | Asynchronously adds user to the chat.
Public method | AddUsers | Adds users to the chat.
Public method | AddUsersAsync | Asynchronously adds users to the chat.
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChatIsWatching | Determines whether an chat watch is active.
Public method | ChatStartWatching | Starts watching the chat interaction.
Public method | ChatStartWatchingAsync | Asynchronously starts watching the chat interaction.
Public method | ChatStopWatching | Stops watching the chats interaction.
Public method | ChatStopWatchingAsync | Asynchronously stops watching the chats interaction.
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Gets the chat history-returned in an array of ChatText objects.
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetMembers | Gets the members.
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SendFile(String) | Sends a file to the chat members.
Public method | SendFile(Stream, String) | Sends a file to the chat members.
Public method | SendFileAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously sends a file to the chat members.
Public method | SendFileAsync(Stream, String, AsyncCompletedEventHandler, Object) | Asynchronously sends a file to the chat members.
Public method | SendText | Sends text to the chat members.
Public method | SendTextAsync | Asynchronously sends text to the chat members.
Public method | SendUrl | Sends a Url to the chat members.
Public method | SendUrlAsync | Asynchronously sends a Url to the chat members.
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetTypingIndicator | Sets the typing indicator for the Session user.
Public method | SetTypingIndicatorAsync | Asynchronously sets the typing indicator for the Session user.
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

ChatInteraction Class
ININ.IceLib.Interactions Namespace


AddMembers Method

[image]

IceLib Technical Reference
ChatInteraction..::..AddMembers Method
ChatInteraction Class See Also Send Feedback
Adds interactions to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddMembers(
    InteractionId[] interactionsToAdd
)
Visual Basic
Public Sub AddMembers ( _
    interactionsToAdd As InteractionId() _
)

Parameters

interactionsToAdd
Type: array< ININ.IceLib.Interactions..::..InteractionId >[]()[][]
The interactions to add.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


AddMembersAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..AddMembersAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously adds interactions to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddMembersAsync(
    InteractionId[] interactionsToAdd,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AddMembersAsync ( _
    interactionsToAdd As InteractionId(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactionsToAdd
Type: array< ININ.IceLib.Interactions..::..InteractionId >[]()[][]
The interactions to add.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


AddUser Method

[image]

IceLib Technical Reference
ChatInteraction..::..AddUser Method
ChatInteraction Class See Also Send Feedback
Adds user to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUser(
    string userIdToAdd
)
Visual Basic
Public Sub AddUser ( _
    userIdToAdd As String _
)

Parameters

userIdToAdd
Type: System..::..String
The user to add.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The string parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


AddUserAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..AddUserAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously adds user to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUserAsync(
    string userIdToAdd,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AddUserAsync ( _
    userIdToAdd As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIdToAdd
Type: System..::..String
The user to add.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


AddUsers Method

[image]

IceLib Technical Reference
ChatInteraction..::..AddUsers Method
ChatInteraction Class See Also Send Feedback
Adds users to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUsers(
    string[] userIdsToAdd
)
Visual Basic
Public Sub AddUsers ( _
    userIdsToAdd As String() _
)

Parameters

userIdsToAdd
Type: array<System..::..String>[]()[][]
The users to add.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


AddUsersAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..AddUsersAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously adds users to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUsersAsync(
    string[] userIdsToAdd,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AddUsersAsync ( _
    userIdsToAdd As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIdsToAdd
Type: array<System..::..String>[]()[][]
The users to add.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatIsWatching Method

[image]

IceLib Technical Reference
ChatInteraction..::..ChatIsWatching Method
ChatInteraction Class See Also Send Feedback
Determines whether an chat watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ChatIsWatching()
Visual Basic
Public Function ChatIsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if an chat watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether an chat watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatStartWatching Method

[image]

IceLib Technical Reference
ChatInteraction..::..ChatStartWatching Method
ChatInteraction Class See Also Send Feedback
Starts watching the chat interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChatStartWatching()
Visual Basic
Public Sub ChatStartWatching

Remarks

Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatStartWatchingAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..ChatStartWatchingAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously starts watching the chat interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChatStartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChatStartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatStopWatching Method

[image]

IceLib Technical Reference
ChatInteraction..::..ChatStopWatching Method
ChatInteraction Class See Also Send Feedback
Stops watching the chats interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChatStopWatching()
Visual Basic
Public Sub ChatStopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatStopWatchingAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..ChatStopWatchingAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously stops watching the chats interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChatStopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChatStopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


GetHistory Method

[image]

IceLib Technical Reference
ChatInteraction..::..GetHistory Method
ChatInteraction Class See Also Send Feedback
Gets the chat history-returned in an array of ChatText objects.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ChatText> GetHistory()
Visual Basic
Public Function GetHistory As ReadOnlyCollection(Of ChatText)

Return Value

The ChatText array.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The interaction is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


GetMembers Method

[image]

IceLib Technical Reference
ChatInteraction..::..GetMembers Method
ChatInteraction Class See Also Send Feedback
Gets the members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ChatMember> GetMembers()
Visual Basic
Public Function GetMembers As ReadOnlyCollection(Of ChatMember)

Return Value

The ChatMember array.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The interaction is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SendFile Method

[image] [image]

IceLib Technical Reference
ChatInteraction..::..SendFile Method
ChatInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendFile(String) | Sends a file to the chat members.
Public method | SendFile(Stream, String) | Sends a file to the chat members.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SendFile Method (String)

[image]

IceLib Technical Reference
ChatInteraction..::..SendFile Method (String)
ChatInteraction Class See Also Send Feedback
Sends a file to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendFile(
    string path
)
Visual Basic
Public Sub SendFile ( _
    path As String _
)

Parameters

path
Type: System..::..String
The path of the file to send.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
SendFile Overload
ININ.IceLib.Interactions Namespace


SendFile Method (Stream, String)

[image]

IceLib Technical Reference
ChatInteraction..::..SendFile Method (Stream, String)
ChatInteraction Class See Also Send Feedback
Sends a file to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendFile(
    Stream fileStream,
    string fileName
)
Visual Basic
Public Sub SendFile ( _
    fileStream As Stream, _
    fileName As String _
)

Parameters

fileStream
Type: System.IO..::..Stream
A stream connected to the file to send.
fileName
Type: System..::..String
The name of the file to send.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
SendFile Overload
ININ.IceLib.Interactions Namespace


SendFileAsync Method

[image] [image]

IceLib Technical Reference
ChatInteraction..::..SendFileAsync Method
ChatInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendFileAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously sends a file to the chat members.
Public method | SendFileAsync(Stream, String, AsyncCompletedEventHandler, Object) | Asynchronously sends a file to the chat members.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SendFileAsync Method (String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ChatInteraction..::..SendFileAsync Method (String, AsyncCompletedEventHandler, Object)
ChatInteraction Class See Also Send Feedback
Asynchronously sends a file to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendFileAsync(
    string path,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SendFileAsync ( _
    path As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

path
Type: System..::..String
The path of the file to send.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
SendFileAsync Overload
ININ.IceLib.Interactions Namespace


SendFileAsync Method (Stream, String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
ChatInteraction..::..SendFileAsync Method (Stream, String, AsyncCompletedEventHandler, Object)
ChatInteraction Class See Also Send Feedback
Asynchronously sends a file to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendFileAsync(
    Stream fileStream,
    string fileName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SendFileAsync ( _
    fileStream As Stream, _
    fileName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

fileStream
Type: System.IO..::..Stream
A stream connected to the file to send.
fileName
Type: System..::..String
The name of the file to send.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
SendFileAsync Overload
ININ.IceLib.Interactions Namespace


SendText Method

[image]

IceLib Technical Reference
ChatInteraction..::..SendText Method
ChatInteraction Class See Also Send Feedback
Sends text to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendText(
    string message
)
Visual Basic
Public Sub SendText ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SendTextAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..SendTextAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously sends text to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendTextAsync(
    string message,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SendTextAsync ( _
    message As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

message
Type: System..::..String
The message.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SendUrl Method

[image]

IceLib Technical Reference
ChatInteraction..::..SendUrl Method
ChatInteraction Class See Also Send Feedback
Sends a Url to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendUrl(
    Uri uri
)
Visual Basic
Public Sub SendUrl ( _
    uri As Uri _
)

Parameters

uri
Type: System..::..Uri
The url to send.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SendUrlAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..SendUrlAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously sends a Url to the chat members.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendUrlAsync(
    Uri uri,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SendUrlAsync ( _
    uri As Uri, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

uri
Type: System..::..Uri
The url to send.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SetTypingIndicator Method

[image]

IceLib Technical Reference
ChatInteraction..::..SetTypingIndicator Method
ChatInteraction Class See Also Send Feedback
Sets the typing indicator for the Session user.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTypingIndicator(
    bool isTyping
)
Visual Basic
Public Sub SetTypingIndicator ( _
    isTyping As Boolean _
)

Parameters

isTyping
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) user is typing.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


SetTypingIndicatorAsync Method

[image]

IceLib Technical Reference
ChatInteraction..::..SetTypingIndicatorAsync Method
ChatInteraction Class See Also Send Feedback
Asynchronously sets the typing indicator for the Session user.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetTypingIndicatorAsync(
    bool isTyping,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetTypingIndicatorAsync ( _
    isTyping As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

isTyping
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) user is typing.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatInteraction Properties

[image] [image]

IceLib Technical Reference
ChatInteraction Properties
ChatInteraction Class See Also Send Feedback

The ChatInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

ChatInteraction Class
ININ.IceLib.Interactions Namespace


ChatInteraction Events

[image] [image]

IceLib Technical Reference
ChatInteraction Events
ChatInteraction Class See Also Send Feedback

The ChatInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | ChatMemberAdded | Occurs when a ChatMember is added to the ChatInteraction.
Public event | ChatMemberChanged | Occurs when a ChatMember's DisplayName property changes.
Public event | ChatMemberRemoved | Occurs when a ChatMember is removed from the ChatInteraction.
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)
Public event | TextAdded | Occurs when text is added to the chat.
Public event | TypingChanged | Occurs when a ChatMember's IsTyping property changes.
Public event | UrlAdded | Occurs when a URL is added to the chat.

See Also

ChatInteraction Class
ININ.IceLib.Interactions Namespace


ChatMemberAdded Event

[image]

IceLib Technical Reference
ChatInteraction..::..ChatMemberAdded Event
ChatInteraction Class See Also Send Feedback
Occurs when a ChatMember is added to the ChatInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ChatMemberEventArgs> ChatMemberAdded
Visual Basic
Public Event ChatMemberAdded As EventHandler(Of ChatMemberEventArgs)

Remarks

This event will only occur if the chat is being watched. To start watching the chat call either the ChatStartWatching()()()() method or the ChatStartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatMemberChanged Event

[image]

IceLib Technical Reference
ChatInteraction..::..ChatMemberChanged Event
ChatInteraction Class See Also Send Feedback
Occurs when a ChatMember's DisplayName property changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ChatMemberEventArgs> ChatMemberChanged
Visual Basic
Public Event ChatMemberChanged As EventHandler(Of ChatMemberEventArgs)

Remarks

This event will only occur if the chat is being watched. To start watching the chat call either the ChatStartWatching()()()() method or the ChatStartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatMemberRemoved Event

[image]

IceLib Technical Reference
ChatInteraction..::..ChatMemberRemoved Event
ChatInteraction Class See Also Send Feedback
Occurs when a ChatMember is removed from the ChatInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ChatMemberEventArgs> ChatMemberRemoved
Visual Basic
Public Event ChatMemberRemoved As EventHandler(Of ChatMemberEventArgs)

Remarks

This event will only occur if the chat is being watched. To start watching the chat call either the ChatStartWatching()()()() method or the ChatStartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


TextAdded Event

[image]

IceLib Technical Reference
ChatInteraction..::..TextAdded Event
ChatInteraction Class See Also Send Feedback
Occurs when text is added to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ChatUpdateEventArgs> TextAdded
Visual Basic
Public Event TextAdded As EventHandler(Of ChatUpdateEventArgs)

Remarks

This event will only occur if the chat is being watched. To start watching the chat call either the ChatStartWatching()()()() method or the ChatStartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


TypingChanged Event

[image]

IceLib Technical Reference
ChatInteraction..::..TypingChanged Event
ChatInteraction Class See Also Send Feedback
Occurs when a ChatMember's IsTyping property changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ChatMemberEventArgs> TypingChanged
Visual Basic
Public Event TypingChanged As EventHandler(Of ChatMemberEventArgs)

Remarks

This event will only occur if the chat is being watched. To start watching the chat call either the ChatStartWatching()()()() method or the ChatStartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


UrlAdded Event

[image]

IceLib Technical Reference
ChatInteraction..::..UrlAdded Event
ChatInteraction Class See Also Send Feedback
Occurs when a URL is added to the chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ChatUpdateEventArgs> UrlAdded
Visual Basic
Public Event UrlAdded As EventHandler(Of ChatUpdateEventArgs)

Remarks

This event will only occur if the chat is being watched. To start watching the chat call either the ChatStartWatching()()()() method or the ChatStartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling ChatStartWatching()()()() or ChatStartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatInteraction Class
ChatInteraction Members
ININ.IceLib.Interactions Namespace


ChatMember Class

[image]

IceLib Technical Reference
ChatMember Class
Members See Also Send Feedback
Represents a member (person participating) in a ChatInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ChatMember
Visual Basic
Public Class ChatMember

Remarks

Chat interactions in IC allow users to send and receive text, files, or URLs. Chat members have a type (usually internal or external), a display name, an associated interaction ID, and a typing indicator. There is also an explicit "System Member" that represents the IC system chat text.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ChatMember

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Members
ININ.IceLib.Interactions Namespace


ChatMember Members

[image] [image]

IceLib Technical Reference
ChatMember Members
ChatMember Class Methods Fields Properties See Also Send Feedback

The ChatMember type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ChatMember) | Determines whether the specified ChatMember is equal to the current ChatMember.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
SystemMember | Represents the Chat System as a member.

Properties

 | Name | Description
Public property | ChatMemberType | Gets the type of the chat member.
Public property | DisplayName | Gets the display name of the member.
Public property | InteractionId | Gets the interaction ID of the member.
Public property | IsTyping | Gets a value indicating whether this ChatMember is typing.
Public property | UserId | Gets the user ID of the chat member.

See Also

ChatMember Class
ININ.IceLib.Interactions Namespace


ChatMember Fields

[image] [image]

IceLib Technical Reference
ChatMember Fields
ChatMember Class See Also Send Feedback

The ChatMember type exposes the following members.

Fields

Name | Description
SystemMember | Represents the Chat System as a member.

See Also

ChatMember Class
ININ.IceLib.Interactions Namespace


SystemMember Field

[image]

IceLib Technical Reference
ChatMember..::..SystemMember Field
ChatMember Class See Also Send Feedback
Represents the Chat System as a member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly ChatMember SystemMember
Visual Basic
Public Shared ReadOnly SystemMember As ChatMember

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


ChatMember Methods

[image] [image]

IceLib Technical Reference
ChatMember Methods
ChatMember Class See Also Send Feedback

The ChatMember type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ChatMember) | Determines whether the specified ChatMember is equal to the current ChatMember.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ChatMember Class
ININ.IceLib.Interactions Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ChatMember..::..Equals Method
ChatMember Class See Also Send Feedback
Determines whether two ChatMember instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ChatMember) | Determines whether the specified ChatMember is equal to the current ChatMember.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ChatMember..::..Equals Method (Object)
ChatMember Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
Equals Overload
ININ.IceLib.Interactions Namespace


Equals Method (ChatMember)

[image]

IceLib Technical Reference
ChatMember..::..Equals Method (ChatMember)
ChatMember Class See Also Send Feedback
Determines whether the specified ChatMember is equal to the current ChatMember.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ChatMember other
)
Visual Basic
Public Function Equals ( _
    other As ChatMember _
) As Boolean

Parameters

other
Type: ININ.IceLib.Interactions..::..ChatMember
The ChatMember to compare with the current ChatMember.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified ChatMember is equal to the current ChatMember; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
Equals Overload
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ChatMember..::..GetHashCode Method
ChatMember Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
ChatMember..::..ToString Method
ChatMember Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


ChatMember Properties

[image] [image]

IceLib Technical Reference
ChatMember Properties
ChatMember Class See Also Send Feedback

The ChatMember type exposes the following members.

Properties

 | Name | Description
Public property | ChatMemberType | Gets the type of the chat member.
Public property | DisplayName | Gets the display name of the member.
Public property | InteractionId | Gets the interaction ID of the member.
Public property | IsTyping | Gets a value indicating whether this ChatMember is typing.
Public property | UserId | Gets the user ID of the chat member.

See Also

ChatMember Class
ININ.IceLib.Interactions Namespace


ChatMemberType Property

[image]

IceLib Technical Reference
ChatMember..::..ChatMemberType Property
ChatMember Class See Also Send Feedback
Gets the type of the chat member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatMemberType ChatMemberType { get; internal set; }
Visual Basic
Public Property ChatMemberType As ChatMemberType
    Get
    Friend Set

Field Value

The type of the chat member.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


DisplayName Property

[image]

IceLib Technical Reference
ChatMember..::..DisplayName Property
ChatMember Class See Also Send Feedback
Gets the display name of the member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; internal set; }
Visual Basic
Public Property DisplayName As String
    Get
    Friend Set

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
ChatMember..::..InteractionId Property
ChatMember Class See Also Send Feedback
Gets the interaction ID of the member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


IsTyping Property

[image]

IceLib Technical Reference
ChatMember..::..IsTyping Property
ChatMember Class See Also Send Feedback
Gets a value indicating whether this ChatMember is typing.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsTyping { get; internal set; }
Visual Basic
Public Property IsTyping As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if typing; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


UserId Property

[image]

IceLib Technical Reference
ChatMember..::..UserId Property
ChatMember Class See Also Send Feedback
Gets the user ID of the chat member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; internal set; }
Visual Basic
Public Property UserId As String
    Get
    Friend Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

ChatMember Class
ChatMember Members
ININ.IceLib.Interactions Namespace


ChatMemberEventArgs Class

[image]

IceLib Technical Reference
ChatMemberEventArgs Class
Members See Also Send Feedback
Provides data for the ChatMemberAdded/Changed/Removed events of a ChatInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ChatMemberEventArgs : EventArgs
Visual Basic
Public Class ChatMemberEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..ChatMemberEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMemberEventArgs Members
ININ.IceLib.Interactions Namespace


ChatMemberEventArgs Members

[image] [image]

IceLib Technical Reference
ChatMemberEventArgs Members
ChatMemberEventArgs Class Constructors Methods Properties See Also Send Feedback

The ChatMemberEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ChatMemberEventArgs | Initializes a new instance of the ChatMemberEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChatMember | Gets the ChatMember associated with the change.

See Also

ChatMemberEventArgs Class
ININ.IceLib.Interactions Namespace


ChatMemberEventArgs Constructor

[image]

IceLib Technical Reference
ChatMemberEventArgs Constructor
ChatMemberEventArgs Class See Also Send Feedback
Initializes a new instance of the ChatMemberEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatMemberEventArgs(
    ChatMember chatMember
)
Visual Basic
Public Sub New ( _
    chatMember As ChatMember _
)

Parameters

chatMember
Type: ININ.IceLib.Interactions..::..ChatMember
The chat member.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMemberEventArgs Class
ChatMemberEventArgs Members
ININ.IceLib.Interactions Namespace


ChatMemberEventArgs Methods

[image] [image]

IceLib Technical Reference
ChatMemberEventArgs Methods
ChatMemberEventArgs Class See Also Send Feedback

The ChatMemberEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChatMemberEventArgs Class
ININ.IceLib.Interactions Namespace


ChatMemberEventArgs Properties

[image] [image]

IceLib Technical Reference
ChatMemberEventArgs Properties
ChatMemberEventArgs Class See Also Send Feedback

The ChatMemberEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChatMember | Gets the ChatMember associated with the change.

See Also

ChatMemberEventArgs Class
ININ.IceLib.Interactions Namespace


ChatMember Property

[image]

IceLib Technical Reference
ChatMemberEventArgs..::..ChatMember Property
ChatMemberEventArgs Class See Also Send Feedback
Gets the ChatMember associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatMember ChatMember { get; }
Visual Basic
Public ReadOnly Property ChatMember As ChatMember
    Get

Field Value

The chat member.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatMemberEventArgs Class
ChatMemberEventArgs Members
ININ.IceLib.Interactions Namespace


ChatMemberType Enumeration

[image]

IceLib Technical Reference
ChatMemberType Enumeration
See Also Send Feedback
Specifies constants indicating the whether a ChatMember is internal or external.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ChatMemberType
Visual Basic
Public Enumeration ChatMemberType

Members

Member name | Value | Description
None | 0 | There is no chat member type available.
SystemMember | 1 | The SystemMember.
ChatInteraction | 2 | The chat member associated with the ChatInteraction.
Internal | 3 | The chat member is internal.
External | 4 | The chat member is external.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


ChatText Class

[image]

IceLib Technical Reference
ChatText Class
Members See Also Send Feedback
Represents a single chat entry in a ChatInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ChatText
Visual Basic
Public Class ChatText

Remarks

The Text property of the ChatText object contains the text of a single entry in the chat history. To get all entries exchanged in the course of the chat, call the GetHistory()()()() method of the ChatInteraction class. It returns a read-only collection of ChatText objects.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ChatText

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatText Members
ININ.IceLib.Interactions Namespace


ChatText Members

[image] [image]

IceLib Technical Reference
ChatText Members
ChatText Class Methods Properties See Also Send Feedback

The ChatText type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChatMember | Gets the chat member.
Public property | Text | Gets the text.
Public property | Timestamp | Gets the timestamp for the text.

See Also

ChatText Class
ININ.IceLib.Interactions Namespace


ChatText Methods

[image] [image]

IceLib Technical Reference
ChatText Methods
ChatText Class See Also Send Feedback

The ChatText type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChatText Class
ININ.IceLib.Interactions Namespace


ChatText Properties

[image] [image]

IceLib Technical Reference
ChatText Properties
ChatText Class See Also Send Feedback

The ChatText type exposes the following members.

Properties

 | Name | Description
Public property | ChatMember | Gets the chat member.
Public property | Text | Gets the text.
Public property | Timestamp | Gets the timestamp for the text.

See Also

ChatText Class
ININ.IceLib.Interactions Namespace


ChatMember Property

[image]

IceLib Technical Reference
ChatText..::..ChatMember Property
ChatText Class See Also Send Feedback
Gets the chat member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatMember ChatMember { get; }
Visual Basic
Public ReadOnly Property ChatMember As ChatMember
    Get

Field Value

The chat member.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatText Class
ChatText Members
ININ.IceLib.Interactions Namespace


Text Property

[image]

IceLib Technical Reference
ChatText..::..Text Property
ChatText Class See Also Send Feedback
Gets the text.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get

Field Value

The text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatText Class
ChatText Members
ININ.IceLib.Interactions Namespace


Timestamp Property

[image]

IceLib Technical Reference
ChatText..::..Timestamp Property
ChatText Class See Also Send Feedback
Gets the timestamp for the text.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Timestamp { get; }
Visual Basic
Public ReadOnly Property Timestamp As DateTime
    Get

Field Value

The timestamp.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ChatText Class
ChatText Members
ININ.IceLib.Interactions Namespace


ChatUpdateEventArgs Class

[image]

IceLib Technical Reference
ChatUpdateEventArgs Class
Members See Also Send Feedback
Provides data for the ChatMemberAdded/Removed events of a ChatInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ChatUpdateEventArgs : EventArgs
Visual Basic
Public Class ChatUpdateEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..ChatUpdateEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


ChatUpdateEventArgs Members

[image] [image]

IceLib Technical Reference
ChatUpdateEventArgs Members
ChatUpdateEventArgs Class Constructors Methods Properties See Also Send Feedback

The ChatUpdateEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ChatUpdateEventArgs | Initializes a new instance of the ChatUpdateEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChatMember | Gets the ChatMember associated with the change.
Public property | Text | Gets the Text associated with the change (if any).
Public property | Url | Gets the Url associated with the change (if any).

See Also

ChatUpdateEventArgs Class
ININ.IceLib.Interactions Namespace


ChatUpdateEventArgs Constructor

[image]

IceLib Technical Reference
ChatUpdateEventArgs Constructor
ChatUpdateEventArgs Class See Also Send Feedback
Initializes a new instance of the ChatUpdateEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatUpdateEventArgs(
    ChatMember chatMember
)
Visual Basic
Public Sub New ( _
    chatMember As ChatMember _
)

Parameters

chatMember
Type: ININ.IceLib.Interactions..::..ChatMember
The chat member.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatUpdateEventArgs Class
ChatUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


ChatUpdateEventArgs Methods

[image] [image]

IceLib Technical Reference
ChatUpdateEventArgs Methods
ChatUpdateEventArgs Class See Also Send Feedback

The ChatUpdateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChatUpdateEventArgs Class
ININ.IceLib.Interactions Namespace


ChatUpdateEventArgs Properties

[image] [image]

IceLib Technical Reference
ChatUpdateEventArgs Properties
ChatUpdateEventArgs Class See Also Send Feedback

The ChatUpdateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChatMember | Gets the ChatMember associated with the change.
Public property | Text | Gets the Text associated with the change (if any).
Public property | Url | Gets the Url associated with the change (if any).

See Also

ChatUpdateEventArgs Class
ININ.IceLib.Interactions Namespace


ChatMember Property

[image]

IceLib Technical Reference
ChatUpdateEventArgs..::..ChatMember Property
ChatUpdateEventArgs Class See Also Send Feedback
Gets the ChatMember associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatMember ChatMember { get; }
Visual Basic
Public ReadOnly Property ChatMember As ChatMember
    Get

Field Value

The chat member.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatUpdateEventArgs Class
ChatUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


Text Property

[image]

IceLib Technical Reference
ChatUpdateEventArgs..::..Text Property
ChatUpdateEventArgs Class See Also Send Feedback
Gets the Text associated with the change (if any).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Text { get; internal set; }
Visual Basic
Public Property Text As String
    Get
    Friend Set

Field Value

The text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatUpdateEventArgs Class
ChatUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


Url Property

[image]

IceLib Technical Reference
ChatUpdateEventArgs..::..Url Property
ChatUpdateEventArgs Class See Also Send Feedback
Gets the Url associated with the change (if any).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Url { get; internal set; }
Visual Basic
Public Property Url As String
    Get
    Friend Set

Field Value

The URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ChatUpdateEventArgs Class
ChatUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceId Class

[image]

IceLib Technical Reference
ConferenceId Class
Members See Also Send Feedback
Identifies a Conference within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class ConferenceId : IComparable,
    IComparable<ConferenceId>
Visual Basic
<SerializableAttribute> _
Public Class ConferenceId _
    Implements IComparable, IComparable(Of ConferenceId)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ConferenceId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Members
ININ.IceLib.Interactions Namespace


ConferenceId Members

[image] [image]

IceLib Technical Reference
ConferenceId Members
ConferenceId Class Constructors Methods Operators Properties See Also Send Feedback

The ConferenceId type exposes the following members.

Constructors

 | Name | Description
Public method | ConferenceId(Int64) | Initializes a new instance of the ConferenceId class with the specified values.
Public method | ConferenceId(String) | Initializes a new instance of the ConferenceId class with the specified values.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(ConferenceId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ConferenceId) | Determines whether the specified ConferenceId is equal to the current ConferenceId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of ConferenceId are equal.
Inequality | Determines whether two instances of ConferenceId are not equal.

Properties

 | Name | Description
Public property | Id | Gets a numeric representation of the Conference ID.
Public property | RawId | Gets a numeric (non-CLS-compliant) representation of the Conference ID.

See Also

ConferenceId Class
ININ.IceLib.Interactions Namespace


ConferenceId Constructor

[image] [image]

IceLib Technical Reference
ConferenceId Constructor
ConferenceId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConferenceId(Int64) | Initializes a new instance of the ConferenceId class with the specified values.
Public method | ConferenceId(String) | Initializes a new instance of the ConferenceId class with the specified values.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


ConferenceId Constructor (Int64)

[image]

IceLib Technical Reference
ConferenceId Constructor (Int64)
ConferenceId Class See Also Send Feedback
Initializes a new instance of the ConferenceId class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId(
    long id
)
Visual Basic
Public Sub New ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | id was invalid, it must be in the range of 0 and MaxValue inclusive.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ConferenceId Overload
ININ.IceLib.Interactions Namespace


ConferenceId Constructor (String)

[image]

IceLib Technical Reference
ConferenceId Constructor (String)
ConferenceId Class See Also Send Feedback
Initializes a new instance of the ConferenceId class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ConferenceId Overload
ININ.IceLib.Interactions Namespace


ConferenceId Methods

[image] [image]

IceLib Technical Reference
ConferenceId Methods
ConferenceId Class See Also Send Feedback

The ConferenceId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(ConferenceId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ConferenceId) | Determines whether the specified ConferenceId is equal to the current ConferenceId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ConferenceId Class
ININ.IceLib.Interactions Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
ConferenceId..::..CompareTo Method
ConferenceId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(ConferenceId) | Compares the current object with another object of the same type.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


CompareTo Method (Object)

[image]

IceLib Technical Reference
ConferenceId..::..CompareTo Method (Object)
ConferenceId Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


CompareTo Method (ConferenceId)

[image]

IceLib Technical Reference
ConferenceId..::..CompareTo Method (ConferenceId)
ConferenceId Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    ConferenceId other
)
Visual Basic
Public Function CompareTo ( _
    other As ConferenceId _
) As Integer

Parameters

other
Type: ININ.IceLib.Interactions..::..ConferenceId
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ConferenceId..::..Equals Method
ConferenceId Class See Also Send Feedback
Determines whether two ConferenceId instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ConferenceId) | Determines whether the specified ConferenceId is equal to the current ConferenceId.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ConferenceId..::..Equals Method (Object)
ConferenceId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
Equals Overload
ININ.IceLib.Interactions Namespace


Equals Method (ConferenceId)

[image]

IceLib Technical Reference
ConferenceId..::..Equals Method (ConferenceId)
ConferenceId Class See Also Send Feedback
Determines whether the specified ConferenceId is equal to the current ConferenceId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ConferenceId other
)
Visual Basic
Public Function Equals ( _
    other As ConferenceId _
) As Boolean

Parameters

other
Type: ININ.IceLib.Interactions..::..ConferenceId
The ConferenceId to compare with the current ConferenceId.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified ConferenceId is equal to the current ConferenceId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
Equals Overload
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ConferenceId..::..GetHashCode Method
ConferenceId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
ConferenceId..::..ToString Method
ConferenceId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


ConferenceId Operators

[image] [image]

IceLib Technical Reference
ConferenceId Operators
ConferenceId Class See Also Send Feedback

The ConferenceId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of ConferenceId are equal.
Inequality | Determines whether two instances of ConferenceId are not equal.

See Also

ConferenceId Class
ININ.IceLib.Interactions Namespace


Equality Operator

[image]

IceLib Technical Reference
ConferenceId..::..Equality Operator
ConferenceId Class See Also Send Feedback
Determines whether two instances of ConferenceId are equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ConferenceId a,
    ConferenceId b
)
Visual Basic
Public Shared Operator = ( _
    a As ConferenceId, _
    b As ConferenceId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..ConferenceId
The first ConferenceId to compare.
b
Type: ININ.IceLib.Interactions..::..ConferenceId
The second ConferenceId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


Inequality Operator

[image]

IceLib Technical Reference
ConferenceId..::..Inequality Operator
ConferenceId Class See Also Send Feedback
Determines whether two instances of ConferenceId are not equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ConferenceId a,
    ConferenceId b
)
Visual Basic
Public Shared Operator <> ( _
    a As ConferenceId, _
    b As ConferenceId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..ConferenceId
The first ConferenceId to compare.
b
Type: ININ.IceLib.Interactions..::..ConferenceId
The second ConferenceId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


ConferenceId Properties

[image] [image]

IceLib Technical Reference
ConferenceId Properties
ConferenceId Class See Also Send Feedback

The ConferenceId type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets a numeric representation of the Conference ID.
Public property | RawId | Gets a numeric (non-CLS-compliant) representation of the Conference ID.

See Also

ConferenceId Class
ININ.IceLib.Interactions Namespace


Id Property

[image]

IceLib Technical Reference
ConferenceId..::..Id Property
ConferenceId Class See Also Send Feedback
Gets a numeric representation of the Conference ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long Id { get; }
Visual Basic
Public ReadOnly Property Id As Long
    Get

Field Value

The conference ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


RawId Property

[image]

IceLib Technical Reference
ConferenceId..::..RawId Property
ConferenceId Class See Also Send Feedback
Gets a numeric (non-CLS-compliant) representation of the Conference ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[CLSCompliantAttribute(false)]
public uint RawId { get; }
Visual Basic
<CLSCompliantAttribute(False)> _
Public ReadOnly Property RawId As UInteger
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceId Class
ConferenceId Members
ININ.IceLib.Interactions Namespace


ConferenceInteractionAttributesEventArgs Class

[image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs Class
Members See Also Send Feedback
Provides data for the ConferenceInteractionChanged event of an InteractionQueue object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConferenceInteractionAttributesEventArgs : EventArgs
Visual Basic
Public Class ConferenceInteractionAttributesEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..ConferenceInteractionAttributesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceInteractionAttributesEventArgs Members

[image] [image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs Members
ConferenceInteractionAttributesEventArgs Class Constructors Methods Properties See Also Send Feedback

The ConferenceInteractionAttributesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConferenceInteractionAttributesEventArgs | Initializes a new instance of the InteractionAttributesEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets the Conference ID associated with the change.
Public property | ConferenceItem | Gets the Conference item associated with the change.
Public property | Interaction | Gets the Interaction associated with the change.
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

ConferenceInteractionAttributesEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceInteractionAttributesEventArgs Constructor

[image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs Constructor
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback
Initializes a new instance of the InteractionAttributesEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceInteractionAttributesEventArgs(
    Interaction interaction,
    Interaction conferenceItem,
    ConferenceId conferenceId,
    IList<string> interactionAttributeNames
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    conferenceItem As Interaction, _
    conferenceId As ConferenceId, _
    interactionAttributeNames As IList(Of String) _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
conferenceItem
Type: ININ.IceLib.Interactions..::..Interaction
The conference item.
conferenceId
Type: ININ.IceLib.Interactions..::..ConferenceId
The interaction conference.
interactionAttributeNames
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The interaction attribute names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionAttributesEventArgs Class
ConferenceInteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceInteractionAttributesEventArgs Methods

[image] [image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs Methods
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback

The ConferenceInteractionAttributesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConferenceInteractionAttributesEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceInteractionAttributesEventArgs Properties

[image] [image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs Properties
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback

The ConferenceInteractionAttributesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets the Conference ID associated with the change.
Public property | ConferenceItem | Gets the Conference item associated with the change.
Public property | Interaction | Gets the Interaction associated with the change.
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

ConferenceInteractionAttributesEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceId Property

[image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs..::..ConferenceId Property
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback
Gets the Conference ID associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId ConferenceId { get; }
Visual Basic
Public ReadOnly Property ConferenceId As ConferenceId
    Get

Field Value

The conference ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionAttributesEventArgs Class
ConferenceInteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceItem Property

[image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs..::..ConferenceItem Property
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback
Gets the Conference item associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ConferenceItem { get; }
Visual Basic
Public ReadOnly Property ConferenceItem As Interaction
    Get

Field Value

The conference item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionAttributesEventArgs Class
ConferenceInteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs..::..Interaction Property
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback
Gets the Interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionAttributesEventArgs Class
ConferenceInteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionAttributeNames Property

[image]

IceLib Technical Reference
ConferenceInteractionAttributesEventArgs..::..InteractionAttributeNames Property
ConferenceInteractionAttributesEventArgs Class See Also Send Feedback
Gets the attribute names associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> InteractionAttributeNames { get; }
Visual Basic
Public ReadOnly Property InteractionAttributeNames As ReadOnlyCollection(Of String)
    Get

Field Value

The interaction attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionAttributesEventArgs Class
ConferenceInteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceInteractionEventArgs Class

[image]

IceLib Technical Reference
ConferenceInteractionEventArgs Class
Members See Also Send Feedback
Provides data for the events involving a single Interaction conference member.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConferenceInteractionEventArgs : EventArgs
Visual Basic
Public Class ConferenceInteractionEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..ConferenceInteractionEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceInteractionEventArgs Members

[image] [image]

IceLib Technical Reference
ConferenceInteractionEventArgs Members
ConferenceInteractionEventArgs Class Constructors Methods Properties See Also Send Feedback

The ConferenceInteractionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConferenceInteractionEventArgs | Initializes a new instance of the ConferenceInteractionEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets the Conference associated with the change.
Public property | ConferenceItem | Gets the Conference item associated with the change.
Public property | Interaction | Gets the Interaction associated with the change.

See Also

ConferenceInteractionEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceInteractionEventArgs Constructor

[image]

IceLib Technical Reference
ConferenceInteractionEventArgs Constructor
ConferenceInteractionEventArgs Class See Also Send Feedback
Initializes a new instance of the ConferenceInteractionEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceInteractionEventArgs(
    Interaction interaction,
    Interaction conferenceItem,
    ConferenceId conferenceId
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    conferenceItem As Interaction, _
    conferenceId As ConferenceId _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
conferenceItem
Type: ININ.IceLib.Interactions..::..Interaction
The conference item.
conferenceId
Type: ININ.IceLib.Interactions..::..ConferenceId
The interaction conference.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionEventArgs Class
ConferenceInteractionEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceInteractionEventArgs Methods

[image] [image]

IceLib Technical Reference
ConferenceInteractionEventArgs Methods
ConferenceInteractionEventArgs Class See Also Send Feedback

The ConferenceInteractionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConferenceInteractionEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceInteractionEventArgs Properties

[image] [image]

IceLib Technical Reference
ConferenceInteractionEventArgs Properties
ConferenceInteractionEventArgs Class See Also Send Feedback

The ConferenceInteractionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets the Conference associated with the change.
Public property | ConferenceItem | Gets the Conference item associated with the change.
Public property | Interaction | Gets the Interaction associated with the change.

See Also

ConferenceInteractionEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceId Property

[image]

IceLib Technical Reference
ConferenceInteractionEventArgs..::..ConferenceId Property
ConferenceInteractionEventArgs Class See Also Send Feedback
Gets the Conference associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId ConferenceId { get; }
Visual Basic
Public ReadOnly Property ConferenceId As ConferenceId
    Get

Field Value

The conference ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionEventArgs Class
ConferenceInteractionEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceItem Property

[image]

IceLib Technical Reference
ConferenceInteractionEventArgs..::..ConferenceItem Property
ConferenceInteractionEventArgs Class See Also Send Feedback
Gets the Conference item associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ConferenceItem { get; }
Visual Basic
Public ReadOnly Property ConferenceItem As Interaction
    Get

Field Value

The conference item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionEventArgs Class
ConferenceInteractionEventArgs Members
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
ConferenceInteractionEventArgs..::..Interaction Property
ConferenceInteractionEventArgs Class See Also Send Feedback
Gets the Interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ConferenceInteractionEventArgs Class
ConferenceInteractionEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceItemData Class

[image]

IceLib Technical Reference
ConferenceItemData Class
Members See Also Send Feedback
Contains information about a conference item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConferenceItemData
Visual Basic
Public Class ConferenceItemData

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ConferenceItemData

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConferenceItemData Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..GetConferenceContents()()()()


ConferenceItemData Members

[image] [image]

IceLib Technical Reference
ConferenceItemData Members
ConferenceItemData Class Methods Properties See Also Send Feedback

The ConferenceItemData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets the conference ID that this conference item is for.
Public property | Interaction | Gets the member interaction that is associated with the ParentInteraction.
Public property | ParentInteraction | Gets the parent interaction that this conference item is for.

See Also

ConferenceItemData Class
ININ.IceLib.Interactions Namespace


ConferenceItemData Methods

[image] [image]

IceLib Technical Reference
ConferenceItemData Methods
ConferenceItemData Class See Also Send Feedback

The ConferenceItemData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConferenceItemData Class
ININ.IceLib.Interactions Namespace


ConferenceItemData Properties

[image] [image]

IceLib Technical Reference
ConferenceItemData Properties
ConferenceItemData Class See Also Send Feedback

The ConferenceItemData type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets the conference ID that this conference item is for.
Public property | Interaction | Gets the member interaction that is associated with the ParentInteraction.
Public property | ParentInteraction | Gets the parent interaction that this conference item is for.

See Also

ConferenceItemData Class
ININ.IceLib.Interactions Namespace


ConferenceId Property

[image]

IceLib Technical Reference
ConferenceItemData..::..ConferenceId Property
ConferenceItemData Class See Also Send Feedback
Gets the conference ID that this conference item is for.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId ConferenceId { get; }
Visual Basic
Public ReadOnly Property ConferenceId As ConferenceId
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConferenceItemData Class
ConferenceItemData Members
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
ConferenceItemData..::..Interaction Property
ConferenceItemData Class See Also Send Feedback
Gets the member interaction that is associated with the ParentInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConferenceItemData Class
ConferenceItemData Members
ININ.IceLib.Interactions Namespace


ParentInteraction Property

[image]

IceLib Technical Reference
ConferenceItemData..::..ParentInteraction Property
ConferenceItemData Class See Also Send Feedback
Gets the parent interaction that this conference item is for.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ParentInteraction { get; }
Visual Basic
Public ReadOnly Property ParentInteraction As Interaction
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConferenceItemData Class
ConferenceItemData Members
ININ.IceLib.Interactions Namespace


ConsultTransfer Class

[image]

IceLib Technical Reference
ConsultTransfer Class
Members See Also Send Feedback
Represents a consult transfer between a caller, agent, and consult.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConsultTransfer
Visual Basic
Public Class ConsultTransfer

Remarks

An agent may seek to transfer a caller to a consult as part of an interaction. The agent would first make the consult transfer, which will allow the agent to speak to either the caller, the consult, or both. The agent may conclude the consult transfer by either completing the transfer, resulting in the caller speaking to the consult. Alternatively, the agent may cancel the transfer, resulting in the caller speaking with the agent.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ConsultTransfer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ConsultTransfer Members

[image] [image]

IceLib Technical Reference
ConsultTransfer Members
ConsultTransfer Class Methods Properties Events See Also Send Feedback

The ConsultTransfer type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels the consult transfer, resulting in the caller speaking to the agent.
Public method | CancelAsync | Asynchronous request to cancel the consult transfer.
Public method | ChangeSpeakers | Changes the speakers on the consult transfer.
Public method | ChangeSpeakersAsync | Asynchronous request to change the speakers on the consult transfer.
Public method | Conclude | Completes the consult transfer, resulting in the caller speaking to the consult.
Public method | ConcludeAsync | Asynchronous request to complete the consult transfer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConsultTransferFromInteraction | Gets the consult transfer from interaction.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallerInteractionId | Gets the InteractionId associated with this ConsultTransfer. This value represents the original Caller interaction ID.
Public property | ConsultInteractionId | Gets the InteractionId of the ConsultTransfer. This value represents the interaction ID of the consult transfer.
Public property | SpeakingTo | Gets the parties the agent is speaking to on this consult transfer.

Events

 | Name | Description
Public event | SpeakersChanged | Occurs when the speakers in the ConsultTransfer change.

See Also

ConsultTransfer Class
ININ.IceLib.Interactions Namespace


ConsultTransfer Methods

[image] [image]

IceLib Technical Reference
ConsultTransfer Methods
ConsultTransfer Class See Also Send Feedback

The ConsultTransfer type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels the consult transfer, resulting in the caller speaking to the agent.
Public method | CancelAsync | Asynchronous request to cancel the consult transfer.
Public method | ChangeSpeakers | Changes the speakers on the consult transfer.
Public method | ChangeSpeakersAsync | Asynchronous request to change the speakers on the consult transfer.
Public method | Conclude | Completes the consult transfer, resulting in the caller speaking to the consult.
Public method | ConcludeAsync | Asynchronous request to complete the consult transfer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConsultTransferFromInteraction | Gets the consult transfer from interaction.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConsultTransfer Class
ININ.IceLib.Interactions Namespace


Cancel Method

[image]

IceLib Technical Reference
ConsultTransfer..::..Cancel Method
ConsultTransfer Class See Also Send Feedback
Cancels the consult transfer, resulting in the caller speaking to the agent.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


CancelAsync Method

[image]

IceLib Technical Reference
ConsultTransfer..::..CancelAsync Method
ConsultTransfer Class See Also Send Feedback
Asynchronous request to cancel the consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CancelAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ChangeSpeakers Method

[image]

IceLib Technical Reference
ConsultTransfer..::..ChangeSpeakers Method
ConsultTransfer Class See Also Send Feedback
Changes the speakers on the consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeSpeakers(
    ConsultTransferParticipants speakTo
)
Visual Basic
Public Sub ChangeSpeakers ( _
    speakTo As ConsultTransferParticipants _
)

Parameters

speakTo
Type: ININ.IceLib.Interactions..::..ConsultTransferParticipants
The speakers to participate with the agent.

Remarks

When using Agent for the speakTo value, neither the consult nor the caller will be speaking. Additionally, the agent is always a speaker on a consult, if Agent is omitted, it will be added back by default. When using Caller for the speakTo value, only the agent and the caller will be speaking. When using Consult for the speakTo value, only the agent and the consult will be speaking. When using All for the speakTo value, all parties will be speaking.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified speak to is not from the ConsultTransferParticipants enumeration. The specified speak to is set to None.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ChangeSpeakersAsync Method

[image]

IceLib Technical Reference
ConsultTransfer..::..ChangeSpeakersAsync Method
ConsultTransfer Class See Also Send Feedback
Asynchronous request to change the speakers on the consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeSpeakersAsync(
    ConsultTransferParticipants speakTo,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeSpeakersAsync ( _
    speakTo As ConsultTransferParticipants, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

speakTo
Type: ININ.IceLib.Interactions..::..ConsultTransferParticipants
The participants to speak with.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When using Agent for the speakTo value, neither the consult nor the caller will be speaking. Additionally, the agent is always a speaker on a consult, if Agent is omitted, it will be added back by default. When using Caller for the speakTo value, only the agent and the caller will be speaking. When using Consult for the speakTo value, only the agent and the consult will be speaking. When using All for the speakTo value, all parties will be speaking.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified speak to is not from the ConsultTransferParticipants enumeration. The specified speak to is set to None.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


Conclude Method

[image]

IceLib Technical Reference
ConsultTransfer..::..Conclude Method
ConsultTransfer Class See Also Send Feedback
Completes the consult transfer, resulting in the caller speaking to the consult.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Conclude()
Visual Basic
Public Sub Conclude

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ConcludeAsync Method

[image]

IceLib Technical Reference
ConsultTransfer..::..ConcludeAsync Method
ConsultTransfer Class See Also Send Feedback
Asynchronous request to complete the consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConcludeAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ConcludeAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


GetConsultTransferFromInteraction Method

[image]

IceLib Technical Reference
ConsultTransfer..::..GetConsultTransferFromInteraction Method
ConsultTransfer Class See Also Send Feedback
Gets the consult transfer from interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ConsultTransfer GetConsultTransferFromInteraction(
    Interaction interaction
)
Visual Basic
Public Shared Function GetConsultTransferFromInteraction ( _
    interaction As Interaction _
) As ConsultTransfer

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.

Return Value

The consult transfer, if the interaction is a consult transfer, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If an interaction is a consult transfer the ConsultCallId attribute will be set. Use this method to recover the ConsultTransfer instance from the interaction.

This method is intended to be used to recover a Consult Transfer from an Interaction in case of a client crash. If you need to create a new Consult Transfer, use the MakeConsultTransfer(ConsultTransferParameters) method instead.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..MakeConsultTransfer(ConsultTransferParameters)


ConsultTransfer Properties

[image] [image]

IceLib Technical Reference
ConsultTransfer Properties
ConsultTransfer Class See Also Send Feedback

The ConsultTransfer type exposes the following members.

Properties

 | Name | Description
Public property | CallerInteractionId | Gets the InteractionId associated with this ConsultTransfer. This value represents the original Caller interaction ID.
Public property | ConsultInteractionId | Gets the InteractionId of the ConsultTransfer. This value represents the interaction ID of the consult transfer.
Public property | SpeakingTo | Gets the parties the agent is speaking to on this consult transfer.

See Also

ConsultTransfer Class
ININ.IceLib.Interactions Namespace


CallerInteractionId Property

[image]

IceLib Technical Reference
ConsultTransfer..::..CallerInteractionId Property
ConsultTransfer Class See Also Send Feedback
Gets the InteractionId associated with this ConsultTransfer. This value represents the original Caller interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId CallerInteractionId { get; private set; }
Visual Basic
Public Property CallerInteractionId As InteractionId
    Get
    Private Set

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ConsultInteractionId Property

[image]

IceLib Technical Reference
ConsultTransfer..::..ConsultInteractionId Property
ConsultTransfer Class See Also Send Feedback
Gets the InteractionId of the ConsultTransfer. This value represents the interaction ID of the consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId ConsultInteractionId { get; private set; }
Visual Basic
Public Property ConsultInteractionId As InteractionId
    Get
    Private Set

Field Value

The consult interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


SpeakingTo Property

[image]

IceLib Technical Reference
ConsultTransfer..::..SpeakingTo Property
ConsultTransfer Class See Also Send Feedback
Gets the parties the agent is speaking to on this consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransferParticipants SpeakingTo { get; private set; }
Visual Basic
Public Property SpeakingTo As ConsultTransferParticipants
    Get
    Private Set

Field Value

The parties the agent is speaking to.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ConsultTransfer Events

[image] [image]

IceLib Technical Reference
ConsultTransfer Events
ConsultTransfer Class See Also Send Feedback

The ConsultTransfer type exposes the following members.

Events

 | Name | Description
Public event | SpeakersChanged | Occurs when the speakers in the ConsultTransfer change.

See Also

ConsultTransfer Class
ININ.IceLib.Interactions Namespace


SpeakersChanged Event

[image]

IceLib Technical Reference
ConsultTransfer..::..SpeakersChanged Event
ConsultTransfer Class See Also Send Feedback
Occurs when the speakers in the ConsultTransfer change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EventArgs> SpeakersChanged
Visual Basic
Public Event SpeakersChanged As EventHandler(Of EventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransfer Class
ConsultTransfer Members
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Class

[image]

IceLib Technical Reference
ConsultTransferParameters Class
Members See Also Send Feedback
Provides details when creating Consult Transfers via MakeConsultTransfer(ConsultTransferParameters).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConsultTransferParameters
Visual Basic
Public Class ConsultTransferParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ConsultTransferParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Members

[image] [image]

IceLib Technical Reference
ConsultTransferParameters Members
ConsultTransferParameters Class Constructors Methods Properties See Also Send Feedback

The ConsultTransferParameters type exposes the following members.

Constructors

 | Name | Description
Public method | ConsultTransferParameters(String, InteractionId) | Initializes a new instance of the ConsultTransferParameters using a QueueId to specify the target, and initializing the CallMadeStage to the default value.
Public method | ConsultTransferParameters(QueueId, InteractionId) | Initializes a new instance of the ConsultTransferParameters using the default value for the CallMadeStage.
Public method | ConsultTransferParameters(String, InteractionId, CallMadeStage) | Initializes a new instance of the ConsultTransferParameters.
Public method | ConsultTransferParameters(QueueId, InteractionId, CallMadeStage) | Initializes a new instance of the ConsultTransferParameters using a QueueId to specify the target.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of ConsultTransferParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | CallerInteractionId | Gets the InteractionId associated with this consult transfer. This value represents the original Caller interaction ID.
Public property | CallMadeStage | Gets or sets the call made stage.
Public property | Target | Gets or sets the target.

See Also

ConsultTransferParameters Class
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Constructor

[image] [image]

IceLib Technical Reference
ConsultTransferParameters Constructor
ConsultTransferParameters Class See Also Send Feedback
Initializes a new instance of the ConsultTransferParameters.

Overload List

 | Name | Description
Public method | ConsultTransferParameters(String, InteractionId) | Initializes a new instance of the ConsultTransferParameters using a QueueId to specify the target, and initializing the CallMadeStage to the default value.
Public method | ConsultTransferParameters(QueueId, InteractionId) | Initializes a new instance of the ConsultTransferParameters using the default value for the CallMadeStage.
Public method | ConsultTransferParameters(String, InteractionId, CallMadeStage) | Initializes a new instance of the ConsultTransferParameters.
Public method | ConsultTransferParameters(QueueId, InteractionId, CallMadeStage) | Initializes a new instance of the ConsultTransferParameters using a QueueId to specify the target.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Constructor (String, InteractionId)

[image]

IceLib Technical Reference
ConsultTransferParameters Constructor (String, InteractionId)
ConsultTransferParameters Class See Also Send Feedback
Initializes a new instance of the ConsultTransferParameters using a QueueId to specify the target, and initializing the CallMadeStage to the default value.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransferParameters(
    string target,
    InteractionId callerInteractionId
)
Visual Basic
Public Sub New ( _
    target As String, _
    callerInteractionId As InteractionId _
)

Parameters

target
Type: System..::..String
The target.
callerInteractionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId of the consult transfer.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ConsultTransferParameters Overload
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Constructor (QueueId, InteractionId)

[image]

IceLib Technical Reference
ConsultTransferParameters Constructor (QueueId, InteractionId)
ConsultTransferParameters Class See Also Send Feedback
Initializes a new instance of the ConsultTransferParameters using the default value for the CallMadeStage.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransferParameters(
    QueueId target,
    InteractionId callerInteractionId
)
Visual Basic
Public Sub New ( _
    target As QueueId, _
    callerInteractionId As InteractionId _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.
callerInteractionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId of the consult transfer.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ConsultTransferParameters Overload
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Constructor (String, InteractionId, CallMadeStage)

[image]

IceLib Technical Reference
ConsultTransferParameters Constructor (String, InteractionId, CallMadeStage)
ConsultTransferParameters Class See Also Send Feedback
Initializes a new instance of the ConsultTransferParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransferParameters(
    string target,
    InteractionId callerInteractionId,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As String, _
    callerInteractionId As InteractionId, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: System..::..String
The target.
callerInteractionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId associated with this consult transfer.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ConsultTransferParameters Overload
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Constructor (QueueId, InteractionId, CallMadeStage)

[image]

IceLib Technical Reference
ConsultTransferParameters Constructor (QueueId, InteractionId, CallMadeStage)
ConsultTransferParameters Class See Also Send Feedback
Initializes a new instance of the ConsultTransferParameters using a QueueId to specify the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransferParameters(
    QueueId target,
    InteractionId callerInteractionId,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As QueueId, _
    callerInteractionId As InteractionId, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.
callerInteractionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId of the consult transfer.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ConsultTransferParameters Overload
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Methods

[image] [image]

IceLib Technical Reference
ConsultTransferParameters Methods
ConsultTransferParameters Class See Also Send Feedback

The ConsultTransferParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of ConsultTransferParameters. (Overrides Object..::..ToString()()()().)

See Also

ConsultTransferParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
ConsultTransferParameters..::..ToString Method
ConsultTransferParameters Class See Also Send Feedback
Gets the string representation of ConsultTransferParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


ConsultTransferParameters Properties

[image] [image]

IceLib Technical Reference
ConsultTransferParameters Properties
ConsultTransferParameters Class See Also Send Feedback

The ConsultTransferParameters type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | CallerInteractionId | Gets the InteractionId associated with this consult transfer. This value represents the original Caller interaction ID.
Public property | CallMadeStage | Gets or sets the call made stage.
Public property | Target | Gets or sets the target.

See Also

ConsultTransferParameters Class
ININ.IceLib.Interactions Namespace


AdditionalAttributes Property

[image]

IceLib Technical Reference
ConsultTransferParameters..::..AdditionalAttributes Property
ConsultTransferParameters Class See Also Send Feedback
Gets a collection which can be used to set additional attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> AdditionalAttributes { get; internal set; }
Visual Basic
Public Property AdditionalAttributes As IDictionary(Of String, String)
    Get
    Friend Set

Field Value

The additional attributes collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


CallerInteractionId Property

[image]

IceLib Technical Reference
ConsultTransferParameters..::..CallerInteractionId Property
ConsultTransferParameters Class See Also Send Feedback
Gets the InteractionId associated with this consult transfer. This value represents the original Caller interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId CallerInteractionId { get; }
Visual Basic
Public ReadOnly Property CallerInteractionId As InteractionId
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


CallMadeStage Property

[image]

IceLib Technical Reference
ConsultTransferParameters..::..CallMadeStage Property
ConsultTransferParameters Class See Also Send Feedback
Gets or sets the call made stage.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallMadeStage CallMadeStage { get; set; }
Visual Basic
Public Property CallMadeStage As CallMadeStage
    Get
    Set

Field Value

Specifies when to raise the CallMade event.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


Target Property

[image]

IceLib Technical Reference
ConsultTransferParameters..::..Target Property
ConsultTransferParameters Class See Also Send Feedback
Gets or sets the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set

Field Value

The target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ConsultTransferParameters Class
ConsultTransferParameters Members
ININ.IceLib.Interactions Namespace


ConsultTransferParticipants Enumeration

[image]

IceLib Technical Reference
ConsultTransferParticipants Enumeration
See Also Send Feedback
The participants in a ConsultTransfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum ConsultTransferParticipants
Visual Basic
<FlagsAttribute> _
Public Enumeration ConsultTransferParticipants

Members

Member name | Value | Description
None | 0 | Neither the caller, nor the agent, nor the consult.
Agent | 1 | Represents the agent party in a consult transfer.
Caller | 2 | Represents the caller party in a consult transfer.
Consult | 4 | Represents the consult party in a consult transfer.
All | 7 | Represents the agent, caller and consult in a consult transfer.

Remarks

See ChangeSpeakers(ConsultTransferParticipants) or ChangeSpeakersAsync(ConsultTransferParticipants, AsyncCompletedEventHandler, Object) on using these values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


EmailAddress Class

[image]

IceLib Technical Reference
EmailAddress Class
Members See Also Send Feedback
Represents a resolved Email address from an EmailResolver.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailAddress
Visual Basic
Public Class EmailAddress

Remarks

Email addresses contain the string address and the string containing the display name of the Email address.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddress Members
ININ.IceLib.Interactions Namespace


EmailAddress Members

[image] [image]

IceLib Technical Reference
EmailAddress Members
EmailAddress Class Constructors Methods Properties See Also Send Feedback

The EmailAddress type exposes the following members.

Constructors

 | Name | Description
Public method | EmailAddress | Initializes a new instance of the EmailAddress class.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailAddress object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | Gets the Email address.
Public property | DisplayName | Gets the display name of the address.

See Also

EmailAddress Class
ININ.IceLib.Interactions Namespace


EmailAddress Constructor

[image]

IceLib Technical Reference
EmailAddress Constructor
EmailAddress Class See Also Send Feedback
Initializes a new instance of the EmailAddress class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailAddress(
    string address,
    string displayName
)
Visual Basic
Public Sub New ( _
    address As String, _
    displayName As String _
)

Parameters

address
Type: System..::..String
The Email address.
displayName
Type: System..::..String
Display name of the member.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddress Class
EmailAddress Members
ININ.IceLib.Interactions Namespace


EmailAddress Methods

[image] [image]

IceLib Technical Reference
EmailAddress Methods
EmailAddress Class See Also Send Feedback

The EmailAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailAddress object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailAddress Class
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailAddress..::..Equals Method
EmailAddress Class See Also Send Feedback
The Equals method determines whether the specified System.Object is equal to the current EmailAddress object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddress Class
EmailAddress Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailAddress..::..GetHashCode Method
EmailAddress Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddress Class
EmailAddress Members
ININ.IceLib.Interactions Namespace


EmailAddress Properties

[image] [image]

IceLib Technical Reference
EmailAddress Properties
EmailAddress Class See Also Send Feedback

The EmailAddress type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the Email address.
Public property | DisplayName | Gets the display name of the address.

See Also

EmailAddress Class
ININ.IceLib.Interactions Namespace


Address Property

[image]

IceLib Technical Reference
EmailAddress..::..Address Property
EmailAddress Class See Also Send Feedback
Gets the Email address.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; }
Visual Basic
Public ReadOnly Property Address As String
    Get

Field Value

The Email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddress Class
EmailAddress Members
ININ.IceLib.Interactions Namespace


DisplayName Property

[image]

IceLib Technical Reference
EmailAddress..::..DisplayName Property
EmailAddress Class See Also Send Feedback
Gets the display name of the address.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddress Class
EmailAddress Members
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Class

[image]

IceLib Technical Reference
EmailAddressesEventArgs Class
Members See Also Send Feedback
Provides data for the EmailResolved event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailAddressesEventArgs : EventArgs
Visual Basic
Public Class EmailAddressesEventArgs _
    Inherits EventArgs

Remarks

When the EmailResolved event is triggered the resolved email addresses are contained in objects of this class.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..EmailAddressesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddressesEventArgs Members
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Members

[image] [image]

IceLib Technical Reference
EmailAddressesEventArgs Members
EmailAddressesEventArgs Class Constructors Methods Properties See Also Send Feedback

The EmailAddressesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EmailAddressesEventArgs(String, array<EmailAddress>[]()[][]) | Initializes a new instance of the EmailAddressesEventArgs class with the specified values.
Public method | EmailAddressesEventArgs(String, array<EmailAddress>[]()[][], Boolean) | Initializes a new instance of the EmailAddressesEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressSearch | Gets the address search being resolved.
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available than what is in Results.
Public property | Results | Gets the EmailAddresses with the change.

See Also

EmailAddressesEventArgs Class
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Constructor

[image] [image]

IceLib Technical Reference
EmailAddressesEventArgs Constructor
EmailAddressesEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmailAddressesEventArgs(String, array<EmailAddress>[]()[][]) | Initializes a new instance of the EmailAddressesEventArgs class with the specified values.
Public method | EmailAddressesEventArgs(String, array<EmailAddress>[]()[][], Boolean) | Initializes a new instance of the EmailAddressesEventArgs class with the specified values.

See Also

EmailAddressesEventArgs Class
EmailAddressesEventArgs Members
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Constructor (String, EmailAddress[])

[image]

IceLib Technical Reference
EmailAddressesEventArgs Constructor (String, array<EmailAddress>[]()[][])
EmailAddressesEventArgs Class See Also Send Feedback
Initializes a new instance of the EmailAddressesEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailAddressesEventArgs(
    string addressSearch,
    EmailAddress[] emailAddresses
)
Visual Basic
Public Sub New ( _
    addressSearch As String, _
    emailAddresses As EmailAddress() _
)

Parameters

addressSearch
Type: System..::..String
The address search.
emailAddresses
Type: array< ININ.IceLib.Interactions..::..EmailAddress >[]()[][]
The Email addresses.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddressesEventArgs Class
EmailAddressesEventArgs Members
EmailAddressesEventArgs Overload
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Constructor (String, EmailAddress[], Boolean)

[image]

IceLib Technical Reference
EmailAddressesEventArgs Constructor (String, array<EmailAddress>[]()[][], Boolean)
EmailAddressesEventArgs Class See Also Send Feedback
Initializes a new instance of the EmailAddressesEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailAddressesEventArgs(
    string addressSearch,
    EmailAddress[] emailAddresses,
    bool moreResultsAvailable
)
Visual Basic
Public Sub New ( _
    addressSearch As String, _
    emailAddresses As EmailAddress(), _
    moreResultsAvailable As Boolean _
)

Parameters

addressSearch
Type: System..::..String
The address search.
emailAddresses
Type: array< ININ.IceLib.Interactions..::..EmailAddress >[]()[][]
The Email addresses.
moreResultsAvailable
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) then more results were available than what was in emailAddresses.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddressesEventArgs Class
EmailAddressesEventArgs Members
EmailAddressesEventArgs Overload
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Methods

[image] [image]

IceLib Technical Reference
EmailAddressesEventArgs Methods
EmailAddressesEventArgs Class See Also Send Feedback

The EmailAddressesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailAddressesEventArgs Class
ININ.IceLib.Interactions Namespace


EmailAddressesEventArgs Properties

[image] [image]

IceLib Technical Reference
EmailAddressesEventArgs Properties
EmailAddressesEventArgs Class See Also Send Feedback

The EmailAddressesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AddressSearch | Gets the address search being resolved.
Public property | MoreResultsAvailable | Gets a value indicating whether more results were available than what is in Results.
Public property | Results | Gets the EmailAddresses with the change.

See Also

EmailAddressesEventArgs Class
ININ.IceLib.Interactions Namespace


AddressSearch Property

[image]

IceLib Technical Reference
EmailAddressesEventArgs..::..AddressSearch Property
EmailAddressesEventArgs Class See Also Send Feedback
Gets the address search being resolved.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddressSearch { get; }
Visual Basic
Public ReadOnly Property AddressSearch As String
    Get

Field Value

The address search.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddressesEventArgs Class
EmailAddressesEventArgs Members
ININ.IceLib.Interactions Namespace


MoreResultsAvailable Property

[image]

IceLib Technical Reference
EmailAddressesEventArgs..::..MoreResultsAvailable Property
EmailAddressesEventArgs Class See Also Send Feedback
Gets a value indicating whether more results were available than what is in Results.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool MoreResultsAvailable { get; }
Visual Basic
Public ReadOnly Property MoreResultsAvailable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if more results were available; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

The value indicates whether the number of email addresses in Results was limited by the MaxResults property of EmailResolver.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddressesEventArgs Class
EmailAddressesEventArgs Members
ININ.IceLib.Interactions Namespace


Results Property

[image]

IceLib Technical Reference
EmailAddressesEventArgs..::..Results Property
EmailAddressesEventArgs Class See Also Send Feedback
Gets the EmailAddresses with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<EmailAddress> Results { get; }
Visual Basic
Public ReadOnly Property Results As ReadOnlyCollection(Of EmailAddress)
    Get

Field Value

The results.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailAddressesEventArgs Class
EmailAddressesEventArgs Members
ININ.IceLib.Interactions Namespace


EmailBody Class

[image]

IceLib Technical Reference
EmailBody Class
Members See Also Send Feedback
Represents an email body within an EmailContent.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailBody
Visual Basic
Public Class EmailBody

Remarks

An email body consists of the text content and a MIME content-type describing its format.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailBody

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailBody Members
ININ.IceLib.Interactions Namespace


EmailBody Members

[image] [image]

IceLib Technical Reference
EmailBody Members
EmailBody Class Constructors Methods Properties See Also Send Feedback

The EmailBody type exposes the following members.

Constructors

 | Name | Description
Public method | EmailBody | Initializes a new instance of the EmailBody class.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailBody object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Content | Gets the body content in the format specified by ContentType.
Public property | ContentType | Gets the MIME content-type describing the data contained in Content (e.g. text/html or text/plain).

See Also

EmailBody Class
ININ.IceLib.Interactions Namespace


EmailBody Constructor

[image]

IceLib Technical Reference
EmailBody Constructor
EmailBody Class See Also Send Feedback
Initializes a new instance of the EmailBody class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailBody(
    string contentType,
    string content
)
Visual Basic
Public Sub New ( _
    contentType As String, _
    content As String _
)

Parameters

contentType
Type: System..::..String
The MIME content-type of the body content, e.g. text/html or text/plain.
content
Type: System..::..String
The body content.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailBody Class
EmailBody Members
ININ.IceLib.Interactions Namespace


EmailBody Methods

[image] [image]

IceLib Technical Reference
EmailBody Methods
EmailBody Class See Also Send Feedback

The EmailBody type exposes the following members.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailBody object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailBody Class
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailBody..::..Equals Method
EmailBody Class See Also Send Feedback
The Equals method determines whether the specified System.Object is equal to the current EmailBody object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailBody Class
EmailBody Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailBody..::..GetHashCode Method
EmailBody Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailBody Class
EmailBody Members
ININ.IceLib.Interactions Namespace


EmailBody Properties

[image] [image]

IceLib Technical Reference
EmailBody Properties
EmailBody Class See Also Send Feedback

The EmailBody type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets the body content in the format specified by ContentType.
Public property | ContentType | Gets the MIME content-type describing the data contained in Content (e.g. text/html or text/plain).

See Also

EmailBody Class
ININ.IceLib.Interactions Namespace


Content Property

[image]

IceLib Technical Reference
EmailBody..::..Content Property
EmailBody Class See Also Send Feedback
Gets the body content in the format specified by ContentType.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Content { get; }
Visual Basic
Public ReadOnly Property Content As String
    Get

Field Value

The body content.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailBody Class
EmailBody Members
ININ.IceLib.Interactions Namespace


ContentType Property

[image]

IceLib Technical Reference
EmailBody..::..ContentType Property
EmailBody Class See Also Send Feedback
Gets the MIME content-type describing the data contained in Content (e.g. text/html or text/plain).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ContentType { get; }
Visual Basic
Public ReadOnly Property ContentType As String
    Get

Field Value

The MIME content-type conforming to RFC 2045 Section 5.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailBody Class
EmailBody Members
ININ.IceLib.Interactions Namespace


EmailCloneAttachmentType Enumeration

[image]

IceLib Technical Reference
EmailCloneAttachmentType Enumeration
See Also Send Feedback
Determines what attachments from the source email to include when an EmailContent object is cloned.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EmailCloneAttachmentType
Visual Basic
Public Enumeration EmailCloneAttachmentType

Members

Member name | Value | Description
NoAttachments | 0 | No attachements will be included in the new EmailContent object.
InLineOnly | 1 | Only in line attachements will be included in the new EmailContent object.
AllAttachments | 2 | All attachements will be included in the new EmailContent object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


EmailContent Class

[image]

IceLib Technical Reference
EmailContent Class
Members See Also Send Feedback
Represents the content for an EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailContent
Visual Basic
Public Class EmailContent

Remarks

This class contains all of the information about the content of an Email interaction such as subject, body, sender, To/CC/BCC/Reply-To recipients, and any attachments.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailContent

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Members
ININ.IceLib.Interactions Namespace


EmailContent Members

[image] [image]

IceLib Technical Reference
EmailContent Members
EmailContent Class Constructors Methods Properties See Also Send Feedback

The EmailContent type exposes the following members.

Constructors

 | Name | Description
Public method | EmailContent | Initializes a new instance of the EmailContent class.

Methods

 | Name | Description
Public method | CloneForResponse | Clones this content to be used in a response email.
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailContent object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BccRecipients | Gets the 'bcc' recipients.
Public property | Bodies | Gets the bodies of a multi-part email message.
Public property | Body | Gets or sets the text body of the Email message.
Public property | CcRecipients | Gets the 'cc' recipients.
Public property | DateReceived | Gets the time that this email was received.
Public property | DigitalSignatures | Gets the read only collection of digital signatures.
Public property | EncryptionCertificate | Gets the encryption certificate.
Public property | FileAttachments | Gets the read only collection of file attachments.
Public property | InteractionId | Gets the ID of the Interaction.
Public property | MessageAttachments | Gets the read only collection of message attachments.
Public property | ReplyToRecipients | Gets the 'reply-to' recipients.
Public property | Sender | Gets or sets the sender.
Public property | Subject | Gets or sets the subject.
Public property | ToRecipients | Gets the 'to' recipients.

See Also

EmailContent Class
ININ.IceLib.Interactions Namespace


EmailContent Constructor

[image]

IceLib Technical Reference
EmailContent Constructor
EmailContent Class See Also Send Feedback
Initializes a new instance of the EmailContent class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContent()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


EmailContent Methods

[image] [image]

IceLib Technical Reference
EmailContent Methods
EmailContent Class See Also Send Feedback

The EmailContent type exposes the following members.

Methods

 | Name | Description
Public method | CloneForResponse | Clones this content to be used in a response email.
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailContent object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailContent Class
ININ.IceLib.Interactions Namespace


CloneForResponse Method

[image]

IceLib Technical Reference
EmailContent..::..CloneForResponse Method
EmailContent Class See Also Send Feedback
Clones this content to be used in a response email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContent CloneForResponse(
    EmailCloneAttachmentType attachmentType
)
Visual Basic
Public Function CloneForResponse ( _
    attachmentType As EmailCloneAttachmentType _
) As EmailContent

Parameters

attachmentType
Type: ININ.IceLib.Interactions..::..EmailCloneAttachmentType
Determines what attachments to include in the cloned content.

Return Value

An editable clone of this content.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailContent..::..Equals Method
EmailContent Class See Also Send Feedback
The Equals method determines whether the specified System.Object is equal to the current EmailContent object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailContent..::..GetHashCode Method
EmailContent Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


EmailContent Properties

[image] [image]

IceLib Technical Reference
EmailContent Properties
EmailContent Class See Also Send Feedback

The EmailContent type exposes the following members.

Properties

 | Name | Description
Public property | BccRecipients | Gets the 'bcc' recipients.
Public property | Bodies | Gets the bodies of a multi-part email message.
Public property | Body | Gets or sets the text body of the Email message.
Public property | CcRecipients | Gets the 'cc' recipients.
Public property | DateReceived | Gets the time that this email was received.
Public property | DigitalSignatures | Gets the read only collection of digital signatures.
Public property | EncryptionCertificate | Gets the encryption certificate.
Public property | FileAttachments | Gets the read only collection of file attachments.
Public property | InteractionId | Gets the ID of the Interaction.
Public property | MessageAttachments | Gets the read only collection of message attachments.
Public property | ReplyToRecipients | Gets the 'reply-to' recipients.
Public property | Sender | Gets or sets the sender.
Public property | Subject | Gets or sets the subject.
Public property | ToRecipients | Gets the 'to' recipients.

See Also

EmailContent Class
ININ.IceLib.Interactions Namespace


BccRecipients Property

[image]

IceLib Technical Reference
EmailContent..::..BccRecipients Property
EmailContent Class See Also Send Feedback
Gets the 'bcc' recipients.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailAddress> BccRecipients { get; }
Visual Basic
Public ReadOnly Property BccRecipients As IList(Of EmailAddress)
    Get

Field Value

The 'bcc' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


Bodies Property

[image]

IceLib Technical Reference
EmailContent..::..Bodies Property
EmailContent Class See Also Send Feedback
Gets the bodies of a multi-part email message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailBody> Bodies { get; }
Visual Basic
Public ReadOnly Property Bodies As IList(Of EmailBody)
    Get

Field Value

The bodies.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


Body Property

[image]

IceLib Technical Reference
EmailContent..::..Body Property
EmailContent Class See Also Send Feedback
Gets or sets the text body of the Email message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Body { get; set; }
Visual Basic
Public Property Body As String
    Get
    Set

Field Value

The body.

Remarks

The MIME content-type of the body is always text/plain. For HTML email, see Bodies.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The content is in read-only mode.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace
EmailContent..::..Bodies


CcRecipients Property

[image]

IceLib Technical Reference
EmailContent..::..CcRecipients Property
EmailContent Class See Also Send Feedback
Gets the 'cc' recipients.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailAddress> CcRecipients { get; }
Visual Basic
Public ReadOnly Property CcRecipients As IList(Of EmailAddress)
    Get

Field Value

The 'cc' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


DateReceived Property

[image]

IceLib Technical Reference
EmailContent..::..DateReceived Property
EmailContent Class See Also Send Feedback
Gets the time that this email was received.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime DateReceived { get; }
Visual Basic
Public ReadOnly Property DateReceived As DateTime
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


DigitalSignatures Property

[image]

IceLib Technical Reference
EmailContent..::..DigitalSignatures Property
EmailContent Class See Also Send Feedback
Gets the read only collection of digital signatures.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailSignatureCertificate> DigitalSignatures { get; }
Visual Basic
Public ReadOnly Property DigitalSignatures As IList(Of EmailSignatureCertificate)
    Get

Field Value

The digital signatures.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


EncryptionCertificate Property

[image]

IceLib Technical Reference
EmailContent..::..EncryptionCertificate Property
EmailContent Class See Also Send Feedback
Gets the encryption certificate.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailEncryptionCertificate EncryptionCertificate { get; }
Visual Basic
Public ReadOnly Property EncryptionCertificate As EmailEncryptionCertificate
    Get

Field Value

The encryption certificate.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


FileAttachments Property

[image]

IceLib Technical Reference
EmailContent..::..FileAttachments Property
EmailContent Class See Also Send Feedback
Gets the read only collection of file attachments.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailFileAttachment> FileAttachments { get; }
Visual Basic
Public ReadOnly Property FileAttachments As IList(Of EmailFileAttachment)
    Get

Field Value

The file attachments.

Remarks

To manage the attachments, use the UploadFileAttachmentAsync(String, AsyncCompletedEventHandler, Object) and RemoveFileAttachmentAsync(EmailFileAttachment, AsyncCompletedEventHandler, Object) methods.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
EmailContent..::..InteractionId Property
EmailContent Class See Also Send Feedback
Gets the ID of the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


MessageAttachments Property

[image]

IceLib Technical Reference
EmailContent..::..MessageAttachments Property
EmailContent Class See Also Send Feedback
Gets the read only collection of message attachments.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailMessageAttachment> MessageAttachments { get; }
Visual Basic
Public ReadOnly Property MessageAttachments As IList(Of EmailMessageAttachment)
    Get

Field Value

The message attachments.

Remarks

Message attachments are only valid on incoming emails.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


ReplyToRecipients Property

[image]

IceLib Technical Reference
EmailContent..::..ReplyToRecipients Property
EmailContent Class See Also Send Feedback
Gets the 'reply-to' recipients.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailAddress> ReplyToRecipients { get; }
Visual Basic
Public ReadOnly Property ReplyToRecipients As IList(Of EmailAddress)
    Get

Field Value

The 'reply-to' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


Sender Property

[image]

IceLib Technical Reference
EmailContent..::..Sender Property
EmailContent Class See Also Send Feedback
Gets or sets the sender.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailAddress Sender { get; set; }
Visual Basic
Public Property Sender As EmailAddress
    Get
    Set

Field Value

The sender.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The content is in read-only mode.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


Subject Property

[image]

IceLib Technical Reference
EmailContent..::..Subject Property
EmailContent Class See Also Send Feedback
Gets or sets the subject.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set

Field Value

The subject.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The content is in read-only mode.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


ToRecipients Property

[image]

IceLib Technical Reference
EmailContent..::..ToRecipients Property
EmailContent Class See Also Send Feedback
Gets the 'to' recipients.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IList<EmailAddress> ToRecipients { get; }
Visual Basic
Public ReadOnly Property ToRecipients As IList(Of EmailAddress)
    Get

Field Value

The 'to' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailContent Class
EmailContent Members
ININ.IceLib.Interactions Namespace


EmailContentUpdateEventArgs Class

[image]

IceLib Technical Reference
EmailContentUpdateEventArgs Class
Members See Also Send Feedback
Used to notify listeners of updated email contents.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailContentUpdateEventArgs : EventArgs
Visual Basic
Public Class EmailContentUpdateEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..EmailContentUpdateEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

EmailContentUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


EmailContentUpdateEventArgs Members

[image] [image]

IceLib Technical Reference
EmailContentUpdateEventArgs Members
EmailContentUpdateEventArgs Class Constructors Methods Properties See Also Send Feedback

The EmailContentUpdateEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EmailContentUpdateEventArgs | Initializes a new instance of the EmailContentUpdateEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Exception | Gets the exception, if any, that was thrown when retrieving the contents.

See Also

EmailContentUpdateEventArgs Class
ININ.IceLib.Interactions Namespace


EmailContentUpdateEventArgs Constructor

[image]

IceLib Technical Reference
EmailContentUpdateEventArgs Constructor
EmailContentUpdateEventArgs Class See Also Send Feedback
Initializes a new instance of the EmailContentUpdateEventArgs class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContentUpdateEventArgs(
    Exception exception
)
Visual Basic
Public Sub New ( _
    exception As Exception _
)

Parameters

exception
Type: System..::..Exception
The exception, if any, that was thrown when retrieving the contents.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

EmailContentUpdateEventArgs Class
EmailContentUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


EmailContentUpdateEventArgs Methods

[image] [image]

IceLib Technical Reference
EmailContentUpdateEventArgs Methods
EmailContentUpdateEventArgs Class See Also Send Feedback

The EmailContentUpdateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailContentUpdateEventArgs Class
ININ.IceLib.Interactions Namespace


EmailContentUpdateEventArgs Properties

[image] [image]

IceLib Technical Reference
EmailContentUpdateEventArgs Properties
EmailContentUpdateEventArgs Class See Also Send Feedback

The EmailContentUpdateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Exception | Gets the exception, if any, that was thrown when retrieving the contents.

See Also

EmailContentUpdateEventArgs Class
ININ.IceLib.Interactions Namespace


Exception Property

[image]

IceLib Technical Reference
EmailContentUpdateEventArgs..::..Exception Property
EmailContentUpdateEventArgs Class See Also Send Feedback
Gets the exception, if any, that was thrown when retrieving the contents.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Exception Exception { get; }
Visual Basic
Public ReadOnly Property Exception As Exception
    Get

Field Value

The exception, if any, that was thrown when retrieving the contents.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

EmailContentUpdateEventArgs Class
EmailContentUpdateEventArgs Members
ININ.IceLib.Interactions Namespace


EmailCreateResponseCompletedEventArgs Class

[image]

IceLib Technical Reference
EmailCreateResponseCompletedEventArgs Class
Members See Also Send Feedback
Represents the completion of a CreateResponseAsync(EmailContent, EmailResponseType, EventHandler<(Of <<'(EmailCreateResponseCompletedEventArgs>)>>), Object) call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailCreateResponseCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class EmailCreateResponseCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..EmailCreateResponseCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailCreateResponseCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


EmailCreateResponseCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
EmailCreateResponseCompletedEventArgs Members
EmailCreateResponseCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The EmailCreateResponseCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EmailCreateResponseCompletedEventArgs | Initializes a new instance of the EmailCreateResponseCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Email | Gets the resulting email interaction.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

EmailCreateResponseCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


EmailCreateResponseCompletedEventArgs Constructor

[image]

IceLib Technical Reference
EmailCreateResponseCompletedEventArgs Constructor
EmailCreateResponseCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the EmailCreateResponseCompletedEventArgs class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailCreateResponseCompletedEventArgs(
    EmailInteraction email,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    email As EmailInteraction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

email
Type: ININ.IceLib.Interactions..::..EmailInteraction
The resulting email interaction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailCreateResponseCompletedEventArgs Class
EmailCreateResponseCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


EmailCreateResponseCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
EmailCreateResponseCompletedEventArgs Methods
EmailCreateResponseCompletedEventArgs Class See Also Send Feedback

The EmailCreateResponseCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailCreateResponseCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


EmailCreateResponseCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
EmailCreateResponseCompletedEventArgs Properties
EmailCreateResponseCompletedEventArgs Class See Also Send Feedback

The EmailCreateResponseCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Email | Gets the resulting email interaction.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

EmailCreateResponseCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


Email Property

[image]

IceLib Technical Reference
EmailCreateResponseCompletedEventArgs..::..Email Property
EmailCreateResponseCompletedEventArgs Class See Also Send Feedback
Gets the resulting email interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteraction Email { get; }
Visual Basic
Public ReadOnly Property Email As EmailInteraction
    Get

Field Value

The email interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailCreateResponseCompletedEventArgs Class
EmailCreateResponseCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


EmailDownloadMessageAttachmentCompletedEventArgs Class

[image]

IceLib Technical Reference
EmailDownloadMessageAttachmentCompletedEventArgs Class
Members See Also Send Feedback
Represents the completion of a DownloadMessageAttachmentAsync(EmailMessageAttachment, EventHandler<(Of <<'(EmailDownloadMessageAttachmentCompletedEventArgs>)>>), Object) call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailDownloadMessageAttachmentCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class EmailDownloadMessageAttachmentCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..EmailDownloadMessageAttachmentCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailDownloadMessageAttachmentCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


EmailDownloadMessageAttachmentCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
EmailDownloadMessageAttachmentCompletedEventArgs Members
EmailDownloadMessageAttachmentCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The EmailDownloadMessageAttachmentCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EmailDownloadMessageAttachmentCompletedEventArgs | Initializes a new instance of the EmailDownloadMessageAttachmentCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Content | Gets the resulting email content.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

EmailDownloadMessageAttachmentCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


EmailDownloadMessageAttachmentCompletedEventArgs Constructor

[image]

IceLib Technical Reference
EmailDownloadMessageAttachmentCompletedEventArgs Constructor
EmailDownloadMessageAttachmentCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the EmailDownloadMessageAttachmentCompletedEventArgs class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailDownloadMessageAttachmentCompletedEventArgs(
    EmailContent content,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    content As EmailContent, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

content
Type: ININ.IceLib.Interactions..::..EmailContent
The resulting email interaction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailDownloadMessageAttachmentCompletedEventArgs Class
EmailDownloadMessageAttachmentCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


EmailDownloadMessageAttachmentCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
EmailDownloadMessageAttachmentCompletedEventArgs Methods
EmailDownloadMessageAttachmentCompletedEventArgs Class See Also Send Feedback

The EmailDownloadMessageAttachmentCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailDownloadMessageAttachmentCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


EmailDownloadMessageAttachmentCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
EmailDownloadMessageAttachmentCompletedEventArgs Properties
EmailDownloadMessageAttachmentCompletedEventArgs Class See Also Send Feedback

The EmailDownloadMessageAttachmentCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Content | Gets the resulting email content.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

EmailDownloadMessageAttachmentCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


Content Property

[image]

IceLib Technical Reference
EmailDownloadMessageAttachmentCompletedEventArgs..::..Content Property
EmailDownloadMessageAttachmentCompletedEventArgs Class See Also Send Feedback
Gets the resulting email content.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContent Content { get; }
Visual Basic
Public ReadOnly Property Content As EmailContent
    Get

Field Value

The email content.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailDownloadMessageAttachmentCompletedEventArgs Class
EmailDownloadMessageAttachmentCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


EmailEncryptionCertificate Class

[image]

IceLib Technical Reference
EmailEncryptionCertificate Class
Members See Also Send Feedback
Definition for EmailEncryptionCertificate class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailEncryptionCertificate
Visual Basic
Public Class EmailEncryptionCertificate

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailEncryptionCertificate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailEncryptionCertificate Members
ININ.IceLib.Interactions Namespace


EmailEncryptionCertificate Members

[image] [image]

IceLib Technical Reference
EmailEncryptionCertificate Members
EmailEncryptionCertificate Class Methods Properties See Also Send Feedback

The EmailEncryptionCertificate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Algorithm | Gets the encryption algorithm.
Public property | Certificate | Gets the certificate.
Public property | Status | Gets the encryption status.

See Also

EmailEncryptionCertificate Class
ININ.IceLib.Interactions Namespace


EmailEncryptionCertificate Methods

[image] [image]

IceLib Technical Reference
EmailEncryptionCertificate Methods
EmailEncryptionCertificate Class See Also Send Feedback

The EmailEncryptionCertificate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailEncryptionCertificate Class
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailEncryptionCertificate..::..Equals Method
EmailEncryptionCertificate Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Security.Cryptography..::..CryptographicException | The certificate handle is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailEncryptionCertificate Class
EmailEncryptionCertificate Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailEncryptionCertificate..::..GetHashCode Method
EmailEncryptionCertificate Class See Also Send Feedback
Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailEncryptionCertificate Class
EmailEncryptionCertificate Members
ININ.IceLib.Interactions Namespace


EmailEncryptionCertificate Properties

[image] [image]

IceLib Technical Reference
EmailEncryptionCertificate Properties
EmailEncryptionCertificate Class See Also Send Feedback

The EmailEncryptionCertificate type exposes the following members.

Properties

 | Name | Description
Public property | Algorithm | Gets the encryption algorithm.
Public property | Certificate | Gets the certificate.
Public property | Status | Gets the encryption status.

See Also

EmailEncryptionCertificate Class
ININ.IceLib.Interactions Namespace


Algorithm Property

[image]

IceLib Technical Reference
EmailEncryptionCertificate..::..Algorithm Property
EmailEncryptionCertificate Class See Also Send Feedback
Gets the encryption algorithm.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Algorithm { get; }
Visual Basic
Public ReadOnly Property Algorithm As String
    Get

Field Value

The encryption algorithm.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailEncryptionCertificate Class
EmailEncryptionCertificate Members
ININ.IceLib.Interactions Namespace


Certificate Property

[image]

IceLib Technical Reference
EmailEncryptionCertificate..::..Certificate Property
EmailEncryptionCertificate Class See Also Send Feedback
Gets the certificate.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public X509Certificate2 Certificate { get; }
Visual Basic
Public ReadOnly Property Certificate As X509Certificate2
    Get

Field Value

The certificate.

Exceptions

Exception | Condition
System.Security.Cryptography..::..CryptographicException | The certificate handle is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailEncryptionCertificate Class
EmailEncryptionCertificate Members
ININ.IceLib.Interactions Namespace


Status Property

[image]

IceLib Technical Reference
EmailEncryptionCertificate..::..Status Property
EmailEncryptionCertificate Class See Also Send Feedback
Gets the encryption status.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailEncryptionStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As EmailEncryptionStatus
    Get

Field Value

The encryption status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailEncryptionCertificate Class
EmailEncryptionCertificate Members
ININ.IceLib.Interactions Namespace


EmailEncryptionStatus Enumeration

[image]

IceLib Technical Reference
EmailEncryptionStatus Enumeration
See Also Send Feedback
Possible encryption status of an EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EmailEncryptionStatus
Visual Basic
Public Enumeration EmailEncryptionStatus

Members

Member name | Value | Description
None | 0 | Message was not encrypted.
Ok | 1 | Message was successfully decrypted.
Denied | 2 | Decryption was denied by an xIC policy.
Failed | 3 | Decryption failed (private key not found, malformed S/MIME, etc.).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


EmailFileAttachment Class

[image]

IceLib Technical Reference
EmailFileAttachment Class
Members See Also Send Feedback
Represents an attachment to an EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailFileAttachment
Visual Basic
Public Class EmailFileAttachment

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailFileAttachment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


EmailFileAttachment Members

[image] [image]

IceLib Technical Reference
EmailFileAttachment Members
EmailFileAttachment Class Methods Properties See Also Send Feedback

The EmailFileAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailFileAttachment object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContentId | Gets the Content-ID of an inline attachment conforming to RFC 2111.
Public property | Cookie | Gets the Cookie of an inline attachment.
Public property | HasInlineAttachment | Gets a value indicating whether this EmailFileAttachment has an inline attachment.
Public property | Id | Gets the ID.
Public property | Name | Gets the name.

See Also

EmailFileAttachment Class
ININ.IceLib.Interactions Namespace


EmailFileAttachment Methods

[image] [image]

IceLib Technical Reference
EmailFileAttachment Methods
EmailFileAttachment Class See Also Send Feedback

The EmailFileAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailFileAttachment object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailFileAttachment Class
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailFileAttachment..::..Equals Method
EmailFileAttachment Class See Also Send Feedback
The Equals method determines whether the specified System.Object is equal to the current EmailFileAttachment object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailFileAttachment..::..GetHashCode Method
EmailFileAttachment Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


EmailFileAttachment Properties

[image] [image]

IceLib Technical Reference
EmailFileAttachment Properties
EmailFileAttachment Class See Also Send Feedback

The EmailFileAttachment type exposes the following members.

Properties

 | Name | Description
Public property | ContentId | Gets the Content-ID of an inline attachment conforming to RFC 2111.
Public property | Cookie | Gets the Cookie of an inline attachment.
Public property | HasInlineAttachment | Gets a value indicating whether this EmailFileAttachment has an inline attachment.
Public property | Id | Gets the ID.
Public property | Name | Gets the name.

See Also

EmailFileAttachment Class
ININ.IceLib.Interactions Namespace


ContentId Property

[image]

IceLib Technical Reference
EmailFileAttachment..::..ContentId Property
EmailFileAttachment Class See Also Send Feedback
Gets the Content-ID of an inline attachment conforming to RFC 2111.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ContentId { get; }
Visual Basic
Public ReadOnly Property ContentId As String
    Get

Field Value

The Content-ID if this is an inline attachment; otherwise empty string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


Cookie Property

[image]

IceLib Technical Reference
EmailFileAttachment..::..Cookie Property
EmailFileAttachment Class See Also Send Feedback
Gets the Cookie of an inline attachment.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Cookie { get; }
Visual Basic
Public ReadOnly Property Cookie As String
    Get

Field Value

Identifies the type and location of this attachment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


HasInlineAttachment Property

[image]

IceLib Technical Reference
EmailFileAttachment..::..HasInlineAttachment Property
EmailFileAttachment Class See Also Send Feedback
Gets a value indicating whether this EmailFileAttachment has an inline attachment.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasInlineAttachment { get; }
Visual Basic
Public ReadOnly Property HasInlineAttachment As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has inline attachment; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


Id Property

[image]

IceLib Technical Reference
EmailFileAttachment..::..Id Property
EmailFileAttachment Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


Name Property

[image]

IceLib Technical Reference
EmailFileAttachment..::..Name Property
EmailFileAttachment Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailFileAttachment Class
EmailFileAttachment Members
ININ.IceLib.Interactions Namespace


EmailInteraction Class

[image]

IceLib Technical Reference
EmailInteraction Class
Members See Also Send Feedback
Represents an email within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailInteraction : Interaction
Visual Basic
Public Class EmailInteraction _
    Inherits Interaction

Remarks

This class can be used to start and stop watches on an email interaction along with downloading, uploading, and deleting attachments, and sending email messages.

To start a watch, call EmailStartWatching()()()() or EmailStartWatchingAsync(AsyncCompletedEventHandler, Object). When the email start watch operation completes it invokes the completedCallback delegate. To stop watching an email interaction call EmailStopWatching()()()() or EmailStopWatchingAsync(AsyncCompletedEventHandler, Object). When the email stop watch operation completes it invokes the completedCallback delegate.

To create a new email, call MakeEmail(EmailInteractionParameters).

To create a response to this email, call CreateResponse(EmailContent, EmailResponseType) or CreateResponse(EmailContent, EmailResponseType) with an EmailContent object. To create an EmailContent object for response, use the source content's CloneForResponse(EmailCloneAttachmentType). When the asynchronous set response operation completes it invokes the completedCallback delegate.

To download a file attachment from the server call DownloadFileAttachment(EmailFileAttachment, Stream) or DownloadFileAttachmentAsync(EmailFileAttachment, Stream, AsyncCompletedEventHandler, Object) providing an EmailFileAttachment object and a local path to save the attachment. When the asynchronous download attachment operation completes it invokes the completedCallback delegate.

To download a message attachment from the server call DownloadMessageAttachment(EmailMessageAttachment) or DownloadMessageAttachmentAsync(EmailMessageAttachment, EventHandler<(Of <<'(EmailDownloadMessageAttachmentCompletedEventArgs>)>>), Object) providing an EmailMessageAttachment object. When the asynchronous download attachment operation completes it invokes the completedCallback delegate.

To upload a file attachment to the server call UploadFileAttachment(String) or UploadFileAttachmentAsync(String, AsyncCompletedEventHandler, Object) providing a file name of the attachment to upload. When the asynchronous upload operation completes it invokes the completedCallback delegate.

To upload an inline file attachment to the server call UploadFileAttachment(String, String) or UploadFileAttachmentAsync(String, String, AsyncCompletedEventHandler, Object) providing a file name of the attachment to upload and the Content-ID used to identify the attachment within the HTML body of the email. Use GenerateContentId(String) to create a unique Content-ID that can be used when uploading the given file as an inline attachment.

To remove a file attachment call RemoveFileAttachment(EmailFileAttachment) or RemoveFileAttachmentAsync(EmailFileAttachment, AsyncCompletedEventHandler, Object) with an EmailFileAttachment object to be removed. When the asynchronous operation completes it invokes the completedCallback delegate.

To send an email, call SendEmail()()()() or SendEmailAsync(AsyncCompletedEventHandler, Object). When the asynchronous send operation completes it invokes the completedCallback delegate.

Calling EmailStartWatching()()()() or EmailStartWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is already in place, or calling EmailStopWatching()()()() or EmailStopWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is not in place raises and InvalidOperationException.

Note
The asynchronous version of these methods is preferred since these operations can be lengthy.
Note
This class has been updated for 4.0 to replace the EmailResponse with EmailContent with expanded functionality.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..EmailInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailInteraction Members

[image] [image]

IceLib Technical Reference
EmailInteraction Members
EmailInteraction Class Constructors Methods Properties Events See Also Send Feedback

The EmailInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | EmailInteraction | Initializes a new instance of the EmailInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | CreateResponse | Creates an email interaction in response (reply, forward, etc...) to this email.
Public method | CreateResponseAsync | Asynchronously creates an email interaction in response (reply, forward, etc...) to this email.
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | DownloadFileAttachment(EmailFileAttachment, Stream) | Downloads an attachment into a specified stream.
Public method | DownloadFileAttachment(EmailFileAttachment, String) | Downloads an attachment into a specified file.
Public method | DownloadFileAttachmentAsync(EmailFileAttachment, Stream, AsyncCompletedEventHandler, Object) | Asynchronously downloads an attachment into a specified stream.
Public method | DownloadFileAttachmentAsync(EmailFileAttachment, String, AsyncCompletedEventHandler, Object) | Asynchronously downloads an attachment into a specified file.
Public method | DownloadMessageAttachment | Downloads an attached message.
Public method | DownloadMessageAttachmentAsync | Asynchronously downloads an attached message.
Public method | EmailIsWatching | Determines whether an email watch is active.
Public method | EmailStartWatching | Obsolete. Starts watching the email interaction.
Public method | EmailStartWatchingAsync | Obsolete. Asynchronously starts watching the email interaction.
Public method | EmailStartWatchingWithEvent | Starts watching the email interaction. The content will be unavailable until notified by the EmailContentUpdated event.
Public method | EmailStartWatchingWithEventAsync | Starts watching the email interaction asynchronously. The content will be unavailable until notified by the EmailContentUpdated event.
Public method | EmailStopWatching | Stops watching the emails interaction.
Public method | EmailStopWatchingAsync | Asynchronously stops watching the emails interaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateContentId | Generates a Content-ID to use when uploading a file as an inline attachment.
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetContent | Gets the email content.
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | HasEmailContent | Determines whether this email has content.
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RemoveFileAttachment | Removes an attachment from the current EmailInteraction.
Public method | RemoveFileAttachmentAsync | Asynchronously removes an attachment from the current EmailInteraction.
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SaveEmail | Saves the email.
Public method | SaveEmailAsync | Asynchronously saves the email.
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SendEmail | Sends the email.
Public method | SendEmailAsync | Asynchronously sends the email.
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | SupportsResponseType | Determines if this email supports the given response type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | UploadFileAttachment(String) | Uploads an attachment from a local file to this EmailInteraction.
Public method | UploadFileAttachment(Stream, String) | Uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachment(String, String) | Uploads an attachment from a local file to this EmailInteraction.
Public method | UploadFileAttachment(Stream, String, String) | Uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachmentAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment from a local file to the current EmailContent.
Public method | UploadFileAttachmentAsync(Stream, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachmentAsync(String, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment from a local file to the current EmailContent.
Public method | UploadFileAttachmentAsync(Stream, String, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment to this EmailInteraction from a given Stream.
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | ConversationId | Gets the conversation identifier.
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | EmailCapabilities | Gets the email capabilities portion of Capabilities.
Public property | EmailType | Gets the response type of EmailType.
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsReadOnly | Gets a value indicating whether this instance is read only.
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | ParentInteraction | Gets the parent interaction ID.
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | EmailContentUpdated | Occurs when the email content changes or is received for the first time.
Public event | EmailUpdated | Obsolete. Occurs when the email response changes.
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

EmailInteraction Class
ININ.IceLib.Interactions Namespace


EmailInteraction Constructor

[image]

IceLib Technical Reference
EmailInteraction Constructor
EmailInteraction Class See Also Send Feedback
Initializes a new instance of the EmailInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailInteraction Methods

[image] [image]

IceLib Technical Reference
EmailInteraction Methods
EmailInteraction Class See Also Send Feedback

The EmailInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | CreateResponse | Creates an email interaction in response (reply, forward, etc...) to this email.
Public method | CreateResponseAsync | Asynchronously creates an email interaction in response (reply, forward, etc...) to this email.
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | DownloadFileAttachment(EmailFileAttachment, Stream) | Downloads an attachment into a specified stream.
Public method | DownloadFileAttachment(EmailFileAttachment, String) | Downloads an attachment into a specified file.
Public method | DownloadFileAttachmentAsync(EmailFileAttachment, Stream, AsyncCompletedEventHandler, Object) | Asynchronously downloads an attachment into a specified stream.
Public method | DownloadFileAttachmentAsync(EmailFileAttachment, String, AsyncCompletedEventHandler, Object) | Asynchronously downloads an attachment into a specified file.
Public method | DownloadMessageAttachment | Downloads an attached message.
Public method | DownloadMessageAttachmentAsync | Asynchronously downloads an attached message.
Public method | EmailIsWatching | Determines whether an email watch is active.
Public method | EmailStartWatching | Obsolete. Starts watching the email interaction.
Public method | EmailStartWatchingAsync | Obsolete. Asynchronously starts watching the email interaction.
Public method | EmailStartWatchingWithEvent | Starts watching the email interaction. The content will be unavailable until notified by the EmailContentUpdated event.
Public method | EmailStartWatchingWithEventAsync | Starts watching the email interaction asynchronously. The content will be unavailable until notified by the EmailContentUpdated event.
Public method | EmailStopWatching | Stops watching the emails interaction.
Public method | EmailStopWatchingAsync | Asynchronously stops watching the emails interaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateContentId | Generates a Content-ID to use when uploading a file as an inline attachment.
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetContent | Gets the email content.
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | HasEmailContent | Determines whether this email has content.
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RemoveFileAttachment | Removes an attachment from the current EmailInteraction.
Public method | RemoveFileAttachmentAsync | Asynchronously removes an attachment from the current EmailInteraction.
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SaveEmail | Saves the email.
Public method | SaveEmailAsync | Asynchronously saves the email.
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SendEmail | Sends the email.
Public method | SendEmailAsync | Asynchronously sends the email.
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | SupportsResponseType | Determines if this email supports the given response type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | UploadFileAttachment(String) | Uploads an attachment from a local file to this EmailInteraction.
Public method | UploadFileAttachment(Stream, String) | Uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachment(String, String) | Uploads an attachment from a local file to this EmailInteraction.
Public method | UploadFileAttachment(Stream, String, String) | Uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachmentAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment from a local file to the current EmailContent.
Public method | UploadFileAttachmentAsync(Stream, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachmentAsync(String, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment from a local file to the current EmailContent.
Public method | UploadFileAttachmentAsync(Stream, String, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment to this EmailInteraction from a given Stream.
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

EmailInteraction Class
ININ.IceLib.Interactions Namespace


CreateResponse Method

[image]

IceLib Technical Reference
EmailInteraction..::..CreateResponse Method
EmailInteraction Class See Also Send Feedback
Creates an email interaction in response (reply, forward, etc...) to this email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteraction CreateResponse(
    EmailContent newContent,
    EmailResponseType responseType
)
Visual Basic
Public Function CreateResponse ( _
    newContent As EmailContent, _
    responseType As EmailResponseType _
) As EmailInteraction

Parameters

newContent
Type: ININ.IceLib.Interactions..::..EmailContent
The new email's content.
responseType
Type: ININ.IceLib.Interactions..::..EmailResponseType
The type of response to create.

Remarks

Use CloneForResponse(EmailCloneAttachmentType) to create content for the new message.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This is a email does not support the requested response type.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


CreateResponseAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..CreateResponseAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously creates an email interaction in response (reply, forward, etc...) to this email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateResponseAsync(
    EmailContent newContent,
    EmailResponseType responseType,
    EventHandler<EmailCreateResponseCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateResponseAsync ( _
    newContent As EmailContent, _
    responseType As EmailResponseType, _
    completedCallback As EventHandler(Of EmailCreateResponseCompletedEventArgs), _
    userState As Object _
)

Parameters

newContent
Type: ININ.IceLib.Interactions..::..EmailContent
The initial content of the newly created email.
responseType
Type: ININ.IceLib.Interactions..::..EmailResponseType
The type of response that is created.
completedCallback
Type: System..::..EventHandler<(Of <(<' EmailCreateResponseCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

Use CloneForResponse(EmailCloneAttachmentType) to create content for the new message.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This is a email does not support the requested response type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


DownloadFileAttachment Method

[image] [image]

IceLib Technical Reference
EmailInteraction..::..DownloadFileAttachment Method
EmailInteraction Class See Also Send Feedback
Downloads an EmailFileAttachment from the server.

Overload List

 | Name | Description
Public method | DownloadFileAttachment(EmailFileAttachment, Stream) | Downloads an attachment into a specified stream.
Public method | DownloadFileAttachment(EmailFileAttachment, String) | Downloads an attachment into a specified file.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


DownloadFileAttachment Method (EmailFileAttachment, Stream)

[image]

IceLib Technical Reference
EmailInteraction..::..DownloadFileAttachment Method (EmailFileAttachment, Stream)
EmailInteraction Class See Also Send Feedback
Downloads an attachment into a specified stream.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadFileAttachment(
    EmailFileAttachment emailAttachment,
    Stream outputStream
)
Visual Basic
Public Sub DownloadFileAttachment ( _
    emailAttachment As EmailFileAttachment, _
    outputStream As Stream _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailFileAttachment
The EmailFileAttachment of this EmailInteraction.
outputStream
Type: System.IO..::..Stream
The Stream to which the downloaded file should be written.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib..::..NotCachedException | The email is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
DownloadFileAttachment Overload
ININ.IceLib.Interactions Namespace


DownloadFileAttachment Method (EmailFileAttachment, String)

[image]

IceLib Technical Reference
EmailInteraction..::..DownloadFileAttachment Method (EmailFileAttachment, String)
EmailInteraction Class See Also Send Feedback
Downloads an attachment into a specified file.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadFileAttachment(
    EmailFileAttachment emailAttachment,
    string fileName
)
Visual Basic
Public Sub DownloadFileAttachment ( _
    emailAttachment As EmailFileAttachment, _
    fileName As String _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailFileAttachment
The EmailFileAttachment of this EmailInteraction.
fileName
Type: System..::..String
The path and name of a local file to save the attachment into.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib..::..NotCachedException | The email is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
DownloadFileAttachment Overload
ININ.IceLib.Interactions Namespace


DownloadFileAttachmentAsync Method

[image] [image]

IceLib Technical Reference
EmailInteraction..::..DownloadFileAttachmentAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously downloads an EmailFileAttachment from the server.

Overload List

 | Name | Description
Public method | DownloadFileAttachmentAsync(EmailFileAttachment, Stream, AsyncCompletedEventHandler, Object) | Asynchronously downloads an attachment into a specified stream.
Public method | DownloadFileAttachmentAsync(EmailFileAttachment, String, AsyncCompletedEventHandler, Object) | Asynchronously downloads an attachment into a specified file.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


DownloadFileAttachmentAsync Method (EmailFileAttachment, Stream, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
EmailInteraction..::..DownloadFileAttachmentAsync Method (EmailFileAttachment, Stream, AsyncCompletedEventHandler, Object)
EmailInteraction Class See Also Send Feedback
Asynchronously downloads an attachment into a specified stream.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadFileAttachmentAsync(
    EmailFileAttachment emailAttachment,
    Stream outputStream,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DownloadFileAttachmentAsync ( _
    emailAttachment As EmailFileAttachment, _
    outputStream As Stream, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailFileAttachment
The EmailFileAttachment of this EmailInteraction.
outputStream
Type: System.IO..::..Stream
The Stream to which the downloaded file should be written.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
DownloadFileAttachmentAsync Overload
ININ.IceLib.Interactions Namespace


DownloadFileAttachmentAsync Method (EmailFileAttachment, String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
EmailInteraction..::..DownloadFileAttachmentAsync Method (EmailFileAttachment, String, AsyncCompletedEventHandler, Object)
EmailInteraction Class See Also Send Feedback
Asynchronously downloads an attachment into a specified file.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadFileAttachmentAsync(
    EmailFileAttachment emailAttachment,
    string fileName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DownloadFileAttachmentAsync ( _
    emailAttachment As EmailFileAttachment, _
    fileName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailFileAttachment
The EmailFileAttachment of this EmailInteraction.
fileName
Type: System..::..String
The path and name of a local file to save the attachment into.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
DownloadFileAttachmentAsync Overload
ININ.IceLib.Interactions Namespace


DownloadMessageAttachment Method

[image]

IceLib Technical Reference
EmailInteraction..::..DownloadMessageAttachment Method
EmailInteraction Class See Also Send Feedback
Downloads an attached message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContent DownloadMessageAttachment(
    EmailMessageAttachment emailAttachment
)
Visual Basic
Public Function DownloadMessageAttachment ( _
    emailAttachment As EmailMessageAttachment _
) As EmailContent

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailMessageAttachment
The EmailMessageAttachment of this EmailInteraction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The email is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


DownloadMessageAttachmentAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..DownloadMessageAttachmentAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously downloads an attached message.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DownloadMessageAttachmentAsync(
    EmailMessageAttachment emailAttachment,
    EventHandler<EmailDownloadMessageAttachmentCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub DownloadMessageAttachmentAsync ( _
    emailAttachment As EmailMessageAttachment, _
    completedCallback As EventHandler(Of EmailDownloadMessageAttachmentCompletedEventArgs), _
    userState As Object _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailMessageAttachment
The EmailMessageAttachment of this EmailInteraction.
completedCallback
Type: System..::..EventHandler<(Of <(<' EmailDownloadMessageAttachmentCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailIsWatching Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailIsWatching Method
EmailInteraction Class See Also Send Feedback
Determines whether an email watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool EmailIsWatching()
Visual Basic
Public Function EmailIsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if an email watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether an email watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailStartWatching Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailStartWatching Method
EmailInteraction Class See Also Send Feedback
Starts watching the email interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("EmailStartWatching has been deprecated. Use EmailStartWatchingWithEvent instead.",
    false)]
public void EmailStartWatching()
Visual Basic
<ObsoleteAttribute("EmailStartWatching has been deprecated. Use EmailStartWatchingWithEvent instead.",  _
    False)> _
Public Sub EmailStartWatching

Exceptions

Exception | Condition
System..::..InvalidOperationException | The email is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailStartWatchingAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailStartWatchingAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously starts watching the email interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("EmailStartWatchingAsync has been deprecated. Use EmailStartWatchingWithEventAsync instead.",
    false)]
public void EmailStartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("EmailStartWatchingAsync has been deprecated. Use EmailStartWatchingWithEventAsync instead.",  _
    False)> _
Public Sub EmailStartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailStartWatchingWithEvent Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailStartWatchingWithEvent Method
EmailInteraction Class See Also Send Feedback
Starts watching the email interaction. The content will be unavailable until notified by the EmailContentUpdated event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EmailStartWatchingWithEvent()
Visual Basic
Public Sub EmailStartWatchingWithEvent

Exceptions

Exception | Condition
System..::..InvalidOperationException | The email is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailStartWatchingWithEventAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailStartWatchingWithEventAsync Method
EmailInteraction Class See Also Send Feedback
Starts watching the email interaction asynchronously. The content will be unavailable until notified by the EmailContentUpdated event.

Note: This method is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EmailStartWatchingWithEventAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EmailStartWatchingWithEventAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
userState
Type: System..::..Object

Exceptions

Exception | Condition
System..::..InvalidOperationException | The email is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailStopWatching Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailStopWatching Method
EmailInteraction Class See Also Send Feedback
Stops watching the emails interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EmailStopWatching()
Visual Basic
Public Sub EmailStopWatching

Exceptions

Exception | Condition
System..::..InvalidOperationException | The email is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailStopWatchingAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..EmailStopWatchingAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously stops watching the emails interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EmailStopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EmailStopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


GenerateContentId Method

[image]

IceLib Technical Reference
EmailInteraction..::..GenerateContentId Method
EmailInteraction Class See Also Send Feedback
Generates a Content-ID to use when uploading a file as an inline attachment.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GenerateContentId(
    string fileName
)
Visual Basic
Public Function GenerateContentId ( _
    fileName As String _
) As String

Parameters

fileName
Type: System..::..String
The path and name of the local file that will be uploaded as the inline attachment.

Return Value

The generated Content-ID conforming to RFCs 2111 and 822.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


GetContent Method

[image]

IceLib Technical Reference
EmailInteraction..::..GetContent Method
EmailInteraction Class See Also Send Feedback
Gets the email content.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContent GetContent()
Visual Basic
Public Function GetContent As EmailContent

Return Value

The EmailContent.

Remarks

A call to EmailStartWatching()()()() or EmailStartWatchingAsync(AsyncCompletedEventHandler, Object) is required to initialize the cache.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The email is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


HasEmailContent Method

[image]

IceLib Technical Reference
EmailInteraction..::..HasEmailContent Method
EmailInteraction Class See Also Send Feedback
Determines whether this email has content.

Note: This method is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasEmailContent()
Visual Basic
Public Function HasEmailContent As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this email has content; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


RemoveFileAttachment Method

[image]

IceLib Technical Reference
EmailInteraction..::..RemoveFileAttachment Method
EmailInteraction Class See Also Send Feedback
Removes an attachment from the current EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveFileAttachment(
    EmailFileAttachment emailAttachment
)
Visual Basic
Public Sub RemoveFileAttachment ( _
    emailAttachment As EmailFileAttachment _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailFileAttachment
The EmailFileAttachment of this EmailInteraction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The email is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


RemoveFileAttachmentAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..RemoveFileAttachmentAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously removes an attachment from the current EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveFileAttachmentAsync(
    EmailFileAttachment emailAttachment,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RemoveFileAttachmentAsync ( _
    emailAttachment As EmailFileAttachment, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

emailAttachment
Type: ININ.IceLib.Interactions..::..EmailFileAttachment
The EmailFileAttachment of this EmailInteraction.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


SaveEmail Method

[image]

IceLib Technical Reference
EmailInteraction..::..SaveEmail Method
EmailInteraction Class See Also Send Feedback
Saves the email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveEmail()
Visual Basic
Public Sub SaveEmail

Exceptions

Exception | Condition
System..::..InvalidOperationException | This is a read only email, saving an email that is in read only mode is invalid.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


SaveEmailAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..SaveEmailAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously saves the email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveEmailAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SaveEmailAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This is a read only email, saving an email that is in read only mode is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


SendEmail Method

[image]

IceLib Technical Reference
EmailInteraction..::..SendEmail Method
EmailInteraction Class See Also Send Feedback
Sends the email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendEmail()
Visual Basic
Public Sub SendEmail

Exceptions

Exception | Condition
System..::..InvalidOperationException | This is a read only email, sending an email that is in read only mode is invalid.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


SendEmailAsync Method

[image]

IceLib Technical Reference
EmailInteraction..::..SendEmailAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously sends the email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendEmailAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SendEmailAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This is a read only email, sending an email that is in read only mode is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


SupportsResponseType Method

[image]

IceLib Technical Reference
EmailInteraction..::..SupportsResponseType Method
EmailInteraction Class See Also Send Feedback
Determines if this email supports the given response type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SupportsResponseType(
    EmailResponseType type
)
Visual Basic
Public Function SupportsResponseType ( _
    type As EmailResponseType _
) As Boolean

Parameters

type
Type: ININ.IceLib.Interactions..::..EmailResponseType
The type.

Return Value

trueTruetruetrue (True in Visual Basic) if the type is supported; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


UploadFileAttachment Method

[image] [image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachment Method
EmailInteraction Class See Also Send Feedback
Uploads a file to the server as an attachment on this EmailInteraction.

Overload List

 | Name | Description
Public method | UploadFileAttachment(String) | Uploads an attachment from a local file to this EmailInteraction.
Public method | UploadFileAttachment(Stream, String) | Uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachment(String, String) | Uploads an attachment from a local file to this EmailInteraction.
Public method | UploadFileAttachment(Stream, String, String) | Uploads an attachment to this EmailInteraction from a given Stream.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


UploadFileAttachment Method (String)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachment Method (String)
EmailInteraction Class See Also Send Feedback
Uploads an attachment from a local file to this EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachment(
    string fileName
)
Visual Basic
Public Sub UploadFileAttachment ( _
    fileName As String _
)

Parameters

fileName
Type: System..::..String
The path and name of a local file to upload the attachment from.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachment Overload
ININ.IceLib.Interactions Namespace


UploadFileAttachment Method (Stream, String)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachment Method (Stream, String)
EmailInteraction Class See Also Send Feedback
Uploads an attachment to this EmailInteraction from a given Stream.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachment(
    Stream inputStream,
    string fileName
)
Visual Basic
Public Sub UploadFileAttachment ( _
    inputStream As Stream, _
    fileName As String _
)

Parameters

inputStream
Type: System.IO..::..Stream
The Stream from which the file content should be read.
fileName
Type: System..::..String
The file name to be given to the created attachment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachment Overload
ININ.IceLib.Interactions Namespace


UploadFileAttachment Method (String, String)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachment Method (String, String)
EmailInteraction Class See Also Send Feedback
Uploads an attachment from a local file to this EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachment(
    string fileName,
    string contentId
)
Visual Basic
Public Sub UploadFileAttachment ( _
    fileName As String, _
    contentId As String _
)

Parameters

fileName
Type: System..::..String
The path and name of a local file to upload the attachment from.
contentId
Type: System..::..String
The Content-ID for an inline attachment conforming to RFC 2111.

Remarks

A non-null, non-empty Content-ID must be provided to create an inline attachment. Inline attachments conform to RFC 2111, and appear within the body of an email if a Content-ID is provided and the HTML email body includes an element (e.g. <img>) associated to a valid URL using the cid: URL scheme.

Use GenerateContentId(String) to generate a unique Content-ID for an inline attachment prior to uploading it.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachment Overload
ININ.IceLib.Interactions Namespace
EmailInteraction..::..GenerateContentId(String)


UploadFileAttachment Method (Stream, String, String)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachment Method (Stream, String, String)
EmailInteraction Class See Also Send Feedback
Uploads an attachment to this EmailInteraction from a given Stream.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachment(
    Stream inputStream,
    string fileName,
    string contentId
)
Visual Basic
Public Sub UploadFileAttachment ( _
    inputStream As Stream, _
    fileName As String, _
    contentId As String _
)

Parameters

inputStream
Type: System.IO..::..Stream
The Stream from which the file content should be read.
fileName
Type: System..::..String
The file name to be given to the created attachment.
contentId
Type: System..::..String
The Content-ID for an inline attachment conforming to RFC 2111.

Remarks

A non-null, non-empty Content-ID must be provided to create an inline attachment. Inline attachments conform to RFC 2111, and appear within the body of an email if a Content-ID is provided and the HTML email body includes an element (e.g. <img>) associated to a valid URL using the cid: URL scheme.

Use GenerateContentId(String) to generate a unique Content-ID for an inline attachment prior to uploading it.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachment Overload
ININ.IceLib.Interactions Namespace
EmailInteraction..::..GenerateContentId(String)


UploadFileAttachmentAsync Method

[image] [image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachmentAsync Method
EmailInteraction Class See Also Send Feedback
Asynchronously uploads a file to the server as an attachment on this EmailInteraction.

Overload List

 | Name | Description
Public method | UploadFileAttachmentAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment from a local file to the current EmailContent.
Public method | UploadFileAttachmentAsync(Stream, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment to this EmailInteraction from a given Stream.
Public method | UploadFileAttachmentAsync(String, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment from a local file to the current EmailContent.
Public method | UploadFileAttachmentAsync(Stream, String, String, AsyncCompletedEventHandler, Object) | Asynchronously uploads an attachment to this EmailInteraction from a given Stream.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


UploadFileAttachmentAsync Method (String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachmentAsync Method (String, AsyncCompletedEventHandler, Object)
EmailInteraction Class See Also Send Feedback
Asynchronously uploads an attachment from a local file to the current EmailContent.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachmentAsync(
    string fileName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UploadFileAttachmentAsync ( _
    fileName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

fileName
Type: System..::..String
The path and name of a local file to upload the attachment from.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachmentAsync Overload
ININ.IceLib.Interactions Namespace


UploadFileAttachmentAsync Method (Stream, String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachmentAsync Method (Stream, String, AsyncCompletedEventHandler, Object)
EmailInteraction Class See Also Send Feedback
Asynchronously uploads an attachment to this EmailInteraction from a given Stream.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachmentAsync(
    Stream inputStream,
    string fileName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UploadFileAttachmentAsync ( _
    inputStream As Stream, _
    fileName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

inputStream
Type: System.IO..::..Stream
The Stream from which the file content should be read.
fileName
Type: System..::..String
The file name to be given to the created attachment.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachmentAsync Overload
ININ.IceLib.Interactions Namespace


UploadFileAttachmentAsync Method (String, String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachmentAsync Method (String, String, AsyncCompletedEventHandler, Object)
EmailInteraction Class See Also Send Feedback
Asynchronously uploads an attachment from a local file to the current EmailContent.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachmentAsync(
    string fileName,
    string contentId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UploadFileAttachmentAsync ( _
    fileName As String, _
    contentId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

fileName
Type: System..::..String
The path and name of a local file to upload the attachment from.
contentId
Type: System..::..String
The Content-ID for an inline attachment conforming to RFC 2111.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

A non-null, non-empty Content-ID must be provided to create an inline attachment. Inline attachments conform to RFC 2111, and appear within the body of an email if a Content-ID is provided and the HTML email body includes an element (e.g. <img>) associated to a valid URL using the cid: URL scheme.

Use GenerateContentId(String) to generate a unique Content-ID for an inline attachment prior to uploading it.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachmentAsync Overload
ININ.IceLib.Interactions Namespace
EmailInteraction..::..GenerateContentId(String)


UploadFileAttachmentAsync Method (Stream, String, String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
EmailInteraction..::..UploadFileAttachmentAsync Method (Stream, String, String, AsyncCompletedEventHandler, Object)
EmailInteraction Class See Also Send Feedback
Asynchronously uploads an attachment to this EmailInteraction from a given Stream.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UploadFileAttachmentAsync(
    Stream inputStream,
    string fileName,
    string contentId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UploadFileAttachmentAsync ( _
    inputStream As Stream, _
    fileName As String, _
    contentId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

inputStream
Type: System.IO..::..Stream
The Stream from which the file content should be read.
fileName
Type: System..::..String
The file name to be given to the created attachment.
contentId
Type: System..::..String
The Content-ID for an inline attachment conforming to RFC 2111.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

A non-null, non-empty Content-ID must be provided to create an inline attachment. Inline attachments conform to RFC 2111, and appear within the body of an email if a Content-ID is provided and the HTML email body includes an element (e.g. <img>) associated to a valid URL using the cid: URL scheme.

Use GenerateContentId(String) to generate a unique Content-ID for an inline attachment prior to uploading it.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
UploadFileAttachmentAsync Overload
ININ.IceLib.Interactions Namespace
EmailInteraction..::..GenerateContentId(String)


EmailInteraction Properties

[image] [image]

IceLib Technical Reference
EmailInteraction Properties
EmailInteraction Class See Also Send Feedback

The EmailInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | ConversationId | Gets the conversation identifier.
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | EmailCapabilities | Gets the email capabilities portion of Capabilities.
Public property | EmailType | Gets the response type of EmailType.
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsReadOnly | Gets a value indicating whether this instance is read only.
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | ParentInteraction | Gets the parent interaction ID.
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

EmailInteraction Class
ININ.IceLib.Interactions Namespace


ConversationId Property

[image]

IceLib Technical Reference
EmailInteraction..::..ConversationId Property
EmailInteraction Class See Also Send Feedback
Gets the conversation identifier.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ConversationId { get; }
Visual Basic
Public ReadOnly Property ConversationId As String
    Get

Field Value

The conversation identifier.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailCapabilities Property

[image]

IceLib Technical Reference
EmailInteraction..::..EmailCapabilities Property
EmailInteraction Class See Also Send Feedback
Gets the email capabilities portion of Capabilities.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteractionCapabilities EmailCapabilities { get; }
Visual Basic
Public ReadOnly Property EmailCapabilities As EmailInteractionCapabilities
    Get

Field Value

The email capabilities.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailType Property

[image]

IceLib Technical Reference
EmailInteraction..::..EmailType Property
EmailInteraction Class See Also Send Feedback
Gets the response type of EmailType.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailResponseType EmailType { get; }
Visual Basic
Public ReadOnly Property EmailType As EmailResponseType
    Get

Field Value

The email capabilities.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


IsReadOnly Property

[image]

IceLib Technical Reference
EmailInteraction..::..IsReadOnly Property
EmailInteraction Class See Also Send Feedback
Gets a value indicating whether this instance is read only.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is read only; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


ParentInteraction Property

[image]

IceLib Technical Reference
EmailInteraction..::..ParentInteraction Property
EmailInteraction Class See Also Send Feedback
Gets the parent interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId ParentInteraction { get; }
Visual Basic
Public ReadOnly Property ParentInteraction As InteractionId
    Get

Field Value

The parent interaction ID.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailInteraction Events

[image] [image]

IceLib Technical Reference
EmailInteraction Events
EmailInteraction Class See Also Send Feedback

The EmailInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | EmailContentUpdated | Occurs when the email content changes or is received for the first time.
Public event | EmailUpdated | Obsolete. Occurs when the email response changes.
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

EmailInteraction Class
ININ.IceLib.Interactions Namespace


EmailContentUpdated Event

[image]

IceLib Technical Reference
EmailInteraction..::..EmailContentUpdated Event
EmailInteraction Class See Also Send Feedback
Occurs when the email content changes or is received for the first time.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EmailContentUpdateEventArgs> EmailContentUpdated
Visual Basic
Public Event EmailContentUpdated As EventHandler(Of EmailContentUpdateEventArgs)

Remarks

This event is invoked when using EmailStartWatchingWithEvent()()()(). The start watching method will return immediately or throw an exception if there was a problem starting the watch. This event will be raised whenever the email content is received from the server.

Version Information

Supported for IC Server version 2015 R1 and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailUpdated Event

[image]

IceLib Technical Reference
EmailInteraction..::..EmailUpdated Event
EmailInteraction Class See Also Send Feedback
Occurs when the email response changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("EmailUpdated has been deprecated. Use EmailContentUpdated with EmailStartWatchingWithEvent instead.",
    false)]
public event EventHandler EmailUpdated
Visual Basic
<ObsoleteAttribute("EmailUpdated has been deprecated. Use EmailContentUpdated with EmailStartWatchingWithEvent instead.",  _
    False)> _
Public Event EmailUpdated As EventHandler

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteraction Class
EmailInteraction Members
ININ.IceLib.Interactions Namespace


EmailInteractionAttributeName Class

[image]

IceLib Technical Reference
EmailInteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class EmailInteractionAttributeName : InteractionAttributeName
Visual Basic
Public MustInherit Class EmailInteractionAttributeName _
    Inherits InteractionAttributeName

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.Interactions..::..EmailInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


EmailInteractionAttributeName Members

[image] [image]

IceLib Technical Reference
EmailInteractionAttributeName Members
EmailInteractionAttributeName Class Methods Fields See Also Send Feedback

The EmailInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ConversationId | The ID of the conversation this email belongs to.
EmailType | The type of the email.
ParentInteractionId | The interaction ID of the parent email.

See Also

EmailInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


EmailInteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
EmailInteractionAttributeName Fields
EmailInteractionAttributeName Class See Also Send Feedback

The EmailInteractionAttributeName type exposes the following members.

Fields

Name | Description
ConversationId | The ID of the conversation this email belongs to.
EmailType | The type of the email.
ParentInteractionId | The interaction ID of the parent email.

See Also

EmailInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


ConversationId Field

[image]

IceLib Technical Reference
EmailInteractionAttributeName..::..ConversationId Field
EmailInteractionAttributeName Class See Also Send Feedback
The ID of the conversation this email belongs to.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ConversationId
Visual Basic
Public Shared ReadOnly ConversationId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionAttributeName Class
EmailInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


EmailType Field

[image]

IceLib Technical Reference
EmailInteractionAttributeName..::..EmailType Field
EmailInteractionAttributeName Class See Also Send Feedback
The type of the email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string EmailType
Visual Basic
Public Shared ReadOnly EmailType As String

Remarks

"S"=System
"N"=New
"R"=Reply
"A"=AutoReply
"F"=Forward

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionAttributeName Class
EmailInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


ParentInteractionId Field

[image]

IceLib Technical Reference
EmailInteractionAttributeName..::..ParentInteractionId Field
EmailInteractionAttributeName Class See Also Send Feedback
The interaction ID of the parent email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ParentInteractionId
Visual Basic
Public Shared ReadOnly ParentInteractionId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionAttributeName Class
EmailInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


EmailInteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
EmailInteractionAttributeName Methods
EmailInteractionAttributeName Class See Also Send Feedback

The EmailInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


EmailInteractionCapabilities Enumeration

[image]

IceLib Technical Reference
EmailInteractionCapabilities Enumeration
See Also Send Feedback
Specifies constants indicating the capabilities of an EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum EmailInteractionCapabilities
Visual Basic
<FlagsAttribute> _
Public Enumeration EmailInteractionCapabilities

Members

Member name | Value | Description
None | 0 | The email has no capabilities.
Edit | 1 | The email can be edited.
Reply | 2 | The email can be replied to.
ReplyAll | 4 | The email supports performing a reply all.
Forward | 8 | The email can be forwarded.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


EmailInteractionParameters Class

[image]

IceLib Technical Reference
EmailInteractionParameters Class
Members See Also Send Feedback
Provides details when making an email via InteractionsManager's MakeEmail method.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailInteractionParameters
Visual Basic
Public Class EmailInteractionParameters

Remarks

Note
At this time, creating inbound email interactions is not supported.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailInteractionParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


EmailInteractionParameters Members

[image] [image]

IceLib Technical Reference
EmailInteractionParameters Members
EmailInteractionParameters Class Constructors Methods Properties See Also Send Feedback

The EmailInteractionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | EmailInteractionParameters(EmailContent) | Initializes a new instance of the EmailInteractionParameters class to be used to create a new email from scratch.
Public method | EmailInteractionParameters(EmailContent, EmailInteraction, EmailResponseType) | Initializes a new instance of the EmailInteractionParameters class to be used to create a new email in response to an existing email.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of EmailInteractionParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | Content | Gets the content.
Public property | OnBehalfOfWorkgroup | Gets or sets the on behalf of workgroup.
Public property | ParentEmailId | Gets the parent email ID.
Public property | ResponseType | Gets the response type.

See Also

EmailInteractionParameters Class
ININ.IceLib.Interactions Namespace


EmailInteractionParameters Constructor

[image] [image]

IceLib Technical Reference
EmailInteractionParameters Constructor
EmailInteractionParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmailInteractionParameters(EmailContent) | Initializes a new instance of the EmailInteractionParameters class to be used to create a new email from scratch.
Public method | EmailInteractionParameters(EmailContent, EmailInteraction, EmailResponseType) | Initializes a new instance of the EmailInteractionParameters class to be used to create a new email in response to an existing email.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


EmailInteractionParameters Constructor (EmailContent)

[image]

IceLib Technical Reference
EmailInteractionParameters Constructor (EmailContent)
EmailInteractionParameters Class See Also Send Feedback
Initializes a new instance of the EmailInteractionParameters class to be used to create a new email from scratch.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteractionParameters(
    EmailContent content
)
Visual Basic
Public Sub New ( _
    content As EmailContent _
)

Parameters

content
Type: ININ.IceLib.Interactions..::..EmailContent
The new initial content.

Remarks

Note
At this time, creating inbound email interactions is not supported.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
EmailInteractionParameters Overload
ININ.IceLib.Interactions Namespace


EmailInteractionParameters Constructor (EmailContent, EmailInteraction, EmailResponseType)

[image]

IceLib Technical Reference
EmailInteractionParameters Constructor (EmailContent, EmailInteraction, EmailResponseType)
EmailInteractionParameters Class See Also Send Feedback
Initializes a new instance of the EmailInteractionParameters class to be used to create a new email in response to an existing email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteractionParameters(
    EmailContent content,
    EmailInteraction parentEmail,
    EmailResponseType responseType
)
Visual Basic
Public Sub New ( _
    content As EmailContent, _
    parentEmail As EmailInteraction, _
    responseType As EmailResponseType _
)

Parameters

content
Type: ININ.IceLib.Interactions..::..EmailContent
The new initial content.
parentEmail
Type: ININ.IceLib.Interactions..::..EmailInteraction
The the email that this is in response to.
responseType
Type: ININ.IceLib.Interactions..::..EmailResponseType
The type of response this email is.

Remarks

Use CloneForResponse(EmailCloneAttachmentType) to create content for the new message.
Note
At this time, creating inbound email interactions is not supported.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter was invalid.
System..::..InvalidOperationException | The requested response email could not be created.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
EmailInteractionParameters Overload
ININ.IceLib.Interactions Namespace


EmailInteractionParameters Methods

[image] [image]

IceLib Technical Reference
EmailInteractionParameters Methods
EmailInteractionParameters Class See Also Send Feedback

The EmailInteractionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of EmailInteractionParameters. (Overrides Object..::..ToString()()()().)

See Also

EmailInteractionParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
EmailInteractionParameters..::..ToString Method
EmailInteractionParameters Class See Also Send Feedback
Gets the string representation of EmailInteractionParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


EmailInteractionParameters Properties

[image] [image]

IceLib Technical Reference
EmailInteractionParameters Properties
EmailInteractionParameters Class See Also Send Feedback

The EmailInteractionParameters type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | Content | Gets the content.
Public property | OnBehalfOfWorkgroup | Gets or sets the on behalf of workgroup.
Public property | ParentEmailId | Gets the parent email ID.
Public property | ResponseType | Gets the response type.

See Also

EmailInteractionParameters Class
ININ.IceLib.Interactions Namespace


AdditionalAttributes Property

[image]

IceLib Technical Reference
EmailInteractionParameters..::..AdditionalAttributes Property
EmailInteractionParameters Class See Also Send Feedback
Gets a collection which can be used to set additional attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> AdditionalAttributes { get; }
Visual Basic
Public ReadOnly Property AdditionalAttributes As IDictionary(Of String, String)
    Get

Field Value

The additional attributes collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


Content Property

[image]

IceLib Technical Reference
EmailInteractionParameters..::..Content Property
EmailInteractionParameters Class See Also Send Feedback
Gets the content.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailContent Content { get; }
Visual Basic
Public ReadOnly Property Content As EmailContent
    Get

Field Value

The content.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


OnBehalfOfWorkgroup Property

[image]

IceLib Technical Reference
EmailInteractionParameters..::..OnBehalfOfWorkgroup Property
EmailInteractionParameters Class See Also Send Feedback
Gets or sets the on behalf of workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OnBehalfOfWorkgroup { get; set; }
Visual Basic
Public Property OnBehalfOfWorkgroup As String
    Get
    Set

Field Value

The on behalf of workgroup.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The value was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


ParentEmailId Property

[image]

IceLib Technical Reference
EmailInteractionParameters..::..ParentEmailId Property
EmailInteractionParameters Class See Also Send Feedback
Gets the parent email ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId ParentEmailId { get; }
Visual Basic
Public ReadOnly Property ParentEmailId As InteractionId
    Get

Field Value

The parent email ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


ResponseType Property

[image]

IceLib Technical Reference
EmailInteractionParameters..::..ResponseType Property
EmailInteractionParameters Class See Also Send Feedback
Gets the response type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailResponseType ResponseType { get; }
Visual Basic
Public ReadOnly Property ResponseType As EmailResponseType
    Get

Field Value

The response type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailInteractionParameters Class
EmailInteractionParameters Members
ININ.IceLib.Interactions Namespace


EmailMessageAttachment Class

[image]

IceLib Technical Reference
EmailMessageAttachment Class
Members See Also Send Feedback
Represents a message attachment to a EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailMessageAttachment
Visual Basic
Public Class EmailMessageAttachment

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailMessageAttachment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAttachment Members
ININ.IceLib.Interactions Namespace


EmailMessageAttachment Members

[image] [image]

IceLib Technical Reference
EmailMessageAttachment Members
EmailMessageAttachment Class Methods Properties See Also Send Feedback

The EmailMessageAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailAttachment object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Subject | Gets the subject.

See Also

EmailMessageAttachment Class
ININ.IceLib.Interactions Namespace


EmailMessageAttachment Methods

[image] [image]

IceLib Technical Reference
EmailMessageAttachment Methods
EmailMessageAttachment Class See Also Send Feedback

The EmailMessageAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | The Equals method determines whether the specified System.Object is equal to the current EmailAttachment object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailMessageAttachment Class
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailMessageAttachment..::..Equals Method
EmailMessageAttachment Class See Also Send Feedback
The Equals method determines whether the specified System.Object is equal to the current EmailAttachment object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAttachment Class
EmailMessageAttachment Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailMessageAttachment..::..GetHashCode Method
EmailMessageAttachment Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailMessageAttachment Class
EmailMessageAttachment Members
ININ.IceLib.Interactions Namespace


EmailMessageAttachment Properties

[image] [image]

IceLib Technical Reference
EmailMessageAttachment Properties
EmailMessageAttachment Class See Also Send Feedback

The EmailMessageAttachment type exposes the following members.

Properties

 | Name | Description
Public property | Subject | Gets the subject.

See Also

EmailMessageAttachment Class
ININ.IceLib.Interactions Namespace


Subject Property

[image]

IceLib Technical Reference
EmailMessageAttachment..::..Subject Property
EmailMessageAttachment Class See Also Send Feedback
Gets the subject.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Subject { get; }
Visual Basic
Public ReadOnly Property Subject As String
    Get

Field Value

The subject.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAttachment Class
EmailMessageAttachment Members
ININ.IceLib.Interactions Namespace


EmailPriority Enumeration

[image]

IceLib Technical Reference
EmailPriority Enumeration
See Also Send Feedback
The priority of an e-mail.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EmailPriority
Visual Basic
Public Enumeration EmailPriority

Members

Member name | Value | Description
None | 0 | No priority.
Normal | 1 | Normal priority.
Low | 2 | Low priority.
High | 3 | High priority.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


EmailResolver Class

[image]

IceLib Technical Reference
EmailResolver Class
Members See Also Send Feedback
Allows resolving Email addresses within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailResolver
Visual Basic
Public Class EmailResolver

Remarks

This class takes a string containing a full or partial Email address and the IC server resolves it into an array of EmailAddress objects.

To resolve an Email address string, pass it to the ResolveName(String) or ResolveNameAsync(String, AsyncCompletedEventHandler, Object) methods. When the asynchronous resolve name operation completes it invokes the completedCallback delegate. When the server has finished resolving the Email address it triggers the EmailResolved event. The resolved email addresses are returned in the EmailAddressesEventArgs object of this event.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailResolver

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Members
ININ.IceLib.Interactions Namespace


EmailResolver Members

[image] [image]

IceLib Technical Reference
EmailResolver Members
EmailResolver Class Constructors Methods Properties Events See Also Send Feedback

The EmailResolver type exposes the following members.

Constructors

 | Name | Description
Public method | EmailResolver | Initializes a new instance of the EmailResolver class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveName | Resolves an email address.
Public method | ResolveNameAsync | Asynchronously resolves an email address.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated.
Public property | MaxResults | Gets or sets the maximum number of results to include in the Results property of EmailAddressesEventArgs when the EmailResolved event is raised.

Events

 | Name | Description
Public event | EmailResolved | Occurs when Email recipients have been resolved.

See Also

EmailResolver Class
ININ.IceLib.Interactions Namespace


EmailResolver Constructor

[image]

IceLib Technical Reference
EmailResolver Constructor
EmailResolver Class See Also Send Feedback
Initializes a new instance of the EmailResolver class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailResolver(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Class
EmailResolver Members
ININ.IceLib.Interactions Namespace


EmailResolver Methods

[image] [image]

IceLib Technical Reference
EmailResolver Methods
EmailResolver Class See Also Send Feedback

The EmailResolver type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveName | Resolves an email address.
Public method | ResolveNameAsync | Asynchronously resolves an email address.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailResolver Class
ININ.IceLib.Interactions Namespace


ResolveName Method

[image]

IceLib Technical Reference
EmailResolver..::..ResolveName Method
EmailResolver Class See Also Send Feedback
Resolves an email address.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ResolveName(
    string addressSearch
)
Visual Basic
Public Sub ResolveName ( _
    addressSearch As String _
)

Parameters

addressSearch
Type: System..::..String
The full or partial address.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Class
EmailResolver Members
ININ.IceLib.Interactions Namespace


ResolveNameAsync Method

[image]

IceLib Technical Reference
EmailResolver..::..ResolveNameAsync Method
EmailResolver Class See Also Send Feedback
Asynchronously resolves an email address.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ResolveNameAsync(
    string addressSearch,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ResolveNameAsync ( _
    addressSearch As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

addressSearch
Type: System..::..String
The full or partial address.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Class
EmailResolver Members
ININ.IceLib.Interactions Namespace


EmailResolver Properties

[image] [image]

IceLib Technical Reference
EmailResolver Properties
EmailResolver Class See Also Send Feedback

The EmailResolver type exposes the following members.

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated.
Public property | MaxResults | Gets or sets the maximum number of results to include in the Results property of EmailAddressesEventArgs when the EmailResolved event is raised.

See Also

EmailResolver Class
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
EmailResolver..::..InteractionsManager Property
EmailResolver Class See Also Send Feedback
Gets the InteractionManager with which this Interaction is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Class
EmailResolver Members
ININ.IceLib.Interactions Namespace


MaxResults Property

[image]

IceLib Technical Reference
EmailResolver..::..MaxResults Property
EmailResolver Class See Also Send Feedback
Gets or sets the maximum number of results to include in the Results property of EmailAddressesEventArgs when the EmailResolved event is raised.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaxResults { get; set; }
Visual Basic
Public Property MaxResults As Integer
    Get
    Set

Field Value

The maximum number of results.

Remarks

A value less than zero indicates that all results should be returned.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Class
EmailResolver Members
ININ.IceLib.Interactions Namespace


EmailResolver Events

[image] [image]

IceLib Technical Reference
EmailResolver Events
EmailResolver Class See Also Send Feedback

The EmailResolver type exposes the following members.

Events

 | Name | Description
Public event | EmailResolved | Occurs when Email recipients have been resolved.

See Also

EmailResolver Class
ININ.IceLib.Interactions Namespace


EmailResolved Event

[image]

IceLib Technical Reference
EmailResolver..::..EmailResolved Event
EmailResolver Class See Also Send Feedback
Occurs when Email recipients have been resolved.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EmailAddressesEventArgs> EmailResolved
Visual Basic
Public Event EmailResolved As EventHandler(Of EmailAddressesEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailResolver Class
EmailResolver Members
ININ.IceLib.Interactions Namespace


EmailResponseType Enumeration

[image]

IceLib Technical Reference
EmailResponseType Enumeration
See Also Send Feedback
Specifies constants indicating the response type of an EmailInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EmailResponseType
Visual Basic
Public Enumeration EmailResponseType

Members

Member name | Value | Description
None | 0 | No response type specified.
New | 1 | An email created from scratch.
Reply | 2 | An email that is a reply to an existing email.
ReplyAll | 3 | An email that is a reply all to an existing email.
Forward | 4 | An email that is a forward of an existing email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


EmailSignatureCertificate Class

[image]

IceLib Technical Reference
EmailSignatureCertificate Class
Members See Also Send Feedback
Definition for EmailSignatureCertificate class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailSignatureCertificate
Visual Basic
Public Class EmailSignatureCertificate

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..EmailSignatureCertificate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailSignatureCertificate Members
ININ.IceLib.Interactions Namespace


EmailSignatureCertificate Members

[image] [image]

IceLib Technical Reference
EmailSignatureCertificate Members
EmailSignatureCertificate Class Methods Properties See Also Send Feedback

The EmailSignatureCertificate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Certificate | Gets the certificate.
Public property | Status | Gets the signature status.

See Also

EmailSignatureCertificate Class
ININ.IceLib.Interactions Namespace


EmailSignatureCertificate Methods

[image] [image]

IceLib Technical Reference
EmailSignatureCertificate Methods
EmailSignatureCertificate Class See Also Send Feedback

The EmailSignatureCertificate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailSignatureCertificate Class
ININ.IceLib.Interactions Namespace


Equals Method

[image]

IceLib Technical Reference
EmailSignatureCertificate..::..Equals Method
EmailSignatureCertificate Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Security.Cryptography..::..CryptographicException | The certificate handle is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailSignatureCertificate Class
EmailSignatureCertificate Members
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
EmailSignatureCertificate..::..GetHashCode Method
EmailSignatureCertificate Class See Also Send Feedback
Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailSignatureCertificate Class
EmailSignatureCertificate Members
ININ.IceLib.Interactions Namespace


EmailSignatureCertificate Properties

[image] [image]

IceLib Technical Reference
EmailSignatureCertificate Properties
EmailSignatureCertificate Class See Also Send Feedback

The EmailSignatureCertificate type exposes the following members.

Properties

 | Name | Description
Public property | Certificate | Gets the certificate.
Public property | Status | Gets the signature status.

See Also

EmailSignatureCertificate Class
ININ.IceLib.Interactions Namespace


Certificate Property

[image]

IceLib Technical Reference
EmailSignatureCertificate..::..Certificate Property
EmailSignatureCertificate Class See Also Send Feedback
Gets the certificate.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public X509Certificate2 Certificate { get; }
Visual Basic
Public ReadOnly Property Certificate As X509Certificate2
    Get

Field Value

The certificate.

Exceptions

Exception | Condition
System.Security.Cryptography..::..CryptographicException | The certificate handle is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailSignatureCertificate Class
EmailSignatureCertificate Members
ININ.IceLib.Interactions Namespace


Status Property

[image]

IceLib Technical Reference
EmailSignatureCertificate..::..Status Property
EmailSignatureCertificate Class See Also Send Feedback
Gets the signature status.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailSignatureStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As EmailSignatureStatus
    Get

Field Value

The signature status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EmailSignatureCertificate Class
EmailSignatureCertificate Members
ININ.IceLib.Interactions Namespace


EmailSignatureStatus Enumeration

[image]

IceLib Technical Reference
EmailSignatureStatus Enumeration
See Also Send Feedback
Possible status of an DigitalSignatures.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum EmailSignatureStatus
Visual Basic
<FlagsAttribute> _
Public Enumeration EmailSignatureStatus

Members

Member name | Value | Description
Unknown | 255 | Any sort of catastrophic failure (malformed S/MIME, internal error, etc.).
Ok | 0 | Signature does not show any known problems.
MessageModified | 1 | The cryptographic hash does not match the message. Message was possibly tampered with in transit.
CertificateNotTrusted | 2 | The signer's certificate is not trusted. This could be for various reasons: * One or more of the certificates in the chain is missing from the certificate store or is not trusted. * The signer's certificate has expired or is not yet valid. * The signer's certificate does not have Digital Signature or Email Protection (1.3.6.1.5.5.7.3.4) as a valid use.
EmailHeaderMismatch | 4 | The From: address in the email's header does not match the email address in the certificate.

Remarks

Any flag being on would indicate that the signature has some errors. Please note that 'Unknown' has a value of 0xFF (255) - which has 7 bits on.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


GenericInteraction Class

[image]

IceLib Technical Reference
GenericInteraction Class
Members See Also Send Feedback
Represents a generic interaction object within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GenericInteraction : Interaction
Visual Basic
Public Class GenericInteraction _
    Inherits Interaction

Remarks

Generic interactions are generic objects that can be placed on queues and instantiated as part of an interaction queue watch.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..GenericInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteraction Members
ININ.IceLib.Interactions Namespace


GenericInteraction Members

[image] [image]

IceLib Technical Reference
GenericInteraction Members
GenericInteraction Class Constructors Methods Properties Events See Also Send Feedback

The GenericInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | GenericInteraction | Initializes a new instance of the GenericInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

GenericInteraction Class
ININ.IceLib.Interactions Namespace


GenericInteraction Constructor

[image]

IceLib Technical Reference
GenericInteraction Constructor
GenericInteraction Class See Also Send Feedback
Initializes a new instance of the GenericInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GenericInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteraction Class
GenericInteraction Members
ININ.IceLib.Interactions Namespace


GenericInteraction Methods

[image] [image]

IceLib Technical Reference
GenericInteraction Methods
GenericInteraction Class See Also Send Feedback

The GenericInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

GenericInteraction Class
ININ.IceLib.Interactions Namespace


GenericInteraction Properties

[image] [image]

IceLib Technical Reference
GenericInteraction Properties
GenericInteraction Class See Also Send Feedback

The GenericInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

GenericInteraction Class
ININ.IceLib.Interactions Namespace


GenericInteraction Events

[image] [image]

IceLib Technical Reference
GenericInteraction Events
GenericInteraction Class See Also Send Feedback

The GenericInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

GenericInteraction Class
ININ.IceLib.Interactions Namespace


GenericInteractionParameters Class

[image]

IceLib Technical Reference
GenericInteractionParameters Class
Members See Also Send Feedback
Provides details when creating Generic Interactions via MakeGenericInteraction(GenericInteractionParameters).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GenericInteractionParameters
Visual Basic
Public Class GenericInteractionParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..GenericInteractionParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


GenericInteractionParameters Members

[image] [image]

IceLib Technical Reference
GenericInteractionParameters Members
GenericInteractionParameters Class Constructors Methods Properties See Also Send Feedback

The GenericInteractionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | GenericInteractionParameters | Initializes a new instance of the GenericInteractionParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of GenericInteractionParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | InitialState | Gets the initial state.
Public property | InteractionDirection | Gets or sets the interaction direction.
Public property | LocalLocation | Gets or sets the local location.
Public property | LocalPartyType | Gets or sets the type of the local party.
Public property | RemoteId | Gets or sets the remote ID.
Public property | RemoteName | Gets or sets the name of the remote.
Public property | RemotePartyType | Gets or sets the type of the remote party.
Public property | TargetQueueId | Gets the queue ID.

See Also

GenericInteractionParameters Class
ININ.IceLib.Interactions Namespace


GenericInteractionParameters Constructor

[image]

IceLib Technical Reference
GenericInteractionParameters Constructor
GenericInteractionParameters Class See Also Send Feedback
Initializes a new instance of the GenericInteractionParameters class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GenericInteractionParameters(
    QueueId targetQueueId,
    InteractionState initialState
)
Visual Basic
Public Sub New ( _
    targetQueueId As QueueId, _
    initialState As InteractionState _
)

Parameters

targetQueueId
Type: ININ.IceLib.Interactions..::..QueueId
The ID of the target queue.
initialState
Type: ININ.IceLib.Interactions..::..InteractionState
The initial state.

Remarks

initialState can be one of Alerting, Connected, Held, Parked, Internal Disconnect, External Disconnect, Offering, System, Proceeding or Messaging

Exceptions

Exception | Condition
System..::..ArgumentException | targetQueueId is nullNothingnullptra null reference (Nothing in Visual Basic), or initialState is not one of Alerting, Connected, Held, Parked, Internal Disconnect, External Disconnect, Offering, System, Proceeding or Messaging.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


GenericInteractionParameters Methods

[image] [image]

IceLib Technical Reference
GenericInteractionParameters Methods
GenericInteractionParameters Class See Also Send Feedback

The GenericInteractionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of GenericInteractionParameters. (Overrides Object..::..ToString()()()().)

See Also

GenericInteractionParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
GenericInteractionParameters..::..ToString Method
GenericInteractionParameters Class See Also Send Feedback
Gets the string representation of GenericInteractionParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


GenericInteractionParameters Properties

[image] [image]

IceLib Technical Reference
GenericInteractionParameters Properties
GenericInteractionParameters Class See Also Send Feedback

The GenericInteractionParameters type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets a collection which can be used to set additional attributes.
Public property | InitialState | Gets the initial state.
Public property | InteractionDirection | Gets or sets the interaction direction.
Public property | LocalLocation | Gets or sets the local location.
Public property | LocalPartyType | Gets or sets the type of the local party.
Public property | RemoteId | Gets or sets the remote ID.
Public property | RemoteName | Gets or sets the name of the remote.
Public property | RemotePartyType | Gets or sets the type of the remote party.
Public property | TargetQueueId | Gets the queue ID.

See Also

GenericInteractionParameters Class
ININ.IceLib.Interactions Namespace


AdditionalAttributes Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..AdditionalAttributes Property
GenericInteractionParameters Class See Also Send Feedback
Gets a collection which can be used to set additional attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> AdditionalAttributes { get; internal set; }
Visual Basic
Public Property AdditionalAttributes As IDictionary(Of String, String)
    Get
    Friend Set

Field Value

The additional attributes collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


InitialState Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..InitialState Property
GenericInteractionParameters Class See Also Send Feedback
Gets the initial state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionState InitialState { get; internal set; }
Visual Basic
Public Property InitialState As InteractionState
    Get
    Friend Set

Field Value

The initial state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


InteractionDirection Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..InteractionDirection Property
GenericInteractionParameters Class See Also Send Feedback
Gets or sets the interaction direction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionDirection InteractionDirection { get; set; }
Visual Basic
Public Property InteractionDirection As InteractionDirection
    Get
    Set

Field Value

The interaction direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


LocalLocation Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..LocalLocation Property
GenericInteractionParameters Class See Also Send Feedback
Gets or sets the local location.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalLocation { get; set; }
Visual Basic
Public Property LocalLocation As String
    Get
    Set

Field Value

The local location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


LocalPartyType Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..LocalPartyType Property
GenericInteractionParameters Class See Also Send Feedback
Gets or sets the type of the local party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionPartyType LocalPartyType { get; set; }
Visual Basic
Public Property LocalPartyType As InteractionPartyType
    Get
    Set

Field Value

The type of the local party.

Remarks

local party type can be internal or system.

Exceptions

Exception | Condition
System..::..ArgumentException | LocalPartyType must be Internal when creating objects through IceLib.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


RemoteId Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..RemoteId Property
GenericInteractionParameters Class See Also Send Feedback
Gets or sets the remote ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteId { get; set; }
Visual Basic
Public Property RemoteId As String
    Get
    Set

Field Value

The remote ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


RemoteName Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..RemoteName Property
GenericInteractionParameters Class See Also Send Feedback
Gets or sets the name of the remote.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteName { get; set; }
Visual Basic
Public Property RemoteName As String
    Get
    Set

Field Value

The name of the remote.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


RemotePartyType Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..RemotePartyType Property
GenericInteractionParameters Class See Also Send Feedback
Gets or sets the type of the remote party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionPartyType RemotePartyType { get; set; }
Visual Basic
Public Property RemotePartyType As InteractionPartyType
    Get
    Set

Field Value

The type of the remote party.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


TargetQueueId Property

[image]

IceLib Technical Reference
GenericInteractionParameters..::..TargetQueueId Property
GenericInteractionParameters Class See Also Send Feedback
Gets the queue ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueId TargetQueueId { get; internal set; }
Visual Basic
Public Property TargetQueueId As QueueId
    Get
    Friend Set

Field Value

The queue ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GenericInteractionParameters Class
GenericInteractionParameters Members
ININ.IceLib.Interactions Namespace


GetAttributeCompletedEventArgs(TAttributeValue) Class

[image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of GetBooleanAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Boolean>)>>)>)>>), Object), GetStringAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(String>)>>)>)>>), Object), GetIntegerAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object), and GetDateTimeAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(DateTime>)>>)>)>>), Object) events of a Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetAttributeCompletedEventArgs<TAttributeValue> : AsyncCompletedEventArgs
Visual Basic
Public Class GetAttributeCompletedEventArgs(Of TAttributeValue) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TAttributeValue
The attribute value.

Remarks

An interaction attribute is a piece of information about an interaction that travels with it throughout the Interaction Center. For example, Telephone calls, chat sessions, Emails, and generic objects are entities in IC that have some type of attribute associated with them. Attributes can be created by a variety of entities, including the Interaction Center itself. For example, the Telephony Services subsystem creates default call object attributes when a call object is established. Handlers, IC applications, and programs developed using APIs can create and modify attributes.

Attributes are name/value pairs. To retrieve the value of an attribute, you must know its attribute name. The value of an attribute is usually string data. However, chat and call attributes can contain 32-bit binary data in DWORD format. Email objects return data that is stored in Interaction Designer’s list variable format.

  • Attribute names are not case-sensitive. "Eic_StationName" "eic_stationname" refer to the same attribute.

  • Attributes names that begin with Eic_ are primarily used by Interaction Client to display information about an object.

  • Attributes whose name does not begin with Eic_ are primarily used by handlers or chat objects.

  • Attributes whose name ends with "Raw" contain original, unprocessed values. These attributes are logged for reporting purposes.

  • Directory Services "attributes" are not the same as interaction attributes discussed here. A Directory Services attribute is an item of information that is stored in Directory Services as a registry key. Interaction attributes are name/value pairs that travel with an object as it is processed by the Interaction Center server.

Note
For more information about attributes, see Interaction Attributes Reference Guide in the System APIs section of the IC Documentation library on your IC server.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Members
ININ.IceLib.Interactions Namespace


GetAttributeCompletedEventArgs(TAttributeValue) Members

[image] [image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Members
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class Constructors Methods Properties See Also Send Feedback

The GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> | Initializes a new instance of this class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeName | Gets the attribute name associated with the event.
Public property | AttributeValue | Gets the attribute value associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
ININ.IceLib.Interactions Namespace


GetAttributeCompletedEventArgs(TAttributeValue) Constructor

[image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Constructor
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class See Also Send Feedback
Initializes a new instance of this class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetAttributeCompletedEventArgs(
    string attributeName,
    TAttributeValue attributeValue,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    attributeName As String, _
    attributeValue As TAttributeValue, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
attributeValue
Type: TAttributeValue
The attribute value.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Members
ININ.IceLib.Interactions Namespace


GetAttributeCompletedEventArgs(TAttributeValue) Methods

[image] [image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Methods
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class See Also Send Feedback

The GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
ININ.IceLib.Interactions Namespace


GetAttributeCompletedEventArgs(TAttributeValue) Properties

[image] [image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Properties
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class See Also Send Feedback

The GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AttributeName | Gets the attribute name associated with the event.
Public property | AttributeValue | Gets the attribute value associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
ININ.IceLib.Interactions Namespace


AttributeName Property

[image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)>..::..AttributeName Property
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class See Also Send Feedback
Gets the attribute name associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AttributeName { get; }
Visual Basic
Public ReadOnly Property AttributeName As String
    Get

Field Value

The name of the attribute.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Members
ININ.IceLib.Interactions Namespace


AttributeValue Property

[image]

IceLib Technical Reference
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)>..::..AttributeValue Property
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class See Also Send Feedback
Gets the attribute value associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TAttributeValue AttributeValue { get; }
Visual Basic
Public ReadOnly Property AttributeValue As TAttributeValue
    Get

Field Value

The attribute value.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Class
GetAttributeCompletedEventArgs<(Of <(<'TAttributeValue>)>)> Members
ININ.IceLib.Interactions Namespace


GetContentsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetContentsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of InteractionConference and InteractionQueue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetContentsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetContentsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..GetContentsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetContentsCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


GetContentsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetContentsCompletedEventArgs Members
GetContentsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetContentsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetContentsCompletedEventArgs | Initializes a new instance of the GetContentsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Interactions | Gets the Interactions associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetContentsCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


GetContentsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetContentsCompletedEventArgs Constructor
GetContentsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetContentsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetContentsCompletedEventArgs(
    Interaction[] interactions,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    interactions As Interaction(), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

interactions
Type: array< ININ.IceLib.Interactions..::..Interaction >[]()[][]
The interactions.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetContentsCompletedEventArgs Class
GetContentsCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


GetContentsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetContentsCompletedEventArgs Methods
GetContentsCompletedEventArgs Class See Also Send Feedback

The GetContentsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetContentsCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


GetContentsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetContentsCompletedEventArgs Properties
GetContentsCompletedEventArgs Class See Also Send Feedback

The GetContentsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Interactions | Gets the Interactions associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetContentsCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


Interactions Property

[image]

IceLib Technical Reference
GetContentsCompletedEventArgs..::..Interactions Property
GetContentsCompletedEventArgs Class See Also Send Feedback
Gets the Interactions associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Interaction> Interactions { get; }
Visual Basic
Public ReadOnly Property Interactions As ReadOnlyCollection(Of Interaction)
    Get

Field Value

The interactions.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetContentsCompletedEventArgs Class
GetContentsCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


GetStringAttributesCompletedEventArgs Class

[image]

IceLib Technical Reference
GetStringAttributesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of GetStringAttributesAsync(array<String>[]()[][], EventHandler<(Of <<'(GetStringAttributesCompletedEventArgs>)>>), Object) events of a Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetStringAttributesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetStringAttributesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Remarks

An interaction attribute is a piece of information about an interaction that travels with it throughout the Interaction Center. For example, Telephone calls, chat sessions, Emails, and generic objects are entities in IC that have some type of attribute associated with them. Attributes can be created by a variety of entities, including the Interaction Center itself. For example, the Telephony Services subsystem creates default call object attributes when a call object is established. Handlers, IC applications, and programs developed using APIs can create and modify attributes.

Attributes are name/value pairs. To retrieve the value of an attribute, you must know its attribute name. The value of an attribute is usually string data. However, chat and call attributes can contain 32-bit binary data in DWORD format. Email objects return data that is stored in Interaction Designer’s list variable format.

  • Attribute names are not case-sensitive. "Eic_StationName" "eic_stationname" refer to the same attribute.

  • Attributes names that begin with Eic_ are primarily used by Interaction Client to display information about an object.

  • Attributes whose name does not begin with Eic_ are primarily used by handlers or chat objects.

  • Attributes whose name ends with "Raw" contain original, unprocessed values. These attributes are logged for reporting purposes.

  • Directory Services "attributes" are not the same as interaction attributes discussed here. A Directory Services attribute is an item of information that is stored in Directory Services as a registry key. Interaction attributes are name/value pairs that travel with an object as it is processed by the Interaction Center server.

Note
For more information about attributes, see Interaction Attributes Reference Guide in the System APIs section of the IC Documentation library on your IC server.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..GetStringAttributesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

GetStringAttributesCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


GetStringAttributesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetStringAttributesCompletedEventArgs Members
GetStringAttributesCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetStringAttributesCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetStringAttributesCompletedEventArgs | Initializes a new instance of this class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets the attributes associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetStringAttributesCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


GetStringAttributesCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetStringAttributesCompletedEventArgs Constructor
GetStringAttributesCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of this class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetStringAttributesCompletedEventArgs(
    IDictionary<string, string> attributes,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    attributes As IDictionary(Of String, String), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The attributes.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributes is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

GetStringAttributesCompletedEventArgs Class
GetStringAttributesCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


GetStringAttributesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetStringAttributesCompletedEventArgs Methods
GetStringAttributesCompletedEventArgs Class See Also Send Feedback

The GetStringAttributesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetStringAttributesCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


GetStringAttributesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetStringAttributesCompletedEventArgs Properties
GetStringAttributesCompletedEventArgs Class See Also Send Feedback

The GetStringAttributesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetStringAttributesCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


Attributes Property

[image]

IceLib Technical Reference
GetStringAttributesCompletedEventArgs..::..Attributes Property
GetStringAttributesCompletedEventArgs Class See Also Send Feedback
Gets the attributes associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As IDictionary(Of String, String)
    Get

Field Value

The attributes.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

GetStringAttributesCompletedEventArgs Class
GetStringAttributesCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


HistoryItem Class

[image]

IceLib Technical Reference
HistoryItem Class
Members See Also Send Feedback
Contains history information for an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class HistoryItem
Visual Basic
Public Class HistoryItem

Remarks

The HistoryItem class is a container for history information about a past interaction.

Use the InteractionsHistory class to retrieve HistoryItem objects for the user's interactions.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..HistoryItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..InteractionsHistory


HistoryItem Members

[image] [image]

IceLib Technical Reference
HistoryItem Members
HistoryItem Class Methods Properties See Also Send Feedback

The HistoryItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BeginTime | Gets the time the interaction began.
Public property | Direction | Gets the direction of the interaction.
Public property | EndTime | Gets the time the interaction was disconnected or left the queue.
Public property | InteractionId | Gets the interaction ID of the Interaction to which the history data corresponds.
Public property | InteractionLog | Gets log information about the interaction as a string.
Public property | ItemFlags | Gets flags indicating the status of the interaction.
Public property | LocalAddress | Gets the address of the local party.
Public property | LocalId | Gets the displayable address of local party.
Public property | LocalName | Gets the displayable name of the local party.
Public property | Notes | Gets the notes that were added to the interaction.
Public property | RemoteAddress | Gets the address of the remote party.
Public property | RemoteId | Gets the remote party ID as a friendly display value.
Public property | RemoteName | Gets the displayable name of the remote party.

See Also

HistoryItem Class
ININ.IceLib.Interactions Namespace


HistoryItem Methods

[image] [image]

IceLib Technical Reference
HistoryItem Methods
HistoryItem Class See Also Send Feedback

The HistoryItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryItem Class
ININ.IceLib.Interactions Namespace


HistoryItem Properties

[image] [image]

IceLib Technical Reference
HistoryItem Properties
HistoryItem Class See Also Send Feedback

The HistoryItem type exposes the following members.

Properties

 | Name | Description
Public property | BeginTime | Gets the time the interaction began.
Public property | Direction | Gets the direction of the interaction.
Public property | EndTime | Gets the time the interaction was disconnected or left the queue.
Public property | InteractionId | Gets the interaction ID of the Interaction to which the history data corresponds.
Public property | InteractionLog | Gets log information about the interaction as a string.
Public property | ItemFlags | Gets flags indicating the status of the interaction.
Public property | LocalAddress | Gets the address of the local party.
Public property | LocalId | Gets the displayable address of local party.
Public property | LocalName | Gets the displayable name of the local party.
Public property | Notes | Gets the notes that were added to the interaction.
Public property | RemoteAddress | Gets the address of the remote party.
Public property | RemoteId | Gets the remote party ID as a friendly display value.
Public property | RemoteName | Gets the displayable name of the remote party.

See Also

HistoryItem Class
ININ.IceLib.Interactions Namespace


BeginTime Property

[image]

IceLib Technical Reference
HistoryItem..::..BeginTime Property
HistoryItem Class See Also Send Feedback
Gets the time the interaction began.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime BeginTime { get; }
Visual Basic
Public ReadOnly Property BeginTime As DateTime
    Get

Field Value

The begin time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


Direction Property

[image]

IceLib Technical Reference
HistoryItem..::..Direction Property
HistoryItem Class See Also Send Feedback
Gets the direction of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionDirection Direction { get; }
Visual Basic
Public ReadOnly Property Direction As InteractionDirection
    Get

Field Value

The direction of the interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..InteractionDirection


EndTime Property

[image]

IceLib Technical Reference
HistoryItem..::..EndTime Property
HistoryItem Class See Also Send Feedback
Gets the time the interaction was disconnected or left the queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime EndTime { get; }
Visual Basic
Public ReadOnly Property EndTime As DateTime
    Get

Field Value

The end time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
HistoryItem..::..InteractionId Property
HistoryItem Class See Also Send Feedback
Gets the interaction ID of the Interaction to which the history data corresponds.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


InteractionLog Property

[image]

IceLib Technical Reference
HistoryItem..::..InteractionLog Property
HistoryItem Class See Also Send Feedback
Gets log information about the interaction as a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionLog { get; }
Visual Basic
Public ReadOnly Property InteractionLog As String
    Get

Field Value

The log.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


ItemFlags Property

[image]

IceLib Technical Reference
HistoryItem..::..ItemFlags Property
HistoryItem Class See Also Send Feedback
Gets flags indicating the status of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HistoryItemFlags ItemFlags { get; }
Visual Basic
Public ReadOnly Property ItemFlags As HistoryItemFlags
    Get

Field Value

The item flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..HistoryItemFlags


LocalAddress Property

[image]

IceLib Technical Reference
HistoryItem..::..LocalAddress Property
HistoryItem Class See Also Send Feedback
Gets the address of the local party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalAddress { get; }
Visual Basic
Public ReadOnly Property LocalAddress As String
    Get

Field Value

The local address string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


LocalId Property

[image]

IceLib Technical Reference
HistoryItem..::..LocalId Property
HistoryItem Class See Also Send Feedback
Gets the displayable address of local party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalId { get; }
Visual Basic
Public ReadOnly Property LocalId As String
    Get

Field Value

The displayable local address string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


LocalName Property

[image]

IceLib Technical Reference
HistoryItem..::..LocalName Property
HistoryItem Class See Also Send Feedback
Gets the displayable name of the local party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalName { get; }
Visual Basic
Public ReadOnly Property LocalName As String
    Get

Field Value

The displayable name of the local party.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


Notes Property

[image]

IceLib Technical Reference
HistoryItem..::..Notes Property
HistoryItem Class See Also Send Feedback
Gets the notes that were added to the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; }
Visual Basic
Public ReadOnly Property Notes As String
    Get

Field Value

The interaction notes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


RemoteAddress Property

[image]

IceLib Technical Reference
HistoryItem..::..RemoteAddress Property
HistoryItem Class See Also Send Feedback
Gets the address of the remote party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteAddress { get; }
Visual Basic
Public ReadOnly Property RemoteAddress As String
    Get

Field Value

The remote address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


RemoteId Property

[image]

IceLib Technical Reference
HistoryItem..::..RemoteId Property
HistoryItem Class See Also Send Feedback
Gets the remote party ID as a friendly display value.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteId { get; }
Visual Basic
Public ReadOnly Property RemoteId As String
    Get

Field Value

The remote ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


RemoteName Property

[image]

IceLib Technical Reference
HistoryItem..::..RemoteName Property
HistoryItem Class See Also Send Feedback
Gets the displayable name of the remote party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteName { get; }
Visual Basic
Public ReadOnly Property RemoteName As String
    Get

Field Value

The displayable name of the remote party.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

HistoryItem Class
HistoryItem Members
ININ.IceLib.Interactions Namespace


HistoryItemFlags Enumeration

[image]

IceLib Technical Reference
HistoryItemFlags Enumeration
See Also Send Feedback
An set of flags to indicate the status of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum HistoryItemFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration HistoryItemFlags

Members

Member name | Value | Description
None | 0 | No status indicated.
BeenConnected | 1 | The Interaction had been connected.
Forwarded | 2 | The Interaction was forwarded.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


HistoryItemProperty Enumeration

[image]

IceLib Technical Reference
HistoryItemProperty Enumeration
See Also Send Feedback
Each value in the enumeration represents a property of HistoryItem.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum HistoryItemProperty
Visual Basic
Public Enumeration HistoryItemProperty

Members

Member name | Value | Description
None | 0 | No property is indicated.
BeginTime | 1 | Represents the BeginTime property.
Direction | 2 | Represents the Direction property.
EndTime | 3 | Represents the EndTime property.
InteractionId | 4 | Represents the InteractionId property.
InteractionLog | 5 | Represents the InteractionLog property.
ItemFlags | 6 | Represents the ItemFlags property.
LocalAddress | 7 | Represents the LocalAddress property.
LocalId | 8 | Represents the LocalId property.
LocalName | 9 | Represents the LocalName property.
RemoteAddress | 10 | Represents the RemoteAddress property.
RemoteId | 11 | Represents the RemoteId property.
RemoteName | 12 | Represents the RemoteName property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InitiateSecureInputCompletedEventArgs Class

[image]

IceLib Technical Reference
InitiateSecureInputCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the InitiateSecureInputAsync(SecureInputParameters, EventHandler<(Of <<'(InitiateSecureInputCompletedEventArgs>)>>), Object)'s completedCallback delegate of Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InitiateSecureInputCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class InitiateSecureInputCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..InitiateSecureInputCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InitiateSecureInputCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InitiateSecureInputCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
InitiateSecureInputCompletedEventArgs Members
InitiateSecureInputCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The InitiateSecureInputCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InitiateSecureInputCompletedEventArgs | Initializes a new instance of the MakeCallbackInteractionCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TransactionId | Gets the transaction ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

InitiateSecureInputCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InitiateSecureInputCompletedEventArgs Constructor

[image]

IceLib Technical Reference
InitiateSecureInputCompletedEventArgs Constructor
InitiateSecureInputCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeCallbackInteractionCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InitiateSecureInputCompletedEventArgs(
    string transactionId,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    transactionId As String, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

transactionId
Type: System..::..String
The transaction ID.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InitiateSecureInputCompletedEventArgs Class
InitiateSecureInputCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InitiateSecureInputCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
InitiateSecureInputCompletedEventArgs Methods
InitiateSecureInputCompletedEventArgs Class See Also Send Feedback

The InitiateSecureInputCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitiateSecureInputCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InitiateSecureInputCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
InitiateSecureInputCompletedEventArgs Properties
InitiateSecureInputCompletedEventArgs Class See Also Send Feedback

The InitiateSecureInputCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TransactionId | Gets the transaction ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

InitiateSecureInputCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


TransactionId Property

[image]

IceLib Technical Reference
InitiateSecureInputCompletedEventArgs..::..TransactionId Property
InitiateSecureInputCompletedEventArgs Class See Also Send Feedback
Gets the transaction ID associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TransactionId { get; }
Visual Basic
Public ReadOnly Property TransactionId As String
    Get

Field Value

The transaction ID.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

InitiateSecureInputCompletedEventArgs Class
InitiateSecureInputCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


Interaction Class

[image]

IceLib Technical Reference
Interaction Class
Members Example See Also Send Feedback
Represents an Interaction within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class Interaction
Visual Basic
Public MustInherit Class Interaction

Remarks

Interactions in the Interaction Center system can be calls, chats, emails, email, monitors, or recordings.

This class allows you to start, stop, and change watches on interaction attributes along with interaction control actions such as pickup, hold, disconnect, park, etc.

To start watching interaction attributes, call StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) passing in an array of attribute names to watch (For built in attributes see InteractionAttributeName). When the asynchronous start watching completes it invokes the specified AsyncCompletedEventHandler delegate.

To stop watching interaction attributes, call StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object). When the asynchronous stop watch action completes, it invokes the completedCallback delegate.

To change the interaction attributes to watch, call ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object). When the asynchronous change watched attributes action completes it invokes the completedCallback delegate.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) when a watch is in place or StopWatching()()()(), StopWatchingAsync(AsyncCompletedEventHandler, Object), ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean), or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) when a watch is not in place raises an InvalidOperationException.

Accessing interaction properties when a watch is not in place raises a NotCachedException.

To retrieve the value of a Boolean attribute call GetBooleanAttribute(String) or GetBooleanAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Boolean>)>>)>)>>), Object) and provide an attribute name. When the asynchronous get attribute operation completes it invokes the completedCallback delegate returning the value of this attribute.

To retrieve the value of a integer attribute call GetIntegerAttribute(String) or GetIntegerAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) and provide an attribute name. When the asynchronous get attribute operation completes it invokes the completedCallback delegate returning the value of this attribute.

To retrieve the value of a string attribute call GetStringAttribute(String) or GetStringAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(String>)>>)>)>>), Object) and provide an attribute name. When the asynchronous get attribute operation completes it invokes the completedCallback delegate returning the value of this attribute.

To retrieve the value of a DateTime attribute call GetDateTimeAttribute(String) or GetDateTimeAttributeAsync(String, EventHandler<(Of <<'(GetAttributeCompletedEventArgs<(Of <<'(DateTime>)>>)>)>>), Object) and provide an attribute name. When the asynchronous get attribute operation completes it invokes the completedCallback delegate returning the value of this attribute.

To set the value of a DateTime attribute call SetDateTimeAttribute(String, DateTime) or SetDateTimeAttributeAsync(String, DateTime, AsyncCompletedEventHandler, Object). When the set attribute value completes it invokes the completedCallback delegate.

To set the value of a string attribute call SetStringAttribute(String, String) or SetStringAttributeAsync(String, String, AsyncCompletedEventHandler, Object). When the set attribute value completes it invokes the completedCallback delegate.

To append a value to a string attribute call AppendStringAttribute(String, String, String) or AppendStringAttributeAsync(String, String, String, AsyncCompletedEventHandler, Object) and provide the string to append to the attribute value. When the append operation completes it invokes the completedCallback delegate.

To perform a Pickup operation on an interaction, call Pickup()()()() or PickupAsync(AsyncCompletedEventHandler, Object). When the asynchronous Pickup operation completes it invokes the completedCallback delegate.

To perform a Disconnect operation on an interaction, call Disconnect()()()() or DisconnectAsync(AsyncCompletedEventHandler, Object). When the asynchronous Disconnect operation completes it invokes the completedCallback delegate.

To perform a Hold operation on an interaction, call Hold(Boolean) or HoldAsync(Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Hold operation completes it invokes the completedCallback delegate.

To perform a Record operation on an interaction, call Record(Boolean, Boolean) or RecordAsync(Boolean, Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Record operation completes it invokes the completedCallback delegate.

To perform a BlindTransfer operation on an interaction, call BlindTransfer or BlindTransferAsync. When the asynchronous BlindTransfer operation completes it invokes the completedCallback delegate.

To perform a ConsultTransfer operation on an interaction, call ConsultTransfer(InteractionId) or ConsultTransferAsync(InteractionId, AsyncCompletedEventHandler, Object). When the asynchronous ConsultTransfer operation completes it invokes the completedCallback delegate.

To perform a TransferToVoicemail operation on an interaction, call TransferToVoicemail or TransferToVoicemailAsync. When the asynchronous TransferToVoicemail operation completes it invokes the completedCallback delegate.

To perform a Park operation on an interaction, call Park or ParkAsync. When the asynchronous Park operation completes it invokes the completedCallback delegate.

To perform a Listen operation on an interaction, call Listen(Boolean, Boolean) or ListenAsync(Boolean, Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Listen operation completes it invokes the completedCallback delegate.

To perform a Coach operation on an interaction, call Coach(Boolean, Boolean) or CoachAsync(Boolean, Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Coach operation completes it invokes the completedCallback delegate.

To perform a Mute operation on an interaction, call Mute(Boolean) or MuteAsync(Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Mute operation completes it invokes the completedCallback delegate.

To perform a Pause operation on an interaction, call Pause(Boolean) or PauseAsync(Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Pause operation completes it invokes the completedCallback delegate.

To perform a Private operation on an interaction, call Private(Boolean) or PrivateAsync(Boolean, AsyncCompletedEventHandler, Object). When the asynchronous Private operation completes it invokes the completedCallback delegate.

To perform a Voicemail operation on an interaction, call Voicemail()()()() or VoicemailAsync(AsyncCompletedEventHandler, Object). When the asynchronous Voicemail operation completes it invokes the completedCallback delegate.

To perform a Join operation on an interaction, call Join()()()() or JoinAsync(AsyncCompletedEventHandler, Object). When the asynchronous Join operation completes it invokes the completedCallback delegate.

To perform a RequestHelp operation on an interaction, call RequestHelp(String) or RequestHelpAsync(String, AsyncCompletedEventHandler, Object). When the asynchronous RequestHelp operation completes it invokes the completedCallback delegate.

Note
The asynchronous methods are preferred since the above operations can be lengthy.
Note
For more information on getting started with queues and interactions see Getting Started With Interactions.

Examples

The following is an example of retrieving an interaction attribute and returning the string value.
CopyC#
private void queryAttributeButton_Click(object sender, System.EventArgs e)
   {
       if (_Interaction != null)
       {
           _Interaction.GetStringAttributeAsync(attributeNameTextBox.Text, GetStringAttributeCompleted, null);
       }
   }

private void GetStringAttributeCompleted(object sender, GetAttributeCompletedEventArgs<string> e)
   {
       try
       {
         attributeValueTextBox.Text = e.AttributeValue;
       }
       catch (Exception ex)
       {
           attributeValueTextBox.Text = String.Empty;
           MessageBox.Show(ex.StackTrace, ex.Message);
       }
   }

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..CallbackInteraction
ININ.IceLib.Interactions..::..CallInteraction
ININ.IceLib.Interactions..::..ChatInteraction
ININ.IceLib.Interactions..::..EmailInteraction
ININ.IceLib.Interactions..::..GenericInteraction
ININ.IceLib.Interactions..::..MonitorInteraction
ININ.IceLib.Interactions..::..RecorderInteraction
ININ.IceLib.Interactions..::..SocialConversationInteraction
ININ.IceLib.Interactions..::..SocialDirectMessageInteraction
ININ.IceLib.ProcessAutomation..::..WorkItemInteraction
ININ.IceLib.Tracker..::..TrackerInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Members
ININ.IceLib.Interactions Namespace


Interaction Members

[image] [image]

IceLib Technical Reference
Interaction Members
Interaction Class Constructors Methods Properties Events See Also Send Feedback

The Interaction type exposes the following members.

Constructors

 | Name | Description
Protected method | Interaction | Initializes a new instance of the Interaction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes.
Public method | AppendNoteAsync | Asynchronously appends to the Notes.
Public method | AppendStringAttribute | Sets the value of a string attribute.
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute.
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string.
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target.
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string.
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target.
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | Coach | Changes the coaching state of the interaction.
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction.
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction.
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction.
Public method | Disconnect | Disconnects this Interaction.
Public method | DisconnectAsync | Asynchronously disconnects this Interaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean.
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean.
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime.
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32.
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32.
Public method | GetStringAttribute | Gets the value of an attribute as a String.
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String.
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String.
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean.
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime.
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32.
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String.
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String.
Public method | Hold | Places the interaction on hold or takes it off hold.
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold.
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction.
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction.
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided.
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input.
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Public method | Join | Joins this Interaction in a conference.
Public method | JoinAsync | Asynchronously joins this Interaction in a conference.
Public method | Listen | Changes the listen state of the interaction.
Public method | ListenAsync | Asynchronously changes the listen state of the interaction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state.
Public method | MuteAsync | Asynchronously changes the mute state.
Public method | Park(String) | Parks the Interaction on the specified target, given a string.
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target.
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string.
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target.
Public method | Pause | Changes the recording pause state.
Public method | PauseAsync | Asynchronously changes the recording pause state.
Public method | Pickup | Picks up this Interaction.
Public method | PickupAsync | Asynchronously picks up this Interaction.
Public method | Private | Changes the private state.
Public method | PrivateAsync | Asynchronously changes the private state.
Public method | Record | Changes the record state.
Public method | RecordAsync | Asynchronously changes the record state.
Public method | RequestHelp | Obsolete. Sends a request for help.
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help.
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state.
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state.
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.
Public method | SetAccountCodeId | Sets the Account Code ID.
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID.
Public method | SetDateTimeAttribute | Sets the value of a string attribute.
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute.
Public method | SetRemoteName | Sets the RemoteName.
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName.
Public method | SetStateDescription | Sets the StateDescription.
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription.
Public method | SetStringAttribute | Sets the value of a string attribute.
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute.
Public method | SetStringAttributes | Sets the values of a set of string attributes.
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes.
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID.
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID.
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StopWatching | Stops watching the Interaction.
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string.
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId.
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string.
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId.
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean.
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime.
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32.
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String.
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String.
Public method | Voicemail | Sends the Interaction to voicemail.
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched.
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched.
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched.
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched.
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched.
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched.
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched.
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched.
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched.
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched.
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched.
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched.
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched.
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched.
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched.
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings.
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched.
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched.
Public property | InteractionId | Gets the ID of the Interaction.
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated.
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched.
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched.
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched.
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched.
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched.
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched.
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched.
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched.
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched.
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched.
Public property | IsShared | Gets a value indicating whether this is a shared instance.
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched.
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched.
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched.
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched.
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched.
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched.
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched.
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched.
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched.
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched.
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched.
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched.
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched.
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched.
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched.
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched.
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched.
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched.
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched.
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched.
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched.
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched.
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched.
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched.
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched.
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched.
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched.
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched.
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched.
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched.
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched.
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched.
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched.
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched.
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched.
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched.
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched.
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change.
Public event | Deallocated | Occurs when an Interaction is deallocated.
Public event | LostRights | Occurs when the User loses rights for the Interaction.
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation).
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction.

See Also

Interaction Class
ININ.IceLib.Interactions Namespace


Interaction Constructor

[image]

IceLib Technical Reference
Interaction Constructor
Interaction Class See Also Send Feedback
Initializes a new instance of the Interaction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected Interaction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Protected Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Interaction Methods

[image] [image]

IceLib Technical Reference
Interaction Methods
Interaction Class See Also Send Feedback

The Interaction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes.
Public method | AppendNoteAsync | Asynchronously appends to the Notes.
Public method | AppendStringAttribute | Sets the value of a string attribute.
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute.
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string.
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target.
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string.
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target.
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | Coach | Changes the coaching state of the interaction.
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction.
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction.
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction.
Public method | Disconnect | Disconnects this Interaction.
Public method | DisconnectAsync | Asynchronously disconnects this Interaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean.
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean.
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime.
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32.
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32.
Public method | GetStringAttribute | Gets the value of an attribute as a String.
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String.
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String.
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean.
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime.
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32.
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String.
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String.
Public method | Hold | Places the interaction on hold or takes it off hold.
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold.
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction.
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction.
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided.
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input.
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Public method | Join | Joins this Interaction in a conference.
Public method | JoinAsync | Asynchronously joins this Interaction in a conference.
Public method | Listen | Changes the listen state of the interaction.
Public method | ListenAsync | Asynchronously changes the listen state of the interaction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state.
Public method | MuteAsync | Asynchronously changes the mute state.
Public method | Park(String) | Parks the Interaction on the specified target, given a string.
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target.
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string.
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target.
Public method | Pause | Changes the recording pause state.
Public method | PauseAsync | Asynchronously changes the recording pause state.
Public method | Pickup | Picks up this Interaction.
Public method | PickupAsync | Asynchronously picks up this Interaction.
Public method | Private | Changes the private state.
Public method | PrivateAsync | Asynchronously changes the private state.
Public method | Record | Changes the record state.
Public method | RecordAsync | Asynchronously changes the record state.
Public method | RequestHelp | Obsolete. Sends a request for help.
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help.
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state.
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state.
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.
Public method | SetAccountCodeId | Sets the Account Code ID.
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID.
Public method | SetDateTimeAttribute | Sets the value of a string attribute.
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute.
Public method | SetRemoteName | Sets the RemoteName.
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName.
Public method | SetStateDescription | Sets the StateDescription.
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription.
Public method | SetStringAttribute | Sets the value of a string attribute.
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute.
Public method | SetStringAttributes | Sets the values of a set of string attributes.
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes.
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID.
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID.
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StopWatching | Stops watching the Interaction.
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string.
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId.
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string.
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId.
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean.
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime.
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32.
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String.
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String.
Public method | Voicemail | Sends the Interaction to voicemail.
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail.

See Also

Interaction Class
ININ.IceLib.Interactions Namespace


AppendNote Method

[image]

IceLib Technical Reference
Interaction..::..AppendNote Method
Interaction Class See Also Send Feedback
Appends to the Notes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AppendNote(
    string appendedText
)
Visual Basic
Public Sub AppendNote ( _
    appendedText As String _
)

Parameters

appendedText
Type: System..::..String
The appended text.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


AppendNoteAsync Method

[image]

IceLib Technical Reference
Interaction..::..AppendNoteAsync Method
Interaction Class See Also Send Feedback
Asynchronously appends to the Notes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AppendNoteAsync(
    string appendedText,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AppendNoteAsync ( _
    appendedText As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

appendedText
Type: System..::..String
The appended text.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


AppendStringAttribute Method

[image]

IceLib Technical Reference
Interaction..::..AppendStringAttribute Method
Interaction Class See Also Send Feedback
Sets the value of a string attribute.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AppendStringAttribute(
    string attributeName,
    string appendedValue,
    string delimiter
)
Visual Basic
Public Sub AppendStringAttribute ( _
    attributeName As String, _
    appendedValue As String, _
    delimiter As String _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
appendedValue
Type: System..::..String
The value to append.
delimiter
Type: System..::..String
The string used to separate appeneded values. If delimiter is nullNothingnullptra null reference (Nothing in Visual Basic) the default delimiter of "|" will be used. Use String.Empty to specify that no delimter is to be used.

Remarks

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


AppendStringAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..AppendStringAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the value of a string attribute.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AppendStringAttributeAsync(
    string attributeName,
    string appendedValue,
    string delimiter,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AppendStringAttributeAsync ( _
    attributeName As String, _
    appendedValue As String, _
    delimiter As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
appendedValue
Type: System..::..String
The value to append.
delimiter
Type: System..::..String
The string used to separate appended values. If delimiter is nullNothingnullptra null reference (Nothing in Visual Basic) the default delimiter of "|" will be used. Use String.Empty to specify that no delimiter is to be used.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


BlindTransfer Method

[image] [image]

IceLib Technical Reference
Interaction..::..BlindTransfer Method
Interaction Class See Also Send Feedback
Performs a blind transfer to the specified number.

Overload List

 | Name | Description
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string.
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


BlindTransfer Method (String)

[image]

IceLib Technical Reference
Interaction..::..BlindTransfer Method (String)
Interaction Class See Also Send Feedback
Performs a blind transfer to the specified number given the number as a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void BlindTransfer(
    string target
)
Visual Basic
Public Sub BlindTransfer ( _
    target As String _
)

Parameters

target
Type: System..::..String
The number to which to transfer.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
BlindTransfer Overload
ININ.IceLib.Interactions Namespace


BlindTransfer Method (QueueId)

[image]

IceLib Technical Reference
Interaction..::..BlindTransfer Method (QueueId)
Interaction Class See Also Send Feedback
Performs a blind transfer to the specified target, given the QueueId of the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void BlindTransfer(
    QueueId target
)
Visual Basic
Public Sub BlindTransfer ( _
    target As QueueId _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The queue to which to transfer. The QueueType member must be either User, Station, or Orbit.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An invalid QueueId was used as a parameter.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
BlindTransfer Overload
ININ.IceLib.Interactions Namespace


BlindTransferAsync Method

[image] [image]

IceLib Technical Reference
Interaction..::..BlindTransferAsync Method
Interaction Class See Also Send Feedback
Asynchronously performs a blind transfer to the specified number.

Overload List

 | Name | Description
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string.
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


BlindTransferAsync Method (String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..BlindTransferAsync Method (String, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously performs a blind transfer to the specified number, given that number as a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void BlindTransferAsync(
    string target,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub BlindTransferAsync ( _
    target As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

target
Type: System..::..String
The number to which to transfer.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
BlindTransferAsync Overload
ININ.IceLib.Interactions Namespace


BlindTransferAsync Method (QueueId, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..BlindTransferAsync Method (QueueId, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously performs a blind transfer to the specified target, given the QueueId of the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void BlindTransferAsync(
    QueueId target,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub BlindTransferAsync ( _
    target As QueueId, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The queue to which to transfer. The QueueType member must be either User, Station, or Orbit.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An invalid QueueId was used as a parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
BlindTransferAsync Overload
ININ.IceLib.Interactions Namespace


ChangeWatchedAttributes Method

[image]

IceLib Technical Reference
Interaction..::..ChangeWatchedAttributes Method
Interaction Class See Also Send Feedback
Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributes(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedAttributes ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is not being watched or cannot perform this operation on Interaction object obtained from InteractionAttributeMonitor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ChangeWatchedAttributesAsync Method

[image]

IceLib Technical Reference
Interaction..::..ChangeWatchedAttributesAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributesAsync(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAttributesAsync ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Coach Method

[image]

IceLib Technical Reference
Interaction..::..Coach Method
Interaction Class See Also Send Feedback
Changes the coaching state of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Coach(
    bool on,
    bool supervisor
)
Visual Basic
Public Sub Coach ( _
    on As Boolean, _
    supervisor As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting monitor will be included in SupervisorMonitors, otherwise included in Monitors.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


CoachAsync Method

[image]

IceLib Technical Reference
Interaction..::..CoachAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the coaching state of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CoachAsync(
    bool on,
    bool supervisor,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CoachAsync ( _
    on As Boolean, _
    supervisor As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting monitor will be included in SupervisorMonitors, otherwise included in Monitors.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ConsultTransfer Method

[image]

IceLib Technical Reference
Interaction..::..ConsultTransfer Method
Interaction Class See Also Send Feedback
Performs a consult transfer with the specified interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConsultTransfer(
    InteractionId consultId
)
Visual Basic
Public Sub ConsultTransfer ( _
    consultId As InteractionId _
)

Parameters

consultId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction to consult with.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for ConsultId.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ConsultTransferAsync Method

[image]

IceLib Technical Reference
Interaction..::..ConsultTransferAsync Method
Interaction Class See Also Send Feedback
Asynchronously performs a consult transfer with the specified interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConsultTransferAsync(
    InteractionId consultId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ConsultTransferAsync ( _
    consultId As InteractionId, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

consultId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction to consult with.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for ConsultId.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Disconnect Method

[image]

IceLib Technical Reference
Interaction..::..Disconnect Method
Interaction Class See Also Send Feedback
Disconnects this Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


DisconnectAsync Method

[image]

IceLib Technical Reference
Interaction..::..DisconnectAsync Method
Interaction Class See Also Send Feedback
Asynchronously disconnects this Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DisconnectAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DisconnectAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetBooleanAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetBooleanAttribute Method
Interaction Class See Also Send Feedback
Gets the value of an attribute as a Boolean.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool GetBooleanAttribute(
    string attributeName
)
Visual Basic
Public Function GetBooleanAttribute ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
Name of the attribute.

Return Value

The Boolean value.

Remarks

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetBooleanAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..GetBooleanAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously gets the value of an attribute as a Boolean.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetBooleanAttributeAsync(
    string attributeName,
    EventHandler<GetAttributeCompletedEventArgs<bool>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetBooleanAttributeAsync ( _
    attributeName As String, _
    completedCallback As EventHandler(Of GetAttributeCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
Name of the attribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetAttributeCompletedEventArgs <(Of <(<'Boolean>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetDateTimeAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetDateTimeAttribute Method
Interaction Class See Also Send Feedback
Gets the value of an attribute as a DateTime.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime GetDateTimeAttribute(
    string attributeName
)
Visual Basic
Public Function GetDateTimeAttribute ( _
    attributeName As String _
) As DateTime

Parameters

attributeName
Type: System..::..String
Name of the attribute.

Return Value

The DateTime value.

Remarks

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

The return value will be adjusted according to the ClockSkew value.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetDateTimeAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..GetDateTimeAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously gets the value of an attribute as a DateTime.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetDateTimeAttributeAsync(
    string attributeName,
    EventHandler<GetAttributeCompletedEventArgs<DateTime>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetDateTimeAttributeAsync ( _
    attributeName As String, _
    completedCallback As EventHandler(Of GetAttributeCompletedEventArgs(Of DateTime)), _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
Name of the attribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetAttributeCompletedEventArgs <(Of <(<'DateTime>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

The return value will be adjusted according to the ClockSkew value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetIntegerAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetIntegerAttribute Method
Interaction Class See Also Send Feedback
Gets the value of an attribute as an Int32.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int GetIntegerAttribute(
    string attributeName
)
Visual Basic
Public Function GetIntegerAttribute ( _
    attributeName As String _
) As Integer

Parameters

attributeName
Type: System..::..String
Name of the attribute.

Return Value

The Integer value.

Remarks

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetIntegerAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..GetIntegerAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously gets the value of an attribute as an Int32.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetIntegerAttributeAsync(
    string attributeName,
    EventHandler<GetAttributeCompletedEventArgs<int>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetIntegerAttributeAsync ( _
    attributeName As String, _
    completedCallback As EventHandler(Of GetAttributeCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
Name of the attribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetAttributeCompletedEventArgs <(Of <(<'Int32>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetStringAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetStringAttribute Method
Interaction Class See Also Send Feedback
Gets the value of an attribute as a String.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetStringAttribute(
    string attributeName
)
Visual Basic
Public Function GetStringAttribute ( _
    attributeName As String _
) As String

Parameters

attributeName
Type: System..::..String
Name of the attribute.

Return Value

The string value.

Remarks

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetStringAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..GetStringAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously gets the value of an attribute as a String.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetStringAttributeAsync(
    string attributeName,
    EventHandler<GetAttributeCompletedEventArgs<string>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetStringAttributeAsync ( _
    attributeName As String, _
    completedCallback As EventHandler(Of GetAttributeCompletedEventArgs(Of String)), _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
Name of the attribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetAttributeCompletedEventArgs <(Of <(<'String>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetStringAttributes Method

[image]

IceLib Technical Reference
Interaction..::..GetStringAttributes Method
Interaction Class See Also Send Feedback
Gets the values of attributes, where each attribute value is returned as a String.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> GetStringAttributes(
    string[] attributeNames
)
Visual Basic
Public Function GetStringAttributes ( _
    attributeNames As String() _
) As IDictionary(Of String, String)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
A list of the names of the attributes.

Return Value

The attribute values.

Remarks

This method will return the values from the cache, if the attributes are cached. If the attributes are not being cached, it will send a request to the server and get the attributes.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributeNames is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetStringAttributesAsync Method

[image]

IceLib Technical Reference
Interaction..::..GetStringAttributesAsync Method
Interaction Class See Also Send Feedback
Asynchronously gets the values of attributes, where each attribute value is returned as a String.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetStringAttributesAsync(
    string[] attributeNames,
    EventHandler<GetStringAttributesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetStringAttributesAsync ( _
    attributeNames As String(), _
    completedCallback As EventHandler(Of GetStringAttributesCompletedEventArgs), _
    userState As Object _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
Names of the attributes.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetStringAttributesCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

This method will return the value from the cache, if the attribute is cached. If the attribute is not being cached, it will send a request to the server and get the attribute.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributeNames is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetWatchedBooleanAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetWatchedBooleanAttribute Method
Interaction Class See Also Send Feedback
Gets the value of a watched attribute as a Boolean.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool GetWatchedBooleanAttribute(
    string attributeName
)
Visual Basic
Public Function GetWatchedBooleanAttribute ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

The Boolean that was returned.

Remarks

This method can get values of the attributes that are currently being watched.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetWatchedDateTimeAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetWatchedDateTimeAttribute Method
Interaction Class See Also Send Feedback
Gets the value of a watched attribute as a DateTime.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime GetWatchedDateTimeAttribute(
    string attributeName
)
Visual Basic
Public Function GetWatchedDateTimeAttribute ( _
    attributeName As String _
) As DateTime

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

The DateTime that was returned.

Remarks

This method can get values of the attributes that are currently being watched. If this method is used to get a unwatched-attribute it will result in a NotCachedException.

The return value will be adjusted according to the ClockSkew value.

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetWatchedIntegerAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetWatchedIntegerAttribute Method
Interaction Class See Also Send Feedback
Gets the value of a watched attribute as an Int32.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int GetWatchedIntegerAttribute(
    string attributeName
)
Visual Basic
Public Function GetWatchedIntegerAttribute ( _
    attributeName As String _
) As Integer

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

The Int32 that was returned.

Remarks

This method can get values of the attributes that are currently being watched.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetWatchedStringAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetWatchedStringAttribute Method
Interaction Class See Also Send Feedback
Gets the value of a watched attribute as a String.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetWatchedStringAttribute(
    string attributeName
)
Visual Basic
Public Function GetWatchedStringAttribute ( _
    attributeName As String _
) As String

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

The String that was returned.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


GetWatchedStringsAttribute Method

[image]

IceLib Technical Reference
Interaction..::..GetWatchedStringsAttribute Method
Interaction Class See Also Send Feedback
Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> GetWatchedStringsAttribute(
    string attributeName
)
Visual Basic
Public Function GetWatchedStringsAttribute ( _
    attributeName As String _
) As ReadOnlyCollection(Of String)

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

The String array that was returned.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Hold Method

[image]

IceLib Technical Reference
Interaction..::..Hold Method
Interaction Class See Also Send Feedback
Places the interaction on hold or takes it off hold.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Hold(
    bool on
)
Visual Basic
Public Sub Hold ( _
    on As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


HoldAsync Method

[image]

IceLib Technical Reference
Interaction..::..HoldAsync Method
Interaction Class See Also Send Feedback
Asynchronously places the interaction on hold or takes it off hold.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void HoldAsync(
    bool on,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub HoldAsync ( _
    on As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InitiateRecordingSnip Method

[image]

IceLib Technical Reference
Interaction..::..InitiateRecordingSnip Method
Interaction Class See Also Send Feedback
Changes the recording snippet state of the interaction.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InitiateRecordingSnip(
    bool on,
    bool supervisor
)
Visual Basic
Public Sub InitiateRecordingSnip ( _
    on As Boolean, _
    supervisor As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting monitor will be included in SupervisorRecorders, otherwise included in SupervisorRecorders.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InitiateRecordingSnipAsync Method

[image]

IceLib Technical Reference
Interaction..::..InitiateRecordingSnipAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the recording snip state of the interaction.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InitiateRecordingSnipAsync(
    bool on,
    bool supervisor,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub InitiateRecordingSnipAsync ( _
    on As Boolean, _
    supervisor As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting monitor will be included in SupervisorRecorders, otherwise included in Recorders.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InitiateSecureInput Method

[image]

IceLib Technical Reference
Interaction..::..InitiateSecureInput Method
Interaction Class See Also Send Feedback
Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InitiateSecureInput(
    SecureInputParameters secureInputParameters
)
Visual Basic
Public Function InitiateSecureInput ( _
    secureInputParameters As SecureInputParameters _
) As String

Parameters

secureInputParameters
Type: ININ.IceLib.Interactions..::..SecureInputParameters
The secure input parameters.

Return Value

The transaction ID that was returned.

Exceptions

Exception | Condition
System..::..ArgumentNullException | secureInputParameters is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | An error occurred while initiating secure input.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InitiateSecureInputAsync Method

[image]

IceLib Technical Reference
Interaction..::..InitiateSecureInputAsync Method
Interaction Class See Also Send Feedback
Asynchronously initiates secure input.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InitiateSecureInputAsync(
    SecureInputParameters secureInputParameters,
    EventHandler<InitiateSecureInputCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub InitiateSecureInputAsync ( _
    secureInputParameters As SecureInputParameters, _
    completedCallback As EventHandler(Of InitiateSecureInputCompletedEventArgs), _
    userState As Object _
)

Parameters

secureInputParameters
Type: ININ.IceLib.Interactions..::..SecureInputParameters
The secure input parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' InitiateSecureInputCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsValidCapability Method

[image]

IceLib Technical Reference
Interaction..::..IsValidCapability Method
Interaction Class See Also Send Feedback
Determines whether the interaction has the specified capabilities.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsValidCapability(
    InteractionCapabilities interactionCapabilities
)
Visual Basic
Public Function IsValidCapability ( _
    interactionCapabilities As InteractionCapabilities _
) As Boolean

Parameters

interactionCapabilities
Type: ININ.IceLib.Interactions..::..InteractionCapabilities
The interaction capabilities.

Return Value

trueTruetruetrue (True in Visual Basic) if the interaction has the capabilities; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
Interaction..::..IsWatching Method
Interaction Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
Interaction..::..IsWatching Method
Interaction Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
IsWatching Overload
ININ.IceLib.Interactions Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
Interaction..::..IsWatching Method (String)
Interaction Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string attributeName
)
Visual Basic
Public Function IsWatching ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
IsWatching Overload
ININ.IceLib.Interactions Namespace


Join Method

[image]

IceLib Technical Reference
Interaction..::..Join Method
Interaction Class See Also Send Feedback
Joins this Interaction in a conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Join()
Visual Basic
Public Sub Join

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


JoinAsync Method

[image]

IceLib Technical Reference
Interaction..::..JoinAsync Method
Interaction Class See Also Send Feedback
Asynchronously joins this Interaction in a conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void JoinAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub JoinAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | Exception encountered during asynchronous call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Listen Method

[image]

IceLib Technical Reference
Interaction..::..Listen Method
Interaction Class See Also Send Feedback
Changes the listen state of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Listen(
    bool on,
    bool supervisor
)
Visual Basic
Public Sub Listen ( _
    on As Boolean, _
    supervisor As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting monitor will be included in SupervisorMonitors, otherwise included in Monitors.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ListenAsync Method

[image]

IceLib Technical Reference
Interaction..::..ListenAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the listen state of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ListenAsync(
    bool on,
    bool supervisor,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ListenAsync ( _
    on As Boolean, _
    supervisor As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting monitor will be included in SupervisorMonitors, otherwise included in Monitors.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Mute Method

[image]

IceLib Technical Reference
Interaction..::..Mute Method
Interaction Class See Also Send Feedback
Changes the mute state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Mute(
    bool on
)
Visual Basic
Public Sub Mute ( _
    on As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


MuteAsync Method

[image]

IceLib Technical Reference
Interaction..::..MuteAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the mute state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MuteAsync(
    bool on,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub MuteAsync ( _
    on As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Park Method

[image] [image]

IceLib Technical Reference
Interaction..::..Park Method
Interaction Class See Also Send Feedback
Parks the Interaction on the specified target.

Overload List

 | Name | Description
Public method | Park(String) | Parks the Interaction on the specified target, given a string.
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Park Method (String)

[image]

IceLib Technical Reference
Interaction..::..Park Method (String)
Interaction Class See Also Send Feedback
Parks the Interaction on the specified target, given a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Park(
    string target
)
Visual Basic
Public Sub Park ( _
    target As String _
)

Parameters

target
Type: System..::..String
The number to which to transfer.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..ResourceInUseException | Attempt to park to orbit queue failed because the Orbit was already in use.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
Park Overload
ININ.IceLib.Interactions Namespace


Park Method (QueueId)

[image]

IceLib Technical Reference
Interaction..::..Park Method (QueueId)
Interaction Class See Also Send Feedback
Parks the Interaction on the specified target, given the QueueId of the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Park(
    QueueId target
)
Visual Basic
Public Sub Park ( _
    target As QueueId _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The queue to which to transfer. The QueueType member must be either User, Station, or Orbit.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An invalid QueueId was used as a parameter.
ININ.IceLib..::..ResourceInUseException | Attempt to park to orbit queue failed because the Orbit was already in use.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
Park Overload
ININ.IceLib.Interactions Namespace


ParkAsync Method

[image] [image]

IceLib Technical Reference
Interaction..::..ParkAsync Method
Interaction Class See Also Send Feedback
Asynchronously parks the Interaction on the specified target.

Overload List

 | Name | Description
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string.
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ParkAsync Method (String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..ParkAsync Method (String, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously parks the Interaction on the specified target, given a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ParkAsync(
    string target,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ParkAsync ( _
    target As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

target
Type: System..::..String
The number to which to transfer.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ParkAsync Overload
ININ.IceLib.Interactions Namespace


ParkAsync Method (QueueId, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..ParkAsync Method (QueueId, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously parks the Interaction on the specified target, given the QueueId of the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ParkAsync(
    QueueId target,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ParkAsync ( _
    target As QueueId, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The queue to which to transfer. The QueueType member must be either User, Station, or Orbit.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An invalid QueueId was used as a parameter.
System..::..ArgumentException | The target queue type is not valid for this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ParkAsync Overload
ININ.IceLib.Interactions Namespace


Pause Method

[image]

IceLib Technical Reference
Interaction..::..Pause Method
Interaction Class See Also Send Feedback
Changes the recording pause state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Pause(
    bool on
)
Visual Basic
Public Sub Pause ( _
    on As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


PauseAsync Method

[image]

IceLib Technical Reference
Interaction..::..PauseAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the recording pause state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PauseAsync(
    bool on,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PauseAsync ( _
    on As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Pickup Method

[image]

IceLib Technical Reference
Interaction..::..Pickup Method
Interaction Class See Also Send Feedback
Picks up this Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Pickup()
Visual Basic
Public Sub Pickup

Remarks

NOTE: When picking up a Work Item Interaction, see the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses for this method.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


PickupAsync Method

[image]

IceLib Technical Reference
Interaction..::..PickupAsync Method
Interaction Class See Also Send Feedback
Asynchronously picks up this Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PickupAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PickupAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

NOTE: When picking up a Work Item Interaction, see the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses for this method.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Private Method

[image]

IceLib Technical Reference
Interaction..::..Private Method
Interaction Class See Also Send Feedback
Changes the private state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Private(
    bool on
)
Visual Basic
Public Sub Private ( _
    on As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


PrivateAsync Method

[image]

IceLib Technical Reference
Interaction..::..PrivateAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the private state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PrivateAsync(
    bool on,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PrivateAsync ( _
    on As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Record Method

[image]

IceLib Technical Reference
Interaction..::..Record Method
Interaction Class See Also Send Feedback
Changes the record state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Record(
    bool on,
    bool supervisor
)
Visual Basic
Public Sub Record ( _
    on As Boolean, _
    supervisor As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting recorder will be included in SupervisorRecorders, otherwise included in Recorders.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RecordAsync Method

[image]

IceLib Technical Reference
Interaction..::..RecordAsync Method
Interaction Class See Also Send Feedback
Asynchronously changes the record state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RecordAsync(
    bool on,
    bool supervisor,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RecordAsync ( _
    on As Boolean, _
    supervisor As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
supervisor
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), the resulting recorder will be included in SupervisorRecorders, otherwise included in Recorders.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On and Supervisor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RequestHelp Method

[image]

IceLib Technical Reference
Interaction..::..RequestHelp Method
Interaction Class See Also Send Feedback
Sends a request for help.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("RequestHelp is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequest instead.")]
public void RequestHelp(
    string message
)
Visual Basic
<ObsoleteAttribute("RequestHelp is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequest instead.")> _
Public Sub RequestHelp ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Message.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RequestHelpAsync Method

[image]

IceLib Technical Reference
Interaction..::..RequestHelpAsync Method
Interaction Class See Also Send Feedback
Asynchronously sends a request for help.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("RequestHelpAsync is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequestAsync instead.")]
public void RequestHelpAsync(
    string message,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("RequestHelpAsync is no longer used.  Use AgentAssistanceList, SupervisorAssistanceList and InteractionsManager.SendAssistanceRequestAsync instead.")> _
Public Sub RequestHelpAsync ( _
    message As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

message
Type: System..::..String
The message.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Message.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SecureRecordingPause Method

[image] [image]

IceLib Technical Reference
Interaction..::..SecureRecordingPause Method
Interaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state.
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SecureRecordingPause Method (Boolean)

[image]

IceLib Technical Reference
Interaction..::..SecureRecordingPause Method (Boolean)
Interaction Class See Also Send Feedback
Changes the secure recording pause state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SecureRecordingPause(bool on) has been deprecated. Instead use SecureRecordingPause(SecureRecordingPauseParameters parameters).")]
public void SecureRecordingPause(
    bool on
)
Visual Basic
<ObsoleteAttribute("SecureRecordingPause(bool on) has been deprecated. Instead use SecureRecordingPause(SecureRecordingPauseParameters parameters).")> _
Public Sub SecureRecordingPause ( _
    on As Boolean _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 15 and beyond.

See Also

Interaction Class
Interaction Members
SecureRecordingPause Overload
ININ.IceLib.Interactions Namespace


SecureRecordingPause Method (SecureRecordingPauseParameters)

[image]

IceLib Technical Reference
Interaction..::..SecureRecordingPause Method (SecureRecordingPauseParameters)
Interaction Class See Also Send Feedback
Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SecureRecordingPause(
    SecureRecordingPauseParameters parameters
)
Visual Basic
Public Sub SecureRecordingPause ( _
    parameters As SecureRecordingPauseParameters _
)

Parameters

parameters
Type: ININ.IceLib.Interactions..::..SecureRecordingPauseParameters
The parameters specify what type of action with regards to the pause should be taken. SecureRecordingPauseParameters for more details on setting the parameters.

Remarks

Note
This recording pause has nothing to do with a recording started by Record(Boolean, Boolean) or RecordAsync(Boolean, Boolean, AsyncCompletedEventHandler, Object).

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

Interaction Class
Interaction Members
SecureRecordingPause Overload
ININ.IceLib.Interactions Namespace


SecureRecordingPauseAsync Method

[image] [image]

IceLib Technical Reference
Interaction..::..SecureRecordingPauseAsync Method
Interaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state.
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SecureRecordingPauseAsync Method (Boolean, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..SecureRecordingPauseAsync Method (Boolean, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously changes the secure recording pause state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("SecureRecordingPauseAsync(bool on, AsyncCompletedEventHandler completedCallback, object userState) has been deprecated. Instead use SecureRecordingPauseAsync(SecureRecordingPauseParameters parameters, AsyncCompletedEventHandler completedCallback, object userState).")]
public void SecureRecordingPauseAsync(
    bool on,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("SecureRecordingPauseAsync(bool on, AsyncCompletedEventHandler completedCallback, object userState) has been deprecated. Instead use SecureRecordingPauseAsync(SecureRecordingPauseParameters parameters, AsyncCompletedEventHandler completedCallback, object userState).")> _
Public Sub SecureRecordingPauseAsync ( _
    on As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

on
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic), on.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 15 and beyond.

See Also

Interaction Class
Interaction Members
SecureRecordingPauseAsync Overload
ININ.IceLib.Interactions Namespace


SecureRecordingPauseAsync Method (SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..SecureRecordingPauseAsync Method (SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SecureRecordingPauseAsync(
    SecureRecordingPauseParameters parameters,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SecureRecordingPauseAsync ( _
    parameters As SecureRecordingPauseParameters, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

parameters
Type: ININ.IceLib.Interactions..::..SecureRecordingPauseParameters
The parameters specify what type of action with regards to the pause should be taken. See SecureRecordingPauseParameters for more details on setting the parameters.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for On.

Note
This recording pause has nothing to do with a recording started by Record(Boolean, Boolean) or RecordAsync(Boolean, Boolean, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

Interaction Class
Interaction Members
SecureRecordingPauseAsync Overload
ININ.IceLib.Interactions Namespace


SetAccountCodeId Method

[image]

IceLib Technical Reference
Interaction..::..SetAccountCodeId Method
Interaction Class See Also Send Feedback
Sets the Account Code ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAccountCodeId(
    string accountCodeId
)
Visual Basic
Public Sub SetAccountCodeId ( _
    accountCodeId As String _
)

Parameters

accountCodeId
Type: System..::..String
The account code ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetAccountCodeIdAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetAccountCodeIdAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the Account Code ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAccountCodeIdAsync(
    string accountCodeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetAccountCodeIdAsync ( _
    accountCodeId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

accountCodeId
Type: System..::..String
The account code ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetDateTimeAttribute Method

[image]

IceLib Technical Reference
Interaction..::..SetDateTimeAttribute Method
Interaction Class See Also Send Feedback
Sets the value of a string attribute.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDateTimeAttribute(
    string attributeName,
    DateTime attributeValue
)
Visual Basic
Public Sub SetDateTimeAttribute ( _
    attributeName As String, _
    attributeValue As DateTime _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
attributeValue
Type: System..::..DateTime
The attribute value.

Remarks

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetDateTimeAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetDateTimeAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the value of a string attribute.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetDateTimeAttributeAsync(
    string attributeName,
    DateTime attributeValue,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetDateTimeAttributeAsync ( _
    attributeName As String, _
    attributeValue As DateTime, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
attributeValue
Type: System..::..DateTime
The attribute value.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetRemoteName Method

[image]

IceLib Technical Reference
Interaction..::..SetRemoteName Method
Interaction Class See Also Send Feedback
Sets the RemoteName.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetRemoteName(
    string remoteName
)
Visual Basic
Public Sub SetRemoteName ( _
    remoteName As String _
)

Parameters

remoteName
Type: System..::..String
Remote party name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetRemoteNameAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetRemoteNameAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the RemoteName.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetRemoteNameAsync(
    string remoteName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetRemoteNameAsync ( _
    remoteName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

remoteName
Type: System..::..String
Remote party name.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetStateDescription Method

[image]

IceLib Technical Reference
Interaction..::..SetStateDescription Method
Interaction Class See Also Send Feedback
Sets the StateDescription.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStateDescription(
    string stateDescription
)
Visual Basic
Public Sub SetStateDescription ( _
    stateDescription As String _
)

Parameters

stateDescription
Type: System..::..String
The state description.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetStateDescriptionAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetStateDescriptionAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the StateDescription.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStateDescriptionAsync(
    string stateDescription,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetStateDescriptionAsync ( _
    stateDescription As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

stateDescription
Type: System..::..String
The state description.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetStringAttribute Method

[image]

IceLib Technical Reference
Interaction..::..SetStringAttribute Method
Interaction Class See Also Send Feedback
Sets the value of a string attribute.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStringAttribute(
    string attributeName,
    string attributeValue
)
Visual Basic
Public Sub SetStringAttribute ( _
    attributeName As String, _
    attributeValue As String _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
attributeValue
Type: System..::..String
The attribute value.

Remarks

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetStringAttributeAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetStringAttributeAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the value of a string attribute.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStringAttributeAsync(
    string attributeName,
    string attributeValue,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetStringAttributeAsync ( _
    attributeName As String, _
    attributeValue As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute name.
attributeValue
Type: System..::..String
The attribute value.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetStringAttributes Method

[image]

IceLib Technical Reference
Interaction..::..SetStringAttributes Method
Interaction Class See Also Send Feedback
Sets the values of a set of string attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStringAttributes(
    IDictionary<string, string> attributes
)
Visual Basic
Public Sub SetStringAttributes ( _
    attributes As IDictionary(Of String, String) _
)

Parameters

attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The mapping from attribute names to attribute values.

Remarks

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter, attribute name, or attribute value is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetStringAttributesAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetStringAttributesAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the values of a set of string attributes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetStringAttributesAsync(
    IDictionary<string, string> attributes,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetStringAttributesAsync ( _
    attributes As IDictionary(Of String, String), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The mapping from attribute names to attribute values.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter, attribute name, or attribute value is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetWrapUpCodeId Method

[image]

IceLib Technical Reference
Interaction..::..SetWrapUpCodeId Method
Interaction Class See Also Send Feedback
Sets the WrapUp Code ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Use InteractionsManager.AddWrapUpAssignment(WrapUpAssignment assignment)")]
public void SetWrapUpCodeId(
    string wrapUpCodeId
)
Visual Basic
<ObsoleteAttribute("Use InteractionsManager.AddWrapUpAssignment(WrapUpAssignment assignment)")> _
Public Sub SetWrapUpCodeId ( _
    wrapUpCodeId As String _
)

Parameters

wrapUpCodeId
Type: System..::..String
The WrapUp code ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SetWrapUpCodeIdAsync Method

[image]

IceLib Technical Reference
Interaction..::..SetWrapUpCodeIdAsync Method
Interaction Class See Also Send Feedback
Asynchronously sets the WrapUp Code ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Use InteractionsManager.AddWrapUpAssignment(WrapUpAssignment assignment)")]
public void SetWrapUpCodeIdAsync(
    string wrapUpCodeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("Use InteractionsManager.AddWrapUpAssignment(WrapUpAssignment assignment)")> _
Public Sub SetWrapUpCodeIdAsync ( _
    wrapUpCodeId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

wrapUpCodeId
Type: System..::..String
The WrapUp code ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
Interaction..::..StartWatching Method
Interaction Class See Also Send Feedback
Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] attributeNames
)
Visual Basic
Public Sub StartWatching ( _
    attributeNames As String() _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched or cannot perform this operation on Interaction object obtained from InteractionAttributeMonitor.
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
Interaction..::..StartWatchingAsync Method
Interaction Class See Also Send Feedback
Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] attributeNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    attributeNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
Interaction..::..StopWatching Method
Interaction Class See Also Send Feedback
Stops watching the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched or cannot perform this operation on Interaction object obtained from InteractionAttributeMonitor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
Interaction..::..StopWatchingAsync Method
Interaction Class See Also Send Feedback
Asynchronously stops watching the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
Interaction..::..ToString Method
Interaction Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TransferToVoicemail Method

[image] [image]

IceLib Technical Reference
Interaction..::..TransferToVoicemail Method
Interaction Class See Also Send Feedback
Transfers to voicemail at the specified number.

Overload List

 | Name | Description
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string.
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TransferToVoicemail Method (String)

[image]

IceLib Technical Reference
Interaction..::..TransferToVoicemail Method (String)
Interaction Class See Also Send Feedback
Transfers to voicemail at the specified number, given a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TransferToVoicemail(
    string target
)
Visual Basic
Public Sub TransferToVoicemail ( _
    target As String _
)

Parameters

target
Type: System..::..String
The number to which to transfer.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

The TransferToVoicemail capability should be checked prior to making this call to ensure that the logged in user has the appropriate rights to send the Interaction to the target's voicemail.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
TransferToVoicemail Overload
ININ.IceLib.Interactions Namespace
InteractionCapabilities..::..TransferToVoicemail
InteractionCapabilities..::..Messaging
Interaction..::..Voicemail()()()()
Interaction..::..TransferToVoicemail(QueueId)


TransferToVoicemail Method (QueueId)

[image]

IceLib Technical Reference
Interaction..::..TransferToVoicemail Method (QueueId)
Interaction Class See Also Send Feedback
Transfers to voicemail at the specified number, given a QueueId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TransferToVoicemail(
    QueueId target
)
Visual Basic
Public Sub TransferToVoicemail ( _
    target As QueueId _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The number to which to transfer.

Remarks

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

The TransferToVoicemail capability should be checked prior to making this call to ensure that the logged in user has the appropriate rights to send the Interaction to the target's voicemail.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
TransferToVoicemail Overload
ININ.IceLib.Interactions Namespace
InteractionCapabilities..::..TransferToVoicemail
InteractionCapabilities..::..Messaging
Interaction..::..Voicemail()()()()
Interaction..::..TransferToVoicemail(String)


TransferToVoicemailAsync Method

[image] [image]

IceLib Technical Reference
Interaction..::..TransferToVoicemailAsync Method
Interaction Class See Also Send Feedback
Asynchronously transfers to voicemail at the specified number.

Overload List

 | Name | Description
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string.
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TransferToVoicemailAsync Method (String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..TransferToVoicemailAsync Method (String, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously transfers to voicemail at the specified number, given the target as a string.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TransferToVoicemailAsync(
    string target,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub TransferToVoicemailAsync ( _
    target As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

target
Type: System..::..String
The number to which to transfer.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

The TransferToVoicemail capability should be checked prior to making this call to ensure that the logged in user has the appropriate rights to send the Interaction to the target's voicemail.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
TransferToVoicemailAsync Overload
ININ.IceLib.Interactions Namespace
InteractionCapabilities..::..TransferToVoicemail
InteractionCapabilities..::..Messaging
Interaction..::..VoicemailAsync(AsyncCompletedEventHandler, Object)
Interaction..::..TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object)


TransferToVoicemailAsync Method (QueueId, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
Interaction..::..TransferToVoicemailAsync Method (QueueId, AsyncCompletedEventHandler, Object)
Interaction Class See Also Send Feedback
Asynchronously transfers to voicemail at the specified number, given the target as a QueueId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TransferToVoicemailAsync(
    QueueId target,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub TransferToVoicemailAsync ( _
    target As QueueId, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The number to which to transfer.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will raise the PerformingAction event and (if the action was not cancelled) the PerformedAction event. When those events are raised, the two events' arguments (ActionParameters and ActionParameters, respectively) will contain an entry for Target.

The TransferToVoicemail capability should be checked prior to making this call to ensure that the logged in user has the appropriate rights to send the Interaction to the target's voicemail.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
TransferToVoicemailAsync Overload
ININ.IceLib.Interactions Namespace
InteractionCapabilities..::..TransferToVoicemail
InteractionCapabilities..::..Messaging
Interaction..::..VoicemailAsync(AsyncCompletedEventHandler, Object)
Interaction..::..TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object)


TryGetWatchedBooleanAttribute Method

[image]

IceLib Technical Reference
Interaction..::..TryGetWatchedBooleanAttribute Method
Interaction Class See Also Send Feedback
Tries to get the value of a watched attribute as a Boolean.

Note: This method is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetWatchedBooleanAttribute(
    string attributeName,
    out bool value
)
Visual Basic
Public Function TryGetWatchedBooleanAttribute ( _
    attributeName As String, _
    <OutAttribute> ByRef value As Boolean _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.
value
Type: System..::..Boolean%
The attribute value.

Return Value

trueTruetruetrue (True in Visual Basic) if the attribute is being watched, and was successfully retrieved; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
Note
GetWatchedBooleanAttribute(String) is the preferred method of retrieving a watched boolean attribute. Using this method will suppress the NotCachedException if the specified attribute is not being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TryGetWatchedDateTimeAttribute Method

[image]

IceLib Technical Reference
Interaction..::..TryGetWatchedDateTimeAttribute Method
Interaction Class See Also Send Feedback
Tries to get the value of a watched attribute as a DateTime.

Note: This method is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetWatchedDateTimeAttribute(
    string attributeName,
    out DateTime value
)
Visual Basic
Public Function TryGetWatchedDateTimeAttribute ( _
    attributeName As String, _
    <OutAttribute> ByRef value As DateTime _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.
value
Type: System..::..DateTime%
The attribute value.

Return Value

trueTruetruetrue (True in Visual Basic) if the attribute is being watched, and was successfully retrieved; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
Note
GetWatchedDateTimeAttribute(String) is the preferred method of retrieving a watched DateTime attribute. Using this method will suppress the NotCachedException if the specified attribute is not being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TryGetWatchedIntegerAttribute Method

[image]

IceLib Technical Reference
Interaction..::..TryGetWatchedIntegerAttribute Method
Interaction Class See Also Send Feedback
Tries to get the value of a watched attribute as an Int32.

Note: This method is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetWatchedIntegerAttribute(
    string attributeName,
    out int value
)
Visual Basic
Public Function TryGetWatchedIntegerAttribute ( _
    attributeName As String, _
    <OutAttribute> ByRef value As Integer _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.
value
Type: System..::..Int32%
The attribute value.

Return Value

trueTruetruetrue (True in Visual Basic) if the attribute is being watched, and was successfully retrieved; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
Note
GetWatchedIntegerAttribute(String) is the preferred method of retrieving a watched integer attribute. Using this method will suppress the NotCachedException if the specified attribute is not being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TryGetWatchedStringAttribute Method

[image]

IceLib Technical Reference
Interaction..::..TryGetWatchedStringAttribute Method
Interaction Class See Also Send Feedback
Tries to get the value of a watched attribute as a String.

Note: This method is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetWatchedStringAttribute(
    string attributeName,
    out string value
)
Visual Basic
Public Function TryGetWatchedStringAttribute ( _
    attributeName As String, _
    <OutAttribute> ByRef value As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.
value
Type: System..::..String%
The attribute value.

Return Value

trueTruetruetrue (True in Visual Basic) if the attribute is being watched, and was successfully retrieved; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
Note
GetWatchedStringAttribute(String) is the preferred method of retrieving a watched string attribute. Using this method will suppress the NotCachedException if the specified attribute is not being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TryGetWatchedStringsAttribute Method

[image]

IceLib Technical Reference
Interaction..::..TryGetWatchedStringsAttribute Method
Interaction Class See Also Send Feedback
Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String.

Note: This method is supported for IC Server version 2016 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetWatchedStringsAttribute(
    string attributeName,
    out ReadOnlyCollection<string> values
)
Visual Basic
Public Function TryGetWatchedStringsAttribute ( _
    attributeName As String, _
    <OutAttribute> ByRef values As ReadOnlyCollection(Of String) _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.
values
Type: System.Collections.ObjectModel..::..ReadOnlyCollection<(Of <(<'String>)>)>%
The attribute value.

Return Value

trueTruetruetrue (True in Visual Basic) if the attribute is being watched, and was successfully retrieved; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
Note
GetWatchedStringsAttribute(String) is the preferred method of retrieving a watched attribute as a collection of strings. Using this method will suppress the NotCachedException if the specified attribute is not being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R4 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Voicemail Method

[image]

IceLib Technical Reference
Interaction..::..Voicemail Method
Interaction Class See Also Send Feedback
Sends the Interaction to voicemail.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Voicemail()
Visual Basic
Public Sub Voicemail

Remarks

The Messaging capability should be checked prior to making this call to ensure that the logged in user has the appropriate rights to send the Interaction to voicemail.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace
InteractionCapabilities..::..TransferToVoicemail
InteractionCapabilities..::..Messaging
Interaction..::..TransferToVoicemail(String)
Interaction..::..TransferToVoicemail(QueueId)


VoicemailAsync Method

[image]

IceLib Technical Reference
Interaction..::..VoicemailAsync Method
Interaction Class See Also Send Feedback
Asynchronously sends the Interaction to voicemail.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void VoicemailAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub VoicemailAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

The Messaging capability should be checked prior to making this call to ensure that the logged in user has the appropriate rights to send the Interaction to voicemail.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | Exception encountered during asynchronous call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace
Interaction..::..TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object)
Interaction..::..TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object)


Interaction Properties

[image] [image]

IceLib Technical Reference
Interaction Properties
Interaction Class See Also Send Feedback

The Interaction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched.
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched.
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched.
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched.
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched.
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched.
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched.
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched.
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched.
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched.
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched.
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched.
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched.
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched.
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched.
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings.
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched.
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched.
Public property | InteractionId | Gets the ID of the Interaction.
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated.
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched.
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched.
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched.
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched.
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched.
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched.
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched.
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched.
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched.
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched.
Public property | IsShared | Gets a value indicating whether this is a shared instance.
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched.
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched.
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched.
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched.
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched.
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched.
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched.
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched.
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched.
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched.
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched.
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched.
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched.
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched.
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched.
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched.
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched.
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched.
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched.
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched.
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched.
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched.
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched.
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched.
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched.
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched.
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched.
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched.
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched.
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched.
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched.
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched.
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched.
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched.
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched.
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched.
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched.
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code.

See Also

Interaction Class
ININ.IceLib.Interactions Namespace


AccountCodeId Property

[image]

IceLib Technical Reference
Interaction..::..AccountCodeId Property
Interaction Class See Also Send Feedback
Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCodeId { get; }
Visual Basic
Public ReadOnly Property AccountCodeId As String
    Get

Field Value

The account code ID.

Remarks

Account codes are used in IC to associate calls with accounts. An account code is a number assigned to an account name. Account codes are mapped to incoming and outgoing calls for reporting purposes. For example, Interaction Client users can assign account codes to incoming and outgoing calls from the Interactions page, or from any queue.

Users who have been given access to an account code can assign it to a call so it can be tracked. Account codes can also be used to track outgoing calls made to specific customers, or to track incoming call information for billing purposes.

For more information about Account Codes, refer to the topic titled Account Codes in IC in the Technical Reference Documents section of the IC Documentation library on your server.

Note
The account code ID can be used with an ININ.IceLib.People.AccountCode.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


AlertSound Property

[image]

IceLib Technical Reference
Interaction..::..AlertSound Property
Interaction Class See Also Send Feedback
Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AlertSound { get; }
Visual Basic
Public ReadOnly Property AlertSound As String
    Get

Field Value

The alert sound.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


AssociatedProcessDisplayName Property

[image]

IceLib Technical Reference
Interaction..::..AssociatedProcessDisplayName Property
Interaction Class See Also Send Feedback
Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssociatedProcessDisplayName { get; }
Visual Basic
Public ReadOnly Property AssociatedProcessDisplayName As String
    Get

Field Value

The display name of the process that this interaction is associated with.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


AssociatedProcessInstanceId Property

[image]

IceLib Technical Reference
Interaction..::..AssociatedProcessInstanceId Property
Interaction Class See Also Send Feedback
Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssociatedProcessInstanceId { get; }
Visual Basic
Public ReadOnly Property AssociatedProcessInstanceId As String
    Get

Field Value

The ID of the process that this interaction is associated with.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


CallIdKey Property

[image]

IceLib Technical Reference
Interaction..::..CallIdKey Property
Interaction Class See Also Send Feedback
Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallIdKey { get; }
Visual Basic
Public ReadOnly Property CallIdKey As String
    Get

Field Value

The call ID key. IC generates unique IDs for each interaction in the system. These identifiers are called "Call ID" in Interaction Client, and they are modified and stored in the IC database as unique "CallIDKey" in the "Call ID" column. These identifiers apply to all interaction types, not just calls. The CallID is embedded in the CallIDKey. CallIDKey is the 10 digit CallId plus an eight digit date in this format: YYYYMMDD. For example, a call placed on April 9, 2004 might show a Call ID of 2101990183 on Interaction Client. The resulting CallIDKey stored in the database would be that CallID plus the date: 210199018320040409.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


CallType Property

[image]

IceLib Technical Reference
Interaction..::..CallType Property
Interaction Class See Also Send Feedback
Gets the CallType. CallType is only available if the CallType attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCallType CallType { get; }
Visual Basic
Public ReadOnly Property CallType As InteractionCallType
    Get

Field Value

The call type.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Capabilities Property

[image]

IceLib Technical Reference
Interaction..::..Capabilities Property
Interaction Class See Also Send Feedback
Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCapabilities Capabilities { get; }
Visual Basic
Public ReadOnly Property Capabilities As InteractionCapabilities
    Get

Field Value

The capabilities.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ClientMessage Property

[image]

IceLib Technical Reference
Interaction..::..ClientMessage Property
Interaction Class See Also Send Feedback
Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ClientMessage { get; }
Visual Basic
Public ReadOnly Property ClientMessage As String
    Get

Field Value

The client message.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ConferenceId Property

[image]

IceLib Technical Reference
Interaction..::..ConferenceId Property
Interaction Class See Also Send Feedback
Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId ConferenceId { get; }
Visual Basic
Public ReadOnly Property ConferenceId As ConferenceId
    Get

Field Value

The conference ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ConsultCallId Property

[image]

IceLib Technical Reference
Interaction..::..ConsultCallId Property
Interaction Class See Also Send Feedback
Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId ConsultCallId { get; }
Visual Basic
Public ReadOnly Property ConsultCallId As InteractionId
    Get

Field Value

The ID of the ConsultTransfer.

Remarks

The value returned represents the ID of the ConsultTransfer. If the value is not set, this interaction is not a ConsultTransfer.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


DeallocationSeconds Property

[image]

IceLib Technical Reference
Interaction..::..DeallocationSeconds Property
Interaction Class See Also Send Feedback
Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int DeallocationSeconds { get; }
Visual Basic
Public ReadOnly Property DeallocationSeconds As Integer
    Get

Field Value

The number of seconds after the interaction is disconnected until it will automatically be deallocated.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Direction Property

[image]

IceLib Technical Reference
Interaction..::..Direction Property
Interaction Class See Also Send Feedback
Gets the Direction. Direction is only available if the Direction attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionDirection Direction { get; }
Visual Basic
Public ReadOnly Property Direction As InteractionDirection
    Get

Field Value

The direction.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


DisconnectionTime Property

[image]

IceLib Technical Reference
Interaction..::..DisconnectionTime Property
Interaction Class See Also Send Feedback
Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime DisconnectionTime { get; }
Visual Basic
Public ReadOnly Property DisconnectionTime As DateTime
    Get

Field Value

The disconnection time.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


DisconnectRingNoAnswer Property

[image]

IceLib Technical Reference
Interaction..::..DisconnectRingNoAnswer Property
Interaction Class See Also Send Feedback
Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DisconnectRingNoAnswer { get; }
Visual Basic
Public ReadOnly Property DisconnectRingNoAnswer As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if to disconnect on ring no answer; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Duration Property

[image]

IceLib Technical Reference
Interaction..::..Duration Property
Interaction Class See Also Send Feedback
Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Duration { get; }
Visual Basic
Public ReadOnly Property Duration As TimeSpan
    Get

Field Value

The duration.

Remarks

This is a helper that returns the duration from the InitiationTime until either the DisconnectionTime (if disconnected) or the current time (if connected).

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


HasSnippetRecording Property

[image]

IceLib Technical Reference
Interaction..::..HasSnippetRecording Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance has snippet recordings.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasSnippetRecording { get; }
Visual Basic
Public ReadOnly Property HasSnippetRecording As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is has a snippet recording; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | An associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


ImmediateAccess Property

[image]

IceLib Technical Reference
Interaction..::..ImmediateAccess Property
Interaction Class See Also Send Feedback
Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ImmediateAccess { get; }
Visual Basic
Public ReadOnly Property ImmediateAccess As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if immediate access allowed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InitiationTime Property

[image]

IceLib Technical Reference
Interaction..::..InitiationTime Property
Interaction Class See Also Send Feedback
Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime InitiationTime { get; }
Visual Basic
Public ReadOnly Property InitiationTime As DateTime
    Get

Field Value

The initiation time.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
Interaction..::..InteractionId Property
Interaction Class See Also Send Feedback
Gets the ID of the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Field Value

The interaction ID.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception was thrown.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
Interaction..::..InteractionsManager Property
Interaction Class See Also Send Feedback
Gets the InteractionManager with which this Interaction is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception was thrown.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InteractionType Property

[image]

IceLib Technical Reference
Interaction..::..InteractionType Property
Interaction Class See Also Send Feedback
Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionType InteractionType { get; }
Visual Basic
Public ReadOnly Property InteractionType As InteractionType
    Get

Field Value

The type of the interaction.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsConnected Property

[image]

IceLib Technical Reference
Interaction..::..IsConnected Property
Interaction Class See Also Send Feedback
Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsConnected { get; }
Visual Basic
Public ReadOnly Property IsConnected As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is connected; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

It is considered connected if its in Connected, Messaging, or System.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsDisconnected Property

[image]

IceLib Technical Reference
Interaction..::..IsDisconnected Property
Interaction Class See Also Send Feedback
Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsDisconnected { get; }
Visual Basic
Public ReadOnly Property IsDisconnected As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is disconnected; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Looks for External or Internal disconnect state.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsHeld Property

[image]

IceLib Technical Reference
Interaction..::..IsHeld Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsHeld { get; }
Visual Basic
Public ReadOnly Property IsHeld As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is held; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsMonitored Property

[image]

IceLib Technical Reference
Interaction..::..IsMonitored Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsMonitored { get; }
Visual Basic
Public ReadOnly Property IsMonitored As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this interaction is monitored; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Requires both Monitors and SupervisorMonitors.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | An associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsMuted Property

[image]

IceLib Technical Reference
Interaction..::..IsMuted Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsMuted { get; }
Visual Basic
Public ReadOnly Property IsMuted As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is muted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsOnMyInteractionsQueue Property

[image]

IceLib Technical Reference
Interaction..::..IsOnMyInteractionsQueue Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsOnMyInteractionsQueue { get; }
Visual Basic
Public ReadOnly Property IsOnMyInteractionsQueue As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is on the MyInteractions queue; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attributes are not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsPaused Property

[image]

IceLib Technical Reference
Interaction..::..IsPaused Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPaused { get; }
Visual Basic
Public ReadOnly Property IsPaused As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is paused; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Requires both Recorders and SupervisorRecorders.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | An associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsPrivate Property

[image]

IceLib Technical Reference
Interaction..::..IsPrivate Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPrivate { get; }
Visual Basic
Public ReadOnly Property IsPrivate As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsRecording Property

[image]

IceLib Technical Reference
Interaction..::..IsRecording Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsRecording { get; }
Visual Basic
Public ReadOnly Property IsRecording As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is being recorded; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Requires both Recorders and SupervisorRecorders.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | An associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


IsShared Property

[image]

IceLib Technical Reference
Interaction..::..IsShared Property
Interaction Class See Also Send Feedback
Gets a value indicating whether this is a shared instance.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsShared { get; internal set; }
Visual Basic
Public Property IsShared As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this is a shared instance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

IceLib automatically conserves memory by maintaining a shared instance of each unique Interaction that it creates internally.

A shared instance cannot be watched. This prevents the assignment of conflicting sets of watched attributes. To watch this Interaction, create a new instance using the InteractionId.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Language Property

[image]

IceLib Technical Reference
Interaction..::..Language Property
Interaction Class See Also Send Feedback
Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Language { get; }
Visual Basic
Public ReadOnly Property Language As String
    Get

Field Value

The language to use for the prompt.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LastSegment Property

[image]

IceLib Technical Reference
Interaction..::..LastSegment Property
Interaction Class See Also Send Feedback
Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegment LastSegment { get; }
Visual Basic
Public ReadOnly Property LastSegment As InteractionSegment
    Get

Field Value

The last segment.

Remarks

If there are no segments on this interaction, returns nullNothingnullptra null reference (Nothing in Visual Basic). Otherwise, returns the most recent segment.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LastSegmentForCurrentUser Property

[image]

IceLib Technical Reference
Interaction..::..LastSegmentForCurrentUser Property
Interaction Class See Also Send Feedback
Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegment LastSegmentForCurrentUser { get; }
Visual Basic
Public ReadOnly Property LastSegmentForCurrentUser As InteractionSegment
    Get

Field Value

The last segment for the current user.

Remarks

If the session user does not have a segment on this interaction, returns nullNothingnullptra null reference (Nothing in Visual Basic). Otherwise, returns the most recent segment for the session user.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LineName Property

[image]

IceLib Technical Reference
Interaction..::..LineName Property
Interaction Class See Also Send Feedback
Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LineName { get; }
Visual Basic
Public ReadOnly Property LineName As String
    Get

Field Value

The unscoped name of the line queue.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LocalAddress Property

[image]

IceLib Technical Reference
Interaction..::..LocalAddress Property
Interaction Class See Also Send Feedback
Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalAddress { get; }
Visual Basic
Public ReadOnly Property LocalAddress As String
    Get

Field Value

The local address string.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LocalId Property

[image]

IceLib Technical Reference
Interaction..::..LocalId Property
Interaction Class See Also Send Feedback
Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalId { get; }
Visual Basic
Public ReadOnly Property LocalId As String
    Get

Field Value

The displayable local address string.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LocalName Property

[image]

IceLib Technical Reference
Interaction..::..LocalName Property
Interaction Class See Also Send Feedback
Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalName { get; }
Visual Basic
Public ReadOnly Property LocalName As String
    Get

Field Value

The user-friendly name of the local party.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LocalPartyType Property

[image]

IceLib Technical Reference
Interaction..::..LocalPartyType Property
Interaction Class See Also Send Feedback
Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCallPartyType LocalPartyType { get; }
Visual Basic
Public ReadOnly Property LocalPartyType As InteractionCallPartyType
    Get

Field Value

The type of the local party.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LocalSecurityLevelRequested Property

[image]

IceLib Technical Reference
Interaction..::..LocalSecurityLevelRequested Property
Interaction Class See Also Send Feedback
Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSecurityLevel LocalSecurityLevelRequested { get; }
Visual Basic
Public ReadOnly Property LocalSecurityLevelRequested As InteractionSecurityLevel
    Get

Field Value

The requested local security level.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Log Property

[image]

IceLib Technical Reference
Interaction..::..Log Property
Interaction Class See Also Send Feedback
Gets the Log. Log is only available if the Log attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Log { get; }
Visual Basic
Public ReadOnly Property Log As String
    Get

Field Value

The log.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Monitors Property

[image]

IceLib Technical Reference
Interaction..::..Monitors Property
Interaction Class See Also Send Feedback
Gets the Monitors. Monitors is only available if the Monitors attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionMonitor> Monitors { get; }
Visual Basic
Public ReadOnly Property Monitors As ReadOnlyCollection(Of InteractionMonitor)
    Get

Field Value

The monitors.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


MonitorsCombinedCount Property

[image]

IceLib Technical Reference
Interaction..::..MonitorsCombinedCount Property
Interaction Class See Also Send Feedback
Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MonitorsCombinedCount { get; }
Visual Basic
Public ReadOnly Property MonitorsCombinedCount As Integer
    Get

Field Value

The monitors combined count.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


MonitorType Property

[image]

IceLib Technical Reference
Interaction..::..MonitorType Property
Interaction Class See Also Send Feedback
Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionMonitorType MonitorType { get; }
Visual Basic
Public ReadOnly Property MonitorType As InteractionMonitorType
    Get

Field Value

The type of the monitor.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Notes Property

[image]

IceLib Technical Reference
Interaction..::..Notes Property
Interaction Class See Also Send Feedback
Gets the Notes. Notes is only available if the Notes attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; }
Visual Basic
Public ReadOnly Property Notes As String
    Get

Field Value

The notes.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


OrbitQueueName Property

[image]

IceLib Technical Reference
Interaction..::..OrbitQueueName Property
Interaction Class See Also Send Feedback
Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrbitQueueName { get; }
Visual Basic
Public ReadOnly Property OrbitQueueName As String
    Get

Field Value

The unscoped name of the orbit queue.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


PopApplication Property

[image]

IceLib Technical Reference
Interaction..::..PopApplication Property
Interaction Class See Also Send Feedback
Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PopApplication { get; }
Visual Basic
Public ReadOnly Property PopApplication As String
    Get

Field Value

The pop application.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Recorders Property

[image]

IceLib Technical Reference
Interaction..::..Recorders Property
Interaction Class See Also Send Feedback
Gets the Recorders. Recorders is only available if the Recorders attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionRecord> Recorders { get; }
Visual Basic
Public ReadOnly Property Recorders As ReadOnlyCollection(Of InteractionRecord)
    Get

Field Value

The recorders.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RecordersCombinedCount Property

[image]

IceLib Technical Reference
Interaction..::..RecordersCombinedCount Property
Interaction Class See Also Send Feedback
Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RecordersCombinedCount { get; }
Visual Basic
Public ReadOnly Property RecordersCombinedCount As Integer
    Get

Field Value

The recorders combined count.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RelatedSnippetRecordings Property

[image]

IceLib Technical Reference
Interaction..::..RelatedSnippetRecordings Property
Interaction Class See Also Send Feedback
Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RelatedSnippetRecording> RelatedSnippetRecordings { get; }
Visual Basic
Public ReadOnly Property RelatedSnippetRecordings As ReadOnlyCollection(Of RelatedSnippetRecording)
    Get

Field Value

The snippet recordings for this interaction.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RemoteAddress Property

[image]

IceLib Technical Reference
Interaction..::..RemoteAddress Property
Interaction Class See Also Send Feedback
Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteAddress { get; }
Visual Basic
Public ReadOnly Property RemoteAddress As String
    Get

Field Value

The remote address.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RemoteDisplay Property

[image]

IceLib Technical Reference
Interaction..::..RemoteDisplay Property
Interaction Class See Also Send Feedback
Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteDisplay { get; }
Visual Basic
Public ReadOnly Property RemoteDisplay As String
    Get

Field Value

The RemoteName if populated, otherwise the RemoteId.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RemoteId Property

[image]

IceLib Technical Reference
Interaction..::..RemoteId Property
Interaction Class See Also Send Feedback
Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteId { get; }
Visual Basic
Public ReadOnly Property RemoteId As String
    Get

Field Value

The remote ID.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RemoteName Property

[image]

IceLib Technical Reference
Interaction..::..RemoteName Property
Interaction Class See Also Send Feedback
Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteName { get; }
Visual Basic
Public ReadOnly Property RemoteName As String
    Get

Field Value

The name of the remote.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RemotePartyType Property

[image]

IceLib Technical Reference
Interaction..::..RemotePartyType Property
Interaction Class See Also Send Feedback
Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCallPartyType RemotePartyType { get; }
Visual Basic
Public ReadOnly Property RemotePartyType As InteractionCallPartyType
    Get

Field Value

The type of the remote party.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RemoteSecurityLevelRequested Property

[image]

IceLib Technical Reference
Interaction..::..RemoteSecurityLevelRequested Property
Interaction Class See Also Send Feedback
Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSecurityLevel RemoteSecurityLevelRequested { get; }
Visual Basic
Public ReadOnly Property RemoteSecurityLevelRequested As InteractionSecurityLevel
    Get

Field Value

The requested remote security level.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SecurityLevelActual Property

[image]

IceLib Technical Reference
Interaction..::..SecurityLevelActual Property
Interaction Class See Also Send Feedback
Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSecurityLevel SecurityLevelActual { get; }
Visual Basic
Public ReadOnly Property SecurityLevelActual As InteractionSecurityLevel
    Get

Field Value

The actual security level.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SecurityLevelViolation Property

[image]

IceLib Technical Reference
Interaction..::..SecurityLevelViolation Property
Interaction Class See Also Send Feedback
Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SecurityLevelViolation { get; }
Visual Basic
Public ReadOnly Property SecurityLevelViolation As String
    Get

Field Value

The reason for the security level violation.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Segments Property

[image]

IceLib Technical Reference
Interaction..::..Segments Property
Interaction Class See Also Send Feedback
Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionSegment> Segments { get; }
Visual Basic
Public ReadOnly Property Segments As ReadOnlyCollection(Of InteractionSegment)
    Get

Field Value

The segments for this interaction.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


State Property

[image]

IceLib Technical Reference
Interaction..::..State Property
Interaction Class See Also Send Feedback
Gets the Interaction State. State is only available if the State attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionState State { get; }
Visual Basic
Public ReadOnly Property State As InteractionState
    Get

Field Value

The state.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


StateDescription Property

[image]

IceLib Technical Reference
Interaction..::..StateDescription Property
Interaction Class See Also Send Feedback
Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StateDescription { get; }
Visual Basic
Public ReadOnly Property StateDescription As String
    Get

Field Value

The state display string.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


StationQueueNames Property

[image]

IceLib Technical Reference
Interaction..::..StationQueueNames Property
Interaction Class See Also Send Feedback
Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> StationQueueNames { get; }
Visual Basic
Public ReadOnly Property StationQueueNames As ReadOnlyCollection(Of String)
    Get

Field Value

The unscoped name(s) of the station queue(s).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SupervisorMonitors Property

[image]

IceLib Technical Reference
Interaction..::..SupervisorMonitors Property
Interaction Class See Also Send Feedback
Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionMonitor> SupervisorMonitors { get; }
Visual Basic
Public ReadOnly Property SupervisorMonitors As ReadOnlyCollection(Of InteractionMonitor)
    Get

Field Value

The supervisor monitors.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


SupervisorRecorders Property

[image]

IceLib Technical Reference
Interaction..::..SupervisorRecorders Property
Interaction Class See Also Send Feedback
Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionRecord> SupervisorRecorders { get; }
Visual Basic
Public ReadOnly Property SupervisorRecorders As ReadOnlyCollection(Of InteractionRecord)
    Get

Field Value

The supervisor recorders.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


TimeInWorkgroupQueue Property

[image]

IceLib Technical Reference
Interaction..::..TimeInWorkgroupQueue Property
Interaction Class See Also Send Feedback
Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan TimeInWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property TimeInWorkgroupQueue As TimeSpan
    Get

Field Value

The duration.

Remarks

This is a helper that returns the duration from the WorkgroupQueueTimestamp until either the DisconnectionTime (if disconnected) or the current time (if connected).

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


UserQueueNames Property

[image]

IceLib Technical Reference
Interaction..::..UserQueueNames Property
Interaction Class See Also Send Feedback
Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> UserQueueNames { get; }
Visual Basic
Public ReadOnly Property UserQueueNames As ReadOnlyCollection(Of String)
    Get

Field Value

The unscoped name(s) of the user queue(s).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


WorkgroupQueueDisplayName Property

[image]

IceLib Technical Reference
Interaction..::..WorkgroupQueueDisplayName Property
Interaction Class See Also Send Feedback
Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkgroupQueueDisplayName { get; }
Visual Basic
Public ReadOnly Property WorkgroupQueueDisplayName As String
    Get

Field Value

The display name of the workgroup queue.

Remarks

This can be assigned via handlers to be different than the actual workgroup name. The associated attribute to set from handlers is 'Eic_AssignedWorkgroup'.

This can allow client applications to display a more "friendly name" to the end user, by making the desired handler customization and using the WorkgroupQueueDisplayName attribute for display purposes.

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


WorkgroupQueueName Property

[image]

IceLib Technical Reference
Interaction..::..WorkgroupQueueName Property
Interaction Class See Also Send Feedback
Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkgroupQueueName { get; }
Visual Basic
Public ReadOnly Property WorkgroupQueueName As String
    Get

Field Value

The unscoped name of the workgroup queue.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


WrapUpAssignments Property

[image]

IceLib Technical Reference
Interaction..::..WrapUpAssignments Property
Interaction Class See Also Send Feedback
Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WrapUpAssignment> WrapUpAssignments { get; }
Visual Basic
Public ReadOnly Property WrapUpAssignments As ReadOnlyCollection(Of WrapUpAssignment)
    Get

Field Value

The wrap up assignments.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


WrapUpCodeId Property

[image]

IceLib Technical Reference
Interaction..::..WrapUpCodeId Property
Interaction Class See Also Send Feedback
Gets the ID of the wrap up code.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("WrapUpCodeId is deprecated. Please use WrapUpAssignment instead.")]
public string WrapUpCodeId { get; }
Visual Basic
<ObsoleteAttribute("WrapUpCodeId is deprecated. Please use WrapUpAssignment instead.")> _
Public ReadOnly Property WrapUpCodeId As String
    Get

Field Value

The wrap up code ID.

Remarks

The ID can be used with an ININ.IceLib.People.WrapUpCode.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Interaction Events

[image] [image]

IceLib Technical Reference
Interaction Events
Interaction Class See Also Send Feedback

The Interaction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change.
Public event | Deallocated | Occurs when an Interaction is deallocated.
Public event | LostRights | Occurs when the User loses rights for the Interaction.
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation).
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction.

See Also

Interaction Class
ININ.IceLib.Interactions Namespace


AttributesChanged Event

[image]

IceLib Technical Reference
Interaction..::..AttributesChanged Event
Interaction Class See Also Send Feedback
Occurs when an Interaction's watched attributes change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AttributesEventArgs> AttributesChanged
Visual Basic
Public Event AttributesChanged As EventHandler(Of AttributesEventArgs)

Remarks

This event will only occur when attributes being watched have changed. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Deallocated Event

[image]

IceLib Technical Reference
Interaction..::..Deallocated Event
Interaction Class See Also Send Feedback
Occurs when an Interaction is deallocated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler Deallocated
Visual Basic
Public Event Deallocated As EventHandler

Remarks

This event will only occur if the Interaction is being watched. To start watching call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


LostRights Event

[image]

IceLib Technical Reference
Interaction..::..LostRights Event
Interaction Class See Also Send Feedback
Occurs when the User loses rights for the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler LostRights
Visual Basic
Public Event LostRights As EventHandler

Remarks

This event will only occur if the Interaction is being watched. To start watching call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


Morphed Event

[image]

IceLib Technical Reference
Interaction..::..Morphed Event
Interaction Class See Also Send Feedback
Occurs when an Interaction is replaced by another (e.g. during a Consult operation).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionEventArgs> Morphed
Visual Basic
Public Event Morphed As EventHandler(Of InteractionEventArgs)

Remarks

This event will only occur if the Interaction is being watched. To start watching call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


RecordingSnippetCreated Event

[image]

IceLib Technical Reference
Interaction..::..RecordingSnippetCreated Event
Interaction Class See Also Send Feedback
Occurs when a recording snippet is created for an interaction.

Note: This event is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<RecordingSnippetCreatedEventArgs> RecordingSnippetCreated
Visual Basic
Public Event RecordingSnippetCreated As EventHandler(Of RecordingSnippetCreatedEventArgs)

Remarks

This event will only occur if the Interaction is being watched. To start watching call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Interactions Namespace


InteractionAlertAction Enumeration

[image]

IceLib Technical Reference
InteractionAlertAction Enumeration
See Also Send Feedback
Indicates the action that needs to be taken when an alert event is received.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionAlertAction
Visual Basic
Public Enumeration InteractionAlertAction

Members

Member name | Value | Description
None | 0 | No action required.
StartAlerting | 1 | Start alerting for the Interaction.
StopAlerting | 2 | Stop alerting for the Interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionAlerting Class

[image]

IceLib Technical Reference
InteractionAlerting Class
Members See Also Send Feedback
This class provides information about Interactions that are alerting for the Session User.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAlerting
Visual Basic
Public Class InteractionAlerting

Remarks

InteractionAlerting relies on its related Session to be connected to function properly; the Session is set via the InteractionsManager used to create the InteractionAlerting instance. If an InteractionAlerting instance is created when its related Session is not connected, it will correct itself when StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object) is called. Be aware that until that time, attempting to call ToString()()()() or access the UserId property will will return a value of Empty.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAlerting

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Members
ININ.IceLib.Interactions Namespace


InteractionAlerting Members

[image] [image]

IceLib Technical Reference
InteractionAlerting Members
InteractionAlerting Class Constructors Methods Properties Events See Also Send Feedback

The InteractionAlerting type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionAlerting | Initializes a new instance of the InteractionAlerting class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for alerting events.
Public method | StartWatchingAsync | Asynchronously starts watching for alerting events.
Public method | StopWatching | Stops watching for alerting events.
Public method | StopWatchingAsync | Asynchronously stops watching for alerting events.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager associated with this object.
Public property | UserId | Gets the user ID.

Events

 | Name | Description
Public event | AlertReceived | Occurs when an interaction is about to be alerted or when an interaction is about to stop alerting.

See Also

InteractionAlerting Class
ININ.IceLib.Interactions Namespace


InteractionAlerting Constructor

[image]

IceLib Technical Reference
InteractionAlerting Constructor
InteractionAlerting Class See Also Send Feedback
Initializes a new instance of the InteractionAlerting class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAlerting(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


InteractionAlerting Methods

[image] [image]

IceLib Technical Reference
InteractionAlerting Methods
InteractionAlerting Class See Also Send Feedback

The InteractionAlerting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for alerting events.
Public method | StartWatchingAsync | Asynchronously starts watching for alerting events.
Public method | StopWatching | Stops watching for alerting events.
Public method | StopWatchingAsync | Asynchronously stops watching for alerting events.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionAlerting Class
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
InteractionAlerting..::..IsWatching Method
InteractionAlerting Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
InteractionAlerting..::..StartWatching Method
InteractionAlerting Class See Also Send Feedback
Starts watching for alerting events.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionAlertingDetails> StartWatching()
Visual Basic
Public Function StartWatching As ReadOnlyCollection(Of InteractionAlertingDetails)

Return Value

The initial alerting details.

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
InteractionAlerting..::..StartWatchingAsync Method
InteractionAlerting Class See Also Send Feedback
Asynchronously starts watching for alerting events.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    EventHandler<AsyncStartWatchCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncStartWatchCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncStartWatchCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
InteractionAlerting..::..StopWatching Method
InteractionAlerting Class See Also Send Feedback
Stops watching for alerting events.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
InteractionAlerting..::..StopWatchingAsync Method
InteractionAlerting Class See Also Send Feedback
Asynchronously stops watching for alerting events.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionAlerting..::..ToString Method
InteractionAlerting Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Remarks

See the InteractionAlerting class remarks for some caveats if the InteractionAlerting class is created before its related Session is connected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


InteractionAlerting Properties

[image] [image]

IceLib Technical Reference
InteractionAlerting Properties
InteractionAlerting Class See Also Send Feedback

The InteractionAlerting type exposes the following members.

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager associated with this object.
Public property | UserId | Gets the user ID.

See Also

InteractionAlerting Class
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
InteractionAlerting..::..InteractionsManager Property
InteractionAlerting Class See Also Send Feedback
Gets the InteractionManager associated with this object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


UserId Property

[image]

IceLib Technical Reference
InteractionAlerting..::..UserId Property
InteractionAlerting Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Remarks

See the InteractionAlerting class remarks for some caveats if the InteractionAlerting class is created before its related Session is connected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


InteractionAlerting Events

[image] [image]

IceLib Technical Reference
InteractionAlerting Events
InteractionAlerting Class See Also Send Feedback

The InteractionAlerting type exposes the following members.

Events

 | Name | Description
Public event | AlertReceived | Occurs when an interaction is about to be alerted or when an interaction is about to stop alerting.

See Also

InteractionAlerting Class
ININ.IceLib.Interactions Namespace


AlertReceived Event

[image]

IceLib Technical Reference
InteractionAlerting..::..AlertReceived Event
InteractionAlerting Class See Also Send Feedback
Occurs when an interaction is about to be alerted or when an interaction is about to stop alerting.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionAlertingEventArgs> AlertReceived
Visual Basic
Public Event AlertReceived As EventHandler(Of InteractionAlertingEventArgs)

Remarks

This event will only occur if the interaction is being watched. To start watching the interaction call either the StartWatching()()()() method or the StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(EventHandler<(Of <<'(AsyncStartWatchCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlerting Class
InteractionAlerting Members
ININ.IceLib.Interactions Namespace


InteractionAlertingDetails Class

[image]

IceLib Technical Reference
InteractionAlertingDetails Class
Members See Also Send Feedback
Provides details for alerting via the InteractionAlerting class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAlertingDetails
Visual Basic
Public Class InteractionAlertingDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAlertingDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


InteractionAlertingDetails Members

[image] [image]

IceLib Technical Reference
InteractionAlertingDetails Members
InteractionAlertingDetails Class Methods Properties See Also Send Feedback

The InteractionAlertingDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AlertAction | Gets the alert action, which indicates if the alert is starting or stopping.
Public property | AlertType | Gets the type of the alert.
Public property | AutoAnswer | Gets a value indicating whether the interaction is set to auto answer.
Public property | CallingAddress | Gets the calling party address.
Public property | CallingName | Gets the name of the calling party.
Public property | InteractionId | Gets the ID of the interaction that is about to start or stop alerting.
Public property | MonitoredQueue | Gets the monitored queue, if any.

See Also

InteractionAlertingDetails Class
ININ.IceLib.Interactions Namespace


InteractionAlertingDetails Methods

[image] [image]

IceLib Technical Reference
InteractionAlertingDetails Methods
InteractionAlertingDetails Class See Also Send Feedback

The InteractionAlertingDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionAlertingDetails Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..ToString Method
InteractionAlertingDetails Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


InteractionAlertingDetails Properties

[image] [image]

IceLib Technical Reference
InteractionAlertingDetails Properties
InteractionAlertingDetails Class See Also Send Feedback

The InteractionAlertingDetails type exposes the following members.

Properties

 | Name | Description
Public property | AlertAction | Gets the alert action, which indicates if the alert is starting or stopping.
Public property | AlertType | Gets the type of the alert.
Public property | AutoAnswer | Gets a value indicating whether the interaction is set to auto answer.
Public property | CallingAddress | Gets the calling party address.
Public property | CallingName | Gets the name of the calling party.
Public property | InteractionId | Gets the ID of the interaction that is about to start or stop alerting.
Public property | MonitoredQueue | Gets the monitored queue, if any.

See Also

InteractionAlertingDetails Class
ININ.IceLib.Interactions Namespace


AlertAction Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..AlertAction Property
InteractionAlertingDetails Class See Also Send Feedback
Gets the alert action, which indicates if the alert is starting or stopping.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAlertAction AlertAction { get; }
Visual Basic
Public ReadOnly Property AlertAction As InteractionAlertAction
    Get

Field Value

The alert action, which indicates if the alert is starting or stopping.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


AlertType Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..AlertType Property
InteractionAlertingDetails Class See Also Send Feedback
Gets the type of the alert.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAlertType AlertType { get; }
Visual Basic
Public ReadOnly Property AlertType As InteractionAlertType
    Get

Field Value

The type of the alert.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


AutoAnswer Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..AutoAnswer Property
InteractionAlertingDetails Class See Also Send Feedback
Gets a value indicating whether the interaction is set to auto answer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AutoAnswer { get; }
Visual Basic
Public ReadOnly Property AutoAnswer As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if is set to auto answer; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


CallingAddress Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..CallingAddress Property
InteractionAlertingDetails Class See Also Send Feedback
Gets the calling party address.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallingAddress { get; }
Visual Basic
Public ReadOnly Property CallingAddress As String
    Get

Field Value

The calling party address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


CallingName Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..CallingName Property
InteractionAlertingDetails Class See Also Send Feedback
Gets the name of the calling party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallingName { get; }
Visual Basic
Public ReadOnly Property CallingName As String
    Get

Field Value

The name of the calling party.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..InteractionId Property
InteractionAlertingDetails Class See Also Send Feedback
Gets the ID of the interaction that is about to start or stop alerting.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Field Value

The ID of the interaction that is about to start or stop alerting.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


MonitoredQueue Property

[image]

IceLib Technical Reference
InteractionAlertingDetails..::..MonitoredQueue Property
InteractionAlertingDetails Class See Also Send Feedback
Gets the monitored queue, if any.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueId MonitoredQueue { get; }
Visual Basic
Public ReadOnly Property MonitoredQueue As QueueId
    Get

Field Value

The monitored queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingDetails Class
InteractionAlertingDetails Members
ININ.IceLib.Interactions Namespace


InteractionAlertingEventArgs Class

[image]

IceLib Technical Reference
InteractionAlertingEventArgs Class
Members See Also Send Feedback
Provides data for the AlertReceived event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAlertingEventArgs : EventArgs
Visual Basic
Public Class InteractionAlertingEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..InteractionAlertingEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionAlertingEventArgs Members

[image] [image]

IceLib Technical Reference
InteractionAlertingEventArgs Members
InteractionAlertingEventArgs Class Methods Properties See Also Send Feedback

The InteractionAlertingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlertingDetails | Gets the alerting details.

See Also

InteractionAlertingEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionAlertingEventArgs Methods

[image] [image]

IceLib Technical Reference
InteractionAlertingEventArgs Methods
InteractionAlertingEventArgs Class See Also Send Feedback

The InteractionAlertingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionAlertingEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionAlertingEventArgs Properties

[image] [image]

IceLib Technical Reference
InteractionAlertingEventArgs Properties
InteractionAlertingEventArgs Class See Also Send Feedback

The InteractionAlertingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AlertingDetails | Gets the alerting details.

See Also

InteractionAlertingEventArgs Class
ININ.IceLib.Interactions Namespace


AlertingDetails Property

[image]

IceLib Technical Reference
InteractionAlertingEventArgs..::..AlertingDetails Property
InteractionAlertingEventArgs Class See Also Send Feedback
Gets the alerting details.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionAlertingDetails> AlertingDetails { get; }
Visual Basic
Public ReadOnly Property AlertingDetails As ReadOnlyCollection(Of InteractionAlertingDetails)
    Get

Field Value

The alerting details.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAlertingEventArgs Class
InteractionAlertingEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionAlertType Enumeration

[image]

IceLib Technical Reference
InteractionAlertType Enumeration
See Also Send Feedback
Represents the reason why an interaction is alerting.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionAlertType
Visual Basic
Public Enumeration InteractionAlertType

Members

Member name | Value | Description
None | 0 | The Interaction is alerting, source unknown.
User | 1 | The Interaction is alerting on a user queue.
Station | 2 | The Interaction is alerting on a station queue.
Workgroup | 3 | The Interaction is alerting on a workgroup queue.
StationGroup | 4 | The Interaction is alerting on a station group queue.
AcdUser | 5 | The Interaction is alerting on the ACD user.
AcdStation | 6 | The Interaction is alerting on ACD station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionAttributeMonitor Class

[image]

IceLib Technical Reference
InteractionAttributeMonitor Class
Members See Also Send Feedback
Allows attribute level monitors on the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAttributeMonitor
Visual Basic
Public Class InteractionAttributeMonitor

Remarks

Use this class to be notified of interactions that have an attribute set to a specific value. For ex. an application would like to know about attributes "Eic_State, Eic_CallId" on all interactions that have CallClassification attribute set to "Emergency". Please refer to ININ.People.UserDataSettings.AllowedClassificationList to get a list of call classifications that you have access to.

Examples

CallClassification attribute set to "Emergency" can be represented by AttributeMonitorId. InteractionAttributeMonitor should be used to
CopyC#
string attributeValue = "Emergency";

InteractionsManager manager = InteractionsManager.GetInstance(_Session);

AttributeMonitorId monitorId = new AttributeMonitorId(InteractionAttributeName.CallClassification, attributeValue);
InteractionAttributeMonitor monitor = new InteractionAttributeMonitor(manager, monitorId);

string[] attributes = new string[] { "Eic_State", "Eic_CallId" };

monitor.StartWatching(attributes);
 The object "monitor" will start receiving notifications as long as CallClassification attribute is set to "Emergency" on any interactions. InteractionAttributesEventArgs contains the interactions that match AttributeMonitorId.

Note
When monitoring emergency calls, be sure to monitor the following attributes. These attributes contain originating station's (the station from which emergency call was made) emergency information.
  • StationLocationDescription - Station Location Description
  • StationEmergencyOutboundAni - Station Emergency Outbound ANI
  • StationEmergencyCustomerLocationDescription - Station Emergency Customer Location Description
  • StationEmergencyCustomerName - Station Emergency Customer Name

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeMonitor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionAttributeMonitor Members

[image] [image]

IceLib Technical Reference
InteractionAttributeMonitor Members
InteractionAttributeMonitor Class Constructors Methods Properties Events See Also Send Feedback

The InteractionAttributeMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionAttributeMonitor | Initializes a new instance of the InteractionAttributeMonitor class.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StopWatching | Stops watching the Interaction.
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AttributeMonitorId | Gets the ID of the Monitor.
Public property | CachedInteractions | Gets the cached Interactions.
Public property | InteractionsManager | Gets the InteractionManager with which this monitor is associated.

Events

 | Name | Description
Public event | InteractionAdded | Occurs when an Interaction is added to the Attribute Monitor.
Public event | InteractionChanged | Occurs when an Interaction on the Attribute Monitor changes.
Public event | InteractionRemoved | Occurs when an Interaction is removed from the Attribute Monitor.
Public event | LostRights | Occurs when the user lost rights to receive events on this monitor.

See Also

InteractionAttributeMonitor Class
ININ.IceLib.Interactions Namespace


InteractionAttributeMonitor Constructor

[image]

IceLib Technical Reference
InteractionAttributeMonitor Constructor
InteractionAttributeMonitor Class See Also Send Feedback
Initializes a new instance of the InteractionAttributeMonitor class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAttributeMonitor(
    InteractionsManager interactionsManager,
    AttributeMonitorId monitorId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    monitorId As AttributeMonitorId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
monitorId
Type: ININ.IceLib.Interactions..::..AttributeMonitorId
The monitor ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionAttributeMonitor Methods

[image] [image]

IceLib Technical Reference
InteractionAttributeMonitor Methods
InteractionAttributeMonitor Class See Also Send Feedback

The InteractionAttributeMonitor type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)
Public method | StopWatching | Stops watching the Interaction.
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionAttributeMonitor Class
ININ.IceLib.Interactions Namespace


ChangeWatchedAttributes Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..ChangeWatchedAttributes Method
InteractionAttributeMonitor Class See Also Send Feedback
Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributes(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedAttributes ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


ChangeWatchedAttributesAsync Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..ChangeWatchedAttributesAsync Method
InteractionAttributeMonitor Class See Also Send Feedback
Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributesAsync(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAttributesAsync ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
InteractionAttributeMonitor..::..IsWatching Method
InteractionAttributeMonitor Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..IsWatching Method
InteractionAttributeMonitor Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance. InteractionAttributeName provides a list of attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
IsWatching Overload
ININ.IceLib.Interactions Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..IsWatching Method (String)
InteractionAttributeMonitor Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string attributeName
)
Visual Basic
Public Function IsWatching ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
IsWatching Overload
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..StartWatching Method
InteractionAttributeMonitor Class See Also Send Feedback
Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] attributeNames
)
Visual Basic
Public Sub StartWatching ( _
    attributeNames As String() _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.

Remarks

Applications cannot call StartWatching(array<String>[]()[][]) on the interactions that this object caches. A new instance of interaction object needs to be constructed in order to watch. However, actions such as Join()()()(), Listen(Boolean, Boolean) can be performed on this instance of interaction. A new instance need not be created. This instance of the interaction object is not based off InteractionQueue.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A watch is already in progress.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..StartWatchingAsync Method
InteractionAttributeMonitor Class See Also Send Feedback
Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] attributeNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    attributeNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..StopWatching Method
InteractionAttributeMonitor Class See Also Send Feedback
Stops watching the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..StopWatchingAsync Method
InteractionAttributeMonitor Class See Also Send Feedback
Asynchronously stops watching the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..ToString Method
InteractionAttributeMonitor Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionAttributeMonitor Properties

[image] [image]

IceLib Technical Reference
InteractionAttributeMonitor Properties
InteractionAttributeMonitor Class See Also Send Feedback

The InteractionAttributeMonitor type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMonitorId | Gets the ID of the Monitor.
Public property | CachedInteractions | Gets the cached Interactions.
Public property | InteractionsManager | Gets the InteractionManager with which this monitor is associated.

See Also

InteractionAttributeMonitor Class
ININ.IceLib.Interactions Namespace


AttributeMonitorId Property

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..AttributeMonitorId Property
InteractionAttributeMonitor Class See Also Send Feedback
Gets the ID of the Monitor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttributeMonitorId AttributeMonitorId { get; }
Visual Basic
Public ReadOnly Property AttributeMonitorId As AttributeMonitorId
    Get

Field Value

The monitor ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


CachedInteractions Property

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..CachedInteractions Property
InteractionAttributeMonitor Class See Also Send Feedback
Gets the cached Interactions.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Interaction> CachedInteractions { get; }
Visual Basic
Public ReadOnly Property CachedInteractions As ReadOnlyCollection(Of Interaction)
    Get

Field Value

The cached interactions.

Remarks

Applications cannot call StartWatching(array<String>[]()[][]) on these cached interactions. A new instance of interaction object needs to be constructed in order to watch. This instance of the interaction object is not based off InteractionQueue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..InteractionsManager Property
InteractionAttributeMonitor Class See Also Send Feedback
Gets the InteractionManager with which this monitor is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionAttributeMonitor Events

[image] [image]

IceLib Technical Reference
InteractionAttributeMonitor Events
InteractionAttributeMonitor Class See Also Send Feedback

The InteractionAttributeMonitor type exposes the following members.

Events

 | Name | Description
Public event | InteractionAdded | Occurs when an Interaction is added to the Attribute Monitor.
Public event | InteractionChanged | Occurs when an Interaction on the Attribute Monitor changes.
Public event | InteractionRemoved | Occurs when an Interaction is removed from the Attribute Monitor.
Public event | LostRights | Occurs when the user lost rights to receive events on this monitor.

See Also

InteractionAttributeMonitor Class
ININ.IceLib.Interactions Namespace


InteractionAdded Event

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..InteractionAdded Event
InteractionAttributeMonitor Class See Also Send Feedback
Occurs when an Interaction is added to the Attribute Monitor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionAttributesEventArgs> InteractionAdded
Visual Basic
Public Event InteractionAdded As EventHandler(Of InteractionAttributesEventArgs)

Remarks

This event will only occur when watching Interaction attributes. To start watching for interactions call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which interactions are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionChanged Event

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..InteractionChanged Event
InteractionAttributeMonitor Class See Also Send Feedback
Occurs when an Interaction on the Attribute Monitor changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionAttributesEventArgs> InteractionChanged
Visual Basic
Public Event InteractionChanged As EventHandler(Of InteractionAttributesEventArgs)

Remarks

This event will only occur when Interaction attributes being watched have changed. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionRemoved Event

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..InteractionRemoved Event
InteractionAttributeMonitor Class See Also Send Feedback
Occurs when an Interaction is removed from the Attribute Monitor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionAttributesEventArgs> InteractionRemoved
Visual Basic
Public Event InteractionRemoved As EventHandler(Of InteractionAttributesEventArgs)

Remarks

This event will only occur when watching Interaction attributes. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


LostRights Event

[image]

IceLib Technical Reference
InteractionAttributeMonitor..::..LostRights Event
InteractionAttributeMonitor Class See Also Send Feedback
Occurs when the user lost rights to receive events on this monitor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EventArgs> LostRights
Visual Basic
Public Event LostRights As EventHandler(Of EventArgs)

Remarks

One of the scenarios this might occur is when the user is removed from Call classification's notification list.

This event will only occur when watching Interaction attributes. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeMonitor Class
InteractionAttributeMonitor Members
ININ.IceLib.Interactions Namespace


InteractionAttributeName Class

[image]

IceLib Technical Reference
InteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with Interaction watches.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class InteractionAttributeName
Visual Basic
Public MustInherit Class InteractionAttributeName

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the Interaction, InteractionQueue, and InteractionAttributeMonitor classes.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.Interactions..::..CallbackInteractionAttributeName
ININ.IceLib.Interactions..::..EmailInteractionAttributeName
ININ.IceLib.Interactions..::..MonitorInteractionAttributeName
ININ.IceLib.Interactions..::..RecorderInteractionAttributeName
ININ.IceLib.ProcessAutomation..::..WorkItemInteractionAttributeName
ININ.IceLib.Tracker..::..TrackerInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..InteractionQueue
ININ.IceLib.Interactions..::..InteractionAttributeMonitor


InteractionAttributeName Members

[image] [image]

IceLib Technical Reference
InteractionAttributeName Members
InteractionAttributeName Class Methods Fields See Also Send Feedback

The InteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AccountCodeId | The ID of the account code associated with the interaction.
AlertSound | The sound to play when the interaction is alerting.
AssociatedProcessDisplayName | The name of the process to which the interaction is associated.
AssociatedProcessInstanceId | The ID of the process to which the interaction is associated.
CallClassification | The call classification (Local, Long Distance, International, Emergency, etc).
CallIdKey | The call ID key of the interaction.
CallType | Indicates the call type.
Capabilities | The capabilities of the Interaction.
ClientMessage | The client message to display.
ConferenceId | The InteractionId of the associated ConferenceInteraction.
ConsultCallId | When set, indicates the interaction is intended to be the target of a consult transfer.
DeallocationSeconds | The number of seconds after the interaction is disconnected until it will automatically be deallocated.
Direction | The direction of the interaction.
DisconnectionTime | The time when the interaction was disconnected.
DisconnectRingNoAnswer | Whether to disconnect on ring no answer.
ImmediateAccess | Whether to allow immediate access to the interaction.
InitiationTime | The time when the interaction was initiated.
InteractionConnectionSegments | A collection of segments of the interaction representing connection to a workgroup.
InteractionId | The InteractionId of the interaction.
InteractionType | The type of interaction.
InteractionUserSegments | A collection of segments of the interaction representing connection to a user queue.
Language | The language to use for the prompt.
LineQueueName | The unscoped name of the line queue on which the interaction is occurring.
LocalAddress | The address of local party (telephone number, IP 'dot' address, etc).
LocalId | The displayable address of local party (formatted telephone number, IP address, etc).
LocalName | The user-friendly name of the local party.
LocalPartyType | The user-friendly name of the local party type.
LocalSecurityLevelRequested | The security level the local endpoint has requested.
Log | The log associated with the interaction.
Monitors | The monitors on the interaction.
MonitorsCombinedCount | The total number of monitors.
MonitorType | The type of monitor on the interaction.
Muted | Whether the interaction is muted.
Notes | The notes associated with the interaction.
OrbitQueueName | The unscoped name of the orbit queue containing the interaction.
PopApplication | The application that should be popped for the interaction.
Private | Whether the interaction is marked as private.
Recorders | The recorders of the interaction.
RecordersCombinedCount | The total number of recorders.
RecordingsAutoResumeTime | The date and time at which the current Secure Recording Pause will expire and recordings will resume.
RelatedSnippetRecordings | The snippet recordings related to an interaction.
RemoteAddress | The remote address.
RemoteId | The ID of the remote party.
RemoteName | The name of the remote party.
RemotePartyType | The type of the remote party.
RemoteSecurityLevelRequested | The security level the remote endpoint has requested.
SecurityLevelActual | The actual security level the interaction is using.
SecurityLevelViolation | Indicates the security level violation and the reason for the violation.
State | The interaction state.
StateDescription | The interaction state description.
StationEmergencyCustomerLocationDescription | The Station's emergency customer location description. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationEmergencyCustomerName | The Station's emergency customer name. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationEmergencyOutboundAni | The Station's emergency outbound ANI. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationLocationDescription | The Station location description. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationQueueNames | The name(s) of the station queue(s).
SupervisorMonitors | The supervisory monitors on the interaction.
SupervisorRecorders | The supervisory recorders of the interaction.
UserQueueNames | The unscoped names of the user queue(s).
WorkgroupQueueDisplayName | The display name of the workgroup queue.
WorkgroupQueueName | The unscoped name of the workgroup queue.
WorkgroupQueueTimestamp | The time when the interaction was queued for a workgroup.
WrapUpAssignments | A collection of wrap up code assignments associated with the interaction.
WrapUpCodeId | Obsolete. The ID of the wrap up code associated with the interaction.

See Also

InteractionAttributeName Class
ININ.IceLib.Interactions Namespace


InteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
InteractionAttributeName Fields
InteractionAttributeName Class See Also Send Feedback

The InteractionAttributeName type exposes the following members.

Fields

Name | Description
AccountCodeId | The ID of the account code associated with the interaction.
AlertSound | The sound to play when the interaction is alerting.
AssociatedProcessDisplayName | The name of the process to which the interaction is associated.
AssociatedProcessInstanceId | The ID of the process to which the interaction is associated.
CallClassification | The call classification (Local, Long Distance, International, Emergency, etc).
CallIdKey | The call ID key of the interaction.
CallType | Indicates the call type.
Capabilities | The capabilities of the Interaction.
ClientMessage | The client message to display.
ConferenceId | The InteractionId of the associated ConferenceInteraction.
ConsultCallId | When set, indicates the interaction is intended to be the target of a consult transfer.
DeallocationSeconds | The number of seconds after the interaction is disconnected until it will automatically be deallocated.
Direction | The direction of the interaction.
DisconnectionTime | The time when the interaction was disconnected.
DisconnectRingNoAnswer | Whether to disconnect on ring no answer.
ImmediateAccess | Whether to allow immediate access to the interaction.
InitiationTime | The time when the interaction was initiated.
InteractionConnectionSegments | A collection of segments of the interaction representing connection to a workgroup.
InteractionId | The InteractionId of the interaction.
InteractionType | The type of interaction.
InteractionUserSegments | A collection of segments of the interaction representing connection to a user queue.
Language | The language to use for the prompt.
LineQueueName | The unscoped name of the line queue on which the interaction is occurring.
LocalAddress | The address of local party (telephone number, IP 'dot' address, etc).
LocalId | The displayable address of local party (formatted telephone number, IP address, etc).
LocalName | The user-friendly name of the local party.
LocalPartyType | The user-friendly name of the local party type.
LocalSecurityLevelRequested | The security level the local endpoint has requested.
Log | The log associated with the interaction.
Monitors | The monitors on the interaction.
MonitorsCombinedCount | The total number of monitors.
MonitorType | The type of monitor on the interaction.
Muted | Whether the interaction is muted.
Notes | The notes associated with the interaction.
OrbitQueueName | The unscoped name of the orbit queue containing the interaction.
PopApplication | The application that should be popped for the interaction.
Private | Whether the interaction is marked as private.
Recorders | The recorders of the interaction.
RecordersCombinedCount | The total number of recorders.
RecordingsAutoResumeTime | The date and time at which the current Secure Recording Pause will expire and recordings will resume.
RelatedSnippetRecordings | The snippet recordings related to an interaction.
RemoteAddress | The remote address.
RemoteId | The ID of the remote party.
RemoteName | The name of the remote party.
RemotePartyType | The type of the remote party.
RemoteSecurityLevelRequested | The security level the remote endpoint has requested.
SecurityLevelActual | The actual security level the interaction is using.
SecurityLevelViolation | Indicates the security level violation and the reason for the violation.
State | The interaction state.
StateDescription | The interaction state description.
StationEmergencyCustomerLocationDescription | The Station's emergency customer location description. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationEmergencyCustomerName | The Station's emergency customer name. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationEmergencyOutboundAni | The Station's emergency outbound ANI. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationLocationDescription | The Station location description. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.
StationQueueNames | The name(s) of the station queue(s).
SupervisorMonitors | The supervisory monitors on the interaction.
SupervisorRecorders | The supervisory recorders of the interaction.
UserQueueNames | The unscoped names of the user queue(s).
WorkgroupQueueDisplayName | The display name of the workgroup queue.
WorkgroupQueueName | The unscoped name of the workgroup queue.
WorkgroupQueueTimestamp | The time when the interaction was queued for a workgroup.
WrapUpAssignments | A collection of wrap up code assignments associated with the interaction.
WrapUpCodeId | Obsolete. The ID of the wrap up code associated with the interaction.

See Also

InteractionAttributeName Class
ININ.IceLib.Interactions Namespace


AccountCodeId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..AccountCodeId Field
InteractionAttributeName Class See Also Send Feedback
The ID of the account code associated with the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AccountCodeId
Visual Basic
Public Shared ReadOnly AccountCodeId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


AlertSound Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..AlertSound Field
InteractionAttributeName Class See Also Send Feedback
The sound to play when the interaction is alerting.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AlertSound
Visual Basic
Public Shared ReadOnly AlertSound As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


AssociatedProcessDisplayName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..AssociatedProcessDisplayName Field
InteractionAttributeName Class See Also Send Feedback
The name of the process to which the interaction is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AssociatedProcessDisplayName
Visual Basic
Public Shared ReadOnly AssociatedProcessDisplayName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


AssociatedProcessInstanceId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..AssociatedProcessInstanceId Field
InteractionAttributeName Class See Also Send Feedback
The ID of the process to which the interaction is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AssociatedProcessInstanceId
Visual Basic
Public Shared ReadOnly AssociatedProcessInstanceId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallClassification Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..CallClassification Field
InteractionAttributeName Class See Also Send Feedback
The call classification (Local, Long Distance, International, Emergency, etc).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallClassification
Visual Basic
Public Shared ReadOnly CallClassification As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallIdKey Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..CallIdKey Field
InteractionAttributeName Class See Also Send Feedback
The call ID key of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallIdKey
Visual Basic
Public Shared ReadOnly CallIdKey As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


CallType Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..CallType Field
InteractionAttributeName Class See Also Send Feedback
Indicates the call type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CallType
Visual Basic
Public Shared ReadOnly CallType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Capabilities Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Capabilities Field
InteractionAttributeName Class See Also Send Feedback
The capabilities of the Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Capabilities
Visual Basic
Public Shared ReadOnly Capabilities As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


ClientMessage Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..ClientMessage Field
InteractionAttributeName Class See Also Send Feedback
The client message to display.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ClientMessage
Visual Basic
Public Shared ReadOnly ClientMessage As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


ConferenceId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..ConferenceId Field
InteractionAttributeName Class See Also Send Feedback
The InteractionId of the associated ConferenceInteraction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ConferenceId
Visual Basic
Public Shared ReadOnly ConferenceId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


ConsultCallId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..ConsultCallId Field
InteractionAttributeName Class See Also Send Feedback
When set, indicates the interaction is intended to be the target of a consult transfer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ConsultCallId
Visual Basic
Public Shared ReadOnly ConsultCallId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


DeallocationSeconds Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..DeallocationSeconds Field
InteractionAttributeName Class See Also Send Feedback
The number of seconds after the interaction is disconnected until it will automatically be deallocated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DeallocationSeconds
Visual Basic
Public Shared ReadOnly DeallocationSeconds As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Direction Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Direction Field
InteractionAttributeName Class See Also Send Feedback
The direction of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Direction
Visual Basic
Public Shared ReadOnly Direction As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


DisconnectionTime Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..DisconnectionTime Field
InteractionAttributeName Class See Also Send Feedback
The time when the interaction was disconnected.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DisconnectionTime
Visual Basic
Public Shared ReadOnly DisconnectionTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


DisconnectRingNoAnswer Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..DisconnectRingNoAnswer Field
InteractionAttributeName Class See Also Send Feedback
Whether to disconnect on ring no answer.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DisconnectRingNoAnswer
Visual Basic
Public Shared ReadOnly DisconnectRingNoAnswer As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


ImmediateAccess Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..ImmediateAccess Field
InteractionAttributeName Class See Also Send Feedback
Whether to allow immediate access to the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ImmediateAccess
Visual Basic
Public Shared ReadOnly ImmediateAccess As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


InitiationTime Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..InitiationTime Field
InteractionAttributeName Class See Also Send Feedback
The time when the interaction was initiated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string InitiationTime
Visual Basic
Public Shared ReadOnly InitiationTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


InteractionConnectionSegments Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..InteractionConnectionSegments Field
InteractionAttributeName Class See Also Send Feedback
A collection of segments of the interaction representing connection to a workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string InteractionConnectionSegments
Visual Basic
Public Shared ReadOnly InteractionConnectionSegments As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


InteractionId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..InteractionId Field
InteractionAttributeName Class See Also Send Feedback
The InteractionId of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string InteractionId
Visual Basic
Public Shared ReadOnly InteractionId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


InteractionType Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..InteractionType Field
InteractionAttributeName Class See Also Send Feedback
The type of interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string InteractionType
Visual Basic
Public Shared ReadOnly InteractionType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


InteractionUserSegments Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..InteractionUserSegments Field
InteractionAttributeName Class See Also Send Feedback
A collection of segments of the interaction representing connection to a user queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string InteractionUserSegments
Visual Basic
Public Shared ReadOnly InteractionUserSegments As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Language Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Language Field
InteractionAttributeName Class See Also Send Feedback
The language to use for the prompt.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Language
Visual Basic
Public Shared ReadOnly Language As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


LineQueueName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..LineQueueName Field
InteractionAttributeName Class See Also Send Feedback
The unscoped name of the line queue on which the interaction is occurring.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LineQueueName
Visual Basic
Public Shared ReadOnly LineQueueName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


LocalAddress Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..LocalAddress Field
InteractionAttributeName Class See Also Send Feedback
The address of local party (telephone number, IP 'dot' address, etc).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LocalAddress
Visual Basic
Public Shared ReadOnly LocalAddress As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


LocalId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..LocalId Field
InteractionAttributeName Class See Also Send Feedback
The displayable address of local party (formatted telephone number, IP address, etc).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LocalId
Visual Basic
Public Shared ReadOnly LocalId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


LocalName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..LocalName Field
InteractionAttributeName Class See Also Send Feedback
The user-friendly name of the local party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LocalName
Visual Basic
Public Shared ReadOnly LocalName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


LocalPartyType Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..LocalPartyType Field
InteractionAttributeName Class See Also Send Feedback
The user-friendly name of the local party type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LocalPartyType
Visual Basic
Public Shared ReadOnly LocalPartyType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


LocalSecurityLevelRequested Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..LocalSecurityLevelRequested Field
InteractionAttributeName Class See Also Send Feedback
The security level the local endpoint has requested.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LocalSecurityLevelRequested
Visual Basic
Public Shared ReadOnly LocalSecurityLevelRequested As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Log Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Log Field
InteractionAttributeName Class See Also Send Feedback
The log associated with the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Log
Visual Basic
Public Shared ReadOnly Log As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Monitors Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Monitors Field
InteractionAttributeName Class See Also Send Feedback
The monitors on the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Monitors
Visual Basic
Public Shared ReadOnly Monitors As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


MonitorsCombinedCount Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..MonitorsCombinedCount Field
InteractionAttributeName Class See Also Send Feedback
The total number of monitors.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MonitorsCombinedCount
Visual Basic
Public Shared ReadOnly MonitorsCombinedCount As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


MonitorType Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..MonitorType Field
InteractionAttributeName Class See Also Send Feedback
The type of monitor on the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MonitorType
Visual Basic
Public Shared ReadOnly MonitorType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Muted Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Muted Field
InteractionAttributeName Class See Also Send Feedback
Whether the interaction is muted.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Muted
Visual Basic
Public Shared ReadOnly Muted As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Notes Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Notes Field
InteractionAttributeName Class See Also Send Feedback
The notes associated with the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Notes
Visual Basic
Public Shared ReadOnly Notes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


OrbitQueueName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..OrbitQueueName Field
InteractionAttributeName Class See Also Send Feedback
The unscoped name of the orbit queue containing the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OrbitQueueName
Visual Basic
Public Shared ReadOnly OrbitQueueName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


PopApplication Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..PopApplication Field
InteractionAttributeName Class See Also Send Feedback
The application that should be popped for the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PopApplication
Visual Basic
Public Shared ReadOnly PopApplication As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Private Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Private Field
InteractionAttributeName Class See Also Send Feedback
Whether the interaction is marked as private.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Private
Visual Basic
Public Shared ReadOnly Private As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


Recorders Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..Recorders Field
InteractionAttributeName Class See Also Send Feedback
The recorders of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Recorders
Visual Basic
Public Shared ReadOnly Recorders As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RecordersCombinedCount Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RecordersCombinedCount Field
InteractionAttributeName Class See Also Send Feedback
The total number of recorders.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordersCombinedCount
Visual Basic
Public Shared ReadOnly RecordersCombinedCount As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RecordingsAutoResumeTime Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RecordingsAutoResumeTime Field
InteractionAttributeName Class See Also Send Feedback
The date and time at which the current Secure Recording Pause will expire and recordings will resume.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordingsAutoResumeTime
Visual Basic
Public Shared ReadOnly RecordingsAutoResumeTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RelatedSnippetRecordings Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RelatedSnippetRecordings Field
InteractionAttributeName Class See Also Send Feedback
The snippet recordings related to an interaction.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RelatedSnippetRecordings
Visual Basic
Public Shared ReadOnly RelatedSnippetRecordings As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RemoteAddress Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RemoteAddress Field
InteractionAttributeName Class See Also Send Feedback
The remote address.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RemoteAddress
Visual Basic
Public Shared ReadOnly RemoteAddress As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RemoteId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RemoteId Field
InteractionAttributeName Class See Also Send Feedback
The ID of the remote party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RemoteId
Visual Basic
Public Shared ReadOnly RemoteId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RemoteName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RemoteName Field
InteractionAttributeName Class See Also Send Feedback
The name of the remote party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RemoteName
Visual Basic
Public Shared ReadOnly RemoteName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RemotePartyType Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RemotePartyType Field
InteractionAttributeName Class See Also Send Feedback
The type of the remote party.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RemotePartyType
Visual Basic
Public Shared ReadOnly RemotePartyType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RemoteSecurityLevelRequested Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..RemoteSecurityLevelRequested Field
InteractionAttributeName Class See Also Send Feedback
The security level the remote endpoint has requested.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RemoteSecurityLevelRequested
Visual Basic
Public Shared ReadOnly RemoteSecurityLevelRequested As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


SecurityLevelActual Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..SecurityLevelActual Field
InteractionAttributeName Class See Also Send Feedback
The actual security level the interaction is using.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SecurityLevelActual
Visual Basic
Public Shared ReadOnly SecurityLevelActual As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


SecurityLevelViolation Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..SecurityLevelViolation Field
InteractionAttributeName Class See Also Send Feedback
Indicates the security level violation and the reason for the violation.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SecurityLevelViolation
Visual Basic
Public Shared ReadOnly SecurityLevelViolation As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


State Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..State Field
InteractionAttributeName Class See Also Send Feedback
The interaction state.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string State
Visual Basic
Public Shared ReadOnly State As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


StateDescription Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..StateDescription Field
InteractionAttributeName Class See Also Send Feedback
The interaction state description.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StateDescription
Visual Basic
Public Shared ReadOnly StateDescription As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


StationEmergencyCustomerLocationDescription Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..StationEmergencyCustomerLocationDescription Field
InteractionAttributeName Class See Also Send Feedback
The Station's emergency customer location description. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StationEmergencyCustomerLocationDescription
Visual Basic
Public Shared ReadOnly StationEmergencyCustomerLocationDescription As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


StationEmergencyCustomerName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..StationEmergencyCustomerName Field
InteractionAttributeName Class See Also Send Feedback
The Station's emergency customer name. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StationEmergencyCustomerName
Visual Basic
Public Shared ReadOnly StationEmergencyCustomerName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


StationEmergencyOutboundAni Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..StationEmergencyOutboundAni Field
InteractionAttributeName Class See Also Send Feedback
The Station's emergency outbound ANI. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StationEmergencyOutboundAni
Visual Basic
Public Shared ReadOnly StationEmergencyOutboundAni As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


StationLocationDescription Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..StationLocationDescription Field
InteractionAttributeName Class See Also Send Feedback
The Station location description. This attribute will only work with InteractionAttributeMonitor and will be set only for calls that have CallClassification set to any call classification with category 'Emergency'.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StationLocationDescription
Visual Basic
Public Shared ReadOnly StationLocationDescription As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


StationQueueNames Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..StationQueueNames Field
InteractionAttributeName Class See Also Send Feedback
The name(s) of the station queue(s).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StationQueueNames
Visual Basic
Public Shared ReadOnly StationQueueNames As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


SupervisorMonitors Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..SupervisorMonitors Field
InteractionAttributeName Class See Also Send Feedback
The supervisory monitors on the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SupervisorMonitors
Visual Basic
Public Shared ReadOnly SupervisorMonitors As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


SupervisorRecorders Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..SupervisorRecorders Field
InteractionAttributeName Class See Also Send Feedback
The supervisory recorders of the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SupervisorRecorders
Visual Basic
Public Shared ReadOnly SupervisorRecorders As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


UserQueueNames Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..UserQueueNames Field
InteractionAttributeName Class See Also Send Feedback
The unscoped names of the user queue(s).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string UserQueueNames
Visual Basic
Public Shared ReadOnly UserQueueNames As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


WorkgroupQueueDisplayName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..WorkgroupQueueDisplayName Field
InteractionAttributeName Class See Also Send Feedback
The display name of the workgroup queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkgroupQueueDisplayName
Visual Basic
Public Shared ReadOnly WorkgroupQueueDisplayName As String

Remarks

This can be assigned via handlers to be different than the actual workgroup name. The associated attribute to set from handlers is 'Eic_AssignedWorkgroup'.

This can allow client applications to display a more "friendly name" to the end user, by making the desired handler customization and using the WorkgroupQueueDisplayName attribute for display purposes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


WorkgroupQueueName Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..WorkgroupQueueName Field
InteractionAttributeName Class See Also Send Feedback
The unscoped name of the workgroup queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkgroupQueueName
Visual Basic
Public Shared ReadOnly WorkgroupQueueName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


WorkgroupQueueTimestamp Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..WorkgroupQueueTimestamp Field
InteractionAttributeName Class See Also Send Feedback
The time when the interaction was queued for a workgroup.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkgroupQueueTimestamp
Visual Basic
Public Shared ReadOnly WorkgroupQueueTimestamp As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


WrapUpAssignments Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..WrapUpAssignments Field
InteractionAttributeName Class See Also Send Feedback
A collection of wrap up code assignments associated with the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WrapUpAssignments
Visual Basic
Public Shared ReadOnly WrapUpAssignments As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


WrapUpCodeId Field

[image]

IceLib Technical Reference
InteractionAttributeName..::..WrapUpCodeId Field
InteractionAttributeName Class See Also Send Feedback
The ID of the wrap up code associated with the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("WrapUpCodeId has been deprecated. Please use WrapUpAssignments instead.",
    false)]
public static readonly string WrapUpCodeId
Visual Basic
<ObsoleteAttribute("WrapUpCodeId has been deprecated. Please use WrapUpAssignments instead.",  _
    False)> _
Public Shared ReadOnly WrapUpCodeId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributeName Class
InteractionAttributeName Members
ININ.IceLib.Interactions Namespace


InteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
InteractionAttributeName Methods
InteractionAttributeName Class See Also Send Feedback

The InteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionAttributeName Class
ININ.IceLib.Interactions Namespace


InteractionAttributesEventArgs Class

[image]

IceLib Technical Reference
InteractionAttributesEventArgs Class
Members See Also Send Feedback
Provides data for the InteractionAttributesChanged event of a InteractionQueue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAttributesEventArgs : EventArgs
Visual Basic
Public Class InteractionAttributesEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..InteractionAttributesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionAttributesEventArgs Members

[image] [image]

IceLib Technical Reference
InteractionAttributesEventArgs Members
InteractionAttributesEventArgs Class Constructors Methods Properties See Also Send Feedback

The InteractionAttributesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionAttributesEventArgs | Initializes a new instance of the InteractionAttributesEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the Interaction associated with the change.
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

InteractionAttributesEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionAttributesEventArgs Constructor

[image]

IceLib Technical Reference
InteractionAttributesEventArgs Constructor
InteractionAttributesEventArgs Class See Also Send Feedback
Initializes a new instance of the InteractionAttributesEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAttributesEventArgs(
    Interaction interaction,
    IList<string> interactionAttributeNames
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    interactionAttributeNames As IList(Of String) _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
interactionAttributeNames
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The interaction attribute names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributesEventArgs Class
InteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionAttributesEventArgs Methods

[image] [image]

IceLib Technical Reference
InteractionAttributesEventArgs Methods
InteractionAttributesEventArgs Class See Also Send Feedback

The InteractionAttributesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionAttributesEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionAttributesEventArgs Properties

[image] [image]

IceLib Technical Reference
InteractionAttributesEventArgs Properties
InteractionAttributesEventArgs Class See Also Send Feedback

The InteractionAttributesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the Interaction associated with the change.
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

InteractionAttributesEventArgs Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
InteractionAttributesEventArgs..::..Interaction Property
InteractionAttributesEventArgs Class See Also Send Feedback
Gets the Interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributesEventArgs Class
InteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionAttributeNames Property

[image]

IceLib Technical Reference
InteractionAttributesEventArgs..::..InteractionAttributeNames Property
InteractionAttributesEventArgs Class See Also Send Feedback
Gets the attribute names associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> InteractionAttributeNames { get; }
Visual Basic
Public ReadOnly Property InteractionAttributeNames As ReadOnlyCollection(Of String)
    Get

Field Value

The interaction attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAttributesEventArgs Class
InteractionAttributesEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionCallPartyType Enumeration

[image]

IceLib Technical Reference
InteractionCallPartyType Enumeration
See Also Send Feedback
Specifies constants indicating the party type of a call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionCallPartyType
Visual Basic
Public Enumeration InteractionCallPartyType

Members

Member name | Value | Description
Unknown | 0 | Indicates an unknown party type.
Internal | 1 | Indicates an internal party type.
External | 2 | Indicates an external party type.
System | 3 | Indicates a system party type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionCallType Enumeration

[image]

IceLib Technical Reference
InteractionCallType Enumeration
See Also Send Feedback
Specifies constants indicating the call type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionCallType
Visual Basic
Public Enumeration InteractionCallType

Members

Member name | Value | Description
Unknown | 0 | The call type is unknown. Possibly the caller is not an IC user.
Intercom | 1 | The call is an intercom call, which means that the caller is an internal IC participant.
External | 2 | The call is an external call. The caller is a non-IC participant.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionCapabilities Enumeration

[image]

IceLib Technical Reference
InteractionCapabilities Enumeration
See Also Send Feedback
Specifies constants indicating the capabilities of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum InteractionCapabilities
Visual Basic
<FlagsAttribute> _
Public Enumeration InteractionCapabilities

Members

Member name | Value | Description
None | 0 | The Interaction has no capabilities.
Consult | 1 | The Interaction can perform consults.
Disconnect | 2 | The Interaction can be disconnected.
Hold | 4 | The Interaction can be held.
Listen | 8 | The Interaction can perform listens.
Messaging | 16 | The Interaction can perform messaging. Starting with 2017 R2, when tranferring an Interaction to voicemail with a specific target (via TransferToVoicemail(String) or TransferToVoicemail(QueueId)), this capability has been replaced by TransferToVoicemail. For transferring an Interaction without a specific target (via Voicemail()()()()), this capability should continue to be used.
Mute | 32 | The Interaction can be muted.
Park | 64 | The Interaction can be parked.
Pause | 128 | The Interaction can pause recording.
Pickup | 256 | The Interaction can be picked up.
Private | 512 | The Interaction can be marked private.
Record | 1024 | The Interaction can be recorded.
RequestHelp | 2048 | The Interaction can have help requested.
Transfer | 4096 | The Interaction can be transferred.
Join | 8192 | The ConferenceInteraction can be joined.
ObjectWindow | 16384 | The Interaction can have an object window displayed.
Conference | 32768 | The Interaction can be conferenced.
Coach | 65536 | The Interaction can be coached.
Suspended | 131072 | The Interaction can be suspended.
SecureRecordingPause | 262144 | The Interaction can pause recording for security.
SecureInput | 524288 | The Interaction can initiate secure input.
RecordingSnip | 33554432 | The interaction can create a recording snippet.
TransferToVoicemail | 67108864 | The interaction can be transferred to voicemail by specifying a target (via TransferToVoicemail(String) or TransferToVoicemail(QueueId)). When checking to see if an Interaction can be transferred to a specific target's voicemail, starting with 2017 R2, this capability takes the place of the Messaging capability. For transferring an Interaction without a specific target (via Voicemail()()()()), the Messaging capability should continue to be used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionCompletedEventArgs Class

[image]

IceLib Technical Reference
InteractionCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class InteractionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..InteractionCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
InteractionCompletedEventArgs Members
InteractionCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The InteractionCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionCompletedEventArgs | Initializes a new instance of the InteractionCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Interaction | Gets the Interaction associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

InteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionCompletedEventArgs Constructor

[image]

IceLib Technical Reference
InteractionCompletedEventArgs Constructor
InteractionCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the InteractionCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCompletedEventArgs(
    Interaction interaction,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionCompletedEventArgs Class
InteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
InteractionCompletedEventArgs Methods
InteractionCompletedEventArgs Class See Also Send Feedback

The InteractionCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
InteractionCompletedEventArgs Properties
InteractionCompletedEventArgs Class See Also Send Feedback

The InteractionCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Interaction | Gets the Interaction associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

InteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
InteractionCompletedEventArgs..::..Interaction Property
InteractionCompletedEventArgs Class See Also Send Feedback
Gets the Interaction associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionCompletedEventArgs Class
InteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionConference Class

[image]

IceLib Technical Reference
InteractionConference Class
Members See Also Send Feedback
Represents a conference within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionConference
Visual Basic
Public Class InteractionConference

Remarks

An interaction conference occurs when multiple parties are participating in the same interaction. This class provides support for representing an interaction conference and for adding and listing parties in the interaction.

To add parties to an interaction, call AddParties(array<Interaction>[]()[][]) or AddPartiesAsync(array<Interaction>[]()[][], AsyncCompletedEventHandler, Object) providing an array of Interaction objects. When the asynchronous add parties operation completes, it invokes the completedCallback delegate.

To get the parties of a conference interaction, call GetParties()()()() or GetPartiesAsync(EventHandler<(Of <<'(GetContentsCompletedEventArgs>)>>), Object). When the asynchronous get parties operation completes, it invokes the completedCallback delegate returning the list of interactions in the GetContentsCompletedEventArgs object.

Note
The asynchronous version of the above methods is preferred since these operations can be lengthy.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionConference

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Members
ININ.IceLib.Interactions Namespace


InteractionConference Members

[image] [image]

IceLib Technical Reference
InteractionConference Members
InteractionConference Class Constructors Methods Properties See Also Send Feedback

The InteractionConference type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionConference | Initializes a new instance of the InteractionConference class.

Methods

 | Name | Description
Public method | AddParties | Adds parties to the InteractionConference.
Public method | AddPartiesAsync | Asynchronously adds parties to the InteractionConference.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties in the InteractionConference.
Public method | GetPartiesAsync | Asynchronously gets the parties in the InteractionConference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InviteParty | Invites a party to the InteractionConference.
Public method | InvitePartyAsync | Asynchronously invites a party to the InteractionConference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets the ID of the Conference.
Public property | ConferenceType | Gets the type of interactions being conferenced.
Public property | InteractionsManager | Gets the InteractionManager with which this Conference is associated.

See Also

InteractionConference Class
ININ.IceLib.Interactions Namespace


InteractionConference Constructor

[image]

IceLib Technical Reference
InteractionConference Constructor
InteractionConference Class See Also Send Feedback
Initializes a new instance of the InteractionConference class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionConference(
    InteractionsManager interactionsManager,
    InteractionType conferenceType,
    ConferenceId conferenceId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    conferenceType As InteractionType, _
    conferenceId As ConferenceId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
conferenceType
Type: ININ.IceLib.Interactions..::..InteractionType
Type of the conference.
conferenceId
Type: ININ.IceLib.Interactions..::..ConferenceId
The conference ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


InteractionConference Methods

[image] [image]

IceLib Technical Reference
InteractionConference Methods
InteractionConference Class See Also Send Feedback

The InteractionConference type exposes the following members.

Methods

 | Name | Description
Public method | AddParties | Adds parties to the InteractionConference.
Public method | AddPartiesAsync | Asynchronously adds parties to the InteractionConference.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParties | Gets the parties in the InteractionConference.
Public method | GetPartiesAsync | Asynchronously gets the parties in the InteractionConference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InviteParty | Invites a party to the InteractionConference.
Public method | InvitePartyAsync | Asynchronously invites a party to the InteractionConference.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionConference Class
ININ.IceLib.Interactions Namespace


AddParties Method

[image]

IceLib Technical Reference
InteractionConference..::..AddParties Method
InteractionConference Class See Also Send Feedback
Adds parties to the InteractionConference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddParties(
    Interaction[] interactions
)
Visual Basic
Public Sub AddParties ( _
    interactions As Interaction() _
)

Parameters

interactions
Type: array< ININ.IceLib.Interactions..::..Interaction >[]()[][]
The interactions.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


AddPartiesAsync Method

[image]

IceLib Technical Reference
InteractionConference..::..AddPartiesAsync Method
InteractionConference Class See Also Send Feedback
Asynchronously adds parties to the InteractionConference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddPartiesAsync(
    Interaction[] interactions,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AddPartiesAsync ( _
    interactions As Interaction(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactions
Type: array< ININ.IceLib.Interactions..::..Interaction >[]()[][]
The interactions.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


GetParties Method

[image]

IceLib Technical Reference
InteractionConference..::..GetParties Method
InteractionConference Class See Also Send Feedback
Gets the parties in the InteractionConference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Interaction> GetParties()
Visual Basic
Public Function GetParties As ReadOnlyCollection(Of Interaction)

Return Value

The Interaction array that was returned.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


GetPartiesAsync Method

[image]

IceLib Technical Reference
InteractionConference..::..GetPartiesAsync Method
InteractionConference Class See Also Send Feedback
Asynchronously gets the parties in the InteractionConference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetPartiesAsync(
    EventHandler<GetContentsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetPartiesAsync ( _
    completedCallback As EventHandler(Of GetContentsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetContentsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


InviteParty Method

[image]

IceLib Technical Reference
InteractionConference..::..InviteParty Method
InteractionConference Class See Also Send Feedback
Invites a party to the InteractionConference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction InviteParty(
    InvitePartyParameters inviteParameters
)
Visual Basic
Public Function InviteParty ( _
    inviteParameters As InvitePartyParameters _
) As Interaction

Parameters

inviteParameters
Type: ININ.IceLib.Interactions..::..InvitePartyParameters
The invite parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
System..::..NotSupportedException | inviteParameters is Started.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..InviteParty(InteractionId, InvitePartyParameters)


InvitePartyAsync Method

[image]

IceLib Technical Reference
InteractionConference..::..InvitePartyAsync Method
InteractionConference Class See Also Send Feedback
Asynchronously invites a party to the InteractionConference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InvitePartyAsync(
    InvitePartyParameters inviteParameters,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub InvitePartyAsync ( _
    inviteParameters As InvitePartyParameters, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

inviteParameters
Type: ININ.IceLib.Interactions..::..InvitePartyParameters
The invite parameters.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
System..::..NotSupportedException | inviteParameters is Started.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..InvitePartyAsync(InteractionId, InvitePartyParameters, EventHandler<(Of <<'(InvitePartyCompletedEventArgs>)>>), Object)


InteractionConference Properties

[image] [image]

IceLib Technical Reference
InteractionConference Properties
InteractionConference Class See Also Send Feedback

The InteractionConference type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets the ID of the Conference.
Public property | ConferenceType | Gets the type of interactions being conferenced.
Public property | InteractionsManager | Gets the InteractionManager with which this Conference is associated.

See Also

InteractionConference Class
ININ.IceLib.Interactions Namespace


ConferenceId Property

[image]

IceLib Technical Reference
InteractionConference..::..ConferenceId Property
InteractionConference Class See Also Send Feedback
Gets the ID of the Conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId ConferenceId { get; }
Visual Basic
Public ReadOnly Property ConferenceId As ConferenceId
    Get

Field Value

The conference ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


ConferenceType Property

[image]

IceLib Technical Reference
InteractionConference..::..ConferenceType Property
InteractionConference Class See Also Send Feedback
Gets the type of interactions being conferenced.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionType ConferenceType { get; }
Visual Basic
Public ReadOnly Property ConferenceType As InteractionType
    Get

Field Value

The type of the conference.

Remarks

This is the same as the InteractionType property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
InteractionConference..::..InteractionsManager Property
InteractionConference Class See Also Send Feedback
Gets the InteractionManager with which this Conference is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionConference Class
InteractionConference Members
ININ.IceLib.Interactions Namespace


InteractionDirection Enumeration

[image]

IceLib Technical Reference
InteractionDirection Enumeration
See Also Send Feedback
Specifies constants indicating the direction of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionDirection
Visual Basic
Public Enumeration InteractionDirection

Members

Member name | Value | Description
None | 0 | The Interaction has an indeterminate direction.
Incoming | 1 | The Interaction is incoming.
Outgoing | 2 | The Interaction is outgoing.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionEventArgs Class

[image]

IceLib Technical Reference
InteractionEventArgs Class
Members See Also Send Feedback
Provides data for events involving a single Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionEventArgs : EventArgs
Visual Basic
Public Class InteractionEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..InteractionEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionEventArgs Members

[image] [image]

IceLib Technical Reference
InteractionEventArgs Members
InteractionEventArgs Class Constructors Methods Properties See Also Send Feedback

The InteractionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionEventArgs | Initializes a new instance of the InteractionEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the Interaction associated with the change.

See Also

InteractionEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionEventArgs Constructor

[image]

IceLib Technical Reference
InteractionEventArgs Constructor
InteractionEventArgs Class See Also Send Feedback
Initializes a new instance of the InteractionEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionEventArgs(
    Interaction interaction
)
Visual Basic
Public Sub New ( _
    interaction As Interaction _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionEventArgs Class
InteractionEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionEventArgs Methods

[image] [image]

IceLib Technical Reference
InteractionEventArgs Methods
InteractionEventArgs Class See Also Send Feedback

The InteractionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionEventArgs Properties

[image] [image]

IceLib Technical Reference
InteractionEventArgs Properties
InteractionEventArgs Class See Also Send Feedback

The InteractionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the Interaction associated with the change.

See Also

InteractionEventArgs Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
InteractionEventArgs..::..Interaction Property
InteractionEventArgs Class See Also Send Feedback
Gets the Interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionEventArgs Class
InteractionEventArgs Members
ININ.IceLib.Interactions Namespace


InteractionId Class

[image]

IceLib Technical Reference
InteractionId Class
Members See Also Send Feedback
Identifies an Interaction within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class InteractionId : IComparable,
    IComparable<InteractionId>
Visual Basic
<SerializableAttribute> _
Public Class InteractionId _
    Implements IComparable, IComparable(Of InteractionId)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Members
ININ.IceLib.Interactions Namespace


InteractionId Members

[image] [image]

IceLib Technical Reference
InteractionId Members
InteractionId Class Constructors Methods Operators Properties See Also Send Feedback

The InteractionId type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionId(Int64) | Initializes a new instance of the InteractionId class with the specified values.
Public method | InteractionId(String) | Initializes a new instance of the InteractionId class with the specified values.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(InteractionId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(InteractionId) | Determines whether the specified InteractionId is equal to the current InteractionId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of InteractionId are equal.
Inequality | Determines whether two instances of InteractionId are not equal.

Properties

 | Name | Description
Public property | Id | Gets a numeric representation of the Interaction ID.
Public property | RawId | Gets a numeric (non-CLS-compliant) representation of the Interaction ID.

See Also

InteractionId Class
ININ.IceLib.Interactions Namespace


InteractionId Constructor

[image] [image]

IceLib Technical Reference
InteractionId Constructor
InteractionId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InteractionId(Int64) | Initializes a new instance of the InteractionId class with the specified values.
Public method | InteractionId(String) | Initializes a new instance of the InteractionId class with the specified values.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


InteractionId Constructor (Int64)

[image]

IceLib Technical Reference
InteractionId Constructor (Int64)
InteractionId Class See Also Send Feedback
Initializes a new instance of the InteractionId class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId(
    long id
)
Visual Basic
Public Sub New ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | id was invalid, it must be in the range of 0 and MaxValue inclusive.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
InteractionId Overload
ININ.IceLib.Interactions Namespace


InteractionId Constructor (String)

[image]

IceLib Technical Reference
InteractionId Constructor (String)
InteractionId Class See Also Send Feedback
Initializes a new instance of the InteractionId class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
InteractionId Overload
ININ.IceLib.Interactions Namespace


InteractionId Methods

[image] [image]

IceLib Technical Reference
InteractionId Methods
InteractionId Class See Also Send Feedback

The InteractionId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(InteractionId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(InteractionId) | Determines whether the specified InteractionId is equal to the current InteractionId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionId Class
ININ.IceLib.Interactions Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
InteractionId..::..CompareTo Method
InteractionId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(InteractionId) | Compares the current object with another object of the same type.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


CompareTo Method (Object)

[image]

IceLib Technical Reference
InteractionId..::..CompareTo Method (Object)
InteractionId Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


CompareTo Method (InteractionId)

[image]

IceLib Technical Reference
InteractionId..::..CompareTo Method (InteractionId)
InteractionId Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    InteractionId other
)
Visual Basic
Public Function CompareTo ( _
    other As InteractionId _
) As Integer

Parameters

other
Type: ININ.IceLib.Interactions..::..InteractionId
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


Equals Method

[image] [image]

IceLib Technical Reference
InteractionId..::..Equals Method
InteractionId Class See Also Send Feedback
Determines whether two InteractionId instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(InteractionId) | Determines whether the specified InteractionId is equal to the current InteractionId.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
InteractionId..::..Equals Method (Object)
InteractionId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
Equals Overload
ININ.IceLib.Interactions Namespace


Equals Method (InteractionId)

[image]

IceLib Technical Reference
InteractionId..::..Equals Method (InteractionId)
InteractionId Class See Also Send Feedback
Determines whether the specified InteractionId is equal to the current InteractionId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    InteractionId other
)
Visual Basic
Public Function Equals ( _
    other As InteractionId _
) As Boolean

Parameters

other
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId to compare with the current InteractionId.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified InteractionId is equal to the current InteractionId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
Equals Overload
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
InteractionId..::..GetHashCode Method
InteractionId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionId..::..ToString Method
InteractionId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


InteractionId Operators

[image] [image]

IceLib Technical Reference
InteractionId Operators
InteractionId Class See Also Send Feedback

The InteractionId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of InteractionId are equal.
Inequality | Determines whether two instances of InteractionId are not equal.

See Also

InteractionId Class
ININ.IceLib.Interactions Namespace


Equality Operator

[image]

IceLib Technical Reference
InteractionId..::..Equality Operator
InteractionId Class See Also Send Feedback
Determines whether two instances of InteractionId are equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    InteractionId a,
    InteractionId b
)
Visual Basic
Public Shared Operator = ( _
    a As InteractionId, _
    b As InteractionId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..InteractionId
The first InteractionId to compare.
b
Type: ININ.IceLib.Interactions..::..InteractionId
The second InteractionId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


Inequality Operator

[image]

IceLib Technical Reference
InteractionId..::..Inequality Operator
InteractionId Class See Also Send Feedback
Determines whether two instances of InteractionId are not equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    InteractionId a,
    InteractionId b
)
Visual Basic
Public Shared Operator <> ( _
    a As InteractionId, _
    b As InteractionId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..InteractionId
The first InteractionId to compare.
b
Type: ININ.IceLib.Interactions..::..InteractionId
The second InteractionId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


InteractionId Properties

[image] [image]

IceLib Technical Reference
InteractionId Properties
InteractionId Class See Also Send Feedback

The InteractionId type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets a numeric representation of the Interaction ID.
Public property | RawId | Gets a numeric (non-CLS-compliant) representation of the Interaction ID.

See Also

InteractionId Class
ININ.IceLib.Interactions Namespace


Id Property

[image]

IceLib Technical Reference
InteractionId..::..Id Property
InteractionId Class See Also Send Feedback
Gets a numeric representation of the Interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long Id { get; }
Visual Basic
Public ReadOnly Property Id As Long
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


RawId Property

[image]

IceLib Technical Reference
InteractionId..::..RawId Property
InteractionId Class See Also Send Feedback
Gets a numeric (non-CLS-compliant) representation of the Interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[CLSCompliantAttribute(false)]
public uint RawId { get; }
Visual Basic
<CLSCompliantAttribute(False)> _
Public ReadOnly Property RawId As UInteger
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionId Class
InteractionId Members
ININ.IceLib.Interactions Namespace


InteractionMonitor Class

[image]

IceLib Technical Reference
InteractionMonitor Class
Members See Also Send Feedback
Represents a monitoring on an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionMonitor
Visual Basic
Public Class InteractionMonitor

Remarks

Interactions sent to an agent, station, workgroup queue, or line queue, can be monitored. You must have security rights to view any queues other than your own.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionMonitor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionMonitor Members
ININ.IceLib.Interactions Namespace


InteractionMonitor Members

[image] [image]

IceLib Technical Reference
InteractionMonitor Members
InteractionMonitor Class Methods Properties See Also Send Feedback

The InteractionMonitor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | MonitorType | Gets the type of the monitor.
Public property | User | Gets the user.

See Also

InteractionMonitor Class
ININ.IceLib.Interactions Namespace


InteractionMonitor Methods

[image] [image]

IceLib Technical Reference
InteractionMonitor Methods
InteractionMonitor Class See Also Send Feedback

The InteractionMonitor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionMonitor Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionMonitor..::..ToString Method
InteractionMonitor Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionMonitor Class
InteractionMonitor Members
ININ.IceLib.Interactions Namespace


InteractionMonitor Properties

[image] [image]

IceLib Technical Reference
InteractionMonitor Properties
InteractionMonitor Class See Also Send Feedback

The InteractionMonitor type exposes the following members.

Properties

 | Name | Description
Public property | MonitorType | Gets the type of the monitor.
Public property | User | Gets the user.

See Also

InteractionMonitor Class
ININ.IceLib.Interactions Namespace


MonitorType Property

[image]

IceLib Technical Reference
InteractionMonitor..::..MonitorType Property
InteractionMonitor Class See Also Send Feedback
Gets the type of the monitor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionMonitorType MonitorType { get; }
Visual Basic
Public ReadOnly Property MonitorType As InteractionMonitorType
    Get

Field Value

The type of the monitor.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionMonitor Class
InteractionMonitor Members
ININ.IceLib.Interactions Namespace


User Property

[image]

IceLib Technical Reference
InteractionMonitor..::..User Property
InteractionMonitor Class See Also Send Feedback
Gets the user.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string User { get; }
Visual Basic
Public ReadOnly Property User As String
    Get

Field Value

The user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionMonitor Class
InteractionMonitor Members
ININ.IceLib.Interactions Namespace


InteractionMonitorType Enumeration

[image]

IceLib Technical Reference
InteractionMonitorType Enumeration
See Also Send Feedback
Specifies constants indicating the type of an Interaction monitor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionMonitorType
Visual Basic
Public Enumeration InteractionMonitorType

Members

Member name | Value | Description
None | 0 | The Interaction is not being monitored.
Coach | 1 | The Interaction monitor is a coach. Coaching is typically performed by supervisors who provide advice to an agent without the customer knowing that anyone is assisting on the interaction. The agent can hear the coach, but the customer cannot.
Monitor | 2 | The Interaction monitor is a normal monitor, meaning that the queue object is being listened to or examined by someone who is not coaching or interacting with the agent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionPartyType Enumeration

[image]

IceLib Technical Reference
InteractionPartyType Enumeration
See Also Send Feedback
Represents local party type and remote party type of an interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionPartyType
Visual Basic
Public Enumeration InteractionPartyType

Members

Member name | Value | Description
Internal | 1 | Party type is internal.
External | 2 | Party type is external.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionQueue Class

[image]

IceLib Technical Reference
InteractionQueue Class
Members See Also Send Feedback
Represents a queue of Interactions within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionQueue
Visual Basic
Public Class InteractionQueue

Remarks

This class provides support for setting up watches and retrieving the contents of an interaction queue.

To start a watch on an interaction queue, call StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) and provide and array of attributes. When the asynchronous start watch operation completes, it invokes the completedCallback delegate.

To stop a watch on an interaction queue, call StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object). When the asynchronous stop watch operation completes, it invokes the completedCallback delegate.

To change the attributes watched, call ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object). When the asynchronous change watch operation completes, it invokes the completedCallback delegate.

To retrieve the contents of an interaction queue, call GetContents()()()() or GetContentsAsync(EventHandler<(Of <<'(GetContentsCompletedEventArgs>)>>), Object). When the asynchronous get contents operation completes, it invokes the completedCallback delegate and returns the InteractionCompletedEventArgs object containing the contents of the interaction queue. The queue contents is represented by a collection of Interaction objects.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) when a watch is in place or StopWatching()()()(), StopWatchingAsync(AsyncCompletedEventHandler, Object), ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean), or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) when a watch is not in place raises an InvalidOperationException.

Note
The asynchronous version of the above methods is preferred since these operations can be lengthy.
Note
For more information on getting started with queues and interactions see Getting Started With Interactions.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionQueue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Members
ININ.IceLib.Interactions Namespace


InteractionQueue Members

[image] [image]

IceLib Technical Reference
InteractionQueue Members
InteractionQueue Class Constructors Methods Properties Events See Also Send Feedback

The InteractionQueue type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionQueue | Initializes a new instance of the InteractionQueue class.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the InteractionQueue are being watched. (See InteractionAttributeName.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the InteractionQueue are being watched. (See InteractionAttributeName.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConferenceContents()()()() | Gets the conference members of all the conferences currently in cache.
Public method | GetConferenceContents(ConferenceId) | Gets the conference members of specified conference currently in cache.
Public method | GetContents | Gets the contents.
Public method | GetContentsAsync | Asynchronously gets the contents.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified attributeNames for this InteractionQueue. (See InteractionAttributeName.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this InteractionQueue. (See InteractionAttributeName.)
Public method | StopWatching | Stops watching the InteractionQueue.
Public method | StopWatchingAsync | Asynchronously stops watching the InteractionQueue.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager with which this Queue is associated.
Public property | IsSuspended | Gets a value indicating whether or not notifications on this InteractionQueue have been temporarily suspended by the Interaction Center Server.
Public property | QueueId | Gets the ID of the Queue.
Public property | SuspendedAdditionalInformation | Gets any additional information, if available, when notifications on this InteractionQueue have been temporarily suspended.

Events

 | Name | Description
Public event | ConferenceInteractionAdded | Occurs when a conference Interaction is added to the Queue.
Public event | ConferenceInteractionChanged | Occurs when a conference Interaction on the Queue changes.
Public event | ConferenceInteractionRemoved | Occurs when a conference Interaction is removed from the Queue.
Public event | InteractionAdded | Occurs when an Interaction is added to the Queue.
Public event | InteractionChanged | Occurs when an Interaction on the Queue changes.
Public event | InteractionRemoved | Occurs when an Interaction is removed from the Queue.
Public event | LostRights | Occurs when the User loses rights for the Queue.
Public event | NotificationsSuspendedChanged | Occurs when notifications on this InteractionQueue have been temporarily suspended by the Interaction Center Server.
Public event | QueueContentsChanged | Occurs when an Interaction or Conference Interaction is added, updated, or removed.

See Also

InteractionQueue Class
ININ.IceLib.Interactions Namespace


InteractionQueue Constructor

[image]

IceLib Technical Reference
InteractionQueue Constructor
InteractionQueue Class See Also Send Feedback
Initializes a new instance of the InteractionQueue class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionQueue(
    InteractionsManager interactionsManager,
    QueueId queueId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    queueId As QueueId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
queueId
Type: ININ.IceLib.Interactions..::..QueueId
The queue ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


InteractionQueue Methods

[image] [image]

IceLib Technical Reference
InteractionQueue Methods
InteractionQueue Class See Also Send Feedback

The InteractionQueue type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the InteractionQueue are being watched. (See InteractionAttributeName.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the InteractionQueue are being watched. (See InteractionAttributeName.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConferenceContents()()()() | Gets the conference members of all the conferences currently in cache.
Public method | GetConferenceContents(ConferenceId) | Gets the conference members of specified conference currently in cache.
Public method | GetContents | Gets the contents.
Public method | GetContentsAsync | Asynchronously gets the contents.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified attributeNames for this InteractionQueue. (See InteractionAttributeName.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this InteractionQueue. (See InteractionAttributeName.)
Public method | StopWatching | Stops watching the InteractionQueue.
Public method | StopWatchingAsync | Asynchronously stops watching the InteractionQueue.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionQueue Class
ININ.IceLib.Interactions Namespace


ChangeWatchedAttributes Method

[image]

IceLib Technical Reference
InteractionQueue..::..ChangeWatchedAttributes Method
InteractionQueue Class See Also Send Feedback
Changes what attributes of the InteractionQueue are being watched. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributes(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedAttributes ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


ChangeWatchedAttributesAsync Method

[image]

IceLib Technical Reference
InteractionQueue..::..ChangeWatchedAttributesAsync Method
InteractionQueue Class See Also Send Feedback
Asynchronously changes what attributes of the InteractionQueue are being watched. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributesAsync(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAttributesAsync ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


GetConferenceContents Method

[image] [image]

IceLib Technical Reference
InteractionQueue..::..GetConferenceContents Method
InteractionQueue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetConferenceContents()()()() | Gets the conference members of all the conferences currently in cache.
Public method | GetConferenceContents(ConferenceId) | Gets the conference members of specified conference currently in cache.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


GetConferenceContents Method

[image]

IceLib Technical Reference
InteractionQueue..::..GetConferenceContents Method
InteractionQueue Class See Also Send Feedback
Gets the conference members of all the conferences currently in cache.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ConferenceItemData> GetConferenceContents()
Visual Basic
Public Function GetConferenceContents As ReadOnlyCollection(Of ConferenceItemData)

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ConferenceItemData objects.

Remarks

Calling GetConferenceContents does not request information from the IC Server, and requires an active watch on the object to return results.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
GetConferenceContents Overload
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..InteractionQueue


GetConferenceContents Method (ConferenceId)

[image]

IceLib Technical Reference
InteractionQueue..::..GetConferenceContents Method (ConferenceId)
InteractionQueue Class See Also Send Feedback
Gets the conference members of specified conference currently in cache.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ConferenceItemData> GetConferenceContents(
    ConferenceId conferenceId
)
Visual Basic
Public Function GetConferenceContents ( _
    conferenceId As ConferenceId _
) As ReadOnlyCollection(Of ConferenceItemData)

Parameters

conferenceId
Type: ININ.IceLib.Interactions..::..ConferenceId
The conference ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ConferenceItemData objects.

Remarks

Calling GetConferenceContents does not request information from the IC Server, and requires an active watch on the object to return results.

Exceptions

Exception | Condition
System..::..ArgumentNullException | conferenceId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
GetConferenceContents Overload
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..InteractionQueue


GetContents Method

[image]

IceLib Technical Reference
InteractionQueue..::..GetContents Method
InteractionQueue Class See Also Send Feedback
Gets the contents.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Interaction> GetContents()
Visual Basic
Public Function GetContents As ReadOnlyCollection(Of Interaction)

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of Interaction objects.

Remarks

Calling GetContents without an active InteractionQueue watch will retrieve the queue contents from the IC Server, but will not keep them up to date. This means that the collection of Interaction objects returned from this call will eventually become stale. Making subsequent GetContents calls will not refresh the collection. If the desired behavior is to have an up-to-date Interaction collection, a watch must first be started on an InteractionQueue object, being sure to have all event handlers set before starting the watch.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


GetContentsAsync Method

[image]

IceLib Technical Reference
InteractionQueue..::..GetContentsAsync Method
InteractionQueue Class See Also Send Feedback
Asynchronously gets the contents.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetContentsAsync(
    EventHandler<GetContentsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetContentsAsync ( _
    completedCallback As EventHandler(Of GetContentsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetContentsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Calling GetContentsAsync without an active InteractionQueue watch will retrieve the queue contents from the IC Server, but will not keep them up to date. This means that the collection of Interaction objects returned from this call will eventually become stale. Making subsequent GetContents calls will not refresh the collection. If the desired behavior is to have an up-to-date Interaction collection, a watch must first be started on an InteractionQueue object, being sure to have all event handlers set before starting the watch.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
InteractionQueue..::..IsWatching Method
InteractionQueue Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
InteractionQueue..::..IsWatching Method
InteractionQueue Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
IsWatching Overload
ININ.IceLib.Interactions Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
InteractionQueue..::..IsWatching Method (String)
InteractionQueue Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string attributeName
)
Visual Basic
Public Function IsWatching ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
IsWatching Overload
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
InteractionQueue..::..StartWatching Method
InteractionQueue Class See Also Send Feedback
Starts watching the specified attributeNames for this InteractionQueue. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] attributeNames
)
Visual Basic
Public Sub StartWatching ( _
    attributeNames As String() _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.
Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
InteractionQueue..::..StartWatchingAsync Method
InteractionQueue Class See Also Send Feedback
Asynchronously starts watching the specified attributeNames for this InteractionQueue. (See InteractionAttributeName.)

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] attributeNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    attributeNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For information about the standard attributes defined by the Interaction Center System, see the "Interaction Attributes Technical Reference" in the Interaction Center Documentation Library. This document describes the attributes and the format of their values.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in InteractionAttributeName however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
InteractionQueue..::..StopWatching Method
InteractionQueue Class See Also Send Feedback
Stops watching the InteractionQueue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
InteractionQueue..::..StopWatchingAsync Method
InteractionQueue Class See Also Send Feedback
Asynchronously stops watching the InteractionQueue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionQueue..::..ToString Method
InteractionQueue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


InteractionQueue Properties

[image] [image]

IceLib Technical Reference
InteractionQueue Properties
InteractionQueue Class See Also Send Feedback

The InteractionQueue type exposes the following members.

Properties

 | Name | Description
Public property | InteractionsManager | Gets the InteractionManager with which this Queue is associated.
Public property | IsSuspended | Gets a value indicating whether or not notifications on this InteractionQueue have been temporarily suspended by the Interaction Center Server.
Public property | QueueId | Gets the ID of the Queue.
Public property | SuspendedAdditionalInformation | Gets any additional information, if available, when notifications on this InteractionQueue have been temporarily suspended.

See Also

InteractionQueue Class
ININ.IceLib.Interactions Namespace


InteractionsManager Property

[image]

IceLib Technical Reference
InteractionQueue..::..InteractionsManager Property
InteractionQueue Class See Also Send Feedback
Gets the InteractionManager with which this Queue is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsManager InteractionsManager { get; }
Visual Basic
Public ReadOnly Property InteractionsManager As InteractionsManager
    Get

Field Value

The interactions manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


IsSuspended Property

[image]

IceLib Technical Reference
InteractionQueue..::..IsSuspended Property
InteractionQueue Class See Also Send Feedback
Gets a value indicating whether or not notifications on this InteractionQueue have been temporarily suspended by the Interaction Center Server.

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsSuspended { get; }
Visual Basic
Public ReadOnly Property IsSuspended As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if notifications have been temporarily suspended by the Interaction Center Server; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..NotificationsSuspendedChanged
InteractionQueue..::..SuspendedAdditionalInformation


QueueId Property

[image]

IceLib Technical Reference
InteractionQueue..::..QueueId Property
InteractionQueue Class See Also Send Feedback
Gets the ID of the Queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueId QueueId { get; }
Visual Basic
Public ReadOnly Property QueueId As QueueId
    Get

Field Value

The queue ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


SuspendedAdditionalInformation Property

[image]

IceLib Technical Reference
InteractionQueue..::..SuspendedAdditionalInformation Property
InteractionQueue Class See Also Send Feedback
Gets any additional information, if available, when notifications on this InteractionQueue have been temporarily suspended.

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SuspendedAdditionalInformation { get; }
Visual Basic
Public ReadOnly Property SuspendedAdditionalInformation As String
    Get

Field Value

The additional information, if available, when notifications on this InteractionQueue have been temporarily suspended.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..NotificationsSuspendedChanged
InteractionQueue..::..IsSuspended


InteractionQueue Events

[image] [image]

IceLib Technical Reference
InteractionQueue Events
InteractionQueue Class See Also Send Feedback

The InteractionQueue type exposes the following members.

Events

 | Name | Description
Public event | ConferenceInteractionAdded | Occurs when a conference Interaction is added to the Queue.
Public event | ConferenceInteractionChanged | Occurs when a conference Interaction on the Queue changes.
Public event | ConferenceInteractionRemoved | Occurs when a conference Interaction is removed from the Queue.
Public event | InteractionAdded | Occurs when an Interaction is added to the Queue.
Public event | InteractionChanged | Occurs when an Interaction on the Queue changes.
Public event | InteractionRemoved | Occurs when an Interaction is removed from the Queue.
Public event | LostRights | Occurs when the User loses rights for the Queue.
Public event | NotificationsSuspendedChanged | Occurs when notifications on this InteractionQueue have been temporarily suspended by the Interaction Center Server.
Public event | QueueContentsChanged | Occurs when an Interaction or Conference Interaction is added, updated, or removed.

See Also

InteractionQueue Class
ININ.IceLib.Interactions Namespace


ConferenceInteractionAdded Event

[image]

IceLib Technical Reference
InteractionQueue..::..ConferenceInteractionAdded Event
InteractionQueue Class See Also Send Feedback
Occurs when a conference Interaction is added to the Queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConferenceInteractionAttributesEventArgs> ConferenceInteractionAdded
Visual Basic
Public Event ConferenceInteractionAdded As EventHandler(Of ConferenceInteractionAttributesEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..QueueContentsChanged


ConferenceInteractionChanged Event

[image]

IceLib Technical Reference
InteractionQueue..::..ConferenceInteractionChanged Event
InteractionQueue Class See Also Send Feedback
Occurs when a conference Interaction on the Queue changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConferenceInteractionAttributesEventArgs> ConferenceInteractionChanged
Visual Basic
Public Event ConferenceInteractionChanged As EventHandler(Of ConferenceInteractionAttributesEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur when attributes being watched have changed. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..QueueContentsChanged


ConferenceInteractionRemoved Event

[image]

IceLib Technical Reference
InteractionQueue..::..ConferenceInteractionRemoved Event
InteractionQueue Class See Also Send Feedback
Occurs when a conference Interaction is removed from the Queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ConferenceInteractionEventArgs> ConferenceInteractionRemoved
Visual Basic
Public Event ConferenceInteractionRemoved As EventHandler(Of ConferenceInteractionEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..QueueContentsChanged


InteractionAdded Event

[image]

IceLib Technical Reference
InteractionQueue..::..InteractionAdded Event
InteractionQueue Class See Also Send Feedback
Occurs when an Interaction is added to the Queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionAttributesEventArgs> InteractionAdded
Visual Basic
Public Event InteractionAdded As EventHandler(Of InteractionAttributesEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..QueueContentsChanged


InteractionChanged Event

[image]

IceLib Technical Reference
InteractionQueue..::..InteractionChanged Event
InteractionQueue Class See Also Send Feedback
Occurs when an Interaction on the Queue changes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionAttributesEventArgs> InteractionChanged
Visual Basic
Public Event InteractionChanged As EventHandler(Of InteractionAttributesEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur when attributes being watched have changed. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..QueueContentsChanged


InteractionRemoved Event

[image]

IceLib Technical Reference
InteractionQueue..::..InteractionRemoved Event
InteractionQueue Class See Also Send Feedback
Occurs when an Interaction is removed from the Queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionEventArgs> InteractionRemoved
Visual Basic
Public Event InteractionRemoved As EventHandler(Of InteractionEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..QueueContentsChanged


LostRights Event

[image]

IceLib Technical Reference
InteractionQueue..::..LostRights Event
InteractionQueue Class See Also Send Feedback
Occurs when the User loses rights for the Queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler LostRights
Visual Basic
Public Event LostRights As EventHandler

Remarks

This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace


NotificationsSuspendedChanged Event

[image]

IceLib Technical Reference
InteractionQueue..::..NotificationsSuspendedChanged Event
InteractionQueue Class See Also Send Feedback
Occurs when notifications on this InteractionQueue have been temporarily suspended by the Interaction Center Server.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<NotificationsSuspendedEventArgs> NotificationsSuspendedChanged
Visual Basic
Public Event NotificationsSuspendedChanged As EventHandler(Of NotificationsSuspendedEventArgs)

Remarks

This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).

If the IsSuspended property is set to trueTruetruetrue (True in Visual Basic), then all notifications will be suspended for this InteractionQueue (with exception to additional NotificationsSuspendedChanged notifications). A QueueContentsChanged notification, or the appropriate InteractionRemoved notifications will also be fired to notify of the removal of the current interactions. It is not necessary to stop the watch on the queue at this time.

If the IsSuspended property is set to falseFalsefalsefalse (False in Visual Basic), then all notifications will be resumed for this InteractionQueue. A QueueContentsChanged notification, or the appropriate InteractionAdded notifications will also be fired to notify of the current contents of the queue.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..IsSuspended
InteractionQueue..::..SuspendedAdditionalInformation


QueueContentsChanged Event

[image]

IceLib Technical Reference
InteractionQueue..::..QueueContentsChanged Event
InteractionQueue Class See Also Send Feedback
Occurs when an Interaction or Conference Interaction is added, updated, or removed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<QueueContentsChangedEventArgs> QueueContentsChanged
Visual Basic
Public Event QueueContentsChanged As EventHandler(Of QueueContentsChangedEventArgs)

Remarks

Note
If an event handler is added for the QueueContentsChanged event, then the following events will not be raised, even if they have an event handler: InteractionAdded, InteractionChanged, InteractionRemoved, ConferenceInteractionAdded, ConferenceInteractionChanged, ConferenceInteractionRemoved.
This event will only occur if the InteractionQueue is being watched. To start watching the queue call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionQueue Class
InteractionQueue Members
ININ.IceLib.Interactions Namespace
InteractionQueue..::..InteractionAdded
InteractionQueue..::..InteractionChanged
InteractionQueue..::..InteractionRemoved
InteractionQueue..::..ConferenceInteractionAdded
InteractionQueue..::..ConferenceInteractionChanged
InteractionQueue..::..ConferenceInteractionRemoved


InteractionRecord Class

[image]

IceLib Technical Reference
InteractionRecord Class
Members See Also Send Feedback
Represents a recording of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionRecord
Visual Basic
Public Class InteractionRecord

Remarks

Objects of this class are used in a list of recorders for a given interaction.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionRecord

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionRecord Members
ININ.IceLib.Interactions Namespace


InteractionRecord Members

[image] [image]

IceLib Technical Reference
InteractionRecord Members
InteractionRecord Class Methods Properties See Also Send Feedback

The InteractionRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Intercom | Gets a value indicating whether this InteractionRecord is an Intercom record.
Public property | Paused | Gets a value indicating whether this InteractionRecord is paused.
Public property | User | Gets the user.

See Also

InteractionRecord Class
ININ.IceLib.Interactions Namespace


InteractionRecord Methods

[image] [image]

IceLib Technical Reference
InteractionRecord Methods
InteractionRecord Class See Also Send Feedback

The InteractionRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

InteractionRecord Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InteractionRecord..::..ToString Method
InteractionRecord Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionRecord Class
InteractionRecord Members
ININ.IceLib.Interactions Namespace


InteractionRecord Properties

[image] [image]

IceLib Technical Reference
InteractionRecord Properties
InteractionRecord Class See Also Send Feedback

The InteractionRecord type exposes the following members.

Properties

 | Name | Description
Public property | Intercom | Gets a value indicating whether this InteractionRecord is an Intercom record.
Public property | Paused | Gets a value indicating whether this InteractionRecord is paused.
Public property | User | Gets the user.

See Also

InteractionRecord Class
ININ.IceLib.Interactions Namespace


Intercom Property

[image]

IceLib Technical Reference
InteractionRecord..::..Intercom Property
InteractionRecord Class See Also Send Feedback
Gets a value indicating whether this InteractionRecord is an Intercom record.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Intercom { get; }
Visual Basic
Public ReadOnly Property Intercom As Boolean
    Get

Field Value

The property is trueTruetruetrue (True in Visual Basic) if the InteractionRecord is an Intercom record; otherwise, it is falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionRecord Class
InteractionRecord Members
ININ.IceLib.Interactions Namespace


Paused Property

[image]

IceLib Technical Reference
InteractionRecord..::..Paused Property
InteractionRecord Class See Also Send Feedback
Gets a value indicating whether this InteractionRecord is paused.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Paused { get; }
Visual Basic
Public ReadOnly Property Paused As Boolean
    Get

Field Value

The property is trueTruetruetrue (True in Visual Basic) if the InteractionRecord is paused; otherwise, it is falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionRecord Class
InteractionRecord Members
ININ.IceLib.Interactions Namespace


User Property

[image]

IceLib Technical Reference
InteractionRecord..::..User Property
InteractionRecord Class See Also Send Feedback
Gets the user.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string User { get; }
Visual Basic
Public ReadOnly Property User As String
    Get

Field Value

The user name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionRecord Class
InteractionRecord Members
ININ.IceLib.Interactions Namespace


InteractionSecurityLevel Enumeration

[image]

IceLib Technical Reference
InteractionSecurityLevel Enumeration
See Also Send Feedback
Specifies constants indicating the security level of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionSecurityLevel
Visual Basic
Public Enumeration InteractionSecurityLevel

Members

Member name | Value | Description
None | 0 | Used to indicate an insecure level of security.
Trusted | 1 | Used to indicate a trusted level of security.
Encrypted | 2 | Used to indicate an encrypted level of security.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionSegment Class

[image]

IceLib Technical Reference
InteractionSegment Class
Members See Also Send Feedback
A segment of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public sealed class InteractionSegment : ICompoundAttributeValue
Visual Basic
Public NotInheritable Class InteractionSegment _
    Implements ICompoundAttributeValue

Remarks

There are two types of segments: user segments and connection segments. User segments are segments associated to a user via a user queue. Connection segments are associated with a workgroup queue. For example, in a conference call, there is one connection segment which represents the conference, and a user segment for each party that joins the conference.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionSegment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSegment Members
ININ.IceLib.Interactions Namespace


InteractionSegment Members

[image] [image]

IceLib Technical Reference
InteractionSegment Members
InteractionSegment Class Methods Properties See Also Send Feedback

The InteractionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionId | Gets the interaction ID.
Public property | QueueId | Gets the Queue ID for the interaction (i.e. the name of the workgroup/distribution queue).
Public property | SegmentId | Gets the segment ID.
Public property | UserId | Gets the user ID.
Public property | WrapUpRequired | Gets a value indicating whether a wrap up code is required for the segment.

See Also

InteractionSegment Class
ININ.IceLib.Interactions Namespace


InteractionSegment Methods

[image] [image]

IceLib Technical Reference
InteractionSegment Methods
InteractionSegment Class See Also Send Feedback

The InteractionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSegment Class
ININ.IceLib.Interactions Namespace


InteractionSegment Properties

[image] [image]

IceLib Technical Reference
InteractionSegment Properties
InteractionSegment Class See Also Send Feedback

The InteractionSegment type exposes the following members.

Properties

 | Name | Description
Public property | InteractionId | Gets the interaction ID.
Public property | QueueId | Gets the Queue ID for the interaction (i.e. the name of the workgroup/distribution queue).
Public property | SegmentId | Gets the segment ID.
Public property | UserId | Gets the user ID.
Public property | WrapUpRequired | Gets a value indicating whether a wrap up code is required for the segment.

See Also

InteractionSegment Class
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
InteractionSegment..::..InteractionId Property
InteractionSegment Class See Also Send Feedback
Gets the interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; internal set; }
Visual Basic
Public Property InteractionId As InteractionId
    Get
    Friend Set

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Interactions Namespace


QueueId Property

[image]

IceLib Technical Reference
InteractionSegment..::..QueueId Property
InteractionSegment Class See Also Send Feedback
Gets the Queue ID for the interaction (i.e. the name of the workgroup/distribution queue).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string QueueId { get; internal set; }
Visual Basic
Public Property QueueId As String
    Get
    Friend Set

Field Value

The queue ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Interactions Namespace


SegmentId Property

[image]

IceLib Technical Reference
InteractionSegment..::..SegmentId Property
InteractionSegment Class See Also Send Feedback
Gets the segment ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SegmentId { get; internal set; }
Visual Basic
Public Property SegmentId As Integer
    Get
    Friend Set

Field Value

The segment ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Interactions Namespace


UserId Property

[image]

IceLib Technical Reference
InteractionSegment..::..UserId Property
InteractionSegment Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; internal set; }
Visual Basic
Public Property UserId As String
    Get
    Friend Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Interactions Namespace


WrapUpRequired Property

[image]

IceLib Technical Reference
InteractionSegment..::..WrapUpRequired Property
InteractionSegment Class See Also Send Feedback
Gets a value indicating whether a wrap up code is required for the segment.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool WrapUpRequired { get; internal set; }
Visual Basic
Public Property WrapUpRequired As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if wrap up is required for this segment; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Interactions Namespace


InteractionsHistory Class

[image]

IceLib Technical Reference
InteractionsHistory Class
Members See Also Send Feedback
Provides access to interaction history information for a user.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionsHistory
Visual Basic
Public Class InteractionsHistory

Remarks

The InteractionsHistory class provides access to historical information about the user's interactions, such as the begin time and remote number. See HistoryItem for a complete explanation of the data provided.

Note
Currently only call-specific interaction history is supported.
When the interactions history is being watched, the class will notify the client application of any changes to the history records via registered event handlers. The data is also accessible through the HistoryDataCollection property.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionsHistory

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..HistoryItem


InteractionsHistory Members

[image] [image]

IceLib Technical Reference
InteractionsHistory Members
InteractionsHistory Class Constructors Methods Properties Events See Also Send Feedback

The InteractionsHistory type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionsHistory(InteractionsManager) | Initializes a new instance of the InteractionsHistory class.
Public method | InteractionsHistory(InteractionsManager, Boolean) | Initializes a new instance of the InteractionsHistory class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for changes to the user's interaction history.
Public method | StartWatchingAsync | Asynchronously starts watching for changes to the user's interaction history.
Public method | StopWatching | Stop watching for changes to the user's interaction history.
Public method | StopWatchingAsync | Asynchronously stops the watch for changes to the user's interaction history.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HistoryDataCollection | Gets a collection of HistoryItem objects for this user's past interactions.
Public property | Item | Gets the HistoryItem with the specified ID.

Events

 | Name | Description
Public event | InteractionHistoryDataChanged | Occurs when the user's interaction history information has changed.

See Also

InteractionsHistory Class
ININ.IceLib.Interactions Namespace


InteractionsHistory Constructor

[image] [image]

IceLib Technical Reference
InteractionsHistory Constructor
InteractionsHistory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InteractionsHistory(InteractionsManager) | Initializes a new instance of the InteractionsHistory class.
Public method | InteractionsHistory(InteractionsManager, Boolean) | Initializes a new instance of the InteractionsHistory class.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


InteractionsHistory Constructor (InteractionsManager)

[image]

IceLib Technical Reference
InteractionsHistory Constructor (InteractionsManager)
InteractionsHistory Class See Also Send Feedback
Initializes a new instance of the InteractionsHistory class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsHistory(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
InteractionsHistory Overload
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..InteractionsManager


InteractionsHistory Constructor (InteractionsManager, Boolean)

[image]

IceLib Technical Reference
InteractionsHistory Constructor (InteractionsManager, Boolean)
InteractionsHistory Class See Also Send Feedback
Initializes a new instance of the InteractionsHistory class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionsHistory(
    InteractionsManager interactionsManager,
    bool applyClockSkewAndAdditionalUtcOffset
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    applyClockSkewAndAdditionalUtcOffset As Boolean _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
applyClockSkewAndAdditionalUtcOffset
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) then the ClockSkew and AdditionalUtcOffset values will be applied to HistoryItems.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
InteractionsHistory Overload
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..InteractionsManager


InteractionsHistory Methods

[image] [image]

IceLib Technical Reference
InteractionsHistory Methods
InteractionsHistory Class See Also Send Feedback

The InteractionsHistory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for changes to the user's interaction history.
Public method | StartWatchingAsync | Asynchronously starts watching for changes to the user's interaction history.
Public method | StopWatching | Stop watching for changes to the user's interaction history.
Public method | StopWatchingAsync | Asynchronously stops the watch for changes to the user's interaction history.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionsHistory Class
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
InteractionsHistory..::..IsWatching Method
InteractionsHistory Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
InteractionsHistory..::..StartWatching Method
InteractionsHistory Class See Also Send Feedback
Starts watching for changes to the user's interaction history.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling. StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
Currently only call-specific interaction history is supported.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
InteractionsHistory..::..StartWatchingAsync Method
InteractionsHistory Class See Also Send Feedback
Asynchronously starts watching for changes to the user's interaction history.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
Currently only call-specific interaction history is supported.
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
InteractionsHistory..::..StopWatching Method
InteractionsHistory Class See Also Send Feedback
Stop watching for changes to the user's interaction history.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
InteractionsHistory..::..StopWatchingAsync Method
InteractionsHistory Class See Also Send Feedback
Asynchronously stops the watch for changes to the user's interaction history.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


InteractionsHistory Properties

[image] [image]

IceLib Technical Reference
InteractionsHistory Properties
InteractionsHistory Class See Also Send Feedback

The InteractionsHistory type exposes the following members.

Properties

 | Name | Description
Public property | HistoryDataCollection | Gets a collection of HistoryItem objects for this user's past interactions.
Public property | Item | Gets the HistoryItem with the specified ID.

See Also

InteractionsHistory Class
ININ.IceLib.Interactions Namespace


HistoryDataCollection Property

[image]

IceLib Technical Reference
InteractionsHistory..::..HistoryDataCollection Property
InteractionsHistory Class See Also Send Feedback
Gets a collection of HistoryItem objects for this user's past interactions.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<HistoryItem> HistoryDataCollection { get; }
Visual Basic
Public ReadOnly Property HistoryDataCollection As ReadOnlyCollection(Of HistoryItem)
    Get

Field Value

The history data collection.

Remarks

This property provides read-only access to the collection of HistoryItem objects that make up the interaction history for the user.
Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This object is not watching the interaction history.
ININ.IceLib..::..NotCachedException | The requested object or attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


Item Property

[image]

IceLib Technical Reference
InteractionsHistory..::..Item Property
InteractionsHistory Class See Also Send Feedback
Gets the HistoryItem with the specified ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public HistoryItem this[
    InteractionId id
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    id As InteractionId _
) As HistoryItem
    Get

Parameters

id
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId that indicates the interaction to retrieve the history for.

Field Value

The history data object for the specified interaction ID.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The id was nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | There is no history data for the given InteractionId.
System..::..InvalidOperationException | The interactions history is not being watched by this object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


InteractionsHistory Events

[image] [image]

IceLib Technical Reference
InteractionsHistory Events
InteractionsHistory Class See Also Send Feedback

The InteractionsHistory type exposes the following members.

Events

 | Name | Description
Public event | InteractionHistoryDataChanged | Occurs when the user's interaction history information has changed.

See Also

InteractionsHistory Class
ININ.IceLib.Interactions Namespace


InteractionHistoryDataChanged Event

[image]

IceLib Technical Reference
InteractionsHistory..::..InteractionHistoryDataChanged Event
InteractionsHistory Class See Also Send Feedback
Occurs when the user's interaction history information has changed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<KeyedObjectsChangedEventArgs<InteractionId, HistoryItemProperty>> InteractionHistoryDataChanged
Visual Basic
Public Event InteractionHistoryDataChanged As EventHandler(Of KeyedObjectsChangedEventArgs(Of InteractionId, HistoryItemProperty))

Remarks

This event will only occur if the interaction history is being watched. To start watching the interaction history call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsHistory Class
InteractionsHistory Members
ININ.IceLib.Interactions Namespace


InteractionsManager Class

[image]

IceLib Technical Reference
InteractionsManager Class
Members See Also Send Feedback
Provides access to Interactions and InteractionQueues.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionsManager
Visual Basic
Public Class InteractionsManager

Remarks

Use the InteractionsManager class to access the functionality found in the ININ.IceLib.Interactions namespace.

The ININ.IceLib.Interactions namespace includes all functionality for manipulating interactions and interaction queues managed by an IC server. Most features provided in the InteractionsManager are available in synchronous and asynchronous versions allowing you to choose the model that best suits your needs. The asynchronous versions are preferred since these operations can be lengthy and block the calling thread.

Examples

All "manager" classes found in the IceLib library are designed as singletons. To begin working with any of the functionality provided in the InteractionsManager you must obtain the instance through a call to GetInstance(Session).
CopyC#
Session session = new Session();
session.Connect(...);
InteractionsManager interactionsManager = InteractionsManager.GetInstance(session);

Examples

The following example illustrates using this class to make a call.
CopyC#
...

string _PhoneNumber = "555-1212";

private void btMakeCall_Click(object sender, System.EventArgs e)
{
    if (_Session.ConnectionState != ConnectionState.Up)
    {
        MessageBox.Show("Connection is down");
        return;
    }
    _InteractionsManager.MakeCallAsync(
        new CallInteractionParameters(_PhoneNumber),
        new EventHandler<InteractionCompletedArgs>(InteractionsManager_MakeCallCompleted),
        null);
}

private void InteractionsManager_MakeCallCompleted(object sender, InteractionCompletedEventArgs e)
{
    if (e.Error != null)
    {
        MessageBox.Show(e.Error.StackTrace, e.Error.Message);
        return;
    }

    Interaction interaction = e.Interaction;

    _LastInteraction = interaction;

    if (interaction != null)
    {
        MessageBox.Show(String.Format("Call Made. InteractionId={0}", interaction.InteractionId);
    }
    else
    {
        MessageBox.Show("MakeCall Failed.");
    }
 }

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionsManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Members
ININ.IceLib.Interactions Namespace


InteractionsManager Members

[image] [image]

IceLib Technical Reference
InteractionsManager Members
InteractionsManager Class Methods Properties Events See Also Send Feedback

The InteractionsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddWrapUpAssignment | Adds a WrapUpAssignment to a segment of the target interaction.
Public method | AddWrapUpAssignmentAsync | Asynchronously adds a WrapUpAssignment to a segment of the target interaction.
Public method | ConsultMakeCall(CallInteractionParameters) | Makes a consult call using the values specified in the CallInteractionParameters parameter.
Public method | ConsultMakeCall(String, CallMadeStage) | Makes a consult call given a string specifying the target and a CallMadeStage value.
Public method | ConsultMakeCall(QueueId, CallMadeStage) | Makes a consult call given a QueueId for the target and a CallMadeStage value.
Public method | ConsultMakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call using the values specified in the CallInteractionParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.
Public method | ConsultMakeCallAsync(String, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call given a string specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.
Public method | ConsultMakeCallAsync(QueueId, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call given a QueueId specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.
Public method | CreateInteraction | Creates an Interaction instance for a given ID.
Public method | CreateInteractionAsync | Asynchronously creates an Interaction instance for a given ID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets an InteractionsManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InviteParty | Invites a party to a conference.
Public method | InvitePartyAsync | Asynchronously invites a party to a conference.
Public method | MakeCall | Makes the call.
Public method | MakeCallAsync | Asynchronously makes a call.
Public method | MakeCallbackInteraction | Makes a callback interaction.
Public method | MakeCallbackInteractionAsync | Asynchronously makes a callback interaction.
Public method | MakeChat | Makes a chat.
Public method | MakeChatAsync | Asynchronously makes a chat.
Public method | MakeConsultTransfer | Makes a consult transfer using the values specified in the ConsultTransferParameters parameter.
Public method | MakeConsultTransferAsync | Asynchronously makes a consult transfer call using the values specified in the ConsultTransferParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.
Public method | MakeEmail | Makes the email.
Public method | MakeEmailAsync | Asynchronously makes an email.
Public method | MakeGenericInteraction | Makes a generic interaction.
Public method | MakeGenericInteractionAsync | Asynchronously makes a generic interaction.
Public method | MakeNewConference | Makes the new conference.
Public method | MakeNewConferenceAsync | Asynchronously makes the new conference.
Public method | MakeRemoteNumberConnection | Makes a connection to a Remote Number.
Public method | MakeRemoteNumberConnectionAsync | Asynchronously makes a connection to a Remote Number.
Public method | MakeStationConnection | Makes a connection to a station.
Public method | MakeStationConnectionAsync | Asynchronously makes a connection to a station.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryPhoneNumberDetails | Queries phone number details.
Public method | QueryPhoneNumberDetailsAsync | Asynchronously queries phone number details.
Public method | SendAssistanceRequest | Sends an assistance request.
Public method | SendAssistanceRequestAsync | Asynchronously sends an assistance request.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SensitiveAttributeDataContext | Gets the sensitive attribute data context for this session.
Public property | Session | Gets the Session with which this StatisticsManager is associated.

Events

 | Name | Description
Public event | CallMade | Occurs when a MakeCall type operation completes.
Public event | InteractionAutoAnswered | Occurs when an Interaction is automatically answered.
Public event | PerformedAction | Occurs after an Action is performed on any Interaction in the Session.
Public event | PerformingAction | Occurs when an Action is performed on any Interaction in the Session.

See Also

InteractionsManager Class
ININ.IceLib.Interactions Namespace


InteractionsManager Methods

[image] [image]

IceLib Technical Reference
InteractionsManager Methods
InteractionsManager Class See Also Send Feedback

The InteractionsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddWrapUpAssignment | Adds a WrapUpAssignment to a segment of the target interaction.
Public method | AddWrapUpAssignmentAsync | Asynchronously adds a WrapUpAssignment to a segment of the target interaction.
Public method | ConsultMakeCall(CallInteractionParameters) | Makes a consult call using the values specified in the CallInteractionParameters parameter.
Public method | ConsultMakeCall(String, CallMadeStage) | Makes a consult call given a string specifying the target and a CallMadeStage value.
Public method | ConsultMakeCall(QueueId, CallMadeStage) | Makes a consult call given a QueueId for the target and a CallMadeStage value.
Public method | ConsultMakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call using the values specified in the CallInteractionParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.
Public method | ConsultMakeCallAsync(String, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call given a string specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.
Public method | ConsultMakeCallAsync(QueueId, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call given a QueueId specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.
Public method | CreateInteraction | Creates an Interaction instance for a given ID.
Public method | CreateInteractionAsync | Asynchronously creates an Interaction instance for a given ID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets an InteractionsManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InviteParty | Invites a party to a conference.
Public method | InvitePartyAsync | Asynchronously invites a party to a conference.
Public method | MakeCall | Makes the call.
Public method | MakeCallAsync | Asynchronously makes a call.
Public method | MakeCallbackInteraction | Makes a callback interaction.
Public method | MakeCallbackInteractionAsync | Asynchronously makes a callback interaction.
Public method | MakeChat | Makes a chat.
Public method | MakeChatAsync | Asynchronously makes a chat.
Public method | MakeConsultTransfer | Makes a consult transfer using the values specified in the ConsultTransferParameters parameter.
Public method | MakeConsultTransferAsync | Asynchronously makes a consult transfer call using the values specified in the ConsultTransferParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.
Public method | MakeEmail | Makes the email.
Public method | MakeEmailAsync | Asynchronously makes an email.
Public method | MakeGenericInteraction | Makes a generic interaction.
Public method | MakeGenericInteractionAsync | Asynchronously makes a generic interaction.
Public method | MakeNewConference | Makes the new conference.
Public method | MakeNewConferenceAsync | Asynchronously makes the new conference.
Public method | MakeRemoteNumberConnection | Makes a connection to a Remote Number.
Public method | MakeRemoteNumberConnectionAsync | Asynchronously makes a connection to a Remote Number.
Public method | MakeStationConnection | Makes a connection to a station.
Public method | MakeStationConnectionAsync | Asynchronously makes a connection to a station.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | QueryPhoneNumberDetails | Queries phone number details.
Public method | QueryPhoneNumberDetailsAsync | Asynchronously queries phone number details.
Public method | SendAssistanceRequest | Sends an assistance request.
Public method | SendAssistanceRequestAsync | Asynchronously sends an assistance request.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionsManager Class
ININ.IceLib.Interactions Namespace


AddWrapUpAssignment Method

[image]

IceLib Technical Reference
InteractionsManager..::..AddWrapUpAssignment Method
InteractionsManager Class See Also Send Feedback
Adds a WrapUpAssignment to a segment of the target interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddWrapUpAssignment(
    WrapUpAssignment assignment
)
Visual Basic
Public Sub AddWrapUpAssignment ( _
    assignment As WrapUpAssignment _
)

Parameters

assignment
Type: ININ.IceLib.Interactions..::..WrapUpAssignment
The wrap-up assignment.

Remarks

Each segment of an interaction may have a wrap-up code assigned. Calling this method multiple times on the same segment of an interaction will replace the existing WrapUpAssignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


AddWrapUpAssignmentAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..AddWrapUpAssignmentAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously adds a WrapUpAssignment to a segment of the target interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddWrapUpAssignmentAsync(
    WrapUpAssignment assignment,
    EventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub AddWrapUpAssignmentAsync ( _
    assignment As WrapUpAssignment, _
    completedCallback As EventHandler, _
    userState As Object _
)

Parameters

assignment
Type: ININ.IceLib.Interactions..::..WrapUpAssignment
The wrap-up assignment.
completedCallback
Type: System..::..EventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Each segment of an interaction may have a wrap-up code assigned. Calling this method multiple times on the same segment of an interaction will replace the existing WrapUpAssignment.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


ConsultMakeCall Method

[image] [image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCall Method
InteractionsManager Class See Also Send Feedback
Makes a consult call.

Overload List

 | Name | Description
Public method | ConsultMakeCall(CallInteractionParameters) | Makes a consult call using the values specified in the CallInteractionParameters parameter.
Public method | ConsultMakeCall(String, CallMadeStage) | Makes a consult call given a string specifying the target and a CallMadeStage value.
Public method | ConsultMakeCall(QueueId, CallMadeStage) | Makes a consult call given a QueueId for the target and a CallMadeStage value.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


ConsultMakeCall Method (CallInteractionParameters)

[image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCall Method (CallInteractionParameters)
InteractionsManager Class See Also Send Feedback
Makes a consult call using the values specified in the CallInteractionParameters parameter.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ConsultMakeCall(
    CallInteractionParameters callParameters
)
Visual Basic
Public Function ConsultMakeCall ( _
    callParameters As CallInteractionParameters _
) As Interaction

Parameters

callParameters
Type: ININ.IceLib.Interactions..::..CallInteractionParameters
The call parameters.

Return Value

The consult Interaction.

Remarks

If the CallMadeStage of the callParameters is None the CallMade event will be raised when the call is allocated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ConsultMakeCall Overload
ININ.IceLib.Interactions Namespace


ConsultMakeCall Method (String, CallMadeStage)

[image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCall Method (String, CallMadeStage)
InteractionsManager Class See Also Send Feedback
Makes a consult call given a string specifying the target and a CallMadeStage value.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ConsultMakeCall(
    string target,
    CallMadeStage callMadeStage
)
Visual Basic
Public Function ConsultMakeCall ( _
    target As String, _
    callMadeStage As CallMadeStage _
) As Interaction

Parameters

target
Type: System..::..String
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Return Value

The consult Interaction.

Remarks

If the callMadeStage is None the CallMade event will be raised when the call is allocated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ConsultMakeCall Overload
ININ.IceLib.Interactions Namespace


ConsultMakeCall Method (QueueId, CallMadeStage)

[image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCall Method (QueueId, CallMadeStage)
InteractionsManager Class See Also Send Feedback
Makes a consult call given a QueueId for the target and a CallMadeStage value.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ConsultMakeCall(
    QueueId target,
    CallMadeStage callMadeStage
)
Visual Basic
Public Function ConsultMakeCall ( _
    target As QueueId, _
    callMadeStage As CallMadeStage _
) As Interaction

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Return Value

The consult Interaction.

Remarks

If the callMadeStage is None the CallMade event will be raised when the call is allocated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ConsultMakeCall Overload
ININ.IceLib.Interactions Namespace


ConsultMakeCallAsync Method

[image] [image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCallAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a consult call.

Overload List

 | Name | Description
Public method | ConsultMakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call using the values specified in the CallInteractionParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.
Public method | ConsultMakeCallAsync(String, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call given a string specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.
Public method | ConsultMakeCallAsync(QueueId, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object) | Asynchronously makes a consult call given a QueueId specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


ConsultMakeCallAsync Method (CallInteractionParameters, EventHandler(InteractionCompletedEventArgs), Object)

[image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCallAsync Method (CallInteractionParameters, EventHandler<(Of <(<'InteractionCompletedEventArgs>)>)>, Object)
InteractionsManager Class See Also Send Feedback
Asynchronously makes a consult call using the values specified in the CallInteractionParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConsultMakeCallAsync(
    CallInteractionParameters callParameters,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ConsultMakeCallAsync ( _
    callParameters As CallInteractionParameters, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

callParameters
Type: ININ.IceLib.Interactions..::..CallInteractionParameters
The call parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

If the CallMadeStage of callParameters is None the CallMade event will be raised when the call is allocated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ConsultMakeCallAsync Overload
ININ.IceLib.Interactions Namespace


ConsultMakeCallAsync Method (String, CallMadeStage, EventHandler(InteractionCompletedEventArgs), Object)

[image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCallAsync Method (String, CallMadeStage, EventHandler<(Of <(<'InteractionCompletedEventArgs>)>)>, Object)
InteractionsManager Class See Also Send Feedback
Asynchronously makes a consult call given a string specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConsultMakeCallAsync(
    string target,
    CallMadeStage callMadeStage,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ConsultMakeCallAsync ( _
    target As String, _
    callMadeStage As CallMadeStage, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

target
Type: System..::..String
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

If the callMadeStage is None the CallMade event will be raised when the call is allocated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ConsultMakeCallAsync Overload
ININ.IceLib.Interactions Namespace


ConsultMakeCallAsync Method (QueueId, CallMadeStage, EventHandler(InteractionCompletedEventArgs), Object)

[image]

IceLib Technical Reference
InteractionsManager..::..ConsultMakeCallAsync Method (QueueId, CallMadeStage, EventHandler<(Of <(<'InteractionCompletedEventArgs>)>)>, Object)
InteractionsManager Class See Also Send Feedback
Asynchronously makes a consult call given a QueueId specifying the target and a CallMadeStage value. The handler specified by completedCallback is invoked when the operation is completed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ConsultMakeCallAsync(
    QueueId target,
    CallMadeStage callMadeStage,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ConsultMakeCallAsync ( _
    target As QueueId, _
    callMadeStage As CallMadeStage, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

target
Type: ININ.IceLib.Interactions..::..QueueId
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

If the callMadeStage is None the CallMade event will be raised when the call is allocated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ConsultMakeCallAsync Overload
ININ.IceLib.Interactions Namespace


CreateInteraction Method

[image]

IceLib Technical Reference
InteractionsManager..::..CreateInteraction Method
InteractionsManager Class See Also Send Feedback
Creates an Interaction instance for a given ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction CreateInteraction(
    InteractionId interactionId
)
Visual Basic
Public Function CreateInteraction ( _
    interactionId As InteractionId _
) As Interaction

Parameters

interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Return Value

The Interaction that was returned.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


CreateInteractionAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..CreateInteractionAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously creates an Interaction instance for a given ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateInteractionAsync(
    InteractionId interactionId,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateInteractionAsync ( _
    interactionId As InteractionId, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


GetInstance Method

[image]

IceLib Technical Reference
InteractionsManager..::..GetInstance Method
InteractionsManager Class See Also Send Feedback
Gets an InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static InteractionsManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As InteractionsManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The InteractionsManager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


InviteParty Method

[image]

IceLib Technical Reference
InteractionsManager..::..InviteParty Method
InteractionsManager Class See Also Send Feedback
Invites a party to a conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction InviteParty(
    InteractionId inviteTo,
    InvitePartyParameters inviteParameters
)
Visual Basic
Public Function InviteParty ( _
    inviteTo As InteractionId, _
    inviteParameters As InvitePartyParameters _
) As Interaction

Parameters

inviteTo
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID to invite to.
inviteParameters
Type: ININ.IceLib.Interactions..::..InvitePartyParameters
The invite parameters.

Return Value

The Interaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
System..::..NotSupportedException | inviteParameters is Started.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
InteractionConference..::..InvitePartyAsync(InvitePartyParameters, AsyncCompletedEventHandler, Object)


InvitePartyAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..InvitePartyAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously invites a party to a conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InvitePartyAsync(
    InteractionId inviteTo,
    InvitePartyParameters inviteParameters,
    EventHandler<InvitePartyCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub InvitePartyAsync ( _
    inviteTo As InteractionId, _
    inviteParameters As InvitePartyParameters, _
    completedCallback As EventHandler(Of InvitePartyCompletedEventArgs), _
    userState As Object _
)

Parameters

inviteTo
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID to invite to.
inviteParameters
Type: ININ.IceLib.Interactions..::..InvitePartyParameters
The invite parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' InvitePartyCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
System..::..NotSupportedException | inviteParameters is Started.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
InteractionConference..::..InvitePartyAsync(InvitePartyParameters, AsyncCompletedEventHandler, Object)


MakeCall Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeCall Method
InteractionsManager Class See Also Send Feedback
Makes the call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction MakeCall(
    CallInteractionParameters callParameters
)
Visual Basic
Public Function MakeCall ( _
    callParameters As CallInteractionParameters _
) As Interaction

Parameters

callParameters
Type: ININ.IceLib.Interactions..::..CallInteractionParameters
The call parameters.

Return Value

The Interaction that was returned.

Remarks

If the CallMadeStage of the callParameters is None the CallMade event will be raised when the call is allocated.

See Target for information on using Attendant DS values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Interactions..::..MakeCallException | Call could not be made because of a server side error.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeCallAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeCallAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeCallAsync(
    CallInteractionParameters callParameters,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeCallAsync ( _
    callParameters As CallInteractionParameters, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

callParameters
Type: ININ.IceLib.Interactions..::..CallInteractionParameters
The call parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

If the CallMadeStage of callParameters is None the CallMade event will be raised when the call is allocated.

See Target for information on using Attendant DS values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeCallbackInteraction Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeCallbackInteraction Method
InteractionsManager Class See Also Send Feedback
Makes a callback interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackInteraction MakeCallbackInteraction(
    CallbackInteractionParameters callbackInteractionParameters
)
Visual Basic
Public Function MakeCallbackInteraction ( _
    callbackInteractionParameters As CallbackInteractionParameters _
) As CallbackInteraction

Parameters

callbackInteractionParameters
Type: ININ.IceLib.Interactions..::..CallbackInteractionParameters
The callback interaction parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeCallbackInteractionAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeCallbackInteractionAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a callback interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeCallbackInteractionAsync(
    CallbackInteractionParameters callbackInteractionParameters,
    EventHandler<MakeCallbackInteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeCallbackInteractionAsync ( _
    callbackInteractionParameters As CallbackInteractionParameters, _
    completedCallback As EventHandler(Of MakeCallbackInteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

callbackInteractionParameters
Type: ININ.IceLib.Interactions..::..CallbackInteractionParameters
The callback interaction parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' MakeCallbackInteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeChat Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeChat Method
InteractionsManager Class See Also Send Feedback
Makes a chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatInteraction MakeChat(
    string targetUser
)
Visual Basic
Public Function MakeChat ( _
    targetUser As String _
) As ChatInteraction

Parameters

targetUser
Type: System..::..String
The target user to chat with.

Return Value

The ChatInteraction that was returned.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeChatAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeChatAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a chat.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeChatAsync(
    string targetUser,
    EventHandler<MakeChatCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeChatAsync ( _
    targetUser As String, _
    completedCallback As EventHandler(Of MakeChatCompletedEventArgs), _
    userState As Object _
)

Parameters

targetUser
Type: System..::..String
The target user to chat with.
completedCallback
Type: System..::..EventHandler<(Of <(<' MakeChatCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeConsultTransfer Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeConsultTransfer Method
InteractionsManager Class See Also Send Feedback
Makes a consult transfer using the values specified in the ConsultTransferParameters parameter.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransfer MakeConsultTransfer(
    ConsultTransferParameters consultTransferParams
)
Visual Basic
Public Function MakeConsultTransfer ( _
    consultTransferParams As ConsultTransferParameters _
) As ConsultTransfer

Parameters

consultTransferParams
Type: ININ.IceLib.Interactions..::..ConsultTransferParameters
The transfer parameters.

Return Value

The consult transfer.

Remarks

If the CallMadeStage of the consultTransferParams is None the CallMade event will be raised when the call is allocated.

This method is intended to be used to start a new Consult Transfer. If you need to recover an existing Consult Transfer, due to a client crash, use the GetConsultTransferFromInteraction(Interaction) method instead.

Note
A consult transfer tracks and responds to Morph events. Cancel()()()() or Conclude()()()() must be called at the conclusion of a consult transfer for proper clean up to occur.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
ConsultTransfer..::..GetConsultTransferFromInteraction(Interaction)


MakeConsultTransferAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeConsultTransferAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a consult transfer call using the values specified in the ConsultTransferParameters parameter. The handler specified by completedCallback is invoked when the operation is completed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeConsultTransferAsync(
    ConsultTransferParameters consultTransferParameters,
    EventHandler<MakeConsultTransferCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeConsultTransferAsync ( _
    consultTransferParameters As ConsultTransferParameters, _
    completedCallback As EventHandler(Of MakeConsultTransferCompletedEventArgs), _
    userState As Object _
)

Parameters

consultTransferParameters
Type: ININ.IceLib.Interactions..::..ConsultTransferParameters
The transfer parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' MakeConsultTransferCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

If the CallMadeStage of consultTransferParameters is None the CallMade event will be raised when the call is allocated.

Note
A consult transfer tracks and responds to Morph events. Cancel()()()() or Conclude()()()() must be called at the conclusion of a consult transfer for proper clean up to occur.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeEmail Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeEmail Method
InteractionsManager Class See Also Send Feedback
Makes the email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteraction MakeEmail(
    EmailInteractionParameters emailParameters
)
Visual Basic
Public Function MakeEmail ( _
    emailParameters As EmailInteractionParameters _
) As EmailInteraction

Parameters

emailParameters
Type: ININ.IceLib.Interactions..::..EmailInteractionParameters
The email parameters.

Return Value

The Interaction that was returned.

Remarks

Note
MakeEmail requires that the provided work group has its routing configured to handle email. If the created email interaction is to be handled by the .NET Client, the default email body content type is text/html. If the desired content type is text/plain, then do not add the EmailBodyto the Bodies collection, but only assign the string to the Body property.
Note
At this time, creating inbound email interactions is not supported.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeEmailAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeEmailAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes an email.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeEmailAsync(
    EmailInteractionParameters emailParameters,
    EventHandler<MakeEmailCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeEmailAsync ( _
    emailParameters As EmailInteractionParameters, _
    completedCallback As EventHandler(Of MakeEmailCompletedEventArgs), _
    userState As Object _
)

Parameters

emailParameters
Type: ININ.IceLib.Interactions..::..EmailInteractionParameters
The email parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' MakeEmailCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
MakeEmail requires that the provided work group has its routing configured to handle email. If the created email interaction is to be handled by the .NET Client, the default email body content type is text/html. If the desired content type is text/plain, then do not add the EmailBodyto the Bodies collection, but only assign the string to the Body property.
Note
At this time, creating inbound email interactions is not supported.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeGenericInteraction Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeGenericInteraction Method
InteractionsManager Class See Also Send Feedback
Makes a generic interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GenericInteraction MakeGenericInteraction(
    GenericInteractionParameters genericInteractionParameters
)
Visual Basic
Public Function MakeGenericInteraction ( _
    genericInteractionParameters As GenericInteractionParameters _
) As GenericInteraction

Parameters

genericInteractionParameters
Type: ININ.IceLib.Interactions..::..GenericInteractionParameters
The generic interaction parameters.

Return Value

The GenericInteraction that was returned.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeGenericInteractionAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeGenericInteractionAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a generic interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeGenericInteractionAsync(
    GenericInteractionParameters genericInteractionParameters,
    EventHandler<MakeGenericInteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeGenericInteractionAsync ( _
    genericInteractionParameters As GenericInteractionParameters, _
    completedCallback As EventHandler(Of MakeGenericInteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

genericInteractionParameters
Type: ININ.IceLib.Interactions..::..GenericInteractionParameters
The generic interaction parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' MakeGenericInteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeNewConference Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeNewConference Method
InteractionsManager Class See Also Send Feedback
Makes the new conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionConference MakeNewConference(
    Interaction[] interactions
)
Visual Basic
Public Function MakeNewConference ( _
    interactions As Interaction() _
) As InteractionConference

Parameters

interactions
Type: array< ININ.IceLib.Interactions..::..Interaction >[]()[][]
The interactions.

Return Value

The Conference.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeNewConferenceAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeNewConferenceAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes the new conference.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeNewConferenceAsync(
    Interaction[] interactions,
    EventHandler<MakeNewConferenceCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeNewConferenceAsync ( _
    interactions As Interaction(), _
    completedCallback As EventHandler(Of MakeNewConferenceCompletedEventArgs), _
    userState As Object _
)

Parameters

interactions
Type: array< ININ.IceLib.Interactions..::..Interaction >[]()[][]
The interactions.
completedCallback
Type: System..::..EventHandler<(Of <(<' MakeNewConferenceCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeRemoteNumberConnection Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeRemoteNumberConnection Method
InteractionsManager Class See Also Send Feedback
Makes a connection to a Remote Number.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction MakeRemoteNumberConnection(
    string remoteNumber
)
Visual Basic
Public Function MakeRemoteNumberConnection ( _
    remoteNumber As String _
) As Interaction

Parameters

remoteNumber
Type: System..::..String
The remote number.

Return Value

The Interaction that was returned.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeRemoteNumberConnectionAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeRemoteNumberConnectionAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a connection to a Remote Number.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeRemoteNumberConnectionAsync(
    string remoteNumber,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeRemoteNumberConnectionAsync ( _
    remoteNumber As String, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

remoteNumber
Type: System..::..String
The remote number.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeStationConnection Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeStationConnection Method
InteractionsManager Class See Also Send Feedback
Makes a connection to a station.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction MakeStationConnection(
    string station
)
Visual Basic
Public Function MakeStationConnection ( _
    station As String _
) As Interaction

Parameters

station
Type: System..::..String
The station identifier.

Return Value

The Interaction that was returned.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


MakeStationConnectionAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..MakeStationConnectionAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously makes a connection to a station.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MakeStationConnectionAsync(
    string station,
    EventHandler<InteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub MakeStationConnectionAsync ( _
    station As String, _
    completedCallback As EventHandler(Of InteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

station
Type: System..::..String
The station identifier.
completedCallback
Type: System..::..EventHandler<(Of <(<' InteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


QueryPhoneNumberDetails Method

[image]

IceLib Technical Reference
InteractionsManager..::..QueryPhoneNumberDetails Method
InteractionsManager Class See Also Send Feedback
Queries phone number details.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PhoneNumber> QueryPhoneNumberDetails(
    string[] phoneNumbers
)
Visual Basic
Public Function QueryPhoneNumberDetails ( _
    phoneNumbers As String() _
) As ReadOnlyCollection(Of PhoneNumber)

Parameters

phoneNumbers
Type: array<System..::..String>[]()[][]
The phone numbers.

Return Value

A PhoneNumber array.

Remarks

The arguments to this method can be phone numbers without any formatting, not fully specified phone numbers, etc. If the phone number string requires matching, pattern matching engine is invoked in an attempt to try to resolve (recognize) it. Part of the resolving process is to generate a new input number, which is the result of the Input Conversion mapping step. This new number will will overwrite the data member holding the original input number. Whether or not a match is found, the input number will be prepared by having white space and formatting characters removed and alphas mapped to digits; the exceptions to this are SIP numbers, which only have white space characters removed.

For more information please refer to PhoneNumber.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..PhoneNumber


QueryPhoneNumberDetailsAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..QueryPhoneNumberDetailsAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously queries phone number details.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void QueryPhoneNumberDetailsAsync(
    string[] phoneNumbers,
    EventHandler<QueryPhoneNumberDetailsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub QueryPhoneNumberDetailsAsync ( _
    phoneNumbers As String(), _
    completedCallback As EventHandler(Of QueryPhoneNumberDetailsCompletedEventArgs), _
    userState As Object _
)

Parameters

phoneNumbers
Type: array<System..::..String>[]()[][]
The phone numbers.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryPhoneNumberDetailsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter contains an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


SendAssistanceRequest Method

[image]

IceLib Technical Reference
InteractionsManager..::..SendAssistanceRequest Method
InteractionsManager Class See Also Send Feedback
Sends an assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssistanceItem SendAssistanceRequest(
    SendAssistanceRequestParameters parameters
)
Visual Basic
Public Function SendAssistanceRequest ( _
    parameters As SendAssistanceRequestParameters _
) As AssistanceItem

Parameters

parameters
Type: ININ.IceLib.Interactions..::..SendAssistanceRequestParameters
The parameters used to create the assistance request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


SendAssistanceRequestAsync Method

[image]

IceLib Technical Reference
InteractionsManager..::..SendAssistanceRequestAsync Method
InteractionsManager Class See Also Send Feedback
Asynchronously sends an assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendAssistanceRequestAsync(
    SendAssistanceRequestParameters parameters,
    EventHandler<AssistanceRequestCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendAssistanceRequestAsync ( _
    parameters As SendAssistanceRequestParameters, _
    completedCallback As EventHandler(Of AssistanceRequestCompletedEventArgs), _
    userState As Object _
)

Parameters

parameters
Type: ININ.IceLib.Interactions..::..SendAssistanceRequestParameters
The parameters used to create the assistance request.
completedCallback
Type: System..::..EventHandler<(Of <(<' AssistanceRequestCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


InteractionsManager Properties

[image] [image]

IceLib Technical Reference
InteractionsManager Properties
InteractionsManager Class See Also Send Feedback

The InteractionsManager type exposes the following members.

Properties

 | Name | Description
Public property | SensitiveAttributeDataContext | Gets the sensitive attribute data context for this session.
Public property | Session | Gets the Session with which this StatisticsManager is associated.

See Also

InteractionsManager Class
ININ.IceLib.Interactions Namespace


SensitiveAttributeDataContext Property

[image]

IceLib Technical Reference
InteractionsManager..::..SensitiveAttributeDataContext Property
InteractionsManager Class See Also Send Feedback
Gets the sensitive attribute data context for this session.

Note: This property is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SensitiveAttributeDataContext SensitiveAttributeDataContext { get; }
Visual Basic
Public ReadOnly Property SensitiveAttributeDataContext As SensitiveAttributeDataContext
    Get

Field Value

The sensitive data context.

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..SensitiveAttributeDataContext
ININ.IceLib.Connection..::..SensitiveDataContext


Session Property

[image]

IceLib Technical Reference
InteractionsManager..::..Session Property
InteractionsManager Class See Also Send Feedback
Gets the Session with which this StatisticsManager is associated.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


InteractionsManager Events

[image] [image]

IceLib Technical Reference
InteractionsManager Events
InteractionsManager Class See Also Send Feedback

The InteractionsManager type exposes the following members.

Events

 | Name | Description
Public event | CallMade | Occurs when a MakeCall type operation completes.
Public event | InteractionAutoAnswered | Occurs when an Interaction is automatically answered.
Public event | PerformedAction | Occurs after an Action is performed on any Interaction in the Session.
Public event | PerformingAction | Occurs when an Action is performed on any Interaction in the Session.

See Also

InteractionsManager Class
ININ.IceLib.Interactions Namespace


CallMade Event

[image]

IceLib Technical Reference
InteractionsManager..::..CallMade Event
InteractionsManager Class See Also Send Feedback
Occurs when a MakeCall type operation completes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<CallMadeEventArgs> CallMade
Visual Basic
Public Event CallMade As EventHandler(Of CallMadeEventArgs)

Remarks

The event is raised when the call completes the stage specified by the CallMadeStage.

This event will only occur after a call has been made using MakeCall or ConsultMakeCall

Note
All event handlers should be added before calling MakeCall or ConsultMakeCall.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..MakeCall(CallInteractionParameters)
InteractionsManager..::..MakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)
InteractionsManager..::..ConsultMakeCall(CallInteractionParameters)
InteractionsManager..::..ConsultMakeCall(QueueId, CallMadeStage)
InteractionsManager..::..ConsultMakeCall(String, CallMadeStage)
InteractionsManager..::..ConsultMakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)
InteractionsManager..::..ConsultMakeCallAsync(QueueId, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)
InteractionsManager..::..ConsultMakeCallAsync(String, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)


InteractionAutoAnswered Event

[image]

IceLib Technical Reference
InteractionsManager..::..InteractionAutoAnswered Event
InteractionsManager Class See Also Send Feedback
Occurs when an Interaction is automatically answered.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<InteractionEventArgs> InteractionAutoAnswered
Visual Basic
Public Event InteractionAutoAnswered As EventHandler(Of InteractionEventArgs)

Remarks

This event will only occur while the Session is connected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace


PerformedAction Event

[image]

IceLib Technical Reference
InteractionsManager..::..PerformedAction Event
InteractionsManager Class See Also Send Feedback
Occurs after an Action is performed on any Interaction in the Session.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<PerformedActionEventArgs> PerformedAction
Visual Basic
Public Event PerformedAction As EventHandler(Of PerformedActionEventArgs)

Remarks

This event will only occur while the Session is connected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..PerformingAction


PerformingAction Event

[image]

IceLib Technical Reference
InteractionsManager..::..PerformingAction Event
InteractionsManager Class See Also Send Feedback
Occurs when an Action is performed on any Interaction in the Session.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<PerformingActionEventArgs> PerformingAction
Visual Basic
Public Event PerformingAction As EventHandler(Of PerformingActionEventArgs)

Remarks

This event will only occur while the Session is connected.
Note
This event is only applicable to the specific IceLib Session instance and will not be received for actions performed via other Session instances.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionsManager Class
InteractionsManager Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..PerformedAction


InteractionState Enumeration

[image]

IceLib Technical Reference
InteractionState Enumeration
See Also Send Feedback
Specifies constants indicating the state of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionState
Visual Basic
Public Enumeration InteractionState

Members

Member name | Value | Description
None | 0 | The Interaction is in an indeterminate state.
Alerting | 1 | A user is being notified that he or she has an incoming interaction. This state applies to inbound interactions.
Connected | 2 | Both parties are connected and are able to speak with each other. This state applies to inbound and outbound interactions.
Held | 3 | The interaction is on hold. This state applies to inbound and outbound interactions.
Messaging | 4 | The caller is leaving a voice mail message.
Offering | 5 | The interaction has been placed in a queue, but the interaction is not alerting. IC is determining if the called party is available to take the interaction. This state applies to inbound interactions only.
Parked | 6 | The Interaction is parked, waiting for the recipient user to pick it up.
Proceeding | 7 | The interaction is proceeding through the outside telephone network. Proceeding is used if a user has enabled Call Analysis. This state applies to outbound calls only.
System | 8 | The Interaction is being processed by the system.
InternalDisconnect | 9 | The Interaction has been disconnected internally and is no longer active. This state applies to inbound and outbound interactions.
ExternalDisconnect | 10 | The Interaction has been disconnected externally and is no longer active. This state applies to inbound and outbound interactions.
Suspended | 11 | The interaction is suspended. This state applies to inbound and outbound interactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InteractionType Enumeration

[image]

IceLib Technical Reference
InteractionType Enumeration
See Also Send Feedback
Specifies constants indicating the type of an Interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionType
Visual Basic
Public Enumeration InteractionType

Members

Member name | Value | Description
None | 0 | The Interaction is of an unknown type.
Call | 1 | The Interaction is a Call.
Callback | 2 | The Interaction is a Callback.
Chat | 3 | The Interaction is a Chat.
Email | 4 | The Interaction is an Email.
Generic | 5 | The Interaction is a Generic object.
Monitor | 6 | The Interaction is a Monitor.
Recorder | 7 | The Interaction is a Record.
WorkItem | 8 | The Interaction is a Work Item.
SocialConversation | 9 | The Interaction is a Social Conversation.
SocialDirectMessage | 10 | The Interaction is a Social DirectMessage.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


InvitePartyCompletedEventArgs Class

[image]

IceLib Technical Reference
InvitePartyCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the InvitePartyAsync(InteractionId, InvitePartyParameters, EventHandler<(Of <<'(InvitePartyCompletedEventArgs>)>>), Object) completedCallback delegate of InvitePartyAsync(InteractionId, InvitePartyParameters, EventHandler<(Of <<'(InvitePartyCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InvitePartyCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class InvitePartyCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..InvitePartyCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InvitePartyCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
InvitePartyCompletedEventArgs Members
InvitePartyCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The InvitePartyCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InvitePartyCompletedEventArgs | Initializes a new instance of the InvitePartyCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Interaction | Gets the Interaction associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

InvitePartyCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InvitePartyCompletedEventArgs Constructor

[image]

IceLib Technical Reference
InvitePartyCompletedEventArgs Constructor
InvitePartyCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the InvitePartyCompletedEventArgs class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvitePartyCompletedEventArgs(
    Interaction interaction,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The Interaction.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
Not currently supported.
userState
Type: System..::..Object
The user-supplied object to be passed to the asynchronous password policy operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyCompletedEventArgs Class
InvitePartyCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InvitePartyCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
InvitePartyCompletedEventArgs Methods
InvitePartyCompletedEventArgs Class See Also Send Feedback

The InvitePartyCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InvitePartyCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InvitePartyCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
InvitePartyCompletedEventArgs Properties
InvitePartyCompletedEventArgs Class See Also Send Feedback

The InvitePartyCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Interaction | Gets the Interaction associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

InvitePartyCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
InvitePartyCompletedEventArgs..::..Interaction Property
InvitePartyCompletedEventArgs Class See Also Send Feedback
Gets the Interaction associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyCompletedEventArgs Class
InvitePartyCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


InvitePartyParameters Class

[image]

IceLib Technical Reference
InvitePartyParameters Class
Members See Also Send Feedback
Provides details when inviting a party via InviteParty(InteractionId, InvitePartyParameters).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InvitePartyParameters
Visual Basic
Public Class InvitePartyParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InvitePartyParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyParameters Members
ININ.IceLib.Interactions Namespace


InvitePartyParameters Members

[image] [image]

IceLib Technical Reference
InvitePartyParameters Members
InvitePartyParameters Class Constructors Methods Properties See Also Send Feedback

The InvitePartyParameters type exposes the following members.

Constructors

 | Name | Description
Public method | InvitePartyParameters(String) | Initializes a new instance of the InvitePartyParameters using a QueueId to specify the target, and initializing the CallMadeStage to the default value.
Public method | InvitePartyParameters(String, CallMadeStage) | Initializes a new instance of the InvitePartyParameters.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of InvitePartyParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CallMadeStage | Gets or sets the call made stage.
Public property | Target | Gets or sets the target.

See Also

InvitePartyParameters Class
ININ.IceLib.Interactions Namespace


InvitePartyParameters Constructor

[image] [image]

IceLib Technical Reference
InvitePartyParameters Constructor
InvitePartyParameters Class See Also Send Feedback
Initializes a new instance of the InvitePartyParameters.

Overload List

 | Name | Description
Public method | InvitePartyParameters(String) | Initializes a new instance of the InvitePartyParameters using a QueueId to specify the target, and initializing the CallMadeStage to the default value.
Public method | InvitePartyParameters(String, CallMadeStage) | Initializes a new instance of the InvitePartyParameters.

See Also

InvitePartyParameters Class
InvitePartyParameters Members
ININ.IceLib.Interactions Namespace


InvitePartyParameters Constructor (String)

[image]

IceLib Technical Reference
InvitePartyParameters Constructor (String)
InvitePartyParameters Class See Also Send Feedback
Initializes a new instance of the InvitePartyParameters using a QueueId to specify the target, and initializing the CallMadeStage to the default value.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvitePartyParameters(
    string target
)
Visual Basic
Public Sub New ( _
    target As String _
)

Parameters

target
Type: System..::..String
The target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyParameters Class
InvitePartyParameters Members
InvitePartyParameters Overload
ININ.IceLib.Interactions Namespace


InvitePartyParameters Constructor (String, CallMadeStage)

[image]

IceLib Technical Reference
InvitePartyParameters Constructor (String, CallMadeStage)
InvitePartyParameters Class See Also Send Feedback
Initializes a new instance of the InvitePartyParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InvitePartyParameters(
    string target,
    CallMadeStage callMadeStage
)
Visual Basic
Public Sub New ( _
    target As String, _
    callMadeStage As CallMadeStage _
)

Parameters

target
Type: System..::..String
The target.
callMadeStage
Type: ININ.IceLib.Interactions..::..CallMadeStage
Specifies when to raise the CallMade event.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyParameters Class
InvitePartyParameters Members
InvitePartyParameters Overload
ININ.IceLib.Interactions Namespace


InvitePartyParameters Methods

[image] [image]

IceLib Technical Reference
InvitePartyParameters Methods
InvitePartyParameters Class See Also Send Feedback

The InvitePartyParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of InvitePartyParameters. (Overrides Object..::..ToString()()()().)

See Also

InvitePartyParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
InvitePartyParameters..::..ToString Method
InvitePartyParameters Class See Also Send Feedback
Gets the string representation of InvitePartyParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyParameters Class
InvitePartyParameters Members
ININ.IceLib.Interactions Namespace


InvitePartyParameters Properties

[image] [image]

IceLib Technical Reference
InvitePartyParameters Properties
InvitePartyParameters Class See Also Send Feedback

The InvitePartyParameters type exposes the following members.

Properties

 | Name | Description
Public property | CallMadeStage | Gets or sets the call made stage.
Public property | Target | Gets or sets the target.

See Also

InvitePartyParameters Class
ININ.IceLib.Interactions Namespace


CallMadeStage Property

[image]

IceLib Technical Reference
InvitePartyParameters..::..CallMadeStage Property
InvitePartyParameters Class See Also Send Feedback
Gets or sets the call made stage.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallMadeStage CallMadeStage { get; set; }
Visual Basic
Public Property CallMadeStage As CallMadeStage
    Get
    Set

Field Value

Specifies when to raise the CallMade event.

Remarks

Note
CallMadeStage.Started is not supported for this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyParameters Class
InvitePartyParameters Members
ININ.IceLib.Interactions Namespace


Target Property

[image]

IceLib Technical Reference
InvitePartyParameters..::..Target Property
InvitePartyParameters Class See Also Send Feedback
Gets or sets the target.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Target { get; set; }
Visual Basic
Public Property Target As String
    Get
    Set

Field Value

The target.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The target parameter was null.
System..::..ArgumentException | The target parameter was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InvitePartyParameters Class
InvitePartyParameters Members
ININ.IceLib.Interactions Namespace


IsdnCauseCode Enumeration

[image]

IceLib Technical Reference
IsdnCauseCode Enumeration
See Also Send Feedback
ISDN Cause Codes that may have been returned when placing a call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum IsdnCauseCode
Visual Basic
Public Enumeration IsdnCauseCode

Members

Member name | Value | Description
None | 0 | No cause code.
UnassignedNumber_001 | 1 | Unassigned number (ISDN Cause Code 01).
NoRouteToSpecifiedTransitNetwork_002 | 2 | No route to specified transit network (ISDN Cause Code 02).
NoRouteToDestination_003 | 3 | No route to destination (ISDN Cause Code 03).
ChannelUnacceptable_006 | 6 | Channel unacceptable (ISDN Cause Code 06).
NormalCallClearing_016 | 16 | Normal call clearing (ISDN Cause Code 16).
RemoteBusy_017 | 17 | Remote busy (ISDN Cause Code 17).
NoUserResponding_018 | 18 | No user responding (ISDN Cause Code 18).
UserAlertingNoAnswer_019 | 19 | User alerting no answer (ISDN Cause Code 19).
CallRejected_021 | 21 | Call rejected (ISDN Cause Code 21).
NumberChanged_022 | 22 | Number changed (ISDN Cause Code 22).
DestinationOutOfOrder_027 | 27 | Destination out-of-order (ISDN Cause Code 27).
InvalidNumberFormat_028 | 28 | Invalid number format (ISDN Cause Code 28).
FacilityRejected_029 | 29 | Facility rejected (ISDN Cause Code 29).
ResponseToStatusInquiry_030 | 30 | Response to status inquiry (ISDN Cause Code 30).
NormalUnspecified_031 | 31 | Normal, unpecified (ISDN Cause Code 31).
NoChannelAvailable_034 | 34 | No channel available (ISDN Cause Code 34).
NetworkOutOfOrder_038 | 38 | Network out-of-order (ISDN Cause Code 38).
TemporaryFailure_041 | 41 | Temporary failure (ISDN Cause Code 41).
SwitchingEquipmentCongestion_042 | 42 | Switching equipment congestion (ISDN Cause Code 42).
AccessInformationDiscarded_043 | 43 | Access information discarded (ISDN Cause Code 43).
RequestedChannelNotAvailable_044 | 44 | Requested channel not available (ISDN Cause Code 44).
PreEmpted_045 | 45 | Pre-empted (ISDN Cause Code 45).
RequestFacilityNotSubscribed_050 | 50 | Request facility not subscribed (ISDN Cause Code 50).
OutgoingCallsBarred_052 | 52 | Outgoing calls barred (ISDN Cause Code 52).
IncomingCallsBarred_054 | 54 | Incoming calls barred (ISDN Cause Code 54).
BearerCapabilityNotAuthorized_057 | 57 | Bearer capability not presently authorized (ISDN Cause Code 57).
BearerCapabilityNotAvailable_058 | 58 | Bearer capability not presently available (ISDN Cause Code 58).
ServiceNotAvailableUnspecified_063 | 63 | Service or option not available, unspecified (ISDN Cause Code 63).
CapabilityNotImplemented_065 | 65 | Bearer capability not implemented (ISDN Cause Code 65).
ChannelTypeNotImplemented_066 | 66 | Channel type not implemented (ISDN Cause Code 66).
RequestFacilityNotImplemented_069 | 69 | Request facility not implemented (ISDN Cause Code 69).
InvalidCallReferenceValue_081 | 81 | Invalid call reference value (ISDN Cause Code 81).
IdentifiedChannelDoesNotExist_082 | 82 | Identified channel does not exist (ISDN Cause Code 82).
IncompatibleDestination_088 | 88 | Incompatible destination (ISDN Cause Code 88).
InvalidMessageUnspecified_095 | 95 | Invalid message, unspecified (ISDN Cause Code 95).
MandatoryInformationElementMissing_096 | 96 | Mandatory information element missing (ISDN Cause Code 96).
MessageTypeNonexistent_097 | 97 | Message type nonexistent or not implemented (ISDN Cause Code 97).
MessageNotCompatibleWithCallState_098 | 98 | Message not compatible with call state, or message type is nonexistent (ISDN Cause Code 98).
InformationElementNonexistent_099 | 99 | Information element nonexistent or not implemented (ISDN Cause Code 99).
InvalidInformationElementContents_100 | 100 | Invalid information element contents (ISDN Cause Code 100).
MessageNotCompatibleWithCallState_101 | 101 | Message not compatible with call state (ISDN Cause Code 101).
RecoveryOnTimerExpiry_102 | 102 | Recovery on timer expiry (ISDN Cause Code 102).
MandatoryInformationElementLengthError_103 | 103 | Mandatory information element length error (ISDN Cause Code 103).
ProtocolErrorUnspecified_111 | 111 | Protocol error, unspecified (ISDN Cause Code 111).
InterworkingUnspecified_127 | 127 | Interworking, unspecified (ISDN Cause Code 127).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.
For 2.4, supported for IC Server version 2.4 SU 35 and beyond.

See Also

ININ.IceLib.Interactions Namespace
InteractionsManager..::..MakeCall(CallInteractionParameters)


MakeCallbackInteractionCompletedEventArgs Class

[image]

IceLib Technical Reference
MakeCallbackInteractionCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the MakeCallbackInteractionAsync(CallbackInteractionParameters, EventHandler<(Of <<'(MakeCallbackInteractionCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MakeCallbackInteractionCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class MakeCallbackInteractionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..MakeCallbackInteractionCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

MakeCallbackInteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeCallbackInteractionCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
MakeCallbackInteractionCompletedEventArgs Members
MakeCallbackInteractionCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The MakeCallbackInteractionCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MakeCallbackInteractionCompletedEventArgs | Initializes a new instance of the MakeCallbackInteractionCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallbackInteraction | Gets the GenericInteraction associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeCallbackInteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeCallbackInteractionCompletedEventArgs Constructor

[image]

IceLib Technical Reference
MakeCallbackInteractionCompletedEventArgs Constructor
MakeCallbackInteractionCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeCallbackInteractionCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeCallbackInteractionCompletedEventArgs(
    CallbackInteraction callbackInteraction,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    callbackInteraction As CallbackInteraction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

callbackInteraction
Type: ININ.IceLib.Interactions..::..CallbackInteraction
The CallbackInteraction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

MakeCallbackInteractionCompletedEventArgs Class
MakeCallbackInteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeCallbackInteractionCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
MakeCallbackInteractionCompletedEventArgs Methods
MakeCallbackInteractionCompletedEventArgs Class See Also Send Feedback

The MakeCallbackInteractionCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeCallbackInteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeCallbackInteractionCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
MakeCallbackInteractionCompletedEventArgs Properties
MakeCallbackInteractionCompletedEventArgs Class See Also Send Feedback

The MakeCallbackInteractionCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CallbackInteraction | Gets the GenericInteraction associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeCallbackInteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


CallbackInteraction Property

[image]

IceLib Technical Reference
MakeCallbackInteractionCompletedEventArgs..::..CallbackInteraction Property
MakeCallbackInteractionCompletedEventArgs Class See Also Send Feedback
Gets the GenericInteraction associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallbackInteraction CallbackInteraction { get; }
Visual Basic
Public ReadOnly Property CallbackInteraction As CallbackInteraction
    Get

Field Value

The generic interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

MakeCallbackInteractionCompletedEventArgs Class
MakeCallbackInteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeCallException Class

[image]

IceLib Technical Reference
MakeCallException Class
Members See Also Send Feedback
This exception is thrown by various MakeCall methods of InteractionsManager when the server is unable to make a call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class MakeCallException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class MakeCallException _
    Inherits IceLibException

Remarks

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

This exception that is thrown for IceLib when one of the following methods fail.

  • MakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)
  • MakeCall(CallInteractionParameters)
  • ConsultMakeCall(String, CallMadeStage)
  • ConsultMakeCall(QueueId, CallMadeStage)
  • ConsultMakeCall(CallInteractionParameters)
  • ConsultMakeCallAsync(String, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)
  • ConsultMakeCallAsync(QueueId, CallMadeStage, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)
  • ConsultMakeCallAsync(CallInteractionParameters, EventHandler<(Of <<'(InteractionCompletedEventArgs>)>>), Object)

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.Interactions..::..MakeCallException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.
For 2.4, supported for IC Server version 2.4 SU 35 and beyond.

See Also

MakeCallException Members
ININ.IceLib.Interactions Namespace


MakeCallException Members

[image] [image]

IceLib Technical Reference
MakeCallException Members
MakeCallException Class Methods Properties Events See Also Send Feedback

The MakeCallException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Interaction | Gets the Interaction associated with the change.
Public property | IsdnCauseCode | Gets the ISDN cause code that may have been returned by the equipment when making the call.
Public property | MakeCallFailureCode | Gets the call failure code returned by the server when attempting to make the call.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MakeCallException Class
ININ.IceLib.Interactions Namespace


MakeCallException Methods

[image] [image]

IceLib Technical Reference
MakeCallException Methods
MakeCallException Class See Also Send Feedback

The MakeCallException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MakeCallException Class
ININ.IceLib.Interactions Namespace


MakeCallException Properties

[image] [image]

IceLib Technical Reference
MakeCallException Properties
MakeCallException Class See Also Send Feedback

The MakeCallException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Interaction | Gets the Interaction associated with the change.
Public property | IsdnCauseCode | Gets the ISDN cause code that may have been returned by the equipment when making the call.
Public property | MakeCallFailureCode | Gets the call failure code returned by the server when attempting to make the call.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MakeCallException Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
MakeCallException..::..Interaction Property
MakeCallException Class See Also Send Feedback
Gets the Interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.
For 2.4, supported for IC Server version 2.4 SU 35 and beyond.

See Also

MakeCallException Class
MakeCallException Members
ININ.IceLib.Interactions Namespace


IsdnCauseCode Property

[image]

IceLib Technical Reference
MakeCallException..::..IsdnCauseCode Property
MakeCallException Class See Also Send Feedback
Gets the ISDN cause code that may have been returned by the equipment when making the call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IsdnCauseCode IsdnCauseCode { get; }
Visual Basic
Public ReadOnly Property IsdnCauseCode As IsdnCauseCode
    Get

Field Value

The ISDN cause code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.
For 2.4, supported for IC Server version 2.4 SU 35 and beyond.

See Also

MakeCallException Class
MakeCallException Members
ININ.IceLib.Interactions Namespace


MakeCallFailureCode Property

[image]

IceLib Technical Reference
MakeCallException..::..MakeCallFailureCode Property
MakeCallException Class See Also Send Feedback
Gets the call failure code returned by the server when attempting to make the call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeCallFailureCode MakeCallFailureCode { get; }
Visual Basic
Public ReadOnly Property MakeCallFailureCode As MakeCallFailureCode
    Get

Field Value

The failure code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.
For 2.4, supported for IC Server version 2.4 SU 35 and beyond.

See Also

MakeCallException Class
MakeCallException Members
ININ.IceLib.Interactions Namespace


MakeCallException Events

[image] [image]

IceLib Technical Reference
MakeCallException Events
MakeCallException Class See Also Send Feedback

The MakeCallException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MakeCallException Class
ININ.IceLib.Interactions Namespace


MakeCallFailureCode Enumeration

[image]

IceLib Technical Reference
MakeCallFailureCode Enumeration
See Also Send Feedback
Call failure codes describing the results of an attempt to place a call.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MakeCallFailureCode
Visual Basic
Public Enumeration MakeCallFailureCode

Members

Member name | Value | Description
None | 0 | There was no failure code.
UnexpectedMessageFormat | 1 | The response to the make call request used an unexpected message format.
Authentication | 2 | Failed to authenticate the request to make call.
Cancelled | 3 | The command was cancelled.
Timeout | 4 | The command timeout period elapsed.
InvalidVersion | 5 | The version of the message protocol used in the response was invalid.
InvalidApiVersion | 6 | Command attempted to use an invalid Telephony Service API Version.
NoneRunningAsync | 7 | No error occurred, the comamnd is running asynchronously.
CallDoesNotExist | 8 | The call no longer exists.
QueueNotFound | 9 | The requested queue was not found.
InvalidQueue | 10 | The requested queue is invalid.
InvalidStation | 11 | The requested station is invalid.
StationNotActive | 12 | The requested station is not active.
ConferenceDoesNotExist | 13 | The requested conference no longer exists.
ConferenceNotEmpty | 14 | The requested conference is not empty.
ActiveNotInterrupted | 15 | The active call was not interrupted.
InvalidLine | 16 | The requested line was invalid.
LineNotActive | 17 | The requested line was not active.
LineAlreadyUsedByStation | 18 | The line is already in use by station.
NoStationVolume | 19 | The requested station does not support volume control.
MaximumNumberOfCallAppearancesReached | 20 | The maximum number of call appearances has been reached.
NoVoiceResource | 21 | No voice resources were available.
NoConferenceResource | 22 | No conference resources were available.
NoIpResource | 23 | No IP resources were available.
InvalidCallState | 24 | The call is in an invalid state.
InvalidLineState | 25 | The line is in an invalid state.
InvalidCallType | 26 | The call type is not valid.
TargetSelf | 27 | Call targeted self.
InvalidStationState | 28 | The station is in an invalid state.
InvalidNumber | 29 | The requested number is invalid.
OutboundCallLimitExceeded | 30 | The outbound call limit has been exceeded.
NoAnswer | 31 | The call was not answered.
NoRingback | 32 | No ringback was received on the call.
NoDialTone | 33 | No tone was present on the call.
NormalBusy | 34 | The call received a normal busy signal.
NoCircuitAvailable | 35 | No circuits were available to complete the call.
OperatorIntercept | 36 | The call was intercepted by an operator.
AnsweringMachineConnection | 37 | The call failed due to an answering machine connection.
DestinationNotReachedUnknown | 38 | The destination could not be reached for an unknown reason.
NoRemoteFaxTone | 39 | A fax tone was not detected on the remote connection.
NoAvailableVMSession | 40 | No available VM session.
NoLinesAvailable | 41 | There were no lines available to make the call.
StationNotReached | 42 | The station is unreachable.
StationNotReachedNoAnswer | 43 | There was no answer on the line used to contact the station.
StationNotReachedNoRingback | 44 | There was no ringback on the line used to contact the station.
StationNotReachedNoDialTone | 45 | There was no dial tone on the line used to contact the station.
StationNotReachedBusy | 46 | The station was busy.
StationNotReachedSitToneDetected | 47 | A special information tone (SIT) was detected when contacting the station.
StationNotReachedNoCircuitsAvailable | 48 | There were no circuits available to contact the station.
StationNotReachedOperatorIntercept | 49 | An operator intercept occurred on the line used to contact the station.
StationNotReachedNoIpResponse | 50 | There was no IP response on the line used to contact the station.
NoIpResponse | 51 | Obsolete. Use StationNotReachedNoIpResponse instead.
StationNotReachedNoLinesAvailable | 52 | There were no lines available to contact the station.
Private | 53 | The call is private.
NotPrivate | 54 | The call is not private.
AlreadyPrivate | 55 | The call is already private.
NotMuted | 56 | The call is not muted.
AlreadyMuted | 57 | The call is already muted.
MuteIntercom | 58 | Cannot mute an intercom call.
General | 59 | A general telephony failure.
OrbitInUse | 60 | Park orbit already in use.
ReOrder | 61 | A re-order (fast busy) tone was detected.
Rfc2833Required | 62 | RFC 2833 is required.
SitToneDetected | 63 | A Special Information Tone (SIT) was detected on the line used to contact the station.
SubsystemFailure | 64 | There was a subsystem failure that caused the call to fail.
RtpCodecNotSupported | 65 | Obsolete. The RTP Codec is not supported.
DialplanError | 66 | Obsolete. The call was disconnected due to a dial plan error.
InsufficientDialingPrivileges | 67 | Obsolete. The Call was disconnected due to insufficient dialing privileges.
UnrecognizedError | 68 | The error code did not map to an existing MakeCallFailureCode.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.
For 2.4, supported for IC Server version 2.4 SU 35 and beyond.

See Also

ININ.IceLib.Interactions Namespace
InteractionsManager..::..MakeCall(CallInteractionParameters)


MakeChatCompletedEventArgs Class

[image]

IceLib Technical Reference
MakeChatCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the MakeChatAsync(String, EventHandler<(Of <<'(MakeChatCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MakeChatCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class MakeChatCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..MakeChatCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeChatCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeChatCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
MakeChatCompletedEventArgs Members
MakeChatCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The MakeChatCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MakeChatCompletedEventArgs | Initializes a new instance of the MakeChatCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | ChatInteraction | Gets the ChatInteraction associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeChatCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeChatCompletedEventArgs Constructor

[image]

IceLib Technical Reference
MakeChatCompletedEventArgs Constructor
MakeChatCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeChatCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeChatCompletedEventArgs(
    ChatInteraction chatInteraction,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    chatInteraction As ChatInteraction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

chatInteraction
Type: ININ.IceLib.Interactions..::..ChatInteraction
The ChatInteraction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeChatCompletedEventArgs Class
MakeChatCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeChatCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
MakeChatCompletedEventArgs Methods
MakeChatCompletedEventArgs Class See Also Send Feedback

The MakeChatCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeChatCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeChatCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
MakeChatCompletedEventArgs Properties
MakeChatCompletedEventArgs Class See Also Send Feedback

The MakeChatCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | ChatInteraction | Gets the ChatInteraction associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeChatCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


ChatInteraction Property

[image]

IceLib Technical Reference
MakeChatCompletedEventArgs..::..ChatInteraction Property
MakeChatCompletedEventArgs Class See Also Send Feedback
Gets the ChatInteraction associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChatInteraction ChatInteraction { get; }
Visual Basic
Public ReadOnly Property ChatInteraction As ChatInteraction
    Get

Field Value

The chat interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeChatCompletedEventArgs Class
MakeChatCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeConsultTransferCompletedEventArgs Class

[image]

IceLib Technical Reference
MakeConsultTransferCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the MakeConsultTransferAsync(ConsultTransferParameters, EventHandler<(Of <<'(MakeConsultTransferCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MakeConsultTransferCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class MakeConsultTransferCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..MakeConsultTransferCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MakeConsultTransferCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeConsultTransferCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
MakeConsultTransferCompletedEventArgs Members
MakeConsultTransferCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The MakeConsultTransferCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MakeConsultTransferCompletedEventArgs | Initializes a new instance of the MakeConsultTransferCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | ConsultTransfer | Gets the ConsultTransfer associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeConsultTransferCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeConsultTransferCompletedEventArgs Constructor

[image]

IceLib Technical Reference
MakeConsultTransferCompletedEventArgs Constructor
MakeConsultTransferCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeConsultTransferCompletedEventArgs class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeConsultTransferCompletedEventArgs(
    ConsultTransfer consultTransfer,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    consultTransfer As ConsultTransfer, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

consultTransfer
Type: ININ.IceLib.Interactions..::..ConsultTransfer
The ConsultTransfer.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
Not currently supported.
userState
Type: System..::..Object
The user-supplied object to be passed to the asynchronous password policy operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MakeConsultTransferCompletedEventArgs Class
MakeConsultTransferCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeConsultTransferCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
MakeConsultTransferCompletedEventArgs Methods
MakeConsultTransferCompletedEventArgs Class See Also Send Feedback

The MakeConsultTransferCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeConsultTransferCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeConsultTransferCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
MakeConsultTransferCompletedEventArgs Properties
MakeConsultTransferCompletedEventArgs Class See Also Send Feedback

The MakeConsultTransferCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | ConsultTransfer | Gets the ConsultTransfer associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeConsultTransferCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


ConsultTransfer Property

[image]

IceLib Technical Reference
MakeConsultTransferCompletedEventArgs..::..ConsultTransfer Property
MakeConsultTransferCompletedEventArgs Class See Also Send Feedback
Gets the ConsultTransfer associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConsultTransfer ConsultTransfer { get; }
Visual Basic
Public ReadOnly Property ConsultTransfer As ConsultTransfer
    Get

Field Value

The consult transfer.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MakeConsultTransferCompletedEventArgs Class
MakeConsultTransferCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeEmailCompletedEventArgs Class

[image]

IceLib Technical Reference
MakeEmailCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the MakeEmailAsync(EmailInteractionParameters, EventHandler<(Of <<'(MakeEmailCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MakeEmailCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class MakeEmailCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..MakeEmailCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

MakeEmailCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeEmailCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
MakeEmailCompletedEventArgs Members
MakeEmailCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The MakeEmailCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MakeEmailCompletedEventArgs | Initializes a new instance of the MakeEmailCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | EmailInteraction | Gets the EmailInteraction associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeEmailCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeEmailCompletedEventArgs Constructor

[image]

IceLib Technical Reference
MakeEmailCompletedEventArgs Constructor
MakeEmailCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeEmailCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeEmailCompletedEventArgs(
    EmailInteraction emailInteraction,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    emailInteraction As EmailInteraction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

emailInteraction
Type: ININ.IceLib.Interactions..::..EmailInteraction
The EmailInteraction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

MakeEmailCompletedEventArgs Class
MakeEmailCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeEmailCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
MakeEmailCompletedEventArgs Methods
MakeEmailCompletedEventArgs Class See Also Send Feedback

The MakeEmailCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeEmailCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeEmailCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
MakeEmailCompletedEventArgs Properties
MakeEmailCompletedEventArgs Class See Also Send Feedback

The MakeEmailCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | EmailInteraction | Gets the EmailInteraction associated with the event.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeEmailCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


EmailInteraction Property

[image]

IceLib Technical Reference
MakeEmailCompletedEventArgs..::..EmailInteraction Property
MakeEmailCompletedEventArgs Class See Also Send Feedback
Gets the EmailInteraction associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailInteraction EmailInteraction { get; }
Visual Basic
Public ReadOnly Property EmailInteraction As EmailInteraction
    Get

Field Value

The email interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 7 and beyond.

See Also

MakeEmailCompletedEventArgs Class
MakeEmailCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeGenericInteractionCompletedEventArgs Class

[image]

IceLib Technical Reference
MakeGenericInteractionCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the MakeGenericInteractionAsync(GenericInteractionParameters, EventHandler<(Of <<'(MakeGenericInteractionCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MakeGenericInteractionCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class MakeGenericInteractionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..MakeGenericInteractionCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeGenericInteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeGenericInteractionCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
MakeGenericInteractionCompletedEventArgs Members
MakeGenericInteractionCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The MakeGenericInteractionCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MakeGenericInteractionCompletedEventArgs | Initializes a new instance of the MakeGenericInteractionCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | GenericInteraction | Gets the GenericInteraction associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeGenericInteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeGenericInteractionCompletedEventArgs Constructor

[image]

IceLib Technical Reference
MakeGenericInteractionCompletedEventArgs Constructor
MakeGenericInteractionCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeGenericInteractionCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeGenericInteractionCompletedEventArgs(
    GenericInteraction genericInteraction,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    genericInteraction As GenericInteraction, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

genericInteraction
Type: ININ.IceLib.Interactions..::..GenericInteraction
The GenericInteraction.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeGenericInteractionCompletedEventArgs Class
MakeGenericInteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeGenericInteractionCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
MakeGenericInteractionCompletedEventArgs Methods
MakeGenericInteractionCompletedEventArgs Class See Also Send Feedback

The MakeGenericInteractionCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeGenericInteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeGenericInteractionCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
MakeGenericInteractionCompletedEventArgs Properties
MakeGenericInteractionCompletedEventArgs Class See Also Send Feedback

The MakeGenericInteractionCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | GenericInteraction | Gets the GenericInteraction associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeGenericInteractionCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


GenericInteraction Property

[image]

IceLib Technical Reference
MakeGenericInteractionCompletedEventArgs..::..GenericInteraction Property
MakeGenericInteractionCompletedEventArgs Class See Also Send Feedback
Gets the GenericInteraction associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GenericInteraction GenericInteraction { get; }
Visual Basic
Public ReadOnly Property GenericInteraction As GenericInteraction
    Get

Field Value

The generic interaction.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeGenericInteractionCompletedEventArgs Class
MakeGenericInteractionCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeNewConferenceCompletedEventArgs Class

[image]

IceLib Technical Reference
MakeNewConferenceCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the MakeNewConferenceAsync(array<Interaction>[]()[][], EventHandler<(Of <<'(MakeNewConferenceCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MakeNewConferenceCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class MakeNewConferenceCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..MakeNewConferenceCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeNewConferenceCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeNewConferenceCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
MakeNewConferenceCompletedEventArgs Members
MakeNewConferenceCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The MakeNewConferenceCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MakeNewConferenceCompletedEventArgs | Initializes a new instance of the MakeNewConferenceCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionConference | Gets the InteractionConference associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeNewConferenceCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeNewConferenceCompletedEventArgs Constructor

[image]

IceLib Technical Reference
MakeNewConferenceCompletedEventArgs Constructor
MakeNewConferenceCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MakeNewConferenceCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MakeNewConferenceCompletedEventArgs(
    InteractionConference interactionConference,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    interactionConference As InteractionConference, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

interactionConference
Type: ININ.IceLib.Interactions..::..InteractionConference
The interaction conference.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeNewConferenceCompletedEventArgs Class
MakeNewConferenceCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MakeNewConferenceCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
MakeNewConferenceCompletedEventArgs Methods
MakeNewConferenceCompletedEventArgs Class See Also Send Feedback

The MakeNewConferenceCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeNewConferenceCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


MakeNewConferenceCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
MakeNewConferenceCompletedEventArgs Properties
MakeNewConferenceCompletedEventArgs Class See Also Send Feedback

The MakeNewConferenceCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionConference | Gets the InteractionConference associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

MakeNewConferenceCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


InteractionConference Property

[image]

IceLib Technical Reference
MakeNewConferenceCompletedEventArgs..::..InteractionConference Property
MakeNewConferenceCompletedEventArgs Class See Also Send Feedback
Gets the InteractionConference associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionConference InteractionConference { get; }
Visual Basic
Public ReadOnly Property InteractionConference As InteractionConference
    Get

Field Value

The interaction conference.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MakeNewConferenceCompletedEventArgs Class
MakeNewConferenceCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


MonitoredQueueAlerting Class

[image]

IceLib Technical Reference
MonitoredQueueAlerting Class
Members See Also Send Feedback
This class provides the main interface to enable alerting on a monitored queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MonitoredQueueAlerting
Visual Basic
Public Class MonitoredQueueAlerting

Remarks

A monitored queue (monitored appearance) can be configured to track interactions of other users. MonitoredQueueAlerting provides an interface for enabling and disabling alerting on a monitored queue. When enabling or disabling a monitored queue, MonitoredQueueAlertMode controls if the alert should be silent or if the phone should ring.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..MonitoredQueueAlerting

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MonitoredQueueAlerting Members
ININ.IceLib.Interactions Namespace


MonitoredQueueAlerting Members

[image] [image]

IceLib Technical Reference
MonitoredQueueAlerting Members
MonitoredQueueAlerting Class Constructors Methods See Also Send Feedback

The MonitoredQueueAlerting type exposes the following members.

Constructors

 | Name | Description
Public method | MonitoredQueueAlerting | Initializes a new instance of the MonitoredQueueAlerting class.

Methods

 | Name | Description
Public method | DisableAlerting | Disables alerting on the given list of monitored queues.
Public method | DisableAlertingAsync | Asynchronously disables alerting on the given list of monitored queues.
Public method | EnableAlerting | Enables alerting on the given list of monitored queues.
Public method | EnableAlertingAsync | Asynchronously enables alerting on the given list of monitored queues.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonitoredQueueAlerting Class
ININ.IceLib.Interactions Namespace


MonitoredQueueAlerting Constructor

[image]

IceLib Technical Reference
MonitoredQueueAlerting Constructor
MonitoredQueueAlerting Class See Also Send Feedback
Initializes a new instance of the MonitoredQueueAlerting class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MonitoredQueueAlerting(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MonitoredQueueAlerting Class
MonitoredQueueAlerting Members
ININ.IceLib.Interactions Namespace


MonitoredQueueAlerting Methods

[image] [image]

IceLib Technical Reference
MonitoredQueueAlerting Methods
MonitoredQueueAlerting Class See Also Send Feedback

The MonitoredQueueAlerting type exposes the following members.

Methods

 | Name | Description
Public method | DisableAlerting | Disables alerting on the given list of monitored queues.
Public method | DisableAlertingAsync | Asynchronously disables alerting on the given list of monitored queues.
Public method | EnableAlerting | Enables alerting on the given list of monitored queues.
Public method | EnableAlertingAsync | Asynchronously enables alerting on the given list of monitored queues.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonitoredQueueAlerting Class
ININ.IceLib.Interactions Namespace


DisableAlerting Method

[image]

IceLib Technical Reference
MonitoredQueueAlerting..::..DisableAlerting Method
MonitoredQueueAlerting Class See Also Send Feedback
Disables alerting on the given list of monitored queues.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DisableAlerting(
    IEnumerable<string> scopedQueueNames,
    MonitoredQueueAlertMode alertMode
)
Visual Basic
Public Sub DisableAlerting ( _
    scopedQueueNames As IEnumerable(Of String), _
    alertMode As MonitoredQueueAlertMode _
)

Parameters

scopedQueueNames
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of the scoped queue names for which alerting will be disabled.
alertMode
Type: ININ.IceLib.Interactions..::..MonitoredQueueAlertMode
Alerting is silent if set to AlertSilently.

Exceptions

Exception | Condition
System..::..ArgumentException | scopedQueueNames is empty.
System..::..ArgumentNullException | One or more arguments was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | This exception occurs when alertMode is not from the MonitoredQueueAlertMode enumeration.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MonitoredQueueAlerting Class
MonitoredQueueAlerting Members
ININ.IceLib.Interactions Namespace


DisableAlertingAsync Method

[image]

IceLib Technical Reference
MonitoredQueueAlerting..::..DisableAlertingAsync Method
MonitoredQueueAlerting Class See Also Send Feedback
Asynchronously disables alerting on the given list of monitored queues.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DisableAlertingAsync(
    IEnumerable<string> scopedQueueNames,
    MonitoredQueueAlertMode alertMode,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DisableAlertingAsync ( _
    scopedQueueNames As IEnumerable(Of String), _
    alertMode As MonitoredQueueAlertMode, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

scopedQueueNames
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of the scoped queue names for which alerting will be disabled.
alertMode
Type: ININ.IceLib.Interactions..::..MonitoredQueueAlertMode
Alerting is silent if set to AlertSilently.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Exceptions

Exception | Condition
System..::..ArgumentException | scopedQueueNames is empty.
System..::..ArgumentNullException | One or more arguments was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | This exception occurs when alertMode is not from the MonitoredQueueAlertMode enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MonitoredQueueAlerting Class
MonitoredQueueAlerting Members
ININ.IceLib.Interactions Namespace


EnableAlerting Method

[image]

IceLib Technical Reference
MonitoredQueueAlerting..::..EnableAlerting Method
MonitoredQueueAlerting Class See Also Send Feedback
Enables alerting on the given list of monitored queues.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EnableAlerting(
    IEnumerable<string> scopedQueueNames,
    MonitoredQueueAlertMode alertMode
)
Visual Basic
Public Sub EnableAlerting ( _
    scopedQueueNames As IEnumerable(Of String), _
    alertMode As MonitoredQueueAlertMode _
)

Parameters

scopedQueueNames
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of the scoped queue names for which alerting will be enabled.
alertMode
Type: ININ.IceLib.Interactions..::..MonitoredQueueAlertMode
Alerting is silent if set to AlertSilently.

Exceptions

Exception | Condition
System..::..ArgumentException | scopedQueueNames is empty.
System..::..ArgumentNullException | One or more arguments was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | This exception occurs when alertMode is not from the MonitoredQueueAlertMode enumeration.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MonitoredQueueAlerting Class
MonitoredQueueAlerting Members
ININ.IceLib.Interactions Namespace


EnableAlertingAsync Method

[image]

IceLib Technical Reference
MonitoredQueueAlerting..::..EnableAlertingAsync Method
MonitoredQueueAlerting Class See Also Send Feedback
Asynchronously enables alerting on the given list of monitored queues.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EnableAlertingAsync(
    IEnumerable<string> scopedQueueNames,
    MonitoredQueueAlertMode alertMode,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EnableAlertingAsync ( _
    scopedQueueNames As IEnumerable(Of String), _
    alertMode As MonitoredQueueAlertMode, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

scopedQueueNames
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of the scoped queue names for which alerting will be enabled.
alertMode
Type: ININ.IceLib.Interactions..::..MonitoredQueueAlertMode
Alerting is silent if set to AlertSilently.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Exceptions

Exception | Condition
System..::..ArgumentException | scopedQueueNames is empty.
System..::..ArgumentNullException | One or more arguments was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | This exception occurs when alertMode is not from the MonitoredQueueAlertMode enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MonitoredQueueAlerting Class
MonitoredQueueAlerting Members
ININ.IceLib.Interactions Namespace


MonitoredQueueAlertMode Enumeration

[image]

IceLib Technical Reference
MonitoredQueueAlertMode Enumeration
See Also Send Feedback
Specifies if an alert should be a silent alert or not.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MonitoredQueueAlertMode
Visual Basic
Public Enumeration MonitoredQueueAlertMode

Members

Member name | Value | Description
AlertSilently | 0 | The alert on the monitored queue does not cause the phone to ring.
RingTelephone | 1 | The alert on the monitored queue causes the phone to ring.

Remarks

This enumeration is used by MonitoredQueueAlerting to determine if an event on a monitored queue should cause the phone to ring.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


MonitorInteraction Class

[image]

IceLib Technical Reference
MonitorInteraction Class
Members See Also Send Feedback
Represents a monitor interaction within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MonitorInteraction : Interaction
Visual Basic
Public Class MonitorInteraction _
    Inherits Interaction

Remarks

Interactions in the Interaction Center system can be calls, chats, emails, email, monitors, or recordings. Objects of this class represent interactions in which a user is monitoring another user's interaction. These objects are part of an interaction queue watch.

Note
Accessing the properties of this class when an interaction watch is not in place raises a NotCachedException.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..MonitorInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteraction Members
ININ.IceLib.Interactions Namespace


MonitorInteraction Members

[image] [image]

IceLib Technical Reference
MonitorInteraction Members
MonitorInteraction Class Constructors Methods Properties Events See Also Send Feedback

The MonitorInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | MonitorInteraction | Initializes a new instance of the MonitorInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | MonitoredInteractionId | Gets the MonitoredInteractionId.
Public property | MonitoredInteractionType | Gets the MonitoredInteractionType.
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

MonitorInteraction Class
ININ.IceLib.Interactions Namespace


MonitorInteraction Constructor

[image]

IceLib Technical Reference
MonitorInteraction Constructor
MonitorInteraction Class See Also Send Feedback
Initializes a new instance of the MonitorInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MonitorInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteraction Class
MonitorInteraction Members
ININ.IceLib.Interactions Namespace


MonitorInteraction Methods

[image] [image]

IceLib Technical Reference
MonitorInteraction Methods
MonitorInteraction Class See Also Send Feedback

The MonitorInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

MonitorInteraction Class
ININ.IceLib.Interactions Namespace


MonitorInteraction Properties

[image] [image]

IceLib Technical Reference
MonitorInteraction Properties
MonitorInteraction Class See Also Send Feedback

The MonitorInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | MonitoredInteractionId | Gets the MonitoredInteractionId.
Public property | MonitoredInteractionType | Gets the MonitoredInteractionType.
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

MonitorInteraction Class
ININ.IceLib.Interactions Namespace


MonitoredInteractionId Property

[image]

IceLib Technical Reference
MonitorInteraction..::..MonitoredInteractionId Property
MonitorInteraction Class See Also Send Feedback
Gets the MonitoredInteractionId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId MonitoredInteractionId { get; }
Visual Basic
Public ReadOnly Property MonitoredInteractionId As InteractionId
    Get

Field Value

The monitored interaction ID.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteraction Class
MonitorInteraction Members
ININ.IceLib.Interactions Namespace


MonitoredInteractionType Property

[image]

IceLib Technical Reference
MonitorInteraction..::..MonitoredInteractionType Property
MonitorInteraction Class See Also Send Feedback
Gets the MonitoredInteractionType.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionType MonitoredInteractionType { get; }
Visual Basic
Public ReadOnly Property MonitoredInteractionType As InteractionType
    Get

Field Value

The type of monitored interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteraction Class
MonitorInteraction Members
ININ.IceLib.Interactions Namespace


MonitorInteraction Events

[image] [image]

IceLib Technical Reference
MonitorInteraction Events
MonitorInteraction Class See Also Send Feedback

The MonitorInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

MonitorInteraction Class
ININ.IceLib.Interactions Namespace


MonitorInteractionAttributeName Class

[image]

IceLib Technical Reference
MonitorInteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with the MonitorInteractions class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class MonitorInteractionAttributeName : InteractionAttributeName
Visual Basic
Public MustInherit Class MonitorInteractionAttributeName _
    Inherits InteractionAttributeName

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.Interactions..::..MonitorInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


MonitorInteractionAttributeName Members

[image] [image]

IceLib Technical Reference
MonitorInteractionAttributeName Members
MonitorInteractionAttributeName Class Methods Fields See Also Send Feedback

The MonitorInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MonitoredInteractionId | The monitored interaction ID.
MonitoredInteractionType | The type of monitored interaction.

See Also

MonitorInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


MonitorInteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
MonitorInteractionAttributeName Fields
MonitorInteractionAttributeName Class See Also Send Feedback

The MonitorInteractionAttributeName type exposes the following members.

Fields

Name | Description
MonitoredInteractionId | The monitored interaction ID.
MonitoredInteractionType | The type of monitored interaction.

See Also

MonitorInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


MonitoredInteractionId Field

[image]

IceLib Technical Reference
MonitorInteractionAttributeName..::..MonitoredInteractionId Field
MonitorInteractionAttributeName Class See Also Send Feedback
The monitored interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MonitoredInteractionId
Visual Basic
Public Shared ReadOnly MonitoredInteractionId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteractionAttributeName Class
MonitorInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


MonitoredInteractionType Field

[image]

IceLib Technical Reference
MonitorInteractionAttributeName..::..MonitoredInteractionType Field
MonitorInteractionAttributeName Class See Also Send Feedback
The type of monitored interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MonitoredInteractionType
Visual Basic
Public Shared ReadOnly MonitoredInteractionType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MonitorInteractionAttributeName Class
MonitorInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


MonitorInteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
MonitorInteractionAttributeName Methods
MonitorInteractionAttributeName Class See Also Send Feedback

The MonitorInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonitorInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


NotificationsSuspendedEventArgs Class

[image]

IceLib Technical Reference
NotificationsSuspendedEventArgs Class
Members See Also Send Feedback
Provides data for the NotificationsSuspendedChanged notification.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NotificationsSuspendedEventArgs : EventArgs
Visual Basic
Public Class NotificationsSuspendedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..NotificationsSuspendedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

NotificationsSuspendedEventArgs Members
ININ.IceLib.Interactions Namespace


NotificationsSuspendedEventArgs Members

[image] [image]

IceLib Technical Reference
NotificationsSuspendedEventArgs Members
NotificationsSuspendedEventArgs Class Constructors Methods Properties See Also Send Feedback

The NotificationsSuspendedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationsSuspendedEventArgs | Initializes a new instance of the NotificationsSuspendedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalInformation | Gets the additional information.
Public property | IsSuspended | Gets a value indicating whether the notifications for the associated queue are suspended.

See Also

NotificationsSuspendedEventArgs Class
ININ.IceLib.Interactions Namespace


NotificationsSuspendedEventArgs Constructor

[image]

IceLib Technical Reference
NotificationsSuspendedEventArgs Constructor
NotificationsSuspendedEventArgs Class See Also Send Feedback
Initializes a new instance of the NotificationsSuspendedEventArgs class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotificationsSuspendedEventArgs(
    bool isSuspended,
    string additionalInformation
)
Visual Basic
Public Sub New ( _
    isSuspended As Boolean, _
    additionalInformation As String _
)

Parameters

isSuspended
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) then notifications are currently suspended.
additionalInformation
Type: System..::..String
The additional information, if any (can be nullNothingnullptra null reference (Nothing in Visual Basic)).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

NotificationsSuspendedEventArgs Class
NotificationsSuspendedEventArgs Members
ININ.IceLib.Interactions Namespace


NotificationsSuspendedEventArgs Methods

[image] [image]

IceLib Technical Reference
NotificationsSuspendedEventArgs Methods
NotificationsSuspendedEventArgs Class See Also Send Feedback

The NotificationsSuspendedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationsSuspendedEventArgs Class
ININ.IceLib.Interactions Namespace


NotificationsSuspendedEventArgs Properties

[image] [image]

IceLib Technical Reference
NotificationsSuspendedEventArgs Properties
NotificationsSuspendedEventArgs Class See Also Send Feedback

The NotificationsSuspendedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalInformation | Gets the additional information.
Public property | IsSuspended | Gets a value indicating whether the notifications for the associated queue are suspended.

See Also

NotificationsSuspendedEventArgs Class
ININ.IceLib.Interactions Namespace


AdditionalInformation Property

[image]

IceLib Technical Reference
NotificationsSuspendedEventArgs..::..AdditionalInformation Property
NotificationsSuspendedEventArgs Class See Also Send Feedback
Gets the additional information.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AdditionalInformation { get; private set; }
Visual Basic
Public Property AdditionalInformation As String
    Get
    Private Set

Field Value

The additional information, if any (can be nullNothingnullptra null reference (Nothing in Visual Basic)).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

NotificationsSuspendedEventArgs Class
NotificationsSuspendedEventArgs Members
ININ.IceLib.Interactions Namespace


IsSuspended Property

[image]

IceLib Technical Reference
NotificationsSuspendedEventArgs..::..IsSuspended Property
NotificationsSuspendedEventArgs Class See Also Send Feedback
Gets a value indicating whether the notifications for the associated queue are suspended.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsSuspended { get; private set; }
Visual Basic
Public Property IsSuspended As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if the notifications are suspended; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

NotificationsSuspendedEventArgs Class
NotificationsSuspendedEventArgs Members
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Class

[image]

IceLib Technical Reference
PerformedActionEventArgs Class
Members See Also Send Feedback
Provides data for the PerformingAction event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PerformedActionEventArgs : EventArgs
Visual Basic
Public Class PerformedActionEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..PerformedActionEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformedActionEventArgs Members
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Members

[image] [image]

IceLib Technical Reference
PerformedActionEventArgs Members
PerformedActionEventArgs Class Constructors Methods Properties See Also Send Feedback

The PerformedActionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PerformedActionEventArgs(InteractionCapabilities, Interaction) | Initializes a new instance of the PerformedActionEventArgs class with the specified values.
Public method | PerformedActionEventArgs(InteractionCapabilities, Interaction, IDictionary<(Of <<'(String, Object>)>>)) | Initializes a new instance of the PerformedActionEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the InteractionCapabilities associated with the change.
Public property | ActionParameters | Gets the parameters passed into the method that initiated the action.
Public property | Interaction | Gets the interaction associated with the change.

See Also

PerformedActionEventArgs Class
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Constructor

[image] [image]

IceLib Technical Reference
PerformedActionEventArgs Constructor
PerformedActionEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformedActionEventArgs(InteractionCapabilities, Interaction) | Initializes a new instance of the PerformedActionEventArgs class with the specified values.
Public method | PerformedActionEventArgs(InteractionCapabilities, Interaction, IDictionary<(Of <<'(String, Object>)>>)) | Initializes a new instance of the PerformedActionEventArgs class with the specified values.

See Also

PerformedActionEventArgs Class
PerformedActionEventArgs Members
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Constructor (InteractionCapabilities, Interaction)

[image]

IceLib Technical Reference
PerformedActionEventArgs Constructor (InteractionCapabilities, Interaction)
PerformedActionEventArgs Class See Also Send Feedback
Initializes a new instance of the PerformedActionEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PerformedActionEventArgs(
    InteractionCapabilities action,
    Interaction interaction
)
Visual Basic
Public Sub New ( _
    action As InteractionCapabilities, _
    interaction As Interaction _
)

Parameters

action
Type: ININ.IceLib.Interactions..::..InteractionCapabilities
The action.
interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformedActionEventArgs Class
PerformedActionEventArgs Members
PerformedActionEventArgs Overload
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Constructor (InteractionCapabilities, Interaction, IDictionary(String, Object))

[image]

IceLib Technical Reference
PerformedActionEventArgs Constructor (InteractionCapabilities, Interaction, IDictionary<(Of <(<'String, Object>)>)>)
PerformedActionEventArgs Class See Also Send Feedback
Initializes a new instance of the PerformedActionEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PerformedActionEventArgs(
    InteractionCapabilities action,
    Interaction interaction,
    IDictionary<string, Object> actionParameters
)
Visual Basic
Public Sub New ( _
    action As InteractionCapabilities, _
    interaction As Interaction, _
    actionParameters As IDictionary(Of String, Object) _
)

Parameters

action
Type: ININ.IceLib.Interactions..::..InteractionCapabilities
The action.
interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
actionParameters
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, Object>)>)>
A dictionary of parameters passed into the method that initiated the action.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformedActionEventArgs Class
PerformedActionEventArgs Members
PerformedActionEventArgs Overload
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Methods

[image] [image]

IceLib Technical Reference
PerformedActionEventArgs Methods
PerformedActionEventArgs Class See Also Send Feedback

The PerformedActionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformedActionEventArgs Class
ININ.IceLib.Interactions Namespace


PerformedActionEventArgs Properties

[image] [image]

IceLib Technical Reference
PerformedActionEventArgs Properties
PerformedActionEventArgs Class See Also Send Feedback

The PerformedActionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the InteractionCapabilities associated with the change.
Public property | ActionParameters | Gets the parameters passed into the method that initiated the action.
Public property | Interaction | Gets the interaction associated with the change.

See Also

PerformedActionEventArgs Class
ININ.IceLib.Interactions Namespace


Action Property

[image]

IceLib Technical Reference
PerformedActionEventArgs..::..Action Property
PerformedActionEventArgs Class See Also Send Feedback
Gets the InteractionCapabilities associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCapabilities Action { get; private set; }
Visual Basic
Public Property Action As InteractionCapabilities
    Get
    Private Set

Field Value

The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformedActionEventArgs Class
PerformedActionEventArgs Members
ININ.IceLib.Interactions Namespace


ActionParameters Property

[image]

IceLib Technical Reference
PerformedActionEventArgs..::..ActionParameters Property
PerformedActionEventArgs Class See Also Send Feedback
Gets the parameters passed into the method that initiated the action.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, Object> ActionParameters { get; private set; }
Visual Basic
Public Property ActionParameters As IDictionary(Of String, Object)
    Get
    Private Set

Field Value

The action parameter dictionary.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformedActionEventArgs Class
PerformedActionEventArgs Members
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
PerformedActionEventArgs..::..Interaction Property
PerformedActionEventArgs Class See Also Send Feedback
Gets the interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; private set; }
Visual Basic
Public Property Interaction As Interaction
    Get
    Private Set

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformedActionEventArgs Class
PerformedActionEventArgs Members
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Class

[image]

IceLib Technical Reference
PerformingActionEventArgs Class
Members See Also Send Feedback
Provides data for the PerformingAction event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PerformingActionEventArgs : CancelEventArgs
Visual Basic
Public Class PerformingActionEventArgs _
    Inherits CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
ININ.IceLib.Interactions..::..PerformingActionEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PerformingActionEventArgs Members
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Members

[image] [image]

IceLib Technical Reference
PerformingActionEventArgs Members
PerformingActionEventArgs Class Constructors Methods Properties See Also Send Feedback

The PerformingActionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PerformingActionEventArgs(InteractionCapabilities, Interaction) | Initializes a new instance of the PerformingActionEventArgs class with the specified values.
Public method | PerformingActionEventArgs(InteractionCapabilities, Interaction, IDictionary<(Of <<'(String, Object>)>>)) | Initializes a new instance of the PerformingActionEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the InteractionCapabilities associated with the change.
Public property | ActionParameters | Gets the parameters passed into the method that initiated the action.
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Interaction | Gets the interaction associated with the change.

See Also

PerformingActionEventArgs Class
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Constructor

[image] [image]

IceLib Technical Reference
PerformingActionEventArgs Constructor
PerformingActionEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformingActionEventArgs(InteractionCapabilities, Interaction) | Initializes a new instance of the PerformingActionEventArgs class with the specified values.
Public method | PerformingActionEventArgs(InteractionCapabilities, Interaction, IDictionary<(Of <<'(String, Object>)>>)) | Initializes a new instance of the PerformingActionEventArgs class with the specified values.

See Also

PerformingActionEventArgs Class
PerformingActionEventArgs Members
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Constructor (InteractionCapabilities, Interaction)

[image]

IceLib Technical Reference
PerformingActionEventArgs Constructor (InteractionCapabilities, Interaction)
PerformingActionEventArgs Class See Also Send Feedback
Initializes a new instance of the PerformingActionEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PerformingActionEventArgs(
    InteractionCapabilities action,
    Interaction interaction
)
Visual Basic
Public Sub New ( _
    action As InteractionCapabilities, _
    interaction As Interaction _
)

Parameters

action
Type: ININ.IceLib.Interactions..::..InteractionCapabilities
The action.
interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PerformingActionEventArgs Class
PerformingActionEventArgs Members
PerformingActionEventArgs Overload
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Constructor (InteractionCapabilities, Interaction, IDictionary(String, Object))

[image]

IceLib Technical Reference
PerformingActionEventArgs Constructor (InteractionCapabilities, Interaction, IDictionary<(Of <(<'String, Object>)>)>)
PerformingActionEventArgs Class See Also Send Feedback
Initializes a new instance of the PerformingActionEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PerformingActionEventArgs(
    InteractionCapabilities action,
    Interaction interaction,
    IDictionary<string, Object> actionParameters
)
Visual Basic
Public Sub New ( _
    action As InteractionCapabilities, _
    interaction As Interaction, _
    actionParameters As IDictionary(Of String, Object) _
)

Parameters

action
Type: ININ.IceLib.Interactions..::..InteractionCapabilities
The action.
interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
actionParameters
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, Object>)>)>
A dictionary of parameters passed into the method that initiated the action.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformingActionEventArgs Class
PerformingActionEventArgs Members
PerformingActionEventArgs Overload
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Methods

[image] [image]

IceLib Technical Reference
PerformingActionEventArgs Methods
PerformingActionEventArgs Class See Also Send Feedback

The PerformingActionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformingActionEventArgs Class
ININ.IceLib.Interactions Namespace


PerformingActionEventArgs Properties

[image] [image]

IceLib Technical Reference
PerformingActionEventArgs Properties
PerformingActionEventArgs Class See Also Send Feedback

The PerformingActionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the InteractionCapabilities associated with the change.
Public property | ActionParameters | Gets the parameters passed into the method that initiated the action.
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Interaction | Gets the interaction associated with the change.

See Also

PerformingActionEventArgs Class
ININ.IceLib.Interactions Namespace


Action Property

[image]

IceLib Technical Reference
PerformingActionEventArgs..::..Action Property
PerformingActionEventArgs Class See Also Send Feedback
Gets the InteractionCapabilities associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionCapabilities Action { get; private set; }
Visual Basic
Public Property Action As InteractionCapabilities
    Get
    Private Set

Field Value

The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PerformingActionEventArgs Class
PerformingActionEventArgs Members
ININ.IceLib.Interactions Namespace


ActionParameters Property

[image]

IceLib Technical Reference
PerformingActionEventArgs..::..ActionParameters Property
PerformingActionEventArgs Class See Also Send Feedback
Gets the parameters passed into the method that initiated the action.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, Object> ActionParameters { get; private set; }
Visual Basic
Public Property ActionParameters As IDictionary(Of String, Object)
    Get
    Private Set

Field Value

The action parameter dictionary.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformingActionEventArgs Class
PerformingActionEventArgs Members
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
PerformingActionEventArgs..::..Interaction Property
PerformingActionEventArgs Class See Also Send Feedback
Gets the interaction associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; private set; }
Visual Basic
Public Property Interaction As Interaction
    Get
    Private Set

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PerformingActionEventArgs Class
PerformingActionEventArgs Members
ININ.IceLib.Interactions Namespace


PhoneNumber Class

[image]

IceLib Technical Reference
PhoneNumber Class
Members See Also Send Feedback
Detailed information about a phone number within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class PhoneNumber
Visual Basic
<SerializableAttribute> _
Public Class PhoneNumber

Remarks

This class contains detailed information about a phone number that is retrieved by calling QueryPhoneNumberDetails(array<String>[]()[][]) or QueryPhoneNumberDetailsAsync(array<String>[]()[][], EventHandler<(Of <<'(QueryPhoneNumberDetailsCompletedEventArgs>)>>), Object). The phone number information is determined by the Interaction Center server by applying the dial plan information to a given phone number string to determine the normalized phone number for the Interaction Center system to make a call. Also, the IC system can determine if the phone number is local, long-distance, international, etc.

Explanation of each property

  • RawText - The input text.
  • NormalizedText - The string that will be used by Interaction Center when dialing this phone numbers.
  • DisplayText - Descriptive text set for this type of phone number.
  • EditBase - The string that can be presented to the user for editing this phone number.
  • Extension - The string that indicates the intercom extension, if this phone number is an extension. This would be empty if the PhoneNumber.RawText is not an intercom extension.
  • DefaultClassification - The default Phone number classification for this phone number.
  • Classifications - Classifications that this phone number falls into.
  • Internal - Is this an internal number?
  • QueueType - If this number matches an InteractionQueue, then the type of the queue.
  • QueueName - A valid scoped queue name if this number has a queue type.
  • VoicemailCapable - Can this number receive voicemails?
  • DialCapable - Can this number be dialed?
  • AutoDialExtension - Will the Interaction Center dial extension (if exists) while dialing this number?

When the method QueryPhoneNumberDetails(array<String>[]()[][]) is called with an input string '8004562354', the properties of this class may look like this:

  • RawText: 8004562354 -
  • NormalizedText: +18004562354 -
  • DisplayText: (Tool Free) 1 (800) 456-2354 -
  • EditBase: 1 (800) 456-2354 -
  • Extension: -
  • DefaultClassification: Tool Free -
  • Classifications: Tool Free -
  • Internal: false -
  • QueueType: None -
  • QueueName: -
  • VoicemailCapable: false -
  • DialCapable: true -
  • AutoDialExtension: false -

When the method QueryPhoneNumberDetails(array<String>[]()[][]) is called with extension of a user, for ex., 6929, the properties of this class may look like this:

  • RawText: 6929 -
  • NormalizedText: /6929 -
  • DisplayText: 6929 -
  • EditBase: -
  • Extension: 6929 -
  • DefaultClassification: Intercom -
  • Classifications: Intercom -
  • Internal: true -
  • QueueType: User -
  • QueueName: User Queue:<userId> -
  • VoicemailCapable: true -
  • DialCapable: true -
  • AutoDialExtension: true -

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..PhoneNumber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Members
ININ.IceLib.Interactions Namespace
InteractionsManager..::..QueryPhoneNumberDetails(array<String>[]()[][])
InteractionsManager..::..QueryPhoneNumberDetailsAsync(array<String>[]()[][], EventHandler<(Of <<'(QueryPhoneNumberDetailsCompletedEventArgs>)>>), Object)


PhoneNumber Members

[image] [image]

IceLib Technical Reference
PhoneNumber Members
PhoneNumber Class Methods Properties See Also Send Feedback

The PhoneNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AutoDialExtension | Indicates whether Extension (if exists) will to be included while Interaction Centers dials this number.
Public property | Classifications | Gets the classifications for this PhoneNumber.
Public property | DefaultClassification | The default classification for this PhoneNumber. There can be multiple Classifications.
Public property | DialCapable | Indicates whether this PhoneNumber can be dialed.
Public property | DisplayText | The text used to display this PhoneNumber in a client application.
Public property | EditBase | The editable format of this PhoneNumber.
Public property | Extension | The Extension of this PhoneNumber.
Public property | Internal | Indicates whether this PhoneNumber in an internal number.
Public property | NormalizedText | The system normalized phone number text used for this PhoneNumber.
Public property | QueueName | The name of the queue for this PhoneNumber.
Public property | QueueType | The type of the queue for this PhoneNumber.
Public property | RawText | The phone number for which this PhoneNumber was created.
Public property | VoicemailCapable | Indicates whether this PhoneNumber is configured to receive voice mail.

See Also

PhoneNumber Class
ININ.IceLib.Interactions Namespace


PhoneNumber Methods

[image] [image]

IceLib Technical Reference
PhoneNumber Methods
PhoneNumber Class See Also Send Feedback

The PhoneNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

PhoneNumber Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
PhoneNumber..::..ToString Method
PhoneNumber Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


PhoneNumber Properties

[image] [image]

IceLib Technical Reference
PhoneNumber Properties
PhoneNumber Class See Also Send Feedback

The PhoneNumber type exposes the following members.

Properties

 | Name | Description
Public property | AutoDialExtension | Indicates whether Extension (if exists) will to be included while Interaction Centers dials this number.
Public property | Classifications | Gets the classifications for this PhoneNumber.
Public property | DefaultClassification | The default classification for this PhoneNumber. There can be multiple Classifications.
Public property | DialCapable | Indicates whether this PhoneNumber can be dialed.
Public property | DisplayText | The text used to display this PhoneNumber in a client application.
Public property | EditBase | The editable format of this PhoneNumber.
Public property | Extension | The Extension of this PhoneNumber.
Public property | Internal | Indicates whether this PhoneNumber in an internal number.
Public property | NormalizedText | The system normalized phone number text used for this PhoneNumber.
Public property | QueueName | The name of the queue for this PhoneNumber.
Public property | QueueType | The type of the queue for this PhoneNumber.
Public property | RawText | The phone number for which this PhoneNumber was created.
Public property | VoicemailCapable | Indicates whether this PhoneNumber is configured to receive voice mail.

See Also

PhoneNumber Class
ININ.IceLib.Interactions Namespace


AutoDialExtension Property

[image]

IceLib Technical Reference
PhoneNumber..::..AutoDialExtension Property
PhoneNumber Class See Also Send Feedback
Indicates whether Extension (if exists) will to be included while Interaction Centers dials this number.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AutoDialExtension { get; }
Visual Basic
Public ReadOnly Property AutoDialExtension As Boolean
    Get

Field Value

Returns true if Extension should be auto dialed; otherwise, false.

Remarks

NormalizedText will look like '+18004562354/^1234' when this property is set to true.

NormalizedText will look like '+18004562354^1234' when this property is set to false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


Classifications Property

[image]

IceLib Technical Reference
PhoneNumber..::..Classifications Property
PhoneNumber Class See Also Send Feedback
Gets the classifications for this PhoneNumber.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Classifications { get; }
Visual Basic
Public ReadOnly Property Classifications As ReadOnlyCollection(Of String)
    Get

Field Value

The classifications.

Remarks

Phone numbers that can be identified by a pattern in the numbers, or an explicit group of phone numbers with a common purpose are called phone number "classifications". For example, internal calls could be identified by the "Internal" classification, toll free (for example, 800 numbers) could be identified by the "Toll Free" classification, and calls to emergency services (such as 911, fire department, police, and hospital) could be identified by the "Emergency" classification.

When IC users dial a phone number, IC matches the number dialed with the appropriate classification pattern. It then checks the user's dialing privileges to determine if the user or station is authorized to place the call. In this way, IC uses phone number classifications to control individual users, workgroups, roles, and station dialing privileges.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace
PhoneNumber..::..DefaultClassification


DefaultClassification Property

[image]

IceLib Technical Reference
PhoneNumber..::..DefaultClassification Property
PhoneNumber Class See Also Send Feedback
The default classification for this PhoneNumber. There can be multiple Classifications.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultClassification { get; }
Visual Basic
Public ReadOnly Property DefaultClassification As String
    Get

Field Value

The default classification.

Remarks

Phone numbers that can be identified by a pattern in the numbers, or an explicit group of phone numbers with a common purpose are called phone number "classifications". For example, internal calls could be identified by the "Internal" classification, toll free (for example, 800 numbers) could be identified by the "Toll Free" classification, and calls to emergency services (such as 911, fire department, police, and hospital) could be identified by the "Emergency" classification.

When IC users dial a phone number, IC matches the number dialed with the appropriate classification pattern. It then checks the user's dialing privileges to determine if the user or station is authorized to place the call. In this way, IC uses phone number classifications to control individual users, workgroups, roles, and station dialing privileges.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace
PhoneNumber..::..Classifications


DialCapable Property

[image]

IceLib Technical Reference
PhoneNumber..::..DialCapable Property
PhoneNumber Class See Also Send Feedback
Indicates whether this PhoneNumber can be dialed.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DialCapable { get; }
Visual Basic
Public ReadOnly Property DialCapable As Boolean
    Get

Field Value

Returns trueTruetruetrue (True in Visual Basic) if this phone number is dial-capable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


DisplayText Property

[image]

IceLib Technical Reference
PhoneNumber..::..DisplayText Property
PhoneNumber Class See Also Send Feedback
The text used to display this PhoneNumber in a client application.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayText { get; }
Visual Basic
Public ReadOnly Property DisplayText As String
    Get

Field Value

The display text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


EditBase Property

[image]

IceLib Technical Reference
PhoneNumber..::..EditBase Property
PhoneNumber Class See Also Send Feedback
The editable format of this PhoneNumber.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EditBase { get; }
Visual Basic
Public ReadOnly Property EditBase As String
    Get

Field Value

The edit base.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


Extension Property

[image]

IceLib Technical Reference
PhoneNumber..::..Extension Property
PhoneNumber Class See Also Send Feedback
The Extension of this PhoneNumber.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The Extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


Internal Property

[image]

IceLib Technical Reference
PhoneNumber..::..Internal Property
PhoneNumber Class See Also Send Feedback
Indicates whether this PhoneNumber in an internal number.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Internal { get; }
Visual Basic
Public ReadOnly Property Internal As Boolean
    Get

Field Value

Returns trueTruetruetrue (True in Visual Basic) if this phone number is internal to IC; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


NormalizedText Property

[image]

IceLib Technical Reference
PhoneNumber..::..NormalizedText Property
PhoneNumber Class See Also Send Feedback
The system normalized phone number text used for this PhoneNumber.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string NormalizedText { get; }
Visual Basic
Public ReadOnly Property NormalizedText As String
    Get

Field Value

The normalized text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


QueueName Property

[image]

IceLib Technical Reference
PhoneNumber..::..QueueName Property
PhoneNumber Class See Also Send Feedback
The name of the queue for this PhoneNumber.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string QueueName { get; }
Visual Basic
Public ReadOnly Property QueueName As String
    Get

Field Value

The name of the queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


QueueType Property

[image]

IceLib Technical Reference
PhoneNumber..::..QueueType Property
PhoneNumber Class See Also Send Feedback
The type of the queue for this PhoneNumber.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueType QueueType { get; }
Visual Basic
Public ReadOnly Property QueueType As QueueType
    Get

Field Value

The type of the queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


RawText Property

[image]

IceLib Technical Reference
PhoneNumber..::..RawText Property
PhoneNumber Class See Also Send Feedback
The phone number for which this PhoneNumber was created.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RawText { get; }
Visual Basic
Public ReadOnly Property RawText As String
    Get

Field Value

The original number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


VoicemailCapable Property

[image]

IceLib Technical Reference
PhoneNumber..::..VoicemailCapable Property
PhoneNumber Class See Also Send Feedback
Indicates whether this PhoneNumber is configured to receive voice mail.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool VoicemailCapable { get; }
Visual Basic
Public ReadOnly Property VoicemailCapable As Boolean
    Get

Field Value

Returns trueTruetruetrue (True in Visual Basic) if the number is voice mail capable; otherwise falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PhoneNumber Class
PhoneNumber Members
ININ.IceLib.Interactions Namespace


QueryPhoneNumberDetailsCompletedEventArgs Class

[image]

IceLib Technical Reference
QueryPhoneNumberDetailsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the QueryPhoneNumberDetailsAsync(array<String>[]()[][], EventHandler<(Of <<'(QueryPhoneNumberDetailsCompletedEventArgs>)>>), Object) completedCallback delegate of InteractionsManager.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueryPhoneNumberDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class QueryPhoneNumberDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Interactions..::..QueryPhoneNumberDetailsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryPhoneNumberDetailsCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


QueryPhoneNumberDetailsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
QueryPhoneNumberDetailsCompletedEventArgs Members
QueryPhoneNumberDetailsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The QueryPhoneNumberDetailsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueryPhoneNumberDetailsCompletedEventArgs | Initializes a new instance of the QueryPhoneNumberDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PhoneNumbers | Gets the InteractionConference associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryPhoneNumberDetailsCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


QueryPhoneNumberDetailsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
QueryPhoneNumberDetailsCompletedEventArgs Constructor
QueryPhoneNumberDetailsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the QueryPhoneNumberDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueryPhoneNumberDetailsCompletedEventArgs(
    PhoneNumber[] phoneNumbers,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    phoneNumbers As PhoneNumber(), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

phoneNumbers
Type: array< ININ.IceLib.Interactions..::..PhoneNumber >[]()[][]
A PhoneNumber array.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryPhoneNumberDetailsCompletedEventArgs Class
QueryPhoneNumberDetailsCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


QueryPhoneNumberDetailsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
QueryPhoneNumberDetailsCompletedEventArgs Methods
QueryPhoneNumberDetailsCompletedEventArgs Class See Also Send Feedback

The QueryPhoneNumberDetailsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryPhoneNumberDetailsCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


QueryPhoneNumberDetailsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
QueryPhoneNumberDetailsCompletedEventArgs Properties
QueryPhoneNumberDetailsCompletedEventArgs Class See Also Send Feedback

The QueryPhoneNumberDetailsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PhoneNumbers | Gets the InteractionConference associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryPhoneNumberDetailsCompletedEventArgs Class
ININ.IceLib.Interactions Namespace


PhoneNumbers Property

[image]

IceLib Technical Reference
QueryPhoneNumberDetailsCompletedEventArgs..::..PhoneNumbers Property
QueryPhoneNumberDetailsCompletedEventArgs Class See Also Send Feedback
Gets the InteractionConference associated with the event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PhoneNumber> PhoneNumbers { get; }
Visual Basic
Public ReadOnly Property PhoneNumbers As ReadOnlyCollection(Of PhoneNumber)
    Get

Field Value

The phone numbers.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryPhoneNumberDetailsCompletedEventArgs Class
QueryPhoneNumberDetailsCompletedEventArgs Members
ININ.IceLib.Interactions Namespace


QueueConferenceItem Class

[image]

IceLib Technical Reference
QueueConferenceItem Class
Members See Also Send Feedback
Provides queue conference item details for QueueContentsChangedEventArgs.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueConferenceItem
Visual Basic
Public Class QueueConferenceItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..QueueConferenceItem
ININ.IceLib.Interactions..::..QueueConferenceItemAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItem Members
ININ.IceLib.Interactions Namespace


QueueConferenceItem Members

[image] [image]

IceLib Technical Reference
QueueConferenceItem Members
QueueConferenceItem Class Constructors Methods Properties See Also Send Feedback

The QueueConferenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | QueueConferenceItem | Initializes a new instance of the QueueConferenceItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets the conference ID.
Public property | ConferenceItem | Gets the conference item.
Public property | Interaction | Gets the interaction.

See Also

QueueConferenceItem Class
ININ.IceLib.Interactions Namespace


QueueConferenceItem Constructor

[image]

IceLib Technical Reference
QueueConferenceItem Constructor
QueueConferenceItem Class See Also Send Feedback
Initializes a new instance of the QueueConferenceItem class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueConferenceItem(
    Interaction interaction,
    Interaction conferenceItem,
    ConferenceId conferenceId
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    conferenceItem As Interaction, _
    conferenceId As ConferenceId _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
conferenceItem
Type: ININ.IceLib.Interactions..::..Interaction
The conference item.
conferenceId
Type: ININ.IceLib.Interactions..::..ConferenceId
The interaction conference.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItem Class
QueueConferenceItem Members
ININ.IceLib.Interactions Namespace


QueueConferenceItem Methods

[image] [image]

IceLib Technical Reference
QueueConferenceItem Methods
QueueConferenceItem Class See Also Send Feedback

The QueueConferenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueueConferenceItem Class
ININ.IceLib.Interactions Namespace


QueueConferenceItem Properties

[image] [image]

IceLib Technical Reference
QueueConferenceItem Properties
QueueConferenceItem Class See Also Send Feedback

The QueueConferenceItem type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets the conference ID.
Public property | ConferenceItem | Gets the conference item.
Public property | Interaction | Gets the interaction.

See Also

QueueConferenceItem Class
ININ.IceLib.Interactions Namespace


ConferenceId Property

[image]

IceLib Technical Reference
QueueConferenceItem..::..ConferenceId Property
QueueConferenceItem Class See Also Send Feedback
Gets the conference ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceId ConferenceId { get; }
Visual Basic
Public ReadOnly Property ConferenceId As ConferenceId
    Get

Field Value

The conference ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItem Class
QueueConferenceItem Members
ININ.IceLib.Interactions Namespace


ConferenceItem Property

[image]

IceLib Technical Reference
QueueConferenceItem..::..ConferenceItem Property
QueueConferenceItem Class See Also Send Feedback
Gets the conference item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction ConferenceItem { get; }
Visual Basic
Public ReadOnly Property ConferenceItem As Interaction
    Get

Field Value

The conference item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItem Class
QueueConferenceItem Members
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
QueueConferenceItem..::..Interaction Property
QueueConferenceItem Class See Also Send Feedback
Gets the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItem Class
QueueConferenceItem Members
ININ.IceLib.Interactions Namespace


QueueConferenceItemAttributes Class

[image]

IceLib Technical Reference
QueueConferenceItemAttributes Class
Members See Also Send Feedback
Provides queue conference item details for QueueContentsChangedEventArgs.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueConferenceItemAttributes : QueueConferenceItem
Visual Basic
Public Class QueueConferenceItemAttributes _
    Inherits QueueConferenceItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..QueueConferenceItem
ININ.IceLib.Interactions..::..QueueConferenceItemAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItemAttributes Members
ININ.IceLib.Interactions Namespace


QueueConferenceItemAttributes Members

[image] [image]

IceLib Technical Reference
QueueConferenceItemAttributes Members
QueueConferenceItemAttributes Class Constructors Methods Properties See Also Send Feedback

The QueueConferenceItemAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | QueueConferenceItemAttributes | Initializes a new instance of the QueueConferenceItemAttributes class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets the conference ID. (Inherited from QueueConferenceItem.)
Public property | ConferenceItem | Gets the conference item. (Inherited from QueueConferenceItem.)
Public property | Interaction | Gets the interaction. (Inherited from QueueConferenceItem.)
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

QueueConferenceItemAttributes Class
ININ.IceLib.Interactions Namespace


QueueConferenceItemAttributes Constructor

[image]

IceLib Technical Reference
QueueConferenceItemAttributes Constructor
QueueConferenceItemAttributes Class See Also Send Feedback
Initializes a new instance of the QueueConferenceItemAttributes class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueConferenceItemAttributes(
    Interaction interaction,
    Interaction conferenceItem,
    ConferenceId conferenceId,
    IList<string> interactionAttributeNames
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    conferenceItem As Interaction, _
    conferenceId As ConferenceId, _
    interactionAttributeNames As IList(Of String) _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
conferenceItem
Type: ININ.IceLib.Interactions..::..Interaction
The conference item.
conferenceId
Type: ININ.IceLib.Interactions..::..ConferenceId
The interaction conference.
interactionAttributeNames
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The interaction attribute names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItemAttributes Class
QueueConferenceItemAttributes Members
ININ.IceLib.Interactions Namespace


QueueConferenceItemAttributes Methods

[image] [image]

IceLib Technical Reference
QueueConferenceItemAttributes Methods
QueueConferenceItemAttributes Class See Also Send Feedback

The QueueConferenceItemAttributes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueueConferenceItemAttributes Class
ININ.IceLib.Interactions Namespace


QueueConferenceItemAttributes Properties

[image] [image]

IceLib Technical Reference
QueueConferenceItemAttributes Properties
QueueConferenceItemAttributes Class See Also Send Feedback

The QueueConferenceItemAttributes type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets the conference ID. (Inherited from QueueConferenceItem.)
Public property | ConferenceItem | Gets the conference item. (Inherited from QueueConferenceItem.)
Public property | Interaction | Gets the interaction. (Inherited from QueueConferenceItem.)
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

QueueConferenceItemAttributes Class
ININ.IceLib.Interactions Namespace


InteractionAttributeNames Property

[image]

IceLib Technical Reference
QueueConferenceItemAttributes..::..InteractionAttributeNames Property
QueueConferenceItemAttributes Class See Also Send Feedback
Gets the attribute names associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> InteractionAttributeNames { get; }
Visual Basic
Public ReadOnly Property InteractionAttributeNames As ReadOnlyCollection(Of String)
    Get

Field Value

The interaction attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueConferenceItemAttributes Class
QueueConferenceItemAttributes Members
ININ.IceLib.Interactions Namespace


QueueContentsChangedEventArgs Class

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs Class
Members See Also Send Feedback
Provides data for the QueueContentsChanged event of a InteractionQueue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueContentsChangedEventArgs : EventArgs
Visual Basic
Public Class QueueContentsChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..QueueContentsChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


QueueContentsChangedEventArgs Members

[image] [image]

IceLib Technical Reference
QueueContentsChangedEventArgs Members
QueueContentsChangedEventArgs Class Methods Properties See Also Send Feedback

The QueueContentsChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceItemsAdded | Gets the conference items added with this change event.
Public property | ConferenceItemsChanged | Gets the conference items changed with this change event.
Public property | ConferenceItemsRemoved | Gets the conference items removed with this change event.
Public property | ItemsAdded | Gets the items added with this change event.
Public property | ItemsChanged | Gets the items changed with this change event.
Public property | ItemsRemoved | Gets the items removed with this change event.

See Also

QueueContentsChangedEventArgs Class
ININ.IceLib.Interactions Namespace


QueueContentsChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
QueueContentsChangedEventArgs Methods
QueueContentsChangedEventArgs Class See Also Send Feedback

The QueueContentsChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueueContentsChangedEventArgs Class
ININ.IceLib.Interactions Namespace


QueueContentsChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
QueueContentsChangedEventArgs Properties
QueueContentsChangedEventArgs Class See Also Send Feedback

The QueueContentsChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceItemsAdded | Gets the conference items added with this change event.
Public property | ConferenceItemsChanged | Gets the conference items changed with this change event.
Public property | ConferenceItemsRemoved | Gets the conference items removed with this change event.
Public property | ItemsAdded | Gets the items added with this change event.
Public property | ItemsChanged | Gets the items changed with this change event.
Public property | ItemsRemoved | Gets the items removed with this change event.

See Also

QueueContentsChangedEventArgs Class
ININ.IceLib.Interactions Namespace


ConferenceItemsAdded Property

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs..::..ConferenceItemsAdded Property
QueueContentsChangedEventArgs Class See Also Send Feedback
Gets the conference items added with this change event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueConferenceItemAttributes> ConferenceItemsAdded { get; }
Visual Basic
Public ReadOnly Property ConferenceItemsAdded As ReadOnlyCollection(Of QueueConferenceItemAttributes)
    Get

Field Value

The conference items added.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Class
QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceItemsChanged Property

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs..::..ConferenceItemsChanged Property
QueueContentsChangedEventArgs Class See Also Send Feedback
Gets the conference items changed with this change event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueConferenceItemAttributes> ConferenceItemsChanged { get; }
Visual Basic
Public ReadOnly Property ConferenceItemsChanged As ReadOnlyCollection(Of QueueConferenceItemAttributes)
    Get

Field Value

The conference items changed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Class
QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


ConferenceItemsRemoved Property

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs..::..ConferenceItemsRemoved Property
QueueContentsChangedEventArgs Class See Also Send Feedback
Gets the conference items removed with this change event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueConferenceItem> ConferenceItemsRemoved { get; }
Visual Basic
Public ReadOnly Property ConferenceItemsRemoved As ReadOnlyCollection(Of QueueConferenceItem)
    Get

Field Value

The conference items removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Class
QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


ItemsAdded Property

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs..::..ItemsAdded Property
QueueContentsChangedEventArgs Class See Also Send Feedback
Gets the items added with this change event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueItemAttributes> ItemsAdded { get; }
Visual Basic
Public ReadOnly Property ItemsAdded As ReadOnlyCollection(Of QueueItemAttributes)
    Get

Field Value

The items added.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Class
QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


ItemsChanged Property

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs..::..ItemsChanged Property
QueueContentsChangedEventArgs Class See Also Send Feedback
Gets the items changed with this change event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueItemAttributes> ItemsChanged { get; }
Visual Basic
Public ReadOnly Property ItemsChanged As ReadOnlyCollection(Of QueueItemAttributes)
    Get

Field Value

The items changed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Class
QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


ItemsRemoved Property

[image]

IceLib Technical Reference
QueueContentsChangedEventArgs..::..ItemsRemoved Property
QueueContentsChangedEventArgs Class See Also Send Feedback
Gets the items removed with this change event.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<QueueItem> ItemsRemoved { get; }
Visual Basic
Public ReadOnly Property ItemsRemoved As ReadOnlyCollection(Of QueueItem)
    Get

Field Value

The items removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueContentsChangedEventArgs Class
QueueContentsChangedEventArgs Members
ININ.IceLib.Interactions Namespace


QueueId Class

[image]

IceLib Technical Reference
QueueId Class
Members See Also Send Feedback
Identifies an InteractionQueue within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class QueueId : IComparable, IComparable<QueueId>
Visual Basic
<SerializableAttribute> _
Public Class QueueId _
    Implements IComparable, IComparable(Of QueueId)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..QueueId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Members
ININ.IceLib.Interactions Namespace


QueueId Members

[image] [image]

IceLib Technical Reference
QueueId Members
QueueId Class Constructors Methods Operators Properties See Also Send Feedback

The QueueId type exposes the following members.

Constructors

 | Name | Description
Public method | QueueId(String) | Initializes a new instance of the QueueId class with the specified values.
Public method | QueueId(QueueType, String) | Initializes a new instance of the QueueId class with the specified values.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(QueueId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(QueueId) | Determines whether the specified QueueId is equal to the current QueueId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of QueueId are equal.
Inequality | Determines whether two instances of QueueId are not equal.

Properties

 | Name | Description
Public property | ObfuscatedScopedName | Gets the obfuscated scoped name of the Queue being identified.
Public property | QueueName | Gets the name of the Queue being identified.
Public property | QueueType | Gets the type of Queue being identified.
Public property | ScopedName | Gets the scoped name of the Queue being identified.

See Also

QueueId Class
ININ.IceLib.Interactions Namespace


QueueId Constructor

[image] [image]

IceLib Technical Reference
QueueId Constructor
QueueId Class See Also Send Feedback
Initializes a new instance of the QueueId class.

Overload List

 | Name | Description
Public method | QueueId(String) | Initializes a new instance of the QueueId class with the specified values.
Public method | QueueId(QueueType, String) | Initializes a new instance of the QueueId class with the specified values.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


QueueId Constructor (String)

[image]

IceLib Technical Reference
QueueId Constructor (String)
QueueId Class See Also Send Feedback
Initializes a new instance of the QueueId class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueId(
    string scopedName
)
Visual Basic
Public Sub New ( _
    scopedName As String _
)

Parameters

scopedName
Type: System..::..String
The scoped queue name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
QueueId Overload
ININ.IceLib.Interactions Namespace


QueueId Constructor (QueueType, String)

[image]

IceLib Technical Reference
QueueId Constructor (QueueType, String)
QueueId Class See Also Send Feedback
Initializes a new instance of the QueueId class with the specified values.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueId(
    QueueType queueType,
    string queueName
)
Visual Basic
Public Sub New ( _
    queueType As QueueType, _
    queueName As String _
)

Parameters

queueType
Type: ININ.IceLib.Interactions..::..QueueType
The queue type enumeration value.
queueName
Type: System..::..String
The queue name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
QueueId Overload
ININ.IceLib.Interactions Namespace


QueueId Methods

[image] [image]

IceLib Technical Reference
QueueId Methods
QueueId Class See Also Send Feedback

The QueueId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(QueueId) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(QueueId) | Determines whether the specified QueueId is equal to the current QueueId.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

QueueId Class
ININ.IceLib.Interactions Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
QueueId..::..CompareTo Method
QueueId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(QueueId) | Compares the current object with another object of the same type.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


CompareTo Method (Object)

[image]

IceLib Technical Reference
QueueId..::..CompareTo Method (Object)
QueueId Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


CompareTo Method (QueueId)

[image]

IceLib Technical Reference
QueueId..::..CompareTo Method (QueueId)
QueueId Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    QueueId other
)
Visual Basic
Public Function CompareTo ( _
    other As QueueId _
) As Integer

Parameters

other
Type: ININ.IceLib.Interactions..::..QueueId
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
CompareTo Overload
ININ.IceLib.Interactions Namespace


Equals Method

[image] [image]

IceLib Technical Reference
QueueId..::..Equals Method
QueueId Class See Also Send Feedback
Determines whether two QueueId instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(QueueId) | Determines whether the specified QueueId is equal to the current QueueId.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
QueueId..::..Equals Method (Object)
QueueId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
Equals Overload
ININ.IceLib.Interactions Namespace


Equals Method (QueueId)

[image]

IceLib Technical Reference
QueueId..::..Equals Method (QueueId)
QueueId Class See Also Send Feedback
Determines whether the specified QueueId is equal to the current QueueId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    QueueId other
)
Visual Basic
Public Function Equals ( _
    other As QueueId _
) As Boolean

Parameters

other
Type: ININ.IceLib.Interactions..::..QueueId
The QueueId to compare with the current QueueId.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified QueueId is equal to the current QueueId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
Equals Overload
ININ.IceLib.Interactions Namespace


GetHashCode Method

[image]

IceLib Technical Reference
QueueId..::..GetHashCode Method
QueueId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
QueueId..::..ToString Method
QueueId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


QueueId Operators

[image] [image]

IceLib Technical Reference
QueueId Operators
QueueId Class See Also Send Feedback

The QueueId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of QueueId are equal.
Inequality | Determines whether two instances of QueueId are not equal.

See Also

QueueId Class
ININ.IceLib.Interactions Namespace


Equality Operator

[image]

IceLib Technical Reference
QueueId..::..Equality Operator
QueueId Class See Also Send Feedback
Determines whether two instances of QueueId are equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    QueueId a,
    QueueId b
)
Visual Basic
Public Shared Operator = ( _
    a As QueueId, _
    b As QueueId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..QueueId
The first QueueId to compare.
b
Type: ININ.IceLib.Interactions..::..QueueId
The second QueueId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


Inequality Operator

[image]

IceLib Technical Reference
QueueId..::..Inequality Operator
QueueId Class See Also Send Feedback
Determines whether two instances of QueueId are not equal.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    QueueId a,
    QueueId b
)
Visual Basic
Public Shared Operator <> ( _
    a As QueueId, _
    b As QueueId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Interactions..::..QueueId
The first QueueId to compare.
b
Type: ININ.IceLib.Interactions..::..QueueId
The second QueueId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


QueueId Properties

[image] [image]

IceLib Technical Reference
QueueId Properties
QueueId Class See Also Send Feedback

The QueueId type exposes the following members.

Properties

 | Name | Description
Public property | ObfuscatedScopedName | Gets the obfuscated scoped name of the Queue being identified.
Public property | QueueName | Gets the name of the Queue being identified.
Public property | QueueType | Gets the type of Queue being identified.
Public property | ScopedName | Gets the scoped name of the Queue being identified.

See Also

QueueId Class
ININ.IceLib.Interactions Namespace


ObfuscatedScopedName Property

[image]

IceLib Technical Reference
QueueId..::..ObfuscatedScopedName Property
QueueId Class See Also Send Feedback
Gets the obfuscated scoped name of the Queue being identified.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ObfuscatedScopedName { get; }
Visual Basic
Public ReadOnly Property ObfuscatedScopedName As String
    Get

Field Value

The obfuscated scoped name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


QueueName Property

[image]

IceLib Technical Reference
QueueId..::..QueueName Property
QueueId Class See Also Send Feedback
Gets the name of the Queue being identified.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string QueueName { get; }
Visual Basic
Public ReadOnly Property QueueName As String
    Get

Field Value

The name of the queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


QueueType Property

[image]

IceLib Technical Reference
QueueId..::..QueueType Property
QueueId Class See Also Send Feedback
Gets the type of Queue being identified.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueType QueueType { get; }
Visual Basic
Public ReadOnly Property QueueType As QueueType
    Get

Field Value

The type of the queue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


ScopedName Property

[image]

IceLib Technical Reference
QueueId..::..ScopedName Property
QueueId Class See Also Send Feedback
Gets the scoped name of the Queue being identified.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ScopedName { get; }
Visual Basic
Public ReadOnly Property ScopedName As String
    Get

Field Value

The scoped name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueueId Class
QueueId Members
ININ.IceLib.Interactions Namespace


QueueItem Class

[image]

IceLib Technical Reference
QueueItem Class
Members See Also Send Feedback
Provides queue item details for QueueContentsChangedEventArgs.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueItem
Visual Basic
Public Class QueueItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..QueueItem
ININ.IceLib.Interactions..::..QueueItemAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueItem Members
ININ.IceLib.Interactions Namespace


QueueItem Members

[image] [image]

IceLib Technical Reference
QueueItem Members
QueueItem Class Constructors Methods Properties See Also Send Feedback

The QueueItem type exposes the following members.

Constructors

 | Name | Description
Public method | QueueItem | Initializes a new instance of the QueueItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the interaction.

See Also

QueueItem Class
ININ.IceLib.Interactions Namespace


QueueItem Constructor

[image]

IceLib Technical Reference
QueueItem Constructor
QueueItem Class See Also Send Feedback
Initializes a new instance of the QueueItem class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueItem(
    Interaction interaction
)
Visual Basic
Public Sub New ( _
    interaction As Interaction _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueItem Class
QueueItem Members
ININ.IceLib.Interactions Namespace


QueueItem Methods

[image] [image]

IceLib Technical Reference
QueueItem Methods
QueueItem Class See Also Send Feedback

The QueueItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueueItem Class
ININ.IceLib.Interactions Namespace


QueueItem Properties

[image] [image]

IceLib Technical Reference
QueueItem Properties
QueueItem Class See Also Send Feedback

The QueueItem type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the interaction.

See Also

QueueItem Class
ININ.IceLib.Interactions Namespace


Interaction Property

[image]

IceLib Technical Reference
QueueItem..::..Interaction Property
QueueItem Class See Also Send Feedback
Gets the interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As Interaction
    Get

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueItem Class
QueueItem Members
ININ.IceLib.Interactions Namespace


QueueItemAttributes Class

[image]

IceLib Technical Reference
QueueItemAttributes Class
Members See Also Send Feedback
Provides queue item details for QueueContentsChangedEventArgs.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueueItemAttributes : QueueItem
Visual Basic
Public Class QueueItemAttributes _
    Inherits QueueItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..QueueItem
ININ.IceLib.Interactions..::..QueueItemAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueItemAttributes Members
ININ.IceLib.Interactions Namespace


QueueItemAttributes Members

[image] [image]

IceLib Technical Reference
QueueItemAttributes Members
QueueItemAttributes Class Constructors Methods Properties See Also Send Feedback

The QueueItemAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | QueueItemAttributes | Initializes a new instance of the QueueItemAttributes class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the interaction. (Inherited from QueueItem.)
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

QueueItemAttributes Class
ININ.IceLib.Interactions Namespace


QueueItemAttributes Constructor

[image]

IceLib Technical Reference
QueueItemAttributes Constructor
QueueItemAttributes Class See Also Send Feedback
Initializes a new instance of the QueueItemAttributes class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueueItemAttributes(
    Interaction interaction,
    IList<string> interactionAttributeNames
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    interactionAttributeNames As IList(Of String) _
)

Parameters

interaction
Type: ININ.IceLib.Interactions..::..Interaction
The interaction.
interactionAttributeNames
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The interaction attribute names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueItemAttributes Class
QueueItemAttributes Members
ININ.IceLib.Interactions Namespace


QueueItemAttributes Methods

[image] [image]

IceLib Technical Reference
QueueItemAttributes Methods
QueueItemAttributes Class See Also Send Feedback

The QueueItemAttributes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueueItemAttributes Class
ININ.IceLib.Interactions Namespace


QueueItemAttributes Properties

[image] [image]

IceLib Technical Reference
QueueItemAttributes Properties
QueueItemAttributes Class See Also Send Feedback

The QueueItemAttributes type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the interaction. (Inherited from QueueItem.)
Public property | InteractionAttributeNames | Gets the attribute names associated with the change.

See Also

QueueItemAttributes Class
ININ.IceLib.Interactions Namespace


InteractionAttributeNames Property

[image]

IceLib Technical Reference
QueueItemAttributes..::..InteractionAttributeNames Property
QueueItemAttributes Class See Also Send Feedback
Gets the attribute names associated with the change.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> InteractionAttributeNames { get; }
Visual Basic
Public ReadOnly Property InteractionAttributeNames As ReadOnlyCollection(Of String)
    Get

Field Value

The interaction attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

QueueItemAttributes Class
QueueItemAttributes Members
ININ.IceLib.Interactions Namespace


QueueType Enumeration

[image]

IceLib Technical Reference
QueueType Enumeration
See Also Send Feedback
Specifies constants indicating the type of an InteractionQueue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum QueueType
Visual Basic
Public Enumeration QueueType

Members

Member name | Value | Description
None | 0 | The Queue type cannot be identified.
MyInteractions | 1 | A special Queue that represents a interactions on a user's user or station queue.
User | 2 | Represents a user's interactions.
Station | 3 | Represents a station's interactions.
Workgroup | 4 | Represents a workgroup's interactions. Interactions passed to a Workgroup queue can be picked up by its member agents.
Orbit | 5 | Represents an orbit queue's interactions. An orbit queue is a list of all calls parked to specific locations (numbered orbits). This feature is especially helpful for Public Announcement system operators who can park a call in Orbit, then page the recipient and relay that he or she has a call on a specific Orbit (i.e. "John Doe, you have a call on Orbit 12", thus enabling John Doe to move to any station and pick up the call).
Line | 6 | Represents a line's interactions. (This can be an expensive queue to watch.)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Interactions Namespace


RecorderInteraction Class

[image]

IceLib Technical Reference
RecorderInteraction Class
Members See Also Send Feedback
Represents a recorder interaction within the Interaction Center system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecorderInteraction : Interaction
Visual Basic
Public Class RecorderInteraction _
    Inherits Interaction

Remarks

Recorded interactions represent an interaction where a supervisor or another user is recording another user's interaction.

Note
Accessing the properties of this class without an interaction watch in place raises the NotCachedException.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..RecorderInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteraction Members
ININ.IceLib.Interactions Namespace


RecorderInteraction Members

[image] [image]

IceLib Technical Reference
RecorderInteraction Members
RecorderInteraction Class Constructors Methods Properties Events See Also Send Feedback

The RecorderInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | RecorderInteraction | Initializes a new instance of the RecorderInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | RecordedFileName | Gets the RecordedFileName.
Public property | RecordedInteractionId | Gets the RecordedInteractionId.
Public property | RecordedInteractionType | Gets the RecordedInteractionType.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

RecorderInteraction Class
ININ.IceLib.Interactions Namespace


RecorderInteraction Constructor

[image]

IceLib Technical Reference
RecorderInteraction Constructor
RecorderInteraction Class See Also Send Feedback
Initializes a new instance of the RecorderInteraction class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecorderInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteraction Class
RecorderInteraction Members
ININ.IceLib.Interactions Namespace


RecorderInteraction Methods

[image] [image]

IceLib Technical Reference
RecorderInteraction Methods
RecorderInteraction Class See Also Send Feedback

The RecorderInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

RecorderInteraction Class
ININ.IceLib.Interactions Namespace


RecorderInteraction Properties

[image] [image]

IceLib Technical Reference
RecorderInteraction Properties
RecorderInteraction Class See Also Send Feedback

The RecorderInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | RecordedFileName | Gets the RecordedFileName.
Public property | RecordedInteractionId | Gets the RecordedInteractionId.
Public property | RecordedInteractionType | Gets the RecordedInteractionType.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

RecorderInteraction Class
ININ.IceLib.Interactions Namespace


RecordedFileName Property

[image]

IceLib Technical Reference
RecorderInteraction..::..RecordedFileName Property
RecorderInteraction Class See Also Send Feedback
Gets the RecordedFileName.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RecordedFileName { get; }
Visual Basic
Public ReadOnly Property RecordedFileName As String
    Get

Field Value

The recorded file.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteraction Class
RecorderInteraction Members
ININ.IceLib.Interactions Namespace


RecordedInteractionId Property

[image]

IceLib Technical Reference
RecorderInteraction..::..RecordedInteractionId Property
RecorderInteraction Class See Also Send Feedback
Gets the RecordedInteractionId.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId RecordedInteractionId { get; }
Visual Basic
Public ReadOnly Property RecordedInteractionId As InteractionId
    Get

Field Value

The recorded interaction ID.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteraction Class
RecorderInteraction Members
ININ.IceLib.Interactions Namespace


RecordedInteractionType Property

[image]

IceLib Technical Reference
RecorderInteraction..::..RecordedInteractionType Property
RecorderInteraction Class See Also Send Feedback
Gets the RecordedInteractionType.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionType RecordedInteractionType { get; }
Visual Basic
Public ReadOnly Property RecordedInteractionType As InteractionType
    Get

Field Value

The type of recorded interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteraction Class
RecorderInteraction Members
ININ.IceLib.Interactions Namespace


RecorderInteraction Events

[image] [image]

IceLib Technical Reference
RecorderInteraction Events
RecorderInteraction Class See Also Send Feedback

The RecorderInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

RecorderInteraction Class
ININ.IceLib.Interactions Namespace


RecorderInteractionAttributeName Class

[image]

IceLib Technical Reference
RecorderInteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with RecorderInteractions.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class RecorderInteractionAttributeName : InteractionAttributeName
Visual Basic
Public MustInherit Class RecorderInteractionAttributeName _
    Inherits InteractionAttributeName

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.Interactions..::..RecorderInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RecorderInteractionAttributeName Members

[image] [image]

IceLib Technical Reference
RecorderInteractionAttributeName Members
RecorderInteractionAttributeName Class Methods Fields See Also Send Feedback

The RecorderInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
RecordedFileName | The recorded file.
RecordedInteractionId | The recorded interaction ID.
RecordedInteractionType | The type of recorded interaction.

See Also

RecorderInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


RecorderInteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
RecorderInteractionAttributeName Fields
RecorderInteractionAttributeName Class See Also Send Feedback

The RecorderInteractionAttributeName type exposes the following members.

Fields

Name | Description
RecordedFileName | The recorded file.
RecordedInteractionId | The recorded interaction ID.
RecordedInteractionType | The type of recorded interaction.

See Also

RecorderInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


RecordedFileName Field

[image]

IceLib Technical Reference
RecorderInteractionAttributeName..::..RecordedFileName Field
RecorderInteractionAttributeName Class See Also Send Feedback
The recorded file.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordedFileName
Visual Basic
Public Shared ReadOnly RecordedFileName As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteractionAttributeName Class
RecorderInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RecordedInteractionId Field

[image]

IceLib Technical Reference
RecorderInteractionAttributeName..::..RecordedInteractionId Field
RecorderInteractionAttributeName Class See Also Send Feedback
The recorded interaction ID.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordedInteractionId
Visual Basic
Public Shared ReadOnly RecordedInteractionId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteractionAttributeName Class
RecorderInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RecordedInteractionType Field

[image]

IceLib Technical Reference
RecorderInteractionAttributeName..::..RecordedInteractionType Field
RecorderInteractionAttributeName Class See Also Send Feedback
The type of recorded interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordedInteractionType
Visual Basic
Public Shared ReadOnly RecordedInteractionType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RecorderInteractionAttributeName Class
RecorderInteractionAttributeName Members
ININ.IceLib.Interactions Namespace


RecorderInteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
RecorderInteractionAttributeName Methods
RecorderInteractionAttributeName Class See Also Send Feedback

The RecorderInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecorderInteractionAttributeName Class
ININ.IceLib.Interactions Namespace


RecordingSnippetCreatedEventArgs Class

[image]

IceLib Technical Reference
RecordingSnippetCreatedEventArgs Class
Members See Also Send Feedback
Provides data for the RecordingSnippetCreated event of a Interaction.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecordingSnippetCreatedEventArgs : EventArgs
Visual Basic
Public Class RecordingSnippetCreatedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..RecordingSnippetCreatedEventArgs

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingSnippetCreatedEventArgs Members
ININ.IceLib.Interactions Namespace


RecordingSnippetCreatedEventArgs Members

[image] [image]

IceLib Technical Reference
RecordingSnippetCreatedEventArgs Members
RecordingSnippetCreatedEventArgs Class Constructors Methods Properties See Also Send Feedback

The RecordingSnippetCreatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RecordingSnippetCreatedEventArgs | Initializes a new instance of the RecordingSnippetCreatedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RecordingSnippetId | Gets the recording snippet Id created.

See Also

RecordingSnippetCreatedEventArgs Class
ININ.IceLib.Interactions Namespace


RecordingSnippetCreatedEventArgs Constructor

[image]

IceLib Technical Reference
RecordingSnippetCreatedEventArgs Constructor
RecordingSnippetCreatedEventArgs Class See Also Send Feedback
Initializes a new instance of the RecordingSnippetCreatedEventArgs class with the specified values.

Note: This constructor is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecordingSnippetCreatedEventArgs(
    Guid recordingSnippetId
)
Visual Basic
Public Sub New ( _
    recordingSnippetId As Guid _
)

Parameters

recordingSnippetId
Type: System..::..Guid
The recording snippet ID.

Exceptions

Exception | Condition
System..::..ArgumentException | A parameter is Empty.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingSnippetCreatedEventArgs Class
RecordingSnippetCreatedEventArgs Members
ININ.IceLib.Interactions Namespace


RecordingSnippetCreatedEventArgs Methods

[image] [image]

IceLib Technical Reference
RecordingSnippetCreatedEventArgs Methods
RecordingSnippetCreatedEventArgs Class See Also Send Feedback

The RecordingSnippetCreatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordingSnippetCreatedEventArgs Class
ININ.IceLib.Interactions Namespace


RecordingSnippetCreatedEventArgs Properties

[image] [image]

IceLib Technical Reference
RecordingSnippetCreatedEventArgs Properties
RecordingSnippetCreatedEventArgs Class See Also Send Feedback

The RecordingSnippetCreatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | RecordingSnippetId | Gets the recording snippet Id created.

See Also

RecordingSnippetCreatedEventArgs Class
ININ.IceLib.Interactions Namespace


RecordingSnippetId Property

[image]

IceLib Technical Reference
RecordingSnippetCreatedEventArgs..::..RecordingSnippetId Property
RecordingSnippetCreatedEventArgs Class See Also Send Feedback
Gets the recording snippet Id created.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Guid RecordingSnippetId { get; private set; }
Visual Basic
Public Property RecordingSnippetId As Guid
    Get
    Private Set

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingSnippetCreatedEventArgs Class
RecordingSnippetCreatedEventArgs Members
ININ.IceLib.Interactions Namespace


RelatedSnippetRecording Class

[image]

IceLib Technical Reference
RelatedSnippetRecording Class
Members See Also Send Feedback
Represents a related snippet recording of an Interaction.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RelatedSnippetRecording
Visual Basic
Public Class RelatedSnippetRecording

Remarks

Objects of this class are used in a list of related snippet recordings for a given interaction.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..RelatedSnippetRecording

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RelatedSnippetRecording Members
ININ.IceLib.Interactions Namespace


RelatedSnippetRecording Members

[image] [image]

IceLib Technical Reference
RelatedSnippetRecording Members
RelatedSnippetRecording Class Methods Properties See Also Send Feedback

The RelatedSnippetRecording type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | SnippetRecordingId | Gets the recording ID associated with this snippet recording.
Public property | Time | Gets the start time of the snippet recording.
Public property | UserId | Gets the user ID associated with this snippet recording.

See Also

RelatedSnippetRecording Class
ININ.IceLib.Interactions Namespace


RelatedSnippetRecording Methods

[image] [image]

IceLib Technical Reference
RelatedSnippetRecording Methods
RelatedSnippetRecording Class See Also Send Feedback

The RelatedSnippetRecording type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RelatedSnippetRecording Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
RelatedSnippetRecording..::..ToString Method
RelatedSnippetRecording Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RelatedSnippetRecording Class
RelatedSnippetRecording Members
ININ.IceLib.Interactions Namespace


RelatedSnippetRecording Properties

[image] [image]

IceLib Technical Reference
RelatedSnippetRecording Properties
RelatedSnippetRecording Class See Also Send Feedback

The RelatedSnippetRecording type exposes the following members.

Properties

 | Name | Description
Public property | SnippetRecordingId | Gets the recording ID associated with this snippet recording.
Public property | Time | Gets the start time of the snippet recording.
Public property | UserId | Gets the user ID associated with this snippet recording.

See Also

RelatedSnippetRecording Class
ININ.IceLib.Interactions Namespace


SnippetRecordingId Property

[image]

IceLib Technical Reference
RelatedSnippetRecording..::..SnippetRecordingId Property
RelatedSnippetRecording Class See Also Send Feedback
Gets the recording ID associated with this snippet recording.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SnippetRecordingId { get; private set; }
Visual Basic
Public Property SnippetRecordingId As String
    Get
    Private Set

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RelatedSnippetRecording Class
RelatedSnippetRecording Members
ININ.IceLib.Interactions Namespace


Time Property

[image]

IceLib Technical Reference
RelatedSnippetRecording..::..Time Property
RelatedSnippetRecording Class See Also Send Feedback
Gets the start time of the snippet recording.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Time { get; private set; }
Visual Basic
Public Property Time As DateTime
    Get
    Private Set

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RelatedSnippetRecording Class
RelatedSnippetRecording Members
ININ.IceLib.Interactions Namespace


UserId Property

[image]

IceLib Technical Reference
RelatedSnippetRecording..::..UserId Property
RelatedSnippetRecording Class See Also Send Feedback
Gets the user ID associated with this snippet recording.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; private set; }
Visual Basic
Public Property UserId As String
    Get
    Private Set

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RelatedSnippetRecording Class
RelatedSnippetRecording Members
ININ.IceLib.Interactions Namespace


ScreenPop Class

[image]

IceLib Technical Reference
ScreenPop Class
Members See Also Send Feedback
This class serves as the main interface for tracking when DDE screen pops occur.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScreenPop
Visual Basic
Public Class ScreenPop

Remarks

A ScreenPop object is used to receive notifications when a DDE screen pop is received. Upon receipt the ScreenPopCreated event is triggered if this ScreenPop object has watching turned on. Watching is turned on and off via the StartWatching()()()() and StopWatching()()()() functions. Screen pops are dde events that are triggered by the "Actions" item in Interaction Administrator.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ScreenPop

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Members
ININ.IceLib.Interactions Namespace


ScreenPop Members

[image] [image]

IceLib Technical Reference
ScreenPop Members
ScreenPop Class Constructors Methods Events See Also Send Feedback

The ScreenPop type exposes the following members.

Constructors

 | Name | Description
Public method | ScreenPop | Initializes a new instance of the ScreenPop class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a screen pop watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for screen pops.
Public method | StartWatchingAsync | Asynchronously starts watching for screen pops.
Public method | StopWatching | Stops watching for screen pops.
Public method | StopWatchingAsync | Asynchronously stops watching for screen pops.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | ScreenPopCreated | Occurs when a screen pop message is added to the system.

See Also

ScreenPop Class
ININ.IceLib.Interactions Namespace


ScreenPop Constructor

[image]

IceLib Technical Reference
ScreenPop Constructor
ScreenPop Class See Also Send Feedback
Initializes a new instance of the ScreenPop class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ScreenPop(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


ScreenPop Methods

[image] [image]

IceLib Technical Reference
ScreenPop Methods
ScreenPop Class See Also Send Feedback

The ScreenPop type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a screen pop watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for screen pops.
Public method | StartWatchingAsync | Asynchronously starts watching for screen pops.
Public method | StopWatching | Stops watching for screen pops.
Public method | StopWatchingAsync | Asynchronously stops watching for screen pops.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenPop Class
ININ.IceLib.Interactions Namespace


IsWatching Method

[image]

IceLib Technical Reference
ScreenPop..::..IsWatching Method
ScreenPop Class See Also Send Feedback
Determines whether a screen pop watch is active.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a screen pop watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a screen pop watch is in place.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


StartWatching Method

[image]

IceLib Technical Reference
ScreenPop..::..StartWatching Method
ScreenPop Class See Also Send Feedback
Starts watching for screen pops.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
ScreenPop..::..StartWatchingAsync Method
ScreenPop Class See Also Send Feedback
Asynchronously starts watching for screen pops.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


StopWatching Method

[image]

IceLib Technical Reference
ScreenPop..::..StopWatching Method
ScreenPop Class See Also Send Feedback
Stops watching for screen pops.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
ScreenPop..::..StopWatchingAsync Method
ScreenPop Class See Also Send Feedback
Asynchronously stops watching for screen pops.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


ScreenPop Events

[image] [image]

IceLib Technical Reference
ScreenPop Events
ScreenPop Class See Also Send Feedback

The ScreenPop type exposes the following members.

Events

 | Name | Description
Public event | ScreenPopCreated | Occurs when a screen pop message is added to the system.

See Also

ScreenPop Class
ININ.IceLib.Interactions Namespace


ScreenPopCreated Event

[image]

IceLib Technical Reference
ScreenPop..::..ScreenPopCreated Event
ScreenPop Class See Also Send Feedback
Occurs when a screen pop message is added to the system.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ScreenPopEventArgs> ScreenPopCreated
Visual Basic
Public Event ScreenPopCreated As EventHandler(Of ScreenPopEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPop Class
ScreenPop Members
ININ.IceLib.Interactions Namespace


ScreenPopEventArgs Class

[image]

IceLib Technical Reference
ScreenPopEventArgs Class
Members See Also Send Feedback
Provides data for the screen pop events of ScreenPop.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScreenPopEventArgs : EventArgs
Visual Basic
Public Class ScreenPopEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Interactions..::..ScreenPopEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopEventArgs Members
ININ.IceLib.Interactions Namespace


ScreenPopEventArgs Members

[image] [image]

IceLib Technical Reference
ScreenPopEventArgs Members
ScreenPopEventArgs Class Methods Properties See Also Send Feedback

The ScreenPopEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ScreenPopItem | Gets the screen pop item.

See Also

ScreenPopEventArgs Class
ININ.IceLib.Interactions Namespace


ScreenPopEventArgs Methods

[image] [image]

IceLib Technical Reference
ScreenPopEventArgs Methods
ScreenPopEventArgs Class See Also Send Feedback

The ScreenPopEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenPopEventArgs Class
ININ.IceLib.Interactions Namespace


ScreenPopEventArgs Properties

[image] [image]

IceLib Technical Reference
ScreenPopEventArgs Properties
ScreenPopEventArgs Class See Also Send Feedback

The ScreenPopEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ScreenPopItem | Gets the screen pop item.

See Also

ScreenPopEventArgs Class
ININ.IceLib.Interactions Namespace


ScreenPopItem Property

[image]

IceLib Technical Reference
ScreenPopEventArgs..::..ScreenPopItem Property
ScreenPopEventArgs Class See Also Send Feedback
Gets the screen pop item.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ScreenPopItem ScreenPopItem { get; }
Visual Basic
Public ReadOnly Property ScreenPopItem As ScreenPopItem
    Get

Field Value

The screen pop item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopEventArgs Class
ScreenPopEventArgs Members
ININ.IceLib.Interactions Namespace


ScreenPopItem Class

[image]

IceLib Technical Reference
ScreenPopItem Class
Members See Also Send Feedback
This class contains the ScreenPop event data.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScreenPopItem
Visual Basic
Public Class ScreenPopItem

Remarks

The ScreenPopItem object holds the data for a DDE command that is to be issued as a result of the ScreenPopCreated event.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..ScreenPopItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Members
ININ.IceLib.Interactions Namespace


ScreenPopItem Members

[image] [image]

IceLib Technical Reference
ScreenPopItem Members
ScreenPopItem Class Methods Properties See Also Send Feedback

The ScreenPopItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionName | Gets the name of this screen pop.
Public property | ApplicationName | Gets the name of the application that the DDE command executes.
Public property | Commands | Gets the list of DDE commands.
Public property | ExecutableName | Gets the name of the executable that the DDE command executes.
Public property | InteractionId | Gets the interaction ID that triggered this screen pop.
Public property | TopicName | Gets the DDE topic command name.

See Also

ScreenPopItem Class
ININ.IceLib.Interactions Namespace


ScreenPopItem Methods

[image] [image]

IceLib Technical Reference
ScreenPopItem Methods
ScreenPopItem Class See Also Send Feedback

The ScreenPopItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenPopItem Class
ININ.IceLib.Interactions Namespace


ScreenPopItem Properties

[image] [image]

IceLib Technical Reference
ScreenPopItem Properties
ScreenPopItem Class See Also Send Feedback

The ScreenPopItem type exposes the following members.

Properties

 | Name | Description
Public property | ActionName | Gets the name of this screen pop.
Public property | ApplicationName | Gets the name of the application that the DDE command executes.
Public property | Commands | Gets the list of DDE commands.
Public property | ExecutableName | Gets the name of the executable that the DDE command executes.
Public property | InteractionId | Gets the interaction ID that triggered this screen pop.
Public property | TopicName | Gets the DDE topic command name.

See Also

ScreenPopItem Class
ININ.IceLib.Interactions Namespace


ActionName Property

[image]

IceLib Technical Reference
ScreenPopItem..::..ActionName Property
ScreenPopItem Class See Also Send Feedback
Gets the name of this screen pop.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ActionName { get; }
Visual Basic
Public ReadOnly Property ActionName As String
    Get

Field Value

The name of the action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Class
ScreenPopItem Members
ININ.IceLib.Interactions Namespace


ApplicationName Property

[image]

IceLib Technical Reference
ScreenPopItem..::..ApplicationName Property
ScreenPopItem Class See Also Send Feedback
Gets the name of the application that the DDE command executes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationName { get; }
Visual Basic
Public ReadOnly Property ApplicationName As String
    Get

Field Value

The name of the application.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Class
ScreenPopItem Members
ININ.IceLib.Interactions Namespace


Commands Property

[image]

IceLib Technical Reference
ScreenPopItem..::..Commands Property
ScreenPopItem Class See Also Send Feedback
Gets the list of DDE commands.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public List<string> Commands { get; }
Visual Basic
Public ReadOnly Property Commands As List(Of String)
    Get

Field Value

The commands.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Class
ScreenPopItem Members
ININ.IceLib.Interactions Namespace


ExecutableName Property

[image]

IceLib Technical Reference
ScreenPopItem..::..ExecutableName Property
ScreenPopItem Class See Also Send Feedback
Gets the name of the executable that the DDE command executes.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExecutableName { get; }
Visual Basic
Public ReadOnly Property ExecutableName As String
    Get

Field Value

The name of the executable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Class
ScreenPopItem Members
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
ScreenPopItem..::..InteractionId Property
ScreenPopItem Class See Also Send Feedback
Gets the interaction ID that triggered this screen pop.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As Long
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Class
ScreenPopItem Members
ININ.IceLib.Interactions Namespace


TopicName Property

[image]

IceLib Technical Reference
ScreenPopItem..::..TopicName Property
ScreenPopItem Class See Also Send Feedback
Gets the DDE topic command name.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TopicName { get; }
Visual Basic
Public ReadOnly Property TopicName As String
    Get

Field Value

The name of the topic.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenPopItem Class
ScreenPopItem Members
ININ.IceLib.Interactions Namespace


SecureInputParameters Class

[image]

IceLib Technical Reference
SecureInputParameters Class
Members See Also Send Feedback
Provides details when initiating secure input via the InitiateSecureInput(SecureInputParameters) method.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecureInputParameters
Visual Basic
Public Class SecureInputParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..SecureInputParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputParameters Members
ININ.IceLib.Interactions Namespace


SecureInputParameters Members

[image] [image]

IceLib Technical Reference
SecureInputParameters Members
SecureInputParameters Class Constructors Methods Properties See Also Send Feedback

The SecureInputParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SecureInputParameters | Initializes a new instance of the SecureInputParameters class to be used to initiate secure input.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of SecureInputParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FormFields | Gets the name/value pairs from the form.
Public property | IvrHandlerName | Gets the IVR handler name.

See Also

SecureInputParameters Class
ININ.IceLib.Interactions Namespace


SecureInputParameters Constructor

[image]

IceLib Technical Reference
SecureInputParameters Constructor
SecureInputParameters Class See Also Send Feedback
Initializes a new instance of the SecureInputParameters class to be used to initiate secure input.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureInputParameters(
    string ivrHandlerName,
    IDictionary<string, string> formFields
)
Visual Basic
Public Sub New ( _
    ivrHandlerName As String, _
    formFields As IDictionary(Of String, String) _
)

Parameters

ivrHandlerName
Type: System..::..String
The ivr handler name.
formFields
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The name/value pairs from the form.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Parameter ivrHandlerName or formFields was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Parameter ivrHandlerName was an empty string or formFields' collection was empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputParameters Class
SecureInputParameters Members
ININ.IceLib.Interactions Namespace


SecureInputParameters Methods

[image] [image]

IceLib Technical Reference
SecureInputParameters Methods
SecureInputParameters Class See Also Send Feedback

The SecureInputParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of SecureInputParameters. (Overrides Object..::..ToString()()()().)

See Also

SecureInputParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
SecureInputParameters..::..ToString Method
SecureInputParameters Class See Also Send Feedback
Gets the string representation of SecureInputParameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Field Value

The string representation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputParameters Class
SecureInputParameters Members
ININ.IceLib.Interactions Namespace


SecureInputParameters Properties

[image] [image]

IceLib Technical Reference
SecureInputParameters Properties
SecureInputParameters Class See Also Send Feedback

The SecureInputParameters type exposes the following members.

Properties

 | Name | Description
Public property | FormFields | Gets the name/value pairs from the form.
Public property | IvrHandlerName | Gets the IVR handler name.

See Also

SecureInputParameters Class
ININ.IceLib.Interactions Namespace


FormFields Property

[image]

IceLib Technical Reference
SecureInputParameters..::..FormFields Property
SecureInputParameters Class See Also Send Feedback
Gets the name/value pairs from the form.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> FormFields { get; private set; }
Visual Basic
Public Property FormFields As IDictionary(Of String, String)
    Get
    Private Set

Field Value

The name/value pairs from the form.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputParameters Class
SecureInputParameters Members
ININ.IceLib.Interactions Namespace


IvrHandlerName Property

[image]

IceLib Technical Reference
SecureInputParameters..::..IvrHandlerName Property
SecureInputParameters Class See Also Send Feedback
Gets the IVR handler name.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IvrHandlerName { get; private set; }
Visual Basic
Public Property IvrHandlerName As String
    Get
    Private Set

Field Value

The IVR handler name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

SecureInputParameters Class
SecureInputParameters Members
ININ.IceLib.Interactions Namespace


SecureRecordingPauseAction Enumeration

[image]

IceLib Technical Reference
SecureRecordingPauseAction Enumeration
See Also Send Feedback
Specifies the secure recording pause action that should be taken.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum SecureRecordingPauseAction
Visual Basic
Public Enumeration SecureRecordingPauseAction

Members

Member name | Value | Description
None | 0 | Performs no action.
PauseWithDefaultTimeout 1 Pauses a secure recording with the default time specified in Interaction Administrator.
Note
If a timed secure recording pause is already in effect, then this will reset the pause timer to the default value in Interaction Administrator. Pauses are not cumulative, so if 10 seconds were remaining on a current pause and the default was set at 15 seconds, the recording would only be paused for 15 seconds following this request, not 25.
PauseWithInfiniteTimeout | 2 | Pauses a secure recording indefinitely.
PauseWithSpecifiedTimeout 3 Pauses a secure recording for a specified time.
Note
If a timed secure recording pause is already in effect, then this will reset the pause timer to the specified timeout value. Pauses are not cumulative, so if 10 seconds were remaining on a current pause and 15 seconds were specified for this pause, the recording would only be paused for 15 seconds following this request, not 25.
ResumeRecording | 4 | Restarts a secure recording on the interaction if it was paused. If a secure recording is not paused, this action will have no effect and the recording will continue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Class

[image]

IceLib Technical Reference
SecureRecordingPauseParameters Class
Members See Also Send Feedback
Provides a mechanism to pass secure recording pause parameters. Used in SecureRecordingPause(SecureRecordingPauseParameters) and SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object).

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SecureRecordingPauseParameters
Visual Basic
Public Class SecureRecordingPauseParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..SecureRecordingPauseParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

SecureRecordingPauseParameters Members
ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Members

[image] [image]

IceLib Technical Reference
SecureRecordingPauseParameters Members
SecureRecordingPauseParameters Class Constructors Methods Properties See Also Send Feedback

The SecureRecordingPauseParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SecureRecordingPauseParameters(TimeSpan) | Initializes a new instance of the SecureRecordingPauseParameters class. Action will be set to PauseWithSpecifiedTimeout.
Public method | SecureRecordingPauseParameters(SecureRecordingPauseAction) | Initializes a new instance of the SecureRecordingPauseParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the SecureRecordingPauseAction for this instance.
Public property | Timeout | Gets the timeout for this instance.

See Also

SecureRecordingPauseParameters Class
ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Constructor

[image] [image]

IceLib Technical Reference
SecureRecordingPauseParameters Constructor
SecureRecordingPauseParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SecureRecordingPauseParameters(TimeSpan) | Initializes a new instance of the SecureRecordingPauseParameters class. Action will be set to PauseWithSpecifiedTimeout.
Public method | SecureRecordingPauseParameters(SecureRecordingPauseAction) | Initializes a new instance of the SecureRecordingPauseParameters class.

See Also

SecureRecordingPauseParameters Class
SecureRecordingPauseParameters Members
ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Constructor (TimeSpan)

[image]

IceLib Technical Reference
SecureRecordingPauseParameters Constructor (TimeSpan)
SecureRecordingPauseParameters Class See Also Send Feedback
Initializes a new instance of the SecureRecordingPauseParameters class. Action will be set to PauseWithSpecifiedTimeout.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureRecordingPauseParameters(
    TimeSpan timeout
)
Visual Basic
Public Sub New ( _
    timeout As TimeSpan _
)

Parameters

timeout
Type: System..::..TimeSpan
The period of time for which a secure recording should be paused. Must be greater than zero and TotalSeconds must be less than MaxValue.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The timeout was less than 1 or greater than or equal to MaxValue seconds.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

SecureRecordingPauseParameters Class
SecureRecordingPauseParameters Members
SecureRecordingPauseParameters Overload
ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Constructor (SecureRecordingPauseAction)

[image]

IceLib Technical Reference
SecureRecordingPauseParameters Constructor (SecureRecordingPauseAction)
SecureRecordingPauseParameters Class See Also Send Feedback
Initializes a new instance of the SecureRecordingPauseParameters class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureRecordingPauseParameters(
    SecureRecordingPauseAction action
)
Visual Basic
Public Sub New ( _
    action As SecureRecordingPauseAction _
)

Parameters

action
Type: ININ.IceLib.Interactions..::..SecureRecordingPauseAction
The action to perform. If PauseWithSpecifiedTimeout is desired, use SecureRecordingPauseParameters(TimeSpan) instead.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The action was None or PauseWithSpecifiedTimeout.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

SecureRecordingPauseParameters Class
SecureRecordingPauseParameters Members
SecureRecordingPauseParameters Overload
ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Methods

[image] [image]

IceLib Technical Reference
SecureRecordingPauseParameters Methods
SecureRecordingPauseParameters Class See Also Send Feedback

The SecureRecordingPauseParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecureRecordingPauseParameters Class
ININ.IceLib.Interactions Namespace


SecureRecordingPauseParameters Properties

[image] [image]

IceLib Technical Reference
SecureRecordingPauseParameters Properties
SecureRecordingPauseParameters Class See Also Send Feedback

The SecureRecordingPauseParameters type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the SecureRecordingPauseAction for this instance.
Public property | Timeout | Gets the timeout for this instance.

See Also

SecureRecordingPauseParameters Class
ININ.IceLib.Interactions Namespace


Action Property

[image]

IceLib Technical Reference
SecureRecordingPauseParameters..::..Action Property
SecureRecordingPauseParameters Class See Also Send Feedback
Gets the SecureRecordingPauseAction for this instance.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SecureRecordingPauseAction Action { get; private set; }
Visual Basic
Public Property Action As SecureRecordingPauseAction
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

SecureRecordingPauseParameters Class
SecureRecordingPauseParameters Members
ININ.IceLib.Interactions Namespace


Timeout Property

[image]

IceLib Technical Reference
SecureRecordingPauseParameters..::..Timeout Property
SecureRecordingPauseParameters Class See Also Send Feedback
Gets the timeout for this instance.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Timeout { get; private set; }
Visual Basic
Public Property Timeout As TimeSpan
    Get
    Private Set

Remarks

This is the period of time for which a secure recording should be paused.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

SecureRecordingPauseParameters Class
SecureRecordingPauseParameters Members
ININ.IceLib.Interactions Namespace


SendAssistanceRequestParameters Class

[image]

IceLib Technical Reference
SendAssistanceRequestParameters Class
Members See Also Send Feedback
Provides details when sending an assistance request via SendAssistanceRequest(SendAssistanceRequestParameters).

Note: This class is supported for IC Server version 4.0 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SendAssistanceRequestParameters
Visual Basic
Public Class SendAssistanceRequestParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..SendAssistanceRequestParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendAssistanceRequestParameters Members
ININ.IceLib.Interactions Namespace


SendAssistanceRequestParameters Members

[image] [image]

IceLib Technical Reference
SendAssistanceRequestParameters Members
SendAssistanceRequestParameters Class Constructors Methods Properties See Also Send Feedback

The SendAssistanceRequestParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SendAssistanceRequestParameters | Initializes a new instance of SendAssistanceRequestParameters with the specified parameters.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | InteractionId | Gets the interaction ID associated with the assistance request.
Public property | ProblemDescription | Gets the text that describes the problem for the assistance request.

See Also

SendAssistanceRequestParameters Class
ININ.IceLib.Interactions Namespace


SendAssistanceRequestParameters Constructor

[image]

IceLib Technical Reference
SendAssistanceRequestParameters Constructor
SendAssistanceRequestParameters Class See Also Send Feedback
Initializes a new instance of SendAssistanceRequestParameters with the specified parameters.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SendAssistanceRequestParameters(
    InteractionId interactionId,
    string problemDescription
)
Visual Basic
Public Sub New ( _
    interactionId As InteractionId, _
    problemDescription As String _
)

Parameters

interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.
problemDescription
Type: System..::..String
The problem description.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendAssistanceRequestParameters Class
SendAssistanceRequestParameters Members
ININ.IceLib.Interactions Namespace


SendAssistanceRequestParameters Methods

[image] [image]

IceLib Technical Reference
SendAssistanceRequestParameters Methods
SendAssistanceRequestParameters Class See Also Send Feedback

The SendAssistanceRequestParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SendAssistanceRequestParameters Class
ININ.IceLib.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
SendAssistanceRequestParameters..::..ToString Method
SendAssistanceRequestParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SendAssistanceRequestParameters Class
SendAssistanceRequestParameters Members
ININ.IceLib.Interactions Namespace


SendAssistanceRequestParameters Properties

[image] [image]

IceLib Technical Reference
SendAssistanceRequestParameters Properties
SendAssistanceRequestParameters Class See Also Send Feedback

The SendAssistanceRequestParameters type exposes the following members.

Properties

 | Name | Description
Public property | InteractionId | Gets the interaction ID associated with the assistance request.
Public property | ProblemDescription | Gets the text that describes the problem for the assistance request.

See Also

SendAssistanceRequestParameters Class
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
SendAssistanceRequestParameters..::..InteractionId Property
SendAssistanceRequestParameters Class See Also Send Feedback
Gets the interaction ID associated with the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As InteractionId
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendAssistanceRequestParameters Class
SendAssistanceRequestParameters Members
ININ.IceLib.Interactions Namespace


ProblemDescription Property

[image]

IceLib Technical Reference
SendAssistanceRequestParameters..::..ProblemDescription Property
SendAssistanceRequestParameters Class See Also Send Feedback
Gets the text that describes the problem for the assistance request.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProblemDescription { get; }
Visual Basic
Public ReadOnly Property ProblemDescription As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SendAssistanceRequestParameters Class
SendAssistanceRequestParameters Members
ININ.IceLib.Interactions Namespace


SensitiveAttributeDataContext Class

[image]

IceLib Technical Reference
SensitiveAttributeDataContext Class
Members See Also Send Feedback
Provides access to the Session's sensitive data context for Interaction attributes.

Note: This class is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SensitiveAttributeDataContext
Visual Basic
Public Class SensitiveAttributeDataContext

Remarks

Use this class to get access to the Session's sensitive data information for Interaction attributes.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..SensitiveAttributeDataContext

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveAttributeDataContext Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Connection..::..SensitiveDataContext


SensitiveAttributeDataContext Members

[image] [image]

IceLib Technical Reference
SensitiveAttributeDataContext Members
SensitiveAttributeDataContext Class Methods Properties Events See Also Send Feedback

The SensitiveAttributeDataContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToSensitiveInteractionAttributeValue | Gets the attribute value that should be traced, adhering to sensitive data settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SensitiveInteractionAttributeKeys | Gets the interaction / queue attributes that contain sensitive data.

Events

 | Name | Description
Public event | SensitiveDataContextChanged | Occurs when the sensitive data context has changed.

See Also

SensitiveAttributeDataContext Class
ININ.IceLib.Interactions Namespace


SensitiveAttributeDataContext Methods

[image] [image]

IceLib Technical Reference
SensitiveAttributeDataContext Methods
SensitiveAttributeDataContext Class See Also Send Feedback

The SensitiveAttributeDataContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToSensitiveInteractionAttributeValue | Gets the attribute value that should be traced, adhering to sensitive data settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SensitiveAttributeDataContext Class
ININ.IceLib.Interactions Namespace


ToSensitiveInteractionAttributeValue Method

[image]

IceLib Technical Reference
SensitiveAttributeDataContext..::..ToSensitiveInteractionAttributeValue Method
SensitiveAttributeDataContext Class See Also Send Feedback
Gets the attribute value that should be traced, adhering to sensitive data settings.

Note: This method is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ToSensitiveInteractionAttributeValue(
    string attributeName,
    string attributeValue
)
Visual Basic
Public Function ToSensitiveInteractionAttributeValue ( _
    attributeName As String, _
    attributeValue As String _
) As String

Parameters

attributeName
Type: System..::..String
The attribute name.
attributeValue
Type: System..::..String
The attribute value.

Return Value

Either attributeValue or the hash value of attributeValue if attributeKey is marked as sensitive, values should not be traced.

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveAttributeDataContext Class
SensitiveAttributeDataContext Members
ININ.IceLib.Interactions Namespace


SensitiveAttributeDataContext Properties

[image] [image]

IceLib Technical Reference
SensitiveAttributeDataContext Properties
SensitiveAttributeDataContext Class See Also Send Feedback

The SensitiveAttributeDataContext type exposes the following members.

Properties

 | Name | Description
Public property | SensitiveInteractionAttributeKeys | Gets the interaction / queue attributes that contain sensitive data.

See Also

SensitiveAttributeDataContext Class
ININ.IceLib.Interactions Namespace


SensitiveInteractionAttributeKeys Property

[image]

IceLib Technical Reference
SensitiveAttributeDataContext..::..SensitiveInteractionAttributeKeys Property
SensitiveAttributeDataContext Class See Also Send Feedback
Gets the interaction / queue attributes that contain sensitive data.

Note: This property is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> SensitiveInteractionAttributeKeys { get; }
Visual Basic
Public ReadOnly Property SensitiveInteractionAttributeKeys As ReadOnlyCollection(Of String)
    Get

Field Value

The sensitive attributes.

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveAttributeDataContext Class
SensitiveAttributeDataContext Members
ININ.IceLib.Interactions Namespace


SensitiveAttributeDataContext Events

[image] [image]

IceLib Technical Reference
SensitiveAttributeDataContext Events
SensitiveAttributeDataContext Class See Also Send Feedback

The SensitiveAttributeDataContext type exposes the following members.

Events

 | Name | Description
Public event | SensitiveDataContextChanged | Occurs when the sensitive data context has changed.

See Also

SensitiveAttributeDataContext Class
ININ.IceLib.Interactions Namespace


SensitiveDataContextChanged Event

[image]

IceLib Technical Reference
SensitiveAttributeDataContext..::..SensitiveDataContextChanged Event
SensitiveAttributeDataContext Class See Also Send Feedback
Occurs when the sensitive data context has changed.

Note: This event is supported for IC Server version 2018 R2 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EventArgs> SensitiveDataContextChanged
Visual Basic
Public Event SensitiveDataContextChanged As EventHandler(Of EventArgs)

Version Information

Supported for IC Server version 2018 R2 and beyond.

See Also

SensitiveAttributeDataContext Class
SensitiveAttributeDataContext Members
ININ.IceLib.Interactions Namespace


SocialConversationInteraction Class

[image]

IceLib Technical Reference
SocialConversationInteraction Class
Members See Also Send Feedback
SocialConversationInteraction - Social Conversation Interactions are handled here

Note: This class is supported for IC Server version 2021 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SocialConversationInteraction : Interaction
Visual Basic
Public Class SocialConversationInteraction _
    Inherits Interaction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..SocialConversationInteraction

Version Information

Supported for IC Server version 2021 R3 and beyond.

See Also

SocialConversationInteraction Members
ININ.IceLib.Interactions Namespace


SocialConversationInteraction Members

[image] [image]

IceLib Technical Reference
SocialConversationInteraction Members
SocialConversationInteraction Class Constructors Methods Properties Events See Also Send Feedback

The SocialConversationInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | SocialConversationInteraction | Initializes a new instance of the SocialConversationInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

SocialConversationInteraction Class
ININ.IceLib.Interactions Namespace


SocialConversationInteraction Constructor

[image]

IceLib Technical Reference
SocialConversationInteraction Constructor
SocialConversationInteraction Class See Also Send Feedback
Initializes a new instance of the SocialConversationInteraction class.

Note: This constructor is supported for IC Server version 2021 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SocialConversationInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2021 R3 and beyond.

See Also

SocialConversationInteraction Class
SocialConversationInteraction Members
ININ.IceLib.Interactions Namespace


SocialConversationInteraction Methods

[image] [image]

IceLib Technical Reference
SocialConversationInteraction Methods
SocialConversationInteraction Class See Also Send Feedback

The SocialConversationInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

SocialConversationInteraction Class
ININ.IceLib.Interactions Namespace


SocialConversationInteraction Properties

[image] [image]

IceLib Technical Reference
SocialConversationInteraction Properties
SocialConversationInteraction Class See Also Send Feedback

The SocialConversationInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

SocialConversationInteraction Class
ININ.IceLib.Interactions Namespace


SocialConversationInteraction Events

[image] [image]

IceLib Technical Reference
SocialConversationInteraction Events
SocialConversationInteraction Class See Also Send Feedback

The SocialConversationInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

SocialConversationInteraction Class
ININ.IceLib.Interactions Namespace


SocialDirectMessageInteraction Class

[image]

IceLib Technical Reference
SocialDirectMessageInteraction Class
Members See Also Send Feedback
Represents Social Direct Message within the Interaction Center system.

Note: This class is supported for IC Server version 2021 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SocialDirectMessageInteraction : Interaction
Visual Basic
Public Class SocialDirectMessageInteraction _
    Inherits Interaction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Interactions..::..SocialDirectMessageInteraction

Version Information

Supported for IC Server version 2021 R3 and beyond.

See Also

SocialDirectMessageInteraction Members
ININ.IceLib.Interactions Namespace


SocialDirectMessageInteraction Members

[image] [image]

IceLib Technical Reference
SocialDirectMessageInteraction Members
SocialDirectMessageInteraction Class Constructors Methods Properties Events See Also Send Feedback

The SocialDirectMessageInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | SocialDirectMessageInteraction | Initializes a new instance of the SocialDirectMessageInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

SocialDirectMessageInteraction Class
ININ.IceLib.Interactions Namespace


SocialDirectMessageInteraction Constructor

[image]

IceLib Technical Reference
SocialDirectMessageInteraction Constructor
SocialDirectMessageInteraction Class See Also Send Feedback
Initializes a new instance of the SocialDirectMessageInteraction class.

Note: This constructor is supported for IC Server version 2021 R3 and beyond.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SocialDirectMessageInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2021 R3 and beyond.

See Also

SocialDirectMessageInteraction Class
SocialDirectMessageInteraction Members
ININ.IceLib.Interactions Namespace


SocialDirectMessageInteraction Methods

[image] [image]

IceLib Technical Reference
SocialDirectMessageInteraction Methods
SocialDirectMessageInteraction Class See Also Send Feedback

The SocialDirectMessageInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

SocialDirectMessageInteraction Class
ININ.IceLib.Interactions Namespace


SocialDirectMessageInteraction Properties

[image] [image]

IceLib Technical Reference
SocialDirectMessageInteraction Properties
SocialDirectMessageInteraction Class See Also Send Feedback

The SocialDirectMessageInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

SocialDirectMessageInteraction Class
ININ.IceLib.Interactions Namespace


SocialDirectMessageInteraction Events

[image] [image]

IceLib Technical Reference
SocialDirectMessageInteraction Events
SocialDirectMessageInteraction Class See Also Send Feedback

The SocialDirectMessageInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

SocialDirectMessageInteraction Class
ININ.IceLib.Interactions Namespace


SupervisorAssistanceList Class

[image]

IceLib Technical Reference
SupervisorAssistanceList Class
Members See Also Send Feedback
This class represents a collection of assistance request items belonging to a supervisor.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SupervisorAssistanceList : AssistanceList
Visual Basic
Public Class SupervisorAssistanceList _
    Inherits AssistanceList

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..AssistanceList
ININ.IceLib.Interactions..::..SupervisorAssistanceList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SupervisorAssistanceList Members
ININ.IceLib.Interactions Namespace
ININ.IceLib.Interactions..::..AssistanceList


SupervisorAssistanceList Members

[image] [image]

IceLib Technical Reference
SupervisorAssistanceList Members
SupervisorAssistanceList Class Constructors Methods Properties Events See Also Send Feedback

The SupervisorAssistanceList type exposes the following members.

Constructors

 | Name | Description
Public method | SupervisorAssistanceList | Initializes a new instance of the SupervisorAssistanceList class.

Methods

 | Name | Description
Public method | Accept | Accepts an assistance request. (Inherited from AssistanceList.)
Public method | AcceptAsync | Asynchronously accepts an assistance request. (Inherited from AssistanceList.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssistanceRequests | Gets the list of assistance request items associated with this list. (Inherited from AssistanceList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Ignore | Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IgnoreAsync | Asynchronously Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IsWatching | Determines whether a watch is active. (Inherited from AssistanceList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatching | Stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets an assistance request item with the associated ID. (Inherited from AssistanceList.)

Events

 | Name | Description
Public event | ItemAdded | Event that occurs when a new assistance item is added to the assistance list. (Inherited from AssistanceList.)
Public event | ItemRemoved | Event that occurs when an assistance item is removed from the assistance list. (Inherited from AssistanceList.)
Public event | ItemStateChanged | Event that occurs when an assistance item's state changes in the assistance list. (Inherited from AssistanceList.)

See Also

SupervisorAssistanceList Class
ININ.IceLib.Interactions Namespace


SupervisorAssistanceList Constructor

[image]

IceLib Technical Reference
SupervisorAssistanceList Constructor
SupervisorAssistanceList Class See Also Send Feedback
Initializes a new instance of the SupervisorAssistanceList class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SupervisorAssistanceList(
    InteractionsManager interactionsManager
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SupervisorAssistanceList Class
SupervisorAssistanceList Members
ININ.IceLib.Interactions Namespace


SupervisorAssistanceList Methods

[image] [image]

IceLib Technical Reference
SupervisorAssistanceList Methods
SupervisorAssistanceList Class See Also Send Feedback

The SupervisorAssistanceList type exposes the following members.

Methods

 | Name | Description
Public method | Accept | Accepts an assistance request. (Inherited from AssistanceList.)
Public method | AcceptAsync | Asynchronously accepts an assistance request. (Inherited from AssistanceList.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssistanceRequests | Gets the list of assistance request items associated with this list. (Inherited from AssistanceList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Ignore | Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IgnoreAsync | Asynchronously Ignores an assistance request. (Inherited from AssistanceList.)
Public method | IsWatching | Determines whether a watch is active. (Inherited from AssistanceList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StartWatchingAsync | Asynchronously starts watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatching | Stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | StopWatchingAsync | Asynchronously stops watching the AssistanceList. (Inherited from AssistanceList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupervisorAssistanceList Class
ININ.IceLib.Interactions Namespace


SupervisorAssistanceList Properties

[image] [image]

IceLib Technical Reference
SupervisorAssistanceList Properties
SupervisorAssistanceList Class See Also Send Feedback

The SupervisorAssistanceList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets an assistance request item with the associated ID. (Inherited from AssistanceList.)

See Also

SupervisorAssistanceList Class
ININ.IceLib.Interactions Namespace


SupervisorAssistanceList Events

[image] [image]

IceLib Technical Reference
SupervisorAssistanceList Events
SupervisorAssistanceList Class See Also Send Feedback

The SupervisorAssistanceList type exposes the following members.

Events

 | Name | Description
Public event | ItemAdded | Event that occurs when a new assistance item is added to the assistance list. (Inherited from AssistanceList.)
Public event | ItemRemoved | Event that occurs when an assistance item is removed from the assistance list. (Inherited from AssistanceList.)
Public event | ItemStateChanged | Event that occurs when an assistance item's state changes in the assistance list. (Inherited from AssistanceList.)

See Also

SupervisorAssistanceList Class
ININ.IceLib.Interactions Namespace


WrapUpAssignment Class

[image]

IceLib Technical Reference
WrapUpAssignment Class
Members See Also Send Feedback
Representation of an assignment of a wrap-up code to a segment of an interaction.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public sealed class WrapUpAssignment : ICompoundAttributeValue
Visual Basic
Public NotInheritable Class WrapUpAssignment _
    Implements ICompoundAttributeValue

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..WrapUpAssignment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


WrapUpAssignment Members

[image] [image]

IceLib Technical Reference
WrapUpAssignment Members
WrapUpAssignment Class Constructors Methods Properties See Also Send Feedback

The WrapUpAssignment type exposes the following members.

Constructors

 | Name | Description
Public method | WrapUpAssignment | Initializes a new instance of the WrapUpAssignment class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionId | Gets the interaction ID of the interaction on the user queue.
Public property | SegmentId | Gets the segment ID at which the interaction was connected to the workgroup queue.
Public property | SourceInteractionId | Gets the interaction ID of the source interaction on the user queue. This is the interaction that has the attribute requiring a wrap up code. This will frequently be the same as InteractionId, but could differ.
Public property | Timestamp | Gets the time stamp, in UTC, at which the wrap-up was entered.
Public property | User | Gets the user name of the user that entered the wrap-up code.
Public property | WrapUpCode | Gets the identifier for the wrap-up code entered by the user.

See Also

WrapUpAssignment Class
ININ.IceLib.Interactions Namespace


WrapUpAssignment Constructor

[image]

IceLib Technical Reference
WrapUpAssignment Constructor
WrapUpAssignment Class See Also Send Feedback
Initializes a new instance of the WrapUpAssignment class.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WrapUpAssignment(
    InteractionId interactionId,
    InteractionId sourceInteractionId,
    int segmentId,
    string wrapUpCode,
    DateTime timeStamp
)
Visual Basic
Public Sub New ( _
    interactionId As InteractionId, _
    sourceInteractionId As InteractionId, _
    segmentId As Integer, _
    wrapUpCode As String, _
    timeStamp As DateTime _
)

Parameters

interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId of the interaction that will receive the wrap-up code.
sourceInteractionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId of the interaction that contains the attribute requiring a wrap-up code.
segmentId
Type: System..::..Int32
The segment ID for the wrap-up assignment. This should be a reference to LastSegment.
wrapUpCode
Type: System..::..String
The wrap up code.
timeStamp
Type: System..::..DateTime
The time stamp.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The interactionId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


WrapUpAssignment Methods

[image] [image]

IceLib Technical Reference
WrapUpAssignment Methods
WrapUpAssignment Class See Also Send Feedback

The WrapUpAssignment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WrapUpAssignment Class
ININ.IceLib.Interactions Namespace


WrapUpAssignment Properties

[image] [image]

IceLib Technical Reference
WrapUpAssignment Properties
WrapUpAssignment Class See Also Send Feedback

The WrapUpAssignment type exposes the following members.

Properties

 | Name | Description
Public property | InteractionId | Gets the interaction ID of the interaction on the user queue.
Public property | SegmentId | Gets the segment ID at which the interaction was connected to the workgroup queue.
Public property | SourceInteractionId | Gets the interaction ID of the source interaction on the user queue. This is the interaction that has the attribute requiring a wrap up code. This will frequently be the same as InteractionId, but could differ.
Public property | Timestamp | Gets the time stamp, in UTC, at which the wrap-up was entered.
Public property | User | Gets the user name of the user that entered the wrap-up code.
Public property | WrapUpCode | Gets the identifier for the wrap-up code entered by the user.

See Also

WrapUpAssignment Class
ININ.IceLib.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
WrapUpAssignment..::..InteractionId Property
WrapUpAssignment Class See Also Send Feedback
Gets the interaction ID of the interaction on the user queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId InteractionId { get; internal set; }
Visual Basic
Public Property InteractionId As InteractionId
    Get
    Friend Set

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


SegmentId Property

[image]

IceLib Technical Reference
WrapUpAssignment..::..SegmentId Property
WrapUpAssignment Class See Also Send Feedback
Gets the segment ID at which the interaction was connected to the workgroup queue.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SegmentId { get; internal set; }
Visual Basic
Public Property SegmentId As Integer
    Get
    Friend Set

Field Value

The segment ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


SourceInteractionId Property

[image]

IceLib Technical Reference
WrapUpAssignment..::..SourceInteractionId Property
WrapUpAssignment Class See Also Send Feedback
Gets the interaction ID of the source interaction on the user queue. This is the interaction that has the attribute requiring a wrap up code. This will frequently be the same as InteractionId, but could differ.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId SourceInteractionId { get; internal set; }
Visual Basic
Public Property SourceInteractionId As InteractionId
    Get
    Friend Set

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


Timestamp Property

[image]

IceLib Technical Reference
WrapUpAssignment..::..Timestamp Property
WrapUpAssignment Class See Also Send Feedback
Gets the time stamp, in UTC, at which the wrap-up was entered.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Timestamp { get; internal set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Friend Set

Field Value

Time stamp, in UTC, at which the wrap-up was entered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


User Property

[image]

IceLib Technical Reference
WrapUpAssignment..::..User Property
WrapUpAssignment Class See Also Send Feedback
Gets the user name of the user that entered the wrap-up code.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string User { get; internal set; }
Visual Basic
Public Property User As String
    Get
    Friend Set

Field Value

The user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


WrapUpCode Property

[image]

IceLib Technical Reference
WrapUpAssignment..::..WrapUpCode Property
WrapUpAssignment Class See Also Send Feedback
Gets the identifier for the wrap-up code entered by the user.

Namespace: ININ.IceLib.Interactions
Assembly: ININ.IceLib.Interactions (in ININ.IceLib.Interactions.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WrapUpCode { get; internal set; }
Visual Basic
Public Property WrapUpCode As String
    Get
    Friend Set

Field Value

The wrap up code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WrapUpAssignment Class
WrapUpAssignment Members
ININ.IceLib.Interactions Namespace


ININ.IceLib.People Namespace

[image]

IceLib Technical Reference
ININ.IceLib.People Namespace
Send Feedback

The ININ.IceLib.People namespace contains classes for accessing Interaction Center workgroups, status messages, users and users' statuses.

Attribute Watches. Some object classes get specific settings for the session user. These objects are watched, meaning that any time an attribute is changed, the internal cache of that object is kept up to date. Whenever that attribute's property is referenced the current value will be returned. An event notification is available when any of the attributes changes in value. Examples of watched attribute classes are:

  • UserRightsSettings
  • UserAccessListsSettings
  • UserDataSettings
  • UserSettings
  • WorkgroupDetails

Examples

The following example illustrates an attribute watch to watch attributes for user workgroup details.

CopyC#
public class WorkgroupDetailsWatcher
{
     PeopleManager _PeopleManager;
     WorkgroupDetails _WorkgroupDetails;
     string _WorkgroupName = "Marketing";
     //We are interested in watching the Members and Supervisors attributes of the Workgroup Details.
     string[] _WatchedAttributes = new string[] { WorkgroupAttributes.Members, WorkgroupAttributes.Supervisors };

     public WorkgroupDetailsWatcher(PeopleManager peopleManager)
     {
         _PeopleManager = peopleManager;
     }
      private void WorkgroupDetailsChanged(object sender, ININ.IceLib.People.WatchedAttributesEventArgs e)
     {
         DisplayAttributes();
     }
     private void DisplayAttributes()
     {
         ReadOnlyCollection<string> members = _WorkgroupDetails.Members;
         StringBuilder sb = new StringBuilder();

         sb.Append("The members of ").Append(_WorkgroupName).Append(" are ");

         foreach (string member in members)
         {
            sb.Append(member).Append("\n");
         }

         MessageBox.Show(sb.ToString());
     }
     public override void StartWatch()
     {
         if( _WorkgroupDetails == null )
         {
             _WorkgroupDetails = new WorkgroupDetails(_PeopleManager, _WorkgroupName);
             _WorkgroupDetails.WatchedAttributesChanged += new EventHandler<WatchedAttributesEventArgs>(WorkgroupDetailsChanged);
             _WorkgroupDetails.StartWatchingCompleted += new AsyncCompletedEventHandler(_WorkgroupDetails_StartWatchingCompleted);
             _WorkgroupDetails.StopWatchingCompleted += new AsyncCompletedEventHandler(_WorkgroupDetails_StopWatchingCompleted);

         }
         _WorkgroupDetails.StartWatchingAsync(_WatchedAttributes, null);
     }
     void _WorkgroupDetails_StopWatchingCompleted(object sender, AsyncCompletedEventArgs e)
     {
         MessageBox.Show("WorkgroupDetails.StopWatchingAsync succeeded!");
     }

     void _WorkgroupDetails_StartWatchingCompleted(object sender, AsyncCompletedEventArgs e)
     {
         DisplayAttributes();
     }
     public override void StopWatch()
     {
         if( _WorkgroupDetails == null )
         {
             MessageBox.Show("A start watch has not been called");
             return;
         }
         _WorkgroupDetails.StopWatchingAsync(null);
     }
 }

Object Watches. Some of these classes represent object watches. They are used to maintain a list of objects and watch for changes to those objects. The internal cache of these objects is kept up to data so anytime an object's property is referenced the current value will be returned. An event notification is available when a set of watched objects changes. Examples of watched object classes are: StatusMessageList watching StatusMessageDetails objects, UserStatusList watching UserStatus objects, UserWorkgroupActivationList watching UserWorkgroupActivation objects, and CustomButtonList watching CustomButton objects.

Examples

The following example illustrates an object watch on the list of custom buttons defined for the user in Interaction Administrator. When the list changes, this code is notified of the change.

CopyC#
  public class CustomButtonListWatcher
  {
     private CustomButtonList _CustomButtonList;
     private PeopleManager _PeopleManager = PeopleManager.GetInstance(_Session);

     public void StartWatch()
     {
       // Create the call back and send the asynchronous query
       if( _CustomButtonList == null )
       {
            _CustomButtonList = new CustomButtonList(_PeopleManager);

            _CustomButtonList.WatchedObjectsChanged += new EventHandler<WatchedObjectsEventArgs>(CustomButtonListChanged);
            _CustomButtonList.StartWatchingCompleted += new AsyncCompletedEventHandler(_CustomButtonList_StartWatchingCompleted);
            _CustomButtonList.StopWatchingCompleted += new AsyncCompletedEventHandler(_CustomButtonList_StopWatchingCompleted);
       }
       _CustomButtonList.StartWatchingAsync(null);
  }

   void _CustomButtonList_StartWatchingCompleted(object sender, AsyncCompletedEventArgs e)
   {
       ReadOnlyCollection<CustomButton> buttonList = _CustomButtonList.GetList();

       foreach(CustomButton button in buttonList)
       {
          //Display the text of the button
          MessageBox.Show(button.Text);
       }
   }

  void _CustomButtonList_StopWatchingCompleted(object sender, AsyncCompletedEventArgs e)
  {
      MessageBox.Show("No longer watching the Custom Button List");
  }
  private void CustomButtonListChanged(object sender, WatchedObjectsEventArgs e)
  {
      //The custom button list has changed, display the list again showing the updates
      ReadOnlyCollection<CustomButton> buttonList = _CustomButtonList.GetList();

      foreach(CustomButton button in buttonList)
      {
          MessageBox.Show(button.Text);
      }
  }
}

Examples

The IceLib SDK includes example application references to the ININ.IceLib.People namespace. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 57, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 144, in StatisticCatalogViewModel.SessionConnectionStateChanged

Classes

Class Description
Public class AccountCode
Represents an account code.
Public class ACDRoutingOutboundMailbox
Represents an ACD Routing mailbox for sending outbound e-mail interactions on behalf of a workgroup.
Public class CustomButton
Represents a custom button watched object.

Object instances of this class are managed by the CustomButtonList class.

Public class CustomButtonList
Represents a watched list of custom buttons (CustomButton).
Public class ExternalSystemConfiguration
Represents external system configuration information for a user.
Public class ExternalSystemConfigurations
Provides a list of ExternalSystemConfigurations.
Public class FilteredStatusMessageChangedEventArgs
Provides data for the filtered status message list changed event.
Public class FilteredStatusMessageList
Represents a watched list of (StatusMessageDetails) available for a set of users.
Public class GetLookupEntriesCompletedEventArgs
Provides data for asynchronous completed events of GetLookupEntriesAsync or GetLookupEntriesAsync.
Public class GetPreviousStatusInfoCompletedEventArgs
Provides data for asynchronous completed events of UserStatusList.
Public class GetUserActivationListCompletedEventArgs
Provides data for asynchronous completed events of GetUserActivationList(String).
Public class GetUserStatusCompletedEventArgs
Provides data for asynchronous completed events of UserStatusList.
Public class LicenseManagement
This class provides support for performing license operations for the session user.
Public class LicenseNameAttributes
Static constants for common IC license names used in the LicenseRequest class.
Public class LicenseOperationCompletedEventArgs
Arguments returned by the asynchronous license operation request.
Public class LicenseRequest
This class implements a license request operation.
Public class LicensesEventArgs
Provides data for the LicensesChanged event of a LicenseManagement.
Public class LookupEntriesDetails
Represents the return value for GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.
Public class LookupEntry
Represents a lookup entry.
Public class LookupParameters
Represents the input for GetLookupEntriesAsync or GetLookupEntries.
Public class PeopleManager
Provides access to all watched attribute and object classes in the People namespace.
Public class PerformLicenseOperationCompletedEventArgs
Arguments returned by the asynchronous perform license operation request.
Public class PerformLicenseOperationResult
Contains information regarding a license operation result from a call to PerformLicenseOperation(IList<(Of <<'(LicenseRequest>)>>)) or PerformLicenseOperationAsync(IList<(Of <<'(LicenseRequest>)>>), EventHandler<(Of <<'(PerformLicenseOperationCompletedEventArgs>)>>), Object).
Public class StatusMessageChangedEventArgs
Provides data for the filtered status message list changed event for status message attributes.
Public class StatusMessageDetails
Represents the details for a status message watched object. Object instances of this class are managed by the StatusMessageList class.
Public class StatusMessageList
Represents a watched list of status messages. Use StatusMessageDetails to get the details of a status message watched object.
Public class UserAccessListsAttributes
Attribute strings for the UserAccessListsSettings watched class.

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the UserAccessListsSettings class.
Public class UserAccessListsSettings
Represents the access control lists settings for an IC user. These settings are configured in the Access control section of the Security tab in Interaction Administrator.
Public class UserDataAttributes
Attribute strings for the UserDataSettings watched class.
Public class UserDataSettings
Represents miscellaneous data settings for an IC user, such as the user's workgroup membership, supervisory rights, and greeting preference. These settings are configured in Interaction Administrator.
Public class UserEntry
Represents a user entry watched object. For example, their display name, company, extension, etc. Object instances of this class are managed by the UserEntryList class.
Public class UserEntryList
Represents a list of watched user entries (UserEntry).
Public class UserRightsAttributes
Attribute strings for the UserRightsSettings watched class.
Public class UserRightsSettings
Represents the basic user rights settings for an IC user. User rights are set in Interaction Administrator at the Default User, User or Workgroup level.
Public class UserSettings
Represents the basic settings for an IC user.
Public class UserStatus
Represents a user's status watched object. For example, Available, Do Not Disturb and so on. Object instances of this class are managed by the UserStatusList class.
Public class UserStatusList
Represents a list of watched user statuses (UserStatus).
Public class UserStatusPreviousInfo
Represents a user's previous status settings for a particular status.
Public class UserStatusUpdate
This object is used to change a user's status.
Public class UserWorkgroupActivation
Represents the status of a user's activation in a workgroup. When a user is activated in a workgroup, then the user is eligible to handle ACD interactions.
Public class UserWorkgroupActivationList
Class to implement a list of UserWorkgroupActivation objects.
Public class UserWorkgroupActivationUpdate
This object is used to update a user's workgroup activation.
Public class VoicePrompts
Manages user voice prompts by starting actions for a voice prompt type.
Public class WatchedAttributesEventArgs
Provides data for the WatchedAttributesChangedEvent event of a WorkgroupDetails class or UserSettings derived classes.
Public class WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)>
Provides data for the watched objects changed event for a watched object.
Public class WorkgroupActivation
Represents a users workgroup activation as used in batch processing.
Public class WorkgroupActivationChangedEventArgs
Provides data for the workgroup activation list changed event.
Public class WorkgroupActivationList
Represents a list of user workgroup activations. This class allows for bulk access to user workgroup activations.
Public class WorkgroupAttributes
Attribute strings for the WorkgroupDetails watched class.
Public class WorkgroupDetails
Represents the common details for an IC workgroup.
Public class WrapUpCode
Represents a wrap-up code definition. Wrap-up codes are provided for agents to submit the resolution of an ACD interaction.

Enumerations

 | Enumeration | Description
Public enumeration | CustomButtonAction | Action to perform when button is pressed.
Public enumeration | CustomButtonAvailability | When is the button available to be selected.
Public enumeration | CustomButtonLocations | Specifies locations that custom buttons can occupy.
Public enumeration | CustomButtonProperty | Each value in this enumeration represents a property in CustomButton.
Public enumeration | LicenseRequestType | Enumeration for the type of operation requested for a license.
Public enumeration | LicenseStatusType | Represents the license status.
Public enumeration | LookupComparisonType | Represents the types of comparison for GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.
Public enumeration | LookupEntryProperty | Represents properties contained in a LookupEntry.
Public enumeration | LookupEntryType | Represents different sources in which lookup entries can be searched.
Public enumeration | StatusMessageProperty | Each value in this enumeration represents a property in StatusMessageDetails.
Public enumeration | UserEntryProperty | Each value in this enumeration represents a property in UserEntry.
Public enumeration | UserStatusProperty | Each value in this enumeration represents a property in UserStatus.
Public enumeration | UserWorkgroupActivationProperty | Each value in this enumeration represents a property in UserWorkgroupActivation.
Public enumeration | VoicePromptActionTypes | The set of actions that can be performed on a voice prompt. Voice prompts are handled via a VoicePrompts object.
Public enumeration | VoicePromptType | Indicates the type of voice prompt. Voice prompts are handled via a VoicePrompts object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


AccountCode Class

[image]

IceLib Technical Reference
AccountCode Class
Members See Also Send Feedback
Represents an account code.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AccountCode
Visual Basic
Public Class AccountCode

Remarks

Account codes are used in IC to associate calls with accounts. An account code is a number assigned to an account name in Interaction Administrator. Account codes can be assigned to incoming and outgoing calls for reporting purposes. For example, Interaction Client users can assign account codes to incoming and outgoing calls from the Interactions page, or from any queue. Users who have been given access to an account code can assign it to a call so it can be tracked. Account codes can also be used to track outgoing calls made to specific customers, or to track incoming call information for billing purposes.

Note
For more information about Account Codes, refer to the topic titled Account Codes in IC in the Technical Reference Documents section of the IC Documentation library on your server.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..AccountCode

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AccountCode Members
ININ.IceLib.People Namespace


AccountCode Members

[image] [image]

IceLib Technical Reference
AccountCode Members
AccountCode Class Methods Properties See Also Send Feedback

The AccountCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Get a string containing the account code ID and Description elements. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Description | Gets the descriptive name for this account code as it was defined in Interaction Administrator.
Public property | Id | Gets the account code's ID.

See Also

AccountCode Class
ININ.IceLib.People Namespace


AccountCode Methods

[image] [image]

IceLib Technical Reference
AccountCode Methods
AccountCode Class See Also Send Feedback

The AccountCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Get a string containing the account code ID and Description elements. (Overrides Object..::..ToString()()()().)

See Also

AccountCode Class
ININ.IceLib.People Namespace


ToString Method

[image]

IceLib Technical Reference
AccountCode..::..ToString Method
AccountCode Class See Also Send Feedback
Get a string containing the account code ID and Description elements.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string with the following format: {ID,Description}.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AccountCode Class
AccountCode Members
ININ.IceLib.People Namespace


AccountCode Properties

[image] [image]

IceLib Technical Reference
AccountCode Properties
AccountCode Class See Also Send Feedback

The AccountCode type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the descriptive name for this account code as it was defined in Interaction Administrator.
Public property | Id | Gets the account code's ID.

See Also

AccountCode Class
ININ.IceLib.People Namespace


Description Property

[image]

IceLib Technical Reference
AccountCode..::..Description Property
AccountCode Class See Also Send Feedback
Gets the descriptive name for this account code as it was defined in Interaction Administrator.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The description of the account code. e.g.: ManagedTours, Inc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AccountCode Class
AccountCode Members
ININ.IceLib.People Namespace


Id Property

[image]

IceLib Technical Reference
AccountCode..::..Id Property
AccountCode Class See Also Send Feedback
Gets the account code's ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The account code ID number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AccountCode Class
AccountCode Members
ININ.IceLib.People Namespace


ACDRoutingOutboundMailbox Class

[image]

IceLib Technical Reference
ACDRoutingOutboundMailbox Class
Members See Also Send Feedback
Represents an ACD Routing mailbox for sending outbound e-mail interactions on behalf of a workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ACDRoutingOutboundMailbox
Visual Basic
Public Class ACDRoutingOutboundMailbox

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..ACDRoutingOutboundMailbox

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ACDRoutingOutboundMailbox Members
ININ.IceLib.People Namespace


ACDRoutingOutboundMailbox Members

[image] [image]

IceLib Technical Reference
ACDRoutingOutboundMailbox Members
ACDRoutingOutboundMailbox Class Constructors Methods Properties See Also Send Feedback

The ACDRoutingOutboundMailbox type exposes the following members.

Constructors

 | Name | Description
Public method | ACDRoutingOutboundMailbox | Creates an instance of ACDRoutingOutboundMailbox.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a string representation of an ACD routing outbound mailbox. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Address | Gets/sets the e-mail address of this mailbox.
Public property | DisplayName | Gets/sets the display name of this mailbox.
Public property | Name | Gets/sets the identifier name of this mailbox.

See Also

ACDRoutingOutboundMailbox Class
ININ.IceLib.People Namespace


ACDRoutingOutboundMailbox Constructor

[image]

IceLib Technical Reference
ACDRoutingOutboundMailbox Constructor
ACDRoutingOutboundMailbox Class See Also Send Feedback
Creates an instance of ACDRoutingOutboundMailbox.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ACDRoutingOutboundMailbox(
    string name,
    string displayName,
    string address
)
Visual Basic
Public Sub New ( _
    name As String, _
    displayName As String, _
    address As String _
)

Parameters

name
Type: System..::..String
The name identifier of the mailbox.
displayName
Type: System..::..String
The display name of the mailbox.
address
Type: System..::..String
The address of the mailbox.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ACDRoutingOutboundMailbox Class
ACDRoutingOutboundMailbox Members
ININ.IceLib.People Namespace


ACDRoutingOutboundMailbox Methods

[image] [image]

IceLib Technical Reference
ACDRoutingOutboundMailbox Methods
ACDRoutingOutboundMailbox Class See Also Send Feedback

The ACDRoutingOutboundMailbox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a string representation of an ACD routing outbound mailbox. (Overrides Object..::..ToString()()()().)

See Also

ACDRoutingOutboundMailbox Class
ININ.IceLib.People Namespace


ToString Method

[image]

IceLib Technical Reference
ACDRoutingOutboundMailbox..::..ToString Method
ACDRoutingOutboundMailbox Class See Also Send Feedback
Gets a string representation of an ACD routing outbound mailbox.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

The mailbox in the format (name,displayName,address).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ACDRoutingOutboundMailbox Class
ACDRoutingOutboundMailbox Members
ININ.IceLib.People Namespace


ACDRoutingOutboundMailbox Properties

[image] [image]

IceLib Technical Reference
ACDRoutingOutboundMailbox Properties
ACDRoutingOutboundMailbox Class See Also Send Feedback

The ACDRoutingOutboundMailbox type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets/sets the e-mail address of this mailbox.
Public property | DisplayName | Gets/sets the display name of this mailbox.
Public property | Name | Gets/sets the identifier name of this mailbox.

See Also

ACDRoutingOutboundMailbox Class
ININ.IceLib.People Namespace


Address Property

[image]

IceLib Technical Reference
ACDRoutingOutboundMailbox..::..Address Property
ACDRoutingOutboundMailbox Class See Also Send Feedback
Gets/sets the e-mail address of this mailbox.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ACDRoutingOutboundMailbox Class
ACDRoutingOutboundMailbox Members
ININ.IceLib.People Namespace


DisplayName Property

[image]

IceLib Technical Reference
ACDRoutingOutboundMailbox..::..DisplayName Property
ACDRoutingOutboundMailbox Class See Also Send Feedback
Gets/sets the display name of this mailbox.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ACDRoutingOutboundMailbox Class
ACDRoutingOutboundMailbox Members
ININ.IceLib.People Namespace


Name Property

[image]

IceLib Technical Reference
ACDRoutingOutboundMailbox..::..Name Property
ACDRoutingOutboundMailbox Class See Also Send Feedback
Gets/sets the identifier name of this mailbox.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The identifier name of this mailbox.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ACDRoutingOutboundMailbox Class
ACDRoutingOutboundMailbox Members
ININ.IceLib.People Namespace


CustomButton Class

[image]

IceLib Technical Reference
CustomButton Class
Members See Also Send Feedback
Represents a custom button watched object.

Object instances of this class are managed by the CustomButtonList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomButton
Visual Basic
Public Class CustomButton

Remarks

Custom buttons are defined in Interaction Administrator and are used to add user-specific functionality to the client application.

A custom button can invoke a handler or launch a local application. For example, if you add a custom button in Interaction Administrator and assign the command line to be "C:\Windows\System32\calc.exe", then invoking this button launches the calculator.

The button can be set to be available always, when any interaction is selected or only when an active (not disconnected) interaction is selected. All custom buttons are shown by default and appended to the right side of the Call Control toolbar. The actions performed by custom buttons are also listed on the context menu.

When custom buttons are added they are retrieved from the server and cached in the CustomButtonList object. Custom buttons are assigned a command line string to execute upon invocation of the button.

The label and description of the custom button can be localized based on the language identifier of the user's session. In Interaction Administrator label and description text can be defined for any number of languages.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..CustomButton

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Members
ININ.IceLib.People Namespace


CustomButton Members

[image] [image]

IceLib Technical Reference
CustomButton Members
CustomButton Class Methods Properties See Also Send Feedback

The CustomButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the action CustomButtonAction enumeration value. This value indicates whether the button will send a custom notification to a handler, launch an application, or whether no button action was specifed.
Public property | Availability | Gets the availability CustomButtonAvailability enumeration value. It indicates whether the button should be available always, only with an active interaction, with any interaction, or whether no availability has been specified.
Public property | ButtonText | Gets the text to display for this custom button. This is the text that appears on the button.
Public property | DeactivateAfterUse | Gets the deactivate after user value; a Boolean that indicates whether the button will be disabled after first-time use per session.
Public property | Description | Gets the descriptive text for this button. Interaction Client displays this description as a tool tip text when users mouse-over the button.
Public property | DisplayNotification | Gets a value indicating whether this custom button should also initiate a notification in a client application indicating that the button was activated.
Public property | Enabled | Gets the enabled status: whether or not the button was configured in Interaction Administrator to appear enabled.
Public property | Icon | Gets the optional icon associated with this button. If no icon, then nullNothingnullptra null reference (Nothing in Visual Basic) is returned.
Public property | IconFileName | Gets the icon file name.
Public property | Id | Gets the unique identifier for this custom button. The ButtonText is used for display purposes.
Public property | InteractionTypes | Gets the collection of interaction type InteractionTypes enumeration values. These values indicate what interaction types this button applies to.
Public property | LocalApplication | Gets the application associated with the action. This is the fully qualified local path to an executable, or a path relative to the local Interaction Client workstation (e.g., C:\Program Files\Interactive Intelligence\application.exe), or a UNC path (e.g., \\hydra\icapplications\application.exe).
Public property | Locations | Gets the location CustomButtonLocations enumeration value. This value indicates at what locations the button will appear.

See Also

CustomButton Class
ININ.IceLib.People Namespace


CustomButton Methods

[image] [image]

IceLib Technical Reference
CustomButton Methods
CustomButton Class See Also Send Feedback

The CustomButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomButton Class
ININ.IceLib.People Namespace


CustomButton Properties

[image] [image]

IceLib Technical Reference
CustomButton Properties
CustomButton Class See Also Send Feedback

The CustomButton type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the action CustomButtonAction enumeration value. This value indicates whether the button will send a custom notification to a handler, launch an application, or whether no button action was specifed.
Public property | Availability | Gets the availability CustomButtonAvailability enumeration value. It indicates whether the button should be available always, only with an active interaction, with any interaction, or whether no availability has been specified.
Public property | ButtonText | Gets the text to display for this custom button. This is the text that appears on the button.
Public property | DeactivateAfterUse | Gets the deactivate after user value; a Boolean that indicates whether the button will be disabled after first-time use per session.
Public property | Description | Gets the descriptive text for this button. Interaction Client displays this description as a tool tip text when users mouse-over the button.
Public property | DisplayNotification | Gets a value indicating whether this custom button should also initiate a notification in a client application indicating that the button was activated.
Public property | Enabled | Gets the enabled status: whether or not the button was configured in Interaction Administrator to appear enabled.
Public property | Icon | Gets the optional icon associated with this button. If no icon, then nullNothingnullptra null reference (Nothing in Visual Basic) is returned.
Public property | IconFileName | Gets the icon file name.
Public property | Id | Gets the unique identifier for this custom button. The ButtonText is used for display purposes.
Public property | InteractionTypes | Gets the collection of interaction type InteractionTypes enumeration values. These values indicate what interaction types this button applies to.
Public property | LocalApplication | Gets the application associated with the action. This is the fully qualified local path to an executable, or a path relative to the local Interaction Client workstation (e.g., C:\Program Files\Interactive Intelligence\application.exe), or a UNC path (e.g., \\hydra\icapplications\application.exe).
Public property | Locations | Gets the location CustomButtonLocations enumeration value. This value indicates at what locations the button will appear.

See Also

CustomButton Class
ININ.IceLib.People Namespace


Action Property

[image]

IceLib Technical Reference
CustomButton..::..Action Property
CustomButton Class See Also Send Feedback
Gets the action CustomButtonAction enumeration value. This value indicates whether the button will send a custom notification to a handler, launch an application, or whether no button action was specifed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomButtonAction Action { get; }
Visual Basic
Public ReadOnly Property Action As CustomButtonAction
    Get

Field Value

The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


Availability Property

[image]

IceLib Technical Reference
CustomButton..::..Availability Property
CustomButton Class See Also Send Feedback
Gets the availability CustomButtonAvailability enumeration value. It indicates whether the button should be available always, only with an active interaction, with any interaction, or whether no availability has been specified.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomButtonAvailability Availability { get; }
Visual Basic
Public ReadOnly Property Availability As CustomButtonAvailability
    Get

Field Value

An enumerated value that indicates when the button can be selected.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


ButtonText Property

[image]

IceLib Technical Reference
CustomButton..::..ButtonText Property
CustomButton Class See Also Send Feedback
Gets the text to display for this custom button. This is the text that appears on the button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ButtonText { get; }
Visual Basic
Public ReadOnly Property ButtonText As String
    Get

Field Value

The button text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


DeactivateAfterUse Property

[image]

IceLib Technical Reference
CustomButton..::..DeactivateAfterUse Property
CustomButton Class See Also Send Feedback
Gets the deactivate after user value; a Boolean that indicates whether the button will be disabled after first-time use per session.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DeactivateAfterUse { get; }
Visual Basic
Public ReadOnly Property DeactivateAfterUse As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if should deactivate after use; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


Description Property

[image]

IceLib Technical Reference
CustomButton..::..Description Property
CustomButton Class See Also Send Feedback
Gets the descriptive text for this button. Interaction Client displays this description as a tool tip text when users mouse-over the button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The description of the button. This text does not appear on the button.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


DisplayNotification Property

[image]

IceLib Technical Reference
CustomButton..::..DisplayNotification Property
CustomButton Class See Also Send Feedback
Gets a value indicating whether this custom button should also initiate a notification in a client application indicating that the button was activated.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DisplayNotification { get; }
Visual Basic
Public ReadOnly Property DisplayNotification As Boolean
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


Enabled Property

[image]

IceLib Technical Reference
CustomButton..::..Enabled Property
CustomButton Class See Also Send Feedback
Gets the enabled status: whether or not the button was configured in Interaction Administrator to appear enabled.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Enabled { get; }
Visual Basic
Public ReadOnly Property Enabled As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if enabled; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


Icon Property

[image]

IceLib Technical Reference
CustomButton..::..Icon Property
CustomButton Class See Also Send Feedback
Gets the optional icon associated with this button. If no icon, then nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Icon Icon { get; }
Visual Basic
Public ReadOnly Property Icon As Icon
    Get

Field Value

The icon.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


IconFileName Property

[image]

IceLib Technical Reference
CustomButton..::..IconFileName Property
CustomButton Class See Also Send Feedback
Gets the icon file name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IconFileName { get; }
Visual Basic
Public ReadOnly Property IconFileName As String
    Get

Field Value

The name of the icon file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


Id Property

[image]

IceLib Technical Reference
CustomButton..::..Id Property
CustomButton Class See Also Send Feedback
Gets the unique identifier for this custom button. The ButtonText is used for display purposes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


InteractionTypes Property

[image]

IceLib Technical Reference
CustomButton..::..InteractionTypes Property
CustomButton Class See Also Send Feedback
Gets the collection of interaction type InteractionTypes enumeration values. These values indicate what interaction types this button applies to.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionType> InteractionTypes { get; }
Visual Basic
Public ReadOnly Property InteractionTypes As ReadOnlyCollection(Of InteractionType)
    Get

Field Value

The collection of interaction types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


LocalApplication Property

[image]

IceLib Technical Reference
CustomButton..::..LocalApplication Property
CustomButton Class See Also Send Feedback
Gets the application associated with the action. This is the fully qualified local path to an executable, or a path relative to the local Interaction Client workstation (e.g., C:\Program Files\Interactive Intelligence\application.exe), or a UNC path (e.g., \\hydra\icapplications\application.exe).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalApplication { get; }
Visual Basic
Public ReadOnly Property LocalApplication As String
    Get

Field Value

The fully qualified path to the application that will run when the button is pressed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


Locations Property

[image]

IceLib Technical Reference
CustomButton..::..Locations Property
CustomButton Class See Also Send Feedback
Gets the location CustomButtonLocations enumeration value. This value indicates at what locations the button will appear.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomButtonLocations Locations { get; }
Visual Basic
Public ReadOnly Property Locations As CustomButtonLocations
    Get

Field Value

The location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

CustomButton Class
CustomButton Members
ININ.IceLib.People Namespace


CustomButtonAction Enumeration

[image]

IceLib Technical Reference
CustomButtonAction Enumeration
See Also Send Feedback
Action to perform when button is pressed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CustomButtonAction
Visual Basic
Public Enumeration CustomButtonAction

Members

Member name | Value | Description
None | 0 | No action has been specifed.
CustomNotification | 1 | Send a custom notification to a handler.
LaunchApplication | 2 | Launch an application.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


CustomButtonAvailability Enumeration

[image]

IceLib Technical Reference
CustomButtonAvailability Enumeration
See Also Send Feedback
When is the button available to be selected.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CustomButtonAvailability
Visual Basic
Public Enumeration CustomButtonAvailability

Members

Member name | Value | Description
None | 0 | No availability has been specifed.
Always | 1 | The button should be available always.
WithActiveInteractionSelected | 2 | The button should be available only with an active interaction.
WithInteractionSelected | 3 | The button should be available only with any interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


CustomButtonList Class

[image]

IceLib Technical Reference
CustomButtonList Class
Members See Also Send Feedback
Represents a watched list of custom buttons (CustomButton).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomButtonList
Visual Basic
Public Class CustomButtonList

Remarks

This class maintains a list of custom buttons defined for a user session. The user defines custom buttons in Interaction Administator. The custom buttons are then sent from the IC server to the client provided it has the necessary permissions. Each button contains an icon, and localized text and description information based on the language setting of the user's session. The custom buttons are stored in a cache that is updated when there is a change to the list.

To start a watch, call the StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object) methods. The completedCallback delegate is invoked when the asynchronous start watch operation completes. To stop a watch call the StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods. The StopWatchingCompleted delegate is invoked when the asynchronous stop watch operation completes. An InvalidOperationException is raised if StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object) is called when a watch is already in place. The InvalidOperationException is also raised if StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) is called when a watch is not in place.

When this list of custom buttons changes, the WatchedObjectsChanged event is triggered.

If a watch is in place you can access the list of custom buttons by calling the GetList()()()() method. An InvalidOperationException is raised if a watch is not in place.

Note: The asynchronous methods are preferred since the start, change, and stop watch can be lengthy operations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..CustomButtonList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Members
ININ.IceLib.People Namespace


CustomButtonList Members

[image] [image]

IceLib Technical Reference
CustomButtonList Members
CustomButtonList Class Constructors Methods Properties Events See Also Send Feedback

The CustomButtonList type exposes the following members.

Constructors

 | Name | Description
Public method | CustomButtonList | Initializes a new instance of the CustomButtonList class.

Methods

 | Name | Description
Public method | ActivateButtonAction(String) | Executes the custom button action for the given button ID.
Public method | ActivateButtonAction(String, InteractionId) | Executes the custom button action for the given button ID.
Public method | ActivateButtonActionAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously executes the custom button action for the given button ID.
Public method | ActivateButtonActionAsync(String, InteractionId, AsyncCompletedEventHandler, Object) | Asynchronously executes the custom button action for the given button ID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of custom buttons.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the custom button list.
Public method | StartWatchingAsync | Asynchronously starts watching the custom button list.
Public method | StopWatching | Implements a synchronous request to stop watching the custom button list.
Public method | StopWatchingAsync | Asynchronously stops watching the custom button list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get an individual custom button definition by its unique name.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the CustomButton watched objects has changed.

See Also

CustomButtonList Class
ININ.IceLib.People Namespace


CustomButtonList Constructor

[image]

IceLib Technical Reference
CustomButtonList Constructor
CustomButtonList Class See Also Send Feedback
Initializes a new instance of the CustomButtonList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomButtonList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


CustomButtonList Methods

[image] [image]

IceLib Technical Reference
CustomButtonList Methods
CustomButtonList Class See Also Send Feedback

The CustomButtonList type exposes the following members.

Methods

 | Name | Description
Public method | ActivateButtonAction(String) | Executes the custom button action for the given button ID.
Public method | ActivateButtonAction(String, InteractionId) | Executes the custom button action for the given button ID.
Public method | ActivateButtonActionAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously executes the custom button action for the given button ID.
Public method | ActivateButtonActionAsync(String, InteractionId, AsyncCompletedEventHandler, Object) | Asynchronously executes the custom button action for the given button ID.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of custom buttons.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the custom button list.
Public method | StartWatchingAsync | Asynchronously starts watching the custom button list.
Public method | StopWatching | Implements a synchronous request to stop watching the custom button list.
Public method | StopWatchingAsync | Asynchronously stops watching the custom button list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomButtonList Class
ININ.IceLib.People Namespace


ActivateButtonAction Method

[image] [image]

IceLib Technical Reference
CustomButtonList..::..ActivateButtonAction Method
CustomButtonList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ActivateButtonAction(String) | Executes the custom button action for the given button ID.
Public method | ActivateButtonAction(String, InteractionId) | Executes the custom button action for the given button ID.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


ActivateButtonAction Method (String)

[image]

IceLib Technical Reference
CustomButtonList..::..ActivateButtonAction Method (String)
CustomButtonList Class See Also Send Feedback
Executes the custom button action for the given button ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ActivateButtonAction(
    string buttonId
)
Visual Basic
Public Sub ActivateButtonAction ( _
    buttonId As String _
)

Parameters

buttonId
Type: System..::..String
The Id of the button to activate.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The buttonId length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ActivateButtonAction Overload
ININ.IceLib.People Namespace


ActivateButtonAction Method (String, InteractionId)

[image]

IceLib Technical Reference
CustomButtonList..::..ActivateButtonAction Method (String, InteractionId)
CustomButtonList Class See Also Send Feedback
Executes the custom button action for the given button ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ActivateButtonAction(
    string buttonId,
    InteractionId interactionId
)
Visual Basic
Public Sub ActivateButtonAction ( _
    buttonId As String, _
    interactionId As InteractionId _
)

Parameters

buttonId
Type: System..::..String
The Id of the button to activate.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId associated with this action.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The buttonId length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ActivateButtonAction Overload
ININ.IceLib.People Namespace


ActivateButtonActionAsync Method

[image] [image]

IceLib Technical Reference
CustomButtonList..::..ActivateButtonActionAsync Method
CustomButtonList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ActivateButtonActionAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously executes the custom button action for the given button ID.
Public method | ActivateButtonActionAsync(String, InteractionId, AsyncCompletedEventHandler, Object) | Asynchronously executes the custom button action for the given button ID.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


ActivateButtonActionAsync Method (String, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
CustomButtonList..::..ActivateButtonActionAsync Method (String, AsyncCompletedEventHandler, Object)
CustomButtonList Class See Also Send Feedback
Asynchronously executes the custom button action for the given button ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ActivateButtonActionAsync(
    string buttonId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ActivateButtonActionAsync ( _
    buttonId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

buttonId
Type: System..::..String
The Id of the button to activate.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The buttonId length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ActivateButtonActionAsync Overload
ININ.IceLib.People Namespace


ActivateButtonActionAsync Method (String, InteractionId, AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
CustomButtonList..::..ActivateButtonActionAsync Method (String, InteractionId, AsyncCompletedEventHandler, Object)
CustomButtonList Class See Also Send Feedback
Asynchronously executes the custom button action for the given button ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ActivateButtonActionAsync(
    string buttonId,
    InteractionId interactionId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ActivateButtonActionAsync ( _
    buttonId As String, _
    interactionId As InteractionId, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

buttonId
Type: System..::..String
The Id of the button to activate.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The InteractionId associated with this action.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The buttonId length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ActivateButtonActionAsync Overload
ININ.IceLib.People Namespace


GetList Method

[image]

IceLib Technical Reference
CustomButtonList..::..GetList Method
CustomButtonList Class See Also Send Feedback
Get a list of custom buttons.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<CustomButton> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of CustomButton)

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)>.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | If the requested objects are not in the cache.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
CustomButtonList..::..IsWatching Method
CustomButtonList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
CustomButtonList..::..StartWatching Method
CustomButtonList Class See Also Send Feedback
Starts watching the custom button list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is already in progress.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
CustomButtonList..::..StartWatchingAsync Method
CustomButtonList Class See Also Send Feedback
Asynchronously starts watching the custom button list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
CustomButtonList..::..StopWatching Method
CustomButtonList Class See Also Send Feedback
Implements a synchronous request to stop watching the custom button list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
CustomButtonList..::..StopWatchingAsync Method
CustomButtonList Class See Also Send Feedback
Asynchronously stops watching the custom button list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


CustomButtonList Properties

[image] [image]

IceLib Technical Reference
CustomButtonList Properties
CustomButtonList Class See Also Send Feedback

The CustomButtonList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Get an individual custom button definition by its unique name.

See Also

CustomButtonList Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
CustomButtonList..::..Item Property
CustomButtonList Class See Also Send Feedback
Get an individual custom button definition by its unique name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomButton this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As CustomButton
    Get

Parameters

name
Type: System..::..String
The button to get.

Field Value

The custom button.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
System.Collections.Generic..::..KeyNotFoundException | If the CustomButton requested by name is not in the list.
ININ.IceLib..::..NotCachedException | If the requested object is not in the cache.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


CustomButtonList Events

[image] [image]

IceLib Technical Reference
CustomButtonList Events
CustomButtonList Class See Also Send Feedback

The CustomButtonList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the CustomButton watched objects has changed.

See Also

CustomButtonList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
CustomButtonList..::..WatchedObjectsChanged Event
CustomButtonList Class See Also Send Feedback
Occurs when one of the CustomButton watched objects has changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedObjectsEventArgs<CustomButtonProperty>> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of WatchedObjectsEventArgs(Of CustomButtonProperty))

Remarks

Note that changes, additions, and removal of objects are monitored for a CustomButtonList.

Each Changed notification for a CustomButton object is described by the integer values defined in the CustomButtonProperty enumeration.

This event will only occur if the list is being watched. To start watching the list call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CustomButtonList Class
CustomButtonList Members
ININ.IceLib.People Namespace


CustomButtonLocations Enumeration

[image]

IceLib Technical Reference
CustomButtonLocations Enumeration
See Also Send Feedback
Specifies locations that custom buttons can occupy.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum CustomButtonLocations
Visual Basic
<FlagsAttribute> _
Public Enumeration CustomButtonLocations

Members

Member name | Value | Description
None | 0 | No location has been specified.
Queue | 1 | Button to appear in queues.
Interaction | 2 | Button to appear in interactions.
All | 3 | Button to appear in all locations possible.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

ININ.IceLib.People Namespace


CustomButtonProperty Enumeration

[image]

IceLib Technical Reference
CustomButtonProperty Enumeration
See Also Send Feedback
Each value in this enumeration represents a property in CustomButton.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CustomButtonProperty
Visual Basic
Public Enumeration CustomButtonProperty

Members

Member name | Value | Description
None | 0 | No property is defined.
Id | 1 | Represents the Id property.
ButtonText | 2 | Represents the ButtonText property.
Enabled | 3 | Represents the Enabled property.
IconFileName | 4 | Represents the IconFileName property.
Icon | 5 | Represents the Icon property.
Availability | 6 | Represents the Availability property.
DeactivateAfterUse | 7 | Represents the DeactivateAfterUse property.
Description | 8 | Represents the Description property.
LocalApplication | 9 | Represents the LocalApplication property.
Action | 10 | Represents the Action property.
DisplayNotification | 11 | Represents the DisplayNotification property.
Locations | 12 | Represents the Locations property.
InteractionTypes | 13 | Represents the InteractionTypes property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


ExternalSystemConfiguration Class

[image]

IceLib Technical Reference
ExternalSystemConfiguration Class
Members See Also Send Feedback
Represents external system configuration information for a user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExternalSystemConfiguration
Visual Basic
Public Class ExternalSystemConfiguration

Remarks

External system configuration can include information about integrations a user is configured for. For example, if a user is configured for an integration with "Product X", an ExternalSystemConfiguration instance could exist with the SystemName property set to "Product X".

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..ExternalSystemConfiguration

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalSystemConfiguration Members
ININ.IceLib.People Namespace


ExternalSystemConfiguration Members

[image] [image]

IceLib Technical Reference
ExternalSystemConfiguration Members
ExternalSystemConfiguration Class Methods Properties See Also Send Feedback

The ExternalSystemConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SystemName | Gets the name of the external system.

See Also

ExternalSystemConfiguration Class
ININ.IceLib.People Namespace


ExternalSystemConfiguration Methods

[image] [image]

IceLib Technical Reference
ExternalSystemConfiguration Methods
ExternalSystemConfiguration Class See Also Send Feedback

The ExternalSystemConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalSystemConfiguration Class
ININ.IceLib.People Namespace


ExternalSystemConfiguration Properties

[image] [image]

IceLib Technical Reference
ExternalSystemConfiguration Properties
ExternalSystemConfiguration Class See Also Send Feedback

The ExternalSystemConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | SystemName | Gets the name of the external system.

See Also

ExternalSystemConfiguration Class
ININ.IceLib.People Namespace


SystemName Property

[image]

IceLib Technical Reference
ExternalSystemConfiguration..::..SystemName Property
ExternalSystemConfiguration Class See Also Send Feedback
Gets the name of the external system.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SystemName { get; private set; }
Visual Basic
Public Property SystemName As String
    Get
    Private Set

Field Value

The external system name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalSystemConfiguration Class
ExternalSystemConfiguration Members
ININ.IceLib.People Namespace


ExternalSystemConfigurations Class

[image]

IceLib Technical Reference
ExternalSystemConfigurations Class
Members See Also Send Feedback
Provides a list of ExternalSystemConfigurations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ExternalSystemConfigurations : IEnumerable<KeyValuePair<string, ExternalSystemConfiguration>>,
    IEnumerable
Visual Basic
Public Class ExternalSystemConfigurations _
    Implements IEnumerable(Of KeyValuePair(Of String, ExternalSystemConfiguration)),  _
    IEnumerable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..ExternalSystemConfigurations

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalSystemConfigurations Members
ININ.IceLib.People Namespace


ExternalSystemConfigurations Members

[image] [image]

IceLib Technical Reference
ExternalSystemConfigurations Members
ExternalSystemConfigurations Class Methods Properties See Also Send Feedback

The ExternalSystemConfigurations type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the ExternalSystemConfiguration with the specified system name.

See Also

ExternalSystemConfigurations Class
ININ.IceLib.People Namespace


ExternalSystemConfigurations Methods

[image] [image]

IceLib Technical Reference
ExternalSystemConfigurations Methods
ExternalSystemConfigurations Class See Also Send Feedback

The ExternalSystemConfigurations type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalSystemConfigurations Class
ININ.IceLib.People Namespace


GetEnumerator Method

[image]

IceLib Technical Reference
ExternalSystemConfigurations..::..GetEnumerator Method
ExternalSystemConfigurations Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerator<KeyValuePair<string, ExternalSystemConfiguration>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, ExternalSystemConfiguration))

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalSystemConfigurations Class
ExternalSystemConfigurations Members
ININ.IceLib.People Namespace


ExternalSystemConfigurations Properties

[image] [image]

IceLib Technical Reference
ExternalSystemConfigurations Properties
ExternalSystemConfigurations Class See Also Send Feedback

The ExternalSystemConfigurations type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the ExternalSystemConfiguration with the specified system name.

See Also

ExternalSystemConfigurations Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
ExternalSystemConfigurations..::..Item Property
ExternalSystemConfigurations Class See Also Send Feedback
Gets the ExternalSystemConfiguration with the specified system name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExternalSystemConfiguration this[
    string systemName
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    systemName As String _
) As ExternalSystemConfiguration
    Get

Parameters

systemName
Type: System..::..String

Field Value

The ExternalSystemConfiguration matching the system name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ExternalSystemConfigurations Class
ExternalSystemConfigurations Members
ININ.IceLib.People Namespace


FilteredStatusMessageChangedEventArgs Class

[image]

IceLib Technical Reference
FilteredStatusMessageChangedEventArgs Class
Members See Also Send Feedback
Provides data for the filtered status message list changed event.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FilteredStatusMessageChangedEventArgs : EventArgs
Visual Basic
Public Class FilteredStatusMessageChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People..::..FilteredStatusMessageChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageChangedEventArgs Members
ININ.IceLib.People Namespace
FilteredStatusMessageList..::..WatchedObjectsChanged


FilteredStatusMessageChangedEventArgs Members

[image] [image]

IceLib Technical Reference
FilteredStatusMessageChangedEventArgs Members
FilteredStatusMessageChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FilteredStatusMessageChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredStatusMessageChangedEventArgs | Constructs an object of type FilteredStatusMessageChangedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changed | Contains a collection of status messages that have changed for a given user.

See Also

FilteredStatusMessageChangedEventArgs Class
ININ.IceLib.People Namespace


FilteredStatusMessageChangedEventArgs Constructor

[image]

IceLib Technical Reference
FilteredStatusMessageChangedEventArgs Constructor
FilteredStatusMessageChangedEventArgs Class See Also Send Feedback
Constructs an object of type FilteredStatusMessageChangedEventArgs.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilteredStatusMessageChangedEventArgs(
    IDictionary<string, ReadOnlyCollection<StatusMessageDetails>> changed
)
Visual Basic
Public Sub New ( _
    changed As IDictionary(Of String, ReadOnlyCollection(Of StatusMessageDetails)) _
)

Parameters

changed
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, ReadOnlyCollection<(Of <(<' StatusMessageDetails >)>)>>)>)>
The status messages that have changed for a given user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageChangedEventArgs Class
FilteredStatusMessageChangedEventArgs Members
ININ.IceLib.People Namespace


FilteredStatusMessageChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
FilteredStatusMessageChangedEventArgs Methods
FilteredStatusMessageChangedEventArgs Class See Also Send Feedback

The FilteredStatusMessageChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredStatusMessageChangedEventArgs Class
ININ.IceLib.People Namespace


FilteredStatusMessageChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
FilteredStatusMessageChangedEventArgs Properties
FilteredStatusMessageChangedEventArgs Class See Also Send Feedback

The FilteredStatusMessageChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Contains a collection of status messages that have changed for a given user.

See Also

FilteredStatusMessageChangedEventArgs Class
ININ.IceLib.People Namespace


Changed Property

[image]

IceLib Technical Reference
FilteredStatusMessageChangedEventArgs..::..Changed Property
FilteredStatusMessageChangedEventArgs Class See Also Send Feedback
Contains a collection of status messages that have changed for a given user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ReadOnlyCollection<StatusMessageDetails>> Changed { get; set; }
Visual Basic
Public Property Changed As IDictionary(Of String, ReadOnlyCollection(Of StatusMessageDetails))
    Get
    Set

Field Value

The changed status messages.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageChangedEventArgs Class
FilteredStatusMessageChangedEventArgs Members
ININ.IceLib.People Namespace


FilteredStatusMessageList Class

[image]

IceLib Technical Reference
FilteredStatusMessageList Class
Members See Also Send Feedback
Represents a watched list of (StatusMessageDetails) available for a set of users.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FilteredStatusMessageList
Visual Basic
Public Class FilteredStatusMessageList

Remarks

The list of status messages that is available to a user is filtered by the available status messages for the workgroups to which the user belongs. To start watching the list of status messages available to a set of users, call the StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) methods, providing an array of user names that you want to watch. The completedCallback delegate is invoked when the asynchronous start watch operation completes. To stop watching, call the StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods. The completedCallback delegate is invoked when the asynchronous stop watch operation completes. To change the set of users you wish to watch, call ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedUsersAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) methods providing the new set of users you wish to watch. This replaces the former set of users with a new set of users to watch. The completedCallback delegate is invoked when the asynchronous change watch operation completes.

Once a watch is in place, any changes to the status message list trigger the WatchedObjectsChanged event. You can access the list of status messages by calling GetList()()()(). Calling GetList()()()() if a watch is not in progress raises the InvalidOperationException. Calling StartWatching(array<String>[]()[][]),StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object), ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean), or ChangeWatchedUsersAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) when a watch is already in place for a given user, or calling StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is not in place also raises the InvalidOperationException.

Note
The asynchronous methods are preferred since the start, change, and stop watch can be lengthy operations.

There are two classes in IceLib for watching status messages. The StatusMessageList class allows you to watch the list of all status messages defined in IC that the session user has the rights to view. The FilteredStatusMessageList class allows you to watch the status messages that are available for a particular IC user. The list of available status messages for a user can vary based on workgroup membership, role, and user settings in Interaction Administrator.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..FilteredStatusMessageList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Members
ININ.IceLib.People Namespace


FilteredStatusMessageList Members

[image] [image]

IceLib Technical Reference
FilteredStatusMessageList Members
FilteredStatusMessageList Class Constructors Methods Properties Events See Also Send Feedback

The FilteredStatusMessageList type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredStatusMessageList | Initializes a new instance of the FilteredStatusMessageList class.

Methods

 | Name | Description
Public method | CanHaveStatus | Determines whether a user can have a given status.
Public method | ChangeWatchedUsers | Changes the set of user names for a watch of their Filtered Status Message list.
Public method | ChangeWatchedUsersAsync | Asynchronously changes the set of user names for a watch of their filtered status message list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the table of filtered status messages lists for all users watched by this object.
Public method | GetStatusMessageDetailsForUser | Gets a specific filtered status message for the given user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the Filtered Status Message List for a set of users.
Public method | StartWatchingAsync | Asynchronously starts watching the Filtered Status Message List for a set of users.
Public method | StopWatching | Stops watching the Filtered Status Message List for a set of users.
Public method | StopWatchingAsync | Asynchronously stops watching the Filtered Status Message List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets the list of filtered status messages for the given user.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the FilteredStatusMessageList watched objects has changed.
Public event | WatchedStatusMessageObjectsChanged | Occurs when one of the FilteredStatusMessageList watched objects has an attribute changed.

See Also

FilteredStatusMessageList Class
ININ.IceLib.People Namespace


FilteredStatusMessageList Constructor

[image]

IceLib Technical Reference
FilteredStatusMessageList Constructor
FilteredStatusMessageList Class See Also Send Feedback
Initializes a new instance of the FilteredStatusMessageList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilteredStatusMessageList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


FilteredStatusMessageList Methods

[image] [image]

IceLib Technical Reference
FilteredStatusMessageList Methods
FilteredStatusMessageList Class See Also Send Feedback

The FilteredStatusMessageList type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveStatus | Determines whether a user can have a given status.
Public method | ChangeWatchedUsers | Changes the set of user names for a watch of their Filtered Status Message list.
Public method | ChangeWatchedUsersAsync | Asynchronously changes the set of user names for a watch of their filtered status message list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Gets the table of filtered status messages lists for all users watched by this object.
Public method | GetStatusMessageDetailsForUser | Gets a specific filtered status message for the given user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the Filtered Status Message List for a set of users.
Public method | StartWatchingAsync | Asynchronously starts watching the Filtered Status Message List for a set of users.
Public method | StopWatching | Stops watching the Filtered Status Message List for a set of users.
Public method | StopWatchingAsync | Asynchronously stops watching the Filtered Status Message List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredStatusMessageList Class
ININ.IceLib.People Namespace


CanHaveStatus Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..CanHaveStatus Method
FilteredStatusMessageList Class See Also Send Feedback
Determines whether a user can have a given status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanHaveStatus(
    string userId,
    string statusId
)
Visual Basic
Public Function CanHaveStatus ( _
    userId As String, _
    statusId As String _
) As Boolean

Parameters

userId
Type: System..::..String
The user ID.
statusId
Type: System..::..String
The status ID.

Return Value

trueTruetruetrue (True in Visual Basic) if the user can have the specified status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | The user ID is not being watched.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


ChangeWatchedUsers Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..ChangeWatchedUsers Method
FilteredStatusMessageList Class See Also Send Feedback
Changes the set of user names for a watch of their Filtered Status Message list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedUsers(
    string[] userIDsToAdd,
    string[] userIDsToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedUsers ( _
    userIDsToAdd As String(), _
    userIDsToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

userIDsToAdd
Type: array<System..::..String>[]()[][]
The user IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
userIDsToRemove
Type: array<System..::..String>[]()[][]
The user IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An item in userIDsToAdd or userIDsToRemove is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | A watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


ChangeWatchedUsersAsync Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..ChangeWatchedUsersAsync Method
FilteredStatusMessageList Class See Also Send Feedback
Asynchronously changes the set of user names for a watch of their filtered status message list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedUsersAsync(
    string[] userIDsToAdd,
    string[] userIDsToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedUsersAsync ( _
    userIDsToAdd As String(), _
    userIDsToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIDsToAdd
Type: array<System..::..String>[]()[][]
The user IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
userIDsToRemove
Type: array<System..::..String>[]()[][]
The user IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
Delegate caled when the operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An item in userIDsToAdd or userIDsToRemove is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


GetList Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..GetList Method
FilteredStatusMessageList Class See Also Send Feedback
Gets the table of filtered status messages lists for all users watched by this object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ReadOnlyCollection<StatusMessageDetails>> GetList()
Visual Basic
Public Function GetList As IDictionary(Of String, ReadOnlyCollection(Of StatusMessageDetails))

Return Value

The lists of filtered status messages for all users watched by this object.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | No user IDs are being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


GetStatusMessageDetailsForUser Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..GetStatusMessageDetailsForUser Method
FilteredStatusMessageList Class See Also Send Feedback
Gets a specific filtered status message for the given user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageDetails GetStatusMessageDetailsForUser(
    string userId,
    string statusId
)
Visual Basic
Public Function GetStatusMessageDetailsForUser ( _
    userId As String, _
    statusId As String _
) As StatusMessageDetails

Parameters

userId
Type: System..::..String
The user ID.
statusId
Type: System..::..String
The status ID.

Return Value

The specified filtered status message for the given userId.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | The user ID is not being watched.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
FilteredStatusMessageList..::..IsWatching Method
FilteredStatusMessageList Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..IsWatching Method
FilteredStatusMessageList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..IsWatching Method (String)
FilteredStatusMessageList Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string userId
)
Visual Basic
Public Function IsWatching ( _
    userId As String _
) As Boolean

Parameters

userId
Type: System..::..String
The user.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
IsWatching Overload
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..StartWatching Method
FilteredStatusMessageList Class See Also Send Feedback
Starts watching the Filtered Status Message List for a set of users.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] userIds
)
Visual Basic
Public Sub StartWatching ( _
    userIds As String() _
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
An array of users to request a watch of their status message list.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An item in userIds is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.
System..::..InvalidOperationException | A watch is already in progress.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..StartWatchingAsync Method
FilteredStatusMessageList Class See Also Send Feedback
Asynchronously starts watching the Filtered Status Message List for a set of users.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] userIds,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    userIds As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
An array of users to request a watch of their status message list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An item in userIds is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..StopWatching Method
FilteredStatusMessageList Class See Also Send Feedback
Stops watching the Filtered Status Message List for a set of users.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..StopWatchingAsync Method
FilteredStatusMessageList Class See Also Send Feedback
Asynchronously stops watching the Filtered Status Message List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


FilteredStatusMessageList Properties

[image] [image]

IceLib Technical Reference
FilteredStatusMessageList Properties
FilteredStatusMessageList Class See Also Send Feedback

The FilteredStatusMessageList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the list of filtered status messages for the given user.

See Also

FilteredStatusMessageList Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..Item Property
FilteredStatusMessageList Class See Also Send Feedback
Gets the list of filtered status messages for the given user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatusMessageDetails> this[
    string userId
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    userId As String _
) As ReadOnlyCollection(Of StatusMessageDetails)
    Get

Parameters

userId
Type: System..::..String
The user to retrieve the list of filtered status messages.

Return Value

The list of filtered status messages for the given userId.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | The user ID is not being watched.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


FilteredStatusMessageList Events

[image] [image]

IceLib Technical Reference
FilteredStatusMessageList Events
FilteredStatusMessageList Class See Also Send Feedback

The FilteredStatusMessageList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the FilteredStatusMessageList watched objects has changed.
Public event | WatchedStatusMessageObjectsChanged | Occurs when one of the FilteredStatusMessageList watched objects has an attribute changed.

See Also

FilteredStatusMessageList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..WatchedObjectsChanged Event
FilteredStatusMessageList Class See Also Send Feedback
Occurs when one of the FilteredStatusMessageList watched objects has changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<FilteredStatusMessageChangedEventArgs> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of FilteredStatusMessageChangedEventArgs)

Remarks

Note that changes, additions, and removal of objects are monitored for a FilteredStatusMessageList.

Each Changed notification for a given user is described in the StatusMessageDetails object defined in the collection of StatusMessageDetails objects.

This event will only occur if the status message list is being watched. To start watching the status message list call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


WatchedStatusMessageObjectsChanged Event

[image]

IceLib Technical Reference
FilteredStatusMessageList..::..WatchedStatusMessageObjectsChanged Event
FilteredStatusMessageList Class See Also Send Feedback
Occurs when one of the FilteredStatusMessageList watched objects has an attribute changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<StatusMessageChangedEventArgs> WatchedStatusMessageObjectsChanged
Visual Basic
Public Event WatchedStatusMessageObjectsChanged As EventHandler(Of StatusMessageChangedEventArgs)

Remarks

Note that changes of objects are monitored for a FilteredStatusMessageList.

Each Changed notification for a given status message is described in the collection of StatusMessageProperty values.

This event will only occur if the status message list is being watched and one of the watched status messages has an attribute that changes. To start watching the status message list call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

FilteredStatusMessageList Class
FilteredStatusMessageList Members
ININ.IceLib.People Namespace


GetLookupEntriesCompletedEventArgs Class

[image]

IceLib Technical Reference
GetLookupEntriesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetLookupEntriesAsync or GetLookupEntriesAsync.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetLookupEntriesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetLookupEntriesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.People..::..GetLookupEntriesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetLookupEntriesCompletedEventArgs Members
ININ.IceLib.People Namespace


GetLookupEntriesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetLookupEntriesCompletedEventArgs Members
GetLookupEntriesCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetLookupEntriesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LookupEntriesDetails | Gets the Lookup Entries.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetLookupEntriesCompletedEventArgs Class
ININ.IceLib.People Namespace


GetLookupEntriesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetLookupEntriesCompletedEventArgs Methods
GetLookupEntriesCompletedEventArgs Class See Also Send Feedback

The GetLookupEntriesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetLookupEntriesCompletedEventArgs Class
ININ.IceLib.People Namespace


GetLookupEntriesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetLookupEntriesCompletedEventArgs Properties
GetLookupEntriesCompletedEventArgs Class See Also Send Feedback

The GetLookupEntriesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LookupEntriesDetails | Gets the Lookup Entries.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetLookupEntriesCompletedEventArgs Class
ININ.IceLib.People Namespace


LookupEntriesDetails Property

[image]

IceLib Technical Reference
GetLookupEntriesCompletedEventArgs..::..LookupEntriesDetails Property
GetLookupEntriesCompletedEventArgs Class See Also Send Feedback
Gets the Lookup Entries.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupEntriesDetails LookupEntriesDetails { get; }
Visual Basic
Public ReadOnly Property LookupEntriesDetails As LookupEntriesDetails
    Get

Field Value

The Lookup Entries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetLookupEntriesCompletedEventArgs Class
GetLookupEntriesCompletedEventArgs Members
ININ.IceLib.People Namespace


GetPreviousStatusInfoCompletedEventArgs Class

[image]

IceLib Technical Reference
GetPreviousStatusInfoCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of UserStatusList.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetPreviousStatusInfoCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetPreviousStatusInfoCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.People..::..GetPreviousStatusInfoCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetPreviousStatusInfoCompletedEventArgs Members
ININ.IceLib.People Namespace


GetPreviousStatusInfoCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetPreviousStatusInfoCompletedEventArgs Members
GetPreviousStatusInfoCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetPreviousStatusInfoCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetPreviousStatusInfoCompletedEventArgs | Initializes a new instance of the GetPreviousStatusInfoCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PreviousStatusInfo | Gets the previous status info associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPreviousStatusInfoCompletedEventArgs Class
ININ.IceLib.People Namespace


GetPreviousStatusInfoCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetPreviousStatusInfoCompletedEventArgs Constructor
GetPreviousStatusInfoCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetPreviousStatusInfoCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetPreviousStatusInfoCompletedEventArgs(
    Dictionary<string, UserStatusPreviousInfo> previousStatusInfo,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    previousStatusInfo As Dictionary(Of String, UserStatusPreviousInfo), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

previousStatusInfo
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, UserStatusPreviousInfo >)>)>
The previous status info.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetPreviousStatusInfoCompletedEventArgs Class
GetPreviousStatusInfoCompletedEventArgs Members
ININ.IceLib.People Namespace


GetPreviousStatusInfoCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetPreviousStatusInfoCompletedEventArgs Methods
GetPreviousStatusInfoCompletedEventArgs Class See Also Send Feedback

The GetPreviousStatusInfoCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPreviousStatusInfoCompletedEventArgs Class
ININ.IceLib.People Namespace


GetPreviousStatusInfoCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetPreviousStatusInfoCompletedEventArgs Properties
GetPreviousStatusInfoCompletedEventArgs Class See Also Send Feedback

The GetPreviousStatusInfoCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PreviousStatusInfo | Gets the previous status info associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPreviousStatusInfoCompletedEventArgs Class
ININ.IceLib.People Namespace


PreviousStatusInfo Property

[image]

IceLib Technical Reference
GetPreviousStatusInfoCompletedEventArgs..::..PreviousStatusInfo Property
GetPreviousStatusInfoCompletedEventArgs Class See Also Send Feedback
Gets the previous status info associated with the event.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Dictionary<string, UserStatusPreviousInfo> PreviousStatusInfo { get; }
Visual Basic
Public ReadOnly Property PreviousStatusInfo As Dictionary(Of String, UserStatusPreviousInfo)
    Get

Field Value

The previous status info.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetPreviousStatusInfoCompletedEventArgs Class
GetPreviousStatusInfoCompletedEventArgs Members
ININ.IceLib.People Namespace


GetUserActivationListCompletedEventArgs Class

[image]

IceLib Technical Reference
GetUserActivationListCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of GetUserActivationList(String).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetUserActivationListCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetUserActivationListCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.People..::..GetUserActivationListCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetUserActivationListCompletedEventArgs Members
ININ.IceLib.People Namespace


GetUserActivationListCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetUserActivationListCompletedEventArgs Members
GetUserActivationListCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetUserActivationListCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | WorkgroupActivations | Gets the workgroup activations.

See Also

GetUserActivationListCompletedEventArgs Class
ININ.IceLib.People Namespace


GetUserActivationListCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetUserActivationListCompletedEventArgs Methods
GetUserActivationListCompletedEventArgs Class See Also Send Feedback

The GetUserActivationListCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetUserActivationListCompletedEventArgs Class
ININ.IceLib.People Namespace


GetUserActivationListCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetUserActivationListCompletedEventArgs Properties
GetUserActivationListCompletedEventArgs Class See Also Send Feedback

The GetUserActivationListCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | WorkgroupActivations | Gets the workgroup activations.

See Also

GetUserActivationListCompletedEventArgs Class
ININ.IceLib.People Namespace


WorkgroupActivations Property

[image]

IceLib Technical Reference
GetUserActivationListCompletedEventArgs..::..WorkgroupActivations Property
GetUserActivationListCompletedEventArgs Class See Also Send Feedback
Gets the workgroup activations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WorkgroupActivation> WorkgroupActivations { get; }
Visual Basic
Public ReadOnly Property WorkgroupActivations As ReadOnlyCollection(Of WorkgroupActivation)
    Get

Field Value

The workgroup activations.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetUserActivationListCompletedEventArgs Class
GetUserActivationListCompletedEventArgs Members
ININ.IceLib.People Namespace


GetUserStatusCompletedEventArgs Class

[image]

IceLib Technical Reference
GetUserStatusCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of UserStatusList.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetUserStatusCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetUserStatusCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.People..::..GetUserStatusCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetUserStatusCompletedEventArgs Members
ININ.IceLib.People Namespace


GetUserStatusCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetUserStatusCompletedEventArgs Members
GetUserStatusCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetUserStatusCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetUserStatusCompletedEventArgs | Initializes a new instance of the GetUserStatusCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | UserStatus | Gets the user status associated with the event.

See Also

GetUserStatusCompletedEventArgs Class
ININ.IceLib.People Namespace


GetUserStatusCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetUserStatusCompletedEventArgs Constructor
GetUserStatusCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetUserStatusCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetUserStatusCompletedEventArgs(
    UserStatus userStatus,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    userStatus As UserStatus, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

userStatus
Type: ININ.IceLib.People..::..UserStatus
The user status.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetUserStatusCompletedEventArgs Class
GetUserStatusCompletedEventArgs Members
ININ.IceLib.People Namespace


GetUserStatusCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetUserStatusCompletedEventArgs Methods
GetUserStatusCompletedEventArgs Class See Also Send Feedback

The GetUserStatusCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetUserStatusCompletedEventArgs Class
ININ.IceLib.People Namespace


GetUserStatusCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetUserStatusCompletedEventArgs Properties
GetUserStatusCompletedEventArgs Class See Also Send Feedback

The GetUserStatusCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | UserStatus | Gets the user status associated with the event.

See Also

GetUserStatusCompletedEventArgs Class
ININ.IceLib.People Namespace


UserStatus Property

[image]

IceLib Technical Reference
GetUserStatusCompletedEventArgs..::..UserStatus Property
GetUserStatusCompletedEventArgs Class See Also Send Feedback
Gets the user status associated with the event.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatus UserStatus { get; }
Visual Basic
Public ReadOnly Property UserStatus As UserStatus
    Get

Field Value

The user status.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetUserStatusCompletedEventArgs Class
GetUserStatusCompletedEventArgs Members
ININ.IceLib.People Namespace


LicenseManagement Class

[image]

IceLib Technical Reference
LicenseManagement Class
Members Example See Also Send Feedback
This class provides support for performing license operations for the session user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LicenseManagement
Visual Basic
Public Class LicenseManagement

Remarks

To perform a license operation, create a LicenseRequest object and set the appropriate flag for the requested operation, then call LicenseOperation(IList<(Of <<'(LicenseRequest>)>>)) or LicenseOperationAsync(IList<(Of <<'(LicenseRequest>)>>), EventHandler<(Of <<'(LicenseOperationCompletedEventArgs>)>>), Object) providing a list of LicenseRequest objects. The asynchronous version of this method contains an optional callback function that is invoked when this operation completes. When this operation completes it returns a list of boolean flags indicating success or failure of each LicenseRequest.

This class can be used to query, acquire, release, and replace user licenses as well as to query feature licenses on the IC server.

Note
The document titled IC Licensing Overview provides additional information about licensing. It includes details on IC Server Feature Licenses, IC Client Access Licenses, and steps for configuring and managing license information with Interaction Administrator and the PureConnect License Management Web site.

You will find IC Licensing Overview in the Technical Reference Documents section of the IC Documentation Library on your IC Server.

Examples

CopyC#
...

LicenseRequest request = new LicenseRequest(textBoxLicense.Text, LicenseRequestType.Query);
Collection<LicenseRequest> requests = new Collection<LicenseRequest>();

requests.Add(request);

if (_LicenseManager != null)
{
   _LicenseManager.LicenseOperationAsync(requests, queryLicenseCompleted, textBoxLicense.Text);
}

private void queryLicenseCompleted(object sender, LicenseOperationCompletedEventArgs e)
{
    if (e.Error == null)
    {
        ReadOnlyCollection<bool> results;
        string license;

        string message;

        results = e.LicenseOperationResults;
        license = e.UserState as string;

        if (results[0] == true)
        {
            message = license + " is available for " + m_Session.UserId;
            MessageBox.Show(this, message, "People Client", MessageBoxButtons.OK, MessageBoxIcon.Information);
        }
        else
        {
            message = license + " is not available for " + m_Session.UserId;
            MessageBox.Show(this, message, "People Client", MessageBoxButtons.OK, MessageBoxIcon.Exclamation);
        }

    }
}

Examples

The IceLib SDK includes example application references to the LicenseManagement class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 58, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 145, in StatisticCatalogViewModel.SessionConnectionStateChanged

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..LicenseManagement

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseManagement Members
ININ.IceLib.People Namespace


LicenseManagement Members

[image] [image]

IceLib Technical Reference
LicenseManagement Members
LicenseManagement Class Constructors Methods Events See Also Send Feedback

The LicenseManagement type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseManagement | Initializes a new instance of the LicenseManagement class.

Methods

 | Name | Description
Public method | ChangeWatchedLicenses | Changes which licenses are being watched.
Public method | ChangeWatchedLicensesAsync | Asynchronously changes which licenses are being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLicenseAssigned | Gets a value indicating whether or not the license is assigned to the user.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Public method | LicenseOperation | Issues a synchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Public method | LicenseOperationAsync | Issues an asynchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformLicenseOperation | Issues a synchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Public method | PerformLicenseOperationAsync | Issues an asynchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Public method | StartWatching | Starts watching the specified licenseNames.
Public method | StartWatchingAsync | Asynchronously starts watching the specified licenseNames.
Public method | StopWatching | Stops watching the licenses.
Public method | StopWatchingAsync | Asynchronously stops watching the licenses.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | LicensesChanged | Occurs when a license changes.

See Also

LicenseManagement Class
ININ.IceLib.People Namespace


LicenseManagement Constructor

[image]

IceLib Technical Reference
LicenseManagement Constructor
LicenseManagement Class Example See Also Send Feedback
Initializes a new instance of the LicenseManagement class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseManagement(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
The PeopleManager instance for this session user.

Examples

The IceLib SDK includes example application references to the LicenseManagement constructor. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 58, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 145, in StatisticCatalogViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


LicenseManagement Methods

[image] [image]

IceLib Technical Reference
LicenseManagement Methods
LicenseManagement Class See Also Send Feedback

The LicenseManagement type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedLicenses | Changes which licenses are being watched.
Public method | ChangeWatchedLicensesAsync | Asynchronously changes which licenses are being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLicenseAssigned | Gets a value indicating whether or not the license is assigned to the user.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Public method | LicenseOperation | Issues a synchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Public method | LicenseOperationAsync | Issues an asynchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformLicenseOperation | Issues a synchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Public method | PerformLicenseOperationAsync | Issues an asynchronous request to perform license operations (query, request, release, replace) on a set of licenses.
Public method | StartWatching | Starts watching the specified licenseNames.
Public method | StartWatchingAsync | Asynchronously starts watching the specified licenseNames.
Public method | StopWatching | Stops watching the licenses.
Public method | StopWatchingAsync | Asynchronously stops watching the licenses.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LicenseManagement Class
ININ.IceLib.People Namespace


ChangeWatchedLicenses Method

[image]

IceLib Technical Reference
LicenseManagement..::..ChangeWatchedLicenses Method
LicenseManagement Class See Also Send Feedback
Changes which licenses are being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedLicenses(
    string[] licenseNamesToAdd,
    string[] licenseNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedLicenses ( _
    licenseNamesToAdd As String(), _
    licenseNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

licenseNamesToAdd
Type: array<System..::..String>[]()[][]
The license names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
licenseNamesToRemove
Type: array<System..::..String>[]()[][]
The license names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


ChangeWatchedLicensesAsync Method

[image]

IceLib Technical Reference
LicenseManagement..::..ChangeWatchedLicensesAsync Method
LicenseManagement Class See Also Send Feedback
Asynchronously changes which licenses are being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedLicensesAsync(
    string[] licenseNamesToAdd,
    string[] licenseNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedLicensesAsync ( _
    licenseNamesToAdd As String(), _
    licenseNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

licenseNamesToAdd
Type: array<System..::..String>[]()[][]
The license names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
licenseNamesToRemove
Type: array<System..::..String>[]()[][]
The license names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


IsLicenseAssigned Method

[image]

IceLib Technical Reference
LicenseManagement..::..IsLicenseAssigned Method
LicenseManagement Class See Also Send Feedback
Gets a value indicating whether or not the license is assigned to the user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsLicenseAssigned(
    string licenseName
)
Visual Basic
Public Function IsLicenseAssigned ( _
    licenseName As String _
) As Boolean

Parameters

licenseName
Type: System..::..String
Name of the license.

Return Value

The trueTruetruetrue (True in Visual Basic) if the license is assigned, falseFalsefalsefalse (False in Visual Basic) otherwise.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..NotCachedException | The license is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
LicenseManagement..::..IsWatching Method
LicenseManagement Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
LicenseManagement..::..IsWatching Method
LicenseManagement Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
LicenseManagement..::..IsWatching Method (String)
LicenseManagement Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string licenseName
)
Visual Basic
Public Function IsWatching ( _
    licenseName As String _
) As Boolean

Parameters

licenseName
Type: System..::..String
The license name.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
IsWatching Overload
ININ.IceLib.People Namespace


LicenseOperation Method

[image]

IceLib Technical Reference
LicenseManagement..::..LicenseOperation Method
LicenseManagement Class Example See Also Send Feedback
Issues a synchronous request to perform license operations (query, request, release, replace) on a set of licenses.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<bool> LicenseOperation(
    IList<LicenseRequest> licenseRequests
)
Visual Basic
Public Function LicenseOperation ( _
    licenseRequests As IList(Of LicenseRequest) _
) As ReadOnlyCollection(Of Boolean)

Parameters

licenseRequests
Type: System.Collections.Generic..::..IList<(Of <(<' LicenseRequest >)>)>
A set of license operations to perform.

Return Value

A set of boolean flags indicating the results of each LicenseRequest.

Examples

The IceLib SDK includes example application references to the LicenseOperation method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 59, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 146, in StatisticCatalogViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


LicenseOperationAsync Method

[image]

IceLib Technical Reference
LicenseManagement..::..LicenseOperationAsync Method
LicenseManagement Class See Also Send Feedback
Issues an asynchronous request to perform license operations (query, request, release, replace) on a set of licenses.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void LicenseOperationAsync(
    IList<LicenseRequest> licenseRequests,
    EventHandler<LicenseOperationCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub LicenseOperationAsync ( _
    licenseRequests As IList(Of LicenseRequest), _
    completedCallback As EventHandler(Of LicenseOperationCompletedEventArgs), _
    userState As Object _
)

Parameters

licenseRequests
Type: System.Collections.Generic..::..IList<(Of <(<' LicenseRequest >)>)>
A set of license operation requests to perform.
completedCallback
Type: System..::..EventHandler<(Of <(<' LicenseOperationCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


PerformLicenseOperation Method

[image]

IceLib Technical Reference
LicenseManagement..::..PerformLicenseOperation Method
LicenseManagement Class See Also Send Feedback
Issues a synchronous request to perform license operations (query, request, release, replace) on a set of licenses.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PerformLicenseOperationResult> PerformLicenseOperation(
    IList<LicenseRequest> licenseRequests
)
Visual Basic
Public Function PerformLicenseOperation ( _
    licenseRequests As IList(Of LicenseRequest) _
) As ReadOnlyCollection(Of PerformLicenseOperationResult)

Parameters

licenseRequests
Type: System.Collections.Generic..::..IList<(Of <(<' LicenseRequest >)>)>
A set of license operations to perform.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of PerformLicenseOperationResult objects indicating the results of each LicenseRequest.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


PerformLicenseOperationAsync Method

[image]

IceLib Technical Reference
LicenseManagement..::..PerformLicenseOperationAsync Method
LicenseManagement Class See Also Send Feedback
Issues an asynchronous request to perform license operations (query, request, release, replace) on a set of licenses.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PerformLicenseOperationAsync(
    IList<LicenseRequest> licenseRequests,
    EventHandler<PerformLicenseOperationCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub PerformLicenseOperationAsync ( _
    licenseRequests As IList(Of LicenseRequest), _
    completedCallback As EventHandler(Of PerformLicenseOperationCompletedEventArgs), _
    userState As Object _
)

Parameters

licenseRequests
Type: System.Collections.Generic..::..IList<(Of <(<' LicenseRequest >)>)>
A set of license operation requests to perform.
completedCallback
Type: System..::..EventHandler<(Of <(<' PerformLicenseOperationCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
LicenseManagement..::..StartWatching Method
LicenseManagement Class See Also Send Feedback
Starts watching the specified licenseNames.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] licenseNames
)
Visual Basic
Public Sub StartWatching ( _
    licenseNames As String() _
)

Parameters

licenseNames
Type: array<System..::..String>[]()[][]
The license names.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
LicenseManagement..::..StartWatchingAsync Method
LicenseManagement Class See Also Send Feedback
Asynchronously starts watching the specified licenseNames.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] licenseNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    licenseNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

licenseNames
Type: array<System..::..String>[]()[][]
The license names.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
LicenseManagement..::..StopWatching Method
LicenseManagement Class See Also Send Feedback
Stops watching the licenses.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
LicenseManagement..::..StopWatchingAsync Method
LicenseManagement Class See Also Send Feedback
Asynchronously stops watching the licenses.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


LicenseManagement Events

[image] [image]

IceLib Technical Reference
LicenseManagement Events
LicenseManagement Class See Also Send Feedback

The LicenseManagement type exposes the following members.

Events

 | Name | Description
Public event | LicensesChanged | Occurs when a license changes.

See Also

LicenseManagement Class
ININ.IceLib.People Namespace


LicensesChanged Event

[image]

IceLib Technical Reference
LicenseManagement..::..LicensesChanged Event
LicenseManagement Class See Also Send Feedback
Occurs when a license changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<LicensesEventArgs> LicensesChanged
Visual Basic
Public Event LicensesChanged As EventHandler(Of LicensesEventArgs)

Remarks

This event will only occur when licenses being watched have changed. To start watching for licenses call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which licenses are being watched once the watch has been started, use the ChangeWatchedLicenses(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicenseManagement Class
LicenseManagement Members
ININ.IceLib.People Namespace


LicenseNameAttributes Class

[image]

IceLib Technical Reference
LicenseNameAttributes Class
Members See Also Send Feedback
Static constants for common IC license names used in the LicenseRequest class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class LicenseNameAttributes
Visual Basic
Public NotInheritable Class LicenseNameAttributes

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..LicenseNameAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Members
ININ.IceLib.People Namespace


LicenseNameAttributes Members

[image] [image]

IceLib Technical Reference
LicenseNameAttributes Members
LicenseNameAttributes Class Fields See Also Send Feedback

The LicenseNameAttributes type exposes the following members.

Fields

Name | Description
CICFeatureVersion | This is a feature license that provides the session user with the Contact Interaction Center (CIC) set of functionality.
CommuniteFeatureVersion | This is a feature license that provides the session user with the Communité set of functionality.
EICFeatureVersion | This is a feature license that provides the session user with the Enterprise Interaction Center (EIC) set of functionality.
OperatorClientAccess | This is a license that provides the session user access to the Interaction Client - Operator Edition.
OptimizerAccess | This is a license that provides the session user access to the Optimizer Plugin.
RecorderAdvancedFeature | This is a feature license that provides the session user with advanced Recorder functionality.
RecorderBaseFeature | This is a feature license that provides the session user with the Recorder functionality.
ReportAssistantSupervisorPluginAccess | This is license that provides access to the session user for the supervisor report assistant reporting plugin.
SICFeatureVersion | This is a feature license that provides the session user with the Service Interaction Center (SIC) set of functionality.
TrackerAccess | This is a license that provides the session user access to the Tracker Plugin.

See Also

LicenseNameAttributes Class
ININ.IceLib.People Namespace


LicenseNameAttributes Fields

[image] [image]

IceLib Technical Reference
LicenseNameAttributes Fields
LicenseNameAttributes Class See Also Send Feedback

The LicenseNameAttributes type exposes the following members.

Fields

Name | Description
CICFeatureVersion | This is a feature license that provides the session user with the Contact Interaction Center (CIC) set of functionality.
CommuniteFeatureVersion | This is a feature license that provides the session user with the Communité set of functionality.
EICFeatureVersion | This is a feature license that provides the session user with the Enterprise Interaction Center (EIC) set of functionality.
OperatorClientAccess | This is a license that provides the session user access to the Interaction Client - Operator Edition.
OptimizerAccess | This is a license that provides the session user access to the Optimizer Plugin.
RecorderAdvancedFeature | This is a feature license that provides the session user with advanced Recorder functionality.
RecorderBaseFeature | This is a feature license that provides the session user with the Recorder functionality.
ReportAssistantSupervisorPluginAccess | This is license that provides access to the session user for the supervisor report assistant reporting plugin.
SICFeatureVersion | This is a feature license that provides the session user with the Service Interaction Center (SIC) set of functionality.
TrackerAccess | This is a license that provides the session user access to the Tracker Plugin.

See Also

LicenseNameAttributes Class
ININ.IceLib.People Namespace


CICFeatureVersion Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..CICFeatureVersion Field
LicenseNameAttributes Class See Also Send Feedback
This is a feature license that provides the session user with the Contact Interaction Center (CIC) set of functionality.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CICFeatureVersion
Visual Basic
Public Shared ReadOnly CICFeatureVersion As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


CommuniteFeatureVersion Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..CommuniteFeatureVersion Field
LicenseNameAttributes Class See Also Send Feedback
This is a feature license that provides the session user with the Communité set of functionality.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CommuniteFeatureVersion
Visual Basic
Public Shared ReadOnly CommuniteFeatureVersion As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


EICFeatureVersion Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..EICFeatureVersion Field
LicenseNameAttributes Class See Also Send Feedback
This is a feature license that provides the session user with the Enterprise Interaction Center (EIC) set of functionality.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string EICFeatureVersion
Visual Basic
Public Shared ReadOnly EICFeatureVersion As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


OperatorClientAccess Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..OperatorClientAccess Field
LicenseNameAttributes Class See Also Send Feedback
This is a license that provides the session user access to the Interaction Client - Operator Edition.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OperatorClientAccess
Visual Basic
Public Shared ReadOnly OperatorClientAccess As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


OptimizerAccess Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..OptimizerAccess Field
LicenseNameAttributes Class See Also Send Feedback
This is a license that provides the session user access to the Optimizer Plugin.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerAccess
Visual Basic
Public Shared ReadOnly OptimizerAccess As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


RecorderAdvancedFeature Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..RecorderAdvancedFeature Field
LicenseNameAttributes Class See Also Send Feedback
This is a feature license that provides the session user with advanced Recorder functionality.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecorderAdvancedFeature
Visual Basic
Public Shared ReadOnly RecorderAdvancedFeature As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


RecorderBaseFeature Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..RecorderBaseFeature Field
LicenseNameAttributes Class See Also Send Feedback
This is a feature license that provides the session user with the Recorder functionality.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecorderBaseFeature
Visual Basic
Public Shared ReadOnly RecorderBaseFeature As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


ReportAssistantSupervisorPluginAccess Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..ReportAssistantSupervisorPluginAccess Field
LicenseNameAttributes Class See Also Send Feedback
This is license that provides access to the session user for the supervisor report assistant reporting plugin.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ReportAssistantSupervisorPluginAccess
Visual Basic
Public Shared ReadOnly ReportAssistantSupervisorPluginAccess As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


SICFeatureVersion Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..SICFeatureVersion Field
LicenseNameAttributes Class See Also Send Feedback
This is a feature license that provides the session user with the Service Interaction Center (SIC) set of functionality.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SICFeatureVersion
Visual Basic
Public Shared ReadOnly SICFeatureVersion As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


TrackerAccess Field

[image]

IceLib Technical Reference
LicenseNameAttributes..::..TrackerAccess Field
LicenseNameAttributes Class See Also Send Feedback
This is a license that provides the session user access to the Tracker Plugin.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string TrackerAccess
Visual Basic
Public Shared ReadOnly TrackerAccess As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseNameAttributes Class
LicenseNameAttributes Members
ININ.IceLib.People Namespace


LicenseOperationCompletedEventArgs Class

[image]

IceLib Technical Reference
LicenseOperationCompletedEventArgs Class
Members See Also Send Feedback
Arguments returned by the asynchronous license operation request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LicenseOperationCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class LicenseOperationCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.People..::..LicenseOperationCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseOperationCompletedEventArgs Members
ININ.IceLib.People Namespace


LicenseOperationCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
LicenseOperationCompletedEventArgs Members
LicenseOperationCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The LicenseOperationCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseOperationCompletedEventArgs | Creates an instance of LicenseOperationCompletedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LicenseOperationResults | Set of flags indicating the result of each license operation.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LicenseOperationCompletedEventArgs Class
ININ.IceLib.People Namespace


LicenseOperationCompletedEventArgs Constructor

[image]

IceLib Technical Reference
LicenseOperationCompletedEventArgs Constructor
LicenseOperationCompletedEventArgs Class See Also Send Feedback
Creates an instance of LicenseOperationCompletedEventArgs.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseOperationCompletedEventArgs(
    IList<bool> licenseOperationResults,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    licenseOperationResults As IList(Of Boolean), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

licenseOperationResults
Type: System.Collections.Generic..::..IList<(Of <(<'Boolean>)>)>
The license operation results to return to the user.
error
Type: System..::..Exception
The exception.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
The user-supplied object to be passed to the asynchronous license operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseOperationCompletedEventArgs Class
LicenseOperationCompletedEventArgs Members
ININ.IceLib.People Namespace


LicenseOperationCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
LicenseOperationCompletedEventArgs Methods
LicenseOperationCompletedEventArgs Class See Also Send Feedback

The LicenseOperationCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LicenseOperationCompletedEventArgs Class
ININ.IceLib.People Namespace


LicenseOperationCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
LicenseOperationCompletedEventArgs Properties
LicenseOperationCompletedEventArgs Class See Also Send Feedback

The LicenseOperationCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LicenseOperationResults | Set of flags indicating the result of each license operation.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LicenseOperationCompletedEventArgs Class
ININ.IceLib.People Namespace


LicenseOperationResults Property

[image]

IceLib Technical Reference
LicenseOperationCompletedEventArgs..::..LicenseOperationResults Property
LicenseOperationCompletedEventArgs Class See Also Send Feedback
Set of flags indicating the result of each license operation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<bool> LicenseOperationResults { get; }
Visual Basic
Public ReadOnly Property LicenseOperationResults As ReadOnlyCollection(Of Boolean)
    Get

Field Value

The license operation results.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseOperationCompletedEventArgs Class
LicenseOperationCompletedEventArgs Members
ININ.IceLib.People Namespace


LicenseRequest Class

[image]

IceLib Technical Reference
LicenseRequest Class
Members Example See Also Send Feedback
This class implements a license request operation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LicenseRequest
Visual Basic
Public Class LicenseRequest

Remarks

Objects of this class are used to perform license operation requests. The license requests that can be performed are query, request, replace, and release. This class can be used to query, request, replace, and release user licenses as well as query feature licenses on the IC server.

Examples

The IceLib SDK includes example application references to the LicenseRequest class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 59, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 146, in StatisticCatalogViewModel.SessionConnectionStateChanged

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..LicenseRequest

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Members
ININ.IceLib.People Namespace


LicenseRequest Members

[image] [image]

IceLib Technical Reference
LicenseRequest Members
LicenseRequest Class Constructors Methods Properties See Also Send Feedback

The LicenseRequest type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseRequest()()()() | The default constructor creates an instance of the LicenseRequest class.
Public method | LicenseRequest(String) | Creates a default license request object that queries the existence of the requested license. The license can be a user license or a feature license on the IC server.
Public method | LicenseRequest(String, LicenseRequestType) | Creates a license request object to perform a query, request, replace, or release operation on a license. The license can be a user license or a feature license on the IC server.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | LicenseRequestType | Gets the type of the license request.
Public property | Name | Gets the license name.

See Also

LicenseRequest Class
ININ.IceLib.People Namespace


LicenseRequest Constructor

[image] [image]

IceLib Technical Reference
LicenseRequest Constructor
LicenseRequest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LicenseRequest()()()() | The default constructor creates an instance of the LicenseRequest class.
Public method | LicenseRequest(String) | Creates a default license request object that queries the existence of the requested license. The license can be a user license or a feature license on the IC server.
Public method | LicenseRequest(String, LicenseRequestType) | Creates a license request object to perform a query, request, replace, or release operation on a license. The license can be a user license or a feature license on the IC server.

See Also

LicenseRequest Class
LicenseRequest Members
ININ.IceLib.People Namespace


LicenseRequest Constructor

[image]

IceLib Technical Reference
LicenseRequest Constructor
LicenseRequest Class See Also Send Feedback
The default constructor creates an instance of the LicenseRequest class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseRequest()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Class
LicenseRequest Members
LicenseRequest Overload
ININ.IceLib.People Namespace


LicenseRequest Constructor (String)

[image]

IceLib Technical Reference
LicenseRequest Constructor (String)
LicenseRequest Class Example See Also Send Feedback
Creates a default license request object that queries the existence of the requested license. The license can be a user license or a feature license on the IC server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseRequest(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::..String
The name of the requested license.

Remarks

The LicenseNameAttributes class contains common IC license names to be used with the name parameter however custom strings may also be used for custom licenses.

Examples

The IceLib SDK includes example application references to the LicenseRequest constructor. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 59, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 146, in StatisticCatalogViewModel.SessionConnectionStateChanged

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Class
LicenseRequest Members
LicenseRequest Overload
ININ.IceLib.People Namespace
ININ.IceLib.People..::..LicenseNameAttributes


LicenseRequest Constructor (String, LicenseRequestType)

[image]

IceLib Technical Reference
LicenseRequest Constructor (String, LicenseRequestType)
LicenseRequest Class See Also Send Feedback
Creates a license request object to perform a query, request, replace, or release operation on a license. The license can be a user license or a feature license on the IC server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseRequest(
    string name,
    LicenseRequestType licenseRequestType
)
Visual Basic
Public Sub New ( _
    name As String, _
    licenseRequestType As LicenseRequestType _
)

Parameters

name
Type: System..::..String
The license name.
licenseRequestType
Type: ININ.IceLib.People..::..LicenseRequestType
The type of operation to perform on this license.

Remarks

The LicenseNameAttributes class contains common IC license names to be used with the name parameter however custom strings may also be used for custom licenses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Class
LicenseRequest Members
LicenseRequest Overload
ININ.IceLib.People Namespace
ININ.IceLib.People..::..LicenseNameAttributes


LicenseRequest Methods

[image] [image]

IceLib Technical Reference
LicenseRequest Methods
LicenseRequest Class See Also Send Feedback

The LicenseRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

LicenseRequest Class
ININ.IceLib.People Namespace


ToString Method

[image]

IceLib Technical Reference
LicenseRequest..::..ToString Method
LicenseRequest Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Class
LicenseRequest Members
ININ.IceLib.People Namespace


LicenseRequest Properties

[image] [image]

IceLib Technical Reference
LicenseRequest Properties
LicenseRequest Class See Also Send Feedback

The LicenseRequest type exposes the following members.

Properties

 | Name | Description
Public property | LicenseRequestType | Gets the type of the license request.
Public property | Name | Gets the license name.

See Also

LicenseRequest Class
ININ.IceLib.People Namespace


LicenseRequestType Property

[image]

IceLib Technical Reference
LicenseRequest..::..LicenseRequestType Property
LicenseRequest Class See Also Send Feedback
Gets the type of the license request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseRequestType LicenseRequestType { get; }
Visual Basic
Public ReadOnly Property LicenseRequestType As LicenseRequestType
    Get

Field Value

The type of the license request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Class
LicenseRequest Members
ININ.IceLib.People Namespace


Name Property

[image]

IceLib Technical Reference
LicenseRequest..::..Name Property
LicenseRequest Class See Also Send Feedback
Gets the license name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LicenseRequest Class
LicenseRequest Members
ININ.IceLib.People Namespace


LicenseRequestType Enumeration

[image]

IceLib Technical Reference
LicenseRequestType Enumeration
See Also Send Feedback
Enumeration for the type of operation requested for a license.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LicenseRequestType
Visual Basic
Public Enumeration LicenseRequestType

Members

Member name | Value | Description
Query | 0 | Queries the availability of a license for a session user.
Request | 1 | Requests a license for a session user.
Replace | 2 | Requests a replacement of a license for a session user.
Release | 3 | Requests a release of a license for a session user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


LicensesEventArgs Class

[image]

IceLib Technical Reference
LicensesEventArgs Class
Members See Also Send Feedback
Provides data for the LicensesChanged event of a LicenseManagement.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LicensesEventArgs : EventArgs
Visual Basic
Public Class LicensesEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People..::..LicensesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicensesEventArgs Members
ININ.IceLib.People Namespace


LicensesEventArgs Members

[image] [image]

IceLib Technical Reference
LicensesEventArgs Members
LicensesEventArgs Class Constructors Methods Properties See Also Send Feedback

The LicensesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LicensesEventArgs | Initializes a new instance of the LicensesEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LicenseNames | Gets the license names associated with the change.

See Also

LicensesEventArgs Class
ININ.IceLib.People Namespace


LicensesEventArgs Constructor

[image]

IceLib Technical Reference
LicensesEventArgs Constructor
LicensesEventArgs Class See Also Send Feedback
Initializes a new instance of the LicensesEventArgs class with the specified values.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicensesEventArgs(
    string[] licenseNames
)
Visual Basic
Public Sub New ( _
    licenseNames As String() _
)

Parameters

licenseNames
Type: array<System..::..String>[]()[][]
The license names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicensesEventArgs Class
LicensesEventArgs Members
ININ.IceLib.People Namespace


LicensesEventArgs Methods

[image] [image]

IceLib Technical Reference
LicensesEventArgs Methods
LicensesEventArgs Class See Also Send Feedback

The LicensesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LicensesEventArgs Class
ININ.IceLib.People Namespace


LicensesEventArgs Properties

[image] [image]

IceLib Technical Reference
LicensesEventArgs Properties
LicensesEventArgs Class See Also Send Feedback

The LicensesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | LicenseNames | Gets the license names associated with the change.

See Also

LicensesEventArgs Class
ININ.IceLib.People Namespace


LicenseNames Property

[image]

IceLib Technical Reference
LicensesEventArgs..::..LicenseNames Property
LicensesEventArgs Class See Also Send Feedback
Gets the license names associated with the change.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> LicenseNames { get; }
Visual Basic
Public ReadOnly Property LicenseNames As ReadOnlyCollection(Of String)
    Get

Field Value

The license names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

LicensesEventArgs Class
LicensesEventArgs Members
ININ.IceLib.People Namespace


LicenseStatusType Enumeration

[image]

IceLib Technical Reference
LicenseStatusType Enumeration
See Also Send Feedback
Represents the license status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LicenseStatusType
Visual Basic
Public Enumeration LicenseStatusType

Members

Member name | Value | Description
UnknownError | -1 | Indicates that an error occured while checking the license.
None | 0 | Represents no status.
Available | 1 | Represents a license that is available.
NotAssigned | 2 | Represents a license that has not been assigned.
LicenseUnavailable | 3 | Represents a license that assigned but unavailable because all concurrent licenses are in use, or insufficient licenses are installed.
UserOnAnotherStation | 4 | Represents a license that is unavailable because the user is logged onto another station.
StationAlreadyInUseOnAnotherMachine | 5 | Represents a license that is unavailable because the station is already in use on another machine.
StationAlreadyInUseByAnotherUser | 6 | Represents a license that is unavailable because the station is being used by another user.
OtherApplicationUsingLicense | 7 | Represents a license that is unavailable because the license is in use by another application.
FeatureUnavailable | 8 | Represents a license that is unavailable because the feature is not available.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


LookupComparisonType Enumeration

[image]

IceLib Technical Reference
LookupComparisonType Enumeration
See Also Send Feedback
Represents the types of comparison for GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LookupComparisonType
Visual Basic
Public Enumeration LookupComparisonType

Members

Member name | Value | Description
None | 0 | None.
Exact | 1 | The lookup string matches a property exactly.
StartsWith | 2 | A property value starts with the lookup string.
Contains | 3 | The lookup string is a substring of a property.
Wildcards | 4 | The lookup string contains wildcards. The filter expression may contain wildcard symbols. A "*" will match zero or more characters. A "?" will match any single character. For example "Dev*" would match "Developers", "Development-Asia", and "Devices". "T?m" would match "Tim" and "Tom" but not "Team".

Remarks

The server always does case insensitive comparisons while doing lookups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

ININ.IceLib.People Namespace


LookupEntriesDetails Class

[image]

IceLib Technical Reference
LookupEntriesDetails Class
Members See Also Send Feedback
Represents the return value for GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LookupEntriesDetails
Visual Basic
Public Class LookupEntriesDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..LookupEntriesDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Members
ININ.IceLib.People Namespace


LookupEntriesDetails Members

[image] [image]

IceLib Technical Reference
LookupEntriesDetails Members
LookupEntriesDetails Class Methods Properties See Also Send Feedback

The LookupEntriesDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnsToMatch | Gets the columns to match that were passed into the request.
Public property | ComparisonTypes | Gets the comparison types that were passed into the request.
Public property | DirectoriesToSearch | Gets the directories to search that were passed into the request.
Public property | LookupEntries | Gets the Lookup Entries that matched the lookup operation GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.
Public property | LookupString | Gets the lookup string that was passed into the request.
Public property | MoreEntriesMatched | Gets a value indicating whether more entries matched.

See Also

LookupEntriesDetails Class
ININ.IceLib.People Namespace


LookupEntriesDetails Methods

[image] [image]

IceLib Technical Reference
LookupEntriesDetails Methods
LookupEntriesDetails Class See Also Send Feedback

The LookupEntriesDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LookupEntriesDetails Class
ININ.IceLib.People Namespace


LookupEntriesDetails Properties

[image] [image]

IceLib Technical Reference
LookupEntriesDetails Properties
LookupEntriesDetails Class See Also Send Feedback

The LookupEntriesDetails type exposes the following members.

Properties

 | Name | Description
Public property | ColumnsToMatch | Gets the columns to match that were passed into the request.
Public property | ComparisonTypes | Gets the comparison types that were passed into the request.
Public property | DirectoriesToSearch | Gets the directories to search that were passed into the request.
Public property | LookupEntries | Gets the Lookup Entries that matched the lookup operation GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.
Public property | LookupString | Gets the lookup string that was passed into the request.
Public property | MoreEntriesMatched | Gets a value indicating whether more entries matched.

See Also

LookupEntriesDetails Class
ININ.IceLib.People Namespace


ColumnsToMatch Property

[image]

IceLib Technical Reference
LookupEntriesDetails..::..ColumnsToMatch Property
LookupEntriesDetails Class See Also Send Feedback
Gets the columns to match that were passed into the request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LookupEntryProperty> ColumnsToMatch { get; }
Visual Basic
Public ReadOnly Property ColumnsToMatch As ReadOnlyCollection(Of LookupEntryProperty)
    Get

Field Value

The columns to match.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Class
LookupEntriesDetails Members
ININ.IceLib.People Namespace


ComparisonTypes Property

[image]

IceLib Technical Reference
LookupEntriesDetails..::..ComparisonTypes Property
LookupEntriesDetails Class See Also Send Feedback
Gets the comparison types that were passed into the request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LookupComparisonType> ComparisonTypes { get; }
Visual Basic
Public ReadOnly Property ComparisonTypes As ReadOnlyCollection(Of LookupComparisonType)
    Get

Field Value

The comparison types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Class
LookupEntriesDetails Members
ININ.IceLib.People Namespace


DirectoriesToSearch Property

[image]

IceLib Technical Reference
LookupEntriesDetails..::..DirectoriesToSearch Property
LookupEntriesDetails Class See Also Send Feedback
Gets the directories to search that were passed into the request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LookupEntryType> DirectoriesToSearch { get; }
Visual Basic
Public ReadOnly Property DirectoriesToSearch As ReadOnlyCollection(Of LookupEntryType)
    Get

Field Value

The directories to search.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Class
LookupEntriesDetails Members
ININ.IceLib.People Namespace


LookupEntries Property

[image]

IceLib Technical Reference
LookupEntriesDetails..::..LookupEntries Property
LookupEntriesDetails Class See Also Send Feedback
Gets the Lookup Entries that matched the lookup operation GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LookupEntry> LookupEntries { get; }
Visual Basic
Public ReadOnly Property LookupEntries As ReadOnlyCollection(Of LookupEntry)
    Get

Field Value

The entries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Class
LookupEntriesDetails Members
ININ.IceLib.People Namespace


LookupString Property

[image]

IceLib Technical Reference
LookupEntriesDetails..::..LookupString Property
LookupEntriesDetails Class See Also Send Feedback
Gets the lookup string that was passed into the request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LookupString { get; }
Visual Basic
Public ReadOnly Property LookupString As String
    Get

Field Value

The lookup string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Class
LookupEntriesDetails Members
ININ.IceLib.People Namespace


MoreEntriesMatched Property

[image]

IceLib Technical Reference
LookupEntriesDetails..::..MoreEntriesMatched Property
LookupEntriesDetails Class See Also Send Feedback
Gets a value indicating whether more entries matched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool MoreEntriesMatched { get; }
Visual Basic
Public ReadOnly Property MoreEntriesMatched As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if more entries matched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Gets a boolean indicating whether there are more entries that matched the lookup operation than what was given out by LookupEntries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntriesDetails Class
LookupEntriesDetails Members
ININ.IceLib.People Namespace


LookupEntry Class

[image]

IceLib Technical Reference
LookupEntry Class
Members See Also Send Feedback
Represents a lookup entry.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LookupEntry
Visual Basic
Public Class LookupEntry

Remarks

A Lookup Entry is a condensed ContactEntry. This can be used to search for contacts for operations such as transfering an Interaction.

A lookup entry can be either a user, a station, a standalone phone, a workgroup queue, or an attendant profile. Refer to the LookupEntryType enumeration.

Lookup entries can be obtained by calling GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..LookupEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Members
ININ.IceLib.People Namespace


LookupEntry Members

[image] [image]

IceLib Technical Reference
LookupEntry Members
LookupEntry Class Methods Properties See Also Send Feedback

The LookupEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BusinessEmail | Gets the lookup entry's business email address.
Public property | BusinessPhone | Gets the lookup entry's business phone number.
Public property | BusinessPhone2 | Gets the lookup entry's alternate business phone number.
Public property | Department | Gets the lookup entry's department.
Public property | DisplayName | Gets the lookup entry's display name.
Public property | EntryId | Gets the lookup entry's ID.
Public property | Extension | Gets the lookup entry's extension.
Public property | FirstName | Gets the lookup entry's first name.
Public property | HomeEmail | Gets the lookup entry's home email address.
Public property | HomePhone | Gets the lookup entry's home phone number.
Public property | HomePhone2 | Gets the lookup entry's alternate home phone number.
Public property | IsActive | Gets a value indicating whether a lookup entry is active or not.
Public property | LastName | Gets the lookup entry's last name.
Public property | LookupComparisonType | Gets the manner in which this lookup entry matched the lookup query.
Public property | LookupEntryType | Gets the type of the directory where this lookup entry is found.
Public property | MobilePhone | Gets the lookup entry's mobile phone number.
Public property | StatusUri | Gets the lookup entry's Status URI.

See Also

LookupEntry Class
ININ.IceLib.People Namespace


LookupEntry Methods

[image] [image]

IceLib Technical Reference
LookupEntry Methods
LookupEntry Class See Also Send Feedback

The LookupEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LookupEntry Class
ININ.IceLib.People Namespace


LookupEntry Properties

[image] [image]

IceLib Technical Reference
LookupEntry Properties
LookupEntry Class See Also Send Feedback

The LookupEntry type exposes the following members.

Properties

 | Name | Description
Public property | BusinessEmail | Gets the lookup entry's business email address.
Public property | BusinessPhone | Gets the lookup entry's business phone number.
Public property | BusinessPhone2 | Gets the lookup entry's alternate business phone number.
Public property | Department | Gets the lookup entry's department.
Public property | DisplayName | Gets the lookup entry's display name.
Public property | EntryId | Gets the lookup entry's ID.
Public property | Extension | Gets the lookup entry's extension.
Public property | FirstName | Gets the lookup entry's first name.
Public property | HomeEmail | Gets the lookup entry's home email address.
Public property | HomePhone | Gets the lookup entry's home phone number.
Public property | HomePhone2 | Gets the lookup entry's alternate home phone number.
Public property | IsActive | Gets a value indicating whether a lookup entry is active or not.
Public property | LastName | Gets the lookup entry's last name.
Public property | LookupComparisonType | Gets the manner in which this lookup entry matched the lookup query.
Public property | LookupEntryType | Gets the type of the directory where this lookup entry is found.
Public property | MobilePhone | Gets the lookup entry's mobile phone number.
Public property | StatusUri | Gets the lookup entry's Status URI.

See Also

LookupEntry Class
ININ.IceLib.People Namespace


BusinessEmail Property

[image]

IceLib Technical Reference
LookupEntry..::..BusinessEmail Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's business email address.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessEmail { get; }
Visual Basic
Public ReadOnly Property BusinessEmail As String
    Get

Field Value

The business email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


BusinessPhone Property

[image]

IceLib Technical Reference
LookupEntry..::..BusinessPhone Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's business phone number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone { get; }
Visual Basic
Public ReadOnly Property BusinessPhone As String
    Get

Field Value

The business phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


BusinessPhone2 Property

[image]

IceLib Technical Reference
LookupEntry..::..BusinessPhone2 Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's alternate business phone number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone2 { get; }
Visual Basic
Public ReadOnly Property BusinessPhone2 As String
    Get

Field Value

The alternate business phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


Department Property

[image]

IceLib Technical Reference
LookupEntry..::..Department Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's department.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; }
Visual Basic
Public ReadOnly Property Department As String
    Get

Field Value

The department.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


DisplayName Property

[image]

IceLib Technical Reference
LookupEntry..::..DisplayName Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's display name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


EntryId Property

[image]

IceLib Technical Reference
LookupEntry..::..EntryId Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EntryId { get; }
Visual Basic
Public ReadOnly Property EntryId As String
    Get

Field Value

The entry ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


Extension Property

[image]

IceLib Technical Reference
LookupEntry..::..Extension Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's extension.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


FirstName Property

[image]

IceLib Technical Reference
LookupEntry..::..FirstName Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's first name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; }
Visual Basic
Public ReadOnly Property FirstName As String
    Get

Field Value

The first name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


HomeEmail Property

[image]

IceLib Technical Reference
LookupEntry..::..HomeEmail Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's home email address.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeEmail { get; }
Visual Basic
Public ReadOnly Property HomeEmail As String
    Get

Field Value

The home email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


HomePhone Property

[image]

IceLib Technical Reference
LookupEntry..::..HomePhone Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's home phone number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomePhone { get; }
Visual Basic
Public ReadOnly Property HomePhone As String
    Get

Field Value

The home phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


HomePhone2 Property

[image]

IceLib Technical Reference
LookupEntry..::..HomePhone2 Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's alternate home phone number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomePhone2 { get; }
Visual Basic
Public ReadOnly Property HomePhone2 As String
    Get

Field Value

The alternate home phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


IsActive Property

[image]

IceLib Technical Reference
LookupEntry..::..IsActive Property
LookupEntry Class See Also Send Feedback
Gets a value indicating whether a lookup entry is active or not.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get

Field Value

true if active; otherwise, false.

Remarks

Gets a boolean indicating whether whether a lookup entry is active or not. Currently this property applies to workgroups only.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


LastName Property

[image]

IceLib Technical Reference
LookupEntry..::..LastName Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's last name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; }
Visual Basic
Public ReadOnly Property LastName As String
    Get

Field Value

The last name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


LookupComparisonType Property

[image]

IceLib Technical Reference
LookupEntry..::..LookupComparisonType Property
LookupEntry Class See Also Send Feedback
Gets the manner in which this lookup entry matched the lookup query.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupComparisonType LookupComparisonType { get; internal set; }
Visual Basic
Public Property LookupComparisonType As LookupComparisonType
    Get
    Friend Set

Field Value

The comparison type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


LookupEntryType Property

[image]

IceLib Technical Reference
LookupEntry..::..LookupEntryType Property
LookupEntry Class See Also Send Feedback
Gets the type of the directory where this lookup entry is found.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupEntryType LookupEntryType { get; }
Visual Basic
Public ReadOnly Property LookupEntryType As LookupEntryType
    Get

Field Value

The type of the lookup entry.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


MobilePhone Property

[image]

IceLib Technical Reference
LookupEntry..::..MobilePhone Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's mobile phone number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MobilePhone { get; }
Visual Basic
Public ReadOnly Property MobilePhone As String
    Get

Field Value

The mobile phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


StatusUri Property

[image]

IceLib Technical Reference
LookupEntry..::..StatusUri Property
LookupEntry Class See Also Send Feedback
Gets the lookup entry's Status URI.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StatusUri { get; }
Visual Basic
Public ReadOnly Property StatusUri As String
    Get

Field Value

The status URI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupEntry Class
LookupEntry Members
ININ.IceLib.People Namespace


LookupEntryProperty Enumeration

[image]

IceLib Technical Reference
LookupEntryProperty Enumeration
See Also Send Feedback
Represents properties contained in a LookupEntry.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LookupEntryProperty
Visual Basic
Public Enumeration LookupEntryProperty

Members

Member name | Value | Description
None | 0 | None.
FirstName | 1 | First Name.
LastName | 2 | Last Name.
DisplayName | 3 | Display Name.
Department | 4 | Department.
EntryId | 5 | ID of this lookup entry, e.g. the username.
Extension | 6 | Extension of this lookup entry.
MobilePhone | 7 | Mobile phone number of this lookup entry.
HomePhone | 8 | Home phone number of this lookup entry.
HomePhone2 | 9 | Alternate home phone number of this lookup entry.
HomeEmail | 10 | Home email address of this lookup entry.
BusinessPhone | 11 | Business phone number of this lookup entry.
BusinessPhone2 | 12 | Alternate business phone number of this lookup entry.
BusinessEmail | 13 | Business email address of this lookup entry.
IsActive | 14 | Is Active (applies to workgroups only).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

ININ.IceLib.People Namespace


LookupEntryType Enumeration

[image]

IceLib Technical Reference
LookupEntryType Enumeration
See Also Send Feedback
Represents different sources in which lookup entries can be searched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum LookupEntryType
Visual Basic
Public Enumeration LookupEntryType

Members

Member name | Value | Description
None | 0 | No lookup entry type specified.
User | 1 | Include Users while doing lookups.
StandalonePhone | 2 | Include Standalone Phones while doing lookups.
Station | 3 | Include Stations while doing lookups.
StationGroup | 4 | Include Station Groups while doing lookups.
AttendantProfile | 5 | Include Attendant Profiles while doing lookups.
Workgroup | 6 | Include Workgroups while doing lookups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

ININ.IceLib.People Namespace


LookupParameters Class

[image]

IceLib Technical Reference
LookupParameters Class
Members See Also Send Feedback
Represents the input for GetLookupEntriesAsync or GetLookupEntries.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LookupParameters
Visual Basic
Public Class LookupParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..LookupParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Members
ININ.IceLib.People Namespace


LookupParameters Members

[image] [image]

IceLib Technical Reference
LookupParameters Members
LookupParameters Class Constructors Methods Properties See Also Send Feedback

The LookupParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LookupParameters | Constructs a default LookupParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ColumnsToMatch | Gets or sets the columns to match with the LookupString, using the specified ComparisonType.
Public property | ComparisonType | Gets or sets the comparison type.
Public property | DirectoriesToSearch | Gets or sets the directories to search.
Public property | IncludeUsersExcludedFromCompanyDirectory | Gets or sets a boolean indicating whether to include users that are not shown on the company directory.
Public property | LookupString | Gets or sets the lookup string.
Public property | MaxEntries | Gets or sets the Lookup Entries that matched the lookup operation GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

See Also

LookupParameters Class
ININ.IceLib.People Namespace


LookupParameters Constructor

[image]

IceLib Technical Reference
LookupParameters Constructor
LookupParameters Class See Also Send Feedback
Constructs a default LookupParameters class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupParameters()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


LookupParameters Methods

[image] [image]

IceLib Technical Reference
LookupParameters Methods
LookupParameters Class See Also Send Feedback

The LookupParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

LookupParameters Class
ININ.IceLib.People Namespace


ToString Method

[image]

IceLib Technical Reference
LookupParameters..::..ToString Method
LookupParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


LookupParameters Properties

[image] [image]

IceLib Technical Reference
LookupParameters Properties
LookupParameters Class See Also Send Feedback

The LookupParameters type exposes the following members.

Properties

 | Name | Description
Public property | ColumnsToMatch | Gets or sets the columns to match with the LookupString, using the specified ComparisonType.
Public property | ComparisonType | Gets or sets the comparison type.
Public property | DirectoriesToSearch | Gets or sets the directories to search.
Public property | IncludeUsersExcludedFromCompanyDirectory | Gets or sets a boolean indicating whether to include users that are not shown on the company directory.
Public property | LookupString | Gets or sets the lookup string.
Public property | MaxEntries | Gets or sets the Lookup Entries that matched the lookup operation GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

See Also

LookupParameters Class
ININ.IceLib.People Namespace


ColumnsToMatch Property

[image]

IceLib Technical Reference
LookupParameters..::..ColumnsToMatch Property
LookupParameters Class See Also Send Feedback
Gets or sets the columns to match with the LookupString, using the specified ComparisonType.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public List<LookupEntryProperty> ColumnsToMatch { get; set; }
Visual Basic
Public Property ColumnsToMatch As List(Of LookupEntryProperty)
    Get
    Set

Field Value

The columns to match.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


ComparisonType Property

[image]

IceLib Technical Reference
LookupParameters..::..ComparisonType Property
LookupParameters Class See Also Send Feedback
Gets or sets the comparison type.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupComparisonType ComparisonType { get; set; }
Visual Basic
Public Property ComparisonType As LookupComparisonType
    Get
    Set

Field Value

The comparison type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


DirectoriesToSearch Property

[image]

IceLib Technical Reference
LookupParameters..::..DirectoriesToSearch Property
LookupParameters Class See Also Send Feedback
Gets or sets the directories to search.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public List<LookupEntryType> DirectoriesToSearch { get; set; }
Visual Basic
Public Property DirectoriesToSearch As List(Of LookupEntryType)
    Get
    Set

Field Value

The directories to search.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


IncludeUsersExcludedFromCompanyDirectory Property

[image]

IceLib Technical Reference
LookupParameters..::..IncludeUsersExcludedFromCompanyDirectory Property
LookupParameters Class See Also Send Feedback
Gets or sets a boolean indicating whether to include users that are not shown on the company directory.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IncludeUsersExcludedFromCompanyDirectory { get; set; }
Visual Basic
Public Property IncludeUsersExcludedFromCompanyDirectory As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) include users that are not shown on the company directory; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Gets a boolean indicating whether there are more entries that matched the lookup operation than what was given out by LookupEntries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


LookupString Property

[image]

IceLib Technical Reference
LookupParameters..::..LookupString Property
LookupParameters Class See Also Send Feedback
Gets or sets the lookup string.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LookupString { get; set; }
Visual Basic
Public Property LookupString As String
    Get
    Set

Field Value

The lookup string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


MaxEntries Property

[image]

IceLib Technical Reference
LookupParameters..::..MaxEntries Property
LookupParameters Class See Also Send Feedback
Gets or sets the Lookup Entries that matched the lookup operation GetLookupEntries and GetLookupEntries or the corresponding asynchronous variants GetLookupEntriesAsync and GetLookupEntriesAsync.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaxEntries { get; set; }
Visual Basic
Public Property MaxEntries As Integer
    Get
    Set

Field Value

The entries.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

LookupParameters Class
LookupParameters Members
ININ.IceLib.People Namespace


PeopleManager Class

[image]

IceLib Technical Reference
PeopleManager Class
Members Example See Also Send Feedback
Provides access to all watched attribute and object classes in the People namespace.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PeopleManager
Visual Basic
Public Class PeopleManager

Remarks

This class serves as the initial entry point into the People namespace. It contains references to all watched object and watched attribute caches. All classes in the People namespace send and receive messages to/from the IC system via the Session object of the PeopleManager.

Note
The PeopleManager class is a singleton object and is accessed using the GetInstance(Session) method.

Examples

CopyC#
Session session = new Session();
session.Connect(...);
PeopleManager peopleManager = PeopleManager.GetInstance(session);

Examples

The IceLib SDK includes example application references to the PeopleManager class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 57, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 144, in StatisticCatalogViewModel.SessionConnectionStateChanged

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..PeopleManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PeopleManager Members
ININ.IceLib.People Namespace


PeopleManager Members

[image] [image]

IceLib Technical Reference
PeopleManager Members
PeopleManager Class Methods Properties See Also Send Feedback

The PeopleManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayName | Gets a properly-formatted display name for a contact.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a PeopleManager.
Public method | GetLookupEntries(LookupParameters) | Looks up simple contact entries.
Public method | GetLookupEntries(IEnumerable<(Of <<'(LookupEntryType>)>>), IEnumerable<(Of <<'(LookupEntryProperty>)>>), LookupComparisonType, String, Int32) | Looks up simple contact entries.
Public method | GetLookupEntriesAsync(LookupParameters, EventHandler<(Of <<'(GetLookupEntriesCompletedEventArgs>)>>), Object) | Asynchoronously looks up simple contact entries.
Public method | GetLookupEntriesAsync(IEnumerable<(Of <<'(LookupEntryType>)>>), IEnumerable<(Of <<'(LookupEntryProperty>)>>), LookupComparisonType, String, Int32, EventHandler<(Of <<'(GetLookupEntriesCompletedEventArgs>)>>), Object) | Asynchoronously looks up simple contact entries.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PeopleId | Gets the unique ID for this object instance.
Public property | Session | Gets the Session with which this PeopleManager is associated.

See Also

PeopleManager Class
ININ.IceLib.People Namespace


PeopleManager Methods

[image] [image]

IceLib Technical Reference
PeopleManager Methods
PeopleManager Class See Also Send Feedback

The PeopleManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayName | Gets a properly-formatted display name for a contact.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a PeopleManager.
Public method | GetLookupEntries(LookupParameters) | Looks up simple contact entries.
Public method | GetLookupEntries(IEnumerable<(Of <<'(LookupEntryType>)>>), IEnumerable<(Of <<'(LookupEntryProperty>)>>), LookupComparisonType, String, Int32) | Looks up simple contact entries.
Public method | GetLookupEntriesAsync(LookupParameters, EventHandler<(Of <<'(GetLookupEntriesCompletedEventArgs>)>>), Object) | Asynchoronously looks up simple contact entries.
Public method | GetLookupEntriesAsync(IEnumerable<(Of <<'(LookupEntryType>)>>), IEnumerable<(Of <<'(LookupEntryProperty>)>>), LookupComparisonType, String, Int32, EventHandler<(Of <<'(GetLookupEntriesCompletedEventArgs>)>>), Object) | Asynchoronously looks up simple contact entries.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PeopleManager Class
ININ.IceLib.People Namespace


GetDisplayName Method

[image]

IceLib Technical Reference
PeopleManager..::..GetDisplayName Method
PeopleManager Class See Also Send Feedback
Gets a properly-formatted display name for a contact.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetDisplayName(
    string firstName,
    string middleName,
    string lastName,
    string userId,
    string stationName,
    string companyName,
    string interactionAddress
)
Visual Basic
Public Function GetDisplayName ( _
    firstName As String, _
    middleName As String, _
    lastName As String, _
    userId As String, _
    stationName As String, _
    companyName As String, _
    interactionAddress As String _
) As String

Parameters

firstName
Type: System..::..String
Can be null. If not null, this parameter is the contact's first name.
middleName
Type: System..::..String
Can be null. If not null this parameter is the contact's middle name.
lastName
Type: System..::..String
Can be null. If not null this parameter is the contact's last name.
userId
Type: System..::..String
Can be null. If not null this parameter is the contact's IC user ID.
stationName
Type: System..::..String
Can be null. If not null this parameter is the contact's IC station name.
companyName
Type: System..::..String
Can be null. If not null this parameter is the contact's company name.
interactionAddress
Type: System..::..String
Can be null. If not null this parameter is the contact's interaction address.

Return Value

The correctly-formatted display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PeopleManager Class
PeopleManager Members
ININ.IceLib.People Namespace


GetInstance Method

[image]

IceLib Technical Reference
PeopleManager..::..GetInstance Method
PeopleManager Class Example See Also Send Feedback
Gets a PeopleManager.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static PeopleManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As PeopleManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The PeopleManager object.

Examples

The IceLib SDK includes example application references to the GetInstance method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 57, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 144, in StatisticCatalogViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PeopleManager Class
PeopleManager Members
ININ.IceLib.People Namespace


GetLookupEntries Method

[image] [image]

IceLib Technical Reference
PeopleManager..::..GetLookupEntries Method
PeopleManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLookupEntries(LookupParameters) | Looks up simple contact entries.
Public method | GetLookupEntries(IEnumerable<(Of <<'(LookupEntryType>)>>), IEnumerable<(Of <<'(LookupEntryProperty>)>>), LookupComparisonType, String, Int32) | Looks up simple contact entries.

See Also

PeopleManager Class
PeopleManager Members
ININ.IceLib.People Namespace


GetLookupEntries Method (LookupParameters)

[image]

IceLib Technical Reference
PeopleManager..::..GetLookupEntries Method (LookupParameters)
PeopleManager Class See Also Send Feedback
Looks up simple contact entries.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupEntriesDetails GetLookupEntries(
    LookupParameters queryParameters
)
Visual Basic
Public Function GetLookupEntries ( _
    queryParameters As LookupParameters _
) As LookupEntriesDetails

Parameters

queryParameters
Type: ININ.IceLib.People..::..LookupParameters
The search criteria.

Return Value

A collection of LookupEntry objects.

Remarks

The logged in user must have the appropriate search rights configured in Interaction Administrator for results to be included. These search rights can be found in the Access Control container under the Search column.

When specifying AttendantProfile, attendant profiles can only be included in the lookup results if the logged in user has the sufficient search rights assigned. From within Interaction Administrator, the logged in user must have the search rights for the appropriate Email/Inbound/Operator/Outbound profiles set in the Access Control container. Additionally, the attendant profile must also be setup to be a transfer target from within Interaction Attendant.

Examples

This can be used to search for contacts for operations such as transfering an Interaction.
CopyC#
using ININ.IceLib.People;
PeopleManager peopleManager = PeopleManager.GetInstance(session);
LookupParameters queryParameters = new LookupParameters();
queryParameters.DirectoriesToSearch = new List<LookupEntryType> {LookupEntryType.User};
queryParameters.ColumnsToMatch = new List<LookupEntryProperty> {LookupEntryProperty.DisplayName, LookupEntryProperty.EntryId};
queryParameters.LookupString = "John";
queryParameters.ComparisonType = LookupComparisonType.StartsWith;
queryParameters.MaxEntries = 50;
queryParameters.IncludeUsersExcludedFromCompanyDirectory = true;

LookupEntriesDetails entries = peopleManager.GetLookupEntries(queryParameters);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PeopleManager Class
PeopleManager Members
GetLookupEntries Overload
ININ.IceLib.People Namespace


GetLookupEntries Method (IEnumerable(LookupEntryType), IEnumerable(LookupEntryProperty), LookupComparisonType, String, Int32)

[image]

IceLib Technical Reference
PeopleManager..::..GetLookupEntries Method (IEnumerable<(Of <(<'LookupEntryType>)>)>, IEnumerable<(Of <(<'LookupEntryProperty>)>)>, LookupComparisonType, String, Int32)
PeopleManager Class See Also Send Feedback
Looks up simple contact entries.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LookupEntriesDetails GetLookupEntries(
    IEnumerable<LookupEntryType> directoriesToSearch,
    IEnumerable<LookupEntryProperty> columnsToMatch,
    LookupComparisonType comparisonType,
    string lookupString,
    int maxEntries
)
Visual Basic
Public Function GetLookupEntries ( _
    directoriesToSearch As IEnumerable(Of LookupEntryType), _
    columnsToMatch As IEnumerable(Of LookupEntryProperty), _
    comparisonType As LookupComparisonType, _
    lookupString As String, _
    maxEntries As Integer _
) As LookupEntriesDetails

Parameters

directoriesToSearch
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' LookupEntryType >)>)>
The directories to search.
columnsToMatch
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' LookupEntryProperty >)>)>
The columns to match with the lookupString, using the specified comparisonType.
comparisonType
Type: ININ.IceLib.People..::..LookupComparisonType
The comparison type.
lookupString
Type: System..::..String
The lookup string that the server needs to match.
maxEntries
Type: System..::..Int32
The maximum number of lookup entries that the application would like to receive.

Return Value

A collection of LookupEntry objects.

Remarks

The logged in user must have the appropriate search rights configured in Interaction Administrator for results to be included. These search rights can be found in the Access Control container under the Search column.

When specifying AttendantProfile, attendant profiles can only be included in the lookup results if the logged in user has the sufficient search rights assigned. From within Interaction Administrator, the logged in user must have the search rights for the appropriate Email/Inbound/Operator/Outbound profiles set in the Access Control container. Additionally, the attendant profile must also be setup to be a transfer target from within Interaction Attendant.

Examples

This can be used to search for contacts for operations such as transfering an Interaction.
CopyC#
using ININ.IceLib.People;
PeopleManager peopleManager = PeopleManager.GetInstance(session);

LookupEntryType[] directoriesToSearch = {LookupEntryType.User};
LookupEntryProperty[] columnsToMatch = {LookupEntryProperty.DisplayName,
                                        LookupEntryProperty.EntryId};
string lookupString = "John";

LookupEntriesDetails entries = peopleManager.GetLookupEntries(directoriesToSearch,
                                                              columnsToMatch,
                                                              LookupComparisonType.StartsWith,
                                                              lookupString, 50);

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

PeopleManager Class
PeopleManager Members
GetLookupEntries Overload
ININ.IceLib.People Namespace


GetLookupEntriesAsync Method

[image] [image]

IceLib Technical Reference
PeopleManager..::..GetLookupEntriesAsync Method
PeopleManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLookupEntriesAsync(LookupParameters, EventHandler<(Of <<'(GetLookupEntriesCompletedEventArgs>)>>), Object) | Asynchoronously looks up simple contact entries.
Public method | GetLookupEntriesAsync(IEnumerable<(Of <<'(LookupEntryType>)>>), IEnumerable<(Of <<'(LookupEntryProperty>)>>), LookupComparisonType, String, Int32, EventHandler<(Of <<'(GetLookupEntriesCompletedEventArgs>)>>), Object) | Asynchoronously looks up simple contact entries.

See Also

PeopleManager Class
PeopleManager Members
ININ.IceLib.People Namespace


GetLookupEntriesAsync Method (LookupParameters, EventHandler(GetLookupEntriesCompletedEventArgs), Object)

[image]

IceLib Technical Reference
PeopleManager..::..GetLookupEntriesAsync Method (LookupParameters, EventHandler<(Of <(<'GetLookupEntriesCompletedEventArgs>)>)>, Object)
PeopleManager Class See Also Send Feedback
Asynchoronously looks up simple contact entries.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetLookupEntriesAsync(
    LookupParameters queryParameters,
    EventHandler<GetLookupEntriesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetLookupEntriesAsync ( _
    queryParameters As LookupParameters, _
    completedCallback As EventHandler(Of GetLookupEntriesCompletedEventArgs), _
    userState As Object _
)

Parameters

queryParameters
Type: ININ.IceLib.People..::..LookupParameters
The search criteria.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetLookupEntriesCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This can be used to search for contacts for operations such as transfering an Interaction.

Examples

The logged in user must have the appropriate search rights configured in Interaction Administrator for results to be included. These search rights can be found in the Access Control container under the Search column.

When specifying AttendantProfile, attendant profiles can only be included in the lookup results if the logged in user has the sufficient search rights assigned. From within Interaction Administrator, the logged in user must have the search rights for the appropriate Email/Inbound/Operator/Outbound profiles set in the Access Control container. Additionally, the attendant profile must also be setup to be a transfer target from within Interaction Attendant.

CopyC#
using ININ.IceLib.People;
PeopleManager peopleManager = PeopleManager.GetInstance(session);

LookupParameters queryParameters = new LookupParameters();
queryParameters.DirectoriesToSearch = new List<LookupEntryType> {LookupEntryType.User};
queryParameters.ColumnsToMatch = new List<LookupEntryProperty> {LookupEntryProperty.DisplayName, LookupEntryProperty.EntryId};
queryParameters.LookupString = "John";
queryParameters.ComparisonType = LookupComparisonType.StartsWith;
queryParameters.MaxEntries = 50;
queryParameters.IncludeUsersExcludedFromCompanyDirectory = true;

peopleManager.GetLookupEntriesAsync(queryParameters, LookupCompletedCallback, GetNextSequenceNumber());

private void LookupCompletedCallback(object sender, GetLookupEntriesCompletedEventArgs eventArgs)
{
    if (eventArgs.Error != null )// failed. handle the failure.
    {
    }
    else
    {
        int sequenceNumber = eventArgs.UserState as int;
        if ( sequenceNumber != GetCurrentSequenceNumber() ) // another call to GetLookupEntriesAsync happened by the time our function completed. Maybe we could ignore this old result.
        {
            return;
        }

        LookupEntriesDetails result = eventArgs.LookupEntriesDetails;
        // handle the result
    }
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

PeopleManager Class
PeopleManager Members
GetLookupEntriesAsync Overload
ININ.IceLib.People Namespace


GetLookupEntriesAsync Method (IEnumerable(LookupEntryType), IEnumerable(LookupEntryProperty), LookupComparisonType, String, Int32, EventHandler(GetLookupEntriesCompletedEventArgs), Object)

[image]

IceLib Technical Reference
PeopleManager..::..GetLookupEntriesAsync Method (IEnumerable<(Of <(<'LookupEntryType>)>)>, IEnumerable<(Of <(<'LookupEntryProperty>)>)>, LookupComparisonType, String, Int32, EventHandler<(Of <(<'GetLookupEntriesCompletedEventArgs>)>)>, Object)
PeopleManager Class See Also Send Feedback
Asynchoronously looks up simple contact entries.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetLookupEntriesAsync(
    IEnumerable<LookupEntryType> directoriesToSearch,
    IEnumerable<LookupEntryProperty> columnsToMatch,
    LookupComparisonType comparisonType,
    string lookupString,
    int maxEntries,
    EventHandler<GetLookupEntriesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetLookupEntriesAsync ( _
    directoriesToSearch As IEnumerable(Of LookupEntryType), _
    columnsToMatch As IEnumerable(Of LookupEntryProperty), _
    comparisonType As LookupComparisonType, _
    lookupString As String, _
    maxEntries As Integer, _
    completedCallback As EventHandler(Of GetLookupEntriesCompletedEventArgs), _
    userState As Object _
)

Parameters

directoriesToSearch
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' LookupEntryType >)>)>
The directories to search.
columnsToMatch
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' LookupEntryProperty >)>)>
The columns to match with the lookupString, using the specified comparisonType.
comparisonType
Type: ININ.IceLib.People..::..LookupComparisonType
The comparison type.
lookupString
Type: System..::..String
The lookup string that the server needs to match.
maxEntries
Type: System..::..Int32
The maximum number of lookup entries that the application would like to receive.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetLookupEntriesCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

The logged in user must have the appropriate search rights configured in Interaction Administrator for results to be included. These search rights can be found in the Access Control container under the Search column.

When specifying AttendantProfile, attendant profiles can only be included in the lookup results if the logged in user has the sufficient search rights assigned. From within Interaction Administrator, the logged in user must have the search rights for the appropriate Email/Inbound/Operator/Outbound profiles set in the Access Control container. Additionally, the attendant profile must also be setup to be a transfer target from within Interaction Attendant.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This can be used to search for contacts for operations such as transfering an Interaction.

Examples

CopyC#
using ININ.IceLib.People;
PeopleManager peopleManager = PeopleManager.GetInstance(session);

LookupEntryType[] directoriesToSearch = {LookupEntryType.User};
LookupEntryProperty[] columnsToMatch = {LookupEntryProperty.DisplayName,
                                        LookupEntryProperty.Extension};
string lookupString = "John";

peopleManager.GetLookupEntriesAsync(directoriesToSearch, columnsToMatch, LookupComparisonType.StartsWith, lookupString, 50, LookupCompletedCallback, GetNextSequenceNumber());

private void LookupCompletedCallback(object sender, GetLookupEntriesCompletedEventArgs eventArgs)
{
    if (eventArgs.Error != null )// failed. handle the failure.
    {
    }
    else
    {
        int sequenceNumber = eventArgs.UserState as int;
        if ( sequenceNumber != GetCurrentSequenceNumber() ) // another call to GetLookupEntriesAsync happened by the time our function completed. Ignore this old result (maybe).
        {
            return;
        }

        LookupEntriesDetails result = eventArgs.LookupEntriesDetails;
        // handle the result
    }
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

PeopleManager Class
PeopleManager Members
GetLookupEntriesAsync Overload
ININ.IceLib.People Namespace


PeopleManager Properties

[image] [image]

IceLib Technical Reference
PeopleManager Properties
PeopleManager Class See Also Send Feedback

The PeopleManager type exposes the following members.

Properties

 | Name | Description
Public property | PeopleId | Gets the unique ID for this object instance.
Public property | Session | Gets the Session with which this PeopleManager is associated.

See Also

PeopleManager Class
ININ.IceLib.People Namespace


PeopleId Property

[image]

IceLib Technical Reference
PeopleManager..::..PeopleId Property
PeopleManager Class See Also Send Feedback
Gets the unique ID for this object instance.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long PeopleId { get; }
Visual Basic
Public ReadOnly Property PeopleId As Long
    Get

Field Value

The people ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PeopleManager Class
PeopleManager Members
ININ.IceLib.People Namespace


Session Property

[image]

IceLib Technical Reference
PeopleManager..::..Session Property
PeopleManager Class See Also Send Feedback
Gets the Session with which this PeopleManager is associated.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PeopleManager Class
PeopleManager Members
ININ.IceLib.People Namespace


PerformLicenseOperationCompletedEventArgs Class

[image]

IceLib Technical Reference
PerformLicenseOperationCompletedEventArgs Class
Members See Also Send Feedback
Arguments returned by the asynchronous perform license operation request.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PerformLicenseOperationCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class PerformLicenseOperationCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.People..::..PerformLicenseOperationCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationCompletedEventArgs Members
ININ.IceLib.People Namespace


PerformLicenseOperationCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
PerformLicenseOperationCompletedEventArgs Members
PerformLicenseOperationCompletedEventArgs Class Methods Properties See Also Send Feedback

The PerformLicenseOperationCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PerformLicenseOperationResults | Collection of objects indicating the result of each license operation.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

PerformLicenseOperationCompletedEventArgs Class
ININ.IceLib.People Namespace


PerformLicenseOperationCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
PerformLicenseOperationCompletedEventArgs Methods
PerformLicenseOperationCompletedEventArgs Class See Also Send Feedback

The PerformLicenseOperationCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformLicenseOperationCompletedEventArgs Class
ININ.IceLib.People Namespace


PerformLicenseOperationCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
PerformLicenseOperationCompletedEventArgs Properties
PerformLicenseOperationCompletedEventArgs Class See Also Send Feedback

The PerformLicenseOperationCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | PerformLicenseOperationResults | Collection of objects indicating the result of each license operation.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

PerformLicenseOperationCompletedEventArgs Class
ININ.IceLib.People Namespace


PerformLicenseOperationResults Property

[image]

IceLib Technical Reference
PerformLicenseOperationCompletedEventArgs..::..PerformLicenseOperationResults Property
PerformLicenseOperationCompletedEventArgs Class See Also Send Feedback
Collection of objects indicating the result of each license operation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<PerformLicenseOperationResult> PerformLicenseOperationResults { get; }
Visual Basic
Public ReadOnly Property PerformLicenseOperationResults As ReadOnlyCollection(Of PerformLicenseOperationResult)
    Get

Field Value

The license operation results.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationCompletedEventArgs Class
PerformLicenseOperationCompletedEventArgs Members
ININ.IceLib.People Namespace


PerformLicenseOperationResult Class

[image]

IceLib Technical Reference
PerformLicenseOperationResult Class
Members See Also Send Feedback
Contains information regarding a license operation result from a call to PerformLicenseOperation(IList<(Of <<'(LicenseRequest>)>>)) or PerformLicenseOperationAsync(IList<(Of <<'(LicenseRequest>)>>), EventHandler<(Of <<'(PerformLicenseOperationCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class PerformLicenseOperationResult
Visual Basic
Public Class PerformLicenseOperationResult

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..PerformLicenseOperationResult

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationResult Members
ININ.IceLib.People Namespace


PerformLicenseOperationResult Members

[image] [image]

IceLib Technical Reference
PerformLicenseOperationResult Members
PerformLicenseOperationResult Class Methods Properties See Also Send Feedback

The PerformLicenseOperationResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorDetails | Gets the license error details.
Public property | IsAvailable | Gets a value indicating whether the license is available.
Public property | LicenseName | Gets the name of the license.
Public property | LicenseStatus | Gets the license status.

See Also

PerformLicenseOperationResult Class
ININ.IceLib.People Namespace


PerformLicenseOperationResult Methods

[image] [image]

IceLib Technical Reference
PerformLicenseOperationResult Methods
PerformLicenseOperationResult Class See Also Send Feedback

The PerformLicenseOperationResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformLicenseOperationResult Class
ININ.IceLib.People Namespace


PerformLicenseOperationResult Properties

[image] [image]

IceLib Technical Reference
PerformLicenseOperationResult Properties
PerformLicenseOperationResult Class See Also Send Feedback

The PerformLicenseOperationResult type exposes the following members.

Properties

 | Name | Description
Public property | ErrorDetails | Gets the license error details.
Public property | IsAvailable | Gets a value indicating whether the license is available.
Public property | LicenseName | Gets the name of the license.
Public property | LicenseStatus | Gets the license status.

See Also

PerformLicenseOperationResult Class
ININ.IceLib.People Namespace


ErrorDetails Property

[image]

IceLib Technical Reference
PerformLicenseOperationResult..::..ErrorDetails Property
PerformLicenseOperationResult Class See Also Send Feedback
Gets the license error details.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ErrorDetails { get; private set; }
Visual Basic
Public Property ErrorDetails As String
    Get
    Private Set

Field Value

The license error details.

Remarks

This is set when LicenseStatus is not None or Available.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationResult Class
PerformLicenseOperationResult Members
ININ.IceLib.People Namespace


IsAvailable Property

[image]

IceLib Technical Reference
PerformLicenseOperationResult..::..IsAvailable Property
PerformLicenseOperationResult Class See Also Send Feedback
Gets a value indicating whether the license is available.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsAvailable { get; private set; }
Visual Basic
Public Property IsAvailable As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if the license is available; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationResult Class
PerformLicenseOperationResult Members
ININ.IceLib.People Namespace


LicenseName Property

[image]

IceLib Technical Reference
PerformLicenseOperationResult..::..LicenseName Property
PerformLicenseOperationResult Class See Also Send Feedback
Gets the name of the license.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LicenseName { get; private set; }
Visual Basic
Public Property LicenseName As String
    Get
    Private Set

Field Value

The name of the license.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationResult Class
PerformLicenseOperationResult Members
ININ.IceLib.People Namespace


LicenseStatus Property

[image]

IceLib Technical Reference
PerformLicenseOperationResult..::..LicenseStatus Property
PerformLicenseOperationResult Class See Also Send Feedback
Gets the license status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LicenseStatusType LicenseStatus { get; private set; }
Visual Basic
Public Property LicenseStatus As LicenseStatusType
    Get
    Private Set

Field Value

The license status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

PerformLicenseOperationResult Class
PerformLicenseOperationResult Members
ININ.IceLib.People Namespace


StatusMessageChangedEventArgs Class

[image]

IceLib Technical Reference
StatusMessageChangedEventArgs Class
Members See Also Send Feedback
Provides data for the filtered status message list changed event for status message attributes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusMessageChangedEventArgs : EventArgs
Visual Basic
Public Class StatusMessageChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People..::..StatusMessageChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatusMessageChangedEventArgs Members
ININ.IceLib.People Namespace
FilteredStatusMessageList..::..WatchedStatusMessageObjectsChanged


StatusMessageChangedEventArgs Members

[image] [image]

IceLib Technical Reference
StatusMessageChangedEventArgs Members
StatusMessageChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The StatusMessageChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | StatusMessageChangedEventArgs | Constructs an object of type StatusMessageChangedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changed | Contains a collection of status message properties that have changed for a given status message.

See Also

StatusMessageChangedEventArgs Class
ININ.IceLib.People Namespace


StatusMessageChangedEventArgs Constructor

[image]

IceLib Technical Reference
StatusMessageChangedEventArgs Constructor
StatusMessageChangedEventArgs Class See Also Send Feedback
Constructs an object of type StatusMessageChangedEventArgs.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageChangedEventArgs(
    IDictionary<string, ReadOnlyCollection<StatusMessageProperty>> changed
)
Visual Basic
Public Sub New ( _
    changed As IDictionary(Of String, ReadOnlyCollection(Of StatusMessageProperty)) _
)

Parameters

changed
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, ReadOnlyCollection<(Of <(<' StatusMessageProperty >)>)>>)>)>
The status messages that have had attributes changed.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatusMessageChangedEventArgs Class
StatusMessageChangedEventArgs Members
ININ.IceLib.People Namespace


StatusMessageChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
StatusMessageChangedEventArgs Methods
StatusMessageChangedEventArgs Class See Also Send Feedback

The StatusMessageChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusMessageChangedEventArgs Class
ININ.IceLib.People Namespace


StatusMessageChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
StatusMessageChangedEventArgs Properties
StatusMessageChangedEventArgs Class See Also Send Feedback

The StatusMessageChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Contains a collection of status message properties that have changed for a given status message.

See Also

StatusMessageChangedEventArgs Class
ININ.IceLib.People Namespace


Changed Property

[image]

IceLib Technical Reference
StatusMessageChangedEventArgs..::..Changed Property
StatusMessageChangedEventArgs Class See Also Send Feedback
Contains a collection of status message properties that have changed for a given status message.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ReadOnlyCollection<StatusMessageProperty>> Changed { get; set; }
Visual Basic
Public Property Changed As IDictionary(Of String, ReadOnlyCollection(Of StatusMessageProperty))
    Get
    Set

Field Value

The changed status messages.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatusMessageChangedEventArgs Class
StatusMessageChangedEventArgs Members
ININ.IceLib.People Namespace


StatusMessageDetails Class

[image]

IceLib Technical Reference
StatusMessageDetails Class
Members See Also Send Feedback
Represents the details for a status message watched object. Object instances of this class are managed by the StatusMessageList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusMessageDetails
Visual Basic
Public Class StatusMessageDetails

Remarks

This class contains information about a status message, such as its description, icon, and type of status (Do Not Disturb, After Call Work, Persistent, etc). Users can add, remove, and modify status messages in Interaction Administrator. Each property is represented by an integer value within the StatusMessageProperty enumeration.

Note
The IC server only provides the file name on the server of the status message icons. In order to access these icons, they must be installed in the "Resources" subdirectory of the directory where your application executable resides. If the appropriate icon cannot be found, the icon will be substituted with the stock "Available" icon, unless the status is a "Do Not Disturb" status in which case the stock "Do Not Disturb" icon will be used.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..StatusMessageDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Members
ININ.IceLib.People Namespace


StatusMessageDetails Members

[image] [image]

IceLib Technical Reference
StatusMessageDetails Members
StatusMessageDetails Class Methods Operators Properties See Also Send Feedback

The StatusMessageDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatusMessageDetails) | Determines whether the specified StatusMessageDetails is equal to the current StatusMessageDetails.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of StatusMessageDetails are equal.
Inequality | Determines whether two instances of StatusMessageDetails are not equal.

Properties

 | Name | Description
Public property | CanHaveDate | Gets a value indicating whether this status can have an ending date.
Public property | CanHaveTime | Gets a value indicating whether this status can have an ending time.
 | DefaultAvailableIcon | Gets the default icon associated with any valid Available status.
 | DefaultUnavailableIcon | Gets the default icon associated with any invalid or Unavailable status.
Public property | GroupTag | Gets the group this status belongs to for reporting.
Public property | Icon | Gets the icon associated with this status message.
Public property | IconFileName | Gets the path to an icon file used to display for this status.
Public property | Id | Gets the unique internal identifier for this status. See MessageText for display usages.
Public property | IsAcdStatus | Gets a value indicating whether this status allows ACD calls.
Public property | IsAfterCallWorkStatus | Gets a value indicating whether this status requires after call work (ACW).
Public property | IsAllowFollowUpStatus | Gets a value indicating whether this status allows follow up.
Public property | IsDoNotDisturbStatus | Gets a value indicating whether this instance is a do not disturb status.
Public property | IsFollowMeStatus | Gets a value indicating whether this status is a "follow me" status.
Public property | IsForwardStatus | Gets a value indicating whether this instance is a forward status.
Public property | IsPersistentStatus | Gets a value indicating whether the status can persist when the agent logs out of IC.
Public property | IsSelectableStatus | Gets a value indicating whether this status is selectable by an agent.
Public property | IsValid | Gets whether this status message is valid.
Public property | MessageText | Gets the localized message text when displaying this status.
Public property | SystemId | Gets an unique numeric identifier for this status message.

See Also

StatusMessageDetails Class
ININ.IceLib.People Namespace


StatusMessageDetails Methods

[image] [image]

IceLib Technical Reference
StatusMessageDetails Methods
StatusMessageDetails Class See Also Send Feedback

The StatusMessageDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatusMessageDetails) | Determines whether the specified StatusMessageDetails is equal to the current StatusMessageDetails.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusMessageDetails Class
ININ.IceLib.People Namespace


Equals Method

[image] [image]

IceLib Technical Reference
StatusMessageDetails..::..Equals Method
StatusMessageDetails Class See Also Send Feedback
Determines whether two StatusMessageDetails instances are equal.

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatusMessageDetails) | Determines whether the specified StatusMessageDetails is equal to the current StatusMessageDetails.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
StatusMessageDetails..::..Equals Method (Object)
StatusMessageDetails Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
Equals Overload
ININ.IceLib.People Namespace


Equals Method (StatusMessageDetails)

[image]

IceLib Technical Reference
StatusMessageDetails..::..Equals Method (StatusMessageDetails)
StatusMessageDetails Class See Also Send Feedback
Determines whether the specified StatusMessageDetails is equal to the current StatusMessageDetails.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    StatusMessageDetails other
)
Visual Basic
Public Function Equals ( _
    other As StatusMessageDetails _
) As Boolean

Parameters

other
Type: ININ.IceLib.People..::..StatusMessageDetails
The StatusMessageDetails to compare with the current StatusMessageDetails.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified StatusMessageDetails is equal to the current StatusMessageDetails; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
Equals Overload
ININ.IceLib.People Namespace


GetHashCode Method

[image]

IceLib Technical Reference
StatusMessageDetails..::..GetHashCode Method
StatusMessageDetails Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


StatusMessageDetails Operators

[image] [image]

IceLib Technical Reference
StatusMessageDetails Operators
StatusMessageDetails Class See Also Send Feedback

The StatusMessageDetails type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of StatusMessageDetails are equal.
Inequality | Determines whether two instances of StatusMessageDetails are not equal.

See Also

StatusMessageDetails Class
ININ.IceLib.People Namespace


Equality Operator

[image]

IceLib Technical Reference
StatusMessageDetails..::..Equality Operator
StatusMessageDetails Class See Also Send Feedback
Determines whether two instances of StatusMessageDetails are equal.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    StatusMessageDetails a,
    StatusMessageDetails b
)
Visual Basic
Public Shared Operator = ( _
    a As StatusMessageDetails, _
    b As StatusMessageDetails _
) As Boolean

Parameters

a
Type: ININ.IceLib.People..::..StatusMessageDetails
The first StatusMessageDetails to compare.
b
Type: ININ.IceLib.People..::..StatusMessageDetails
The second StatusMessageDetails to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


Inequality Operator

[image]

IceLib Technical Reference
StatusMessageDetails..::..Inequality Operator
StatusMessageDetails Class See Also Send Feedback
Determines whether two instances of StatusMessageDetails are not equal.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    StatusMessageDetails a,
    StatusMessageDetails b
)
Visual Basic
Public Shared Operator <> ( _
    a As StatusMessageDetails, _
    b As StatusMessageDetails _
) As Boolean

Parameters

a
Type: ININ.IceLib.People..::..StatusMessageDetails
The first StatusMessageDetails to compare.
b
Type: ININ.IceLib.People..::..StatusMessageDetails
The second StatusMessageDetails to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


StatusMessageDetails Properties

[image] [image]

IceLib Technical Reference
StatusMessageDetails Properties
StatusMessageDetails Class See Also Send Feedback

The StatusMessageDetails type exposes the following members.

Properties

 | Name | Description
Public property | CanHaveDate | Gets a value indicating whether this status can have an ending date.
Public property | CanHaveTime | Gets a value indicating whether this status can have an ending time.
 | DefaultAvailableIcon | Gets the default icon associated with any valid Available status.
 | DefaultUnavailableIcon | Gets the default icon associated with any invalid or Unavailable status.
Public property | GroupTag | Gets the group this status belongs to for reporting.
Public property | Icon | Gets the icon associated with this status message.
Public property | IconFileName | Gets the path to an icon file used to display for this status.
Public property | Id | Gets the unique internal identifier for this status. See MessageText for display usages.
Public property | IsAcdStatus | Gets a value indicating whether this status allows ACD calls.
Public property | IsAfterCallWorkStatus | Gets a value indicating whether this status requires after call work (ACW).
Public property | IsAllowFollowUpStatus | Gets a value indicating whether this status allows follow up.
Public property | IsDoNotDisturbStatus | Gets a value indicating whether this instance is a do not disturb status.
Public property | IsFollowMeStatus | Gets a value indicating whether this status is a "follow me" status.
Public property | IsForwardStatus | Gets a value indicating whether this instance is a forward status.
Public property | IsPersistentStatus | Gets a value indicating whether the status can persist when the agent logs out of IC.
Public property | IsSelectableStatus | Gets a value indicating whether this status is selectable by an agent.
Public property | IsValid | Gets whether this status message is valid.
Public property | MessageText | Gets the localized message text when displaying this status.
Public property | SystemId | Gets an unique numeric identifier for this status message.

See Also

StatusMessageDetails Class
ININ.IceLib.People Namespace


CanHaveDate Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..CanHaveDate Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status can have an ending date.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanHaveDate { get; }
Visual Basic
Public ReadOnly Property CanHaveDate As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this status can have an ending date; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


CanHaveTime Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..CanHaveTime Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status can have an ending time.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanHaveTime { get; }
Visual Basic
Public ReadOnly Property CanHaveTime As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this status can have an ending time; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


DefaultAvailableIcon Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..DefaultAvailableIcon Property
StatusMessageDetails Class See Also Send Feedback
Gets the default icon associated with any valid Available status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static Icon DefaultAvailableIcon { get; }
Visual Basic
Public Shared ReadOnly Property DefaultAvailableIcon As Icon
    Get

Field Value

The icon.

Remarks

A status is considered Available if IsDoNotDisturbStatus is falseFalsefalsefalse (False in Visual Basic). If an instance of StatusMessageDetails is an Available status, and the configured icon cannot be loaded, then Icon will be this icon by default.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


DefaultUnavailableIcon Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..DefaultUnavailableIcon Property
StatusMessageDetails Class See Also Send Feedback
Gets the default icon associated with any invalid or Unavailable status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static Icon DefaultUnavailableIcon { get; }
Visual Basic
Public Shared ReadOnly Property DefaultUnavailableIcon As Icon
    Get

Field Value

The icon.

Remarks

A status is considered Unavailable if IsDoNotDisturbStatus is trueTruetruetrue (True in Visual Basic). If an instance of StatusMessageDetails is an Unavailable status, and the configured icon cannot be loaded, then Icon will be this icon by default.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


GroupTag Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..GroupTag Property
StatusMessageDetails Class See Also Send Feedback
Gets the group this status belongs to for reporting.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GroupTag { get; }
Visual Basic
Public ReadOnly Property GroupTag As String
    Get

Field Value

The group tag assigned to this status.

Remarks

A Status Group is a name that loosely categorizes a status message for reporting purposes. When a new status is defined in Interaction Administrator using the System Configuration > Status Messages container, it is mapped to a Status Group for reporting purposes.

For example, statuses such as "Gone Home", "On Vacation", and "Out of the office" are mapped to the UNAVAILABLE group, while "Available" and "Available, No ACD" are mapped to AVAILABLE. The default status groups are AVAILABLE, BREAK, FOLLOWUP, TRAINING, and UNAVAILABLE. Additional groups can be user-defined.

In general, status messages indicate the details of agent activity and add granularity to reporting. Conversely, status groups roll up related status conditions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


Icon Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..Icon Property
StatusMessageDetails Class See Also Send Feedback
Gets the icon associated with this status message.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Icon Icon { get; }
Visual Basic
Public ReadOnly Property Icon As Icon
    Get

Field Value

The icon.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IconFileName Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IconFileName Property
StatusMessageDetails Class See Also Send Feedback
Gets the path to an icon file used to display for this status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IconFileName { get; }
Visual Basic
Public ReadOnly Property IconFileName As String
    Get

Field Value

The name of the icon file.

Remarks

Note
The IC server only provides the file name on the server of the status message icons. In order to access these icons, they must be installed in the "Resources" subdirectory of the directory where your application executable resides. If the appropriate icon cannot be found, the icon will be substituted with the stock "Available" icon, unless the status is a "Do Not Disturb" status in which case the stock "Do Not Disturb" icon will be used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


Id Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..Id Property
StatusMessageDetails Class See Also Send Feedback
Gets the unique internal identifier for this status. See MessageText for display usages.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID. e.g.: "AcdAgentNotAnswering".

Remarks

This internal name for the status is not localized. It is the "Message Name" created when the status was defined in Interaction Administrator. The MessageText on the other hand, is the localized string that is displayed in Interaction Client. For example, the ID "AcdAgentNotAnswering", corresponds to MessageText "ACD - Agent Not Answering". The key difference is that status MessageTexts are localized, and status IDs are not.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsAcdStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsAcdStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status allows ACD calls.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsAcdStatus { get; }
Visual Basic
Public ReadOnly Property IsAcdStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is an ACD status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Indicates an agent is available to receive ACD calls.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsAfterCallWorkStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsAfterCallWorkStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status requires after call work (ACW).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsAfterCallWorkStatus { get; }
Visual Basic
Public ReadOnly Property IsAfterCallWorkStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is an after call work status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Indicates that an agent is in "Follow Up" mode (IsAllowFollowUpStatus) after an ACD call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsAllowFollowUpStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsAllowFollowUpStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status allows follow up.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsAllowFollowUpStatus { get; }
Visual Basic
Public ReadOnly Property IsAllowFollowUpStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is an allow follow up status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Indicates that an agent's status can change to "Follow Up" after an ACD call terminates.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsDoNotDisturbStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsDoNotDisturbStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this instance is a do not disturb status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsDoNotDisturbStatus { get; }
Visual Basic
Public ReadOnly Property IsDoNotDisturbStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is a do not disturb status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

When a user has this status, they do not wish to be disturbed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsFollowMeStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsFollowMeStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status is a "follow me" status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsFollowMeStatus { get; }
Visual Basic
Public ReadOnly Property IsFollowMeStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is a "follow me" status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Indicates that an agent's status is a "follow me" status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsForwardStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsForwardStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this instance is a forward status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsForwardStatus { get; }
Visual Basic
Public ReadOnly Property IsForwardStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is forward status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

When a user has this status, they are available at a different phone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsPersistentStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsPersistentStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether the status can persist when the agent logs out of IC.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPersistentStatus { get; }
Visual Basic
Public ReadOnly Property IsPersistentStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is a persistent status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsSelectableStatus Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsSelectableStatus Property
StatusMessageDetails Class See Also Send Feedback
Gets a value indicating whether this status is selectable by an agent.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsSelectableStatus { get; }
Visual Basic
Public ReadOnly Property IsSelectableStatus As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is a selectable status; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


IsValid Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..IsValid Property
StatusMessageDetails Class See Also Send Feedback
Gets whether this status message is valid.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This only gets set to falseFalsefalsefalse (False in Visual Basic) as a result of calls to the indexer on StatusMessageList.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


MessageText Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..MessageText Property
StatusMessageDetails Class See Also Send Feedback
Gets the localized message text when displaying this status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageText { get; }
Visual Basic
Public ReadOnly Property MessageText As String
    Get

Field Value

The message text. e.g.: "ACD - Agent Not Answering".

Remarks

This is the text that appears in Interaction Client's list of selectable statuses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


SystemId Property

[image]

IceLib Technical Reference
StatusMessageDetails..::..SystemId Property
StatusMessageDetails Class See Also Send Feedback
Gets an unique numeric identifier for this status message.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SystemId { get; }
Visual Basic
Public ReadOnly Property SystemId As Integer
    Get

Field Value

The system ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageDetails Class
StatusMessageDetails Members
ININ.IceLib.People Namespace


StatusMessageList Class

[image]

IceLib Technical Reference
StatusMessageList Class
Members See Also Send Feedback
Represents a watched list of status messages. Use StatusMessageDetails to get the details of a status message watched object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatusMessageList
Visual Basic
Public Class StatusMessageList

Remarks

The list of status messages can be modified in Interaction Administrator. To start watching the list of status messages, call the StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object) methods. The completedCallback delegate is invoked when the asynchronous start watch operation completes. To stop watching, call the StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods. The completedCallback delegate is invoked when the asynchronous stop watch operation completes.

Once a watch is in place any changes to the status message list trigger the WatchedObjectsChanged event. You can access the list of status messages by calling GetList()()()(). Calling GetList()()()() if a watch is not in progress raises the InvalidOperationException. Calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is already in place, or calling StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is not in place also raises the InvalidOperationException.

Note
The asynchronous methods are preferred since the start, change, and stop watch can be lengthy operations.

There are two classes in IceLib for watching status messages. The StatusMessageList class allows you to watch the list of all status messages defined in IC that the session user has the rights to view. The FilteredStatusMessageList class allows you to watch the status messages that are available for a particular IC user. The list of available status messages for a user can vary based on workgroup membership, role, and user settings in Interaction Administrator.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..StatusMessageList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Members
ININ.IceLib.People Namespace


StatusMessageList Members

[image] [image]

IceLib Technical Reference
StatusMessageList Members
StatusMessageList Class Constructors Methods Properties Events See Also Send Feedback

The StatusMessageList type exposes the following members.

Constructors

 | Name | Description
Public method | StatusMessageList | Initializes a new instance of the StatusMessageList class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of the defined status messages.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidStatus | Determines whether a given status is defined.
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the Status Message List.
Public method | StartWatchingAsync | Asynchronously starts watching the Status Message List.
Public method | StopWatching | Stops watching the Status Message List.
Public method | StopWatchingAsync | Asynchronously stops watching the Status Message List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get an individual status message definition by its unique name.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the StatusMessageDetails watched objects has changed.

See Also

StatusMessageList Class
ININ.IceLib.People Namespace


StatusMessageList Constructor

[image]

IceLib Technical Reference
StatusMessageList Constructor
StatusMessageList Class See Also Send Feedback
Initializes a new instance of the StatusMessageList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StatusMessageList Methods

[image] [image]

IceLib Technical Reference
StatusMessageList Methods
StatusMessageList Class See Also Send Feedback

The StatusMessageList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of the defined status messages.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidStatus | Determines whether a given status is defined.
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the Status Message List.
Public method | StartWatchingAsync | Asynchronously starts watching the Status Message List.
Public method | StopWatching | Stops watching the Status Message List.
Public method | StopWatchingAsync | Asynchronously stops watching the Status Message List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusMessageList Class
ININ.IceLib.People Namespace


GetList Method

[image]

IceLib Technical Reference
StatusMessageList..::..GetList Method
StatusMessageList Class See Also Send Feedback
Get a list of the defined status messages.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatusMessageDetails> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of StatusMessageDetails)

Return Value

An array of StatusMessageDetails.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | There are no objects in the cache.
System..::..InvalidOperationException | A watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


IsValidStatus Method

[image]

IceLib Technical Reference
StatusMessageList..::..IsValidStatus Method
StatusMessageList Class See Also Send Feedback
Determines whether a given status is defined.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsValidStatus(
    string name
)
Visual Basic
Public Function IsValidStatus ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
The status message to check.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified status is defined; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
StatusMessageList..::..IsWatching Method
StatusMessageList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
StatusMessageList..::..StartWatching Method
StatusMessageList Class See Also Send Feedback
Starts watching the Status Message List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch is already in progress.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
StatusMessageList..::..StartWatchingAsync Method
StatusMessageList Class See Also Send Feedback
Asynchronously starts watching the Status Message List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
StatusMessageList..::..StopWatching Method
StatusMessageList Class See Also Send Feedback
Stops watching the Status Message List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
StatusMessageList..::..StopWatchingAsync Method
StatusMessageList Class See Also Send Feedback
Asynchronously stops watching the Status Message List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StatusMessageList Properties

[image] [image]

IceLib Technical Reference
StatusMessageList Properties
StatusMessageList Class See Also Send Feedback

The StatusMessageList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Get an individual status message definition by its unique name.

See Also

StatusMessageList Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
StatusMessageList..::..Item Property
StatusMessageList Class See Also Send Feedback
Get an individual status message definition by its unique name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageDetails this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As StatusMessageDetails
    Get

Parameters

name
Type: System..::..String
The status message to get.

Field Value

The status message details.

Remarks

If the status message is not defined, a StatusMessageDetails is still returned, with IsValid set to falseFalsefalsefalse (False in Visual Basic). The IconFileName will be set to "invalid.ico". If this icon file exists, Icon will return it, otherwise a default invalid icon will be returned.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StatusMessageList Events

[image] [image]

IceLib Technical Reference
StatusMessageList Events
StatusMessageList Class See Also Send Feedback

The StatusMessageList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the StatusMessageDetails watched objects has changed.

See Also

StatusMessageList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
StatusMessageList..::..WatchedObjectsChanged Event
StatusMessageList Class See Also Send Feedback
Occurs when one of the StatusMessageDetails watched objects has changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedObjectsEventArgs<StatusMessageProperty>> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of WatchedObjectsEventArgs(Of StatusMessageProperty))

Remarks

Note that changes, additions, and removal of objects are monitored for a StatusMessageList.

Each Changed notification for a StatusMessageDetails object is described by the integer values defined in the StatusMessageProperty enumeration.

This event will only occur if the status message list is being watched. To start watching the status message list call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatusMessageList Class
StatusMessageList Members
ININ.IceLib.People Namespace


StatusMessageProperty Enumeration

[image]

IceLib Technical Reference
StatusMessageProperty Enumeration
See Also Send Feedback
Each value in this enumeration represents a property in StatusMessageDetails.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StatusMessageProperty
Visual Basic
Public Enumeration StatusMessageProperty

Members

Member name | Value | Description
None | 0 | No property is defined.
Id | 1 | Represents the Id property.
MessageText | 2 | Represents the MessageText property.
IconFileName | 3 | Represents the IconFileName property.
GroupTag | 4 | Represents the GroupTag property.
CanHaveDate | 5 | Represents the CanHaveDate property.
CanHaveTime | 6 | Represents the CanHaveTime property.
IsDoNotDisturbStatus | 7 | Represents the IsDoNotDisturbStatus property.
IsSelectableStatus | 8 | Represents the IsSelectableStatus property.
IsPersistentStatus | 9 | Represents the IsPersistentStatus property.
IsForwardStatus | 10 | Represents the IsForwardStatus property.
IsAfterCallWorkStatus | 11 | Represents the IsAfterCallWorkStatus property.
IsAcdStatus | 12 | Represents the IsAcdStatus property.
IsAllowFollowUpStatus | 13 | Represents the IsAllowFollowUpStatus property.
SystemId | 14 | Represents the SystemId property.
Icon | 15 | Represents the Icon property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


UserAccessListsAttributes Class

[image]

IceLib Technical Reference
UserAccessListsAttributes Class
Members See Also Send Feedback
Attribute strings for the UserAccessListsSettings watched class.

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the UserAccessListsSettings class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class UserAccessListsAttributes
Visual Basic
Public NotInheritable Class UserAccessListsAttributes

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserAccessListsAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Members
ININ.IceLib.People Namespace
ININ.IceLib.People..::..UserAccessListsSettings


UserAccessListsAttributes Members

[image] [image]

IceLib Technical Reference
UserAccessListsAttributes Members
UserAccessListsAttributes Class Fields See Also Send Feedback

The UserAccessListsAttributes type exposes the following members.

Fields

Name | Description
AccountCodesList | Get the list of account codes the user can use.
ActivateOthersList | Get the list of queues the user can activate other users on.
ActivateSelfList | Get the list of queues the user can activate themselves.
ActivateUser | Access to activate a user on any workgroup queue that they are a member of.
ChangeUserStatus | Access to change a user's status.
ClientButtonsList | Get the list of call control buttons that the user can configure.
CoachLineQueue | Access to coach on a line queue.
CoachStationQueue | Access to coach on a station queue.
CoachUserQueue | Access to coach on a user queue.
CoachWorkgroupQueue | Access to coach on a workgroup queue.
DisconnectLineQueue | Access to disconnect on a line queue.
DisconnectStationQueue | Access to disconnect on a station queue.
DisconnectUserQueue | Access to disconnect on a user queue.
DisconnectWorkgroupQueue | Access to disconnect on a workgroup queue.
JoinLineQueue | Access to join on a line queue.
JoinStationQueue | Access to join on a station queue.
JoinUserQueue | Access to join on a user queue.
JoinWorkgroupQueue | Access to join on a workgroup queue.
ListenLineQueue | Access to listen on a line queue.
ListenStationQueue | Access to listen on a station queue.
ListenUserQueue | Access to listen on a user queue.
ListenWorkgroupQueue | Access to listen on a workgroup queue.
LoginStations | Access to which stations a user may login to.
ModifyLineQueueList | Obsolete. Get the list of line queues that can be modified. For example, pick up, transfer from, and so on.
ModifyStationGroups | Modify access to station groups.
ModifyStationQueueList | Obsolete. Get the list of station queues that can be modified. For example, pick up, transfer from, and so on.
ModifyUserQueueList | Obsolete. Get the list of user queues that can be modified. This allows the user to make changes to other users' status, pick up calls, and so on.
ModifyWorkgroupQueueList | Obsolete. Get the list of workgroup queues that can be modified. For example, queues that can pick up, transfer interactions from, and so on.
OptimizerCreateAgentConstraints | Get the list of optimizer scheduling units that the user has create access for agent constraints.
OptimizerCreateAgentGroups | Get the list of optimizer scheduling units that the user has create access for agent groups.
OptimizerCreateForecasts | Get the list of optimizer scheduling units that the user has create access for forecasts.
OptimizerCreateSchedules | Get the list of optimizer scheduling units that the user has create access for schedules.
OptimizerCreateShiftRotations | Get the list of optimizer scheduling units that the user has create access for shift rotations.
OptimizerCreateShifts | Get the list of optimizer scheduling units that the user has create access for shifts.
OptimizerCreateTimeOffRequests | Get the list of optimizer scheduling units that the user has create access for time off requests.
OptimizerDeleteAgentConstraints | Get the list of optimizer scheduling units that the user has delete access for agent constraints.
OptimizerDeleteAgentGroups | Get the list of optimizer scheduling units that the user has delete access for agent groups.
OptimizerDeleteForecasts | Get the list of optimizer scheduling units that the user has delete access for forecasts.
OptimizerDeleteSchedules | Get the list of optimizer scheduling units that the user has delete access for schedules.
OptimizerDeleteShiftRotations | Get the list of optimizer scheduling units that the user has delete access for shift rotations.
OptimizerDeleteShifts | Get the list of optimizer scheduling units that the user has delete access for shifts.
OptimizerDeleteTimeOffRequests | Get the list of optimizer scheduling units that the user has delete access for time off requests.
OptimizerModifyAgentConstraints | Get the list of optimizer scheduling units that the user has modify access for agent constraints.
OptimizerModifyAgentGroups | Get the list of optimizer scheduling units that the user has modify access for agent groups.
OptimizerModifyForecasts | Get the list of optimizer scheduling units that the user has modify access for forecasts.
OptimizerModifyRealTimeAdherence | Get the list of optimizer scheduling units that the user has modify access for real-time adherence.
OptimizerModifySchedules | Get the list of optimizer scheduling units that the user has modify access for schedules.
OptimizerModifySchedulingUnitConfiguration | Get the list of optimizer scheduling units that the user has modify access for scheduling unit configuration.
OptimizerModifyShiftRotations | Get the list of optimizer scheduling units that the user has modify access for shift rotations.
OptimizerModifyShifts | Get the list of optimizer scheduling units that the user has modify access for shifts.
OptimizerModifyShiftTrading | Get the list of optimizer scheduling units that the user has modify access to shift trading.
OptimizerModifyTimeOffRequests | Get the list of optimizer scheduling units that the user has modify access for time off requests.
OptimizerSchedulingUnitsList | Obsolete. Get the list of optimizer scheduling units that the user has access to.
OptimizerSchedulingUnitsModifyViewAll | Get the list of optimizer scheduling units the user has access to do all view/modify operations.
OptimizerViewAgentConstraints | Get the list of optimizer scheduling units that the user has view access for agent constraints.
OptimizerViewAgentGroups | Get the list of optimizer scheduling units that the user has view access for agent groups.
OptimizerViewForecasts | Get the list of optimizer scheduling units that the user has view access for forecasts.
OptimizerViewIntradayMonitoring | Get the list of optimizer scheduling units that the user has view access for intraday monitoring.
OptimizerViewRealTimeAdherence | Get the list of optimizer scheduling units that the user has view access for real-time adherence.
OptimizerViewSchedulePreferences | Get the list of optimizer scheduling units that the user has view access for schedule preferences.
OptimizerViewSchedules | Get the list of optimizer scheduling units that the user has view access for schedules.
OptimizerViewSchedulingUnitConfiguration | Get the list of optimizer scheduling units that the user has view access for scheduling unit configuration.
OptimizerViewShiftRotations | Get the list of optimizer scheduling units that the user has view access for shift rotations.
OptimizerViewShifts | Get the list of optimizer scheduling units that the user has view access for shifts.
OptimizerViewShiftTrading | Get the list of optimizer scheduling units that the user has view access access to shift trading
OptimizerViewTimeOffRequests | Get the list of optimizer scheduling units that the user has view access for time off requests.
PhoneNumberClassificationFollowMeList | Get the list of dial plan phone number classifications that the user can use as a follow-me number.
PhoneNumberClassificationForwardList | Get the list of dial plan phone number classifications that the user can use as a forward number.
PhoneNumberClassificationList | Get the list of dial plan phone number classifications that the user can use.
PickupLineQueue | Access to pickup on a line queue.
PickupStationQueue | Access to pickup on a station queue.
PickupUserQueue | Access to pickup on a user queue.
PickupWorkgroupQueue | Access to pickup on a workgroup queue.
PreviewEmailUserQueue | Access to preview emails on a user queue.
PreviewEmailWorkgroupQueue | Access to preview emails on a workgroup queue.
RecordLineQueue | Access to record on a line queue.
RecordStationQueue | Access to record on a station queue.
RecordUserQueue | Access to record on a user queue.
RecordWorkgroupQueue | Access to record on a workgroup queue.
SnipLineQueue | Access to snip interactions on a line queue.
SnipStationQueue | Access to snip interactions on a station queue.
SnipUserQueue | Access to snip interactions on a user queue.
SnipWorkgroupQueue | Access to snip interactions on a workgroup queue.
StatusMessages | Get the list of status messages the user can use.
TransferLineQueue | Access to transfer to a line queue.
TransferStationQueue | Access to transfer to a station queue.
TransferUserQueue | Access to transfer to a user queue.
TransferWorkgroupQueue | Access to transfer to a workgroup queue.
ViewAttendantProfilesInSearch | Access to which profiles a user can see in transfer dialog.
ViewGeneralDirectories | View only access to general directories.
ViewIndividualStats | View access to user statistics.
ViewInSearchStationQueue | Access to which stations a user can see in transfer dialog.
ViewInSearchWorkgroupQueue | Access to view a workgroup queue in a search.
ViewLineQueueList | Get the list of line queues for view only access.
ViewStationGroups | View only access to station groups.
ViewStationQueueList | Get the list of station queues for view only access.
ViewStatusColumns | View only access to status columns.
ViewUserQueueList | Get the list of user queues for view only access.
ViewWorkgroupList | Get the list of workgroups for view only access.
ViewWorkgroupQueueList | Get the list of workgroup queues for view only access.
ViewWorkgroupStatistics | View access to workgroup statistics.

See Also

UserAccessListsAttributes Class
ININ.IceLib.People Namespace


UserAccessListsAttributes Fields

[image] [image]

IceLib Technical Reference
UserAccessListsAttributes Fields
UserAccessListsAttributes Class See Also Send Feedback

The UserAccessListsAttributes type exposes the following members.

Fields

Name | Description
AccountCodesList | Get the list of account codes the user can use.
ActivateOthersList | Get the list of queues the user can activate other users on.
ActivateSelfList | Get the list of queues the user can activate themselves.
ActivateUser | Access to activate a user on any workgroup queue that they are a member of.
ChangeUserStatus | Access to change a user's status.
ClientButtonsList | Get the list of call control buttons that the user can configure.
CoachLineQueue | Access to coach on a line queue.
CoachStationQueue | Access to coach on a station queue.
CoachUserQueue | Access to coach on a user queue.
CoachWorkgroupQueue | Access to coach on a workgroup queue.
DisconnectLineQueue | Access to disconnect on a line queue.
DisconnectStationQueue | Access to disconnect on a station queue.
DisconnectUserQueue | Access to disconnect on a user queue.
DisconnectWorkgroupQueue | Access to disconnect on a workgroup queue.
JoinLineQueue | Access to join on a line queue.
JoinStationQueue | Access to join on a station queue.
JoinUserQueue | Access to join on a user queue.
JoinWorkgroupQueue | Access to join on a workgroup queue.
ListenLineQueue | Access to listen on a line queue.
ListenStationQueue | Access to listen on a station queue.
ListenUserQueue | Access to listen on a user queue.
ListenWorkgroupQueue | Access to listen on a workgroup queue.
LoginStations | Access to which stations a user may login to.
ModifyLineQueueList | Obsolete. Get the list of line queues that can be modified. For example, pick up, transfer from, and so on.
ModifyStationGroups | Modify access to station groups.
ModifyStationQueueList | Obsolete. Get the list of station queues that can be modified. For example, pick up, transfer from, and so on.
ModifyUserQueueList | Obsolete. Get the list of user queues that can be modified. This allows the user to make changes to other users' status, pick up calls, and so on.
ModifyWorkgroupQueueList | Obsolete. Get the list of workgroup queues that can be modified. For example, queues that can pick up, transfer interactions from, and so on.
OptimizerCreateAgentConstraints | Get the list of optimizer scheduling units that the user has create access for agent constraints.
OptimizerCreateAgentGroups | Get the list of optimizer scheduling units that the user has create access for agent groups.
OptimizerCreateForecasts | Get the list of optimizer scheduling units that the user has create access for forecasts.
OptimizerCreateSchedules | Get the list of optimizer scheduling units that the user has create access for schedules.
OptimizerCreateShiftRotations | Get the list of optimizer scheduling units that the user has create access for shift rotations.
OptimizerCreateShifts | Get the list of optimizer scheduling units that the user has create access for shifts.
OptimizerCreateTimeOffRequests | Get the list of optimizer scheduling units that the user has create access for time off requests.
OptimizerDeleteAgentConstraints | Get the list of optimizer scheduling units that the user has delete access for agent constraints.
OptimizerDeleteAgentGroups | Get the list of optimizer scheduling units that the user has delete access for agent groups.
OptimizerDeleteForecasts | Get the list of optimizer scheduling units that the user has delete access for forecasts.
OptimizerDeleteSchedules | Get the list of optimizer scheduling units that the user has delete access for schedules.
OptimizerDeleteShiftRotations | Get the list of optimizer scheduling units that the user has delete access for shift rotations.
OptimizerDeleteShifts | Get the list of optimizer scheduling units that the user has delete access for shifts.
OptimizerDeleteTimeOffRequests | Get the list of optimizer scheduling units that the user has delete access for time off requests.
OptimizerModifyAgentConstraints | Get the list of optimizer scheduling units that the user has modify access for agent constraints.
OptimizerModifyAgentGroups | Get the list of optimizer scheduling units that the user has modify access for agent groups.
OptimizerModifyForecasts | Get the list of optimizer scheduling units that the user has modify access for forecasts.
OptimizerModifyRealTimeAdherence | Get the list of optimizer scheduling units that the user has modify access for real-time adherence.
OptimizerModifySchedules | Get the list of optimizer scheduling units that the user has modify access for schedules.
OptimizerModifySchedulingUnitConfiguration | Get the list of optimizer scheduling units that the user has modify access for scheduling unit configuration.
OptimizerModifyShiftRotations | Get the list of optimizer scheduling units that the user has modify access for shift rotations.
OptimizerModifyShifts | Get the list of optimizer scheduling units that the user has modify access for shifts.
OptimizerModifyShiftTrading | Get the list of optimizer scheduling units that the user has modify access to shift trading.
OptimizerModifyTimeOffRequests | Get the list of optimizer scheduling units that the user has modify access for time off requests.
OptimizerSchedulingUnitsList | Obsolete. Get the list of optimizer scheduling units that the user has access to.
OptimizerSchedulingUnitsModifyViewAll | Get the list of optimizer scheduling units the user has access to do all view/modify operations.
OptimizerViewAgentConstraints | Get the list of optimizer scheduling units that the user has view access for agent constraints.
OptimizerViewAgentGroups | Get the list of optimizer scheduling units that the user has view access for agent groups.
OptimizerViewForecasts | Get the list of optimizer scheduling units that the user has view access for forecasts.
OptimizerViewIntradayMonitoring | Get the list of optimizer scheduling units that the user has view access for intraday monitoring.
OptimizerViewRealTimeAdherence | Get the list of optimizer scheduling units that the user has view access for real-time adherence.
OptimizerViewSchedulePreferences | Get the list of optimizer scheduling units that the user has view access for schedule preferences.
OptimizerViewSchedules | Get the list of optimizer scheduling units that the user has view access for schedules.
OptimizerViewSchedulingUnitConfiguration | Get the list of optimizer scheduling units that the user has view access for scheduling unit configuration.
OptimizerViewShiftRotations | Get the list of optimizer scheduling units that the user has view access for shift rotations.
OptimizerViewShifts | Get the list of optimizer scheduling units that the user has view access for shifts.
OptimizerViewShiftTrading | Get the list of optimizer scheduling units that the user has view access access to shift trading
OptimizerViewTimeOffRequests | Get the list of optimizer scheduling units that the user has view access for time off requests.
PhoneNumberClassificationFollowMeList | Get the list of dial plan phone number classifications that the user can use as a follow-me number.
PhoneNumberClassificationForwardList | Get the list of dial plan phone number classifications that the user can use as a forward number.
PhoneNumberClassificationList | Get the list of dial plan phone number classifications that the user can use.
PickupLineQueue | Access to pickup on a line queue.
PickupStationQueue | Access to pickup on a station queue.
PickupUserQueue | Access to pickup on a user queue.
PickupWorkgroupQueue | Access to pickup on a workgroup queue.
PreviewEmailUserQueue | Access to preview emails on a user queue.
PreviewEmailWorkgroupQueue | Access to preview emails on a workgroup queue.
RecordLineQueue | Access to record on a line queue.
RecordStationQueue | Access to record on a station queue.
RecordUserQueue | Access to record on a user queue.
RecordWorkgroupQueue | Access to record on a workgroup queue.
SnipLineQueue | Access to snip interactions on a line queue.
SnipStationQueue | Access to snip interactions on a station queue.
SnipUserQueue | Access to snip interactions on a user queue.
SnipWorkgroupQueue | Access to snip interactions on a workgroup queue.
StatusMessages | Get the list of status messages the user can use.
TransferLineQueue | Access to transfer to a line queue.
TransferStationQueue | Access to transfer to a station queue.
TransferUserQueue | Access to transfer to a user queue.
TransferWorkgroupQueue | Access to transfer to a workgroup queue.
ViewAttendantProfilesInSearch | Access to which profiles a user can see in transfer dialog.
ViewGeneralDirectories | View only access to general directories.
ViewIndividualStats | View access to user statistics.
ViewInSearchStationQueue | Access to which stations a user can see in transfer dialog.
ViewInSearchWorkgroupQueue | Access to view a workgroup queue in a search.
ViewLineQueueList | Get the list of line queues for view only access.
ViewStationGroups | View only access to station groups.
ViewStationQueueList | Get the list of station queues for view only access.
ViewStatusColumns | View only access to status columns.
ViewUserQueueList | Get the list of user queues for view only access.
ViewWorkgroupList | Get the list of workgroups for view only access.
ViewWorkgroupQueueList | Get the list of workgroup queues for view only access.
ViewWorkgroupStatistics | View access to workgroup statistics.

See Also

UserAccessListsAttributes Class
ININ.IceLib.People Namespace


AccountCodesList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..AccountCodesList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of account codes the user can use.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AccountCodesList
Visual Basic
Public Shared ReadOnly AccountCodesList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ActivateOthersList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ActivateOthersList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of queues the user can activate other users on.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ActivateOthersList
Visual Basic
Public Shared ReadOnly ActivateOthersList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ActivateSelfList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ActivateSelfList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of queues the user can activate themselves.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ActivateSelfList
Visual Basic
Public Shared ReadOnly ActivateSelfList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ActivateUser Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ActivateUser Field
UserAccessListsAttributes Class See Also Send Feedback
Access to activate a user on any workgroup queue that they are a member of.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ActivateUser
Visual Basic
Public Shared ReadOnly ActivateUser As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ChangeUserStatus Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ChangeUserStatus Field
UserAccessListsAttributes Class See Also Send Feedback
Access to change a user's status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ChangeUserStatus
Visual Basic
Public Shared ReadOnly ChangeUserStatus As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ClientButtonsList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ClientButtonsList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of call control buttons that the user can configure.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ClientButtonsList
Visual Basic
Public Shared ReadOnly ClientButtonsList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


CoachLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..CoachLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to coach on a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CoachLineQueue
Visual Basic
Public Shared ReadOnly CoachLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


CoachStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..CoachStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to coach on a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CoachStationQueue
Visual Basic
Public Shared ReadOnly CoachStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


CoachUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..CoachUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to coach on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CoachUserQueue
Visual Basic
Public Shared ReadOnly CoachUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


CoachWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..CoachWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to coach on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CoachWorkgroupQueue
Visual Basic
Public Shared ReadOnly CoachWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


DisconnectLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..DisconnectLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to disconnect on a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DisconnectLineQueue
Visual Basic
Public Shared ReadOnly DisconnectLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


DisconnectStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..DisconnectStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to disconnect on a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DisconnectStationQueue
Visual Basic
Public Shared ReadOnly DisconnectStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


DisconnectUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..DisconnectUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to disconnect on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DisconnectUserQueue
Visual Basic
Public Shared ReadOnly DisconnectUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


DisconnectWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..DisconnectWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to disconnect on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string DisconnectWorkgroupQueue
Visual Basic
Public Shared ReadOnly DisconnectWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


JoinLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..JoinLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to join on a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string JoinLineQueue
Visual Basic
Public Shared ReadOnly JoinLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


JoinStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..JoinStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to join on a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string JoinStationQueue
Visual Basic
Public Shared ReadOnly JoinStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


JoinUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..JoinUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to join on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string JoinUserQueue
Visual Basic
Public Shared ReadOnly JoinUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


JoinWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..JoinWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to join on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string JoinWorkgroupQueue
Visual Basic
Public Shared ReadOnly JoinWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ListenLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ListenLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to listen on a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ListenLineQueue
Visual Basic
Public Shared ReadOnly ListenLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ListenStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ListenStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to listen on a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ListenStationQueue
Visual Basic
Public Shared ReadOnly ListenStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ListenUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ListenUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to listen on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ListenUserQueue
Visual Basic
Public Shared ReadOnly ListenUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ListenWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ListenWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to listen on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ListenWorkgroupQueue
Visual Basic
Public Shared ReadOnly ListenWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


LoginStations Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..LoginStations Field
UserAccessListsAttributes Class See Also Send Feedback
Access to which stations a user may login to.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LoginStations
Visual Basic
Public Shared ReadOnly LoginStations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ModifyLineQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ModifyLineQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of line queues that can be modified. For example, pick up, transfer from, and so on.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyLineQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public static readonly string ModifyLineQueueList
Visual Basic
<ObsoleteAttribute("ModifyLineQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public Shared ReadOnly ModifyLineQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ModifyStationGroups Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ModifyStationGroups Field
UserAccessListsAttributes Class See Also Send Feedback
Modify access to station groups.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ModifyStationGroups
Visual Basic
Public Shared ReadOnly ModifyStationGroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ModifyStationQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ModifyStationQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of station queues that can be modified. For example, pick up, transfer from, and so on.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyStationQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public static readonly string ModifyStationQueueList
Visual Basic
<ObsoleteAttribute("ModifyStationQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public Shared ReadOnly ModifyStationQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ModifyUserQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ModifyUserQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of user queues that can be modified. This allows the user to make changes to other users' status, pick up calls, and so on.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyUserQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public static readonly string ModifyUserQueueList
Visual Basic
<ObsoleteAttribute("ModifyUserQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public Shared ReadOnly ModifyUserQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ModifyWorkgroupQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ModifyWorkgroupQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of workgroup queues that can be modified. For example, queues that can pick up, transfer interactions from, and so on.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyWorkgroupQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public static readonly string ModifyWorkgroupQueueList
Visual Basic
<ObsoleteAttribute("ModifyWorkgroupQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public Shared ReadOnly ModifyWorkgroupQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateAgentConstraints Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateAgentConstraints Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for agent constraints.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateAgentConstraints
Visual Basic
Public Shared ReadOnly OptimizerCreateAgentConstraints As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateAgentGroups Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateAgentGroups Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for agent groups.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateAgentGroups
Visual Basic
Public Shared ReadOnly OptimizerCreateAgentGroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateForecasts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateForecasts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for forecasts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateForecasts
Visual Basic
Public Shared ReadOnly OptimizerCreateForecasts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateSchedules Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateSchedules Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for schedules.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateSchedules
Visual Basic
Public Shared ReadOnly OptimizerCreateSchedules As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateShiftRotations Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateShiftRotations Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for shift rotations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateShiftRotations
Visual Basic
Public Shared ReadOnly OptimizerCreateShiftRotations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateShifts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateShifts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for shifts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateShifts
Visual Basic
Public Shared ReadOnly OptimizerCreateShifts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerCreateTimeOffRequests Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerCreateTimeOffRequests Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has create access for time off requests.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerCreateTimeOffRequests
Visual Basic
Public Shared ReadOnly OptimizerCreateTimeOffRequests As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteAgentConstraints Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteAgentConstraints Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for agent constraints.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteAgentConstraints
Visual Basic
Public Shared ReadOnly OptimizerDeleteAgentConstraints As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteAgentGroups Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteAgentGroups Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for agent groups.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteAgentGroups
Visual Basic
Public Shared ReadOnly OptimizerDeleteAgentGroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteForecasts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteForecasts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for forecasts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteForecasts
Visual Basic
Public Shared ReadOnly OptimizerDeleteForecasts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteSchedules Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteSchedules Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for schedules.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteSchedules
Visual Basic
Public Shared ReadOnly OptimizerDeleteSchedules As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteShiftRotations Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteShiftRotations Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for shift rotations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteShiftRotations
Visual Basic
Public Shared ReadOnly OptimizerDeleteShiftRotations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteShifts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteShifts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for shifts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteShifts
Visual Basic
Public Shared ReadOnly OptimizerDeleteShifts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerDeleteTimeOffRequests Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerDeleteTimeOffRequests Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has delete access for time off requests.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerDeleteTimeOffRequests
Visual Basic
Public Shared ReadOnly OptimizerDeleteTimeOffRequests As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyAgentConstraints Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyAgentConstraints Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for agent constraints.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyAgentConstraints
Visual Basic
Public Shared ReadOnly OptimizerModifyAgentConstraints As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyAgentGroups Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyAgentGroups Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for agent groups.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyAgentGroups
Visual Basic
Public Shared ReadOnly OptimizerModifyAgentGroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyForecasts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyForecasts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for forecasts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyForecasts
Visual Basic
Public Shared ReadOnly OptimizerModifyForecasts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyRealTimeAdherence Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyRealTimeAdherence Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for real-time adherence.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyRealTimeAdherence
Visual Basic
Public Shared ReadOnly OptimizerModifyRealTimeAdherence As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifySchedules Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifySchedules Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for schedules.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifySchedules
Visual Basic
Public Shared ReadOnly OptimizerModifySchedules As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifySchedulingUnitConfiguration Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifySchedulingUnitConfiguration Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for scheduling unit configuration.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifySchedulingUnitConfiguration
Visual Basic
Public Shared ReadOnly OptimizerModifySchedulingUnitConfiguration As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyShiftRotations Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyShiftRotations Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for shift rotations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyShiftRotations
Visual Basic
Public Shared ReadOnly OptimizerModifyShiftRotations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyShifts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyShifts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for shifts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyShifts
Visual Basic
Public Shared ReadOnly OptimizerModifyShifts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyShiftTrading Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyShiftTrading Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access to shift trading.

Note: This field is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyShiftTrading
Visual Basic
Public Shared ReadOnly OptimizerModifyShiftTrading As String

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerModifyTimeOffRequests Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerModifyTimeOffRequests Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has modify access for time off requests.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerModifyTimeOffRequests
Visual Basic
Public Shared ReadOnly OptimizerModifyTimeOffRequests As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerSchedulingUnitsList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerSchedulingUnitsList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has access to.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("OptimizerSchedulingUnitsList is no longer used.")]
public static readonly string OptimizerSchedulingUnitsList
Visual Basic
<ObsoleteAttribute("OptimizerSchedulingUnitsList is no longer used.")> _
Public Shared ReadOnly OptimizerSchedulingUnitsList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerSchedulingUnitsModifyViewAll Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerSchedulingUnitsModifyViewAll Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units the user has access to do all view/modify operations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerSchedulingUnitsModifyViewAll
Visual Basic
Public Shared ReadOnly OptimizerSchedulingUnitsModifyViewAll As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewAgentConstraints Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewAgentConstraints Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for agent constraints.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewAgentConstraints
Visual Basic
Public Shared ReadOnly OptimizerViewAgentConstraints As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewAgentGroups Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewAgentGroups Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for agent groups.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewAgentGroups
Visual Basic
Public Shared ReadOnly OptimizerViewAgentGroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewForecasts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewForecasts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for forecasts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewForecasts
Visual Basic
Public Shared ReadOnly OptimizerViewForecasts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewIntradayMonitoring Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewIntradayMonitoring Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for intraday monitoring.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewIntradayMonitoring
Visual Basic
Public Shared ReadOnly OptimizerViewIntradayMonitoring As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewRealTimeAdherence Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewRealTimeAdherence Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for real-time adherence.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewRealTimeAdherence
Visual Basic
Public Shared ReadOnly OptimizerViewRealTimeAdherence As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewSchedulePreferences Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewSchedulePreferences Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for schedule preferences.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewSchedulePreferences
Visual Basic
Public Shared ReadOnly OptimizerViewSchedulePreferences As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewSchedules Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewSchedules Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for schedules.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewSchedules
Visual Basic
Public Shared ReadOnly OptimizerViewSchedules As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewSchedulingUnitConfiguration Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewSchedulingUnitConfiguration Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for scheduling unit configuration.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewSchedulingUnitConfiguration
Visual Basic
Public Shared ReadOnly OptimizerViewSchedulingUnitConfiguration As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewShiftRotations Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewShiftRotations Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for shift rotations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewShiftRotations
Visual Basic
Public Shared ReadOnly OptimizerViewShiftRotations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewShifts Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewShifts Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for shifts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewShifts
Visual Basic
Public Shared ReadOnly OptimizerViewShifts As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewShiftTrading Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewShiftTrading Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access access to shift trading

Note: This field is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewShiftTrading
Visual Basic
Public Shared ReadOnly OptimizerViewShiftTrading As String

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


OptimizerViewTimeOffRequests Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..OptimizerViewTimeOffRequests Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of optimizer scheduling units that the user has view access for time off requests.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string OptimizerViewTimeOffRequests
Visual Basic
Public Shared ReadOnly OptimizerViewTimeOffRequests As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PhoneNumberClassificationFollowMeList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PhoneNumberClassificationFollowMeList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of dial plan phone number classifications that the user can use as a follow-me number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PhoneNumberClassificationFollowMeList
Visual Basic
Public Shared ReadOnly PhoneNumberClassificationFollowMeList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PhoneNumberClassificationForwardList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PhoneNumberClassificationForwardList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of dial plan phone number classifications that the user can use as a forward number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PhoneNumberClassificationForwardList
Visual Basic
Public Shared ReadOnly PhoneNumberClassificationForwardList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PhoneNumberClassificationList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PhoneNumberClassificationList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of dial plan phone number classifications that the user can use.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PhoneNumberClassificationList
Visual Basic
Public Shared ReadOnly PhoneNumberClassificationList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PickupLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PickupLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to pickup on a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PickupLineQueue
Visual Basic
Public Shared ReadOnly PickupLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PickupStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PickupStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to pickup on a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PickupStationQueue
Visual Basic
Public Shared ReadOnly PickupStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PickupUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PickupUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to pickup on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PickupUserQueue
Visual Basic
Public Shared ReadOnly PickupUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PickupWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PickupWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to pickup on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PickupWorkgroupQueue
Visual Basic
Public Shared ReadOnly PickupWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PreviewEmailUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PreviewEmailUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to preview emails on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PreviewEmailUserQueue
Visual Basic
Public Shared ReadOnly PreviewEmailUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


PreviewEmailWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..PreviewEmailWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to preview emails on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PreviewEmailWorkgroupQueue
Visual Basic
Public Shared ReadOnly PreviewEmailWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


RecordLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..RecordLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to record on a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordLineQueue
Visual Basic
Public Shared ReadOnly RecordLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


RecordStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..RecordStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to record on a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordStationQueue
Visual Basic
Public Shared ReadOnly RecordStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


RecordUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..RecordUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to record on a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordUserQueue
Visual Basic
Public Shared ReadOnly RecordUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


RecordWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..RecordWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to record on a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RecordWorkgroupQueue
Visual Basic
Public Shared ReadOnly RecordWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


SnipLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..SnipLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to snip interactions on a line queue.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SnipLineQueue
Visual Basic
Public Shared ReadOnly SnipLineQueue As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


SnipStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..SnipStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to snip interactions on a station queue.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SnipStationQueue
Visual Basic
Public Shared ReadOnly SnipStationQueue As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


SnipUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..SnipUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to snip interactions on a user queue.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SnipUserQueue
Visual Basic
Public Shared ReadOnly SnipUserQueue As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


SnipWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..SnipWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to snip interactions on a workgroup queue.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SnipWorkgroupQueue
Visual Basic
Public Shared ReadOnly SnipWorkgroupQueue As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


StatusMessages Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..StatusMessages Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of status messages the user can use.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string StatusMessages
Visual Basic
Public Shared ReadOnly StatusMessages As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


TransferLineQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..TransferLineQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to transfer to a line queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string TransferLineQueue
Visual Basic
Public Shared ReadOnly TransferLineQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


TransferStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..TransferStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to transfer to a station queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string TransferStationQueue
Visual Basic
Public Shared ReadOnly TransferStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


TransferUserQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..TransferUserQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to transfer to a user queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string TransferUserQueue
Visual Basic
Public Shared ReadOnly TransferUserQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


TransferWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..TransferWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to transfer to a workgroup queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string TransferWorkgroupQueue
Visual Basic
Public Shared ReadOnly TransferWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewAttendantProfilesInSearch Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewAttendantProfilesInSearch Field
UserAccessListsAttributes Class See Also Send Feedback
Access to which profiles a user can see in transfer dialog.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewAttendantProfilesInSearch
Visual Basic
Public Shared ReadOnly ViewAttendantProfilesInSearch As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewGeneralDirectories Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewGeneralDirectories Field
UserAccessListsAttributes Class See Also Send Feedback
View only access to general directories.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewGeneralDirectories
Visual Basic
Public Shared ReadOnly ViewGeneralDirectories As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewIndividualStats Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewIndividualStats Field
UserAccessListsAttributes Class See Also Send Feedback
View access to user statistics.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewIndividualStats
Visual Basic
Public Shared ReadOnly ViewIndividualStats As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewInSearchStationQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewInSearchStationQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to which stations a user can see in transfer dialog.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewInSearchStationQueue
Visual Basic
Public Shared ReadOnly ViewInSearchStationQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewInSearchWorkgroupQueue Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewInSearchWorkgroupQueue Field
UserAccessListsAttributes Class See Also Send Feedback
Access to view a workgroup queue in a search.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewInSearchWorkgroupQueue
Visual Basic
Public Shared ReadOnly ViewInSearchWorkgroupQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewLineQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewLineQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of line queues for view only access.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewLineQueueList
Visual Basic
Public Shared ReadOnly ViewLineQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewStationGroups Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewStationGroups Field
UserAccessListsAttributes Class See Also Send Feedback
View only access to station groups.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewStationGroups
Visual Basic
Public Shared ReadOnly ViewStationGroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewStationQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewStationQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of station queues for view only access.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewStationQueueList
Visual Basic
Public Shared ReadOnly ViewStationQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewStatusColumns Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewStatusColumns Field
UserAccessListsAttributes Class See Also Send Feedback
View only access to status columns.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewStatusColumns
Visual Basic
Public Shared ReadOnly ViewStatusColumns As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewUserQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewUserQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of user queues for view only access.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewUserQueueList
Visual Basic
Public Shared ReadOnly ViewUserQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewWorkgroupList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewWorkgroupList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of workgroups for view only access.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewWorkgroupList
Visual Basic
Public Shared ReadOnly ViewWorkgroupList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewWorkgroupQueueList Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewWorkgroupQueueList Field
UserAccessListsAttributes Class See Also Send Feedback
Get the list of workgroup queues for view only access.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewWorkgroupQueueList
Visual Basic
Public Shared ReadOnly ViewWorkgroupQueueList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


ViewWorkgroupStatistics Field

[image]

IceLib Technical Reference
UserAccessListsAttributes..::..ViewWorkgroupStatistics Field
UserAccessListsAttributes Class See Also Send Feedback
View access to workgroup statistics.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewWorkgroupStatistics
Visual Basic
Public Shared ReadOnly ViewWorkgroupStatistics As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsAttributes Class
UserAccessListsAttributes Members
ININ.IceLib.People Namespace


UserAccessListsSettings Class

[image]

IceLib Technical Reference
UserAccessListsSettings Class
Members See Also Send Feedback
Represents the access control lists settings for an IC user. These settings are configured in the Access control section of the Security tab in Interaction Administrator.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserAccessListsSettings : UserSettings
Visual Basic
Public Class UserAccessListsSettings _
    Inherits UserSettings

Remarks

Access control options are set in Interaction Administrator at the Default User, Roles, User, or Workgroup level. These options determine which queues a User, Workgroup or Role can view and which queues they can modify (that is, perform Interaction Client functions such as pick up calls, listen in on calls, place calls on hold, change status, and so on).

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserSettings
ININ.IceLib.People..::..UserAccessListsSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Members
ININ.IceLib.People Namespace


UserAccessListsSettings Members

[image] [image]

IceLib Technical Reference
UserAccessListsSettings Members
UserAccessListsSettings Class Constructors Methods Properties Events See Also Send Feedback

The UserAccessListsSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserAccessListsSettings | Initializes a new instance of the UserAccessListsSettings class for the current session user.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountCodesList | Gets the AccountCodesList access control list. This list value is a ReadOnlyCollection<(Of <(<'T>)>)> of account codes that this user can use.
Public property | ActivateSelfList | Gets the ActivateSelfList access control list of queues this user can activate.
Public property | ActivateUser | Gets the ActivateUser access control list.
Public property | ChangeUserStatus | Gets the ChangeUserStatus access control list.
Public property | ClientButtonsList | Gets the ClientButtonsList access control list of call control buttons this user can configure.
Public property | CoachLineQueue | Gets the CoachLineQueue access control list.
Public property | CoachStationQueue | Gets the CoachStationQueue access control list.
Public property | CoachUserQueue | Gets the CoachUserQueue access control list.
Public property | CoachWorkgroupQueue | Gets the CoachWorkgroupQueue access control list.
Public property | DisconnectLineQueue | Gets the DisconnectLineQueue access control list.
Public property | DisconnectStationQueue | Gets the DisconnectStationQueue access control list.
Public property | DisconnectUserQueue | Gets the DisconnectUserQueue access control list.
Public property | DisconnectWorkgroupQueue | Gets the DisconnectWorkgroupQueue access control list.
Public property | JoinLineQueue | Gets the JoinLineQueue access control list.
Public property | JoinStationQueue | Gets the JoinStationQueue access control list.
Public property | JoinUserQueue | Gets the JoinUserQueue access control list.
Public property | JoinWorkgroupQueue | Gets the JoinWorkgroupQueue access control list.
Public property | ListenLineQueue | Gets the ListenLineQueue access control list.
Public property | ListenStationQueue | Gets the ListenStationQueue access control list.
Public property | ListenUserQueue | Gets the ListenUserQueue access control list.
Public property | ListenWorkgroupQueue | Gets the ListenWorkgroupQueue access control list.
Public property | LoginStations | Gets the LoginStations access control list.
Public property | ModifyLineQueueList | Obsolete. Gets the ModifyLineQueueList access control list of line queues that this user can modify.
Public property | ModifyStationGroups | Gets the ModifyStationGroups access control list.
Public property | ModifyStationQueueList | Obsolete. Gets the ModifyStationQueueList access control list of station queues that this user can modify.
Public property | ModifyUserQueueList | Obsolete. Gets the ModifyUserQueueList access control list of user queues that can be modified by this user to make changes to other users' status, pick up calls, and so on.
Public property | ModifyWorkgroupQueueList | Obsolete. Gets the ModifyWorkgroupQueueList access control list of workgroup queues that can be modified. From these queues the user can pick up, transfer from, etc.
Public property | OptimizerCreateAgentConstraints | Gets the OptimizerCreateAgentConstraints access control list.
Public property | OptimizerCreateAgentGroupsSUList | Gets the OptimizerCreateAgentGroups access control list.
Public property | OptimizerCreateForecasts | Gets the OptimizerCreateForecasts access control list.
Public property | OptimizerCreateSchedules | Gets the OptimizerCreateSchedules access control list.
Public property | OptimizerCreateShiftRotations | Gets the OptimizerCreateShiftRotations access control list.
Public property | OptimizerCreateShifts | Gets the OptimizerCreateShifts access control list.
Public property | OptimizerCreateTimeOffRequests | Gets the OptimizerCreateTimeOffRequests access control list.
Public property | OptimizerDeleteAgentConstraints | Gets the OptimizerDeleteAgentConstraints access control list.
Public property | OptimizerDeleteAgentGroups | Gets the OptimizerDeleteAgentGroups access control list.
Public property | OptimizerDeleteForecasts | Gets the OptimizerDeleteForecasts access control list.
Public property | OptimizerDeleteSchedules | Gets the OptimizerDeleteSchedules access control list.
Public property | OptimizerDeleteShiftRotations | Gets the OptimizerDeleteShiftRotations access control list.
Public property | OptimizerDeleteShifts | Gets the OptimizerDeleteShifts access control list.
Public property | OptimizerDeleteTimeOffRequests | Gets the OptimizerDeleteTimeOffRequests access control list.
Public property | OptimizerModifyAgentConstraints | Gets the OptimizerModifyAgentConstraints access control list.
Public property | OptimizerModifyAgentGroups | Gets the OptimizerModifyAgentGroups access control list.
Public property | OptimizerModifyForecasts | Gets the OptimizerModifyForecasts access control list.
Public property | OptimizerModifyRealTimeAdherence | Gets the OptimizerModifyRealTimeAdherence access control list.
Public property | OptimizerModifySchedules | Gets the OptimizerModifySchedules access control list.
Public property | OptimizerModifySchedulingUnitConfiguration | Gets the OptimizerModifySchedulingUnitConfiguration access control list.
Public property | OptimizerModifyShiftRotations | Gets the OptimizerModifyShiftRotations access control list.
Public property | OptimizerModifyShifts | Gets the OptimizerModifyShifts access control list.
Public property | OptimizerModifyShiftTrading | Gets the OptimizerModifyShiftTrading access control list.
Public property | OptimizerModifyTimeOffRequests | Gets the OptimizerModifyTimeOffRequests access control list.
Public property | OptimizerSchedulingUnitsList | Obsolete. Gets the OptimizerSchedulingUnitsList access control list.
Public property | OptimizerSchedulingUnitsModifyViewAll | Gets the OptimizerSchedulingUnitsModifyViewAll access control list.
Public property | OptimizerViewAgentConstraints | Gets the OptimizerViewAgentConstraints access control list.
Public property | OptimizerViewAgentGroups | Gets the OptimizerViewAgentGroups access control list.
Public property | OptimizerViewForecasts | Gets the OptimizerViewForecasts access control list.
Public property | OptimizerViewIntradayMonitoring | Gets the OptimizerViewIntradayMonitoring access control list.
Public property | OptimizerViewRealTimeAdherence | Gets the OptimizerViewRealTimeAdherence access control list.
Public property | OptimizerViewSchedulePreferences | Gets the OptimizerViewSchedulePreferences access control list.
Public property | OptimizerViewSchedules | Gets the OptimizerViewSchedules access control list.
Public property | OptimizerViewSchedulingUnitConfiguration | Gets the OptimizerViewSchedulingUnitConfiguration access control list.
Public property | OptimizerViewShiftRotations | Gets the OptimizerViewShiftRotations access control list.
Public property | OptimizerViewShifts | Gets the OptimizerViewShifts access control list.
Public property | OptimizerViewShiftTrading | Gets the OptimizerViewShiftTrading access control list.
Public property | OptimizerViewTimeOffRequests | Gets the OptimizerViewTimeOffRequests access control list.
Public property | PhoneNumberClassificationFollowMeList | Gets the PhoneNumberClassificationList access control list of dial plan phone number classifications that this user can use as follow-me numbers.
Public property | PhoneNumberClassificationForwardList | Gets the PhoneNumberClassificationForwardList access control list of dial plan phone number classifications this user can forward calls to.
Public property | PhoneNumberClassificationList | Gets the PhoneNumberClassificationList access control list of dial plan phone number classifications that this user can use.
Public property | PickupLineQueue | Gets the PickupLineQueue access control list.
Public property | PickupStationQueue | Gets the PickupStationQueue access control list.
Public property | PickupUserQueue | Gets the PickupUserQueue access control list.
Public property | PickupWorkgroupQueue | Gets the PickupWorkgroupQueue access control list.
Public property | PreviewEmailUserQueue | Gets the PreviewEmailUserQueue access control list.
Public property | PreviewEmailWorkgroupQueue | Gets the PreviewEmailWorkgroupQueue access control list.
Public property | RecordLineQueue | Gets the RecordLineQueue access control list.
Public property | RecordStationQueue | Gets the RecordStationQueue access control list.
Public property | RecordUserQueue | Gets the RecordUserQueue access control list.
Public property | RecordWorkgroupQueue | Gets the RecordWorkgroupQueue access control list.
Public property | SnipLineQueue | Gets the SnipLineQueue access control list.
Public property | SnipStationQueue | Gets the SnipStationQueue access control list.
Public property | SnipUserQueue | Gets the SnipUserQueue access control list.
Public property | SnipWorkgroupQueue | Gets the SnipWorkgroupQueue access control list.
Public property | StatusMessageList | Gets the StatusMessages access control list of all status messages that the user can see.
Public property | TransferLineQueue | Gets the TransferLineQueue access control list.
Public property | TransferStationQueue | Gets the TransferStationQueue access control list.
Public property | TransferUserQueue | Gets the TransferUserQueue access control list.
Public property | TransferWorkgroupQueue | Gets the TransferWorkgroupQueue access control list.
Public property | ViewAttendantProfilesInSearch | Gets the ViewAttendantProfilesInSearch access control list.
Public property | ViewGeneralDirectories | Gets the ViewGeneralDirectories access control list.
Public property | ViewIndividualStats | Gets the ViewIndividualStats access control list.
Public property | ViewInSearchStationQueue | Gets the ViewInSearchStationQueue access control list.
Public property | ViewInSearchWorkgroupQueue | Gets the ViewInSearchWorkgroupQueue access control list.
Public property | ViewLineQueueList | Gets the ViewLineQueueList access control list of line queues that this user can view but not modify.
Public property | ViewStationGroups | Gets the ViewStationGroups access control list.
Public property | ViewStationQueueList | Gets the ViewStationQueueList access control list of station queues that this user can view but not modify.
Public property | ViewStatusColumns | Gets the ViewStatusColumns access control list.
Public property | ViewUserQueueList | Gets the ViewUserQueueList access control list of user queues that this user can view but not modify.
Public property | ViewWorkgroupList | Gets the ViewWorkgroupList access control list of workgroups that this user can view but not modify.
Public property | ViewWorkgroupQueueList | Gets the ViewWorkgroupQueueList access control list of workgroup queues that this user can view but not modify.
Public property | ViewWorkgroupStatistics | Gets the ViewWorkgroupStatistics access control list.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserAccessListsSettings Class
ININ.IceLib.People Namespace


UserAccessListsSettings Constructor

[image]

IceLib Technical Reference
UserAccessListsSettings Constructor
UserAccessListsSettings Class See Also Send Feedback
Initializes a new instance of the UserAccessListsSettings class for the current session user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserAccessListsSettings(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


UserAccessListsSettings Methods

[image] [image]

IceLib Technical Reference
UserAccessListsSettings Methods
UserAccessListsSettings Class See Also Send Feedback

The UserAccessListsSettings type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserAccessListsSettings Class
ININ.IceLib.People Namespace


UserAccessListsSettings Properties

[image] [image]

IceLib Technical Reference
UserAccessListsSettings Properties
UserAccessListsSettings Class See Also Send Feedback

The UserAccessListsSettings type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodesList | Gets the AccountCodesList access control list. This list value is a ReadOnlyCollection<(Of <(<'T>)>)> of account codes that this user can use.
Public property | ActivateSelfList | Gets the ActivateSelfList access control list of queues this user can activate.
Public property | ActivateUser | Gets the ActivateUser access control list.
Public property | ChangeUserStatus | Gets the ChangeUserStatus access control list.
Public property | ClientButtonsList | Gets the ClientButtonsList access control list of call control buttons this user can configure.
Public property | CoachLineQueue | Gets the CoachLineQueue access control list.
Public property | CoachStationQueue | Gets the CoachStationQueue access control list.
Public property | CoachUserQueue | Gets the CoachUserQueue access control list.
Public property | CoachWorkgroupQueue | Gets the CoachWorkgroupQueue access control list.
Public property | DisconnectLineQueue | Gets the DisconnectLineQueue access control list.
Public property | DisconnectStationQueue | Gets the DisconnectStationQueue access control list.
Public property | DisconnectUserQueue | Gets the DisconnectUserQueue access control list.
Public property | DisconnectWorkgroupQueue | Gets the DisconnectWorkgroupQueue access control list.
Public property | JoinLineQueue | Gets the JoinLineQueue access control list.
Public property | JoinStationQueue | Gets the JoinStationQueue access control list.
Public property | JoinUserQueue | Gets the JoinUserQueue access control list.
Public property | JoinWorkgroupQueue | Gets the JoinWorkgroupQueue access control list.
Public property | ListenLineQueue | Gets the ListenLineQueue access control list.
Public property | ListenStationQueue | Gets the ListenStationQueue access control list.
Public property | ListenUserQueue | Gets the ListenUserQueue access control list.
Public property | ListenWorkgroupQueue | Gets the ListenWorkgroupQueue access control list.
Public property | LoginStations | Gets the LoginStations access control list.
Public property | ModifyLineQueueList | Obsolete. Gets the ModifyLineQueueList access control list of line queues that this user can modify.
Public property | ModifyStationGroups | Gets the ModifyStationGroups access control list.
Public property | ModifyStationQueueList | Obsolete. Gets the ModifyStationQueueList access control list of station queues that this user can modify.
Public property | ModifyUserQueueList | Obsolete. Gets the ModifyUserQueueList access control list of user queues that can be modified by this user to make changes to other users' status, pick up calls, and so on.
Public property | ModifyWorkgroupQueueList | Obsolete. Gets the ModifyWorkgroupQueueList access control list of workgroup queues that can be modified. From these queues the user can pick up, transfer from, etc.
Public property | OptimizerCreateAgentConstraints | Gets the OptimizerCreateAgentConstraints access control list.
Public property | OptimizerCreateAgentGroupsSUList | Gets the OptimizerCreateAgentGroups access control list.
Public property | OptimizerCreateForecasts | Gets the OptimizerCreateForecasts access control list.
Public property | OptimizerCreateSchedules | Gets the OptimizerCreateSchedules access control list.
Public property | OptimizerCreateShiftRotations | Gets the OptimizerCreateShiftRotations access control list.
Public property | OptimizerCreateShifts | Gets the OptimizerCreateShifts access control list.
Public property | OptimizerCreateTimeOffRequests | Gets the OptimizerCreateTimeOffRequests access control list.
Public property | OptimizerDeleteAgentConstraints | Gets the OptimizerDeleteAgentConstraints access control list.
Public property | OptimizerDeleteAgentGroups | Gets the OptimizerDeleteAgentGroups access control list.
Public property | OptimizerDeleteForecasts | Gets the OptimizerDeleteForecasts access control list.
Public property | OptimizerDeleteSchedules | Gets the OptimizerDeleteSchedules access control list.
Public property | OptimizerDeleteShiftRotations | Gets the OptimizerDeleteShiftRotations access control list.
Public property | OptimizerDeleteShifts | Gets the OptimizerDeleteShifts access control list.
Public property | OptimizerDeleteTimeOffRequests | Gets the OptimizerDeleteTimeOffRequests access control list.
Public property | OptimizerModifyAgentConstraints | Gets the OptimizerModifyAgentConstraints access control list.
Public property | OptimizerModifyAgentGroups | Gets the OptimizerModifyAgentGroups access control list.
Public property | OptimizerModifyForecasts | Gets the OptimizerModifyForecasts access control list.
Public property | OptimizerModifyRealTimeAdherence | Gets the OptimizerModifyRealTimeAdherence access control list.
Public property | OptimizerModifySchedules | Gets the OptimizerModifySchedules access control list.
Public property | OptimizerModifySchedulingUnitConfiguration | Gets the OptimizerModifySchedulingUnitConfiguration access control list.
Public property | OptimizerModifyShiftRotations | Gets the OptimizerModifyShiftRotations access control list.
Public property | OptimizerModifyShifts | Gets the OptimizerModifyShifts access control list.
Public property | OptimizerModifyShiftTrading | Gets the OptimizerModifyShiftTrading access control list.
Public property | OptimizerModifyTimeOffRequests | Gets the OptimizerModifyTimeOffRequests access control list.
Public property | OptimizerSchedulingUnitsList | Obsolete. Gets the OptimizerSchedulingUnitsList access control list.
Public property | OptimizerSchedulingUnitsModifyViewAll | Gets the OptimizerSchedulingUnitsModifyViewAll access control list.
Public property | OptimizerViewAgentConstraints | Gets the OptimizerViewAgentConstraints access control list.
Public property | OptimizerViewAgentGroups | Gets the OptimizerViewAgentGroups access control list.
Public property | OptimizerViewForecasts | Gets the OptimizerViewForecasts access control list.
Public property | OptimizerViewIntradayMonitoring | Gets the OptimizerViewIntradayMonitoring access control list.
Public property | OptimizerViewRealTimeAdherence | Gets the OptimizerViewRealTimeAdherence access control list.
Public property | OptimizerViewSchedulePreferences | Gets the OptimizerViewSchedulePreferences access control list.
Public property | OptimizerViewSchedules | Gets the OptimizerViewSchedules access control list.
Public property | OptimizerViewSchedulingUnitConfiguration | Gets the OptimizerViewSchedulingUnitConfiguration access control list.
Public property | OptimizerViewShiftRotations | Gets the OptimizerViewShiftRotations access control list.
Public property | OptimizerViewShifts | Gets the OptimizerViewShifts access control list.
Public property | OptimizerViewShiftTrading | Gets the OptimizerViewShiftTrading access control list.
Public property | OptimizerViewTimeOffRequests | Gets the OptimizerViewTimeOffRequests access control list.
Public property | PhoneNumberClassificationFollowMeList | Gets the PhoneNumberClassificationList access control list of dial plan phone number classifications that this user can use as follow-me numbers.
Public property | PhoneNumberClassificationForwardList | Gets the PhoneNumberClassificationForwardList access control list of dial plan phone number classifications this user can forward calls to.
Public property | PhoneNumberClassificationList | Gets the PhoneNumberClassificationList access control list of dial plan phone number classifications that this user can use.
Public property | PickupLineQueue | Gets the PickupLineQueue access control list.
Public property | PickupStationQueue | Gets the PickupStationQueue access control list.
Public property | PickupUserQueue | Gets the PickupUserQueue access control list.
Public property | PickupWorkgroupQueue | Gets the PickupWorkgroupQueue access control list.
Public property | PreviewEmailUserQueue | Gets the PreviewEmailUserQueue access control list.
Public property | PreviewEmailWorkgroupQueue | Gets the PreviewEmailWorkgroupQueue access control list.
Public property | RecordLineQueue | Gets the RecordLineQueue access control list.
Public property | RecordStationQueue | Gets the RecordStationQueue access control list.
Public property | RecordUserQueue | Gets the RecordUserQueue access control list.
Public property | RecordWorkgroupQueue | Gets the RecordWorkgroupQueue access control list.
Public property | SnipLineQueue | Gets the SnipLineQueue access control list.
Public property | SnipStationQueue | Gets the SnipStationQueue access control list.
Public property | SnipUserQueue | Gets the SnipUserQueue access control list.
Public property | SnipWorkgroupQueue | Gets the SnipWorkgroupQueue access control list.
Public property | StatusMessageList | Gets the StatusMessages access control list of all status messages that the user can see.
Public property | TransferLineQueue | Gets the TransferLineQueue access control list.
Public property | TransferStationQueue | Gets the TransferStationQueue access control list.
Public property | TransferUserQueue | Gets the TransferUserQueue access control list.
Public property | TransferWorkgroupQueue | Gets the TransferWorkgroupQueue access control list.
Public property | ViewAttendantProfilesInSearch | Gets the ViewAttendantProfilesInSearch access control list.
Public property | ViewGeneralDirectories | Gets the ViewGeneralDirectories access control list.
Public property | ViewIndividualStats | Gets the ViewIndividualStats access control list.
Public property | ViewInSearchStationQueue | Gets the ViewInSearchStationQueue access control list.
Public property | ViewInSearchWorkgroupQueue | Gets the ViewInSearchWorkgroupQueue access control list.
Public property | ViewLineQueueList | Gets the ViewLineQueueList access control list of line queues that this user can view but not modify.
Public property | ViewStationGroups | Gets the ViewStationGroups access control list.
Public property | ViewStationQueueList | Gets the ViewStationQueueList access control list of station queues that this user can view but not modify.
Public property | ViewStatusColumns | Gets the ViewStatusColumns access control list.
Public property | ViewUserQueueList | Gets the ViewUserQueueList access control list of user queues that this user can view but not modify.
Public property | ViewWorkgroupList | Gets the ViewWorkgroupList access control list of workgroups that this user can view but not modify.
Public property | ViewWorkgroupQueueList | Gets the ViewWorkgroupQueueList access control list of workgroup queues that this user can view but not modify.
Public property | ViewWorkgroupStatistics | Gets the ViewWorkgroupStatistics access control list.

See Also

UserAccessListsSettings Class
ININ.IceLib.People Namespace


AccountCodesList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..AccountCodesList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the AccountCodesList access control list. This list value is a ReadOnlyCollection<(Of <(<'T>)>)> of account codes that this user can use.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AccountCode> AccountCodesList { get; }
Visual Basic
Public ReadOnly Property AccountCodesList As ReadOnlyCollection(Of AccountCode)
    Get

Field Value

The account codes list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ActivateSelfList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ActivateSelfList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ActivateSelfList access control list of queues this user can activate.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ActivateSelfList { get; }
Visual Basic
Public ReadOnly Property ActivateSelfList As ReadOnlyCollection(Of String)
    Get

Field Value

The activate self list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ActivateUser Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ActivateUser Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ActivateUser access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ActivateUser { get; }
Visual Basic
Public ReadOnly Property ActivateUser As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ChangeUserStatus Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ChangeUserStatus Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ChangeUserStatus access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ChangeUserStatus { get; }
Visual Basic
Public ReadOnly Property ChangeUserStatus As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ClientButtonsList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ClientButtonsList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ClientButtonsList access control list of call control buttons this user can configure.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ClientButtonsList { get; }
Visual Basic
Public ReadOnly Property ClientButtonsList As ReadOnlyCollection(Of String)
    Get

Field Value

The client buttons list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


CoachLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..CoachLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the CoachLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> CoachLineQueue { get; }
Visual Basic
Public ReadOnly Property CoachLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


CoachStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..CoachStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the CoachStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> CoachStationQueue { get; }
Visual Basic
Public ReadOnly Property CoachStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


CoachUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..CoachUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the CoachUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> CoachUserQueue { get; }
Visual Basic
Public ReadOnly Property CoachUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


CoachWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..CoachWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the CoachWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> CoachWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property CoachWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


DisconnectLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..DisconnectLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the DisconnectLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> DisconnectLineQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


DisconnectStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..DisconnectStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the DisconnectStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> DisconnectStationQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


DisconnectUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..DisconnectUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the DisconnectUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> DisconnectUserQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


DisconnectWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..DisconnectWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the DisconnectWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> DisconnectWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property DisconnectWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


JoinLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..JoinLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the JoinLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> JoinLineQueue { get; }
Visual Basic
Public ReadOnly Property JoinLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


JoinStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..JoinStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the JoinStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> JoinStationQueue { get; }
Visual Basic
Public ReadOnly Property JoinStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


JoinUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..JoinUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the JoinUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> JoinUserQueue { get; }
Visual Basic
Public ReadOnly Property JoinUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


JoinWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..JoinWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the JoinWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> JoinWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property JoinWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ListenLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ListenLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ListenLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ListenLineQueue { get; }
Visual Basic
Public ReadOnly Property ListenLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ListenStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ListenStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ListenStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ListenStationQueue { get; }
Visual Basic
Public ReadOnly Property ListenStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ListenUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ListenUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ListenUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ListenUserQueue { get; }
Visual Basic
Public ReadOnly Property ListenUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ListenWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ListenWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ListenWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ListenWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property ListenWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


LoginStations Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..LoginStations Property
UserAccessListsSettings Class See Also Send Feedback
Gets the LoginStations access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> LoginStations { get; }
Visual Basic
Public ReadOnly Property LoginStations As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ModifyLineQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ModifyLineQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ModifyLineQueueList access control list of line queues that this user can modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyLineQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public ReadOnlyCollection<string> ModifyLineQueueList { get; }
Visual Basic
<ObsoleteAttribute("ModifyLineQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public ReadOnly Property ModifyLineQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The modify line queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ModifyStationGroups Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ModifyStationGroups Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ModifyStationGroups access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ModifyStationGroups { get; }
Visual Basic
Public ReadOnly Property ModifyStationGroups As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ModifyStationQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ModifyStationQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ModifyStationQueueList access control list of station queues that this user can modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyStationQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public ReadOnlyCollection<string> ModifyStationQueueList { get; }
Visual Basic
<ObsoleteAttribute("ModifyStationQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public ReadOnly Property ModifyStationQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The modify station queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ModifyUserQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ModifyUserQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ModifyUserQueueList access control list of user queues that can be modified by this user to make changes to other users' status, pick up calls, and so on.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyUserQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public ReadOnlyCollection<string> ModifyUserQueueList { get; }
Visual Basic
<ObsoleteAttribute("ModifyUserQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public ReadOnly Property ModifyUserQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The modify user queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ModifyWorkgroupQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ModifyWorkgroupQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ModifyWorkgroupQueueList access control list of workgroup queues that can be modified. From these queues the user can pick up, transfer from, etc.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("ModifyWorkgroupQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")]
public ReadOnlyCollection<string> ModifyWorkgroupQueueList { get; }
Visual Basic
<ObsoleteAttribute("ModifyWorkgroupQueueList is deprecated.  Use the more specific Record, Listen, Join, Coach, Pickup, Transfer, and Disconnect rights instead.")> _
Public ReadOnly Property ModifyWorkgroupQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The modify workgroup queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateAgentConstraints Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateAgentConstraints access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateAgentConstraints { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateAgentConstraints As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateAgentGroupsSUList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateAgentGroupsSUList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateAgentGroups access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateAgentGroupsSUList { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateAgentGroupsSUList As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateForecasts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateForecasts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateForecasts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateForecasts { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateForecasts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateSchedules Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateSchedules Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateSchedules access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateSchedules { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateSchedules As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateShiftRotations Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateShiftRotations Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateShiftRotations access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateShiftRotations { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateShiftRotations As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateShifts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateShifts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateShifts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateShifts { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateShifts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerCreateTimeOffRequests Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerCreateTimeOffRequests Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerCreateTimeOffRequests access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerCreateTimeOffRequests { get; }
Visual Basic
Public ReadOnly Property OptimizerCreateTimeOffRequests As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteAgentConstraints Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteAgentConstraints access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteAgentConstraints { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteAgentConstraints As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteAgentGroups Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteAgentGroups Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteAgentGroups access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteAgentGroups { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteAgentGroups As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteForecasts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteForecasts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteForecasts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteForecasts { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteForecasts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteSchedules Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteSchedules Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteSchedules access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteSchedules { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteSchedules As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteShiftRotations Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteShiftRotations Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteShiftRotations access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteShiftRotations { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteShiftRotations As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteShifts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteShifts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteShifts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteShifts { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteShifts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerDeleteTimeOffRequests Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerDeleteTimeOffRequests Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerDeleteTimeOffRequests access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerDeleteTimeOffRequests { get; }
Visual Basic
Public ReadOnly Property OptimizerDeleteTimeOffRequests As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyAgentConstraints Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyAgentConstraints access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyAgentConstraints { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyAgentConstraints As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyAgentGroups Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyAgentGroups Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyAgentGroups access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyAgentGroups { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyAgentGroups As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyForecasts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyForecasts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyForecasts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyForecasts { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyForecasts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyRealTimeAdherence Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyRealTimeAdherence Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyRealTimeAdherence access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyRealTimeAdherence { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyRealTimeAdherence As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifySchedules Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifySchedules Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifySchedules access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifySchedules { get; }
Visual Basic
Public ReadOnly Property OptimizerModifySchedules As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifySchedulingUnitConfiguration Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifySchedulingUnitConfiguration Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifySchedulingUnitConfiguration access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifySchedulingUnitConfiguration { get; }
Visual Basic
Public ReadOnly Property OptimizerModifySchedulingUnitConfiguration As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyShiftRotations Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyShiftRotations Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyShiftRotations access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyShiftRotations { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyShiftRotations As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyShifts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyShifts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyShifts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyShifts { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyShifts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyShiftTrading Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyShiftTrading Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyShiftTrading access control list.

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyShiftTrading { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyShiftTrading As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerModifyTimeOffRequests Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerModifyTimeOffRequests Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerModifyTimeOffRequests access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerModifyTimeOffRequests { get; }
Visual Basic
Public ReadOnly Property OptimizerModifyTimeOffRequests As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerSchedulingUnitsList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerSchedulingUnitsList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerSchedulingUnitsList access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("OptimizerSchedulingUnitsList is no longer used.")]
public ReadOnlyCollection<string> OptimizerSchedulingUnitsList { get; }
Visual Basic
<ObsoleteAttribute("OptimizerSchedulingUnitsList is no longer used.")> _
Public ReadOnly Property OptimizerSchedulingUnitsList As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerSchedulingUnitsModifyViewAll Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerSchedulingUnitsModifyViewAll Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerSchedulingUnitsModifyViewAll access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerSchedulingUnitsModifyViewAll { get; }
Visual Basic
Public ReadOnly Property OptimizerSchedulingUnitsModifyViewAll As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewAgentConstraints Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewAgentConstraints Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewAgentConstraints access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewAgentConstraints { get; }
Visual Basic
Public ReadOnly Property OptimizerViewAgentConstraints As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewAgentGroups Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewAgentGroups Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewAgentGroups access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewAgentGroups { get; }
Visual Basic
Public ReadOnly Property OptimizerViewAgentGroups As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewForecasts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewForecasts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewForecasts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewForecasts { get; }
Visual Basic
Public ReadOnly Property OptimizerViewForecasts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewIntradayMonitoring Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewIntradayMonitoring Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewIntradayMonitoring access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewIntradayMonitoring { get; }
Visual Basic
Public ReadOnly Property OptimizerViewIntradayMonitoring As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewRealTimeAdherence Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewRealTimeAdherence Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewRealTimeAdherence access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewRealTimeAdherence { get; }
Visual Basic
Public ReadOnly Property OptimizerViewRealTimeAdherence As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewSchedulePreferences Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewSchedulePreferences Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewSchedulePreferences access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewSchedulePreferences { get; }
Visual Basic
Public ReadOnly Property OptimizerViewSchedulePreferences As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewSchedules Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewSchedules Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewSchedules access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewSchedules { get; }
Visual Basic
Public ReadOnly Property OptimizerViewSchedules As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewSchedulingUnitConfiguration Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewSchedulingUnitConfiguration Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewSchedulingUnitConfiguration access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewSchedulingUnitConfiguration { get; }
Visual Basic
Public ReadOnly Property OptimizerViewSchedulingUnitConfiguration As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewShiftRotations Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewShiftRotations Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewShiftRotations access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewShiftRotations { get; }
Visual Basic
Public ReadOnly Property OptimizerViewShiftRotations As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewShifts Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewShifts Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewShifts access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewShifts { get; }
Visual Basic
Public ReadOnly Property OptimizerViewShifts As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewShiftTrading Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewShiftTrading Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewShiftTrading access control list.

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewShiftTrading { get; }
Visual Basic
Public ReadOnly Property OptimizerViewShiftTrading As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


OptimizerViewTimeOffRequests Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..OptimizerViewTimeOffRequests Property
UserAccessListsSettings Class See Also Send Feedback
Gets the OptimizerViewTimeOffRequests access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> OptimizerViewTimeOffRequests { get; }
Visual Basic
Public ReadOnly Property OptimizerViewTimeOffRequests As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PhoneNumberClassificationFollowMeList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PhoneNumberClassificationFollowMeList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PhoneNumberClassificationList access control list of dial plan phone number classifications that this user can use as follow-me numbers.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PhoneNumberClassificationFollowMeList { get; }
Visual Basic
Public ReadOnly Property PhoneNumberClassificationFollowMeList As ReadOnlyCollection(Of String)
    Get

Field Value

The phone number classification list.

Remarks

Phone numbers that can be identified by a pattern in the numbers, or an explicit group of phone numbers with a common purpose are called phone number "classifications". For example, internal calls could be identified by the "Internal" classification, toll free (for example, 800 numbers) could be identified by the "Toll Free" classification, and calls to emergency services (such as 911, fire department, police, and hospital) could be identified by the "Emergency" classification.

When IC users configure follow-me numbers, IC matches the number entered with the appropriate classification pattern. It then checks the user's follow-me privileges to determine if the number is authorized.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PhoneNumberClassificationForwardList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PhoneNumberClassificationForwardList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PhoneNumberClassificationForwardList access control list of dial plan phone number classifications this user can forward calls to.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PhoneNumberClassificationForwardList { get; }
Visual Basic
Public ReadOnly Property PhoneNumberClassificationForwardList As ReadOnlyCollection(Of String)
    Get

Field Value

The phone number classification forward list.

Remarks

Phone numbers that can be identified by a pattern in the numbers, or an explicit group of phone numbers with a common purpose are called phone number "classifications". For example, internal calls could be identified by the "Internal" classification, toll free (for example, 800 numbers) could be identified by the "Toll Free" classification, and calls to emergency services (such as 911, fire department, police, and hospital) could be identified by the "Emergency" classification.

When IC users set a Forward Number, IC matches the number with the appropriate classification pattern. It then checks the user's forwarding privileges to determine if the number is authorized.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PhoneNumberClassificationList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PhoneNumberClassificationList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PhoneNumberClassificationList access control list of dial plan phone number classifications that this user can use.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PhoneNumberClassificationList { get; }
Visual Basic
Public ReadOnly Property PhoneNumberClassificationList As ReadOnlyCollection(Of String)
    Get

Field Value

The phone number classification list.

Remarks

Phone numbers that can be identified by a pattern in the numbers, or an explicit group of phone numbers with a common purpose are called phone number "classifications". For example, internal calls could be identified by the "Internal" classification, toll free (for example, 800 numbers) could be identified by the "Toll Free" classification, and calls to emergency services (such as 911, fire department, police, and hospital) could be identified by the "Emergency" classification.

When IC users dial a phone number, IC matches the number dialed with the appropriate classification pattern. It then checks the user's dialing privileges to determine if the user or station is authorized to place the call. In this way, IC uses phone number classifications to control individual users, workgroups, roles, and station dialing privileges.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PickupLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PickupLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PickupLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PickupLineQueue { get; }
Visual Basic
Public ReadOnly Property PickupLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PickupStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PickupStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PickupStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PickupStationQueue { get; }
Visual Basic
Public ReadOnly Property PickupStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PickupUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PickupUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PickupUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PickupUserQueue { get; }
Visual Basic
Public ReadOnly Property PickupUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PickupWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PickupWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PickupWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PickupWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property PickupWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PreviewEmailUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PreviewEmailUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PreviewEmailUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PreviewEmailUserQueue { get; }
Visual Basic
Public ReadOnly Property PreviewEmailUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


PreviewEmailWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..PreviewEmailWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the PreviewEmailWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PreviewEmailWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property PreviewEmailWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


RecordLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..RecordLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the RecordLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> RecordLineQueue { get; }
Visual Basic
Public ReadOnly Property RecordLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


RecordStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..RecordStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the RecordStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> RecordStationQueue { get; }
Visual Basic
Public ReadOnly Property RecordStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


RecordUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..RecordUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the RecordUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> RecordUserQueue { get; }
Visual Basic
Public ReadOnly Property RecordUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


RecordWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..RecordWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the RecordWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> RecordWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property RecordWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


SnipLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..SnipLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the SnipLineQueue access control list.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> SnipLineQueue { get; }
Visual Basic
Public ReadOnly Property SnipLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


SnipStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..SnipStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the SnipStationQueue access control list.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> SnipStationQueue { get; }
Visual Basic
Public ReadOnly Property SnipStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


SnipUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..SnipUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the SnipUserQueue access control list.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> SnipUserQueue { get; }
Visual Basic
Public ReadOnly Property SnipUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


SnipWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..SnipWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the SnipWorkgroupQueue access control list.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> SnipWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property SnipWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


StatusMessageList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..StatusMessageList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the StatusMessages access control list of all status messages that the user can see.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> StatusMessageList { get; }
Visual Basic
Public ReadOnly Property StatusMessageList As ReadOnlyCollection(Of String)
    Get

Field Value

The list of status messages.

Remarks

Status messages are filtered by workgroup so that the list of status messages the user can see is the union of all status messages from their assigned workgroup.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


TransferLineQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..TransferLineQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the TransferLineQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> TransferLineQueue { get; }
Visual Basic
Public ReadOnly Property TransferLineQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


TransferStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..TransferStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the TransferStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> TransferStationQueue { get; }
Visual Basic
Public ReadOnly Property TransferStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


TransferUserQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..TransferUserQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the TransferUserQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> TransferUserQueue { get; }
Visual Basic
Public ReadOnly Property TransferUserQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


TransferWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..TransferWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the TransferWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> TransferWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property TransferWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewAttendantProfilesInSearch Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewAttendantProfilesInSearch Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewAttendantProfilesInSearch access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewAttendantProfilesInSearch { get; }
Visual Basic
Public ReadOnly Property ViewAttendantProfilesInSearch As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewGeneralDirectories Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewGeneralDirectories Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewGeneralDirectories access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewGeneralDirectories { get; }
Visual Basic
Public ReadOnly Property ViewGeneralDirectories As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewIndividualStats Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewIndividualStats Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewIndividualStats access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewIndividualStats { get; }
Visual Basic
Public ReadOnly Property ViewIndividualStats As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewInSearchStationQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewInSearchStationQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewInSearchStationQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewInSearchStationQueue { get; }
Visual Basic
Public ReadOnly Property ViewInSearchStationQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewInSearchWorkgroupQueue Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewInSearchWorkgroupQueue Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewInSearchWorkgroupQueue access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewInSearchWorkgroupQueue { get; }
Visual Basic
Public ReadOnly Property ViewInSearchWorkgroupQueue As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewLineQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewLineQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewLineQueueList access control list of line queues that this user can view but not modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewLineQueueList { get; }
Visual Basic
Public ReadOnly Property ViewLineQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The view line queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewStationGroups Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewStationGroups Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewStationGroups access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewStationGroups { get; }
Visual Basic
Public ReadOnly Property ViewStationGroups As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewStationQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewStationQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewStationQueueList access control list of station queues that this user can view but not modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewStationQueueList { get; }
Visual Basic
Public ReadOnly Property ViewStationQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The view station queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewStatusColumns Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewStatusColumns Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewStatusColumns access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewStatusColumns { get; }
Visual Basic
Public ReadOnly Property ViewStatusColumns As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewUserQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewUserQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewUserQueueList access control list of user queues that this user can view but not modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewUserQueueList { get; }
Visual Basic
Public ReadOnly Property ViewUserQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The view user queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewWorkgroupList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewWorkgroupList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewWorkgroupList access control list of workgroups that this user can view but not modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewWorkgroupList { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroupList As ReadOnlyCollection(Of String)
    Get

Field Value

The view workgroup list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewWorkgroupQueueList Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewWorkgroupQueueList Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewWorkgroupQueueList access control list of workgroup queues that this user can view but not modify.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewWorkgroupQueueList { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroupQueueList As ReadOnlyCollection(Of String)
    Get

Field Value

The view workgroup queue list.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


ViewWorkgroupStatistics Property

[image]

IceLib Technical Reference
UserAccessListsSettings..::..ViewWorkgroupStatistics Property
UserAccessListsSettings Class See Also Send Feedback
Gets the ViewWorkgroupStatistics access control list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewWorkgroupStatistics { get; }
Visual Basic
Public ReadOnly Property ViewWorkgroupStatistics As ReadOnlyCollection(Of String)
    Get

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserAccessListsSettings Class
UserAccessListsSettings Members
ININ.IceLib.People Namespace


UserAccessListsSettings Events

[image] [image]

IceLib Technical Reference
UserAccessListsSettings Events
UserAccessListsSettings Class See Also Send Feedback

The UserAccessListsSettings type exposes the following members.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserAccessListsSettings Class
ININ.IceLib.People Namespace


UserDataAttributes Class

[image]

IceLib Technical Reference
UserDataAttributes Class
Members See Also Send Feedback
Attribute strings for the UserDataSettings watched class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class UserDataAttributes
Visual Basic
Public NotInheritable Class UserDataAttributes

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the UserDataSettings class.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserDataAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Members
ININ.IceLib.People Namespace
ININ.IceLib.People..::..UserDataSettings


UserDataAttributes Members

[image] [image]

IceLib Technical Reference
UserDataAttributes Members
UserDataAttributes Class Fields See Also Send Feedback

The UserDataAttributes type exposes the following members.

Fields

Name | Description
AllowedClassificationList | List of classifications that the user is allowed to monitor.
ExternalSystemConfigurations | List of External Systems this user is configured for.
LaunchableProcessList | List of processes that a user can launch.
ManageProcessList | List of processes that a user can manage.
PlayAcdAgentGreeting | Indicates whether the agent's greeting ("smile") prompt should be played for callers at the beginning of every ACD call to this agent.
SupervisedWorkgroups | List of workgroups supervised by the user.
ViewProcessList | List of processes that a user can view.
Workgroups | List of workgroups this user is a member of.

See Also

UserDataAttributes Class
ININ.IceLib.People Namespace


UserDataAttributes Fields

[image] [image]

IceLib Technical Reference
UserDataAttributes Fields
UserDataAttributes Class See Also Send Feedback

The UserDataAttributes type exposes the following members.

Fields

Name | Description
AllowedClassificationList | List of classifications that the user is allowed to monitor.
ExternalSystemConfigurations | List of External Systems this user is configured for.
LaunchableProcessList | List of processes that a user can launch.
ManageProcessList | List of processes that a user can manage.
PlayAcdAgentGreeting | Indicates whether the agent's greeting ("smile") prompt should be played for callers at the beginning of every ACD call to this agent.
SupervisedWorkgroups | List of workgroups supervised by the user.
ViewProcessList | List of processes that a user can view.
Workgroups | List of workgroups this user is a member of.

See Also

UserDataAttributes Class
ININ.IceLib.People Namespace


AllowedClassificationList Field

[image]

IceLib Technical Reference
UserDataAttributes..::..AllowedClassificationList Field
UserDataAttributes Class See Also Send Feedback
List of classifications that the user is allowed to monitor.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AllowedClassificationList
Visual Basic
Public Shared ReadOnly AllowedClassificationList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


ExternalSystemConfigurations Field

[image]

IceLib Technical Reference
UserDataAttributes..::..ExternalSystemConfigurations Field
UserDataAttributes Class See Also Send Feedback
List of External Systems this user is configured for.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ExternalSystemConfigurations
Visual Basic
Public Shared ReadOnly ExternalSystemConfigurations As String

Remarks

Users may be configured for external system integrations. This includes data pertinent to these integrated systems.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 4 and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


LaunchableProcessList Field

[image]

IceLib Technical Reference
UserDataAttributes..::..LaunchableProcessList Field
UserDataAttributes Class See Also Send Feedback
List of processes that a user can launch.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string LaunchableProcessList
Visual Basic
Public Shared ReadOnly LaunchableProcessList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


ManageProcessList Field

[image]

IceLib Technical Reference
UserDataAttributes..::..ManageProcessList Field
UserDataAttributes Class See Also Send Feedback
List of processes that a user can manage.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ManageProcessList
Visual Basic
Public Shared ReadOnly ManageProcessList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


PlayAcdAgentGreeting Field

[image]

IceLib Technical Reference
UserDataAttributes..::..PlayAcdAgentGreeting Field
UserDataAttributes Class See Also Send Feedback
Indicates whether the agent's greeting ("smile") prompt should be played for callers at the beginning of every ACD call to this agent.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PlayAcdAgentGreeting
Visual Basic
Public Shared ReadOnly PlayAcdAgentGreeting As String

Remarks

When trueTruetruetrue (True in Visual Basic), the agent's greeting is played for callers at the beginning of every ACD call sent to the agent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


SupervisedWorkgroups Field

[image]

IceLib Technical Reference
UserDataAttributes..::..SupervisedWorkgroups Field
UserDataAttributes Class See Also Send Feedback
List of workgroups supervised by the user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string SupervisedWorkgroups
Visual Basic
Public Shared ReadOnly SupervisedWorkgroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


ViewProcessList Field

[image]

IceLib Technical Reference
UserDataAttributes..::..ViewProcessList Field
UserDataAttributes Class See Also Send Feedback
List of processes that a user can view.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewProcessList
Visual Basic
Public Shared ReadOnly ViewProcessList As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


Workgroups Field

[image]

IceLib Technical Reference
UserDataAttributes..::..Workgroups Field
UserDataAttributes Class See Also Send Feedback
List of workgroups this user is a member of.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Workgroups
Visual Basic
Public Shared ReadOnly Workgroups As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataAttributes Class
UserDataAttributes Members
ININ.IceLib.People Namespace


UserDataSettings Class

[image]

IceLib Technical Reference
UserDataSettings Class
Members See Also Send Feedback
Represents miscellaneous data settings for an IC user, such as the user's workgroup membership, supervisory rights, and greeting preference. These settings are configured in Interaction Administrator.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserDataSettings : UserSettings
Visual Basic
Public Class UserDataSettings _
    Inherits UserSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserSettings
ININ.IceLib.People..::..UserDataSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Members
ININ.IceLib.People Namespace


UserDataSettings Members

[image] [image]

IceLib Technical Reference
UserDataSettings Members
UserDataSettings Class Constructors Methods Properties Events See Also Send Feedback

The UserDataSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserDataSettings | Initializes a new instance of the UserDataSettings class for the current session user.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowedClassificationList | Gets the AllowedClassificationList value.
Public property | ExternalSystemConfigurations | Gets the ExternalSystemConfigurations value.
Public property | LaunchableProcessList | Gets the LaunchableProcessList value.
Public property | ManageProcessList | Gets the ManageProcessList value.
Public property | PlayAcdAgentGreeting | Gets the PlayAcdAgentGreeting value.
Public property | SupervisedWorkgroups | Gets the SupervisedWorkgroups for the user.
Public property | ViewProcessList | Gets the ViewProcessList value.
Public property | Workgroups | Gets the Workgroups the user is a member of.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserDataSettings Class
ININ.IceLib.People Namespace


UserDataSettings Constructor

[image]

IceLib Technical Reference
UserDataSettings Constructor
UserDataSettings Class See Also Send Feedback
Initializes a new instance of the UserDataSettings class for the current session user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserDataSettings(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


UserDataSettings Methods

[image] [image]

IceLib Technical Reference
UserDataSettings Methods
UserDataSettings Class See Also Send Feedback

The UserDataSettings type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserDataSettings Class
ININ.IceLib.People Namespace


UserDataSettings Properties

[image] [image]

IceLib Technical Reference
UserDataSettings Properties
UserDataSettings Class See Also Send Feedback

The UserDataSettings type exposes the following members.

Properties

 | Name | Description
Public property | AllowedClassificationList | Gets the AllowedClassificationList value.
Public property | ExternalSystemConfigurations | Gets the ExternalSystemConfigurations value.
Public property | LaunchableProcessList | Gets the LaunchableProcessList value.
Public property | ManageProcessList | Gets the ManageProcessList value.
Public property | PlayAcdAgentGreeting | Gets the PlayAcdAgentGreeting value.
Public property | SupervisedWorkgroups | Gets the SupervisedWorkgroups for the user.
Public property | ViewProcessList | Gets the ViewProcessList value.
Public property | Workgroups | Gets the Workgroups the user is a member of.

See Also

UserDataSettings Class
ININ.IceLib.People Namespace


AllowedClassificationList Property

[image]

IceLib Technical Reference
UserDataSettings..::..AllowedClassificationList Property
UserDataSettings Class See Also Send Feedback
Gets the AllowedClassificationList value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> AllowedClassificationList { get; }
Visual Basic
Public ReadOnly Property AllowedClassificationList As ReadOnlyCollection(Of String)
    Get

Field Value

The list of classifications that the user can watch.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


ExternalSystemConfigurations Property

[image]

IceLib Technical Reference
UserDataSettings..::..ExternalSystemConfigurations Property
UserDataSettings Class See Also Send Feedback
Gets the ExternalSystemConfigurations value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ExternalSystemConfigurations ExternalSystemConfigurations { get; }
Visual Basic
Public ReadOnly Property ExternalSystemConfigurations As ExternalSystemConfigurations
    Get

Field Value

The list of external system configurations.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 4 and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


LaunchableProcessList Property

[image]

IceLib Technical Reference
UserDataSettings..::..LaunchableProcessList Property
UserDataSettings Class See Also Send Feedback
Gets the LaunchableProcessList value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> LaunchableProcessList { get; }
Visual Basic
Public ReadOnly Property LaunchableProcessList As ReadOnlyCollection(Of String)
    Get

Field Value

The list of processes that the user can launch.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


ManageProcessList Property

[image]

IceLib Technical Reference
UserDataSettings..::..ManageProcessList Property
UserDataSettings Class See Also Send Feedback
Gets the ManageProcessList value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ManageProcessList { get; }
Visual Basic
Public ReadOnly Property ManageProcessList As ReadOnlyCollection(Of String)
    Get

Field Value

The list of processes that the user can manage.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


PlayAcdAgentGreeting Property

[image]

IceLib Technical Reference
UserDataSettings..::..PlayAcdAgentGreeting Property
UserDataSettings Class See Also Send Feedback
Gets the PlayAcdAgentGreeting value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PlayAcdAgentGreeting { get; }
Visual Basic
Public ReadOnly Property PlayAcdAgentGreeting As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if should play an ACD agent greeting; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


SupervisedWorkgroups Property

[image]

IceLib Technical Reference
UserDataSettings..::..SupervisedWorkgroups Property
UserDataSettings Class See Also Send Feedback
Gets the SupervisedWorkgroups for the user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> SupervisedWorkgroups { get; }
Visual Basic
Public ReadOnly Property SupervisedWorkgroups As ReadOnlyCollection(Of String)
    Get

Field Value

The supervised workgroups.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


ViewProcessList Property

[image]

IceLib Technical Reference
UserDataSettings..::..ViewProcessList Property
UserDataSettings Class See Also Send Feedback
Gets the ViewProcessList value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewProcessList { get; }
Visual Basic
Public ReadOnly Property ViewProcessList As ReadOnlyCollection(Of String)
    Get

Field Value

The list of processes that the user can view.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


Workgroups Property

[image]

IceLib Technical Reference
UserDataSettings..::..Workgroups Property
UserDataSettings Class See Also Send Feedback
Gets the Workgroups the user is a member of.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Workgroups { get; }
Visual Basic
Public ReadOnly Property Workgroups As ReadOnlyCollection(Of String)
    Get

Field Value

The workgroups.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserDataSettings Class
UserDataSettings Members
ININ.IceLib.People Namespace


UserDataSettings Events

[image] [image]

IceLib Technical Reference
UserDataSettings Events
UserDataSettings Class See Also Send Feedback

The UserDataSettings type exposes the following members.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserDataSettings Class
ININ.IceLib.People Namespace


UserEntry Class

[image]

IceLib Technical Reference
UserEntry Class
Members See Also Send Feedback
Represents a user entry watched object. For example, their display name, company, extension, etc. Object instances of this class are managed by the UserEntryList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserEntry
Visual Basic
Public Class UserEntry

Remarks

Each property is represented by an integer value within the UserEntryProperty enumeration. The user's entry contains information such as a display name, department, and home site, and so on.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Members
ININ.IceLib.People Namespace


UserEntry Members

[image] [image]

IceLib Technical Reference
UserEntry Members
UserEntry Class Methods Properties See Also Send Feedback

The UserEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Company | Gets the Company.
Public property | DefaultWorkstation | Gets the default Workstation.
Public property | Department | Gets the Department.
Public property | DisplayName | Gets the display name.
Public property | Extension | Gets the Extension.
Public property | HomeSite | Gets the HomeSite.
Public property | UserId | The unique identifier for this user entry. This is the IC User ID.

See Also

UserEntry Class
ININ.IceLib.People Namespace


UserEntry Methods

[image] [image]

IceLib Technical Reference
UserEntry Methods
UserEntry Class See Also Send Feedback

The UserEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserEntry Class
ININ.IceLib.People Namespace


UserEntry Properties

[image] [image]

IceLib Technical Reference
UserEntry Properties
UserEntry Class See Also Send Feedback

The UserEntry type exposes the following members.

Properties

 | Name | Description
Public property | Company | Gets the Company.
Public property | DefaultWorkstation | Gets the default Workstation.
Public property | Department | Gets the Department.
Public property | DisplayName | Gets the display name.
Public property | Extension | Gets the Extension.
Public property | HomeSite | Gets the HomeSite.
Public property | UserId | The unique identifier for this user entry. This is the IC User ID.

See Also

UserEntry Class
ININ.IceLib.People Namespace


Company Property

[image]

IceLib Technical Reference
UserEntry..::..Company Property
UserEntry Class See Also Send Feedback
Gets the Company.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; }
Visual Basic
Public ReadOnly Property Company As String
    Get

Field Value

The Company.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


DefaultWorkstation Property

[image]

IceLib Technical Reference
UserEntry..::..DefaultWorkstation Property
UserEntry Class See Also Send Feedback
Gets the default Workstation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultWorkstation { get; }
Visual Basic
Public ReadOnly Property DefaultWorkstation As String
    Get

Field Value

The DefaultWorkstation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 4 and beyond.
For 2.4, supported for IC Server version 2.4 SU 33 and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


Department Property

[image]

IceLib Technical Reference
UserEntry..::..Department Property
UserEntry Class See Also Send Feedback
Gets the Department.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; }
Visual Basic
Public ReadOnly Property Department As String
    Get

Field Value

The Department.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


DisplayName Property

[image]

IceLib Technical Reference
UserEntry..::..DisplayName Property
UserEntry Class See Also Send Feedback
Gets the display name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


Extension Property

[image]

IceLib Technical Reference
UserEntry..::..Extension Property
UserEntry Class See Also Send Feedback
Gets the Extension.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The Extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


HomeSite Property

[image]

IceLib Technical Reference
UserEntry..::..HomeSite Property
UserEntry Class See Also Send Feedback
Gets the HomeSite.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeSite { get; }
Visual Basic
Public ReadOnly Property HomeSite As String
    Get

Field Value

The HomeSite.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


UserId Property

[image]

IceLib Technical Reference
UserEntry..::..UserId Property
UserEntry Class See Also Send Feedback
The unique identifier for this user entry. This is the IC User ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntry Class
UserEntry Members
ININ.IceLib.People Namespace


UserEntryList Class

[image]

IceLib Technical Reference
UserEntryList Class
Members See Also Send Feedback
Represents a list of watched user entries (UserEntry).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserEntryList
Visual Basic
Public Class UserEntryList

Remarks

This class allows you to start, stop, and change watches on the user entry for a number of users. To start a watch for an array of users, call StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) methods with an array of user IDs. When the asynchronous start watch operation completes, the completedCallback delegate is invoked.

You can change the users for which you want to monitor their entry by calling the ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedUsersAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) methods and passing an array of user IDs. When the asynchronous change watch operation completes, the completedCallback delegate is invoked.

You can stop watching user entry by calling the StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods. When the asynchronous stop watch operation completes the completedCallback delegate is invoked.

To get the list of watched user entries, call the GetList()()()() method. An InvalidOperationException is raised if a watch is not in progress.

When a user entry changes, the WatchedObjectsChanged event is triggered, providing information on the user entry that has changed.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) when a watch has already been started, or calling ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean), ChangeWatchedUsersAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object), StopWatching()()()(), or StopWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is not in progress raises the InvalidOperationException.

Note
The asynchronous methods are preferred since the start, change, and stop watch can be lengthy operations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserEntryList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Members
ININ.IceLib.People Namespace


UserEntryList Members

[image] [image]

IceLib Technical Reference
UserEntryList Members
UserEntryList Class Constructors Methods Properties Events See Also Send Feedback

The UserEntryList type exposes the following members.

Constructors

 | Name | Description
Public method | UserEntryList | Initializes a new instance of the UserEntryList class.

Methods

 | Name | Description
Public method | ChangeWatchedUsers | Changes the users being watched.
Public method | ChangeWatchedUsersAsync | Asynchronously changes the users being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of user entries being watched.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the User Entry List.
Public method | StartWatchingAsync | Asynchronously starts watching the User Entry List.
Public method | StopWatching | Stops watching the User Entry List.
Public method | StopWatchingAsync | Asynchronously stops watching the User Entry List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get an individual entry for a user.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the UserEntry watched objects has changed or has been removed.

See Also

UserEntryList Class
ININ.IceLib.People Namespace


UserEntryList Constructor

[image]

IceLib Technical Reference
UserEntryList Constructor
UserEntryList Class See Also Send Feedback
Initializes a new instance of the UserEntryList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserEntryList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


UserEntryList Methods

[image] [image]

IceLib Technical Reference
UserEntryList Methods
UserEntryList Class See Also Send Feedback

The UserEntryList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedUsers | Changes the users being watched.
Public method | ChangeWatchedUsersAsync | Asynchronously changes the users being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of user entries being watched.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the User Entry List.
Public method | StartWatchingAsync | Asynchronously starts watching the User Entry List.
Public method | StopWatching | Stops watching the User Entry List.
Public method | StopWatchingAsync | Asynchronously stops watching the User Entry List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserEntryList Class
ININ.IceLib.People Namespace


ChangeWatchedUsers Method

[image]

IceLib Technical Reference
UserEntryList..::..ChangeWatchedUsers Method
UserEntryList Class See Also Send Feedback
Changes the users being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedUsers(
    string[] userIDsToAdd,
    string[] userIDsToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedUsers ( _
    userIDsToAdd As String(), _
    userIDsToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

userIDsToAdd
Type: array<System..::..String>[]()[][]
The user IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
userIDsToRemove
Type: array<System..::..String>[]()[][]
The user IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


ChangeWatchedUsersAsync Method

[image]

IceLib Technical Reference
UserEntryList..::..ChangeWatchedUsersAsync Method
UserEntryList Class See Also Send Feedback
Asynchronously changes the users being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedUsersAsync(
    string[] userIDsToAdd,
    string[] userIDsToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedUsersAsync ( _
    userIDsToAdd As String(), _
    userIDsToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIDsToAdd
Type: array<System..::..String>[]()[][]
The user IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
userIDsToRemove
Type: array<System..::..String>[]()[][]
The user IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


GetList Method

[image]

IceLib Technical Reference
UserEntryList..::..GetList Method
UserEntryList Class See Also Send Feedback
Get a list of user entries being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<UserEntry> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of UserEntry)

Return Value

A list of UserEntry.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | If the user entry list is not cached.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
UserEntryList..::..IsWatching Method
UserEntryList Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
UserEntryList..::..IsWatching Method
UserEntryList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
UserEntryList..::..IsWatching Method (String)
UserEntryList Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string userId
)
Visual Basic
Public Function IsWatching ( _
    userId As String _
) As Boolean

Parameters

userId
Type: System..::..String
The user.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
IsWatching Overload
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
UserEntryList..::..StartWatching Method
UserEntryList Class See Also Send Feedback
Starts watching the User Entry List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] userIds
)
Visual Basic
Public Sub StartWatching ( _
    userIds As String() _
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
An array of user IDs for watching user entry.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
UserEntryList..::..StartWatchingAsync Method
UserEntryList Class See Also Send Feedback
Asynchronously starts watching the User Entry List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] userIds,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    userIds As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
An array of user IDs for watching user entry.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
UserEntryList..::..StopWatching Method
UserEntryList Class See Also Send Feedback
Stops watching the User Entry List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
UserEntryList..::..StopWatchingAsync Method
UserEntryList Class See Also Send Feedback
Asynchronously stops watching the User Entry List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


UserEntryList Properties

[image] [image]

IceLib Technical Reference
UserEntryList Properties
UserEntryList Class See Also Send Feedback

The UserEntryList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Get an individual entry for a user.

See Also

UserEntryList Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
UserEntryList..::..Item Property
UserEntryList Class See Also Send Feedback
Get an individual entry for a user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserEntry this[
    string userId
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    userId As String _
) As UserEntry
    Get

Parameters

userId
Type: System..::..String
The entry to get.

Field Value

The entry details.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | If the requested userId is not in the cache.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


UserEntryList Events

[image] [image]

IceLib Technical Reference
UserEntryList Events
UserEntryList Class See Also Send Feedback

The UserEntryList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the UserEntry watched objects has changed or has been removed.

See Also

UserEntryList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
UserEntryList..::..WatchedObjectsChanged Event
UserEntryList Class See Also Send Feedback
Occurs when one of the UserEntry watched objects has changed or has been removed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedObjectsEventArgs<UserEntryProperty>> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of WatchedObjectsEventArgs(Of UserEntryProperty))

Remarks

Note that only changes to existing objects in the watch are monitored. There are no objects added to the UserEntryList watched objects.

Each Changed notification for a UserEntry object is described by the integer values defined in the UserEntryProperty enumeration.

This event will only occur when users being watched have changed or have been removed. To start watching for users call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which users are being watched once the watch has been started, use the ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserEntryList Class
UserEntryList Members
ININ.IceLib.People Namespace


UserEntryProperty Enumeration

[image]

IceLib Technical Reference
UserEntryProperty Enumeration
See Also Send Feedback
Each value in this enumeration represents a property in UserEntry.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum UserEntryProperty
Visual Basic
Public Enumeration UserEntryProperty

Members

Member name | Value | Description
None | 0 | No property is defined.
UserId | 1 | Represents the UserId property.
DisplayName | 2 | Represents the DisplayName property.
Company | 3 | Represents the Company property.
Department | 4 | Represents the Department property.
Extension | 5 | Represents the Extension property.
HomeSite | 6 | Represents the HomeSite property.
DefaultWorkstation | 7 | Represents the DefaultWorkstation property. This enumeration item will work in 2.4 SU 33 & beyond and 3.0 SU 4 & beyond.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


UserRightsAttributes Class

[image]

IceLib Technical Reference
UserRightsAttributes Class
Members See Also Send Feedback
Attribute strings for the UserRightsSettings watched class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class UserRightsAttributes
Visual Basic
Public NotInheritable Class UserRightsAttributes

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the UserRightsSettings class.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserRightsAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Members
ININ.IceLib.People Namespace
ININ.IceLib.People..::..UserRightsSettings


UserRightsAttributes Members

[image] [image]

IceLib Technical Reference
UserRightsAttributes Members
UserRightsAttributes Class Fields See Also Send Feedback

The UserRightsAttributes type exposes the following members.

Fields

Name | Description
AllowAccessToProblemReporter | Allows the user to use ProblemReporter.
AllowForceUserLogout | Provides access to Force User Logout.
AllowIntercomChat | Allows users to use intercom chat.
AllowMiniMode | Allows the user to user mini mode.
CanAccessAllConferences | Provides access to all conferences.
CanAccessOptimizerShiftTrading | This right controls if an agent with optimizer thinclient plugin license would be able to access shift trading feature.
CanAccessOrbitQueue | Permits access to orbit queue.
CanAccessOwnConferences | Provides access to conferences that the user owns.
CanAccessPersonalRules | Provides access to personal rules.
CanAccessResponseManagement | Permits access to response management.
CanAccessTrackerInteractions | Permits access to tracker interactions.
CanAccessWorkgroupProfilesTab | Permits access to workgroups / profiles tab.
CanChangePhoneticSettings | Allows the user to modify the phonetic spellings for their name.
CanCoachInteractions | Permits the user to add themselves to another agent's call on any user or station queue they have permission to monitor.
CanCreateConferenceCalls | Permits access to create conference calls.
CanCreateOptimizerActivityCodes | This right controls if a user can create optimizer activity codes.
CanCreateOptimizerDayClassifications | This right controls if a user can create optimizer day classifications.
CanCreateOptimizerSchedulingUnit | This right controls if a user can create an optimizer scheduling unit.
CanCreateSpeedDials | Permits access to create speed dials.
CanCreateStatusNotes | Permits access to create status notes.
CanCustomizeClient | Allows the user to customize their client.
CanDeleteOptimizerActivityCodes | This right controls if a user can delete optimizer activity codes.
CanDeleteOptimizerDayClassifications | This right controls if a user can delete optimizer day classifications.
CanDeleteOptimizerSchedulingUnit | This right controls if a user can delete an optimizer scheduling unit.
CanDisconnectInteractions | Permits the user to disconnect the current call.
CanHavePrivateInteractions | Allows the user to view the private button and to prevent other users from recording or listening to their conversation.
CanHoldInteractions | Permits users to place the selected call on hold.
CanInitiateSecureInput | Permits users to initiate a secure input session.
CanJoinInteractions | Permits users who are supervisors to join in on an interaction between other agents.
CanListenOnInteraction | Allows the user to view the listen button and to listen to another interaction.
CanModifyOptimizerActivityCodes | This right controls if a user can modify optimizer activity codes.
CanModifyOptimizerDayClassifications | This right controls if a user can modify optimizer day classifications.
CanModifyOptimizerStatusToActivityTypeMapping | This right controls if a user can modify optimizer status to activity type mapping.
CanMuteInteractions | Permits the user to disable the mouthpiece on their telephones so that the other party or parties cannot hear what is being said.
CanParkInteractions | Permits users to park interactions.
CanPauseInteractions | Permits users to control a recording session by stopping the session.
CanPickupInteractions | Permits users to answer the current call, or to take the current call off hold.
CanRecordInteraction | Allows the user to view the record button.
CanRequestSupervisorAssistance | Permits users who are members of a distribution queue to request assistance from a supervisor.
CanSecureRecordingPauseInteractions | Permits users to control all recording sessions by pausing each session for an administrator configured period of time.
CanSendInteractionsToVoicemail | Permits users to send an interaction to their voice mail account.
CanShowAssistanceButton | Allows users that are members of a distribution queue to view the assistance button.
CanShowCoachButton | Allows the user to view the coach button.
CanShowDisconnectButton | Allows the user to view the disconnect button.
CanShowHoldButton | Allows the user to view the hold button.
CanShowJoinButton | Allows the user to view the join button.
CanShowMuteButton | Allows the user to view the mute button.
CanShowParkButton | Allows the user to view the park button.
CanShowPauseButton | Allows the user to view the pause button for a recording session.
CanShowPickupButton | Allows the user to view the pickup button.
CanShowRecordingSnipButton | Allows the user to view the recording snip button.
CanShowSecureInputButton | Allows users to view the secure input button.
CanShowSecureRecordingPauseButton | Allows the user to view the Secure Recording Pause button.
CanShowTransferButton | Allows the user to view the transfer button.
CanShowVoicemailButton | Allows the user to view the voice mail button.
CanSnipRecording | Permits the user to create a recording snippet for the current interaction.
CanSubmitTimeOff | This right controls if an agent with optimizer thinclient plugin license would be able to create, edit, or delete time off requests.
CanTransferInteractions | Permits users to open the transfer window where they can select a transfer recipient and the type of transfer operation they want to perform.
CanViewOptimizerActivityCodes | This right controls if a user can view optimizer activity codes.
CanViewOptimizerDayClassifications | This right controls if a user can view optimizer day classifications.
CanViewOptimizerStatusToActivityTypeMapping | This right controls if a user can view optimizer status to activity type mapping.
CloudWorkforceEngagementAdministrator | Permits the user to administer Genesys Cloud Workforce Engagement components.
ConfiguredForOutlookIntegration | This right specificies if the user is configured for Outlook Integration.
MinimizeClientToNotificationArea | Should the client be minimized to notification area instead of taskbar.
PersistentConnection | Allows the user to start a remote client with the persistent option.
ShowAgentPreferences | This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Preferences" menu item.
ShowAgentRank | This right controls if an agent can see his rank in optimizer agent group
ShowAgentRelativeRank | This right controls if an agent can see his relative rank in optimizer agent group
ShowMonitorColumns | Allows the user to show monitor columns.
ShowScheduleBidding | This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Bidding" menu item

See Also

UserRightsAttributes Class
ININ.IceLib.People Namespace


UserRightsAttributes Fields

[image] [image]

IceLib Technical Reference
UserRightsAttributes Fields
UserRightsAttributes Class See Also Send Feedback

The UserRightsAttributes type exposes the following members.

Fields

Name | Description
AllowAccessToProblemReporter | Allows the user to use ProblemReporter.
AllowForceUserLogout | Provides access to Force User Logout.
AllowIntercomChat | Allows users to use intercom chat.
AllowMiniMode | Allows the user to user mini mode.
CanAccessAllConferences | Provides access to all conferences.
CanAccessOptimizerShiftTrading | This right controls if an agent with optimizer thinclient plugin license would be able to access shift trading feature.
CanAccessOrbitQueue | Permits access to orbit queue.
CanAccessOwnConferences | Provides access to conferences that the user owns.
CanAccessPersonalRules | Provides access to personal rules.
CanAccessResponseManagement | Permits access to response management.
CanAccessTrackerInteractions | Permits access to tracker interactions.
CanAccessWorkgroupProfilesTab | Permits access to workgroups / profiles tab.
CanChangePhoneticSettings | Allows the user to modify the phonetic spellings for their name.
CanCoachInteractions | Permits the user to add themselves to another agent's call on any user or station queue they have permission to monitor.
CanCreateConferenceCalls | Permits access to create conference calls.
CanCreateOptimizerActivityCodes | This right controls if a user can create optimizer activity codes.
CanCreateOptimizerDayClassifications | This right controls if a user can create optimizer day classifications.
CanCreateOptimizerSchedulingUnit | This right controls if a user can create an optimizer scheduling unit.
CanCreateSpeedDials | Permits access to create speed dials.
CanCreateStatusNotes | Permits access to create status notes.
CanCustomizeClient | Allows the user to customize their client.
CanDeleteOptimizerActivityCodes | This right controls if a user can delete optimizer activity codes.
CanDeleteOptimizerDayClassifications | This right controls if a user can delete optimizer day classifications.
CanDeleteOptimizerSchedulingUnit | This right controls if a user can delete an optimizer scheduling unit.
CanDisconnectInteractions | Permits the user to disconnect the current call.
CanHavePrivateInteractions | Allows the user to view the private button and to prevent other users from recording or listening to their conversation.
CanHoldInteractions | Permits users to place the selected call on hold.
CanInitiateSecureInput | Permits users to initiate a secure input session.
CanJoinInteractions | Permits users who are supervisors to join in on an interaction between other agents.
CanListenOnInteraction | Allows the user to view the listen button and to listen to another interaction.
CanModifyOptimizerActivityCodes | This right controls if a user can modify optimizer activity codes.
CanModifyOptimizerDayClassifications | This right controls if a user can modify optimizer day classifications.
CanModifyOptimizerStatusToActivityTypeMapping | This right controls if a user can modify optimizer status to activity type mapping.
CanMuteInteractions | Permits the user to disable the mouthpiece on their telephones so that the other party or parties cannot hear what is being said.
CanParkInteractions | Permits users to park interactions.
CanPauseInteractions | Permits users to control a recording session by stopping the session.
CanPickupInteractions | Permits users to answer the current call, or to take the current call off hold.
CanRecordInteraction | Allows the user to view the record button.
CanRequestSupervisorAssistance | Permits users who are members of a distribution queue to request assistance from a supervisor.
CanSecureRecordingPauseInteractions | Permits users to control all recording sessions by pausing each session for an administrator configured period of time.
CanSendInteractionsToVoicemail | Permits users to send an interaction to their voice mail account.
CanShowAssistanceButton | Allows users that are members of a distribution queue to view the assistance button.
CanShowCoachButton | Allows the user to view the coach button.
CanShowDisconnectButton | Allows the user to view the disconnect button.
CanShowHoldButton | Allows the user to view the hold button.
CanShowJoinButton | Allows the user to view the join button.
CanShowMuteButton | Allows the user to view the mute button.
CanShowParkButton | Allows the user to view the park button.
CanShowPauseButton | Allows the user to view the pause button for a recording session.
CanShowPickupButton | Allows the user to view the pickup button.
CanShowRecordingSnipButton | Allows the user to view the recording snip button.
CanShowSecureInputButton | Allows users to view the secure input button.
CanShowSecureRecordingPauseButton | Allows the user to view the Secure Recording Pause button.
CanShowTransferButton | Allows the user to view the transfer button.
CanShowVoicemailButton | Allows the user to view the voice mail button.
CanSnipRecording | Permits the user to create a recording snippet for the current interaction.
CanSubmitTimeOff | This right controls if an agent with optimizer thinclient plugin license would be able to create, edit, or delete time off requests.
CanTransferInteractions | Permits users to open the transfer window where they can select a transfer recipient and the type of transfer operation they want to perform.
CanViewOptimizerActivityCodes | This right controls if a user can view optimizer activity codes.
CanViewOptimizerDayClassifications | This right controls if a user can view optimizer day classifications.
CanViewOptimizerStatusToActivityTypeMapping | This right controls if a user can view optimizer status to activity type mapping.
CloudWorkforceEngagementAdministrator | Permits the user to administer Genesys Cloud Workforce Engagement components.
ConfiguredForOutlookIntegration | This right specificies if the user is configured for Outlook Integration.
MinimizeClientToNotificationArea | Should the client be minimized to notification area instead of taskbar.
PersistentConnection | Allows the user to start a remote client with the persistent option.
ShowAgentPreferences | This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Preferences" menu item.
ShowAgentRank | This right controls if an agent can see his rank in optimizer agent group
ShowAgentRelativeRank | This right controls if an agent can see his relative rank in optimizer agent group
ShowMonitorColumns | Allows the user to show monitor columns.
ShowScheduleBidding | This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Bidding" menu item

See Also

UserRightsAttributes Class
ININ.IceLib.People Namespace


AllowAccessToProblemReporter Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..AllowAccessToProblemReporter Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to use ProblemReporter.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AllowAccessToProblemReporter
Visual Basic
Public Shared ReadOnly AllowAccessToProblemReporter As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace
ININ.IceLib.Connection.Extensions..::..ProblemReporter


AllowForceUserLogout Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..AllowForceUserLogout Field
UserRightsAttributes Class See Also Send Feedback
Provides access to Force User Logout.

Note: This field is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AllowForceUserLogout
Visual Basic
Public Shared ReadOnly AllowForceUserLogout As String

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


AllowIntercomChat Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..AllowIntercomChat Field
UserRightsAttributes Class See Also Send Feedback
Allows users to use intercom chat.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AllowIntercomChat
Visual Basic
Public Shared ReadOnly AllowIntercomChat As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


AllowMiniMode Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..AllowMiniMode Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to user mini mode.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AllowMiniMode
Visual Basic
Public Shared ReadOnly AllowMiniMode As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessAllConferences Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessAllConferences Field
UserRightsAttributes Class See Also Send Feedback
Provides access to all conferences.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessAllConferences
Visual Basic
Public Shared ReadOnly CanAccessAllConferences As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessOptimizerShiftTrading Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessOptimizerShiftTrading Field
UserRightsAttributes Class See Also Send Feedback
This right controls if an agent with optimizer thinclient plugin license would be able to access shift trading feature.

Note: This field is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessOptimizerShiftTrading
Visual Basic
Public Shared ReadOnly CanAccessOptimizerShiftTrading As String

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessOrbitQueue Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessOrbitQueue Field
UserRightsAttributes Class See Also Send Feedback
Permits access to orbit queue.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessOrbitQueue
Visual Basic
Public Shared ReadOnly CanAccessOrbitQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessOwnConferences Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessOwnConferences Field
UserRightsAttributes Class See Also Send Feedback
Provides access to conferences that the user owns.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessOwnConferences
Visual Basic
Public Shared ReadOnly CanAccessOwnConferences As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessPersonalRules Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessPersonalRules Field
UserRightsAttributes Class See Also Send Feedback
Provides access to personal rules.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessPersonalRules
Visual Basic
Public Shared ReadOnly CanAccessPersonalRules As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessResponseManagement Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessResponseManagement Field
UserRightsAttributes Class See Also Send Feedback
Permits access to response management.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessResponseManagement
Visual Basic
Public Shared ReadOnly CanAccessResponseManagement As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessTrackerInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessTrackerInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits access to tracker interactions.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessTrackerInteractions
Visual Basic
Public Shared ReadOnly CanAccessTrackerInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanAccessWorkgroupProfilesTab Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanAccessWorkgroupProfilesTab Field
UserRightsAttributes Class See Also Send Feedback
Permits access to workgroups / profiles tab.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAccessWorkgroupProfilesTab
Visual Basic
Public Shared ReadOnly CanAccessWorkgroupProfilesTab As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanChangePhoneticSettings Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanChangePhoneticSettings Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to modify the phonetic spellings for their name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanChangePhoneticSettings
Visual Basic
Public Shared ReadOnly CanChangePhoneticSettings As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCoachInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCoachInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits the user to add themselves to another agent's call on any user or station queue they have permission to monitor.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCoachInteractions
Visual Basic
Public Shared ReadOnly CanCoachInteractions As String

Remarks

This allows users to add themselves to another agent's call on any user or station queue they have permission to monitor. It enables them to provide advice to the agent without the customer knowing that anyone is assisting on the call.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCreateConferenceCalls Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCreateConferenceCalls Field
UserRightsAttributes Class See Also Send Feedback
Permits access to create conference calls.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCreateConferenceCalls
Visual Basic
Public Shared ReadOnly CanCreateConferenceCalls As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCreateOptimizerActivityCodes Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCreateOptimizerActivityCodes Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can create optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCreateOptimizerActivityCodes
Visual Basic
Public Shared ReadOnly CanCreateOptimizerActivityCodes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCreateOptimizerDayClassifications Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCreateOptimizerDayClassifications Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can create optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCreateOptimizerDayClassifications
Visual Basic
Public Shared ReadOnly CanCreateOptimizerDayClassifications As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCreateOptimizerSchedulingUnit Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCreateOptimizerSchedulingUnit Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can create an optimizer scheduling unit.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCreateOptimizerSchedulingUnit
Visual Basic
Public Shared ReadOnly CanCreateOptimizerSchedulingUnit As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCreateSpeedDials Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCreateSpeedDials Field
UserRightsAttributes Class See Also Send Feedback
Permits access to create speed dials.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCreateSpeedDials
Visual Basic
Public Shared ReadOnly CanCreateSpeedDials As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCreateStatusNotes Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCreateStatusNotes Field
UserRightsAttributes Class See Also Send Feedback
Permits access to create status notes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCreateStatusNotes
Visual Basic
Public Shared ReadOnly CanCreateStatusNotes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanCustomizeClient Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanCustomizeClient Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to customize their client.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanCustomizeClient
Visual Basic
Public Shared ReadOnly CanCustomizeClient As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanDeleteOptimizerActivityCodes Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanDeleteOptimizerActivityCodes Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can delete optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanDeleteOptimizerActivityCodes
Visual Basic
Public Shared ReadOnly CanDeleteOptimizerActivityCodes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanDeleteOptimizerDayClassifications Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanDeleteOptimizerDayClassifications Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can delete optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanDeleteOptimizerDayClassifications
Visual Basic
Public Shared ReadOnly CanDeleteOptimizerDayClassifications As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanDeleteOptimizerSchedulingUnit Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanDeleteOptimizerSchedulingUnit Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can delete an optimizer scheduling unit.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanDeleteOptimizerSchedulingUnit
Visual Basic
Public Shared ReadOnly CanDeleteOptimizerSchedulingUnit As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanDisconnectInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanDisconnectInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits the user to disconnect the current call.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanDisconnectInteractions
Visual Basic
Public Shared ReadOnly CanDisconnectInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanHavePrivateInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanHavePrivateInteractions Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the private button and to prevent other users from recording or listening to their conversation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanHavePrivateInteractions
Visual Basic
Public Shared ReadOnly CanHavePrivateInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanHoldInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanHoldInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users to place the selected call on hold.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanHoldInteractions
Visual Basic
Public Shared ReadOnly CanHoldInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanInitiateSecureInput Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanInitiateSecureInput Field
UserRightsAttributes Class See Also Send Feedback
Permits users to initiate a secure input session.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanInitiateSecureInput
Visual Basic
Public Shared ReadOnly CanInitiateSecureInput As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanJoinInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanJoinInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users who are supervisors to join in on an interaction between other agents.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanJoinInteractions
Visual Basic
Public Shared ReadOnly CanJoinInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanListenOnInteraction Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanListenOnInteraction Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the listen button and to listen to another interaction.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanListenOnInteraction
Visual Basic
Public Shared ReadOnly CanListenOnInteraction As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanModifyOptimizerActivityCodes Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanModifyOptimizerActivityCodes Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can modify optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanModifyOptimizerActivityCodes
Visual Basic
Public Shared ReadOnly CanModifyOptimizerActivityCodes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanModifyOptimizerDayClassifications Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanModifyOptimizerDayClassifications Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can modify optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanModifyOptimizerDayClassifications
Visual Basic
Public Shared ReadOnly CanModifyOptimizerDayClassifications As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanModifyOptimizerStatusToActivityTypeMapping Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanModifyOptimizerStatusToActivityTypeMapping Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can modify optimizer status to activity type mapping.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanModifyOptimizerStatusToActivityTypeMapping
Visual Basic
Public Shared ReadOnly CanModifyOptimizerStatusToActivityTypeMapping As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanMuteInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanMuteInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits the user to disable the mouthpiece on their telephones so that the other party or parties cannot hear what is being said.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanMuteInteractions
Visual Basic
Public Shared ReadOnly CanMuteInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanParkInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanParkInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users to park interactions.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanParkInteractions
Visual Basic
Public Shared ReadOnly CanParkInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanPauseInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanPauseInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users to control a recording session by stopping the session.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanPauseInteractions
Visual Basic
Public Shared ReadOnly CanPauseInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanPickupInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanPickupInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users to answer the current call, or to take the current call off hold.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanPickupInteractions
Visual Basic
Public Shared ReadOnly CanPickupInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanRecordInteraction Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanRecordInteraction Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the record button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanRecordInteraction
Visual Basic
Public Shared ReadOnly CanRecordInteraction As String

Remarks

The recording is saved as a .wav file. After the call is completed, the .wav file is attached to an email that is sent to the user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanRequestSupervisorAssistance Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanRequestSupervisorAssistance Field
UserRightsAttributes Class See Also Send Feedback
Permits users who are members of a distribution queue to request assistance from a supervisor.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanRequestSupervisorAssistance
Visual Basic
Public Shared ReadOnly CanRequestSupervisorAssistance As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanSecureRecordingPauseInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanSecureRecordingPauseInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users to control all recording sessions by pausing each session for an administrator configured period of time.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanSecureRecordingPauseInteractions
Visual Basic
Public Shared ReadOnly CanSecureRecordingPauseInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanSendInteractionsToVoicemail Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanSendInteractionsToVoicemail Field
UserRightsAttributes Class See Also Send Feedback
Permits users to send an interaction to their voice mail account.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanSendInteractionsToVoicemail
Visual Basic
Public Shared ReadOnly CanSendInteractionsToVoicemail As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowAssistanceButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowAssistanceButton Field
UserRightsAttributes Class See Also Send Feedback
Allows users that are members of a distribution queue to view the assistance button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowAssistanceButton
Visual Basic
Public Shared ReadOnly CanShowAssistanceButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowCoachButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowCoachButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the coach button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowCoachButton
Visual Basic
Public Shared ReadOnly CanShowCoachButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowDisconnectButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowDisconnectButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the disconnect button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowDisconnectButton
Visual Basic
Public Shared ReadOnly CanShowDisconnectButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowHoldButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowHoldButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the hold button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowHoldButton
Visual Basic
Public Shared ReadOnly CanShowHoldButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowJoinButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowJoinButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the join button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowJoinButton
Visual Basic
Public Shared ReadOnly CanShowJoinButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowMuteButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowMuteButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the mute button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowMuteButton
Visual Basic
Public Shared ReadOnly CanShowMuteButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowParkButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowParkButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the park button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowParkButton
Visual Basic
Public Shared ReadOnly CanShowParkButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowPauseButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowPauseButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the pause button for a recording session.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowPauseButton
Visual Basic
Public Shared ReadOnly CanShowPauseButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowPickupButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowPickupButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the pickup button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowPickupButton
Visual Basic
Public Shared ReadOnly CanShowPickupButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowRecordingSnipButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowRecordingSnipButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the recording snip button.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowRecordingSnipButton
Visual Basic
Public Shared ReadOnly CanShowRecordingSnipButton As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowSecureInputButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowSecureInputButton Field
UserRightsAttributes Class See Also Send Feedback
Allows users to view the secure input button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowSecureInputButton
Visual Basic
Public Shared ReadOnly CanShowSecureInputButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowSecureRecordingPauseButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowSecureRecordingPauseButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the Secure Recording Pause button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowSecureRecordingPauseButton
Visual Basic
Public Shared ReadOnly CanShowSecureRecordingPauseButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowTransferButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowTransferButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the transfer button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowTransferButton
Visual Basic
Public Shared ReadOnly CanShowTransferButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanShowVoicemailButton Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanShowVoicemailButton Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to view the voice mail button.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanShowVoicemailButton
Visual Basic
Public Shared ReadOnly CanShowVoicemailButton As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanSnipRecording Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanSnipRecording Field
UserRightsAttributes Class See Also Send Feedback
Permits the user to create a recording snippet for the current interaction.

Note: This field is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanSnipRecording
Visual Basic
Public Shared ReadOnly CanSnipRecording As String

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanSubmitTimeOff Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanSubmitTimeOff Field
UserRightsAttributes Class See Also Send Feedback
This right controls if an agent with optimizer thinclient plugin license would be able to create, edit, or delete time off requests.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanSubmitTimeOff
Visual Basic
Public Shared ReadOnly CanSubmitTimeOff As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanTransferInteractions Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanTransferInteractions Field
UserRightsAttributes Class See Also Send Feedback
Permits users to open the transfer window where they can select a transfer recipient and the type of transfer operation they want to perform.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanTransferInteractions
Visual Basic
Public Shared ReadOnly CanTransferInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanViewOptimizerActivityCodes Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanViewOptimizerActivityCodes Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can view optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanViewOptimizerActivityCodes
Visual Basic
Public Shared ReadOnly CanViewOptimizerActivityCodes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanViewOptimizerDayClassifications Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanViewOptimizerDayClassifications Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can view optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanViewOptimizerDayClassifications
Visual Basic
Public Shared ReadOnly CanViewOptimizerDayClassifications As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CanViewOptimizerStatusToActivityTypeMapping Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CanViewOptimizerStatusToActivityTypeMapping Field
UserRightsAttributes Class See Also Send Feedback
This right controls if a user can view optimizer status to activity type mapping.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanViewOptimizerStatusToActivityTypeMapping
Visual Basic
Public Shared ReadOnly CanViewOptimizerStatusToActivityTypeMapping As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


CloudWorkforceEngagementAdministrator Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..CloudWorkforceEngagementAdministrator Field
UserRightsAttributes Class See Also Send Feedback
Permits the user to administer Genesys Cloud Workforce Engagement components.

Note: This field is supported for IC Server version 2020 R2 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CloudWorkforceEngagementAdministrator
Visual Basic
Public Shared ReadOnly CloudWorkforceEngagementAdministrator As String

Version Information

Supported for IC Server version 2020 R2 and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


ConfiguredForOutlookIntegration Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..ConfiguredForOutlookIntegration Field
UserRightsAttributes Class See Also Send Feedback
This right specificies if the user is configured for Outlook Integration.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ConfiguredForOutlookIntegration
Visual Basic
Public Shared ReadOnly ConfiguredForOutlookIntegration As String

Remarks

When this attribute is set for a user, all information relating to e-mail will appear in Outlook integration and will be hidden from the user in the .NET client.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


MinimizeClientToNotificationArea Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..MinimizeClientToNotificationArea Field
UserRightsAttributes Class See Also Send Feedback
Should the client be minimized to notification area instead of taskbar.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MinimizeClientToNotificationArea
Visual Basic
Public Shared ReadOnly MinimizeClientToNotificationArea As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


PersistentConnection Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..PersistentConnection Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to start a remote client with the persistent option.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PersistentConnection
Visual Basic
Public Shared ReadOnly PersistentConnection As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


ShowAgentPreferences Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..ShowAgentPreferences Field
UserRightsAttributes Class See Also Send Feedback
This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Preferences" menu item.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ShowAgentPreferences
Visual Basic
Public Shared ReadOnly ShowAgentPreferences As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


ShowAgentRank Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..ShowAgentRank Field
UserRightsAttributes Class See Also Send Feedback
This right controls if an agent can see his rank in optimizer agent group

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ShowAgentRank
Visual Basic
Public Shared ReadOnly ShowAgentRank As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


ShowAgentRelativeRank Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..ShowAgentRelativeRank Field
UserRightsAttributes Class See Also Send Feedback
This right controls if an agent can see his relative rank in optimizer agent group

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ShowAgentRelativeRank
Visual Basic
Public Shared ReadOnly ShowAgentRelativeRank As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


ShowMonitorColumns Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..ShowMonitorColumns Field
UserRightsAttributes Class See Also Send Feedback
Allows the user to show monitor columns.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ShowMonitorColumns
Visual Basic
Public Shared ReadOnly ShowMonitorColumns As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


ShowScheduleBidding Field

[image]

IceLib Technical Reference
UserRightsAttributes..::..ShowScheduleBidding Field
UserRightsAttributes Class See Also Send Feedback
This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Bidding" menu item

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ShowScheduleBidding
Visual Basic
Public Shared ReadOnly ShowScheduleBidding As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsAttributes Class
UserRightsAttributes Members
ININ.IceLib.People Namespace


UserRightsSettings Class

[image]

IceLib Technical Reference
UserRightsSettings Class
Members See Also Send Feedback
Represents the basic user rights settings for an IC user. User rights are set in Interaction Administrator at the Default User, User or Workgroup level.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserRightsSettings : UserSettings
Visual Basic
Public Class UserRightsSettings _
    Inherits UserSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserSettings
ININ.IceLib.People..::..UserRightsSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Members
ININ.IceLib.People Namespace


UserRightsSettings Members

[image] [image]

IceLib Technical Reference
UserRightsSettings Members
UserRightsSettings Class Constructors Methods Properties Events See Also Send Feedback

The UserRightsSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserRightsSettings | Initializes a new instance of the UserRightsSettings class for the current session user.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowAccessToProblemReporter | Gets the AllowAccessToProblemReporter value.
Public property | AllowForceUserLogout | Gets the AllowForceUserLogout value.
Public property | AllowIntercomChat | Gets the AllowIntercomChat value.
Public property | AllowMiniMode | Gets the AllowMiniMode value.
Public property | CanAccessAllConferences | Gets the CanAccessAllConferences value.
Public property | CanAccessOptimizerShiftTrading | Gets the CanAccessOptimizerShiftTrading value. This right controls if a user can access optimizer shift trading.
Public property | CanAccessOrbitQueue | Gets the CanAccessOrbitQueue value.
Public property | CanAccessOwnConferences | Gets the CanAccessOwnConferences value.
Public property | CanAccessPersonalRules | Gets the CanAccessPersonalRules value.
Public property | CanAccessResponseManagement | Gets the CanAccessResponseManagement value.
Public property | CanAccessTrackerInteractions | Gets the CanAccessTrackerInteractions value.
Public property | CanAccessWorkgroupProfilesTab | Gets the CanAccessWorkgroupProfilesTab value.
Public property | CanChangePhoneticSettings | Gets the CanChangePhoneticSettings value.
Public property | CanCoach | Gets the CanCoachInteractions value.
Public property | CanCreateConferenceCalls | Gets the CanCreateConferenceCalls value.
Public property | CanCreateOptimizerActivityCodes | Gets the CanCreateOptimizerActivityCodes value. This right controls if a user can create optimizer activity codes.
Public property | CanCreateOptimizerDayClassifications | Gets the CanCreateOptimizerDayClassifications value. This right controls if a user can create optimizer day classifications.
Public property | CanCreateOptimizerSchedulingUnit | Gets the CanCreateOptimizerSchedulingUnit value. This right controls if a user can create an optimizer scheduling unit.
Public property | CanCreateSpeedDials | Gets the CanCreateSpeedDials value.
Public property | CanCreateStatusNotes | Gets the CanCreateStatusNotes value.
Public property | CanCustomizeClient | Gets the CanCustomizeClient value.
Public property | CanDeleteOptimizerActivityCodes | Gets the CanDeleteOptimizerActivityCodes value. This right controls if a user can delete optimizer activity codes.
Public property | CanDeleteOptimizerDayClassifications | Gets the CanDeleteOptimizerDayClassifications value. This right controls if a user can delete optimizer day classifications.
Public property | CanDeleteOptimizerSchedulingUnit | Gets the CanDeleteOptimizerSchedulingUnit value. This right controls if a user can delete an optimizer scheduling unit.
Public property | CanDisconnectInteraction | Gets the CanDisconnectInteractions value.
Public property | CanGetAssistance | Gets the CanRequestSupervisorAssistance value.
Public property | CanHavePrivateInteractions | Gets the CanHavePrivateInteractions value.
Public property | CanHoldInteraction | Gets the CanHoldInteractions value.
Public property | CanInitiateSecureInput | Gets the CanInitiateSecureInput value.
Public property | CanInvokeTracker | Gets the CanInvokeTracker value.
Public property | CanJoinInteraction | Gets the CanJoinInteractions value.
Public property | CanListenOnInteraction | Gets the CanListenOnInteraction value.
Public property | CanModifyOptimizerActivityCodes | Gets the CanModifyOptimizerActivityCodes value. This right controls if a user can modify optimizer activity codes.
Public property | CanModifyOptimizerDayClassifications | Gets the CanModifyOptimizerDayClassifications value. This right controls if a user can modify optimizer day classifications.
Public property | CanModifyOptimizerStatusToActivityTypeMapping | Gets the CanModifyOptimizerStatusToActivityTypeMapping value. This right controls if a user can modify optimizer status to activity type mapping.
Public property | CanMuteInteraction | Gets the CanMuteInteractions value.
Public property | CanParkInteraction | Gets the CanParkInteractions value.
Public property | CanPauseInteraction | Gets the CanPauseInteractions value.
Public property | CanPickupInteraction | Gets the CanPickupInteractions value.
Public property | CanRecordInteraction | Gets the CanRecordInteraction value.
Public property | CanSecureRecordingPauseInteractions | Gets the CanSecureRecordingPauseInteractions value.
Public property | CanSendInteractionToVoicemail | Gets the CanSendInteractionsToVoicemail value.
Public property | CanShowAssistanceButton | Gets the CanShowAssistanceButton value.
Public property | CanShowCoachButton | Gets the CanShowCoachButton value.
Public property | CanShowDisconnectButton | Gets the CanShowDisconnectButton value.
Public property | CanShowHoldButton | Gets the CanShowHoldButton value.
Public property | CanShowJoinButton | Gets the CanShowJoinButton value.
Public property | CanShowMuteButton | Gets the CanShowMuteButton value.
Public property | CanShowParkButton | Gets the CanShowParkButton value.
Public property | CanShowPauseButton | Gets the CanShowPauseButton value.
Public property | CanShowPickupButton | Gets the CanShowPickupButton value.
Public property | CanShowRecordingSnipButton | Gets the CanShowRecordingSnipButton value.
Public property | CanShowSecureInputButton | Gets the CanShowSecureInputButton value.
Public property | CanShowSecureRecordingPauseButton | Gets the CanShowSecureRecordingPauseButton value.
Public property | CanShowTransferButton | Gets the CanShowTransferButton value.
Public property | CanShowVoicemailButton | Gets the CanShowVoicemailButton value.
Public property | CanSnipRecording | Gets the CanSnipRecording value.
Public property | CanSubmitTimeOff | Gets the CanSubmitTimeOff value. This right controls if an agent with optimizer thinclient plugin license would be able to create, edit, or delete time off requests.
Public property | CanTransferInteraction | Gets the CanTransferInteractions value.
Public property | CanViewOptimizerActivityCodes | Gets the CanViewOptimizerActivityCodes value. This right controls if a user can view optimizer activity codes.
Public property | CanViewOptimizerDayClassifications | Gets the CanViewOptimizerDayClassifications value. This right controls if a user can view optimizer day classifications.
Public property | CanViewOptimizerStatusToActivityTypeMapping | Gets the CanViewOptimizerStatusToActivityTypeMapping value. This right controls if a user can view optimizer status to activity type mapping.
Public property | CloudWorkforceEngagementAdministrator | Gets the CloudWorkforceEngagementAdministrator value.
Public property | ConfiguredForOutlookIntegration | Gets the ConfiguredForOutlookIntegration value.
Public property | MinimizeClientToNotificationArea | Gets the MinimizeClientToNotificationArea value.
Public property | PersistentConnection | Gets the PersistentConnection value.
Public property | ShowAgentPreferences | Gets the ShowAgentPreferences value. This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Preferences" menu item.
Public property | ShowAgentRank | Gets the ShowAgentRank value. This right controls if an agent with optimizer thinclient plugin license would be able to see "Agent Group Rank" during schedule bidding.
Public property | ShowAgentRelativeRank | Gets the ShowAgentRelativeRank value. This right controls if an agent with optimizer thinclient plugin license would be able to see "Agent Group Relative Rank" during schedule bidding.
Public property | ShowMonitorColumns | Gets the ShowMonitorColumns value.
Public property | ShowScheduleBidding | Gets the ShowScheduleBidding value. This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Bidding" menu item.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserRightsSettings Class
ININ.IceLib.People Namespace


UserRightsSettings Constructor

[image]

IceLib Technical Reference
UserRightsSettings Constructor
UserRightsSettings Class See Also Send Feedback
Initializes a new instance of the UserRightsSettings class for the current session user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserRightsSettings(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


UserRightsSettings Methods

[image] [image]

IceLib Technical Reference
UserRightsSettings Methods
UserRightsSettings Class See Also Send Feedback

The UserRightsSettings type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserRightsSettings Class
ININ.IceLib.People Namespace


UserRightsSettings Properties

[image] [image]

IceLib Technical Reference
UserRightsSettings Properties
UserRightsSettings Class See Also Send Feedback

The UserRightsSettings type exposes the following members.

Properties

 | Name | Description
Public property | AllowAccessToProblemReporter | Gets the AllowAccessToProblemReporter value.
Public property | AllowForceUserLogout | Gets the AllowForceUserLogout value.
Public property | AllowIntercomChat | Gets the AllowIntercomChat value.
Public property | AllowMiniMode | Gets the AllowMiniMode value.
Public property | CanAccessAllConferences | Gets the CanAccessAllConferences value.
Public property | CanAccessOptimizerShiftTrading | Gets the CanAccessOptimizerShiftTrading value. This right controls if a user can access optimizer shift trading.
Public property | CanAccessOrbitQueue | Gets the CanAccessOrbitQueue value.
Public property | CanAccessOwnConferences | Gets the CanAccessOwnConferences value.
Public property | CanAccessPersonalRules | Gets the CanAccessPersonalRules value.
Public property | CanAccessResponseManagement | Gets the CanAccessResponseManagement value.
Public property | CanAccessTrackerInteractions | Gets the CanAccessTrackerInteractions value.
Public property | CanAccessWorkgroupProfilesTab | Gets the CanAccessWorkgroupProfilesTab value.
Public property | CanChangePhoneticSettings | Gets the CanChangePhoneticSettings value.
Public property | CanCoach | Gets the CanCoachInteractions value.
Public property | CanCreateConferenceCalls | Gets the CanCreateConferenceCalls value.
Public property | CanCreateOptimizerActivityCodes | Gets the CanCreateOptimizerActivityCodes value. This right controls if a user can create optimizer activity codes.
Public property | CanCreateOptimizerDayClassifications | Gets the CanCreateOptimizerDayClassifications value. This right controls if a user can create optimizer day classifications.
Public property | CanCreateOptimizerSchedulingUnit | Gets the CanCreateOptimizerSchedulingUnit value. This right controls if a user can create an optimizer scheduling unit.
Public property | CanCreateSpeedDials | Gets the CanCreateSpeedDials value.
Public property | CanCreateStatusNotes | Gets the CanCreateStatusNotes value.
Public property | CanCustomizeClient | Gets the CanCustomizeClient value.
Public property | CanDeleteOptimizerActivityCodes | Gets the CanDeleteOptimizerActivityCodes value. This right controls if a user can delete optimizer activity codes.
Public property | CanDeleteOptimizerDayClassifications | Gets the CanDeleteOptimizerDayClassifications value. This right controls if a user can delete optimizer day classifications.
Public property | CanDeleteOptimizerSchedulingUnit | Gets the CanDeleteOptimizerSchedulingUnit value. This right controls if a user can delete an optimizer scheduling unit.
Public property | CanDisconnectInteraction | Gets the CanDisconnectInteractions value.
Public property | CanGetAssistance | Gets the CanRequestSupervisorAssistance value.
Public property | CanHavePrivateInteractions | Gets the CanHavePrivateInteractions value.
Public property | CanHoldInteraction | Gets the CanHoldInteractions value.
Public property | CanInitiateSecureInput | Gets the CanInitiateSecureInput value.
Public property | CanInvokeTracker | Gets the CanInvokeTracker value.
Public property | CanJoinInteraction | Gets the CanJoinInteractions value.
Public property | CanListenOnInteraction | Gets the CanListenOnInteraction value.
Public property | CanModifyOptimizerActivityCodes | Gets the CanModifyOptimizerActivityCodes value. This right controls if a user can modify optimizer activity codes.
Public property | CanModifyOptimizerDayClassifications | Gets the CanModifyOptimizerDayClassifications value. This right controls if a user can modify optimizer day classifications.
Public property | CanModifyOptimizerStatusToActivityTypeMapping | Gets the CanModifyOptimizerStatusToActivityTypeMapping value. This right controls if a user can modify optimizer status to activity type mapping.
Public property | CanMuteInteraction | Gets the CanMuteInteractions value.
Public property | CanParkInteraction | Gets the CanParkInteractions value.
Public property | CanPauseInteraction | Gets the CanPauseInteractions value.
Public property | CanPickupInteraction | Gets the CanPickupInteractions value.
Public property | CanRecordInteraction | Gets the CanRecordInteraction value.
Public property | CanSecureRecordingPauseInteractions | Gets the CanSecureRecordingPauseInteractions value.
Public property | CanSendInteractionToVoicemail | Gets the CanSendInteractionsToVoicemail value.
Public property | CanShowAssistanceButton | Gets the CanShowAssistanceButton value.
Public property | CanShowCoachButton | Gets the CanShowCoachButton value.
Public property | CanShowDisconnectButton | Gets the CanShowDisconnectButton value.
Public property | CanShowHoldButton | Gets the CanShowHoldButton value.
Public property | CanShowJoinButton | Gets the CanShowJoinButton value.
Public property | CanShowMuteButton | Gets the CanShowMuteButton value.
Public property | CanShowParkButton | Gets the CanShowParkButton value.
Public property | CanShowPauseButton | Gets the CanShowPauseButton value.
Public property | CanShowPickupButton | Gets the CanShowPickupButton value.
Public property | CanShowRecordingSnipButton | Gets the CanShowRecordingSnipButton value.
Public property | CanShowSecureInputButton | Gets the CanShowSecureInputButton value.
Public property | CanShowSecureRecordingPauseButton | Gets the CanShowSecureRecordingPauseButton value.
Public property | CanShowTransferButton | Gets the CanShowTransferButton value.
Public property | CanShowVoicemailButton | Gets the CanShowVoicemailButton value.
Public property | CanSnipRecording | Gets the CanSnipRecording value.
Public property | CanSubmitTimeOff | Gets the CanSubmitTimeOff value. This right controls if an agent with optimizer thinclient plugin license would be able to create, edit, or delete time off requests.
Public property | CanTransferInteraction | Gets the CanTransferInteractions value.
Public property | CanViewOptimizerActivityCodes | Gets the CanViewOptimizerActivityCodes value. This right controls if a user can view optimizer activity codes.
Public property | CanViewOptimizerDayClassifications | Gets the CanViewOptimizerDayClassifications value. This right controls if a user can view optimizer day classifications.
Public property | CanViewOptimizerStatusToActivityTypeMapping | Gets the CanViewOptimizerStatusToActivityTypeMapping value. This right controls if a user can view optimizer status to activity type mapping.
Public property | CloudWorkforceEngagementAdministrator | Gets the CloudWorkforceEngagementAdministrator value.
Public property | ConfiguredForOutlookIntegration | Gets the ConfiguredForOutlookIntegration value.
Public property | MinimizeClientToNotificationArea | Gets the MinimizeClientToNotificationArea value.
Public property | PersistentConnection | Gets the PersistentConnection value.
Public property | ShowAgentPreferences | Gets the ShowAgentPreferences value. This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Preferences" menu item.
Public property | ShowAgentRank | Gets the ShowAgentRank value. This right controls if an agent with optimizer thinclient plugin license would be able to see "Agent Group Rank" during schedule bidding.
Public property | ShowAgentRelativeRank | Gets the ShowAgentRelativeRank value. This right controls if an agent with optimizer thinclient plugin license would be able to see "Agent Group Relative Rank" during schedule bidding.
Public property | ShowMonitorColumns | Gets the ShowMonitorColumns value.
Public property | ShowScheduleBidding | Gets the ShowScheduleBidding value. This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Bidding" menu item.

See Also

UserRightsSettings Class
ININ.IceLib.People Namespace


AllowAccessToProblemReporter Property

[image]

IceLib Technical Reference
UserRightsSettings..::..AllowAccessToProblemReporter Property
UserRightsSettings Class See Also Send Feedback
Gets the AllowAccessToProblemReporter value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowAccessToProblemReporter { get; }
Visual Basic
Public ReadOnly Property AllowAccessToProblemReporter As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can use ProblemReporter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace
ININ.IceLib.Connection.Extensions..::..ProblemReporter


AllowForceUserLogout Property

[image]

IceLib Technical Reference
UserRightsSettings..::..AllowForceUserLogout Property
UserRightsSettings Class See Also Send Feedback
Gets the AllowForceUserLogout value.

Note: This property is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowForceUserLogout { get; }
Visual Basic
Public ReadOnly Property AllowForceUserLogout As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to Force User Logout; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


AllowIntercomChat Property

[image]

IceLib Technical Reference
UserRightsSettings..::..AllowIntercomChat Property
UserRightsSettings Class See Also Send Feedback
Gets the AllowIntercomChat value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowIntercomChat { get; }
Visual Basic
Public ReadOnly Property AllowIntercomChat As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can use intercom chats; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


AllowMiniMode Property

[image]

IceLib Technical Reference
UserRightsSettings..::..AllowMiniMode Property
UserRightsSettings Class See Also Send Feedback
Gets the AllowMiniMode value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AllowMiniMode { get; }
Visual Basic
Public ReadOnly Property AllowMiniMode As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can use mini mode; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessAllConferences Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessAllConferences Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessAllConferences value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessAllConferences { get; }
Visual Basic
Public ReadOnly Property CanAccessAllConferences As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to all conferences; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessOptimizerShiftTrading Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessOptimizerShiftTrading Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessOptimizerShiftTrading value. This right controls if a user can access optimizer shift trading.

Note: This property is supported for IC Server version 2015 R4 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessOptimizerShiftTrading { get; }
Visual Basic
Public ReadOnly Property CanAccessOptimizerShiftTrading As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can access optimizer shift trading; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R4 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessOrbitQueue Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessOrbitQueue Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessOrbitQueue value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessOrbitQueue { get; }
Visual Basic
Public ReadOnly Property CanAccessOrbitQueue As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to an orbit queue; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessOwnConferences Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessOwnConferences Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessOwnConferences value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessOwnConferences { get; }
Visual Basic
Public ReadOnly Property CanAccessOwnConferences As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to conferences that he/she owns; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessPersonalRules Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessPersonalRules Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessPersonalRules value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessPersonalRules { get; }
Visual Basic
Public ReadOnly Property CanAccessPersonalRules As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to personal rules; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessResponseManagement Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessResponseManagement Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessResponseManagement value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessResponseManagement { get; }
Visual Basic
Public ReadOnly Property CanAccessResponseManagement As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to response management; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessTrackerInteractions Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessTrackerInteractions Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessTrackerInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessTrackerInteractions { get; }
Visual Basic
Public ReadOnly Property CanAccessTrackerInteractions As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to tracker interactions; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanAccessWorkgroupProfilesTab Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanAccessWorkgroupProfilesTab Property
UserRightsSettings Class See Also Send Feedback
Gets the CanAccessWorkgroupProfilesTab value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAccessWorkgroupProfilesTab { get; }
Visual Basic
Public ReadOnly Property CanAccessWorkgroupProfilesTab As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to the workgroup profiles tab; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanChangePhoneticSettings Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanChangePhoneticSettings Property
UserRightsSettings Class See Also Send Feedback
Gets the CanChangePhoneticSettings value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanChangePhoneticSettings { get; }
Visual Basic
Public ReadOnly Property CanChangePhoneticSettings As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can change their phonetic settings; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCoach Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCoach Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCoachInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCoach { get; }
Visual Basic
Public ReadOnly Property CanCoach As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can coach; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCreateConferenceCalls Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCreateConferenceCalls Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCreateConferenceCalls value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateConferenceCalls { get; }
Visual Basic
Public ReadOnly Property CanCreateConferenceCalls As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has can create conference calls; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCreateOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCreateOptimizerActivityCodes Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCreateOptimizerActivityCodes value. This right controls if a user can create optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanCreateOptimizerActivityCodes As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can create optimizer activity codes; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCreateOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCreateOptimizerDayClassifications Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCreateOptimizerDayClassifications value. This right controls if a user can create optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanCreateOptimizerDayClassifications As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can create optimizer day classifications; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCreateOptimizerSchedulingUnit Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCreateOptimizerSchedulingUnit Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCreateOptimizerSchedulingUnit value. This right controls if a user can create an optimizer scheduling unit.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateOptimizerSchedulingUnit { get; }
Visual Basic
Public ReadOnly Property CanCreateOptimizerSchedulingUnit As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can create scheduling unit; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCreateSpeedDials Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCreateSpeedDials Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCreateSpeedDials value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateSpeedDials { get; }
Visual Basic
Public ReadOnly Property CanCreateSpeedDials As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to create speed dials; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCreateStatusNotes Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCreateStatusNotes Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCreateStatusNotes value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCreateStatusNotes { get; }
Visual Basic
Public ReadOnly Property CanCreateStatusNotes As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user has access to create status notes; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanCustomizeClient Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanCustomizeClient Property
UserRightsSettings Class See Also Send Feedback
Gets the CanCustomizeClient value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanCustomizeClient { get; }
Visual Basic
Public ReadOnly Property CanCustomizeClient As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can customize the client; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanDeleteOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanDeleteOptimizerActivityCodes Property
UserRightsSettings Class See Also Send Feedback
Gets the CanDeleteOptimizerActivityCodes value. This right controls if a user can delete optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanDeleteOptimizerActivityCodes As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can delete optimizer activity codes; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanDeleteOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanDeleteOptimizerDayClassifications Property
UserRightsSettings Class See Also Send Feedback
Gets the CanDeleteOptimizerDayClassifications value. This right controls if a user can delete optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanDeleteOptimizerDayClassifications As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can delete optimizer day classifications; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanDeleteOptimizerSchedulingUnit Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanDeleteOptimizerSchedulingUnit Property
UserRightsSettings Class See Also Send Feedback
Gets the CanDeleteOptimizerSchedulingUnit value. This right controls if a user can delete an optimizer scheduling unit.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteOptimizerSchedulingUnit { get; }
Visual Basic
Public ReadOnly Property CanDeleteOptimizerSchedulingUnit As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can delete scheduling unit; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanDisconnectInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanDisconnectInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanDisconnectInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDisconnectInteraction { get; }
Visual Basic
Public ReadOnly Property CanDisconnectInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can disconnect an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanGetAssistance Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanGetAssistance Property
UserRightsSettings Class See Also Send Feedback
Gets the CanRequestSupervisorAssistance value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanGetAssistance { get; }
Visual Basic
Public ReadOnly Property CanGetAssistance As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can get assistance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanHavePrivateInteractions Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanHavePrivateInteractions Property
UserRightsSettings Class See Also Send Feedback
Gets the CanHavePrivateInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanHavePrivateInteractions { get; }
Visual Basic
Public ReadOnly Property CanHavePrivateInteractions As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can have private interactions; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanHoldInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanHoldInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanHoldInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanHoldInteraction { get; }
Visual Basic
Public ReadOnly Property CanHoldInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can hold an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanInitiateSecureInput Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanInitiateSecureInput Property
UserRightsSettings Class See Also Send Feedback
Gets the CanInitiateSecureInput value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanInitiateSecureInput { get; }
Visual Basic
Public ReadOnly Property CanInitiateSecureInput As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can initiate a secure input session; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanInvokeTracker Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanInvokeTracker Property
UserRightsSettings Class See Also Send Feedback
Gets the CanInvokeTracker value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanInvokeTracker { get; }
Visual Basic
Public ReadOnly Property CanInvokeTracker As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can invoke tracker; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanJoinInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanJoinInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanJoinInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanJoinInteraction { get; }
Visual Basic
Public ReadOnly Property CanJoinInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can join an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanListenOnInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanListenOnInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanListenOnInteraction value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanListenOnInteraction { get; }
Visual Basic
Public ReadOnly Property CanListenOnInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can listen on an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanModifyOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanModifyOptimizerActivityCodes Property
UserRightsSettings Class See Also Send Feedback
Gets the CanModifyOptimizerActivityCodes value. This right controls if a user can modify optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanModifyOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanModifyOptimizerActivityCodes As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can modify optimizer activity codes; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanModifyOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanModifyOptimizerDayClassifications Property
UserRightsSettings Class See Also Send Feedback
Gets the CanModifyOptimizerDayClassifications value. This right controls if a user can modify optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanModifyOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanModifyOptimizerDayClassifications As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can modify optimizer day classifications; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanModifyOptimizerStatusToActivityTypeMapping Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanModifyOptimizerStatusToActivityTypeMapping Property
UserRightsSettings Class See Also Send Feedback
Gets the CanModifyOptimizerStatusToActivityTypeMapping value. This right controls if a user can modify optimizer status to activity type mapping.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanModifyOptimizerStatusToActivityTypeMapping { get; }
Visual Basic
Public ReadOnly Property CanModifyOptimizerStatusToActivityTypeMapping As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can modify optimizer status to activity type mapping; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanMuteInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanMuteInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanMuteInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanMuteInteraction { get; }
Visual Basic
Public ReadOnly Property CanMuteInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can mute an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanParkInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanParkInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanParkInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanParkInteraction { get; }
Visual Basic
Public ReadOnly Property CanParkInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can park an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanPauseInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanPauseInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanPauseInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanPauseInteraction { get; }
Visual Basic
Public ReadOnly Property CanPauseInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can pause an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanPickupInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanPickupInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanPickupInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanPickupInteraction { get; }
Visual Basic
Public ReadOnly Property CanPickupInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can pickup an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanRecordInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanRecordInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanRecordInteraction value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanRecordInteraction { get; }
Visual Basic
Public ReadOnly Property CanRecordInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can record an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanSecureRecordingPauseInteractions Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanSecureRecordingPauseInteractions Property
UserRightsSettings Class See Also Send Feedback
Gets the CanSecureRecordingPauseInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanSecureRecordingPauseInteractions { get; }
Visual Basic
Public ReadOnly Property CanSecureRecordingPauseInteractions As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can control all recording sessions by pausing each session for an administrator configured period of time; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanSendInteractionToVoicemail Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanSendInteractionToVoicemail Property
UserRightsSettings Class See Also Send Feedback
Gets the CanSendInteractionsToVoicemail value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanSendInteractionToVoicemail { get; }
Visual Basic
Public ReadOnly Property CanSendInteractionToVoicemail As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can send an interaction to voicemail; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowAssistanceButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowAssistanceButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowAssistanceButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowAssistanceButton { get; }
Visual Basic
Public ReadOnly Property CanShowAssistanceButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to get assistance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowCoachButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowCoachButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowCoachButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowCoachButton { get; }
Visual Basic
Public ReadOnly Property CanShowCoachButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the coach button; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowDisconnectButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowDisconnectButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowDisconnectButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowDisconnectButton { get; }
Visual Basic
Public ReadOnly Property CanShowDisconnectButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to disconnect an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowHoldButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowHoldButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowHoldButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowHoldButton { get; }
Visual Basic
Public ReadOnly Property CanShowHoldButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to hold an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowJoinButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowJoinButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowJoinButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowJoinButton { get; }
Visual Basic
Public ReadOnly Property CanShowJoinButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to join an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowMuteButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowMuteButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowMuteButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowMuteButton { get; }
Visual Basic
Public ReadOnly Property CanShowMuteButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to mute an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowParkButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowParkButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowParkButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowParkButton { get; }
Visual Basic
Public ReadOnly Property CanShowParkButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to park an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowPauseButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowPauseButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowPauseButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowPauseButton { get; }
Visual Basic
Public ReadOnly Property CanShowPauseButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to pause an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowPickupButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowPickupButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowPickupButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowPickupButton { get; }
Visual Basic
Public ReadOnly Property CanShowPickupButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to pickup an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowRecordingSnipButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowRecordingSnipButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowRecordingSnipButton value.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowRecordingSnipButton { get; }
Visual Basic
Public ReadOnly Property CanShowRecordingSnipButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can view the Recording Snip button; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowSecureInputButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowSecureInputButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowSecureInputButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowSecureInputButton { get; }
Visual Basic
Public ReadOnly Property CanShowSecureInputButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to initiate a secure input session; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowSecureRecordingPauseButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowSecureRecordingPauseButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowSecureRecordingPauseButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowSecureRecordingPauseButton { get; }
Visual Basic
Public ReadOnly Property CanShowSecureRecordingPauseButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to initiate secure recording pause; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowTransferButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowTransferButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowTransferButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowTransferButton { get; }
Visual Basic
Public ReadOnly Property CanShowTransferButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to transfer an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanShowVoicemailButton Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanShowVoicemailButton Property
UserRightsSettings Class See Also Send Feedback
Gets the CanShowVoicemailButton value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanShowVoicemailButton { get; }
Visual Basic
Public ReadOnly Property CanShowVoicemailButton As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show the button to send an interaction to voicemail; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanSnipRecording Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanSnipRecording Property
UserRightsSettings Class See Also Send Feedback
Gets the CanSnipRecording value.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanSnipRecording { get; }
Visual Basic
Public ReadOnly Property CanSnipRecording As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can snip a recording; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanSubmitTimeOff Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanSubmitTimeOff Property
UserRightsSettings Class See Also Send Feedback
Gets the CanSubmitTimeOff value. This right controls if an agent with optimizer thinclient plugin license would be able to create, edit, or delete time off requests.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanSubmitTimeOff { get; }
Visual Basic
Public ReadOnly Property CanSubmitTimeOff As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can create, edit, or delete time off requests; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanTransferInteraction Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanTransferInteraction Property
UserRightsSettings Class See Also Send Feedback
Gets the CanTransferInteractions value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanTransferInteraction { get; }
Visual Basic
Public ReadOnly Property CanTransferInteraction As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can transfer an interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanViewOptimizerActivityCodes Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanViewOptimizerActivityCodes Property
UserRightsSettings Class See Also Send Feedback
Gets the CanViewOptimizerActivityCodes value. This right controls if a user can view optimizer activity codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanViewOptimizerActivityCodes { get; }
Visual Basic
Public ReadOnly Property CanViewOptimizerActivityCodes As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can view optimizer activity codes; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanViewOptimizerDayClassifications Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanViewOptimizerDayClassifications Property
UserRightsSettings Class See Also Send Feedback
Gets the CanViewOptimizerDayClassifications value. This right controls if a user can view optimizer day classifications.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanViewOptimizerDayClassifications { get; }
Visual Basic
Public ReadOnly Property CanViewOptimizerDayClassifications As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can view optimizer day classifications; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CanViewOptimizerStatusToActivityTypeMapping Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CanViewOptimizerStatusToActivityTypeMapping Property
UserRightsSettings Class See Also Send Feedback
Gets the CanViewOptimizerStatusToActivityTypeMapping value. This right controls if a user can view optimizer status to activity type mapping.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanViewOptimizerStatusToActivityTypeMapping { get; }
Visual Basic
Public ReadOnly Property CanViewOptimizerStatusToActivityTypeMapping As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user can view optimizer status to activity type mapping; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


CloudWorkforceEngagementAdministrator Property

[image]

IceLib Technical Reference
UserRightsSettings..::..CloudWorkforceEngagementAdministrator Property
UserRightsSettings Class See Also Send Feedback
Gets the CloudWorkforceEngagementAdministrator value.

Note: This property is supported for IC Server version 2020 R2 and beyond.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CloudWorkforceEngagementAdministrator { get; }
Visual Basic
Public ReadOnly Property CloudWorkforceEngagementAdministrator As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can administer Genesys Cloud Workforce Engagement components; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2020 R2 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


ConfiguredForOutlookIntegration Property

[image]

IceLib Technical Reference
UserRightsSettings..::..ConfiguredForOutlookIntegration Property
UserRightsSettings Class See Also Send Feedback
Gets the ConfiguredForOutlookIntegration value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ConfiguredForOutlookIntegration { get; }
Visual Basic
Public ReadOnly Property ConfiguredForOutlookIntegration As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user is configured for Outlook integration; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


MinimizeClientToNotificationArea Property

[image]

IceLib Technical Reference
UserRightsSettings..::..MinimizeClientToNotificationArea Property
UserRightsSettings Class See Also Send Feedback
Gets the MinimizeClientToNotificationArea value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool MinimizeClientToNotificationArea { get; }
Visual Basic
Public ReadOnly Property MinimizeClientToNotificationArea As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the client is set to be minimized to notification area instead of taskbar; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


PersistentConnection Property

[image]

IceLib Technical Reference
UserRightsSettings..::..PersistentConnection Property
UserRightsSettings Class See Also Send Feedback
Gets the PersistentConnection value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PersistentConnection { get; }
Visual Basic
Public ReadOnly Property PersistentConnection As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if can have a persistent connection; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

When a persistent voice connection is made with an IC Server, the audio path between the station and the server persists (is not disconnected) until the station initiates the disconnection. This allows the server to route calls to the station more quickly, by reusing the existing audio path.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


ShowAgentPreferences Property

[image]

IceLib Technical Reference
UserRightsSettings..::..ShowAgentPreferences Property
UserRightsSettings Class See Also Send Feedback
Gets the ShowAgentPreferences value. This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Preferences" menu item.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShowAgentPreferences { get; }
Visual Basic
Public ReadOnly Property ShowAgentPreferences As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user has access to "Schedule Preferences"; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


ShowAgentRank Property

[image]

IceLib Technical Reference
UserRightsSettings..::..ShowAgentRank Property
UserRightsSettings Class See Also Send Feedback
Gets the ShowAgentRank value. This right controls if an agent with optimizer thinclient plugin license would be able to see "Agent Group Rank" during schedule bidding.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShowAgentRank { get; }
Visual Basic
Public ReadOnly Property ShowAgentRank As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can see "Agent Group Rank""; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


ShowAgentRelativeRank Property

[image]

IceLib Technical Reference
UserRightsSettings..::..ShowAgentRelativeRank Property
UserRightsSettings Class See Also Send Feedback
Gets the ShowAgentRelativeRank value. This right controls if an agent with optimizer thinclient plugin license would be able to see "Agent Group Relative Rank" during schedule bidding.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShowAgentRelativeRank { get; }
Visual Basic
Public ReadOnly Property ShowAgentRelativeRank As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the user can see ""Agent Group Relative Rank""; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


ShowMonitorColumns Property

[image]

IceLib Technical Reference
UserRightsSettings..::..ShowMonitorColumns Property
UserRightsSettings Class See Also Send Feedback
Gets the ShowMonitorColumns value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShowMonitorColumns { get; }
Visual Basic
Public ReadOnly Property ShowMonitorColumns As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user can show monitor columns; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


ShowScheduleBidding Property

[image]

IceLib Technical Reference
UserRightsSettings..::..ShowScheduleBidding Property
UserRightsSettings Class See Also Send Feedback
Gets the ShowScheduleBidding value. This right controls if an agent with optimizer thinclient plugin license would be able to see and access "Schedule Bidding" menu item.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShowScheduleBidding { get; }
Visual Basic
Public ReadOnly Property ShowScheduleBidding As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if user has access to "Schedule Bidding"; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

UserRightsSettings Class
UserRightsSettings Members
ININ.IceLib.People Namespace


UserRightsSettings Events

[image] [image]

IceLib Technical Reference
UserRightsSettings Events
UserRightsSettings Class See Also Send Feedback

The UserRightsSettings type exposes the following members.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserRightsSettings Class
ININ.IceLib.People Namespace


UserSettings Class

[image]

IceLib Technical Reference
UserSettings Class
Members See Also Send Feedback
Represents the basic settings for an IC user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserSettings
Visual Basic
Public Class UserSettings

Remarks

Derived classes must invoke the public constructor.
CopyC#
public class MyUserSettings : UserSettings
{
    public MyUserSettings(PeopleManager peopleManager) : base(peopleManager)
    {
    }
...
}

This class implements a watched attribute object for basic user settings for an IC user.

To start a watch call StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) with an array of attributes to watch. When the asynchronous start watch completes the completedCallback delegate is invoked. To stop a watch call StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object). When the asynchronous stop watch operation completes, the completedCallback delegate is invoked. To change the list of attributes that are watched call the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) with the new array of attributes to watch. When the asynchronous change watching operation completes, the completedCallback delegate is invoked.

When an attribute changes, the WatchedAttributesChanged event is triggered providing information about which attributes have changed.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) when a watch is already in place, or calling StopWatching()()()(), StopWatchingAsync(AsyncCompletedEventHandler, Object), ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean), or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) when a watch is not in place, raises the InvalidOperationException.

Accessing a property for an attribute that is not being watched raises the NotCachedException.

Note
The asynchronous version of these methods is preferred since the start, stop, and change watch operations can be lengthy.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserSettings
ININ.IceLib.People..::..UserAccessListsSettings
ININ.IceLib.People..::..UserDataSettings
ININ.IceLib.People..::..UserRightsSettings
ININ.IceLib.Tracker..::..UserTrackerRightsSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Members
ININ.IceLib.People Namespace


UserSettings Members

[image] [image]

IceLib Technical Reference
UserSettings Members
UserSettings Class Constructors Methods Events See Also Send Feedback

The UserSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserSettings | Initializes a new instance of the UserSettings class for the current session user.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch.
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes".
Public method | GetAttributeAsString | Gets the values for the named attribute.
Public method | GetAttributeAsStrings | Gets the string values for the named attribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes.
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes.
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes.
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes.
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes.
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes.
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings.
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings.
Public method | StopWatching | Stops watching user settings.
Public method | StopWatchingAsync | Asynchronously stops watching user settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed.

See Also

UserSettings Class
ININ.IceLib.People Namespace


UserSettings Constructor

[image]

IceLib Technical Reference
UserSettings Constructor
UserSettings Class See Also Send Feedback
Initializes a new instance of the UserSettings class for the current session user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserSettings(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


UserSettings Methods

[image] [image]

IceLib Technical Reference
UserSettings Methods
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch.
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes".
Public method | GetAttributeAsString | Gets the values for the named attribute.
Public method | GetAttributeAsStrings | Gets the string values for the named attribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes.
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes.
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes.
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes.
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes.
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes.
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings.
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings.
Public method | StopWatching | Stops watching user settings.
Public method | StopWatchingAsync | Asynchronously stops watching user settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserSettings Class
ININ.IceLib.People Namespace


ChangeWatchedAttributes Method

[image]

IceLib Technical Reference
UserSettings..::..ChangeWatchedAttributes Method
UserSettings Class See Also Send Feedback
Changes what attributes of the UserSettings are being watch.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributes(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedAttributes ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Derived classes have attribute classes which define the attributeNamesToAdd and attributeNamesToRemove strings each derived class can support. Custom strings may also be used for custom handlers. For a list of derived classes and their associated attribute classes see the StartWatching(array<String>[]()[][]) method.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is already being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


ChangeWatchedAttributesAsync Method

[image]

IceLib Technical Reference
UserSettings..::..ChangeWatchedAttributesAsync Method
UserSettings Class See Also Send Feedback
Asynchronously changes what attributes of the UserSettings are being watch.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributesAsync(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAttributesAsync ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Derived classes have attribute classes which define the attributeNamesToAdd and attributeNamesToRemove strings each derived class can support. Custom strings may also be used for custom handlers. For a list of derived classes and their associated attribute classes see the StartWatching(array<String>[]()[][]) method.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


GetAttributeAsBool Method

[image]

IceLib Technical Reference
UserSettings..::..GetAttributeAsBool Method
UserSettings Class See Also Send Feedback
Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes".

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool GetAttributeAsBool(
    string attributeName
)
Visual Basic
Public Function GetAttributeAsBool ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
Name of the attribute.

Return Value

trueTruetruetrue (True in Visual Basic) if the string value is set to "Yes".

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


GetAttributeAsString Method

[image]

IceLib Technical Reference
UserSettings..::..GetAttributeAsString Method
UserSettings Class See Also Send Feedback
Gets the values for the named attribute.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetAttributeAsString(
    string attributeName
)
Visual Basic
Public Function GetAttributeAsString ( _
    attributeName As String _
) As String

Parameters

attributeName
Type: System..::..String
Name of attribute to get.

Return Value

String value for that attribute. If this is a multi-value attribute, then the first value in the array is returned. If there is no value associated with this attribute then an empty string is returned.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


GetAttributeAsStrings Method

[image]

IceLib Technical Reference
UserSettings..::..GetAttributeAsStrings Method
UserSettings Class See Also Send Feedback
Gets the string values for the named attribute.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string[] GetAttributeAsStrings(
    string attributeName
)
Visual Basic
Public Function GetAttributeAsStrings ( _
    attributeName As String _
) As String()

Parameters

attributeName
Type: System..::..String
Name of attribute to get.

Return Value

The string array of values associated with this attribute.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
UserSettings..::..IsWatching Method
UserSettings Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
UserSettings..::..IsWatching Method
UserSettings Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
UserSettings..::..IsWatching Method (String)
UserSettings Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string attributeName
)
Visual Basic
Public Function IsWatching ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The setting.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
IsWatching Overload
ININ.IceLib.People Namespace


SetAttributeFromBool Method

[image]

IceLib Technical Reference
UserSettings..::..SetAttributeFromBool Method
UserSettings Class See Also Send Feedback
Sets attribute value and propagates the changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAttributeFromBool(
    string attributeName,
    bool attributeValue
)
Visual Basic
Public Sub SetAttributeFromBool ( _
    attributeName As String, _
    attributeValue As Boolean _
)

Parameters

attributeName
Type: System..::..String
The attribute names.
attributeValue
Type: System..::..Boolean
The attribute value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The attributeName length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


SetAttributeFromBoolAsync Method

[image]

IceLib Technical Reference
UserSettings..::..SetAttributeFromBoolAsync Method
UserSettings Class See Also Send Feedback
Asynchronously sets attribute value and propagates the changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAttributeFromBoolAsync(
    string attributeName,
    bool attributeValue,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetAttributeFromBoolAsync ( _
    attributeName As String, _
    attributeValue As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute names.
attributeValue
Type: System..::..Boolean
The attribute value.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The attributeName length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


SetAttributeFromString Method

[image]

IceLib Technical Reference
UserSettings..::..SetAttributeFromString Method
UserSettings Class See Also Send Feedback
Sets the attribute value and propagates the changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAttributeFromString(
    string attributeName,
    string attributeValue
)
Visual Basic
Public Sub SetAttributeFromString ( _
    attributeName As String, _
    attributeValue As String _
)

Parameters

attributeName
Type: System..::..String
The attribute names.
attributeValue
Type: System..::..String
The attribute value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The attributeName length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


SetAttributeFromStringAsync Method

[image]

IceLib Technical Reference
UserSettings..::..SetAttributeFromStringAsync Method
UserSettings Class See Also Send Feedback
Asynchronously sets the attribute value and propagates the changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAttributeFromStringAsync(
    string attributeName,
    string attributeValue,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetAttributeFromStringAsync ( _
    attributeName As String, _
    attributeValue As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute names.
attributeValue
Type: System..::..String
The attribute value.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The attributeName length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


SetAttributeFromStrings Method

[image]

IceLib Technical Reference
UserSettings..::..SetAttributeFromStrings Method
UserSettings Class See Also Send Feedback
Sets attribute value based on strings and propagates the changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAttributeFromStrings(
    string attributeName,
    string[] attributeValues
)
Visual Basic
Public Sub SetAttributeFromStrings ( _
    attributeName As String, _
    attributeValues As String() _
)

Parameters

attributeName
Type: System..::..String
The attribute names.
attributeValues
Type: array<System..::..String>[]()[][]
The attribute values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The attributeName length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


SetAttributeFromStringsAsync Method

[image]

IceLib Technical Reference
UserSettings..::..SetAttributeFromStringsAsync Method
UserSettings Class See Also Send Feedback
Asynchronously sets attribute value based on strings and propagates the changes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetAttributeFromStringsAsync(
    string attributeName,
    string[] attributeValues,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetAttributeFromStringsAsync ( _
    attributeName As String, _
    attributeValues As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeName
Type: System..::..String
The attribute names.
attributeValues
Type: array<System..::..String>[]()[][]
The attribute values.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The attributeName length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
UserSettings..::..StartWatching Method
UserSettings Class See Also Send Feedback
Starts watching the specified attributeNames for these UserSettings.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] attributeNames
)
Visual Basic
Public Sub StartWatching ( _
    attributeNames As String() _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
An array of settings to watch.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Derived classes have attribute classes which define the attributeNames strings each derived class can support. Custom strings may also be used for custom handlers.
Derived Class | Attribute Class
UserAccessListsSettings | UserAccessListsAttributes
UserDataSettings | UserDataAttributes
UserRightsSettings | UserRightsAttributes
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
UserSettings..::..StartWatchingAsync Method
UserSettings Class See Also Send Feedback
Asynchronously starts watching the specified attributeNames for these UserSettings.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] attributeNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    attributeNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
An array of settings to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).

Derived classes have attribute classes which define the attributeNames strings each derived class can support. Custom strings may also be used for custom handlers. For a list of derived classes and their associated attribute classes see the StartWatching(array<String>[]()[][]) method.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
UserSettings..::..StopWatching Method
UserSettings Class See Also Send Feedback
Stops watching user settings.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
UserSettings..::..StopWatchingAsync Method
UserSettings Class See Also Send Feedback
Asynchronously stops watching user settings.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


UserSettings Events

[image] [image]

IceLib Technical Reference
UserSettings Events
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed.

See Also

UserSettings Class
ININ.IceLib.People Namespace


WatchedAttributesChanged Event

[image]

IceLib Technical Reference
UserSettings..::..WatchedAttributesChanged Event
UserSettings Class See Also Send Feedback
Occurs when one of the watched attribute values has been changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedAttributesEventArgs> WatchedAttributesChanged
Visual Basic
Public Event WatchedAttributesChanged As EventHandler(Of WatchedAttributesEventArgs)

Remarks

This event will only occur when attributes being watched have changed. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserSettings Class
UserSettings Members
ININ.IceLib.People Namespace


UserStatus Class

[image]

IceLib Technical Reference
UserStatus Class
Members See Also Send Feedback
Represents a user's status watched object. For example, Available, Do Not Disturb and so on. Object instances of this class are managed by the UserStatusList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserStatus
Visual Basic
Public Class UserStatus

Remarks

Each property (with the exception of OnPhoneChangedHasValue, StatusChangedHasValue, and LoggedIn) is represented by an integer value within the UserStatusProperty enumeration. The user's status contains information such as a forward telephone number, status notes, a date and time until which the user will be in the selected status, the date and time they entered that status, and so on. Note that the OnPhoneChanged and StatusChanged datetime values only have granularity to the second, which means that multiple changes to those properties in the same second will only result in a single WatchedObjectsChanged notification.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserStatus

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Members
ININ.IceLib.People Namespace


UserStatus Members

[image] [image]

IceLib Technical Reference
UserStatus Members
UserStatus Class Methods Properties See Also Send Feedback

The UserStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ForwardNumber | Gets the status forwarded number.
Public property | ICServers | Gets the list of IC Servers.
Public property | IsInitialized | Indicates whether this status has been initialized and is valid.
Public property | IsStale | Gets a value indicating whether the user status is stale or not.
Public property | LoggedIn | Gets a value indicating whether the user is currently logged in.
Public property | Notes | Gets the status notes.
Public property | OnPhone | Gets a value indicating whether the user is on the phone.
Public property | OnPhoneChanged | Gets the time the current user went on the phone.
Public property | OnPhoneChangedHasValue | Returns if the server set a valid DateTime value for OnPhoneChanged.
Public property | PresenceServer | Gets the name of the server that is providing status for this user.
Public property | Stations | Gets the list of stations.
Public property | StatusChanged | Gets the time the user started in this status.
Public property | StatusChangedHasValue | Returns if the server set a valid DateTime value for StatusChanged.
Public property | StatusMessageDetails | Gets the status message definition.
Public property | UntilDate | Gets the status until date.
Public property | UntilTime | Gets the status until time.
Public property | UserId | Gets the unique identifier for this user status entry. This is the IC User name.

See Also

UserStatus Class
ININ.IceLib.People Namespace


UserStatus Methods

[image] [image]

IceLib Technical Reference
UserStatus Methods
UserStatus Class See Also Send Feedback

The UserStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserStatus Class
ININ.IceLib.People Namespace


UserStatus Properties

[image] [image]

IceLib Technical Reference
UserStatus Properties
UserStatus Class See Also Send Feedback

The UserStatus type exposes the following members.

Properties

 | Name | Description
Public property | ForwardNumber | Gets the status forwarded number.
Public property | ICServers | Gets the list of IC Servers.
Public property | IsInitialized | Indicates whether this status has been initialized and is valid.
Public property | IsStale | Gets a value indicating whether the user status is stale or not.
Public property | LoggedIn | Gets a value indicating whether the user is currently logged in.
Public property | Notes | Gets the status notes.
Public property | OnPhone | Gets a value indicating whether the user is on the phone.
Public property | OnPhoneChanged | Gets the time the current user went on the phone.
Public property | OnPhoneChangedHasValue | Returns if the server set a valid DateTime value for OnPhoneChanged.
Public property | PresenceServer | Gets the name of the server that is providing status for this user.
Public property | Stations | Gets the list of stations.
Public property | StatusChanged | Gets the time the user started in this status.
Public property | StatusChangedHasValue | Returns if the server set a valid DateTime value for StatusChanged.
Public property | StatusMessageDetails | Gets the status message definition.
Public property | UntilDate | Gets the status until date.
Public property | UntilTime | Gets the status until time.
Public property | UserId | Gets the unique identifier for this user status entry. This is the IC User name.

See Also

UserStatus Class
ININ.IceLib.People Namespace


ForwardNumber Property

[image]

IceLib Technical Reference
UserStatus..::..ForwardNumber Property
UserStatus Class See Also Send Feedback
Gets the status forwarded number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ForwardNumber { get; }
Visual Basic
Public ReadOnly Property ForwardNumber As String
    Get

Field Value

The forward number.

Remarks

This requires the view access right for Forward Number in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


ICServers Property

[image]

IceLib Technical Reference
UserStatus..::..ICServers Property
UserStatus Class See Also Send Feedback
Gets the list of IC Servers.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ICServers { get; }
Visual Basic
Public ReadOnly Property ICServers As ReadOnlyCollection(Of String)
    Get

Field Value

The IC servers.

Remarks

This requires the view access right for Status Summary in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


IsInitialized Property

[image]

IceLib Technical Reference
UserStatus..::..IsInitialized Property
UserStatus Class See Also Send Feedback
Indicates whether this status has been initialized and is valid.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsInitialized { get; }
Visual Basic
Public ReadOnly Property IsInitialized As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the status is initialized; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This requires the view access right for Activated in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


IsStale Property

[image]

IceLib Technical Reference
UserStatus..::..IsStale Property
UserStatus Class See Also Send Feedback
Gets a value indicating whether the user status is stale or not.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsStale { get; }
Visual Basic
Public ReadOnly Property IsStale As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if stale; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


LoggedIn Property

[image]

IceLib Technical Reference
UserStatus..::..LoggedIn Property
UserStatus Class See Also Send Feedback
Gets a value indicating whether the user is currently logged in.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool LoggedIn { get; }
Visual Basic
Public ReadOnly Property LoggedIn As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this user is logged in; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This requires the view access right for Logged In in Interaction Administrator. Starting in 2018 R5 trueTruetruetrue (True in Visual Basic) will be returned for stationless sessions. To get the old 2018 R4 behavior you can check if the status has any stations or ICServers.
CopyC#
bool loggedIn = (userStatus.Stations != null && userStatus.Stations.Length > 0) || (userStatus.ICServers != null && userStatus.ICServers.Length > 0);

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


Notes Property

[image]

IceLib Technical Reference
UserStatus..::..Notes Property
UserStatus Class See Also Send Feedback
Gets the status notes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; }
Visual Basic
Public ReadOnly Property Notes As String
    Get

Field Value

The notes.

Remarks

This requires the view access right for Notes in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


OnPhone Property

[image]

IceLib Technical Reference
UserStatus..::..OnPhone Property
UserStatus Class See Also Send Feedback
Gets a value indicating whether the user is on the phone.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool OnPhone { get; }
Visual Basic
Public ReadOnly Property OnPhone As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if on phone; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This requires the view access right for On Phone in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


OnPhoneChanged Property

[image]

IceLib Technical Reference
UserStatus..::..OnPhoneChanged Property
UserStatus Class See Also Send Feedback
Gets the time the current user went on the phone.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime OnPhoneChanged { get; }
Visual Basic
Public ReadOnly Property OnPhoneChanged As DateTime
    Get

Field Value

The time when the on phone changed.

Remarks

Note that this value only has granularity to the second, which means that multiple changes to this property in the same second will only result in a single WatchedObjectsChanged notification.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


OnPhoneChangedHasValue Property

[image]

IceLib Technical Reference
UserStatus..::..OnPhoneChangedHasValue Property
UserStatus Class See Also Send Feedback
Returns if the server set a valid DateTime value for OnPhoneChanged.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool OnPhoneChangedHasValue { get; }
Visual Basic
Public ReadOnly Property OnPhoneChangedHasValue As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the server set a valid DateTime value for OnPhoneChanged; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


PresenceServer Property

[image]

IceLib Technical Reference
UserStatus..::..PresenceServer Property
UserStatus Class See Also Send Feedback
Gets the name of the server that is providing status for this user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PresenceServer { get; }
Visual Basic
Public ReadOnly Property PresenceServer As String
    Get

Field Value

The server that provided this status information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


Stations Property

[image]

IceLib Technical Reference
UserStatus..::..Stations Property
UserStatus Class See Also Send Feedback
Gets the list of stations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Stations { get; }
Visual Basic
Public ReadOnly Property Stations As ReadOnlyCollection(Of String)
    Get

Field Value

The stations.

Remarks

This requires the view access right for Status Summary in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


StatusChanged Property

[image]

IceLib Technical Reference
UserStatus..::..StatusChanged Property
UserStatus Class See Also Send Feedback
Gets the time the user started in this status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime StatusChanged { get; }
Visual Basic
Public ReadOnly Property StatusChanged As DateTime
    Get

Field Value

The time when the status changed.

Remarks

Note that this value only has granularity to the second, which means that multiple changes to this property in the same second will only result in a single WatchedObjectsChanged notification. If the desire is to check for a change in a user's status, it is recommended to check StatusMessageDetails instead.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


StatusChangedHasValue Property

[image]

IceLib Technical Reference
UserStatus..::..StatusChangedHasValue Property
UserStatus Class See Also Send Feedback
Returns if the server set a valid DateTime value for StatusChanged.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool StatusChangedHasValue { get; }
Visual Basic
Public ReadOnly Property StatusChangedHasValue As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the server set a valid DateTime value for StatusChanged; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


StatusMessageDetails Property

[image]

IceLib Technical Reference
UserStatus..::..StatusMessageDetails Property
UserStatus Class See Also Send Feedback
Gets the status message definition.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageDetails StatusMessageDetails { get; }
Visual Basic
Public ReadOnly Property StatusMessageDetails As StatusMessageDetails
    Get

Field Value

The status message.

Remarks

This requires the view access right for Status in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


UntilDate Property

[image]

IceLib Technical Reference
UserStatus..::..UntilDate Property
UserStatus Class See Also Send Feedback
Gets the status until date.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> UntilDate { get; }
Visual Basic
Public ReadOnly Property UntilDate As Nullable(Of DateTime)
    Get

Field Value

The until date.

Remarks

This requires the view access right for Until in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


UntilTime Property

[image]

IceLib Technical Reference
UserStatus..::..UntilTime Property
UserStatus Class See Also Send Feedback
Gets the status until time.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> UntilTime { get; }
Visual Basic
Public ReadOnly Property UntilTime As Nullable(Of DateTime)
    Get

Field Value

The until time.

Remarks

This requires the view access right for Until in Interaction Administrator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


UserId Property

[image]

IceLib Technical Reference
UserStatus..::..UserId Property
UserStatus Class See Also Send Feedback
Gets the unique identifier for this user status entry. This is the IC User name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatus Class
UserStatus Members
ININ.IceLib.People Namespace


UserStatusList Class

[image]

IceLib Technical Reference
UserStatusList Class
Members See Also Send Feedback
Represents a list of watched user statuses (UserStatus).

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserStatusList
Visual Basic
Public Class UserStatusList

Remarks

This class allows you to start, stop, and change watches on the user status for a number of users. To start a watch for an array of users, call StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) methods with an array of user IDs. When the asynchronous start watch operation completes, the completedCallback delegate is invoked.

You can change the users for which you want to monitor their status by calling the ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedUsersAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) methods and passing an array of user IDs. When the asynchronous change watch operation completes, the completedCallback delegate is invoked.

You can stop watching user status by calling the StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods. When the asynchronous stop watch operation completes the completedCallback delegate is invoked.

To get the list of watched user status, call the GetList()()()() method. An InvalidOperationException is raised if a watch is not in progress.

When a user status changes, the WatchedObjectsChanged event is triggered, providing information on the user status that has changed.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) when a watch has already been started, or calling ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean), ChangeWatchedUsersAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object), StopWatching()()()(), or StopWatchingAsync(AsyncCompletedEventHandler, Object) when a watch is not in progress raises the InvalidOperationException.

Note
The asynchronous methods are preferred since the start, change, and stop watch can be lengthy operations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserStatusList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Members
ININ.IceLib.People Namespace


UserStatusList Members

[image] [image]

IceLib Technical Reference
UserStatusList Members
UserStatusList Class Constructors Methods Properties Events See Also Send Feedback

The UserStatusList type exposes the following members.

Constructors

 | Name | Description
Public method | UserStatusList | Initializes a new instance of the UserStatusList class.

Methods

 | Name | Description
Public method | ChangeWatchedUsers | Changes the users being watched.
Public method | ChangeWatchedUsersAsync | Asynchronously changes the users being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of user statuses being watched.
Public method | GetPreviousStatusInfo()()()() | Gets the previous status info for the Session User from the server.
Public method | GetPreviousStatusInfo(String) | Gets the previous status info for a User from the server.
Public method | GetPreviousStatusInfoAsync(EventHandler<(Of <<'(GetPreviousStatusInfoCompletedEventArgs>)>>), Object) | Asynchronously gets the previous status info for the Session User from the server.
Public method | GetPreviousStatusInfoAsync(String, EventHandler<(Of <<'(GetPreviousStatusInfoCompletedEventArgs>)>>), Object) | Asynchronously gets the previous status info for a User from the server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserStatus | Gets the status for a User from the server.
Public method | GetUserStatusAsync | Asynchronously gets the status for a User from the server.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the User Status List.
Public method | StartWatchingAsync | Asynchronously starts watching the User Status List.
Public method | StopWatching | Stops watching the User Status List.
Public method | StopWatchingAsync | Asynchronously stops watching the User Status List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get an individual status for a user.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the UserStatus watched objects has changed.

See Also

UserStatusList Class
ININ.IceLib.People Namespace


UserStatusList Constructor

[image]

IceLib Technical Reference
UserStatusList Constructor
UserStatusList Class See Also Send Feedback
Initializes a new instance of the UserStatusList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatusList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


UserStatusList Methods

[image] [image]

IceLib Technical Reference
UserStatusList Methods
UserStatusList Class See Also Send Feedback

The UserStatusList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedUsers | Changes the users being watched.
Public method | ChangeWatchedUsersAsync | Asynchronously changes the users being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of user statuses being watched.
Public method | GetPreviousStatusInfo()()()() | Gets the previous status info for the Session User from the server.
Public method | GetPreviousStatusInfo(String) | Gets the previous status info for a User from the server.
Public method | GetPreviousStatusInfoAsync(EventHandler<(Of <<'(GetPreviousStatusInfoCompletedEventArgs>)>>), Object) | Asynchronously gets the previous status info for the Session User from the server.
Public method | GetPreviousStatusInfoAsync(String, EventHandler<(Of <<'(GetPreviousStatusInfoCompletedEventArgs>)>>), Object) | Asynchronously gets the previous status info for a User from the server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserStatus | Gets the status for a User from the server.
Public method | GetUserStatusAsync | Asynchronously gets the status for a User from the server.
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the User Status List.
Public method | StartWatchingAsync | Asynchronously starts watching the User Status List.
Public method | StopWatching | Stops watching the User Status List.
Public method | StopWatchingAsync | Asynchronously stops watching the User Status List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserStatusList Class
ININ.IceLib.People Namespace


ChangeWatchedUsers Method

[image]

IceLib Technical Reference
UserStatusList..::..ChangeWatchedUsers Method
UserStatusList Class See Also Send Feedback
Changes the users being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedUsers(
    string[] userIDsToAdd,
    string[] userIDsToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedUsers ( _
    userIDsToAdd As String(), _
    userIDsToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

userIDsToAdd
Type: array<System..::..String>[]()[][]
The user IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
userIDsToRemove
Type: array<System..::..String>[]()[][]
The user IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


ChangeWatchedUsersAsync Method

[image]

IceLib Technical Reference
UserStatusList..::..ChangeWatchedUsersAsync Method
UserStatusList Class See Also Send Feedback
Asynchronously changes the users being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedUsersAsync(
    string[] userIDsToAdd,
    string[] userIDsToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedUsersAsync ( _
    userIDsToAdd As String(), _
    userIDsToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIDsToAdd
Type: array<System..::..String>[]()[][]
The user IDs to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
userIDsToRemove
Type: array<System..::..String>[]()[][]
The user IDs to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


GetList Method

[image]

IceLib Technical Reference
UserStatusList..::..GetList Method
UserStatusList Class See Also Send Feedback
Get a list of user statuses being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<UserStatus> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of UserStatus)

Return Value

A list of UserStatus.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | If the user status list is not cached.
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


GetPreviousStatusInfo Method

[image] [image]

IceLib Technical Reference
UserStatusList..::..GetPreviousStatusInfo Method
UserStatusList Class See Also Send Feedback
Gets the previous status info for the Session User from the server.

Overload List

 | Name | Description
Public method | GetPreviousStatusInfo()()()() | Gets the previous status info for the Session User from the server.
Public method | GetPreviousStatusInfo(String) | Gets the previous status info for a User from the server.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


GetPreviousStatusInfo Method

[image]

IceLib Technical Reference
UserStatusList..::..GetPreviousStatusInfo Method
UserStatusList Class See Also Send Feedback
Gets the previous status info for the Session User from the server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Dictionary<string, UserStatusPreviousInfo> GetPreviousStatusInfo()
Visual Basic
Public Function GetPreviousStatusInfo As Dictionary(Of String, UserStatusPreviousInfo)

Return Value

The UserStatusPreviousInfo collection that was returned.

Remarks

This can be useful for pre-filling previous values when a User is setting a status, so that old status info can be pre-populated into a dialog. The data can then be used with the UserStatusUpdate class to retain previous values. The same result could be obtained by setting the Notes and Forward Number to nullNothingnullptra null reference (Nothing in Visual Basic) in the UserStatusUpdate class, but usage of the GetPreviousStatusInfo method can allow the user to know what values will be set ahead of time.

Note
Only returns results for statuses that have had Notes or a ForwardNumber previously set.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
GetPreviousStatusInfo Overload
ININ.IceLib.People Namespace


GetPreviousStatusInfo Method (String)

[image]

IceLib Technical Reference
UserStatusList..::..GetPreviousStatusInfo Method (String)
UserStatusList Class See Also Send Feedback
Gets the previous status info for a User from the server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Dictionary<string, UserStatusPreviousInfo> GetPreviousStatusInfo(
    string userId
)
Visual Basic
Public Function GetPreviousStatusInfo ( _
    userId As String _
) As Dictionary(Of String, UserStatusPreviousInfo)

Parameters

userId
Type: System..::..String
The user ID.

Return Value

The UserStatusPreviousInfo collection that was returned.

Remarks

This can be useful for pre-filling previous values when a User is setting a status, so that old status info can be pre-populated into a dialog. The data can then be used with the UserStatusUpdate class to retain previous values. The same result could be obtained by setting the Notes and Forward Number to nullNothingnullptra null reference (Nothing in Visual Basic) in the UserStatusUpdate class, but usage of the GetPreviousStatusInfo method can allow the user to know what values will be set ahead of time.

Note
Only returns results for statuses that have had Notes or a ForwardNumber previously set.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
GetPreviousStatusInfo Overload
ININ.IceLib.People Namespace


GetPreviousStatusInfoAsync Method

[image] [image]

IceLib Technical Reference
UserStatusList..::..GetPreviousStatusInfoAsync Method
UserStatusList Class See Also Send Feedback
Asynchronously gets the previous status info for the Session User from the server.

Overload List

 | Name | Description
Public method | GetPreviousStatusInfoAsync(EventHandler<(Of <<'(GetPreviousStatusInfoCompletedEventArgs>)>>), Object) | Asynchronously gets the previous status info for the Session User from the server.
Public method | GetPreviousStatusInfoAsync(String, EventHandler<(Of <<'(GetPreviousStatusInfoCompletedEventArgs>)>>), Object) | Asynchronously gets the previous status info for a User from the server.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


GetPreviousStatusInfoAsync Method (EventHandler(GetPreviousStatusInfoCompletedEventArgs), Object)

[image]

IceLib Technical Reference
UserStatusList..::..GetPreviousStatusInfoAsync Method (EventHandler<(Of <(<'GetPreviousStatusInfoCompletedEventArgs>)>)>, Object)
UserStatusList Class See Also Send Feedback
Asynchronously gets the previous status info for the Session User from the server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetPreviousStatusInfoAsync(
    EventHandler<GetPreviousStatusInfoCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetPreviousStatusInfoAsync ( _
    completedCallback As EventHandler(Of GetPreviousStatusInfoCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetPreviousStatusInfoCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This can be useful for pre-filling previous values when a User is setting a status, so that old status info can be pre-populated into a dialog. The data can then be used with the UserStatusUpdate class to retain previous values. The same result could be obtained by setting the Notes and Forward Number to nullNothingnullptra null reference (Nothing in Visual Basic) in the UserStatusUpdate class, but usage of the GetPreviousStatusInfo method can allow the user to know what values will be set ahead of time.

Note
Only returns results for statuses that have had Notes or a ForwardNumber previously set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
GetPreviousStatusInfoAsync Overload
ININ.IceLib.People Namespace


GetPreviousStatusInfoAsync Method (String, EventHandler(GetPreviousStatusInfoCompletedEventArgs), Object)

[image]

IceLib Technical Reference
UserStatusList..::..GetPreviousStatusInfoAsync Method (String, EventHandler<(Of <(<'GetPreviousStatusInfoCompletedEventArgs>)>)>, Object)
UserStatusList Class See Also Send Feedback
Asynchronously gets the previous status info for a User from the server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetPreviousStatusInfoAsync(
    string userId,
    EventHandler<GetPreviousStatusInfoCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetPreviousStatusInfoAsync ( _
    userId As String, _
    completedCallback As EventHandler(Of GetPreviousStatusInfoCompletedEventArgs), _
    userState As Object _
)

Parameters

userId
Type: System..::..String
The user ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetPreviousStatusInfoCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This can be useful for pre-filling previous values when a User is setting a status, so that old status info can be pre-populated into a dialog. The data can then be used with the UserStatusUpdate class to retain previous values. The same result could be obtained by setting the Notes and Forward Number to nullNothingnullptra null reference (Nothing in Visual Basic) in the UserStatusUpdate class, but usage of the GetPreviousStatusInfo method can allow the user to know what values will be set ahead of time.

Note
Only returns results for statuses that have had Notes or a ForwardNumber previously set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
GetPreviousStatusInfoAsync Overload
ININ.IceLib.People Namespace


GetUserStatus Method

[image]

IceLib Technical Reference
UserStatusList..::..GetUserStatus Method
UserStatusList Class See Also Send Feedback
Gets the status for a User from the server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatus GetUserStatus(
    string userId
)
Visual Basic
Public Function GetUserStatus ( _
    userId As String _
) As UserStatus

Parameters

userId
Type: System..::..String
The user ID.

Return Value

The UserStatus.

Remarks

This method will return the value from the cache, if the user's status is cached. If the user's status is not being cached, it will send a request to the server and get the status.

Note
This method can be particularly inefficient if neither a UserStatusList watch nor a StatusMessageList watch is active since both the UserStatus and its StatusMessageDetails must be queried from the server. If neither of these watches is active, please consider maintaining a StatusMessageList watch.

If StartWatching(array<String>[]()[][]) was recently called but has not finished updating the cache, the result's IsInitialized property will be false, indicating the returned value is invalid.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


GetUserStatusAsync Method

[image]

IceLib Technical Reference
UserStatusList..::..GetUserStatusAsync Method
UserStatusList Class See Also Send Feedback
Asynchronously gets the status for a User from the server.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetUserStatusAsync(
    string userId,
    EventHandler<GetUserStatusCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetUserStatusAsync ( _
    userId As String, _
    completedCallback As EventHandler(Of GetUserStatusCompletedEventArgs), _
    userState As Object _
)

Parameters

userId
Type: System..::..String
The user ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetUserStatusCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will return the value from the cache, if the user's status is cached. If the user's status is not being cached, it will send a request to the server and get the status.

If StartWatching(array<String>[]()[][]) was recently called but has not finished updating the cache, the result's IsInitialized property will be false, indicating the returned value is invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
UserStatusList..::..IsWatching Method
UserStatusList Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
UserStatusList..::..IsWatching Method
UserStatusList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
UserStatusList..::..IsWatching Method (String)
UserStatusList Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string userId
)
Visual Basic
Public Function IsWatching ( _
    userId As String _
) As Boolean

Parameters

userId
Type: System..::..String
The user.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
IsWatching Overload
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
UserStatusList..::..StartWatching Method
UserStatusList Class See Also Send Feedback
Starts watching the User Status List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] userIds
)
Visual Basic
Public Sub StartWatching ( _
    userIds As String() _
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
An array of user IDs for watching user status.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Calls to GetList()()()() and GetUserStatus(String) after calling StartWatching(array<String>[]()[][]) should wait until after the first WatchedObjectsChanged event is fired. Otherwise IsInitialized will be false, indicating that the returned status is invalid.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
UserStatusList..::..StartWatchingAsync Method
UserStatusList Class See Also Send Feedback
Asynchronously starts watching the User Status List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] userIds,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    userIds As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
An array of user IDs for watching user status.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Calls to GetList()()()() and GetUserStatus(String) after calling StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) should wait until after the first WatchedObjectsChanged event is fired. Otherwise IsInitialized will be false, indicating that the returned status is invalid.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
UserStatusList..::..StopWatching Method
UserStatusList Class See Also Send Feedback
Stops watching the User Status List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
UserStatusList..::..StopWatchingAsync Method
UserStatusList Class See Also Send Feedback
Asynchronously stops watching the User Status List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


UserStatusList Properties

[image] [image]

IceLib Technical Reference
UserStatusList Properties
UserStatusList Class See Also Send Feedback

The UserStatusList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Get an individual status for a user.

See Also

UserStatusList Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
UserStatusList..::..Item Property
UserStatusList Class See Also Send Feedback
Get an individual status for a user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatus this[
    string userId
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    userId As String _
) As UserStatus
    Get

Parameters

userId
Type: System..::..String
The status to get.

Field Value

The status details.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | If the requested userId is not in the cache.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


UserStatusList Events

[image] [image]

IceLib Technical Reference
UserStatusList Events
UserStatusList Class See Also Send Feedback

The UserStatusList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the UserStatus watched objects has changed.

See Also

UserStatusList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
UserStatusList..::..WatchedObjectsChanged Event
UserStatusList Class See Also Send Feedback
Occurs when one of the UserStatus watched objects has changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedObjectsEventArgs<UserStatusProperty>> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of WatchedObjectsEventArgs(Of UserStatusProperty))

Remarks

Note that only changes to existing objects in the watch are monitored. There are no objects added to or removed from the UserStatusList watched objects.

Each Changed notification for a UserStatus object is described by the integer values defined in the UserStatusProperty enumeration.

This event will only occur when users being watched have changed. To start watching for users call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which users are being watched once the watch has been started, use the ChangeWatchedUsers(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusList Class
UserStatusList Members
ININ.IceLib.People Namespace


UserStatusPreviousInfo Class

[image]

IceLib Technical Reference
UserStatusPreviousInfo Class
Members See Also Send Feedback
Represents a user's previous status settings for a particular status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserStatusPreviousInfo
Visual Basic
Public Class UserStatusPreviousInfo

Remarks

This is used with the UserStatusList GetPreviousStatusInfo methods.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserStatusPreviousInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusPreviousInfo Members
ININ.IceLib.People Namespace


UserStatusPreviousInfo Members

[image] [image]

IceLib Technical Reference
UserStatusPreviousInfo Members
UserStatusPreviousInfo Class Methods Properties See Also Send Feedback

The UserStatusPreviousInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ForwardNumber | Gets the status forwarded number.
Public property | Notes | Gets the status notes.
Public property | StatusId | The status message identifier. Use this ID to access the status message definition defined in StatusMessageList.

See Also

UserStatusPreviousInfo Class
ININ.IceLib.People Namespace


UserStatusPreviousInfo Methods

[image] [image]

IceLib Technical Reference
UserStatusPreviousInfo Methods
UserStatusPreviousInfo Class See Also Send Feedback

The UserStatusPreviousInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserStatusPreviousInfo Class
ININ.IceLib.People Namespace


UserStatusPreviousInfo Properties

[image] [image]

IceLib Technical Reference
UserStatusPreviousInfo Properties
UserStatusPreviousInfo Class See Also Send Feedback

The UserStatusPreviousInfo type exposes the following members.

Properties

 | Name | Description
Public property | ForwardNumber | Gets the status forwarded number.
Public property | Notes | Gets the status notes.
Public property | StatusId | The status message identifier. Use this ID to access the status message definition defined in StatusMessageList.

See Also

UserStatusPreviousInfo Class
ININ.IceLib.People Namespace


ForwardNumber Property

[image]

IceLib Technical Reference
UserStatusPreviousInfo..::..ForwardNumber Property
UserStatusPreviousInfo Class See Also Send Feedback
Gets the status forwarded number.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ForwardNumber { get; internal set; }
Visual Basic
Public Property ForwardNumber As String
    Get
    Friend Set

Field Value

The forward number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusPreviousInfo Class
UserStatusPreviousInfo Members
ININ.IceLib.People Namespace


Notes Property

[image]

IceLib Technical Reference
UserStatusPreviousInfo..::..Notes Property
UserStatusPreviousInfo Class See Also Send Feedback
Gets the status notes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; internal set; }
Visual Basic
Public Property Notes As String
    Get
    Friend Set

Field Value

The notes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusPreviousInfo Class
UserStatusPreviousInfo Members
ININ.IceLib.People Namespace


StatusId Property

[image]

IceLib Technical Reference
UserStatusPreviousInfo..::..StatusId Property
UserStatusPreviousInfo Class See Also Send Feedback
The status message identifier. Use this ID to access the status message definition defined in StatusMessageList.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StatusId { get; }
Visual Basic
Public ReadOnly Property StatusId As String
    Get

Field Value

The status ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusPreviousInfo Class
UserStatusPreviousInfo Members
ININ.IceLib.People Namespace


UserStatusProperty Enumeration

[image]

IceLib Technical Reference
UserStatusProperty Enumeration
See Also Send Feedback
Each value in this enumeration represents a property in UserStatus.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum UserStatusProperty
Visual Basic
Public Enumeration UserStatusProperty

Members

Member name | Value | Description
None | 0 | No property is defined.
UserId | 1 | Represents the UserId property.
StatusMessageDetails | 2 | Represents the StatusMessageDetails property.
Notes | 3 | Represents the Notes property.
ForwardNumber | 4 | Represents the ForwardNumber property.
UntilDate | 5 | Represents the UntilDate property.
UntilTime | 6 | Represents the UntilTime property.
OnPhone | 7 | Represents the OnPhone property.
OnPhoneChanged | 8 | Represents the OnPhoneChanged property.
StatusChanged | 9 | Represents the StatusChanged property.
Stations | 10 | Represents the Stations property.
ICServers | 11 | Represents the ICServers property.
IsStale | 12 | Represents the IsStale property.
PresenceServer | 13 | Represents the PresenceServer property.
IsInitialized | 14 | Represents the IsInitialized property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


UserStatusUpdate Class

[image]

IceLib Technical Reference
UserStatusUpdate Class
Members See Also Send Feedback
This object is used to change a user's status.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserStatusUpdate
Visual Basic
Public Class UserStatusUpdate

Remarks

To change a user's status, create an instance of this object and supply the desired UserStatus, and then call either the UpdateRequest()()()() or UpdateRequestAsync(AsyncCompletedEventHandler, Object) methods. If you use the asynchronous version of this method, the UpdateRequest()()()() event will be triggered when the update of the user's status has completed.

Note
The asynchronous method is preferred since the update can be a lengthy operation.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserStatusUpdate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Members
ININ.IceLib.People Namespace


UserStatusUpdate Members

[image] [image]

IceLib Technical Reference
UserStatusUpdate Members
UserStatusUpdate Class Constructors Methods Properties See Also Send Feedback

The UserStatusUpdate type exposes the following members.

Constructors

 | Name | Description
Public method | UserStatusUpdate(PeopleManager) | Constructs a UserStatusUpdate object.
Public method | UserStatusUpdate(PeopleManager, UserStatus) | Constructs a UserStatusUpdate object from a UserStatus.
Public method | UserStatusUpdate(PeopleManager, String) | Constructs a UserStatusUpdate object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRequest | Updates the user status with the specified settings.
Public method | UpdateRequestAsync | Asynchronously updates the user status with the specified settings.

Properties

 | Name | Description
Public property | ForwardNumber | Gets or sets the status forwarded number. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Notes | Gets or sets the status notes. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StatusMessageDetails | Gets or sets the status message.
Public property | UntilDate | Gets or sets the status until date.
Public property | UntilTime | Gets or sets the status until time.
Public property | UserId | Gets or sets the unique identifier for this user status to update. This is the IC User name.

See Also

UserStatusUpdate Class
ININ.IceLib.People Namespace


UserStatusUpdate Constructor

[image] [image]

IceLib Technical Reference
UserStatusUpdate Constructor
UserStatusUpdate Class See Also Send Feedback
Initializes a new instance of the UserStatusUpdate class.

Overload List

 | Name | Description
Public method | UserStatusUpdate(PeopleManager) | Constructs a UserStatusUpdate object.
Public method | UserStatusUpdate(PeopleManager, UserStatus) | Constructs a UserStatusUpdate object from a UserStatus.
Public method | UserStatusUpdate(PeopleManager, String) | Constructs a UserStatusUpdate object.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UserStatusUpdate Constructor (PeopleManager)

[image]

IceLib Technical Reference
UserStatusUpdate Constructor (PeopleManager)
UserStatusUpdate Class See Also Send Feedback
Constructs a UserStatusUpdate object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatusUpdate(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Remarks

This will update the status of the Session user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
UserStatusUpdate Overload
ININ.IceLib.People Namespace


UserStatusUpdate Constructor (PeopleManager, UserStatus)

[image]

IceLib Technical Reference
UserStatusUpdate Constructor (PeopleManager, UserStatus)
UserStatusUpdate Class See Also Send Feedback
Constructs a UserStatusUpdate object from a UserStatus.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatusUpdate(
    PeopleManager peopleManager,
    UserStatus userStatus
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager, _
    userStatus As UserStatus _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.
userStatus
Type: ININ.IceLib.People..::..UserStatus
Initial parameters are copied from the UserStatus watched object.

Remarks

The userStatus instance's StatusMessageDetails must be valid. Check the IsValid property before calling this constructor.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The userStatus instance's StatusMessageDetails is not valid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
UserStatusUpdate Overload
ININ.IceLib.People Namespace


UserStatusUpdate Constructor (PeopleManager, String)

[image]

IceLib Technical Reference
UserStatusUpdate Constructor (PeopleManager, String)
UserStatusUpdate Class See Also Send Feedback
Constructs a UserStatusUpdate object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserStatusUpdate(
    PeopleManager peopleManager,
    string userId
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager, _
    userId As String _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.
userId
Type: System..::..String
The user ID.

Remarks

This will update the status of the Session user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
UserStatusUpdate Overload
ININ.IceLib.People Namespace


UserStatusUpdate Methods

[image] [image]

IceLib Technical Reference
UserStatusUpdate Methods
UserStatusUpdate Class See Also Send Feedback

The UserStatusUpdate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRequest | Updates the user status with the specified settings.
Public method | UpdateRequestAsync | Asynchronously updates the user status with the specified settings.

See Also

UserStatusUpdate Class
ININ.IceLib.People Namespace


UpdateRequest Method

[image]

IceLib Technical Reference
UserStatusUpdate..::..UpdateRequest Method
UserStatusUpdate Class See Also Send Feedback
Updates the user status with the specified settings.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateRequest()
Visual Basic
Public Sub UpdateRequest

Remarks

If the status is not able to be set, an IceLibException will be thrown. Examples are:

  • The status is a forward status and the ForwardNumber is not able to be converted into a phone number.
  • The status is a forward status, no ForwardNumber was specified, and no previous forward number had existed for the status.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibException | The User's status was not able to be set or the Session does not have a valid connection.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UpdateRequestAsync Method

[image]

IceLib Technical Reference
UserStatusUpdate..::..UpdateRequestAsync Method
UserStatusUpdate Class See Also Send Feedback
Asynchronously updates the user status with the specified settings.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateRequestAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateRequestAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

If the status is not able to be set, an IceLibException will be returned to the callback. Examples are:

  • The status is a forward status and the ForwardNumber is not able to be converted into a phone number.
  • The status is a forward status, no ForwardNumber was specified, and no previous forward number had existed for the status.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UserStatusUpdate Properties

[image] [image]

IceLib Technical Reference
UserStatusUpdate Properties
UserStatusUpdate Class See Also Send Feedback

The UserStatusUpdate type exposes the following members.

Properties

 | Name | Description
Public property | ForwardNumber | Gets or sets the status forwarded number. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Notes | Gets or sets the status notes. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StatusMessageDetails | Gets or sets the status message.
Public property | UntilDate | Gets or sets the status until date.
Public property | UntilTime | Gets or sets the status until time.
Public property | UserId | Gets or sets the unique identifier for this user status to update. This is the IC User name.

See Also

UserStatusUpdate Class
ININ.IceLib.People Namespace


ForwardNumber Property

[image]

IceLib Technical Reference
UserStatusUpdate..::..ForwardNumber Property
UserStatusUpdate Class See Also Send Feedback
Gets or sets the status forwarded number. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ForwardNumber { get; set; }
Visual Basic
Public Property ForwardNumber As String
    Get
    Set

Field Value

The forward number.

Remarks

If nullNothingnullptra null reference (Nothing in Visual Basic), the value last associated with this statusKey will be used.

Exceptions

Exception | Condition
System..::..ArgumentException | The value length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


Notes Property

[image]

IceLib Technical Reference
UserStatusUpdate..::..Notes Property
UserStatusUpdate Class See Also Send Feedback
Gets or sets the status notes. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Notes { get; set; }
Visual Basic
Public Property Notes As String
    Get
    Set

Field Value

The notes.

Remarks

If nullNothingnullptra null reference (Nothing in Visual Basic), the value last associated with this statusKey will be used.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


StatusMessageDetails Property

[image]

IceLib Technical Reference
UserStatusUpdate..::..StatusMessageDetails Property
UserStatusUpdate Class See Also Send Feedback
Gets or sets the status message.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatusMessageDetails StatusMessageDetails { get; set; }
Visual Basic
Public Property StatusMessageDetails As StatusMessageDetails
    Get
    Set

Field Value

The status message.

Remarks

The status message must be valid. Check the IsValid property before calling this property.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The StatusMessageDetails is not valid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UntilDate Property

[image]

IceLib Technical Reference
UserStatusUpdate..::..UntilDate Property
UserStatusUpdate Class See Also Send Feedback
Gets or sets the status until date.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> UntilDate { get; set; }
Visual Basic
Public Property UntilDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The until date.

Remarks

Note
This property will only be applied if CanHaveDate is trueTruetruetrue (True in Visual Basic).
Note
Only the date portion will be used, with the time set to midnight.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UntilTime Property

[image]

IceLib Technical Reference
UserStatusUpdate..::..UntilTime Property
UserStatusUpdate Class See Also Send Feedback
Gets or sets the status until time.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> UntilTime { get; set; }
Visual Basic
Public Property UntilTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The until time.

Remarks

Note
This property will only be applied if CanHaveTime is trueTruetruetrue (True in Visual Basic).
Note
Only the hours and minutes portions will be used, with the date set to today's date.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UserId Property

[image]

IceLib Technical Reference
UserStatusUpdate..::..UserId Property
UserStatusUpdate Class See Also Send Feedback
Gets or sets the unique identifier for this user status to update. This is the IC User name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set

Field Value

The user ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The value length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserStatusUpdate Class
UserStatusUpdate Members
ININ.IceLib.People Namespace


UserWorkgroupActivation Class

[image]

IceLib Technical Reference
UserWorkgroupActivation Class
Members See Also Send Feedback
Represents the status of a user's activation in a workgroup. When a user is activated in a workgroup, then the user is eligible to handle ACD interactions.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserWorkgroupActivation
Visual Basic
Public Class UserWorkgroupActivation

Remarks

This class contains the name of a workgroup and a boolean flag to indicate if the user is activated in that workgroup. Agents and supervisors can activate/deactivate an agent from an ACD workgroup.

Object instances of this class are managed by the UserWorkgroupActivationList class. Each property is represented by an integer value in the UserWorkgroupActivationProperty enumeration.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserWorkgroupActivation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivation Members
ININ.IceLib.People Namespace


UserWorkgroupActivation Members

[image] [image]

IceLib Technical Reference
UserWorkgroupActivation Members
UserWorkgroupActivation Class Methods Properties See Also Send Feedback

The UserWorkgroupActivation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActivationsForUser | Gets the workgroup activations for the given user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserWorkgroupActivations | Given a list of workgroups to which the current user is assigned, this method returns an array of booleans indicating if the user is activated in the workgroup.
 | GetUserWorkgroups | Retrieves the list of workgroups to which a user is assigned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsActive | Retruns trueTruetruetrue (True in Visual Basic) if the user is activated in this workgroup.
Public property | UserId | The user identifier.
Public property | Workgroup | A workgroup to which this user is assigned.

See Also

UserWorkgroupActivation Class
ININ.IceLib.People Namespace


UserWorkgroupActivation Methods

[image] [image]

IceLib Technical Reference
UserWorkgroupActivation Methods
UserWorkgroupActivation Class See Also Send Feedback

The UserWorkgroupActivation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetActivationsForUser | Gets the workgroup activations for the given user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserWorkgroupActivations | Given a list of workgroups to which the current user is assigned, this method returns an array of booleans indicating if the user is activated in the workgroup.
 | GetUserWorkgroups | Retrieves the list of workgroups to which a user is assigned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserWorkgroupActivation Class
ININ.IceLib.People Namespace


GetActivationsForUser Method

[image]

IceLib Technical Reference
UserWorkgroupActivation..::..GetActivationsForUser Method
UserWorkgroupActivation Class See Also Send Feedback
Gets the workgroup activations for the given user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<UserWorkgroupActivation> GetActivationsForUser(
    PeopleManager peopleManager,
    string userId
)
Visual Basic
Public Shared Function GetActivationsForUser ( _
    peopleManager As PeopleManager, _
    userId As String _
) As ReadOnlyCollection(Of UserWorkgroupActivation)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
The people manager.
userId
Type: System..::..String
The user id.

Return Value

The list of workgroups and activations for the supplied user.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.

Exceptions

Exception | Condition
System..::..ArgumentNullException | An argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An argument is Empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

UserWorkgroupActivation Class
UserWorkgroupActivation Members
ININ.IceLib.People Namespace


GetUserWorkgroupActivations Method

[image]

IceLib Technical Reference
UserWorkgroupActivation..::..GetUserWorkgroupActivations Method
UserWorkgroupActivation Class See Also Send Feedback
Given a list of workgroups to which the current user is assigned, this method returns an array of booleans indicating if the user is activated in the workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<bool> GetUserWorkgroupActivations(
    PeopleManager peopleManager,
    ICollection<string> workgroups
)
Visual Basic
Public Shared Function GetUserWorkgroupActivations ( _
    peopleManager As PeopleManager, _
    workgroups As ICollection(Of String) _
) As ReadOnlyCollection(Of Boolean)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
The PeopleManager instance.
workgroups
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The ReadOnlyCollection<(Of <(<'T>)>)> of workgroups to which the user is assigned.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of workgroup activation flags.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivation Class
UserWorkgroupActivation Members
ININ.IceLib.People Namespace


GetUserWorkgroups Method

[image]

IceLib Technical Reference
UserWorkgroupActivation..::..GetUserWorkgroups Method
UserWorkgroupActivation Class See Also Send Feedback
Retrieves the list of workgroups to which a user is assigned.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReadOnlyCollection<string> GetUserWorkgroups(
    PeopleManager peopleManager
)
Visual Basic
Public Shared Function GetUserWorkgroups ( _
    peopleManager As PeopleManager _
) As ReadOnlyCollection(Of String)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
An instance of PeopleManager.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> containing the workgroups to which the current user is a assigned.

Remarks

Note
This method call will result in a call to the server. This call can potentially time out, and caution should be taken to ensure that this call is made as few times as possible.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivation Class
UserWorkgroupActivation Members
ININ.IceLib.People Namespace


UserWorkgroupActivation Properties

[image] [image]

IceLib Technical Reference
UserWorkgroupActivation Properties
UserWorkgroupActivation Class See Also Send Feedback

The UserWorkgroupActivation type exposes the following members.

Properties

 | Name | Description
Public property | IsActive | Retruns trueTruetruetrue (True in Visual Basic) if the user is activated in this workgroup.
Public property | UserId | The user identifier.
Public property | Workgroup | A workgroup to which this user is assigned.

See Also

UserWorkgroupActivation Class
ININ.IceLib.People Namespace


IsActive Property

[image]

IceLib Technical Reference
UserWorkgroupActivation..::..IsActive Property
UserWorkgroupActivation Class See Also Send Feedback
Retruns trueTruetruetrue (True in Visual Basic) if the user is activated in this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivation Class
UserWorkgroupActivation Members
ININ.IceLib.People Namespace


UserId Property

[image]

IceLib Technical Reference
UserWorkgroupActivation..::..UserId Property
UserWorkgroupActivation Class See Also Send Feedback
The user identifier.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivation Class
UserWorkgroupActivation Members
ININ.IceLib.People Namespace


Workgroup Property

[image]

IceLib Technical Reference
UserWorkgroupActivation..::..Workgroup Property
UserWorkgroupActivation Class See Also Send Feedback
A workgroup to which this user is assigned.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; }
Visual Basic
Public ReadOnly Property Workgroup As String
    Get

Field Value

The workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivation Class
UserWorkgroupActivation Members
ININ.IceLib.People Namespace


UserWorkgroupActivationList Class

[image]

IceLib Technical Reference
UserWorkgroupActivationList Class
Members See Also Send Feedback
Class to implement a list of UserWorkgroupActivation objects.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserWorkgroupActivationList
Visual Basic
Public Class UserWorkgroupActivationList

Remarks

This class implements a list of user workgroup activations. It can start and stop watches for these objects.

Users have the ability to activate and deactivate themselves in ACD workgroups. If a user is activated in a workgroup to which they are assigned, they are available to handle ACD interactions.

To begin a watch on a user's workgroup activation, call the StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) methods, passing in a string array of workgroups for which you are interested in watching this user's activation. The completedCallback delegate is invoked when the asynchronous start watch operation has completed.

To stop watching user workgroup activations, call the StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods. The completedCallback delegate is invoked when the asynchronous stop watch operation completes. You can get the list of all workgroups for which the user is assigned from the helper method GetUserWorkgroups(PeopleManager).

For example: If a user is a member of both the Support and Custom Service workgroups and activates himself to begin handling interactions for the Support workgroup, the WatchedObjectsChanged event will be triggered if a watch is in progress.

To access the list of workgroup activations, call the GetList()()()() method. If a watch is not in progress an InvalidOperationException is raised.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) methods when a watch is already in progress, or calling StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object) methods when a watch is not in progress raises the InvalidOperationException.

Note
The asynchronous methods are preferred since the start, change, and stop watch can be lengthy operations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserWorkgroupActivationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


UserWorkgroupActivationList Members

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationList Members
UserWorkgroupActivationList Class Constructors Methods Properties Events See Also Send Feedback

The UserWorkgroupActivationList type exposes the following members.

Constructors

 | Name | Description
Public method | UserWorkgroupActivationList | Initializes a new instance of the UserWorkgroupActivationList class.

Methods

 | Name | Description
Public method | ChangeWatchedWorkgroups | Changes the workgroups being watched.
Public method | ChangeWatchedWorkgroupsAsync | Asynchronously changes the workgroups being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of user activations being watched.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the User Workgroup Activation List.
Public method | StartWatchingAsync | Asynchronously starts watching the User Workgroup Activation.
Public method | StopWatching | Stops watching the user workgroup activation list.
Public method | StopWatchingAsync | Asynchronously stops watching the user workgroup activation list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get an individual user workgroup activation for a user.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the UserWorkgroupActivation watched objects has changed.

See Also

UserWorkgroupActivationList Class
ININ.IceLib.People Namespace


UserWorkgroupActivationList Constructor

[image]

IceLib Technical Reference
UserWorkgroupActivationList Constructor
UserWorkgroupActivationList Class See Also Send Feedback
Initializes a new instance of the UserWorkgroupActivationList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserWorkgroupActivationList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


UserWorkgroupActivationList Methods

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationList Methods
UserWorkgroupActivationList Class See Also Send Feedback

The UserWorkgroupActivationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedWorkgroups | Changes the workgroups being watched.
Public method | ChangeWatchedWorkgroupsAsync | Asynchronously changes the workgroups being watched.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList | Get a list of user activations being watched.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the User Workgroup Activation List.
Public method | StartWatchingAsync | Asynchronously starts watching the User Workgroup Activation.
Public method | StopWatching | Stops watching the user workgroup activation list.
Public method | StopWatchingAsync | Asynchronously stops watching the user workgroup activation list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserWorkgroupActivationList Class
ININ.IceLib.People Namespace


ChangeWatchedWorkgroups Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..ChangeWatchedWorkgroups Method
UserWorkgroupActivationList Class See Also Send Feedback
Changes the workgroups being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedWorkgroups(
    string[] workgroupNamesToAdd,
    string[] workgroupNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedWorkgroups ( _
    workgroupNamesToAdd As String(), _
    workgroupNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

workgroupNamesToAdd
Type: array<System..::..String>[]()[][]
The workgroup names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
workgroupNamesToRemove
Type: array<System..::..String>[]()[][]
The workgroup names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


ChangeWatchedWorkgroupsAsync Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..ChangeWatchedWorkgroupsAsync Method
UserWorkgroupActivationList Class See Also Send Feedback
Asynchronously changes the workgroups being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedWorkgroupsAsync(
    string[] workgroupNamesToAdd,
    string[] workgroupNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedWorkgroupsAsync ( _
    workgroupNamesToAdd As String(), _
    workgroupNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

workgroupNamesToAdd
Type: array<System..::..String>[]()[][]
The workgroup names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
workgroupNamesToRemove
Type: array<System..::..String>[]()[][]
The workgroup names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


GetList Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..GetList Method
UserWorkgroupActivationList Class See Also Send Feedback
Get a list of user activations being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<UserWorkgroupActivation> GetList()
Visual Basic
Public Function GetList As ReadOnlyCollection(Of UserWorkgroupActivation)

Return Value

A list of UserWorkgroupActivation.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | If the user workgroup activation list is not cached.
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationList..::..IsWatching Method
UserWorkgroupActivationList Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..IsWatching Method
UserWorkgroupActivationList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..IsWatching Method (String)
UserWorkgroupActivationList Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string workgroupName
)
Visual Basic
Public Function IsWatching ( _
    workgroupName As String _
) As Boolean

Parameters

workgroupName
Type: System..::..String
The workgroup.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
IsWatching Overload
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..StartWatching Method
UserWorkgroupActivationList Class See Also Send Feedback
Starts watching the User Workgroup Activation List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] workgroupNames
)
Visual Basic
Public Sub StartWatching ( _
    workgroupNames As String() _
)

Parameters

workgroupNames
Type: array<System..::..String>[]()[][]
A list of workgroups for which an agent's self activation is monitored.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..StartWatchingAsync Method
UserWorkgroupActivationList Class See Also Send Feedback
Asynchronously starts watching the User Workgroup Activation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] workgroupNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    workgroupNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

workgroupNames
Type: array<System..::..String>[]()[][]
A list of workgroup names to monitor.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..StopWatching Method
UserWorkgroupActivationList Class See Also Send Feedback
Stops watching the user workgroup activation list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..StopWatchingAsync Method
UserWorkgroupActivationList Class See Also Send Feedback
Asynchronously stops watching the user workgroup activation list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


UserWorkgroupActivationList Properties

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationList Properties
UserWorkgroupActivationList Class See Also Send Feedback

The UserWorkgroupActivationList type exposes the following members.

Properties

 | Name | Description
Public property | Item | Get an individual user workgroup activation for a user.

See Also

UserWorkgroupActivationList Class
ININ.IceLib.People Namespace


Item Property

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..Item Property
UserWorkgroupActivationList Class See Also Send Feedback
Get an individual user workgroup activation for a user.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserWorkgroupActivation this[
    string workgroup
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    workgroup As String _
) As UserWorkgroupActivation
    Get

Parameters

workgroup
Type: System..::..String
The workgroup to get.

Field Value

The user workgroup activation.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.
ININ.IceLib..::..NotCachedException | If the UserWorkgroupActivation request by workgroup is not in the cache.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


UserWorkgroupActivationList Events

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationList Events
UserWorkgroupActivationList Class See Also Send Feedback

The UserWorkgroupActivationList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the UserWorkgroupActivation watched objects has changed.

See Also

UserWorkgroupActivationList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
UserWorkgroupActivationList..::..WatchedObjectsChanged Event
UserWorkgroupActivationList Class See Also Send Feedback
Occurs when one of the UserWorkgroupActivation watched objects has changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedObjectsEventArgs<UserWorkgroupActivationProperty>> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of WatchedObjectsEventArgs(Of UserWorkgroupActivationProperty))

Remarks

Note that only changes to existing objects in the watch are monitored. There are no objects added to or removed from the UserWorkgroupActivationList watched objects.

Each Changed notification for a UserWorkgroupActivation object is described by the integer values defined in the UserWorkgroupActivationProperty enumeration.

This event will only occur when workgroups being watched have changed. To start watching for workgroups call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which workgroups are being watched once the watch has been started, use the ChangeWatchedWorkgroups(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationList Class
UserWorkgroupActivationList Members
ININ.IceLib.People Namespace


UserWorkgroupActivationProperty Enumeration

[image]

IceLib Technical Reference
UserWorkgroupActivationProperty Enumeration
See Also Send Feedback
Each value in this enumeration represents a property in UserWorkgroupActivation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum UserWorkgroupActivationProperty
Visual Basic
Public Enumeration UserWorkgroupActivationProperty

Members

Member name | Value | Description
None | 0 | No Property is defined.
UserId | 1 | Represents the UserId property.
Workgroup | 2 | Represents the Workgroup property.
IsActive | 3 | Represents the IsActive property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


UserWorkgroupActivationUpdate Class

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate Class
Members See Also Send Feedback
This object is used to update a user's workgroup activation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserWorkgroupActivationUpdate
Visual Basic
Public Class UserWorkgroupActivationUpdate

Remarks

This class is used to modify a user's workgroup activation. To modify a user's workgroup activation, create an object of this class and set the Workgroup, IsActive, and UserId properties and then call the UpdateRequest()()()() or UpdateRequestAsync(AsyncCompletedEventHandler, Object) methods to change the workgroup activation for a particular workgroup. If the UpdateRequestAsync(AsyncCompletedEventHandler, Object) method is called the completedCallback delegate will be invoked when the user's workgroup activation has been modified.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserWorkgroupActivationUpdate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


UserWorkgroupActivationUpdate Members

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationUpdate Members
UserWorkgroupActivationUpdate Class Constructors Methods Properties See Also Send Feedback

The UserWorkgroupActivationUpdate type exposes the following members.

Constructors

 | Name | Description
Public method | UserWorkgroupActivationUpdate | Constructs a UserWorkgroupActivationUpdate object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRequest | Updates the User Workgroup Activation.
Public method | UpdateRequestAsync | Asynchronously updates the User Workgroup Activation.

Properties

 | Name | Description
Public property | IsActive | Gets or sets a value indicating whether the user is active in this workgroup.
Public property | UserId | The user's identifier.
Public property | Workgroup | The workgroup identifier.

See Also

UserWorkgroupActivationUpdate Class
ININ.IceLib.People Namespace


UserWorkgroupActivationUpdate Constructor

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate Constructor
UserWorkgroupActivationUpdate Class See Also Send Feedback
Constructs a UserWorkgroupActivationUpdate object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserWorkgroupActivationUpdate(
    PeopleManager peopleManager,
    UserWorkgroupActivation userWorkgroupActivation
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager, _
    userWorkgroupActivation As UserWorkgroupActivation _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.
userWorkgroupActivation
Type: ININ.IceLib.People..::..UserWorkgroupActivation
Initial parameters are copied from the UserWorkgroupActivation instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Class
UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


UserWorkgroupActivationUpdate Methods

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationUpdate Methods
UserWorkgroupActivationUpdate Class See Also Send Feedback

The UserWorkgroupActivationUpdate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRequest | Updates the User Workgroup Activation.
Public method | UpdateRequestAsync | Asynchronously updates the User Workgroup Activation.

See Also

UserWorkgroupActivationUpdate Class
ININ.IceLib.People Namespace


UpdateRequest Method

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate..::..UpdateRequest Method
UserWorkgroupActivationUpdate Class See Also Send Feedback
Updates the User Workgroup Activation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateRequest()
Visual Basic
Public Sub UpdateRequest

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Class
UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


UpdateRequestAsync Method

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate..::..UpdateRequestAsync Method
UserWorkgroupActivationUpdate Class See Also Send Feedback
Asynchronously updates the User Workgroup Activation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateRequestAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateRequestAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Class
UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


UserWorkgroupActivationUpdate Properties

[image] [image]

IceLib Technical Reference
UserWorkgroupActivationUpdate Properties
UserWorkgroupActivationUpdate Class See Also Send Feedback

The UserWorkgroupActivationUpdate type exposes the following members.

Properties

 | Name | Description
Public property | IsActive | Gets or sets a value indicating whether the user is active in this workgroup.
Public property | UserId | The user's identifier.
Public property | Workgroup | The workgroup identifier.

See Also

UserWorkgroupActivationUpdate Class
ININ.IceLib.People Namespace


IsActive Property

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate..::..IsActive Property
UserWorkgroupActivationUpdate Class See Also Send Feedback
Gets or sets a value indicating whether the user is active in this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsActive { get; set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Class
UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


UserId Property

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate..::..UserId Property
UserWorkgroupActivationUpdate Class See Also Send Feedback
The user's identifier.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Class
UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


Workgroup Property

[image]

IceLib Technical Reference
UserWorkgroupActivationUpdate..::..Workgroup Property
UserWorkgroupActivationUpdate Class See Also Send Feedback
The workgroup identifier.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; set; }
Visual Basic
Public Property Workgroup As String
    Get
    Set

Field Value

The workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserWorkgroupActivationUpdate Class
UserWorkgroupActivationUpdate Members
ININ.IceLib.People Namespace


VoicePromptActionTypes Enumeration

[image]

IceLib Technical Reference
VoicePromptActionTypes Enumeration
See Also Send Feedback
The set of actions that can be performed on a voice prompt. Voice prompts are handled via a VoicePrompts object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum VoicePromptActionTypes
Visual Basic
<FlagsAttribute> _
Public Enumeration VoicePromptActionTypes

Members

Member name | Value | Description
Record | 1 | Records the voice prompt.
Commit | 2 | Commits the recording to memory.
Preview | 4 | Previews the prompt.
Clear | 8 | Clears the voice prompt from memory.
Cancel | 16 | Cancels the current actions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


VoicePrompts Class

[image]

IceLib Technical Reference
VoicePrompts Class
Members See Also Send Feedback
Manages user voice prompts by starting actions for a voice prompt type.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoicePrompts
Visual Basic
Public Class VoicePrompts

Remarks

The VoicePrompts object is used to issue commands to handle the recording of personal prompts. There is a list of the different voice prompts that can be managed. The prompt that is to be managed is selected by the VoicePromptType enum that is passed into ManageVoicePrompts(VoicePromptActionTypes, VoicePromptType) or ManageVoicePromptsAsync(VoicePromptActionTypes, VoicePromptType, AsyncCompletedEventHandler, Object).

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..VoicePrompts

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoicePrompts Members
ININ.IceLib.People Namespace


VoicePrompts Members

[image] [image]

IceLib Technical Reference
VoicePrompts Members
VoicePrompts Class Constructors Methods See Also Send Feedback

The VoicePrompts type exposes the following members.

Constructors

 | Name | Description
Public method | VoicePrompts | Initializes a new instance of the VoicePrompts class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ManageVoicePrompts | Manage voice prompts.
Public method | ManageVoicePromptsAsync | Asynchronously manages voice prompts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicePrompts Class
ININ.IceLib.People Namespace


VoicePrompts Constructor

[image]

IceLib Technical Reference
VoicePrompts Constructor
VoicePrompts Class See Also Send Feedback
Initializes a new instance of the VoicePrompts class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicePrompts(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
The people manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoicePrompts Class
VoicePrompts Members
ININ.IceLib.People Namespace


VoicePrompts Methods

[image] [image]

IceLib Technical Reference
VoicePrompts Methods
VoicePrompts Class See Also Send Feedback

The VoicePrompts type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ManageVoicePrompts | Manage voice prompts.
Public method | ManageVoicePromptsAsync | Asynchronously manages voice prompts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicePrompts Class
ININ.IceLib.People Namespace


ManageVoicePrompts Method

[image]

IceLib Technical Reference
VoicePrompts..::..ManageVoicePrompts Method
VoicePrompts Class See Also Send Feedback
Manage voice prompts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ManageVoicePrompts(
    VoicePromptActionTypes actions,
    VoicePromptType promptType
)
Visual Basic
Public Sub ManageVoicePrompts ( _
    actions As VoicePromptActionTypes, _
    promptType As VoicePromptType _
)

Parameters

actions
Type: ININ.IceLib.People..::..VoicePromptActionTypes
The action to take on the given prompt.
promptType
Type: ININ.IceLib.People..::..VoicePromptType
The prompt that the action will be performed against.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not from the enumeration.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoicePrompts Class
VoicePrompts Members
ININ.IceLib.People Namespace


ManageVoicePromptsAsync Method

[image]

IceLib Technical Reference
VoicePrompts..::..ManageVoicePromptsAsync Method
VoicePrompts Class See Also Send Feedback
Asynchronously manages voice prompts.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ManageVoicePromptsAsync(
    VoicePromptActionTypes actions,
    VoicePromptType promptType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ManageVoicePromptsAsync ( _
    actions As VoicePromptActionTypes, _
    promptType As VoicePromptType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

actions
Type: ININ.IceLib.People..::..VoicePromptActionTypes
The action to take on the given prompt.
promptType
Type: ININ.IceLib.People..::..VoicePromptType
The prompt that the action will be performed against.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not from the enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

VoicePrompts Class
VoicePrompts Members
ININ.IceLib.People Namespace


VoicePromptType Enumeration

[image]

IceLib Technical Reference
VoicePromptType Enumeration
See Also Send Feedback
Indicates the type of voice prompt. Voice prompts are handled via a VoicePrompts object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum VoicePromptType
Visual Basic
Public Enumeration VoicePromptType

Members

Member name | Value | Description
OutOfOffice | 0 | The prompt is an out of office response.
NoAnswer | 1 | The prompt is a no answer response.
FollowMe | 2 | The prompt is a follow-me response.
Name | 3 | The prompt is a name prompt.
Greeting | 4 | The prompt is a standard greeting response.
AvailableForward | 5 | The prompt is an available forward response.
QuickHold | 6 | The prompt is a quick hold response.
All | 7 | The action applies to all voice prompt types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.People Namespace


WatchedAttributesEventArgs Class

[image]

IceLib Technical Reference
WatchedAttributesEventArgs Class
Members See Also Send Feedback
Provides data for the WatchedAttributesChangedEvent event of a WorkgroupDetails class or UserSettings derived classes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WatchedAttributesEventArgs : EventArgs
Visual Basic
Public Class WatchedAttributesEventArgs _
    Inherits EventArgs

Remarks

This class extends EventArgs, the base class for classes containing event data.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People..::..WatchedAttributesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedAttributesEventArgs Members
ININ.IceLib.People Namespace


WatchedAttributesEventArgs Members

[image] [image]

IceLib Technical Reference
WatchedAttributesEventArgs Members
WatchedAttributesEventArgs Class Constructors Methods Properties See Also Send Feedback

The WatchedAttributesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | WatchedAttributesEventArgs | Initializes a new instance of the WatchedAttributesEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeNames | Gets the attribute names associated with the change.

See Also

WatchedAttributesEventArgs Class
ININ.IceLib.People Namespace


WatchedAttributesEventArgs Constructor

[image]

IceLib Technical Reference
WatchedAttributesEventArgs Constructor
WatchedAttributesEventArgs Class See Also Send Feedback
Initializes a new instance of the WatchedAttributesEventArgs class with the specified values.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WatchedAttributesEventArgs(
    string[] attributeNames
)
Visual Basic
Public Sub New ( _
    attributeNames As String() _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
The attribute names.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedAttributesEventArgs Class
WatchedAttributesEventArgs Members
ININ.IceLib.People Namespace


WatchedAttributesEventArgs Methods

[image] [image]

IceLib Technical Reference
WatchedAttributesEventArgs Methods
WatchedAttributesEventArgs Class See Also Send Feedback

The WatchedAttributesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WatchedAttributesEventArgs Class
ININ.IceLib.People Namespace


WatchedAttributesEventArgs Properties

[image] [image]

IceLib Technical Reference
WatchedAttributesEventArgs Properties
WatchedAttributesEventArgs Class See Also Send Feedback

The WatchedAttributesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AttributeNames | Gets the attribute names associated with the change.

See Also

WatchedAttributesEventArgs Class
ININ.IceLib.People Namespace


AttributeNames Property

[image]

IceLib Technical Reference
WatchedAttributesEventArgs..::..AttributeNames Property
WatchedAttributesEventArgs Class See Also Send Feedback
Gets the attribute names associated with the change.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> AttributeNames { get; }
Visual Basic
Public ReadOnly Property AttributeNames As ReadOnlyCollection(Of String)
    Get

Field Value

The attribute names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedAttributesEventArgs Class
WatchedAttributesEventArgs Members
ININ.IceLib.People Namespace


WatchedObjectsEventArgs(TPropertyEnum) Class

[image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
Members See Also Send Feedback
Provides data for the watched objects changed event for a watched object.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WatchedObjectsEventArgs<TPropertyEnum> : EventArgs
Visual Basic
Public Class WatchedObjectsEventArgs(Of TPropertyEnum) _
    Inherits EventArgs

Type Parameters

TPropertyEnum
Type parameter to indicate the type of property values that have changed.

Remarks

This class extends EventArgs, the base class for classes containing event data.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People..::..WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.People Namespace


WatchedObjectsEventArgs(TPropertyEnum) Members

[image] [image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Members
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class Methods Properties See Also Send Feedback

The WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed. This is a map with the object indentifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.People Namespace


WatchedObjectsEventArgs(TPropertyEnum) Methods

[image] [image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Methods
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.People Namespace


WatchedObjectsEventArgs(TPropertyEnum) Properties

[image] [image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Properties
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback

The WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed. This is a map with the object indentifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
ININ.IceLib.People Namespace


Added Property

[image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Added Property
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were added.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of String)
    Get

Field Value

The added objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.People Namespace


Changed Property

[image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Changed Property
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing objects that changed. This is a map with the object indentifier as the key and a List<(Of <(<'T>)>)> of integers indicating which properties have changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, ReadOnlyCollection<TPropertyEnum>> Changed { get; }
Visual Basic
Public ReadOnly Property Changed As IDictionary(Of String, ReadOnlyCollection(Of TPropertyEnum))
    Get

Field Value

The changed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.People Namespace


Removed Property

[image]

IceLib Technical Reference
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)>..::..Removed Property
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were removed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of String)
    Get

Field Value

The removed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Class
WatchedObjectsEventArgs<(Of <(<'TPropertyEnum>)>)> Members
ININ.IceLib.People Namespace


WorkgroupActivation Class

[image]

IceLib Technical Reference
WorkgroupActivation Class
Members See Also Send Feedback
Represents a users workgroup activation as used in batch processing.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupActivation
Visual Basic
Public Class WorkgroupActivation

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..WorkgroupActivation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivation Members
ININ.IceLib.People Namespace


WorkgroupActivation Members

[image] [image]

IceLib Technical Reference
WorkgroupActivation Members
WorkgroupActivation Class Constructors Methods Properties See Also Send Feedback

The WorkgroupActivation type exposes the following members.

Constructors

 | Name | Description
Public method | WorkgroupActivation(String, Boolean) | Initializes a new instance of the WorkgroupActivation class.
Public method | WorkgroupActivation(String, String, Boolean) | Initializes a new instance of the WorkgroupActivation class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Gets the display name for the user that this record applies to.
Public property | IsActive | Gets or sets activation status of this user as applied to the selected workgroup.
Public property | UserId | Gets or sets the user ID of this activation record.

See Also

WorkgroupActivation Class
ININ.IceLib.People Namespace


WorkgroupActivation Constructor

[image] [image]

IceLib Technical Reference
WorkgroupActivation Constructor
WorkgroupActivation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WorkgroupActivation(String, Boolean) | Initializes a new instance of the WorkgroupActivation class.
Public method | WorkgroupActivation(String, String, Boolean) | Initializes a new instance of the WorkgroupActivation class.

See Also

WorkgroupActivation Class
WorkgroupActivation Members
ININ.IceLib.People Namespace


WorkgroupActivation Constructor (String, Boolean)

[image]

IceLib Technical Reference
WorkgroupActivation Constructor (String, Boolean)
WorkgroupActivation Class See Also Send Feedback
Initializes a new instance of the WorkgroupActivation class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupActivation(
    string userId,
    bool isActive
)
Visual Basic
Public Sub New ( _
    userId As String, _
    isActive As Boolean _
)

Parameters

userId
Type: System..::..String
The user ID.
isActive
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) the user is active.

Remarks

This constructor should be used with SetUserActivations(IEnumerable<(Of <<'(WorkgroupActivation>)>>), String) and SetUserActivationsAsync(IEnumerable<(Of <<'(WorkgroupActivation>)>>), String, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

WorkgroupActivation Class
WorkgroupActivation Members
WorkgroupActivation Overload
ININ.IceLib.People Namespace
WorkgroupActivationList..::..SetUserActivations(IEnumerable<(Of <<'(WorkgroupActivation>)>>), String)
WorkgroupActivationList..::..SetUserActivationsAsync(IEnumerable<(Of <<'(WorkgroupActivation>)>>), String, AsyncCompletedEventHandler, Object)


WorkgroupActivation Constructor (String, String, Boolean)

[image]

IceLib Technical Reference
WorkgroupActivation Constructor (String, String, Boolean)
WorkgroupActivation Class See Also Send Feedback
Initializes a new instance of the WorkgroupActivation class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupActivation(
    string userId,
    string displayName,
    bool isActive
)
Visual Basic
Public Sub New ( _
    userId As String, _
    displayName As String, _
    isActive As Boolean _
)

Parameters

userId
Type: System..::..String
The user ID.
displayName
Type: System..::..String
The display name.
isActive
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) the user is active.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivation Class
WorkgroupActivation Members
WorkgroupActivation Overload
ININ.IceLib.People Namespace
WorkgroupActivationList..::..GetUserActivationList(String)
WorkgroupActivationList..::..GetUserActivationListAsync(String, EventHandler<(Of <<'(GetUserActivationListCompletedEventArgs>)>>), Object)


WorkgroupActivation Methods

[image] [image]

IceLib Technical Reference
WorkgroupActivation Methods
WorkgroupActivation Class See Also Send Feedback

The WorkgroupActivation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupActivation Class
ININ.IceLib.People Namespace


WorkgroupActivation Properties

[image] [image]

IceLib Technical Reference
WorkgroupActivation Properties
WorkgroupActivation Class See Also Send Feedback

The WorkgroupActivation type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets the display name for the user that this record applies to.
Public property | IsActive | Gets or sets activation status of this user as applied to the selected workgroup.
Public property | UserId | Gets or sets the user ID of this activation record.

See Also

WorkgroupActivation Class
ININ.IceLib.People Namespace


DisplayName Property

[image]

IceLib Technical Reference
WorkgroupActivation..::..DisplayName Property
WorkgroupActivation Class See Also Send Feedback
Gets the display name for the user that this record applies to.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivation Class
WorkgroupActivation Members
ININ.IceLib.People Namespace


IsActive Property

[image]

IceLib Technical Reference
WorkgroupActivation..::..IsActive Property
WorkgroupActivation Class See Also Send Feedback
Gets or sets activation status of this user as applied to the selected workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsActive { get; set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if the user is activated; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivation Class
WorkgroupActivation Members
ININ.IceLib.People Namespace


UserId Property

[image]

IceLib Technical Reference
WorkgroupActivation..::..UserId Property
WorkgroupActivation Class See Also Send Feedback
Gets or sets the user ID of this activation record.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivation Class
WorkgroupActivation Members
ININ.IceLib.People Namespace


WorkgroupActivationChangedEventArgs Class

[image]

IceLib Technical Reference
WorkgroupActivationChangedEventArgs Class
Members See Also Send Feedback
Provides data for the workgroup activation list changed event.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupActivationChangedEventArgs : EventArgs
Visual Basic
Public Class WorkgroupActivationChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People..::..WorkgroupActivationChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationChangedEventArgs Members
ININ.IceLib.People Namespace


WorkgroupActivationChangedEventArgs Members

[image] [image]

IceLib Technical Reference
WorkgroupActivationChangedEventArgs Members
WorkgroupActivationChangedEventArgs Class Methods Properties See Also Send Feedback

The WorkgroupActivationChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changed | Gets the read only list of changed WorkgroupActivation objects.
Public property | WorkgroupName | Gets the name of the workgroup that triggered this event.

See Also

WorkgroupActivationChangedEventArgs Class
ININ.IceLib.People Namespace


WorkgroupActivationChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
WorkgroupActivationChangedEventArgs Methods
WorkgroupActivationChangedEventArgs Class See Also Send Feedback

The WorkgroupActivationChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupActivationChangedEventArgs Class
ININ.IceLib.People Namespace


WorkgroupActivationChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
WorkgroupActivationChangedEventArgs Properties
WorkgroupActivationChangedEventArgs Class See Also Send Feedback

The WorkgroupActivationChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Changed | Gets the read only list of changed WorkgroupActivation objects.
Public property | WorkgroupName | Gets the name of the workgroup that triggered this event.

See Also

WorkgroupActivationChangedEventArgs Class
ININ.IceLib.People Namespace


Changed Property

[image]

IceLib Technical Reference
WorkgroupActivationChangedEventArgs..::..Changed Property
WorkgroupActivationChangedEventArgs Class See Also Send Feedback
Gets the read only list of changed WorkgroupActivation objects.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WorkgroupActivation> Changed { get; private set; }
Visual Basic
Public Property Changed As ReadOnlyCollection(Of WorkgroupActivation)
    Get
    Private Set

Field Value

The changed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationChangedEventArgs Class
WorkgroupActivationChangedEventArgs Members
ININ.IceLib.People Namespace


WorkgroupName Property

[image]

IceLib Technical Reference
WorkgroupActivationChangedEventArgs..::..WorkgroupName Property
WorkgroupActivationChangedEventArgs Class See Also Send Feedback
Gets the name of the workgroup that triggered this event.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkgroupName { get; private set; }
Visual Basic
Public Property WorkgroupName As String
    Get
    Private Set

Field Value

The name of the workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationChangedEventArgs Class
WorkgroupActivationChangedEventArgs Members
ININ.IceLib.People Namespace


WorkgroupActivationList Class

[image]

IceLib Technical Reference
WorkgroupActivationList Class
Members See Also Send Feedback
Represents a list of user workgroup activations. This class allows for bulk access to user workgroup activations.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupActivationList
Visual Basic
Public Class WorkgroupActivationList

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..WorkgroupActivationList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivationList Members
ININ.IceLib.People Namespace


WorkgroupActivationList Members

[image] [image]

IceLib Technical Reference
WorkgroupActivationList Members
WorkgroupActivationList Class Constructors Methods Properties Events See Also Send Feedback

The WorkgroupActivationList type exposes the following members.

Constructors

 | Name | Description
Public method | WorkgroupActivationList | Initializes a new instance of the WorkgroupActivationList class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActivationList | Retrieves a list of user activations for a given workgroup.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserActivationList | Retrieves a list of user activations for a given workgroup.
Public method | GetUserActivationListAsync | Asynchronously retrieves a list of user activations for a given workgroup.
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetUserActivations | Sets the user activations on the given workgroup.
Public method | SetUserActivationsAsync | Asynchronously sets the user activations on the given workgroup.
Public method | StartWatching | Starts watching the workgroup activation list for a workgroup.
Public method | StartWatchingAsync | Asynchronously starts watching the workgroup activation list for a set of users.
Public method | StopWatching | Stops watching the workgroup activation list.
Public method | StopWatchingAsync | Asynchronously stops watching the workgroup activation List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | WorkgroupName | Gets the name of the workgroup that is currently being watched. The workgroup name will be Empty if no watch is active. Use IsWatching()()()() to determine if a watch is active.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the FilteredStatusMessageList watched objects has changed.

See Also

WorkgroupActivationList Class
ININ.IceLib.People Namespace


WorkgroupActivationList Constructor

[image]

IceLib Technical Reference
WorkgroupActivationList Constructor
WorkgroupActivationList Class See Also Send Feedback
Initializes a new instance of the WorkgroupActivationList class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupActivationList(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


WorkgroupActivationList Methods

[image] [image]

IceLib Technical Reference
WorkgroupActivationList Methods
WorkgroupActivationList Class See Also Send Feedback

The WorkgroupActivationList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActivationList | Retrieves a list of user activations for a given workgroup.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserActivationList | Retrieves a list of user activations for a given workgroup.
Public method | GetUserActivationListAsync | Asynchronously retrieves a list of user activations for a given workgroup.
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetUserActivations | Sets the user activations on the given workgroup.
Public method | SetUserActivationsAsync | Asynchronously sets the user activations on the given workgroup.
Public method | StartWatching | Starts watching the workgroup activation list for a workgroup.
Public method | StartWatchingAsync | Asynchronously starts watching the workgroup activation list for a set of users.
Public method | StopWatching | Stops watching the workgroup activation list.
Public method | StopWatchingAsync | Asynchronously stops watching the workgroup activation List.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupActivationList Class
ININ.IceLib.People Namespace


GetActivationList Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..GetActivationList Method
WorkgroupActivationList Class See Also Send Feedback
Retrieves a list of user activations for a given workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WorkgroupActivation> GetActivationList(
    string workgroupName
)
Visual Basic
Public Function GetActivationList ( _
    workgroupName As String _
) As ReadOnlyCollection(Of WorkgroupActivation)

Parameters

workgroupName
Type: System..::..String
Workgroup to search against.

Return Value

A read only collection of WorkgroupActivation objects.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The workgroup is not watched.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | "A parameter is Empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


GetUserActivationList Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..GetUserActivationList Method
WorkgroupActivationList Class See Also Send Feedback
Retrieves a list of user activations for a given workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WorkgroupActivation> GetUserActivationList(
    string workgroupName
)
Visual Basic
Public Function GetUserActivationList ( _
    workgroupName As String _
) As ReadOnlyCollection(Of WorkgroupActivation)

Parameters

workgroupName
Type: System..::..String
Workgroup to search against.

Return Value

A read only collection of WorkgroupActivation objects.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has a length of zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 11 and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


GetUserActivationListAsync Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..GetUserActivationListAsync Method
WorkgroupActivationList Class See Also Send Feedback
Asynchronously retrieves a list of user activations for a given workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetUserActivationListAsync(
    string workgroupName,
    EventHandler<GetUserActivationListCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetUserActivationListAsync ( _
    workgroupName As String, _
    completedCallback As EventHandler(Of GetUserActivationListCompletedEventArgs), _
    userState As Object _
)

Parameters

workgroupName
Type: System..::..String
Workgroup to search against.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetUserActivationListCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Return Value

A read only collection of WorkgroupActivation objects.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has a length of zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..IsWatching Method
WorkgroupActivationList Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


SetUserActivations Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..SetUserActivations Method
WorkgroupActivationList Class See Also Send Feedback
Sets the user activations on the given workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetUserActivations(
    IEnumerable<WorkgroupActivation> users,
    string workgroupName
)
Visual Basic
Public Sub SetUserActivations ( _
    users As IEnumerable(Of WorkgroupActivation), _
    workgroupName As String _
)

Parameters

users
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' WorkgroupActivation >)>)>
The users to update.
workgroupName
Type: System..::..String
Name of the workgroup.

Remarks

Values for users can be created via WorkgroupActivation(String, Boolean).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has a length of zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace
WorkgroupActivation..::..WorkgroupActivation(String, Boolean)


SetUserActivationsAsync Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..SetUserActivationsAsync Method
WorkgroupActivationList Class See Also Send Feedback
Asynchronously sets the user activations on the given workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetUserActivationsAsync(
    IEnumerable<WorkgroupActivation> users,
    string workgroupName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetUserActivationsAsync ( _
    users As IEnumerable(Of WorkgroupActivation), _
    workgroupName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

users
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' WorkgroupActivation >)>)>
The users to update.
workgroupName
Type: System..::..String
Name of the workgroup.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Values for users can be created via WorkgroupActivation(String, Boolean).

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | A parameter has a length of zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace
WorkgroupActivation..::..WorkgroupActivation(String, Boolean)


StartWatching Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..StartWatching Method
WorkgroupActivationList Class See Also Send Feedback
Starts watching the workgroup activation list for a workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string workgroupName
)
Visual Basic
Public Sub StartWatching ( _
    workgroupName As String _
)

Parameters

workgroupName
Type: System..::..String
The name of the workgroup to watch.

Remarks

Note
All event handlers should be added before calling StartWatching(String) or StartWatchingAsync(String, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | A watch is already in progress.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..StartWatchingAsync Method
WorkgroupActivationList Class See Also Send Feedback
Asynchronously starts watching the workgroup activation list for a set of users.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string workgroupName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    workgroupName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

workgroupName
Type: System..::..String
The name of thr workgroup that will be watched.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(String) or StartWatchingAsync(String, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..StopWatching Method
WorkgroupActivationList Class See Also Send Feedback
Stops watching the workgroup activation list.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
WorkgroupActivationList..::..StopWatchingAsync Method
WorkgroupActivationList Class See Also Send Feedback
Asynchronously stops watching the workgroup activation List.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


WorkgroupActivationList Properties

[image] [image]

IceLib Technical Reference
WorkgroupActivationList Properties
WorkgroupActivationList Class See Also Send Feedback

The WorkgroupActivationList type exposes the following members.

Properties

 | Name | Description
Public property | WorkgroupName | Gets the name of the workgroup that is currently being watched. The workgroup name will be Empty if no watch is active. Use IsWatching()()()() to determine if a watch is active.

See Also

WorkgroupActivationList Class
ININ.IceLib.People Namespace


WorkgroupName Property

[image]

IceLib Technical Reference
WorkgroupActivationList..::..WorkgroupName Property
WorkgroupActivationList Class See Also Send Feedback
Gets the name of the workgroup that is currently being watched. The workgroup name will be Empty if no watch is active. Use IsWatching()()()() to determine if a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkgroupName { get; }
Visual Basic
Public ReadOnly Property WorkgroupName As String
    Get

Field Value

The name of the workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


WorkgroupActivationList Events

[image] [image]

IceLib Technical Reference
WorkgroupActivationList Events
WorkgroupActivationList Class See Also Send Feedback

The WorkgroupActivationList type exposes the following members.

Events

 | Name | Description
Public event | WatchedObjectsChanged | Occurs when one of the FilteredStatusMessageList watched objects has changed.

See Also

WorkgroupActivationList Class
ININ.IceLib.People Namespace


WatchedObjectsChanged Event

[image]

IceLib Technical Reference
WorkgroupActivationList..::..WatchedObjectsChanged Event
WorkgroupActivationList Class See Also Send Feedback
Occurs when one of the FilteredStatusMessageList watched objects has changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WorkgroupActivationChangedEventArgs> WatchedObjectsChanged
Visual Basic
Public Event WatchedObjectsChanged As EventHandler(Of WorkgroupActivationChangedEventArgs)

Remarks

This event will only occur if the workgroup activation list is being watched. To start watching the status message list call either the StartWatching(String) method or the StartWatchingAsync(String, AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(String) or StartWatchingAsync(String, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

WorkgroupActivationList Class
WorkgroupActivationList Members
ININ.IceLib.People Namespace


WorkgroupAttributes Class

[image]

IceLib Technical Reference
WorkgroupAttributes Class
Members See Also Send Feedback
Attribute strings for the WorkgroupDetails watched class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class WorkgroupAttributes
Visual Basic
Public NotInheritable Class WorkgroupAttributes

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the WorkgroupDetails class.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..WorkgroupAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Members
ININ.IceLib.People Namespace
ININ.IceLib.People..::..WorkgroupDetails


WorkgroupAttributes Members

[image] [image]

IceLib Technical Reference
WorkgroupAttributes Members
WorkgroupAttributes Class Fields See Also Send Feedback

The WorkgroupAttributes type exposes the following members.

Fields

Name | Description
AcdRoutingOutboundMailboxes | A list of configured mailboxes for sending outbound e-mails for a given ACD workgroup. See also AcdRoutingOutboundMailboxes.
ActiveMembers | List of activated members for this workgroup.
Extension | The workgroup's extension.
HasActivation | Indicates that the workgroup has been activated by the user. This setting is only relevant if HasQueue is enabled.
HasMailbox | Indicates that the workgroup has a mailbox.
HasQueue | Indicates whether the workgroup is operating as a queue. See also QueueType.
IsActive | Indicates that the workgroup is ready to receive interactions.
IsWrapUpActive | Indicates that wrap-up codes are active for this workgroup.
MaximumChatResponseTime | Time in seconds before a user should be warned about an inactive chat.
Members | List of members for this workgroup.
QueueType | The workgroup queue type. This can have the values: Custom, ACD, Group Ring, Sequential, or Round-robin.
RingToneForCalls | Ring tone for calls that arrive into a workgroup. See also RingToneForCalls.
RingToneForChats | Ring tone for chats that arrive into a workgroup. See also RingToneForChats.
RingToneForEmails | Ring tone for emails that arrive into a workgroup. See also RingToneForEmails.
RingToneForOtherInteractions | Ring tone for interactions other than emails, chats and calls that arrive into a workgroup. See also RingToneForOtherInteractions.
Supervisors | List of available supervisors for this workgroup.
WrapUpClientTimeout | Time in seconds to wait for a wrap-up code.
WrapUpCodes | A list of wrap-up codes available for this workgroup. See also WrapUpCode.

See Also

WorkgroupAttributes Class
ININ.IceLib.People Namespace


WorkgroupAttributes Fields

[image] [image]

IceLib Technical Reference
WorkgroupAttributes Fields
WorkgroupAttributes Class See Also Send Feedback

The WorkgroupAttributes type exposes the following members.

Fields

Name | Description
AcdRoutingOutboundMailboxes | A list of configured mailboxes for sending outbound e-mails for a given ACD workgroup. See also AcdRoutingOutboundMailboxes.
ActiveMembers | List of activated members for this workgroup.
Extension | The workgroup's extension.
HasActivation | Indicates that the workgroup has been activated by the user. This setting is only relevant if HasQueue is enabled.
HasMailbox | Indicates that the workgroup has a mailbox.
HasQueue | Indicates whether the workgroup is operating as a queue. See also QueueType.
IsActive | Indicates that the workgroup is ready to receive interactions.
IsWrapUpActive | Indicates that wrap-up codes are active for this workgroup.
MaximumChatResponseTime | Time in seconds before a user should be warned about an inactive chat.
Members | List of members for this workgroup.
QueueType | The workgroup queue type. This can have the values: Custom, ACD, Group Ring, Sequential, or Round-robin.
RingToneForCalls | Ring tone for calls that arrive into a workgroup. See also RingToneForCalls.
RingToneForChats | Ring tone for chats that arrive into a workgroup. See also RingToneForChats.
RingToneForEmails | Ring tone for emails that arrive into a workgroup. See also RingToneForEmails.
RingToneForOtherInteractions | Ring tone for interactions other than emails, chats and calls that arrive into a workgroup. See also RingToneForOtherInteractions.
Supervisors | List of available supervisors for this workgroup.
WrapUpClientTimeout | Time in seconds to wait for a wrap-up code.
WrapUpCodes | A list of wrap-up codes available for this workgroup. See also WrapUpCode.

See Also

WorkgroupAttributes Class
ININ.IceLib.People Namespace


AcdRoutingOutboundMailboxes Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..AcdRoutingOutboundMailboxes Field
WorkgroupAttributes Class See Also Send Feedback
A list of configured mailboxes for sending outbound e-mails for a given ACD workgroup. See also AcdRoutingOutboundMailboxes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AcdRoutingOutboundMailboxes
Visual Basic
Public Shared ReadOnly AcdRoutingOutboundMailboxes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


ActiveMembers Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..ActiveMembers Field
WorkgroupAttributes Class See Also Send Feedback
List of activated members for this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ActiveMembers
Visual Basic
Public Shared ReadOnly ActiveMembers As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


Extension Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..Extension Field
WorkgroupAttributes Class See Also Send Feedback
The workgroup's extension.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Extension
Visual Basic
Public Shared ReadOnly Extension As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


HasActivation Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..HasActivation Field
WorkgroupAttributes Class See Also Send Feedback
Indicates that the workgroup has been activated by the user. This setting is only relevant if HasQueue is enabled.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string HasActivation
Visual Basic
Public Shared ReadOnly HasActivation As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


HasMailbox Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..HasMailbox Field
WorkgroupAttributes Class See Also Send Feedback
Indicates that the workgroup has a mailbox.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string HasMailbox
Visual Basic
Public Shared ReadOnly HasMailbox As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


HasQueue Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..HasQueue Field
WorkgroupAttributes Class See Also Send Feedback
Indicates whether the workgroup is operating as a queue. See also QueueType.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string HasQueue
Visual Basic
Public Shared ReadOnly HasQueue As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


IsActive Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..IsActive Field
WorkgroupAttributes Class See Also Send Feedback
Indicates that the workgroup is ready to receive interactions.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string IsActive
Visual Basic
Public Shared ReadOnly IsActive As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


IsWrapUpActive Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..IsWrapUpActive Field
WorkgroupAttributes Class See Also Send Feedback
Indicates that wrap-up codes are active for this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string IsWrapUpActive
Visual Basic
Public Shared ReadOnly IsWrapUpActive As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


MaximumChatResponseTime Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..MaximumChatResponseTime Field
WorkgroupAttributes Class See Also Send Feedback
Time in seconds before a user should be warned about an inactive chat.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MaximumChatResponseTime
Visual Basic
Public Shared ReadOnly MaximumChatResponseTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


Members Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..Members Field
WorkgroupAttributes Class See Also Send Feedback
List of members for this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Members
Visual Basic
Public Shared ReadOnly Members As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


QueueType Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..QueueType Field
WorkgroupAttributes Class See Also Send Feedback
The workgroup queue type. This can have the values: Custom, ACD, Group Ring, Sequential, or Round-robin.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string QueueType
Visual Basic
Public Shared ReadOnly QueueType As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


RingToneForCalls Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..RingToneForCalls Field
WorkgroupAttributes Class See Also Send Feedback
Ring tone for calls that arrive into a workgroup. See also RingToneForCalls.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RingToneForCalls
Visual Basic
Public Shared ReadOnly RingToneForCalls As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


RingToneForChats Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..RingToneForChats Field
WorkgroupAttributes Class See Also Send Feedback
Ring tone for chats that arrive into a workgroup. See also RingToneForChats.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RingToneForChats
Visual Basic
Public Shared ReadOnly RingToneForChats As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


RingToneForEmails Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..RingToneForEmails Field
WorkgroupAttributes Class See Also Send Feedback
Ring tone for emails that arrive into a workgroup. See also RingToneForEmails.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RingToneForEmails
Visual Basic
Public Shared ReadOnly RingToneForEmails As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


RingToneForOtherInteractions Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..RingToneForOtherInteractions Field
WorkgroupAttributes Class See Also Send Feedback
Ring tone for interactions other than emails, chats and calls that arrive into a workgroup. See also RingToneForOtherInteractions.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string RingToneForOtherInteractions
Visual Basic
Public Shared ReadOnly RingToneForOtherInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


Supervisors Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..Supervisors Field
WorkgroupAttributes Class See Also Send Feedback
List of available supervisors for this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string Supervisors
Visual Basic
Public Shared ReadOnly Supervisors As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


WrapUpClientTimeout Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..WrapUpClientTimeout Field
WorkgroupAttributes Class See Also Send Feedback
Time in seconds to wait for a wrap-up code.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WrapUpClientTimeout
Visual Basic
Public Shared ReadOnly WrapUpClientTimeout As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


WrapUpCodes Field

[image]

IceLib Technical Reference
WorkgroupAttributes..::..WrapUpCodes Field
WorkgroupAttributes Class See Also Send Feedback
A list of wrap-up codes available for this workgroup. See also WrapUpCode.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WrapUpCodes
Visual Basic
Public Shared ReadOnly WrapUpCodes As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupAttributes Class
WorkgroupAttributes Members
ININ.IceLib.People Namespace


WorkgroupDetails Class

[image]

IceLib Technical Reference
WorkgroupDetails Class
Members See Also Send Feedback
Represents the common details for an IC workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkgroupDetails
Visual Basic
Public Class WorkgroupDetails

Remarks

This class implements a watched attribute object to watch for changes of workgroup attributes.

To start a watch, call StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) and pass in an array of WorkgroupAttributes strings. When the asynchronous start watch completes, the completedCallback delegate is invoked.

To stop a watch, call StopWatching()()()() or StopWatchingAsync(AsyncCompletedEventHandler, Object). When the asynchronous stop watch operation completes, the completedCallback delegate is invoked.

To change the list of attributes to watch, call ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object). When the asynchronous change watch operation completes, the completedCallback delegate is invoked.

When workgroup details change, the WatchedAttributesChanged event is raised, providing information about the workgroup details attributes that have changed.

Calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) when a watch is already started, or calling StopWatching()()()(), StopWatchingAsync(AsyncCompletedEventHandler, Object), ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean), or ChangeWatchedAttributesAsync(array<String>[]()[][], array<String>[]()[][], Boolean, AsyncCompletedEventHandler, Object) when a watch is not in progress raises the InvalidOperationException.

Attempting to access a workgroup attribute that is not being watched raises the NotCachedException.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..WorkgroupDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Members
ININ.IceLib.People Namespace


WorkgroupDetails Members

[image] [image]

IceLib Technical Reference
WorkgroupDetails Members
WorkgroupDetails Class Constructors Methods Properties Events See Also Send Feedback

The WorkgroupDetails type exposes the following members.

Constructors

 | Name | Description
Public method | WorkgroupDetails | Initializes a new instance of the WorkgroupDetails class.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the WorkgroupDetails are being watch. (See WorkgroupAttributes.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the WorkgroupDetails are being watch. (See WorkgroupAttributes.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified attributeNames for this WorkgroupDetails. (See WorkgroupAttributes.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this WorkgroupDetails object. (See WorkgroupAttributes.)
Public method | StopWatching | Stops watching the workgroup attributes.
Public method | StopWatchingAsync | Asynchronously stops watching a list of workgroup attributes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AcdRoutingOutboundMailboxes | Gets the ACD routing outbound mailboxes for sending outbound e-mail from an ACD workgroup.
Public property | ActiveMembers | Gets the Workgroup's active members.
Public property | Extension | Gets the extension for the Workgroup.
Public property | HasActivation | Gets whether the Workgroup has activation.
Public property | HasMailbox | Gets whether the Workgroup has a mailbox associated with it.
Public property | HasQueue | Gets whether the Workgroup has a Queue associated with it.
Public property | IsActive | Gets whether the Workgroup is active.
Public property | IsWrapUpActive | Gets whether the Workgroup has wrap up active.
Public property | MaximumChatResponseTime | Gets the number of seconds that should elapse before an unattended chat interaction should warn the user about a lack of activity.
Public property | Members | Gets the Workgroup's members.
Public property | Name | Gets the name of the Workgroup.
Public property | QueueType | Gets the QueueType for the Workgroup.
Public property | RingToneForCalls | Gets the ring tone for calls that arrive into this workgroup.
Public property | RingToneForChats | Gets the ring tone for chats that arrive into this workgroup.
Public property | RingToneForEmails | Gets the ring tone for emails that arrive into this workgroup.
Public property | RingToneForOtherInteractions | Gets the ring tone for interactions other than chats, emails and calls that arrive into this workgroup.
Public property | Supervisors | Gets the Workgroup's supervisors.
Public property | WrapUpClientTimeout | Gets workgroup's wrap up client timeout value.
Public property | WrapUpCodes | Gets the workgroups's wrap-up codes.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed.

See Also

WorkgroupDetails Class
ININ.IceLib.People Namespace


WorkgroupDetails Constructor

[image]

IceLib Technical Reference
WorkgroupDetails Constructor
WorkgroupDetails Class See Also Send Feedback
Initializes a new instance of the WorkgroupDetails class.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkgroupDetails(
    PeopleManager peopleManager,
    string name
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager, _
    name As String _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.
name
Type: System..::..String
The name of the workgroup.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


WorkgroupDetails Methods

[image] [image]

IceLib Technical Reference
WorkgroupDetails Methods
WorkgroupDetails Class See Also Send Feedback

The WorkgroupDetails type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the WorkgroupDetails are being watch. (See WorkgroupAttributes.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the WorkgroupDetails are being watch. (See WorkgroupAttributes.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the specified attributeNames for this WorkgroupDetails. (See WorkgroupAttributes.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this WorkgroupDetails object. (See WorkgroupAttributes.)
Public method | StopWatching | Stops watching the workgroup attributes.
Public method | StopWatchingAsync | Asynchronously stops watching a list of workgroup attributes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkgroupDetails Class
ININ.IceLib.People Namespace


ChangeWatchedAttributes Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..ChangeWatchedAttributes Method
WorkgroupDetails Class See Also Send Feedback
Changes what attributes of the WorkgroupDetails are being watch. (See WorkgroupAttributes.)

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributes(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedAttributes ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in WorkgroupAttributes however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


ChangeWatchedAttributesAsync Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..ChangeWatchedAttributesAsync Method
WorkgroupDetails Class See Also Send Feedback
Asynchronously changes what attributes of the WorkgroupDetails are being watch. (See WorkgroupAttributes.)

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAttributesAsync(
    string[] attributeNamesToAdd,
    string[] attributeNamesToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAttributesAsync ( _
    attributeNamesToAdd As String(), _
    attributeNamesToRemove As String(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNamesToAdd
Type: array<System..::..String>[]()[][]
The attribute names to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
attributeNamesToRemove
Type: array<System..::..String>[]()[][]
The attribute names to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note: This method silently ignores attempts to add items already being watched or to remove items not being watched.

Note
Strings for attributeNamesToAdd and attributeNamesToRemove are defined in WorkgroupAttributes however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
WorkgroupDetails..::..IsWatching Method
WorkgroupDetails Class See Also Send Feedback
Determines whether a watch is active.

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether a watch is active.
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


IsWatching Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..IsWatching Method
WorkgroupDetails Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
IsWatching Overload
ININ.IceLib.People Namespace


IsWatching Method (String)

[image]

IceLib Technical Reference
WorkgroupDetails..::..IsWatching Method (String)
WorkgroupDetails Class See Also Send Feedback
Determines whether a watch is active and if the specified value is being watched.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    string attributeName
)
Visual Basic
Public Function IsWatching ( _
    attributeName As String _
) As Boolean

Parameters

attributeName
Type: System..::..String
The workgroup attribute.

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active and the specified value is being watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance and whether the specified value is being watched.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
IsWatching Overload
ININ.IceLib.People Namespace


StartWatching Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..StartWatching Method
WorkgroupDetails Class See Also Send Feedback
Starts watching the specified attributeNames for this WorkgroupDetails. (See WorkgroupAttributes.)

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    string[] attributeNames
)
Visual Basic
Public Sub StartWatching ( _
    attributeNames As String() _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
Array of workgroup attributes to watch.

Remarks

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in WorkgroupAttributes however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | The object is already being watched.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..StartWatchingAsync Method
WorkgroupDetails Class See Also Send Feedback
Asynchronously starts watching the specified attributeNames for this WorkgroupDetails object. (See WorkgroupAttributes.)

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    string[] attributeNames,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    attributeNames As String(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attributeNames
Type: array<System..::..String>[]()[][]
A list of workgroup attributes that the user is requesting to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
Strings for attributeNames are defined in WorkgroupAttributes however custom strings may also be used for custom handlers.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


StopWatching Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..StopWatching Method
WorkgroupDetails Class See Also Send Feedback
Stops watching the workgroup attributes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
WorkgroupDetails..::..StopWatchingAsync Method
WorkgroupDetails Class See Also Send Feedback
Asynchronously stops watching a list of workgroup attributes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


WorkgroupDetails Properties

[image] [image]

IceLib Technical Reference
WorkgroupDetails Properties
WorkgroupDetails Class See Also Send Feedback

The WorkgroupDetails type exposes the following members.

Properties

 | Name | Description
Public property | AcdRoutingOutboundMailboxes | Gets the ACD routing outbound mailboxes for sending outbound e-mail from an ACD workgroup.
Public property | ActiveMembers | Gets the Workgroup's active members.
Public property | Extension | Gets the extension for the Workgroup.
Public property | HasActivation | Gets whether the Workgroup has activation.
Public property | HasMailbox | Gets whether the Workgroup has a mailbox associated with it.
Public property | HasQueue | Gets whether the Workgroup has a Queue associated with it.
Public property | IsActive | Gets whether the Workgroup is active.
Public property | IsWrapUpActive | Gets whether the Workgroup has wrap up active.
Public property | MaximumChatResponseTime | Gets the number of seconds that should elapse before an unattended chat interaction should warn the user about a lack of activity.
Public property | Members | Gets the Workgroup's members.
Public property | Name | Gets the name of the Workgroup.
Public property | QueueType | Gets the QueueType for the Workgroup.
Public property | RingToneForCalls | Gets the ring tone for calls that arrive into this workgroup.
Public property | RingToneForChats | Gets the ring tone for chats that arrive into this workgroup.
Public property | RingToneForEmails | Gets the ring tone for emails that arrive into this workgroup.
Public property | RingToneForOtherInteractions | Gets the ring tone for interactions other than chats, emails and calls that arrive into this workgroup.
Public property | Supervisors | Gets the Workgroup's supervisors.
Public property | WrapUpClientTimeout | Gets workgroup's wrap up client timeout value.
Public property | WrapUpCodes | Gets the workgroups's wrap-up codes.

See Also

WorkgroupDetails Class
ININ.IceLib.People Namespace


AcdRoutingOutboundMailboxes Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..AcdRoutingOutboundMailboxes Property
WorkgroupDetails Class See Also Send Feedback
Gets the ACD routing outbound mailboxes for sending outbound e-mail from an ACD workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ACDRoutingOutboundMailbox> AcdRoutingOutboundMailboxes { get; }
Visual Basic
Public ReadOnly Property AcdRoutingOutboundMailboxes As ReadOnlyCollection(Of ACDRoutingOutboundMailbox)
    Get

Field Value

The collection of mailbox names configured for outbound e-mail.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


ActiveMembers Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..ActiveMembers Property
WorkgroupDetails Class See Also Send Feedback
Gets the Workgroup's active members.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ActiveMembers { get; }
Visual Basic
Public ReadOnly Property ActiveMembers As ReadOnlyCollection(Of String)
    Get

Field Value

The active members.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


Extension Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..Extension Property
WorkgroupDetails Class See Also Send Feedback
Gets the extension for the Workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Extension { get; }
Visual Basic
Public ReadOnly Property Extension As String
    Get

Field Value

The extension.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


HasActivation Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..HasActivation Property
WorkgroupDetails Class See Also Send Feedback
Gets whether the Workgroup has activation.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasActivation { get; }
Visual Basic
Public ReadOnly Property HasActivation As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has activation; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


HasMailbox Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..HasMailbox Property
WorkgroupDetails Class See Also Send Feedback
Gets whether the Workgroup has a mailbox associated with it.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasMailbox { get; }
Visual Basic
Public ReadOnly Property HasMailbox As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has a mailbox; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


HasQueue Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..HasQueue Property
WorkgroupDetails Class See Also Send Feedback
Gets whether the Workgroup has a Queue associated with it.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasQueue { get; }
Visual Basic
Public ReadOnly Property HasQueue As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has a queue; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


IsActive Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..IsActive Property
WorkgroupDetails Class See Also Send Feedback
Gets whether the Workgroup is active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


IsWrapUpActive Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..IsWrapUpActive Property
WorkgroupDetails Class See Also Send Feedback
Gets whether the Workgroup has wrap up active.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWrapUpActive { get; }
Visual Basic
Public ReadOnly Property IsWrapUpActive As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has wrap up active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


MaximumChatResponseTime Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..MaximumChatResponseTime Property
WorkgroupDetails Class See Also Send Feedback
Gets the number of seconds that should elapse before an unattended chat interaction should warn the user about a lack of activity.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaximumChatResponseTime { get; }
Visual Basic
Public ReadOnly Property MaximumChatResponseTime As Integer
    Get

Field Value

The maximum number of seconds before a user should be warned about an inactive chat.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


Members Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..Members Property
WorkgroupDetails Class See Also Send Feedback
Gets the Workgroup's members.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Members { get; }
Visual Basic
Public ReadOnly Property Members As ReadOnlyCollection(Of String)
    Get

Field Value

The members.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


Name Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..Name Property
WorkgroupDetails Class See Also Send Feedback
Gets the name of the Workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


QueueType Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..QueueType Property
WorkgroupDetails Class See Also Send Feedback
Gets the QueueType for the Workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string QueueType { get; }
Visual Basic
Public ReadOnly Property QueueType As String
    Get

Field Value

The type of the queue.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


RingToneForCalls Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..RingToneForCalls Property
WorkgroupDetails Class See Also Send Feedback
Gets the ring tone for calls that arrive into this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RingToneForCalls { get; }
Visual Basic
Public ReadOnly Property RingToneForCalls As String
    Get

Field Value

The ring tone for calls.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


RingToneForChats Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..RingToneForChats Property
WorkgroupDetails Class See Also Send Feedback
Gets the ring tone for chats that arrive into this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RingToneForChats { get; }
Visual Basic
Public ReadOnly Property RingToneForChats As String
    Get

Field Value

The ring tone for calls.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


RingToneForEmails Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..RingToneForEmails Property
WorkgroupDetails Class See Also Send Feedback
Gets the ring tone for emails that arrive into this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RingToneForEmails { get; }
Visual Basic
Public ReadOnly Property RingToneForEmails As String
    Get

Field Value

The ring tone for calls.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


RingToneForOtherInteractions Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..RingToneForOtherInteractions Property
WorkgroupDetails Class See Also Send Feedback
Gets the ring tone for interactions other than chats, emails and calls that arrive into this workgroup.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RingToneForOtherInteractions { get; }
Visual Basic
Public ReadOnly Property RingToneForOtherInteractions As String
    Get

Field Value

The ring tone for calls.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


Supervisors Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..Supervisors Property
WorkgroupDetails Class See Also Send Feedback
Gets the Workgroup's supervisors.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Supervisors { get; }
Visual Basic
Public ReadOnly Property Supervisors As ReadOnlyCollection(Of String)
    Get

Field Value

The supervisors.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


WrapUpClientTimeout Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..WrapUpClientTimeout Property
WorkgroupDetails Class See Also Send Feedback
Gets workgroup's wrap up client timeout value.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int WrapUpClientTimeout { get; }
Visual Basic
Public ReadOnly Property WrapUpClientTimeout As Integer
    Get

Field Value

The wrap up client timeout.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


WrapUpCodes Property

[image]

IceLib Technical Reference
WorkgroupDetails..::..WrapUpCodes Property
WorkgroupDetails Class See Also Send Feedback
Gets the workgroups's wrap-up codes.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<WrapUpCode> WrapUpCodes { get; }
Visual Basic
Public ReadOnly Property WrapUpCodes As ReadOnlyCollection(Of WrapUpCode)
    Get

Field Value

The wrap up codes.

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


WorkgroupDetails Events

[image] [image]

IceLib Technical Reference
WorkgroupDetails Events
WorkgroupDetails Class See Also Send Feedback

The WorkgroupDetails type exposes the following members.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed.

See Also

WorkgroupDetails Class
ININ.IceLib.People Namespace


WatchedAttributesChanged Event

[image]

IceLib Technical Reference
WorkgroupDetails..::..WatchedAttributesChanged Event
WorkgroupDetails Class See Also Send Feedback
Occurs when one of the watched attribute values has been changed.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<WatchedAttributesEventArgs> WatchedAttributesChanged
Visual Basic
Public Event WatchedAttributesChanged As EventHandler(Of WatchedAttributesEventArgs)

Remarks

This event will only occur when attributes being watched have changed. To start watching for attributes call either the StartWatching(array<String>[]()[][]) method or the StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object) method. To modify which attributes are being watched once the watch has been started, use the ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) method.
Note
All event handlers should be added before calling StartWatching(array<String>[]()[][]) or StartWatchingAsync(array<String>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WorkgroupDetails Class
WorkgroupDetails Members
ININ.IceLib.People Namespace


WrapUpCode Class

[image]

IceLib Technical Reference
WrapUpCode Class
Members See Also Send Feedback
Represents a wrap-up code definition. Wrap-up codes are provided for agents to submit the resolution of an ACD interaction.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WrapUpCode
Visual Basic
Public Class WrapUpCode

Remarks

Inteaction Client users can assign wrap-up codes to an interaction to describe it. For example, a wrap-up code such as "Billing Problem", "New Order", or "Service Request" might be assigned to a telephone call. IC provides several reports specific to wrap-up codes. Wrap-up codes are defined in Interaction Administrator. Each code has a descriptive name, an internal-use ID, and customer-defined digits that are unique among wrap-up codes.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..WrapUpCode

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WrapUpCode Members
ININ.IceLib.People Namespace


WrapUpCode Members

[image] [image]

IceLib Technical Reference
WrapUpCode Members
WrapUpCode Class Constructors Methods Properties See Also Send Feedback

The WrapUpCode type exposes the following members.

Constructors

 | Name | Description
Public method | WrapUpCode | Construct the wrap-up code based on its name, digits, and description.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Get a string showing the wrap-up code elements. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Description | Get the wrap-up code display name.
Public property | Digits | Get the wrap-up code digits.
Public property | Id | Get the wrap-up code unique ID.

See Also

WrapUpCode Class
ININ.IceLib.People Namespace


WrapUpCode Constructor

[image]

IceLib Technical Reference
WrapUpCode Constructor
WrapUpCode Class See Also Send Feedback
Construct the wrap-up code based on its name, digits, and description.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WrapUpCode(
    string id,
    string digits,
    string displayName
)
Visual Basic
Public Sub New ( _
    id As String, _
    digits As String, _
    displayName As String _
)

Parameters

id
Type: System..::..String
Unique identifier for the wrap-up code.
digits
Type: System..::..String
Wrap-up code digits.
displayName
Type: System..::..String
Wrap-up code display name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WrapUpCode Class
WrapUpCode Members
ININ.IceLib.People Namespace


WrapUpCode Methods

[image] [image]

IceLib Technical Reference
WrapUpCode Methods
WrapUpCode Class See Also Send Feedback

The WrapUpCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Get a string showing the wrap-up code elements. (Overrides Object..::..ToString()()()().)

See Also

WrapUpCode Class
ININ.IceLib.People Namespace


ToString Method

[image]

IceLib Technical Reference
WrapUpCode..::..ToString Method
WrapUpCode Class See Also Send Feedback
Get a string showing the wrap-up code elements.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string with the following format: {Id,Digits,DisplayName}.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WrapUpCode Class
WrapUpCode Members
ININ.IceLib.People Namespace


WrapUpCode Properties

[image] [image]

IceLib Technical Reference
WrapUpCode Properties
WrapUpCode Class See Also Send Feedback

The WrapUpCode type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the wrap-up code display name.
Public property | Digits | Get the wrap-up code digits.
Public property | Id | Get the wrap-up code unique ID.

See Also

WrapUpCode Class
ININ.IceLib.People Namespace


Description Property

[image]

IceLib Technical Reference
WrapUpCode..::..Description Property
WrapUpCode Class See Also Send Feedback
Get the wrap-up code display name.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WrapUpCode Class
WrapUpCode Members
ININ.IceLib.People Namespace


Digits Property

[image]

IceLib Technical Reference
WrapUpCode..::..Digits Property
WrapUpCode Class See Also Send Feedback
Get the wrap-up code digits.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Digits { get; }
Visual Basic
Public ReadOnly Property Digits As String
    Get

Field Value

The digits.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WrapUpCode Class
WrapUpCode Members
ININ.IceLib.People Namespace


Id Property

[image]

IceLib Technical Reference
WrapUpCode..::..Id Property
WrapUpCode Class See Also Send Feedback
Get the wrap-up code unique ID.

Namespace: ININ.IceLib.People
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

WrapUpCode Class
WrapUpCode Members
ININ.IceLib.People Namespace


ININ.IceLib.People.ResponseManagement Namespace

[image]

IceLib Technical Reference
ININ.IceLib.People.ResponseManagement Namespace
Send Feedback

The ININ.IceLib.People.ResponseManagement namespace contains classes for retrieving Interaction Center Response Documents and for editing user specific Response Documents. These are typically a collection of frequently asked questions. The agents can use the standard answers defined in these Response Documents when he or she is participating in a chat session.

Response Management is the general term for features that allow a user to send pre-defined responses, such as textual messages, URLs, or files to other persons participating in a Chat interaction. Messages, URLs, or files can be sent from Interaction Client, and using this API, from your custom applications.

Note
To use Response Management, you must have Web Services installed and configured on your Web server. For details, see Installing and Using IC's Web Services in the IC Documentation Library on the IC Server. The library of response documents is stored on the IC server, and may be administered using the Response Management container.

Response Management works as follows:

A web visitor requests an interactive Chat session.

An agent is alerted by the Interaction Client (or a custom IceLib application). The agent "picks up" the interaction request.

  • For a Chat, Interaction Client pops a dialog on the agent's workstation that allows the agent to begin an interactive typing session with the customer. The Responses tab of the agent's Chat dialog can contain the names of preset standard text messages, URLs which the agent can push the visitor's browser, and text file names. The agent can drag any combination of these responses into the Response field. When a URL is sent, the remote chat participant’s web browser opens to that address.

Some Interaction Center products allow users to add personal responses, such as a personal greeting or a frequently sent file or URL, to the Response Management library. These personal responses are listed on the Responses tab under the [User Name].xml directory, and are not available to other Interaction Client users.

Response Management Objects

A ResponseItem represents Interaction Messages, Interaction Urls and Interaction Files:

  • An Interaction Message is a note, URL, or file that an agent can send to a web visitor during an interactive session. Interaction Message objects typically display short messages. For example, an Interaction Message titled 'Standard Response Times' could contain 'Standard response times for a support request are .....'.

  • An Interaction Url stores frequently used Urls. For example, an Interaction Url titled 'Support web site' could be defined as 'http://www.inin.com/support'.

  • An Interaction File points to a file path. For example, an Interaction File titled 'Icelib Documentation' could point to 'C:\Program Files\Interactive Intelligence\Icelib\Documentation\Icelib.chm'.

ResponseItemType indicates if a ResponseItem is a Message or a Url or a File or a document.

ResponseDocument is a collection of Interaction Messages, Interaction Urls and Interaction Files. A ResponseDocument may contain nodes that in turn contain a collection of Interaction Messages, Interaction Urls and Interaction Files. A response node can contain child nodes.

ResponseNode is a collection of Interaction Messages, Interaction Urls and Interaction Files. A ResponseNode may contain more ResponseNodes and also ResponseItems.

ResponseManager has the capability to retrive Response Documents, Interaction Messages, Interaction Urls and Interaction Files. In addition, ResponseManager can also receive any updates at the server.

EditableResponseDocument is a Response Document that can be edited by the application. By default, all documents are read-only. User can add response nodes and response items to the editable document. The editable can be obtained from the ResponseManager's UserDocument property.

EditableResponseItem is a Response Item that can be edited by the application. By default, the ResponseItems are read-only. EditableResponseItems can be obtained from either EditableResponseNode or from EditableResponseDocument.

EditableResponseNode is a Response Node that can be edited by the application. By default, the ResponseNodes are read-only. EditableResponseNodes can be obtained from either EditableResponseNode or from EditableResponseDocument.

ResponseChangedEventArgs indicates that there has been a change in Response documents at the server. Set a event handler for ResponseChanged to receive updates.

Examples

This example shows how the classes ResponseManager and ResponseManager can be used to get Response Documents, Interaction Messages, Interaction Urls and Interaction Files.
CopyC#
public class MyResponseManagementClass
{
    private Session _Session;
    private PeopleManager _PeopleManager;
    private ResponseManager _ResponseManager;

    private void MyClient_StartWatchingCompleted(object sender, AsyncCompletedEventArgs e)
    {
        if ( e.Error != null )
        {
            // handle the error
            return;
        }

        // this means that our request 'StartWatching' to the server was successful.
        // TODO: Add your code here.
    }

    private void InitiateResponseManagement()
    {
        if (_PeopleManager == null)
            _PeopleManager = PeopleManager.GetInstance(_Session);
        if (_ResponseManager == null)
            _ResponseManager = new ResponseManager(_PeopleManager);

        // The following statements will make sure that the data obtained from the server is always upto date.
        _ResponseManager.StartWatchingCompleted += new AsyncCompletedEventHandler(MyClient_StartWatchingCompleted);
        object userStateObject1 = new object();
        _ResponseManager.StartWatchingAsync(userStateObject1);

        // Handle updates
        _ResponseManager.ResponseAdded += new EventHandler<ResponseChangedEventArgs>(MyClient_HandleResponsesAdded);
        _ResponseManager.ResponseChanged += new EventHandler<ResponseChangedEventArgs>(MyClient_HandleResponsesChanged);
        _ResponseManager.ResponseDeleted += new EventHandler<ResponseChangedEventArgs>(MyClient_HandleResponsesDeleted);

        // The following statements will get the response management data from the server.
        _ResponseManager.GetAvailableResponsesCompleted += new AsyncCompletedEventHandler(MyClient_GetAvailableResponsesCompleted);
        object userStateObject2 = new object();
        _ResponseManager.GetAvailableResponsesAsync(userStateObject2);
    }

    private void LoadResponseManagementTreeView()
    {
        EditableResponseDocument userDocument = _ResponseManager.UserDocument;
        ReadOnlyCollection<ResponseDocument> serverDocuments = _ResponseManager.ServerDocuments;
        ReadOnlyCollection<ResponseItem> interactionMessages = _ResponseManager.InteractionMessages;
        ReadOnlyCollection<ResponseItem> interactionUrls = _ResponseManager.InteractionUrls;
        ReadOnlyCollection<ResponseItem> interactionFiles = _ResponseManager.InteractionFiles;
        // ......
        // ......
    }

    private void MyClient_GetAvailableResponsesCompleted(object sender, AsyncCompletedEventArgs e)
    {
        if (e.Error != null)
        {
            // handle the error
            return;
        }

        LoadResponseManagementTreeView();
    }

    private void MyClient_HandleResponsesAdded(object sender, ResponseChangedEventArgs e)
    {
        switch(e.ChangedResponseType)
        {
            case ChangedResponseType.File:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.Message:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.Url:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.ServerDocument:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.UserDocument:
            {
                // TODO: Add your code here
                break;
            }
            default:
                break;
        }
    }

    private void MyClient_HandleResponsesAdded(object sender, ResponseChangedEventArgs e)
    {
        switch(e.ChangedResponseType)
        {
            case ChangedResponseType.File:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.Message:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.Url:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.ServerDocument:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.UserDocument:
            {
                // TODO: Add your code here
                break;
            }
            default:
                break;
        }
    }

    private void MyClient_HandleResponsesDeleted(object sender, ResponseChangedEventArgs e)
    {
        switch(e.ChangedResponseType)
        {
            case ChangedResponseType.File:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.Message:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.Url:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.ServerDocument:
            {
                // TODO: Add your code here
                break;
            }
            case ChangedResponseType.UserDocument:
            {
                // TODO: Add your code here
                break;
            }
            default:
                break;
        }
    }

    public AddResponseItem(string name, string text)
    {
        EditableResponseDocument userDoc = _ResponseManager.UserDocument;
        userDoc.AddResponseItem(new EditableResponseItem(ResponseItemType.Message, name, text));
    }

    public UpdateResponseItem(EditableResponseNode parent, ResponseItem item, string name, string text)
    {
        EditableResponseItem editableItem = parent.GetEditableResponseItem(item);
        editableItem.Name = name;
        editableItem.Value = text;
    }

    public SaveDocument()
    {
        _ResponseManager.SaveUserDocumentAsync();
    }
}

Classes

 | Class | Description
Public class | EditableResponseDocument | Represents an editable Response Document. Please refer to ResponseDocument for more information.
Public class | EditableResponseItem | Represents an editable ResponseItem. Please refer to ResponseItem for more information.
Public class | EditableResponseNode | Represents an editable Node in the Response Document. Please refer to ResponseNode for more information.
Public class | ResponseChangedEventArgs | Provides data for the event ResponseChanged.
Public class | ResponseDocument | Represents a read-only Response Document.
Public class | ResponseItem | Represents a read-only ResponseItem object. Each ResponseItem has a unique identifier, name, type, and value.
Public class | ResponseManager | The ResponseManager class has the capability to retrieve Response Documents, Interaction Messages, Interaction Urls and Interaction Files. It can also watch for changes to response management data, and receive any updates at the server.
Public class | ResponseNode | Represents a read-only Response Node.

Enumerations

 | Enumeration | Description
Public enumeration | ChangedResponseType | Represents the type of Response that has changed.
Public enumeration | ResponseItemType | Represents the type of Response.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


ChangedResponseType Enumeration

[image]

IceLib Technical Reference
ChangedResponseType Enumeration
See Also Send Feedback
Represents the type of Response that has changed.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ChangedResponseType
Visual Basic
Public Enumeration ChangedResponseType

Members

Member name | Value | Description
None | 0 | No item type specified.
ResponseItem | 1 | Represents either a interaction message or a url or a file.
ServerDocument | 2 | A server Document item.
UserDocument | 3 | A user Document item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People.ResponseManagement Namespace


EditableResponseDocument Class

[image]

IceLib Technical Reference
EditableResponseDocument Class
Members See Also Send Feedback
Represents an editable Response Document. Please refer to ResponseDocument for more information.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EditableResponseDocument : ResponseDocument
Visual Basic
Public Class EditableResponseDocument _
    Inherits ResponseDocument

Remarks

A Response Document is a collection of Interaction Messages, Interaction URLs and Interaction Files. A ResponseDocument may contain nodes that in turn contain a collection of Interaction Messages, Interaction Urls and Interaction Files. A response node can contain child nodes.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseNode
ININ.IceLib.People.ResponseManagement..::..ResponseDocument
ININ.IceLib.People.ResponseManagement..::..EditableResponseDocument

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseDocument Members

[image] [image]

IceLib Technical Reference
EditableResponseDocument Members
EditableResponseDocument Class Constructors Methods Properties See Also Send Feedback

The EditableResponseDocument type exposes the following members.

Constructors

 | Name | Description
Public method | EditableResponseDocument | Initializes a new instance of the EditableResponseDocument class.

Methods

 | Name | Description
Public method | AddResponseItem | Adds the Response Item.
Public method | AddResponseNode | Adds the Response Node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditableResponseItem | Gets the editable Response Item.
Public method | GetEditableResponseNode | Gets the editable Response Node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveResponseItem | Removes the Response Item.
Public method | RemoveResponseNode | Removes the Response Node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions. (Inherited from ResponseNode.)
Public property | Name | Gets or sets the name.
Public property | ResponseItems | Gets the read-only response items. (Inherited from ResponseNode.)
Public property | ResponseNodes | Gets the read-only response nodes. (Inherited from ResponseNode.)

See Also

EditableResponseDocument Class
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseDocument Constructor

[image]

IceLib Technical Reference
EditableResponseDocument Constructor
EditableResponseDocument Class See Also Send Feedback
Initializes a new instance of the EditableResponseDocument class.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseDocument(
    string name,
    string description,
    string server
)
Visual Basic
Public Sub New ( _
    name As String, _
    description As String, _
    server As String _
)

Parameters

name
Type: System..::..String
The name.
description
Type: System..::..String
The description.
server
Type: System..::..String
The server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseDocument Methods

[image] [image]

IceLib Technical Reference
EditableResponseDocument Methods
EditableResponseDocument Class See Also Send Feedback

The EditableResponseDocument type exposes the following members.

Methods

 | Name | Description
Public method | AddResponseItem | Adds the Response Item.
Public method | AddResponseNode | Adds the Response Node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditableResponseItem | Gets the editable Response Item.
Public method | GetEditableResponseNode | Gets the editable Response Node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveResponseItem | Removes the Response Item.
Public method | RemoveResponseNode | Removes the Response Node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditableResponseDocument Class
ININ.IceLib.People.ResponseManagement Namespace


AddResponseItem Method

[image]

IceLib Technical Reference
EditableResponseDocument..::..AddResponseItem Method
EditableResponseDocument Class See Also Send Feedback
Adds the Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddResponseItem(
    EditableResponseItem item
)
Visual Basic
Public Sub AddResponseItem ( _
    item As EditableResponseItem _
)

Parameters

item
Type: ININ.IceLib.People.ResponseManagement..::..EditableResponseItem
The item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


AddResponseNode Method

[image]

IceLib Technical Reference
EditableResponseDocument..::..AddResponseNode Method
EditableResponseDocument Class See Also Send Feedback
Adds the Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddResponseNode(
    EditableResponseNode node
)
Visual Basic
Public Sub AddResponseNode ( _
    node As EditableResponseNode _
)

Parameters

node
Type: ININ.IceLib.People.ResponseManagement..::..EditableResponseNode
The node.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


GetEditableResponseItem Method

[image]

IceLib Technical Reference
EditableResponseDocument..::..GetEditableResponseItem Method
EditableResponseDocument Class See Also Send Feedback
Gets the editable Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseItem GetEditableResponseItem(
    ResponseItem item
)
Visual Basic
Public Function GetEditableResponseItem ( _
    item As ResponseItem _
) As EditableResponseItem

Parameters

item
Type: ININ.IceLib.People.ResponseManagement..::..ResponseItem
The item.

Return Value

Editable Response Item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


GetEditableResponseNode Method

[image]

IceLib Technical Reference
EditableResponseDocument..::..GetEditableResponseNode Method
EditableResponseDocument Class See Also Send Feedback
Gets the editable Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseNode GetEditableResponseNode(
    ResponseNode node
)
Visual Basic
Public Function GetEditableResponseNode ( _
    node As ResponseNode _
) As EditableResponseNode

Parameters

node
Type: ININ.IceLib.People.ResponseManagement..::..ResponseNode
The node.

Return Value

Editable Response Node.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


RemoveResponseItem Method

[image]

IceLib Technical Reference
EditableResponseDocument..::..RemoveResponseItem Method
EditableResponseDocument Class See Also Send Feedback
Removes the Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveResponseItem(
    ResponseItem item
)
Visual Basic
Public Sub RemoveResponseItem ( _
    item As ResponseItem _
)

Parameters

item
Type: ININ.IceLib.People.ResponseManagement..::..ResponseItem
The item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


RemoveResponseNode Method

[image]

IceLib Technical Reference
EditableResponseDocument..::..RemoveResponseNode Method
EditableResponseDocument Class See Also Send Feedback
Removes the Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveResponseNode(
    ResponseNode node
)
Visual Basic
Public Sub RemoveResponseNode ( _
    node As ResponseNode _
)

Parameters

node
Type: ININ.IceLib.People.ResponseManagement..::..ResponseNode
The node.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseDocument Properties

[image] [image]

IceLib Technical Reference
EditableResponseDocument Properties
EditableResponseDocument Class See Also Send Feedback

The EditableResponseDocument type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions. (Inherited from ResponseNode.)
Public property | Name | Gets or sets the name.
Public property | ResponseItems | Gets the read-only response items. (Inherited from ResponseNode.)
Public property | ResponseNodes | Gets the read-only response nodes. (Inherited from ResponseNode.)

See Also

EditableResponseDocument Class
ININ.IceLib.People.ResponseManagement Namespace


Description Property

[image]

IceLib Technical Reference
EditableResponseDocument..::..Description Property
EditableResponseDocument Class See Also Send Feedback
Gets or sets the description.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


Name Property

[image]

IceLib Technical Reference
EditableResponseDocument..::..Name Property
EditableResponseDocument Class See Also Send Feedback
Gets or sets the name.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseDocument Class
EditableResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Class

[image]

IceLib Technical Reference
EditableResponseItem Class
Members See Also Send Feedback
Represents an editable ResponseItem. Please refer to ResponseItem for more information.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EditableResponseItem : ResponseItem
Visual Basic
Public Class EditableResponseItem _
    Inherits ResponseItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseItem
ININ.IceLib.People.ResponseManagement..::..EditableResponseItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Members

[image] [image]

IceLib Technical Reference
EditableResponseItem Members
EditableResponseItem Class Constructors Methods Properties See Also Send Feedback

The EditableResponseItem type exposes the following members.

Constructors

 | Name | Description
Public method | EditableResponseItem(ResponseItemType, String, String) | Obsolete. Initializes a new instance of the EditableResponseItem class.
Public method | EditableResponseItem(ResponseItemType, String, String, String, List<(Of <<'(String>)>>)) | Initializes a new instance of the EditableResponseItem class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the unique identifier of this Response Item. This is typically only useful if an application is persisting information about Response Items between sessions. (Inherited from ResponseItem.)
Public property | Keywords | Gets or sets the keywords.
Public property | Name | Gets or sets the name.
Public property | PlainTextValue | Gets the Value in plain text, removing any HTML. (Inherited from ResponseItem.)
Public property | ResponseItemType | Gets the type of this Response Item. (Inherited from ResponseItem.)
Public property | Shortcut | Gets or sets the shortcut.
Public property | Value | Gets or sets the value.

See Also

EditableResponseItem Class
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Constructor

[image] [image]

IceLib Technical Reference
EditableResponseItem Constructor
EditableResponseItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditableResponseItem(ResponseItemType, String, String) | Obsolete. Initializes a new instance of the EditableResponseItem class.
Public method | EditableResponseItem(ResponseItemType, String, String, String, List<(Of <<'(String>)>>)) | Initializes a new instance of the EditableResponseItem class.

See Also

EditableResponseItem Class
EditableResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Constructor (ResponseItemType, String, String)

[image]

IceLib Technical Reference
EditableResponseItem Constructor (ResponseItemType, String, String)
EditableResponseItem Class See Also Send Feedback
Initializes a new instance of the EditableResponseItem class.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Please use the constructor that takes a Shortcut and Keywords.",
    false)]
public EditableResponseItem(
    ResponseItemType type,
    string name,
    string itemValue
)
Visual Basic
<ObsoleteAttribute("Please use the constructor that takes a Shortcut and Keywords.",  _
    False)> _
Public Sub New ( _
    type As ResponseItemType, _
    name As String, _
    itemValue As String _
)

Parameters

type
Type: ININ.IceLib.People.ResponseManagement..::..ResponseItemType
The type enumeration indicates whether this item is a simple note message, URL, or file response.
name
Type: System..::..String
Returns or assigns a name to this ResponseItem.
itemValue
Type: System..::..String
The value (File Name / Text / Url).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseItem Class
EditableResponseItem Members
EditableResponseItem Overload
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Constructor (ResponseItemType, String, String, String, List(String))

[image]

IceLib Technical Reference
EditableResponseItem Constructor (ResponseItemType, String, String, String, List<(Of <(<'String>)>)>)
EditableResponseItem Class See Also Send Feedback
Initializes a new instance of the EditableResponseItem class.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseItem(
    ResponseItemType type,
    string name,
    string itemValue,
    string shortcut,
    List<string> keywords
)
Visual Basic
Public Sub New ( _
    type As ResponseItemType, _
    name As String, _
    itemValue As String, _
    shortcut As String, _
    keywords As List(Of String) _
)

Parameters

type
Type: ININ.IceLib.People.ResponseManagement..::..ResponseItemType
The type enumeration indicates whether this item is a simple note message, URL, or file response.
name
Type: System..::..String
Returns or assigns a name to this ResponseItem.
itemValue
Type: System..::..String
The value (File Name / Text / Url).
shortcut
Type: System..::..String
The shortcut for this ResponseItem.
keywords
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
The keywords (A set of strings used to search for this ResponseItem).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

EditableResponseItem Class
EditableResponseItem Members
EditableResponseItem Overload
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Methods

[image] [image]

IceLib Technical Reference
EditableResponseItem Methods
EditableResponseItem Class See Also Send Feedback

The EditableResponseItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditableResponseItem Class
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseItem Properties

[image] [image]

IceLib Technical Reference
EditableResponseItem Properties
EditableResponseItem Class See Also Send Feedback

The EditableResponseItem type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier of this Response Item. This is typically only useful if an application is persisting information about Response Items between sessions. (Inherited from ResponseItem.)
Public property | Keywords | Gets or sets the keywords.
Public property | Name | Gets or sets the name.
Public property | PlainTextValue | Gets the Value in plain text, removing any HTML. (Inherited from ResponseItem.)
Public property | ResponseItemType | Gets the type of this Response Item. (Inherited from ResponseItem.)
Public property | Shortcut | Gets or sets the shortcut.
Public property | Value | Gets or sets the value.

See Also

EditableResponseItem Class
ININ.IceLib.People.ResponseManagement Namespace


Keywords Property

[image]

IceLib Technical Reference
EditableResponseItem..::..Keywords Property
EditableResponseItem Class See Also Send Feedback
Gets or sets the keywords.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public List<string> Keywords { get; set; }
Visual Basic
Public Property Keywords As List(Of String)
    Get
    Set

Field Value

The keywords.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

EditableResponseItem Class
EditableResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Name Property

[image]

IceLib Technical Reference
EditableResponseItem..::..Name Property
EditableResponseItem Class See Also Send Feedback
Gets or sets the name.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseItem Class
EditableResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Shortcut Property

[image]

IceLib Technical Reference
EditableResponseItem..::..Shortcut Property
EditableResponseItem Class See Also Send Feedback
Gets or sets the shortcut.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Shortcut { get; set; }
Visual Basic
Public Property Shortcut As String
    Get
    Set

Field Value

The shortcut.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

EditableResponseItem Class
EditableResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Value Property

[image]

IceLib Technical Reference
EditableResponseItem..::..Value Property
EditableResponseItem Class See Also Send Feedback
Gets or sets the value.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseItem Class
EditableResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseNode Class

[image]

IceLib Technical Reference
EditableResponseNode Class
Members See Also Send Feedback
Represents an editable Node in the Response Document. Please refer to ResponseNode for more information.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EditableResponseNode : ResponseNode
Visual Basic
Public Class EditableResponseNode _
    Inherits ResponseNode

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseNode
ININ.IceLib.People.ResponseManagement..::..EditableResponseNode

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseNode Members

[image] [image]

IceLib Technical Reference
EditableResponseNode Members
EditableResponseNode Class Constructors Methods Properties See Also Send Feedback

The EditableResponseNode type exposes the following members.

Constructors

 | Name | Description
Public method | EditableResponseNode | Initializes a new instance of the EditableResponseNode class. This object is a collection of Interaction Messages, Interaction Urls and Interaction Files. A ResponseNode may contain more ResponseNodes and also ResponseItems.

Methods

 | Name | Description
Public method | AddResponseItem | Adds the Response Item.
Public method | AddResponseNode | Adds the Response Node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditableResponseItem | Gets the editable Response Item.
Public method | GetEditableResponseNode | Gets the editable Response Node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveResponseItem | Removes the Response Item.
Public method | RemoveResponseNode | Removes the Response Node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions. (Inherited from ResponseNode.)
Public property | Name | Gets or sets the name.
Public property | ResponseItems | Gets the read-only response items. (Inherited from ResponseNode.)
Public property | ResponseNodes | Gets the read-only response nodes. (Inherited from ResponseNode.)

See Also

EditableResponseNode Class
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseNode Constructor

[image]

IceLib Technical Reference
EditableResponseNode Constructor
EditableResponseNode Class See Also Send Feedback
Initializes a new instance of the EditableResponseNode class. This object is a collection of Interaction Messages, Interaction Urls and Interaction Files. A ResponseNode may contain more ResponseNodes and also ResponseItems.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseNode(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::..String
The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseNode Methods

[image] [image]

IceLib Technical Reference
EditableResponseNode Methods
EditableResponseNode Class See Also Send Feedback

The EditableResponseNode type exposes the following members.

Methods

 | Name | Description
Public method | AddResponseItem | Adds the Response Item.
Public method | AddResponseNode | Adds the Response Node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditableResponseItem | Gets the editable Response Item.
Public method | GetEditableResponseNode | Gets the editable Response Node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveResponseItem | Removes the Response Item.
Public method | RemoveResponseNode | Removes the Response Node.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditableResponseNode Class
ININ.IceLib.People.ResponseManagement Namespace


AddResponseItem Method

[image]

IceLib Technical Reference
EditableResponseNode..::..AddResponseItem Method
EditableResponseNode Class See Also Send Feedback
Adds the Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddResponseItem(
    EditableResponseItem item
)
Visual Basic
Public Sub AddResponseItem ( _
    item As EditableResponseItem _
)

Parameters

item
Type: ININ.IceLib.People.ResponseManagement..::..EditableResponseItem
The item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


AddResponseNode Method

[image]

IceLib Technical Reference
EditableResponseNode..::..AddResponseNode Method
EditableResponseNode Class See Also Send Feedback
Adds the Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddResponseNode(
    EditableResponseNode node
)
Visual Basic
Public Sub AddResponseNode ( _
    node As EditableResponseNode _
)

Parameters

node
Type: ININ.IceLib.People.ResponseManagement..::..EditableResponseNode
The node.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


GetEditableResponseItem Method

[image]

IceLib Technical Reference
EditableResponseNode..::..GetEditableResponseItem Method
EditableResponseNode Class See Also Send Feedback
Gets the editable Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseItem GetEditableResponseItem(
    ResponseItem item
)
Visual Basic
Public Function GetEditableResponseItem ( _
    item As ResponseItem _
) As EditableResponseItem

Parameters

item
Type: ININ.IceLib.People.ResponseManagement..::..ResponseItem
The item.

Return Value

The editable response item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


GetEditableResponseNode Method

[image]

IceLib Technical Reference
EditableResponseNode..::..GetEditableResponseNode Method
EditableResponseNode Class See Also Send Feedback
Gets the editable Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseNode GetEditableResponseNode(
    ResponseNode node
)
Visual Basic
Public Function GetEditableResponseNode ( _
    node As ResponseNode _
) As EditableResponseNode

Parameters

node
Type: ININ.IceLib.People.ResponseManagement..::..ResponseNode
The node.

Return Value

The editable response node.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


RemoveResponseItem Method

[image]

IceLib Technical Reference
EditableResponseNode..::..RemoveResponseItem Method
EditableResponseNode Class See Also Send Feedback
Removes the Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveResponseItem(
    ResponseItem item
)
Visual Basic
Public Sub RemoveResponseItem ( _
    item As ResponseItem _
)

Parameters

item
Type: ININ.IceLib.People.ResponseManagement..::..ResponseItem
The item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


RemoveResponseNode Method

[image]

IceLib Technical Reference
EditableResponseNode..::..RemoveResponseNode Method
EditableResponseNode Class See Also Send Feedback
Removes the Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveResponseNode(
    ResponseNode node
)
Visual Basic
Public Sub RemoveResponseNode ( _
    node As ResponseNode _
)

Parameters

node
Type: ININ.IceLib.People.ResponseManagement..::..ResponseNode
The node.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


EditableResponseNode Properties

[image] [image]

IceLib Technical Reference
EditableResponseNode Properties
EditableResponseNode Class See Also Send Feedback

The EditableResponseNode type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions. (Inherited from ResponseNode.)
Public property | Name | Gets or sets the name.
Public property | ResponseItems | Gets the read-only response items. (Inherited from ResponseNode.)
Public property | ResponseNodes | Gets the read-only response nodes. (Inherited from ResponseNode.)

See Also

EditableResponseNode Class
ININ.IceLib.People.ResponseManagement Namespace


Name Property

[image]

IceLib Technical Reference
EditableResponseNode..::..Name Property
EditableResponseNode Class See Also Send Feedback
Gets or sets the name.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

EditableResponseNode Class
EditableResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseChangedEventArgs Class

[image]

IceLib Technical Reference
ResponseChangedEventArgs Class
Members See Also Send Feedback
Provides data for the event ResponseChanged.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseChangedEventArgs : EventArgs
Visual Basic
Public Class ResponseChangedEventArgs _
    Inherits EventArgs

Remarks

When this method is called, it indicates that something has changed on the server that has relevance to the logged-in user. The change could be any of Interaction Message, Interaction Url, Interaction File, a Server document, or a User Document. The example code below illustrates the details about this event args.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.People.ResponseManagement..::..ResponseChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseChangedEventArgs Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseChangedEventArgs Members

[image] [image]

IceLib Technical Reference
ResponseChangedEventArgs Members
ResponseChangedEventArgs Class Methods Properties See Also Send Feedback

The ResponseChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChangedResponseType | Gets the type of the changed response.
Public property | ResponseItem | Gets the interaction message / interaction url / interaction file that was changed.
Public property | ServerDocument | Gets the server document that was changed.
Public property | UserDocument | Gets the server document that was changed.

See Also

ResponseChangedEventArgs Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
ResponseChangedEventArgs Methods
ResponseChangedEventArgs Class See Also Send Feedback

The ResponseChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResponseChangedEventArgs Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
ResponseChangedEventArgs Properties
ResponseChangedEventArgs Class See Also Send Feedback

The ResponseChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChangedResponseType | Gets the type of the changed response.
Public property | ResponseItem | Gets the interaction message / interaction url / interaction file that was changed.
Public property | ServerDocument | Gets the server document that was changed.
Public property | UserDocument | Gets the server document that was changed.

See Also

ResponseChangedEventArgs Class
ININ.IceLib.People.ResponseManagement Namespace


ChangedResponseType Property

[image]

IceLib Technical Reference
ResponseChangedEventArgs..::..ChangedResponseType Property
ResponseChangedEventArgs Class See Also Send Feedback
Gets the type of the changed response.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ChangedResponseType ChangedResponseType { get; }
Visual Basic
Public ReadOnly Property ChangedResponseType As ChangedResponseType
    Get

Field Value

The type of the changed response.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseChangedEventArgs Class
ResponseChangedEventArgs Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseItem Property

[image]

IceLib Technical Reference
ResponseChangedEventArgs..::..ResponseItem Property
ResponseChangedEventArgs Class See Also Send Feedback
Gets the interaction message / interaction url / interaction file that was changed.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseItem ResponseItem { get; }
Visual Basic
Public ReadOnly Property ResponseItem As ResponseItem
    Get

Field Value

The interaction message / interaction url / interaction file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseChangedEventArgs Class
ResponseChangedEventArgs Members
ININ.IceLib.People.ResponseManagement Namespace


ServerDocument Property

[image]

IceLib Technical Reference
ResponseChangedEventArgs..::..ServerDocument Property
ResponseChangedEventArgs Class See Also Send Feedback
Gets the server document that was changed.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseDocument ServerDocument { get; }
Visual Basic
Public ReadOnly Property ServerDocument As ResponseDocument
    Get

Field Value

The server document.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseChangedEventArgs Class
ResponseChangedEventArgs Members
ININ.IceLib.People.ResponseManagement Namespace


UserDocument Property

[image]

IceLib Technical Reference
ResponseChangedEventArgs..::..UserDocument Property
ResponseChangedEventArgs Class See Also Send Feedback
Gets the server document that was changed.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseDocument UserDocument { get; }
Visual Basic
Public ReadOnly Property UserDocument As ResponseDocument
    Get

Field Value

The server document.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseChangedEventArgs Class
ResponseChangedEventArgs Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseDocument Class

[image]

IceLib Technical Reference
ResponseDocument Class
Members See Also Send Feedback
Represents a read-only Response Document.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseDocument : ResponseNode
Visual Basic
Public Class ResponseDocument _
    Inherits ResponseNode

Remarks

ResponseDocument is a collection of Interaction Messages, Interaction Urls and Interaction Files. A ResponseDocument may contain nodes that in turn contains a collection of Interaction Messages, Interaction URLs and Interaction Files. A response node in turn can contain child nodes.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseNode
ININ.IceLib.People.ResponseManagement..::..ResponseDocument
ININ.IceLib.People.ResponseManagement..::..EditableResponseDocument

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseDocument Members

[image] [image]

IceLib Technical Reference
ResponseDocument Members
ResponseDocument Class Methods Properties See Also Send Feedback

The ResponseDocument type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets the description.
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions. (Inherited from ResponseNode.)
Public property | Name | Gets the name of this ResponseNode. (Inherited from ResponseNode.)
Public property | ResponseItems | Gets the read-only response items. (Inherited from ResponseNode.)
Public property | ResponseNodes | Gets the read-only response nodes. (Inherited from ResponseNode.)

See Also

ResponseDocument Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseDocument Methods

[image] [image]

IceLib Technical Reference
ResponseDocument Methods
ResponseDocument Class See Also Send Feedback

The ResponseDocument type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResponseDocument Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseDocument Properties

[image] [image]

IceLib Technical Reference
ResponseDocument Properties
ResponseDocument Class See Also Send Feedback

The ResponseDocument type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description.
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions. (Inherited from ResponseNode.)
Public property | Name | Gets the name of this ResponseNode. (Inherited from ResponseNode.)
Public property | ResponseItems | Gets the read-only response items. (Inherited from ResponseNode.)
Public property | ResponseNodes | Gets the read-only response nodes. (Inherited from ResponseNode.)

See Also

ResponseDocument Class
ININ.IceLib.People.ResponseManagement Namespace


Description Property

[image]

IceLib Technical Reference
ResponseDocument..::..Description Property
ResponseDocument Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseDocument Class
ResponseDocument Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseItem Class

[image]

IceLib Technical Reference
ResponseItem Class
Members See Also Send Feedback
Represents a read-only ResponseItem object. Each ResponseItem has a unique identifier, name, type, and value.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseItem
Visual Basic
Public Class ResponseItem

Remarks

A ResponseItem represents Interaction Messages, Interaction Urls and Interaction Files:

  • An Interaction Message is a note, URL, or file that an agent can send to a web visitor during an interactive session. Interaction Message objects typically display short messages. For example, an Interaction Message titled 'Standard Response Times' could contain 'Standard response times for a support request are ...'.

  • An Interaction Url stores frequently used Urls. For example, an Interaction Url titled 'Support web site' could be defined as 'http://www.inin.com/support'.

  • An Interaction File points to a file path. For example, an Interaction File titled 'Icelib Documentation' could point to 'C:\Program Files\Interactive Intelligence\Icelib\Documentation\Icelib.chm'.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseItem
ININ.IceLib.People.ResponseManagement..::..EditableResponseItem

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseItem Members

[image] [image]

IceLib Technical Reference
ResponseItem Members
ResponseItem Class Methods Properties See Also Send Feedback

The ResponseItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the unique identifier of this Response Item. This is typically only useful if an application is persisting information about Response Items between sessions.
Public property | Keywords | Gets the keywords.
Public property | Name | Gets the name.
Public property | PlainTextValue | Gets the Value in plain text, removing any HTML.
Public property | ResponseItemType | Gets the type of this Response Item.
Public property | Shortcut | Gets the shortcut.
Public property | Value | Gets the value.

See Also

ResponseItem Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseItem Methods

[image] [image]

IceLib Technical Reference
ResponseItem Methods
ResponseItem Class See Also Send Feedback

The ResponseItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResponseItem Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseItem Properties

[image] [image]

IceLib Technical Reference
ResponseItem Properties
ResponseItem Class See Also Send Feedback

The ResponseItem type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier of this Response Item. This is typically only useful if an application is persisting information about Response Items between sessions.
Public property | Keywords | Gets the keywords.
Public property | Name | Gets the name.
Public property | PlainTextValue | Gets the Value in plain text, removing any HTML.
Public property | ResponseItemType | Gets the type of this Response Item.
Public property | Shortcut | Gets the shortcut.
Public property | Value | Gets the value.

See Also

ResponseItem Class
ININ.IceLib.People.ResponseManagement Namespace


Id Property

[image]

IceLib Technical Reference
ResponseItem..::..Id Property
ResponseItem Class See Also Send Feedback
Gets the unique identifier of this Response Item. This is typically only useful if an application is persisting information about Response Items between sessions.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Guid Id { get; }
Visual Basic
Public ReadOnly Property Id As Guid
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Keywords Property

[image]

IceLib Technical Reference
ResponseItem..::..Keywords Property
ResponseItem Class See Also Send Feedback
Gets the keywords.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Keywords { get; }
Visual Basic
Public ReadOnly Property Keywords As ReadOnlyCollection(Of String)
    Get

Field Value

The keywords.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Name Property

[image]

IceLib Technical Reference
ResponseItem..::..Name Property
ResponseItem Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


PlainTextValue Property

[image]

IceLib Technical Reference
ResponseItem..::..PlainTextValue Property
ResponseItem Class See Also Send Feedback
Gets the Value in plain text, removing any HTML.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PlainTextValue { get; }
Visual Basic
Public ReadOnly Property PlainTextValue As String
    Get

Field Value

The plain text value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseItemType Property

[image]

IceLib Technical Reference
ResponseItem..::..ResponseItemType Property
ResponseItem Class See Also Send Feedback
Gets the type of this Response Item.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseItemType ResponseItemType { get; }
Visual Basic
Public ReadOnly Property ResponseItemType As ResponseItemType
    Get

Field Value

The type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Shortcut Property

[image]

IceLib Technical Reference
ResponseItem..::..Shortcut Property
ResponseItem Class See Also Send Feedback
Gets the shortcut.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Shortcut { get; }
Visual Basic
Public ReadOnly Property Shortcut As String
    Get

Field Value

The shortcut.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


Value Property

[image]

IceLib Technical Reference
ResponseItem..::..Value Property
ResponseItem Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseItem Class
ResponseItem Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseItemType Enumeration

[image]

IceLib Technical Reference
ResponseItemType Enumeration
See Also Send Feedback
Represents the type of Response.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ResponseItemType
Visual Basic
Public Enumeration ResponseItemType

Members

Member name | Value | Description
None | 0 | None specified.
Message | 1 | A note response.
Url | 2 | A url response.
File | 3 | A file response.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.People.ResponseManagement Namespace


ResponseManager Class

[image]

IceLib Technical Reference
ResponseManager Class
Members Example See Also Send Feedback
The ResponseManager class has the capability to retrieve Response Documents, Interaction Messages, Interaction Urls and Interaction Files. It can also watch for changes to response management data, and receive any updates at the server.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseManager
Visual Basic
Public Class ResponseManager

Remarks

Use this class to get response management documents, interaction messages, interaction urls and interaction files.

Examples

This example shows how the classes ResponseManager and PeopleManager can be used to get Response Documents, Interaction Messages, Interaction Urls and Interaction Files.
CopyC#
public class MyResponseManagementClass
{
    private Session _Session;
    private PeopleManager _PeopleManager;
    private ResponseManager _ResponseManager;

    private void MyClient_StartWatchingCompleted(object sender, AsyncCompletedEventArgs e)
    {
        if ( e.Error != null )
        {
            // handle the error
            return;
        }

        // this means that our request 'StartWatching' to the server was successful.
        // TODO: Add your code here.
    }

    private void InitiateResponseManagement()
    {
        if (_PeopleManager == null)
            _PeopleManager = PeopleManager.GetInstance(_Session);
        if (_ResponseManager == null)
            _ResponseManager = new ResponseManager(_PeopleManager);

        // The following statements will make sure that the data obtained from the server is always upto date.
        _ResponseManager.StartWatchingCompleted += new AsyncCompletedEventHandler(MyClient_StartWatchingCompleted);
        object userStateObject1 = new object();
        _ResponseManager.StartWatchingAsync(userStateObject1);

        // The following statements will get the response management data from the server.
        _ResponseManager.GetAvailableResponsesCompleted += new AsyncCompletedEventHandler(MyClient_GetAvailableResponsesCompleted);
        object userStateObject2 = new object();
        _ResponseManager.GetAvailableResponsesAsync(userStateObject2);
    }

    private void LoadResponseManagementTreeView()
    {
        EditableResponseDocument userDocument = _ResponseManager.UserDocument;
        ReadOnlyCollection<ResponseDocument> serverDocuments = _ResponseManager.ServerDocuments;
        ReadOnlyCollection<ResponseItem> interactionMessages = _ResponseManager.InteractionMessages;
        ReadOnlyCollection<ResponseItem> interactionUrls = _ResponseManager.InteractionUrls;
        ReadOnlyCollection<ResponseItem> interactionFiles = _ResponseManager.InteractionFiles;
        // ......
        // ......
    }

    private void MyClient_GetAvailableResponsesCompleted(object sender, AsyncCompletedEventArgs e)
    {
        if (e.Error != null)
        {
            // handle the error
            return;
        }

        LoadResponseManagementTreeView();
    }

    // TODO: Add your methods here
}

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseManager Members

[image] [image]

IceLib Technical Reference
ResponseManager Members
ResponseManager Class Constructors Methods Properties Events See Also Send Feedback

The ResponseManager type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseManager | Initializes a new instance of the ResponseManager class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAvailableResponses | Gets the available responses.
Public method | GetAvailableResponsesAsync | Gets the available responses asynchronously.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveUserDocument | Saves the user document.
Public method | SaveUserDocumentAsync | Saves the user document asynchronously.
Public method | StartWatching | Subscribes for changes; Start monitoring changes to the response management data.
Public method | StartWatchingAsync | Subscribes for changes asynchronously; Start monitoring changes to the response management data.
Public method | StopWatching | Unsubscribes for changes; Stop monitoring changes to the response management data.
Public method | StopWatchingAsync | Unsubscribes for changes asynchronously; Stop monitoring changes to the response management data.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | InitCollapsed | Gets if the preferred approach is to show the tree view collapsed / expanded. This is a Server Parameter. This can be set using Interaction Administrator.
Public property | InteractionFiles | Obsolete. Gets the interaction message files.
Public property | InteractionMessages | Obsolete. Gets the interaction messages.
Public property | InteractionUrls | Obsolete. Gets the interaction message Urls.
Public property | PeopleManager | Gets the PeopleManager with which this Response Management object is associated.
Public property | ServerDocuments | Gets the server documents.
Public property | UserDocument | Gets the user document.
Public property | UserId | Gets the user ID this Response Management is object is associated with.

Events

 | Name | Description
Public event | ResponseAdded | Occurs when new items are added at the server.
Public event | ResponseChanged | Occurs when existing items are updated at the server.
Public event | ResponseDeleted | Occurs when existing items are deleted on the server.

See Also

ResponseManager Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseManager Constructor

[image]

IceLib Technical Reference
ResponseManager Constructor
ResponseManager Class See Also Send Feedback
Initializes a new instance of the ResponseManager class.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ResponseManager(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
The people manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseManager Methods

[image] [image]

IceLib Technical Reference
ResponseManager Methods
ResponseManager Class See Also Send Feedback

The ResponseManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAvailableResponses | Gets the available responses.
Public method | GetAvailableResponsesAsync | Gets the available responses asynchronously.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveUserDocument | Saves the user document.
Public method | SaveUserDocumentAsync | Saves the user document asynchronously.
Public method | StartWatching | Subscribes for changes; Start monitoring changes to the response management data.
Public method | StartWatchingAsync | Subscribes for changes asynchronously; Start monitoring changes to the response management data.
Public method | StopWatching | Unsubscribes for changes; Stop monitoring changes to the response management data.
Public method | StopWatchingAsync | Unsubscribes for changes asynchronously; Stop monitoring changes to the response management data.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ResponseManager Class
ININ.IceLib.People.ResponseManagement Namespace


GetAvailableResponses Method

[image]

IceLib Technical Reference
ResponseManager..::..GetAvailableResponses Method
ResponseManager Class See Also Send Feedback
Gets the available responses.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetAvailableResponses()
Visual Basic
Public Sub GetAvailableResponses

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


GetAvailableResponsesAsync Method

[image]

IceLib Technical Reference
ResponseManager..::..GetAvailableResponsesAsync Method
ResponseManager Class See Also Send Feedback
Gets the available responses asynchronously.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetAvailableResponsesAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub GetAvailableResponsesAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


IsWatching Method

[image]

IceLib Technical Reference
ResponseManager..::..IsWatching Method
ResponseManager Class See Also Send Feedback
Determines whether a watch is active.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if a watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether a watch is in place for this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


SaveUserDocument Method

[image]

IceLib Technical Reference
ResponseManager..::..SaveUserDocument Method
ResponseManager Class See Also Send Feedback
Saves the user document.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveUserDocument()
Visual Basic
Public Sub SaveUserDocument

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


SaveUserDocumentAsync Method

[image]

IceLib Technical Reference
ResponseManager..::..SaveUserDocumentAsync Method
ResponseManager Class See Also Send Feedback
Saves the user document asynchronously.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveUserDocumentAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SaveUserDocumentAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


StartWatching Method

[image]

IceLib Technical Reference
ResponseManager..::..StartWatching Method
ResponseManager Class See Also Send Feedback
Subscribes for changes; Start monitoring changes to the response management data.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
ResponseManager..::..StartWatchingAsync Method
ResponseManager Class See Also Send Feedback
Subscribes for changes asynchronously; Start monitoring changes to the response management data.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


StopWatching Method

[image]

IceLib Technical Reference
ResponseManager..::..StopWatching Method
ResponseManager Class See Also Send Feedback
Unsubscribes for changes; Stop monitoring changes to the response management data.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
ResponseManager..::..StopWatchingAsync Method
ResponseManager Class See Also Send Feedback
Unsubscribes for changes asynchronously; Stop monitoring changes to the response management data.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ToString Method

[image]

IceLib Technical Reference
ResponseManager..::..ToString Method
ResponseManager Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseManager Properties

[image] [image]

IceLib Technical Reference
ResponseManager Properties
ResponseManager Class See Also Send Feedback

The ResponseManager type exposes the following members.

Properties

 | Name | Description
Public property | InitCollapsed | Gets if the preferred approach is to show the tree view collapsed / expanded. This is a Server Parameter. This can be set using Interaction Administrator.
Public property | InteractionFiles | Obsolete. Gets the interaction message files.
Public property | InteractionMessages | Obsolete. Gets the interaction messages.
Public property | InteractionUrls | Obsolete. Gets the interaction message Urls.
Public property | PeopleManager | Gets the PeopleManager with which this Response Management object is associated.
Public property | ServerDocuments | Gets the server documents.
Public property | UserDocument | Gets the user document.
Public property | UserId | Gets the user ID this Response Management is object is associated with.

See Also

ResponseManager Class
ININ.IceLib.People.ResponseManagement Namespace


InitCollapsed Property

[image]

IceLib Technical Reference
ResponseManager..::..InitCollapsed Property
ResponseManager Class See Also Send Feedback
Gets if the preferred approach is to show the tree view collapsed / expanded. This is a Server Parameter. This can be set using Interaction Administrator.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool InitCollapsed { get; }
Visual Basic
Public ReadOnly Property InitCollapsed As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic), if collapsed; falseFalsefalsefalse (False in Visual Basic) otherwise.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


InteractionFiles Property

[image]

IceLib Technical Reference
ResponseManager..::..InteractionFiles Property
ResponseManager Class See Also Send Feedback
Gets the interaction message files.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionFiles has been deprecated. Use ServerDocuments instead.")]
public ReadOnlyCollection<ResponseItem> InteractionFiles { get; }
Visual Basic
<ObsoleteAttribute("InteractionFiles has been deprecated. Use ServerDocuments instead.")> _
Public ReadOnly Property InteractionFiles As ReadOnlyCollection(Of ResponseItem)
    Get

Field Value

The interaction message files.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


InteractionMessages Property

[image]

IceLib Technical Reference
ResponseManager..::..InteractionMessages Property
ResponseManager Class See Also Send Feedback
Gets the interaction messages.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionMessages has been deprecated. Use ServerDocuments instead.")]
public ReadOnlyCollection<ResponseItem> InteractionMessages { get; }
Visual Basic
<ObsoleteAttribute("InteractionMessages has been deprecated. Use ServerDocuments instead.")> _
Public ReadOnly Property InteractionMessages As ReadOnlyCollection(Of ResponseItem)
    Get

Field Value

The interaction messages.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


InteractionUrls Property

[image]

IceLib Technical Reference
ResponseManager..::..InteractionUrls Property
ResponseManager Class See Also Send Feedback
Gets the interaction message Urls.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("InteractionUrls has been deprecated. Use ServerDocuments instead.")]
public ReadOnlyCollection<ResponseItem> InteractionUrls { get; }
Visual Basic
<ObsoleteAttribute("InteractionUrls has been deprecated. Use ServerDocuments instead.")> _
Public ReadOnly Property InteractionUrls As ReadOnlyCollection(Of ResponseItem)
    Get

Field Value

The interaction message Urls.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


PeopleManager Property

[image]

IceLib Technical Reference
ResponseManager..::..PeopleManager Property
ResponseManager Class See Also Send Feedback
Gets the PeopleManager with which this Response Management object is associated.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PeopleManager PeopleManager { get; }
Visual Basic
Public ReadOnly Property PeopleManager As PeopleManager
    Get

Field Value

The people manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ServerDocuments Property

[image]

IceLib Technical Reference
ResponseManager..::..ServerDocuments Property
ResponseManager Class See Also Send Feedback
Gets the server documents.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseDocument> ServerDocuments { get; }
Visual Basic
Public ReadOnly Property ServerDocuments As ReadOnlyCollection(Of ResponseDocument)
    Get

Field Value

The server documents.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


UserDocument Property

[image]

IceLib Technical Reference
ResponseManager..::..UserDocument Property
ResponseManager Class See Also Send Feedback
Gets the user document.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableResponseDocument UserDocument { get; }
Visual Basic
Public ReadOnly Property UserDocument As EditableResponseDocument
    Get

Field Value

The user document.

Exceptions

Exception | Condition
System..::..InvalidOperationException | If a watch is not in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


UserId Property

[image]

IceLib Technical Reference
ResponseManager..::..UserId Property
ResponseManager Class See Also Send Feedback
Gets the user ID this Response Management is object is associated with.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseManager Events

[image] [image]

IceLib Technical Reference
ResponseManager Events
ResponseManager Class See Also Send Feedback

The ResponseManager type exposes the following members.

Events

 | Name | Description
Public event | ResponseAdded | Occurs when new items are added at the server.
Public event | ResponseChanged | Occurs when existing items are updated at the server.
Public event | ResponseDeleted | Occurs when existing items are deleted on the server.

See Also

ResponseManager Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseAdded Event

[image]

IceLib Technical Reference
ResponseManager..::..ResponseAdded Event
ResponseManager Class See Also Send Feedback
Occurs when new items are added at the server.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ResponseChangedEventArgs> ResponseAdded
Visual Basic
Public Event ResponseAdded As EventHandler(Of ResponseChangedEventArgs)

Remarks

This event will only occur if the response manager is being watched. To start watching the response manager call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseChanged Event

[image]

IceLib Technical Reference
ResponseManager..::..ResponseChanged Event
ResponseManager Class See Also Send Feedback
Occurs when existing items are updated at the server.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ResponseChangedEventArgs> ResponseChanged
Visual Basic
Public Event ResponseChanged As EventHandler(Of ResponseChangedEventArgs)

Remarks

This event will only occur if the response manager is being watched. To start watching the response manager call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseDeleted Event

[image]

IceLib Technical Reference
ResponseManager..::..ResponseDeleted Event
ResponseManager Class See Also Send Feedback
Occurs when existing items are deleted on the server.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ResponseChangedEventArgs> ResponseDeleted
Visual Basic
Public Event ResponseDeleted As EventHandler(Of ResponseChangedEventArgs)

Remarks

This event will only occur if the response manager is being watched. To start watching the response manager call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseManager Class
ResponseManager Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseNode Class

[image]

IceLib Technical Reference
ResponseNode Class
Members See Also Send Feedback
Represents a read-only Response Node.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ResponseNode
Visual Basic
Public Class ResponseNode

Remarks

ResponseNode contains a collection of Interaction Messages, Interaction URLs and Interaction Files. A ResponseNode may contain more ResponseNodes and also ResponseItems.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People.ResponseManagement..::..ResponseNode
ININ.IceLib.People.ResponseManagement..::..EditableResponseNode
ININ.IceLib.People.ResponseManagement..::..ResponseDocument

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseNode Members

[image] [image]

IceLib Technical Reference
ResponseNode Members
ResponseNode Class Methods Properties See Also Send Feedback

The ResponseNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions.
Public property | Name | Gets the name of this ResponseNode.
Public property | ResponseItems | Gets the read-only response items.
Public property | ResponseNodes | Gets the read-only response nodes.

See Also

ResponseNode Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseNode Methods

[image] [image]

IceLib Technical Reference
ResponseNode Methods
ResponseNode Class See Also Send Feedback

The ResponseNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResponseNode Class
ININ.IceLib.People.ResponseManagement Namespace


ResponseNode Properties

[image] [image]

IceLib Technical Reference
ResponseNode Properties
ResponseNode Class See Also Send Feedback

The ResponseNode type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions.
Public property | Name | Gets the name of this ResponseNode.
Public property | ResponseItems | Gets the read-only response items.
Public property | ResponseNodes | Gets the read-only response nodes.

See Also

ResponseNode Class
ININ.IceLib.People.ResponseManagement Namespace


Id Property

[image]

IceLib Technical Reference
ResponseNode..::..Id Property
ResponseNode Class See Also Send Feedback
Gets the unique identifier. This typically only useful if an application is persisting information about Response Nodes between sessions.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Guid Id { get; }
Visual Basic
Public ReadOnly Property Id As Guid
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseNode Class
ResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


Name Property

[image]

IceLib Technical Reference
ResponseNode..::..Name Property
ResponseNode Class See Also Send Feedback
Gets the name of this ResponseNode.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseNode Class
ResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseItems Property

[image]

IceLib Technical Reference
ResponseNode..::..ResponseItems Property
ResponseNode Class See Also Send Feedback
Gets the read-only response items.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseItem> ResponseItems { get; }
Visual Basic
Public ReadOnly Property ResponseItems As ReadOnlyCollection(Of ResponseItem)
    Get

Field Value

The collection of ResponseItems.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseNode Class
ResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


ResponseNodes Property

[image]

IceLib Technical Reference
ResponseNode..::..ResponseNodes Property
ResponseNode Class See Also Send Feedback
Gets the read-only response nodes.

Namespace: ININ.IceLib.People.ResponseManagement
Assembly: ININ.IceLib.People (in ININ.IceLib.People.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ResponseNode> ResponseNodes { get; }
Visual Basic
Public ReadOnly Property ResponseNodes As ReadOnlyCollection(Of ResponseNode)
    Get

Field Value

The nodes collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ResponseNode Class
ResponseNode Members
ININ.IceLib.People.ResponseManagement Namespace


ININ.IceLib.ProcessAutomation Namespace

[image]

IceLib Technical Reference
ININ.IceLib.ProcessAutomation Namespace
Send Feedback

The ININ.IceLib.ProcessAutomation namespace contains classes for manipulating, monitoring, and managing Interaction Process Automation data.

The Interaction Process Automation system consists of many entities such as Processes, Process instances, and Work Items.

In order to use some of the Process Automation APIs, the custom IceLib-based application must acquire an IPA license for the logged in user. Having acquired any of these 4 licenses will be sufficient to pass the validation check. The IA control is a radio button, so a user will at most have only 1 of the licenses.

Licenses for Interaction Process Automation and its APIs are assigned and configured in Interaction Administrator. A user can have only one of the following licenses:

  • Direct Routed Work Items - Users with the I3_ACCESS_IPA_USER license can receive work items that are routed directly to them.
  • Group Routed Work Items - Users with the I3_ACCESS_IPA_USER_ACD license can receive work items that are routed to them either directly or as a member of a workgroup (similar to an ACD queue).
  • Process Monitor - Users with the I3_ACCESS_IPA_MONITOR license can view process statuses and details in the Process Monitor.
  • Process Designer - Users with the I3_ACCESS_IPA_DESIGNER license can receive work items or create and modify processes.

The licenses are cumulative. That is, the Group Routed Work Items license includes the Direct Routed Work Items license, the Process Monitor license includes both of the Routed Work Items licenses, and the Process Designer license includes all the other licenses.

The asynchronous and synchronous versions of these methods are affected:

  • CreateInstance(ProcessLaunchParameters)
  • LaunchProcessByName(String, ProcessLaunchParameters)
  • Pickup()()()() (for Work Item Interactions)

Classes

 | Class | Description
Public class | AsyncGetLaunchableProcessesCompletedEventArgs | Provides data for the asynchronous completed events of GetLaunchableProcessesAsync(EventHandler<(Of <<'(AsyncGetLaunchableProcessesCompletedEventArgs>)>>), Object).
Public class | AsyncGetProcessDefinitionsCompletedEventArgs | Provides data for the asynchronous completed events of ProcessDefinitionList.
Public class | LaunchableProcessesEventArgs | Provides data for the LaunchableProcessesChanged event of a ProcessManager.
Public class | ProcessDefinition | Provides information about a process that the user can launch.
Public class | ProcessDefinitionList | A watchable list of all ProcessDefinition instances the current user has access to.
Public class | ProcessDefinitionListEventArgs | Provides data for the ProcessDefinitionsListChanged event.
Public class | ProcessInstance | Defines an instance of a process.
Public class | ProcessInstanceCancelData | Class that holds data for canceling a process instance.
Public class | ProcessLaunchParameters | Provides a way to attach data while launching processes.
Public class | ProcessManager | Provides access to all process automation classes in the ININ.IceLib.ProcessAutomation namespace.
Public class | ProcessManager..::..CancelResults | The result code of a cancel process attempt.
Public class | ProcessStatus | Represents the current status of ProcessInstance.
Public class | WorkItemInteraction | Represents a work item interaction within the Interaction Center system.
Public class | WorkItemInteractionAttributeName | Specifies attribute names that can be used with WorkItemInteractions.

Enumerations

 | Enumeration | Description
Public enumeration | FlowStatus | Represents the running flow status.
Public enumeration | PasOverloadedAtLaunchOption | Specifies the action that should be taken by Process Automation Server (PAS) if PAS is overloaded at the time of the launch request.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.


AsyncGetLaunchableProcessesCompletedEventArgs Class

[image]

IceLib Technical Reference
AsyncGetLaunchableProcessesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of GetLaunchableProcessesAsync(EventHandler<(Of <<'(AsyncGetLaunchableProcessesCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncGetLaunchableProcessesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncGetLaunchableProcessesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.ProcessAutomation..::..AsyncGetLaunchableProcessesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

AsyncGetLaunchableProcessesCompletedEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


AsyncGetLaunchableProcessesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncGetLaunchableProcessesCompletedEventArgs Members
AsyncGetLaunchableProcessesCompletedEventArgs Class Methods Properties See Also Send Feedback

The AsyncGetLaunchableProcessesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProcessDefinitions | Gets the list of launchable processes for the currently logged in user.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetLaunchableProcessesCompletedEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


AsyncGetLaunchableProcessesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncGetLaunchableProcessesCompletedEventArgs Methods
AsyncGetLaunchableProcessesCompletedEventArgs Class See Also Send Feedback

The AsyncGetLaunchableProcessesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncGetLaunchableProcessesCompletedEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


AsyncGetLaunchableProcessesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncGetLaunchableProcessesCompletedEventArgs Properties
AsyncGetLaunchableProcessesCompletedEventArgs Class See Also Send Feedback

The AsyncGetLaunchableProcessesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProcessDefinitions | Gets the list of launchable processes for the currently logged in user.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetLaunchableProcessesCompletedEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitions Property

[image]

IceLib Technical Reference
AsyncGetLaunchableProcessesCompletedEventArgs..::..ProcessDefinitions Property
AsyncGetLaunchableProcessesCompletedEventArgs Class See Also Send Feedback
Gets the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> ProcessDefinitions { get; }
Visual Basic
Public ReadOnly Property ProcessDefinitions As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

AsyncGetLaunchableProcessesCompletedEventArgs Class
AsyncGetLaunchableProcessesCompletedEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


AsyncGetProcessDefinitionsCompletedEventArgs Class

[image]

IceLib Technical Reference
AsyncGetProcessDefinitionsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of ProcessDefinitionList.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncGetProcessDefinitionsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncGetProcessDefinitionsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.ProcessAutomation..::..AsyncGetProcessDefinitionsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

AsyncGetProcessDefinitionsCompletedEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


AsyncGetProcessDefinitionsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncGetProcessDefinitionsCompletedEventArgs Members
AsyncGetProcessDefinitionsCompletedEventArgs Class Methods Properties See Also Send Feedback

The AsyncGetProcessDefinitionsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProcessDefinitions | Gets the list of ProcessDefinition instances for the currently logged in user.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetProcessDefinitionsCompletedEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


AsyncGetProcessDefinitionsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncGetProcessDefinitionsCompletedEventArgs Methods
AsyncGetProcessDefinitionsCompletedEventArgs Class See Also Send Feedback

The AsyncGetProcessDefinitionsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncGetProcessDefinitionsCompletedEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


AsyncGetProcessDefinitionsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncGetProcessDefinitionsCompletedEventArgs Properties
AsyncGetProcessDefinitionsCompletedEventArgs Class See Also Send Feedback

The AsyncGetProcessDefinitionsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ProcessDefinitions | Gets the list of ProcessDefinition instances for the currently logged in user.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetProcessDefinitionsCompletedEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitions Property

[image]

IceLib Technical Reference
AsyncGetProcessDefinitionsCompletedEventArgs..::..ProcessDefinitions Property
AsyncGetProcessDefinitionsCompletedEventArgs Class See Also Send Feedback
Gets the list of ProcessDefinition instances for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> ProcessDefinitions { get; }
Visual Basic
Public ReadOnly Property ProcessDefinitions As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

AsyncGetProcessDefinitionsCompletedEventArgs Class
AsyncGetProcessDefinitionsCompletedEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


FlowStatus Enumeration

[image]

IceLib Technical Reference
FlowStatus Enumeration
See Also Send Feedback
Represents the running flow status.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FlowStatus
Visual Basic
Public Enumeration FlowStatus

Members

Member name | Value | Description
None | 0 | Unknown flow status.
NotFound | 1 | Status not found.
Invalid | 2 | The flow is invalid.
Running | 3 | The flow is running.
Error | 4 | The flow is in error.
Completed | 5 | The flow is completed.
Cancelled | 6 | The flow is cancelled.
RestoredInError | 7 | The flow is restored and it is in an error state.
PropagatedError | 8 | Error state due to one of the child actions being in an error state.
Queued | 9 | The flow is queued.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ININ.IceLib.ProcessAutomation Namespace


LaunchableProcessesEventArgs Class

[image]

IceLib Technical Reference
LaunchableProcessesEventArgs Class
Members See Also Send Feedback
Provides data for the LaunchableProcessesChanged event of a ProcessManager.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LaunchableProcessesEventArgs : EventArgs
Visual Basic
Public Class LaunchableProcessesEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.ProcessAutomation..::..LaunchableProcessesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

LaunchableProcessesEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


LaunchableProcessesEventArgs Members

[image] [image]

IceLib Technical Reference
LaunchableProcessesEventArgs Members
LaunchableProcessesEventArgs Class Methods Properties See Also Send Feedback

The LaunchableProcessesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Gets the list of new launchable processes that are added for the currently logged in user.
Public property | Removed | Gets the list of launchable processes that are removed for the currently logged in user.
Public property | Updated | Gets the list of updated launchable processes for the currently logged in user.

See Also

LaunchableProcessesEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


LaunchableProcessesEventArgs Methods

[image] [image]

IceLib Technical Reference
LaunchableProcessesEventArgs Methods
LaunchableProcessesEventArgs Class See Also Send Feedback

The LaunchableProcessesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LaunchableProcessesEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


LaunchableProcessesEventArgs Properties

[image] [image]

IceLib Technical Reference
LaunchableProcessesEventArgs Properties
LaunchableProcessesEventArgs Class See Also Send Feedback

The LaunchableProcessesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Added | Gets the list of new launchable processes that are added for the currently logged in user.
Public property | Removed | Gets the list of launchable processes that are removed for the currently logged in user.
Public property | Updated | Gets the list of updated launchable processes for the currently logged in user.

See Also

LaunchableProcessesEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


Added Property

[image]

IceLib Technical Reference
LaunchableProcessesEventArgs..::..Added Property
LaunchableProcessesEventArgs Class See Also Send Feedback
Gets the list of new launchable processes that are added for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

LaunchableProcessesEventArgs Class
LaunchableProcessesEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


Removed Property

[image]

IceLib Technical Reference
LaunchableProcessesEventArgs..::..Removed Property
LaunchableProcessesEventArgs Class See Also Send Feedback
Gets the list of launchable processes that are removed for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

LaunchableProcessesEventArgs Class
LaunchableProcessesEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


Updated Property

[image]

IceLib Technical Reference
LaunchableProcessesEventArgs..::..Updated Property
LaunchableProcessesEventArgs Class See Also Send Feedback
Gets the list of updated launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> Updated { get; }
Visual Basic
Public ReadOnly Property Updated As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

LaunchableProcessesEventArgs Class
LaunchableProcessesEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


PasOverloadedAtLaunchOption Enumeration

[image]

IceLib Technical Reference
PasOverloadedAtLaunchOption Enumeration
See Also Send Feedback
Specifies the action that should be taken by Process Automation Server (PAS) if PAS is overloaded at the time of the launch request.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum PasOverloadedAtLaunchOption
Visual Basic
Public Enumeration PasOverloadedAtLaunchOption

Members

Member name | Value | Description
None | 0 | None
Fail | 1 | Fail the launch request without creating a process instance.
Queue | 2 | Create a new process instance and queue execution of the new process so it can be executed later when Process Automation Server (PAS) is no longer overloaded. If the process gets queued at launch by PAS, the returned ProcessInstance object will have a Status property whose Id property will be set to Queued.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

ININ.IceLib.ProcessAutomation Namespace


ProcessDefinition Class

[image]

IceLib Technical Reference
ProcessDefinition Class
Members See Also Send Feedback
Provides information about a process that the user can launch.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessDefinition
Visual Basic
Public Class ProcessDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinition Members

[image] [image]

IceLib Technical Reference
ProcessDefinition Members
ProcessDefinition Class Methods Properties See Also Send Feedback

The ProcessDefinition type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Launches this process.
Public method | CreateInstanceAsync | Asynchronously launches this process.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Description | Gets the Description of the process definition.
Public property | Id | Gets the ID of the process definition.
Public property | Inputs | Gets the Xml schema for the inputs to the published version of this process. The inputs can change when a new version of a process is published, so ensure you are watching the ProcessDefinition object for changes via the ProcessDefinitionList.
Public property | Name | Gets the Name of the process definition.
Public property | PublishedVersion | Gets the Published Version of this process. When launching a process IPA will always launch the published version. Watch for changes to the published version to determine when inputs, etc to the process have changed.

See Also

ProcessDefinition Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinition Methods

[image] [image]

IceLib Technical Reference
ProcessDefinition Methods
ProcessDefinition Class See Also Send Feedback

The ProcessDefinition type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Launches this process.
Public method | CreateInstanceAsync | Asynchronously launches this process.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ProcessDefinition Class
ININ.IceLib.ProcessAutomation Namespace


CreateInstance Method

[image]

IceLib Technical Reference
ProcessDefinition..::..CreateInstance Method
ProcessDefinition Class See Also Send Feedback
Launches this process.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessInstance CreateInstance(
    ProcessLaunchParameters launchParameters
)
Visual Basic
Public Function CreateInstance ( _
    launchParameters As ProcessLaunchParameters _
) As ProcessInstance

Parameters

launchParameters
Type: ININ.IceLib.ProcessAutomation..::..ProcessLaunchParameters
The parameters needs to be set while launching the process.

Return Value

The created Process Instance.

Remarks

NOTE: See the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses for this method.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


CreateInstanceAsync Method

[image]

IceLib Technical Reference
ProcessDefinition..::..CreateInstanceAsync Method
ProcessDefinition Class See Also Send Feedback
Asynchronously launches this process.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateInstanceAsync(
    ProcessLaunchParameters launchParameters,
    EventHandler<AsyncCompletedEventArgs<ProcessInstance>> completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateInstanceAsync ( _
    launchParameters As ProcessLaunchParameters, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of ProcessInstance)), _
    userState As Object _
)

Parameters

launchParameters
Type: ININ.IceLib.ProcessAutomation..::..ProcessLaunchParameters
The parameters needs to be set while launching the process.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncCompletedEventArgs <(Of <(<' ProcessInstance >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

NOTE: See the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses for this method.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


Equals Method

[image]

IceLib Technical Reference
ProcessDefinition..::..Equals Method
ProcessDefinition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ProcessDefinition..::..GetHashCode Method
ProcessDefinition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


ToString Method

[image]

IceLib Technical Reference
ProcessDefinition..::..ToString Method
ProcessDefinition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinition Properties

[image] [image]

IceLib Technical Reference
ProcessDefinition Properties
ProcessDefinition Class See Also Send Feedback

The ProcessDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the Description of the process definition.
Public property | Id | Gets the ID of the process definition.
Public property | Inputs | Gets the Xml schema for the inputs to the published version of this process. The inputs can change when a new version of a process is published, so ensure you are watching the ProcessDefinition object for changes via the ProcessDefinitionList.
Public property | Name | Gets the Name of the process definition.
Public property | PublishedVersion | Gets the Published Version of this process. When launching a process IPA will always launch the published version. Watch for changes to the published version to determine when inputs, etc to the process have changed.

See Also

ProcessDefinition Class
ININ.IceLib.ProcessAutomation Namespace


Description Property

[image]

IceLib Technical Reference
ProcessDefinition..::..Description Property
ProcessDefinition Class See Also Send Feedback
Gets the Description of the process definition.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The Process Definition Description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


Id Property

[image]

IceLib Technical Reference
ProcessDefinition..::..Id Property
ProcessDefinition Class See Also Send Feedback
Gets the ID of the process definition.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The Process Definition ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


Inputs Property

[image]

IceLib Technical Reference
ProcessDefinition..::..Inputs Property
ProcessDefinition Class See Also Send Feedback
Gets the Xml schema for the inputs to the published version of this process. The inputs can change when a new version of a process is published, so ensure you are watching the ProcessDefinition object for changes via the ProcessDefinitionList.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public XmlSchema Inputs { get; }
Visual Basic
Public ReadOnly Property Inputs As XmlSchema
    Get

Field Value

The Process Definition Inputs.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


Name Property

[image]

IceLib Technical Reference
ProcessDefinition..::..Name Property
ProcessDefinition Class See Also Send Feedback
Gets the Name of the process definition.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The Process Definition Name .

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


PublishedVersion Property

[image]

IceLib Technical Reference
ProcessDefinition..::..PublishedVersion Property
ProcessDefinition Class See Also Send Feedback
Gets the Published Version of this process. When launching a process IPA will always launch the published version. Watch for changes to the published version to determine when inputs, etc to the process have changed.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PublishedVersion { get; }
Visual Basic
Public ReadOnly Property PublishedVersion As String
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessDefinition Class
ProcessDefinition Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionList Class

[image]

IceLib Technical Reference
ProcessDefinitionList Class
Members See Also Send Feedback
A watchable list of all ProcessDefinition instances the current user has access to.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessDefinitionList
Visual Basic
Public Class ProcessDefinitionList

Remarks

This class can be used to start and stop a watch on all ProcessDefinition instances the current user has access to. This is different from the watch available on ProcessManager, which only watches instances that are launchable.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessDefinitionList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionList Members

[image] [image]

IceLib Technical Reference
ProcessDefinitionList Members
ProcessDefinitionList Class Constructors Methods Properties Events See Also Send Feedback

The ProcessDefinitionList type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessDefinitionList | Initializes a new instance of the ProcessDefinitionList class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Sends a request to the server to watch the list of processes definitions for the currently logged in user.
Public method | StartWatchingAsync | Asynchronously sends a request to the server to watch the list of process definitions for the currently logged in user.
Public method | StopWatching | Sends a request to the server to stop watching the list of process definitions for the currently logged in user.
Public method | StopWatchingAsync | Asynchronously sends a request to the server to stop watching the list of process definitions for the currently logged in user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsWatching | Gets a value indicating whether this instance is watched.
Public property | ProcessDefinitions | Gets the cached list of processes definitions.

Events

 | Name | Description
Public event | ProcessDefinitionChanged | Raised when the properties of a process definition change.
Public event | ProcessDefinitionsListChanged | Raised when existing process definitions for the logged in user are updated.

See Also

ProcessDefinitionList Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionList Constructor

[image]

IceLib Technical Reference
ProcessDefinitionList Constructor
ProcessDefinitionList Class See Also Send Feedback
Initializes a new instance of the ProcessDefinitionList class.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessDefinitionList(
    ProcessManager processManager
)
Visual Basic
Public Sub New ( _
    processManager As ProcessManager _
)

Parameters

processManager
Type: ININ.IceLib.ProcessAutomation..::..ProcessManager
The process manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionList Methods

[image] [image]

IceLib Technical Reference
ProcessDefinitionList Methods
ProcessDefinitionList Class See Also Send Feedback

The ProcessDefinitionList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Sends a request to the server to watch the list of processes definitions for the currently logged in user.
Public method | StartWatchingAsync | Asynchronously sends a request to the server to watch the list of process definitions for the currently logged in user.
Public method | StopWatching | Sends a request to the server to stop watching the list of process definitions for the currently logged in user.
Public method | StopWatchingAsync | Asynchronously sends a request to the server to stop watching the list of process definitions for the currently logged in user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessDefinitionList Class
ININ.IceLib.ProcessAutomation Namespace


StartWatching Method

[image]

IceLib Technical Reference
ProcessDefinitionList..::..StartWatching Method
ProcessDefinitionList Class See Also Send Feedback
Sends a request to the server to watch the list of processes definitions for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> StartWatching()
Visual Basic
Public Function StartWatching As ReadOnlyCollection(Of ProcessDefinition)

Return Value

The list of process definitions for the currently logged in user.

Remarks

When this method completes, it will raise the event ProcessDefinitionsListChanged. Note that an event handler needs to be set for ProcessDefinitionsListChanged before calling this method.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..InvalidOperationException | The list of process definitions is already watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
ProcessDefinitionList..::..StartWatchingAsync Method
ProcessDefinitionList Class See Also Send Feedback
Asynchronously sends a request to the server to watch the list of process definitions for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    EventHandler<AsyncGetProcessDefinitionsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncGetProcessDefinitionsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncGetProcessDefinitionsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The list of process definitions is already watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


StopWatching Method

[image]

IceLib Technical Reference
ProcessDefinitionList..::..StopWatching Method
ProcessDefinitionList Class See Also Send Feedback
Sends a request to the server to stop watching the list of process definitions for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Exceptions

Exception | Condition
System..::..InvalidOperationException | The list of process definitions is not watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
ProcessDefinitionList..::..StopWatchingAsync Method
ProcessDefinitionList Class See Also Send Feedback
Asynchronously sends a request to the server to stop watching the list of process definitions for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The list of process definitions is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionList Properties

[image] [image]

IceLib Technical Reference
ProcessDefinitionList Properties
ProcessDefinitionList Class See Also Send Feedback

The ProcessDefinitionList type exposes the following members.

Properties

 | Name | Description
Public property | IsWatching | Gets a value indicating whether this instance is watched.
Public property | ProcessDefinitions | Gets the cached list of processes definitions.

See Also

ProcessDefinitionList Class
ININ.IceLib.ProcessAutomation Namespace


IsWatching Property

[image]

IceLib Technical Reference
ProcessDefinitionList..::..IsWatching Property
ProcessDefinitionList Class See Also Send Feedback
Gets a value indicating whether this instance is watched.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching { get; }
Visual Basic
Public ReadOnly Property IsWatching As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is watched; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitions Property

[image]

IceLib Technical Reference
ProcessDefinitionList..::..ProcessDefinitions Property
ProcessDefinitionList Class See Also Send Feedback
Gets the cached list of processes definitions.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> ProcessDefinitions { get; }
Visual Basic
Public ReadOnly Property ProcessDefinitions As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The processes definitions.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | A StartWatching()()()() has not been called / it has been called, but not completed yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionList Events

[image] [image]

IceLib Technical Reference
ProcessDefinitionList Events
ProcessDefinitionList Class See Also Send Feedback

The ProcessDefinitionList type exposes the following members.

Events

 | Name | Description
Public event | ProcessDefinitionChanged | Raised when the properties of a process definition change.
Public event | ProcessDefinitionsListChanged | Raised when existing process definitions for the logged in user are updated.

See Also

ProcessDefinitionList Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionChanged Event

[image]

IceLib Technical Reference
ProcessDefinitionList..::..ProcessDefinitionChanged Event
ProcessDefinitionList Class See Also Send Feedback
Raised when the properties of a process definition change.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ProcessDefinitionListEventArgs> ProcessDefinitionChanged
Visual Basic
Public Event ProcessDefinitionChanged As EventHandler(Of ProcessDefinitionListEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionsListChanged Event

[image]

IceLib Technical Reference
ProcessDefinitionList..::..ProcessDefinitionsListChanged Event
ProcessDefinitionList Class See Also Send Feedback
Raised when existing process definitions for the logged in user are updated.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<ProcessDefinitionListEventArgs> ProcessDefinitionsListChanged
Visual Basic
Public Event ProcessDefinitionsListChanged As EventHandler(Of ProcessDefinitionListEventArgs)

Remarks

When this event is raised it is an indication that the list of ProcessDefinitions that the logged in user has access to has changed in some way. For example, a new ProcessDefinition may have been added, or an existing one removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionList Class
ProcessDefinitionList Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionListEventArgs Class

[image]

IceLib Technical Reference
ProcessDefinitionListEventArgs Class
Members See Also Send Feedback
Provides data for the ProcessDefinitionsListChanged event.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessDefinitionListEventArgs : EventArgs
Visual Basic
Public Class ProcessDefinitionListEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.ProcessAutomation..::..ProcessDefinitionListEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionListEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionListEventArgs Members

[image] [image]

IceLib Technical Reference
ProcessDefinitionListEventArgs Members
ProcessDefinitionListEventArgs Class Methods Properties See Also Send Feedback

The ProcessDefinitionListEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Gets the list of new ProcessDefinition instances for the currently logged in user.
Public property | Removed | Gets the list of removed ProcessDefinition instances for the currently logged in user.
Public property | Updated | Gets the list of updated ProcessDefinition instances for the currently logged in user.

See Also

ProcessDefinitionListEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionListEventArgs Methods

[image] [image]

IceLib Technical Reference
ProcessDefinitionListEventArgs Methods
ProcessDefinitionListEventArgs Class See Also Send Feedback

The ProcessDefinitionListEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessDefinitionListEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionListEventArgs Properties

[image] [image]

IceLib Technical Reference
ProcessDefinitionListEventArgs Properties
ProcessDefinitionListEventArgs Class See Also Send Feedback

The ProcessDefinitionListEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Added | Gets the list of new ProcessDefinition instances for the currently logged in user.
Public property | Removed | Gets the list of removed ProcessDefinition instances for the currently logged in user.
Public property | Updated | Gets the list of updated ProcessDefinition instances for the currently logged in user.

See Also

ProcessDefinitionListEventArgs Class
ININ.IceLib.ProcessAutomation Namespace


Added Property

[image]

IceLib Technical Reference
ProcessDefinitionListEventArgs..::..Added Property
ProcessDefinitionListEventArgs Class See Also Send Feedback
Gets the list of new ProcessDefinition instances for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionListEventArgs Class
ProcessDefinitionListEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


Removed Property

[image]

IceLib Technical Reference
ProcessDefinitionListEventArgs..::..Removed Property
ProcessDefinitionListEventArgs Class See Also Send Feedback
Gets the list of removed ProcessDefinition instances for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionListEventArgs Class
ProcessDefinitionListEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


Updated Property

[image]

IceLib Technical Reference
ProcessDefinitionListEventArgs..::..Updated Property
ProcessDefinitionListEventArgs Class See Also Send Feedback
Gets the list of updated ProcessDefinition instances for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> Updated { get; }
Visual Basic
Public ReadOnly Property Updated As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The process definitions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessDefinitionListEventArgs Class
ProcessDefinitionListEventArgs Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstance Class

[image]

IceLib Technical Reference
ProcessInstance Class
Members See Also Send Feedback
Defines an instance of a process.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessInstance
Visual Basic
Public Class ProcessInstance

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessInstance

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstance Members

[image] [image]

IceLib Technical Reference
ProcessInstance Members
ProcessInstance Class Constructors Methods Properties See Also Send Feedback

The ProcessInstance type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessInstance | Initializes a new instance of the ProcessInstance class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CancelReason | Gets the cancel reason.
Public property | DefinitionId | Gets the identifier of the process definition.
Public property | Description | Gets the description of the process instance.
Public property | DynamicDetails | Gets the dynamic details.
Public property | EndTime | Gets the end time.
Public property | Id | Gets the globally unique identifier of a process instance.
Public property | LaunchingUserDisplayName | Gets the display name of the user that launched this process.
Public property | LaunchName | Gets the name of the launch.
Public property | Name | Gets the name of the process instance.
Public property | NumericId | Gets the numeric identifier for this process instance. The numeric identifier is only unique on a given Interaction Center site.
Public property | StartTime | Gets the start time.
Public property | StateName | Gets the name of the state the process instance is currently in.
Public property | Status | Gets the process instance status.
Public property | Version | Gets the version of the process instance.

See Also

ProcessInstance Class
ININ.IceLib.ProcessAutomation Namespace


ProcessInstance Constructor

[image]

IceLib Technical Reference
ProcessInstance Constructor
ProcessInstance Class See Also Send Feedback
Initializes a new instance of the ProcessInstance class.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessInstance(
    ProcessManager processManager,
    string processInstanceId
)
Visual Basic
Public Sub New ( _
    processManager As ProcessManager, _
    processInstanceId As String _
)

Parameters

processManager
Type: ININ.IceLib.ProcessAutomation..::..ProcessManager
The process manager.
processInstanceId
Type: System..::..String
The process instance identifier.

Remarks

Constructing an instance of ProcessInstance will not automatically populate the object with data about the process instance matching the processInstanceId parameter. To retrieve an existing ProcessInstance, use GetLaunchableProcesses()()()() or its asynchronous equivalent, GetLaunchableProcessesAsync(EventHandler<(Of <<'(AsyncGetLaunchableProcessesCompletedEventArgs>)>>), Object). To create a new ProcessInstance, use CreateInstance(ProcessLaunchParameters).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstance Methods

[image] [image]

IceLib Technical Reference
ProcessInstance Methods
ProcessInstance Class See Also Send Feedback

The ProcessInstance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ProcessInstance Class
ININ.IceLib.ProcessAutomation Namespace


ToString Method

[image]

IceLib Technical Reference
ProcessInstance..::..ToString Method
ProcessInstance Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstance Properties

[image] [image]

IceLib Technical Reference
ProcessInstance Properties
ProcessInstance Class See Also Send Feedback

The ProcessInstance type exposes the following members.

Properties

 | Name | Description
Public property | CancelReason | Gets the cancel reason.
Public property | DefinitionId | Gets the identifier of the process definition.
Public property | Description | Gets the description of the process instance.
Public property | DynamicDetails | Gets the dynamic details.
Public property | EndTime | Gets the end time.
Public property | Id | Gets the globally unique identifier of a process instance.
Public property | LaunchingUserDisplayName | Gets the display name of the user that launched this process.
Public property | LaunchName | Gets the name of the launch.
Public property | Name | Gets the name of the process instance.
Public property | NumericId | Gets the numeric identifier for this process instance. The numeric identifier is only unique on a given Interaction Center site.
Public property | StartTime | Gets the start time.
Public property | StateName | Gets the name of the state the process instance is currently in.
Public property | Status | Gets the process instance status.
Public property | Version | Gets the version of the process instance.

See Also

ProcessInstance Class
ININ.IceLib.ProcessAutomation Namespace


CancelReason Property

[image]

IceLib Technical Reference
ProcessInstance..::..CancelReason Property
ProcessInstance Class See Also Send Feedback
Gets the cancel reason.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CancelReason { get; }
Visual Basic
Public ReadOnly Property CancelReason As String
    Get

Field Value

The cancel reason.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


DefinitionId Property

[image]

IceLib Technical Reference
ProcessInstance..::..DefinitionId Property
ProcessInstance Class See Also Send Feedback
Gets the identifier of the process definition.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefinitionId { get; }
Visual Basic
Public ReadOnly Property DefinitionId As String
    Get

Field Value

The process definition identifier.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


Description Property

[image]

IceLib Technical Reference
ProcessInstance..::..Description Property
ProcessInstance Class See Also Send Feedback
Gets the description of the process instance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Field Value

The process instance description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


DynamicDetails Property

[image]

IceLib Technical Reference
ProcessInstance..::..DynamicDetails Property
ProcessInstance Class See Also Send Feedback
Gets the dynamic details.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DynamicDetails { get; internal set; }
Visual Basic
Public Property DynamicDetails As String
    Get
    Friend Set

Field Value

The dynamic details.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


EndTime Property

[image]

IceLib Technical Reference
ProcessInstance..::..EndTime Property
ProcessInstance Class See Also Send Feedback
Gets the end time.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime EndTime { get; }
Visual Basic
Public ReadOnly Property EndTime As DateTime
    Get

Field Value

The end time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


Id Property

[image]

IceLib Technical Reference
ProcessInstance..::..Id Property
ProcessInstance Class See Also Send Feedback
Gets the globally unique identifier of a process instance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The process instance identifier.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


LaunchingUserDisplayName Property

[image]

IceLib Technical Reference
ProcessInstance..::..LaunchingUserDisplayName Property
ProcessInstance Class See Also Send Feedback
Gets the display name of the user that launched this process.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LaunchingUserDisplayName { get; }
Visual Basic
Public ReadOnly Property LaunchingUserDisplayName As String
    Get

Field Value

The display name of the launching user.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


LaunchName Property

[image]

IceLib Technical Reference
ProcessInstance..::..LaunchName Property
ProcessInstance Class See Also Send Feedback
Gets the name of the launch.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LaunchName { get; }
Visual Basic
Public ReadOnly Property LaunchName As String
    Get

Field Value

The name of the launch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


Name Property

[image]

IceLib Technical Reference
ProcessInstance..::..Name Property
ProcessInstance Class See Also Send Feedback
Gets the name of the process instance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The process instance name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


NumericId Property

[image]

IceLib Technical Reference
ProcessInstance..::..NumericId Property
ProcessInstance Class See Also Send Feedback
Gets the numeric identifier for this process instance. The numeric identifier is only unique on a given Interaction Center site.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long NumericId { get; }
Visual Basic
Public ReadOnly Property NumericId As Long
    Get

Field Value

The numeric identifier.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


StartTime Property

[image]

IceLib Technical Reference
ProcessInstance..::..StartTime Property
ProcessInstance Class See Also Send Feedback
Gets the start time.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime StartTime { get; }
Visual Basic
Public ReadOnly Property StartTime As DateTime
    Get

Field Value

The start time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


StateName Property

[image]

IceLib Technical Reference
ProcessInstance..::..StateName Property
ProcessInstance Class See Also Send Feedback
Gets the name of the state the process instance is currently in.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StateName { get; internal set; }
Visual Basic
Public Property StateName As String
    Get
    Friend Set

Field Value

The name of the state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


Status Property

[image]

IceLib Technical Reference
ProcessInstance..::..Status Property
ProcessInstance Class See Also Send Feedback
Gets the process instance status.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As ProcessStatus
    Get

Field Value

The process instance status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


Version Property

[image]

IceLib Technical Reference
ProcessInstance..::..Version Property
ProcessInstance Class See Also Send Feedback
Gets the version of the process instance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Version { get; }
Visual Basic
Public ReadOnly Property Version As String
    Get

Field Value

The version.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessInstance Class
ProcessInstance Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceCancelData Class

[image]

IceLib Technical Reference
ProcessInstanceCancelData Class
Members See Also Send Feedback
Class that holds data for canceling a process instance.

Note: This class is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessInstanceCancelData
Visual Basic
Public Class ProcessInstanceCancelData

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessInstanceCancelData

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessInstanceCancelData Members
ININ.IceLib.ProcessAutomation Namespace
ProcessManager..::..CancelProcessInstances(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>))
ProcessManager..::..CancelProcessInstancesAsync(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object)


ProcessInstanceCancelData Members

[image] [image]

IceLib Technical Reference
ProcessInstanceCancelData Members
ProcessInstanceCancelData Class Constructors Methods Properties See Also Send Feedback

The ProcessInstanceCancelData type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessInstanceCancelData | Initializes a new instance of the ProcessInstanceCancelData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CancelReason | Gets the cancel reason.
Public property | ProcessInstanceId | Gets a string that represents the process instance ID.

See Also

ProcessInstanceCancelData Class
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceCancelData Constructor

[image]

IceLib Technical Reference
ProcessInstanceCancelData Constructor
ProcessInstanceCancelData Class See Also Send Feedback
Initializes a new instance of the ProcessInstanceCancelData class.

Note: This constructor is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessInstanceCancelData(
    string processInstanceId,
    string cancelReason
)
Visual Basic
Public Sub New ( _
    processInstanceId As String, _
    cancelReason As String _
)

Parameters

processInstanceId
Type: System..::..String
The process instance ID. These process IDs can be found in Id.
cancelReason
Type: System..::..String
The reason the process was canceled.

Exceptions

Exception | Condition
System..::..ArgumentException | The target parameter was invalid.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessInstanceCancelData Class
ProcessInstanceCancelData Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceCancelData Methods

[image] [image]

IceLib Technical Reference
ProcessInstanceCancelData Methods
ProcessInstanceCancelData Class See Also Send Feedback

The ProcessInstanceCancelData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ProcessInstanceCancelData Class
ININ.IceLib.ProcessAutomation Namespace


ToString Method

[image]

IceLib Technical Reference
ProcessInstanceCancelData..::..ToString Method
ProcessInstanceCancelData Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProcessInstanceCancelData Class
ProcessInstanceCancelData Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceCancelData Properties

[image] [image]

IceLib Technical Reference
ProcessInstanceCancelData Properties
ProcessInstanceCancelData Class See Also Send Feedback

The ProcessInstanceCancelData type exposes the following members.

Properties

 | Name | Description
Public property | CancelReason | Gets the cancel reason.
Public property | ProcessInstanceId | Gets a string that represents the process instance ID.

See Also

ProcessInstanceCancelData Class
ININ.IceLib.ProcessAutomation Namespace


CancelReason Property

[image]

IceLib Technical Reference
ProcessInstanceCancelData..::..CancelReason Property
ProcessInstanceCancelData Class See Also Send Feedback
Gets the cancel reason.

Note: This property is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CancelReason { get; }
Visual Basic
Public ReadOnly Property CancelReason As String
    Get

Field Value

The cancel reason.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessInstanceCancelData Class
ProcessInstanceCancelData Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceId Property

[image]

IceLib Technical Reference
ProcessInstanceCancelData..::..ProcessInstanceId Property
ProcessInstanceCancelData Class See Also Send Feedback
Gets a string that represents the process instance ID.

Note: This property is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProcessInstanceId { get; }
Visual Basic
Public ReadOnly Property ProcessInstanceId As String
    Get

Field Value

The process instance.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessInstanceCancelData Class
ProcessInstanceCancelData Members
ININ.IceLib.ProcessAutomation Namespace


ProcessLaunchParameters Class

[image]

IceLib Technical Reference
ProcessLaunchParameters Class
Members See Also Send Feedback
Provides a way to attach data while launching processes.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessLaunchParameters
Visual Basic
Public Class ProcessLaunchParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessLaunchParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessLaunchParameters Members
ININ.IceLib.ProcessAutomation Namespace


ProcessLaunchParameters Members

[image] [image]

IceLib Technical Reference
ProcessLaunchParameters Members
ProcessLaunchParameters Class Constructors Methods Properties See Also Send Feedback

The ProcessLaunchParameters type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessLaunchParameters | Initializes a new instance of the ProcessLaunchParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssociatedInteraction | Gets or sets the associated interaction.
Public property | InputDocument | Gets or sets the input document.
Public property | PasOverloadedAtlaunchOption | Gets or sets the option that describes what action should be taken by Process Automation Server (PAS) if PAS is overloaded at the time of the launch request. The default, if not specified, is to fail the launch request, which is the behavior that happened before Process Automation Server (PAS) had the ability to queue launch requests.

See Also

ProcessLaunchParameters Class
ININ.IceLib.ProcessAutomation Namespace


ProcessLaunchParameters Constructor

[image]

IceLib Technical Reference
ProcessLaunchParameters Constructor
ProcessLaunchParameters Class See Also Send Feedback
Initializes a new instance of the ProcessLaunchParameters class

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessLaunchParameters()
Visual Basic
Public Sub New

See Also

ProcessLaunchParameters Class
ProcessLaunchParameters Members
ININ.IceLib.ProcessAutomation Namespace


ProcessLaunchParameters Methods

[image] [image]

IceLib Technical Reference
ProcessLaunchParameters Methods
ProcessLaunchParameters Class See Also Send Feedback

The ProcessLaunchParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessLaunchParameters Class
ININ.IceLib.ProcessAutomation Namespace


ProcessLaunchParameters Properties

[image] [image]

IceLib Technical Reference
ProcessLaunchParameters Properties
ProcessLaunchParameters Class See Also Send Feedback

The ProcessLaunchParameters type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedInteraction | Gets or sets the associated interaction.
Public property | InputDocument | Gets or sets the input document.
Public property | PasOverloadedAtlaunchOption | Gets or sets the option that describes what action should be taken by Process Automation Server (PAS) if PAS is overloaded at the time of the launch request. The default, if not specified, is to fail the launch request, which is the behavior that happened before Process Automation Server (PAS) had the ability to queue launch requests.

See Also

ProcessLaunchParameters Class
ININ.IceLib.ProcessAutomation Namespace


AssociatedInteraction Property

[image]

IceLib Technical Reference
ProcessLaunchParameters..::..AssociatedInteraction Property
ProcessLaunchParameters Class See Also Send Feedback
Gets or sets the associated interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId AssociatedInteraction { get; set; }
Visual Basic
Public Property AssociatedInteraction As InteractionId
    Get
    Set

Field Value

The associated interaction.

Remarks

The associated interaction will be shown when viewing details of this process from the Process Monitor or the Interaction Client.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessLaunchParameters Class
ProcessLaunchParameters Members
ININ.IceLib.ProcessAutomation Namespace


InputDocument Property

[image]

IceLib Technical Reference
ProcessLaunchParameters..::..InputDocument Property
ProcessLaunchParameters Class Example See Also Send Feedback
Gets or sets the input document.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public XmlDocument InputDocument { get; set; }
Visual Basic
Public Property InputDocument As XmlDocument
    Get
    Set

Field Value

The input document.

Remarks

Use the input document to specify the initial values of process input variables. Only variables you have added to a process under variables can be set.

For process input variables that are collections you can specify the element name multiple times as shown above. A collection input variable cannot be NOT_SET. The values in a collection can be NOT_SET.

Interaction Process Automation supports the concept of NOT_SET, which means the process variable does not have a value. To specify NOT_SET in the XML document, add xsi:nil="true" as an attribute of the element name. No element text should be specified. For example: <ExampleUser xsi:nil="true"/>

The following is a list of supported data types in Interaction Process Automation along with information about how to specify the value for each data type as a string to conform with XML data type standards.

  • Boolean - A boolean can be any of the following values: true, false, 1, 0
  • Date - A date must be in the following format: YYYY-MM-DD[Z|(+|-)hh:mm] where YYYY = 4 digit year, MM = 2 digit month, DD = 2 digit day, hh = 2 digit hour offset and mm = 2 digit minute offset. YYYY-MM-DD represents the year, month and day portion of the date. [Z|(+|-)hh:mm] represents the offset of the date from universal coordinated time. If no offset is specified the timezone for this date will be set to the timezone of the IC server. Otherwise the offset will be applied and the timezone will be changed to universal coordinated time. The date must be between 1800-1-1 and 2200-12-31. For example: 2001-10-26, 2001-10-26+02:00, 2001-10-26Z, 2001-10-26+00:00
  • DateTime - A datetime must be in the following format: YYYY-MM-DDThh:mm:ss[Z|(+|-)hh:mm] where YYYY = 4 digit year, MM = 2 digit month, DD = 2 digit day, hh = 2 digit hour, mm = 2 digit minute and ss = 2 digit second. YYYY-MM-DDThh:mm:ss represents the year, month, day, hour, minute and second portion of the date time. T is a separator indicating where the time portion starts. [Z|(+|-)hh:mm] represents the offset of the date time from universal coordinated time. If no offset is specified the timezone for this datetime will be set to the timezone of the IC server. Otherwise the offset will be applied and the timezone will be changed to universal coordinated time The date time must be between 1800-1-1T00:00:00 and 2200-12-31T23:59:59 For example: 2001-10-26T21:32:52, 2001-10-26T21:32:52+02:00, 2001-10-26T19:32:52Z, 2001-10-26T19:32:52+00:00, or 2001-10-26T21:32:52.12679
  • Decimal - A decimal must have a value consisting of a mantissa followed, optionally, by the character "E" or "e", followed by an exponent. The exponent must be an integer. The mantissa must be a decimal number. The representations for exponent and mantissa must follow the rules for integer and decimal. If the "E" or "e" and the following exponent are omitted, an exponent value of 0 is assumed. The value space of a decimal consists of the values m × 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive. For example: 6.2, -1E4, 1267.43233E12, 12.78e-2, 12, and 0 are all legal values for a decimal.
  • Duration - A duration must be in the following format: "(-)PnDTnHnMnS" where P indicates the period, nD the number of days, T indicates the start of the time section, nH the number of hours, nM the number of minutes and nS the number of seconds. Numeric components in the string like 'nD' that represent the number of days will not be returned if n equals 0. The minus sign will be present if the duration is negative. Note: nS may include fractional seconds. For example: PT1004199059S, PT130S, PT2M10S, P1DT2S, or P3DT5H20M30.123S
  • Integer - An integer must be a number between 9223372036854775807 and -9223372036854775808 inclusive. For example: -1, 0, 12678967543233, 100000
  • Mailbox - A mailbox must contain two parts. The part before the @ sign is the local-part of the address, often the username of the recipient (jsmith), and the part after the @ sign is the domain which is a hostname to which the e-mail message will be sent (example.com). For example: Info@ININ.com, jsmith@example.com
  • Skill - A skill is a string that matches an existing skill name in Interaction Administrator. For example: Spanish, English
  • String - A string is a finite-length sequence of characters. For example: Hello World!
  • Time - A time must be in the following format: hh:mm:ss[Z|(+|-)hh:mm] where hh = 2 digit hour, mm = 2 digit minute and ss = 2 digit second. hh:mm:ss represents the hour, minute and second portion of the time. [Z|(+|-)hh:mm] represents the offset of the time from universal coordinated time. If no offset is specified the timezone for this datetime will be set to the timezone of the IC server. Otherwise the offset will be applied and the timezone will be changed to universal coordinated time. For example: 21:32:52, 21:32:52+02:00, 19:32:52Z, 19:32:52+00:00, and 21:32:52.12679.
  • User - A user is a string that matches an existing user name in Interaction Administrator. For example: admin
  • Workgroup - A workgroup is a string that matches an existing workgroup name in Interaction Administrator. For example: Support

Examples

CopyC#
static XmlDocument CreateInputXmlDocument()
{
   // Create a new XmlDocument to pass as the initial values for IPA process input variables
   XmlDocument xmldoc = new XmlDocument();

   // Creates the XML declaration
   XmlNode xmlnode = xmldoc.CreateNode(XmlNodeType.XmlDeclaration, "", "");
   xmldoc.AppendChild(xmlnode);

   // The root element of all process input XML documents is "Process"
   XmlElement xmlelement = xmldoc.CreateElement("Process");
   xmlelement.SetAttribute("xmlns:xsi", "http://www.w3.org/2001/XMLSchema-instance");

   // Add an element for each process input variable that should be set when the process starts.
   // You can set a process variable as an input in Interaction Process Automation
   // by changing the assessibility parameter of the variable to "Input."
   // Variables are set to Private by default. The accessibility should be changed to "Input" or "Input/Output" as needed.
   // If a variable is defined in the Xml, but still has an accessibility of Private the process will fail to launch.
   // The name of the element needs to match the variable name in Interaction Process
   // Automation exactly.
   AddXmlElement(xmldoc, xmlelement, "ExampleBoolean", "true");
   AddXmlElement(xmldoc, xmlelement, "ExampleDate", "2002-09-24");
   AddXmlElement(xmldoc, xmlelement, "ExampleDateTime", "2002-05-30T09:00:00");
   AddXmlElement(xmldoc, xmlelement, "ExampleDecimal", "127.00");
   AddXmlElement(xmldoc, xmlelement, "ExampleDuration", "P5DT15H");
   AddXmlElement(xmldoc, xmlelement, "ExampleInteger", "72");
   AddXmlElement(xmldoc, xmlelement, "ExampleMailbox", "Info@ININ.com");
   AddXmlElement(xmldoc, xmlelement, "ExampleSkill", "Spanish");
   AddXmlElement(xmldoc, xmlelement, "ExampleString", "Hello World!");
   AddXmlElement(xmldoc, xmlelement, "ExampleTime", "09:30:10");
   AddXmlElement(xmldoc, xmlelement, "ExampleUser", "admin");
   AddXmlElement(xmldoc, xmlelement, "ExampleWorkgroup", "Support");
   AddXmlElement(xmldoc, xmlelement, "ExampleStringCollection", "Red");
   AddXmlElement(xmldoc, xmlelement, "ExampleStringCollection", "Green");
   AddXmlElement(xmldoc, xmlelement, "ExampleStringCollection", "Blue");

   xmldoc.AppendChild(xmlelement);

   return xmldoc;
}

public static void AddXmlElement(XmlDocument doc, XmlElement parent, string name, string value)
{
   if (string.IsNullOrEmpty(value)) return;

   XmlElement element = doc.CreateElement(name);
   element.AppendChild(doc.CreateTextNode(value));
   parent.AppendChild(element);
}

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessLaunchParameters Class
ProcessLaunchParameters Members
ININ.IceLib.ProcessAutomation Namespace


PasOverloadedAtlaunchOption Property

[image]

IceLib Technical Reference
ProcessLaunchParameters..::..PasOverloadedAtlaunchOption Property
ProcessLaunchParameters Class See Also Send Feedback
Gets or sets the option that describes what action should be taken by Process Automation Server (PAS) if PAS is overloaded at the time of the launch request. The default, if not specified, is to fail the launch request, which is the behavior that happened before Process Automation Server (PAS) had the ability to queue launch requests.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PasOverloadedAtLaunchOption PasOverloadedAtlaunchOption { get; set; }
Visual Basic
Public Property PasOverloadedAtlaunchOption As PasOverloadedAtLaunchOption
    Get
    Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 6 and beyond.
For 3.0, supported for IC Server version 3.0 SU 19 and beyond.

See Also

ProcessLaunchParameters Class
ProcessLaunchParameters Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager Class

[image]

IceLib Technical Reference
ProcessManager Class
Members See Also Send Feedback
Provides access to all process automation classes in the ININ.IceLib.ProcessAutomation namespace.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessManager
Visual Basic
Public Class ProcessManager

Remarks

This class serves as the initial entry point into the ININ.IceLib.ProcessAutomation namespace. It contains references to all watched objects and watched attribute caches. All classes in the ININ.IceLib.ProcessAutomation namespace send and receive messages to/from the IC system via the Session object of the ProcessManager.

Note
The ProcessManager class is a singleton object and is accessed using the GetInstance(Session) method.

Examples

CopyC#
Session session = new Session();
session.Connect(...);
ProcessManager manager = ProcessManager.GetInstance(session);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager Members

[image] [image]

IceLib Technical Reference
ProcessManager Members
ProcessManager Class Methods Properties Events See Also Send Feedback

The ProcessManager type exposes the following members.

Methods

 | Name | Description
Public method | CancelProcessInstances(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>)) | Cancels the running process instances specified by the list of ProcessInstanceCancelData.
Public method | CancelProcessInstances(ICollection<(Of <<'(Int64>)>>), ICollection<(Of <<'(String>)>>)) | Obsolete. Cancels process instances specified by the list of numeric IDs.
Public method | CancelProcessInstancesAsync(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object) | Asynchronously cancels the running process instances specified by the list of ProcessInstanceCancelData.
Public method | CancelProcessInstancesAsync(ICollection<(Of <<'(Int64>)>>), ICollection<(Of <<'(String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object) | Obsolete. Asynchronously cancels process instances specified by the list of numeric IDs.
Public method | CheckForRunningProcess | Checks to see if the specified process is already running.
Public method | CheckForRunningProcessAsync | Asynchronously checks to see if the specified process is already running.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a ProcessManager.
Public method | GetLaunchableProcesses | Gets the list of launchable processes for the currently logged in user.
Public method | GetLaunchableProcessesAsync | Asynchronously gets the list of launchable processes for the currently logged in user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LaunchProcessByName | Launches a process specified by Name.
Public method | LaunchProcessByNameAsync | Asynchronously launches a process specified by Name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatchingLaunchableProcesses | Sends a request to the server to watch the list of launchable processes for the currently logged in user.
Public method | StartWatchingLaunchableProcessesAsync | Asynchronously sends a request to the server to watch the list of launchable processes for the currently logged in user.
Public method | StopWatchingLaunchableProcesses | Sends a request to the server to stop watching the list of launchable processes for the currently logged in user.
Public method | StopWatchingLaunchableProcessesAsync | Asynchronously sends a request to the server to stop watching the list of launchable processes for the currently logged in user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPASv2 | Specifies if the server is running PASv1 or PASv2.
Public property | LaunchableProcesses | Gets the cached list of launchable processes.
Public property | Session | Gets the Session with which this ProcessManager is associated.

Events

 | Name | Description
Public event | LaunchableProcessesChanged | Raised when existing launchable processes for the logged in user are updated.

See Also

ProcessManager Class
ININ.IceLib.ProcessAutomation Namespace


ProcessManager Methods

[image] [image]

IceLib Technical Reference
ProcessManager Methods
ProcessManager Class See Also Send Feedback

The ProcessManager type exposes the following members.

Methods

 | Name | Description
Public method | CancelProcessInstances(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>)) | Cancels the running process instances specified by the list of ProcessInstanceCancelData.
Public method | CancelProcessInstances(ICollection<(Of <<'(Int64>)>>), ICollection<(Of <<'(String>)>>)) | Obsolete. Cancels process instances specified by the list of numeric IDs.
Public method | CancelProcessInstancesAsync(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object) | Asynchronously cancels the running process instances specified by the list of ProcessInstanceCancelData.
Public method | CancelProcessInstancesAsync(ICollection<(Of <<'(Int64>)>>), ICollection<(Of <<'(String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object) | Obsolete. Asynchronously cancels process instances specified by the list of numeric IDs.
Public method | CheckForRunningProcess | Checks to see if the specified process is already running.
Public method | CheckForRunningProcessAsync | Asynchronously checks to see if the specified process is already running.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a ProcessManager.
Public method | GetLaunchableProcesses | Gets the list of launchable processes for the currently logged in user.
Public method | GetLaunchableProcessesAsync | Asynchronously gets the list of launchable processes for the currently logged in user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LaunchProcessByName | Launches a process specified by Name.
Public method | LaunchProcessByNameAsync | Asynchronously launches a process specified by Name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatchingLaunchableProcesses | Sends a request to the server to watch the list of launchable processes for the currently logged in user.
Public method | StartWatchingLaunchableProcessesAsync | Asynchronously sends a request to the server to watch the list of launchable processes for the currently logged in user.
Public method | StopWatchingLaunchableProcesses | Sends a request to the server to stop watching the list of launchable processes for the currently logged in user.
Public method | StopWatchingLaunchableProcessesAsync | Asynchronously sends a request to the server to stop watching the list of launchable processes for the currently logged in user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessManager Class
ININ.IceLib.ProcessAutomation Namespace


CancelProcessInstances Method

[image] [image]

IceLib Technical Reference
ProcessManager..::..CancelProcessInstances Method
ProcessManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CancelProcessInstances(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>)) | Cancels the running process instances specified by the list of ProcessInstanceCancelData.
Public method | CancelProcessInstances(ICollection<(Of <<'(Int64>)>>), ICollection<(Of <<'(String>)>>)) | Obsolete. Cancels process instances specified by the list of numeric IDs.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


CancelProcessInstances Method (IEnumerable(ProcessInstanceCancelData))

[image]

IceLib Technical Reference
ProcessManager..::..CancelProcessInstances Method (IEnumerable<(Of <(<'ProcessInstanceCancelData>)>)>)
ProcessManager Class See Also Send Feedback
Cancels the running process instances specified by the list of ProcessInstanceCancelData.

Note: This method is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessManager..::..CancelResults> CancelProcessInstances(
    IEnumerable<ProcessInstanceCancelData> cancelData
)
Visual Basic
Public Function CancelProcessInstances ( _
    cancelData As IEnumerable(Of ProcessInstanceCancelData) _
) As ReadOnlyCollection(Of ProcessManager..::..CancelResults)

Parameters

cancelData
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ProcessInstanceCancelData >)>)>
The process defined by ProcessInstanceCancelData.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ProcessManager..::..CancelResults objects.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessManager Class
ProcessManager Members
CancelProcessInstances Overload
ININ.IceLib.ProcessAutomation Namespace


CancelProcessInstances Method (ICollection(Int64), ICollection(String))

[image]

IceLib Technical Reference
ProcessManager..::..CancelProcessInstances Method (ICollection<(Of <(<'Int64>)>)>, ICollection<(Of <(<'String>)>)>)
ProcessManager Class See Also Send Feedback
Cancels process instances specified by the list of numeric IDs.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("This method has been deprecated, use the overload that uses an IEnumerable<ProcessInstanceCancelData> instead.")]
public ReadOnlyCollection<ProcessManager..::..CancelResults> CancelProcessInstances(
    ICollection<long> numericIds,
    ICollection<string> cancelReasons
)
Visual Basic
<ObsoleteAttribute("This method has been deprecated, use the overload that uses an IEnumerable<ProcessInstanceCancelData> instead.")> _
Public Function CancelProcessInstances ( _
    numericIds As ICollection(Of Long), _
    cancelReasons As ICollection(Of String) _
) As ReadOnlyCollection(Of ProcessManager..::..CancelResults)

Parameters

numericIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'Int64>)>)>
The process definition numeric IDs. These numeric IDs can be found in NumericId.
cancelReasons
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The reasons the processes were canceled.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of ProcessManager..::..CancelResults objects.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | A parameter did not have did not contain the right number of elements.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessManager Class
ProcessManager Members
CancelProcessInstances Overload
ININ.IceLib.ProcessAutomation Namespace


CancelProcessInstancesAsync Method

[image] [image]

IceLib Technical Reference
ProcessManager..::..CancelProcessInstancesAsync Method
ProcessManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CancelProcessInstancesAsync(IEnumerable<(Of <<'(ProcessInstanceCancelData>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object) | Asynchronously cancels the running process instances specified by the list of ProcessInstanceCancelData.
Public method | CancelProcessInstancesAsync(ICollection<(Of <<'(Int64>)>>), ICollection<(Of <<'(String>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(ReadOnlyCollection<(Of <<'(ProcessManager..::..CancelResults>)>>)>)>>)>)>>), Object) | Obsolete. Asynchronously cancels process instances specified by the list of numeric IDs.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


CancelProcessInstancesAsync Method (IEnumerable(ProcessInstanceCancelData), EventHandler(AsyncCompletedEventArgs(ReadOnlyCollection(ProcessManager.CancelResults))), Object)

[image]

IceLib Technical Reference
ProcessManager..::..CancelProcessInstancesAsync Method (IEnumerable<(Of <(<'ProcessInstanceCancelData>)>)>, EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'ReadOnlyCollection<(Of <(<'ProcessManager..::..CancelResults>)>)>>)>)>>)>)>, Object)
ProcessManager Class See Also Send Feedback
Asynchronously cancels the running process instances specified by the list of ProcessInstanceCancelData.

Note: This method is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelProcessInstancesAsync(
    IEnumerable<ProcessInstanceCancelData> cancelData,
    EventHandler<AsyncCompletedEventArgs<ReadOnlyCollection<ProcessManager..::..CancelResults>>> completedCallback,
    Object userState
)
Visual Basic
Public Sub CancelProcessInstancesAsync ( _
    cancelData As IEnumerable(Of ProcessInstanceCancelData), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of ReadOnlyCollection(Of ProcessManager..::..CancelResults))), _
    userState As Object _
)

Parameters

cancelData
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ProcessInstanceCancelData >)>)>
The process defined by ProcessInstanceCancelData.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncCompletedEventArgs <(Of <(<'ReadOnlyCollection<(Of <(<' ProcessManager..::..CancelResults >)>)>>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The target parameter was invalid.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessManager Class
ProcessManager Members
CancelProcessInstancesAsync Overload
ININ.IceLib.ProcessAutomation Namespace


CancelProcessInstancesAsync Method (ICollection(Int64), ICollection(String), EventHandler(AsyncCompletedEventArgs(ReadOnlyCollection(ProcessManager.CancelResults))), Object)

[image]

IceLib Technical Reference
ProcessManager..::..CancelProcessInstancesAsync Method (ICollection<(Of <(<'Int64>)>)>, ICollection<(Of <(<'String>)>)>, EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'ReadOnlyCollection<(Of <(<'ProcessManager..::..CancelResults>)>)>>)>)>>)>)>, Object)
ProcessManager Class See Also Send Feedback
Asynchronously cancels process instances specified by the list of numeric IDs.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("This method has been deprecated, use the overload that uses an IEnumerable<ProcessInstanceCancelData> instead.")]
public void CancelProcessInstancesAsync(
    ICollection<long> numericIds,
    ICollection<string> cancelReasons,
    EventHandler<AsyncCompletedEventArgs<ReadOnlyCollection<ProcessManager..::..CancelResults>>> completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("This method has been deprecated, use the overload that uses an IEnumerable<ProcessInstanceCancelData> instead.")> _
Public Sub CancelProcessInstancesAsync ( _
    numericIds As ICollection(Of Long), _
    cancelReasons As ICollection(Of String), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of ReadOnlyCollection(Of ProcessManager..::..CancelResults))), _
    userState As Object _
)

Parameters

numericIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'Int64>)>)>
The process definition numeric IDs. These numeric IDs can be found in NumericId.
cancelReasons
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The reasons the processes were canceled.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncCompletedEventArgs <(Of <(<'ReadOnlyCollection<(Of <(<' ProcessManager..::..CancelResults >)>)>>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | A parameter did not have did not contain the right number of elements.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessManager Class
ProcessManager Members
CancelProcessInstancesAsync Overload
ININ.IceLib.ProcessAutomation Namespace


CheckForRunningProcess Method

[image]

IceLib Technical Reference
ProcessManager..::..CheckForRunningProcess Method
ProcessManager Class See Also Send Feedback
Checks to see if the specified process is already running.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CheckForRunningProcess(
    string processDefinitionId
)
Visual Basic
Public Function CheckForRunningProcess ( _
    processDefinitionId As String _
) As Boolean

Parameters

processDefinitionId
Type: System..::..String
The process definition ID. (See Id.)

Return Value

true if specified process is already running; othwerwise false.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.
For 3.0, supported for IC Server version 3.0 SU 15 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


CheckForRunningProcessAsync Method

[image]

IceLib Technical Reference
ProcessManager..::..CheckForRunningProcessAsync Method
ProcessManager Class See Also Send Feedback
Asynchronously checks to see if the specified process is already running.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CheckForRunningProcessAsync(
    string processDefinitionId,
    EventHandler<AsyncCompletedEventArgs<bool>> completedCallback,
    Object userState
)
Visual Basic
Public Sub CheckForRunningProcessAsync ( _
    processDefinitionId As String, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

processDefinitionId
Type: System..::..String
The process definition ID. (See Id.)
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncCompletedEventArgs <(Of <(<'Boolean>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.
For 3.0, supported for IC Server version 3.0 SU 15 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


GetInstance Method

[image]

IceLib Technical Reference
ProcessManager..::..GetInstance Method
ProcessManager Class See Also Send Feedback
Gets a ProcessManager.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ProcessManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As ProcessManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The ProcessManager object.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


GetLaunchableProcesses Method

[image]

IceLib Technical Reference
ProcessManager..::..GetLaunchableProcesses Method
ProcessManager Class See Also Send Feedback
Gets the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> GetLaunchableProcesses()
Visual Basic
Public Function GetLaunchableProcesses As ReadOnlyCollection(Of ProcessDefinition)

Return Value

The launchable processes.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


GetLaunchableProcessesAsync Method

[image]

IceLib Technical Reference
ProcessManager..::..GetLaunchableProcessesAsync Method
ProcessManager Class See Also Send Feedback
Asynchronously gets the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetLaunchableProcessesAsync(
    EventHandler<AsyncGetLaunchableProcessesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetLaunchableProcessesAsync ( _
    completedCallback As EventHandler(Of AsyncGetLaunchableProcessesCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncGetLaunchableProcessesCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


LaunchProcessByName Method

[image]

IceLib Technical Reference
ProcessManager..::..LaunchProcessByName Method
ProcessManager Class Example See Also Send Feedback
Launches a process specified by Name.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ProcessInstance LaunchProcessByName(
    string processName,
    ProcessLaunchParameters launchParameters
)
Visual Basic
Public Function LaunchProcessByName ( _
    processName As String, _
    launchParameters As ProcessLaunchParameters _
) As ProcessInstance

Parameters

processName
Type: System..::..String
The process Name.
launchParameters
Type: ININ.IceLib.ProcessAutomation..::..ProcessLaunchParameters
The parameters needs to be set while launching the process.

Return Value

The created Process Instance.

Remarks

NOTE: See the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses for this method.

The name of the process needs to exactly match the name given to the process by the process designer.

Ensure the process is published in Interaction Process Automation and ensure that the launching user has "Launch Process" access control rights in Interaction Administrator, otherwise the launch will fail.

Examples

The following code can be used to connect to the IC server, connect as the specified user, and launch a process with a set of initial data.
CopyC#
Session session = new Session();
session.Connect(...);
ProcessManager wfManager = ProcessManager.GetInstance(session);
ProcessLaunchParameters parameters = new ProcessLaunchParameters();

// This creates an XmlDocument to be passed into the launch as the initial values
// for process input variables.  See the documentation for InputDocument for the example
// code for CreateInputXmlDocument().
parameters.InputDocument = CreateInputXmlDocument();
try
{
    ProcessInstance instance = wfManager.LaunchProcessByName("Sample Process Launch", parameters);
    if (instance != null)
    {
        Console.WriteLine("Process started Id: " + instance.NumericId);
    }
    else
    {
        Console.WriteLine("Failed to start process. LaunchProcessByName returned a null instance.");
    }
}
catch (Exception exception)
{
   Console.WriteLine("Caught an exception while starting the process: " + exception.Message);
}

Exceptions

Exception | Condition
System..::..ArgumentException | An argument was invalid.
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


LaunchProcessByNameAsync Method

[image]

IceLib Technical Reference
ProcessManager..::..LaunchProcessByNameAsync Method
ProcessManager Class See Also Send Feedback
Asynchronously launches a process specified by Name.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void LaunchProcessByNameAsync(
    string processName,
    ProcessLaunchParameters launchParameters,
    EventHandler<AsyncCompletedEventArgs<ProcessInstance>> completedCallback,
    Object userState
)
Visual Basic
Public Sub LaunchProcessByNameAsync ( _
    processName As String, _
    launchParameters As ProcessLaunchParameters, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of ProcessInstance)), _
    userState As Object _
)

Parameters

processName
Type: System..::..String
The process Name.
launchParameters
Type: ININ.IceLib.ProcessAutomation..::..ProcessLaunchParameters
The parameters needs to be set while launching the process.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncCompletedEventArgs <(Of <(<' ProcessInstance >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

NOTE: See the ININ.IceLib.ProcessAutomation namespace documentation for additional details on the required licenses for this method.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


StartWatchingLaunchableProcesses Method

[image]

IceLib Technical Reference
ProcessManager..::..StartWatchingLaunchableProcesses Method
ProcessManager Class See Also Send Feedback
Sends a request to the server to watch the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingLaunchableProcesses()
Visual Basic
Public Sub StartWatchingLaunchableProcesses

Remarks

When this method completes, it will raise the event LaunchableProcessesChanged. Note that an event handler needs to be set for LaunchableProcessesChanged before calling this method.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


StartWatchingLaunchableProcessesAsync Method

[image]

IceLib Technical Reference
ProcessManager..::..StartWatchingLaunchableProcessesAsync Method
ProcessManager Class See Also Send Feedback
Asynchronously sends a request to the server to watch the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingLaunchableProcessesAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingLaunchableProcessesAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


StopWatchingLaunchableProcesses Method

[image]

IceLib Technical Reference
ProcessManager..::..StopWatchingLaunchableProcesses Method
ProcessManager Class See Also Send Feedback
Sends a request to the server to stop watching the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingLaunchableProcesses()
Visual Basic
Public Sub StopWatchingLaunchableProcesses

Remarks

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


StopWatchingLaunchableProcessesAsync Method

[image]

IceLib Technical Reference
ProcessManager..::..StopWatchingLaunchableProcessesAsync Method
ProcessManager Class See Also Send Feedback
Asynchronously sends a request to the server to stop watching the list of launchable processes for the currently logged in user.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingLaunchableProcessesAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingLaunchableProcessesAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager Properties

[image] [image]

IceLib Technical Reference
ProcessManager Properties
ProcessManager Class See Also Send Feedback

The ProcessManager type exposes the following members.

Properties

 | Name | Description
Public property | IsPASv2 | Specifies if the server is running PASv1 or PASv2.
Public property | LaunchableProcesses | Gets the cached list of launchable processes.
Public property | Session | Gets the Session with which this ProcessManager is associated.

See Also

ProcessManager Class
ININ.IceLib.ProcessAutomation Namespace


IsPASv2 Property

[image]

IceLib Technical Reference
ProcessManager..::..IsPASv2 Property
ProcessManager Class See Also Send Feedback
Specifies if the server is running PASv1 or PASv2.

Note: This property is supported for IC Server version 2015 R3 and beyond.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsPASv2 { get; }
Visual Basic
Public ReadOnly Property IsPASv2 As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if running PASV2; otherwise falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R3 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


LaunchableProcesses Property

[image]

IceLib Technical Reference
ProcessManager..::..LaunchableProcesses Property
ProcessManager Class See Also Send Feedback
Gets the cached list of launchable processes.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ProcessDefinition> LaunchableProcesses { get; }
Visual Basic
Public ReadOnly Property LaunchableProcesses As ReadOnlyCollection(Of ProcessDefinition)
    Get

Field Value

The launchable processes.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | A StartWatchingLaunchableProcesses()()()() has not been called / it has been called, but not completed yet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


Session Property

[image]

IceLib Technical Reference
ProcessManager..::..Session Property
ProcessManager Class See Also Send Feedback
Gets the Session with which this ProcessManager is associated.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager Events

[image] [image]

IceLib Technical Reference
ProcessManager Events
ProcessManager Class See Also Send Feedback

The ProcessManager type exposes the following members.

Events

 | Name | Description
Public event | LaunchableProcessesChanged | Raised when existing launchable processes for the logged in user are updated.

See Also

ProcessManager Class
ININ.IceLib.ProcessAutomation Namespace


LaunchableProcessesChanged Event

[image]

IceLib Technical Reference
ProcessManager..::..LaunchableProcessesChanged Event
ProcessManager Class See Also Send Feedback
Raised when existing launchable processes for the logged in user are updated.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<LaunchableProcessesEventArgs> LaunchableProcessesChanged
Visual Basic
Public Event LaunchableProcessesChanged As EventHandler(Of LaunchableProcessesEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessManager Class
ProcessManager Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager.CancelResults Class

[image]

IceLib Technical Reference
ProcessManager..::..CancelResults Class
ProcessManager Class Members See Also Send Feedback
The result code of a cancel process attempt.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CancelResults
Visual Basic
Public Class CancelResults

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessManager..::..CancelResults

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessManager..::..CancelResults Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager.CancelResults Members

[image] [image]

IceLib Technical Reference
ProcessManager..::..CancelResults Members
ProcessManager..::..CancelResults Class Constructors Methods Properties See Also Send Feedback

The ProcessManager..::..CancelResults type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessManager..::..CancelResults | Initializes a new instance of the ProcessManager..::..CancelResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorString | Gets the error string if an error occurs.
Public property | Success | Gets the value indicating whether this result is a success.

See Also

ProcessManager..::..CancelResults Class
ININ.IceLib.ProcessAutomation Namespace


ProcessManager.CancelResults Constructor

[image]

IceLib Technical Reference
ProcessManager..::..CancelResults Constructor
ProcessManager..::..CancelResults Class See Also Send Feedback
Initializes a new instance of the ProcessManager..::..CancelResults class

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CancelResults()
Visual Basic
Public Sub New

See Also

ProcessManager..::..CancelResults Class
ProcessManager..::..CancelResults Members
ININ.IceLib.ProcessAutomation Namespace


ProcessManager.CancelResults Methods

[image] [image]

IceLib Technical Reference
ProcessManager..::..CancelResults Methods
ProcessManager..::..CancelResults Class See Also Send Feedback

The ProcessManager..::..CancelResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessManager..::..CancelResults Class
ININ.IceLib.ProcessAutomation Namespace


ProcessManager.CancelResults Properties

[image] [image]

IceLib Technical Reference
ProcessManager..::..CancelResults Properties
ProcessManager..::..CancelResults Class See Also Send Feedback

The ProcessManager..::..CancelResults type exposes the following members.

Properties

 | Name | Description
Public property | ErrorString | Gets the error string if an error occurs.
Public property | Success | Gets the value indicating whether this result is a success.

See Also

ProcessManager..::..CancelResults Class
ININ.IceLib.ProcessAutomation Namespace


ErrorString Property

[image]

IceLib Technical Reference
ProcessManager..::..CancelResults..::..ErrorString Property
ProcessManager..::..CancelResults Class See Also Send Feedback
Gets the error string if an error occurs.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ErrorString { get; internal set; }
Visual Basic
Public Property ErrorString As String
    Get
    Friend Set

Field Value

The error string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessManager..::..CancelResults Class
ProcessManager..::..CancelResults Members
ININ.IceLib.ProcessAutomation Namespace


Success Property

[image]

IceLib Technical Reference
ProcessManager..::..CancelResults..::..Success Property
ProcessManager..::..CancelResults Class See Also Send Feedback
Gets the value indicating whether this result is a success.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Success { get; internal set; }
Visual Basic
Public Property Success As Boolean
    Get
    Friend Set

Field Value

true if success; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

ProcessManager..::..CancelResults Class
ProcessManager..::..CancelResults Members
ININ.IceLib.ProcessAutomation Namespace


ProcessStatus Class

[image]

IceLib Technical Reference
ProcessStatus Class
Members See Also Send Feedback
Represents the current status of ProcessInstance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ProcessStatus
Visual Basic
Public Class ProcessStatus

Inheritance Hierarchy

System..::..Object
ININ.IceLib.ProcessAutomation..::..ProcessStatus

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessStatus Members
ININ.IceLib.ProcessAutomation Namespace


ProcessStatus Members

[image] [image]

IceLib Technical Reference
ProcessStatus Members
ProcessStatus Class Methods Properties See Also Send Feedback

The ProcessStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Description | Gets the status description of ProcessInstance.
Public property | Id | Gets the status ID.
Public property | Name | Gets the status name of ProcessInstance.

See Also

ProcessStatus Class
ININ.IceLib.ProcessAutomation Namespace


ProcessStatus Methods

[image] [image]

IceLib Technical Reference
ProcessStatus Methods
ProcessStatus Class See Also Send Feedback

The ProcessStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ProcessStatus Class
ININ.IceLib.ProcessAutomation Namespace


ToString Method

[image]

IceLib Technical Reference
ProcessStatus..::..ToString Method
ProcessStatus Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ProcessStatus Class
ProcessStatus Members
ININ.IceLib.ProcessAutomation Namespace


ProcessStatus Properties

[image] [image]

IceLib Technical Reference
ProcessStatus Properties
ProcessStatus Class See Also Send Feedback

The ProcessStatus type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the status description of ProcessInstance.
Public property | Id | Gets the status ID.
Public property | Name | Gets the status name of ProcessInstance.

See Also

ProcessStatus Class
ININ.IceLib.ProcessAutomation Namespace


Description Property

[image]

IceLib Technical Reference
ProcessStatus..::..Description Property
ProcessStatus Class See Also Send Feedback
Gets the status description of ProcessInstance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

Return Value

The flow status description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessStatus Class
ProcessStatus Members
ININ.IceLib.ProcessAutomation Namespace


Id Property

[image]

IceLib Technical Reference
ProcessStatus..::..Id Property
ProcessStatus Class See Also Send Feedback
Gets the status ID.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FlowStatus Id { get; }
Visual Basic
Public ReadOnly Property Id As FlowStatus
    Get

Return Value

The flow status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessStatus Class
ProcessStatus Members
ININ.IceLib.ProcessAutomation Namespace


Name Property

[image]

IceLib Technical Reference
ProcessStatus..::..Name Property
ProcessStatus Class See Also Send Feedback
Gets the status name of ProcessInstance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Return Value

The flow status name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ProcessStatus Class
ProcessStatus Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Class

[image]

IceLib Technical Reference
WorkItemInteraction Class
Members See Also Send Feedback
Represents a work item interaction within the Interaction Center system.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkItemInteraction : Interaction
Visual Basic
Public Class WorkItemInteraction _
    Inherits Interaction

Remarks

Actions that require user input are executed by placing Work Item interactions on a user queue.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.ProcessAutomation..::..WorkItemInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Members

[image] [image]

IceLib Technical Reference
WorkItemInteraction Members
WorkItemInteraction Class Constructors Methods Properties Events See Also Send Feedback

The WorkItemInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | WorkItemInteraction(InteractionsManager, InteractionId) | Initializes a new instance of the WorkItemInteraction class.
Public method | WorkItemInteraction(ProcessManager, InteractionId) | Initializes a new instance of the WorkItemInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | ProcessDefinitionId | Gets the ProcessDefinitionId.
Public property | ProcessInstanceId | Gets the ProcessInstanceId.
Public property | ProcessNumericId | Gets the ProcessNumericId.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WorkItemCategory | Gets the WorkItemCategory.
Public property | WorkItemDescription | Gets the WorkItemDescription.
Public property | WorkItemDueDate | Gets the WorkItemDueDate.
Public property | WorkItemError | Gets the WorkItemError.
Public property | WorkItemInitiationTime | Gets the WorkItemInitiationTime.
Public property | WorkItemIsTransferable | Gets the WorkItemIsTransferable.
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

WorkItemInteraction Class
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Constructor

[image] [image]

IceLib Technical Reference
WorkItemInteraction Constructor
WorkItemInteraction Class See Also Send Feedback
Initializes a new instance of the WorkItemInteraction class.

Overload List

 | Name | Description
Public method | WorkItemInteraction(InteractionsManager, InteractionId) | Initializes a new instance of the WorkItemInteraction class.
Public method | WorkItemInteraction(ProcessManager, InteractionId) | Initializes a new instance of the WorkItemInteraction class.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Constructor (InteractionsManager, InteractionId)

[image]

IceLib Technical Reference
WorkItemInteraction Constructor (InteractionsManager, InteractionId)
WorkItemInteraction Class See Also Send Feedback
Initializes a new instance of the WorkItemInteraction class.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkItemInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The Interactions Manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
WorkItemInteraction Overload
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Constructor (ProcessManager, InteractionId)

[image]

IceLib Technical Reference
WorkItemInteraction Constructor (ProcessManager, InteractionId)
WorkItemInteraction Class See Also Send Feedback
Initializes a new instance of the WorkItemInteraction class.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WorkItemInteraction(
    ProcessManager processManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    processManager As ProcessManager, _
    interactionId As InteractionId _
)

Parameters

processManager
Type: ININ.IceLib.ProcessAutomation..::..ProcessManager
The process manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
WorkItemInteraction Overload
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Methods

[image] [image]

IceLib Technical Reference
WorkItemInteraction Methods
WorkItemInteraction Class See Also Send Feedback

The WorkItemInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

WorkItemInteraction Class
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Properties

[image] [image]

IceLib Technical Reference
WorkItemInteraction Properties
WorkItemInteraction Class See Also Send Feedback

The WorkItemInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | ProcessDefinitionId | Gets the ProcessDefinitionId.
Public property | ProcessInstanceId | Gets the ProcessInstanceId.
Public property | ProcessNumericId | Gets the ProcessNumericId.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WorkItemCategory | Gets the WorkItemCategory.
Public property | WorkItemDescription | Gets the WorkItemDescription.
Public property | WorkItemDueDate | Gets the WorkItemDueDate.
Public property | WorkItemError | Gets the WorkItemError.
Public property | WorkItemInitiationTime | Gets the WorkItemInitiationTime.
Public property | WorkItemIsTransferable | Gets the WorkItemIsTransferable.
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

WorkItemInteraction Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionId Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..ProcessDefinitionId Property
WorkItemInteraction Class See Also Send Feedback
Gets the ProcessDefinitionId.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProcessDefinitionId { get; }
Visual Basic
Public ReadOnly Property ProcessDefinitionId As String
    Get

Field Value

The ID of the process definition from which the process instances were created that created this work item interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceId Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..ProcessInstanceId Property
WorkItemInteraction Class See Also Send Feedback
Gets the ProcessInstanceId.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProcessInstanceId { get; }
Visual Basic
Public ReadOnly Property ProcessInstanceId As String
    Get

Field Value

The ID of the process that this work item interaction is associated with.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


ProcessNumericId Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..ProcessNumericId Property
WorkItemInteraction Class See Also Send Feedback
Gets the ProcessNumericId.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ProcessNumericId { get; }
Visual Basic
Public ReadOnly Property ProcessNumericId As String
    Get

Field Value

The human readable numeric ID of the process that this work item interaction is associated with.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemCategory Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..WorkItemCategory Property
WorkItemInteraction Class See Also Send Feedback
Gets the WorkItemCategory.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkItemCategory { get; }
Visual Basic
Public ReadOnly Property WorkItemCategory As String
    Get

Field Value

The current category for the work item associated with this work item interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemDescription Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..WorkItemDescription Property
WorkItemInteraction Class See Also Send Feedback
Gets the WorkItemDescription.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkItemDescription { get; }
Visual Basic
Public ReadOnly Property WorkItemDescription As String
    Get

Field Value

The current description for the work item associated with this work item interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemDueDate Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..WorkItemDueDate Property
WorkItemInteraction Class See Also Send Feedback
Gets the WorkItemDueDate.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime WorkItemDueDate { get; }
Visual Basic
Public ReadOnly Property WorkItemDueDate As DateTime
    Get

Field Value

The due date for the work item associated with this work item interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemError Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..WorkItemError Property
WorkItemInteraction Class See Also Send Feedback
Gets the WorkItemError.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkItemError { get; }
Visual Basic
Public ReadOnly Property WorkItemError As String
    Get

Field Value

The error occurred while processing this work item interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInitiationTime Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..WorkItemInitiationTime Property
WorkItemInteraction Class See Also Send Feedback
Gets the WorkItemInitiationTime.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime WorkItemInitiationTime { get; }
Visual Basic
Public ReadOnly Property WorkItemInitiationTime As DateTime
    Get

Field Value

The initiation time for the work item associated with this work item interaction.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemIsTransferable Property

[image]

IceLib Technical Reference
WorkItemInteraction..::..WorkItemIsTransferable Property
WorkItemInteraction Class See Also Send Feedback
Gets the WorkItemIsTransferable.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool WorkItemIsTransferable { get; }
Visual Basic
Public ReadOnly Property WorkItemIsTransferable As Boolean
    Get

Field Value

The value that determines if this work item interaction is transferable.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkItemInteraction Class
WorkItemInteraction Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteraction Events

[image] [image]

IceLib Technical Reference
WorkItemInteraction Events
WorkItemInteraction Class See Also Send Feedback

The WorkItemInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

WorkItemInteraction Class
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteractionAttributeName Class

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with WorkItemInteractions.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WorkItemInteractionAttributeName : InteractionAttributeName
Visual Basic
Public Class WorkItemInteractionAttributeName _
    Inherits InteractionAttributeName

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.ProcessAutomation..::..WorkItemInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteractionAttributeName Members

[image] [image]

IceLib Technical Reference
WorkItemInteractionAttributeName Members
WorkItemInteractionAttributeName Class Methods Fields See Also Send Feedback

The WorkItemInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ProcessDefinitionId | The process definition from which the process instances were created that created this interaction.
ProcessInstanceId | The process instance that initiated this interaction.
ProcessNumericId | The human readable numeric ID assigned to the process instance.
WorkItemCategory | The current category for the work item interaction.
WorkItemDescription | The current description for the work item interaction.
WorkItemDueDate | The due date of the work item interaction.
WorkItemError | An error occurred while processing this work item.
WorkItemInitiationTime | The initiation time of the work item interaction.
WorkItemIsTransferable | Determines if this work item interaction can be transfered.

See Also

WorkItemInteractionAttributeName Class
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
WorkItemInteractionAttributeName Fields
WorkItemInteractionAttributeName Class See Also Send Feedback

The WorkItemInteractionAttributeName type exposes the following members.

Fields

Name | Description
ProcessDefinitionId | The process definition from which the process instances were created that created this interaction.
ProcessInstanceId | The process instance that initiated this interaction.
ProcessNumericId | The human readable numeric ID assigned to the process instance.
WorkItemCategory | The current category for the work item interaction.
WorkItemDescription | The current description for the work item interaction.
WorkItemDueDate | The due date of the work item interaction.
WorkItemError | An error occurred while processing this work item.
WorkItemInitiationTime | The initiation time of the work item interaction.
WorkItemIsTransferable | Determines if this work item interaction can be transfered.

See Also

WorkItemInteractionAttributeName Class
ININ.IceLib.ProcessAutomation Namespace


ProcessDefinitionId Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..ProcessDefinitionId Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The process definition from which the process instances were created that created this interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ProcessDefinitionId
Visual Basic
Public Shared ReadOnly ProcessDefinitionId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


ProcessInstanceId Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..ProcessInstanceId Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The process instance that initiated this interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ProcessInstanceId
Visual Basic
Public Shared ReadOnly ProcessInstanceId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


ProcessNumericId Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..ProcessNumericId Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The human readable numeric ID assigned to the process instance.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ProcessNumericId
Visual Basic
Public Shared ReadOnly ProcessNumericId As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemCategory Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..WorkItemCategory Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The current category for the work item interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkItemCategory
Visual Basic
Public Shared ReadOnly WorkItemCategory As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemDescription Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..WorkItemDescription Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The current description for the work item interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkItemDescription
Visual Basic
Public Shared ReadOnly WorkItemDescription As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemDueDate Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..WorkItemDueDate Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The due date of the work item interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkItemDueDate
Visual Basic
Public Shared ReadOnly WorkItemDueDate As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemError Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..WorkItemError Field
WorkItemInteractionAttributeName Class See Also Send Feedback
An error occurred while processing this work item.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkItemError
Visual Basic
Public Shared ReadOnly WorkItemError As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInitiationTime Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..WorkItemInitiationTime Field
WorkItemInteractionAttributeName Class See Also Send Feedback
The initiation time of the work item interaction.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkItemInitiationTime
Visual Basic
Public Shared ReadOnly WorkItemInitiationTime As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemIsTransferable Field

[image]

IceLib Technical Reference
WorkItemInteractionAttributeName..::..WorkItemIsTransferable Field
WorkItemInteractionAttributeName Class See Also Send Feedback
Determines if this work item interaction can be transfered.

Namespace: ININ.IceLib.ProcessAutomation
Assembly: ININ.IceLib.ProcessAutomation (in ININ.IceLib.ProcessAutomation.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string WorkItemIsTransferable
Visual Basic
Public Shared ReadOnly WorkItemIsTransferable As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

WorkItemInteractionAttributeName Class
WorkItemInteractionAttributeName Members
ININ.IceLib.ProcessAutomation Namespace


WorkItemInteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
WorkItemInteractionAttributeName Methods
WorkItemInteractionAttributeName Class See Also Send Feedback

The WorkItemInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkItemInteractionAttributeName Class
ININ.IceLib.ProcessAutomation Namespace


ININ.IceLib.QualityManagement Namespace

[image]

IceLib Technical Reference
ININ.IceLib.QualityManagement Namespace
Send Feedback

The ININ.IceLib.QualityManagement namespace contains classes for implementing quality management related features using the IceLib API and Interaction Center.

Classes

 | Class | Description
Public class | GetExportUriCompletedEventArgs | Class to encapsulate the recording export URI returned from Recorder server.
Public class | QualityManagementManager | Provides access to Quality Management functionality, such as recordings and surveys.
Public class | QueryRecordingAttributesCompletedEventArgs | Class to encapsulate the read-only dictionary of recording attributes returned from Recorder server.
Public class | QueryRecordingTagsCompletedEventArgs | Class to encapsulate the read-only collection of tags returned from Recorder server.
Public class | RecordingsManager | Provides methods for accessing and managing IC recordings.
Public class | ScreenPauseCompletedEventArgs | Provides data for the PauseRecordingsAsync(String, EventHandler<(Of <<'(ScreenPauseCompletedEventArgs>)>>), Object) completedCallback delegate of ScreenRecorder.
Public class | ScreenRecorder | This class provides the interface for creating screen recordings.
Public class | StartRecordingCompletedEventArgs | Provides data for the StartRecordingAsync(String, EventHandler<(Of <<'(StartRecordingCompletedEventArgs>)>>), Object) completedCallback delegate of ScreenRecorder.
Public class | StartStationAudioPlaybackCompletedEventArgs | Class to encapsulate the call ID returned from Recorder server.
Public class | StartTimedRecordingCompletedEventArgs | Provides data for the StartTimedRecordingAsync(String, TimeSpan, EventHandler<(Of <<'(StartTimedRecordingCompletedEventArgs>)>>), Object) completedCallback delegate of ScreenRecorder.

Enumerations

 | Enumeration | Description
Public enumeration | RecordingMediaType | Enumeration of recording media types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.


GetExportUriCompletedEventArgs Class

[image]

IceLib Technical Reference
GetExportUriCompletedEventArgs Class
Members See Also Send Feedback
Class to encapsulate the recording export URI returned from Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetExportUriCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetExportUriCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..GetExportUriCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

GetExportUriCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


GetExportUriCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetExportUriCompletedEventArgs Members
GetExportUriCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetExportUriCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetExportUriCompletedEventArgs | Creates an instance of GetExportUriCompletedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Uri | Gets the URI of a recording exported from the IC system.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetExportUriCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


GetExportUriCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetExportUriCompletedEventArgs Constructor
GetExportUriCompletedEventArgs Class See Also Send Feedback
Creates an instance of GetExportUriCompletedEventArgs.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetExportUriCompletedEventArgs(
    Uri uri,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    uri As Uri, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

uri
Type: System..::..Uri
The requested URI.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

GetExportUriCompletedEventArgs Class
GetExportUriCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


GetExportUriCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetExportUriCompletedEventArgs Methods
GetExportUriCompletedEventArgs Class See Also Send Feedback

The GetExportUriCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetExportUriCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


GetExportUriCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetExportUriCompletedEventArgs Properties
GetExportUriCompletedEventArgs Class See Also Send Feedback

The GetExportUriCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Uri | Gets the URI of a recording exported from the IC system.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetExportUriCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


Uri Property

[image]

IceLib Technical Reference
GetExportUriCompletedEventArgs..::..Uri Property
GetExportUriCompletedEventArgs Class See Also Send Feedback
Gets the URI of a recording exported from the IC system.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Uri Uri { get; }
Visual Basic
Public ReadOnly Property Uri As Uri
    Get

Field Value

The URI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

GetExportUriCompletedEventArgs Class
GetExportUriCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


QualityManagementManager Class

[image]

IceLib Technical Reference
QualityManagementManager Class
Members Example See Also Send Feedback
Provides access to Quality Management functionality, such as recordings and surveys.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QualityManagementManager
Visual Basic
Public Class QualityManagementManager

Examples

All "manager" classes found in the IceLib library are designed as singletons. To begin working with any of the functionality provided in the QualityManagementManager you must obtain the instance through a call to GetInstance(Session).

CopyC#
Session session = new Session();
session.Connect(...);
QualityManagementManager qualityManagementManager = QualityManagementManager.GetInstance(session);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.QualityManagement..::..QualityManagementManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

QualityManagementManager Members
ININ.IceLib.QualityManagement Namespace


QualityManagementManager Members

[image] [image]

IceLib Technical Reference
QualityManagementManager Members
QualityManagementManager Class Methods Properties See Also Send Feedback

The QualityManagementManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets the QualityManagementManager for the specified session.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RecordingsManager | Gets a reference to the Recordings Manager, which performs operations related to the Recorder subsystem.
Public property | Session | Gets the Session with which this QualityManagementManager is associated.

See Also

QualityManagementManager Class
ININ.IceLib.QualityManagement Namespace


QualityManagementManager Methods

[image] [image]

IceLib Technical Reference
QualityManagementManager Methods
QualityManagementManager Class See Also Send Feedback

The QualityManagementManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets the QualityManagementManager for the specified session.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QualityManagementManager Class
ININ.IceLib.QualityManagement Namespace


GetInstance Method

[image]

IceLib Technical Reference
QualityManagementManager..::..GetInstance Method
QualityManagementManager Class See Also Send Feedback
Gets the QualityManagementManager for the specified session.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static QualityManagementManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As QualityManagementManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The QualityManagementManager for the specified session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

QualityManagementManager Class
QualityManagementManager Members
ININ.IceLib.QualityManagement Namespace


QualityManagementManager Properties

[image] [image]

IceLib Technical Reference
QualityManagementManager Properties
QualityManagementManager Class See Also Send Feedback

The QualityManagementManager type exposes the following members.

Properties

 | Name | Description
Public property | RecordingsManager | Gets a reference to the Recordings Manager, which performs operations related to the Recorder subsystem.
Public property | Session | Gets the Session with which this QualityManagementManager is associated.

See Also

QualityManagementManager Class
ININ.IceLib.QualityManagement Namespace


RecordingsManager Property

[image]

IceLib Technical Reference
QualityManagementManager..::..RecordingsManager Property
QualityManagementManager Class See Also Send Feedback
Gets a reference to the Recordings Manager, which performs operations related to the Recorder subsystem.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RecordingsManager RecordingsManager { get; }
Visual Basic
Public ReadOnly Property RecordingsManager As RecordingsManager
    Get

Field Value

The recordings manager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

QualityManagementManager Class
QualityManagementManager Members
ININ.IceLib.QualityManagement Namespace


Session Property

[image]

IceLib Technical Reference
QualityManagementManager..::..Session Property
QualityManagementManager Class See Also Send Feedback
Gets the Session with which this QualityManagementManager is associated.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The Session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

QualityManagementManager Class
QualityManagementManager Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributesCompletedEventArgs Class

[image]

IceLib Technical Reference
QueryRecordingAttributesCompletedEventArgs Class
Members See Also Send Feedback
Class to encapsulate the read-only dictionary of recording attributes returned from Recorder server.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueryRecordingAttributesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class QueryRecordingAttributesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..QueryRecordingAttributesCompletedEventArgs

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

QueryRecordingAttributesCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
QueryRecordingAttributesCompletedEventArgs Members
QueryRecordingAttributesCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The QueryRecordingAttributesCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueryRecordingAttributesCompletedEventArgs | Creates an instance of QueryRecordingAttributesCompletedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets a read-only dictionary of attributes on a recording.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryRecordingAttributesCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributesCompletedEventArgs Constructor

[image]

IceLib Technical Reference
QueryRecordingAttributesCompletedEventArgs Constructor
QueryRecordingAttributesCompletedEventArgs Class See Also Send Feedback
Creates an instance of QueryRecordingAttributesCompletedEventArgs.

Note: This constructor is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueryRecordingAttributesCompletedEventArgs(
    IDictionary<string, string> attributes,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    attributes As IDictionary(Of String, String), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The dictionary of attributes on the recording.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

QueryRecordingAttributesCompletedEventArgs Class
QueryRecordingAttributesCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
QueryRecordingAttributesCompletedEventArgs Methods
QueryRecordingAttributesCompletedEventArgs Class See Also Send Feedback

The QueryRecordingAttributesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryRecordingAttributesCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
QueryRecordingAttributesCompletedEventArgs Properties
QueryRecordingAttributesCompletedEventArgs Class See Also Send Feedback

The QueryRecordingAttributesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets a read-only dictionary of attributes on a recording.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryRecordingAttributesCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


Attributes Property

[image]

IceLib Technical Reference
QueryRecordingAttributesCompletedEventArgs..::..Attributes Property
QueryRecordingAttributesCompletedEventArgs Class See Also Send Feedback
Gets a read-only dictionary of attributes on a recording.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As IDictionary(Of String, String)
    Get

Field Value

The read-only dictionary of recording attributes.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

QueryRecordingAttributesCompletedEventArgs Class
QueryRecordingAttributesCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingTagsCompletedEventArgs Class

[image]

IceLib Technical Reference
QueryRecordingTagsCompletedEventArgs Class
Members See Also Send Feedback
Class to encapsulate the read-only collection of tags returned from Recorder server.

Note: This class is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueryRecordingTagsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class QueryRecordingTagsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..QueryRecordingTagsCompletedEventArgs

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

QueryRecordingTagsCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingTagsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
QueryRecordingTagsCompletedEventArgs Members
QueryRecordingTagsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The QueryRecordingTagsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | QueryRecordingTagsCompletedEventArgs | Creates an instance of QueryRecordingTagsCompletedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Tags | Gets a read-only collection of tags on a recording.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryRecordingTagsCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


QueryRecordingTagsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
QueryRecordingTagsCompletedEventArgs Constructor
QueryRecordingTagsCompletedEventArgs Class See Also Send Feedback
Creates an instance of QueryRecordingTagsCompletedEventArgs.

Note: This constructor is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueryRecordingTagsCompletedEventArgs(
    IList<string> tags,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    tags As IList(Of String), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

tags
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The list of tags on the recording.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

QueryRecordingTagsCompletedEventArgs Class
QueryRecordingTagsCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingTagsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
QueryRecordingTagsCompletedEventArgs Methods
QueryRecordingTagsCompletedEventArgs Class See Also Send Feedback

The QueryRecordingTagsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryRecordingTagsCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


QueryRecordingTagsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
QueryRecordingTagsCompletedEventArgs Properties
QueryRecordingTagsCompletedEventArgs Class See Also Send Feedback

The QueryRecordingTagsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Tags | Gets a read-only collection of tags on a recording.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryRecordingTagsCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


Tags Property

[image]

IceLib Technical Reference
QueryRecordingTagsCompletedEventArgs..::..Tags Property
QueryRecordingTagsCompletedEventArgs Class See Also Send Feedback
Gets a read-only collection of tags on a recording.

Note: This property is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Tags { get; }
Visual Basic
Public ReadOnly Property Tags As ReadOnlyCollection(Of String)
    Get

Field Value

The read-only collection of recording tags.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

QueryRecordingTagsCompletedEventArgs Class
QueryRecordingTagsCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


RecordingMediaType Enumeration

[image]

IceLib Technical Reference
RecordingMediaType Enumeration
See Also Send Feedback
Enumeration of recording media types.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RecordingMediaType
Visual Basic
Public Enumeration RecordingMediaType

Members

Member name | Value | Description
None | -1 | No media type.
PrimaryMedia | 0 | Primary Media.
ScreenRecording | 1 | Screen Recording.
EmailAttachment | 2 | E-mail Attachment.

Remarks

Values dictated by IR Server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

ININ.IceLib.QualityManagement Namespace


RecordingsManager Class

[image]

IceLib Technical Reference
RecordingsManager Class
Members See Also Send Feedback
Provides methods for accessing and managing IC recordings.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RecordingsManager
Visual Basic
Public Class RecordingsManager

Remarks

Use RecordingsManager to get an instance of the RecordingsManager for a Session.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.QualityManagement..::..RecordingsManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RecordingsManager Members

[image] [image]

IceLib Technical Reference
RecordingsManager Members
RecordingsManager Class Methods See Also Send Feedback

The RecordingsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRecordingAttributes | Add attributes to a recording.
Public method | AddRecordingAttributesAsync | Asynchronously add recording attributes.
Public method | AddRecordingTags | Adds tags to a recording.
Public method | AddRecordingTagsAsync | Asynchronously adds recording tags.
Public method | DeregisterUser | Obsolete. Deregisters a user from Recorder server.
Public method | DeregisterUserAsync | Obsolete. Asynchronously deregisters a user from Recorder server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExportUri | Gets the export URI for a recording.
Public method | GetExportUriAsync | Asynchronously gets the export URI for a recording.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSecureExportUri | Gets the secure export URI for a recording. If HTTPS playback, archiving, and exporting is enabled, the HTTPS URI will be returned; otherwise, the HTTP URI will be returned.
Public method | GetSecureExportUriAsync | Asynchronously gets the secure export URI for a recording. If HTTPS playback, archiving, and exporting is enabled, the HTTPS URI will be returned; otherwise, the HTTP URI will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ModifyRecordingAttributes | Modify the value of attributes for a recording.
Public method | ModifyRecordingAttributesAsync | Asynchronously modify recording attributes.
Public method | QueryRecordingAttributes | Query the attributes for a recording.
Public method | QueryRecordingAttributesAsync | Asynchronously query recording attributes.
Public method | QueryRecordingTags | Query the tags for a recording.
Public method | QueryRecordingTagsAsync | Asynchronously query recording tags.
Public method | RegisterUser | Obsolete. Registers the current session user with the Recorder server.This must be called before issuing requests to Recorder server.
Public method | RegisterUserAsync | Obsolete. Asynchronously registers the current session user with the Recorder server. This must be called before issuing requests to Recorder server.
Public method | RemoveRecordingAttributes | Remove attributes from a recording.
Public method | RemoveRecordingAttributesAsync | Asynchronously remove attributes from a recording.
Public method | RemoveRecordingTags | Remove tags from a recording.
Public method | RemoveRecordingTagsAsync | Asynchronously remove recording tags.
Public method | SendRecordingsEmail | Sends an email containing a list of recording Ids to Recorder server.
Public method | SendRecordingsEmailAsync | Asynchronously sends an email containing a list of recording IDs to Recorder server.
Public method | StartStationAudioPlayback | Starts playback of a recording to a station.
Public method | StartStationAudioPlaybackAsync | Asynchronously starts playback of a recording to a station.
Public method | StopStationAudioPlayback | Stops playback of a recording over station audio.
Public method | StopStationAudioPlaybackAsync | Asynchronously stops playback of a recording over station audio.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordingsManager Class
ININ.IceLib.QualityManagement Namespace


RecordingsManager Methods

[image] [image]

IceLib Technical Reference
RecordingsManager Methods
RecordingsManager Class See Also Send Feedback

The RecordingsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRecordingAttributes | Add attributes to a recording.
Public method | AddRecordingAttributesAsync | Asynchronously add recording attributes.
Public method | AddRecordingTags | Adds tags to a recording.
Public method | AddRecordingTagsAsync | Asynchronously adds recording tags.
Public method | DeregisterUser | Obsolete. Deregisters a user from Recorder server.
Public method | DeregisterUserAsync | Obsolete. Asynchronously deregisters a user from Recorder server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExportUri | Gets the export URI for a recording.
Public method | GetExportUriAsync | Asynchronously gets the export URI for a recording.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSecureExportUri | Gets the secure export URI for a recording. If HTTPS playback, archiving, and exporting is enabled, the HTTPS URI will be returned; otherwise, the HTTP URI will be returned.
Public method | GetSecureExportUriAsync | Asynchronously gets the secure export URI for a recording. If HTTPS playback, archiving, and exporting is enabled, the HTTPS URI will be returned; otherwise, the HTTP URI will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ModifyRecordingAttributes | Modify the value of attributes for a recording.
Public method | ModifyRecordingAttributesAsync | Asynchronously modify recording attributes.
Public method | QueryRecordingAttributes | Query the attributes for a recording.
Public method | QueryRecordingAttributesAsync | Asynchronously query recording attributes.
Public method | QueryRecordingTags | Query the tags for a recording.
Public method | QueryRecordingTagsAsync | Asynchronously query recording tags.
Public method | RegisterUser | Obsolete. Registers the current session user with the Recorder server.This must be called before issuing requests to Recorder server.
Public method | RegisterUserAsync | Obsolete. Asynchronously registers the current session user with the Recorder server. This must be called before issuing requests to Recorder server.
Public method | RemoveRecordingAttributes | Remove attributes from a recording.
Public method | RemoveRecordingAttributesAsync | Asynchronously remove attributes from a recording.
Public method | RemoveRecordingTags | Remove tags from a recording.
Public method | RemoveRecordingTagsAsync | Asynchronously remove recording tags.
Public method | SendRecordingsEmail | Sends an email containing a list of recording Ids to Recorder server.
Public method | SendRecordingsEmailAsync | Asynchronously sends an email containing a list of recording IDs to Recorder server.
Public method | StartStationAudioPlayback | Starts playback of a recording to a station.
Public method | StartStationAudioPlaybackAsync | Asynchronously starts playback of a recording to a station.
Public method | StopStationAudioPlayback | Stops playback of a recording over station audio.
Public method | StopStationAudioPlaybackAsync | Asynchronously stops playback of a recording over station audio.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordingsManager Class
ININ.IceLib.QualityManagement Namespace


AddRecordingAttributes Method

[image]

IceLib Technical Reference
RecordingsManager..::..AddRecordingAttributes Method
RecordingsManager Class See Also Send Feedback
Add attributes to a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddRecordingAttributes(
    string recordingId,
    IDictionary<string, string> attributes
)
Visual Basic
Public Sub AddRecordingAttributes ( _
    recordingId As String, _
    attributes As IDictionary(Of String, String) _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The attributes to be added to the recording.

Remarks

Attribute names are case insensitive within Recorder Server, so an attribute name of "test" or "Test" will refer to the same attribute. If multiple attributes with the same name are added to a recording, only the first attribute will be added and the rest will be ignored as duplicates.

If an attribute is added that already exists on the recording, the value will not be updated.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | attributes is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributes is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


AddRecordingAttributesAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..AddRecordingAttributesAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously add recording attributes.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddRecordingAttributesAsync(
    string recordingId,
    IDictionary<string, string> attributes,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddRecordingAttributesAsync ( _
    recordingId As String, _
    attributes As IDictionary(Of String, String), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The attributes to be added to the recording.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

Attribute names are case insensitive within Recorder Server, so an attribute name of "test" or "Test" will refer to the same attribute. If multiple attributes with the same name are added to a recording, only the first attribute will be added and the rest will be ignored as duplicates.

If an attribute is added that already exists on the recording, the value will not be updated.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | attributes is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributes is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


AddRecordingTags Method

[image]

IceLib Technical Reference
RecordingsManager..::..AddRecordingTags Method
RecordingsManager Class See Also Send Feedback
Adds tags to a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddRecordingTags(
    string recordingId,
    IEnumerable<string> tags
)
Visual Basic
Public Sub AddRecordingTags ( _
    recordingId As String, _
    tags As IEnumerable(Of String) _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
tags
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The tags to be added to the recording.

Remarks

Tags are case insensitive within Recorder Server, so a tag of "test" or "Test" will be considered the same tag. If multiple tags with the same value are added to a recording, only the first tag will be added and the rest will be ignored as duplicates.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | tags is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | tags is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


AddRecordingTagsAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..AddRecordingTagsAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously adds recording tags.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddRecordingTagsAsync(
    string recordingId,
    IEnumerable<string> tags,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddRecordingTagsAsync ( _
    recordingId As String, _
    tags As IEnumerable(Of String), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
tags
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The recording tags to be added to the recording.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

Tags are case insensitive within Recorder Server, so a tag of "test" or "Test" will be considered the same tag. If multiple tags with the same value are added to a recording, only the first tag will be added and the rest will be ignored as duplicates.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | tags is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | tags is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


DeregisterUser Method

[image]

IceLib Technical Reference
RecordingsManager..::..DeregisterUser Method
RecordingsManager Class See Also Send Feedback
Deregisters a user from Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Registering recorder users is no longer required.")]
public void DeregisterUser()
Visual Basic
<ObsoleteAttribute("Registering recorder users is no longer required.")> _
Public Sub DeregisterUser

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


DeregisterUserAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..DeregisterUserAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously deregisters a user from Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Registering recorder users is no longer required.")]
public void DeregisterUserAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("Registering recorder users is no longer required.")> _
Public Sub DeregisterUserAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


GetExportUri Method

[image]

IceLib Technical Reference
RecordingsManager..::..GetExportUri Method
RecordingsManager Class See Also Send Feedback
Gets the export URI for a recording.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Uri GetExportUri(
    string recordingId,
    RecordingMediaType mediaType,
    string screenRecordingParticipantId,
    int attachmentId
)
Visual Basic
Public Function GetExportUri ( _
    recordingId As String, _
    mediaType As RecordingMediaType, _
    screenRecordingParticipantId As String, _
    attachmentId As Integer _
) As Uri

Parameters

recordingId
Type: System..::..String
The recording ID.
mediaType
Type: ININ.IceLib.QualityManagement..::..RecordingMediaType
The recording media type.
screenRecordingParticipantId
Type: System..::..String
The name of the screen recording participant.
attachmentId
Type: System..::..Int32
The ID of the recording attachment, ranging from 0...n.

Return Value

A Uri object that can be used to access the recording when exporting it from the IC system.

Remarks

Note
attachmentId is only used when mediaType is set to EmailAttachment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


GetExportUriAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..GetExportUriAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously gets the export URI for a recording.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetExportUriAsync(
    string recordingId,
    RecordingMediaType mediaType,
    string screenRecordingParticipantId,
    int attachmentId,
    EventHandler<GetExportUriCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetExportUriAsync ( _
    recordingId As String, _
    mediaType As RecordingMediaType, _
    screenRecordingParticipantId As String, _
    attachmentId As Integer, _
    completedCallback As EventHandler(Of GetExportUriCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
mediaType
Type: ININ.IceLib.QualityManagement..::..RecordingMediaType
The recording media type.
screenRecordingParticipantId
Type: System..::..String
The name of the screen recording participant.
attachmentId
Type: System..::..Int32
The ID of the recording attachment.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetExportUriCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


GetSecureExportUri Method

[image]

IceLib Technical Reference
RecordingsManager..::..GetSecureExportUri Method
RecordingsManager Class See Also Send Feedback
Gets the secure export URI for a recording. If HTTPS playback, archiving, and exporting is enabled, the HTTPS URI will be returned; otherwise, the HTTP URI will be returned.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Uri GetSecureExportUri(
    string recordingId,
    RecordingMediaType mediaType,
    string screenRecordingParticipantId,
    int attachmentId
)
Visual Basic
Public Function GetSecureExportUri ( _
    recordingId As String, _
    mediaType As RecordingMediaType, _
    screenRecordingParticipantId As String, _
    attachmentId As Integer _
) As Uri

Parameters

recordingId
Type: System..::..String
The recording ID.
mediaType
Type: ININ.IceLib.QualityManagement..::..RecordingMediaType
The recording media type.
screenRecordingParticipantId
Type: System..::..String
The name of the screen recording participant.
attachmentId
Type: System..::..Int32
The ID of the recording attachment, ranging from 0...n.

Return Value

A Uri object that can be used to access the recording when exporting it from the IC system.

Remarks

Note
attachmentId is only used when mediaType is set to EmailAttachment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


GetSecureExportUriAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..GetSecureExportUriAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously gets the secure export URI for a recording. If HTTPS playback, archiving, and exporting is enabled, the HTTPS URI will be returned; otherwise, the HTTP URI will be returned.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetSecureExportUriAsync(
    string recordingId,
    RecordingMediaType mediaType,
    string screenRecordingParticipantId,
    int attachmentId,
    EventHandler<GetExportUriCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetSecureExportUriAsync ( _
    recordingId As String, _
    mediaType As RecordingMediaType, _
    screenRecordingParticipantId As String, _
    attachmentId As Integer, _
    completedCallback As EventHandler(Of GetExportUriCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
mediaType
Type: ININ.IceLib.QualityManagement..::..RecordingMediaType
The recording media type.
screenRecordingParticipantId
Type: System..::..String
The name of the screen recording participant.
attachmentId
Type: System..::..Int32
The ID of the recording attachment.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetExportUriCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Version Information

Supported for IC Server version 2017 R1 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


ModifyRecordingAttributes Method

[image]

IceLib Technical Reference
RecordingsManager..::..ModifyRecordingAttributes Method
RecordingsManager Class See Also Send Feedback
Modify the value of attributes for a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ModifyRecordingAttributes(
    string recordingId,
    IDictionary<string, string> attributes
)
Visual Basic
Public Sub ModifyRecordingAttributes ( _
    recordingId As String, _
    attributes As IDictionary(Of String, String) _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The attributes to be modified.

Remarks

If the given attribute does not exist on the recording, the attribute will not be added.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | attributes is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributes is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


ModifyRecordingAttributesAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..ModifyRecordingAttributesAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously modify recording attributes.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ModifyRecordingAttributesAsync(
    string recordingId,
    IDictionary<string, string> attributes,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ModifyRecordingAttributesAsync ( _
    recordingId As String, _
    attributes As IDictionary(Of String, String), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The attributes to be modified.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

If the given attribute does not exist on the recording, the attribute will not be added.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | attributes is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributes is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributes Method

[image]

IceLib Technical Reference
RecordingsManager..::..QueryRecordingAttributes Method
RecordingsManager Class See Also Send Feedback
Query the attributes for a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IDictionary<string, string> QueryRecordingAttributes(
    string recordingId
)
Visual Basic
Public Function QueryRecordingAttributes ( _
    recordingId As String _
) As IDictionary(Of String, String)

Parameters

recordingId
Type: System..::..String
The recording ID.

Return Value

A ReadOnlyDictionary of attributes on the recording.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingAttributesAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..QueryRecordingAttributesAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously query recording attributes.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void QueryRecordingAttributesAsync(
    string recordingId,
    EventHandler<QueryRecordingAttributesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub QueryRecordingAttributesAsync ( _
    recordingId As String, _
    completedCallback As EventHandler(Of QueryRecordingAttributesCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryRecordingAttributesCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingTags Method

[image]

IceLib Technical Reference
RecordingsManager..::..QueryRecordingTags Method
RecordingsManager Class See Also Send Feedback
Query the tags for a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> QueryRecordingTags(
    string recordingId
)
Visual Basic
Public Function QueryRecordingTags ( _
    recordingId As String _
) As ReadOnlyCollection(Of String)

Parameters

recordingId
Type: System..::..String
The recording ID.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> containing the tags on the recording.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


QueryRecordingTagsAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..QueryRecordingTagsAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously query recording tags.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void QueryRecordingTagsAsync(
    string recordingId,
    EventHandler<QueryRecordingTagsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub QueryRecordingTagsAsync ( _
    recordingId As String, _
    completedCallback As EventHandler(Of QueryRecordingTagsCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryRecordingTagsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RegisterUser Method

[image]

IceLib Technical Reference
RecordingsManager..::..RegisterUser Method
RecordingsManager Class See Also Send Feedback
Registers the current session user with the Recorder server.This must be called before issuing requests to Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Registering recorder users is no longer required.")]
public RegisterUserData RegisterUser()
Visual Basic
<ObsoleteAttribute("Registering recorder users is no longer required.")> _
Public Function RegisterUser As RegisterUserData

Remarks

A RegisterUserData object with data returned from Recorder server.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RegisterUserAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..RegisterUserAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously registers the current session user with the Recorder server. This must be called before issuing requests to Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Registering recorder users is no longer required.")]
public void RegisterUserAsync(
    EventHandler<RegisterUserCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("Registering recorder users is no longer required.")> _
Public Sub RegisterUserAsync ( _
    completedCallback As EventHandler(Of RegisterUserCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'RegisterUserCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RemoveRecordingAttributes Method

[image]

IceLib Technical Reference
RecordingsManager..::..RemoveRecordingAttributes Method
RecordingsManager Class See Also Send Feedback
Remove attributes from a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveRecordingAttributes(
    string recordingId,
    IEnumerable<string> attributeNames
)
Visual Basic
Public Sub RemoveRecordingAttributes ( _
    recordingId As String, _
    attributeNames As IEnumerable(Of String) _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
attributeNames
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The names of the attributes to be removed from the recording.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | attributeNames is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributeNames is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RemoveRecordingAttributesAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..RemoveRecordingAttributesAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously remove attributes from a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveRecordingAttributesAsync(
    string recordingId,
    IEnumerable<string> attributeNames,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub RemoveRecordingAttributesAsync ( _
    recordingId As String, _
    attributeNames As IEnumerable(Of String), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
attributeNames
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The names of the attributes to be removed from the recording.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | attributeNames is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | attributeNames is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RemoveRecordingTags Method

[image]

IceLib Technical Reference
RecordingsManager..::..RemoveRecordingTags Method
RecordingsManager Class See Also Send Feedback
Remove tags from a recording.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveRecordingTags(
    string recordingId,
    IEnumerable<string> tags
)
Visual Basic
Public Sub RemoveRecordingTags ( _
    recordingId As String, _
    tags As IEnumerable(Of String) _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
tags
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The tags to be removed from the recording.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | tags is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | tags is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


RemoveRecordingTagsAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..RemoveRecordingTagsAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously remove recording tags.

Note: This method is supported for IC Server version 2016 R3 and beyond.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveRecordingTagsAsync(
    string recordingId,
    IEnumerable<string> tags,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub RemoveRecordingTagsAsync ( _
    recordingId As String, _
    tags As IEnumerable(Of String), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

recordingId
Type: System..::..String
The recording ID.
tags
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The recording tags to be removed from the recording.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | recordingId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | recordingId length is zero.
System..::..ArgumentNullException | tags is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | tags is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2016 R3 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


SendRecordingsEmail Method

[image]

IceLib Technical Reference
RecordingsManager..::..SendRecordingsEmail Method
RecordingsManager Class See Also Send Feedback
Sends an email containing a list of recording Ids to Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendRecordingsEmail(
    IEnumerable<EmailAddress> toRecipients,
    IEnumerable<EmailAddress> ccRecipients,
    string subject,
    string bodyText,
    IEnumerable<string> recordingIds,
    EmailPriority importance
)
Visual Basic
Public Sub SendRecordingsEmail ( _
    toRecipients As IEnumerable(Of EmailAddress), _
    ccRecipients As IEnumerable(Of EmailAddress), _
    subject As String, _
    bodyText As String, _
    recordingIds As IEnumerable(Of String), _
    importance As EmailPriority _
)

Parameters

toRecipients
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' EmailAddress >)>)>
The recipients in the "To:" address of the e-mail. (Note: There must be at least one recipient.)
ccRecipients
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' EmailAddress >)>)>
The recipients in the "Cc:" address of the e-mail.(Or nullNothingnullptra null reference (Nothing in Visual Basic) for none.)
subject
Type: System..::..String
The e-mail subject.
bodyText
Type: System..::..String
The e-mail body text.
recordingIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
This list of recording Ids attached to the e-mail.
importance
Type: ININ.IceLib.Interactions..::..EmailPriority
The importance of the e-mail.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | If toRecipients or recordingIds is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


SendRecordingsEmailAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..SendRecordingsEmailAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously sends an email containing a list of recording IDs to Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendRecordingsEmailAsync(
    IEnumerable<EmailAddress> toRecipients,
    IEnumerable<EmailAddress> ccRecipients,
    string subject,
    string bodyText,
    IEnumerable<string> recordingIds,
    EmailPriority importance,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendRecordingsEmailAsync ( _
    toRecipients As IEnumerable(Of EmailAddress), _
    ccRecipients As IEnumerable(Of EmailAddress), _
    subject As String, _
    bodyText As String, _
    recordingIds As IEnumerable(Of String), _
    importance As EmailPriority, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

toRecipients
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' EmailAddress >)>)>
The recipients in the "To:" address of the e-mail.
ccRecipients
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' EmailAddress >)>)>
The recipients in the "Cc:" address of the e-mail.(Or nullNothingnullptra null reference (Nothing in Visual Basic) for none.)
subject
Type: System..::..String
The e-mail subject.
bodyText
Type: System..::..String
The e-mail body text.
recordingIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
This list of recording Ids attached to the e-mail.
importance
Type: ININ.IceLib.Interactions..::..EmailPriority
The importance of the e-mail.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | If toRecipients or recordingIds is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlayback Method

[image]

IceLib Technical Reference
RecordingsManager..::..StartStationAudioPlayback Method
RecordingsManager Class See Also Send Feedback
Starts playback of a recording to a station.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId StartStationAudioPlayback(
    string playbackUri,
    string station
)
Visual Basic
Public Function StartStationAudioPlayback ( _
    playbackUri As String, _
    station As String _
) As InteractionId

Parameters

playbackUri
Type: System..::..String
Playback URI of a recording.
station
Type: System..::..String
Name of the station with the handset to play on.

Return Value

ID of the call made to the station.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlaybackAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..StartStationAudioPlaybackAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously starts playback of a recording to a station.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartStationAudioPlaybackAsync(
    string playbackUri,
    string station,
    EventHandler<StartStationAudioPlaybackCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartStationAudioPlaybackAsync ( _
    playbackUri As String, _
    station As String, _
    completedCallback As EventHandler(Of StartStationAudioPlaybackCompletedEventArgs), _
    userState As Object _
)

Parameters

playbackUri
Type: System..::..String
Playback URI of a recording.
station
Type: System..::..String
Name of the station with the handset to play on.
completedCallback
Type: System..::..EventHandler<(Of <(<' StartStationAudioPlaybackCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs - derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


StopStationAudioPlayback Method

[image]

IceLib Technical Reference
RecordingsManager..::..StopStationAudioPlayback Method
RecordingsManager Class See Also Send Feedback
Stops playback of a recording over station audio.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopStationAudioPlayback(
    InteractionId callId
)
Visual Basic
Public Sub StopStationAudioPlayback ( _
    callId As InteractionId _
)

Parameters

callId
Type: ININ.IceLib.Interactions..::..InteractionId
ID of the station audio call interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


StopStationAudioPlaybackAsync Method

[image]

IceLib Technical Reference
RecordingsManager..::..StopStationAudioPlaybackAsync Method
RecordingsManager Class See Also Send Feedback
Asynchronously stops playback of a recording over station audio.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopStationAudioPlaybackAsync(
    InteractionId callId,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopStationAudioPlaybackAsync ( _
    callId As InteractionId, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

callId
Type: ININ.IceLib.Interactions..::..InteractionId
ID of the station audio call interaction.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

RecordingsManager Class
RecordingsManager Members
ININ.IceLib.QualityManagement Namespace


ScreenPauseCompletedEventArgs Class

[image]

IceLib Technical Reference
ScreenPauseCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the PauseRecordingsAsync(String, EventHandler<(Of <<'(ScreenPauseCompletedEventArgs>)>>), Object) completedCallback delegate of ScreenRecorder.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScreenPauseCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class ScreenPauseCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..ScreenPauseCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ScreenPauseCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


ScreenPauseCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
ScreenPauseCompletedEventArgs Members
ScreenPauseCompletedEventArgs Class Methods Properties See Also Send Feedback

The ScreenPauseCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | RecordingIds | Gets the IDs of recordings that were paused.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ScreenPauseCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


ScreenPauseCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
ScreenPauseCompletedEventArgs Methods
ScreenPauseCompletedEventArgs Class See Also Send Feedback

The ScreenPauseCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenPauseCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


ScreenPauseCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
ScreenPauseCompletedEventArgs Properties
ScreenPauseCompletedEventArgs Class See Also Send Feedback

The ScreenPauseCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | RecordingIds | Gets the IDs of recordings that were paused.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ScreenPauseCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


RecordingIds Property

[image]

IceLib Technical Reference
ScreenPauseCompletedEventArgs..::..RecordingIds Property
ScreenPauseCompletedEventArgs Class See Also Send Feedback
Gets the IDs of recordings that were paused.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> RecordingIds { get; }
Visual Basic
Public ReadOnly Property RecordingIds As ReadOnlyCollection(Of String)
    Get

Field Value

Array of recording IDs.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ScreenPauseCompletedEventArgs Class
ScreenPauseCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


ScreenRecorder Class

[image]

IceLib Technical Reference
ScreenRecorder Class
Members See Also Send Feedback
This class provides the interface for creating screen recordings.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ScreenRecorder
Visual Basic
Public Class ScreenRecorder

Remarks

A ScreenRecorder object is used to initiate and control screen recording on a target user. Recordings that run for a specified length of time are initiated with StartTimedRecording(String, TimeSpan).

Inheritance Hierarchy

System..::..Object
ININ.IceLib.QualityManagement..::..ScreenRecorder

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


ScreenRecorder Members

[image] [image]

IceLib Technical Reference
ScreenRecorder Members
ScreenRecorder Class Constructors Methods See Also Send Feedback

The ScreenRecorder type exposes the following members.

Constructors

 | Name | Description
Public method | ScreenRecorder | Initializes a new instance of the ScreenRecorder class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PauseRecordings | Pauses all screen recordings being made for the given user.
Public method | PauseRecordingsAsync | Asynchronously pauses all screen recordings being made for the given user.
Public method | ResumeRecordings | Resumes all screen recordings being made for the given user.
Public method | ResumeRecordingsAsync | Asynchronously resumes all screen recordings being made for the given user.
Public method | StartRecording | Starts a new screen recording.
Public method | StartRecordingAsync | Asynchronously starts a new screen recording.
Public method | StartTimedRecording | Starts a new recording that will run for a predetermined amount of time.
Public method | StartTimedRecordingAsync | Asynchronously starts a new recording that will run for a predetermined amount of time.
Public method | StopRecording | Stops existing screen recording(s) for the specified user.
Public method | StopRecordingAsync | Asynchronously stops existing screen recording(s) for the specified user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenRecorder Class
ININ.IceLib.QualityManagement Namespace


ScreenRecorder Constructor

[image]

IceLib Technical Reference
ScreenRecorder Constructor
ScreenRecorder Class See Also Send Feedback
Initializes a new instance of the ScreenRecorder class.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ScreenRecorder(
    QualityManagementManager qualityManagementManager
)
Visual Basic
Public Sub New ( _
    qualityManagementManager As QualityManagementManager _
)

Parameters

qualityManagementManager
Type: ININ.IceLib.QualityManagement..::..QualityManagementManager
The quality management manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


ScreenRecorder Methods

[image] [image]

IceLib Technical Reference
ScreenRecorder Methods
ScreenRecorder Class See Also Send Feedback

The ScreenRecorder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PauseRecordings | Pauses all screen recordings being made for the given user.
Public method | PauseRecordingsAsync | Asynchronously pauses all screen recordings being made for the given user.
Public method | ResumeRecordings | Resumes all screen recordings being made for the given user.
Public method | ResumeRecordingsAsync | Asynchronously resumes all screen recordings being made for the given user.
Public method | StartRecording | Starts a new screen recording.
Public method | StartRecordingAsync | Asynchronously starts a new screen recording.
Public method | StartTimedRecording | Starts a new recording that will run for a predetermined amount of time.
Public method | StartTimedRecordingAsync | Asynchronously starts a new recording that will run for a predetermined amount of time.
Public method | StopRecording | Stops existing screen recording(s) for the specified user.
Public method | StopRecordingAsync | Asynchronously stops existing screen recording(s) for the specified user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScreenRecorder Class
ININ.IceLib.QualityManagement Namespace


PauseRecordings Method

[image]

IceLib Technical Reference
ScreenRecorder..::..PauseRecordings Method
ScreenRecorder Class See Also Send Feedback
Pauses all screen recordings being made for the given user.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> PauseRecordings(
    string userId
)
Visual Basic
Public Function PauseRecordings ( _
    userId As String _
) As ReadOnlyCollection(Of String)

Parameters

userId
Type: System..::..String
The user whose screen recordings will be paused.

Return Value

IDs of all recordings that were paused.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


PauseRecordingsAsync Method

[image]

IceLib Technical Reference
ScreenRecorder..::..PauseRecordingsAsync Method
ScreenRecorder Class See Also Send Feedback
Asynchronously pauses all screen recordings being made for the given user.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PauseRecordingsAsync(
    string userId,
    EventHandler<ScreenPauseCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub PauseRecordingsAsync ( _
    userId As String, _
    completedCallback As EventHandler(Of ScreenPauseCompletedEventArgs), _
    userState As Object _
)

Parameters

userId
Type: System..::..String
The user whose screen recordings will be paused.
completedCallback
Type: System..::..EventHandler<(Of <(<' ScreenPauseCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


ResumeRecordings Method

[image]

IceLib Technical Reference
ScreenRecorder..::..ResumeRecordings Method
ScreenRecorder Class See Also Send Feedback
Resumes all screen recordings being made for the given user.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ResumeRecordings(
    string userId
)
Visual Basic
Public Function ResumeRecordings ( _
    userId As String _
) As ReadOnlyCollection(Of String)

Parameters

userId
Type: System..::..String
The user whose screen recordings will be paused.

Return Value

IDs of all recordings that were paused.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


ResumeRecordingsAsync Method

[image]

IceLib Technical Reference
ScreenRecorder..::..ResumeRecordingsAsync Method
ScreenRecorder Class See Also Send Feedback
Asynchronously resumes all screen recordings being made for the given user.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ResumeRecordingsAsync(
    string userId,
    EventHandler<ScreenPauseCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ResumeRecordingsAsync ( _
    userId As String, _
    completedCallback As EventHandler(Of ScreenPauseCompletedEventArgs), _
    userState As Object _
)

Parameters

userId
Type: System..::..String
The user whose screen recordings will be paused.
completedCallback
Type: System..::..EventHandler<(Of <(<' ScreenPauseCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 3 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StartRecording Method

[image]

IceLib Technical Reference
ScreenRecorder..::..StartRecording Method
ScreenRecorder Class See Also Send Feedback
Starts a new screen recording.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<Guid> StartRecording(
    string userIdToRecord
)
Visual Basic
Public Function StartRecording ( _
    userIdToRecord As String _
) As IEnumerable(Of Guid)

Parameters

userIdToRecord
Type: System..::..String
The user whose screen will be recorded.

Return Value

The recording IDs.

Exceptions

Exception | Condition
System..::..ArgumentNullException | userIdToRecord is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | userIdToRecord length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StartRecordingAsync Method

[image]

IceLib Technical Reference
ScreenRecorder..::..StartRecordingAsync Method
ScreenRecorder Class See Also Send Feedback
Asynchronously starts a new screen recording.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartRecordingAsync(
    string userIdToRecord,
    EventHandler<StartRecordingCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartRecordingAsync ( _
    userIdToRecord As String, _
    completedCallback As EventHandler(Of StartRecordingCompletedEventArgs), _
    userState As Object _
)

Parameters

userIdToRecord
Type: System..::..String
The user whose screen will be recorded.
completedCallback
Type: System..::..EventHandler<(Of <(<' StartRecordingCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | userIdToRecord is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | userIdToRecord length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StartTimedRecording Method

[image]

IceLib Technical Reference
ScreenRecorder..::..StartTimedRecording Method
ScreenRecorder Class See Also Send Feedback
Starts a new recording that will run for a predetermined amount of time.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StartTimedRecording(
    string userIdToRecord,
    TimeSpan recordingDuration
)
Visual Basic
Public Function StartTimedRecording ( _
    userIdToRecord As String, _
    recordingDuration As TimeSpan _
) As String

Parameters

userIdToRecord
Type: System..::..String
The user whose screen will be recorded.
recordingDuration
Type: System..::..TimeSpan
The length of time that the recording will run. Note that the recording duration will be rounded up to the nearest second.

Return Value

The timed recording ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | userIdToRecord is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The userIdToRecord length is zero.
System..::..ArgumentOutOfRangeException | The value of recordingDuration is negative.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StartTimedRecordingAsync Method

[image]

IceLib Technical Reference
ScreenRecorder..::..StartTimedRecordingAsync Method
ScreenRecorder Class See Also Send Feedback
Asynchronously starts a new recording that will run for a predetermined amount of time.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartTimedRecordingAsync(
    string userIdToRecord,
    TimeSpan recordingDuration,
    EventHandler<StartTimedRecordingCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartTimedRecordingAsync ( _
    userIdToRecord As String, _
    recordingDuration As TimeSpan, _
    completedCallback As EventHandler(Of StartTimedRecordingCompletedEventArgs), _
    userState As Object _
)

Parameters

userIdToRecord
Type: System..::..String
The user whose screen will be recorded.
recordingDuration
Type: System..::..TimeSpan
The length of time that the recording will run. Note that the recording duration will be rounded up to the nearest second.
completedCallback
Type: System..::..EventHandler<(Of <(<' StartTimedRecordingCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | userIdToRecord is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The userIdToRecord length is zero.
System..::..ArgumentOutOfRangeException | The value of recordingDuration is negative.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StopRecording Method

[image]

IceLib Technical Reference
ScreenRecorder..::..StopRecording Method
ScreenRecorder Class See Also Send Feedback
Stops existing screen recording(s) for the specified user.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopRecording(
    string userId,
    IEnumerable<Guid> recordingIds
)
Visual Basic
Public Sub StopRecording ( _
    userId As String, _
    recordingIds As IEnumerable(Of Guid) _
)

Parameters

userId
Type: System..::..String
The user whose screen is being recorded.
recordingIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'Guid>)>)>
IDs of the existing recordings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | userId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | userId length is zero.
System..::..ArgumentException | recordingIds is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StopRecordingAsync Method

[image]

IceLib Technical Reference
ScreenRecorder..::..StopRecordingAsync Method
ScreenRecorder Class See Also Send Feedback
Asynchronously stops existing screen recording(s) for the specified user.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopRecordingAsync(
    string userId,
    IEnumerable<Guid> recordingIds,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopRecordingAsync ( _
    userId As String, _
    recordingIds As IEnumerable(Of Guid), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

userId
Type: System..::..String
The user whose screen is being recorded.
recordingIds
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'Guid>)>)>
IDs of the existing recordings.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | userId is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | userId length is zero.
System..::..ArgumentException | recordingIds is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ScreenRecorder Class
ScreenRecorder Members
ININ.IceLib.QualityManagement Namespace


StartRecordingCompletedEventArgs Class

[image]

IceLib Technical Reference
StartRecordingCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the StartRecordingAsync(String, EventHandler<(Of <<'(StartRecordingCompletedEventArgs>)>>), Object) completedCallback delegate of ScreenRecorder.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StartRecordingCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class StartRecordingCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..StartRecordingCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StartRecordingCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartRecordingCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
StartRecordingCompletedEventArgs Members
StartRecordingCompletedEventArgs Class Methods Properties See Also Send Feedback

The StartRecordingCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | RecordingIds | Guids for the screen recordings started.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

StartRecordingCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


StartRecordingCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
StartRecordingCompletedEventArgs Methods
StartRecordingCompletedEventArgs Class See Also Send Feedback

The StartRecordingCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartRecordingCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


StartRecordingCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
StartRecordingCompletedEventArgs Properties
StartRecordingCompletedEventArgs Class See Also Send Feedback

The StartRecordingCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | RecordingIds | Guids for the screen recordings started.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

StartRecordingCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


RecordingIds Property

[image]

IceLib Technical Reference
StartRecordingCompletedEventArgs..::..RecordingIds Property
StartRecordingCompletedEventArgs Class See Also Send Feedback
Guids for the screen recordings started.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<Guid> RecordingIds { get; private set; }
Visual Basic
Public Property RecordingIds As IEnumerable(Of Guid)
    Get
    Private Set

Field Value

IEnumerable<(Of <(<'T>)>)> of Guid for each started recording.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StartRecordingCompletedEventArgs Class
StartRecordingCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlaybackCompletedEventArgs Class

[image]

IceLib Technical Reference
StartStationAudioPlaybackCompletedEventArgs Class
Members See Also Send Feedback
Class to encapsulate the call ID returned from Recorder server.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StartStationAudioPlaybackCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class StartStationAudioPlaybackCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..StartStationAudioPlaybackCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

StartStationAudioPlaybackCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlaybackCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
StartStationAudioPlaybackCompletedEventArgs Members
StartStationAudioPlaybackCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The StartStationAudioPlaybackCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | StartStationAudioPlaybackCompletedEventArgs | Creates an instance of StartStationAudioPlaybackCompletedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallId | Gets the ID of the call made to the station.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

StartStationAudioPlaybackCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlaybackCompletedEventArgs Constructor

[image]

IceLib Technical Reference
StartStationAudioPlaybackCompletedEventArgs Constructor
StartStationAudioPlaybackCompletedEventArgs Class See Also Send Feedback
Creates an instance of StartStationAudioPlaybackCompletedEventArgs.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StartStationAudioPlaybackCompletedEventArgs(
    InteractionId callId,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    callId As InteractionId, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

callId
Type: ININ.IceLib.Interactions..::..InteractionId
The ID of the call made to the station.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

StartStationAudioPlaybackCompletedEventArgs Class
StartStationAudioPlaybackCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlaybackCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
StartStationAudioPlaybackCompletedEventArgs Methods
StartStationAudioPlaybackCompletedEventArgs Class See Also Send Feedback

The StartStationAudioPlaybackCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartStationAudioPlaybackCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


StartStationAudioPlaybackCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
StartStationAudioPlaybackCompletedEventArgs Properties
StartStationAudioPlaybackCompletedEventArgs Class See Also Send Feedback

The StartStationAudioPlaybackCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CallId | Gets the ID of the call made to the station.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

StartStationAudioPlaybackCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


CallId Property

[image]

IceLib Technical Reference
StartStationAudioPlaybackCompletedEventArgs..::..CallId Property
StartStationAudioPlaybackCompletedEventArgs Class See Also Send Feedback
Gets the ID of the call made to the station.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionId CallId { get; }
Visual Basic
Public ReadOnly Property CallId As InteractionId
    Get

Field Value

The call ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 8 and beyond.

See Also

StartStationAudioPlaybackCompletedEventArgs Class
StartStationAudioPlaybackCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartTimedRecordingCompletedEventArgs Class

[image]

IceLib Technical Reference
StartTimedRecordingCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the StartTimedRecordingAsync(String, TimeSpan, EventHandler<(Of <<'(StartTimedRecordingCompletedEventArgs>)>>), Object) completedCallback delegate of ScreenRecorder.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StartTimedRecordingCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class StartTimedRecordingCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.QualityManagement..::..StartTimedRecordingCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StartTimedRecordingCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartTimedRecordingCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
StartTimedRecordingCompletedEventArgs Members
StartTimedRecordingCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The StartTimedRecordingCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | StartTimedRecordingCompletedEventArgs | Initializes a new instance of the StartTimedRecordingCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TimedRecordingId | Gets the Timed Recording ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

StartTimedRecordingCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


StartTimedRecordingCompletedEventArgs Constructor

[image]

IceLib Technical Reference
StartTimedRecordingCompletedEventArgs Constructor
StartTimedRecordingCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the StartTimedRecordingCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StartTimedRecordingCompletedEventArgs(
    string timedRecordingId,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    timedRecordingId As String, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

timedRecordingId
Type: System..::..String
The timed recording ID.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StartTimedRecordingCompletedEventArgs Class
StartTimedRecordingCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


StartTimedRecordingCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
StartTimedRecordingCompletedEventArgs Methods
StartTimedRecordingCompletedEventArgs Class See Also Send Feedback

The StartTimedRecordingCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartTimedRecordingCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


StartTimedRecordingCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
StartTimedRecordingCompletedEventArgs Properties
StartTimedRecordingCompletedEventArgs Class See Also Send Feedback

The StartTimedRecordingCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | TimedRecordingId | Gets the Timed Recording ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

StartTimedRecordingCompletedEventArgs Class
ININ.IceLib.QualityManagement Namespace


TimedRecordingId Property

[image]

IceLib Technical Reference
StartTimedRecordingCompletedEventArgs..::..TimedRecordingId Property
StartTimedRecordingCompletedEventArgs Class See Also Send Feedback
Gets the Timed Recording ID associated with the event.

Namespace: ININ.IceLib.QualityManagement
Assembly: ININ.IceLib.QualityManagement (in ININ.IceLib.QualityManagement.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TimedRecordingId { get; private set; }
Visual Basic
Public Property TimedRecordingId As String
    Get
    Private Set

Field Value

The timed recording ID.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StartTimedRecordingCompletedEventArgs Class
StartTimedRecordingCompletedEventArgs Members
ININ.IceLib.QualityManagement Namespace


ININ.IceLib.Reporting Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Reporting Namespace
Send Feedback

The ININ.IceLib.Reporting namespace contains classes for implementing reporting related features using the IceLib API and Interaction Center.

InteractionSnapshotBrowser can be used to retrieve historical information about interactions. Use GetInteractionSnapshot(GetInteractionSnapshotParameters) to retrieve historical data about a specific interaction, or use GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)) to retrieve a filtered list of historical data about multiple interactions.

Classes

 | Class | Description
Public class | ReportingManager | Provides access to Reporting functionality, such as historical Interaction details.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


ReportingManager Class

[image]

IceLib Technical Reference
ReportingManager Class
Members Example See Also Send Feedback
Provides access to Reporting functionality, such as historical Interaction details.

Namespace: ININ.IceLib.Reporting
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReportingManager
Visual Basic
Public Class ReportingManager

Examples

All "manager" classes found in the IceLib library are designed as singletons. To begin working with any of the functionality provided in the ReportingManager you must obtain the instance through a call to GetInstance(Session).

CopyC#
Session session = new Session();
session.Connect(...);
ReportingManager reportingManager = ReportingManager.GetInstance(session);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting..::..ReportingManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportingManager Members
ININ.IceLib.Reporting Namespace


ReportingManager Members

[image] [image]

IceLib Technical Reference
ReportingManager Members
ReportingManager Class Methods Properties See Also Send Feedback

The ReportingManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets the ReportingManager for the specified session.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Session | Gets the Session with which this ReportingManager is associated.
Public property | SupportsAllSites | Returns trueTruetruetrue (True in Visual Basic) if the server supports the use of the all site identifier for site ID.

See Also

ReportingManager Class
ININ.IceLib.Reporting Namespace


ReportingManager Methods

[image] [image]

IceLib Technical Reference
ReportingManager Methods
ReportingManager Class See Also Send Feedback

The ReportingManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets the ReportingManager for the specified session.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportingManager Class
ININ.IceLib.Reporting Namespace


GetInstance Method

[image]

IceLib Technical Reference
ReportingManager..::..GetInstance Method
ReportingManager Class See Also Send Feedback
Gets the ReportingManager for the specified session.

Namespace: ININ.IceLib.Reporting
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static ReportingManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As ReportingManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The ReportingManager for the specified session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportingManager Class
ReportingManager Members
ININ.IceLib.Reporting Namespace


ReportingManager Properties

[image] [image]

IceLib Technical Reference
ReportingManager Properties
ReportingManager Class See Also Send Feedback

The ReportingManager type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session with which this ReportingManager is associated.
Public property | SupportsAllSites | Returns trueTruetruetrue (True in Visual Basic) if the server supports the use of the all site identifier for site ID.

See Also

ReportingManager Class
ININ.IceLib.Reporting Namespace


Session Property

[image]

IceLib Technical Reference
ReportingManager..::..Session Property
ReportingManager Class See Also Send Feedback
Gets the Session with which this ReportingManager is associated.

Namespace: ININ.IceLib.Reporting
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The Session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ReportingManager Class
ReportingManager Members
ININ.IceLib.Reporting Namespace


SupportsAllSites Property

[image]

IceLib Technical Reference
ReportingManager..::..SupportsAllSites Property
ReportingManager Class See Also Send Feedback
Returns trueTruetruetrue (True in Visual Basic) if the server supports the use of the all site identifier for site ID.

Note: This property is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.Reporting
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SupportsAllSites { get; }
Visual Basic
Public ReadOnly Property SupportsAllSites As Boolean
    Get

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

ReportingManager Class
ReportingManager Members
ININ.IceLib.Reporting Namespace


ININ.IceLib.Reporting.Interactions Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Reporting.Interactions Namespace
Send Feedback

The ININ.IceLib.Reporting.Interactions namespace contains classes that provide support for Interactions reporting classes.

Classes

 | Class | Description
Public class | GetCurrentSiteIdCompletedEventArgs | Provides data for the completedCallback delegate of GetCurrentSiteIdAsync(EventHandler<(Of <<'(GetCurrentSiteIdCompletedEventArgs>)>>), Object).
Public class | GetInteractionSnapshotCompletedEventArgs | Provides data for the completedCallback delegate of GetInteractionSnapshotAsync(GetInteractionSnapshotParameters, EventHandler<(Of <<'(GetInteractionSnapshotCompletedEventArgs>)>>), Object).
Public class | GetInteractionSnapshotParameters | Provides details when retrieving an interaction snapshot via GetInteractionSnapshot(GetInteractionSnapshotParameters).
Public class | GetInteractionSnapshotsCompletedEventArgs | Provides data for the completedCallback delegate of GetInteractionSnapshotsAsync(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>), EventHandler<(Of <<'(GetInteractionSnapshotsCompletedEventArgs>)>>), Object).
Public class | InteractionSnapshot | Describes historical data of an interaction retrieved from GetInteractionSnapshot(GetInteractionSnapshotParameters) and GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | InteractionSnapshotBrowser | Used to browse historical data on interactions.
Public class | InteractionSnapshotResults | Represents the results retrieved from GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Enumerations

 | Enumeration | Description
Public enumeration | InteractionSnapshotDirection | Represents an interaction's direction.
Public enumeration | InteractionSnapshotDisposition | Represents an interaction's disposition.
Public enumeration | InteractionSnapshotMediaType | Represents and interaction's media type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


GetCurrentSiteIdCompletedEventArgs Class

[image]

IceLib Technical Reference
GetCurrentSiteIdCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of GetCurrentSiteIdAsync(EventHandler<(Of <<'(GetCurrentSiteIdCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetCurrentSiteIdCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetCurrentSiteIdCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Reporting.Interactions..::..GetCurrentSiteIdCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

GetCurrentSiteIdCompletedEventArgs Members
ININ.IceLib.Reporting.Interactions Namespace


GetCurrentSiteIdCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetCurrentSiteIdCompletedEventArgs Members
GetCurrentSiteIdCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCurrentSiteIdCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SiteId | Gets the site ID for the current user.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCurrentSiteIdCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


GetCurrentSiteIdCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetCurrentSiteIdCompletedEventArgs Methods
GetCurrentSiteIdCompletedEventArgs Class See Also Send Feedback

The GetCurrentSiteIdCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCurrentSiteIdCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


GetCurrentSiteIdCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetCurrentSiteIdCompletedEventArgs Properties
GetCurrentSiteIdCompletedEventArgs Class See Also Send Feedback

The GetCurrentSiteIdCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SiteId | Gets the site ID for the current user.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCurrentSiteIdCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


SiteId Property

[image]

IceLib Technical Reference
GetCurrentSiteIdCompletedEventArgs..::..SiteId Property
GetCurrentSiteIdCompletedEventArgs Class See Also Send Feedback
Gets the site ID for the current user.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SiteId { get; }
Visual Basic
Public ReadOnly Property SiteId As Integer
    Get

Field Value

The site ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

GetCurrentSiteIdCompletedEventArgs Class
GetCurrentSiteIdCompletedEventArgs Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotCompletedEventArgs Class

[image]

IceLib Technical Reference
GetInteractionSnapshotCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of GetInteractionSnapshotAsync(GetInteractionSnapshotParameters, EventHandler<(Of <<'(GetInteractionSnapshotCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetInteractionSnapshotCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetInteractionSnapshotCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Reporting.Interactions..::..GetInteractionSnapshotCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotCompletedEventArgs Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotCompletedEventArgs Members
GetInteractionSnapshotCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInteractionSnapshotCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionSnapshot | Gets the interaction snapshot.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionSnapshotCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotCompletedEventArgs Methods
GetInteractionSnapshotCompletedEventArgs Class See Also Send Feedback

The GetInteractionSnapshotCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInteractionSnapshotCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotCompletedEventArgs Properties
GetInteractionSnapshotCompletedEventArgs Class See Also Send Feedback

The GetInteractionSnapshotCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionSnapshot | Gets the interaction snapshot.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionSnapshotCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshot Property

[image]

IceLib Technical Reference
GetInteractionSnapshotCompletedEventArgs..::..InteractionSnapshot Property
GetInteractionSnapshotCompletedEventArgs Class See Also Send Feedback
Gets the interaction snapshot.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshot InteractionSnapshot { get; }
Visual Basic
Public ReadOnly Property InteractionSnapshot As InteractionSnapshot
    Get

Field Value

An InteractionSnapshot.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotCompletedEventArgs Class
GetInteractionSnapshotCompletedEventArgs Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Class

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters Class
Members See Also Send Feedback
Provides details when retrieving an interaction snapshot via GetInteractionSnapshot(GetInteractionSnapshotParameters).

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetInteractionSnapshotParameters
Visual Basic
Public Class GetInteractionSnapshotParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions..::..GetInteractionSnapshotParameters

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Members

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotParameters Members
GetInteractionSnapshotParameters Class Constructors Methods Properties See Also Send Feedback

The GetInteractionSnapshotParameters type exposes the following members.

Constructors

 | Name | Description
Public method | GetInteractionSnapshotParameters(String, Int32, Int32) | Initializes a new instance of the GetInteractionSnapshotParameters class. The three parameters form a unique key used to identify an interaction.
Public method | GetInteractionSnapshotParameters(String, Int32, Int32, CultureInfo) | Initializes a new instance of the GetInteractionSnapshotParameters class. The first three parameters form a unique key used to identify an interaction. The fourth allows the results to be returned formatted for a particular culture.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CultureInfo | Gets the culture info of the caller.
Public property | InteractionIdKey | Gets the interaction ID key.
Public property | SequenceNumber | Gets the sequence number.
Public property | SiteId | Gets the site ID.

See Also

GetInteractionSnapshotParameters Class
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Constructor

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotParameters Constructor
GetInteractionSnapshotParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInteractionSnapshotParameters(String, Int32, Int32) | Initializes a new instance of the GetInteractionSnapshotParameters class. The three parameters form a unique key used to identify an interaction.
Public method | GetInteractionSnapshotParameters(String, Int32, Int32, CultureInfo) | Initializes a new instance of the GetInteractionSnapshotParameters class. The first three parameters form a unique key used to identify an interaction. The fourth allows the results to be returned formatted for a particular culture.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Constructor (String, Int32, Int32)

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters Constructor (String, Int32, Int32)
GetInteractionSnapshotParameters Class See Also Send Feedback
Initializes a new instance of the GetInteractionSnapshotParameters class. The three parameters form a unique key used to identify an interaction.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetInteractionSnapshotParameters(
    string interactionIdKey,
    int siteId,
    int sequenceNumber
)
Visual Basic
Public Sub New ( _
    interactionIdKey As String, _
    siteId As Integer, _
    sequenceNumber As Integer _
)

Parameters

interactionIdKey
Type: System..::..String
The interaction ID key.
siteId
Type: System..::..Int32
The site ID. Valid values are 0 to 999.
sequenceNumber
Type: System..::..Int32
The sequence number. Valid values are 0 to 255, inclusive.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.
System..::..ArgumentOutOfRangeException | siteId is not a number between 0 and 999 (inclusive). sequenceNumber is not a number between 0 and 255 (inclusive).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
GetInteractionSnapshotParameters Overload
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Constructor (String, Int32, Int32, CultureInfo)

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters Constructor (String, Int32, Int32, CultureInfo)
GetInteractionSnapshotParameters Class See Also Send Feedback
Initializes a new instance of the GetInteractionSnapshotParameters class. The first three parameters form a unique key used to identify an interaction. The fourth allows the results to be returned formatted for a particular culture.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetInteractionSnapshotParameters(
    string interactionIdKey,
    int siteId,
    int sequenceNumber,
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    interactionIdKey As String, _
    siteId As Integer, _
    sequenceNumber As Integer, _
    cultureInfo As CultureInfo _
)

Parameters

interactionIdKey
Type: System..::..String
The interaction ID key.
siteId
Type: System..::..Int32
The site ID. Valid values are 0 to 999.
sequenceNumber
Type: System..::..Int32
The sequence number. Valid values are 0 to 255, inclusive.
cultureInfo
Type: System.Globalization..::..CultureInfo
The culture in which to format the results.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.
System..::..ArgumentOutOfRangeException | siteId is not a number between 0 and 999 (inclusive). sequenceNumber is not a number between 0 and 255 (inclusive).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
GetInteractionSnapshotParameters Overload
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Methods

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotParameters Methods
GetInteractionSnapshotParameters Class See Also Send Feedback

The GetInteractionSnapshotParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

GetInteractionSnapshotParameters Class
ININ.IceLib.Reporting.Interactions Namespace


ToString Method

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters..::..ToString Method
GetInteractionSnapshotParameters Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotParameters Properties

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotParameters Properties
GetInteractionSnapshotParameters Class See Also Send Feedback

The GetInteractionSnapshotParameters type exposes the following members.

Properties

 | Name | Description
Public property | CultureInfo | Gets the culture info of the caller.
Public property | InteractionIdKey | Gets the interaction ID key.
Public property | SequenceNumber | Gets the sequence number.
Public property | SiteId | Gets the site ID.

See Also

GetInteractionSnapshotParameters Class
ININ.IceLib.Reporting.Interactions Namespace


CultureInfo Property

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters..::..CultureInfo Property
GetInteractionSnapshotParameters Class See Also Send Feedback
Gets the culture info of the caller.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CultureInfo CultureInfo { get; private set; }
Visual Basic
Public Property CultureInfo As CultureInfo
    Get
    Private Set

Field Value

The culture info.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionIdKey Property

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters..::..InteractionIdKey Property
GetInteractionSnapshotParameters Class See Also Send Feedback
Gets the interaction ID key.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionIdKey { get; private set; }
Visual Basic
Public Property InteractionIdKey As String
    Get
    Private Set

Field Value

The interaction ID key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


SequenceNumber Property

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters..::..SequenceNumber Property
GetInteractionSnapshotParameters Class See Also Send Feedback
Gets the sequence number.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SequenceNumber { get; private set; }
Visual Basic
Public Property SequenceNumber As Integer
    Get
    Private Set

Field Value

The sequence number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


SiteId Property

[image]

IceLib Technical Reference
GetInteractionSnapshotParameters..::..SiteId Property
GetInteractionSnapshotParameters Class See Also Send Feedback
Gets the site ID.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SiteId { get; private set; }
Visual Basic
Public Property SiteId As Integer
    Get
    Private Set

Field Value

The site ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotParameters Class
GetInteractionSnapshotParameters Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetInteractionSnapshotsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the completedCallback delegate of GetInteractionSnapshotsAsync(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>), EventHandler<(Of <<'(GetInteractionSnapshotsCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetInteractionSnapshotsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetInteractionSnapshotsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Reporting.Interactions..::..GetInteractionSnapshotsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotsCompletedEventArgs Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotsCompletedEventArgs Members
GetInteractionSnapshotsCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInteractionSnapshotsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionSnapshotResults | Gets the interaction snapshot results.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionSnapshotsCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotsCompletedEventArgs Methods
GetInteractionSnapshotsCompletedEventArgs Class See Also Send Feedback

The GetInteractionSnapshotsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInteractionSnapshotsCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetInteractionSnapshotsCompletedEventArgs Properties
GetInteractionSnapshotsCompletedEventArgs Class See Also Send Feedback

The GetInteractionSnapshotsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionSnapshotResults | Gets the interaction snapshot results.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionSnapshotsCompletedEventArgs Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotResults Property

[image]

IceLib Technical Reference
GetInteractionSnapshotsCompletedEventArgs..::..InteractionSnapshotResults Property
GetInteractionSnapshotsCompletedEventArgs Class See Also Send Feedback
Gets the interaction snapshot results.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotResults InteractionSnapshotResults { get; }
Visual Basic
Public ReadOnly Property InteractionSnapshotResults As InteractionSnapshotResults
    Get

Field Value

An InteractionSnapshotResults object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

GetInteractionSnapshotsCompletedEventArgs Class
GetInteractionSnapshotsCompletedEventArgs Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshot Class

[image]

IceLib Technical Reference
InteractionSnapshot Class
Members See Also Send Feedback
Describes historical data of an interaction retrieved from GetInteractionSnapshot(GetInteractionSnapshotParameters) and GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionSnapshot
Visual Basic
Public Class InteractionSnapshot

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions..::..InteractionSnapshot

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshot Members

[image] [image]

IceLib Technical Reference
InteractionSnapshot Members
InteractionSnapshot Class Methods Properties See Also Send Feedback

The InteractionSnapshot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | Gets the direction of this interaction. See InteractionSnapshotDirection for valid values.
Public property | Disposition | Gets the disposition of this interaction. See InteractionSnapshotDisposition for valid values.
Public property | InitiationTime | Gets the initiation time. Value is expressed as local time.
Public property | InteractionId | Gets the interaction ID. This may not be a unique value.
Public property | InteractionIdKey | Gets the interaction ID key. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.
Public property | MediaType | Gets the media type for this interaction. See InteractionSnapshotMediaType for valid values.
Public property | SegmentLog | Gets the segment log. The segment log contains an XML representation of the segments within this interaction.
Public property | SequenceNumber | Gets the sequence number. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.
Public property | SiteId | Gets the site ID. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.
Public property | SummaryValues | Gets a collection of KeyValuePairs containing all available information about this interaction.

See Also

InteractionSnapshot Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshot Methods

[image] [image]

IceLib Technical Reference
InteractionSnapshot Methods
InteractionSnapshot Class See Also Send Feedback

The InteractionSnapshot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSnapshot Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshot Properties

[image] [image]

IceLib Technical Reference
InteractionSnapshot Properties
InteractionSnapshot Class See Also Send Feedback

The InteractionSnapshot type exposes the following members.

Properties

 | Name | Description
Public property | Direction | Gets the direction of this interaction. See InteractionSnapshotDirection for valid values.
Public property | Disposition | Gets the disposition of this interaction. See InteractionSnapshotDisposition for valid values.
Public property | InitiationTime | Gets the initiation time. Value is expressed as local time.
Public property | InteractionId | Gets the interaction ID. This may not be a unique value.
Public property | InteractionIdKey | Gets the interaction ID key. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.
Public property | MediaType | Gets the media type for this interaction. See InteractionSnapshotMediaType for valid values.
Public property | SegmentLog | Gets the segment log. The segment log contains an XML representation of the segments within this interaction.
Public property | SequenceNumber | Gets the sequence number. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.
Public property | SiteId | Gets the site ID. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.
Public property | SummaryValues | Gets a collection of KeyValuePairs containing all available information about this interaction.

See Also

InteractionSnapshot Class
ININ.IceLib.Reporting.Interactions Namespace


Direction Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..Direction Property
InteractionSnapshot Class See Also Send Feedback
Gets the direction of this interaction. See InteractionSnapshotDirection for valid values.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotDirection Direction { get; private set; }
Visual Basic
Public Property Direction As InteractionSnapshotDirection
    Get
    Private Set

Field Value

The direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


Disposition Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..Disposition Property
InteractionSnapshot Class See Also Send Feedback
Gets the disposition of this interaction. See InteractionSnapshotDisposition for valid values.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotDisposition Disposition { get; private set; }
Visual Basic
Public Property Disposition As InteractionSnapshotDisposition
    Get
    Private Set

Field Value

The disposition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


InitiationTime Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..InitiationTime Property
InteractionSnapshot Class See Also Send Feedback
Gets the initiation time. Value is expressed as local time.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime InitiationTime { get; private set; }
Visual Basic
Public Property InitiationTime As DateTime
    Get
    Private Set

Field Value

The initiation time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionId Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..InteractionId Property
InteractionSnapshot Class See Also Send Feedback
Gets the interaction ID. This may not be a unique value.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionId { get; private set; }
Visual Basic
Public Property InteractionId As String
    Get
    Private Set

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionIdKey Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..InteractionIdKey Property
InteractionSnapshot Class See Also Send Feedback
Gets the interaction ID key. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionIdKey { get; private set; }
Visual Basic
Public Property InteractionIdKey As String
    Get
    Private Set

Field Value

The interaction ID key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


MediaType Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..MediaType Property
InteractionSnapshot Class See Also Send Feedback
Gets the media type for this interaction. See InteractionSnapshotMediaType for valid values.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotMediaType MediaType { get; private set; }
Visual Basic
Public Property MediaType As InteractionSnapshotMediaType
    Get
    Private Set

Field Value

The media type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


SegmentLog Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..SegmentLog Property
InteractionSnapshot Class See Also Send Feedback
Gets the segment log. The segment log contains an XML representation of the segments within this interaction.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SegmentLog { get; private set; }
Visual Basic
Public Property SegmentLog As String
    Get
    Private Set

Field Value

The segment log.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


SequenceNumber Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..SequenceNumber Property
InteractionSnapshot Class See Also Send Feedback
Gets the sequence number. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SequenceNumber { get; private set; }
Visual Basic
Public Property SequenceNumber As Integer
    Get
    Private Set

Field Value

The sequence number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


SiteId Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..SiteId Property
InteractionSnapshot Class See Also Send Feedback
Gets the site ID. This is one part of a unique tripartite key consisting of InteractionIdKey, SequenceNumber and SiteId.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SiteId { get; private set; }
Visual Basic
Public Property SiteId As Integer
    Get
    Private Set

Field Value

The site ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


SummaryValues Property

[image]

IceLib Technical Reference
InteractionSnapshot..::..SummaryValues Property
InteractionSnapshot Class See Also Send Feedback
Gets a collection of KeyValuePairs containing all available information about this interaction.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<KeyValuePair<string, string>> SummaryValues { get; private set; }
Visual Basic
Public Property SummaryValues As IEnumerable(Of KeyValuePair(Of String, String))
    Get
    Private Set

Field Value

The summary values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshot Class
InteractionSnapshot Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotBrowser Class

[image]

IceLib Technical Reference
InteractionSnapshotBrowser Class
Members See Also Send Feedback
Used to browse historical data on interactions.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionSnapshotBrowser
Visual Basic
Public Class InteractionSnapshotBrowser

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions..::..InteractionSnapshotBrowser

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotBrowser Members

[image] [image]

IceLib Technical Reference
InteractionSnapshotBrowser Members
InteractionSnapshotBrowser Class Constructors Methods See Also Send Feedback

The InteractionSnapshotBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionSnapshotBrowser | Initializes a new instance of the InteractionSnapshotBrowser class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentSiteId | Gets the site ID for the current user.
Public method | GetCurrentSiteIdAsync | Asynchronously gets the site ID for the current user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInteractionSnapshot | Gets the interaction snapshot by the parameters specified in GetInteractionSnapshotParameters.
Public method | GetInteractionSnapshotAsync | Asynchronously gets the interaction snapshot by the parameters specified in GetInteractionSnapshotParameters.
Public method | GetInteractionSnapshots | Gets the interaction snapshots matching a provided set of InteractionSnapshotFilter criteria. Results will match on all specified criteria.
Public method | GetInteractionSnapshotsAsync | Asynchronously gets the interaction snapshots matching a provided set of InteractionSnapshotFilter criteria. Results will match on all specified criteria.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSnapshotBrowser Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotBrowser Constructor

[image]

IceLib Technical Reference
InteractionSnapshotBrowser Constructor
InteractionSnapshotBrowser Class See Also Send Feedback
Initializes a new instance of the InteractionSnapshotBrowser class.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotBrowser(
    ReportingManager reportingManager
)
Visual Basic
Public Sub New ( _
    reportingManager As ReportingManager _
)

Parameters

reportingManager
Type: ININ.IceLib.Reporting..::..ReportingManager
The reporting manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotBrowser Methods

[image] [image]

IceLib Technical Reference
InteractionSnapshotBrowser Methods
InteractionSnapshotBrowser Class See Also Send Feedback

The InteractionSnapshotBrowser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentSiteId | Gets the site ID for the current user.
Public method | GetCurrentSiteIdAsync | Asynchronously gets the site ID for the current user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInteractionSnapshot | Gets the interaction snapshot by the parameters specified in GetInteractionSnapshotParameters.
Public method | GetInteractionSnapshotAsync | Asynchronously gets the interaction snapshot by the parameters specified in GetInteractionSnapshotParameters.
Public method | GetInteractionSnapshots | Gets the interaction snapshots matching a provided set of InteractionSnapshotFilter criteria. Results will match on all specified criteria.
Public method | GetInteractionSnapshotsAsync | Asynchronously gets the interaction snapshots matching a provided set of InteractionSnapshotFilter criteria. Results will match on all specified criteria.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSnapshotBrowser Class
ININ.IceLib.Reporting.Interactions Namespace


GetCurrentSiteId Method

[image]

IceLib Technical Reference
InteractionSnapshotBrowser..::..GetCurrentSiteId Method
InteractionSnapshotBrowser Class See Also Send Feedback
Gets the site ID for the current user.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int GetCurrentSiteId()
Visual Basic
Public Function GetCurrentSiteId As Integer

Return Value

The site ID.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


GetCurrentSiteIdAsync Method

[image]

IceLib Technical Reference
InteractionSnapshotBrowser..::..GetCurrentSiteIdAsync Method
InteractionSnapshotBrowser Class See Also Send Feedback
Asynchronously gets the site ID for the current user.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetCurrentSiteIdAsync(
    EventHandler<GetCurrentSiteIdCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetCurrentSiteIdAsync ( _
    completedCallback As EventHandler(Of GetCurrentSiteIdCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetCurrentSiteIdCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshot Method

[image]

IceLib Technical Reference
InteractionSnapshotBrowser..::..GetInteractionSnapshot Method
InteractionSnapshotBrowser Class See Also Send Feedback
Gets the interaction snapshot by the parameters specified in GetInteractionSnapshotParameters.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshot GetInteractionSnapshot(
    GetInteractionSnapshotParameters parameters
)
Visual Basic
Public Function GetInteractionSnapshot ( _
    parameters As GetInteractionSnapshotParameters _
) As InteractionSnapshot

Parameters

parameters
Type: ININ.IceLib.Reporting.Interactions..::..GetInteractionSnapshotParameters
The parameters.

Return Value

An InteractionSnapshot.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotAsync Method

[image]

IceLib Technical Reference
InteractionSnapshotBrowser..::..GetInteractionSnapshotAsync Method
InteractionSnapshotBrowser Class See Also Send Feedback
Asynchronously gets the interaction snapshot by the parameters specified in GetInteractionSnapshotParameters.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionSnapshotAsync(
    GetInteractionSnapshotParameters parameters,
    EventHandler<GetInteractionSnapshotCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionSnapshotAsync ( _
    parameters As GetInteractionSnapshotParameters, _
    completedCallback As EventHandler(Of GetInteractionSnapshotCompletedEventArgs), _
    userState As Object _
)

Parameters

parameters
Type: ININ.IceLib.Reporting.Interactions..::..GetInteractionSnapshotParameters
The parameters.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetInteractionSnapshotCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshots Method

[image]

IceLib Technical Reference
InteractionSnapshotBrowser..::..GetInteractionSnapshots Method
InteractionSnapshotBrowser Class See Also Send Feedback
Gets the interaction snapshots matching a provided set of InteractionSnapshotFilter criteria. Results will match on all specified criteria.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotResults GetInteractionSnapshots(
    IEnumerable<InteractionSnapshotFilter> filters
)
Visual Basic
Public Function GetInteractionSnapshots ( _
    filters As IEnumerable(Of InteractionSnapshotFilter) _
) As InteractionSnapshotResults

Parameters

filters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' InteractionSnapshotFilter >)>)>
The filters.

Return Value

An InteractionSnapshotResults object.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


GetInteractionSnapshotsAsync Method

[image]

IceLib Technical Reference
InteractionSnapshotBrowser..::..GetInteractionSnapshotsAsync Method
InteractionSnapshotBrowser Class See Also Send Feedback
Asynchronously gets the interaction snapshots matching a provided set of InteractionSnapshotFilter criteria. Results will match on all specified criteria.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionSnapshotsAsync(
    IEnumerable<InteractionSnapshotFilter> filters,
    EventHandler<GetInteractionSnapshotsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionSnapshotsAsync ( _
    filters As IEnumerable(Of InteractionSnapshotFilter), _
    completedCallback As EventHandler(Of GetInteractionSnapshotsCompletedEventArgs), _
    userState As Object _
)

Parameters

filters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' InteractionSnapshotFilter >)>)>
The filters.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetInteractionSnapshotsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotBrowser Class
InteractionSnapshotBrowser Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotDirection Enumeration

[image]

IceLib Technical Reference
InteractionSnapshotDirection Enumeration
See Also Send Feedback
Represents an interaction's direction.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionSnapshotDirection
Visual Basic
Public Enumeration InteractionSnapshotDirection

Members

Member name | Value | Description
Unknown | 0 | Unknown interaction direction.
Inbound | 1 | An inbound interaction.
Outbound | 2 | An outbound interaction.
Intercom | 3 | An intercom interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotDisposition Enumeration

[image]

IceLib Technical Reference
InteractionSnapshotDisposition Enumeration
See Also Send Feedback
Represents an interaction's disposition.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionSnapshotDisposition
Visual Basic
Public Enumeration InteractionSnapshotDisposition

Members

Member name | Value | Description
Unknown | 0 | An unknown disposition.
NeverConnected | 1 | The interaction was never connected.
RemoteDisconnectDuringDelaySegment | 2 | The interaction was disconnected by the remote party during the delay segment.
LocalDisconnectDuringDelaySegment | 3 | The interaction was disconnected by the local party during the delay segment.
RemoteDisconnectDuringAlertSegment | 4 | The interaction was disconnected by the remote party during the alert segment.
LocalDisconnectDuringAlertSegment | 5 | The interaction was disconnected by the local party during the alert segment.
RemoteDisconnectDuringConnectSegment | 6 | The interaction was disconnected by the remote party during the connect segment.
LocalDisconnectDuringConnectSegment | 7 | The interaction was disconnected by the local party during the connect segment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotMediaType Enumeration

[image]

IceLib Technical Reference
InteractionSnapshotMediaType Enumeration
See Also Send Feedback
Represents and interaction's media type.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionSnapshotMediaType
Visual Basic
Public Enumeration InteractionSnapshotMediaType

Members

Member name | Value | Description
Invalid | 0 | An invalid media type.
Call | 1 | A call interaction.
Chat | 2 | A chat interaction.
Sms | 3 | An SMS interaction.
Generic | 4 | A generic interaction.
Email | 5 | An email interaction.
Callback | 6 | A callback interaction.
InstantQuestion | 7 | An instant question interaction.
WebCollaboration | 8 | A web collaboration interaction.
Fax | 9 | A fax interaction.
WorkflowItemObject | 10 | A workflow item object for an IPA interaction.
MonitoredObject | 11 | A Monitored object for an interaction.
SocialConversation | 12 | A social media conversation object.
SocialDirectMessage | 13 | A social media directmessage object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotResults Class

[image]

IceLib Technical Reference
InteractionSnapshotResults Class
Members See Also Send Feedback
Represents the results retrieved from GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionSnapshotResults
Visual Basic
Public Class InteractionSnapshotResults

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions..::..InteractionSnapshotResults

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotResults Members
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotResults Members

[image] [image]

IceLib Technical Reference
InteractionSnapshotResults Members
InteractionSnapshotResults Class Methods Properties See Also Send Feedback

The InteractionSnapshotResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionSnapshots | Gets the interaction snapshots matching the filter criteria, limited to the number of rows specified by the MaxRowsFilter.
Public property | TotalCount | Gets the count of interaction snapshots matching all filter criteria except MaxRowsFilter. This can be used for determining if filter criteria needs to be refined to retrieve the desired results.

See Also

InteractionSnapshotResults Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotResults Methods

[image] [image]

IceLib Technical Reference
InteractionSnapshotResults Methods
InteractionSnapshotResults Class See Also Send Feedback

The InteractionSnapshotResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSnapshotResults Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshotResults Properties

[image] [image]

IceLib Technical Reference
InteractionSnapshotResults Properties
InteractionSnapshotResults Class See Also Send Feedback

The InteractionSnapshotResults type exposes the following members.

Properties

 | Name | Description
Public property | InteractionSnapshots | Gets the interaction snapshots matching the filter criteria, limited to the number of rows specified by the MaxRowsFilter.
Public property | TotalCount | Gets the count of interaction snapshots matching all filter criteria except MaxRowsFilter. This can be used for determining if filter criteria needs to be refined to retrieve the desired results.

See Also

InteractionSnapshotResults Class
ININ.IceLib.Reporting.Interactions Namespace


InteractionSnapshots Property

[image]

IceLib Technical Reference
InteractionSnapshotResults..::..InteractionSnapshots Property
InteractionSnapshotResults Class See Also Send Feedback
Gets the interaction snapshots matching the filter criteria, limited to the number of rows specified by the MaxRowsFilter.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionSnapshot> InteractionSnapshots { get; private set; }
Visual Basic
Public Property InteractionSnapshots As ReadOnlyCollection(Of InteractionSnapshot)
    Get
    Private Set

Field Value

The interaction snapshots.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotResults Class
InteractionSnapshotResults Members
ININ.IceLib.Reporting.Interactions Namespace


TotalCount Property

[image]

IceLib Technical Reference
InteractionSnapshotResults..::..TotalCount Property
InteractionSnapshotResults Class See Also Send Feedback
Gets the count of interaction snapshots matching all filter criteria except MaxRowsFilter. This can be used for determining if filter criteria needs to be refined to retrieve the desired results.

Namespace: ININ.IceLib.Reporting.Interactions
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TotalCount { get; private set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Private Set

Field Value

The count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotResults Class
InteractionSnapshotResults Members
ININ.IceLib.Reporting.Interactions Namespace


ININ.IceLib.Reporting.Interactions.Details Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Reporting.Interactions.Details Namespace
Send Feedback

The ININ.IceLib.Reporting.Interactions.Details namespace contains classes that provide a more detailed breakdown of the InteractionSnapshot.

Classes

 | Class | Description
Public class | ConferenceParty | Represents a conference party in an interaction.
Public class | Interaction | This class represents the snapshot of an interaction at a point in time. It provides a more detailed breakdown of an InteractionSnapshot.
Public class | InteractionEvent | Represents an event that occurs within an interaction. An event has a time, but no duration.
Public class | InteractionSegment | Represents a segment that occurred during an interaction.
Public class | InteractionSegmentParameterValue | Represents a parameter, including type, raw value, and display value.
Public class | LocalParty | Represents a local party in an interaction.

Enumerations

 | Enumeration | Description
Public enumeration | DispositionType | Represents the disposition of an interaction.
Public enumeration | InteractionDirection | Represents the direction of the interaction.
Public enumeration | InteractionEventType | The type of an event that occurred within an interaction.
Public enumeration | InteractionSegmentParameterType | Represents the type of a parameter. This is used to map the values from the server into strongly typed values.
Public enumeration | InteractionSegmentType | Represents the type of the interaction segment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.


ConferenceParty Class

[image]

IceLib Technical Reference
ConferenceParty Class
Members See Also Send Feedback
Represents a conference party in an interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ConferenceParty
Visual Basic
Public Class ConferenceParty

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Details..::..ConferenceParty

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConferenceParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ConferenceParty Members

[image] [image]

IceLib Technical Reference
ConferenceParty Members
ConferenceParty Class Constructors Methods Properties See Also Send Feedback

The ConferenceParty type exposes the following members.

Constructors

 | Name | Description
Public method | ConferenceParty | Initializes a new instance of the ConferenceParty class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsExternal | Gets a value indicating whether the conference party is external.
Public property | Name | Gets the name.
Public property | UserId | Gets the user ID.

See Also

ConferenceParty Class
ININ.IceLib.Reporting.Interactions.Details Namespace


ConferenceParty Constructor

[image]

IceLib Technical Reference
ConferenceParty Constructor
ConferenceParty Class See Also Send Feedback
Initializes a new instance of the ConferenceParty class

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ConferenceParty()
Visual Basic
Public Sub New

See Also

ConferenceParty Class
ConferenceParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ConferenceParty Methods

[image] [image]

IceLib Technical Reference
ConferenceParty Methods
ConferenceParty Class See Also Send Feedback

The ConferenceParty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConferenceParty Class
ININ.IceLib.Reporting.Interactions.Details Namespace


ConferenceParty Properties

[image] [image]

IceLib Technical Reference
ConferenceParty Properties
ConferenceParty Class See Also Send Feedback

The ConferenceParty type exposes the following members.

Properties

 | Name | Description
Public property | IsExternal | Gets a value indicating whether the conference party is external.
Public property | Name | Gets the name.
Public property | UserId | Gets the user ID.

See Also

ConferenceParty Class
ININ.IceLib.Reporting.Interactions.Details Namespace


IsExternal Property

[image]

IceLib Technical Reference
ConferenceParty..::..IsExternal Property
ConferenceParty Class See Also Send Feedback
Gets a value indicating whether the conference party is external.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsExternal { get; }
Visual Basic
Public ReadOnly Property IsExternal As Boolean
    Get

Field Value

true if the conference party is external; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConferenceParty Class
ConferenceParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Name Property

[image]

IceLib Technical Reference
ConferenceParty..::..Name Property
ConferenceParty Class See Also Send Feedback
Gets the name.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConferenceParty Class
ConferenceParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


UserId Property

[image]

IceLib Technical Reference
ConferenceParty..::..UserId Property
ConferenceParty Class See Also Send Feedback
Gets the user ID.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; }
Visual Basic
Public ReadOnly Property UserId As String
    Get

Field Value

The user ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ConferenceParty Class
ConferenceParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


DispositionType Enumeration

[image]

IceLib Technical Reference
DispositionType Enumeration
See Also Send Feedback
Represents the disposition of an interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum DispositionType
Visual Basic
Public Enumeration DispositionType

Members

Member name | Value | Description
Unknown | 0 | Unknown disposition type.
NeverConnected | 1 | The interaction was never connected.
RemoteDisconnectDuringDelaySegment | 2 | The interaction was disconnected remotely during the delay segment.
LocalDisconnectDuringDelaySegment | 3 | The interaction was disconnected locally during the delay segment.
RemoteDisconnectDuringAlertSegment | 4 | The interaction was disconnected remotely during the alert segment.
LocalDisconnectDuringAlertSegment | 5 | The interaction was disconnected locally during the alert segment.
RemoteDisconnectDuringConnectSegment | 6 | The interaction was disconnected remotely during the connect segment.
LocalDisconnectDuringConnectSegment | 7 | The interaction was disconnected locally during the connect segment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Class

[image]

IceLib Technical Reference
Interaction Class
Members See Also Send Feedback
This class represents the snapshot of an interaction at a point in time. It provides a more detailed breakdown of an InteractionSnapshot.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Interaction
Visual Basic
Public Class Interaction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Details..::..Interaction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Members

[image] [image]

IceLib Technical Reference
Interaction Members
Interaction Class Constructors Methods Properties See Also Send Feedback

The Interaction type exposes the following members.

Constructors

 | Name | Description
Public method | Interaction | Initializes a new instance of the Interaction class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceParties | Gets the conference parties.
Public property | Direction | Gets the interaction direction. See InteractionDirection for the legal values.
Public property | DispositionType | Gets the disposition for the interaction.
Public property | Events | Gets the events.
Public property | InteractionId | Gets the Interaction ID.
Public property | InteractionIdKey | Gets the interaction ID key.
Public property | LocalParties | Gets the local parties.
Public property | MediaType | Gets the media type for the interaction.
Public property | Parameters | Gets the parameterized values of the interaction.
Public property | Segments | Gets the segments.
Public property | SequenceNumber | Gets the sequence number.
Public property | SiteId | Gets the site ID.
Public property | UtcTime | Gets the time of the interaction in UTC.

See Also

Interaction Class
ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Constructor

[image]

IceLib Technical Reference
Interaction Constructor
Interaction Class See Also Send Feedback
Initializes a new instance of the Interaction class.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction(
    InteractionSnapshot interactionSnapshot
)
Visual Basic
Public Sub New ( _
    interactionSnapshot As InteractionSnapshot _
)

Parameters

interactionSnapshot
Type: ININ.IceLib.Reporting.Interactions..::..InteractionSnapshot

Exceptions

Exception | Condition
 | interactionSnapshot is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Methods

[image] [image]

IceLib Technical Reference
Interaction Methods
Interaction Class See Also Send Feedback

The Interaction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Interaction Class
ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Properties

[image] [image]

IceLib Technical Reference
Interaction Properties
Interaction Class See Also Send Feedback

The Interaction type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceParties | Gets the conference parties.
Public property | Direction | Gets the interaction direction. See InteractionDirection for the legal values.
Public property | DispositionType | Gets the disposition for the interaction.
Public property | Events | Gets the events.
Public property | InteractionId | Gets the Interaction ID.
Public property | InteractionIdKey | Gets the interaction ID key.
Public property | LocalParties | Gets the local parties.
Public property | MediaType | Gets the media type for the interaction.
Public property | Parameters | Gets the parameterized values of the interaction.
Public property | Segments | Gets the segments.
Public property | SequenceNumber | Gets the sequence number.
Public property | SiteId | Gets the site ID.
Public property | UtcTime | Gets the time of the interaction in UTC.

See Also

Interaction Class
ININ.IceLib.Reporting.Interactions.Details Namespace


ConferenceParties Property

[image]

IceLib Technical Reference
Interaction..::..ConferenceParties Property
Interaction Class See Also Send Feedback
Gets the conference parties.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<ConferenceParty> ConferenceParties { get; }
Visual Basic
Public ReadOnly Property ConferenceParties As IEnumerable(Of ConferenceParty)
    Get

Field Value

The conference parties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Direction Property

[image]

IceLib Technical Reference
Interaction..::..Direction Property
Interaction Class See Also Send Feedback
Gets the interaction direction. See InteractionDirection for the legal values.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotDirection Direction { get; }
Visual Basic
Public ReadOnly Property Direction As InteractionSnapshotDirection
    Get

Field Value

The direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


DispositionType Property

[image]

IceLib Technical Reference
Interaction..::..DispositionType Property
Interaction Class See Also Send Feedback
Gets the disposition for the interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotDisposition DispositionType { get; }
Visual Basic
Public ReadOnly Property DispositionType As InteractionSnapshotDisposition
    Get

Field Value

The type of the disposition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Events Property

[image]

IceLib Technical Reference
Interaction..::..Events Property
Interaction Class See Also Send Feedback
Gets the events.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<InteractionEvent> Events { get; }
Visual Basic
Public ReadOnly Property Events As IEnumerable(Of InteractionEvent)
    Get

Field Value

The events.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionId Property

[image]

IceLib Technical Reference
Interaction..::..InteractionId Property
Interaction Class See Also Send Feedback
Gets the Interaction ID.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionId { get; }
Visual Basic
Public ReadOnly Property InteractionId As String
    Get

Field Value

The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionIdKey Property

[image]

IceLib Technical Reference
Interaction..::..InteractionIdKey Property
Interaction Class See Also Send Feedback
Gets the interaction ID key.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionIdKey { get; }
Visual Basic
Public ReadOnly Property InteractionIdKey As String
    Get

Field Value

The interaction ID key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParties Property

[image]

IceLib Technical Reference
Interaction..::..LocalParties Property
Interaction Class See Also Send Feedback
Gets the local parties.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<LocalParty> LocalParties { get; }
Visual Basic
Public ReadOnly Property LocalParties As IEnumerable(Of LocalParty)
    Get

Field Value

The local parties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


MediaType Property

[image]

IceLib Technical Reference
Interaction..::..MediaType Property
Interaction Class See Also Send Feedback
Gets the media type for the interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSnapshotMediaType MediaType { get; }
Visual Basic
Public ReadOnly Property MediaType As InteractionSnapshotMediaType
    Get

Field Value

The type of the media.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Parameters Property

[image]

IceLib Technical Reference
Interaction..::..Parameters Property
Interaction Class See Also Send Feedback
Gets the parameterized values of the interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<KeyValuePair<string, string>> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As IEnumerable(Of KeyValuePair(Of String, String))
    Get

Field Value

The parameterized values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Segments Property

[image]

IceLib Technical Reference
Interaction..::..Segments Property
Interaction Class See Also Send Feedback
Gets the segments.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<InteractionSegment> Segments { get; }
Visual Basic
Public ReadOnly Property Segments As IEnumerable(Of InteractionSegment)
    Get

Field Value

The segments.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


SequenceNumber Property

[image]

IceLib Technical Reference
Interaction..::..SequenceNumber Property
Interaction Class See Also Send Feedback
Gets the sequence number.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SequenceNumber { get; }
Visual Basic
Public ReadOnly Property SequenceNumber As Integer
    Get

Field Value

The sequence number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


SiteId Property

[image]

IceLib Technical Reference
Interaction..::..SiteId Property
Interaction Class See Also Send Feedback
Gets the site ID.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SiteId { get; }
Visual Basic
Public ReadOnly Property SiteId As Integer
    Get

Field Value

The site ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


UtcTime Property

[image]

IceLib Technical Reference
Interaction..::..UtcTime Property
Interaction Class See Also Send Feedback
Gets the time of the interaction in UTC.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime UtcTime { get; }
Visual Basic
Public ReadOnly Property UtcTime As DateTime
    Get

Field Value

The time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

Interaction Class
Interaction Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionDirection Enumeration

[image]

IceLib Technical Reference
InteractionDirection Enumeration
See Also Send Feedback
Represents the direction of the interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionDirection
Visual Basic
Public Enumeration InteractionDirection

Members

Member name | Value | Description
Unknown | 0 | Represents an unknown interaction direction.
Inbound | 1 | Represents an inbound interaction direction.
Outbound | 2 | Represents an outbound interaction direction.
Intercom | 3 | Represents an intercom interaction direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionEvent Class

[image]

IceLib Technical Reference
InteractionEvent Class
Members See Also Send Feedback
Represents an event that occurs within an interaction. An event has a time, but no duration.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionEvent
Visual Basic
Public Class InteractionEvent

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Details..::..InteractionEvent

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionEvent Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionEvent Members

[image] [image]

IceLib Technical Reference
InteractionEvent Members
InteractionEvent Class Methods Properties See Also Send Feedback

The InteractionEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventType | Gets the type of the event.
Public property | Name | Gets the name of the event. This is a display name and may provide more detail than just the event type.
Public property | TimeFromInteractionStart | Gets the relative time the event started based on when the interaction started. This is in milliseconds.

See Also

InteractionEvent Class
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionEvent Methods

[image] [image]

IceLib Technical Reference
InteractionEvent Methods
InteractionEvent Class See Also Send Feedback

The InteractionEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionEvent Class
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionEvent Properties

[image] [image]

IceLib Technical Reference
InteractionEvent Properties
InteractionEvent Class See Also Send Feedback

The InteractionEvent type exposes the following members.

Properties

 | Name | Description
Public property | EventType | Gets the type of the event.
Public property | Name | Gets the name of the event. This is a display name and may provide more detail than just the event type.
Public property | TimeFromInteractionStart | Gets the relative time the event started based on when the interaction started. This is in milliseconds.

See Also

InteractionEvent Class
ININ.IceLib.Reporting.Interactions.Details Namespace


EventType Property

[image]

IceLib Technical Reference
InteractionEvent..::..EventType Property
InteractionEvent Class See Also Send Feedback
Gets the type of the event.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionEventType EventType { get; private set; }
Visual Basic
Public Property EventType As InteractionEventType
    Get
    Private Set

Field Value

The type of the event.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionEvent Class
InteractionEvent Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Name Property

[image]

IceLib Technical Reference
InteractionEvent..::..Name Property
InteractionEvent Class See Also Send Feedback
Gets the name of the event. This is a display name and may provide more detail than just the event type.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionEvent Class
InteractionEvent Members
ININ.IceLib.Reporting.Interactions.Details Namespace


TimeFromInteractionStart Property

[image]

IceLib Technical Reference
InteractionEvent..::..TimeFromInteractionStart Property
InteractionEvent Class See Also Send Feedback
Gets the relative time the event started based on when the interaction started. This is in milliseconds.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TimeFromInteractionStart { get; private set; }
Visual Basic
Public Property TimeFromInteractionStart As Integer
    Get
    Private Set

Field Value

The time from interaction start.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionEvent Class
InteractionEvent Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionEventType Enumeration

[image]

IceLib Technical Reference
InteractionEventType Enumeration
See Also Send Feedback
The type of an event that occurred within an interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionEventType
Visual Basic
Public Enumeration InteractionEventType

Members

Member name | Value | Description
Unknown | 0 | An unknown event type
LocalTransfer | 1 | A transfer to a local party.
RemoteTransfer | 2 | A transfer to a remote party.
CallbackSnooze | 3 | A callback snooze event.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegment Class

[image]

IceLib Technical Reference
InteractionSegment Class
Members See Also Send Feedback
Represents a segment that occurred during an interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionSegment
Visual Basic
Public Class InteractionSegment

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Details..::..InteractionSegment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegment Members

[image] [image]

IceLib Technical Reference
InteractionSegment Members
InteractionSegment Class Constructors Methods Properties See Also Send Feedback

The InteractionSegment type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionSegment | Initializes a new instance of the InteractionSegment class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClientTime | Gets the time this segment began according to the client.
Public property | ClientTimeAsDateTimeString | Gets the client time as a formatted date time string in the local timezone.
Public property | ConferenceParties | Gets the conference parties involved in this segment.
Public property | Duration | Gets the duration of this segment in milliseconds.
Public property | DurationAsString | Gets the duration as a formatted string "HH:MM:SS".
Public property | EndCode | Gets the end code.
Public property | EndCodeValue | Gets the end code value
Public property | HasWrapupCode | Gets a value indicating whether this instance has a wrapup code.
Public property | Interaction | Gets the interaction this segment belongs to.
Public property | LocalParties | Gets the local parties involved in this segment.
Public property | Parameters | Gets the parameters.
Public property | ServerTime | Gets the time this segment began according to the server.
Public property | ServerTimeAsDateTimeString | Gets the server time as a formatted date time string in the local timezone.
Public property | Type | Gets the segment type.
Public property | Workgroup | Gets the workgroup.
Public property | WrapupCode | Gets the wrapup code.

See Also

InteractionSegment Class
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegment Constructor

[image]

IceLib Technical Reference
InteractionSegment Constructor
InteractionSegment Class See Also Send Feedback
Initializes a new instance of the InteractionSegment class.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegment(
    Interaction interaction,
    InteractionSegmentType type,
    DateTime serverTime,
    IEnumerable<InteractionSegmentParameterValue> parameters
)
Visual Basic
Public Sub New ( _
    interaction As Interaction, _
    type As InteractionSegmentType, _
    serverTime As DateTime, _
    parameters As IEnumerable(Of InteractionSegmentParameterValue) _
)

Parameters

interaction
Type: ININ.IceLib.Reporting.Interactions.Details..::..Interaction
The interaction.
type
Type: ININ.IceLib.Reporting.Interactions.Details..::..InteractionSegmentType
The segment type.
serverTime
Type: System..::..DateTime
The server time.
parameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' InteractionSegmentParameterValue >)>)>
The parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegment Methods

[image] [image]

IceLib Technical Reference
InteractionSegment Methods
InteractionSegment Class See Also Send Feedback

The InteractionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSegment Class
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegment Properties

[image] [image]

IceLib Technical Reference
InteractionSegment Properties
InteractionSegment Class See Also Send Feedback

The InteractionSegment type exposes the following members.

Properties

 | Name | Description
Public property | ClientTime | Gets the time this segment began according to the client.
Public property | ClientTimeAsDateTimeString | Gets the client time as a formatted date time string in the local timezone.
Public property | ConferenceParties | Gets the conference parties involved in this segment.
Public property | Duration | Gets the duration of this segment in milliseconds.
Public property | DurationAsString | Gets the duration as a formatted string "HH:MM:SS".
Public property | EndCode | Gets the end code.
Public property | EndCodeValue | Gets the end code value
Public property | HasWrapupCode | Gets a value indicating whether this instance has a wrapup code.
Public property | Interaction | Gets the interaction this segment belongs to.
Public property | LocalParties | Gets the local parties involved in this segment.
Public property | Parameters | Gets the parameters.
Public property | ServerTime | Gets the time this segment began according to the server.
Public property | ServerTimeAsDateTimeString | Gets the server time as a formatted date time string in the local timezone.
Public property | Type | Gets the segment type.
Public property | Workgroup | Gets the workgroup.
Public property | WrapupCode | Gets the wrapup code.

See Also

InteractionSegment Class
ININ.IceLib.Reporting.Interactions.Details Namespace


ClientTime Property

[image]

IceLib Technical Reference
InteractionSegment..::..ClientTime Property
InteractionSegment Class See Also Send Feedback
Gets the time this segment began according to the client.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime ClientTime { get; }
Visual Basic
Public ReadOnly Property ClientTime As DateTime
    Get

Field Value

The client time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ClientTimeAsDateTimeString Property

[image]

IceLib Technical Reference
InteractionSegment..::..ClientTimeAsDateTimeString Property
InteractionSegment Class See Also Send Feedback
Gets the client time as a formatted date time string in the local timezone.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ClientTimeAsDateTimeString { get; }
Visual Basic
Public ReadOnly Property ClientTimeAsDateTimeString As String
    Get

Field Value

The client time as date time string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ConferenceParties Property

[image]

IceLib Technical Reference
InteractionSegment..::..ConferenceParties Property
InteractionSegment Class See Also Send Feedback
Gets the conference parties involved in this segment.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<ConferenceParty> ConferenceParties { get; private set; }
Visual Basic
Public Property ConferenceParties As IEnumerable(Of ConferenceParty)
    Get
    Private Set

Field Value

The conference parties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Duration Property

[image]

IceLib Technical Reference
InteractionSegment..::..Duration Property
InteractionSegment Class See Also Send Feedback
Gets the duration of this segment in milliseconds.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Duration { get; }
Visual Basic
Public ReadOnly Property Duration As Integer
    Get

Field Value

The duration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


DurationAsString Property

[image]

IceLib Technical Reference
InteractionSegment..::..DurationAsString Property
InteractionSegment Class See Also Send Feedback
Gets the duration as a formatted string "HH:MM:SS".

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DurationAsString { get; }
Visual Basic
Public ReadOnly Property DurationAsString As String
    Get

Field Value

The duration as a string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


EndCode Property

[image]

IceLib Technical Reference
InteractionSegment..::..EndCode Property
InteractionSegment Class See Also Send Feedback
Gets the end code.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EndCode { get; }
Visual Basic
Public ReadOnly Property EndCode As String
    Get

Field Value

The end code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


EndCodeValue Property

[image]

IceLib Technical Reference
InteractionSegment..::..EndCodeValue Property
InteractionSegment Class See Also Send Feedback
Gets the end code value

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EndCodeValue { get; }
Visual Basic
Public ReadOnly Property EndCodeValue As String
    Get

Field Value

The end code value

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


HasWrapupCode Property

[image]

IceLib Technical Reference
InteractionSegment..::..HasWrapupCode Property
InteractionSegment Class See Also Send Feedback
Gets a value indicating whether this instance has a wrapup code.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasWrapupCode { get; }
Visual Basic
Public ReadOnly Property HasWrapupCode As Boolean
    Get

Field Value

true if this instance has wrapup code; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Property

[image]

IceLib Technical Reference
InteractionSegment..::..Interaction Property
InteractionSegment Class See Also Send Feedback
Gets the interaction this segment belongs to.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; private set; }
Visual Basic
Public Property Interaction As Interaction
    Get
    Private Set

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParties Property

[image]

IceLib Technical Reference
InteractionSegment..::..LocalParties Property
InteractionSegment Class See Also Send Feedback
Gets the local parties involved in this segment.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<LocalParty> LocalParties { get; private set; }
Visual Basic
Public Property LocalParties As IEnumerable(Of LocalParty)
    Get
    Private Set

Field Value

The local parties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Parameters Property

[image]

IceLib Technical Reference
InteractionSegment..::..Parameters Property
InteractionSegment Class See Also Send Feedback
Gets the parameters.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionSegmentParameterValue> Parameters { get; private set; }
Visual Basic
Public Property Parameters As ReadOnlyCollection(Of InteractionSegmentParameterValue)
    Get
    Private Set

Field Value

The parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ServerTime Property

[image]

IceLib Technical Reference
InteractionSegment..::..ServerTime Property
InteractionSegment Class See Also Send Feedback
Gets the time this segment began according to the server.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime ServerTime { get; private set; }
Visual Basic
Public Property ServerTime As DateTime
    Get
    Private Set

Field Value

The server time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ServerTimeAsDateTimeString Property

[image]

IceLib Technical Reference
InteractionSegment..::..ServerTimeAsDateTimeString Property
InteractionSegment Class See Also Send Feedback
Gets the server time as a formatted date time string in the local timezone.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ServerTimeAsDateTimeString { get; }
Visual Basic
Public ReadOnly Property ServerTimeAsDateTimeString As String
    Get

Field Value

The server time as date time string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Type Property

[image]

IceLib Technical Reference
InteractionSegment..::..Type Property
InteractionSegment Class See Also Send Feedback
Gets the segment type.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegmentType Type { get; private set; }
Visual Basic
Public Property Type As InteractionSegmentType
    Get
    Private Set

Field Value

The type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Workgroup Property

[image]

IceLib Technical Reference
InteractionSegment..::..Workgroup Property
InteractionSegment Class See Also Send Feedback
Gets the workgroup.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; }
Visual Basic
Public ReadOnly Property Workgroup As String
    Get

Field Value

The workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


WrapupCode Property

[image]

IceLib Technical Reference
InteractionSegment..::..WrapupCode Property
InteractionSegment Class See Also Send Feedback
Gets the wrapup code.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WrapupCode { get; }
Visual Basic
Public ReadOnly Property WrapupCode As String
    Get

Field Value

The wrapup code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentParameterType Enumeration

[image]

IceLib Technical Reference
InteractionSegmentParameterType Enumeration
See Also Send Feedback
Represents the type of a parameter. This is used to map the values from the server into strongly typed values.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionSegmentParameterType
Visual Basic
Public Enumeration InteractionSegmentParameterType

Members

Member name | Value | Description
Unknown | 0 | Unknown parameter type.
ClientUtc | 1 | Client time in UTC parameter type.
InteractionKey | 2 | Interaction Key parameter type.
SegmentSequence | 3 | Segment Sequence number parameter type.
Duration | 4 | Duration parameter type.
LocalParty | 5 | Local Party parameter type.
Queue | 6 | Queue parameter type.
EndCode | 7 | End Code parameter type.
Details | 8 | Details parameter type.
WrapupCode | 9 | Wrapup Code parameter type.
WrapupSegmentNumber | 10 | Wrapup Segment Number parameter type.
RemoteAddress | 11 | Remote Address parameter type.
RemoteName | 12 | Remote Name parameter type.
AlertParties | 13 | Alert Parties parameter type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentParameterValue Class

[image]

IceLib Technical Reference
InteractionSegmentParameterValue Class
Members See Also Send Feedback
Represents a parameter, including type, raw value, and display value.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionSegmentParameterValue
Visual Basic
Public Class InteractionSegmentParameterValue

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Details..::..InteractionSegmentParameterValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegmentParameterValue Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentParameterValue Members

[image] [image]

IceLib Technical Reference
InteractionSegmentParameterValue Members
InteractionSegmentParameterValue Class Constructors Methods Properties See Also Send Feedback

The InteractionSegmentParameterValue type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionSegmentParameterValue | Initializes a new instance of the InteractionSegmentParameterValue class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayValue | Gets the display value.
Public property | ParameterType | Gets the type of the parameter.
Public property | Value | Gets the value.

See Also

InteractionSegmentParameterValue Class
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentParameterValue Constructor

[image]

IceLib Technical Reference
InteractionSegmentParameterValue Constructor
InteractionSegmentParameterValue Class See Also Send Feedback
Initializes a new instance of the InteractionSegmentParameterValue class.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegmentParameterValue(
    InteractionSegmentParameterType parameterType,
    string value,
    string displayValue
)
Visual Basic
Public Sub New ( _
    parameterType As InteractionSegmentParameterType, _
    value As String, _
    displayValue As String _
)

Parameters

parameterType
Type: ININ.IceLib.Reporting.Interactions.Details..::..InteractionSegmentParameterType
Type of the parameter.
value
Type: System..::..String
The value.
displayValue
Type: System..::..String
The display value.

Exceptions

Exception | Condition
 | parameterType or value is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegmentParameterValue Class
InteractionSegmentParameterValue Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentParameterValue Methods

[image] [image]

IceLib Technical Reference
InteractionSegmentParameterValue Methods
InteractionSegmentParameterValue Class See Also Send Feedback

The InteractionSegmentParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSegmentParameterValue Class
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentParameterValue Properties

[image] [image]

IceLib Technical Reference
InteractionSegmentParameterValue Properties
InteractionSegmentParameterValue Class See Also Send Feedback

The InteractionSegmentParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | DisplayValue | Gets the display value.
Public property | ParameterType | Gets the type of the parameter.
Public property | Value | Gets the value.

See Also

InteractionSegmentParameterValue Class
ININ.IceLib.Reporting.Interactions.Details Namespace


DisplayValue Property

[image]

IceLib Technical Reference
InteractionSegmentParameterValue..::..DisplayValue Property
InteractionSegmentParameterValue Class See Also Send Feedback
Gets the display value.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayValue { get; private set; }
Visual Basic
Public Property DisplayValue As String
    Get
    Private Set

Field Value

The display value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegmentParameterValue Class
InteractionSegmentParameterValue Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ParameterType Property

[image]

IceLib Technical Reference
InteractionSegmentParameterValue..::..ParameterType Property
InteractionSegmentParameterValue Class See Also Send Feedback
Gets the type of the parameter.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegmentParameterType ParameterType { get; private set; }
Visual Basic
Public Property ParameterType As InteractionSegmentParameterType
    Get
    Private Set

Field Value

The type of the parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegmentParameterValue Class
InteractionSegmentParameterValue Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Value Property

[image]

IceLib Technical Reference
InteractionSegmentParameterValue..::..Value Property
InteractionSegmentParameterValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; private set; }
Visual Basic
Public Property Value As String
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

InteractionSegmentParameterValue Class
InteractionSegmentParameterValue Members
ININ.IceLib.Reporting.Interactions.Details Namespace


InteractionSegmentType Enumeration

[image]

IceLib Technical Reference
InteractionSegmentType Enumeration
See Also Send Feedback
Represents the type of the interaction segment.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionSegmentType
Visual Basic
Public Enumeration InteractionSegmentType

Members

Member name | Value | Description
Unknown | 0 | Unknown segment type.
Ivr | 1 | IVR segment type.
System | 2 | System segment type.
Delay | 3 | Delay segment type.
Alert | 4 | Alert segment type.
Connect | 5 | Connect segment type.
Hold | 6 | Hold segment type.
Suspend | 7 | Suspend segment type.
Consult | 8 | Consult segment type.
Conference | 9 | Conference segment type.
ExternalTransfer | 10 | External Transfer segment type.
Acw | 11 | ACW segment type.
Messaging | 12 | Messaging segment type.
Dialing | 13 | Dialing segment type.
Park | 14 | Park segment type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParty Class

[image]

IceLib Technical Reference
LocalParty Class
Members See Also Send Feedback
Represents a local party in an interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocalParty
Visual Basic
Public Class LocalParty

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Details..::..LocalParty

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

LocalParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParty Members

[image] [image]

IceLib Technical Reference
LocalParty Members
LocalParty Class Constructors Methods Properties See Also Send Feedback

The LocalParty type exposes the following members.

Constructors

 | Name | Description
Public method | LocalParty | Initializes a new instance of the LocalParty class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the interaction.
Public property | Name | Gets the name of the local party, as provided by the server.
Public property | Segments | Gets the segments of the interaction this local party participated in.

See Also

LocalParty Class
ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParty Constructor

[image]

IceLib Technical Reference
LocalParty Constructor
LocalParty Class See Also Send Feedback
Initializes a new instance of the LocalParty class

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocalParty()
Visual Basic
Public Sub New

See Also

LocalParty Class
LocalParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParty Methods

[image] [image]

IceLib Technical Reference
LocalParty Methods
LocalParty Class See Also Send Feedback

The LocalParty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocalParty Class
ININ.IceLib.Reporting.Interactions.Details Namespace


LocalParty Properties

[image] [image]

IceLib Technical Reference
LocalParty Properties
LocalParty Class See Also Send Feedback

The LocalParty type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the interaction.
Public property | Name | Gets the name of the local party, as provided by the server.
Public property | Segments | Gets the segments of the interaction this local party participated in.

See Also

LocalParty Class
ININ.IceLib.Reporting.Interactions.Details Namespace


Interaction Property

[image]

IceLib Technical Reference
LocalParty..::..Interaction Property
LocalParty Class See Also Send Feedback
Gets the interaction.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Interaction Interaction { get; private set; }
Visual Basic
Public Property Interaction As Interaction
    Get
    Private Set

Field Value

The interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

LocalParty Class
LocalParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Name Property

[image]

IceLib Technical Reference
LocalParty..::..Name Property
LocalParty Class See Also Send Feedback
Gets the name of the local party, as provided by the server.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

LocalParty Class
LocalParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


Segments Property

[image]

IceLib Technical Reference
LocalParty..::..Segments Property
LocalParty Class See Also Send Feedback
Gets the segments of the interaction this local party participated in.

Namespace: ININ.IceLib.Reporting.Interactions.Details
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionSegment> Segments { get; }
Visual Basic
Public ReadOnly Property Segments As ReadOnlyCollection(Of InteractionSegment)
    Get

Field Value

The segments.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

LocalParty Class
LocalParty Members
ININ.IceLib.Reporting.Interactions.Details Namespace


ININ.IceLib.Reporting.Interactions.Filters Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Reporting.Interactions.Filters Namespace
Send Feedback

The ININ.IceLib.Reporting.Interactions.Filters namespace contains classes that provide support for filtering interaction snapshot's via GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Classes

 | Class | Description
Public class | AniFilter | Represents criteria used to filter on an interaction's ANI. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | DateTimeRangeFilter | Represents criteria used to filter on whether an interaction's intiation time falls within a datetime range. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | DirectionFilter | Represents criteria used to filter on an interaction's direction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | DnisFilter | Represents criteria used to filter on an interaction's DNIS. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | InteractionIdFilter | Represents criteria used to filter on an interaction's ID. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | InteractionSnapshotFilter | Represents criteria used to filter on an interaction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | LastICUserNameFilter | Represents criteria used to filter on the last IC username involved in an interaction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | LastWorkgroupFilter | Represents criteria used to filter on the last workgroup involved in an interaction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | LineDurationFilter | Represents criteria used to filter on whether an interaction's line duration falls within a specified range of timespans. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | MaxRowsFilter | Used to limit the number to rows returned for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | MediaTypeFilter | Represents criteria used to filter whether an interaction's media type is one of the provided media types. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).
Public class | MultipleValueFilter<(Of <(<'TValueType>)>)> | Holds information on a multiple value filter for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)). This filter will return records that match any of the supplied values. See the following (and other) implementations:
Public class | RangeValueFilter<(Of <(<'TValueType>)>)> | Holds information on a range value filter for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)). See the following (and other) implementations:
Public class | SingleValueFilter<(Of <(<'TValueType>)>)> | Holds information on a single value filter for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)). See the following (and other) implementations:
Public class | SiteIdFilter | Represents criteria used to filter on an interaction's site ID. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


AniFilter Class

[image]

IceLib Technical Reference
AniFilter Class
Members See Also Send Feedback
Represents criteria used to filter on an interaction's ANI. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AniFilter : SingleValueFilter<string>
Visual Basic
Public Class AniFilter _
    Inherits SingleValueFilter(Of String)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'String>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..AniFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AniFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


AniFilter Members

[image] [image]

IceLib Technical Reference
AniFilter Members
AniFilter Class Constructors Methods Properties See Also Send Feedback

The AniFilter type exposes the following members.

Constructors

 | Name | Description
Public method | AniFilter | Initializes a new instance of the AniFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

AniFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


AniFilter Constructor

[image]

IceLib Technical Reference
AniFilter Constructor
AniFilter Class See Also Send Feedback
Initializes a new instance of the AniFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AniFilter(
    string ani
)
Visual Basic
Public Sub New ( _
    ani As String _
)

Parameters

ani
Type: System..::..String
The ANI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AniFilter Class
AniFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


AniFilter Methods

[image] [image]

IceLib Technical Reference
AniFilter Methods
AniFilter Class See Also Send Feedback

The AniFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

AniFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


AniFilter Properties

[image] [image]

IceLib Technical Reference
AniFilter Properties
AniFilter Class See Also Send Feedback

The AniFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

AniFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DateTimeRangeFilter Class

[image]

IceLib Technical Reference
DateTimeRangeFilter Class
Members See Also Send Feedback
Represents criteria used to filter on whether an interaction's intiation time falls within a datetime range. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DateTimeRangeFilter : RangeValueFilter<DateTime>
Visual Basic
Public Class DateTimeRangeFilter _
    Inherits RangeValueFilter(Of DateTime)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..RangeValueFilter <(Of <(<'DateTime>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..DateTimeRangeFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DateTimeRangeFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


DateTimeRangeFilter Members

[image] [image]

IceLib Technical Reference
DateTimeRangeFilter Members
DateTimeRangeFilter Class Constructors Methods Properties See Also Send Feedback

The DateTimeRangeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeRangeFilter | Initializes a new instance of the DateTimeRangeFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterMaximumValue | Gets the filter maximum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterMinimumValue | Gets the filter minimum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)

See Also

DateTimeRangeFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DateTimeRangeFilter Constructor

[image]

IceLib Technical Reference
DateTimeRangeFilter Constructor
DateTimeRangeFilter Class See Also Send Feedback
Initializes a new instance of the DateTimeRangeFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTimeRangeFilter(
    DateTime minimumValue,
    DateTime maximumValue
)
Visual Basic
Public Sub New ( _
    minimumValue As DateTime, _
    maximumValue As DateTime _
)

Parameters

minimumValue
Type: System..::..DateTime
maximumValue
Type: System..::..DateTime

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | minimumValue or maximumValue is MinValue, or maximumValue is less than minimumValue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DateTimeRangeFilter Class
DateTimeRangeFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


DateTimeRangeFilter Methods

[image] [image]

IceLib Technical Reference
DateTimeRangeFilter Methods
DateTimeRangeFilter Class See Also Send Feedback

The DateTimeRangeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DateTimeRangeFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DateTimeRangeFilter Properties

[image] [image]

IceLib Technical Reference
DateTimeRangeFilter Properties
DateTimeRangeFilter Class See Also Send Feedback

The DateTimeRangeFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterMaximumValue | Gets the filter maximum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterMinimumValue | Gets the filter minimum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)

See Also

DateTimeRangeFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DirectionFilter Class

[image]

IceLib Technical Reference
DirectionFilter Class
Members See Also Send Feedback
Represents criteria used to filter on an interaction's direction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DirectionFilter : SingleValueFilter<InteractionSnapshotDirection>
Visual Basic
Public Class DirectionFilter _
    Inherits SingleValueFilter(Of InteractionSnapshotDirection)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<' InteractionSnapshotDirection >)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..DirectionFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DirectionFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


DirectionFilter Members

[image] [image]

IceLib Technical Reference
DirectionFilter Members
DirectionFilter Class Constructors Methods Properties See Also Send Feedback

The DirectionFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DirectionFilter | Initializes a new instance of the DirectionFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DirectionFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DirectionFilter Constructor

[image]

IceLib Technical Reference
DirectionFilter Constructor
DirectionFilter Class See Also Send Feedback
Initializes a new instance of the DirectionFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DirectionFilter(
    InteractionSnapshotDirection direction
)
Visual Basic
Public Sub New ( _
    direction As InteractionSnapshotDirection _
)

Parameters

direction
Type: ININ.IceLib.Reporting.Interactions..::..InteractionSnapshotDirection
The interaction's direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DirectionFilter Class
DirectionFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


DirectionFilter Methods

[image] [image]

IceLib Technical Reference
DirectionFilter Methods
DirectionFilter Class See Also Send Feedback

The DirectionFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DirectionFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DirectionFilter Properties

[image] [image]

IceLib Technical Reference
DirectionFilter Properties
DirectionFilter Class See Also Send Feedback

The DirectionFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DirectionFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DnisFilter Class

[image]

IceLib Technical Reference
DnisFilter Class
Members See Also Send Feedback
Represents criteria used to filter on an interaction's DNIS. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DnisFilter : SingleValueFilter<string>
Visual Basic
Public Class DnisFilter _
    Inherits SingleValueFilter(Of String)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'String>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..DnisFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DnisFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


DnisFilter Members

[image] [image]

IceLib Technical Reference
DnisFilter Members
DnisFilter Class Constructors Methods Properties See Also Send Feedback

The DnisFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DnisFilter | Initializes a new instance of the DnisFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DnisFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DnisFilter Constructor

[image]

IceLib Technical Reference
DnisFilter Constructor
DnisFilter Class See Also Send Feedback
Initializes a new instance of the DnisFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DnisFilter(
    string dnis
)
Visual Basic
Public Sub New ( _
    dnis As String _
)

Parameters

dnis
Type: System..::..String
The DNIS.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DnisFilter Class
DnisFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


DnisFilter Methods

[image] [image]

IceLib Technical Reference
DnisFilter Methods
DnisFilter Class See Also Send Feedback

The DnisFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DnisFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


DnisFilter Properties

[image] [image]

IceLib Technical Reference
DnisFilter Properties
DnisFilter Class See Also Send Feedback

The DnisFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

DnisFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionIdFilter Class

[image]

IceLib Technical Reference
InteractionIdFilter Class
Members See Also Send Feedback
Represents criteria used to filter on an interaction's ID. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionIdFilter : SingleValueFilter<string>
Visual Basic
Public Class InteractionIdFilter _
    Inherits SingleValueFilter(Of String)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'String>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionIdFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionIdFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionIdFilter Members

[image] [image]

IceLib Technical Reference
InteractionIdFilter Members
InteractionIdFilter Class Constructors Methods Properties See Also Send Feedback

The InteractionIdFilter type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionIdFilter | Initializes a new instance of the InteractionIdFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

InteractionIdFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionIdFilter Constructor

[image]

IceLib Technical Reference
InteractionIdFilter Constructor
InteractionIdFilter Class See Also Send Feedback
Initializes a new instance of the InteractionIdFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionIdFilter(
    string interactionId
)
Visual Basic
Public Sub New ( _
    interactionId As String _
)

Parameters

interactionId
Type: System..::..String
The interaction ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionIdFilter Class
InteractionIdFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionIdFilter Methods

[image] [image]

IceLib Technical Reference
InteractionIdFilter Methods
InteractionIdFilter Class See Also Send Feedback

The InteractionIdFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

InteractionIdFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionIdFilter Properties

[image] [image]

IceLib Technical Reference
InteractionIdFilter Properties
InteractionIdFilter Class See Also Send Feedback

The InteractionIdFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

InteractionIdFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionSnapshotFilter Class

[image]

IceLib Technical Reference
InteractionSnapshotFilter Class
Members See Also Send Feedback
Represents criteria used to filter on an interaction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class InteractionSnapshotFilter
Visual Basic
Public MustInherit Class InteractionSnapshotFilter

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..MultipleValueFilter<(Of <(<'TValueType>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..RangeValueFilter<(Of <(<'TValueType>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter<(Of <(<'TValueType>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionSnapshotFilter Members

[image] [image]

IceLib Technical Reference
InteractionSnapshotFilter Members
InteractionSnapshotFilter Class Constructors Methods Properties See Also Send Feedback

The InteractionSnapshotFilter type exposes the following members.

Constructors

 | Name | Description
Protected method | InteractionSnapshotFilter | Initializes a new instance of the InteractionSnapshotFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter.

See Also

InteractionSnapshotFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionSnapshotFilter Constructor

[image]

IceLib Technical Reference
InteractionSnapshotFilter Constructor
InteractionSnapshotFilter Class See Also Send Feedback
Initializes a new instance of the InteractionSnapshotFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected InteractionSnapshotFilter(
    string filterName
)
Visual Basic
Protected Sub New ( _
    filterName As String _
)

Parameters

filterName
Type: System..::..String
Name of the filter.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotFilter Class
InteractionSnapshotFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionSnapshotFilter Methods

[image] [image]

IceLib Technical Reference
InteractionSnapshotFilter Methods
InteractionSnapshotFilter Class See Also Send Feedback

The InteractionSnapshotFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSnapshotFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


InteractionSnapshotFilter Properties

[image] [image]

IceLib Technical Reference
InteractionSnapshotFilter Properties
InteractionSnapshotFilter Class See Also Send Feedback

The InteractionSnapshotFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter.

See Also

InteractionSnapshotFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


FilterName Property

[image]

IceLib Technical Reference
InteractionSnapshotFilter..::..FilterName Property
InteractionSnapshotFilter Class See Also Send Feedback
Gets the name of the filter.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FilterName { get; private set; }
Visual Basic
Public Property FilterName As String
    Get
    Private Set

Field Value

The name of the filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

InteractionSnapshotFilter Class
InteractionSnapshotFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastICUserNameFilter Class

[image]

IceLib Technical Reference
LastICUserNameFilter Class
Members See Also Send Feedback
Represents criteria used to filter on the last IC username involved in an interaction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LastICUserNameFilter : SingleValueFilter<string>
Visual Basic
Public Class LastICUserNameFilter _
    Inherits SingleValueFilter(Of String)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'String>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..LastICUserNameFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LastICUserNameFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastICUserNameFilter Members

[image] [image]

IceLib Technical Reference
LastICUserNameFilter Members
LastICUserNameFilter Class Constructors Methods Properties See Also Send Feedback

The LastICUserNameFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LastICUserNameFilter | Initializes a new instance of the LastICUserNameFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LastICUserNameFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastICUserNameFilter Constructor

[image]

IceLib Technical Reference
LastICUserNameFilter Constructor
LastICUserNameFilter Class See Also Send Feedback
Initializes a new instance of the LastICUserNameFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LastICUserNameFilter(
    string icUserName
)
Visual Basic
Public Sub New ( _
    icUserName As String _
)

Parameters

icUserName
Type: System..::..String
Name of the IC user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or Empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LastICUserNameFilter Class
LastICUserNameFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastICUserNameFilter Methods

[image] [image]

IceLib Technical Reference
LastICUserNameFilter Methods
LastICUserNameFilter Class See Also Send Feedback

The LastICUserNameFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LastICUserNameFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastICUserNameFilter Properties

[image] [image]

IceLib Technical Reference
LastICUserNameFilter Properties
LastICUserNameFilter Class See Also Send Feedback

The LastICUserNameFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LastICUserNameFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastWorkgroupFilter Class

[image]

IceLib Technical Reference
LastWorkgroupFilter Class
Members See Also Send Feedback
Represents criteria used to filter on the last workgroup involved in an interaction. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LastWorkgroupFilter : SingleValueFilter<string>
Visual Basic
Public Class LastWorkgroupFilter _
    Inherits SingleValueFilter(Of String)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'String>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..LastWorkgroupFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LastWorkgroupFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastWorkgroupFilter Members

[image] [image]

IceLib Technical Reference
LastWorkgroupFilter Members
LastWorkgroupFilter Class Constructors Methods Properties See Also Send Feedback

The LastWorkgroupFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LastWorkgroupFilter | Initializes a new instance of the LastWorkgroupFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LastWorkgroupFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastWorkgroupFilter Constructor

[image]

IceLib Technical Reference
LastWorkgroupFilter Constructor
LastWorkgroupFilter Class See Also Send Feedback
Initializes a new instance of the LastWorkgroupFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LastWorkgroupFilter(
    string workgroup
)
Visual Basic
Public Sub New ( _
    workgroup As String _
)

Parameters

workgroup
Type: System..::..String
The workgroup.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LastWorkgroupFilter Class
LastWorkgroupFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastWorkgroupFilter Methods

[image] [image]

IceLib Technical Reference
LastWorkgroupFilter Methods
LastWorkgroupFilter Class See Also Send Feedback

The LastWorkgroupFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LastWorkgroupFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LastWorkgroupFilter Properties

[image] [image]

IceLib Technical Reference
LastWorkgroupFilter Properties
LastWorkgroupFilter Class See Also Send Feedback

The LastWorkgroupFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LastWorkgroupFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LineDurationFilter Class

[image]

IceLib Technical Reference
LineDurationFilter Class
Members See Also Send Feedback
Represents criteria used to filter on whether an interaction's line duration falls within a specified range of timespans. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LineDurationFilter : RangeValueFilter<TimeSpan>
Visual Basic
Public Class LineDurationFilter _
    Inherits RangeValueFilter(Of TimeSpan)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..RangeValueFilter <(Of <(<'TimeSpan>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..LineDurationFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineDurationFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LineDurationFilter Members

[image] [image]

IceLib Technical Reference
LineDurationFilter Members
LineDurationFilter Class Constructors Methods Properties See Also Send Feedback

The LineDurationFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LineDurationFilter | Initializes a new instance of the LineDurationFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterMaximumValue | Gets the filter maximum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterMinimumValue | Gets the filter minimum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)

See Also

LineDurationFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LineDurationFilter Constructor

[image]

IceLib Technical Reference
LineDurationFilter Constructor
LineDurationFilter Class See Also Send Feedback
Initializes a new instance of the LineDurationFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LineDurationFilter(
    TimeSpan minLineDuration,
    TimeSpan maxLineDuration
)
Visual Basic
Public Sub New ( _
    minLineDuration As TimeSpan, _
    maxLineDuration As TimeSpan _
)

Parameters

minLineDuration
Type: System..::..TimeSpan
Min duration of the line.
maxLineDuration
Type: System..::..TimeSpan
Max duration of the line.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | maxLineDuration is less than minLineDuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

LineDurationFilter Class
LineDurationFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


LineDurationFilter Methods

[image] [image]

IceLib Technical Reference
LineDurationFilter Methods
LineDurationFilter Class See Also Send Feedback

The LineDurationFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)

See Also

LineDurationFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


LineDurationFilter Properties

[image] [image]

IceLib Technical Reference
LineDurationFilter Properties
LineDurationFilter Class See Also Send Feedback

The LineDurationFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterMaximumValue | Gets the filter maximum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterMinimumValue | Gets the filter minimum value. (Inherited from RangeValueFilter<(Of <(<'TValueType>)>)>.)
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)

See Also

LineDurationFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Class

[image]

IceLib Technical Reference
MaxRowsFilter Class
Members See Also Send Feedback
Used to limit the number to rows returned for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MaxRowsFilter : SingleValueFilter<int>
Visual Basic
Public Class MaxRowsFilter _
    Inherits SingleValueFilter(Of Integer)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'Int32>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..MaxRowsFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MaxRowsFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Members

[image] [image]

IceLib Technical Reference
MaxRowsFilter Members
MaxRowsFilter Class Constructors Methods Properties See Also Send Feedback

The MaxRowsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | MaxRowsFilter()()()() | Initializes a new instance of the SiteIdFilter class.
Public method | MaxRowsFilter(Int32) | Initializes a new instance of the MaxRowsFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

MaxRowsFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Constructor

[image] [image]

IceLib Technical Reference
MaxRowsFilter Constructor
MaxRowsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaxRowsFilter()()()() | Initializes a new instance of the SiteIdFilter class.
Public method | MaxRowsFilter(Int32) | Initializes a new instance of the MaxRowsFilter class.

See Also

MaxRowsFilter Class
MaxRowsFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Constructor

[image]

IceLib Technical Reference
MaxRowsFilter Constructor
MaxRowsFilter Class See Also Send Feedback
Initializes a new instance of the SiteIdFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MaxRowsFilter()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MaxRowsFilter Class
MaxRowsFilter Members
MaxRowsFilter Overload
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Constructor (Int32)

[image]

IceLib Technical Reference
MaxRowsFilter Constructor (Int32)
MaxRowsFilter Class See Also Send Feedback
Initializes a new instance of the MaxRowsFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MaxRowsFilter(
    int maxRows
)
Visual Basic
Public Sub New ( _
    maxRows As Integer _
)

Parameters

maxRows
Type: System..::..Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | maxRows is not a positive value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MaxRowsFilter Class
MaxRowsFilter Members
MaxRowsFilter Overload
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Methods

[image] [image]

IceLib Technical Reference
MaxRowsFilter Methods
MaxRowsFilter Class See Also Send Feedback

The MaxRowsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

MaxRowsFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MaxRowsFilter Properties

[image] [image]

IceLib Technical Reference
MaxRowsFilter Properties
MaxRowsFilter Class See Also Send Feedback

The MaxRowsFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

MaxRowsFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MediaTypeFilter Class

[image]

IceLib Technical Reference
MediaTypeFilter Class
Members See Also Send Feedback
Represents criteria used to filter whether an interaction's media type is one of the provided media types. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MediaTypeFilter : MultipleValueFilter<InteractionSnapshotMediaType>
Visual Basic
Public Class MediaTypeFilter _
    Inherits MultipleValueFilter(Of InteractionSnapshotMediaType)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..MultipleValueFilter <(Of <(<' InteractionSnapshotMediaType >)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..MediaTypeFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MediaTypeFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


MediaTypeFilter Members

[image] [image]

IceLib Technical Reference
MediaTypeFilter Members
MediaTypeFilter Class Constructors Methods Properties See Also Send Feedback

The MediaTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | MediaTypeFilter | Initializes a new instance of the MediaTypeFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from MultipleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValues | Gets the filter values. (Inherited from MultipleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

MediaTypeFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MediaTypeFilter Constructor

[image]

IceLib Technical Reference
MediaTypeFilter Constructor
MediaTypeFilter Class See Also Send Feedback
Initializes a new instance of the MediaTypeFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MediaTypeFilter(
    IEnumerable<InteractionSnapshotMediaType> mediaTypes
)
Visual Basic
Public Sub New ( _
    mediaTypes As IEnumerable(Of InteractionSnapshotMediaType) _
)

Parameters

mediaTypes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' InteractionSnapshotMediaType >)>)>
The media types.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | One of the mediaTypes is not a valid InteractionSnapshotMediaType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MediaTypeFilter Class
MediaTypeFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


MediaTypeFilter Methods

[image] [image]

IceLib Technical Reference
MediaTypeFilter Methods
MediaTypeFilter Class See Also Send Feedback

The MediaTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from MultipleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

MediaTypeFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MediaTypeFilter Properties

[image] [image]

IceLib Technical Reference
MediaTypeFilter Properties
MediaTypeFilter Class See Also Send Feedback

The MediaTypeFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValues | Gets the filter values. (Inherited from MultipleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

MediaTypeFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MultipleValueFilter(TValueType) Class

[image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)> Class
Members See Also Send Feedback
Holds information on a multiple value filter for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)). This filter will return records that match any of the supplied values. See the following (and other) implementations:

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MultipleValueFilter<TValueType> : InteractionSnapshotFilter
Visual Basic
Public Class MultipleValueFilter(Of TValueType) _
    Inherits InteractionSnapshotFilter

Type Parameters

TValueType
The type of the filter.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..MultipleValueFilter<(Of <(<'TValueType>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..MediaTypeFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace
ININ.IceLib.Reporting.Interactions.Filters..::..MediaTypeFilter


MultipleValueFilter(TValueType) Members

[image] [image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)> Members
MultipleValueFilter<(Of <(<'TValueType>)>)> Class Constructors Methods Properties See Also Send Feedback

The MultipleValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | MultipleValueFilter<(Of <(<'TValueType>)>)> | Initializes a new instance of the MultipleValueFilter<(Of <(<'TValueType>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValues | Gets the filter values.

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


MultipleValueFilter(TValueType) Constructor

[image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)> Constructor
MultipleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Initializes a new instance of the MultipleValueFilter<(Of <(<'TValueType>)>)> class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MultipleValueFilter(
    string filterName,
    IEnumerable<TValueType> filterValues
)
Visual Basic
Public Sub New ( _
    filterName As String, _
    filterValues As IEnumerable(Of TValueType) _
)

Parameters

filterName
Type: System..::..String
Name of the filter.
filterValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' TValueType >)>)>
The filter values.

Exceptions

Exception | Condition
System..::..ArgumentNullException | One or more of the values in filterValues is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Class
MultipleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


MultipleValueFilter(TValueType) Methods

[image] [image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)> Methods
MultipleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback

The MultipleValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


ToString Method

[image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)>..::..ToString Method
MultipleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Class
MultipleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


MultipleValueFilter(TValueType) Properties

[image] [image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)> Properties
MultipleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback

The MultipleValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValues | Gets the filter values.

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


FilterValues Property

[image]

IceLib Technical Reference
MultipleValueFilter<(Of <(<'TValueType>)>)>..::..FilterValues Property
MultipleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Gets the filter values.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TValueType> FilterValues { get; private set; }
Visual Basic
Public Property FilterValues As ReadOnlyCollection(Of TValueType)
    Get
    Private Set

Field Value

The filter values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MultipleValueFilter<(Of <(<'TValueType>)>)> Class
MultipleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


RangeValueFilter(TValueType) Class

[image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)> Class
Members See Also Send Feedback
Holds information on a range value filter for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)). See the following (and other) implementations:

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RangeValueFilter<TValueType> : InteractionSnapshotFilter
Visual Basic
Public Class RangeValueFilter(Of TValueType) _
    Inherits InteractionSnapshotFilter

Type Parameters

TValueType
The type of the filter.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..RangeValueFilter<(Of <(<'TValueType>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..DateTimeRangeFilter
ININ.IceLib.Reporting.Interactions.Filters..::..LineDurationFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace
ININ.IceLib.Reporting.Interactions.Filters..::..DateTimeRangeFilter
ININ.IceLib.Reporting.Interactions.Filters..::..LineDurationFilter


RangeValueFilter(TValueType) Members

[image] [image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)> Members
RangeValueFilter<(Of <(<'TValueType>)>)> Class Constructors Methods Properties See Also Send Feedback

The RangeValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | RangeValueFilter<(Of <(<'TValueType>)>)> | Initializes a new instance of the RangeValueFilter<(Of <(<'TValueType>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilterMaximumValue | Gets the filter maximum value.
Public property | FilterMinimumValue | Gets the filter minimum value.
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


RangeValueFilter(TValueType) Constructor

[image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)> Constructor
RangeValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Initializes a new instance of the RangeValueFilter<(Of <(<'TValueType>)>)> class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RangeValueFilter(
    string filterName,
    TValueType minimumValue,
    TValueType maximumValue
)
Visual Basic
Public Sub New ( _
    filterName As String, _
    minimumValue As TValueType, _
    maximumValue As TValueType _
)

Parameters

filterName
Type: System..::..String
Name of the filter.
minimumValue
Type: TValueType
The minimum value.
maximumValue
Type: TValueType
The maximum value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | minimumValue or maximumValue is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
RangeValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


RangeValueFilter(TValueType) Methods

[image] [image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)> Methods
RangeValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback

The RangeValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


ToString Method

[image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)>..::..ToString Method
RangeValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
RangeValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


RangeValueFilter(TValueType) Properties

[image] [image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)> Properties
RangeValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback

The RangeValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilterMaximumValue | Gets the filter maximum value.
Public property | FilterMinimumValue | Gets the filter minimum value.
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


FilterMaximumValue Property

[image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)>..::..FilterMaximumValue Property
RangeValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Gets the filter maximum value.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValueType FilterMaximumValue { get; private set; }
Visual Basic
Public Property FilterMaximumValue As TValueType
    Get
    Private Set

Field Value

The filter maximum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
RangeValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


FilterMinimumValue Property

[image]

IceLib Technical Reference
RangeValueFilter<(Of <(<'TValueType>)>)>..::..FilterMinimumValue Property
RangeValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Gets the filter minimum value.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValueType FilterMinimumValue { get; private set; }
Visual Basic
Public Property FilterMinimumValue As TValueType
    Get
    Private Set

Field Value

The filter minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RangeValueFilter<(Of <(<'TValueType>)>)> Class
RangeValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


SingleValueFilter(TValueType) Class

[image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)> Class
Members See Also Send Feedback
Holds information on a single value filter for calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)). See the following (and other) implementations:

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SingleValueFilter<TValueType> : InteractionSnapshotFilter
Visual Basic
Public Class SingleValueFilter(Of TValueType) _
    Inherits InteractionSnapshotFilter

Type Parameters

TValueType
The type of the filter.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter<(Of <(<'TValueType>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..AniFilter
ININ.IceLib.Reporting.Interactions.Filters..::..DirectionFilter
ININ.IceLib.Reporting.Interactions.Filters..::..DnisFilter
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionIdFilter
ININ.IceLib.Reporting.Interactions.Filters..::..LastICUserNameFilter
ININ.IceLib.Reporting.Interactions.Filters..::..LastWorkgroupFilter
ININ.IceLib.Reporting.Interactions.Filters..::..MaxRowsFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SiteIdFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace
ININ.IceLib.Reporting.Interactions.Filters..::..LastICUserNameFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SiteIdFilter


SingleValueFilter(TValueType) Members

[image] [image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)> Members
SingleValueFilter<(Of <(<'TValueType>)>)> Class Constructors Methods Properties See Also Send Feedback

The SingleValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SingleValueFilter<(Of <(<'TValueType>)>)> | Initializes a new instance of the SingleValueFilter<(Of <(<'TValueType>)>)> class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value.

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


SingleValueFilter(TValueType) Constructor

[image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)> Constructor
SingleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Initializes a new instance of the SingleValueFilter<(Of <(<'TValueType>)>)> class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SingleValueFilter(
    string filterName,
    TValueType filterValue
)
Visual Basic
Public Sub New ( _
    filterName As String, _
    filterValue As TValueType _
)

Parameters

filterName
Type: System..::..String
Name of the filter.
filterValue
Type: TValueType
The filter value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Class
SingleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


SingleValueFilter(TValueType) Methods

[image] [image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)> Methods
SingleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback

The SingleValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


ToString Method

[image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)>..::..ToString Method
SingleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Class
SingleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


SingleValueFilter(TValueType) Properties

[image] [image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)> Properties
SingleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback

The SingleValueFilter<(Of <(<'TValueType>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value.

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


FilterValue Property

[image]

IceLib Technical Reference
SingleValueFilter<(Of <(<'TValueType>)>)>..::..FilterValue Property
SingleValueFilter<(Of <(<'TValueType>)>)> Class See Also Send Feedback
Gets the filter value.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TValueType FilterValue { get; private set; }
Visual Basic
Public Property FilterValue As TValueType
    Get
    Private Set

Field Value

The filter value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SingleValueFilter<(Of <(<'TValueType>)>)> Class
SingleValueFilter<(Of <(<'TValueType>)>)> Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Class

[image]

IceLib Technical Reference
SiteIdFilter Class
Members See Also Send Feedback
Represents criteria used to filter on an interaction's site ID. The filter is used in calls to GetInteractionSnapshots(IEnumerable<(Of <<'(InteractionSnapshotFilter>)>>)).

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SiteIdFilter : SingleValueFilter<int>
Visual Basic
Public Class SiteIdFilter _
    Inherits SingleValueFilter(Of Integer)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Reporting.Interactions.Filters..::..InteractionSnapshotFilter
ININ.IceLib.Reporting.Interactions.Filters..::..SingleValueFilter <(Of <(<'Int32>)>)>
ININ.IceLib.Reporting.Interactions.Filters..::..SiteIdFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteIdFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Members

[image] [image]

IceLib Technical Reference
SiteIdFilter Members
SiteIdFilter Class Constructors Methods Properties See Also Send Feedback

The SiteIdFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SiteIdFilter()()()() | Initializes a new instance of the SiteIdFilter class.
Public method | SiteIdFilter(Int32) | Initializes a new instance of the SiteIdFilter class.
Public method | SiteIdFilter(ReportingManager, Int32) | Initializes a new instance of the SiteIdFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

SiteIdFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Constructor

[image] [image]

IceLib Technical Reference
SiteIdFilter Constructor
SiteIdFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SiteIdFilter()()()() | Initializes a new instance of the SiteIdFilter class.
Public method | SiteIdFilter(Int32) | Initializes a new instance of the SiteIdFilter class.
Public method | SiteIdFilter(ReportingManager, Int32) | Initializes a new instance of the SiteIdFilter class.

See Also

SiteIdFilter Class
SiteIdFilter Members
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Constructor

[image]

IceLib Technical Reference
SiteIdFilter Constructor
SiteIdFilter Class See Also Send Feedback
Initializes a new instance of the SiteIdFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SiteIdFilter()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteIdFilter Class
SiteIdFilter Members
SiteIdFilter Overload
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Constructor (Int32)

[image]

IceLib Technical Reference
SiteIdFilter Constructor (Int32)
SiteIdFilter Class See Also Send Feedback
Initializes a new instance of the SiteIdFilter class.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SiteIdFilter(
    int siteId
)
Visual Basic
Public Sub New ( _
    siteId As Integer _
)

Parameters

siteId
Type: System..::..Int32
The site ID. Valid values are 0 to 999.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | siteId is not a number between 0 and 999 (inclusive).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

SiteIdFilter Class
SiteIdFilter Members
SiteIdFilter Overload
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Constructor (ReportingManager, Int32)

[image]

IceLib Technical Reference
SiteIdFilter Constructor (ReportingManager, Int32)
SiteIdFilter Class See Also Send Feedback
Initializes a new instance of the SiteIdFilter class.

Note: This constructor is supported for IC Server version 2017 R3 and beyond.

Namespace: ININ.IceLib.Reporting.Interactions.Filters
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SiteIdFilter(
    ReportingManager manager,
    int siteId
)
Visual Basic
Public Sub New ( _
    manager As ReportingManager, _
    siteId As Integer _
)

Parameters

manager
Type: ININ.IceLib.Reporting..::..ReportingManager
The associated ReportingManager for this request.
siteId
Type: System..::..Int32
The site ID. Valid values are -1 to 999.

Remarks

If a value of -1 is specified all sites will be checked. In order to see if all sites is supported check SupportsAllSites.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | siteId is not a number between -1 and 999 (inclusive) and the server supports all sites. If the server does not support all sites when siteId is not between 0 and 999 (inclusive).

Version Information

Supported for IC Server version 2017 R3 and beyond.

See Also

SiteIdFilter Class
SiteIdFilter Members
SiteIdFilter Overload
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Methods

[image] [image]

IceLib Technical Reference
SiteIdFilter Methods
SiteIdFilter Class See Also Send Feedback

The SiteIdFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

SiteIdFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


SiteIdFilter Properties

[image] [image]

IceLib Technical Reference
SiteIdFilter Properties
SiteIdFilter Class See Also Send Feedback

The SiteIdFilter type exposes the following members.

Properties

 | Name | Description
Public property | FilterName | Gets the name of the filter. (Inherited from InteractionSnapshotFilter.)
Public property | FilterValue | Gets the filter value. (Inherited from SingleValueFilter<(Of <(<'TValueType>)>)>.)

See Also

SiteIdFilter Class
ININ.IceLib.Reporting.Interactions.Filters Namespace


ININ.IceLib.Reporting.Metadata Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Reporting.Metadata Namespace
Send Feedback

The ININ.IceLib.Reporting.MetaData namespace contains classes that provide support for Reporting Metadata classes.

Enumerations

 | Enumeration | Description
Public enumeration | InternalParameterSource | Source of this parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.


InternalParameterSource Enumeration

[image]

IceLib Technical Reference
InternalParameterSource Enumeration
See Also Send Feedback
Source of this parameter.

Namespace: ININ.IceLib.Reporting.Metadata
Assembly: ININ.IceLib.Reporting (in ININ.IceLib.Reporting.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InternalParameterSource
Visual Basic
Public Enumeration InternalParameterSource

Members

Member name | Value | Description
None | 0 | Unset Value.
FixedToDefault | 1 | Parameter can only be a default value, entered by the report administrator.
UserSupplied | 2 | User must supply parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Reporting.Metadata Namespace


ININ.IceLib.Statistics Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Statistics Namespace
Send Feedback

The ININ.IceLib.Statistics namespace contains classes for watching and listening to Interaction Center statistics.

There are a number of classes within the ININ.IceLib.Statistics namespace that provide support to the classes mentioned in the preceding summary. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

The StatisticCatalog can be used to watch statistics. This watch will provide the details about the definition of the statistic, such as units, precision, name, and description. The StatisticListener can be used to listen to statistic values. This will retrieve the current value of the statistic of interest and send out events when that value changes.

Note
For more information on getting started with statistics see Getting Started With Statistics.
Note
For for the list of available statistics see Statistics Catalog.

Examples

The IceLib SDK includes example application references to the ININ.IceLib.Statistics namespace. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 102, in SystemStatisticsViewModel.StartWatchingCatalogCompleted
 | SystemStatisticsViewModel.cs, line 64, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | SystemStatisticsViewModel.cs, line 130, in SystemStatisticsViewModel.StatisticListenerStatisticValueUpdated
 | SystemStatisticsViewModel.cs, line 30, in SystemStatisticsViewModel.#ctor
 | SystemStatisticsViewModel._StatisticsManager
 | SystemStatisticsViewModel._StatisticCatalog
 | SystemStatisticsViewModel._StatisticListener
 | SystemStatisticsViewModel._SystemStatistics
 | StatisticCatalogViewModel.cs, line 153, in StatisticCatalogViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 61, in StatisticCatalogViewModel.set_SelectedStatisticCategory
 | StatisticCatalogViewModel.cs, line 30, in StatisticCatalogViewModel.#ctor
 | StatisticCatalogViewModel.cs, line 236, in StatisticCatalogViewModel.StartWatchingCompleted
 | StatisticCatalogViewModel.cs, line 46, in StatisticCatalogViewModel.set_AvailableStatisticCategories
 | StatisticCatalogViewModel.cs, line 134, in StatisticCatalogViewModel.set_StatisticDefinitions
 | StatisticViewModel.cs, line 26, in StatisticViewModel.SetStatisticValue
 | StatisticViewModel.cs, line 9, in StatisticViewModel.#ctor
 | StatisticViewModel._StatisticValue
 | StatisticViewModel._StatisticKey

Classes

 | Class | Description
Public class | AssociatedParameterSetDefinition | A collection of associated parameter types that define a valid parameter set for querying or watching a statistic value.
Public class | AssociatedParameterSetQuery | Defines a query for AssociatedParameterSetValues that match a AssociatedParameterSetDefinition.
Public class | AssociatedParameterSetQueryEventArgs | Details for an event notifying of a change to the results for a watched AssociatedParameterSetQuery.
Public class | AssociatedParameterSetValue | Values for a set of associated parameter types.
Public class | DetailedParameterValue | ParameterValue with additional display string and description.
Public class | DrillDown | Represents a drill down lookup. If this data is present, additional drill down data is present and can be queried with GetDrillDownData(Session, String).
Public class | DrillDownData | Represents additional statistical information that can be retrieved via the drill down process. See DrillDown for how to access this data.
Public class | DrillDownDataEntry | Represents a collection of data for a specified drill down.
Public class | FilteredParameterQuery | Represents a query to retrieve a filtered list of the available values for a given parameter type.
Public class | ParameterQuery | Represents a query to list the available values for a given parameter type. ParameterQuery is used in ExecuteQuery(ParameterQuery) to define what is being queried.
Public class | ParameterQueryCompletedEventArgs | Provides data for asynchronous completed events of ParameterValuesDepot.
Public class | ParameterQueryResult | Represents the results from ExecuteQuery(ParameterQuery).
Public class | ParameterType | Defines the type of a parameter.
Public class | ParameterTypeDefinition | Represents additional details for a ParameterType object.
Public class | ParameterTypeId | The ID value of a ParameterType.
Public class | ParameterValue | Represents a parameter type and its value. A statistic parameter helps define which specific statistic is being dealt with. For example, an alert can be setup to trigger for a queue. Using a parameter, that alert can be defined to only apply to specific members of a workgroup.
Public class | ParameterValueEventArgs | Provides data for the ParameterValuesDepot changed, added and removed events.
Public class | ParameterValueKeyedCollection | Represents an ordered keyed collection of parameter types and their values.
Public class | ParameterValuesDepot | Represents a watched object used to query the valid parameters when making statistic values requests.
Public class | RequiredParametersDefinition | Details information about the required parameter types that define a valid parameter set for a statistic value.
Public class | StatisticBoolValue | The StatisticValue for statistics with data type.
Public class | StatisticCatalog | Gateway to the definitions of available IC statistics.
Public class | StatisticCatalogChangedEventArgs | Provides data for for the StatisticCatalogChanged event. This contains a list of objects that have been added or removed and a list of all objects that have changed.
Public class | StatisticCategory | Specific constants identifying a grouping of statistic definitions.
Public class | StatisticDefinition | Represents information about an IC statistic.
Public class | StatisticDoubleValue | The StatisticValue for statistics with data type.
Public class | StatisticDurationValue | The StatisticValue for statistics with data type.
Public class | StatisticFiniteDurationValue | The StatisticValue for statistics with a data type that can be fixed or actively increasing.
Public class | StatisticFutureDurationValue | The StatisticValue for statistics with data type that is duration until something will happen.
Public class | StatisticIdentifier | Identifies a statistic.
Public class | StatisticIntValue | The StatisticValue for statistics with data type.
Public class | StatisticKey | Identifies a specific statistic value of interest.
Public class | StatisticKeyTemplate | Represents a class to manipulate the contents of a StatisticKey.
Public class | StatisticListener | Represents a watched object to query for IC statistics and listen for updates to those statistics.
Public class | StatisticPercentValue | The StatisticValue for statistics with percentage values represented as a data type.
Public class | StatisticsManager | Provides access to statistics.
Public class | StatisticStatusMessageKeyValue | The StatisticValue for statistics with a time in status data type. Defines the length of time in status.
Public class | StatisticStringValue | The StatisticValue for statistics with data type.
Public class | StatisticTimeDurationValue | The StatisticValue for statistics with data type that is duration since something happened.
Public class | StatisticTimeStampValue | The StatisticValue for statistics with data type.
Public class | StatisticValue | Represents an abstract class statistic values are based on.
Public class | StatisticValueUpdatedEventArgs | Provides data for StatisticValueUpdated event.
Public class | ValidateAssociatedParameterSetCompletedEventArgs | Provides data for completion of ValidateAssociatedParameterSetAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(ValidateAssociatedParameterSetCompletedEventArgs>)>>), Object).
Public class | ValidatedAssociatedParameterSetValue | Represents an ordered set of ValidatedDetailedParameterValue.
Public class | ValidatedDetailedParameterValue | Represents the details for a ParameterValue from a request to validate a set of associated parameter values.

Delegates

 | Delegate | Description
Public delegate | ParameterValuesDepot..::..ParameterQueryCompletedEventHandler | Represents the method that will handle the completed callback for an ExecuteQueryAsync(ParameterQuery, EventHandler<(Of <<'(ParameterQueryCompletedEventArgs>)>>), Object) operation.

Enumerations

 | Enumeration | Description
Public enumeration | BoundValueType | Represents the type of boundary conditions a statistic may have.
Public enumeration | ParameterQueryResultStatus | Represents the status of a ParameterQueryResult.
Public enumeration | StatisticDefinitionFlags | Additional flags that may be set to modify a statistic definition.
Public enumeration | StatisticErrorValueType | Represents the error type of a statistic.
Public enumeration | StatisticUnits | Defines the measurement units of a StatisticValue.
Public enumeration | StatisticValueType | Represents the value type of a statistic.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


AssociatedParameterSetDefinition Class

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition Class
Members See Also Send Feedback
A collection of associated parameter types that define a valid parameter set for querying or watching a statistic value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssociatedParameterSetDefinition : IEnumerable<ParameterTypeId>,
    IEnumerable, IEquatable<AssociatedParameterSetDefinition>
Visual Basic
Public Class AssociatedParameterSetDefinition _
    Implements IEnumerable(Of ParameterTypeId), IEnumerable,  _
    IEquatable(Of AssociatedParameterSetDefinition)

Remarks

The order of the parameter types that compose the definition is important.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
ININ.IceLib.Statistics..::..RequiredParametersDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..AssociatedParameterSetQuery


AssociatedParameterSetDefinition Members

[image] [image]

IceLib Technical Reference
AssociatedParameterSetDefinition Members
AssociatedParameterSetDefinition Class Constructors Methods Operators See Also Send Feedback

The AssociatedParameterSetDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | AssociatedParameterSetDefinition | Initializes a new instance of the AssociatedParameterSetDefinition class.

Methods

 | Name | Description
Public method | CompareTo | Compares one AssociatedParameterSetDefinition value to another.
Public method | Contains | Determines whether the AssociatedParameterSetDefinition contains the specified ParameterTypeId.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetDefinition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of AssociatedParameterSetDefinition are equal.
GreaterThan | Determines whether one instance of AssociatedParameterSetDefinition is greater than another.
GreaterThanOrEqual | Determines whether one instance of AssociatedParameterSetDefinition is greater than or equal to another.
Inequality | Determines whether two instances of AssociatedParameterSetDefinition are not equal.
LessThan | Determines whether one instance of AssociatedParameterSetDefinition is less than another.
LessThanOrEqual | Determines whether one instance of AssociatedParameterSetDefinition is less than or equal to another.

See Also

AssociatedParameterSetDefinition Class
ININ.IceLib.Statistics Namespace


AssociatedParameterSetDefinition Constructor

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition Constructor
AssociatedParameterSetDefinition Class See Also Send Feedback
Initializes a new instance of the AssociatedParameterSetDefinition class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssociatedParameterSetDefinition(
    IEnumerable<ParameterTypeId> orderedTypes
)
Visual Basic
Public Sub New ( _
    orderedTypes As IEnumerable(Of ParameterTypeId) _
)

Parameters

orderedTypes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterTypeId >)>)>
The ordered types.

Exceptions

Exception | Condition
System..::..ArgumentException | orderedTypes was nullNothingnullptra null reference (Nothing in Visual Basic), or contained a ParameterType multiple times.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetDefinition Methods

[image] [image]

IceLib Technical Reference
AssociatedParameterSetDefinition Methods
AssociatedParameterSetDefinition Class See Also Send Feedback

The AssociatedParameterSetDefinition type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares one AssociatedParameterSetDefinition value to another.
Public method | Contains | Determines whether the AssociatedParameterSetDefinition contains the specified ParameterTypeId.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetDefinition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssociatedParameterSetDefinition Class
ININ.IceLib.Statistics Namespace


CompareTo Method

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..CompareTo Method
AssociatedParameterSetDefinition Class See Also Send Feedback
Compares one AssociatedParameterSetDefinition value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual int CompareTo(
    AssociatedParameterSetDefinition other
)
Visual Basic
Public Overridable Function CompareTo ( _
    other As AssociatedParameterSetDefinition _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The value to compare against.

Return Value

A 32-bit signed integer that indicates the lexical relationship.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


Contains Method

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..Contains Method
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether the AssociatedParameterSetDefinition contains the specified ParameterTypeId.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Contains(
    ParameterTypeId parameterType
)
Visual Basic
Public Function Contains ( _
    parameterType As ParameterTypeId _
) As Boolean

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
Type of the parameter.

Return Value

trueTruetruetrue (True in Visual Basic) if the AssociatedParameterSetDefinition contains the specified ParameterTypeId; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..Equals Method
AssociatedParameterSetDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetDefinition) | Indicates whether the current object is equal to another object of the same type.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..Equals Method (Object)
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (AssociatedParameterSetDefinition)

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..Equals Method (AssociatedParameterSetDefinition)
AssociatedParameterSetDefinition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AssociatedParameterSetDefinition other
)
Visual Basic
Public Function Equals ( _
    other As AssociatedParameterSetDefinition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
An object to compare with this object.

Return Value

trueTruetruetrue (True in Visual Basic) if the current object is equal to the other parameter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetEnumerator Method

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..GetEnumerator Method
AssociatedParameterSetDefinition Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerator<ParameterTypeId> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of ParameterTypeId)

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..GetHashCode Method
AssociatedParameterSetDefinition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetDefinition Operators

[image] [image]

IceLib Technical Reference
AssociatedParameterSetDefinition Operators
AssociatedParameterSetDefinition Class See Also Send Feedback

The AssociatedParameterSetDefinition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of AssociatedParameterSetDefinition are equal.
GreaterThan | Determines whether one instance of AssociatedParameterSetDefinition is greater than another.
GreaterThanOrEqual | Determines whether one instance of AssociatedParameterSetDefinition is greater than or equal to another.
Inequality | Determines whether two instances of AssociatedParameterSetDefinition are not equal.
LessThan | Determines whether one instance of AssociatedParameterSetDefinition is less than another.
LessThanOrEqual | Determines whether one instance of AssociatedParameterSetDefinition is less than or equal to another.

See Also

AssociatedParameterSetDefinition Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..Equality Operator
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether two instances of AssociatedParameterSetDefinition are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AssociatedParameterSetDefinition a,
    AssociatedParameterSetDefinition b
)
Visual Basic
Public Shared Operator = ( _
    a As AssociatedParameterSetDefinition, _
    b As AssociatedParameterSetDefinition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The first AssociatedParameterSetDefinition to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The second AssociatedParameterSetDefinition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


GreaterThan Operator

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..GreaterThan Operator
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetDefinition is greater than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >(
    AssociatedParameterSetDefinition a,
    AssociatedParameterSetDefinition b
)
Visual Basic
Public Shared Operator > ( _
    a As AssociatedParameterSetDefinition, _
    b As AssociatedParameterSetDefinition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The first AssociatedParameterSetDefinition to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The second AssociatedParameterSetDefinition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


GreaterThanOrEqual Operator

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..GreaterThanOrEqual Operator
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetDefinition is greater than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >=(
    AssociatedParameterSetDefinition a,
    AssociatedParameterSetDefinition b
)
Visual Basic
Public Shared Operator >= ( _
    a As AssociatedParameterSetDefinition, _
    b As AssociatedParameterSetDefinition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The first AssociatedParameterSetDefinition to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The second AssociatedParameterSetDefinition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..Inequality Operator
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether two instances of AssociatedParameterSetDefinition are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AssociatedParameterSetDefinition a,
    AssociatedParameterSetDefinition b
)
Visual Basic
Public Shared Operator <> ( _
    a As AssociatedParameterSetDefinition, _
    b As AssociatedParameterSetDefinition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The first AssociatedParameterSetDefinition to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The second AssociatedParameterSetDefinition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


LessThan Operator

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..LessThan Operator
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetDefinition is less than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <(
    AssociatedParameterSetDefinition a,
    AssociatedParameterSetDefinition b
)
Visual Basic
Public Shared Operator < ( _
    a As AssociatedParameterSetDefinition, _
    b As AssociatedParameterSetDefinition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The first AssociatedParameterSetDefinition to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The second AssociatedParameterSetDefinition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


LessThanOrEqual Operator

[image]

IceLib Technical Reference
AssociatedParameterSetDefinition..::..LessThanOrEqual Operator
AssociatedParameterSetDefinition Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetDefinition is less than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <=(
    AssociatedParameterSetDefinition a,
    AssociatedParameterSetDefinition b
)
Visual Basic
Public Shared Operator <= ( _
    a As AssociatedParameterSetDefinition, _
    b As AssociatedParameterSetDefinition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The first AssociatedParameterSetDefinition to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The second AssociatedParameterSetDefinition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetDefinition Class
AssociatedParameterSetDefinition Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQuery Class

[image]

IceLib Technical Reference
AssociatedParameterSetQuery Class
Members See Also Send Feedback
Defines a query for AssociatedParameterSetValues that match a AssociatedParameterSetDefinition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssociatedParameterSetQuery : IEquatable<AssociatedParameterSetQuery>
Visual Basic
Public Class AssociatedParameterSetQuery _
    Implements IEquatable(Of AssociatedParameterSetQuery)

Remarks

By default, the query will match all parameter values that fits the query definition. The query can be refined to match only a specific parameter value by supplying a specific value for a given parameter type. Once an All node is matched, all following parameter types must also be set to match All.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..AssociatedParameterSetQuery

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace
ParameterValuesDepot..::..StartWatchingQuery(AssociatedParameterSetQuery)


AssociatedParameterSetQuery Members

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQuery Members
AssociatedParameterSetQuery Class Constructors Methods Operators Properties See Also Send Feedback

The AssociatedParameterSetQuery type exposes the following members.

Constructors

 | Name | Description
Public method | AssociatedParameterSetQuery | Initializes a new instance of the AssociatedParameterSetQuery class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetQuery) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueForParameterType | Gets the type of the value for parameter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValueForParameterType | Sets the type of the value for parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValueMatchesQuery | Indicates if the given AssociatedParameterSetValue is a valid match to this AssociatedParameterSetQuery.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | QueryDefinition | Gets the query definition.

See Also

AssociatedParameterSetQuery Class
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQuery Constructor

[image]

IceLib Technical Reference
AssociatedParameterSetQuery Constructor
AssociatedParameterSetQuery Class See Also Send Feedback
Initializes a new instance of the AssociatedParameterSetQuery class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssociatedParameterSetQuery(
    AssociatedParameterSetDefinition query
)
Visual Basic
Public Sub New ( _
    query As AssociatedParameterSetDefinition _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
The query.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQuery Methods

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQuery Methods
AssociatedParameterSetQuery Class See Also Send Feedback

The AssociatedParameterSetQuery type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetQuery) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueForParameterType | Gets the type of the value for parameter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValueForParameterType | Sets the type of the value for parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValueMatchesQuery | Indicates if the given AssociatedParameterSetValue is a valid match to this AssociatedParameterSetQuery.

See Also

AssociatedParameterSetQuery Class
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..Equals Method
AssociatedParameterSetQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetQuery) | Indicates whether the current object is equal to another object of the same type.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..Equals Method (Object)
AssociatedParameterSetQuery Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (AssociatedParameterSetQuery)

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..Equals Method (AssociatedParameterSetQuery)
AssociatedParameterSetQuery Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AssociatedParameterSetQuery other
)
Visual Basic
Public Function Equals ( _
    other As AssociatedParameterSetQuery _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..GetHashCode Method
AssociatedParameterSetQuery Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


GetValueForParameterType Method

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..GetValueForParameterType Method
AssociatedParameterSetQuery Class See Also Send Feedback
Gets the type of the value for parameter.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetValueForParameterType(
    ParameterTypeId parameterType
)
Visual Basic
Public Function GetValueForParameterType ( _
    parameterType As ParameterTypeId _
) As String

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
Type of the parameter.

Return Value

The value for the specified parameterType.

Exceptions

Exception | Condition
System..::..ArgumentException | The parameterType is not a member of the definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


SetValueForParameterType Method

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..SetValueForParameterType Method
AssociatedParameterSetQuery Class See Also Send Feedback
Sets the type of the value for parameter.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetValueForParameterType(
    ParameterTypeId parameterType,
    string parameterValue
)
Visual Basic
Public Sub SetValueForParameterType ( _
    parameterType As ParameterTypeId, _
    parameterValue As String _
)

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
Type of the parameter.
parameterValue
Type: System..::..String
The parameter value.

Exceptions

Exception | Condition
System..::..ArgumentException | The parameterType is not a member of the definition, or the parameterValue is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


ValueMatchesQuery Method

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..ValueMatchesQuery Method
AssociatedParameterSetQuery Class See Also Send Feedback
Indicates if the given AssociatedParameterSetValue is a valid match to this AssociatedParameterSetQuery.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ValueMatchesQuery(
    AssociatedParameterSetValue value
)
Visual Basic
Public Function ValueMatchesQuery ( _
    value As AssociatedParameterSetValue _
) As Boolean

Parameters

value
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The value.

Return Value

trueTruetruetrue (True in Visual Basic) if the value matches the query; otherwise falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQuery Operators

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQuery Operators
AssociatedParameterSetQuery Class See Also Send Feedback

The AssociatedParameterSetQuery type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

AssociatedParameterSetQuery Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..Equality Operator
AssociatedParameterSetQuery Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AssociatedParameterSetQuery a,
    AssociatedParameterSetQuery b
)
Visual Basic
Public Shared Operator = ( _
    a As AssociatedParameterSetQuery, _
    b As AssociatedParameterSetQuery _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
A.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..Inequality Operator
AssociatedParameterSetQuery Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AssociatedParameterSetQuery a,
    AssociatedParameterSetQuery b
)
Visual Basic
Public Shared Operator <> ( _
    a As AssociatedParameterSetQuery, _
    b As AssociatedParameterSetQuery _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
A.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQuery Properties

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQuery Properties
AssociatedParameterSetQuery Class See Also Send Feedback

The AssociatedParameterSetQuery type exposes the following members.

Properties

 | Name | Description
Public property | QueryDefinition | Gets the query definition.

See Also

AssociatedParameterSetQuery Class
ININ.IceLib.Statistics Namespace


QueryDefinition Property

[image]

IceLib Technical Reference
AssociatedParameterSetQuery..::..QueryDefinition Property
AssociatedParameterSetQuery Class See Also Send Feedback
Gets the query definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssociatedParameterSetDefinition QueryDefinition { get; private set; }
Visual Basic
Public Property QueryDefinition As AssociatedParameterSetDefinition
    Get
    Private Set

Field Value

The query definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQuery Class
AssociatedParameterSetQuery Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQueryEventArgs Class

[image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs Class
Members See Also Send Feedback
Details for an event notifying of a change to the results for a watched AssociatedParameterSetQuery.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssociatedParameterSetQueryEventArgs : EventArgs
Visual Basic
Public Class AssociatedParameterSetQueryEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics..::..AssociatedParameterSetQueryEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQueryEventArgs Members
ININ.IceLib.Statistics Namespace
ParameterValuesDepot..::..QueryResultsChanged


AssociatedParameterSetQueryEventArgs Members

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs Members
AssociatedParameterSetQueryEventArgs Class Constructors Methods Properties See Also Send Feedback

The AssociatedParameterSetQueryEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AssociatedParameterSetQueryEventArgs | Initializes a new instance of the AssociatedParameterSetQueryEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Gets the collection of AssociatedParameterSetValue that were added and now match the query.
Public property | Removed | Gets the collection of AssociatedParameterSetValue that were removed and no longer match the query.
Public property | Updated | Gets the collection of AssociatedParameterSetValue that were updated and still match the query.

See Also

AssociatedParameterSetQueryEventArgs Class
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQueryEventArgs Constructor

[image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs Constructor
AssociatedParameterSetQueryEventArgs Class See Also Send Feedback
Initializes a new instance of the AssociatedParameterSetQueryEventArgs class

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssociatedParameterSetQueryEventArgs()
Visual Basic
Public Sub New

See Also

AssociatedParameterSetQueryEventArgs Class
AssociatedParameterSetQueryEventArgs Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQueryEventArgs Methods

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs Methods
AssociatedParameterSetQueryEventArgs Class See Also Send Feedback

The AssociatedParameterSetQueryEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssociatedParameterSetQueryEventArgs Class
ININ.IceLib.Statistics Namespace


AssociatedParameterSetQueryEventArgs Properties

[image] [image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs Properties
AssociatedParameterSetQueryEventArgs Class See Also Send Feedback

The AssociatedParameterSetQueryEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Added | Gets the collection of AssociatedParameterSetValue that were added and now match the query.
Public property | Removed | Gets the collection of AssociatedParameterSetValue that were removed and no longer match the query.
Public property | Updated | Gets the collection of AssociatedParameterSetValue that were updated and still match the query.

See Also

AssociatedParameterSetQueryEventArgs Class
ININ.IceLib.Statistics Namespace


Added Property

[image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs..::..Added Property
AssociatedParameterSetQueryEventArgs Class See Also Send Feedback
Gets the collection of AssociatedParameterSetValue that were added and now match the query.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssociatedParameterSetValue> Added { get; internal set; }
Visual Basic
Public Property Added As ReadOnlyCollection(Of AssociatedParameterSetValue)
    Get
    Friend Set

Field Value

The added AssociatedParameterSetValue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQueryEventArgs Class
AssociatedParameterSetQueryEventArgs Members
ININ.IceLib.Statistics Namespace


Removed Property

[image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs..::..Removed Property
AssociatedParameterSetQueryEventArgs Class See Also Send Feedback
Gets the collection of AssociatedParameterSetValue that were removed and no longer match the query.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssociatedParameterSetValue> Removed { get; internal set; }
Visual Basic
Public Property Removed As ReadOnlyCollection(Of AssociatedParameterSetValue)
    Get
    Friend Set

Field Value

The removed AssociatedParameterSetValue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQueryEventArgs Class
AssociatedParameterSetQueryEventArgs Members
ININ.IceLib.Statistics Namespace


Updated Property

[image]

IceLib Technical Reference
AssociatedParameterSetQueryEventArgs..::..Updated Property
AssociatedParameterSetQueryEventArgs Class See Also Send Feedback
Gets the collection of AssociatedParameterSetValue that were updated and still match the query.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssociatedParameterSetValue> Updated { get; internal set; }
Visual Basic
Public Property Updated As ReadOnlyCollection(Of AssociatedParameterSetValue)
    Get
    Friend Set

Field Value

The updated AssociatedParameterSetValue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetQueryEventArgs Class
AssociatedParameterSetQueryEventArgs Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetValue Class

[image]

IceLib Technical Reference
AssociatedParameterSetValue Class
Members See Also Send Feedback
Values for a set of associated parameter types.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AssociatedParameterSetValue : IEquatable<AssociatedParameterSetValue>,
    IComparable<AssociatedParameterSetValue>, IEnumerable<DetailedParameterValue>, IEnumerable
Visual Basic
Public Class AssociatedParameterSetValue _
    Implements IEquatable(Of AssociatedParameterSetValue), IComparable(Of AssociatedParameterSetValue),  _
    IEnumerable(Of DetailedParameterValue), IEnumerable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..AssociatedParameterSetValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
ININ.IceLib.Statistics..::..AssociatedParameterSetQueryEventArgs


AssociatedParameterSetValue Members

[image] [image]

IceLib Technical Reference
AssociatedParameterSetValue Members
AssociatedParameterSetValue Class Methods Operators Properties See Also Send Feedback

The AssociatedParameterSetValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetValue) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of AssociatedParameterSetValue are equal.
GreaterThan | Determines whether one instance of AssociatedParameterSetValue is greater than another.
GreaterThanOrEqual | Determines whether one instance of AssociatedParameterSetValue is greater than or equal to another.
Inequality | Determines whether two instances of AssociatedParameterSetValue are not equal.
LessThan | Determines whether one instance of AssociatedParameterSetValue is less than another.
LessThanOrEqual | Determines whether one instance of AssociatedParameterSetValue is less than or equal to another.

Properties

 | Name | Description
Public property | Definition | Gets the AssociatedParameterSetDefinition that defines the parameters types and order for this AssociatedParameterSetValue.
Public property | Item | Gets or sets the Value for the ParameterType in this AssociatedParameterSetValue.

See Also

AssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


AssociatedParameterSetValue Methods

[image] [image]

IceLib Technical Reference
AssociatedParameterSetValue Methods
AssociatedParameterSetValue Class See Also Send Feedback

The AssociatedParameterSetValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetValue) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


CompareTo Method

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..CompareTo Method
AssociatedParameterSetValue Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual int CompareTo(
    AssociatedParameterSetValue other
)
Visual Basic
Public Overridable Function CompareTo ( _
    other As AssociatedParameterSetValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Equals Method
AssociatedParameterSetValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetValue) | Indicates whether the current object is equal to another object of the same type.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Equals Method (Object)
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (AssociatedParameterSetValue)

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Equals Method (AssociatedParameterSetValue)
AssociatedParameterSetValue Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AssociatedParameterSetValue otherAction
)
Visual Basic
Public Function Equals ( _
    otherAction As AssociatedParameterSetValue _
) As Boolean

Parameters

otherAction
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetEnumerator Method

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..GetEnumerator Method
AssociatedParameterSetValue Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerator<DetailedParameterValue> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of DetailedParameterValue)

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..GetHashCode Method
AssociatedParameterSetValue Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetValue Operators

[image] [image]

IceLib Technical Reference
AssociatedParameterSetValue Operators
AssociatedParameterSetValue Class See Also Send Feedback

The AssociatedParameterSetValue type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of AssociatedParameterSetValue are equal.
GreaterThan | Determines whether one instance of AssociatedParameterSetValue is greater than another.
GreaterThanOrEqual | Determines whether one instance of AssociatedParameterSetValue is greater than or equal to another.
Inequality | Determines whether two instances of AssociatedParameterSetValue are not equal.
LessThan | Determines whether one instance of AssociatedParameterSetValue is less than another.
LessThanOrEqual | Determines whether one instance of AssociatedParameterSetValue is less than or equal to another.

See Also

AssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Equality Operator
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether two instances of AssociatedParameterSetValue are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AssociatedParameterSetValue a,
    AssociatedParameterSetValue b
)
Visual Basic
Public Shared Operator = ( _
    a As AssociatedParameterSetValue, _
    b As AssociatedParameterSetValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The first AssociatedParameterSetValue to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The second AssociatedParameterSetValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


GreaterThan Operator

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..GreaterThan Operator
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetValue is greater than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >(
    AssociatedParameterSetValue a,
    AssociatedParameterSetValue b
)
Visual Basic
Public Shared Operator > ( _
    a As AssociatedParameterSetValue, _
    b As AssociatedParameterSetValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The first AssociatedParameterSetValue to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The second AssociatedParameterSetValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


GreaterThanOrEqual Operator

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..GreaterThanOrEqual Operator
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetValue is greater than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >=(
    AssociatedParameterSetValue a,
    AssociatedParameterSetValue b
)
Visual Basic
Public Shared Operator >= ( _
    a As AssociatedParameterSetValue, _
    b As AssociatedParameterSetValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The first AssociatedParameterSetValue to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The second AssociatedParameterSetValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Inequality Operator
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether two instances of AssociatedParameterSetValue are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AssociatedParameterSetValue a,
    AssociatedParameterSetValue b
)
Visual Basic
Public Shared Operator <> ( _
    a As AssociatedParameterSetValue, _
    b As AssociatedParameterSetValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The first AssociatedParameterSetValue to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The second AssociatedParameterSetValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


LessThan Operator

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..LessThan Operator
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetValue is less than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <(
    AssociatedParameterSetValue a,
    AssociatedParameterSetValue b
)
Visual Basic
Public Shared Operator < ( _
    a As AssociatedParameterSetValue, _
    b As AssociatedParameterSetValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The first AssociatedParameterSetValue to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The second AssociatedParameterSetValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


LessThanOrEqual Operator

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..LessThanOrEqual Operator
AssociatedParameterSetValue Class See Also Send Feedback
Determines whether one instance of AssociatedParameterSetValue is less than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <=(
    AssociatedParameterSetValue a,
    AssociatedParameterSetValue b
)
Visual Basic
Public Shared Operator <= ( _
    a As AssociatedParameterSetValue, _
    b As AssociatedParameterSetValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The first AssociatedParameterSetValue to compare.
b
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetValue
The second AssociatedParameterSetValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


AssociatedParameterSetValue Properties

[image] [image]

IceLib Technical Reference
AssociatedParameterSetValue Properties
AssociatedParameterSetValue Class See Also Send Feedback

The AssociatedParameterSetValue type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets the AssociatedParameterSetDefinition that defines the parameters types and order for this AssociatedParameterSetValue.
Public property | Item | Gets or sets the Value for the ParameterType in this AssociatedParameterSetValue.

See Also

AssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


Definition Property

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Definition Property
AssociatedParameterSetValue Class See Also Send Feedback
Gets the AssociatedParameterSetDefinition that defines the parameters types and order for this AssociatedParameterSetValue.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssociatedParameterSetDefinition Definition { get; private set; }
Visual Basic
Public Property Definition As AssociatedParameterSetDefinition
    Get
    Private Set

Field Value

The definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


Item Property

[image]

IceLib Technical Reference
AssociatedParameterSetValue..::..Item Property
AssociatedParameterSetValue Class See Also Send Feedback
Gets or sets the Value for the ParameterType in this AssociatedParameterSetValue.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DetailedParameterValue this[
    ParameterTypeId index
] { get; internal set; }
Visual Basic
Public Default Property Item ( _
    index As ParameterTypeId _
) As DetailedParameterValue
    Get
    Friend Set

Parameters

index
Type: ININ.IceLib.Statistics..::..ParameterTypeId

Field Value

The Value for the ParameterType.

Exceptions

Exception | Condition
System..::..ArgumentException | The given ParameterType is not a member of the AssociatedParameterSetValue.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AssociatedParameterSetValue Class
AssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


BoundValueType Enumeration

[image]

IceLib Technical Reference
BoundValueType Enumeration
See Also Send Feedback
Represents the type of boundary conditions a statistic may have.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum BoundValueType
Visual Basic
Public Enumeration BoundValueType

Members

Member name | Value | Description
None | 0 | The value has no boundaries.
Dynamic | 1 | The boundary value is dynamicly determined.
Fixed | 2 | The boundary value is fixed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..StatisticDefinition


DetailedParameterValue Class

[image]

IceLib Technical Reference
DetailedParameterValue Class
Members See Also Send Feedback
ParameterValue with additional display string and description.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DetailedParameterValue : ParameterValue,
    IComparable<DetailedParameterValue>
Visual Basic
Public Class DetailedParameterValue _
    Inherits ParameterValue _
    Implements IComparable(Of DetailedParameterValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterValue
ININ.IceLib.Statistics..::..DetailedParameterValue
ININ.IceLib.Statistics..::..ValidatedDetailedParameterValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..ParameterValue


DetailedParameterValue Members

[image] [image]

IceLib Technical Reference
DetailedParameterValue Members
DetailedParameterValue Class Methods Operators Properties See Also Send Feedback

The DetailedParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(DetailedParameterValue) | Compares the current object with another object of the same type.
Public method | CompareTo(ParameterValue) | Compares the current object with another object of the same type. (Inherited from ParameterValue.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ParameterValue..::..Equals(Object).)
Public method | Equals(DetailedParameterValue) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from ParameterValue.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ParameterValue..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ParameterValue..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of DetailedParameterValue are equal.
GreaterThan | Determines whether one instance of DetailedParameterValue is greater than another.
GreaterThanOrEqual | Determines whether one instance of DetailedParameterValue is greater than or equal to another.
Inequality | Determines whether two instances of DetailedParameterValue are not equal.
LessThan | Determines whether one instance of DetailedParameterValue is less than another.
LessThanOrEqual | Determines whether one instance of DetailedParameterValue is less than or equal to another.

Properties

 | Name | Description
Public property | Description | Gets the description of the parameter.
Public property | DisplayString | Gets the parameter value display string.
Public property | Type | Gets parameter type. (Inherited from ParameterValue.)
Public property | Value | Gets the parameter value ID. (Inherited from ParameterValue.)

See Also

DetailedParameterValue Class
ININ.IceLib.Statistics Namespace


DetailedParameterValue Methods

[image] [image]

IceLib Technical Reference
DetailedParameterValue Methods
DetailedParameterValue Class See Also Send Feedback

The DetailedParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(DetailedParameterValue) | Compares the current object with another object of the same type.
Public method | CompareTo(ParameterValue) | Compares the current object with another object of the same type. (Inherited from ParameterValue.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ParameterValue..::..Equals(Object).)
Public method | Equals(DetailedParameterValue) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from ParameterValue.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ParameterValue..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ParameterValue..::..ToString()()()().)

See Also

DetailedParameterValue Class
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
DetailedParameterValue..::..CompareTo Method
DetailedParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(DetailedParameterValue) | Compares the current object with another object of the same type.
Public method | CompareTo(ParameterValue) | Compares the current object with another object of the same type. (Inherited from ParameterValue.)

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (DetailedParameterValue)

[image]

IceLib Technical Reference
DetailedParameterValue..::..CompareTo Method (DetailedParameterValue)
DetailedParameterValue Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    DetailedParameterValue other
)
Visual Basic
Public Function CompareTo ( _
    other As DetailedParameterValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
DetailedParameterValue..::..Equals Method
DetailedParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ParameterValue..::..Equals(Object).)
Public method | Equals(DetailedParameterValue) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from ParameterValue.)

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
DetailedParameterValue..::..Equals Method (Object)
DetailedParameterValue Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean

Parameters

other
Type: System..::..Object

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (DetailedParameterValue)

[image]

IceLib Technical Reference
DetailedParameterValue..::..Equals Method (DetailedParameterValue)
DetailedParameterValue Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    DetailedParameterValue other
)
Visual Basic
Public Function Equals ( _
    other As DetailedParameterValue _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
An object to compare with this object.

Return Value

trueTruetruetrue (True in Visual Basic) if the current object is equal to the other parameter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
DetailedParameterValue..::..GetHashCode Method
DetailedParameterValue Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
DetailedParameterValue..::..ToString Method
DetailedParameterValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


DetailedParameterValue Operators

[image] [image]

IceLib Technical Reference
DetailedParameterValue Operators
DetailedParameterValue Class See Also Send Feedback

The DetailedParameterValue type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of DetailedParameterValue are equal.
GreaterThan | Determines whether one instance of DetailedParameterValue is greater than another.
GreaterThanOrEqual | Determines whether one instance of DetailedParameterValue is greater than or equal to another.
Inequality | Determines whether two instances of DetailedParameterValue are not equal.
LessThan | Determines whether one instance of DetailedParameterValue is less than another.
LessThanOrEqual | Determines whether one instance of DetailedParameterValue is less than or equal to another.

See Also

DetailedParameterValue Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
DetailedParameterValue..::..Equality Operator
DetailedParameterValue Class See Also Send Feedback
Determines whether two instances of DetailedParameterValue are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    DetailedParameterValue a,
    DetailedParameterValue b
)
Visual Basic
Public Shared Operator = ( _
    a As DetailedParameterValue, _
    b As DetailedParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The first DetailedParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The second DetailedParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


GreaterThan Operator

[image]

IceLib Technical Reference
DetailedParameterValue..::..GreaterThan Operator
DetailedParameterValue Class See Also Send Feedback
Determines whether one instance of DetailedParameterValue is greater than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >(
    DetailedParameterValue a,
    DetailedParameterValue b
)
Visual Basic
Public Shared Operator > ( _
    a As DetailedParameterValue, _
    b As DetailedParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The first DetailedParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The second DetailedParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


GreaterThanOrEqual Operator

[image]

IceLib Technical Reference
DetailedParameterValue..::..GreaterThanOrEqual Operator
DetailedParameterValue Class See Also Send Feedback
Determines whether one instance of DetailedParameterValue is greater than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >=(
    DetailedParameterValue a,
    DetailedParameterValue b
)
Visual Basic
Public Shared Operator >= ( _
    a As DetailedParameterValue, _
    b As DetailedParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The first DetailedParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The second DetailedParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
DetailedParameterValue..::..Inequality Operator
DetailedParameterValue Class See Also Send Feedback
Determines whether two instances of DetailedParameterValue are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    DetailedParameterValue a,
    DetailedParameterValue b
)
Visual Basic
Public Shared Operator <> ( _
    a As DetailedParameterValue, _
    b As DetailedParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The first DetailedParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The second DetailedParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


LessThan Operator

[image]

IceLib Technical Reference
DetailedParameterValue..::..LessThan Operator
DetailedParameterValue Class See Also Send Feedback
Determines whether one instance of DetailedParameterValue is less than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <(
    DetailedParameterValue a,
    DetailedParameterValue b
)
Visual Basic
Public Shared Operator < ( _
    a As DetailedParameterValue, _
    b As DetailedParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The first DetailedParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The second DetailedParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


LessThanOrEqual Operator

[image]

IceLib Technical Reference
DetailedParameterValue..::..LessThanOrEqual Operator
DetailedParameterValue Class See Also Send Feedback
Determines whether one instance of DetailedParameterValue is less than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <=(
    DetailedParameterValue a,
    DetailedParameterValue b
)
Visual Basic
Public Shared Operator <= ( _
    a As DetailedParameterValue, _
    b As DetailedParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The first DetailedParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..DetailedParameterValue
The second DetailedParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


DetailedParameterValue Properties

[image] [image]

IceLib Technical Reference
DetailedParameterValue Properties
DetailedParameterValue Class See Also Send Feedback

The DetailedParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the parameter.
Public property | DisplayString | Gets the parameter value display string.
Public property | Type | Gets parameter type. (Inherited from ParameterValue.)
Public property | Value | Gets the parameter value ID. (Inherited from ParameterValue.)

See Also

DetailedParameterValue Class
ININ.IceLib.Statistics Namespace


Description Property

[image]

IceLib Technical Reference
DetailedParameterValue..::..Description Property
DetailedParameterValue Class See Also Send Feedback
Gets the description of the parameter.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set

Field Value

The description of the parameter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


DisplayString Property

[image]

IceLib Technical Reference
DetailedParameterValue..::..DisplayString Property
DetailedParameterValue Class See Also Send Feedback
Gets the parameter value display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; internal set; }
Visual Basic
Public Property DisplayString As String
    Get
    Friend Set

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DetailedParameterValue Class
DetailedParameterValue Members
ININ.IceLib.Statistics Namespace


DrillDown Class

[image]

IceLib Technical Reference
DrillDown Class
Members See Also Send Feedback
Represents a drill down lookup. If this data is present, additional drill down data is present and can be queried with GetDrillDownData(Session, String).

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DrillDown
Visual Basic
Public Class DrillDown

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..DrillDown

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDown Members
ININ.IceLib.Statistics Namespace


DrillDown Members

[image] [image]

IceLib Technical Reference
DrillDown Members
DrillDown Class Methods Properties See Also Send Feedback

The DrillDown type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDrillDownData | Retrieve the drill down data for this drill down object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HintString | Gets the string that gives a hint as to what this drill down data refers to.
Public property | Id | Gets the ID.
Public property | TypeHint | Gets the hint as to what the format is of the drill down data.

See Also

DrillDown Class
ININ.IceLib.Statistics Namespace


DrillDown Methods

[image] [image]

IceLib Technical Reference
DrillDown Methods
DrillDown Class See Also Send Feedback

The DrillDown type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDrillDownData | Retrieve the drill down data for this drill down object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrillDown Class
ININ.IceLib.Statistics Namespace


GetDrillDownData Method

[image]

IceLib Technical Reference
DrillDown..::..GetDrillDownData Method
DrillDown Class See Also Send Feedback
Retrieve the drill down data for this drill down object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DrillDownData GetDrillDownData(
    Session session,
    string statisticKeyUri
)
Visual Basic
Public Function GetDrillDownData ( _
    session As Session, _
    statisticKeyUri As String _
) As DrillDownData

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.
statisticKeyUri
Type: System..::..String
The statistics definition ID to search against.

Return Value

The drill down data.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The statisticKeyUri length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDown Class
DrillDown Members
ININ.IceLib.Statistics Namespace


DrillDown Properties

[image] [image]

IceLib Technical Reference
DrillDown Properties
DrillDown Class See Also Send Feedback

The DrillDown type exposes the following members.

Properties

 | Name | Description
Public property | HintString | Gets the string that gives a hint as to what this drill down data refers to.
Public property | Id | Gets the ID.
Public property | TypeHint | Gets the hint as to what the format is of the drill down data.

See Also

DrillDown Class
ININ.IceLib.Statistics Namespace


HintString Property

[image]

IceLib Technical Reference
DrillDown..::..HintString Property
DrillDown Class See Also Send Feedback
Gets the string that gives a hint as to what this drill down data refers to.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HintString { get; private set; }
Visual Basic
Public Property HintString As String
    Get
    Private Set

Field Value

The hint string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDown Class
DrillDown Members
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
DrillDown..::..Id Property
DrillDown Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDown Class
DrillDown Members
ININ.IceLib.Statistics Namespace


TypeHint Property

[image]

IceLib Technical Reference
DrillDown..::..TypeHint Property
DrillDown Class See Also Send Feedback
Gets the hint as to what the format is of the drill down data.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TypeHint { get; private set; }
Visual Basic
Public Property TypeHint As String
    Get
    Private Set

Field Value

The type hint.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDown Class
DrillDown Members
ININ.IceLib.Statistics Namespace


DrillDownData Class

[image]

IceLib Technical Reference
DrillDownData Class
Members See Also Send Feedback
Represents additional statistical information that can be retrieved via the drill down process. See DrillDown for how to access this data.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DrillDownData
Visual Basic
Public Class DrillDownData

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..DrillDownData

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownData Members
ININ.IceLib.Statistics Namespace


DrillDownData Members

[image] [image]

IceLib Technical Reference
DrillDownData Members
DrillDownData Class Methods Properties See Also Send Feedback

The DrillDownData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DrillDownId | Gets the drill down ID that this data applies to.
Public property | StatisticKey | Gets the statistics key that this data applies to.
Public property | Types | Gets a read only collection of the drill down data entries.

See Also

DrillDownData Class
ININ.IceLib.Statistics Namespace


DrillDownData Methods

[image] [image]

IceLib Technical Reference
DrillDownData Methods
DrillDownData Class See Also Send Feedback

The DrillDownData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrillDownData Class
ININ.IceLib.Statistics Namespace


DrillDownData Properties

[image] [image]

IceLib Technical Reference
DrillDownData Properties
DrillDownData Class See Also Send Feedback

The DrillDownData type exposes the following members.

Properties

 | Name | Description
Public property | DrillDownId | Gets the drill down ID that this data applies to.
Public property | StatisticKey | Gets the statistics key that this data applies to.
Public property | Types | Gets a read only collection of the drill down data entries.

See Also

DrillDownData Class
ININ.IceLib.Statistics Namespace


DrillDownId Property

[image]

IceLib Technical Reference
DrillDownData..::..DrillDownId Property
DrillDownData Class See Also Send Feedback
Gets the drill down ID that this data applies to.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DrillDownId { get; private set; }
Visual Basic
Public Property DrillDownId As String
    Get
    Private Set

Field Value

The drill down ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownData Class
DrillDownData Members
ININ.IceLib.Statistics Namespace


StatisticKey Property

[image]

IceLib Technical Reference
DrillDownData..::..StatisticKey Property
DrillDownData Class See Also Send Feedback
Gets the statistics key that this data applies to.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StatisticKey { get; private set; }
Visual Basic
Public Property StatisticKey As String
    Get
    Private Set

Field Value

The statistics key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownData Class
DrillDownData Members
ININ.IceLib.Statistics Namespace


Types Property

[image]

IceLib Technical Reference
DrillDownData..::..Types Property
DrillDownData Class See Also Send Feedback
Gets a read only collection of the drill down data entries.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<DrillDownDataEntry> Types { get; private set; }
Visual Basic
Public Property Types As ReadOnlyCollection(Of DrillDownDataEntry)
    Get
    Private Set

Field Value

The types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownData Class
DrillDownData Members
ININ.IceLib.Statistics Namespace


DrillDownDataEntry Class

[image]

IceLib Technical Reference
DrillDownDataEntry Class
Members See Also Send Feedback
Represents a collection of data for a specified drill down.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DrillDownDataEntry
Visual Basic
Public Class DrillDownDataEntry

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..DrillDownDataEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownDataEntry Members
ININ.IceLib.Statistics Namespace


DrillDownDataEntry Members

[image] [image]

IceLib Technical Reference
DrillDownDataEntry Members
DrillDownDataEntry Class Constructors Methods Properties See Also Send Feedback

The DrillDownDataEntry type exposes the following members.

Constructors

 | Name | Description
Public method | DrillDownDataEntry | Initializes a new instance of the DrillDownDataEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The ID of this object.
Public property | Name | Gets the drill down data entries name.
Public property | TypeHint | Gets a hint to the data type of the values.
Public property | Values | Gets a read only collection of values. This is the actual data in the drill down.

See Also

DrillDownDataEntry Class
ININ.IceLib.Statistics Namespace


DrillDownDataEntry Constructor

[image]

IceLib Technical Reference
DrillDownDataEntry Constructor
DrillDownDataEntry Class See Also Send Feedback
Initializes a new instance of the DrillDownDataEntry class

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DrillDownDataEntry()
Visual Basic
Public Sub New

See Also

DrillDownDataEntry Class
DrillDownDataEntry Members
ININ.IceLib.Statistics Namespace


DrillDownDataEntry Methods

[image] [image]

IceLib Technical Reference
DrillDownDataEntry Methods
DrillDownDataEntry Class See Also Send Feedback

The DrillDownDataEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrillDownDataEntry Class
ININ.IceLib.Statistics Namespace


DrillDownDataEntry Properties

[image] [image]

IceLib Technical Reference
DrillDownDataEntry Properties
DrillDownDataEntry Class See Also Send Feedback

The DrillDownDataEntry type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of this object.
Public property | Name | Gets the drill down data entries name.
Public property | TypeHint | Gets a hint to the data type of the values.
Public property | Values | Gets a read only collection of values. This is the actual data in the drill down.

See Also

DrillDownDataEntry Class
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
DrillDownDataEntry..::..Id Property
DrillDownDataEntry Class See Also Send Feedback
The ID of this object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; internal set; }
Visual Basic
Public Property Id As String
    Get
    Friend Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownDataEntry Class
DrillDownDataEntry Members
ININ.IceLib.Statistics Namespace


Name Property

[image]

IceLib Technical Reference
DrillDownDataEntry..::..Name Property
DrillDownDataEntry Class See Also Send Feedback
Gets the drill down data entries name.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownDataEntry Class
DrillDownDataEntry Members
ININ.IceLib.Statistics Namespace


TypeHint Property

[image]

IceLib Technical Reference
DrillDownDataEntry..::..TypeHint Property
DrillDownDataEntry Class See Also Send Feedback
Gets a hint to the data type of the values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TypeHint { get; internal set; }
Visual Basic
Public Property TypeHint As String
    Get
    Friend Set

Field Value

The type hint.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownDataEntry Class
DrillDownDataEntry Members
ININ.IceLib.Statistics Namespace


Values Property

[image]

IceLib Technical Reference
DrillDownDataEntry..::..Values Property
DrillDownDataEntry Class See Also Send Feedback
Gets a read only collection of values. This is the actual data in the drill down.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Values { get; internal set; }
Visual Basic
Public Property Values As ReadOnlyCollection(Of String)
    Get
    Friend Set

Field Value

The values.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

DrillDownDataEntry Class
DrillDownDataEntry Members
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Class

[image]

IceLib Technical Reference
FilteredParameterQuery Class
Members Example See Also Send Feedback
Represents a query to retrieve a filtered list of the available values for a given parameter type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FilteredParameterQuery : ParameterQuery
Visual Basic
Public Class FilteredParameterQuery _
    Inherits ParameterQuery

Remarks

A FilteredParameterQuery can be used to limit the number of ParameterValue returned by a query. In some cases the server may have many thousand values for a particular ParameterType. In addition, a collection of associated ParameterValue instances may be used to further filter the results.

Examples

This example filters the results to those associated with the Marketing and Support workgroups

CopyC#
//Create a FilteredParameterQuery
var parameterType = new ParameterTypeId("Workgroup");
var associatedParameterValues = new List<ParameterValue>();
associatedParameterValues.Add(new ParameterValue(parameterType, "Marketing"));
associatedParameterValues.Add(new ParameterValue(parameterType, "Support"));

FilteredParameterQuery fpq = new FilteredParameterQuery(parameterType,associatedParameterValues);

//Execute Query
StatisticsManager _StatsManager = StatisticsManager.GetInstance(_Session);
ParameterValuesDepot pvd = new ParameterValuesDepot(_StatsManager);
ParameterQueryResult pqr = pvd.ExecuteQuery(query);

// The result only includes values associated with the Marketing and Support workgroups

This example filters the results down to a maximum of 5, which all contain the text "Admin"

CopyC#
//Create a FilteredParameterQuery
var parameterType = new ParameterTypeId("Workgroup");
FilteredParameterQuery fpq = new FilteredParameterQuery(parameterType,"Admin",5);

//Execute Query
StatisticsManager _StatsManager = StatisticsManager.GetInstance(_Session);
ParameterValuesDepot pvd = new ParameterValuesDepot(_StatsManager);
ParameterQueryResult pqr = pvd.ExecuteQuery(query);

// The are up to 5 results all of which must contain the text "Admin"

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterQuery
ININ.IceLib.Statistics..::..FilteredParameterQuery

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Members

[image] [image]

IceLib Technical Reference
FilteredParameterQuery Members
FilteredParameterQuery Class Constructors Methods Fields Properties See Also Send Feedback

The FilteredParameterQuery type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredParameterQuery(ParameterTypeId) | Initializes a new instance of the FilteredParameterQuery class.
Public method | FilteredParameterQuery(ParameterTypeId, IEnumerable<(Of <<'(ParameterValue>)>>)) | Initializes a new instance of the FilteredParameterQuery class.
Public method | FilteredParameterQuery(ParameterTypeId, String, Int32) | Initializes a new instance of the FilteredParameterQuery class.
Public method | FilteredParameterQuery(ParameterTypeId, String, Int32, IEnumerable<(Of <<'(ParameterValue>)>>)) | Initializes a new instance of the FilteredParameterQuery class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ParameterQuery..::..ToString()()()().)

Fields

Name | Description
MaxAllowableReturned | This constant is used in a FilteredParameterQuery to request the maximum number of results permitted by the system.
NoFilter | This constant is used to specify no filter string in a FilteredParameterQuery.

Properties

 | Name | Description
Public property | AssociatedParameterValues | Gets the ParameterValues that the results to this ParameterQuery must have an association with.
Public property | FilterText | Gets the filter text.
Public property | MaxNumberToReturn | Gets the max number to return.
Public property | ParameterType | Gets the type to query parameter values for. (Inherited from ParameterQuery.)

See Also

FilteredParameterQuery Class
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Constructor

[image] [image]

IceLib Technical Reference
FilteredParameterQuery Constructor
FilteredParameterQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilteredParameterQuery(ParameterTypeId) | Initializes a new instance of the FilteredParameterQuery class.
Public method | FilteredParameterQuery(ParameterTypeId, IEnumerable<(Of <<'(ParameterValue>)>>)) | Initializes a new instance of the FilteredParameterQuery class.
Public method | FilteredParameterQuery(ParameterTypeId, String, Int32) | Initializes a new instance of the FilteredParameterQuery class.
Public method | FilteredParameterQuery(ParameterTypeId, String, Int32, IEnumerable<(Of <<'(ParameterValue>)>>)) | Initializes a new instance of the FilteredParameterQuery class.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Constructor (ParameterTypeId)

[image]

IceLib Technical Reference
FilteredParameterQuery Constructor (ParameterTypeId)
FilteredParameterQuery Class See Also Send Feedback
Initializes a new instance of the FilteredParameterQuery class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilteredParameterQuery(
    ParameterTypeId parameterType
)
Visual Basic
Public Sub New ( _
    parameterType As ParameterTypeId _
)

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
ParameterType that is to be queried.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
FilteredParameterQuery Overload
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Constructor (ParameterTypeId, IEnumerable(ParameterValue))

[image]

IceLib Technical Reference
FilteredParameterQuery Constructor (ParameterTypeId, IEnumerable<(Of <(<'ParameterValue>)>)>)
FilteredParameterQuery Class See Also Send Feedback
Initializes a new instance of the FilteredParameterQuery class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilteredParameterQuery(
    ParameterTypeId parameterType,
    IEnumerable<ParameterValue> associatedParameterValues
)
Visual Basic
Public Sub New ( _
    parameterType As ParameterTypeId, _
    associatedParameterValues As IEnumerable(Of ParameterValue) _
)

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
ParameterType that is to be queried.
associatedParameterValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterValue >)>)>
A collection of ParameterValues to use in filtering the results found for the ParameterType query. All ParameterValue returned in the result to the query must have an association to each ParameterValue in the filter. A ParameterValue may appear only once for each ParameterType in the filter.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The associatedParameterValues is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
FilteredParameterQuery Overload
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Constructor (ParameterTypeId, String, Int32)

[image]

IceLib Technical Reference
FilteredParameterQuery Constructor (ParameterTypeId, String, Int32)
FilteredParameterQuery Class See Also Send Feedback
Initializes a new instance of the FilteredParameterQuery class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilteredParameterQuery(
    ParameterTypeId parameterType,
    string filterText,
    int maxNumberToReturn
)
Visual Basic
Public Sub New ( _
    parameterType As ParameterTypeId, _
    filterText As String, _
    maxNumberToReturn As Integer _
)

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
ParameterType that is to be queried.
filterText
Type: System..::..String
Text to filter the resulting ParameterValue set with.
maxNumberToReturn
Type: System..::..Int32
The maximum number of ParameterValue to return.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The filterText is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
FilteredParameterQuery Overload
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Constructor (ParameterTypeId, String, Int32, IEnumerable(ParameterValue))

[image]

IceLib Technical Reference
FilteredParameterQuery Constructor (ParameterTypeId, String, Int32, IEnumerable<(Of <(<'ParameterValue>)>)>)
FilteredParameterQuery Class See Also Send Feedback
Initializes a new instance of the FilteredParameterQuery class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FilteredParameterQuery(
    ParameterTypeId parameterType,
    string filterText,
    int maxNumberToReturn,
    IEnumerable<ParameterValue> associatedParameterValues
)
Visual Basic
Public Sub New ( _
    parameterType As ParameterTypeId, _
    filterText As String, _
    maxNumberToReturn As Integer, _
    associatedParameterValues As IEnumerable(Of ParameterValue) _
)

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
ParameterType that is to be queried.
filterText
Type: System..::..String
Text to filter the resulting ParameterValue set with.
maxNumberToReturn
Type: System..::..Int32
The maximum number of ParameterValue to return.
associatedParameterValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterValue >)>)>
A collection of ParameterValues to use in filtering the results found for the ParameterType query. All ParameterValue returned in the result to the query must have an association to each ParameterValue in the filter. A ParameterValue may appear only once for each ParameterType in the filter.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The filterText or associatedParameterValues is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
FilteredParameterQuery Overload
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Fields

[image] [image]

IceLib Technical Reference
FilteredParameterQuery Fields
FilteredParameterQuery Class See Also Send Feedback

The FilteredParameterQuery type exposes the following members.

Fields

Name | Description
MaxAllowableReturned | This constant is used in a FilteredParameterQuery to request the maximum number of results permitted by the system.
NoFilter | This constant is used to specify no filter string in a FilteredParameterQuery.

See Also

FilteredParameterQuery Class
ININ.IceLib.Statistics Namespace


MaxAllowableReturned Field

[image]

IceLib Technical Reference
FilteredParameterQuery..::..MaxAllowableReturned Field
FilteredParameterQuery Class See Also Send Feedback
This constant is used in a FilteredParameterQuery to request the maximum number of results permitted by the system.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const int MaxAllowableReturned
Visual Basic
Public Const MaxAllowableReturned As Integer

Remarks

A FilteredParameterQuery may specify a maximum number of results to return for a given query. The system also maintains an internal maximum number of results to return. As such, even when the MaxAllowableReturned value is used in the FilteredParameterQuery, the system may not return all results, and instead return a portion of the results to the query.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


NoFilter Field

[image]

IceLib Technical Reference
FilteredParameterQuery..::..NoFilter Field
FilteredParameterQuery Class See Also Send Feedback
This constant is used to specify no filter string in a FilteredParameterQuery.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const string NoFilter
Visual Basic
Public Const NoFilter As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace
ParameterValue..::..All


FilteredParameterQuery Methods

[image] [image]

IceLib Technical Reference
FilteredParameterQuery Methods
FilteredParameterQuery Class See Also Send Feedback

The FilteredParameterQuery type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ParameterQuery..::..ToString()()()().)

See Also

FilteredParameterQuery Class
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
FilteredParameterQuery..::..ToString Method
FilteredParameterQuery Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


FilteredParameterQuery Properties

[image] [image]

IceLib Technical Reference
FilteredParameterQuery Properties
FilteredParameterQuery Class See Also Send Feedback

The FilteredParameterQuery type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedParameterValues | Gets the ParameterValues that the results to this ParameterQuery must have an association with.
Public property | FilterText | Gets the filter text.
Public property | MaxNumberToReturn | Gets the max number to return.
Public property | ParameterType | Gets the type to query parameter values for. (Inherited from ParameterQuery.)

See Also

FilteredParameterQuery Class
ININ.IceLib.Statistics Namespace


AssociatedParameterValues Property

[image]

IceLib Technical Reference
FilteredParameterQuery..::..AssociatedParameterValues Property
FilteredParameterQuery Class See Also Send Feedback
Gets the ParameterValues that the results to this ParameterQuery must have an association with.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ParameterValue> AssociatedParameterValues { get; }
Visual Basic
Public ReadOnly Property AssociatedParameterValues As ReadOnlyCollection(Of ParameterValue)
    Get

Field Value

The collection of required ParameterValues.

Remarks

A query may be further filtered by specifying relationships to other parameter types. For instance, if the query is to return ParameterValue of type Agent, the query could be further refined to only return values for Agents that are a members of Support Workgroup. In this case, the RelatedParameterValues collection would contain a ParameterValue of ParameterType Workgroup with the value Support.

To perform a query that returns only values that are associated to a ParameterType(s), but the specific ParameterValue for that ParameterType is not important, create a ParameterValue with the required ParameterType and the Value set to All.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


FilterText Property

[image]

IceLib Technical Reference
FilteredParameterQuery..::..FilterText Property
FilteredParameterQuery Class See Also Send Feedback
Gets the filter text.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FilterText { get; private set; }
Visual Basic
Public Property FilterText As String
    Get
    Private Set

Field Value

The filter text.

Remarks

The filter text is applied to the results of the query. For instance, if the query is for ParameterType Agent and the filter text is "Jones", only those ParameterValues that contain the string "Jones" will be returned. If the results should not be filtered, set this property to an empty string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


MaxNumberToReturn Property

[image]

IceLib Technical Reference
FilteredParameterQuery..::..MaxNumberToReturn Property
FilteredParameterQuery Class See Also Send Feedback
Gets the max number to return.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaxNumberToReturn { get; private set; }
Visual Basic
Public Property MaxNumberToReturn As Integer
    Get
    Private Set

Field Value

The max number to return.

Remarks

If the server should return the maximum number of results possible, set this value to -1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

FilteredParameterQuery Class
FilteredParameterQuery Members
ININ.IceLib.Statistics Namespace


ParameterQuery Class

[image]

IceLib Technical Reference
ParameterQuery Class
Members See Also Send Feedback
Represents a query to list the available values for a given parameter type. ParameterQuery is used in ExecuteQuery(ParameterQuery) to define what is being queried.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterQuery
Visual Basic
Public Class ParameterQuery

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterQuery
ININ.IceLib.Statistics..::..FilteredParameterQuery

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQuery Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..FilteredParameterQuery


ParameterQuery Members

[image] [image]

IceLib Technical Reference
ParameterQuery Members
ParameterQuery Class Constructors Methods Properties See Also Send Feedback

The ParameterQuery type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterQuery | Initializes a new instance of the ParameterQuery class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ParameterType | Gets the type to query parameter values for.

See Also

ParameterQuery Class
ININ.IceLib.Statistics Namespace


ParameterQuery Constructor

[image]

IceLib Technical Reference
ParameterQuery Constructor
ParameterQuery Class See Also Send Feedback
Initializes a new instance of the ParameterQuery class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQuery(
    ParameterTypeId parameterType
)
Visual Basic
Public Sub New ( _
    parameterType As ParameterTypeId _
)

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
Type of the parameter to query for.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQuery Class
ParameterQuery Members
ININ.IceLib.Statistics Namespace


ParameterQuery Methods

[image] [image]

IceLib Technical Reference
ParameterQuery Methods
ParameterQuery Class See Also Send Feedback

The ParameterQuery type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ParameterQuery Class
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
ParameterQuery..::..ToString Method
ParameterQuery Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterQuery Class
ParameterQuery Members
ININ.IceLib.Statistics Namespace


ParameterQuery Properties

[image] [image]

IceLib Technical Reference
ParameterQuery Properties
ParameterQuery Class See Also Send Feedback

The ParameterQuery type exposes the following members.

Properties

 | Name | Description
Public property | ParameterType | Gets the type to query parameter values for.

See Also

ParameterQuery Class
ININ.IceLib.Statistics Namespace


ParameterType Property

[image]

IceLib Technical Reference
ParameterQuery..::..ParameterType Property
ParameterQuery Class See Also Send Feedback
Gets the type to query parameter values for.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterTypeId ParameterType { get; }
Visual Basic
Public ReadOnly Property ParameterType As ParameterTypeId
    Get

Field Value

The type of the parameter.

Remarks

The parameter values returned by the query will be of type ParameterType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQuery Class
ParameterQuery Members
ININ.IceLib.Statistics Namespace


ParameterQueryCompletedEventArgs Class

[image]

IceLib Technical Reference
ParameterQueryCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronous completed events of ParameterValuesDepot.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterQueryCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class ParameterQueryCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Statistics..::..ParameterQueryCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryCompletedEventArgs Members
ININ.IceLib.Statistics Namespace


ParameterQueryCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
ParameterQueryCompletedEventArgs Members
ParameterQueryCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ParameterQueryCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterQueryCompletedEventArgs | Initializes a new instance of the ParameterQueryCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Results | Gets the results associated with the query.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ParameterQueryCompletedEventArgs Class
ININ.IceLib.Statistics Namespace


ParameterQueryCompletedEventArgs Constructor

[image]

IceLib Technical Reference
ParameterQueryCompletedEventArgs Constructor
ParameterQueryCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ParameterQueryCompletedEventArgs class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQueryCompletedEventArgs(
    ParameterQueryResult results,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    results As ParameterQueryResult, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

results
Type: ININ.IceLib.Statistics..::..ParameterQueryResult
The results.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
State of the user.

Exceptions

Exception | Condition
System..::..ArgumentNullException | results is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryCompletedEventArgs Class
ParameterQueryCompletedEventArgs Members
ININ.IceLib.Statistics Namespace


ParameterQueryCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
ParameterQueryCompletedEventArgs Methods
ParameterQueryCompletedEventArgs Class See Also Send Feedback

The ParameterQueryCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterQueryCompletedEventArgs Class
ININ.IceLib.Statistics Namespace


ParameterQueryCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
ParameterQueryCompletedEventArgs Properties
ParameterQueryCompletedEventArgs Class See Also Send Feedback

The ParameterQueryCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Results | Gets the results associated with the query.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ParameterQueryCompletedEventArgs Class
ININ.IceLib.Statistics Namespace


Results Property

[image]

IceLib Technical Reference
ParameterQueryCompletedEventArgs..::..Results Property
ParameterQueryCompletedEventArgs Class See Also Send Feedback
Gets the results associated with the query.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQueryResult Results { get; }
Visual Basic
Public ReadOnly Property Results As ParameterQueryResult
    Get

Field Value

The results.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryCompletedEventArgs Class
ParameterQueryCompletedEventArgs Members
ININ.IceLib.Statistics Namespace


ParameterQueryResult Class

[image]

IceLib Technical Reference
ParameterQueryResult Class
Members See Also Send Feedback
Represents the results from ExecuteQuery(ParameterQuery).

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterQueryResult
Visual Basic
Public Class ParameterQueryResult

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterQueryResult

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..ParameterQuery


ParameterQueryResult Members

[image] [image]

IceLib Technical Reference
ParameterQueryResult Members
ParameterQueryResult Class Constructors Methods Properties See Also Send Feedback

The ParameterQueryResult type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterQueryResult(ParameterQuery) | Initializes a new instance of the ParameterQueryResult class.
Public method | ParameterQueryResult(ParameterQuery, ParameterQueryResultStatus, IEnumerable<(Of <<'(DetailedParameterValue>)>>)) | Initializes a new instance of the ParameterQueryResult class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NumberValuesAvailable | Gets the number values available.
Public property | NumberValuesReturned | Gets the number values returned.
Public property | Query | Gets the query associated with this query result.
Public property | ResultStatus | Gets the result status.
Public property | Values | Gets the result data set.

See Also

ParameterQueryResult Class
ININ.IceLib.Statistics Namespace


ParameterQueryResult Constructor

[image] [image]

IceLib Technical Reference
ParameterQueryResult Constructor
ParameterQueryResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParameterQueryResult(ParameterQuery) | Initializes a new instance of the ParameterQueryResult class.
Public method | ParameterQueryResult(ParameterQuery, ParameterQueryResultStatus, IEnumerable<(Of <<'(DetailedParameterValue>)>>)) | Initializes a new instance of the ParameterQueryResult class.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ININ.IceLib.Statistics Namespace


ParameterQueryResult Constructor (ParameterQuery)

[image]

IceLib Technical Reference
ParameterQueryResult Constructor (ParameterQuery)
ParameterQueryResult Class See Also Send Feedback
Initializes a new instance of the ParameterQueryResult class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQueryResult(
    ParameterQuery query
)
Visual Basic
Public Sub New ( _
    query As ParameterQuery _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..ParameterQuery
The query.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The query parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ParameterQueryResult Overload
ININ.IceLib.Statistics Namespace


ParameterQueryResult Constructor (ParameterQuery, ParameterQueryResultStatus, IEnumerable(DetailedParameterValue))

[image]

IceLib Technical Reference
ParameterQueryResult Constructor (ParameterQuery, ParameterQueryResultStatus, IEnumerable<(Of <(<'DetailedParameterValue>)>)>)
ParameterQueryResult Class See Also Send Feedback
Initializes a new instance of the ParameterQueryResult class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQueryResult(
    ParameterQuery query,
    ParameterQueryResultStatus resultStatus,
    IEnumerable<DetailedParameterValue> values
)
Visual Basic
Public Sub New ( _
    query As ParameterQuery, _
    resultStatus As ParameterQueryResultStatus, _
    values As IEnumerable(Of DetailedParameterValue) _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..ParameterQuery
The query these results are for.
resultStatus
Type: ININ.IceLib.Statistics..::..ParameterQueryResultStatus
The result status.
values
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DetailedParameterValue >)>)>
The values returned by the query.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The values or query parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | The resultStatus parameter is not a valid value for ParameterQueryResultStatus.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ParameterQueryResult Overload
ININ.IceLib.Statistics Namespace


ParameterQueryResult Methods

[image] [image]

IceLib Technical Reference
ParameterQueryResult Methods
ParameterQueryResult Class See Also Send Feedback

The ParameterQueryResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterQueryResult Class
ININ.IceLib.Statistics Namespace


ParameterQueryResult Properties

[image] [image]

IceLib Technical Reference
ParameterQueryResult Properties
ParameterQueryResult Class See Also Send Feedback

The ParameterQueryResult type exposes the following members.

Properties

 | Name | Description
Public property | NumberValuesAvailable | Gets the number values available.
Public property | NumberValuesReturned | Gets the number values returned.
Public property | Query | Gets the query associated with this query result.
Public property | ResultStatus | Gets the result status.
Public property | Values | Gets the result data set.

See Also

ParameterQueryResult Class
ININ.IceLib.Statistics Namespace


NumberValuesAvailable Property

[image]

IceLib Technical Reference
ParameterQueryResult..::..NumberValuesAvailable Property
ParameterQueryResult Class See Also Send Feedback
Gets the number values available.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int NumberValuesAvailable { get; private set; }
Visual Basic
Public Property NumberValuesAvailable As Integer
    Get
    Private Set

Field Value

The number values available.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ININ.IceLib.Statistics Namespace


NumberValuesReturned Property

[image]

IceLib Technical Reference
ParameterQueryResult..::..NumberValuesReturned Property
ParameterQueryResult Class See Also Send Feedback
Gets the number values returned.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int NumberValuesReturned { get; }
Visual Basic
Public ReadOnly Property NumberValuesReturned As Integer
    Get

Field Value

The number values returned.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ININ.IceLib.Statistics Namespace


Query Property

[image]

IceLib Technical Reference
ParameterQueryResult..::..Query Property
ParameterQueryResult Class See Also Send Feedback
Gets the query associated with this query result.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQuery Query { get; private set; }
Visual Basic
Public Property Query As ParameterQuery
    Get
    Private Set

Field Value

The query.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ININ.IceLib.Statistics Namespace


ResultStatus Property

[image]

IceLib Technical Reference
ParameterQueryResult..::..ResultStatus Property
ParameterQueryResult Class See Also Send Feedback
Gets the result status.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQueryResultStatus ResultStatus { get; private set; }
Visual Basic
Public Property ResultStatus As ParameterQueryResultStatus
    Get
    Private Set

Field Value

The result status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ININ.IceLib.Statistics Namespace


Values Property

[image]

IceLib Technical Reference
ParameterQueryResult..::..Values Property
ParameterQueryResult Class See Also Send Feedback
Gets the result data set.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<DetailedParameterValue> Values { get; }
Visual Basic
Public ReadOnly Property Values As ReadOnlyCollection(Of DetailedParameterValue)
    Get

Field Value

The result data set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterQueryResult Class
ParameterQueryResult Members
ININ.IceLib.Statistics Namespace


ParameterQueryResultStatus Enumeration

[image]

IceLib Technical Reference
ParameterQueryResultStatus Enumeration
See Also Send Feedback
Represents the status of a ParameterQueryResult.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ParameterQueryResultStatus
Visual Basic
Public Enumeration ParameterQueryResultStatus

Members

Member name | Value | Description
None | 0 | Query result status has not been determined yet.
Success | 1 | The query was a success.
QueryNotSupported | 2 | The query is not supported and cannot be fulfilled.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics Namespace


ParameterType Class

[image]

IceLib Technical Reference
ParameterType Class
Members See Also Send Feedback
Defines the type of a parameter.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterType : IEquatable<ParameterType>,
    IComparable<ParameterType>
Visual Basic
Public Class ParameterType _
    Implements IEquatable(Of ParameterType), IComparable(Of ParameterType)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterType

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Members
ININ.IceLib.Statistics Namespace


ParameterType Members

[image] [image]

IceLib Technical Reference
ParameterType Members
ParameterType Class Methods Operators Properties See Also Send Feedback

The ParameterType type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterType) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of ParameterType are equal.
GreaterThan | Determines whether one instance of ParameterType is greater than another.
GreaterThanOrEqual | Determines whether one instance of ParameterType is greater than or equal to another.
Inequality | Determines whether two instances of ParameterType are not equal.
LessThan | Determines whether one instance of ParameterType is less than another.
LessThanOrEqual | Determines whether one instance of ParameterType is less than or equal to another.

Properties

 | Name | Description
Public property | DisplayText | Gets the display text.
Public property | Id | Gets the ID.
Public property | PreserveOrder | Gets the flag that determines if the display order should be preserved.

See Also

ParameterType Class
ININ.IceLib.Statistics Namespace


ParameterType Methods

[image] [image]

IceLib Technical Reference
ParameterType Methods
ParameterType Class See Also Send Feedback

The ParameterType type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterType) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ParameterType Class
ININ.IceLib.Statistics Namespace


CompareTo Method

[image]

IceLib Technical Reference
ParameterType..::..CompareTo Method
ParameterType Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    ParameterType other
)
Visual Basic
Public Function CompareTo ( _
    other As ParameterType _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterType
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ParameterType..::..Equals Method
ParameterType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterType) | Indicates whether the current object is equal to another object of the same type.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ParameterType..::..Equals Method (Object)
ParameterType Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (ParameterType)

[image]

IceLib Technical Reference
ParameterType..::..Equals Method (ParameterType)
ParameterType Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ParameterType other
)
Visual Basic
Public Function Equals ( _
    other As ParameterType _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterType
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ParameterType..::..GetHashCode Method
ParameterType Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
ParameterType..::..ToString Method
ParameterType Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


ParameterType Operators

[image] [image]

IceLib Technical Reference
ParameterType Operators
ParameterType Class See Also Send Feedback

The ParameterType type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of ParameterType are equal.
GreaterThan | Determines whether one instance of ParameterType is greater than another.
GreaterThanOrEqual | Determines whether one instance of ParameterType is greater than or equal to another.
Inequality | Determines whether two instances of ParameterType are not equal.
LessThan | Determines whether one instance of ParameterType is less than another.
LessThanOrEqual | Determines whether one instance of ParameterType is less than or equal to another.

See Also

ParameterType Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
ParameterType..::..Equality Operator
ParameterType Class See Also Send Feedback
Determines whether two instances of ParameterType are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ParameterType a,
    ParameterType b
)
Visual Basic
Public Shared Operator = ( _
    a As ParameterType, _
    b As ParameterType _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterType
The first ParameterType to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterType
The second ParameterType to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


GreaterThan Operator

[image]

IceLib Technical Reference
ParameterType..::..GreaterThan Operator
ParameterType Class See Also Send Feedback
Determines whether one instance of ParameterType is greater than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >(
    ParameterType a,
    ParameterType b
)
Visual Basic
Public Shared Operator > ( _
    a As ParameterType, _
    b As ParameterType _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterType
The first ParameterType to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterType
The second ParameterType to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


GreaterThanOrEqual Operator

[image]

IceLib Technical Reference
ParameterType..::..GreaterThanOrEqual Operator
ParameterType Class See Also Send Feedback
Determines whether one instance of ParameterType is greater than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >=(
    ParameterType a,
    ParameterType b
)
Visual Basic
Public Shared Operator >= ( _
    a As ParameterType, _
    b As ParameterType _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterType
The first ParameterType to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterType
The second ParameterType to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
ParameterType..::..Inequality Operator
ParameterType Class See Also Send Feedback
Determines whether two instances of ParameterType are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ParameterType a,
    ParameterType b
)
Visual Basic
Public Shared Operator <> ( _
    a As ParameterType, _
    b As ParameterType _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterType
The first ParameterType to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterType
The second ParameterType to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


LessThan Operator

[image]

IceLib Technical Reference
ParameterType..::..LessThan Operator
ParameterType Class See Also Send Feedback
Determines whether one instance of ParameterType is less than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <(
    ParameterType a,
    ParameterType b
)
Visual Basic
Public Shared Operator < ( _
    a As ParameterType, _
    b As ParameterType _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterType
The first ParameterType to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterType
The second ParameterType to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


LessThanOrEqual Operator

[image]

IceLib Technical Reference
ParameterType..::..LessThanOrEqual Operator
ParameterType Class See Also Send Feedback
Determines whether one instance of ParameterType is less than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <=(
    ParameterType a,
    ParameterType b
)
Visual Basic
Public Shared Operator <= ( _
    a As ParameterType, _
    b As ParameterType _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterType
The first ParameterType to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterType
The second ParameterType to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


ParameterType Properties

[image] [image]

IceLib Technical Reference
ParameterType Properties
ParameterType Class See Also Send Feedback

The ParameterType type exposes the following members.

Properties

 | Name | Description
Public property | DisplayText | Gets the display text.
Public property | Id | Gets the ID.
Public property | PreserveOrder | Gets the flag that determines if the display order should be preserved.

See Also

ParameterType Class
ININ.IceLib.Statistics Namespace


DisplayText Property

[image]

IceLib Technical Reference
ParameterType..::..DisplayText Property
ParameterType Class See Also Send Feedback
Gets the display text.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayText { get; private set; }
Visual Basic
Public Property DisplayText As String
    Get
    Private Set

Field Value

The display text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
ParameterType..::..Id Property
ParameterType Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterTypeId Id { get; private set; }
Visual Basic
Public Property Id As ParameterTypeId
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


PreserveOrder Property

[image]

IceLib Technical Reference
ParameterType..::..PreserveOrder Property
ParameterType Class See Also Send Feedback
Gets the flag that determines if the display order should be preserved.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PreserveOrder { get; private set; }
Visual Basic
Public Property PreserveOrder As Boolean
    Get
    Private Set

Field Value

The flag for preserving display order.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterType Class
ParameterType Members
ININ.IceLib.Statistics Namespace


ParameterTypeDefinition Class

[image]

IceLib Technical Reference
ParameterTypeDefinition Class
Members See Also Send Feedback
Represents additional details for a ParameterType object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterTypeDefinition
Visual Basic
Public Class ParameterTypeDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterTypeDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeDefinition Members
ININ.IceLib.Statistics Namespace


ParameterTypeDefinition Members

[image] [image]

IceLib Technical Reference
ParameterTypeDefinition Members
ParameterTypeDefinition Class Methods Properties See Also Send Feedback

The ParameterTypeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessControlLists | Access control lists that will be applied on the values of this parameter.
Public property | Description | Gets the description for the associated ParameterType object.
Public property | DisplayString | Gets the display string for the associated ParameterType object.
Public property | Id | Gets the ID of the ParameterType object that this definition applies to.
Public property | PreserveOrder | Gets the flag that determines if the display order should be preserved.

See Also

ParameterTypeDefinition Class
ININ.IceLib.Statistics Namespace


ParameterTypeDefinition Methods

[image] [image]

IceLib Technical Reference
ParameterTypeDefinition Methods
ParameterTypeDefinition Class See Also Send Feedback

The ParameterTypeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterTypeDefinition Class
ININ.IceLib.Statistics Namespace


ParameterTypeDefinition Properties

[image] [image]

IceLib Technical Reference
ParameterTypeDefinition Properties
ParameterTypeDefinition Class See Also Send Feedback

The ParameterTypeDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AccessControlLists | Access control lists that will be applied on the values of this parameter.
Public property | Description | Gets the description for the associated ParameterType object.
Public property | DisplayString | Gets the display string for the associated ParameterType object.
Public property | Id | Gets the ID of the ParameterType object that this definition applies to.
Public property | PreserveOrder | Gets the flag that determines if the display order should be preserved.

See Also

ParameterTypeDefinition Class
ININ.IceLib.Statistics Namespace


AccessControlLists Property

[image]

IceLib Technical Reference
ParameterTypeDefinition..::..AccessControlLists Property
ParameterTypeDefinition Class See Also Send Feedback
Access control lists that will be applied on the values of this parameter.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> AccessControlLists { get; private set; }
Visual Basic
Public Property AccessControlLists As ReadOnlyCollection(Of String)
    Get
    Private Set

Field Value

The Access Control Lists.

Remarks

Each of the access control lists returned by this property could be used to fetch parameter values that the Session user is allowed to use. When retrieving available parameter values associated with this ParameterTypeDefinition, the values will be filtered to only include items allowed by these access control lists.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeDefinition Class
ParameterTypeDefinition Members
ININ.IceLib.Statistics Namespace


Description Property

[image]

IceLib Technical Reference
ParameterTypeDefinition..::..Description Property
ParameterTypeDefinition Class See Also Send Feedback
Gets the description for the associated ParameterType object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeDefinition Class
ParameterTypeDefinition Members
ININ.IceLib.Statistics Namespace


DisplayString Property

[image]

IceLib Technical Reference
ParameterTypeDefinition..::..DisplayString Property
ParameterTypeDefinition Class See Also Send Feedback
Gets the display string for the associated ParameterType object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; private set; }
Visual Basic
Public Property DisplayString As String
    Get
    Private Set

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeDefinition Class
ParameterTypeDefinition Members
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
ParameterTypeDefinition..::..Id Property
ParameterTypeDefinition Class See Also Send Feedback
Gets the ID of the ParameterType object that this definition applies to.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeDefinition Class
ParameterTypeDefinition Members
ININ.IceLib.Statistics Namespace


PreserveOrder Property

[image]

IceLib Technical Reference
ParameterTypeDefinition..::..PreserveOrder Property
ParameterTypeDefinition Class See Also Send Feedback
Gets the flag that determines if the display order should be preserved.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PreserveOrder { get; private set; }
Visual Basic
Public Property PreserveOrder As Boolean
    Get
    Private Set

Field Value

The flag for preserving display order.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeDefinition Class
ParameterTypeDefinition Members
ININ.IceLib.Statistics Namespace


ParameterTypeId Class

[image]

IceLib Technical Reference
ParameterTypeId Class
Members See Also Send Feedback
The ID value of a ParameterType.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterTypeId : IEquatable<ParameterTypeId>,
    IComparable<ParameterTypeId>
Visual Basic
Public Class ParameterTypeId _
    Implements IEquatable(Of ParameterTypeId), IComparable(Of ParameterTypeId)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterTypeId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Members
ININ.IceLib.Statistics Namespace


ParameterTypeId Members

[image] [image]

IceLib Technical Reference
ParameterTypeId Members
ParameterTypeId Class Constructors Methods Operators Properties See Also Send Feedback

The ParameterTypeId type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterTypeId | Initializes a new instance of the ParameterTypeId class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterTypeId) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of ParameterTypeId are equal.
GreaterThan | Determines whether one instance of ParameterTypeId is greater than another.
GreaterThanOrEqual | Determines whether one instance of ParameterTypeId is greater than or equal to another.
Inequality | Determines whether two instances of ParameterTypeId are not equal.
LessThan | Determines whether one instance of ParameterTypeId is less than another.
LessThanOrEqual | Determines whether one instance of ParameterTypeId is less than or equal to another.

Properties

 | Name | Description
Public property | Id | Gets the ID.

See Also

ParameterTypeId Class
ININ.IceLib.Statistics Namespace


ParameterTypeId Constructor

[image]

IceLib Technical Reference
ParameterTypeId Constructor
ParameterTypeId Class See Also Send Feedback
Initializes a new instance of the ParameterTypeId class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterTypeId(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


ParameterTypeId Methods

[image] [image]

IceLib Technical Reference
ParameterTypeId Methods
ParameterTypeId Class See Also Send Feedback

The ParameterTypeId type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterTypeId) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ParameterTypeId Class
ININ.IceLib.Statistics Namespace


CompareTo Method

[image]

IceLib Technical Reference
ParameterTypeId..::..CompareTo Method
ParameterTypeId Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    ParameterTypeId other
)
Visual Basic
Public Function CompareTo ( _
    other As ParameterTypeId _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterTypeId
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ParameterTypeId..::..Equals Method
ParameterTypeId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterTypeId) | Indicates whether the current object is equal to another object of the same type.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ParameterTypeId..::..Equals Method (Object)
ParameterTypeId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (ParameterTypeId)

[image]

IceLib Technical Reference
ParameterTypeId..::..Equals Method (ParameterTypeId)
ParameterTypeId Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ParameterTypeId other
)
Visual Basic
Public Function Equals ( _
    other As ParameterTypeId _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterTypeId
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ParameterTypeId..::..GetHashCode Method
ParameterTypeId Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
ParameterTypeId..::..ToString Method
ParameterTypeId Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


ParameterTypeId Operators

[image] [image]

IceLib Technical Reference
ParameterTypeId Operators
ParameterTypeId Class See Also Send Feedback

The ParameterTypeId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of ParameterTypeId are equal.
GreaterThan | Determines whether one instance of ParameterTypeId is greater than another.
GreaterThanOrEqual | Determines whether one instance of ParameterTypeId is greater than or equal to another.
Inequality | Determines whether two instances of ParameterTypeId are not equal.
LessThan | Determines whether one instance of ParameterTypeId is less than another.
LessThanOrEqual | Determines whether one instance of ParameterTypeId is less than or equal to another.

See Also

ParameterTypeId Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
ParameterTypeId..::..Equality Operator
ParameterTypeId Class See Also Send Feedback
Determines whether two instances of ParameterTypeId are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ParameterTypeId a,
    ParameterTypeId b
)
Visual Basic
Public Shared Operator = ( _
    a As ParameterTypeId, _
    b As ParameterTypeId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The first ParameterTypeId to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The second ParameterTypeId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


GreaterThan Operator

[image]

IceLib Technical Reference
ParameterTypeId..::..GreaterThan Operator
ParameterTypeId Class See Also Send Feedback
Determines whether one instance of ParameterTypeId is greater than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >(
    ParameterTypeId a,
    ParameterTypeId b
)
Visual Basic
Public Shared Operator > ( _
    a As ParameterTypeId, _
    b As ParameterTypeId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The first ParameterTypeId to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The second ParameterTypeId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


GreaterThanOrEqual Operator

[image]

IceLib Technical Reference
ParameterTypeId..::..GreaterThanOrEqual Operator
ParameterTypeId Class See Also Send Feedback
Determines whether one instance of ParameterTypeId is greater than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >=(
    ParameterTypeId a,
    ParameterTypeId b
)
Visual Basic
Public Shared Operator >= ( _
    a As ParameterTypeId, _
    b As ParameterTypeId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The first ParameterTypeId to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The second ParameterTypeId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
ParameterTypeId..::..Inequality Operator
ParameterTypeId Class See Also Send Feedback
Determines whether two instances of ParameterTypeId are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ParameterTypeId a,
    ParameterTypeId b
)
Visual Basic
Public Shared Operator <> ( _
    a As ParameterTypeId, _
    b As ParameterTypeId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The first ParameterTypeId to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The second ParameterTypeId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


LessThan Operator

[image]

IceLib Technical Reference
ParameterTypeId..::..LessThan Operator
ParameterTypeId Class See Also Send Feedback
Determines whether one instance of ParameterTypeId is less than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <(
    ParameterTypeId a,
    ParameterTypeId b
)
Visual Basic
Public Shared Operator < ( _
    a As ParameterTypeId, _
    b As ParameterTypeId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The first ParameterTypeId to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The second ParameterTypeId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


LessThanOrEqual Operator

[image]

IceLib Technical Reference
ParameterTypeId..::..LessThanOrEqual Operator
ParameterTypeId Class See Also Send Feedback
Determines whether one instance of ParameterTypeId is less than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <=(
    ParameterTypeId a,
    ParameterTypeId b
)
Visual Basic
Public Shared Operator <= ( _
    a As ParameterTypeId, _
    b As ParameterTypeId _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The first ParameterTypeId to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The second ParameterTypeId to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


ParameterTypeId Properties

[image] [image]

IceLib Technical Reference
ParameterTypeId Properties
ParameterTypeId Class See Also Send Feedback

The ParameterTypeId type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID.

See Also

ParameterTypeId Class
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
ParameterTypeId..::..Id Property
ParameterTypeId Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; internal set; }
Visual Basic
Public Property Id As String
    Get
    Friend Set

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterTypeId Class
ParameterTypeId Members
ININ.IceLib.Statistics Namespace


ParameterValue Class

[image]

IceLib Technical Reference
ParameterValue Class
Members See Also Send Feedback
Represents a parameter type and its value. A statistic parameter helps define which specific statistic is being dealt with. For example, an alert can be setup to trigger for a queue. Using a parameter, that alert can be defined to only apply to specific members of a workgroup.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterValue : IEquatable<ParameterValue>,
    IComparable<ParameterValue>
Visual Basic
Public Class ParameterValue _
    Implements IEquatable(Of ParameterValue), IComparable(Of ParameterValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterValue
ININ.IceLib.Statistics..::..DetailedParameterValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Members
ININ.IceLib.Statistics Namespace


ParameterValue Members

[image] [image]

IceLib Technical Reference
ParameterValue Members
ParameterValue Class Constructors Methods Operators Properties See Also Send Feedback

The ParameterValue type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterValue(ParameterValue) | Initializes a new instance of the ParameterValue class.
Public method | ParameterValue(ParameterTypeId, String) | Initializes a new instance of the ParameterValue class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two instances of ParameterValue are equal.
GreaterThan | Determines whether one instance of ParameterValue is greater than another.
GreaterThanOrEqual | Determines whether one instance of ParameterValue is greater than or equal to another.
Inequality | Determines whether two instances of ParameterValue are not equal.
LessThan | Determines whether one instance of ParameterValue is less than another.
LessThanOrEqual | Determines whether one instance of ParameterValue is less than or equal to another.

Properties

 | Name | Description
 | All | Value to use when indicating that all valid parameter values are to be used in calculating the statistic.
Public property | Type | Gets parameter type.
Public property | Value | Gets the parameter value ID.

See Also

ParameterValue Class
ININ.IceLib.Statistics Namespace


ParameterValue Constructor

[image] [image]

IceLib Technical Reference
ParameterValue Constructor
ParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParameterValue(ParameterValue) | Initializes a new instance of the ParameterValue class.
Public method | ParameterValue(ParameterTypeId, String) | Initializes a new instance of the ParameterValue class.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


ParameterValue Constructor (ParameterValue)

[image]

IceLib Technical Reference
ParameterValue Constructor (ParameterValue)
ParameterValue Class See Also Send Feedback
Initializes a new instance of the ParameterValue class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValue(
    ParameterValue parameterValue
)
Visual Basic
Public Sub New ( _
    parameterValue As ParameterValue _
)

Parameters

parameterValue
Type: ININ.IceLib.Statistics..::..ParameterValue
The parameter value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | parameterValue is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ParameterValue Overload
ININ.IceLib.Statistics Namespace


ParameterValue Constructor (ParameterTypeId, String)

[image]

IceLib Technical Reference
ParameterValue Constructor (ParameterTypeId, String)
ParameterValue Class See Also Send Feedback
Initializes a new instance of the ParameterValue class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValue(
    ParameterTypeId parameterTypeId,
    string parameterValue
)
Visual Basic
Public Sub New ( _
    parameterTypeId As ParameterTypeId, _
    parameterValue As String _
)

Parameters

parameterTypeId
Type: ININ.IceLib.Statistics..::..ParameterTypeId
Type of the parameter.
parameterValue
Type: System..::..String
The parameter's value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | parameterTypeId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ParameterValue Overload
ININ.IceLib.Statistics Namespace


ParameterValue Methods

[image] [image]

IceLib Technical Reference
ParameterValue Methods
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ParameterValue Class
ININ.IceLib.Statistics Namespace


CompareTo Method

[image]

IceLib Technical Reference
ParameterValue..::..CompareTo Method
ParameterValue Class See Also Send Feedback
Compares the current object with another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual int CompareTo(
    ParameterValue other
)
Visual Basic
Public Overridable Function CompareTo ( _
    other As ParameterValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterValue
An object to compare with this object.

Return Value

A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ParameterValue..::..Equals Method
ParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ParameterValue..::..Equals Method (Object)
ParameterValue Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean

Parameters

other
Type: System..::..Object

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (ParameterValue)

[image]

IceLib Technical Reference
ParameterValue..::..Equals Method (ParameterValue)
ParameterValue Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual bool Equals(
    ParameterValue other
)
Visual Basic
Public Overridable Function Equals ( _
    other As ParameterValue _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterValue
An object to compare with this object.

Return Value

trueTruetruetrue (True in Visual Basic) if the current object is equal to the other parameter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ParameterValue..::..GetHashCode Method
ParameterValue Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
ParameterValue..::..ToString Method
ParameterValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


ParameterValue Operators

[image] [image]

IceLib Technical Reference
ParameterValue Operators
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of ParameterValue are equal.
GreaterThan | Determines whether one instance of ParameterValue is greater than another.
GreaterThanOrEqual | Determines whether one instance of ParameterValue is greater than or equal to another.
Inequality | Determines whether two instances of ParameterValue are not equal.
LessThan | Determines whether one instance of ParameterValue is less than another.
LessThanOrEqual | Determines whether one instance of ParameterValue is less than or equal to another.

See Also

ParameterValue Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
ParameterValue..::..Equality Operator
ParameterValue Class See Also Send Feedback
Determines whether two instances of ParameterValue are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ParameterValue a,
    ParameterValue b
)
Visual Basic
Public Shared Operator = ( _
    a As ParameterValue, _
    b As ParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValue
The first ParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValue
The second ParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


GreaterThan Operator

[image]

IceLib Technical Reference
ParameterValue..::..GreaterThan Operator
ParameterValue Class See Also Send Feedback
Determines whether one instance of ParameterValue is greater than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >(
    ParameterValue a,
    ParameterValue b
)
Visual Basic
Public Shared Operator > ( _
    a As ParameterValue, _
    b As ParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValue
The first ParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValue
The second ParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


GreaterThanOrEqual Operator

[image]

IceLib Technical Reference
ParameterValue..::..GreaterThanOrEqual Operator
ParameterValue Class See Also Send Feedback
Determines whether one instance of ParameterValue is greater than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator >=(
    ParameterValue a,
    ParameterValue b
)
Visual Basic
Public Shared Operator >= ( _
    a As ParameterValue, _
    b As ParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValue
The first ParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValue
The second ParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is greater than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
ParameterValue..::..Inequality Operator
ParameterValue Class See Also Send Feedback
Determines whether two instances of ParameterValue are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ParameterValue a,
    ParameterValue b
)
Visual Basic
Public Shared Operator <> ( _
    a As ParameterValue, _
    b As ParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValue
The first ParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValue
The second ParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


LessThan Operator

[image]

IceLib Technical Reference
ParameterValue..::..LessThan Operator
ParameterValue Class See Also Send Feedback
Determines whether one instance of ParameterValue is less than another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <(
    ParameterValue a,
    ParameterValue b
)
Visual Basic
Public Shared Operator < ( _
    a As ParameterValue, _
    b As ParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValue
The first ParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValue
The second ParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


LessThanOrEqual Operator

[image]

IceLib Technical Reference
ParameterValue..::..LessThanOrEqual Operator
ParameterValue Class See Also Send Feedback
Determines whether one instance of ParameterValue is less than or equal to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator <=(
    ParameterValue a,
    ParameterValue b
)
Visual Basic
Public Shared Operator <= ( _
    a As ParameterValue, _
    b As ParameterValue _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValue
The first ParameterValue to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValue
The second ParameterValue to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the first instance is less than or equal to the second, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


ParameterValue Properties

[image] [image]

IceLib Technical Reference
ParameterValue Properties
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Properties

 | Name | Description
 | All | Value to use when indicating that all valid parameter values are to be used in calculating the statistic.
Public property | Type | Gets parameter type.
Public property | Value | Gets the parameter value ID.

See Also

ParameterValue Class
ININ.IceLib.Statistics Namespace


All Property

[image]

IceLib Technical Reference
ParameterValue..::..All Property
ParameterValue Class See Also Send Feedback
Value to use when indicating that all valid parameter values are to be used in calculating the statistic.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string All { get; }
Visual Basic
Public Shared ReadOnly Property All As String
    Get

Remarks

In some cases a statistic value may be rolled-up into a summary statistic value, such as interaction time across all interaction types. Do not use this All value for that case. In the case where a roll-up parameter value is available, the server will need to supply that value. Use this all value when performing an ExecuteQuery(ParameterQuery).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace
FilteredParameterQuery..::..NoFilter


Type Property

[image]

IceLib Technical Reference
ParameterValue..::..Type Property
ParameterValue Class See Also Send Feedback
Gets parameter type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterTypeId Type { get; private set; }
Visual Basic
Public Property Type As ParameterTypeId
    Get
    Private Set

Field Value

The parameter type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
ParameterValue..::..Value Property
ParameterValue Class See Also Send Feedback
Gets the parameter value ID.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; private set; }
Visual Basic
Public Property Value As String
    Get
    Private Set

Field Value

The parameter value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValue Class
ParameterValue Members
ININ.IceLib.Statistics Namespace


ParameterValueEventArgs Class

[image]

IceLib Technical Reference
ParameterValueEventArgs Class
Members See Also Send Feedback
Provides data for the ParameterValuesDepot changed, added and removed events.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterValueEventArgs : EventArgs
Visual Basic
Public Class ParameterValueEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics..::..ParameterValueEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueEventArgs Members
ININ.IceLib.Statistics Namespace


ParameterValueEventArgs Members

[image] [image]

IceLib Technical Reference
ParameterValueEventArgs Members
ParameterValueEventArgs Class Methods Properties See Also Send Feedback

The ParameterValueEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets the parameter value.

See Also

ParameterValueEventArgs Class
ININ.IceLib.Statistics Namespace


ParameterValueEventArgs Methods

[image] [image]

IceLib Technical Reference
ParameterValueEventArgs Methods
ParameterValueEventArgs Class See Also Send Feedback

The ParameterValueEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterValueEventArgs Class
ININ.IceLib.Statistics Namespace


ParameterValueEventArgs Properties

[image] [image]

IceLib Technical Reference
ParameterValueEventArgs Properties
ParameterValueEventArgs Class See Also Send Feedback

The ParameterValueEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets the parameter value.

See Also

ParameterValueEventArgs Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
ParameterValueEventArgs..::..Value Property
ParameterValueEventArgs Class See Also Send Feedback
Gets the parameter value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValue Value { get; private set; }
Visual Basic
Public Property Value As ParameterValue
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueEventArgs Class
ParameterValueEventArgs Members
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Class

[image]

IceLib Technical Reference
ParameterValueKeyedCollection Class
Members See Also Send Feedback
Represents an ordered keyed collection of parameter types and their values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterValueKeyedCollection : KeyedCollection<ParameterTypeId, ParameterValue>,
    IEquatable<ParameterValueKeyedCollection>
Visual Basic
Public Class ParameterValueKeyedCollection _
    Inherits KeyedCollection(Of ParameterTypeId, ParameterValue) _
    Implements IEquatable(Of ParameterValueKeyedCollection)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection<(Of <(<' ParameterValue >)>)>
System.Collections.ObjectModel..::..KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>
ININ.IceLib.Statistics..::..ParameterValueKeyedCollection

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Members

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection Members
ParameterValueKeyedCollection Class Constructors Methods Operators Properties See Also Send Feedback

The ParameterValueKeyedCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterValueKeyedCollection()()()() | Initializes a new instance of the ParameterValueKeyedCollection class.
Public method | ParameterValueKeyedCollection(ParameterValueKeyedCollection) | Initializes a new instance of the ParameterValueKeyedCollection class.

Methods

 | Name | Description
Public method | Add | Adds a unique ParameterValue instance to the end of the this collection.
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterValueKeyedCollection) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Protected method | GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected method | InsertItem | Inserts an element into the KeyedCollection<(Of <(<'TKey, TItem>)>)> at the specified index. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | ReplaceValue | Replaces a ParameterValue with a different one.
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.

Operators

Name | Description
Equality | Determines whether two instances of ParameterValueKeyedCollection are equal.
Inequality | Determines whether two instances of ParameterValueKeyedCollection are not equal.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public property | Item[([( Int32])]) | Gets the ParameterValue at the specified index.
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)

See Also

ParameterValueKeyedCollection Class
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Constructor

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection Constructor
ParameterValueKeyedCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParameterValueKeyedCollection()()()() | Initializes a new instance of the ParameterValueKeyedCollection class.
Public method | ParameterValueKeyedCollection(ParameterValueKeyedCollection) | Initializes a new instance of the ParameterValueKeyedCollection class.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Constructor

[image]

IceLib Technical Reference
ParameterValueKeyedCollection Constructor
ParameterValueKeyedCollection Class See Also Send Feedback
Initializes a new instance of the ParameterValueKeyedCollection class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValueKeyedCollection()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ParameterValueKeyedCollection Overload
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Constructor (ParameterValueKeyedCollection)

[image]

IceLib Technical Reference
ParameterValueKeyedCollection Constructor (ParameterValueKeyedCollection)
ParameterValueKeyedCollection Class See Also Send Feedback
Initializes a new instance of the ParameterValueKeyedCollection class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValueKeyedCollection(
    ParameterValueKeyedCollection parameterValues
)
Visual Basic
Public Sub New ( _
    parameterValues As ParameterValueKeyedCollection _
)

Parameters

parameterValues
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
The parameter values to copy from.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ParameterValueKeyedCollection Overload
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Methods

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection Methods
ParameterValueKeyedCollection Class See Also Send Feedback

The ParameterValueKeyedCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a unique ParameterValue instance to the end of the this collection.
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterValueKeyedCollection) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Protected method | GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected method | InsertItem | Inserts an element into the KeyedCollection<(Of <(<'TKey, TItem>)>)> at the specified index. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | ReplaceValue | Replaces a ParameterValue with a different one.
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.

See Also

ParameterValueKeyedCollection Class
ININ.IceLib.Statistics Namespace


Add Method

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Add Method
ParameterValueKeyedCollection Class See Also Send Feedback
Adds a unique ParameterValue instance to the end of the this collection.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Add(
    ParameterValue item
)
Visual Basic
Public Sub Add ( _
    item As ParameterValue _
)

Parameters

item
Type: ININ.IceLib.Statistics..::..ParameterValue
The parameter value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | An item with the same key has already been added.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Equals Method
ParameterValueKeyedCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ParameterValueKeyedCollection) | Indicates whether the current object is equal to another object of the same type.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Equals Method (Object)
ParameterValueKeyedCollection Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean

Parameters

other
Type: System..::..Object

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (ParameterValueKeyedCollection)

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Equals Method (ParameterValueKeyedCollection)
ParameterValueKeyedCollection Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    ParameterValueKeyedCollection other
)
Visual Basic
Public Function Equals ( _
    other As ParameterValueKeyedCollection _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..GetHashCode Method
ParameterValueKeyedCollection Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


GetKeyForItem Method

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..GetKeyForItem Method
ParameterValueKeyedCollection Class See Also Send Feedback
When implemented in a derived class, extracts the key from the specified element.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected override ParameterTypeId GetKeyForItem(
    ParameterValue item
)
Visual Basic
Protected Overrides Function GetKeyForItem ( _
    item As ParameterValue _
) As ParameterTypeId

Parameters

item
Type: ININ.IceLib.Statistics..::..ParameterValue
The element from which to extract the key.

Return Value

The key for the specified element.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


ReplaceValue Method

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..ReplaceValue Method
ParameterValueKeyedCollection Class See Also Send Feedback
Replaces a ParameterValue with a different one.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ReplaceValue(
    ParameterValue value
)
Visual Basic
Public Function ReplaceValue ( _
    value As ParameterValue _
) As Boolean

Parameters

value
Type: ININ.IceLib.Statistics..::..ParameterValue
The new ParameterValue.

Return Value

trueTruetruetrue (True in Visual Basic) if the value was found and replaced, falseFalsefalsefalse (False in Visual Basic) otherwise.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


TryGetValue Method

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..TryGetValue Method
ParameterValueKeyedCollection Class See Also Send Feedback
Gets the value associated with the specified key.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetValue(
    ParameterTypeId key,
    out ParameterValue item
)
Visual Basic
Public Function TryGetValue ( _
    key As ParameterTypeId, _
    <OutAttribute> ByRef item As ParameterValue _
) As Boolean

Parameters

key
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The key.
item
Type: ININ.IceLib.Statistics..::..ParameterValue %
The item. When this method returns, the item associated with the specified key, if the key is found; otherwise, nullNothingnullptra null reference (Nothing in Visual Basic). parameter. This parameter is passed uninitialized.

Return Value

trueTruetruetrue (True in Visual Basic) if this instance contains an element with the specified key; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Operators

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection Operators
ParameterValueKeyedCollection Class See Also Send Feedback

The ParameterValueKeyedCollection type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of ParameterValueKeyedCollection are equal.
Inequality | Determines whether two instances of ParameterValueKeyedCollection are not equal.

See Also

ParameterValueKeyedCollection Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Equality Operator
ParameterValueKeyedCollection Class See Also Send Feedback
Determines whether two instances of ParameterValueKeyedCollection are equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    ParameterValueKeyedCollection a,
    ParameterValueKeyedCollection b
)
Visual Basic
Public Shared Operator = ( _
    a As ParameterValueKeyedCollection, _
    b As ParameterValueKeyedCollection _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
The first ParameterValueKeyedCollection to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
The second ParameterValueKeyedCollection to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Inequality Operator
ParameterValueKeyedCollection Class See Also Send Feedback
Determines whether two instances of ParameterValueKeyedCollection are not equal.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    ParameterValueKeyedCollection a,
    ParameterValueKeyedCollection b
)
Visual Basic
Public Shared Operator <> ( _
    a As ParameterValueKeyedCollection, _
    b As ParameterValueKeyedCollection _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
The first ParameterValueKeyedCollection to compare.
b
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
The second ParameterValueKeyedCollection to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


ParameterValueKeyedCollection Properties

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection Properties
ParameterValueKeyedCollection Class See Also Send Feedback

The ParameterValueKeyedCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Public property | Item[([( Int32])]) | Gets the ParameterValue at the specified index.
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' ParameterValue >)>)>.)

See Also

ParameterValueKeyedCollection Class
ININ.IceLib.Statistics Namespace


Item Property

[image] [image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Item Property
ParameterValueKeyedCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets the ParameterValue at the specified index.
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection<(Of <(<' ParameterTypeId, ParameterValue >)>)>.)

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
ININ.IceLib.Statistics Namespace


Item Property (Int32)

[image]

IceLib Technical Reference
ParameterValueKeyedCollection..::..Item Property (Int32)
ParameterValueKeyedCollection Class See Also Send Feedback
Gets the ParameterValue at the specified index.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValue this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ParameterValue
    Get

Parameters

index
Type: System..::..Int32

Field Value

The parameter value at the requested index.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | No index was out of the range for the collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValueKeyedCollection Class
ParameterValueKeyedCollection Members
Item Overload
ININ.IceLib.Statistics Namespace


ParameterValuesDepot Class

[image]

IceLib Technical Reference
ParameterValuesDepot Class
Members See Also Send Feedback
Represents a watched object used to query the valid parameters when making statistic values requests.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ParameterValuesDepot
Visual Basic
Public Class ParameterValuesDepot

Remarks

The ParameterValuesDepot provides access to parameter values. StartWatchingQuery(AssociatedParameterSetQuery) creates a parameter watch for the given query, triggering QueryResultsChanged whenever the parameters have changed. ExecuteQuery(ParameterQuery) will immediately retrieve parameters for the given query. ValidateAssociatedParameterSet(AssociatedParameterSetQuery) will check with the server to determine if the given query is still valid.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterValuesDepot

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ParameterValuesDepot Members

[image] [image]

IceLib Technical Reference
ParameterValuesDepot Members
ParameterValuesDepot Class Constructors Methods Events See Also Send Feedback

The ParameterValuesDepot type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterValuesDepot | Initializes a new instance of the ParameterValuesDepot class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteQuery | Executes a query for parameter values and returns the results.
Public method | ExecuteQueryAsync | Executes a query for parameter values and returns the results asynchronously.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetailedParameterValues | Gets the details for a collection of ParameterValue instances. The input parameter values are not treated as chained. If you need the values to be treated as chained, use ValidateAssociatedParameterSet(AssociatedParameterSetQuery) instead.
Public method | GetDetailedParameterValuesAsync | Asynchronously gets the details for a collection of ParameterValue instances. The input parameter values are not treated as chained. If you need the values to be treated as chained, use ValidateAssociatedParameterSet(AssociatedParameterSetQuery) instead.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedResults | Gets the collection of AssociatedParameterSetValue that match the watched AssociatedParameterSetQuery.
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatchingQuery | A synchronous request to query and watch parameter values.
Public method | StartWatchingQueryAsync | Starts an asynchronous request to query and watch parameter values.
Public method | StopWatchingQuery | A synchronous request to stop watching queried parameter values.
Public method | StopWatchingQueryAsync | Start an asynchronous request to stop watching queried parameter values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateAssociatedParameterSet | Validates a set of associated parameter values.
Public method | ValidateAssociatedParameterSetAsync | Executes a query for parameter values and returns the results asynchronously.

Events

 | Name | Description
Public event | QueryResultsChanged | Occurs when a result to a watched query changes.

See Also

ParameterValuesDepot Class
ININ.IceLib.Statistics Namespace


ParameterValuesDepot Constructor

[image]

IceLib Technical Reference
ParameterValuesDepot Constructor
ParameterValuesDepot Class See Also Send Feedback
Initializes a new instance of the ParameterValuesDepot class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValuesDepot(
    StatisticsManager statisticsManager
)
Visual Basic
Public Sub New ( _
    statisticsManager As StatisticsManager _
)

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | statisticsManager is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ParameterValuesDepot Methods

[image] [image]

IceLib Technical Reference
ParameterValuesDepot Methods
ParameterValuesDepot Class See Also Send Feedback

The ParameterValuesDepot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteQuery | Executes a query for parameter values and returns the results.
Public method | ExecuteQueryAsync | Executes a query for parameter values and returns the results asynchronously.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetailedParameterValues | Gets the details for a collection of ParameterValue instances. The input parameter values are not treated as chained. If you need the values to be treated as chained, use ValidateAssociatedParameterSet(AssociatedParameterSetQuery) instead.
Public method | GetDetailedParameterValuesAsync | Asynchronously gets the details for a collection of ParameterValue instances. The input parameter values are not treated as chained. If you need the values to be treated as chained, use ValidateAssociatedParameterSet(AssociatedParameterSetQuery) instead.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedResults | Gets the collection of AssociatedParameterSetValue that match the watched AssociatedParameterSetQuery.
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatchingQuery | A synchronous request to query and watch parameter values.
Public method | StartWatchingQueryAsync | Starts an asynchronous request to query and watch parameter values.
Public method | StopWatchingQuery | A synchronous request to stop watching queried parameter values.
Public method | StopWatchingQueryAsync | Start an asynchronous request to stop watching queried parameter values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateAssociatedParameterSet | Validates a set of associated parameter values.
Public method | ValidateAssociatedParameterSetAsync | Executes a query for parameter values and returns the results asynchronously.

See Also

ParameterValuesDepot Class
ININ.IceLib.Statistics Namespace


ExecuteQuery Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..ExecuteQuery Method
ParameterValuesDepot Class See Also Send Feedback
Executes a query for parameter values and returns the results.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterQueryResult ExecuteQuery(
    ParameterQuery query
)
Visual Basic
Public Function ExecuteQuery ( _
    query As ParameterQuery _
) As ParameterQueryResult

Parameters

query
Type: ININ.IceLib.Statistics..::..ParameterQuery
The ParameterQuery to execute.

Return Value

The result of the query.

Remarks

Parameter value queries can be qualified or filtered. Qualifying a parameter query consists of using a chain of associated parameter values to specify how to interpret the requested parameter ID. For example, requesting parameter values for users and qualifying it by specifying a workgroup parameter with the value of 'Operator' will result in a list of users who are in the 'Operator' workgroup. When qualifying parameters, order is important. Filtering a parameter query consists of specifying a string and limiting the result set to those values that match the provided string. A query that is completely unfiltered and unqualified can use ParameterQuery, however if a qualification or filter is needed FilteredParameterQuery must be used. Note that not all parameters allow for searching with no qualifications, in these cases FilteredParameterQuery must be used for results to be returned. Details on what associated parameters must be used can be found by examining the contents of the StatisticCatalog. The RequiredParametersDefinition in StatisticDefinition provides the list of required associated parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The query parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ExecuteQueryAsync Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..ExecuteQueryAsync Method
ParameterValuesDepot Class See Also Send Feedback
Executes a query for parameter values and returns the results asynchronously.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ExecuteQueryAsync(
    ParameterQuery query,
    EventHandler<ParameterQueryCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ExecuteQueryAsync ( _
    query As ParameterQuery, _
    completedCallback As EventHandler(Of ParameterQueryCompletedEventArgs), _
    userState As Object _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..ParameterQuery
The ParameterQuery to execute.
completedCallback
Type: System..::..EventHandler<(Of <(<' ParameterQueryCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Parameter value queries can be qualified or filtered. Qualifying a parameter query consists of using a chain of associated parameter values to specify how to interpret the requested parameter ID. For example, requesting parameter values for users and qualifying it by specifying a workgroup parameter with the value of 'Operator' will result in a list of users who are in the 'Operator' workgroup. When qualifying parameters, order is important. Filtering a parameter query consists of specifying a string and limiting the result set to those values that match the provided string. A query that is completely unfiltered and unqualified can use ParameterQuery, however if a qualification or filter is needed FilteredParameterQuery must be used. Note that not all parameters allow for searching with no qualifications, in these cases FilteredParameterQuery must be used for results to be returned. Details on what associated parameters must be used can be found by examining the contents of the StatisticCatalog. The RequiredParametersDefinition in StatisticDefinition provides the list of required associated parameters.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The query parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


GetDetailedParameterValues Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..GetDetailedParameterValues Method
ParameterValuesDepot Class See Also Send Feedback
Gets the details for a collection of ParameterValue instances. The input parameter values are not treated as chained. If you need the values to be treated as chained, use ValidateAssociatedParameterSet(AssociatedParameterSetQuery) instead.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<DetailedParameterValue> GetDetailedParameterValues(
    IEnumerable<ParameterValue> parameterValues
)
Visual Basic
Public Function GetDetailedParameterValues ( _
    parameterValues As IEnumerable(Of ParameterValue) _
) As IEnumerable(Of DetailedParameterValue)

Parameters

parameterValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterValue >)>)>
The parameter values to retrieve details for.

Return Value

The result of the query.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The parameterValues parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameterValues parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


GetDetailedParameterValuesAsync Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..GetDetailedParameterValuesAsync Method
ParameterValuesDepot Class See Also Send Feedback
Asynchronously gets the details for a collection of ParameterValue instances. The input parameter values are not treated as chained. If you need the values to be treated as chained, use ValidateAssociatedParameterSet(AssociatedParameterSetQuery) instead.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetDetailedParameterValuesAsync(
    IEnumerable<ParameterValue> parameterValues,
    EventHandler<AsyncCompletedEventArgs<IEnumerable<DetailedParameterValue>>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetDetailedParameterValuesAsync ( _
    parameterValues As IEnumerable(Of ParameterValue), _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of IEnumerable(Of DetailedParameterValue))), _
    userState As Object _
)

Parameters

parameterValues
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterValue >)>)>
The parameter values to retrieve details for.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncCompletedEventArgs <(Of <(<'IEnumerable<(Of <(<' DetailedParameterValue >)>)>>)>)>>)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The parameterValues parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameterValues parameter is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


GetWatchedResults Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..GetWatchedResults Method
ParameterValuesDepot Class See Also Send Feedback
Gets the collection of AssociatedParameterSetValue that match the watched AssociatedParameterSetQuery.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AssociatedParameterSetValue> GetWatchedResults()
Visual Basic
Public Function GetWatchedResults As ReadOnlyCollection(Of AssociatedParameterSetValue)

Return Value

The collection of AssociatedParameterSetValue that match the watched query.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This ParameterValuesDepot is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


IsWatching Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..IsWatching Method
ParameterValuesDepot Class See Also Send Feedback
Determines whether this instance is watching.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is watching; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


StartWatchingQuery Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..StartWatchingQuery Method
ParameterValuesDepot Class See Also Send Feedback
A synchronous request to query and watch parameter values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingQuery(
    AssociatedParameterSetQuery query
)
Visual Basic
Public Sub StartWatchingQuery ( _
    query As AssociatedParameterSetQuery _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
Definition of the query.

Remarks

Parameter value watches can be qualified. Qualifying a parameter query consists of using a chain of associated parameter values to specify how to interpret the requested parameter ID. For example, requesting parameter values for users and qualifying it by specifying a workgroup parameter with the value of 'Operator' will result in a list of users who are in the 'Operator' workgroup. When qualifying parameters, order is important. Not all parameters allow for searching with no qualifications. Details on what associated parameters must be used can be found by examining the contents of the StatisticCatalog. The RequiredParametersDefinition in StatisticDefinition provides the list of required associated parameters. Parameter value watches do not support filtered watches, if filtered values are needed use ExecuteQuery(ParameterQuery) instead.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | query is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | This ParameterValuesDepot is already watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


StartWatchingQueryAsync Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..StartWatchingQueryAsync Method
ParameterValuesDepot Class See Also Send Feedback
Starts an asynchronous request to query and watch parameter values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingQueryAsync(
    AssociatedParameterSetQuery query,
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingQueryAsync ( _
    query As AssociatedParameterSetQuery, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
Definition of the query.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Parameter value watches can be qualified. Qualifying a parameter query consists of using a chain of associated parameter values to specify how to interpret the requested parameter ID. For example, requesting parameter values for users and qualifying it by specifying a workgroup parameter with the value of 'Operator' will result in a list of users who are in the 'Operator' workgroup. When qualifying parameters, order is important. Not all parameters allow for searching with no qualifications. Details on what associated parameters must be used can be found by examining the contents of the StatisticCatalog. The RequiredParametersDefinition in StatisticDefinition provides the list of required associated parameters. Parameter value watches do not support filtered watches, if filtered values are needed use ExecuteQuery(ParameterQuery) instead.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch has already been started for this instance of ParameterValuesDepot.
System..::..ArgumentNullException | query is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | query is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


StopWatchingQuery Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..StopWatchingQuery Method
ParameterValuesDepot Class See Also Send Feedback
A synchronous request to stop watching queried parameter values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingQuery()
Visual Basic
Public Sub StopWatchingQuery

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This ParameterValuesDepot is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


StopWatchingQueryAsync Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..StopWatchingQueryAsync Method
ParameterValuesDepot Class See Also Send Feedback
Start an asynchronous request to stop watching queried parameter values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingQueryAsync(
    EventHandler<AsyncCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingQueryAsync ( _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started. See StartWatchingQuery(AssociatedParameterSetQuery).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ValidateAssociatedParameterSet Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..ValidateAssociatedParameterSet Method
ParameterValuesDepot Class See Also Send Feedback
Validates a set of associated parameter values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ValidatedAssociatedParameterSetValue ValidateAssociatedParameterSet(
    AssociatedParameterSetQuery query
)
Visual Basic
Public Function ValidateAssociatedParameterSet ( _
    query As AssociatedParameterSetQuery _
) As ValidatedAssociatedParameterSetValue

Parameters

query
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
The ParameterQuery to execute.

Return Value

The result of the query.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The query parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ValidateAssociatedParameterSetAsync Method

[image]

IceLib Technical Reference
ParameterValuesDepot..::..ValidateAssociatedParameterSetAsync Method
ParameterValuesDepot Class See Also Send Feedback
Executes a query for parameter values and returns the results asynchronously.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ValidateAssociatedParameterSetAsync(
    AssociatedParameterSetQuery query,
    EventHandler<ValidateAssociatedParameterSetCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub ValidateAssociatedParameterSetAsync ( _
    query As AssociatedParameterSetQuery, _
    completedCallback As EventHandler(Of ValidateAssociatedParameterSetCompletedEventArgs), _
    userState As Object _
)

Parameters

query
Type: ININ.IceLib.Statistics..::..AssociatedParameterSetQuery
The ParameterQuery to execute.
completedCallback
Type: System..::..EventHandler<(Of <(<' ValidateAssociatedParameterSetCompletedEventArgs >)>)>
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The query parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ParameterValuesDepot Events

[image] [image]

IceLib Technical Reference
ParameterValuesDepot Events
ParameterValuesDepot Class See Also Send Feedback

The ParameterValuesDepot type exposes the following members.

Events

 | Name | Description
Public event | QueryResultsChanged | Occurs when a result to a watched query changes.

See Also

ParameterValuesDepot Class
ININ.IceLib.Statistics Namespace


QueryResultsChanged Event

[image]

IceLib Technical Reference
ParameterValuesDepot..::..QueryResultsChanged Event
ParameterValuesDepot Class See Also Send Feedback
Occurs when a result to a watched query changes.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AssociatedParameterSetQueryEventArgs> QueryResultsChanged
Visual Basic
Public Event QueryResultsChanged As EventHandler(Of AssociatedParameterSetQueryEventArgs)

Remarks

This event will only occur when query results have changed. To start watching for query result changes call either the StartWatchingQuery(AssociatedParameterSetQuery) method or the StartWatchingQueryAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object) method.
Note
All event handlers should be added before calling StartWatchingQuery(AssociatedParameterSetQuery) or StartWatchingQueryAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(AsyncCompletedEventArgs>)>>), Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ParameterValuesDepot Class
ParameterValuesDepot Members
ININ.IceLib.Statistics Namespace


ParameterValuesDepot.ParameterQueryCompletedEventHandler Delegate

[image]

IceLib Technical Reference
ParameterValuesDepot..::..ParameterQueryCompletedEventHandler Delegate
ParameterValuesDepot Class See Also Send Feedback
Represents the method that will handle the completed callback for an ExecuteQueryAsync(ParameterQuery, EventHandler<(Of <<'(ParameterQueryCompletedEventArgs>)>>), Object) operation.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public delegate void ParameterQueryCompletedEventHandler(
    Object sender,
    ParameterQueryCompletedEventArgs e
)
Visual Basic
Public Delegate Sub ParameterQueryCompletedEventHandler ( _
    sender As Object, _
    e As ParameterQueryCompletedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: ININ.IceLib.Statistics..::..ParameterQueryCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics Namespace


RequiredParametersDefinition Class

[image]

IceLib Technical Reference
RequiredParametersDefinition Class
Members See Also Send Feedback
Details information about the required parameter types that define a valid parameter set for a statistic value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class RequiredParametersDefinition : AssociatedParameterSetDefinition
Visual Basic
Public Class RequiredParametersDefinition _
    Inherits AssociatedParameterSetDefinition

Remarks

The order of the parameter types that compose the definition is important.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
ININ.IceLib.Statistics..::..RequiredParametersDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RequiredParametersDefinition Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..AssociatedParameterSetDefinition
ININ.IceLib.Statistics..::..AssociatedParameterSetQuery


RequiredParametersDefinition Members

[image] [image]

IceLib Technical Reference
RequiredParametersDefinition Members
RequiredParametersDefinition Class Methods Properties See Also Send Feedback

The RequiredParametersDefinition type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares one AssociatedParameterSetDefinition value to another. (Inherited from AssociatedParameterSetDefinition.)
Public method | Contains | Determines whether the AssociatedParameterSetDefinition contains the specified ParameterTypeId. (Inherited from AssociatedParameterSetDefinition.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AssociatedParameterSetDefinition..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetDefinition) | Indicates whether the current object is equal to another object of the same type. (Inherited from AssociatedParameterSetDefinition.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from AssociatedParameterSetDefinition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AssociatedParameterSetDefinition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ShouldBeSuppressed | Gets a value indicating whether this AssociatedParameterSetDefinition should be suppressed from direct presentation to the user.

See Also

RequiredParametersDefinition Class
ININ.IceLib.Statistics Namespace


RequiredParametersDefinition Methods

[image] [image]

IceLib Technical Reference
RequiredParametersDefinition Methods
RequiredParametersDefinition Class See Also Send Feedback

The RequiredParametersDefinition type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares one AssociatedParameterSetDefinition value to another. (Inherited from AssociatedParameterSetDefinition.)
Public method | Contains | Determines whether the AssociatedParameterSetDefinition contains the specified ParameterTypeId. (Inherited from AssociatedParameterSetDefinition.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AssociatedParameterSetDefinition..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetDefinition) | Indicates whether the current object is equal to another object of the same type. (Inherited from AssociatedParameterSetDefinition.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from AssociatedParameterSetDefinition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AssociatedParameterSetDefinition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequiredParametersDefinition Class
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
RequiredParametersDefinition..::..Equals Method
RequiredParametersDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AssociatedParameterSetDefinition..::..Equals(Object).)
Public method | Equals(AssociatedParameterSetDefinition) | Indicates whether the current object is equal to another object of the same type. (Inherited from AssociatedParameterSetDefinition.)

See Also

RequiredParametersDefinition Class
RequiredParametersDefinition Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
RequiredParametersDefinition..::..Equals Method (Object)
RequiredParametersDefinition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RequiredParametersDefinition Class
RequiredParametersDefinition Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
RequiredParametersDefinition..::..GetHashCode Method
RequiredParametersDefinition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

RequiredParametersDefinition Class
RequiredParametersDefinition Members
ININ.IceLib.Statistics Namespace


RequiredParametersDefinition Properties

[image] [image]

IceLib Technical Reference
RequiredParametersDefinition Properties
RequiredParametersDefinition Class See Also Send Feedback

The RequiredParametersDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ShouldBeSuppressed | Gets a value indicating whether this AssociatedParameterSetDefinition should be suppressed from direct presentation to the user.

See Also

RequiredParametersDefinition Class
ININ.IceLib.Statistics Namespace


ShouldBeSuppressed Property

[image]

IceLib Technical Reference
RequiredParametersDefinition..::..ShouldBeSuppressed Property
RequiredParametersDefinition Class See Also Send Feedback
Gets a value indicating whether this AssociatedParameterSetDefinition should be suppressed from direct presentation to the user.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShouldBeSuppressed { get; }
Visual Basic
Public ReadOnly Property ShouldBeSuppressed As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if should be suppressed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

RequiredParametersDefinition Class
RequiredParametersDefinition Members
ININ.IceLib.Statistics Namespace


StatisticBoolValue Class

[image]

IceLib Technical Reference
StatisticBoolValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticBoolValue : StatisticValue,
    IComparable<StatisticBoolValue>
Visual Basic
Public Class StatisticBoolValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticBoolValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticBoolValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


StatisticBoolValue Members

[image] [image]

IceLib Technical Reference
StatisticBoolValue Members
StatisticBoolValue Class Methods Properties See Also Send Feedback

The StatisticBoolValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticBoolValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the boolean value as a normalized value by returning 0.0 for falseFalsefalsefalse (False in Visual Basic) and 1.0 for trueTruetruetrue (True in Visual Basic). (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticBoolValue Class
ININ.IceLib.Statistics Namespace


StatisticBoolValue Methods

[image] [image]

IceLib Technical Reference
StatisticBoolValue Methods
StatisticBoolValue Class See Also Send Feedback

The StatisticBoolValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticBoolValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the boolean value as a normalized value by returning 0.0 for falseFalsefalsefalse (False in Visual Basic) and 1.0 for trueTruetruetrue (True in Visual Basic). (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticBoolValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticBoolValue..::..Clone Method
StatisticBoolValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticBoolValue Class
StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticBoolValue..::..CompareTo Method
StatisticBoolValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticBoolValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticBoolValue Class
StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticBoolValue)

[image]

IceLib Technical Reference
StatisticBoolValue..::..CompareTo Method (StatisticBoolValue)
StatisticBoolValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticBoolValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticBoolValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticBoolValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticBoolValue Class
StatisticBoolValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticBoolValue..::..GetDisplayString Method
StatisticBoolValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticBoolValue Class
StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticBoolValue..::..GetNormalizedValue Method
StatisticBoolValue Class See Also Send Feedback
Gets the boolean value as a normalized value by returning 0.0 for falseFalsefalsefalse (False in Visual Basic) and 1.0 for trueTruetruetrue (True in Visual Basic).

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticBoolValue Class
StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticBoolValue..::..ToString Method
StatisticBoolValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticBoolValue Class
StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


StatisticBoolValue Properties

[image] [image]

IceLib Technical Reference
StatisticBoolValue Properties
StatisticBoolValue Class See Also Send Feedback

The StatisticBoolValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticBoolValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticBoolValue..::..Value Property
StatisticBoolValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Value { get; private set; }
Visual Basic
Public Property Value As Boolean
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticBoolValue Class
StatisticBoolValue Members
ININ.IceLib.Statistics Namespace


StatisticCatalog Class

[image]

IceLib Technical Reference
StatisticCatalog Class
Members Example See Also Send Feedback
Gateway to the definitions of available IC statistics.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticCatalog : IStatisticCatalogWatcher
Visual Basic
Public Class StatisticCatalog _
    Implements IStatisticCatalogWatcher

Remarks

Prior to doing any work with the StatisticCatalog, StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object) must be called.

Statistics can be retrieved by StatisticKey with GetStatisticDefinition(StatisticIdentifier), by StatisticCategory with GetStatisticDefinitions(String) or as a complete list with GetStatisticDefinitions()()()().

A StatisticCategory can be retrieved by ID with GetStatisticCategory(String) or the complete list of categories can be retrieved with GetStatisticCategories()()()().

A list of all ParameterType objects available can be retrieved with GetParameterTypes()()()() or an individual ParameterType can be retrieved by ID with GetParameterType(ParameterTypeId). GetParameterDisplayString(ParameterTypeId) will retrieve the human readable display string for a given ParameterType.

Note
For more information on getting started with statistics see Getting Started With Statistics.
Note
For for the list of available statistics see Statistics Catalog.

Examples

The IceLib SDK includes example application references to the StatisticCatalog class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 64, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | SystemStatisticsViewModel.cs, line 102, in SystemStatisticsViewModel.StartWatchingCatalogCompleted
 | SystemStatisticsViewModel.cs, line 32, in SystemStatisticsViewModel.#ctor
 | SystemStatisticsViewModel._StatisticCatalog
 | StatisticCatalogViewModel.cs, line 153, in StatisticCatalogViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 236, in StatisticCatalogViewModel.StartWatchingCompleted
 | StatisticCatalogViewModel.cs, line 32, in StatisticCatalogViewModel.#ctor
 | StatisticCatalogViewModel.cs, line 109, in StatisticCatalogViewModel.set_SelectedStatisticCategory
 | StatisticCatalogViewModel._StatisticCatalog

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticCatalog

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StatisticCatalog Members

[image] [image]

IceLib Technical Reference
StatisticCatalog Members
StatisticCatalog Class Constructors Methods Properties Events See Also Send Feedback

The StatisticCatalog type exposes the following members.

Constructors

 | Name | Description
Public method | StatisticCatalog | Initializes a new instance of the StatisticCatalog class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDisplayString | Gets the display string for a given ParameterType.
Public method | GetParameterType | Gets the ParameterType with the given ParameterTypeId.
Public method | GetParameterTypes | Gets the collection of ParameterTypes defined within the StatisticCatalog.
Public method | GetStatisticCategories | Gets the statistic categories.
Public method | GetStatisticCategory | Gets the statistic category.
Public method | GetStatisticDefinition | Gets the StatisticDefinition based on its ID.
Public method | GetStatisticDefinitions()()()() | Gets all the statistic definitions.
Public method | GetStatisticDefinitions(String) | Gets the statistic definitions for a specific category.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReady | Determines whether the catalog data is ready after a StartWatchingAsync(AsyncCompletedEventHandler, Object) request.
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the statistic catalog.
Public method | StartWatchingAsync | Asynchronously starts watching the statistic catalog.
Public method | StopWatching | Stops watching the statistic catalog.
Public method | StopWatchingAsync | Asynchronously stops watching the statistic catalog.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllCategories | Gets all categories statistic definition.

Events

 | Name | Description
Public event | StatisticCatalogChanged | Occurs when the statistics catalog has changed.

See Also

StatisticCatalog Class
ININ.IceLib.Statistics Namespace


StatisticCatalog Constructor

[image]

IceLib Technical Reference
StatisticCatalog Constructor
StatisticCatalog Class Example See Also Send Feedback
Initializes a new instance of the StatisticCatalog class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticCatalog(
    StatisticsManager statisticsManager
)
Visual Basic
Public Sub New ( _
    statisticsManager As StatisticsManager _
)

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Examples

The IceLib SDK includes example application references to the StatisticCatalog constructor. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 32, in SystemStatisticsViewModel.#ctor
 | StatisticCatalogViewModel.cs, line 32, in StatisticCatalogViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | statisticsManager is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StatisticCatalog Methods

[image] [image]

IceLib Technical Reference
StatisticCatalog Methods
StatisticCatalog Class See Also Send Feedback

The StatisticCatalog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDisplayString | Gets the display string for a given ParameterType.
Public method | GetParameterType | Gets the ParameterType with the given ParameterTypeId.
Public method | GetParameterTypes | Gets the collection of ParameterTypes defined within the StatisticCatalog.
Public method | GetStatisticCategories | Gets the statistic categories.
Public method | GetStatisticCategory | Gets the statistic category.
Public method | GetStatisticDefinition | Gets the StatisticDefinition based on its ID.
Public method | GetStatisticDefinitions()()()() | Gets all the statistic definitions.
Public method | GetStatisticDefinitions(String) | Gets the statistic definitions for a specific category.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReady | Determines whether the catalog data is ready after a StartWatchingAsync(AsyncCompletedEventHandler, Object) request.
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching the statistic catalog.
Public method | StartWatchingAsync | Asynchronously starts watching the statistic catalog.
Public method | StopWatching | Stops watching the statistic catalog.
Public method | StopWatchingAsync | Asynchronously stops watching the statistic catalog.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticCatalog Class
ININ.IceLib.Statistics Namespace


GetParameterDisplayString Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetParameterDisplayString Method
StatisticCatalog Class See Also Send Feedback
Gets the display string for a given ParameterType.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetParameterDisplayString(
    ParameterTypeId parameterType
)
Visual Basic
Public Function GetParameterDisplayString ( _
    parameterType As ParameterTypeId _
) As String

Parameters

parameterType
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The parameter type.

Return Value

The display string.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.
System..::..ArgumentNullException | The ParameterTypeId was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The catalog does not contain a ParameterType with the given ParameterTypeId.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetParameterType Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetParameterType Method
StatisticCatalog Class See Also Send Feedback
Gets the ParameterType with the given ParameterTypeId.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterType GetParameterType(
    ParameterTypeId parameterTypeId
)
Visual Basic
Public Function GetParameterType ( _
    parameterTypeId As ParameterTypeId _
) As ParameterType

Parameters

parameterTypeId
Type: ININ.IceLib.Statistics..::..ParameterTypeId
The ID.

Return Value

The ParameterType with matching ParameterTypeId, or nullNothingnullptra null reference (Nothing in Visual Basic) if the catalog does not contain a matching ParameterType.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetParameterTypes Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetParameterTypes Method
StatisticCatalog Class See Also Send Feedback
Gets the collection of ParameterTypes defined within the StatisticCatalog.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ParameterType> GetParameterTypes()
Visual Basic
Public Function GetParameterTypes As ReadOnlyCollection(Of ParameterType)

Return Value

The collection of parameter types.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetStatisticCategories Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetStatisticCategories Method
StatisticCatalog Class Example See Also Send Feedback
Gets the statistic categories.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticCategory> GetStatisticCategories()
Visual Basic
Public Function GetStatisticCategories As ReadOnlyCollection(Of StatisticCategory)

Return Value

The list of statistic categories.

Remarks

This method is only valid after a StartWatching has been invoked.

Examples

The IceLib SDK includes example application references to the GetStatisticCategories method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | StatisticCatalogViewModel.cs, line 236, in StatisticCatalogViewModel.StartWatchingCompleted

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetStatisticCategory Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetStatisticCategory Method
StatisticCatalog Class Example See Also Send Feedback
Gets the statistic category.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticCategory GetStatisticCategory(
    string categoryId
)
Visual Basic
Public Function GetStatisticCategory ( _
    categoryId As String _
) As StatisticCategory

Parameters

categoryId
Type: System..::..String
The category ID.

Return Value

A statistic category if found, or nullNothingnullptra null reference (Nothing in Visual Basic) if the statistic category does not exist.

Examples

The IceLib SDK includes example application references to the GetStatisticCategory method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 108, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.
System..::..ArgumentNullException | categoryId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetStatisticDefinition Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetStatisticDefinition Method
StatisticCatalog Class See Also Send Feedback
Gets the StatisticDefinition based on its ID.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticDefinition GetStatisticDefinition(
    StatisticIdentifier statisticId
)
Visual Basic
Public Function GetStatisticDefinition ( _
    statisticId As StatisticIdentifier _
) As StatisticDefinition

Parameters

statisticId
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
The ID of the StatisticDefinition.

Return Value

A statistic definition if found, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.
System..::..ArgumentNullException | statisticId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetStatisticDefinitions Method

[image] [image]

IceLib Technical Reference
StatisticCatalog..::..GetStatisticDefinitions Method
StatisticCatalog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStatisticDefinitions()()()() | Gets all the statistic definitions.
Public method | GetStatisticDefinitions(String) | Gets the statistic definitions for a specific category.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


GetStatisticDefinitions Method

[image]

IceLib Technical Reference
StatisticCatalog..::..GetStatisticDefinitions Method
StatisticCatalog Class See Also Send Feedback
Gets all the statistic definitions.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticDefinition> GetStatisticDefinitions()
Visual Basic
Public Function GetStatisticDefinitions As ReadOnlyCollection(Of StatisticDefinition)

Return Value

A list of statistic definitions.

Remarks

This method is only valid after a StartWatching has been invoked.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
GetStatisticDefinitions Overload
ININ.IceLib.Statistics Namespace


GetStatisticDefinitions Method (String)

[image]

IceLib Technical Reference
StatisticCatalog..::..GetStatisticDefinitions Method (String)
StatisticCatalog Class Example See Also Send Feedback
Gets the statistic definitions for a specific category.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticDefinition> GetStatisticDefinitions(
    string categoryId
)
Visual Basic
Public Function GetStatisticDefinitions ( _
    categoryId As String _
) As ReadOnlyCollection(Of StatisticDefinition)

Parameters

categoryId
Type: System..::..String
The category ID.

Return Value

A list of statistic definitions.

Remarks

This method is only valid after a StartWatching has been invoked.

Examples

The IceLib SDK includes example application references to the GetStatisticDefinitions method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 111, in SystemStatisticsViewModel.StartWatchingCatalogCompleted
 | StatisticCatalogViewModel.cs, line 109, in StatisticCatalogViewModel.set_SelectedStatisticCategory

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started.
System..::..ArgumentNullException | categoryId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
GetStatisticDefinitions Overload
ININ.IceLib.Statistics Namespace


IsReady Method

[image]

IceLib Technical Reference
StatisticCatalog..::..IsReady Method
StatisticCatalog Class Example See Also Send Feedback
Determines whether the catalog data is ready after a StartWatchingAsync(AsyncCompletedEventHandler, Object) request.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsReady()
Visual Basic
Public Function IsReady As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is ready; otherwise, falseFalsefalsefalse (False in Visual Basic).

Examples

The IceLib SDK includes example application references to the IsReady method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 102, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


IsWatching Method

[image]

IceLib Technical Reference
StatisticCatalog..::..IsWatching Method
StatisticCatalog Class Example See Also Send Feedback
Determines whether this instance is watching.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is watching; otherwise, falseFalsefalsefalse (False in Visual Basic).

Examples

The IceLib SDK includes example application references to the IsWatching method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 75, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 164, in StatisticCatalogViewModel.SessionConnectionStateChanged

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StartWatching Method

[image]

IceLib Technical Reference
StatisticCatalog..::..StartWatching Method
StatisticCatalog Class See Also Send Feedback
Starts watching the statistic catalog.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Object is already watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
StatisticCatalog..::..StartWatchingAsync Method
StatisticCatalog Class Example See Also Send Feedback
Asynchronously starts watching the statistic catalog.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Examples

The IceLib SDK includes example application references to the StartWatchingAsync method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 64, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 153, in StatisticCatalogViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..Exception | Exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StopWatching Method

[image]

IceLib Technical Reference
StatisticCatalog..::..StopWatching Method
StatisticCatalog Class Example See Also Send Feedback
Stops watching the statistic catalog.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Examples

The IceLib SDK includes example application references to the StopWatching method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 77, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | StatisticCatalogViewModel.cs, line 166, in StatisticCatalogViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..InvalidOperationException | Object is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
StatisticCatalog..::..StopWatchingAsync Method
StatisticCatalog Class See Also Send Feedback
Asynchronously stops watching the statistic catalog.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Object is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StatisticCatalog Properties

[image] [image]

IceLib Technical Reference
StatisticCatalog Properties
StatisticCatalog Class See Also Send Feedback

The StatisticCatalog type exposes the following members.

Properties

 | Name | Description
Public property | AllCategories | Gets all categories statistic definition.

See Also

StatisticCatalog Class
ININ.IceLib.Statistics Namespace


AllCategories Property

[image]

IceLib Technical Reference
StatisticCatalog..::..AllCategories Property
StatisticCatalog Class See Also Send Feedback
Gets all categories statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticCategory AllCategories { get; private set; }
Visual Basic
Public Property AllCategories As StatisticCategory
    Get
    Private Set

Field Value

The all categories statistic definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StatisticCatalog Events

[image] [image]

IceLib Technical Reference
StatisticCatalog Events
StatisticCatalog Class See Also Send Feedback

The StatisticCatalog type exposes the following members.

Events

 | Name | Description
Public event | StatisticCatalogChanged | Occurs when the statistics catalog has changed.

See Also

StatisticCatalog Class
ININ.IceLib.Statistics Namespace


StatisticCatalogChanged Event

[image]

IceLib Technical Reference
StatisticCatalog..::..StatisticCatalogChanged Event
StatisticCatalog Class See Also Send Feedback
Occurs when the statistics catalog has changed.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<StatisticCatalogChangedEventArgs> StatisticCatalogChanged
Visual Basic
Public Event StatisticCatalogChanged As EventHandler(Of StatisticCatalogChangedEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StatisticCatalog Class
StatisticCatalog Members
ININ.IceLib.Statistics Namespace


StatisticCatalogChangedEventArgs Class

[image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs Class
Members See Also Send Feedback
Provides data for for the StatisticCatalogChanged event. This contains a list of objects that have been added or removed and a list of all objects that have changed.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticCatalogChangedEventArgs : EventArgs
Visual Basic
Public Class StatisticCatalogChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics..::..StatisticCatalogChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StatisticCatalogChangedEventArgs Members
ININ.IceLib.Statistics Namespace


StatisticCatalogChangedEventArgs Members

[image] [image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs Members
StatisticCatalogChangedEventArgs Class Methods Properties See Also Send Feedback

The StatisticCatalogChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Get the statistic categories that were added.
Public property | Changed | Get the statistic categories that changed.
Public property | Removed | Get the statistic categories that were removed.

See Also

StatisticCatalogChangedEventArgs Class
ININ.IceLib.Statistics Namespace


StatisticCatalogChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs Methods
StatisticCatalogChangedEventArgs Class See Also Send Feedback

The StatisticCatalogChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticCatalogChangedEventArgs Class
ININ.IceLib.Statistics Namespace


StatisticCatalogChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs Properties
StatisticCatalogChangedEventArgs Class See Also Send Feedback

The StatisticCatalogChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Added | Get the statistic categories that were added.
Public property | Changed | Get the statistic categories that changed.
Public property | Removed | Get the statistic categories that were removed.

See Also

StatisticCatalogChangedEventArgs Class
ININ.IceLib.Statistics Namespace


Added Property

[image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs..::..Added Property
StatisticCatalogChangedEventArgs Class See Also Send Feedback
Get the statistic categories that were added.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticCategory> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of StatisticCategory)
    Get

Field Value

The added statistic categories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StatisticCatalogChangedEventArgs Class
StatisticCatalogChangedEventArgs Members
ININ.IceLib.Statistics Namespace


Changed Property

[image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs..::..Changed Property
StatisticCatalogChangedEventArgs Class See Also Send Feedback
Get the statistic categories that changed.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticCategory> Changed { get; }
Visual Basic
Public ReadOnly Property Changed As ReadOnlyCollection(Of StatisticCategory)
    Get

Field Value

The changed statistic categories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StatisticCatalogChangedEventArgs Class
StatisticCatalogChangedEventArgs Members
ININ.IceLib.Statistics Namespace


Removed Property

[image]

IceLib Technical Reference
StatisticCatalogChangedEventArgs..::..Removed Property
StatisticCatalogChangedEventArgs Class See Also Send Feedback
Get the statistic categories that were removed.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticCategory> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of StatisticCategory)
    Get

Field Value

The removed statistic categories.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

StatisticCatalogChangedEventArgs Class
StatisticCatalogChangedEventArgs Members
ININ.IceLib.Statistics Namespace


StatisticCategory Class

[image]

IceLib Technical Reference
StatisticCategory Class
Members Example See Also Send Feedback
Specific constants identifying a grouping of statistic definitions.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticCategory
Visual Basic
Public Class StatisticCategory

Examples

The IceLib SDK includes example application references to the StatisticCategory class. Some examples are listed below.
Project | Location
TutorialExample | StatisticCatalogViewModel.cs, line 61, in StatisticCatalogViewModel.set_SelectedStatisticCategory
 | StatisticCatalogViewModel.cs, line 46, in StatisticCatalogViewModel.set_AvailableStatisticCategories
 | StatisticCatalogViewModel._AvailableStatisticCategories
 | StatisticCatalogViewModel._SelectedStatisticCategory
 | SystemStatisticsViewModel.cs, line 111, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticCategory

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCategory Members
ININ.IceLib.Statistics Namespace


StatisticCategory Members

[image] [image]

IceLib Technical Reference
StatisticCategory Members
StatisticCategory Class Methods Properties See Also Send Feedback

The StatisticCategory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets a one or two sentence description about this statistic definition.
Public property | DisplayString | Gets the display string for this statistic definition.
Public property | Id | Gets the unique identifier for this statistic definition.
Public property | Licenses | At least one of the licenses that the user should have in order to see this catalog.

See Also

StatisticCategory Class
ININ.IceLib.Statistics Namespace


StatisticCategory Methods

[image] [image]

IceLib Technical Reference
StatisticCategory Methods
StatisticCategory Class See Also Send Feedback

The StatisticCategory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticCategory Class
ININ.IceLib.Statistics Namespace


StatisticCategory Properties

[image] [image]

IceLib Technical Reference
StatisticCategory Properties
StatisticCategory Class See Also Send Feedback

The StatisticCategory type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a one or two sentence description about this statistic definition.
Public property | DisplayString | Gets the display string for this statistic definition.
Public property | Id | Gets the unique identifier for this statistic definition.
Public property | Licenses | At least one of the licenses that the user should have in order to see this catalog.

See Also

StatisticCategory Class
ININ.IceLib.Statistics Namespace


Description Property

[image]

IceLib Technical Reference
StatisticCategory..::..Description Property
StatisticCategory Class See Also Send Feedback
Gets a one or two sentence description about this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCategory Class
StatisticCategory Members
ININ.IceLib.Statistics Namespace


DisplayString Property

[image]

IceLib Technical Reference
StatisticCategory..::..DisplayString Property
StatisticCategory Class See Also Send Feedback
Gets the display string for this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; private set; }
Visual Basic
Public Property DisplayString As String
    Get
    Private Set

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCategory Class
StatisticCategory Members
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
StatisticCategory..::..Id Property
StatisticCategory Class Example See Also Send Feedback
Gets the unique identifier for this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; private set; }
Visual Basic
Public Property Id As String
    Get
    Private Set

Field Value

The ID.

Examples

The IceLib SDK includes example application references to the Id property. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 111, in SystemStatisticsViewModel.StartWatchingCatalogCompleted
 | StatisticCatalogViewModel.cs, line 109, in StatisticCatalogViewModel.set_SelectedStatisticCategory

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCategory Class
StatisticCategory Members
ININ.IceLib.Statistics Namespace


Licenses Property

[image]

IceLib Technical Reference
StatisticCategory..::..Licenses Property
StatisticCategory Class See Also Send Feedback
At least one of the licenses that the user should have in order to see this catalog.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> Licenses { get; private set; }
Visual Basic
Public Property Licenses As ReadOnlyCollection(Of String)
    Get
    Private Set

Field Value

The licenses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticCategory Class
StatisticCategory Members
ININ.IceLib.Statistics Namespace


StatisticDefinition Class

[image]

IceLib Technical Reference
StatisticDefinition Class
Members Example See Also Send Feedback
Represents information about an IC statistic.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticDefinition
Visual Basic
Public Class StatisticDefinition

Remarks

Statistics can be retrieved with the StatisticCatalog. StatisticValue defines the value for an instance of a given statistic. An AlertDefinition can be created with the StatisticKey from a StatisticDefinition.

Examples

The IceLib SDK includes example application references to the StatisticDefinition class. Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 28, in StatisticViewModel.SetStatisticValue
 | StatisticCatalogViewModel.cs, line 134, in StatisticCatalogViewModel.set_StatisticDefinitions
 | StatisticCatalogViewModel._StatisticDefinitions
 | SystemStatisticsViewModel.cs, line 116, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Members
ININ.IceLib.Statistics Namespace


StatisticDefinition Members

[image] [image]

IceLib Technical Reference
StatisticDefinition Members
StatisticDefinition Class Methods Properties See Also Send Feedback

The StatisticDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Description | Gets a one or two sentence description about this statistic definition.
Public property | DisplayString | Gets the display string for this statistic definition.
Public property | DrillDowns | Gets the drill down lookups.
Public property | Expanded | Gets or sets a value indicating whether this StatisticDefinition is expanded.
Public property | Flags | Gets the flags that modify the StatisticDefinition.
Public property | Id | Gets the unique identifier for this statistic definition.
Public property | LowerBoundType | Gets the type of the lower bound.
Public property | LowerBoundValue | Gets the lower bound value.
Public property | Precision | Gets the precision.
Public property | RequiredParameters | Gets the required parameters.
Public property | SortIndex | The sort index is used to sort statistics in views.
Public property | Units | Gets the StatisticUnits for this statistic definition.
Public property | UnitsDisplayString | Gets the StatisticUnits display string.
Public property | UpperBoundType | Gets the type of the upper bound.
Public property | UpperBoundValue | Gets the upper bound value.
Public property | ValueType | Gets the StatisticValueType.

See Also

StatisticDefinition Class
ININ.IceLib.Statistics Namespace


StatisticDefinition Methods

[image] [image]

IceLib Technical Reference
StatisticDefinition Methods
StatisticDefinition Class See Also Send Feedback

The StatisticDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticDefinition Class
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticDefinition..::..ToString Method
StatisticDefinition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


StatisticDefinition Properties

[image] [image]

IceLib Technical Reference
StatisticDefinition Properties
StatisticDefinition Class See Also Send Feedback

The StatisticDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the category.
Public property | Description | Gets a one or two sentence description about this statistic definition.
Public property | DisplayString | Gets the display string for this statistic definition.
Public property | DrillDowns | Gets the drill down lookups.
Public property | Expanded | Gets or sets a value indicating whether this StatisticDefinition is expanded.
Public property | Flags | Gets the flags that modify the StatisticDefinition.
Public property | Id | Gets the unique identifier for this statistic definition.
Public property | LowerBoundType | Gets the type of the lower bound.
Public property | LowerBoundValue | Gets the lower bound value.
Public property | Precision | Gets the precision.
Public property | RequiredParameters | Gets the required parameters.
Public property | SortIndex | The sort index is used to sort statistics in views.
Public property | Units | Gets the StatisticUnits for this statistic definition.
Public property | UnitsDisplayString | Gets the StatisticUnits display string.
Public property | UpperBoundType | Gets the type of the upper bound.
Public property | UpperBoundValue | Gets the upper bound value.
Public property | ValueType | Gets the StatisticValueType.

See Also

StatisticDefinition Class
ININ.IceLib.Statistics Namespace


Category Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Category Property
StatisticDefinition Class See Also Send Feedback
Gets the category.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticCategory Category { get; private set; }
Visual Basic
Public Property Category As StatisticCategory
    Get
    Private Set

Field Value

The category.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


Description Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Description Property
StatisticDefinition Class Example See Also Send Feedback
Gets a one or two sentence description about this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; private set; }
Visual Basic
Public Property Description As String
    Get
    Private Set

Field Value

The description.

Examples

The IceLib SDK includes example application references to the Description property. Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 29, in StatisticViewModel.SetStatisticValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


DisplayString Property

[image]

IceLib Technical Reference
StatisticDefinition..::..DisplayString Property
StatisticDefinition Class Example See Also Send Feedback
Gets the display string for this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; private set; }
Visual Basic
Public Property DisplayString As String
    Get
    Private Set

Field Value

The display string.

Examples

The IceLib SDK includes example application references to the DisplayString property. Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 28, in StatisticViewModel.SetStatisticValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


DrillDowns Property

[image]

IceLib Technical Reference
StatisticDefinition..::..DrillDowns Property
StatisticDefinition Class See Also Send Feedback
Gets the drill down lookups.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<DrillDown> DrillDowns { get; }
Visual Basic
Public ReadOnly Property DrillDowns As ReadOnlyCollection(Of DrillDown)
    Get

Field Value

The drill down lookups.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


Expanded Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Expanded Property
StatisticDefinition Class See Also Send Feedback
Gets or sets a value indicating whether this StatisticDefinition is expanded.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Expanded { get; private set; }
Visual Basic
Public Property Expanded As Boolean
    Get
    Private Set

Field Value

true if expanded; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


Flags Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Flags Property
StatisticDefinition Class See Also Send Feedback
Gets the flags that modify the StatisticDefinition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticDefinitionFlags Flags { get; private set; }
Visual Basic
Public Property Flags As StatisticDefinitionFlags
    Get
    Private Set

Field Value

The flags.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


Id Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Id Property
StatisticDefinition Class Example See Also Send Feedback
Gets the unique identifier for this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticIdentifier Id { get; private set; }
Visual Basic
Public Property Id As StatisticIdentifier
    Get
    Private Set

Field Value

The ID.

Examples

The IceLib SDK includes example application references to the Id property. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 116, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


LowerBoundType Property

[image]

IceLib Technical Reference
StatisticDefinition..::..LowerBoundType Property
StatisticDefinition Class See Also Send Feedback
Gets the type of the lower bound.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public BoundValueType LowerBoundType { get; }
Visual Basic
Public ReadOnly Property LowerBoundType As BoundValueType
    Get

Field Value

The type of the lower bound.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


LowerBoundValue Property

[image]

IceLib Technical Reference
StatisticDefinition..::..LowerBoundValue Property
StatisticDefinition Class See Also Send Feedback
Gets the lower bound value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticValue LowerBoundValue { get; }
Visual Basic
Public ReadOnly Property LowerBoundValue As StatisticValue
    Get

Field Value

The lower bound value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


Precision Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Precision Property
StatisticDefinition Class See Also Send Feedback
Gets the precision.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Precision { get; }
Visual Basic
Public ReadOnly Property Precision As Integer
    Get

Field Value

The precision.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


RequiredParameters Property

[image]

IceLib Technical Reference
StatisticDefinition..::..RequiredParameters Property
StatisticDefinition Class See Also Send Feedback
Gets the required parameters.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<RequiredParametersDefinition> RequiredParameters { get; }
Visual Basic
Public ReadOnly Property RequiredParameters As ReadOnlyCollection(Of RequiredParametersDefinition)
    Get

Field Value

The required parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


SortIndex Property

[image]

IceLib Technical Reference
StatisticDefinition..::..SortIndex Property
StatisticDefinition Class See Also Send Feedback
The sort index is used to sort statistics in views.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int SortIndex { get; private set; }
Visual Basic
Public Property SortIndex As Integer
    Get
    Private Set

Field Value

The sort index of the statistic.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


Units Property

[image]

IceLib Technical Reference
StatisticDefinition..::..Units Property
StatisticDefinition Class See Also Send Feedback
Gets the StatisticUnits for this statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticUnits Units { get; }
Visual Basic
Public ReadOnly Property Units As StatisticUnits
    Get

Field Value

The units.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


UnitsDisplayString Property

[image]

IceLib Technical Reference
StatisticDefinition..::..UnitsDisplayString Property
StatisticDefinition Class Example See Also Send Feedback
Gets the StatisticUnits display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UnitsDisplayString { get; private set; }
Visual Basic
Public Property UnitsDisplayString As String
    Get
    Private Set

Field Value

The units display string.

Examples

The IceLib SDK includes example application references to the UnitsDisplayString property. Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 31, in StatisticViewModel.SetStatisticValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


UpperBoundType Property

[image]

IceLib Technical Reference
StatisticDefinition..::..UpperBoundType Property
StatisticDefinition Class See Also Send Feedback
Gets the type of the upper bound.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public BoundValueType UpperBoundType { get; }
Visual Basic
Public ReadOnly Property UpperBoundType As BoundValueType
    Get

Field Value

The type of the upper bound.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


UpperBoundValue Property

[image]

IceLib Technical Reference
StatisticDefinition..::..UpperBoundValue Property
StatisticDefinition Class See Also Send Feedback
Gets the upper bound value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticValue UpperBoundValue { get; }
Visual Basic
Public ReadOnly Property UpperBoundValue As StatisticValue
    Get

Field Value

The upper bound value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


ValueType Property

[image]

IceLib Technical Reference
StatisticDefinition..::..ValueType Property
StatisticDefinition Class See Also Send Feedback
Gets the StatisticValueType.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticValueType ValueType { get; }
Visual Basic
Public ReadOnly Property ValueType As StatisticValueType
    Get

Field Value

The type of the value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDefinition Class
StatisticDefinition Members
ININ.IceLib.Statistics Namespace


StatisticDefinitionFlags Enumeration

[image]

IceLib Technical Reference
StatisticDefinitionFlags Enumeration
See Also Send Feedback
Additional flags that may be set to modify a statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum StatisticDefinitionFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration StatisticDefinitionFlags

Members

Member name | Value | Description
None | 0 | No modifiers are in effect.
SuppressInUI | 1 | The statistic should not be displayed in the UI.
SuppressInAlerts | 2 | The statistic should not be used for alerts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics Namespace


StatisticDoubleValue Class

[image]

IceLib Technical Reference
StatisticDoubleValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticDoubleValue : StatisticValue,
    IComparable<StatisticDoubleValue>
Visual Basic
Public Class StatisticDoubleValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticDoubleValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticDoubleValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


StatisticDoubleValue Members

[image] [image]

IceLib Technical Reference
StatisticDoubleValue Members
StatisticDoubleValue Class Methods Properties See Also Send Feedback

The StatisticDoubleValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticDoubleValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the double value. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticDoubleValue Class
ININ.IceLib.Statistics Namespace


StatisticDoubleValue Methods

[image] [image]

IceLib Technical Reference
StatisticDoubleValue Methods
StatisticDoubleValue Class See Also Send Feedback

The StatisticDoubleValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticDoubleValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the double value. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticDoubleValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticDoubleValue..::..Clone Method
StatisticDoubleValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticDoubleValue..::..CompareTo Method
StatisticDoubleValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticDoubleValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticDoubleValue)

[image]

IceLib Technical Reference
StatisticDoubleValue..::..CompareTo Method (StatisticDoubleValue)
StatisticDoubleValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticDoubleValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticDoubleValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticDoubleValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticDoubleValue..::..GetDisplayString Method
StatisticDoubleValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticDoubleValue..::..GetNormalizedValue Method
StatisticDoubleValue Class See Also Send Feedback
Gets the double value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticDoubleValue..::..ToString Method
StatisticDoubleValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


StatisticDoubleValue Properties

[image] [image]

IceLib Technical Reference
StatisticDoubleValue Properties
StatisticDoubleValue Class See Also Send Feedback

The StatisticDoubleValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticDoubleValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticDoubleValue..::..Value Property
StatisticDoubleValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public double Value { get; private set; }
Visual Basic
Public Property Value As Double
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDoubleValue Class
StatisticDoubleValue Members
ININ.IceLib.Statistics Namespace


StatisticDurationValue Class

[image]

IceLib Technical Reference
StatisticDurationValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticDurationValue : StatisticValue,
    IComparable<StatisticDurationValue>
Visual Basic
Public Class StatisticDurationValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticDurationValue)

Remarks

A StatisticDurationValue is a time span that is a fixed length of time.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticDurationValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticDurationValue Members

[image] [image]

IceLib Technical Reference
StatisticDurationValue Members
StatisticDurationValue Class Methods Properties See Also Send Feedback

The StatisticDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticDurationValue Class
ININ.IceLib.Statistics Namespace


StatisticDurationValue Methods

[image] [image]

IceLib Technical Reference
StatisticDurationValue Methods
StatisticDurationValue Class See Also Send Feedback

The StatisticDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticDurationValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticDurationValue..::..Clone Method
StatisticDurationValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDurationValue Class
StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticDurationValue..::..CompareTo Method
StatisticDurationValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticDurationValue Class
StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticDurationValue)

[image]

IceLib Technical Reference
StatisticDurationValue..::..CompareTo Method (StatisticDurationValue)
StatisticDurationValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticDurationValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticDurationValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticDurationValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDurationValue Class
StatisticDurationValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticDurationValue..::..GetDisplayString Method
StatisticDurationValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticDurationValue Class
StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticDurationValue..::..GetNormalizedValue Method
StatisticDurationValue Class See Also Send Feedback
Gets the value as a normalized value by casting the number of ticks to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDurationValue Class
StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticDurationValue..::..ToString Method
StatisticDurationValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticDurationValue Class
StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticDurationValue Properties

[image] [image]

IceLib Technical Reference
StatisticDurationValue Properties
StatisticDurationValue Class See Also Send Feedback

The StatisticDurationValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticDurationValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticDurationValue..::..Value Property
StatisticDurationValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Value { get; private set; }
Visual Basic
Public Property Value As TimeSpan
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticDurationValue Class
StatisticDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticErrorValueType Enumeration

[image]

IceLib Technical Reference
StatisticErrorValueType Enumeration
See Also Send Feedback
Represents the error type of a statistic.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StatisticErrorValueType
Visual Basic
Public Enumeration StatisticErrorValueType

Members

Member name | Value | Description
None | 0 | No error retrieving the value.
MalformedStatKey | 1 | The statistic key is malformed.
UnknownStatKey | 2 | The statistic key could not be recognized.
StatProviderTooBusy | 3 | The statistic provider is currently too busy to process the request.
Other | 99 | An unknown error occurred.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

ININ.IceLib.Statistics Namespace


StatisticFiniteDurationValue Class

[image]

IceLib Technical Reference
StatisticFiniteDurationValue Class
Members See Also Send Feedback
The StatisticValue for statistics with a data type that can be fixed or actively increasing.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticFiniteDurationValue : StatisticValue,
    IComparable<StatisticFiniteDurationValue>
Visual Basic
Public Class StatisticFiniteDurationValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticFiniteDurationValue)

Remarks

The StatisticFiniteDurationValue Value is a timespan that can either be static, or constantly increasing depending on the state of the statistic.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticFiniteDurationValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticFiniteDurationValue Members

[image] [image]

IceLib Technical Reference
StatisticFiniteDurationValue Members
StatisticFiniteDurationValue Class Methods Properties See Also Send Feedback

The StatisticFiniteDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticFiniteDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the underlying TimeSpan value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property IsTicking
Gets a value indicating whether this time is currently counting up or not.
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span.

See Also

StatisticFiniteDurationValue Class
ININ.IceLib.Statistics Namespace


StatisticFiniteDurationValue Methods

[image] [image]

IceLib Technical Reference
StatisticFiniteDurationValue Methods
StatisticFiniteDurationValue Class See Also Send Feedback

The StatisticFiniteDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticFiniteDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the underlying TimeSpan value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticFiniteDurationValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..Clone Method
StatisticFiniteDurationValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..CompareTo Method
StatisticFiniteDurationValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticFiniteDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticFiniteDurationValue)

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..CompareTo Method (StatisticFiniteDurationValue)
StatisticFiniteDurationValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticFiniteDurationValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticFiniteDurationValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticFiniteDurationValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..GetDisplayString Method
StatisticFiniteDurationValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..GetNormalizedValue Method
StatisticFiniteDurationValue Class See Also Send Feedback
Gets the underlying TimeSpan value as a normalized value by casting the number of ticks to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


GetTimeStamp Method

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..GetTimeStamp Method
StatisticFiniteDurationValue Class See Also Send Feedback
Gets the time stamp associated with this time duration.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime GetTimeStamp()
Visual Basic
Public Function GetTimeStamp As DateTime

Return Value

The time stamp.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..ToString Method
StatisticFiniteDurationValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticFiniteDurationValue Properties

[image] [image]

IceLib Technical Reference
StatisticFiniteDurationValue Properties
StatisticFiniteDurationValue Class See Also Send Feedback

The StatisticFiniteDurationValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property IsTicking
Gets a value indicating whether this time is currently counting up or not.
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span.

See Also

StatisticFiniteDurationValue Class
ININ.IceLib.Statistics Namespace


IsTicking Property

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..IsTicking Property
StatisticFiniteDurationValue Class See Also Send Feedback
Gets a value indicating whether this time is currently counting up or not.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsTicking { get; }
Visual Basic
Public ReadOnly Property IsTicking As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is ticking; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticFiniteDurationValue..::..Value Property
StatisticFiniteDurationValue Class See Also Send Feedback
Gets the value as a time span.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Value { get; }
Visual Basic
Public ReadOnly Property Value As TimeSpan
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFiniteDurationValue Class
StatisticFiniteDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticFutureDurationValue Class

[image]

IceLib Technical Reference
StatisticFutureDurationValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type that is duration until something will happen.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticFutureDurationValue : StatisticValue,
    IComparable<StatisticFutureDurationValue>
Visual Basic
Public Class StatisticFutureDurationValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticFutureDurationValue)

Remarks

A StatisticFutureDurationValue represents the time span that counts down until something will happen as opposed to StatisticDurationValue that represents a fixed time span, StatisticTimeDurationValue which counts up since something happened, or StatisticFiniteDurationValue which switches between counting and fixed. This allows consumer applications to count down until the event will occur.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticFutureDurationValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticFutureDurationValue Members

[image] [image]

IceLib Technical Reference
StatisticFutureDurationValue Members
StatisticFutureDurationValue Class Methods Properties See Also Send Feedback

The StatisticFutureDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticFutureDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the elapsed TimeSpan value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span. The value returns the TimeSpan since the time stamp associated with this value. See GetTimeStamp()()()().

See Also

StatisticFutureDurationValue Class
ININ.IceLib.Statistics Namespace


StatisticFutureDurationValue Methods

[image] [image]

IceLib Technical Reference
StatisticFutureDurationValue Methods
StatisticFutureDurationValue Class See Also Send Feedback

The StatisticFutureDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticFutureDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the elapsed TimeSpan value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticFutureDurationValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..Clone Method
StatisticFutureDurationValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticFutureDurationValue..::..CompareTo Method
StatisticFutureDurationValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticFutureDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticFutureDurationValue)

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..CompareTo Method (StatisticFutureDurationValue)
StatisticFutureDurationValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticFutureDurationValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticFutureDurationValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticFutureDurationValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..GetDisplayString Method
StatisticFutureDurationValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..GetNormalizedValue Method
StatisticFutureDurationValue Class See Also Send Feedback
Gets the elapsed TimeSpan value as a normalized value by casting the number of ticks to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


GetTimeStamp Method

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..GetTimeStamp Method
StatisticFutureDurationValue Class See Also Send Feedback
Gets the time stamp associated with this time duration.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime GetTimeStamp()
Visual Basic
Public Function GetTimeStamp As DateTime

Return Value

The time stamp.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..ToString Method
StatisticFutureDurationValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticFutureDurationValue Properties

[image] [image]

IceLib Technical Reference
StatisticFutureDurationValue Properties
StatisticFutureDurationValue Class See Also Send Feedback

The StatisticFutureDurationValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span. The value returns the TimeSpan since the time stamp associated with this value. See GetTimeStamp()()()().

See Also

StatisticFutureDurationValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticFutureDurationValue..::..Value Property
StatisticFutureDurationValue Class See Also Send Feedback
Gets the value as a time span. The value returns the TimeSpan since the time stamp associated with this value. See GetTimeStamp()()()().

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Value { get; }
Visual Basic
Public ReadOnly Property Value As TimeSpan
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticFutureDurationValue Class
StatisticFutureDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticIdentifier Class

[image]

IceLib Technical Reference
StatisticIdentifier Class
Members See Also Send Feedback
Identifies a statistic.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticIdentifier : IEquatable<StatisticIdentifier>
Visual Basic
Public Class StatisticIdentifier _
    Implements IEquatable(Of StatisticIdentifier)

Remarks

To obtain an instance of this class, using a source URI string, the StatisticKeyTemplate class can be used along with the StatisticIdentifier property.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticIdentifier

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIdentifier Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..StatisticDefinition


StatisticIdentifier Members

[image] [image]

IceLib Technical Reference
StatisticIdentifier Members
StatisticIdentifier Class Methods Operators Properties See Also Send Feedback

The StatisticIdentifier type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatisticIdentifier) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
ImplicitWideningImplicitImplicitImplicit(StatisticIdentifier to String) | Performs an implicit conversion from StatisticIdentifier to String.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | Uri | Gets the URI string used to identify the statistic.

See Also

StatisticIdentifier Class
ININ.IceLib.Statistics Namespace


StatisticIdentifier Methods

[image] [image]

IceLib Technical Reference
StatisticIdentifier Methods
StatisticIdentifier Class See Also Send Feedback

The StatisticIdentifier type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatisticIdentifier) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticIdentifier Class
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
StatisticIdentifier..::..Equals Method
StatisticIdentifier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatisticIdentifier) | Indicates whether the current object is equal to another object of the same type.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
StatisticIdentifier..::..Equals Method (Object)
StatisticIdentifier Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object otherValue
)
Visual Basic
Public Overrides Function Equals ( _
    otherValue As Object _
) As Boolean

Parameters

otherValue
Type: System..::..Object

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (StatisticIdentifier)

[image]

IceLib Technical Reference
StatisticIdentifier..::..Equals Method (StatisticIdentifier)
StatisticIdentifier Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    StatisticIdentifier otherValue
)
Visual Basic
Public Function Equals ( _
    otherValue As StatisticIdentifier _
) As Boolean

Parameters

otherValue
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
An object to compare with this object.

Return Value

trueTruetruetrue (True in Visual Basic) if the current object is equal to the other parameter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
StatisticIdentifier..::..GetHashCode Method
StatisticIdentifier Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticIdentifier..::..ToString Method
StatisticIdentifier Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


StatisticIdentifier Operators and Type Conversions

[image] [image]

IceLib Technical Reference
StatisticIdentifier Operators and Type Conversions
StatisticIdentifier Class See Also Send Feedback

The StatisticIdentifier type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
ImplicitWideningImplicitImplicitImplicit(StatisticIdentifier to String) | Performs an implicit conversion from StatisticIdentifier to String.
Inequality | Implements the operator !=.

See Also

StatisticIdentifier Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
StatisticIdentifier..::..Equality Operator
StatisticIdentifier Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    StatisticIdentifier a,
    StatisticIdentifier b
)
Visual Basic
Public Shared Operator = ( _
    a As StatisticIdentifier, _
    b As StatisticIdentifier _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
A.
b
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


Implicit Conversion (StatisticIdentifier to String)

[image]

IceLib Technical Reference
StatisticIdentifier ImplicitWideningImplicitImplicitImplicit Conversion (StatisticIdentifier to String)
StatisticIdentifier Class See Also Send Feedback
Performs an implicit conversion from StatisticIdentifier to String.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static implicit operator string (
    StatisticIdentifier identifier
)
Visual Basic
Public Shared Widening Operator CType ( _
    identifier As StatisticIdentifier _
) As String

Parameters

identifier
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
The StatisticIdentifier.

Return Value

The result of the conversion.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
StatisticIdentifier..::..Inequality Operator
StatisticIdentifier Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    StatisticIdentifier a,
    StatisticIdentifier b
)
Visual Basic
Public Shared Operator <> ( _
    a As StatisticIdentifier, _
    b As StatisticIdentifier _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
A.
b
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


StatisticIdentifier Properties

[image] [image]

IceLib Technical Reference
StatisticIdentifier Properties
StatisticIdentifier Class See Also Send Feedback

The StatisticIdentifier type exposes the following members.

Properties

 | Name | Description
Public property | Uri | Gets the URI string used to identify the statistic.

See Also

StatisticIdentifier Class
ININ.IceLib.Statistics Namespace


Uri Property

[image]

IceLib Technical Reference
StatisticIdentifier..::..Uri Property
StatisticIdentifier Class See Also Send Feedback
Gets the URI string used to identify the statistic.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Uri { get; private set; }
Visual Basic
Public Property Uri As String
    Get
    Private Set

Field Value

The URI.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIdentifier Class
StatisticIdentifier Members
ININ.IceLib.Statistics Namespace


StatisticIntValue Class

[image]

IceLib Technical Reference
StatisticIntValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticIntValue : StatisticValue,
    IComparable<StatisticIntValue>
Visual Basic
Public Class StatisticIntValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticIntValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticIntValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIntValue Members
ININ.IceLib.Statistics Namespace


StatisticIntValue Members

[image] [image]

IceLib Technical Reference
StatisticIntValue Members
StatisticIntValue Class Methods Properties See Also Send Feedback

The StatisticIntValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticIntValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the integer value as a normalized value by casting to a double type. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticIntValue Class
ININ.IceLib.Statistics Namespace


StatisticIntValue Methods

[image] [image]

IceLib Technical Reference
StatisticIntValue Methods
StatisticIntValue Class See Also Send Feedback

The StatisticIntValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticIntValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the integer value as a normalized value by casting to a double type. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticIntValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticIntValue..::..Clone Method
StatisticIntValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIntValue Class
StatisticIntValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticIntValue..::..CompareTo Method
StatisticIntValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticIntValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticIntValue Class
StatisticIntValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticIntValue)

[image]

IceLib Technical Reference
StatisticIntValue..::..CompareTo Method (StatisticIntValue)
StatisticIntValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticIntValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticIntValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticIntValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIntValue Class
StatisticIntValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticIntValue..::..GetDisplayString Method
StatisticIntValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticIntValue Class
StatisticIntValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticIntValue..::..GetNormalizedValue Method
StatisticIntValue Class See Also Send Feedback
Gets the integer value as a normalized value by casting to a double type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIntValue Class
StatisticIntValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticIntValue..::..ToString Method
StatisticIntValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticIntValue Class
StatisticIntValue Members
ININ.IceLib.Statistics Namespace


StatisticIntValue Properties

[image] [image]

IceLib Technical Reference
StatisticIntValue Properties
StatisticIntValue Class See Also Send Feedback

The StatisticIntValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticIntValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticIntValue..::..Value Property
StatisticIntValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Value { get; private set; }
Visual Basic
Public Property Value As Integer
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticIntValue Class
StatisticIntValue Members
ININ.IceLib.Statistics Namespace


StatisticKey Class

[image]

IceLib Technical Reference
StatisticKey Class
Members Example See Also Send Feedback
Identifies a specific statistic value of interest.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticKey : IEquatable<StatisticKey>
Visual Basic
Public Class StatisticKey _
    Implements IEquatable(Of StatisticKey)

Remarks

A StatisticKey identifies a StatisticDefinition and a specific set of ParameterValues used in filtering the StatisticValues of that StatisticDefinition. A StatisticKey is used when requesting notification of alerts on a particular StatisticDefinition.

Examples

The IceLib SDK includes example application references to the StatisticKey class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 113, in SystemStatisticsViewModel.StartWatchingCatalogCompleted
 | SystemStatisticsViewModel._SystemStatistics
 | StatisticViewModel.cs, line 9, in StatisticViewModel.#ctor
 | StatisticViewModel._StatisticKey

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticKey

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Members
ININ.IceLib.Statistics Namespace


StatisticKey Members

[image] [image]

IceLib Technical Reference
StatisticKey Members
StatisticKey Class Constructors Methods Operators Properties See Also Send Feedback

The StatisticKey type exposes the following members.

Constructors

 | Name | Description
Public method | StatisticKey(StatisticIdentifier) | Initializes a new instance of the StatisticKey class.
Public method | StatisticKey(StatisticIdentifier, ParameterValueKeyedCollection) | Initializes a new instance of the StatisticKey class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatisticKey) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetParameters | Gets a copy of the parameter value keyed collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | Identifier | Gets the statistic definition.
Public property | UriString | Gets the URI string.

See Also

StatisticKey Class
ININ.IceLib.Statistics Namespace


StatisticKey Constructor

[image] [image]

IceLib Technical Reference
StatisticKey Constructor
StatisticKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StatisticKey(StatisticIdentifier) | Initializes a new instance of the StatisticKey class.
Public method | StatisticKey(StatisticIdentifier, ParameterValueKeyedCollection) | Initializes a new instance of the StatisticKey class.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


StatisticKey Constructor (StatisticIdentifier)

[image]

IceLib Technical Reference
StatisticKey Constructor (StatisticIdentifier)
StatisticKey Class Example See Also Send Feedback
Initializes a new instance of the StatisticKey class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticKey(
    StatisticIdentifier identifier
)
Visual Basic
Public Sub New ( _
    identifier As StatisticIdentifier _
)

Parameters

identifier
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
The statistic definition.

Examples

The IceLib SDK includes example application references to the StatisticKey constructor. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 116, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Exceptions

Exception | Condition
System..::..ArgumentNullException | identifier is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
StatisticKey Overload
ININ.IceLib.Statistics Namespace


StatisticKey Constructor (StatisticIdentifier, ParameterValueKeyedCollection)

[image]

IceLib Technical Reference
StatisticKey Constructor (StatisticIdentifier, ParameterValueKeyedCollection)
StatisticKey Class See Also Send Feedback
Initializes a new instance of the StatisticKey class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticKey(
    StatisticIdentifier identifier,
    ParameterValueKeyedCollection parameters
)
Visual Basic
Public Sub New ( _
    identifier As StatisticIdentifier, _
    parameters As ParameterValueKeyedCollection _
)

Parameters

identifier
Type: ININ.IceLib.Statistics..::..StatisticIdentifier
The definition.
parameters
Type: ININ.IceLib.Statistics..::..ParameterValueKeyedCollection
The parameters.

Exceptions

Exception | Condition
System..::..ArgumentNullException | identifier or parameters is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
StatisticKey Overload
ININ.IceLib.Statistics Namespace


StatisticKey Methods

[image] [image]

IceLib Technical Reference
StatisticKey Methods
StatisticKey Class See Also Send Feedback

The StatisticKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatisticKey) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetParameters | Gets a copy of the parameter value keyed collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticKey Class
ININ.IceLib.Statistics Namespace


Equals Method

[image] [image]

IceLib Technical Reference
StatisticKey..::..Equals Method
StatisticKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(StatisticKey) | Indicates whether the current object is equal to another object of the same type.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
StatisticKey..::..Equals Method (Object)
StatisticKey Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object otherValue
)
Visual Basic
Public Overrides Function Equals ( _
    otherValue As Object _
) As Boolean

Parameters

otherValue
Type: System..::..Object

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
Equals Overload
ININ.IceLib.Statistics Namespace


Equals Method (StatisticKey)

[image]

IceLib Technical Reference
StatisticKey..::..Equals Method (StatisticKey)
StatisticKey Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    StatisticKey otherValue
)
Visual Basic
Public Function Equals ( _
    otherValue As StatisticKey _
) As Boolean

Parameters

otherValue
Type: ININ.IceLib.Statistics..::..StatisticKey
An object to compare with this object.

Return Value

trueTruetruetrue (True in Visual Basic) if the current object is equal to the other parameter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
Equals Overload
ININ.IceLib.Statistics Namespace


GetHashCode Method

[image]

IceLib Technical Reference
StatisticKey..::..GetHashCode Method
StatisticKey Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


GetParameters Method

[image]

IceLib Technical Reference
StatisticKey..::..GetParameters Method
StatisticKey Class See Also Send Feedback
Gets a copy of the parameter value keyed collection.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValueKeyedCollection GetParameters()
Visual Basic
Public Function GetParameters As ParameterValueKeyedCollection

Return Value

The parameter value keyed collection.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticKey..::..ToString Method
StatisticKey Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


StatisticKey Operators

[image] [image]

IceLib Technical Reference
StatisticKey Operators
StatisticKey Class See Also Send Feedback

The StatisticKey type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

StatisticKey Class
ININ.IceLib.Statistics Namespace


Equality Operator

[image]

IceLib Technical Reference
StatisticKey..::..Equality Operator
StatisticKey Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    StatisticKey a,
    StatisticKey b
)
Visual Basic
Public Shared Operator = ( _
    a As StatisticKey, _
    b As StatisticKey _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..StatisticKey
A.
b
Type: ININ.IceLib.Statistics..::..StatisticKey
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


Inequality Operator

[image]

IceLib Technical Reference
StatisticKey..::..Inequality Operator
StatisticKey Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    StatisticKey a,
    StatisticKey b
)
Visual Basic
Public Shared Operator <> ( _
    a As StatisticKey, _
    b As StatisticKey _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics..::..StatisticKey
A.
b
Type: ININ.IceLib.Statistics..::..StatisticKey
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


StatisticKey Properties

[image] [image]

IceLib Technical Reference
StatisticKey Properties
StatisticKey Class See Also Send Feedback

The StatisticKey type exposes the following members.

Properties

 | Name | Description
Public property | Identifier | Gets the statistic definition.
Public property | UriString | Gets the URI string.

See Also

StatisticKey Class
ININ.IceLib.Statistics Namespace


Identifier Property

[image]

IceLib Technical Reference
StatisticKey..::..Identifier Property
StatisticKey Class See Also Send Feedback
Gets the statistic definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticIdentifier Identifier { get; private set; }
Visual Basic
Public Property Identifier As StatisticIdentifier
    Get
    Private Set

Field Value

The statistic definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


UriString Property

[image]

IceLib Technical Reference
StatisticKey..::..UriString Property
StatisticKey Class See Also Send Feedback
Gets the URI string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UriString { get; }
Visual Basic
Public ReadOnly Property UriString As String
    Get

Field Value

The URI string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKey Class
StatisticKey Members
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Class

[image]

IceLib Technical Reference
StatisticKeyTemplate Class
Members See Also Send Feedback
Represents a class to manipulate the contents of a StatisticKey.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticKeyTemplate
Visual Basic
Public Class StatisticKeyTemplate

Remarks

A StatisticKeyTemplate can be created from a source URI or an existing StatisticKey to go back and forth between the two.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticKeyTemplate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Members

[image] [image]

IceLib Technical Reference
StatisticKeyTemplate Members
StatisticKeyTemplate Class Constructors Methods Properties See Also Send Feedback

The StatisticKeyTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | StatisticKeyTemplate(String) | Initializes a new instance of the StatisticKeyTemplate class.
Public method | StatisticKeyTemplate(StatisticIdentifier) | Initializes a new instance of the StatisticKeyTemplate class.
Public method | StatisticKeyTemplate(StatisticKey) | Initializes a new instance of the StatisticKeyTemplate class.

Methods

 | Name | Description
 | ConvertToUriString(StatisticKey, Boolean) | Converts to URI string.
 | ConvertToUriString(String, IEnumerable<(Of <<'(ParameterValue>)>>), Boolean) | Converts to URI string.
 | CreateTemplate | Creates the template from a URI string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateUriString | GenerateUriString the URI string for the StatisticKeyTemplate instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Parameters | Gets the parameters.
Public property | StatisticIdentifier | Gets or sets the statistic definition ID.

See Also

StatisticKeyTemplate Class
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Constructor

[image] [image]

IceLib Technical Reference
StatisticKeyTemplate Constructor
StatisticKeyTemplate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StatisticKeyTemplate(String) | Initializes a new instance of the StatisticKeyTemplate class.
Public method | StatisticKeyTemplate(StatisticIdentifier) | Initializes a new instance of the StatisticKeyTemplate class.
Public method | StatisticKeyTemplate(StatisticKey) | Initializes a new instance of the StatisticKeyTemplate class.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Constructor (String)

[image]

IceLib Technical Reference
StatisticKeyTemplate Constructor (String)
StatisticKeyTemplate Class See Also Send Feedback
Initializes a new instance of the StatisticKeyTemplate class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticKeyTemplate(
    string sourceUri
)
Visual Basic
Public Sub New ( _
    sourceUri As String _
)

Parameters

sourceUri
Type: System..::..String
The uri used to build this key template.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
StatisticKeyTemplate Overload
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Constructor (StatisticIdentifier)

[image]

IceLib Technical Reference
StatisticKeyTemplate Constructor (StatisticIdentifier)
StatisticKeyTemplate Class See Also Send Feedback
Initializes a new instance of the StatisticKeyTemplate class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticKeyTemplate(
    StatisticIdentifier identifer
)
Visual Basic
Public Sub New ( _
    identifer As StatisticIdentifier _
)

Parameters

identifer
Type: ININ.IceLib.Statistics..::..StatisticIdentifier

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
StatisticKeyTemplate Overload
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Constructor (StatisticKey)

[image]

IceLib Technical Reference
StatisticKeyTemplate Constructor (StatisticKey)
StatisticKeyTemplate Class See Also Send Feedback
Initializes a new instance of the StatisticKeyTemplate class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticKeyTemplate(
    StatisticKey sourceStatisticKey
)
Visual Basic
Public Sub New ( _
    sourceStatisticKey As StatisticKey _
)

Parameters

sourceStatisticKey
Type: ININ.IceLib.Statistics..::..StatisticKey
The StatisticKey to created this template.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
StatisticKeyTemplate Overload
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Methods

[image] [image]

IceLib Technical Reference
StatisticKeyTemplate Methods
StatisticKeyTemplate Class See Also Send Feedback

The StatisticKeyTemplate type exposes the following members.

Methods

 | Name | Description
 | ConvertToUriString(StatisticKey, Boolean) | Converts to URI string.
 | ConvertToUriString(String, IEnumerable<(Of <<'(ParameterValue>)>>), Boolean) | Converts to URI string.
 | CreateTemplate | Creates the template from a URI string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateUriString | GenerateUriString the URI string for the StatisticKeyTemplate instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticKeyTemplate Class
ININ.IceLib.Statistics Namespace


ConvertToUriString Method

[image] [image]

IceLib Technical Reference
StatisticKeyTemplate..::..ConvertToUriString Method
StatisticKeyTemplate Class See Also Send Feedback

Overload List

Name | Description
ConvertToUriString(StatisticKey, Boolean) | Converts to URI string.
ConvertToUriString(String, IEnumerable<(Of <<'(ParameterValue>)>>), Boolean) | Converts to URI string.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


ConvertToUriString Method (StatisticKey, Boolean)

[image]

IceLib Technical Reference
StatisticKeyTemplate..::..ConvertToUriString Method (StatisticKey, Boolean)
StatisticKeyTemplate Class See Also Send Feedback
Converts to URI string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ConvertToUriString(
    StatisticKey statisticKey,
    bool includeDisplayString
)
Visual Basic
Public Shared Function ConvertToUriString ( _
    statisticKey As StatisticKey, _
    includeDisplayString As Boolean _
) As String

Parameters

statisticKey
Type: ININ.IceLib.Statistics..::..StatisticKey
The statistic key.
includeDisplayString
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) include the DisplayString in the URI string.

Return Value

A URI string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ConvertToUriString Overload
ININ.IceLib.Statistics Namespace


ConvertToUriString Method (String, IEnumerable(ParameterValue), Boolean)

[image]

IceLib Technical Reference
StatisticKeyTemplate..::..ConvertToUriString Method (String, IEnumerable<(Of <(<'ParameterValue>)>)>, Boolean)
StatisticKeyTemplate Class See Also Send Feedback
Converts to URI string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ConvertToUriString(
    string definitionId,
    IEnumerable<ParameterValue> parameters,
    bool includeDisplayString
)
Visual Basic
Public Shared Function ConvertToUriString ( _
    definitionId As String, _
    parameters As IEnumerable(Of ParameterValue), _
    includeDisplayString As Boolean _
) As String

Parameters

definitionId
Type: System..::..String
The definition ID.
parameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterValue >)>)>
The parameters.
includeDisplayString
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) include the DisplayString in the URI string.

Return Value

A URI string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ConvertToUriString Overload
ININ.IceLib.Statistics Namespace


CreateTemplate Method

[image]

IceLib Technical Reference
StatisticKeyTemplate..::..CreateTemplate Method
StatisticKeyTemplate Class See Also Send Feedback
Creates the template from a URI string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StatisticKeyTemplate CreateTemplate(
    string uriString
)
Visual Basic
Public Shared Function CreateTemplate ( _
    uriString As String _
) As StatisticKeyTemplate

Parameters

uriString
Type: System..::..String
The URI string.

Return Value

The template.

Exceptions

Exception | Condition
System..::..Exception | Exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


GenerateUriString Method

[image]

IceLib Technical Reference
StatisticKeyTemplate..::..GenerateUriString Method
StatisticKeyTemplate Class See Also Send Feedback
GenerateUriString the URI string for the StatisticKeyTemplate instance.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GenerateUriString(
    bool includeDisplayString
)
Visual Basic
Public Function GenerateUriString ( _
    includeDisplayString As Boolean _
) As String

Parameters

includeDisplayString
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) include the DisplayString in the URI string.

Return Value

A URI string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


StatisticKeyTemplate Properties

[image] [image]

IceLib Technical Reference
StatisticKeyTemplate Properties
StatisticKeyTemplate Class See Also Send Feedback

The StatisticKeyTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Parameters | Gets the parameters.
Public property | StatisticIdentifier | Gets or sets the statistic definition ID.

See Also

StatisticKeyTemplate Class
ININ.IceLib.Statistics Namespace


Parameters Property

[image]

IceLib Technical Reference
StatisticKeyTemplate..::..Parameters Property
StatisticKeyTemplate Class See Also Send Feedback
Gets the parameters.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ParameterValueKeyedCollection Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As ParameterValueKeyedCollection
    Get

Field Value

The parameters.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


StatisticIdentifier Property

[image]

IceLib Technical Reference
StatisticKeyTemplate..::..StatisticIdentifier Property
StatisticKeyTemplate Class See Also Send Feedback
Gets or sets the statistic definition ID.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticIdentifier StatisticIdentifier { get; set; }
Visual Basic
Public Property StatisticIdentifier As StatisticIdentifier
    Get
    Set

Field Value

The statistic definition ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticKeyTemplate Class
StatisticKeyTemplate Members
ININ.IceLib.Statistics Namespace


StatisticListener Class

[image]

IceLib Technical Reference
StatisticListener Class
Members Example See Also Send Feedback
Represents a watched object to query for IC statistics and listen for updates to those statistics.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticListener
Visual Basic
Public Class StatisticListener

Remarks

To watch for changes to statistic values, first call StartWatching(array<StatisticKey>[]()[][]) or StartWatchingAsync(array<StatisticKey>[]()[][], AsyncCompletedEventHandler, Object) to start a watch on the StatisticKey objects of interest. You can then use the indexer to retrieve the StatisticValue of a watched key. You can also register an event handler on StatisticValueUpdated to be notified when the statistic values change.

Note
For more information on getting started with statistics see Getting Started With Statistics.
Note
For for the list of available statistics see Statistics Catalog.

Examples

The IceLib SDK includes example application references to the StatisticListener class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 79, in SystemStatisticsViewModel.SessionConnectionStateChanged
 | SystemStatisticsViewModel.cs, line 34, in SystemStatisticsViewModel.#ctor
 | SystemStatisticsViewModel.cs, line 119, in SystemStatisticsViewModel.StartWatchingCatalogCompleted
 | SystemStatisticsViewModel._StatisticListener

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticListener

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Members
ININ.IceLib.Statistics Namespace


StatisticListener Members

[image] [image]

IceLib Technical Reference
StatisticListener Members
StatisticListener Class Constructors Methods Properties Events See Also Send Feedback

The StatisticListener type exposes the following members.

Constructors

 | Name | Description
Public method | StatisticListener | Initializes a new instance of the StatisticListener class.

Methods

 | Name | Description
Public method | ChangeWatchedKeys | A synchronous request to change the watched statistic values.
Public method | ChangeWatchedKeysAsync | Starts an asynchronous request to change the watched statistic values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedKeys | Gets the keys for the watched statistic values.
Public method | IsWatching()()()() | Determines whether this instance is watching.
Public method | IsWatching(StatisticKey) | Determines whether the statistic value at the specified key is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | A synchronous request to query and watch statistic values at the given keys.
Public method | StartWatchingAsync | Starts an asynchronous request to query and watch statistic values at the given keys.
Public method | StopWatching | A synchronous request to stop watching statistic values.
Public method | StopWatchingAsync | Start an asynchronous request to stop watching statistic values.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Item | Gets the StatisticValue with the specified key.

Events

 | Name | Description
Public event | StatisticValueUpdated | Occurs when a statistic value has been updated.

See Also

StatisticListener Class
ININ.IceLib.Statistics Namespace


StatisticListener Constructor

[image]

IceLib Technical Reference
StatisticListener Constructor
StatisticListener Class Example See Also Send Feedback
Initializes a new instance of the StatisticListener class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticListener(
    StatisticsManager statisticsManager
)
Visual Basic
Public Sub New ( _
    statisticsManager As StatisticsManager _
)

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Examples

The IceLib SDK includes example application references to the StatisticListener constructor. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 34, in SystemStatisticsViewModel.#ctor

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StatisticListener Methods

[image] [image]

IceLib Technical Reference
StatisticListener Methods
StatisticListener Class See Also Send Feedback

The StatisticListener type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedKeys | A synchronous request to change the watched statistic values.
Public method | ChangeWatchedKeysAsync | Starts an asynchronous request to change the watched statistic values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedKeys | Gets the keys for the watched statistic values.
Public method | IsWatching()()()() | Determines whether this instance is watching.
Public method | IsWatching(StatisticKey) | Determines whether the statistic value at the specified key is being watched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | A synchronous request to query and watch statistic values at the given keys.
Public method | StartWatchingAsync | Starts an asynchronous request to query and watch statistic values at the given keys.
Public method | StopWatching | A synchronous request to stop watching statistic values.
Public method | StopWatchingAsync | Start an asynchronous request to stop watching statistic values.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticListener Class
ININ.IceLib.Statistics Namespace


ChangeWatchedKeys Method

[image]

IceLib Technical Reference
StatisticListener..::..ChangeWatchedKeys Method
StatisticListener Class See Also Send Feedback
A synchronous request to change the watched statistic values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedKeys(
    StatisticKey[] keysToAdd,
    StatisticKey[] keysToRemove,
    bool replaceExisting
)
Visual Basic
Public Sub ChangeWatchedKeys ( _
    keysToAdd As StatisticKey(), _
    keysToRemove As StatisticKey(), _
    replaceExisting As Boolean _
)

Parameters

keysToAdd
Type: array< ININ.IceLib.Statistics..::..StatisticKey >[]()[][]
The keys of the statistic values to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
keysToRemove
Type: array< ININ.IceLib.Statistics..::..StatisticKey >[]()[][]
The keys of the statistic values to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.

Remarks

Note
For more information on watches see How Watches Work.
Note
Any requests for a statistic that has not yet been added to the cache from any session will initially return the value of 'N/A'. It will then be updated via StatisticValueUpdated when the cache is updated with the actual value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This StatisticListener is not watched.
System..::..ArgumentNullException | The keysToAdd or keysToRemove collection contains a nullNothingnullptra null reference (Nothing in Visual Basic) item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


ChangeWatchedKeysAsync Method

[image]

IceLib Technical Reference
StatisticListener..::..ChangeWatchedKeysAsync Method
StatisticListener Class See Also Send Feedback
Starts an asynchronous request to change the watched statistic values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedKeysAsync(
    StatisticKey[] keysToAdd,
    StatisticKey[] keysToRemove,
    bool replaceExisting,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedKeysAsync ( _
    keysToAdd As StatisticKey(), _
    keysToRemove As StatisticKey(), _
    replaceExisting As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

keysToAdd
Type: array< ININ.IceLib.Statistics..::..StatisticKey >[]()[][]
The keys of the statistic values to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
keysToRemove
Type: array< ININ.IceLib.Statistics..::..StatisticKey >[]()[][]
The keys of the statistic values to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.
Note
Any requests for a statistic that has not yet been added to the cache from any session will initially return the value of 'N/A'. It will then be updated via StatisticValueUpdated when the cache is updated with the actual value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This StatisticListener is not watched.
System..::..ArgumentNullException | The keysToAdd or keysToRemove collection contains a nullNothingnullptra null reference (Nothing in Visual Basic) item.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


GetWatchedKeys Method

[image]

IceLib Technical Reference
StatisticListener..::..GetWatchedKeys Method
StatisticListener Class See Also Send Feedback
Gets the keys for the watched statistic values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticKey> GetWatchedKeys()
Visual Basic
Public Function GetWatchedKeys As ReadOnlyCollection(Of StatisticKey)

Return Value

The collection of statistic keys that are watched.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This StatisticListener is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


IsWatching Method

[image] [image]

IceLib Technical Reference
StatisticListener..::..IsWatching Method
StatisticListener Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsWatching()()()() | Determines whether this instance is watching.
Public method | IsWatching(StatisticKey) | Determines whether the statistic value at the specified key is being watched.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


IsWatching Method

[image]

IceLib Technical Reference
StatisticListener..::..IsWatching Method
StatisticListener Class Example See Also Send Feedback
Determines whether this instance is watching.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is watching; otherwise falseFalsefalsefalse (False in Visual Basic).

Examples

The IceLib SDK includes example application references to the IsWatching method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 79, in SystemStatisticsViewModel.SessionConnectionStateChanged

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
IsWatching Overload
ININ.IceLib.Statistics Namespace


IsWatching Method (StatisticKey)

[image]

IceLib Technical Reference
StatisticListener..::..IsWatching Method (StatisticKey)
StatisticListener Class See Also Send Feedback
Determines whether the statistic value at the specified key is being watched.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching(
    StatisticKey key
)
Visual Basic
Public Function IsWatching ( _
    key As StatisticKey _
) As Boolean

Parameters

key
Type: ININ.IceLib.Statistics..::..StatisticKey
The key for a statistic value.

Return Value

trueTruetruetrue (True in Visual Basic) if the statistic value for the specified key is being watched; otherwise falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
IsWatching Overload
ININ.IceLib.Statistics Namespace


StartWatching Method

[image]

IceLib Technical Reference
StatisticListener..::..StartWatching Method
StatisticListener Class See Also Send Feedback
A synchronous request to query and watch statistic values at the given keys.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    StatisticKey[] keysToWatch
)
Visual Basic
Public Sub StartWatching ( _
    keysToWatch As StatisticKey() _
)

Parameters

keysToWatch
Type: array< ININ.IceLib.Statistics..::..StatisticKey >[]()[][]
The keys for the statistic values to start watching.

Remarks

Note
All event handlers should be added before calling StartWatching(array<StatisticKey>[]()[][]) or StartWatchingAsync(array<StatisticKey>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.
Note
Any requests for a statistic that has not yet been added to the cache from any session will initially return the value of 'N/A'. It will then be updated via StatisticValueUpdated when the cache is updated with the actual value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | keysToWatch is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | keysToWatch is empty.
System..::..InvalidOperationException | This StatisticListener is already watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
StatisticListener..::..StartWatchingAsync Method
StatisticListener Class Example See Also Send Feedback
Starts an asynchronous request to query and watch statistic values at the given keys.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    StatisticKey[] keysToWatch,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    keysToWatch As StatisticKey(), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

keysToWatch
Type: array< ININ.IceLib.Statistics..::..StatisticKey >[]()[][]
The keys for the statistic values to start watching.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<StatisticKey>[]()[][]) or StartWatchingAsync(array<StatisticKey>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.
Note
Any requests for a statistic that has not yet been added to the cache from any session will initially return the value of 'N/A'. It will then be updated via StatisticValueUpdated when the cache is updated with the actual value.

Examples

The IceLib SDK includes example application references to the StartWatchingAsync method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 119, in SystemStatisticsViewModel.StartWatchingCatalogCompleted

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch has already been started for this instance of StatisticListener.
System..::..ArgumentNullException | keysToWatch is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | keysToWatch is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StopWatching Method

[image]

IceLib Technical Reference
StatisticListener..::..StopWatching Method
StatisticListener Class Example See Also Send Feedback
A synchronous request to stop watching statistic values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Examples

The IceLib SDK includes example application references to the StopWatching method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 81, in SystemStatisticsViewModel.SessionConnectionStateChanged

Exceptions

Exception | Condition
System..::..InvalidOperationException | This StatisticListener is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
StatisticListener..::..StopWatchingAsync Method
StatisticListener Class See Also Send Feedback
Start an asynchronous request to stop watching statistic values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | A watch was not started. See StartWatching(array<StatisticKey>[]()[][]).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticListener..::..ToString Method
StatisticListener Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StatisticListener Properties

[image] [image]

IceLib Technical Reference
StatisticListener Properties
StatisticListener Class See Also Send Feedback

The StatisticListener type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the StatisticValue with the specified key.

See Also

StatisticListener Class
ININ.IceLib.Statistics Namespace


Item Property

[image]

IceLib Technical Reference
StatisticListener..::..Item Property
StatisticListener Class See Also Send Feedback
Gets the StatisticValue with the specified key.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticValue this[
    StatisticKey key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As StatisticKey _
) As StatisticValue
    Get

Parameters

key
Type: ININ.IceLib.Statistics..::..StatisticKey

Field Value

The statistic value.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The statistic key is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StatisticListener Events

[image] [image]

IceLib Technical Reference
StatisticListener Events
StatisticListener Class See Also Send Feedback

The StatisticListener type exposes the following members.

Events

 | Name | Description
Public event | StatisticValueUpdated | Occurs when a statistic value has been updated.

See Also

StatisticListener Class
ININ.IceLib.Statistics Namespace


StatisticValueUpdated Event

[image]

IceLib Technical Reference
StatisticListener..::..StatisticValueUpdated Event
StatisticListener Class Example See Also Send Feedback
Occurs when a statistic value has been updated.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<StatisticValueUpdatedEventArgs> StatisticValueUpdated
Visual Basic
Public Event StatisticValueUpdated As EventHandler(Of StatisticValueUpdatedEventArgs)

Remarks

This event will only occur when statistics being watched have changed. To start watching for statistics changes call either the StartWatching(array<StatisticKey>[]()[][]) method or the StartWatchingAsync(array<StatisticKey>[]()[][], AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<StatisticKey>[]()[][]) or StartWatchingAsync(array<StatisticKey>[]()[][], AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Examples

The IceLib SDK includes example application references to the StatisticValueUpdated event. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 35, in SystemStatisticsViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticListener Class
StatisticListener Members
ININ.IceLib.Statistics Namespace


StatisticPercentValue Class

[image]

IceLib Technical Reference
StatisticPercentValue Class
Members See Also Send Feedback
The StatisticValue for statistics with percentage values represented as a data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticPercentValue : StatisticValue,
    IComparable<StatisticPercentValue>
Visual Basic
Public Class StatisticPercentValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticPercentValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticPercentValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


StatisticPercentValue Members

[image] [image]

IceLib Technical Reference
StatisticPercentValue Members
StatisticPercentValue Class Methods Properties See Also Send Feedback

The StatisticPercentValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticPercentValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets underlying percent value. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticPercentValue Class
ININ.IceLib.Statistics Namespace


StatisticPercentValue Methods

[image] [image]

IceLib Technical Reference
StatisticPercentValue Methods
StatisticPercentValue Class See Also Send Feedback

The StatisticPercentValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticPercentValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets underlying percent value. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticPercentValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticPercentValue..::..Clone Method
StatisticPercentValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticPercentValue Class
StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticPercentValue..::..CompareTo Method
StatisticPercentValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticPercentValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticPercentValue Class
StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticPercentValue)

[image]

IceLib Technical Reference
StatisticPercentValue..::..CompareTo Method (StatisticPercentValue)
StatisticPercentValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticPercentValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticPercentValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticPercentValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticPercentValue Class
StatisticPercentValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticPercentValue..::..GetDisplayString Method
StatisticPercentValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticPercentValue Class
StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticPercentValue..::..GetNormalizedValue Method
StatisticPercentValue Class See Also Send Feedback
Gets underlying percent value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticPercentValue Class
StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticPercentValue..::..ToString Method
StatisticPercentValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticPercentValue Class
StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


StatisticPercentValue Properties

[image] [image]

IceLib Technical Reference
StatisticPercentValue Properties
StatisticPercentValue Class See Also Send Feedback

The StatisticPercentValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticPercentValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticPercentValue..::..Value Property
StatisticPercentValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public double Value { get; private set; }
Visual Basic
Public Property Value As Double
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticPercentValue Class
StatisticPercentValue Members
ININ.IceLib.Statistics Namespace


StatisticsManager Class

[image]

IceLib Technical Reference
StatisticsManager Class
Members Example See Also Send Feedback
Provides access to statistics.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticsManager
Visual Basic
Public Class StatisticsManager

Remarks

This class serves as the initial entry point into the Statistics namespace.
CopyC#
Session session = new Session();
session.Connect(...);
StatisticsManager statisticsManager = StatisticsManager.GetInstance(session);

Examples

The IceLib SDK includes example application references to the StatisticsManager class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 30, in SystemStatisticsViewModel.#ctor
 | SystemStatisticsViewModel._StatisticsManager
 | StatisticCatalogViewModel.cs, line 30, in StatisticCatalogViewModel.#ctor
 | StatisticCatalogViewModel._StatisticsManager

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticsManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticsManager Members
ININ.IceLib.Statistics Namespace


StatisticsManager Members

[image] [image]

IceLib Technical Reference
StatisticsManager Members
StatisticsManager Class Methods Properties See Also Send Feedback

The StatisticsManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a StatisticsManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Session | Gets the Session with which this StatisticsManager is associated.

See Also

StatisticsManager Class
ININ.IceLib.Statistics Namespace


StatisticsManager Methods

[image] [image]

IceLib Technical Reference
StatisticsManager Methods
StatisticsManager Class See Also Send Feedback

The StatisticsManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a StatisticsManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticsManager Class
ININ.IceLib.Statistics Namespace


GetInstance Method

[image]

IceLib Technical Reference
StatisticsManager..::..GetInstance Method
StatisticsManager Class Example See Also Send Feedback
Gets a StatisticsManager.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StatisticsManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As StatisticsManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The StatisticsManager.

Examples

The IceLib SDK includes example application references to the GetInstance method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 30, in SystemStatisticsViewModel.#ctor
 | StatisticCatalogViewModel.cs, line 30, in StatisticCatalogViewModel.#ctor

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticsManager Class
StatisticsManager Members
ININ.IceLib.Statistics Namespace


StatisticsManager Properties

[image] [image]

IceLib Technical Reference
StatisticsManager Properties
StatisticsManager Class See Also Send Feedback

The StatisticsManager type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session with which this StatisticsManager is associated.

See Also

StatisticsManager Class
ININ.IceLib.Statistics Namespace


Session Property

[image]

IceLib Technical Reference
StatisticsManager..::..Session Property
StatisticsManager Class See Also Send Feedback
Gets the Session with which this StatisticsManager is associated.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticsManager Class
StatisticsManager Members
ININ.IceLib.Statistics Namespace


StatisticStatusMessageKeyValue Class

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue Class
Members See Also Send Feedback
The StatisticValue for statistics with a time in status data type. Defines the length of time in status.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticStatusMessageKeyValue : StatisticValue,
    IComparable<StatisticStatusMessageKeyValue>
Visual Basic
Public Class StatisticStatusMessageKeyValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticStatusMessageKeyValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticStatusMessageKeyValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


StatisticStatusMessageKeyValue Members

[image] [image]

IceLib Technical Reference
StatisticStatusMessageKeyValue Members
StatisticStatusMessageKeyValue Class Methods Properties See Also Send Feedback

The StatisticStatusMessageKeyValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticStatusMessageKeyValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span. This value can never be negative.

See Also

StatisticStatusMessageKeyValue Class
ININ.IceLib.Statistics Namespace


StatisticStatusMessageKeyValue Methods

[image] [image]

IceLib Technical Reference
StatisticStatusMessageKeyValue Methods
StatisticStatusMessageKeyValue Class See Also Send Feedback

The StatisticStatusMessageKeyValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticStatusMessageKeyValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticStatusMessageKeyValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..Clone Method
StatisticStatusMessageKeyValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..CompareTo Method
StatisticStatusMessageKeyValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticStatusMessageKeyValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticStatusMessageKeyValue)

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..CompareTo Method (StatisticStatusMessageKeyValue)
StatisticStatusMessageKeyValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticStatusMessageKeyValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticStatusMessageKeyValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticStatusMessageKeyValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..GetDisplayString Method
StatisticStatusMessageKeyValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..GetNormalizedValue Method
StatisticStatusMessageKeyValue Class See Also Send Feedback
Gets the value as a normalized value by casting the number of ticks to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


GetTimeStamp Method

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..GetTimeStamp Method
StatisticStatusMessageKeyValue Class See Also Send Feedback
Gets the time stamp associated with this time duration.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime GetTimeStamp()
Visual Basic
Public Function GetTimeStamp As DateTime

Return Value

The time stamp.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..ToString Method
StatisticStatusMessageKeyValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


StatisticStatusMessageKeyValue Properties

[image] [image]

IceLib Technical Reference
StatisticStatusMessageKeyValue Properties
StatisticStatusMessageKeyValue Class See Also Send Feedback

The StatisticStatusMessageKeyValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span. This value can never be negative.

See Also

StatisticStatusMessageKeyValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticStatusMessageKeyValue..::..Value Property
StatisticStatusMessageKeyValue Class See Also Send Feedback
Gets the value as a time span. This value can never be negative.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Value { get; }
Visual Basic
Public ReadOnly Property Value As TimeSpan
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticStatusMessageKeyValue Class
StatisticStatusMessageKeyValue Members
ININ.IceLib.Statistics Namespace


StatisticStringValue Class

[image]

IceLib Technical Reference
StatisticStringValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticStringValue : StatisticValue,
    IComparable<StatisticStringValue>
Visual Basic
Public Class StatisticStringValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticStringValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticStringValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticStringValue Members
ININ.IceLib.Statistics Namespace


StatisticStringValue Members

[image] [image]

IceLib Technical Reference
StatisticStringValue Members
StatisticStringValue Class Methods Properties See Also Send Feedback

The StatisticStringValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticStringValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Returns 0.0, since a string value cannot be converted to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticStringValue Class
ININ.IceLib.Statistics Namespace


StatisticStringValue Methods

[image] [image]

IceLib Technical Reference
StatisticStringValue Methods
StatisticStringValue Class See Also Send Feedback

The StatisticStringValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticStringValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Returns 0.0, since a string value cannot be converted to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticStringValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticStringValue..::..Clone Method
StatisticStringValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticStringValue Class
StatisticStringValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticStringValue..::..CompareTo Method
StatisticStringValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticStringValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticStringValue Class
StatisticStringValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticStringValue)

[image]

IceLib Technical Reference
StatisticStringValue..::..CompareTo Method (StatisticStringValue)
StatisticStringValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticStringValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticStringValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticStringValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticStringValue Class
StatisticStringValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticStringValue..::..GetDisplayString Method
StatisticStringValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticStringValue Class
StatisticStringValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticStringValue..::..GetNormalizedValue Method
StatisticStringValue Class See Also Send Feedback
Returns 0.0, since a string value cannot be converted to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticStringValue Class
StatisticStringValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticStringValue..::..ToString Method
StatisticStringValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticStringValue Class
StatisticStringValue Members
ININ.IceLib.Statistics Namespace


StatisticStringValue Properties

[image] [image]

IceLib Technical Reference
StatisticStringValue Properties
StatisticStringValue Class See Also Send Feedback

The StatisticStringValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticStringValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticStringValue..::..Value Property
StatisticStringValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; private set; }
Visual Basic
Public Property Value As String
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticStringValue Class
StatisticStringValue Members
ININ.IceLib.Statistics Namespace


StatisticTimeDurationValue Class

[image]

IceLib Technical Reference
StatisticTimeDurationValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type that is duration since something happened.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticTimeDurationValue : StatisticValue,
    IComparable<StatisticTimeDurationValue>
Visual Basic
Public Class StatisticTimeDurationValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticTimeDurationValue)

Remarks

A StatisticTimeDurationValue represents the time span that counts up since something happened as opposed to StatisticDurationValue that represents a fixed time span, StatisticFutureDurationValue which counts down since something happened, or StatisticFiniteDurationValue which switches between counting and fixed. This allows consumer applications to count down until the event will occur.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticTimeDurationValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticTimeDurationValue Members

[image] [image]

IceLib Technical Reference
StatisticTimeDurationValue Members
StatisticTimeDurationValue Class Methods Properties See Also Send Feedback

The StatisticTimeDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticTimeDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the elapsed TimeSpan value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span. The value returns the TimeSpan since the time stamp associated with this value. See GetTimeStamp()()()().

See Also

StatisticTimeDurationValue Class
ININ.IceLib.Statistics Namespace


StatisticTimeDurationValue Methods

[image] [image]

IceLib Technical Reference
StatisticTimeDurationValue Methods
StatisticTimeDurationValue Class See Also Send Feedback

The StatisticTimeDurationValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticTimeDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the elapsed TimeSpan value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetTimeStamp | Gets the time stamp associated with this time duration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticTimeDurationValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..Clone Method
StatisticTimeDurationValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticTimeDurationValue..::..CompareTo Method
StatisticTimeDurationValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticTimeDurationValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticTimeDurationValue)

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..CompareTo Method (StatisticTimeDurationValue)
StatisticTimeDurationValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticTimeDurationValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticTimeDurationValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticTimeDurationValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..GetDisplayString Method
StatisticTimeDurationValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..GetNormalizedValue Method
StatisticTimeDurationValue Class See Also Send Feedback
Gets the elapsed TimeSpan value as a normalized value by casting the number of ticks to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


GetTimeStamp Method

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..GetTimeStamp Method
StatisticTimeDurationValue Class See Also Send Feedback
Gets the time stamp associated with this time duration.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime GetTimeStamp()
Visual Basic
Public Function GetTimeStamp As DateTime

Return Value

The time stamp.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..ToString Method
StatisticTimeDurationValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticTimeDurationValue Properties

[image] [image]

IceLib Technical Reference
StatisticTimeDurationValue Properties
StatisticTimeDurationValue Class See Also Send Feedback

The StatisticTimeDurationValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value as a time span. The value returns the TimeSpan since the time stamp associated with this value. See GetTimeStamp()()()().

See Also

StatisticTimeDurationValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticTimeDurationValue..::..Value Property
StatisticTimeDurationValue Class See Also Send Feedback
Gets the value as a time span. The value returns the TimeSpan since the time stamp associated with this value. See GetTimeStamp()()()().

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TimeSpan Value { get; }
Visual Basic
Public ReadOnly Property Value As TimeSpan
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeDurationValue Class
StatisticTimeDurationValue Members
ININ.IceLib.Statistics Namespace


StatisticTimeStampValue Class

[image]

IceLib Technical Reference
StatisticTimeStampValue Class
Members See Also Send Feedback
The StatisticValue for statistics with data type.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticTimeStampValue : StatisticValue,
    IComparable<StatisticTimeStampValue>
Visual Basic
Public Class StatisticTimeStampValue _
    Inherits StatisticValue _
    Implements IComparable(Of StatisticTimeStampValue)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticTimeStampValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


StatisticTimeStampValue Members

[image] [image]

IceLib Technical Reference
StatisticTimeStampValue Members
StatisticTimeStampValue Class Methods Properties See Also Send Feedback

The StatisticTimeStampValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticTimeStampValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticTimeStampValue Class
ININ.IceLib.Statistics Namespace


StatisticTimeStampValue Methods

[image] [image]

IceLib Technical Reference
StatisticTimeStampValue Methods
StatisticTimeStampValue Class See Also Send Feedback

The StatisticTimeStampValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this value. (Overrides StatisticValue..::..Clone()()()().)
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticTimeStampValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string. (Inherited from StatisticValue.)
Protected method | GetBestString(String) | Gets the best string. (Inherited from StatisticValue.)
Public method | GetDisplayString | Gets the value as a display string. (Overrides StatisticValue..::..GetDisplayString()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value by casting the number of ticks to a double. (Overrides StatisticValue..::..GetNormalizedValue()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

StatisticTimeStampValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticTimeStampValue..::..Clone Method
StatisticTimeStampValue Class See Also Send Feedback
Clones this value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override StatisticValue Clone()
Visual Basic
Public Overrides Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticTimeStampValue..::..CompareTo Method
StatisticTimeStampValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another. (Inherited from StatisticValue.)
Public method | CompareTo(StatisticTimeStampValue) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another. (Inherited from StatisticValue.)

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticTimeStampValue)

[image]

IceLib Technical Reference
StatisticTimeStampValue..::..CompareTo Method (StatisticTimeStampValue)
StatisticTimeStampValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticTimeStampValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticTimeStampValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticTimeStampValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticTimeStampValue..::..GetDisplayString Method
StatisticTimeStampValue Class See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string GetDisplayString()
Visual Basic
Public Overrides Function GetDisplayString As String

Return Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticTimeStampValue..::..GetNormalizedValue Method
StatisticTimeStampValue Class See Also Send Feedback
Gets the value as a normalized value by casting the number of ticks to a double.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override double GetNormalizedValue()
Visual Basic
Public Overrides Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


ToString Method

[image]

IceLib Technical Reference
StatisticTimeStampValue..::..ToString Method
StatisticTimeStampValue Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


StatisticTimeStampValue Properties

[image] [image]

IceLib Technical Reference
StatisticTimeStampValue Properties
StatisticTimeStampValue Class See Also Send Feedback

The StatisticTimeStampValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
(Inherited from StatisticValue.)
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
(Inherited from StatisticValue.)
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
(Inherited from StatisticValue.)
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
(Inherited from StatisticValue.)
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
(Inherited from StatisticValue.)
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
(Inherited from StatisticValue.)
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
(Inherited from StatisticValue.)
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.
(Inherited from StatisticValue.)
Public property Value
Gets the value.

See Also

StatisticTimeStampValue Class
ININ.IceLib.Statistics Namespace


Value Property

[image]

IceLib Technical Reference
StatisticTimeStampValue..::..Value Property
StatisticTimeStampValue Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Value { get; private set; }
Visual Basic
Public Property Value As DateTime
    Get
    Private Set

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticTimeStampValue Class
StatisticTimeStampValue Members
ININ.IceLib.Statistics Namespace


StatisticUnits Enumeration

[image]

IceLib Technical Reference
StatisticUnits Enumeration
See Also Send Feedback
Defines the measurement units of a StatisticValue.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StatisticUnits
Visual Basic
Public Enumeration StatisticUnits

Members

Member name | Value | Description
None | 0 | The value has no type specified.
Milliseconds | 1 | The type represents time in milliseconds.
Seconds | 2 | The type represents time in seconds.
Gigabytes | 3 | The type represents gigabytes.
Kilobytes | 4 | The type represents kilobytes.
Percent | 5 | The type represents a percentage.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..StatisticDefinition


StatisticValue Class

[image]

IceLib Technical Reference
StatisticValue Class
Members Example See Also Send Feedback
Represents an abstract class statistic values are based on.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class StatisticValue : IComparable,
    IComparable<StatisticValue>
Visual Basic
Public MustInherit Class StatisticValue _
    Implements IComparable, IComparable(Of StatisticValue)

Remarks

StatisticValue contains the data of the statistic. StatisticListener provides an indexer to return the current StatisticValue for the provided StatisticKey. AlertNotification provides a StatisticValue with the current value of a triggered AlertDefinition.

Examples

The IceLib SDK includes example application references to the StatisticValue class. Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 26, in StatisticViewModel.SetStatisticValue
 | StatisticViewModel._StatisticValue

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..StatisticValue
ININ.IceLib.Statistics..::..StatisticBoolValue
ININ.IceLib.Statistics..::..StatisticDoubleValue
ININ.IceLib.Statistics..::..StatisticDurationValue
ININ.IceLib.Statistics..::..StatisticFiniteDurationValue
ININ.IceLib.Statistics..::..StatisticFutureDurationValue
ININ.IceLib.Statistics..::..StatisticIntValue
ININ.IceLib.Statistics..::..StatisticPercentValue
ININ.IceLib.Statistics..::..StatisticStatusMessageKeyValue
ININ.IceLib.Statistics..::..StatisticStringValue
ININ.IceLib.Statistics..::..StatisticTimeDurationValue
ININ.IceLib.Statistics..::..StatisticTimeStampValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Members
ININ.IceLib.Statistics Namespace


StatisticValue Members

[image] [image]

IceLib Technical Reference
StatisticValue Members
StatisticValue Class Methods Properties See Also Send Feedback

The StatisticValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | CompareTo(Object) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string.
Protected method | GetBestString(String) | Gets the best string.
Public method | GetDisplayString | Gets the value as a display string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Public property Definition
Gets the definition.
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.

See Also

StatisticValue Class
ININ.IceLib.Statistics Namespace


StatisticValue Methods

[image] [image]

IceLib Technical Reference
StatisticValue Methods
StatisticValue Class See Also Send Feedback

The StatisticValue type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones this instance.
Public method | CompareTo(Object) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string.
Protected method | GetBestString(String) | Gets the best string.
Public method | GetDisplayString | Gets the value as a display string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormalizedValue | Gets the value as a normalized value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticValue Class
ININ.IceLib.Statistics Namespace


Clone Method

[image]

IceLib Technical Reference
StatisticValue..::..Clone Method
StatisticValue Class See Also Send Feedback
Clones this instance.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract StatisticValue Clone()
Visual Basic
Public MustOverride Function Clone As StatisticValue

Return Value

The new instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method

[image] [image]

IceLib Technical Reference
StatisticValue..::..CompareTo Method
StatisticValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares one statistic value to another.
Public method | CompareTo(StatisticValue) | Compares one statistic value to another.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


CompareTo Method (Object)

[image]

IceLib Technical Reference
StatisticValue..::..CompareTo Method (Object)
StatisticValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object other
)
Visual Basic
Public Function CompareTo ( _
    other As Object _
) As Integer

Parameters

other
Type: System..::..Object
The value to compare against.

Return Value

An integer.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was not a StatisticValue (or nullNothingnullptra null reference (Nothing in Visual Basic)).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


CompareTo Method (StatisticValue)

[image]

IceLib Technical Reference
StatisticValue..::..CompareTo Method (StatisticValue)
StatisticValue Class See Also Send Feedback
Compares one statistic value to another.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    StatisticValue other
)
Visual Basic
Public Function CompareTo ( _
    other As StatisticValue _
) As Integer

Parameters

other
Type: ININ.IceLib.Statistics..::..StatisticValue
The value to compare against.

Return Value

An integer.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The passed in argument was nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Unsupported value type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
CompareTo Overload
ININ.IceLib.Statistics Namespace


GetBestString Method

[image] [image]

IceLib Technical Reference
StatisticValue..::..GetBestString Method
StatisticValue Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetBestString(Func<(Of <<'(String>)>>)) | Gets the best string.
Protected method | GetBestString(String) | Gets the best string.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


GetBestString Method (Func(String))

[image]

IceLib Technical Reference
StatisticValue..::..GetBestString Method (Func<(Of <(<'String>)>)>)
StatisticValue Class See Also Send Feedback
Gets the best string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected internal string GetBestString(
    Func<string> defaultStringFunction
)
Visual Basic
Protected Friend Function GetBestString ( _
    defaultStringFunction As Func(Of String) _
) As String

Parameters

defaultStringFunction
Type: System..::..Func<(Of <(<'String>)>)>
Delegate function to the default string.

Return Value

The best string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
GetBestString Overload
ININ.IceLib.Statistics Namespace


GetBestString Method (String)

[image]

IceLib Technical Reference
StatisticValue..::..GetBestString Method (String)
StatisticValue Class See Also Send Feedback
Gets the best string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected internal string GetBestString(
    string defaultString
)
Visual Basic
Protected Friend Function GetBestString ( _
    defaultString As String _
) As String

Parameters

defaultString
Type: System..::..String
The default string.

Return Value

The best string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
GetBestString Overload
ININ.IceLib.Statistics Namespace


GetDisplayString Method

[image]

IceLib Technical Reference
StatisticValue..::..GetDisplayString Method
StatisticValue Class Example See Also Send Feedback
Gets the value as a display string.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract string GetDisplayString()
Visual Basic
Public MustOverride Function GetDisplayString As String

Return Value

The display string.

Examples

The IceLib SDK includes example application references to the GetDisplayString method (or a variation). Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 30, in StatisticViewModel.SetStatisticValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


GetNormalizedValue Method

[image]

IceLib Technical Reference
StatisticValue..::..GetNormalizedValue Method
StatisticValue Class See Also Send Feedback
Gets the value as a normalized value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract double GetNormalizedValue()
Visual Basic
Public MustOverride Function GetNormalizedValue As Double

Return Value

The normalized value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


StatisticValue Properties

[image] [image]

IceLib Technical Reference
StatisticValue Properties
StatisticValue Class See Also Send Feedback

The StatisticValue type exposes the following members.

Properties

Name Description
Public property Definition
Gets the definition.
Public property ErrorReason
Gets a value indicating the reason the StatisticValue could not be retrieved.
Public property IsError
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.
Public property IsNull
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.
Public property NullDisplayString
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.
Protected property StatisticErrorValueString
Returns the display string that is used to display a statistic with an error.
Public property TimeSpanWithDayFormatString
Returns the display string that is used to display a TimeSpan that contains a day.
Public property TimeSpanWithoutDayFormatString
Returns the display string that is used to display a TimeSpan that does not contains a day.

See Also

StatisticValue Class
ININ.IceLib.Statistics Namespace


Definition Property

[image]

IceLib Technical Reference
StatisticValue..::..Definition Property
StatisticValue Class Example See Also Send Feedback
Gets the definition.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticDefinition Definition { get; internal set; }
Visual Basic
Public Property Definition As StatisticDefinition
    Get
    Friend Set

Field Value

The definition.

Examples

The IceLib SDK includes example application references to the Definition property. Some examples are listed below.
Project | Location
TutorialExample | StatisticViewModel.cs, line 28, in StatisticViewModel.SetStatisticValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


ErrorReason Property

[image]

IceLib Technical Reference
StatisticValue..::..ErrorReason Property
StatisticValue Class See Also Send Feedback
Gets a value indicating the reason the StatisticValue could not be retrieved.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticErrorValueType ErrorReason { get; private set; }
Visual Basic
Public Property ErrorReason As StatisticErrorValueType
    Get
    Private Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


IsError Property

[image]

IceLib Technical Reference
StatisticValue..::..IsError Property
StatisticValue Class See Also Send Feedback
Gets a value indicating whether this instance is in an error state. This statistic has not been properly received from the server and should not be trusted.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsError { get; private set; }
Visual Basic
Public Property IsError As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is in error; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


IsNull Property

[image]

IceLib Technical Reference
StatisticValue..::..IsNull Property
StatisticValue Class See Also Send Feedback
Gets a value indicating whether this instance is nullNothingnullptra null reference (Nothing in Visual Basic).
Note
In addition to a nullNothingnullptra null reference (Nothing in Visual Basic) value, this object may be in an error state. See IsError.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsNull { get; internal set; }
Visual Basic
Public Property IsNull As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is nullNothingnullptra null reference (Nothing in Visual Basic); otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


NullDisplayString Property

[image]

IceLib Technical Reference
StatisticValue..::..NullDisplayString Property
StatisticValue Class See Also Send Feedback
Returns the display string that is used to display a statistic with a nullNothingnullptra null reference (Nothing in Visual Basic) value.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string NullDisplayString { get; }
Visual Basic
Public ReadOnly Property NullDisplayString As String
    Get

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


StatisticErrorValueString Property

[image]

IceLib Technical Reference
StatisticValue..::..StatisticErrorValueString Property
StatisticValue Class See Also Send Feedback
Returns the display string that is used to display a statistic with an error.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected internal string StatisticErrorValueString { get; }
Visual Basic
Protected Friend ReadOnly Property StatisticErrorValueString As String
    Get

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


TimeSpanWithDayFormatString Property

[image]

IceLib Technical Reference
StatisticValue..::..TimeSpanWithDayFormatString Property
StatisticValue Class See Also Send Feedback
Returns the display string that is used to display a TimeSpan that contains a day.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TimeSpanWithDayFormatString { get; }
Visual Basic
Public ReadOnly Property TimeSpanWithDayFormatString As String
    Get

Field Value

The format string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


TimeSpanWithoutDayFormatString Property

[image]

IceLib Technical Reference
StatisticValue..::..TimeSpanWithoutDayFormatString Property
StatisticValue Class See Also Send Feedback
Returns the display string that is used to display a TimeSpan that does not contains a day.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TimeSpanWithoutDayFormatString { get; }
Visual Basic
Public ReadOnly Property TimeSpanWithoutDayFormatString As String
    Get

Field Value

The format string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 1 and beyond.

See Also

StatisticValue Class
StatisticValue Members
ININ.IceLib.Statistics Namespace


StatisticValueType Enumeration

[image]

IceLib Technical Reference
StatisticValueType Enumeration
See Also Send Feedback
Represents the value type of a statistic.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StatisticValueType
Visual Basic
Public Enumeration StatisticValueType

Members

Member name | Value | Description
NotSupported | 0 | Value type is not supported.
Null | 1 | Value type is nullNothingnullptra null reference (Nothing in Visual Basic).
Error | 2 | Value type is error.
Int | 3 | Value type is an integer.
Double | 4 | Value type is a double.
String | 5 | Value type is a string.
Bool | 6 | Value type is a bool.
TimeStamp | 7 | Value type is time stamp.
TimeDuration | 8 | Value type is time stamp representing a duration.
Duration | 9 | Value type is duration.
FutureDuration | 10 | Value type is a future duration.
FiniteDuration | 11 | Value is a duration that has a finite life.
Percent | 12 | Value type is a percent.
StatusMessageKey | 13 | Value type is a status message key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..StatisticDefinition


StatisticValueUpdatedEventArgs Class

[image]

IceLib Technical Reference
StatisticValueUpdatedEventArgs Class
Members Example See Also Send Feedback
Provides data for StatisticValueUpdated event.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StatisticValueUpdatedEventArgs : EventArgs
Visual Basic
Public Class StatisticValueUpdatedEventArgs _
    Inherits EventArgs

Examples

The IceLib SDK includes example application references to the StatisticValueUpdatedEventArgs class. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 130, in SystemStatisticsViewModel.StatisticListenerStatisticValueUpdated

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics..::..StatisticValueUpdatedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValueUpdatedEventArgs Members
ININ.IceLib.Statistics Namespace
ININ.IceLib.Statistics..::..StatisticListener


StatisticValueUpdatedEventArgs Members

[image] [image]

IceLib Technical Reference
StatisticValueUpdatedEventArgs Members
StatisticValueUpdatedEventArgs Class Methods Properties See Also Send Feedback

The StatisticValueUpdatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | StatisticKeys | Gets the read only collection of statistic keys. This is a parallel array to StatisticValues.
Public property | StatisticValues | Gets the read only collection of statistic values. This is a parallel array to StatisticKeys.

See Also

StatisticValueUpdatedEventArgs Class
ININ.IceLib.Statistics Namespace


StatisticValueUpdatedEventArgs Methods

[image] [image]

IceLib Technical Reference
StatisticValueUpdatedEventArgs Methods
StatisticValueUpdatedEventArgs Class See Also Send Feedback

The StatisticValueUpdatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatisticValueUpdatedEventArgs Class
ININ.IceLib.Statistics Namespace


StatisticValueUpdatedEventArgs Properties

[image] [image]

IceLib Technical Reference
StatisticValueUpdatedEventArgs Properties
StatisticValueUpdatedEventArgs Class See Also Send Feedback

The StatisticValueUpdatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | StatisticKeys | Gets the read only collection of statistic keys. This is a parallel array to StatisticValues.
Public property | StatisticValues | Gets the read only collection of statistic values. This is a parallel array to StatisticKeys.

See Also

StatisticValueUpdatedEventArgs Class
ININ.IceLib.Statistics Namespace


StatisticKeys Property

[image]

IceLib Technical Reference
StatisticValueUpdatedEventArgs..::..StatisticKeys Property
StatisticValueUpdatedEventArgs Class Example See Also Send Feedback
Gets the read only collection of statistic keys. This is a parallel array to StatisticValues.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticKey> StatisticKeys { get; private set; }
Visual Basic
Public Property StatisticKeys As ReadOnlyCollection(Of StatisticKey)
    Get
    Private Set

Field Value

The statistic key collection.

Examples

The IceLib SDK includes example application references to the StatisticKeys property. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 131, in SystemStatisticsViewModel.StatisticListenerStatisticValueUpdated

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValueUpdatedEventArgs Class
StatisticValueUpdatedEventArgs Members
ININ.IceLib.Statistics Namespace


StatisticValues Property

[image]

IceLib Technical Reference
StatisticValueUpdatedEventArgs..::..StatisticValues Property
StatisticValueUpdatedEventArgs Class Example See Also Send Feedback
Gets the read only collection of statistic values. This is a parallel array to StatisticKeys.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<StatisticValue> StatisticValues { get; private set; }
Visual Basic
Public Property StatisticValues As ReadOnlyCollection(Of StatisticValue)
    Get
    Private Set

Field Value

The statistic value collection.

Examples

The IceLib SDK includes example application references to the StatisticValues property. Some examples are listed below.
Project | Location
TutorialExample | SystemStatisticsViewModel.cs, line 136, in SystemStatisticsViewModel.StatisticListenerStatisticValueUpdated

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StatisticValueUpdatedEventArgs Class
StatisticValueUpdatedEventArgs Members
ININ.IceLib.Statistics Namespace


ValidateAssociatedParameterSetCompletedEventArgs Class

[image]

IceLib Technical Reference
ValidateAssociatedParameterSetCompletedEventArgs Class
Members See Also Send Feedback
Provides data for completion of ValidateAssociatedParameterSetAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(ValidateAssociatedParameterSetCompletedEventArgs>)>>), Object).

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValidateAssociatedParameterSetCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class ValidateAssociatedParameterSetCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Statistics..::..ValidateAssociatedParameterSetCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidateAssociatedParameterSetCompletedEventArgs Members
ININ.IceLib.Statistics Namespace
ParameterValuesDepot..::..ValidateAssociatedParameterSet(AssociatedParameterSetQuery)
ParameterValuesDepot..::..ValidateAssociatedParameterSetAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(ValidateAssociatedParameterSetCompletedEventArgs>)>>), Object)


ValidateAssociatedParameterSetCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
ValidateAssociatedParameterSetCompletedEventArgs Members
ValidateAssociatedParameterSetCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ValidateAssociatedParameterSetCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ValidateAssociatedParameterSetCompletedEventArgs | Initializes a new instance of the ValidateAssociatedParameterSetCompletedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Results | Gets the results associated with the validation request.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ValidateAssociatedParameterSetCompletedEventArgs Class
ININ.IceLib.Statistics Namespace


ValidateAssociatedParameterSetCompletedEventArgs Constructor

[image]

IceLib Technical Reference
ValidateAssociatedParameterSetCompletedEventArgs Constructor
ValidateAssociatedParameterSetCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ValidateAssociatedParameterSetCompletedEventArgs class.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ValidateAssociatedParameterSetCompletedEventArgs(
    ValidatedAssociatedParameterSetValue results,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    results As ValidatedAssociatedParameterSetValue, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

results
Type: ININ.IceLib.Statistics..::..ValidatedAssociatedParameterSetValue
The results.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Exceptions

Exception | Condition
System..::..ArgumentNullException | results is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidateAssociatedParameterSetCompletedEventArgs Class
ValidateAssociatedParameterSetCompletedEventArgs Members
ININ.IceLib.Statistics Namespace


ValidateAssociatedParameterSetCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
ValidateAssociatedParameterSetCompletedEventArgs Methods
ValidateAssociatedParameterSetCompletedEventArgs Class See Also Send Feedback

The ValidateAssociatedParameterSetCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateAssociatedParameterSetCompletedEventArgs Class
ININ.IceLib.Statistics Namespace


ValidateAssociatedParameterSetCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
ValidateAssociatedParameterSetCompletedEventArgs Properties
ValidateAssociatedParameterSetCompletedEventArgs Class See Also Send Feedback

The ValidateAssociatedParameterSetCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Results | Gets the results associated with the validation request.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ValidateAssociatedParameterSetCompletedEventArgs Class
ININ.IceLib.Statistics Namespace


Results Property

[image]

IceLib Technical Reference
ValidateAssociatedParameterSetCompletedEventArgs..::..Results Property
ValidateAssociatedParameterSetCompletedEventArgs Class See Also Send Feedback
Gets the results associated with the validation request.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ValidatedAssociatedParameterSetValue Results { get; private set; }
Visual Basic
Public Property Results As ValidatedAssociatedParameterSetValue
    Get
    Private Set

Field Value

The results.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidateAssociatedParameterSetCompletedEventArgs Class
ValidateAssociatedParameterSetCompletedEventArgs Members
ININ.IceLib.Statistics Namespace


ValidatedAssociatedParameterSetValue Class

[image]

IceLib Technical Reference
ValidatedAssociatedParameterSetValue Class
Members See Also Send Feedback
Represents an ordered set of ValidatedDetailedParameterValue.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValidatedAssociatedParameterSetValue : IEnumerable<ValidatedDetailedParameterValue>,
    IEnumerable
Visual Basic
Public Class ValidatedAssociatedParameterSetValue _
    Implements IEnumerable(Of ValidatedDetailedParameterValue), IEnumerable

Remarks

A client application may have a need to retain the ID of a ParameterValue between executions of the client application. This may be necessary for restoring the user's preferred statistic display, for instance. It is possible for the display text and description for a ParameterValue to change while the client is offline, or for the ParameterValue to be removed altogether. For this reason, the client will need to validate the details of the ParameterValue when restoring the display.

The three things that the client is interested in are:

  • The combination of parameter values is still valid.
  • The individual parameter values still exist.
  • Retrieve updated display information for each parameter value.
This can be achieved by requesting the details for the ParameterValue via the GetDetailedParameterValues(IEnumerable<(Of <<'(ParameterValue>)>>)) method. This will return a DetailedParameterValue for all requested ParameterValues that still exist. Another option is use the ValidateAssociatedParameterSet(AssociatedParameterSetQuery) method which will return the DetailedParameterValue if it exists, but will also indicate the number of matching DetailedParameterValue instances for each ParameterType in the AssociatedParameterSetQuery if the query had requested any matching DetailedParameterValue.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ValidatedAssociatedParameterSetValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidatedAssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace
ParameterValuesDepot..::..ValidateAssociatedParameterSet(AssociatedParameterSetQuery)
ParameterValuesDepot..::..ValidateAssociatedParameterSetAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(ValidateAssociatedParameterSetCompletedEventArgs>)>>), Object)
ININ.IceLib.Statistics..::..ValidateAssociatedParameterSetCompletedEventArgs


ValidatedAssociatedParameterSetValue Members

[image] [image]

IceLib Technical Reference
ValidatedAssociatedParameterSetValue Members
ValidatedAssociatedParameterSetValue Class Methods Properties See Also Send Feedback

The ValidatedAssociatedParameterSetValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Gets the AssociatedParameterSetDefinition that defines the parameters types and order for this AssociatedParameterSetValue.

See Also

ValidatedAssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


ValidatedAssociatedParameterSetValue Methods

[image] [image]

IceLib Technical Reference
ValidatedAssociatedParameterSetValue Methods
ValidatedAssociatedParameterSetValue Class See Also Send Feedback

The ValidatedAssociatedParameterSetValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidatedAssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


GetEnumerator Method

[image]

IceLib Technical Reference
ValidatedAssociatedParameterSetValue..::..GetEnumerator Method
ValidatedAssociatedParameterSetValue Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerator<ValidatedDetailedParameterValue> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of ValidatedDetailedParameterValue)

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ValidatedAssociatedParameterSetValue Class
ValidatedAssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


ValidatedAssociatedParameterSetValue Properties

[image] [image]

IceLib Technical Reference
ValidatedAssociatedParameterSetValue Properties
ValidatedAssociatedParameterSetValue Class See Also Send Feedback

The ValidatedAssociatedParameterSetValue type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets the AssociatedParameterSetDefinition that defines the parameters types and order for this AssociatedParameterSetValue.

See Also

ValidatedAssociatedParameterSetValue Class
ININ.IceLib.Statistics Namespace


Definition Property

[image]

IceLib Technical Reference
ValidatedAssociatedParameterSetValue..::..Definition Property
ValidatedAssociatedParameterSetValue Class See Also Send Feedback
Gets the AssociatedParameterSetDefinition that defines the parameters types and order for this AssociatedParameterSetValue.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AssociatedParameterSetDefinition Definition { get; private set; }
Visual Basic
Public Property Definition As AssociatedParameterSetDefinition
    Get
    Private Set

Field Value

The definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidatedAssociatedParameterSetValue Class
ValidatedAssociatedParameterSetValue Members
ININ.IceLib.Statistics Namespace


ValidatedDetailedParameterValue Class

[image]

IceLib Technical Reference
ValidatedDetailedParameterValue Class
Members See Also Send Feedback
Represents the details for a ParameterValue from a request to validate a set of associated parameter values.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ValidatedDetailedParameterValue : DetailedParameterValue
Visual Basic
Public Class ValidatedDetailedParameterValue _
    Inherits DetailedParameterValue

Remarks

A client application may have a need to retain the ID of a ParameterValue between executions of the client application. This may be necessary for restoring the user's preferred statistic display, for instance. It is possible for the display text and description for a ParameterValue to change while the client is offline, or for the ParameterValue to be removed altogether. For this reason, the client will need to validate the details of the ParameterValue when restoring the display.

The three things that the client is interested in are:

  • The combination of parameter values is still valid.
  • The individual parameter values still exist.
  • Retrieve updated display information for each parameter value.
This can be achieved by requesting the details for the ParameterValue via the GetDetailedParameterValues(IEnumerable<(Of <<'(ParameterValue>)>>)) method. This will return a DetailedParameterValue for all requested ParameterValues that still exist. Another option is use the ValidateAssociatedParameterSet(AssociatedParameterSetQuery) method which will return the DetailedParameterValue if it exists, but will also indicate the number of matching DetailedParameterValue instances for each ParameterType in the AssociatedParameterSetQuery if the query had requested any matching DetailedParameterValue.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics..::..ParameterValue
ININ.IceLib.Statistics..::..DetailedParameterValue
ININ.IceLib.Statistics..::..ValidatedDetailedParameterValue

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidatedDetailedParameterValue Members
ININ.IceLib.Statistics Namespace
ParameterValuesDepot..::..ValidateAssociatedParameterSet(AssociatedParameterSetQuery)
ParameterValuesDepot..::..ValidateAssociatedParameterSetAsync(AssociatedParameterSetQuery, EventHandler<(Of <<'(ValidateAssociatedParameterSetCompletedEventArgs>)>>), Object)
ININ.IceLib.Statistics..::..ValidatedDetailedParameterValue


ValidatedDetailedParameterValue Members

[image] [image]

IceLib Technical Reference
ValidatedDetailedParameterValue Members
ValidatedDetailedParameterValue Class Methods Properties See Also Send Feedback

The ValidatedDetailedParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(DetailedParameterValue) | Compares the current object with another object of the same type. (Inherited from DetailedParameterValue.)
Public method | CompareTo(ParameterValue) | Compares the current object with another object of the same type. (Inherited from ParameterValue.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from DetailedParameterValue.)
Public method | Equals(DetailedParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from DetailedParameterValue.)
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from ParameterValue.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from DetailedParameterValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DetailedParameterValue.)

Properties

 | Name | Description
Public property | Description | Gets the description of the parameter. (Inherited from DetailedParameterValue.)
Public property | DisplayString | Gets the parameter value display string. (Inherited from DetailedParameterValue.)
Public property | IsValid | Gets a value indicating whether the requested ParameterValue is valid.
Public property | MatchCount | Gets the count of the number of ParameterValue instances that would be valid if the query to be validated had instead matched any ParameterValue rather than a specific ParameterValue.
Public property | Type | Gets parameter type. (Inherited from ParameterValue.)
Public property | Value | Gets the parameter value ID. (Inherited from ParameterValue.)

See Also

ValidatedDetailedParameterValue Class
ININ.IceLib.Statistics Namespace


ValidatedDetailedParameterValue Methods

[image] [image]

IceLib Technical Reference
ValidatedDetailedParameterValue Methods
ValidatedDetailedParameterValue Class See Also Send Feedback

The ValidatedDetailedParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo(DetailedParameterValue) | Compares the current object with another object of the same type. (Inherited from DetailedParameterValue.)
Public method | CompareTo(ParameterValue) | Compares the current object with another object of the same type. (Inherited from ParameterValue.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from DetailedParameterValue.)
Public method | Equals(DetailedParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from DetailedParameterValue.)
Public method | Equals(ParameterValue) | Indicates whether the current object is equal to another object of the same type. (Inherited from ParameterValue.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from DetailedParameterValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DetailedParameterValue.)

See Also

ValidatedDetailedParameterValue Class
ININ.IceLib.Statistics Namespace


ValidatedDetailedParameterValue Properties

[image] [image]

IceLib Technical Reference
ValidatedDetailedParameterValue Properties
ValidatedDetailedParameterValue Class See Also Send Feedback

The ValidatedDetailedParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of the parameter. (Inherited from DetailedParameterValue.)
Public property | DisplayString | Gets the parameter value display string. (Inherited from DetailedParameterValue.)
Public property | IsValid | Gets a value indicating whether the requested ParameterValue is valid.
Public property | MatchCount | Gets the count of the number of ParameterValue instances that would be valid if the query to be validated had instead matched any ParameterValue rather than a specific ParameterValue.
Public property | Type | Gets parameter type. (Inherited from ParameterValue.)
Public property | Value | Gets the parameter value ID. (Inherited from ParameterValue.)

See Also

ValidatedDetailedParameterValue Class
ININ.IceLib.Statistics Namespace


IsValid Property

[image]

IceLib Technical Reference
ValidatedDetailedParameterValue..::..IsValid Property
ValidatedDetailedParameterValue Class See Also Send Feedback
Gets a value indicating whether the requested ParameterValue is valid.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsValid { get; private set; }
Visual Basic
Public Property IsValid As Boolean
    Get
    Private Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

If falseFalsefalsefalse (False in Visual Basic), the details of the instance should be ignored.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidatedDetailedParameterValue Class
ValidatedDetailedParameterValue Members
ININ.IceLib.Statistics Namespace


MatchCount Property

[image]

IceLib Technical Reference
ValidatedDetailedParameterValue..::..MatchCount Property
ValidatedDetailedParameterValue Class See Also Send Feedback
Gets the count of the number of ParameterValue instances that would be valid if the query to be validated had instead matched any ParameterValue rather than a specific ParameterValue.

Namespace: ININ.IceLib.Statistics
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MatchCount { get; private set; }
Visual Basic
Public Property MatchCount As Integer
    Get
    Private Set

Field Value

The match count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ValidatedDetailedParameterValue Class
ValidatedDetailedParameterValue Members
ININ.IceLib.Statistics Namespace


ININ.IceLib.Statistics.Alerts Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Statistics.Alerts Namespace
Send Feedback

The ININ.IceLib.Statistics.Alerts namespace contains classes for viewing, changing, and receiving Interaction Center statistics alerts.

There are a number of classes within the ININ.IceLib.Statistics.Alerts namespace that provide support to the classes mentioned in the preceding summary. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

The following sequence describes one way of utilizing the members of the ININ.IceLib.Statistics.Alerts namespace for creating an alert to monitor.

  • Use StatisticCatalog to get a list of the available StatisticDefinitions
  • Use a StatisticDefinition to create a StatisticKey, which would describe the threshold for an alert
  • Use the StatisticKey to create an AlertDefinition
  • Create AlertRules associated with the AlertDefinition
  • Add the AlertDefinition to an EditableAlertSet
  • Create the AlertSet by sending the EditableAlertSet to the CreateAlertSet(EditableAlertSet) method
  • Subscribe to notifications for the AlertSet by calling the Subscribe(AlertSet, Boolean) method on AlertCatalog

Memo Watches. A Memo is an object that can be sent out from the server under certain circumstances or sent from a user to a list of recipients. The MemoList is used to watch for Memo objects that are sent out. There are three types of watching that can take place, MyMemos, GeneralMemos, and AlertMemos. MyMemos watch for Memo objects that target the current user. GeneralMemos watch for all non-alert Memo objects. AlertMemos watch for any Memo objects that are associated with an AlertSet. The MemoList is also used for sending out new Memo objects and sending out Memo updates.

Note
For more information on getting started with statistics see Getting Started With Statistics.
Note
For for the list of available statistics see Statistics Catalog.

Classes

 | Class | Description
Public class | AlertAction | Represents an alert action specification. An alert action defines what will occur when an alert triggers. An AlertRule has a list of AlertAction objects that define the behavior of the resulting events.
Public class | AlertActionTargets | Represents a list of well known IDs for action owners. These are used in conjunction with AlertAction to define the target of the alert action.
Public class | AlertCatalog | The alert catalog is used to manage AlertSet configurations, retrieving, creating, editing, and deleting them.
Public class | AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> | Provides data for for the AlertCatalogChanged event. This contains a list of objects that have been added or removed and a list of all objects and properties that have changed.
Public class | AlertCondition | Base class for alert conditions for alert rules. An alert condition defines what state will cause an alert to trigger. This, combined with the target StatisticKey is what makes up an alert.
Public class | AlertDefinition | Represents an alert definition. The alert definition defines a list of AlertRule objects that can be applied to a statistic key.
Public class | AlertFilterKey | Represents a unique key based on the alert set and target ID.
Public class | AlertListener | Represents a class to enable listening for alert notifications. Alert notifications are events that get sent down when an alert enters or exits the alerted state.
Public class | AlertListenerChangedEventArgs | Provides data for the AlertChanged event.
Public class | AlertNotification | Represents the data sent for a given alert. The alert notification contains the data that about what alert has changed state, its new state and value.
Public class | AlertNotificationEventArgs | Provides data for the AlertReceived event.
Public class | AlertRule | An alert rule is defined by a circumstance (AlertCondition) that triggers the rule and the set of outcomes (AlertAction) that occur when the rule is triggered. A collection of alert rules make up an AlertDefinition.
Public class | AlertRuleDelta | Represents a change to an alert rule during an AlertCatalogChanged event. Contains a list of all AlertAction objects that have been added or removed as well as what properties have changed on the AlertRule.
Public class | AlertSet | Represents a set of AlertDefinition objects. An alert set contains a group of alerts (AlertDefinition as well as information about the overall alert set. Use AlertCatalog to manage alert sets.
Public class | AlertSetSubscriber | Represents a subscriber to an AlertSet. An alert set subscriber contains information about a subscriber's subscription status in relation to an AlertSet
Public class | BoolCondition | Represents a boolean alert condition. This condition can be used on boolean statistics to trigger if the value is true or false, or if the statistics is or is not available. To create a new BoolCondition use one of the static Create functions.
Public class | ClientMemoAlertAction | Alert action for a client memo target. A client memo alert action defines a client memo that will be sent out when an alert is triggered.
Public class | CustomHandlerAlertAction | Alert action for a custom handler target. A custom handler alert action defines a custom handler that will be run when an alert is triggered.
Public class | EditableAlertSet | Represents an editable alert set. This object is used to create and update alert sets.
Public class | EmailMessageAlertAction | Alert action for an email message target. An email memo alert action defines an email that will be sent out when an alert is triggered.
Public class | Memo | Represents a memo within the Interaction Center system.
Public class | MemoEventArgs | Provides data for the memo events of MemoList.
Public class | MemoList | This class serves as the main interface for accessing and creating Memo objects.
Public class | MemoRecipient | Represents an entity that is listed as a receiver of a Memo.
Public class | NumericCondition<(Of <(<'T>)>)> | Represents a numeric alert condition. A numeric condition can be used against numeric statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To use a numeric condition, use one of its concrete implementations, such as NumericIntCondition.
Public class | NumericDoubleCondition | Represents a numeric double alert condition. A numeric double condition can be used against double statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericDoubleCondition use one of the static Create functions.
Public class | NumericIntCondition | Represents a numeric integer alert condition. A numeric int condition can be used against integer statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericIntCondition use one of the static Create functions.
Public class | NumericTimeSpanCondition | Represents a numeric time span alert condition. A numeric time span condition can be used against time span statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericTimeSpanCondition use one of the static Create functions.
Public class | NumericTimeStampCondition | Represents a numeric time stamp alert condition. A numeric time stamp condition can be used against time stamp statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericTimeStampCondition use one of the static Create functions.
Public class | StringCondition | Represents a string alert condition. A string condition can be used against string statistics to create alerts that trigger when the statistic has a value that matches, contains, or does not contain the supplied text, or if the statistic is or is not available. To create a new StringCondition use one of the static Create functions.

Enumerations

 | Enumeration | Description
Public enumeration | AlertConditionComparison | Mechanism to use when evaluating an AlertCondition.
Public enumeration | AlertListenerFilter | Filters AlertChanged events based on what changed in the corresponding AlertRule.
Public enumeration | AlertRuleChange | Track what has changed about a rule.
Public enumeration | AlertSet..::..Property | Specifies constants indicating what properties this object supports.
Public enumeration | AlertSetAccessMode | Defines the access mode for an alert set.
Public enumeration | AlertSetCategories | The category of an AlertSet within the AlertCatalog.
Public enumeration | AlertSetSubscriberAction | Defines the action to perform on a AlertSetSubscriber in relation to an AlertSet.
Public enumeration | AlertSetSubscriberType | Associates the _Id with a type.
Public enumeration | AlertSeverity | Represents an alert level for an AlertRule.
Public enumeration | EditableAlertSetUpdateOperation | Defines what update operation will be performed on an EditableAlertSet.
Public enumeration | MemoRecipientType | Represents the type of entity that a MemoRecipient refers to.
Public enumeration | MemoWatchType | Represents the type of the memo watcher.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.


AlertAction Class

[image]

IceLib Technical Reference
AlertAction Class
Members See Also Send Feedback
Represents an alert action specification. An alert action defines what will occur when an alert triggers. An AlertRule has a list of AlertAction objects that define the behavior of the resulting events.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertAction : IEquatable<AlertAction>
Visual Basic
Public Class AlertAction _
    Implements IEquatable(Of AlertAction)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertAction
ININ.IceLib.Statistics.Alerts..::..ClientMemoAlertAction
ININ.IceLib.Statistics.Alerts..::..CustomHandlerAlertAction
ININ.IceLib.Statistics.Alerts..::..EmailMessageAlertAction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Members

[image] [image]

IceLib Technical Reference
AlertAction Members
AlertAction Class Constructors Methods Operators Properties See Also Send Feedback

The AlertAction type exposes the following members.

Constructors

 | Name | Description
Public method | AlertAction(String) | Initializes a new instance of the AlertAction class.
Public method | AlertAction(AlertAction) | Initializes a new instance of the AlertAction class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value for the associated property name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name.

Operators

Name | Description
Equality | Determines whether two instances of AlertAction are equal.
Inequality | Determines whether two instances of AlertAction are not equal.

Properties

 | Name | Description
Public property | ActionId | Gets the action ID.
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | TargetId | Gets the target ID. Who the alert action is destined for.

See Also

AlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Constructor

[image] [image]

IceLib Technical Reference
AlertAction Constructor
AlertAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlertAction(String) | Initializes a new instance of the AlertAction class.
Public method | AlertAction(AlertAction) | Initializes a new instance of the AlertAction class.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Constructor (String)

[image]

IceLib Technical Reference
AlertAction Constructor (String)
AlertAction Class See Also Send Feedback
Initializes a new instance of the AlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertAction(
    string targetId
)
Visual Basic
Public Sub New ( _
    targetId As String _
)

Parameters

targetId
Type: System..::..String
The target ID.

Remarks

Well known target IDs are defined in AlertActionTargets. In order to receive the alert notification, the associated AlertFilterKey must be created using the same targetId value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
AlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Constructor (AlertAction)

[image]

IceLib Technical Reference
AlertAction Constructor (AlertAction)
AlertAction Class See Also Send Feedback
Initializes a new instance of the AlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertAction(
    AlertAction action
)
Visual Basic
Public Sub New ( _
    action As AlertAction _
)

Parameters

action
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
AlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Methods

[image] [image]

IceLib Technical Reference
AlertAction Methods
AlertAction Class See Also Send Feedback

The AlertAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value for the associated property name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name.

See Also

AlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AlertAction..::..Equals Method
AlertAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AlertAction..::..Equals Method (Object)
AlertAction Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertAction)

[image]

IceLib Technical Reference
AlertAction..::..Equals Method (AlertAction)
AlertAction Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AlertAction otherAction
)
Visual Basic
Public Function Equals ( _
    otherAction As AlertAction _
) As Boolean

Parameters

otherAction
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AlertAction..::..GetHashCode Method
AlertAction Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


GetValueNames Method

[image]

IceLib Technical Reference
AlertAction..::..GetValueNames Method
AlertAction Class See Also Send Feedback
Gets names of the values currently contained by this AlertAction.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IEnumerable<string> GetValueNames()
Visual Basic
Public Function GetValueNames As IEnumerable(Of String)

Return Value

The value names.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SetValue Method

[image]

IceLib Technical Reference
AlertAction..::..SetValue Method
AlertAction Class See Also Send Feedback
Sets the value for the associated property name.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetValue(
    string propertyName,
    string propertyValue
)
Visual Basic
Public Sub SetValue ( _
    propertyName As String, _
    propertyValue As String _
)

Parameters

propertyName
Type: System..::..String
Name of the property.
propertyValue
Type: System..::..String
The property value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The instance is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


TryGetValue Method

[image]

IceLib Technical Reference
AlertAction..::..TryGetValue Method
AlertAction Class See Also Send Feedback
Gets the value for the associated property name.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TryGetValue(
    string propertyName,
    out string propertyValue
)
Visual Basic
Public Function TryGetValue ( _
    propertyName As String, _
    <OutAttribute> ByRef propertyValue As String _
) As Boolean

Parameters

propertyName
Type: System..::..String
Name of the property.
propertyValue
Type: System..::..String%
The property value.

Return Value

trueTruetruetrue (True in Visual Basic) if the property exists, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Operators

[image] [image]

IceLib Technical Reference
AlertAction Operators
AlertAction Class See Also Send Feedback

The AlertAction type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of AlertAction are equal.
Inequality | Determines whether two instances of AlertAction are not equal.

See Also

AlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
AlertAction..::..Equality Operator
AlertAction Class See Also Send Feedback
Determines whether two instances of AlertAction are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AlertAction a,
    AlertAction b
)
Visual Basic
Public Shared Operator = ( _
    a As AlertAction, _
    b As AlertAction _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The first AlertAction to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The second AlertAction to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
AlertAction..::..Inequality Operator
AlertAction Class See Also Send Feedback
Determines whether two instances of AlertAction are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AlertAction a,
    AlertAction b
)
Visual Basic
Public Shared Operator <> ( _
    a As AlertAction, _
    b As AlertAction _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The first AlertAction to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The second AlertAction to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


AlertAction Properties

[image] [image]

IceLib Technical Reference
AlertAction Properties
AlertAction Class See Also Send Feedback

The AlertAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionId | Gets the action ID.
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | TargetId | Gets the target ID. Who the alert action is destined for.

See Also

AlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


ActionId Property

[image]

IceLib Technical Reference
AlertAction..::..ActionId Property
AlertAction Class See Also Send Feedback
Gets the action ID.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ActionId { get; internal set; }
Visual Basic
Public Property ActionId As String
    Get
    Friend Set

Field Value

The action ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Property

[image]

IceLib Technical Reference
AlertAction..::..AlertRule Property
AlertAction Class See Also Send Feedback
Gets the AlertRule that this AlertAction participates in.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRule AlertRule { get; internal set; }
Visual Basic
Public Property AlertRule As AlertRule
    Get
    Friend Set

Field Value

The AlertRule.

Remarks

If this AlertAction is not yet associated with an AlertRule, the value will be nullNothingnullptra null reference (Nothing in Visual Basic)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


IsEditable Property

[image]

IceLib Technical Reference
AlertAction..::..IsEditable Property
AlertAction Class See Also Send Feedback
Gets a value indicating whether this instance is editable.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; internal set; }
Visual Basic
Public Property IsEditable As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


TargetId Property

[image]

IceLib Technical Reference
AlertAction..::..TargetId Property
AlertAction Class See Also Send Feedback
Gets the target ID. Who the alert action is destined for.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TargetId { get; set; }
Visual Basic
Public Property TargetId As String
    Get
    Set

Field Value

The target ID.

Remarks

Well known target IDs are defined in AlertActionTargets. In order to receive the alert notification, the associated AlertFilterKey must be created using the same TargetId value.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The instance is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertAction Class
AlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


AlertActionTargets Class

[image]

IceLib Technical Reference
AlertActionTargets Class
Members See Also Send Feedback
Represents a list of well known IDs for action owners. These are used in conjunction with AlertAction to define the target of the alert action.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class AlertActionTargets
Visual Basic
Public NotInheritable Class AlertActionTargets

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertActionTargets

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertActionTargets Members
ININ.IceLib.Statistics.Alerts Namespace


AlertActionTargets Members

[image] [image]

IceLib Technical Reference
AlertActionTargets Members
AlertActionTargets Class Fields See Also Send Feedback

The AlertActionTargets type exposes the following members.

Fields

Name | Description
ClientMemo | The target is a client memo.
CustomHandler | The target is for IC custom handlers.
EmailMessage | The target is the Email subsystem.

See Also

AlertActionTargets Class
ININ.IceLib.Statistics.Alerts Namespace


AlertActionTargets Fields

[image] [image]

IceLib Technical Reference
AlertActionTargets Fields
AlertActionTargets Class See Also Send Feedback

The AlertActionTargets type exposes the following members.

Fields

Name | Description
ClientMemo | The target is a client memo.
CustomHandler | The target is for IC custom handlers.
EmailMessage | The target is the Email subsystem.

See Also

AlertActionTargets Class
ININ.IceLib.Statistics.Alerts Namespace


ClientMemo Field

[image]

IceLib Technical Reference
AlertActionTargets..::..ClientMemo Field
AlertActionTargets Class See Also Send Feedback
The target is a client memo.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ClientMemo
Visual Basic
Public Shared ReadOnly ClientMemo As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertActionTargets Class
AlertActionTargets Members
ININ.IceLib.Statistics.Alerts Namespace


CustomHandler Field

[image]

IceLib Technical Reference
AlertActionTargets..::..CustomHandler Field
AlertActionTargets Class See Also Send Feedback
The target is for IC custom handlers.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CustomHandler
Visual Basic
Public Shared ReadOnly CustomHandler As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertActionTargets Class
AlertActionTargets Members
ININ.IceLib.Statistics.Alerts Namespace


EmailMessage Field

[image]

IceLib Technical Reference
AlertActionTargets..::..EmailMessage Field
AlertActionTargets Class See Also Send Feedback
The target is the Email subsystem.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string EmailMessage
Visual Basic
Public Shared ReadOnly EmailMessage As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertActionTargets Class
AlertActionTargets Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalog Class

[image]

IceLib Technical Reference
AlertCatalog Class
Members See Also Send Feedback
The alert catalog is used to manage AlertSet configurations, retrieving, creating, editing, and deleting them.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertCatalog
Visual Basic
Public Class AlertCatalog

Remarks

This class allows you to start, stop, and change watches on on the entire alert catalog or a specified subset of it. StartWatching()()()() and StartWatchingAsync(AsyncCompletedEventHandler, Object) allow for watching the entire alert catalog. StartWatching(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) and StartWatchingAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) allow for watching for specific property changes on alert sets in a given category. StartWatching(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) and StartWatchingAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) allow for watching for specific property changes on the specified alerts. ChangeWatch(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)), ChangeWatchAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object), ChangeWatch(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)), and ChangeWatchAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) allow for modifying existing watches. StopWatching()()()() and StopWatchingAsync(AsyncCompletedEventHandler, Object) allow for stopping the existing watch. AlertCatalogChanged will be triggered when there is a change in one of the watched alert sets and properties. GetWatchedAlertSets()()()(), GetWatchedOwnerDefaultAlertSet()()()(), and GetWatchedSharedAlertSets()()()() can be used to retrieve the list of all alert sets, alert sets in the owner default category, and alert sets in the shared category respectively. GetAlertSet(String) can be used to retrieve a specific alert set. GetAlertDefinitions(StatisticKey, Boolean) will retrieve the alert definitions for a given statistic key. There must be an active watch to retrieve alert sets and definitions.

To create an alert set, first instantiate a new EditableAlertSet, filling it out as needed. Then call either CreateAlertSet(EditableAlertSet) or CreateAlertSetAsync(EditableAlertSet, AsyncCompletedEventHandler, Object) to create the alert set.

To modify an alert set, first retrieve the alert set by starting a watch and calling GetAlertSet(String), GetWatchedAlertSets()()()(), GetWatchedOwnerDefaultAlertSet()()()(), or GetWatchedSharedAlertSets()()()(). Then create an EditableAlertSet out of the AlertSet you wish to modify. Make the changes and call UpdateAlertSet(EditableAlertSet) or UpdateAlertSetAsync(EditableAlertSet, AsyncCompletedEventHandler, Object) to commit the changes.

To remove an alert set, call RemoveAlertSet(String) or RemoveAlertSetAsync(String, AsyncCompletedEventHandler, Object) specifying the alert set ID to remove.

Subscribe(AlertSet, Boolean) and SubscribeAsync(AlertSet, Boolean, AsyncCompletedEventHandler, Object) allow for subscribing and unsubscribing to a specific alert set.

Note
For more information on getting started with statistics see Getting Started With Statistics.
Note
For for the list of available statistics see Statistics Catalog.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCatalog

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalog Members

[image] [image]

IceLib Technical Reference
AlertCatalog Members
AlertCatalog Class Constructors Methods Events See Also Send Feedback

The AlertCatalog type exposes the following members.

Constructors

 | Name | Description
Public method | AlertCatalog | Initializes a new instance of the AlertCatalog class.

Methods

 | Name | Description
Public method | ChangeWatch(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to change the watched alert filters.
Public method | ChangeWatch(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to change the watched alert filters.
Public method | ChangeWatchAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to change the watched alert filters.
Public method | ChangeWatchAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to change the watched alert filters.
Public method | CreateAlertSet | Creates the alert set.
Public method | CreateAlertSetAsync | Updates the alert set asynchronously.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlertDefinitions | Gets the alert definitions for a specific statistic key.
Public method | GetAlertSet | Gets the alert set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedAlertSets | Gets the watched alert sets.
Public method | GetWatchedOwnerDefaultAlertSet | Gets the owner's default alert set.
Public method | GetWatchedSharedAlertSets | Gets the watched shared alert sets.
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertSet | Removes the alert set.
Public method | RemoveAlertSetAsync | Asynchronously removes the alert set.
Public method | StartWatching()()()() | Synchronous request to start watching alert filters.
Public method | StartWatching(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to start watching alert filters.
Public method | StartWatching(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to start watching alert filters.
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StartWatchingAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StartWatchingAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StopWatching | Stops watching the alert catalog.
Public method | StopWatchingAlertAdministrator | Stops the watching of the alert catalog that was started with Alert Administrator rights.
Public method | StopWatchingAlertAdministratorAsync | Asynchronously stops the watching of the alert catalog that was started with Alert Administrator rights.
Public method | StopWatchingAsync | Asynchronously stops watching the alert catalog.
Public method | Subscribe | Subscribes to the specified alert set.
Public method | SubscribeAsync | Asynchronously subscribes to the specified alert set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransferOwnership | Transfers the ownership for the given alertSet.
Public method | TransferOwnershipAsync | Asynchronously transfers the ownership for the given alertSet.
Public method | UpdateAlertSet | Updates the alert set.
Public method | UpdateAlertSetAsync | Asynchronously updates the alert set.
Public method | UpdateSubscriptions | Updates the subscriptions for an AlertSet.
Public method | UpdateSubscriptionsAsync | Asynchronously updates the subscriptions for an AlertSet.

Events

 | Name | Description
Public event | AlertCatalogChanged | Occurs when the alert catalog has changed.

See Also

AlertCatalog Class
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalog Constructor

[image]

IceLib Technical Reference
AlertCatalog Constructor
AlertCatalog Class See Also Send Feedback
Initializes a new instance of the AlertCatalog class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertCatalog(
    StatisticsManager statisticsManager
)
Visual Basic
Public Sub New ( _
    statisticsManager As StatisticsManager _
)

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | statisticsManager is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalog Methods

[image] [image]

IceLib Technical Reference
AlertCatalog Methods
AlertCatalog Class See Also Send Feedback

The AlertCatalog type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatch(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to change the watched alert filters.
Public method | ChangeWatch(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to change the watched alert filters.
Public method | ChangeWatchAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to change the watched alert filters.
Public method | ChangeWatchAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to change the watched alert filters.
Public method | CreateAlertSet | Creates the alert set.
Public method | CreateAlertSetAsync | Updates the alert set asynchronously.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlertDefinitions | Gets the alert definitions for a specific statistic key.
Public method | GetAlertSet | Gets the alert set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedAlertSets | Gets the watched alert sets.
Public method | GetWatchedOwnerDefaultAlertSet | Gets the owner's default alert set.
Public method | GetWatchedSharedAlertSets | Gets the watched shared alert sets.
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertSet | Removes the alert set.
Public method | RemoveAlertSetAsync | Asynchronously removes the alert set.
Public method | StartWatching()()()() | Synchronous request to start watching alert filters.
Public method | StartWatching(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to start watching alert filters.
Public method | StartWatching(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to start watching alert filters.
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StartWatchingAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StartWatchingAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StopWatching | Stops watching the alert catalog.
Public method | StopWatchingAlertAdministrator | Stops the watching of the alert catalog that was started with Alert Administrator rights.
Public method | StopWatchingAlertAdministratorAsync | Asynchronously stops the watching of the alert catalog that was started with Alert Administrator rights.
Public method | StopWatchingAsync | Asynchronously stops watching the alert catalog.
Public method | Subscribe | Subscribes to the specified alert set.
Public method | SubscribeAsync | Asynchronously subscribes to the specified alert set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransferOwnership | Transfers the ownership for the given alertSet.
Public method | TransferOwnershipAsync | Asynchronously transfers the ownership for the given alertSet.
Public method | UpdateAlertSet | Updates the alert set.
Public method | UpdateAlertSetAsync | Asynchronously updates the alert set.
Public method | UpdateSubscriptions | Updates the subscriptions for an AlertSet.
Public method | UpdateSubscriptionsAsync | Asynchronously updates the subscriptions for an AlertSet.

See Also

AlertCatalog Class
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatch Method

[image] [image]

IceLib Technical Reference
AlertCatalog..::..ChangeWatch Method
AlertCatalog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeWatch(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to change the watched alert filters.
Public method | ChangeWatch(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to change the watched alert filters.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatch Method (IEnumerable(AlertSet), IEnumerable(AlertSet.Property))

[image]

IceLib Technical Reference
AlertCatalog..::..ChangeWatch Method (IEnumerable<(Of <(<'AlertSet>)>)>, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>)
AlertCatalog Class See Also Send Feedback
Synchronous request to change the watched alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatch(
    IEnumerable<AlertSet> alertSets,
    IEnumerable<AlertSet..::..Property> properties
)
Visual Basic
Public Sub ChangeWatch ( _
    alertSets As IEnumerable(Of AlertSet), _
    properties As IEnumerable(Of AlertSet..::..Property) _
)

Parameters

alertSets
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet >)>)>
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ChangeWatch Overload
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatch Method (AlertSetCategories, IEnumerable(AlertSet.Property))

[image]

IceLib Technical Reference
AlertCatalog..::..ChangeWatch Method (AlertSetCategories, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>)
AlertCatalog Class See Also Send Feedback
Synchronous request to change the watched alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatch(
    AlertSetCategories categories,
    IEnumerable<AlertSet..::..Property> properties
)
Visual Basic
Public Sub ChangeWatch ( _
    categories As AlertSetCategories, _
    properties As IEnumerable(Of AlertSet..::..Property) _
)

Parameters

categories
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetCategories
The category or categories to watch.
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>
The AlertSet properties to watch.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or the requested categories are invalid.
System..::..ArgumentException | The parameter array is empty.
System..::..InvalidOperationException | The AlertCatalog is not watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ChangeWatch Overload
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatchAsync Method

[image] [image]

IceLib Technical Reference
AlertCatalog..::..ChangeWatchAsync Method
AlertCatalog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeWatchAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to change the watched alert filters.
Public method | ChangeWatchAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to change the watched alert filters.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatchAsync Method (IEnumerable(AlertSet), IEnumerable(AlertSet.Property), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
AlertCatalog..::..ChangeWatchAsync Method (IEnumerable<(Of <(<'AlertSet>)>)>, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>, AsyncCompletedEventHandler, Object)
AlertCatalog Class See Also Send Feedback
Asynchronous request to change the watched alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchAsync(
    IEnumerable<AlertSet> alertSets,
    IEnumerable<AlertSet..::..Property> properties,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchAsync ( _
    alertSets As IEnumerable(Of AlertSet), _
    properties As IEnumerable(Of AlertSet..::..Property), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

alertSets
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet >)>)>
The AlertSet instances to watch.
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>
The AlertSet properties to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ChangeWatchAsync Overload
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatchAsync Method (AlertSetCategories, IEnumerable(AlertSet.Property), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
AlertCatalog..::..ChangeWatchAsync Method (AlertSetCategories, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>, AsyncCompletedEventHandler, Object)
AlertCatalog Class See Also Send Feedback
Asynchronous request to change the watched alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchAsync(
    AlertSetCategories categories,
    IEnumerable<AlertSet..::..Property> properties,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchAsync ( _
    categories As AlertSetCategories, _
    properties As IEnumerable(Of AlertSet..::..Property), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

categories
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetCategories
The category or categories to watch.
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>
The AlertSet properties to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or the requested categories are invalid.
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ChangeWatchAsync Overload
ININ.IceLib.Statistics.Alerts Namespace


CreateAlertSet Method

[image]

IceLib Technical Reference
AlertCatalog..::..CreateAlertSet Method
AlertCatalog Class See Also Send Feedback
Creates the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateAlertSet(
    EditableAlertSet alertSet
)
Visual Basic
Public Sub CreateAlertSet ( _
    alertSet As EditableAlertSet _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..EditableAlertSet
The alert set.

Exceptions

Exception | Condition
System..::..ArgumentNullException | alertSet is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Alert set does not have create update operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


CreateAlertSetAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..CreateAlertSetAsync Method
AlertCatalog Class See Also Send Feedback
Updates the alert set asynchronously.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CreateAlertSetAsync(
    EditableAlertSet alertSet,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CreateAlertSetAsync ( _
    alertSet As EditableAlertSet, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..EditableAlertSet
The alert set.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | alertSet is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Alert set does not have create update operation.
System..::..Exception | Unexpected exception when creating the alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


GetAlertDefinitions Method

[image]

IceLib Technical Reference
AlertCatalog..::..GetAlertDefinitions Method
AlertCatalog Class See Also Send Feedback
Gets the alert definitions for a specific statistic key.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertDefinition> GetAlertDefinitions(
    StatisticKey statisticKey,
    bool subscribedOnly
)
Visual Basic
Public Function GetAlertDefinitions ( _
    statisticKey As StatisticKey, _
    subscribedOnly As Boolean _
) As ReadOnlyCollection(Of AlertDefinition)

Parameters

statisticKey
Type: ININ.IceLib.Statistics..::..StatisticKey
The statistic key.
subscribedOnly
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) only subscribed alerts will be returned.

Return Value

A list of alert definitions.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


GetAlertSet Method

[image]

IceLib Technical Reference
AlertCatalog..::..GetAlertSet Method
AlertCatalog Class See Also Send Feedback
Gets the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSet GetAlertSet(
    string alertSetId
)
Visual Basic
Public Function GetAlertSet ( _
    alertSetId As String _
) As AlertSet

Parameters

alertSetId
Type: System..::..String
The alert set ID.

Return Value

The alert set if found, nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched, or the requested alertSetId is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


GetWatchedAlertSets Method

[image]

IceLib Technical Reference
AlertCatalog..::..GetWatchedAlertSets Method
AlertCatalog Class See Also Send Feedback
Gets the watched alert sets.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertSet> GetWatchedAlertSets()
Visual Basic
Public Function GetWatchedAlertSets As ReadOnlyCollection(Of AlertSet)

Return Value

A collection of watched alert sets.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


GetWatchedOwnerDefaultAlertSet Method

[image]

IceLib Technical Reference
AlertCatalog..::..GetWatchedOwnerDefaultAlertSet Method
AlertCatalog Class See Also Send Feedback
Gets the owner's default alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSet GetWatchedOwnerDefaultAlertSet()
Visual Basic
Public Function GetWatchedOwnerDefaultAlertSet As AlertSet

Return Value

The alert set.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


GetWatchedSharedAlertSets Method

[image]

IceLib Technical Reference
AlertCatalog..::..GetWatchedSharedAlertSets Method
AlertCatalog Class See Also Send Feedback
Gets the watched shared alert sets.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertSet> GetWatchedSharedAlertSets()
Visual Basic
Public Function GetWatchedSharedAlertSets As ReadOnlyCollection(Of AlertSet)

Return Value

A collection of shared alert sets.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


IsWatching Method

[image]

IceLib Technical Reference
AlertCatalog..::..IsWatching Method
AlertCatalog Class See Also Send Feedback
Determines whether this instance is watching.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is watching; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


RemoveAlertSet Method

[image]

IceLib Technical Reference
AlertCatalog..::..RemoveAlertSet Method
AlertCatalog Class See Also Send Feedback
Removes the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveAlertSet(
    string alertSetId
)
Visual Basic
Public Sub RemoveAlertSet ( _
    alertSetId As String _
)

Parameters

alertSetId
Type: System..::..String
The alert set ID.

Exceptions

Exception | Condition
ININ.IceLib..::..InsufficientRightsException | Insufficient rights to delete the alert set.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


RemoveAlertSetAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..RemoveAlertSetAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously removes the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveAlertSetAsync(
    string alertSetId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RemoveAlertSetAsync ( _
    alertSetId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

alertSetId
Type: System..::..String
The alert set ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception while removing the alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatching Method

[image] [image]

IceLib Technical Reference
AlertCatalog..::..StartWatching Method
AlertCatalog Class See Also Send Feedback
Synchronous request to start watching alert filters.

Overload List

 | Name | Description
Public method | StartWatching()()()() | Synchronous request to start watching alert filters.
Public method | StartWatching(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to start watching alert filters.
Public method | StartWatching(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>)) | Synchronous request to start watching alert filters.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatching Method

[image]

IceLib Technical Reference
AlertCatalog..::..StartWatching Method
AlertCatalog Class See Also Send Feedback
Synchronous request to start watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
Starts a watch on all AlertSetCategories. The user must have the Alert Administrator right set in Interaction Administrator.
Note
All event handlers should be added before calling StartWatching or StartWatchingAsync.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The watch is already watching.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
StartWatching Overload
ININ.IceLib.Statistics.Alerts Namespace


StartWatching Method (IEnumerable(AlertSet), IEnumerable(AlertSet.Property))

[image]

IceLib Technical Reference
AlertCatalog..::..StartWatching Method (IEnumerable<(Of <(<'AlertSet>)>)>, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>)
AlertCatalog Class See Also Send Feedback
Synchronous request to start watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    IEnumerable<AlertSet> alertSets,
    IEnumerable<AlertSet..::..Property> properties
)
Visual Basic
Public Sub StartWatching ( _
    alertSets As IEnumerable(Of AlertSet), _
    properties As IEnumerable(Of AlertSet..::..Property) _
)

Parameters

alertSets
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet >)>)>
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>

Remarks

Note
All event handlers should be added before calling StartWatching or StartWatchingAsync.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The watch is already watching.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
StartWatching Overload
ININ.IceLib.Statistics.Alerts Namespace


StartWatching Method (AlertSetCategories, IEnumerable(AlertSet.Property))

[image]

IceLib Technical Reference
AlertCatalog..::..StartWatching Method (AlertSetCategories, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>)
AlertCatalog Class Example See Also Send Feedback
Synchronous request to start watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    AlertSetCategories categories,
    IEnumerable<AlertSet..::..Property> properties
)
Visual Basic
Public Sub StartWatching ( _
    categories As AlertSetCategories, _
    properties As IEnumerable(Of AlertSet..::..Property) _
)

Parameters

categories
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetCategories
The category or categories to watch.
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>
The AlertSet properties to watch.

Remarks

Note
If categories is All or categories has the AdminAccess flag, the user must have the Alert Administrator right set in Interaction Administrator.
Note
Using the All or AdminAccess will pull all Alerts from the system and in conjunction with listening to all Alerts can be harmful to performance.
Note
All event handlers should be added before calling StartWatching or StartWatchingAsync.
Note
For more information on watches see How Watches Work.

Examples

This example illustrates what should be avoided when using All or AdminAccess.
CopyC#
    Session session = new Session();
    session.Connect(...);
    StatisticsManager statisticsManager = StatisticsManager.GetInstance(session);
    AlertCatalog alertCatalog = new AlertCatalog(statisticsManager);
    AlertListener alertListener = new AlertListener(statisticsManager);

    AlertSet.Property[] properties = new[]
                                               {
                                                   AlertSet.Property.AccessMode,
                                                    AlertSet.Property.AlertDefinitions,
                                                    AlertSet.Property.Created,
                                                    AlertSet.Property.Description,
                                                    AlertSet.Property.DisplayString,
                                                    AlertSet.Property.Id,
                                                    AlertSet.Property.Modified,
                                                    AlertSet.Property.ModifiedBy,
                                                    AlertSet.Property.Owner,
                                                    AlertSet.Property.OwnerDisplayName,
                                                    AlertSet.Property.SubscribedByOther,
                                                    AlertSet.Property.SubscribedByUser,
                                                    AlertSet.Property.AlertSetSubscribers
                                                };

    alertCatalog.StartWatching(AlertSetCategories.All, properties);

    alertListener.AlertReceived += AlertListenerAlertReceived;
    alertListener.AlertChanged += AlertListenerAlertChanged;

    // This will return all AlertSets from the server when using <see cref="F:ININ.IceLib.Statistics.Alerts.AlertSetCategories.All" /> or <see cref="F:ININ.IceLib.Statistics.Alerts.AlertSetCategories.AdminAccess" />.
    var watchedAlertSets = alertCatalog.GetWatchedAlertSets();

    // Build AlertFilterKeys
    List<AlertFilterKey> filterKeys = new List<AlertFilterKey>();

    foreach (AlertSet alertSet in watchedAlertSets)
    {
        filterKeys.AddRange(BuildAlertFilterKey(alertSet));
    }

    // If AlertSetCategories.All or AlertSetCategories.AdminAccess was used this will start a watch on every unique AlertDefinition in each AlertSet.
    // **This is where performance could be impacted.**
    alertListener.StartWatching(
            filterKeys.ToArray(),
               AlertListenerFilter.Action | AlertListenerFilter.Condition | AlertListenerFilter.Severity);
}

private IEnumerable<AlertFilterKey> BuildAlertFilterKey(AlertSet alertSet)
{
    List<AlertFilterKey> alertFilterKeys = new List<AlertFilterKey>();
    List<string> uniqueTargets = new List<string>();

    foreach (AlertDefinition alertDefinition in alertSet.AlertDefinitions)
    {
        foreach (AlertRule alertRule in alertDefinition.AlertRules)
        {
            foreach (AlertAction alertAction in alertRule.AlertActions)
               {
                   if (!uniqueTargets.Contains(alertAction.TargetId))
                   {
                      uniqueTargets.Add(alertAction.TargetId);
                       alertFilterKeys.Add(new AlertFilterKey(alertSet, alertAction.TargetId));
                   }
               }
           }
    }

    return alertFilterKeys;
}

Exceptions

Exception | Condition
System..::..InvalidOperationException | The watch is already watching.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or the requested categories are invalid.
System..::..ArgumentException | The parameter array is empty.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
StartWatching Overload
ININ.IceLib.Statistics.Alerts Namespace


StartWatchingAsync Method

[image] [image]

IceLib Technical Reference
AlertCatalog..::..StartWatchingAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronous request to start watching the alert catalog.

Overload List

 | Name | Description
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StartWatchingAsync(IEnumerable<(Of <<'(AlertSet>)>>), IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.
Public method | StartWatchingAsync(AlertSetCategories, IEnumerable<(Of <<'(AlertSet..::..Property>)>>), AsyncCompletedEventHandler, Object) | Asynchronous request to start watching the alert catalog.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatchingAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
AlertCatalog..::..StartWatchingAsync Method (AsyncCompletedEventHandler, Object)
AlertCatalog Class See Also Send Feedback
Asynchronous request to start watching the alert catalog.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching or StartWatchingAsync.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
StartWatchingAsync Overload
ININ.IceLib.Statistics.Alerts Namespace


StartWatchingAsync Method (IEnumerable(AlertSet), IEnumerable(AlertSet.Property), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
AlertCatalog..::..StartWatchingAsync Method (IEnumerable<(Of <(<'AlertSet>)>)>, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>, AsyncCompletedEventHandler, Object)
AlertCatalog Class See Also Send Feedback
Asynchronous request to start watching the alert catalog.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    IEnumerable<AlertSet> alertSets,
    IEnumerable<AlertSet..::..Property> properties,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    alertSets As IEnumerable(Of AlertSet), _
    properties As IEnumerable(Of AlertSet..::..Property), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

alertSets
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet >)>)>
The AlertSet instances to watch.
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>
The AlertSet properties to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching or StartWatchingAsync.
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
StartWatchingAsync Overload
ININ.IceLib.Statistics.Alerts Namespace


StartWatchingAsync Method (AlertSetCategories, IEnumerable(AlertSet.Property), AsyncCompletedEventHandler, Object)

[image]

IceLib Technical Reference
AlertCatalog..::..StartWatchingAsync Method (AlertSetCategories, IEnumerable<(Of <(<'AlertSet..::..Property>)>)>, AsyncCompletedEventHandler, Object)
AlertCatalog Class Example See Also Send Feedback
Asynchronous request to start watching the alert catalog.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AlertSetCategories categories,
    IEnumerable<AlertSet..::..Property> properties,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    categories As AlertSetCategories, _
    properties As IEnumerable(Of AlertSet..::..Property), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

categories
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetCategories
The category or categories to watch.
properties
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSet..::..Property >)>)>
The AlertSet properties to watch.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching or StartWatchingAsync.
Note
If categories is All or categories has the AdminAccess flag, the user must have the Alert Administrator right set in Interaction Administrator.
Note
Using the All or AdminAccess will pull all Alerts from the system and in conjunction with listening to all Alerts can be harmful to performance.
Note
For more information on watches see How Watches Work.

Examples

This example illustrates what should be avoided when using All or AdminAccess.
CopyC#
    Session session = new Session();
    session.Connect(...);
    StatisticsManager statisticsManager = StatisticsManager.GetInstance(session);
    AlertCatalog alertCatalog = new AlertCatalog(statisticsManager);
    AlertListener alertListener = new AlertListener(statisticsManager);

    AlertSet.Property[] properties = new[]
                                               {
                                                   AlertSet.Property.AccessMode,
                                                    AlertSet.Property.AlertDefinitions,
                                                    AlertSet.Property.Created,
                                                    AlertSet.Property.Description,
                                                    AlertSet.Property.DisplayString,
                                                    AlertSet.Property.Id,
                                                    AlertSet.Property.Modified,
                                                    AlertSet.Property.ModifiedBy,
                                                    AlertSet.Property.Owner,
                                                    AlertSet.Property.OwnerDisplayName,
                                                    AlertSet.Property.SubscribedByOther,
                                                    AlertSet.Property.SubscribedByUser,
                                                    AlertSet.Property.AlertSetSubscribers
                                                };

    alertCatalog.StartWatching(AlertSetCategories.All, properties);

    alertListener.AlertReceived += AlertListenerAlertReceived;
    alertListener.AlertChanged += AlertListenerAlertChanged;

    // This will return all AlertSets from the server when using <see cref="F:ININ.IceLib.Statistics.Alerts.AlertSetCategories.All" /> or <see cref="F:ININ.IceLib.Statistics.Alerts.AlertSetCategories.AdminAccess" />.
    var watchedAlertSets = alertCatalog.GetWatchedAlertSets();

    // Build AlertFilterKeys
    List<AlertFilterKey> filterKeys = new List<AlertFilterKey>();

    foreach (AlertSet alertSet in watchedAlertSets)
    {
        filterKeys.AddRange(BuildAlertFilterKey(alertSet));
    }

    // If AlertSetCategories.All or AlertSetCategories.AdminAccess was used this will start a watch on every unique AlertDefinition in each AlertSet.
    // **This is where performance could be impacted.**
    alertListener.StartWatching(
            filterKeys.ToArray(),
               AlertListenerFilter.Action | AlertListenerFilter.Condition | AlertListenerFilter.Severity);
}

private IEnumerable<AlertFilterKey> BuildAlertFilterKey(AlertSet alertSet)
{
    List<AlertFilterKey> alertFilterKeys = new List<AlertFilterKey>();
    List<string> uniqueTargets = new List<string>();

    foreach (AlertDefinition alertDefinition in alertSet.AlertDefinitions)
    {
        foreach (AlertRule alertRule in alertDefinition.AlertRules)
        {
            foreach (AlertAction alertAction in alertRule.AlertActions)
               {
                   if (!uniqueTargets.Contains(alertAction.TargetId))
                   {
                      uniqueTargets.Add(alertAction.TargetId);
                       alertFilterKeys.Add(new AlertFilterKey(alertSet, alertAction.TargetId));
                   }
               }
           }
    }

    return alertFilterKeys;
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic) or the requested categories are invalid.
System..::..ArgumentException | The parameter array is empty.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
StartWatchingAsync Overload
ININ.IceLib.Statistics.Alerts Namespace


StopWatching Method

[image]

IceLib Technical Reference
AlertCatalog..::..StopWatching Method
AlertCatalog Class See Also Send Feedback
Stops watching the alert catalog.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatchingAlertAdministrator Method

[image]

IceLib Technical Reference
AlertCatalog..::..StopWatchingAlertAdministrator Method
AlertCatalog Class See Also Send Feedback
Stops the watching of the alert catalog that was started with Alert Administrator rights.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAlertAdministrator()
Visual Basic
Public Sub StopWatchingAlertAdministrator

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatchingAlertAdministratorAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..StopWatchingAlertAdministratorAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously stops the watching of the alert catalog that was started with Alert Administrator rights.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAlertAdministratorAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAlertAdministratorAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..StopWatchingAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously stops watching the alert catalog.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertCatalog is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


Subscribe Method

[image]

IceLib Technical Reference
AlertCatalog..::..Subscribe Method
AlertCatalog Class See Also Send Feedback
Subscribes to the specified alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Subscribe(
    AlertSet alertSet,
    bool subscribeFlag
)
Visual Basic
Public Sub Subscribe ( _
    alertSet As AlertSet, _
    subscribeFlag As Boolean _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set.
subscribeFlag
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) subscribe to alert set, else if set to falseFalsefalsefalse (False in Visual Basic) unsubscribe from the alert set.

Exceptions

Exception | Condition
System..::..ArgumentNullException | alertSet is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Cannot perform subscribe operation on default alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


SubscribeAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..SubscribeAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously subscribes to the specified alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SubscribeAsync(
    AlertSet alertSet,
    bool subscribeFlag,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SubscribeAsync ( _
    alertSet As AlertSet, _
    subscribeFlag As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set.
subscribeFlag
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) subscribe to alert set, else if set to falseFalsefalsefalse (False in Visual Basic) unsubscribe from the alert set.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | alertSet is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Cannot perform subscribe operation on default alert set.
System..::..Exception | An unexpected exception occurred while subscribing.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


TransferOwnership Method

[image]

IceLib Technical Reference
AlertCatalog..::..TransferOwnership Method
AlertCatalog Class See Also Send Feedback
Transfers the ownership for the given alertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TransferOwnership(
    string userId,
    AlertSet alertSet
)
Visual Basic
Public Sub TransferOwnership ( _
    userId As String, _
    alertSet As AlertSet _
)

Parameters

userId
Type: System..::..String
The user ID.
alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set.

Exceptions

Exception | Condition
System..::..ArgumentException | a parameter is an empty string.
System..::..ArgumentNullException | a parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Can not transfer ownership of a default alert set.
ININ.IceLib..::..InsufficientRightsException | Insufficient rights to transfer the ownership of the AlertSet.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


TransferOwnershipAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..TransferOwnershipAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously transfers the ownership for the given alertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void TransferOwnershipAsync(
    string userId,
    AlertSet alertSet,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub TransferOwnershipAsync ( _
    userId As String, _
    alertSet As AlertSet, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userId
Type: System..::..String
The user ID.
alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set's ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception occurred while transfering the ownership of the alert set.
System..::..ArgumentException | a parameter is an empty string.
System..::..ArgumentNullException | a parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


UpdateAlertSet Method

[image]

IceLib Technical Reference
AlertCatalog..::..UpdateAlertSet Method
AlertCatalog Class See Also Send Feedback
Updates the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateAlertSet(
    EditableAlertSet alertSet
)
Visual Basic
Public Sub UpdateAlertSet ( _
    alertSet As EditableAlertSet _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..EditableAlertSet
The alert set.

Exceptions

Exception | Condition
ININ.IceLib..::..InsufficientRightsException | Insufficient rights to modify the EditableAlertSet.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


UpdateAlertSetAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..UpdateAlertSetAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously updates the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateAlertSetAsync(
    EditableAlertSet alertSet,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateAlertSetAsync ( _
    alertSet As EditableAlertSet, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..EditableAlertSet
The alert set.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | Unexpected exception while updating the alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


UpdateSubscriptions Method

[image]

IceLib Technical Reference
AlertCatalog..::..UpdateSubscriptions Method
AlertCatalog Class See Also Send Feedback
Updates the subscriptions for an AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateSubscriptions(
    IEnumerable<AlertSetSubscriber> subscribers,
    string alertSetId
)
Visual Basic
Public Sub UpdateSubscriptions ( _
    subscribers As IEnumerable(Of AlertSetSubscriber), _
    alertSetId As String _
)

Parameters

subscribers
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSetSubscriber >)>)>
The subscribers.
alertSetId
Type: System..::..String
The alert set's ID.

Exceptions

Exception | Condition
System..::..ArgumentException | subscribers is empty or alertSetId is an empty string.
System..::..ArgumentNullException | a parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System.ComponentModel..::..InvalidEnumArgumentException | A subscriber has its Action set to Unknown or its Type set to Unknown.
ININ.IceLib..::..InsufficientRightsException | Insufficient rights to share or force subscriptions on the alert set.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


UpdateSubscriptionsAsync Method

[image]

IceLib Technical Reference
AlertCatalog..::..UpdateSubscriptionsAsync Method
AlertCatalog Class See Also Send Feedback
Asynchronously updates the subscriptions for an AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateSubscriptionsAsync(
    IEnumerable<AlertSetSubscriber> subscribers,
    string alertSetId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateSubscriptionsAsync ( _
    subscribers As IEnumerable(Of AlertSetSubscriber), _
    alertSetId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

subscribers
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertSetSubscriber >)>)>
The subscribers.
alertSetId
Type: System..::..String
The alert set's ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception occurred while updating the subscriptions of the alert set.
System..::..ArgumentException | subscribers is empty or alertSetId is an empty string.
System..::..ArgumentNullException | a parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalog Events

[image] [image]

IceLib Technical Reference
AlertCatalog Events
AlertCatalog Class See Also Send Feedback

The AlertCatalog type exposes the following members.

Events

 | Name | Description
Public event | AlertCatalogChanged | Occurs when the alert catalog has changed.

See Also

AlertCatalog Class
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalogChanged Event

[image]

IceLib Technical Reference
AlertCatalog..::..AlertCatalogChanged Event
AlertCatalog Class See Also Send Feedback
Occurs when the alert catalog has changed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AlertCatalogChangedEventArgs<AlertSet, AlertSet..::..Property>> AlertCatalogChanged
Visual Basic
Public Event AlertCatalogChanged As EventHandler(Of AlertCatalogChangedEventArgs(Of AlertSet, AlertSet..::..Property))

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalog Class
AlertCatalog Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalogChangedEventArgs(TWatchedObject, TWatchedObjectPropertiesEnum) Class

[image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
Members See Also Send Feedback
Provides data for for the AlertCatalogChanged event. This contains a list of objects that have been added or removed and a list of all objects and properties that have changed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertCatalogChangedEventArgs<TWatchedObject, TWatchedObjectPropertiesEnum> : EventArgs
where TWatchedObject : class
where TWatchedObjectPropertiesEnum : struct, new()
Visual Basic
Public Class AlertCatalogChangedEventArgs(Of TWatchedObject As Class, TWatchedObjectPropertiesEnum As {Structure, New}) _
    Inherits EventArgs

Type Parameters

TWatchedObject
The watched object.
TWatchedObjectPropertiesEnum
Enumeration describing the properties of the watched object.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics.Alerts..::..AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalogChangedEventArgs(TWatchedObject, TWatchedObjectPropertiesEnum) Members

[image] [image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Members
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class Methods Properties See Also Send Feedback

The AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChangedProperties | Gets the changed properties.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalogChangedEventArgs(TWatchedObject, TWatchedObjectPropertiesEnum) Methods

[image] [image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Methods
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class See Also Send Feedback

The AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChangedProperties | Gets the changed properties.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
ININ.IceLib.Statistics.Alerts Namespace


GetChangedProperties Method

[image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)>..::..GetChangedProperties Method
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class See Also Send Feedback
Gets the changed properties.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObjectPropertiesEnum> GetChangedProperties(
    TWatchedObject watchedObject
)
Visual Basic
Public Function GetChangedProperties ( _
    watchedObject As TWatchedObject _
) As ReadOnlyCollection(Of TWatchedObjectPropertiesEnum)

Parameters

watchedObject
Type: TWatchedObject
The watched object.

Return Value

Returns a list of properties that have changed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCatalogChangedEventArgs(TWatchedObject, TWatchedObjectPropertiesEnum) Properties

[image] [image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Properties
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class See Also Send Feedback

The AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Added | Get the existing object identifiers that were added.
Public property | Changed | Get the existing objects that changed.
Public property | Removed | Get the existing object identifiers that were removed.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
ININ.IceLib.Statistics.Alerts Namespace


Added Property

[image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)>..::..Added Property
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were added.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObject> Added { get; }
Visual Basic
Public ReadOnly Property Added As ReadOnlyCollection(Of TWatchedObject)
    Get

Field Value

The added objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


Changed Property

[image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)>..::..Changed Property
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class See Also Send Feedback
Get the existing objects that changed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObject> Changed { get; }
Visual Basic
Public ReadOnly Property Changed As ReadOnlyCollection(Of TWatchedObject)
    Get

Field Value

The collection of changed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


Removed Property

[image]

IceLib Technical Reference
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)>..::..Removed Property
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class See Also Send Feedback
Get the existing object identifiers that were removed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TWatchedObject> Removed { get; }
Visual Basic
Public ReadOnly Property Removed As ReadOnlyCollection(Of TWatchedObject)
    Get

Field Value

The removed objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Class
AlertCatalogChangedEventArgs<(Of <(<'TWatchedObject, TWatchedObjectPropertiesEnum>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCondition Class

[image]

IceLib Technical Reference
AlertCondition Class
Members See Also Send Feedback
Base class for alert conditions for alert rules. An alert condition defines what state will cause an alert to trigger. This, combined with the target StatisticKey is what makes up an alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class AlertCondition : IEquatable<AlertCondition>
Visual Basic
Public MustInherit Class AlertCondition _
    Implements IEquatable(Of AlertCondition)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..BoolCondition
ININ.IceLib.Statistics.Alerts..::..NumericCondition<(Of <(<'T>)>)>
ININ.IceLib.Statistics.Alerts..::..StringCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCondition Members

[image] [image]

IceLib Technical Reference
AlertCondition Members
AlertCondition Class Constructors Methods Operators Properties See Also Send Feedback

The AlertCondition type exposes the following members.

Constructors

 | Name | Description
Protected method | AlertCondition | Initializes a new instance of the AlertCondition class

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of AlertCondition are equal.
Inequality | Determines whether two instances of AlertCondition are not equal.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition.

See Also

AlertCondition Class
ININ.IceLib.Statistics.Alerts Namespace


AlertCondition Constructor

[image]

IceLib Technical Reference
AlertCondition Constructor
AlertCondition Class See Also Send Feedback
Initializes a new instance of the AlertCondition class

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected AlertCondition()
Visual Basic
Protected Sub New

See Also

AlertCondition Class
AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCondition Methods

[image] [image]

IceLib Technical Reference
AlertCondition Methods
AlertCondition Class See Also Send Feedback

The AlertCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AlertCondition..::..Equals Method
AlertCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type.

See Also

AlertCondition Class
AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AlertCondition..::..Equals Method (Object)
AlertCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertCondition Class
AlertCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
AlertCondition..::..Equals Method (AlertCondition)
AlertCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual bool Equals(
    AlertCondition other
)
Visual Basic
Public Overridable Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertCondition Class
AlertCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AlertCondition..::..GetHashCode Method
AlertCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertCondition Class
AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCondition Operators

[image] [image]

IceLib Technical Reference
AlertCondition Operators
AlertCondition Class See Also Send Feedback

The AlertCondition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of AlertCondition are equal.
Inequality | Determines whether two instances of AlertCondition are not equal.

See Also

AlertCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
AlertCondition..::..Equality Operator
AlertCondition Class See Also Send Feedback
Determines whether two instances of AlertCondition are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AlertCondition a,
    AlertCondition b
)
Visual Basic
Public Shared Operator = ( _
    a As AlertCondition, _
    b As AlertCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
The first AlertCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
The second AlertCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCondition Class
AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
AlertCondition..::..Inequality Operator
AlertCondition Class See Also Send Feedback
Determines whether two instances of AlertCondition are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AlertCondition a,
    AlertCondition b
)
Visual Basic
Public Shared Operator <> ( _
    a As AlertCondition, _
    b As AlertCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
The first AlertCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
The second AlertCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCondition Class
AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertCondition Properties

[image] [image]

IceLib Technical Reference
AlertCondition Properties
AlertCondition Class See Also Send Feedback

The AlertCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition.

See Also

AlertCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Comparison Property

[image]

IceLib Technical Reference
AlertCondition..::..Comparison Property
AlertCondition Class See Also Send Feedback
Gets the comparison mechanism to use when evaluating the AlertCondition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertConditionComparison Comparison { get; internal set; }
Visual Basic
Public Property Comparison As AlertConditionComparison
    Get
    Friend Set

Field Value

The comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertCondition Class
AlertCondition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertConditionComparison Enumeration

[image]

IceLib Technical Reference
AlertConditionComparison Enumeration
See Also Send Feedback
Mechanism to use when evaluating an AlertCondition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AlertConditionComparison
Visual Basic
Public Enumeration AlertConditionComparison

Members

Member name | Value | Description
Unknown | 0 | Represents the condition has not been specified yet.
IsNotAvailable | 1 | Repesents a condition where IsNull is trueTruetruetrue (True in Visual Basic), which indicates nullNothingnullptra null reference (Nothing in Visual Basic), or not set value.
IsAvailable | 2 | Repesents a condition where IsNull is falseFalsefalsefalse (False in Visual Basic), which indicates a valid value other than nullNothingnullptra null reference (Nothing in Visual Basic).
IsTrue | 3 | Represents a condition where the boolean value is expected to be trueTruetruetrue (True in Visual Basic).
IsFalse | 4 | Represents a condition where the boolean value is expected to be falseFalsefalsefalse (False in Visual Basic).
IsLessThan | 5 | Represents a condition where the numeric value is expected to be less than the minimum.
IsGreaterThan | 6 | Represents a condition where the numeric value is expected to be greater than the maximum.
Range | 7 | Represents a condition where the numeric value is between the lower and the upper bound (minimum and maximum).
EqualTo | 8 | Represents a condition where a StatisticValue string value is equal to the comparison value.
NotEqualTo | 9 | Represents a condition where a StatisticValue string value is not equal to the comparison value.
Contains | 10 | Represents a condition where a StatisticValue string value contains the comparison value.
DoesNotContain | 11 | Represents a condition where a StatisticValue string value does not contain the comparison value.
MatchesPrefix | 12 | Represents a condition where a StatisticValue string value matches the prefix.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Class

[image]

IceLib Technical Reference
AlertDefinition Class
Members See Also Send Feedback
Represents an alert definition. The alert definition defines a list of AlertRule objects that can be applied to a statistic key.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertDefinition
Visual Basic
Public Class AlertDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertDefinition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Members

[image] [image]

IceLib Technical Reference
AlertDefinition Members
AlertDefinition Class Constructors Methods Properties See Also Send Feedback

The AlertDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | AlertDefinition(AlertDefinition) | Initializes a new instance of the AlertDefinition class.
Public method | AlertDefinition(AlertSet, StatisticKey) | Initializes a new instance of the AlertDefinition class.

Methods

 | Name | Description
Public method | AddAlertRule | Adds an AlertRule to the AlertDefinition.
Public method | AddAlertRules | Adds the alerts.
Public method | CloneTo | Clones an AlertDefinition and associates it to the supplied EditableAlertSet.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertRule | Removes an AlertRule from the AlertDefinition.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AlertRules | Gets the alert rules.
Public property | AlertSet | Gets the alert set associated with this AlertDefinition instance.
Public property | Description | Gets the description.
Public property | DisplayString | Gets the display string.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | StatisticKey | Gets the statistic key that is defined for this AlertDefinition.

See Also

AlertDefinition Class
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Constructor

[image] [image]

IceLib Technical Reference
AlertDefinition Constructor
AlertDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlertDefinition(AlertDefinition) | Initializes a new instance of the AlertDefinition class.
Public method | AlertDefinition(AlertSet, StatisticKey) | Initializes a new instance of the AlertDefinition class.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Constructor (AlertDefinition)

[image]

IceLib Technical Reference
AlertDefinition Constructor (AlertDefinition)
AlertDefinition Class See Also Send Feedback
Initializes a new instance of the AlertDefinition class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertDefinition(
    AlertDefinition definition
)
Visual Basic
Public Sub New ( _
    definition As AlertDefinition _
)

Parameters

definition
Type: ININ.IceLib.Statistics.Alerts..::..AlertDefinition
The definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
AlertDefinition Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Constructor (AlertSet, StatisticKey)

[image]

IceLib Technical Reference
AlertDefinition Constructor (AlertSet, StatisticKey)
AlertDefinition Class See Also Send Feedback
Initializes a new instance of the AlertDefinition class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertDefinition(
    AlertSet alertSet,
    StatisticKey statisticKey
)
Visual Basic
Public Sub New ( _
    alertSet As AlertSet, _
    statisticKey As StatisticKey _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set.
statisticKey
Type: ININ.IceLib.Statistics..::..StatisticKey
The statistic key.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
AlertDefinition Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Methods

[image] [image]

IceLib Technical Reference
AlertDefinition Methods
AlertDefinition Class See Also Send Feedback

The AlertDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddAlertRule | Adds an AlertRule to the AlertDefinition.
Public method | AddAlertRules | Adds the alerts.
Public method | CloneTo | Clones an AlertDefinition and associates it to the supplied EditableAlertSet.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertRule | Removes an AlertRule from the AlertDefinition.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AlertDefinition Class
ININ.IceLib.Statistics.Alerts Namespace


AddAlertRule Method

[image]

IceLib Technical Reference
AlertDefinition..::..AddAlertRule Method
AlertDefinition Class See Also Send Feedback
Adds an AlertRule to the AlertDefinition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAlertRule(
    AlertRule rule
)
Visual Basic
Public Sub AddAlertRule ( _
    rule As AlertRule _
)

Parameters

rule
Type: ININ.IceLib.Statistics.Alerts..::..AlertRule
The rule.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinition is not editable or the AlertRule is already associated with an AlertDefinition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


AddAlertRules Method

[image]

IceLib Technical Reference
AlertDefinition..::..AddAlertRules Method
AlertDefinition Class See Also Send Feedback
Adds the alerts.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAlertRules(
    IEnumerable<AlertRule> rules
)
Visual Basic
Public Sub AddAlertRules ( _
    rules As IEnumerable(Of AlertRule) _
)

Parameters

rules
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' AlertRule >)>)>
The list of AlertRules to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinition is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


CloneTo Method

[image]

IceLib Technical Reference
AlertDefinition..::..CloneTo Method
AlertDefinition Class See Also Send Feedback
Clones an AlertDefinition and associates it to the supplied EditableAlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertDefinition CloneTo(
    EditableAlertSet alertSet
)
Visual Basic
Public Function CloneTo ( _
    alertSet As EditableAlertSet _
) As AlertDefinition

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..EditableAlertSet
The EditableAlertSet to associate.

Return Value

The cloned AlertDefinition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


RemoveAlertRule Method

[image]

IceLib Technical Reference
AlertDefinition..::..RemoveAlertRule Method
AlertDefinition Class See Also Send Feedback
Removes an AlertRule from the AlertDefinition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveAlertRule(
    AlertRule rule
)
Visual Basic
Public Sub RemoveAlertRule ( _
    rule As AlertRule _
)

Parameters

rule
Type: ININ.IceLib.Statistics.Alerts..::..AlertRule
The rule.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinition is not editable or the AlertRule is not associated with this AlertDefinition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


ToString Method

[image]

IceLib Technical Reference
AlertDefinition..::..ToString Method
AlertDefinition Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Properties

[image] [image]

IceLib Technical Reference
AlertDefinition Properties
AlertDefinition Class See Also Send Feedback

The AlertDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AlertRules | Gets the alert rules.
Public property | AlertSet | Gets the alert set associated with this AlertDefinition instance.
Public property | Description | Gets the description.
Public property | DisplayString | Gets the display string.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | StatisticKey | Gets the statistic key that is defined for this AlertDefinition.

See Also

AlertDefinition Class
ININ.IceLib.Statistics.Alerts Namespace


AlertRules Property

[image]

IceLib Technical Reference
AlertDefinition..::..AlertRules Property
AlertDefinition Class See Also Send Feedback
Gets the alert rules.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertRule> AlertRules { get; }
Visual Basic
Public ReadOnly Property AlertRules As ReadOnlyCollection(Of AlertRule)
    Get

Field Value

The alert rules.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSet Property

[image]

IceLib Technical Reference
AlertDefinition..::..AlertSet Property
AlertDefinition Class See Also Send Feedback
Gets the alert set associated with this AlertDefinition instance.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSet AlertSet { get; internal set; }
Visual Basic
Public Property AlertSet As AlertSet
    Get
    Friend Set

Field Value

The alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


Description Property

[image]

IceLib Technical Reference
AlertDefinition..::..Description Property
AlertDefinition Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Field Value

The description.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinition is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


DisplayString Property

[image]

IceLib Technical Reference
AlertDefinition..::..DisplayString Property
AlertDefinition Class See Also Send Feedback
Gets the display string.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; set; }
Visual Basic
Public Property DisplayString As String
    Get
    Set

Field Value

The display name.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinition is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


IsEditable Property

[image]

IceLib Technical Reference
AlertDefinition..::..IsEditable Property
AlertDefinition Class See Also Send Feedback
Gets a value indicating whether this instance is editable.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; internal set; }
Visual Basic
Public Property IsEditable As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


StatisticKey Property

[image]

IceLib Technical Reference
AlertDefinition..::..StatisticKey Property
AlertDefinition Class See Also Send Feedback
Gets the statistic key that is defined for this AlertDefinition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticKey StatisticKey { get; set; }
Visual Basic
Public Property StatisticKey As StatisticKey
    Get
    Set

Field Value

The statistic key.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinition is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertDefinition Class
AlertDefinition Members
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Class

[image]

IceLib Technical Reference
AlertFilterKey Class
Members See Also Send Feedback
Represents a unique key based on the alert set and target ID.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertFilterKey : IEquatable<AlertFilterKey>
Visual Basic
Public Class AlertFilterKey _
    Implements IEquatable(Of AlertFilterKey)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertFilterKey

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Members

[image] [image]

IceLib Technical Reference
AlertFilterKey Members
AlertFilterKey Class Constructors Methods Operators Properties See Also Send Feedback

The AlertFilterKey type exposes the following members.

Constructors

 | Name | Description
Public method | AlertFilterKey(AlertSet) | Initializes a new instance of the AlertFilterKey class.
Public method | AlertFilterKey(AlertSet, String) | Initializes a new instance of the AlertFilterKey class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertFilterKey) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Properties

 | Name | Description
Public property | AlertSet | Gets the alert set.
Public property | TargetId | Gets the target ID.

See Also

AlertFilterKey Class
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Constructor

[image] [image]

IceLib Technical Reference
AlertFilterKey Constructor
AlertFilterKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlertFilterKey(AlertSet) | Initializes a new instance of the AlertFilterKey class.
Public method | AlertFilterKey(AlertSet, String) | Initializes a new instance of the AlertFilterKey class.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Constructor (AlertSet)

[image]

IceLib Technical Reference
AlertFilterKey Constructor (AlertSet)
AlertFilterKey Class See Also Send Feedback
Initializes a new instance of the AlertFilterKey class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertFilterKey(
    AlertSet alertSet
)
Visual Basic
Public Sub New ( _
    alertSet As AlertSet _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set.

Remarks

AlertFilterKey objects created with this constructor will have a TargetId that is Empty. In order to receive alert notifications, the alert must have been created with the same value, which in this case would be Empty (see TargetId).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 5 and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
AlertFilterKey Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Constructor (AlertSet, String)

[image]

IceLib Technical Reference
AlertFilterKey Constructor (AlertSet, String)
AlertFilterKey Class See Also Send Feedback
Initializes a new instance of the AlertFilterKey class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertFilterKey(
    AlertSet alertSet,
    string targetId
)
Visual Basic
Public Sub New ( _
    alertSet As AlertSet, _
    targetId As String _
)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set.
targetId
Type: System..::..String
The target ID.

Remarks

Well known target IDs are defined in AlertActionTargets. In order to receive alert notifications, the alert must have been created with the same value as targetId (see TargetId).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
AlertFilterKey Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Methods

[image] [image]

IceLib Technical Reference
AlertFilterKey Methods
AlertFilterKey Class See Also Send Feedback

The AlertFilterKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertFilterKey) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AlertFilterKey Class
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AlertFilterKey..::..Equals Method
AlertFilterKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertFilterKey) | Indicates whether the current object is equal to another object of the same type.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AlertFilterKey..::..Equals Method (Object)
AlertFilterKey Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object otherValue
)
Visual Basic
Public Overrides Function Equals ( _
    otherValue As Object _
) As Boolean

Parameters

otherValue
Type: System..::..Object

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertFilterKey)

[image]

IceLib Technical Reference
AlertFilterKey..::..Equals Method (AlertFilterKey)
AlertFilterKey Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AlertFilterKey otherValue
)
Visual Basic
Public Function Equals ( _
    otherValue As AlertFilterKey _
) As Boolean

Parameters

otherValue
Type: ININ.IceLib.Statistics.Alerts..::..AlertFilterKey
An object to compare with this object.

Return Value

trueTruetruetrue (True in Visual Basic) if the current object is equal to the other parameter; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AlertFilterKey..::..GetHashCode Method
AlertFilterKey Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


ToString Method

[image]

IceLib Technical Reference
AlertFilterKey..::..ToString Method
AlertFilterKey Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Operators

[image] [image]

IceLib Technical Reference
AlertFilterKey Operators
AlertFilterKey Class See Also Send Feedback

The AlertFilterKey type exposes the following members.

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

See Also

AlertFilterKey Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
AlertFilterKey..::..Equality Operator
AlertFilterKey Class See Also Send Feedback
Implements the operator ==.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    AlertFilterKey a,
    AlertFilterKey b
)
Visual Basic
Public Shared Operator = ( _
    a As AlertFilterKey, _
    b As AlertFilterKey _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..AlertFilterKey
A.
b
Type: ININ.IceLib.Statistics.Alerts..::..AlertFilterKey
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
AlertFilterKey..::..Inequality Operator
AlertFilterKey Class See Also Send Feedback
Implements the operator !=.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    AlertFilterKey a,
    AlertFilterKey b
)
Visual Basic
Public Shared Operator <> ( _
    a As AlertFilterKey, _
    b As AlertFilterKey _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..AlertFilterKey
A.
b
Type: ININ.IceLib.Statistics.Alerts..::..AlertFilterKey
The b.

Return Value

The result of the operator.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


AlertFilterKey Properties

[image] [image]

IceLib Technical Reference
AlertFilterKey Properties
AlertFilterKey Class See Also Send Feedback

The AlertFilterKey type exposes the following members.

Properties

 | Name | Description
Public property | AlertSet | Gets the alert set.
Public property | TargetId | Gets the target ID.

See Also

AlertFilterKey Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSet Property

[image]

IceLib Technical Reference
AlertFilterKey..::..AlertSet Property
AlertFilterKey Class See Also Send Feedback
Gets the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSet AlertSet { get; }
Visual Basic
Public ReadOnly Property AlertSet As AlertSet
    Get

Field Value

The alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


TargetId Property

[image]

IceLib Technical Reference
AlertFilterKey..::..TargetId Property
AlertFilterKey Class See Also Send Feedback
Gets the target ID.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TargetId { get; }
Visual Basic
Public ReadOnly Property TargetId As String
    Get

Field Value

The target ID.

Remarks

Well known target IDs are defined in AlertActionTargets.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertFilterKey Class
AlertFilterKey Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListener Class

[image]

IceLib Technical Reference
AlertListener Class
Members See Also Send Feedback
Represents a class to enable listening for alert notifications. Alert notifications are events that get sent down when an alert enters or exits the alerted state.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertListener
Visual Basic
Public Class AlertListener

Remarks

Note
For more information on getting started with statistics see Getting Started With Statistics.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertListener

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListener Members

[image] [image]

IceLib Technical Reference
AlertListener Members
AlertListener Class Constructors Methods Events See Also Send Feedback

The AlertListener type exposes the following members.

Constructors

 | Name | Description
Public method | AlertListener | Initializes a new instance of the AlertListener class.

Methods

 | Name | Description
Public method | ChangeWatchedAlerts | Synchronous request to change the watched alert filters.
Public method | ChangeWatchedAlertsAsync | Asynchronous request to change the watched alert filters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlertNotifications(AlertSet) | Gets the available alert notifications for an AlertSet.
Public method | GetAlertNotifications(StatisticKey) | Gets the alert notifications for a StatisticKey.
Public method | GetFilterKeys | Gets the watched Alert Filter Keys.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Synchronous request to start watching alert filters.
Public method | StartWatchingAsync | Asynchronous request to start watching alert filters.
Public method | StopWatching | Synchronous request to stop watching alert filters.
Public method | StopWatchingAsync | Asynchronous request to stop watching alert filters.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | AlertChanged | Occurs as a result of catalog change on an alert we are listening too.
Public event | AlertReceived | Occurs when the listener receives alert notifications.

See Also

AlertListener Class
ININ.IceLib.Statistics.Alerts Namespace


AlertListener Constructor

[image]

IceLib Technical Reference
AlertListener Constructor
AlertListener Class See Also Send Feedback
Initializes a new instance of the AlertListener class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertListener(
    StatisticsManager statisticsManager
)
Visual Basic
Public Sub New ( _
    statisticsManager As StatisticsManager _
)

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListener Methods

[image] [image]

IceLib Technical Reference
AlertListener Methods
AlertListener Class See Also Send Feedback

The AlertListener type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAlerts | Synchronous request to change the watched alert filters.
Public method | ChangeWatchedAlertsAsync | Asynchronous request to change the watched alert filters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlertNotifications(AlertSet) | Gets the available alert notifications for an AlertSet.
Public method | GetAlertNotifications(StatisticKey) | Gets the alert notifications for a StatisticKey.
Public method | GetFilterKeys | Gets the watched Alert Filter Keys.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether this instance is watching.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Synchronous request to start watching alert filters.
Public method | StartWatchingAsync | Asynchronous request to start watching alert filters.
Public method | StopWatching | Synchronous request to stop watching alert filters.
Public method | StopWatchingAsync | Asynchronous request to stop watching alert filters.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertListener Class
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatchedAlerts Method

[image]

IceLib Technical Reference
AlertListener..::..ChangeWatchedAlerts Method
AlertListener Class See Also Send Feedback
Synchronous request to change the watched alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAlerts(
    AlertFilterKey[] keysToAdd,
    AlertFilterKey[] keysToRemove,
    bool replaceExisting,
    AlertListenerFilter filter
)
Visual Basic
Public Sub ChangeWatchedAlerts ( _
    keysToAdd As AlertFilterKey(), _
    keysToRemove As AlertFilterKey(), _
    replaceExisting As Boolean, _
    filter As AlertListenerFilter _
)

Parameters

keysToAdd
Type: array< ININ.IceLib.Statistics.Alerts..::..AlertFilterKey >[]()[][]
The keys of the alert filters to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
keysToRemove
Type: array< ININ.IceLib.Statistics.Alerts..::..AlertFilterKey >[]()[][]
The keys of the alert filters to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
filter
Type: ININ.IceLib.Statistics.Alerts..::..AlertListenerFilter
The filter to apply to the AlertChanged event.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This AlertListener is not watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


ChangeWatchedAlertsAsync Method

[image]

IceLib Technical Reference
AlertListener..::..ChangeWatchedAlertsAsync Method
AlertListener Class See Also Send Feedback
Asynchronous request to change the watched alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ChangeWatchedAlertsAsync(
    AlertFilterKey[] keysToAdd,
    AlertFilterKey[] keysToRemove,
    bool replaceExisting,
    AlertListenerFilter filter,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ChangeWatchedAlertsAsync ( _
    keysToAdd As AlertFilterKey(), _
    keysToRemove As AlertFilterKey(), _
    replaceExisting As Boolean, _
    filter As AlertListenerFilter, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

keysToAdd
Type: array< ININ.IceLib.Statistics.Alerts..::..AlertFilterKey >[]()[][]
The keys of the alert filters to add. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
keysToRemove
Type: array< ININ.IceLib.Statistics.Alerts..::..AlertFilterKey >[]()[][]
The keys of the alert filters to remove. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
replaceExisting
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic), replace the existing list.
filter
Type: ININ.IceLib.Statistics.Alerts..::..AlertListenerFilter
The filter to apply to the AlertChanged event.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This AlertListener is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


GetAlertNotifications Method

[image] [image]

IceLib Technical Reference
AlertListener..::..GetAlertNotifications Method
AlertListener Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAlertNotifications(AlertSet) | Gets the available alert notifications for an AlertSet.
Public method | GetAlertNotifications(StatisticKey) | Gets the alert notifications for a StatisticKey.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


GetAlertNotifications Method (AlertSet)

[image]

IceLib Technical Reference
AlertListener..::..GetAlertNotifications Method (AlertSet)
AlertListener Class See Also Send Feedback
Gets the available alert notifications for an AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertNotification> GetAlertNotifications(
    AlertSet alertSet
)
Visual Basic
Public Function GetAlertNotifications ( _
    alertSet As AlertSet _
) As ReadOnlyCollection(Of AlertNotification)

Parameters

alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The AlertSet to get available alert notifications for.

Return Value

A read-only collection of available alert notifications.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception occurred.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
GetAlertNotifications Overload
ININ.IceLib.Statistics.Alerts Namespace


GetAlertNotifications Method (StatisticKey)

[image]

IceLib Technical Reference
AlertListener..::..GetAlertNotifications Method (StatisticKey)
AlertListener Class See Also Send Feedback
Gets the alert notifications for a StatisticKey.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertNotification> GetAlertNotifications(
    StatisticKey statisticKey
)
Visual Basic
Public Function GetAlertNotifications ( _
    statisticKey As StatisticKey _
) As ReadOnlyCollection(Of AlertNotification)

Parameters

statisticKey
Type: ININ.IceLib.Statistics..::..StatisticKey
The StatisticKey to get available alert notifications for.

Return Value

A read-only collection of available alert notifications.

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception occurred.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
GetAlertNotifications Overload
ININ.IceLib.Statistics.Alerts Namespace


GetFilterKeys Method

[image]

IceLib Technical Reference
AlertListener..::..GetFilterKeys Method
AlertListener Class See Also Send Feedback
Gets the watched Alert Filter Keys.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertFilterKey> GetFilterKeys()
Visual Basic
Public Function GetFilterKeys As ReadOnlyCollection(Of AlertFilterKey)

Return Value

A read-only collection of the Alert Filter Keys that are being watched.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertListener is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


IsWatching Method

[image]

IceLib Technical Reference
AlertListener..::..IsWatching Method
AlertListener Class See Also Send Feedback
Determines whether this instance is watching.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if this instance is watching; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..Exception | An unexpected exception occurred.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatching Method

[image]

IceLib Technical Reference
AlertListener..::..StartWatching Method
AlertListener Class See Also Send Feedback
Synchronous request to start watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching(
    AlertFilterKey[] keysToAdd,
    AlertListenerFilter filter
)
Visual Basic
Public Sub StartWatching ( _
    keysToAdd As AlertFilterKey(), _
    filter As AlertListenerFilter _
)

Parameters

keysToAdd
Type: array< ININ.IceLib.Statistics.Alerts..::..AlertFilterKey >[]()[][]
The keys of the alert filters to start watching.
filter
Type: ININ.IceLib.Statistics.Alerts..::..AlertListenerFilter
The filter to apply to the AlertChanged event.

Remarks

Starting an alert listener watch will allow AlertReceived events to trigger when the state of an alert changes, either into or out of alert and for AlertChanged events to trigger when an alert catalog change occurs on an alert we're interested in.
Note
All event handlers should be added before calling StartWatching(array<AlertFilterKey>[]()[][], AlertListenerFilter) or StartWatchingAsync(array<AlertFilterKey>[]()[][], AlertListenerFilter, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | keysToAdd is nullNothingnullptra null reference (Nothing in Visual Basic) or contains an element that is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | keysToAdd is empty.
System..::..ArgumentOutOfRangeException | filter has an invalid value.
System..::..InvalidOperationException | The watch is already watching.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
AlertListener..::..StartWatchingAsync Method
AlertListener Class See Also Send Feedback
Asynchronous request to start watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AlertFilterKey[] keysToAdd,
    AlertListenerFilter filter,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    keysToAdd As AlertFilterKey(), _
    filter As AlertListenerFilter, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

keysToAdd
Type: array< ININ.IceLib.Statistics.Alerts..::..AlertFilterKey >[]()[][]
The keys of the alert filters to start watching.
filter
Type: ININ.IceLib.Statistics.Alerts..::..AlertListenerFilter
The filter to apply to the AlertChanged event.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Starting an alert listener watch will allow AlertReceived events to trigger when the state of an alert changes, either into or out of alert and for AlertChanged events to trigger when an alert catalog change occurs on an alert we're interested in.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching(array<AlertFilterKey>[]()[][], AlertListenerFilter) or StartWatchingAsync(array<AlertFilterKey>[]()[][], AlertListenerFilter, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | keysToAdd is nullNothingnullptra null reference (Nothing in Visual Basic) or contains an element that is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | keysToAdd is empty.
System..::..InvalidOperationException | The watch is already watching.
System..::..ArgumentOutOfRangeException | filter has an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatching Method

[image]

IceLib Technical Reference
AlertListener..::..StopWatching Method
AlertListener Class See Also Send Feedback
Synchronous request to stop watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This AlertListener is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
AlertListener..::..StopWatchingAsync Method
AlertListener Class See Also Send Feedback
Asynchronous request to stop watching alert filters.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This AlertListener is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListener Events

[image] [image]

IceLib Technical Reference
AlertListener Events
AlertListener Class See Also Send Feedback

The AlertListener type exposes the following members.

Events

 | Name | Description
Public event | AlertChanged | Occurs as a result of catalog change on an alert we are listening too.
Public event | AlertReceived | Occurs when the listener receives alert notifications.

See Also

AlertListener Class
ININ.IceLib.Statistics.Alerts Namespace


AlertChanged Event

[image]

IceLib Technical Reference
AlertListener..::..AlertChanged Event
AlertListener Class See Also Send Feedback
Occurs as a result of catalog change on an alert we are listening too.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AlertListenerChangedEventArgs> AlertChanged
Visual Basic
Public Event AlertChanged As EventHandler(Of AlertListenerChangedEventArgs)

Remarks

A watch must be active to receive alerts, use StartWatching(array<AlertFilterKey>[]()[][], AlertListenerFilter) to start a watch. The catalog changes are filter by the AlertListenerFilter that is provided during the start watch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


AlertReceived Event

[image]

IceLib Technical Reference
AlertListener..::..AlertReceived Event
AlertListener Class See Also Send Feedback
Occurs when the listener receives alert notifications.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AlertNotificationEventArgs> AlertReceived
Visual Basic
Public Event AlertReceived As EventHandler(Of AlertNotificationEventArgs)

Remarks

This event will only occur when alert notifications are received. To start watching for alerts call either the StartWatching(array<AlertFilterKey>[]()[][], AlertListenerFilter) method or the StartWatchingAsync(array<AlertFilterKey>[]()[][], AlertListenerFilter, AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching(array<AlertFilterKey>[]()[][], AlertListenerFilter) or StartWatchingAsync(array<AlertFilterKey>[]()[][], AlertListenerFilter, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListener Class
AlertListener Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListenerChangedEventArgs Class

[image]

IceLib Technical Reference
AlertListenerChangedEventArgs Class
Members See Also Send Feedback
Provides data for the AlertChanged event.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertListenerChangedEventArgs : EventArgs
Visual Basic
Public Class AlertListenerChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics.Alerts..::..AlertListenerChangedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListenerChangedEventArgs Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListenerChangedEventArgs Members

[image] [image]

IceLib Technical Reference
AlertListenerChangedEventArgs Members
AlertListenerChangedEventArgs Class Methods Properties See Also Send Feedback

The AlertListenerChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Changes | Gets the read only collection of rules that have just changed that affects the AlertListener and what has changed on the rules.

See Also

AlertListenerChangedEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


AlertListenerChangedEventArgs Methods

[image] [image]

IceLib Technical Reference
AlertListenerChangedEventArgs Methods
AlertListenerChangedEventArgs Class See Also Send Feedback

The AlertListenerChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertListenerChangedEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


AlertListenerChangedEventArgs Properties

[image] [image]

IceLib Technical Reference
AlertListenerChangedEventArgs Properties
AlertListenerChangedEventArgs Class See Also Send Feedback

The AlertListenerChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Changes | Gets the read only collection of rules that have just changed that affects the AlertListener and what has changed on the rules.

See Also

AlertListenerChangedEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


Changes Property

[image]

IceLib Technical Reference
AlertListenerChangedEventArgs..::..Changes Property
AlertListenerChangedEventArgs Class See Also Send Feedback
Gets the read only collection of rules that have just changed that affects the AlertListener and what has changed on the rules.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertRuleDelta> Changes { get; }
Visual Basic
Public ReadOnly Property Changes As ReadOnlyCollection(Of AlertRuleDelta)
    Get

Field Value

The changed rules.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertListenerChangedEventArgs Class
AlertListenerChangedEventArgs Members
ININ.IceLib.Statistics.Alerts Namespace


AlertListenerFilter Enumeration

[image]

IceLib Technical Reference
AlertListenerFilter Enumeration
See Also Send Feedback
Filters AlertChanged events based on what changed in the corresponding AlertRule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum AlertListenerFilter
Visual Basic
<FlagsAttribute> _
Public Enumeration AlertListenerFilter

Members

Member name | Value | Description
None | 0 | No alert rule changes should be sent.
Severity | 1 | Send events if the severity of an alert rule changes.
Condition | 2 | Send events if a condition on the alert rule changes.
Action | 4 | Send events if an action on the alert rule changes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertNotification Class

[image]

IceLib Technical Reference
AlertNotification Class
Members See Also Send Feedback
Represents the data sent for a given alert. The alert notification contains the data that about what alert has changed state, its new state and value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertNotification
Visual Basic
Public Class AlertNotification

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertNotification

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


AlertNotification Members

[image] [image]

IceLib Technical Reference
AlertNotification Members
AlertNotification Class Methods Properties See Also Send Feedback

The AlertNotification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alert | Gets the alert definition.
Public property | Cleared | Gets a value indicating whether this AlertNotification is cleared.
Public property | ExpandedStatisticDefinitionId | Gets the expanded statistic definition id. If not expandable, this will be an empty string.
Public property | Received | Gets the received time.
Public property | Rule | Gets the rule the alert was raised on.
Public property | Value | Gets the value.

See Also

AlertNotification Class
ININ.IceLib.Statistics.Alerts Namespace


AlertNotification Methods

[image] [image]

IceLib Technical Reference
AlertNotification Methods
AlertNotification Class See Also Send Feedback

The AlertNotification type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertNotification Class
ININ.IceLib.Statistics.Alerts Namespace


AlertNotification Properties

[image] [image]

IceLib Technical Reference
AlertNotification Properties
AlertNotification Class See Also Send Feedback

The AlertNotification type exposes the following members.

Properties

 | Name | Description
Public property | Alert | Gets the alert definition.
Public property | Cleared | Gets a value indicating whether this AlertNotification is cleared.
Public property | ExpandedStatisticDefinitionId | Gets the expanded statistic definition id. If not expandable, this will be an empty string.
Public property | Received | Gets the received time.
Public property | Rule | Gets the rule the alert was raised on.
Public property | Value | Gets the value.

See Also

AlertNotification Class
ININ.IceLib.Statistics.Alerts Namespace


Alert Property

[image]

IceLib Technical Reference
AlertNotification..::..Alert Property
AlertNotification Class See Also Send Feedback
Gets the alert definition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertDefinition Alert { get; }
Visual Basic
Public ReadOnly Property Alert As AlertDefinition
    Get

Field Value

The alert definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Class
AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


Cleared Property

[image]

IceLib Technical Reference
AlertNotification..::..Cleared Property
AlertNotification Class See Also Send Feedback
Gets a value indicating whether this AlertNotification is cleared.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Cleared { get; internal set; }
Visual Basic
Public Property Cleared As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if cleared; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Class
AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


ExpandedStatisticDefinitionId Property

[image]

IceLib Technical Reference
AlertNotification..::..ExpandedStatisticDefinitionId Property
AlertNotification Class See Also Send Feedback
Gets the expanded statistic definition id. If not expandable, this will be an empty string.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExpandedStatisticDefinitionId { get; internal set; }
Visual Basic
Public Property ExpandedStatisticDefinitionId As String
    Get
    Friend Set

Field Value

The expanded statistic definition id.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Class
AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


Received Property

[image]

IceLib Technical Reference
AlertNotification..::..Received Property
AlertNotification Class See Also Send Feedback
Gets the received time.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Received { get; internal set; }
Visual Basic
Public Property Received As DateTime
    Get
    Friend Set

Field Value

The received time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Class
AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


Rule Property

[image]

IceLib Technical Reference
AlertNotification..::..Rule Property
AlertNotification Class See Also Send Feedback
Gets the rule the alert was raised on.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRule Rule { get; }
Visual Basic
Public ReadOnly Property Rule As AlertRule
    Get

Field Value

The alert range.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Class
AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


Value Property

[image]

IceLib Technical Reference
AlertNotification..::..Value Property
AlertNotification Class See Also Send Feedback
Gets the value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public StatisticValue Value { get; }
Visual Basic
Public ReadOnly Property Value As StatisticValue
    Get

Field Value

The value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotification Class
AlertNotification Members
ININ.IceLib.Statistics.Alerts Namespace


AlertNotificationEventArgs Class

[image]

IceLib Technical Reference
AlertNotificationEventArgs Class
Members See Also Send Feedback
Provides data for the AlertReceived event.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertNotificationEventArgs : EventArgs
Visual Basic
Public Class AlertNotificationEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics.Alerts..::..AlertNotificationEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotificationEventArgs Members
ININ.IceLib.Statistics.Alerts Namespace


AlertNotificationEventArgs Members

[image] [image]

IceLib Technical Reference
AlertNotificationEventArgs Members
AlertNotificationEventArgs Class Methods Properties See Also Send Feedback

The AlertNotificationEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlertNotifications | Gets the read-only collection of alert notifications.

See Also

AlertNotificationEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


AlertNotificationEventArgs Methods

[image] [image]

IceLib Technical Reference
AlertNotificationEventArgs Methods
AlertNotificationEventArgs Class See Also Send Feedback

The AlertNotificationEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertNotificationEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


AlertNotificationEventArgs Properties

[image] [image]

IceLib Technical Reference
AlertNotificationEventArgs Properties
AlertNotificationEventArgs Class See Also Send Feedback

The AlertNotificationEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AlertNotifications | Gets the read-only collection of alert notifications.

See Also

AlertNotificationEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


AlertNotifications Property

[image]

IceLib Technical Reference
AlertNotificationEventArgs..::..AlertNotifications Property
AlertNotificationEventArgs Class See Also Send Feedback
Gets the read-only collection of alert notifications.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertNotification> AlertNotifications { get; }
Visual Basic
Public ReadOnly Property AlertNotifications As ReadOnlyCollection(Of AlertNotification)
    Get

Field Value

The alert notifications.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertNotificationEventArgs Class
AlertNotificationEventArgs Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Class

[image]

IceLib Technical Reference
AlertRule Class
Members See Also Send Feedback
An alert rule is defined by a circumstance (AlertCondition) that triggers the rule and the set of outcomes (AlertAction) that occur when the rule is triggered. A collection of alert rules make up an AlertDefinition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertRule : IEqualityComparer<AlertRule>
Visual Basic
Public Class AlertRule _
    Implements IEqualityComparer(Of AlertRule)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertRule

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Members

[image] [image]

IceLib Technical Reference
AlertRule Members
AlertRule Class Constructors Methods Properties See Also Send Feedback

The AlertRule type exposes the following members.

Constructors

 | Name | Description
Public method | AlertRule(AlertRule) | Initializes a new instance of the AlertRule class as a clone of another instance.
Public method | AlertRule(AlertDefinition, AlertSeverity) | Initializes a new instance of the AlertRule class.

Methods

 | Name | Description
Public method | AddAlertAction | Adds an AlertAction to this AlertRule.
Public method | CloneTo | Clones an AlertRule and associates it to the supplied AlertDefinition.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertRule, AlertRule) | Determines whether the specified objects are equal.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(AlertRule) | Returns a hash code for the specified object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertAction | Removes an AlertAction from this AlertRule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlertActions | Gets the actions.
Public property | AlertDefinition | Gets the alert definition that is associated with this alert range.
Public property | AlertSeverity | Gets the alert severity.
Public property | Condition | Gets the condition.
Public property | Id | Gets the ID for the AlertRule.
Public property | IsEditable | Gets a value indicating whether this instance is editable.

See Also

AlertRule Class
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Constructor

[image] [image]

IceLib Technical Reference
AlertRule Constructor
AlertRule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlertRule(AlertRule) | Initializes a new instance of the AlertRule class as a clone of another instance.
Public method | AlertRule(AlertDefinition, AlertSeverity) | Initializes a new instance of the AlertRule class.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Constructor (AlertRule)

[image]

IceLib Technical Reference
AlertRule Constructor (AlertRule)
AlertRule Class See Also Send Feedback
Initializes a new instance of the AlertRule class as a clone of another instance.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRule(
    AlertRule alertRule
)
Visual Basic
Public Sub New ( _
    alertRule As AlertRule _
)

Parameters

alertRule
Type: ININ.IceLib.Statistics.Alerts..::..AlertRule
The AlertRule to clone.

Remarks

This constructor can be used to clone an existing AlertRule for editing.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The AlertRule to clone is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
AlertRule Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Constructor (AlertDefinition, AlertSeverity)

[image]

IceLib Technical Reference
AlertRule Constructor (AlertDefinition, AlertSeverity)
AlertRule Class See Also Send Feedback
Initializes a new instance of the AlertRule class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRule(
    AlertDefinition alertDefinition,
    AlertSeverity alertSeverity
)
Visual Basic
Public Sub New ( _
    alertDefinition As AlertDefinition, _
    alertSeverity As AlertSeverity _
)

Parameters

alertDefinition
Type: ININ.IceLib.Statistics.Alerts..::..AlertDefinition
The alert definition.
alertSeverity
Type: ININ.IceLib.Statistics.Alerts..::..AlertSeverity
The alert severity.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
AlertRule Overload
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Methods

[image] [image]

IceLib Technical Reference
AlertRule Methods
AlertRule Class See Also Send Feedback

The AlertRule type exposes the following members.

Methods

 | Name | Description
Public method | AddAlertAction | Adds an AlertAction to this AlertRule.
Public method | CloneTo | Clones an AlertRule and associates it to the supplied AlertDefinition.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertRule, AlertRule) | Determines whether the specified objects are equal.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(AlertRule) | Returns a hash code for the specified object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertAction | Removes an AlertAction from this AlertRule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertRule Class
ININ.IceLib.Statistics.Alerts Namespace


AddAlertAction Method

[image]

IceLib Technical Reference
AlertRule..::..AddAlertAction Method
AlertRule Class See Also Send Feedback
Adds an AlertAction to this AlertRule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAlertAction(
    AlertAction action
)
Visual Basic
Public Sub AddAlertAction ( _
    action As AlertAction _
)

Parameters

action
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The action to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertRule is not editable, or the AlertAction is already associated with another AlertRule.
System..::..ArgumentNullException | action is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


CloneTo Method

[image]

IceLib Technical Reference
AlertRule..::..CloneTo Method
AlertRule Class See Also Send Feedback
Clones an AlertRule and associates it to the supplied AlertDefinition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRule CloneTo(
    AlertDefinition alertDefinition
)
Visual Basic
Public Function CloneTo ( _
    alertDefinition As AlertDefinition _
) As AlertRule

Parameters

alertDefinition
Type: ININ.IceLib.Statistics.Alerts..::..AlertDefinition
The AlertDefinition to associate.

Return Value

The cloned AlertRule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AlertRule..::..Equals Method
AlertRule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(AlertRule, AlertRule) | Determines whether the specified objects are equal.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
AlertRule..::..Equals Method (Object)
AlertRule Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertRule, AlertRule)

[image]

IceLib Technical Reference
AlertRule..::..Equals Method (AlertRule, AlertRule)
AlertRule Class See Also Send Feedback
Determines whether the specified objects are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AlertRule x,
    AlertRule y
)
Visual Basic
Public Function Equals ( _
    x As AlertRule, _
    y As AlertRule _
) As Boolean

Parameters

x
Type: ININ.IceLib.Statistics.Alerts..::..AlertRule
The first object of type T to compare.
y
Type: ININ.IceLib.Statistics.Alerts..::..AlertRule
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(<'T>)>)>..::..Equals(T, T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image] [image]

IceLib Technical Reference
AlertRule..::..GetHashCode Method
AlertRule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(AlertRule) | Returns a hash code for the specified object.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AlertRule..::..GetHashCode Method
AlertRule Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
GetHashCode Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method (AlertRule)

[image]

IceLib Technical Reference
AlertRule..::..GetHashCode Method (AlertRule)
AlertRule Class See Also Send Feedback
Returns a hash code for the specified object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int GetHashCode(
    AlertRule obj
)
Visual Basic
Public Function GetHashCode ( _
    obj As AlertRule _
) As Integer

Parameters

obj
Type: ININ.IceLib.Statistics.Alerts..::..AlertRule
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<(Of <(<'T>)>)>..::..GetHashCode(T)

Exceptions

Exception | Condition
System..::..ArgumentNullException | The type of obj is a reference type and obj is null.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
GetHashCode Overload
ININ.IceLib.Statistics.Alerts Namespace


RemoveAlertAction Method

[image]

IceLib Technical Reference
AlertRule..::..RemoveAlertAction Method
AlertRule Class See Also Send Feedback
Removes an AlertAction from this AlertRule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveAlertAction(
    AlertAction action
)
Visual Basic
Public Sub RemoveAlertAction ( _
    action As AlertAction _
)

Parameters

action
Type: ININ.IceLib.Statistics.Alerts..::..AlertAction
The action.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertRule is not editable.
System..::..ArgumentNullException | action is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRule Properties

[image] [image]

IceLib Technical Reference
AlertRule Properties
AlertRule Class See Also Send Feedback

The AlertRule type exposes the following members.

Properties

 | Name | Description
Public property | AlertActions | Gets the actions.
Public property | AlertDefinition | Gets the alert definition that is associated with this alert range.
Public property | AlertSeverity | Gets the alert severity.
Public property | Condition | Gets the condition.
Public property | Id | Gets the ID for the AlertRule.
Public property | IsEditable | Gets a value indicating whether this instance is editable.

See Also

AlertRule Class
ININ.IceLib.Statistics.Alerts Namespace


AlertActions Property

[image]

IceLib Technical Reference
AlertRule..::..AlertActions Property
AlertRule Class See Also Send Feedback
Gets the actions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertAction> AlertActions { get; }
Visual Basic
Public ReadOnly Property AlertActions As ReadOnlyCollection(Of AlertAction)
    Get

Field Value

The actions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinition Property

[image]

IceLib Technical Reference
AlertRule..::..AlertDefinition Property
AlertRule Class See Also Send Feedback
Gets the alert definition that is associated with this alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertDefinition AlertDefinition { get; internal set; }
Visual Basic
Public Property AlertDefinition As AlertDefinition
    Get
    Friend Set

Field Value

The alert definition.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSeverity Property

[image]

IceLib Technical Reference
AlertRule..::..AlertSeverity Property
AlertRule Class See Also Send Feedback
Gets the alert severity.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSeverity AlertSeverity { get; set; }
Visual Basic
Public Property AlertSeverity As AlertSeverity
    Get
    Set

Field Value

The alert severity.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The instance is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


Condition Property

[image]

IceLib Technical Reference
AlertRule..::..Condition Property
AlertRule Class See Also Send Feedback
Gets the condition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertCondition Condition { get; set; }
Visual Basic
Public Property Condition As AlertCondition
    Get
    Set

Field Value

The condition.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertRule is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


Id Property

[image]

IceLib Technical Reference
AlertRule..::..Id Property
AlertRule Class See Also Send Feedback
Gets the ID for the AlertRule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; internal set; }
Visual Basic
Public Property Id As String
    Get
    Friend Set

Field Value

The ID of the AlertRule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


IsEditable Property

[image]

IceLib Technical Reference
AlertRule..::..IsEditable Property
AlertRule Class See Also Send Feedback
Gets a value indicating whether this instance is editable.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; internal set; }
Visual Basic
Public Property IsEditable As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRule Class
AlertRule Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRuleChange Enumeration

[image]

IceLib Technical Reference
AlertRuleChange Enumeration
See Also Send Feedback
Track what has changed about a rule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum AlertRuleChange
Visual Basic
<FlagsAttribute> _
Public Enumeration AlertRuleChange

Members

Member name | Value | Description
None | 0 | No change.
New | 1 | This is a new rule.
Removed | 2 | This rule has been removed.
ChangeSeverity | 4 | Severity has changed.
ChangeCondition | 8 | Condition has changed.
ChangeAction | 16 | An action has changed.
ChangeOther | 1073741824 | A non-tracked change has been made.
ChangeAll | 1073741852 | Everything has changed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertRuleDelta Class

[image]

IceLib Technical Reference
AlertRuleDelta Class
Members See Also Send Feedback
Represents a change to an alert rule during an AlertCatalogChanged event. Contains a list of all AlertAction objects that have been added or removed as well as what properties have changed on the AlertRule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertRuleDelta
Visual Basic
Public Class AlertRuleDelta

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertRuleDelta

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRuleDelta Members
ININ.IceLib.Statistics.Alerts Namespace


AlertRuleDelta Members

[image] [image]

IceLib Technical Reference
AlertRuleDelta Members
AlertRuleDelta Class Methods Properties See Also Send Feedback

The AlertRuleDelta type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddedActions | Gets the read only collection of added actions.
Public property | Changes | Gets the flags determining what has changed.
Public property | RemovedActions | Gets the read only collection of removed actions.
Public property | Rule | Gets the rule that has changed.

See Also

AlertRuleDelta Class
ININ.IceLib.Statistics.Alerts Namespace


AlertRuleDelta Methods

[image] [image]

IceLib Technical Reference
AlertRuleDelta Methods
AlertRuleDelta Class See Also Send Feedback

The AlertRuleDelta type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertRuleDelta Class
ININ.IceLib.Statistics.Alerts Namespace


AlertRuleDelta Properties

[image] [image]

IceLib Technical Reference
AlertRuleDelta Properties
AlertRuleDelta Class See Also Send Feedback

The AlertRuleDelta type exposes the following members.

Properties

 | Name | Description
Public property | AddedActions | Gets the read only collection of added actions.
Public property | Changes | Gets the flags determining what has changed.
Public property | RemovedActions | Gets the read only collection of removed actions.
Public property | Rule | Gets the rule that has changed.

See Also

AlertRuleDelta Class
ININ.IceLib.Statistics.Alerts Namespace


AddedActions Property

[image]

IceLib Technical Reference
AlertRuleDelta..::..AddedActions Property
AlertRuleDelta Class See Also Send Feedback
Gets the read only collection of added actions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertAction> AddedActions { get; }
Visual Basic
Public ReadOnly Property AddedActions As ReadOnlyCollection(Of AlertAction)
    Get

Field Value

The added actions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRuleDelta Class
AlertRuleDelta Members
ININ.IceLib.Statistics.Alerts Namespace


Changes Property

[image]

IceLib Technical Reference
AlertRuleDelta..::..Changes Property
AlertRuleDelta Class See Also Send Feedback
Gets the flags determining what has changed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRuleChange Changes { get; }
Visual Basic
Public ReadOnly Property Changes As AlertRuleChange
    Get

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRuleDelta Class
AlertRuleDelta Members
ININ.IceLib.Statistics.Alerts Namespace


RemovedActions Property

[image]

IceLib Technical Reference
AlertRuleDelta..::..RemovedActions Property
AlertRuleDelta Class See Also Send Feedback
Gets the read only collection of removed actions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertAction> RemovedActions { get; }
Visual Basic
Public ReadOnly Property RemovedActions As ReadOnlyCollection(Of AlertAction)
    Get

Field Value

The removed actions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRuleDelta Class
AlertRuleDelta Members
ININ.IceLib.Statistics.Alerts Namespace


Rule Property

[image]

IceLib Technical Reference
AlertRuleDelta..::..Rule Property
AlertRuleDelta Class See Also Send Feedback
Gets the rule that has changed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertRule Rule { get; }
Visual Basic
Public ReadOnly Property Rule As AlertRule
    Get

Field Value

The rule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertRuleDelta Class
AlertRuleDelta Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSet Class

[image]

IceLib Technical Reference
AlertSet Class
Members See Also Send Feedback
Represents a set of AlertDefinition objects. An alert set contains a group of alerts (AlertDefinition as well as information about the overall alert set. Use AlertCatalog to manage alert sets.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertSet : IEquatable<AlertSet>,
    IComparable
Visual Basic
Public Class AlertSet _
    Implements IEquatable(Of AlertSet), IComparable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertSet
ININ.IceLib.Statistics.Alerts..::..EditableAlertSet

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSet Members

[image] [image]

IceLib Technical Reference
AlertSet Members
AlertSet Class Methods Properties See Also Send Feedback

The AlertSet type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(AlertSet) | Compares this instance to the specified other.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubscribedBy | Determines if a AlertSetSubscriberType is subscribed to this AlertSet.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessMode | Gets the access mode.
Public property | AlertDefinitions | Gets the alerts.
Protected property | AlertMap | Gets the alert map.
Public property | AlertSetSubscribers | Gets the subscribers for this AlertSet.
Public property | Created | Date and time the alert set was created.
Public property | Description | Gets the description.
Public property | DisplayString | Gets the display string.
Public property | Id | Gets the ID.
Public property | Modified | Date and time the alert set was modified.
Public property | ModifiedBy | Gets the name of the user who last modified this AlertSet.
Public property | Owner | Gets the owner.
Public property | OwnerDisplayName | Gets the display name of the owner.
Public property | SubscribedByOther | Gets a value indicating whether the AlertSet is subscribed to by users other than the current user.
Public property | SubscribedByOwner | Gets whether or not this AlertSet is subscribed to by the Owner.
Public property | SubscribedByUser | Gets a value indicating whether the AlertSet is subscribed to by the current user.

See Also

AlertSet Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSet Methods

[image] [image]

IceLib Technical Reference
AlertSet Methods
AlertSet Class See Also Send Feedback

The AlertSet type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(AlertSet) | Compares this instance to the specified other.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubscribedBy | Determines if a AlertSetSubscriberType is subscribed to this AlertSet.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertSet Class
ININ.IceLib.Statistics.Alerts Namespace


CompareTo Method

[image]

IceLib Technical Reference
AlertSet..::..CompareTo Method
AlertSet Class See Also Send Feedback
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer

Parameters

obj
Type: System..::..Object
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparable..::..CompareTo(Object)

Exceptions

Exception | Condition
System..::..ArgumentException | obj is not the same type as this instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
AlertSet..::..Equals Method
AlertSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(AlertSet) | Compares this instance to the specified other.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertSet)

[image]

IceLib Technical Reference
AlertSet..::..Equals Method (AlertSet)
AlertSet Class See Also Send Feedback
Compares this instance to the specified other.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    AlertSet other
)
Visual Basic
Public Function Equals ( _
    other As AlertSet _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The other instance to compare to.

Return Value

if equal, otherwise.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
AlertSet..::..GetHashCode Method
AlertSet Class See Also Send Feedback
Returns a hash code for this instance.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


IsSubscribedBy Method

[image]

IceLib Technical Reference
AlertSet..::..IsSubscribedBy Method
AlertSet Class See Also Send Feedback
Determines if a AlertSetSubscriberType is subscribed to this AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsSubscribedBy(
    string id,
    AlertSetSubscriberType type
)
Visual Basic
Public Function IsSubscribedBy ( _
    id As String, _
    type As AlertSetSubscriberType _
) As Boolean

Parameters

id
Type: System..::..String
The ID.
type
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetSubscriberType
The AlertSetSubscriberType.

Return Value

trueTruetruetrue (True in Visual Basic) if the AlertSetSubscriberType is subcribed, otherwise falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscribers property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSet Properties

[image] [image]

IceLib Technical Reference
AlertSet Properties
AlertSet Class See Also Send Feedback

The AlertSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessMode | Gets the access mode.
Public property | AlertDefinitions | Gets the alerts.
Protected property | AlertMap | Gets the alert map.
Public property | AlertSetSubscribers | Gets the subscribers for this AlertSet.
Public property | Created | Date and time the alert set was created.
Public property | Description | Gets the description.
Public property | DisplayString | Gets the display string.
Public property | Id | Gets the ID.
Public property | Modified | Date and time the alert set was modified.
Public property | ModifiedBy | Gets the name of the user who last modified this AlertSet.
Public property | Owner | Gets the owner.
Public property | OwnerDisplayName | Gets the display name of the owner.
Public property | SubscribedByOther | Gets a value indicating whether the AlertSet is subscribed to by users other than the current user.
Public property | SubscribedByOwner | Gets whether or not this AlertSet is subscribed to by the Owner.
Public property | SubscribedByUser | Gets a value indicating whether the AlertSet is subscribed to by the current user.

See Also

AlertSet Class
ININ.IceLib.Statistics.Alerts Namespace


AccessMode Property

[image]

IceLib Technical Reference
AlertSet..::..AccessMode Property
AlertSet Class See Also Send Feedback
Gets the access mode.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSetAccessMode AccessMode { get; protected internal set; }
Visual Basic
Public Property AccessMode As AlertSetAccessMode
    Get
    Protected Friend Set

Field Value

The access mode.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AccessMode property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AlertDefinitions Property

[image]

IceLib Technical Reference
AlertSet..::..AlertDefinitions Property
AlertSet Class See Also Send Feedback
Gets the alerts.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertDefinition> AlertDefinitions { get; }
Visual Basic
Public ReadOnly Property AlertDefinitions As ReadOnlyCollection(Of AlertDefinition)
    Get

Field Value

The alerts.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertDefinitions property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AlertMap Property

[image]

IceLib Technical Reference
AlertSet..::..AlertMap Property
AlertSet Class See Also Send Feedback
Gets the alert map.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected internal Dictionary<StatisticKey, AlertDefinition> AlertMap { get; }
Visual Basic
Protected Friend ReadOnly Property AlertMap As Dictionary(Of StatisticKey, AlertDefinition)
    Get

Field Value

The alert map.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscribers Property

[image]

IceLib Technical Reference
AlertSet..::..AlertSetSubscribers Property
AlertSet Class See Also Send Feedback
Gets the subscribers for this AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AlertSetSubscriber> AlertSetSubscribers { get; }
Visual Basic
Public ReadOnly Property AlertSetSubscribers As ReadOnlyCollection(Of AlertSetSubscriber)
    Get

Field Value

The collection of AlertSetSubscribers.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscribers property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Created Property

[image]

IceLib Technical Reference
AlertSet..::..Created Property
AlertSet Class See Also Send Feedback
Date and time the alert set was created.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Created { get; protected internal set; }
Visual Basic
Public Property Created As DateTime
    Get
    Protected Friend Set

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Created property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Description Property

[image]

IceLib Technical Reference
AlertSet..::..Description Property
AlertSet Class See Also Send Feedback
Gets the description.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; protected internal set; }
Visual Basic
Public Property Description As String
    Get
    Protected Friend Set

Field Value

The description.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Description property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


DisplayString Property

[image]

IceLib Technical Reference
AlertSet..::..DisplayString Property
AlertSet Class See Also Send Feedback
Gets the display string.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; protected internal set; }
Visual Basic
Public Property DisplayString As String
    Get
    Protected Friend Set

Field Value

The display string.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The DisplayString property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Id Property

[image]

IceLib Technical Reference
AlertSet..::..Id Property
AlertSet Class See Also Send Feedback
Gets the ID.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ID property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Modified Property

[image]

IceLib Technical Reference
AlertSet..::..Modified Property
AlertSet Class See Also Send Feedback
Date and time the alert set was modified.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Modified { get; protected internal set; }
Visual Basic
Public Property Modified As DateTime
    Get
    Protected Friend Set

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Modified property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


ModifiedBy Property

[image]

IceLib Technical Reference
AlertSet..::..ModifiedBy Property
AlertSet Class See Also Send Feedback
Gets the name of the user who last modified this AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ModifiedBy { get; protected internal set; }
Visual Basic
Public Property ModifiedBy As String
    Get
    Protected Friend Set

Field Value

User who last modified this AlertSet.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The ModifiedBy property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Owner Property

[image]

IceLib Technical Reference
AlertSet..::..Owner Property
AlertSet Class See Also Send Feedback
Gets the owner.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Owner { get; protected internal set; }
Visual Basic
Public Property Owner As String
    Get
    Protected Friend Set

Field Value

The owner.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The Owner property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


OwnerDisplayName Property

[image]

IceLib Technical Reference
AlertSet..::..OwnerDisplayName Property
AlertSet Class See Also Send Feedback
Gets the display name of the owner.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerDisplayName { get; protected internal set; }
Visual Basic
Public Property OwnerDisplayName As String
    Get
    Protected Friend Set

Field Value

The display name of the owner.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The OwnerDisplayName property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


SubscribedByOther Property

[image]

IceLib Technical Reference
AlertSet..::..SubscribedByOther Property
AlertSet Class See Also Send Feedback
Gets a value indicating whether the AlertSet is subscribed to by users other than the current user.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SubscribedByOther { get; internal set; }
Visual Basic
Public Property SubscribedByOther As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if subscribed to by others; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The SubscribedByOther property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


SubscribedByOwner Property

[image]

IceLib Technical Reference
AlertSet..::..SubscribedByOwner Property
AlertSet Class See Also Send Feedback
Gets whether or not this AlertSet is subscribed to by the Owner.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SubscribedByOwner { get; }
Visual Basic
Public ReadOnly Property SubscribedByOwner As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if subscribed, otherwise falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscribers property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


SubscribedByUser Property

[image]

IceLib Technical Reference
AlertSet..::..SubscribedByUser Property
AlertSet Class See Also Send Feedback
Gets a value indicating whether the AlertSet is subscribed to by the current user.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SubscribedByUser { get; internal set; }
Visual Basic
Public Property SubscribedByUser As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if subscribed to by the current user; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | The SubscribedByUser property is not watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

AlertSet Class
AlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSet.Property Enumeration

[image]

IceLib Technical Reference
AlertSet..::..Property Enumeration
AlertSet Class See Also Send Feedback
Specifies constants indicating what properties this object supports.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
AccessMode | 0 | The AccessMode.
AlertDefinitions | 1 | The alert definitions.
Created | 2 | The timestamp of when the AlertSet was created.
Description | 3 | The Description.
DisplayString | 4 | The DisplayString.
Id | 5 | The ID of the AlertSet.
Modified | 6 | The Modified time.
ModifiedBy | 7 | The user responsible for the most recent modification.
Owner | 8 | The Owner.
OwnerDisplayName | 9 | The Display Name of the Owner.
SubscribedByOther | 10 | Flag used to indicate if the AlertSet is subscribed to by anyone other than the current user.
SubscribedByUser | 11 | Flag used to indicate if the AlertSet is subscribed to by the current user.
AlertSetSubscribers | 12 | The subscribers to this AlertSet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertSetAccessMode Enumeration

[image]

IceLib Technical Reference
AlertSetAccessMode Enumeration
See Also Send Feedback
Defines the access mode for an alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public enum AlertSetAccessMode
Visual Basic
<SerializableAttribute> _
Public Enumeration AlertSetAccessMode

Members

Member name | Value | Description
None | 0 | Access mode has not been set.
OwnerDefault | 1 | Access to the owner's default alert set.
Owned | 2 | Access as an owned alert set.
Shared | 3 | Other users may access and subscribe to the alert set in a read-only manner.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertSetCategories Enumeration

[image]

IceLib Technical Reference
AlertSetCategories Enumeration
See Also Send Feedback
The category of an AlertSet within the AlertCatalog.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum AlertSetCategories
Visual Basic
<FlagsAttribute> _
Public Enumeration AlertSetCategories

Members

Member name | Value | Description
Unknown | 0 | The category of the AlertSet is unknown.
Shared | 1 | AlertSet instances that are shared.
Owned | 2 | AlertSet instances that are owned by the current user.
Subscribed | 4 | AlertSet instances that are subscribed to by the current user.
OwnerDefault | 8 | The default AlertSet for the current user.
AdminAccess | 16 | Alert set instances that administrators have access to. Must have the Alert Administrator right set in Interaction Administrator.
All | 31 | All AlertSet instances within the AlertCatalog.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriber Class

[image]

IceLib Technical Reference
AlertSetSubscriber Class
Members See Also Send Feedback
Represents a subscriber to an AlertSet. An alert set subscriber contains information about a subscriber's subscription status in relation to an AlertSet

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AlertSetSubscriber
Visual Basic
Public Class AlertSetSubscriber

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertSetSubscriber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriber Members

[image] [image]

IceLib Technical Reference
AlertSetSubscriber Members
AlertSetSubscriber Class Constructors Methods Properties See Also Send Feedback

The AlertSetSubscriber type exposes the following members.

Constructors

 | Name | Description
Public method | AlertSetSubscriber | Initializes a new instance of the AlertSetSubscriber class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets or sets the Action.
Public property | Id | Gets or sets the ID.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | IsSubscribed | Gets a value indicating whether or not this AlertSetSubscriber is subscribed.
Public property | IsSubscriptionForced | Gets a value indicating whether or not this AlertSetSubscriber's subscription is forced.
Public property | Type | Gets or sets the Type.

See Also

AlertSetSubscriber Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriber Constructor

[image]

IceLib Technical Reference
AlertSetSubscriber Constructor
AlertSetSubscriber Class See Also Send Feedback
Initializes a new instance of the AlertSetSubscriber class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSetSubscriber(
    string id,
    AlertSetSubscriberType type,
    AlertSetSubscriberAction action,
    bool isSubscribed,
    bool isSubscriptionForced
)
Visual Basic
Public Sub New ( _
    id As String, _
    type As AlertSetSubscriberType, _
    action As AlertSetSubscriberAction, _
    isSubscribed As Boolean, _
    isSubscriptionForced As Boolean _
)

Parameters

id
Type: System..::..String
The ID of the subscriber.
type
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetSubscriberType
The type of the subscriber. Role is currently not supported.
action
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetSubscriberAction
The action to perform on the subscriber.
isSubscribed
Type: System..::..Boolean
Whether the subscriber is subscribed (trueTruetruetrue (True in Visual Basic)) or not (falseFalsefalsefalse (False in Visual Basic)).
isSubscriptionForced
Type: System..::..Boolean
Whether the subscription is forced (trueTruetruetrue (True in Visual Basic)) or not (falseFalsefalsefalse (False in Visual Basic)).

Exceptions

Exception | Condition
System..::..ArgumentNullException | id is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | type is not a valid value for enum type AlertSetSubscriberType.
System..::..ArgumentException | action is not a valid value for enum type AlertSetSubscriberAction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriber Methods

[image] [image]

IceLib Technical Reference
AlertSetSubscriber Methods
AlertSetSubscriber Class See Also Send Feedback

The AlertSetSubscriber type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlertSetSubscriber Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriber Properties

[image] [image]

IceLib Technical Reference
AlertSetSubscriber Properties
AlertSetSubscriber Class See Also Send Feedback

The AlertSetSubscriber type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets or sets the Action.
Public property | Id | Gets or sets the ID.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | IsSubscribed | Gets a value indicating whether or not this AlertSetSubscriber is subscribed.
Public property | IsSubscriptionForced | Gets a value indicating whether or not this AlertSetSubscriber's subscription is forced.
Public property | Type | Gets or sets the Type.

See Also

AlertSetSubscriber Class
ININ.IceLib.Statistics.Alerts Namespace


Action Property

[image]

IceLib Technical Reference
AlertSetSubscriber..::..Action Property
AlertSetSubscriber Class See Also Send Feedback
Gets or sets the Action.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSetSubscriberAction Action { get; set; }
Visual Basic
Public Property Action As AlertSetSubscriberAction
    Get
    Set

Field Value

The AlertSetSubscriberAction.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


Id Property

[image]

IceLib Technical Reference
AlertSetSubscriber..::..Id Property
AlertSetSubscriber Class See Also Send Feedback
Gets or sets the ID.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


IsEditable Property

[image]

IceLib Technical Reference
AlertSetSubscriber..::..IsEditable Property
AlertSetSubscriber Class See Also Send Feedback
Gets a value indicating whether this instance is editable.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; internal set; }
Visual Basic
Public Property IsEditable As Boolean
    Get
    Friend Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


IsSubscribed Property

[image]

IceLib Technical Reference
AlertSetSubscriber..::..IsSubscribed Property
AlertSetSubscriber Class See Also Send Feedback
Gets a value indicating whether or not this AlertSetSubscriber is subscribed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsSubscribed { get; set; }
Visual Basic
Public Property IsSubscribed As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this AlertSetSubscriber is subscribed; otherwise, falseFalsefalsefalse (False in Visual Basic)

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


IsSubscriptionForced Property

[image]

IceLib Technical Reference
AlertSetSubscriber..::..IsSubscriptionForced Property
AlertSetSubscriber Class See Also Send Feedback
Gets a value indicating whether or not this AlertSetSubscriber's subscription is forced.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsSubscriptionForced { get; set; }
Visual Basic
Public Property IsSubscriptionForced As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this AlertSetSubscriber's subscription is forced; otherwise, falseFalsefalsefalse (False in Visual Basic)

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


Type Property

[image]

IceLib Technical Reference
AlertSetSubscriber..::..Type Property
AlertSetSubscriber Class See Also Send Feedback
Gets or sets the Type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSetSubscriberType Type { get; set; }
Visual Basic
Public Property Type As AlertSetSubscriberType
    Get
    Set

Field Value

The AlertSetSubscriberType.

Remarks

Role is currently not supported.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The AlertSetSubscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

AlertSetSubscriber Class
AlertSetSubscriber Members
ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriberAction Enumeration

[image]

IceLib Technical Reference
AlertSetSubscriberAction Enumeration
See Also Send Feedback
Defines the action to perform on a AlertSetSubscriber in relation to an AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public enum AlertSetSubscriberAction
Visual Basic
<SerializableAttribute> _
Public Enumeration AlertSetSubscriberAction

Members

Member name | Value | Description
Unknown | 0 | Action has not been set.
Add | 1 | Add a subscriber.
Remove | 2 | Remove a subscriber.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertSetSubscriberType Enumeration

[image]

IceLib Technical Reference
AlertSetSubscriberType Enumeration
See Also Send Feedback
Associates the _Id with a type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public enum AlertSetSubscriberType
Visual Basic
<SerializableAttribute> _
Public Enumeration AlertSetSubscriberType

Members

Member name | Value | Description
Unknown | 0 | Type has not been set.
User | 1 | Subscriber is of type user.
Workgroup | 2 | Subscriber is of type workgroup.
Role | 3 | Subscriber is of type role.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


AlertSeverity Enumeration

[image]

IceLib Technical Reference
AlertSeverity Enumeration
See Also Send Feedback
Represents an alert level for an AlertRule.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public enum AlertSeverity
Visual Basic
<SerializableAttribute> _
Public Enumeration AlertSeverity

Members

Member name | Value | Description
None | 0 | Alert severity is not set.
Normal | 1 | The status of the resource is normal.
Minor | 2 | An alert level that indicates a problem of relatively low severity that should not impede use of the resource.
Major | 3 | An alert level that indicates some kind of possibly service-affecting problem with the resource. The severity of the problem is relatively high and normal use of the resource is likely to be impaired.
Warning | 4 | An alert level that indicates a condition exists that could potentially cause a problem with the resource.
Critical | 5 | An alert level that indicates a severe problem exists with the resource and normal use is disrupted or severely impeded. This is the most severe alarm level.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


BoolCondition Class

[image]

IceLib Technical Reference
BoolCondition Class
Members See Also Send Feedback
Represents a boolean alert condition. This condition can be used on boolean statistics to trigger if the value is true or false, or if the statistics is or is not available. To create a new BoolCondition use one of the static Create functions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class BoolCondition : AlertCondition
Visual Basic
Public Class BoolCondition _
    Inherits AlertCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..BoolCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

BoolCondition Members
ININ.IceLib.Statistics.Alerts Namespace


BoolCondition Members

[image] [image]

IceLib Technical Reference
BoolCondition Members
BoolCondition Class Methods Properties See Also Send Feedback

The BoolCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a bool alert.
 | CreateIsFalseCondition | Creates an IsFalse condition for a bool alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a bool alert.
 | CreateIsTrueCondition | Creates an IsTrue condition for a bool alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertCondition.)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertCondition.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)

See Also

BoolCondition Class
ININ.IceLib.Statistics.Alerts Namespace


BoolCondition Methods

[image] [image]

IceLib Technical Reference
BoolCondition Methods
BoolCondition Class See Also Send Feedback

The BoolCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a bool alert.
 | CreateIsFalseCondition | Creates an IsFalse condition for a bool alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a bool alert.
 | CreateIsTrueCondition | Creates an IsTrue condition for a bool alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertCondition.)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertCondition.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoolCondition Class
ININ.IceLib.Statistics.Alerts Namespace


CreateIsAvailableCondition Method

[image]

IceLib Technical Reference
BoolCondition..::..CreateIsAvailableCondition Method
BoolCondition Class See Also Send Feedback
Creates an IsAvailable condition for a bool alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static BoolCondition CreateIsAvailableCondition()
Visual Basic
Public Shared Function CreateIsAvailableCondition As BoolCondition

Return Value

An instance of a BoolCondition triggering on an IsAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

BoolCondition Class
BoolCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsFalseCondition Method

[image]

IceLib Technical Reference
BoolCondition..::..CreateIsFalseCondition Method
BoolCondition Class See Also Send Feedback
Creates an IsFalse condition for a bool alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static BoolCondition CreateIsFalseCondition()
Visual Basic
Public Shared Function CreateIsFalseCondition As BoolCondition

Return Value

An instance of a BoolCondition triggering on an IsFalse comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

BoolCondition Class
BoolCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsNotAvailableCondition Method

[image]

IceLib Technical Reference
BoolCondition..::..CreateIsNotAvailableCondition Method
BoolCondition Class See Also Send Feedback
Creates an IsNotAvailable condition for a bool alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static BoolCondition CreateIsNotAvailableCondition()
Visual Basic
Public Shared Function CreateIsNotAvailableCondition As BoolCondition

Return Value

An instance of a BoolCondition triggering on an IsNotAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

BoolCondition Class
BoolCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsTrueCondition Method

[image]

IceLib Technical Reference
BoolCondition..::..CreateIsTrueCondition Method
BoolCondition Class See Also Send Feedback
Creates an IsTrue condition for a bool alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static BoolCondition CreateIsTrueCondition()
Visual Basic
Public Shared Function CreateIsTrueCondition As BoolCondition

Return Value

An instance of a BoolCondition triggering on an IsTrue comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

BoolCondition Class
BoolCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
BoolCondition..::..Equals Method
BoolCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertCondition.)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)

See Also

BoolCondition Class
BoolCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
BoolCondition..::..Equals Method (AlertCondition)
BoolCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    AlertCondition other
)
Visual Basic
Public Overrides Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

BoolCondition Class
BoolCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


BoolCondition Properties

[image] [image]

IceLib Technical Reference
BoolCondition Properties
BoolCondition Class See Also Send Feedback

The BoolCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)

See Also

BoolCondition Class
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Class

[image]

IceLib Technical Reference
ClientMemoAlertAction Class
Members See Also Send Feedback
Alert action for a client memo target. A client memo alert action defines a client memo that will be sent out when an alert is triggered.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ClientMemoAlertAction : AlertAction
Visual Basic
Public Class ClientMemoAlertAction _
    Inherits AlertAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertAction
ININ.IceLib.Statistics.Alerts..::..ClientMemoAlertAction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Members

[image] [image]

IceLib Technical Reference
ClientMemoAlertAction Members
ClientMemoAlertAction Class Constructors Methods Properties See Also Send Feedback

The ClientMemoAlertAction type exposes the following members.

Constructors

 | Name | Description
Public method | ClientMemoAlertAction()()()() | Initializes a new instance of the ClientMemoAlertAction class.
Public method | ClientMemoAlertAction(ClientMemoAlertAction) | Initializes a new instance of the ClientMemoAlertAction class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertAction.)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertAction.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction. (Inherited from AlertAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMessageId | Sets the message ID for this object.
Public method | SetValue | Sets the value for the associated property name. (Inherited from AlertAction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name. (Inherited from AlertAction.)

Properties

 | Name | Description
Public property | ActionId | Gets the action ID. (Inherited from AlertAction.)
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in. (Inherited from AlertAction.)
Public property | AlertSetId | Gets the ID of the alert set.
Public property | CanExpire | Gets a value indicating if the message can expire.
Public property | CreatedOn | Gets the time that the ClientMemoAlertAction was created.
Public property | DisplayUrl | Gets a value indicating whether to display a URL.
Public property | Expiration | Gets the time that the ClientMemoAlertAction will expire.
Public property | IconFile | Gets the icon file.
Public property | IsEditable | Gets a value indicating whether this instance is editable. (Inherited from AlertAction.)
Public property | MessageId | Gets the ID of the message.
Public property | MessageName | Gets the name of the message.
Public property | MessageText | Gets the message text.
Public property | PlaySound | Gets a value indicating whether to play a sound.
Public property | PopupType | Gets whether or not this is a pop-up type.
Public property | Recipients | Gets the list of recipients.
Public property | SenderDisplayName | Gets the display name of the sender.
Public property | SenderId | Gets the ID of the sender.
Public property | SendToAlertSetSubscribers | Gets a value indicating whether to send the memo to all the subscribers of the AlertSet.
Public property | ShowIcon | Gets a value indicating whether to show an icon.
Public property | SoundFile | Gets the sound file.
Public property | TargetId | Gets the target ID. Who the alert action is destined for. (Inherited from AlertAction.)
Public property | Url | Gets the URL.

See Also

ClientMemoAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Constructor

[image] [image]

IceLib Technical Reference
ClientMemoAlertAction Constructor
ClientMemoAlertAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClientMemoAlertAction()()()() | Initializes a new instance of the ClientMemoAlertAction class.
Public method | ClientMemoAlertAction(ClientMemoAlertAction) | Initializes a new instance of the ClientMemoAlertAction class.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Constructor

[image]

IceLib Technical Reference
ClientMemoAlertAction Constructor
ClientMemoAlertAction Class See Also Send Feedback
Initializes a new instance of the ClientMemoAlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ClientMemoAlertAction()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ClientMemoAlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Constructor (ClientMemoAlertAction)

[image]

IceLib Technical Reference
ClientMemoAlertAction Constructor (ClientMemoAlertAction)
ClientMemoAlertAction Class See Also Send Feedback
Initializes a new instance of the ClientMemoAlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ClientMemoAlertAction(
    ClientMemoAlertAction action
)
Visual Basic
Public Sub New ( _
    action As ClientMemoAlertAction _
)

Parameters

action
Type: ININ.IceLib.Statistics.Alerts..::..ClientMemoAlertAction
The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ClientMemoAlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Methods

[image] [image]

IceLib Technical Reference
ClientMemoAlertAction Methods
ClientMemoAlertAction Class See Also Send Feedback

The ClientMemoAlertAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertAction.)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertAction.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction. (Inherited from AlertAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMessageId | Sets the message ID for this object.
Public method | SetValue | Sets the value for the associated property name. (Inherited from AlertAction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name. (Inherited from AlertAction.)

See Also

ClientMemoAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


SetMessageId Method

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..SetMessageId Method
ClientMemoAlertAction Class See Also Send Feedback
Sets the message ID for this object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMessageId(
    Memo memo
)
Visual Basic
Public Sub SetMessageId ( _
    memo As Memo _
)

Parameters

memo
Type: ININ.IceLib.Statistics.Alerts..::..Memo
The memo to use for this alert action.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


ClientMemoAlertAction Properties

[image] [image]

IceLib Technical Reference
ClientMemoAlertAction Properties
ClientMemoAlertAction Class See Also Send Feedback

The ClientMemoAlertAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionId | Gets the action ID. (Inherited from AlertAction.)
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in. (Inherited from AlertAction.)
Public property | AlertSetId | Gets the ID of the alert set.
Public property | CanExpire | Gets a value indicating if the message can expire.
Public property | CreatedOn | Gets the time that the ClientMemoAlertAction was created.
Public property | DisplayUrl | Gets a value indicating whether to display a URL.
Public property | Expiration | Gets the time that the ClientMemoAlertAction will expire.
Public property | IconFile | Gets the icon file.
Public property | IsEditable | Gets a value indicating whether this instance is editable. (Inherited from AlertAction.)
Public property | MessageId | Gets the ID of the message.
Public property | MessageName | Gets the name of the message.
Public property | MessageText | Gets the message text.
Public property | PlaySound | Gets a value indicating whether to play a sound.
Public property | PopupType | Gets whether or not this is a pop-up type.
Public property | Recipients | Gets the list of recipients.
Public property | SenderDisplayName | Gets the display name of the sender.
Public property | SenderId | Gets the ID of the sender.
Public property | SendToAlertSetSubscribers | Gets a value indicating whether to send the memo to all the subscribers of the AlertSet.
Public property | ShowIcon | Gets a value indicating whether to show an icon.
Public property | SoundFile | Gets the sound file.
Public property | TargetId | Gets the target ID. Who the alert action is destined for. (Inherited from AlertAction.)
Public property | Url | Gets the URL.

See Also

ClientMemoAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSetId Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..AlertSetId Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the ID of the alert set.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AlertSetId { get; }
Visual Basic
Public ReadOnly Property AlertSetId As String
    Get

Field Value

The ID of the alert set.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


CanExpire Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..CanExpire Property
ClientMemoAlertAction Class See Also Send Feedback
Gets a value indicating if the message can expire.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanExpire { get; }
Visual Basic
Public ReadOnly Property CanExpire As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can expire; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


CreatedOn Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..CreatedOn Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the time that the ClientMemoAlertAction was created.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime CreatedOn { get; }
Visual Basic
Public ReadOnly Property CreatedOn As DateTime
    Get

Field Value

The created on time.

Remarks

The time is expressed in local time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


DisplayUrl Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..DisplayUrl Property
ClientMemoAlertAction Class See Also Send Feedback
Gets a value indicating whether to display a URL.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool DisplayUrl { get; }
Visual Basic
Public ReadOnly Property DisplayUrl As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if a URL is to be displayed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


Expiration Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..Expiration Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the time that the ClientMemoAlertAction will expire.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Expiration { get; }
Visual Basic
Public ReadOnly Property Expiration As DateTime
    Get

Field Value

The expiration.

Remarks

The time is expressed in local time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


IconFile Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..IconFile Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the icon file.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IconFile { get; }
Visual Basic
Public ReadOnly Property IconFile As String
    Get

Field Value

The icon file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


MessageId Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..MessageId Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the ID of the message.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageId { get; }
Visual Basic
Public ReadOnly Property MessageId As String
    Get

Field Value

The ID of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


MessageName Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..MessageName Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the name of the message.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageName { get; }
Visual Basic
Public ReadOnly Property MessageName As String
    Get

Field Value

The name of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


MessageText Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..MessageText Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the message text.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageText { get; }
Visual Basic
Public ReadOnly Property MessageText As String
    Get

Field Value

The message text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


PlaySound Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..PlaySound Property
ClientMemoAlertAction Class See Also Send Feedback
Gets a value indicating whether to play a sound.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PlaySound { get; }
Visual Basic
Public ReadOnly Property PlaySound As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if a sound is to be played; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


PopupType Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..PopupType Property
ClientMemoAlertAction Class See Also Send Feedback
Gets whether or not this is a pop-up type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PopupType { get; }
Visual Basic
Public ReadOnly Property PopupType As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this is a popup type; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


Recipients Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..Recipients Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the list of recipients.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<MemoRecipient> Recipients { get; }
Visual Basic
Public ReadOnly Property Recipients As ReadOnlyCollection(Of MemoRecipient)
    Get

Field Value

List of recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SenderDisplayName Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..SenderDisplayName Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the display name of the sender.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SenderDisplayName { get; }
Visual Basic
Public ReadOnly Property SenderDisplayName As String
    Get

Field Value

The display name of the sender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SenderId Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..SenderId Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the ID of the sender.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SenderId { get; }
Visual Basic
Public ReadOnly Property SenderId As String
    Get

Field Value

The ID of the sender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SendToAlertSetSubscribers Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..SendToAlertSetSubscribers Property
ClientMemoAlertAction Class See Also Send Feedback
Gets a value indicating whether to send the memo to all the subscribers of the AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendToAlertSetSubscribers { get; }
Visual Basic
Public ReadOnly Property SendToAlertSetSubscribers As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the memo is to be sent to all AlertSet subscribers; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


ShowIcon Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..ShowIcon Property
ClientMemoAlertAction Class See Also Send Feedback
Gets a value indicating whether to show an icon.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ShowIcon { get; }
Visual Basic
Public ReadOnly Property ShowIcon As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if an icon is to be shown; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SoundFile Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..SoundFile Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the sound file.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SoundFile { get; }
Visual Basic
Public ReadOnly Property SoundFile As String
    Get

Field Value

The sound file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


Url Property

[image]

IceLib Technical Reference
ClientMemoAlertAction..::..Url Property
ClientMemoAlertAction Class See Also Send Feedback
Gets the URL.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Url { get; }
Visual Basic
Public ReadOnly Property Url As String
    Get

Field Value

The URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ClientMemoAlertAction Class
ClientMemoAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Class

[image]

IceLib Technical Reference
CustomHandlerAlertAction Class
Members See Also Send Feedback
Alert action for a custom handler target. A custom handler alert action defines a custom handler that will be run when an alert is triggered.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CustomHandlerAlertAction : AlertAction
Visual Basic
Public Class CustomHandlerAlertAction _
    Inherits AlertAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertAction
ININ.IceLib.Statistics.Alerts..::..CustomHandlerAlertAction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Members

[image] [image]

IceLib Technical Reference
CustomHandlerAlertAction Members
CustomHandlerAlertAction Class Constructors Methods Properties See Also Send Feedback

The CustomHandlerAlertAction type exposes the following members.

Constructors

 | Name | Description
Public method | CustomHandlerAlertAction()()()() | Initializes a new instance of the CustomHandlerAlertAction class.
Public method | CustomHandlerAlertAction(CustomHandlerAlertAction) | Initializes a new instance of the CustomHandlerAlertAction class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertAction.)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertAction.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction. (Inherited from AlertAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value for the associated property name. (Inherited from AlertAction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name. (Inherited from AlertAction.)

Properties

 | Name | Description
Public property | ActionId | Gets the action ID. (Inherited from AlertAction.)
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in. (Inherited from AlertAction.)
Public property | HandlerName | Gets the handler name.
Public property | InitiateHandlerOnChangeWithinRange | Gets a value indicating whether to initiate a handler on a change within the alert range.
Public property | InitiateHandlerOnEnteringRange | Gets a value indicating whether to initiate a handler on entering the alert range.
Public property | InitiateHandlerOnExitingRange | Gets a value indicating whether to initiate a handler on exiting the alert range.
Public property | InitiateHandlerOnObservedValueChange | Gets a value indicating whether to initiate a handler on an observed value change the alert range.
Public property | IsEditable | Gets a value indicating whether this instance is editable. (Inherited from AlertAction.)
Public property | TargetId | Gets the target ID. Who the alert action is destined for. (Inherited from AlertAction.)
Public property | UserData | Gets the user data to pass to the handler.

See Also

CustomHandlerAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Constructor

[image] [image]

IceLib Technical Reference
CustomHandlerAlertAction Constructor
CustomHandlerAlertAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomHandlerAlertAction()()()() | Initializes a new instance of the CustomHandlerAlertAction class.
Public method | CustomHandlerAlertAction(CustomHandlerAlertAction) | Initializes a new instance of the CustomHandlerAlertAction class.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Constructor

[image]

IceLib Technical Reference
CustomHandlerAlertAction Constructor
CustomHandlerAlertAction Class See Also Send Feedback
Initializes a new instance of the CustomHandlerAlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomHandlerAlertAction()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
CustomHandlerAlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Constructor (CustomHandlerAlertAction)

[image]

IceLib Technical Reference
CustomHandlerAlertAction Constructor (CustomHandlerAlertAction)
CustomHandlerAlertAction Class See Also Send Feedback
Initializes a new instance of the CustomHandlerAlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CustomHandlerAlertAction(
    CustomHandlerAlertAction action
)
Visual Basic
Public Sub New ( _
    action As CustomHandlerAlertAction _
)

Parameters

action
Type: ININ.IceLib.Statistics.Alerts..::..CustomHandlerAlertAction
The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
CustomHandlerAlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Methods

[image] [image]

IceLib Technical Reference
CustomHandlerAlertAction Methods
CustomHandlerAlertAction Class See Also Send Feedback

The CustomHandlerAlertAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertAction.)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertAction.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction. (Inherited from AlertAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value for the associated property name. (Inherited from AlertAction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name. (Inherited from AlertAction.)

See Also

CustomHandlerAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


CustomHandlerAlertAction Properties

[image] [image]

IceLib Technical Reference
CustomHandlerAlertAction Properties
CustomHandlerAlertAction Class See Also Send Feedback

The CustomHandlerAlertAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionId | Gets the action ID. (Inherited from AlertAction.)
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in. (Inherited from AlertAction.)
Public property | HandlerName | Gets the handler name.
Public property | InitiateHandlerOnChangeWithinRange | Gets a value indicating whether to initiate a handler on a change within the alert range.
Public property | InitiateHandlerOnEnteringRange | Gets a value indicating whether to initiate a handler on entering the alert range.
Public property | InitiateHandlerOnExitingRange | Gets a value indicating whether to initiate a handler on exiting the alert range.
Public property | InitiateHandlerOnObservedValueChange | Gets a value indicating whether to initiate a handler on an observed value change the alert range.
Public property | IsEditable | Gets a value indicating whether this instance is editable. (Inherited from AlertAction.)
Public property | TargetId | Gets the target ID. Who the alert action is destined for. (Inherited from AlertAction.)
Public property | UserData | Gets the user data to pass to the handler.

See Also

CustomHandlerAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


HandlerName Property

[image]

IceLib Technical Reference
CustomHandlerAlertAction..::..HandlerName Property
CustomHandlerAlertAction Class See Also Send Feedback
Gets the handler name.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HandlerName { get; set; }
Visual Basic
Public Property HandlerName As String
    Get
    Set

Field Value

The handler name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


InitiateHandlerOnChangeWithinRange Property

[image]

IceLib Technical Reference
CustomHandlerAlertAction..::..InitiateHandlerOnChangeWithinRange Property
CustomHandlerAlertAction Class See Also Send Feedback
Gets a value indicating whether to initiate a handler on a change within the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool InitiateHandlerOnChangeWithinRange { get; set; }
Visual Basic
Public Property InitiateHandlerOnChangeWithinRange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if a handler is to be initiated on a change within the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


InitiateHandlerOnEnteringRange Property

[image]

IceLib Technical Reference
CustomHandlerAlertAction..::..InitiateHandlerOnEnteringRange Property
CustomHandlerAlertAction Class See Also Send Feedback
Gets a value indicating whether to initiate a handler on entering the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool InitiateHandlerOnEnteringRange { get; set; }
Visual Basic
Public Property InitiateHandlerOnEnteringRange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if a handler is to be initiated on entering the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


InitiateHandlerOnExitingRange Property

[image]

IceLib Technical Reference
CustomHandlerAlertAction..::..InitiateHandlerOnExitingRange Property
CustomHandlerAlertAction Class See Also Send Feedback
Gets a value indicating whether to initiate a handler on exiting the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool InitiateHandlerOnExitingRange { get; set; }
Visual Basic
Public Property InitiateHandlerOnExitingRange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if a handler is to be initiated on exiting the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


InitiateHandlerOnObservedValueChange Property

[image]

IceLib Technical Reference
CustomHandlerAlertAction..::..InitiateHandlerOnObservedValueChange Property
CustomHandlerAlertAction Class See Also Send Feedback
Gets a value indicating whether to initiate a handler on an observed value change the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool InitiateHandlerOnObservedValueChange { get; set; }
Visual Basic
Public Property InitiateHandlerOnObservedValueChange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if a handler is to be initiated on an observed value change the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


UserData Property

[image]

IceLib Technical Reference
CustomHandlerAlertAction..::..UserData Property
CustomHandlerAlertAction Class See Also Send Feedback
Gets the user data to pass to the handler.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserData { get; set; }
Visual Basic
Public Property UserData As String
    Get
    Set

Field Value

The user data to pass to the handler.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

CustomHandlerAlertAction Class
CustomHandlerAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Class

[image]

IceLib Technical Reference
EditableAlertSet Class
Members See Also Send Feedback
Represents an editable alert set. This object is used to create and update alert sets.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EditableAlertSet : AlertSet
Visual Basic
Public Class EditableAlertSet _
    Inherits AlertSet

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertSet
ININ.IceLib.Statistics.Alerts..::..EditableAlertSet

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Members

[image] [image]

IceLib Technical Reference
EditableAlertSet Members
EditableAlertSet Class Constructors Methods Properties See Also Send Feedback

The EditableAlertSet type exposes the following members.

Constructors

 | Name | Description
Public method | EditableAlertSet()()()() | Initializes a new instance of the EditableAlertSet class.
Public method | EditableAlertSet(EditableAlertSetUpdateOperation, AlertSet) | Initializes a new instance of the EditableAlertSet class for an update operation.

Methods

 | Name | Description
Public method | AddAlertDefinition | Adds the alert definition.
Public method | AddAlertSetSubscriber | Adds the alert set subscriber.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from AlertSet.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(AlertSet) | Compares this instance to the specified other. (Inherited from AlertSet.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from AlertSet.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubscribedBy | Determines if a AlertSetSubscriberType is subscribed to this AlertSet. (Inherited from AlertSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertDefinition | Removes the alert definition.
Public method | RemoveAlertSetSubscriber | Removes the alert set subscriber.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessMode | Gets or sets the access mode.
Public property | AlertDefinitions | Gets the alerts. (Inherited from AlertSet.)
Protected property | AlertMap | Gets the alert map. (Inherited from AlertSet.)
Public property | AlertSetSubscribers | Gets the subscribers for this AlertSet. (Inherited from AlertSet.)
Public property | Created | Gets or sets the Date and time the alert set was created.
Public property | Description | Gets or sets the description.
Public property | DisplayString | Gets or sets the display string.
Public property | Id | Gets the ID. (Inherited from AlertSet.)
Public property | Modified | Gets or sets the Date and time the alert set was modified.
Public property | ModifiedBy | Gets or sets the name of the user who last modified this AlertSet.
Public property | Owner | Gets or sets the owner.
Public property | OwnerDisplayName | Gets or sets the owner display name.
Public property | SubscribedByOther | Gets a value indicating whether the AlertSet is subscribed to by users other than the current user. (Inherited from AlertSet.)
Public property | SubscribedByOwner | Gets whether or not this AlertSet is subscribed to by the Owner. (Inherited from AlertSet.)
Public property | SubscribedByUser | Gets a value indicating whether the AlertSet is subscribed to by the current user. (Inherited from AlertSet.)
Public property | UpdateOperation | Gets the update operation.

See Also

EditableAlertSet Class
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Constructor

[image] [image]

IceLib Technical Reference
EditableAlertSet Constructor
EditableAlertSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditableAlertSet()()()() | Initializes a new instance of the EditableAlertSet class.
Public method | EditableAlertSet(EditableAlertSetUpdateOperation, AlertSet) | Initializes a new instance of the EditableAlertSet class for an update operation.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Constructor

[image]

IceLib Technical Reference
EditableAlertSet Constructor
EditableAlertSet Class See Also Send Feedback
Initializes a new instance of the EditableAlertSet class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableAlertSet()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
EditableAlertSet Overload
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Constructor (EditableAlertSetUpdateOperation, AlertSet)

[image]

IceLib Technical Reference
EditableAlertSet Constructor (EditableAlertSetUpdateOperation, AlertSet)
EditableAlertSet Class See Also Send Feedback
Initializes a new instance of the EditableAlertSet class for an update operation.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableAlertSet(
    EditableAlertSetUpdateOperation updateOperation,
    AlertSet alertSet
)
Visual Basic
Public Sub New ( _
    updateOperation As EditableAlertSetUpdateOperation, _
    alertSet As AlertSet _
)

Parameters

updateOperation
Type: ININ.IceLib.Statistics.Alerts..::..EditableAlertSetUpdateOperation
The update operation.
alertSet
Type: ININ.IceLib.Statistics.Alerts..::..AlertSet
The alert set to copy from.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
EditableAlertSet Overload
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Methods

[image] [image]

IceLib Technical Reference
EditableAlertSet Methods
EditableAlertSet Class See Also Send Feedback

The EditableAlertSet type exposes the following members.

Methods

 | Name | Description
Public method | AddAlertDefinition | Adds the alert definition.
Public method | AddAlertSetSubscriber | Adds the alert set subscriber.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from AlertSet.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(AlertSet) | Compares this instance to the specified other. (Inherited from AlertSet.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Inherited from AlertSet.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubscribedBy | Determines if a AlertSetSubscriberType is subscribed to this AlertSet. (Inherited from AlertSet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAlertDefinition | Removes the alert definition.
Public method | RemoveAlertSetSubscriber | Removes the alert set subscriber.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditableAlertSet Class
ININ.IceLib.Statistics.Alerts Namespace


AddAlertDefinition Method

[image]

IceLib Technical Reference
EditableAlertSet..::..AddAlertDefinition Method
EditableAlertSet Class See Also Send Feedback
Adds the alert definition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAlertDefinition(
    AlertDefinition definition
)
Visual Basic
Public Sub AddAlertDefinition ( _
    definition As AlertDefinition _
)

Parameters

definition
Type: ININ.IceLib.Statistics.Alerts..::..AlertDefinition
The definition.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The definition is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


AddAlertSetSubscriber Method

[image]

IceLib Technical Reference
EditableAlertSet..::..AddAlertSetSubscriber Method
EditableAlertSet Class See Also Send Feedback
Adds the alert set subscriber.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAlertSetSubscriber(
    AlertSetSubscriber subscriber
)
Visual Basic
Public Sub AddAlertSetSubscriber ( _
    subscriber As AlertSetSubscriber _
)

Parameters

subscriber
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetSubscriber
The subscriber.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The subscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


RemoveAlertDefinition Method

[image]

IceLib Technical Reference
EditableAlertSet..::..RemoveAlertDefinition Method
EditableAlertSet Class See Also Send Feedback
Removes the alert definition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveAlertDefinition(
    AlertDefinition definition
)
Visual Basic
Public Sub RemoveAlertDefinition ( _
    definition As AlertDefinition _
)

Parameters

definition
Type: ININ.IceLib.Statistics.Alerts..::..AlertDefinition
The definition.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The definition is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


RemoveAlertSetSubscriber Method

[image]

IceLib Technical Reference
EditableAlertSet..::..RemoveAlertSetSubscriber Method
EditableAlertSet Class See Also Send Feedback
Removes the alert set subscriber.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveAlertSetSubscriber(
    AlertSetSubscriber subscriber
)
Visual Basic
Public Sub RemoveAlertSetSubscriber ( _
    subscriber As AlertSetSubscriber _
)

Parameters

subscriber
Type: ININ.IceLib.Statistics.Alerts..::..AlertSetSubscriber
The subscriber.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The subscriber is not editable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSet Properties

[image] [image]

IceLib Technical Reference
EditableAlertSet Properties
EditableAlertSet Class See Also Send Feedback

The EditableAlertSet type exposes the following members.

Properties

 | Name | Description
Public property | AccessMode | Gets or sets the access mode.
Public property | AlertDefinitions | Gets the alerts. (Inherited from AlertSet.)
Protected property | AlertMap | Gets the alert map. (Inherited from AlertSet.)
Public property | AlertSetSubscribers | Gets the subscribers for this AlertSet. (Inherited from AlertSet.)
Public property | Created | Gets or sets the Date and time the alert set was created.
Public property | Description | Gets or sets the description.
Public property | DisplayString | Gets or sets the display string.
Public property | Id | Gets the ID. (Inherited from AlertSet.)
Public property | Modified | Gets or sets the Date and time the alert set was modified.
Public property | ModifiedBy | Gets or sets the name of the user who last modified this AlertSet.
Public property | Owner | Gets or sets the owner.
Public property | OwnerDisplayName | Gets or sets the owner display name.
Public property | SubscribedByOther | Gets a value indicating whether the AlertSet is subscribed to by users other than the current user. (Inherited from AlertSet.)
Public property | SubscribedByOwner | Gets whether or not this AlertSet is subscribed to by the Owner. (Inherited from AlertSet.)
Public property | SubscribedByUser | Gets a value indicating whether the AlertSet is subscribed to by the current user. (Inherited from AlertSet.)
Public property | UpdateOperation | Gets the update operation.

See Also

EditableAlertSet Class
ININ.IceLib.Statistics.Alerts Namespace


AccessMode Property

[image]

IceLib Technical Reference
EditableAlertSet..::..AccessMode Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the access mode.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AlertSetAccessMode AccessMode { get; set; }
Visual Basic
Public Property AccessMode As AlertSetAccessMode
    Get
    Set

Field Value

The access mode.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Created Property

[image]

IceLib Technical Reference
EditableAlertSet..::..Created Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the Date and time the alert set was created.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Created { get; set; }
Visual Basic
Public Property Created As DateTime
    Get
    Set

Field Value

The date/time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Description Property

[image]

IceLib Technical Reference
EditableAlertSet..::..Description Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the description.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Field Value

The description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


DisplayString Property

[image]

IceLib Technical Reference
EditableAlertSet..::..DisplayString Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the display string.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayString { get; set; }
Visual Basic
Public Property DisplayString As String
    Get
    Set

Field Value

The display string.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Modified Property

[image]

IceLib Technical Reference
EditableAlertSet..::..Modified Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the Date and time the alert set was modified.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Modified { get; set; }
Visual Basic
Public Property Modified As DateTime
    Get
    Set

Field Value

The date/time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


ModifiedBy Property

[image]

IceLib Technical Reference
EditableAlertSet..::..ModifiedBy Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the name of the user who last modified this AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ModifiedBy { get; set; }
Visual Basic
Public Property ModifiedBy As String
    Get
    Set

Field Value

User who last modified this AlertSet.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


Owner Property

[image]

IceLib Technical Reference
EditableAlertSet..::..Owner Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the owner.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Owner { get; set; }
Visual Basic
Public Property Owner As String
    Get
    Set

Field Value

The owner.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


OwnerDisplayName Property

[image]

IceLib Technical Reference
EditableAlertSet..::..OwnerDisplayName Property
EditableAlertSet Class See Also Send Feedback
Gets or sets the owner display name.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerDisplayName { get; set; }
Visual Basic
Public Property OwnerDisplayName As String
    Get
    Set

Field Value

The owner display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


UpdateOperation Property

[image]

IceLib Technical Reference
EditableAlertSet..::..UpdateOperation Property
EditableAlertSet Class See Also Send Feedback
Gets the update operation.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EditableAlertSetUpdateOperation UpdateOperation { get; }
Visual Basic
Public ReadOnly Property UpdateOperation As EditableAlertSetUpdateOperation
    Get

Field Value

The update operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EditableAlertSet Class
EditableAlertSet Members
ININ.IceLib.Statistics.Alerts Namespace


EditableAlertSetUpdateOperation Enumeration

[image]

IceLib Technical Reference
EditableAlertSetUpdateOperation Enumeration
See Also Send Feedback
Defines what update operation will be performed on an EditableAlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EditableAlertSetUpdateOperation
Visual Basic
Public Enumeration EditableAlertSetUpdateOperation

Members

Member name | Value | Description
Create | 0 | The object will be created.
Modify | 1 | The object instance will be modified.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Class

[image]

IceLib Technical Reference
EmailMessageAlertAction Class
Members See Also Send Feedback
Alert action for an email message target. An email memo alert action defines an email that will be sent out when an alert is triggered.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class EmailMessageAlertAction : AlertAction
Visual Basic
Public Class EmailMessageAlertAction _
    Inherits AlertAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertAction
ININ.IceLib.Statistics.Alerts..::..EmailMessageAlertAction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Members

[image] [image]

IceLib Technical Reference
EmailMessageAlertAction Members
EmailMessageAlertAction Class Constructors Methods Properties See Also Send Feedback

The EmailMessageAlertAction type exposes the following members.

Constructors

 | Name | Description
Public method | EmailMessageAlertAction()()()() | Initializes a new instance of the EmailMessageAlertAction class.
Public method | EmailMessageAlertAction(EmailMessageAlertAction) | Initializes a new instance of the EmailMessageAlertAction class.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertAction.)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertAction.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction. (Inherited from AlertAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value for the associated property name. (Inherited from AlertAction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name. (Inherited from AlertAction.)

Properties

 | Name | Description
Public property | ActionId | Gets the action ID. (Inherited from AlertAction.)
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in. (Inherited from AlertAction.)
Public property | EmailAddresses | Gets or sets the list of addresses to send an email to.
Public property | IsEditable | Gets a value indicating whether this instance is editable. (Inherited from AlertAction.)
Public property | SendEmailOnChangeWithinRange | Gets or sets a value indicating whether to send an email on a change within the alert range.
Public property | SendEmailOnEnteringRange | Gets or sets a value indicating whether to send an email on entering the alert range.
Public property | SendEmailOnExitingRange | Gets or sets a value indicating whether to send an email on exiting the alert range.
Public property | SendEmailOnObservedValueChange | Gets or sets a value indicating whether to send an email on an observed value change the alert range.
Public property | SendToAlertSetSubscribers | Gets or sets a value indicating whether to send an email to all the subscribers of the AlertSet.
Public property | TargetId | Gets the target ID. Who the alert action is destined for. (Inherited from AlertAction.)

See Also

EmailMessageAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Constructor

[image] [image]

IceLib Technical Reference
EmailMessageAlertAction Constructor
EmailMessageAlertAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EmailMessageAlertAction()()()() | Initializes a new instance of the EmailMessageAlertAction class.
Public method | EmailMessageAlertAction(EmailMessageAlertAction) | Initializes a new instance of the EmailMessageAlertAction class.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Constructor

[image]

IceLib Technical Reference
EmailMessageAlertAction Constructor
EmailMessageAlertAction Class See Also Send Feedback
Initializes a new instance of the EmailMessageAlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailMessageAlertAction()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
EmailMessageAlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Constructor (EmailMessageAlertAction)

[image]

IceLib Technical Reference
EmailMessageAlertAction Constructor (EmailMessageAlertAction)
EmailMessageAlertAction Class See Also Send Feedback
Initializes a new instance of the EmailMessageAlertAction class.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EmailMessageAlertAction(
    EmailMessageAlertAction action
)
Visual Basic
Public Sub New ( _
    action As EmailMessageAlertAction _
)

Parameters

action
Type: ININ.IceLib.Statistics.Alerts..::..EmailMessageAlertAction
The action.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
EmailMessageAlertAction Overload
ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Methods

[image] [image]

IceLib Technical Reference
EmailMessageAlertAction Methods
EmailMessageAlertAction Class See Also Send Feedback

The EmailMessageAlertAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertAction.)
Public method | Equals(AlertAction) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertAction.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertAction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueNames | Gets names of the values currently contained by this AlertAction. (Inherited from AlertAction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value for the associated property name. (Inherited from AlertAction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value for the associated property name. (Inherited from AlertAction.)

See Also

EmailMessageAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


EmailMessageAlertAction Properties

[image] [image]

IceLib Technical Reference
EmailMessageAlertAction Properties
EmailMessageAlertAction Class See Also Send Feedback

The EmailMessageAlertAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionId | Gets the action ID. (Inherited from AlertAction.)
Public property | AlertRule | Gets the AlertRule that this AlertAction participates in. (Inherited from AlertAction.)
Public property | EmailAddresses | Gets or sets the list of addresses to send an email to.
Public property | IsEditable | Gets a value indicating whether this instance is editable. (Inherited from AlertAction.)
Public property | SendEmailOnChangeWithinRange | Gets or sets a value indicating whether to send an email on a change within the alert range.
Public property | SendEmailOnEnteringRange | Gets or sets a value indicating whether to send an email on entering the alert range.
Public property | SendEmailOnExitingRange | Gets or sets a value indicating whether to send an email on exiting the alert range.
Public property | SendEmailOnObservedValueChange | Gets or sets a value indicating whether to send an email on an observed value change the alert range.
Public property | SendToAlertSetSubscribers | Gets or sets a value indicating whether to send an email to all the subscribers of the AlertSet.
Public property | TargetId | Gets the target ID. Who the alert action is destined for. (Inherited from AlertAction.)

See Also

EmailMessageAlertAction Class
ININ.IceLib.Statistics.Alerts Namespace


EmailAddresses Property

[image]

IceLib Technical Reference
EmailMessageAlertAction..::..EmailAddresses Property
EmailMessageAlertAction Class See Also Send Feedback
Gets or sets the list of addresses to send an email to.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailAddresses { get; set; }
Visual Basic
Public Property EmailAddresses As String
    Get
    Set

Field Value

The list of email addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SendEmailOnChangeWithinRange Property

[image]

IceLib Technical Reference
EmailMessageAlertAction..::..SendEmailOnChangeWithinRange Property
EmailMessageAlertAction Class See Also Send Feedback
Gets or sets a value indicating whether to send an email on a change within the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendEmailOnChangeWithinRange { get; set; }
Visual Basic
Public Property SendEmailOnChangeWithinRange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if an email is to be sent on a change within the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SendEmailOnEnteringRange Property

[image]

IceLib Technical Reference
EmailMessageAlertAction..::..SendEmailOnEnteringRange Property
EmailMessageAlertAction Class See Also Send Feedback
Gets or sets a value indicating whether to send an email on entering the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendEmailOnEnteringRange { get; set; }
Visual Basic
Public Property SendEmailOnEnteringRange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if an email is to be sent on entering the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SendEmailOnExitingRange Property

[image]

IceLib Technical Reference
EmailMessageAlertAction..::..SendEmailOnExitingRange Property
EmailMessageAlertAction Class See Also Send Feedback
Gets or sets a value indicating whether to send an email on exiting the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendEmailOnExitingRange { get; set; }
Visual Basic
Public Property SendEmailOnExitingRange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if an email is to be sent on exiting the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SendEmailOnObservedValueChange Property

[image]

IceLib Technical Reference
EmailMessageAlertAction..::..SendEmailOnObservedValueChange Property
EmailMessageAlertAction Class See Also Send Feedback
Gets or sets a value indicating whether to send an email on an observed value change the alert range.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendEmailOnObservedValueChange { get; set; }
Visual Basic
Public Property SendEmailOnObservedValueChange As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if an email is to be sent on an observed value change the alert range; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


SendToAlertSetSubscribers Property

[image]

IceLib Technical Reference
EmailMessageAlertAction..::..SendToAlertSetSubscribers Property
EmailMessageAlertAction Class See Also Send Feedback
Gets or sets a value indicating whether to send an email to all the subscribers of the AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendToAlertSetSubscribers { get; set; }
Visual Basic
Public Property SendToAlertSetSubscribers As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if an email is to be sent to all AlertSet subscribers; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

EmailMessageAlertAction Class
EmailMessageAlertAction Members
ININ.IceLib.Statistics.Alerts Namespace


Memo Class

[image]

IceLib Technical Reference
Memo Class
Members See Also Send Feedback
Represents a memo within the Interaction Center system.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Memo
Visual Basic
Public Class Memo

Remarks

A memo can be received for a variety of reasons, either from another user or as part of an automated process. The MemoList object should be instantiated and used to listen for memos and sending out new memos.

To create a new local Memo object to work with use CreateMemo(Session, String, String, String, Boolean, Icon, Boolean, DateTime, String), CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String), or CreateEditableMemo(Session, Memo). There are two classes of memo: a regular memo and an alert memo. Alert memos use the AlertSetId field to associate with an AlertSet. Regular memos do not have that association, however they can bet set to expire using CanExpire and Expiration. CreateMemo(Session, String, String, String, Boolean, Icon, Boolean, DateTime, String) should be used to create new, regular memos while CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String) should be used to create alert memos. CreateEditableMemo(Session, Memo) should be used to copy an existing memo that has been received. Received memo objects can not be edited instead a new, cloned copy must be made to make modifications to be rebroadcast.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..Memo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Members
ININ.IceLib.Statistics.Alerts Namespace


Memo Members

[image] [image]

IceLib Technical Reference
Memo Members
Memo Class Methods Properties See Also Send Feedback

The Memo type exposes the following members.

Methods

 | Name | Description
 | CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String) | Creates a new Memo that is associated with an AlertSet.
 | CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String, Boolean) | Creates a new Memo that is associated with an AlertSet.
 | CreateEditableMemo | Creates a new editable Memo from a given Memo.
 | CreateMemo | Creates a new Memo.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AlertSetId | Gets or sets or sets the AlertSetID, to be used for Alert memos.
Public property | CanExpire | Gets or sets whether or not the message can expire.
Public property | Expiration | Gets or sets the UTC based time that the MemoList will expire.
Public property | Icon | Gets or sets the icon.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | IsExpired | Gets a value indicating whether this instance is expired.
Public property | MessageId | Gets the ID of the message.
Public property | MessageName | Gets or sets the name of the message.
Public property | MessageText | Gets or sets the message text.
Public property | PopupType | Gets or sets whether or not the memo is a pop-up type.
Public property | Recipients | Gets the list of recipients.
Public property | SenderDisplayName | Gets the display name of the sender.
Public property | SenderId | Gets the ID of the sender.
Public property | SendToAlertSetSubscribers | Gets or sets a value indicating whether to send the memo to all the subscribers of the AlertSet.
Public property | SoundFile | Gets or sets the sound.
Public property | Url | Gets or sets the URL.

See Also

Memo Class
ININ.IceLib.Statistics.Alerts Namespace


Memo Methods

[image] [image]

IceLib Technical Reference
Memo Methods
Memo Class See Also Send Feedback

The Memo type exposes the following members.

Methods

 | Name | Description
 | CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String) | Creates a new Memo that is associated with an AlertSet.
 | CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String, Boolean) | Creates a new Memo that is associated with an AlertSet.
 | CreateEditableMemo | Creates a new editable Memo from a given Memo.
 | CreateMemo | Creates a new Memo.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

Memo Class
ININ.IceLib.Statistics.Alerts Namespace


CreateAlertMemo Method

[image] [image]

IceLib Technical Reference
Memo..::..CreateAlertMemo Method
Memo Class See Also Send Feedback

Overload List

Name | Description
CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String) | Creates a new Memo that is associated with an AlertSet.
CreateAlertMemo(Session, String, String, String, Boolean, Icon, String, String, Boolean) | Creates a new Memo that is associated with an AlertSet.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


CreateAlertMemo Method (Session, String, String, String, Boolean, Icon, String, String)

[image]

IceLib Technical Reference
Memo..::..CreateAlertMemo Method (Session, String, String, String, Boolean, Icon, String, String)
Memo Class See Also Send Feedback
Creates a new Memo that is associated with an AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static Memo CreateAlertMemo(
    Session session,
    string messageText,
    string messageName,
    string url,
    bool popupType,
    Icon icon,
    string soundFile,
    string alertSetId
)
Visual Basic
Public Shared Function CreateAlertMemo ( _
    session As Session, _
    messageText As String, _
    messageName As String, _
    url As String, _
    popupType As Boolean, _
    icon As Icon, _
    soundFile As String, _
    alertSetId As String _
) As Memo

Parameters

session
Type: ININ.IceLib.Connection..::..Session
Session object used to aid construction.
messageText
Type: System..::..String
Text of the Memo.
messageName
Type: System..::..String
The name of the Memo.
url
Type: System..::..String
The URL to navigate to, may be nullNothingnullptra null reference (Nothing in Visual Basic).
popupType
Type: System..::..Boolean
Determines if the Memo should popup.
icon
Type: System.Drawing..::..Icon
Icon to display.
soundFile
Type: System..::..String
Sound to play, may be nullNothingnullptra null reference (Nothing in Visual Basic).
alertSetId
Type: System..::..String
The ID of the AlertSet that this Memo is associated with.

Return Value

Newly created Memo.

Remarks

An alert Memo is a Memo that is sent for an alert. The only situation that one should be created manually is when creating a template for an AlertSet.
Note
An alert Memo cannot expire and as such does not use the Expiration nor the CanExpire fields.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The alertSetId length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

Memo Class
Memo Members
CreateAlertMemo Overload
ININ.IceLib.Statistics.Alerts Namespace


CreateAlertMemo Method (Session, String, String, String, Boolean, Icon, String, String, Boolean)

[image]

IceLib Technical Reference
Memo..::..CreateAlertMemo Method (Session, String, String, String, Boolean, Icon, String, String, Boolean)
Memo Class See Also Send Feedback
Creates a new Memo that is associated with an AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static Memo CreateAlertMemo(
    Session session,
    string messageText,
    string messageName,
    string url,
    bool popupType,
    Icon icon,
    string soundFile,
    string alertSetId,
    bool sendToAlertSetSubscribers
)
Visual Basic
Public Shared Function CreateAlertMemo ( _
    session As Session, _
    messageText As String, _
    messageName As String, _
    url As String, _
    popupType As Boolean, _
    icon As Icon, _
    soundFile As String, _
    alertSetId As String, _
    sendToAlertSetSubscribers As Boolean _
) As Memo

Parameters

session
Type: ININ.IceLib.Connection..::..Session
Session object used to aid construction.
messageText
Type: System..::..String
Text of the Memo.
messageName
Type: System..::..String
The name of the Memo.
url
Type: System..::..String
The URL to navigate to, may be nullNothingnullptra null reference (Nothing in Visual Basic).
popupType
Type: System..::..Boolean
Determines if the Memo should popup.
icon
Type: System.Drawing..::..Icon
Icon to display.
soundFile
Type: System..::..String
Sound to play, may be nullNothingnullptra null reference (Nothing in Visual Basic).
alertSetId
Type: System..::..String
The ID of the AlertSet that this Memo is associated with.
sendToAlertSetSubscribers
Type: System..::..Boolean
Determines if the memo should go to all subscribers of the alertSetId.

Return Value

Newly created Memo.

Remarks

An alert Memo is a Memo that is sent for an alert. The only situation that one should be created manually is when creating a template for an AlertSet.
Note
An alert Memo cannot expire and as such does not use the Expiration nor the CanExpire fields.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The alertSetId length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

Memo Class
Memo Members
CreateAlertMemo Overload
ININ.IceLib.Statistics.Alerts Namespace


CreateEditableMemo Method

[image]

IceLib Technical Reference
Memo..::..CreateEditableMemo Method
Memo Class See Also Send Feedback
Creates a new editable Memo from a given Memo.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static Memo CreateEditableMemo(
    Session session,
    Memo source
)
Visual Basic
Public Shared Function CreateEditableMemo ( _
    session As Session, _
    source As Memo _
) As Memo

Parameters

session
Type: ININ.IceLib.Connection..::..Session
Session object used to aid construction.
source
Type: ININ.IceLib.Statistics.Alerts..::..Memo
The source Memo.

Return Value

An editable copy of the existing Memo.

Remarks

This should be used to take an existing Memo from the server and turn it into a new Memo that can be modified and sent back to the server to perform an update on the existing Memo. The new Memo and the existing Memo will have the same MessageId.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


CreateMemo Method

[image]

IceLib Technical Reference
Memo..::..CreateMemo Method
Memo Class See Also Send Feedback
Creates a new Memo.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static Memo CreateMemo(
    Session session,
    string messageText,
    string messageName,
    string url,
    bool popupType,
    Icon icon,
    bool canExpire,
    DateTime expiration,
    string soundFile
)
Visual Basic
Public Shared Function CreateMemo ( _
    session As Session, _
    messageText As String, _
    messageName As String, _
    url As String, _
    popupType As Boolean, _
    icon As Icon, _
    canExpire As Boolean, _
    expiration As DateTime, _
    soundFile As String _
) As Memo

Parameters

session
Type: ININ.IceLib.Connection..::..Session
Session object to aid in creation.
messageText
Type: System..::..String
Text of the Memo.
messageName
Type: System..::..String
Name of the Memo.
url
Type: System..::..String
The URL to navigate to, may be nullNothingnullptra null reference (Nothing in Visual Basic).
popupType
Type: System..::..Boolean
Determine if the Memo should show a desktop alert.
icon
Type: System.Drawing..::..Icon
Icon to display.
canExpire
Type: System..::..Boolean
Does this Memo have a vaild expiration.
expiration
Type: System..::..DateTime
Expiration, may be zeroed.
soundFile
Type: System..::..String
Sound to play, may be nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

Newly created Memo.

Remarks

This function is to be used to create a Memo object that can be used to distribute a Memo to the server.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


ToString Method

[image]

IceLib Technical Reference
Memo..::..ToString Method
Memo Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


Memo Properties

[image] [image]

IceLib Technical Reference
Memo Properties
Memo Class See Also Send Feedback

The Memo type exposes the following members.

Properties

 | Name | Description
Public property | AlertSetId | Gets or sets or sets the AlertSetID, to be used for Alert memos.
Public property | CanExpire | Gets or sets whether or not the message can expire.
Public property | Expiration | Gets or sets the UTC based time that the MemoList will expire.
Public property | Icon | Gets or sets the icon.
Public property | IsEditable | Gets a value indicating whether this instance is editable.
Public property | IsExpired | Gets a value indicating whether this instance is expired.
Public property | MessageId | Gets the ID of the message.
Public property | MessageName | Gets or sets the name of the message.
Public property | MessageText | Gets or sets the message text.
Public property | PopupType | Gets or sets whether or not the memo is a pop-up type.
Public property | Recipients | Gets the list of recipients.
Public property | SenderDisplayName | Gets the display name of the sender.
Public property | SenderId | Gets the ID of the sender.
Public property | SendToAlertSetSubscribers | Gets or sets a value indicating whether to send the memo to all the subscribers of the AlertSet.
Public property | SoundFile | Gets or sets the sound.
Public property | Url | Gets or sets the URL.

See Also

Memo Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSetId Property

[image]

IceLib Technical Reference
Memo..::..AlertSetId Property
Memo Class See Also Send Feedback
Gets or sets or sets the AlertSetID, to be used for Alert memos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AlertSetId { get; set; }
Visual Basic
Public Property AlertSetId As String
    Get
    Set

Field Value

The alert set ID.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.
System..::..ArgumentNullException | AlertSetId is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


CanExpire Property

[image]

IceLib Technical Reference
Memo..::..CanExpire Property
Memo Class See Also Send Feedback
Gets or sets whether or not the message can expire.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanExpire { get; set; }
Visual Basic
Public Property CanExpire As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can expire; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


Expiration Property

[image]

IceLib Technical Reference
Memo..::..Expiration Property
Memo Class See Also Send Feedback
Gets or sets the UTC based time that the MemoList will expire.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime Expiration { get; set; }
Visual Basic
Public Property Expiration As DateTime
    Get
    Set

Field Value

The expiration.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


Icon Property

[image]

IceLib Technical Reference
Memo..::..Icon Property
Memo Class See Also Send Feedback
Gets or sets the icon.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Icon Icon { get; set; }
Visual Basic
Public Property Icon As Icon
    Get
    Set

Field Value

The icon, nullNothingnullptra null reference (Nothing in Visual Basic) if there is no icon.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


IsEditable Property

[image]

IceLib Technical Reference
Memo..::..IsEditable Property
Memo Class See Also Send Feedback
Gets a value indicating whether this instance is editable.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


IsExpired Property

[image]

IceLib Technical Reference
Memo..::..IsExpired Property
Memo Class See Also Send Feedback
Gets a value indicating whether this instance is expired.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsExpired { get; }
Visual Basic
Public ReadOnly Property IsExpired As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is expired; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


MessageId Property

[image]

IceLib Technical Reference
Memo..::..MessageId Property
Memo Class See Also Send Feedback
Gets the ID of the message.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageId { get; }
Visual Basic
Public ReadOnly Property MessageId As String
    Get

Field Value

The ID of the message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


MessageName Property

[image]

IceLib Technical Reference
Memo..::..MessageName Property
Memo Class See Also Send Feedback
Gets or sets the name of the message.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageName { get; set; }
Visual Basic
Public Property MessageName As String
    Get
    Set

Field Value

The name of the message.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.
System..::..ArgumentNullException | MessageName is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


MessageText Property

[image]

IceLib Technical Reference
Memo..::..MessageText Property
Memo Class See Also Send Feedback
Gets or sets the message text.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MessageText { get; set; }
Visual Basic
Public Property MessageText As String
    Get
    Set

Field Value

The message text.

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


PopupType Property

[image]

IceLib Technical Reference
Memo..::..PopupType Property
Memo Class See Also Send Feedback
Gets or sets whether or not the memo is a pop-up type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool PopupType { get; set; }
Visual Basic
Public Property PopupType As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if its a pop-up type; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


Recipients Property

[image]

IceLib Technical Reference
Memo..::..Recipients Property
Memo Class See Also Send Feedback
Gets the list of recipients.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<MemoRecipient> Recipients { get; }
Visual Basic
Public ReadOnly Property Recipients As ReadOnlyCollection(Of MemoRecipient)
    Get

Field Value

List of recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


SenderDisplayName Property

[image]

IceLib Technical Reference
Memo..::..SenderDisplayName Property
Memo Class See Also Send Feedback
Gets the display name of the sender.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SenderDisplayName { get; }
Visual Basic
Public ReadOnly Property SenderDisplayName As String
    Get

Field Value

The display name of the sender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


SenderId Property

[image]

IceLib Technical Reference
Memo..::..SenderId Property
Memo Class See Also Send Feedback
Gets the ID of the sender.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SenderId { get; }
Visual Basic
Public ReadOnly Property SenderId As String
    Get

Field Value

The ID of the sender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


SendToAlertSetSubscribers Property

[image]

IceLib Technical Reference
Memo..::..SendToAlertSetSubscribers Property
Memo Class See Also Send Feedback
Gets or sets a value indicating whether to send the memo to all the subscribers of the AlertSet.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SendToAlertSetSubscribers { get; set; }
Visual Basic
Public Property SendToAlertSetSubscribers As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if the memo is to be sent to all AlertSet subscribers; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


SoundFile Property

[image]

IceLib Technical Reference
Memo..::..SoundFile Property
Memo Class See Also Send Feedback
Gets or sets the sound.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SoundFile { get; set; }
Visual Basic
Public Property SoundFile As String
    Get
    Set

Field Value

The sound, can be nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


Url Property

[image]

IceLib Technical Reference
Memo..::..Url Property
Memo Class See Also Send Feedback
Gets or sets the URL.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set

Field Value

The URL, can be nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
System..::..InvalidOperationException | This memo is not in editable mode, this mode is determined by IsEditable.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

Memo Class
Memo Members
ININ.IceLib.Statistics.Alerts Namespace


MemoEventArgs Class

[image]

IceLib Technical Reference
MemoEventArgs Class
Members See Also Send Feedback
Provides data for the memo events of MemoList.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MemoEventArgs : EventArgs
Visual Basic
Public Class MemoEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Statistics.Alerts..::..MemoEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoEventArgs Members
ININ.IceLib.Statistics.Alerts Namespace


MemoEventArgs Members

[image] [image]

IceLib Technical Reference
MemoEventArgs Members
MemoEventArgs Class Methods Properties See Also Send Feedback

The MemoEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Memo | Gets the memo.

See Also

MemoEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


MemoEventArgs Methods

[image] [image]

IceLib Technical Reference
MemoEventArgs Methods
MemoEventArgs Class See Also Send Feedback

The MemoEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


MemoEventArgs Properties

[image] [image]

IceLib Technical Reference
MemoEventArgs Properties
MemoEventArgs Class See Also Send Feedback

The MemoEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Memo | Gets the memo.

See Also

MemoEventArgs Class
ININ.IceLib.Statistics.Alerts Namespace


Memo Property

[image]

IceLib Technical Reference
MemoEventArgs..::..Memo Property
MemoEventArgs Class See Also Send Feedback
Gets the memo.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Memo Memo { get; }
Visual Basic
Public ReadOnly Property Memo As Memo
    Get

Field Value

The memo.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoEventArgs Class
MemoEventArgs Members
ININ.IceLib.Statistics.Alerts Namespace


MemoList Class

[image]

IceLib Technical Reference
MemoList Class
Members See Also Send Feedback
This class serves as the main interface for accessing and creating Memo objects.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MemoList
Visual Basic
Public Class MemoList

Remarks

A MemoList object is used to track when Memo objects are received. There are three types of watches: MyMemos, General, and Alert which track two types of memos: alerts and non-alerts. Alert memos are associated with an AlertSet while non-alert memos have no association. Alert watches will track a memos associated with a given alert set ID. General watches track all memos that do not have an alertSetID. MyMemos will track all memos that are sent to the current user. The MemoList object can also be used to create new memos and to delete or modify existing memos, if the current user has rights to those actions.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..MemoList

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


MemoList Members

[image] [image]

IceLib Technical Reference
MemoList Members
MemoList Class Methods Properties Events See Also Send Feedback

The MemoList type exposes the following members.

Methods

 | Name | Description
Public method | CommitMemo | Distributes a given Memo to all listeners.
Public method | CommitMemoAsync | Asynchronously distributes a given Memo to all listeners.
 | CreateAlertMemoList | Creates the memo list to watch for alert Memo messages.
 | CreateGeneralMemoList | Creates the memo list to watch for non-alert Memo messages.
 | CreateMyMemoList | Creates the memo list to watch for Memo messages sent to the current user.
Public method | DeleteMemo | Deletes a Memo and notifies all listeners of its deletion.
Public method | DeleteMemoAsync | Asynchronously deletes a Memo and notifies all listeners of its deletion.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMemos | Gets all active memos.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a memo watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for memos.
Public method | StartWatchingAsync | Asynchronously starts watching for memos.
Public method | StopWatching | Stops watching for memos.
Public method | StopWatchingAsync | Asynchronously stops watching for memos.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlertSetId | Gets the ID of the alert set this watch is associated with. Only valid if WatchType is set to AlertMemos.
Public property | WatchType | Gets the type of Memo events to watch for.

Events

 | Name | Description
Public event | MemoAdded | Occurs when a memo is added to the queue.
Public event | MemoChanged | Occurs when a memo in the queue is changed.
Public event | MemoDeleted | Occurs when a memo is deleted from the queue.

See Also

MemoList Class
ININ.IceLib.Statistics.Alerts Namespace


MemoList Methods

[image] [image]

IceLib Technical Reference
MemoList Methods
MemoList Class See Also Send Feedback

The MemoList type exposes the following members.

Methods

 | Name | Description
Public method | CommitMemo | Distributes a given Memo to all listeners.
Public method | CommitMemoAsync | Asynchronously distributes a given Memo to all listeners.
 | CreateAlertMemoList | Creates the memo list to watch for alert Memo messages.
 | CreateGeneralMemoList | Creates the memo list to watch for non-alert Memo messages.
 | CreateMyMemoList | Creates the memo list to watch for Memo messages sent to the current user.
Public method | DeleteMemo | Deletes a Memo and notifies all listeners of its deletion.
Public method | DeleteMemoAsync | Asynchronously deletes a Memo and notifies all listeners of its deletion.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMemos | Gets all active memos.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching | Determines whether a memo watch is active.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatching | Starts watching for memos.
Public method | StartWatchingAsync | Asynchronously starts watching for memos.
Public method | StopWatching | Stops watching for memos.
Public method | StopWatchingAsync | Asynchronously stops watching for memos.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoList Class
ININ.IceLib.Statistics.Alerts Namespace


CommitMemo Method

[image]

IceLib Technical Reference
MemoList..::..CommitMemo Method
MemoList Class See Also Send Feedback
Distributes a given Memo to all listeners.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CommitMemo(
    IEnumerable<string> userIDs,
    IEnumerable<string> workgroupIDs,
    Memo memo
)
Visual Basic
Public Sub CommitMemo ( _
    userIDs As IEnumerable(Of String), _
    workgroupIDs As IEnumerable(Of String), _
    memo As Memo _
)

Parameters

userIDs
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of IDs for users that are targets.
workgroupIDs
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of IDs for workgroups that are targets.
memo
Type: ININ.IceLib.Statistics.Alerts..::..Memo
Memo object to be distributed.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


CommitMemoAsync Method

[image]

IceLib Technical Reference
MemoList..::..CommitMemoAsync Method
MemoList Class See Also Send Feedback
Asynchronously distributes a given Memo to all listeners.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CommitMemoAsync(
    IEnumerable<string> userIDs,
    IEnumerable<string> workgroupIDs,
    Memo memo,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CommitMemoAsync ( _
    userIDs As IEnumerable(Of String), _
    workgroupIDs As IEnumerable(Of String), _
    memo As Memo, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

userIDs
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of IDs for users that are targets.
workgroupIDs
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
List of IDs for workgroups that are targets.
memo
Type: ININ.IceLib.Statistics.Alerts..::..Memo
Message to send.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


CreateAlertMemoList Method

[image]

IceLib Technical Reference
MemoList..::..CreateAlertMemoList Method
MemoList Class See Also Send Feedback
Creates the memo list to watch for alert Memo messages.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static MemoList CreateAlertMemoList(
    StatisticsManager statisticsManager,
    string alertSetID
)
Visual Basic
Public Shared Function CreateAlertMemoList ( _
    statisticsManager As StatisticsManager, _
    alertSetID As String _
) As MemoList

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.
alertSetID
Type: System..::..String
The alert set ID to watch on.

Return Value

A MemoList that watches for alert Memo objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


CreateGeneralMemoList Method

[image]

IceLib Technical Reference
MemoList..::..CreateGeneralMemoList Method
MemoList Class See Also Send Feedback
Creates the memo list to watch for non-alert Memo messages.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static MemoList CreateGeneralMemoList(
    StatisticsManager statisticsManager
)
Visual Basic
Public Shared Function CreateGeneralMemoList ( _
    statisticsManager As StatisticsManager _
) As MemoList

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Return Value

A MemoList that watches for Memo objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


CreateMyMemoList Method

[image]

IceLib Technical Reference
MemoList..::..CreateMyMemoList Method
MemoList Class See Also Send Feedback
Creates the memo list to watch for Memo messages sent to the current user.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static MemoList CreateMyMemoList(
    StatisticsManager statisticsManager
)
Visual Basic
Public Shared Function CreateMyMemoList ( _
    statisticsManager As StatisticsManager _
) As MemoList

Parameters

statisticsManager
Type: ININ.IceLib.Statistics..::..StatisticsManager
The statistics manager.

Return Value

A MemoList that watches for Memo objects.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


DeleteMemo Method

[image]

IceLib Technical Reference
MemoList..::..DeleteMemo Method
MemoList Class See Also Send Feedback
Deletes a Memo and notifies all listeners of its deletion.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteMemo(
    string messageID
)
Visual Basic
Public Sub DeleteMemo ( _
    messageID As String _
)

Parameters

messageID
Type: System..::..String
Name of the Memo to be deleted.

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The messageID length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


DeleteMemoAsync Method

[image]

IceLib Technical Reference
MemoList..::..DeleteMemoAsync Method
MemoList Class See Also Send Feedback
Asynchronously deletes a Memo and notifies all listeners of its deletion.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteMemoAsync(
    string messageID,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteMemoAsync ( _
    messageID As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

messageID
Type: System..::..String
Name of Memo to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The messageID length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


GetMemos Method

[image]

IceLib Technical Reference
MemoList..::..GetMemos Method
MemoList Class See Also Send Feedback
Gets all active memos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<Memo> GetMemos()
Visual Basic
Public Function GetMemos As ReadOnlyCollection(Of Memo)

Field Value

The memos.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


IsWatching Method

[image]

IceLib Technical Reference
MemoList..::..IsWatching Method
MemoList Class See Also Send Feedback
Determines whether a memo watch is active.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsWatching()
Visual Basic
Public Function IsWatching As Boolean

Return Value

trueTruetruetrue (True in Visual Basic) if an memo watch is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This method determines whether an memo watch is in place.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatching Method

[image]

IceLib Technical Reference
MemoList..::..StartWatching Method
MemoList Class See Also Send Feedback
Starts watching for memos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatching()
Visual Basic
Public Sub StartWatching

Remarks

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is already being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


StartWatchingAsync Method

[image]

IceLib Technical Reference
MemoList..::..StartWatchingAsync Method
MemoList Class See Also Send Feedback
Asynchronously starts watching for memos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatching Method

[image]

IceLib Technical Reference
MemoList..::..StopWatching Method
MemoList Class See Also Send Feedback
Stops watching for memos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatching()
Visual Basic
Public Sub StopWatching

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
System..::..InvalidOperationException | The object is not being watched.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


StopWatchingAsync Method

[image]

IceLib Technical Reference
MemoList..::..StopWatchingAsync Method
MemoList Class See Also Send Feedback
Asynchronously stops watching for memos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


MemoList Properties

[image] [image]

IceLib Technical Reference
MemoList Properties
MemoList Class See Also Send Feedback

The MemoList type exposes the following members.

Properties

 | Name | Description
Public property | AlertSetId | Gets the ID of the alert set this watch is associated with. Only valid if WatchType is set to AlertMemos.
Public property | WatchType | Gets the type of Memo events to watch for.

See Also

MemoList Class
ININ.IceLib.Statistics.Alerts Namespace


AlertSetId Property

[image]

IceLib Technical Reference
MemoList..::..AlertSetId Property
MemoList Class See Also Send Feedback
Gets the ID of the alert set this watch is associated with. Only valid if WatchType is set to AlertMemos.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AlertSetId { get; }
Visual Basic
Public ReadOnly Property AlertSetId As String
    Get

Field Value

The alert set ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


WatchType Property

[image]

IceLib Technical Reference
MemoList..::..WatchType Property
MemoList Class See Also Send Feedback
Gets the type of Memo events to watch for.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MemoWatchType WatchType { get; }
Visual Basic
Public ReadOnly Property WatchType As MemoWatchType
    Get

Field Value

The type of the watch.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


MemoList Events

[image] [image]

IceLib Technical Reference
MemoList Events
MemoList Class See Also Send Feedback

The MemoList type exposes the following members.

Events

 | Name | Description
Public event | MemoAdded | Occurs when a memo is added to the queue.
Public event | MemoChanged | Occurs when a memo in the queue is changed.
Public event | MemoDeleted | Occurs when a memo is deleted from the queue.

See Also

MemoList Class
ININ.IceLib.Statistics.Alerts Namespace


MemoAdded Event

[image]

IceLib Technical Reference
MemoList..::..MemoAdded Event
MemoList Class See Also Send Feedback
Occurs when a memo is added to the queue.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<MemoEventArgs> MemoAdded
Visual Basic
Public Event MemoAdded As EventHandler(Of MemoEventArgs)

Remarks

This event will only occur when memos being watched have changed. To start watching for memo changes call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


MemoChanged Event

[image]

IceLib Technical Reference
MemoList..::..MemoChanged Event
MemoList Class See Also Send Feedback
Occurs when a memo in the queue is changed.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<MemoEventArgs> MemoChanged
Visual Basic
Public Event MemoChanged As EventHandler(Of MemoEventArgs)

Remarks

This event will only occur when memos being watched have changed. To start watching for memo changes call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


MemoDeleted Event

[image]

IceLib Technical Reference
MemoList..::..MemoDeleted Event
MemoList Class See Also Send Feedback
Occurs when a memo is deleted from the queue.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<MemoEventArgs> MemoDeleted
Visual Basic
Public Event MemoDeleted As EventHandler(Of MemoEventArgs)

Remarks

This event will only occur when memos being watched have changed. To start watching for memo changes call either the StartWatching()()()() method or the StartWatchingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatching()()()() or StartWatchingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoList Class
MemoList Members
ININ.IceLib.Statistics.Alerts Namespace


MemoRecipient Class

[image]

IceLib Technical Reference
MemoRecipient Class
Members See Also Send Feedback
Represents an entity that is listed as a receiver of a Memo.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MemoRecipient
Visual Basic
Public Class MemoRecipient

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..MemoRecipient

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoRecipient Members
ININ.IceLib.Statistics.Alerts Namespace


MemoRecipient Members

[image] [image]

IceLib Technical Reference
MemoRecipient Members
MemoRecipient Class Methods Properties See Also Send Feedback

The MemoRecipient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the displayable internal unique identifier. Consists of both the ID and the displayable name.
Public property | RecipientType | Gets the type of the recipient.

See Also

MemoRecipient Class
ININ.IceLib.Statistics.Alerts Namespace


MemoRecipient Methods

[image] [image]

IceLib Technical Reference
MemoRecipient Methods
MemoRecipient Class See Also Send Feedback

The MemoRecipient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemoRecipient Class
ININ.IceLib.Statistics.Alerts Namespace


MemoRecipient Properties

[image] [image]

IceLib Technical Reference
MemoRecipient Properties
MemoRecipient Class See Also Send Feedback

The MemoRecipient type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the displayable internal unique identifier. Consists of both the ID and the displayable name.
Public property | RecipientType | Gets the type of the recipient.

See Also

MemoRecipient Class
ININ.IceLib.Statistics.Alerts Namespace


Id Property

[image]

IceLib Technical Reference
MemoRecipient..::..Id Property
MemoRecipient Class See Also Send Feedback
Gets the displayable internal unique identifier. Consists of both the ID and the displayable name.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DisplayableId Id { get; }
Visual Basic
Public ReadOnly Property Id As DisplayableId
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoRecipient Class
MemoRecipient Members
ININ.IceLib.Statistics.Alerts Namespace


RecipientType Property

[image]

IceLib Technical Reference
MemoRecipient..::..RecipientType Property
MemoRecipient Class See Also Send Feedback
Gets the type of the recipient.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MemoRecipientType RecipientType { get; }
Visual Basic
Public ReadOnly Property RecipientType As MemoRecipientType
    Get

Field Value

The type of the recipient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

MemoRecipient Class
MemoRecipient Members
ININ.IceLib.Statistics.Alerts Namespace


MemoRecipientType Enumeration

[image]

IceLib Technical Reference
MemoRecipientType Enumeration
See Also Send Feedback
Represents the type of entity that a MemoRecipient refers to.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MemoRecipientType
Visual Basic
Public Enumeration MemoRecipientType

Members

Member name | Value | Description
User | 0 | The recipient of the memo is a user.
Workgroup | 1 | The recipient of the memo is a workgroup.

Remarks

A Memo has a list of recipients. A recipient may be an entity of a number of different types. This enumeration dictates that type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


MemoWatchType Enumeration

[image]

IceLib Technical Reference
MemoWatchType Enumeration
See Also Send Feedback
Represents the type of the memo watcher.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum MemoWatchType
Visual Basic
Public Enumeration MemoWatchType

Members

Member name | Value | Description
MyMemos | 0 | Watches for Memo objects that are addressed to the current user.
GeneralMemos | 1 | Watches for all non-alert Memo objects.
AlertMemos | 2 | Watches for alert Memo objects. This watch type will only watch for alerts that match a given AlertSet ID.

Remarks

MemoList objects can be created to watch for different circumstances. This enum differentiates between the watch types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

ININ.IceLib.Statistics.Alerts Namespace


NumericCondition(T) Class

[image]

IceLib Technical Reference
NumericCondition<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents a numeric alert condition. A numeric condition can be used against numeric statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To use a numeric condition, use one of its concrete implementations, such as NumericIntCondition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class NumericCondition<T> : AlertCondition
where T : Object, IComparable<T>
Visual Basic
Public MustInherit Class NumericCondition(Of T As {Object, IComparable(Of T)}) _
    Inherits AlertCondition

Type Parameters

T
The value type.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..NumericCondition<(Of <(<'T>)>)>
ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition
ININ.IceLib.Statistics.Alerts..::..NumericIntCondition
ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition
ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericCondition<(Of <(<'T>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


NumericCondition(T) Members

[image] [image]

IceLib Technical Reference
NumericCondition<(Of <(<'T>)>)> Members
NumericCondition<(Of <(<'T>)>)> Class Methods Properties See Also Send Feedback

The NumericCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertCondition.)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertCondition.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertCondition.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition.
Public property | Minimum | Gets the minimum bounding condition.

See Also

NumericCondition<(Of <(<'T>)>)> Class
ININ.IceLib.Statistics.Alerts Namespace


NumericCondition(T) Methods

[image] [image]

IceLib Technical Reference
NumericCondition<(Of <(<'T>)>)> Methods
NumericCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The NumericCondition<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from AlertCondition.)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Inherited from AlertCondition.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from AlertCondition.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericCondition<(Of <(<'T>)>)> Class
ININ.IceLib.Statistics.Alerts Namespace


NumericCondition(T) Properties

[image] [image]

IceLib Technical Reference
NumericCondition<(Of <(<'T>)>)> Properties
NumericCondition<(Of <(<'T>)>)> Class See Also Send Feedback

The NumericCondition<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition.
Public property | Minimum | Gets the minimum bounding condition.

See Also

NumericCondition<(Of <(<'T>)>)> Class
ININ.IceLib.Statistics.Alerts Namespace


Maximum Property

[image]

IceLib Technical Reference
NumericCondition<(Of <(<'T>)>)>..::..Maximum Property
NumericCondition<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the maximum bounding condition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public T Maximum { get; private set; }
Visual Basic
Public Property Maximum As T
    Get
    Private Set

Field Value

The maximum value if Comparison is Range or Maximum.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericCondition<(Of <(<'T>)>)> Class
NumericCondition<(Of <(<'T>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


Minimum Property

[image]

IceLib Technical Reference
NumericCondition<(Of <(<'T>)>)>..::..Minimum Property
NumericCondition<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the minimum bounding condition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public T Minimum { get; private set; }
Visual Basic
Public Property Minimum As T
    Get
    Private Set

Field Value

The minimum value if the comparison is Range or Minimum.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericCondition<(Of <(<'T>)>)> Class
NumericCondition<(Of <(<'T>)>)> Members
ININ.IceLib.Statistics.Alerts Namespace


NumericDoubleCondition Class

[image]

IceLib Technical Reference
NumericDoubleCondition Class
Members See Also Send Feedback
Represents a numeric double alert condition. A numeric double condition can be used against double statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericDoubleCondition use one of the static Create functions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NumericDoubleCondition : NumericCondition<double>
Visual Basic
Public Class NumericDoubleCondition _
    Inherits NumericCondition(Of Double)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..NumericCondition <(Of <(<'Double>)>)>
ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericDoubleCondition Members

[image] [image]

IceLib Technical Reference
NumericDoubleCondition Members
NumericDoubleCondition Class Methods Operators Properties See Also Send Feedback

The NumericDoubleCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a double alert.
 | CreateIsGreaterThanCondition | Creates the IsGreaterThan condition for a double alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for a double alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a double alert.
 | CreateRangeCondition | Creates a Range condition for a double alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericDoubleCondition) | Determines whether this instance and another specified NumericDoubleCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of NumericDoubleCondition are equal.
Inequality | Determines whether two instances of NumericDoubleCondition are not equal.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericDoubleCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericDoubleCondition Methods

[image] [image]

IceLib Technical Reference
NumericDoubleCondition Methods
NumericDoubleCondition Class See Also Send Feedback

The NumericDoubleCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a double alert.
 | CreateIsGreaterThanCondition | Creates the IsGreaterThan condition for a double alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for a double alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a double alert.
 | CreateRangeCondition | Creates a Range condition for a double alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericDoubleCondition) | Determines whether this instance and another specified NumericDoubleCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericDoubleCondition Class
ININ.IceLib.Statistics.Alerts Namespace


CreateIsAvailableCondition Method

[image]

IceLib Technical Reference
NumericDoubleCondition..::..CreateIsAvailableCondition Method
NumericDoubleCondition Class See Also Send Feedback
Creates an IsAvailable condition for a double alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericDoubleCondition CreateIsAvailableCondition()
Visual Basic
Public Shared Function CreateIsAvailableCondition As NumericDoubleCondition

Return Value

An instance of a NumericDoubleCondition triggering on an IsAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsGreaterThanCondition Method

[image]

IceLib Technical Reference
NumericDoubleCondition..::..CreateIsGreaterThanCondition Method
NumericDoubleCondition Class See Also Send Feedback
Creates the IsGreaterThan condition for a double alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericDoubleCondition CreateIsGreaterThanCondition(
    double value
)
Visual Basic
Public Shared Function CreateIsGreaterThanCondition ( _
    value As Double _
) As NumericDoubleCondition

Parameters

value
Type: System..::..Double
The value.

Return Value

An instance of a NumericDoubleCondition triggering on an IsGreaterThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsLessThanCondition Method

[image]

IceLib Technical Reference
NumericDoubleCondition..::..CreateIsLessThanCondition Method
NumericDoubleCondition Class See Also Send Feedback
Creates an IsLessThan condition for a double alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericDoubleCondition CreateIsLessThanCondition(
    double value
)
Visual Basic
Public Shared Function CreateIsLessThanCondition ( _
    value As Double _
) As NumericDoubleCondition

Parameters

value
Type: System..::..Double
The value.

Return Value

An instance of a NumericDoubleCondition triggering on an IsLessThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsNotAvailableCondition Method

[image]

IceLib Technical Reference
NumericDoubleCondition..::..CreateIsNotAvailableCondition Method
NumericDoubleCondition Class See Also Send Feedback
Creates an IsNotAvailable condition for a double alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericDoubleCondition CreateIsNotAvailableCondition()
Visual Basic
Public Shared Function CreateIsNotAvailableCondition As NumericDoubleCondition

Return Value

An instance of a NumericDoubleCondition triggering on an IsNotAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateRangeCondition Method

[image]

IceLib Technical Reference
NumericDoubleCondition..::..CreateRangeCondition Method
NumericDoubleCondition Class See Also Send Feedback
Creates a Range condition for a double alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericDoubleCondition CreateRangeCondition(
    double minimum,
    double maximum
)
Visual Basic
Public Shared Function CreateRangeCondition ( _
    minimum As Double, _
    maximum As Double _
) As NumericDoubleCondition

Parameters

minimum
Type: System..::..Double
The minimum.
maximum
Type: System..::..Double
The maximum.

Return Value

An instance of a NumericDoubleCondition triggering on a range comparison.

Exceptions

Exception | Condition
System..::..ArgumentException | The maximum value must be greater than the minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
NumericDoubleCondition..::..Equals Method
NumericDoubleCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericDoubleCondition) | Determines whether this instance and another specified NumericDoubleCondition object have the same value.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
NumericDoubleCondition..::..Equals Method (Object)
NumericDoubleCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
NumericDoubleCondition..::..Equals Method (AlertCondition)
NumericDoubleCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    AlertCondition other
)
Visual Basic
Public Overrides Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (NumericDoubleCondition)

[image]

IceLib Technical Reference
NumericDoubleCondition..::..Equals Method (NumericDoubleCondition)
NumericDoubleCondition Class See Also Send Feedback
Determines whether this instance and another specified NumericDoubleCondition object have the same value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    NumericDoubleCondition other
)
Visual Basic
Public Function Equals ( _
    other As NumericDoubleCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition
The NumericDoubleCondition to compare to this instance.

Return Value

trueTruetruetrue (True in Visual Basic) if the value of the other parameter is the same as this instance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
NumericDoubleCondition..::..GetHashCode Method
NumericDoubleCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericDoubleCondition Operators

[image] [image]

IceLib Technical Reference
NumericDoubleCondition Operators
NumericDoubleCondition Class See Also Send Feedback

The NumericDoubleCondition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of NumericDoubleCondition are equal.
Inequality | Determines whether two instances of NumericDoubleCondition are not equal.

See Also

NumericDoubleCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
NumericDoubleCondition..::..Equality Operator
NumericDoubleCondition Class See Also Send Feedback
Determines whether two instances of NumericDoubleCondition are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    NumericDoubleCondition a,
    NumericDoubleCondition b
)
Visual Basic
Public Shared Operator = ( _
    a As NumericDoubleCondition, _
    b As NumericDoubleCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition
The first NumericDoubleCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition
The second NumericDoubleCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
NumericDoubleCondition..::..Inequality Operator
NumericDoubleCondition Class See Also Send Feedback
Determines whether two instances of NumericDoubleCondition are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    NumericDoubleCondition a,
    NumericDoubleCondition b
)
Visual Basic
Public Shared Operator <> ( _
    a As NumericDoubleCondition, _
    b As NumericDoubleCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition
The first NumericDoubleCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericDoubleCondition
The second NumericDoubleCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericDoubleCondition Class
NumericDoubleCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericDoubleCondition Properties

[image] [image]

IceLib Technical Reference
NumericDoubleCondition Properties
NumericDoubleCondition Class See Also Send Feedback

The NumericDoubleCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericDoubleCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericIntCondition Class

[image]

IceLib Technical Reference
NumericIntCondition Class
Members See Also Send Feedback
Represents a numeric integer alert condition. A numeric int condition can be used against integer statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericIntCondition use one of the static Create functions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NumericIntCondition : NumericCondition<int>
Visual Basic
Public Class NumericIntCondition _
    Inherits NumericCondition(Of Integer)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..NumericCondition <(Of <(<'Int32>)>)>
ININ.IceLib.Statistics.Alerts..::..NumericIntCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericIntCondition Members

[image] [image]

IceLib Technical Reference
NumericIntCondition Members
NumericIntCondition Class Methods Operators Properties See Also Send Feedback

The NumericIntCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for an integer alert.
 | CreateIsGreaterThanCondition | Creates the IsGreaterThan condition for a integer alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for an integer alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for an integer alert.
 | CreateRangeCondition | Creates a Range condition for an integer alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericIntCondition) | Determines whether this instance and another specified NumericIntCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of NumericIntCondition are equal.
Inequality | Determines whether two instances of NumericIntCondition are not equal.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericIntCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericIntCondition Methods

[image] [image]

IceLib Technical Reference
NumericIntCondition Methods
NumericIntCondition Class See Also Send Feedback

The NumericIntCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for an integer alert.
 | CreateIsGreaterThanCondition | Creates the IsGreaterThan condition for a integer alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for an integer alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for an integer alert.
 | CreateRangeCondition | Creates a Range condition for an integer alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericIntCondition) | Determines whether this instance and another specified NumericIntCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericIntCondition Class
ININ.IceLib.Statistics.Alerts Namespace


CreateIsAvailableCondition Method

[image]

IceLib Technical Reference
NumericIntCondition..::..CreateIsAvailableCondition Method
NumericIntCondition Class See Also Send Feedback
Creates an IsAvailable condition for an integer alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericIntCondition CreateIsAvailableCondition()
Visual Basic
Public Shared Function CreateIsAvailableCondition As NumericIntCondition

Return Value

An instance of a NumericIntCondition triggering on an IsAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsGreaterThanCondition Method

[image]

IceLib Technical Reference
NumericIntCondition..::..CreateIsGreaterThanCondition Method
NumericIntCondition Class See Also Send Feedback
Creates the IsGreaterThan condition for a integer alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericIntCondition CreateIsGreaterThanCondition(
    int value
)
Visual Basic
Public Shared Function CreateIsGreaterThanCondition ( _
    value As Integer _
) As NumericIntCondition

Parameters

value
Type: System..::..Int32
The value.

Return Value

An instance of a NumericIntCondition triggering on an IsGreaterThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsLessThanCondition Method

[image]

IceLib Technical Reference
NumericIntCondition..::..CreateIsLessThanCondition Method
NumericIntCondition Class See Also Send Feedback
Creates an IsLessThan condition for an integer alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericIntCondition CreateIsLessThanCondition(
    int value
)
Visual Basic
Public Shared Function CreateIsLessThanCondition ( _
    value As Integer _
) As NumericIntCondition

Parameters

value
Type: System..::..Int32
The value.

Return Value

An instance of a NumericIntCondition triggering on an IsLessThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsNotAvailableCondition Method

[image]

IceLib Technical Reference
NumericIntCondition..::..CreateIsNotAvailableCondition Method
NumericIntCondition Class See Also Send Feedback
Creates an IsNotAvailable condition for an integer alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericIntCondition CreateIsNotAvailableCondition()
Visual Basic
Public Shared Function CreateIsNotAvailableCondition As NumericIntCondition

Return Value

An instance of a NumericTimeStampCondition triggering on an IsNotAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateRangeCondition Method

[image]

IceLib Technical Reference
NumericIntCondition..::..CreateRangeCondition Method
NumericIntCondition Class See Also Send Feedback
Creates a Range condition for an integer alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericIntCondition CreateRangeCondition(
    int minimum,
    int maximum
)
Visual Basic
Public Shared Function CreateRangeCondition ( _
    minimum As Integer, _
    maximum As Integer _
) As NumericIntCondition

Parameters

minimum
Type: System..::..Int32
The minimum.
maximum
Type: System..::..Int32
The maximum.

Return Value

An instance of a NumericIntCondition triggering on a range comparison.

Exceptions

Exception | Condition
System..::..ArgumentException | The maximum value must be greater than the minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
NumericIntCondition..::..Equals Method
NumericIntCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericIntCondition) | Determines whether this instance and another specified NumericIntCondition object have the same value.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
NumericIntCondition..::..Equals Method (Object)
NumericIntCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
NumericIntCondition..::..Equals Method (AlertCondition)
NumericIntCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    AlertCondition other
)
Visual Basic
Public Overrides Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (NumericIntCondition)

[image]

IceLib Technical Reference
NumericIntCondition..::..Equals Method (NumericIntCondition)
NumericIntCondition Class See Also Send Feedback
Determines whether this instance and another specified NumericIntCondition object have the same value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    NumericIntCondition other
)
Visual Basic
Public Function Equals ( _
    other As NumericIntCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..NumericIntCondition
The NumericIntCondition to compare to this instance.

Return Value

trueTruetruetrue (True in Visual Basic) if the value of the other parameter is the same as this instance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
NumericIntCondition..::..GetHashCode Method
NumericIntCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericIntCondition Operators

[image] [image]

IceLib Technical Reference
NumericIntCondition Operators
NumericIntCondition Class See Also Send Feedback

The NumericIntCondition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of NumericIntCondition are equal.
Inequality | Determines whether two instances of NumericIntCondition are not equal.

See Also

NumericIntCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
NumericIntCondition..::..Equality Operator
NumericIntCondition Class See Also Send Feedback
Determines whether two instances of NumericIntCondition are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    NumericIntCondition a,
    NumericIntCondition b
)
Visual Basic
Public Shared Operator = ( _
    a As NumericIntCondition, _
    b As NumericIntCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericIntCondition
The first NumericIntCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericIntCondition
The second NumericIntCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
NumericIntCondition..::..Inequality Operator
NumericIntCondition Class See Also Send Feedback
Determines whether two instances of NumericIntCondition are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    NumericIntCondition a,
    NumericIntCondition b
)
Visual Basic
Public Shared Operator <> ( _
    a As NumericIntCondition, _
    b As NumericIntCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericIntCondition
The first NumericIntCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericIntCondition
The second NumericIntCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericIntCondition Class
NumericIntCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericIntCondition Properties

[image] [image]

IceLib Technical Reference
NumericIntCondition Properties
NumericIntCondition Class See Also Send Feedback

The NumericIntCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericIntCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeSpanCondition Class

[image]

IceLib Technical Reference
NumericTimeSpanCondition Class
Members See Also Send Feedback
Represents a numeric time span alert condition. A numeric time span condition can be used against time span statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericTimeSpanCondition use one of the static Create functions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NumericTimeSpanCondition : NumericCondition<TimeSpan>
Visual Basic
Public Class NumericTimeSpanCondition _
    Inherits NumericCondition(Of TimeSpan)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..NumericCondition <(Of <(<'TimeSpan>)>)>
ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeSpanCondition Members

[image] [image]

IceLib Technical Reference
NumericTimeSpanCondition Members
NumericTimeSpanCondition Class Methods Operators Properties See Also Send Feedback

The NumericTimeSpanCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a time span alert.
 | CreateIsGreaterThanCondition | Creates the IsGreaterThan condition for a time span alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for a time span alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a time span alert.
 | CreateRangeCondition | Creates a Range condition for a time span alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericTimeSpanCondition) | Determines whether this instance and another specified NumericTimeSpanCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of NumericTimeSpanCondition are equal.
Inequality | Determines whether two instances of NumericTimeSpanCondition are not equal.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericTimeSpanCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeSpanCondition Methods

[image] [image]

IceLib Technical Reference
NumericTimeSpanCondition Methods
NumericTimeSpanCondition Class See Also Send Feedback

The NumericTimeSpanCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a time span alert.
 | CreateIsGreaterThanCondition | Creates the IsGreaterThan condition for a time span alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for a time span alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a time span alert.
 | CreateRangeCondition | Creates a Range condition for a time span alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericTimeSpanCondition) | Determines whether this instance and another specified NumericTimeSpanCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericTimeSpanCondition Class
ININ.IceLib.Statistics.Alerts Namespace


CreateIsAvailableCondition Method

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..CreateIsAvailableCondition Method
NumericTimeSpanCondition Class See Also Send Feedback
Creates an IsAvailable condition for a time span alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeSpanCondition CreateIsAvailableCondition()
Visual Basic
Public Shared Function CreateIsAvailableCondition As NumericTimeSpanCondition

Return Value

An instance of a NumericTimeSpanCondition triggering on an IsAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsGreaterThanCondition Method

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..CreateIsGreaterThanCondition Method
NumericTimeSpanCondition Class See Also Send Feedback
Creates the IsGreaterThan condition for a time span alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeSpanCondition CreateIsGreaterThanCondition(
    TimeSpan value
)
Visual Basic
Public Shared Function CreateIsGreaterThanCondition ( _
    value As TimeSpan _
) As NumericTimeSpanCondition

Parameters

value
Type: System..::..TimeSpan
The value.

Return Value

An instance of a NumericTimeSpanCondition triggering on an IsGreaterThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsLessThanCondition Method

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..CreateIsLessThanCondition Method
NumericTimeSpanCondition Class See Also Send Feedback
Creates an IsLessThan condition for a time span alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeSpanCondition CreateIsLessThanCondition(
    TimeSpan value
)
Visual Basic
Public Shared Function CreateIsLessThanCondition ( _
    value As TimeSpan _
) As NumericTimeSpanCondition

Parameters

value
Type: System..::..TimeSpan
The value.

Return Value

An instance of a NumericTimeSpanCondition triggering on an IsLessThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsNotAvailableCondition Method

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..CreateIsNotAvailableCondition Method
NumericTimeSpanCondition Class See Also Send Feedback
Creates an IsNotAvailable condition for a time span alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeSpanCondition CreateIsNotAvailableCondition()
Visual Basic
Public Shared Function CreateIsNotAvailableCondition As NumericTimeSpanCondition

Return Value

An instance of a NumericTimeSpanCondition triggering on an IsNotAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateRangeCondition Method

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..CreateRangeCondition Method
NumericTimeSpanCondition Class See Also Send Feedback
Creates a Range condition for a time span alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeSpanCondition CreateRangeCondition(
    TimeSpan minimum,
    TimeSpan maximum
)
Visual Basic
Public Shared Function CreateRangeCondition ( _
    minimum As TimeSpan, _
    maximum As TimeSpan _
) As NumericTimeSpanCondition

Parameters

minimum
Type: System..::..TimeSpan
The minimum.
maximum
Type: System..::..TimeSpan
The maximum.

Return Value

An instance of a NumericTimeSpanCondition triggering on a range comparison.

Exceptions

Exception | Condition
System..::..ArgumentException | The maximum value must be greater than the minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
NumericTimeSpanCondition..::..Equals Method
NumericTimeSpanCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericTimeSpanCondition) | Determines whether this instance and another specified NumericTimeSpanCondition object have the same value.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..Equals Method (Object)
NumericTimeSpanCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..Equals Method (AlertCondition)
NumericTimeSpanCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    AlertCondition other
)
Visual Basic
Public Overrides Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (NumericTimeSpanCondition)

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..Equals Method (NumericTimeSpanCondition)
NumericTimeSpanCondition Class See Also Send Feedback
Determines whether this instance and another specified NumericTimeSpanCondition object have the same value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    NumericTimeSpanCondition other
)
Visual Basic
Public Function Equals ( _
    other As NumericTimeSpanCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition
The NumericTimeSpanCondition to compare to this instance.

Return Value

trueTruetruetrue (True in Visual Basic) if the value of the other parameter is the same as this instance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..GetHashCode Method
NumericTimeSpanCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeSpanCondition Operators

[image] [image]

IceLib Technical Reference
NumericTimeSpanCondition Operators
NumericTimeSpanCondition Class See Also Send Feedback

The NumericTimeSpanCondition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of NumericTimeSpanCondition are equal.
Inequality | Determines whether two instances of NumericTimeSpanCondition are not equal.

See Also

NumericTimeSpanCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..Equality Operator
NumericTimeSpanCondition Class See Also Send Feedback
Determines whether two instances of NumericTimeSpanCondition are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    NumericTimeSpanCondition a,
    NumericTimeSpanCondition b
)
Visual Basic
Public Shared Operator = ( _
    a As NumericTimeSpanCondition, _
    b As NumericTimeSpanCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition
The first NumericTimeSpanCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition
The second NumericTimeSpanCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
NumericTimeSpanCondition..::..Inequality Operator
NumericTimeSpanCondition Class See Also Send Feedback
Determines whether two instances of NumericTimeSpanCondition are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    NumericTimeSpanCondition a,
    NumericTimeSpanCondition b
)
Visual Basic
Public Shared Operator <> ( _
    a As NumericTimeSpanCondition, _
    b As NumericTimeSpanCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition
The first NumericTimeSpanCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeSpanCondition
The second NumericTimeSpanCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeSpanCondition Class
NumericTimeSpanCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeSpanCondition Properties

[image] [image]

IceLib Technical Reference
NumericTimeSpanCondition Properties
NumericTimeSpanCondition Class See Also Send Feedback

The NumericTimeSpanCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericTimeSpanCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeStampCondition Class

[image]

IceLib Technical Reference
NumericTimeStampCondition Class
Members See Also Send Feedback
Represents a numeric time stamp alert condition. A numeric time stamp condition can be used against time stamp statistics to create alerts that trigger when the statistic is greater than, less then, between, equal to, or not equal to the supplied values, or if the statistic is or is not available. To create a new NumericTimeStampCondition use one of the static Create functions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NumericTimeStampCondition : NumericCondition<DateTime>
Visual Basic
Public Class NumericTimeStampCondition _
    Inherits NumericCondition(Of DateTime)

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..NumericCondition <(Of <(<'DateTime>)>)>
ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeStampCondition Members

[image] [image]

IceLib Technical Reference
NumericTimeStampCondition Members
NumericTimeStampCondition Class Methods Operators Properties See Also Send Feedback

The NumericTimeStampCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a time stamp alert.
 | CreateIsGreaterThanCondition | Creates an IsGreaterThan condition for a time stamp alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for a time stamp alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a time stamp alert.
 | CreateRangeCondition | Creates a Range condition for a time stamp alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericTimeStampCondition) | Determines whether this instance and another specified NumericTimeStampCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of NumericTimeStampCondition are equal.
Inequality | Determines whether two instances of NumericTimeStampCondition are not equal.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericTimeStampCondition Class
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeStampCondition Methods

[image] [image]

IceLib Technical Reference
NumericTimeStampCondition Methods
NumericTimeStampCondition Class See Also Send Feedback

The NumericTimeStampCondition type exposes the following members.

Methods

 | Name | Description
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a time stamp alert.
 | CreateIsGreaterThanCondition | Creates an IsGreaterThan condition for a time stamp alert.
 | CreateIsLessThanCondition | Creates an IsLessThan condition for a time stamp alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a time stamp alert.
 | CreateRangeCondition | Creates a Range condition for a time stamp alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericTimeStampCondition) | Determines whether this instance and another specified NumericTimeStampCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericTimeStampCondition Class
ININ.IceLib.Statistics.Alerts Namespace


CreateIsAvailableCondition Method

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..CreateIsAvailableCondition Method
NumericTimeStampCondition Class See Also Send Feedback
Creates an IsAvailable condition for a time stamp alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeStampCondition CreateIsAvailableCondition()
Visual Basic
Public Shared Function CreateIsAvailableCondition As NumericTimeStampCondition

Return Value

An instance of a NumericTimeStampCondition triggering on an IsAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsGreaterThanCondition Method

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..CreateIsGreaterThanCondition Method
NumericTimeStampCondition Class See Also Send Feedback
Creates an IsGreaterThan condition for a time stamp alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeStampCondition CreateIsGreaterThanCondition(
    DateTime value
)
Visual Basic
Public Shared Function CreateIsGreaterThanCondition ( _
    value As DateTime _
) As NumericTimeStampCondition

Parameters

value
Type: System..::..DateTime
The value.

Return Value

An instance of a NumericTimeStampCondition triggering on an IsGreaterThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsLessThanCondition Method

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..CreateIsLessThanCondition Method
NumericTimeStampCondition Class See Also Send Feedback
Creates an IsLessThan condition for a time stamp alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeStampCondition CreateIsLessThanCondition(
    DateTime value
)
Visual Basic
Public Shared Function CreateIsLessThanCondition ( _
    value As DateTime _
) As NumericTimeStampCondition

Parameters

value
Type: System..::..DateTime
The value.

Return Value

An instance of a NumericTimeStampCondition triggering on an IsLessThan comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsNotAvailableCondition Method

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..CreateIsNotAvailableCondition Method
NumericTimeStampCondition Class See Also Send Feedback
Creates an IsNotAvailable condition for a time stamp alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeStampCondition CreateIsNotAvailableCondition()
Visual Basic
Public Shared Function CreateIsNotAvailableCondition As NumericTimeStampCondition

Return Value

An instance of a NumericTimeStampCondition triggering on an IsNotAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateRangeCondition Method

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..CreateRangeCondition Method
NumericTimeStampCondition Class See Also Send Feedback
Creates a Range condition for a time stamp alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static NumericTimeStampCondition CreateRangeCondition(
    DateTime minimum,
    DateTime maximum
)
Visual Basic
Public Shared Function CreateRangeCondition ( _
    minimum As DateTime, _
    maximum As DateTime _
) As NumericTimeStampCondition

Parameters

minimum
Type: System..::..DateTime
The minimum.
maximum
Type: System..::..DateTime
The maximum.

Return Value

An instance of a NumericTimeStampCondition triggering on a range comparison.

Exceptions

Exception | Condition
System..::..ArgumentException | The maximum value must be greater than the minimum value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
NumericTimeStampCondition..::..Equals Method
NumericTimeStampCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(NumericTimeStampCondition) | Determines whether this instance and another specified NumericTimeStampCondition object have the same value.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..Equals Method (Object)
NumericTimeStampCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..Equals Method (AlertCondition)
NumericTimeStampCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    AlertCondition other
)
Visual Basic
Public Overrides Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (NumericTimeStampCondition)

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..Equals Method (NumericTimeStampCondition)
NumericTimeStampCondition Class See Also Send Feedback
Determines whether this instance and another specified NumericTimeStampCondition object have the same value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    NumericTimeStampCondition other
)
Visual Basic
Public Function Equals ( _
    other As NumericTimeStampCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition
The NumericTimeStampCondition to compare to this instance.

Return Value

trueTruetruetrue (True in Visual Basic) if the value of the other parameter is the same as this instance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..GetHashCode Method
NumericTimeStampCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeStampCondition Operators

[image] [image]

IceLib Technical Reference
NumericTimeStampCondition Operators
NumericTimeStampCondition Class See Also Send Feedback

The NumericTimeStampCondition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of NumericTimeStampCondition are equal.
Inequality | Determines whether two instances of NumericTimeStampCondition are not equal.

See Also

NumericTimeStampCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..Equality Operator
NumericTimeStampCondition Class See Also Send Feedback
Determines whether two instances of NumericTimeStampCondition are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    NumericTimeStampCondition a,
    NumericTimeStampCondition b
)
Visual Basic
Public Shared Operator = ( _
    a As NumericTimeStampCondition, _
    b As NumericTimeStampCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition
The first NumericTimeStampCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition
The second NumericTimeStampCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
NumericTimeStampCondition..::..Inequality Operator
NumericTimeStampCondition Class See Also Send Feedback
Determines whether two instances of NumericTimeStampCondition are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    NumericTimeStampCondition a,
    NumericTimeStampCondition b
)
Visual Basic
Public Shared Operator <> ( _
    a As NumericTimeStampCondition, _
    b As NumericTimeStampCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition
The first NumericTimeStampCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..NumericTimeStampCondition
The second NumericTimeStampCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

NumericTimeStampCondition Class
NumericTimeStampCondition Members
ININ.IceLib.Statistics.Alerts Namespace


NumericTimeStampCondition Properties

[image] [image]

IceLib Technical Reference
NumericTimeStampCondition Properties
NumericTimeStampCondition Class See Also Send Feedback

The NumericTimeStampCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Maximum | Gets the maximum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)
Public property | Minimum | Gets the minimum bounding condition. (Inherited from NumericCondition<(Of <(<'T>)>)>.)

See Also

NumericTimeStampCondition Class
ININ.IceLib.Statistics.Alerts Namespace


StringCondition Class

[image]

IceLib Technical Reference
StringCondition Class
Members See Also Send Feedback
Represents a string alert condition. A string condition can be used against string statistics to create alerts that trigger when the statistic has a value that matches, contains, or does not contain the supplied text, or if the statistic is or is not available. To create a new StringCondition use one of the static Create functions.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class StringCondition : AlertCondition
Visual Basic
Public Class StringCondition _
    Inherits AlertCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Statistics.Alerts..::..AlertCondition
ININ.IceLib.Statistics.Alerts..::..StringCondition

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


StringCondition Members

[image] [image]

IceLib Technical Reference
StringCondition Members
StringCondition Class Methods Operators Properties See Also Send Feedback

The StringCondition type exposes the following members.

Methods

 | Name | Description
 | CreateContainsCondition | Creates a Contains condition for a string alert.
 | CreateDoesNotContainCondition | Creates a DoesNotContain condition for a string alert.
 | CreateEqualToCondition | Creates an EqualTo condition for a string alert.
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a string alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a string alert.
 | CreateMatchesPrefixCondition | Creates a MatchesPrefix condition for a string alert.
 | CreateNotEqualToCondition | Creates an NotEqualTo condition for a string alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(StringCondition) | Determines whether this instance and another specified StringCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two instances of StringCondition are equal.
Inequality | Determines whether two instances of StringCondition are not equal.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Text | Gets the specified text to match the string condition.

See Also

StringCondition Class
ININ.IceLib.Statistics.Alerts Namespace


StringCondition Methods

[image] [image]

IceLib Technical Reference
StringCondition Methods
StringCondition Class See Also Send Feedback

The StringCondition type exposes the following members.

Methods

 | Name | Description
 | CreateContainsCondition | Creates a Contains condition for a string alert.
 | CreateDoesNotContainCondition | Creates a DoesNotContain condition for a string alert.
 | CreateEqualToCondition | Creates an EqualTo condition for a string alert.
 | CreateIsAvailableCondition | Creates an IsAvailable condition for a string alert.
 | CreateIsNotAvailableCondition | Creates an IsNotAvailable condition for a string alert.
 | CreateMatchesPrefixCondition | Creates a MatchesPrefix condition for a string alert.
 | CreateNotEqualToCondition | Creates an NotEqualTo condition for a string alert.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(StringCondition) | Determines whether this instance and another specified StringCondition object have the same value.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AlertCondition..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringCondition Class
ININ.IceLib.Statistics.Alerts Namespace


CreateContainsCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateContainsCondition Method
StringCondition Class See Also Send Feedback
Creates a Contains condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateContainsCondition(
    string text
)
Visual Basic
Public Shared Function CreateContainsCondition ( _
    text As String _
) As StringCondition

Parameters

text
Type: System..::..String
The text.

Return Value

An instance of a StringCondition triggering on a Contains comparison.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The text parameter must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateDoesNotContainCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateDoesNotContainCondition Method
StringCondition Class See Also Send Feedback
Creates a DoesNotContain condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateDoesNotContainCondition(
    string text
)
Visual Basic
Public Shared Function CreateDoesNotContainCondition ( _
    text As String _
) As StringCondition

Parameters

text
Type: System..::..String
The text.

Return Value

An instance of a StringCondition triggering on a DoesNotContain comparison.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The text parameter must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateEqualToCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateEqualToCondition Method
StringCondition Class See Also Send Feedback
Creates an EqualTo condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateEqualToCondition(
    string text
)
Visual Basic
Public Shared Function CreateEqualToCondition ( _
    text As String _
) As StringCondition

Parameters

text
Type: System..::..String
The text.

Return Value

An instance of a StringCondition triggering on an IsAvailable comparison.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The text parameter must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsAvailableCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateIsAvailableCondition Method
StringCondition Class See Also Send Feedback
Creates an IsAvailable condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateIsAvailableCondition()
Visual Basic
Public Shared Function CreateIsAvailableCondition As StringCondition

Return Value

An instance of a StringCondition triggering on an IsAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateIsNotAvailableCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateIsNotAvailableCondition Method
StringCondition Class See Also Send Feedback
Creates an IsNotAvailable condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateIsNotAvailableCondition()
Visual Basic
Public Shared Function CreateIsNotAvailableCondition As StringCondition

Return Value

An instance of a StringCondition triggering on an IsNotAvailable comparison.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateMatchesPrefixCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateMatchesPrefixCondition Method
StringCondition Class See Also Send Feedback
Creates a MatchesPrefix condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateMatchesPrefixCondition(
    string text
)
Visual Basic
Public Shared Function CreateMatchesPrefixCondition ( _
    text As String _
) As StringCondition

Parameters

text
Type: System..::..String
The text.

Return Value

An instance of a StringCondition triggering on an MatchesPrefix comparison.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The text parameter must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


CreateNotEqualToCondition Method

[image]

IceLib Technical Reference
StringCondition..::..CreateNotEqualToCondition Method
StringCondition Class See Also Send Feedback
Creates an NotEqualTo condition for a string alert.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static StringCondition CreateNotEqualToCondition(
    string text
)
Visual Basic
Public Shared Function CreateNotEqualToCondition ( _
    text As String _
) As StringCondition

Parameters

text
Type: System..::..String
The text.

Return Value

An instance of a StringCondition triggering on an IsNotAvailable comparison.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The text parameter must not be nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method

[image] [image]

IceLib Technical Reference
StringCondition..::..Equals Method
StringCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides AlertCondition..::..Equals(Object).)
Public method | Equals(AlertCondition) | Indicates whether the current object is equal to another object of the same type. (Overrides AlertCondition..::..Equals(AlertCondition).)
Public method | Equals(StringCondition) | Determines whether this instance and another specified StringCondition object have the same value.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (Object)

[image]

IceLib Technical Reference
StringCondition..::..Equals Method (Object)
StringCondition Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (AlertCondition)

[image]

IceLib Technical Reference
StringCondition..::..Equals Method (AlertCondition)
StringCondition Class See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    AlertCondition other
)
Visual Basic
Public Overrides Function Equals ( _
    other As AlertCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..AlertCondition
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


Equals Method (StringCondition)

[image]

IceLib Technical Reference
StringCondition..::..Equals Method (StringCondition)
StringCondition Class See Also Send Feedback
Determines whether this instance and another specified StringCondition object have the same value.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool Equals(
    StringCondition other
)
Visual Basic
Public Function Equals ( _
    other As StringCondition _
) As Boolean

Parameters

other
Type: ININ.IceLib.Statistics.Alerts..::..StringCondition
The StringCondition to compare to this instance.

Return Value

trueTruetruetrue (True in Visual Basic) if the value of the other parameter is the same as this instance; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
Equals Overload
ININ.IceLib.Statistics.Alerts Namespace


GetHashCode Method

[image]

IceLib Technical Reference
StringCondition..::..GetHashCode Method
StringCondition Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


StringCondition Operators

[image] [image]

IceLib Technical Reference
StringCondition Operators
StringCondition Class See Also Send Feedback

The StringCondition type exposes the following members.

Operators

Name | Description
Equality | Determines whether two instances of StringCondition are equal.
Inequality | Determines whether two instances of StringCondition are not equal.

See Also

StringCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Equality Operator

[image]

IceLib Technical Reference
StringCondition..::..Equality Operator
StringCondition Class See Also Send Feedback
Determines whether two instances of StringCondition are equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator ==(
    StringCondition a,
    StringCondition b
)
Visual Basic
Public Shared Operator = ( _
    a As StringCondition, _
    b As StringCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..StringCondition
The first StringCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..StringCondition
The second StringCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


Inequality Operator

[image]

IceLib Technical Reference
StringCondition..::..Inequality Operator
StringCondition Class See Also Send Feedback
Determines whether two instances of StringCondition are not equal.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static bool operator !=(
    StringCondition a,
    StringCondition b
)
Visual Basic
Public Shared Operator <> ( _
    a As StringCondition, _
    b As StringCondition _
) As Boolean

Parameters

a
Type: ININ.IceLib.Statistics.Alerts..::..StringCondition
The first StringCondition to compare.
b
Type: ININ.IceLib.Statistics.Alerts..::..StringCondition
The second StringCondition to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if the instances are not equal, falseFalsefalsefalse (False in Visual Basic) otherwise.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


StringCondition Properties

[image] [image]

IceLib Technical Reference
StringCondition Properties
StringCondition Class See Also Send Feedback

The StringCondition type exposes the following members.

Properties

 | Name | Description
Public property | Comparison | Gets the comparison mechanism to use when evaluating the AlertCondition. (Inherited from AlertCondition.)
Public property | Text | Gets the specified text to match the string condition.

See Also

StringCondition Class
ININ.IceLib.Statistics.Alerts Namespace


Text Property

[image]

IceLib Technical Reference
StringCondition..::..Text Property
StringCondition Class See Also Send Feedback
Gets the specified text to match the string condition.

Namespace: ININ.IceLib.Statistics.Alerts
Assembly: ININ.IceLib.Statistics (in ININ.IceLib.Statistics.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Text { get; private set; }
Visual Basic
Public Property Text As String
    Get
    Private Set

Field Value

The text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.

See Also

StringCondition Class
StringCondition Members
ININ.IceLib.Statistics.Alerts Namespace


ININ.IceLib.Tracker Namespace

[image]

IceLib Technical Reference
ININ.IceLib.Tracker Namespace
Send Feedback

The ININ.IceLib.Tracker namespace contains classes for manipulating and managing Interaction Tracker data. The Interaction Tracker system consists of many entities such as Interactions, Organizations, Individuals, AddressTypes, and InteractionAddressTypes. Together, these entities provide Interaction Center users with a robust means of managing contact information, tracking interactions, and retrieving information pertaining to these different entities from the Tracker database. A valid Tracker Access license is required for any user running an application that makes use of the Tracker classes.

The three main classes in the ININ.IceLib.Tracker namespace are:

  • - Contains methods that perform administrative tasks.
  • Contains methods that perform typical user tasks.
  • Contains methods that perform search operations.

Each of the above classes takes a Session type as an input paramater to its constructor. Thus, a session must already be established before instantiating any of the above types. Each of the above classes contains a TransactionClient type. This is accesable via the public getter, and can be used to modify settings used during the communication with the underlying TransactionBuilder system. (In most cases you will not need to modify any of these settings.) For more information, please see the documentation for TransactionClient and ININ.IceLib.Data.TransactionBuilder.

If a user is not licensed for Tracker, eny attempt to call any methods in these classes will result in an IceLibLicenseException being thrown.

There are also a number of classes within the ININ.IceLib.Tracker namespace that provide support to the classes mentioned in the preceding summary. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

TrackerAdmin

The TrackerAdmin class consists of a set of methods that allow you to add, delete, update and retrieve Tracker types. The Tracker types are:

  • - Used to classify addresses within Tracker.
  • Used to classify interaction addresses within Tracker.
  • Used to further classify interaction addresses within Tracker.
  • Used to classify Individuals within Tracker.
  • Used to classify Organizations within Tracker.
  • Used to classify Attributes within Tracker.
  • Represent titles that can be assigned to individuals (Mr., Miss, Dr., etc.)
You will be familiar with these types if you have ever performed a Tracker administrative task in Interaction Administrator. The Tracker node in Interaction Administrator allows admins to add, delete, and update AddressTypes, IndividualTypes, OrganizationTypes, etc. If you want to create a .Net application that provides administrative capabilites for Tracker, you would use the TrackerAdmin class.

Examples

The following example retrieves the list of AddressTypes from Tracker. The returned Collection of AddressTypes is iterated over while each AddressType is added to a ListView.
CopyC#
...
if (_TrackerAdmin != null)
{
   // Get the address types from Tracker.
   Collection<AddressType> addressTypes = _TrackerAdmin.GetAddressTypes();
   foreach (AddressType addressType in addressTypes)
    {
        ListViewItem item = new ListViewItem(addressType.Name);
        item.ImageIndex = GetSelectedTreeNodeImageUnselected();
        item.Tag = addressType;
        _MainListView.Items.Add(item);
    }
}
TrackerUser

The TrackerUser class consists of a set of methods that allow you to add, delete, update and retrieve Tracker data that relates to Individuals, Organizations, and Locations. The main classes used here are:

  • Represents an Individual within Tracker.
  • Represents an Organization within Tracker.
  • Represents a Location within Tracker.
  • Represents an Annotation within Tracker.
  • Represents an address for an Individual within Tracker.
  • Represents an interaction address for an Individual within Tracker.
  • Represents an address for an Organization within Tracker.
  • Represents an interaction address for an Organization within Tracker.
  • Represents an address for a Location within Tracker.
  • Represents an interaction address for a Location within Tracker.
You will be familiar with these Tracker entities if you have ever used the Win32 TrackerClient application. The TrackerClient allows you to manage Tracker Contacts. You can add an address for an Individual. You can associate an Individual with a particular Organization. You can add a new Organization or Location. If you want to create a .Net application that provides these user level capabilites for Tracker, you would use the TrackerUser class.

Examples

The following example creates a new Organization.
CopyC#
...
if (_TrackerUser != null)
{
   // Instantiate the Organization.
   Organization organization = new Organization();
   annotation.Name = "My Company";
   string newID = _TrackerUser.AddOrganization(organization);
}
TrackerSearch

The TrackerSearch class consists of a set of methods that allow you to search the Tracker database for Individuals, Organizations, Locations, and Interactions. The main classes used here are:

  • Contains information about an Individual within Tracker.
  • Contains information about an Organization within Tracker.
  • Contains information about a Location within Tracker.
  • Contains information about an Interaction within Tracker.
The above classes are designed to contain a subset of information that lies within their associated non-view classes (e.g. Individual vs. IndividualView). Note: There is no Interaction class. Interactions are stored as InteractionSegments in Tracker. The above "View" classes are used to hold the search results when searching for about Tracker entities. If you want to create a .Net application that provides search capabilities, you would use the TrackerSearch class.

Examples

The following example searches for Individuals with a last name of "Smith." The results are then displayed in a ListView.
CopyC#
...
if (_TrackerSearch != null)
{
   // Create the input filter..

   SearchIndividualsFilter filter = new SearchIndividualsFilter();
   filter.FirstName = "Joe";
   filter.LastName = "Smith";
   // Create an IndividualView to hold the result..
   Collection<IndividualView> individualViewResults;
   // Perform the search..
   individualViewResults = _TrackerSearch.SearchIndividuals(filter);
   // Display the results of the search in a ListView..
   foreach (IndividualView individualView in individualViewResults)
    {
        ListViewItem item = new ListViewItem(individualView.FirstName + individualView.LastName);
        item.Tag = individualView;
        _MainListView.Items.Add(item);
    }
}

Classes

 | Class | Description
Public class | AddressType | Represents an address type within Tracker.
Public class | AddUpdateCompletedEventArgs | Provides data for asynchronously completed events of a TrackerUser.
Public class | Annotation | Represents an annotation within Tracker.
Public class | AnnotationView | Represents an annotation view within Tracker.
Public class | CanViewInteractionCompletedEventArgs | Provides data for the CanViewInteractionCompleted event of a TrackerUser.
Public class | GetCurrentSegmentOrganizationIndividualCompletedEventArgs | Provides data for the GetCurrentSegmentOrganizationIndividualCompleted event of a TrackerUser.
Public class | GetICUserIndividualInformationCompletedEventArgs | Provides data for the GetICUserIndividualInformation event of a TrackerUser.
Public class | GetIndividualDetailsCompletedEventArgs | Provides data for the GetIndividualDetailsCompleted event of a TrackerUser.
Public class | GetInteractionDetailsCompletedEventArgs | Provides data for the GetInteractionDetailsCompleted event of a TrackerUser.
Public class | GetLocationDetailsCompletedEventArgs | Provides data for the GetLocationDetailsCompleted event of a TrackerUser.
Public class | GetOrganizationDetailsCompletedEventArgs | Provides data for the GetOrganizationDetailsCompleted event of a TrackerUser.
Public class | GetPossibleDuplicateIndividualCompletedEventArgs | Provides data for the GetPossibleDuplicateIndividualCompleted event of a TrackerUser.
Public class | ICUserId | Represents an IC user ID within Tracker.
Public class | ICUserIndividualInformation | Helper class to contain the results of the GetICUserIndividualInformation(String) methods.
Public class | Individual | Represents an individual within Tracker.
Public class | IndividualAddress | Represents an individual address within Tracker.
Public class | IndividualDetails | Helper class to contain the results of the GetIndividualDetails(String) methods.
Public class | IndividualInteractionAddress | Represents an individual interaction address within Tracker.
Public class | IndividualType | Represents an individual type within Tracker.
Public class | IndividualView | Represents an individual view within Tracker.
Public class | InteractionAddressSubtype | Represents an interaction address subtype within Tracker.
Public class | InteractionAddressType | Represents an interaction address type within Tracker.
Public class | InteractionDetails | Helper class to contain the results from the GetInteractionDetails(String, String) methods.
Public class | InteractionParticipantView | Represents an interaction participant view within Tracker.
Public class | InteractionSegment | Represents an interaction segment within Tracker.
Public class | InteractionView | Represents an interaction view within Tracker.
Public class | IsUnknownOrSystemIndividualCompletedEventArgs | Provides data for the IsUnknownOrSystemIndividualCompleted event of a TrackerUser.
Public class | Location | Represents a location within Tracker.
Public class | LocationAddress | Represents a location address within Tracker.
Public class | LocationDetails | Helper class to contain the return parameters for the GetLocationDetails(String) methods.
Public class | LocationInteractionAddress | Represents a location InteractionAddress within Tracker.
Public class | LocationName | Represents a location name within Tracker.
Public class | LocationView | Represents a location view within Tracker.
Public class | MultipartAccountCode | Represents a multipart account code within Tracker.
Public class | MultipartAccountCodeExtended | Represents an extended multipart account code within Tracker.
Public class | NewIdCompletedEventArgs<(Of <(<'TId>)>)> | Provides data for asynchronous completed events of a TrackerUser.
Public class | Organization | Represents an organization within Tracker.
Public class | OrganizationAddress | Represents an organization address within Tracker.
Public class | OrganizationDetails | Helper class to contain the return parameters for the GetOrganizationDetails(String) methods.
Public class | OrganizationInteractionAddress | Represents an organization InteractionAddress within Tracker.
Public class | OrganizationName | Represents an organization name within Tracker.
Public class | OrganizationType | Represents an organization type within Tracker.
Public class | OrganizationView | Represents an organization view within Tracker.
Public class | QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> | Provides a collection of data for asynchronously completed events of a TrackerAdmin.
Public class | QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> | Provides data for asynchronously completed events of a TrackerAdmin.
Public class | ReverseInteractionAddressLookupInformation | Represents reverse InteractionAddress lookup information within Tracker.
Public class | ReverseWhitepagesCommonInfo | Holds common information used during reverse whitepage operations.
Public class | ReverseWhitepagesGeneralInfo | Holds general information used during reverse whitepage operations.
Public class | ReverseWhitepagesIndividualInfo | Holds information about an individual that is used during reverse whitepage operations.
Public class | ReverseWhitepagesInfo | Holds reverse whitepages lookup information that Tracker Server sends or receives.
Public class | ReverseWhitepagesLocationInfo | Holds information about a location that is used during reverse whitepage operations.
Public class | ReverseWhitepagesOrganizationInfo | Holds information about an organization that is used during reverse whitepage operations.
Public class | SearchForResolutionCandidatesCompletedEventArgs | Provides data for the SearchForResolutionCandidatesCompleted event of a TrackerSearch.
Public class | SearchIndividualsFilter | This class represents a filter that is used to search Individuals.
Public class | SearchInteractionsFilter | This class represents a filter that is used to search Interactions.
Public class | SearchLocationsFilter | This class represents a filter that is used to search Locations.
Public class | SearchOrganizationsFilter | This class represents a filter that is used to search Organizations.
Public class | SegmentOrganizationIndividualDetails | Helper class to contain the return values for the GetCurrentSegmentOrganizationIndividual(String, String) methods.
Public class | Title | Represents a title within Tracker.
Public class | TrackerAdmin | Contains methods necessary to perform typical Tracker admin related operations.
Public class | TrackerAttribute | Represents an attribute within Tracker.
Public class | TrackerAttributeType | Represents a Tracker attribute type within Tracker.
Public class | TrackerAttributeView | Represents an attribute view within Tracker.
Public class | TrackerContactEntry | Provides extended Tracker information for a ContactEntry in a Tracker Directory.
Public class | TrackerInteraction | Provides access to Tracker information for an interaction within the Interaction Center system.
Public class | TrackerInteractionAttributeName | Specifies attribute names that can be used with TrackerInteractions.
Public class | TrackerSearch | Contains methods necessary to perform typical Tracker search-related operations.
Public class | TrackerUser | Contains methods necessary to perform typical Tracker user related operations.
Public class | UserTrackerRightsAttributes | Attribute strings for the UserTrackerRightsSettings watched class.
Public class | UserTrackerRightsSettings | Represents the basic user rights settings for an IC user. User rights are set in Interaction Administrator at the Default User, User or Workgroup level.

Enumerations

 | Enumeration | Description
Public enumeration | ActiveType | This enum is used to distinguish between active entities and inactive entities.
Public enumeration | AdminType | This enumeration is used to distinguish between tracker admin users and non tracker admin users.
Public enumeration | AppliesToTypes | This enum consists of a set of Tracker types that certain methods use to limit their result set. For instance, the method GetTrackerAttributeTypes(AppliesToTypes) uses this enum to determine which TrackerAttributeTypes to fetch. An input value of AppliesToTypes.Individuals would cause the Tracker subsystem to return only TrackerAttributeTypes that are used for Individuals.
Public enumeration | DirectionType | The direction types that an interaction can have.
Public enumeration | HowEnded | This enum consists of a set of Tracker types that describe a given Segment.
Public enumeration | InteractionType | Represents the various interaction types within Interaction Center.
Public enumeration | PrivateType | This enum is used to distinguish between public interactions and private interactions.
Public enumeration | RoleType | This enum consists of a set of Tracker types that describe the various roles that an Individual can play in an interaction.
Public enumeration | SegmentTypes | This enum consists of a set of Tracker types that describe a given Segment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


ActiveType Enumeration

[image]

IceLib Technical Reference
ActiveType Enumeration
See Also Send Feedback
This enum is used to distinguish between active entities and inactive entities.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum ActiveType
Visual Basic
Public Enumeration ActiveType

Members

Member name | Value | Description
Inactive | 0 | Inactive entities.
Active | 1 | Active entities.
Both | 2 | Both active and Inactive entities.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


AddressType Class

[image]

IceLib Technical Reference
AddressType Class
Members See Also Send Feedback
Represents an address type within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AddressType
Visual Basic
Public Class AddressType

Remarks

AddressTypes are used to classify addresses within Tracker. The most important property of an AddressType is the Name property. This property is what is usually displayed to users in applications. Typical AddressType names are: billing, business, home, and shipping. Each IndividualAddress, LocationAddress, and OrganizationAddress contains an AddressType member that is used to hold the type of address that it represents.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..AddressType

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Members
ININ.IceLib.Tracker Namespace


AddressType Members

[image] [image]

IceLib Technical Reference
AddressType Members
AddressType Class Constructors Methods Properties See Also Send Feedback

The AddressType type exposes the following members.

Constructors

 | Name | Description
Public method | AddressType | Initializes a new instance of the AddressType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InsertionOrder | Gets or sets the insertion order. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

AddressType Class
ININ.IceLib.Tracker Namespace


AddressType Constructor

[image]

IceLib Technical Reference
AddressType Constructor
AddressType Class See Also Send Feedback
Initializes a new instance of the AddressType class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AddressType()
Visual Basic
Public Sub New

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


AddressType Methods

[image] [image]

IceLib Technical Reference
AddressType Methods
AddressType Class See Also Send Feedback

The AddressType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddressType Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
AddressType..::..Reset Method
AddressType Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


AddressType Properties

[image] [image]

IceLib Technical Reference
AddressType Properties
AddressType Class See Also Send Feedback

The AddressType type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InsertionOrder | Gets or sets the insertion order. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

AddressType Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
AddressType..::..AdminEditable Property
AddressType Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
AddressType..::..Id Property
AddressType Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


InsertionOrder Property

[image]

IceLib Technical Reference
AddressType..::..InsertionOrder Property
AddressType Class See Also Send Feedback
Gets or sets the insertion order. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InsertionOrder { get; set; }
Visual Basic
Public Property InsertionOrder As Nullable(Of Long)
    Get
    Set

Field Value

The insertion order, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
AddressType..::..Name Property
AddressType Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
AddressType..::..Version Property
AddressType Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddressType Class
AddressType Members
ININ.IceLib.Tracker Namespace


AddUpdateCompletedEventArgs Class

[image]

IceLib Technical Reference
AddUpdateCompletedEventArgs Class
Members See Also Send Feedback
Provides data for asynchronously completed events of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AddUpdateCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AddUpdateCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..AddUpdateCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddUpdateCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


AddUpdateCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AddUpdateCompletedEventArgs Members
AddUpdateCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The AddUpdateCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AddUpdateCompletedEventArgs | Initializes a new instance of the AddUpdateCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | WasAdded | Gets a value indicating whether an item was added.

See Also

AddUpdateCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


AddUpdateCompletedEventArgs Constructor

[image]

IceLib Technical Reference
AddUpdateCompletedEventArgs Constructor
AddUpdateCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the AddUpdateCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AddUpdateCompletedEventArgs(
    bool wasAdded,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    wasAdded As Boolean, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

wasAdded
Type: System..::..Boolean
A value indicating whether an item was added.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddUpdateCompletedEventArgs Class
AddUpdateCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


AddUpdateCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AddUpdateCompletedEventArgs Methods
AddUpdateCompletedEventArgs Class See Also Send Feedback

The AddUpdateCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddUpdateCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


AddUpdateCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AddUpdateCompletedEventArgs Properties
AddUpdateCompletedEventArgs Class See Also Send Feedback

The AddUpdateCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | WasAdded | Gets a value indicating whether an item was added.

See Also

AddUpdateCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


WasAdded Property

[image]

IceLib Technical Reference
AddUpdateCompletedEventArgs..::..WasAdded Property
AddUpdateCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether an item was added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool WasAdded { get; }
Visual Basic
Public ReadOnly Property WasAdded As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if was added; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AddUpdateCompletedEventArgs Class
AddUpdateCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


AdminType Enumeration

[image]

IceLib Technical Reference
AdminType Enumeration
See Also Send Feedback
This enumeration is used to distinguish between tracker admin users and non tracker admin users.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum AdminType
Visual Basic
Public Enumeration AdminType

Members

Member name | Value | Description
NonTrackerAdmin | 0 | A non-Tracker Admin.
TrackerAdmin | 1 | A Tracker Admin.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


Annotation Class

[image]

IceLib Technical Reference
Annotation Class
Members See Also Send Feedback
Represents an annotation within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Annotation
Visual Basic
Public Class Annotation

Remarks

A Tracker annotation is simply a string of text that can be associated interactions and Individuals. Use the Text property to set the text

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..Annotation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Members
ININ.IceLib.Tracker Namespace


Annotation Members

[image] [image]

IceLib Technical Reference
Annotation Members
Annotation Class Constructors Methods Properties See Also Send Feedback

The Annotation type exposes the following members.

Constructors

 | Name | Description
Public method | Annotation | Initializes a new instance of the Annotation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionId | Gets or sets the interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Text | Gets or sets the text. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Annotation Class
ININ.IceLib.Tracker Namespace


Annotation Constructor

[image]

IceLib Technical Reference
Annotation Constructor
Annotation Class See Also Send Feedback
Initializes a new instance of the Annotation class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Annotation()
Visual Basic
Public Sub New

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


Annotation Methods

[image] [image]

IceLib Technical Reference
Annotation Methods
Annotation Class See Also Send Feedback

The Annotation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Annotation Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
Annotation..::..Reset Method
Annotation Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


Annotation Properties

[image] [image]

IceLib Technical Reference
Annotation Properties
Annotation Class See Also Send Feedback

The Annotation type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionId | Gets or sets the interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Text | Gets or sets the text. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Annotation Class
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
Annotation..::..Id Property
Annotation Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
Annotation..::..IndividualId Property
Annotation Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


InteractionId Property

[image]

IceLib Technical Reference
Annotation..::..InteractionId Property
Annotation Class See Also Send Feedback
Gets or sets the interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionId { get; set; }
Visual Basic
Public Property InteractionId As String
    Get
    Set

Field Value

The interaction ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
Annotation..::..IsPrivate Property
Annotation Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


Text Property

[image]

IceLib Technical Reference
Annotation..::..Text Property
Annotation Class See Also Send Feedback
Gets or sets the text. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Field Value

The text, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
Annotation..::..Version Property
Annotation Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Annotation Class
Annotation Members
ININ.IceLib.Tracker Namespace


AnnotationView Class

[image]

IceLib Technical Reference
AnnotationView Class
Members See Also Send Feedback
Represents an annotation view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AnnotationView
Visual Basic
Public Class AnnotationView

Remarks

The AnnotationView class is used by methods that return information about Annotations. One such method is the GetInteractionDetails(String, String) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..AnnotationView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Members
ININ.IceLib.Tracker Namespace


AnnotationView Members

[image] [image]

IceLib Technical Reference
AnnotationView Members
AnnotationView Class Constructors Methods Properties See Also Send Feedback

The AnnotationView type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationView | Initializes a new instance of the AnnotationView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnnotationId | Gets or sets the annotation ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId | Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Text | Gets or sets the text. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

AnnotationView Class
ININ.IceLib.Tracker Namespace


AnnotationView Constructor

[image]

IceLib Technical Reference
AnnotationView Constructor
AnnotationView Class See Also Send Feedback
Initializes a new instance of the AnnotationView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AnnotationView()
Visual Basic
Public Sub New

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


AnnotationView Methods

[image] [image]

IceLib Technical Reference
AnnotationView Methods
AnnotationView Class See Also Send Feedback

The AnnotationView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
AnnotationView..::..Reset Method
AnnotationView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


AnnotationView Properties

[image] [image]

IceLib Technical Reference
AnnotationView Properties
AnnotationView Class See Also Send Feedback

The AnnotationView type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationId | Gets or sets the annotation ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId | Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Text | Gets or sets the text. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

AnnotationView Class
ININ.IceLib.Tracker Namespace


AnnotationId Property

[image]

IceLib Technical Reference
AnnotationView..::..AnnotationId Property
AnnotationView Class See Also Send Feedback
Gets or sets the annotation ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AnnotationId { get; set; }
Visual Basic
Public Property AnnotationId As Nullable(Of Long)
    Get
    Set

Field Value

The annotation ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


ICUserId Property

[image]

IceLib Technical Reference
AnnotationView..::..ICUserId Property
AnnotationView Class See Also Send Feedback
Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUserId { get; set; }
Visual Basic
Public Property ICUserId As String
    Get
    Set

Field Value

The IC user ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
AnnotationView..::..IndividualId Property
AnnotationView Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
AnnotationView..::..IsPrivate Property
AnnotationView Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


Text Property

[image]

IceLib Technical Reference
AnnotationView..::..Text Property
AnnotationView Class See Also Send Feedback
Gets or sets the text. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Field Value

The text, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
AnnotationView..::..Version Property
AnnotationView Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AnnotationView Class
AnnotationView Members
ININ.IceLib.Tracker Namespace


AppliesToTypes Enumeration

[image]

IceLib Technical Reference
AppliesToTypes Enumeration
See Also Send Feedback
This enum consists of a set of Tracker types that certain methods use to limit their result set. For instance, the method GetTrackerAttributeTypes(AppliesToTypes) uses this enum to determine which TrackerAttributeTypes to fetch. An input value of AppliesToTypes.Individuals would cause the Tracker subsystem to return only TrackerAttributeTypes that are used for Individuals.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum AppliesToTypes
Visual Basic
<FlagsAttribute> _
Public Enumeration AppliesToTypes

Members

Member name | Value | Description
All | 15 | This action applies to Interactions, Individuals, Locations and Organizations.
Interactions | 1 | This action only applies to Interactions.
Individuals | 2 | This action only applies to Individuals.
Locations | 4 | This action only applies to Locations.
Organizations | 8 | This action only applies to Organizations.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


CanViewInteractionCompletedEventArgs Class

[image]

IceLib Technical Reference
CanViewInteractionCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the CanViewInteractionCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class CanViewInteractionCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class CanViewInteractionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..CanViewInteractionCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CanViewInteractionCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


CanViewInteractionCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
CanViewInteractionCompletedEventArgs Members
CanViewInteractionCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The CanViewInteractionCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CanViewInteractionCompletedEventArgs | Initializes a new instance of the CanViewInteractionCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | CanView | Gets a value indicating whether an Interaction can be viewed.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CanViewInteractionCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


CanViewInteractionCompletedEventArgs Constructor

[image]

IceLib Technical Reference
CanViewInteractionCompletedEventArgs Constructor
CanViewInteractionCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the CanViewInteractionCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CanViewInteractionCompletedEventArgs(
    bool canView,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    canView As Boolean, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

canView
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) can view.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CanViewInteractionCompletedEventArgs Class
CanViewInteractionCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


CanViewInteractionCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
CanViewInteractionCompletedEventArgs Methods
CanViewInteractionCompletedEventArgs Class See Also Send Feedback

The CanViewInteractionCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanViewInteractionCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


CanViewInteractionCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
CanViewInteractionCompletedEventArgs Properties
CanViewInteractionCompletedEventArgs Class See Also Send Feedback

The CanViewInteractionCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | CanView | Gets a value indicating whether an Interaction can be viewed.
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CanViewInteractionCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


CanView Property

[image]

IceLib Technical Reference
CanViewInteractionCompletedEventArgs..::..CanView Property
CanViewInteractionCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether an Interaction can be viewed.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanView { get; }
Visual Basic
Public ReadOnly Property CanView As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can view an Interaction; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

CanViewInteractionCompletedEventArgs Class
CanViewInteractionCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


DirectionType Enumeration

[image]

IceLib Technical Reference
DirectionType Enumeration
See Also Send Feedback
The direction types that an interaction can have.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum DirectionType
Visual Basic
Public Enumeration DirectionType

Members

Member name | Value | Description
Unknown | 0 | The direction is unknown.
Inbound | 1 | The direction is inbound.
Outbound | 2 | The direction is outbound.
Intercom | 3 | The interaction is an intercom interaction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class

[image]

IceLib Technical Reference
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetCurrentSegmentOrganizationIndividualCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetCurrentSegmentOrganizationIndividualCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetCurrentSegmentOrganizationIndividualCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetCurrentSegmentOrganizationIndividualCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetCurrentSegmentOrganizationIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividualCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Members
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetCurrentSegmentOrganizationIndividualCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetCurrentSegmentOrganizationIndividualCompletedEventArgs | Initializes a new instance of the GetOrganizationDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SegmentOrganizationIndividualDetails | Gets the segment organization individual details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividualCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Constructor
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetOrganizationDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetCurrentSegmentOrganizationIndividualCompletedEventArgs(
    SegmentOrganizationIndividualDetails segmentOrganizationIndividualDetails,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    segmentOrganizationIndividualDetails As SegmentOrganizationIndividualDetails, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

segmentOrganizationIndividualDetails
Type: ININ.IceLib.Tracker..::..SegmentOrganizationIndividualDetails
The SegmentOrganizationIndividualDetails.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividualCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Methods
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class See Also Send Feedback

The GetCurrentSegmentOrganizationIndividualCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividualCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Properties
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class See Also Send Feedback

The GetCurrentSegmentOrganizationIndividualCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SegmentOrganizationIndividualDetails | Gets the segment organization individual details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


SegmentOrganizationIndividualDetails Property

[image]

IceLib Technical Reference
GetCurrentSegmentOrganizationIndividualCompletedEventArgs..::..SegmentOrganizationIndividualDetails Property
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class See Also Send Feedback
Gets the segment organization individual details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SegmentOrganizationIndividualDetails SegmentOrganizationIndividualDetails { get; }
Visual Basic
Public ReadOnly Property SegmentOrganizationIndividualDetails As SegmentOrganizationIndividualDetails
    Get

Field Value

The segment organization individual details.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetCurrentSegmentOrganizationIndividualCompletedEventArgs Class
GetCurrentSegmentOrganizationIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformationCompletedEventArgs Class

[image]

IceLib Technical Reference
GetICUserIndividualInformationCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetICUserIndividualInformation event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetICUserIndividualInformationCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetICUserIndividualInformationCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetICUserIndividualInformationCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetICUserIndividualInformationCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformationCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetICUserIndividualInformationCompletedEventArgs Members
GetICUserIndividualInformationCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetICUserIndividualInformationCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetICUserIndividualInformationCompletedEventArgs | Initializes a new instance of the GetIndividualDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ICUserIndividualInformation | Gets the individual IC User information.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetICUserIndividualInformationCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformationCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetICUserIndividualInformationCompletedEventArgs Constructor
GetICUserIndividualInformationCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetIndividualDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetICUserIndividualInformationCompletedEventArgs(
    ICUserIndividualInformation icUserIndividualInformation,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    icUserIndividualInformation As ICUserIndividualInformation, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

icUserIndividualInformation
Type: ININ.IceLib.Tracker..::..ICUserIndividualInformation
The ICUserIndividualInformation.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetICUserIndividualInformationCompletedEventArgs Class
GetICUserIndividualInformationCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformationCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetICUserIndividualInformationCompletedEventArgs Methods
GetICUserIndividualInformationCompletedEventArgs Class See Also Send Feedback

The GetICUserIndividualInformationCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetICUserIndividualInformationCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformationCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetICUserIndividualInformationCompletedEventArgs Properties
GetICUserIndividualInformationCompletedEventArgs Class See Also Send Feedback

The GetICUserIndividualInformationCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ICUserIndividualInformation | Gets the individual IC User information.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetICUserIndividualInformationCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


ICUserIndividualInformation Property

[image]

IceLib Technical Reference
GetICUserIndividualInformationCompletedEventArgs..::..ICUserIndividualInformation Property
GetICUserIndividualInformationCompletedEventArgs Class See Also Send Feedback
Gets the individual IC User information.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICUserIndividualInformation ICUserIndividualInformation { get; }
Visual Basic
Public ReadOnly Property ICUserIndividualInformation As ICUserIndividualInformation
    Get

Field Value

These details include the individual ID, organization ID and location ID of the individual as well as a security checksum.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetICUserIndividualInformationCompletedEventArgs Class
GetICUserIndividualInformationCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetIndividualDetailsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetIndividualDetailsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetIndividualDetailsCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetIndividualDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetIndividualDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetIndividualDetailsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetIndividualDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetIndividualDetailsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetIndividualDetailsCompletedEventArgs Members
GetIndividualDetailsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetIndividualDetailsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetIndividualDetailsCompletedEventArgs | Initializes a new instance of the GetIndividualDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | IndividualDetails | Gets the individual details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetIndividualDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetIndividualDetailsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetIndividualDetailsCompletedEventArgs Constructor
GetIndividualDetailsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetIndividualDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetIndividualDetailsCompletedEventArgs(
    IndividualDetails individualDetails,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    individualDetails As IndividualDetails, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

individualDetails
Type: ININ.IceLib.Tracker..::..IndividualDetails
The IndividualDetails.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetIndividualDetailsCompletedEventArgs Class
GetIndividualDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetIndividualDetailsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetIndividualDetailsCompletedEventArgs Methods
GetIndividualDetailsCompletedEventArgs Class See Also Send Feedback

The GetIndividualDetailsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetIndividualDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetIndividualDetailsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetIndividualDetailsCompletedEventArgs Properties
GetIndividualDetailsCompletedEventArgs Class See Also Send Feedback

The GetIndividualDetailsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | IndividualDetails | Gets the individual details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetIndividualDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


IndividualDetails Property

[image]

IceLib Technical Reference
GetIndividualDetailsCompletedEventArgs..::..IndividualDetails Property
GetIndividualDetailsCompletedEventArgs Class See Also Send Feedback
Gets the individual details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualDetails IndividualDetails { get; }
Visual Basic
Public ReadOnly Property IndividualDetails As IndividualDetails
    Get

Field Value

These details include the individual, address, interaction address, Tracker attribute views, location and organization.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetIndividualDetailsCompletedEventArgs Class
GetIndividualDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetInteractionDetailsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetInteractionDetailsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetInteractionDetailsCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetInteractionDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetInteractionDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetInteractionDetailsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetInteractionDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetInteractionDetailsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetInteractionDetailsCompletedEventArgs Members
GetInteractionDetailsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetInteractionDetailsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetInteractionDetailsCompletedEventArgs | Initializes a new instance of the GetInteractionDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionDetails | Gets the interaction details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetInteractionDetailsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetInteractionDetailsCompletedEventArgs Constructor
GetInteractionDetailsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetInteractionDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetInteractionDetailsCompletedEventArgs(
    InteractionDetails interactionDetails,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    interactionDetails As InteractionDetails, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

interactionDetails
Type: ININ.IceLib.Tracker..::..InteractionDetails
The InteractionDetails.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetInteractionDetailsCompletedEventArgs Class
GetInteractionDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetInteractionDetailsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetInteractionDetailsCompletedEventArgs Methods
GetInteractionDetailsCompletedEventArgs Class See Also Send Feedback

The GetInteractionDetailsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInteractionDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetInteractionDetailsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetInteractionDetailsCompletedEventArgs Properties
GetInteractionDetailsCompletedEventArgs Class See Also Send Feedback

The GetInteractionDetailsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | InteractionDetails | Gets the interaction details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInteractionDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


InteractionDetails Property

[image]

IceLib Technical Reference
GetInteractionDetailsCompletedEventArgs..::..InteractionDetails Property
GetInteractionDetailsCompletedEventArgs Class See Also Send Feedback
Gets the interaction details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionDetails InteractionDetails { get; }
Visual Basic
Public ReadOnly Property InteractionDetails As InteractionDetails
    Get

Field Value

The interaction details.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetInteractionDetailsCompletedEventArgs Class
GetInteractionDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetLocationDetailsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetLocationDetailsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetLocationDetailsCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetLocationDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetLocationDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetLocationDetailsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetLocationDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetLocationDetailsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetLocationDetailsCompletedEventArgs Members
GetLocationDetailsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetLocationDetailsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetLocationDetailsCompletedEventArgs | Initializes a new instance of the GetLocationDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LocationDetails | Gets the location details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetLocationDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetLocationDetailsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetLocationDetailsCompletedEventArgs Constructor
GetLocationDetailsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetLocationDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetLocationDetailsCompletedEventArgs(
    LocationDetails locationDetails,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    locationDetails As LocationDetails, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

locationDetails
Type: ININ.IceLib.Tracker..::..LocationDetails
The LocationDetails.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetLocationDetailsCompletedEventArgs Class
GetLocationDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetLocationDetailsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetLocationDetailsCompletedEventArgs Methods
GetLocationDetailsCompletedEventArgs Class See Also Send Feedback

The GetLocationDetailsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetLocationDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetLocationDetailsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetLocationDetailsCompletedEventArgs Properties
GetLocationDetailsCompletedEventArgs Class See Also Send Feedback

The GetLocationDetailsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LocationDetails | Gets the location details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetLocationDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


LocationDetails Property

[image]

IceLib Technical Reference
GetLocationDetailsCompletedEventArgs..::..LocationDetails Property
GetLocationDetailsCompletedEventArgs Class See Also Send Feedback
Gets the location details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationDetails LocationDetails { get; }
Visual Basic
Public ReadOnly Property LocationDetails As LocationDetails
    Get

Field Value

These location details provide the location, LocationAddresses, LocationInteractionAddresses, interaction addresses, location Tracker attribute view, and name of the organization.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetLocationDetailsCompletedEventArgs Class
GetLocationDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetOrganizationDetailsCompletedEventArgs Class

[image]

IceLib Technical Reference
GetOrganizationDetailsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetOrganizationDetailsCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetOrganizationDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetOrganizationDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetOrganizationDetailsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetOrganizationDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetOrganizationDetailsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetOrganizationDetailsCompletedEventArgs Members
GetOrganizationDetailsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetOrganizationDetailsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetOrganizationDetailsCompletedEventArgs | Initializes a new instance of the GetOrganizationDetailsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | OrganizationDetails | Gets the organization details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrganizationDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetOrganizationDetailsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetOrganizationDetailsCompletedEventArgs Constructor
GetOrganizationDetailsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetOrganizationDetailsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetOrganizationDetailsCompletedEventArgs(
    OrganizationDetails organizationDetails,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    organizationDetails As OrganizationDetails, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

organizationDetails
Type: ININ.IceLib.Tracker..::..OrganizationDetails
The OrganizationDetails.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetOrganizationDetailsCompletedEventArgs Class
GetOrganizationDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetOrganizationDetailsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetOrganizationDetailsCompletedEventArgs Methods
GetOrganizationDetailsCompletedEventArgs Class See Also Send Feedback

The GetOrganizationDetailsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetOrganizationDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetOrganizationDetailsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetOrganizationDetailsCompletedEventArgs Properties
GetOrganizationDetailsCompletedEventArgs Class See Also Send Feedback

The GetOrganizationDetailsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | OrganizationDetails | Gets the organization details.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrganizationDetailsCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


OrganizationDetails Property

[image]

IceLib Technical Reference
GetOrganizationDetailsCompletedEventArgs..::..OrganizationDetails Property
GetOrganizationDetailsCompletedEventArgs Class See Also Send Feedback
Gets the organization details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationDetails OrganizationDetails { get; }
Visual Basic
Public ReadOnly Property OrganizationDetails As OrganizationDetails
    Get

Field Value

The organization details include the location views, Organization, organization addresses, interaction addresses, and the organization Tracker attribute views.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetOrganizationDetailsCompletedEventArgs Class
GetOrganizationDetailsCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividualCompletedEventArgs Class

[image]

IceLib Technical Reference
GetPossibleDuplicateIndividualCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetPossibleDuplicateIndividualCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class GetPossibleDuplicateIndividualCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetPossibleDuplicateIndividualCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..GetPossibleDuplicateIndividualCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetPossibleDuplicateIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividualCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
GetPossibleDuplicateIndividualCompletedEventArgs Members
GetPossibleDuplicateIndividualCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetPossibleDuplicateIndividualCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetPossibleDuplicateIndividualCompletedEventArgs | Initializes a new instance of the GetPossibleDuplicateIndividualCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | IndividualId | Gets the Individual ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPossibleDuplicateIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividualCompletedEventArgs Constructor

[image]

IceLib Technical Reference
GetPossibleDuplicateIndividualCompletedEventArgs Constructor
GetPossibleDuplicateIndividualCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetPossibleDuplicateIndividualCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public GetPossibleDuplicateIndividualCompletedEventArgs(
    string individualId,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    individualId As String, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetPossibleDuplicateIndividualCompletedEventArgs Class
GetPossibleDuplicateIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividualCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
GetPossibleDuplicateIndividualCompletedEventArgs Methods
GetPossibleDuplicateIndividualCompletedEventArgs Class See Also Send Feedback

The GetPossibleDuplicateIndividualCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPossibleDuplicateIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividualCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
GetPossibleDuplicateIndividualCompletedEventArgs Properties
GetPossibleDuplicateIndividualCompletedEventArgs Class See Also Send Feedback

The GetPossibleDuplicateIndividualCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | IndividualId | Gets the Individual ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPossibleDuplicateIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
GetPossibleDuplicateIndividualCompletedEventArgs..::..IndividualId Property
GetPossibleDuplicateIndividualCompletedEventArgs Class See Also Send Feedback
Gets the Individual ID associated with the event.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; }
Visual Basic
Public ReadOnly Property IndividualId As String
    Get

Field Value

The Individual ID.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

GetPossibleDuplicateIndividualCompletedEventArgs Class
GetPossibleDuplicateIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


HowEnded Enumeration

[image]

IceLib Technical Reference
HowEnded Enumeration
See Also Send Feedback
This enum consists of a set of Tracker types that describe a given Segment.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum HowEnded
Visual Basic
Public Enumeration HowEnded

Members

Member name | Value | Description
NotEnded | 0 | The segment has not ended.
Disconnect | 1 | The segment was disconnected.
LocalDisconnect | 2 | The segment was locally disconnected.
RemoteDisconnect | 3 | The segment was remotely disconnected.
Transfer | 4 | The segment was transferred.
LocalTransfer | 5 | The segment was locally transferred.
RemoteTransfer | 6 | The segment was remotely transferred.
Conference | 7 | The segment was conferenced.
System | 8 | The segment was sent to the system.
Connect | 9 | The segment was connected.
Messaging | 10 | The segment was messaging.
Alert | 11 | The segment was alerted.
Hold | 12 | The segment was held.
Retrieve | 13 | The segment was retrieved.
Park | 14 | The segment was parked.
ConsultTransfer | 15 | The segment was consult transferred.
Grabbed | 16 | The segment was grabbed.
WorkgroupChanged | 17 | The servicing workgroup changed (maybe to none)
IVR | 18 | The segment went into IVR.
Suspend | 19 | The segment was suspended.
Delay | 20 | The segment went into a wait (usually in a workgroup queue).
Survey | 21 | The segment went into survey/feedback.
Snoozed | 22 | The segment went into snooze.
Dialing | 23 | The segment went into dialing.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


ICUserId Class

[image]

IceLib Technical Reference
ICUserId Class
Members See Also Send Feedback
Represents an IC user ID within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ICUserId
Visual Basic
Public Class ICUserId

Remarks

Provides a mapping of IC user IDs to Tracker IndividualIds.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ICUserId

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserId Members
ININ.IceLib.Tracker Namespace


ICUserId Members

[image] [image]

IceLib Technical Reference
ICUserId Members
ICUserId Class Constructors Methods Properties See Also Send Feedback

The ICUserId type exposes the following members.

Constructors

 | Name | Description
Public method | ICUserId | Initializes a new instance of the ICUserId class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | UserId | Gets or sets the user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

ICUserId Class
ININ.IceLib.Tracker Namespace


ICUserId Constructor

[image]

IceLib Technical Reference
ICUserId Constructor
ICUserId Class See Also Send Feedback
Initializes a new instance of the ICUserId class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICUserId()
Visual Basic
Public Sub New

See Also

ICUserId Class
ICUserId Members
ININ.IceLib.Tracker Namespace


ICUserId Methods

[image] [image]

IceLib Technical Reference
ICUserId Methods
ICUserId Class See Also Send Feedback

The ICUserId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ICUserId Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
ICUserId..::..Reset Method
ICUserId Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserId Class
ICUserId Members
ININ.IceLib.Tracker Namespace


ICUserId Properties

[image] [image]

IceLib Technical Reference
ICUserId Properties
ICUserId Class See Also Send Feedback

The ICUserId type exposes the following members.

Properties

 | Name | Description
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | UserId | Gets or sets the user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

ICUserId Class
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
ICUserId..::..IndividualId Property
ICUserId Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserId Class
ICUserId Members
ININ.IceLib.Tracker Namespace


UserId Property

[image]

IceLib Technical Reference
ICUserId..::..UserId Property
ICUserId Class See Also Send Feedback
Gets or sets the user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set

Field Value

The user ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserId Class
ICUserId Members
ININ.IceLib.Tracker Namespace


ICUserIndividualInformation Class

[image]

IceLib Technical Reference
ICUserIndividualInformation Class
Members See Also Send Feedback
Helper class to contain the results of the GetICUserIndividualInformation(String) methods.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ICUserIndividualInformation
Visual Basic
Public Class ICUserIndividualInformation

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ICUserIndividualInformation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserIndividualInformation Members
ININ.IceLib.Tracker Namespace


ICUserIndividualInformation Members

[image] [image]

IceLib Technical Reference
ICUserIndividualInformation Members
ICUserIndividualInformation Class Methods Properties See Also Send Feedback

The ICUserIndividualInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IndividualId | Gets the Individual ID.
Public property | LocationId | Gets the Location ID.
Public property | OrganizationId | Gets the Organization ID.
Public property | SecurityChecksum | Gets the security checksum.

See Also

ICUserIndividualInformation Class
ININ.IceLib.Tracker Namespace


ICUserIndividualInformation Methods

[image] [image]

IceLib Technical Reference
ICUserIndividualInformation Methods
ICUserIndividualInformation Class See Also Send Feedback

The ICUserIndividualInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ICUserIndividualInformation Class
ININ.IceLib.Tracker Namespace


ICUserIndividualInformation Properties

[image] [image]

IceLib Technical Reference
ICUserIndividualInformation Properties
ICUserIndividualInformation Class See Also Send Feedback

The ICUserIndividualInformation type exposes the following members.

Properties

 | Name | Description
Public property | IndividualId | Gets the Individual ID.
Public property | LocationId | Gets the Location ID.
Public property | OrganizationId | Gets the Organization ID.
Public property | SecurityChecksum | Gets the security checksum.

See Also

ICUserIndividualInformation Class
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
ICUserIndividualInformation..::..IndividualId Property
ICUserIndividualInformation Class See Also Send Feedback
Gets the Individual ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; }
Visual Basic
Public ReadOnly Property IndividualId As String
    Get

Field Value

The Individual ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserIndividualInformation Class
ICUserIndividualInformation Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
ICUserIndividualInformation..::..LocationId Property
ICUserIndividualInformation Class See Also Send Feedback
Gets the Location ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; }
Visual Basic
Public ReadOnly Property LocationId As String
    Get

Field Value

The Location ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserIndividualInformation Class
ICUserIndividualInformation Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
ICUserIndividualInformation..::..OrganizationId Property
ICUserIndividualInformation Class See Also Send Feedback
Gets the Organization ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; }
Visual Basic
Public ReadOnly Property OrganizationId As String
    Get

Field Value

The Organization ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserIndividualInformation Class
ICUserIndividualInformation Members
ININ.IceLib.Tracker Namespace


SecurityChecksum Property

[image]

IceLib Technical Reference
ICUserIndividualInformation..::..SecurityChecksum Property
ICUserIndividualInformation Class See Also Send Feedback
Gets the security checksum.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long SecurityChecksum { get; }
Visual Basic
Public ReadOnly Property SecurityChecksum As Long
    Get

Field Value

The security checksum.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ICUserIndividualInformation Class
ICUserIndividualInformation Members
ININ.IceLib.Tracker Namespace


Individual Class

[image]

IceLib Technical Reference
Individual Class
Members See Also Send Feedback
Represents an individual within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Individual
Visual Basic
Public Class Individual

Remarks

Information about Tracker Contacts is stored in the Individuals table of the Tracker database. The IceLib Individual class provides a means for accessing and updating this information. For example, the GetIndividualDetails(String) method returns an Individual.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..Individual

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Members
ININ.IceLib.Tracker Namespace


Individual Members

[image] [image]

IceLib Technical Reference
Individual Members
Individual Class Constructors Methods Properties See Also Send Feedback

The Individual type exposes the following members.

Constructors

 | Name | Description
Public method | Individual | Initializes a new instance of the Individual class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationIndividualId | Gets or sets the application individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AssistantName | Gets or sets the name of the assistant. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Company | Gets or sets the company. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Department | Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalId | Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalSource | Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId | Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualImage | Gets or sets the individual image. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualTypeId | Gets or sets the individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualUrl | Gets or sets the individual URL. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsActive | Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | JobTitle | Gets or sets the job title. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TitleId | Gets or sets the title ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WebLogin | Gets or sets the web login. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WebPassword | Gets or sets the web password. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Individual Class
ININ.IceLib.Tracker Namespace


Individual Constructor

[image]

IceLib Technical Reference
Individual Constructor
Individual Class See Also Send Feedback
Initializes a new instance of the Individual class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Individual()
Visual Basic
Public Sub New

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


Individual Methods

[image] [image]

IceLib Technical Reference
Individual Methods
Individual Class See Also Send Feedback

The Individual type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Individual Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
Individual..::..Reset Method
Individual Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


Individual Properties

[image] [image]

IceLib Technical Reference
Individual Properties
Individual Class See Also Send Feedback

The Individual type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationIndividualId | Gets or sets the application individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AssistantName | Gets or sets the name of the assistant. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Company | Gets or sets the company. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Department | Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalId | Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalSource | Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId | Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualImage | Gets or sets the individual image. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualTypeId | Gets or sets the individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualUrl | Gets or sets the individual URL. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsActive | Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | JobTitle | Gets or sets the job title. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TitleId | Gets or sets the title ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WebLogin | Gets or sets the web login. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WebPassword | Gets or sets the web password. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Individual Class
ININ.IceLib.Tracker Namespace


ApplicationIndividualId Property

[image]

IceLib Technical Reference
Individual..::..ApplicationIndividualId Property
Individual Class See Also Send Feedback
Gets or sets the application individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationIndividualId { get; set; }
Visual Basic
Public Property ApplicationIndividualId As String
    Get
    Set

Field Value

The application individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


AssistantName Property

[image]

IceLib Technical Reference
Individual..::..AssistantName Property
Individual Class See Also Send Feedback
Gets or sets the name of the assistant. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistantName { get; set; }
Visual Basic
Public Property AssistantName As String
    Get
    Set

Field Value

The name of the assistant, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


Company Property

[image]

IceLib Technical Reference
Individual..::..Company Property
Individual Class See Also Send Feedback
Gets or sets the company. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set

Field Value

The company, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


Department Property

[image]

IceLib Technical Reference
Individual..::..Department Property
Individual Class See Also Send Feedback
Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; set; }
Visual Basic
Public Property Department As String
    Get
    Set

Field Value

The department, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
Individual..::..ExternalId Property
Individual Class See Also Send Feedback
Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
Individual..::..ExternalSource Property
Individual Class See Also Send Feedback
Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
Individual..::..FirstName Property
Individual Class See Also Send Feedback
Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


ICUserId Property

[image]

IceLib Technical Reference
Individual..::..ICUserId Property
Individual Class See Also Send Feedback
Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUserId { get; set; }
Visual Basic
Public Property ICUserId As String
    Get
    Set

Field Value

The IC user ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
Individual..::..IndividualId Property
Individual Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IndividualImage Property

[image]

IceLib Technical Reference
Individual..::..IndividualImage Property
Individual Class See Also Send Feedback
Gets or sets the individual image. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualImage { get; set; }
Visual Basic
Public Property IndividualImage As String
    Get
    Set

Field Value

The individual image, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IndividualTypeId Property

[image]

IceLib Technical Reference
Individual..::..IndividualTypeId Property
Individual Class See Also Send Feedback
Gets or sets the individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> IndividualTypeId { get; set; }
Visual Basic
Public Property IndividualTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The individual type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IndividualUrl Property

[image]

IceLib Technical Reference
Individual..::..IndividualUrl Property
Individual Class See Also Send Feedback
Gets or sets the individual URL. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualUrl { get; set; }
Visual Basic
Public Property IndividualUrl As String
    Get
    Set

Field Value

The individual URL, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IsActive Property

[image]

IceLib Technical Reference
Individual..::..IsActive Property
Individual Class See Also Send Feedback
Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsActive { get; set; }
Visual Basic
Public Property IsActive As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
Individual..::..IsPrivate Property
Individual Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


JobTitle Property

[image]

IceLib Technical Reference
Individual..::..JobTitle Property
Individual Class See Also Send Feedback
Gets or sets the job title. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string JobTitle { get; set; }
Visual Basic
Public Property JobTitle As String
    Get
    Set

Field Value

The job title, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
Individual..::..LastName Property
Individual Class See Also Send Feedback
Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The last name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
Individual..::..LocationId Property
Individual Class See Also Send Feedback
Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


MiddleName Property

[image]

IceLib Technical Reference
Individual..::..MiddleName Property
Individual Class See Also Send Feedback
Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic
Public Property MiddleName As String
    Get
    Set

Field Value

The middle name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


ModifyDateTime Property

[image]

IceLib Technical Reference
Individual..::..ModifyDateTime Property
Individual Class See Also Send Feedback
Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> ModifyDateTime { get; internal set; }
Visual Basic
Public Property ModifyDateTime As Nullable(Of DateTime)
    Get
    Friend Set

Field Value

The modify date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
Individual..::..OrganizationId Property
Individual Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


OwnerId Property

[image]

IceLib Technical Reference
Individual..::..OwnerId Property
Individual Class See Also Send Feedback
Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

Field Value

The owner ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


SiteId Property

[image]

IceLib Technical Reference
Individual..::..SiteId Property
Individual Class See Also Send Feedback
Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> SiteId { get; set; }
Visual Basic
Public Property SiteId As Nullable(Of Long)
    Get
    Set

Field Value

The site ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


TitleId Property

[image]

IceLib Technical Reference
Individual..::..TitleId Property
Individual Class See Also Send Feedback
Gets or sets the title ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> TitleId { get; set; }
Visual Basic
Public Property TitleId As Nullable(Of Long)
    Get
    Set

Field Value

The title ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
Individual..::..Version Property
Individual Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


WebLogin Property

[image]

IceLib Technical Reference
Individual..::..WebLogin Property
Individual Class See Also Send Feedback
Gets or sets the web login. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WebLogin { get; set; }
Visual Basic
Public Property WebLogin As String
    Get
    Set

Field Value

The web login, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


WebPassword Property

[image]

IceLib Technical Reference
Individual..::..WebPassword Property
Individual Class See Also Send Feedback
Gets or sets the web password. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WebPassword { get; set; }
Visual Basic
Public Property WebPassword As String
    Get
    Set

Field Value

The web password, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Individual Class
Individual Members
ININ.IceLib.Tracker Namespace


IndividualAddress Class

[image]

IceLib Technical Reference
IndividualAddress Class
Members See Also Send Feedback
Represents an individual address within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class IndividualAddress
Visual Basic
Public Class IndividualAddress

Remarks

Provides a way to assign Tracker addresses to Individuals.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..IndividualAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Members
ININ.IceLib.Tracker Namespace


IndividualAddress Members

[image] [image]

IceLib Technical Reference
IndividualAddress Members
IndividualAddress Class Constructors Methods Properties See Also Send Feedback

The IndividualAddress type exposes the following members.

Constructors

 | Name | Description
Public method | IndividualAddress | Initializes a new instance of the IndividualAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressInstanceId | Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AddressTypeId | Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualAddress Class
ININ.IceLib.Tracker Namespace


IndividualAddress Constructor

[image]

IceLib Technical Reference
IndividualAddress Constructor
IndividualAddress Class See Also Send Feedback
Initializes a new instance of the IndividualAddress class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualAddress()
Visual Basic
Public Sub New

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


IndividualAddress Methods

[image] [image]

IceLib Technical Reference
IndividualAddress Methods
IndividualAddress Class See Also Send Feedback

The IndividualAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndividualAddress Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
IndividualAddress..::..Reset Method
IndividualAddress Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


IndividualAddress Properties

[image] [image]

IceLib Technical Reference
IndividualAddress Properties
IndividualAddress Class See Also Send Feedback

The IndividualAddress type exposes the following members.

Properties

 | Name | Description
Public property | AddressInstanceId | Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AddressTypeId | Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualAddress Class
ININ.IceLib.Tracker Namespace


AddressInstanceId Property

[image]

IceLib Technical Reference
IndividualAddress..::..AddressInstanceId Property
IndividualAddress Class See Also Send Feedback
Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AddressInstanceId { get; set; }
Visual Basic
Public Property AddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


AddressTypeId Property

[image]

IceLib Technical Reference
IndividualAddress..::..AddressTypeId Property
IndividualAddress Class See Also Send Feedback
Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AddressTypeId { get; set; }
Visual Basic
Public Property AddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
IndividualAddress..::..City Property
IndividualAddress Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
IndividualAddress..::..Country Property
IndividualAddress Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
IndividualAddress..::..IndividualId Property
IndividualAddress Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


IsDefault Property

[image]

IceLib Technical Reference
IndividualAddress..::..IsDefault Property
IndividualAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


State Property

[image]

IceLib Technical Reference
IndividualAddress..::..State Property
IndividualAddress Class See Also Send Feedback
Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set

Field Value

The state, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


StreetAddress Property

[image]

IceLib Technical Reference
IndividualAddress..::..StreetAddress Property
IndividualAddress Class See Also Send Feedback
Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StreetAddress { get; set; }
Visual Basic
Public Property StreetAddress As String
    Get
    Set

Field Value

The street address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


SystemInsertDate Property

[image]

IceLib Technical Reference
IndividualAddress..::..SystemInsertDate Property
IndividualAddress Class See Also Send Feedback
Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> SystemInsertDate { get; set; }
Visual Basic
Public Property SystemInsertDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The system insert date, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
IndividualAddress..::..Version Property
IndividualAddress Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


Zip Property

[image]

IceLib Technical Reference
IndividualAddress..::..Zip Property
IndividualAddress Class See Also Send Feedback
Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Zip { get; set; }
Visual Basic
Public Property Zip As String
    Get
    Set

Field Value

The zip, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualAddress Class
IndividualAddress Members
ININ.IceLib.Tracker Namespace


IndividualDetails Class

[image]

IceLib Technical Reference
IndividualDetails Class
Members See Also Send Feedback
Helper class to contain the results of the GetIndividualDetails(String) methods.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class IndividualDetails
Visual Basic
Public Class IndividualDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..IndividualDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Members
ININ.IceLib.Tracker Namespace


IndividualDetails Members

[image] [image]

IceLib Technical Reference
IndividualDetails Members
IndividualDetails Class Methods Properties See Also Send Feedback

The IndividualDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Individual | Gets the individual.
Public property | IndividualAddresses | Gets the individual addresses.
Public property | IndividualInteractionAddresses | Gets the individual interaction addresses.
Public property | IndividualTrackerAttributeViews | Gets the individual Tracker attribute views.
Public property | LocationName | Gets the name of the location.
Public property | OrganizationName | Gets the name of the organization.

See Also

IndividualDetails Class
ININ.IceLib.Tracker Namespace


IndividualDetails Methods

[image] [image]

IceLib Technical Reference
IndividualDetails Methods
IndividualDetails Class See Also Send Feedback

The IndividualDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndividualDetails Class
ININ.IceLib.Tracker Namespace


IndividualDetails Properties

[image] [image]

IceLib Technical Reference
IndividualDetails Properties
IndividualDetails Class See Also Send Feedback

The IndividualDetails type exposes the following members.

Properties

 | Name | Description
Public property | Individual | Gets the individual.
Public property | IndividualAddresses | Gets the individual addresses.
Public property | IndividualInteractionAddresses | Gets the individual interaction addresses.
Public property | IndividualTrackerAttributeViews | Gets the individual Tracker attribute views.
Public property | LocationName | Gets the name of the location.
Public property | OrganizationName | Gets the name of the organization.

See Also

IndividualDetails Class
ININ.IceLib.Tracker Namespace


Individual Property

[image]

IceLib Technical Reference
IndividualDetails..::..Individual Property
IndividualDetails Class See Also Send Feedback
Gets the individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Individual Individual { get; }
Visual Basic
Public ReadOnly Property Individual As Individual
    Get

Field Value

The individual.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Class
IndividualDetails Members
ININ.IceLib.Tracker Namespace


IndividualAddresses Property

[image]

IceLib Technical Reference
IndividualDetails..::..IndividualAddresses Property
IndividualDetails Class See Also Send Feedback
Gets the individual addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<IndividualAddress> IndividualAddresses { get; }
Visual Basic
Public ReadOnly Property IndividualAddresses As ReadOnlyCollection(Of IndividualAddress)
    Get

Field Value

The individual addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Class
IndividualDetails Members
ININ.IceLib.Tracker Namespace


IndividualInteractionAddresses Property

[image]

IceLib Technical Reference
IndividualDetails..::..IndividualInteractionAddresses Property
IndividualDetails Class See Also Send Feedback
Gets the individual interaction addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<IndividualInteractionAddress> IndividualInteractionAddresses { get; }
Visual Basic
Public ReadOnly Property IndividualInteractionAddresses As ReadOnlyCollection(Of IndividualInteractionAddress)
    Get

Field Value

The individual interaction addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Class
IndividualDetails Members
ININ.IceLib.Tracker Namespace


IndividualTrackerAttributeViews Property

[image]

IceLib Technical Reference
IndividualDetails..::..IndividualTrackerAttributeViews Property
IndividualDetails Class See Also Send Feedback
Gets the individual Tracker attribute views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TrackerAttributeView> IndividualTrackerAttributeViews { get; }
Visual Basic
Public ReadOnly Property IndividualTrackerAttributeViews As ReadOnlyCollection(Of TrackerAttributeView)
    Get

Field Value

The individual Tracker attribute views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Class
IndividualDetails Members
ININ.IceLib.Tracker Namespace


LocationName Property

[image]

IceLib Technical Reference
IndividualDetails..::..LocationName Property
IndividualDetails Class See Also Send Feedback
Gets the name of the location.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationName { get; }
Visual Basic
Public ReadOnly Property LocationName As String
    Get

Field Value

The name of the location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Class
IndividualDetails Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
IndividualDetails..::..OrganizationName Property
IndividualDetails Class See Also Send Feedback
Gets the name of the organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; }
Visual Basic
Public ReadOnly Property OrganizationName As String
    Get

Field Value

The name of the organization.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualDetails Class
IndividualDetails Members
ININ.IceLib.Tracker Namespace


IndividualInteractionAddress Class

[image]

IceLib Technical Reference
IndividualInteractionAddress Class
Members See Also Send Feedback
Represents an individual interaction address within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class IndividualInteractionAddress
Visual Basic
Public Class IndividualInteractionAddress

Remarks

Provides a way to assign Tracker interaction addresses to Individuals.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..IndividualInteractionAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


IndividualInteractionAddress Members

[image] [image]

IceLib Technical Reference
IndividualInteractionAddress Members
IndividualInteractionAddress Class Constructors Methods Properties See Also Send Feedback

The IndividualInteractionAddress type exposes the following members.

Constructors

 | Name | Description
Public method | IndividualInteractionAddress | Initializes a new instance of the IndividualInteractionAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressSubtypeId | Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualInteractionAddress Class
ININ.IceLib.Tracker Namespace


IndividualInteractionAddress Constructor

[image]

IceLib Technical Reference
IndividualInteractionAddress Constructor
IndividualInteractionAddress Class See Also Send Feedback
Initializes a new instance of the IndividualInteractionAddress class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualInteractionAddress()
Visual Basic
Public Sub New

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


IndividualInteractionAddress Methods

[image] [image]

IceLib Technical Reference
IndividualInteractionAddress Methods
IndividualInteractionAddress Class See Also Send Feedback

The IndividualInteractionAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndividualInteractionAddress Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..Reset Method
IndividualInteractionAddress Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


IndividualInteractionAddress Properties

[image] [image]

IceLib Technical Reference
IndividualInteractionAddress Properties
IndividualInteractionAddress Class See Also Send Feedback

The IndividualInteractionAddress type exposes the following members.

Properties

 | Name | Description
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressSubtypeId | Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualInteractionAddress Class
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..IndividualId Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressInstanceId Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..InteractionAddressInstanceId Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressInstanceId { get; set; }
Visual Basic
Public Property InteractionAddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtypeId Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..InteractionAddressSubtypeId Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressSubtypeId { get; set; }
Visual Basic
Public Property InteractionAddressSubtypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address subtype ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressTypeId Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..InteractionAddressTypeId Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressTypeId { get; set; }
Visual Basic
Public Property InteractionAddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


IsDefault Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..IsDefault Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


SystemInsertDate Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..SystemInsertDate Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> SystemInsertDate { get; set; }
Visual Basic
Public Property SystemInsertDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The system insert date, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


Value Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..Value Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value (e.g. JohnDoe@mycompany.com, 555-1212, etc.), or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
IndividualInteractionAddress..::..Version Property
IndividualInteractionAddress Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualInteractionAddress Class
IndividualInteractionAddress Members
ININ.IceLib.Tracker Namespace


IndividualType Class

[image]

IceLib Technical Reference
IndividualType Class
Members See Also Send Feedback
Represents an individual type within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class IndividualType
Visual Basic
Public Class IndividualType

Remarks

IndividualTypes are used to classify Individuals within Tracker. The most important property of an IndividualType is the Name property. This property is what is usually displayed to users in applications. Typical IndividualType names are: Customer, External, IC User, and Partner. Each Individual contains an IndividualType member that is used to hold the type of the Individual that it represents.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..IndividualType

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualType Members
ININ.IceLib.Tracker Namespace


IndividualType Members

[image] [image]

IceLib Technical Reference
IndividualType Members
IndividualType Class Constructors Methods Properties See Also Send Feedback

The IndividualType type exposes the following members.

Constructors

 | Name | Description
Public method | IndividualType | Initializes a new instance of the IndividualType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualType Class
ININ.IceLib.Tracker Namespace


IndividualType Constructor

[image]

IceLib Technical Reference
IndividualType Constructor
IndividualType Class See Also Send Feedback
Initializes a new instance of the IndividualType class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualType()
Visual Basic
Public Sub New

See Also

IndividualType Class
IndividualType Members
ININ.IceLib.Tracker Namespace


IndividualType Methods

[image] [image]

IceLib Technical Reference
IndividualType Methods
IndividualType Class See Also Send Feedback

The IndividualType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndividualType Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
IndividualType..::..Reset Method
IndividualType Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualType Class
IndividualType Members
ININ.IceLib.Tracker Namespace


IndividualType Properties

[image] [image]

IceLib Technical Reference
IndividualType Properties
IndividualType Class See Also Send Feedback

The IndividualType type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualType Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
IndividualType..::..AdminEditable Property
IndividualType Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualType Class
IndividualType Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
IndividualType..::..Id Property
IndividualType Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualType Class
IndividualType Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
IndividualType..::..Name Property
IndividualType Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualType Class
IndividualType Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
IndividualType..::..Version Property
IndividualType Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualType Class
IndividualType Members
ININ.IceLib.Tracker Namespace


IndividualView Class

[image]

IceLib Technical Reference
IndividualView Class
Members See Also Send Feedback
Represents an individual view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class IndividualView
Visual Basic
Public Class IndividualView

Remarks

The IndividualView class is used by methods that return information about Individuals. One such method is the SearchIndividuals(SearchIndividualsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..IndividualView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Members
ININ.IceLib.Tracker Namespace


IndividualView Members

[image] [image]

IceLib Technical Reference
IndividualView Members
IndividualView Class Constructors Methods Properties See Also Send Feedback

The IndividualView type exposes the following members.

Constructors

 | Name | Description
Public method | IndividualView | Initializes a new instance of the IndividualView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue | Gets or sets the InteractionAddress value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the name of the location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Type | Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualView Class
ININ.IceLib.Tracker Namespace


IndividualView Constructor

[image]

IceLib Technical Reference
IndividualView Constructor
IndividualView Class See Also Send Feedback
Initializes a new instance of the IndividualView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualView()
Visual Basic
Public Sub New

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


IndividualView Methods

[image] [image]

IceLib Technical Reference
IndividualView Methods
IndividualView Class See Also Send Feedback

The IndividualView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndividualView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
IndividualView..::..Reset Method
IndividualView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


IndividualView Properties

[image] [image]

IceLib Technical Reference
IndividualView Properties
IndividualView Class See Also Send Feedback

The IndividualView type exposes the following members.

Properties

 | Name | Description
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue | Gets or sets the InteractionAddress value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the name of the location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Type | Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

IndividualView Class
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
IndividualView..::..FirstName Property
IndividualView Class See Also Send Feedback
Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
IndividualView..::..Id Property
IndividualView Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


InteractionAddressInstanceId Property

[image]

IceLib Technical Reference
IndividualView..::..InteractionAddressInstanceId Property
IndividualView Class See Also Send Feedback
Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressInstanceId { get; set; }
Visual Basic
Public Property InteractionAddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


InteractionAddressTypeId Property

[image]

IceLib Technical Reference
IndividualView..::..InteractionAddressTypeId Property
IndividualView Class See Also Send Feedback
Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressTypeId { get; set; }
Visual Basic
Public Property InteractionAddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


InteractionAddressValue Property

[image]

IceLib Technical Reference
IndividualView..::..InteractionAddressValue Property
IndividualView Class See Also Send Feedback
Gets or sets the InteractionAddress value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddressValue { get; set; }
Visual Basic
Public Property InteractionAddressValue As String
    Get
    Set

Field Value

The InteractionAddress value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
IndividualView..::..LastName Property
IndividualView Class See Also Send Feedback
Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The last name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


LocationName Property

[image]

IceLib Technical Reference
IndividualView..::..LocationName Property
IndividualView Class See Also Send Feedback
Gets or sets the name of the location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationName { get; set; }
Visual Basic
Public Property LocationName As String
    Get
    Set

Field Value

The name of the location, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
IndividualView..::..OrganizationName Property
IndividualView Class See Also Send Feedback
Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; set; }
Visual Basic
Public Property OrganizationName As String
    Get
    Set

Field Value

The name of the organization, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


Type Property

[image]

IceLib Technical Reference
IndividualView..::..Type Property
IndividualView Class See Also Send Feedback
Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

Field Value

The type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IndividualView Class
IndividualView Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtype Class

[image]

IceLib Technical Reference
InteractionAddressSubtype Class
Members See Also Send Feedback
Represents an interaction address subtype within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAddressSubtype
Visual Basic
Public Class InteractionAddressSubtype

Remarks

InteractionAddressSubtypes are used to further classify InteractionAddressTypes within Tracker. The most important property of an InteractionAddressSubtype is the Name property. This property is what is usually displayed to users in applications. Typical InteractionAddressSubtype names are: Assistant, Business2, Home2. Each IndividualInteractionAddress, LocationInteractionAddress, and OrganizationInteractionAddress contains an InteractionAddressSubtype member that is used to hold the address subtype that it represents. A typical IndividualInteractionAddress may contain an interaction address type of Phone and an interaction address subtype of Assistant.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..InteractionAddressSubtype

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtype Members

[image] [image]

IceLib Technical Reference
InteractionAddressSubtype Members
InteractionAddressSubtype Class Constructors Methods Properties See Also Send Feedback

The InteractionAddressSubtype type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionAddressSubtype | Initializes a new instance of the InteractionAddressSubtype class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InsertionOrder | Gets or sets the insertion order. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionAddressSubtype Class
ININ.IceLib.Tracker Namespace


InteractionAddressSubtype Constructor

[image]

IceLib Technical Reference
InteractionAddressSubtype Constructor
InteractionAddressSubtype Class See Also Send Feedback
Initializes a new instance of the InteractionAddressSubtype class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAddressSubtype()
Visual Basic
Public Sub New

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtype Methods

[image] [image]

IceLib Technical Reference
InteractionAddressSubtype Methods
InteractionAddressSubtype Class See Also Send Feedback

The InteractionAddressSubtype type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionAddressSubtype Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
InteractionAddressSubtype..::..Reset Method
InteractionAddressSubtype Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtype Properties

[image] [image]

IceLib Technical Reference
InteractionAddressSubtype Properties
InteractionAddressSubtype Class See Also Send Feedback

The InteractionAddressSubtype type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InsertionOrder | Gets or sets the insertion order. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionAddressSubtype Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
InteractionAddressSubtype..::..AdminEditable Property
InteractionAddressSubtype Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
InteractionAddressSubtype..::..Id Property
InteractionAddressSubtype Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


InsertionOrder Property

[image]

IceLib Technical Reference
InteractionAddressSubtype..::..InsertionOrder Property
InteractionAddressSubtype Class See Also Send Feedback
Gets or sets the insertion order. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InsertionOrder { get; set; }
Visual Basic
Public Property InsertionOrder As Nullable(Of Long)
    Get
    Set

Field Value

The insertion order, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
InteractionAddressSubtype..::..Name Property
InteractionAddressSubtype Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
InteractionAddressSubtype..::..Version Property
InteractionAddressSubtype Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressSubtype Class
InteractionAddressSubtype Members
ININ.IceLib.Tracker Namespace


InteractionAddressType Class

[image]

IceLib Technical Reference
InteractionAddressType Class
Members See Also Send Feedback
Represents an interaction address type within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionAddressType
Visual Basic
Public Class InteractionAddressType

Remarks

InteractionAddressTypes are used to classify interaction addresses within Tracker. The most important property of an InteractionAddressType is the Name property. This property is what is usually displayed to users in applications. Typical InteractionAddressType names are: Chat, Email, Fax, and Pager. Each IndividualInteractionAddress, LocationInteractionAddress, and OrganizationInteractionAddress contains an InteractionAddressType member that is used to hold the address type that it represents. A typical IndividualInteractionAddress may contain an interaction address type of Phone and an interaction address subtype of Assistant.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..InteractionAddressType

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressType Members
ININ.IceLib.Tracker Namespace


InteractionAddressType Members

[image] [image]

IceLib Technical Reference
InteractionAddressType Members
InteractionAddressType Class Constructors Methods Properties See Also Send Feedback

The InteractionAddressType type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionAddressType | Initializes a new instance of the InteractionAddressType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionAddressType Class
ININ.IceLib.Tracker Namespace


InteractionAddressType Constructor

[image]

IceLib Technical Reference
InteractionAddressType Constructor
InteractionAddressType Class See Also Send Feedback
Initializes a new instance of the InteractionAddressType class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAddressType()
Visual Basic
Public Sub New

See Also

InteractionAddressType Class
InteractionAddressType Members
ININ.IceLib.Tracker Namespace


InteractionAddressType Methods

[image] [image]

IceLib Technical Reference
InteractionAddressType Methods
InteractionAddressType Class See Also Send Feedback

The InteractionAddressType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionAddressType Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
InteractionAddressType..::..Reset Method
InteractionAddressType Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressType Class
InteractionAddressType Members
ININ.IceLib.Tracker Namespace


InteractionAddressType Properties

[image] [image]

IceLib Technical Reference
InteractionAddressType Properties
InteractionAddressType Class See Also Send Feedback

The InteractionAddressType type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionAddressType Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
InteractionAddressType..::..AdminEditable Property
InteractionAddressType Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressType Class
InteractionAddressType Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
InteractionAddressType..::..Id Property
InteractionAddressType Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressType Class
InteractionAddressType Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
InteractionAddressType..::..Name Property
InteractionAddressType Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressType Class
InteractionAddressType Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
InteractionAddressType..::..Version Property
InteractionAddressType Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionAddressType Class
InteractionAddressType Members
ININ.IceLib.Tracker Namespace


InteractionDetails Class

[image]

IceLib Technical Reference
InteractionDetails Class
Members See Also Send Feedback
Helper class to contain the results from the GetInteractionDetails(String, String) methods.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionDetails
Visual Basic
Public Class InteractionDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..InteractionDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionDetails Members
ININ.IceLib.Tracker Namespace


InteractionDetails Members

[image] [image]

IceLib Technical Reference
InteractionDetails Members
InteractionDetails Class Methods Properties See Also Send Feedback

The InteractionDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnnotationViews | Gets the annotation views.
Public property | InteractionSegment | Gets the interaction segment.
Public property | ParticipantViews | Gets the participant views.
Public property | TrackerAttributeViews | Gets the Tracker attribute views.

See Also

InteractionDetails Class
ININ.IceLib.Tracker Namespace


InteractionDetails Methods

[image] [image]

IceLib Technical Reference
InteractionDetails Methods
InteractionDetails Class See Also Send Feedback

The InteractionDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionDetails Class
ININ.IceLib.Tracker Namespace


InteractionDetails Properties

[image] [image]

IceLib Technical Reference
InteractionDetails Properties
InteractionDetails Class See Also Send Feedback

The InteractionDetails type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationViews | Gets the annotation views.
Public property | InteractionSegment | Gets the interaction segment.
Public property | ParticipantViews | Gets the participant views.
Public property | TrackerAttributeViews | Gets the Tracker attribute views.

See Also

InteractionDetails Class
ININ.IceLib.Tracker Namespace


AnnotationViews Property

[image]

IceLib Technical Reference
InteractionDetails..::..AnnotationViews Property
InteractionDetails Class See Also Send Feedback
Gets the annotation views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<AnnotationView> AnnotationViews { get; }
Visual Basic
Public ReadOnly Property AnnotationViews As ReadOnlyCollection(Of AnnotationView)
    Get

Field Value

The annoation views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionDetails Class
InteractionDetails Members
ININ.IceLib.Tracker Namespace


InteractionSegment Property

[image]

IceLib Technical Reference
InteractionDetails..::..InteractionSegment Property
InteractionDetails Class See Also Send Feedback
Gets the interaction segment.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegment InteractionSegment { get; }
Visual Basic
Public ReadOnly Property InteractionSegment As InteractionSegment
    Get

Field Value

The interaction segment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionDetails Class
InteractionDetails Members
ININ.IceLib.Tracker Namespace


ParticipantViews Property

[image]

IceLib Technical Reference
InteractionDetails..::..ParticipantViews Property
InteractionDetails Class See Also Send Feedback
Gets the participant views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<InteractionParticipantView> ParticipantViews { get; }
Visual Basic
Public ReadOnly Property ParticipantViews As ReadOnlyCollection(Of InteractionParticipantView)
    Get

Field Value

The participant views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionDetails Class
InteractionDetails Members
ININ.IceLib.Tracker Namespace


TrackerAttributeViews Property

[image]

IceLib Technical Reference
InteractionDetails..::..TrackerAttributeViews Property
InteractionDetails Class See Also Send Feedback
Gets the Tracker attribute views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TrackerAttributeView> TrackerAttributeViews { get; }
Visual Basic
Public ReadOnly Property TrackerAttributeViews As ReadOnlyCollection(Of TrackerAttributeView)
    Get

Field Value

The Tracker attribute views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionDetails Class
InteractionDetails Members
ININ.IceLib.Tracker Namespace


InteractionParticipantView Class

[image]

IceLib Technical Reference
InteractionParticipantView Class
Members See Also Send Feedback
Represents an interaction participant view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionParticipantView
Visual Basic
Public Class InteractionParticipantView

Remarks

The InteractionParticipantView class is used by methods that return information about Participants. One such method is the GetInteractionDetails(String, String) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..InteractionParticipantView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


InteractionParticipantView Members

[image] [image]

IceLib Technical Reference
InteractionParticipantView Members
InteractionParticipantView Class Constructors Methods Properties See Also Send Feedback

The InteractionParticipantView type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionParticipantView | Initializes a new instance of the InteractionParticipantView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallIdKey | Gets or sets the call ID key. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DateOffset | Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName | Gets or sets the display name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Duration | Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | HowEnded | Gets or sets how the interaction ended. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue | Gets or sets the InteractionAddress value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionParticipantId | Gets or sets the interaction participant ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsRecorded | Gets or sets a value indicating whether this instance is recorded. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | RecordingStartOffset | Gets or sets the recording start offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | RecordingStopOffset | Gets or sets the recording stop offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Role | Gets or sets the role. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName | Gets or sets the name of the station. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WrapUpCode | Gets or sets the wrap up code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionParticipantView Class
ININ.IceLib.Tracker Namespace


InteractionParticipantView Constructor

[image]

IceLib Technical Reference
InteractionParticipantView Constructor
InteractionParticipantView Class See Also Send Feedback
Initializes a new instance of the InteractionParticipantView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionParticipantView()
Visual Basic
Public Sub New

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


InteractionParticipantView Methods

[image] [image]

IceLib Technical Reference
InteractionParticipantView Methods
InteractionParticipantView Class See Also Send Feedback

The InteractionParticipantView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionParticipantView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
InteractionParticipantView..::..Reset Method
InteractionParticipantView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


InteractionParticipantView Properties

[image] [image]

IceLib Technical Reference
InteractionParticipantView Properties
InteractionParticipantView Class See Also Send Feedback

The InteractionParticipantView type exposes the following members.

Properties

 | Name | Description
Public property | CallIdKey | Gets or sets the call ID key. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DateOffset | Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName | Gets or sets the display name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Duration | Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | HowEnded | Gets or sets how the interaction ended. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue | Gets or sets the InteractionAddress value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionParticipantId | Gets or sets the interaction participant ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsRecorded | Gets or sets a value indicating whether this instance is recorded. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | RecordingStartOffset | Gets or sets the recording start offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | RecordingStopOffset | Gets or sets the recording stop offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Role | Gets or sets the role. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName | Gets or sets the name of the station. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WrapUpCode | Gets or sets the wrap up code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionParticipantView Class
ININ.IceLib.Tracker Namespace


CallIdKey Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..CallIdKey Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the call ID key. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CallIdKey { get; set; }
Visual Basic
Public Property CallIdKey As String
    Get
    Set

Field Value

The call ID key, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


DateOffset Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..DateOffset Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> DateOffset { get; set; }
Visual Basic
Public Property DateOffset As Nullable(Of Long)
    Get
    Set

Field Value

The date offset, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


DisplayName Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..DisplayName Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the display name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The display name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


Duration Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..Duration Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Duration { get; set; }
Visual Basic
Public Property Duration As Nullable(Of Long)
    Get
    Set

Field Value

The duration, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..FirstName Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


HowEnded Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..HowEnded Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets how the interaction ended. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<HowEnded> HowEnded { get; set; }
Visual Basic
Public Property HowEnded As Nullable(Of HowEnded)
    Get
    Set

Field Value

How the interaction ended.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..IndividualId Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


InteractionAddressValue Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..InteractionAddressValue Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the InteractionAddress value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddressValue { get; set; }
Visual Basic
Public Property InteractionAddressValue As String
    Get
    Set

Field Value

The InteractionAddress value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


InteractionParticipantId Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..InteractionParticipantId Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the interaction participant ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionParticipantId { get; set; }
Visual Basic
Public Property InteractionParticipantId As String
    Get
    Set

Field Value

The interaction participant ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


IsRecorded Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..IsRecorded Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets a value indicating whether this instance is recorded. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsRecorded { get; set; }
Visual Basic
Public Property IsRecorded As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is recorded; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..LastName Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The last name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


MiddleName Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..MiddleName Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic
Public Property MiddleName As String
    Get
    Set

Field Value

The middle name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..OrganizationId Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..OrganizationName Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; set; }
Visual Basic
Public Property OrganizationName As String
    Get
    Set

Field Value

The name of the organization, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


RecordingStartOffset Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..RecordingStartOffset Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the recording start offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> RecordingStartOffset { get; set; }
Visual Basic
Public Property RecordingStartOffset As Nullable(Of Long)
    Get
    Set

Field Value

The recording start offset, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


RecordingStopOffset Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..RecordingStopOffset Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the recording stop offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> RecordingStopOffset { get; set; }
Visual Basic
Public Property RecordingStopOffset As Nullable(Of Long)
    Get
    Set

Field Value

The recording stop offset, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


Role Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..Role Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the role. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Role { get; set; }
Visual Basic
Public Property Role As Nullable(Of Long)
    Get
    Set

Field Value

The role, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


StartDateTime Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..StartDateTime Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> StartDateTime { get; set; }
Visual Basic
Public Property StartDateTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The start date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


StationName Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..StationName Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the name of the station. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationName { get; set; }
Visual Basic
Public Property StationName As String
    Get
    Set

Field Value

The name of the station, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


WrapUpCode Property

[image]

IceLib Technical Reference
InteractionParticipantView..::..WrapUpCode Property
InteractionParticipantView Class See Also Send Feedback
Gets or sets the wrap up code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WrapUpCode { get; set; }
Visual Basic
Public Property WrapUpCode As String
    Get
    Set

Field Value

The wrap up code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionParticipantView Class
InteractionParticipantView Members
ININ.IceLib.Tracker Namespace


InteractionSegment Class

[image]

IceLib Technical Reference
InteractionSegment Class
Members See Also Send Feedback
Represents an interaction segment within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionSegment
Visual Basic
Public Class InteractionSegment

Remarks

As interactions progress through an xIC system, they can be divided into segments. Segmentation occurs, for example, when a call is transfered from one party to another. The InteractionSegment class is used to store information about such segments.

The TrackerUser GetInteractionDetails(String, String) method can be used to retrieve segment information.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..InteractionSegment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Members
ININ.IceLib.Tracker Namespace


InteractionSegment Members

[image] [image]

IceLib Technical Reference
InteractionSegment Members
InteractionSegment Class Constructors Methods Properties See Also Send Feedback

The InteractionSegment type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionSegment | Initializes a new instance of the InteractionSegment class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the account code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationIncidentId | Gets or sets the application incident ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ConferenceId | Gets or sets the conference ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DateOffset | Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Direction | Gets or sets the direction. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Duration | Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EmailCc | Gets or sets the email CC. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EmailPriority | Gets or sets the email priority. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EmailSubject | Gets or sets the email subject. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionInstantiatedDateTime | Gets or sets the interaction instantiated date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | NextInteractionId | Gets or sets the next interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PreviousInteractionId | Gets or sets the previous interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentLog | Gets or sets the segment log. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentTypes | Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TypeId | Gets or sets the type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Workgroup | Gets or sets the workgroup. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionSegment Class
ININ.IceLib.Tracker Namespace


InteractionSegment Constructor

[image]

IceLib Technical Reference
InteractionSegment Constructor
InteractionSegment Class See Also Send Feedback
Initializes a new instance of the InteractionSegment class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionSegment()
Visual Basic
Public Sub New

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


InteractionSegment Methods

[image] [image]

IceLib Technical Reference
InteractionSegment Methods
InteractionSegment Class See Also Send Feedback

The InteractionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionSegment Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
InteractionSegment..::..Reset Method
InteractionSegment Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


InteractionSegment Properties

[image] [image]

IceLib Technical Reference
InteractionSegment Properties
InteractionSegment Class See Also Send Feedback

The InteractionSegment type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the account code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationIncidentId | Gets or sets the application incident ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ConferenceId | Gets or sets the conference ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DateOffset | Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Direction | Gets or sets the direction. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Duration | Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EmailCc | Gets or sets the email CC. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EmailPriority | Gets or sets the email priority. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EmailSubject | Gets or sets the email subject. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionInstantiatedDateTime | Gets or sets the interaction instantiated date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | NextInteractionId | Gets or sets the next interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PreviousInteractionId | Gets or sets the previous interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentLog | Gets or sets the segment log. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentTypes | Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TypeId | Gets or sets the type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Workgroup | Gets or sets the workgroup. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionSegment Class
ININ.IceLib.Tracker Namespace


AccountCode Property

[image]

IceLib Technical Reference
InteractionSegment..::..AccountCode Property
InteractionSegment Class See Also Send Feedback
Gets or sets the account code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCode { get; set; }
Visual Basic
Public Property AccountCode As String
    Get
    Set

Field Value

The account code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


ApplicationIncidentId Property

[image]

IceLib Technical Reference
InteractionSegment..::..ApplicationIncidentId Property
InteractionSegment Class See Also Send Feedback
Gets or sets the application incident ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationIncidentId { get; set; }
Visual Basic
Public Property ApplicationIncidentId As String
    Get
    Set

Field Value

The application incident ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


ConferenceId Property

[image]

IceLib Technical Reference
InteractionSegment..::..ConferenceId Property
InteractionSegment Class See Also Send Feedback
Gets or sets the conference ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> ConferenceId { get; set; }
Visual Basic
Public Property ConferenceId As Nullable(Of Long)
    Get
    Set

Field Value

The conference ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


DateOffset Property

[image]

IceLib Technical Reference
InteractionSegment..::..DateOffset Property
InteractionSegment Class See Also Send Feedback
Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> DateOffset { get; set; }
Visual Basic
Public Property DateOffset As Nullable(Of Long)
    Get
    Set

Field Value

The date offset, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


Direction Property

[image]

IceLib Technical Reference
InteractionSegment..::..Direction Property
InteractionSegment Class See Also Send Feedback
Gets or sets the direction. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Direction { get; set; }
Visual Basic
Public Property Direction As Nullable(Of Long)
    Get
    Set

Field Value

The direction, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


Duration Property

[image]

IceLib Technical Reference
InteractionSegment..::..Duration Property
InteractionSegment Class See Also Send Feedback
Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Duration { get; set; }
Visual Basic
Public Property Duration As Nullable(Of Long)
    Get
    Set

Field Value

The duration, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


EmailCc Property

[image]

IceLib Technical Reference
InteractionSegment..::..EmailCc Property
InteractionSegment Class See Also Send Feedback
Gets or sets the email CC. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailCc { get; set; }
Visual Basic
Public Property EmailCc As String
    Get
    Set

Field Value

The email CC, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


EmailPriority Property

[image]

IceLib Technical Reference
InteractionSegment..::..EmailPriority Property
InteractionSegment Class See Also Send Feedback
Gets or sets the email priority. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> EmailPriority { get; set; }
Visual Basic
Public Property EmailPriority As Nullable(Of Long)
    Get
    Set

Field Value

The email priority, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


EmailSubject Property

[image]

IceLib Technical Reference
InteractionSegment..::..EmailSubject Property
InteractionSegment Class See Also Send Feedback
Gets or sets the email subject. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EmailSubject { get; set; }
Visual Basic
Public Property EmailSubject As String
    Get
    Set

Field Value

The email subject, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
InteractionSegment..::..Id Property
InteractionSegment Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


InteractionInstantiatedDateTime Property

[image]

IceLib Technical Reference
InteractionSegment..::..InteractionInstantiatedDateTime Property
InteractionSegment Class See Also Send Feedback
Gets or sets the interaction instantiated date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> InteractionInstantiatedDateTime { get; set; }
Visual Basic
Public Property InteractionInstantiatedDateTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The interaction instantiated date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
InteractionSegment..::..IsPrivate Property
InteractionSegment Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


ModifyDateTime Property

[image]

IceLib Technical Reference
InteractionSegment..::..ModifyDateTime Property
InteractionSegment Class See Also Send Feedback
Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> ModifyDateTime { get; internal set; }
Visual Basic
Public Property ModifyDateTime As Nullable(Of DateTime)
    Get
    Friend Set

Field Value

The modify date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


NextInteractionId Property

[image]

IceLib Technical Reference
InteractionSegment..::..NextInteractionId Property
InteractionSegment Class See Also Send Feedback
Gets or sets the next interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string NextInteractionId { get; set; }
Visual Basic
Public Property NextInteractionId As String
    Get
    Set

Field Value

The next interaction ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


PreviousInteractionId Property

[image]

IceLib Technical Reference
InteractionSegment..::..PreviousInteractionId Property
InteractionSegment Class See Also Send Feedback
Gets or sets the previous interaction ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PreviousInteractionId { get; set; }
Visual Basic
Public Property PreviousInteractionId As String
    Get
    Set

Field Value

The previous interaction ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


SegmentLog Property

[image]

IceLib Technical Reference
InteractionSegment..::..SegmentLog Property
InteractionSegment Class See Also Send Feedback
Gets or sets the segment log. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SegmentLog { get; set; }
Visual Basic
Public Property SegmentLog As String
    Get
    Set

Field Value

The segment log, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


SegmentTypes Property

[image]

IceLib Technical Reference
InteractionSegment..::..SegmentTypes Property
InteractionSegment Class See Also Send Feedback
Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<SegmentTypes> SegmentTypes { get; set; }
Visual Basic
Public Property SegmentTypes As Nullable(Of SegmentTypes)
    Get
    Set

Field Value

The segment type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


SiteId Property

[image]

IceLib Technical Reference
InteractionSegment..::..SiteId Property
InteractionSegment Class See Also Send Feedback
Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> SiteId { get; set; }
Visual Basic
Public Property SiteId As Nullable(Of Long)
    Get
    Set

Field Value

The site ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


StartDateTime Property

[image]

IceLib Technical Reference
InteractionSegment..::..StartDateTime Property
InteractionSegment Class See Also Send Feedback
Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> StartDateTime { get; set; }
Visual Basic
Public Property StartDateTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The start date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


TypeId Property

[image]

IceLib Technical Reference
InteractionSegment..::..TypeId Property
InteractionSegment Class See Also Send Feedback
Gets or sets the type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> TypeId { get; set; }
Visual Basic
Public Property TypeId As Nullable(Of Long)
    Get
    Set

Field Value

The type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
InteractionSegment..::..Version Property
InteractionSegment Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


Workgroup Property

[image]

IceLib Technical Reference
InteractionSegment..::..Workgroup Property
InteractionSegment Class See Also Send Feedback
Gets or sets the workgroup. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; set; }
Visual Basic
Public Property Workgroup As String
    Get
    Set

Field Value

The workgroup, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionSegment Class
InteractionSegment Members
ININ.IceLib.Tracker Namespace


InteractionType Enumeration

[image]

IceLib Technical Reference
InteractionType Enumeration
See Also Send Feedback
Represents the various interaction types within Interaction Center.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum InteractionType
Visual Basic
Public Enumeration InteractionType

Members

Member name | Value | Description
Unknown | 0 | The type of interaction is unknown.
Call | 1 | The interaction is a call.
Chat | 2 | The interaction is a chat.
Email | 3 | The interaction is an email.
Fax | 4 | The interaction is a fax.
WebCollaboration | 5 | The interaction is a web collaboration.
InstantQuestion | 6 | The interaction is an instant question.
GenericObject | 7 | The interaction is a generic object.
WorkflowItem | 8 | The interaction is a workflow item.

Remarks

Use this enum wherever an interaction type is required. The TrackerSearch method SearchForResolutionCandidates(String, InteractionType, String, String, String, String, String, String) uses InteractionType.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


InteractionView Class

[image]

IceLib Technical Reference
InteractionView Class
Members See Also Send Feedback
Represents an interaction view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionView
Visual Basic
Public Class InteractionView

Remarks

The InteractionView class is used by methods that return information about interactions. One such method is the SearchInteractions(SearchInteractionsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..InteractionView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Members
ININ.IceLib.Tracker Namespace


InteractionView Members

[image] [image]

IceLib Technical Reference
InteractionView Members
InteractionView Class Constructors Methods Properties See Also Send Feedback

The InteractionView type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionView | Initializes a new instance of the InteractionView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConferenceId | Gets or sets the conference ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DateOffset | Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName1 | Gets or sets the display name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName2 | Gets or sets the display name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Duration | Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName1 | Gets or sets the first name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName2 | Gets or sets the first name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId1 | Gets or sets the IC user ID1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId2 | Gets or sets the IC user ID2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue1 | Gets or sets the InteractionAddress value1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue2 | Gets or sets the InteractionAddress value2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName1 | Gets or sets the last name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName2 | Gets or sets the last name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName1 | Gets or sets the organization name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName2 | Gets or sets the organization name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentTypes | Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName1 | Gets or sets the station name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName2 | Gets or sets the station name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Type | Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TypeId | Gets or sets the type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionView Class
ININ.IceLib.Tracker Namespace


InteractionView Constructor

[image]

IceLib Technical Reference
InteractionView Constructor
InteractionView Class See Also Send Feedback
Initializes a new instance of the InteractionView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionView()
Visual Basic
Public Sub New

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


InteractionView Methods

[image] [image]

IceLib Technical Reference
InteractionView Methods
InteractionView Class See Also Send Feedback

The InteractionView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
InteractionView..::..Reset Method
InteractionView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


InteractionView Properties

[image] [image]

IceLib Technical Reference
InteractionView Properties
InteractionView Class See Also Send Feedback

The InteractionView type exposes the following members.

Properties

 | Name | Description
Public property | ConferenceId | Gets or sets the conference ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DateOffset | Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName1 | Gets or sets the display name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName2 | Gets or sets the display name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Duration | Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName1 | Gets or sets the first name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName2 | Gets or sets the first name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId1 | Gets or sets the IC user ID1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId2 | Gets or sets the IC user ID2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue1 | Gets or sets the InteractionAddress value1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressValue2 | Gets or sets the InteractionAddress value2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName1 | Gets or sets the last name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName2 | Gets or sets the last name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName1 | Gets or sets the organization name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName2 | Gets or sets the organization name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentTypes | Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName1 | Gets or sets the station name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName2 | Gets or sets the station name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Type | Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TypeId | Gets or sets the type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

InteractionView Class
ININ.IceLib.Tracker Namespace


ConferenceId Property

[image]

IceLib Technical Reference
InteractionView..::..ConferenceId Property
InteractionView Class See Also Send Feedback
Gets or sets the conference ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> ConferenceId { get; set; }
Visual Basic
Public Property ConferenceId As Nullable(Of Long)
    Get
    Set

Field Value

The conference ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


DateOffset Property

[image]

IceLib Technical Reference
InteractionView..::..DateOffset Property
InteractionView Class See Also Send Feedback
Gets or sets the date offset. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> DateOffset { get; set; }
Visual Basic
Public Property DateOffset As Nullable(Of Long)
    Get
    Set

Field Value

The date offset, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


DisplayName1 Property

[image]

IceLib Technical Reference
InteractionView..::..DisplayName1 Property
InteractionView Class See Also Send Feedback
Gets or sets the display name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName1 { get; set; }
Visual Basic
Public Property DisplayName1 As String
    Get
    Set

Field Value

The display name1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


DisplayName2 Property

[image]

IceLib Technical Reference
InteractionView..::..DisplayName2 Property
InteractionView Class See Also Send Feedback
Gets or sets the display name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName2 { get; set; }
Visual Basic
Public Property DisplayName2 As String
    Get
    Set

Field Value

The display name2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


Duration Property

[image]

IceLib Technical Reference
InteractionView..::..Duration Property
InteractionView Class See Also Send Feedback
Gets or sets the duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Duration { get; set; }
Visual Basic
Public Property Duration As Nullable(Of Long)
    Get
    Set

Field Value

The duration, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


FirstName1 Property

[image]

IceLib Technical Reference
InteractionView..::..FirstName1 Property
InteractionView Class See Also Send Feedback
Gets or sets the first name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName1 { get; set; }
Visual Basic
Public Property FirstName1 As String
    Get
    Set

Field Value

The first name1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


FirstName2 Property

[image]

IceLib Technical Reference
InteractionView..::..FirstName2 Property
InteractionView Class See Also Send Feedback
Gets or sets the first name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName2 { get; set; }
Visual Basic
Public Property FirstName2 As String
    Get
    Set

Field Value

The first name2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


ICUserId1 Property

[image]

IceLib Technical Reference
InteractionView..::..ICUserId1 Property
InteractionView Class See Also Send Feedback
Gets or sets the IC user ID1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUserId1 { get; set; }
Visual Basic
Public Property ICUserId1 As String
    Get
    Set

Field Value

The IC user ID1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


ICUserId2 Property

[image]

IceLib Technical Reference
InteractionView..::..ICUserId2 Property
InteractionView Class See Also Send Feedback
Gets or sets the IC user ID2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUserId2 { get; set; }
Visual Basic
Public Property ICUserId2 As String
    Get
    Set

Field Value

The IC user ID2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
InteractionView..::..Id Property
InteractionView Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


InteractionAddressValue1 Property

[image]

IceLib Technical Reference
InteractionView..::..InteractionAddressValue1 Property
InteractionView Class See Also Send Feedback
Gets or sets the InteractionAddress value1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddressValue1 { get; set; }
Visual Basic
Public Property InteractionAddressValue1 As String
    Get
    Set

Field Value

The InteractionAddress value1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


InteractionAddressValue2 Property

[image]

IceLib Technical Reference
InteractionView..::..InteractionAddressValue2 Property
InteractionView Class See Also Send Feedback
Gets or sets the InteractionAddress value2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddressValue2 { get; set; }
Visual Basic
Public Property InteractionAddressValue2 As String
    Get
    Set

Field Value

The InteractionAddress value2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


LastName1 Property

[image]

IceLib Technical Reference
InteractionView..::..LastName1 Property
InteractionView Class See Also Send Feedback
Gets or sets the last name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName1 { get; set; }
Visual Basic
Public Property LastName1 As String
    Get
    Set

Field Value

The last name1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


LastName2 Property

[image]

IceLib Technical Reference
InteractionView..::..LastName2 Property
InteractionView Class See Also Send Feedback
Gets or sets the last name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName2 { get; set; }
Visual Basic
Public Property LastName2 As String
    Get
    Set

Field Value

The last name2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


OrganizationName1 Property

[image]

IceLib Technical Reference
InteractionView..::..OrganizationName1 Property
InteractionView Class See Also Send Feedback
Gets or sets the organization name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName1 { get; set; }
Visual Basic
Public Property OrganizationName1 As String
    Get
    Set

Field Value

The organization name1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


OrganizationName2 Property

[image]

IceLib Technical Reference
InteractionView..::..OrganizationName2 Property
InteractionView Class See Also Send Feedback
Gets or sets the organization name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName2 { get; set; }
Visual Basic
Public Property OrganizationName2 As String
    Get
    Set

Field Value

The organization name2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


SegmentTypes Property

[image]

IceLib Technical Reference
InteractionView..::..SegmentTypes Property
InteractionView Class See Also Send Feedback
Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<SegmentTypes> SegmentTypes { get; set; }
Visual Basic
Public Property SegmentTypes As Nullable(Of SegmentTypes)
    Get
    Set

Field Value

The segment type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


StartDateTime Property

[image]

IceLib Technical Reference
InteractionView..::..StartDateTime Property
InteractionView Class See Also Send Feedback
Gets or sets the start date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> StartDateTime { get; set; }
Visual Basic
Public Property StartDateTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The start date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


StationName1 Property

[image]

IceLib Technical Reference
InteractionView..::..StationName1 Property
InteractionView Class See Also Send Feedback
Gets or sets the station name1. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationName1 { get; set; }
Visual Basic
Public Property StationName1 As String
    Get
    Set

Field Value

The station name1, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


StationName2 Property

[image]

IceLib Technical Reference
InteractionView..::..StationName2 Property
InteractionView Class See Also Send Feedback
Gets or sets the station name2. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationName2 { get; set; }
Visual Basic
Public Property StationName2 As String
    Get
    Set

Field Value

The station name2, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


Type Property

[image]

IceLib Technical Reference
InteractionView..::..Type Property
InteractionView Class See Also Send Feedback
Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

Field Value

The type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


TypeId Property

[image]

IceLib Technical Reference
InteractionView..::..TypeId Property
InteractionView Class See Also Send Feedback
Gets or sets the type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> TypeId { get; set; }
Visual Basic
Public Property TypeId As Nullable(Of Long)
    Get
    Set

Field Value

The type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

InteractionView Class
InteractionView Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualCompletedEventArgs Class

[image]

IceLib Technical Reference
IsUnknownOrSystemIndividualCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the IsUnknownOrSystemIndividualCompleted event of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class IsUnknownOrSystemIndividualCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class IsUnknownOrSystemIndividualCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..IsUnknownOrSystemIndividualCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IsUnknownOrSystemIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
IsUnknownOrSystemIndividualCompletedEventArgs Members
IsUnknownOrSystemIndividualCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The IsUnknownOrSystemIndividualCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | IsUnknownOrSystemIndividualCompletedEventArgs | Initializes a new instance of the IsUnknownOrSystemIndividualCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | IsUnknownOrSystemIndividual | Gets a value indicating whether an Individual is recognized.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

IsUnknownOrSystemIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualCompletedEventArgs Constructor

[image]

IceLib Technical Reference
IsUnknownOrSystemIndividualCompletedEventArgs Constructor
IsUnknownOrSystemIndividualCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the IsUnknownOrSystemIndividualCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IsUnknownOrSystemIndividualCompletedEventArgs(
    bool isUnknownOrSystemIndividual,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    isUnknownOrSystemIndividual As Boolean, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

isUnknownOrSystemIndividual
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) is unknown or system Individual.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IsUnknownOrSystemIndividualCompletedEventArgs Class
IsUnknownOrSystemIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
IsUnknownOrSystemIndividualCompletedEventArgs Methods
IsUnknownOrSystemIndividualCompletedEventArgs Class See Also Send Feedback

The IsUnknownOrSystemIndividualCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsUnknownOrSystemIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
IsUnknownOrSystemIndividualCompletedEventArgs Properties
IsUnknownOrSystemIndividualCompletedEventArgs Class See Also Send Feedback

The IsUnknownOrSystemIndividualCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | IsUnknownOrSystemIndividual | Gets a value indicating whether an Individual is recognized.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

IsUnknownOrSystemIndividualCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividual Property

[image]

IceLib Technical Reference
IsUnknownOrSystemIndividualCompletedEventArgs..::..IsUnknownOrSystemIndividual Property
IsUnknownOrSystemIndividualCompletedEventArgs Class See Also Send Feedback
Gets a value indicating whether an Individual is recognized.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsUnknownOrSystemIndividual { get; }
Visual Basic
Public ReadOnly Property IsUnknownOrSystemIndividual As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is unknown or system Individual; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

IsUnknownOrSystemIndividualCompletedEventArgs Class
IsUnknownOrSystemIndividualCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


Location Class

[image]

IceLib Technical Reference
Location Class
Members See Also Send Feedback
Represents a location within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Location
Visual Basic
Public Class Location

Remarks

Tracker Locations represent physical locations of Organizations. An Organization can have any number of locations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..Location

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Members
ININ.IceLib.Tracker Namespace


Location Members

[image] [image]

IceLib Technical Reference
Location Members
Location Class Constructors Methods Properties See Also Send Feedback

The Location type exposes the following members.

Constructors

 | Name | Description
Public method | Location | Initializes a new instance of the Location class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationLocationId | Gets or sets the application location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalId | Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalSource | Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsActive | Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | UnknownIndividualId | Gets or sets the unknown individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Location Class
ININ.IceLib.Tracker Namespace


Location Constructor

[image]

IceLib Technical Reference
Location Constructor
Location Class See Also Send Feedback
Initializes a new instance of the Location class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Location()
Visual Basic
Public Sub New

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


Location Methods

[image] [image]

IceLib Technical Reference
Location Methods
Location Class See Also Send Feedback

The Location type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Location Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
Location..::..Reset Method
Location Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


Location Properties

[image] [image]

IceLib Technical Reference
Location Properties
Location Class See Also Send Feedback

The Location type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationLocationId | Gets or sets the application location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalId | Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalSource | Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsActive | Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | UnknownIndividualId | Gets or sets the unknown individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Location Class
ININ.IceLib.Tracker Namespace


ApplicationLocationId Property

[image]

IceLib Technical Reference
Location..::..ApplicationLocationId Property
Location Class See Also Send Feedback
Gets or sets the application location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationLocationId { get; set; }
Visual Basic
Public Property ApplicationLocationId As String
    Get
    Set

Field Value

The application location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
Location..::..ExternalId Property
Location Class See Also Send Feedback
Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
Location..::..ExternalSource Property
Location Class See Also Send Feedback
Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


IsActive Property

[image]

IceLib Technical Reference
Location..::..IsActive Property
Location Class See Also Send Feedback
Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsActive { get; set; }
Visual Basic
Public Property IsActive As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
Location..::..IsPrivate Property
Location Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
Location..::..LocationId Property
Location Class See Also Send Feedback
Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


ModifyDateTime Property

[image]

IceLib Technical Reference
Location..::..ModifyDateTime Property
Location Class See Also Send Feedback
Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> ModifyDateTime { get; internal set; }
Visual Basic
Public Property ModifyDateTime As Nullable(Of DateTime)
    Get
    Friend Set

Field Value

The modify date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
Location..::..Name Property
Location Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
Location..::..OrganizationId Property
Location Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


OwnerId Property

[image]

IceLib Technical Reference
Location..::..OwnerId Property
Location Class See Also Send Feedback
Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

Field Value

The owner ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


SiteId Property

[image]

IceLib Technical Reference
Location..::..SiteId Property
Location Class See Also Send Feedback
Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> SiteId { get; set; }
Visual Basic
Public Property SiteId As Nullable(Of Long)
    Get
    Set

Field Value

The site ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


UnknownIndividualId Property

[image]

IceLib Technical Reference
Location..::..UnknownIndividualId Property
Location Class See Also Send Feedback
Gets or sets the unknown individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UnknownIndividualId { get; set; }
Visual Basic
Public Property UnknownIndividualId As String
    Get
    Set

Field Value

The unknown individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
Location..::..Version Property
Location Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Location Class
Location Members
ININ.IceLib.Tracker Namespace


LocationAddress Class

[image]

IceLib Technical Reference
LocationAddress Class
Members See Also Send Feedback
Represents a location address within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationAddress
Visual Basic
Public Class LocationAddress

Remarks

Provides a way to assign Tracker addresses to Locations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..LocationAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Members
ININ.IceLib.Tracker Namespace


LocationAddress Members

[image] [image]

IceLib Technical Reference
LocationAddress Members
LocationAddress Class Constructors Methods Properties See Also Send Feedback

The LocationAddress type exposes the following members.

Constructors

 | Name | Description
Public method | LocationAddress | Initializes a new instance of the LocationAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressInstanceId | Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AddressTypeId | Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForIndividual | Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationAddress Class
ININ.IceLib.Tracker Namespace


LocationAddress Constructor

[image]

IceLib Technical Reference
LocationAddress Constructor
LocationAddress Class See Also Send Feedback
Initializes a new instance of the LocationAddress class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationAddress()
Visual Basic
Public Sub New

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


LocationAddress Methods

[image] [image]

IceLib Technical Reference
LocationAddress Methods
LocationAddress Class See Also Send Feedback

The LocationAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationAddress Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
LocationAddress..::..Reset Method
LocationAddress Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


LocationAddress Properties

[image] [image]

IceLib Technical Reference
LocationAddress Properties
LocationAddress Class See Also Send Feedback

The LocationAddress type exposes the following members.

Properties

 | Name | Description
Public property | AddressInstanceId | Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AddressTypeId | Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForIndividual | Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationAddress Class
ININ.IceLib.Tracker Namespace


AddressInstanceId Property

[image]

IceLib Technical Reference
LocationAddress..::..AddressInstanceId Property
LocationAddress Class See Also Send Feedback
Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AddressInstanceId { get; set; }
Visual Basic
Public Property AddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


AddressTypeId Property

[image]

IceLib Technical Reference
LocationAddress..::..AddressTypeId Property
LocationAddress Class See Also Send Feedback
Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AddressTypeId { get; set; }
Visual Basic
Public Property AddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
LocationAddress..::..City Property
LocationAddress Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
LocationAddress..::..Country Property
LocationAddress Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


IsDefault Property

[image]

IceLib Technical Reference
LocationAddress..::..IsDefault Property
LocationAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


IsDefaultAddressForIndividual Property

[image]

IceLib Technical Reference
LocationAddress..::..IsDefaultAddressForIndividual Property
LocationAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefaultAddressForIndividual { get; set; }
Visual Basic
Public Property IsDefaultAddressForIndividual As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default address for individual; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
LocationAddress..::..LocationId Property
LocationAddress Class See Also Send Feedback
Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


State Property

[image]

IceLib Technical Reference
LocationAddress..::..State Property
LocationAddress Class See Also Send Feedback
Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set

Field Value

The state, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


StreetAddress Property

[image]

IceLib Technical Reference
LocationAddress..::..StreetAddress Property
LocationAddress Class See Also Send Feedback
Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StreetAddress { get; set; }
Visual Basic
Public Property StreetAddress As String
    Get
    Set

Field Value

The street address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


SystemInsertDate Property

[image]

IceLib Technical Reference
LocationAddress..::..SystemInsertDate Property
LocationAddress Class See Also Send Feedback
Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> SystemInsertDate { get; set; }
Visual Basic
Public Property SystemInsertDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The system insert date, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
LocationAddress..::..Version Property
LocationAddress Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


Zip Property

[image]

IceLib Technical Reference
LocationAddress..::..Zip Property
LocationAddress Class See Also Send Feedback
Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Zip { get; set; }
Visual Basic
Public Property Zip As String
    Get
    Set

Field Value

The zip, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationAddress Class
LocationAddress Members
ININ.IceLib.Tracker Namespace


LocationDetails Class

[image]

IceLib Technical Reference
LocationDetails Class
Members See Also Send Feedback
Helper class to contain the return parameters for the GetLocationDetails(String) methods.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationDetails
Visual Basic
Public Class LocationDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..LocationDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationDetails Members
ININ.IceLib.Tracker Namespace


LocationDetails Members

[image] [image]

IceLib Technical Reference
LocationDetails Members
LocationDetails Class Methods Properties See Also Send Feedback

The LocationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Location | Gets the location.
Public property | LocationAddresses | Gets the location addresses.
Public property | LocationInteractionAddresses | Gets the location interaction addresses.
Public property | LocationTrackerAttributeViews | Gets the location Tracker attribute views.
Public property | OrganizationName | Gets the name of the organization.

See Also

LocationDetails Class
ININ.IceLib.Tracker Namespace


LocationDetails Methods

[image] [image]

IceLib Technical Reference
LocationDetails Methods
LocationDetails Class See Also Send Feedback

The LocationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationDetails Class
ININ.IceLib.Tracker Namespace


LocationDetails Properties

[image] [image]

IceLib Technical Reference
LocationDetails Properties
LocationDetails Class See Also Send Feedback

The LocationDetails type exposes the following members.

Properties

 | Name | Description
Public property | Location | Gets the location.
Public property | LocationAddresses | Gets the location addresses.
Public property | LocationInteractionAddresses | Gets the location interaction addresses.
Public property | LocationTrackerAttributeViews | Gets the location Tracker attribute views.
Public property | OrganizationName | Gets the name of the organization.

See Also

LocationDetails Class
ININ.IceLib.Tracker Namespace


Location Property

[image]

IceLib Technical Reference
LocationDetails..::..Location Property
LocationDetails Class See Also Send Feedback
Gets the location.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Location Location { get; }
Visual Basic
Public ReadOnly Property Location As Location
    Get

Field Value

The location.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationDetails Class
LocationDetails Members
ININ.IceLib.Tracker Namespace


LocationAddresses Property

[image]

IceLib Technical Reference
LocationDetails..::..LocationAddresses Property
LocationDetails Class See Also Send Feedback
Gets the location addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LocationAddress> LocationAddresses { get; }
Visual Basic
Public ReadOnly Property LocationAddresses As ReadOnlyCollection(Of LocationAddress)
    Get

Field Value

The location addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationDetails Class
LocationDetails Members
ININ.IceLib.Tracker Namespace


LocationInteractionAddresses Property

[image]

IceLib Technical Reference
LocationDetails..::..LocationInteractionAddresses Property
LocationDetails Class See Also Send Feedback
Gets the location interaction addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LocationInteractionAddress> LocationInteractionAddresses { get; }
Visual Basic
Public ReadOnly Property LocationInteractionAddresses As ReadOnlyCollection(Of LocationInteractionAddress)
    Get

Field Value

The location interaction addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationDetails Class
LocationDetails Members
ININ.IceLib.Tracker Namespace


LocationTrackerAttributeViews Property

[image]

IceLib Technical Reference
LocationDetails..::..LocationTrackerAttributeViews Property
LocationDetails Class See Also Send Feedback
Gets the location Tracker attribute views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TrackerAttributeView> LocationTrackerAttributeViews { get; }
Visual Basic
Public ReadOnly Property LocationTrackerAttributeViews As ReadOnlyCollection(Of TrackerAttributeView)
    Get

Field Value

The location Tracker attribute views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationDetails Class
LocationDetails Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
LocationDetails..::..OrganizationName Property
LocationDetails Class See Also Send Feedback
Gets the name of the organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; }
Visual Basic
Public ReadOnly Property OrganizationName As String
    Get

Field Value

The name of the organization.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationDetails Class
LocationDetails Members
ININ.IceLib.Tracker Namespace


LocationInteractionAddress Class

[image]

IceLib Technical Reference
LocationInteractionAddress Class
Members See Also Send Feedback
Represents a location InteractionAddress within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationInteractionAddress
Visual Basic
Public Class LocationInteractionAddress

Remarks

Provides a way to assign Tracker interaction addresses to Locations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..LocationInteractionAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


LocationInteractionAddress Members

[image] [image]

IceLib Technical Reference
LocationInteractionAddress Members
LocationInteractionAddress Class Constructors Methods Properties See Also Send Feedback

The LocationInteractionAddress type exposes the following members.

Constructors

 | Name | Description
Public method | LocationInteractionAddress | Initializes a new instance of the LocationInteractionAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressSubtypeId | Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForIndividual | Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationInteractionAddress Class
ININ.IceLib.Tracker Namespace


LocationInteractionAddress Constructor

[image]

IceLib Technical Reference
LocationInteractionAddress Constructor
LocationInteractionAddress Class See Also Send Feedback
Initializes a new instance of the LocationInteractionAddress class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationInteractionAddress()
Visual Basic
Public Sub New

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


LocationInteractionAddress Methods

[image] [image]

IceLib Technical Reference
LocationInteractionAddress Methods
LocationInteractionAddress Class See Also Send Feedback

The LocationInteractionAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationInteractionAddress Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
LocationInteractionAddress..::..Reset Method
LocationInteractionAddress Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


LocationInteractionAddress Properties

[image] [image]

IceLib Technical Reference
LocationInteractionAddress Properties
LocationInteractionAddress Class See Also Send Feedback

The LocationInteractionAddress type exposes the following members.

Properties

 | Name | Description
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressSubtypeId | Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForIndividual | Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationInteractionAddress Class
ININ.IceLib.Tracker Namespace


InteractionAddressInstanceId Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..InteractionAddressInstanceId Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressInstanceId { get; set; }
Visual Basic
Public Property InteractionAddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtypeId Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..InteractionAddressSubtypeId Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressSubtypeId { get; set; }
Visual Basic
Public Property InteractionAddressSubtypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address subtype ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressTypeId Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..InteractionAddressTypeId Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressTypeId { get; set; }
Visual Basic
Public Property InteractionAddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


IsDefault Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..IsDefault Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


IsDefaultAddressForIndividual Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..IsDefaultAddressForIndividual Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefaultAddressForIndividual { get; set; }
Visual Basic
Public Property IsDefaultAddressForIndividual As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default address for individual; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..LocationId Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


SystemInsertDate Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..SystemInsertDate Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> SystemInsertDate { get; set; }
Visual Basic
Public Property SystemInsertDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The system insert date, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


Value Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..Value Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
LocationInteractionAddress..::..Version Property
LocationInteractionAddress Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationInteractionAddress Class
LocationInteractionAddress Members
ININ.IceLib.Tracker Namespace


LocationName Class

[image]

IceLib Technical Reference
LocationName Class
Members See Also Send Feedback
Represents a location name within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationName
Visual Basic
Public Class LocationName

Remarks

Provides a mapping between Locations and names.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..LocationName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationName Members
ININ.IceLib.Tracker Namespace


LocationName Members

[image] [image]

IceLib Technical Reference
LocationName Members
LocationName Class Constructors Methods Properties See Also Send Feedback

The LocationName type exposes the following members.

Constructors

 | Name | Description
Public method | LocationName | Initializes a new instance of the LocationName class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationName Class
ININ.IceLib.Tracker Namespace


LocationName Constructor

[image]

IceLib Technical Reference
LocationName Constructor
LocationName Class See Also Send Feedback
Initializes a new instance of the LocationName class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationName()
Visual Basic
Public Sub New

See Also

LocationName Class
LocationName Members
ININ.IceLib.Tracker Namespace


LocationName Methods

[image] [image]

IceLib Technical Reference
LocationName Methods
LocationName Class See Also Send Feedback

The LocationName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationName Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
LocationName..::..Reset Method
LocationName Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationName Class
LocationName Members
ININ.IceLib.Tracker Namespace


LocationName Properties

[image] [image]

IceLib Technical Reference
LocationName Properties
LocationName Class See Also Send Feedback

The LocationName type exposes the following members.

Properties

 | Name | Description
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationName Class
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
LocationName..::..LocationId Property
LocationName Class See Also Send Feedback
Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationName Class
LocationName Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
LocationName..::..Name Property
LocationName Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationName Class
LocationName Members
ININ.IceLib.Tracker Namespace


LocationView Class

[image]

IceLib Technical Reference
LocationView Class
Members See Also Send Feedback
Represents a location view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class LocationView
Visual Basic
Public Class LocationView

Remarks

The LocationView class is used by methods that return information about Locations. One such method is the SearchLocations(SearchLocationsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..LocationView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Members
ININ.IceLib.Tracker Namespace


LocationView Members

[image] [image]

IceLib Technical Reference
LocationView Members
LocationView Class Constructors Methods Properties See Also Send Feedback

The LocationView type exposes the following members.

Constructors

 | Name | Description
Public method | LocationView | Initializes a new instance of the LocationView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationView Class
ININ.IceLib.Tracker Namespace


LocationView Constructor

[image]

IceLib Technical Reference
LocationView Constructor
LocationView Class See Also Send Feedback
Initializes a new instance of the LocationView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationView()
Visual Basic
Public Sub New

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


LocationView Methods

[image] [image]

IceLib Technical Reference
LocationView Methods
LocationView Class See Also Send Feedback

The LocationView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
LocationView..::..Reset Method
LocationView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


LocationView Properties

[image] [image]

IceLib Technical Reference
LocationView Properties
LocationView Class See Also Send Feedback

The LocationView type exposes the following members.

Properties

 | Name | Description
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

LocationView Class
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
LocationView..::..City Property
LocationView Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
LocationView..::..Country Property
LocationView Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
LocationView..::..Id Property
LocationView Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
LocationView..::..Name Property
LocationView Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


State Property

[image]

IceLib Technical Reference
LocationView..::..State Property
LocationView Class See Also Send Feedback
Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set

Field Value

The state, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

LocationView Class
LocationView Members
ININ.IceLib.Tracker Namespace


MultipartAccountCode Class

[image]

IceLib Technical Reference
MultipartAccountCode Class
Members See Also Send Feedback
Represents a multipart account code within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MultipartAccountCode
Visual Basic
Public Class MultipartAccountCode

Remarks

Multipart account codes can be assigned to Interactions.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..MultipartAccountCode

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


MultipartAccountCode Members

[image] [image]

IceLib Technical Reference
MultipartAccountCode Members
MultipartAccountCode Class Constructors Methods Properties See Also Send Feedback

The MultipartAccountCode type exposes the following members.

Constructors

 | Name | Description
Public method | MultipartAccountCode | Initializes a new instance of the MultipartAccountCode class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the AccountCode. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DispositionDescription | Gets or sets the DispositionDescription. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalIndividualFirstName | Gets or sets the first name of the external Individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalIndividualLastName | Gets or sets the last name of the external Individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalIndividualOrganizationName | Gets or sets the ExternalIndividualOrganizationName. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WorkItemId | Gets or sets the WorkItemId. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

MultipartAccountCode Class
ININ.IceLib.Tracker Namespace


MultipartAccountCode Constructor

[image]

IceLib Technical Reference
MultipartAccountCode Constructor
MultipartAccountCode Class See Also Send Feedback
Initializes a new instance of the MultipartAccountCode class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MultipartAccountCode()
Visual Basic
Public Sub New

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


MultipartAccountCode Methods

[image] [image]

IceLib Technical Reference
MultipartAccountCode Methods
MultipartAccountCode Class See Also Send Feedback

The MultipartAccountCode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultipartAccountCode Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
MultipartAccountCode..::..Reset Method
MultipartAccountCode Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


MultipartAccountCode Properties

[image] [image]

IceLib Technical Reference
MultipartAccountCode Properties
MultipartAccountCode Class See Also Send Feedback

The MultipartAccountCode type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the AccountCode. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DispositionDescription | Gets or sets the DispositionDescription. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalIndividualFirstName | Gets or sets the first name of the external Individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalIndividualLastName | Gets or sets the last name of the external Individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalIndividualOrganizationName | Gets or sets the ExternalIndividualOrganizationName. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WorkItemId | Gets or sets the WorkItemId. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

MultipartAccountCode Class
ININ.IceLib.Tracker Namespace


AccountCode Property

[image]

IceLib Technical Reference
MultipartAccountCode..::..AccountCode Property
MultipartAccountCode Class See Also Send Feedback
Gets or sets the AccountCode. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCode { get; set; }
Visual Basic
Public Property AccountCode As String
    Get
    Set

Field Value

The AccountCode, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


DispositionDescription Property

[image]

IceLib Technical Reference
MultipartAccountCode..::..DispositionDescription Property
MultipartAccountCode Class See Also Send Feedback
Gets or sets the DispositionDescription. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DispositionDescription { get; set; }
Visual Basic
Public Property DispositionDescription As String
    Get
    Set

Field Value

The DispositionDescription, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


ExternalIndividualFirstName Property

[image]

IceLib Technical Reference
MultipartAccountCode..::..ExternalIndividualFirstName Property
MultipartAccountCode Class See Also Send Feedback
Gets or sets the first name of the external Individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualFirstName { get; set; }
Visual Basic
Public Property ExternalIndividualFirstName As String
    Get
    Set

Field Value

The ExternalIndividualFirstName, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


ExternalIndividualLastName Property

[image]

IceLib Technical Reference
MultipartAccountCode..::..ExternalIndividualLastName Property
MultipartAccountCode Class See Also Send Feedback
Gets or sets the last name of the external Individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualLastName { get; set; }
Visual Basic
Public Property ExternalIndividualLastName As String
    Get
    Set

Field Value

The ExternalIndividualLastName, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationName Property

[image]

IceLib Technical Reference
MultipartAccountCode..::..ExternalIndividualOrganizationName Property
MultipartAccountCode Class See Also Send Feedback
Gets or sets the ExternalIndividualOrganizationName. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationName { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationName As String
    Get
    Set

Field Value

The ExternalIndividualOrganizationName, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


WorkItemId Property

[image]

IceLib Technical Reference
MultipartAccountCode..::..WorkItemId Property
MultipartAccountCode Class See Also Send Feedback
Gets or sets the WorkItemId. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkItemId { get; set; }
Visual Basic
Public Property WorkItemId As String
    Get
    Set

Field Value

The WorkItemId, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCode Class
MultipartAccountCode Members
ININ.IceLib.Tracker Namespace


MultipartAccountCodeExtended Class

[image]

IceLib Technical Reference
MultipartAccountCodeExtended Class
Members See Also Send Feedback
Represents an extended multipart account code within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class MultipartAccountCodeExtended
Visual Basic
Public Class MultipartAccountCodeExtended

Remarks

Multipart account codes can be assigned to Interactions.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..MultipartAccountCodeExtended

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


MultipartAccountCodeExtended Members

[image] [image]

IceLib Technical Reference
MultipartAccountCodeExtended Members
MultipartAccountCodeExtended Class Constructors Methods Properties See Also Send Feedback

The MultipartAccountCodeExtended type exposes the following members.

Constructors

 | Name | Description
Public method | MultipartAccountCodeExtended | Initializes a new instance of the MultipartAccountCodeExtended class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the account code.
Public property | Description1 | Gets or sets description 1.
Public property | Description2 | Gets or sets description 2.
Public property | Description3 | Gets or sets description 3.
Public property | DispositionCode | Gets or sets the disposition code.
Public property | DispositionDescription | Gets or sets the Disposition description.
Public property | ExternalIndividualCity | Gets or sets the external Individual City.
Public property | ExternalIndividualCountry | Gets or sets the external Individual Country.
Public property | ExternalIndividualFirstName | Gets or sets the external Individual first name.
Public property | ExternalIndividualId | Gets or sets the Individual ID of the external Individual.
Public property | ExternalIndividualLastName | Gets or sets the external Individual last name.
Public property | ExternalIndividualMiddleName | Gets or sets the external Individual middle name.
Public property | ExternalIndividualOrganizationCity | Gets or sets the external Individual Organization City.
Public property | ExternalIndividualOrganizationCountry | Gets or sets the external Individual Organization Country.
Public property | ExternalIndividualOrganizationDefaultInteractionAddress | Gets or sets the default InteractionAddress for the external Individual's Organization.
Public property | ExternalIndividualOrganizationName | Gets or sets the external Individual Organization name.
Public property | ExternalIndividualOrganizationState | Gets or sets the external Individual Organization State.
Public property | ExternalIndividualOrganizationStreetAddress | Gets or sets the external Individual Organization street address.
Public property | ExternalIndividualOrganizationZip | Gets or sets the external Individual Organization Zip code.
Public property | ExternalIndividualState | Gets or sets the external Individual State.
Public property | ExternalIndividualStreetAddress | Gets or sets the external Individual street address.
Public property | ExternalIndividualZip | Gets or sets the external Individual Zip code.
Public property | InternalIndividualCity | Gets or sets the internal Individual City.
Public property | InternalIndividualCountry | Gets or sets the internal Individual Country.
Public property | InternalIndividualFirstName | Gets or sets the internal Individual first name.
Public property | InternalIndividualId | Gets or sets the Individual ID of the internal Individual.
Public property | InternalIndividualLastName | Gets or sets the internal Individual last name.
Public property | InternalIndividualMiddleName | Gets or sets the internal Individual middle name.
Public property | InternalIndividualOrganizationCity | Gets or sets the internal Individual Organization City.
Public property | InternalIndividualOrganizationCountry | Gets or sets the internal Individual Organization Country.
Public property | InternalIndividualOrganizationDefaultInteractionAddress | Gets or sets the default InteractionAddress for the internal Individual's Organization.
Public property | InternalIndividualOrganizationName | Gets or sets the internal Individual Organization name.
Public property | InternalIndividualOrganizationState | Gets or sets the internal Individual Organization State.
Public property | InternalIndividualOrganizationStreetAddress | Gets or sets the internal Individual Organization street address.
Public property | InternalIndividualOrganizationZip | Gets or sets the internal Individual Organization Zip code.
Public property | InternalIndividualState | Gets or sets the internal Individual State.
Public property | InternalIndividualStreetAddress | Gets or sets the internal Individual street address.
Public property | InternalIndividualZip | Gets or sets the internal Individual Zip code.
Public property | UserCode1 | Gets or sets user code 1.
Public property | UserCode2 | Gets or sets user code 2.
Public property | UserCode3 | Gets or sets user code 3.
Public property | WorkItemCodeDescription | Gets or sets the WorkItem code description.
Public property | WorkItemCodeId | Gets or sets the WorkItem code ID.

See Also

MultipartAccountCodeExtended Class
ININ.IceLib.Tracker Namespace


MultipartAccountCodeExtended Constructor

[image]

IceLib Technical Reference
MultipartAccountCodeExtended Constructor
MultipartAccountCodeExtended Class See Also Send Feedback
Initializes a new instance of the MultipartAccountCodeExtended class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public MultipartAccountCodeExtended()
Visual Basic
Public Sub New

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


MultipartAccountCodeExtended Methods

[image] [image]

IceLib Technical Reference
MultipartAccountCodeExtended Methods
MultipartAccountCodeExtended Class See Also Send Feedback

The MultipartAccountCodeExtended type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultipartAccountCodeExtended Class
ININ.IceLib.Tracker Namespace


MultipartAccountCodeExtended Properties

[image] [image]

IceLib Technical Reference
MultipartAccountCodeExtended Properties
MultipartAccountCodeExtended Class See Also Send Feedback

The MultipartAccountCodeExtended type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the account code.
Public property | Description1 | Gets or sets description 1.
Public property | Description2 | Gets or sets description 2.
Public property | Description3 | Gets or sets description 3.
Public property | DispositionCode | Gets or sets the disposition code.
Public property | DispositionDescription | Gets or sets the Disposition description.
Public property | ExternalIndividualCity | Gets or sets the external Individual City.
Public property | ExternalIndividualCountry | Gets or sets the external Individual Country.
Public property | ExternalIndividualFirstName | Gets or sets the external Individual first name.
Public property | ExternalIndividualId | Gets or sets the Individual ID of the external Individual.
Public property | ExternalIndividualLastName | Gets or sets the external Individual last name.
Public property | ExternalIndividualMiddleName | Gets or sets the external Individual middle name.
Public property | ExternalIndividualOrganizationCity | Gets or sets the external Individual Organization City.
Public property | ExternalIndividualOrganizationCountry | Gets or sets the external Individual Organization Country.
Public property | ExternalIndividualOrganizationDefaultInteractionAddress | Gets or sets the default InteractionAddress for the external Individual's Organization.
Public property | ExternalIndividualOrganizationName | Gets or sets the external Individual Organization name.
Public property | ExternalIndividualOrganizationState | Gets or sets the external Individual Organization State.
Public property | ExternalIndividualOrganizationStreetAddress | Gets or sets the external Individual Organization street address.
Public property | ExternalIndividualOrganizationZip | Gets or sets the external Individual Organization Zip code.
Public property | ExternalIndividualState | Gets or sets the external Individual State.
Public property | ExternalIndividualStreetAddress | Gets or sets the external Individual street address.
Public property | ExternalIndividualZip | Gets or sets the external Individual Zip code.
Public property | InternalIndividualCity | Gets or sets the internal Individual City.
Public property | InternalIndividualCountry | Gets or sets the internal Individual Country.
Public property | InternalIndividualFirstName | Gets or sets the internal Individual first name.
Public property | InternalIndividualId | Gets or sets the Individual ID of the internal Individual.
Public property | InternalIndividualLastName | Gets or sets the internal Individual last name.
Public property | InternalIndividualMiddleName | Gets or sets the internal Individual middle name.
Public property | InternalIndividualOrganizationCity | Gets or sets the internal Individual Organization City.
Public property | InternalIndividualOrganizationCountry | Gets or sets the internal Individual Organization Country.
Public property | InternalIndividualOrganizationDefaultInteractionAddress | Gets or sets the default InteractionAddress for the internal Individual's Organization.
Public property | InternalIndividualOrganizationName | Gets or sets the internal Individual Organization name.
Public property | InternalIndividualOrganizationState | Gets or sets the internal Individual Organization State.
Public property | InternalIndividualOrganizationStreetAddress | Gets or sets the internal Individual Organization street address.
Public property | InternalIndividualOrganizationZip | Gets or sets the internal Individual Organization Zip code.
Public property | InternalIndividualState | Gets or sets the internal Individual State.
Public property | InternalIndividualStreetAddress | Gets or sets the internal Individual street address.
Public property | InternalIndividualZip | Gets or sets the internal Individual Zip code.
Public property | UserCode1 | Gets or sets user code 1.
Public property | UserCode2 | Gets or sets user code 2.
Public property | UserCode3 | Gets or sets user code 3.
Public property | WorkItemCodeDescription | Gets or sets the WorkItem code description.
Public property | WorkItemCodeId | Gets or sets the WorkItem code ID.

See Also

MultipartAccountCodeExtended Class
ININ.IceLib.Tracker Namespace


AccountCode Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..AccountCode Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the account code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCode { get; set; }
Visual Basic
Public Property AccountCode As String
    Get
    Set

Field Value

The account code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


Description1 Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..Description1 Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets description 1.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description1 { get; set; }
Visual Basic
Public Property Description1 As String
    Get
    Set

Field Value

The description 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


Description2 Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..Description2 Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets description 2.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description2 { get; set; }
Visual Basic
Public Property Description2 As String
    Get
    Set

Field Value

The description 2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


Description3 Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..Description3 Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets description 3.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Description3 { get; set; }
Visual Basic
Public Property Description3 As String
    Get
    Set

Field Value

The description 3.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


DispositionCode Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..DispositionCode Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the disposition code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DispositionCode { get; set; }
Visual Basic
Public Property DispositionCode As String
    Get
    Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


DispositionDescription Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..DispositionDescription Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the Disposition description.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DispositionDescription { get; set; }
Visual Basic
Public Property DispositionDescription As String
    Get
    Set

Field Value

The disposition description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualCity Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualCity Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualCity { get; set; }
Visual Basic
Public Property ExternalIndividualCity As String
    Get
    Set

Field Value

The city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualCountry Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualCountry Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualCountry { get; set; }
Visual Basic
Public Property ExternalIndividualCountry As String
    Get
    Set

Field Value

The country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualFirstName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualFirstName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual first name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualFirstName { get; set; }
Visual Basic
Public Property ExternalIndividualFirstName As String
    Get
    Set

Field Value

The first name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualId Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualId Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the Individual ID of the external Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualId { get; set; }
Visual Basic
Public Property ExternalIndividualId As String
    Get
    Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualLastName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualLastName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual last name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualLastName { get; set; }
Visual Basic
Public Property ExternalIndividualLastName As String
    Get
    Set

Field Value

The last name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualMiddleName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualMiddleName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual middle name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualMiddleName { get; set; }
Visual Basic
Public Property ExternalIndividualMiddleName As String
    Get
    Set

Field Value

The middle name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationCity Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationCity Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Organization City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationCity { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationCity As String
    Get
    Set

Field Value

The city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationCountry Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationCountry Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Organization Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationCountry { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationCountry As String
    Get
    Set

Field Value

The country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationDefaultInteractionAddress Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationDefaultInteractionAddress Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the default InteractionAddress for the external Individual's Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationDefaultInteractionAddress { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationDefaultInteractionAddress As String
    Get
    Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Organization name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationName { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationName As String
    Get
    Set

Field Value

The individual organization name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationState Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationState Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Organization State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationState { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationState As String
    Get
    Set

Field Value

The state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationStreetAddress Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationStreetAddress Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Organization street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationStreetAddress { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationStreetAddress As String
    Get
    Set

Field Value

The street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualOrganizationZip Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualOrganizationZip Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Organization Zip code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualOrganizationZip { get; set; }
Visual Basic
Public Property ExternalIndividualOrganizationZip As String
    Get
    Set

Field Value

The zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualState Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualState Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualState { get; set; }
Visual Basic
Public Property ExternalIndividualState As String
    Get
    Set

Field Value

The state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualStreetAddress Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualStreetAddress Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualStreetAddress { get; set; }
Visual Basic
Public Property ExternalIndividualStreetAddress As String
    Get
    Set

Field Value

The street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


ExternalIndividualZip Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..ExternalIndividualZip Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the external Individual Zip code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalIndividualZip { get; set; }
Visual Basic
Public Property ExternalIndividualZip As String
    Get
    Set

Field Value

The zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualCity Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualCity Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualCity { get; set; }
Visual Basic
Public Property InternalIndividualCity As String
    Get
    Set

Field Value

The city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualCountry Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualCountry Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualCountry { get; set; }
Visual Basic
Public Property InternalIndividualCountry As String
    Get
    Set

Field Value

The country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualFirstName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualFirstName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual first name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualFirstName { get; set; }
Visual Basic
Public Property InternalIndividualFirstName As String
    Get
    Set

Field Value

The first name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualId Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualId Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the Individual ID of the internal Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualId { get; set; }
Visual Basic
Public Property InternalIndividualId As String
    Get
    Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualLastName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualLastName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual last name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualLastName { get; set; }
Visual Basic
Public Property InternalIndividualLastName As String
    Get
    Set

Field Value

The last name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualMiddleName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualMiddleName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual middle name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualMiddleName { get; set; }
Visual Basic
Public Property InternalIndividualMiddleName As String
    Get
    Set

Field Value

The middle name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationCity Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationCity Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Organization City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationCity { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationCity As String
    Get
    Set

Field Value

The city.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationCountry Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationCountry Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Organization Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationCountry { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationCountry As String
    Get
    Set

Field Value

The country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationDefaultInteractionAddress Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationDefaultInteractionAddress Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the default InteractionAddress for the internal Individual's Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationDefaultInteractionAddress { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationDefaultInteractionAddress As String
    Get
    Set

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationName Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationName Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Organization name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationName { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationName As String
    Get
    Set

Field Value

The Organization name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationState Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationState Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Organization State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationState { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationState As String
    Get
    Set

Field Value

The state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationStreetAddress Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationStreetAddress Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Organization street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationStreetAddress { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationStreetAddress As String
    Get
    Set

Field Value

The street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualOrganizationZip Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualOrganizationZip Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Organization Zip code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualOrganizationZip { get; set; }
Visual Basic
Public Property InternalIndividualOrganizationZip As String
    Get
    Set

Field Value

The zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualState Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualState Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualState { get; set; }
Visual Basic
Public Property InternalIndividualState As String
    Get
    Set

Field Value

The state.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualStreetAddress Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualStreetAddress Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualStreetAddress { get; set; }
Visual Basic
Public Property InternalIndividualStreetAddress As String
    Get
    Set

Field Value

The street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


InternalIndividualZip Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..InternalIndividualZip Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the internal Individual Zip code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InternalIndividualZip { get; set; }
Visual Basic
Public Property InternalIndividualZip As String
    Get
    Set

Field Value

The zip code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


UserCode1 Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..UserCode1 Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets user code 1.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserCode1 { get; set; }
Visual Basic
Public Property UserCode1 As String
    Get
    Set

Field Value

The user code 1.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


UserCode2 Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..UserCode2 Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets user code 2.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserCode2 { get; set; }
Visual Basic
Public Property UserCode2 As String
    Get
    Set

Field Value

The user code 2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


UserCode3 Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..UserCode3 Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets user code 3.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserCode3 { get; set; }
Visual Basic
Public Property UserCode3 As String
    Get
    Set

Field Value

The user code 3.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


WorkItemCodeDescription Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..WorkItemCodeDescription Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the WorkItem code description.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WorkItemCodeDescription { get; set; }
Visual Basic
Public Property WorkItemCodeDescription As String
    Get
    Set

Field Value

The work item code description.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


WorkItemCodeId Property

[image]

IceLib Technical Reference
MultipartAccountCodeExtended..::..WorkItemCodeId Property
MultipartAccountCodeExtended Class See Also Send Feedback
Gets or sets the WorkItem code ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> WorkItemCodeId { get; set; }
Visual Basic
Public Property WorkItemCodeId As Nullable(Of Long)
    Get
    Set

Field Value

The work item code ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

MultipartAccountCodeExtended Class
MultipartAccountCodeExtended Members
ININ.IceLib.Tracker Namespace


NewIdCompletedEventArgs(TId) Class

[image]

IceLib Technical Reference
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class
Members See Also Send Feedback
Provides data for asynchronous completed events of a TrackerUser.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NewIdCompletedEventArgs<TId> : AsyncCompletedEventArgs
Visual Basic
Public Class NewIdCompletedEventArgs(Of TId) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TId
The ID.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..NewIdCompletedEventArgs<(Of <(<'TId>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NewIdCompletedEventArgs<(Of <(<'TId>)>)> Members
ININ.IceLib.Tracker Namespace


NewIdCompletedEventArgs(TId) Members

[image] [image]

IceLib Technical Reference
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Members
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class Constructors Methods Properties See Also Send Feedback

The NewIdCompletedEventArgs<(Of <(<'TId>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | NewIdCompletedEventArgs<(Of <(<'TId>)>)> | Initializes a new instance of the NewIdCompletedEventArgs<(Of <(<'TId>)>)> class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Id | Gets the ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class
ININ.IceLib.Tracker Namespace


NewIdCompletedEventArgs(TId) Constructor

[image]

IceLib Technical Reference
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Constructor
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class See Also Send Feedback
Initializes a new instance of the NewIdCompletedEventArgs<(Of <(<'TId>)>)> class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NewIdCompletedEventArgs(
    TId id,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    id As TId, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

id
Type: TId
The ID.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Members
ININ.IceLib.Tracker Namespace


NewIdCompletedEventArgs(TId) Methods

[image] [image]

IceLib Technical Reference
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Methods
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class See Also Send Feedback

The NewIdCompletedEventArgs<(Of <(<'TId>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class
ININ.IceLib.Tracker Namespace


NewIdCompletedEventArgs(TId) Properties

[image] [image]

IceLib Technical Reference
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Properties
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class See Also Send Feedback

The NewIdCompletedEventArgs<(Of <(<'TId>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Id | Gets the ID associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
NewIdCompletedEventArgs<(Of <(<'TId>)>)>..::..Id Property
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class See Also Send Feedback
Gets the ID associated with the event.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TId Id { get; }
Visual Basic
Public ReadOnly Property Id As TId
    Get

Field Value

The ID.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

NewIdCompletedEventArgs<(Of <(<'TId>)>)> Class
NewIdCompletedEventArgs<(Of <(<'TId>)>)> Members
ININ.IceLib.Tracker Namespace


Organization Class

[image]

IceLib Technical Reference
Organization Class
Members See Also Send Feedback
Represents an organization within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Organization
Visual Basic
Public Class Organization

Remarks

An Organization represents a business entity within Tracker. Individuals can belong to Organizations. Organizations can have multiple Locations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..Organization

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Members
ININ.IceLib.Tracker Namespace


Organization Members

[image] [image]

IceLib Technical Reference
Organization Members
Organization Class Constructors Methods Properties See Also Send Feedback

The Organization type exposes the following members.

Constructors

 | Name | Description
Public method | Organization | Initializes a new instance of the Organization class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationOrganizationId | Gets or sets the application organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalId | Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalSource | Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsActive | Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationTypeId | Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | UnknownIndividualId | Gets or sets the unknown individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Organization Class
ININ.IceLib.Tracker Namespace


Organization Constructor

[image]

IceLib Technical Reference
Organization Constructor
Organization Class See Also Send Feedback
Initializes a new instance of the Organization class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Organization()
Visual Basic
Public Sub New

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


Organization Methods

[image] [image]

IceLib Technical Reference
Organization Methods
Organization Class See Also Send Feedback

The Organization type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Organization Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
Organization..::..Reset Method
Organization Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


Organization Properties

[image] [image]

IceLib Technical Reference
Organization Properties
Organization Class See Also Send Feedback

The Organization type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationOrganizationId | Gets or sets the application organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalId | Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ExternalSource | Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsActive | Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ModifyDateTime | Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationTypeId | Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | UnknownIndividualId | Gets or sets the unknown individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Organization Class
ININ.IceLib.Tracker Namespace


ApplicationOrganizationId Property

[image]

IceLib Technical Reference
Organization..::..ApplicationOrganizationId Property
Organization Class See Also Send Feedback
Gets or sets the application organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationOrganizationId { get; set; }
Visual Basic
Public Property ApplicationOrganizationId As String
    Get
    Set

Field Value

The application organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
Organization..::..ExternalId Property
Organization Class See Also Send Feedback
Gets or sets the external ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
Organization..::..ExternalSource Property
Organization Class See Also Send Feedback
Gets or sets the external source. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


IsActive Property

[image]

IceLib Technical Reference
Organization..::..IsActive Property
Organization Class See Also Send Feedback
Gets or sets a value indicating whether this instance is active. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsActive { get; set; }
Visual Basic
Public Property IsActive As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is active; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
Organization..::..IsPrivate Property
Organization Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


ModifyDateTime Property

[image]

IceLib Technical Reference
Organization..::..ModifyDateTime Property
Organization Class See Also Send Feedback
Gets or sets the modify date time. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> ModifyDateTime { get; internal set; }
Visual Basic
Public Property ModifyDateTime As Nullable(Of DateTime)
    Get
    Friend Set

Field Value

The modify date time, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
Organization..::..Name Property
Organization Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
Organization..::..OrganizationId Property
Organization Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


OrganizationTypeId Property

[image]

IceLib Technical Reference
Organization..::..OrganizationTypeId Property
Organization Class See Also Send Feedback
Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> OrganizationTypeId { get; set; }
Visual Basic
Public Property OrganizationTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The organization type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


OwnerId Property

[image]

IceLib Technical Reference
Organization..::..OwnerId Property
Organization Class See Also Send Feedback
Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

Field Value

The owner ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


SiteId Property

[image]

IceLib Technical Reference
Organization..::..SiteId Property
Organization Class See Also Send Feedback
Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> SiteId { get; set; }
Visual Basic
Public Property SiteId As Nullable(Of Long)
    Get
    Set

Field Value

The site ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


UnknownIndividualId Property

[image]

IceLib Technical Reference
Organization..::..UnknownIndividualId Property
Organization Class See Also Send Feedback
Gets or sets the unknown individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UnknownIndividualId { get; set; }
Visual Basic
Public Property UnknownIndividualId As String
    Get
    Set

Field Value

The unknown individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
Organization..::..Version Property
Organization Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Organization Class
Organization Members
ININ.IceLib.Tracker Namespace


OrganizationAddress Class

[image]

IceLib Technical Reference
OrganizationAddress Class
Members See Also Send Feedback
Represents an organization address within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OrganizationAddress
Visual Basic
Public Class OrganizationAddress

Remarks

Provides a way to assign Tracker addresses to Organizations.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..OrganizationAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Members
ININ.IceLib.Tracker Namespace


OrganizationAddress Members

[image] [image]

IceLib Technical Reference
OrganizationAddress Members
OrganizationAddress Class Constructors Methods Properties See Also Send Feedback

The OrganizationAddress type exposes the following members.

Constructors

 | Name | Description
Public method | OrganizationAddress | Initializes a new instance of the OrganizationAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressInstanceId | Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AddressTypeId | Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForIndividual | Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForLocation | Gets or sets a value indicating whether this instance is default address for location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationAddress Class
ININ.IceLib.Tracker Namespace


OrganizationAddress Constructor

[image]

IceLib Technical Reference
OrganizationAddress Constructor
OrganizationAddress Class See Also Send Feedback
Initializes a new instance of the OrganizationAddress class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationAddress()
Visual Basic
Public Sub New

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


OrganizationAddress Methods

[image] [image]

IceLib Technical Reference
OrganizationAddress Methods
OrganizationAddress Class See Also Send Feedback

The OrganizationAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrganizationAddress Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
OrganizationAddress..::..Reset Method
OrganizationAddress Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


OrganizationAddress Properties

[image] [image]

IceLib Technical Reference
OrganizationAddress Properties
OrganizationAddress Class See Also Send Feedback

The OrganizationAddress type exposes the following members.

Properties

 | Name | Description
Public property | AddressInstanceId | Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AddressTypeId | Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForIndividual | Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultAddressForLocation | Gets or sets a value indicating whether this instance is default address for location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationAddress Class
ININ.IceLib.Tracker Namespace


AddressInstanceId Property

[image]

IceLib Technical Reference
OrganizationAddress..::..AddressInstanceId Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AddressInstanceId { get; set; }
Visual Basic
Public Property AddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


AddressTypeId Property

[image]

IceLib Technical Reference
OrganizationAddress..::..AddressTypeId Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AddressTypeId { get; set; }
Visual Basic
Public Property AddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
OrganizationAddress..::..City Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
OrganizationAddress..::..Country Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


IsDefault Property

[image]

IceLib Technical Reference
OrganizationAddress..::..IsDefault Property
OrganizationAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


IsDefaultAddressForIndividual Property

[image]

IceLib Technical Reference
OrganizationAddress..::..IsDefaultAddressForIndividual Property
OrganizationAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default address for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefaultAddressForIndividual { get; set; }
Visual Basic
Public Property IsDefaultAddressForIndividual As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default address for individual; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


IsDefaultAddressForLocation Property

[image]

IceLib Technical Reference
OrganizationAddress..::..IsDefaultAddressForLocation Property
OrganizationAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default address for location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefaultAddressForLocation { get; set; }
Visual Basic
Public Property IsDefaultAddressForLocation As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default address for location; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
OrganizationAddress..::..OrganizationId Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


State Property

[image]

IceLib Technical Reference
OrganizationAddress..::..State Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set

Field Value

The state, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


StreetAddress Property

[image]

IceLib Technical Reference
OrganizationAddress..::..StreetAddress Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StreetAddress { get; set; }
Visual Basic
Public Property StreetAddress As String
    Get
    Set

Field Value

The street address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


SystemInsertDate Property

[image]

IceLib Technical Reference
OrganizationAddress..::..SystemInsertDate Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> SystemInsertDate { get; set; }
Visual Basic
Public Property SystemInsertDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The system insert date, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
OrganizationAddress..::..Version Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


Zip Property

[image]

IceLib Technical Reference
OrganizationAddress..::..Zip Property
OrganizationAddress Class See Also Send Feedback
Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Zip { get; set; }
Visual Basic
Public Property Zip As String
    Get
    Set

Field Value

The zip, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationAddress Class
OrganizationAddress Members
ININ.IceLib.Tracker Namespace


OrganizationDetails Class

[image]

IceLib Technical Reference
OrganizationDetails Class
Members See Also Send Feedback
Helper class to contain the return parameters for the GetOrganizationDetails(String) methods.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OrganizationDetails
Visual Basic
Public Class OrganizationDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..OrganizationDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationDetails Members
ININ.IceLib.Tracker Namespace


OrganizationDetails Members

[image] [image]

IceLib Technical Reference
OrganizationDetails Members
OrganizationDetails Class Methods Properties See Also Send Feedback

The OrganizationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LocationViews | Gets the location views.
Public property | Organization | Gets the organization.
Public property | OrganizationAddresses | Gets the organization addresses.
Public property | OrganizationInteractionAddresses | Gets the organization interaction addresses.
Public property | OrganizationTrackerAttributeViews | Gets the organization Tracker attribute views.

See Also

OrganizationDetails Class
ININ.IceLib.Tracker Namespace


OrganizationDetails Methods

[image] [image]

IceLib Technical Reference
OrganizationDetails Methods
OrganizationDetails Class See Also Send Feedback

The OrganizationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrganizationDetails Class
ININ.IceLib.Tracker Namespace


OrganizationDetails Properties

[image] [image]

IceLib Technical Reference
OrganizationDetails Properties
OrganizationDetails Class See Also Send Feedback

The OrganizationDetails type exposes the following members.

Properties

 | Name | Description
Public property | LocationViews | Gets the location views.
Public property | Organization | Gets the organization.
Public property | OrganizationAddresses | Gets the organization addresses.
Public property | OrganizationInteractionAddresses | Gets the organization interaction addresses.
Public property | OrganizationTrackerAttributeViews | Gets the organization Tracker attribute views.

See Also

OrganizationDetails Class
ININ.IceLib.Tracker Namespace


LocationViews Property

[image]

IceLib Technical Reference
OrganizationDetails..::..LocationViews Property
OrganizationDetails Class See Also Send Feedback
Gets the location views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<LocationView> LocationViews { get; }
Visual Basic
Public ReadOnly Property LocationViews As ReadOnlyCollection(Of LocationView)
    Get

Field Value

The location views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationDetails Class
OrganizationDetails Members
ININ.IceLib.Tracker Namespace


Organization Property

[image]

IceLib Technical Reference
OrganizationDetails..::..Organization Property
OrganizationDetails Class See Also Send Feedback
Gets the organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Organization Organization { get; }
Visual Basic
Public ReadOnly Property Organization As Organization
    Get

Field Value

The organization.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationDetails Class
OrganizationDetails Members
ININ.IceLib.Tracker Namespace


OrganizationAddresses Property

[image]

IceLib Technical Reference
OrganizationDetails..::..OrganizationAddresses Property
OrganizationDetails Class See Also Send Feedback
Gets the organization addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<OrganizationAddress> OrganizationAddresses { get; }
Visual Basic
Public ReadOnly Property OrganizationAddresses As ReadOnlyCollection(Of OrganizationAddress)
    Get

Field Value

The organization addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationDetails Class
OrganizationDetails Members
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddresses Property

[image]

IceLib Technical Reference
OrganizationDetails..::..OrganizationInteractionAddresses Property
OrganizationDetails Class See Also Send Feedback
Gets the organization interaction addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<OrganizationInteractionAddress> OrganizationInteractionAddresses { get; }
Visual Basic
Public ReadOnly Property OrganizationInteractionAddresses As ReadOnlyCollection(Of OrganizationInteractionAddress)
    Get

Field Value

The organization interaction addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationDetails Class
OrganizationDetails Members
ININ.IceLib.Tracker Namespace


OrganizationTrackerAttributeViews Property

[image]

IceLib Technical Reference
OrganizationDetails..::..OrganizationTrackerAttributeViews Property
OrganizationDetails Class See Also Send Feedback
Gets the organization Tracker attribute views.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<TrackerAttributeView> OrganizationTrackerAttributeViews { get; }
Visual Basic
Public ReadOnly Property OrganizationTrackerAttributeViews As ReadOnlyCollection(Of TrackerAttributeView)
    Get

Field Value

The organization Tracker attribute views.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationDetails Class
OrganizationDetails Members
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddress Class

[image]

IceLib Technical Reference
OrganizationInteractionAddress Class
Members See Also Send Feedback
Represents an organization InteractionAddress within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OrganizationInteractionAddress
Visual Basic
Public Class OrganizationInteractionAddress

Remarks

Provides a way to assign Tracker interaction addresses to Individuals.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..OrganizationInteractionAddress

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddress Members

[image] [image]

IceLib Technical Reference
OrganizationInteractionAddress Members
OrganizationInteractionAddress Class Constructors Methods Properties See Also Send Feedback

The OrganizationInteractionAddress type exposes the following members.

Constructors

 | Name | Description
Public method | OrganizationInteractionAddress | Initializes a new instance of the OrganizationInteractionAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressSubtypeId | Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultInteractionAddressForIndividual | Gets or sets a value indicating whether this instance is default InteractionAddress for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultInteractionAddressForLocation | Gets or sets a value indicating whether this instance is the default InteractionAddress for location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationInteractionAddress Class
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddress Constructor

[image]

IceLib Technical Reference
OrganizationInteractionAddress Constructor
OrganizationInteractionAddress Class See Also Send Feedback
Initializes a new instance of the OrganizationInteractionAddress class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationInteractionAddress()
Visual Basic
Public Sub New

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddress Methods

[image] [image]

IceLib Technical Reference
OrganizationInteractionAddress Methods
OrganizationInteractionAddress Class See Also Send Feedback

The OrganizationInteractionAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrganizationInteractionAddress Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..Reset Method
OrganizationInteractionAddress Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddress Properties

[image] [image]

IceLib Technical Reference
OrganizationInteractionAddress Properties
OrganizationInteractionAddress Class See Also Send Feedback

The OrganizationInteractionAddress type exposes the following members.

Properties

 | Name | Description
Public property | InteractionAddressInstanceId | Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressSubtypeId | Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddressTypeId | Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefault | Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultInteractionAddressForIndividual | Gets or sets a value indicating whether this instance is default InteractionAddress for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsDefaultInteractionAddressForLocation | Gets or sets a value indicating whether this instance is the default InteractionAddress for location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SystemInsertDate | Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationInteractionAddress Class
ININ.IceLib.Tracker Namespace


InteractionAddressInstanceId Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..InteractionAddressInstanceId Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address instance ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressInstanceId { get; set; }
Visual Basic
Public Property InteractionAddressInstanceId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address instance ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressSubtypeId Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..InteractionAddressSubtypeId Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address subtype ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressSubtypeId { get; set; }
Visual Basic
Public Property InteractionAddressSubtypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address subtype ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


InteractionAddressTypeId Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..InteractionAddressTypeId Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the interaction address type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> InteractionAddressTypeId { get; set; }
Visual Basic
Public Property InteractionAddressTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The interaction address type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


IsDefault Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..IsDefault Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


IsDefaultInteractionAddressForIndividual Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..IsDefaultInteractionAddressForIndividual Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is default InteractionAddress for individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefaultInteractionAddressForIndividual { get; set; }
Visual Basic
Public Property IsDefaultInteractionAddressForIndividual As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default InteractionAddress for individual; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


IsDefaultInteractionAddressForLocation Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..IsDefaultInteractionAddressForLocation Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets a value indicating whether this instance is the default InteractionAddress for location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefaultInteractionAddressForLocation { get; set; }
Visual Basic
Public Property IsDefaultInteractionAddressForLocation As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is default InteractionAddress for location; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..OrganizationId Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


SystemInsertDate Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..SystemInsertDate Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the system insert date. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> SystemInsertDate { get; set; }
Visual Basic
Public Property SystemInsertDate As Nullable(Of DateTime)
    Get
    Set

Field Value

The system insert date, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


Value Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..Value Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
OrganizationInteractionAddress..::..Version Property
OrganizationInteractionAddress Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationInteractionAddress Class
OrganizationInteractionAddress Members
ININ.IceLib.Tracker Namespace


OrganizationName Class

[image]

IceLib Technical Reference
OrganizationName Class
Members See Also Send Feedback
Represents an organization name within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OrganizationName
Visual Basic
Public Class OrganizationName

Remarks

Provides a mapping between Organizations and names.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..OrganizationName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationName Members
ININ.IceLib.Tracker Namespace


OrganizationName Members

[image] [image]

IceLib Technical Reference
OrganizationName Members
OrganizationName Class Constructors Methods Properties See Also Send Feedback

The OrganizationName type exposes the following members.

Constructors

 | Name | Description
Public method | OrganizationName | Initializes a new instance of the OrganizationName class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationName Class
ININ.IceLib.Tracker Namespace


OrganizationName Constructor

[image]

IceLib Technical Reference
OrganizationName Constructor
OrganizationName Class See Also Send Feedback
Initializes a new instance of the OrganizationName class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationName()
Visual Basic
Public Sub New

See Also

OrganizationName Class
OrganizationName Members
ININ.IceLib.Tracker Namespace


OrganizationName Methods

[image] [image]

IceLib Technical Reference
OrganizationName Methods
OrganizationName Class See Also Send Feedback

The OrganizationName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrganizationName Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
OrganizationName..::..Reset Method
OrganizationName Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationName Class
OrganizationName Members
ININ.IceLib.Tracker Namespace


OrganizationName Properties

[image] [image]

IceLib Technical Reference
OrganizationName Properties
OrganizationName Class See Also Send Feedback

The OrganizationName type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationName Class
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
OrganizationName..::..Name Property
OrganizationName Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationName Class
OrganizationName Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
OrganizationName..::..OrganizationId Property
OrganizationName Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationName Class
OrganizationName Members
ININ.IceLib.Tracker Namespace


OrganizationType Class

[image]

IceLib Technical Reference
OrganizationType Class
Members See Also Send Feedback
Represents an organization type within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OrganizationType
Visual Basic
Public Class OrganizationType

Remarks

OrganizationTypes are used to classify Organizations within Tracker. The most important property of an OrganizationType is the Name property. This property is what is usually displayed to users in applications. Typical OrganizationType names are: Customer, Vendor, External, and Partner.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..OrganizationType

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationType Members
ININ.IceLib.Tracker Namespace


OrganizationType Members

[image] [image]

IceLib Technical Reference
OrganizationType Members
OrganizationType Class Constructors Methods Properties See Also Send Feedback

The OrganizationType type exposes the following members.

Constructors

 | Name | Description
Public method | OrganizationType | Initializes a new instance of the OrganizationType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationType Class
ININ.IceLib.Tracker Namespace


OrganizationType Constructor

[image]

IceLib Technical Reference
OrganizationType Constructor
OrganizationType Class See Also Send Feedback
Initializes a new instance of the OrganizationType class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationType()
Visual Basic
Public Sub New

See Also

OrganizationType Class
OrganizationType Members
ININ.IceLib.Tracker Namespace


OrganizationType Methods

[image] [image]

IceLib Technical Reference
OrganizationType Methods
OrganizationType Class See Also Send Feedback

The OrganizationType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrganizationType Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
OrganizationType..::..Reset Method
OrganizationType Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationType Class
OrganizationType Members
ININ.IceLib.Tracker Namespace


OrganizationType Properties

[image] [image]

IceLib Technical Reference
OrganizationType Properties
OrganizationType Class See Also Send Feedback

The OrganizationType type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationType Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
OrganizationType..::..AdminEditable Property
OrganizationType Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationType Class
OrganizationType Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
OrganizationType..::..Id Property
OrganizationType Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationType Class
OrganizationType Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
OrganizationType..::..Name Property
OrganizationType Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationType Class
OrganizationType Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
OrganizationType..::..Version Property
OrganizationType Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationType Class
OrganizationType Members
ININ.IceLib.Tracker Namespace


OrganizationView Class

[image]

IceLib Technical Reference
OrganizationView Class
Members See Also Send Feedback
Represents an organization view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class OrganizationView
Visual Basic
Public Class OrganizationView

Remarks

The OrganizationView class is used by methods that return information about Organizations. One such method is the SearchOrganizations(SearchOrganizationsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..OrganizationView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Members
ININ.IceLib.Tracker Namespace


OrganizationView Members

[image] [image]

IceLib Technical Reference
OrganizationView Members
OrganizationView Class Constructors Methods Properties See Also Send Feedback

The OrganizationView type exposes the following members.

Constructors

 | Name | Description
Public method | OrganizationView | Initializes a new instance of the OrganizationView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Type | Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationView Class
ININ.IceLib.Tracker Namespace


OrganizationView Constructor

[image]

IceLib Technical Reference
OrganizationView Constructor
OrganizationView Class See Also Send Feedback
Initializes a new instance of the OrganizationView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationView()
Visual Basic
Public Sub New

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


OrganizationView Methods

[image] [image]

IceLib Technical Reference
OrganizationView Methods
OrganizationView Class See Also Send Feedback

The OrganizationView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrganizationView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
OrganizationView..::..Reset Method
OrganizationView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


OrganizationView Properties

[image] [image]

IceLib Technical Reference
OrganizationView Properties
OrganizationView Class See Also Send Feedback

The OrganizationView type exposes the following members.

Properties

 | Name | Description
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Type | Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

OrganizationView Class
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
OrganizationView..::..City Property
OrganizationView Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
OrganizationView..::..Country Property
OrganizationView Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
OrganizationView..::..Id Property
OrganizationView Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
OrganizationView..::..Name Property
OrganizationView Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


State Property

[image]

IceLib Technical Reference
OrganizationView..::..State Property
OrganizationView Class See Also Send Feedback
Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set

Field Value

The state, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


Type Property

[image]

IceLib Technical Reference
OrganizationView..::..Type Property
OrganizationView Class See Also Send Feedback
Gets or sets the type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

Field Value

The type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

OrganizationView Class
OrganizationView Members
ININ.IceLib.Tracker Namespace


PrivateType Enumeration

[image]

IceLib Technical Reference
PrivateType Enumeration
See Also Send Feedback
This enum is used to distinguish between public interactions and private interactions.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum PrivateType
Visual Basic
Public Enumeration PrivateType

Members

Member name | Value | Description
Public | 0 | Public interactions.
Private | 1 | Private interactions.
PublicAndPrivate | 2 | Both public and private interactions.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


QueryCollectionResultCompletedEventArgs(TResult) Class

[image]

IceLib Technical Reference
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
Members See Also Send Feedback
Provides a collection of data for asynchronously completed events of a TrackerAdmin.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueryCollectionResultCompletedEventArgs<TResult> : AsyncCompletedEventArgs
where TResult : class
Visual Basic
Public Class QueryCollectionResultCompletedEventArgs(Of TResult As Class) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TResult
The result.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib.Tracker Namespace


QueryCollectionResultCompletedEventArgs(TResult) Members

[image] [image]

IceLib Technical Reference
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class Constructors Methods Properties See Also Send Feedback

The QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> | Initializes a new instance of the QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result | Gets the result associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib.Tracker Namespace


QueryCollectionResultCompletedEventArgs(TResult) Constructor

[image]

IceLib Technical Reference
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Constructor
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback
Initializes a new instance of the QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueryCollectionResultCompletedEventArgs(
    Collection<TResult> result,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    result As Collection(Of TResult), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

result
Type: System.Collections.ObjectModel..::..Collection<(Of <(<' TResult >)>)>
The Collection<(Of <(<'T>)>)> of results.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib.Tracker Namespace


QueryCollectionResultCompletedEventArgs(TResult) Methods

[image] [image]

IceLib Technical Reference
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Methods
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback

The QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib.Tracker Namespace


QueryCollectionResultCompletedEventArgs(TResult) Properties

[image] [image]

IceLib Technical Reference
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Properties
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback

The QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result | Gets the result associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib.Tracker Namespace


Result Property

[image]

IceLib Technical Reference
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)>..::..Result Property
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback
Gets the result associated with the event.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<TResult> Result { get; }
Visual Basic
Public ReadOnly Property Result As Collection(Of TResult)
    Get

Field Value

The result.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
QueryCollectionResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib.Tracker Namespace


QueryResultCompletedEventArgs(TResult) Class

[image]

IceLib Technical Reference
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
Members See Also Send Feedback
Provides data for asynchronously completed events of a TrackerAdmin.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class QueryResultCompletedEventArgs<TResult> : AsyncCompletedEventArgs
where TResult : class
Visual Basic
Public Class QueryResultCompletedEventArgs(Of TResult As Class) _
    Inherits AsyncCompletedEventArgs

Type Parameters

TResult
The result.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..QueryResultCompletedEventArgs<(Of <(<'TResult>)>)>

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib.Tracker Namespace


QueryResultCompletedEventArgs(TResult) Members

[image] [image]

IceLib Technical Reference
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class Constructors Methods Properties See Also Send Feedback

The QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> | Initializes a new instance of the QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result | Gets the result associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib.Tracker Namespace


QueryResultCompletedEventArgs(TResult) Constructor

[image]

IceLib Technical Reference
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Constructor
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback
Initializes a new instance of the QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public QueryResultCompletedEventArgs(
    TResult result,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    result As TResult, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

result
Type: TResult
The result.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib.Tracker Namespace


QueryResultCompletedEventArgs(TResult) Methods

[image] [image]

IceLib Technical Reference
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Methods
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback

The QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib.Tracker Namespace


QueryResultCompletedEventArgs(TResult) Properties

[image] [image]

IceLib Technical Reference
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Properties
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback

The QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | Result | Gets the result associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
ININ.IceLib.Tracker Namespace


Result Property

[image]

IceLib Technical Reference
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)>..::..Result Property
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class See Also Send Feedback
Gets the result associated with the event.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TResult Result { get; }
Visual Basic
Public ReadOnly Property Result As TResult
    Get

Field Value

The result.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Class
QueryResultCompletedEventArgs<(Of <(<'TResult>)>)> Members
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookupInformation Class

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation Class
Members See Also Send Feedback
Represents reverse InteractionAddress lookup information within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseInteractionAddressLookupInformation
Visual Basic
Public Class ReverseInteractionAddressLookupInformation

Remarks

The TrackerSearch method ReverseInteractionAddressLookup(String, InteractionType, String) uses the ReverseInteractionAddressLookupInformation class to return the results of the lookup.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseInteractionAddressLookupInformation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookupInformation Members

[image] [image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation Members
ReverseInteractionAddressLookupInformation Class Constructors Methods Properties See Also Send Feedback

The ReverseInteractionAddressLookupInformation type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseInteractionAddressLookupInformation | Initializes a new instance of the ReverseInteractionAddressLookupInformation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Company | Gets or sets the company. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Department | Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Email | Gets or sets the email. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Fax | Gets or sets the fax. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId | Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the name of the location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Phone | Gets or sets the phone. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Web | Gets or sets the web. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

ReverseInteractionAddressLookupInformation Class
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookupInformation Constructor

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation Constructor
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Initializes a new instance of the ReverseInteractionAddressLookupInformation class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseInteractionAddressLookupInformation()
Visual Basic
Public Sub New

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookupInformation Methods

[image] [image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation Methods
ReverseInteractionAddressLookupInformation Class See Also Send Feedback

The ReverseInteractionAddressLookupInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseInteractionAddressLookupInformation Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Reset Method
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookupInformation Properties

[image] [image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation Properties
ReverseInteractionAddressLookupInformation Class See Also Send Feedback

The ReverseInteractionAddressLookupInformation type exposes the following members.

Properties

 | Name | Description
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Company | Gets or sets the company. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Department | Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Email | Gets or sets the email. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Fax | Gets or sets the fax. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUserId | Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the name of the location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Phone | Gets or sets the phone. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | State | Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StreetAddress | Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Web | Gets or sets the web. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Zip | Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

ReverseInteractionAddressLookupInformation Class
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..City Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Company Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Company Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the company. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set

Field Value

The company, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Country Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Department Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Department Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; set; }
Visual Basic
Public Property Department As String
    Get
    Set

Field Value

The department, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Email Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Email Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the email. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set

Field Value

The email, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Fax Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Fax Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the fax. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set

Field Value

The fax, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..FirstName Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


ICUserId Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..ICUserId Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the IC user ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUserId { get; set; }
Visual Basic
Public Property ICUserId As String
    Get
    Set

Field Value

The IC user ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..IndividualId Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..IsPrivate Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..LastName Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The last name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..LocationId Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


LocationName Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..LocationName Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the name of the location. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationName { get; set; }
Visual Basic
Public Property LocationName As String
    Get
    Set

Field Value

The name of the location, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


MiddleName Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..MiddleName Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic
Public Property MiddleName As String
    Get
    Set

Field Value

The middle name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..OrganizationId Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..OrganizationName Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the name of the organization. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; set; }
Visual Basic
Public Property OrganizationName As String
    Get
    Set

Field Value

The name of the organization, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Phone Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Phone Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the phone. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Phone { get; set; }
Visual Basic
Public Property Phone As String
    Get
    Set

Field Value

The phone, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


State Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..State Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the state. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set

Field Value

The state, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


StreetAddress Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..StreetAddress Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the street address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StreetAddress { get; set; }
Visual Basic
Public Property StreetAddress As String
    Get
    Set

Field Value

The street address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Web Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Web Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the web. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Web { get; set; }
Visual Basic
Public Property Web As String
    Get
    Set

Field Value

The web, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


Zip Property

[image]

IceLib Technical Reference
ReverseInteractionAddressLookupInformation..::..Zip Property
ReverseInteractionAddressLookupInformation Class See Also Send Feedback
Gets or sets the zip. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Zip { get; set; }
Visual Basic
Public Property Zip As String
    Get
    Set

Field Value

The zip, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseInteractionAddressLookupInformation Class
ReverseInteractionAddressLookupInformation Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesCommonInfo Class

[image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo Class
Members See Also Send Feedback
Holds common information used during reverse whitepage operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseWhitepagesCommonInfo
Visual Basic
Public Class ReverseWhitepagesCommonInfo

Remarks

Use this class to hold common reverse whitepage information.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseWhitepagesCommonInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesCommonInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesCommonInfo Members

[image] [image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo Members
ReverseWhitepagesCommonInfo Class Constructors Methods Properties See Also Send Feedback

The ReverseWhitepagesCommonInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseWhitepagesCommonInfo | Initializes a new instance of the ReverseWhitepagesCommonInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExternalId | Gets or sets the external ID.
Public property | ExternalSource | Gets or sets the external source.
Public property | Remarks | Gets or sets the remarks.

See Also

ReverseWhitepagesCommonInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesCommonInfo Constructor

[image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo Constructor
ReverseWhitepagesCommonInfo Class See Also Send Feedback
Initializes a new instance of the ReverseWhitepagesCommonInfo class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesCommonInfo()
Visual Basic
Public Sub New

See Also

ReverseWhitepagesCommonInfo Class
ReverseWhitepagesCommonInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesCommonInfo Methods

[image] [image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo Methods
ReverseWhitepagesCommonInfo Class See Also Send Feedback

The ReverseWhitepagesCommonInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseWhitepagesCommonInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesCommonInfo Properties

[image] [image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo Properties
ReverseWhitepagesCommonInfo Class See Also Send Feedback

The ReverseWhitepagesCommonInfo type exposes the following members.

Properties

 | Name | Description
Public property | ExternalId | Gets or sets the external ID.
Public property | ExternalSource | Gets or sets the external source.
Public property | Remarks | Gets or sets the remarks.

See Also

ReverseWhitepagesCommonInfo Class
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo..::..ExternalId Property
ReverseWhitepagesCommonInfo Class See Also Send Feedback
Gets or sets the external ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesCommonInfo Class
ReverseWhitepagesCommonInfo Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo..::..ExternalSource Property
ReverseWhitepagesCommonInfo Class See Also Send Feedback
Gets or sets the external source.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesCommonInfo Class
ReverseWhitepagesCommonInfo Members
ININ.IceLib.Tracker Namespace


Remarks Property

[image]

IceLib Technical Reference
ReverseWhitepagesCommonInfo..::..Remarks Property
ReverseWhitepagesCommonInfo Class See Also Send Feedback
Gets or sets the remarks.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Remarks { get; set; }
Visual Basic
Public Property Remarks As String
    Get
    Set

Field Value

The remarks.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesCommonInfo Class
ReverseWhitepagesCommonInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesGeneralInfo Class

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo Class
Members See Also Send Feedback
Holds general information used during reverse whitepage operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseWhitepagesGeneralInfo
Visual Basic
Public Class ReverseWhitepagesGeneralInfo

Remarks

Use this class to hold general reverse whitepage information.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseWhitepagesGeneralInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesGeneralInfo Members

[image] [image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo Members
ReverseWhitepagesGeneralInfo Class Constructors Methods Properties See Also Send Feedback

The ReverseWhitepagesGeneralInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseWhitepagesGeneralInfo | Initializes a new instance of the ReverseWhitepagesGeneralInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactSummary | Gets or sets the contact summary.
Public property | DisplayName | Gets or sets the display name.
Public property | ICInteractionAttribute | Gets or sets the IC Interaction Attribute.
Public property | InteractionAddress | Gets or sets the interaction address.
Public property | InteractionDirection | Gets or sets the interaction direction.
Public property | InteractionType | Gets or sets the interaction type.
Public property | IsDefinitiveResult | Will be trueTruetruetrue (True in Visual Basic) if this result is definitive.
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private.
Public property | IsStopSource | Will be trueTruetruetrue (True in Visual Basic) if this is the stop source.
Public property | Origin | Gets or sets the origin.
Public property | Owner | Gets or sets the owner.
Public property | Replicate | This will be trueTruetruetrue (True in Visual Basic) if this contact should be replicated.
Public property | Source | Gets or sets the source.

See Also

ReverseWhitepagesGeneralInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesGeneralInfo Constructor

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo Constructor
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Initializes a new instance of the ReverseWhitepagesGeneralInfo class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesGeneralInfo()
Visual Basic
Public Sub New

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesGeneralInfo Methods

[image] [image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo Methods
ReverseWhitepagesGeneralInfo Class See Also Send Feedback

The ReverseWhitepagesGeneralInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseWhitepagesGeneralInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesGeneralInfo Properties

[image] [image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo Properties
ReverseWhitepagesGeneralInfo Class See Also Send Feedback

The ReverseWhitepagesGeneralInfo type exposes the following members.

Properties

 | Name | Description
Public property | ContactSummary | Gets or sets the contact summary.
Public property | DisplayName | Gets or sets the display name.
Public property | ICInteractionAttribute | Gets or sets the IC Interaction Attribute.
Public property | InteractionAddress | Gets or sets the interaction address.
Public property | InteractionDirection | Gets or sets the interaction direction.
Public property | InteractionType | Gets or sets the interaction type.
Public property | IsDefinitiveResult | Will be trueTruetruetrue (True in Visual Basic) if this result is definitive.
Public property | IsPrivate | Gets or sets a value indicating whether this instance is private.
Public property | IsStopSource | Will be trueTruetruetrue (True in Visual Basic) if this is the stop source.
Public property | Origin | Gets or sets the origin.
Public property | Owner | Gets or sets the owner.
Public property | Replicate | This will be trueTruetruetrue (True in Visual Basic) if this contact should be replicated.
Public property | Source | Gets or sets the source.

See Also

ReverseWhitepagesGeneralInfo Class
ININ.IceLib.Tracker Namespace


ContactSummary Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..ContactSummary Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the contact summary.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ContactSummary { get; set; }
Visual Basic
Public Property ContactSummary As String
    Get
    Set

Field Value

The contact summary.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


DisplayName Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..DisplayName Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the display name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The display name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


ICInteractionAttribute Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..ICInteractionAttribute Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the IC Interaction Attribute.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICInteractionAttribute { get; set; }
Visual Basic
Public Property ICInteractionAttribute As String
    Get
    Set

Field Value

The IC Interaction Attribute.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


InteractionAddress Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..InteractionAddress Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the interaction address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddress { get; set; }
Visual Basic
Public Property InteractionAddress As String
    Get
    Set

Field Value

The interaction Address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


InteractionDirection Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..InteractionDirection Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the interaction direction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<InteractionDirection> InteractionDirection { get; set; }
Visual Basic
Public Property InteractionDirection As Nullable(Of InteractionDirection)
    Get
    Set

Field Value

The interaction direction.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


InteractionType Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..InteractionType Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the interaction type.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<InteractionType> InteractionType { get; set; }
Visual Basic
Public Property InteractionType As Nullable(Of InteractionType)
    Get
    Set

Field Value

The interaction type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


IsDefinitiveResult Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..IsDefinitiveResult Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Will be trueTruetruetrue (True in Visual Basic) if this result is definitive.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsDefinitiveResult { get; set; }
Visual Basic
Public Property IsDefinitiveResult As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this result is definitive; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


IsPrivate Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..IsPrivate Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is private.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsPrivate { get; set; }
Visual Basic
Public Property IsPrivate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is private; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


IsStopSource Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..IsStopSource Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Will be trueTruetruetrue (True in Visual Basic) if this is the stop source.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> IsStopSource { get; set; }
Visual Basic
Public Property IsStopSource As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this is the stop source; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


Origin Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..Origin Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the origin.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Origin { get; set; }
Visual Basic
Public Property Origin As String
    Get
    Set

Field Value

The origin.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


Owner Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..Owner Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the owner.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Owner { get; set; }
Visual Basic
Public Property Owner As String
    Get
    Set

Field Value

The owner.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


Replicate Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..Replicate Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
This will be trueTruetruetrue (True in Visual Basic) if this contact should be replicated.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> Replicate { get; set; }
Visual Basic
Public Property Replicate As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if this contact should be replicated; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


Source Property

[image]

IceLib Technical Reference
ReverseWhitepagesGeneralInfo..::..Source Property
ReverseWhitepagesGeneralInfo Class See Also Send Feedback
Gets or sets the source.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Source { get; set; }
Visual Basic
Public Property Source As String
    Get
    Set

Field Value

The source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesGeneralInfo Class
ReverseWhitepagesGeneralInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesIndividualInfo Class

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo Class
Members See Also Send Feedback
Holds information about an individual that is used during reverse whitepage operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseWhitepagesIndividualInfo
Visual Basic
Public Class ReverseWhitepagesIndividualInfo

Remarks

Use this class to hold reverse whitepage information about an individual.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseWhitepagesIndividualInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesIndividualInfo Members

[image] [image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo Members
ReverseWhitepagesIndividualInfo Class Constructors Methods Properties See Also Send Feedback

The ReverseWhitepagesIndividualInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseWhitepagesIndividualInfo | Initializes a new instance of the ReverseWhitepagesIndividualInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationId | Gets or sets the application ID.
Public property | AssistantName | Gets or sets the assistant name.
Public property | AssistantPhone | Gets or sets the assistant phone.
Public property | BusinessChat | Gets or sets the business chat URL.
Public property | BusinessCity | Gets or sets the business City.
Public property | BusinessCountry | Gets or sets the business Country.
Public property | BusinessEmail | Gets or sets the business email address.
Public property | BusinessFax | Gets or sets the business fax.
Public property | BusinessMobile | Gets or sets the business mobile.
Public property | BusinessPager | Gets or sets the business pager.
Public property | BusinessPhone | Gets or sets the business phone.
Public property | BusinessPhone2 | Gets or sets the business phone2.
Public property | BusinessState | Gets or sets the business State.
Public property | BusinessStreetAddress | Gets or sets the business street address.
Public property | BusinessUrl | Gets or sets the business Url (homepage).
Public property | BusinessZip | Gets or sets the business Zip.
Public property | Company | Gets or sets the company.
Public property | Department | Gets or sets the department.
Public property | ExternalId | Gets or sets the external ID.
Public property | ExternalSource | Gets or sets the external source.
Public property | FirstName | Gets or sets the first name.
Public property | Gender | Gets or sets the gender.
Public property | HomeChat | Gets or sets the home chat.
Public property | HomeCity | Gets or sets the home City.
Public property | HomeCountry | Gets or sets the home Country.
Public property | HomeEmail | Gets or sets the home email.
Public property | HomeFax | Gets or sets the home fax.
Public property | HomeMobile | Gets or sets the home mobile.
Public property | HomePager | Gets or sets the home pager.
Public property | HomePhone | Gets or sets the home phone.
Public property | HomePhone2 | Gets or sets the home phone2.
Public property | HomeState | Gets or sets the home State.
Public property | HomeStreetAddress | Gets or sets the home street address.
Public property | HomeUrl | Gets or sets the home URL (homepage).
Public property | HomeZip | Gets or sets the home Zip.
Public property | ICUserId | Gets or sets the IC User ID.
Public property | ImageFile | Gets or sets the image file.
Public property | IndividualId | Gets or sets the individual ID.
Public property | IndividualTypeId | Gets or sets the individual type ID.
Public property | JobTitle | Gets or sets the job title.
Public property | LastName | Gets or sets the last name.
Public property | MiddleName | Gets or sets the middle name.
Public property | Remarks | Gets or sets the remarks.
Public property | StationName | Gets or sets the station name.
Public property | TitleId | Gets or sets the title ID.
Public property | Url | Gets or sets the URL.
Public property | WebLogin | Gets or sets the web login.
Public property | WebPassword | Gets or sets the web password.

See Also

ReverseWhitepagesIndividualInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesIndividualInfo Constructor

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo Constructor
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Initializes a new instance of the ReverseWhitepagesIndividualInfo class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesIndividualInfo()
Visual Basic
Public Sub New

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesIndividualInfo Methods

[image] [image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo Methods
ReverseWhitepagesIndividualInfo Class See Also Send Feedback

The ReverseWhitepagesIndividualInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseWhitepagesIndividualInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesIndividualInfo Properties

[image] [image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo Properties
ReverseWhitepagesIndividualInfo Class See Also Send Feedback

The ReverseWhitepagesIndividualInfo type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationId | Gets or sets the application ID.
Public property | AssistantName | Gets or sets the assistant name.
Public property | AssistantPhone | Gets or sets the assistant phone.
Public property | BusinessChat | Gets or sets the business chat URL.
Public property | BusinessCity | Gets or sets the business City.
Public property | BusinessCountry | Gets or sets the business Country.
Public property | BusinessEmail | Gets or sets the business email address.
Public property | BusinessFax | Gets or sets the business fax.
Public property | BusinessMobile | Gets or sets the business mobile.
Public property | BusinessPager | Gets or sets the business pager.
Public property | BusinessPhone | Gets or sets the business phone.
Public property | BusinessPhone2 | Gets or sets the business phone2.
Public property | BusinessState | Gets or sets the business State.
Public property | BusinessStreetAddress | Gets or sets the business street address.
Public property | BusinessUrl | Gets or sets the business Url (homepage).
Public property | BusinessZip | Gets or sets the business Zip.
Public property | Company | Gets or sets the company.
Public property | Department | Gets or sets the department.
Public property | ExternalId | Gets or sets the external ID.
Public property | ExternalSource | Gets or sets the external source.
Public property | FirstName | Gets or sets the first name.
Public property | Gender | Gets or sets the gender.
Public property | HomeChat | Gets or sets the home chat.
Public property | HomeCity | Gets or sets the home City.
Public property | HomeCountry | Gets or sets the home Country.
Public property | HomeEmail | Gets or sets the home email.
Public property | HomeFax | Gets or sets the home fax.
Public property | HomeMobile | Gets or sets the home mobile.
Public property | HomePager | Gets or sets the home pager.
Public property | HomePhone | Gets or sets the home phone.
Public property | HomePhone2 | Gets or sets the home phone2.
Public property | HomeState | Gets or sets the home State.
Public property | HomeStreetAddress | Gets or sets the home street address.
Public property | HomeUrl | Gets or sets the home URL (homepage).
Public property | HomeZip | Gets or sets the home Zip.
Public property | ICUserId | Gets or sets the IC User ID.
Public property | ImageFile | Gets or sets the image file.
Public property | IndividualId | Gets or sets the individual ID.
Public property | IndividualTypeId | Gets or sets the individual type ID.
Public property | JobTitle | Gets or sets the job title.
Public property | LastName | Gets or sets the last name.
Public property | MiddleName | Gets or sets the middle name.
Public property | Remarks | Gets or sets the remarks.
Public property | StationName | Gets or sets the station name.
Public property | TitleId | Gets or sets the title ID.
Public property | Url | Gets or sets the URL.
Public property | WebLogin | Gets or sets the web login.
Public property | WebPassword | Gets or sets the web password.

See Also

ReverseWhitepagesIndividualInfo Class
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..ApplicationId Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the application ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The individual application ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


AssistantName Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..AssistantName Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the assistant name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistantName { get; set; }
Visual Basic
Public Property AssistantName As String
    Get
    Set

Field Value

The assistant name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


AssistantPhone Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..AssistantPhone Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the assistant phone.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AssistantPhone { get; set; }
Visual Basic
Public Property AssistantPhone As String
    Get
    Set

Field Value

The assistant phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessChat Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessChat Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business chat URL.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessChat { get; set; }
Visual Basic
Public Property BusinessChat As String
    Get
    Set

Field Value

The business chat URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessCity Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessCity Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCity { get; set; }
Visual Basic
Public Property BusinessCity As String
    Get
    Set

Field Value

The business City.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessCountry Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessCountry Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCountry { get; set; }
Visual Basic
Public Property BusinessCountry As String
    Get
    Set

Field Value

The business Country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessEmail Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessEmail Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business email address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessEmail { get; set; }
Visual Basic
Public Property BusinessEmail As String
    Get
    Set

Field Value

The business email address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessFax Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessFax Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business fax.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessFax { get; set; }
Visual Basic
Public Property BusinessFax As String
    Get
    Set

Field Value

The business fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessMobile Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessMobile Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business mobile.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessMobile { get; set; }
Visual Basic
Public Property BusinessMobile As String
    Get
    Set

Field Value

The business mobile.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessPager Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessPager Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business pager.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPager { get; set; }
Visual Basic
Public Property BusinessPager As String
    Get
    Set

Field Value

The business pager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessPhone Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessPhone Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business phone.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone { get; set; }
Visual Basic
Public Property BusinessPhone As String
    Get
    Set

Field Value

The business phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessPhone2 Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessPhone2 Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business phone2.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone2 { get; set; }
Visual Basic
Public Property BusinessPhone2 As String
    Get
    Set

Field Value

The business phone2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessState Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessState Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessState { get; set; }
Visual Basic
Public Property BusinessState As String
    Get
    Set

Field Value

The business State.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessStreetAddress Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessStreetAddress Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessStreetAddress { get; set; }
Visual Basic
Public Property BusinessStreetAddress As String
    Get
    Set

Field Value

The business street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessUrl Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessUrl Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business Url (homepage).

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessUrl { get; set; }
Visual Basic
Public Property BusinessUrl As String
    Get
    Set

Field Value

The business URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


BusinessZip Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..BusinessZip Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the business Zip.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessZip { get; set; }
Visual Basic
Public Property BusinessZip As String
    Get
    Set

Field Value

The business Zip.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


Company Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..Company Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the company.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set

Field Value

The company.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


Department Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..Department Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the department.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; set; }
Visual Basic
Public Property Department As String
    Get
    Set

Field Value

The department.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..ExternalId Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the external ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..ExternalSource Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the external source.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..FirstName Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the first name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


Gender Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..Gender Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the gender.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Gender { get; set; }
Visual Basic
Public Property Gender As String
    Get
    Set

Field Value

The gender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeChat Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeChat Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home chat.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeChat { get; set; }
Visual Basic
Public Property HomeChat As String
    Get
    Set

Field Value

The home chat.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeCity Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeCity Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeCity { get; set; }
Visual Basic
Public Property HomeCity As String
    Get
    Set

Field Value

The home City.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeCountry Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeCountry Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeCountry { get; set; }
Visual Basic
Public Property HomeCountry As String
    Get
    Set

Field Value

The home Country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeEmail Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeEmail Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home email.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeEmail { get; set; }
Visual Basic
Public Property HomeEmail As String
    Get
    Set

Field Value

The home email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeFax Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeFax Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home fax.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeFax { get; set; }
Visual Basic
Public Property HomeFax As String
    Get
    Set

Field Value

The home fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeMobile Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeMobile Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home mobile.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeMobile { get; set; }
Visual Basic
Public Property HomeMobile As String
    Get
    Set

Field Value

The home mobile.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomePager Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomePager Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home pager.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomePager { get; set; }
Visual Basic
Public Property HomePager As String
    Get
    Set

Field Value

The home pager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomePhone Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomePhone Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home phone.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomePhone { get; set; }
Visual Basic
Public Property HomePhone As String
    Get
    Set

Field Value

The home phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomePhone2 Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomePhone2 Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home phone2.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomePhone2 { get; set; }
Visual Basic
Public Property HomePhone2 As String
    Get
    Set

Field Value

The home phone2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeState Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeState Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeState { get; set; }
Visual Basic
Public Property HomeState As String
    Get
    Set

Field Value

The home State.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeStreetAddress Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeStreetAddress Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeStreetAddress { get; set; }
Visual Basic
Public Property HomeStreetAddress As String
    Get
    Set

Field Value

The home street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeUrl Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeUrl Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home URL (homepage).

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeUrl { get; set; }
Visual Basic
Public Property HomeUrl As String
    Get
    Set

Field Value

The home URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


HomeZip Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..HomeZip Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the home Zip.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string HomeZip { get; set; }
Visual Basic
Public Property HomeZip As String
    Get
    Set

Field Value

The home Zip.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ICUserId Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..ICUserId Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the IC User ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUserId { get; set; }
Visual Basic
Public Property ICUserId As String
    Get
    Set

Field Value

The IC User ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ImageFile Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..ImageFile Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the image file.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ImageFile { get; set; }
Visual Basic
Public Property ImageFile As String
    Get
    Set

Field Value

The image file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..IndividualId Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the individual ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The individual ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


IndividualTypeId Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..IndividualTypeId Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the individual type ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> IndividualTypeId { get; set; }
Visual Basic
Public Property IndividualTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The individual type ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


JobTitle Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..JobTitle Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the job title.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string JobTitle { get; set; }
Visual Basic
Public Property JobTitle As String
    Get
    Set

Field Value

The job title.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..LastName Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the last name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The individual last name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


MiddleName Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..MiddleName Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the middle name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic
Public Property MiddleName As String
    Get
    Set

Field Value

The middle name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


Remarks Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..Remarks Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the remarks.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Remarks { get; set; }
Visual Basic
Public Property Remarks As String
    Get
    Set

Field Value

The remarks.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


StationName Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..StationName Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the station name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationName { get; set; }
Visual Basic
Public Property StationName As String
    Get
    Set

Field Value

The station name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


TitleId Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..TitleId Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the title ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> TitleId { get; set; }
Visual Basic
Public Property TitleId As Nullable(Of Long)
    Get
    Set

Field Value

The title ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


Url Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..Url Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the URL.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set

Field Value

The URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


WebLogin Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..WebLogin Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the web login.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WebLogin { get; set; }
Visual Basic
Public Property WebLogin As String
    Get
    Set

Field Value

The web login.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


WebPassword Property

[image]

IceLib Technical Reference
ReverseWhitepagesIndividualInfo..::..WebPassword Property
ReverseWhitepagesIndividualInfo Class See Also Send Feedback
Gets or sets the web password.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WebPassword { get; set; }
Visual Basic
Public Property WebPassword As String
    Get
    Set

Field Value

The web password.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesIndividualInfo Class
ReverseWhitepagesIndividualInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesInfo Class

[image]

IceLib Technical Reference
ReverseWhitepagesInfo Class
Members See Also Send Feedback
Holds reverse whitepages lookup information that Tracker Server sends or receives.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseWhitepagesInfo
Visual Basic
Public Class ReverseWhitepagesInfo

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseWhitepagesInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesInfo Members

[image] [image]

IceLib Technical Reference
ReverseWhitepagesInfo Members
ReverseWhitepagesInfo Class Constructors Methods Properties See Also Send Feedback

The ReverseWhitepagesInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseWhitepagesInfo | Initializes a new instance of the ReverseWhitepagesInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommonInfo | Gets or sets the common info.
Public property | GeneralInfo | Gets or sets the general info.
Public property | IndividualInfo | Gets or sets the individual info.
Public property | LocationInfo | Gets or sets the location info.
Public property | OrganizationInfo | Gets or sets the organization info.

See Also

ReverseWhitepagesInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesInfo Constructor

[image]

IceLib Technical Reference
ReverseWhitepagesInfo Constructor
ReverseWhitepagesInfo Class See Also Send Feedback
Initializes a new instance of the ReverseWhitepagesInfo class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesInfo()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Class
ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesInfo Methods

[image] [image]

IceLib Technical Reference
ReverseWhitepagesInfo Methods
ReverseWhitepagesInfo Class See Also Send Feedback

The ReverseWhitepagesInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseWhitepagesInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesInfo Properties

[image] [image]

IceLib Technical Reference
ReverseWhitepagesInfo Properties
ReverseWhitepagesInfo Class See Also Send Feedback

The ReverseWhitepagesInfo type exposes the following members.

Properties

 | Name | Description
Public property | CommonInfo | Gets or sets the common info.
Public property | GeneralInfo | Gets or sets the general info.
Public property | IndividualInfo | Gets or sets the individual info.
Public property | LocationInfo | Gets or sets the location info.
Public property | OrganizationInfo | Gets or sets the organization info.

See Also

ReverseWhitepagesInfo Class
ININ.IceLib.Tracker Namespace


CommonInfo Property

[image]

IceLib Technical Reference
ReverseWhitepagesInfo..::..CommonInfo Property
ReverseWhitepagesInfo Class See Also Send Feedback
Gets or sets the common info.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesCommonInfo CommonInfo { get; set; }
Visual Basic
Public Property CommonInfo As ReverseWhitepagesCommonInfo
    Get
    Set

Field Value

The common info.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Class
ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


GeneralInfo Property

[image]

IceLib Technical Reference
ReverseWhitepagesInfo..::..GeneralInfo Property
ReverseWhitepagesInfo Class See Also Send Feedback
Gets or sets the general info.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesGeneralInfo GeneralInfo { get; set; }
Visual Basic
Public Property GeneralInfo As ReverseWhitepagesGeneralInfo
    Get
    Set

Field Value

The general info.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Class
ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


IndividualInfo Property

[image]

IceLib Technical Reference
ReverseWhitepagesInfo..::..IndividualInfo Property
ReverseWhitepagesInfo Class See Also Send Feedback
Gets or sets the individual info.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesIndividualInfo IndividualInfo { get; set; }
Visual Basic
Public Property IndividualInfo As ReverseWhitepagesIndividualInfo
    Get
    Set

Field Value

The individual info.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Class
ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


LocationInfo Property

[image]

IceLib Technical Reference
ReverseWhitepagesInfo..::..LocationInfo Property
ReverseWhitepagesInfo Class See Also Send Feedback
Gets or sets the location info.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesLocationInfo LocationInfo { get; set; }
Visual Basic
Public Property LocationInfo As ReverseWhitepagesLocationInfo
    Get
    Set

Field Value

The location info.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Class
ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


OrganizationInfo Property

[image]

IceLib Technical Reference
ReverseWhitepagesInfo..::..OrganizationInfo Property
ReverseWhitepagesInfo Class See Also Send Feedback
Gets or sets the organization info.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesOrganizationInfo OrganizationInfo { get; set; }
Visual Basic
Public Property OrganizationInfo As ReverseWhitepagesOrganizationInfo
    Get
    Set

Field Value

The organization info.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesInfo Class
ReverseWhitepagesInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesLocationInfo Class

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo Class
Members See Also Send Feedback
Holds information about a location that is used during reverse whitepage operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseWhitepagesLocationInfo
Visual Basic
Public Class ReverseWhitepagesLocationInfo

Remarks

Use this class to hold reverse whitepage information about a location.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseWhitepagesLocationInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesLocationInfo Members

[image] [image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo Members
ReverseWhitepagesLocationInfo Class Constructors Methods Properties See Also Send Feedback

The ReverseWhitepagesLocationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseWhitepagesLocationInfo | Initializes a new instance of the ReverseWhitepagesLocationInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationId | Gets or sets the application ID.
Public property | BusinessChat | Gets or sets the business chat.
Public property | BusinessCity | Gets or sets the business City.
Public property | BusinessCountry | Gets or sets the business Country.
Public property | BusinessEmail | Gets or sets the business email.
Public property | BusinessFax | Gets or sets the business Fax.
Public property | BusinessMobile | Gets or sets the business mobile.
Public property | BusinessPager | Gets or sets the business pager.
Public property | BusinessPhone | Gets or sets the business phone.
Public property | BusinessPhone2 | Gets or sets the business phone2.
Public property | BusinessState | Gets or sets the business State.
Public property | BusinessStreetAddress | Gets or sets the business street address.
Public property | BusinessUrl | Gets or sets the business URL.
Public property | BusinessZip | Gets or sets the business Zip.
Public property | ExternalId | Gets or sets the external ID.
Public property | ExternalSource | Gets or sets the external source.
Public property | LocationId | Gets or sets the location ID.
Public property | Name | Gets or sets the location name.
Public property | Remarks | Gets or sets remarks.

See Also

ReverseWhitepagesLocationInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesLocationInfo Constructor

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo Constructor
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Initializes a new instance of the ReverseWhitepagesLocationInfo class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesLocationInfo()
Visual Basic
Public Sub New

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesLocationInfo Methods

[image] [image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo Methods
ReverseWhitepagesLocationInfo Class See Also Send Feedback

The ReverseWhitepagesLocationInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseWhitepagesLocationInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesLocationInfo Properties

[image] [image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo Properties
ReverseWhitepagesLocationInfo Class See Also Send Feedback

The ReverseWhitepagesLocationInfo type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationId | Gets or sets the application ID.
Public property | BusinessChat | Gets or sets the business chat.
Public property | BusinessCity | Gets or sets the business City.
Public property | BusinessCountry | Gets or sets the business Country.
Public property | BusinessEmail | Gets or sets the business email.
Public property | BusinessFax | Gets or sets the business Fax.
Public property | BusinessMobile | Gets or sets the business mobile.
Public property | BusinessPager | Gets or sets the business pager.
Public property | BusinessPhone | Gets or sets the business phone.
Public property | BusinessPhone2 | Gets or sets the business phone2.
Public property | BusinessState | Gets or sets the business State.
Public property | BusinessStreetAddress | Gets or sets the business street address.
Public property | BusinessUrl | Gets or sets the business URL.
Public property | BusinessZip | Gets or sets the business Zip.
Public property | ExternalId | Gets or sets the external ID.
Public property | ExternalSource | Gets or sets the external source.
Public property | LocationId | Gets or sets the location ID.
Public property | Name | Gets or sets the location name.
Public property | Remarks | Gets or sets remarks.

See Also

ReverseWhitepagesLocationInfo Class
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..ApplicationId Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the application ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The application ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessChat Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessChat Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business chat.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessChat { get; set; }
Visual Basic
Public Property BusinessChat As String
    Get
    Set

Field Value

The business chat.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessCity Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessCity Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCity { get; set; }
Visual Basic
Public Property BusinessCity As String
    Get
    Set

Field Value

The business City.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessCountry Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessCountry Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCountry { get; set; }
Visual Basic
Public Property BusinessCountry As String
    Get
    Set

Field Value

The business Country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessEmail Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessEmail Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business email.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessEmail { get; set; }
Visual Basic
Public Property BusinessEmail As String
    Get
    Set

Field Value

The business email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessFax Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessFax Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business Fax.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessFax { get; set; }
Visual Basic
Public Property BusinessFax As String
    Get
    Set

Field Value

The business Fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessMobile Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessMobile Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business mobile.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessMobile { get; set; }
Visual Basic
Public Property BusinessMobile As String
    Get
    Set

Field Value

The business mobile.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessPager Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessPager Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business pager.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPager { get; set; }
Visual Basic
Public Property BusinessPager As String
    Get
    Set

Field Value

The business pager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessPhone Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessPhone Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business phone.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone { get; set; }
Visual Basic
Public Property BusinessPhone As String
    Get
    Set

Field Value

The business phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessPhone2 Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessPhone2 Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business phone2.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone2 { get; set; }
Visual Basic
Public Property BusinessPhone2 As String
    Get
    Set

Field Value

The business phone2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessState Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessState Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessState { get; set; }
Visual Basic
Public Property BusinessState As String
    Get
    Set

Field Value

The business State.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessStreetAddress Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessStreetAddress Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessStreetAddress { get; set; }
Visual Basic
Public Property BusinessStreetAddress As String
    Get
    Set

Field Value

The business street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessUrl Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessUrl Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business URL.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessUrl { get; set; }
Visual Basic
Public Property BusinessUrl As String
    Get
    Set

Field Value

The business URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


BusinessZip Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..BusinessZip Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the business Zip.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessZip { get; set; }
Visual Basic
Public Property BusinessZip As String
    Get
    Set

Field Value

The business Zip.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..ExternalId Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the external ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..ExternalSource Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the external source.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..LocationId Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the location ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The location ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..Name Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets the location name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The location name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


Remarks Property

[image]

IceLib Technical Reference
ReverseWhitepagesLocationInfo..::..Remarks Property
ReverseWhitepagesLocationInfo Class See Also Send Feedback
Gets or sets remarks.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Remarks { get; set; }
Visual Basic
Public Property Remarks As String
    Get
    Set

Field Value

The remarks.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesLocationInfo Class
ReverseWhitepagesLocationInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesOrganizationInfo Class

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo Class
Members See Also Send Feedback
Holds information about an organization that is used during reverse whitepage operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ReverseWhitepagesOrganizationInfo
Visual Basic
Public Class ReverseWhitepagesOrganizationInfo

Remarks

Use this class to hold reverse whitepage information about an organization.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..ReverseWhitepagesOrganizationInfo

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesOrganizationInfo Members

[image] [image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo Members
ReverseWhitepagesOrganizationInfo Class Constructors Methods Properties See Also Send Feedback

The ReverseWhitepagesOrganizationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReverseWhitepagesOrganizationInfo | Initializes a new instance of the ReverseWhitepagesOrganizationInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationId | Gets or sets the application ID.
Public property | BusinessChat | Gets or sets the business chat (URL).
Public property | BusinessCity | Gets or sets the business City.
Public property | BusinessCountry | Gets or sets the business Country.
Public property | BusinessEmail | Gets or sets the business email.
Public property | BusinessFax | Gets or sets the business fax.
Public property | BusinessMobile | Gets or sets the business mobile.
Public property | BusinessPager | Gets or sets the business pager.
Public property | BusinessPhone | Gets or sets the business phone.
Public property | BusinessPhone2 | Gets or sets the business phone2.
Public property | BusinessState | Gets or sets the business State.
Public property | BusinessStreetAddress | Gets or sets the business street address.
Public property | BusinessUrl | Gets or sets the business URL (homepage).
Public property | BusinessZip | Gets or sets the business Zip.
Public property | ExternalId | Gets or sets external ID for this contact.
Public property | ExternalSource | Gets or sets the external source for this contact.
Public property | Name | Gets or sets the name for this organization.
Public property | OrganizationId | Gets or sets the organization ID.
Public property | OrganizationTypeId | Gets or sets the organization type ID.
Public property | Remarks | Gets or sets the remarks.

See Also

ReverseWhitepagesOrganizationInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesOrganizationInfo Constructor

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo Constructor
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Initializes a new instance of the ReverseWhitepagesOrganizationInfo class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReverseWhitepagesOrganizationInfo()
Visual Basic
Public Sub New

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


ReverseWhitepagesOrganizationInfo Methods

[image] [image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo Methods
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback

The ReverseWhitepagesOrganizationInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverseWhitepagesOrganizationInfo Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesOrganizationInfo Properties

[image] [image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo Properties
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback

The ReverseWhitepagesOrganizationInfo type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationId | Gets or sets the application ID.
Public property | BusinessChat | Gets or sets the business chat (URL).
Public property | BusinessCity | Gets or sets the business City.
Public property | BusinessCountry | Gets or sets the business Country.
Public property | BusinessEmail | Gets or sets the business email.
Public property | BusinessFax | Gets or sets the business fax.
Public property | BusinessMobile | Gets or sets the business mobile.
Public property | BusinessPager | Gets or sets the business pager.
Public property | BusinessPhone | Gets or sets the business phone.
Public property | BusinessPhone2 | Gets or sets the business phone2.
Public property | BusinessState | Gets or sets the business State.
Public property | BusinessStreetAddress | Gets or sets the business street address.
Public property | BusinessUrl | Gets or sets the business URL (homepage).
Public property | BusinessZip | Gets or sets the business Zip.
Public property | ExternalId | Gets or sets external ID for this contact.
Public property | ExternalSource | Gets or sets the external source for this contact.
Public property | Name | Gets or sets the name for this organization.
Public property | OrganizationId | Gets or sets the organization ID.
Public property | OrganizationTypeId | Gets or sets the organization type ID.
Public property | Remarks | Gets or sets the remarks.

See Also

ReverseWhitepagesOrganizationInfo Class
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..ApplicationId Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the application ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The application ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessChat Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessChat Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business chat (URL).

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessChat { get; set; }
Visual Basic
Public Property BusinessChat As String
    Get
    Set

Field Value

The business chat.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessCity Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessCity Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business City.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCity { get; set; }
Visual Basic
Public Property BusinessCity As String
    Get
    Set

Field Value

The business City.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessCountry Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessCountry Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business Country.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessCountry { get; set; }
Visual Basic
Public Property BusinessCountry As String
    Get
    Set

Field Value

The business Country.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessEmail Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessEmail Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business email.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessEmail { get; set; }
Visual Basic
Public Property BusinessEmail As String
    Get
    Set

Field Value

The business email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessFax Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessFax Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business fax.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessFax { get; set; }
Visual Basic
Public Property BusinessFax As String
    Get
    Set

Field Value

The business fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessMobile Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessMobile Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business mobile.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessMobile { get; set; }
Visual Basic
Public Property BusinessMobile As String
    Get
    Set

Field Value

The business mobile.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessPager Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessPager Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business pager.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPager { get; set; }
Visual Basic
Public Property BusinessPager As String
    Get
    Set

Field Value

The business pager.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessPhone Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessPhone Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business phone.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone { get; set; }
Visual Basic
Public Property BusinessPhone As String
    Get
    Set

Field Value

The business phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessPhone2 Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessPhone2 Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business phone2.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessPhone2 { get; set; }
Visual Basic
Public Property BusinessPhone2 As String
    Get
    Set

Field Value

The business phone2.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessState Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessState Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business State.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessState { get; set; }
Visual Basic
Public Property BusinessState As String
    Get
    Set

Field Value

The business State.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessStreetAddress Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessStreetAddress Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business street address.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessStreetAddress { get; set; }
Visual Basic
Public Property BusinessStreetAddress As String
    Get
    Set

Field Value

The business street address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessUrl Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessUrl Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business URL (homepage).

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessUrl { get; set; }
Visual Basic
Public Property BusinessUrl As String
    Get
    Set

Field Value

The business URL.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


BusinessZip Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..BusinessZip Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the business Zip.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string BusinessZip { get; set; }
Visual Basic
Public Property BusinessZip As String
    Get
    Set

Field Value

The business Zip.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


ExternalId Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..ExternalId Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets external ID for this contact.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalId { get; set; }
Visual Basic
Public Property ExternalId As String
    Get
    Set

Field Value

The external ID for this contact.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


ExternalSource Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..ExternalSource Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the external source for this contact.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ExternalSource { get; set; }
Visual Basic
Public Property ExternalSource As String
    Get
    Set

Field Value

The external source.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..Name Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the name for this organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..OrganizationId Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the organization ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The organization ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


OrganizationTypeId Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..OrganizationTypeId Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the organization type ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> OrganizationTypeId { get; set; }
Visual Basic
Public Property OrganizationTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The organization type ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


Remarks Property

[image]

IceLib Technical Reference
ReverseWhitepagesOrganizationInfo..::..Remarks Property
ReverseWhitepagesOrganizationInfo Class See Also Send Feedback
Gets or sets the remarks.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Remarks { get; set; }
Visual Basic
Public Property Remarks As String
    Get
    Set

Field Value

The remarks.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ReverseWhitepagesOrganizationInfo Class
ReverseWhitepagesOrganizationInfo Members
ININ.IceLib.Tracker Namespace


RoleType Enumeration

[image]

IceLib Technical Reference
RoleType Enumeration
See Also Send Feedback
This enum consists of a set of Tracker types that describe the various roles that an Individual can play in an interaction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RoleType
Visual Basic
Public Enumeration RoleType

Members

Member name | Value | Description
Unknown | 0 | The role of the Individual not known.
Initiator | 1 | The Individual initiated the interaction.
Respondent | 2 | The Individual responded to (e.g answered) the interaction.
Participant | 3 | The Individual was a participant in the interaction (in a conference call, for instance).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


SearchForResolutionCandidatesCompletedEventArgs Class

[image]

IceLib Technical Reference
SearchForResolutionCandidatesCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SearchForResolutionCandidatesCompleted event of a TrackerSearch.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchForResolutionCandidatesCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class SearchForResolutionCandidatesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Tracker..::..SearchForResolutionCandidatesCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchForResolutionCandidatesCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


SearchForResolutionCandidatesCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
SearchForResolutionCandidatesCompletedEventArgs Members
SearchForResolutionCandidatesCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SearchForResolutionCandidatesCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SearchForResolutionCandidatesCompletedEventArgs | Initializes a new instance of the SearchForResolutionCandidatesCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ReverseWhitepagesInfos | Gets the result rows associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SearchForResolutionCandidatesCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


SearchForResolutionCandidatesCompletedEventArgs Constructor

[image]

IceLib Technical Reference
SearchForResolutionCandidatesCompletedEventArgs Constructor
SearchForResolutionCandidatesCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the SearchForResolutionCandidatesCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchForResolutionCandidatesCompletedEventArgs(
    Collection<ReverseWhitepagesInfo> reverseWhitepagesInfos,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    reverseWhitepagesInfos As Collection(Of ReverseWhitepagesInfo), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

reverseWhitepagesInfos
Type: System.Collections.ObjectModel..::..Collection<(Of <(<' ReverseWhitepagesInfo >)>)>
The collection of reverse whitepages information.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchForResolutionCandidatesCompletedEventArgs Class
SearchForResolutionCandidatesCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


SearchForResolutionCandidatesCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
SearchForResolutionCandidatesCompletedEventArgs Methods
SearchForResolutionCandidatesCompletedEventArgs Class See Also Send Feedback

The SearchForResolutionCandidatesCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchForResolutionCandidatesCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


SearchForResolutionCandidatesCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
SearchForResolutionCandidatesCompletedEventArgs Properties
SearchForResolutionCandidatesCompletedEventArgs Class See Also Send Feedback

The SearchForResolutionCandidatesCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | ReverseWhitepagesInfos | Gets the result rows associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SearchForResolutionCandidatesCompletedEventArgs Class
ININ.IceLib.Tracker Namespace


ReverseWhitepagesInfos Property

[image]

IceLib Technical Reference
SearchForResolutionCandidatesCompletedEventArgs..::..ReverseWhitepagesInfos Property
SearchForResolutionCandidatesCompletedEventArgs Class See Also Send Feedback
Gets the result rows associated with the event.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<ReverseWhitepagesInfo> ReverseWhitepagesInfos { get; }
Visual Basic
Public ReadOnly Property ReverseWhitepagesInfos As Collection(Of ReverseWhitepagesInfo)
    Get

Field Value

The result rows.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchForResolutionCandidatesCompletedEventArgs Class
SearchForResolutionCandidatesCompletedEventArgs Members
ININ.IceLib.Tracker Namespace


SearchIndividualsFilter Class

[image]

IceLib Technical Reference
SearchIndividualsFilter Class
Members See Also Send Feedback
This class represents a filter that is used to search Individuals.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchIndividualsFilter
Visual Basic
Public Class SearchIndividualsFilter

Remarks

Use an instance of this class as an input to the TrackerSearch SearchIndividuals(SearchIndividualsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..SearchIndividualsFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


SearchIndividualsFilter Members

[image] [image]

IceLib Technical Reference
SearchIndividualsFilter Members
SearchIndividualsFilter Class Constructors Methods Properties See Also Send Feedback

The SearchIndividualsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SearchIndividualsFilter | Initializes a new instance of the SearchIndividualsFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchIndividualsFilter object into a string that is formatted properly for the SearchIndividuals method. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Active | Gets or sets the ActiveType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Address | Gets or sets the address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Admin | Gets or sets the AdminType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Department | Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUser | Gets or sets the ICUser. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualTypeId | Gets or sets the Individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the interaction address for the individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle names. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Private | Gets or sets the PrivateType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StateOrProvince | Gets or sets the state (or province). (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeName | Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeValue | Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchIndividualsFilter Class
ININ.IceLib.Tracker Namespace


SearchIndividualsFilter Constructor

[image]

IceLib Technical Reference
SearchIndividualsFilter Constructor
SearchIndividualsFilter Class See Also Send Feedback
Initializes a new instance of the SearchIndividualsFilter class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchIndividualsFilter()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


SearchIndividualsFilter Methods

[image] [image]

IceLib Technical Reference
SearchIndividualsFilter Methods
SearchIndividualsFilter Class See Also Send Feedback

The SearchIndividualsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchIndividualsFilter object into a string that is formatted properly for the SearchIndividuals method. (Overrides Object..::..ToString()()()().)

See Also

SearchIndividualsFilter Class
ININ.IceLib.Tracker Namespace


ToString Method

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..ToString Method
SearchIndividualsFilter Class See Also Send Feedback
Converts the SearchIndividualsFilter object into a string that is formatted properly for the SearchIndividuals method.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current SearchIndividualsFilter.

Remarks

Can also be useful for tracing out the search filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


SearchIndividualsFilter Properties

[image] [image]

IceLib Technical Reference
SearchIndividualsFilter Properties
SearchIndividualsFilter Class See Also Send Feedback

The SearchIndividualsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the ActiveType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Address | Gets or sets the address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Admin | Gets or sets the AdminType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Department | Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ICUser | Gets or sets the ICUser. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualTypeId | Gets or sets the Individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the interaction address for the individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle names. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Private | Gets or sets the PrivateType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StateOrProvince | Gets or sets the state (or province). (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeName | Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeValue | Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchIndividualsFilter Class
ININ.IceLib.Tracker Namespace


Active Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..Active Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the ActiveType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<ActiveType> Active { get; set; }
Visual Basic
Public Property Active As Nullable(Of ActiveType)
    Get
    Set

Field Value

The ActiveType, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


Address Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..Address Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

Field Value

The address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


Admin Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..Admin Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the AdminType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<AdminType> Admin { get; set; }
Visual Basic
Public Property Admin As Nullable(Of AdminType)
    Get
    Set

Field Value

The AdminType, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..ApplicationId Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The application ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..City Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..Country Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


Department Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..Department Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the department. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Department { get; set; }
Visual Basic
Public Property Department As String
    Get
    Set

Field Value

The department, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..FirstName Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


ICUser Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..ICUser Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the ICUser. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ICUser { get; set; }
Visual Basic
Public Property ICUser As String
    Get
    Set

Field Value

The ICUser, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


IndividualTypeId Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..IndividualTypeId Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the Individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> IndividualTypeId { get; set; }
Visual Basic
Public Property IndividualTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The Individual type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


InteractionAddress Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..InteractionAddress Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the interaction address for the individual. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddress { get; set; }
Visual Basic
Public Property InteractionAddress As String
    Get
    Set

Field Value

The individual address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..LastName Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The last name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


LocationName Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..LocationName Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationName { get; set; }
Visual Basic
Public Property LocationName As String
    Get
    Set

Field Value

The location name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


MiddleName Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..MiddleName Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the middle names. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic
Public Property MiddleName As String
    Get
    Set

Field Value

The middle name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..OrganizationName Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; set; }
Visual Basic
Public Property OrganizationName As String
    Get
    Set

Field Value

The organization, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


OwnerId Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..OwnerId Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

Field Value

The owner ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


PostalCode Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..PostalCode Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set

Field Value

The postal code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


Private Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..Private Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the PrivateType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<PrivateType> Private { get; set; }
Visual Basic
Public Property Private As Nullable(Of PrivateType)
    Get
    Set

Field Value

The PrivateType, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


SiteId Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..SiteId Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> SiteId { get; set; }
Visual Basic
Public Property SiteId As Nullable(Of Long)
    Get
    Set

Field Value

The site ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


StateOrProvince Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..StateOrProvince Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the state (or province). (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StateOrProvince { get; set; }
Visual Basic
Public Property StateOrProvince As String
    Get
    Set

Field Value

The state (or province), or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


TrackerAttributeName Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..TrackerAttributeName Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerAttributeName { get; set; }
Visual Basic
Public Property TrackerAttributeName As String
    Get
    Set

Field Value

The Tracker attribute name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


TrackerAttributeValue Property

[image]

IceLib Technical Reference
SearchIndividualsFilter..::..TrackerAttributeValue Property
SearchIndividualsFilter Class See Also Send Feedback
Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerAttributeValue { get; set; }
Visual Basic
Public Property TrackerAttributeValue As String
    Get
    Set

Field Value

The Tracker attribute value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchIndividualsFilter Class
SearchIndividualsFilter Members
ININ.IceLib.Tracker Namespace


SearchInteractionsFilter Class

[image]

IceLib Technical Reference
SearchInteractionsFilter Class
Members See Also Send Feedback
This class represents a filter that is used to search Interactions.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchInteractionsFilter
Visual Basic
Public Class SearchInteractionsFilter

Remarks

Use an instance of this class as an input to the TrackerSearch SearchInteractions(SearchInteractionsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..SearchInteractionsFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


SearchInteractionsFilter Members

[image] [image]

IceLib Technical Reference
SearchInteractionsFilter Members
SearchInteractionsFilter Class Constructors Methods Properties See Also Send Feedback

The SearchInteractionsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SearchInteractionsFilter | Initializes a new instance of the SearchInteractionsFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchInteractionsFilter object into a string that is formatted properly for the SearchInteractions method. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the account code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Address | Gets or sets the address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName | Gets or sets the display name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EndDateTime | Gets or sets the end datetime. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).) The EndDateTime must be later than the StartDateTime.
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IncidentId | Gets or sets the incident ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the Individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualTypeId | Gets or sets the individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionIdKey | Gets or sets the interaction ID key. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionType | Gets or sets the interaction type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationAddress | Gets or sets the location address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationApplicationId | Gets or sets the location application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationCity | Gets or sets the location city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationCountry | Gets or sets the location country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the Location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationInteractionAddress | Gets or sets the location interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationPostalCode | Gets or sets the location postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationStateOrProvince | Gets or sets the location state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MaximumDuration | Gets or sets the maximum duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MinimumDuration | Gets or sets the minimum duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationAddress | Gets or sets the organization address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationApplicationId | Gets or sets the organization application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationCity | Gets or sets the organization city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationCountry | Gets or sets the organization country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the Organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationInteractionAddress | Gets or sets the organization interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationPostalCode | Gets or sets the organization postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationStateOrProvince | Gets or sets the organization state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationTypeId | Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Role | Gets or sets the role. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentTypes | Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start datetime. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).) The StartDateTime must be earlier than the EndDateTime.
Public property | StateOrProvince | Gets or sets the state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName | Gets or sets the station name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeName | Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeValue | Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Workgroup | Gets or sets the workgroup. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WrapupCode | Gets or sets the wrap up code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchInteractionsFilter Class
ININ.IceLib.Tracker Namespace


SearchInteractionsFilter Constructor

[image]

IceLib Technical Reference
SearchInteractionsFilter Constructor
SearchInteractionsFilter Class See Also Send Feedback
Initializes a new instance of the SearchInteractionsFilter class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchInteractionsFilter()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


SearchInteractionsFilter Methods

[image] [image]

IceLib Technical Reference
SearchInteractionsFilter Methods
SearchInteractionsFilter Class See Also Send Feedback

The SearchInteractionsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchInteractionsFilter object into a string that is formatted properly for the SearchInteractions method. (Overrides Object..::..ToString()()()().)

See Also

SearchInteractionsFilter Class
ININ.IceLib.Tracker Namespace


ToString Method

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..ToString Method
SearchInteractionsFilter Class See Also Send Feedback
Converts the SearchInteractionsFilter object into a string that is formatted properly for the SearchInteractions method.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current SearchInteractionsFilter.

Remarks

Can also be useful for tracing out the search filter.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | is thrown if the StartDateTime is not earlier then the EndDateTime, or if MinimumDuration is greater than MaximumDuration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


SearchInteractionsFilter Properties

[image] [image]

IceLib Technical Reference
SearchInteractionsFilter Properties
SearchInteractionsFilter Class See Also Send Feedback

The SearchInteractionsFilter type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | Gets or sets the account code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Address | Gets or sets the address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | DisplayName | Gets or sets the display name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | EndDateTime | Gets or sets the end datetime. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).) The EndDateTime must be later than the StartDateTime.
Public property | FirstName | Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IncidentId | Gets or sets the incident ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualId | Gets or sets the Individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | IndividualTypeId | Gets or sets the individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionIdKey | Gets or sets the interaction ID key. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionType | Gets or sets the interaction type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LastName | Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationAddress | Gets or sets the location address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationApplicationId | Gets or sets the location application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationCity | Gets or sets the location city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationCountry | Gets or sets the location country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationId | Gets or sets the Location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationInteractionAddress | Gets or sets the location interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationName | Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationPostalCode | Gets or sets the location postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LocationStateOrProvince | Gets or sets the location state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MaximumDuration | Gets or sets the maximum duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MiddleName | Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | MinimumDuration | Gets or sets the minimum duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationAddress | Gets or sets the organization address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationApplicationId | Gets or sets the organization application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationCity | Gets or sets the organization city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationCountry | Gets or sets the organization country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationId | Gets or sets the Organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationInteractionAddress | Gets or sets the organization interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationName | Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationPostalCode | Gets or sets the organization postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationStateOrProvince | Gets or sets the organization state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationTypeId | Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Role | Gets or sets the role. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SegmentTypes | Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | SiteId | Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StartDateTime | Gets or sets the start datetime. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).) The StartDateTime must be earlier than the EndDateTime.
Public property | StateOrProvince | Gets or sets the state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StationName | Gets or sets the station name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeName | Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeValue | Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Workgroup | Gets or sets the workgroup. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | WrapupCode | Gets or sets the wrap up code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchInteractionsFilter Class
ININ.IceLib.Tracker Namespace


AccountCode Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..AccountCode Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the account code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCode { get; set; }
Visual Basic
Public Property AccountCode As String
    Get
    Set

Field Value

The account code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


Address Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..Address Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

Field Value

The address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..ApplicationId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The application ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..City Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..Country Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


DisplayName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..DisplayName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the display name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The display name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


EndDateTime Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..EndDateTime Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the end datetime. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).) The EndDateTime must be later than the StartDateTime.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> EndDateTime { get; set; }
Visual Basic
Public Property EndDateTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The end datetime, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


FirstName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..FirstName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the first name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set

Field Value

The first name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


IncidentId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..IncidentId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the incident ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IncidentId { get; set; }
Visual Basic
Public Property IncidentId As String
    Get
    Set

Field Value

The incident ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..IndividualId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the Individual ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; set; }
Visual Basic
Public Property IndividualId As String
    Get
    Set

Field Value

The Individual ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


IndividualTypeId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..IndividualTypeId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the individual type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> IndividualTypeId { get; set; }
Visual Basic
Public Property IndividualTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The individual type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


InteractionAddress Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..InteractionAddress Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddress { get; set; }
Visual Basic
Public Property InteractionAddress As String
    Get
    Set

Field Value

The InteractionAddress, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


InteractionIdKey Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..InteractionIdKey Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the interaction ID key. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionIdKey { get; set; }
Visual Basic
Public Property InteractionIdKey As String
    Get
    Set

Field Value

The interaction ID key, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


InteractionType Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..InteractionType Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the interaction type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<InteractionType> InteractionType { get; set; }
Visual Basic
Public Property InteractionType As Nullable(Of InteractionType)
    Get
    Set

Field Value

The interaction type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LastName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LastName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the last name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set

Field Value

The last name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationAddress Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationAddress Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationAddress { get; set; }
Visual Basic
Public Property LocationAddress As String
    Get
    Set

Field Value

The location address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationApplicationId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationApplicationId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationApplicationId { get; set; }
Visual Basic
Public Property LocationApplicationId As String
    Get
    Set

Field Value

The location application ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationCity Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationCity Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationCity { get; set; }
Visual Basic
Public Property LocationCity As String
    Get
    Set

Field Value

The location city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationCountry Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationCountry Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationCountry { get; set; }
Visual Basic
Public Property LocationCountry As String
    Get
    Set

Field Value

The location country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the Location ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationId { get; set; }
Visual Basic
Public Property LocationId As String
    Get
    Set

Field Value

The Location ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationInteractionAddress Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationInteractionAddress Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationInteractionAddress { get; set; }
Visual Basic
Public Property LocationInteractionAddress As String
    Get
    Set

Field Value

The location interaction address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationName { get; set; }
Visual Basic
Public Property LocationName As String
    Get
    Set

Field Value

The location name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationPostalCode Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationPostalCode Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationPostalCode { get; set; }
Visual Basic
Public Property LocationPostalCode As String
    Get
    Set

Field Value

The location postal code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


LocationStateOrProvince Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..LocationStateOrProvince Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the location state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocationStateOrProvince { get; set; }
Visual Basic
Public Property LocationStateOrProvince As String
    Get
    Set

Field Value

The location state or province, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


MaximumDuration Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..MaximumDuration Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the maximum duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> MaximumDuration { get; set; }
Visual Basic
Public Property MaximumDuration As Nullable(Of Long)
    Get
    Set

Field Value

The maximum duration, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


MiddleName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..MiddleName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the middle name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic
Public Property MiddleName As String
    Get
    Set

Field Value

The middle name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


MinimumDuration Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..MinimumDuration Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the minimum duration. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> MinimumDuration { get; set; }
Visual Basic
Public Property MinimumDuration As Nullable(Of Long)
    Get
    Set

Field Value

The minimum duration, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationAddress Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationAddress Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationAddress { get; set; }
Visual Basic
Public Property OrganizationAddress As String
    Get
    Set

Field Value

The organization address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationApplicationId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationApplicationId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationApplicationId { get; set; }
Visual Basic
Public Property OrganizationApplicationId As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationCity Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationCity Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationCity { get; set; }
Visual Basic
Public Property OrganizationCity As String
    Get
    Set

Field Value

The organization city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationCountry Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationCountry Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationCountry { get; set; }
Visual Basic
Public Property OrganizationCountry As String
    Get
    Set

Field Value

The organization country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the Organization ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; set; }
Visual Basic
Public Property OrganizationId As String
    Get
    Set

Field Value

The Organization ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationInteractionAddress Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationInteractionAddress Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationInteractionAddress { get; set; }
Visual Basic
Public Property OrganizationInteractionAddress As String
    Get
    Set

Field Value

The organization interaction address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationName { get; set; }
Visual Basic
Public Property OrganizationName As String
    Get
    Set

Field Value

The organization name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationPostalCode Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationPostalCode Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationPostalCode { get; set; }
Visual Basic
Public Property OrganizationPostalCode As String
    Get
    Set

Field Value

The organization postal code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationStateOrProvince Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationStateOrProvince Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationStateOrProvince { get; set; }
Visual Basic
Public Property OrganizationStateOrProvince As String
    Get
    Set

Field Value

The organization state or province, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationTypeId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..OrganizationTypeId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> OrganizationTypeId { get; set; }
Visual Basic
Public Property OrganizationTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The organization type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


PostalCode Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..PostalCode Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set

Field Value

The postal code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


Role Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..Role Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the role. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<RoleType> Role { get; set; }
Visual Basic
Public Property Role As Nullable(Of RoleType)
    Get
    Set

Field Value

The role, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


SegmentTypes Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..SegmentTypes Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the segment type. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<SegmentTypes> SegmentTypes { get; set; }
Visual Basic
Public Property SegmentTypes As Nullable(Of SegmentTypes)
    Get
    Set

Field Value

The segment type, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


SiteId Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..SiteId Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the site ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> SiteId { get; set; }
Visual Basic
Public Property SiteId As Nullable(Of Long)
    Get
    Set

Field Value

The site ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


StartDateTime Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..StartDateTime Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the start datetime. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).) The StartDateTime must be earlier than the EndDateTime.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<DateTime> StartDateTime { get; set; }
Visual Basic
Public Property StartDateTime As Nullable(Of DateTime)
    Get
    Set

Field Value

The start datetime, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


StateOrProvince Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..StateOrProvince Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StateOrProvince { get; set; }
Visual Basic
Public Property StateOrProvince As String
    Get
    Set

Field Value

The state or province, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


StationName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..StationName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the station name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationName { get; set; }
Visual Basic
Public Property StationName As String
    Get
    Set

Field Value

The station name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


TrackerAttributeName Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..TrackerAttributeName Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerAttributeName { get; set; }
Visual Basic
Public Property TrackerAttributeName As String
    Get
    Set

Field Value

The Tracker attribute name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


TrackerAttributeValue Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..TrackerAttributeValue Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerAttributeValue { get; set; }
Visual Basic
Public Property TrackerAttributeValue As String
    Get
    Set

Field Value

The Tracker attribute value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


Workgroup Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..Workgroup Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the workgroup. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Workgroup { get; set; }
Visual Basic
Public Property Workgroup As String
    Get
    Set

Field Value

The workgroup, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


WrapupCode Property

[image]

IceLib Technical Reference
SearchInteractionsFilter..::..WrapupCode Property
SearchInteractionsFilter Class See Also Send Feedback
Gets or sets the wrap up code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WrapupCode { get; set; }
Visual Basic
Public Property WrapupCode As String
    Get
    Set

Field Value

The wrap up code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchInteractionsFilter Class
SearchInteractionsFilter Members
ININ.IceLib.Tracker Namespace


SearchLocationsFilter Class

[image]

IceLib Technical Reference
SearchLocationsFilter Class
Members See Also Send Feedback
This class represents a filter that is used to search Locations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchLocationsFilter
Visual Basic
Public Class SearchLocationsFilter

Remarks

Use an instance of this class as an input to the TrackerSearch SearchLocations(SearchLocationsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..SearchLocationsFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


SearchLocationsFilter Members

[image] [image]

IceLib Technical Reference
SearchLocationsFilter Members
SearchLocationsFilter Class Constructors Methods Properties See Also Send Feedback

The SearchLocationsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SearchLocationsFilter | Initializes a new instance of the SearchOrganizationsFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchLocationsFilter object into a string that is formatted properly for the SearchLocations method. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Address | Gets or sets the location address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the location application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the location city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the location country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the location interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the location postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StateOrProvince | Gets or sets the location state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchLocationsFilter Class
ININ.IceLib.Tracker Namespace


SearchLocationsFilter Constructor

[image]

IceLib Technical Reference
SearchLocationsFilter Constructor
SearchLocationsFilter Class See Also Send Feedback
Initializes a new instance of the SearchOrganizationsFilter class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchLocationsFilter()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


SearchLocationsFilter Methods

[image] [image]

IceLib Technical Reference
SearchLocationsFilter Methods
SearchLocationsFilter Class See Also Send Feedback

The SearchLocationsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchLocationsFilter object into a string that is formatted properly for the SearchLocations method. (Overrides Object..::..ToString()()()().)

See Also

SearchLocationsFilter Class
ININ.IceLib.Tracker Namespace


ToString Method

[image]

IceLib Technical Reference
SearchLocationsFilter..::..ToString Method
SearchLocationsFilter Class See Also Send Feedback
Converts the SearchLocationsFilter object into a string that is formatted properly for the SearchLocations method.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current SearchLocationsFilter.

Remarks

Can also be useful for tracing out the search filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


SearchLocationsFilter Properties

[image] [image]

IceLib Technical Reference
SearchLocationsFilter Properties
SearchLocationsFilter Class See Also Send Feedback

The SearchLocationsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets or sets the location address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the location application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the location city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the location country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the location interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the location postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StateOrProvince | Gets or sets the location state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchLocationsFilter Class
ININ.IceLib.Tracker Namespace


Address Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..Address Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

Field Value

The location address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..ApplicationId Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..City Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The location city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..Country Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The location country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


InteractionAddress Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..InteractionAddress Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddress { get; set; }
Visual Basic
Public Property InteractionAddress As String
    Get
    Set

Field Value

The location interaction address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..Name Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The location name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


PostalCode Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..PostalCode Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set

Field Value

The location postal code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


StateOrProvince Property

[image]

IceLib Technical Reference
SearchLocationsFilter..::..StateOrProvince Property
SearchLocationsFilter Class See Also Send Feedback
Gets or sets the location state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StateOrProvince { get; set; }
Visual Basic
Public Property StateOrProvince As String
    Get
    Set

Field Value

The location state or province, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchLocationsFilter Class
SearchLocationsFilter Members
ININ.IceLib.Tracker Namespace


SearchOrganizationsFilter Class

[image]

IceLib Technical Reference
SearchOrganizationsFilter Class
Members See Also Send Feedback
This class represents a filter that is used to search Organizations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SearchOrganizationsFilter
Visual Basic
Public Class SearchOrganizationsFilter

Remarks

Use an instance of this class as an input to the TrackerSearch SearchOrganizations(SearchOrganizationsFilter) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..SearchOrganizationsFilter

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


SearchOrganizationsFilter Members

[image] [image]

IceLib Technical Reference
SearchOrganizationsFilter Members
SearchOrganizationsFilter Class Constructors Methods Properties See Also Send Feedback

The SearchOrganizationsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SearchOrganizationsFilter | Initializes a new instance of the SearchOrganizationsFilter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchOrganizationsFilter object into a string that is formatted properly for the SearchOrganizations method. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Active | Gets or sets the ActiveType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Address | Gets or sets the organization address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the organization application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the organization city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the organization country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the organization interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationTypeId | Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the organization postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StateOrProvince | Gets or sets the organization state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeName | Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeValue | Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchOrganizationsFilter Class
ININ.IceLib.Tracker Namespace


SearchOrganizationsFilter Constructor

[image]

IceLib Technical Reference
SearchOrganizationsFilter Constructor
SearchOrganizationsFilter Class See Also Send Feedback
Initializes a new instance of the SearchOrganizationsFilter class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SearchOrganizationsFilter()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


SearchOrganizationsFilter Methods

[image] [image]

IceLib Technical Reference
SearchOrganizationsFilter Methods
SearchOrganizationsFilter Class See Also Send Feedback

The SearchOrganizationsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the SearchOrganizationsFilter object into a string that is formatted properly for the SearchOrganizations method. (Overrides Object..::..ToString()()()().)

See Also

SearchOrganizationsFilter Class
ININ.IceLib.Tracker Namespace


ToString Method

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..ToString Method
SearchOrganizationsFilter Class See Also Send Feedback
Converts the SearchOrganizationsFilter object into a string that is formatted properly for the SearchOrganizations method.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current SearchOrganizationsFilter.

Remarks

Can also be useful for tracing out the search filter.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


SearchOrganizationsFilter Properties

[image] [image]

IceLib Technical Reference
SearchOrganizationsFilter Properties
SearchOrganizationsFilter Class See Also Send Feedback

The SearchOrganizationsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the ActiveType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Address | Gets or sets the organization address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ApplicationId | Gets or sets the organization application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | City | Gets or sets the organization city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Country | Gets or sets the organization country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | InteractionAddress | Gets or sets the organization interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OrganizationTypeId | Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | OwnerId | Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | PostalCode | Gets or sets the organization postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | StateOrProvince | Gets or sets the organization state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeName | Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeValue | Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

SearchOrganizationsFilter Class
ININ.IceLib.Tracker Namespace


Active Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..Active Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the ActiveType. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<ActiveType> Active { get; set; }
Visual Basic
Public Property Active As Nullable(Of ActiveType)
    Get
    Set

Field Value

The ActiveType, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


Address Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..Address Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

Field Value

The organization address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


ApplicationId Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..ApplicationId Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization application ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ApplicationId { get; set; }
Visual Basic
Public Property ApplicationId As String
    Get
    Set

Field Value

The city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


City Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..City Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization city. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set

Field Value

The organization city, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


Country Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..Country Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization country. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set

Field Value

The organization country, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


InteractionAddress Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..InteractionAddress Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization interaction address. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string InteractionAddress { get; set; }
Visual Basic
Public Property InteractionAddress As String
    Get
    Set

Field Value

The organization interaction address, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..Name Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The organization name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


OrganizationTypeId Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..OrganizationTypeId Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> OrganizationTypeId { get; set; }
Visual Basic
Public Property OrganizationTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The organization type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


OwnerId Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..OwnerId Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the owner ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

Field Value

The owner ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


PostalCode Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..PostalCode Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization postal code. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set

Field Value

The organization postal code, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


StateOrProvince Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..StateOrProvince Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the organization state or province. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StateOrProvince { get; set; }
Visual Basic
Public Property StateOrProvince As String
    Get
    Set

Field Value

The organization state or province, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


TrackerAttributeName Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..TrackerAttributeName Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the Tracker attribute name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerAttributeName { get; set; }
Visual Basic
Public Property TrackerAttributeName As String
    Get
    Set

Field Value

The Tracker attribute name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


TrackerAttributeValue Property

[image]

IceLib Technical Reference
SearchOrganizationsFilter..::..TrackerAttributeValue Property
SearchOrganizationsFilter Class See Also Send Feedback
Gets or sets the Tracker attribute value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerAttributeValue { get; set; }
Visual Basic
Public Property TrackerAttributeValue As String
    Get
    Set

Field Value

The Tracker attribute value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SearchOrganizationsFilter Class
SearchOrganizationsFilter Members
ININ.IceLib.Tracker Namespace


SegmentOrganizationIndividualDetails Class

[image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails Class
Members See Also Send Feedback
Helper class to contain the return values for the GetCurrentSegmentOrganizationIndividual(String, String) methods.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class SegmentOrganizationIndividualDetails
Visual Basic
Public Class SegmentOrganizationIndividualDetails

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..SegmentOrganizationIndividualDetails

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SegmentOrganizationIndividualDetails Members
ININ.IceLib.Tracker Namespace


SegmentOrganizationIndividualDetails Members

[image] [image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails Members
SegmentOrganizationIndividualDetails Class Methods Properties See Also Send Feedback

The SegmentOrganizationIndividualDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IndividualId | Gets the individual ID.
Public property | OrganizationId | Gets the organization ID.
Public property | SegmentId | Gets the segment ID.

See Also

SegmentOrganizationIndividualDetails Class
ININ.IceLib.Tracker Namespace


SegmentOrganizationIndividualDetails Methods

[image] [image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails Methods
SegmentOrganizationIndividualDetails Class See Also Send Feedback

The SegmentOrganizationIndividualDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SegmentOrganizationIndividualDetails Class
ININ.IceLib.Tracker Namespace


SegmentOrganizationIndividualDetails Properties

[image] [image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails Properties
SegmentOrganizationIndividualDetails Class See Also Send Feedback

The SegmentOrganizationIndividualDetails type exposes the following members.

Properties

 | Name | Description
Public property | IndividualId | Gets the individual ID.
Public property | OrganizationId | Gets the organization ID.
Public property | SegmentId | Gets the segment ID.

See Also

SegmentOrganizationIndividualDetails Class
ININ.IceLib.Tracker Namespace


IndividualId Property

[image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails..::..IndividualId Property
SegmentOrganizationIndividualDetails Class See Also Send Feedback
Gets the individual ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string IndividualId { get; }
Visual Basic
Public ReadOnly Property IndividualId As String
    Get

Field Value

The individual ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SegmentOrganizationIndividualDetails Class
SegmentOrganizationIndividualDetails Members
ININ.IceLib.Tracker Namespace


OrganizationId Property

[image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails..::..OrganizationId Property
SegmentOrganizationIndividualDetails Class See Also Send Feedback
Gets the organization ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string OrganizationId { get; }
Visual Basic
Public ReadOnly Property OrganizationId As String
    Get

Field Value

The organization ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SegmentOrganizationIndividualDetails Class
SegmentOrganizationIndividualDetails Members
ININ.IceLib.Tracker Namespace


SegmentId Property

[image]

IceLib Technical Reference
SegmentOrganizationIndividualDetails..::..SegmentId Property
SegmentOrganizationIndividualDetails Class See Also Send Feedback
Gets the segment ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SegmentId { get; }
Visual Basic
Public ReadOnly Property SegmentId As String
    Get

Field Value

The segment ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

SegmentOrganizationIndividualDetails Class
SegmentOrganizationIndividualDetails Members
ININ.IceLib.Tracker Namespace


SegmentTypes Enumeration

[image]

IceLib Technical Reference
SegmentTypes Enumeration
See Also Send Feedback
This enum consists of a set of Tracker types that describe a given Segment.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum SegmentTypes
Visual Basic
<FlagsAttribute> _
Public Enumeration SegmentTypes

Members

Member name | Value | Description
Alert | 1 | The segment included an alert.
System | 2 | The segment included a system operation.
WorkgroupQueue | 4 | The segment included a workgroup queue.
Hold | 8 | The segment was held.
Messaging | 16 | The segment included a messaging operation.
Interaction | 32 | The segment included an interaction.
Conference | 64 | The segment included a conference.
ConsultCall | 128 | The segment included a consult call.
NotAnswered | 256 | The segment was not answered.
SecurityChange | 512 | The segment included a security change.
All | 1023 | All known segment types.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.Tracker Namespace


Title Class

[image]

IceLib Technical Reference
Title Class
Members See Also Send Feedback
Represents a title within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class Title
Visual Basic
Public Class Title

Remarks

Titles can be associated with Individuals. Some examples of titles are Dr., Mr., Mrs.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..Title

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Title Members
ININ.IceLib.Tracker Namespace


Title Members

[image] [image]

IceLib Technical Reference
Title Members
Title Class Constructors Methods Properties See Also Send Feedback

The Title type exposes the following members.

Constructors

 | Name | Description
Public method | Title | Initializes a new instance of the Title class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Title Class
ININ.IceLib.Tracker Namespace


Title Constructor

[image]

IceLib Technical Reference
Title Constructor
Title Class See Also Send Feedback
Initializes a new instance of the Title class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Title()
Visual Basic
Public Sub New

See Also

Title Class
Title Members
ININ.IceLib.Tracker Namespace


Title Methods

[image] [image]

IceLib Technical Reference
Title Methods
Title Class See Also Send Feedback

The Title type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Title Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
Title..::..Reset Method
Title Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Title Class
Title Members
ININ.IceLib.Tracker Namespace


Title Properties

[image] [image]

IceLib Technical Reference
Title Properties
Title Class See Also Send Feedback

The Title type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

Title Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
Title..::..AdminEditable Property
Title Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Title Class
Title Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
Title..::..Id Property
Title Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Title Class
Title Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
Title..::..Name Property
Title Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Title Class
Title Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
Title..::..Version Property
Title Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

Title Class
Title Members
ININ.IceLib.Tracker Namespace


TrackerAdmin Class

[image]

IceLib Technical Reference
TrackerAdmin Class
Members See Also Send Feedback
Contains methods necessary to perform typical Tracker admin related operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerAdmin
Visual Basic
Public Class TrackerAdmin

Remarks

The TrackerAdmin type is instantiated like the two other main Tracker types (TrackerUser and TrackerSearch), by passing in a valid Session object. Use the TrackerAdmin type when you want to perform Tracker administrative tasks such as adding a new Organization type, deleting an address type, adding a new title, updating an attribute type, etc.

The current user must have a valid Tracker Access license or an IceLibLicenseException will be thrown when any methods of this class are called.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..TrackerAdmin

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Members
ININ.IceLib.Tracker Namespace


TrackerAdmin Members

[image] [image]

IceLib Technical Reference
TrackerAdmin Members
TrackerAdmin Class Constructors Methods Properties See Also Send Feedback

The TrackerAdmin type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerAdmin | Initializes a new instance of the TrackerAdmin class.

Methods

 | Name | Description
Public method | AddAddressType | Adds an AddressType to the Tracker database.
Public method | AddAddressTypeAsync | Asynchronously adds an AddressType to the Tracker database.
Public method | AddIndividualType | Adds an IndividualType to the Tracker database.
Public method | AddIndividualTypeAsync | Asynchronously adds an IndividualType to the Tracker database.
Public method | AddInteractionAddressSubtype | Adds an InteractionAddressSubtype to the Tracker database.
Public method | AddInteractionAddressSubtypeAsync | Asynchronously adds an InteractionAddressSubtype to the Tracker database.
Public method | AddInteractionAddressType | Adds an InteractionAddressType to the Tracker database.
Public method | AddInteractionAddressTypeAsync | Asynchronously adds an InteractionAddressType to the Tracker database.
Public method | AddOrganizationType | Adds an OrganizationType to the Tracker database.
Public method | AddOrganizationTypeAsync | Asynchronously adds an OrganizationType to the Tracker database.
Public method | AddTitle | Adds a Title to the Tracker database.
Public method | AddTitleAsync | Asynchronously adds a Title to the Tracker database.
Public method | AddTrackerAttributeType | Adds a TrackerAttributeType to the Tracker database.
Public method | AddTrackerAttributeTypeAsync | Asynchronously adds a TrackerAttributeType to the Tracker database.
Public method | DeleteAddressType | Deletes an AddressType from the Tracker database.
Public method | DeleteAddressTypeAsync | Asynchronously deletes an AddressType from the Tracker database.
Public method | DeleteIndividualType | Deletes an IndividualType from the Tracker database.
Public method | DeleteIndividualTypeAsync | Asynchronously deletes an IndividualType from the Tracker database.
Public method | DeleteInteractionAddressSubtype | Deletes an InteractionAddressSubtype from the Tracker database.
Public method | DeleteInteractionAddressSubtypeAsync | Asynchronously deletes an InteractionAddressSubtype from the Tracker database.
Public method | DeleteInteractionAddressType | Deletes an InteractionAddressType from the Tracker database.
Public method | DeleteInteractionAddressTypeAsync | Asynchronously deletes an InteractionAddressType from the Tracker database.
Public method | DeleteOrganizationType | Deletes an OrganizationType from the Tracker database.
Public method | DeleteOrganizationTypeAsync | Asynchronously deletes an OrganizationType from the Tracker database.
Public method | DeleteTitle | Deletes a Title from the Tracker database.
Public method | DeleteTitleAsync | Asynchronously deletes a Title from the Tracker database.
Public method | DeleteTrackerAttributeType | Deletes a TrackerAttributeType from the Tracker database.
Public method | DeleteTrackerAttributeTypeAsync | Asynchronously deletes a TrackerAttributeType from the Tracker database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressTypeById | Gets an AddressType by ID.
Public method | GetAddressTypeByIdAsync | Asynchronously gets an AddressType by ID.
Public method | GetAddressTypes | Gets all AddressTypes.
Public method | GetAddressTypesAsync | Asynchronously gets all AddressTypes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndividualTypeById | Gets an IndividualType by ID.
Public method | GetIndividualTypeByIdAsync | Asynchronously gets an IndividualType by ID.
Public method | GetIndividualTypes | Gets all IndividualTypes.
Public method | GetIndividualTypesAsync | Asynchronously gets all IndividualTypes.
Public method | GetInteractionAddressSubtypeById | Gets an InteractionAddressSubtype by ID.
Public method | GetInteractionAddressSubtypeByIdAsync | Asynchronously gets an InteractionAddressSubtype by ID.
Public method | GetInteractionAddressSubtypes | Gets all InteractionAddressSubtypes.
Public method | GetInteractionAddressSubtypesAsync | Asynchronously gets all InteractionAddressSubtypes.
Public method | GetInteractionAddressTypeById | Gets an InteractionAddressType by ID.
Public method | GetInteractionAddressTypeByIdAsync | Asynchronously gets an InteractionAddressType by ID.
Public method | GetInteractionAddressTypes | Gets all InteractionAddressTypes.
Public method | GetInteractionAddressTypesAsync | Asynchronously gets all InteractionAddressTypes.
Public method | GetOrganizationTypeById | Gets an OrganizationType by ID.
Public method | GetOrganizationTypeByIdAsync | Asynchronously gets an OrganizationType by ID.
Public method | GetOrganizationTypes | Gets all OrganizationTypes.
Public method | GetOrganizationTypesAsync | Asynchronously gets all OrganizationTypes.
Public method | GetTitleById | Gets a Title by ID.
Public method | GetTitleByIdAsync | Asynchronously gets a Title by ID.
Public method | GetTitles | Gets all Titles.
Public method | GetTitlesAsync | Asynchronously gets all Title.
Public method | GetTrackerAttributeTypeById | Gets a TrackerAttributeType by ID.
Public method | GetTrackerAttributeTypeByIdAsync | Asynchronously gets a TrackerAttributeType by ID.
Public method | GetTrackerAttributeTypes | Gets all TrackerAttributeTypes.
Public method | GetTrackerAttributeTypesAsync | Asynchronously gets all TrackerAttributeTypes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ICUserModified | Marks an IC user as modified.
Public method | ICUserModifiedAsync | Asynchronously marks an IC user as modified.
Public method | ImportICUsers | Imports the IC users.
Public method | ImportICUsersAsync | Asynchronously imports the IC users.
Public method | IsUnknownOrSystemIndividual | Determines whether the specific Individual is unknown or a system Individual.
Public method | IsUnknownOrSystemIndividualAsync | Asynchronously determines whether the specific Individual is unknown or a system Individual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAddressType | Updates an AddressType.
Public method | UpdateAddressTypeAsync | Asynchronously updates an AddressType.
Public method | UpdateIndividualType | Updates an IndividualType.
Public method | UpdateIndividualTypeAsync | Asynchronously updates an IndividualType.
Public method | UpdateInteractionAddressSubtype | Updates an InteractionAddressSubtype.
Public method | UpdateInteractionAddressSubtypeAsync | Asynchronously updates an InteractionAddressSubtype.
Public method | UpdateInteractionAddressType | Updates an InteractionAddressType.
Public method | UpdateInteractionAddressTypeAsync | Asynchronously updates an InteractionAddressType.
Public method | UpdateOrganizationType | Updates an OrganizationType.
Public method | UpdateOrganizationTypeAsync | Asynchronously updates an OrganizationType.
Public method | UpdateTitle | Updates a Title.
Public method | UpdateTitleAsync | Asynchronously updates a Title.
Public method | UpdateTrackerAttributeType | Updates a TrackerAttributeType.
Public method | UpdateTrackerAttributeTypeAsync | Asynchronously updates a TrackerAttributeType.
Public method | UpdateUserSecurity | Updates the security for an IC user.
Public method | UpdateUserSecurityAsync | Asynchronously updates the security for an IC user.

Properties

 | Name | Description
Public property | TransactionClient | Gets the TransactionClient.

See Also

TrackerAdmin Class
ININ.IceLib.Tracker Namespace


TrackerAdmin Constructor

[image]

IceLib Technical Reference
TrackerAdmin Constructor
TrackerAdmin Class See Also Send Feedback
Initializes a new instance of the TrackerAdmin class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerAdmin(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


TrackerAdmin Methods

[image] [image]

IceLib Technical Reference
TrackerAdmin Methods
TrackerAdmin Class See Also Send Feedback

The TrackerAdmin type exposes the following members.

Methods

 | Name | Description
Public method | AddAddressType | Adds an AddressType to the Tracker database.
Public method | AddAddressTypeAsync | Asynchronously adds an AddressType to the Tracker database.
Public method | AddIndividualType | Adds an IndividualType to the Tracker database.
Public method | AddIndividualTypeAsync | Asynchronously adds an IndividualType to the Tracker database.
Public method | AddInteractionAddressSubtype | Adds an InteractionAddressSubtype to the Tracker database.
Public method | AddInteractionAddressSubtypeAsync | Asynchronously adds an InteractionAddressSubtype to the Tracker database.
Public method | AddInteractionAddressType | Adds an InteractionAddressType to the Tracker database.
Public method | AddInteractionAddressTypeAsync | Asynchronously adds an InteractionAddressType to the Tracker database.
Public method | AddOrganizationType | Adds an OrganizationType to the Tracker database.
Public method | AddOrganizationTypeAsync | Asynchronously adds an OrganizationType to the Tracker database.
Public method | AddTitle | Adds a Title to the Tracker database.
Public method | AddTitleAsync | Asynchronously adds a Title to the Tracker database.
Public method | AddTrackerAttributeType | Adds a TrackerAttributeType to the Tracker database.
Public method | AddTrackerAttributeTypeAsync | Asynchronously adds a TrackerAttributeType to the Tracker database.
Public method | DeleteAddressType | Deletes an AddressType from the Tracker database.
Public method | DeleteAddressTypeAsync | Asynchronously deletes an AddressType from the Tracker database.
Public method | DeleteIndividualType | Deletes an IndividualType from the Tracker database.
Public method | DeleteIndividualTypeAsync | Asynchronously deletes an IndividualType from the Tracker database.
Public method | DeleteInteractionAddressSubtype | Deletes an InteractionAddressSubtype from the Tracker database.
Public method | DeleteInteractionAddressSubtypeAsync | Asynchronously deletes an InteractionAddressSubtype from the Tracker database.
Public method | DeleteInteractionAddressType | Deletes an InteractionAddressType from the Tracker database.
Public method | DeleteInteractionAddressTypeAsync | Asynchronously deletes an InteractionAddressType from the Tracker database.
Public method | DeleteOrganizationType | Deletes an OrganizationType from the Tracker database.
Public method | DeleteOrganizationTypeAsync | Asynchronously deletes an OrganizationType from the Tracker database.
Public method | DeleteTitle | Deletes a Title from the Tracker database.
Public method | DeleteTitleAsync | Asynchronously deletes a Title from the Tracker database.
Public method | DeleteTrackerAttributeType | Deletes a TrackerAttributeType from the Tracker database.
Public method | DeleteTrackerAttributeTypeAsync | Asynchronously deletes a TrackerAttributeType from the Tracker database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressTypeById | Gets an AddressType by ID.
Public method | GetAddressTypeByIdAsync | Asynchronously gets an AddressType by ID.
Public method | GetAddressTypes | Gets all AddressTypes.
Public method | GetAddressTypesAsync | Asynchronously gets all AddressTypes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndividualTypeById | Gets an IndividualType by ID.
Public method | GetIndividualTypeByIdAsync | Asynchronously gets an IndividualType by ID.
Public method | GetIndividualTypes | Gets all IndividualTypes.
Public method | GetIndividualTypesAsync | Asynchronously gets all IndividualTypes.
Public method | GetInteractionAddressSubtypeById | Gets an InteractionAddressSubtype by ID.
Public method | GetInteractionAddressSubtypeByIdAsync | Asynchronously gets an InteractionAddressSubtype by ID.
Public method | GetInteractionAddressSubtypes | Gets all InteractionAddressSubtypes.
Public method | GetInteractionAddressSubtypesAsync | Asynchronously gets all InteractionAddressSubtypes.
Public method | GetInteractionAddressTypeById | Gets an InteractionAddressType by ID.
Public method | GetInteractionAddressTypeByIdAsync | Asynchronously gets an InteractionAddressType by ID.
Public method | GetInteractionAddressTypes | Gets all InteractionAddressTypes.
Public method | GetInteractionAddressTypesAsync | Asynchronously gets all InteractionAddressTypes.
Public method | GetOrganizationTypeById | Gets an OrganizationType by ID.
Public method | GetOrganizationTypeByIdAsync | Asynchronously gets an OrganizationType by ID.
Public method | GetOrganizationTypes | Gets all OrganizationTypes.
Public method | GetOrganizationTypesAsync | Asynchronously gets all OrganizationTypes.
Public method | GetTitleById | Gets a Title by ID.
Public method | GetTitleByIdAsync | Asynchronously gets a Title by ID.
Public method | GetTitles | Gets all Titles.
Public method | GetTitlesAsync | Asynchronously gets all Title.
Public method | GetTrackerAttributeTypeById | Gets a TrackerAttributeType by ID.
Public method | GetTrackerAttributeTypeByIdAsync | Asynchronously gets a TrackerAttributeType by ID.
Public method | GetTrackerAttributeTypes | Gets all TrackerAttributeTypes.
Public method | GetTrackerAttributeTypesAsync | Asynchronously gets all TrackerAttributeTypes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ICUserModified | Marks an IC user as modified.
Public method | ICUserModifiedAsync | Asynchronously marks an IC user as modified.
Public method | ImportICUsers | Imports the IC users.
Public method | ImportICUsersAsync | Asynchronously imports the IC users.
Public method | IsUnknownOrSystemIndividual | Determines whether the specific Individual is unknown or a system Individual.
Public method | IsUnknownOrSystemIndividualAsync | Asynchronously determines whether the specific Individual is unknown or a system Individual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAddressType | Updates an AddressType.
Public method | UpdateAddressTypeAsync | Asynchronously updates an AddressType.
Public method | UpdateIndividualType | Updates an IndividualType.
Public method | UpdateIndividualTypeAsync | Asynchronously updates an IndividualType.
Public method | UpdateInteractionAddressSubtype | Updates an InteractionAddressSubtype.
Public method | UpdateInteractionAddressSubtypeAsync | Asynchronously updates an InteractionAddressSubtype.
Public method | UpdateInteractionAddressType | Updates an InteractionAddressType.
Public method | UpdateInteractionAddressTypeAsync | Asynchronously updates an InteractionAddressType.
Public method | UpdateOrganizationType | Updates an OrganizationType.
Public method | UpdateOrganizationTypeAsync | Asynchronously updates an OrganizationType.
Public method | UpdateTitle | Updates a Title.
Public method | UpdateTitleAsync | Asynchronously updates a Title.
Public method | UpdateTrackerAttributeType | Updates a TrackerAttributeType.
Public method | UpdateTrackerAttributeTypeAsync | Asynchronously updates a TrackerAttributeType.
Public method | UpdateUserSecurity | Updates the security for an IC user.
Public method | UpdateUserSecurityAsync | Asynchronously updates the security for an IC user.

See Also

TrackerAdmin Class
ININ.IceLib.Tracker Namespace


AddAddressType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddAddressType Method
TrackerAdmin Class See Also Send Feedback
Adds an AddressType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddAddressType(
    AddressType addressType
)
Visual Basic
Public Function AddAddressType ( _
    addressType As AddressType _
) As Long

Parameters

addressType
Type: ININ.IceLib.Tracker..::..AddressType
The AddressType to add.

Return Value

The ID of the new AddressType.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddAddressTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddAddressTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds an AddressType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAddressTypeAsync(
    AddressType addressType,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddAddressTypeAsync ( _
    addressType As AddressType, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

addressType
Type: ININ.IceLib.Tracker..::..AddressType
The AddressType to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddIndividualType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddIndividualType Method
TrackerAdmin Class See Also Send Feedback
Adds an IndividualType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddIndividualType(
    IndividualType individualType
)
Visual Basic
Public Function AddIndividualType ( _
    individualType As IndividualType _
) As Long

Parameters

individualType
Type: ININ.IceLib.Tracker..::..IndividualType
The IndividualType to add.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddIndividualTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddIndividualTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds an IndividualType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddIndividualTypeAsync(
    IndividualType individualType,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddIndividualTypeAsync ( _
    individualType As IndividualType, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

individualType
Type: ININ.IceLib.Tracker..::..IndividualType
The IndividualType to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddInteractionAddressSubtype Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddInteractionAddressSubtype Method
TrackerAdmin Class See Also Send Feedback
Adds an InteractionAddressSubtype to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddInteractionAddressSubtype(
    InteractionAddressSubtype interactionAddressSubtype
)
Visual Basic
Public Function AddInteractionAddressSubtype ( _
    interactionAddressSubtype As InteractionAddressSubtype _
) As Long

Parameters

interactionAddressSubtype
Type: ININ.IceLib.Tracker..::..InteractionAddressSubtype
The InteractionAddressSubtype to add.

Return Value

The ID of the new InteractionAddressSubtype.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddInteractionAddressSubtypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddInteractionAddressSubtypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds an InteractionAddressSubtype to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddInteractionAddressSubtypeAsync(
    InteractionAddressSubtype interactionAddressSubtype,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddInteractionAddressSubtypeAsync ( _
    interactionAddressSubtype As InteractionAddressSubtype, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

interactionAddressSubtype
Type: ININ.IceLib.Tracker..::..InteractionAddressSubtype
The InteractionAddressSubtype to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddInteractionAddressType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddInteractionAddressType Method
TrackerAdmin Class See Also Send Feedback
Adds an InteractionAddressType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddInteractionAddressType(
    InteractionAddressType interactionAddressType
)
Visual Basic
Public Function AddInteractionAddressType ( _
    interactionAddressType As InteractionAddressType _
) As Long

Parameters

interactionAddressType
Type: ININ.IceLib.Tracker..::..InteractionAddressType
The InteractionAddressType to add.

Return Value

The ID of the new InteractionAddressType.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddInteractionAddressTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddInteractionAddressTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds an InteractionAddressType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddInteractionAddressTypeAsync(
    InteractionAddressType interactionAddressType,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddInteractionAddressTypeAsync ( _
    interactionAddressType As InteractionAddressType, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

interactionAddressType
Type: ININ.IceLib.Tracker..::..InteractionAddressType
The InteractionAddressSubtype to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddOrganizationType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddOrganizationType Method
TrackerAdmin Class See Also Send Feedback
Adds an OrganizationType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddOrganizationType(
    OrganizationType organizationType
)
Visual Basic
Public Function AddOrganizationType ( _
    organizationType As OrganizationType _
) As Long

Parameters

organizationType
Type: ININ.IceLib.Tracker..::..OrganizationType
The OrganizationType to add.

Return Value

The ID of the new OrganizationType.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddOrganizationTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddOrganizationTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds an OrganizationType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddOrganizationTypeAsync(
    OrganizationType organizationType,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddOrganizationTypeAsync ( _
    organizationType As OrganizationType, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

organizationType
Type: ININ.IceLib.Tracker..::..OrganizationType
The OrganizationType to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddTitle Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddTitle Method
TrackerAdmin Class See Also Send Feedback
Adds a Title to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddTitle(
    Title title
)
Visual Basic
Public Function AddTitle ( _
    title As Title _
) As Long

Parameters

title
Type: ININ.IceLib.Tracker..::..Title
The Title to add.

Return Value

The ID of the new title.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddTitleAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddTitleAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds a Title to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddTitleAsync(
    Title title,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddTitleAsync ( _
    title As Title, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

title
Type: ININ.IceLib.Tracker..::..Title
The Title to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddTrackerAttributeType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddTrackerAttributeType Method
TrackerAdmin Class See Also Send Feedback
Adds a TrackerAttributeType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddTrackerAttributeType(
    TrackerAttributeType trackerAttributeType
)
Visual Basic
Public Function AddTrackerAttributeType ( _
    trackerAttributeType As TrackerAttributeType _
) As Long

Parameters

trackerAttributeType
Type: ININ.IceLib.Tracker..::..TrackerAttributeType
The TrackerAttributeType to add.

Return Value

The ID of the new TrackerAttributeType.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


AddTrackerAttributeTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..AddTrackerAttributeTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously adds a TrackerAttributeType to the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddTrackerAttributeTypeAsync(
    TrackerAttributeType trackerAttributeType,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddTrackerAttributeTypeAsync ( _
    trackerAttributeType As TrackerAttributeType, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

trackerAttributeType
Type: ININ.IceLib.Tracker..::..TrackerAttributeType
The TrackerAttributeType to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteAddressType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteAddressType Method
TrackerAdmin Class See Also Send Feedback
Deletes an AddressType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAddressType(
    long id
)
Visual Basic
Public Sub DeleteAddressType ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the AddressType to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteAddressTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteAddressTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes an AddressType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAddressTypeAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteAddressTypeAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the AddressType to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteIndividualType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteIndividualType Method
TrackerAdmin Class See Also Send Feedback
Deletes an IndividualType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualType(
    long id
)
Visual Basic
Public Sub DeleteIndividualType ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the IndividualType to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteIndividualTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteIndividualTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes an IndividualType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualTypeAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteIndividualTypeAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the IndividualType to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteInteractionAddressSubtype Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteInteractionAddressSubtype Method
TrackerAdmin Class See Also Send Feedback
Deletes an InteractionAddressSubtype from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteInteractionAddressSubtype(
    long id
)
Visual Basic
Public Sub DeleteInteractionAddressSubtype ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the InteractionAddressSubtype to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteInteractionAddressSubtypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteInteractionAddressSubtypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes an InteractionAddressSubtype from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteInteractionAddressSubtypeAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteInteractionAddressSubtypeAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the InteractionAddressSubtype to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteInteractionAddressType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteInteractionAddressType Method
TrackerAdmin Class See Also Send Feedback
Deletes an InteractionAddressType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteInteractionAddressType(
    long interactionAddressId
)
Visual Basic
Public Sub DeleteInteractionAddressType ( _
    interactionAddressId As Long _
)

Parameters

interactionAddressId
Type: System..::..Int64
The ID of the InteractionAddressType to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteInteractionAddressTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteInteractionAddressTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes an InteractionAddressType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteInteractionAddressTypeAsync(
    long interactionAddressId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteInteractionAddressTypeAsync ( _
    interactionAddressId As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactionAddressId
Type: System..::..Int64
The ID of the InteractionAddressType to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteOrganizationType Method
TrackerAdmin Class See Also Send Feedback
Deletes an OrganizationType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationType(
    long id
)
Visual Basic
Public Sub DeleteOrganizationType ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationType to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteOrganizationTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes an OrganizationType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationTypeAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteOrganizationTypeAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationType to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteTitle Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteTitle Method
TrackerAdmin Class See Also Send Feedback
Deletes a Title from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteTitle(
    long id
)
Visual Basic
Public Sub DeleteTitle ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the Title to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteTitleAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteTitleAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes a Title from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteTitleAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteTitleAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the Title to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteTrackerAttributeType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteTrackerAttributeType Method
TrackerAdmin Class See Also Send Feedback
Deletes a TrackerAttributeType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteTrackerAttributeType(
    long id
)
Visual Basic
Public Sub DeleteTrackerAttributeType ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the TrackerAttributeType to delete.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


DeleteTrackerAttributeTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..DeleteTrackerAttributeTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously deletes a TrackerAttributeType from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteTrackerAttributeTypeAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteTrackerAttributeTypeAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the TrackerAttributeType to delete.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetAddressTypeById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetAddressTypeById Method
TrackerAdmin Class See Also Send Feedback
Gets an AddressType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AddressType GetAddressTypeById(
    long id
)
Visual Basic
Public Function GetAddressTypeById ( _
    id As Long _
) As AddressType

Parameters

id
Type: System..::..Int64
The ID of the AddressType to get.

Return Value

The address type.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetAddressTypeByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetAddressTypeByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets an AddressType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetAddressTypeByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<AddressType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetAddressTypeByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of AddressType)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the AddressType to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' AddressType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetAddressTypes Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetAddressTypes Method
TrackerAdmin Class See Also Send Feedback
Gets all AddressTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<AddressType> GetAddressTypes()
Visual Basic
Public Function GetAddressTypes As Collection(Of AddressType)

Return Value

The AddressTypes.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetAddressTypesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetAddressTypesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all AddressTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetAddressTypesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<AddressType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetAddressTypesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of AddressType)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' AddressType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetIndividualTypeById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetIndividualTypeById Method
TrackerAdmin Class See Also Send Feedback
Gets an IndividualType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualType GetIndividualTypeById(
    long id
)
Visual Basic
Public Function GetIndividualTypeById ( _
    id As Long _
) As IndividualType

Parameters

id
Type: System..::..Int64
The ID of the IndividualType to get.

Return Value

The IndividualType.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetIndividualTypeByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetIndividualTypeByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets an IndividualType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetIndividualTypeByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<IndividualType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetIndividualTypeByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of IndividualType)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the IndividualType to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' IndividualType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetIndividualTypes Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetIndividualTypes Method
TrackerAdmin Class See Also Send Feedback
Gets all IndividualTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<IndividualType> GetIndividualTypes()
Visual Basic
Public Function GetIndividualTypes As Collection(Of IndividualType)

Return Value

The IndividualTypes.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetIndividualTypesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetIndividualTypesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all IndividualTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetIndividualTypesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<IndividualType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetIndividualTypesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of IndividualType)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' IndividualType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressSubtypeById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressSubtypeById Method
TrackerAdmin Class See Also Send Feedback
Gets an InteractionAddressSubtype by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAddressSubtype GetInteractionAddressSubtypeById(
    long id
)
Visual Basic
Public Function GetInteractionAddressSubtypeById ( _
    id As Long _
) As InteractionAddressSubtype

Parameters

id
Type: System..::..Int64
The ID of the InteractionAddressSubtype to get.

Return Value

The InteractionAddressSubtype.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressSubtypeByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressSubtypeByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets an InteractionAddressSubtype by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionAddressSubtypeByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<InteractionAddressSubtype>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionAddressSubtypeByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of InteractionAddressSubtype)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the InteractionAddressSubtype to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' InteractionAddressSubtype >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressSubtypes Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressSubtypes Method
TrackerAdmin Class See Also Send Feedback
Gets all InteractionAddressSubtypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<InteractionAddressSubtype> GetInteractionAddressSubtypes()
Visual Basic
Public Function GetInteractionAddressSubtypes As Collection(Of InteractionAddressSubtype)

Return Value

The InteractionAddressSubtypes.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressSubtypesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressSubtypesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all InteractionAddressSubtypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionAddressSubtypesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<InteractionAddressSubtype>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionAddressSubtypesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of InteractionAddressSubtype)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' InteractionAddressSubtype >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressTypeById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressTypeById Method
TrackerAdmin Class See Also Send Feedback
Gets an InteractionAddressType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionAddressType GetInteractionAddressTypeById(
    long id
)
Visual Basic
Public Function GetInteractionAddressTypeById ( _
    id As Long _
) As InteractionAddressType

Parameters

id
Type: System..::..Int64
The ID of the InteractionAddressType to get.

Return Value

The InteractionAddressType.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressTypeByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressTypeByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets an InteractionAddressType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionAddressTypeByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<InteractionAddressType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionAddressTypeByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of InteractionAddressType)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the InteractionAddressType to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' InteractionAddressType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressTypes Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressTypes Method
TrackerAdmin Class See Also Send Feedback
Gets all InteractionAddressTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<InteractionAddressType> GetInteractionAddressTypes()
Visual Basic
Public Function GetInteractionAddressTypes As Collection(Of InteractionAddressType)

Return Value

The InteractionAddressTypes.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetInteractionAddressTypesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetInteractionAddressTypesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all InteractionAddressTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionAddressTypesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<InteractionAddressType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionAddressTypesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of InteractionAddressType)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' InteractionAddressType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetOrganizationTypeById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetOrganizationTypeById Method
TrackerAdmin Class See Also Send Feedback
Gets an OrganizationType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationType GetOrganizationTypeById(
    long id
)
Visual Basic
Public Function GetOrganizationTypeById ( _
    id As Long _
) As OrganizationType

Parameters

id
Type: System..::..Int64
The ID of the OrganizationType to get.

Return Value

The OrganizationType.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetOrganizationTypeByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetOrganizationTypeByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets an OrganizationType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetOrganizationTypeByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<OrganizationType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetOrganizationTypeByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of OrganizationType)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationType to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' OrganizationType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetOrganizationTypes Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetOrganizationTypes Method
TrackerAdmin Class See Also Send Feedback
Gets all OrganizationTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<OrganizationType> GetOrganizationTypes()
Visual Basic
Public Function GetOrganizationTypes As Collection(Of OrganizationType)

Return Value

The OrganizationTypes.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetOrganizationTypesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetOrganizationTypesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all OrganizationTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetOrganizationTypesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<OrganizationType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetOrganizationTypesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of OrganizationType)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' OrganizationType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTitleById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTitleById Method
TrackerAdmin Class See Also Send Feedback
Gets a Title by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Title GetTitleById(
    long id
)
Visual Basic
Public Function GetTitleById ( _
    id As Long _
) As Title

Parameters

id
Type: System..::..Int64
The ID of the Title to get.

Return Value

The Title.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTitleByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTitleByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets a Title by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetTitleByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<Title>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetTitleByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of Title)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the Title to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' Title >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTitles Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTitles Method
TrackerAdmin Class See Also Send Feedback
Gets all Titles.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<Title> GetTitles()
Visual Basic
Public Function GetTitles As Collection(Of Title)

Return Value

The Titles.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTitlesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTitlesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all Title.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetTitlesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<Title>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetTitlesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of Title)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' Title >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTrackerAttributeTypeById Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTrackerAttributeTypeById Method
TrackerAdmin Class See Also Send Feedback
Gets a TrackerAttributeType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerAttributeType GetTrackerAttributeTypeById(
    long id
)
Visual Basic
Public Function GetTrackerAttributeTypeById ( _
    id As Long _
) As TrackerAttributeType

Parameters

id
Type: System..::..Int64
The ID of the TrackerAttributeType to get.

Return Value

The TrackerAttributeType.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTrackerAttributeTypeByIdAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTrackerAttributeTypeByIdAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets a TrackerAttributeType by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetTrackerAttributeTypeByIdAsync(
    long id,
    EventHandler<QueryResultCompletedEventArgs<TrackerAttributeType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetTrackerAttributeTypeByIdAsync ( _
    id As Long, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of TrackerAttributeType)), _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the TrackerAttributeType to get.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' TrackerAttributeType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTrackerAttributeTypes Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTrackerAttributeTypes Method
TrackerAdmin Class See Also Send Feedback
Gets all TrackerAttributeTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<TrackerAttributeType> GetTrackerAttributeTypes(
    AppliesToTypes appliesTo
)
Visual Basic
Public Function GetTrackerAttributeTypes ( _
    appliesTo As AppliesToTypes _
) As Collection(Of TrackerAttributeType)

Parameters

appliesTo
Type: ININ.IceLib.Tracker..::..AppliesToTypes
Only return TrackerAttributeTypes for these Tracker types. Use the AppliesToTypes enum to specify the Tracker types.

Return Value

The TrackerAttributeTypes.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


GetTrackerAttributeTypesAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..GetTrackerAttributeTypesAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously gets all TrackerAttributeTypes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetTrackerAttributeTypesAsync(
    AppliesToTypes appliesTo,
    EventHandler<QueryCollectionResultCompletedEventArgs<TrackerAttributeType>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetTrackerAttributeTypesAsync ( _
    appliesTo As AppliesToTypes, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of TrackerAttributeType)), _
    userState As Object _
)

Parameters

appliesTo
Type: ININ.IceLib.Tracker..::..AppliesToTypes
Only return TrackerAttributeTypes for these Tracker types. Use the AppliesToTypes enum to specify the Tracker types.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' TrackerAttributeType >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


ICUserModified Method

[image]

IceLib Technical Reference
TrackerAdmin..::..ICUserModified Method
TrackerAdmin Class See Also Send Feedback
Marks an IC user as modified.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ICUserModified(
    string ICUserId
)
Visual Basic
Public Sub ICUserModified ( _
    ICUserId As String _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


ICUserModifiedAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..ICUserModifiedAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously marks an IC user as modified.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ICUserModifiedAsync(
    string ICUserId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ICUserModifiedAsync ( _
    ICUserId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


ImportICUsers Method

[image]

IceLib Technical Reference
TrackerAdmin..::..ImportICUsers Method
TrackerAdmin Class See Also Send Feedback
Imports the IC users.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ImportICUsers(
    bool updateExistingUsers,
    string siteIds
)
Visual Basic
Public Sub ImportICUsers ( _
    updateExistingUsers As Boolean, _
    siteIds As String _
)

Parameters

updateExistingUsers
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) update existing users.
siteIds
Type: System..::..String
The site IDs.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


ImportICUsersAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..ImportICUsersAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously imports the IC users.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ImportICUsersAsync(
    bool updateExistingUsers,
    string siteIds,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ImportICUsersAsync ( _
    updateExistingUsers As Boolean, _
    siteIds As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

updateExistingUsers
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) update existing users.
siteIds
Type: System..::..String
The site IDs.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividual Method

[image]

IceLib Technical Reference
TrackerAdmin..::..IsUnknownOrSystemIndividual Method
TrackerAdmin Class See Also Send Feedback
Determines whether the specific Individual is unknown or a system Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsUnknownOrSystemIndividual(
    string individualId
)
Visual Basic
Public Function IsUnknownOrSystemIndividual ( _
    individualId As String _
) As Boolean

Parameters

individualId
Type: System..::..String
The ID of the Individual.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Individual is recognized; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..IsUnknownOrSystemIndividualAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously determines whether the specific Individual is unknown or a system Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void IsUnknownOrSystemIndividualAsync(
    string individualId,
    EventHandler<IsUnknownOrSystemIndividualCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub IsUnknownOrSystemIndividualAsync ( _
    individualId As String, _
    completedCallback As EventHandler(Of IsUnknownOrSystemIndividualCompletedEventArgs), _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' IsUnknownOrSystemIndividualCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateAddressType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateAddressType Method
TrackerAdmin Class See Also Send Feedback
Updates an AddressType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateAddressType(
    AddressType addressType
)
Visual Basic
Public Sub UpdateAddressType ( _
    addressType As AddressType _
)

Parameters

addressType
Type: ININ.IceLib.Tracker..::..AddressType
The AddressType to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateAddressTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateAddressTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates an AddressType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateAddressTypeAsync(
    AddressType addressType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateAddressTypeAsync ( _
    addressType As AddressType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

addressType
Type: ININ.IceLib.Tracker..::..AddressType
The AddressType to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateIndividualType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateIndividualType Method
TrackerAdmin Class See Also Send Feedback
Updates an IndividualType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualType(
    IndividualType individualType
)
Visual Basic
Public Sub UpdateIndividualType ( _
    individualType As IndividualType _
)

Parameters

individualType
Type: ININ.IceLib.Tracker..::..IndividualType
The IndividualType to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateIndividualTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateIndividualTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates an IndividualType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualTypeAsync(
    IndividualType individualType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateIndividualTypeAsync ( _
    individualType As IndividualType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

individualType
Type: ININ.IceLib.Tracker..::..IndividualType
The IndividualType to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateInteractionAddressSubtype Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateInteractionAddressSubtype Method
TrackerAdmin Class See Also Send Feedback
Updates an InteractionAddressSubtype.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateInteractionAddressSubtype(
    InteractionAddressSubtype interactionAddressSubtype
)
Visual Basic
Public Sub UpdateInteractionAddressSubtype ( _
    interactionAddressSubtype As InteractionAddressSubtype _
)

Parameters

interactionAddressSubtype
Type: ININ.IceLib.Tracker..::..InteractionAddressSubtype
The InteractionAddressSubtype to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateInteractionAddressSubtypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateInteractionAddressSubtypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates an InteractionAddressSubtype.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateInteractionAddressSubtypeAsync(
    InteractionAddressSubtype interactionAddressSubtype,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateInteractionAddressSubtypeAsync ( _
    interactionAddressSubtype As InteractionAddressSubtype, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactionAddressSubtype
Type: ININ.IceLib.Tracker..::..InteractionAddressSubtype
The InteractionAddressSubtype to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateInteractionAddressType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateInteractionAddressType Method
TrackerAdmin Class See Also Send Feedback
Updates an InteractionAddressType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateInteractionAddressType(
    InteractionAddressType interactionAddressType
)
Visual Basic
Public Sub UpdateInteractionAddressType ( _
    interactionAddressType As InteractionAddressType _
)

Parameters

interactionAddressType
Type: ININ.IceLib.Tracker..::..InteractionAddressType
The InteractionAddressType to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateInteractionAddressTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateInteractionAddressTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates an InteractionAddressType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateInteractionAddressTypeAsync(
    InteractionAddressType interactionAddressType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateInteractionAddressTypeAsync ( _
    interactionAddressType As InteractionAddressType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactionAddressType
Type: ININ.IceLib.Tracker..::..InteractionAddressType
The InteractionAddressType to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateOrganizationType Method
TrackerAdmin Class See Also Send Feedback
Updates an OrganizationType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationType(
    OrganizationType organizationType
)
Visual Basic
Public Sub UpdateOrganizationType ( _
    organizationType As OrganizationType _
)

Parameters

organizationType
Type: ININ.IceLib.Tracker..::..OrganizationType
The OrganizationType to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateOrganizationTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates an OrganizationType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationTypeAsync(
    OrganizationType organizationType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateOrganizationTypeAsync ( _
    organizationType As OrganizationType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

organizationType
Type: ININ.IceLib.Tracker..::..OrganizationType
The OrganizationType to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateTitle Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateTitle Method
TrackerAdmin Class See Also Send Feedback
Updates a Title.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateTitle(
    Title title
)
Visual Basic
Public Sub UpdateTitle ( _
    title As Title _
)

Parameters

title
Type: ININ.IceLib.Tracker..::..Title
The Title to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateTitleAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateTitleAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates a Title.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateTitleAsync(
    Title title,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateTitleAsync ( _
    title As Title, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

title
Type: ININ.IceLib.Tracker..::..Title
The Title to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateTrackerAttributeType Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateTrackerAttributeType Method
TrackerAdmin Class See Also Send Feedback
Updates a TrackerAttributeType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateTrackerAttributeType(
    TrackerAttributeType trackerAttributeType
)
Visual Basic
Public Sub UpdateTrackerAttributeType ( _
    trackerAttributeType As TrackerAttributeType _
)

Parameters

trackerAttributeType
Type: ININ.IceLib.Tracker..::..TrackerAttributeType
The TrackerAttributeType to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateTrackerAttributeTypeAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateTrackerAttributeTypeAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates a TrackerAttributeType.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateTrackerAttributeTypeAsync(
    TrackerAttributeType trackerAttributeType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateTrackerAttributeTypeAsync ( _
    trackerAttributeType As TrackerAttributeType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

trackerAttributeType
Type: ININ.IceLib.Tracker..::..TrackerAttributeType
The TrackerAttributeType to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateUserSecurity Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateUserSecurity Method
TrackerAdmin Class See Also Send Feedback
Updates the security for an IC user.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateUserSecurity(
    string ICUserId,
    long securityChecksum,
    string viewableUsers
)
Visual Basic
Public Sub UpdateUserSecurity ( _
    ICUserId As String, _
    securityChecksum As Long, _
    viewableUsers As String _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.
securityChecksum
Type: System..::..Int64
The security checksum.
viewableUsers
Type: System..::..String
The viewable users.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


UpdateUserSecurityAsync Method

[image]

IceLib Technical Reference
TrackerAdmin..::..UpdateUserSecurityAsync Method
TrackerAdmin Class See Also Send Feedback
Asynchronously updates the security for an IC user.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateUserSecurityAsync(
    string ICUserId,
    long securityChecksum,
    string viewableUsers,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateUserSecurityAsync ( _
    ICUserId As String, _
    securityChecksum As Long, _
    viewableUsers As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.
securityChecksum
Type: System..::..Int64
The security checksum.
viewableUsers
Type: System..::..String
The viewable users.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


TrackerAdmin Properties

[image] [image]

IceLib Technical Reference
TrackerAdmin Properties
TrackerAdmin Class See Also Send Feedback

The TrackerAdmin type exposes the following members.

Properties

 | Name | Description
Public property | TransactionClient | Gets the TransactionClient.

See Also

TrackerAdmin Class
ININ.IceLib.Tracker Namespace


TransactionClient Property

[image]

IceLib Technical Reference
TrackerAdmin..::..TransactionClient Property
TrackerAdmin Class See Also Send Feedback
Gets the TransactionClient.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionClient TransactionClient { get; }
Visual Basic
Public ReadOnly Property TransactionClient As TransactionClient
    Get

Field Value

The TransactionClient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAdmin Class
TrackerAdmin Members
ININ.IceLib.Tracker Namespace


TrackerAttribute Class

[image]

IceLib Technical Reference
TrackerAttribute Class
Members See Also Send Feedback
Represents an attribute within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerAttribute
Visual Basic
Public Class TrackerAttribute

Remarks

A Tracker Attribute is not the same as an xIC Attribute. Attributes in Tracker consist of a TrackerAttributeType and a string Value. A Tracker Attribute can be associated with Individuals, Organization, Locations and Interactions.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..TrackerAttribute

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttribute Members
ININ.IceLib.Tracker Namespace


TrackerAttribute Members

[image] [image]

IceLib Technical Reference
TrackerAttribute Members
TrackerAttribute Class Constructors Methods Properties See Also Send Feedback

The TrackerAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerAttribute | Initializes a new instance of the TrackerAttribute class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TrackerAttributeTypeId | Gets or sets the Tracker attribute type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerEntityId | Gets or sets the ID of the Tracker entity (Individual, Organization, Location, Interactions) that is associated with this Tracker Attribute. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

TrackerAttribute Class
ININ.IceLib.Tracker Namespace


TrackerAttribute Constructor

[image]

IceLib Technical Reference
TrackerAttribute Constructor
TrackerAttribute Class See Also Send Feedback
Initializes a new instance of the TrackerAttribute class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerAttribute()
Visual Basic
Public Sub New

See Also

TrackerAttribute Class
TrackerAttribute Members
ININ.IceLib.Tracker Namespace


TrackerAttribute Methods

[image] [image]

IceLib Technical Reference
TrackerAttribute Methods
TrackerAttribute Class See Also Send Feedback

The TrackerAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerAttribute Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
TrackerAttribute..::..Reset Method
TrackerAttribute Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttribute Class
TrackerAttribute Members
ININ.IceLib.Tracker Namespace


TrackerAttribute Properties

[image] [image]

IceLib Technical Reference
TrackerAttribute Properties
TrackerAttribute Class See Also Send Feedback

The TrackerAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TrackerAttributeTypeId | Gets or sets the Tracker attribute type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerEntityId | Gets or sets the ID of the Tracker entity (Individual, Organization, Location, Interactions) that is associated with this Tracker Attribute. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

TrackerAttribute Class
ININ.IceLib.Tracker Namespace


TrackerAttributeTypeId Property

[image]

IceLib Technical Reference
TrackerAttribute..::..TrackerAttributeTypeId Property
TrackerAttribute Class See Also Send Feedback
Gets or sets the Tracker attribute type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> TrackerAttributeTypeId { get; set; }
Visual Basic
Public Property TrackerAttributeTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The Tracker attribute type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttribute Class
TrackerAttribute Members
ININ.IceLib.Tracker Namespace


TrackerEntityId Property

[image]

IceLib Technical Reference
TrackerAttribute..::..TrackerEntityId Property
TrackerAttribute Class See Also Send Feedback
Gets or sets the ID of the Tracker entity (Individual, Organization, Location, Interactions) that is associated with this Tracker Attribute. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string TrackerEntityId { get; set; }
Visual Basic
Public Property TrackerEntityId As String
    Get
    Set

Field Value

The Tracker entity ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttribute Class
TrackerAttribute Members
ININ.IceLib.Tracker Namespace


Value Property

[image]

IceLib Technical Reference
TrackerAttribute..::..Value Property
TrackerAttribute Class See Also Send Feedback
Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttribute Class
TrackerAttribute Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
TrackerAttribute..::..Version Property
TrackerAttribute Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttribute Class
TrackerAttribute Members
ININ.IceLib.Tracker Namespace


TrackerAttributeType Class

[image]

IceLib Technical Reference
TrackerAttributeType Class
Members See Also Send Feedback
Represents a Tracker attribute type within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerAttributeType
Visual Basic
Public Class TrackerAttributeType

Remarks

TrackerAttributeTypes are used to classify Attributes within Tracker. A TrackerAttributeType can have a Name and an optional set of LegalValues. Each Tracker TrackerAttribute has a TrackerAttributeType.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..TrackerAttributeType

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


TrackerAttributeType Members

[image] [image]

IceLib Technical Reference
TrackerAttributeType Members
TrackerAttributeType Class Constructors Methods Properties See Also Send Feedback

The TrackerAttributeType type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerAttributeType | Initializes a new instance of the TrackerAttributeType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AppliesTo | Gets or sets the applies to setting. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LegalValues | Gets or sets the legal values. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ShowIfEmpty | Gets or sets a value indicating whether to show if empty. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

TrackerAttributeType Class
ININ.IceLib.Tracker Namespace


TrackerAttributeType Constructor

[image]

IceLib Technical Reference
TrackerAttributeType Constructor
TrackerAttributeType Class See Also Send Feedback
Initializes a new instance of the TrackerAttributeType class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerAttributeType()
Visual Basic
Public Sub New

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


TrackerAttributeType Methods

[image] [image]

IceLib Technical Reference
TrackerAttributeType Methods
TrackerAttributeType Class See Also Send Feedback

The TrackerAttributeType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerAttributeType Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
TrackerAttributeType..::..Reset Method
TrackerAttributeType Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


TrackerAttributeType Properties

[image] [image]

IceLib Technical Reference
TrackerAttributeType Properties
TrackerAttributeType Class See Also Send Feedback

The TrackerAttributeType type exposes the following members.

Properties

 | Name | Description
Public property | AdminEditable | Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | AppliesTo | Gets or sets the applies to setting. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Id | Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | LegalValues | Gets or sets the legal values. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | ShowIfEmpty | Gets or sets a value indicating whether to show if empty. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

TrackerAttributeType Class
ININ.IceLib.Tracker Namespace


AdminEditable Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..AdminEditable Property
TrackerAttributeType Class See Also Send Feedback
Gets or sets a value indicating whether the instance is admin editable. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> AdminEditable { get; set; }
Visual Basic
Public Property AdminEditable As Nullable(Of Long)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if admin editable; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


AppliesTo Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..AppliesTo Property
TrackerAttributeType Class See Also Send Feedback
Gets or sets the applies to setting. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<AppliesToTypes> AppliesTo { get; set; }
Visual Basic
Public Property AppliesTo As Nullable(Of AppliesToTypes)
    Get
    Set

Field Value

The applies to setting, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


Id Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..Id Property
TrackerAttributeType Class See Also Send Feedback
Gets or sets the ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Long)
    Get
    Set

Field Value

The ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


LegalValues Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..LegalValues Property
TrackerAttributeType Class See Also Send Feedback
Gets or sets the legal values. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> LegalValues { get; set; }
Visual Basic
Public Property LegalValues As ReadOnlyCollection(Of String)
    Get
    Set

Field Value

The legal values, or nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Legal values are useful for storing a set of strings that the Value of a TrackerAttribute can be restricted to. For instance, if you had a TrackerAttributeType with a Name of cars, you may want to display a list of possible Values for this Tracker attribute. If the desired list of values is Chevy, Ford, Toyota, then the LegalValues property would contain: "Chevy", "Ford", and "Toyota"

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..Name Property
TrackerAttributeType Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


ShowIfEmpty Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..ShowIfEmpty Property
TrackerAttributeType Class See Also Send Feedback
Gets or sets a value indicating whether to show if empty. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<bool> ShowIfEmpty { get; set; }
Visual Basic
Public Property ShowIfEmpty As Nullable(Of Boolean)
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should show if empty; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
TrackerAttributeType..::..Version Property
TrackerAttributeType Class See Also Send Feedback
Gets version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeType Class
TrackerAttributeType Members
ININ.IceLib.Tracker Namespace


TrackerAttributeView Class

[image]

IceLib Technical Reference
TrackerAttributeView Class
Members See Also Send Feedback
Represents an attribute view within Tracker.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerAttributeView
Visual Basic
Public Class TrackerAttributeView

Remarks

The TrackerAttributeView class is used by methods that return information about Tracker attributes. One such method is the GetInteractionDetails(String, String) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..TrackerAttributeView

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


TrackerAttributeView Members

[image] [image]

IceLib Technical Reference
TrackerAttributeView Members
TrackerAttributeView Class Constructors Methods Properties See Also Send Feedback

The TrackerAttributeView type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerAttributeView | Initializes a new instance of the TrackerAttributeView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeTypeId | Gets or sets the Tracker attribute type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

TrackerAttributeView Class
ININ.IceLib.Tracker Namespace


TrackerAttributeView Constructor

[image]

IceLib Technical Reference
TrackerAttributeView Constructor
TrackerAttributeView Class See Also Send Feedback
Initializes a new instance of the TrackerAttributeView class

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerAttributeView()
Visual Basic
Public Sub New

See Also

TrackerAttributeView Class
TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


TrackerAttributeView Methods

[image] [image]

IceLib Technical Reference
TrackerAttributeView Methods
TrackerAttributeView Class See Also Send Feedback

The TrackerAttributeView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerAttributeView Class
ININ.IceLib.Tracker Namespace


Reset Method

[image]

IceLib Technical Reference
TrackerAttributeView..::..Reset Method
TrackerAttributeView Class See Also Send Feedback
Sets all members to nullNothingnullptra null reference (Nothing in Visual Basic). Useful for validating return data.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeView Class
TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


TrackerAttributeView Properties

[image] [image]

IceLib Technical Reference
TrackerAttributeView Properties
TrackerAttributeView Class See Also Send Feedback

The TrackerAttributeView type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | TrackerAttributeTypeId | Gets or sets the Tracker attribute type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Value | Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)
Public property | Version | Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

See Also

TrackerAttributeView Class
ININ.IceLib.Tracker Namespace


Name Property

[image]

IceLib Technical Reference
TrackerAttributeView..::..Name Property
TrackerAttributeView Class See Also Send Feedback
Gets or sets the name. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeView Class
TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


TrackerAttributeTypeId Property

[image]

IceLib Technical Reference
TrackerAttributeView..::..TrackerAttributeTypeId Property
TrackerAttributeView Class See Also Send Feedback
Gets or sets the Tracker attribute type ID. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> TrackerAttributeTypeId { get; set; }
Visual Basic
Public Property TrackerAttributeTypeId As Nullable(Of Long)
    Get
    Set

Field Value

The Tracker attribute type ID, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeView Class
TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


Value Property

[image]

IceLib Technical Reference
TrackerAttributeView..::..Value Property
TrackerAttributeView Class See Also Send Feedback
Gets or sets the value. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Field Value

The value, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeView Class
TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


Version Property

[image]

IceLib Technical Reference
TrackerAttributeView..::..Version Property
TrackerAttributeView Class See Also Send Feedback
Gets or sets the version. (Can be nullNothingnullptra null reference (Nothing in Visual Basic).)

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Nullable<long> Version { get; internal set; }
Visual Basic
Public Property Version As Nullable(Of Long)
    Get
    Friend Set

Field Value

The version, or nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerAttributeView Class
TrackerAttributeView Members
ININ.IceLib.Tracker Namespace


TrackerContactEntry Class

[image]

IceLib Technical Reference
TrackerContactEntry Class
Members See Also Send Feedback
Provides extended Tracker information for a ContactEntry in a Tracker Directory.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerContactEntry : ContactEntry
Visual Basic
Public Class TrackerContactEntry _
    Inherits ContactEntry

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Directories..::..ContactEntry
ININ.IceLib.Tracker..::..TrackerContactEntry

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerContactEntry Members
ININ.IceLib.Tracker Namespace


TrackerContactEntry Members

[image] [image]

IceLib Technical Reference
TrackerContactEntry Members
TrackerContactEntry Class Constructors Methods Properties See Also Send Feedback

The TrackerContactEntry type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerContactEntry | Initializes a new instance of the TrackerContactEntry class.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type. (Inherited from ContactEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultPhoneNumber | This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance. (Inherited from ContactEntry.)
Public method | GetDisplayableIdentifier | This is a convenience method that will retrieve an displayable identifier for this ContactEntry. (Inherited from ContactEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ContactEntry.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAccess | Determines whether the specified access rights have been granted. (Inherited from ContactEntry.)
Public method | IsOwner | Determines whether the specified possible owner is the actual owner of this contact entry. (Inherited from ContactEntry.)
Public method | IsPropertySet | Determines whether the specified ContactProperty contains data for this ContactEntry. (Inherited from ContactEntry.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ContactEntry.)

Properties

 | Name | Description
Public property | AccessRights | Gets the access rights. (Inherited from ContactEntry.)
Public property | Addresses | Gets the addresses.
Public property | Alias | Gets the alias. (Inherited from ContactEntry.)
Public property | Assistant | Gets the assistant. (Inherited from ContactEntry.)
Public property | AssistantPhone | Gets the assistant phone. (Inherited from ContactEntry.)
Public property | BusinessAddress | Gets the business address. (Inherited from ContactEntry.)
Public property | BusinessCity | Gets the business city. (Inherited from ContactEntry.)
Public property | BusinessCountry | Gets the business country. (Inherited from ContactEntry.)
Public property | BusinessEmail | Gets the business Email. (Inherited from ContactEntry.)
Public property | BusinessPhone | Gets the business telephone number. (Inherited from ContactEntry.)
Public property | BusinessPhone2 | Gets the second business phone. (Inherited from ContactEntry.)
Public property | BusinessState | Gets the state of the business. (Inherited from ContactEntry.)
Public property | BusinessZipCode | Gets the business zip code. (Inherited from ContactEntry.)
Public property | Company | Gets the company. (Inherited from ContactEntry.)
Public property | ContactSources | Gets the contact's source(s). See ContactSource for further details. (Inherited from ContactEntry.)
Public property | Department | Gets the department. (Inherited from ContactEntry.)
Public property | DisplayName | Gets the directory contact display name. (Inherited from ContactEntry.)
Public property | EntryId | Gets the entry ID. A unique identifier for a directory contact instance. (Inherited from ContactEntry.)
Public property | Extension | Gets the extension. (Inherited from ContactEntry.)
Public property | ExtensionAsPhoneNumber | Gets the extension in Phone Number format. DirectoryPhoneNumber. (Inherited from ContactEntry.)
Public property | ExternalContactEntries | Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC. (Inherited from ContactEntry.)
Public property | ExternalPresenceProviders | Gets the available external presence providers for this contact. (Inherited from ContactEntry.)
Public property | Fax | Gets the Fax. (Inherited from ContactEntry.)
Public property | FirstName | Gets the first name of the contact. (Inherited from ContactEntry.)
Public property | HomeAddress | Gets the home address. (Inherited from ContactEntry.)
Public property | HomeCity | Gets the home city. (Inherited from ContactEntry.)
Public property | HomeCountry | Gets the home country. (Inherited from ContactEntry.)
Public property | HomeEmail | Gets the home Email. (Inherited from ContactEntry.)
Public property | HomePhone | Gets the home telephone number. (Inherited from ContactEntry.)
Public property | HomePhone2 | Gets the second home phone. (Inherited from ContactEntry.)
Public property | HomeState | Gets the state of the home. (Inherited from ContactEntry.)
Public property | HomeZipCode | Gets the home zip code. (Inherited from ContactEntry.)
Public property | Index | Gets the location of this contact on a paged directory. (Inherited from ContactEntry.)
Public property | InteractionsAddresses | Gets the interactions addresses.
Public property | LastName | Gets the last name of the contact. (Inherited from ContactEntry.)
Public property | LyncSipAddress | Obsolete. Gets the Lync SIP Address for this contact. (Inherited from ContactEntry.)
Public property | MobilePhone | Gets the mobile phone. (Inherited from ContactEntry.)
Public property | Notes | Gets the notes. (Inherited from ContactEntry.)
Public property | OwnerId | Gets the owner. (Inherited from ContactEntry.)
Public property | Pager | Gets the pager. (Inherited from ContactEntry.)
Public property | PrimaryNumberDesignation | Gets the primary number designation. (Inherited from ContactEntry.)
Public property | Skills | Gets the Skills set for this contact. (Inherited from ContactEntry.)
Public property | StatusUri | Gets the Status Uri. (Inherited from ContactEntry.)
Public property | Title | Gets the title. (Inherited from ContactEntry.)
Public property | TrackerAttributes | Gets the tracker attributes.
Public property | TrackerData | Gets the tracker data. (Inherited from ContactEntry.)
Public property | UserId | Gets the user ID. (Inherited from ContactEntry.)
Public property | VoicemailLocation | Gets the Voicemail location. (Inherited from ContactEntry.)
Public property | Webpage | Gets the web page. (Inherited from ContactEntry.)
Public property | Workgroups | Gets the workgroups. (Inherited from ContactEntry.)

See Also

TrackerContactEntry Class
ININ.IceLib.Tracker Namespace


TrackerContactEntry Constructor

[image]

IceLib Technical Reference
TrackerContactEntry Constructor
TrackerContactEntry Class See Also Send Feedback
Initializes a new instance of the TrackerContactEntry class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerContactEntry(
    ContactEntry contactEntry
)
Visual Basic
Public Sub New ( _
    contactEntry As ContactEntry _
)

Parameters

contactEntry
Type: ININ.IceLib.Directories..::..ContactEntry
The contact entry.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerContactEntry Class
TrackerContactEntry Members
ININ.IceLib.Tracker Namespace


TrackerContactEntry Methods

[image] [image]

IceLib Technical Reference
TrackerContactEntry Methods
TrackerContactEntry Class See Also Send Feedback

The TrackerContactEntry type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type. (Inherited from ContactEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultPhoneNumber | This is a convenience method that will apply some heuristics to return a suitable phone number that can be dialed for this contact entry object instance. (Inherited from ContactEntry.)
Public method | GetDisplayableIdentifier | This is a convenience method that will retrieve an displayable identifier for this ContactEntry. (Inherited from ContactEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from ContactEntry.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAccess | Determines whether the specified access rights have been granted. (Inherited from ContactEntry.)
Public method | IsOwner | Determines whether the specified possible owner is the actual owner of this contact entry. (Inherited from ContactEntry.)
Public method | IsPropertySet | Determines whether the specified ContactProperty contains data for this ContactEntry. (Inherited from ContactEntry.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ContactEntry.)

See Also

TrackerContactEntry Class
ININ.IceLib.Tracker Namespace


TrackerContactEntry Properties

[image] [image]

IceLib Technical Reference
TrackerContactEntry Properties
TrackerContactEntry Class See Also Send Feedback

The TrackerContactEntry type exposes the following members.

Properties

 | Name | Description
Public property | AccessRights | Gets the access rights. (Inherited from ContactEntry.)
Public property | Addresses | Gets the addresses.
Public property | Alias | Gets the alias. (Inherited from ContactEntry.)
Public property | Assistant | Gets the assistant. (Inherited from ContactEntry.)
Public property | AssistantPhone | Gets the assistant phone. (Inherited from ContactEntry.)
Public property | BusinessAddress | Gets the business address. (Inherited from ContactEntry.)
Public property | BusinessCity | Gets the business city. (Inherited from ContactEntry.)
Public property | BusinessCountry | Gets the business country. (Inherited from ContactEntry.)
Public property | BusinessEmail | Gets the business Email. (Inherited from ContactEntry.)
Public property | BusinessPhone | Gets the business telephone number. (Inherited from ContactEntry.)
Public property | BusinessPhone2 | Gets the second business phone. (Inherited from ContactEntry.)
Public property | BusinessState | Gets the state of the business. (Inherited from ContactEntry.)
Public property | BusinessZipCode | Gets the business zip code. (Inherited from ContactEntry.)
Public property | Company | Gets the company. (Inherited from ContactEntry.)
Public property | ContactSources | Gets the contact's source(s). See ContactSource for further details. (Inherited from ContactEntry.)
Public property | Department | Gets the department. (Inherited from ContactEntry.)
Public property | DisplayName | Gets the directory contact display name. (Inherited from ContactEntry.)
Public property | EntryId | Gets the entry ID. A unique identifier for a directory contact instance. (Inherited from ContactEntry.)
Public property | Extension | Gets the extension. (Inherited from ContactEntry.)
Public property | ExtensionAsPhoneNumber | Gets the extension in Phone Number format. DirectoryPhoneNumber. (Inherited from ContactEntry.)
Public property | ExternalContactEntries | Gets the collection of ExternalContactEntry objects that contain additional information about this contact in relation to a system external to IC. (Inherited from ContactEntry.)
Public property | ExternalPresenceProviders | Gets the available external presence providers for this contact. (Inherited from ContactEntry.)
Public property | Fax | Gets the Fax. (Inherited from ContactEntry.)
Public property | FirstName | Gets the first name of the contact. (Inherited from ContactEntry.)
Public property | HomeAddress | Gets the home address. (Inherited from ContactEntry.)
Public property | HomeCity | Gets the home city. (Inherited from ContactEntry.)
Public property | HomeCountry | Gets the home country. (Inherited from ContactEntry.)
Public property | HomeEmail | Gets the home Email. (Inherited from ContactEntry.)
Public property | HomePhone | Gets the home telephone number. (Inherited from ContactEntry.)
Public property | HomePhone2 | Gets the second home phone. (Inherited from ContactEntry.)
Public property | HomeState | Gets the state of the home. (Inherited from ContactEntry.)
Public property | HomeZipCode | Gets the home zip code. (Inherited from ContactEntry.)
Public property | Index | Gets the location of this contact on a paged directory. (Inherited from ContactEntry.)
Public property | InteractionsAddresses | Gets the interactions addresses.
Public property | LastName | Gets the last name of the contact. (Inherited from ContactEntry.)
Public property | LyncSipAddress | Obsolete. Gets the Lync SIP Address for this contact. (Inherited from ContactEntry.)
Public property | MobilePhone | Gets the mobile phone. (Inherited from ContactEntry.)
Public property | Notes | Gets the notes. (Inherited from ContactEntry.)
Public property | OwnerId | Gets the owner. (Inherited from ContactEntry.)
Public property | Pager | Gets the pager. (Inherited from ContactEntry.)
Public property | PrimaryNumberDesignation | Gets the primary number designation. (Inherited from ContactEntry.)
Public property | Skills | Gets the Skills set for this contact. (Inherited from ContactEntry.)
Public property | StatusUri | Gets the Status Uri. (Inherited from ContactEntry.)
Public property | Title | Gets the title. (Inherited from ContactEntry.)
Public property | TrackerAttributes | Gets the tracker attributes.
Public property | TrackerData | Gets the tracker data. (Inherited from ContactEntry.)
Public property | UserId | Gets the user ID. (Inherited from ContactEntry.)
Public property | VoicemailLocation | Gets the Voicemail location. (Inherited from ContactEntry.)
Public property | Webpage | Gets the web page. (Inherited from ContactEntry.)
Public property | Workgroups | Gets the workgroups. (Inherited from ContactEntry.)

See Also

TrackerContactEntry Class
ININ.IceLib.Tracker Namespace


Addresses Property

[image]

IceLib Technical Reference
TrackerContactEntry..::..Addresses Property
TrackerContactEntry Class See Also Send Feedback
Gets the addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<IndividualAddress> Addresses { get; }
Visual Basic
Public ReadOnly Property Addresses As Collection(Of IndividualAddress)
    Get

Field Value

The addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerContactEntry Class
TrackerContactEntry Members
ININ.IceLib.Tracker Namespace


InteractionsAddresses Property

[image]

IceLib Technical Reference
TrackerContactEntry..::..InteractionsAddresses Property
TrackerContactEntry Class See Also Send Feedback
Gets the interactions addresses.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<IndividualInteractionAddress> InteractionsAddresses { get; }
Visual Basic
Public ReadOnly Property InteractionsAddresses As Collection(Of IndividualInteractionAddress)
    Get

Field Value

The interactions addresses.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerContactEntry Class
TrackerContactEntry Members
ININ.IceLib.Tracker Namespace


TrackerAttributes Property

[image]

IceLib Technical Reference
TrackerContactEntry..::..TrackerAttributes Property
TrackerContactEntry Class See Also Send Feedback
Gets the tracker attributes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<TrackerAttribute> TrackerAttributes { get; }
Visual Basic
Public ReadOnly Property TrackerAttributes As Collection(Of TrackerAttribute)
    Get

Field Value

The tracker attributes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerContactEntry Class
TrackerContactEntry Members
ININ.IceLib.Tracker Namespace


TrackerInteraction Class

[image]

IceLib Technical Reference
TrackerInteraction Class
Members See Also Send Feedback
Provides access to Tracker information for an interaction within the Interaction Center system.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerInteraction : Interaction
Visual Basic
Public Class TrackerInteraction _
    Inherits Interaction

Remarks

Calling properties on this object without a watch in place raises the NotCachedException.

Note
The asynchronous methods are preferred since the stop completion task can be lengthy.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..Interaction
ININ.IceLib.Tracker..::..TrackerInteraction

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Members
ININ.IceLib.Tracker Namespace


TrackerInteraction Members

[image] [image]

IceLib Technical Reference
TrackerInteraction Members
TrackerInteraction Class Constructors Methods Properties Events See Also Send Feedback

The TrackerInteraction type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerInteraction | Initializes a new instance of the TrackerInteraction class.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetMultiPartAccountCodeId | Sets the multi-part account code ID.
Public method | SetMultiPartAccountCodeIdAsync | Asynchronously Sets the multi-part account code ID.
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | IsTrackingDisabled | Gets a value indicating whether this instance is TrackingDisabled.
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | MultiPartAccountCode | Gets the multi-part account code.
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | PrivateReverseWhitepages | Gets the private reverse whitepages information.
Public property | PublicReverseWhitepages | Gets the public reverse whitepages information.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

TrackerInteraction Class
ININ.IceLib.Tracker Namespace


TrackerInteraction Constructor

[image]

IceLib Technical Reference
TrackerInteraction Constructor
TrackerInteraction Class See Also Send Feedback
Initializes a new instance of the TrackerInteraction class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerInteraction(
    InteractionsManager interactionsManager,
    InteractionId interactionId
)
Visual Basic
Public Sub New ( _
    interactionsManager As InteractionsManager, _
    interactionId As InteractionId _
)

Parameters

interactionsManager
Type: ININ.IceLib.Interactions..::..InteractionsManager
The interactions manager.
interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


TrackerInteraction Methods

[image] [image]

IceLib Technical Reference
TrackerInteraction Methods
TrackerInteraction Class See Also Send Feedback

The TrackerInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | Appends to the Notes. (Inherited from Interaction.)
Public method | AppendNoteAsync | Asynchronously appends to the Notes. (Inherited from Interaction.)
Public method | AppendStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | BlindTransfer(String) | Performs a blind transfer to the specified number given the number as a string. (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | Performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified number, given that number as a string. (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously performs a blind transfer to the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ChangeWatchedAttributes | Changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the Interaction are being watched. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | Coach | Changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | CoachAsync | Asynchronously changes the coaching state of the interaction. (Inherited from Interaction.)
Public method | ConsultTransfer | Performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | ConsultTransferAsync | Asynchronously performs a consult transfer with the specified interaction. (Inherited from Interaction.)
Public method | Disconnect | Disconnects this Interaction. (Inherited from Interaction.)
Public method | DisconnectAsync | Asynchronously disconnects this Interaction. (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | Gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | Asynchronously gets the value of an attribute as a Boolean. (Inherited from Interaction.)
Public method | GetDateTimeAttribute | Gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | Asynchronously gets the value of an attribute as a DateTime. (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | Gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | Asynchronously gets the value of an attribute as an Int32. (Inherited from Interaction.)
Public method | GetStringAttribute | Gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributeAsync | Asynchronously gets the value of an attribute as a String. (Inherited from Interaction.)
Public method | GetStringAttributes | Gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetStringAttributesAsync | Asynchronously gets the values of attributes, where each attribute value is returned as a String. (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | Gets the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | Gets the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | Gets the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | Gets the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | Gets the value of a watched attribute as a ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Hold | Places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | HoldAsync | Asynchronously places the interaction on hold or takes it off hold. (Inherited from Interaction.)
Public method | InitiateRecordingSnip | Changes the recording snippet state of the interaction. (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | Asynchronously changes the recording snip state of the interaction. (Inherited from Interaction.)
Public method | InitiateSecureInput | Initiates secure input which allows for confidential information (e.g., credit card number, expiration date, etc) to be securely provided. (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | Asynchronously initiates secure input. (Inherited from Interaction.)
Public method | IsValidCapability | Determines whether the interaction has the specified capabilities. (Inherited from Interaction.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from Interaction.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from Interaction.)
Public method | Join | Joins this Interaction in a conference. (Inherited from Interaction.)
Public method | JoinAsync | Asynchronously joins this Interaction in a conference. (Inherited from Interaction.)
Public method | Listen | Changes the listen state of the interaction. (Inherited from Interaction.)
Public method | ListenAsync | Asynchronously changes the listen state of the interaction. (Inherited from Interaction.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | Changes the mute state. (Inherited from Interaction.)
Public method | MuteAsync | Asynchronously changes the mute state. (Inherited from Interaction.)
Public method | Park(String) | Parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | Park(QueueId) | Parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given a string. (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously parks the Interaction on the specified target, given the QueueId of the target. (Inherited from Interaction.)
Public method | Pause | Changes the recording pause state. (Inherited from Interaction.)
Public method | PauseAsync | Asynchronously changes the recording pause state. (Inherited from Interaction.)
Public method | Pickup | Picks up this Interaction. (Inherited from Interaction.)
Public method | PickupAsync | Asynchronously picks up this Interaction. (Inherited from Interaction.)
Public method | Private | Changes the private state. (Inherited from Interaction.)
Public method | PrivateAsync | Asynchronously changes the private state. (Inherited from Interaction.)
Public method | Record | Changes the record state. (Inherited from Interaction.)
Public method | RecordAsync | Asynchronously changes the record state. (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. Sends a request for help. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. Asynchronously sends a request for help. (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. Changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. Asynchronously changes the secure recording pause state. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | Pauses or resumes a secure recording. Secure recordings are recordings started by Recorder, which are configured via Interaction Administrator. (Inherited from Interaction.)
Public method | SetAccountCodeId | Sets the Account Code ID. (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | Asynchronously sets the Account Code ID. (Inherited from Interaction.)
Public method | SetDateTimeAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetMultiPartAccountCodeId | Sets the multi-part account code ID.
Public method | SetMultiPartAccountCodeIdAsync | Asynchronously Sets the multi-part account code ID.
Public method | SetRemoteName | Sets the RemoteName. (Inherited from Interaction.)
Public method | SetRemoteNameAsync | Asynchronously sets the RemoteName. (Inherited from Interaction.)
Public method | SetStateDescription | Sets the StateDescription. (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | Asynchronously sets the StateDescription. (Inherited from Interaction.)
Public method | SetStringAttribute | Sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributeAsync | Asynchronously sets the value of a string attribute. (Inherited from Interaction.)
Public method | SetStringAttributes | Sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetStringAttributesAsync | Asynchronously sets the values of a set of string attributes. (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. Sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. Asynchronously sets the WrapUp Code ID. (Inherited from Interaction.)
Public method | StartWatching | Starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for this Interaction. (See InteractionAttributeName.) (Inherited from Interaction.)
Public method | StopWatching | Stops watching the Interaction. (Inherited from Interaction.)
Public method | StopWatchingAsync | Asynchronously stops watching the Interaction. (Inherited from Interaction.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Interaction.)
Public method | TransferToVoicemail(String) | Transfers to voicemail at the specified number, given a string. (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | Transfers to voicemail at the specified number, given a QueueId. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a string. (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | Asynchronously transfers to voicemail at the specified number, given the target as a QueueId. (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | Tries to get the value of a watched attribute as a Boolean. (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | Tries to get the value of a watched attribute as a DateTime. (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | Tries to get the value of a watched attribute as an Int32. (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | Tries to get the value of a watched attribute as a String. (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | Tries to get the value of a watched attribute as ReadOnlyCollection<(Of <(<'T>)>)> of String. (Inherited from Interaction.)
Public method | Voicemail | Sends the Interaction to voicemail. (Inherited from Interaction.)
Public method | VoicemailAsync | Asynchronously sends the Interaction to voicemail. (Inherited from Interaction.)

See Also

TrackerInteraction Class
ININ.IceLib.Tracker Namespace


SetMultiPartAccountCodeId Method

[image]

IceLib Technical Reference
TrackerInteraction..::..SetMultiPartAccountCodeId Method
TrackerInteraction Class See Also Send Feedback
Sets the multi-part account code ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMultiPartAccountCodeId(
    string multiPartAccountCodeId
)
Visual Basic
Public Sub SetMultiPartAccountCodeId ( _
    multiPartAccountCodeId As String _
)

Parameters

multiPartAccountCodeId
Type: System..::..String
The multi-part account code ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


SetMultiPartAccountCodeIdAsync Method

[image]

IceLib Technical Reference
TrackerInteraction..::..SetMultiPartAccountCodeIdAsync Method
TrackerInteraction Class See Also Send Feedback
Asynchronously Sets the multi-part account code ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetMultiPartAccountCodeIdAsync(
    string multiPartAccountCodeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetMultiPartAccountCodeIdAsync ( _
    multiPartAccountCodeId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

multiPartAccountCodeId
Type: System..::..String
The multi-part account code ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


TrackerInteraction Properties

[image] [image]

IceLib Technical Reference
TrackerInteraction Properties
TrackerInteraction Class See Also Send Feedback

The TrackerInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | Gets the Id of the account code. AccountCodeId is only available if the AccountCodeId attribute is being watched. (Inherited from Interaction.)
Public property | AlertSound | Gets the AlertSound. AlertSound is only available if the AlertSound attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | Gets the AssociatedProcessDisplayName. AssociatedProcessDisplayName is only available if the AssociatedProcessDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | Gets the AssociatedProcessInstanceId. AssociatedProcessInstanceId is only available if the AssociatedProcessInstanceId attribute is being watched. (Inherited from Interaction.)
Public property | CallIdKey | Gets the CallIdKey. CallIdKey is only available if the CallIdKey attribute is being watched. (Inherited from Interaction.)
Public property | CallType | Gets the CallType. CallType is only available if the CallType attribute is being watched. (Inherited from Interaction.)
Public property | Capabilities | Gets the capabilities of this interaction. The EffectiveStation comes into effect when determining the capabilities of this interaction. Capabilities are only available if the Capabilities attribute is being watched. (Inherited from Interaction.)
Public property | ClientMessage | Gets the ClientMessage. ClientMessage is only available if the ClientMessage attribute is being watched. (Inherited from Interaction.)
Public property | ConferenceId | Gets the ConferenceId. ConferenceId is only available if the ConferenceId attribute is being watched. (Inherited from Interaction.)
Public property | ConsultCallId | Gets ID of the ConsultTransfer, if this interaction is participating in a consult transfer. ConsultCallId is only available if the ConsultCallId attribute is being watched. (Inherited from Interaction.)
Public property | DeallocationSeconds | Gets the DeallocationSeconds. DeallocationSeconds is only available if the DeallocationSeconds attribute is being watched. (Inherited from Interaction.)
Public property | Direction | Gets the Direction. Direction is only available if the Direction attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectionTime | Gets the DisconnectionTime. DisconnectionTime is only available if the DisconnectionTime attribute is being watched. (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | Gets a value indicating whether to disconnect on ring no answer. DisconnectRingNoAnswer is only available if the DisconnectRingNoAnswer attribute is being watched. (Inherited from Interaction.)
Public property | Duration | Gets the duration of the Interaction as of the current time (using InitiationTime and DisconnectionTime). Duration is only available when InitiationTime, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | HasSnippetRecording | Gets a value indicating whether this instance has snippet recordings. (Inherited from Interaction.)
Public property | ImmediateAccess | Gets a value indicating whether to allow ImmediateAccess. ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | InitiationTime | Gets the InitiationTime. InitiationTime is only available if the InitiationTime attribute is being watched. (Inherited from Interaction.)
Public property | InteractionId | Gets the ID of the Interaction. (Inherited from Interaction.)
Public property | InteractionsManager | Gets the InteractionManager with which this Interaction is associated. (Inherited from Interaction.)
Public property | InteractionType | Gets the type of the interaction. InteractionType is only available if the InteractionType attribute is being watched. (Inherited from Interaction.)
Public property | IsConnected | Gets a value indicating whether the Interaction is in a connected state. IsConnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsDisconnected | Gets a value indicating whether the Interaction is in a disconnected state. IsDisconnected is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsHeld | Gets a value indicating whether this instance is Held. IsHeld is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | IsMonitored | Gets a value indicating whether this instance is being monitored by the session user. IsMonitored is only available if the Monitors and SupervisorMonitors attributes are being watched. (Inherited from Interaction.)
Public property | IsMuted | Gets a value indicating whether this instance is Muted. IsMuted is only available if the Muted attribute is being watched. (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | Gets a value indicating whether this instance is on the MyInteractions queue. IsOnMyInterationsQueue is only available if the UserQueueNames and StationQueueNames attributes are being watched. (Inherited from Interaction.)
Public property | IsPaused | Gets a value indicating whether this instance has a paused recorder for the session user. IsPaused is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsPrivate | Gets a value indicating whether this instance is Private. IsPrivate is only available if the Private attribute is being watched. (Inherited from Interaction.)
Public property | IsRecording | Gets a value indicating whether this instance is being recorded by the session user. IsRecording is only available if the Recorders and SupervisorRecorders attributes are being watched. (Inherited from Interaction.)
Public property | IsShared | Gets a value indicating whether this is a shared instance. (Inherited from Interaction.)
Public property | IsTrackingDisabled | Gets a value indicating whether this instance is TrackingDisabled.
Public property | Language | Gets the Language to use for the prompt. Language is only available if the Language attribute is being watched. (Inherited from Interaction.)
Public property | LastSegment | Gets the last segment on this interaction. LastSegment is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | Gets the last segment for the session user on this interaction. LastSegmentForCurrentUser is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | LineName | Gets the name of the line queue. LineName is only available if the LineQueueName attribute is being watched. (Inherited from Interaction.)
Public property | LocalAddress | Gets the address of the local party. LocalAddress is only available if the LocalAddress attribute is being watched. (Inherited from Interaction.)
Public property | LocalId | Gets the displayable address of local party. LocalId is only available if the LocalId attribute is being watched. (Inherited from Interaction.)
Public property | LocalName | Gets the user-friendly name of the local party. LocalName is only available if the LocalName attribute is being watched. (Inherited from Interaction.)
Public property | LocalPartyType | Gets the LocalPartyType of the local party. LocalPartyType is only available if the LocalPartyType attribute is being watched. (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | Gets the requested local security level. (See LocalSecurityLevelRequested). LocalSecurityLevelRequested is only available if the LocalSecurityLevelRequested attribute is being watched. (Inherited from Interaction.)
Public property | Log | Gets the Log. Log is only available if the Log attribute is being watched. (Inherited from Interaction.)
Public property | Monitors | Gets the Monitors. Monitors is only available if the Monitors attribute is being watched. (Inherited from Interaction.)
Public property | MonitorsCombinedCount | Gets the MonitorsCombinedCount. MonitorsCombinedCount is only available if the MonitorsCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | MonitorType | Gets the type of the monitor. MonitorType is only available if the MonitorType attribute is being watched. (Inherited from Interaction.)
Public property | MultiPartAccountCode | Gets the multi-part account code.
Public property | Notes | Gets the Notes. Notes is only available if the Notes attribute is being watched. (Inherited from Interaction.)
Public property | OrbitQueueName | Gets the unscoped orbit queue name. OrbitQueueName is only available if the OrbitQueueName attribute is being watched. (Inherited from Interaction.)
Public property | PopApplication | Gets the application that should be popped for the Interaction. PopApplication is only available if the PopApplication attribute is being watched. (Inherited from Interaction.)
Public property | PrivateReverseWhitepages | Gets the private reverse whitepages information.
Public property | PublicReverseWhitepages | Gets the public reverse whitepages information.
Public property | Recorders | Gets the Recorders. Recorders is only available if the Recorders attribute is being watched. (Inherited from Interaction.)
Public property | RecordersCombinedCount | Gets the RecordersCombinedCount. RecordersCombinedCount is only available if the RecordersCombinedCount attribute is being watched. (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | Gets the RelatedSnippetRecordings. RelatedSnippetRecordings is only available if the RelatedSnippetRecordings attribute is being watched. (Inherited from Interaction.)
Public property | RemoteAddress | Gets the RemoteAddress. RemoteAddress is only available if the RemoteAddress attribute is being watched. (Inherited from Interaction.)
Public property | RemoteDisplay | Gets a displayable identifier for an interaction. RemoteDisplay is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemoteId | Gets the remote party ID as a friendly display value. RemoteId is only available if the RemoteId attribute is being watched. (Inherited from Interaction.)
Public property | RemoteName | Gets the name of the remote party. RemoteName is only available if the RemoteName attribute is being watched. (Inherited from Interaction.)
Public property | RemotePartyType | Gets the RemotePartyType of the remote party. RemotePartyType is only available if the RemotePartyType attribute is being watched. (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | Gets the requested remote security level. (See RemoteSecurityLevelRequested). ImmediateAccess is only available if the ImmediateAccess attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelActual | Gets the actual security level. (See SecurityLevelActual). SecurityLevelActual is only available if the SecurityLevelActual attribute is being watched. (Inherited from Interaction.)
Public property | SecurityLevelViolation | Gets the reason for the security level violation. (See SecurityLevelViolation). SecurityLevelViolation is only available if the SecurityLevelViolation attribute is being watched. (Inherited from Interaction.)
Public property | Segments | Gets the collection of segments for this interaction. (See InteractionConnectionSegments). Segments is only available if the InteractionConnectionSegments attribute is being watched. (Inherited from Interaction.)
Public property | State | Gets the Interaction State. State is only available if the State attribute is being watched. (Inherited from Interaction.)
Public property | StateDescription | Gets the state display string. StateDescription is only available if the StateDescription attribute is being watched. (Inherited from Interaction.)
Public property | StationQueueNames | Gets the unscoped name(s) of the station queue(s). StationQueueNames is only available if the StationQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorMonitors | Gets the SupervisorMonitors. SupervisorMonitors is only available if the SupervisorMonitors attribute is being watched. (Inherited from Interaction.)
Public property | SupervisorRecorders | Gets the SupervisorRecorders. SupervisorRecorders is only available if the SupervisorRecorders attribute is being watched. (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | Gets the duration of the Interaction as of the time it joined a workgroup queue (using WorkgroupQueueTimestamp and DisconnectionTime). TimeInWorkgroupQueue is only available when WorkgroupQueueTimestamp, DisconnectionTime and State are being watched. (Inherited from Interaction.)
Public property | UserQueueNames | Gets the unscoped name(s) of the user queue(s). UserQueueNames is only available if the UserQueueNames attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | Gets the display name of the workgroup queue. WorkgroupQueueDisplayName is only available if the WorkgroupQueueDisplayName attribute is being watched. (Inherited from Interaction.)
Public property | WorkgroupQueueName | Gets the unscoped name of the workgroup queue. WorkgroupQueueName is only available if the WorkgroupQueueName attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpAssignments | Gets the wrap up assignments for this interaction. (See WrapUpAssignments). WrapUpAssignments is only available if the WrapUpAssignments attribute is being watched. (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. Gets the ID of the wrap up code. (Inherited from Interaction.)

See Also

TrackerInteraction Class
ININ.IceLib.Tracker Namespace


IsTrackingDisabled Property

[image]

IceLib Technical Reference
TrackerInteraction..::..IsTrackingDisabled Property
TrackerInteraction Class See Also Send Feedback
Gets a value indicating whether this instance is TrackingDisabled.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsTrackingDisabled { get; }
Visual Basic
Public ReadOnly Property IsTrackingDisabled As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance is muted; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


MultiPartAccountCode Property

[image]

IceLib Technical Reference
TrackerInteraction..::..MultiPartAccountCode Property
TrackerInteraction Class See Also Send Feedback
Gets the multi-part account code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string MultiPartAccountCode { get; }
Visual Basic
Public ReadOnly Property MultiPartAccountCode As String
    Get

Field Value

The multi-part account code.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


PrivateReverseWhitepages Property

[image]

IceLib Technical Reference
TrackerInteraction..::..PrivateReverseWhitepages Property
TrackerInteraction Class See Also Send Feedback
Gets the private reverse whitepages information.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReverseWhitepagesInfo> PrivateReverseWhitepages { get; }
Visual Basic
Public ReadOnly Property PrivateReverseWhitepages As ReadOnlyCollection(Of ReverseWhitepagesInfo)
    Get

Field Value

The private reverse whitepages information.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


PublicReverseWhitepages Property

[image]

IceLib Technical Reference
TrackerInteraction..::..PublicReverseWhitepages Property
TrackerInteraction Class See Also Send Feedback
Gets the public reverse whitepages information.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<ReverseWhitepagesInfo> PublicReverseWhitepages { get; }
Visual Basic
Public ReadOnly Property PublicReverseWhitepages As ReadOnlyCollection(Of ReverseWhitepagesInfo)
    Get

Field Value

The public reverse whitepages information.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteraction Class
TrackerInteraction Members
ININ.IceLib.Tracker Namespace


TrackerInteraction Events

[image] [image]

IceLib Technical Reference
TrackerInteraction Events
TrackerInteraction Class See Also Send Feedback

The TrackerInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Occurs when an Interaction's watched attributes change. (Inherited from Interaction.)
Public event | Deallocated | Occurs when an Interaction is deallocated. (Inherited from Interaction.)
Public event | LostRights | Occurs when the User loses rights for the Interaction. (Inherited from Interaction.)
Public event | Morphed | Occurs when an Interaction is replaced by another (e.g. during a Consult operation). (Inherited from Interaction.)
Public event | RecordingSnippetCreated | Occurs when a recording snippet is created for an interaction. (Inherited from Interaction.)

See Also

TrackerInteraction Class
ININ.IceLib.Tracker Namespace


TrackerInteractionAttributeName Class

[image]

IceLib Technical Reference
TrackerInteractionAttributeName Class
Members See Also Send Feedback
Specifies attribute names that can be used with TrackerInteractions.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class TrackerInteractionAttributeName : InteractionAttributeName
Visual Basic
Public MustInherit Class TrackerInteractionAttributeName _
    Inherits InteractionAttributeName

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Interactions..::..InteractionAttributeName
ININ.IceLib.Tracker..::..TrackerInteractionAttributeName

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteractionAttributeName Members
ININ.IceLib.Tracker Namespace


TrackerInteractionAttributeName Members

[image] [image]

IceLib Technical Reference
TrackerInteractionAttributeName Members
TrackerInteractionAttributeName Class Methods Fields See Also Send Feedback

The TrackerInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MultiPartAccountCode | The multi-part account code.
PrivateReverseWhitepages | The private reverse whitepages information.
PublicReverseWhitepages | The public reverse whitepages information.
TrackingDisabled | The tracking state of this Interaction.

See Also

TrackerInteractionAttributeName Class
ININ.IceLib.Tracker Namespace


TrackerInteractionAttributeName Fields

[image] [image]

IceLib Technical Reference
TrackerInteractionAttributeName Fields
TrackerInteractionAttributeName Class See Also Send Feedback

The TrackerInteractionAttributeName type exposes the following members.

Fields

Name | Description
MultiPartAccountCode | The multi-part account code.
PrivateReverseWhitepages | The private reverse whitepages information.
PublicReverseWhitepages | The public reverse whitepages information.
TrackingDisabled | The tracking state of this Interaction.

See Also

TrackerInteractionAttributeName Class
ININ.IceLib.Tracker Namespace


MultiPartAccountCode Field

[image]

IceLib Technical Reference
TrackerInteractionAttributeName..::..MultiPartAccountCode Field
TrackerInteractionAttributeName Class See Also Send Feedback
The multi-part account code.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string MultiPartAccountCode
Visual Basic
Public Shared ReadOnly MultiPartAccountCode As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteractionAttributeName Class
TrackerInteractionAttributeName Members
ININ.IceLib.Tracker Namespace


PrivateReverseWhitepages Field

[image]

IceLib Technical Reference
TrackerInteractionAttributeName..::..PrivateReverseWhitepages Field
TrackerInteractionAttributeName Class See Also Send Feedback
The private reverse whitepages information.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PrivateReverseWhitepages
Visual Basic
Public Shared ReadOnly PrivateReverseWhitepages As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteractionAttributeName Class
TrackerInteractionAttributeName Members
ININ.IceLib.Tracker Namespace


PublicReverseWhitepages Field

[image]

IceLib Technical Reference
TrackerInteractionAttributeName..::..PublicReverseWhitepages Field
TrackerInteractionAttributeName Class See Also Send Feedback
The public reverse whitepages information.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string PublicReverseWhitepages
Visual Basic
Public Shared ReadOnly PublicReverseWhitepages As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteractionAttributeName Class
TrackerInteractionAttributeName Members
ININ.IceLib.Tracker Namespace


TrackingDisabled Field

[image]

IceLib Technical Reference
TrackerInteractionAttributeName..::..TrackingDisabled Field
TrackerInteractionAttributeName Class See Also Send Feedback
The tracking state of this Interaction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string TrackingDisabled
Visual Basic
Public Shared ReadOnly TrackingDisabled As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerInteractionAttributeName Class
TrackerInteractionAttributeName Members
ININ.IceLib.Tracker Namespace


TrackerInteractionAttributeName Methods

[image] [image]

IceLib Technical Reference
TrackerInteractionAttributeName Methods
TrackerInteractionAttributeName Class See Also Send Feedback

The TrackerInteractionAttributeName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerInteractionAttributeName Class
ININ.IceLib.Tracker Namespace


TrackerSearch Class

[image]

IceLib Technical Reference
TrackerSearch Class
Members See Also Send Feedback
Contains methods necessary to perform typical Tracker search-related operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerSearch
Visual Basic
Public Class TrackerSearch

Remarks

The TrackerSearch type is instantiated like the two other main Tracker types (TrackerAdmin and TrackerUser), by passing in a valid Session object. Use the TrackerSearch type when you want to perform searches on the Tracker database.

The current user must have a valid Tracker Access license or an IceLibLicenseException will be thrown when any methods of this class are called.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibLicenseException | A required license is not available.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..TrackerSearch

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Members
ININ.IceLib.Tracker Namespace


TrackerSearch Members

[image] [image]

IceLib Technical Reference
TrackerSearch Members
TrackerSearch Class Constructors Methods Properties See Also Send Feedback

The TrackerSearch type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerSearch | Initializes a new instance of the TrackerSearch class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveInteraction | Associates reverse whitepages information with an Interaction.
Public method | ResolveInteractionAsync | Asynchronously associates reverse whitepages information with an Interaction.
Public method | ReverseInteractionAddressLookup | Performs a reverse interaction address lookup.
Public method | ReverseInteractionAddressLookupAsync | Asynchronously performs a reverse interaction address lookup.
Public method | SearchForResolutionCandidates | Searches the Tracker database for Individuals that are resolution candidates.
Public method | SearchForResolutionCandidatesAsync | Asynchronously searches the Tracker database for Individuals that are resolution candidates.
Public method | SearchIndividuals | Searches the Tracker database for Individuals using the specified filter criteria.
Public method | SearchIndividualsAsync | Asynchronously searches the Tracker database for Individuals using the specified filter criteria.
Public method | SearchInteractions | Searches the Tracker database for interactions that match the filter criteria.
Public method | SearchInteractionsAsync | Asynchronously searches the Tracker database for interactions that match the filter criteria.
Public method | SearchLocations | Searches the Tracker database for Locations that match the filter criteria.
Public method | SearchLocationsAsync | Asynchronously searches the Tracker database for Locations that match the filter criteria.
Public method | SearchOrganizations | Searches the Tracker database for Organizations that match the filter criteria.
Public method | SearchOrganizationsAsync | Asynchronously searches the Tracker database for Organizations that match the filter criteria.
 | ToDirectionType | Converts a long value to a direction type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TransactionClient | Gets the TransactionClient.

See Also

TrackerSearch Class
ININ.IceLib.Tracker Namespace


TrackerSearch Constructor

[image]

IceLib Technical Reference
TrackerSearch Constructor
TrackerSearch Class See Also Send Feedback
Initializes a new instance of the TrackerSearch class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerSearch(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


TrackerSearch Methods

[image] [image]

IceLib Technical Reference
TrackerSearch Methods
TrackerSearch Class See Also Send Feedback

The TrackerSearch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveInteraction | Associates reverse whitepages information with an Interaction.
Public method | ResolveInteractionAsync | Asynchronously associates reverse whitepages information with an Interaction.
Public method | ReverseInteractionAddressLookup | Performs a reverse interaction address lookup.
Public method | ReverseInteractionAddressLookupAsync | Asynchronously performs a reverse interaction address lookup.
Public method | SearchForResolutionCandidates | Searches the Tracker database for Individuals that are resolution candidates.
Public method | SearchForResolutionCandidatesAsync | Asynchronously searches the Tracker database for Individuals that are resolution candidates.
Public method | SearchIndividuals | Searches the Tracker database for Individuals using the specified filter criteria.
Public method | SearchIndividualsAsync | Asynchronously searches the Tracker database for Individuals using the specified filter criteria.
Public method | SearchInteractions | Searches the Tracker database for interactions that match the filter criteria.
Public method | SearchInteractionsAsync | Asynchronously searches the Tracker database for interactions that match the filter criteria.
Public method | SearchLocations | Searches the Tracker database for Locations that match the filter criteria.
Public method | SearchLocationsAsync | Asynchronously searches the Tracker database for Locations that match the filter criteria.
Public method | SearchOrganizations | Searches the Tracker database for Organizations that match the filter criteria.
Public method | SearchOrganizationsAsync | Asynchronously searches the Tracker database for Organizations that match the filter criteria.
 | ToDirectionType | Converts a long value to a direction type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerSearch Class
ININ.IceLib.Tracker Namespace


ResolveInteraction Method

[image]

IceLib Technical Reference
TrackerSearch..::..ResolveInteraction Method
TrackerSearch Class See Also Send Feedback
Associates reverse whitepages information with an Interaction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ResolveInteraction(
    InteractionId interactionId,
    ReverseWhitepagesInfo reverseWhitepagesInfo,
    bool isDefinitive
)
Visual Basic
Public Sub ResolveInteraction ( _
    interactionId As InteractionId, _
    reverseWhitepagesInfo As ReverseWhitepagesInfo, _
    isDefinitive As Boolean _
)

Parameters

interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.
reverseWhitepagesInfo
Type: ININ.IceLib.Tracker..::..ReverseWhitepagesInfo
The reverse whitepages information.
isDefinitive
Type: System..::..Boolean
if set to trueTruetruetrue (True in Visual Basic) is definitive.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


ResolveInteractionAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..ResolveInteractionAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously associates reverse whitepages information with an Interaction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ResolveInteractionAsync(
    InteractionId interactionId,
    ReverseWhitepagesInfo reverseWhitepagesInfo,
    bool isDefinitive,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ResolveInteractionAsync ( _
    interactionId As InteractionId, _
    reverseWhitepagesInfo As ReverseWhitepagesInfo, _
    isDefinitive As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactionId
Type: ININ.IceLib.Interactions..::..InteractionId
The interaction ID.
reverseWhitepagesInfo
Type: ININ.IceLib.Tracker..::..ReverseWhitepagesInfo
The reverse whitepages information.
isDefinitive
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) is definitive.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookup Method

[image]

IceLib Technical Reference
TrackerSearch..::..ReverseInteractionAddressLookup Method
TrackerSearch Class See Also Send Feedback
Performs a reverse interaction address lookup.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<ReverseInteractionAddressLookupInformation> ReverseInteractionAddressLookup(
    string value,
    InteractionType interactionType,
    string ICUserId
)
Visual Basic
Public Function ReverseInteractionAddressLookup ( _
    value As String, _
    interactionType As InteractionType, _
    ICUserId As String _
) As Collection(Of ReverseInteractionAddressLookupInformation)

Parameters

value
Type: System..::..String
One of the following: The Value of the IndividualInteractionAddress. The Value of the LocationInteractionAddress. Or the Value of the OrganizationInteractionAddress. This represents the text to search for.
interactionType
Type: ININ.IceLib.Tracker..::..InteractionType
The InteractionType to search.
ICUserId
Type: System..::..String
The IC user ID.

Return Value

A collection of ReverseInteractionAddressLookupInformation objects containing the results of the search.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


ReverseInteractionAddressLookupAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..ReverseInteractionAddressLookupAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously performs a reverse interaction address lookup.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ReverseInteractionAddressLookupAsync(
    string value,
    InteractionType interactionType,
    string ICUserId,
    EventHandler<QueryCollectionResultCompletedEventArgs<ReverseInteractionAddressLookupInformation>> completedCallback,
    Object userState
)
Visual Basic
Public Sub ReverseInteractionAddressLookupAsync ( _
    value As String, _
    interactionType As InteractionType, _
    ICUserId As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of ReverseInteractionAddressLookupInformation)), _
    userState As Object _
)

Parameters

value
Type: System..::..String
One of the following: The Value of the IndividualInteractionAddress. The Value of the LocationInteractionAddress. Or the Value of the OrganizationInteractionAddress. This represents the text to search for.
interactionType
Type: ININ.IceLib.Tracker..::..InteractionType
The InteractionType to search.
ICUserId
Type: System..::..String
The IC user ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' ReverseInteractionAddressLookupInformation >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchForResolutionCandidates Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchForResolutionCandidates Method
TrackerSearch Class See Also Send Feedback
Searches the Tracker database for Individuals that are resolution candidates.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<ReverseWhitepagesInfo> SearchForResolutionCandidates(
    string interactionAddress,
    InteractionType interactionType,
    string firstName,
    string lastName,
    string organizationId,
    string organizationName,
    string locationId,
    string locationName
)
Visual Basic
Public Function SearchForResolutionCandidates ( _
    interactionAddress As String, _
    interactionType As InteractionType, _
    firstName As String, _
    lastName As String, _
    organizationId As String, _
    organizationName As String, _
    locationId As String, _
    locationName As String _
) As Collection(Of ReverseWhitepagesInfo)

Parameters

interactionAddress
Type: System..::..String
The Value of the IndividualInteractionAddress.
interactionType
Type: ININ.IceLib.Tracker..::..InteractionType
The InteractionType to search.
firstName
Type: System..::..String
First name of the Individual.
lastName
Type: System..::..String
Last name of the Individual.
organizationId
Type: System..::..String
The ID of the Organization.
organizationName
Type: System..::..String
Name of the Organization.
locationId
Type: System..::..String
The ID of the Location.
locationName
Type: System..::..String
Name of the Location.

Return Value

The collection of whitepages info.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchForResolutionCandidatesAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchForResolutionCandidatesAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously searches the Tracker database for Individuals that are resolution candidates.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SearchForResolutionCandidatesAsync(
    string interactionAddress,
    InteractionType interactionType,
    string firstName,
    string lastName,
    string organizationId,
    string organizationName,
    string locationId,
    string locationName,
    EventHandler<SearchForResolutionCandidatesCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SearchForResolutionCandidatesAsync ( _
    interactionAddress As String, _
    interactionType As InteractionType, _
    firstName As String, _
    lastName As String, _
    organizationId As String, _
    organizationName As String, _
    locationId As String, _
    locationName As String, _
    completedCallback As EventHandler(Of SearchForResolutionCandidatesCompletedEventArgs), _
    userState As Object _
)

Parameters

interactionAddress
Type: System..::..String
The Value of the IndividualInteractionAddress.
interactionType
Type: ININ.IceLib.Tracker..::..InteractionType
The InteractionType to search.
firstName
Type: System..::..String
First name of the Individual.
lastName
Type: System..::..String
Last name of the Individual.
organizationId
Type: System..::..String
The ID of the Organization.
organizationName
Type: System..::..String
Name of the Organization.
locationId
Type: System..::..String
The ID of the Location.
locationName
Type: System..::..String
Name of the Location.
completedCallback
Type: System..::..EventHandler<(Of <(<' SearchForResolutionCandidatesCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchIndividuals Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchIndividuals Method
TrackerSearch Class See Also Send Feedback
Searches the Tracker database for Individuals using the specified filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<IndividualView> SearchIndividuals(
    SearchIndividualsFilter filter
)
Visual Basic
Public Function SearchIndividuals ( _
    filter As SearchIndividualsFilter _
) As Collection(Of IndividualView)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchIndividualsFilter
The search filter in the form of a SearchIndividualsFilter object.

Return Value

A collection of IndividualViews containing one IndividualView for each Individual that matches the filter criteria.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchIndividualsAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchIndividualsAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously searches the Tracker database for Individuals using the specified filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SearchIndividualsAsync(
    SearchIndividualsFilter filter,
    EventHandler<QueryCollectionResultCompletedEventArgs<IndividualView>> completedCallback,
    Object userState
)
Visual Basic
Public Sub SearchIndividualsAsync ( _
    filter As SearchIndividualsFilter, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of IndividualView)), _
    userState As Object _
)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchIndividualsFilter
The search filter in the form of a SearchIndividualsFilter object.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' IndividualView >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchInteractions Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchInteractions Method
TrackerSearch Class See Also Send Feedback
Searches the Tracker database for interactions that match the filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<InteractionView> SearchInteractions(
    SearchInteractionsFilter filter
)
Visual Basic
Public Function SearchInteractions ( _
    filter As SearchInteractionsFilter _
) As Collection(Of InteractionView)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchInteractionsFilter
The filter.

Return Value

A collection of InteractionViews containing one InteractionView for each interaction that matches the filter criteria.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchInteractionsAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchInteractionsAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously searches the Tracker database for interactions that match the filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SearchInteractionsAsync(
    SearchInteractionsFilter filter,
    EventHandler<QueryCollectionResultCompletedEventArgs<InteractionView>> completedCallback,
    Object userState
)
Visual Basic
Public Sub SearchInteractionsAsync ( _
    filter As SearchInteractionsFilter, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of InteractionView)), _
    userState As Object _
)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchInteractionsFilter
The filter.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' InteractionView >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchLocations Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchLocations Method
TrackerSearch Class See Also Send Feedback
Searches the Tracker database for Locations that match the filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<LocationView> SearchLocations(
    SearchLocationsFilter filter
)
Visual Basic
Public Function SearchLocations ( _
    filter As SearchLocationsFilter _
) As Collection(Of LocationView)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchLocationsFilter
The filter.

Return Value

A collection of LocationView containing one LocationView for each Location that matches the filter criteria.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchLocationsAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchLocationsAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously searches the Tracker database for Locations that match the filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SearchLocationsAsync(
    SearchLocationsFilter filter,
    EventHandler<QueryCollectionResultCompletedEventArgs<LocationView>> completedCallback,
    Object userState
)
Visual Basic
Public Sub SearchLocationsAsync ( _
    filter As SearchLocationsFilter, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of LocationView)), _
    userState As Object _
)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchLocationsFilter
The filter.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' LocationView >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchOrganizations Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchOrganizations Method
TrackerSearch Class See Also Send Feedback
Searches the Tracker database for Organizations that match the filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<OrganizationView> SearchOrganizations(
    SearchOrganizationsFilter filter
)
Visual Basic
Public Function SearchOrganizations ( _
    filter As SearchOrganizationsFilter _
) As Collection(Of OrganizationView)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchOrganizationsFilter
The filter.

Return Value

A collection of OrganizationView containing one OrganizationView for each Organization that matches the filter criteria.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


SearchOrganizationsAsync Method

[image]

IceLib Technical Reference
TrackerSearch..::..SearchOrganizationsAsync Method
TrackerSearch Class See Also Send Feedback
Asynchronously searches the Tracker database for Organizations that match the filter criteria.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SearchOrganizationsAsync(
    SearchOrganizationsFilter filter,
    EventHandler<QueryCollectionResultCompletedEventArgs<OrganizationView>> completedCallback,
    Object userState
)
Visual Basic
Public Sub SearchOrganizationsAsync ( _
    filter As SearchOrganizationsFilter, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of OrganizationView)), _
    userState As Object _
)

Parameters

filter
Type: ININ.IceLib.Tracker..::..SearchOrganizationsFilter
The filter.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' OrganizationView >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


ToDirectionType Method

[image]

IceLib Technical Reference
TrackerSearch..::..ToDirectionType Method
TrackerSearch Class See Also Send Feedback
Converts a long value to a direction type.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static DirectionType ToDirectionType(
    long direction
)
Visual Basic
Public Shared Function ToDirectionType ( _
    direction As Long _
) As DirectionType

Parameters

direction
Type: System..::..Int64
The direction value.

Return Value

The direction type.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


TrackerSearch Properties

[image] [image]

IceLib Technical Reference
TrackerSearch Properties
TrackerSearch Class See Also Send Feedback

The TrackerSearch type exposes the following members.

Properties

 | Name | Description
Public property | TransactionClient | Gets the TransactionClient.

See Also

TrackerSearch Class
ININ.IceLib.Tracker Namespace


TransactionClient Property

[image]

IceLib Technical Reference
TrackerSearch..::..TransactionClient Property
TrackerSearch Class See Also Send Feedback
Gets the TransactionClient.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionClient TransactionClient { get; }
Visual Basic
Public ReadOnly Property TransactionClient As TransactionClient
    Get

Field Value

The TransactionClient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerSearch Class
TrackerSearch Members
ININ.IceLib.Tracker Namespace


TrackerUser Class

[image]

IceLib Technical Reference
TrackerUser Class
Members See Also Send Feedback
Contains methods necessary to perform typical Tracker user related operations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class TrackerUser
Visual Basic
Public Class TrackerUser

Remarks

The TrackerUser type is instantiated like the two other main Tracker types (TrackerAdmin and TrackerSearch), by passing in a valid Session object. Use the TrackerUser type when you want to perform Tracker tasks such as getting the details of a Tracker Individual, creating a new Organization (not to be confused with the admin task of creating a new OrganizationType), deleting an annotation, etc.

The current user must have a valid Tracker Access license or an IceLibLicenseException will be thrown when any methods of this class are called.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..TrackerUser

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Members
ININ.IceLib.Tracker Namespace


TrackerUser Members

[image] [image]

IceLib Technical Reference
TrackerUser Members
TrackerUser Class Constructors Methods Properties See Also Send Feedback

The TrackerUser type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerUser | Initializes a new instance of the TrackerUser class.

Methods

 | Name | Description
Public method | AddAnnotation | Adds the Annotation.
Public method | AddAnnotationAsync | Asynchronously adds the Annotation.
Public method | AddIndividual | Adds the Individual.
Public method | AddIndividualAddress | Adds the IndividualAddress.
Public method | AddIndividualAddressAsync | Asynchronously adds the IndividualAddress.
Public method | AddIndividualAsync | Asynchronously adds the Individual.
Public method | AddIndividualInteractionAddress | Adds the IndividualInteractionAddress.
Public method | AddIndividualInteractionAddressAsync | Asynchronously adds the IndividualInteractionAddress.
Public method | AddLocation | Adds the Location.
Public method | AddLocationAddress | Adds the LocationAddress.
Public method | AddLocationAddressAsync | Asynchronously adds the LocationAddress.
Public method | AddLocationAsync | Asynchronously adds the Location.
Public method | AddLocationInteractionAddress | Adds the LocationInteractionAddress.
Public method | AddLocationInteractionAddressAsync | Asynchronously adds the LocationInteractionAddress.
Public method | AddOrganization | Adds the Organization.
Public method | AddOrganizationAddress | Adds the OrganizationAddress.
Public method | AddOrganizationAddressAsync | Asynchronously adds the OrganizationAddress.
Public method | AddOrganizationAsync | Asynchronously adds the Organization.
Public method | AddOrganizationInteractionAddress | Adds the OrganizationInteractionAddress.
Public method | AddOrganizationInteractionAddressAsync | Asynchronously adds the OrganizationInteractionAddress.
Public method | AddUpdateIndividualTrackerAttribute | Adds a TrackerAttribute for an Individual. If the TrackerAttribute exists for this Individual, it is updated. Otherwise it is added.
Public method | AddUpdateIndividualTrackerAttributeAsync | Asynchronously adds a TrackerAttribute for an Individual. If the TrackerAttribute exists, then it is updated, otherwise it is added.
Public method | AddUpdateInteractionTrackerAttribute | Adds or updates a TrackerAttribute for an interaction. If the TrackerAttribute exists for this interaction, it is updated. Otherwise it is added.
Public method | AddUpdateInteractionTrackerAttributeAsync | Asynchronously adds or updates a TrackerAttribute for an interaction. If the TrackerAttribute exists for this interaction, it is updated. Otherwise it is added.
Public method | AddUpdateLocationTrackerAttribute | Adds or updates a TrackerAttribute for a Location. If the TrackerAttribute exists Location, it is updated. Otherwise it is added.
Public method | AddUpdateLocationTrackerAttributeAsync | Asynchronously adds or updates a TrackerAttribute for a Location. If the TrackerAttribute exists for this Location, it is updated. Otherwise it is added.
Public method | AddUpdateOrganizationTrackerAttribute | Adds a TrackerAttribute for an Organization. If the TrackerAttribute exists for this Organization, it is updated. Otherwise it is added.
Public method | AddUpdateOrganizationTrackerAttributeAsync | Asynchronously adds a TrackerAttribute for an Organization. If the TrackerAttribute exists for this Organization, it is updated. Otherwise it is added.
Public method | CanViewInteraction | Determines whether the specified interaction can be viewed by the current Individual.
Public method | CanViewInteractionAsync | Asynchronously determines whether the specified interaction can be viewed by the current Individual.
Public method | DeleteAnnotation | Deletes the Annotation from the Tracker database.
Public method | DeleteAnnotationAsync | Asynchronously deletes the Annotation from the Tracker database.
Public method | DeleteIndividual | Deletes the Individual from the Tracker database.
Public method | DeleteIndividualAddress | Deletes the IndividualAddress from the Tracker database.
Public method | DeleteIndividualAddressAsync | Asynchronously deletes the IndividualAddress from the Tracker database.
Public method | DeleteIndividualAsync | Asynchronously deletes the Individual from the Tracker database.
Public method | DeleteIndividualInteractionAddress | Deletes an IndividualInteractionAddress from the Tracker database.
Public method | DeleteIndividualInteractionAddressAsync | Asynchronously deletes an IndividualInteractionAddress from the Tracker database.
Public method | DeleteIndividualTrackerAttribute | Deletes the Individual TrackerAttribute from the Tracker database.
Public method | DeleteIndividualTrackerAttributeAsync | Asynchronously deletes the Individual TrackerAttribute from the Tracker database.
Public method | DeleteInteractionTrackerAttribute | Deletes the interaction TrackerAttribute from the Tracker database.
Public method | DeleteInteractionTrackerAttributeAsync | Asynchronously deletes the interaction TrackerAttribute from the Tracker database.
Public method | DeleteLocation | Deletes the Location from the Tracker database.
Public method | DeleteLocationAddress | Deletes the LocationAddress from the Tracker database.
Public method | DeleteLocationAddressAsync | Asynchronously deletes the LocationAddress from the Tracker database.
Public method | DeleteLocationAsync | Asynchronously deletes the Location from the Tracker database.
Public method | DeleteLocationInteractionAddress | Deletes the LocationInteractionAddress from the Tracker database.
Public method | DeleteLocationInteractionAddressAsync | Asynchronously deletes the LocationInteractionAddress from the Tracker database.
Public method | DeleteLocationTrackerAttribute | Deletes the Location TrackerAttribute from the Tracker database.
Public method | DeleteLocationTrackerAttributeAsync | Asynchronously deletes the Location TrackerAttribute from the Tracker database.
Public method | DeleteOrganization | Deletes the Organization from the Tracker database.
Public method | DeleteOrganizationAddress | Deletes the OrganizationAddress from the Tracker database.
Public method | DeleteOrganizationAddressAsync | Asynchronously deletes the OrganizationAddress from the Tracker database.
Public method | DeleteOrganizationAsync | Asynchronously deletes the Organization from the Tracker database.
Public method | DeleteOrganizationInteractionAddress | Deletes the OrganizationInteractionAddress from the Tracker database.
Public method | DeleteOrganizationInteractionAddressAsync | Asynchronously deletes the OrganizationInteractionAddress from the Tracker database.
Public method | DeleteOrganizationTrackerAttribute | Deletes the OrganizationAddress from the Tracker database.
Public method | DeleteOrganizationTrackerAttributeAsync | Asynchronously deletes the Organization TrackerAttribute from the Tracker database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllMultipartAccountCodes | Gets all MultipartAccountCodes.
Public method | GetAllMultipartAccountCodesAsync | Asynchronously gets all MultipartAccountCodes.
Public method | GetCurrentSegmentOrganizationIndividual | Gets the current segment information for an interaction.
Public method | GetCurrentSegmentOrganizationIndividualAsync | Asynchronously gets the current segment information for an interaction.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetICUserIndividualInformation | Gets the ICUserIndividualInformation for an Individual.
Public method | GetICUserIndividualInformationAsync | Asynchronously gets the ICUserIndividualInformation.
Public method | GetIndividualDetails | Gets the IndividualDetails.
Public method | GetIndividualDetailsAsync | Asynchronously gets the IndividualDetails.
Public method | GetIndividualMultipartAccountCodeMRUList | Gets the most recently used Multipart account codes for an Individual..
Public method | GetIndividualMultipartAccountCodeMRUListAsync | Asynchronously gets the most recently used Multipart account codes for an Individual..
Public method | GetIndividualMultipartAccountCodes | Gets all Multipart account codes for an Individual..
Public method | GetIndividualMultipartAccountCodesAsync | Asynchronously gets all Multipart account codes for an Individual..
Public method | GetInheritedIndividualAddress | Gets the inherited IndividualAddress.
Public method | GetInheritedIndividualAddressAsync | Asynchronously gets the inherited IndividualAddress.
Public method | GetInheritedIndividualInteractionAddress | Gets the inherited IndividualInteractionAddress.
Public method | GetInheritedIndividualInteractionAddressAsync | Asynchronously gets the inherited IndividualInteractionAddress.
Public method | GetInheritedLocationAddress | Gets the inherited LocationAddress.
Public method | GetInheritedLocationAddressAsync | Asynchronously gets the inherited LocationAddress.
Public method | GetInheritedLocationInteractionAddress | Gets the inherited LocationInteractionAddress.
Public method | GetInheritedLocationInteractionAddressAsync | Asynchronously gets the inherited LocationInteractionAddress.
Public method | GetInteractionDetails | Gets the interaction details.
Public method | GetInteractionDetailsAsync | Asynchronously gets the interaction details.
Public method | GetLocationDetails | Gets the LocationDetails details.
Public method | GetLocationDetailsAsync | Asynchronously gets the Location details.
Public method | GetLocationNamesByName | Gets the LocationNames by name.
Public method | GetLocationNamesByNameAsync | Asynchronously gets the LocationNames by name.
Public method | GetLocationNamesByOrganizationId | Gets the LocationNames by Organization ID.
Public method | GetLocationNamesByOrganizationIdAsync | Asynchronously gets the Location names by Organization ID.
Public method | GetOrganizationById | Gets the Organization by ID.
Public method | GetOrganizationByIdAsync | Asynchronously gets the Organization by ID.
Public method | GetOrganizationDetails | Gets the OrganizationDetails.
Public method | GetOrganizationDetailsAsync | Asynchronously gets the OrganizationDetails.
Public method | GetOrganizationNamesByName | Gets the Organization names.
Public method | GetOrganizationNamesByNameAsync | Asynchronously gets the Organization names.
Public method | GetPossibleDuplicateIndividual | Gets the possible duplicate Individual.
Public method | GetPossibleDuplicateIndividualAsync | Asynchronously gets the possible duplicate Individual.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsersCanViewInteractionOn | Gets the ICUserIds that can view interactions for the given Location and Organization.
Public method | GetUsersCanViewInteractionOnAsync | Asynchronously gets the ICUserIds that can view interactions for the given Location and Organization.
Public method | ICUserModified | Marks an IC user as modified.
Public method | ICUserModifiedAsync | Asynchronously marks an IC user as modified.
Public method | IsUnknownOrSystemIndividual | Determines whether the specific Individual is unknown or a system Individual.
Public method | IsUnknownOrSystemIndividualAsync | Asynchronously determines whether the specific Individual is unknown or a system Individual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetIndividualImages | Sets the image file for all IC users.
Public method | SetIndividualImagesAsync | Asynchronously sets the image file for all IC users.
Public method | SetIndividualUrls | Sets the individual URLs.
Public method | SetIndividualUrlsAsync | Asynchronously sets individual URLs.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAnnotation | Updates the Annotation.
Public method | UpdateAnnotationAsync | Asynchronously updates the Annotation.
Public method | UpdateApplicationIncidentId | Updates the application incident ID.
Public method | UpdateApplicationIncidentIdAsync | Asynchronously updates the application incident ID.
Public method | UpdateIndividual | Updates the Individual.
Public method | UpdateIndividualAddress | Updates the IndividualAddress.
Public method | UpdateIndividualAddressAsync | Asynchronously updates the IndividualAddress.
Public method | UpdateIndividualAsync | Asynchronously updates the Individual.
Public method | UpdateIndividualInteractionAddress | Updates the IndividualInteractionAddress.
Public method | UpdateIndividualInteractionAddressAsync | Asynchronously updates the IndividualInteractionAddress.
Public method | UpdateLocation | Updates the Location.
Public method | UpdateLocationAddress | Updates the LocationAddress.
Public method | UpdateLocationAddressAsync | Asynchronously updates the LocationAddress.
Public method | UpdateLocationAsync | Asynchronously updates the Location.
Public method | UpdateLocationInteractionAddress | Updates the LocationInteractionAddress.
Public method | UpdateLocationInteractionAddressAsync | Asynchronously updates the LocationInteractionAddress.
Public method | UpdateOrganization | Updates the Organization.
Public method | UpdateOrganizationAddress | Updates the OrganizationAddress.
Public method | UpdateOrganizationAddressAsync | Asynchronously updates the OrganizationAddress.
Public method | UpdateOrganizationAsync | Asynchronously updates the Organization.
Public method | UpdateOrganizationInteractionAddress | Updates the OrganizationInteractionAddress.
Public method | UpdateOrganizationInteractionAddressAsync | Asynchronously updates the OrganizationInteractionAddress.
Public method | UpdateUserSecurity | Updates the user security.
Public method | UpdateUserSecurityAsync | Asynchronously updates the user security.

Properties

 | Name | Description
Public property | TransactionClient | Gets the TransactionClient.

See Also

TrackerUser Class
ININ.IceLib.Tracker Namespace


TrackerUser Constructor

[image]

IceLib Technical Reference
TrackerUser Constructor
TrackerUser Class See Also Send Feedback
Initializes a new instance of the TrackerUser class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TrackerUser(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The session.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


TrackerUser Methods

[image] [image]

IceLib Technical Reference
TrackerUser Methods
TrackerUser Class See Also Send Feedback

The TrackerUser type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds the Annotation.
Public method | AddAnnotationAsync | Asynchronously adds the Annotation.
Public method | AddIndividual | Adds the Individual.
Public method | AddIndividualAddress | Adds the IndividualAddress.
Public method | AddIndividualAddressAsync | Asynchronously adds the IndividualAddress.
Public method | AddIndividualAsync | Asynchronously adds the Individual.
Public method | AddIndividualInteractionAddress | Adds the IndividualInteractionAddress.
Public method | AddIndividualInteractionAddressAsync | Asynchronously adds the IndividualInteractionAddress.
Public method | AddLocation | Adds the Location.
Public method | AddLocationAddress | Adds the LocationAddress.
Public method | AddLocationAddressAsync | Asynchronously adds the LocationAddress.
Public method | AddLocationAsync | Asynchronously adds the Location.
Public method | AddLocationInteractionAddress | Adds the LocationInteractionAddress.
Public method | AddLocationInteractionAddressAsync | Asynchronously adds the LocationInteractionAddress.
Public method | AddOrganization | Adds the Organization.
Public method | AddOrganizationAddress | Adds the OrganizationAddress.
Public method | AddOrganizationAddressAsync | Asynchronously adds the OrganizationAddress.
Public method | AddOrganizationAsync | Asynchronously adds the Organization.
Public method | AddOrganizationInteractionAddress | Adds the OrganizationInteractionAddress.
Public method | AddOrganizationInteractionAddressAsync | Asynchronously adds the OrganizationInteractionAddress.
Public method | AddUpdateIndividualTrackerAttribute | Adds a TrackerAttribute for an Individual. If the TrackerAttribute exists for this Individual, it is updated. Otherwise it is added.
Public method | AddUpdateIndividualTrackerAttributeAsync | Asynchronously adds a TrackerAttribute for an Individual. If the TrackerAttribute exists, then it is updated, otherwise it is added.
Public method | AddUpdateInteractionTrackerAttribute | Adds or updates a TrackerAttribute for an interaction. If the TrackerAttribute exists for this interaction, it is updated. Otherwise it is added.
Public method | AddUpdateInteractionTrackerAttributeAsync | Asynchronously adds or updates a TrackerAttribute for an interaction. If the TrackerAttribute exists for this interaction, it is updated. Otherwise it is added.
Public method | AddUpdateLocationTrackerAttribute | Adds or updates a TrackerAttribute for a Location. If the TrackerAttribute exists Location, it is updated. Otherwise it is added.
Public method | AddUpdateLocationTrackerAttributeAsync | Asynchronously adds or updates a TrackerAttribute for a Location. If the TrackerAttribute exists for this Location, it is updated. Otherwise it is added.
Public method | AddUpdateOrganizationTrackerAttribute | Adds a TrackerAttribute for an Organization. If the TrackerAttribute exists for this Organization, it is updated. Otherwise it is added.
Public method | AddUpdateOrganizationTrackerAttributeAsync | Asynchronously adds a TrackerAttribute for an Organization. If the TrackerAttribute exists for this Organization, it is updated. Otherwise it is added.
Public method | CanViewInteraction | Determines whether the specified interaction can be viewed by the current Individual.
Public method | CanViewInteractionAsync | Asynchronously determines whether the specified interaction can be viewed by the current Individual.
Public method | DeleteAnnotation | Deletes the Annotation from the Tracker database.
Public method | DeleteAnnotationAsync | Asynchronously deletes the Annotation from the Tracker database.
Public method | DeleteIndividual | Deletes the Individual from the Tracker database.
Public method | DeleteIndividualAddress | Deletes the IndividualAddress from the Tracker database.
Public method | DeleteIndividualAddressAsync | Asynchronously deletes the IndividualAddress from the Tracker database.
Public method | DeleteIndividualAsync | Asynchronously deletes the Individual from the Tracker database.
Public method | DeleteIndividualInteractionAddress | Deletes an IndividualInteractionAddress from the Tracker database.
Public method | DeleteIndividualInteractionAddressAsync | Asynchronously deletes an IndividualInteractionAddress from the Tracker database.
Public method | DeleteIndividualTrackerAttribute | Deletes the Individual TrackerAttribute from the Tracker database.
Public method | DeleteIndividualTrackerAttributeAsync | Asynchronously deletes the Individual TrackerAttribute from the Tracker database.
Public method | DeleteInteractionTrackerAttribute | Deletes the interaction TrackerAttribute from the Tracker database.
Public method | DeleteInteractionTrackerAttributeAsync | Asynchronously deletes the interaction TrackerAttribute from the Tracker database.
Public method | DeleteLocation | Deletes the Location from the Tracker database.
Public method | DeleteLocationAddress | Deletes the LocationAddress from the Tracker database.
Public method | DeleteLocationAddressAsync | Asynchronously deletes the LocationAddress from the Tracker database.
Public method | DeleteLocationAsync | Asynchronously deletes the Location from the Tracker database.
Public method | DeleteLocationInteractionAddress | Deletes the LocationInteractionAddress from the Tracker database.
Public method | DeleteLocationInteractionAddressAsync | Asynchronously deletes the LocationInteractionAddress from the Tracker database.
Public method | DeleteLocationTrackerAttribute | Deletes the Location TrackerAttribute from the Tracker database.
Public method | DeleteLocationTrackerAttributeAsync | Asynchronously deletes the Location TrackerAttribute from the Tracker database.
Public method | DeleteOrganization | Deletes the Organization from the Tracker database.
Public method | DeleteOrganizationAddress | Deletes the OrganizationAddress from the Tracker database.
Public method | DeleteOrganizationAddressAsync | Asynchronously deletes the OrganizationAddress from the Tracker database.
Public method | DeleteOrganizationAsync | Asynchronously deletes the Organization from the Tracker database.
Public method | DeleteOrganizationInteractionAddress | Deletes the OrganizationInteractionAddress from the Tracker database.
Public method | DeleteOrganizationInteractionAddressAsync | Asynchronously deletes the OrganizationInteractionAddress from the Tracker database.
Public method | DeleteOrganizationTrackerAttribute | Deletes the OrganizationAddress from the Tracker database.
Public method | DeleteOrganizationTrackerAttributeAsync | Asynchronously deletes the Organization TrackerAttribute from the Tracker database.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllMultipartAccountCodes | Gets all MultipartAccountCodes.
Public method | GetAllMultipartAccountCodesAsync | Asynchronously gets all MultipartAccountCodes.
Public method | GetCurrentSegmentOrganizationIndividual | Gets the current segment information for an interaction.
Public method | GetCurrentSegmentOrganizationIndividualAsync | Asynchronously gets the current segment information for an interaction.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetICUserIndividualInformation | Gets the ICUserIndividualInformation for an Individual.
Public method | GetICUserIndividualInformationAsync | Asynchronously gets the ICUserIndividualInformation.
Public method | GetIndividualDetails | Gets the IndividualDetails.
Public method | GetIndividualDetailsAsync | Asynchronously gets the IndividualDetails.
Public method | GetIndividualMultipartAccountCodeMRUList | Gets the most recently used Multipart account codes for an Individual..
Public method | GetIndividualMultipartAccountCodeMRUListAsync | Asynchronously gets the most recently used Multipart account codes for an Individual..
Public method | GetIndividualMultipartAccountCodes | Gets all Multipart account codes for an Individual..
Public method | GetIndividualMultipartAccountCodesAsync | Asynchronously gets all Multipart account codes for an Individual..
Public method | GetInheritedIndividualAddress | Gets the inherited IndividualAddress.
Public method | GetInheritedIndividualAddressAsync | Asynchronously gets the inherited IndividualAddress.
Public method | GetInheritedIndividualInteractionAddress | Gets the inherited IndividualInteractionAddress.
Public method | GetInheritedIndividualInteractionAddressAsync | Asynchronously gets the inherited IndividualInteractionAddress.
Public method | GetInheritedLocationAddress | Gets the inherited LocationAddress.
Public method | GetInheritedLocationAddressAsync | Asynchronously gets the inherited LocationAddress.
Public method | GetInheritedLocationInteractionAddress | Gets the inherited LocationInteractionAddress.
Public method | GetInheritedLocationInteractionAddressAsync | Asynchronously gets the inherited LocationInteractionAddress.
Public method | GetInteractionDetails | Gets the interaction details.
Public method | GetInteractionDetailsAsync | Asynchronously gets the interaction details.
Public method | GetLocationDetails | Gets the LocationDetails details.
Public method | GetLocationDetailsAsync | Asynchronously gets the Location details.
Public method | GetLocationNamesByName | Gets the LocationNames by name.
Public method | GetLocationNamesByNameAsync | Asynchronously gets the LocationNames by name.
Public method | GetLocationNamesByOrganizationId | Gets the LocationNames by Organization ID.
Public method | GetLocationNamesByOrganizationIdAsync | Asynchronously gets the Location names by Organization ID.
Public method | GetOrganizationById | Gets the Organization by ID.
Public method | GetOrganizationByIdAsync | Asynchronously gets the Organization by ID.
Public method | GetOrganizationDetails | Gets the OrganizationDetails.
Public method | GetOrganizationDetailsAsync | Asynchronously gets the OrganizationDetails.
Public method | GetOrganizationNamesByName | Gets the Organization names.
Public method | GetOrganizationNamesByNameAsync | Asynchronously gets the Organization names.
Public method | GetPossibleDuplicateIndividual | Gets the possible duplicate Individual.
Public method | GetPossibleDuplicateIndividualAsync | Asynchronously gets the possible duplicate Individual.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsersCanViewInteractionOn | Gets the ICUserIds that can view interactions for the given Location and Organization.
Public method | GetUsersCanViewInteractionOnAsync | Asynchronously gets the ICUserIds that can view interactions for the given Location and Organization.
Public method | ICUserModified | Marks an IC user as modified.
Public method | ICUserModifiedAsync | Asynchronously marks an IC user as modified.
Public method | IsUnknownOrSystemIndividual | Determines whether the specific Individual is unknown or a system Individual.
Public method | IsUnknownOrSystemIndividualAsync | Asynchronously determines whether the specific Individual is unknown or a system Individual.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetIndividualImages | Sets the image file for all IC users.
Public method | SetIndividualImagesAsync | Asynchronously sets the image file for all IC users.
Public method | SetIndividualUrls | Sets the individual URLs.
Public method | SetIndividualUrlsAsync | Asynchronously sets individual URLs.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAnnotation | Updates the Annotation.
Public method | UpdateAnnotationAsync | Asynchronously updates the Annotation.
Public method | UpdateApplicationIncidentId | Updates the application incident ID.
Public method | UpdateApplicationIncidentIdAsync | Asynchronously updates the application incident ID.
Public method | UpdateIndividual | Updates the Individual.
Public method | UpdateIndividualAddress | Updates the IndividualAddress.
Public method | UpdateIndividualAddressAsync | Asynchronously updates the IndividualAddress.
Public method | UpdateIndividualAsync | Asynchronously updates the Individual.
Public method | UpdateIndividualInteractionAddress | Updates the IndividualInteractionAddress.
Public method | UpdateIndividualInteractionAddressAsync | Asynchronously updates the IndividualInteractionAddress.
Public method | UpdateLocation | Updates the Location.
Public method | UpdateLocationAddress | Updates the LocationAddress.
Public method | UpdateLocationAddressAsync | Asynchronously updates the LocationAddress.
Public method | UpdateLocationAsync | Asynchronously updates the Location.
Public method | UpdateLocationInteractionAddress | Updates the LocationInteractionAddress.
Public method | UpdateLocationInteractionAddressAsync | Asynchronously updates the LocationInteractionAddress.
Public method | UpdateOrganization | Updates the Organization.
Public method | UpdateOrganizationAddress | Updates the OrganizationAddress.
Public method | UpdateOrganizationAddressAsync | Asynchronously updates the OrganizationAddress.
Public method | UpdateOrganizationAsync | Asynchronously updates the Organization.
Public method | UpdateOrganizationInteractionAddress | Updates the OrganizationInteractionAddress.
Public method | UpdateOrganizationInteractionAddressAsync | Asynchronously updates the OrganizationInteractionAddress.
Public method | UpdateUserSecurity | Updates the user security.
Public method | UpdateUserSecurityAsync | Asynchronously updates the user security.

See Also

TrackerUser Class
ININ.IceLib.Tracker Namespace


AddAnnotation Method

[image]

IceLib Technical Reference
TrackerUser..::..AddAnnotation Method
TrackerUser Class See Also Send Feedback
Adds the Annotation.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddAnnotation(
    Annotation annotation
)
Visual Basic
Public Function AddAnnotation ( _
    annotation As Annotation _
) As Long

Parameters

annotation
Type: ININ.IceLib.Tracker..::..Annotation
The Annotation.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddAnnotationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddAnnotationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the Annotation.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddAnnotationAsync(
    Annotation annotation,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddAnnotationAsync ( _
    annotation As Annotation, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

annotation
Type: ININ.IceLib.Tracker..::..Annotation
The Annotation.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddIndividual Method

[image]

IceLib Technical Reference
TrackerUser..::..AddIndividual Method
TrackerUser Class See Also Send Feedback
Adds the Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddIndividual(
    Individual individual
)
Visual Basic
Public Function AddIndividual ( _
    individual As Individual _
) As String

Parameters

individual
Type: ININ.IceLib.Tracker..::..Individual
The Individual to add.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddIndividualAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..AddIndividualAddress Method
TrackerUser Class See Also Send Feedback
Adds the IndividualAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddIndividualAddress(
    IndividualAddress individualAddress
)
Visual Basic
Public Function AddIndividualAddress ( _
    individualAddress As IndividualAddress _
) As Long

Parameters

individualAddress
Type: ININ.IceLib.Tracker..::..IndividualAddress
The IndividualAddress.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddIndividualAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddIndividualAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the IndividualAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddIndividualAddressAsync(
    IndividualAddress individualAddress,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddIndividualAddressAsync ( _
    individualAddress As IndividualAddress, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

individualAddress
Type: ININ.IceLib.Tracker..::..IndividualAddress
The IndividualAddress.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddIndividualAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddIndividualAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddIndividualAsync(
    Individual individual,
    EventHandler<NewIdCompletedEventArgs<string>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddIndividualAsync ( _
    individual As Individual, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of String)), _
    userState As Object _
)

Parameters

individual
Type: ININ.IceLib.Tracker..::..Individual
The Individual to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'String>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddIndividualInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..AddIndividualInteractionAddress Method
TrackerUser Class See Also Send Feedback
Adds the IndividualInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddIndividualInteractionAddress(
    IndividualInteractionAddress individualInteractionAddress
)
Visual Basic
Public Function AddIndividualInteractionAddress ( _
    individualInteractionAddress As IndividualInteractionAddress _
) As Long

Parameters

individualInteractionAddress
Type: ININ.IceLib.Tracker..::..IndividualInteractionAddress
The IndividualInteractionAddress.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddIndividualInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddIndividualInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the IndividualInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddIndividualInteractionAddressAsync(
    IndividualInteractionAddress individualInteractionAddress,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddIndividualInteractionAddressAsync ( _
    individualInteractionAddress As IndividualInteractionAddress, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

individualInteractionAddress
Type: ININ.IceLib.Tracker..::..IndividualInteractionAddress
The IndividualInteractionAddress.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddLocation Method

[image]

IceLib Technical Reference
TrackerUser..::..AddLocation Method
TrackerUser Class See Also Send Feedback
Adds the Location.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddLocation(
    Location location
)
Visual Basic
Public Function AddLocation ( _
    location As Location _
) As String

Parameters

location
Type: ININ.IceLib.Tracker..::..Location
The Location to add.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddLocationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..AddLocationAddress Method
TrackerUser Class See Also Send Feedback
Adds the LocationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddLocationAddress(
    LocationAddress locationAddress
)
Visual Basic
Public Function AddLocationAddress ( _
    locationAddress As LocationAddress _
) As Long

Parameters

locationAddress
Type: ININ.IceLib.Tracker..::..LocationAddress
The LocationAddress.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddLocationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddLocationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the LocationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddLocationAddressAsync(
    LocationAddress locationAddress,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddLocationAddressAsync ( _
    locationAddress As LocationAddress, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

locationAddress
Type: ININ.IceLib.Tracker..::..LocationAddress
The LocationAddress.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddLocationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddLocationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the Location.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddLocationAsync(
    Location location,
    EventHandler<NewIdCompletedEventArgs<string>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddLocationAsync ( _
    location As Location, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of String)), _
    userState As Object _
)

Parameters

location
Type: ININ.IceLib.Tracker..::..Location
The Location to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'String>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddLocationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..AddLocationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Adds the LocationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddLocationInteractionAddress(
    LocationInteractionAddress locationInteractionAddress
)
Visual Basic
Public Function AddLocationInteractionAddress ( _
    locationInteractionAddress As LocationInteractionAddress _
) As Long

Parameters

locationInteractionAddress
Type: ININ.IceLib.Tracker..::..LocationInteractionAddress
The LocationInteractionAddress.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddLocationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddLocationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the LocationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddLocationInteractionAddressAsync(
    LocationInteractionAddress locationInteractionAddress,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddLocationInteractionAddressAsync ( _
    locationInteractionAddress As LocationInteractionAddress, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

locationInteractionAddress
Type: ININ.IceLib.Tracker..::..LocationInteractionAddress
The LocationInteractionAddress.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddOrganization Method

[image]

IceLib Technical Reference
TrackerUser..::..AddOrganization Method
TrackerUser Class See Also Send Feedback
Adds the Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AddOrganization(
    Organization organization
)
Visual Basic
Public Function AddOrganization ( _
    organization As Organization _
) As String

Parameters

organization
Type: ININ.IceLib.Tracker..::..Organization
The Organization to add.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddOrganizationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..AddOrganizationAddress Method
TrackerUser Class See Also Send Feedback
Adds the OrganizationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddOrganizationAddress(
    OrganizationAddress organizationAddress
)
Visual Basic
Public Function AddOrganizationAddress ( _
    organizationAddress As OrganizationAddress _
) As Long

Parameters

organizationAddress
Type: ININ.IceLib.Tracker..::..OrganizationAddress
The OrganizationAddress to add.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddOrganizationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddOrganizationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the OrganizationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddOrganizationAddressAsync(
    OrganizationAddress organizationAddress,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddOrganizationAddressAsync ( _
    organizationAddress As OrganizationAddress, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

organizationAddress
Type: ININ.IceLib.Tracker..::..OrganizationAddress
The OrganizationAddress to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddOrganizationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddOrganizationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddOrganizationAsync(
    Organization organization,
    EventHandler<NewIdCompletedEventArgs<string>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddOrganizationAsync ( _
    organization As Organization, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of String)), _
    userState As Object _
)

Parameters

organization
Type: ININ.IceLib.Tracker..::..Organization
The Organization to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'String>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddOrganizationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..AddOrganizationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Adds the OrganizationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long AddOrganizationInteractionAddress(
    OrganizationInteractionAddress organizationInteractionAddress
)
Visual Basic
Public Function AddOrganizationInteractionAddress ( _
    organizationInteractionAddress As OrganizationInteractionAddress _
) As Long

Parameters

organizationInteractionAddress
Type: ININ.IceLib.Tracker..::..OrganizationInteractionAddress
The OrganizationInteractionAddress to add.

Return Value

The new ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddOrganizationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddOrganizationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds the OrganizationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddOrganizationInteractionAddressAsync(
    OrganizationInteractionAddress organizationInteractionAddress,
    EventHandler<NewIdCompletedEventArgs<long>> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddOrganizationInteractionAddressAsync ( _
    organizationInteractionAddress As OrganizationInteractionAddress, _
    completedCallback As EventHandler(Of NewIdCompletedEventArgs(Of Long)), _
    userState As Object _
)

Parameters

organizationInteractionAddress
Type: ININ.IceLib.Tracker..::..OrganizationInteractionAddress
The OrganizationInteractionAddress to add.
completedCallback
Type: System..::..EventHandler<(Of <(<' NewIdCompletedEventArgs <(Of <(<'Int64>)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateIndividualTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateIndividualTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Adds a TrackerAttribute for an Individual. If the TrackerAttribute exists for this Individual, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AddUpdateIndividualTrackerAttribute(
    TrackerAttribute trackerAttribute
)
Visual Basic
Public Function AddUpdateIndividualTrackerAttribute ( _
    trackerAttribute As TrackerAttribute _
) As Boolean

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute.

Return Value

trueTruetruetrue (True in Visual Basic) if the TrackerAttribute was added.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateIndividualTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateIndividualTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds a TrackerAttribute for an Individual. If the TrackerAttribute exists, then it is updated, otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUpdateIndividualTrackerAttributeAsync(
    TrackerAttribute trackerAttribute,
    EventHandler<AddUpdateCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddUpdateIndividualTrackerAttributeAsync ( _
    trackerAttribute As TrackerAttribute, _
    completedCallback As EventHandler(Of AddUpdateCompletedEventArgs), _
    userState As Object _
)

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' AddUpdateCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateInteractionTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateInteractionTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Adds or updates a TrackerAttribute for an interaction. If the TrackerAttribute exists for this interaction, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AddUpdateInteractionTrackerAttribute(
    TrackerAttribute trackerAttribute
)
Visual Basic
Public Function AddUpdateInteractionTrackerAttribute ( _
    trackerAttribute As TrackerAttribute _
) As Boolean

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute.

Return Value

trueTruetruetrue (True in Visual Basic) if the TrackerAttribute was added.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateInteractionTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateInteractionTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds or updates a TrackerAttribute for an interaction. If the TrackerAttribute exists for this interaction, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUpdateInteractionTrackerAttributeAsync(
    TrackerAttribute trackerAttribute,
    EventHandler<AddUpdateCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddUpdateInteractionTrackerAttributeAsync ( _
    trackerAttribute As TrackerAttribute, _
    completedCallback As EventHandler(Of AddUpdateCompletedEventArgs), _
    userState As Object _
)

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' AddUpdateCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateLocationTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateLocationTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Adds or updates a TrackerAttribute for a Location. If the TrackerAttribute exists Location, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AddUpdateLocationTrackerAttribute(
    TrackerAttribute trackerAttribute
)
Visual Basic
Public Function AddUpdateLocationTrackerAttribute ( _
    trackerAttribute As TrackerAttribute _
) As Boolean

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute.

Return Value

trueTruetruetrue (True in Visual Basic) if the TrackerAttribute was added.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateLocationTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateLocationTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds or updates a TrackerAttribute for a Location. If the TrackerAttribute exists for this Location, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUpdateLocationTrackerAttributeAsync(
    TrackerAttribute trackerAttribute,
    EventHandler<AddUpdateCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddUpdateLocationTrackerAttributeAsync ( _
    trackerAttribute As TrackerAttribute, _
    completedCallback As EventHandler(Of AddUpdateCompletedEventArgs), _
    userState As Object _
)

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute.
completedCallback
Type: System..::..EventHandler<(Of <(<' AddUpdateCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateOrganizationTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateOrganizationTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Adds a TrackerAttribute for an Organization. If the TrackerAttribute exists for this Organization, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AddUpdateOrganizationTrackerAttribute(
    TrackerAttribute trackerAttribute
)
Visual Basic
Public Function AddUpdateOrganizationTrackerAttribute ( _
    trackerAttribute As TrackerAttribute _
) As Boolean

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute to add or update.

Return Value

trueTruetruetrue (True in Visual Basic) if the TrackerAttribute was added.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


AddUpdateOrganizationTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..AddUpdateOrganizationTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously adds a TrackerAttribute for an Organization. If the TrackerAttribute exists for this Organization, it is updated. Otherwise it is added.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddUpdateOrganizationTrackerAttributeAsync(
    TrackerAttribute trackerAttribute,
    EventHandler<AddUpdateCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub AddUpdateOrganizationTrackerAttributeAsync ( _
    trackerAttribute As TrackerAttribute, _
    completedCallback As EventHandler(Of AddUpdateCompletedEventArgs), _
    userState As Object _
)

Parameters

trackerAttribute
Type: ININ.IceLib.Tracker..::..TrackerAttribute
The TrackerAttribute to add or update.
completedCallback
Type: System..::..EventHandler<(Of <(<' AddUpdateCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


CanViewInteraction Method

[image]

IceLib Technical Reference
TrackerUser..::..CanViewInteraction Method
TrackerUser Class See Also Send Feedback
Determines whether the specified interaction can be viewed by the current Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanViewInteraction(
    string interactionId,
    bool canViewOtherPrivate
)
Visual Basic
Public Function CanViewInteraction ( _
    interactionId As String, _
    canViewOtherPrivate As Boolean _
) As Boolean

Parameters

interactionId
Type: System..::..String
The interaction ID.
canViewOtherPrivate
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) can view other's private interactions.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified interaction can be viewed; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


CanViewInteractionAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..CanViewInteractionAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously determines whether the specified interaction can be viewed by the current Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CanViewInteractionAsync(
    string interactionId,
    bool canViewOtherPrivate,
    EventHandler<CanViewInteractionCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub CanViewInteractionAsync ( _
    interactionId As String, _
    canViewOtherPrivate As Boolean, _
    completedCallback As EventHandler(Of CanViewInteractionCompletedEventArgs), _
    userState As Object _
)

Parameters

interactionId
Type: System..::..String
The interaction ID.
canViewOtherPrivate
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) can view other's private interactions.
completedCallback
Type: System..::..EventHandler<(Of <(<' CanViewInteractionCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteAnnotation Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteAnnotation Method
TrackerUser Class See Also Send Feedback
Deletes the Annotation from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAnnotation(
    long id
)
Visual Basic
Public Sub DeleteAnnotation ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The Annotation ID.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteAnnotationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteAnnotationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Annotation from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAnnotationAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteAnnotationAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The Annotation ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividual Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividual Method
TrackerUser Class See Also Send Feedback
Deletes the Individual from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividual(
    string individualId,
    bool deactivateIfDependencies
)
Visual Basic
Public Sub DeleteIndividual ( _
    individualId As String, _
    deactivateIfDependencies As Boolean _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
deactivateIfDependencies
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) deactivate if dependencies.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualAddress Method
TrackerUser Class See Also Send Feedback
Deletes the IndividualAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualAddress(
    long id
)
Visual Basic
Public Sub DeleteIndividualAddress ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The IndividualAddress ID.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the IndividualAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualAddressAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteIndividualAddressAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The IndividualAddress ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Individual from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualAsync(
    string individualId,
    bool deactivateIfDependencies,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteIndividualAsync ( _
    individualId As String, _
    deactivateIfDependencies As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
deactivateIfDependencies
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) deactivate if dependencies.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualInteractionAddress Method
TrackerUser Class See Also Send Feedback
Deletes an IndividualInteractionAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualInteractionAddress(
    long id
)
Visual Basic
Public Sub DeleteIndividualInteractionAddress ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The IndividualInteractionAddress ID.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes an IndividualInteractionAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualInteractionAddressAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteIndividualInteractionAddressAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Deletes the Individual TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualTrackerAttribute(
    string individualId,
    long trackerAttributeTypeId
)
Visual Basic
Public Sub DeleteIndividualTrackerAttribute ( _
    individualId As String, _
    trackerAttributeTypeId As Long _
)

Parameters

individualId
Type: System..::..String
The Individual ID.
trackerAttributeTypeId
Type: System..::..Int64
The TrackerAttributeType ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteIndividualTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteIndividualTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Individual TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteIndividualTrackerAttributeAsync(
    string individualId,
    long trackerAttributeTypeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteIndividualTrackerAttributeAsync ( _
    individualId As String, _
    trackerAttributeTypeId As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The Individual ID.
trackerAttributeTypeId
Type: System..::..Int64
The TrackerAttributeType ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteInteractionTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteInteractionTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Deletes the interaction TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteInteractionTrackerAttribute(
    string interactionId,
    long trackerAttributeTypeId
)
Visual Basic
Public Sub DeleteInteractionTrackerAttribute ( _
    interactionId As String, _
    trackerAttributeTypeId As Long _
)

Parameters

interactionId
Type: System..::..String
The interaction ID.
trackerAttributeTypeId
Type: System..::..Int64
The TrackerAttributeType ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteInteractionTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteInteractionTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the interaction TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteInteractionTrackerAttributeAsync(
    string interactionId,
    long trackerAttributeTypeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteInteractionTrackerAttributeAsync ( _
    interactionId As String, _
    trackerAttributeTypeId As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

interactionId
Type: System..::..String
The interaction ID.
trackerAttributeTypeId
Type: System..::..Int64
The TrackerAttributeType ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocation Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocation Method
TrackerUser Class See Also Send Feedback
Deletes the Location from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocation(
    string locationId,
    bool deleteIndividuals,
    bool deactivateIfDependencies
)
Visual Basic
Public Sub DeleteLocation ( _
    locationId As String, _
    deleteIndividuals As Boolean, _
    deactivateIfDependencies As Boolean _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
deleteIndividuals
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) delete Individuals.
deactivateIfDependencies
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) deactivate if dependencies.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationAddress Method
TrackerUser Class See Also Send Feedback
Deletes the LocationAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationAddress(
    long id
)
Visual Basic
Public Sub DeleteLocationAddress ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the LocationAddress.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the LocationAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationAddressAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteLocationAddressAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the LocationAddress.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Location from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationAsync(
    string locationId,
    bool deleteIndividuals,
    bool deactivateIfDependencies,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteLocationAsync ( _
    locationId As String, _
    deleteIndividuals As Boolean, _
    deactivateIfDependencies As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
deleteIndividuals
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) delete Individuals.
deactivateIfDependencies
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) deactivate if dependencies.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Deletes the LocationInteractionAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationInteractionAddress(
    long id
)
Visual Basic
Public Sub DeleteLocationInteractionAddress ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the LocationInteractionAddress.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the LocationInteractionAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationInteractionAddressAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteLocationInteractionAddressAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the LocationInteractionAddress.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Deletes the Location TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationTrackerAttribute(
    string locationId,
    long trackerAttributeTypeId
)
Visual Basic
Public Sub DeleteLocationTrackerAttribute ( _
    locationId As String, _
    trackerAttributeTypeId As Long _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
trackerAttributeTypeId
Type: System..::..Int64
The ID of the TrackerAttributeType ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteLocationTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteLocationTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Location TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteLocationTrackerAttributeAsync(
    string locationId,
    long trackerAttributeTypeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteLocationTrackerAttributeAsync ( _
    locationId As String, _
    trackerAttributeTypeId As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
trackerAttributeTypeId
Type: System..::..Int64
The ID of the TrackerAttributeType.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganization Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganization Method
TrackerUser Class See Also Send Feedback
Deletes the Organization from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganization(
    string organizationId,
    bool deleteIndividuals,
    bool deactivateIfDependencies
)
Visual Basic
Public Sub DeleteOrganization ( _
    organizationId As String, _
    deleteIndividuals As Boolean, _
    deactivateIfDependencies As Boolean _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
deleteIndividuals
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) delete Individuals.
deactivateIfDependencies
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) deactivate if dependencies.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationAddress Method
TrackerUser Class See Also Send Feedback
Deletes the OrganizationAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationAddress(
    long id
)
Visual Basic
Public Sub DeleteOrganizationAddress ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationAddress.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the OrganizationAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationAddressAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteOrganizationAddressAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationAddress.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Organization from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationAsync(
    string organizationId,
    bool deleteIndividuals,
    bool deactivateIfDependencies,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteOrganizationAsync ( _
    organizationId As String, _
    deleteIndividuals As Boolean, _
    deactivateIfDependencies As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
deleteIndividuals
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) delete Individuals.
deactivateIfDependencies
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) deactivate if dependencies.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Deletes the OrganizationInteractionAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationInteractionAddress(
    long id
)
Visual Basic
Public Sub DeleteOrganizationInteractionAddress ( _
    id As Long _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationInteractionAddress.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the OrganizationInteractionAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationInteractionAddressAsync(
    long id,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteOrganizationInteractionAddressAsync ( _
    id As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..Int64
The ID of the OrganizationInteractionAddress.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationTrackerAttribute Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationTrackerAttribute Method
TrackerUser Class See Also Send Feedback
Deletes the OrganizationAddress from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationTrackerAttribute(
    string organizationId,
    long trackerAttributeTypeId
)
Visual Basic
Public Sub DeleteOrganizationTrackerAttribute ( _
    organizationId As String, _
    trackerAttributeTypeId As Long _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
trackerAttributeTypeId
Type: System..::..Int64
The ID of the TrackerAttributeType.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


DeleteOrganizationTrackerAttributeAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..DeleteOrganizationTrackerAttributeAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously deletes the Organization TrackerAttribute from the Tracker database.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteOrganizationTrackerAttributeAsync(
    string organizationId,
    long trackerAttributeTypeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteOrganizationTrackerAttributeAsync ( _
    organizationId As String, _
    trackerAttributeTypeId As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
trackerAttributeTypeId
Type: System..::..Int64
The ID of the TrackerAttributeType.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetAllMultipartAccountCodes Method

[image]

IceLib Technical Reference
TrackerUser..::..GetAllMultipartAccountCodes Method
TrackerUser Class See Also Send Feedback
Gets all MultipartAccountCodes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<MultipartAccountCodeExtended> GetAllMultipartAccountCodes()
Visual Basic
Public Function GetAllMultipartAccountCodes As Collection(Of MultipartAccountCodeExtended)

Return Value

A collection of MultipartAccountCodeExtended objects.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetAllMultipartAccountCodesAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetAllMultipartAccountCodesAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets all MultipartAccountCodes.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetAllMultipartAccountCodesAsync(
    EventHandler<QueryCollectionResultCompletedEventArgs<MultipartAccountCodeExtended>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetAllMultipartAccountCodesAsync ( _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of MultipartAccountCodeExtended)), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' MultipartAccountCodeExtended >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividual Method

[image]

IceLib Technical Reference
TrackerUser..::..GetCurrentSegmentOrganizationIndividual Method
TrackerUser Class See Also Send Feedback
Gets the current segment information for an interaction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public SegmentOrganizationIndividualDetails GetCurrentSegmentOrganizationIndividual(
    string callIdKey,
    string ICUserId
)
Visual Basic
Public Function GetCurrentSegmentOrganizationIndividual ( _
    callIdKey As String, _
    ICUserId As String _
) As SegmentOrganizationIndividualDetails

Parameters

callIdKey
Type: System..::..String
The call ID key.
ICUserId
Type: System..::..String
The IC user ID.

Return Value

The SegmentOrganizationIndividualDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetCurrentSegmentOrganizationIndividualAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetCurrentSegmentOrganizationIndividualAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the current segment information for an interaction.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetCurrentSegmentOrganizationIndividualAsync(
    string callIdKey,
    string ICUserId,
    EventHandler<GetCurrentSegmentOrganizationIndividualCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetCurrentSegmentOrganizationIndividualAsync ( _
    callIdKey As String, _
    ICUserId As String, _
    completedCallback As EventHandler(Of GetCurrentSegmentOrganizationIndividualCompletedEventArgs), _
    userState As Object _
)

Parameters

callIdKey
Type: System..::..String
The call ID key.
ICUserId
Type: System..::..String
The IC user ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetCurrentSegmentOrganizationIndividualCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformation Method

[image]

IceLib Technical Reference
TrackerUser..::..GetICUserIndividualInformation Method
TrackerUser Class See Also Send Feedback
Gets the ICUserIndividualInformation for an Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ICUserIndividualInformation GetICUserIndividualInformation(
    string icUserId
)
Visual Basic
Public Function GetICUserIndividualInformation ( _
    icUserId As String _
) As ICUserIndividualInformation

Parameters

icUserId
Type: System..::..String
The IC User ID of the Individual.

Return Value

The ICUserIndividualInformation.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetICUserIndividualInformationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetICUserIndividualInformationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the ICUserIndividualInformation.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetICUserIndividualInformationAsync(
    string icUserId,
    EventHandler<GetICUserIndividualInformationCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetICUserIndividualInformationAsync ( _
    icUserId As String, _
    completedCallback As EventHandler(Of GetICUserIndividualInformationCompletedEventArgs), _
    userState As Object _
)

Parameters

icUserId
Type: System..::..String
The IC User ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetICUserIndividualInformationCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetIndividualDetails Method

[image]

IceLib Technical Reference
TrackerUser..::..GetIndividualDetails Method
TrackerUser Class See Also Send Feedback
Gets the IndividualDetails.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualDetails GetIndividualDetails(
    string individualId
)
Visual Basic
Public Function GetIndividualDetails ( _
    individualId As String _
) As IndividualDetails

Parameters

individualId
Type: System..::..String
The ID of the Individual.

Return Value

The IndividualDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetIndividualDetailsAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetIndividualDetailsAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the IndividualDetails.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetIndividualDetailsAsync(
    string individualId,
    EventHandler<GetIndividualDetailsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetIndividualDetailsAsync ( _
    individualId As String, _
    completedCallback As EventHandler(Of GetIndividualDetailsCompletedEventArgs), _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetIndividualDetailsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetIndividualMultipartAccountCodeMRUList Method

[image]

IceLib Technical Reference
TrackerUser..::..GetIndividualMultipartAccountCodeMRUList Method
TrackerUser Class See Also Send Feedback
Gets the most recently used Multipart account codes for an Individual..

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<MultipartAccountCode> GetIndividualMultipartAccountCodeMRUList(
    string individualId
)
Visual Basic
Public Function GetIndividualMultipartAccountCodeMRUList ( _
    individualId As String _
) As Collection(Of MultipartAccountCode)

Parameters

individualId
Type: System..::..String
The ID of the Individual.

Return Value

The MultipartAccountCodes.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetIndividualMultipartAccountCodeMRUListAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetIndividualMultipartAccountCodeMRUListAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the most recently used Multipart account codes for an Individual..

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetIndividualMultipartAccountCodeMRUListAsync(
    string individualId,
    EventHandler<QueryCollectionResultCompletedEventArgs<MultipartAccountCode>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetIndividualMultipartAccountCodeMRUListAsync ( _
    individualId As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of MultipartAccountCode)), _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' MultipartAccountCode >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetIndividualMultipartAccountCodes Method

[image]

IceLib Technical Reference
TrackerUser..::..GetIndividualMultipartAccountCodes Method
TrackerUser Class See Also Send Feedback
Gets all Multipart account codes for an Individual..

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<MultipartAccountCode> GetIndividualMultipartAccountCodes(
    string individualId
)
Visual Basic
Public Function GetIndividualMultipartAccountCodes ( _
    individualId As String _
) As Collection(Of MultipartAccountCode)

Parameters

individualId
Type: System..::..String
The ID of the Individual.

Return Value

The MultipartAccountCodes.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetIndividualMultipartAccountCodesAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetIndividualMultipartAccountCodesAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets all Multipart account codes for an Individual..

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetIndividualMultipartAccountCodesAsync(
    string individualId,
    EventHandler<QueryCollectionResultCompletedEventArgs<MultipartAccountCode>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetIndividualMultipartAccountCodesAsync ( _
    individualId As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of MultipartAccountCode)), _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' MultipartAccountCode >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedIndividualAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedIndividualAddress Method
TrackerUser Class See Also Send Feedback
Gets the inherited IndividualAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualAddress GetInheritedIndividualAddress(
    string locationId,
    string organizationId
)
Visual Basic
Public Function GetInheritedIndividualAddress ( _
    locationId As String, _
    organizationId As String _
) As IndividualAddress

Parameters

locationId
Type: System..::..String
The ID of the Location.
organizationId
Type: System..::..String
The ID of the Organization.

Return Value

The IndividualAddress.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedIndividualAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedIndividualAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the inherited IndividualAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInheritedIndividualAddressAsync(
    string locationId,
    string organizationId,
    EventHandler<QueryResultCompletedEventArgs<IndividualAddress>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInheritedIndividualAddressAsync ( _
    locationId As String, _
    organizationId As String, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of IndividualAddress)), _
    userState As Object _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
organizationId
Type: System..::..String
The ID of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' IndividualAddress >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedIndividualInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedIndividualInteractionAddress Method
TrackerUser Class See Also Send Feedback
Gets the inherited IndividualInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IndividualInteractionAddress GetInheritedIndividualInteractionAddress(
    string locationId,
    string organizationId
)
Visual Basic
Public Function GetInheritedIndividualInteractionAddress ( _
    locationId As String, _
    organizationId As String _
) As IndividualInteractionAddress

Parameters

locationId
Type: System..::..String
The ID of the Location.
organizationId
Type: System..::..String
The ID of the Organization.

Return Value

The IndividualInteractionAddress.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedIndividualInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedIndividualInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the inherited IndividualInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInheritedIndividualInteractionAddressAsync(
    string locationId,
    string organizationId,
    EventHandler<QueryResultCompletedEventArgs<IndividualInteractionAddress>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInheritedIndividualInteractionAddressAsync ( _
    locationId As String, _
    organizationId As String, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of IndividualInteractionAddress)), _
    userState As Object _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
organizationId
Type: System..::..String
The ID of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' IndividualInteractionAddress >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedLocationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedLocationAddress Method
TrackerUser Class See Also Send Feedback
Gets the inherited LocationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationAddress GetInheritedLocationAddress(
    string organizationId
)
Visual Basic
Public Function GetInheritedLocationAddress ( _
    organizationId As String _
) As LocationAddress

Parameters

organizationId
Type: System..::..String
The ID of the Organization.

Return Value

The LocationAddress.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedLocationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedLocationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the inherited LocationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInheritedLocationAddressAsync(
    string organizationId,
    EventHandler<QueryResultCompletedEventArgs<LocationAddress>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInheritedLocationAddressAsync ( _
    organizationId As String, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of LocationAddress)), _
    userState As Object _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' LocationAddress >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedLocationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedLocationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Gets the inherited LocationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationInteractionAddress GetInheritedLocationInteractionAddress(
    string organizationId
)
Visual Basic
Public Function GetInheritedLocationInteractionAddress ( _
    organizationId As String _
) As LocationInteractionAddress

Parameters

organizationId
Type: System..::..String
The ID of the Organization.

Return Value

The LocationInteractionAddress.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInheritedLocationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInheritedLocationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the inherited LocationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInheritedLocationInteractionAddressAsync(
    string organizationId,
    EventHandler<QueryResultCompletedEventArgs<LocationInteractionAddress>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInheritedLocationInteractionAddressAsync ( _
    organizationId As String, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of LocationInteractionAddress)), _
    userState As Object _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' LocationInteractionAddress >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInteractionDetails Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInteractionDetails Method
TrackerUser Class See Also Send Feedback
Gets the interaction details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionDetails GetInteractionDetails(
    string interactionId,
    string individualId
)
Visual Basic
Public Function GetInteractionDetails ( _
    interactionId As String, _
    individualId As String _
) As InteractionDetails

Parameters

interactionId
Type: System..::..String
The interaction ID.
individualId
Type: System..::..String
The ID of the Individual.

Return Value

The InteractionDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetInteractionDetailsAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetInteractionDetailsAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the interaction details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetInteractionDetailsAsync(
    string interactionId,
    string individualId,
    EventHandler<GetInteractionDetailsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetInteractionDetailsAsync ( _
    interactionId As String, _
    individualId As String, _
    completedCallback As EventHandler(Of GetInteractionDetailsCompletedEventArgs), _
    userState As Object _
)

Parameters

interactionId
Type: System..::..String
The interaction ID.
individualId
Type: System..::..String
The ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetInteractionDetailsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetLocationDetails Method

[image]

IceLib Technical Reference
TrackerUser..::..GetLocationDetails Method
TrackerUser Class See Also Send Feedback
Gets the LocationDetails details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public LocationDetails GetLocationDetails(
    string id
)
Visual Basic
Public Function GetLocationDetails ( _
    id As String _
) As LocationDetails

Parameters

id
Type: System..::..String
The Location ID.

Return Value

The LocationDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetLocationDetailsAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetLocationDetailsAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the Location details.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetLocationDetailsAsync(
    string id,
    EventHandler<GetLocationDetailsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetLocationDetailsAsync ( _
    id As String, _
    completedCallback As EventHandler(Of GetLocationDetailsCompletedEventArgs), _
    userState As Object _
)

Parameters

id
Type: System..::..String
The Location ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetLocationDetailsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetLocationNamesByName Method

[image]

IceLib Technical Reference
TrackerUser..::..GetLocationNamesByName Method
TrackerUser Class See Also Send Feedback
Gets the LocationNames by name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<LocationName> GetLocationNamesByName(
    long isPrivate,
    string ownerId,
    string organizationId,
    string locationName
)
Visual Basic
Public Function GetLocationNamesByName ( _
    isPrivate As Long, _
    ownerId As String, _
    organizationId As String, _
    locationName As String _
) As Collection(Of LocationName)

Parameters

isPrivate
Type: System..::..Int64
Whether it is private.
ownerId
Type: System..::..String
The owner ID.
organizationId
Type: System..::..String
The ID of the Organization.
locationName
Type: System..::..String
Name of the Location.

Return Value

The LocationNames.

Remarks

If locationName is empty, all known LocationNames are returned (while still considering isPrivate and ownerId). Otherwise, locationName is treated like a wildcard.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetLocationNamesByNameAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetLocationNamesByNameAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the LocationNames by name.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetLocationNamesByNameAsync(
    long isPrivate,
    string ownerId,
    string organizationId,
    string locationName,
    EventHandler<QueryCollectionResultCompletedEventArgs<LocationName>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetLocationNamesByNameAsync ( _
    isPrivate As Long, _
    ownerId As String, _
    organizationId As String, _
    locationName As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of LocationName)), _
    userState As Object _
)

Parameters

isPrivate
Type: System..::..Int64
Whether it is private.
ownerId
Type: System..::..String
The owner ID.
organizationId
Type: System..::..String
The ID of the Organization.
locationName
Type: System..::..String
Name of the Location.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' LocationName >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

If locationName is empty, all known LocationNames are returned (while still considering isPrivate and ownerId). Otherwise, locationName is treated like a wildcard.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetLocationNamesByOrganizationId Method

[image]

IceLib Technical Reference
TrackerUser..::..GetLocationNamesByOrganizationId Method
TrackerUser Class See Also Send Feedback
Gets the LocationNames by Organization ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<LocationName> GetLocationNamesByOrganizationId(
    string organizationId
)
Visual Basic
Public Function GetLocationNamesByOrganizationId ( _
    organizationId As String _
) As Collection(Of LocationName)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.

Return Value

The LocationNames.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetLocationNamesByOrganizationIdAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetLocationNamesByOrganizationIdAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the Location names by Organization ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetLocationNamesByOrganizationIdAsync(
    string organizationId,
    EventHandler<QueryCollectionResultCompletedEventArgs<LocationName>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetLocationNamesByOrganizationIdAsync ( _
    organizationId As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of LocationName)), _
    userState As Object _
)

Parameters

organizationId
Type: System..::..String
The ID of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' LocationName >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetOrganizationById Method

[image]

IceLib Technical Reference
TrackerUser..::..GetOrganizationById Method
TrackerUser Class See Also Send Feedback
Gets the Organization by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Organization GetOrganizationById(
    string id
)
Visual Basic
Public Function GetOrganizationById ( _
    id As String _
) As Organization

Parameters

id
Type: System..::..String
The Organization ID.

Return Value

The Organization.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetOrganizationByIdAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetOrganizationByIdAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the Organization by ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetOrganizationByIdAsync(
    string id,
    EventHandler<QueryResultCompletedEventArgs<Organization>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetOrganizationByIdAsync ( _
    id As String, _
    completedCallback As EventHandler(Of QueryResultCompletedEventArgs(Of Organization)), _
    userState As Object _
)

Parameters

id
Type: System..::..String
The Organization ID.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryResultCompletedEventArgs <(Of <(<' Organization >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetOrganizationDetails Method

[image]

IceLib Technical Reference
TrackerUser..::..GetOrganizationDetails Method
TrackerUser Class See Also Send Feedback
Gets the OrganizationDetails.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public OrganizationDetails GetOrganizationDetails(
    string id
)
Visual Basic
Public Function GetOrganizationDetails ( _
    id As String _
) As OrganizationDetails

Parameters

id
Type: System..::..String
The OrganizationID.

Return Value

The OrganizationDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetOrganizationDetailsAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetOrganizationDetailsAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the OrganizationDetails.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetOrganizationDetailsAsync(
    string id,
    EventHandler<GetOrganizationDetailsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetOrganizationDetailsAsync ( _
    id As String, _
    completedCallback As EventHandler(Of GetOrganizationDetailsCompletedEventArgs), _
    userState As Object _
)

Parameters

id
Type: System..::..String
The OrganizationID.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetOrganizationDetailsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetOrganizationNamesByName Method

[image]

IceLib Technical Reference
TrackerUser..::..GetOrganizationNamesByName Method
TrackerUser Class See Also Send Feedback
Gets the Organization names.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<OrganizationName> GetOrganizationNamesByName(
    long isPrivate,
    string ownerId,
    string organizationName
)
Visual Basic
Public Function GetOrganizationNamesByName ( _
    isPrivate As Long, _
    ownerId As String, _
    organizationName As String _
) As Collection(Of OrganizationName)

Parameters

isPrivate
Type: System..::..Int64
Whether it is private.
ownerId
Type: System..::..String
The owner ID.
organizationName
Type: System..::..String
Name of the Organization.

Return Value

The Organization names.

Remarks

If organizationName is empty, all known OrganizationNames are returned (while still considering isPrivate and ownerId). Otherwise, organizationName is treated like a wildcard.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetOrganizationNamesByNameAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetOrganizationNamesByNameAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the Organization names.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetOrganizationNamesByNameAsync(
    long isPrivate,
    string ownerId,
    string organizationName,
    EventHandler<QueryCollectionResultCompletedEventArgs<OrganizationName>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetOrganizationNamesByNameAsync ( _
    isPrivate As Long, _
    ownerId As String, _
    organizationName As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of OrganizationName)), _
    userState As Object _
)

Parameters

isPrivate
Type: System..::..Int64
Whether it is private.
ownerId
Type: System..::..String
The owner ID.
organizationName
Type: System..::..String
Name of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' OrganizationName >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

If organizationName is empty, all known OrganizationNames are returned (while still considering isPrivate and ownerId). Otherwise, organizationName is treated like a wildcard.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividual Method

[image]

IceLib Technical Reference
TrackerUser..::..GetPossibleDuplicateIndividual Method
TrackerUser Class See Also Send Feedback
Gets the possible duplicate Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string GetPossibleDuplicateIndividual(
    string lastName,
    string firstName,
    string interactionAddressValue
)
Visual Basic
Public Function GetPossibleDuplicateIndividual ( _
    lastName As String, _
    firstName As String, _
    interactionAddressValue As String _
) As String

Parameters

lastName
Type: System..::..String
Last name of Individual.
firstName
Type: System..::..String
First name of Individual.
interactionAddressValue
Type: System..::..String
The Value of the IndividualInteractionAddress.

Return Value

The ID of the Individual.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetPossibleDuplicateIndividualAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetPossibleDuplicateIndividualAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the possible duplicate Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetPossibleDuplicateIndividualAsync(
    string lastName,
    string firstName,
    string interactionAddressValue,
    EventHandler<GetPossibleDuplicateIndividualCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetPossibleDuplicateIndividualAsync ( _
    lastName As String, _
    firstName As String, _
    interactionAddressValue As String, _
    completedCallback As EventHandler(Of GetPossibleDuplicateIndividualCompletedEventArgs), _
    userState As Object _
)

Parameters

lastName
Type: System..::..String
Last name of Individual.
firstName
Type: System..::..String
First name of Individual.
interactionAddressValue
Type: System..::..String
The Value of the IndividualInteractionAddress.
completedCallback
Type: System..::..EventHandler<(Of <(<' GetPossibleDuplicateIndividualCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetUsersCanViewInteractionOn Method

[image]

IceLib Technical Reference
TrackerUser..::..GetUsersCanViewInteractionOn Method
TrackerUser Class See Also Send Feedback
Gets the ICUserIds that can view interactions for the given Location and Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Collection<ICUserId> GetUsersCanViewInteractionOn(
    string locationId,
    string organizationId
)
Visual Basic
Public Function GetUsersCanViewInteractionOn ( _
    locationId As String, _
    organizationId As String _
) As Collection(Of ICUserId)

Parameters

locationId
Type: System..::..String
The ID of the Location.
organizationId
Type: System..::..String
The ID of the Organization.

Return Value

The IC User IDs.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


GetUsersCanViewInteractionOnAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..GetUsersCanViewInteractionOnAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously gets the ICUserIds that can view interactions for the given Location and Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetUsersCanViewInteractionOnAsync(
    string locationId,
    string organizationId,
    EventHandler<QueryCollectionResultCompletedEventArgs<ICUserId>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetUsersCanViewInteractionOnAsync ( _
    locationId As String, _
    organizationId As String, _
    completedCallback As EventHandler(Of QueryCollectionResultCompletedEventArgs(Of ICUserId)), _
    userState As Object _
)

Parameters

locationId
Type: System..::..String
The ID of the Location.
organizationId
Type: System..::..String
The ID of the Organization.
completedCallback
Type: System..::..EventHandler<(Of <(<' QueryCollectionResultCompletedEventArgs <(Of <(<' ICUserId >)>)>>)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


ICUserModified Method

[image]

IceLib Technical Reference
TrackerUser..::..ICUserModified Method
TrackerUser Class See Also Send Feedback
Marks an IC user as modified.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ICUserModified(
    string ICUserId
)
Visual Basic
Public Sub ICUserModified ( _
    ICUserId As String _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


ICUserModifiedAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..ICUserModifiedAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously marks an IC user as modified.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void ICUserModifiedAsync(
    string ICUserId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub ICUserModifiedAsync ( _
    ICUserId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividual Method

[image]

IceLib Technical Reference
TrackerUser..::..IsUnknownOrSystemIndividual Method
TrackerUser Class See Also Send Feedback
Determines whether the specific Individual is unknown or a system Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool IsUnknownOrSystemIndividual(
    string individualId
)
Visual Basic
Public Function IsUnknownOrSystemIndividual ( _
    individualId As String _
) As Boolean

Parameters

individualId
Type: System..::..String
The ID of the Individual.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Individual is recognized; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


IsUnknownOrSystemIndividualAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..IsUnknownOrSystemIndividualAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously determines whether the specific Individual is unknown or a system Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void IsUnknownOrSystemIndividualAsync(
    string individualId,
    EventHandler<IsUnknownOrSystemIndividualCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub IsUnknownOrSystemIndividualAsync ( _
    individualId As String, _
    completedCallback As EventHandler(Of IsUnknownOrSystemIndividualCompletedEventArgs), _
    userState As Object _
)

Parameters

individualId
Type: System..::..String
The ID of the Individual.
completedCallback
Type: System..::..EventHandler<(Of <(<' IsUnknownOrSystemIndividualCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


SetIndividualImages Method

[image]

IceLib Technical Reference
TrackerUser..::..SetIndividualImages Method
TrackerUser Class See Also Send Feedback
Sets the image file for all IC users.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetIndividualImages(
    string image
)
Visual Basic
Public Sub SetIndividualImages ( _
    image As String _
)

Parameters

image
Type: System..::..String
The full UNC path of the image file.

Remarks

This method will set the same image file for all IC users. The supported image formats are .bmp, .jpg, .gif, .tif, .tiff, .png.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


SetIndividualImagesAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..SetIndividualImagesAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously sets the image file for all IC users.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetIndividualImagesAsync(
    string image,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetIndividualImagesAsync ( _
    image As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

image
Type: System..::..String
The full UNC path of the image file.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

This method will set the same image file for all IC users. The supported image formats are .bmp, .jpg, .gif, .tif, .tiff, .png.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


SetIndividualUrls Method

[image]

IceLib Technical Reference
TrackerUser..::..SetIndividualUrls Method
TrackerUser Class See Also Send Feedback
Sets the individual URLs.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetIndividualUrls(
    string url
)
Visual Basic
Public Sub SetIndividualUrls ( _
    url As String _
)

Parameters

url
Type: System..::..String
The URL.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


SetIndividualUrlsAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..SetIndividualUrlsAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously sets individual URLs.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SetIndividualUrlsAsync(
    string url,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetIndividualUrlsAsync ( _
    url As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

url
Type: System..::..String
The URL.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateAnnotation Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateAnnotation Method
TrackerUser Class See Also Send Feedback
Updates the Annotation.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateAnnotation(
    Annotation annotation
)
Visual Basic
Public Sub UpdateAnnotation ( _
    annotation As Annotation _
)

Parameters

annotation
Type: ININ.IceLib.Tracker..::..Annotation
The Annotation.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateAnnotationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateAnnotationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the Annotation.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateAnnotationAsync(
    Annotation annotation,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateAnnotationAsync ( _
    annotation As Annotation, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

annotation
Type: ININ.IceLib.Tracker..::..Annotation
The Annotation.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateApplicationIncidentId Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateApplicationIncidentId Method
TrackerUser Class See Also Send Feedback
Updates the application incident ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateApplicationIncidentId(
    string id,
    string applicationIncidentId
)
Visual Basic
Public Sub UpdateApplicationIncidentId ( _
    id As String, _
    applicationIncidentId As String _
)

Parameters

id
Type: System..::..String
The ID.
applicationIncidentId
Type: System..::..String
The application incident ID.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateApplicationIncidentIdAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateApplicationIncidentIdAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the application incident ID.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateApplicationIncidentIdAsync(
    string id,
    string applicationIncidentId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateApplicationIncidentIdAsync ( _
    id As String, _
    applicationIncidentId As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

id
Type: System..::..String
The ID.
applicationIncidentId
Type: System..::..String
The application incident ID.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateIndividual Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateIndividual Method
TrackerUser Class See Also Send Feedback
Updates the Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividual(
    Individual individual
)
Visual Basic
Public Sub UpdateIndividual ( _
    individual As Individual _
)

Parameters

individual
Type: ININ.IceLib.Tracker..::..Individual
The Individual to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateIndividualAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateIndividualAddress Method
TrackerUser Class See Also Send Feedback
Updates the IndividualAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualAddress(
    IndividualAddress individualAddress
)
Visual Basic
Public Sub UpdateIndividualAddress ( _
    individualAddress As IndividualAddress _
)

Parameters

individualAddress
Type: ININ.IceLib.Tracker..::..IndividualAddress
The IndividualAddress to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateIndividualAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateIndividualAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the IndividualAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualAddressAsync(
    IndividualAddress individualAddress,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateIndividualAddressAsync ( _
    individualAddress As IndividualAddress, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

individualAddress
Type: ININ.IceLib.Tracker..::..IndividualAddress
The IndividualAddress to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateIndividualAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateIndividualAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the Individual.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualAsync(
    Individual individual,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateIndividualAsync ( _
    individual As Individual, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

individual
Type: ININ.IceLib.Tracker..::..Individual
The Individual to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateIndividualInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateIndividualInteractionAddress Method
TrackerUser Class See Also Send Feedback
Updates the IndividualInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualInteractionAddress(
    IndividualInteractionAddress individualInteractionAddress
)
Visual Basic
Public Sub UpdateIndividualInteractionAddress ( _
    individualInteractionAddress As IndividualInteractionAddress _
)

Parameters

individualInteractionAddress
Type: ININ.IceLib.Tracker..::..IndividualInteractionAddress
The IndividualInteractionAddress to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateIndividualInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateIndividualInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the IndividualInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateIndividualInteractionAddressAsync(
    IndividualInteractionAddress individualInteractionAddress,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateIndividualInteractionAddressAsync ( _
    individualInteractionAddress As IndividualInteractionAddress, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

individualInteractionAddress
Type: ININ.IceLib.Tracker..::..IndividualInteractionAddress
The IndividualInteractionAddress to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateLocation Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateLocation Method
TrackerUser Class See Also Send Feedback
Updates the Location.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateLocation(
    Location location
)
Visual Basic
Public Sub UpdateLocation ( _
    location As Location _
)

Parameters

location
Type: ININ.IceLib.Tracker..::..Location
The Location to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateLocationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateLocationAddress Method
TrackerUser Class See Also Send Feedback
Updates the LocationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateLocationAddress(
    LocationAddress locationAddress
)
Visual Basic
Public Sub UpdateLocationAddress ( _
    locationAddress As LocationAddress _
)

Parameters

locationAddress
Type: ININ.IceLib.Tracker..::..LocationAddress
The LocationAddress to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateLocationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateLocationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the LocationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateLocationAddressAsync(
    LocationAddress locationAddress,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateLocationAddressAsync ( _
    locationAddress As LocationAddress, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

locationAddress
Type: ININ.IceLib.Tracker..::..LocationAddress
The LocationAddress to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateLocationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateLocationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the Location.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateLocationAsync(
    Location location,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateLocationAsync ( _
    location As Location, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

location
Type: ININ.IceLib.Tracker..::..Location
The Location to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateLocationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateLocationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Updates the LocationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateLocationInteractionAddress(
    LocationInteractionAddress locationInteractionAddress
)
Visual Basic
Public Sub UpdateLocationInteractionAddress ( _
    locationInteractionAddress As LocationInteractionAddress _
)

Parameters

locationInteractionAddress
Type: ININ.IceLib.Tracker..::..LocationInteractionAddress
The LocationInteractionAddress to update.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateLocationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateLocationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the LocationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateLocationInteractionAddressAsync(
    LocationInteractionAddress locationInteractionAddress,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateLocationInteractionAddressAsync ( _
    locationInteractionAddress As LocationInteractionAddress, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

locationInteractionAddress
Type: ININ.IceLib.Tracker..::..LocationInteractionAddress
The LocationInteractionAddress to update.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateOrganization Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateOrganization Method
TrackerUser Class See Also Send Feedback
Updates the Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganization(
    Organization organization
)
Visual Basic
Public Sub UpdateOrganization ( _
    organization As Organization _
)

Parameters

organization
Type: ININ.IceLib.Tracker..::..Organization
The Organization.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateOrganizationAddress Method
TrackerUser Class See Also Send Feedback
Updates the OrganizationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationAddress(
    OrganizationAddress organizationAddress
)
Visual Basic
Public Sub UpdateOrganizationAddress ( _
    organizationAddress As OrganizationAddress _
)

Parameters

organizationAddress
Type: ININ.IceLib.Tracker..::..OrganizationAddress
The OrganizationAddress.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateOrganizationAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the OrganizationAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationAddressAsync(
    OrganizationAddress organizationAddress,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateOrganizationAddressAsync ( _
    organizationAddress As OrganizationAddress, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

organizationAddress
Type: ININ.IceLib.Tracker..::..OrganizationAddress
OrganizationAddress.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateOrganizationAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the Organization.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationAsync(
    Organization organization,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateOrganizationAsync ( _
    organization As Organization, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

organization
Type: ININ.IceLib.Tracker..::..Organization
The Organization.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationInteractionAddress Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateOrganizationInteractionAddress Method
TrackerUser Class See Also Send Feedback
Updates the OrganizationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationInteractionAddress(
    OrganizationInteractionAddress organizationInteractionAddress
)
Visual Basic
Public Sub UpdateOrganizationInteractionAddress ( _
    organizationInteractionAddress As OrganizationInteractionAddress _
)

Parameters

organizationInteractionAddress
Type: ININ.IceLib.Tracker..::..OrganizationInteractionAddress
The OrganizationInteractionAddress.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateOrganizationInteractionAddressAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateOrganizationInteractionAddressAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the OrganizationInteractionAddress.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateOrganizationInteractionAddressAsync(
    OrganizationInteractionAddress organizationInteractionAddress,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateOrganizationInteractionAddressAsync ( _
    organizationInteractionAddress As OrganizationInteractionAddress, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

organizationInteractionAddress
Type: ININ.IceLib.Tracker..::..OrganizationInteractionAddress
The OrganizationInteractionAddress.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateUserSecurity Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateUserSecurity Method
TrackerUser Class See Also Send Feedback
Updates the user security.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateUserSecurity(
    string ICUserId,
    long securityChecksum,
    string viewableUsers
)
Visual Basic
Public Sub UpdateUserSecurity ( _
    ICUserId As String, _
    securityChecksum As Long, _
    viewableUsers As String _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.
securityChecksum
Type: System..::..Int64
The security checksum.
viewableUsers
Type: System..::..String
The viewable users.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib..::..IceLibLicenseException | The client does not have the license required to perform this operation.
ININ.IceLib..::..IceLibException | An error occurred while executing the transaction. See the LastError property of this object's TransactionClient for more information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UpdateUserSecurityAsync Method

[image]

IceLib Technical Reference
TrackerUser..::..UpdateUserSecurityAsync Method
TrackerUser Class See Also Send Feedback
Asynchronously updates the user security.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateUserSecurityAsync(
    string ICUserId,
    long securityChecksum,
    string viewableUsers,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateUserSecurityAsync ( _
    ICUserId As String, _
    securityChecksum As Long, _
    viewableUsers As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

ICUserId
Type: System..::..String
The IC user ID.
securityChecksum
Type: System..::..Int64
The security checksum.
viewableUsers
Type: System..::..String
The viewable users.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The completed callback.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


TrackerUser Properties

[image] [image]

IceLib Technical Reference
TrackerUser Properties
TrackerUser Class See Also Send Feedback

The TrackerUser type exposes the following members.

Properties

 | Name | Description
Public property | TransactionClient | Gets the TransactionClient.

See Also

TrackerUser Class
ININ.IceLib.Tracker Namespace


TransactionClient Property

[image]

IceLib Technical Reference
TrackerUser..::..TransactionClient Property
TrackerUser Class See Also Send Feedback
Gets the TransactionClient.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public TransactionClient TransactionClient { get; }
Visual Basic
Public ReadOnly Property TransactionClient As TransactionClient
    Get

Field Value

The TransactionClient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

TrackerUser Class
TrackerUser Members
ININ.IceLib.Tracker Namespace


UserTrackerRightsAttributes Class

[image]

IceLib Technical Reference
UserTrackerRightsAttributes Class
Members See Also Send Feedback
Attribute strings for the UserTrackerRightsSettings watched class.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class UserTrackerRightsAttributes
Visual Basic
Public NotInheritable Class UserTrackerRightsAttributes

Remarks

The attribute names specified in this class are used in conjunction with the synchronous and asynchronous StartWatching and ChangeWatchedAttributes methods in the UserTrackerRightsSettings class.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Tracker..::..UserTrackerRightsAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace
ININ.IceLib.Tracker..::..UserTrackerRightsSettings


UserTrackerRightsAttributes Members

[image] [image]

IceLib Technical Reference
UserTrackerRightsAttributes Members
UserTrackerRightsAttributes Class Fields See Also Send Feedback

The UserTrackerRightsAttributes type exposes the following members.

Fields

Name | Description
AllowRelatedInteractionsPage | Allows the user to use the related interactions page.
CanAddIndividuals | Allows the user to add individuals.
CanAddOrganizations | Allows the user to add organizations.
CanAddPrivateIndividuals | Allows the user to add private individuals.
CanDeleteIndividuals | Allows the user to delete individuals.
CanDeleteOrganizations | Allows the user to delete organizations.
CanPerformTrackerAdministration | Allows the user to perform Tracker administration.
CanUpdateIndividuals | Allows the user to update individuals.
CanUpdateInteractions | Allows the user to update interactions.
CanUpdateOrganizations | Allows the user to update organizations.
CanViewNonParticipantInteractions | Allows the user to view Interactions when they are not a participant.
ViewUserInteractionHistory | Indicates which users' interaction history the user has permission to view.

See Also

UserTrackerRightsAttributes Class
ININ.IceLib.Tracker Namespace


UserTrackerRightsAttributes Fields

[image] [image]

IceLib Technical Reference
UserTrackerRightsAttributes Fields
UserTrackerRightsAttributes Class See Also Send Feedback

The UserTrackerRightsAttributes type exposes the following members.

Fields

Name | Description
AllowRelatedInteractionsPage | Allows the user to use the related interactions page.
CanAddIndividuals | Allows the user to add individuals.
CanAddOrganizations | Allows the user to add organizations.
CanAddPrivateIndividuals | Allows the user to add private individuals.
CanDeleteIndividuals | Allows the user to delete individuals.
CanDeleteOrganizations | Allows the user to delete organizations.
CanPerformTrackerAdministration | Allows the user to perform Tracker administration.
CanUpdateIndividuals | Allows the user to update individuals.
CanUpdateInteractions | Allows the user to update interactions.
CanUpdateOrganizations | Allows the user to update organizations.
CanViewNonParticipantInteractions | Allows the user to view Interactions when they are not a participant.
ViewUserInteractionHistory | Indicates which users' interaction history the user has permission to view.

See Also

UserTrackerRightsAttributes Class
ININ.IceLib.Tracker Namespace


AllowRelatedInteractionsPage Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..AllowRelatedInteractionsPage Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to use the related interactions page.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string AllowRelatedInteractionsPage
Visual Basic
Public Shared ReadOnly AllowRelatedInteractionsPage As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanAddIndividuals Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanAddIndividuals Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to add individuals.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAddIndividuals
Visual Basic
Public Shared ReadOnly CanAddIndividuals As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanAddOrganizations Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanAddOrganizations Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to add organizations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAddOrganizations
Visual Basic
Public Shared ReadOnly CanAddOrganizations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanAddPrivateIndividuals Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanAddPrivateIndividuals Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to add private individuals.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanAddPrivateIndividuals
Visual Basic
Public Shared ReadOnly CanAddPrivateIndividuals As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanDeleteIndividuals Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanDeleteIndividuals Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to delete individuals.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanDeleteIndividuals
Visual Basic
Public Shared ReadOnly CanDeleteIndividuals As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanDeleteOrganizations Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanDeleteOrganizations Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to delete organizations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanDeleteOrganizations
Visual Basic
Public Shared ReadOnly CanDeleteOrganizations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanPerformTrackerAdministration Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanPerformTrackerAdministration Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to perform Tracker administration.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanPerformTrackerAdministration
Visual Basic
Public Shared ReadOnly CanPerformTrackerAdministration As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanUpdateIndividuals Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanUpdateIndividuals Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to update individuals.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanUpdateIndividuals
Visual Basic
Public Shared ReadOnly CanUpdateIndividuals As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanUpdateInteractions Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanUpdateInteractions Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to update interactions.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanUpdateInteractions
Visual Basic
Public Shared ReadOnly CanUpdateInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanUpdateOrganizations Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanUpdateOrganizations Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to update organizations.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanUpdateOrganizations
Visual Basic
Public Shared ReadOnly CanUpdateOrganizations As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


CanViewNonParticipantInteractions Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..CanViewNonParticipantInteractions Field
UserTrackerRightsAttributes Class See Also Send Feedback
Allows the user to view Interactions when they are not a participant.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string CanViewNonParticipantInteractions
Visual Basic
Public Shared ReadOnly CanViewNonParticipantInteractions As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


ViewUserInteractionHistory Field

[image]

IceLib Technical Reference
UserTrackerRightsAttributes..::..ViewUserInteractionHistory Field
UserTrackerRightsAttributes Class See Also Send Feedback
Indicates which users' interaction history the user has permission to view.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly string ViewUserInteractionHistory
Visual Basic
Public Shared ReadOnly ViewUserInteractionHistory As String

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserTrackerRightsAttributes Class
UserTrackerRightsAttributes Members
ININ.IceLib.Tracker Namespace


UserTrackerRightsSettings Class

[image]

IceLib Technical Reference
UserTrackerRightsSettings Class
Members See Also Send Feedback
Represents the basic user rights settings for an IC user. User rights are set in Interaction Administrator at the Default User, User or Workgroup level.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UserTrackerRightsSettings : UserSettings
Visual Basic
Public Class UserTrackerRightsSettings _
    Inherits UserSettings

Remarks

Note
The strings for the StartWatching(array<String>[]()[][])and ChangeWatchedAttributes(array<String>[]()[][], array<String>[]()[][], Boolean) methods for this derived class are defined in UserTrackerRightsAttributes however custom strings may also be used for custom handlers.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.People..::..UserSettings
ININ.IceLib.Tracker..::..UserTrackerRightsSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


UserTrackerRightsSettings Members

[image] [image]

IceLib Technical Reference
UserTrackerRightsSettings Members
UserTrackerRightsSettings Class Constructors Methods Properties Events See Also Send Feedback

The UserTrackerRightsSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserTrackerRightsSettings | Initializes a new instance of the UserTrackerRightsSettings class for the current session user.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanAddIndividuals | Gets the CanAddIndividuals value.
Public property | CanAddOrganizations | Gets the CanAddOrganizations value.
Public property | CanAddPrivateIndividuals | Gets the CanAddPrivateIndividuals value.
Public property | CanDeleteIndividuals | Gets the CanDeleteIndividuals value.
Public property | CanDeleteOrganizations | Gets the CanDeleteOrganizations value.
Public property | CanPerformTrackerAdministration | Gets the CanPerformTrackerAdministration value.
Public property | CanUpdateIndividuals | Gets the CanUpdateIndividuals value.
Public property | CanUpdateInteractions | Gets the CanUpdateInteractions value.
Public property | CanUpdateOrganizations | Gets the CanUpdateOrganizations value.
Public property | CanUseRelatedInteractionsPage | Gets a value indicating whether this instance can use the related interactions page.
Public property | CanViewNonParticipantInteractions | Gets the CanViewNonParticipantInteractions value.
Public property | ViewUserInteractionHistory | Gets a value indicating which users' interaction history the user has permission to view.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserTrackerRightsSettings Class
ININ.IceLib.Tracker Namespace


UserTrackerRightsSettings Constructor

[image]

IceLib Technical Reference
UserTrackerRightsSettings Constructor
UserTrackerRightsSettings Class See Also Send Feedback
Initializes a new instance of the UserTrackerRightsSettings class for the current session user.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public UserTrackerRightsSettings(
    PeopleManager peopleManager
)
Visual Basic
Public Sub New ( _
    peopleManager As PeopleManager _
)

Parameters

peopleManager
Type: ININ.IceLib.People..::..PeopleManager
A PeopleManager instance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


UserTrackerRightsSettings Methods

[image] [image]

IceLib Technical Reference
UserTrackerRightsSettings Methods
UserTrackerRightsSettings Class See Also Send Feedback

The UserTrackerRightsSettings type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchedAttributes | Changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | ChangeWatchedAttributesAsync | Asynchronously changes what attributes of the UserSettings are being watch. (Inherited from UserSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeAsBool | Gets boolean value for the named attribute. A trueTruetruetrue (True in Visual Basic) boolean attribute has a string value. of "Yes". (Inherited from UserSettings.)
Public method | GetAttributeAsString | Gets the values for the named attribute. (Inherited from UserSettings.)
Public method | GetAttributeAsStrings | Gets the string values for the named attribute. (Inherited from UserSettings.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWatching()()()() | Determines whether a watch is active. (Inherited from UserSettings.)
Public method | IsWatching(String) | Determines whether a watch is active and if the specified value is being watched. (Inherited from UserSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttributeFromBool | Sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromBoolAsync | Asynchronously sets attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromString | Sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringAsync | Asynchronously sets the attribute value and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStrings | Sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | SetAttributeFromStringsAsync | Asynchronously sets attribute value based on strings and propagates the changes. (Inherited from UserSettings.)
Public method | StartWatching | Starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StartWatchingAsync | Asynchronously starts watching the specified attributeNames for these UserSettings. (Inherited from UserSettings.)
Public method | StopWatching | Stops watching user settings. (Inherited from UserSettings.)
Public method | StopWatchingAsync | Asynchronously stops watching user settings. (Inherited from UserSettings.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserTrackerRightsSettings Class
ININ.IceLib.Tracker Namespace


UserTrackerRightsSettings Properties

[image] [image]

IceLib Technical Reference
UserTrackerRightsSettings Properties
UserTrackerRightsSettings Class See Also Send Feedback

The UserTrackerRightsSettings type exposes the following members.

Properties

 | Name | Description
Public property | CanAddIndividuals | Gets the CanAddIndividuals value.
Public property | CanAddOrganizations | Gets the CanAddOrganizations value.
Public property | CanAddPrivateIndividuals | Gets the CanAddPrivateIndividuals value.
Public property | CanDeleteIndividuals | Gets the CanDeleteIndividuals value.
Public property | CanDeleteOrganizations | Gets the CanDeleteOrganizations value.
Public property | CanPerformTrackerAdministration | Gets the CanPerformTrackerAdministration value.
Public property | CanUpdateIndividuals | Gets the CanUpdateIndividuals value.
Public property | CanUpdateInteractions | Gets the CanUpdateInteractions value.
Public property | CanUpdateOrganizations | Gets the CanUpdateOrganizations value.
Public property | CanUseRelatedInteractionsPage | Gets a value indicating whether this instance can use the related interactions page.
Public property | CanViewNonParticipantInteractions | Gets the CanViewNonParticipantInteractions value.
Public property | ViewUserInteractionHistory | Gets a value indicating which users' interaction history the user has permission to view.

See Also

UserTrackerRightsSettings Class
ININ.IceLib.Tracker Namespace


CanAddIndividuals Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanAddIndividuals Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanAddIndividuals value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAddIndividuals { get; }
Visual Basic
Public ReadOnly Property CanAddIndividuals As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can add individuals; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanAddOrganizations Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanAddOrganizations Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanAddOrganizations value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAddOrganizations { get; }
Visual Basic
Public ReadOnly Property CanAddOrganizations As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can add organizations; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanAddPrivateIndividuals Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanAddPrivateIndividuals Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanAddPrivateIndividuals value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanAddPrivateIndividuals { get; }
Visual Basic
Public ReadOnly Property CanAddPrivateIndividuals As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can add private individuals; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanDeleteIndividuals Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanDeleteIndividuals Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanDeleteIndividuals value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteIndividuals { get; }
Visual Basic
Public ReadOnly Property CanDeleteIndividuals As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can delete individuals; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanDeleteOrganizations Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanDeleteOrganizations Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanDeleteOrganizations value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanDeleteOrganizations { get; }
Visual Basic
Public ReadOnly Property CanDeleteOrganizations As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can delete organizations; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanPerformTrackerAdministration Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanPerformTrackerAdministration Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanPerformTrackerAdministration value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanPerformTrackerAdministration { get; }
Visual Basic
Public ReadOnly Property CanPerformTrackerAdministration As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can perform Tracker administration; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanUpdateIndividuals Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanUpdateIndividuals Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanUpdateIndividuals value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUpdateIndividuals { get; }
Visual Basic
Public ReadOnly Property CanUpdateIndividuals As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can update individuals; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanUpdateInteractions Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanUpdateInteractions Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanUpdateInteractions value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUpdateInteractions { get; }
Visual Basic
Public ReadOnly Property CanUpdateInteractions As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can update interactions; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanUpdateOrganizations Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanUpdateOrganizations Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanUpdateOrganizations value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUpdateOrganizations { get; }
Visual Basic
Public ReadOnly Property CanUpdateOrganizations As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can update organizations; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanUseRelatedInteractionsPage Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanUseRelatedInteractionsPage Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets a value indicating whether this instance can use the related interactions page.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanUseRelatedInteractionsPage { get; }
Visual Basic
Public ReadOnly Property CanUseRelatedInteractionsPage As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can use the related interactions page; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


CanViewNonParticipantInteractions Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..CanViewNonParticipantInteractions Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets the CanViewNonParticipantInteractions value.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool CanViewNonParticipantInteractions { get; }
Visual Basic
Public ReadOnly Property CanViewNonParticipantInteractions As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance can view Interactions when they are not a participant; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | The associated attribute is not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


ViewUserInteractionHistory Property

[image]

IceLib Technical Reference
UserTrackerRightsSettings..::..ViewUserInteractionHistory Property
UserTrackerRightsSettings Class See Also Send Feedback
Gets a value indicating which users' interaction history the user has permission to view.

Namespace: ININ.IceLib.Tracker
Assembly: ININ.IceLib.Tracker (in ININ.IceLib.Tracker.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> ViewUserInteractionHistory { get; }
Visual Basic
Public ReadOnly Property ViewUserInteractionHistory As ReadOnlyCollection(Of String)
    Get

Field Value

A read only collection of string IC User Ids whose interaction history the user has permission to view.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 6 and beyond.

See Also

UserTrackerRightsSettings Class
UserTrackerRightsSettings Members
ININ.IceLib.Tracker Namespace


UserTrackerRightsSettings Events

[image] [image]

IceLib Technical Reference
UserTrackerRightsSettings Events
UserTrackerRightsSettings Class See Also Send Feedback

The UserTrackerRightsSettings type exposes the following members.

Events

 | Name | Description
Public event | WatchedAttributesChanged | Occurs when one of the watched attribute values has been changed. (Inherited from UserSettings.)

See Also

UserTrackerRightsSettings Class
ININ.IceLib.Tracker Namespace


ININ.IceLib.UnifiedMessaging Namespace

[image]

IceLib Technical Reference
ININ.IceLib.UnifiedMessaging Namespace
Send Feedback

The ININ.IceLib.UnifiedMessaging namespace contains classes for manipulating and managing Interaction Center Voicemails and Faxes.

Working with Voicemails

The voicemail functionality is implemented by classes that allow you to manage and playback voice messages received by an IC server as well as to monitor for new incoming messages.

Voicemail Retrieval

A list of current voicemail messages can be retrieved via the Voicemails property on the UnifiedMessagingManager class. To populate this list, the local Voicemail Cache must first be refreshed by calling RefreshVoicemailCache(Int32). A call to RefreshVoicemailCache(Int32) can be made at any time. Refreshing the cache will cause the following events to be fired, if applicable: NewVoicemail, VoicemailUpdated, or VoicemailDeleted.

Voicemail Playback

The primary playback functionality is available through the VoicemailMessage class. This class allows a developer to play a voice message to any of the following locations:

  • Telephone Handset (PlayToHandset(VoicemailAttachment, Boolean)) - The handset associated with the station a user is currently logged into. In the case of SIP audio this handset would be speakers or headphones. In a traditional phone setup the handset is typically a phone receiver.
  • Number (PlayToNumber(VoicemailAttachment, String, Boolean, Boolean)) - A remote phone number
  • Station (PlayToStation(VoicemailAttachment, String, Boolean, Boolean)) - A station defined in IC

An instance of a VoicemailMessage contains zero or more VoicemailAttachment items. Each VoicemailAttachment represents an attachment to the voicemail that can be downloaded to a local file by calling SaveAsFile(VoicemailAttachment, String, Boolean).

Note
A VoicemailAttachment may (or may not) reference an audio file. When unified messaging is employed such that voicemails are stored within email messages, other arbitrary files can be added to the email (and show up as a VoicemailAttachment).

Examples

The example below iterates the list of available voicemail messages and downloads each message to a new local file. It is not recommended to use synchronous methods in client applications, nor is it recommended to download all voicemail files in this manner. This is purely a syntax usage example only.

CopyC#
// "session" is a valid ININ.IceLib.Connection.Session instance.
UnifiedMessagingManager manager = UnifiedMessagingManager.GetInstance(session);
manager.RefreshVoicemailCache(-1);
foreach (VoicemailMessage message in manager.Voicemails)
{
  foreach (VoicemailAttachment attachment in message.Attachments)
  {
    string fileName = System.IO.Path.GetTempFileName();
    message.SaveAsFile(attachment, fileName, false /* Don't mark as read */);
  }
}

Working with Faxes

The Fax functionality consists of a set of classes that allow you to manipulate and submit Faxes to an IC server for delivery, monitor all outgoing Fax activity for a logged-in user, and manage and download Fax messages received by an IC server.

Fax Retrieval

A list of current Fax messages can be retrieved via the Faxes property on the UnifiedMessagingManager class. To populate this list, the local Fax Cache must first be refreshed by calling RefreshFaxCache(Int32). A call to RefreshFaxCache(Int32) can be made at any time. Refreshing the cache will cause the following events to be fired, if applicable: NewFax, FaxUpdated, or FaxDeleted.

An instance of a FaxMessage contains zero or more FaxAttachment items. Each FaxAttachment represents an attachment to the Fax message that can be downloaded to a local file by calling SaveAsFile(FaxAttachment, String, Boolean).

Note
A FaxAttachment may (or may not) reference a Fax file. When unified messaging is employed such that Faxes are stored within email messages, other arbitrary files can be added to the Email (and show up as a FaxAttachment).

Examples

The example below iterates the list of available Fax messages and downloads each message to a new local file. It is not recommended to use synchronous methods in client applications, nor is it recommended to download all Fax files in this manner. This is purely a syntax usage example only.

CopyC#
// "session" is a valid ININ.IceLib.Connection.Session instance.
UnifiedMessagingManager manager = UnifiedMessagingManager.GetInstance(session);
manager.RefreshFaxCache(-1);
foreach (FaxMessage message in manager.Faxes)
{
  foreach (FaxAttachment attachment in message.Attachments)
  {
    string fileName = System.IO.Path.GetTempFileName();
    message.SaveAsFile(attachment, fileName, false /* Don't mark as read */);
  }
}

Fax Sending and Monitoring

Functionality that includes sending and monitoring Interaction Faxes are separated into a collection of Images, Attributes and Envelopes all available through a central class, FaxFile.

In addition to the viewing and editing capability exposed through the FaxFile, you also have the ability to send a Fax through the IC server. Faxes are addressed by using the AddEnvelope(FaxEnvelope) method on the FaxFile to add a new FaxEnvelope. Once a Fax has been assigned one or more envelopes, it is ready to be used in a call to SendFax(String) to have it submitted to the IC server for delivery.

Monitoring the status of outgoing Faxes is enabled through a call to EnableFaxMonitoring(Boolean). An application that has enabled monitoring for an IC user will periodically receive FaxMonitorUpdate events to indicate the state of each Fax being processed on the IC server on behalf of that user.

Examples

The following example demonstrates the processing of an incoming FaxMonitorUpdate event.

CopyC#
...
private delegate void UpdateStatusListDel(FaxStatus statusUpdate);

private void FaxMonitorUpdateHandler(object sender, FaxMonitorUpdateEventArgs e)
{
    if (this.InvokeRequired)
    {
        UpdateStatusListDel del = new UpdateStatusListDel(UpdateStatusList);
        this.BeginInvoke(del, new object[]{e.FaxStatus});
    }
    else
    {
        UpdateStatusList(e.FaxStatus);
    }
}

private void UpdateStatusList(FaxStatus statusUpdate)
{
    if (statusUpdate.Code == FaxStatusCode.None)
    {
        // Ignoring update for invalid status.
        return;
    }

    // Search for a row containing the envelope ID.  If we don't find it
    // then add a new row, otherwise update the current line
    ListViewItem newItem = null;
    BuildListItem(statusUpdate, out newItem);

    int nItemIdx = FindEnvelopeInList(statusUpdate.EnvelopeId);
    if (nItemIdx != -1)
    {
        // Replacing envelope at nItemIdx with new item
        statusList.Items[nItemIdx] = newItem;
    }
    else
        statusList.Items.Add(newItem);
}

private int FindEnvelopeInList(Int64 searchId)
{
    int nEnvelopeIndex = -1;
    lock (statusList.Items)
    {
        foreach (ListViewItem currentItem in this.statusList.Items)
        {
            Int64 envelopeId = (Int64)currentItem.Tag;
            if (searchId == envelopeId)
            {
                nEnvelopeIndex = this.statusList.Items.IndexOf(currentItem);
                break;
            }
        }
    }

    return nEnvelopeIndex;
}

Classes

Class Description
Public class AsyncGetFaxPropertiesEventArgs
Provides data for the GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object) completedCallback.
Public class AsyncGetFaxServerSettingsCompletedEventArgs
Provides data for the GetFaxServerSettingsAsync(EventHandler<(Of <<'(AsyncGetFaxServerSettingsCompletedEventArgs>)>>), Object) completedCallback.
Public class AsyncSaveAsFileCompletedEventArgs
Provides data for the SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) event.
Public class AsyncSendFaxCompletedEventArgs
Provides data for the SendFaxAsync(String, EventHandler<(Of <<'(AsyncSendFaxCompletedEventArgs>)>>), Object) completedCallback that occurs when the asynchronous operation completes.
Public class AttributeEventArgs
Provides data for the Fax attribute change event.
Public class FaxAddressee
The addressee who will be receiving a Fax.
Public class FaxAttachment
Represents an attachment (containing the actual Fax file) in a FaxMessage.
Public class FaxCoverPageTemplate
The information used to control generation of a Fax cover page.
Public class FaxDeliveryNotification
Controls notifications about the delivery state of a Fax.
Public class FaxDeliverySchedule
Controls when a Fax will be delivered to an addressee.
Public class FaxEnvelope
Stores information related to the delivery of a Fax file.
Public class FaxEnvelopeProperties
Class to contain the properties of a fax in progress. An instance of FaxEnvelopeProperties is created as a result of a call to GetFaxProperties(Int64) or GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object). In the case of the latter this object is returned in the AsyncGetFaxPropertiesEventArgs object. Objects of this class contain all of the important information about a fax and can be used whenever you want to display properties of an on-going fax.

Examples

The following example demonstrates getting the properties of an on-going fax.
CopyC#
  private void GetFaxProperties(FaxStatus status)
  {
        if (_UnifiedMessagingManager != null)
        {
            _UnifiedMessagingManager.GetFaxPropertiesAsync(Convert.ToInt32(status.EnvelopeId), new EventHandler<AsyncGetFaxPropertiesEventArgs>(OnGetFaxPropertiesCompleted), null);
        }
 }
 private void OnGetFaxPropertiesCompleted(object sender, AsyncGetFaxPropertiesEventArgs args)
{
    if (args.Error != null)
    {
        MessageBox.Show(this, args.Error.Message, "Fax Monitor", MessageBoxButtons.OK, MessageBoxIcon.Exclamation);
    }
    else
    {
        //Do something here to display the fax properties data
    }
}
Public class FaxEventArgs
Provides data for the NewFax, FaxDeleted, and FaxUpdated events.
Public class FaxFile
Provides an interface for manipulating Fax files on a file system in .i3f or .TIF format.
Public class FaxMessage
Represents a Fax message within the Interaction Center system.
Public class FaxMonitorUpdateEventArgs
Provides the FaxStatus for the FaxMonitorUpdate event.
Public class FaxPageAttributes
Specifies display preferences used to render a Fax page image.
Public class FaxPageSettings
Stores information on how a fax page is to be formatted when it is sent.
Public class FaxRecipient
Represents a recipient of a FaxMessage.
Public class FaxResult
Represents the result of a send Fax operation.
Public class FaxServerSettings
Represents the Fax configuration settings on an IC server.
Public class FaxStatus
Represent the progress of a Fax that was submitted for delivery.
Public class FaxTransmitOptions
Represents Fax device configuration information.
Public class RateLimitedException
The exception that is thrown when requests to refresh a voicemail or fax have been sent too frequently.
Public class UnifiedMessagingManager
Provides access to the UnifiedMessaging namespace.
Public class VoicemailAttachment
Represents an attachment (containing the actual Voicemail message) in a VoicemailMessage.
Public class VoicemailEventArgs
Provides data for the NewVoicemail, VoicemailDeleted, and VoicemailUpdated events.
Public class VoicemailMessage
Represents a Voicemail message within the Interaction Center system.
Public class VoicemailRecipient
Represents both a recipient and sender of a VoicemailMessage.
Public class VoicemailServerPlayResultEventArgs
Provides data for the VoicemailServerPlayResult event.
Public class VoiceMessageServerPlayResult
The result sent back from the server when a Voicemail was played to the user.

Structures

 | Structure | Description
Public structure | PageResolution | Represent the vertical and horizontal resolution of a Fax Page.

Enumerations

 | Enumeration | Description
Public enumeration | CallFailureType | Indicates the type of call failure occurring during fax transmission.
Public enumeration | EventAttributeType | Indicates the attribute that changed to trigger an attribute change event.
Public enumeration | FaxColorScheme | Indicates the color choice for displaying a Fax page.
Public enumeration | FaxDeliveryType | Indicates when a fax should be delivered.
Public enumeration | FaxImageQuality | Specifies the resolutions that can be used for the fax image.
Public enumeration | FaxImageSettings | Provides flags indicating how an image should be processed in preparation for faxing.
Public enumeration | FaxOrientation | Indicates orientation for a Fax page (horizontal and vertical).
Public enumeration | FaxPageSize | Enumerates various paper sizes that can be used for faxing.
Public enumeration | FaxRotation | Indicates direction of rotation for a Fax page.
Public enumeration | FaxStatusCode | Indicates the current status of a fax.
Public enumeration | RetryStrategyType | Determines the strategy employed on how a fax should be resent.
Public enumeration | StorageFormat | Indicates the storage format used when loading or saving Fax data in files.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.


AsyncGetFaxPropertiesEventArgs Class

[image]

IceLib Technical Reference
AsyncGetFaxPropertiesEventArgs Class
Members See Also Send Feedback
Provides data for the GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object) completedCallback.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncGetFaxPropertiesEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncGetFaxPropertiesEventArgs _
    Inherits AsyncCompletedEventArgs

Remarks

Provide a completedCallback. delegate to be informed when a call to GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object) has completed.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.UnifiedMessaging..::..AsyncGetFaxPropertiesEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncGetFaxPropertiesEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxPropertiesEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncGetFaxPropertiesEventArgs Members
AsyncGetFaxPropertiesEventArgs Class Constructors Methods Properties See Also Send Feedback

The AsyncGetFaxPropertiesEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AsyncGetFaxPropertiesEventArgs | Returns the FaxEnvelopeProperties in the GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object) completedCallback delegate.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FaxEnvelopeProperties | Gets the fax envelope properties.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetFaxPropertiesEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxPropertiesEventArgs Constructor

[image]

IceLib Technical Reference
AsyncGetFaxPropertiesEventArgs Constructor
AsyncGetFaxPropertiesEventArgs Class See Also Send Feedback
Returns the FaxEnvelopeProperties in the GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object) completedCallback delegate.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AsyncGetFaxPropertiesEventArgs(
    FaxEnvelopeProperties faxEnvelopeProperties,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    faxEnvelopeProperties As FaxEnvelopeProperties, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

faxEnvelopeProperties
Type: ININ.IceLib.UnifiedMessaging..::..FaxEnvelopeProperties
The FaxEnvelopeProperties to return.
error
Type: System..::..Exception
Any exception if it occurs, nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.
cancelled
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) if the asynchronous operation is cancelled, falseFalsefalsefalse (False in Visual Basic) otherwise.
userState
Type: System..::..Object
The user-specified object provided to the asynchronous operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncGetFaxPropertiesEventArgs Class
AsyncGetFaxPropertiesEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxPropertiesEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncGetFaxPropertiesEventArgs Methods
AsyncGetFaxPropertiesEventArgs Class See Also Send Feedback

The AsyncGetFaxPropertiesEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncGetFaxPropertiesEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxPropertiesEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncGetFaxPropertiesEventArgs Properties
AsyncGetFaxPropertiesEventArgs Class See Also Send Feedback

The AsyncGetFaxPropertiesEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FaxEnvelopeProperties | Gets the fax envelope properties.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetFaxPropertiesEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelopeProperties Property

[image]

IceLib Technical Reference
AsyncGetFaxPropertiesEventArgs..::..FaxEnvelopeProperties Property
AsyncGetFaxPropertiesEventArgs Class See Also Send Feedback
Gets the fax envelope properties.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEnvelopeProperties FaxEnvelopeProperties { get; }
Visual Basic
Public ReadOnly Property FaxEnvelopeProperties As FaxEnvelopeProperties
    Get

Field Value

The fax envelope properties.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncGetFaxPropertiesEventArgs Class
AsyncGetFaxPropertiesEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxServerSettingsCompletedEventArgs Class

[image]

IceLib Technical Reference
AsyncGetFaxServerSettingsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the GetFaxServerSettingsAsync(EventHandler<(Of <<'(AsyncGetFaxServerSettingsCompletedEventArgs>)>>), Object) completedCallback.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncGetFaxServerSettingsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncGetFaxServerSettingsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Remarks

Provide a completedCallback. delegate to be informed when a call to GetFaxServerSettingsAsync(EventHandler<(Of <<'(AsyncGetFaxServerSettingsCompletedEventArgs>)>>), Object) has completed.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.UnifiedMessaging..::..AsyncGetFaxServerSettingsCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncGetFaxServerSettingsCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxServerSettingsCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncGetFaxServerSettingsCompletedEventArgs Members
AsyncGetFaxServerSettingsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The AsyncGetFaxServerSettingsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AsyncGetFaxServerSettingsCompletedEventArgs | Returns the FaxServerSettings in the GetFaxServerSettingsAsync(EventHandler<(Of <<'(AsyncGetFaxServerSettingsCompletedEventArgs>)>>), Object) completedCallback delegate.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FaxServerSettings | Gets or sets the FaxServerSettings.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetFaxServerSettingsCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxServerSettingsCompletedEventArgs Constructor

[image]

IceLib Technical Reference
AsyncGetFaxServerSettingsCompletedEventArgs Constructor
AsyncGetFaxServerSettingsCompletedEventArgs Class See Also Send Feedback
Returns the FaxServerSettings in the GetFaxServerSettingsAsync(EventHandler<(Of <<'(AsyncGetFaxServerSettingsCompletedEventArgs>)>>), Object) completedCallback delegate.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AsyncGetFaxServerSettingsCompletedEventArgs(
    FaxServerSettings faxServerSettings,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    faxServerSettings As FaxServerSettings, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

faxServerSettings
Type: ININ.IceLib.UnifiedMessaging..::..FaxServerSettings
The FaxServerSettings to return.
error
Type: System..::..Exception
Any exception if it occurs, nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.
cancelled
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) if the asynchronous operation is cancelled, falseFalsefalsefalse (False in Visual Basic) otherwise.
userState
Type: System..::..Object
The user-specified object provided to the asynchronous operation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncGetFaxServerSettingsCompletedEventArgs Class
AsyncGetFaxServerSettingsCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxServerSettingsCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncGetFaxServerSettingsCompletedEventArgs Methods
AsyncGetFaxServerSettingsCompletedEventArgs Class See Also Send Feedback

The AsyncGetFaxServerSettingsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncGetFaxServerSettingsCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncGetFaxServerSettingsCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncGetFaxServerSettingsCompletedEventArgs Properties
AsyncGetFaxServerSettingsCompletedEventArgs Class See Also Send Feedback

The AsyncGetFaxServerSettingsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FaxServerSettings | Gets or sets the FaxServerSettings.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncGetFaxServerSettingsCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxServerSettings Property

[image]

IceLib Technical Reference
AsyncGetFaxServerSettingsCompletedEventArgs..::..FaxServerSettings Property
AsyncGetFaxServerSettingsCompletedEventArgs Class See Also Send Feedback
Gets or sets the FaxServerSettings.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxServerSettings FaxServerSettings { get; set; }
Visual Basic
Public Property FaxServerSettings As FaxServerSettings
    Get
    Set

Field Value

The Fax server settings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncGetFaxServerSettingsCompletedEventArgs Class
AsyncGetFaxServerSettingsCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncSaveAsFileCompletedEventArgs Class

[image]

IceLib Technical Reference
AsyncSaveAsFileCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncSaveAsFileCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncSaveAsFileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Remarks

Handle the SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) event to be informed when a call to SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) has completed.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.UnifiedMessaging..::..AsyncSaveAsFileCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncSaveAsFileCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncSaveAsFileCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncSaveAsFileCompletedEventArgs Members
AsyncSaveAsFileCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The AsyncSaveAsFileCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AsyncSaveAsFileCompletedEventArgs | Constructs an instance of AsyncSaveAsFileCompletedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SaveAsCompleted | Indicates whether the SaveAs operation completed successfully.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncSaveAsFileCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncSaveAsFileCompletedEventArgs Constructor

[image]

IceLib Technical Reference
AsyncSaveAsFileCompletedEventArgs Constructor
AsyncSaveAsFileCompletedEventArgs Class See Also Send Feedback
Constructs an instance of AsyncSaveAsFileCompletedEventArgs.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AsyncSaveAsFileCompletedEventArgs(
    bool saveAsCompleted,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    saveAsCompleted As Boolean, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

saveAsCompleted
Type: System..::..Boolean
Set from the result value of the SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) method.
error
Type: System..::..Exception
An exception thrown by the SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) method.
cancelled
Type: System..::..Boolean
The cancelled state of the SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) method.
userState
Type: System..::..Object
A user-defined object passed to SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncSaveAsFileCompletedEventArgs Class
AsyncSaveAsFileCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncSaveAsFileCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncSaveAsFileCompletedEventArgs Methods
AsyncSaveAsFileCompletedEventArgs Class See Also Send Feedback

The AsyncSaveAsFileCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncSaveAsFileCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncSaveAsFileCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncSaveAsFileCompletedEventArgs Properties
AsyncSaveAsFileCompletedEventArgs Class See Also Send Feedback

The AsyncSaveAsFileCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | SaveAsCompleted | Indicates whether the SaveAs operation completed successfully.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncSaveAsFileCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


SaveAsCompleted Property

[image]

IceLib Technical Reference
AsyncSaveAsFileCompletedEventArgs..::..SaveAsCompleted Property
AsyncSaveAsFileCompletedEventArgs Class See Also Send Feedback
Indicates whether the SaveAs operation completed successfully.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SaveAsCompleted { get; }
Visual Basic
Public ReadOnly Property SaveAsCompleted As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if save as completed successfully; otherwise, falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncSaveAsFileCompletedEventArgs Class
AsyncSaveAsFileCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncSendFaxCompletedEventArgs Class

[image]

IceLib Technical Reference
AsyncSendFaxCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SendFaxAsync(String, EventHandler<(Of <<'(AsyncSendFaxCompletedEventArgs>)>>), Object) completedCallback that occurs when the asynchronous operation completes.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AsyncSendFaxCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class AsyncSendFaxCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Remarks

Provide a completedCallback delegate to be informed when a call to SendFaxAsync(String, EventHandler<(Of <<'(AsyncSendFaxCompletedEventArgs>)>>), Object) has completed.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.UnifiedMessaging..::..AsyncSendFaxCompletedEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncSendFaxCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncSendFaxCompletedEventArgs Members

[image] [image]

IceLib Technical Reference
AsyncSendFaxCompletedEventArgs Members
AsyncSendFaxCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The AsyncSendFaxCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AsyncSendFaxCompletedEventArgs | Constructs a AsyncSendFaxCompletedEventArgs object to be returned in the SendFaxAsync(String, EventHandler<(Of <<'(AsyncSendFaxCompletedEventArgs>)>>), Object) completedCallback delegate.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FaxResult | The result of the Send Fax operation.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncSendFaxCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncSendFaxCompletedEventArgs Constructor

[image]

IceLib Technical Reference
AsyncSendFaxCompletedEventArgs Constructor
AsyncSendFaxCompletedEventArgs Class See Also Send Feedback
Constructs a AsyncSendFaxCompletedEventArgs object to be returned in the SendFaxAsync(String, EventHandler<(Of <<'(AsyncSendFaxCompletedEventArgs>)>>), Object) completedCallback delegate.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AsyncSendFaxCompletedEventArgs(
    FaxResult faxResult,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    faxResult As FaxResult, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

faxResult
Type: ININ.IceLib.UnifiedMessaging..::..FaxResult
The fax result.
error
Type: System..::..Exception
The error.
cancelled
Type: System..::..Boolean
If set to trueTruetruetrue (True in Visual Basic) was cancelled.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncSendFaxCompletedEventArgs Class
AsyncSendFaxCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AsyncSendFaxCompletedEventArgs Methods

[image] [image]

IceLib Technical Reference
AsyncSendFaxCompletedEventArgs Methods
AsyncSendFaxCompletedEventArgs Class See Also Send Feedback

The AsyncSendFaxCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsyncSendFaxCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AsyncSendFaxCompletedEventArgs Properties

[image] [image]

IceLib Technical Reference
AsyncSendFaxCompletedEventArgs Properties
AsyncSendFaxCompletedEventArgs Class See Also Send Feedback

The AsyncSendFaxCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FaxResult | The result of the Send Fax operation.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AsyncSendFaxCompletedEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxResult Property

[image]

IceLib Technical Reference
AsyncSendFaxCompletedEventArgs..::..FaxResult Property
AsyncSendFaxCompletedEventArgs Class See Also Send Feedback
The result of the Send Fax operation.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxResult FaxResult { get; set; }
Visual Basic
Public Property FaxResult As FaxResult
    Get
    Set

Field Value

The Fax result.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AsyncSendFaxCompletedEventArgs Class
AsyncSendFaxCompletedEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AttributeEventArgs Class

[image]

IceLib Technical Reference
AttributeEventArgs Class
Members See Also Send Feedback
Provides data for the Fax attribute change event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AttributeEventArgs : EventArgs
Visual Basic
Public Class AttributeEventArgs _
    Inherits EventArgs

Remarks

The AttributeEventArgs event is raised when any of the properties in a FaxPageAttributes instance have changed.

This change notification can be used to help determine when the visual representation of a page in a Fax should be updated.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.UnifiedMessaging..::..AttributeEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes


AttributeEventArgs Members

[image] [image]

IceLib Technical Reference
AttributeEventArgs Members
AttributeEventArgs Class Constructors Methods Properties See Also Send Feedback

The AttributeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeEventArgs | Initializes a new instance of the AttributeEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventAttributeType | Gets the EventAttributeType associated with the change. This indicates that a change in resolution, orientation, rotation or color scheme has occurred.

See Also

AttributeEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AttributeEventArgs Constructor

[image]

IceLib Technical Reference
AttributeEventArgs Constructor
AttributeEventArgs Class See Also Send Feedback
Initializes a new instance of the AttributeEventArgs class with the specified values.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AttributeEventArgs(
    EventAttributeType eventAttributeType
)
Visual Basic
Public Sub New ( _
    eventAttributeType As EventAttributeType _
)

Parameters

eventAttributeType
Type: ININ.IceLib.UnifiedMessaging..::..EventAttributeType
Type of the event attribute.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not from the enumeration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeEventArgs Class
AttributeEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


AttributeEventArgs Methods

[image] [image]

IceLib Technical Reference
AttributeEventArgs Methods
AttributeEventArgs Class See Also Send Feedback

The AttributeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributeEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


AttributeEventArgs Properties

[image] [image]

IceLib Technical Reference
AttributeEventArgs Properties
AttributeEventArgs Class See Also Send Feedback

The AttributeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | EventAttributeType | Gets the EventAttributeType associated with the change. This indicates that a change in resolution, orientation, rotation or color scheme has occurred.

See Also

AttributeEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


EventAttributeType Property

[image]

IceLib Technical Reference
AttributeEventArgs..::..EventAttributeType Property
AttributeEventArgs Class See Also Send Feedback
Gets the EventAttributeType associated with the change. This indicates that a change in resolution, orientation, rotation or color scheme has occurred.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public EventAttributeType EventAttributeType { get; }
Visual Basic
Public ReadOnly Property EventAttributeType As EventAttributeType
    Get

Field Value

The type of the event attribute.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

AttributeEventArgs Class
AttributeEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


CallFailureType Enumeration

[image]

IceLib Technical Reference
CallFailureType Enumeration
See Also Send Feedback
Indicates the type of call failure occurring during fax transmission.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum CallFailureType
Visual Basic
Public Enumeration CallFailureType

Members

Member name | Value | Description
Busy | 0 | The phone line was busy.
NoAnswer | 1 | There was no answer from the recipient.
NoFax | 2 | No fax machine is present at this number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


EventAttributeType Enumeration

[image]

IceLib Technical Reference
EventAttributeType Enumeration
See Also Send Feedback
Indicates the attribute that changed to trigger an attribute change event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum EventAttributeType
Visual Basic
Public Enumeration EventAttributeType

Members

Member name | Value | Description
Resolution | 0 | Indicates a change in resolution.
Orientation | 1 | Indicates a change in orientation.
Rotation | 2 | Indicates a change in rotation.
ColorScheme | 3 | Indicates a change in color scheme.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxAddressee Class

[image]

IceLib Technical Reference
FaxAddressee Class
Members See Also Send Feedback
The addressee who will be receiving a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxAddressee : ICloneable
Visual Basic
Public Class FaxAddressee _
    Implements ICloneable

Remarks

Use the FaxAddressee class to define the recipient of a Fax to use in a FaxEnvelope.

If a FaxCoverPageTemplate has been provided in the FaxEnvelope then the information contained in the FaxAddressee is used to populate several fields in the generated cover page. The exact fields used depend on the cover page template specified in the Name property of the FaxCoverPageTemplate.

Note
The Fax property is used to instruct the Fax server where to send a Fax and is required for a send operation to succeed.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxAddressee

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxCoverPageTemplate
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope


FaxAddressee Members

[image] [image]

IceLib Technical Reference
FaxAddressee Members
FaxAddressee Class Constructors Methods Properties See Also Send Feedback

The FaxAddressee type exposes the following members.

Constructors

 | Name | Description
Public method | FaxAddressee()()()() | Constructs an empty fax addressee.
Protected method | FaxAddressee(FaxAddressee) | Protected copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this addressee object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full addressee information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AccountCode | The account code used to bill this addressee.
Public property | Company | Addressee's company name.
Public property | Fax | Fax number used to contact this addressee.
Public property | Name | Addressee's name.
Public property | Phone | Phone number used to contact this addressee.

See Also

FaxAddressee Class
ININ.IceLib.UnifiedMessaging Namespace


FaxAddressee Constructor

[image] [image]

IceLib Technical Reference
FaxAddressee Constructor
FaxAddressee Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxAddressee()()()() | Constructs an empty fax addressee.
Protected method | FaxAddressee(FaxAddressee) | Protected copy constructor.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


FaxAddressee Constructor

[image]

IceLib Technical Reference
FaxAddressee Constructor
FaxAddressee Class See Also Send Feedback
Constructs an empty fax addressee.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxAddressee()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
FaxAddressee Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxAddressee Constructor (FaxAddressee)

[image]

IceLib Technical Reference
FaxAddressee Constructor (FaxAddressee)
FaxAddressee Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxAddressee(
    FaxAddressee addressee
)
Visual Basic
Protected Sub New ( _
    addressee As FaxAddressee _
)

Parameters

addressee
Type: ININ.IceLib.UnifiedMessaging..::..FaxAddressee
Existing FaxAddressee object to use for value assignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
FaxAddressee Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxAddressee Methods

[image] [image]

IceLib Technical Reference
FaxAddressee Methods
FaxAddressee Class See Also Send Feedback

The FaxAddressee type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this addressee object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full addressee information. (Overrides Object..::..ToString()()()().)

See Also

FaxAddressee Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxAddressee..::..Clone Method
FaxAddressee Class See Also Send Feedback
Creates a duplicate of this addressee object by copying all members.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

The new addressee.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxAddressee..::..ToString Method
FaxAddressee Class See Also Send Feedback
Override of ToString()()()() that prints full addressee information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A formatted string describing the addressee.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


FaxAddressee Properties

[image] [image]

IceLib Technical Reference
FaxAddressee Properties
FaxAddressee Class See Also Send Feedback

The FaxAddressee type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | The account code used to bill this addressee.
Public property | Company | Addressee's company name.
Public property | Fax | Fax number used to contact this addressee.
Public property | Name | Addressee's name.
Public property | Phone | Phone number used to contact this addressee.

See Also

FaxAddressee Class
ININ.IceLib.UnifiedMessaging Namespace


AccountCode Property

[image]

IceLib Technical Reference
FaxAddressee..::..AccountCode Property
FaxAddressee Class See Also Send Feedback
The account code used to bill this addressee.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string AccountCode { get; set; }
Visual Basic
Public Property AccountCode As String
    Get
    Set

Field Value

The account code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


Company Property

[image]

IceLib Technical Reference
FaxAddressee..::..Company Property
FaxAddressee Class See Also Send Feedback
Addressee's company name.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set

Field Value

The company.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


Fax Property

[image]

IceLib Technical Reference
FaxAddressee..::..Fax Property
FaxAddressee Class See Also Send Feedback
Fax number used to contact this addressee.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set

Field Value

The fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


Name Property

[image]

IceLib Technical Reference
FaxAddressee..::..Name Property
FaxAddressee Class See Also Send Feedback
Addressee's name.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


Phone Property

[image]

IceLib Technical Reference
FaxAddressee..::..Phone Property
FaxAddressee Class See Also Send Feedback
Phone number used to contact this addressee.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Phone { get; set; }
Visual Basic
Public Property Phone As String
    Get
    Set

Field Value

The phone.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAddressee Class
FaxAddressee Members
ININ.IceLib.UnifiedMessaging Namespace


FaxAttachment Class

[image]

IceLib Technical Reference
FaxAttachment Class
Members See Also Send Feedback
Represents an attachment (containing the actual Fax file) in a FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxAttachment
Visual Basic
Public Class FaxAttachment

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxAttachment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAttachment Members
ININ.IceLib.UnifiedMessaging Namespace
See the documentation on for how this class is used, and what information it contains.


FaxAttachment Members

[image] [image]

IceLib Technical Reference
FaxAttachment Members
FaxAttachment Class Methods Properties See Also Send Feedback

The FaxAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two FaxAttachment objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the ID of this FaxAttachment.
Public property | Moniker | Gets the moniker of this FaxAttachment.
Public property | Name | Gets the filename of this FaxAttachment.

See Also

FaxAttachment Class
ININ.IceLib.UnifiedMessaging Namespace


FaxAttachment Methods

[image] [image]

IceLib Technical Reference
FaxAttachment Methods
FaxAttachment Class See Also Send Feedback

The FaxAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two FaxAttachment objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxAttachment Class
ININ.IceLib.UnifiedMessaging Namespace


Equals Method

[image]

IceLib Technical Reference
FaxAttachment..::..Equals Method
FaxAttachment Class See Also Send Feedback
Compares two FaxAttachment objects.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAttachment Class
FaxAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


GetHashCode Method

[image]

IceLib Technical Reference
FaxAttachment..::..GetHashCode Method
FaxAttachment Class See Also Send Feedback
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAttachment Class
FaxAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


FaxAttachment Properties

[image] [image]

IceLib Technical Reference
FaxAttachment Properties
FaxAttachment Class See Also Send Feedback

The FaxAttachment type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID of this FaxAttachment.
Public property | Moniker | Gets the moniker of this FaxAttachment.
Public property | Name | Gets the filename of this FaxAttachment.

See Also

FaxAttachment Class
ININ.IceLib.UnifiedMessaging Namespace


Id Property

[image]

IceLib Technical Reference
FaxAttachment..::..Id Property
FaxAttachment Class See Also Send Feedback
Gets the ID of this FaxAttachment.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAttachment Class
FaxAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


Moniker Property

[image]

IceLib Technical Reference
FaxAttachment..::..Moniker Property
FaxAttachment Class See Also Send Feedback
Gets the moniker of this FaxAttachment.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Moniker { get; }
Visual Basic
Public ReadOnly Property Moniker As String
    Get

Field Value

The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 15 and beyond.

See Also

FaxAttachment Class
FaxAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


Name Property

[image]

IceLib Technical Reference
FaxAttachment..::..Name Property
FaxAttachment Class See Also Send Feedback
Gets the filename of this FaxAttachment.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxAttachment Class
FaxAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


FaxColorScheme Enumeration

[image]

IceLib Technical Reference
FaxColorScheme Enumeration
See Also Send Feedback
Indicates the color choice for displaying a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxColorScheme
Visual Basic
Public Enumeration FaxColorScheme

Members

Member name | Value | Description
Normal | 0 | Standard black on white display.
Inverted | 1 | Inverted white on black display.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxCoverPageTemplate Class

[image]

IceLib Technical Reference
FaxCoverPageTemplate Class
Members See Also Send Feedback
The information used to control generation of a Fax cover page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxCoverPageTemplate : ICloneable
Visual Basic
Public Class FaxCoverPageTemplate _
    Implements ICloneable

Remarks

Use the FaxCoverPageTemplate class to describe the cover page to attach to an outbound Fax. This class is used when configuring a FaxEnvelope.

When the Name has been set to a valid Fax cover page template the Fax server will use the other properties, along with any information in the FaxAddressee to create a cover page image using that template.

Examples

All known templates are stored on the IC server. The following example demonstrates retrieving the list of templates available to a user.
CopyC#
FaxServerSettings faxServerSettings;

UnifiedMessagingManager umManager = UnifiedMessagingManager.GetInstance(IceLibSession);
faxServerSettings = umManager.GetFaxServerSettings();

ReadOnlyCollection<string> CoverPages = faxServerSettings.CoverPages;

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxCoverPageTemplate

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxAddressee
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope
ININ.IceLib.UnifiedMessaging..::..UnifiedMessagingManager


FaxCoverPageTemplate Members

[image] [image]

IceLib Technical Reference
FaxCoverPageTemplate Members
FaxCoverPageTemplate Class Constructors Methods Properties See Also Send Feedback

The FaxCoverPageTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | FaxCoverPageTemplate()()()() | Constructs an empty cover page template.
Protected method | FaxCoverPageTemplate(FaxCoverPageTemplate) | Protected copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this cover page template object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full cover page information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Comments | Comment information used to fill in the cover page template.
Public property | FromCompany | Company information used to fill in the cover page template.
Public property | FromFax | Fax information used to fill in the cover page template.
Public property | FromName | Sender information used to fill in the cover page template.
Public property | FromPhone | Phone information used to fill in the cover page template.
Public property | Name | Name of the Fax cover page template used to generate a cover page.
Public property | Type | The type of cover page this object represents.

See Also

FaxCoverPageTemplate Class
ININ.IceLib.UnifiedMessaging Namespace


FaxCoverPageTemplate Constructor

[image] [image]

IceLib Technical Reference
FaxCoverPageTemplate Constructor
FaxCoverPageTemplate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxCoverPageTemplate()()()() | Constructs an empty cover page template.
Protected method | FaxCoverPageTemplate(FaxCoverPageTemplate) | Protected copy constructor.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FaxCoverPageTemplate Constructor

[image]

IceLib Technical Reference
FaxCoverPageTemplate Constructor
FaxCoverPageTemplate Class See Also Send Feedback
Constructs an empty cover page template.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxCoverPageTemplate()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
FaxCoverPageTemplate Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxCoverPageTemplate Constructor (FaxCoverPageTemplate)

[image]

IceLib Technical Reference
FaxCoverPageTemplate Constructor (FaxCoverPageTemplate)
FaxCoverPageTemplate Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxCoverPageTemplate(
    FaxCoverPageTemplate template
)
Visual Basic
Protected Sub New ( _
    template As FaxCoverPageTemplate _
)

Parameters

template
Type: ININ.IceLib.UnifiedMessaging..::..FaxCoverPageTemplate
Existing cover page template object to use for value assignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
FaxCoverPageTemplate Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxCoverPageTemplate Methods

[image] [image]

IceLib Technical Reference
FaxCoverPageTemplate Methods
FaxCoverPageTemplate Class See Also Send Feedback

The FaxCoverPageTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this cover page template object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full cover page information. (Overrides Object..::..ToString()()()().)

See Also

FaxCoverPageTemplate Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..Clone Method
FaxCoverPageTemplate Class See Also Send Feedback
Creates a duplicate of this cover page template object by copying all members.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

The new cover page template.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..ToString Method
FaxCoverPageTemplate Class See Also Send Feedback
Override of ToString()()()() that prints full cover page information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A formatted string describing the cover page.

Remarks

The formatted string contains named values separated by commas: "Type=, Name=, From=, Fax=, Phone=, Company=, Comments=".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FaxCoverPageTemplate Properties

[image] [image]

IceLib Technical Reference
FaxCoverPageTemplate Properties
FaxCoverPageTemplate Class See Also Send Feedback

The FaxCoverPageTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Comments | Comment information used to fill in the cover page template.
Public property | FromCompany | Company information used to fill in the cover page template.
Public property | FromFax | Fax information used to fill in the cover page template.
Public property | FromName | Sender information used to fill in the cover page template.
Public property | FromPhone | Phone information used to fill in the cover page template.
Public property | Name | Name of the Fax cover page template used to generate a cover page.
Public property | Type | The type of cover page this object represents.

See Also

FaxCoverPageTemplate Class
ININ.IceLib.UnifiedMessaging Namespace


Comments Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..Comments Property
FaxCoverPageTemplate Class See Also Send Feedback
Comment information used to fill in the cover page template.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set

Field Value

Any introductory remarks or instructions that need to appear on the cover page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FromCompany Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..FromCompany Property
FaxCoverPageTemplate Class See Also Send Feedback
Company information used to fill in the cover page template.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FromCompany { get; set; }
Visual Basic
Public Property FromCompany As String
    Get
    Set

Field Value

The sender’s company name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FromFax Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..FromFax Property
FaxCoverPageTemplate Class See Also Send Feedback
Fax information used to fill in the cover page template.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FromFax { get; set; }
Visual Basic
Public Property FromFax As String
    Get
    Set

Field Value

The sender’s Fax number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FromName Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..FromName Property
FaxCoverPageTemplate Class See Also Send Feedback
Sender information used to fill in the cover page template.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FromName { get; set; }
Visual Basic
Public Property FromName As String
    Get
    Set

Field Value

The name of the person sending the Fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FromPhone Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..FromPhone Property
FaxCoverPageTemplate Class See Also Send Feedback
Phone information used to fill in the cover page template.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FromPhone { get; set; }
Visual Basic
Public Property FromPhone As String
    Get
    Set

Field Value

The sender’s voice telephone number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


Name Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..Name Property
FaxCoverPageTemplate Class See Also Send Feedback
Name of the Fax cover page template used to generate a cover page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

The name of the Fax cover page template.

Remarks

IC includes four basic cover page templates that can be customized. By default, these files appear in the \I3\IC\Resources\CoverPages directory on the IC server after installation. The cover page files ship with IC are:

  • FaxCoverConfidential1.i3c
  • FaxCoverLetter1.i3c
  • FaxCoverLetter2.i3c
  • FaxCoverUrgent1.i3c

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


Type Property

[image]

IceLib Technical Reference
FaxCoverPageTemplate..::..Type Property
FaxCoverPageTemplate Class See Also Send Feedback
The type of cover page this object represents.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Type { get; set; }
Visual Basic
Public Property Type As Integer
    Get
    Set

Field Value

The type of cover page.

Remarks

Type represents type of file used to construct the cover page. Type is 0 for an Interaction Fax format (.I3F file), 1 for bitmap files, or 2 for ActiveX printable documents. The ActiveX printable documents that are compatible at this time are MS Word and MS PowerPoint files.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxCoverPageTemplate Class
FaxCoverPageTemplate Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryNotification Class

[image]

IceLib Technical Reference
FaxDeliveryNotification Class
Members See Also Send Feedback
Controls notifications about the delivery state of a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxDeliveryNotification : ICloneable
Visual Basic
Public Class FaxDeliveryNotification _
    Implements ICloneable

Remarks

Use the FaxDeliveryNotification class to define the notifications to send when the final delivery state of a Fax has been determined. This class is used when configuring a FaxEnvelope.

The delivery mechanism for a Fax allows the Fax server to notify an interested party when a fax has been successfully sent or has failed all attempts at delivery. The FaxDeliveryNotification class allows you to define who is notified under each condition.

When setting either NotifyOnSuccess or NotifyOnFailure to trueTruetruetrue (True in Visual Basic), make sure to set the matching Email field to a valid address (SMTP, Exchange, etc.).

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxDeliveryNotification

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope


FaxDeliveryNotification Members

[image] [image]

IceLib Technical Reference
FaxDeliveryNotification Members
FaxDeliveryNotification Class Constructors Methods Properties See Also Send Feedback

The FaxDeliveryNotification type exposes the following members.

Constructors

 | Name | Description
Public method | FaxDeliveryNotification()()()() | Constructs an empty delivery notification object.
Protected method | FaxDeliveryNotification(FaxDeliveryNotification) | Protected copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this notification object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full notification information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FailureEmail | Email address to notify on failure.
Public property | NotifyEmail | Email address to notify on success.
Public property | NotifyOnFailure | Notify via email if Fax could not be sent.
Public property | NotifyOnSuccess | Notify via Email when Fax is sent.

See Also

FaxDeliveryNotification Class
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryNotification Constructor

[image] [image]

IceLib Technical Reference
FaxDeliveryNotification Constructor
FaxDeliveryNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxDeliveryNotification()()()() | Constructs an empty delivery notification object.
Protected method | FaxDeliveryNotification(FaxDeliveryNotification) | Protected copy constructor.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryNotification Constructor

[image]

IceLib Technical Reference
FaxDeliveryNotification Constructor
FaxDeliveryNotification Class See Also Send Feedback
Constructs an empty delivery notification object.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliveryNotification()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
FaxDeliveryNotification Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryNotification Constructor (FaxDeliveryNotification)

[image]

IceLib Technical Reference
FaxDeliveryNotification Constructor (FaxDeliveryNotification)
FaxDeliveryNotification Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxDeliveryNotification(
    FaxDeliveryNotification notification
)
Visual Basic
Protected Sub New ( _
    notification As FaxDeliveryNotification _
)

Parameters

notification
Type: ININ.IceLib.UnifiedMessaging..::..FaxDeliveryNotification
Existing notification object to use for value assignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
FaxDeliveryNotification Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryNotification Methods

[image] [image]

IceLib Technical Reference
FaxDeliveryNotification Methods
FaxDeliveryNotification Class See Also Send Feedback

The FaxDeliveryNotification type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this notification object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full notification information. (Overrides Object..::..ToString()()()().)

See Also

FaxDeliveryNotification Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxDeliveryNotification..::..Clone Method
FaxDeliveryNotification Class See Also Send Feedback
Creates a duplicate of this notification object by copying all members.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

The new delivery notification.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxDeliveryNotification..::..ToString Method
FaxDeliveryNotification Class See Also Send Feedback
Override of ToString()()()() that prints full notification information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A formatted string describing the notification options.

Remarks

The formatted string is "NotifyOnSuccess=value, NotifyOnFailure=value, NotifyEmail=value, FailureEmail=value".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryNotification Properties

[image] [image]

IceLib Technical Reference
FaxDeliveryNotification Properties
FaxDeliveryNotification Class See Also Send Feedback

The FaxDeliveryNotification type exposes the following members.

Properties

 | Name | Description
Public property | FailureEmail | Email address to notify on failure.
Public property | NotifyEmail | Email address to notify on success.
Public property | NotifyOnFailure | Notify via email if Fax could not be sent.
Public property | NotifyOnSuccess | Notify via Email when Fax is sent.

See Also

FaxDeliveryNotification Class
ININ.IceLib.UnifiedMessaging Namespace


FailureEmail Property

[image]

IceLib Technical Reference
FaxDeliveryNotification..::..FailureEmail Property
FaxDeliveryNotification Class See Also Send Feedback
Email address to notify on failure.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FailureEmail { get; set; }
Visual Basic
Public Property FailureEmail As String
    Get
    Set

Field Value

The failure Email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


NotifyEmail Property

[image]

IceLib Technical Reference
FaxDeliveryNotification..::..NotifyEmail Property
FaxDeliveryNotification Class See Also Send Feedback
Email address to notify on success.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string NotifyEmail { get; set; }
Visual Basic
Public Property NotifyEmail As String
    Get
    Set

Field Value

The notify email.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


NotifyOnFailure Property

[image]

IceLib Technical Reference
FaxDeliveryNotification..::..NotifyOnFailure Property
FaxDeliveryNotification Class See Also Send Feedback
Notify via email if Fax could not be sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool NotifyOnFailure { get; set; }
Visual Basic
Public Property NotifyOnFailure As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should notify on failure; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


NotifyOnSuccess Property

[image]

IceLib Technical Reference
FaxDeliveryNotification..::..NotifyOnSuccess Property
FaxDeliveryNotification Class See Also Send Feedback
Notify via Email when Fax is sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool NotifyOnSuccess { get; set; }
Visual Basic
Public Property NotifyOnSuccess As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should notify on success; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliveryNotification Class
FaxDeliveryNotification Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliverySchedule Class

[image]

IceLib Technical Reference
FaxDeliverySchedule Class
Members See Also Send Feedback
Controls when a Fax will be delivered to an addressee.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxDeliverySchedule : ICloneable
Visual Basic
Public Class FaxDeliverySchedule _
    Implements ICloneable

Remarks

Use the FaxDeliverySchedule class to tell the Fax server when to begin delivery attempts on a Fax. This class is used when configuring a FaxEnvelope.

Note
Instances of this class should leave all values set at their defaults. The Fax server will always attempt to deliver Faxes as soon as possible according to the availability schedule established on the IC server.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxDeliverySchedule

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope


FaxDeliverySchedule Members

[image] [image]

IceLib Technical Reference
FaxDeliverySchedule Members
FaxDeliverySchedule Class Constructors Methods Properties See Also Send Feedback

The FaxDeliverySchedule type exposes the following members.

Constructors

 | Name | Description
Public method | FaxDeliverySchedule()()()() | Initializes a new instance of the FaxDeliverySchedule class.
Protected method | FaxDeliverySchedule(FaxDeliverySchedule) | Protected copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this schedule object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full schedule information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | EarliestDelivery | Gets or sets the earliest time Fax should be transmitted for FaxDeliveryType Immediate.
Public property | OffPeakBegin | Gets the start of low-rate time period for FaxDeliveryType OffPeak.
Public property | OffPeakEnd | Gets the end of low-rate time period for FaxDeliveryType OffPeak.
Public property | Type | Gets or sets a value indicating when the Fax should be delivered.

See Also

FaxDeliverySchedule Class
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliverySchedule Constructor

[image] [image]

IceLib Technical Reference
FaxDeliverySchedule Constructor
FaxDeliverySchedule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxDeliverySchedule()()()() | Initializes a new instance of the FaxDeliverySchedule class.
Protected method | FaxDeliverySchedule(FaxDeliverySchedule) | Protected copy constructor.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliverySchedule Constructor

[image]

IceLib Technical Reference
FaxDeliverySchedule Constructor
FaxDeliverySchedule Class See Also Send Feedback
Initializes a new instance of the FaxDeliverySchedule class.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliverySchedule()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
FaxDeliverySchedule Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliverySchedule Constructor (FaxDeliverySchedule)

[image]

IceLib Technical Reference
FaxDeliverySchedule Constructor (FaxDeliverySchedule)
FaxDeliverySchedule Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxDeliverySchedule(
    FaxDeliverySchedule schedule
)
Visual Basic
Protected Sub New ( _
    schedule As FaxDeliverySchedule _
)

Parameters

schedule
Type: ININ.IceLib.UnifiedMessaging..::..FaxDeliverySchedule
Existing schedule object to use for value assignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
FaxDeliverySchedule Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliverySchedule Methods

[image] [image]

IceLib Technical Reference
FaxDeliverySchedule Methods
FaxDeliverySchedule Class See Also Send Feedback

The FaxDeliverySchedule type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this schedule object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full schedule information. (Overrides Object..::..ToString()()()().)

See Also

FaxDeliverySchedule Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxDeliverySchedule..::..Clone Method
FaxDeliverySchedule Class See Also Send Feedback
Creates a duplicate of this schedule object by copying all members.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

The new delivery schedule.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxDeliverySchedule..::..ToString Method
FaxDeliverySchedule Class See Also Send Feedback
Override of ToString()()()() that prints full schedule information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A formatted string describing the schedule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliverySchedule Properties

[image] [image]

IceLib Technical Reference
FaxDeliverySchedule Properties
FaxDeliverySchedule Class See Also Send Feedback

The FaxDeliverySchedule type exposes the following members.

Properties

 | Name | Description
Public property | EarliestDelivery | Gets or sets the earliest time Fax should be transmitted for FaxDeliveryType Immediate.
Public property | OffPeakBegin | Gets the start of low-rate time period for FaxDeliveryType OffPeak.
Public property | OffPeakEnd | Gets the end of low-rate time period for FaxDeliveryType OffPeak.
Public property | Type | Gets or sets a value indicating when the Fax should be delivered.

See Also

FaxDeliverySchedule Class
ININ.IceLib.UnifiedMessaging Namespace


EarliestDelivery Property

[image]

IceLib Technical Reference
FaxDeliverySchedule..::..EarliestDelivery Property
FaxDeliverySchedule Class See Also Send Feedback
Gets or sets the earliest time Fax should be transmitted for FaxDeliveryType Immediate.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime EarliestDelivery { get; set; }
Visual Basic
Public Property EarliestDelivery As DateTime
    Get
    Set

Field Value

The earliest delivery.

Remarks

Send the Fax immediately, or as soon as a line is available.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


OffPeakBegin Property

[image]

IceLib Technical Reference
FaxDeliverySchedule..::..OffPeakBegin Property
FaxDeliverySchedule Class See Also Send Feedback
Gets the start of low-rate time period for FaxDeliveryType OffPeak.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime OffPeakBegin { get; internal set; }
Visual Basic
Public Property OffPeakBegin As DateTime
    Get
    Friend Set

Field Value

The off peak begin.

Remarks

The fax will be sent during this range of off peak hours. The value is only populated when retrieving Fax status, not when sending new Faxes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


OffPeakEnd Property

[image]

IceLib Technical Reference
FaxDeliverySchedule..::..OffPeakEnd Property
FaxDeliverySchedule Class See Also Send Feedback
Gets the end of low-rate time period for FaxDeliveryType OffPeak.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime OffPeakEnd { get; internal set; }
Visual Basic
Public Property OffPeakEnd As DateTime
    Get
    Friend Set

Field Value

The off peak end.

Remarks

The fax will be sent during this range of off peak hours. The value is only populated when retrieving Fax status, not when sending new Faxes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


Type Property

[image]

IceLib Technical Reference
FaxDeliverySchedule..::..Type Property
FaxDeliverySchedule Class See Also Send Feedback
Gets or sets a value indicating when the Fax should be delivered.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliveryType Type { get; set; }
Visual Basic
Public Property Type As FaxDeliveryType
    Get
    Set

Field Value

The Type. See FaxDeliveryType enumeration.

Remarks

Type is an enumeration that indicates when this Fax should be sent: immediately, during off-peak hours, or in accordance with a schedule date and time.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxDeliverySchedule Class
FaxDeliverySchedule Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeliveryType Enumeration

[image]

IceLib Technical Reference
FaxDeliveryType Enumeration
See Also Send Feedback
Indicates when a fax should be delivered.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxDeliveryType
Visual Basic
Public Enumeration FaxDeliveryType

Members

Member name | Value | Description
Immediate | 0 | Send immediately.
OffPeak | 1 | Send during off-peak hours.
Scheduled | 2 | Schedule a date and time for delivery.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Class

[image]

IceLib Technical Reference
FaxEnvelope Class
Members See Also Send Feedback
Stores information related to the delivery of a Fax file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxEnvelope : ICloneable
Visual Basic
Public Class FaxEnvelope _
    Implements ICloneable

Remarks

Use the FaxEnvelope class to define the recipient and delivery options for a Fax. You can specify who receives a fax, when it should be delivered, what type of cover page it should have, and who should be notified after a send attempt. Where the FaxFile class defines the content of a Fax, the FaxEnvelope defines all aspects of its delivery.

Note
Each FaxEnvelope added to a FaxFile represents a single addressee that will receive the Fax. If you will be sending a fax to multiple recipients, you must create a FaxEnvelope for each recipient.

A FaxEnvelope is logically divided into a CoverPage, a Schedule, a Recipient, Options, and Notification preferences. When creating a new FaxEnvelope, these properties are all assigned default values that will allow a Fax to be successfully delivered with the exception of the Recipient. You must assign a number to the Fax property of the Recipient in order to have a destination for this envelope.

In addition to providing an actual Fax number, you must assign a valid IC user name to the SenderId. You should also set the TimeSent to indicate when the envelope was finalized for delivery.

The Fax delivery will fail if a SenderId is not provided or if the Fax property is not set.

Examples

The following example demonstrates the creation of a default envelope and assignment of a SenderId and Fax number.
CopyC#
FaxEnvelope envelope = new FaxEnvelope();

envelope.Recipient.Fax = destinationNumber;
envelope.SenderId = icUser; // userId of IC user submitting the fax
envelope.TimeSent = DateTime.Now;

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxCoverPageTemplate
ININ.IceLib.UnifiedMessaging..::..FaxDeliverySchedule
ININ.IceLib.UnifiedMessaging..::..FaxDeliveryNotification
ININ.IceLib.UnifiedMessaging..::..FaxTransmitOptions
ININ.IceLib.UnifiedMessaging..::..FaxAddressee
ININ.IceLib.UnifiedMessaging..::..FaxFile


FaxEnvelope Members

[image] [image]

IceLib Technical Reference
FaxEnvelope Members
FaxEnvelope Class Constructors Methods Properties See Also Send Feedback

The FaxEnvelope type exposes the following members.

Constructors

 | Name | Description
Public method | FaxEnvelope()()()() | Creates a new envelope with defaults for when, where, and how a Fax will be sent.
Protected method | FaxEnvelope(FaxEnvelope) | Protected copy constructor.
Public method | FaxEnvelope(FaxAddressee, FaxCoverPageTemplate, FaxDeliverySchedule, FaxDeliveryNotification, FaxTransmitOptions) | Creates a new envelope for when, where and how a Fax will be sent.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this Fax Envelope object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream | Constructs a new envelope by reading existing envelope data from a stream object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Writes an Envelope object to an open stream.
Public method | ToString | Override of ToString()()()() that prints full Fax envelope information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CoverPage | The information used to generate a cover page.
Public property | Notification | The information used to control delivery receipts.
Public property | Options | The information used to control how a Fax is sent.
Public property | Recipient | The information used to identify the recipient of a Fax.
Public property | Schedule | The information used to control when a Fax is delivered.
Public property | SenderId | The unique identifier for a user sending a fax. This is an IC User name or name of an IP handler.
Public property | TimeSent | The Date and Time a fax was sent.
Public property | Version | The revision identifier of this FaxEnvelope.

See Also

FaxEnvelope Class
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Constructor

[image] [image]

IceLib Technical Reference
FaxEnvelope Constructor
FaxEnvelope Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxEnvelope()()()() | Creates a new envelope with defaults for when, where, and how a Fax will be sent.
Protected method | FaxEnvelope(FaxEnvelope) | Protected copy constructor.
Public method | FaxEnvelope(FaxAddressee, FaxCoverPageTemplate, FaxDeliverySchedule, FaxDeliveryNotification, FaxTransmitOptions) | Creates a new envelope for when, where and how a Fax will be sent.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Constructor

[image]

IceLib Technical Reference
FaxEnvelope Constructor
FaxEnvelope Class See Also Send Feedback
Creates a new envelope with defaults for when, where, and how a Fax will be sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEnvelope()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
FaxEnvelope Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Constructor (FaxEnvelope)

[image]

IceLib Technical Reference
FaxEnvelope Constructor (FaxEnvelope)
FaxEnvelope Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxEnvelope(
    FaxEnvelope envelope
)
Visual Basic
Protected Sub New ( _
    envelope As FaxEnvelope _
)

Parameters

envelope
Type: ININ.IceLib.UnifiedMessaging..::..FaxEnvelope
Existing envelope object to use for value assignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
FaxEnvelope Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Constructor (FaxAddressee, FaxCoverPageTemplate, FaxDeliverySchedule, FaxDeliveryNotification, FaxTransmitOptions)

[image]

IceLib Technical Reference
FaxEnvelope Constructor (FaxAddressee, FaxCoverPageTemplate, FaxDeliverySchedule, FaxDeliveryNotification, FaxTransmitOptions)
FaxEnvelope Class See Also Send Feedback
Creates a new envelope for when, where and how a Fax will be sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEnvelope(
    FaxAddressee recipient,
    FaxCoverPageTemplate coverPage,
    FaxDeliverySchedule schedule,
    FaxDeliveryNotification notification,
    FaxTransmitOptions options
)
Visual Basic
Public Sub New ( _
    recipient As FaxAddressee, _
    coverPage As FaxCoverPageTemplate, _
    schedule As FaxDeliverySchedule, _
    notification As FaxDeliveryNotification, _
    options As FaxTransmitOptions _
)

Parameters

recipient
Type: ININ.IceLib.UnifiedMessaging..::..FaxAddressee
The recipient of the Fax.
coverPage
Type: ININ.IceLib.UnifiedMessaging..::..FaxCoverPageTemplate
Options used to generate a cover page on send.
schedule
Type: ININ.IceLib.UnifiedMessaging..::..FaxDeliverySchedule
The delivery schedule.
notification
Type: ININ.IceLib.UnifiedMessaging..::..FaxDeliveryNotification
Controls generation of a delivery receipt.
options
Type: ININ.IceLib.UnifiedMessaging..::..FaxTransmitOptions
Controls the Fax device that will send a Fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
FaxEnvelope Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Methods

[image] [image]

IceLib Technical Reference
FaxEnvelope Methods
FaxEnvelope Class See Also Send Feedback

The FaxEnvelope type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this Fax Envelope object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream | Constructs a new envelope by reading existing envelope data from a stream object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Writes an Envelope object to an open stream.
Public method | ToString | Override of ToString()()()() that prints full Fax envelope information. (Overrides Object..::..ToString()()()().)

See Also

FaxEnvelope Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxEnvelope..::..Clone Method
FaxEnvelope Class See Also Send Feedback
Creates a duplicate of this Fax Envelope object by copying all members.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

The new Fax Envelope.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


FromStream Method

[image]

IceLib Technical Reference
FaxEnvelope..::..FromStream Method
FaxEnvelope Class See Also Send Feedback
Constructs a new envelope by reading existing envelope data from a stream object.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static FaxEnvelope FromStream(
    Stream dataStream
)
Visual Basic
Public Shared Function FromStream ( _
    dataStream As Stream _
) As FaxEnvelope

Parameters

dataStream
Type: System.IO..::..Stream
The stream to read the envelope from.

Return Value

A new envelope created from the stream.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System.IO..::..IOException | General stream read error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


Serialize Method

[image]

IceLib Technical Reference
FaxEnvelope..::..Serialize Method
FaxEnvelope Class See Also Send Feedback
Writes an Envelope object to an open stream.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Serialize(
    Stream dataStream
)
Visual Basic
Public Sub Serialize ( _
    dataStream As Stream _
)

Parameters

dataStream
Type: System.IO..::..Stream
An existing file stream that will receive the serialized envelope.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | An attempt was made to write data to a closed stream.
System.IO..::..IOException | General stream write error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxEnvelope..::..ToString Method
FaxEnvelope Class See Also Send Feedback
Override of ToString()()()() that prints full Fax envelope information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A formatted string Fax envelope.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelope Properties

[image] [image]

IceLib Technical Reference
FaxEnvelope Properties
FaxEnvelope Class See Also Send Feedback

The FaxEnvelope type exposes the following members.

Properties

 | Name | Description
Public property | CoverPage | The information used to generate a cover page.
Public property | Notification | The information used to control delivery receipts.
Public property | Options | The information used to control how a Fax is sent.
Public property | Recipient | The information used to identify the recipient of a Fax.
Public property | Schedule | The information used to control when a Fax is delivered.
Public property | SenderId | The unique identifier for a user sending a fax. This is an IC User name or name of an IP handler.
Public property | TimeSent | The Date and Time a fax was sent.
Public property | Version | The revision identifier of this FaxEnvelope.

See Also

FaxEnvelope Class
ININ.IceLib.UnifiedMessaging Namespace


CoverPage Property

[image]

IceLib Technical Reference
FaxEnvelope..::..CoverPage Property
FaxEnvelope Class See Also Send Feedback
The information used to generate a cover page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxCoverPageTemplate CoverPage { get; private set; }
Visual Basic
Public Property CoverPage As FaxCoverPageTemplate
    Get
    Private Set

Field Value

The cover page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


Notification Property

[image]

IceLib Technical Reference
FaxEnvelope..::..Notification Property
FaxEnvelope Class See Also Send Feedback
The information used to control delivery receipts.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliveryNotification Notification { get; private set; }
Visual Basic
Public Property Notification As FaxDeliveryNotification
    Get
    Private Set

Field Value

The notification.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


Options Property

[image]

IceLib Technical Reference
FaxEnvelope..::..Options Property
FaxEnvelope Class See Also Send Feedback
The information used to control how a Fax is sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxTransmitOptions Options { get; private set; }
Visual Basic
Public Property Options As FaxTransmitOptions
    Get
    Private Set

Field Value

The options.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


Recipient Property

[image]

IceLib Technical Reference
FaxEnvelope..::..Recipient Property
FaxEnvelope Class See Also Send Feedback
The information used to identify the recipient of a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxAddressee Recipient { get; private set; }
Visual Basic
Public Property Recipient As FaxAddressee
    Get
    Private Set

Field Value

The recipient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


Schedule Property

[image]

IceLib Technical Reference
FaxEnvelope..::..Schedule Property
FaxEnvelope Class See Also Send Feedback
The information used to control when a Fax is delivered.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliverySchedule Schedule { get; private set; }
Visual Basic
Public Property Schedule As FaxDeliverySchedule
    Get
    Private Set

Field Value

The schedule.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


SenderId Property

[image]

IceLib Technical Reference
FaxEnvelope..::..SenderId Property
FaxEnvelope Class See Also Send Feedback
The unique identifier for a user sending a fax. This is an IC User name or name of an IP handler.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SenderId { get; set; }
Visual Basic
Public Property SenderId As String
    Get
    Set

Field Value

The sender ID.

Remarks

When sending a fax this field should be set prior to the envelope being serialized into the fax file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


TimeSent Property

[image]

IceLib Technical Reference
FaxEnvelope..::..TimeSent Property
FaxEnvelope Class See Also Send Feedback
The Date and Time a fax was sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime TimeSent { get; set; }
Visual Basic
Public Property TimeSent As DateTime
    Get
    Set

Field Value

The time sent.

Remarks

When sending a fax this field should be set prior to the envelope being serialized into the fax file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


Version Property

[image]

IceLib Technical Reference
FaxEnvelope..::..Version Property
FaxEnvelope Class See Also Send Feedback
The revision identifier of this FaxEnvelope.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Version { get; }
Visual Basic
Public ReadOnly Property Version As Integer
    Get

Field Value

The version number.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelope Class
FaxEnvelope Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelopeProperties Class

[image]

IceLib Technical Reference
FaxEnvelopeProperties Class
Members See Also Send Feedback
Class to contain the properties of a fax in progress. An instance of FaxEnvelopeProperties is created as a result of a call to GetFaxProperties(Int64) or GetFaxPropertiesAsync(Int64, EventHandler<(Of <<'(AsyncGetFaxPropertiesEventArgs>)>>), Object). In the case of the latter this object is returned in the AsyncGetFaxPropertiesEventArgs object. Objects of this class contain all of the important information about a fax and can be used whenever you want to display properties of an on-going fax.

Examples

The following example demonstrates getting the properties of an on-going fax.
CopyC#
  private void GetFaxProperties(FaxStatus status)
  {
        if (_UnifiedMessagingManager != null)
        {
            _UnifiedMessagingManager.GetFaxPropertiesAsync(Convert.ToInt32(status.EnvelopeId), new EventHandler<AsyncGetFaxPropertiesEventArgs>(OnGetFaxPropertiesCompleted), null);
        }
 }
 private void OnGetFaxPropertiesCompleted(object sender, AsyncGetFaxPropertiesEventArgs args)
{
    if (args.Error != null)
    {
        MessageBox.Show(this, args.Error.Message, "Fax Monitor", MessageBoxButtons.OK, MessageBoxIcon.Exclamation);
    }
    else
    {
        //Do something here to display the fax properties data
    }
}

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxEnvelopeProperties
Visual Basic
Public Class FaxEnvelopeProperties

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxEnvelopeProperties

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelopeProperties Members

[image] [image]

IceLib Technical Reference
FaxEnvelopeProperties Members
FaxEnvelopeProperties Class Constructors Methods Properties See Also Send Feedback

The FaxEnvelopeProperties type exposes the following members.

Constructors

 | Name | Description
Public method | FaxEnvelopeProperties | Initializes a new instance of the FaxEnvelopeProperties class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFromMessage | Deserializes an instance of FaxEnvelopeProperties from a server message.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualTransmissionSpeed | Gets the actual transmission speed in bytes/sec.
Public property | CallFailureType | Gets the type of the call failure.
Public property | CallId | Gets the call ID.
Public property | CoverPage | Gets the cover page template for this fax.
Public property | DeliveryNotification | Gets the delivery notification data for this fax.
Public property | DeviceError | Gets the device error.
Public property | Duration | Gets the duration.
Public property | EnvelopeId | Gets the envelope ID.
Public property | FailedAttempts | Gets the count of failed attempts.
Public property | FaxDeviceName | Gets the name of the fax device from which the fax is recevied.
Public property | FaxId | Gets the fax ID.
Public property | FromNumber | Gets the telephone number of the sender of the fax.
Public property | LineId | Gets the line ID.
Public property | LocalCsid | Gets the local CSID.
Public property | Options | Gets the transimssion options for this fax.
Public property | RemoteCsid | Gets the remote CSID.
Public property | RetryStrategy | Gets the retry strategy.
Public property | Schedule | Gets the delivery schedule for this fax.
Public property | SenderId | The unique identifier for a user sending a fax. This is an IC User name or name of an IP handler.
Public property | T30SubAddress | Gets the T30 subaddress.
Public property | TimeSent | Gets the time sent.
Public property | ToAddress | Gets recipient address information.
Public property | UserError | Gets the user error.

See Also

FaxEnvelopeProperties Class
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelopeProperties Constructor

[image]

IceLib Technical Reference
FaxEnvelopeProperties Constructor
FaxEnvelopeProperties Class See Also Send Feedback
Initializes a new instance of the FaxEnvelopeProperties class.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEnvelopeProperties()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelopeProperties Methods

[image] [image]

IceLib Technical Reference
FaxEnvelopeProperties Methods
FaxEnvelopeProperties Class See Also Send Feedback

The FaxEnvelopeProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadFromMessage | Deserializes an instance of FaxEnvelopeProperties from a server message.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxEnvelopeProperties Class
ININ.IceLib.UnifiedMessaging Namespace


ReadFromMessage Method

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..ReadFromMessage Method
FaxEnvelopeProperties Class See Also Send Feedback
Deserializes an instance of FaxEnvelopeProperties from a server message.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static FaxEnvelopeProperties ReadFromMessage(
    NotifierReader reader
)
Visual Basic
Public Shared Function ReadFromMessage ( _
    reader As NotifierReader _
) As FaxEnvelopeProperties

Parameters

reader
Type: NotifierReader
The NotifierReader.

Return Value

A new instance of FaxEnvelopeProperties.

Exceptions

Exception | Condition
System..::..ArgumentNullException | If reader is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEnvelopeProperties Properties

[image] [image]

IceLib Technical Reference
FaxEnvelopeProperties Properties
FaxEnvelopeProperties Class See Also Send Feedback

The FaxEnvelopeProperties type exposes the following members.

Properties

 | Name | Description
Public property | ActualTransmissionSpeed | Gets the actual transmission speed in bytes/sec.
Public property | CallFailureType | Gets the type of the call failure.
Public property | CallId | Gets the call ID.
Public property | CoverPage | Gets the cover page template for this fax.
Public property | DeliveryNotification | Gets the delivery notification data for this fax.
Public property | DeviceError | Gets the device error.
Public property | Duration | Gets the duration.
Public property | EnvelopeId | Gets the envelope ID.
Public property | FailedAttempts | Gets the count of failed attempts.
Public property | FaxDeviceName | Gets the name of the fax device from which the fax is recevied.
Public property | FaxId | Gets the fax ID.
Public property | FromNumber | Gets the telephone number of the sender of the fax.
Public property | LineId | Gets the line ID.
Public property | LocalCsid | Gets the local CSID.
Public property | Options | Gets the transimssion options for this fax.
Public property | RemoteCsid | Gets the remote CSID.
Public property | RetryStrategy | Gets the retry strategy.
Public property | Schedule | Gets the delivery schedule for this fax.
Public property | SenderId | The unique identifier for a user sending a fax. This is an IC User name or name of an IP handler.
Public property | T30SubAddress | Gets the T30 subaddress.
Public property | TimeSent | Gets the time sent.
Public property | ToAddress | Gets recipient address information.
Public property | UserError | Gets the user error.

See Also

FaxEnvelopeProperties Class
ININ.IceLib.UnifiedMessaging Namespace


ActualTransmissionSpeed Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..ActualTransmissionSpeed Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the actual transmission speed in bytes/sec.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ActualTransmissionSpeed { get; }
Visual Basic
Public ReadOnly Property ActualTransmissionSpeed As Integer
    Get

Field Value

The actual transmission speed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


CallFailureType Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..CallFailureType Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the type of the call failure.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public CallFailureType CallFailureType { get; }
Visual Basic
Public ReadOnly Property CallFailureType As CallFailureType
    Get

Field Value

The type of the call failure.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


CallId Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..CallId Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the call ID.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long CallId { get; }
Visual Basic
Public ReadOnly Property CallId As Long
    Get

Field Value

The call ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


CoverPage Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..CoverPage Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the cover page template for this fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxCoverPageTemplate CoverPage { get; }
Visual Basic
Public ReadOnly Property CoverPage As FaxCoverPageTemplate
    Get

Field Value

The cover page template for this fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


DeliveryNotification Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..DeliveryNotification Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the delivery notification data for this fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliveryNotification DeliveryNotification { get; }
Visual Basic
Public ReadOnly Property DeliveryNotification As FaxDeliveryNotification
    Get

Field Value

The delivery notification for this fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


DeviceError Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..DeviceError Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the device error.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DeviceError { get; }
Visual Basic
Public ReadOnly Property DeviceError As String
    Get

Field Value

The device error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


Duration Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..Duration Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the duration.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Duration { get; }
Visual Basic
Public ReadOnly Property Duration As Integer
    Get

Field Value

The duration.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


EnvelopeId Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..EnvelopeId Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the envelope ID.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long EnvelopeId { get; }
Visual Basic
Public ReadOnly Property EnvelopeId As Long
    Get

Field Value

The envelope ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FailedAttempts Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..FailedAttempts Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the count of failed attempts.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int FailedAttempts { get; }
Visual Basic
Public ReadOnly Property FailedAttempts As Integer
    Get

Field Value

The count failed attempts.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FaxDeviceName Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..FaxDeviceName Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the name of the fax device from which the fax is recevied.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FaxDeviceName { get; }
Visual Basic
Public ReadOnly Property FaxDeviceName As String
    Get

Field Value

The name of the fax device from which the fax is received.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FaxId Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..FaxId Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the fax ID.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long FaxId { get; }
Visual Basic
Public ReadOnly Property FaxId As Long
    Get

Field Value

The fax ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FromNumber Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..FromNumber Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the telephone number of the sender of the fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FromNumber { get; }
Visual Basic
Public ReadOnly Property FromNumber As String
    Get

Field Value

The telephone number of the sender of the fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


LineId Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..LineId Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the line ID.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int LineId { get; }
Visual Basic
Public ReadOnly Property LineId As Integer
    Get

Field Value

The line ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


LocalCsid Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..LocalCsid Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the local CSID.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string LocalCsid { get; }
Visual Basic
Public ReadOnly Property LocalCsid As String
    Get

Field Value

The local CSID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


Options Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..Options Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the transimssion options for this fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxTransmitOptions Options { get; }
Visual Basic
Public ReadOnly Property Options As FaxTransmitOptions
    Get

Field Value

The transmission options for this fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


RemoteCsid Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..RemoteCsid Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the remote CSID.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RemoteCsid { get; }
Visual Basic
Public ReadOnly Property RemoteCsid As String
    Get

Field Value

The remote CSID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


RetryStrategy Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..RetryStrategy Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the retry strategy.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RetryStrategyType RetryStrategy { get; }
Visual Basic
Public ReadOnly Property RetryStrategy As RetryStrategyType
    Get

Field Value

The retry strategy.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


Schedule Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..Schedule Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the delivery schedule for this fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxDeliverySchedule Schedule { get; }
Visual Basic
Public ReadOnly Property Schedule As FaxDeliverySchedule
    Get

Field Value

The delivery schedule for this fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


SenderId Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..SenderId Property
FaxEnvelopeProperties Class See Also Send Feedback
The unique identifier for a user sending a fax. This is an IC User name or name of an IP handler.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string SenderId { get; }
Visual Basic
Public ReadOnly Property SenderId As String
    Get

Field Value

The sender ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


T30SubAddress Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..T30SubAddress Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the T30 subaddress.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string T30SubAddress { get; }
Visual Basic
Public ReadOnly Property T30SubAddress As String
    Get

Field Value

The T30 subaddress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


TimeSent Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..TimeSent Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the time sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime TimeSent { get; }
Visual Basic
Public ReadOnly Property TimeSent As DateTime
    Get

Field Value

The time sent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


ToAddress Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..ToAddress Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets recipient address information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxAddressee ToAddress { get; }
Visual Basic
Public ReadOnly Property ToAddress As FaxAddressee
    Get

Field Value

The recipient address information.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


UserError Property

[image]

IceLib Technical Reference
FaxEnvelopeProperties..::..UserError Property
FaxEnvelopeProperties Class See Also Send Feedback
Gets the user error.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string UserError { get; }
Visual Basic
Public ReadOnly Property UserError As String
    Get

Field Value

The user error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEnvelopeProperties Class
FaxEnvelopeProperties Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEventArgs Class

[image]

IceLib Technical Reference
FaxEventArgs Class
Members See Also Send Feedback
Provides data for the NewFax, FaxDeleted, and FaxUpdated events.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxEventArgs : EventArgs
Visual Basic
Public Class FaxEventArgs _
    Inherits EventArgs

Remarks

Handle the NewFax event to be informed when a new Fax has been added to the Faxes list.
Handle the FaxDeleted event to be informed when an existing Fax has been removed from the Faxes list.
Handle the FaxUpdated event to be informed when an existing Fax in the Faxes list has been changed.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.UnifiedMessaging..::..FaxEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEventArgs Members

[image] [image]

IceLib Technical Reference
FaxEventArgs Members
FaxEventArgs Class Constructors Methods Properties See Also Send Feedback

The FaxEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FaxEventArgs | Initializes a new instance of the FaxEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets the Fax message associated with the event.

See Also

FaxEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxEventArgs Constructor

[image]

IceLib Technical Reference
FaxEventArgs Constructor
FaxEventArgs Class See Also Send Feedback
Initializes a new instance of the FaxEventArgs class with the specified values.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEventArgs(
    FaxMessage message
)
Visual Basic
Public Sub New ( _
    message As FaxMessage _
)

Parameters

message
Type: ININ.IceLib.UnifiedMessaging..::..FaxMessage
The message.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEventArgs Class
FaxEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


FaxEventArgs Methods

[image] [image]

IceLib Technical Reference
FaxEventArgs Methods
FaxEventArgs Class See Also Send Feedback

The FaxEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxEventArgs Properties

[image] [image]

IceLib Technical Reference
FaxEventArgs Properties
FaxEventArgs Class See Also Send Feedback

The FaxEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the Fax message associated with the event.

See Also

FaxEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


Message Property

[image]

IceLib Technical Reference
FaxEventArgs..::..Message Property
FaxEventArgs Class See Also Send Feedback
Gets the Fax message associated with the event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxMessage Message { get; }
Visual Basic
Public ReadOnly Property Message As FaxMessage
    Get

Field Value

The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxEventArgs Class
FaxEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


FaxFile Class

[image]

IceLib Technical Reference
FaxFile Class
Members See Also Send Feedback
Provides an interface for manipulating Fax files on a file system in .i3f or .TIF format.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxFile : IDisposable
Visual Basic
Public Class FaxFile _
    Implements IDisposable

Remarks

Use the FaxFile class to create, read from or write to a .TIF or .i3f formatted Fax file on a file system. You can add, remove and update each Image representing a page in a Fax and commit the changes to a .TIF or .i3f file on a file system. All modifications are kept in memory until the SaveAs(String, StorageFormat) method is called.

Note
Most fax terminals can't handle widths larger than 1728 pixels. If the width of the Image will exceed 1728 pixels, it is recommended to store the image in portrait orientation and set the FaxPageAttributes instance to indicate that the image has been rotated.
This can also be handled by specifying FitToPage when adding or updating pages. This will cause the image to be scaled to fit on the page. If FitToPage is not specified, no resizing will be done and the image will be cropped.

The FaxFile class also provides methods for manipulating the envelopes necessary for submitting a Fax to an IC server. Before an .i3f file can be submitted for sending, one or more envelopes must be added and the Fax file saved to the file system. Use AddEnvelope(FaxEnvelope) to add a FaxEnvelope for each recipient who will receive a copy of the fax.

Note
Envelopes are not generally considered part of a Fax and are used primarily for delivery purposes. It is recommended that you build the fax containing envelopes in a temporary location in the file system. That addressed Fax can then be deleted when the send operation is complete.

Examples

The following example demonstrates the creation and delivery of a new FaxFile.
CopyC#
_faxFile = new ININ.IceLib.UnifiedMessaging.FaxFile();

FaxPageAttributes pageAttributes = new FaxPageAttributes();
pageAttributes.Resolution =
    new PageResolution( Convert.ToInt32(faxPageImage.HorizontalResolution),
                        Convert.ToInt32(faxPageImage.VerticalResolution));

_faxFile.AddPage(faxPageImage, pageAttributes);

// Gather information about the intended recipients, delivery schedule, etc. from a user
...

DateTime submitTime = DateTime.Now;
foreach (FaxAddressee recipient in dlg.Recipients)
{
    FaxEnvelope envelope = new FaxEnvelope(recipient,
        dlg.CoverPageTemplate, dlg.DeliverySchedule,
        dlg.DeliveryNotification, dlg.TransmitOptions);

    envelope.SenderId = icUser; // userId of IC user submitting the fax
    envelope.TimeSent = submitTime;

    _faxFile.AddEnvelope(envelope);
}

string tempFilename = System.IO.Path.GetTempFileName();
_faxFile.SaveAs(tempFilename, StorageFormat.I3F);

UnifiedMessagingManager manager = UnifiedMessagingManager.GetInstance(IceLibSession);
try
{
    manager.SendFax(tempFilename);
}

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxFile

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
ININ.IceLib.UnifiedMessaging..::..UnifiedMessagingManager


FaxFile Members

[image] [image]

IceLib Technical Reference
FaxFile Members
FaxFile Class Constructors Methods Fields Properties See Also Send Feedback

The FaxFile type exposes the following members.

Constructors

 | Name | Description
Public method | FaxFile | Constructs a new Fax file interface with an underlying empty temporary Fax file in the filesystem.

Methods

 | Name | Description
Public method | AddEnvelope | Adds a new envelope to the Fax.
Public method | AddPage(Image, FaxPageAttributes) | Adds a new page to the Fax.
Public method | AddPage(Image, FaxPageAttributes, FaxPageSettings) | Adds a new page to the Fax for each frame in the input image.
Public method | Dispose()()()() | Releases all stored image objects and removes the scratch file from the filesystem.
Protected method | Dispose(Boolean) | Internal implementation for the Dispose, allowing it to be called by a finalizer if desired.
Public method | Envelope | Returns a Fax Envelope object representing delivery details for a Fax.
Public method | EnvelopeId | Returns the identifier for an envelope. IDs are typically an 8 character filename with the extension ENV.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPage(Int32, Image, FaxPageAttributes) | Inserts a new page into the Fax at the specified index.
Public method | InsertPage(Int32, Image, FaxPageAttributes, FaxPageSettings) | Inserts a new page in the fax, starting at the specified index.
Public method | LoadFrom | Populates this Fax object by copying all information found in the specified Fax file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MovePage | Moves a page up or down in the page ordering by index.
Public method | PageAttributes(Int32) | Returns the information for a specific page in a Fax.
Public method | PageAttributes(String) | Returns the attribute information for a specific page in a Fax.
Public method | PageId | Returns the identifier for a page image. IDs are typically a TIFF filename with the extension .TIF.
Public method | PageImage(Int32) | Returns a Bitmap object representing a Fax page.
Public method | PageImage(String) | Returns a Bitmap object representing a Fax page.
Public method | RemoveEnvelope(Int32) | Remove an envelope from the Fax.
Public method | RemoveEnvelope(String) | Remove an envelope from the Fax.
Public method | RemovePage(Int32) | Remove a page and it's associated page information from the Fax.
Public method | RemovePage(String) | Removes a page and it's associated page information from the Fax.
Public method | SaveAs | Saves the working Fax file using the provided filename.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePage(Int32, Image, FaxPageAttributes) | Updates the page image and attributes for a specified page.
Public method | UpdatePage(String, Image, FaxPageAttributes) | Updates the page image and attributes for a specified page.
Public method | UpdatePage(String, Image, FaxPageAttributes, FaxPageSettings) | Updates the page image and attributes for a specified page.

Fields

Name | Description
StandardFaxImageWidth | The width, in pixels, of a standard fax image.

Properties

 | Name | Description
Public property | EnvelopeCount | Returns a count of the number of envelopes in this Fax.
Public property | PageCount | Returns a count of the number of pages in this Fax.

See Also

FaxFile Class
ININ.IceLib.UnifiedMessaging Namespace


FaxFile Constructor

[image]

IceLib Technical Reference
FaxFile Constructor
FaxFile Class See Also Send Feedback
Constructs a new Fax file interface with an underlying empty temporary Fax file in the filesystem.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxFile()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


FaxFile Fields

[image] [image]

IceLib Technical Reference
FaxFile Fields
FaxFile Class See Also Send Feedback

The FaxFile type exposes the following members.

Fields

Name | Description
StandardFaxImageWidth | The width, in pixels, of a standard fax image.

See Also

FaxFile Class
ININ.IceLib.UnifiedMessaging Namespace


StandardFaxImageWidth Field

[image]

IceLib Technical Reference
FaxFile..::..StandardFaxImageWidth Field
FaxFile Class See Also Send Feedback
The width, in pixels, of a standard fax image.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static readonly int StandardFaxImageWidth
Visual Basic
Public Shared ReadOnly StandardFaxImageWidth As Integer

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


FaxFile Methods

[image] [image]

IceLib Technical Reference
FaxFile Methods
FaxFile Class See Also Send Feedback

The FaxFile type exposes the following members.

Methods

 | Name | Description
Public method | AddEnvelope | Adds a new envelope to the Fax.
Public method | AddPage(Image, FaxPageAttributes) | Adds a new page to the Fax.
Public method | AddPage(Image, FaxPageAttributes, FaxPageSettings) | Adds a new page to the Fax for each frame in the input image.
Public method | Dispose()()()() | Releases all stored image objects and removes the scratch file from the filesystem.
Protected method | Dispose(Boolean) | Internal implementation for the Dispose, allowing it to be called by a finalizer if desired.
Public method | Envelope | Returns a Fax Envelope object representing delivery details for a Fax.
Public method | EnvelopeId | Returns the identifier for an envelope. IDs are typically an 8 character filename with the extension ENV.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertPage(Int32, Image, FaxPageAttributes) | Inserts a new page into the Fax at the specified index.
Public method | InsertPage(Int32, Image, FaxPageAttributes, FaxPageSettings) | Inserts a new page in the fax, starting at the specified index.
Public method | LoadFrom | Populates this Fax object by copying all information found in the specified Fax file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MovePage | Moves a page up or down in the page ordering by index.
Public method | PageAttributes(Int32) | Returns the information for a specific page in a Fax.
Public method | PageAttributes(String) | Returns the attribute information for a specific page in a Fax.
Public method | PageId | Returns the identifier for a page image. IDs are typically a TIFF filename with the extension .TIF.
Public method | PageImage(Int32) | Returns a Bitmap object representing a Fax page.
Public method | PageImage(String) | Returns a Bitmap object representing a Fax page.
Public method | RemoveEnvelope(Int32) | Remove an envelope from the Fax.
Public method | RemoveEnvelope(String) | Remove an envelope from the Fax.
Public method | RemovePage(Int32) | Remove a page and it's associated page information from the Fax.
Public method | RemovePage(String) | Removes a page and it's associated page information from the Fax.
Public method | SaveAs | Saves the working Fax file using the provided filename.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePage(Int32, Image, FaxPageAttributes) | Updates the page image and attributes for a specified page.
Public method | UpdatePage(String, Image, FaxPageAttributes) | Updates the page image and attributes for a specified page.
Public method | UpdatePage(String, Image, FaxPageAttributes, FaxPageSettings) | Updates the page image and attributes for a specified page.

See Also

FaxFile Class
ININ.IceLib.UnifiedMessaging Namespace


AddEnvelope Method

[image]

IceLib Technical Reference
FaxFile..::..AddEnvelope Method
FaxFile Class See Also Send Feedback
Adds a new envelope to the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddEnvelope(
    FaxEnvelope envelope
)
Visual Basic
Public Sub AddEnvelope ( _
    envelope As FaxEnvelope _
)

Parameters

envelope
Type: ININ.IceLib.UnifiedMessaging..::..FaxEnvelope
The FaxEnvelope envelope.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope


AddPage Method

[image] [image]

IceLib Technical Reference
FaxFile..::..AddPage Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPage(Image, FaxPageAttributes) | Adds a new page to the Fax.
Public method | AddPage(Image, FaxPageAttributes, FaxPageSettings) | Adds a new page to the Fax for each frame in the input image.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


AddPage Method (Image, FaxPageAttributes)

[image]

IceLib Technical Reference
FaxFile..::..AddPage Method (Image, FaxPageAttributes)
FaxFile Class See Also Send Feedback
Adds a new page to the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddPage(
    Image pageImage,
    FaxPageAttributes faxPageAttributes
)
Visual Basic
Public Sub AddPage ( _
    pageImage As Image, _
    faxPageAttributes As FaxPageAttributes _
)

Parameters

pageImage
Type: System.Drawing..::..Image
The Image image of the Fax page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The page attributes that describe the new Fax page.

Remarks

The image will be resized using FitToPage and MaintainAspectRatio. The quality will be set to Standard. The page size will be Letter. If pageImage is a multi-page Image a new page will be appended to the Fax using only the first frame of the Image.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
AddPage Overload
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes


AddPage Method (Image, FaxPageAttributes, FaxPageSettings)

[image]

IceLib Technical Reference
FaxFile..::..AddPage Method (Image, FaxPageAttributes, FaxPageSettings)
FaxFile Class See Also Send Feedback
Adds a new page to the Fax for each frame in the input image.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void AddPage(
    Image pageImage,
    FaxPageAttributes faxPageAttributes,
    FaxPageSettings faxPageSettings
)
Visual Basic
Public Sub AddPage ( _
    pageImage As Image, _
    faxPageAttributes As FaxPageAttributes, _
    faxPageSettings As FaxPageSettings _
)

Parameters

pageImage
Type: System.Drawing..::..Image
The Image image of the Fax page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The fax page attributes.
faxPageSettings
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageSettings
The fax page settings.

Remarks

A new page will be appended to the Fax, in order, for each frame in pageImage.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
AddPage Overload
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes


Dispose Method

[image] [image]

IceLib Technical Reference
FaxFile..::..Dispose Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all stored image objects and removes the scratch file from the filesystem.
Protected method | Dispose(Boolean) | Internal implementation for the Dispose, allowing it to be called by a finalizer if desired.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method

[image]

IceLib Technical Reference
FaxFile..::..Dispose Method
FaxFile Class See Also Send Feedback
Releases all stored image objects and removes the scratch file from the filesystem.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
Dispose Overload
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
FaxFile..::..Dispose Method (Boolean)
FaxFile Class See Also Send Feedback
Internal implementation for the Dispose, allowing it to be called by a finalizer if desired.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates if the object is being disposed. falseFalsefalsefalse (False in Visual Basic) indicates the object is being finalized.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
Dispose Overload
ININ.IceLib.UnifiedMessaging Namespace


Envelope Method

[image]

IceLib Technical Reference
FaxFile..::..Envelope Method
FaxFile Class See Also Send Feedback
Returns a Fax Envelope object representing delivery details for a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEnvelope Envelope(
    int envelopeIndex
)
Visual Basic
Public Function Envelope ( _
    envelopeIndex As Integer _
) As FaxEnvelope

Parameters

envelopeIndex
Type: System..::..Int32
The 0 based envelope number in the Fax whose object is being requested.

Return Value

Fax Envelope object representing the delivery details.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


EnvelopeId Method

[image]

IceLib Technical Reference
FaxFile..::..EnvelopeId Method
FaxFile Class See Also Send Feedback
Returns the identifier for an envelope. IDs are typically an 8 character filename with the extension ENV.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string EnvelopeId(
    int envelopeIndex
)
Visual Basic
Public Function EnvelopeId ( _
    envelopeIndex As Integer _
) As String

Parameters

envelopeIndex
Type: System..::..Int32
The 0 based envelope number of the envelope whose ID is being requested.

Return Value

The string name used to identify the envelope data.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | Thrown when the ID is requested for an envelope that doesn't exist.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


InsertPage Method

[image] [image]

IceLib Technical Reference
FaxFile..::..InsertPage Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertPage(Int32, Image, FaxPageAttributes) | Inserts a new page into the Fax at the specified index.
Public method | InsertPage(Int32, Image, FaxPageAttributes, FaxPageSettings) | Inserts a new page in the fax, starting at the specified index.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


InsertPage Method (Int32, Image, FaxPageAttributes)

[image]

IceLib Technical Reference
FaxFile..::..InsertPage Method (Int32, Image, FaxPageAttributes)
FaxFile Class See Also Send Feedback
Inserts a new page into the Fax at the specified index.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InsertPage(
    int pageIndex,
    Image pageImage,
    FaxPageAttributes faxPageAttributes
)
Visual Basic
Public Sub InsertPage ( _
    pageIndex As Integer, _
    pageImage As Image, _
    faxPageAttributes As FaxPageAttributes _
)

Parameters

pageIndex
Type: System..::..Int32
The 0 based location of the page within the Fax. A value of -1 indicates that the page should be inserted at the end.
pageImage
Type: System.Drawing..::..Image
The Image image of the fax page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The page attributes that describe the new Fax page.

Remarks

If pageImage is a multi-page Image a new page will be inserted in the Fax using the first frame of the Image.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | If pageIndex is greater than the number of pages or an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
InsertPage Overload
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes


InsertPage Method (Int32, Image, FaxPageAttributes, FaxPageSettings)

[image]

IceLib Technical Reference
FaxFile..::..InsertPage Method (Int32, Image, FaxPageAttributes, FaxPageSettings)
FaxFile Class See Also Send Feedback
Inserts a new page in the fax, starting at the specified index.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void InsertPage(
    int pageIndex,
    Image faxPageImage,
    FaxPageAttributes faxPageAttributes,
    FaxPageSettings faxPageSettings
)
Visual Basic
Public Sub InsertPage ( _
    pageIndex As Integer, _
    faxPageImage As Image, _
    faxPageAttributes As FaxPageAttributes, _
    faxPageSettings As FaxPageSettings _
)

Parameters

pageIndex
Type: System..::..Int32
The 0 based location of the page within the Fax. A value of -1 indicates that the page should be inserted at the end.
faxPageImage
Type: System.Drawing..::..Image
The Image image of the fax page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The page attributes that describe the new Fax page.
faxPageSettings
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageSettings
The fax page settings that control how faxPageImage will be added to the fax page.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentOutOfRangeException | If pageIndex is greater than the number of pages or an invalid value.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
InsertPage Overload
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes


LoadFrom Method

[image]

IceLib Technical Reference
FaxFile..::..LoadFrom Method
FaxFile Class See Also Send Feedback
Populates this Fax object by copying all information found in the specified Fax file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void LoadFrom(
    string fileName,
    StorageFormat storageFormat
)
Visual Basic
Public Sub LoadFrom ( _
    fileName As String, _
    storageFormat As StorageFormat _
)

Parameters

fileName
Type: System..::..String
Existing i3f or Tiff Fax file to retrieve information from.
storageFormat
Type: ININ.IceLib.UnifiedMessaging..::..StorageFormat
The format that was used to store the Fax data.

Remarks

When a Tiff file is specified the file must contain only a valid 1bpp indexed Tiff image.

Exceptions

Exception | Condition
System.IO..::..FileLoadException | Thrown when the structure of an i3f file is incorrect.
System.IO..::..IOException | General stream read error or there was an error creating a temporary file.
System..::..ArgumentException | Thrown when the API is unable to determine the storage format by extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


MovePage Method

[image]

IceLib Technical Reference
FaxFile..::..MovePage Method
FaxFile Class See Also Send Feedback
Moves a page up or down in the page ordering by index.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void MovePage(
    int pageIndex,
    int newIndex
)
Visual Basic
Public Sub MovePage ( _
    pageIndex As Integer, _
    newIndex As Integer _
)

Parameters

pageIndex
Type: System..::..Int32
The 0 based page number of the Fax page that is being moved.
newIndex
Type: System..::..Int32
The 0 based page number to move in front of. A value of -1 indicates that the page should be moved to the end.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If pageIndex or newIndex is greater than the number of pages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


PageAttributes Method

[image] [image]

IceLib Technical Reference
FaxFile..::..PageAttributes Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PageAttributes(Int32) | Returns the information for a specific page in a Fax.
Public method | PageAttributes(String) | Returns the attribute information for a specific page in a Fax.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


PageAttributes Method (Int32)

[image]

IceLib Technical Reference
FaxFile..::..PageAttributes Method (Int32)
FaxFile Class See Also Send Feedback
Returns the information for a specific page in a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxPageAttributes PageAttributes(
    int pageIndex
)
Visual Basic
Public Function PageAttributes ( _
    pageIndex As Integer _
) As FaxPageAttributes

Parameters

pageIndex
Type: System..::..Int32
The 0 based page number of the Fax page whose information is being requested.

Return Value

A FaxPageAttributes object describing the Fax page image.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
PageAttributes Overload
ININ.IceLib.UnifiedMessaging Namespace


PageAttributes Method (String)

[image]

IceLib Technical Reference
FaxFile..::..PageAttributes Method (String)
FaxFile Class See Also Send Feedback
Returns the attribute information for a specific page in a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxPageAttributes PageAttributes(
    string pageId
)
Visual Basic
Public Function PageAttributes ( _
    pageId As String _
) As FaxPageAttributes

Parameters

pageId
Type: System..::..String
The ID of the Fax page whose information is being requested.

Return Value

A FaxPageAttributes object describing the Fax page image.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
PageAttributes Overload
ININ.IceLib.UnifiedMessaging Namespace


PageId Method

[image]

IceLib Technical Reference
FaxFile..::..PageId Method
FaxFile Class See Also Send Feedback
Returns the identifier for a page image. IDs are typically a TIFF filename with the extension .TIF.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PageId(
    int pageIndex
)
Visual Basic
Public Function PageId ( _
    pageIndex As Integer _
) As String

Parameters

pageIndex
Type: System..::..Int32
The 0 based page number of the page whose ID is being requested.

Return Value

The string name used to identify the page image.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | Thrown when the ID is requested for a page that doesn't exist.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


PageImage Method

[image] [image]

IceLib Technical Reference
FaxFile..::..PageImage Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PageImage(Int32) | Returns a Bitmap object representing a Fax page.
Public method | PageImage(String) | Returns a Bitmap object representing a Fax page.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


PageImage Method (Int32)

[image]

IceLib Technical Reference
FaxFile..::..PageImage Method (Int32)
FaxFile Class See Also Send Feedback
Returns a Bitmap object representing a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Image PageImage(
    int pageIndex
)
Visual Basic
Public Function PageImage ( _
    pageIndex As Integer _
) As Image

Parameters

pageIndex
Type: System..::..Int32
The 0 based page number in the Fax whose image is being requested.

Return Value

Bitmap object representing the Fax page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
PageImage Overload
ININ.IceLib.UnifiedMessaging Namespace


PageImage Method (String)

[image]

IceLib Technical Reference
FaxFile..::..PageImage Method (String)
FaxFile Class See Also Send Feedback
Returns a Bitmap object representing a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Image PageImage(
    string pageId
)
Visual Basic
Public Function PageImage ( _
    pageId As String _
) As Image

Parameters

pageId
Type: System..::..String
The page identifier of the Fax page whose image is being requested.

Return Value

Bitmap object representing the Fax page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
PageImage Overload
ININ.IceLib.UnifiedMessaging Namespace


RemoveEnvelope Method

[image] [image]

IceLib Technical Reference
FaxFile..::..RemoveEnvelope Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveEnvelope(Int32) | Remove an envelope from the Fax.
Public method | RemoveEnvelope(String) | Remove an envelope from the Fax.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


RemoveEnvelope Method (Int32)

[image]

IceLib Technical Reference
FaxFile..::..RemoveEnvelope Method (Int32)
FaxFile Class See Also Send Feedback
Remove an envelope from the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveEnvelope(
    int envelopeIndex
)
Visual Basic
Public Sub RemoveEnvelope ( _
    envelopeIndex As Integer _
)

Parameters

envelopeIndex
Type: System..::..Int32
The 0 based envelope number of the envelope that is being removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
RemoveEnvelope Overload
ININ.IceLib.UnifiedMessaging Namespace


RemoveEnvelope Method (String)

[image]

IceLib Technical Reference
FaxFile..::..RemoveEnvelope Method (String)
FaxFile Class See Also Send Feedback
Remove an envelope from the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemoveEnvelope(
    string envelopeId
)
Visual Basic
Public Sub RemoveEnvelope ( _
    envelopeId As String _
)

Parameters

envelopeId
Type: System..::..String
The identifier of the envelope being removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
RemoveEnvelope Overload
ININ.IceLib.UnifiedMessaging Namespace


RemovePage Method

[image] [image]

IceLib Technical Reference
FaxFile..::..RemovePage Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemovePage(Int32) | Remove a page and it's associated page information from the Fax.
Public method | RemovePage(String) | Removes a page and it's associated page information from the Fax.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


RemovePage Method (Int32)

[image]

IceLib Technical Reference
FaxFile..::..RemovePage Method (Int32)
FaxFile Class See Also Send Feedback
Remove a page and it's associated page information from the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemovePage(
    int pageIndex
)
Visual Basic
Public Sub RemovePage ( _
    pageIndex As Integer _
)

Parameters

pageIndex
Type: System..::..Int32
The 0 based page number of the Fax page that is being removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
RemovePage Overload
ININ.IceLib.UnifiedMessaging Namespace


RemovePage Method (String)

[image]

IceLib Technical Reference
FaxFile..::..RemovePage Method (String)
FaxFile Class See Also Send Feedback
Removes a page and it's associated page information from the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RemovePage(
    string pageId
)
Visual Basic
Public Sub RemovePage ( _
    pageId As String _
)

Parameters

pageId
Type: System..::..String
The ID of the Fax page that is being removed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
RemovePage Overload
ININ.IceLib.UnifiedMessaging Namespace


SaveAs Method

[image]

IceLib Technical Reference
FaxFile..::..SaveAs Method
FaxFile Class See Also Send Feedback
Saves the working Fax file using the provided filename.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveAs(
    string fileName,
    StorageFormat storageFormat
)
Visual Basic
Public Sub SaveAs ( _
    fileName As String, _
    storageFormat As StorageFormat _
)

Parameters

fileName
Type: System..::..String
The full pathname of the file to write the Fax information to. If the destination file exists it will be overwritten.
storageFormat
Type: ININ.IceLib.UnifiedMessaging..::..StorageFormat
The format used to store the Fax data.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown when the API is unable to determine the storage format by extension.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


UpdatePage Method

[image] [image]

IceLib Technical Reference
FaxFile..::..UpdatePage Method
FaxFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdatePage(Int32, Image, FaxPageAttributes) | Updates the page image and attributes for a specified page.
Public method | UpdatePage(String, Image, FaxPageAttributes) | Updates the page image and attributes for a specified page.
Public method | UpdatePage(String, Image, FaxPageAttributes, FaxPageSettings) | Updates the page image and attributes for a specified page.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


UpdatePage Method (Int32, Image, FaxPageAttributes)

[image]

IceLib Technical Reference
FaxFile..::..UpdatePage Method (Int32, Image, FaxPageAttributes)
FaxFile Class See Also Send Feedback
Updates the page image and attributes for a specified page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdatePage(
    int pageIndex,
    Image pageImage,
    FaxPageAttributes faxPageAttributes
)
Visual Basic
Public Sub UpdatePage ( _
    pageIndex As Integer, _
    pageImage As Image, _
    faxPageAttributes As FaxPageAttributes _
)

Parameters

pageIndex
Type: System..::..Int32
The 0 based page number of the page being updated.
pageImage
Type: System.Drawing..::..Image
The new image for the page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The new attributes for the page.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The page to update does not exist.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
UpdatePage Overload
ININ.IceLib.UnifiedMessaging Namespace


UpdatePage Method (String, Image, FaxPageAttributes)

[image]

IceLib Technical Reference
FaxFile..::..UpdatePage Method (String, Image, FaxPageAttributes)
FaxFile Class See Also Send Feedback
Updates the page image and attributes for a specified page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdatePage(
    string pageId,
    Image pageImage,
    FaxPageAttributes faxPageAttributes
)
Visual Basic
Public Sub UpdatePage ( _
    pageId As String, _
    pageImage As Image, _
    faxPageAttributes As FaxPageAttributes _
)

Parameters

pageId
Type: System..::..String
The ID of the Fax page that is being removed.
pageImage
Type: System.Drawing..::..Image
The new image for the page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The new attributes for the page.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The specified page does not exist.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
UpdatePage Overload
ININ.IceLib.UnifiedMessaging Namespace


UpdatePage Method (String, Image, FaxPageAttributes, FaxPageSettings)

[image]

IceLib Technical Reference
FaxFile..::..UpdatePage Method (String, Image, FaxPageAttributes, FaxPageSettings)
FaxFile Class See Also Send Feedback
Updates the page image and attributes for a specified page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdatePage(
    string pageId,
    Image pageImage,
    FaxPageAttributes faxPageAttributes,
    FaxPageSettings faxPageSettings
)
Visual Basic
Public Sub UpdatePage ( _
    pageId As String, _
    pageImage As Image, _
    faxPageAttributes As FaxPageAttributes, _
    faxPageSettings As FaxPageSettings _
)

Parameters

pageId
Type: System..::..String
The ID of the Fax page that is being removed.
pageImage
Type: System.Drawing..::..Image
The new image for the page.
faxPageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
The fax page attributes.
faxPageSettings
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageSettings
The fax page settings.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | The specified page does not exist.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
UpdatePage Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxFile Properties

[image] [image]

IceLib Technical Reference
FaxFile Properties
FaxFile Class See Also Send Feedback

The FaxFile type exposes the following members.

Properties

 | Name | Description
Public property | EnvelopeCount | Returns a count of the number of envelopes in this Fax.
Public property | PageCount | Returns a count of the number of pages in this Fax.

See Also

FaxFile Class
ININ.IceLib.UnifiedMessaging Namespace


EnvelopeCount Property

[image]

IceLib Technical Reference
FaxFile..::..EnvelopeCount Property
FaxFile Class See Also Send Feedback
Returns a count of the number of envelopes in this Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int EnvelopeCount { get; }
Visual Basic
Public ReadOnly Property EnvelopeCount As Integer
    Get

Field Value

The envelope count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


PageCount Property

[image]

IceLib Technical Reference
FaxFile..::..PageCount Property
FaxFile Class See Also Send Feedback
Returns a count of the number of pages in this Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int PageCount { get; }
Visual Basic
Public ReadOnly Property PageCount As Integer
    Get

Field Value

The page count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxFile Class
FaxFile Members
ININ.IceLib.UnifiedMessaging Namespace


FaxImageQuality Enumeration

[image]

IceLib Technical Reference
FaxImageQuality Enumeration
See Also Send Feedback
Specifies the resolutions that can be used for the fax image.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxImageQuality
Visual Basic
Public Enumeration FaxImageQuality

Members

Member name | Value | Description
Standard | 0 | Standard fax resolution (204x98 pixels per inch).
Fine | 1 | Fine fax resolution (204x196 pixels per inch).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxImageSettings Enumeration

[image]

IceLib Technical Reference
FaxImageSettings Enumeration
See Also Send Feedback
Provides flags indicating how an image should be processed in preparation for faxing.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[FlagsAttribute]
public enum FaxImageSettings
Visual Basic
<FlagsAttribute> _
Public Enumeration FaxImageSettings

Members

Member name | Value | Description
None | 0 | No flags specified.
FitToPage | 1 | The image should be stretched to fit the page.
MaintainAspectRatio | 2 | The width and height of the image should be scaled by the same factor. This flag is only valid in conjunction with the FitToPage flag.
AddAllFrames | 8 | If this flag is set each frame of the image will be used, otherwise only the first frame will be used.
All | 11 | Every flag in the enum is set. Used for parameter checking, etc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxMessage Class

[image]

IceLib Technical Reference
FaxMessage Class
Members See Also Send Feedback
Represents a Fax message within the Interaction Center system.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxMessage : IDisposable
Visual Basic
Public Class FaxMessage _
    Implements IDisposable

Remarks

All FaxMessages are accessible through the Faxes property of the UnifiedMessagingManager instance. The Faxes list is not automatically kept current. It must be refreshed by calling RefreshFaxCache(Int32) or RefreshFaxCacheAsync(Int32, AsyncCompletedEventHandler, Object). In addition to referencing the entire list, code can be informed of changes to the list by subscribing to the NewFax, FaxDeleted, and FaxUpdated events.

A FaxMessage contains various pieces of information about the Fax itself (for example: From, To, Subject, Body), as well as a list of actual Fax file attachments to the FaxMessage. A FaxMessage may contain zero or more FaxAttachments (available from the Attachments property), each one representing a Fax file added to the Fax message at any given time. In typical scenarios there will only be one attachment which is the Fax itself, but it is possible for users to group several Fax files together into a single fax message.

Currently, FaxMessages may not be changed and saved.

Note
Although this is not typical, each FaxAttachment may not necessarily contain a Fax file. It is possible for a user to attach any file they wish to a FaxMessage.

Examples

The following example demonstrates saving a FaxAttachment to the file system.

CopyC#
...
UnifiedMessagingManager manager = UnifiedMessagingManager.GetInstance(_session);
manager.RefreshFaxCache(-1);
if (manager.Faxes.Count > 0)
{
    FaxMessage msg = manager.Faxes[0];
    if ((msg.Attachments.Count > 0) && (IsFaxFileExtension(msg.Attachments[0].Name))
    {
        string fileName = System.IO.Path.GetTempFileName();
        msg.SaveAsFile(msg.Attachments[0], fileName, true);
    }
}
...

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxMessage

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMessage Members

[image] [image]

IceLib Technical Reference
FaxMessage Members
FaxMessage Class Methods Properties Events See Also Send Feedback

The FaxMessage type exposes the following members.

Methods

 | Name | Description
Public method | CancelSaveAsFile | Cancels the current downloading to a file.
Public method | Delete | Issues a synchronous request to delete this FaxMessage.
Public method | DeleteAsync | Issues an asynchronous request to delete this FaxMessage.
Public method | Dispose()()()() | Releases resources held by this instance.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAsFile | Downloads this FaxMessage into a specified file.
Public method | SaveAsFileAsync | Asynchronously downloads this FaxMessage into a specified file.
Public method | SaveToStream | Downloads this FaxMessage into a specified stream.
Public method | SaveToStreamAsync | Asynchronously downloads this FaxMessage into a specified stream.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attachments | Gets the list of attachments on this FaxMessage.
Public property | Body | Gets the body text of this FaxMessage.
Public property | Cc | Gets the list of recipients carbon-copied on this FaxMessage.
Public property | DateReceived | Gets the DateTime this FaxMessage was received.
Public property | From | Gets the sender of the FaxMessage.
Public property | HasBeenRead | Gets a flag indicating whether this FaxMessage is marked as read or unread.
Public property | Id | Gets the ID of this FaxMessage.
Public property | Importance | Gets the importance level of this FaxMessage.
Public property | Moniker | Gets the moniker of this FaxMessage.
Public property | Sensitivity | Gets the sensitivity level of this FaxMessage.
Public property | Subject | Gets the subject of the FaxMessage.
Public property | To | Gets the list of recipients for this FaxMessage.

Events

 | Name | Description
Public event | DownloadProgressChanged | Occurs when the progress of downloading a FaxMessage changes.
Public event | PlaybackComplete | Occurs when playback to a remote number or station has completed.

See Also

FaxMessage Class
ININ.IceLib.UnifiedMessaging Namespace


FaxMessage Methods

[image] [image]

IceLib Technical Reference
FaxMessage Methods
FaxMessage Class See Also Send Feedback

The FaxMessage type exposes the following members.

Methods

 | Name | Description
Public method | CancelSaveAsFile | Cancels the current downloading to a file.
Public method | Delete | Issues a synchronous request to delete this FaxMessage.
Public method | DeleteAsync | Issues an asynchronous request to delete this FaxMessage.
Public method | Dispose()()()() | Releases resources held by this instance.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveAsFile | Downloads this FaxMessage into a specified file.
Public method | SaveAsFileAsync | Asynchronously downloads this FaxMessage into a specified file.
Public method | SaveToStream | Downloads this FaxMessage into a specified stream.
Public method | SaveToStreamAsync | Asynchronously downloads this FaxMessage into a specified stream.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxMessage Class
ININ.IceLib.UnifiedMessaging Namespace


CancelSaveAsFile Method

[image]

IceLib Technical Reference
FaxMessage..::..CancelSaveAsFile Method
FaxMessage Class See Also Send Feedback
Cancels the current downloading to a file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelSaveAsFile(
    FaxAttachment attachment
)
Visual Basic
Public Sub CancelSaveAsFile ( _
    attachment As FaxAttachment _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..FaxAttachment
The attachment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Delete Method

[image]

IceLib Technical Reference
FaxMessage..::..Delete Method
FaxMessage Class See Also Send Feedback
Issues a synchronous request to delete this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


DeleteAsync Method

[image]

IceLib Technical Reference
FaxMessage..::..DeleteAsync Method
FaxMessage Class See Also Send Feedback
Issues an asynchronous request to delete this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
FaxMessage..::..Dispose Method
FaxMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases resources held by this instance.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method

[image]

IceLib Technical Reference
FaxMessage..::..Dispose Method
FaxMessage Class See Also Send Feedback
Releases resources held by this instance.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
Dispose Overload
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
FaxMessage..::..Dispose Method (Boolean)
FaxMessage Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
Dispose Overload
ININ.IceLib.UnifiedMessaging Namespace


SaveAsFile Method

[image]

IceLib Technical Reference
FaxMessage..::..SaveAsFile Method
FaxMessage Class See Also Send Feedback
Downloads this FaxMessage into a specified file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SaveAsFile(
    FaxAttachment attachment,
    string fileName,
    bool markAsRead
)
Visual Basic
Public Function SaveAsFile ( _
    attachment As FaxAttachment, _
    fileName As String, _
    markAsRead As Boolean _
) As Boolean

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..FaxAttachment
The FaxAttachment of this message to download.
fileName
Type: System..::..String
The path and name of a local file to save the fax into.
markAsRead
Type: System..::..Boolean
Mark this message as read.

Return Value

trueTruetruetrue (True in Visual Basic) if the file was saved successfully.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If the fileName length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


SaveAsFileAsync Method

[image]

IceLib Technical Reference
FaxMessage..::..SaveAsFileAsync Method
FaxMessage Class See Also Send Feedback
Asynchronously downloads this FaxMessage into a specified file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveAsFileAsync(
    FaxAttachment attachment,
    string fileName,
    bool markAsRead,
    EventHandler<AsyncSaveAsFileCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SaveAsFileAsync ( _
    attachment As FaxAttachment, _
    fileName As String, _
    markAsRead As Boolean, _
    completedCallback As EventHandler(Of AsyncSaveAsFileCompletedEventArgs), _
    userState As Object _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..FaxAttachment
The FaxAttachment of this FaxMessage to download.
fileName
Type: System..::..String
The path and name of a local file to save the fax into.
markAsRead
Type: System..::..Boolean
Mark this FaxMessage as read.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncSaveAsFileCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If the fileName length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


SaveToStream Method

[image]

IceLib Technical Reference
FaxMessage..::..SaveToStream Method
FaxMessage Class See Also Send Feedback
Downloads this FaxMessage into a specified stream.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SaveToStream(
    FaxAttachment attachment,
    Stream stream,
    bool markAsRead
)
Visual Basic
Public Function SaveToStream ( _
    attachment As FaxAttachment, _
    stream As Stream, _
    markAsRead As Boolean _
) As Boolean

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..FaxAttachment
The FaxAttachment of this message to download.
stream
Type: System.IO..::..Stream
The stream to save the fax into.
markAsRead
Type: System..::..Boolean
Mark this message as read.

Return Value

trueTruetruetrue (True in Visual Basic) if the file was saved successfully.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


SaveToStreamAsync Method

[image]

IceLib Technical Reference
FaxMessage..::..SaveToStreamAsync Method
FaxMessage Class See Also Send Feedback
Asynchronously downloads this FaxMessage into a specified stream.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveToStreamAsync(
    FaxAttachment attachment,
    Stream stream,
    bool markAsRead,
    EventHandler<AsyncSaveAsFileCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SaveToStreamAsync ( _
    attachment As FaxAttachment, _
    stream As Stream, _
    markAsRead As Boolean, _
    completedCallback As EventHandler(Of AsyncSaveAsFileCompletedEventArgs), _
    userState As Object _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..FaxAttachment
The FaxAttachment of this FaxMessage to download.
stream
Type: System.IO..::..Stream
The stream to save the fax into.
markAsRead
Type: System..::..Boolean
Mark this FaxMessage as read.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncSaveAsFileCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 2 and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMessage Properties

[image] [image]

IceLib Technical Reference
FaxMessage Properties
FaxMessage Class See Also Send Feedback

The FaxMessage type exposes the following members.

Properties

 | Name | Description
Public property | Attachments | Gets the list of attachments on this FaxMessage.
Public property | Body | Gets the body text of this FaxMessage.
Public property | Cc | Gets the list of recipients carbon-copied on this FaxMessage.
Public property | DateReceived | Gets the DateTime this FaxMessage was received.
Public property | From | Gets the sender of the FaxMessage.
Public property | HasBeenRead | Gets a flag indicating whether this FaxMessage is marked as read or unread.
Public property | Id | Gets the ID of this FaxMessage.
Public property | Importance | Gets the importance level of this FaxMessage.
Public property | Moniker | Gets the moniker of this FaxMessage.
Public property | Sensitivity | Gets the sensitivity level of this FaxMessage.
Public property | Subject | Gets the subject of the FaxMessage.
Public property | To | Gets the list of recipients for this FaxMessage.

See Also

FaxMessage Class
ININ.IceLib.UnifiedMessaging Namespace


Attachments Property

[image]

IceLib Technical Reference
FaxMessage..::..Attachments Property
FaxMessage Class See Also Send Feedback
Gets the list of attachments on this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<FaxAttachment> Attachments { get; }
Visual Basic
Public ReadOnly Property Attachments As ReadOnlyCollection(Of FaxAttachment)
    Get

Field Value

The attachments.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Body Property

[image]

IceLib Technical Reference
FaxMessage..::..Body Property
FaxMessage Class See Also Send Feedback
Gets the body text of this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Body { get; }
Visual Basic
Public ReadOnly Property Body As String
    Get

Field Value

The body.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Cc Property

[image]

IceLib Technical Reference
FaxMessage..::..Cc Property
FaxMessage Class See Also Send Feedback
Gets the list of recipients carbon-copied on this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<FaxRecipient> Cc { get; }
Visual Basic
Public ReadOnly Property Cc As ReadOnlyCollection(Of FaxRecipient)
    Get

Field Value

The 'cc' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


DateReceived Property

[image]

IceLib Technical Reference
FaxMessage..::..DateReceived Property
FaxMessage Class See Also Send Feedback
Gets the DateTime this FaxMessage was received.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime DateReceived { get; }
Visual Basic
Public ReadOnly Property DateReceived As DateTime
    Get

Field Value

The date received.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


From Property

[image]

IceLib Technical Reference
FaxMessage..::..From Property
FaxMessage Class See Also Send Feedback
Gets the sender of the FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxRecipient From { get; }
Visual Basic
Public ReadOnly Property From As FaxRecipient
    Get

Field Value

The sender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


HasBeenRead Property

[image]

IceLib Technical Reference
FaxMessage..::..HasBeenRead Property
FaxMessage Class See Also Send Feedback
Gets a flag indicating whether this FaxMessage is marked as read or unread.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasBeenRead { get; }
Visual Basic
Public ReadOnly Property HasBeenRead As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has been read; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Id Property

[image]

IceLib Technical Reference
FaxMessage..::..Id Property
FaxMessage Class See Also Send Feedback
Gets the ID of this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Importance Property

[image]

IceLib Technical Reference
FaxMessage..::..Importance Property
FaxMessage Class See Also Send Feedback
Gets the importance level of this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Importance { get; }
Visual Basic
Public ReadOnly Property Importance As Integer
    Get

Field Value

The importance.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Moniker Property

[image]

IceLib Technical Reference
FaxMessage..::..Moniker Property
FaxMessage Class See Also Send Feedback
Gets the moniker of this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Moniker { get; }
Visual Basic
Public ReadOnly Property Moniker As String
    Get

Field Value

The moniker.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 15 and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Sensitivity Property

[image]

IceLib Technical Reference
FaxMessage..::..Sensitivity Property
FaxMessage Class See Also Send Feedback
Gets the sensitivity level of this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Sensitivity { get; }
Visual Basic
Public ReadOnly Property Sensitivity As Integer
    Get

Field Value

The sensitivity.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Subject Property

[image]

IceLib Technical Reference
FaxMessage..::..Subject Property
FaxMessage Class See Also Send Feedback
Gets the subject of the FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Subject { get; }
Visual Basic
Public ReadOnly Property Subject As String
    Get

Field Value

The subject.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


To Property

[image]

IceLib Technical Reference
FaxMessage..::..To Property
FaxMessage Class See Also Send Feedback
Gets the list of recipients for this FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<FaxRecipient> To { get; }
Visual Basic
Public ReadOnly Property To As ReadOnlyCollection(Of FaxRecipient)
    Get

Field Value

The 'to' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMessage Events

[image] [image]

IceLib Technical Reference
FaxMessage Events
FaxMessage Class See Also Send Feedback

The FaxMessage type exposes the following members.

Events

 | Name | Description
Public event | DownloadProgressChanged | Occurs when the progress of downloading a FaxMessage changes.
Public event | PlaybackComplete | Occurs when playback to a remote number or station has completed.

See Also

FaxMessage Class
ININ.IceLib.UnifiedMessaging Namespace


DownloadProgressChanged Event

[image]

IceLib Technical Reference
FaxMessage..::..DownloadProgressChanged Event
FaxMessage Class See Also Send Feedback
Occurs when the progress of downloading a FaxMessage changes.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<TransferProgressChangedEventArgs> DownloadProgressChanged
Visual Basic
Public Event DownloadProgressChanged As EventHandler(Of TransferProgressChangedEventArgs)

Remarks

This event will only occur when saving a fax as a file. To save a fax as a file call the SaveAsFile(FaxAttachment, String, Boolean) method or the SaveAsFileAsync(FaxAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object) method.
Note
All event handlers should be added before calling SaveAsFile(FaxAttachment, String, Boolean) or SaveAsFileAsync(FaxAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace
FaxMessage..::..SaveAsFile(FaxAttachment, String, Boolean)
FaxMessage..::..SaveAsFileAsync(FaxAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object)


PlaybackComplete Event

[image]

IceLib Technical Reference
FaxMessage..::..PlaybackComplete Event
FaxMessage Class See Also Send Feedback
Occurs when playback to a remote number or station has completed.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler PlaybackComplete
Visual Basic
Public Event PlaybackComplete As EventHandler

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMessage Class
FaxMessage Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMonitorUpdateEventArgs Class

[image]

IceLib Technical Reference
FaxMonitorUpdateEventArgs Class
Members See Also Send Feedback
Provides the FaxStatus for the FaxMonitorUpdate event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxMonitorUpdateEventArgs : EventArgs
Visual Basic
Public Class FaxMonitorUpdateEventArgs _
    Inherits EventArgs

Remarks

The FaxMonitorUpdateEventArgs class contains a single property FaxStatus that encapsulates all of the information necessary to communicate the current progress of an individual Fax. Each Fax in progress will periodically generate a new FaxStatus that will be broadcast to all registered listeners through the FaxMonitorUpdate event.

See ININ.IceLib.UnifiedMessaging for an example of responding to a FaxMonitorUpdate event.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.UnifiedMessaging..::..FaxMonitorUpdateEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMonitorUpdateEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMonitorUpdateEventArgs Members

[image] [image]

IceLib Technical Reference
FaxMonitorUpdateEventArgs Members
FaxMonitorUpdateEventArgs Class Constructors Methods Properties See Also Send Feedback

The FaxMonitorUpdateEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FaxMonitorUpdateEventArgs | Initializes a new instance of the FaxMonitorUpdateEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FaxStatus | Gets the Fax status associated with the change.

See Also

FaxMonitorUpdateEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxMonitorUpdateEventArgs Constructor

[image]

IceLib Technical Reference
FaxMonitorUpdateEventArgs Constructor
FaxMonitorUpdateEventArgs Class See Also Send Feedback
Initializes a new instance of the FaxMonitorUpdateEventArgs class with the specified values.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxMonitorUpdateEventArgs(
    FaxStatus faxStatus
)
Visual Basic
Public Sub New ( _
    faxStatus As FaxStatus _
)

Parameters

faxStatus
Type: ININ.IceLib.UnifiedMessaging..::..FaxStatus
The Fax status.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMonitorUpdateEventArgs Class
FaxMonitorUpdateEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMonitorUpdateEventArgs Methods

[image] [image]

IceLib Technical Reference
FaxMonitorUpdateEventArgs Methods
FaxMonitorUpdateEventArgs Class See Also Send Feedback

The FaxMonitorUpdateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxMonitorUpdateEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxMonitorUpdateEventArgs Properties

[image] [image]

IceLib Technical Reference
FaxMonitorUpdateEventArgs Properties
FaxMonitorUpdateEventArgs Class See Also Send Feedback

The FaxMonitorUpdateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | FaxStatus | Gets the Fax status associated with the change.

See Also

FaxMonitorUpdateEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


FaxStatus Property

[image]

IceLib Technical Reference
FaxMonitorUpdateEventArgs..::..FaxStatus Property
FaxMonitorUpdateEventArgs Class See Also Send Feedback
Gets the Fax status associated with the change.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxStatus FaxStatus { get; }
Visual Basic
Public ReadOnly Property FaxStatus As FaxStatus
    Get

Field Value

The Fax status.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxMonitorUpdateEventArgs Class
FaxMonitorUpdateEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


FaxOrientation Enumeration

[image]

IceLib Technical Reference
FaxOrientation Enumeration
See Also Send Feedback
Indicates orientation for a Fax page (horizontal and vertical).

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxOrientation
Visual Basic
Public Enumeration FaxOrientation

Members

Member name | Value | Description
Normal | 0 | No Orientation applied.
HorizontalFlip | 1 | Page is flipped horizontal (upside-down).
VerticalFlip | 2 | Page is flipped vertical (backwards).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Class

[image]

IceLib Technical Reference
FaxPageAttributes Class
Members See Also Send Feedback
Specifies display preferences used to render a Fax page image.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class FaxPageAttributes : ICloneable
Visual Basic
<SerializableAttribute> _
Public Class FaxPageAttributes _
    Implements ICloneable

Remarks

Use the FaxPageAttributes to indicate to an application how the image representing a Fax page should be presented.

Fax page images stored in an .i3f or .tif file are kept in an orientation and color scheme that is appropriate for ensuring successful delivery of a Fax through the IC server. In most cases this storage format is portrait orientation with black text on a white background for the color scheme. These attributes may not be the best choice for displaying a page of a fax to an end user. The separation of page image from page attributes allows the image to be stored in the correct format for sending to the Fax server, while also allowing it to be adjusted and presented appropriately on-screen.

When adding or updating a page image in a FaxFile, make sure you set the properties of the FaxPageAttributes to correctly indicate the viewing preferences of that page.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Members

[image] [image]

IceLib Technical Reference
FaxPageAttributes Members
FaxPageAttributes Class Constructors Methods Properties Events See Also Send Feedback

The FaxPageAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | FaxPageAttributes()()()() | Constructs a new FaxPageAttributes object.
Protected method | FaxPageAttributes(FaxPageAttributes) | Protected copy constructor.

Methods

 | Name | Description
Public method | Clone | Clones the FaxPageAttributes object by making a deep copy of all member values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream | Constructs a new FaxPageAttributes object by reading from an existing file stream.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Writes a FaxPageAttributes object to an open stream.
Public method | ToString | Override of ToString()()()() that prints full attribute information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ColorScheme | Determines the display colors used for a Fax page.
Public property | Orientation | Determines the orientation settings for a Fax page.
Public property | Resolution | Determines the resolution settings for a Fax page.
Public property | Rotation | Determines the rotation settings for a Fax page.

Events

 | Name | Description
Public event | AttributeChange | Indicates that a change in one of the attributes of a Fax Page has occurred.

See Also

FaxPageAttributes Class
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Constructor

[image] [image]

IceLib Technical Reference
FaxPageAttributes Constructor
FaxPageAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxPageAttributes()()()() | Constructs a new FaxPageAttributes object.
Protected method | FaxPageAttributes(FaxPageAttributes) | Protected copy constructor.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Constructor

[image]

IceLib Technical Reference
FaxPageAttributes Constructor
FaxPageAttributes Class See Also Send Feedback
Constructs a new FaxPageAttributes object.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxPageAttributes()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
FaxPageAttributes Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Constructor (FaxPageAttributes)

[image]

IceLib Technical Reference
FaxPageAttributes Constructor (FaxPageAttributes)
FaxPageAttributes Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxPageAttributes(
    FaxPageAttributes pageAttributes
)
Visual Basic
Protected Sub New ( _
    pageAttributes As FaxPageAttributes _
)

Parameters

pageAttributes
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageAttributes
Existing attributes object to use for value assignment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
FaxPageAttributes Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Methods

[image] [image]

IceLib Technical Reference
FaxPageAttributes Methods
FaxPageAttributes Class See Also Send Feedback

The FaxPageAttributes type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the FaxPageAttributes object by making a deep copy of all member values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream | Constructs a new FaxPageAttributes object by reading from an existing file stream.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Writes a FaxPageAttributes object to an open stream.
Public method | ToString | Override of ToString()()()() that prints full attribute information. (Overrides Object..::..ToString()()()().)

See Also

FaxPageAttributes Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxPageAttributes..::..Clone Method
FaxPageAttributes Class See Also Send Feedback
Clones the FaxPageAttributes object by making a deep copy of all member values.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new cloned object.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


FromStream Method

[image]

IceLib Technical Reference
FaxPageAttributes..::..FromStream Method
FaxPageAttributes Class See Also Send Feedback
Constructs a new FaxPageAttributes object by reading from an existing file stream.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static FaxPageAttributes FromStream(
    Stream dataStream
)
Visual Basic
Public Shared Function FromStream ( _
    dataStream As Stream _
) As FaxPageAttributes

Parameters

dataStream
Type: System.IO..::..Stream
An existing file stream containing attribute information.

Return Value

A new FaxPageAttributes object.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


Serialize Method

[image]

IceLib Technical Reference
FaxPageAttributes..::..Serialize Method
FaxPageAttributes Class See Also Send Feedback
Writes a FaxPageAttributes object to an open stream.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Serialize(
    Stream dataStream
)
Visual Basic
Public Sub Serialize ( _
    dataStream As Stream _
)

Parameters

dataStream
Type: System.IO..::..Stream
An existing file stream that will receive the serialized attributes.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxPageAttributes..::..ToString Method
FaxPageAttributes Class See Also Send Feedback
Override of ToString()()()() that prints full attribute information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Properties

[image] [image]

IceLib Technical Reference
FaxPageAttributes Properties
FaxPageAttributes Class See Also Send Feedback

The FaxPageAttributes type exposes the following members.

Properties

 | Name | Description
Public property | ColorScheme | Determines the display colors used for a Fax page.
Public property | Orientation | Determines the orientation settings for a Fax page.
Public property | Resolution | Determines the resolution settings for a Fax page.
Public property | Rotation | Determines the rotation settings for a Fax page.

See Also

FaxPageAttributes Class
ININ.IceLib.UnifiedMessaging Namespace


ColorScheme Property

[image]

IceLib Technical Reference
FaxPageAttributes..::..ColorScheme Property
FaxPageAttributes Class See Also Send Feedback
Determines the display colors used for a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxColorScheme ColorScheme { get; set; }
Visual Basic
Public Property ColorScheme As FaxColorScheme
    Get
    Set

Field Value

The color scheme.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


Orientation Property

[image]

IceLib Technical Reference
FaxPageAttributes..::..Orientation Property
FaxPageAttributes Class See Also Send Feedback
Determines the orientation settings for a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxOrientation Orientation { get; set; }
Visual Basic
Public Property Orientation As FaxOrientation
    Get
    Set

Field Value

The orientation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


Resolution Property

[image]

IceLib Technical Reference
FaxPageAttributes..::..Resolution Property
FaxPageAttributes Class See Also Send Feedback
Determines the resolution settings for a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PageResolution Resolution { get; set; }
Visual Basic
Public Property Resolution As PageResolution
    Get
    Set

Field Value

The resolution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


Rotation Property

[image]

IceLib Technical Reference
FaxPageAttributes..::..Rotation Property
FaxPageAttributes Class See Also Send Feedback
Determines the rotation settings for a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxRotation Rotation { get; set; }
Visual Basic
Public Property Rotation As FaxRotation
    Get
    Set

Field Value

The rotation.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageAttributes Events

[image] [image]

IceLib Technical Reference
FaxPageAttributes Events
FaxPageAttributes Class See Also Send Feedback

The FaxPageAttributes type exposes the following members.

Events

 | Name | Description
Public event | AttributeChange | Indicates that a change in one of the attributes of a Fax Page has occurred.

See Also

FaxPageAttributes Class
ININ.IceLib.UnifiedMessaging Namespace


AttributeChange Event

[image]

IceLib Technical Reference
FaxPageAttributes..::..AttributeChange Event
FaxPageAttributes Class See Also Send Feedback
Indicates that a change in one of the attributes of a Fax Page has occurred.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<AttributeEventArgs> AttributeChange
Visual Basic
Public Event AttributeChange As EventHandler(Of AttributeEventArgs)

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageAttributes Class
FaxPageAttributes Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSettings Class

[image]

IceLib Technical Reference
FaxPageSettings Class
Members See Also Send Feedback
Stores information on how a fax page is to be formatted when it is sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxPageSettings
Visual Basic
Public Class FaxPageSettings

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxPageSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSettings Members

[image] [image]

IceLib Technical Reference
FaxPageSettings Members
FaxPageSettings Class Constructors Methods Properties See Also Send Feedback

The FaxPageSettings type exposes the following members.

Constructors

 | Name | Description
Public method | FaxPageSettings | Initializes a new instance of the FaxPageSettings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FaxImageQuality | Gets or sets the fax image quality.
Public property | FaxImageSettings | Gets or sets the fax image settings.
Public property | FaxPageSize | Gets or sets the paper size of the fax page.

See Also

FaxPageSettings Class
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSettings Constructor

[image]

IceLib Technical Reference
FaxPageSettings Constructor
FaxPageSettings Class See Also Send Feedback
Initializes a new instance of the FaxPageSettings class.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxPageSettings(
    FaxImageSettings faxImageSettings,
    FaxImageQuality faxImageQuality,
    FaxPageSize faxPageSize
)
Visual Basic
Public Sub New ( _
    faxImageSettings As FaxImageSettings, _
    faxImageQuality As FaxImageQuality, _
    faxPageSize As FaxPageSize _
)

Parameters

faxImageSettings
Type: ININ.IceLib.UnifiedMessaging..::..FaxImageSettings
The fax image settings.
faxImageQuality
Type: ININ.IceLib.UnifiedMessaging..::..FaxImageQuality
The fax image quality.
faxPageSize
Type: ININ.IceLib.UnifiedMessaging..::..FaxPageSize
Size of the fax page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageSettings Class
FaxPageSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSettings Methods

[image] [image]

IceLib Technical Reference
FaxPageSettings Methods
FaxPageSettings Class See Also Send Feedback

The FaxPageSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

FaxPageSettings Class
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxPageSettings..::..ToString Method
FaxPageSettings Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageSettings Class
FaxPageSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSettings Properties

[image] [image]

IceLib Technical Reference
FaxPageSettings Properties
FaxPageSettings Class See Also Send Feedback

The FaxPageSettings type exposes the following members.

Properties

 | Name | Description
Public property | FaxImageQuality | Gets or sets the fax image quality.
Public property | FaxImageSettings | Gets or sets the fax image settings.
Public property | FaxPageSize | Gets or sets the paper size of the fax page.

See Also

FaxPageSettings Class
ININ.IceLib.UnifiedMessaging Namespace


FaxImageQuality Property

[image]

IceLib Technical Reference
FaxPageSettings..::..FaxImageQuality Property
FaxPageSettings Class See Also Send Feedback
Gets or sets the fax image quality.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxImageQuality FaxImageQuality { get; set; }
Visual Basic
Public Property FaxImageQuality As FaxImageQuality
    Get
    Set

Field Value

The fax image quality.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageSettings Class
FaxPageSettings Members
ININ.IceLib.UnifiedMessaging Namespace
FaxPageSettings..::..FaxImageQuality


FaxImageSettings Property

[image]

IceLib Technical Reference
FaxPageSettings..::..FaxImageSettings Property
FaxPageSettings Class See Also Send Feedback
Gets or sets the fax image settings.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxImageSettings FaxImageSettings { get; set; }
Visual Basic
Public Property FaxImageSettings As FaxImageSettings
    Get
    Set

Field Value

The fax image settings.

Remarks

The FaxImageSettings flags indicate how an image should be transformed into a fax page.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value specified invalid flags for the FaxImageSettings enum.
System..::..ArgumentException | An invalid combination of flags was specified. See FaxImageSettings.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageSettings Class
FaxPageSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSize Property

[image]

IceLib Technical Reference
FaxPageSettings..::..FaxPageSize Property
FaxPageSettings Class See Also Send Feedback
Gets or sets the paper size of the fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxPageSize FaxPageSize { get; set; }
Visual Basic
Public Property FaxPageSize As FaxPageSize
    Get
    Set

Field Value

The size of the fax page.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxPageSettings Class
FaxPageSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxPageSize Enumeration

[image]

IceLib Technical Reference
FaxPageSize Enumeration
See Also Send Feedback
Enumerates various paper sizes that can be used for faxing.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxPageSize
Visual Basic
Public Enumeration FaxPageSize

Members

Member name | Value | Description
Letter | 0 | Letter-sized paper (8.5x11 inches).
Legal | 1 | Legal-sized paper (8.5x14 inches).
A4 | 2 | A4-sized paper (8.26x11.69 inches).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxRecipient Class

[image]

IceLib Technical Reference
FaxRecipient Class
Members See Also Send Feedback
Represents a recipient of a FaxMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxRecipient
Visual Basic
Public Class FaxRecipient

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxRecipient

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


FaxRecipient Members

[image] [image]

IceLib Technical Reference
FaxRecipient Members
FaxRecipient Class Methods Properties See Also Send Feedback

The FaxRecipient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two FaxRecipient objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | Gets the address of this recipient.
Public property | Name | Gets the display name of this recipient.

See Also

FaxRecipient Class
ININ.IceLib.UnifiedMessaging Namespace


FaxRecipient Methods

[image] [image]

IceLib Technical Reference
FaxRecipient Methods
FaxRecipient Class See Also Send Feedback

The FaxRecipient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two FaxRecipient objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxRecipient Class
ININ.IceLib.UnifiedMessaging Namespace


Equals Method

[image]

IceLib Technical Reference
FaxRecipient..::..Equals Method
FaxRecipient Class See Also Send Feedback
Compares two FaxRecipient objects.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxRecipient Class
FaxRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


GetHashCode Method

[image]

IceLib Technical Reference
FaxRecipient..::..GetHashCode Method
FaxRecipient Class See Also Send Feedback
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxRecipient Class
FaxRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


FaxRecipient Properties

[image] [image]

IceLib Technical Reference
FaxRecipient Properties
FaxRecipient Class See Also Send Feedback

The FaxRecipient type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the address of this recipient.
Public property | Name | Gets the display name of this recipient.

See Also

FaxRecipient Class
ININ.IceLib.UnifiedMessaging Namespace


Address Property

[image]

IceLib Technical Reference
FaxRecipient..::..Address Property
FaxRecipient Class See Also Send Feedback
Gets the address of this recipient.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; }
Visual Basic
Public ReadOnly Property Address As String
    Get

Field Value

The address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxRecipient Class
FaxRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


Name Property

[image]

IceLib Technical Reference
FaxRecipient..::..Name Property
FaxRecipient Class See Also Send Feedback
Gets the display name of this recipient.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxRecipient Class
FaxRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


FaxResult Class

[image]

IceLib Technical Reference
FaxResult Class
Members See Also Send Feedback
Represents the result of a send Fax operation.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxResult
Visual Basic
Public Class FaxResult

Remarks

The FaxResult links the full local pathname of a Fax file to an ID resulting from a SendFax(String) operation. When an asynchronous send operation such as SendFaxAsync(String, EventHandler<(Of <<'(AsyncSendFaxCompletedEventArgs>)>>), Object) is used, the FaxFile property allows you to perform validation against the specified filename if desired.

Note
The FaxId returned is not guaranteed to be unique.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxResult

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxResult Members
ININ.IceLib.UnifiedMessaging Namespace


FaxResult Members

[image] [image]

IceLib Technical Reference
FaxResult Members
FaxResult Class Methods Properties See Also Send Feedback

The FaxResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FaxFile | Gets the full pathname of the file that was submitted for faxing.
Public property | FaxId | Gets the ID that was assigned to the faxed file during the send operation.

See Also

FaxResult Class
ININ.IceLib.UnifiedMessaging Namespace


FaxResult Methods

[image] [image]

IceLib Technical Reference
FaxResult Methods
FaxResult Class See Also Send Feedback

The FaxResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

FaxResult Class
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxResult..::..ToString Method
FaxResult Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxResult Class
FaxResult Members
ININ.IceLib.UnifiedMessaging Namespace


FaxResult Properties

[image] [image]

IceLib Technical Reference
FaxResult Properties
FaxResult Class See Also Send Feedback

The FaxResult type exposes the following members.

Properties

 | Name | Description
Public property | FaxFile | Gets the full pathname of the file that was submitted for faxing.
Public property | FaxId | Gets the ID that was assigned to the faxed file during the send operation.

See Also

FaxResult Class
ININ.IceLib.UnifiedMessaging Namespace


FaxFile Property

[image]

IceLib Technical Reference
FaxResult..::..FaxFile Property
FaxResult Class See Also Send Feedback
Gets the full pathname of the file that was submitted for faxing.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string FaxFile { get; }
Visual Basic
Public ReadOnly Property FaxFile As String
    Get

Field Value

The Fax file.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxResult Class
FaxResult Members
ININ.IceLib.UnifiedMessaging Namespace


FaxId Property

[image]

IceLib Technical Reference
FaxResult..::..FaxId Property
FaxResult Class See Also Send Feedback
Gets the ID that was assigned to the faxed file during the send operation.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long FaxId { get; }
Visual Basic
Public ReadOnly Property FaxId As Long
    Get

Field Value

The Fax ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxResult Class
FaxResult Members
ININ.IceLib.UnifiedMessaging Namespace


FaxRotation Enumeration

[image]

IceLib Technical Reference
FaxRotation Enumeration
See Also Send Feedback
Indicates direction of rotation for a Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxRotation
Visual Basic
Public Enumeration FaxRotation

Members

Member name | Value | Description
Normal | 0 | No rotation applied.
Right90 | 1 | Page is rotated 90° to the right (clockwise).
Rotate180 | 2 | Page is rotated 180° (upside-down).
Left90 | 3 | Page is rotated 90° to the left (counter-clockwise).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxServerSettings Class

[image]

IceLib Technical Reference
FaxServerSettings Class
Members See Also Send Feedback
Represents the Fax configuration settings on an IC server.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxServerSettings
Visual Basic
Public Class FaxServerSettings

Remarks

Use the FaxServerSettings to retrieve the set of Fax-related behavior settings defined on the IC server.

The properties available in this class represent the defaults established by the IC server administrator for items such as the default cover page template and values used to populate that page, as well as the delivery behavior (RetryAttempts, RetryDelay).

Before using any of the properties exposed through this class you should check to see if the settings are valid. Each of the integer-based properties like RetryAttempts have a matching property with a "Valid" extension that indicates if the property contains a valid value (RetryAttemptsValid). String properties can be compared against nullNothingnullptra null reference (Nothing in Visual Basic) to determine their validity.

Note
The properties exposed through the FaxServerSettings class are read-only. Changes to these values may only be made by an IC administrator.

Examples

The following example demonstrates retrieving the list of Fax groups visible to a user.
CopyC#
FaxServerSettings faxServerSettings;

UnifiedMessagingManager umManager = UnifiedMessagingManager.GetInstance(IceLibSession);
faxServerSettings = umManager.GetFaxServerSettings();

ReadOnlyCollection<string> FaxGroups = faxServerSettings.FaxGroups;

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxServerSettings

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxServerSettings Members

[image] [image]

IceLib Technical Reference
FaxServerSettings Members
FaxServerSettings Class Methods Properties See Also Send Feedback

The FaxServerSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnswerTimeout | The number of seconds the server will wait for an answer from a remote Fax machine before marking a send operation as failed.
Public property | AnswerTimeoutValid | Indicates if a value is actually specified for the AnswerTimeout property.
Public property | CoverPages | The names of all cover page templates defined on the server.
Public property | DefaultCoverPage | The cover page template used to generate a cover page for all outgoing faxes.
Public property | DefaultFaxGroup | The Fax group used when sending outgoing Faxes.
Public property | DefaultFromCompany | The company of the originating party sending a Fax.
Public property | DefaultFromFax | The Fax number of the originating party sending a Fax.
Public property | DefaultFromName | The name used to identify the originating party of a Fax.
Public property | DefaultFromVoice | The voice number of the originating party sending a Fax.
Public property | FaxGroups | The names of all Fax groups defined on the server.
Public property | PageHeader | The text displayed at the top of all Faxed pages.
Public property | RetryAttempts | The maximum number of times a send operation should be tried if the initial attempt fails.
Public property | RetryAttemptsValid | Indicates if a value is actually specified for the RetryAttempts property.
Public property | RetryDelay | The number of seconds the server will wait before trying a failed send operation again.
Public property | RetryDelayValid | Indicates if a value is actually specified for the RetryDelay property.
Public property | StationId | The station number displayed on the receiving Fax station’s display window and Fax log.
Public property | TransmissionSpeed | The maximum transmission rate to use when executing Fax send operations.
Public property | TransmissionSpeedValid | Indicates if a value is actually specified for the TransmissionSpeed property.

See Also

FaxServerSettings Class
ININ.IceLib.UnifiedMessaging Namespace


FaxServerSettings Methods

[image] [image]

IceLib Technical Reference
FaxServerSettings Methods
FaxServerSettings Class See Also Send Feedback

The FaxServerSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaxServerSettings Class
ININ.IceLib.UnifiedMessaging Namespace


FaxServerSettings Properties

[image] [image]

IceLib Technical Reference
FaxServerSettings Properties
FaxServerSettings Class See Also Send Feedback

The FaxServerSettings type exposes the following members.

Properties

 | Name | Description
Public property | AnswerTimeout | The number of seconds the server will wait for an answer from a remote Fax machine before marking a send operation as failed.
Public property | AnswerTimeoutValid | Indicates if a value is actually specified for the AnswerTimeout property.
Public property | CoverPages | The names of all cover page templates defined on the server.
Public property | DefaultCoverPage | The cover page template used to generate a cover page for all outgoing faxes.
Public property | DefaultFaxGroup | The Fax group used when sending outgoing Faxes.
Public property | DefaultFromCompany | The company of the originating party sending a Fax.
Public property | DefaultFromFax | The Fax number of the originating party sending a Fax.
Public property | DefaultFromName | The name used to identify the originating party of a Fax.
Public property | DefaultFromVoice | The voice number of the originating party sending a Fax.
Public property | FaxGroups | The names of all Fax groups defined on the server.
Public property | PageHeader | The text displayed at the top of all Faxed pages.
Public property | RetryAttempts | The maximum number of times a send operation should be tried if the initial attempt fails.
Public property | RetryAttemptsValid | Indicates if a value is actually specified for the RetryAttempts property.
Public property | RetryDelay | The number of seconds the server will wait before trying a failed send operation again.
Public property | RetryDelayValid | Indicates if a value is actually specified for the RetryDelay property.
Public property | StationId | The station number displayed on the receiving Fax station’s display window and Fax log.
Public property | TransmissionSpeed | The maximum transmission rate to use when executing Fax send operations.
Public property | TransmissionSpeedValid | Indicates if a value is actually specified for the TransmissionSpeed property.

See Also

FaxServerSettings Class
ININ.IceLib.UnifiedMessaging Namespace


AnswerTimeout Property

[image]

IceLib Technical Reference
FaxServerSettings..::..AnswerTimeout Property
FaxServerSettings Class See Also Send Feedback
The number of seconds the server will wait for an answer from a remote Fax machine before marking a send operation as failed.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int AnswerTimeout { get; }
Visual Basic
Public ReadOnly Property AnswerTimeout As Integer
    Get

Field Value

The answer timeout.

Remarks

The AnswerTimeoutValid property should always be checked before attempting to access this property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


AnswerTimeoutValid Property

[image]

IceLib Technical Reference
FaxServerSettings..::..AnswerTimeoutValid Property
FaxServerSettings Class See Also Send Feedback
Indicates if a value is actually specified for the AnswerTimeout property.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool AnswerTimeoutValid { get; }
Visual Basic
Public ReadOnly Property AnswerTimeoutValid As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the answer timeout is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This property should always be checked before attempting to access the AnswerTimeout property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


CoverPages Property

[image]

IceLib Technical Reference
FaxServerSettings..::..CoverPages Property
FaxServerSettings Class See Also Send Feedback
The names of all cover page templates defined on the server.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> CoverPages { get; }
Visual Basic
Public ReadOnly Property CoverPages As ReadOnlyCollection(Of String)
    Get

Field Value

The cover pages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


DefaultCoverPage Property

[image]

IceLib Technical Reference
FaxServerSettings..::..DefaultCoverPage Property
FaxServerSettings Class See Also Send Feedback
The cover page template used to generate a cover page for all outgoing faxes.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultCoverPage { get; }
Visual Basic
Public ReadOnly Property DefaultCoverPage As String
    Get

Field Value

The default cover page.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


DefaultFaxGroup Property

[image]

IceLib Technical Reference
FaxServerSettings..::..DefaultFaxGroup Property
FaxServerSettings Class See Also Send Feedback
The Fax group used when sending outgoing Faxes.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultFaxGroup { get; }
Visual Basic
Public ReadOnly Property DefaultFaxGroup As String
    Get

Field Value

The default Fax group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


DefaultFromCompany Property

[image]

IceLib Technical Reference
FaxServerSettings..::..DefaultFromCompany Property
FaxServerSettings Class See Also Send Feedback
The company of the originating party sending a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultFromCompany { get; }
Visual Basic
Public ReadOnly Property DefaultFromCompany As String
    Get

Field Value

The default from company.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


DefaultFromFax Property

[image]

IceLib Technical Reference
FaxServerSettings..::..DefaultFromFax Property
FaxServerSettings Class See Also Send Feedback
The Fax number of the originating party sending a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultFromFax { get; }
Visual Basic
Public ReadOnly Property DefaultFromFax As String
    Get

Field Value

The default from Fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


DefaultFromName Property

[image]

IceLib Technical Reference
FaxServerSettings..::..DefaultFromName Property
FaxServerSettings Class See Also Send Feedback
The name used to identify the originating party of a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultFromName { get; }
Visual Basic
Public ReadOnly Property DefaultFromName As String
    Get

Field Value

The default from name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


DefaultFromVoice Property

[image]

IceLib Technical Reference
FaxServerSettings..::..DefaultFromVoice Property
FaxServerSettings Class See Also Send Feedback
The voice number of the originating party sending a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DefaultFromVoice { get; }
Visual Basic
Public ReadOnly Property DefaultFromVoice As String
    Get

Field Value

The default from voice.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxGroups Property

[image]

IceLib Technical Reference
FaxServerSettings..::..FaxGroups Property
FaxServerSettings Class See Also Send Feedback
The names of all Fax groups defined on the server.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<string> FaxGroups { get; }
Visual Basic
Public ReadOnly Property FaxGroups As ReadOnlyCollection(Of String)
    Get

Field Value

The Fax groups.

Remarks

A Fax group is a named group of Fax resources dedicated for a particular purpose.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


PageHeader Property

[image]

IceLib Technical Reference
FaxServerSettings..::..PageHeader Property
FaxServerSettings Class See Also Send Feedback
The text displayed at the top of all Faxed pages.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PageHeader { get; }
Visual Basic
Public ReadOnly Property PageHeader As String
    Get

Field Value

The page header.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


RetryAttempts Property

[image]

IceLib Technical Reference
FaxServerSettings..::..RetryAttempts Property
FaxServerSettings Class See Also Send Feedback
The maximum number of times a send operation should be tried if the initial attempt fails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RetryAttempts { get; }
Visual Basic
Public ReadOnly Property RetryAttempts As Integer
    Get

Field Value

The retry attempts.

Remarks

The RetryAttemptsValid property should always be checked before attempting to access this property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


RetryAttemptsValid Property

[image]

IceLib Technical Reference
FaxServerSettings..::..RetryAttemptsValid Property
FaxServerSettings Class See Also Send Feedback
Indicates if a value is actually specified for the RetryAttempts property.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool RetryAttemptsValid { get; }
Visual Basic
Public ReadOnly Property RetryAttemptsValid As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the retry attempts is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This property should always be checked before attempting to access the RetryAttempts property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


RetryDelay Property

[image]

IceLib Technical Reference
FaxServerSettings..::..RetryDelay Property
FaxServerSettings Class See Also Send Feedback
The number of seconds the server will wait before trying a failed send operation again.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RetryDelay { get; }
Visual Basic
Public ReadOnly Property RetryDelay As Integer
    Get

Field Value

The retry delay.

Remarks

The RetryDelayValid property should always be checked before attempting to access this property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


RetryDelayValid Property

[image]

IceLib Technical Reference
FaxServerSettings..::..RetryDelayValid Property
FaxServerSettings Class See Also Send Feedback
Indicates if a value is actually specified for the RetryDelay property.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool RetryDelayValid { get; }
Visual Basic
Public ReadOnly Property RetryDelayValid As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the retry delay is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This property should always be checked before attempting to access the RetryDelay property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


StationId Property

[image]

IceLib Technical Reference
FaxServerSettings..::..StationId Property
FaxServerSettings Class See Also Send Feedback
The station number displayed on the receiving Fax station’s display window and Fax log.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationId { get; }
Visual Basic
Public ReadOnly Property StationId As String
    Get

Field Value

The station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


TransmissionSpeed Property

[image]

IceLib Technical Reference
FaxServerSettings..::..TransmissionSpeed Property
FaxServerSettings Class See Also Send Feedback
The maximum transmission rate to use when executing Fax send operations.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int TransmissionSpeed { get; }
Visual Basic
Public ReadOnly Property TransmissionSpeed As Integer
    Get

Field Value

The transmission speed.

Remarks

The TransmissionSpeedValid property should always be checked before attempting to access this property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


TransmissionSpeedValid Property

[image]

IceLib Technical Reference
FaxServerSettings..::..TransmissionSpeedValid Property
FaxServerSettings Class See Also Send Feedback
Indicates if a value is actually specified for the TransmissionSpeed property.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool TransmissionSpeedValid { get; }
Visual Basic
Public ReadOnly Property TransmissionSpeedValid As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if the transmission speed is valid; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

This property should always be checked before attempting to access the TransmissionSpeed property.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxServerSettings Class
FaxServerSettings Members
ININ.IceLib.UnifiedMessaging Namespace


FaxStatus Class

[image]

IceLib Technical Reference
FaxStatus Class
Members See Also Send Feedback
Represent the progress of a Fax that was submitted for delivery.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxStatus
Visual Basic
Public Class FaxStatus

Remarks

The FaxStatus class represents the progress information received from an IC server about a Fax submitted by a user.

The FaxStatus is wrapped into a FaxMonitorUpdate event and broadcast to any registered listeners when monitoring has been turned on through a call to EnableFaxMonitoring(Boolean).

See ININ.IceLib.UnifiedMessaging for an example of responding to a FaxMonitorUpdate event.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxStatus

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


FaxStatus Members

[image] [image]

IceLib Technical Reference
FaxStatus Members
FaxStatus Class Methods Properties See Also Send Feedback

The FaxStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Code | Gets the FaxStatusCode that described the current status of the Fax.
Public property | Details | Gets details about the current status of the Fax.
Public property | DetailsExtended | Gets additional details about the current status of the Fax.
Public property | EnvelopeId | Gets the identifier of the Fax being processed.
Public property | HoldingUntilTime | Gets the time until the fax will be sent, if holding.
Public property | PagesTransmitted | Gets the number of pages transmitted so far.
Public property | RecipientFax | Gets fax number used to contact the recipient.
Public property | RecipientName | Gets the intended recipient of the Fax.
Public property | RetryCount | Gets the number of attempts made to send the Fax.
Public property | TimeSent | Gets the Date and Time a Fax was sent.

See Also

FaxStatus Class
ININ.IceLib.UnifiedMessaging Namespace


FaxStatus Methods

[image] [image]

IceLib Technical Reference
FaxStatus Methods
FaxStatus Class See Also Send Feedback

The FaxStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

FaxStatus Class
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxStatus..::..ToString Method
FaxStatus Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


FaxStatus Properties

[image] [image]

IceLib Technical Reference
FaxStatus Properties
FaxStatus Class See Also Send Feedback

The FaxStatus type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets the FaxStatusCode that described the current status of the Fax.
Public property | Details | Gets details about the current status of the Fax.
Public property | DetailsExtended | Gets additional details about the current status of the Fax.
Public property | EnvelopeId | Gets the identifier of the Fax being processed.
Public property | HoldingUntilTime | Gets the time until the fax will be sent, if holding.
Public property | PagesTransmitted | Gets the number of pages transmitted so far.
Public property | RecipientFax | Gets fax number used to contact the recipient.
Public property | RecipientName | Gets the intended recipient of the Fax.
Public property | RetryCount | Gets the number of attempts made to send the Fax.
Public property | TimeSent | Gets the Date and Time a Fax was sent.

See Also

FaxStatus Class
ININ.IceLib.UnifiedMessaging Namespace


Code Property

[image]

IceLib Technical Reference
FaxStatus..::..Code Property
FaxStatus Class See Also Send Feedback
Gets the FaxStatusCode that described the current status of the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxStatusCode Code { get; }
Visual Basic
Public ReadOnly Property Code As FaxStatusCode
    Get

Field Value

The status code indicates whether this Fax is queued for sending, currently transmitting, etc.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


Details Property

[image]

IceLib Technical Reference
FaxStatus..::..Details Property
FaxStatus Class See Also Send Feedback
Gets details about the current status of the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Details { get; }
Visual Basic
Public ReadOnly Property Details As String
    Get

Field Value

The details.

Remarks

The meaning of this field is dependent on the value of the Code property

Holding - Details of last failure if RetryCount > 0
QueuedForSend - Details of last failure if RetryCount > 0
Connecting - Connecting Information (Phone number, IP address etc.)
Transmitting - Connection Info (rate if available, remote station ID)
Successful - Call Subscriber ID (CSID)
Failed - Failure Information

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


DetailsExtended Property

[image]

IceLib Technical Reference
FaxStatus..::..DetailsExtended Property
FaxStatus Class See Also Send Feedback
Gets additional details about the current status of the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DetailsExtended { get; }
Visual Basic
Public ReadOnly Property DetailsExtended As String
    Get

Field Value

The extended details.

Remarks

The meaning of this field is dependent on the value of the Code property.

Holding - Device details (if any) of last failure if RetryCount > 0
QueuedForSend - Device details (if any) of last failure if RetryCount > 0
Failed - Device details (if any) of failure

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


EnvelopeId Property

[image]

IceLib Technical Reference
FaxStatus..::..EnvelopeId Property
FaxStatus Class See Also Send Feedback
Gets the identifier of the Fax being processed.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public long EnvelopeId { get; }
Visual Basic
Public ReadOnly Property EnvelopeId As Long
    Get

Field Value

The envelope ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


HoldingUntilTime Property

[image]

IceLib Technical Reference
FaxStatus..::..HoldingUntilTime Property
FaxStatus Class See Also Send Feedback
Gets the time until the fax will be sent, if holding.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime HoldingUntilTime { get; }
Visual Basic
Public ReadOnly Property HoldingUntilTime As DateTime
    Get

Field Value

The holding until time.

Remarks

For the Code property value of Holding, the time envelope will be queued for send.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


PagesTransmitted Property

[image]

IceLib Technical Reference
FaxStatus..::..PagesTransmitted Property
FaxStatus Class See Also Send Feedback
Gets the number of pages transmitted so far.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int PagesTransmitted { get; }
Visual Basic
Public ReadOnly Property PagesTransmitted As Integer
    Get

Field Value

The number of pages transmitted.

Remarks

For the Code property values of Transmitting, Successful, and Failed, the number of pages transmitted.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


RecipientFax Property

[image]

IceLib Technical Reference
FaxStatus..::..RecipientFax Property
FaxStatus Class See Also Send Feedback
Gets fax number used to contact the recipient.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RecipientFax { get; }
Visual Basic
Public ReadOnly Property RecipientFax As String
    Get

Field Value

The recipient Fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


RecipientName Property

[image]

IceLib Technical Reference
FaxStatus..::..RecipientName Property
FaxStatus Class See Also Send Feedback
Gets the intended recipient of the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string RecipientName { get; }
Visual Basic
Public ReadOnly Property RecipientName As String
    Get

Field Value

The name of the recipient.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


RetryCount Property

[image]

IceLib Technical Reference
FaxStatus..::..RetryCount Property
FaxStatus Class See Also Send Feedback
Gets the number of attempts made to send the Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RetryCount { get; }
Visual Basic
Public ReadOnly Property RetryCount As Integer
    Get

Field Value

The retry count.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


TimeSent Property

[image]

IceLib Technical Reference
FaxStatus..::..TimeSent Property
FaxStatus Class See Also Send Feedback
Gets the Date and Time a Fax was sent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime TimeSent { get; }
Visual Basic
Public ReadOnly Property TimeSent As DateTime
    Get

Field Value

The time sent.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxStatus Class
FaxStatus Members
ININ.IceLib.UnifiedMessaging Namespace


FaxStatusCode Enumeration

[image]

IceLib Technical Reference
FaxStatusCode Enumeration
See Also Send Feedback
Indicates the current status of a fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum FaxStatusCode
Visual Basic
Public Enumeration FaxStatusCode

Members

Member name | Value | Description
None | 0 | The fax is in an unknown or invalid status.
Holding | 1 | The fax is currently waiting to be placed in the send queue.
QueuedForSend | 2 | The fax has been queued for sending.
Connecting | 3 | The fax device is currently negotiating a connection with a remote fax.
Transmitting | 4 | The fax device is currently transmitting the fax to the remote fax.
Successful | 5 | The fax was delivered successfully.
Failed | 6 | The fax was not delivered.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


FaxTransmitOptions Class

[image]

IceLib Technical Reference
FaxTransmitOptions Class
Members See Also Send Feedback
Represents Fax device configuration information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class FaxTransmitOptions : ICloneable
Visual Basic
Public Class FaxTransmitOptions _
    Implements ICloneable

Remarks

Use the FaxTransmitOptions class to tell the Fax server how the Fax device should behave when sending a Fax. This class is used when configuring a FaxEnvelope.

The properties contained in this class may be used to override several of the default behaviors that have been configured for Fax devices by your IC administrator.

Accepting the default values for an instance of this class will instruct the Fax server to use the settings defined by the administrator. If additional control over the behavior is desired, then the default values may be read from the FaxServerSettings and modified as necessary.

Note
When setting DeviceGroup, the value * (the default) is a wildcard used to indicate any available device group.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..FaxTransmitOptions

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxEnvelope
ININ.IceLib.UnifiedMessaging..::..FaxServerSettings


FaxTransmitOptions Members

[image] [image]

IceLib Technical Reference
FaxTransmitOptions Members
FaxTransmitOptions Class Constructors Methods Properties See Also Send Feedback

The FaxTransmitOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FaxTransmitOptions()()()() | Constructs an object with all transmission options defaulted.
Protected method | FaxTransmitOptions(FaxTransmitOptions) | Protected copy constructor.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this transmit options object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full fax options information. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DeviceGroup | Fax port group name used to send Fax.
Public property | MaxTransmissionRate | Maximum BPS rate to use in Fax transmission.
Public property | PageHeader | Included in the header line of each Fax page.
Public property | ResendCoverOnRetry | Boolean that indicates whether the cover page be sent again when re-attempting a failed Fax send operation.
Public property | Retries | Retries before returning error report.
Public property | RetryDelay | Delay between retries (seconds).
Public property | StationId | Identification string to display to a remote station receiving a Fax.

See Also

FaxTransmitOptions Class
ININ.IceLib.UnifiedMessaging Namespace


FaxTransmitOptions Constructor

[image] [image]

IceLib Technical Reference
FaxTransmitOptions Constructor
FaxTransmitOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FaxTransmitOptions()()()() | Constructs an object with all transmission options defaulted.
Protected method | FaxTransmitOptions(FaxTransmitOptions) | Protected copy constructor.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


FaxTransmitOptions Constructor

[image]

IceLib Technical Reference
FaxTransmitOptions Constructor
FaxTransmitOptions Class See Also Send Feedback
Constructs an object with all transmission options defaulted.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxTransmitOptions()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
FaxTransmitOptions Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxTransmitOptions Constructor (FaxTransmitOptions)

[image]

IceLib Technical Reference
FaxTransmitOptions Constructor (FaxTransmitOptions)
FaxTransmitOptions Class See Also Send Feedback
Protected copy constructor.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected FaxTransmitOptions(
    FaxTransmitOptions options
)
Visual Basic
Protected Sub New ( _
    options As FaxTransmitOptions _
)

Parameters

options
Type: ININ.IceLib.UnifiedMessaging..::..FaxTransmitOptions
Existing options object to use for value assignment.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
FaxTransmitOptions Overload
ININ.IceLib.UnifiedMessaging Namespace


FaxTransmitOptions Methods

[image] [image]

IceLib Technical Reference
FaxTransmitOptions Methods
FaxTransmitOptions Class See Also Send Feedback

The FaxTransmitOptions type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a duplicate of this transmit options object by copying all members.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Override of ToString()()()() that prints full fax options information. (Overrides Object..::..ToString()()()().)

See Also

FaxTransmitOptions Class
ININ.IceLib.UnifiedMessaging Namespace


Clone Method

[image]

IceLib Technical Reference
FaxTransmitOptions..::..Clone Method
FaxTransmitOptions Class See Also Send Feedback
Creates a duplicate of this transmit options object by copying all members.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

The new transmit options.

Implements

ICloneable..::..Clone()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


ToString Method

[image]

IceLib Technical Reference
FaxTransmitOptions..::..ToString Method
FaxTransmitOptions Class See Also Send Feedback
Override of ToString()()()() that prints full fax options information.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A formatted string describing the options.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


FaxTransmitOptions Properties

[image] [image]

IceLib Technical Reference
FaxTransmitOptions Properties
FaxTransmitOptions Class See Also Send Feedback

The FaxTransmitOptions type exposes the following members.

Properties

 | Name | Description
Public property | DeviceGroup | Fax port group name used to send Fax.
Public property | MaxTransmissionRate | Maximum BPS rate to use in Fax transmission.
Public property | PageHeader | Included in the header line of each Fax page.
Public property | ResendCoverOnRetry | Boolean that indicates whether the cover page be sent again when re-attempting a failed Fax send operation.
Public property | Retries | Retries before returning error report.
Public property | RetryDelay | Delay between retries (seconds).
Public property | StationId | Identification string to display to a remote station receiving a Fax.

See Also

FaxTransmitOptions Class
ININ.IceLib.UnifiedMessaging Namespace


DeviceGroup Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..DeviceGroup Property
FaxTransmitOptions Class See Also Send Feedback
Fax port group name used to send Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string DeviceGroup { get; set; }
Visual Basic
Public Property DeviceGroup As String
    Get
    Set

Field Value

The device group.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


MaxTransmissionRate Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..MaxTransmissionRate Property
FaxTransmitOptions Class See Also Send Feedback
Maximum BPS rate to use in Fax transmission.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int MaxTransmissionRate { get; set; }
Visual Basic
Public Property MaxTransmissionRate As Integer
    Get
    Set

Field Value

The maximum transmission rate, expressed in bits per second.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


PageHeader Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..PageHeader Property
FaxTransmitOptions Class See Also Send Feedback
Included in the header line of each Fax page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string PageHeader { get; set; }
Visual Basic
Public Property PageHeader As String
    Get
    Set

Field Value

The page header.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


ResendCoverOnRetry Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..ResendCoverOnRetry Property
FaxTransmitOptions Class See Also Send Feedback
Boolean that indicates whether the cover page be sent again when re-attempting a failed Fax send operation.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool ResendCoverOnRetry { get; set; }
Visual Basic
Public Property ResendCoverOnRetry As Boolean
    Get
    Set

Field Value

trueTruetruetrue (True in Visual Basic) if should resend cover on retry; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


Retries Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..Retries Property
FaxTransmitOptions Class See Also Send Feedback
Retries before returning error report.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Retries { get; set; }
Visual Basic
Public Property Retries As Integer
    Get
    Set

Field Value

The number of retries.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


RetryDelay Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..RetryDelay Property
FaxTransmitOptions Class See Also Send Feedback
Delay between retries (seconds).

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int RetryDelay { get; set; }
Visual Basic
Public Property RetryDelay As Integer
    Get
    Set

Field Value

The retry delay interval, in seconds.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


StationId Property

[image]

IceLib Technical Reference
FaxTransmitOptions..::..StationId Property
FaxTransmitOptions Class See Also Send Feedback
Identification string to display to a remote station receiving a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string StationId { get; set; }
Visual Basic
Public Property StationId As String
    Get
    Set

Field Value

The station ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

FaxTransmitOptions Class
FaxTransmitOptions Members
ININ.IceLib.UnifiedMessaging Namespace


PageResolution Structure

[image]

IceLib Technical Reference
PageResolution Structure
Members See Also Send Feedback
Represent the vertical and horizontal resolution of a Fax Page.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public struct PageResolution
Visual Basic
<SerializableAttribute> _
Public Structure PageResolution

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PageResolution Members
ININ.IceLib.UnifiedMessaging Namespace


PageResolution Members

[image] [image]

IceLib Technical Reference
PageResolution Members
PageResolution Structure Constructors Methods Properties See Also Send Feedback

The PageResolution type exposes the following members.

Constructors

 | Name | Description
Public method | PageResolution | Creates a new PageResolution structure with the provided resolution.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Horizontal | The horizontal resolution (pixels-per-inch).
Public property | Vertical | The vertical resolution (pixels-per-inch).

See Also

PageResolution Structure
ININ.IceLib.UnifiedMessaging Namespace


PageResolution Constructor

[image]

IceLib Technical Reference
PageResolution Constructor
PageResolution Structure See Also Send Feedback
Creates a new PageResolution structure with the provided resolution.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public PageResolution(
    int horizontal,
    int vertical
)
Visual Basic
Public Sub New ( _
    horizontal As Integer, _
    vertical As Integer _
)

Parameters

horizontal
Type: System..::..Int32
The horizontal resolution (pixels-per-inch).
vertical
Type: System..::..Int32
The vertical resolution (pixels-per-inch).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | A parameter value was invalid.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PageResolution Structure
PageResolution Members
ININ.IceLib.UnifiedMessaging Namespace


PageResolution Methods

[image] [image]

IceLib Technical Reference
PageResolution Methods
PageResolution Structure See Also Send Feedback

The PageResolution type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

PageResolution Structure
ININ.IceLib.UnifiedMessaging Namespace


PageResolution Properties

[image] [image]

IceLib Technical Reference
PageResolution Properties
PageResolution Structure See Also Send Feedback

The PageResolution type exposes the following members.

Properties

 | Name | Description
Public property | Horizontal | The horizontal resolution (pixels-per-inch).
Public property | Vertical | The vertical resolution (pixels-per-inch).

See Also

PageResolution Structure
ININ.IceLib.UnifiedMessaging Namespace


Horizontal Property

[image]

IceLib Technical Reference
PageResolution..::..Horizontal Property
PageResolution Structure See Also Send Feedback
The horizontal resolution (pixels-per-inch).

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Horizontal { get; }
Visual Basic
Public ReadOnly Property Horizontal As Integer
    Get

Field Value

The horizontal resolution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PageResolution Structure
PageResolution Members
ININ.IceLib.UnifiedMessaging Namespace


Vertical Property

[image]

IceLib Technical Reference
PageResolution..::..Vertical Property
PageResolution Structure See Also Send Feedback
The vertical resolution (pixels-per-inch).

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Vertical { get; }
Visual Basic
Public ReadOnly Property Vertical As Integer
    Get

Field Value

The vertical resolution.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

PageResolution Structure
PageResolution Members
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Class

[image]

IceLib Technical Reference
RateLimitedException Class
Members See Also Send Feedback
The exception that is thrown when requests to refresh a voicemail or fax have been sent too frequently.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SerializableAttribute]
public class RateLimitedException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class RateLimitedException _
    Inherits IceLibException

Remarks

This exception is thrown when requests to refresh a voicemail or fax are being sent too frequently.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.IceLib..::..IceLibException
ININ.IceLib.UnifiedMessaging..::..RateLimitedException

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Members
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Members

[image] [image]

IceLib Technical Reference
RateLimitedException Members
RateLimitedException Class Constructors Methods Properties Events See Also Send Feedback

The RateLimitedException type exposes the following members.

Constructors

 | Name | Description
Public method | RateLimitedException()()()() | Initializes a new instance of the RateLimitedException class with default settings.
Public method | RateLimitedException(Exception) | Initializes a new instance of the RateLimitedException class with a specified error message.
Public method | RateLimitedException(CultureInfo) | Initializes a new instance of the RateLimitedException class with default settings.
Public method | RateLimitedException(String) | Initializes a new instance of the RateLimitedException class with a specified error message.
Public method | RateLimitedException(CultureInfo, Exception) | Initializes a new instance of the RateLimitedException class with a specified error message.
Protected method | RateLimitedException(SerializationInfo, StreamingContext) | Initializes a new instance of the RateLimitedException class with a specified error message.
Public method | RateLimitedException(String, Exception) | Initializes a new instance of the RateLimitedException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RateLimitedException Class
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor

[image] [image]

IceLib Technical Reference
RateLimitedException Constructor
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class.

Overload List

 | Name | Description
Public method | RateLimitedException()()()() | Initializes a new instance of the RateLimitedException class with default settings.
Public method | RateLimitedException(Exception) | Initializes a new instance of the RateLimitedException class with a specified error message.
Public method | RateLimitedException(CultureInfo) | Initializes a new instance of the RateLimitedException class with default settings.
Public method | RateLimitedException(String) | Initializes a new instance of the RateLimitedException class with a specified error message.
Public method | RateLimitedException(CultureInfo, Exception) | Initializes a new instance of the RateLimitedException class with a specified error message.
Protected method | RateLimitedException(SerializationInfo, StreamingContext) | Initializes a new instance of the RateLimitedException class with a specified error message.
Public method | RateLimitedException(String, Exception) | Initializes a new instance of the RateLimitedException class with a specified error message.

See Also

RateLimitedException Class
RateLimitedException Members
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor

[image]

IceLib Technical Reference
RateLimitedException Constructor
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with default settings.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RateLimitedException()
Visual Basic
Public Sub New

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor (Exception)

[image]

IceLib Technical Reference
RateLimitedException Constructor (Exception)
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with a specified error message.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RateLimitedException(
    Exception innerException
)
Visual Basic
Public Sub New ( _
    innerException As Exception _
)

Parameters

innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor (CultureInfo)

[image]

IceLib Technical Reference
RateLimitedException Constructor (CultureInfo)
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with default settings.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RateLimitedException(
    CultureInfo cultureInfo
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor (String)

[image]

IceLib Technical Reference
RateLimitedException Constructor (String)
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with a specified error message.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RateLimitedException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String
The message that describes the error.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor (CultureInfo, Exception)

[image]

IceLib Technical Reference
RateLimitedException Constructor (CultureInfo, Exception)
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with a specified error message.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RateLimitedException(
    CultureInfo cultureInfo,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    cultureInfo As CultureInfo, _
    innerException As Exception _
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
The culture info for which to load the resource.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor (SerializationInfo, StreamingContext)

[image]

IceLib Technical Reference
RateLimitedException Constructor (SerializationInfo, StreamingContext)
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with a specified error message.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected RateLimitedException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Constructor (String, Exception)

[image]

IceLib Technical Reference
RateLimitedException Constructor (String, Exception)
RateLimitedException Class See Also Send Feedback
Initializes a new instance of the RateLimitedException class with a specified error message.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public RateLimitedException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception. If the innerException parameter is not nullNothingnullptra null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
RateLimitedException Overload
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Methods

[image] [image]

IceLib Technical Reference
RateLimitedException Methods
RateLimitedException Class See Also Send Feedback

The RateLimitedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RateLimitedException Class
ININ.IceLib.UnifiedMessaging Namespace


GetObjectData Method

[image]

IceLib Technical Reference
RateLimitedException..::..GetObjectData Method
RateLimitedException Class See Also Send Feedback
Sets the SerializationInfo with information about the exception.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 SU 4 and beyond.

See Also

RateLimitedException Class
RateLimitedException Members
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Properties

[image] [image]

IceLib Technical Reference
RateLimitedException Properties
RateLimitedException Class See Also Send Feedback

The RateLimitedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets or sets the internal error code. (Inherited from IceLibException.)
Public property | ErrorType | Gets the value for the type of error. (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RateLimitedException Class
ININ.IceLib.UnifiedMessaging Namespace


RateLimitedException Events

[image] [image]

IceLib Technical Reference
RateLimitedException Events
RateLimitedException Class See Also Send Feedback

The RateLimitedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RateLimitedException Class
ININ.IceLib.UnifiedMessaging Namespace


RetryStrategyType Enumeration

[image]

IceLib Technical Reference
RetryStrategyType Enumeration
See Also Send Feedback
Determines the strategy employed on how a fax should be resent.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum RetryStrategyType
Visual Basic
Public Enumeration RetryStrategyType

Members

Member name | Value | Description
All | 0 | Resend all pages.
Incomplete | 1 | Resend only incomplete pages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


StorageFormat Enumeration

[image]

IceLib Technical Reference
StorageFormat Enumeration
See Also Send Feedback
Indicates the storage format used when loading or saving Fax data in files.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum StorageFormat
Visual Basic
Public Enumeration StorageFormat

Members

Member name | Value | Description
ByExtension | 0 | Use the file extension to determine the file format.
I3F | 1 | I3F encoded fax.
Tiff | 2 | Multipage Tiff encoded fax.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

ININ.IceLib.UnifiedMessaging Namespace


UnifiedMessagingManager Class

[image]

IceLib Technical Reference
UnifiedMessagingManager Class
Members See Also Send Feedback
Provides access to the UnifiedMessaging namespace.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class UnifiedMessagingManager
Visual Basic
Public Class UnifiedMessagingManager

Remarks

Use the UnifiedMessagingManager class to access the functionality found in the ININ.IceLib.UnifiedMessaging namespace.

The ININ.IceLib.UnifiedMessaging namespace includes all functionality for manipulating Fax and voicemail data managed by an IC server. Most features provided in the UnifiedMessagingManager are available in synchronous and asynchronous versions, allowing you to choose the model that best suits your needs.

Examples

All "manager" classes found in the IceLib library are designed as singletons. To begin working with any of the functionality provided in the UnifiedMessagingManager you must obtain the instance through a call to GetInstance(Session).

CopyC#
Session session = new Session();
session.Connect(...);
UnifiedMessagingManager unifiedMessagingManager = UnifiedMessagingManager.GetInstance(session);

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..UnifiedMessagingManager

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


UnifiedMessagingManager Members

[image] [image]

IceLib Technical Reference
UnifiedMessagingManager Members
UnifiedMessagingManager Class Methods Properties Events See Also Send Feedback

The UnifiedMessagingManager type exposes the following members.

Methods

 | Name | Description
Public method | CancelFax | Issues a synchronous request to cancel a fax.
Public method | CancelFaxAsync | Issues an asynchronous request to cancel a fax.
Public method | EnableFaxMonitoring | Issues an synchronous request to enable or disable monitoring of Fax server events.
Public method | EnableFaxMonitoringAsync | Issues an asynchronous request to enable or disable monitoring of Fax server events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFaxProperties | Issues a synchronous request to get the fax envelope properties for a fax in progress.
Public method | GetFaxPropertiesAsync | Issues an asynchronous request to get the envelope properties of a fax in progress.
Public method | GetFaxServerSettings | Issues a synchronous request to retrieve the Fax configuration settings on the IC server.
Public method | GetFaxServerSettingsAsync | Issues an asynchronous request to retrieve the Fax configuration settings on the IC server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a UnifiedMessagingManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshFaxCache | Issues a synchronous request to refresh the fax cache.
Public method | RefreshFaxCacheAsync | Issues an asynchronous request to refresh the fax cache.
Public method | RefreshVoicemailCache | Issues a synchronous request to refresh the voicemail cache.
Public method | RefreshVoicemailCacheAsync | Issues an asynchronous request to refresh the voicemail cache.
Public method | SendFax | Issues a synchronous request to send a Fax.
Public method | SendFaxAsync | Issues an asynchronous request to send a Fax.
Public method | StartWatchingVoicemailWaiting | Issues a synchronous request to watch for waiting voicemails.
Public method | StartWatchingVoicemailWaitingAsync | Issues an asynchronous request to watch for waiting voicemails.
Public method | StopVoicemailHandsetPlayback | Issues a synchronous request to stop voicemail playback on the handset.
Public method | StopVoicemailHandsetPlaybackAsync | Issues an asychronous request to stop voicemail playback on the handset.
Public method | StopWatchingVoicemailWaiting | Issues a synchronous request to stop watching for waiting voicemails.
Public method | StopWatchingVoicemailWaitingAsync | Issues an asynchronous request to stop watching for waiting voicemails.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateMessageWaitingIndicator | Issues a synchronous request to update the message waiting indicator.
Public method | UpdateMessageWaitingIndicatorAsync | Issues an asynchronous request to update the message waiting indicator.

Properties

 | Name | Description
Public property | Faxes | Gets a ReadOnlyCollection<(Of <(<'T>)>)> of all FaxMessages.
Public property | Session | Gets the Session with which this UnifiedMessagingManager is associated.
Public property | Voicemails | Gets a ReadOnlyCollection<(Of <(<'T>)>)> of all VoicemailMessages.
Public property | VoicemailWaiting | Gets the existence of waiting (unread) voicemails.

Events

 | Name | Description
Public event | FaxDeleted | Occurs when a fax is deleted.
Public event | FaxMonitorUpdate | Occurs when monitoring is turned on and a Fax event is detected.
Public event | FaxUpdated | Occurs when a fax is modified.
Public event | NewFax | Occurs when a new fax is received.
Public event | NewVoicemail | Occurs when a new voicemail is received.
Public event | VoicemailDeleted | Occurs when a voicemail is deleted.
Public event | VoicemailServerPlayResult | Occurs when the server has completed playing a voicemail to the user.
Public event | VoicemailUpdateCompleted | Occurs when an operation finishes updating the list of voicemails.
Public event | VoicemailUpdated | Occurs when a voicemail is modified.
Public event | VoicemailUpdateStarted | Occurs when an operation begins updating the list of voicemails.
Public event | VoicemailWaitingChanged | Occurs when the VoicemailWaiting value changes.

See Also

UnifiedMessagingManager Class
ININ.IceLib.UnifiedMessaging Namespace


UnifiedMessagingManager Methods

[image] [image]

IceLib Technical Reference
UnifiedMessagingManager Methods
UnifiedMessagingManager Class See Also Send Feedback

The UnifiedMessagingManager type exposes the following members.

Methods

 | Name | Description
Public method | CancelFax | Issues a synchronous request to cancel a fax.
Public method | CancelFaxAsync | Issues an asynchronous request to cancel a fax.
Public method | EnableFaxMonitoring | Issues an synchronous request to enable or disable monitoring of Fax server events.
Public method | EnableFaxMonitoringAsync | Issues an asynchronous request to enable or disable monitoring of Fax server events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFaxProperties | Issues a synchronous request to get the fax envelope properties for a fax in progress.
Public method | GetFaxPropertiesAsync | Issues an asynchronous request to get the envelope properties of a fax in progress.
Public method | GetFaxServerSettings | Issues a synchronous request to retrieve the Fax configuration settings on the IC server.
Public method | GetFaxServerSettingsAsync | Issues an asynchronous request to retrieve the Fax configuration settings on the IC server.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance | Gets a UnifiedMessagingManager.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshFaxCache | Issues a synchronous request to refresh the fax cache.
Public method | RefreshFaxCacheAsync | Issues an asynchronous request to refresh the fax cache.
Public method | RefreshVoicemailCache | Issues a synchronous request to refresh the voicemail cache.
Public method | RefreshVoicemailCacheAsync | Issues an asynchronous request to refresh the voicemail cache.
Public method | SendFax | Issues a synchronous request to send a Fax.
Public method | SendFaxAsync | Issues an asynchronous request to send a Fax.
Public method | StartWatchingVoicemailWaiting | Issues a synchronous request to watch for waiting voicemails.
Public method | StartWatchingVoicemailWaitingAsync | Issues an asynchronous request to watch for waiting voicemails.
Public method | StopVoicemailHandsetPlayback | Issues a synchronous request to stop voicemail playback on the handset.
Public method | StopVoicemailHandsetPlaybackAsync | Issues an asychronous request to stop voicemail playback on the handset.
Public method | StopWatchingVoicemailWaiting | Issues a synchronous request to stop watching for waiting voicemails.
Public method | StopWatchingVoicemailWaitingAsync | Issues an asynchronous request to stop watching for waiting voicemails.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateMessageWaitingIndicator | Issues a synchronous request to update the message waiting indicator.
Public method | UpdateMessageWaitingIndicatorAsync | Issues an asynchronous request to update the message waiting indicator.

See Also

UnifiedMessagingManager Class
ININ.IceLib.UnifiedMessaging Namespace


CancelFax Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..CancelFax Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to cancel a fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelFax(
    long envelopeId
)
Visual Basic
Public Sub CancelFax ( _
    envelopeId As Long _
)

Parameters

envelopeId
Type: System..::..Int64
The envelope ID of the fax.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The argument isn't in the expected range.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


CancelFaxAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..CancelFaxAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to cancel a fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelFaxAsync(
    long envelopeId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CancelFaxAsync ( _
    envelopeId As Long, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

envelopeId
Type: System..::..Int64
The envelope ID of the fax.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The argument isn't in the expected range.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


EnableFaxMonitoring Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..EnableFaxMonitoring Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an synchronous request to enable or disable monitoring of Fax server events.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EnableFaxMonitoring(
    bool enabled
)
Visual Basic
Public Sub EnableFaxMonitoring ( _
    enabled As Boolean _
)

Parameters

enabled
Type: System..::..Boolean
Should monitoring be turned on.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


EnableFaxMonitoringAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..EnableFaxMonitoringAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to enable or disable monitoring of Fax server events.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void EnableFaxMonitoringAsync(
    bool enabled,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EnableFaxMonitoringAsync ( _
    enabled As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

enabled
Type: System..::..Boolean
Should monitoring be turned on.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


GetFaxProperties Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..GetFaxProperties Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to get the fax envelope properties for a fax in progress.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxEnvelopeProperties GetFaxProperties(
    long envelopeId
)
Visual Basic
Public Function GetFaxProperties ( _
    envelopeId As Long _
) As FaxEnvelopeProperties

Parameters

envelopeId
Type: System..::..Int64
The envelope ID of the fax.

Return Value

The FaxEnvelopeProperties for this fax.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The argument isn't in the expected range.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


GetFaxPropertiesAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..GetFaxPropertiesAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to get the envelope properties of a fax in progress.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetFaxPropertiesAsync(
    long envelopeId,
    EventHandler<AsyncGetFaxPropertiesEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetFaxPropertiesAsync ( _
    envelopeId As Long, _
    completedCallback As EventHandler(Of AsyncGetFaxPropertiesEventArgs), _
    userState As Object _
)

Parameters

envelopeId
Type: System..::..Int64
The envelope ID of the fax for which properties are requested.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncGetFaxPropertiesEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The argument isn't in the expected range.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 SU 1 and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


GetFaxServerSettings Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..GetFaxServerSettings Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to retrieve the Fax configuration settings on the IC server.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxServerSettings GetFaxServerSettings()
Visual Basic
Public Function GetFaxServerSettings As FaxServerSettings

Return Value

A FaxServerSettings object with the Fax configuration settings on the IC server.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


GetFaxServerSettingsAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..GetFaxServerSettingsAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to retrieve the Fax configuration settings on the IC server.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void GetFaxServerSettingsAsync(
    EventHandler<AsyncGetFaxServerSettingsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetFaxServerSettingsAsync ( _
    completedCallback As EventHandler(Of AsyncGetFaxServerSettingsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncGetFaxServerSettingsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


GetInstance Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..GetInstance Method
UnifiedMessagingManager Class See Also Send Feedback
Gets a UnifiedMessagingManager.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static UnifiedMessagingManager GetInstance(
    Session session
)
Visual Basic
Public Shared Function GetInstance ( _
    session As Session _
) As UnifiedMessagingManager

Parameters

session
Type: ININ.IceLib.Connection..::..Session
The Session with which it is associated.

Return Value

The UnifiedMessagingManager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


RefreshFaxCache Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..RefreshFaxCache Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to refresh the fax cache.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshFaxCache(
    int maxMessages
)
Visual Basic
Public Sub RefreshFaxCache ( _
    maxMessages As Integer _
)

Parameters

maxMessages
Type: System..::..Int32
The number of messages to refresh, -1 to refresh them all.

Remarks

Any subsequent calls to this method or its async version (RefreshFaxCacheAsync(Int32, AsyncCompletedEventHandler, Object)) within a 5 second period will be rejected with a RateLimitedException. This restriction is per message type, a call to RefreshFaxCache(Int32) followed by a call to RefreshVoicemailCache(Int32) or RefreshVoicemailCacheAsync(Int32, AsyncCompletedEventHandler, Object) within a 5 second period will be successful.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibException | There was an error refreshing the list or this method was called more than once within a 5 second period.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


RefreshFaxCacheAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..RefreshFaxCacheAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to refresh the fax cache.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshFaxCacheAsync(
    int maxMessages,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RefreshFaxCacheAsync ( _
    maxMessages As Integer, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

maxMessages
Type: System..::..Int32
The number of messages to refresh, -1 to refresh them all.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Any subsequent calls to this method or its synchronous version (RefreshFaxCache(Int32)) within a 5 second period will be rejected with a RateLimitedException. This restriction is per message type, a call to RefreshFaxCacheAsync(Int32, AsyncCompletedEventHandler, Object) followed by a call to RefreshVoicemailCache(Int32) or RefreshVoicemailCacheAsync(Int32, AsyncCompletedEventHandler, Object) within a 5 second period will be successful.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


RefreshVoicemailCache Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..RefreshVoicemailCache Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to refresh the voicemail cache.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshVoicemailCache(
    int maxMessages
)
Visual Basic
Public Sub RefreshVoicemailCache ( _
    maxMessages As Integer _
)

Parameters

maxMessages
Type: System..::..Int32
The number of messages to refresh, -1 to refresh them all.

Remarks

Any subsequent calls to this method or its async version (RefreshVoicemailCacheAsync(Int32, AsyncCompletedEventHandler, Object)) within a 5 second period will be rejected with a RateLimitedException. This restriction is per message type, a call to RefreshVoicemailCache(Int32) followed by a call to RefreshFaxCache(Int32) or RefreshFaxCacheAsync(Int32, AsyncCompletedEventHandler, Object) within a 5 second period will be successful.

Exceptions

Exception | Condition
ININ.IceLib..::..IceLibException | There was an error refreshing the list or this method was called more than once within a 5 second period.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


RefreshVoicemailCacheAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..RefreshVoicemailCacheAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to refresh the voicemail cache.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void RefreshVoicemailCacheAsync(
    int maxMessages,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RefreshVoicemailCacheAsync ( _
    maxMessages As Integer, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

maxMessages
Type: System..::..Int32
The number of messages to refresh, -1 to refresh them all.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Any subsequent calls to this method or its synchronous version (RefreshVoicemailCache(Int32)) within a 5 second period will be rejected with a RateLimitedException. This restriction is per message type, a call to RefreshVoicemailCacheAsync(Int32, AsyncCompletedEventHandler, Object) followed by a call to RefreshFaxCache(Int32) or RefreshFaxCacheAsync(Int32, AsyncCompletedEventHandler, Object) within a 5 second period will be successful.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


SendFax Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..SendFax Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to send a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public FaxResult SendFax(
    string fileName
)
Visual Basic
Public Function SendFax ( _
    fileName As String _
) As FaxResult

Parameters

fileName
Type: System..::..String
The file name of the Fax to send.

Return Value

A FaxResult object with the results of the SendFax method.

Remarks

Use the FaxFile class to create a .TIF or .i3f formatted Fax file in the file system before sending.

Note
Most fax terminals can't handle widths larger than 1728 pixels. If the width of the Image will exceed 1728 pixels, it is recommended to store the image in portrait orientation and set the FaxPageAttributes instance to indicate that the image has been rotated.
This can also be handled by specifying FitToPage when adding or updating pages. This will cause the image to be scaled to fit on the page. If FitToPage is not specified, no resizing will be done and the image will be cropped.

Exceptions

Exception | Condition
System..::..ArgumentException | If a fileName of length zero.
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxFile


SendFaxAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..SendFaxAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to send a Fax.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SendFaxAsync(
    string fileName,
    EventHandler<AsyncSendFaxCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SendFaxAsync ( _
    fileName As String, _
    completedCallback As EventHandler(Of AsyncSendFaxCompletedEventArgs), _
    userState As Object _
)

Parameters

fileName
Type: System..::..String
The file name of the Fax to send.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncSendFaxCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

Use the FaxFile class to create a .TIF or .i3f formatted Fax file in the file system before sending.

Note
Most fax terminals can't handle widths larger than 1728 pixels. If the width of the Image will exceed 1728 pixels, it is recommended to store the image in portrait orientation and set the FaxPageAttributes instance to indicate that the image has been rotated.
This can also be handled by specifying FitToPage when adding or updating pages. This will cause the image to be scaled to fit on the page. If FitToPage is not specified, no resizing will be done and the image will be cropped.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If a fileName of length zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace
ININ.IceLib.UnifiedMessaging..::..FaxFile


StartWatchingVoicemailWaiting Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..StartWatchingVoicemailWaiting Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to watch for waiting voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingVoicemailWaiting()
Visual Basic
Public Sub StartWatchingVoicemailWaiting

Remarks

Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


StartWatchingVoicemailWaitingAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..StartWatchingVoicemailWaitingAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to watch for waiting voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartWatchingVoicemailWaitingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartWatchingVoicemailWaitingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


StopVoicemailHandsetPlayback Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..StopVoicemailHandsetPlayback Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to stop voicemail playback on the handset.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopVoicemailHandsetPlayback()
Visual Basic
Public Sub StopVoicemailHandsetPlayback

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


StopVoicemailHandsetPlaybackAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..StopVoicemailHandsetPlaybackAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asychronous request to stop voicemail playback on the handset.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopVoicemailHandsetPlaybackAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopVoicemailHandsetPlaybackAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


StopWatchingVoicemailWaiting Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..StopWatchingVoicemailWaiting Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to stop watching for waiting voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingVoicemailWaiting()
Visual Basic
Public Sub StopWatchingVoicemailWaiting

Remarks

Note
For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


StopWatchingVoicemailWaitingAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..StopWatchingVoicemailWaitingAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to stop watching for waiting voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopWatchingVoicemailWaitingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopWatchingVoicemailWaitingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


UpdateMessageWaitingIndicator Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..UpdateMessageWaitingIndicator Method
UnifiedMessagingManager Class See Also Send Feedback
Issues a synchronous request to update the message waiting indicator.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateMessageWaitingIndicator(
    int actualMessageCount
)
Visual Basic
Public Sub UpdateMessageWaitingIndicator ( _
    actualMessageCount As Integer _
)

Parameters

actualMessageCount
Type: System..::..Int32
The count of messages, or -1 to force the server to compute the count.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


UpdateMessageWaitingIndicatorAsync Method

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..UpdateMessageWaitingIndicatorAsync Method
UnifiedMessagingManager Class See Also Send Feedback
Issues an asynchronous request to update the message waiting indicator.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void UpdateMessageWaitingIndicatorAsync(
    int actualMessageCount,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateMessageWaitingIndicatorAsync ( _
    actualMessageCount As Integer, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

actualMessageCount
Type: System..::..Int32
The count of messages, or -1 to force the server to compute the count.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


UnifiedMessagingManager Properties

[image] [image]

IceLib Technical Reference
UnifiedMessagingManager Properties
UnifiedMessagingManager Class See Also Send Feedback

The UnifiedMessagingManager type exposes the following members.

Properties

 | Name | Description
Public property | Faxes | Gets a ReadOnlyCollection<(Of <(<'T>)>)> of all FaxMessages.
Public property | Session | Gets the Session with which this UnifiedMessagingManager is associated.
Public property | Voicemails | Gets a ReadOnlyCollection<(Of <(<'T>)>)> of all VoicemailMessages.
Public property | VoicemailWaiting | Gets the existence of waiting (unread) voicemails.

See Also

UnifiedMessagingManager Class
ININ.IceLib.UnifiedMessaging Namespace


Faxes Property

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..Faxes Property
UnifiedMessagingManager Class See Also Send Feedback
Gets a ReadOnlyCollection<(Of <(<'T>)>)> of all FaxMessages.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<FaxMessage> Faxes { get; }
Visual Basic
Public ReadOnly Property Faxes As ReadOnlyCollection(Of FaxMessage)
    Get

Field Value

The fax messages.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


Session Property

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..Session Property
UnifiedMessagingManager Class See Also Send Feedback
Gets the Session with which this UnifiedMessagingManager is associated.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


Voicemails Property

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..Voicemails Property
UnifiedMessagingManager Class See Also Send Feedback
Gets a ReadOnlyCollection<(Of <(<'T>)>)> of all VoicemailMessages.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<VoicemailMessage> Voicemails { get; }
Visual Basic
Public ReadOnly Property Voicemails As ReadOnlyCollection(Of VoicemailMessage)
    Get

Field Value

The voicemail messages.

Remarks

Note
The Voicemails property will not be populated until after either the RefreshVoicemailCache(Int32) method or the RefreshVoicemailCacheAsync(Int32, AsyncCompletedEventHandler, Object) method has been called and the NewVoicemail event has fired.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailWaiting Property

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailWaiting Property
UnifiedMessagingManager Class See Also Send Feedback
Gets the existence of waiting (unread) voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool VoicemailWaiting { get; }
Visual Basic
Public ReadOnly Property VoicemailWaiting As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if a voicemail is waiting; otherwise, falseFalsefalsefalse (False in Visual Basic).

Remarks

Note
Accessing this property before a watch is started which includes this property raises a NotCachedException. A watch must be started first. For more information on watches see How Watches Work.

Exceptions

Exception | Condition
ININ.IceLib..::..NotCachedException | VoicemailWaiting not being watched.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


UnifiedMessagingManager Events

[image] [image]

IceLib Technical Reference
UnifiedMessagingManager Events
UnifiedMessagingManager Class See Also Send Feedback

The UnifiedMessagingManager type exposes the following members.

Events

 | Name | Description
Public event | FaxDeleted | Occurs when a fax is deleted.
Public event | FaxMonitorUpdate | Occurs when monitoring is turned on and a Fax event is detected.
Public event | FaxUpdated | Occurs when a fax is modified.
Public event | NewFax | Occurs when a new fax is received.
Public event | NewVoicemail | Occurs when a new voicemail is received.
Public event | VoicemailDeleted | Occurs when a voicemail is deleted.
Public event | VoicemailServerPlayResult | Occurs when the server has completed playing a voicemail to the user.
Public event | VoicemailUpdateCompleted | Occurs when an operation finishes updating the list of voicemails.
Public event | VoicemailUpdated | Occurs when a voicemail is modified.
Public event | VoicemailUpdateStarted | Occurs when an operation begins updating the list of voicemails.
Public event | VoicemailWaitingChanged | Occurs when the VoicemailWaiting value changes.

See Also

UnifiedMessagingManager Class
ININ.IceLib.UnifiedMessaging Namespace


FaxDeleted Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..FaxDeleted Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when a fax is deleted.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<FaxEventArgs> FaxDeleted
Visual Basic
Public Event FaxDeleted As EventHandler(Of FaxEventArgs)

Remarks

This event will only occur if faxes are being monitored. To start monitoring faxes call either the EnableFaxMonitoring(Boolean) method or the EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling EnableFaxMonitoring(Boolean) or EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


FaxMonitorUpdate Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..FaxMonitorUpdate Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when monitoring is turned on and a Fax event is detected.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<FaxMonitorUpdateEventArgs> FaxMonitorUpdate
Visual Basic
Public Event FaxMonitorUpdate As EventHandler(Of FaxMonitorUpdateEventArgs)

Remarks

This event will only occur if faxes are being monitored. To start monitoring faxes call either the EnableFaxMonitoring(Boolean) method or the EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling EnableFaxMonitoring(Boolean) or EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


FaxUpdated Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..FaxUpdated Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when a fax is modified.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<FaxEventArgs> FaxUpdated
Visual Basic
Public Event FaxUpdated As EventHandler(Of FaxEventArgs)

Remarks

This event will only occur if faxes are being monitored. To start monitoring faxes call either the EnableFaxMonitoring(Boolean) method or the EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling EnableFaxMonitoring(Boolean) or EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


NewFax Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..NewFax Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when a new fax is received.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<FaxEventArgs> NewFax
Visual Basic
Public Event NewFax As EventHandler(Of FaxEventArgs)

Remarks

This event will only occur if faxes are being monitored. To start monitoring faxes call either the EnableFaxMonitoring(Boolean) method or the EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling EnableFaxMonitoring(Boolean) or EnableFaxMonitoringAsync(Boolean, AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


NewVoicemail Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..NewVoicemail Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when a new voicemail is received.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<VoicemailEventArgs> NewVoicemail
Visual Basic
Public Event NewVoicemail As EventHandler(Of VoicemailEventArgs)

Remarks

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailDeleted Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailDeleted Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when a voicemail is deleted.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<VoicemailEventArgs> VoicemailDeleted
Visual Basic
Public Event VoicemailDeleted As EventHandler(Of VoicemailEventArgs)

Remarks

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailServerPlayResult Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailServerPlayResult Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when the server has completed playing a voicemail to the user.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<VoicemailServerPlayResultEventArgs> VoicemailServerPlayResult
Visual Basic
Public Event VoicemailServerPlayResult As EventHandler(Of VoicemailServerPlayResultEventArgs)

Remarks

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

This event will only occur when PlayToHandset(VoicemailAttachment, Boolean) or PlayToHandsetAsync(VoicemailAttachment, Boolean, AsyncCompletedEventHandler, Object) is invoked.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace
VoicemailMessage..::..PlayToHandset(VoicemailAttachment, Boolean)
VoicemailMessage..::..PlayToHandsetAsync(VoicemailAttachment, Boolean, AsyncCompletedEventHandler, Object)


VoicemailUpdateCompleted Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailUpdateCompleted Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when an operation finishes updating the list of voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EventArgs> VoicemailUpdateCompleted
Visual Basic
Public Event VoicemailUpdateCompleted As EventHandler(Of EventArgs)

Remarks

This event occurs when an operation, such as RefreshVoicemailCache(Int32), finishes updating the local list of voicemails. A corresponding VoicemailUpdateStarted event occurs when the operation begins.

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailUpdated Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailUpdated Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when a voicemail is modified.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<VoicemailEventArgs> VoicemailUpdated
Visual Basic
Public Event VoicemailUpdated As EventHandler(Of VoicemailEventArgs)

Remarks

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailUpdateStarted Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailUpdateStarted Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when an operation begins updating the list of voicemails.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<EventArgs> VoicemailUpdateStarted
Visual Basic
Public Event VoicemailUpdateStarted As EventHandler(Of EventArgs)

Remarks

This event occurs when an operation, such as RefreshVoicemailCache(Int32), begins updating the local list of voicemails. A corresponding VoicemailUpdateCompleted event will will occur when the operation completes.

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailWaitingChanged Event

[image]

IceLib Technical Reference
UnifiedMessagingManager..::..VoicemailWaitingChanged Event
UnifiedMessagingManager Class See Also Send Feedback
Occurs when the VoicemailWaiting value changes.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler VoicemailWaitingChanged
Visual Basic
Public Event VoicemailWaitingChanged As EventHandler

Remarks

This event will only occur if voicemails are being watched. To start watching voicemails either the StartWatchingVoicemailWaiting()()()() method or the StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object) method.
Note
All event handlers should be added before calling StartWatchingVoicemailWaiting()()()() or StartWatchingVoicemailWaitingAsync(AsyncCompletedEventHandler, Object).
Note
For more information on watches see How Watches Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

UnifiedMessagingManager Class
UnifiedMessagingManager Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailAttachment Class

[image]

IceLib Technical Reference
VoicemailAttachment Class
Members See Also Send Feedback
Represents an attachment (containing the actual Voicemail message) in a VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoicemailAttachment
Visual Basic
Public Class VoicemailAttachment

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailAttachment Members
ININ.IceLib.UnifiedMessaging Namespace
See the documentation on VoicemailMessage for how this class is used, and what information it contains.


VoicemailAttachment Members

[image] [image]

IceLib Technical Reference
VoicemailAttachment Members
VoicemailAttachment Class Methods Properties See Also Send Feedback

The VoicemailAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two VoicemailAttachment objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets the ID of this VoicemailAttachment.
Public property | Name | Gets the filename of this VoicemailAttachment.

See Also

VoicemailAttachment Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailAttachment Methods

[image] [image]

IceLib Technical Reference
VoicemailAttachment Methods
VoicemailAttachment Class See Also Send Feedback

The VoicemailAttachment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two VoicemailAttachment objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicemailAttachment Class
ININ.IceLib.UnifiedMessaging Namespace


Equals Method

[image]

IceLib Technical Reference
VoicemailAttachment..::..Equals Method
VoicemailAttachment Class See Also Send Feedback
Compares two VoicemailAttachment objects.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailAttachment Class
VoicemailAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


GetHashCode Method

[image]

IceLib Technical Reference
VoicemailAttachment..::..GetHashCode Method
VoicemailAttachment Class See Also Send Feedback
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailAttachment Class
VoicemailAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailAttachment Properties

[image] [image]

IceLib Technical Reference
VoicemailAttachment Properties
VoicemailAttachment Class See Also Send Feedback

The VoicemailAttachment type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets the ID of this VoicemailAttachment.
Public property | Name | Gets the filename of this VoicemailAttachment.

See Also

VoicemailAttachment Class
ININ.IceLib.UnifiedMessaging Namespace


Id Property

[image]

IceLib Technical Reference
VoicemailAttachment..::..Id Property
VoicemailAttachment Class See Also Send Feedback
Gets the ID of this VoicemailAttachment.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailAttachment Class
VoicemailAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


Name Property

[image]

IceLib Technical Reference
VoicemailAttachment..::..Name Property
VoicemailAttachment Class See Also Send Feedback
Gets the filename of this VoicemailAttachment.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The filename.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailAttachment Class
VoicemailAttachment Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailEventArgs Class

[image]

IceLib Technical Reference
VoicemailEventArgs Class
Members See Also Send Feedback
Provides data for the NewVoicemail, VoicemailDeleted, and VoicemailUpdated events.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoicemailEventArgs : EventArgs
Visual Basic
Public Class VoicemailEventArgs _
    Inherits EventArgs

Remarks

Handle the NewVoicemail event to be informed when a new voicemail has been added to the Voicemails list.
Handle the VoicemailDeleted event to be informed when an existing voicemail has been removed from the Voicemails list.
Handle the VoicemailUpdated event to be informed when an existing voicemail in the Voicemails list has been changed.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.UnifiedMessaging..::..VoicemailEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailEventArgs Members

[image] [image]

IceLib Technical Reference
VoicemailEventArgs Members
VoicemailEventArgs Class Constructors Methods Properties See Also Send Feedback

The VoicemailEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VoicemailEventArgs | Initializes a new instance of the VoicemailEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets the Voicemail message associated with the event.

See Also

VoicemailEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailEventArgs Constructor

[image]

IceLib Technical Reference
VoicemailEventArgs Constructor
VoicemailEventArgs Class See Also Send Feedback
Initializes a new instance of the VoicemailEventArgs class with the specified values.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicemailEventArgs(
    VoicemailMessage message
)
Visual Basic
Public Sub New ( _
    message As VoicemailMessage _
)

Parameters

message
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailMessage
The message.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailEventArgs Class
VoicemailEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailEventArgs Methods

[image] [image]

IceLib Technical Reference
VoicemailEventArgs Methods
VoicemailEventArgs Class See Also Send Feedback

The VoicemailEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicemailEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailEventArgs Properties

[image] [image]

IceLib Technical Reference
VoicemailEventArgs Properties
VoicemailEventArgs Class See Also Send Feedback

The VoicemailEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the Voicemail message associated with the event.

See Also

VoicemailEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


Message Property

[image]

IceLib Technical Reference
VoicemailEventArgs..::..Message Property
VoicemailEventArgs Class See Also Send Feedback
Gets the Voicemail message associated with the event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicemailMessage Message { get; }
Visual Basic
Public ReadOnly Property Message As VoicemailMessage
    Get

Field Value

The message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailEventArgs Class
VoicemailEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailMessage Class

[image]

IceLib Technical Reference
VoicemailMessage Class
Members See Also Send Feedback
Represents a Voicemail message within the Interaction Center system.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoicemailMessage : IDisposable
Visual Basic
Public Class VoicemailMessage _
    Implements IDisposable

Remarks

All VoicemailMessages are accessible through the Voicemails property of the UnifiedMessagingManager instance. The Voicemails list is not automatically kept current. It must be refreshed by calling RefreshVoicemailCache(Int32) or RefreshVoicemailCacheAsync(Int32, AsyncCompletedEventHandler, Object). In addition to referencing the entire list, code can be informed of changes to the list by subscribing to the NewVoicemail, VoicemailDeleted, and VoicemailUpdated events.

A VoicemailMessage contains various pieces of information about the voicemail itself (for example: From, To, Subject, Body), as well as a list of actual audio attachments to the voicemail. A VoicemailMessage may contain zero or more VoicemailAttachments (available from the Attachments property), each one representing some portion of audio added to the voicemail at any given time. This can include the original voicemail message, comments that have been attached and forwarded, etc.

Note
Although this is not typical, each VoicemailAttachment may not necessarily contain audio data. It is possible for a user to attach any file they wish to a VoicemailMessage.

A VoicemailMessage can be played to a target (PlayToHandset(VoicemailAttachment, Boolean), PlayToNumber(VoicemailAttachment, String, Boolean, Boolean), PlayToStation(VoicemailAttachment, String, Boolean, Boolean)), or downloaded as a file (SaveAsFile(VoicemailAttachment, String, Boolean)) for local playback/manipulation.

Note
Currently, VoicemailMessages may not be changed and saved.

Examples

The following example demonstrates playing back a VoicemailMessage to the logged in station's handset.
CopyC#
...
UnifiedMessagingManager manager = UnifiedMessagingManager.GetInstance(_session);
manager.RefreshVoicemailCache(-1);
if (manager.Voicemails.Count > 0)
{
    VoicemailMessage msg = manager.Voicemails[0];
    if ((msg.Attachments.Count > 0) && (IsWavFileExtension(msg.Attachments[0].Name))
    {
        msg.PlayToHandset(msg.Attachments[0], true);
    }
}
...

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..VoicemailMessage

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailMessage Members

[image] [image]

IceLib Technical Reference
VoicemailMessage Members
VoicemailMessage Class Methods Properties Events See Also Send Feedback

The VoicemailMessage type exposes the following members.

Methods

 | Name | Description
Public method | CancelSaveAsFile | Cancels the current downloading to a file.
Public method | Delete | Issues a synchronous request to delete this VoicemailMessage.
Public method | DeleteAsync | Issues an asynchronous request to delete this VoicemailMessage.
Public method | Dispose()()()() | Releases resources held by this instance.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlayToHandset | Issues a synchronous request to play a VoicemailAttachment to the handset of the current logged-in station.
Public method | PlayToHandsetAsync | Issues an asynchronous request to play a VoicemailAttachment to the handset of the current logged-in station.
Public method | PlayToNumber | Issues a synchronous request to play a VoicemailMessage to a specified target number.
Public method | PlayToNumberAsync | Issues an asynchronous request to play a VoicemailAttachment to a specified target number.
Public method | PlayToStation | Issues an synchronous request to play this VoicemailMessage to a specified station.
Public method | PlayToStationAsync | Issues an asynchronous request to play this VoicemailMessage to a specified station.
Public method | SaveAsFile | Downloads this message into a specified file.
Public method | SaveAsFileAsync | Asynchronously downloads this VoicemailMessage into a specified file.
Public method | StopPlayToNumber | Issues a synchronous request to stop playing a VoicemailMessage to a remote number.
Public method | StopPlayToNumberAsync | Issues an asynchronous request to stop playing a VoicemailMessage to a remote number.
Public method | StopPlayToStation | Issues a synchronous request to stop playing a VoicemailMessage to a station.
Public method | StopPlayToStationAsync | Issues an asynchronous request to stop playing a VoicemailMessage to a station.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attachments | Gets the list of attachments on this VoicemailMessage.
Public property | Body | Gets the body text of this VoicemailMessage.
Public property | Cc | Gets the list of recipients carbon-copied on this VoicemailMessage.
Public property | DateReceived | Gets the DateTime this VoicemailMessage was received.
Public property | From | Gets the sender of the VoicemailMessage.
Public property | HasBeenRead | Gets a flag indicating whether this VoicemailMessage is marked as read or unread.
Public property | Id | Gets the ID of this VoicemailMessage.
Public property | Importance | Gets the importance level of this VoicemailMessage.
Public property | Sensitivity | Gets the sensitivity level of this VoicemailMessage.
Public property | Subject | Gets the subject of the VoicemailMessage.
Public property | To | Gets the list of recipients for this VoicemailMessage.

Events

 | Name | Description
Public event | DownloadProgressChanged | Occurs when the progress of downloading a VoicemailMessage changes.
Public event | PlaybackComplete | Occurs when playback to a remote number or station has completed.

See Also

VoicemailMessage Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailMessage Methods

[image] [image]

IceLib Technical Reference
VoicemailMessage Methods
VoicemailMessage Class See Also Send Feedback

The VoicemailMessage type exposes the following members.

Methods

 | Name | Description
Public method | CancelSaveAsFile | Cancels the current downloading to a file.
Public method | Delete | Issues a synchronous request to delete this VoicemailMessage.
Public method | DeleteAsync | Issues an asynchronous request to delete this VoicemailMessage.
Public method | Dispose()()()() | Releases resources held by this instance.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlayToHandset | Issues a synchronous request to play a VoicemailAttachment to the handset of the current logged-in station.
Public method | PlayToHandsetAsync | Issues an asynchronous request to play a VoicemailAttachment to the handset of the current logged-in station.
Public method | PlayToNumber | Issues a synchronous request to play a VoicemailMessage to a specified target number.
Public method | PlayToNumberAsync | Issues an asynchronous request to play a VoicemailAttachment to a specified target number.
Public method | PlayToStation | Issues an synchronous request to play this VoicemailMessage to a specified station.
Public method | PlayToStationAsync | Issues an asynchronous request to play this VoicemailMessage to a specified station.
Public method | SaveAsFile | Downloads this message into a specified file.
Public method | SaveAsFileAsync | Asynchronously downloads this VoicemailMessage into a specified file.
Public method | StopPlayToNumber | Issues a synchronous request to stop playing a VoicemailMessage to a remote number.
Public method | StopPlayToNumberAsync | Issues an asynchronous request to stop playing a VoicemailMessage to a remote number.
Public method | StopPlayToStation | Issues a synchronous request to stop playing a VoicemailMessage to a station.
Public method | StopPlayToStationAsync | Issues an asynchronous request to stop playing a VoicemailMessage to a station.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicemailMessage Class
ININ.IceLib.UnifiedMessaging Namespace


CancelSaveAsFile Method

[image]

IceLib Technical Reference
VoicemailMessage..::..CancelSaveAsFile Method
VoicemailMessage Class See Also Send Feedback
Cancels the current downloading to a file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void CancelSaveAsFile(
    VoicemailAttachment attachment
)
Visual Basic
Public Sub CancelSaveAsFile ( _
    attachment As VoicemailAttachment _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The attachment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Delete Method

[image]

IceLib Technical Reference
VoicemailMessage..::..Delete Method
VoicemailMessage Class See Also Send Feedback
Issues a synchronous request to delete this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


DeleteAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..DeleteAsync Method
VoicemailMessage Class See Also Send Feedback
Issues an asynchronous request to delete this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void DeleteAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub DeleteAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method

[image] [image]

IceLib Technical Reference
VoicemailMessage..::..Dispose Method
VoicemailMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases resources held by this instance.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method

[image]

IceLib Technical Reference
VoicemailMessage..::..Dispose Method
VoicemailMessage Class See Also Send Feedback
Releases resources held by this instance.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
Dispose Overload
ININ.IceLib.UnifiedMessaging Namespace


Dispose Method (Boolean)

[image]

IceLib Technical Reference
VoicemailMessage..::..Dispose Method (Boolean)
VoicemailMessage Class See Also Send Feedback
Releases the unmanaged resources used by the AuthSettings and optionally releases the managed resources.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
Indicates whether the control is in the process of being disposed of.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
Dispose Overload
ININ.IceLib.UnifiedMessaging Namespace


PlayToHandset Method

[image]

IceLib Technical Reference
VoicemailMessage..::..PlayToHandset Method
VoicemailMessage Class See Also Send Feedback
Issues a synchronous request to play a VoicemailAttachment to the handset of the current logged-in station.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayToHandset(
    VoicemailAttachment attachment,
    bool markAsRead
)
Visual Basic
Public Sub PlayToHandset ( _
    attachment As VoicemailAttachment, _
    markAsRead As Boolean _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment to play.
markAsRead
Type: System..::..Boolean
Mark this message as read.

Remarks

When playback is complete, VoicemailServerPlayResult will be invoked.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | If playback is already in progress.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace
UnifiedMessagingManager..::..VoicemailServerPlayResult


PlayToHandsetAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..PlayToHandsetAsync Method
VoicemailMessage Class See Also Send Feedback
Issues an asynchronous request to play a VoicemailAttachment to the handset of the current logged-in station.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayToHandsetAsync(
    VoicemailAttachment attachment,
    bool markAsRead,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PlayToHandsetAsync ( _
    attachment As VoicemailAttachment, _
    markAsRead As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment to play.
markAsRead
Type: System..::..Boolean
Mark this voicemail message as read.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When playback is complete, VoicemailServerPlayResult will be invoked.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | If playback is already in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace
UnifiedMessagingManager..::..VoicemailServerPlayResult


PlayToNumber Method

[image]

IceLib Technical Reference
VoicemailMessage..::..PlayToNumber Method
VoicemailMessage Class See Also Send Feedback
Issues a synchronous request to play a VoicemailMessage to a specified target number.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayToNumber(
    VoicemailAttachment attachment,
    string target,
    bool markAsRead,
    bool enableDigits
)
Visual Basic
Public Sub PlayToNumber ( _
    attachment As VoicemailAttachment, _
    target As String, _
    markAsRead As Boolean, _
    enableDigits As Boolean _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment to play.
target
Type: System..::..String
The telephone number of the specified target.
markAsRead
Type: System..::..Boolean
Marks this message as read.
enableDigits
Type: System..::..Boolean
Enables the playing of digits to skip around the message.

Remarks

When playback completes, PlaybackComplete will be invoked.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | If playback is already in progress.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace
VoicemailMessage..::..PlaybackComplete


PlayToNumberAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..PlayToNumberAsync Method
VoicemailMessage Class See Also Send Feedback
Issues an asynchronous request to play a VoicemailAttachment to a specified target number.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayToNumberAsync(
    VoicemailAttachment attachment,
    string target,
    bool markAsRead,
    bool enableDigits,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PlayToNumberAsync ( _
    attachment As VoicemailAttachment, _
    target As String, _
    markAsRead As Boolean, _
    enableDigits As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment to play.
target
Type: System..::..String
The telephone number of the specified target.
markAsRead
Type: System..::..Boolean
Marks this message as read.
enableDigits
Type: System..::..Boolean
Enables the playing of digits to skip around the message.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When playback completes, PlaybackComplete will be invoked.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | If playback is already in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace
VoicemailMessage..::..PlaybackComplete


PlayToStation Method

[image]

IceLib Technical Reference
VoicemailMessage..::..PlayToStation Method
VoicemailMessage Class See Also Send Feedback
Issues an synchronous request to play this VoicemailMessage to a specified station.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayToStation(
    VoicemailAttachment attachment,
    string stationName,
    bool markAsRead,
    bool enableDigits
)
Visual Basic
Public Sub PlayToStation ( _
    attachment As VoicemailAttachment, _
    stationName As String, _
    markAsRead As Boolean, _
    enableDigits As Boolean _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment of this VoicemailMessage to play.
stationName
Type: System..::..String
The station name to play to.
markAsRead
Type: System..::..Boolean
Mark this VoicemailMessage as read.
enableDigits
Type: System..::..Boolean
Enable playing of digits to skip forward or back in voicemail. The user must have appropriate permissions for this to work, otherwise the entire playback will fail.

Remarks

When playback completes, PlaybackComplete will be invoked.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | If playback is already in progress.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace
VoicemailMessage..::..PlaybackComplete


PlayToStationAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..PlayToStationAsync Method
VoicemailMessage Class See Also Send Feedback
Issues an asynchronous request to play this VoicemailMessage to a specified station.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void PlayToStationAsync(
    VoicemailAttachment attachment,
    string stationName,
    bool markAsRead,
    bool enableDigits,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PlayToStationAsync ( _
    attachment As VoicemailAttachment, _
    stationName As String, _
    markAsRead As Boolean, _
    enableDigits As Boolean, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment of this message to play.
stationName
Type: System..::..String
The station name to play to.
markAsRead
Type: System..::..Boolean
Mark this message as read.
enableDigits
Type: System..::..Boolean
Enable playing of digits to skip forward or back in voicemail. The user must have appropriate permissions for this to work, otherwise the entire playback will fail.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

When playback completes, PlaybackComplete will be invoked.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
ININ.IceLib..::..IceLibException | If playback is already in progress.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace
VoicemailMessage..::..PlaybackComplete


SaveAsFile Method

[image]

IceLib Technical Reference
VoicemailMessage..::..SaveAsFile Method
VoicemailMessage Class See Also Send Feedback
Downloads this message into a specified file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool SaveAsFile(
    VoicemailAttachment attachment,
    string fileName,
    bool markAsRead
)
Visual Basic
Public Function SaveAsFile ( _
    attachment As VoicemailAttachment, _
    fileName As String, _
    markAsRead As Boolean _
) As Boolean

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment of this message to download.
fileName
Type: System..::..String
The path and name of a local file to save the voicemail into.
markAsRead
Type: System..::..Boolean
Mark this message as read.

Return Value

trueTruetruetrue (True in Visual Basic) if the file was saved successfully.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If the fileName length is zero.
ININ.IceLib.Connection..::..RequestTimeoutException | The request timed out while waiting for a response.
ININ.IceLib.Connection..::..SessionDisconnectedException | The Session does not have a valid connection.
System..::..ObjectDisposedException | The Session has been disposed.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


SaveAsFileAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..SaveAsFileAsync Method
VoicemailMessage Class See Also Send Feedback
Asynchronously downloads this VoicemailMessage into a specified file.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void SaveAsFileAsync(
    VoicemailAttachment attachment,
    string fileName,
    bool markAsRead,
    EventHandler<AsyncSaveAsFileCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub SaveAsFileAsync ( _
    attachment As VoicemailAttachment, _
    fileName As String, _
    markAsRead As Boolean, _
    completedCallback As EventHandler(Of AsyncSaveAsFileCompletedEventArgs), _
    userState As Object _
)

Parameters

attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The VoicemailAttachment of this VoicemailMessage to download.
fileName
Type: System..::..String
The path and name of a local file to save the voicemail into.
markAsRead
Type: System..::..Boolean
">Mark this VoicemailMessage as read.
completedCallback
Type: System..::..EventHandler<(Of <(<' AsyncSaveAsFileCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | If the fileName length is zero.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


StopPlayToNumber Method

[image]

IceLib Technical Reference
VoicemailMessage..::..StopPlayToNumber Method
VoicemailMessage Class See Also Send Feedback
Issues a synchronous request to stop playing a VoicemailMessage to a remote number.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopPlayToNumber()
Visual Basic
Public Sub StopPlayToNumber

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


StopPlayToNumberAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..StopPlayToNumberAsync Method
VoicemailMessage Class See Also Send Feedback
Issues an asynchronous request to stop playing a VoicemailMessage to a remote number.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopPlayToNumberAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopPlayToNumberAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


StopPlayToStation Method

[image]

IceLib Technical Reference
VoicemailMessage..::..StopPlayToStation Method
VoicemailMessage Class See Also Send Feedback
Issues a synchronous request to stop playing a VoicemailMessage to a station.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopPlayToStation()
Visual Basic
Public Sub StopPlayToStation

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


StopPlayToStationAsync Method

[image]

IceLib Technical Reference
VoicemailMessage..::..StopPlayToStationAsync Method
VoicemailMessage Class See Also Send Feedback
Issues an asynchronous request to stop playing a VoicemailMessage to a station.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopPlayToStationAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StopPlayToStationAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An optional object that contains state information for this request. This object is a way for the caller to store context information which will be provided to the AsyncCompleted event. If no context information is desired then nullNothingnullptra null reference (Nothing in Visual Basic) may be supplied.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information. For more information on async method calls, see How Async Calls Work.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailMessage Properties

[image] [image]

IceLib Technical Reference
VoicemailMessage Properties
VoicemailMessage Class See Also Send Feedback

The VoicemailMessage type exposes the following members.

Properties

 | Name | Description
Public property | Attachments | Gets the list of attachments on this VoicemailMessage.
Public property | Body | Gets the body text of this VoicemailMessage.
Public property | Cc | Gets the list of recipients carbon-copied on this VoicemailMessage.
Public property | DateReceived | Gets the DateTime this VoicemailMessage was received.
Public property | From | Gets the sender of the VoicemailMessage.
Public property | HasBeenRead | Gets a flag indicating whether this VoicemailMessage is marked as read or unread.
Public property | Id | Gets the ID of this VoicemailMessage.
Public property | Importance | Gets the importance level of this VoicemailMessage.
Public property | Sensitivity | Gets the sensitivity level of this VoicemailMessage.
Public property | Subject | Gets the subject of the VoicemailMessage.
Public property | To | Gets the list of recipients for this VoicemailMessage.

See Also

VoicemailMessage Class
ININ.IceLib.UnifiedMessaging Namespace


Attachments Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Attachments Property
VoicemailMessage Class See Also Send Feedback
Gets the list of attachments on this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<VoicemailAttachment> Attachments { get; }
Visual Basic
Public ReadOnly Property Attachments As ReadOnlyCollection(Of VoicemailAttachment)
    Get

Field Value

The attachments.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Body Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Body Property
VoicemailMessage Class See Also Send Feedback
Gets the body text of this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Body { get; }
Visual Basic
Public ReadOnly Property Body As String
    Get

Field Value

The body.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Cc Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Cc Property
VoicemailMessage Class See Also Send Feedback
Gets the list of recipients carbon-copied on this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<VoicemailRecipient> Cc { get; }
Visual Basic
Public ReadOnly Property Cc As ReadOnlyCollection(Of VoicemailRecipient)
    Get

Field Value

The 'cc' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


DateReceived Property

[image]

IceLib Technical Reference
VoicemailMessage..::..DateReceived Property
VoicemailMessage Class See Also Send Feedback
Gets the DateTime this VoicemailMessage was received.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DateTime DateReceived { get; }
Visual Basic
Public ReadOnly Property DateReceived As DateTime
    Get

Field Value

The date received.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


From Property

[image]

IceLib Technical Reference
VoicemailMessage..::..From Property
VoicemailMessage Class See Also Send Feedback
Gets the sender of the VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicemailRecipient From { get; }
Visual Basic
Public ReadOnly Property From As VoicemailRecipient
    Get

Field Value

The sender.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


HasBeenRead Property

[image]

IceLib Technical Reference
VoicemailMessage..::..HasBeenRead Property
VoicemailMessage Class See Also Send Feedback
Gets a flag indicating whether this VoicemailMessage is marked as read or unread.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public bool HasBeenRead { get; }
Visual Basic
Public ReadOnly Property HasBeenRead As Boolean
    Get

Field Value

trueTruetruetrue (True in Visual Basic) if this instance has been read; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Id Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Id Property
VoicemailMessage Class See Also Send Feedback
Gets the ID of this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get

Field Value

The ID.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Importance Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Importance Property
VoicemailMessage Class See Also Send Feedback
Gets the importance level of this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Importance { get; }
Visual Basic
Public ReadOnly Property Importance As Integer
    Get

Field Value

The importance. On most Email systems, the importance of the message is "Low", "Normal", or "High".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Sensitivity Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Sensitivity Property
VoicemailMessage Class See Also Send Feedback
Gets the sensitivity level of this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int Sensitivity { get; }
Visual Basic
Public ReadOnly Property Sensitivity As Integer
    Get

Field Value

The sensitivity.

Remarks

Sensitivity indicates the confidentiality of the message ("Normal", "Personal", "Private", or "Confidential"). The default is "Normal".

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


Subject Property

[image]

IceLib Technical Reference
VoicemailMessage..::..Subject Property
VoicemailMessage Class See Also Send Feedback
Gets the subject of the VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Subject { get; }
Visual Basic
Public ReadOnly Property Subject As String
    Get

Field Value

The subject.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


To Property

[image]

IceLib Technical Reference
VoicemailMessage..::..To Property
VoicemailMessage Class See Also Send Feedback
Gets the list of recipients for this VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ReadOnlyCollection<VoicemailRecipient> To { get; }
Visual Basic
Public ReadOnly Property To As ReadOnlyCollection(Of VoicemailRecipient)
    Get

Field Value

The 'to' recipients.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailMessage Events

[image] [image]

IceLib Technical Reference
VoicemailMessage Events
VoicemailMessage Class See Also Send Feedback

The VoicemailMessage type exposes the following members.

Events

 | Name | Description
Public event | DownloadProgressChanged | Occurs when the progress of downloading a VoicemailMessage changes.
Public event | PlaybackComplete | Occurs when playback to a remote number or station has completed.

See Also

VoicemailMessage Class
ININ.IceLib.UnifiedMessaging Namespace


DownloadProgressChanged Event

[image]

IceLib Technical Reference
VoicemailMessage..::..DownloadProgressChanged Event
VoicemailMessage Class See Also Send Feedback
Occurs when the progress of downloading a VoicemailMessage changes.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler<TransferProgressChangedEventArgs> DownloadProgressChanged
Visual Basic
Public Event DownloadProgressChanged As EventHandler(Of TransferProgressChangedEventArgs)

Remarks

This event will only occur if a download has been started. (See PlayToNumber(VoicemailAttachment, String, Boolean, Boolean), PlayToNumberAsync(VoicemailAttachment, String, Boolean, Boolean, AsyncCompletedEventHandler, Object), PlayToStation(VoicemailAttachment, String, Boolean, Boolean), PlayToStationAsync(VoicemailAttachment, String, Boolean, Boolean, AsyncCompletedEventHandler, Object), SaveAsFile(VoicemailAttachment, String, Boolean), or SaveAsFileAsync(VoicemailAttachment, String, Boolean, EventHandler<(Of <<'(AsyncSaveAsFileCompletedEventArgs>)>>), Object).)

Note
All event handlers should be added before the download is started.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


PlaybackComplete Event

[image]

IceLib Technical Reference
VoicemailMessage..::..PlaybackComplete Event
VoicemailMessage Class See Also Send Feedback
Occurs when playback to a remote number or station has completed.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event EventHandler PlaybackComplete
Visual Basic
Public Event PlaybackComplete As EventHandler

Remarks

This event will only occur when a playback action has completed.
Note
All event handlers should be added before calling PlayToNumber(VoicemailAttachment, String, Boolean, Boolean), PlayToNumberAsync(VoicemailAttachment, String, Boolean, Boolean, AsyncCompletedEventHandler, Object), PlayToStation(VoicemailAttachment, String, Boolean, Boolean), or PlayToStationAsync(VoicemailAttachment, String, Boolean, Boolean, AsyncCompletedEventHandler, Object).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailMessage Class
VoicemailMessage Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailRecipient Class

[image]

IceLib Technical Reference
VoicemailRecipient Class
Members See Also Send Feedback
Represents both a recipient and sender of a VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoicemailRecipient
Visual Basic
Public Class VoicemailRecipient

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..VoicemailRecipient

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailRecipient Members

[image] [image]

IceLib Technical Reference
VoicemailRecipient Members
VoicemailRecipient Class Methods Properties See Also Send Feedback

The VoicemailRecipient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two VoicemailRecipient objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | Gets the Internet address of this recipient. This value is typically an Email address.
Public property | Name | Gets the display name of this recipient.

See Also

VoicemailRecipient Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailRecipient Methods

[image] [image]

IceLib Technical Reference
VoicemailRecipient Methods
VoicemailRecipient Class See Also Send Feedback

The VoicemailRecipient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two VoicemailRecipient objects. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicemailRecipient Class
ININ.IceLib.UnifiedMessaging Namespace


Equals Method

[image]

IceLib Technical Reference
VoicemailRecipient..::..Equals Method
VoicemailRecipient Class See Also Send Feedback
Compares two VoicemailRecipient objects.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
The Object to compare with the current Object.

Return Value

trueTruetruetrue (True in Visual Basic) if the specified Object is equal to the current Object; otherwise, falseFalsefalsefalse (False in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailRecipient Class
VoicemailRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


GetHashCode Method

[image]

IceLib Technical Reference
VoicemailRecipient..::..GetHashCode Method
VoicemailRecipient Class See Also Send Feedback
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current Object.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailRecipient Class
VoicemailRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailRecipient Properties

[image] [image]

IceLib Technical Reference
VoicemailRecipient Properties
VoicemailRecipient Class See Also Send Feedback

The VoicemailRecipient type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the Internet address of this recipient. This value is typically an Email address.
Public property | Name | Gets the display name of this recipient.

See Also

VoicemailRecipient Class
ININ.IceLib.UnifiedMessaging Namespace


Address Property

[image]

IceLib Technical Reference
VoicemailRecipient..::..Address Property
VoicemailRecipient Class See Also Send Feedback
Gets the Internet address of this recipient. This value is typically an Email address.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Address { get; }
Visual Basic
Public ReadOnly Property Address As String
    Get

Field Value

The address.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailRecipient Class
VoicemailRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


Name Property

[image]

IceLib Technical Reference
VoicemailRecipient..::..Name Property
VoicemailRecipient Class See Also Send Feedback
Gets the display name of this recipient.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

The name.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailRecipient Class
VoicemailRecipient Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailServerPlayResultEventArgs Class

[image]

IceLib Technical Reference
VoicemailServerPlayResultEventArgs Class
Members See Also Send Feedback
Provides data for the VoicemailServerPlayResult event.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoicemailServerPlayResultEventArgs : EventArgs
Visual Basic
Public Class VoicemailServerPlayResultEventArgs _
    Inherits EventArgs

Remarks

Handle the VoicemailServerPlayResult event to be informed when playback to the server of a voicemail has completed. The Result property identifies the voicemail message that completed playing, in addition to a result code and message.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.UnifiedMessaging..::..VoicemailServerPlayResultEventArgs

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailServerPlayResultEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailServerPlayResultEventArgs Members

[image] [image]

IceLib Technical Reference
VoicemailServerPlayResultEventArgs Members
VoicemailServerPlayResultEventArgs Class Constructors Methods Properties See Also Send Feedback

The VoicemailServerPlayResultEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VoicemailServerPlayResultEventArgs | Initializes a new instance of the VoicemailServerPlayResultEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Result | Gets the result.

See Also

VoicemailServerPlayResultEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailServerPlayResultEventArgs Constructor

[image]

IceLib Technical Reference
VoicemailServerPlayResultEventArgs Constructor
VoicemailServerPlayResultEventArgs Class See Also Send Feedback
Initializes a new instance of the VoicemailServerPlayResultEventArgs class with the specified values.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicemailServerPlayResultEventArgs(
    VoiceMessageServerPlayResult result
)
Visual Basic
Public Sub New ( _
    result As VoiceMessageServerPlayResult _
)

Parameters

result
Type: ININ.IceLib.UnifiedMessaging..::..VoiceMessageServerPlayResult
The result.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailServerPlayResultEventArgs Class
VoicemailServerPlayResultEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


VoicemailServerPlayResultEventArgs Methods

[image] [image]

IceLib Technical Reference
VoicemailServerPlayResultEventArgs Methods
VoicemailServerPlayResultEventArgs Class See Also Send Feedback

The VoicemailServerPlayResultEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoicemailServerPlayResultEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


VoicemailServerPlayResultEventArgs Properties

[image] [image]

IceLib Technical Reference
VoicemailServerPlayResultEventArgs Properties
VoicemailServerPlayResultEventArgs Class See Also Send Feedback

The VoicemailServerPlayResultEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Result | Gets the result.

See Also

VoicemailServerPlayResultEventArgs Class
ININ.IceLib.UnifiedMessaging Namespace


Result Property

[image]

IceLib Technical Reference
VoicemailServerPlayResultEventArgs..::..Result Property
VoicemailServerPlayResultEventArgs Class See Also Send Feedback
Gets the result.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoiceMessageServerPlayResult Result { get; private set; }
Visual Basic
Public Property Result As VoiceMessageServerPlayResult
    Get
    Private Set

Field Value

The result.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoicemailServerPlayResultEventArgs Class
VoicemailServerPlayResultEventArgs Members
ININ.IceLib.UnifiedMessaging Namespace


VoiceMessageServerPlayResult Class

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult Class
Members See Also Send Feedback
The result sent back from the server when a Voicemail was played to the user.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class VoiceMessageServerPlayResult
Visual Basic
Public Class VoiceMessageServerPlayResult

Remarks

The VoiceMessageServerPlayResult contains information about the VoicemailMessage and VoicemailAttachment that was played to the user, as well as the ResultCode that specifies the server's return code, and ResultText that specifies an error or success message generated by the server.

Note
Compare the ResultCode value to PlaybackAbortedResultCode to evaluate if the user explicitly stopped the playback.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.UnifiedMessaging..::..VoiceMessageServerPlayResult

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace


VoiceMessageServerPlayResult Members

[image] [image]

IceLib Technical Reference
VoiceMessageServerPlayResult Members
VoiceMessageServerPlayResult Class Constructors Methods Properties See Also Send Feedback

The VoiceMessageServerPlayResult type exposes the following members.

Constructors

 | Name | Description
Public method | VoiceMessageServerPlayResult | Initializes a new instance of the VoiceMessageServerPlayResult class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attachment | Gets the VoicemailAttachment that was played.
Public property | Message | Gets the VoicemailMessage that was played.
 | PlaybackAbortedResultCode | Result code returned when playback is stopped by user.
Public property | ResultCode | Gets the result code from playing the VoicemailMessage.
Public property | ResultText | Gets the result text (error or success) of playing the VoicemailMessage.

See Also

VoiceMessageServerPlayResult Class
ININ.IceLib.UnifiedMessaging Namespace


VoiceMessageServerPlayResult Constructor

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult Constructor
VoiceMessageServerPlayResult Class See Also Send Feedback
Initializes a new instance of the VoiceMessageServerPlayResult class.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoiceMessageServerPlayResult(
    VoicemailMessage message,
    VoicemailAttachment attachment,
    int resultCode,
    string resultText
)
Visual Basic
Public Sub New ( _
    message As VoicemailMessage, _
    attachment As VoicemailAttachment, _
    resultCode As Integer, _
    resultText As String _
)

Parameters

message
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailMessage
The message.
attachment
Type: ININ.IceLib.UnifiedMessaging..::..VoicemailAttachment
The attachment.
resultCode
Type: System..::..Int32
The result code.
resultText
Type: System..::..String
The result text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Class
VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace


VoiceMessageServerPlayResult Methods

[image] [image]

IceLib Technical Reference
VoiceMessageServerPlayResult Methods
VoiceMessageServerPlayResult Class See Also Send Feedback

The VoiceMessageServerPlayResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoiceMessageServerPlayResult Class
ININ.IceLib.UnifiedMessaging Namespace


VoiceMessageServerPlayResult Properties

[image] [image]

IceLib Technical Reference
VoiceMessageServerPlayResult Properties
VoiceMessageServerPlayResult Class See Also Send Feedback

The VoiceMessageServerPlayResult type exposes the following members.

Properties

 | Name | Description
Public property | Attachment | Gets the VoicemailAttachment that was played.
Public property | Message | Gets the VoicemailMessage that was played.
 | PlaybackAbortedResultCode | Result code returned when playback is stopped by user.
Public property | ResultCode | Gets the result code from playing the VoicemailMessage.
Public property | ResultText | Gets the result text (error or success) of playing the VoicemailMessage.

See Also

VoiceMessageServerPlayResult Class
ININ.IceLib.UnifiedMessaging Namespace


Attachment Property

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult..::..Attachment Property
VoiceMessageServerPlayResult Class See Also Send Feedback
Gets the VoicemailAttachment that was played.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicemailAttachment Attachment { get; }
Visual Basic
Public ReadOnly Property Attachment As VoicemailAttachment
    Get

Field Value

The Voicemail attachment.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Class
VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace


Message Property

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult..::..Message Property
VoiceMessageServerPlayResult Class See Also Send Feedback
Gets the VoicemailMessage that was played.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public VoicemailMessage Message { get; }
Visual Basic
Public ReadOnly Property Message As VoicemailMessage
    Get

Field Value

The Voicemail message.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Class
VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace


PlaybackAbortedResultCode Property

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult..::..PlaybackAbortedResultCode Property
VoiceMessageServerPlayResult Class See Also Send Feedback
Result code returned when playback is stopped by user.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static int PlaybackAbortedResultCode { get; }
Visual Basic
Public Shared ReadOnly Property PlaybackAbortedResultCode As Integer
    Get

Field Value

The result code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Class
VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace


ResultCode Property

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult..::..ResultCode Property
VoiceMessageServerPlayResult Class See Also Send Feedback
Gets the result code from playing the VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public int ResultCode { get; }
Visual Basic
Public ReadOnly Property ResultCode As Integer
    Get

Field Value

The result code.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Class
VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace


ResultText Property

[image]

IceLib Technical Reference
VoiceMessageServerPlayResult..::..ResultText Property
VoiceMessageServerPlayResult Class See Also Send Feedback
Gets the result text (error or success) of playing the VoicemailMessage.

Namespace: ININ.IceLib.UnifiedMessaging
Assembly: ININ.IceLib.UnifiedMessaging (in ININ.IceLib.UnifiedMessaging.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ResultText { get; }
Visual Basic
Public ReadOnly Property ResultText As String
    Get

Field Value

The result text.

Version Information

Supported for IC Server version 2015 R1 and beyond.
For 4.0, supported for IC Server version 4.0 GA and beyond.
For 3.0, supported for IC Server version 3.0 GA and beyond.

See Also

VoiceMessageServerPlayResult Class
VoiceMessageServerPlayResult Members
ININ.IceLib.UnifiedMessaging Namespace